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Introduction

This document describes how to optimize Microsoft Internet Explorer and other web
browsers to work with Sitecore. It also describes how to troubleshoot browser issues.

This document contains the following chapters:

e Chapter 1 — Introduction
e Chapter 2 — Configuring Microsoft Internet Explorer
e Chapter 3— Troubleshooting Microsoft Internet Explorer

e Chapter 4 — Configuring Other Browsers

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
contents of this document are the property of Sitecore. Copyright © 2001-2013 Sitecore. All rights reserved.
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11

Supported Web Browsers

Sitecore currently supports the following web browsers:

Note

Microsoft Internet Explorer 8, 9, and 10.
Mozilla Firefox 17 and later.
Google Chrome 25 and later.

Apple Safari 6 for Mac OS — Windows in not supported by Apple.

@ sitecore

Sitecore CMS 7.0 supports all current stable versions of these browsers unless stated otherwise.

Note

Sitecore only supports Word and WebDAYV with Internet Explorer, and only when they are configured
according to the instructions described in this document.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
contents of this document are the property of Sitecore. Copyright © 2001-2013 Sitecore. All rights reserved.
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Configuring Microsoft Internet Explorer

This chapter describes how to configure Microsoft Internet Explorer to work with
Sitecore. Some of these considerations may also apply to other browsers, although
the Ul instructions may differ from browser to browser.

This chapter contains the following sections:

How to Determine the Internet Explorer Version
Internet Explorer Configuration Summary
Required Configuration

Recommended Configuration

Optional Configuration

@ sitecore
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@ sitecore

2.1 How to Determine the Internet Explorer Version

To determine which version of Internet Explorer is installed on your computer:

In Internet Explorer, click the Help menu or press ALT-H, and then click About Internet Explorer.

The About Internet Explorer dialog box appears and tells you which version of Internet Explorer you

are running.

About Internet Explorer

e Internet
Explorer10

Product

[} Install n

(KB2829530)
AAL5D

ons automatically

© 2012 Microsoft Corporation. All rights reserved.

Close !

Important

Some of the instructions described in this document may require Windows administrative rights.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
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2.2 Internet Explorer Configuration Summary

When you are familiar with the configuration process, you can use this summary as a configuration

checklist.

e Install Adobe Flash —recommended.

For more information, see the section Install Adobe Flash.

e Install Windows Web Folders or the Windows Desktop Experience —required for WebDAV.

For more information, see the section Windows Web Folders Client or the Windows Desktop
Experience.

e Use the Internet Options, Security tab to configure the Trusted Sites zone:

o

Add the CMS to the Internet Explorer Trusted Sites zone — required.
For more information, see the section Trusted Sites Zone.

Enable Automatic Prompting for ActiveX Controls — required for the Word Document
field type.

For more information, see the section Word Document Field Type Configuration.
Enable launching programs and files in an IFRAME — recommended for WebDAV.
For more information, see the section WebDAV Configuration.

Disable the Pop-up Blocker — required.

For more information, see the section Pop-up Blocker.

Disable the SmartScreen/Phishing Filter — recommended.

For more information, see the section Disable the SmartScreen or Phishing Filter.
Allow script-initiated windows without size or position constraints — optional.

For more information, see the section Minor Issues.

Allow websites to open windows without the address or status bars — optional.
For more information, see section Minor Issues.

Enable Programmatic clipboard access — optional.

For more information, see the section Minor Issues.

Display mixed content — optional.

For more information, see the section Minor Issues.

e Ensure that the WebClient Windows Service is active (required for WebDAYV).

e Onthe Internet Options, General tab:

o

o

Select the tab preferences that you want to use (optional) — see the section New
Windows or New Tabs.

Configure the browser cache (optional) — see the section Configure Management of
Temporary Internet Files.

e Onthe Internet Options, Advanced tab:

o

Select the Empty temporary internet files folder when browser is closed option
— optional.

For more information, see the section Configure Management of Temporary Internet
Files.

Clear the Disable script debugging check box — optional.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
contents of this document are the property of Sitecore. Copyright © 2001-2013 Sitecore. All rights reserved.
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For more information, see the section Miscellaneous Settings.

o Display a naotification about every script error — optional.
For more information, see the section Miscellaneous Settings.

o Disable Reuse windows for launching shortcuts — optional.
For more information, see the section Miscellaneous Settings.

o Disable Show friendly HTTP error messages — optional.
For more information, see the section Miscellaneous Settings.

e Disable session merging — optional.
For more information, see the section Internet Explorer 8, 9, and 10 Session Merging.

e Configure concurrent HTTP request limits (optional) — see the section Concurrent HTTP
Request Limits.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
contents of this document are the property of Sitecore. Copyright © 2001-2013 Sitecore. All rights reserved.
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2.3 Required Configuration

This section describes the configuration that you should apply to every instance of Internet Explorer
that you use to access Sitecore.

Important
Backup the system before making any changes.

Important

Before configuring Internet Explorer, close all the Internet Explorer windows, and only open Internet
Explorer when needed. After any configuration task, close all the Internet Explorer windows. Reboot
the computer after you make any registry changes.

2.3.1 Trusted Sites Zone

In Internet Explorer, Add all the Sitecore instances to the Trusted Sites zone.
To add a Sitecore instance to the Trusted Sites zone in Internet Explorer 8, 9, and 10:
1. Ensure that there is only one open instance of Internet Explorer.

2. InlInternet Explorer, click the Tools menu or press ALT-T, and then click Internet Options
and the Internet Options dialog box appears.

In the Internet Options dialog box, click the Security tab.

4. On the Security tab, click the Trusted Sites zone, and then click Sites. The Trusted sites
dialog box appears.

Select a zone to view or changf security settingy.
) ﬁ‘!r.
e A v

ry
Internet  Local nﬁane\{

)

Restricted \

sites

Trusted sites T
£ This zone contains websites that you [ oses |

¥ trustnot to damage your computer or
your files,

5. Inthe Trusted sites dialog box, in the Add this Website to the zone field, enter the URL of
the Sitecore instance, such as http://localhost.

Trusted sites (=3

# You can add and remove websites from this zone. All websites in

o/ this zone will use the zone's security settings.

Add this website to the zone:
http://localhost Add

Websites:
https: /flocalhost

3
7

V| Require server verification (https:) for all sites in this zone

Close

6. If the Sitecore instance does not use the HTTPS protocol, in the Trusted Sites dialog box,
clear the Require server verification (https:) for all sites in this zone check box.

7. Inthe Trusted sites dialog box, click Add, and then click Close.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
contents of this document are the property of Sitecore. Copyright © 2001-2013 Sitecore. All rights reserved.
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2.3.2 Pop-up Blocker

You can enable pop-ups for the sites that are listed the Internet Explorer Trusted Sites zone or for
individual Sitecore instances.

To enable pop-ups for all the sites in the Internet Explorer Trusted Sites zone in Internet Explorer 8:
1. Ensure that there is only one open instance of Internet Explorer.

2. IniInternet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

In the Internet Options dialog box, click the Security tab.

On the Security tab, click the Trusted Sites zone, and then click Custom Level. The
Security Settings - Trusted Sites Zone dialog box appears.

5. Inthe Security Settings - Trusted Sites Zone dialog box, in the Miscellaneous section,
under Use Pop-up Blocker, select Disable, and then click OK.

Security Settings - Trusted Sites Zone [==3a]

Settings

Disable -
@ Enable
|__| Submit non-encrypted form data
Disable
@ Enable

T
|| Use Pop-up Blocker
@) Disable
Enable
T Use Smaraeen Flter
Disable
@ Enable
|| Userdata persistence
Disable
@ Enable
Misheita in lace nrivilanad weh rantant nne an navinate in
m

4

Takes effect after you restart your computer

Reset custom settings

Resetto!  (Megium (default) v [ reset.. |

6. If a confirmation prompt appears, click Yes.

To enable pop-ups for all the sites in the Internet Explorer Trusted Sites zone in Internet Explorer 9
and 10:

1. Ensure that there is only one open instance of Internet Explorer.

2. InlInternet Explorer, click the Tools menu or press ALT-T, and then click Pop-Up Blocker,
Turn off Pop-up Blocker.

View downloads Ctrl+]  @net Sitecore Intranet
Pop-up Blocker 3 Turn off Pop-up Blocker

SmartScreen Filter 3 Pop-up Blocker settings

Manage add-ons P— E—

Alternatively, to enable pop-ups for an individual Sitecore instance, access that instance of Sitecore.
When the Internet Explorer Information Bar appears at the top or bottom of the browser window
(depending on the browser version) to indicate that Internet Explorer has blocked a pop-up:

1. If an Information Bar alert appears, click Close.

2. InInternet Explorer, right-click the Information Bar, then click Pop-Up Blocked, and then
click Always Allow Pop-ups from This Site. If a confirmation prompt appears, click Yes.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
contents of this document are the property of Sitecore. Copyright © 2001-2013 Sitecore. All rights reserved.
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Important

2.3.3

6.

Word Document Field Type Configuration

To configure Internet Explorer to support the Word Document field type:
1.
2.

Ensure that there is only one open instance of Internet Explorer.

In the Internet Options dialog, click the Security tab.

Security Settings - Trusted Sites Zone

Settings

@ Enable -
@) Allow Scriptlets
@) Disable
Enable
Prompt

Disable
@ Enable
¥ BMaTy A st et vior
Administrator approved
Disable
@ Enable
@] Display video and animation on a webpage that does not use
@ Disable
Enable

|¥| Automatic prompting for ActiveX controls ]

\

41 Nemmload cinned ArtieY contrale S

¢ T G

Takes effect after you restart your computer

Reset cstom settings

Beset 0 [Mecium (default) <) [ Reset.. |

If a confirmation prompt appears, click Yes.

@ sitecore

Disable any additional pop-up blockers, or configure them to allow pop-ups for Sitecore.

In Internet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

On the Security tab, click the Trusted Sites zone, and then click Custom Level. The
Security Settings Trusted Sites Zone dialog box appears.

In the Security Settings Trusted Sites Zone dialog box, in the ActiveX controls and plug-
ins section, under Automatic prompting for ActiveX controls, select Enable, and then
click OK.

If you would prefer not to enable automatic prompting, install the Word OCX control as follows:

1.

Note

You can use the following command to uninstall the Word OCX control:

Extract the contents of the /sitecore/shell/Applications/Content
Manager/officeviewer.cab file to a temporary directory.

Open a Windows command prompt as a local administrator.

In the Windows command prompt, execute the following command:

regsvr32 officeviewer.ocx

regsvr32 /u officeviewer.ocx

In the Windows command prompt, navigate to the directory that contains the files you just
extracted.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
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@ sitecore
Note

After installing or uninstalling the Word OCX control, you can delete the files you extracted previously.

2.3.4 WebDAYV Configuration
To configure Internet Explorer to support WebDAV and the File Drop Area field type:
1. Ensure that there is only one open instance of Internet Explorer.

2. InInternet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

In the Internet Options dialog box, click the Security tab.

On the Security tab, click the Trusted Sites zone, and then click Custom Level. The
Security Settings Trusted Sites Zone dialog box appears.

5. Inthe Security Settings Trusted Sites Zone dialog box, in the Miscellaneous section,
under Launching programs and files in an IFRAME, select Enable, and then click OK.

Security Settings - Trusted Sites Zone [==3a]

Settings

@ Enable -
__| Include local directory path when uploading files to a server
Disable
@ Enable
|| Launching applications and unsafe files
Disable
Enable

o
|| Launching programs and files in an IFRAME
Disable
Enable
@ Prompt
T ] Mevigate windows and frames across different domains
@ Disable
Enable

Denmnt

4 T »

Takes effect after you restart your computer

Reset custom settings

Reset to:

Medium (default)

v [ reset.. |

6. If a confirmation prompt appears, click Yes.

Windows Web Folders Client or the Windows Desktop Experience

If you want the client to use the Sitecore WebDAYV features, install the Microsoft Windows Web

Folders Client, including any available updates.
On Windows 2008, install the Windows Desktop Experience.

For more information, see http://www.microsoft.com/downloads/details.aspx?Familyld=17C36612-

632E-4C04-9382-987622ED1D64&displaylang=en.

The WebClient Windows Service

The Internet Explorer WebDAV implementation depends on the WebClient Windows service. Ensure

that the WebClient Windows service is active and configured to start automatically.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
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2.4 Recommended Configuration

This section describes the extra Internet Explorer configuration that Sitecore recommends.

2.4.1 Disable the SmartScreen or Phishing Filter

The SmartScreen Filter — previously known as the Phishing Filter — may adversely affect the
performance of Sitecore clients.

Disabling the SmartScreen or Phishing filter can improve browser performance.

Internet Explorer 8

To disable the SmartScreen Filter for all the websites in the Internet Explorer Trusted Sites zone in
Internet Explorer 8:

1. Ensure that there is only one open instance of Internet Explorer.

2. InInternet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

In the Internet Options dialog box, click the Security tab.

On the Security tab, click the Trusted Sites zone, and then click Custom Level. The
Security Settings Trusted Sites Zone dialog box appears.

5. Inthe Security Settings Trusted Sites Zone dialog box, in the Miscellaneous section,
under Use SmartScreen Filter, select Disable, and then click OK.

Security Settings - Trusted Sites Zone =

Settings

@ Enable -
Prompt
|_] Use Pop-up Blocker
@ Disable

|| Use smartScreen Filter
Disable
@ Enable
|_| Userdata persistence
Disable
@ Enable
|| Websites in less privileged web content zone can navigate in
Disable
@ Enable
Prompt

Sevintinn

*Takes effect after you restart your computer

Reset custom settings

Reset ! [egium (default) v [ Reset. |

G

6. If a confirmation prompt appears, click Yes.

Internet Explorer 9 and 10

To disable the SmartScreen Filter for all sites in the Internet Explorer Trusted Sites zone in Internet
Explorer 9 and 10:

1. Ensure that there is only one open instance of Internet Explorer.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
contents of this document are the property of Sitecore. Copyright © 2001-2013 Sitecore. All rights reserved.
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2. InlInternet Explorer, click the Tools menu or press ALT-T, select SmartScreen Filter, and
then click Turn off SmartScreen Filter.

FUP-Up DIULRED
SmartScreen Filter 3 Check this website

Manage add-ons Turn off SmartScreen Filter...

[N U S,

2.4.2 Install Adobe Flash

To install Adobe Flash in Internet Explorer 8, 9, and 10:
1. InlInternet Explorer, open http://get.adobe.com/flashplayer/.

2. On the http://get.adobe.com/flashplayer/ webpage, clear the Install Google Chrome check
box.

3. Follow the tips displayed on the page.

Note
The default user interface that you use to upload files to the Sitecore media library uses Adobe Flash.
Some reporting interfaces in the Digital Marketing Suite (DMS) require Adobe Flash.

If you cannot install Adobe Flash, you can configure Sitecore to use an HTML user interface to upload
media by changing the Upload.Classic setting in the web.config file on the Sitecore server to
true.

2.4.3  Minor Issues
This section describes the configuration that you should apply to avoid various minor issues.
To avoid various minor issues in Internet Explorer:

1. Ensure that there is only one open instance of Internet Explorer.

2. InInternet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

In the Internet Options dialog box, click the Security tab.

4. On the Security tab, click the Trusted Sites zone, and then click Custom Level. The
Security Settings - Trusted Sites Zone dialog box appears.

5. Inthe Security Settings - Trusted Sites Zone dialog box, in the Miscellaneous section,
select the following settings:

Setting Value

Allow script-initiated windows Enable
without size or position constraints

Allow websites to open windows Enable
without address or status bars

Display mixed content Enable

Note

In the Security Settings Trusted Sites Zone dialog box, in the Scripting section, under Allow
Programmatic clipboard access, select Enable. The Allow Programmatic clipboard access
setting only applies to content management environments that use the HTTPS protocol.

6. Inthe Security Settings trusted Sites Zone dialog box, click OK.

7. If a confirmation prompt appears, click Yes.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
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24.4

Configure Management of Temporary Internet Files

To increase the stability of Internet Explorer at the cost of performance, you can configure some
Internet Explorer caching options.

To configure the browser cache in Internet Explorer 8, 9, and 10:

1.
2,

5.

Ensure that there is only one open instance of Internet Explorer.

In Internet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

In the Internet Options dialog box, click the General tab.

On the General tab in the Browsing history section, click Settings. The Website Data
Settings dialog box appears.

Browsing history

Delete temporary files, history, cookies, saved passwords, and web
form information.

[ Delete browsing history on exit

In the Website Data Settings dialog box, on the Temporary Internet Files tab, in the Check
for newer versions of stored pages setting, select the Automatically or the Every time |
Start Internet Explorer option, and then click OK.

Website Data Settings [~ 7 |[wE3]

Temporary Internet Files | History | Caches and databases |

Internet Explorer stores copies of webpages, images, and media
for faster viewing later.

Check for newer versions of stored pages:
*) Every time I visit the webpage

_) Every time I start Internet Explorer
@ Automaticaly:

) Never

Disk space to use (8-1024MB) 250 |
(Recommended: 50-250MB)
Current location:

C:\sers\ely\AppData'LocalMicrosoftiWindowsTemporary
Internet Files

[ Move folder.. | [ viewcbjects | [ viewfles |

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
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Note
If you select to clear the cache Automatically, you may experience improved performance with
Sitecore and other browser-based Web sites and applications. Clear the browser cache manually if
you experience any issues. If you select Every Time | Start Internet Explorer, you should rarely
need to clear the browser cache manually.
To configure Internet Explorer 8 to clear the cache when Internet Explorer closes:

1. Ensure that there is only one open instance of Internet Explorer.

2. InlInternet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

In the Internet Options dialog box, click the Advanced tab.

In the Settings field, scroll down to the Security section and select the Empty Temporary
Internet Files folder when browser is closed check box, and then click OK.

To configure Internet Explorer 9 and 10 to clear the cache when Internet Explorer closes:
1. Ensure that there is only one open instance of Internet Explorer.

2. InInternet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

3. Select the Delete browsing history on exit check box.

Warning

While it may assist with some cases of cache corruption, you cannot rely on this setting to clear the
browser cache. For example, if Internet Explorer crashes, then Internet Explorer may not clear the
browser cache.

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The
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2.5 Optional Configuration

This section describes optional techniques and Internet Explorer configuration that you can apply to
achieve specific objectives and address various issues.

2.5.1 New Windows or New Tabs
To control whether Internet Explorer 9 and 10 open pop-ups as new windows or as new tabs:
1. Ensure that there is only one open instance of Internet Explorer.

2. Click the Tools menu or press ALT-T, and then click Internet Options. The Internet Options
dialog box appears.

3. Inthe Internet Options dialog box, click the General tab, and then click Tabs. The Tabbed
Browsing Settings dialog box appears. In earlier versions of IE (Internet Explorer 8), on the
General tab in the Tabs section, click Settings.

4. Inthe Tabbed Browsing Settings dialog box, to control how Internet Explorer handles pop-
ups, select an option in the When a pop-up is encountered section.

5. Inthe Tabbed Browsing Settings dialog box, to control how Internet Explorer opens links
activated from other applications, such as email clients, select an option under Open links
from other programs.

Tabbed Browsing Settings ===

V| Enable Tabbed Browsing (requires restarting Internat Explorer)

Warn me when dosing multiple tabs
Always switch to new tabs when they are created
V| show previews for individual tabs in the taskbar™
Enable Quick Tabs (Ctrl+Q)*
¥|Enable Tab Groups®
Open each new tab next to the current tab
Open orly the first home page when Internet Explorer starts

When 2 new tab is opened, open:

The new tab page -

When a pop-up is encountered:
Let Internet Explorer decide how pop-ups should open

Always open pop-ups in a new window
@ Always open pop-ups in a new tab
Open links from other programs in:
A new window
@ A new tab in the current window
The current tab or window

*Takes effect after you restart your computer

Restore defaults oK [ concel

2.5.2 Internet Explorer 8, 9, and 10 Session Merging

Internet Explorer 8 introduced a feature known as Merged Frame Process, or MFP. MFP shares client
session data, including authentication and other cookies, between all Internet Explorer tabs and
windows. New Internet Explorer processes merge with an existing Internet Explorer process and then
terminate. The new browser window uses session data from the pre-existing Internet Explorer
process.

MFP presents limitations for users, including Sitecore developers that work in multiple Sitecore modes
and security contexts. You can use any of the technigues described in this section to work in multiple
Internet Explorer sessions.

The New Session Command

To open a window in a new session, click the File menu or press ALT-F, and then click New Session.
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The -NoSessionMerging Command Line Parameter

To open a new browser window with a new session, add the -NoSessionMerging parameter to the

command line:

iexplore -NoSessionMerging http://localhost/sitecore

The SessionMerging Registry Setting
To disable session merging for all new Internet Explorer processes for a Windows user:

Warning

Backup the system before updating the registry, and be cautious when working in the Registry Editor.

1. Hold down the WINDOWS key and press R. The Run dialog box appears.
2. Inthe Run dialog box, type regedit, click OK and the Registry Editor appears.

= Run

=

== Typethe name of a program, felder, document, or Internet
resource, and Windows will open it for you.

E5

Open: [

' This task will be created with administrative privileges.

I

ok | [ Concel

] [ Browse...

3. Inthe Registry Editor, expand HKEY CURRENT USER\Software\Microsoft\Internet
Explorer\Main.

@’ Registry Editor

File Edit View Favorites Help

| Image Caching
| TnformationCard Toker

International

Low Rights

MAIN
ErrorThresholds
FeatureControl
UrlTemplate

Miaration

Name Type
a5 (Default) REG_
1] Anchor_Visitatio... REG_
14 ApplicationTilel.. REG_
% AssociationActi.. REG_
4| AutoHide REG_
1] Cache Percent_... REG_

ab) Check_Associati... REG_]

Note

You may be able to apply this setting for all Windows users by making the corresponding
change under HKEY LOCAL MACHINE\Software\Microsoft\Internet
Explorer\Main instead of under HKEY CURRENT USER.
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4. Inthe Registry Editor, right-click Internet Options, and then select New DWORD (32-bit)
Value. Name the new entry SessionMerging.

,L_D‘_"f_""gm || %% ApplicationTilel.. REG_DWORD 0:0C
a]
H Collapse gsociationActi., REG_DWORD 000
New » Key yes
0a0
| el String Value yes
| Delete Binary Value htt
[} Rename DWORD (32-bit) Value htt)
[} 4
! Erm QWORD (B4-bit) Value yes
Multi-String Value
I Permissions... yes
Expandable String Value
[} abo)
) Copy Key Name r
4 - SR REG_SZ T
Security = H | Placeholder_Hei.. REG_BINARY 1a0)
Setun S oo oo P

5. Inthe Registry Editor, right-click SessionMerging, and then select Modify. The Edit
DWORD (32-bit) Value dialog box appears.

| ines el occimum

n| Edit DWORD (32-bit) Value [E=<=|

<

o
Value name:

.| SessionMerging

™ Value data: Base
b 0] @ Hexadecimal

Decimal

N =

b AppPath REG
#4SessionMerging  REG_DWORD

T

on Vector

=

6. Inthe Edit DWORD (32-bit) Value dialog box, for Value data, enter 0, and then click OK.
7. Reboot.

2.5.3 Concurrent HTTP Request Limits

In some cases, you can improve the performance of Internet Explorer by configuring it to allow more
than the default number of concurrent HTTP requests to a single Web server.

Warning
Backup the system before updating the registry, and be cautious when working in the Registry Editor.

Important
Do not exceed the concurrent request limits of the Web servers that you access. Three clients
configured to allow two concurrent requests can exceed this limit.

Note
This change may apply to other user agents installed on the same machine and used by the same
user.
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To configure a Windows account to allow more than the default number of HTTP connections to any
single Web server:

1.

254

Hold down the WINDOWS key and press R. The Run dialog box appears. In the Run dialog
box, type regedit, and then click OK. The Registry Editor appears.

= Run =3

Type the name of a program, folder, document, or Internet
resaurce, and Windows will apen it for you.

Open: | IEER A

% This task will be created with administrative privileges.

=

[ 0K ] ‘ Cancel | | Browse...

In the Registry Editor, expand
HKEY CURRENT USER\Software\Microsoft\Windows\CurrentVersion\Internet
Settings.

Note

You may be able to apply this setting for all Windows users by making the corresponding
change under

HKEY LOCAL MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet

Settings instead of under HKEY CURRENT USER.

In the Registry Editor, right-click Internet Settings, and then click New, DWORD (32-bit)
Value. Name the new entry MaxConnectionsPerl 0OServer.

In the Registry Editor, double-click MaxConnectionsPerl OServer. The Edit DWORD
(32-bit) Value dialog box appears.

In the Edit DWORD (32-bit) Value dialog box, select Decimal, and then for Value data, enter
the maximum number of concurrent connections to allow for HTTP 1.0 servers, and then click
OK.

In the Registry Editor, right-click Internet Settings, and then select New DWORD (32-bit)
Value. Name the new entry MaxConnectionsPerServer.

In the Registry Editor, right-click MaxConnectionsPerServer, and then select Modify. The
Edit DWORD (32-bit) Value dialog box appears.

In the Edit DWORD (32-bit) Value dialog box, select Decimal, and for Value data, enter the
maximum number of concurrent connections to allow for HTTP 1.1 servers, and then click
OK.

Reboot.

Miscellaneous Settings

You can choose to follow any of the following suggestions:

1.

In Internet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

In the Internet Options dialog box, click the Advanced tab.

On the Advanced tab, in the Browsing section:

Setting Value

Disable script debugging (Internet Explorer) Clear
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Setting Value
Display a notification about every script error Select
Reuse windows for launching shortcuts (when | Clear
tabbed browsing is off)

Show friendly HTTP error messages Clear

4. Inthe Internet Options dialog box, click OK.
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Troubleshooting Microsoft Internet Explorer

This chapter contains instructions for troubleshooting issues with Internet Explorer.

Some of these considerations may also apply to other browsers, although the Ul
instructions may differ from browser to browser.

This chapter contains the following sections:
e Troubleshooting Process

e Additional Troubleshooting Resources
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3.1 Troubleshooting Process

This section describes the process that you can follow to troubleshoot issues with Internet Explorer.
To summarize the troubleshooting process:

e Check Sitecore Client Requirements.

e Check Browser Configuration.

e Disable Browser Plug-ins.

e Clear Browser Temporary Files.

e Patch Windows and Components.

e Check Internet Security Software.

e Reset Internet Explorer Configuration.

e Reproduce the Issue Using another Browser.
e Reproduce the Issue as another User.

e Reproduce the Issue from another Machine.

3.1.1 Check Sitecore Client Requirements

Ensure that the client meets the Sitecore client requirements. For more information about the Sitecore
client requirements, see the Sitecore CMS installation guide for the version that you are using.

3.1.2 Check Browser Configuration

Ensure that you have correctly followed the appropriate steps outlined in this document.

3.1.3 Disable Browser Plug-ins

Uninstall or disable any browser plug-ins such as toolbars, pop-up blockers, and other components.

3.1.4 Clear Browser Temporary Files

Users are unable to reproduce numerous issues after clearing the Internet Explorer cache or all
temporary files.

Important
To force Internet Explorer to retrieve any updated resources, you should always clear the browser
cache after upgrading Sitecore.
To clear the browser cache in Internet Explorer 8, 9 and 10:
1. Ensure that there is only one open instance of Internet Explorer.

2. InlInternet Explorer, click the Tools menu or press ALT-T, and then click Delete browsing
history. The Delete Browsing History dialog box appears.

3. Inthe Delete Browsing History dialog box, ensure that Temporary Internet Files is the only
selection, and then click Delete.

4. Close Internet Explorer.
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If the issue persists:

Important
To avoid losing personal data, skip this step, and return to this section after exhausting all other
troubleshooting options.

Note
In some environments, instead of deleting all of the browser cookies, you may be able to delete only
the cookie associated with the Sitecore instance.

1. Ensure that there is only one open instance of Internet Explorer.

2. InlInternet Explorer, click the Tools menu or press ALT-T, and then click Delete browsing
history. The Delete Browsing History dialog box appears.

3. Inthe Delete Browsing History dialog box, clear the Preserve Favorites website data
check box, select all of the other options, and then click Delete.

4. Close Internet Explorer.

3.1.5 Patch Windows and Components

Use Windows Update to patch Windows, Internet Explorer, MSXML, and other system components.
Reboot even if no updates were available.

3.1.6 Check Internet Security Software

Software firewalls, antivirus, and other Internet security software can adversely affect Web
applications. To determine if the issue could be a software conflict:

1. Disable your security software,
2. Close every Internet Explorer window.

3. Clear the Internet Explorer cache as described in the section Clear Browser Temporary
Files.

4. Reboot.
5. Attempt the failed operation again.

If you cannot reproduce an issue with the security software disabled, and can reproduce that issue
with that software enabled, then contact Sitecore as described in the section Additional
Troubleshooting Resources.

3.1.7 Reset Internet Explorer Configuration

If you cannot determine the cause of an issue, you can reset Internet Explorer to its default state, and
then apply the configuration described in this document.

To reset the Internet Explorer configuration:
1. Ensure that there is only one open instance of Internet Explorer.

2. InlInternet Explorer, click the Tools menu or press ALT-T, and then click Internet Options.
The Internet Options dialog box appears.

3. Inthe Internet Options dialog box, click the General tab, and then in the Tabs section, click
Tabs. The Tabbed Browsing Settings dialog box appears.

In the Tabbed Browsing Settings dialog box, click Restore Defaults, and then click OK.

In the Internet Options dialog box, click the Security tab, then click Trusted Sites, and then
click Default Level.
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6. Inthe Internet Options dialog box, click the Advanced tab, and then click Restore
Advanced Settings.

7. Inthe Internet Options dialog box, on the Advanced tab, click Reset, acknowledge the
prompt, and then click OK.

Close every Internet Explorer window.

9. Apply the configuration that is described in this document.

3.1.8 Reproduce the Issue Using another Browser

An issue that you cannot reproduce using another browser probably results from the Internet Explorer
configuration or the cache. If you can reproduce the issue using multiple browsers, the root cause
may be something other than Internet Explorer configuration, such as the network or server
configuration.

3.1.9 Reproduce the Issue as another User

An issue that you cannot reproduce as another user likely results from permissions, browser cookies,
profile settings, or other user-specific configuration.

3.1.10 Reproduce the Issue from another Machine

An issue that does not result from browser or user configuration and that you cannot reproduce from
another machine is likely to result from machine or network configuration.
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3.2 Additional Troubleshooting Resources

If you cannot resolve an issue after applying the instructions in this document, check for proper server
configuration. Describe the issue and the troubleshooting steps you have attempted using the
General Forum on the Sitecore Developer Network. If you are a certified Sitecore developer, file a
case in the Sitecore Support Portal. Otherwise, have a certified Sitecore developer in your
organization investigate your configuration and file a case on your behalf.

Tip
To copy an error message to the Windows clipboard, press ALT-PRTSCN and paste the image into a
document or email message.
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Configuring Other Browsers

This chapter describes the configuration issues that are related to other popular
browsers.

This chapter contains the following sections:
e Enabling Pop-up Windows in Google Chrome
e Enabling Pop-up Windows in Other Browsers

e Preventing Mozilla Firefox from Showing Confirmation Dialog Box in the
Page Editor
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4.1

Enabling Pop-up Windows in Google Chrome

Google Chrome can run Sitecore but does not have pop-ups enabled by default. Create an exception
in Google Chrome to only allow pop-ups for Sitecore web sites. This requires you to make an
exception in the Content Settings window.

To create an exception in Google Chrome:

1.
2,

S o

Open your Google Chrome browser.

Click the Spanner icon in the top right of the browser window: Customize and control Google
Chrome.

=l

o3

In the drop-down menu, click Options.
Click the Under the Hood tab.
In Privacy, click Content settings.

In the Content Settings window, click Pop-ups and then select the do not allow any site to
show pop-ups (recommended) radio button.

Click Exceptions to open the Pop-up Exceptions window.

| Pop-up Exceptions

Pattern Action
[*Jlocalhost Allow
[*Jsupport.sitecore.net Allow

Add... Edit... Remove Remove All

In the Pop-up Exceptions window, add the following exceptions:

[*.]localhost
[*.]support.sitecore.net

This ensures that pop-ups are blocked on all web sites unless it is a Sitecore site or running
on local host.

Click Close and return to your web browser.
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4.2 Enabling Pop-up Windows in Other Browsers
In Mozilla Firefox and Apple Safari it is not necessary to enable pop-up windows.

In Firefox, when you first open Sitecore you are prompted to enable or block pop-ups. An exception
for Sitecore is added to the Allowed Sites window in Firefox.

@ Allowed Sites - Pop-ups EI@

You can specify which web sites are allowed to open pop-up
windows, Type the exact address of the site you want to allow and
then click Allow.

Address of web site:

Allow

Status

Remove Site ] ’ Remowve 4ll Sites

To view allowed sites in a Firefox browser:
1. Click Tools, Options, and then click the Content tab.

2.  Ensure the Block pop-up windows check box is selected, and then click Exceptions.
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4.3 Preventing Mozilla Firefox from Showing Confirmation

Dialog Box in the Page Editor

In the Page Editor, Mozilla Firefox may show the Prevent this page from creating additional dialogs
confirmation dialog box if you open modal dialogs too often. To prevent Mozilla Firefox from showing

this confirmation dialog box:

1. Inthe browser address bar, enter about:config.

2. Right-click on the preferences area and then click New, Integer.

[] aboutcanfig

Eilter:

Preference Name
accelerometer.enabled
accessibility.accesskeycausesactivation
accessibility.blockautorefresh
accessibility.browsewithcaret

Toggle

accessibility.moy

accessibility.tabf{ Copy
accessibility.tabf Copy Name
accessibiiy type Copy Volue
accessibility.type]

New 4

accessibility.type]
accessibility.type Reset
accessibility.typeaheadfind.enabletimec
accessibility.typeaheadfind flashBar
accessibility.typeaheadfind linksonly

String
Integer

Boolean

3. Inthe New Integer Value dialog box, enter dom.successive_dialog_time_limit and click Ok.

4. Inthe Enter Integer Value dialog box, enter 0 and click OK.
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