
Sitecore CMS 6.0-6.2  
Content Cookbook Rev: 2012-10-19 

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The contents of 
this document are the property of Sitecore. Copyright © 2001-2012 Sitecore. All rights reserved. 
 

Sitecore CMS 6.0-6.2 

Content Cookbook 
Tips and Techniques for CMS Editors and Authors  



Sitecore CMS 6.0-6.2 Content Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The contents of 
this document are the property of Sitecore. Copyright © 2001-2012 Sitecore. All rights reserved.  

Page 2 of 46 

Table of Contents 

Chapter 1 Introduction .......................................................................................................................... 3 
1.1 Accessing Sitecore .................................................................................................................. 4 

1.1.1 Advanced Login Mode ........................................................................................................ 6 
Chapter 2 Managing Content ............................................................................................................... 8 

2.1 Managing Items in the Content Tree ....................................................................................... 9 
2.1.1 Copying an Item to another Location .................................................................................. 9 
2.1.2 Duplicating an Item............................................................................................................ 10 
2.1.3 Moving an Item .................................................................................................................. 10 
2.1.4 Deleting an Item ................................................................................................................ 11 
2.1.5 Renaming an Item ............................................................................................................. 12 
2.1.6 Sorting Items ..................................................................................................................... 12 
2.1.7 Using the context menu (right-click) .................................................................................. 13 
2.1.8 Using the drag&drop feature. ............................................................................................ 13 
2.1.9 Using the Clipboard ........................................................................................................... 14 

2.2 Media Library......................................................................................................................... 15 
2.2.1 How to Access the Media Library?.................................................................................... 15 
2.2.2 Uploading Files to the Medial Library ................................................................................ 15 
2.2.3 Advanced Upload Options ................................................................................................ 17 
2.2.4 How to Upload Multiple Files in a Batch? ......................................................................... 19 

2.3 Versioning ............................................................................................................................. 20 
2.3.1 How to Switch Between Versions? ................................................................................... 20 
2.3.2 Adding a New Numbered Version ..................................................................................... 20 
2.3.3 Removing a Numbered Version of an Item ....................................................................... 21 
2.3.4 Checking What Has Changed Between Two Versions of an Item .................................... 22 
2.3.5 Translating Item Content into a Different Language ......................................................... 23 
2.3.6 How is a New Language Version Created? ...................................................................... 24 

Chapter 3 Managing Languages ........................................................................................................ 25 
3.1 How to Add a New Language? ............................................................................................. 26 
3.2 How to Remove a Language?............................................................................................... 29 

Chapter 4 Publishing Content ............................................................................................................ 30 
4.1 How to Publish an Item or a Whole Site? ............................................................................. 31 

4.1.1 Publishing an Item with Advanced Options ....................................................................... 32 
4.1.2 Publishing the Whole Site ................................................................................................. 32 

4.2 How to Hide a Version of an Item? ....................................................................................... 35 
4.3 How to Unpublish an Item? ................................................................................................... 36 
4.4 How to Schedule Item Publication? ...................................................................................... 37 
4.5 How to See Which Version of an Item Will be Published? ................................................... 40 

Chapter 5 Maintaining Search............................................................................................................ 41 
5.1.1 How to rebuild the Search Index and the Link Database? ................................................ 41 

Chapter 6 Administrator’s Notes ........................................................................................................ 44 
6.1 Customizing Login Page ....................................................................................................... 45 
6.2 Changing the Default Client Language ................................................................................. 46 

 



Sitecore CMS 6.0-6.2 Content Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The contents of 
this document are the property of Sitecore. Copyright © 2001-2012 Sitecore. All rights reserved.  

Page 3 of 46 

Chapter 1  

Introduction 

This cookbook contains tips and tutorials for Sitecore CMS content editors. The 
document consists of the following chapters: 

 Chapter 1 – Introduction 

 Chapter 2 – Managing Content 

 Chapter 3 – Managing Languages 

 Chapter 4 – Publishing Content 

 Chapter 5 – Maintaining Search 

 Chapter 6 – Administrator’s Notes 
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1.1 Accessing Sitecore 

Users access the Sitecore web interfaces via the Sitecore login page. Access the login page by typing 
“sitecore” at the end of the base URL for the site. For example, if the site URL is: 

http://www.mysite.com/ 

then you can access the Sitecore login page via:  

http://www.mysite.com/sitecore 

The login page is shown in the following image: 

 

Choose the login options (described below), enter your user name and password and click “Login” to 
login. 

The following paragraphs describe the controls and areas of the login page. 

1 

2 3 

4 
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1. Login/Advanced links. 
 
Use these links to switch between the advanced and the simple login views. The simple login 
view allows to choose between the Page Editor and the Content Editor while the Advanced view 
provides more options which determine which interface a user will see after logging in. Take a 
look: 
 
Login view 

 
Advanced view 

 
The Advanced View is described in detail in a section further in this document. 

2. Login Form.  
 
Enter your login and password here and click the Login button to login. 
Note: The username is case insensitive, while the password is case sensitive. It means that if 
your username is Claire, you will be successfully logged in as claire. However, if your password is 
MyPassword, then mypassword will not work.  
 
Sitecore will remember the last username and other options provided.  
 
The Forgot Your Password and Change Password links allow to retrieve a forgotten password 
and change your password (you need to enter the current password in order to change it). 

3. License and version information. 
 
View the information about the current installation, including the exact release of Sitecore that is 
running. 
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4. Browser notes. 
 
View the important notes concerning the browser used and other important notices. 

1.1.1 Advanced Login Mode 

In the Advanced Login Mode users can select which interface to display after the username and 
password have been validated. 

 

Note: Administrators may override this option for certain users, thus forcing these users to always start in 
a specific interface. 

The Advanced mode also provides the following settings: 

 Browser Display Mode. 
This setting has three options: Normal, Without Toolbars, Fullscreen. 
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 Client Language. 
The Client Language setting allows selecting the language in which the client functionality is 
displayed. 

 
The client language selection affects only the language in which buttons and descriptions are 
displayed in the interface. The content language, however, is managed separately. Administrators 
can specify the default content language on a per-user (via the Edit User dialog) or per-site basis 
(via the shell site element in the web.config file). 
 
If some of the languages do not have complete translations, English versions will be shown for 
items where a translation is unavailable. 
 
“Default” means that the client language set in the User Properties for a username provided is 
set. The default client language for all users in Sitecore is English. However, it is possible to 
change the default language for a certain user. 
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Chapter 2  

Managing Content 

This chapter contains tips on managing items in the content tree, using media library, 
uploading files and using item versioning features. 
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2.1 Managing Items in the Content Tree 

There are several ways to move, create, and edit items in the content tree: 

1. Use the appropriate groups and buttons on the Home tab. 

2. Use the context menu (right-click an item). 

3. Use the drag&drop feature. 

4. Use the Clipboard group in the Home tab to cut/copy and paste items. 

In this document, each action is usually described using the first approach in detail with some brief 
explanations of the other approaches. 

Note: 

Some parts of the Content Tree may be hidden due to the Content Editor settings.  

You should check the Hidden Items checkbox in the View tab to see the Layout, System and Templates 
items. If you do not see the Media Library in the Content Editor, check the Entire Tree checkbox. 

 

2.1.1 Copying an Item to another Location 

To copy an item to another location: 

1. In the content tree, select the item that you want to copy. 

2. On the Home tab, in the Operations group, click Copy To. 
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3. In the Copy Item To dialog box, select the location that you want to copy the item to. 

 

4. Click Copy and the item is copied to the specified location. 

2.1.2 Duplicating an Item 

To duplicate an existing item: 

1. In the content tree, select the item that you want to duplicate. 

2. On the Home tab, in the Operations group, click Duplicate and a dialog box appears prompting 
you to name the new item. 

 

3. Enter a name for the new item and it is added to the content tree at the same level as the item 
you duplicated. It also contains all of the same text, images and so on as the original item. 

2.1.3 Moving an Item 

To move an item: 

1. In the content tree, locate the item that you want to move. 
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2. On the Home tab, in the Operations group, click Move To. 

 

3. In the Move Item To dialog box, select the location that you want to move the item to. 

4. Click Move to move the item to the new location. 

2.1.4 Deleting an Item 

To delete an item from the Web site: 

1. In the content tree, select the item that you want to delete. 

2. On the Home tab, in the Operations group, click Delete. 

 

The item is deleted from the Web site. 

If you try to delete an item that contains sub-items, a message will appear informing you that that the 
section contains sub-items and that these items will be deleted along with the main item. 

 

If you want to save any of the items, you must move them to another part of the Web site. Click OK to 
delete the item and its subitems. 

If you want to delete only the subitems of the selected item, click the triangle next to the Delete button 
and select the Delete Subitems button. 
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2.1.5 Renaming an Item 

To rename an item: 

1. In the content tree, select the item that you want to rename. 

2. On the Home tab, in the Rename group, click Rename. 

 

3. In the prompt dialog enter the new name and click OK. 

 
The item is renamed. 

Using the Rename group you can also change the Display Name of an item. 

2.1.6 Sorting Items 

To sort items in the content tree, use the Sorting group on the Home tab. 

 

 Click Up to move the selected item before the previous one. 

 Click Down to move the selected item after the next one. 

 Click First to make the item first. 

 Click Last to make the item last. 

Click the advanced options icon to use the subitem sorting options. 
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You will see the following window: 

 

2.1.7 Using the context menu (right-click) 

Right-click an item to access the context menu which allows to perform various actions: 

 

2.1.8 Using the drag&drop feature. 

Click an item and drag it to move this item to another location. 

 Drag&drop an item with the Ctrl button pressed to copy the item. 

 Drag&drop an item with the Alt button pressed to change the sorting order. You can use this 
feature both for sorting subitems and for moving items to another location. 
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2.1.9 Using the Clipboard 

Use the Clipboard group in the Home tab to cut/copy and paste items. 

 

Select an item, click Cut, navigate to the item where you want to paste it and click Paste - the item you 
cut will be created as a child of the selected item and the original item will be removed. 

Copy-Paste works in the same way but the original item is not removed. 
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2.2 Media Library 

This section describes how to access the Media Library and upload files to it. 

2.2.1 How to Access the Media Library? 

You can access the Media Library in the following ways: 

 From the Desktop, select Sitecore » Media Library. 

 In the Content Editor, select Media Library in the bottom bar: 

 

 In the Content Editor, navigate to Media Library folders in the content tree (“Hidden Items” and 
“Entire Tree” checkboxes must be checked in the View tab). 

2.2.2 Uploading Files to the Medial Library 

To upload files to the Media Library: 

1. Navigate to a folder in the Media Library. In the right part of the screen you will see the following 
menu: 

 

2. Click Upload Files. In the prompt dialog select the files you want to upload; you can select 
multiple files (by holding Ctrl while selecting or drawing the selection area): 
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Click Open when done, the upload process will start and you will see a similar screen: 
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3. When the upload process finishes, review the uploaded files: 

 

2.2.3 Advanced Upload Options 

To use the advanced upload options, select the Upload Files (Advanced) button.  
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Select the files you want to upload; you can select multiple files (by holding Ctrl while selecting or drawing 
the selection area): 

 

Click Open. The following dialog will appear: 

 

This dialog provides the following advanced options: 

Alternate Text 

Use the Alternate Text field to enter the text for the alt tag for an image. 
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Unpack ZIP Archives 

Use this checkbox to unpack ZIP archives after they are uploaded. The archives themselves are deleted 
after unpacking. If the archive contains folders, such folders will be created in the Media Library as well. 
This feature is extremely useful if you need to upload a big number of files. 

Overwrite Existing Media Items 

Check this checkbox if you want to overwrite an existing item if you upload an item with the same name. If 
the checkbox is not checked and the name of the file you upload coincides with the name of some item 
which already exists in the folder you upload to, them another item with the same name will be created. 

Make Uploaded Media Items Versionable 

Check this checkbox if you want to make the media items you upload versionable. By default, media 
items are uploaded as non versionable (as determined by the Media.UploadAsVersionableByDefault 
setting in web.config). 

2.2.4 How to Upload Multiple Files in a Batch? 

To upload multiple files in a batch, you should do the following: 

 Create a .zip archive with files you intend to upload on your disk. You can include folders with 
files – the folder structure will be preserved in the media library after extraction. 

 In a media library folder, click the Upload Files (Advanced) button and select your .zip archive 
using the Browse button. 

 Check “Unpack ZIP archives” checkbox. 

 Click the Upload button. The archive will be uploaded and extracted in the currently selected 
media library folder. 
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2.3 Versioning 

This section describes how to work with versions in Sitecore CMS. 

2.3.1 How to Switch Between Versions? 

To switch between numbered versions, click the numbered version button in the Content Editor and 
choose a version: 

 

To switch between language versions, click the language version button in the Content Editor and choose 
a language: 

 

2.3.2 Adding a New Numbered Version 

Follow the steps below to add a new numbered version to the currently selected item. 
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In the Content Editor, click on the version number mark in the upper right corner of the content area. The 
list of versions will appear: 

 

Click the Add Version button in the bottom of the list. The new version in the current language will be 
added. 

Note 
A new version is added by copying the currently selected version. All field values are copied. 

Adding a New Numbered Version via the Ribbon 

 Select the item for which you want to add a new version. 

 Select the Versions tab in the ribbon. 

 

 Click the Add button in the Versions group. The new version in the current language will be 
added. 

2.3.3 Removing a Numbered Version of an Item 

To remove a numbered version of an item: 

 Select an item. 

 Select the version you want to remove. 
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 Click the Remove button in the Versions group of the Versions tab. 

 
The currently active version will be removed. 

2.3.4 Checking What Has Changed Between Two Versions of an Item 

To check what has changed between two versions of an item: 

 Select an item in the Content Editor. 

 On the Versions tab, in the Versions group, Click Compare. 

 

You will see the following dialog: 

 

The dialog above shows differences between versions two and three. Changes in fields are marked with 
blue color. 
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In the image above you see the two column mode. One column mode looks like this: 

 

2.3.5 Translating Item Content into a Different Language 

To translate an item content into a different language: 

 Select an item you want to translate. 

 On the Versions tab, in the Translate group, Click Translate. 

 
Once Translate is clicked, the Translate group options becomes active: 

 

 Choose a language in the Language field. You will see the fields in this language in the right 
column (see the image below): 
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Enter the translated text in these fields. 

In the Translate group you can also see the Compare fields. You can use these fields to compare 
different versions of the item right in the Content Editor window, but as against to the Compare button in 
the Versions group, this feature does not highlight the differences. 

2.3.6 How is a New Language Version Created? 

To add a version in a different language, you should switch to this language in the Language group of the 
Versions tab and add a numbered version. This numbered version will be created in the currently 
selected language. 

The following chapter describes how to add a new language. 
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Chapter 3  

Managing Languages 

This chapter describes how to add and remove languages in Sitecore CMS. 
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3.1 How to Add a New Language? 

To add a new language, select the /sitecore/system/Languages item and add a new language using the 
Language template: 

 

When you select the Language template, the following dialog appears: 
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In the topmost field select the language you want to add, when you do this all other fields except for the 
Custom Code field will be filled automatically. 

Click Next. 

The Codepage and Encoding dialog will appear with the default settings for the selected language 
entered: 

 

Click Next. 

The Spellchecker Dictionary dialog will appear with the default setting entered: 
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Click Next, view the final window and click Finish. The language is added: 

 

Alternatively you can add a language via the Control Panel: 

 Open Sitecore » Control Panel » Globalization » Add a New Language. This will start the 
same dialog as described above. 
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3.2 How to Remove a Language? 

To remove a language from a Sitecore CMS solution: 

1. Under the /sitecore/system/Languages item, select a language you want to remove. 

 

2. Select Delete in the Home tab, just like you would do with a usual item. 

3. In the prompt dialog, confirm that you want to delete the item and the following dialog will appear: 

 
Click OK to proceed. The language and all content in this language will be removed. 

Note 
Removing a language from a Sitecore CMS solution will remove all the content in this language from 
every item. 

Alternatively you can remove a language via the Control Panel.  

 Open Sitecore » Control Panel » Globalization » Delete a Language. This will start the same 
dialog as described above. 
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Chapter 4  

Publishing Content 

This section provides instructions on various actions related to publishing. 
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4.1 How to Publish an Item or a Whole Site? 

To publish an item, on the Publish tab, in the Publish group, click Publish. 

 

The following dialog will appear: 

 

Click OK. The following dialog will appear: 

 

Click OK, the publishing process will run in the background and in a short period of time (the period 
depends on the current publish queue and server performance, but generally the published content 
appears in the target database within a few seconds). 

The Publish button has a submenu which provides additional options described in the following sections: 
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4.1.1 Publishing an Item with Advanced Options 

To publish an item with advanced options, select the Publish Item sub option: 

 

The following dialog will appear: 

 

Choose the options necessary and click Publish. 

Review the summary dialog and click Finish. 

4.1.2 Publishing the Whole Site 

To publish the whole site, select the Publish Site sub option: 
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The following dialog will appear: 

 

Choose the options necessary and click Publish. The following window will appear: 

 

Note 
You may close the publishing dialog before the process is completed. The publishing will continue 
anyway, but you will not see the summary window. 
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When the publishing process will be completed, the summary window will appear. 

 

Review the window and click Finish. 
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4.2 How to Hide a Version of an Item? 

If an item has multiple versions, the last version by number is published unless it is hidden or has other 
publishing restrictions. 

To hide a version of an item: 

1. On the Publish tab, in the Restrictions group, click the Change button: 

 

2. The following window will appear: 

 

3. To hide a version of the item, clear the checkbox in the Publishable column next to the version 
number. 
If you want to hide the version of the item until a certain date, check the Publishable checkbox 
and set the appropriate date and time in the Publishable From field. 
If you want to hide the version of the item after a certain date, check the Publishable checkbox 
and set the appropriate date and time in the Publishable To field. 

4. Click OK. 

5. Save the item. 

6. The appropriate version will be put into the web database when the next publishing operation is 
performed. For instance, if you have cleared the Publishable checkbox for version 3, version 2 
will be put into the web database (if it does not have restrictions in one’s turn). 
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4.3 How to Unpublish an Item? 

To unpublish an item and all of its versions: 

1. On the Publish tab, in the Restrictions group, click the Change button: 

 

2. In the prompt window select the Item tab: 

 

3. To unpublish the item, clear the Publishable checkbox. 
If you want to unpublish the item until a certain date, check the Publishable checkbox and set 
the appropriate date and time in the Publishable From field. 
If you want to unpublish the item after a certain date, check the Publishable checkbox and set 
the appropriate date and time in the Publishable To field. 

4. Click OK. 

5. Save the item. 

6. The item will be removed from the web database when the next publishing operation is 
performed.  
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4.4 How to Schedule Item Publication? 

Scheduling an item publication is implemented using the Sitecore Scheduled Tasks functionality and 
requires some coding. The following example shows how to set up a sample scheduled task which starts 
on a certain time and writes a message to file. In order to publish an item using such approach you 
should write a class which implements publishing instead of the class shown in the example. 

The following steps describe how to configure such a task: 

1. Create your own class. This class must implement at least one public method with the following 
parameters: 
 
      using System; 

      using Sitecore.Data.Items; 

      using Sitecore.Tasks; 

      namespace CustomScheduleTasks 

      {  

         public class Task1  

         {  

            public void WriteToLogFile(Item[] itemArray, CommandItem 

commandItem, ScheduleItem scheduledItem)  

            {  

               Sitecore.Diagnostics.Log.Info("Test Scheduled task: 

"+DateTime.Now, this);  

            }  

         } 

      } 

2. Compile this assembly and put the resulting file, for example: CustomScheduleTasks.dll, into the 
/bin folder under the Sitecore web root. 

3. In the Content Editor navigate to the System item, locate the /System/Tasks/Commands/ folder 
and create a new item based on the /sitecore/templates/System/Tasks/Command template. 

 



Sitecore CMS 6.0-6.2 Content Cookbook   

 

Sitecore® is a registered trademark. All other brand and product names are the property of their respective holders. The contents of 
this document are the property of Sitecore. Copyright © 2001-2012 Sitecore. All rights reserved.  

Page 38 of 46 

4. Fill in the fields of the command item: 

 
The Type field holds the %namespace.class%, %assembly name% value. The Method indicates 
the method to call from the specified class.  
Your command is now ready to use as a scheduled task. 

5. Navigate to the /System/Tasks/Schedules/ folder and create the new item based on the 
/sitecore/templates/System/Tasks/Schedule template. 

 

6. Fill in the fields of the schedule item: 
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Command: select command created in the previous step. 
Items: if you want to pass an array of items to your method you can place any XPath expression 
here. Multiple items can be divided by the pipe separator. For example: 
/Sitecore/content/Home/Globals/Item1|/Sitecore/content/Home/Globals/Item2. 
Schedule: 20080720T235900|20090630T235900|127|00:10:00. 
In this example, the task will be executed from 2008.07.20 23:59:00 to 2009.06.30 23:59:00, 
every day (as specified by the number 127) and every 10 minutes (as specified by 00:10:00). 
In the Schedule field you can place 4 parameters divided by pipe separators: 
From Date|To Date|Day of the Week|Period of time 
 
For the day of the week DaysOfWeek enumeration is used. For example for Monday and Friday 
you should write 34 (2+32) 
 
        public enum DaysOfWeek 

        { 

          None = 0, 

          Sunday = 1, 

          Monday = 2, 

          Tuesday = 4, 

          Wednesday = 8, 

          Thursday = 16, 

          Friday = 32, 

          Saturday = 64, 

        } 

        
Period of time has the following format: hh:mm:ss. 
Auto Remove: if this field is checked, then the schedule item will be removed (deleted) after it is 
completed. 

7. Set the necessary frequency and interval parameters in the web.config: 
 
<scheduling>  

  <!-- Time between checking for scheduled tasks waiting to execute --> 

  <frequency>01:00:00</frequency> 

 

  <!-- Agent to process schedules embedded as items in a database --> 

  <agent type="Sitecore.Tasks.DatabaseAgent" method="Run" 

interval="01:00:00"> 

    <param desc="database">master</param> 

    <param desc="schedule root">/sitecore/system/tasks/schedules</param> 

    <LogActivity>true</LogActivity> 

  </agent>  

   ... 

Note 
In the environments with many instances, this task will be performed on each instance that is connected 
to the database that contains the item task. This can lead to unexpected results, such as wrong 
publishing or republishing of the same items if the task is designed for publishing operations. Additional 
checks must be added to ensure that the task runs only on one instance. 
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4.5 How to See Which Version of an Item Will be Published? 

To see which version of an item will be published on a certain time you should open the Publishing 
Viewer application. 

On the Publish tab, in the Publish Group, select the Publish Viewer application: 

 

The following window will appear: 

 

Use the Start Date and End Date calendar fields to select the time span you want to view. 

The bars in the lower part of the window indicate whether the item or its versions can be published. 

The bar coloring follows the code: 

 Green: The version is active and valid for publish. 

 Gray: Inactive. The version is typically superseded by a newer version. 

 Blue: The period where the item is valid. It is not necessarily published. 
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Chapter 5  

Maintaining Search 

This chapter contains notes about maintaining the search functionality in Sitecore CMS. 

5.1.1 How to rebuild the Search Index and the Link Database? 

The Search Index and the Link Database can be rebuilt via the Control Panel. 

Open the Control Panel (Sitecore » Control Panel): 

 

Select the Database section: 
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Select the Rebuild the Link Database link to rebuild the Link Database: 

 

Choose the databases where the Link Databases should be rebuilt and click Rebuild. 
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Select the Rebuild the Search Index link to rebuild the Search Index: 

 

Choose the databases where the indexes should be rebuilt and click Rebuild. 
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Chapter 6  

Administrator’s Notes 

Useful tips and notes for administrators. 
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6.1 Customizing Login Page 

Developers may choose to customize the login page for your site. Therefore, the login page you see may 
differ from the one shown in the screenshot above.  Developers can choose simple changes, such as 
changing the “Welcome to Sitecore” title or provide additional text by modifying the “WelcomeTitle” and 
“WelcomeText” settings in the web.config.  

Developers may also choose to make more significant changes to the login page by modifying the 
associated .aspx, .js, .css, or image files associated with the page. The source of these related files is 
under the Sitecore web root in the /sitecore/login folder. 
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6.2 Changing the Default Client Language 

The default client language for all users in Sitecore is English. However, it is possible to change the 
default language for a certain user. To do that, follow the steps below: 

Start the User Manager application: Sitecore » Security Tools » user Manager. 

 

Select the user for whom you want to change the client language and click Edit in the Users group. 

The Edit User window will appear. In this window select the Language Settings tab: 

 

In the Client Language field set the needed value. 
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