InSite.Domain Namespace

[image]

.NET Framework Class Library
InSite.Domain Namespace
Send Feedback

Classes

Class | Description
ErrorHandler |
FlexLoginCommand |
FlexLoginService |
FlexService |
Send feedback on this topic to Microsoft.


ErrorHandler Class

[image]

.NET Framework Class Library
ErrorHandler Class
Members See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ErrorHandler
C#
public class ErrorHandler
Visual C++
public ref class ErrorHandler
JavaScript
InSite.Domain.ErrorHandler = function();

Type.createClass(
    'InSite.Domain.ErrorHandler');

Inheritance Hierarchy

System..::.Object
InSite.Domain..::.ErrorHandler

See Also

ErrorHandler Members
InSite.Domain Namespace


ErrorHandler Members

[image] [image]

.NET Framework Class Library
ErrorHandler Members
ErrorHandler Class Constructors Methods See Also Send Feedback

The ErrorHandler type exposes the following members.

Constructors

Name | Description
ErrorHandler |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LogAndEmailError | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ErrorHandler Class
InSite.Domain Namespace


ErrorHandler Constructor

[image]

.NET Framework Class Library
ErrorHandler Constructor
ErrorHandler Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ErrorHandler()
Visual C++
public:
ErrorHandler()
JavaScript
InSite.Domain.ErrorHandler = function();

See Also

ErrorHandler Class
InSite.Domain Namespace


ErrorHandler Methods

[image] [image]

.NET Framework Class Library
ErrorHandler Methods
ErrorHandler Class See Also Send Feedback

The ErrorHandler type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LogAndEmailError | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ErrorHandler Class
InSite.Domain Namespace


LogAndEmailError Method

[image] [image]

.NET Framework Class Library
ErrorHandler..::.LogAndEmailError Method
ErrorHandler Class See Also Send Feedback

Overload List

Name | Description
LogAndEmailError(Exception) |
LogAndEmailError(HttpServerUtility) |
LogAndEmailError(Exception, String, Int32) |
LogAndEmailError(String, String, Int32, Boolean) |

See Also

ErrorHandler Class
ErrorHandler Members
InSite.Domain Namespace


LogAndEmailError Method (Exception)

[image]

.NET Framework Class Library
ErrorHandler..::.LogAndEmailError Method (Exception)
ErrorHandler Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogAndEmailError ( _
    ex As Exception _
)
C#
public static void LogAndEmailError(
    Exception ex
)
Visual C++
public:
static void LogAndEmailError(
    Exception^ ex
)
JavaScript
InSite.Domain.ErrorHandler.logAndEmailError = function(ex);

Parameters

ex
Type: System..::.Exception

See Also

ErrorHandler Class
LogAndEmailError Overload
InSite.Domain Namespace


LogAndEmailError Method (HttpServerUtility)

[image]

.NET Framework Class Library
ErrorHandler..::.LogAndEmailError Method (HttpServerUtility)
ErrorHandler Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogAndEmailError ( _
    Server As HttpServerUtility _
)
C#
public static void LogAndEmailError(
    HttpServerUtility Server
)
Visual C++
public:
static void LogAndEmailError(
    HttpServerUtility^ Server
)
JavaScript
InSite.Domain.ErrorHandler.logAndEmailError = function(Server);

Parameters

Server
Type: System.Web..::.HttpServerUtility

See Also

ErrorHandler Class
LogAndEmailError Overload
InSite.Domain Namespace


LogAndEmailError Method (Exception, String, Int32)

[image]

.NET Framework Class Library
ErrorHandler..::.LogAndEmailError Method (Exception, String, Int32)
ErrorHandler Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogAndEmailError ( _
    ex As Exception, _
    source As String, _
    batchNumber As Integer _
)
C#
public static void LogAndEmailError(
    Exception ex,
    string source,
    int batchNumber
)
Visual C++
public:
static void LogAndEmailError(
    Exception^ ex,
    String^ source,
    int batchNumber
)
JavaScript
InSite.Domain.ErrorHandler.logAndEmailError = function(ex, source, batchNumber);

Parameters

ex
Type: System..::.Exception
source
Type: System..::.String
batchNumber
Type: System..::.Int32

See Also

ErrorHandler Class
LogAndEmailError Overload
InSite.Domain Namespace


LogAndEmailError Method (String, String, Int32, Boolean)

[image]

.NET Framework Class Library
ErrorHandler..::.LogAndEmailError Method (String, String, Int32, Boolean)
ErrorHandler Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogAndEmailError ( _
    message As String, _
    source As String, _
    batchNumber As Integer, _
    isInSiteException As Boolean _
)
C#
public static void LogAndEmailError(
    string message,
    string source,
    int batchNumber,
    bool isInSiteException
)
Visual C++
public:
static void LogAndEmailError(
    String^ message,
    String^ source,
    int batchNumber,
    bool isInSiteException
)
JavaScript
InSite.Domain.ErrorHandler.logAndEmailError = function(message, source, batchNumber, isInSiteException);

Parameters

message
Type: System..::.String
source
Type: System..::.String
batchNumber
Type: System..::.Int32
isInSiteException
Type: System..::.Boolean

See Also

ErrorHandler Class
LogAndEmailError Overload
InSite.Domain Namespace


FlexLoginCommand Class

[image]

.NET Framework Class Library
FlexLoginCommand Class
Members See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class FlexLoginCommand _
    Inherits GenericLoginCommand
C#
public class FlexLoginCommand : GenericLoginCommand
Visual C++
public ref class FlexLoginCommand : public GenericLoginCommand
JavaScript
InSite.Domain.FlexLoginCommand = function();

Type.createClass(
    'InSite.Domain.FlexLoginCommand',
    FluorineFx.Security.GenericLoginCommand);

Inheritance Hierarchy

System..::.Object
GenericLoginCommand
InSite.Domain..::.FlexLoginCommand

See Also

FlexLoginCommand Members
InSite.Domain Namespace


FlexLoginCommand Members

[image] [image]

.NET Framework Class Library
FlexLoginCommand Members
FlexLoginCommand Class Constructors Methods See Also Send Feedback

The FlexLoginCommand type exposes the following members.

Constructors

Name | Description
FlexLoginCommand |

Methods

Name | Description
DoAuthentication | (Overrides GenericLoginCommandDoAuthentication(String, Hashtable).)
DoAuthorization | (Inherited from GenericLoginCommand.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Logout | (Inherited from GenericLoginCommand.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Start | (Inherited from GenericLoginCommand.)
Stop | (Inherited from GenericLoginCommand.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexLoginCommand Class
InSite.Domain Namespace


FlexLoginCommand Constructor

[image]

.NET Framework Class Library
FlexLoginCommand Constructor
FlexLoginCommand Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlexLoginCommand()
Visual C++
public:
FlexLoginCommand()
JavaScript
InSite.Domain.FlexLoginCommand = function();

See Also

FlexLoginCommand Class
InSite.Domain Namespace


FlexLoginCommand Methods

[image] [image]

.NET Framework Class Library
FlexLoginCommand Methods
FlexLoginCommand Class See Also Send Feedback

The FlexLoginCommand type exposes the following members.

Methods

Name | Description
DoAuthentication | (Overrides GenericLoginCommandDoAuthentication(String, Hashtable).)
DoAuthorization | (Inherited from GenericLoginCommand.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Logout | (Inherited from GenericLoginCommand.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Start | (Inherited from GenericLoginCommand.)
Stop | (Inherited from GenericLoginCommand.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexLoginCommand Class
InSite.Domain Namespace


DoAuthentication Method

[image]

.NET Framework Class Library
FlexLoginCommand..::.DoAuthentication Method
FlexLoginCommand Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function DoAuthentication ( _
    userName As String, _
    credentials As Hashtable _
) As IPrincipal
C#
public override IPrincipal DoAuthentication(
    string userName,
    Hashtable credentials
)
Visual C++
public:
virtual IPrincipal^ DoAuthentication(
    String^ userName,
    Hashtable^ credentials
) override
JavaScript
function doAuthentication(userName, credentials);

Parameters

userName
Type: System..::.String
credentials
Type: System.Collections..::.Hashtable

Implements

ILoginCommandDoAuthentication(String, Hashtable)

See Also

FlexLoginCommand Class
InSite.Domain Namespace


FlexLoginService Class

[image]

.NET Framework Class Library
FlexLoginService Class
Members See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<RemotingServiceAttribute> _
Public Class FlexLoginService
C#
[RemotingServiceAttribute]
public class FlexLoginService
Visual C++
[RemotingServiceAttribute]
public ref class FlexLoginService
JavaScript
InSite.Domain.FlexLoginService = function();

Type.createClass(
    'InSite.Domain.FlexLoginService');

Inheritance Hierarchy

System..::.Object
InSite.Domain..::.FlexLoginService

See Also

FlexLoginService Members
InSite.Domain Namespace


FlexLoginService Members

[image] [image]

.NET Framework Class Library
FlexLoginService Members
FlexLoginService Class Constructors Methods See Also Send Feedback

The FlexLoginService type exposes the following members.

Constructors

Name | Description
FlexLoginService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Login |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexLoginService Class
InSite.Domain Namespace


FlexLoginService Constructor

[image]

.NET Framework Class Library
FlexLoginService Constructor
FlexLoginService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlexLoginService()
Visual C++
public:
FlexLoginService()
JavaScript
InSite.Domain.FlexLoginService = function();

See Also

FlexLoginService Class
InSite.Domain Namespace


FlexLoginService Methods

[image] [image]

.NET Framework Class Library
FlexLoginService Methods
FlexLoginService Class See Also Send Feedback

The FlexLoginService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Login |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexLoginService Class
InSite.Domain Namespace


Login Method

[image]

.NET Framework Class Library
FlexLoginService..::.Login Method
FlexLoginService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Login ( _
    userName As String, _
    password As String _
) As UserProfile
C#
public virtual UserProfile Login(
    string userName,
    string password
)
Visual C++
public:
virtual UserProfile^ Login(
    String^ userName,
    String^ password
)
JavaScript
function login(userName, password);

Parameters

userName
Type: System..::.String
password
Type: System..::.String

See Also

FlexLoginService Class
InSite.Domain Namespace


FlexService Class

[image]

.NET Framework Class Library
FlexService Class
Members See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<RemotingServiceAttribute> _
Public Class FlexService
C#
[RemotingServiceAttribute]
public class FlexService
Visual C++
[RemotingServiceAttribute]
public ref class FlexService
JavaScript
InSite.Domain.FlexService = function();

Type.createClass(
    'InSite.Domain.FlexService');

Inheritance Hierarchy

System..::.Object
InSite.Domain..::.FlexService

See Also

FlexService Members
InSite.Domain Namespace


FlexService Members

[image] [image]

.NET Framework Class Library
FlexService Members
FlexService Class Constructors Methods See Also Send Feedback

The FlexService type exposes the following members.

Constructors

Name | Description
FlexService |

Methods

Name | Description
ChangePassword |
ChangePasswordQuestionAndAnswer |
CommitList |
CopyProduct |
CreateUser |
DeleteFile |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteRealTimeTask |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomerPriceCodes |
GetDashBoardData |
GetFileManager |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLicenses |
GetList |
GetPluginList |
GetProductPriceCategories |
GetProductPriceCodes |
GetProductPriceLines |
GetRoles |
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImportXLS |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshFromDB |
RegenerateApplicationDictionaries |
Register |
ResetPassword | Overloaded.
ScheduleTask |
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexService Class
InSite.Domain Namespace


FlexService Constructor

[image]

.NET Framework Class Library
FlexService Constructor
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlexService()
Visual C++
public:
FlexService()
JavaScript
InSite.Domain.FlexService = function();

See Also

FlexService Class
InSite.Domain Namespace


FlexService Methods

[image] [image]

.NET Framework Class Library
FlexService Methods
FlexService Class See Also Send Feedback

The FlexService type exposes the following members.

Methods

Name | Description
ChangePassword |
ChangePasswordQuestionAndAnswer |
CommitList |
CopyProduct |
CreateUser |
DeleteFile |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteRealTimeTask |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomerPriceCodes |
GetDashBoardData |
GetFileManager |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLicenses |
GetList |
GetPluginList |
GetProductPriceCategories |
GetProductPriceCodes |
GetProductPriceLines |
GetRoles |
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImportXLS |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshFromDB |
RegenerateApplicationDictionaries |
Register |
ResetPassword | Overloaded.
ScheduleTask |
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexService Class
InSite.Domain Namespace


ChangePassword Method

[image]

.NET Framework Class Library
FlexService..::.ChangePassword Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ChangePassword ( _
    userName As String, _
    oldPassword As String, _
    newPassword As String _
) As Boolean
C#
public virtual bool ChangePassword(
    string userName,
    string oldPassword,
    string newPassword
)
Visual C++
public:
virtual bool ChangePassword(
    String^ userName,
    String^ oldPassword,
    String^ newPassword
)
JavaScript
function changePassword(userName, oldPassword, newPassword);

Parameters

userName
Type: System..::.String
oldPassword
Type: System..::.String
newPassword
Type: System..::.String

See Also

FlexService Class
InSite.Domain Namespace


ChangePasswordQuestionAndAnswer Method

[image]

.NET Framework Class Library
FlexService..::.ChangePasswordQuestionAndAnswer Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ChangePasswordQuestionAndAnswer ( _
    userName As String, _
    password As String, _
    newPasswordQuestion As String, _
    newPasswordAnswer As String _
) As Boolean
C#
public virtual bool ChangePasswordQuestionAndAnswer(
    string userName,
    string password,
    string newPasswordQuestion,
    string newPasswordAnswer
)
Visual C++
public:
virtual bool ChangePasswordQuestionAndAnswer(
    String^ userName,
    String^ password,
    String^ newPasswordQuestion,
    String^ newPasswordAnswer
)
JavaScript
function changePasswordQuestionAndAnswer(userName, password, newPasswordQuestion, newPasswordAnswer);

Parameters

userName
Type: System..::.String
password
Type: System..::.String
newPasswordQuestion
Type: System..::.String
newPasswordAnswer
Type: System..::.String

See Also

FlexService Class
InSite.Domain Namespace


CommitList Method

[image]

.NET Framework Class Library
FlexService..::.CommitList Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CommitList ( _
    list As IList _
) As IList
C#
public virtual IList CommitList(
    IList list
)
Visual C++
public:
virtual IList^ CommitList(
    IList^ list
)
JavaScript
function commitList(list);

Parameters

list
Type: System.Collections..::.IList

See Also

FlexService Class
InSite.Domain Namespace


CopyProduct Method

[image]

.NET Framework Class Library
FlexService..::.CopyProduct Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CopyProduct ( _
    product As Product _
) As Product
C#
public virtual Product CopyProduct(
    Product product
)
Visual C++
public:
virtual Product^ CopyProduct(
    Product^ product
)
JavaScript
function copyProduct(product);

Parameters

product
Type: InSite.Model..::.Product

See Also

FlexService Class
InSite.Domain Namespace


CreateUser Method

[image]

.NET Framework Class Library
FlexService..::.CreateUser Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CreateUser ( _
    userName As String, _
    password As String, _
    email As String, _
    isApproved As Boolean _
) As UserProfile
C#
public virtual UserProfile CreateUser(
    string userName,
    string password,
    string email,
    bool isApproved
)
Visual C++
public:
virtual UserProfile^ CreateUser(
    String^ userName,
    String^ password,
    String^ email,
    bool isApproved
)
JavaScript
function createUser(userName, password, email, isApproved);

Parameters

userName
Type: System..::.String
password
Type: System..::.String
email
Type: System..::.String
isApproved
Type: System..::.Boolean

See Also

FlexService Class
InSite.Domain Namespace


DeleteFile Method

[image]

.NET Framework Class Library
FlexService..::.DeleteFile Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DeleteFile ( _
    fullPathToFile As String _
) As String
C#
public virtual string DeleteFile(
    string fullPathToFile
)
Visual C++
public:
virtual String^ DeleteFile(
    String^ fullPathToFile
)
JavaScript
function deleteFile(fullPathToFile);

Parameters

fullPathToFile
Type: System..::.String

See Also

FlexService Class
InSite.Domain Namespace


ExecuteRealTimeTask Method

[image]

.NET Framework Class Library
FlexService..::.ExecuteRealTimeTask Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ExecuteRealTimeTask ( _
    taskType As String, _
    parameter As String _
)
C#
public virtual void ExecuteRealTimeTask(
    string taskType,
    string parameter
)
Visual C++
public:
virtual void ExecuteRealTimeTask(
    String^ taskType,
    String^ parameter
)
JavaScript
function executeRealTimeTask(taskType, parameter);

Parameters

taskType
Type: System..::.String
parameter
Type: System..::.String

See Also

FlexService Class
InSite.Domain Namespace


GetCustomerPriceCodes Method

[image]

.NET Framework Class Library
FlexService..::.GetCustomerPriceCodes Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCustomerPriceCodes As String
C#
public virtual string GetCustomerPriceCodes()
Visual C++
public:
virtual String^ GetCustomerPriceCodes()
JavaScript
function getCustomerPriceCodes();

See Also

FlexService Class
InSite.Domain Namespace


GetDashBoardData Method

[image]

.NET Framework Class Library
FlexService..::.GetDashBoardData Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDashBoardData ( _
    name As String _
) As String
C#
public virtual string GetDashBoardData(
    string name
)
Visual C++
public:
virtual String^ GetDashBoardData(
    String^ name
)
JavaScript
function getDashBoardData(name);

Parameters

name
Type: System..::.String

See Also

FlexService Class
InSite.Domain Namespace


GetFileManager Method

[image]

.NET Framework Class Library
FlexService..::.GetFileManager Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetFileManager As String
C#
public virtual string GetFileManager()
Visual C++
public:
virtual String^ GetFileManager()
JavaScript
function getFileManager();

See Also

FlexService Class
InSite.Domain Namespace


GetLicenses Method

[image]

.NET Framework Class Library
FlexService..::.GetLicenses Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetLicenses As IList
C#
public virtual IList GetLicenses()
Visual C++
public:
virtual IList^ GetLicenses()
JavaScript
function getLicenses();

See Also

FlexService Class
InSite.Domain Namespace


GetList Method

[image]

.NET Framework Class Library
FlexService..::.GetList Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetList ( _
    filter As SOAFilterObject, _
    startRow As Integer, _
    pageSize As Integer _
) As IList
C#
public virtual IList GetList(
    SOAFilterObject filter,
    int startRow,
    int pageSize
)
Visual C++
public:
virtual IList^ GetList(
    SOAFilterObject^ filter,
    int startRow,
    int pageSize
)
JavaScript
function getList(filter, startRow, pageSize);

Parameters

filter
Type: InSite.Model..::.SOAFilterObject
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

FlexService Class
InSite.Domain Namespace


GetPluginList Method

[image]

.NET Framework Class Library
FlexService..::.GetPluginList Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPluginList As String
C#
public virtual string GetPluginList()
Visual C++
public:
virtual String^ GetPluginList()
JavaScript
function getPluginList();

See Also

FlexService Class
InSite.Domain Namespace


GetProductPriceCategories Method

[image]

.NET Framework Class Library
FlexService..::.GetProductPriceCategories Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProductPriceCategories As String
C#
public virtual string GetProductPriceCategories()
Visual C++
public:
virtual String^ GetProductPriceCategories()
JavaScript
function getProductPriceCategories();

See Also

FlexService Class
InSite.Domain Namespace


GetProductPriceCodes Method

[image]

.NET Framework Class Library
FlexService..::.GetProductPriceCodes Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProductPriceCodes As String
C#
public virtual string GetProductPriceCodes()
Visual C++
public:
virtual String^ GetProductPriceCodes()
JavaScript
function getProductPriceCodes();

See Also

FlexService Class
InSite.Domain Namespace


GetProductPriceLines Method

[image]

.NET Framework Class Library
FlexService..::.GetProductPriceLines Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProductPriceLines As String
C#
public virtual string GetProductPriceLines()
Visual C++
public:
virtual String^ GetProductPriceLines()
JavaScript
function getProductPriceLines();

See Also

FlexService Class
InSite.Domain Namespace


GetRoles Method

[image]

.NET Framework Class Library
FlexService..::.GetRoles Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRoles As IList
C#
public virtual IList GetRoles()
Visual C++
public:
virtual IList^ GetRoles()
JavaScript
function getRoles();

See Also

FlexService Class
InSite.Domain Namespace


ImportXLS Method

[image]

.NET Framework Class Library
FlexService..::.ImportXLS Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ImportXLS ( _
    fileName As String, _
    objectName As String _
) As IList
C#
public virtual IList ImportXLS(
    string fileName,
    string objectName
)
Visual C++
public:
virtual IList^ ImportXLS(
    String^ fileName,
    String^ objectName
)
JavaScript
function importXLS(fileName, objectName);

Parameters

fileName
Type: System..::.String
objectName
Type: System..::.String

See Also

FlexService Class
InSite.Domain Namespace


RefreshFromDB Method

[image]

.NET Framework Class Library
FlexService..::.RefreshFromDB Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function RefreshFromDB ( _
    obj As Object _
) As Object
C#
public virtual Object RefreshFromDB(
    Object obj
)
Visual C++
public:
virtual Object^ RefreshFromDB(
    Object^ obj
)
JavaScript
function refreshFromDB(obj);

Parameters

obj
Type: System..::.Object

See Also

FlexService Class
InSite.Domain Namespace


RegenerateApplicationDictionaries Method

[image]

.NET Framework Class Library
FlexService..::.RegenerateApplicationDictionaries Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegenerateApplicationDictionaries
C#
public virtual void RegenerateApplicationDictionaries()
Visual C++
public:
virtual void RegenerateApplicationDictionaries()
JavaScript
function regenerateApplicationDictionaries();

See Also

FlexService Class
InSite.Domain Namespace


Register Method

[image]

.NET Framework Class Library
FlexService..::.Register Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Register ( _
    customerId As String, _
    contactName As String, _
    contactPhone As String, _
    contactEmail As String, _
    companyName As String _
) As IList
C#
public virtual IList Register(
    string customerId,
    string contactName,
    string contactPhone,
    string contactEmail,
    string companyName
)
Visual C++
public:
virtual IList^ Register(
    String^ customerId,
    String^ contactName,
    String^ contactPhone,
    String^ contactEmail,
    String^ companyName
)
JavaScript
function register(customerId, contactName, contactPhone, contactEmail, companyName);

Parameters

customerId
Type: System..::.String
contactName
Type: System..::.String
contactPhone
Type: System..::.String
contactEmail
Type: System..::.String
companyName
Type: System..::.String

See Also

FlexService Class
InSite.Domain Namespace


ResetPassword Method

[image] [image]

.NET Framework Class Library
FlexService..::.ResetPassword Method
FlexService Class See Also Send Feedback

Overload List

Name | Description
ResetPassword(String) |
ResetPassword(String, String) |

See Also

FlexService Class
FlexService Members
InSite.Domain Namespace


ResetPassword Method (String)

[image]

.NET Framework Class Library
FlexService..::.ResetPassword Method (String)
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResetPassword ( _
    userName As String _
) As String
C#
public virtual string ResetPassword(
    string userName
)
Visual C++
public:
virtual String^ ResetPassword(
    String^ userName
)
JavaScript
function resetPassword(userName);

Parameters

userName
Type: System..::.String

See Also

FlexService Class
ResetPassword Overload
InSite.Domain Namespace


ResetPassword Method (String, String)

[image]

.NET Framework Class Library
FlexService..::.ResetPassword Method (String, String)
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResetPassword ( _
    userName As String, _
    passwordAnswer As String _
) As String
C#
public virtual string ResetPassword(
    string userName,
    string passwordAnswer
)
Visual C++
public:
virtual String^ ResetPassword(
    String^ userName,
    String^ passwordAnswer
)
JavaScript
function resetPassword(userName, passwordAnswer);

Parameters

userName
Type: System..::.String
passwordAnswer
Type: System..::.String

See Also

FlexService Class
ResetPassword Overload
InSite.Domain Namespace


ScheduleTask Method

[image]

.NET Framework Class Library
FlexService..::.ScheduleTask Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ScheduleTask ( _
    taskType As String, _
    parameter As String, _
    runDateTime As DateTime, _
    minuteInterval As Integer _
)
C#
public virtual void ScheduleTask(
    string taskType,
    string parameter,
    DateTime runDateTime,
    int minuteInterval
)
Visual C++
public:
virtual void ScheduleTask(
    String^ taskType,
    String^ parameter,
    DateTime runDateTime,
    int minuteInterval
)
JavaScript
function scheduleTask(taskType, parameter, runDateTime, minuteInterval);

Parameters

taskType
Type: System..::.String
parameter
Type: System..::.String
runDateTime
Type: System..::.DateTime
minuteInterval
Type: System..::.Int32

See Also

FlexService Class
InSite.Domain Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
FlexService..::.SubmitTransaction Method
FlexService Class See Also Send Feedback

Namespace: InSite.Domain
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function SubmitTransaction ( _
    transactionType As String, _
    creditCard As CreditCard _
) As CreditCardTransaction
C#
public virtual CreditCardTransaction SubmitTransaction(
    string transactionType,
    CreditCard creditCard
)
Visual C++
public:
virtual CreditCardTransaction^ SubmitTransaction(
    String^ transactionType,
    CreditCard^ creditCard
)
JavaScript
function submitTransaction(transactionType, creditCard);

Parameters

transactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard

See Also

FlexService Class
InSite.Domain Namespace


InSite.Domain.AuthorizeNetCIM Namespace

[image]

.NET Framework Class Library
InSite.Domain.AuthorizeNetCIM Namespace
Send Feedback

Classes

Class | Description
AuthorizeNetCIMException |
AuthorizeNetCIMProcessor |


AuthorizeNetCIMException Class

[image]

.NET Framework Class Library
AuthorizeNetCIMException Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class AuthorizeNetCIMException _
    Inherits Exception
C#
public class AuthorizeNetCIMException : Exception
Visual C++
public ref class AuthorizeNetCIMException : public Exception
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMException = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Domain.AuthorizeNetCIM..::.AuthorizeNetCIMException

See Also

AuthorizeNetCIMException Members
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMException Members

[image] [image]

.NET Framework Class Library
AuthorizeNetCIMException Members
AuthorizeNetCIMException Class Constructors Methods Properties See Also Send Feedback

The AuthorizeNetCIMException type exposes the following members.

Constructors

Name | Description
AuthorizeNetCIMException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AuthorizeNetCIMException Class
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMException Constructor

[image]

.NET Framework Class Library
AuthorizeNetCIMException Constructor
AuthorizeNetCIMException Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public AuthorizeNetCIMException(
    string message
)
Visual C++
public:
AuthorizeNetCIMException(
    String^ message
)
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMException = function(message);

Parameters

message
Type: System..::.String

See Also

AuthorizeNetCIMException Class
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMException Methods

[image] [image]

.NET Framework Class Library
AuthorizeNetCIMException Methods
AuthorizeNetCIMException Class See Also Send Feedback

The AuthorizeNetCIMException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AuthorizeNetCIMException Class
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMException Properties

[image] [image]

.NET Framework Class Library
AuthorizeNetCIMException Properties
AuthorizeNetCIMException Class See Also Send Feedback

The AuthorizeNetCIMException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AuthorizeNetCIMException Class
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMProcessor Class

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class AuthorizeNetCIMProcessor
C#
public class AuthorizeNetCIMProcessor
Visual C++
public ref class AuthorizeNetCIMProcessor
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor');

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIM..::.AuthorizeNetCIMProcessor

See Also

AuthorizeNetCIMProcessor Members
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMProcessor Members

[image] [image]

.NET Framework Class Library
AuthorizeNetCIMProcessor Members
AuthorizeNetCIMProcessor Class Constructors Methods Fields Properties See Also Send Feedback

The AuthorizeNetCIMProcessor type exposes the following members.

Constructors

Name | Description
AuthorizeNetCIMProcessor |

Methods

Name | Description
CreateAuthorizationTransaction |
CreateCustomerPaymentProfile |
CreateSaleTransaction | Overloaded.
DeleteCustomerPaymentProfile |
DeleteCustomerProfile |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomerProfileId |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLastPaymentProfileId |
GetPaymentProfiles |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveDownCustomerPaymentProfile |
MoveUpCustomerPaymentProfile |
SaveCustomerPaymentProfile |
SaveCustomerProfile |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCustomerPaymentProfile |

Fields

Name | Description
CUSTOMER_PAYMENT_PROFILE_EXPDATE |
CUSTOMER_PAYMENT_PROFILE_KEY |
CUSTOMER_PAYMENT_PROFILE_TYPE |
CUSTOMER_PROFILE_KEY |
RESULT_DUPLICATE_RECORD |
RESULT_INVALID_CARD |
RESULT_INVALID_TRANSACTION |

Properties

Name | Description
CIMService |
Delimiter |
MerchantAuthentication |

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMProcessor Constructor

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor Constructor
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AuthorizeNetCIMProcessor()
Visual C++
public:
AuthorizeNetCIMProcessor()
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor = function();

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMProcessor Fields

[image] [image]

.NET Framework Class Library
AuthorizeNetCIMProcessor Fields
AuthorizeNetCIMProcessor Class See Also Send Feedback

The AuthorizeNetCIMProcessor type exposes the following members.

Fields

Name | Description
CUSTOMER_PAYMENT_PROFILE_EXPDATE |
CUSTOMER_PAYMENT_PROFILE_KEY |
CUSTOMER_PAYMENT_PROFILE_TYPE |
CUSTOMER_PROFILE_KEY |
RESULT_DUPLICATE_RECORD |
RESULT_INVALID_CARD |
RESULT_INVALID_TRANSACTION |

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


CUSTOMER_PAYMENT_PROFILE_EXPDATE Field

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CUSTOMER_PAYMENT_PROFILE_EXPDATE Field
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Const CUSTOMER_PAYMENT_PROFILE_EXPDATE As String
C#
public const string CUSTOMER_PAYMENT_PROFILE_EXPDATE
Visual C++
public:
literal String^ CUSTOMER_PAYMENT_PROFILE_EXPDATE
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor.customeR_PAYMENT_PROFILE_EXPDATE

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


CUSTOMER_PAYMENT_PROFILE_KEY Field

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CUSTOMER_PAYMENT_PROFILE_KEY Field
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Const CUSTOMER_PAYMENT_PROFILE_KEY As String
C#
public const string CUSTOMER_PAYMENT_PROFILE_KEY
Visual C++
public:
literal String^ CUSTOMER_PAYMENT_PROFILE_KEY
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor.customeR_PAYMENT_PROFILE_KEY

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


CUSTOMER_PAYMENT_PROFILE_TYPE Field

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CUSTOMER_PAYMENT_PROFILE_TYPE Field
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Const CUSTOMER_PAYMENT_PROFILE_TYPE As String
C#
public const string CUSTOMER_PAYMENT_PROFILE_TYPE
Visual C++
public:
literal String^ CUSTOMER_PAYMENT_PROFILE_TYPE
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor.customeR_PAYMENT_PROFILE_TYPE

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


CUSTOMER_PROFILE_KEY Field

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CUSTOMER_PROFILE_KEY Field
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Const CUSTOMER_PROFILE_KEY As String
C#
public const string CUSTOMER_PROFILE_KEY
Visual C++
public:
literal String^ CUSTOMER_PROFILE_KEY
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor.customeR_PROFILE_KEY

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


RESULT_DUPLICATE_RECORD Field

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.RESULT_DUPLICATE_RECORD Field
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Const RESULT_DUPLICATE_RECORD As String
C#
public const string RESULT_DUPLICATE_RECORD
Visual C++
public:
literal String^ RESULT_DUPLICATE_RECORD
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor.resulT_DUPLICATE_RECORD

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


RESULT_INVALID_CARD Field

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.RESULT_INVALID_CARD Field
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Const RESULT_INVALID_CARD As String
C#
public const string RESULT_INVALID_CARD
Visual C++
public:
literal String^ RESULT_INVALID_CARD
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor.resulT_INVALID_CARD

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


RESULT_INVALID_TRANSACTION Field

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.RESULT_INVALID_TRANSACTION Field
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Const RESULT_INVALID_TRANSACTION As String
C#
public const string RESULT_INVALID_TRANSACTION
Visual C++
public:
literal String^ RESULT_INVALID_TRANSACTION
JavaScript
InSite.Domain.AuthorizeNetCIM.AuthorizeNetCIMProcessor.resulT_INVALID_TRANSACTION

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMProcessor Methods

[image] [image]

.NET Framework Class Library
AuthorizeNetCIMProcessor Methods
AuthorizeNetCIMProcessor Class See Also Send Feedback

The AuthorizeNetCIMProcessor type exposes the following members.

Methods

Name | Description
CreateAuthorizationTransaction |
CreateCustomerPaymentProfile |
CreateSaleTransaction | Overloaded.
DeleteCustomerPaymentProfile |
DeleteCustomerProfile |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomerProfileId |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLastPaymentProfileId |
GetPaymentProfiles |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveDownCustomerPaymentProfile |
MoveUpCustomerPaymentProfile |
SaveCustomerPaymentProfile |
SaveCustomerProfile |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateCustomerPaymentProfile |

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


CreateAuthorizationTransaction Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CreateAuthorizationTransaction Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateAuthorizationTransaction ( _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction CreateAuthorizationTransaction(
    CustomerOrder customerOrder
)
Visual C++
public:
CreditCardTransaction^ CreateAuthorizationTransaction(
    CustomerOrder^ customerOrder
)
JavaScript
function createAuthorizationTransaction(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


CreateCustomerPaymentProfile Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CreateCustomerPaymentProfile Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateCustomerPaymentProfile ( _
    customer As Customer, _
    creditCard As CreditCard _
) As String
C#
public string CreateCustomerPaymentProfile(
    Customer customer,
    CreditCard creditCard
)
Visual C++
public:
String^ CreateCustomerPaymentProfile(
    Customer^ customer,
    CreditCard^ creditCard
)
JavaScript
function createCustomerPaymentProfile(customer, creditCard);

Parameters

customer
Type: InSite.Model..::.Customer
creditCard
Type: InSite.Model..::.CreditCard

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


CreateSaleTransaction Method

[image] [image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CreateSaleTransaction Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Overload List

Name | Description
CreateSaleTransaction(CustomerOrder) |
CreateSaleTransaction(String, Decimal, String, String) |

See Also

AuthorizeNetCIMProcessor Class
AuthorizeNetCIMProcessor Members
InSite.Domain.AuthorizeNetCIM Namespace


CreateSaleTransaction Method (CustomerOrder)

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CreateSaleTransaction Method (CustomerOrder)
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSaleTransaction ( _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction CreateSaleTransaction(
    CustomerOrder customerOrder
)
Visual C++
public:
CreditCardTransaction^ CreateSaleTransaction(
    CustomerOrder^ customerOrder
)
JavaScript
function createSaleTransaction(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

AuthorizeNetCIMProcessor Class
CreateSaleTransaction Overload
InSite.Domain.AuthorizeNetCIM Namespace


CreateSaleTransaction Method (String, Decimal, String, String)

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CreateSaleTransaction Method (String, Decimal, String, String)
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateSaleTransaction ( _
    customerProfileId As String, _
    amount As Decimal, _
    orderNumber As String, _
    shipmentNumber As String _
) As CreditCardTransaction
C#
public CreditCardTransaction CreateSaleTransaction(
    string customerProfileId,
    decimal amount,
    string orderNumber,
    string shipmentNumber
)
Visual C++
public:
CreditCardTransaction^ CreateSaleTransaction(
    String^ customerProfileId,
    Decimal amount,
    String^ orderNumber,
    String^ shipmentNumber
)
JavaScript
function createSaleTransaction(customerProfileId, amount, orderNumber, shipmentNumber);

Parameters

customerProfileId
Type: System..::.String
amount
Type: System..::.Decimal
orderNumber
Type: System..::.String
shipmentNumber
Type: System..::.String

See Also

AuthorizeNetCIMProcessor Class
CreateSaleTransaction Overload
InSite.Domain.AuthorizeNetCIM Namespace


DeleteCustomerPaymentProfile Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.DeleteCustomerPaymentProfile Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteCustomerPaymentProfile ( _
    customer As Customer, _
    paymentProfileId As String _
)
C#
public void DeleteCustomerPaymentProfile(
    Customer customer,
    string paymentProfileId
)
Visual C++
public:
void DeleteCustomerPaymentProfile(
    Customer^ customer,
    String^ paymentProfileId
)
JavaScript
function deleteCustomerPaymentProfile(customer, paymentProfileId);

Parameters

customer
Type: InSite.Model..::.Customer
paymentProfileId
Type: System..::.String

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


DeleteCustomerProfile Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.DeleteCustomerProfile Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteCustomerProfile ( _
    customer As Customer _
)
C#
public void DeleteCustomerProfile(
    Customer customer
)
Visual C++
public:
void DeleteCustomerProfile(
    Customer^ customer
)
JavaScript
function deleteCustomerProfile(customer);

Parameters

customer
Type: InSite.Model..::.Customer

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


GetCustomerProfileId Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.GetCustomerProfileId Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCustomerProfileId ( _
    customer As Customer _
) As Integer
C#
public int GetCustomerProfileId(
    Customer customer
)
Visual C++
public:
int GetCustomerProfileId(
    Customer^ customer
)
JavaScript
function getCustomerProfileId(customer);

Parameters

customer
Type: InSite.Model..::.Customer

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


GetLastPaymentProfileId Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.GetLastPaymentProfileId Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLastPaymentProfileId ( _
    customer As Customer _
) As String
C#
public string GetLastPaymentProfileId(
    Customer customer
)
Visual C++
public:
String^ GetLastPaymentProfileId(
    Customer^ customer
)
JavaScript
function getLastPaymentProfileId(customer);

Parameters

customer
Type: InSite.Model..::.Customer

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


GetPaymentProfiles Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.GetPaymentProfiles Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPaymentProfiles ( _
    customer As Customer _
) As List(Of CreditCard)
C#
public List<CreditCard> GetPaymentProfiles(
    Customer customer
)
Visual C++
public:
List<CreditCard^>^ GetPaymentProfiles(
    Customer^ customer
)
JavaScript
function getPaymentProfiles(customer);

Parameters

customer
Type: InSite.Model..::.Customer

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


MoveDownCustomerPaymentProfile Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.MoveDownCustomerPaymentProfile Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub MoveDownCustomerPaymentProfile ( _
    customer As Customer, _
    paymentProfileId As String _
)
C#
public void MoveDownCustomerPaymentProfile(
    Customer customer,
    string paymentProfileId
)
Visual C++
public:
void MoveDownCustomerPaymentProfile(
    Customer^ customer,
    String^ paymentProfileId
)
JavaScript
function moveDownCustomerPaymentProfile(customer, paymentProfileId);

Parameters

customer
Type: InSite.Model..::.Customer
paymentProfileId
Type: System..::.String

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


MoveUpCustomerPaymentProfile Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.MoveUpCustomerPaymentProfile Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub MoveUpCustomerPaymentProfile ( _
    customer As Customer, _
    paymentProfileId As String _
)
C#
public void MoveUpCustomerPaymentProfile(
    Customer customer,
    string paymentProfileId
)
Visual C++
public:
void MoveUpCustomerPaymentProfile(
    Customer^ customer,
    String^ paymentProfileId
)
JavaScript
function moveUpCustomerPaymentProfile(customer, paymentProfileId);

Parameters

customer
Type: InSite.Model..::.Customer
paymentProfileId
Type: System..::.String

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


SaveCustomerPaymentProfile Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.SaveCustomerPaymentProfile Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SaveCustomerPaymentProfile ( _
    customer As Customer, _
    creditCard As CreditCard _
) As String
C#
public string SaveCustomerPaymentProfile(
    Customer customer,
    CreditCard creditCard
)
Visual C++
public:
String^ SaveCustomerPaymentProfile(
    Customer^ customer,
    CreditCard^ creditCard
)
JavaScript
function saveCustomerPaymentProfile(customer, creditCard);

Parameters

customer
Type: InSite.Model..::.Customer
creditCard
Type: InSite.Model..::.CreditCard

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


SaveCustomerProfile Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.SaveCustomerProfile Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SaveCustomerProfile ( _
    customer As Customer _
)
C#
public void SaveCustomerProfile(
    Customer customer
)
Visual C++
public:
void SaveCustomerProfile(
    Customer^ customer
)
JavaScript
function saveCustomerProfile(customer);

Parameters

customer
Type: InSite.Model..::.Customer

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


UpdateCustomerPaymentProfile Method

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.UpdateCustomerPaymentProfile Method
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function UpdateCustomerPaymentProfile ( _
    customer As Customer, _
    creditCard As CreditCard _
) As String
C#
public string UpdateCustomerPaymentProfile(
    Customer customer,
    CreditCard creditCard
)
Visual C++
public:
String^ UpdateCustomerPaymentProfile(
    Customer^ customer,
    CreditCard^ creditCard
)
JavaScript
function updateCustomerPaymentProfile(customer, creditCard);

Parameters

customer
Type: InSite.Model..::.Customer
creditCard
Type: InSite.Model..::.CreditCard

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


AuthorizeNetCIMProcessor Properties

[image] [image]

.NET Framework Class Library
AuthorizeNetCIMProcessor Properties
AuthorizeNetCIMProcessor Class See Also Send Feedback

The AuthorizeNetCIMProcessor type exposes the following members.

Properties

Name | Description
CIMService |
Delimiter |
MerchantAuthentication |

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


CIMService Property

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.CIMService Property
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CIMService As Service
C#
public Service CIMService { get; }
Visual C++
public:
property Service^ CIMService {
    Service^ get ();
}
JavaScript
function get_cimService();

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


Delimiter Property

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.Delimiter Property
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delimiter As Char
C#
public char Delimiter { get; }
Visual C++
public:
property wchar_t Delimiter {
    wchar_t get ();
}
JavaScript
function get_delimiter();

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


MerchantAuthentication Property

[image]

.NET Framework Class Library
AuthorizeNetCIMProcessor..::.MerchantAuthentication Property
AuthorizeNetCIMProcessor Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIM
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MerchantAuthentication As MerchantAuthenticationType
C#
public MerchantAuthenticationType MerchantAuthentication { get; }
Visual C++
public:
property MerchantAuthenticationType^ MerchantAuthentication {
    MerchantAuthenticationType^ get ();
}
JavaScript
function get_merchantAuthentication();

See Also

AuthorizeNetCIMProcessor Class
InSite.Domain.AuthorizeNetCIM Namespace


InSite.Domain.AuthorizeNetCIMService Namespace

[image]

.NET Framework Class Library
InSite.Domain.AuthorizeNetCIMService Namespace
Send Feedback

Classes

Class | Description
ANetApiResponseType |
ARBCancelSubscriptionCompletedEventArgs |
ARBCancelSubscriptionResponseType |
ARBCreateSubscriptionCompletedEventArgs |
ARBCreateSubscriptionResponseType |
ARBSubscriptionType |
ARBUpdateSubscriptionCompletedEventArgs |
ARBUpdateSubscriptionResponseType |
AuthenticateTestCompletedEventArgs |
BankAccountBaseType |
BankAccountMaskedType |
BankAccountType |
CreateCustomerPaymentProfileCompletedEventArgs |
CreateCustomerPaymentProfileResponseType |
CreateCustomerProfileCompletedEventArgs |
CreateCustomerProfileResponseType |
CreateCustomerProfileTransactionCompletedEventArgs |
CreateCustomerProfileTransactionResponseType |
CreateCustomerShippingAddressCompletedEventArgs |
CreateCustomerShippingAddressResponseType |
CreditCardMaskedType |
CreditCardSimpleType |
CreditCardType |
CustomerAddressExType |
CustomerAddressType |
CustomerPaymentProfileBaseType |
CustomerPaymentProfileExType |
CustomerPaymentProfileMaskedType |
CustomerPaymentProfileType |
CustomerProfileBaseType |
CustomerProfileExType |
CustomerProfileMaskedType |
CustomerProfileType |
CustomerType |
DeleteCustomerPaymentProfileCompletedEventArgs |
DeleteCustomerPaymentProfileResponseType |
DeleteCustomerProfileCompletedEventArgs |
DeleteCustomerProfileResponseType |
DeleteCustomerShippingAddressCompletedEventArgs |
DeleteCustomerShippingAddressResponseType |
DriversLicenseBaseType |
DriversLicenseMaskedType |
DriversLicenseType |
ExtendedAmountType |
GetCustomerPaymentProfileCompletedEventArgs |
GetCustomerPaymentProfileResponseType |
GetCustomerProfileCompletedEventArgs |
GetCustomerProfileResponseType |
GetCustomerShippingAddressCompletedEventArgs |
GetCustomerShippingAddressResponseType |
IsAliveCompletedEventArgs |
LineItemType |
MerchantAuthenticationType |
MessagesTypeMessage |
NameAndAddressType |
OrderExType |
OrderType |
PaymentMaskedType |
PaymentScheduleType |
PaymentScheduleTypeInterval |
PaymentSimpleType |
PaymentType |
ProfileTransactionType |
ProfileTransAmountType |
ProfileTransAuthCaptureType |
ProfileTransAuthOnlyType |
ProfileTransCaptureOnlyType |
ProfileTransOrderType |
Service |
UpdateCustomerPaymentProfileCompletedEventArgs |
UpdateCustomerPaymentProfileResponseType |
UpdateCustomerProfileCompletedEventArgs |
UpdateCustomerProfileResponseType |
UpdateCustomerShippingAddressCompletedEventArgs |
UpdateCustomerShippingAddressResponseType |
ValidateCustomerPaymentProfileCompletedEventArgs |
ValidateCustomerPaymentProfileResponseType |

Delegates

Delegate | Description
ARBCancelSubscriptionCompletedEventHandler |
ARBCreateSubscriptionCompletedEventHandler |
ARBUpdateSubscriptionCompletedEventHandler |
AuthenticateTestCompletedEventHandler |
CreateCustomerPaymentProfileCompletedEventHandler |
CreateCustomerProfileCompletedEventHandler |
CreateCustomerProfileTransactionCompletedEventHandler |
CreateCustomerShippingAddressCompletedEventHandler |
DeleteCustomerPaymentProfileCompletedEventHandler |
DeleteCustomerProfileCompletedEventHandler |
DeleteCustomerShippingAddressCompletedEventHandler |
GetCustomerPaymentProfileCompletedEventHandler |
GetCustomerProfileCompletedEventHandler |
GetCustomerShippingAddressCompletedEventHandler |
IsAliveCompletedEventHandler |
UpdateCustomerPaymentProfileCompletedEventHandler |
UpdateCustomerProfileCompletedEventHandler |
UpdateCustomerShippingAddressCompletedEventHandler |
ValidateCustomerPaymentProfileCompletedEventHandler |

Enumerations

Enumeration | Description
ARBSubscriptionUnitEnum |
BankAccountTypeEnum |
CustomerTypeEnum |
EcheckTypeEnum |
MessageTypeEnum |
ValidationModeEnum |


ANetApiResponseType Class

[image]

.NET Framework Class Library
ANetApiResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.ARBCancelSubscriptionResponseType
InSite.Domain.AuthorizeNetCIMService..::.ARBCreateSubscriptionResponseType
InSite.Domain.AuthorizeNetCIMService..::.ARBUpdateSubscriptionResponseType
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerPaymentProfileResponseType
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerProfileResponseType
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerProfileTransactionResponseType
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerShippingAddressResponseType
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerPaymentProfileResponseType
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerProfileResponseType
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerShippingAddressResponseType
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerPaymentProfileResponseType
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerProfileResponseType
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerShippingAddressResponseType
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerPaymentProfileResponseType
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerProfileResponseType
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerShippingAddressResponseType
InSite.Domain.AuthorizeNetCIMService..::.ValidateCustomerPaymentProfileResponseType

See Also

ANetApiResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ANetApiResponseType Members

[image] [image]

.NET Framework Class Library
ANetApiResponseType Members
ANetApiResponseType Class Constructors Methods Properties See Also Send Feedback

The ANetApiResponseType type exposes the following members.

Constructors

Name | Description
ANetApiResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages |
resultCode |

See Also

ANetApiResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ANetApiResponseType Constructor

[image]

.NET Framework Class Library
ANetApiResponseType Constructor
ANetApiResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ANetApiResponseType()
Visual C++
public:
ANetApiResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType = function();

See Also

ANetApiResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ANetApiResponseType Methods

[image] [image]

.NET Framework Class Library
ANetApiResponseType Methods
ANetApiResponseType Class See Also Send Feedback

The ANetApiResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ANetApiResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ANetApiResponseType Properties

[image] [image]

.NET Framework Class Library
ANetApiResponseType Properties
ANetApiResponseType Class See Also Send Feedback

The ANetApiResponseType type exposes the following members.

Properties

Name | Description
messages |
resultCode |

See Also

ANetApiResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


messages Property

[image]

.NET Framework Class Library
ANetApiResponseType..::.messages Property
ANetApiResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property messages As MessagesTypeMessage()
C#
public MessagesTypeMessage[] messages { get; set; }
Visual C++
public:
property array<MessagesTypeMessage^>^ messages {
    array<MessagesTypeMessage^>^ get ();
    void set (array<MessagesTypeMessage^>^ value);
}
JavaScript
function get_messages();
function set_messages(value);

Remarks

See Also

ANetApiResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


resultCode Property

[image]

.NET Framework Class Library
ANetApiResponseType..::.resultCode Property
ANetApiResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property resultCode As MessageTypeEnum
C#
public MessageTypeEnum resultCode { get; set; }
Visual C++
public:
property MessageTypeEnum resultCode {
    MessageTypeEnum get ();
    void set (MessageTypeEnum value);
}
JavaScript
function get_resultCode();
function set_resultCode(value);

Remarks

See Also

ANetApiResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionCompletedEventArgs Class

[image]

.NET Framework Class Library
ARBCancelSubscriptionCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class ARBCancelSubscriptionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class ARBCancelSubscriptionCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class ARBCancelSubscriptionCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBCancelSubscriptionCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ARBCancelSubscriptionCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.ARBCancelSubscriptionCompletedEventArgs

See Also

ARBCancelSubscriptionCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
ARBCancelSubscriptionCompletedEventArgs Members
ARBCancelSubscriptionCompletedEventArgs Class Methods Properties See Also Send Feedback

The ARBCancelSubscriptionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ARBCancelSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
ARBCancelSubscriptionCompletedEventArgs Methods
ARBCancelSubscriptionCompletedEventArgs Class See Also Send Feedback

The ARBCancelSubscriptionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARBCancelSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
ARBCancelSubscriptionCompletedEventArgs Properties
ARBCancelSubscriptionCompletedEventArgs Class See Also Send Feedback

The ARBCancelSubscriptionCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ARBCancelSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
ARBCancelSubscriptionCompletedEventArgs..::.Result Property
ARBCancelSubscriptionCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As ARBCancelSubscriptionResponseType
C#
public ARBCancelSubscriptionResponseType Result { get; }
Visual C++
public:
property ARBCancelSubscriptionResponseType^ Result {
    ARBCancelSubscriptionResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

ARBCancelSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionCompletedEventHandler Delegate

[image]

.NET Framework Class Library
ARBCancelSubscriptionCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub ARBCancelSubscriptionCompletedEventHandler ( _
    sender As Object, _
    e As ARBCancelSubscriptionCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void ARBCancelSubscriptionCompletedEventHandler(
    Object sender,
    ARBCancelSubscriptionCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void ARBCancelSubscriptionCompletedEventHandler(
    Object^ sender,
    ARBCancelSubscriptionCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBCancelSubscriptionCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionResponseType Class

[image]

.NET Framework Class Library
ARBCancelSubscriptionResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ARBCancelSubscriptionResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ARBCancelSubscriptionResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ARBCancelSubscriptionResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBCancelSubscriptionResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ARBCancelSubscriptionResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.ARBCancelSubscriptionResponseType

See Also

ARBCancelSubscriptionResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionResponseType Members

[image] [image]

.NET Framework Class Library
ARBCancelSubscriptionResponseType Members
ARBCancelSubscriptionResponseType Class Constructors Methods Properties See Also Send Feedback

The ARBCancelSubscriptionResponseType type exposes the following members.

Constructors

Name | Description
ARBCancelSubscriptionResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

ARBCancelSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionResponseType Constructor

[image]

.NET Framework Class Library
ARBCancelSubscriptionResponseType Constructor
ARBCancelSubscriptionResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ARBCancelSubscriptionResponseType()
Visual C++
public:
ARBCancelSubscriptionResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBCancelSubscriptionResponseType = function();

See Also

ARBCancelSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionResponseType Methods

[image] [image]

.NET Framework Class Library
ARBCancelSubscriptionResponseType Methods
ARBCancelSubscriptionResponseType Class See Also Send Feedback

The ARBCancelSubscriptionResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARBCancelSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionResponseType Properties

[image] [image]

.NET Framework Class Library
ARBCancelSubscriptionResponseType Properties
ARBCancelSubscriptionResponseType Class See Also Send Feedback

The ARBCancelSubscriptionResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

ARBCancelSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionCompletedEventArgs Class

[image]

.NET Framework Class Library
ARBCreateSubscriptionCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class ARBCreateSubscriptionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class ARBCreateSubscriptionCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class ARBCreateSubscriptionCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBCreateSubscriptionCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ARBCreateSubscriptionCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.ARBCreateSubscriptionCompletedEventArgs

See Also

ARBCreateSubscriptionCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
ARBCreateSubscriptionCompletedEventArgs Members
ARBCreateSubscriptionCompletedEventArgs Class Methods Properties See Also Send Feedback

The ARBCreateSubscriptionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ARBCreateSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
ARBCreateSubscriptionCompletedEventArgs Methods
ARBCreateSubscriptionCompletedEventArgs Class See Also Send Feedback

The ARBCreateSubscriptionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARBCreateSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
ARBCreateSubscriptionCompletedEventArgs Properties
ARBCreateSubscriptionCompletedEventArgs Class See Also Send Feedback

The ARBCreateSubscriptionCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ARBCreateSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
ARBCreateSubscriptionCompletedEventArgs..::.Result Property
ARBCreateSubscriptionCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As ARBCreateSubscriptionResponseType
C#
public ARBCreateSubscriptionResponseType Result { get; }
Visual C++
public:
property ARBCreateSubscriptionResponseType^ Result {
    ARBCreateSubscriptionResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

ARBCreateSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionCompletedEventHandler Delegate

[image]

.NET Framework Class Library
ARBCreateSubscriptionCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub ARBCreateSubscriptionCompletedEventHandler ( _
    sender As Object, _
    e As ARBCreateSubscriptionCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void ARBCreateSubscriptionCompletedEventHandler(
    Object sender,
    ARBCreateSubscriptionCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void ARBCreateSubscriptionCompletedEventHandler(
    Object^ sender,
    ARBCreateSubscriptionCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBCreateSubscriptionCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionResponseType Class

[image]

.NET Framework Class Library
ARBCreateSubscriptionResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ARBCreateSubscriptionResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ARBCreateSubscriptionResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ARBCreateSubscriptionResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBCreateSubscriptionResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ARBCreateSubscriptionResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.ARBCreateSubscriptionResponseType

See Also

ARBCreateSubscriptionResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionResponseType Members

[image] [image]

.NET Framework Class Library
ARBCreateSubscriptionResponseType Members
ARBCreateSubscriptionResponseType Class Constructors Methods Properties See Also Send Feedback

The ARBCreateSubscriptionResponseType type exposes the following members.

Constructors

Name | Description
ARBCreateSubscriptionResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)
subscriptionId |

See Also

ARBCreateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionResponseType Constructor

[image]

.NET Framework Class Library
ARBCreateSubscriptionResponseType Constructor
ARBCreateSubscriptionResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ARBCreateSubscriptionResponseType()
Visual C++
public:
ARBCreateSubscriptionResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBCreateSubscriptionResponseType = function();

See Also

ARBCreateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionResponseType Methods

[image] [image]

.NET Framework Class Library
ARBCreateSubscriptionResponseType Methods
ARBCreateSubscriptionResponseType Class See Also Send Feedback

The ARBCreateSubscriptionResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARBCreateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionResponseType Properties

[image] [image]

.NET Framework Class Library
ARBCreateSubscriptionResponseType Properties
ARBCreateSubscriptionResponseType Class See Also Send Feedback

The ARBCreateSubscriptionResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)
subscriptionId |

See Also

ARBCreateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


subscriptionId Property

[image]

.NET Framework Class Library
ARBCreateSubscriptionResponseType..::.subscriptionId Property
ARBCreateSubscriptionResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property subscriptionId As Long
C#
public long subscriptionId { get; set; }
Visual C++
public:
property long long subscriptionId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_subscriptionId();
function set_subscriptionId(value);

Remarks

See Also

ARBCreateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBSubscriptionType Class

[image]

.NET Framework Class Library
ARBSubscriptionType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ARBSubscriptionType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ARBSubscriptionType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ARBSubscriptionType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBSubscriptionType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ARBSubscriptionType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ARBSubscriptionType

See Also

ARBSubscriptionType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBSubscriptionType Members

[image] [image]

.NET Framework Class Library
ARBSubscriptionType Members
ARBSubscriptionType Class Constructors Methods Properties See Also Send Feedback

The ARBSubscriptionType type exposes the following members.

Constructors

Name | Description
ARBSubscriptionType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
amountSpecified |
billTo |
customer |
name |
order |
payment |
paymentSchedule |
shipTo |
trialAmount |
trialAmountSpecified |

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBSubscriptionType Constructor

[image]

.NET Framework Class Library
ARBSubscriptionType Constructor
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ARBSubscriptionType()
Visual C++
public:
ARBSubscriptionType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBSubscriptionType = function();

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBSubscriptionType Methods

[image] [image]

.NET Framework Class Library
ARBSubscriptionType Methods
ARBSubscriptionType Class See Also Send Feedback

The ARBSubscriptionType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBSubscriptionType Properties

[image] [image]

.NET Framework Class Library
ARBSubscriptionType Properties
ARBSubscriptionType Class See Also Send Feedback

The ARBSubscriptionType type exposes the following members.

Properties

Name | Description
amount |
amountSpecified |
billTo |
customer |
name |
order |
payment |
paymentSchedule |
shipTo |
trialAmount |
trialAmountSpecified |

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


amount Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.amount Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As Decimal
C#
public decimal amount { get; set; }
Visual C++
public:
property Decimal amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


amountSpecified Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.amountSpecified Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amountSpecified As Boolean
C#
public bool amountSpecified { get; set; }
Visual C++
public:
property bool amountSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_amountSpecified();
function set_amountSpecified(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


billTo Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.billTo Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billTo As NameAndAddressType
C#
public NameAndAddressType billTo { get; set; }
Visual C++
public:
property NameAndAddressType^ billTo {
    NameAndAddressType^ get ();
    void set (NameAndAddressType^ value);
}
JavaScript
function get_billTo();
function set_billTo(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customer Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.customer Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customer As CustomerType
C#
public CustomerType customer { get; set; }
Visual C++
public:
property CustomerType^ customer {
    CustomerType^ get ();
    void set (CustomerType^ value);
}
JavaScript
function get_customer();
function set_customer(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


name Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.name Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String
C#
public string name { get; set; }
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


order Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.order Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property order As OrderType
C#
public OrderType order { get; set; }
Visual C++
public:
property OrderType^ order {
    OrderType^ get ();
    void set (OrderType^ value);
}
JavaScript
function get_order();
function set_order(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


payment Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.payment Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payment As PaymentType
C#
public PaymentType payment { get; set; }
Visual C++
public:
property PaymentType^ payment {
    PaymentType^ get ();
    void set (PaymentType^ value);
}
JavaScript
function get_payment();
function set_payment(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


paymentSchedule Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.paymentSchedule Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentSchedule As PaymentScheduleType
C#
public PaymentScheduleType paymentSchedule { get; set; }
Visual C++
public:
property PaymentScheduleType^ paymentSchedule {
    PaymentScheduleType^ get ();
    void set (PaymentScheduleType^ value);
}
JavaScript
function get_paymentSchedule();
function set_paymentSchedule(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


shipTo Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.shipTo Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipTo As NameAndAddressType
C#
public NameAndAddressType shipTo { get; set; }
Visual C++
public:
property NameAndAddressType^ shipTo {
    NameAndAddressType^ get ();
    void set (NameAndAddressType^ value);
}
JavaScript
function get_shipTo();
function set_shipTo(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


trialAmount Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.trialAmount Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property trialAmount As Decimal
C#
public decimal trialAmount { get; set; }
Visual C++
public:
property Decimal trialAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_trialAmount();
function set_trialAmount(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


trialAmountSpecified Property

[image]

.NET Framework Class Library
ARBSubscriptionType..::.trialAmountSpecified Property
ARBSubscriptionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property trialAmountSpecified As Boolean
C#
public bool trialAmountSpecified { get; set; }
Visual C++
public:
property bool trialAmountSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_trialAmountSpecified();
function set_trialAmountSpecified(value);

Remarks

See Also

ARBSubscriptionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBSubscriptionUnitEnum Enumeration

[image]

.NET Framework Class Library
ARBSubscriptionUnitEnum Enumeration
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Enumeration ARBSubscriptionUnitEnum
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public enum ARBSubscriptionUnitEnum
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public enum class ARBSubscriptionUnitEnum
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBSubscriptionUnitEnum = function();
InSite.Domain.AuthorizeNetCIMService.ARBSubscriptionUnitEnum.createEnum('InSite.Domain.AuthorizeNetCIMService.ARBSubscriptionUnitEnum', false);

Members

Member name | Description
days |
months |

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionCompletedEventArgs Class

[image]

.NET Framework Class Library
ARBUpdateSubscriptionCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class ARBUpdateSubscriptionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class ARBUpdateSubscriptionCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class ARBUpdateSubscriptionCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBUpdateSubscriptionCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ARBUpdateSubscriptionCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.ARBUpdateSubscriptionCompletedEventArgs

See Also

ARBUpdateSubscriptionCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
ARBUpdateSubscriptionCompletedEventArgs Members
ARBUpdateSubscriptionCompletedEventArgs Class Methods Properties See Also Send Feedback

The ARBUpdateSubscriptionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ARBUpdateSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
ARBUpdateSubscriptionCompletedEventArgs Methods
ARBUpdateSubscriptionCompletedEventArgs Class See Also Send Feedback

The ARBUpdateSubscriptionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARBUpdateSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
ARBUpdateSubscriptionCompletedEventArgs Properties
ARBUpdateSubscriptionCompletedEventArgs Class See Also Send Feedback

The ARBUpdateSubscriptionCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ARBUpdateSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
ARBUpdateSubscriptionCompletedEventArgs..::.Result Property
ARBUpdateSubscriptionCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As ARBUpdateSubscriptionResponseType
C#
public ARBUpdateSubscriptionResponseType Result { get; }
Visual C++
public:
property ARBUpdateSubscriptionResponseType^ Result {
    ARBUpdateSubscriptionResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

ARBUpdateSubscriptionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionCompletedEventHandler Delegate

[image]

.NET Framework Class Library
ARBUpdateSubscriptionCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub ARBUpdateSubscriptionCompletedEventHandler ( _
    sender As Object, _
    e As ARBUpdateSubscriptionCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void ARBUpdateSubscriptionCompletedEventHandler(
    Object sender,
    ARBUpdateSubscriptionCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void ARBUpdateSubscriptionCompletedEventHandler(
    Object^ sender,
    ARBUpdateSubscriptionCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBUpdateSubscriptionCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionResponseType Class

[image]

.NET Framework Class Library
ARBUpdateSubscriptionResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ARBUpdateSubscriptionResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ARBUpdateSubscriptionResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ARBUpdateSubscriptionResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBUpdateSubscriptionResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ARBUpdateSubscriptionResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.ARBUpdateSubscriptionResponseType

See Also

ARBUpdateSubscriptionResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionResponseType Members

[image] [image]

.NET Framework Class Library
ARBUpdateSubscriptionResponseType Members
ARBUpdateSubscriptionResponseType Class Constructors Methods Properties See Also Send Feedback

The ARBUpdateSubscriptionResponseType type exposes the following members.

Constructors

Name | Description
ARBUpdateSubscriptionResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

ARBUpdateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionResponseType Constructor

[image]

.NET Framework Class Library
ARBUpdateSubscriptionResponseType Constructor
ARBUpdateSubscriptionResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ARBUpdateSubscriptionResponseType()
Visual C++
public:
ARBUpdateSubscriptionResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ARBUpdateSubscriptionResponseType = function();

See Also

ARBUpdateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionResponseType Methods

[image] [image]

.NET Framework Class Library
ARBUpdateSubscriptionResponseType Methods
ARBUpdateSubscriptionResponseType Class See Also Send Feedback

The ARBUpdateSubscriptionResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ARBUpdateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionResponseType Properties

[image] [image]

.NET Framework Class Library
ARBUpdateSubscriptionResponseType Properties
ARBUpdateSubscriptionResponseType Class See Also Send Feedback

The ARBUpdateSubscriptionResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

ARBUpdateSubscriptionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestCompletedEventArgs Class

[image]

.NET Framework Class Library
AuthenticateTestCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class AuthenticateTestCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class AuthenticateTestCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class AuthenticateTestCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.AuthenticateTestCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.AuthenticateTestCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.AuthenticateTestCompletedEventArgs

See Also

AuthenticateTestCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
AuthenticateTestCompletedEventArgs Members
AuthenticateTestCompletedEventArgs Class Methods Properties See Also Send Feedback

The AuthenticateTestCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AuthenticateTestCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
AuthenticateTestCompletedEventArgs Methods
AuthenticateTestCompletedEventArgs Class See Also Send Feedback

The AuthenticateTestCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AuthenticateTestCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
AuthenticateTestCompletedEventArgs Properties
AuthenticateTestCompletedEventArgs Class See Also Send Feedback

The AuthenticateTestCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

AuthenticateTestCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
AuthenticateTestCompletedEventArgs..::.Result Property
AuthenticateTestCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As ANetApiResponseType
C#
public ANetApiResponseType Result { get; }
Visual C++
public:
property ANetApiResponseType^ Result {
    ANetApiResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

AuthenticateTestCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestCompletedEventHandler Delegate

[image]

.NET Framework Class Library
AuthenticateTestCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub AuthenticateTestCompletedEventHandler ( _
    sender As Object, _
    e As AuthenticateTestCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void AuthenticateTestCompletedEventHandler(
    Object sender,
    AuthenticateTestCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void AuthenticateTestCompletedEventHandler(
    Object^ sender,
    AuthenticateTestCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.AuthenticateTestCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountBaseType Class

[image]

.NET Framework Class Library
BankAccountBaseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class BankAccountBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class BankAccountBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class BankAccountBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.BankAccountBaseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.BankAccountBaseType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.BankAccountBaseType
InSite.Domain.AuthorizeNetCIMService..::.BankAccountMaskedType
InSite.Domain.AuthorizeNetCIMService..::.BankAccountType

See Also

BankAccountBaseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountBaseType Members

[image] [image]

.NET Framework Class Library
BankAccountBaseType Members
BankAccountBaseType Class Constructors Methods Properties See Also Send Feedback

The BankAccountBaseType type exposes the following members.

Constructors

Name | Description
BankAccountBaseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
accountType |
accountTypeSpecified |
bankName |
echeckType |
echeckTypeSpecified |
nameOnAccount |

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountBaseType Constructor

[image]

.NET Framework Class Library
BankAccountBaseType Constructor
BankAccountBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankAccountBaseType()
Visual C++
public:
BankAccountBaseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.BankAccountBaseType = function();

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountBaseType Methods

[image] [image]

.NET Framework Class Library
BankAccountBaseType Methods
BankAccountBaseType Class See Also Send Feedback

The BankAccountBaseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountBaseType Properties

[image] [image]

.NET Framework Class Library
BankAccountBaseType Properties
BankAccountBaseType Class See Also Send Feedback

The BankAccountBaseType type exposes the following members.

Properties

Name | Description
accountType |
accountTypeSpecified |
bankName |
echeckType |
echeckTypeSpecified |
nameOnAccount |

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


accountType Property

[image]

.NET Framework Class Library
BankAccountBaseType..::.accountType Property
BankAccountBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountType As BankAccountTypeEnum
C#
public BankAccountTypeEnum accountType { get; set; }
Visual C++
public:
property BankAccountTypeEnum accountType {
    BankAccountTypeEnum get ();
    void set (BankAccountTypeEnum value);
}
JavaScript
function get_accountType();
function set_accountType(value);

Remarks

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


accountTypeSpecified Property

[image]

.NET Framework Class Library
BankAccountBaseType..::.accountTypeSpecified Property
BankAccountBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountTypeSpecified As Boolean
C#
public bool accountTypeSpecified { get; set; }
Visual C++
public:
property bool accountTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_accountTypeSpecified();
function set_accountTypeSpecified(value);

Remarks

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


bankName Property

[image]

.NET Framework Class Library
BankAccountBaseType..::.bankName Property
BankAccountBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankName As String
C#
public string bankName { get; set; }
Visual C++
public:
property String^ bankName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankName();
function set_bankName(value);

Remarks

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


echeckType Property

[image]

.NET Framework Class Library
BankAccountBaseType..::.echeckType Property
BankAccountBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property echeckType As EcheckTypeEnum
C#
public EcheckTypeEnum echeckType { get; set; }
Visual C++
public:
property EcheckTypeEnum echeckType {
    EcheckTypeEnum get ();
    void set (EcheckTypeEnum value);
}
JavaScript
function get_echeckType();
function set_echeckType(value);

Remarks

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


echeckTypeSpecified Property

[image]

.NET Framework Class Library
BankAccountBaseType..::.echeckTypeSpecified Property
BankAccountBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property echeckTypeSpecified As Boolean
C#
public bool echeckTypeSpecified { get; set; }
Visual C++
public:
property bool echeckTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_echeckTypeSpecified();
function set_echeckTypeSpecified(value);

Remarks

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


nameOnAccount Property

[image]

.NET Framework Class Library
BankAccountBaseType..::.nameOnAccount Property
BankAccountBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property nameOnAccount As String
C#
public string nameOnAccount { get; set; }
Visual C++
public:
property String^ nameOnAccount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nameOnAccount();
function set_nameOnAccount(value);

Remarks

See Also

BankAccountBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountMaskedType Class

[image]

.NET Framework Class Library
BankAccountMaskedType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class BankAccountMaskedType _
    Inherits BankAccountBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class BankAccountMaskedType : BankAccountBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class BankAccountMaskedType : public BankAccountBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.BankAccountMaskedType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.BankAccountMaskedType',
    InSite.Domain.AuthorizeNetCIMService.BankAccountBaseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.BankAccountBaseType
InSite.Domain.AuthorizeNetCIMService..::.BankAccountMaskedType

See Also

BankAccountMaskedType Members
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountMaskedType Members

[image] [image]

.NET Framework Class Library
BankAccountMaskedType Members
BankAccountMaskedType Class Constructors Methods Properties See Also Send Feedback

The BankAccountMaskedType type exposes the following members.

Constructors

Name | Description
BankAccountMaskedType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
accountNumber |
accountType | (Inherited from BankAccountBaseType.)
accountTypeSpecified | (Inherited from BankAccountBaseType.)
bankName | (Inherited from BankAccountBaseType.)
echeckType | (Inherited from BankAccountBaseType.)
echeckTypeSpecified | (Inherited from BankAccountBaseType.)
nameOnAccount | (Inherited from BankAccountBaseType.)
routingNumber |

See Also

BankAccountMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountMaskedType Constructor

[image]

.NET Framework Class Library
BankAccountMaskedType Constructor
BankAccountMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankAccountMaskedType()
Visual C++
public:
BankAccountMaskedType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.BankAccountMaskedType = function();

See Also

BankAccountMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountMaskedType Methods

[image] [image]

.NET Framework Class Library
BankAccountMaskedType Methods
BankAccountMaskedType Class See Also Send Feedback

The BankAccountMaskedType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankAccountMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountMaskedType Properties

[image] [image]

.NET Framework Class Library
BankAccountMaskedType Properties
BankAccountMaskedType Class See Also Send Feedback

The BankAccountMaskedType type exposes the following members.

Properties

Name | Description
accountNumber |
accountType | (Inherited from BankAccountBaseType.)
accountTypeSpecified | (Inherited from BankAccountBaseType.)
bankName | (Inherited from BankAccountBaseType.)
echeckType | (Inherited from BankAccountBaseType.)
echeckTypeSpecified | (Inherited from BankAccountBaseType.)
nameOnAccount | (Inherited from BankAccountBaseType.)
routingNumber |

See Also

BankAccountMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


accountNumber Property

[image]

.NET Framework Class Library
BankAccountMaskedType..::.accountNumber Property
BankAccountMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountNumber As String
C#
public string accountNumber { get; set; }
Visual C++
public:
property String^ accountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

BankAccountMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


routingNumber Property

[image]

.NET Framework Class Library
BankAccountMaskedType..::.routingNumber Property
BankAccountMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property routingNumber As String
C#
public string routingNumber { get; set; }
Visual C++
public:
property String^ routingNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_routingNumber();
function set_routingNumber(value);

Remarks

See Also

BankAccountMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountType Class

[image]

.NET Framework Class Library
BankAccountType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class BankAccountType _
    Inherits BankAccountBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class BankAccountType : BankAccountBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class BankAccountType : public BankAccountBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.BankAccountType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.BankAccountType',
    InSite.Domain.AuthorizeNetCIMService.BankAccountBaseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.BankAccountBaseType
InSite.Domain.AuthorizeNetCIMService..::.BankAccountType

See Also

BankAccountType Members
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountType Members

[image] [image]

.NET Framework Class Library
BankAccountType Members
BankAccountType Class Constructors Methods Properties See Also Send Feedback

The BankAccountType type exposes the following members.

Constructors

Name | Description
BankAccountType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
accountNumber |
accountType | (Inherited from BankAccountBaseType.)
accountTypeSpecified | (Inherited from BankAccountBaseType.)
bankName | (Inherited from BankAccountBaseType.)
echeckType | (Inherited from BankAccountBaseType.)
echeckTypeSpecified | (Inherited from BankAccountBaseType.)
nameOnAccount | (Inherited from BankAccountBaseType.)
routingNumber |

See Also

BankAccountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountType Constructor

[image]

.NET Framework Class Library
BankAccountType Constructor
BankAccountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankAccountType()
Visual C++
public:
BankAccountType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.BankAccountType = function();

See Also

BankAccountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountType Methods

[image] [image]

.NET Framework Class Library
BankAccountType Methods
BankAccountType Class See Also Send Feedback

The BankAccountType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankAccountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountType Properties

[image] [image]

.NET Framework Class Library
BankAccountType Properties
BankAccountType Class See Also Send Feedback

The BankAccountType type exposes the following members.

Properties

Name | Description
accountNumber |
accountType | (Inherited from BankAccountBaseType.)
accountTypeSpecified | (Inherited from BankAccountBaseType.)
bankName | (Inherited from BankAccountBaseType.)
echeckType | (Inherited from BankAccountBaseType.)
echeckTypeSpecified | (Inherited from BankAccountBaseType.)
nameOnAccount | (Inherited from BankAccountBaseType.)
routingNumber |

See Also

BankAccountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


accountNumber Property

[image]

.NET Framework Class Library
BankAccountType..::.accountNumber Property
BankAccountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountNumber As String
C#
public string accountNumber { get; set; }
Visual C++
public:
property String^ accountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

BankAccountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


routingNumber Property

[image]

.NET Framework Class Library
BankAccountType..::.routingNumber Property
BankAccountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property routingNumber As String
C#
public string routingNumber { get; set; }
Visual C++
public:
property String^ routingNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_routingNumber();
function set_routingNumber(value);

Remarks

See Also

BankAccountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


BankAccountTypeEnum Enumeration

[image]

.NET Framework Class Library
BankAccountTypeEnum Enumeration
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Enumeration BankAccountTypeEnum
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public enum BankAccountTypeEnum
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public enum class BankAccountTypeEnum
JavaScript
InSite.Domain.AuthorizeNetCIMService.BankAccountTypeEnum = function();
InSite.Domain.AuthorizeNetCIMService.BankAccountTypeEnum.createEnum('InSite.Domain.AuthorizeNetCIMService.BankAccountTypeEnum', false);

Members

Member name | Description
checking |
savings |
businessChecking |

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
CreateCustomerPaymentProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class CreateCustomerPaymentProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class CreateCustomerPaymentProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class CreateCustomerPaymentProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerPaymentProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreateCustomerPaymentProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerPaymentProfileCompletedEventArgs

See Also

CreateCustomerPaymentProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
CreateCustomerPaymentProfileCompletedEventArgs Members
CreateCustomerPaymentProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The CreateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
CreateCustomerPaymentProfileCompletedEventArgs Methods
CreateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The CreateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
CreateCustomerPaymentProfileCompletedEventArgs Properties
CreateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The CreateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
CreateCustomerPaymentProfileCompletedEventArgs..::.Result Property
CreateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As CreateCustomerPaymentProfileResponseType
C#
public CreateCustomerPaymentProfileResponseType Result { get; }
Visual C++
public:
property CreateCustomerPaymentProfileResponseType^ Result {
    CreateCustomerPaymentProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

CreateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
CreateCustomerPaymentProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub CreateCustomerPaymentProfileCompletedEventHandler ( _
    sender As Object, _
    e As CreateCustomerPaymentProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void CreateCustomerPaymentProfileCompletedEventHandler(
    Object sender,
    CreateCustomerPaymentProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void CreateCustomerPaymentProfileCompletedEventHandler(
    Object^ sender,
    CreateCustomerPaymentProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerPaymentProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileResponseType Class

[image]

.NET Framework Class Library
CreateCustomerPaymentProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CreateCustomerPaymentProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CreateCustomerPaymentProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CreateCustomerPaymentProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerPaymentProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreateCustomerPaymentProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerPaymentProfileResponseType

See Also

CreateCustomerPaymentProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileResponseType Members

[image] [image]

.NET Framework Class Library
CreateCustomerPaymentProfileResponseType Members
CreateCustomerPaymentProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The CreateCustomerPaymentProfileResponseType type exposes the following members.

Constructors

Name | Description
CreateCustomerPaymentProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
customerPaymentProfileId |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)
validationDirectResponse |

See Also

CreateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileResponseType Constructor

[image]

.NET Framework Class Library
CreateCustomerPaymentProfileResponseType Constructor
CreateCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreateCustomerPaymentProfileResponseType()
Visual C++
public:
CreateCustomerPaymentProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerPaymentProfileResponseType = function();

See Also

CreateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileResponseType Methods

[image] [image]

.NET Framework Class Library
CreateCustomerPaymentProfileResponseType Methods
CreateCustomerPaymentProfileResponseType Class See Also Send Feedback

The CreateCustomerPaymentProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileResponseType Properties

[image] [image]

.NET Framework Class Library
CreateCustomerPaymentProfileResponseType Properties
CreateCustomerPaymentProfileResponseType Class See Also Send Feedback

The CreateCustomerPaymentProfileResponseType type exposes the following members.

Properties

Name | Description
customerPaymentProfileId |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)
validationDirectResponse |

See Also

CreateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerPaymentProfileId Property

[image]

.NET Framework Class Library
CreateCustomerPaymentProfileResponseType..::.customerPaymentProfileId Property
CreateCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerPaymentProfileId As Long
C#
public long customerPaymentProfileId { get; set; }
Visual C++
public:
property long long customerPaymentProfileId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerPaymentProfileId();
function set_customerPaymentProfileId(value);

Remarks

See Also

CreateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


validationDirectResponse Property

[image]

.NET Framework Class Library
CreateCustomerPaymentProfileResponseType..::.validationDirectResponse Property
CreateCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property validationDirectResponse As String
C#
public string validationDirectResponse { get; set; }
Visual C++
public:
property String^ validationDirectResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_validationDirectResponse();
function set_validationDirectResponse(value);

Remarks

See Also

CreateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
CreateCustomerProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class CreateCustomerProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class CreateCustomerProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class CreateCustomerProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerProfileCompletedEventArgs

See Also

CreateCustomerProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
CreateCustomerProfileCompletedEventArgs Members
CreateCustomerProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The CreateCustomerProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
CreateCustomerProfileCompletedEventArgs Methods
CreateCustomerProfileCompletedEventArgs Class See Also Send Feedback

The CreateCustomerProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
CreateCustomerProfileCompletedEventArgs Properties
CreateCustomerProfileCompletedEventArgs Class See Also Send Feedback

The CreateCustomerProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
CreateCustomerProfileCompletedEventArgs..::.Result Property
CreateCustomerProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As CreateCustomerProfileResponseType
C#
public CreateCustomerProfileResponseType Result { get; }
Visual C++
public:
property CreateCustomerProfileResponseType^ Result {
    CreateCustomerProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

CreateCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
CreateCustomerProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub CreateCustomerProfileCompletedEventHandler ( _
    sender As Object, _
    e As CreateCustomerProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void CreateCustomerProfileCompletedEventHandler(
    Object sender,
    CreateCustomerProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void CreateCustomerProfileCompletedEventHandler(
    Object^ sender,
    CreateCustomerProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileResponseType Class

[image]

.NET Framework Class Library
CreateCustomerProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CreateCustomerProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CreateCustomerProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CreateCustomerProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerProfileResponseType

See Also

CreateCustomerProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileResponseType Members

[image] [image]

.NET Framework Class Library
CreateCustomerProfileResponseType Members
CreateCustomerProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The CreateCustomerProfileResponseType type exposes the following members.

Constructors

Name | Description
CreateCustomerProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
customerProfileId |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

CreateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileResponseType Constructor

[image]

.NET Framework Class Library
CreateCustomerProfileResponseType Constructor
CreateCustomerProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreateCustomerProfileResponseType()
Visual C++
public:
CreateCustomerProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileResponseType = function();

See Also

CreateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileResponseType Methods

[image] [image]

.NET Framework Class Library
CreateCustomerProfileResponseType Methods
CreateCustomerProfileResponseType Class See Also Send Feedback

The CreateCustomerProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileResponseType Properties

[image] [image]

.NET Framework Class Library
CreateCustomerProfileResponseType Properties
CreateCustomerProfileResponseType Class See Also Send Feedback

The CreateCustomerProfileResponseType type exposes the following members.

Properties

Name | Description
customerProfileId |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

CreateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerProfileId Property

[image]

.NET Framework Class Library
CreateCustomerProfileResponseType..::.customerProfileId Property
CreateCustomerProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerProfileId As Long
C#
public long customerProfileId { get; set; }
Visual C++
public:
property long long customerProfileId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerProfileId();
function set_customerProfileId(value);

Remarks

See Also

CreateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionCompletedEventArgs Class

[image]

.NET Framework Class Library
CreateCustomerProfileTransactionCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class CreateCustomerProfileTransactionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class CreateCustomerProfileTransactionCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class CreateCustomerProfileTransactionCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileTransactionCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileTransactionCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerProfileTransactionCompletedEventArgs

See Also

CreateCustomerProfileTransactionCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
CreateCustomerProfileTransactionCompletedEventArgs Members
CreateCustomerProfileTransactionCompletedEventArgs Class Methods Properties See Also Send Feedback

The CreateCustomerProfileTransactionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateCustomerProfileTransactionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
CreateCustomerProfileTransactionCompletedEventArgs Methods
CreateCustomerProfileTransactionCompletedEventArgs Class See Also Send Feedback

The CreateCustomerProfileTransactionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateCustomerProfileTransactionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
CreateCustomerProfileTransactionCompletedEventArgs Properties
CreateCustomerProfileTransactionCompletedEventArgs Class See Also Send Feedback

The CreateCustomerProfileTransactionCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateCustomerProfileTransactionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
CreateCustomerProfileTransactionCompletedEventArgs..::.Result Property
CreateCustomerProfileTransactionCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As CreateCustomerProfileTransactionResponseType
C#
public CreateCustomerProfileTransactionResponseType Result { get; }
Visual C++
public:
property CreateCustomerProfileTransactionResponseType^ Result {
    CreateCustomerProfileTransactionResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

CreateCustomerProfileTransactionCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionCompletedEventHandler Delegate

[image]

.NET Framework Class Library
CreateCustomerProfileTransactionCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub CreateCustomerProfileTransactionCompletedEventHandler ( _
    sender As Object, _
    e As CreateCustomerProfileTransactionCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void CreateCustomerProfileTransactionCompletedEventHandler(
    Object sender,
    CreateCustomerProfileTransactionCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void CreateCustomerProfileTransactionCompletedEventHandler(
    Object^ sender,
    CreateCustomerProfileTransactionCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerProfileTransactionCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionResponseType Class

[image]

.NET Framework Class Library
CreateCustomerProfileTransactionResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CreateCustomerProfileTransactionResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CreateCustomerProfileTransactionResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CreateCustomerProfileTransactionResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileTransactionResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileTransactionResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerProfileTransactionResponseType

See Also

CreateCustomerProfileTransactionResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionResponseType Members

[image] [image]

.NET Framework Class Library
CreateCustomerProfileTransactionResponseType Members
CreateCustomerProfileTransactionResponseType Class Constructors Methods Properties See Also Send Feedback

The CreateCustomerProfileTransactionResponseType type exposes the following members.

Constructors

Name | Description
CreateCustomerProfileTransactionResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
directResponse |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

CreateCustomerProfileTransactionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionResponseType Constructor

[image]

.NET Framework Class Library
CreateCustomerProfileTransactionResponseType Constructor
CreateCustomerProfileTransactionResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreateCustomerProfileTransactionResponseType()
Visual C++
public:
CreateCustomerProfileTransactionResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerProfileTransactionResponseType = function();

See Also

CreateCustomerProfileTransactionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionResponseType Methods

[image] [image]

.NET Framework Class Library
CreateCustomerProfileTransactionResponseType Methods
CreateCustomerProfileTransactionResponseType Class See Also Send Feedback

The CreateCustomerProfileTransactionResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateCustomerProfileTransactionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionResponseType Properties

[image] [image]

.NET Framework Class Library
CreateCustomerProfileTransactionResponseType Properties
CreateCustomerProfileTransactionResponseType Class See Also Send Feedback

The CreateCustomerProfileTransactionResponseType type exposes the following members.

Properties

Name | Description
directResponse |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

CreateCustomerProfileTransactionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


directResponse Property

[image]

.NET Framework Class Library
CreateCustomerProfileTransactionResponseType..::.directResponse Property
CreateCustomerProfileTransactionResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directResponse As String
C#
public string directResponse { get; set; }
Visual C++
public:
property String^ directResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_directResponse();
function set_directResponse(value);

Remarks

See Also

CreateCustomerProfileTransactionResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressCompletedEventArgs Class

[image]

.NET Framework Class Library
CreateCustomerShippingAddressCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class CreateCustomerShippingAddressCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class CreateCustomerShippingAddressCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class CreateCustomerShippingAddressCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerShippingAddressCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreateCustomerShippingAddressCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerShippingAddressCompletedEventArgs

See Also

CreateCustomerShippingAddressCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
CreateCustomerShippingAddressCompletedEventArgs Members
CreateCustomerShippingAddressCompletedEventArgs Class Methods Properties See Also Send Feedback

The CreateCustomerShippingAddressCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
CreateCustomerShippingAddressCompletedEventArgs Methods
CreateCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

The CreateCustomerShippingAddressCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
CreateCustomerShippingAddressCompletedEventArgs Properties
CreateCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

The CreateCustomerShippingAddressCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

CreateCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
CreateCustomerShippingAddressCompletedEventArgs..::.Result Property
CreateCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As CreateCustomerShippingAddressResponseType
C#
public CreateCustomerShippingAddressResponseType Result { get; }
Visual C++
public:
property CreateCustomerShippingAddressResponseType^ Result {
    CreateCustomerShippingAddressResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

CreateCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressCompletedEventHandler Delegate

[image]

.NET Framework Class Library
CreateCustomerShippingAddressCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub CreateCustomerShippingAddressCompletedEventHandler ( _
    sender As Object, _
    e As CreateCustomerShippingAddressCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void CreateCustomerShippingAddressCompletedEventHandler(
    Object sender,
    CreateCustomerShippingAddressCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void CreateCustomerShippingAddressCompletedEventHandler(
    Object^ sender,
    CreateCustomerShippingAddressCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerShippingAddressCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressResponseType Class

[image]

.NET Framework Class Library
CreateCustomerShippingAddressResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CreateCustomerShippingAddressResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CreateCustomerShippingAddressResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CreateCustomerShippingAddressResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerShippingAddressResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreateCustomerShippingAddressResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.CreateCustomerShippingAddressResponseType

See Also

CreateCustomerShippingAddressResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressResponseType Members

[image] [image]

.NET Framework Class Library
CreateCustomerShippingAddressResponseType Members
CreateCustomerShippingAddressResponseType Class Constructors Methods Properties See Also Send Feedback

The CreateCustomerShippingAddressResponseType type exposes the following members.

Constructors

Name | Description
CreateCustomerShippingAddressResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
customerAddressId |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

CreateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressResponseType Constructor

[image]

.NET Framework Class Library
CreateCustomerShippingAddressResponseType Constructor
CreateCustomerShippingAddressResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreateCustomerShippingAddressResponseType()
Visual C++
public:
CreateCustomerShippingAddressResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreateCustomerShippingAddressResponseType = function();

See Also

CreateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressResponseType Methods

[image] [image]

.NET Framework Class Library
CreateCustomerShippingAddressResponseType Methods
CreateCustomerShippingAddressResponseType Class See Also Send Feedback

The CreateCustomerShippingAddressResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressResponseType Properties

[image] [image]

.NET Framework Class Library
CreateCustomerShippingAddressResponseType Properties
CreateCustomerShippingAddressResponseType Class See Also Send Feedback

The CreateCustomerShippingAddressResponseType type exposes the following members.

Properties

Name | Description
customerAddressId |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

CreateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerAddressId Property

[image]

.NET Framework Class Library
CreateCustomerShippingAddressResponseType..::.customerAddressId Property
CreateCustomerShippingAddressResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerAddressId As Long
C#
public long customerAddressId { get; set; }
Visual C++
public:
property long long customerAddressId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerAddressId();
function set_customerAddressId(value);

Remarks

See Also

CreateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardMaskedType Class

[image]

.NET Framework Class Library
CreditCardMaskedType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CreditCardMaskedType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CreditCardMaskedType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CreditCardMaskedType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreditCardMaskedType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreditCardMaskedType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CreditCardMaskedType

See Also

CreditCardMaskedType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardMaskedType Members

[image] [image]

.NET Framework Class Library
CreditCardMaskedType Members
CreditCardMaskedType Class Constructors Methods Properties See Also Send Feedback

The CreditCardMaskedType type exposes the following members.

Constructors

Name | Description
CreditCardMaskedType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
cardNumber |
expirationDate |

See Also

CreditCardMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardMaskedType Constructor

[image]

.NET Framework Class Library
CreditCardMaskedType Constructor
CreditCardMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreditCardMaskedType()
Visual C++
public:
CreditCardMaskedType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreditCardMaskedType = function();

See Also

CreditCardMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardMaskedType Methods

[image] [image]

.NET Framework Class Library
CreditCardMaskedType Methods
CreditCardMaskedType Class See Also Send Feedback

The CreditCardMaskedType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreditCardMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardMaskedType Properties

[image] [image]

.NET Framework Class Library
CreditCardMaskedType Properties
CreditCardMaskedType Class See Also Send Feedback

The CreditCardMaskedType type exposes the following members.

Properties

Name | Description
cardNumber |
expirationDate |

See Also

CreditCardMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


cardNumber Property

[image]

.NET Framework Class Library
CreditCardMaskedType..::.cardNumber Property
CreditCardMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardNumber As String
C#
public string cardNumber { get; set; }
Visual C++
public:
property String^ cardNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardNumber();
function set_cardNumber(value);

Remarks

See Also

CreditCardMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


expirationDate Property

[image]

.NET Framework Class Library
CreditCardMaskedType..::.expirationDate Property
CreditCardMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property expirationDate As String
C#
public string expirationDate { get; set; }
Visual C++
public:
property String^ expirationDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationDate();
function set_expirationDate(value);

Remarks

See Also

CreditCardMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardSimpleType Class

[image]

.NET Framework Class Library
CreditCardSimpleType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CreditCardSimpleType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CreditCardSimpleType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CreditCardSimpleType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreditCardSimpleType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreditCardSimpleType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CreditCardSimpleType
InSite.Domain.AuthorizeNetCIMService..::.CreditCardType

See Also

CreditCardSimpleType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardSimpleType Members

[image] [image]

.NET Framework Class Library
CreditCardSimpleType Members
CreditCardSimpleType Class Constructors Methods Properties See Also Send Feedback

The CreditCardSimpleType type exposes the following members.

Constructors

Name | Description
CreditCardSimpleType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
cardNumber |
expirationDate |

See Also

CreditCardSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardSimpleType Constructor

[image]

.NET Framework Class Library
CreditCardSimpleType Constructor
CreditCardSimpleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreditCardSimpleType()
Visual C++
public:
CreditCardSimpleType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreditCardSimpleType = function();

See Also

CreditCardSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardSimpleType Methods

[image] [image]

.NET Framework Class Library
CreditCardSimpleType Methods
CreditCardSimpleType Class See Also Send Feedback

The CreditCardSimpleType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreditCardSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardSimpleType Properties

[image] [image]

.NET Framework Class Library
CreditCardSimpleType Properties
CreditCardSimpleType Class See Also Send Feedback

The CreditCardSimpleType type exposes the following members.

Properties

Name | Description
cardNumber |
expirationDate |

See Also

CreditCardSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


cardNumber Property

[image]

.NET Framework Class Library
CreditCardSimpleType..::.cardNumber Property
CreditCardSimpleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardNumber As String
C#
public string cardNumber { get; set; }
Visual C++
public:
property String^ cardNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardNumber();
function set_cardNumber(value);

Remarks

See Also

CreditCardSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


expirationDate Property

[image]

.NET Framework Class Library
CreditCardSimpleType..::.expirationDate Property
CreditCardSimpleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property expirationDate As String
C#
public string expirationDate { get; set; }
Visual C++
public:
property String^ expirationDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationDate();
function set_expirationDate(value);

Remarks

See Also

CreditCardSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardType Class

[image]

.NET Framework Class Library
CreditCardType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CreditCardType _
    Inherits CreditCardSimpleType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CreditCardType : CreditCardSimpleType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CreditCardType : public CreditCardSimpleType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreditCardType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CreditCardType',
    InSite.Domain.AuthorizeNetCIMService.CreditCardSimpleType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CreditCardSimpleType
InSite.Domain.AuthorizeNetCIMService..::.CreditCardType

See Also

CreditCardType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardType Members

[image] [image]

.NET Framework Class Library
CreditCardType Members
CreditCardType Class Constructors Methods Properties See Also Send Feedback

The CreditCardType type exposes the following members.

Constructors

Name | Description
CreditCardType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
cardCode |
cardNumber | (Inherited from CreditCardSimpleType.)
expirationDate | (Inherited from CreditCardSimpleType.)

See Also

CreditCardType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardType Constructor

[image]

.NET Framework Class Library
CreditCardType Constructor
CreditCardType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreditCardType()
Visual C++
public:
CreditCardType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CreditCardType = function();

See Also

CreditCardType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardType Methods

[image] [image]

.NET Framework Class Library
CreditCardType Methods
CreditCardType Class See Also Send Feedback

The CreditCardType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CreditCardType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreditCardType Properties

[image] [image]

.NET Framework Class Library
CreditCardType Properties
CreditCardType Class See Also Send Feedback

The CreditCardType type exposes the following members.

Properties

Name | Description
cardCode |
cardNumber | (Inherited from CreditCardSimpleType.)
expirationDate | (Inherited from CreditCardSimpleType.)

See Also

CreditCardType Class
InSite.Domain.AuthorizeNetCIMService Namespace


cardCode Property

[image]

.NET Framework Class Library
CreditCardType..::.cardCode Property
CreditCardType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardCode As String
C#
public string cardCode { get; set; }
Visual C++
public:
property String^ cardCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardCode();
function set_cardCode(value);

Remarks

See Also

CreditCardType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressExType Class

[image]

.NET Framework Class Library
CustomerAddressExType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerAddressExType _
    Inherits CustomerAddressType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerAddressExType : CustomerAddressType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerAddressExType : public CustomerAddressType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerAddressExType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerAddressExType',
    InSite.Domain.AuthorizeNetCIMService.CustomerAddressType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.NameAndAddressType
InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressType
InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressExType

See Also

CustomerAddressExType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressExType Members

[image] [image]

.NET Framework Class Library
CustomerAddressExType Members
CustomerAddressExType Class Constructors Methods Properties See Also Send Feedback

The CustomerAddressExType type exposes the following members.

Constructors

Name | Description
CustomerAddressExType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
address | (Inherited from NameAndAddressType.)
city | (Inherited from NameAndAddressType.)
company | (Inherited from NameAndAddressType.)
country | (Inherited from NameAndAddressType.)
customerAddressId |
faxNumber | (Inherited from CustomerAddressType.)
firstName | (Inherited from NameAndAddressType.)
lastName | (Inherited from NameAndAddressType.)
phoneNumber | (Inherited from CustomerAddressType.)
state | (Inherited from NameAndAddressType.)
zip | (Inherited from NameAndAddressType.)

See Also

CustomerAddressExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressExType Constructor

[image]

.NET Framework Class Library
CustomerAddressExType Constructor
CustomerAddressExType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerAddressExType()
Visual C++
public:
CustomerAddressExType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerAddressExType = function();

See Also

CustomerAddressExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressExType Methods

[image] [image]

.NET Framework Class Library
CustomerAddressExType Methods
CustomerAddressExType Class See Also Send Feedback

The CustomerAddressExType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerAddressExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressExType Properties

[image] [image]

.NET Framework Class Library
CustomerAddressExType Properties
CustomerAddressExType Class See Also Send Feedback

The CustomerAddressExType type exposes the following members.

Properties

Name | Description
address | (Inherited from NameAndAddressType.)
city | (Inherited from NameAndAddressType.)
company | (Inherited from NameAndAddressType.)
country | (Inherited from NameAndAddressType.)
customerAddressId |
faxNumber | (Inherited from CustomerAddressType.)
firstName | (Inherited from NameAndAddressType.)
lastName | (Inherited from NameAndAddressType.)
phoneNumber | (Inherited from CustomerAddressType.)
state | (Inherited from NameAndAddressType.)
zip | (Inherited from NameAndAddressType.)

See Also

CustomerAddressExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerAddressId Property

[image]

.NET Framework Class Library
CustomerAddressExType..::.customerAddressId Property
CustomerAddressExType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerAddressId As Long
C#
public long customerAddressId { get; set; }
Visual C++
public:
property long long customerAddressId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerAddressId();
function set_customerAddressId(value);

Remarks

See Also

CustomerAddressExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressType Class

[image]

.NET Framework Class Library
CustomerAddressType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerAddressType _
    Inherits NameAndAddressType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerAddressType : NameAndAddressType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerAddressType : public NameAndAddressType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerAddressType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerAddressType',
    InSite.Domain.AuthorizeNetCIMService.NameAndAddressType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.NameAndAddressType
InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressType
InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressExType

See Also

CustomerAddressType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressType Members

[image] [image]

.NET Framework Class Library
CustomerAddressType Members
CustomerAddressType Class Constructors Methods Properties See Also Send Feedback

The CustomerAddressType type exposes the following members.

Constructors

Name | Description
CustomerAddressType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
address | (Inherited from NameAndAddressType.)
city | (Inherited from NameAndAddressType.)
company | (Inherited from NameAndAddressType.)
country | (Inherited from NameAndAddressType.)
faxNumber |
firstName | (Inherited from NameAndAddressType.)
lastName | (Inherited from NameAndAddressType.)
phoneNumber |
state | (Inherited from NameAndAddressType.)
zip | (Inherited from NameAndAddressType.)

See Also

CustomerAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressType Constructor

[image]

.NET Framework Class Library
CustomerAddressType Constructor
CustomerAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerAddressType()
Visual C++
public:
CustomerAddressType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerAddressType = function();

See Also

CustomerAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressType Methods

[image] [image]

.NET Framework Class Library
CustomerAddressType Methods
CustomerAddressType Class See Also Send Feedback

The CustomerAddressType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerAddressType Properties

[image] [image]

.NET Framework Class Library
CustomerAddressType Properties
CustomerAddressType Class See Also Send Feedback

The CustomerAddressType type exposes the following members.

Properties

Name | Description
address | (Inherited from NameAndAddressType.)
city | (Inherited from NameAndAddressType.)
company | (Inherited from NameAndAddressType.)
country | (Inherited from NameAndAddressType.)
faxNumber |
firstName | (Inherited from NameAndAddressType.)
lastName | (Inherited from NameAndAddressType.)
phoneNumber |
state | (Inherited from NameAndAddressType.)
zip | (Inherited from NameAndAddressType.)

See Also

CustomerAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


faxNumber Property

[image]

.NET Framework Class Library
CustomerAddressType..::.faxNumber Property
CustomerAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property faxNumber As String
C#
public string faxNumber { get; set; }
Visual C++
public:
property String^ faxNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_faxNumber();
function set_faxNumber(value);

Remarks

See Also

CustomerAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


phoneNumber Property

[image]

.NET Framework Class Library
CustomerAddressType..::.phoneNumber Property
CustomerAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property phoneNumber As String
C#
public string phoneNumber { get; set; }
Visual C++
public:
property String^ phoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

CustomerAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileBaseType Class

[image]

.NET Framework Class Library
CustomerPaymentProfileBaseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerPaymentProfileBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerPaymentProfileBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerPaymentProfileBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileBaseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileBaseType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileBaseType
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileMaskedType
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileType

See Also

CustomerPaymentProfileBaseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileBaseType Members

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileBaseType Members
CustomerPaymentProfileBaseType Class Constructors Methods Properties See Also Send Feedback

The CustomerPaymentProfileBaseType type exposes the following members.

Constructors

Name | Description
CustomerPaymentProfileBaseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
billTo |
customerType |
customerTypeSpecified |

See Also

CustomerPaymentProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileBaseType Constructor

[image]

.NET Framework Class Library
CustomerPaymentProfileBaseType Constructor
CustomerPaymentProfileBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerPaymentProfileBaseType()
Visual C++
public:
CustomerPaymentProfileBaseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileBaseType = function();

See Also

CustomerPaymentProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileBaseType Methods

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileBaseType Methods
CustomerPaymentProfileBaseType Class See Also Send Feedback

The CustomerPaymentProfileBaseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerPaymentProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileBaseType Properties

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileBaseType Properties
CustomerPaymentProfileBaseType Class See Also Send Feedback

The CustomerPaymentProfileBaseType type exposes the following members.

Properties

Name | Description
billTo |
customerType |
customerTypeSpecified |

See Also

CustomerPaymentProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


billTo Property

[image]

.NET Framework Class Library
CustomerPaymentProfileBaseType..::.billTo Property
CustomerPaymentProfileBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billTo As CustomerAddressType
C#
public CustomerAddressType billTo { get; set; }
Visual C++
public:
property CustomerAddressType^ billTo {
    CustomerAddressType^ get ();
    void set (CustomerAddressType^ value);
}
JavaScript
function get_billTo();
function set_billTo(value);

Remarks

See Also

CustomerPaymentProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerType Property

[image]

.NET Framework Class Library
CustomerPaymentProfileBaseType..::.customerType Property
CustomerPaymentProfileBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerType As CustomerTypeEnum
C#
public CustomerTypeEnum customerType { get; set; }
Visual C++
public:
property CustomerTypeEnum customerType {
    CustomerTypeEnum get ();
    void set (CustomerTypeEnum value);
}
JavaScript
function get_customerType();
function set_customerType(value);

Remarks

See Also

CustomerPaymentProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerTypeSpecified Property

[image]

.NET Framework Class Library
CustomerPaymentProfileBaseType..::.customerTypeSpecified Property
CustomerPaymentProfileBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerTypeSpecified As Boolean
C#
public bool customerTypeSpecified { get; set; }
Visual C++
public:
property bool customerTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_customerTypeSpecified();
function set_customerTypeSpecified(value);

Remarks

See Also

CustomerPaymentProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileExType Class

[image]

.NET Framework Class Library
CustomerPaymentProfileExType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerPaymentProfileExType _
    Inherits CustomerPaymentProfileType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerPaymentProfileExType : CustomerPaymentProfileType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerPaymentProfileExType : public CustomerPaymentProfileType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileExType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileExType',
    InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileBaseType
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileType
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileExType

See Also

CustomerPaymentProfileExType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileExType Members

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileExType Members
CustomerPaymentProfileExType Class Constructors Methods Properties See Also Send Feedback

The CustomerPaymentProfileExType type exposes the following members.

Constructors

Name | Description
CustomerPaymentProfileExType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
billTo | (Inherited from CustomerPaymentProfileBaseType.)
customerPaymentProfileId |
customerType | (Inherited from CustomerPaymentProfileBaseType.)
customerTypeSpecified | (Inherited from CustomerPaymentProfileBaseType.)
driversLicense | (Inherited from CustomerPaymentProfileType.)
payment | (Inherited from CustomerPaymentProfileType.)
taxId | (Inherited from CustomerPaymentProfileType.)

See Also

CustomerPaymentProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileExType Constructor

[image]

.NET Framework Class Library
CustomerPaymentProfileExType Constructor
CustomerPaymentProfileExType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerPaymentProfileExType()
Visual C++
public:
CustomerPaymentProfileExType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileExType = function();

See Also

CustomerPaymentProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileExType Methods

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileExType Methods
CustomerPaymentProfileExType Class See Also Send Feedback

The CustomerPaymentProfileExType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerPaymentProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileExType Properties

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileExType Properties
CustomerPaymentProfileExType Class See Also Send Feedback

The CustomerPaymentProfileExType type exposes the following members.

Properties

Name | Description
billTo | (Inherited from CustomerPaymentProfileBaseType.)
customerPaymentProfileId |
customerType | (Inherited from CustomerPaymentProfileBaseType.)
customerTypeSpecified | (Inherited from CustomerPaymentProfileBaseType.)
driversLicense | (Inherited from CustomerPaymentProfileType.)
payment | (Inherited from CustomerPaymentProfileType.)
taxId | (Inherited from CustomerPaymentProfileType.)

See Also

CustomerPaymentProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerPaymentProfileId Property

[image]

.NET Framework Class Library
CustomerPaymentProfileExType..::.customerPaymentProfileId Property
CustomerPaymentProfileExType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerPaymentProfileId As Long
C#
public long customerPaymentProfileId { get; set; }
Visual C++
public:
property long long customerPaymentProfileId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerPaymentProfileId();
function set_customerPaymentProfileId(value);

Remarks

See Also

CustomerPaymentProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileMaskedType Class

[image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerPaymentProfileMaskedType _
    Inherits CustomerPaymentProfileBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerPaymentProfileMaskedType : CustomerPaymentProfileBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerPaymentProfileMaskedType : public CustomerPaymentProfileBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileMaskedType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileMaskedType',
    InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileBaseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileBaseType
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileMaskedType

See Also

CustomerPaymentProfileMaskedType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileMaskedType Members

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType Members
CustomerPaymentProfileMaskedType Class Constructors Methods Properties See Also Send Feedback

The CustomerPaymentProfileMaskedType type exposes the following members.

Constructors

Name | Description
CustomerPaymentProfileMaskedType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
billTo | (Inherited from CustomerPaymentProfileBaseType.)
customerPaymentProfileId |
customerType | (Inherited from CustomerPaymentProfileBaseType.)
customerTypeSpecified | (Inherited from CustomerPaymentProfileBaseType.)
driversLicense |
payment |
taxId |

See Also

CustomerPaymentProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileMaskedType Constructor

[image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType Constructor
CustomerPaymentProfileMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerPaymentProfileMaskedType()
Visual C++
public:
CustomerPaymentProfileMaskedType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileMaskedType = function();

See Also

CustomerPaymentProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileMaskedType Methods

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType Methods
CustomerPaymentProfileMaskedType Class See Also Send Feedback

The CustomerPaymentProfileMaskedType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerPaymentProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileMaskedType Properties

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType Properties
CustomerPaymentProfileMaskedType Class See Also Send Feedback

The CustomerPaymentProfileMaskedType type exposes the following members.

Properties

Name | Description
billTo | (Inherited from CustomerPaymentProfileBaseType.)
customerPaymentProfileId |
customerType | (Inherited from CustomerPaymentProfileBaseType.)
customerTypeSpecified | (Inherited from CustomerPaymentProfileBaseType.)
driversLicense |
payment |
taxId |

See Also

CustomerPaymentProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerPaymentProfileId Property

[image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType..::.customerPaymentProfileId Property
CustomerPaymentProfileMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerPaymentProfileId As Long
C#
public long customerPaymentProfileId { get; set; }
Visual C++
public:
property long long customerPaymentProfileId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerPaymentProfileId();
function set_customerPaymentProfileId(value);

Remarks

See Also

CustomerPaymentProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


driversLicense Property

[image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType..::.driversLicense Property
CustomerPaymentProfileMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property driversLicense As DriversLicenseMaskedType
C#
public DriversLicenseMaskedType driversLicense { get; set; }
Visual C++
public:
property DriversLicenseMaskedType^ driversLicense {
    DriversLicenseMaskedType^ get ();
    void set (DriversLicenseMaskedType^ value);
}
JavaScript
function get_driversLicense();
function set_driversLicense(value);

Remarks

See Also

CustomerPaymentProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


payment Property

[image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType..::.payment Property
CustomerPaymentProfileMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payment As PaymentMaskedType
C#
public PaymentMaskedType payment { get; set; }
Visual C++
public:
property PaymentMaskedType^ payment {
    PaymentMaskedType^ get ();
    void set (PaymentMaskedType^ value);
}
JavaScript
function get_payment();
function set_payment(value);

Remarks

See Also

CustomerPaymentProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


taxId Property

[image]

.NET Framework Class Library
CustomerPaymentProfileMaskedType..::.taxId Property
CustomerPaymentProfileMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxId As String
C#
public string taxId { get; set; }
Visual C++
public:
property String^ taxId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxId();
function set_taxId(value);

Remarks

See Also

CustomerPaymentProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileType Class

[image]

.NET Framework Class Library
CustomerPaymentProfileType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerPaymentProfileType _
    Inherits CustomerPaymentProfileBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerPaymentProfileType : CustomerPaymentProfileBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerPaymentProfileType : public CustomerPaymentProfileBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileType',
    InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileBaseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileBaseType
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileType
InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileExType

See Also

CustomerPaymentProfileType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileType Members

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileType Members
CustomerPaymentProfileType Class Constructors Methods Properties See Also Send Feedback

The CustomerPaymentProfileType type exposes the following members.

Constructors

Name | Description
CustomerPaymentProfileType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
billTo | (Inherited from CustomerPaymentProfileBaseType.)
customerType | (Inherited from CustomerPaymentProfileBaseType.)
customerTypeSpecified | (Inherited from CustomerPaymentProfileBaseType.)
driversLicense |
payment |
taxId |

See Also

CustomerPaymentProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileType Constructor

[image]

.NET Framework Class Library
CustomerPaymentProfileType Constructor
CustomerPaymentProfileType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerPaymentProfileType()
Visual C++
public:
CustomerPaymentProfileType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerPaymentProfileType = function();

See Also

CustomerPaymentProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileType Methods

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileType Methods
CustomerPaymentProfileType Class See Also Send Feedback

The CustomerPaymentProfileType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerPaymentProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerPaymentProfileType Properties

[image] [image]

.NET Framework Class Library
CustomerPaymentProfileType Properties
CustomerPaymentProfileType Class See Also Send Feedback

The CustomerPaymentProfileType type exposes the following members.

Properties

Name | Description
billTo | (Inherited from CustomerPaymentProfileBaseType.)
customerType | (Inherited from CustomerPaymentProfileBaseType.)
customerTypeSpecified | (Inherited from CustomerPaymentProfileBaseType.)
driversLicense |
payment |
taxId |

See Also

CustomerPaymentProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


driversLicense Property

[image]

.NET Framework Class Library
CustomerPaymentProfileType..::.driversLicense Property
CustomerPaymentProfileType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property driversLicense As DriversLicenseType
C#
public DriversLicenseType driversLicense { get; set; }
Visual C++
public:
property DriversLicenseType^ driversLicense {
    DriversLicenseType^ get ();
    void set (DriversLicenseType^ value);
}
JavaScript
function get_driversLicense();
function set_driversLicense(value);

Remarks

See Also

CustomerPaymentProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


payment Property

[image]

.NET Framework Class Library
CustomerPaymentProfileType..::.payment Property
CustomerPaymentProfileType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payment As PaymentSimpleType
C#
public PaymentSimpleType payment { get; set; }
Visual C++
public:
property PaymentSimpleType^ payment {
    PaymentSimpleType^ get ();
    void set (PaymentSimpleType^ value);
}
JavaScript
function get_payment();
function set_payment(value);

Remarks

See Also

CustomerPaymentProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


taxId Property

[image]

.NET Framework Class Library
CustomerPaymentProfileType..::.taxId Property
CustomerPaymentProfileType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxId As String
C#
public string taxId { get; set; }
Visual C++
public:
property String^ taxId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxId();
function set_taxId(value);

Remarks

See Also

CustomerPaymentProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileBaseType Class

[image]

.NET Framework Class Library
CustomerProfileBaseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerProfileBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerProfileBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerProfileBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerProfileBaseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerProfileBaseType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileBaseType
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileExType
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileType

See Also

CustomerProfileBaseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileBaseType Members

[image] [image]

.NET Framework Class Library
CustomerProfileBaseType Members
CustomerProfileBaseType Class Constructors Methods Properties See Also Send Feedback

The CustomerProfileBaseType type exposes the following members.

Constructors

Name | Description
CustomerProfileBaseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
description |
email |
merchantCustomerId |

See Also

CustomerProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileBaseType Constructor

[image]

.NET Framework Class Library
CustomerProfileBaseType Constructor
CustomerProfileBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerProfileBaseType()
Visual C++
public:
CustomerProfileBaseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerProfileBaseType = function();

See Also

CustomerProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileBaseType Methods

[image] [image]

.NET Framework Class Library
CustomerProfileBaseType Methods
CustomerProfileBaseType Class See Also Send Feedback

The CustomerProfileBaseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileBaseType Properties

[image] [image]

.NET Framework Class Library
CustomerProfileBaseType Properties
CustomerProfileBaseType Class See Also Send Feedback

The CustomerProfileBaseType type exposes the following members.

Properties

Name | Description
description |
email |
merchantCustomerId |

See Also

CustomerProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


description Property

[image]

.NET Framework Class Library
CustomerProfileBaseType..::.description Property
CustomerProfileBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property description As String
C#
public string description { get; set; }
Visual C++
public:
property String^ description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

CustomerProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


email Property

[image]

.NET Framework Class Library
CustomerProfileBaseType..::.email Property
CustomerProfileBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property email As String
C#
public string email { get; set; }
Visual C++
public:
property String^ email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

Remarks

See Also

CustomerProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


merchantCustomerId Property

[image]

.NET Framework Class Library
CustomerProfileBaseType..::.merchantCustomerId Property
CustomerProfileBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantCustomerId As String
C#
public string merchantCustomerId { get; set; }
Visual C++
public:
property String^ merchantCustomerId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantCustomerId();
function set_merchantCustomerId(value);

Remarks

See Also

CustomerProfileBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileExType Class

[image]

.NET Framework Class Library
CustomerProfileExType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerProfileExType _
    Inherits CustomerProfileBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerProfileExType : CustomerProfileBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerProfileExType : public CustomerProfileBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerProfileExType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerProfileExType',
    InSite.Domain.AuthorizeNetCIMService.CustomerProfileBaseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileBaseType
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileExType
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileMaskedType

See Also

CustomerProfileExType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileExType Members

[image] [image]

.NET Framework Class Library
CustomerProfileExType Members
CustomerProfileExType Class Constructors Methods Properties See Also Send Feedback

The CustomerProfileExType type exposes the following members.

Constructors

Name | Description
CustomerProfileExType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
customerProfileId |
description | (Inherited from CustomerProfileBaseType.)
email | (Inherited from CustomerProfileBaseType.)
merchantCustomerId | (Inherited from CustomerProfileBaseType.)

See Also

CustomerProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileExType Constructor

[image]

.NET Framework Class Library
CustomerProfileExType Constructor
CustomerProfileExType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerProfileExType()
Visual C++
public:
CustomerProfileExType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerProfileExType = function();

See Also

CustomerProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileExType Methods

[image] [image]

.NET Framework Class Library
CustomerProfileExType Methods
CustomerProfileExType Class See Also Send Feedback

The CustomerProfileExType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileExType Properties

[image] [image]

.NET Framework Class Library
CustomerProfileExType Properties
CustomerProfileExType Class See Also Send Feedback

The CustomerProfileExType type exposes the following members.

Properties

Name | Description
customerProfileId |
description | (Inherited from CustomerProfileBaseType.)
email | (Inherited from CustomerProfileBaseType.)
merchantCustomerId | (Inherited from CustomerProfileBaseType.)

See Also

CustomerProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerProfileId Property

[image]

.NET Framework Class Library
CustomerProfileExType..::.customerProfileId Property
CustomerProfileExType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerProfileId As Long
C#
public long customerProfileId { get; set; }
Visual C++
public:
property long long customerProfileId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerProfileId();
function set_customerProfileId(value);

Remarks

See Also

CustomerProfileExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileMaskedType Class

[image]

.NET Framework Class Library
CustomerProfileMaskedType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerProfileMaskedType _
    Inherits CustomerProfileExType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerProfileMaskedType : CustomerProfileExType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerProfileMaskedType : public CustomerProfileExType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerProfileMaskedType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerProfileMaskedType',
    InSite.Domain.AuthorizeNetCIMService.CustomerProfileExType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileBaseType
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileExType
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileMaskedType

See Also

CustomerProfileMaskedType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileMaskedType Members

[image] [image]

.NET Framework Class Library
CustomerProfileMaskedType Members
CustomerProfileMaskedType Class Constructors Methods Properties See Also Send Feedback

The CustomerProfileMaskedType type exposes the following members.

Constructors

Name | Description
CustomerProfileMaskedType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
customerProfileId | (Inherited from CustomerProfileExType.)
description | (Inherited from CustomerProfileBaseType.)
email | (Inherited from CustomerProfileBaseType.)
merchantCustomerId | (Inherited from CustomerProfileBaseType.)
paymentProfiles |
shipToList |

See Also

CustomerProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileMaskedType Constructor

[image]

.NET Framework Class Library
CustomerProfileMaskedType Constructor
CustomerProfileMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerProfileMaskedType()
Visual C++
public:
CustomerProfileMaskedType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerProfileMaskedType = function();

See Also

CustomerProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileMaskedType Methods

[image] [image]

.NET Framework Class Library
CustomerProfileMaskedType Methods
CustomerProfileMaskedType Class See Also Send Feedback

The CustomerProfileMaskedType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileMaskedType Properties

[image] [image]

.NET Framework Class Library
CustomerProfileMaskedType Properties
CustomerProfileMaskedType Class See Also Send Feedback

The CustomerProfileMaskedType type exposes the following members.

Properties

Name | Description
customerProfileId | (Inherited from CustomerProfileExType.)
description | (Inherited from CustomerProfileBaseType.)
email | (Inherited from CustomerProfileBaseType.)
merchantCustomerId | (Inherited from CustomerProfileBaseType.)
paymentProfiles |
shipToList |

See Also

CustomerProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


paymentProfiles Property

[image]

.NET Framework Class Library
CustomerProfileMaskedType..::.paymentProfiles Property
CustomerProfileMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentProfiles As CustomerPaymentProfileMaskedType()
C#
public CustomerPaymentProfileMaskedType[] paymentProfiles { get; set; }
Visual C++
public:
property array<CustomerPaymentProfileMaskedType^>^ paymentProfiles {
    array<CustomerPaymentProfileMaskedType^>^ get ();
    void set (array<CustomerPaymentProfileMaskedType^>^ value);
}
JavaScript
function get_paymentProfiles();
function set_paymentProfiles(value);

Remarks

See Also

CustomerProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


shipToList Property

[image]

.NET Framework Class Library
CustomerProfileMaskedType..::.shipToList Property
CustomerProfileMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToList As CustomerAddressExType()
C#
public CustomerAddressExType[] shipToList { get; set; }
Visual C++
public:
property array<CustomerAddressExType^>^ shipToList {
    array<CustomerAddressExType^>^ get ();
    void set (array<CustomerAddressExType^>^ value);
}
JavaScript
function get_shipToList();
function set_shipToList(value);

Remarks

See Also

CustomerProfileMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileType Class

[image]

.NET Framework Class Library
CustomerProfileType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerProfileType _
    Inherits CustomerProfileBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerProfileType : CustomerProfileBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerProfileType : public CustomerProfileBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerProfileType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerProfileType',
    InSite.Domain.AuthorizeNetCIMService.CustomerProfileBaseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileBaseType
InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileType

See Also

CustomerProfileType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileType Members

[image] [image]

.NET Framework Class Library
CustomerProfileType Members
CustomerProfileType Class Constructors Methods Properties See Also Send Feedback

The CustomerProfileType type exposes the following members.

Constructors

Name | Description
CustomerProfileType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
description | (Inherited from CustomerProfileBaseType.)
email | (Inherited from CustomerProfileBaseType.)
merchantCustomerId | (Inherited from CustomerProfileBaseType.)
paymentProfiles |
shipToList |

See Also

CustomerProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileType Constructor

[image]

.NET Framework Class Library
CustomerProfileType Constructor
CustomerProfileType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerProfileType()
Visual C++
public:
CustomerProfileType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerProfileType = function();

See Also

CustomerProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileType Methods

[image] [image]

.NET Framework Class Library
CustomerProfileType Methods
CustomerProfileType Class See Also Send Feedback

The CustomerProfileType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerProfileType Properties

[image] [image]

.NET Framework Class Library
CustomerProfileType Properties
CustomerProfileType Class See Also Send Feedback

The CustomerProfileType type exposes the following members.

Properties

Name | Description
description | (Inherited from CustomerProfileBaseType.)
email | (Inherited from CustomerProfileBaseType.)
merchantCustomerId | (Inherited from CustomerProfileBaseType.)
paymentProfiles |
shipToList |

See Also

CustomerProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


paymentProfiles Property

[image]

.NET Framework Class Library
CustomerProfileType..::.paymentProfiles Property
CustomerProfileType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentProfiles As CustomerPaymentProfileType()
C#
public CustomerPaymentProfileType[] paymentProfiles { get; set; }
Visual C++
public:
property array<CustomerPaymentProfileType^>^ paymentProfiles {
    array<CustomerPaymentProfileType^>^ get ();
    void set (array<CustomerPaymentProfileType^>^ value);
}
JavaScript
function get_paymentProfiles();
function set_paymentProfiles(value);

Remarks

See Also

CustomerProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


shipToList Property

[image]

.NET Framework Class Library
CustomerProfileType..::.shipToList Property
CustomerProfileType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToList As CustomerAddressType()
C#
public CustomerAddressType[] shipToList { get; set; }
Visual C++
public:
property array<CustomerAddressType^>^ shipToList {
    array<CustomerAddressType^>^ get ();
    void set (array<CustomerAddressType^>^ value);
}
JavaScript
function get_shipToList();
function set_shipToList(value);

Remarks

See Also

CustomerProfileType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerType Class

[image]

.NET Framework Class Library
CustomerType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class CustomerType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class CustomerType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class CustomerType
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.CustomerType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.CustomerType

See Also

CustomerType Members
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerType Members

[image] [image]

.NET Framework Class Library
CustomerType Members
CustomerType Class Constructors Methods Properties See Also Send Feedback

The CustomerType type exposes the following members.

Constructors

Name | Description
CustomerType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
driversLicense |
email |
faxNumber |
id |
phoneNumber |
taxId |
type |
typeSpecified |

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerType Constructor

[image]

.NET Framework Class Library
CustomerType Constructor
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerType()
Visual C++
public:
CustomerType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerType = function();

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerType Methods

[image] [image]

.NET Framework Class Library
CustomerType Methods
CustomerType Class See Also Send Feedback

The CustomerType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerType Properties

[image] [image]

.NET Framework Class Library
CustomerType Properties
CustomerType Class See Also Send Feedback

The CustomerType type exposes the following members.

Properties

Name | Description
driversLicense |
email |
faxNumber |
id |
phoneNumber |
taxId |
type |
typeSpecified |

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


driversLicense Property

[image]

.NET Framework Class Library
CustomerType..::.driversLicense Property
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property driversLicense As DriversLicenseType
C#
public DriversLicenseType driversLicense { get; set; }
Visual C++
public:
property DriversLicenseType^ driversLicense {
    DriversLicenseType^ get ();
    void set (DriversLicenseType^ value);
}
JavaScript
function get_driversLicense();
function set_driversLicense(value);

Remarks

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


email Property

[image]

.NET Framework Class Library
CustomerType..::.email Property
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property email As String
C#
public string email { get; set; }
Visual C++
public:
property String^ email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

Remarks

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


faxNumber Property

[image]

.NET Framework Class Library
CustomerType..::.faxNumber Property
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property faxNumber As String
C#
public string faxNumber { get; set; }
Visual C++
public:
property String^ faxNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_faxNumber();
function set_faxNumber(value);

Remarks

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


id Property

[image]

.NET Framework Class Library
CustomerType..::.id Property
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property id As String
C#
public string id { get; set; }
Visual C++
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


phoneNumber Property

[image]

.NET Framework Class Library
CustomerType..::.phoneNumber Property
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property phoneNumber As String
C#
public string phoneNumber { get; set; }
Visual C++
public:
property String^ phoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


taxId Property

[image]

.NET Framework Class Library
CustomerType..::.taxId Property
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxId As String
C#
public string taxId { get; set; }
Visual C++
public:
property String^ taxId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxId();
function set_taxId(value);

Remarks

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


type Property

[image]

.NET Framework Class Library
CustomerType..::.type Property
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property type As CustomerTypeEnum
C#
public CustomerTypeEnum type { get; set; }
Visual C++
public:
property CustomerTypeEnum type {
    CustomerTypeEnum get ();
    void set (CustomerTypeEnum value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


typeSpecified Property

[image]

.NET Framework Class Library
CustomerType..::.typeSpecified Property
CustomerType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property typeSpecified As Boolean
C#
public bool typeSpecified { get; set; }
Visual C++
public:
property bool typeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_typeSpecified();
function set_typeSpecified(value);

Remarks

See Also

CustomerType Class
InSite.Domain.AuthorizeNetCIMService Namespace


CustomerTypeEnum Enumeration

[image]

.NET Framework Class Library
CustomerTypeEnum Enumeration
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Enumeration CustomerTypeEnum
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public enum CustomerTypeEnum
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public enum class CustomerTypeEnum
JavaScript
InSite.Domain.AuthorizeNetCIMService.CustomerTypeEnum = function();
InSite.Domain.AuthorizeNetCIMService.CustomerTypeEnum.createEnum('InSite.Domain.AuthorizeNetCIMService.CustomerTypeEnum', false);

Members

Member name | Description
individual |
business |

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
DeleteCustomerPaymentProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class DeleteCustomerPaymentProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class DeleteCustomerPaymentProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class DeleteCustomerPaymentProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerPaymentProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DeleteCustomerPaymentProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerPaymentProfileCompletedEventArgs

See Also

DeleteCustomerPaymentProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
DeleteCustomerPaymentProfileCompletedEventArgs Members
DeleteCustomerPaymentProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The DeleteCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

DeleteCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
DeleteCustomerPaymentProfileCompletedEventArgs Methods
DeleteCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The DeleteCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
DeleteCustomerPaymentProfileCompletedEventArgs Properties
DeleteCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The DeleteCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

DeleteCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
DeleteCustomerPaymentProfileCompletedEventArgs..::.Result Property
DeleteCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DeleteCustomerPaymentProfileResponseType
C#
public DeleteCustomerPaymentProfileResponseType Result { get; }
Visual C++
public:
property DeleteCustomerPaymentProfileResponseType^ Result {
    DeleteCustomerPaymentProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

DeleteCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
DeleteCustomerPaymentProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub DeleteCustomerPaymentProfileCompletedEventHandler ( _
    sender As Object, _
    e As DeleteCustomerPaymentProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void DeleteCustomerPaymentProfileCompletedEventHandler(
    Object sender,
    DeleteCustomerPaymentProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void DeleteCustomerPaymentProfileCompletedEventHandler(
    Object^ sender,
    DeleteCustomerPaymentProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerPaymentProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileResponseType Class

[image]

.NET Framework Class Library
DeleteCustomerPaymentProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class DeleteCustomerPaymentProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class DeleteCustomerPaymentProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class DeleteCustomerPaymentProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerPaymentProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DeleteCustomerPaymentProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerPaymentProfileResponseType

See Also

DeleteCustomerPaymentProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileResponseType Members

[image] [image]

.NET Framework Class Library
DeleteCustomerPaymentProfileResponseType Members
DeleteCustomerPaymentProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The DeleteCustomerPaymentProfileResponseType type exposes the following members.

Constructors

Name | Description
DeleteCustomerPaymentProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

DeleteCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileResponseType Constructor

[image]

.NET Framework Class Library
DeleteCustomerPaymentProfileResponseType Constructor
DeleteCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DeleteCustomerPaymentProfileResponseType()
Visual C++
public:
DeleteCustomerPaymentProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerPaymentProfileResponseType = function();

See Also

DeleteCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileResponseType Methods

[image] [image]

.NET Framework Class Library
DeleteCustomerPaymentProfileResponseType Methods
DeleteCustomerPaymentProfileResponseType Class See Also Send Feedback

The DeleteCustomerPaymentProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileResponseType Properties

[image] [image]

.NET Framework Class Library
DeleteCustomerPaymentProfileResponseType Properties
DeleteCustomerPaymentProfileResponseType Class See Also Send Feedback

The DeleteCustomerPaymentProfileResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

DeleteCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
DeleteCustomerProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class DeleteCustomerProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class DeleteCustomerProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class DeleteCustomerProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DeleteCustomerProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerProfileCompletedEventArgs

See Also

DeleteCustomerProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
DeleteCustomerProfileCompletedEventArgs Members
DeleteCustomerProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The DeleteCustomerProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

DeleteCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
DeleteCustomerProfileCompletedEventArgs Methods
DeleteCustomerProfileCompletedEventArgs Class See Also Send Feedback

The DeleteCustomerProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
DeleteCustomerProfileCompletedEventArgs Properties
DeleteCustomerProfileCompletedEventArgs Class See Also Send Feedback

The DeleteCustomerProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

DeleteCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
DeleteCustomerProfileCompletedEventArgs..::.Result Property
DeleteCustomerProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DeleteCustomerProfileResponseType
C#
public DeleteCustomerProfileResponseType Result { get; }
Visual C++
public:
property DeleteCustomerProfileResponseType^ Result {
    DeleteCustomerProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

DeleteCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
DeleteCustomerProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub DeleteCustomerProfileCompletedEventHandler ( _
    sender As Object, _
    e As DeleteCustomerProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void DeleteCustomerProfileCompletedEventHandler(
    Object sender,
    DeleteCustomerProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void DeleteCustomerProfileCompletedEventHandler(
    Object^ sender,
    DeleteCustomerProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileResponseType Class

[image]

.NET Framework Class Library
DeleteCustomerProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class DeleteCustomerProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class DeleteCustomerProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class DeleteCustomerProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DeleteCustomerProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerProfileResponseType

See Also

DeleteCustomerProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileResponseType Members

[image] [image]

.NET Framework Class Library
DeleteCustomerProfileResponseType Members
DeleteCustomerProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The DeleteCustomerProfileResponseType type exposes the following members.

Constructors

Name | Description
DeleteCustomerProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

DeleteCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileResponseType Constructor

[image]

.NET Framework Class Library
DeleteCustomerProfileResponseType Constructor
DeleteCustomerProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DeleteCustomerProfileResponseType()
Visual C++
public:
DeleteCustomerProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerProfileResponseType = function();

See Also

DeleteCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileResponseType Methods

[image] [image]

.NET Framework Class Library
DeleteCustomerProfileResponseType Methods
DeleteCustomerProfileResponseType Class See Also Send Feedback

The DeleteCustomerProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileResponseType Properties

[image] [image]

.NET Framework Class Library
DeleteCustomerProfileResponseType Properties
DeleteCustomerProfileResponseType Class See Also Send Feedback

The DeleteCustomerProfileResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

DeleteCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressCompletedEventArgs Class

[image]

.NET Framework Class Library
DeleteCustomerShippingAddressCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class DeleteCustomerShippingAddressCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class DeleteCustomerShippingAddressCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class DeleteCustomerShippingAddressCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerShippingAddressCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DeleteCustomerShippingAddressCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerShippingAddressCompletedEventArgs

See Also

DeleteCustomerShippingAddressCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
DeleteCustomerShippingAddressCompletedEventArgs Members
DeleteCustomerShippingAddressCompletedEventArgs Class Methods Properties See Also Send Feedback

The DeleteCustomerShippingAddressCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

DeleteCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
DeleteCustomerShippingAddressCompletedEventArgs Methods
DeleteCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

The DeleteCustomerShippingAddressCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
DeleteCustomerShippingAddressCompletedEventArgs Properties
DeleteCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

The DeleteCustomerShippingAddressCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

DeleteCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
DeleteCustomerShippingAddressCompletedEventArgs..::.Result Property
DeleteCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DeleteCustomerShippingAddressResponseType
C#
public DeleteCustomerShippingAddressResponseType Result { get; }
Visual C++
public:
property DeleteCustomerShippingAddressResponseType^ Result {
    DeleteCustomerShippingAddressResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

DeleteCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressCompletedEventHandler Delegate

[image]

.NET Framework Class Library
DeleteCustomerShippingAddressCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub DeleteCustomerShippingAddressCompletedEventHandler ( _
    sender As Object, _
    e As DeleteCustomerShippingAddressCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void DeleteCustomerShippingAddressCompletedEventHandler(
    Object sender,
    DeleteCustomerShippingAddressCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void DeleteCustomerShippingAddressCompletedEventHandler(
    Object^ sender,
    DeleteCustomerShippingAddressCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerShippingAddressCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressResponseType Class

[image]

.NET Framework Class Library
DeleteCustomerShippingAddressResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class DeleteCustomerShippingAddressResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class DeleteCustomerShippingAddressResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class DeleteCustomerShippingAddressResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerShippingAddressResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DeleteCustomerShippingAddressResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.DeleteCustomerShippingAddressResponseType

See Also

DeleteCustomerShippingAddressResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressResponseType Members

[image] [image]

.NET Framework Class Library
DeleteCustomerShippingAddressResponseType Members
DeleteCustomerShippingAddressResponseType Class Constructors Methods Properties See Also Send Feedback

The DeleteCustomerShippingAddressResponseType type exposes the following members.

Constructors

Name | Description
DeleteCustomerShippingAddressResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

DeleteCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressResponseType Constructor

[image]

.NET Framework Class Library
DeleteCustomerShippingAddressResponseType Constructor
DeleteCustomerShippingAddressResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DeleteCustomerShippingAddressResponseType()
Visual C++
public:
DeleteCustomerShippingAddressResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.DeleteCustomerShippingAddressResponseType = function();

See Also

DeleteCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressResponseType Methods

[image] [image]

.NET Framework Class Library
DeleteCustomerShippingAddressResponseType Methods
DeleteCustomerShippingAddressResponseType Class See Also Send Feedback

The DeleteCustomerShippingAddressResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressResponseType Properties

[image] [image]

.NET Framework Class Library
DeleteCustomerShippingAddressResponseType Properties
DeleteCustomerShippingAddressResponseType Class See Also Send Feedback

The DeleteCustomerShippingAddressResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

DeleteCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseBaseType Class

[image]

.NET Framework Class Library
DriversLicenseBaseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class DriversLicenseBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class DriversLicenseBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class DriversLicenseBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.DriversLicenseBaseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DriversLicenseBaseType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.DriversLicenseBaseType
InSite.Domain.AuthorizeNetCIMService..::.DriversLicenseMaskedType
InSite.Domain.AuthorizeNetCIMService..::.DriversLicenseType

See Also

DriversLicenseBaseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseBaseType Members

[image] [image]

.NET Framework Class Library
DriversLicenseBaseType Members
DriversLicenseBaseType Class Constructors Methods Properties See Also Send Feedback

The DriversLicenseBaseType type exposes the following members.

Constructors

Name | Description
DriversLicenseBaseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
state |

See Also

DriversLicenseBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseBaseType Constructor

[image]

.NET Framework Class Library
DriversLicenseBaseType Constructor
DriversLicenseBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DriversLicenseBaseType()
Visual C++
public:
DriversLicenseBaseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.DriversLicenseBaseType = function();

See Also

DriversLicenseBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseBaseType Methods

[image] [image]

.NET Framework Class Library
DriversLicenseBaseType Methods
DriversLicenseBaseType Class See Also Send Feedback

The DriversLicenseBaseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DriversLicenseBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseBaseType Properties

[image] [image]

.NET Framework Class Library
DriversLicenseBaseType Properties
DriversLicenseBaseType Class See Also Send Feedback

The DriversLicenseBaseType type exposes the following members.

Properties

Name | Description
state |

See Also

DriversLicenseBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


state Property

[image]

.NET Framework Class Library
DriversLicenseBaseType..::.state Property
DriversLicenseBaseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

DriversLicenseBaseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseMaskedType Class

[image]

.NET Framework Class Library
DriversLicenseMaskedType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class DriversLicenseMaskedType _
    Inherits DriversLicenseBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class DriversLicenseMaskedType : DriversLicenseBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class DriversLicenseMaskedType : public DriversLicenseBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.DriversLicenseMaskedType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DriversLicenseMaskedType',
    InSite.Domain.AuthorizeNetCIMService.DriversLicenseBaseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.DriversLicenseBaseType
InSite.Domain.AuthorizeNetCIMService..::.DriversLicenseMaskedType

See Also

DriversLicenseMaskedType Members
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseMaskedType Members

[image] [image]

.NET Framework Class Library
DriversLicenseMaskedType Members
DriversLicenseMaskedType Class Constructors Methods Properties See Also Send Feedback

The DriversLicenseMaskedType type exposes the following members.

Constructors

Name | Description
DriversLicenseMaskedType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
dateOfBirth |
number |
state | (Inherited from DriversLicenseBaseType.)

See Also

DriversLicenseMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseMaskedType Constructor

[image]

.NET Framework Class Library
DriversLicenseMaskedType Constructor
DriversLicenseMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DriversLicenseMaskedType()
Visual C++
public:
DriversLicenseMaskedType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.DriversLicenseMaskedType = function();

See Also

DriversLicenseMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseMaskedType Methods

[image] [image]

.NET Framework Class Library
DriversLicenseMaskedType Methods
DriversLicenseMaskedType Class See Also Send Feedback

The DriversLicenseMaskedType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DriversLicenseMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseMaskedType Properties

[image] [image]

.NET Framework Class Library
DriversLicenseMaskedType Properties
DriversLicenseMaskedType Class See Also Send Feedback

The DriversLicenseMaskedType type exposes the following members.

Properties

Name | Description
dateOfBirth |
number |
state | (Inherited from DriversLicenseBaseType.)

See Also

DriversLicenseMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


dateOfBirth Property

[image]

.NET Framework Class Library
DriversLicenseMaskedType..::.dateOfBirth Property
DriversLicenseMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dateOfBirth As String
C#
public string dateOfBirth { get; set; }
Visual C++
public:
property String^ dateOfBirth {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dateOfBirth();
function set_dateOfBirth(value);

Remarks

See Also

DriversLicenseMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


number Property

[image]

.NET Framework Class Library
DriversLicenseMaskedType..::.number Property
DriversLicenseMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property number As String
C#
public string number { get; set; }
Visual C++
public:
property String^ number {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_number();
function set_number(value);

Remarks

See Also

DriversLicenseMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseType Class

[image]

.NET Framework Class Library
DriversLicenseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class DriversLicenseType _
    Inherits DriversLicenseBaseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class DriversLicenseType : DriversLicenseBaseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class DriversLicenseType : public DriversLicenseBaseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.DriversLicenseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.DriversLicenseType',
    InSite.Domain.AuthorizeNetCIMService.DriversLicenseBaseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.DriversLicenseBaseType
InSite.Domain.AuthorizeNetCIMService..::.DriversLicenseType

See Also

DriversLicenseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseType Members

[image] [image]

.NET Framework Class Library
DriversLicenseType Members
DriversLicenseType Class Constructors Methods Properties See Also Send Feedback

The DriversLicenseType type exposes the following members.

Constructors

Name | Description
DriversLicenseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
dateOfBirth |
number |
state | (Inherited from DriversLicenseBaseType.)

See Also

DriversLicenseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseType Constructor

[image]

.NET Framework Class Library
DriversLicenseType Constructor
DriversLicenseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DriversLicenseType()
Visual C++
public:
DriversLicenseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.DriversLicenseType = function();

See Also

DriversLicenseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseType Methods

[image] [image]

.NET Framework Class Library
DriversLicenseType Methods
DriversLicenseType Class See Also Send Feedback

The DriversLicenseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DriversLicenseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


DriversLicenseType Properties

[image] [image]

.NET Framework Class Library
DriversLicenseType Properties
DriversLicenseType Class See Also Send Feedback

The DriversLicenseType type exposes the following members.

Properties

Name | Description
dateOfBirth |
number |
state | (Inherited from DriversLicenseBaseType.)

See Also

DriversLicenseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


dateOfBirth Property

[image]

.NET Framework Class Library
DriversLicenseType..::.dateOfBirth Property
DriversLicenseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dateOfBirth As DateTime
C#
public DateTime dateOfBirth { get; set; }
Visual C++
public:
property DateTime dateOfBirth {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_dateOfBirth();
function set_dateOfBirth(value);

Remarks

See Also

DriversLicenseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


number Property

[image]

.NET Framework Class Library
DriversLicenseType..::.number Property
DriversLicenseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property number As String
C#
public string number { get; set; }
Visual C++
public:
property String^ number {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_number();
function set_number(value);

Remarks

See Also

DriversLicenseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


EcheckTypeEnum Enumeration

[image]

.NET Framework Class Library
EcheckTypeEnum Enumeration
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Enumeration EcheckTypeEnum
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public enum EcheckTypeEnum
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public enum class EcheckTypeEnum
JavaScript
InSite.Domain.AuthorizeNetCIMService.EcheckTypeEnum = function();
InSite.Domain.AuthorizeNetCIMService.EcheckTypeEnum.createEnum('InSite.Domain.AuthorizeNetCIMService.EcheckTypeEnum', false);

Members

Member name | Description
PPD |
WEB |
CCD |
TEL |

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


ExtendedAmountType Class

[image]

.NET Framework Class Library
ExtendedAmountType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ExtendedAmountType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ExtendedAmountType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ExtendedAmountType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ExtendedAmountType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ExtendedAmountType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ExtendedAmountType

See Also

ExtendedAmountType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ExtendedAmountType Members

[image] [image]

.NET Framework Class Library
ExtendedAmountType Members
ExtendedAmountType Class Constructors Methods Properties See Also Send Feedback

The ExtendedAmountType type exposes the following members.

Constructors

Name | Description
ExtendedAmountType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
description |
name |

See Also

ExtendedAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ExtendedAmountType Constructor

[image]

.NET Framework Class Library
ExtendedAmountType Constructor
ExtendedAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExtendedAmountType()
Visual C++
public:
ExtendedAmountType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ExtendedAmountType = function();

See Also

ExtendedAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ExtendedAmountType Methods

[image] [image]

.NET Framework Class Library
ExtendedAmountType Methods
ExtendedAmountType Class See Also Send Feedback

The ExtendedAmountType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtendedAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ExtendedAmountType Properties

[image] [image]

.NET Framework Class Library
ExtendedAmountType Properties
ExtendedAmountType Class See Also Send Feedback

The ExtendedAmountType type exposes the following members.

Properties

Name | Description
amount |
description |
name |

See Also

ExtendedAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


amount Property

[image]

.NET Framework Class Library
ExtendedAmountType..::.amount Property
ExtendedAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As Decimal
C#
public decimal amount { get; set; }
Visual C++
public:
property Decimal amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

ExtendedAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


description Property

[image]

.NET Framework Class Library
ExtendedAmountType..::.description Property
ExtendedAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property description As String
C#
public string description { get; set; }
Visual C++
public:
property String^ description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

ExtendedAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


name Property

[image]

.NET Framework Class Library
ExtendedAmountType..::.name Property
ExtendedAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String
C#
public string name { get; set; }
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

ExtendedAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
GetCustomerPaymentProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class GetCustomerPaymentProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class GetCustomerPaymentProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class GetCustomerPaymentProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerPaymentProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.GetCustomerPaymentProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerPaymentProfileCompletedEventArgs

See Also

GetCustomerPaymentProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetCustomerPaymentProfileCompletedEventArgs Members
GetCustomerPaymentProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetCustomerPaymentProfileCompletedEventArgs Methods
GetCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The GetCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetCustomerPaymentProfileCompletedEventArgs Properties
GetCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The GetCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
GetCustomerPaymentProfileCompletedEventArgs..::.Result Property
GetCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As GetCustomerPaymentProfileResponseType
C#
public GetCustomerPaymentProfileResponseType Result { get; }
Visual C++
public:
property GetCustomerPaymentProfileResponseType^ Result {
    GetCustomerPaymentProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetCustomerPaymentProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub GetCustomerPaymentProfileCompletedEventHandler ( _
    sender As Object, _
    e As GetCustomerPaymentProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void GetCustomerPaymentProfileCompletedEventHandler(
    Object sender,
    GetCustomerPaymentProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void GetCustomerPaymentProfileCompletedEventHandler(
    Object^ sender,
    GetCustomerPaymentProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.GetCustomerPaymentProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileResponseType Class

[image]

.NET Framework Class Library
GetCustomerPaymentProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class GetCustomerPaymentProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class GetCustomerPaymentProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class GetCustomerPaymentProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerPaymentProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.GetCustomerPaymentProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerPaymentProfileResponseType

See Also

GetCustomerPaymentProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileResponseType Members

[image] [image]

.NET Framework Class Library
GetCustomerPaymentProfileResponseType Members
GetCustomerPaymentProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The GetCustomerPaymentProfileResponseType type exposes the following members.

Constructors

Name | Description
GetCustomerPaymentProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
paymentProfile |
resultCode | (Inherited from ANetApiResponseType.)

See Also

GetCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileResponseType Constructor

[image]

.NET Framework Class Library
GetCustomerPaymentProfileResponseType Constructor
GetCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GetCustomerPaymentProfileResponseType()
Visual C++
public:
GetCustomerPaymentProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerPaymentProfileResponseType = function();

See Also

GetCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileResponseType Methods

[image] [image]

.NET Framework Class Library
GetCustomerPaymentProfileResponseType Methods
GetCustomerPaymentProfileResponseType Class See Also Send Feedback

The GetCustomerPaymentProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileResponseType Properties

[image] [image]

.NET Framework Class Library
GetCustomerPaymentProfileResponseType Properties
GetCustomerPaymentProfileResponseType Class See Also Send Feedback

The GetCustomerPaymentProfileResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
paymentProfile |
resultCode | (Inherited from ANetApiResponseType.)

See Also

GetCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


paymentProfile Property

[image]

.NET Framework Class Library
GetCustomerPaymentProfileResponseType..::.paymentProfile Property
GetCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentProfile As CustomerPaymentProfileMaskedType
C#
public CustomerPaymentProfileMaskedType paymentProfile { get; set; }
Visual C++
public:
property CustomerPaymentProfileMaskedType^ paymentProfile {
    CustomerPaymentProfileMaskedType^ get ();
    void set (CustomerPaymentProfileMaskedType^ value);
}
JavaScript
function get_paymentProfile();
function set_paymentProfile(value);

Remarks

See Also

GetCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
GetCustomerProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class GetCustomerProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class GetCustomerProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class GetCustomerProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.GetCustomerProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerProfileCompletedEventArgs

See Also

GetCustomerProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetCustomerProfileCompletedEventArgs Members
GetCustomerProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetCustomerProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetCustomerProfileCompletedEventArgs Methods
GetCustomerProfileCompletedEventArgs Class See Also Send Feedback

The GetCustomerProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetCustomerProfileCompletedEventArgs Properties
GetCustomerProfileCompletedEventArgs Class See Also Send Feedback

The GetCustomerProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
GetCustomerProfileCompletedEventArgs..::.Result Property
GetCustomerProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As GetCustomerProfileResponseType
C#
public GetCustomerProfileResponseType Result { get; }
Visual C++
public:
property GetCustomerProfileResponseType^ Result {
    GetCustomerProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetCustomerProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub GetCustomerProfileCompletedEventHandler ( _
    sender As Object, _
    e As GetCustomerProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void GetCustomerProfileCompletedEventHandler(
    Object sender,
    GetCustomerProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void GetCustomerProfileCompletedEventHandler(
    Object^ sender,
    GetCustomerProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.GetCustomerProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileResponseType Class

[image]

.NET Framework Class Library
GetCustomerProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class GetCustomerProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class GetCustomerProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class GetCustomerProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.GetCustomerProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerProfileResponseType

See Also

GetCustomerProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileResponseType Members

[image] [image]

.NET Framework Class Library
GetCustomerProfileResponseType Members
GetCustomerProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The GetCustomerProfileResponseType type exposes the following members.

Constructors

Name | Description
GetCustomerProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
profile |
resultCode | (Inherited from ANetApiResponseType.)

See Also

GetCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileResponseType Constructor

[image]

.NET Framework Class Library
GetCustomerProfileResponseType Constructor
GetCustomerProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GetCustomerProfileResponseType()
Visual C++
public:
GetCustomerProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerProfileResponseType = function();

See Also

GetCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileResponseType Methods

[image] [image]

.NET Framework Class Library
GetCustomerProfileResponseType Methods
GetCustomerProfileResponseType Class See Also Send Feedback

The GetCustomerProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileResponseType Properties

[image] [image]

.NET Framework Class Library
GetCustomerProfileResponseType Properties
GetCustomerProfileResponseType Class See Also Send Feedback

The GetCustomerProfileResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
profile |
resultCode | (Inherited from ANetApiResponseType.)

See Also

GetCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


profile Property

[image]

.NET Framework Class Library
GetCustomerProfileResponseType..::.profile Property
GetCustomerProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property profile As CustomerProfileMaskedType
C#
public CustomerProfileMaskedType profile { get; set; }
Visual C++
public:
property CustomerProfileMaskedType^ profile {
    CustomerProfileMaskedType^ get ();
    void set (CustomerProfileMaskedType^ value);
}
JavaScript
function get_profile();
function set_profile(value);

Remarks

See Also

GetCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressCompletedEventArgs Class

[image]

.NET Framework Class Library
GetCustomerShippingAddressCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class GetCustomerShippingAddressCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class GetCustomerShippingAddressCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class GetCustomerShippingAddressCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerShippingAddressCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.GetCustomerShippingAddressCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerShippingAddressCompletedEventArgs

See Also

GetCustomerShippingAddressCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetCustomerShippingAddressCompletedEventArgs Members
GetCustomerShippingAddressCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetCustomerShippingAddressCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetCustomerShippingAddressCompletedEventArgs Methods
GetCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

The GetCustomerShippingAddressCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetCustomerShippingAddressCompletedEventArgs Properties
GetCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

The GetCustomerShippingAddressCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
GetCustomerShippingAddressCompletedEventArgs..::.Result Property
GetCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As GetCustomerShippingAddressResponseType
C#
public GetCustomerShippingAddressResponseType Result { get; }
Visual C++
public:
property GetCustomerShippingAddressResponseType^ Result {
    GetCustomerShippingAddressResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetCustomerShippingAddressCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub GetCustomerShippingAddressCompletedEventHandler ( _
    sender As Object, _
    e As GetCustomerShippingAddressCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void GetCustomerShippingAddressCompletedEventHandler(
    Object sender,
    GetCustomerShippingAddressCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void GetCustomerShippingAddressCompletedEventHandler(
    Object^ sender,
    GetCustomerShippingAddressCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.GetCustomerShippingAddressCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressResponseType Class

[image]

.NET Framework Class Library
GetCustomerShippingAddressResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class GetCustomerShippingAddressResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class GetCustomerShippingAddressResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class GetCustomerShippingAddressResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerShippingAddressResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.GetCustomerShippingAddressResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.GetCustomerShippingAddressResponseType

See Also

GetCustomerShippingAddressResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressResponseType Members

[image] [image]

.NET Framework Class Library
GetCustomerShippingAddressResponseType Members
GetCustomerShippingAddressResponseType Class Constructors Methods Properties See Also Send Feedback

The GetCustomerShippingAddressResponseType type exposes the following members.

Constructors

Name | Description
GetCustomerShippingAddressResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
address |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

GetCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressResponseType Constructor

[image]

.NET Framework Class Library
GetCustomerShippingAddressResponseType Constructor
GetCustomerShippingAddressResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GetCustomerShippingAddressResponseType()
Visual C++
public:
GetCustomerShippingAddressResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.GetCustomerShippingAddressResponseType = function();

See Also

GetCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressResponseType Methods

[image] [image]

.NET Framework Class Library
GetCustomerShippingAddressResponseType Methods
GetCustomerShippingAddressResponseType Class See Also Send Feedback

The GetCustomerShippingAddressResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressResponseType Properties

[image] [image]

.NET Framework Class Library
GetCustomerShippingAddressResponseType Properties
GetCustomerShippingAddressResponseType Class See Also Send Feedback

The GetCustomerShippingAddressResponseType type exposes the following members.

Properties

Name | Description
address |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

GetCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


address Property

[image]

.NET Framework Class Library
GetCustomerShippingAddressResponseType..::.address Property
GetCustomerShippingAddressResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property address As CustomerAddressExType
C#
public CustomerAddressExType address { get; set; }
Visual C++
public:
property CustomerAddressExType^ address {
    CustomerAddressExType^ get ();
    void set (CustomerAddressExType^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

GetCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveCompletedEventArgs Class

[image]

.NET Framework Class Library
IsAliveCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class IsAliveCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class IsAliveCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class IsAliveCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.IsAliveCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.IsAliveCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.IsAliveCompletedEventArgs

See Also

IsAliveCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
IsAliveCompletedEventArgs Members
IsAliveCompletedEventArgs Class Methods Properties See Also Send Feedback

The IsAliveCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

IsAliveCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
IsAliveCompletedEventArgs Methods
IsAliveCompletedEventArgs Class See Also Send Feedback

The IsAliveCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsAliveCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
IsAliveCompletedEventArgs Properties
IsAliveCompletedEventArgs Class See Also Send Feedback

The IsAliveCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

IsAliveCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
IsAliveCompletedEventArgs..::.Result Property
IsAliveCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As ANetApiResponseType
C#
public ANetApiResponseType Result { get; }
Visual C++
public:
property ANetApiResponseType^ Result {
    ANetApiResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

IsAliveCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveCompletedEventHandler Delegate

[image]

.NET Framework Class Library
IsAliveCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub IsAliveCompletedEventHandler ( _
    sender As Object, _
    e As IsAliveCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void IsAliveCompletedEventHandler(
    Object sender,
    IsAliveCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void IsAliveCompletedEventHandler(
    Object^ sender,
    IsAliveCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.IsAliveCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


LineItemType Class

[image]

.NET Framework Class Library
LineItemType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class LineItemType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class LineItemType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class LineItemType
JavaScript
InSite.Domain.AuthorizeNetCIMService.LineItemType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.LineItemType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.LineItemType

See Also

LineItemType Members
InSite.Domain.AuthorizeNetCIMService Namespace


LineItemType Members

[image] [image]

.NET Framework Class Library
LineItemType Members
LineItemType Class Constructors Methods Properties See Also Send Feedback

The LineItemType type exposes the following members.

Constructors

Name | Description
LineItemType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
description |
itemId |
name |
quantity |
taxable |
taxableSpecified |
unitPrice |

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


LineItemType Constructor

[image]

.NET Framework Class Library
LineItemType Constructor
LineItemType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LineItemType()
Visual C++
public:
LineItemType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.LineItemType = function();

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


LineItemType Methods

[image] [image]

.NET Framework Class Library
LineItemType Methods
LineItemType Class See Also Send Feedback

The LineItemType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


LineItemType Properties

[image] [image]

.NET Framework Class Library
LineItemType Properties
LineItemType Class See Also Send Feedback

The LineItemType type exposes the following members.

Properties

Name | Description
description |
itemId |
name |
quantity |
taxable |
taxableSpecified |
unitPrice |

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


description Property

[image]

.NET Framework Class Library
LineItemType..::.description Property
LineItemType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property description As String
C#
public string description { get; set; }
Visual C++
public:
property String^ description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


itemId Property

[image]

.NET Framework Class Library
LineItemType..::.itemId Property
LineItemType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property itemId As String
C#
public string itemId { get; set; }
Visual C++
public:
property String^ itemId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_itemId();
function set_itemId(value);

Remarks

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


name Property

[image]

.NET Framework Class Library
LineItemType..::.name Property
LineItemType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String
C#
public string name { get; set; }
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


quantity Property

[image]

.NET Framework Class Library
LineItemType..::.quantity Property
LineItemType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property quantity As Decimal
C#
public decimal quantity { get; set; }
Visual C++
public:
property Decimal quantity {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_quantity();
function set_quantity(value);

Remarks

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


taxable Property

[image]

.NET Framework Class Library
LineItemType..::.taxable Property
LineItemType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxable As Boolean
C#
public bool taxable { get; set; }
Visual C++
public:
property bool taxable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxable();
function set_taxable(value);

Remarks

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


taxableSpecified Property

[image]

.NET Framework Class Library
LineItemType..::.taxableSpecified Property
LineItemType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxableSpecified As Boolean
C#
public bool taxableSpecified { get; set; }
Visual C++
public:
property bool taxableSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxableSpecified();
function set_taxableSpecified(value);

Remarks

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


unitPrice Property

[image]

.NET Framework Class Library
LineItemType..::.unitPrice Property
LineItemType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property unitPrice As Decimal
C#
public decimal unitPrice { get; set; }
Visual C++
public:
property Decimal unitPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_unitPrice();
function set_unitPrice(value);

Remarks

See Also

LineItemType Class
InSite.Domain.AuthorizeNetCIMService Namespace


MerchantAuthenticationType Class

[image]

.NET Framework Class Library
MerchantAuthenticationType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class MerchantAuthenticationType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class MerchantAuthenticationType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class MerchantAuthenticationType
JavaScript
InSite.Domain.AuthorizeNetCIMService.MerchantAuthenticationType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.MerchantAuthenticationType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType

See Also

MerchantAuthenticationType Members
InSite.Domain.AuthorizeNetCIMService Namespace


MerchantAuthenticationType Members

[image] [image]

.NET Framework Class Library
MerchantAuthenticationType Members
MerchantAuthenticationType Class Constructors Methods Properties See Also Send Feedback

The MerchantAuthenticationType type exposes the following members.

Constructors

Name | Description
MerchantAuthenticationType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
name |
transactionKey |

See Also

MerchantAuthenticationType Class
InSite.Domain.AuthorizeNetCIMService Namespace


MerchantAuthenticationType Constructor

[image]

.NET Framework Class Library
MerchantAuthenticationType Constructor
MerchantAuthenticationType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MerchantAuthenticationType()
Visual C++
public:
MerchantAuthenticationType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.MerchantAuthenticationType = function();

See Also

MerchantAuthenticationType Class
InSite.Domain.AuthorizeNetCIMService Namespace


MerchantAuthenticationType Methods

[image] [image]

.NET Framework Class Library
MerchantAuthenticationType Methods
MerchantAuthenticationType Class See Also Send Feedback

The MerchantAuthenticationType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MerchantAuthenticationType Class
InSite.Domain.AuthorizeNetCIMService Namespace


MerchantAuthenticationType Properties

[image] [image]

.NET Framework Class Library
MerchantAuthenticationType Properties
MerchantAuthenticationType Class See Also Send Feedback

The MerchantAuthenticationType type exposes the following members.

Properties

Name | Description
name |
transactionKey |

See Also

MerchantAuthenticationType Class
InSite.Domain.AuthorizeNetCIMService Namespace


name Property

[image]

.NET Framework Class Library
MerchantAuthenticationType..::.name Property
MerchantAuthenticationType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String
C#
public string name { get; set; }
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

MerchantAuthenticationType Class
InSite.Domain.AuthorizeNetCIMService Namespace


transactionKey Property

[image]

.NET Framework Class Library
MerchantAuthenticationType..::.transactionKey Property
MerchantAuthenticationType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionKey As String
C#
public string transactionKey { get; set; }
Visual C++
public:
property String^ transactionKey {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionKey();
function set_transactionKey(value);

Remarks

See Also

MerchantAuthenticationType Class
InSite.Domain.AuthorizeNetCIMService Namespace


MessagesTypeMessage Class

[image]

.NET Framework Class Library
MessagesTypeMessage Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class MessagesTypeMessage
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class MessagesTypeMessage
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class MessagesTypeMessage
JavaScript
InSite.Domain.AuthorizeNetCIMService.MessagesTypeMessage = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.MessagesTypeMessage');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.MessagesTypeMessage

See Also

MessagesTypeMessage Members
InSite.Domain.AuthorizeNetCIMService Namespace


MessagesTypeMessage Members

[image] [image]

.NET Framework Class Library
MessagesTypeMessage Members
MessagesTypeMessage Class Constructors Methods Properties See Also Send Feedback

The MessagesTypeMessage type exposes the following members.

Constructors

Name | Description
MessagesTypeMessage |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
code |
text |

See Also

MessagesTypeMessage Class
InSite.Domain.AuthorizeNetCIMService Namespace


MessagesTypeMessage Constructor

[image]

.NET Framework Class Library
MessagesTypeMessage Constructor
MessagesTypeMessage Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MessagesTypeMessage()
Visual C++
public:
MessagesTypeMessage()
JavaScript
InSite.Domain.AuthorizeNetCIMService.MessagesTypeMessage = function();

See Also

MessagesTypeMessage Class
InSite.Domain.AuthorizeNetCIMService Namespace


MessagesTypeMessage Methods

[image] [image]

.NET Framework Class Library
MessagesTypeMessage Methods
MessagesTypeMessage Class See Also Send Feedback

The MessagesTypeMessage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessagesTypeMessage Class
InSite.Domain.AuthorizeNetCIMService Namespace


MessagesTypeMessage Properties

[image] [image]

.NET Framework Class Library
MessagesTypeMessage Properties
MessagesTypeMessage Class See Also Send Feedback

The MessagesTypeMessage type exposes the following members.

Properties

Name | Description
code |
text |

See Also

MessagesTypeMessage Class
InSite.Domain.AuthorizeNetCIMService Namespace


code Property

[image]

.NET Framework Class Library
MessagesTypeMessage..::.code Property
MessagesTypeMessage Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property code As String
C#
public string code { get; set; }
Visual C++
public:
property String^ code {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_code();
function set_code(value);

Remarks

See Also

MessagesTypeMessage Class
InSite.Domain.AuthorizeNetCIMService Namespace


text Property

[image]

.NET Framework Class Library
MessagesTypeMessage..::.text Property
MessagesTypeMessage Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property text As String
C#
public string text { get; set; }
Visual C++
public:
property String^ text {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_text();
function set_text(value);

Remarks

See Also

MessagesTypeMessage Class
InSite.Domain.AuthorizeNetCIMService Namespace


MessageTypeEnum Enumeration

[image]

.NET Framework Class Library
MessageTypeEnum Enumeration
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Enumeration MessageTypeEnum
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public enum MessageTypeEnum
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public enum class MessageTypeEnum
JavaScript
InSite.Domain.AuthorizeNetCIMService.MessageTypeEnum = function();
InSite.Domain.AuthorizeNetCIMService.MessageTypeEnum.createEnum('InSite.Domain.AuthorizeNetCIMService.MessageTypeEnum', false);

Members

Member name | Description
Ok |
Error |

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


NameAndAddressType Class

[image]

.NET Framework Class Library
NameAndAddressType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class NameAndAddressType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class NameAndAddressType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class NameAndAddressType
JavaScript
InSite.Domain.AuthorizeNetCIMService.NameAndAddressType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.NameAndAddressType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.NameAndAddressType
InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressType

See Also

NameAndAddressType Members
InSite.Domain.AuthorizeNetCIMService Namespace


NameAndAddressType Members

[image] [image]

.NET Framework Class Library
NameAndAddressType Members
NameAndAddressType Class Constructors Methods Properties See Also Send Feedback

The NameAndAddressType type exposes the following members.

Constructors

Name | Description
NameAndAddressType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
address |
city |
company |
country |
firstName |
lastName |
state |
zip |

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


NameAndAddressType Constructor

[image]

.NET Framework Class Library
NameAndAddressType Constructor
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NameAndAddressType()
Visual C++
public:
NameAndAddressType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.NameAndAddressType = function();

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


NameAndAddressType Methods

[image] [image]

.NET Framework Class Library
NameAndAddressType Methods
NameAndAddressType Class See Also Send Feedback

The NameAndAddressType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


NameAndAddressType Properties

[image] [image]

.NET Framework Class Library
NameAndAddressType Properties
NameAndAddressType Class See Also Send Feedback

The NameAndAddressType type exposes the following members.

Properties

Name | Description
address |
city |
company |
country |
firstName |
lastName |
state |
zip |

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


address Property

[image]

.NET Framework Class Library
NameAndAddressType..::.address Property
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property address As String
C#
public string address { get; set; }
Visual C++
public:
property String^ address {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


city Property

[image]

.NET Framework Class Library
NameAndAddressType..::.city Property
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


company Property

[image]

.NET Framework Class Library
NameAndAddressType..::.company Property
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property company As String
C#
public string company { get; set; }
Visual C++
public:
property String^ company {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_company();
function set_company(value);

Remarks

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


country Property

[image]

.NET Framework Class Library
NameAndAddressType..::.country Property
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property country As String
C#
public string country { get; set; }
Visual C++
public:
property String^ country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

Remarks

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


firstName Property

[image]

.NET Framework Class Library
NameAndAddressType..::.firstName Property
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property firstName As String
C#
public string firstName { get; set; }
Visual C++
public:
property String^ firstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

Remarks

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


lastName Property

[image]

.NET Framework Class Library
NameAndAddressType..::.lastName Property
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property lastName As String
C#
public string lastName { get; set; }
Visual C++
public:
property String^ lastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

Remarks

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


state Property

[image]

.NET Framework Class Library
NameAndAddressType..::.state Property
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


zip Property

[image]

.NET Framework Class Library
NameAndAddressType..::.zip Property
NameAndAddressType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property zip As String
C#
public string zip { get; set; }
Visual C++
public:
property String^ zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

Remarks

See Also

NameAndAddressType Class
InSite.Domain.AuthorizeNetCIMService Namespace


OrderExType Class

[image]

.NET Framework Class Library
OrderExType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class OrderExType _
    Inherits OrderType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class OrderExType : OrderType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class OrderExType : public OrderType
JavaScript
InSite.Domain.AuthorizeNetCIMService.OrderExType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.OrderExType',
    InSite.Domain.AuthorizeNetCIMService.OrderType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.OrderType
InSite.Domain.AuthorizeNetCIMService..::.OrderExType

See Also

OrderExType Members
InSite.Domain.AuthorizeNetCIMService Namespace


OrderExType Members

[image] [image]

.NET Framework Class Library
OrderExType Members
OrderExType Class Constructors Methods Properties See Also Send Feedback

The OrderExType type exposes the following members.

Constructors

Name | Description
OrderExType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
description | (Inherited from OrderType.)
invoiceNumber | (Inherited from OrderType.)
purchaseOrderNumber |

See Also

OrderExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


OrderExType Constructor

[image]

.NET Framework Class Library
OrderExType Constructor
OrderExType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OrderExType()
Visual C++
public:
OrderExType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.OrderExType = function();

See Also

OrderExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


OrderExType Methods

[image] [image]

.NET Framework Class Library
OrderExType Methods
OrderExType Class See Also Send Feedback

The OrderExType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrderExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


OrderExType Properties

[image] [image]

.NET Framework Class Library
OrderExType Properties
OrderExType Class See Also Send Feedback

The OrderExType type exposes the following members.

Properties

Name | Description
description | (Inherited from OrderType.)
invoiceNumber | (Inherited from OrderType.)
purchaseOrderNumber |

See Also

OrderExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


purchaseOrderNumber Property

[image]

.NET Framework Class Library
OrderExType..::.purchaseOrderNumber Property
OrderExType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchaseOrderNumber As String
C#
public string purchaseOrderNumber { get; set; }
Visual C++
public:
property String^ purchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchaseOrderNumber();
function set_purchaseOrderNumber(value);

Remarks

See Also

OrderExType Class
InSite.Domain.AuthorizeNetCIMService Namespace


OrderType Class

[image]

.NET Framework Class Library
OrderType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class OrderType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class OrderType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class OrderType
JavaScript
InSite.Domain.AuthorizeNetCIMService.OrderType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.OrderType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.OrderType
InSite.Domain.AuthorizeNetCIMService..::.OrderExType

See Also

OrderType Members
InSite.Domain.AuthorizeNetCIMService Namespace


OrderType Members

[image] [image]

.NET Framework Class Library
OrderType Members
OrderType Class Constructors Methods Properties See Also Send Feedback

The OrderType type exposes the following members.

Constructors

Name | Description
OrderType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
description |
invoiceNumber |

See Also

OrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


OrderType Constructor

[image]

.NET Framework Class Library
OrderType Constructor
OrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OrderType()
Visual C++
public:
OrderType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.OrderType = function();

See Also

OrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


OrderType Methods

[image] [image]

.NET Framework Class Library
OrderType Methods
OrderType Class See Also Send Feedback

The OrderType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


OrderType Properties

[image] [image]

.NET Framework Class Library
OrderType Properties
OrderType Class See Also Send Feedback

The OrderType type exposes the following members.

Properties

Name | Description
description |
invoiceNumber |

See Also

OrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


description Property

[image]

.NET Framework Class Library
OrderType..::.description Property
OrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property description As String
C#
public string description { get; set; }
Visual C++
public:
property String^ description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

OrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


invoiceNumber Property

[image]

.NET Framework Class Library
OrderType..::.invoiceNumber Property
OrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceNumber As String
C#
public string invoiceNumber { get; set; }
Visual C++
public:
property String^ invoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceNumber();
function set_invoiceNumber(value);

Remarks

See Also

OrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentMaskedType Class

[image]

.NET Framework Class Library
PaymentMaskedType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class PaymentMaskedType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class PaymentMaskedType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class PaymentMaskedType
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentMaskedType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.PaymentMaskedType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.PaymentMaskedType

See Also

PaymentMaskedType Members
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentMaskedType Members

[image] [image]

.NET Framework Class Library
PaymentMaskedType Members
PaymentMaskedType Class Constructors Methods Properties See Also Send Feedback

The PaymentMaskedType type exposes the following members.

Constructors

Name | Description
PaymentMaskedType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item |

See Also

PaymentMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentMaskedType Constructor

[image]

.NET Framework Class Library
PaymentMaskedType Constructor
PaymentMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentMaskedType()
Visual C++
public:
PaymentMaskedType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentMaskedType = function();

See Also

PaymentMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentMaskedType Methods

[image] [image]

.NET Framework Class Library
PaymentMaskedType Methods
PaymentMaskedType Class See Also Send Feedback

The PaymentMaskedType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentMaskedType Properties

[image] [image]

.NET Framework Class Library
PaymentMaskedType Properties
PaymentMaskedType Class See Also Send Feedback

The PaymentMaskedType type exposes the following members.

Properties

Name | Description
Item |

See Also

PaymentMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


Item Property

[image]

.NET Framework Class Library
PaymentMaskedType..::.Item Property
PaymentMaskedType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Item As Object
C#
public Object Item { get; set; }
Visual C++
public:
property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}
JavaScript
function get_item();
function set_item(value);

Remarks

See Also

PaymentMaskedType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleType Class

[image]

.NET Framework Class Library
PaymentScheduleType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class PaymentScheduleType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class PaymentScheduleType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class PaymentScheduleType
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentScheduleType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.PaymentScheduleType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.PaymentScheduleType

See Also

PaymentScheduleType Members
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleType Members

[image] [image]

.NET Framework Class Library
PaymentScheduleType Members
PaymentScheduleType Class Constructors Methods Properties See Also Send Feedback

The PaymentScheduleType type exposes the following members.

Constructors

Name | Description
PaymentScheduleType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
interval |
startDate |
startDateSpecified |
totalOccurrences |
totalOccurrencesSpecified |
trialOccurrences |
trialOccurrencesSpecified |

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleType Constructor

[image]

.NET Framework Class Library
PaymentScheduleType Constructor
PaymentScheduleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentScheduleType()
Visual C++
public:
PaymentScheduleType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentScheduleType = function();

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleType Methods

[image] [image]

.NET Framework Class Library
PaymentScheduleType Methods
PaymentScheduleType Class See Also Send Feedback

The PaymentScheduleType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleType Properties

[image] [image]

.NET Framework Class Library
PaymentScheduleType Properties
PaymentScheduleType Class See Also Send Feedback

The PaymentScheduleType type exposes the following members.

Properties

Name | Description
interval |
startDate |
startDateSpecified |
totalOccurrences |
totalOccurrencesSpecified |
trialOccurrences |
trialOccurrencesSpecified |

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


interval Property

[image]

.NET Framework Class Library
PaymentScheduleType..::.interval Property
PaymentScheduleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property interval As PaymentScheduleTypeInterval
C#
public PaymentScheduleTypeInterval interval { get; set; }
Visual C++
public:
property PaymentScheduleTypeInterval^ interval {
    PaymentScheduleTypeInterval^ get ();
    void set (PaymentScheduleTypeInterval^ value);
}
JavaScript
function get_interval();
function set_interval(value);

Remarks

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


startDate Property

[image]

.NET Framework Class Library
PaymentScheduleType..::.startDate Property
PaymentScheduleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property startDate As DateTime
C#
public DateTime startDate { get; set; }
Visual C++
public:
property DateTime startDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_startDate();
function set_startDate(value);

Remarks

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


startDateSpecified Property

[image]

.NET Framework Class Library
PaymentScheduleType..::.startDateSpecified Property
PaymentScheduleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property startDateSpecified As Boolean
C#
public bool startDateSpecified { get; set; }
Visual C++
public:
property bool startDateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_startDateSpecified();
function set_startDateSpecified(value);

Remarks

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


totalOccurrences Property

[image]

.NET Framework Class Library
PaymentScheduleType..::.totalOccurrences Property
PaymentScheduleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalOccurrences As Short
C#
public short totalOccurrences { get; set; }
Visual C++
public:
property short totalOccurrences {
    short get ();
    void set (short value);
}
JavaScript
function get_totalOccurrences();
function set_totalOccurrences(value);

Remarks

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


totalOccurrencesSpecified Property

[image]

.NET Framework Class Library
PaymentScheduleType..::.totalOccurrencesSpecified Property
PaymentScheduleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalOccurrencesSpecified As Boolean
C#
public bool totalOccurrencesSpecified { get; set; }
Visual C++
public:
property bool totalOccurrencesSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_totalOccurrencesSpecified();
function set_totalOccurrencesSpecified(value);

Remarks

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


trialOccurrences Property

[image]

.NET Framework Class Library
PaymentScheduleType..::.trialOccurrences Property
PaymentScheduleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property trialOccurrences As Short
C#
public short trialOccurrences { get; set; }
Visual C++
public:
property short trialOccurrences {
    short get ();
    void set (short value);
}
JavaScript
function get_trialOccurrences();
function set_trialOccurrences(value);

Remarks

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


trialOccurrencesSpecified Property

[image]

.NET Framework Class Library
PaymentScheduleType..::.trialOccurrencesSpecified Property
PaymentScheduleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property trialOccurrencesSpecified As Boolean
C#
public bool trialOccurrencesSpecified { get; set; }
Visual C++
public:
property bool trialOccurrencesSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_trialOccurrencesSpecified();
function set_trialOccurrencesSpecified(value);

Remarks

See Also

PaymentScheduleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleTypeInterval Class

[image]

.NET Framework Class Library
PaymentScheduleTypeInterval Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class PaymentScheduleTypeInterval
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class PaymentScheduleTypeInterval
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class PaymentScheduleTypeInterval
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentScheduleTypeInterval = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.PaymentScheduleTypeInterval');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.PaymentScheduleTypeInterval

See Also

PaymentScheduleTypeInterval Members
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleTypeInterval Members

[image] [image]

.NET Framework Class Library
PaymentScheduleTypeInterval Members
PaymentScheduleTypeInterval Class Constructors Methods Properties See Also Send Feedback

The PaymentScheduleTypeInterval type exposes the following members.

Constructors

Name | Description
PaymentScheduleTypeInterval |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
length |
unit |

See Also

PaymentScheduleTypeInterval Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleTypeInterval Constructor

[image]

.NET Framework Class Library
PaymentScheduleTypeInterval Constructor
PaymentScheduleTypeInterval Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentScheduleTypeInterval()
Visual C++
public:
PaymentScheduleTypeInterval()
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentScheduleTypeInterval = function();

See Also

PaymentScheduleTypeInterval Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleTypeInterval Methods

[image] [image]

.NET Framework Class Library
PaymentScheduleTypeInterval Methods
PaymentScheduleTypeInterval Class See Also Send Feedback

The PaymentScheduleTypeInterval type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentScheduleTypeInterval Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentScheduleTypeInterval Properties

[image] [image]

.NET Framework Class Library
PaymentScheduleTypeInterval Properties
PaymentScheduleTypeInterval Class See Also Send Feedback

The PaymentScheduleTypeInterval type exposes the following members.

Properties

Name | Description
length |
unit |

See Also

PaymentScheduleTypeInterval Class
InSite.Domain.AuthorizeNetCIMService Namespace


length Property

[image]

.NET Framework Class Library
PaymentScheduleTypeInterval..::.length Property
PaymentScheduleTypeInterval Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property length As Short
C#
public short length { get; set; }
Visual C++
public:
property short length {
    short get ();
    void set (short value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

PaymentScheduleTypeInterval Class
InSite.Domain.AuthorizeNetCIMService Namespace


unit Property

[image]

.NET Framework Class Library
PaymentScheduleTypeInterval..::.unit Property
PaymentScheduleTypeInterval Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property unit As ARBSubscriptionUnitEnum
C#
public ARBSubscriptionUnitEnum unit { get; set; }
Visual C++
public:
property ARBSubscriptionUnitEnum unit {
    ARBSubscriptionUnitEnum get ();
    void set (ARBSubscriptionUnitEnum value);
}
JavaScript
function get_unit();
function set_unit(value);

Remarks

See Also

PaymentScheduleTypeInterval Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentSimpleType Class

[image]

.NET Framework Class Library
PaymentSimpleType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class PaymentSimpleType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class PaymentSimpleType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class PaymentSimpleType
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentSimpleType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.PaymentSimpleType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.PaymentSimpleType

See Also

PaymentSimpleType Members
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentSimpleType Members

[image] [image]

.NET Framework Class Library
PaymentSimpleType Members
PaymentSimpleType Class Constructors Methods Properties See Also Send Feedback

The PaymentSimpleType type exposes the following members.

Constructors

Name | Description
PaymentSimpleType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item |

See Also

PaymentSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentSimpleType Constructor

[image]

.NET Framework Class Library
PaymentSimpleType Constructor
PaymentSimpleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentSimpleType()
Visual C++
public:
PaymentSimpleType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentSimpleType = function();

See Also

PaymentSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentSimpleType Methods

[image] [image]

.NET Framework Class Library
PaymentSimpleType Methods
PaymentSimpleType Class See Also Send Feedback

The PaymentSimpleType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentSimpleType Properties

[image] [image]

.NET Framework Class Library
PaymentSimpleType Properties
PaymentSimpleType Class See Also Send Feedback

The PaymentSimpleType type exposes the following members.

Properties

Name | Description
Item |

See Also

PaymentSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


Item Property

[image]

.NET Framework Class Library
PaymentSimpleType..::.Item Property
PaymentSimpleType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Item As Object
C#
public Object Item { get; set; }
Visual C++
public:
property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}
JavaScript
function get_item();
function set_item(value);

Remarks

See Also

PaymentSimpleType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentType Class

[image]

.NET Framework Class Library
PaymentType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class PaymentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class PaymentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class PaymentType
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.PaymentType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.PaymentType

See Also

PaymentType Members
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentType Members

[image] [image]

.NET Framework Class Library
PaymentType Members
PaymentType Class Constructors Methods Properties See Also Send Feedback

The PaymentType type exposes the following members.

Constructors

Name | Description
PaymentType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item |

See Also

PaymentType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentType Constructor

[image]

.NET Framework Class Library
PaymentType Constructor
PaymentType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentType()
Visual C++
public:
PaymentType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.PaymentType = function();

See Also

PaymentType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentType Methods

[image] [image]

.NET Framework Class Library
PaymentType Methods
PaymentType Class See Also Send Feedback

The PaymentType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentType Class
InSite.Domain.AuthorizeNetCIMService Namespace


PaymentType Properties

[image] [image]

.NET Framework Class Library
PaymentType Properties
PaymentType Class See Also Send Feedback

The PaymentType type exposes the following members.

Properties

Name | Description
Item |

See Also

PaymentType Class
InSite.Domain.AuthorizeNetCIMService Namespace


Item Property

[image]

.NET Framework Class Library
PaymentType..::.Item Property
PaymentType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Item As Object
C#
public Object Item { get; set; }
Visual C++
public:
property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}
JavaScript
function get_item();
function set_item(value);

Remarks

See Also

PaymentType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransactionType Class

[image]

.NET Framework Class Library
ProfileTransactionType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ProfileTransactionType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ProfileTransactionType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ProfileTransactionType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransactionType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ProfileTransactionType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransactionType

See Also

ProfileTransactionType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransactionType Members

[image] [image]

.NET Framework Class Library
ProfileTransactionType Members
ProfileTransactionType Class Constructors Methods Properties See Also Send Feedback

The ProfileTransactionType type exposes the following members.

Constructors

Name | Description
ProfileTransactionType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item |

See Also

ProfileTransactionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransactionType Constructor

[image]

.NET Framework Class Library
ProfileTransactionType Constructor
ProfileTransactionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProfileTransactionType()
Visual C++
public:
ProfileTransactionType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransactionType = function();

See Also

ProfileTransactionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransactionType Methods

[image] [image]

.NET Framework Class Library
ProfileTransactionType Methods
ProfileTransactionType Class See Also Send Feedback

The ProfileTransactionType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileTransactionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransactionType Properties

[image] [image]

.NET Framework Class Library
ProfileTransactionType Properties
ProfileTransactionType Class See Also Send Feedback

The ProfileTransactionType type exposes the following members.

Properties

Name | Description
Item |

See Also

ProfileTransactionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


Item Property

[image]

.NET Framework Class Library
ProfileTransactionType..::.Item Property
ProfileTransactionType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Item As ProfileTransOrderType
C#
public ProfileTransOrderType Item { get; set; }
Visual C++
public:
property ProfileTransOrderType^ Item {
    ProfileTransOrderType^ get ();
    void set (ProfileTransOrderType^ value);
}
JavaScript
function get_item();
function set_item(value);

Remarks

See Also

ProfileTransactionType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAmountType Class

[image]

.NET Framework Class Library
ProfileTransAmountType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ProfileTransAmountType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ProfileTransAmountType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ProfileTransAmountType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransAmountType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ProfileTransAmountType');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAmountType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransOrderType

See Also

ProfileTransAmountType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAmountType Members

[image] [image]

.NET Framework Class Library
ProfileTransAmountType Members
ProfileTransAmountType Class Constructors Methods Properties See Also Send Feedback

The ProfileTransAmountType type exposes the following members.

Constructors

Name | Description
ProfileTransAmountType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
duty |
lineItems |
shipping |
tax |

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAmountType Constructor

[image]

.NET Framework Class Library
ProfileTransAmountType Constructor
ProfileTransAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProfileTransAmountType()
Visual C++
public:
ProfileTransAmountType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransAmountType = function();

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAmountType Methods

[image] [image]

.NET Framework Class Library
ProfileTransAmountType Methods
ProfileTransAmountType Class See Also Send Feedback

The ProfileTransAmountType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAmountType Properties

[image] [image]

.NET Framework Class Library
ProfileTransAmountType Properties
ProfileTransAmountType Class See Also Send Feedback

The ProfileTransAmountType type exposes the following members.

Properties

Name | Description
amount |
duty |
lineItems |
shipping |
tax |

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


amount Property

[image]

.NET Framework Class Library
ProfileTransAmountType..::.amount Property
ProfileTransAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As Decimal
C#
public decimal amount { get; set; }
Visual C++
public:
property Decimal amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


duty Property

[image]

.NET Framework Class Library
ProfileTransAmountType..::.duty Property
ProfileTransAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property duty As ExtendedAmountType
C#
public ExtendedAmountType duty { get; set; }
Visual C++
public:
property ExtendedAmountType^ duty {
    ExtendedAmountType^ get ();
    void set (ExtendedAmountType^ value);
}
JavaScript
function get_duty();
function set_duty(value);

Remarks

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


lineItems Property

[image]

.NET Framework Class Library
ProfileTransAmountType..::.lineItems Property
ProfileTransAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property lineItems As LineItemType()
C#
public LineItemType[] lineItems { get; set; }
Visual C++
public:
property array<LineItemType^>^ lineItems {
    array<LineItemType^>^ get ();
    void set (array<LineItemType^>^ value);
}
JavaScript
function get_lineItems();
function set_lineItems(value);

Remarks

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


shipping Property

[image]

.NET Framework Class Library
ProfileTransAmountType..::.shipping Property
ProfileTransAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipping As ExtendedAmountType
C#
public ExtendedAmountType shipping { get; set; }
Visual C++
public:
property ExtendedAmountType^ shipping {
    ExtendedAmountType^ get ();
    void set (ExtendedAmountType^ value);
}
JavaScript
function get_shipping();
function set_shipping(value);

Remarks

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


tax Property

[image]

.NET Framework Class Library
ProfileTransAmountType..::.tax Property
ProfileTransAmountType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property tax As ExtendedAmountType
C#
public ExtendedAmountType tax { get; set; }
Visual C++
public:
property ExtendedAmountType^ tax {
    ExtendedAmountType^ get ();
    void set (ExtendedAmountType^ value);
}
JavaScript
function get_tax();
function set_tax(value);

Remarks

See Also

ProfileTransAmountType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthCaptureType Class

[image]

.NET Framework Class Library
ProfileTransAuthCaptureType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ProfileTransAuthCaptureType _
    Inherits ProfileTransOrderType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ProfileTransAuthCaptureType : ProfileTransOrderType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ProfileTransAuthCaptureType : public ProfileTransOrderType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransAuthCaptureType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ProfileTransAuthCaptureType',
    InSite.Domain.AuthorizeNetCIMService.ProfileTransOrderType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAmountType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransOrderType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAuthCaptureType

See Also

ProfileTransAuthCaptureType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthCaptureType Members

[image] [image]

.NET Framework Class Library
ProfileTransAuthCaptureType Members
ProfileTransAuthCaptureType Class Constructors Methods Properties See Also Send Feedback

The ProfileTransAuthCaptureType type exposes the following members.

Constructors

Name | Description
ProfileTransAuthCaptureType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount | (Inherited from ProfileTransAmountType.)
cardCode | (Inherited from ProfileTransOrderType.)
customerPaymentProfileId | (Inherited from ProfileTransOrderType.)
customerProfileId | (Inherited from ProfileTransOrderType.)
customerShippingAddressId | (Inherited from ProfileTransOrderType.)
customerShippingAddressIdSpecified | (Inherited from ProfileTransOrderType.)
duty | (Inherited from ProfileTransAmountType.)
lineItems | (Inherited from ProfileTransAmountType.)
order | (Inherited from ProfileTransOrderType.)
recurringBilling | (Inherited from ProfileTransOrderType.)
recurringBillingSpecified | (Inherited from ProfileTransOrderType.)
shipping | (Inherited from ProfileTransAmountType.)
tax | (Inherited from ProfileTransAmountType.)
taxExempt | (Inherited from ProfileTransOrderType.)
taxExemptSpecified | (Inherited from ProfileTransOrderType.)

See Also

ProfileTransAuthCaptureType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthCaptureType Constructor

[image]

.NET Framework Class Library
ProfileTransAuthCaptureType Constructor
ProfileTransAuthCaptureType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProfileTransAuthCaptureType()
Visual C++
public:
ProfileTransAuthCaptureType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransAuthCaptureType = function();

See Also

ProfileTransAuthCaptureType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthCaptureType Methods

[image] [image]

.NET Framework Class Library
ProfileTransAuthCaptureType Methods
ProfileTransAuthCaptureType Class See Also Send Feedback

The ProfileTransAuthCaptureType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileTransAuthCaptureType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthCaptureType Properties

[image] [image]

.NET Framework Class Library
ProfileTransAuthCaptureType Properties
ProfileTransAuthCaptureType Class See Also Send Feedback

The ProfileTransAuthCaptureType type exposes the following members.

Properties

Name | Description
amount | (Inherited from ProfileTransAmountType.)
cardCode | (Inherited from ProfileTransOrderType.)
customerPaymentProfileId | (Inherited from ProfileTransOrderType.)
customerProfileId | (Inherited from ProfileTransOrderType.)
customerShippingAddressId | (Inherited from ProfileTransOrderType.)
customerShippingAddressIdSpecified | (Inherited from ProfileTransOrderType.)
duty | (Inherited from ProfileTransAmountType.)
lineItems | (Inherited from ProfileTransAmountType.)
order | (Inherited from ProfileTransOrderType.)
recurringBilling | (Inherited from ProfileTransOrderType.)
recurringBillingSpecified | (Inherited from ProfileTransOrderType.)
shipping | (Inherited from ProfileTransAmountType.)
tax | (Inherited from ProfileTransAmountType.)
taxExempt | (Inherited from ProfileTransOrderType.)
taxExemptSpecified | (Inherited from ProfileTransOrderType.)

See Also

ProfileTransAuthCaptureType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthOnlyType Class

[image]

.NET Framework Class Library
ProfileTransAuthOnlyType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ProfileTransAuthOnlyType _
    Inherits ProfileTransOrderType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ProfileTransAuthOnlyType : ProfileTransOrderType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ProfileTransAuthOnlyType : public ProfileTransOrderType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransAuthOnlyType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ProfileTransAuthOnlyType',
    InSite.Domain.AuthorizeNetCIMService.ProfileTransOrderType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAmountType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransOrderType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAuthOnlyType

See Also

ProfileTransAuthOnlyType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthOnlyType Members

[image] [image]

.NET Framework Class Library
ProfileTransAuthOnlyType Members
ProfileTransAuthOnlyType Class Constructors Methods Properties See Also Send Feedback

The ProfileTransAuthOnlyType type exposes the following members.

Constructors

Name | Description
ProfileTransAuthOnlyType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount | (Inherited from ProfileTransAmountType.)
cardCode | (Inherited from ProfileTransOrderType.)
customerPaymentProfileId | (Inherited from ProfileTransOrderType.)
customerProfileId | (Inherited from ProfileTransOrderType.)
customerShippingAddressId | (Inherited from ProfileTransOrderType.)
customerShippingAddressIdSpecified | (Inherited from ProfileTransOrderType.)
duty | (Inherited from ProfileTransAmountType.)
lineItems | (Inherited from ProfileTransAmountType.)
order | (Inherited from ProfileTransOrderType.)
recurringBilling | (Inherited from ProfileTransOrderType.)
recurringBillingSpecified | (Inherited from ProfileTransOrderType.)
shipping | (Inherited from ProfileTransAmountType.)
tax | (Inherited from ProfileTransAmountType.)
taxExempt | (Inherited from ProfileTransOrderType.)
taxExemptSpecified | (Inherited from ProfileTransOrderType.)

See Also

ProfileTransAuthOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthOnlyType Constructor

[image]

.NET Framework Class Library
ProfileTransAuthOnlyType Constructor
ProfileTransAuthOnlyType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProfileTransAuthOnlyType()
Visual C++
public:
ProfileTransAuthOnlyType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransAuthOnlyType = function();

See Also

ProfileTransAuthOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthOnlyType Methods

[image] [image]

.NET Framework Class Library
ProfileTransAuthOnlyType Methods
ProfileTransAuthOnlyType Class See Also Send Feedback

The ProfileTransAuthOnlyType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileTransAuthOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransAuthOnlyType Properties

[image] [image]

.NET Framework Class Library
ProfileTransAuthOnlyType Properties
ProfileTransAuthOnlyType Class See Also Send Feedback

The ProfileTransAuthOnlyType type exposes the following members.

Properties

Name | Description
amount | (Inherited from ProfileTransAmountType.)
cardCode | (Inherited from ProfileTransOrderType.)
customerPaymentProfileId | (Inherited from ProfileTransOrderType.)
customerProfileId | (Inherited from ProfileTransOrderType.)
customerShippingAddressId | (Inherited from ProfileTransOrderType.)
customerShippingAddressIdSpecified | (Inherited from ProfileTransOrderType.)
duty | (Inherited from ProfileTransAmountType.)
lineItems | (Inherited from ProfileTransAmountType.)
order | (Inherited from ProfileTransOrderType.)
recurringBilling | (Inherited from ProfileTransOrderType.)
recurringBillingSpecified | (Inherited from ProfileTransOrderType.)
shipping | (Inherited from ProfileTransAmountType.)
tax | (Inherited from ProfileTransAmountType.)
taxExempt | (Inherited from ProfileTransOrderType.)
taxExemptSpecified | (Inherited from ProfileTransOrderType.)

See Also

ProfileTransAuthOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransCaptureOnlyType Class

[image]

.NET Framework Class Library
ProfileTransCaptureOnlyType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ProfileTransCaptureOnlyType _
    Inherits ProfileTransOrderType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ProfileTransCaptureOnlyType : ProfileTransOrderType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ProfileTransCaptureOnlyType : public ProfileTransOrderType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransCaptureOnlyType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ProfileTransCaptureOnlyType',
    InSite.Domain.AuthorizeNetCIMService.ProfileTransOrderType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAmountType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransOrderType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransCaptureOnlyType

See Also

ProfileTransCaptureOnlyType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransCaptureOnlyType Members

[image] [image]

.NET Framework Class Library
ProfileTransCaptureOnlyType Members
ProfileTransCaptureOnlyType Class Constructors Methods Properties See Also Send Feedback

The ProfileTransCaptureOnlyType type exposes the following members.

Constructors

Name | Description
ProfileTransCaptureOnlyType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount | (Inherited from ProfileTransAmountType.)
approvalCode |
cardCode | (Inherited from ProfileTransOrderType.)
customerPaymentProfileId | (Inherited from ProfileTransOrderType.)
customerProfileId | (Inherited from ProfileTransOrderType.)
customerShippingAddressId | (Inherited from ProfileTransOrderType.)
customerShippingAddressIdSpecified | (Inherited from ProfileTransOrderType.)
duty | (Inherited from ProfileTransAmountType.)
lineItems | (Inherited from ProfileTransAmountType.)
order | (Inherited from ProfileTransOrderType.)
recurringBilling | (Inherited from ProfileTransOrderType.)
recurringBillingSpecified | (Inherited from ProfileTransOrderType.)
shipping | (Inherited from ProfileTransAmountType.)
tax | (Inherited from ProfileTransAmountType.)
taxExempt | (Inherited from ProfileTransOrderType.)
taxExemptSpecified | (Inherited from ProfileTransOrderType.)

See Also

ProfileTransCaptureOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransCaptureOnlyType Constructor

[image]

.NET Framework Class Library
ProfileTransCaptureOnlyType Constructor
ProfileTransCaptureOnlyType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProfileTransCaptureOnlyType()
Visual C++
public:
ProfileTransCaptureOnlyType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransCaptureOnlyType = function();

See Also

ProfileTransCaptureOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransCaptureOnlyType Methods

[image] [image]

.NET Framework Class Library
ProfileTransCaptureOnlyType Methods
ProfileTransCaptureOnlyType Class See Also Send Feedback

The ProfileTransCaptureOnlyType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileTransCaptureOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransCaptureOnlyType Properties

[image] [image]

.NET Framework Class Library
ProfileTransCaptureOnlyType Properties
ProfileTransCaptureOnlyType Class See Also Send Feedback

The ProfileTransCaptureOnlyType type exposes the following members.

Properties

Name | Description
amount | (Inherited from ProfileTransAmountType.)
approvalCode |
cardCode | (Inherited from ProfileTransOrderType.)
customerPaymentProfileId | (Inherited from ProfileTransOrderType.)
customerProfileId | (Inherited from ProfileTransOrderType.)
customerShippingAddressId | (Inherited from ProfileTransOrderType.)
customerShippingAddressIdSpecified | (Inherited from ProfileTransOrderType.)
duty | (Inherited from ProfileTransAmountType.)
lineItems | (Inherited from ProfileTransAmountType.)
order | (Inherited from ProfileTransOrderType.)
recurringBilling | (Inherited from ProfileTransOrderType.)
recurringBillingSpecified | (Inherited from ProfileTransOrderType.)
shipping | (Inherited from ProfileTransAmountType.)
tax | (Inherited from ProfileTransAmountType.)
taxExempt | (Inherited from ProfileTransOrderType.)
taxExemptSpecified | (Inherited from ProfileTransOrderType.)

See Also

ProfileTransCaptureOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


approvalCode Property

[image]

.NET Framework Class Library
ProfileTransCaptureOnlyType..::.approvalCode Property
ProfileTransCaptureOnlyType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property approvalCode As String
C#
public string approvalCode { get; set; }
Visual C++
public:
property String^ approvalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_approvalCode();
function set_approvalCode(value);

Remarks

See Also

ProfileTransCaptureOnlyType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransOrderType Class

[image]

.NET Framework Class Library
ProfileTransOrderType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ProfileTransOrderType _
    Inherits ProfileTransAmountType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ProfileTransOrderType : ProfileTransAmountType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ProfileTransOrderType : public ProfileTransAmountType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransOrderType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ProfileTransOrderType',
    InSite.Domain.AuthorizeNetCIMService.ProfileTransAmountType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAmountType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransOrderType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAuthCaptureType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransAuthOnlyType
InSite.Domain.AuthorizeNetCIMService..::.ProfileTransCaptureOnlyType

See Also

ProfileTransOrderType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransOrderType Members

[image] [image]

.NET Framework Class Library
ProfileTransOrderType Members
ProfileTransOrderType Class Constructors Methods Properties See Also Send Feedback

The ProfileTransOrderType type exposes the following members.

Constructors

Name | Description
ProfileTransOrderType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount | (Inherited from ProfileTransAmountType.)
cardCode |
customerPaymentProfileId |
customerProfileId |
customerShippingAddressId |
customerShippingAddressIdSpecified |
duty | (Inherited from ProfileTransAmountType.)
lineItems | (Inherited from ProfileTransAmountType.)
order |
recurringBilling |
recurringBillingSpecified |
shipping | (Inherited from ProfileTransAmountType.)
tax | (Inherited from ProfileTransAmountType.)
taxExempt |
taxExemptSpecified |

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransOrderType Constructor

[image]

.NET Framework Class Library
ProfileTransOrderType Constructor
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProfileTransOrderType()
Visual C++
public:
ProfileTransOrderType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ProfileTransOrderType = function();

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransOrderType Methods

[image] [image]

.NET Framework Class Library
ProfileTransOrderType Methods
ProfileTransOrderType Class See Also Send Feedback

The ProfileTransOrderType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ProfileTransOrderType Properties

[image] [image]

.NET Framework Class Library
ProfileTransOrderType Properties
ProfileTransOrderType Class See Also Send Feedback

The ProfileTransOrderType type exposes the following members.

Properties

Name | Description
amount | (Inherited from ProfileTransAmountType.)
cardCode |
customerPaymentProfileId |
customerProfileId |
customerShippingAddressId |
customerShippingAddressIdSpecified |
duty | (Inherited from ProfileTransAmountType.)
lineItems | (Inherited from ProfileTransAmountType.)
order |
recurringBilling |
recurringBillingSpecified |
shipping | (Inherited from ProfileTransAmountType.)
tax | (Inherited from ProfileTransAmountType.)
taxExempt |
taxExemptSpecified |

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


cardCode Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.cardCode Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardCode As String
C#
public string cardCode { get; set; }
Visual C++
public:
property String^ cardCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardCode();
function set_cardCode(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerPaymentProfileId Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.customerPaymentProfileId Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerPaymentProfileId As Long
C#
public long customerPaymentProfileId { get; set; }
Visual C++
public:
property long long customerPaymentProfileId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerPaymentProfileId();
function set_customerPaymentProfileId(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerProfileId Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.customerProfileId Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerProfileId As Long
C#
public long customerProfileId { get; set; }
Visual C++
public:
property long long customerProfileId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerProfileId();
function set_customerProfileId(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerShippingAddressId Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.customerShippingAddressId Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerShippingAddressId As Long
C#
public long customerShippingAddressId { get; set; }
Visual C++
public:
property long long customerShippingAddressId {
    long long get ();
    void set (long long value);
}
JavaScript
function get_customerShippingAddressId();
function set_customerShippingAddressId(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


customerShippingAddressIdSpecified Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.customerShippingAddressIdSpecified Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerShippingAddressIdSpecified As Boolean
C#
public bool customerShippingAddressIdSpecified { get; set; }
Visual C++
public:
property bool customerShippingAddressIdSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_customerShippingAddressIdSpecified();
function set_customerShippingAddressIdSpecified(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


order Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.order Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property order As OrderExType
C#
public OrderExType order { get; set; }
Visual C++
public:
property OrderExType^ order {
    OrderExType^ get ();
    void set (OrderExType^ value);
}
JavaScript
function get_order();
function set_order(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


recurringBilling Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.recurringBilling Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property recurringBilling As Boolean
C#
public bool recurringBilling { get; set; }
Visual C++
public:
property bool recurringBilling {
    bool get ();
    void set (bool value);
}
JavaScript
function get_recurringBilling();
function set_recurringBilling(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


recurringBillingSpecified Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.recurringBillingSpecified Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property recurringBillingSpecified As Boolean
C#
public bool recurringBillingSpecified { get; set; }
Visual C++
public:
property bool recurringBillingSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_recurringBillingSpecified();
function set_recurringBillingSpecified(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


taxExempt Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.taxExempt Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxExempt As Boolean
C#
public bool taxExempt { get; set; }
Visual C++
public:
property bool taxExempt {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxExempt();
function set_taxExempt(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


taxExemptSpecified Property

[image]

.NET Framework Class Library
ProfileTransOrderType..::.taxExemptSpecified Property
ProfileTransOrderType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxExemptSpecified As Boolean
C#
public bool taxExemptSpecified { get; set; }
Visual C++
public:
property bool taxExemptSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxExemptSpecified();
function set_taxExemptSpecified(value);

Remarks

See Also

ProfileTransOrderType Class
InSite.Domain.AuthorizeNetCIMService Namespace


Service Class

[image]

.NET Framework Class Library
Service Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<WebServiceBindingAttribute(Name := "ServiceSoap", Namespace := "https://api.authorize.net/soap/v1/")> _
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class Service _
    Inherits SoapHttpClientProtocol
C#
[WebServiceBindingAttribute(Name = "ServiceSoap", Namespace = "https://api.authorize.net/soap/v1/")]
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class Service : SoapHttpClientProtocol
Visual C++
[WebServiceBindingAttribute(Name = L"ServiceSoap", Namespace = L"https://api.authorize.net/soap/v1/")]
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class Service : public SoapHttpClientProtocol
JavaScript
InSite.Domain.AuthorizeNetCIMService.Service = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.Service',
    SoapHttpClientProtocol);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Web.Services.Protocols..::.WebClientProtocol
System.Web.Services.Protocols..::.HttpWebClientProtocol
System.Web.Services.Protocols..::.SoapHttpClientProtocol
InSite.Domain.AuthorizeNetCIMService..::.Service

See Also

Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


Service Members

[image] [image]

.NET Framework Class Library
Service Members
Service Class Constructors Methods Properties Events See Also Send Feedback

The Service type exposes the following members.

Constructors

Name | Description
Service |

Methods

Name | Description
Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
ARBCancelSubscription |
ARBCancelSubscriptionAsync | Overloaded.
ARBCreateSubscription |
ARBCreateSubscriptionAsync | Overloaded.
ARBUpdateSubscription |
ARBUpdateSubscriptionAsync | Overloaded.
AuthenticateTest |
AuthenticateTestAsync | Overloaded.
BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
CancelAsync |
CreateCustomerPaymentProfile |
CreateCustomerPaymentProfileAsync | Overloaded.
CreateCustomerProfile |
CreateCustomerProfileAsync | Overloaded.
CreateCustomerProfileTransaction |
CreateCustomerProfileTransactionAsync | Overloaded.
CreateCustomerShippingAddress |
CreateCustomerShippingAddressAsync | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DeleteCustomerPaymentProfile |
DeleteCustomerPaymentProfileAsync | Overloaded.
DeleteCustomerProfile |
DeleteCustomerProfileAsync | Overloaded.
DeleteCustomerShippingAddress |
DeleteCustomerShippingAddressAsync | Overloaded.
Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Dispose | Overloaded.
EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetCustomerPaymentProfile |
GetCustomerPaymentProfileAsync | Overloaded.
GetCustomerProfile |
GetCustomerProfileAsync | Overloaded.
GetCustomerShippingAddress |
GetCustomerShippingAddressAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
GetWebResponse | Overloaded.
GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
InvokeAsync | Overloaded.
IsAlive |
IsAliveAsync | Overloaded.
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateCustomerPaymentProfile |
UpdateCustomerPaymentProfileAsync | Overloaded.
UpdateCustomerProfile |
UpdateCustomerProfileAsync | Overloaded.
UpdateCustomerShippingAddress |
UpdateCustomerShippingAddressAsync | Overloaded.
ValidateCustomerPaymentProfile |
ValidateCustomerPaymentProfileAsync | Overloaded.

Properties

Name | Description
AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true. (Inherited from HttpWebClientProtocol.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Url |
UseDefaultCredentials |
UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)

Events

Name | Description
ARBCancelSubscriptionCompleted |
ARBCreateSubscriptionCompleted |
ARBUpdateSubscriptionCompleted |
AuthenticateTestCompleted |
CreateCustomerPaymentProfileCompleted |
CreateCustomerProfileCompleted |
CreateCustomerProfileTransactionCompleted |
CreateCustomerShippingAddressCompleted |
DeleteCustomerPaymentProfileCompleted |
DeleteCustomerProfileCompleted |
DeleteCustomerShippingAddressCompleted |
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
GetCustomerPaymentProfileCompleted |
GetCustomerProfileCompleted |
GetCustomerShippingAddressCompleted |
IsAliveCompleted |
UpdateCustomerPaymentProfileCompleted |
UpdateCustomerProfileCompleted |
UpdateCustomerShippingAddressCompleted |
ValidateCustomerPaymentProfileCompleted |

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


Service Constructor

[image]

.NET Framework Class Library
Service Constructor
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Service()
Visual C++
public:
Service()
JavaScript
InSite.Domain.AuthorizeNetCIMService.Service = function();

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


Service Methods

[image] [image]

.NET Framework Class Library
Service Methods
Service Class See Also Send Feedback

The Service type exposes the following members.

Methods

Name | Description
Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
ARBCancelSubscription |
ARBCancelSubscriptionAsync | Overloaded.
ARBCreateSubscription |
ARBCreateSubscriptionAsync | Overloaded.
ARBUpdateSubscription |
ARBUpdateSubscriptionAsync | Overloaded.
AuthenticateTest |
AuthenticateTestAsync | Overloaded.
BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
CancelAsync |
CreateCustomerPaymentProfile |
CreateCustomerPaymentProfileAsync | Overloaded.
CreateCustomerProfile |
CreateCustomerProfileAsync | Overloaded.
CreateCustomerProfileTransaction |
CreateCustomerProfileTransactionAsync | Overloaded.
CreateCustomerShippingAddress |
CreateCustomerShippingAddressAsync | Overloaded.
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
DeleteCustomerPaymentProfile |
DeleteCustomerPaymentProfileAsync | Overloaded.
DeleteCustomerProfile |
DeleteCustomerProfileAsync | Overloaded.
DeleteCustomerShippingAddress |
DeleteCustomerShippingAddressAsync | Overloaded.
Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Dispose | Overloaded.
EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetCustomerPaymentProfile |
GetCustomerPaymentProfileAsync | Overloaded.
GetCustomerProfile |
GetCustomerProfileAsync | Overloaded.
GetCustomerShippingAddress |
GetCustomerShippingAddressAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
GetWebResponse | Overloaded.
GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
InvokeAsync | Overloaded.
IsAlive |
IsAliveAsync | Overloaded.
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
UpdateCustomerPaymentProfile |
UpdateCustomerPaymentProfileAsync | Overloaded.
UpdateCustomerProfile |
UpdateCustomerProfileAsync | Overloaded.
UpdateCustomerShippingAddress |
UpdateCustomerShippingAddressAsync | Overloaded.
ValidateCustomerPaymentProfile |
ValidateCustomerPaymentProfileAsync | Overloaded.

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscription Method

[image]

.NET Framework Class Library
Service..::.ARBCancelSubscription Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/ARBCancelSubscription", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function ARBCancelSubscription ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscriptionId As Long _
) As ARBCancelSubscriptionResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/ARBCancelSubscription", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public ARBCancelSubscriptionResponseType ARBCancelSubscription(
    MerchantAuthenticationType merchantAuthentication,
    long subscriptionId
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/ARBCancelSubscription", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
ARBCancelSubscriptionResponseType^ ARBCancelSubscription(
    MerchantAuthenticationType^ merchantAuthentication,
    long long subscriptionId
)
JavaScript
function arbCancelSubscription(merchantAuthentication, subscriptionId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscriptionId
Type: System..::.Int64

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionAsync Method

[image] [image]

.NET Framework Class Library
Service..::.ARBCancelSubscriptionAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
ARBCancelSubscriptionAsync(MerchantAuthenticationType, Int64) |
ARBCancelSubscriptionAsync(MerchantAuthenticationType, Int64, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionAsync Method (MerchantAuthenticationType, Int64)

[image]

.NET Framework Class Library
Service..::.ARBCancelSubscriptionAsync Method (MerchantAuthenticationType, Int64)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ARBCancelSubscriptionAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscriptionId As Long _
)
C#
public void ARBCancelSubscriptionAsync(
    MerchantAuthenticationType merchantAuthentication,
    long subscriptionId
)
Visual C++
public:
void ARBCancelSubscriptionAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long subscriptionId
)
JavaScript
function arbCancelSubscriptionAsync(merchantAuthentication, subscriptionId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscriptionId
Type: System..::.Int64

Remarks

See Also

Service Class
ARBCancelSubscriptionAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionAsync Method (MerchantAuthenticationType, Int64, Object)

[image]

.NET Framework Class Library
Service..::.ARBCancelSubscriptionAsync Method (MerchantAuthenticationType, Int64, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ARBCancelSubscriptionAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscriptionId As Long, _
    userState As Object _
)
C#
public void ARBCancelSubscriptionAsync(
    MerchantAuthenticationType merchantAuthentication,
    long subscriptionId,
    Object userState
)
Visual C++
public:
void ARBCancelSubscriptionAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long subscriptionId,
    Object^ userState
)
JavaScript
function arbCancelSubscriptionAsync(merchantAuthentication, subscriptionId, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscriptionId
Type: System..::.Int64
userState
Type: System..::.Object

Remarks

See Also

Service Class
ARBCancelSubscriptionAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscription Method

[image]

.NET Framework Class Library
Service..::.ARBCreateSubscription Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/ARBCreateSubscription", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function ARBCreateSubscription ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscription As ARBSubscriptionType _
) As ARBCreateSubscriptionResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/ARBCreateSubscription", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public ARBCreateSubscriptionResponseType ARBCreateSubscription(
    MerchantAuthenticationType merchantAuthentication,
    ARBSubscriptionType subscription
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/ARBCreateSubscription", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
ARBCreateSubscriptionResponseType^ ARBCreateSubscription(
    MerchantAuthenticationType^ merchantAuthentication,
    ARBSubscriptionType^ subscription
)
JavaScript
function arbCreateSubscription(merchantAuthentication, subscription);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscription
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBSubscriptionType

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionAsync Method

[image] [image]

.NET Framework Class Library
Service..::.ARBCreateSubscriptionAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
ARBCreateSubscriptionAsync(MerchantAuthenticationType, ARBSubscriptionType) |
ARBCreateSubscriptionAsync(MerchantAuthenticationType, ARBSubscriptionType, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionAsync Method (MerchantAuthenticationType, ARBSubscriptionType)

[image]

.NET Framework Class Library
Service..::.ARBCreateSubscriptionAsync Method (MerchantAuthenticationType, ARBSubscriptionType)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ARBCreateSubscriptionAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscription As ARBSubscriptionType _
)
C#
public void ARBCreateSubscriptionAsync(
    MerchantAuthenticationType merchantAuthentication,
    ARBSubscriptionType subscription
)
Visual C++
public:
void ARBCreateSubscriptionAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    ARBSubscriptionType^ subscription
)
JavaScript
function arbCreateSubscriptionAsync(merchantAuthentication, subscription);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscription
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBSubscriptionType

Remarks

See Also

Service Class
ARBCreateSubscriptionAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionAsync Method (MerchantAuthenticationType, ARBSubscriptionType, Object)

[image]

.NET Framework Class Library
Service..::.ARBCreateSubscriptionAsync Method (MerchantAuthenticationType, ARBSubscriptionType, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ARBCreateSubscriptionAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscription As ARBSubscriptionType, _
    userState As Object _
)
C#
public void ARBCreateSubscriptionAsync(
    MerchantAuthenticationType merchantAuthentication,
    ARBSubscriptionType subscription,
    Object userState
)
Visual C++
public:
void ARBCreateSubscriptionAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    ARBSubscriptionType^ subscription,
    Object^ userState
)
JavaScript
function arbCreateSubscriptionAsync(merchantAuthentication, subscription, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscription
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBSubscriptionType
userState
Type: System..::.Object

Remarks

See Also

Service Class
ARBCreateSubscriptionAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscription Method

[image]

.NET Framework Class Library
Service..::.ARBUpdateSubscription Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/ARBUpdateSubscription", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function ARBUpdateSubscription ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscriptionId As Long, _
    subscription As ARBSubscriptionType _
) As ARBUpdateSubscriptionResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/ARBUpdateSubscription", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public ARBUpdateSubscriptionResponseType ARBUpdateSubscription(
    MerchantAuthenticationType merchantAuthentication,
    long subscriptionId,
    ARBSubscriptionType subscription
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/ARBUpdateSubscription", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
ARBUpdateSubscriptionResponseType^ ARBUpdateSubscription(
    MerchantAuthenticationType^ merchantAuthentication,
    long long subscriptionId,
    ARBSubscriptionType^ subscription
)
JavaScript
function arbUpdateSubscription(merchantAuthentication, subscriptionId, subscription);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscriptionId
Type: System..::.Int64
subscription
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBSubscriptionType

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionAsync Method

[image] [image]

.NET Framework Class Library
Service..::.ARBUpdateSubscriptionAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
ARBUpdateSubscriptionAsync(MerchantAuthenticationType, Int64, ARBSubscriptionType) |
ARBUpdateSubscriptionAsync(MerchantAuthenticationType, Int64, ARBSubscriptionType, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionAsync Method (MerchantAuthenticationType, Int64, ARBSubscriptionType)

[image]

.NET Framework Class Library
Service..::.ARBUpdateSubscriptionAsync Method (MerchantAuthenticationType, Int64, ARBSubscriptionType)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ARBUpdateSubscriptionAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscriptionId As Long, _
    subscription As ARBSubscriptionType _
)
C#
public void ARBUpdateSubscriptionAsync(
    MerchantAuthenticationType merchantAuthentication,
    long subscriptionId,
    ARBSubscriptionType subscription
)
Visual C++
public:
void ARBUpdateSubscriptionAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long subscriptionId,
    ARBSubscriptionType^ subscription
)
JavaScript
function arbUpdateSubscriptionAsync(merchantAuthentication, subscriptionId, subscription);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscriptionId
Type: System..::.Int64
subscription
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBSubscriptionType

Remarks

See Also

Service Class
ARBUpdateSubscriptionAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionAsync Method (MerchantAuthenticationType, Int64, ARBSubscriptionType, Object)

[image]

.NET Framework Class Library
Service..::.ARBUpdateSubscriptionAsync Method (MerchantAuthenticationType, Int64, ARBSubscriptionType, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ARBUpdateSubscriptionAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    subscriptionId As Long, _
    subscription As ARBSubscriptionType, _
    userState As Object _
)
C#
public void ARBUpdateSubscriptionAsync(
    MerchantAuthenticationType merchantAuthentication,
    long subscriptionId,
    ARBSubscriptionType subscription,
    Object userState
)
Visual C++
public:
void ARBUpdateSubscriptionAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long subscriptionId,
    ARBSubscriptionType^ subscription,
    Object^ userState
)
JavaScript
function arbUpdateSubscriptionAsync(merchantAuthentication, subscriptionId, subscription, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
subscriptionId
Type: System..::.Int64
subscription
Type: InSite.Domain.AuthorizeNetCIMService..::.ARBSubscriptionType
userState
Type: System..::.Object

Remarks

See Also

Service Class
ARBUpdateSubscriptionAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTest Method

[image]

.NET Framework Class Library
Service..::.AuthenticateTest Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/AuthenticateTest", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function AuthenticateTest ( _
    merchantAuthentication As MerchantAuthenticationType _
) As ANetApiResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/AuthenticateTest", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public ANetApiResponseType AuthenticateTest(
    MerchantAuthenticationType merchantAuthentication
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/AuthenticateTest", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
ANetApiResponseType^ AuthenticateTest(
    MerchantAuthenticationType^ merchantAuthentication
)
JavaScript
function authenticateTest(merchantAuthentication);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestAsync Method

[image] [image]

.NET Framework Class Library
Service..::.AuthenticateTestAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
AuthenticateTestAsync(MerchantAuthenticationType) |
AuthenticateTestAsync(MerchantAuthenticationType, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestAsync Method (MerchantAuthenticationType)

[image]

.NET Framework Class Library
Service..::.AuthenticateTestAsync Method (MerchantAuthenticationType)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub AuthenticateTestAsync ( _
    merchantAuthentication As MerchantAuthenticationType _
)
C#
public void AuthenticateTestAsync(
    MerchantAuthenticationType merchantAuthentication
)
Visual C++
public:
void AuthenticateTestAsync(
    MerchantAuthenticationType^ merchantAuthentication
)
JavaScript
function authenticateTestAsync(merchantAuthentication);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType

Remarks

See Also

Service Class
AuthenticateTestAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestAsync Method (MerchantAuthenticationType, Object)

[image]

.NET Framework Class Library
Service..::.AuthenticateTestAsync Method (MerchantAuthenticationType, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub AuthenticateTestAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    userState As Object _
)
C#
public void AuthenticateTestAsync(
    MerchantAuthenticationType merchantAuthentication,
    Object userState
)
Visual C++
public:
void AuthenticateTestAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    Object^ userState
)
JavaScript
function authenticateTestAsync(merchantAuthentication, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
userState
Type: System..::.Object

Remarks

See Also

Service Class
AuthenticateTestAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


CancelAsync Method

[image]

.NET Framework Class Library
Service..::.CancelAsync Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelAsync ( _
    userState As Object _
)
C#
public void CancelAsync(
    Object userState
)
Visual C++
public:
void CancelAsync(
    Object^ userState
)
JavaScript
function cancelAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfile Method

[image]

.NET Framework Class Library
Service..::.CreateCustomerPaymentProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/CreateCustomerPaymentProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function CreateCustomerPaymentProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    paymentProfile As CustomerPaymentProfileType, _
    validationMode As ValidationModeEnum _
) As CreateCustomerPaymentProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/CreateCustomerPaymentProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public CreateCustomerPaymentProfileResponseType CreateCustomerPaymentProfile(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerPaymentProfileType paymentProfile,
    ValidationModeEnum validationMode
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/CreateCustomerPaymentProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
CreateCustomerPaymentProfileResponseType^ CreateCustomerPaymentProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerPaymentProfileType^ paymentProfile,
    ValidationModeEnum validationMode
)
JavaScript
function createCustomerPaymentProfile(merchantAuthentication, customerProfileId, paymentProfile, validationMode);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
paymentProfile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileType
validationMode
Type: InSite.Domain.AuthorizeNetCIMService..::.ValidationModeEnum

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.CreateCustomerPaymentProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
CreateCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, CustomerPaymentProfileType, ValidationModeEnum) |
CreateCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, CustomerPaymentProfileType, ValidationModeEnum, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, CustomerPaymentProfileType, ValidationModeEnum)

[image]

.NET Framework Class Library
Service..::.CreateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, CustomerPaymentProfileType, ValidationModeEnum)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    paymentProfile As CustomerPaymentProfileType, _
    validationMode As ValidationModeEnum _
)
C#
public void CreateCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerPaymentProfileType paymentProfile,
    ValidationModeEnum validationMode
)
Visual C++
public:
void CreateCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerPaymentProfileType^ paymentProfile,
    ValidationModeEnum validationMode
)
JavaScript
function createCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, paymentProfile, validationMode);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
paymentProfile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileType
validationMode
Type: InSite.Domain.AuthorizeNetCIMService..::.ValidationModeEnum

Remarks

See Also

Service Class
CreateCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, CustomerPaymentProfileType, ValidationModeEnum, Object)

[image]

.NET Framework Class Library
Service..::.CreateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, CustomerPaymentProfileType, ValidationModeEnum, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    paymentProfile As CustomerPaymentProfileType, _
    validationMode As ValidationModeEnum, _
    userState As Object _
)
C#
public void CreateCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerPaymentProfileType paymentProfile,
    ValidationModeEnum validationMode,
    Object userState
)
Visual C++
public:
void CreateCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerPaymentProfileType^ paymentProfile,
    ValidationModeEnum validationMode,
    Object^ userState
)
JavaScript
function createCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, paymentProfile, validationMode, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
paymentProfile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileType
validationMode
Type: InSite.Domain.AuthorizeNetCIMService..::.ValidationModeEnum
userState
Type: System..::.Object

Remarks

See Also

Service Class
CreateCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfile Method

[image]

.NET Framework Class Library
Service..::.CreateCustomerProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/CreateCustomerProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function CreateCustomerProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    profile As CustomerProfileType _
) As CreateCustomerProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/CreateCustomerProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public CreateCustomerProfileResponseType CreateCustomerProfile(
    MerchantAuthenticationType merchantAuthentication,
    CustomerProfileType profile
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/CreateCustomerProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
CreateCustomerProfileResponseType^ CreateCustomerProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    CustomerProfileType^ profile
)
JavaScript
function createCustomerProfile(merchantAuthentication, profile);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
profile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileType

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.CreateCustomerProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
CreateCustomerProfileAsync(MerchantAuthenticationType, CustomerProfileType) |
CreateCustomerProfileAsync(MerchantAuthenticationType, CustomerProfileType, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileAsync Method (MerchantAuthenticationType, CustomerProfileType)

[image]

.NET Framework Class Library
Service..::.CreateCustomerProfileAsync Method (MerchantAuthenticationType, CustomerProfileType)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCustomerProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    profile As CustomerProfileType _
)
C#
public void CreateCustomerProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    CustomerProfileType profile
)
Visual C++
public:
void CreateCustomerProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    CustomerProfileType^ profile
)
JavaScript
function createCustomerProfileAsync(merchantAuthentication, profile);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
profile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileType

Remarks

See Also

Service Class
CreateCustomerProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileAsync Method (MerchantAuthenticationType, CustomerProfileType, Object)

[image]

.NET Framework Class Library
Service..::.CreateCustomerProfileAsync Method (MerchantAuthenticationType, CustomerProfileType, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCustomerProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    profile As CustomerProfileType, _
    userState As Object _
)
C#
public void CreateCustomerProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    CustomerProfileType profile,
    Object userState
)
Visual C++
public:
void CreateCustomerProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    CustomerProfileType^ profile,
    Object^ userState
)
JavaScript
function createCustomerProfileAsync(merchantAuthentication, profile, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
profile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileType
userState
Type: System..::.Object

Remarks

See Also

Service Class
CreateCustomerProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransaction Method

[image]

.NET Framework Class Library
Service..::.CreateCustomerProfileTransaction Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/CreateCustomerProfileTransaction", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function CreateCustomerProfileTransaction ( _
    merchantAuthentication As MerchantAuthenticationType, _
    transaction As ProfileTransactionType, _
    extraOptions As String _
) As CreateCustomerProfileTransactionResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/CreateCustomerProfileTransaction", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public CreateCustomerProfileTransactionResponseType CreateCustomerProfileTransaction(
    MerchantAuthenticationType merchantAuthentication,
    ProfileTransactionType transaction,
    string extraOptions
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/CreateCustomerProfileTransaction", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
CreateCustomerProfileTransactionResponseType^ CreateCustomerProfileTransaction(
    MerchantAuthenticationType^ merchantAuthentication,
    ProfileTransactionType^ transaction,
    String^ extraOptions
)
JavaScript
function createCustomerProfileTransaction(merchantAuthentication, transaction, extraOptions);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
transaction
Type: InSite.Domain.AuthorizeNetCIMService..::.ProfileTransactionType
extraOptions
Type: System..::.String

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionAsync Method

[image] [image]

.NET Framework Class Library
Service..::.CreateCustomerProfileTransactionAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
CreateCustomerProfileTransactionAsync(MerchantAuthenticationType, ProfileTransactionType, String) |
CreateCustomerProfileTransactionAsync(MerchantAuthenticationType, ProfileTransactionType, String, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionAsync Method (MerchantAuthenticationType, ProfileTransactionType, String)

[image]

.NET Framework Class Library
Service..::.CreateCustomerProfileTransactionAsync Method (MerchantAuthenticationType, ProfileTransactionType, String)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCustomerProfileTransactionAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    transaction As ProfileTransactionType, _
    extraOptions As String _
)
C#
public void CreateCustomerProfileTransactionAsync(
    MerchantAuthenticationType merchantAuthentication,
    ProfileTransactionType transaction,
    string extraOptions
)
Visual C++
public:
void CreateCustomerProfileTransactionAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    ProfileTransactionType^ transaction,
    String^ extraOptions
)
JavaScript
function createCustomerProfileTransactionAsync(merchantAuthentication, transaction, extraOptions);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
transaction
Type: InSite.Domain.AuthorizeNetCIMService..::.ProfileTransactionType
extraOptions
Type: System..::.String

Remarks

See Also

Service Class
CreateCustomerProfileTransactionAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionAsync Method (MerchantAuthenticationType, ProfileTransactionType, String, Object)

[image]

.NET Framework Class Library
Service..::.CreateCustomerProfileTransactionAsync Method (MerchantAuthenticationType, ProfileTransactionType, String, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCustomerProfileTransactionAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    transaction As ProfileTransactionType, _
    extraOptions As String, _
    userState As Object _
)
C#
public void CreateCustomerProfileTransactionAsync(
    MerchantAuthenticationType merchantAuthentication,
    ProfileTransactionType transaction,
    string extraOptions,
    Object userState
)
Visual C++
public:
void CreateCustomerProfileTransactionAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    ProfileTransactionType^ transaction,
    String^ extraOptions,
    Object^ userState
)
JavaScript
function createCustomerProfileTransactionAsync(merchantAuthentication, transaction, extraOptions, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
transaction
Type: InSite.Domain.AuthorizeNetCIMService..::.ProfileTransactionType
extraOptions
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

Service Class
CreateCustomerProfileTransactionAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddress Method

[image]

.NET Framework Class Library
Service..::.CreateCustomerShippingAddress Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/CreateCustomerShippingAddress", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function CreateCustomerShippingAddress ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    address As CustomerAddressType _
) As CreateCustomerShippingAddressResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/CreateCustomerShippingAddress", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public CreateCustomerShippingAddressResponseType CreateCustomerShippingAddress(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerAddressType address
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/CreateCustomerShippingAddress", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
CreateCustomerShippingAddressResponseType^ CreateCustomerShippingAddress(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerAddressType^ address
)
JavaScript
function createCustomerShippingAddress(merchantAuthentication, customerProfileId, address);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
address
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressType

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressAsync Method

[image] [image]

.NET Framework Class Library
Service..::.CreateCustomerShippingAddressAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
CreateCustomerShippingAddressAsync(MerchantAuthenticationType, Int64, CustomerAddressType) |
CreateCustomerShippingAddressAsync(MerchantAuthenticationType, Int64, CustomerAddressType, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, CustomerAddressType)

[image]

.NET Framework Class Library
Service..::.CreateCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, CustomerAddressType)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCustomerShippingAddressAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    address As CustomerAddressType _
)
C#
public void CreateCustomerShippingAddressAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerAddressType address
)
Visual C++
public:
void CreateCustomerShippingAddressAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerAddressType^ address
)
JavaScript
function createCustomerShippingAddressAsync(merchantAuthentication, customerProfileId, address);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
address
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressType

Remarks

See Also

Service Class
CreateCustomerShippingAddressAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, CustomerAddressType, Object)

[image]

.NET Framework Class Library
Service..::.CreateCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, CustomerAddressType, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CreateCustomerShippingAddressAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    address As CustomerAddressType, _
    userState As Object _
)
C#
public void CreateCustomerShippingAddressAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerAddressType address,
    Object userState
)
Visual C++
public:
void CreateCustomerShippingAddressAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerAddressType^ address,
    Object^ userState
)
JavaScript
function createCustomerShippingAddressAsync(merchantAuthentication, customerProfileId, address, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
address
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressType
userState
Type: System..::.Object

Remarks

See Also

Service Class
CreateCustomerShippingAddressAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfile Method

[image]

.NET Framework Class Library
Service..::.DeleteCustomerPaymentProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/DeleteCustomerPaymentProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function DeleteCustomerPaymentProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long _
) As DeleteCustomerPaymentProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/DeleteCustomerPaymentProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public DeleteCustomerPaymentProfileResponseType DeleteCustomerPaymentProfile(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/DeleteCustomerPaymentProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DeleteCustomerPaymentProfileResponseType^ DeleteCustomerPaymentProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId
)
JavaScript
function deleteCustomerPaymentProfile(merchantAuthentication, customerProfileId, customerPaymentProfileId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.DeleteCustomerPaymentProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
DeleteCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, Int64) |
DeleteCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, Int64, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64)

[image]

.NET Framework Class Library
Service..::.DeleteCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long _
)
C#
public void DeleteCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId
)
Visual C++
public:
void DeleteCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId
)
JavaScript
function deleteCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, customerPaymentProfileId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64

Remarks

See Also

Service Class
DeleteCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64, Object)

[image]

.NET Framework Class Library
Service..::.DeleteCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long, _
    userState As Object _
)
C#
public void DeleteCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId,
    Object userState
)
Visual C++
public:
void DeleteCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId,
    Object^ userState
)
JavaScript
function deleteCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, customerPaymentProfileId, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64
userState
Type: System..::.Object

Remarks

See Also

Service Class
DeleteCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfile Method

[image]

.NET Framework Class Library
Service..::.DeleteCustomerProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/DeleteCustomerProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function DeleteCustomerProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long _
) As DeleteCustomerProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/DeleteCustomerProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public DeleteCustomerProfileResponseType DeleteCustomerProfile(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/DeleteCustomerProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DeleteCustomerProfileResponseType^ DeleteCustomerProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId
)
JavaScript
function deleteCustomerProfile(merchantAuthentication, customerProfileId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.DeleteCustomerProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
DeleteCustomerProfileAsync(MerchantAuthenticationType, Int64) |
DeleteCustomerProfileAsync(MerchantAuthenticationType, Int64, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileAsync Method (MerchantAuthenticationType, Int64)

[image]

.NET Framework Class Library
Service..::.DeleteCustomerProfileAsync Method (MerchantAuthenticationType, Int64)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteCustomerProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long _
)
C#
public void DeleteCustomerProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId
)
Visual C++
public:
void DeleteCustomerProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId
)
JavaScript
function deleteCustomerProfileAsync(merchantAuthentication, customerProfileId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64

Remarks

See Also

Service Class
DeleteCustomerProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileAsync Method (MerchantAuthenticationType, Int64, Object)

[image]

.NET Framework Class Library
Service..::.DeleteCustomerProfileAsync Method (MerchantAuthenticationType, Int64, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteCustomerProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    userState As Object _
)
C#
public void DeleteCustomerProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    Object userState
)
Visual C++
public:
void DeleteCustomerProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    Object^ userState
)
JavaScript
function deleteCustomerProfileAsync(merchantAuthentication, customerProfileId, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
userState
Type: System..::.Object

Remarks

See Also

Service Class
DeleteCustomerProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddress Method

[image]

.NET Framework Class Library
Service..::.DeleteCustomerShippingAddress Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/DeleteCustomerShippingAddress", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function DeleteCustomerShippingAddress ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerAddressId As Long _
) As DeleteCustomerShippingAddressResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/DeleteCustomerShippingAddress", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public DeleteCustomerShippingAddressResponseType DeleteCustomerShippingAddress(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerAddressId
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/DeleteCustomerShippingAddress", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DeleteCustomerShippingAddressResponseType^ DeleteCustomerShippingAddress(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerAddressId
)
JavaScript
function deleteCustomerShippingAddress(merchantAuthentication, customerProfileId, customerAddressId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerAddressId
Type: System..::.Int64

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressAsync Method

[image] [image]

.NET Framework Class Library
Service..::.DeleteCustomerShippingAddressAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
DeleteCustomerShippingAddressAsync(MerchantAuthenticationType, Int64, Int64) |
DeleteCustomerShippingAddressAsync(MerchantAuthenticationType, Int64, Int64, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, Int64)

[image]

.NET Framework Class Library
Service..::.DeleteCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, Int64)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteCustomerShippingAddressAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerAddressId As Long _
)
C#
public void DeleteCustomerShippingAddressAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerAddressId
)
Visual C++
public:
void DeleteCustomerShippingAddressAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerAddressId
)
JavaScript
function deleteCustomerShippingAddressAsync(merchantAuthentication, customerProfileId, customerAddressId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerAddressId
Type: System..::.Int64

Remarks

See Also

Service Class
DeleteCustomerShippingAddressAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, Int64, Object)

[image]

.NET Framework Class Library
Service..::.DeleteCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, Int64, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteCustomerShippingAddressAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerAddressId As Long, _
    userState As Object _
)
C#
public void DeleteCustomerShippingAddressAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerAddressId,
    Object userState
)
Visual C++
public:
void DeleteCustomerShippingAddressAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerAddressId,
    Object^ userState
)
JavaScript
function deleteCustomerShippingAddressAsync(merchantAuthentication, customerProfileId, customerAddressId, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerAddressId
Type: System..::.Int64
userState
Type: System..::.Object

Remarks

See Also

Service Class
DeleteCustomerShippingAddressAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
Service..::.Dispose Method
Service Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfile Method

[image]

.NET Framework Class Library
Service..::.GetCustomerPaymentProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/GetCustomerPaymentProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetCustomerPaymentProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long _
) As GetCustomerPaymentProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/GetCustomerPaymentProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public GetCustomerPaymentProfileResponseType GetCustomerPaymentProfile(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/GetCustomerPaymentProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
GetCustomerPaymentProfileResponseType^ GetCustomerPaymentProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId
)
JavaScript
function getCustomerPaymentProfile(merchantAuthentication, customerProfileId, customerPaymentProfileId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.GetCustomerPaymentProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
GetCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, Int64) |
GetCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, Int64, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64)

[image]

.NET Framework Class Library
Service..::.GetCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long _
)
C#
public void GetCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId
)
Visual C++
public:
void GetCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId
)
JavaScript
function getCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, customerPaymentProfileId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64

Remarks

See Also

Service Class
GetCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64, Object)

[image]

.NET Framework Class Library
Service..::.GetCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long, _
    userState As Object _
)
C#
public void GetCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId,
    Object userState
)
Visual C++
public:
void GetCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId,
    Object^ userState
)
JavaScript
function getCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, customerPaymentProfileId, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64
userState
Type: System..::.Object

Remarks

See Also

Service Class
GetCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfile Method

[image]

.NET Framework Class Library
Service..::.GetCustomerProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/GetCustomerProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetCustomerProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long _
) As GetCustomerProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/GetCustomerProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public GetCustomerProfileResponseType GetCustomerProfile(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/GetCustomerProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
GetCustomerProfileResponseType^ GetCustomerProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId
)
JavaScript
function getCustomerProfile(merchantAuthentication, customerProfileId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.GetCustomerProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
GetCustomerProfileAsync(MerchantAuthenticationType, Int64) |
GetCustomerProfileAsync(MerchantAuthenticationType, Int64, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileAsync Method (MerchantAuthenticationType, Int64)

[image]

.NET Framework Class Library
Service..::.GetCustomerProfileAsync Method (MerchantAuthenticationType, Int64)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long _
)
C#
public void GetCustomerProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId
)
Visual C++
public:
void GetCustomerProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId
)
JavaScript
function getCustomerProfileAsync(merchantAuthentication, customerProfileId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64

Remarks

See Also

Service Class
GetCustomerProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileAsync Method (MerchantAuthenticationType, Int64, Object)

[image]

.NET Framework Class Library
Service..::.GetCustomerProfileAsync Method (MerchantAuthenticationType, Int64, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    userState As Object _
)
C#
public void GetCustomerProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    Object userState
)
Visual C++
public:
void GetCustomerProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    Object^ userState
)
JavaScript
function getCustomerProfileAsync(merchantAuthentication, customerProfileId, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
userState
Type: System..::.Object

Remarks

See Also

Service Class
GetCustomerProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddress Method

[image]

.NET Framework Class Library
Service..::.GetCustomerShippingAddress Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/GetCustomerShippingAddress", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetCustomerShippingAddress ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerAddressId As Long _
) As GetCustomerShippingAddressResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/GetCustomerShippingAddress", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public GetCustomerShippingAddressResponseType GetCustomerShippingAddress(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerAddressId
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/GetCustomerShippingAddress", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
GetCustomerShippingAddressResponseType^ GetCustomerShippingAddress(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerAddressId
)
JavaScript
function getCustomerShippingAddress(merchantAuthentication, customerProfileId, customerAddressId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerAddressId
Type: System..::.Int64

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressAsync Method

[image] [image]

.NET Framework Class Library
Service..::.GetCustomerShippingAddressAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
GetCustomerShippingAddressAsync(MerchantAuthenticationType, Int64, Int64) |
GetCustomerShippingAddressAsync(MerchantAuthenticationType, Int64, Int64, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, Int64)

[image]

.NET Framework Class Library
Service..::.GetCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, Int64)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerShippingAddressAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerAddressId As Long _
)
C#
public void GetCustomerShippingAddressAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerAddressId
)
Visual C++
public:
void GetCustomerShippingAddressAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerAddressId
)
JavaScript
function getCustomerShippingAddressAsync(merchantAuthentication, customerProfileId, customerAddressId);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerAddressId
Type: System..::.Int64

Remarks

See Also

Service Class
GetCustomerShippingAddressAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, Int64, Object)

[image]

.NET Framework Class Library
Service..::.GetCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, Int64, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerShippingAddressAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerAddressId As Long, _
    userState As Object _
)
C#
public void GetCustomerShippingAddressAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerAddressId,
    Object userState
)
Visual C++
public:
void GetCustomerShippingAddressAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerAddressId,
    Object^ userState
)
JavaScript
function getCustomerShippingAddressAsync(merchantAuthentication, customerProfileId, customerAddressId, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerAddressId
Type: System..::.Int64
userState
Type: System..::.Object

Remarks

See Also

Service Class
GetCustomerShippingAddressAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


GetWebResponse Method

[image] [image]

.NET Framework Class Library
Service..::.GetWebResponse Method
Service Class See Also Send Feedback

Overload List

Name | Description
GetWebResponse(WebRequest) | Returns a response from a synchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
GetWebResponse(WebRequest, IAsyncResult) | Returns a response from an asynchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


InvokeAsync Method

[image] [image]

.NET Framework Class Library
Service..::.InvokeAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
InvokeAsync(String, array<Object>[]()[], SendOrPostCallback) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
InvokeAsync(String, array<Object>[]()[], SendOrPostCallback, Object) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


IsAlive Method

[image]

.NET Framework Class Library
Service..::.IsAlive Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/IsAlive", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function IsAlive As ANetApiResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/IsAlive", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public ANetApiResponseType IsAlive()
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/IsAlive", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
ANetApiResponseType^ IsAlive()
JavaScript
function isAlive();

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveAsync Method

[image] [image]

.NET Framework Class Library
Service..::.IsAliveAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
IsAliveAsync()()() |
IsAliveAsync(Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveAsync Method

[image]

.NET Framework Class Library
Service..::.IsAliveAsync Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub IsAliveAsync
C#
public void IsAliveAsync()
Visual C++
public:
void IsAliveAsync()
JavaScript
function isAliveAsync();

Remarks

See Also

Service Class
IsAliveAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveAsync Method (Object)

[image]

.NET Framework Class Library
Service..::.IsAliveAsync Method (Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub IsAliveAsync ( _
    userState As Object _
)
C#
public void IsAliveAsync(
    Object userState
)
Visual C++
public:
void IsAliveAsync(
    Object^ userState
)
JavaScript
function isAliveAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

Service Class
IsAliveAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
Service..::.MemberwiseClone Method
Service Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfile Method

[image]

.NET Framework Class Library
Service..::.UpdateCustomerPaymentProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/UpdateCustomerPaymentProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function UpdateCustomerPaymentProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    paymentProfile As CustomerPaymentProfileExType _
) As UpdateCustomerPaymentProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/UpdateCustomerPaymentProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public UpdateCustomerPaymentProfileResponseType UpdateCustomerPaymentProfile(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerPaymentProfileExType paymentProfile
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/UpdateCustomerPaymentProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
UpdateCustomerPaymentProfileResponseType^ UpdateCustomerPaymentProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerPaymentProfileExType^ paymentProfile
)
JavaScript
function updateCustomerPaymentProfile(merchantAuthentication, customerProfileId, paymentProfile);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
paymentProfile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileExType

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.UpdateCustomerPaymentProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
UpdateCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, CustomerPaymentProfileExType) |
UpdateCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, CustomerPaymentProfileExType, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, CustomerPaymentProfileExType)

[image]

.NET Framework Class Library
Service..::.UpdateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, CustomerPaymentProfileExType)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    paymentProfile As CustomerPaymentProfileExType _
)
C#
public void UpdateCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerPaymentProfileExType paymentProfile
)
Visual C++
public:
void UpdateCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerPaymentProfileExType^ paymentProfile
)
JavaScript
function updateCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, paymentProfile);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
paymentProfile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileExType

Remarks

See Also

Service Class
UpdateCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, CustomerPaymentProfileExType, Object)

[image]

.NET Framework Class Library
Service..::.UpdateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, CustomerPaymentProfileExType, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    paymentProfile As CustomerPaymentProfileExType, _
    userState As Object _
)
C#
public void UpdateCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerPaymentProfileExType paymentProfile,
    Object userState
)
Visual C++
public:
void UpdateCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerPaymentProfileExType^ paymentProfile,
    Object^ userState
)
JavaScript
function updateCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, paymentProfile, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
paymentProfile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerPaymentProfileExType
userState
Type: System..::.Object

Remarks

See Also

Service Class
UpdateCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfile Method

[image]

.NET Framework Class Library
Service..::.UpdateCustomerProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/UpdateCustomerProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function UpdateCustomerProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    profile As CustomerProfileExType _
) As UpdateCustomerProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/UpdateCustomerProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public UpdateCustomerProfileResponseType UpdateCustomerProfile(
    MerchantAuthenticationType merchantAuthentication,
    CustomerProfileExType profile
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/UpdateCustomerProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
UpdateCustomerProfileResponseType^ UpdateCustomerProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    CustomerProfileExType^ profile
)
JavaScript
function updateCustomerProfile(merchantAuthentication, profile);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
profile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileExType

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.UpdateCustomerProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
UpdateCustomerProfileAsync(MerchantAuthenticationType, CustomerProfileExType) |
UpdateCustomerProfileAsync(MerchantAuthenticationType, CustomerProfileExType, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileAsync Method (MerchantAuthenticationType, CustomerProfileExType)

[image]

.NET Framework Class Library
Service..::.UpdateCustomerProfileAsync Method (MerchantAuthenticationType, CustomerProfileExType)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateCustomerProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    profile As CustomerProfileExType _
)
C#
public void UpdateCustomerProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    CustomerProfileExType profile
)
Visual C++
public:
void UpdateCustomerProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    CustomerProfileExType^ profile
)
JavaScript
function updateCustomerProfileAsync(merchantAuthentication, profile);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
profile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileExType

Remarks

See Also

Service Class
UpdateCustomerProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileAsync Method (MerchantAuthenticationType, CustomerProfileExType, Object)

[image]

.NET Framework Class Library
Service..::.UpdateCustomerProfileAsync Method (MerchantAuthenticationType, CustomerProfileExType, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateCustomerProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    profile As CustomerProfileExType, _
    userState As Object _
)
C#
public void UpdateCustomerProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    CustomerProfileExType profile,
    Object userState
)
Visual C++
public:
void UpdateCustomerProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    CustomerProfileExType^ profile,
    Object^ userState
)
JavaScript
function updateCustomerProfileAsync(merchantAuthentication, profile, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
profile
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerProfileExType
userState
Type: System..::.Object

Remarks

See Also

Service Class
UpdateCustomerProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddress Method

[image]

.NET Framework Class Library
Service..::.UpdateCustomerShippingAddress Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/UpdateCustomerShippingAddress", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function UpdateCustomerShippingAddress ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    address As CustomerAddressExType _
) As UpdateCustomerShippingAddressResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/UpdateCustomerShippingAddress", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public UpdateCustomerShippingAddressResponseType UpdateCustomerShippingAddress(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerAddressExType address
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/UpdateCustomerShippingAddress", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
UpdateCustomerShippingAddressResponseType^ UpdateCustomerShippingAddress(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerAddressExType^ address
)
JavaScript
function updateCustomerShippingAddress(merchantAuthentication, customerProfileId, address);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
address
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressExType

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressAsync Method

[image] [image]

.NET Framework Class Library
Service..::.UpdateCustomerShippingAddressAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
UpdateCustomerShippingAddressAsync(MerchantAuthenticationType, Int64, CustomerAddressExType) |
UpdateCustomerShippingAddressAsync(MerchantAuthenticationType, Int64, CustomerAddressExType, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, CustomerAddressExType)

[image]

.NET Framework Class Library
Service..::.UpdateCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, CustomerAddressExType)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateCustomerShippingAddressAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    address As CustomerAddressExType _
)
C#
public void UpdateCustomerShippingAddressAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerAddressExType address
)
Visual C++
public:
void UpdateCustomerShippingAddressAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerAddressExType^ address
)
JavaScript
function updateCustomerShippingAddressAsync(merchantAuthentication, customerProfileId, address);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
address
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressExType

Remarks

See Also

Service Class
UpdateCustomerShippingAddressAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, CustomerAddressExType, Object)

[image]

.NET Framework Class Library
Service..::.UpdateCustomerShippingAddressAsync Method (MerchantAuthenticationType, Int64, CustomerAddressExType, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateCustomerShippingAddressAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    address As CustomerAddressExType, _
    userState As Object _
)
C#
public void UpdateCustomerShippingAddressAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    CustomerAddressExType address,
    Object userState
)
Visual C++
public:
void UpdateCustomerShippingAddressAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    CustomerAddressExType^ address,
    Object^ userState
)
JavaScript
function updateCustomerShippingAddressAsync(merchantAuthentication, customerProfileId, address, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
address
Type: InSite.Domain.AuthorizeNetCIMService..::.CustomerAddressExType
userState
Type: System..::.Object

Remarks

See Also

Service Class
UpdateCustomerShippingAddressAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfile Method

[image]

.NET Framework Class Library
Service..::.ValidateCustomerPaymentProfile Method
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/ValidateCustomerPaymentProfile", RequestNamespace := "https://api.authorize.net/soap/v1/",  _
    ResponseNamespace := "https://api.authorize.net/soap/v1/", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function ValidateCustomerPaymentProfile ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long, _
    customerShippingAddressId As Long, _
    validationMode As ValidationModeEnum _
) As ValidateCustomerPaymentProfileResponseType
C#
[SoapDocumentMethodAttribute("https://api.authorize.net/soap/v1/ValidateCustomerPaymentProfile", RequestNamespace = "https://api.authorize.net/soap/v1/",
    ResponseNamespace = "https://api.authorize.net/soap/v1/", Use = SoapBindingUse.Literal,
    ParameterStyle = SoapParameterStyle.Wrapped)]
public ValidateCustomerPaymentProfileResponseType ValidateCustomerPaymentProfile(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId,
    long customerShippingAddressId,
    ValidationModeEnum validationMode
)
Visual C++
[SoapDocumentMethodAttribute(L"https://api.authorize.net/soap/v1/ValidateCustomerPaymentProfile", RequestNamespace = L"https://api.authorize.net/soap/v1/",
    ResponseNamespace = L"https://api.authorize.net/soap/v1/", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Wrapped)]
public:
ValidateCustomerPaymentProfileResponseType^ ValidateCustomerPaymentProfile(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId,
    long long customerShippingAddressId,
    ValidationModeEnum validationMode
)
JavaScript
function validateCustomerPaymentProfile(merchantAuthentication, customerProfileId, customerPaymentProfileId, customerShippingAddressId, validationMode);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64
customerShippingAddressId
Type: System..::.Int64
validationMode
Type: InSite.Domain.AuthorizeNetCIMService..::.ValidationModeEnum

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileAsync Method

[image] [image]

.NET Framework Class Library
Service..::.ValidateCustomerPaymentProfileAsync Method
Service Class See Also Send Feedback

Overload List

Name | Description
ValidateCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, Int64, Int64, ValidationModeEnum) |
ValidateCustomerPaymentProfileAsync(MerchantAuthenticationType, Int64, Int64, Int64, ValidationModeEnum, Object) |

See Also

Service Class
Service Members
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64, Int64, ValidationModeEnum)

[image]

.NET Framework Class Library
Service..::.ValidateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64, Int64, ValidationModeEnum)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ValidateCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long, _
    customerShippingAddressId As Long, _
    validationMode As ValidationModeEnum _
)
C#
public void ValidateCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId,
    long customerShippingAddressId,
    ValidationModeEnum validationMode
)
Visual C++
public:
void ValidateCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId,
    long long customerShippingAddressId,
    ValidationModeEnum validationMode
)
JavaScript
function validateCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, customerPaymentProfileId, customerShippingAddressId, validationMode);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64
customerShippingAddressId
Type: System..::.Int64
validationMode
Type: InSite.Domain.AuthorizeNetCIMService..::.ValidationModeEnum

Remarks

See Also

Service Class
ValidateCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64, Int64, ValidationModeEnum, Object)

[image]

.NET Framework Class Library
Service..::.ValidateCustomerPaymentProfileAsync Method (MerchantAuthenticationType, Int64, Int64, Int64, ValidationModeEnum, Object)
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ValidateCustomerPaymentProfileAsync ( _
    merchantAuthentication As MerchantAuthenticationType, _
    customerProfileId As Long, _
    customerPaymentProfileId As Long, _
    customerShippingAddressId As Long, _
    validationMode As ValidationModeEnum, _
    userState As Object _
)
C#
public void ValidateCustomerPaymentProfileAsync(
    MerchantAuthenticationType merchantAuthentication,
    long customerProfileId,
    long customerPaymentProfileId,
    long customerShippingAddressId,
    ValidationModeEnum validationMode,
    Object userState
)
Visual C++
public:
void ValidateCustomerPaymentProfileAsync(
    MerchantAuthenticationType^ merchantAuthentication,
    long long customerProfileId,
    long long customerPaymentProfileId,
    long long customerShippingAddressId,
    ValidationModeEnum validationMode,
    Object^ userState
)
JavaScript
function validateCustomerPaymentProfileAsync(merchantAuthentication, customerProfileId, customerPaymentProfileId, customerShippingAddressId, validationMode, userState);

Parameters

merchantAuthentication
Type: InSite.Domain.AuthorizeNetCIMService..::.MerchantAuthenticationType
customerProfileId
Type: System..::.Int64
customerPaymentProfileId
Type: System..::.Int64
customerShippingAddressId
Type: System..::.Int64
validationMode
Type: InSite.Domain.AuthorizeNetCIMService..::.ValidationModeEnum
userState
Type: System..::.Object

Remarks

See Also

Service Class
ValidateCustomerPaymentProfileAsync Overload
InSite.Domain.AuthorizeNetCIMService Namespace


Service Properties

[image] [image]

.NET Framework Class Library
Service Properties
Service Class See Also Send Feedback

The Service type exposes the following members.

Properties

Name | Description
AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true. (Inherited from HttpWebClientProtocol.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Url |
UseDefaultCredentials |
UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


Url Property

[image]

.NET Framework Class Library
Service..::.Url Property
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url { get; set; }
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_url();
function set_url(value);

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


UseDefaultCredentials Property

[image]

.NET Framework Class Library
Service..::.UseDefaultCredentials Property
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UseDefaultCredentials As Boolean
C#
public bool UseDefaultCredentials { get; set; }
Visual C++
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useDefaultCredentials();
function set_useDefaultCredentials(value);

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


Service Events

[image] [image]

.NET Framework Class Library
Service Events
Service Class See Also Send Feedback

The Service type exposes the following members.

Events

Name | Description
ARBCancelSubscriptionCompleted |
ARBCreateSubscriptionCompleted |
ARBUpdateSubscriptionCompleted |
AuthenticateTestCompleted |
CreateCustomerPaymentProfileCompleted |
CreateCustomerProfileCompleted |
CreateCustomerProfileTransactionCompleted |
CreateCustomerShippingAddressCompleted |
DeleteCustomerPaymentProfileCompleted |
DeleteCustomerProfileCompleted |
DeleteCustomerShippingAddressCompleted |
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
GetCustomerPaymentProfileCompleted |
GetCustomerProfileCompleted |
GetCustomerShippingAddressCompleted |
IsAliveCompleted |
UpdateCustomerPaymentProfileCompleted |
UpdateCustomerProfileCompleted |
UpdateCustomerShippingAddressCompleted |
ValidateCustomerPaymentProfileCompleted |

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCancelSubscriptionCompleted Event

[image]

.NET Framework Class Library
Service..::.ARBCancelSubscriptionCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event ARBCancelSubscriptionCompleted As ARBCancelSubscriptionCompletedEventHandler
C#
public event ARBCancelSubscriptionCompletedEventHandler ARBCancelSubscriptionCompleted
Visual C++
public:
 event ARBCancelSubscriptionCompletedEventHandler^ ARBCancelSubscriptionCompleted {
    void add (ARBCancelSubscriptionCompletedEventHandler^ value);
    void remove (ARBCancelSubscriptionCompletedEventHandler^ value);
}
JavaScript
function add_arbCancelSubscriptionCompleted(value);
function remove_arbCancelSubscriptionCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBCreateSubscriptionCompleted Event

[image]

.NET Framework Class Library
Service..::.ARBCreateSubscriptionCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event ARBCreateSubscriptionCompleted As ARBCreateSubscriptionCompletedEventHandler
C#
public event ARBCreateSubscriptionCompletedEventHandler ARBCreateSubscriptionCompleted
Visual C++
public:
 event ARBCreateSubscriptionCompletedEventHandler^ ARBCreateSubscriptionCompleted {
    void add (ARBCreateSubscriptionCompletedEventHandler^ value);
    void remove (ARBCreateSubscriptionCompletedEventHandler^ value);
}
JavaScript
function add_arbCreateSubscriptionCompleted(value);
function remove_arbCreateSubscriptionCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ARBUpdateSubscriptionCompleted Event

[image]

.NET Framework Class Library
Service..::.ARBUpdateSubscriptionCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event ARBUpdateSubscriptionCompleted As ARBUpdateSubscriptionCompletedEventHandler
C#
public event ARBUpdateSubscriptionCompletedEventHandler ARBUpdateSubscriptionCompleted
Visual C++
public:
 event ARBUpdateSubscriptionCompletedEventHandler^ ARBUpdateSubscriptionCompleted {
    void add (ARBUpdateSubscriptionCompletedEventHandler^ value);
    void remove (ARBUpdateSubscriptionCompletedEventHandler^ value);
}
JavaScript
function add_arbUpdateSubscriptionCompleted(value);
function remove_arbUpdateSubscriptionCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


AuthenticateTestCompleted Event

[image]

.NET Framework Class Library
Service..::.AuthenticateTestCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event AuthenticateTestCompleted As AuthenticateTestCompletedEventHandler
C#
public event AuthenticateTestCompletedEventHandler AuthenticateTestCompleted
Visual C++
public:
 event AuthenticateTestCompletedEventHandler^ AuthenticateTestCompleted {
    void add (AuthenticateTestCompletedEventHandler^ value);
    void remove (AuthenticateTestCompletedEventHandler^ value);
}
JavaScript
function add_authenticateTestCompleted(value);
function remove_authenticateTestCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerPaymentProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.CreateCustomerPaymentProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event CreateCustomerPaymentProfileCompleted As CreateCustomerPaymentProfileCompletedEventHandler
C#
public event CreateCustomerPaymentProfileCompletedEventHandler CreateCustomerPaymentProfileCompleted
Visual C++
public:
 event CreateCustomerPaymentProfileCompletedEventHandler^ CreateCustomerPaymentProfileCompleted {
    void add (CreateCustomerPaymentProfileCompletedEventHandler^ value);
    void remove (CreateCustomerPaymentProfileCompletedEventHandler^ value);
}
JavaScript
function add_createCustomerPaymentProfileCompleted(value);
function remove_createCustomerPaymentProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.CreateCustomerProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event CreateCustomerProfileCompleted As CreateCustomerProfileCompletedEventHandler
C#
public event CreateCustomerProfileCompletedEventHandler CreateCustomerProfileCompleted
Visual C++
public:
 event CreateCustomerProfileCompletedEventHandler^ CreateCustomerProfileCompleted {
    void add (CreateCustomerProfileCompletedEventHandler^ value);
    void remove (CreateCustomerProfileCompletedEventHandler^ value);
}
JavaScript
function add_createCustomerProfileCompleted(value);
function remove_createCustomerProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerProfileTransactionCompleted Event

[image]

.NET Framework Class Library
Service..::.CreateCustomerProfileTransactionCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event CreateCustomerProfileTransactionCompleted As CreateCustomerProfileTransactionCompletedEventHandler
C#
public event CreateCustomerProfileTransactionCompletedEventHandler CreateCustomerProfileTransactionCompleted
Visual C++
public:
 event CreateCustomerProfileTransactionCompletedEventHandler^ CreateCustomerProfileTransactionCompleted {
    void add (CreateCustomerProfileTransactionCompletedEventHandler^ value);
    void remove (CreateCustomerProfileTransactionCompletedEventHandler^ value);
}
JavaScript
function add_createCustomerProfileTransactionCompleted(value);
function remove_createCustomerProfileTransactionCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


CreateCustomerShippingAddressCompleted Event

[image]

.NET Framework Class Library
Service..::.CreateCustomerShippingAddressCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event CreateCustomerShippingAddressCompleted As CreateCustomerShippingAddressCompletedEventHandler
C#
public event CreateCustomerShippingAddressCompletedEventHandler CreateCustomerShippingAddressCompleted
Visual C++
public:
 event CreateCustomerShippingAddressCompletedEventHandler^ CreateCustomerShippingAddressCompleted {
    void add (CreateCustomerShippingAddressCompletedEventHandler^ value);
    void remove (CreateCustomerShippingAddressCompletedEventHandler^ value);
}
JavaScript
function add_createCustomerShippingAddressCompleted(value);
function remove_createCustomerShippingAddressCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerPaymentProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.DeleteCustomerPaymentProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event DeleteCustomerPaymentProfileCompleted As DeleteCustomerPaymentProfileCompletedEventHandler
C#
public event DeleteCustomerPaymentProfileCompletedEventHandler DeleteCustomerPaymentProfileCompleted
Visual C++
public:
 event DeleteCustomerPaymentProfileCompletedEventHandler^ DeleteCustomerPaymentProfileCompleted {
    void add (DeleteCustomerPaymentProfileCompletedEventHandler^ value);
    void remove (DeleteCustomerPaymentProfileCompletedEventHandler^ value);
}
JavaScript
function add_deleteCustomerPaymentProfileCompleted(value);
function remove_deleteCustomerPaymentProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.DeleteCustomerProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event DeleteCustomerProfileCompleted As DeleteCustomerProfileCompletedEventHandler
C#
public event DeleteCustomerProfileCompletedEventHandler DeleteCustomerProfileCompleted
Visual C++
public:
 event DeleteCustomerProfileCompletedEventHandler^ DeleteCustomerProfileCompleted {
    void add (DeleteCustomerProfileCompletedEventHandler^ value);
    void remove (DeleteCustomerProfileCompletedEventHandler^ value);
}
JavaScript
function add_deleteCustomerProfileCompleted(value);
function remove_deleteCustomerProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


DeleteCustomerShippingAddressCompleted Event

[image]

.NET Framework Class Library
Service..::.DeleteCustomerShippingAddressCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event DeleteCustomerShippingAddressCompleted As DeleteCustomerShippingAddressCompletedEventHandler
C#
public event DeleteCustomerShippingAddressCompletedEventHandler DeleteCustomerShippingAddressCompleted
Visual C++
public:
 event DeleteCustomerShippingAddressCompletedEventHandler^ DeleteCustomerShippingAddressCompleted {
    void add (DeleteCustomerShippingAddressCompletedEventHandler^ value);
    void remove (DeleteCustomerShippingAddressCompletedEventHandler^ value);
}
JavaScript
function add_deleteCustomerShippingAddressCompleted(value);
function remove_deleteCustomerShippingAddressCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerPaymentProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.GetCustomerPaymentProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetCustomerPaymentProfileCompleted As GetCustomerPaymentProfileCompletedEventHandler
C#
public event GetCustomerPaymentProfileCompletedEventHandler GetCustomerPaymentProfileCompleted
Visual C++
public:
 event GetCustomerPaymentProfileCompletedEventHandler^ GetCustomerPaymentProfileCompleted {
    void add (GetCustomerPaymentProfileCompletedEventHandler^ value);
    void remove (GetCustomerPaymentProfileCompletedEventHandler^ value);
}
JavaScript
function add_getCustomerPaymentProfileCompleted(value);
function remove_getCustomerPaymentProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.GetCustomerProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetCustomerProfileCompleted As GetCustomerProfileCompletedEventHandler
C#
public event GetCustomerProfileCompletedEventHandler GetCustomerProfileCompleted
Visual C++
public:
 event GetCustomerProfileCompletedEventHandler^ GetCustomerProfileCompleted {
    void add (GetCustomerProfileCompletedEventHandler^ value);
    void remove (GetCustomerProfileCompletedEventHandler^ value);
}
JavaScript
function add_getCustomerProfileCompleted(value);
function remove_getCustomerProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


GetCustomerShippingAddressCompleted Event

[image]

.NET Framework Class Library
Service..::.GetCustomerShippingAddressCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetCustomerShippingAddressCompleted As GetCustomerShippingAddressCompletedEventHandler
C#
public event GetCustomerShippingAddressCompletedEventHandler GetCustomerShippingAddressCompleted
Visual C++
public:
 event GetCustomerShippingAddressCompletedEventHandler^ GetCustomerShippingAddressCompleted {
    void add (GetCustomerShippingAddressCompletedEventHandler^ value);
    void remove (GetCustomerShippingAddressCompletedEventHandler^ value);
}
JavaScript
function add_getCustomerShippingAddressCompleted(value);
function remove_getCustomerShippingAddressCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


IsAliveCompleted Event

[image]

.NET Framework Class Library
Service..::.IsAliveCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event IsAliveCompleted As IsAliveCompletedEventHandler
C#
public event IsAliveCompletedEventHandler IsAliveCompleted
Visual C++
public:
 event IsAliveCompletedEventHandler^ IsAliveCompleted {
    void add (IsAliveCompletedEventHandler^ value);
    void remove (IsAliveCompletedEventHandler^ value);
}
JavaScript
function add_isAliveCompleted(value);
function remove_isAliveCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.UpdateCustomerPaymentProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event UpdateCustomerPaymentProfileCompleted As UpdateCustomerPaymentProfileCompletedEventHandler
C#
public event UpdateCustomerPaymentProfileCompletedEventHandler UpdateCustomerPaymentProfileCompleted
Visual C++
public:
 event UpdateCustomerPaymentProfileCompletedEventHandler^ UpdateCustomerPaymentProfileCompleted {
    void add (UpdateCustomerPaymentProfileCompletedEventHandler^ value);
    void remove (UpdateCustomerPaymentProfileCompletedEventHandler^ value);
}
JavaScript
function add_updateCustomerPaymentProfileCompleted(value);
function remove_updateCustomerPaymentProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.UpdateCustomerProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event UpdateCustomerProfileCompleted As UpdateCustomerProfileCompletedEventHandler
C#
public event UpdateCustomerProfileCompletedEventHandler UpdateCustomerProfileCompleted
Visual C++
public:
 event UpdateCustomerProfileCompletedEventHandler^ UpdateCustomerProfileCompleted {
    void add (UpdateCustomerProfileCompletedEventHandler^ value);
    void remove (UpdateCustomerProfileCompletedEventHandler^ value);
}
JavaScript
function add_updateCustomerProfileCompleted(value);
function remove_updateCustomerProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressCompleted Event

[image]

.NET Framework Class Library
Service..::.UpdateCustomerShippingAddressCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event UpdateCustomerShippingAddressCompleted As UpdateCustomerShippingAddressCompletedEventHandler
C#
public event UpdateCustomerShippingAddressCompletedEventHandler UpdateCustomerShippingAddressCompleted
Visual C++
public:
 event UpdateCustomerShippingAddressCompletedEventHandler^ UpdateCustomerShippingAddressCompleted {
    void add (UpdateCustomerShippingAddressCompletedEventHandler^ value);
    void remove (UpdateCustomerShippingAddressCompletedEventHandler^ value);
}
JavaScript
function add_updateCustomerShippingAddressCompleted(value);
function remove_updateCustomerShippingAddressCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileCompleted Event

[image]

.NET Framework Class Library
Service..::.ValidateCustomerPaymentProfileCompleted Event
Service Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event ValidateCustomerPaymentProfileCompleted As ValidateCustomerPaymentProfileCompletedEventHandler
C#
public event ValidateCustomerPaymentProfileCompletedEventHandler ValidateCustomerPaymentProfileCompleted
Visual C++
public:
 event ValidateCustomerPaymentProfileCompletedEventHandler^ ValidateCustomerPaymentProfileCompleted {
    void add (ValidateCustomerPaymentProfileCompletedEventHandler^ value);
    void remove (ValidateCustomerPaymentProfileCompletedEventHandler^ value);
}
JavaScript
function add_validateCustomerPaymentProfileCompleted(value);
function remove_validateCustomerPaymentProfileCompleted(value);

Remarks

See Also

Service Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
UpdateCustomerPaymentProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class UpdateCustomerPaymentProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class UpdateCustomerPaymentProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class UpdateCustomerPaymentProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerPaymentProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.UpdateCustomerPaymentProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerPaymentProfileCompletedEventArgs

See Also

UpdateCustomerPaymentProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
UpdateCustomerPaymentProfileCompletedEventArgs Members
UpdateCustomerPaymentProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The UpdateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

UpdateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
UpdateCustomerPaymentProfileCompletedEventArgs Methods
UpdateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The UpdateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
UpdateCustomerPaymentProfileCompletedEventArgs Properties
UpdateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The UpdateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

UpdateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
UpdateCustomerPaymentProfileCompletedEventArgs..::.Result Property
UpdateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As UpdateCustomerPaymentProfileResponseType
C#
public UpdateCustomerPaymentProfileResponseType Result { get; }
Visual C++
public:
property UpdateCustomerPaymentProfileResponseType^ Result {
    UpdateCustomerPaymentProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

UpdateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
UpdateCustomerPaymentProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub UpdateCustomerPaymentProfileCompletedEventHandler ( _
    sender As Object, _
    e As UpdateCustomerPaymentProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void UpdateCustomerPaymentProfileCompletedEventHandler(
    Object sender,
    UpdateCustomerPaymentProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void UpdateCustomerPaymentProfileCompletedEventHandler(
    Object^ sender,
    UpdateCustomerPaymentProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerPaymentProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileResponseType Class

[image]

.NET Framework Class Library
UpdateCustomerPaymentProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class UpdateCustomerPaymentProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class UpdateCustomerPaymentProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class UpdateCustomerPaymentProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerPaymentProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.UpdateCustomerPaymentProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerPaymentProfileResponseType

See Also

UpdateCustomerPaymentProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileResponseType Members

[image] [image]

.NET Framework Class Library
UpdateCustomerPaymentProfileResponseType Members
UpdateCustomerPaymentProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The UpdateCustomerPaymentProfileResponseType type exposes the following members.

Constructors

Name | Description
UpdateCustomerPaymentProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

UpdateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileResponseType Constructor

[image]

.NET Framework Class Library
UpdateCustomerPaymentProfileResponseType Constructor
UpdateCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UpdateCustomerPaymentProfileResponseType()
Visual C++
public:
UpdateCustomerPaymentProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerPaymentProfileResponseType = function();

See Also

UpdateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileResponseType Methods

[image] [image]

.NET Framework Class Library
UpdateCustomerPaymentProfileResponseType Methods
UpdateCustomerPaymentProfileResponseType Class See Also Send Feedback

The UpdateCustomerPaymentProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerPaymentProfileResponseType Properties

[image] [image]

.NET Framework Class Library
UpdateCustomerPaymentProfileResponseType Properties
UpdateCustomerPaymentProfileResponseType Class See Also Send Feedback

The UpdateCustomerPaymentProfileResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

UpdateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
UpdateCustomerProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class UpdateCustomerProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class UpdateCustomerProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class UpdateCustomerProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.UpdateCustomerProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerProfileCompletedEventArgs

See Also

UpdateCustomerProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
UpdateCustomerProfileCompletedEventArgs Members
UpdateCustomerProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The UpdateCustomerProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

UpdateCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
UpdateCustomerProfileCompletedEventArgs Methods
UpdateCustomerProfileCompletedEventArgs Class See Also Send Feedback

The UpdateCustomerProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
UpdateCustomerProfileCompletedEventArgs Properties
UpdateCustomerProfileCompletedEventArgs Class See Also Send Feedback

The UpdateCustomerProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

UpdateCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
UpdateCustomerProfileCompletedEventArgs..::.Result Property
UpdateCustomerProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As UpdateCustomerProfileResponseType
C#
public UpdateCustomerProfileResponseType Result { get; }
Visual C++
public:
property UpdateCustomerProfileResponseType^ Result {
    UpdateCustomerProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

UpdateCustomerProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
UpdateCustomerProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub UpdateCustomerProfileCompletedEventHandler ( _
    sender As Object, _
    e As UpdateCustomerProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void UpdateCustomerProfileCompletedEventHandler(
    Object sender,
    UpdateCustomerProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void UpdateCustomerProfileCompletedEventHandler(
    Object^ sender,
    UpdateCustomerProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileResponseType Class

[image]

.NET Framework Class Library
UpdateCustomerProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class UpdateCustomerProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class UpdateCustomerProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class UpdateCustomerProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.UpdateCustomerProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerProfileResponseType

See Also

UpdateCustomerProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileResponseType Members

[image] [image]

.NET Framework Class Library
UpdateCustomerProfileResponseType Members
UpdateCustomerProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The UpdateCustomerProfileResponseType type exposes the following members.

Constructors

Name | Description
UpdateCustomerProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

UpdateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileResponseType Constructor

[image]

.NET Framework Class Library
UpdateCustomerProfileResponseType Constructor
UpdateCustomerProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UpdateCustomerProfileResponseType()
Visual C++
public:
UpdateCustomerProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerProfileResponseType = function();

See Also

UpdateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileResponseType Methods

[image] [image]

.NET Framework Class Library
UpdateCustomerProfileResponseType Methods
UpdateCustomerProfileResponseType Class See Also Send Feedback

The UpdateCustomerProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerProfileResponseType Properties

[image] [image]

.NET Framework Class Library
UpdateCustomerProfileResponseType Properties
UpdateCustomerProfileResponseType Class See Also Send Feedback

The UpdateCustomerProfileResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

UpdateCustomerProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressCompletedEventArgs Class

[image]

.NET Framework Class Library
UpdateCustomerShippingAddressCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class UpdateCustomerShippingAddressCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class UpdateCustomerShippingAddressCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class UpdateCustomerShippingAddressCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerShippingAddressCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.UpdateCustomerShippingAddressCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerShippingAddressCompletedEventArgs

See Also

UpdateCustomerShippingAddressCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
UpdateCustomerShippingAddressCompletedEventArgs Members
UpdateCustomerShippingAddressCompletedEventArgs Class Methods Properties See Also Send Feedback

The UpdateCustomerShippingAddressCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

UpdateCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
UpdateCustomerShippingAddressCompletedEventArgs Methods
UpdateCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

The UpdateCustomerShippingAddressCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
UpdateCustomerShippingAddressCompletedEventArgs Properties
UpdateCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

The UpdateCustomerShippingAddressCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

UpdateCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
UpdateCustomerShippingAddressCompletedEventArgs..::.Result Property
UpdateCustomerShippingAddressCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As UpdateCustomerShippingAddressResponseType
C#
public UpdateCustomerShippingAddressResponseType Result { get; }
Visual C++
public:
property UpdateCustomerShippingAddressResponseType^ Result {
    UpdateCustomerShippingAddressResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

UpdateCustomerShippingAddressCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressCompletedEventHandler Delegate

[image]

.NET Framework Class Library
UpdateCustomerShippingAddressCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub UpdateCustomerShippingAddressCompletedEventHandler ( _
    sender As Object, _
    e As UpdateCustomerShippingAddressCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void UpdateCustomerShippingAddressCompletedEventHandler(
    Object sender,
    UpdateCustomerShippingAddressCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void UpdateCustomerShippingAddressCompletedEventHandler(
    Object^ sender,
    UpdateCustomerShippingAddressCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerShippingAddressCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressResponseType Class

[image]

.NET Framework Class Library
UpdateCustomerShippingAddressResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class UpdateCustomerShippingAddressResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class UpdateCustomerShippingAddressResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class UpdateCustomerShippingAddressResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerShippingAddressResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.UpdateCustomerShippingAddressResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.UpdateCustomerShippingAddressResponseType

See Also

UpdateCustomerShippingAddressResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressResponseType Members

[image] [image]

.NET Framework Class Library
UpdateCustomerShippingAddressResponseType Members
UpdateCustomerShippingAddressResponseType Class Constructors Methods Properties See Also Send Feedback

The UpdateCustomerShippingAddressResponseType type exposes the following members.

Constructors

Name | Description
UpdateCustomerShippingAddressResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

UpdateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressResponseType Constructor

[image]

.NET Framework Class Library
UpdateCustomerShippingAddressResponseType Constructor
UpdateCustomerShippingAddressResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UpdateCustomerShippingAddressResponseType()
Visual C++
public:
UpdateCustomerShippingAddressResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.UpdateCustomerShippingAddressResponseType = function();

See Also

UpdateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressResponseType Methods

[image] [image]

.NET Framework Class Library
UpdateCustomerShippingAddressResponseType Methods
UpdateCustomerShippingAddressResponseType Class See Also Send Feedback

The UpdateCustomerShippingAddressResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


UpdateCustomerShippingAddressResponseType Properties

[image] [image]

.NET Framework Class Library
UpdateCustomerShippingAddressResponseType Properties
UpdateCustomerShippingAddressResponseType Class See Also Send Feedback

The UpdateCustomerShippingAddressResponseType type exposes the following members.

Properties

Name | Description
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

UpdateCustomerShippingAddressResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileCompletedEventArgs Class

[image]

.NET Framework Class Library
ValidateCustomerPaymentProfileCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Class ValidateCustomerPaymentProfileCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public class ValidateCustomerPaymentProfileCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public ref class ValidateCustomerPaymentProfileCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.AuthorizeNetCIMService.ValidateCustomerPaymentProfileCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ValidateCustomerPaymentProfileCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.AuthorizeNetCIMService..::.ValidateCustomerPaymentProfileCompletedEventArgs

See Also

ValidateCustomerPaymentProfileCompletedEventArgs Members
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
ValidateCustomerPaymentProfileCompletedEventArgs Members
ValidateCustomerPaymentProfileCompletedEventArgs Class Methods Properties See Also Send Feedback

The ValidateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ValidateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
ValidateCustomerPaymentProfileCompletedEventArgs Methods
ValidateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The ValidateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
ValidateCustomerPaymentProfileCompletedEventArgs Properties
ValidateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

The ValidateCustomerPaymentProfileCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

ValidateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


Result Property

[image]

.NET Framework Class Library
ValidateCustomerPaymentProfileCompletedEventArgs..::.Result Property
ValidateCustomerPaymentProfileCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As ValidateCustomerPaymentProfileResponseType
C#
public ValidateCustomerPaymentProfileResponseType Result { get; }
Visual C++
public:
property ValidateCustomerPaymentProfileResponseType^ Result {
    ValidateCustomerPaymentProfileResponseType^ get ();
}
JavaScript
function get_result();

Remarks

See Also

ValidateCustomerPaymentProfileCompletedEventArgs Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileCompletedEventHandler Delegate

[image]

.NET Framework Class Library
ValidateCustomerPaymentProfileCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")> _
Public Delegate Sub ValidateCustomerPaymentProfileCompletedEventHandler ( _
    sender As Object, _
    e As ValidateCustomerPaymentProfileCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.1434")]
public delegate void ValidateCustomerPaymentProfileCompletedEventHandler(
    Object sender,
    ValidateCustomerPaymentProfileCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.1434")]
public delegate void ValidateCustomerPaymentProfileCompletedEventHandler(
    Object^ sender,
    ValidateCustomerPaymentProfileCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.AuthorizeNetCIMService..::.ValidateCustomerPaymentProfileCompletedEventArgs

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileResponseType Class

[image]

.NET Framework Class Library
ValidateCustomerPaymentProfileResponseType Class
Members See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Class ValidateCustomerPaymentProfileResponseType _
    Inherits ANetApiResponseType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public class ValidateCustomerPaymentProfileResponseType : ANetApiResponseType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public ref class ValidateCustomerPaymentProfileResponseType : public ANetApiResponseType
JavaScript
InSite.Domain.AuthorizeNetCIMService.ValidateCustomerPaymentProfileResponseType = function();

Type.createClass(
    'InSite.Domain.AuthorizeNetCIMService.ValidateCustomerPaymentProfileResponseType',
    InSite.Domain.AuthorizeNetCIMService.ANetApiResponseType);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.AuthorizeNetCIMService..::.ANetApiResponseType
InSite.Domain.AuthorizeNetCIMService..::.ValidateCustomerPaymentProfileResponseType

See Also

ValidateCustomerPaymentProfileResponseType Members
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileResponseType Members

[image] [image]

.NET Framework Class Library
ValidateCustomerPaymentProfileResponseType Members
ValidateCustomerPaymentProfileResponseType Class Constructors Methods Properties See Also Send Feedback

The ValidateCustomerPaymentProfileResponseType type exposes the following members.

Constructors

Name | Description
ValidateCustomerPaymentProfileResponseType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
directResponse |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

ValidateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileResponseType Constructor

[image]

.NET Framework Class Library
ValidateCustomerPaymentProfileResponseType Constructor
ValidateCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ValidateCustomerPaymentProfileResponseType()
Visual C++
public:
ValidateCustomerPaymentProfileResponseType()
JavaScript
InSite.Domain.AuthorizeNetCIMService.ValidateCustomerPaymentProfileResponseType = function();

See Also

ValidateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileResponseType Methods

[image] [image]

.NET Framework Class Library
ValidateCustomerPaymentProfileResponseType Methods
ValidateCustomerPaymentProfileResponseType Class See Also Send Feedback

The ValidateCustomerPaymentProfileResponseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidateCustomerPaymentProfileResponseType Properties

[image] [image]

.NET Framework Class Library
ValidateCustomerPaymentProfileResponseType Properties
ValidateCustomerPaymentProfileResponseType Class See Also Send Feedback

The ValidateCustomerPaymentProfileResponseType type exposes the following members.

Properties

Name | Description
directResponse |
messages | (Inherited from ANetApiResponseType.)
resultCode | (Inherited from ANetApiResponseType.)

See Also

ValidateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


directResponse Property

[image]

.NET Framework Class Library
ValidateCustomerPaymentProfileResponseType..::.directResponse Property
ValidateCustomerPaymentProfileResponseType Class See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directResponse As String
C#
public string directResponse { get; set; }
Visual C++
public:
property String^ directResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_directResponse();
function set_directResponse(value);

Remarks

See Also

ValidateCustomerPaymentProfileResponseType Class
InSite.Domain.AuthorizeNetCIMService Namespace


ValidationModeEnum Enumeration

[image]

.NET Framework Class Library
ValidationModeEnum Enumeration
See Also Send Feedback

Namespace: InSite.Domain.AuthorizeNetCIMService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")> _
Public Enumeration ValidationModeEnum
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.1434")]
public enum ValidationModeEnum
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.1434")]
public enum class ValidationModeEnum
JavaScript
InSite.Domain.AuthorizeNetCIMService.ValidationModeEnum = function();
InSite.Domain.AuthorizeNetCIMService.ValidationModeEnum.createEnum('InSite.Domain.AuthorizeNetCIMService.ValidationModeEnum', false);

Members

Member name | Description
none |
testMode |
liveMode |

Remarks

See Also

InSite.Domain.AuthorizeNetCIMService Namespace


InSite.Domain.CustomerOrders Namespace

[image]

.NET Framework Class Library
InSite.Domain.CustomerOrders Namespace
Send Feedback

Classes

Class | Description
CustomerOrderProcessor |


CustomerOrderProcessor Class

[image]

.NET Framework Class Library
CustomerOrderProcessor Class
Members See Also Send Feedback

Namespace: InSite.Domain.CustomerOrders
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class CustomerOrderProcessor _
    Implements ICustomerOrderProcessor
C#
public class CustomerOrderProcessor : ICustomerOrderProcessor
Visual C++
public ref class CustomerOrderProcessor : ICustomerOrderProcessor
JavaScript
InSite.Domain.CustomerOrders.CustomerOrderProcessor = function();

Type.createClass(
    'InSite.Domain.CustomerOrders.CustomerOrderProcessor',
    null,
    InSite.Model.ICustomerOrderProcessor);

Inheritance Hierarchy

System..::.Object
InSite.Domain.CustomerOrders..::.CustomerOrderProcessor

See Also

CustomerOrderProcessor Members
InSite.Domain.CustomerOrders Namespace


CustomerOrderProcessor Members

[image] [image]

.NET Framework Class Library
CustomerOrderProcessor Members
CustomerOrderProcessor Class Constructors Methods See Also Send Feedback

The CustomerOrderProcessor type exposes the following members.

Constructors

Name | Description
CustomerOrderProcessor |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetUpOrder |
SubmitOrder |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerOrderProcessor Class
InSite.Domain.CustomerOrders Namespace


CustomerOrderProcessor Constructor

[image]

.NET Framework Class Library
CustomerOrderProcessor Constructor
CustomerOrderProcessor Class See Also Send Feedback

Namespace: InSite.Domain.CustomerOrders
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerOrderProcessor()
Visual C++
public:
CustomerOrderProcessor()
JavaScript
InSite.Domain.CustomerOrders.CustomerOrderProcessor = function();

See Also

CustomerOrderProcessor Class
InSite.Domain.CustomerOrders Namespace


CustomerOrderProcessor Methods

[image] [image]

.NET Framework Class Library
CustomerOrderProcessor Methods
CustomerOrderProcessor Class See Also Send Feedback

The CustomerOrderProcessor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetUpOrder |
SubmitOrder |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerOrderProcessor Class
InSite.Domain.CustomerOrders Namespace


SetUpOrder Method

[image]

.NET Framework Class Library
CustomerOrderProcessor..::.SetUpOrder Method
CustomerOrderProcessor Class See Also Send Feedback

Namespace: InSite.Domain.CustomerOrders
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SetUpOrder ( _
    customerOrder As CustomerOrder, _
    returnURL As String, _
    cancelURL As String _
) As String
C#
public string SetUpOrder(
    CustomerOrder customerOrder,
    string returnURL,
    string cancelURL
)
Visual C++
public:
virtual String^ SetUpOrder(
    CustomerOrder^ customerOrder,
    String^ returnURL,
    String^ cancelURL
) sealed
JavaScript
function setUpOrder(customerOrder, returnURL, cancelURL);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
returnURL
Type: System..::.String
cancelURL
Type: System..::.String

Implements

ICustomerOrderProcessor..::.SetUpOrder(CustomerOrder, String, String)

See Also

CustomerOrderProcessor Class
InSite.Domain.CustomerOrders Namespace


SubmitOrder Method

[image]

.NET Framework Class Library
CustomerOrderProcessor..::.SubmitOrder Method
CustomerOrderProcessor Class See Also Send Feedback

Namespace: InSite.Domain.CustomerOrders
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitOrder ( _
    customerOrder As CustomerOrder _
)
C#
public void SubmitOrder(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual void SubmitOrder(
    CustomerOrder^ customerOrder
) sealed
JavaScript
function submitOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Implements

ICustomerOrderProcessor..::.SubmitOrder(CustomerOrder)

See Also

CustomerOrderProcessor Class
InSite.Domain.CustomerOrders Namespace


InSite.Domain.CyberSourceService Namespace

[image]

.NET Framework Class Library
InSite.Domain.CyberSourceService Namespace
Send Feedback

Classes

Class | Description
Address |
AFSReply |
AFSService |
AirlineData |
BankInfo |
BankTransferRealTimeReply |
BankTransferRealTimeService |
BankTransferRefundReply |
BankTransferRefundService |
BankTransferReply |
BankTransferService |
Batch |
BillTo |
BML |
BoletoPaymentReply |
BoletoPaymentService |
BusinessRules |
Card |
CCAuthReply |
CCAuthReversalReply |
CCAuthReversalService |
CCAuthService |
CCAutoAuthReversalReply |
CCAutoAuthReversalService |
CCCaptureReply |
CCCaptureService |
CCCreditReply |
CCCreditService |
CCDCCReply |
CCDCCService |
Check |
ChinaPaymentReply |
ChinaPaymentService |
ChinaRefundReply |
ChinaRefundService |
DAVReply |
DAVService |
DCC |
DecisionManager |
DecisionReply |
DeniedPartiesMatch |
DirectDebitMandateReply |
DirectDebitMandateService |
DirectDebitRefundReply |
DirectDebitRefundService |
DirectDebitReply |
DirectDebitService |
DirectDebitValidateReply |
DirectDebitValidateService |
ECCreditReply |
ECCreditService |
ECDebitReply |
ECDebitService |
ExportReply |
ExportService |
FundingTotals |
FundTransfer |
FXQuote |
FXRatesReply |
FXRatesService |
GECC |
inputMessageIn |
Installment |
InvoiceHeader |
Item |
JPO |
Leg |
MerchantDefinedData |
MerchantSecureData |
OtherTax |
outputMessageOut |
PayerAuthEnrollReply |
PayerAuthEnrollService |
PayerAuthValidateReply |
PayerAuthValidateService |
PayPal |
PayPalAuthorizationReply |
PayPalAuthorizationService |
PayPalAuthReversalReply |
PayPalAuthReversalService |
PayPalButtonCreateReply |
PayPalButtonCreateService |
PayPalCreditReply |
PayPalCreditService |
PayPalDoCaptureReply |
PayPalDoCaptureService |
PayPalEcDoPaymentReply |
PayPalEcDoPaymentService |
PayPalEcGetDetailsReply |
PayPalEcGetDetailsService |
PayPalEcOrderSetupReply |
PayPalEcOrderSetupService |
PayPalEcSetReply |
PayPalEcSetService |
PayPalPaymentReply |
PayPalPaymentService |
PayPalPreapprovedPaymentReply |
PayPalPreapprovedPaymentService |
PayPalPreapprovedUpdateReply |
PayPalPreapprovedUpdateService |
PayPalRefundReply |
PayPalRefundService |
PaySubscriptionCreateReply |
PaySubscriptionCreateService |
PaySubscriptionEvent |
PaySubscriptionEventUpdateReply |
PaySubscriptionEventUpdateService |
PaySubscriptionRetrieveReply |
PaySubscriptionRetrieveService |
PaySubscriptionUpdateReply |
PaySubscriptionUpdateService |
PinlessDebitReply |
PinlessDebitService |
PinlessDebitValidateReply |
PinlessDebitValidateService |
Pos |
ProfileReply |
PurchaseTotals |
RecurringSubscriptionInfo |
ReplyMessage |
RequestMessage |
RequestReserved |
RiskUpdateReply |
RiskUpdateService |
RuleResultItem |
ShipFrom |
ShipTo |
Subscription |
TaxReply |
TaxReplyItem |
TaxService |
TransactionProcessorClient |
UCAF |
VoidReply |
VoidService |

Interfaces

Interface | Description
ITransactionProcessor |
ITransactionProcessorChannel |


Address Class

[image]

.NET Framework Class Library
Address Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Address _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Address : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Address : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Address = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Address',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Address

See Also

Address Members
InSite.Domain.CyberSourceService Namespace


Address Members

[image] [image]

.NET Framework Class Library
Address Members
Address Class Constructors Methods Properties Events See Also Send Feedback

The Address type exposes the following members.

Constructors

Name | Description
Address |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
city |
country |
postalCode |
state |
street1 |
street2 |

Events

Name | Description
PropertyChanged |

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


Address Constructor

[image]

.NET Framework Class Library
Address Constructor
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Address()
Visual C++
public:
Address()
JavaScript
InSite.Domain.CyberSourceService.Address = function();

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


Address Methods

[image] [image]

.NET Framework Class Library
Address Methods
Address Class See Also Send Feedback

The Address type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Address..::.RaisePropertyChanged Method
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


Address Properties

[image] [image]

.NET Framework Class Library
Address Properties
Address Class See Also Send Feedback

The Address type exposes the following members.

Properties

Name | Description
city |
country |
postalCode |
state |
street1 |
street2 |

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


city Property

[image]

.NET Framework Class Library
Address..::.city Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


country Property

[image]

.NET Framework Class Library
Address..::.country Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property country As String
C#
public string country { get; set; }
Visual C++
public:
property String^ country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

Remarks

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


postalCode Property

[image]

.NET Framework Class Library
Address..::.postalCode Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property postalCode As String
C#
public string postalCode { get; set; }
Visual C++
public:
property String^ postalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


state Property

[image]

.NET Framework Class Library
Address..::.state Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


street1 Property

[image]

.NET Framework Class Library
Address..::.street1 Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street1 As String
C#
public string street1 { get; set; }
Visual C++
public:
property String^ street1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street1();
function set_street1(value);

Remarks

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


street2 Property

[image]

.NET Framework Class Library
Address..::.street2 Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street2 As String
C#
public string street2 { get; set; }
Visual C++
public:
property String^ street2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street2();
function set_street2(value);

Remarks

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


Address Events

[image] [image]

.NET Framework Class Library
Address Events
Address Class See Also Send Feedback

The Address type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Address..::.PropertyChanged Event
Address Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Address Class
InSite.Domain.CyberSourceService Namespace


AFSReply Class

[image]

.NET Framework Class Library
AFSReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class AFSReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class AFSReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class AFSReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.AFSReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.AFSReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.AFSReply

See Also

AFSReply Members
InSite.Domain.CyberSourceService Namespace


AFSReply Members

[image] [image]

.NET Framework Class Library
AFSReply Members
AFSReply Class Constructors Methods Properties Events See Also Send Feedback

The AFSReply type exposes the following members.

Constructors

Name | Description
AFSReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
addressInfoCode |
afsFactorCode |
afsResult |
binCountry |
consumerLocalTime |
hostSeverity |
hotlistInfoCode |
identityInfoCode |
internetInfoCode |
ipCity |
ipCountry |
ipRoutingMethod |
ipState |
phoneInfoCode |
reasonCode |
scoreModelUsed |
suspiciousInfoCode |
velocityInfoCode |

Events

Name | Description
PropertyChanged |

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


AFSReply Constructor

[image]

.NET Framework Class Library
AFSReply Constructor
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AFSReply()
Visual C++
public:
AFSReply()
JavaScript
InSite.Domain.CyberSourceService.AFSReply = function();

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


AFSReply Methods

[image] [image]

.NET Framework Class Library
AFSReply Methods
AFSReply Class See Also Send Feedback

The AFSReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
AFSReply..::.RaisePropertyChanged Method
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


AFSReply Properties

[image] [image]

.NET Framework Class Library
AFSReply Properties
AFSReply Class See Also Send Feedback

The AFSReply type exposes the following members.

Properties

Name | Description
addressInfoCode |
afsFactorCode |
afsResult |
binCountry |
consumerLocalTime |
hostSeverity |
hotlistInfoCode |
identityInfoCode |
internetInfoCode |
ipCity |
ipCountry |
ipRoutingMethod |
ipState |
phoneInfoCode |
reasonCode |
scoreModelUsed |
suspiciousInfoCode |
velocityInfoCode |

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


addressInfoCode Property

[image]

.NET Framework Class Library
AFSReply..::.addressInfoCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property addressInfoCode As String
C#
public string addressInfoCode { get; set; }
Visual C++
public:
property String^ addressInfoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_addressInfoCode();
function set_addressInfoCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


afsFactorCode Property

[image]

.NET Framework Class Library
AFSReply..::.afsFactorCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property afsFactorCode As String
C#
public string afsFactorCode { get; set; }
Visual C++
public:
property String^ afsFactorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_afsFactorCode();
function set_afsFactorCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


afsResult Property

[image]

.NET Framework Class Library
AFSReply..::.afsResult Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property afsResult As String
C#
public string afsResult { get; set; }
Visual C++
public:
property String^ afsResult {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_afsResult();
function set_afsResult(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


binCountry Property

[image]

.NET Framework Class Library
AFSReply..::.binCountry Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property binCountry As String
C#
public string binCountry { get; set; }
Visual C++
public:
property String^ binCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_binCountry();
function set_binCountry(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


consumerLocalTime Property

[image]

.NET Framework Class Library
AFSReply..::.consumerLocalTime Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property consumerLocalTime As String
C#
public string consumerLocalTime { get; set; }
Visual C++
public:
property String^ consumerLocalTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_consumerLocalTime();
function set_consumerLocalTime(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


hostSeverity Property

[image]

.NET Framework Class Library
AFSReply..::.hostSeverity Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property hostSeverity As String
C#
public string hostSeverity { get; set; }
Visual C++
public:
property String^ hostSeverity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_hostSeverity();
function set_hostSeverity(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


hotlistInfoCode Property

[image]

.NET Framework Class Library
AFSReply..::.hotlistInfoCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property hotlistInfoCode As String
C#
public string hotlistInfoCode { get; set; }
Visual C++
public:
property String^ hotlistInfoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_hotlistInfoCode();
function set_hotlistInfoCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


identityInfoCode Property

[image]

.NET Framework Class Library
AFSReply..::.identityInfoCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property identityInfoCode As String
C#
public string identityInfoCode { get; set; }
Visual C++
public:
property String^ identityInfoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_identityInfoCode();
function set_identityInfoCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


internetInfoCode Property

[image]

.NET Framework Class Library
AFSReply..::.internetInfoCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property internetInfoCode As String
C#
public string internetInfoCode { get; set; }
Visual C++
public:
property String^ internetInfoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_internetInfoCode();
function set_internetInfoCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


ipCity Property

[image]

.NET Framework Class Library
AFSReply..::.ipCity Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ipCity As String
C#
public string ipCity { get; set; }
Visual C++
public:
property String^ ipCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ipCity();
function set_ipCity(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


ipCountry Property

[image]

.NET Framework Class Library
AFSReply..::.ipCountry Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ipCountry As String
C#
public string ipCountry { get; set; }
Visual C++
public:
property String^ ipCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ipCountry();
function set_ipCountry(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


ipRoutingMethod Property

[image]

.NET Framework Class Library
AFSReply..::.ipRoutingMethod Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ipRoutingMethod As String
C#
public string ipRoutingMethod { get; set; }
Visual C++
public:
property String^ ipRoutingMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ipRoutingMethod();
function set_ipRoutingMethod(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


ipState Property

[image]

.NET Framework Class Library
AFSReply..::.ipState Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ipState As String
C#
public string ipState { get; set; }
Visual C++
public:
property String^ ipState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ipState();
function set_ipState(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


phoneInfoCode Property

[image]

.NET Framework Class Library
AFSReply..::.phoneInfoCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property phoneInfoCode As String
C#
public string phoneInfoCode { get; set; }
Visual C++
public:
property String^ phoneInfoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneInfoCode();
function set_phoneInfoCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
AFSReply..::.reasonCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


scoreModelUsed Property

[image]

.NET Framework Class Library
AFSReply..::.scoreModelUsed Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property scoreModelUsed As String
C#
public string scoreModelUsed { get; set; }
Visual C++
public:
property String^ scoreModelUsed {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_scoreModelUsed();
function set_scoreModelUsed(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


suspiciousInfoCode Property

[image]

.NET Framework Class Library
AFSReply..::.suspiciousInfoCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property suspiciousInfoCode As String
C#
public string suspiciousInfoCode { get; set; }
Visual C++
public:
property String^ suspiciousInfoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_suspiciousInfoCode();
function set_suspiciousInfoCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


velocityInfoCode Property

[image]

.NET Framework Class Library
AFSReply..::.velocityInfoCode Property
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property velocityInfoCode As String
C#
public string velocityInfoCode { get; set; }
Visual C++
public:
property String^ velocityInfoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_velocityInfoCode();
function set_velocityInfoCode(value);

Remarks

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


AFSReply Events

[image] [image]

.NET Framework Class Library
AFSReply Events
AFSReply Class See Also Send Feedback

The AFSReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
AFSReply..::.PropertyChanged Event
AFSReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

AFSReply Class
InSite.Domain.CyberSourceService Namespace


AFSService Class

[image]

.NET Framework Class Library
AFSService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class AFSService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class AFSService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class AFSService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.AFSService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.AFSService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.AFSService

See Also

AFSService Members
InSite.Domain.CyberSourceService Namespace


AFSService Members

[image] [image]

.NET Framework Class Library
AFSService Members
AFSService Class Constructors Methods Properties Events See Also Send Feedback

The AFSService type exposes the following members.

Constructors

Name | Description
AFSService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
avsCode |
customRiskModel |
cvCode |
disableAVSScoring |
run |

Events

Name | Description
PropertyChanged |

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


AFSService Constructor

[image]

.NET Framework Class Library
AFSService Constructor
AFSService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AFSService()
Visual C++
public:
AFSService()
JavaScript
InSite.Domain.CyberSourceService.AFSService = function();

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


AFSService Methods

[image] [image]

.NET Framework Class Library
AFSService Methods
AFSService Class See Also Send Feedback

The AFSService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
AFSService..::.RaisePropertyChanged Method
AFSService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


AFSService Properties

[image] [image]

.NET Framework Class Library
AFSService Properties
AFSService Class See Also Send Feedback

The AFSService type exposes the following members.

Properties

Name | Description
avsCode |
customRiskModel |
cvCode |
disableAVSScoring |
run |

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


avsCode Property

[image]

.NET Framework Class Library
AFSService..::.avsCode Property
AFSService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property avsCode As String
C#
public string avsCode { get; set; }
Visual C++
public:
property String^ avsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsCode();
function set_avsCode(value);

Remarks

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


customRiskModel Property

[image]

.NET Framework Class Library
AFSService..::.customRiskModel Property
AFSService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customRiskModel As String
C#
public string customRiskModel { get; set; }
Visual C++
public:
property String^ customRiskModel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customRiskModel();
function set_customRiskModel(value);

Remarks

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


cvCode Property

[image]

.NET Framework Class Library
AFSService..::.cvCode Property
AFSService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cvCode As String
C#
public string cvCode { get; set; }
Visual C++
public:
property String^ cvCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cvCode();
function set_cvCode(value);

Remarks

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


disableAVSScoring Property

[image]

.NET Framework Class Library
AFSService..::.disableAVSScoring Property
AFSService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property disableAVSScoring As String
C#
public string disableAVSScoring { get; set; }
Visual C++
public:
property String^ disableAVSScoring {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_disableAVSScoring();
function set_disableAVSScoring(value);

Remarks

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
AFSService..::.run Property
AFSService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


AFSService Events

[image] [image]

.NET Framework Class Library
AFSService Events
AFSService Class See Also Send Feedback

The AFSService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
AFSService..::.PropertyChanged Event
AFSService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

AFSService Class
InSite.Domain.CyberSourceService Namespace


AirlineData Class

[image]

.NET Framework Class Library
AirlineData Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class AirlineData _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class AirlineData : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class AirlineData : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.AirlineData = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.AirlineData',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.AirlineData

See Also

AirlineData Members
InSite.Domain.CyberSourceService Namespace


AirlineData Members

[image] [image]

.NET Framework Class Library
AirlineData Members
AirlineData Class Constructors Methods Properties Events See Also Send Feedback

The AirlineData type exposes the following members.

Constructors

Name | Description
AirlineData |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
agentCode |
agentName |
bookingReference |
carrierName |
chargeDetails |
checkDigit |
clearingCount |
clearingSequence |
customerCode |
documentNumber |
documentNumberOfParts |
documentType |
extendedPaymentCode |
invoiceDate |
invoiceNumber |
leg |
numberOfPassengers |
passengerName |
restrictedTicketIndicator |
ticketIssuerAddress |
ticketIssuerCity |
ticketIssuerCode |
ticketIssuerCountry |
ticketIssuerName |
ticketIssuerPostalCode |
ticketIssuerState |
ticketNumber |
totalClearingAmount |
totalFee |
transactionType |

Events

Name | Description
PropertyChanged |

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


AirlineData Constructor

[image]

.NET Framework Class Library
AirlineData Constructor
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AirlineData()
Visual C++
public:
AirlineData()
JavaScript
InSite.Domain.CyberSourceService.AirlineData = function();

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


AirlineData Methods

[image] [image]

.NET Framework Class Library
AirlineData Methods
AirlineData Class See Also Send Feedback

The AirlineData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
AirlineData..::.RaisePropertyChanged Method
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


AirlineData Properties

[image] [image]

.NET Framework Class Library
AirlineData Properties
AirlineData Class See Also Send Feedback

The AirlineData type exposes the following members.

Properties

Name | Description
agentCode |
agentName |
bookingReference |
carrierName |
chargeDetails |
checkDigit |
clearingCount |
clearingSequence |
customerCode |
documentNumber |
documentNumberOfParts |
documentType |
extendedPaymentCode |
invoiceDate |
invoiceNumber |
leg |
numberOfPassengers |
passengerName |
restrictedTicketIndicator |
ticketIssuerAddress |
ticketIssuerCity |
ticketIssuerCode |
ticketIssuerCountry |
ticketIssuerName |
ticketIssuerPostalCode |
ticketIssuerState |
ticketNumber |
totalClearingAmount |
totalFee |
transactionType |

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


agentCode Property

[image]

.NET Framework Class Library
AirlineData..::.agentCode Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property agentCode As String
C#
public string agentCode { get; set; }
Visual C++
public:
property String^ agentCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_agentCode();
function set_agentCode(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


agentName Property

[image]

.NET Framework Class Library
AirlineData..::.agentName Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property agentName As String
C#
public string agentName { get; set; }
Visual C++
public:
property String^ agentName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_agentName();
function set_agentName(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


bookingReference Property

[image]

.NET Framework Class Library
AirlineData..::.bookingReference Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bookingReference As String
C#
public string bookingReference { get; set; }
Visual C++
public:
property String^ bookingReference {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bookingReference();
function set_bookingReference(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


carrierName Property

[image]

.NET Framework Class Library
AirlineData..::.carrierName Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property carrierName As String
C#
public string carrierName { get; set; }
Visual C++
public:
property String^ carrierName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_carrierName();
function set_carrierName(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


chargeDetails Property

[image]

.NET Framework Class Library
AirlineData..::.chargeDetails Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property chargeDetails As String
C#
public string chargeDetails { get; set; }
Visual C++
public:
property String^ chargeDetails {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_chargeDetails();
function set_chargeDetails(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


checkDigit Property

[image]

.NET Framework Class Library
AirlineData..::.checkDigit Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property checkDigit As String
C#
public string checkDigit { get; set; }
Visual C++
public:
property String^ checkDigit {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_checkDigit();
function set_checkDigit(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


clearingCount Property

[image]

.NET Framework Class Library
AirlineData..::.clearingCount Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clearingCount As String
C#
public string clearingCount { get; set; }
Visual C++
public:
property String^ clearingCount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clearingCount();
function set_clearingCount(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


clearingSequence Property

[image]

.NET Framework Class Library
AirlineData..::.clearingSequence Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clearingSequence As String
C#
public string clearingSequence { get; set; }
Visual C++
public:
property String^ clearingSequence {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clearingSequence();
function set_clearingSequence(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


customerCode Property

[image]

.NET Framework Class Library
AirlineData..::.customerCode Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerCode As String
C#
public string customerCode { get; set; }
Visual C++
public:
property String^ customerCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerCode();
function set_customerCode(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


documentNumber Property

[image]

.NET Framework Class Library
AirlineData..::.documentNumber Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property documentNumber As String
C#
public string documentNumber { get; set; }
Visual C++
public:
property String^ documentNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_documentNumber();
function set_documentNumber(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


documentNumberOfParts Property

[image]

.NET Framework Class Library
AirlineData..::.documentNumberOfParts Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property documentNumberOfParts As String
C#
public string documentNumberOfParts { get; set; }
Visual C++
public:
property String^ documentNumberOfParts {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_documentNumberOfParts();
function set_documentNumberOfParts(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


documentType Property

[image]

.NET Framework Class Library
AirlineData..::.documentType Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property documentType As String
C#
public string documentType { get; set; }
Visual C++
public:
property String^ documentType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_documentType();
function set_documentType(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


extendedPaymentCode Property

[image]

.NET Framework Class Library
AirlineData..::.extendedPaymentCode Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property extendedPaymentCode As String
C#
public string extendedPaymentCode { get; set; }
Visual C++
public:
property String^ extendedPaymentCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_extendedPaymentCode();
function set_extendedPaymentCode(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


invoiceDate Property

[image]

.NET Framework Class Library
AirlineData..::.invoiceDate Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceDate As String
C#
public string invoiceDate { get; set; }
Visual C++
public:
property String^ invoiceDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceDate();
function set_invoiceDate(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


invoiceNumber Property

[image]

.NET Framework Class Library
AirlineData..::.invoiceNumber Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceNumber As String
C#
public string invoiceNumber { get; set; }
Visual C++
public:
property String^ invoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceNumber();
function set_invoiceNumber(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


leg Property

[image]

.NET Framework Class Library
AirlineData..::.leg Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property leg As Leg()
C#
public Leg[] leg { get; set; }
Visual C++
public:
property array<Leg^>^ leg {
    array<Leg^>^ get ();
    void set (array<Leg^>^ value);
}
JavaScript
function get_leg();
function set_leg(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


numberOfPassengers Property

[image]

.NET Framework Class Library
AirlineData..::.numberOfPassengers Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property numberOfPassengers As String
C#
public string numberOfPassengers { get; set; }
Visual C++
public:
property String^ numberOfPassengers {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_numberOfPassengers();
function set_numberOfPassengers(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


passengerName Property

[image]

.NET Framework Class Library
AirlineData..::.passengerName Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property passengerName As String
C#
public string passengerName { get; set; }
Visual C++
public:
property String^ passengerName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_passengerName();
function set_passengerName(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


restrictedTicketIndicator Property

[image]

.NET Framework Class Library
AirlineData..::.restrictedTicketIndicator Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property restrictedTicketIndicator As String
C#
public string restrictedTicketIndicator { get; set; }
Visual C++
public:
property String^ restrictedTicketIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_restrictedTicketIndicator();
function set_restrictedTicketIndicator(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


ticketIssuerAddress Property

[image]

.NET Framework Class Library
AirlineData..::.ticketIssuerAddress Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ticketIssuerAddress As String
C#
public string ticketIssuerAddress { get; set; }
Visual C++
public:
property String^ ticketIssuerAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ticketIssuerAddress();
function set_ticketIssuerAddress(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


ticketIssuerCity Property

[image]

.NET Framework Class Library
AirlineData..::.ticketIssuerCity Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ticketIssuerCity As String
C#
public string ticketIssuerCity { get; set; }
Visual C++
public:
property String^ ticketIssuerCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ticketIssuerCity();
function set_ticketIssuerCity(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


ticketIssuerCode Property

[image]

.NET Framework Class Library
AirlineData..::.ticketIssuerCode Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ticketIssuerCode As String
C#
public string ticketIssuerCode { get; set; }
Visual C++
public:
property String^ ticketIssuerCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ticketIssuerCode();
function set_ticketIssuerCode(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


ticketIssuerCountry Property

[image]

.NET Framework Class Library
AirlineData..::.ticketIssuerCountry Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ticketIssuerCountry As String
C#
public string ticketIssuerCountry { get; set; }
Visual C++
public:
property String^ ticketIssuerCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ticketIssuerCountry();
function set_ticketIssuerCountry(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


ticketIssuerName Property

[image]

.NET Framework Class Library
AirlineData..::.ticketIssuerName Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ticketIssuerName As String
C#
public string ticketIssuerName { get; set; }
Visual C++
public:
property String^ ticketIssuerName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ticketIssuerName();
function set_ticketIssuerName(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


ticketIssuerPostalCode Property

[image]

.NET Framework Class Library
AirlineData..::.ticketIssuerPostalCode Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ticketIssuerPostalCode As String
C#
public string ticketIssuerPostalCode { get; set; }
Visual C++
public:
property String^ ticketIssuerPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ticketIssuerPostalCode();
function set_ticketIssuerPostalCode(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


ticketIssuerState Property

[image]

.NET Framework Class Library
AirlineData..::.ticketIssuerState Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ticketIssuerState As String
C#
public string ticketIssuerState { get; set; }
Visual C++
public:
property String^ ticketIssuerState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ticketIssuerState();
function set_ticketIssuerState(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


ticketNumber Property

[image]

.NET Framework Class Library
AirlineData..::.ticketNumber Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ticketNumber As String
C#
public string ticketNumber { get; set; }
Visual C++
public:
property String^ ticketNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ticketNumber();
function set_ticketNumber(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


totalClearingAmount Property

[image]

.NET Framework Class Library
AirlineData..::.totalClearingAmount Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalClearingAmount As String
C#
public string totalClearingAmount { get; set; }
Visual C++
public:
property String^ totalClearingAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalClearingAmount();
function set_totalClearingAmount(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


totalFee Property

[image]

.NET Framework Class Library
AirlineData..::.totalFee Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalFee As String
C#
public string totalFee { get; set; }
Visual C++
public:
property String^ totalFee {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalFee();
function set_totalFee(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


transactionType Property

[image]

.NET Framework Class Library
AirlineData..::.transactionType Property
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionType As String
C#
public string transactionType { get; set; }
Visual C++
public:
property String^ transactionType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionType();
function set_transactionType(value);

Remarks

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


AirlineData Events

[image] [image]

.NET Framework Class Library
AirlineData Events
AirlineData Class See Also Send Feedback

The AirlineData type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
AirlineData..::.PropertyChanged Event
AirlineData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

AirlineData Class
InSite.Domain.CyberSourceService Namespace


BankInfo Class

[image]

.NET Framework Class Library
BankInfo Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BankInfo _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BankInfo : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BankInfo : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BankInfo = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BankInfo',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BankInfo

See Also

BankInfo Members
InSite.Domain.CyberSourceService Namespace


BankInfo Members

[image] [image]

.NET Framework Class Library
BankInfo Members
BankInfo Class Constructors Methods Properties Events See Also Send Feedback

The BankInfo type exposes the following members.

Constructors

Name | Description
BankInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
address |
bankCode |
branchCode |
city |
country |
issuerID |
name |
sortCode |
swiftCode |

Events

Name | Description
PropertyChanged |

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


BankInfo Constructor

[image]

.NET Framework Class Library
BankInfo Constructor
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankInfo()
Visual C++
public:
BankInfo()
JavaScript
InSite.Domain.CyberSourceService.BankInfo = function();

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


BankInfo Methods

[image] [image]

.NET Framework Class Library
BankInfo Methods
BankInfo Class See Also Send Feedback

The BankInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BankInfo..::.RaisePropertyChanged Method
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


BankInfo Properties

[image] [image]

.NET Framework Class Library
BankInfo Properties
BankInfo Class See Also Send Feedback

The BankInfo type exposes the following members.

Properties

Name | Description
address |
bankCode |
branchCode |
city |
country |
issuerID |
name |
sortCode |
swiftCode |

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


address Property

[image]

.NET Framework Class Library
BankInfo..::.address Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property address As String
C#
public string address { get; set; }
Visual C++
public:
property String^ address {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


bankCode Property

[image]

.NET Framework Class Library
BankInfo..::.bankCode Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankCode As String
C#
public string bankCode { get; set; }
Visual C++
public:
property String^ bankCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankCode();
function set_bankCode(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


branchCode Property

[image]

.NET Framework Class Library
BankInfo..::.branchCode Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property branchCode As String
C#
public string branchCode { get; set; }
Visual C++
public:
property String^ branchCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_branchCode();
function set_branchCode(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


city Property

[image]

.NET Framework Class Library
BankInfo..::.city Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


country Property

[image]

.NET Framework Class Library
BankInfo..::.country Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property country As String
C#
public string country { get; set; }
Visual C++
public:
property String^ country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


issuerID Property

[image]

.NET Framework Class Library
BankInfo..::.issuerID Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property issuerID As String
C#
public string issuerID { get; set; }
Visual C++
public:
property String^ issuerID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_issuerID();
function set_issuerID(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


name Property

[image]

.NET Framework Class Library
BankInfo..::.name Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String
C#
public string name { get; set; }
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


sortCode Property

[image]

.NET Framework Class Library
BankInfo..::.sortCode Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property sortCode As String
C#
public string sortCode { get; set; }
Visual C++
public:
property String^ sortCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_sortCode();
function set_sortCode(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


swiftCode Property

[image]

.NET Framework Class Library
BankInfo..::.swiftCode Property
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property swiftCode As String
C#
public string swiftCode { get; set; }
Visual C++
public:
property String^ swiftCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_swiftCode();
function set_swiftCode(value);

Remarks

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


BankInfo Events

[image] [image]

.NET Framework Class Library
BankInfo Events
BankInfo Class See Also Send Feedback

The BankInfo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BankInfo..::.PropertyChanged Event
BankInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BankInfo Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeReply Class

[image]

.NET Framework Class Library
BankTransferRealTimeReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BankTransferRealTimeReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BankTransferRealTimeReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BankTransferRealTimeReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BankTransferRealTimeReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BankTransferRealTimeReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BankTransferRealTimeReply

See Also

BankTransferRealTimeReply Members
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeReply Members

[image] [image]

.NET Framework Class Library
BankTransferRealTimeReply Members
BankTransferRealTimeReply Class Constructors Methods Properties Events See Also Send Feedback

The BankTransferRealTimeReply type exposes the following members.

Constructors

Name | Description
BankTransferRealTimeReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
formAction |
formMethod |
paymentReference |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeReply Constructor

[image]

.NET Framework Class Library
BankTransferRealTimeReply Constructor
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankTransferRealTimeReply()
Visual C++
public:
BankTransferRealTimeReply()
JavaScript
InSite.Domain.CyberSourceService.BankTransferRealTimeReply = function();

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeReply Methods

[image] [image]

.NET Framework Class Library
BankTransferRealTimeReply Methods
BankTransferRealTimeReply Class See Also Send Feedback

The BankTransferRealTimeReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.RaisePropertyChanged Method
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeReply Properties

[image] [image]

.NET Framework Class Library
BankTransferRealTimeReply Properties
BankTransferRealTimeReply Class See Also Send Feedback

The BankTransferRealTimeReply type exposes the following members.

Properties

Name | Description
amount |
formAction |
formMethod |
paymentReference |
reasonCode |
reconciliationID |
requestDateTime |

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.amount Property
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


formAction Property

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.formAction Property
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property formAction As String
C#
public string formAction { get; set; }
Visual C++
public:
property String^ formAction {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_formAction();
function set_formAction(value);

Remarks

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


formMethod Property

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.formMethod Property
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property formMethod As String
C#
public string formMethod { get; set; }
Visual C++
public:
property String^ formMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_formMethod();
function set_formMethod(value);

Remarks

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


paymentReference Property

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.paymentReference Property
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentReference As String
C#
public string paymentReference { get; set; }
Visual C++
public:
property String^ paymentReference {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentReference();
function set_paymentReference(value);

Remarks

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.reasonCode Property
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.reconciliationID Property
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.requestDateTime Property
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeReply Events

[image] [image]

.NET Framework Class Library
BankTransferRealTimeReply Events
BankTransferRealTimeReply Class See Also Send Feedback

The BankTransferRealTimeReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BankTransferRealTimeReply..::.PropertyChanged Event
BankTransferRealTimeReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BankTransferRealTimeReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeService Class

[image]

.NET Framework Class Library
BankTransferRealTimeService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BankTransferRealTimeService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BankTransferRealTimeService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BankTransferRealTimeService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BankTransferRealTimeService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BankTransferRealTimeService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BankTransferRealTimeService

See Also

BankTransferRealTimeService Members
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeService Members

[image] [image]

.NET Framework Class Library
BankTransferRealTimeService Members
BankTransferRealTimeService Class Constructors Methods Properties Events See Also Send Feedback

The BankTransferRealTimeService type exposes the following members.

Constructors

Name | Description
BankTransferRealTimeService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
bankTransferRealTimeType |
run |

Events

Name | Description
PropertyChanged |

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeService Constructor

[image]

.NET Framework Class Library
BankTransferRealTimeService Constructor
BankTransferRealTimeService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankTransferRealTimeService()
Visual C++
public:
BankTransferRealTimeService()
JavaScript
InSite.Domain.CyberSourceService.BankTransferRealTimeService = function();

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeService Methods

[image] [image]

.NET Framework Class Library
BankTransferRealTimeService Methods
BankTransferRealTimeService Class See Also Send Feedback

The BankTransferRealTimeService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BankTransferRealTimeService..::.RaisePropertyChanged Method
BankTransferRealTimeService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeService Properties

[image] [image]

.NET Framework Class Library
BankTransferRealTimeService Properties
BankTransferRealTimeService Class See Also Send Feedback

The BankTransferRealTimeService type exposes the following members.

Properties

Name | Description
bankTransferRealTimeType |
run |

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


bankTransferRealTimeType Property

[image]

.NET Framework Class Library
BankTransferRealTimeService..::.bankTransferRealTimeType Property
BankTransferRealTimeService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRealTimeType As String
C#
public string bankTransferRealTimeType { get; set; }
Visual C++
public:
property String^ bankTransferRealTimeType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankTransferRealTimeType();
function set_bankTransferRealTimeType(value);

Remarks

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
BankTransferRealTimeService..::.run Property
BankTransferRealTimeService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRealTimeService Events

[image] [image]

.NET Framework Class Library
BankTransferRealTimeService Events
BankTransferRealTimeService Class See Also Send Feedback

The BankTransferRealTimeService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BankTransferRealTimeService..::.PropertyChanged Event
BankTransferRealTimeService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BankTransferRealTimeService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundReply Class

[image]

.NET Framework Class Library
BankTransferRefundReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BankTransferRefundReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BankTransferRefundReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BankTransferRefundReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BankTransferRefundReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BankTransferRefundReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BankTransferRefundReply

See Also

BankTransferRefundReply Members
InSite.Domain.CyberSourceService Namespace


BankTransferRefundReply Members

[image] [image]

.NET Framework Class Library
BankTransferRefundReply Members
BankTransferRefundReply Class Constructors Methods Properties Events See Also Send Feedback

The BankTransferRefundReply type exposes the following members.

Constructors

Name | Description
BankTransferRefundReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundReply Constructor

[image]

.NET Framework Class Library
BankTransferRefundReply Constructor
BankTransferRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankTransferRefundReply()
Visual C++
public:
BankTransferRefundReply()
JavaScript
InSite.Domain.CyberSourceService.BankTransferRefundReply = function();

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundReply Methods

[image] [image]

.NET Framework Class Library
BankTransferRefundReply Methods
BankTransferRefundReply Class See Also Send Feedback

The BankTransferRefundReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BankTransferRefundReply..::.RaisePropertyChanged Method
BankTransferRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundReply Properties

[image] [image]

.NET Framework Class Library
BankTransferRefundReply Properties
BankTransferRefundReply Class See Also Send Feedback

The BankTransferRefundReply type exposes the following members.

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
BankTransferRefundReply..::.amount Property
BankTransferRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
BankTransferRefundReply..::.processorResponse Property
BankTransferRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
BankTransferRefundReply..::.reasonCode Property
BankTransferRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
BankTransferRefundReply..::.reconciliationID Property
BankTransferRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
BankTransferRefundReply..::.requestDateTime Property
BankTransferRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundReply Events

[image] [image]

.NET Framework Class Library
BankTransferRefundReply Events
BankTransferRefundReply Class See Also Send Feedback

The BankTransferRefundReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BankTransferRefundReply..::.PropertyChanged Event
BankTransferRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BankTransferRefundReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundService Class

[image]

.NET Framework Class Library
BankTransferRefundService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BankTransferRefundService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BankTransferRefundService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BankTransferRefundService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BankTransferRefundService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BankTransferRefundService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BankTransferRefundService

See Also

BankTransferRefundService Members
InSite.Domain.CyberSourceService Namespace


BankTransferRefundService Members

[image] [image]

.NET Framework Class Library
BankTransferRefundService Members
BankTransferRefundService Class Constructors Methods Properties Events See Also Send Feedback

The BankTransferRefundService type exposes the following members.

Constructors

Name | Description
BankTransferRefundService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
bankTransferRealTimeReconciliationID |
bankTransferRealTimeRequestID |
bankTransferRealTimeRequestToken |
bankTransferRequestID |
bankTransferRequestToken |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundService Constructor

[image]

.NET Framework Class Library
BankTransferRefundService Constructor
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankTransferRefundService()
Visual C++
public:
BankTransferRefundService()
JavaScript
InSite.Domain.CyberSourceService.BankTransferRefundService = function();

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundService Methods

[image] [image]

.NET Framework Class Library
BankTransferRefundService Methods
BankTransferRefundService Class See Also Send Feedback

The BankTransferRefundService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BankTransferRefundService..::.RaisePropertyChanged Method
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundService Properties

[image] [image]

.NET Framework Class Library
BankTransferRefundService Properties
BankTransferRefundService Class See Also Send Feedback

The BankTransferRefundService type exposes the following members.

Properties

Name | Description
bankTransferRealTimeReconciliationID |
bankTransferRealTimeRequestID |
bankTransferRealTimeRequestToken |
bankTransferRequestID |
bankTransferRequestToken |
reconciliationID |
run |

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


bankTransferRealTimeReconciliationID Property

[image]

.NET Framework Class Library
BankTransferRefundService..::.bankTransferRealTimeReconciliationID Property
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRealTimeReconciliationID As String
C#
public string bankTransferRealTimeReconciliationID { get; set; }
Visual C++
public:
property String^ bankTransferRealTimeReconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankTransferRealTimeReconciliationID();
function set_bankTransferRealTimeReconciliationID(value);

Remarks

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


bankTransferRealTimeRequestID Property

[image]

.NET Framework Class Library
BankTransferRefundService..::.bankTransferRealTimeRequestID Property
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRealTimeRequestID As String
C#
public string bankTransferRealTimeRequestID { get; set; }
Visual C++
public:
property String^ bankTransferRealTimeRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankTransferRealTimeRequestID();
function set_bankTransferRealTimeRequestID(value);

Remarks

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


bankTransferRealTimeRequestToken Property

[image]

.NET Framework Class Library
BankTransferRefundService..::.bankTransferRealTimeRequestToken Property
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRealTimeRequestToken As String
C#
public string bankTransferRealTimeRequestToken { get; set; }
Visual C++
public:
property String^ bankTransferRealTimeRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankTransferRealTimeRequestToken();
function set_bankTransferRealTimeRequestToken(value);

Remarks

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


bankTransferRequestID Property

[image]

.NET Framework Class Library
BankTransferRefundService..::.bankTransferRequestID Property
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRequestID As String
C#
public string bankTransferRequestID { get; set; }
Visual C++
public:
property String^ bankTransferRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankTransferRequestID();
function set_bankTransferRequestID(value);

Remarks

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


bankTransferRequestToken Property

[image]

.NET Framework Class Library
BankTransferRefundService..::.bankTransferRequestToken Property
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRequestToken As String
C#
public string bankTransferRequestToken { get; set; }
Visual C++
public:
property String^ bankTransferRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankTransferRequestToken();
function set_bankTransferRequestToken(value);

Remarks

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
BankTransferRefundService..::.reconciliationID Property
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
BankTransferRefundService..::.run Property
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


BankTransferRefundService Events

[image] [image]

.NET Framework Class Library
BankTransferRefundService Events
BankTransferRefundService Class See Also Send Feedback

The BankTransferRefundService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BankTransferRefundService..::.PropertyChanged Event
BankTransferRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BankTransferRefundService Class
InSite.Domain.CyberSourceService Namespace


BankTransferReply Class

[image]

.NET Framework Class Library
BankTransferReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BankTransferReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BankTransferReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BankTransferReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BankTransferReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BankTransferReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BankTransferReply

See Also

BankTransferReply Members
InSite.Domain.CyberSourceService Namespace


BankTransferReply Members

[image] [image]

.NET Framework Class Library
BankTransferReply Members
BankTransferReply Class Constructors Methods Properties Events See Also Send Feedback

The BankTransferReply type exposes the following members.

Constructors

Name | Description
BankTransferReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
accountHolder |
accountNumber |
amount |
bankCity |
bankCode |
bankCountry |
bankName |
bankSpecialID |
bankSwiftCode |
branchCode |
iban |
paymentReference |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferReply Constructor

[image]

.NET Framework Class Library
BankTransferReply Constructor
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankTransferReply()
Visual C++
public:
BankTransferReply()
JavaScript
InSite.Domain.CyberSourceService.BankTransferReply = function();

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferReply Methods

[image] [image]

.NET Framework Class Library
BankTransferReply Methods
BankTransferReply Class See Also Send Feedback

The BankTransferReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BankTransferReply..::.RaisePropertyChanged Method
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferReply Properties

[image] [image]

.NET Framework Class Library
BankTransferReply Properties
BankTransferReply Class See Also Send Feedback

The BankTransferReply type exposes the following members.

Properties

Name | Description
accountHolder |
accountNumber |
amount |
bankCity |
bankCode |
bankCountry |
bankName |
bankSpecialID |
bankSwiftCode |
branchCode |
iban |
paymentReference |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


accountHolder Property

[image]

.NET Framework Class Library
BankTransferReply..::.accountHolder Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountHolder As String
C#
public string accountHolder { get; set; }
Visual C++
public:
property String^ accountHolder {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountHolder();
function set_accountHolder(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


accountNumber Property

[image]

.NET Framework Class Library
BankTransferReply..::.accountNumber Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountNumber As String
C#
public string accountNumber { get; set; }
Visual C++
public:
property String^ accountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
BankTransferReply..::.amount Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


bankCity Property

[image]

.NET Framework Class Library
BankTransferReply..::.bankCity Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankCity As String
C#
public string bankCity { get; set; }
Visual C++
public:
property String^ bankCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankCity();
function set_bankCity(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


bankCode Property

[image]

.NET Framework Class Library
BankTransferReply..::.bankCode Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankCode As String
C#
public string bankCode { get; set; }
Visual C++
public:
property String^ bankCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankCode();
function set_bankCode(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


bankCountry Property

[image]

.NET Framework Class Library
BankTransferReply..::.bankCountry Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankCountry As String
C#
public string bankCountry { get; set; }
Visual C++
public:
property String^ bankCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankCountry();
function set_bankCountry(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


bankName Property

[image]

.NET Framework Class Library
BankTransferReply..::.bankName Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankName As String
C#
public string bankName { get; set; }
Visual C++
public:
property String^ bankName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankName();
function set_bankName(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


bankSpecialID Property

[image]

.NET Framework Class Library
BankTransferReply..::.bankSpecialID Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankSpecialID As String
C#
public string bankSpecialID { get; set; }
Visual C++
public:
property String^ bankSpecialID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankSpecialID();
function set_bankSpecialID(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


bankSwiftCode Property

[image]

.NET Framework Class Library
BankTransferReply..::.bankSwiftCode Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankSwiftCode As String
C#
public string bankSwiftCode { get; set; }
Visual C++
public:
property String^ bankSwiftCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankSwiftCode();
function set_bankSwiftCode(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


branchCode Property

[image]

.NET Framework Class Library
BankTransferReply..::.branchCode Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property branchCode As String
C#
public string branchCode { get; set; }
Visual C++
public:
property String^ branchCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_branchCode();
function set_branchCode(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


iban Property

[image]

.NET Framework Class Library
BankTransferReply..::.iban Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property iban As String
C#
public string iban { get; set; }
Visual C++
public:
property String^ iban {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_iban();
function set_iban(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


paymentReference Property

[image]

.NET Framework Class Library
BankTransferReply..::.paymentReference Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentReference As String
C#
public string paymentReference { get; set; }
Visual C++
public:
property String^ paymentReference {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentReference();
function set_paymentReference(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
BankTransferReply..::.processorResponse Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
BankTransferReply..::.reasonCode Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
BankTransferReply..::.reconciliationID Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
BankTransferReply..::.requestDateTime Property
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferReply Events

[image] [image]

.NET Framework Class Library
BankTransferReply Events
BankTransferReply Class See Also Send Feedback

The BankTransferReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BankTransferReply..::.PropertyChanged Event
BankTransferReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BankTransferReply Class
InSite.Domain.CyberSourceService Namespace


BankTransferService Class

[image]

.NET Framework Class Library
BankTransferService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BankTransferService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BankTransferService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BankTransferService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BankTransferService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BankTransferService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BankTransferService

See Also

BankTransferService Members
InSite.Domain.CyberSourceService Namespace


BankTransferService Members

[image] [image]

.NET Framework Class Library
BankTransferService Members
BankTransferService Class Constructors Methods Properties Events See Also Send Feedback

The BankTransferService type exposes the following members.

Constructors

Name | Description
BankTransferService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |

Events

Name | Description
PropertyChanged |

See Also

BankTransferService Class
InSite.Domain.CyberSourceService Namespace


BankTransferService Constructor

[image]

.NET Framework Class Library
BankTransferService Constructor
BankTransferService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BankTransferService()
Visual C++
public:
BankTransferService()
JavaScript
InSite.Domain.CyberSourceService.BankTransferService = function();

See Also

BankTransferService Class
InSite.Domain.CyberSourceService Namespace


BankTransferService Methods

[image] [image]

.NET Framework Class Library
BankTransferService Methods
BankTransferService Class See Also Send Feedback

The BankTransferService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BankTransferService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BankTransferService..::.RaisePropertyChanged Method
BankTransferService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BankTransferService Class
InSite.Domain.CyberSourceService Namespace


BankTransferService Properties

[image] [image]

.NET Framework Class Library
BankTransferService Properties
BankTransferService Class See Also Send Feedback

The BankTransferService type exposes the following members.

Properties

Name | Description
run |

See Also

BankTransferService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
BankTransferService..::.run Property
BankTransferService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

BankTransferService Class
InSite.Domain.CyberSourceService Namespace


BankTransferService Events

[image] [image]

.NET Framework Class Library
BankTransferService Events
BankTransferService Class See Also Send Feedback

The BankTransferService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BankTransferService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BankTransferService..::.PropertyChanged Event
BankTransferService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BankTransferService Class
InSite.Domain.CyberSourceService Namespace


Batch Class

[image]

.NET Framework Class Library
Batch Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Batch _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Batch : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Batch : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Batch = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Batch',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Batch

See Also

Batch Members
InSite.Domain.CyberSourceService Namespace


Batch Members

[image] [image]

.NET Framework Class Library
Batch Members
Batch Class Constructors Methods Properties Events See Also Send Feedback

The Batch type exposes the following members.

Constructors

Name | Description
Batch |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
batchID |
recordID |

Events

Name | Description
PropertyChanged |

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


Batch Constructor

[image]

.NET Framework Class Library
Batch Constructor
Batch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Batch()
Visual C++
public:
Batch()
JavaScript
InSite.Domain.CyberSourceService.Batch = function();

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


Batch Methods

[image] [image]

.NET Framework Class Library
Batch Methods
Batch Class See Also Send Feedback

The Batch type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Batch..::.RaisePropertyChanged Method
Batch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


Batch Properties

[image] [image]

.NET Framework Class Library
Batch Properties
Batch Class See Also Send Feedback

The Batch type exposes the following members.

Properties

Name | Description
batchID |
recordID |

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


batchID Property

[image]

.NET Framework Class Library
Batch..::.batchID Property
Batch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property batchID As String
C#
public string batchID { get; set; }
Visual C++
public:
property String^ batchID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_batchID();
function set_batchID(value);

Remarks

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


recordID Property

[image]

.NET Framework Class Library
Batch..::.recordID Property
Batch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property recordID As String
C#
public string recordID { get; set; }
Visual C++
public:
property String^ recordID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_recordID();
function set_recordID(value);

Remarks

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


Batch Events

[image] [image]

.NET Framework Class Library
Batch Events
Batch Class See Also Send Feedback

The Batch type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Batch..::.PropertyChanged Event
Batch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Batch Class
InSite.Domain.CyberSourceService Namespace


BillTo Class

[image]

.NET Framework Class Library
BillTo Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BillTo _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BillTo : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BillTo : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BillTo = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BillTo',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BillTo

See Also

BillTo Members
InSite.Domain.CyberSourceService Namespace


BillTo Members

[image] [image]

.NET Framework Class Library
BillTo Members
BillTo Class Constructors Methods Properties Events See Also Send Feedback

The BillTo type exposes the following members.

Constructors

Name | Description
BillTo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
city |
company |
companyTaxID |
country |
county |
customerID |
dateOfBirth |
domainName |
driversLicenseNumber |
driversLicenseState |
email |
firstName |
hostname |
httpBrowserCookiesAccepted |
httpBrowserEmail |
httpBrowserType |
ipAddress |
ipNetworkAddress |
lastName |
middleName |
nif |
personalID |
phoneNumber |
postalCode |
ssn |
state |
street1 |
street2 |
street3 |
street4 |
suffix |
title |

Events

Name | Description
PropertyChanged |

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


BillTo Constructor

[image]

.NET Framework Class Library
BillTo Constructor
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BillTo()
Visual C++
public:
BillTo()
JavaScript
InSite.Domain.CyberSourceService.BillTo = function();

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


BillTo Methods

[image] [image]

.NET Framework Class Library
BillTo Methods
BillTo Class See Also Send Feedback

The BillTo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BillTo..::.RaisePropertyChanged Method
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


BillTo Properties

[image] [image]

.NET Framework Class Library
BillTo Properties
BillTo Class See Also Send Feedback

The BillTo type exposes the following members.

Properties

Name | Description
city |
company |
companyTaxID |
country |
county |
customerID |
dateOfBirth |
domainName |
driversLicenseNumber |
driversLicenseState |
email |
firstName |
hostname |
httpBrowserCookiesAccepted |
httpBrowserEmail |
httpBrowserType |
ipAddress |
ipNetworkAddress |
lastName |
middleName |
nif |
personalID |
phoneNumber |
postalCode |
ssn |
state |
street1 |
street2 |
street3 |
street4 |
suffix |
title |

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


city Property

[image]

.NET Framework Class Library
BillTo..::.city Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


company Property

[image]

.NET Framework Class Library
BillTo..::.company Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property company As String
C#
public string company { get; set; }
Visual C++
public:
property String^ company {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_company();
function set_company(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


companyTaxID Property

[image]

.NET Framework Class Library
BillTo..::.companyTaxID Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property companyTaxID As String
C#
public string companyTaxID { get; set; }
Visual C++
public:
property String^ companyTaxID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_companyTaxID();
function set_companyTaxID(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


country Property

[image]

.NET Framework Class Library
BillTo..::.country Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property country As String
C#
public string country { get; set; }
Visual C++
public:
property String^ country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


county Property

[image]

.NET Framework Class Library
BillTo..::.county Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property county As String
C#
public string county { get; set; }
Visual C++
public:
property String^ county {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_county();
function set_county(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


customerID Property

[image]

.NET Framework Class Library
BillTo..::.customerID Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerID As String
C#
public string customerID { get; set; }
Visual C++
public:
property String^ customerID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerID();
function set_customerID(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


dateOfBirth Property

[image]

.NET Framework Class Library
BillTo..::.dateOfBirth Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dateOfBirth As String
C#
public string dateOfBirth { get; set; }
Visual C++
public:
property String^ dateOfBirth {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dateOfBirth();
function set_dateOfBirth(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


domainName Property

[image]

.NET Framework Class Library
BillTo..::.domainName Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property domainName As String
C#
public string domainName { get; set; }
Visual C++
public:
property String^ domainName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_domainName();
function set_domainName(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


driversLicenseNumber Property

[image]

.NET Framework Class Library
BillTo..::.driversLicenseNumber Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property driversLicenseNumber As String
C#
public string driversLicenseNumber { get; set; }
Visual C++
public:
property String^ driversLicenseNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_driversLicenseNumber();
function set_driversLicenseNumber(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


driversLicenseState Property

[image]

.NET Framework Class Library
BillTo..::.driversLicenseState Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property driversLicenseState As String
C#
public string driversLicenseState { get; set; }
Visual C++
public:
property String^ driversLicenseState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_driversLicenseState();
function set_driversLicenseState(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


email Property

[image]

.NET Framework Class Library
BillTo..::.email Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property email As String
C#
public string email { get; set; }
Visual C++
public:
property String^ email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


firstName Property

[image]

.NET Framework Class Library
BillTo..::.firstName Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property firstName As String
C#
public string firstName { get; set; }
Visual C++
public:
property String^ firstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


hostname Property

[image]

.NET Framework Class Library
BillTo..::.hostname Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property hostname As String
C#
public string hostname { get; set; }
Visual C++
public:
property String^ hostname {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_hostname();
function set_hostname(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


httpBrowserCookiesAccepted Property

[image]

.NET Framework Class Library
BillTo..::.httpBrowserCookiesAccepted Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property httpBrowserCookiesAccepted As String
C#
public string httpBrowserCookiesAccepted { get; set; }
Visual C++
public:
property String^ httpBrowserCookiesAccepted {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_httpBrowserCookiesAccepted();
function set_httpBrowserCookiesAccepted(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


httpBrowserEmail Property

[image]

.NET Framework Class Library
BillTo..::.httpBrowserEmail Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property httpBrowserEmail As String
C#
public string httpBrowserEmail { get; set; }
Visual C++
public:
property String^ httpBrowserEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_httpBrowserEmail();
function set_httpBrowserEmail(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


httpBrowserType Property

[image]

.NET Framework Class Library
BillTo..::.httpBrowserType Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property httpBrowserType As String
C#
public string httpBrowserType { get; set; }
Visual C++
public:
property String^ httpBrowserType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_httpBrowserType();
function set_httpBrowserType(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


ipAddress Property

[image]

.NET Framework Class Library
BillTo..::.ipAddress Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ipAddress As String
C#
public string ipAddress { get; set; }
Visual C++
public:
property String^ ipAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ipAddress();
function set_ipAddress(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


ipNetworkAddress Property

[image]

.NET Framework Class Library
BillTo..::.ipNetworkAddress Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ipNetworkAddress As String
C#
public string ipNetworkAddress { get; set; }
Visual C++
public:
property String^ ipNetworkAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ipNetworkAddress();
function set_ipNetworkAddress(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


lastName Property

[image]

.NET Framework Class Library
BillTo..::.lastName Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property lastName As String
C#
public string lastName { get; set; }
Visual C++
public:
property String^ lastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


middleName Property

[image]

.NET Framework Class Library
BillTo..::.middleName Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property middleName As String
C#
public string middleName { get; set; }
Visual C++
public:
property String^ middleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_middleName();
function set_middleName(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


nif Property

[image]

.NET Framework Class Library
BillTo..::.nif Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property nif As String
C#
public string nif { get; set; }
Visual C++
public:
property String^ nif {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nif();
function set_nif(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


personalID Property

[image]

.NET Framework Class Library
BillTo..::.personalID Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property personalID As String
C#
public string personalID { get; set; }
Visual C++
public:
property String^ personalID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_personalID();
function set_personalID(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


phoneNumber Property

[image]

.NET Framework Class Library
BillTo..::.phoneNumber Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property phoneNumber As String
C#
public string phoneNumber { get; set; }
Visual C++
public:
property String^ phoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


postalCode Property

[image]

.NET Framework Class Library
BillTo..::.postalCode Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property postalCode As String
C#
public string postalCode { get; set; }
Visual C++
public:
property String^ postalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


ssn Property

[image]

.NET Framework Class Library
BillTo..::.ssn Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ssn As String
C#
public string ssn { get; set; }
Visual C++
public:
property String^ ssn {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ssn();
function set_ssn(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


state Property

[image]

.NET Framework Class Library
BillTo..::.state Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


street1 Property

[image]

.NET Framework Class Library
BillTo..::.street1 Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street1 As String
C#
public string street1 { get; set; }
Visual C++
public:
property String^ street1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street1();
function set_street1(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


street2 Property

[image]

.NET Framework Class Library
BillTo..::.street2 Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street2 As String
C#
public string street2 { get; set; }
Visual C++
public:
property String^ street2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street2();
function set_street2(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


street3 Property

[image]

.NET Framework Class Library
BillTo..::.street3 Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street3 As String
C#
public string street3 { get; set; }
Visual C++
public:
property String^ street3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street3();
function set_street3(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


street4 Property

[image]

.NET Framework Class Library
BillTo..::.street4 Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street4 As String
C#
public string street4 { get; set; }
Visual C++
public:
property String^ street4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street4();
function set_street4(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


suffix Property

[image]

.NET Framework Class Library
BillTo..::.suffix Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property suffix As String
C#
public string suffix { get; set; }
Visual C++
public:
property String^ suffix {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_suffix();
function set_suffix(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


title Property

[image]

.NET Framework Class Library
BillTo..::.title Property
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property title As String
C#
public string title { get; set; }
Visual C++
public:
property String^ title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

Remarks

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


BillTo Events

[image] [image]

.NET Framework Class Library
BillTo Events
BillTo Class See Also Send Feedback

The BillTo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BillTo..::.PropertyChanged Event
BillTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BillTo Class
InSite.Domain.CyberSourceService Namespace


BML Class

[image]

.NET Framework Class Library
BML Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BML _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BML : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BML : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BML = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BML',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BML

See Also

BML Members
InSite.Domain.CyberSourceService Namespace


BML Members

[image] [image]

.NET Framework Class Library
BML Members
BML Class Constructors Methods Properties Events See Also Send Feedback

The BML type exposes the following members.

Constructors

Name | Description
BML |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
adminEmailAddress |
adminFax |
adminFirstName |
adminLastName |
adminPhone |
adminTitle |
alternateIPAddress |
backOfficeIndicator |
billToPhoneType |
businessAddress1 |
businessAddress2 |
businessApplicationID |
businessCity |
businessCountry |
businessDAndBNumber |
businessLegalName |
businessLoanType |
businessMainPhone |
businessNAICSCode |
businessNumberOfEmployees |
businessPONumber |
businessPostalCode |
businessProductCode |
businessState |
businessTaxID |
businessType |
businessYearsInBusiness |
customerAuthenticatedByMerchant |
customerBillingAddressChange |
customerEmailChange |
customerHasCheckingAccount |
customerHasSavingsAccount |
customerPasswordChange |
customerPhoneChange |
customerRegistrationDate |
customerTypeFlag |
dbaName |
employerCity |
employerCompanyName |
employerCountry |
employerPhoneNumber |
employerPhoneType |
employerPostalCode |
employerState |
employerStreet1 |
employerStreet2 |
grossHouseholdIncome |
householdIncomeCurrency |
itemCategory |
merchantPromotionCode |
methodOfPayment |
pgAnnualIncome |
pgCheckingAccountIndicator |
pgDateOfBirth |
pgEmailAddress |
pgFirstName |
pgHomeAddress1 |
pgHomeAddress2 |
pgHomeCity |
pgHomeCountry |
pgHomePhone |
pgHomePostalCode |
pgHomeState |
pgIncomeCurrencyType |
pgLastName |
pgResidenceStatus |
pgSavingsAccountIndicator |
pgSSN |
pgTitle |
pgYearsAtEmployer |
pgYearsAtResidence |
pin |
preapprovalNumber |
productDeliveryTypeIndicator |
productType |
residenceStatus |
shipToEqualsBillToAddressIndicator |
shipToEqualsBillToNameIndicator |
shipToPhoneType |
supervisorEmailAddress |
supervisorFirstName |
supervisorLastName |
tcVersion |
userID |
yearsAtCurrentResidence |
yearsWithCurrentEmployer |

Events

Name | Description
PropertyChanged |

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


BML Constructor

[image]

.NET Framework Class Library
BML Constructor
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BML()
Visual C++
public:
BML()
JavaScript
InSite.Domain.CyberSourceService.BML = function();

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


BML Methods

[image] [image]

.NET Framework Class Library
BML Methods
BML Class See Also Send Feedback

The BML type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BML..::.RaisePropertyChanged Method
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


BML Properties

[image] [image]

.NET Framework Class Library
BML Properties
BML Class See Also Send Feedback

The BML type exposes the following members.

Properties

Name | Description
adminEmailAddress |
adminFax |
adminFirstName |
adminLastName |
adminPhone |
adminTitle |
alternateIPAddress |
backOfficeIndicator |
billToPhoneType |
businessAddress1 |
businessAddress2 |
businessApplicationID |
businessCity |
businessCountry |
businessDAndBNumber |
businessLegalName |
businessLoanType |
businessMainPhone |
businessNAICSCode |
businessNumberOfEmployees |
businessPONumber |
businessPostalCode |
businessProductCode |
businessState |
businessTaxID |
businessType |
businessYearsInBusiness |
customerAuthenticatedByMerchant |
customerBillingAddressChange |
customerEmailChange |
customerHasCheckingAccount |
customerHasSavingsAccount |
customerPasswordChange |
customerPhoneChange |
customerRegistrationDate |
customerTypeFlag |
dbaName |
employerCity |
employerCompanyName |
employerCountry |
employerPhoneNumber |
employerPhoneType |
employerPostalCode |
employerState |
employerStreet1 |
employerStreet2 |
grossHouseholdIncome |
householdIncomeCurrency |
itemCategory |
merchantPromotionCode |
methodOfPayment |
pgAnnualIncome |
pgCheckingAccountIndicator |
pgDateOfBirth |
pgEmailAddress |
pgFirstName |
pgHomeAddress1 |
pgHomeAddress2 |
pgHomeCity |
pgHomeCountry |
pgHomePhone |
pgHomePostalCode |
pgHomeState |
pgIncomeCurrencyType |
pgLastName |
pgResidenceStatus |
pgSavingsAccountIndicator |
pgSSN |
pgTitle |
pgYearsAtEmployer |
pgYearsAtResidence |
pin |
preapprovalNumber |
productDeliveryTypeIndicator |
productType |
residenceStatus |
shipToEqualsBillToAddressIndicator |
shipToEqualsBillToNameIndicator |
shipToPhoneType |
supervisorEmailAddress |
supervisorFirstName |
supervisorLastName |
tcVersion |
userID |
yearsAtCurrentResidence |
yearsWithCurrentEmployer |

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


adminEmailAddress Property

[image]

.NET Framework Class Library
BML..::.adminEmailAddress Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property adminEmailAddress As String
C#
public string adminEmailAddress { get; set; }
Visual C++
public:
property String^ adminEmailAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adminEmailAddress();
function set_adminEmailAddress(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


adminFax Property

[image]

.NET Framework Class Library
BML..::.adminFax Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property adminFax As String
C#
public string adminFax { get; set; }
Visual C++
public:
property String^ adminFax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adminFax();
function set_adminFax(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


adminFirstName Property

[image]

.NET Framework Class Library
BML..::.adminFirstName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property adminFirstName As String
C#
public string adminFirstName { get; set; }
Visual C++
public:
property String^ adminFirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adminFirstName();
function set_adminFirstName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


adminLastName Property

[image]

.NET Framework Class Library
BML..::.adminLastName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property adminLastName As String
C#
public string adminLastName { get; set; }
Visual C++
public:
property String^ adminLastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adminLastName();
function set_adminLastName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


adminPhone Property

[image]

.NET Framework Class Library
BML..::.adminPhone Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property adminPhone As String
C#
public string adminPhone { get; set; }
Visual C++
public:
property String^ adminPhone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adminPhone();
function set_adminPhone(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


adminTitle Property

[image]

.NET Framework Class Library
BML..::.adminTitle Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property adminTitle As String
C#
public string adminTitle { get; set; }
Visual C++
public:
property String^ adminTitle {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adminTitle();
function set_adminTitle(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


alternateIPAddress Property

[image]

.NET Framework Class Library
BML..::.alternateIPAddress Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateIPAddress As String
C#
public string alternateIPAddress { get; set; }
Visual C++
public:
property String^ alternateIPAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateIPAddress();
function set_alternateIPAddress(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


backOfficeIndicator Property

[image]

.NET Framework Class Library
BML..::.backOfficeIndicator Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property backOfficeIndicator As String
C#
public string backOfficeIndicator { get; set; }
Visual C++
public:
property String^ backOfficeIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_backOfficeIndicator();
function set_backOfficeIndicator(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


billToPhoneType Property

[image]

.NET Framework Class Library
BML..::.billToPhoneType Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billToPhoneType As String
C#
public string billToPhoneType { get; set; }
Visual C++
public:
property String^ billToPhoneType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_billToPhoneType();
function set_billToPhoneType(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessAddress1 Property

[image]

.NET Framework Class Library
BML..::.businessAddress1 Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessAddress1 As String
C#
public string businessAddress1 { get; set; }
Visual C++
public:
property String^ businessAddress1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessAddress1();
function set_businessAddress1(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessAddress2 Property

[image]

.NET Framework Class Library
BML..::.businessAddress2 Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessAddress2 As String
C#
public string businessAddress2 { get; set; }
Visual C++
public:
property String^ businessAddress2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessAddress2();
function set_businessAddress2(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessApplicationID Property

[image]

.NET Framework Class Library
BML..::.businessApplicationID Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessApplicationID As String
C#
public string businessApplicationID { get; set; }
Visual C++
public:
property String^ businessApplicationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessApplicationID();
function set_businessApplicationID(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessCity Property

[image]

.NET Framework Class Library
BML..::.businessCity Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessCity As String
C#
public string businessCity { get; set; }
Visual C++
public:
property String^ businessCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessCity();
function set_businessCity(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessCountry Property

[image]

.NET Framework Class Library
BML..::.businessCountry Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessCountry As String
C#
public string businessCountry { get; set; }
Visual C++
public:
property String^ businessCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessCountry();
function set_businessCountry(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessDAndBNumber Property

[image]

.NET Framework Class Library
BML..::.businessDAndBNumber Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessDAndBNumber As String
C#
public string businessDAndBNumber { get; set; }
Visual C++
public:
property String^ businessDAndBNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessDAndBNumber();
function set_businessDAndBNumber(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessLegalName Property

[image]

.NET Framework Class Library
BML..::.businessLegalName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessLegalName As String
C#
public string businessLegalName { get; set; }
Visual C++
public:
property String^ businessLegalName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessLegalName();
function set_businessLegalName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessLoanType Property

[image]

.NET Framework Class Library
BML..::.businessLoanType Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessLoanType As String
C#
public string businessLoanType { get; set; }
Visual C++
public:
property String^ businessLoanType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessLoanType();
function set_businessLoanType(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessMainPhone Property

[image]

.NET Framework Class Library
BML..::.businessMainPhone Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessMainPhone As String
C#
public string businessMainPhone { get; set; }
Visual C++
public:
property String^ businessMainPhone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessMainPhone();
function set_businessMainPhone(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessNAICSCode Property

[image]

.NET Framework Class Library
BML..::.businessNAICSCode Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessNAICSCode As String
C#
public string businessNAICSCode { get; set; }
Visual C++
public:
property String^ businessNAICSCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessNAICSCode();
function set_businessNAICSCode(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessNumberOfEmployees Property

[image]

.NET Framework Class Library
BML..::.businessNumberOfEmployees Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessNumberOfEmployees As String
C#
public string businessNumberOfEmployees { get; set; }
Visual C++
public:
property String^ businessNumberOfEmployees {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessNumberOfEmployees();
function set_businessNumberOfEmployees(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessPONumber Property

[image]

.NET Framework Class Library
BML..::.businessPONumber Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessPONumber As String
C#
public string businessPONumber { get; set; }
Visual C++
public:
property String^ businessPONumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessPONumber();
function set_businessPONumber(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessPostalCode Property

[image]

.NET Framework Class Library
BML..::.businessPostalCode Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessPostalCode As String
C#
public string businessPostalCode { get; set; }
Visual C++
public:
property String^ businessPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessPostalCode();
function set_businessPostalCode(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessProductCode Property

[image]

.NET Framework Class Library
BML..::.businessProductCode Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessProductCode As String
C#
public string businessProductCode { get; set; }
Visual C++
public:
property String^ businessProductCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessProductCode();
function set_businessProductCode(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessState Property

[image]

.NET Framework Class Library
BML..::.businessState Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessState As String
C#
public string businessState { get; set; }
Visual C++
public:
property String^ businessState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessState();
function set_businessState(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessTaxID Property

[image]

.NET Framework Class Library
BML..::.businessTaxID Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessTaxID As String
C#
public string businessTaxID { get; set; }
Visual C++
public:
property String^ businessTaxID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessTaxID();
function set_businessTaxID(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessType Property

[image]

.NET Framework Class Library
BML..::.businessType Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessType As String
C#
public string businessType { get; set; }
Visual C++
public:
property String^ businessType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessType();
function set_businessType(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


businessYearsInBusiness Property

[image]

.NET Framework Class Library
BML..::.businessYearsInBusiness Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessYearsInBusiness As String
C#
public string businessYearsInBusiness { get; set; }
Visual C++
public:
property String^ businessYearsInBusiness {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_businessYearsInBusiness();
function set_businessYearsInBusiness(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerAuthenticatedByMerchant Property

[image]

.NET Framework Class Library
BML..::.customerAuthenticatedByMerchant Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerAuthenticatedByMerchant As String
C#
public string customerAuthenticatedByMerchant { get; set; }
Visual C++
public:
property String^ customerAuthenticatedByMerchant {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerAuthenticatedByMerchant();
function set_customerAuthenticatedByMerchant(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerBillingAddressChange Property

[image]

.NET Framework Class Library
BML..::.customerBillingAddressChange Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerBillingAddressChange As String
C#
public string customerBillingAddressChange { get; set; }
Visual C++
public:
property String^ customerBillingAddressChange {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerBillingAddressChange();
function set_customerBillingAddressChange(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerEmailChange Property

[image]

.NET Framework Class Library
BML..::.customerEmailChange Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerEmailChange As String
C#
public string customerEmailChange { get; set; }
Visual C++
public:
property String^ customerEmailChange {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerEmailChange();
function set_customerEmailChange(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerHasCheckingAccount Property

[image]

.NET Framework Class Library
BML..::.customerHasCheckingAccount Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerHasCheckingAccount As String
C#
public string customerHasCheckingAccount { get; set; }
Visual C++
public:
property String^ customerHasCheckingAccount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerHasCheckingAccount();
function set_customerHasCheckingAccount(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerHasSavingsAccount Property

[image]

.NET Framework Class Library
BML..::.customerHasSavingsAccount Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerHasSavingsAccount As String
C#
public string customerHasSavingsAccount { get; set; }
Visual C++
public:
property String^ customerHasSavingsAccount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerHasSavingsAccount();
function set_customerHasSavingsAccount(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerPasswordChange Property

[image]

.NET Framework Class Library
BML..::.customerPasswordChange Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerPasswordChange As String
C#
public string customerPasswordChange { get; set; }
Visual C++
public:
property String^ customerPasswordChange {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerPasswordChange();
function set_customerPasswordChange(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerPhoneChange Property

[image]

.NET Framework Class Library
BML..::.customerPhoneChange Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerPhoneChange As String
C#
public string customerPhoneChange { get; set; }
Visual C++
public:
property String^ customerPhoneChange {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerPhoneChange();
function set_customerPhoneChange(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerRegistrationDate Property

[image]

.NET Framework Class Library
BML..::.customerRegistrationDate Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerRegistrationDate As String
C#
public string customerRegistrationDate { get; set; }
Visual C++
public:
property String^ customerRegistrationDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerRegistrationDate();
function set_customerRegistrationDate(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


customerTypeFlag Property

[image]

.NET Framework Class Library
BML..::.customerTypeFlag Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerTypeFlag As String
C#
public string customerTypeFlag { get; set; }
Visual C++
public:
property String^ customerTypeFlag {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerTypeFlag();
function set_customerTypeFlag(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


dbaName Property

[image]

.NET Framework Class Library
BML..::.dbaName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dbaName As String
C#
public string dbaName { get; set; }
Visual C++
public:
property String^ dbaName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dbaName();
function set_dbaName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerCity Property

[image]

.NET Framework Class Library
BML..::.employerCity Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerCity As String
C#
public string employerCity { get; set; }
Visual C++
public:
property String^ employerCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerCity();
function set_employerCity(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerCompanyName Property

[image]

.NET Framework Class Library
BML..::.employerCompanyName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerCompanyName As String
C#
public string employerCompanyName { get; set; }
Visual C++
public:
property String^ employerCompanyName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerCompanyName();
function set_employerCompanyName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerCountry Property

[image]

.NET Framework Class Library
BML..::.employerCountry Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerCountry As String
C#
public string employerCountry { get; set; }
Visual C++
public:
property String^ employerCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerCountry();
function set_employerCountry(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerPhoneNumber Property

[image]

.NET Framework Class Library
BML..::.employerPhoneNumber Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerPhoneNumber As String
C#
public string employerPhoneNumber { get; set; }
Visual C++
public:
property String^ employerPhoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerPhoneNumber();
function set_employerPhoneNumber(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerPhoneType Property

[image]

.NET Framework Class Library
BML..::.employerPhoneType Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerPhoneType As String
C#
public string employerPhoneType { get; set; }
Visual C++
public:
property String^ employerPhoneType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerPhoneType();
function set_employerPhoneType(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerPostalCode Property

[image]

.NET Framework Class Library
BML..::.employerPostalCode Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerPostalCode As String
C#
public string employerPostalCode { get; set; }
Visual C++
public:
property String^ employerPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerPostalCode();
function set_employerPostalCode(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerState Property

[image]

.NET Framework Class Library
BML..::.employerState Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerState As String
C#
public string employerState { get; set; }
Visual C++
public:
property String^ employerState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerState();
function set_employerState(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerStreet1 Property

[image]

.NET Framework Class Library
BML..::.employerStreet1 Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerStreet1 As String
C#
public string employerStreet1 { get; set; }
Visual C++
public:
property String^ employerStreet1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerStreet1();
function set_employerStreet1(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


employerStreet2 Property

[image]

.NET Framework Class Library
BML..::.employerStreet2 Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property employerStreet2 As String
C#
public string employerStreet2 { get; set; }
Visual C++
public:
property String^ employerStreet2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_employerStreet2();
function set_employerStreet2(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


grossHouseholdIncome Property

[image]

.NET Framework Class Library
BML..::.grossHouseholdIncome Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property grossHouseholdIncome As String
C#
public string grossHouseholdIncome { get; set; }
Visual C++
public:
property String^ grossHouseholdIncome {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_grossHouseholdIncome();
function set_grossHouseholdIncome(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


householdIncomeCurrency Property

[image]

.NET Framework Class Library
BML..::.householdIncomeCurrency Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property householdIncomeCurrency As String
C#
public string householdIncomeCurrency { get; set; }
Visual C++
public:
property String^ householdIncomeCurrency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_householdIncomeCurrency();
function set_householdIncomeCurrency(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


itemCategory Property

[image]

.NET Framework Class Library
BML..::.itemCategory Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property itemCategory As String
C#
public string itemCategory { get; set; }
Visual C++
public:
property String^ itemCategory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_itemCategory();
function set_itemCategory(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


merchantPromotionCode Property

[image]

.NET Framework Class Library
BML..::.merchantPromotionCode Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantPromotionCode As String
C#
public string merchantPromotionCode { get; set; }
Visual C++
public:
property String^ merchantPromotionCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantPromotionCode();
function set_merchantPromotionCode(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


methodOfPayment Property

[image]

.NET Framework Class Library
BML..::.methodOfPayment Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property methodOfPayment As String
C#
public string methodOfPayment { get; set; }
Visual C++
public:
property String^ methodOfPayment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_methodOfPayment();
function set_methodOfPayment(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgAnnualIncome Property

[image]

.NET Framework Class Library
BML..::.pgAnnualIncome Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgAnnualIncome As String
C#
public string pgAnnualIncome { get; set; }
Visual C++
public:
property String^ pgAnnualIncome {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgAnnualIncome();
function set_pgAnnualIncome(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgCheckingAccountIndicator Property

[image]

.NET Framework Class Library
BML..::.pgCheckingAccountIndicator Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgCheckingAccountIndicator As String
C#
public string pgCheckingAccountIndicator { get; set; }
Visual C++
public:
property String^ pgCheckingAccountIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgCheckingAccountIndicator();
function set_pgCheckingAccountIndicator(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgDateOfBirth Property

[image]

.NET Framework Class Library
BML..::.pgDateOfBirth Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgDateOfBirth As String
C#
public string pgDateOfBirth { get; set; }
Visual C++
public:
property String^ pgDateOfBirth {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgDateOfBirth();
function set_pgDateOfBirth(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgEmailAddress Property

[image]

.NET Framework Class Library
BML..::.pgEmailAddress Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgEmailAddress As String
C#
public string pgEmailAddress { get; set; }
Visual C++
public:
property String^ pgEmailAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgEmailAddress();
function set_pgEmailAddress(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgFirstName Property

[image]

.NET Framework Class Library
BML..::.pgFirstName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgFirstName As String
C#
public string pgFirstName { get; set; }
Visual C++
public:
property String^ pgFirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgFirstName();
function set_pgFirstName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgHomeAddress1 Property

[image]

.NET Framework Class Library
BML..::.pgHomeAddress1 Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgHomeAddress1 As String
C#
public string pgHomeAddress1 { get; set; }
Visual C++
public:
property String^ pgHomeAddress1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgHomeAddress1();
function set_pgHomeAddress1(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgHomeAddress2 Property

[image]

.NET Framework Class Library
BML..::.pgHomeAddress2 Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgHomeAddress2 As String
C#
public string pgHomeAddress2 { get; set; }
Visual C++
public:
property String^ pgHomeAddress2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgHomeAddress2();
function set_pgHomeAddress2(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgHomeCity Property

[image]

.NET Framework Class Library
BML..::.pgHomeCity Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgHomeCity As String
C#
public string pgHomeCity { get; set; }
Visual C++
public:
property String^ pgHomeCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgHomeCity();
function set_pgHomeCity(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgHomeCountry Property

[image]

.NET Framework Class Library
BML..::.pgHomeCountry Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgHomeCountry As String
C#
public string pgHomeCountry { get; set; }
Visual C++
public:
property String^ pgHomeCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgHomeCountry();
function set_pgHomeCountry(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgHomePhone Property

[image]

.NET Framework Class Library
BML..::.pgHomePhone Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgHomePhone As String
C#
public string pgHomePhone { get; set; }
Visual C++
public:
property String^ pgHomePhone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgHomePhone();
function set_pgHomePhone(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgHomePostalCode Property

[image]

.NET Framework Class Library
BML..::.pgHomePostalCode Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgHomePostalCode As String
C#
public string pgHomePostalCode { get; set; }
Visual C++
public:
property String^ pgHomePostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgHomePostalCode();
function set_pgHomePostalCode(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgHomeState Property

[image]

.NET Framework Class Library
BML..::.pgHomeState Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgHomeState As String
C#
public string pgHomeState { get; set; }
Visual C++
public:
property String^ pgHomeState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgHomeState();
function set_pgHomeState(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgIncomeCurrencyType Property

[image]

.NET Framework Class Library
BML..::.pgIncomeCurrencyType Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgIncomeCurrencyType As String
C#
public string pgIncomeCurrencyType { get; set; }
Visual C++
public:
property String^ pgIncomeCurrencyType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgIncomeCurrencyType();
function set_pgIncomeCurrencyType(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgLastName Property

[image]

.NET Framework Class Library
BML..::.pgLastName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgLastName As String
C#
public string pgLastName { get; set; }
Visual C++
public:
property String^ pgLastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgLastName();
function set_pgLastName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgResidenceStatus Property

[image]

.NET Framework Class Library
BML..::.pgResidenceStatus Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgResidenceStatus As String
C#
public string pgResidenceStatus { get; set; }
Visual C++
public:
property String^ pgResidenceStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgResidenceStatus();
function set_pgResidenceStatus(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgSavingsAccountIndicator Property

[image]

.NET Framework Class Library
BML..::.pgSavingsAccountIndicator Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgSavingsAccountIndicator As String
C#
public string pgSavingsAccountIndicator { get; set; }
Visual C++
public:
property String^ pgSavingsAccountIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgSavingsAccountIndicator();
function set_pgSavingsAccountIndicator(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgSSN Property

[image]

.NET Framework Class Library
BML..::.pgSSN Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgSSN As String
C#
public string pgSSN { get; set; }
Visual C++
public:
property String^ pgSSN {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgSSN();
function set_pgSSN(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgTitle Property

[image]

.NET Framework Class Library
BML..::.pgTitle Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgTitle As String
C#
public string pgTitle { get; set; }
Visual C++
public:
property String^ pgTitle {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgTitle();
function set_pgTitle(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgYearsAtEmployer Property

[image]

.NET Framework Class Library
BML..::.pgYearsAtEmployer Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgYearsAtEmployer As String
C#
public string pgYearsAtEmployer { get; set; }
Visual C++
public:
property String^ pgYearsAtEmployer {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgYearsAtEmployer();
function set_pgYearsAtEmployer(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pgYearsAtResidence Property

[image]

.NET Framework Class Library
BML..::.pgYearsAtResidence Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pgYearsAtResidence As String
C#
public string pgYearsAtResidence { get; set; }
Visual C++
public:
property String^ pgYearsAtResidence {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pgYearsAtResidence();
function set_pgYearsAtResidence(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


pin Property

[image]

.NET Framework Class Library
BML..::.pin Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pin As String
C#
public string pin { get; set; }
Visual C++
public:
property String^ pin {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pin();
function set_pin(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


preapprovalNumber Property

[image]

.NET Framework Class Library
BML..::.preapprovalNumber Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property preapprovalNumber As String
C#
public string preapprovalNumber { get; set; }
Visual C++
public:
property String^ preapprovalNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_preapprovalNumber();
function set_preapprovalNumber(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


productDeliveryTypeIndicator Property

[image]

.NET Framework Class Library
BML..::.productDeliveryTypeIndicator Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property productDeliveryTypeIndicator As String
C#
public string productDeliveryTypeIndicator { get; set; }
Visual C++
public:
property String^ productDeliveryTypeIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productDeliveryTypeIndicator();
function set_productDeliveryTypeIndicator(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


productType Property

[image]

.NET Framework Class Library
BML..::.productType Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property productType As String
C#
public string productType { get; set; }
Visual C++
public:
property String^ productType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productType();
function set_productType(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


residenceStatus Property

[image]

.NET Framework Class Library
BML..::.residenceStatus Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property residenceStatus As String
C#
public string residenceStatus { get; set; }
Visual C++
public:
property String^ residenceStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_residenceStatus();
function set_residenceStatus(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


shipToEqualsBillToAddressIndicator Property

[image]

.NET Framework Class Library
BML..::.shipToEqualsBillToAddressIndicator Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToEqualsBillToAddressIndicator As String
C#
public string shipToEqualsBillToAddressIndicator { get; set; }
Visual C++
public:
property String^ shipToEqualsBillToAddressIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToEqualsBillToAddressIndicator();
function set_shipToEqualsBillToAddressIndicator(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


shipToEqualsBillToNameIndicator Property

[image]

.NET Framework Class Library
BML..::.shipToEqualsBillToNameIndicator Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToEqualsBillToNameIndicator As String
C#
public string shipToEqualsBillToNameIndicator { get; set; }
Visual C++
public:
property String^ shipToEqualsBillToNameIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToEqualsBillToNameIndicator();
function set_shipToEqualsBillToNameIndicator(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


shipToPhoneType Property

[image]

.NET Framework Class Library
BML..::.shipToPhoneType Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToPhoneType As String
C#
public string shipToPhoneType { get; set; }
Visual C++
public:
property String^ shipToPhoneType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToPhoneType();
function set_shipToPhoneType(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


supervisorEmailAddress Property

[image]

.NET Framework Class Library
BML..::.supervisorEmailAddress Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property supervisorEmailAddress As String
C#
public string supervisorEmailAddress { get; set; }
Visual C++
public:
property String^ supervisorEmailAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_supervisorEmailAddress();
function set_supervisorEmailAddress(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


supervisorFirstName Property

[image]

.NET Framework Class Library
BML..::.supervisorFirstName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property supervisorFirstName As String
C#
public string supervisorFirstName { get; set; }
Visual C++
public:
property String^ supervisorFirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_supervisorFirstName();
function set_supervisorFirstName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


supervisorLastName Property

[image]

.NET Framework Class Library
BML..::.supervisorLastName Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property supervisorLastName As String
C#
public string supervisorLastName { get; set; }
Visual C++
public:
property String^ supervisorLastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_supervisorLastName();
function set_supervisorLastName(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


tcVersion Property

[image]

.NET Framework Class Library
BML..::.tcVersion Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property tcVersion As String
C#
public string tcVersion { get; set; }
Visual C++
public:
property String^ tcVersion {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_tcVersion();
function set_tcVersion(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


userID Property

[image]

.NET Framework Class Library
BML..::.userID Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property userID As String
C#
public string userID { get; set; }
Visual C++
public:
property String^ userID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_userID();
function set_userID(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


yearsAtCurrentResidence Property

[image]

.NET Framework Class Library
BML..::.yearsAtCurrentResidence Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property yearsAtCurrentResidence As String
C#
public string yearsAtCurrentResidence { get; set; }
Visual C++
public:
property String^ yearsAtCurrentResidence {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_yearsAtCurrentResidence();
function set_yearsAtCurrentResidence(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


yearsWithCurrentEmployer Property

[image]

.NET Framework Class Library
BML..::.yearsWithCurrentEmployer Property
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property yearsWithCurrentEmployer As String
C#
public string yearsWithCurrentEmployer { get; set; }
Visual C++
public:
property String^ yearsWithCurrentEmployer {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_yearsWithCurrentEmployer();
function set_yearsWithCurrentEmployer(value);

Remarks

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


BML Events

[image] [image]

.NET Framework Class Library
BML Events
BML Class See Also Send Feedback

The BML type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BML..::.PropertyChanged Event
BML Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BML Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentReply Class

[image]

.NET Framework Class Library
BoletoPaymentReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BoletoPaymentReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BoletoPaymentReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BoletoPaymentReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BoletoPaymentReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BoletoPaymentReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BoletoPaymentReply

See Also

BoletoPaymentReply Members
InSite.Domain.CyberSourceService Namespace


BoletoPaymentReply Members

[image] [image]

.NET Framework Class Library
BoletoPaymentReply Members
BoletoPaymentReply Class Constructors Methods Properties Events See Also Send Feedback

The BoletoPaymentReply type exposes the following members.

Constructors

Name | Description
BoletoPaymentReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
boletoNumber |
expirationDate |
reasonCode |
reconciliationID |
requestDateTime |
url |

Events

Name | Description
PropertyChanged |

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentReply Constructor

[image]

.NET Framework Class Library
BoletoPaymentReply Constructor
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BoletoPaymentReply()
Visual C++
public:
BoletoPaymentReply()
JavaScript
InSite.Domain.CyberSourceService.BoletoPaymentReply = function();

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentReply Methods

[image] [image]

.NET Framework Class Library
BoletoPaymentReply Methods
BoletoPaymentReply Class See Also Send Feedback

The BoletoPaymentReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BoletoPaymentReply..::.RaisePropertyChanged Method
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentReply Properties

[image] [image]

.NET Framework Class Library
BoletoPaymentReply Properties
BoletoPaymentReply Class See Also Send Feedback

The BoletoPaymentReply type exposes the following members.

Properties

Name | Description
amount |
boletoNumber |
expirationDate |
reasonCode |
reconciliationID |
requestDateTime |
url |

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
BoletoPaymentReply..::.amount Property
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


boletoNumber Property

[image]

.NET Framework Class Library
BoletoPaymentReply..::.boletoNumber Property
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property boletoNumber As String
C#
public string boletoNumber { get; set; }
Visual C++
public:
property String^ boletoNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_boletoNumber();
function set_boletoNumber(value);

Remarks

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


expirationDate Property

[image]

.NET Framework Class Library
BoletoPaymentReply..::.expirationDate Property
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property expirationDate As String
C#
public string expirationDate { get; set; }
Visual C++
public:
property String^ expirationDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationDate();
function set_expirationDate(value);

Remarks

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
BoletoPaymentReply..::.reasonCode Property
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
BoletoPaymentReply..::.reconciliationID Property
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
BoletoPaymentReply..::.requestDateTime Property
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


url Property

[image]

.NET Framework Class Library
BoletoPaymentReply..::.url Property
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property url As String
C#
public string url { get; set; }
Visual C++
public:
property String^ url {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_url();
function set_url(value);

Remarks

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentReply Events

[image] [image]

.NET Framework Class Library
BoletoPaymentReply Events
BoletoPaymentReply Class See Also Send Feedback

The BoletoPaymentReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BoletoPaymentReply..::.PropertyChanged Event
BoletoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BoletoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentService Class

[image]

.NET Framework Class Library
BoletoPaymentService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BoletoPaymentService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BoletoPaymentService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BoletoPaymentService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BoletoPaymentService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BoletoPaymentService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BoletoPaymentService

See Also

BoletoPaymentService Members
InSite.Domain.CyberSourceService Namespace


BoletoPaymentService Members

[image] [image]

.NET Framework Class Library
BoletoPaymentService Members
BoletoPaymentService Class Constructors Methods Properties Events See Also Send Feedback

The BoletoPaymentService type exposes the following members.

Constructors

Name | Description
BoletoPaymentService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
expirationDate |
instruction |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentService Constructor

[image]

.NET Framework Class Library
BoletoPaymentService Constructor
BoletoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BoletoPaymentService()
Visual C++
public:
BoletoPaymentService()
JavaScript
InSite.Domain.CyberSourceService.BoletoPaymentService = function();

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentService Methods

[image] [image]

.NET Framework Class Library
BoletoPaymentService Methods
BoletoPaymentService Class See Also Send Feedback

The BoletoPaymentService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BoletoPaymentService..::.RaisePropertyChanged Method
BoletoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentService Properties

[image] [image]

.NET Framework Class Library
BoletoPaymentService Properties
BoletoPaymentService Class See Also Send Feedback

The BoletoPaymentService type exposes the following members.

Properties

Name | Description
expirationDate |
instruction |
reconciliationID |
run |

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


expirationDate Property

[image]

.NET Framework Class Library
BoletoPaymentService..::.expirationDate Property
BoletoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property expirationDate As String
C#
public string expirationDate { get; set; }
Visual C++
public:
property String^ expirationDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationDate();
function set_expirationDate(value);

Remarks

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


instruction Property

[image]

.NET Framework Class Library
BoletoPaymentService..::.instruction Property
BoletoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property instruction As String
C#
public string instruction { get; set; }
Visual C++
public:
property String^ instruction {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_instruction();
function set_instruction(value);

Remarks

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
BoletoPaymentService..::.reconciliationID Property
BoletoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
BoletoPaymentService..::.run Property
BoletoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


BoletoPaymentService Events

[image] [image]

.NET Framework Class Library
BoletoPaymentService Events
BoletoPaymentService Class See Also Send Feedback

The BoletoPaymentService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BoletoPaymentService..::.PropertyChanged Event
BoletoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BoletoPaymentService Class
InSite.Domain.CyberSourceService Namespace


BusinessRules Class

[image]

.NET Framework Class Library
BusinessRules Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class BusinessRules _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class BusinessRules : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class BusinessRules : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.BusinessRules = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.BusinessRules',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.BusinessRules

See Also

BusinessRules Members
InSite.Domain.CyberSourceService Namespace


BusinessRules Members

[image] [image]

.NET Framework Class Library
BusinessRules Members
BusinessRules Class Constructors Methods Properties Events See Also Send Feedback

The BusinessRules type exposes the following members.

Constructors

Name | Description
BusinessRules |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
declineAVSFlags |
ignoreAVSResult |
ignoreCVResult |
ignoreDAVResult |
ignoreExportResult |
ignoreValidateResult |
scoreThreshold |

Events

Name | Description
PropertyChanged |

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


BusinessRules Constructor

[image]

.NET Framework Class Library
BusinessRules Constructor
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BusinessRules()
Visual C++
public:
BusinessRules()
JavaScript
InSite.Domain.CyberSourceService.BusinessRules = function();

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


BusinessRules Methods

[image] [image]

.NET Framework Class Library
BusinessRules Methods
BusinessRules Class See Also Send Feedback

The BusinessRules type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
BusinessRules..::.RaisePropertyChanged Method
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


BusinessRules Properties

[image] [image]

.NET Framework Class Library
BusinessRules Properties
BusinessRules Class See Also Send Feedback

The BusinessRules type exposes the following members.

Properties

Name | Description
declineAVSFlags |
ignoreAVSResult |
ignoreCVResult |
ignoreDAVResult |
ignoreExportResult |
ignoreValidateResult |
scoreThreshold |

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


declineAVSFlags Property

[image]

.NET Framework Class Library
BusinessRules..::.declineAVSFlags Property
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property declineAVSFlags As String
C#
public string declineAVSFlags { get; set; }
Visual C++
public:
property String^ declineAVSFlags {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_declineAVSFlags();
function set_declineAVSFlags(value);

Remarks

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


ignoreAVSResult Property

[image]

.NET Framework Class Library
BusinessRules..::.ignoreAVSResult Property
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ignoreAVSResult As String
C#
public string ignoreAVSResult { get; set; }
Visual C++
public:
property String^ ignoreAVSResult {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ignoreAVSResult();
function set_ignoreAVSResult(value);

Remarks

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


ignoreCVResult Property

[image]

.NET Framework Class Library
BusinessRules..::.ignoreCVResult Property
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ignoreCVResult As String
C#
public string ignoreCVResult { get; set; }
Visual C++
public:
property String^ ignoreCVResult {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ignoreCVResult();
function set_ignoreCVResult(value);

Remarks

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


ignoreDAVResult Property

[image]

.NET Framework Class Library
BusinessRules..::.ignoreDAVResult Property
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ignoreDAVResult As String
C#
public string ignoreDAVResult { get; set; }
Visual C++
public:
property String^ ignoreDAVResult {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ignoreDAVResult();
function set_ignoreDAVResult(value);

Remarks

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


ignoreExportResult Property

[image]

.NET Framework Class Library
BusinessRules..::.ignoreExportResult Property
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ignoreExportResult As String
C#
public string ignoreExportResult { get; set; }
Visual C++
public:
property String^ ignoreExportResult {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ignoreExportResult();
function set_ignoreExportResult(value);

Remarks

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


ignoreValidateResult Property

[image]

.NET Framework Class Library
BusinessRules..::.ignoreValidateResult Property
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ignoreValidateResult As String
C#
public string ignoreValidateResult { get; set; }
Visual C++
public:
property String^ ignoreValidateResult {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ignoreValidateResult();
function set_ignoreValidateResult(value);

Remarks

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


scoreThreshold Property

[image]

.NET Framework Class Library
BusinessRules..::.scoreThreshold Property
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property scoreThreshold As String
C#
public string scoreThreshold { get; set; }
Visual C++
public:
property String^ scoreThreshold {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_scoreThreshold();
function set_scoreThreshold(value);

Remarks

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


BusinessRules Events

[image] [image]

.NET Framework Class Library
BusinessRules Events
BusinessRules Class See Also Send Feedback

The BusinessRules type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
BusinessRules..::.PropertyChanged Event
BusinessRules Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

BusinessRules Class
InSite.Domain.CyberSourceService Namespace


Card Class

[image]

.NET Framework Class Library
Card Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Card _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Card : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Card : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Card = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Card',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Card

See Also

Card Members
InSite.Domain.CyberSourceService Namespace


Card Members

[image] [image]

.NET Framework Class Library
Card Members
Card Class Constructors Methods Properties Events See Also Send Feedback

The Card type exposes the following members.

Constructors

Name | Description
Card |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
accountEncoderID |
accountNumber |
bin |
cardType |
cvIndicator |
cvNumber |
expirationMonth |
expirationYear |
fullName |
issueNumber |
pin |
startMonth |
startYear |

Events

Name | Description
PropertyChanged |

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


Card Constructor

[image]

.NET Framework Class Library
Card Constructor
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Card()
Visual C++
public:
Card()
JavaScript
InSite.Domain.CyberSourceService.Card = function();

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


Card Methods

[image] [image]

.NET Framework Class Library
Card Methods
Card Class See Also Send Feedback

The Card type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Card..::.RaisePropertyChanged Method
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


Card Properties

[image] [image]

.NET Framework Class Library
Card Properties
Card Class See Also Send Feedback

The Card type exposes the following members.

Properties

Name | Description
accountEncoderID |
accountNumber |
bin |
cardType |
cvIndicator |
cvNumber |
expirationMonth |
expirationYear |
fullName |
issueNumber |
pin |
startMonth |
startYear |

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


accountEncoderID Property

[image]

.NET Framework Class Library
Card..::.accountEncoderID Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountEncoderID As String
C#
public string accountEncoderID { get; set; }
Visual C++
public:
property String^ accountEncoderID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountEncoderID();
function set_accountEncoderID(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


accountNumber Property

[image]

.NET Framework Class Library
Card..::.accountNumber Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountNumber As String
C#
public string accountNumber { get; set; }
Visual C++
public:
property String^ accountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


bin Property

[image]

.NET Framework Class Library
Card..::.bin Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bin As String
C#
public string bin { get; set; }
Visual C++
public:
property String^ bin {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bin();
function set_bin(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


cardType Property

[image]

.NET Framework Class Library
Card..::.cardType Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardType As String
C#
public string cardType { get; set; }
Visual C++
public:
property String^ cardType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardType();
function set_cardType(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


cvIndicator Property

[image]

.NET Framework Class Library
Card..::.cvIndicator Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cvIndicator As String
C#
public string cvIndicator { get; set; }
Visual C++
public:
property String^ cvIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cvIndicator();
function set_cvIndicator(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


cvNumber Property

[image]

.NET Framework Class Library
Card..::.cvNumber Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cvNumber As String
C#
public string cvNumber { get; set; }
Visual C++
public:
property String^ cvNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cvNumber();
function set_cvNumber(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


expirationMonth Property

[image]

.NET Framework Class Library
Card..::.expirationMonth Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property expirationMonth As String
C#
public string expirationMonth { get; set; }
Visual C++
public:
property String^ expirationMonth {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationMonth();
function set_expirationMonth(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


expirationYear Property

[image]

.NET Framework Class Library
Card..::.expirationYear Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property expirationYear As String
C#
public string expirationYear { get; set; }
Visual C++
public:
property String^ expirationYear {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationYear();
function set_expirationYear(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


fullName Property

[image]

.NET Framework Class Library
Card..::.fullName Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fullName As String
C#
public string fullName { get; set; }
Visual C++
public:
property String^ fullName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fullName();
function set_fullName(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


issueNumber Property

[image]

.NET Framework Class Library
Card..::.issueNumber Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property issueNumber As String
C#
public string issueNumber { get; set; }
Visual C++
public:
property String^ issueNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_issueNumber();
function set_issueNumber(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


pin Property

[image]

.NET Framework Class Library
Card..::.pin Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pin As String
C#
public string pin { get; set; }
Visual C++
public:
property String^ pin {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pin();
function set_pin(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


startMonth Property

[image]

.NET Framework Class Library
Card..::.startMonth Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property startMonth As String
C#
public string startMonth { get; set; }
Visual C++
public:
property String^ startMonth {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_startMonth();
function set_startMonth(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


startYear Property

[image]

.NET Framework Class Library
Card..::.startYear Property
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property startYear As String
C#
public string startYear { get; set; }
Visual C++
public:
property String^ startYear {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_startYear();
function set_startYear(value);

Remarks

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


Card Events

[image] [image]

.NET Framework Class Library
Card Events
Card Class See Also Send Feedback

The Card type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Card..::.PropertyChanged Event
Card Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Card Class
InSite.Domain.CyberSourceService Namespace


CCAuthReply Class

[image]

.NET Framework Class Library
CCAuthReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCAuthReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCAuthReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCAuthReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCAuthReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCAuthReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCAuthReply

See Also

CCAuthReply Members
InSite.Domain.CyberSourceService Namespace


CCAuthReply Members

[image] [image]

.NET Framework Class Library
CCAuthReply Members
CCAuthReply Class Constructors Methods Properties Events See Also Send Feedback

The CCAuthReply type exposes the following members.

Constructors

Name | Description
CCAuthReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
accountBalance |
amount |
approvedAmount |
approvedTerms |
authenticationXID |
authFactorCode |
authorizationCode |
authorizationXID |
authorizedDateTime |
authRecord |
avsCode |
avsCodeRaw |
bmlAccountNumber |
cavvResponseCode |
cavvResponseCodeRaw |
creditLine |
cvCode |
cvCodeRaw |
enhancedDataEnabled |
forwardCode |
fundingTotals |
fxQuoteExpirationDateTime |
fxQuoteID |
fxQuoteRate |
fxQuoteType |
merchantAdviceCode |
merchantAdviceCodeRaw |
personalIDCode |
processorCardType |
processorResponse |
reasonCode |
reconciliationID |
referralResponseNumber |
subResponseCode |

Events

Name | Description
PropertyChanged |

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReply Constructor

[image]

.NET Framework Class Library
CCAuthReply Constructor
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCAuthReply()
Visual C++
public:
CCAuthReply()
JavaScript
InSite.Domain.CyberSourceService.CCAuthReply = function();

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReply Methods

[image] [image]

.NET Framework Class Library
CCAuthReply Methods
CCAuthReply Class See Also Send Feedback

The CCAuthReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCAuthReply..::.RaisePropertyChanged Method
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReply Properties

[image] [image]

.NET Framework Class Library
CCAuthReply Properties
CCAuthReply Class See Also Send Feedback

The CCAuthReply type exposes the following members.

Properties

Name | Description
accountBalance |
amount |
approvedAmount |
approvedTerms |
authenticationXID |
authFactorCode |
authorizationCode |
authorizationXID |
authorizedDateTime |
authRecord |
avsCode |
avsCodeRaw |
bmlAccountNumber |
cavvResponseCode |
cavvResponseCodeRaw |
creditLine |
cvCode |
cvCodeRaw |
enhancedDataEnabled |
forwardCode |
fundingTotals |
fxQuoteExpirationDateTime |
fxQuoteID |
fxQuoteRate |
fxQuoteType |
merchantAdviceCode |
merchantAdviceCodeRaw |
personalIDCode |
processorCardType |
processorResponse |
reasonCode |
reconciliationID |
referralResponseNumber |
subResponseCode |

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


accountBalance Property

[image]

.NET Framework Class Library
CCAuthReply..::.accountBalance Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountBalance As String
C#
public string accountBalance { get; set; }
Visual C++
public:
property String^ accountBalance {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountBalance();
function set_accountBalance(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
CCAuthReply..::.amount Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


approvedAmount Property

[image]

.NET Framework Class Library
CCAuthReply..::.approvedAmount Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property approvedAmount As String
C#
public string approvedAmount { get; set; }
Visual C++
public:
property String^ approvedAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_approvedAmount();
function set_approvedAmount(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


approvedTerms Property

[image]

.NET Framework Class Library
CCAuthReply..::.approvedTerms Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property approvedTerms As String
C#
public string approvedTerms { get; set; }
Visual C++
public:
property String^ approvedTerms {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_approvedTerms();
function set_approvedTerms(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


authenticationXID Property

[image]

.NET Framework Class Library
CCAuthReply..::.authenticationXID Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authenticationXID As String
C#
public string authenticationXID { get; set; }
Visual C++
public:
property String^ authenticationXID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authenticationXID();
function set_authenticationXID(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


authFactorCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.authFactorCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authFactorCode As String
C#
public string authFactorCode { get; set; }
Visual C++
public:
property String^ authFactorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authFactorCode();
function set_authFactorCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


authorizationCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.authorizationCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationCode As String
C#
public string authorizationCode { get; set; }
Visual C++
public:
property String^ authorizationCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationCode();
function set_authorizationCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


authorizationXID Property

[image]

.NET Framework Class Library
CCAuthReply..::.authorizationXID Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationXID As String
C#
public string authorizationXID { get; set; }
Visual C++
public:
property String^ authorizationXID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationXID();
function set_authorizationXID(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


authorizedDateTime Property

[image]

.NET Framework Class Library
CCAuthReply..::.authorizedDateTime Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizedDateTime As String
C#
public string authorizedDateTime { get; set; }
Visual C++
public:
property String^ authorizedDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizedDateTime();
function set_authorizedDateTime(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


authRecord Property

[image]

.NET Framework Class Library
CCAuthReply..::.authRecord Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authRecord As String
C#
public string authRecord { get; set; }
Visual C++
public:
property String^ authRecord {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authRecord();
function set_authRecord(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


avsCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.avsCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property avsCode As String
C#
public string avsCode { get; set; }
Visual C++
public:
property String^ avsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsCode();
function set_avsCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


avsCodeRaw Property

[image]

.NET Framework Class Library
CCAuthReply..::.avsCodeRaw Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property avsCodeRaw As String
C#
public string avsCodeRaw { get; set; }
Visual C++
public:
property String^ avsCodeRaw {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsCodeRaw();
function set_avsCodeRaw(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


bmlAccountNumber Property

[image]

.NET Framework Class Library
CCAuthReply..::.bmlAccountNumber Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bmlAccountNumber As String
C#
public string bmlAccountNumber { get; set; }
Visual C++
public:
property String^ bmlAccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bmlAccountNumber();
function set_bmlAccountNumber(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


cavvResponseCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.cavvResponseCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cavvResponseCode As String
C#
public string cavvResponseCode { get; set; }
Visual C++
public:
property String^ cavvResponseCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cavvResponseCode();
function set_cavvResponseCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


cavvResponseCodeRaw Property

[image]

.NET Framework Class Library
CCAuthReply..::.cavvResponseCodeRaw Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cavvResponseCodeRaw As String
C#
public string cavvResponseCodeRaw { get; set; }
Visual C++
public:
property String^ cavvResponseCodeRaw {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cavvResponseCodeRaw();
function set_cavvResponseCodeRaw(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


creditLine Property

[image]

.NET Framework Class Library
CCAuthReply..::.creditLine Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property creditLine As String
C#
public string creditLine { get; set; }
Visual C++
public:
property String^ creditLine {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_creditLine();
function set_creditLine(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


cvCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.cvCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cvCode As String
C#
public string cvCode { get; set; }
Visual C++
public:
property String^ cvCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cvCode();
function set_cvCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


cvCodeRaw Property

[image]

.NET Framework Class Library
CCAuthReply..::.cvCodeRaw Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cvCodeRaw As String
C#
public string cvCodeRaw { get; set; }
Visual C++
public:
property String^ cvCodeRaw {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cvCodeRaw();
function set_cvCodeRaw(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


enhancedDataEnabled Property

[image]

.NET Framework Class Library
CCAuthReply..::.enhancedDataEnabled Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property enhancedDataEnabled As String
C#
public string enhancedDataEnabled { get; set; }
Visual C++
public:
property String^ enhancedDataEnabled {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_enhancedDataEnabled();
function set_enhancedDataEnabled(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


forwardCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.forwardCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property forwardCode As String
C#
public string forwardCode { get; set; }
Visual C++
public:
property String^ forwardCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_forwardCode();
function set_forwardCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


fundingTotals Property

[image]

.NET Framework Class Library
CCAuthReply..::.fundingTotals Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fundingTotals As FundingTotals
C#
public FundingTotals fundingTotals { get; set; }
Visual C++
public:
property FundingTotals^ fundingTotals {
    FundingTotals^ get ();
    void set (FundingTotals^ value);
}
JavaScript
function get_fundingTotals();
function set_fundingTotals(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


fxQuoteExpirationDateTime Property

[image]

.NET Framework Class Library
CCAuthReply..::.fxQuoteExpirationDateTime Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteExpirationDateTime As String
C#
public string fxQuoteExpirationDateTime { get; set; }
Visual C++
public:
property String^ fxQuoteExpirationDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteExpirationDateTime();
function set_fxQuoteExpirationDateTime(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


fxQuoteID Property

[image]

.NET Framework Class Library
CCAuthReply..::.fxQuoteID Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteID As String
C#
public string fxQuoteID { get; set; }
Visual C++
public:
property String^ fxQuoteID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteID();
function set_fxQuoteID(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


fxQuoteRate Property

[image]

.NET Framework Class Library
CCAuthReply..::.fxQuoteRate Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteRate As String
C#
public string fxQuoteRate { get; set; }
Visual C++
public:
property String^ fxQuoteRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteRate();
function set_fxQuoteRate(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


fxQuoteType Property

[image]

.NET Framework Class Library
CCAuthReply..::.fxQuoteType Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteType As String
C#
public string fxQuoteType { get; set; }
Visual C++
public:
property String^ fxQuoteType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteType();
function set_fxQuoteType(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


merchantAdviceCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.merchantAdviceCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantAdviceCode As String
C#
public string merchantAdviceCode { get; set; }
Visual C++
public:
property String^ merchantAdviceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantAdviceCode();
function set_merchantAdviceCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


merchantAdviceCodeRaw Property

[image]

.NET Framework Class Library
CCAuthReply..::.merchantAdviceCodeRaw Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantAdviceCodeRaw As String
C#
public string merchantAdviceCodeRaw { get; set; }
Visual C++
public:
property String^ merchantAdviceCodeRaw {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantAdviceCodeRaw();
function set_merchantAdviceCodeRaw(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


personalIDCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.personalIDCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property personalIDCode As String
C#
public string personalIDCode { get; set; }
Visual C++
public:
property String^ personalIDCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_personalIDCode();
function set_personalIDCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


processorCardType Property

[image]

.NET Framework Class Library
CCAuthReply..::.processorCardType Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorCardType As String
C#
public string processorCardType { get; set; }
Visual C++
public:
property String^ processorCardType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorCardType();
function set_processorCardType(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
CCAuthReply..::.processorResponse Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.reasonCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
CCAuthReply..::.reconciliationID Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


referralResponseNumber Property

[image]

.NET Framework Class Library
CCAuthReply..::.referralResponseNumber Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property referralResponseNumber As String
C#
public string referralResponseNumber { get; set; }
Visual C++
public:
property String^ referralResponseNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_referralResponseNumber();
function set_referralResponseNumber(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


subResponseCode Property

[image]

.NET Framework Class Library
CCAuthReply..::.subResponseCode Property
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property subResponseCode As String
C#
public string subResponseCode { get; set; }
Visual C++
public:
property String^ subResponseCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_subResponseCode();
function set_subResponseCode(value);

Remarks

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReply Events

[image] [image]

.NET Framework Class Library
CCAuthReply Events
CCAuthReply Class See Also Send Feedback

The CCAuthReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCAuthReply..::.PropertyChanged Event
CCAuthReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCAuthReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalReply Class

[image]

.NET Framework Class Library
CCAuthReversalReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCAuthReversalReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCAuthReversalReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCAuthReversalReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCAuthReversalReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCAuthReversalReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCAuthReversalReply

See Also

CCAuthReversalReply Members
InSite.Domain.CyberSourceService Namespace


CCAuthReversalReply Members

[image] [image]

.NET Framework Class Library
CCAuthReversalReply Members
CCAuthReversalReply Class Constructors Methods Properties Events See Also Send Feedback

The CCAuthReversalReply type exposes the following members.

Constructors

Name | Description
CCAuthReversalReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
authorizationCode |
forwardCode |
processorResponse |
reasonCode |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalReply Constructor

[image]

.NET Framework Class Library
CCAuthReversalReply Constructor
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCAuthReversalReply()
Visual C++
public:
CCAuthReversalReply()
JavaScript
InSite.Domain.CyberSourceService.CCAuthReversalReply = function();

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalReply Methods

[image] [image]

.NET Framework Class Library
CCAuthReversalReply Methods
CCAuthReversalReply Class See Also Send Feedback

The CCAuthReversalReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCAuthReversalReply..::.RaisePropertyChanged Method
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalReply Properties

[image] [image]

.NET Framework Class Library
CCAuthReversalReply Properties
CCAuthReversalReply Class See Also Send Feedback

The CCAuthReversalReply type exposes the following members.

Properties

Name | Description
amount |
authorizationCode |
forwardCode |
processorResponse |
reasonCode |
requestDateTime |

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
CCAuthReversalReply..::.amount Property
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


authorizationCode Property

[image]

.NET Framework Class Library
CCAuthReversalReply..::.authorizationCode Property
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationCode As String
C#
public string authorizationCode { get; set; }
Visual C++
public:
property String^ authorizationCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationCode();
function set_authorizationCode(value);

Remarks

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


forwardCode Property

[image]

.NET Framework Class Library
CCAuthReversalReply..::.forwardCode Property
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property forwardCode As String
C#
public string forwardCode { get; set; }
Visual C++
public:
property String^ forwardCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_forwardCode();
function set_forwardCode(value);

Remarks

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
CCAuthReversalReply..::.processorResponse Property
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
CCAuthReversalReply..::.reasonCode Property
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
CCAuthReversalReply..::.requestDateTime Property
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalReply Events

[image] [image]

.NET Framework Class Library
CCAuthReversalReply Events
CCAuthReversalReply Class See Also Send Feedback

The CCAuthReversalReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCAuthReversalReply..::.PropertyChanged Event
CCAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalService Class

[image]

.NET Framework Class Library
CCAuthReversalService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCAuthReversalService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCAuthReversalService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCAuthReversalService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCAuthReversalService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCAuthReversalService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCAuthReversalService

See Also

CCAuthReversalService Members
InSite.Domain.CyberSourceService Namespace


CCAuthReversalService Members

[image] [image]

.NET Framework Class Library
CCAuthReversalService Members
CCAuthReversalService Class Constructors Methods Properties Events See Also Send Feedback

The CCAuthReversalService type exposes the following members.

Constructors

Name | Description
CCAuthReversalService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
authRequestID |
authRequestToken |
run |

Events

Name | Description
PropertyChanged |

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalService Constructor

[image]

.NET Framework Class Library
CCAuthReversalService Constructor
CCAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCAuthReversalService()
Visual C++
public:
CCAuthReversalService()
JavaScript
InSite.Domain.CyberSourceService.CCAuthReversalService = function();

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalService Methods

[image] [image]

.NET Framework Class Library
CCAuthReversalService Methods
CCAuthReversalService Class See Also Send Feedback

The CCAuthReversalService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCAuthReversalService..::.RaisePropertyChanged Method
CCAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalService Properties

[image] [image]

.NET Framework Class Library
CCAuthReversalService Properties
CCAuthReversalService Class See Also Send Feedback

The CCAuthReversalService type exposes the following members.

Properties

Name | Description
authRequestID |
authRequestToken |
run |

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


authRequestID Property

[image]

.NET Framework Class Library
CCAuthReversalService..::.authRequestID Property
CCAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authRequestID As String
C#
public string authRequestID { get; set; }
Visual C++
public:
property String^ authRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authRequestID();
function set_authRequestID(value);

Remarks

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


authRequestToken Property

[image]

.NET Framework Class Library
CCAuthReversalService..::.authRequestToken Property
CCAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authRequestToken As String
C#
public string authRequestToken { get; set; }
Visual C++
public:
property String^ authRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authRequestToken();
function set_authRequestToken(value);

Remarks

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
CCAuthReversalService..::.run Property
CCAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAuthReversalService Events

[image] [image]

.NET Framework Class Library
CCAuthReversalService Events
CCAuthReversalService Class See Also Send Feedback

The CCAuthReversalService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCAuthReversalService..::.PropertyChanged Event
CCAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAuthService Class

[image]

.NET Framework Class Library
CCAuthService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCAuthService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCAuthService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCAuthService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCAuthService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCAuthService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCAuthService

See Also

CCAuthService Members
InSite.Domain.CyberSourceService Namespace


CCAuthService Members

[image] [image]

.NET Framework Class Library
CCAuthService Members
CCAuthService Class Constructors Methods Properties Events See Also Send Feedback

The CCAuthService type exposes the following members.

Constructors

Name | Description
CCAuthService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
aggregatorID |
authenticationXID |
authorizationXID |
authType |
avsLevel |
billPayment |
cavv |
cavvAlgorithm |
checksumKey |
commerceIndicator |
eciRaw |
fxQuoteID |
industryDatatype |
linkToRequest |
paresStatus |
reconciliationID |
returnAuthRecord |
run |
splitTenderIndicator |
traceNumber |
verbalAuthCode |
veresEnrolled |
xid |

Events

Name | Description
PropertyChanged |

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


CCAuthService Constructor

[image]

.NET Framework Class Library
CCAuthService Constructor
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCAuthService()
Visual C++
public:
CCAuthService()
JavaScript
InSite.Domain.CyberSourceService.CCAuthService = function();

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


CCAuthService Methods

[image] [image]

.NET Framework Class Library
CCAuthService Methods
CCAuthService Class See Also Send Feedback

The CCAuthService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCAuthService..::.RaisePropertyChanged Method
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


CCAuthService Properties

[image] [image]

.NET Framework Class Library
CCAuthService Properties
CCAuthService Class See Also Send Feedback

The CCAuthService type exposes the following members.

Properties

Name | Description
aggregatorID |
authenticationXID |
authorizationXID |
authType |
avsLevel |
billPayment |
cavv |
cavvAlgorithm |
checksumKey |
commerceIndicator |
eciRaw |
fxQuoteID |
industryDatatype |
linkToRequest |
paresStatus |
reconciliationID |
returnAuthRecord |
run |
splitTenderIndicator |
traceNumber |
verbalAuthCode |
veresEnrolled |
xid |

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


aggregatorID Property

[image]

.NET Framework Class Library
CCAuthService..::.aggregatorID Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property aggregatorID As String
C#
public string aggregatorID { get; set; }
Visual C++
public:
property String^ aggregatorID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_aggregatorID();
function set_aggregatorID(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


authenticationXID Property

[image]

.NET Framework Class Library
CCAuthService..::.authenticationXID Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authenticationXID As String
C#
public string authenticationXID { get; set; }
Visual C++
public:
property String^ authenticationXID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authenticationXID();
function set_authenticationXID(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


authorizationXID Property

[image]

.NET Framework Class Library
CCAuthService..::.authorizationXID Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationXID As String
C#
public string authorizationXID { get; set; }
Visual C++
public:
property String^ authorizationXID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationXID();
function set_authorizationXID(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


authType Property

[image]

.NET Framework Class Library
CCAuthService..::.authType Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authType As String
C#
public string authType { get; set; }
Visual C++
public:
property String^ authType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authType();
function set_authType(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


avsLevel Property

[image]

.NET Framework Class Library
CCAuthService..::.avsLevel Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property avsLevel As String
C#
public string avsLevel { get; set; }
Visual C++
public:
property String^ avsLevel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsLevel();
function set_avsLevel(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


billPayment Property

[image]

.NET Framework Class Library
CCAuthService..::.billPayment Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billPayment As String
C#
public string billPayment { get; set; }
Visual C++
public:
property String^ billPayment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_billPayment();
function set_billPayment(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


cavv Property

[image]

.NET Framework Class Library
CCAuthService..::.cavv Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cavv As String
C#
public string cavv { get; set; }
Visual C++
public:
property String^ cavv {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cavv();
function set_cavv(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


cavvAlgorithm Property

[image]

.NET Framework Class Library
CCAuthService..::.cavvAlgorithm Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cavvAlgorithm As String
C#
public string cavvAlgorithm { get; set; }
Visual C++
public:
property String^ cavvAlgorithm {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cavvAlgorithm();
function set_cavvAlgorithm(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


checksumKey Property

[image]

.NET Framework Class Library
CCAuthService..::.checksumKey Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property checksumKey As String
C#
public string checksumKey { get; set; }
Visual C++
public:
property String^ checksumKey {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_checksumKey();
function set_checksumKey(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


commerceIndicator Property

[image]

.NET Framework Class Library
CCAuthService..::.commerceIndicator Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commerceIndicator As String
C#
public string commerceIndicator { get; set; }
Visual C++
public:
property String^ commerceIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commerceIndicator();
function set_commerceIndicator(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


eciRaw Property

[image]

.NET Framework Class Library
CCAuthService..::.eciRaw Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property eciRaw As String
C#
public string eciRaw { get; set; }
Visual C++
public:
property String^ eciRaw {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_eciRaw();
function set_eciRaw(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


fxQuoteID Property

[image]

.NET Framework Class Library
CCAuthService..::.fxQuoteID Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteID As String
C#
public string fxQuoteID { get; set; }
Visual C++
public:
property String^ fxQuoteID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteID();
function set_fxQuoteID(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


industryDatatype Property

[image]

.NET Framework Class Library
CCAuthService..::.industryDatatype Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property industryDatatype As String
C#
public string industryDatatype { get; set; }
Visual C++
public:
property String^ industryDatatype {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_industryDatatype();
function set_industryDatatype(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


linkToRequest Property

[image]

.NET Framework Class Library
CCAuthService..::.linkToRequest Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property linkToRequest As String
C#
public string linkToRequest { get; set; }
Visual C++
public:
property String^ linkToRequest {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_linkToRequest();
function set_linkToRequest(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


paresStatus Property

[image]

.NET Framework Class Library
CCAuthService..::.paresStatus Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paresStatus As String
C#
public string paresStatus { get; set; }
Visual C++
public:
property String^ paresStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paresStatus();
function set_paresStatus(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
CCAuthService..::.reconciliationID Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


returnAuthRecord Property

[image]

.NET Framework Class Library
CCAuthService..::.returnAuthRecord Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property returnAuthRecord As String
C#
public string returnAuthRecord { get; set; }
Visual C++
public:
property String^ returnAuthRecord {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_returnAuthRecord();
function set_returnAuthRecord(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
CCAuthService..::.run Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


splitTenderIndicator Property

[image]

.NET Framework Class Library
CCAuthService..::.splitTenderIndicator Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property splitTenderIndicator As String
C#
public string splitTenderIndicator { get; set; }
Visual C++
public:
property String^ splitTenderIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_splitTenderIndicator();
function set_splitTenderIndicator(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


traceNumber Property

[image]

.NET Framework Class Library
CCAuthService..::.traceNumber Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property traceNumber As String
C#
public string traceNumber { get; set; }
Visual C++
public:
property String^ traceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_traceNumber();
function set_traceNumber(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


verbalAuthCode Property

[image]

.NET Framework Class Library
CCAuthService..::.verbalAuthCode Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property verbalAuthCode As String
C#
public string verbalAuthCode { get; set; }
Visual C++
public:
property String^ verbalAuthCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_verbalAuthCode();
function set_verbalAuthCode(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


veresEnrolled Property

[image]

.NET Framework Class Library
CCAuthService..::.veresEnrolled Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property veresEnrolled As String
C#
public string veresEnrolled { get; set; }
Visual C++
public:
property String^ veresEnrolled {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_veresEnrolled();
function set_veresEnrolled(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


xid Property

[image]

.NET Framework Class Library
CCAuthService..::.xid Property
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property xid As String
C#
public string xid { get; set; }
Visual C++
public:
property String^ xid {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_xid();
function set_xid(value);

Remarks

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


CCAuthService Events

[image] [image]

.NET Framework Class Library
CCAuthService Events
CCAuthService Class See Also Send Feedback

The CCAuthService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCAuthService..::.PropertyChanged Event
CCAuthService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCAuthService Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalReply Class

[image]

.NET Framework Class Library
CCAutoAuthReversalReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCAutoAuthReversalReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCAutoAuthReversalReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCAutoAuthReversalReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCAutoAuthReversalReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCAutoAuthReversalReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCAutoAuthReversalReply

See Also

CCAutoAuthReversalReply Members
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalReply Members

[image] [image]

.NET Framework Class Library
CCAutoAuthReversalReply Members
CCAutoAuthReversalReply Class Constructors Methods Properties Events See Also Send Feedback

The CCAutoAuthReversalReply type exposes the following members.

Constructors

Name | Description
CCAutoAuthReversalReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
processorResponse |
reasonCode |
result |

Events

Name | Description
PropertyChanged |

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalReply Constructor

[image]

.NET Framework Class Library
CCAutoAuthReversalReply Constructor
CCAutoAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCAutoAuthReversalReply()
Visual C++
public:
CCAutoAuthReversalReply()
JavaScript
InSite.Domain.CyberSourceService.CCAutoAuthReversalReply = function();

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalReply Methods

[image] [image]

.NET Framework Class Library
CCAutoAuthReversalReply Methods
CCAutoAuthReversalReply Class See Also Send Feedback

The CCAutoAuthReversalReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCAutoAuthReversalReply..::.RaisePropertyChanged Method
CCAutoAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalReply Properties

[image] [image]

.NET Framework Class Library
CCAutoAuthReversalReply Properties
CCAutoAuthReversalReply Class See Also Send Feedback

The CCAutoAuthReversalReply type exposes the following members.

Properties

Name | Description
processorResponse |
reasonCode |
result |

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
CCAutoAuthReversalReply..::.processorResponse Property
CCAutoAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
CCAutoAuthReversalReply..::.reasonCode Property
CCAutoAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


result Property

[image]

.NET Framework Class Library
CCAutoAuthReversalReply..::.result Property
CCAutoAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property result As String
C#
public string result { get; set; }
Visual C++
public:
property String^ result {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_result();
function set_result(value);

Remarks

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalReply Events

[image] [image]

.NET Framework Class Library
CCAutoAuthReversalReply Events
CCAutoAuthReversalReply Class See Also Send Feedback

The CCAutoAuthReversalReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCAutoAuthReversalReply..::.PropertyChanged Event
CCAutoAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCAutoAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalService Class

[image]

.NET Framework Class Library
CCAutoAuthReversalService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCAutoAuthReversalService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCAutoAuthReversalService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCAutoAuthReversalService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCAutoAuthReversalService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCAutoAuthReversalService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCAutoAuthReversalService

See Also

CCAutoAuthReversalService Members
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalService Members

[image] [image]

.NET Framework Class Library
CCAutoAuthReversalService Members
CCAutoAuthReversalService Class Constructors Methods Properties Events See Also Send Feedback

The CCAutoAuthReversalService type exposes the following members.

Constructors

Name | Description
CCAutoAuthReversalService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
authAmount |
authCode |
authPaymentServiceData |
authRequestID |
authType |
billAmount |
billPayment |
commerceIndicator |
dateAdded |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalService Constructor

[image]

.NET Framework Class Library
CCAutoAuthReversalService Constructor
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCAutoAuthReversalService()
Visual C++
public:
CCAutoAuthReversalService()
JavaScript
InSite.Domain.CyberSourceService.CCAutoAuthReversalService = function();

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalService Methods

[image] [image]

.NET Framework Class Library
CCAutoAuthReversalService Methods
CCAutoAuthReversalService Class See Also Send Feedback

The CCAutoAuthReversalService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.RaisePropertyChanged Method
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalService Properties

[image] [image]

.NET Framework Class Library
CCAutoAuthReversalService Properties
CCAutoAuthReversalService Class See Also Send Feedback

The CCAutoAuthReversalService type exposes the following members.

Properties

Name | Description
authAmount |
authCode |
authPaymentServiceData |
authRequestID |
authType |
billAmount |
billPayment |
commerceIndicator |
dateAdded |
reconciliationID |
run |

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


authAmount Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.authAmount Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authAmount As String
C#
public string authAmount { get; set; }
Visual C++
public:
property String^ authAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authAmount();
function set_authAmount(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


authCode Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.authCode Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authCode As String
C#
public string authCode { get; set; }
Visual C++
public:
property String^ authCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authCode();
function set_authCode(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


authPaymentServiceData Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.authPaymentServiceData Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authPaymentServiceData As String
C#
public string authPaymentServiceData { get; set; }
Visual C++
public:
property String^ authPaymentServiceData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authPaymentServiceData();
function set_authPaymentServiceData(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


authRequestID Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.authRequestID Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authRequestID As String
C#
public string authRequestID { get; set; }
Visual C++
public:
property String^ authRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authRequestID();
function set_authRequestID(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


authType Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.authType Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authType As String
C#
public string authType { get; set; }
Visual C++
public:
property String^ authType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authType();
function set_authType(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


billAmount Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.billAmount Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billAmount As String
C#
public string billAmount { get; set; }
Visual C++
public:
property String^ billAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_billAmount();
function set_billAmount(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


billPayment Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.billPayment Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billPayment As String
C#
public string billPayment { get; set; }
Visual C++
public:
property String^ billPayment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_billPayment();
function set_billPayment(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


commerceIndicator Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.commerceIndicator Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commerceIndicator As String
C#
public string commerceIndicator { get; set; }
Visual C++
public:
property String^ commerceIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commerceIndicator();
function set_commerceIndicator(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


dateAdded Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.dateAdded Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dateAdded As String
C#
public string dateAdded { get; set; }
Visual C++
public:
property String^ dateAdded {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dateAdded();
function set_dateAdded(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.reconciliationID Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.run Property
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCAutoAuthReversalService Events

[image] [image]

.NET Framework Class Library
CCAutoAuthReversalService Events
CCAutoAuthReversalService Class See Also Send Feedback

The CCAutoAuthReversalService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCAutoAuthReversalService..::.PropertyChanged Event
CCAutoAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCAutoAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


CCCaptureReply Class

[image]

.NET Framework Class Library
CCCaptureReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCCaptureReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCCaptureReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCCaptureReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCCaptureReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCCaptureReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCCaptureReply

See Also

CCCaptureReply Members
InSite.Domain.CyberSourceService Namespace


CCCaptureReply Members

[image] [image]

.NET Framework Class Library
CCCaptureReply Members
CCCaptureReply Class Constructors Methods Properties Events See Also Send Feedback

The CCCaptureReply type exposes the following members.

Constructors

Name | Description
CCCaptureReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
enhancedDataEnabled |
fundingTotals |
fxQuoteExpirationDateTime |
fxQuoteID |
fxQuoteRate |
fxQuoteType |
purchasingLevel3Enabled |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


CCCaptureReply Constructor

[image]

.NET Framework Class Library
CCCaptureReply Constructor
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCCaptureReply()
Visual C++
public:
CCCaptureReply()
JavaScript
InSite.Domain.CyberSourceService.CCCaptureReply = function();

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


CCCaptureReply Methods

[image] [image]

.NET Framework Class Library
CCCaptureReply Methods
CCCaptureReply Class See Also Send Feedback

The CCCaptureReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCCaptureReply..::.RaisePropertyChanged Method
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


CCCaptureReply Properties

[image] [image]

.NET Framework Class Library
CCCaptureReply Properties
CCCaptureReply Class See Also Send Feedback

The CCCaptureReply type exposes the following members.

Properties

Name | Description
amount |
enhancedDataEnabled |
fundingTotals |
fxQuoteExpirationDateTime |
fxQuoteID |
fxQuoteRate |
fxQuoteType |
purchasingLevel3Enabled |
reasonCode |
reconciliationID |
requestDateTime |

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
CCCaptureReply..::.amount Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


enhancedDataEnabled Property

[image]

.NET Framework Class Library
CCCaptureReply..::.enhancedDataEnabled Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property enhancedDataEnabled As String
C#
public string enhancedDataEnabled { get; set; }
Visual C++
public:
property String^ enhancedDataEnabled {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_enhancedDataEnabled();
function set_enhancedDataEnabled(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


fundingTotals Property

[image]

.NET Framework Class Library
CCCaptureReply..::.fundingTotals Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fundingTotals As FundingTotals
C#
public FundingTotals fundingTotals { get; set; }
Visual C++
public:
property FundingTotals^ fundingTotals {
    FundingTotals^ get ();
    void set (FundingTotals^ value);
}
JavaScript
function get_fundingTotals();
function set_fundingTotals(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


fxQuoteExpirationDateTime Property

[image]

.NET Framework Class Library
CCCaptureReply..::.fxQuoteExpirationDateTime Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteExpirationDateTime As String
C#
public string fxQuoteExpirationDateTime { get; set; }
Visual C++
public:
property String^ fxQuoteExpirationDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteExpirationDateTime();
function set_fxQuoteExpirationDateTime(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


fxQuoteID Property

[image]

.NET Framework Class Library
CCCaptureReply..::.fxQuoteID Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteID As String
C#
public string fxQuoteID { get; set; }
Visual C++
public:
property String^ fxQuoteID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteID();
function set_fxQuoteID(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


fxQuoteRate Property

[image]

.NET Framework Class Library
CCCaptureReply..::.fxQuoteRate Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteRate As String
C#
public string fxQuoteRate { get; set; }
Visual C++
public:
property String^ fxQuoteRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteRate();
function set_fxQuoteRate(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


fxQuoteType Property

[image]

.NET Framework Class Library
CCCaptureReply..::.fxQuoteType Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxQuoteType As String
C#
public string fxQuoteType { get; set; }
Visual C++
public:
property String^ fxQuoteType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fxQuoteType();
function set_fxQuoteType(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


purchasingLevel3Enabled Property

[image]

.NET Framework Class Library
CCCaptureReply..::.purchasingLevel3Enabled Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchasingLevel3Enabled As String
C#
public string purchasingLevel3Enabled { get; set; }
Visual C++
public:
property String^ purchasingLevel3Enabled {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchasingLevel3Enabled();
function set_purchasingLevel3Enabled(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
CCCaptureReply..::.reasonCode Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
CCCaptureReply..::.reconciliationID Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
CCCaptureReply..::.requestDateTime Property
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


CCCaptureReply Events

[image] [image]

.NET Framework Class Library
CCCaptureReply Events
CCCaptureReply Class See Also Send Feedback

The CCCaptureReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCCaptureReply..::.PropertyChanged Event
CCCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCCaptureReply Class
InSite.Domain.CyberSourceService Namespace


CCCaptureService Class

[image]

.NET Framework Class Library
CCCaptureService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCCaptureService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCCaptureService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCCaptureService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCCaptureService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCCaptureService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCCaptureService

See Also

CCCaptureService Members
InSite.Domain.CyberSourceService Namespace


CCCaptureService Members

[image] [image]

.NET Framework Class Library
CCCaptureService Members
CCCaptureService Class Constructors Methods Properties Events See Also Send Feedback

The CCCaptureService type exposes the following members.

Constructors

Name | Description
CCCaptureService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
authRequestID |
authRequestToken |
authType |
checksumKey |
industryDatatype |
merchantReceiptNumber |
partialPaymentID |
posData |
purchasingLevel |
reconciliationID |
run |
transactionID |
verbalAuthCode |

Events

Name | Description
PropertyChanged |

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


CCCaptureService Constructor

[image]

.NET Framework Class Library
CCCaptureService Constructor
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCCaptureService()
Visual C++
public:
CCCaptureService()
JavaScript
InSite.Domain.CyberSourceService.CCCaptureService = function();

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


CCCaptureService Methods

[image] [image]

.NET Framework Class Library
CCCaptureService Methods
CCCaptureService Class See Also Send Feedback

The CCCaptureService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCCaptureService..::.RaisePropertyChanged Method
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


CCCaptureService Properties

[image] [image]

.NET Framework Class Library
CCCaptureService Properties
CCCaptureService Class See Also Send Feedback

The CCCaptureService type exposes the following members.

Properties

Name | Description
authRequestID |
authRequestToken |
authType |
checksumKey |
industryDatatype |
merchantReceiptNumber |
partialPaymentID |
posData |
purchasingLevel |
reconciliationID |
run |
transactionID |
verbalAuthCode |

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


authRequestID Property

[image]

.NET Framework Class Library
CCCaptureService..::.authRequestID Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authRequestID As String
C#
public string authRequestID { get; set; }
Visual C++
public:
property String^ authRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authRequestID();
function set_authRequestID(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


authRequestToken Property

[image]

.NET Framework Class Library
CCCaptureService..::.authRequestToken Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authRequestToken As String
C#
public string authRequestToken { get; set; }
Visual C++
public:
property String^ authRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authRequestToken();
function set_authRequestToken(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


authType Property

[image]

.NET Framework Class Library
CCCaptureService..::.authType Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authType As String
C#
public string authType { get; set; }
Visual C++
public:
property String^ authType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authType();
function set_authType(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


checksumKey Property

[image]

.NET Framework Class Library
CCCaptureService..::.checksumKey Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property checksumKey As String
C#
public string checksumKey { get; set; }
Visual C++
public:
property String^ checksumKey {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_checksumKey();
function set_checksumKey(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


industryDatatype Property

[image]

.NET Framework Class Library
CCCaptureService..::.industryDatatype Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property industryDatatype As String
C#
public string industryDatatype { get; set; }
Visual C++
public:
property String^ industryDatatype {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_industryDatatype();
function set_industryDatatype(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


merchantReceiptNumber Property

[image]

.NET Framework Class Library
CCCaptureService..::.merchantReceiptNumber Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantReceiptNumber As String
C#
public string merchantReceiptNumber { get; set; }
Visual C++
public:
property String^ merchantReceiptNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantReceiptNumber();
function set_merchantReceiptNumber(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


partialPaymentID Property

[image]

.NET Framework Class Library
CCCaptureService..::.partialPaymentID Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property partialPaymentID As String
C#
public string partialPaymentID { get; set; }
Visual C++
public:
property String^ partialPaymentID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_partialPaymentID();
function set_partialPaymentID(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


posData Property

[image]

.NET Framework Class Library
CCCaptureService..::.posData Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property posData As String
C#
public string posData { get; set; }
Visual C++
public:
property String^ posData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_posData();
function set_posData(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


purchasingLevel Property

[image]

.NET Framework Class Library
CCCaptureService..::.purchasingLevel Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchasingLevel As String
C#
public string purchasingLevel { get; set; }
Visual C++
public:
property String^ purchasingLevel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchasingLevel();
function set_purchasingLevel(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
CCCaptureService..::.reconciliationID Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
CCCaptureService..::.run Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


transactionID Property

[image]

.NET Framework Class Library
CCCaptureService..::.transactionID Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionID As String
C#
public string transactionID { get; set; }
Visual C++
public:
property String^ transactionID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionID();
function set_transactionID(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


verbalAuthCode Property

[image]

.NET Framework Class Library
CCCaptureService..::.verbalAuthCode Property
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property verbalAuthCode As String
C#
public string verbalAuthCode { get; set; }
Visual C++
public:
property String^ verbalAuthCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_verbalAuthCode();
function set_verbalAuthCode(value);

Remarks

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


CCCaptureService Events

[image] [image]

.NET Framework Class Library
CCCaptureService Events
CCCaptureService Class See Also Send Feedback

The CCCaptureService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCCaptureService..::.PropertyChanged Event
CCCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCCaptureService Class
InSite.Domain.CyberSourceService Namespace


CCCreditReply Class

[image]

.NET Framework Class Library
CCCreditReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCCreditReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCCreditReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCCreditReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCCreditReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCCreditReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCCreditReply

See Also

CCCreditReply Members
InSite.Domain.CyberSourceService Namespace


CCCreditReply Members

[image] [image]

.NET Framework Class Library
CCCreditReply Members
CCCreditReply Class Constructors Methods Properties Events See Also Send Feedback

The CCCreditReply type exposes the following members.

Constructors

Name | Description
CCCreditReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
authorizationXID |
enhancedDataEnabled |
forwardCode |
purchasingLevel3Enabled |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


CCCreditReply Constructor

[image]

.NET Framework Class Library
CCCreditReply Constructor
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCCreditReply()
Visual C++
public:
CCCreditReply()
JavaScript
InSite.Domain.CyberSourceService.CCCreditReply = function();

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


CCCreditReply Methods

[image] [image]

.NET Framework Class Library
CCCreditReply Methods
CCCreditReply Class See Also Send Feedback

The CCCreditReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCCreditReply..::.RaisePropertyChanged Method
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


CCCreditReply Properties

[image] [image]

.NET Framework Class Library
CCCreditReply Properties
CCCreditReply Class See Also Send Feedback

The CCCreditReply type exposes the following members.

Properties

Name | Description
amount |
authorizationXID |
enhancedDataEnabled |
forwardCode |
purchasingLevel3Enabled |
reasonCode |
reconciliationID |
requestDateTime |

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
CCCreditReply..::.amount Property
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


authorizationXID Property

[image]

.NET Framework Class Library
CCCreditReply..::.authorizationXID Property
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationXID As String
C#
public string authorizationXID { get; set; }
Visual C++
public:
property String^ authorizationXID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationXID();
function set_authorizationXID(value);

Remarks

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


enhancedDataEnabled Property

[image]

.NET Framework Class Library
CCCreditReply..::.enhancedDataEnabled Property
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property enhancedDataEnabled As String
C#
public string enhancedDataEnabled { get; set; }
Visual C++
public:
property String^ enhancedDataEnabled {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_enhancedDataEnabled();
function set_enhancedDataEnabled(value);

Remarks

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


forwardCode Property

[image]

.NET Framework Class Library
CCCreditReply..::.forwardCode Property
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property forwardCode As String
C#
public string forwardCode { get; set; }
Visual C++
public:
property String^ forwardCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_forwardCode();
function set_forwardCode(value);

Remarks

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


purchasingLevel3Enabled Property

[image]

.NET Framework Class Library
CCCreditReply..::.purchasingLevel3Enabled Property
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchasingLevel3Enabled As String
C#
public string purchasingLevel3Enabled { get; set; }
Visual C++
public:
property String^ purchasingLevel3Enabled {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchasingLevel3Enabled();
function set_purchasingLevel3Enabled(value);

Remarks

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
CCCreditReply..::.reasonCode Property
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
CCCreditReply..::.reconciliationID Property
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
CCCreditReply..::.requestDateTime Property
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


CCCreditReply Events

[image] [image]

.NET Framework Class Library
CCCreditReply Events
CCCreditReply Class See Also Send Feedback

The CCCreditReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCCreditReply..::.PropertyChanged Event
CCCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCCreditReply Class
InSite.Domain.CyberSourceService Namespace


CCCreditService Class

[image]

.NET Framework Class Library
CCCreditService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCCreditService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCCreditService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCCreditService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCCreditService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCCreditService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCCreditService

See Also

CCCreditService Members
InSite.Domain.CyberSourceService Namespace


CCCreditService Members

[image] [image]

.NET Framework Class Library
CCCreditService Members
CCCreditService Class Constructors Methods Properties Events See Also Send Feedback

The CCCreditService type exposes the following members.

Constructors

Name | Description
CCCreditService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
aggregatorID |
authCode |
authorizationXID |
billPayment |
captureRequestID |
captureRequestToken |
checksumKey |
commerceIndicator |
industryDatatype |
merchantReceiptNumber |
occurrenceNumber |
partialPaymentID |
purchasingLevel |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


CCCreditService Constructor

[image]

.NET Framework Class Library
CCCreditService Constructor
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCCreditService()
Visual C++
public:
CCCreditService()
JavaScript
InSite.Domain.CyberSourceService.CCCreditService = function();

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


CCCreditService Methods

[image] [image]

.NET Framework Class Library
CCCreditService Methods
CCCreditService Class See Also Send Feedback

The CCCreditService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCCreditService..::.RaisePropertyChanged Method
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


CCCreditService Properties

[image] [image]

.NET Framework Class Library
CCCreditService Properties
CCCreditService Class See Also Send Feedback

The CCCreditService type exposes the following members.

Properties

Name | Description
aggregatorID |
authCode |
authorizationXID |
billPayment |
captureRequestID |
captureRequestToken |
checksumKey |
commerceIndicator |
industryDatatype |
merchantReceiptNumber |
occurrenceNumber |
partialPaymentID |
purchasingLevel |
reconciliationID |
run |

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


aggregatorID Property

[image]

.NET Framework Class Library
CCCreditService..::.aggregatorID Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property aggregatorID As String
C#
public string aggregatorID { get; set; }
Visual C++
public:
property String^ aggregatorID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_aggregatorID();
function set_aggregatorID(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


authCode Property

[image]

.NET Framework Class Library
CCCreditService..::.authCode Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authCode As String
C#
public string authCode { get; set; }
Visual C++
public:
property String^ authCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authCode();
function set_authCode(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


authorizationXID Property

[image]

.NET Framework Class Library
CCCreditService..::.authorizationXID Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationXID As String
C#
public string authorizationXID { get; set; }
Visual C++
public:
property String^ authorizationXID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationXID();
function set_authorizationXID(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


billPayment Property

[image]

.NET Framework Class Library
CCCreditService..::.billPayment Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billPayment As String
C#
public string billPayment { get; set; }
Visual C++
public:
property String^ billPayment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_billPayment();
function set_billPayment(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


captureRequestID Property

[image]

.NET Framework Class Library
CCCreditService..::.captureRequestID Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property captureRequestID As String
C#
public string captureRequestID { get; set; }
Visual C++
public:
property String^ captureRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_captureRequestID();
function set_captureRequestID(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


captureRequestToken Property

[image]

.NET Framework Class Library
CCCreditService..::.captureRequestToken Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property captureRequestToken As String
C#
public string captureRequestToken { get; set; }
Visual C++
public:
property String^ captureRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_captureRequestToken();
function set_captureRequestToken(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


checksumKey Property

[image]

.NET Framework Class Library
CCCreditService..::.checksumKey Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property checksumKey As String
C#
public string checksumKey { get; set; }
Visual C++
public:
property String^ checksumKey {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_checksumKey();
function set_checksumKey(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


commerceIndicator Property

[image]

.NET Framework Class Library
CCCreditService..::.commerceIndicator Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commerceIndicator As String
C#
public string commerceIndicator { get; set; }
Visual C++
public:
property String^ commerceIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commerceIndicator();
function set_commerceIndicator(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


industryDatatype Property

[image]

.NET Framework Class Library
CCCreditService..::.industryDatatype Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property industryDatatype As String
C#
public string industryDatatype { get; set; }
Visual C++
public:
property String^ industryDatatype {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_industryDatatype();
function set_industryDatatype(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


merchantReceiptNumber Property

[image]

.NET Framework Class Library
CCCreditService..::.merchantReceiptNumber Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantReceiptNumber As String
C#
public string merchantReceiptNumber { get; set; }
Visual C++
public:
property String^ merchantReceiptNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantReceiptNumber();
function set_merchantReceiptNumber(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


occurrenceNumber Property

[image]

.NET Framework Class Library
CCCreditService..::.occurrenceNumber Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property occurrenceNumber As String
C#
public string occurrenceNumber { get; set; }
Visual C++
public:
property String^ occurrenceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_occurrenceNumber();
function set_occurrenceNumber(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


partialPaymentID Property

[image]

.NET Framework Class Library
CCCreditService..::.partialPaymentID Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property partialPaymentID As String
C#
public string partialPaymentID { get; set; }
Visual C++
public:
property String^ partialPaymentID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_partialPaymentID();
function set_partialPaymentID(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


purchasingLevel Property

[image]

.NET Framework Class Library
CCCreditService..::.purchasingLevel Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchasingLevel As String
C#
public string purchasingLevel { get; set; }
Visual C++
public:
property String^ purchasingLevel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchasingLevel();
function set_purchasingLevel(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
CCCreditService..::.reconciliationID Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
CCCreditService..::.run Property
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


CCCreditService Events

[image] [image]

.NET Framework Class Library
CCCreditService Events
CCCreditService Class See Also Send Feedback

The CCCreditService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCCreditService..::.PropertyChanged Event
CCCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCCreditService Class
InSite.Domain.CyberSourceService Namespace


CCDCCReply Class

[image]

.NET Framework Class Library
CCDCCReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCDCCReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCDCCReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCDCCReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCDCCReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCDCCReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCDCCReply

See Also

CCDCCReply Members
InSite.Domain.CyberSourceService Namespace


CCDCCReply Members

[image] [image]

.NET Framework Class Library
CCDCCReply Members
CCDCCReply Class Constructors Methods Properties Events See Also Send Feedback

The CCDCCReply type exposes the following members.

Constructors

Name | Description
CCDCCReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
dccSupported |
marginRatePercentage |
reasonCode |
validHours |

Events

Name | Description
PropertyChanged |

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


CCDCCReply Constructor

[image]

.NET Framework Class Library
CCDCCReply Constructor
CCDCCReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCDCCReply()
Visual C++
public:
CCDCCReply()
JavaScript
InSite.Domain.CyberSourceService.CCDCCReply = function();

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


CCDCCReply Methods

[image] [image]

.NET Framework Class Library
CCDCCReply Methods
CCDCCReply Class See Also Send Feedback

The CCDCCReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCDCCReply..::.RaisePropertyChanged Method
CCDCCReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


CCDCCReply Properties

[image] [image]

.NET Framework Class Library
CCDCCReply Properties
CCDCCReply Class See Also Send Feedback

The CCDCCReply type exposes the following members.

Properties

Name | Description
dccSupported |
marginRatePercentage |
reasonCode |
validHours |

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


dccSupported Property

[image]

.NET Framework Class Library
CCDCCReply..::.dccSupported Property
CCDCCReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dccSupported As String
C#
public string dccSupported { get; set; }
Visual C++
public:
property String^ dccSupported {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dccSupported();
function set_dccSupported(value);

Remarks

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


marginRatePercentage Property

[image]

.NET Framework Class Library
CCDCCReply..::.marginRatePercentage Property
CCDCCReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property marginRatePercentage As String
C#
public string marginRatePercentage { get; set; }
Visual C++
public:
property String^ marginRatePercentage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_marginRatePercentage();
function set_marginRatePercentage(value);

Remarks

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
CCDCCReply..::.reasonCode Property
CCDCCReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


validHours Property

[image]

.NET Framework Class Library
CCDCCReply..::.validHours Property
CCDCCReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property validHours As String
C#
public string validHours { get; set; }
Visual C++
public:
property String^ validHours {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_validHours();
function set_validHours(value);

Remarks

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


CCDCCReply Events

[image] [image]

.NET Framework Class Library
CCDCCReply Events
CCDCCReply Class See Also Send Feedback

The CCDCCReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCDCCReply..::.PropertyChanged Event
CCDCCReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCDCCReply Class
InSite.Domain.CyberSourceService Namespace


CCDCCService Class

[image]

.NET Framework Class Library
CCDCCService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class CCDCCService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class CCDCCService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class CCDCCService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.CCDCCService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.CCDCCService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.CCDCCService

See Also

CCDCCService Members
InSite.Domain.CyberSourceService Namespace


CCDCCService Members

[image] [image]

.NET Framework Class Library
CCDCCService Members
CCDCCService Class Constructors Methods Properties Events See Also Send Feedback

The CCDCCService type exposes the following members.

Constructors

Name | Description
CCDCCService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |

Events

Name | Description
PropertyChanged |

See Also

CCDCCService Class
InSite.Domain.CyberSourceService Namespace


CCDCCService Constructor

[image]

.NET Framework Class Library
CCDCCService Constructor
CCDCCService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CCDCCService()
Visual C++
public:
CCDCCService()
JavaScript
InSite.Domain.CyberSourceService.CCDCCService = function();

See Also

CCDCCService Class
InSite.Domain.CyberSourceService Namespace


CCDCCService Methods

[image] [image]

.NET Framework Class Library
CCDCCService Methods
CCDCCService Class See Also Send Feedback

The CCDCCService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCDCCService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
CCDCCService..::.RaisePropertyChanged Method
CCDCCService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

CCDCCService Class
InSite.Domain.CyberSourceService Namespace


CCDCCService Properties

[image] [image]

.NET Framework Class Library
CCDCCService Properties
CCDCCService Class See Also Send Feedback

The CCDCCService type exposes the following members.

Properties

Name | Description
run |

See Also

CCDCCService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
CCDCCService..::.run Property
CCDCCService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

CCDCCService Class
InSite.Domain.CyberSourceService Namespace


CCDCCService Events

[image] [image]

.NET Framework Class Library
CCDCCService Events
CCDCCService Class See Also Send Feedback

The CCDCCService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CCDCCService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CCDCCService..::.PropertyChanged Event
CCDCCService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CCDCCService Class
InSite.Domain.CyberSourceService Namespace


Check Class

[image]

.NET Framework Class Library
Check Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Check _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Check : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Check : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Check = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Check',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Check

See Also

Check Members
InSite.Domain.CyberSourceService Namespace


Check Members

[image] [image]

.NET Framework Class Library
Check Members
Check Class Constructors Methods Properties Events See Also Send Feedback

The Check type exposes the following members.

Constructors

Name | Description
Check |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
accountEncoderID |
accountNumber |
accountType |
bankTransitNumber |
checkNumber |
fullName |
secCode |

Events

Name | Description
PropertyChanged |

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


Check Constructor

[image]

.NET Framework Class Library
Check Constructor
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Check()
Visual C++
public:
Check()
JavaScript
InSite.Domain.CyberSourceService.Check = function();

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


Check Methods

[image] [image]

.NET Framework Class Library
Check Methods
Check Class See Also Send Feedback

The Check type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Check..::.RaisePropertyChanged Method
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


Check Properties

[image] [image]

.NET Framework Class Library
Check Properties
Check Class See Also Send Feedback

The Check type exposes the following members.

Properties

Name | Description
accountEncoderID |
accountNumber |
accountType |
bankTransitNumber |
checkNumber |
fullName |
secCode |

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


accountEncoderID Property

[image]

.NET Framework Class Library
Check..::.accountEncoderID Property
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountEncoderID As String
C#
public string accountEncoderID { get; set; }
Visual C++
public:
property String^ accountEncoderID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountEncoderID();
function set_accountEncoderID(value);

Remarks

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


accountNumber Property

[image]

.NET Framework Class Library
Check..::.accountNumber Property
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountNumber As String
C#
public string accountNumber { get; set; }
Visual C++
public:
property String^ accountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


accountType Property

[image]

.NET Framework Class Library
Check..::.accountType Property
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountType As String
C#
public string accountType { get; set; }
Visual C++
public:
property String^ accountType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountType();
function set_accountType(value);

Remarks

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


bankTransitNumber Property

[image]

.NET Framework Class Library
Check..::.bankTransitNumber Property
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransitNumber As String
C#
public string bankTransitNumber { get; set; }
Visual C++
public:
property String^ bankTransitNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankTransitNumber();
function set_bankTransitNumber(value);

Remarks

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


checkNumber Property

[image]

.NET Framework Class Library
Check..::.checkNumber Property
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property checkNumber As String
C#
public string checkNumber { get; set; }
Visual C++
public:
property String^ checkNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_checkNumber();
function set_checkNumber(value);

Remarks

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


fullName Property

[image]

.NET Framework Class Library
Check..::.fullName Property
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fullName As String
C#
public string fullName { get; set; }
Visual C++
public:
property String^ fullName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fullName();
function set_fullName(value);

Remarks

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


secCode Property

[image]

.NET Framework Class Library
Check..::.secCode Property
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property secCode As String
C#
public string secCode { get; set; }
Visual C++
public:
property String^ secCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_secCode();
function set_secCode(value);

Remarks

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


Check Events

[image] [image]

.NET Framework Class Library
Check Events
Check Class See Also Send Feedback

The Check type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Check..::.PropertyChanged Event
Check Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Check Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentReply Class

[image]

.NET Framework Class Library
ChinaPaymentReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ChinaPaymentReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ChinaPaymentReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ChinaPaymentReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ChinaPaymentReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ChinaPaymentReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ChinaPaymentReply

See Also

ChinaPaymentReply Members
InSite.Domain.CyberSourceService Namespace


ChinaPaymentReply Members

[image] [image]

.NET Framework Class Library
ChinaPaymentReply Members
ChinaPaymentReply Class Constructors Methods Properties Events See Also Send Feedback

The ChinaPaymentReply type exposes the following members.

Constructors

Name | Description
ChinaPaymentReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
currency |
formData |
reasonCode |
reconciliationID |
requestDateTime |
verifyFailure |
verifyInProcess |
verifySuccess |

Events

Name | Description
PropertyChanged |

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentReply Constructor

[image]

.NET Framework Class Library
ChinaPaymentReply Constructor
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChinaPaymentReply()
Visual C++
public:
ChinaPaymentReply()
JavaScript
InSite.Domain.CyberSourceService.ChinaPaymentReply = function();

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentReply Methods

[image] [image]

.NET Framework Class Library
ChinaPaymentReply Methods
ChinaPaymentReply Class See Also Send Feedback

The ChinaPaymentReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ChinaPaymentReply..::.RaisePropertyChanged Method
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentReply Properties

[image] [image]

.NET Framework Class Library
ChinaPaymentReply Properties
ChinaPaymentReply Class See Also Send Feedback

The ChinaPaymentReply type exposes the following members.

Properties

Name | Description
amount |
currency |
formData |
reasonCode |
reconciliationID |
requestDateTime |
verifyFailure |
verifyInProcess |
verifySuccess |

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.amount Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.currency Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


formData Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.formData Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property formData As String
C#
public string formData { get; set; }
Visual C++
public:
property String^ formData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_formData();
function set_formData(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.reasonCode Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.reconciliationID Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.requestDateTime Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


verifyFailure Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.verifyFailure Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property verifyFailure As String
C#
public string verifyFailure { get; set; }
Visual C++
public:
property String^ verifyFailure {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_verifyFailure();
function set_verifyFailure(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


verifyInProcess Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.verifyInProcess Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property verifyInProcess As String
C#
public string verifyInProcess { get; set; }
Visual C++
public:
property String^ verifyInProcess {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_verifyInProcess();
function set_verifyInProcess(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


verifySuccess Property

[image]

.NET Framework Class Library
ChinaPaymentReply..::.verifySuccess Property
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property verifySuccess As String
C#
public string verifySuccess { get; set; }
Visual C++
public:
property String^ verifySuccess {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_verifySuccess();
function set_verifySuccess(value);

Remarks

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentReply Events

[image] [image]

.NET Framework Class Library
ChinaPaymentReply Events
ChinaPaymentReply Class See Also Send Feedback

The ChinaPaymentReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ChinaPaymentReply..::.PropertyChanged Event
ChinaPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ChinaPaymentReply Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentService Class

[image]

.NET Framework Class Library
ChinaPaymentService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ChinaPaymentService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ChinaPaymentService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ChinaPaymentService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ChinaPaymentService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ChinaPaymentService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ChinaPaymentService

See Also

ChinaPaymentService Members
InSite.Domain.CyberSourceService Namespace


ChinaPaymentService Members

[image] [image]

.NET Framework Class Library
ChinaPaymentService Members
ChinaPaymentService Class Constructors Methods Properties Events See Also Send Feedback

The ChinaPaymentService type exposes the following members.

Constructors

Name | Description
ChinaPaymentService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
paymentMode |
returnURL |
run |

Events

Name | Description
PropertyChanged |

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentService Constructor

[image]

.NET Framework Class Library
ChinaPaymentService Constructor
ChinaPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChinaPaymentService()
Visual C++
public:
ChinaPaymentService()
JavaScript
InSite.Domain.CyberSourceService.ChinaPaymentService = function();

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentService Methods

[image] [image]

.NET Framework Class Library
ChinaPaymentService Methods
ChinaPaymentService Class See Also Send Feedback

The ChinaPaymentService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ChinaPaymentService..::.RaisePropertyChanged Method
ChinaPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentService Properties

[image] [image]

.NET Framework Class Library
ChinaPaymentService Properties
ChinaPaymentService Class See Also Send Feedback

The ChinaPaymentService type exposes the following members.

Properties

Name | Description
paymentMode |
returnURL |
run |

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


paymentMode Property

[image]

.NET Framework Class Library
ChinaPaymentService..::.paymentMode Property
ChinaPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentMode As String
C#
public string paymentMode { get; set; }
Visual C++
public:
property String^ paymentMode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentMode();
function set_paymentMode(value);

Remarks

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


returnURL Property

[image]

.NET Framework Class Library
ChinaPaymentService..::.returnURL Property
ChinaPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property returnURL As String
C#
public string returnURL { get; set; }
Visual C++
public:
property String^ returnURL {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_returnURL();
function set_returnURL(value);

Remarks

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
ChinaPaymentService..::.run Property
ChinaPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


ChinaPaymentService Events

[image] [image]

.NET Framework Class Library
ChinaPaymentService Events
ChinaPaymentService Class See Also Send Feedback

The ChinaPaymentService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ChinaPaymentService..::.PropertyChanged Event
ChinaPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ChinaPaymentService Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundReply Class

[image]

.NET Framework Class Library
ChinaRefundReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ChinaRefundReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ChinaRefundReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ChinaRefundReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ChinaRefundReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ChinaRefundReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ChinaRefundReply

See Also

ChinaRefundReply Members
InSite.Domain.CyberSourceService Namespace


ChinaRefundReply Members

[image] [image]

.NET Framework Class Library
ChinaRefundReply Members
ChinaRefundReply Class Constructors Methods Properties Events See Also Send Feedback

The ChinaRefundReply type exposes the following members.

Constructors

Name | Description
ChinaRefundReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
currency |
reasonCode |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundReply Constructor

[image]

.NET Framework Class Library
ChinaRefundReply Constructor
ChinaRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChinaRefundReply()
Visual C++
public:
ChinaRefundReply()
JavaScript
InSite.Domain.CyberSourceService.ChinaRefundReply = function();

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundReply Methods

[image] [image]

.NET Framework Class Library
ChinaRefundReply Methods
ChinaRefundReply Class See Also Send Feedback

The ChinaRefundReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ChinaRefundReply..::.RaisePropertyChanged Method
ChinaRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundReply Properties

[image] [image]

.NET Framework Class Library
ChinaRefundReply Properties
ChinaRefundReply Class See Also Send Feedback

The ChinaRefundReply type exposes the following members.

Properties

Name | Description
amount |
currency |
reasonCode |
requestDateTime |

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
ChinaRefundReply..::.amount Property
ChinaRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
ChinaRefundReply..::.currency Property
ChinaRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
ChinaRefundReply..::.reasonCode Property
ChinaRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
ChinaRefundReply..::.requestDateTime Property
ChinaRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundReply Events

[image] [image]

.NET Framework Class Library
ChinaRefundReply Events
ChinaRefundReply Class See Also Send Feedback

The ChinaRefundReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ChinaRefundReply..::.PropertyChanged Event
ChinaRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ChinaRefundReply Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundService Class

[image]

.NET Framework Class Library
ChinaRefundService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ChinaRefundService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ChinaRefundService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ChinaRefundService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ChinaRefundService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ChinaRefundService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ChinaRefundService

See Also

ChinaRefundService Members
InSite.Domain.CyberSourceService Namespace


ChinaRefundService Members

[image] [image]

.NET Framework Class Library
ChinaRefundService Members
ChinaRefundService Class Constructors Methods Properties Events See Also Send Feedback

The ChinaRefundService type exposes the following members.

Constructors

Name | Description
ChinaRefundService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
chinaPaymentRequestID |
chinaPaymentRequestToken |
refundReason |
run |

Events

Name | Description
PropertyChanged |

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundService Constructor

[image]

.NET Framework Class Library
ChinaRefundService Constructor
ChinaRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChinaRefundService()
Visual C++
public:
ChinaRefundService()
JavaScript
InSite.Domain.CyberSourceService.ChinaRefundService = function();

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundService Methods

[image] [image]

.NET Framework Class Library
ChinaRefundService Methods
ChinaRefundService Class See Also Send Feedback

The ChinaRefundService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ChinaRefundService..::.RaisePropertyChanged Method
ChinaRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundService Properties

[image] [image]

.NET Framework Class Library
ChinaRefundService Properties
ChinaRefundService Class See Also Send Feedback

The ChinaRefundService type exposes the following members.

Properties

Name | Description
chinaPaymentRequestID |
chinaPaymentRequestToken |
refundReason |
run |

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


chinaPaymentRequestID Property

[image]

.NET Framework Class Library
ChinaRefundService..::.chinaPaymentRequestID Property
ChinaRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property chinaPaymentRequestID As String
C#
public string chinaPaymentRequestID { get; set; }
Visual C++
public:
property String^ chinaPaymentRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_chinaPaymentRequestID();
function set_chinaPaymentRequestID(value);

Remarks

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


chinaPaymentRequestToken Property

[image]

.NET Framework Class Library
ChinaRefundService..::.chinaPaymentRequestToken Property
ChinaRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property chinaPaymentRequestToken As String
C#
public string chinaPaymentRequestToken { get; set; }
Visual C++
public:
property String^ chinaPaymentRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_chinaPaymentRequestToken();
function set_chinaPaymentRequestToken(value);

Remarks

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


refundReason Property

[image]

.NET Framework Class Library
ChinaRefundService..::.refundReason Property
ChinaRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property refundReason As String
C#
public string refundReason { get; set; }
Visual C++
public:
property String^ refundReason {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_refundReason();
function set_refundReason(value);

Remarks

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
ChinaRefundService..::.run Property
ChinaRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


ChinaRefundService Events

[image] [image]

.NET Framework Class Library
ChinaRefundService Events
ChinaRefundService Class See Also Send Feedback

The ChinaRefundService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ChinaRefundService..::.PropertyChanged Event
ChinaRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ChinaRefundService Class
InSite.Domain.CyberSourceService Namespace


DAVReply Class

[image]

.NET Framework Class Library
DAVReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DAVReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DAVReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DAVReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DAVReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DAVReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DAVReply

See Also

DAVReply Members
InSite.Domain.CyberSourceService Namespace


DAVReply Members

[image] [image]

.NET Framework Class Library
DAVReply Members
DAVReply Class Constructors Methods Properties Events See Also Send Feedback

The DAVReply type exposes the following members.

Constructors

Name | Description
DAVReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
addressType |
apartmentInfo |
barCode |
barCodeCheckDigit |
caErrorInfo |
caInfo |
careOf |
cityInfo |
countryInfo |
directionalInfo |
intlErrorInfo |
intlInfo |
lvrInfo |
matchScore |
overallInfo |
postalCodeInfo |
reasonCode |
standardizedAddress1 |
standardizedAddress2 |
standardizedAddress3 |
standardizedAddress4 |
standardizedAddressNoApt |
standardizedCity |
standardizedCountry |
standardizedCounty |
standardizedCSP |
standardizedISOCountry |
standardizedPostalCode |
standardizedState |
stateInfo |
streetInfo |
suffixInfo |
usErrorInfo |
usInfo |

Events

Name | Description
PropertyChanged |

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


DAVReply Constructor

[image]

.NET Framework Class Library
DAVReply Constructor
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DAVReply()
Visual C++
public:
DAVReply()
JavaScript
InSite.Domain.CyberSourceService.DAVReply = function();

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


DAVReply Methods

[image] [image]

.NET Framework Class Library
DAVReply Methods
DAVReply Class See Also Send Feedback

The DAVReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DAVReply..::.RaisePropertyChanged Method
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


DAVReply Properties

[image] [image]

.NET Framework Class Library
DAVReply Properties
DAVReply Class See Also Send Feedback

The DAVReply type exposes the following members.

Properties

Name | Description
addressType |
apartmentInfo |
barCode |
barCodeCheckDigit |
caErrorInfo |
caInfo |
careOf |
cityInfo |
countryInfo |
directionalInfo |
intlErrorInfo |
intlInfo |
lvrInfo |
matchScore |
overallInfo |
postalCodeInfo |
reasonCode |
standardizedAddress1 |
standardizedAddress2 |
standardizedAddress3 |
standardizedAddress4 |
standardizedAddressNoApt |
standardizedCity |
standardizedCountry |
standardizedCounty |
standardizedCSP |
standardizedISOCountry |
standardizedPostalCode |
standardizedState |
stateInfo |
streetInfo |
suffixInfo |
usErrorInfo |
usInfo |

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


addressType Property

[image]

.NET Framework Class Library
DAVReply..::.addressType Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property addressType As String
C#
public string addressType { get; set; }
Visual C++
public:
property String^ addressType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_addressType();
function set_addressType(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


apartmentInfo Property

[image]

.NET Framework Class Library
DAVReply..::.apartmentInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property apartmentInfo As String
C#
public string apartmentInfo { get; set; }
Visual C++
public:
property String^ apartmentInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_apartmentInfo();
function set_apartmentInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


barCode Property

[image]

.NET Framework Class Library
DAVReply..::.barCode Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property barCode As String
C#
public string barCode { get; set; }
Visual C++
public:
property String^ barCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_barCode();
function set_barCode(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


barCodeCheckDigit Property

[image]

.NET Framework Class Library
DAVReply..::.barCodeCheckDigit Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property barCodeCheckDigit As String
C#
public string barCodeCheckDigit { get; set; }
Visual C++
public:
property String^ barCodeCheckDigit {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_barCodeCheckDigit();
function set_barCodeCheckDigit(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


caErrorInfo Property

[image]

.NET Framework Class Library
DAVReply..::.caErrorInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property caErrorInfo As String
C#
public string caErrorInfo { get; set; }
Visual C++
public:
property String^ caErrorInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_caErrorInfo();
function set_caErrorInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


caInfo Property

[image]

.NET Framework Class Library
DAVReply..::.caInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property caInfo As String
C#
public string caInfo { get; set; }
Visual C++
public:
property String^ caInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_caInfo();
function set_caInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


careOf Property

[image]

.NET Framework Class Library
DAVReply..::.careOf Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property careOf As String
C#
public string careOf { get; set; }
Visual C++
public:
property String^ careOf {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_careOf();
function set_careOf(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


cityInfo Property

[image]

.NET Framework Class Library
DAVReply..::.cityInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cityInfo As String
C#
public string cityInfo { get; set; }
Visual C++
public:
property String^ cityInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cityInfo();
function set_cityInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


countryInfo Property

[image]

.NET Framework Class Library
DAVReply..::.countryInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countryInfo As String
C#
public string countryInfo { get; set; }
Visual C++
public:
property String^ countryInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryInfo();
function set_countryInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


directionalInfo Property

[image]

.NET Framework Class Library
DAVReply..::.directionalInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directionalInfo As String
C#
public string directionalInfo { get; set; }
Visual C++
public:
property String^ directionalInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_directionalInfo();
function set_directionalInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


intlErrorInfo Property

[image]

.NET Framework Class Library
DAVReply..::.intlErrorInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property intlErrorInfo As String
C#
public string intlErrorInfo { get; set; }
Visual C++
public:
property String^ intlErrorInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_intlErrorInfo();
function set_intlErrorInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


intlInfo Property

[image]

.NET Framework Class Library
DAVReply..::.intlInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property intlInfo As String
C#
public string intlInfo { get; set; }
Visual C++
public:
property String^ intlInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_intlInfo();
function set_intlInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


lvrInfo Property

[image]

.NET Framework Class Library
DAVReply..::.lvrInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property lvrInfo As String
C#
public string lvrInfo { get; set; }
Visual C++
public:
property String^ lvrInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lvrInfo();
function set_lvrInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


matchScore Property

[image]

.NET Framework Class Library
DAVReply..::.matchScore Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property matchScore As String
C#
public string matchScore { get; set; }
Visual C++
public:
property String^ matchScore {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_matchScore();
function set_matchScore(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


overallInfo Property

[image]

.NET Framework Class Library
DAVReply..::.overallInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property overallInfo As String
C#
public string overallInfo { get; set; }
Visual C++
public:
property String^ overallInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_overallInfo();
function set_overallInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


postalCodeInfo Property

[image]

.NET Framework Class Library
DAVReply..::.postalCodeInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property postalCodeInfo As String
C#
public string postalCodeInfo { get; set; }
Visual C++
public:
property String^ postalCodeInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCodeInfo();
function set_postalCodeInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
DAVReply..::.reasonCode Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedAddress1 Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedAddress1 Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedAddress1 As String
C#
public string standardizedAddress1 { get; set; }
Visual C++
public:
property String^ standardizedAddress1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedAddress1();
function set_standardizedAddress1(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedAddress2 Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedAddress2 Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedAddress2 As String
C#
public string standardizedAddress2 { get; set; }
Visual C++
public:
property String^ standardizedAddress2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedAddress2();
function set_standardizedAddress2(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedAddress3 Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedAddress3 Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedAddress3 As String
C#
public string standardizedAddress3 { get; set; }
Visual C++
public:
property String^ standardizedAddress3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedAddress3();
function set_standardizedAddress3(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedAddress4 Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedAddress4 Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedAddress4 As String
C#
public string standardizedAddress4 { get; set; }
Visual C++
public:
property String^ standardizedAddress4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedAddress4();
function set_standardizedAddress4(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedAddressNoApt Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedAddressNoApt Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedAddressNoApt As String
C#
public string standardizedAddressNoApt { get; set; }
Visual C++
public:
property String^ standardizedAddressNoApt {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedAddressNoApt();
function set_standardizedAddressNoApt(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedCity Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedCity Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedCity As String
C#
public string standardizedCity { get; set; }
Visual C++
public:
property String^ standardizedCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedCity();
function set_standardizedCity(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedCountry Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedCountry Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedCountry As String
C#
public string standardizedCountry { get; set; }
Visual C++
public:
property String^ standardizedCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedCountry();
function set_standardizedCountry(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedCounty Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedCounty Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedCounty As String
C#
public string standardizedCounty { get; set; }
Visual C++
public:
property String^ standardizedCounty {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedCounty();
function set_standardizedCounty(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedCSP Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedCSP Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedCSP As String
C#
public string standardizedCSP { get; set; }
Visual C++
public:
property String^ standardizedCSP {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedCSP();
function set_standardizedCSP(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedISOCountry Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedISOCountry Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedISOCountry As String
C#
public string standardizedISOCountry { get; set; }
Visual C++
public:
property String^ standardizedISOCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedISOCountry();
function set_standardizedISOCountry(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedPostalCode Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedPostalCode Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedPostalCode As String
C#
public string standardizedPostalCode { get; set; }
Visual C++
public:
property String^ standardizedPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedPostalCode();
function set_standardizedPostalCode(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


standardizedState Property

[image]

.NET Framework Class Library
DAVReply..::.standardizedState Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property standardizedState As String
C#
public string standardizedState { get; set; }
Visual C++
public:
property String^ standardizedState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_standardizedState();
function set_standardizedState(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


stateInfo Property

[image]

.NET Framework Class Library
DAVReply..::.stateInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property stateInfo As String
C#
public string stateInfo { get; set; }
Visual C++
public:
property String^ stateInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stateInfo();
function set_stateInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


streetInfo Property

[image]

.NET Framework Class Library
DAVReply..::.streetInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property streetInfo As String
C#
public string streetInfo { get; set; }
Visual C++
public:
property String^ streetInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_streetInfo();
function set_streetInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


suffixInfo Property

[image]

.NET Framework Class Library
DAVReply..::.suffixInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property suffixInfo As String
C#
public string suffixInfo { get; set; }
Visual C++
public:
property String^ suffixInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_suffixInfo();
function set_suffixInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


usErrorInfo Property

[image]

.NET Framework Class Library
DAVReply..::.usErrorInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property usErrorInfo As String
C#
public string usErrorInfo { get; set; }
Visual C++
public:
property String^ usErrorInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_usErrorInfo();
function set_usErrorInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


usInfo Property

[image]

.NET Framework Class Library
DAVReply..::.usInfo Property
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property usInfo As String
C#
public string usInfo { get; set; }
Visual C++
public:
property String^ usInfo {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_usInfo();
function set_usInfo(value);

Remarks

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


DAVReply Events

[image] [image]

.NET Framework Class Library
DAVReply Events
DAVReply Class See Also Send Feedback

The DAVReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DAVReply..::.PropertyChanged Event
DAVReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DAVReply Class
InSite.Domain.CyberSourceService Namespace


DAVService Class

[image]

.NET Framework Class Library
DAVService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DAVService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DAVService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DAVService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DAVService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DAVService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DAVService

See Also

DAVService Members
InSite.Domain.CyberSourceService Namespace


DAVService Members

[image] [image]

.NET Framework Class Library
DAVService Members
DAVService Class Constructors Methods Properties Events See Also Send Feedback

The DAVService type exposes the following members.

Constructors

Name | Description
DAVService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |

Events

Name | Description
PropertyChanged |

See Also

DAVService Class
InSite.Domain.CyberSourceService Namespace


DAVService Constructor

[image]

.NET Framework Class Library
DAVService Constructor
DAVService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DAVService()
Visual C++
public:
DAVService()
JavaScript
InSite.Domain.CyberSourceService.DAVService = function();

See Also

DAVService Class
InSite.Domain.CyberSourceService Namespace


DAVService Methods

[image] [image]

.NET Framework Class Library
DAVService Methods
DAVService Class See Also Send Feedback

The DAVService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DAVService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DAVService..::.RaisePropertyChanged Method
DAVService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DAVService Class
InSite.Domain.CyberSourceService Namespace


DAVService Properties

[image] [image]

.NET Framework Class Library
DAVService Properties
DAVService Class See Also Send Feedback

The DAVService type exposes the following members.

Properties

Name | Description
run |

See Also

DAVService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
DAVService..::.run Property
DAVService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

DAVService Class
InSite.Domain.CyberSourceService Namespace


DAVService Events

[image] [image]

.NET Framework Class Library
DAVService Events
DAVService Class See Also Send Feedback

The DAVService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DAVService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DAVService..::.PropertyChanged Event
DAVService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DAVService Class
InSite.Domain.CyberSourceService Namespace


DCC Class

[image]

.NET Framework Class Library
DCC Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DCC _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DCC : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DCC : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DCC = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DCC',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DCC

See Also

DCC Members
InSite.Domain.CyberSourceService Namespace


DCC Members

[image] [image]

.NET Framework Class Library
DCC Members
DCC Class Constructors Methods Properties Events See Also Send Feedback

The DCC type exposes the following members.

Constructors

Name | Description
DCC |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
dccIndicator |

Events

Name | Description
PropertyChanged |

See Also

DCC Class
InSite.Domain.CyberSourceService Namespace


DCC Constructor

[image]

.NET Framework Class Library
DCC Constructor
DCC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DCC()
Visual C++
public:
DCC()
JavaScript
InSite.Domain.CyberSourceService.DCC = function();

See Also

DCC Class
InSite.Domain.CyberSourceService Namespace


DCC Methods

[image] [image]

.NET Framework Class Library
DCC Methods
DCC Class See Also Send Feedback

The DCC type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DCC Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DCC..::.RaisePropertyChanged Method
DCC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DCC Class
InSite.Domain.CyberSourceService Namespace


DCC Properties

[image] [image]

.NET Framework Class Library
DCC Properties
DCC Class See Also Send Feedback

The DCC type exposes the following members.

Properties

Name | Description
dccIndicator |

See Also

DCC Class
InSite.Domain.CyberSourceService Namespace


dccIndicator Property

[image]

.NET Framework Class Library
DCC..::.dccIndicator Property
DCC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dccIndicator As String
C#
public string dccIndicator { get; set; }
Visual C++
public:
property String^ dccIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dccIndicator();
function set_dccIndicator(value);

Remarks

See Also

DCC Class
InSite.Domain.CyberSourceService Namespace


DCC Events

[image] [image]

.NET Framework Class Library
DCC Events
DCC Class See Also Send Feedback

The DCC type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DCC Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DCC..::.PropertyChanged Event
DCC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DCC Class
InSite.Domain.CyberSourceService Namespace


DecisionManager Class

[image]

.NET Framework Class Library
DecisionManager Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DecisionManager _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DecisionManager : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DecisionManager : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DecisionManager = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DecisionManager',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DecisionManager

See Also

DecisionManager Members
InSite.Domain.CyberSourceService Namespace


DecisionManager Members

[image] [image]

.NET Framework Class Library
DecisionManager Members
DecisionManager Class Constructors Methods Properties Events See Also Send Feedback

The DecisionManager type exposes the following members.

Constructors

Name | Description
DecisionManager |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
enabled |
profile |

Events

Name | Description
PropertyChanged |

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


DecisionManager Constructor

[image]

.NET Framework Class Library
DecisionManager Constructor
DecisionManager Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DecisionManager()
Visual C++
public:
DecisionManager()
JavaScript
InSite.Domain.CyberSourceService.DecisionManager = function();

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


DecisionManager Methods

[image] [image]

.NET Framework Class Library
DecisionManager Methods
DecisionManager Class See Also Send Feedback

The DecisionManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DecisionManager..::.RaisePropertyChanged Method
DecisionManager Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


DecisionManager Properties

[image] [image]

.NET Framework Class Library
DecisionManager Properties
DecisionManager Class See Also Send Feedback

The DecisionManager type exposes the following members.

Properties

Name | Description
enabled |
profile |

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


enabled Property

[image]

.NET Framework Class Library
DecisionManager..::.enabled Property
DecisionManager Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property enabled As String
C#
public string enabled { get; set; }
Visual C++
public:
property String^ enabled {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_enabled();
function set_enabled(value);

Remarks

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


profile Property

[image]

.NET Framework Class Library
DecisionManager..::.profile Property
DecisionManager Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property profile As String
C#
public string profile { get; set; }
Visual C++
public:
property String^ profile {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_profile();
function set_profile(value);

Remarks

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


DecisionManager Events

[image] [image]

.NET Framework Class Library
DecisionManager Events
DecisionManager Class See Also Send Feedback

The DecisionManager type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DecisionManager..::.PropertyChanged Event
DecisionManager Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DecisionManager Class
InSite.Domain.CyberSourceService Namespace


DecisionReply Class

[image]

.NET Framework Class Library
DecisionReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DecisionReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DecisionReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DecisionReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DecisionReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DecisionReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DecisionReply

See Also

DecisionReply Members
InSite.Domain.CyberSourceService Namespace


DecisionReply Members

[image] [image]

.NET Framework Class Library
DecisionReply Members
DecisionReply Class Constructors Methods Properties Events See Also Send Feedback

The DecisionReply type exposes the following members.

Constructors

Name | Description
DecisionReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
activeProfileReply |
casePriority |
velocityInfoCode |

Events

Name | Description
PropertyChanged |

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


DecisionReply Constructor

[image]

.NET Framework Class Library
DecisionReply Constructor
DecisionReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DecisionReply()
Visual C++
public:
DecisionReply()
JavaScript
InSite.Domain.CyberSourceService.DecisionReply = function();

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


DecisionReply Methods

[image] [image]

.NET Framework Class Library
DecisionReply Methods
DecisionReply Class See Also Send Feedback

The DecisionReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DecisionReply..::.RaisePropertyChanged Method
DecisionReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


DecisionReply Properties

[image] [image]

.NET Framework Class Library
DecisionReply Properties
DecisionReply Class See Also Send Feedback

The DecisionReply type exposes the following members.

Properties

Name | Description
activeProfileReply |
casePriority |
velocityInfoCode |

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


activeProfileReply Property

[image]

.NET Framework Class Library
DecisionReply..::.activeProfileReply Property
DecisionReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property activeProfileReply As ProfileReply
C#
public ProfileReply activeProfileReply { get; set; }
Visual C++
public:
property ProfileReply^ activeProfileReply {
    ProfileReply^ get ();
    void set (ProfileReply^ value);
}
JavaScript
function get_activeProfileReply();
function set_activeProfileReply(value);

Remarks

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


casePriority Property

[image]

.NET Framework Class Library
DecisionReply..::.casePriority Property
DecisionReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property casePriority As String
C#
public string casePriority { get; set; }
Visual C++
public:
property String^ casePriority {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_casePriority();
function set_casePriority(value);

Remarks

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


velocityInfoCode Property

[image]

.NET Framework Class Library
DecisionReply..::.velocityInfoCode Property
DecisionReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property velocityInfoCode As String
C#
public string velocityInfoCode { get; set; }
Visual C++
public:
property String^ velocityInfoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_velocityInfoCode();
function set_velocityInfoCode(value);

Remarks

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


DecisionReply Events

[image] [image]

.NET Framework Class Library
DecisionReply Events
DecisionReply Class See Also Send Feedback

The DecisionReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DecisionReply..::.PropertyChanged Event
DecisionReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DecisionReply Class
InSite.Domain.CyberSourceService Namespace


DeniedPartiesMatch Class

[image]

.NET Framework Class Library
DeniedPartiesMatch Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DeniedPartiesMatch _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DeniedPartiesMatch : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DeniedPartiesMatch : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DeniedPartiesMatch = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DeniedPartiesMatch',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DeniedPartiesMatch

See Also

DeniedPartiesMatch Members
InSite.Domain.CyberSourceService Namespace


DeniedPartiesMatch Members

[image] [image]

.NET Framework Class Library
DeniedPartiesMatch Members
DeniedPartiesMatch Class Constructors Methods Properties Events See Also Send Feedback

The DeniedPartiesMatch type exposes the following members.

Constructors

Name | Description
DeniedPartiesMatch |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
address |
list |
name |

Events

Name | Description
PropertyChanged |

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


DeniedPartiesMatch Constructor

[image]

.NET Framework Class Library
DeniedPartiesMatch Constructor
DeniedPartiesMatch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DeniedPartiesMatch()
Visual C++
public:
DeniedPartiesMatch()
JavaScript
InSite.Domain.CyberSourceService.DeniedPartiesMatch = function();

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


DeniedPartiesMatch Methods

[image] [image]

.NET Framework Class Library
DeniedPartiesMatch Methods
DeniedPartiesMatch Class See Also Send Feedback

The DeniedPartiesMatch type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DeniedPartiesMatch..::.RaisePropertyChanged Method
DeniedPartiesMatch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


DeniedPartiesMatch Properties

[image] [image]

.NET Framework Class Library
DeniedPartiesMatch Properties
DeniedPartiesMatch Class See Also Send Feedback

The DeniedPartiesMatch type exposes the following members.

Properties

Name | Description
address |
list |
name |

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


address Property

[image]

.NET Framework Class Library
DeniedPartiesMatch..::.address Property
DeniedPartiesMatch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property address As String()
C#
public string[] address { get; set; }
Visual C++
public:
property array<String^>^ address {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


list Property

[image]

.NET Framework Class Library
DeniedPartiesMatch..::.list Property
DeniedPartiesMatch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property list As String
C#
public string list { get; set; }
Visual C++
public:
property String^ list {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_list();
function set_list(value);

Remarks

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


name Property

[image]

.NET Framework Class Library
DeniedPartiesMatch..::.name Property
DeniedPartiesMatch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String()
C#
public string[] name { get; set; }
Visual C++
public:
property array<String^>^ name {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


DeniedPartiesMatch Events

[image] [image]

.NET Framework Class Library
DeniedPartiesMatch Events
DeniedPartiesMatch Class See Also Send Feedback

The DeniedPartiesMatch type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DeniedPartiesMatch..::.PropertyChanged Event
DeniedPartiesMatch Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DeniedPartiesMatch Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateReply Class

[image]

.NET Framework Class Library
DirectDebitMandateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DirectDebitMandateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DirectDebitMandateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DirectDebitMandateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DirectDebitMandateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DirectDebitMandateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DirectDebitMandateReply

See Also

DirectDebitMandateReply Members
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateReply Members

[image] [image]

.NET Framework Class Library
DirectDebitMandateReply Members
DirectDebitMandateReply Class Constructors Methods Properties Events See Also Send Feedback

The DirectDebitMandateReply type exposes the following members.

Constructors

Name | Description
DirectDebitMandateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
mandateID |
mandateMaturationDate |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateReply Constructor

[image]

.NET Framework Class Library
DirectDebitMandateReply Constructor
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DirectDebitMandateReply()
Visual C++
public:
DirectDebitMandateReply()
JavaScript
InSite.Domain.CyberSourceService.DirectDebitMandateReply = function();

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateReply Methods

[image] [image]

.NET Framework Class Library
DirectDebitMandateReply Methods
DirectDebitMandateReply Class See Also Send Feedback

The DirectDebitMandateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DirectDebitMandateReply..::.RaisePropertyChanged Method
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateReply Properties

[image] [image]

.NET Framework Class Library
DirectDebitMandateReply Properties
DirectDebitMandateReply Class See Also Send Feedback

The DirectDebitMandateReply type exposes the following members.

Properties

Name | Description
mandateID |
mandateMaturationDate |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


mandateID Property

[image]

.NET Framework Class Library
DirectDebitMandateReply..::.mandateID Property
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mandateID As String
C#
public string mandateID { get; set; }
Visual C++
public:
property String^ mandateID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mandateID();
function set_mandateID(value);

Remarks

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


mandateMaturationDate Property

[image]

.NET Framework Class Library
DirectDebitMandateReply..::.mandateMaturationDate Property
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mandateMaturationDate As String
C#
public string mandateMaturationDate { get; set; }
Visual C++
public:
property String^ mandateMaturationDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mandateMaturationDate();
function set_mandateMaturationDate(value);

Remarks

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
DirectDebitMandateReply..::.processorResponse Property
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
DirectDebitMandateReply..::.reasonCode Property
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
DirectDebitMandateReply..::.reconciliationID Property
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
DirectDebitMandateReply..::.requestDateTime Property
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateReply Events

[image] [image]

.NET Framework Class Library
DirectDebitMandateReply Events
DirectDebitMandateReply Class See Also Send Feedback

The DirectDebitMandateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DirectDebitMandateReply..::.PropertyChanged Event
DirectDebitMandateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DirectDebitMandateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateService Class

[image]

.NET Framework Class Library
DirectDebitMandateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DirectDebitMandateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DirectDebitMandateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DirectDebitMandateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DirectDebitMandateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DirectDebitMandateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DirectDebitMandateService

See Also

DirectDebitMandateService Members
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateService Members

[image] [image]

.NET Framework Class Library
DirectDebitMandateService Members
DirectDebitMandateService Class Constructors Methods Properties Events See Also Send Feedback

The DirectDebitMandateService type exposes the following members.

Constructors

Name | Description
DirectDebitMandateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
firstDebitDate |
mandateDescriptor |
run |

Events

Name | Description
PropertyChanged |

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateService Constructor

[image]

.NET Framework Class Library
DirectDebitMandateService Constructor
DirectDebitMandateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DirectDebitMandateService()
Visual C++
public:
DirectDebitMandateService()
JavaScript
InSite.Domain.CyberSourceService.DirectDebitMandateService = function();

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateService Methods

[image] [image]

.NET Framework Class Library
DirectDebitMandateService Methods
DirectDebitMandateService Class See Also Send Feedback

The DirectDebitMandateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DirectDebitMandateService..::.RaisePropertyChanged Method
DirectDebitMandateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateService Properties

[image] [image]

.NET Framework Class Library
DirectDebitMandateService Properties
DirectDebitMandateService Class See Also Send Feedback

The DirectDebitMandateService type exposes the following members.

Properties

Name | Description
firstDebitDate |
mandateDescriptor |
run |

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


firstDebitDate Property

[image]

.NET Framework Class Library
DirectDebitMandateService..::.firstDebitDate Property
DirectDebitMandateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property firstDebitDate As String
C#
public string firstDebitDate { get; set; }
Visual C++
public:
property String^ firstDebitDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstDebitDate();
function set_firstDebitDate(value);

Remarks

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


mandateDescriptor Property

[image]

.NET Framework Class Library
DirectDebitMandateService..::.mandateDescriptor Property
DirectDebitMandateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mandateDescriptor As String
C#
public string mandateDescriptor { get; set; }
Visual C++
public:
property String^ mandateDescriptor {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mandateDescriptor();
function set_mandateDescriptor(value);

Remarks

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
DirectDebitMandateService..::.run Property
DirectDebitMandateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitMandateService Events

[image] [image]

.NET Framework Class Library
DirectDebitMandateService Events
DirectDebitMandateService Class See Also Send Feedback

The DirectDebitMandateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DirectDebitMandateService..::.PropertyChanged Event
DirectDebitMandateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DirectDebitMandateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundReply Class

[image]

.NET Framework Class Library
DirectDebitRefundReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DirectDebitRefundReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DirectDebitRefundReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DirectDebitRefundReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DirectDebitRefundReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DirectDebitRefundReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DirectDebitRefundReply

See Also

DirectDebitRefundReply Members
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundReply Members

[image] [image]

.NET Framework Class Library
DirectDebitRefundReply Members
DirectDebitRefundReply Class Constructors Methods Properties Events See Also Send Feedback

The DirectDebitRefundReply type exposes the following members.

Constructors

Name | Description
DirectDebitRefundReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundReply Constructor

[image]

.NET Framework Class Library
DirectDebitRefundReply Constructor
DirectDebitRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DirectDebitRefundReply()
Visual C++
public:
DirectDebitRefundReply()
JavaScript
InSite.Domain.CyberSourceService.DirectDebitRefundReply = function();

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundReply Methods

[image] [image]

.NET Framework Class Library
DirectDebitRefundReply Methods
DirectDebitRefundReply Class See Also Send Feedback

The DirectDebitRefundReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DirectDebitRefundReply..::.RaisePropertyChanged Method
DirectDebitRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundReply Properties

[image] [image]

.NET Framework Class Library
DirectDebitRefundReply Properties
DirectDebitRefundReply Class See Also Send Feedback

The DirectDebitRefundReply type exposes the following members.

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
DirectDebitRefundReply..::.amount Property
DirectDebitRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
DirectDebitRefundReply..::.processorResponse Property
DirectDebitRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
DirectDebitRefundReply..::.reasonCode Property
DirectDebitRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
DirectDebitRefundReply..::.reconciliationID Property
DirectDebitRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
DirectDebitRefundReply..::.requestDateTime Property
DirectDebitRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundReply Events

[image] [image]

.NET Framework Class Library
DirectDebitRefundReply Events
DirectDebitRefundReply Class See Also Send Feedback

The DirectDebitRefundReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DirectDebitRefundReply..::.PropertyChanged Event
DirectDebitRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DirectDebitRefundReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundService Class

[image]

.NET Framework Class Library
DirectDebitRefundService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DirectDebitRefundService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DirectDebitRefundService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DirectDebitRefundService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DirectDebitRefundService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DirectDebitRefundService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DirectDebitRefundService

See Also

DirectDebitRefundService Members
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundService Members

[image] [image]

.NET Framework Class Library
DirectDebitRefundService Members
DirectDebitRefundService Class Constructors Methods Properties Events See Also Send Feedback

The DirectDebitRefundService type exposes the following members.

Constructors

Name | Description
DirectDebitRefundService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
directDebitRequestID |
directDebitRequestToken |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundService Constructor

[image]

.NET Framework Class Library
DirectDebitRefundService Constructor
DirectDebitRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DirectDebitRefundService()
Visual C++
public:
DirectDebitRefundService()
JavaScript
InSite.Domain.CyberSourceService.DirectDebitRefundService = function();

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundService Methods

[image] [image]

.NET Framework Class Library
DirectDebitRefundService Methods
DirectDebitRefundService Class See Also Send Feedback

The DirectDebitRefundService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DirectDebitRefundService..::.RaisePropertyChanged Method
DirectDebitRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundService Properties

[image] [image]

.NET Framework Class Library
DirectDebitRefundService Properties
DirectDebitRefundService Class See Also Send Feedback

The DirectDebitRefundService type exposes the following members.

Properties

Name | Description
directDebitRequestID |
directDebitRequestToken |
reconciliationID |
run |

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


directDebitRequestID Property

[image]

.NET Framework Class Library
DirectDebitRefundService..::.directDebitRequestID Property
DirectDebitRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitRequestID As String
C#
public string directDebitRequestID { get; set; }
Visual C++
public:
property String^ directDebitRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_directDebitRequestID();
function set_directDebitRequestID(value);

Remarks

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


directDebitRequestToken Property

[image]

.NET Framework Class Library
DirectDebitRefundService..::.directDebitRequestToken Property
DirectDebitRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitRequestToken As String
C#
public string directDebitRequestToken { get; set; }
Visual C++
public:
property String^ directDebitRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_directDebitRequestToken();
function set_directDebitRequestToken(value);

Remarks

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
DirectDebitRefundService..::.reconciliationID Property
DirectDebitRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
DirectDebitRefundService..::.run Property
DirectDebitRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitRefundService Events

[image] [image]

.NET Framework Class Library
DirectDebitRefundService Events
DirectDebitRefundService Class See Also Send Feedback

The DirectDebitRefundService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DirectDebitRefundService..::.PropertyChanged Event
DirectDebitRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DirectDebitRefundService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitReply Class

[image]

.NET Framework Class Library
DirectDebitReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DirectDebitReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DirectDebitReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DirectDebitReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DirectDebitReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DirectDebitReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DirectDebitReply

See Also

DirectDebitReply Members
InSite.Domain.CyberSourceService Namespace


DirectDebitReply Members

[image] [image]

.NET Framework Class Library
DirectDebitReply Members
DirectDebitReply Class Constructors Methods Properties Events See Also Send Feedback

The DirectDebitReply type exposes the following members.

Constructors

Name | Description
DirectDebitReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitReply Constructor

[image]

.NET Framework Class Library
DirectDebitReply Constructor
DirectDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DirectDebitReply()
Visual C++
public:
DirectDebitReply()
JavaScript
InSite.Domain.CyberSourceService.DirectDebitReply = function();

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitReply Methods

[image] [image]

.NET Framework Class Library
DirectDebitReply Methods
DirectDebitReply Class See Also Send Feedback

The DirectDebitReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DirectDebitReply..::.RaisePropertyChanged Method
DirectDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitReply Properties

[image] [image]

.NET Framework Class Library
DirectDebitReply Properties
DirectDebitReply Class See Also Send Feedback

The DirectDebitReply type exposes the following members.

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
DirectDebitReply..::.amount Property
DirectDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
DirectDebitReply..::.processorResponse Property
DirectDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
DirectDebitReply..::.reasonCode Property
DirectDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
DirectDebitReply..::.reconciliationID Property
DirectDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
DirectDebitReply..::.requestDateTime Property
DirectDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitReply Events

[image] [image]

.NET Framework Class Library
DirectDebitReply Events
DirectDebitReply Class See Also Send Feedback

The DirectDebitReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DirectDebitReply..::.PropertyChanged Event
DirectDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DirectDebitReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitService Class

[image]

.NET Framework Class Library
DirectDebitService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DirectDebitService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DirectDebitService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DirectDebitService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DirectDebitService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DirectDebitService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DirectDebitService

See Also

DirectDebitService Members
InSite.Domain.CyberSourceService Namespace


DirectDebitService Members

[image] [image]

.NET Framework Class Library
DirectDebitService Members
DirectDebitService Class Constructors Methods Properties Events See Also Send Feedback

The DirectDebitService type exposes the following members.

Constructors

Name | Description
DirectDebitService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
authorizationID |
dateCollect |
directDebitText |
directDebitType |
mandateID |
reconciliationID |
recurringType |
run |
transactionType |
validateRequestID |
validateRequestToken |

Events

Name | Description
PropertyChanged |

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitService Constructor

[image]

.NET Framework Class Library
DirectDebitService Constructor
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DirectDebitService()
Visual C++
public:
DirectDebitService()
JavaScript
InSite.Domain.CyberSourceService.DirectDebitService = function();

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitService Methods

[image] [image]

.NET Framework Class Library
DirectDebitService Methods
DirectDebitService Class See Also Send Feedback

The DirectDebitService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DirectDebitService..::.RaisePropertyChanged Method
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitService Properties

[image] [image]

.NET Framework Class Library
DirectDebitService Properties
DirectDebitService Class See Also Send Feedback

The DirectDebitService type exposes the following members.

Properties

Name | Description
authorizationID |
dateCollect |
directDebitText |
directDebitType |
mandateID |
reconciliationID |
recurringType |
run |
transactionType |
validateRequestID |
validateRequestToken |

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


authorizationID Property

[image]

.NET Framework Class Library
DirectDebitService..::.authorizationID Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationID As String
C#
public string authorizationID { get; set; }
Visual C++
public:
property String^ authorizationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationID();
function set_authorizationID(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


dateCollect Property

[image]

.NET Framework Class Library
DirectDebitService..::.dateCollect Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dateCollect As String
C#
public string dateCollect { get; set; }
Visual C++
public:
property String^ dateCollect {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dateCollect();
function set_dateCollect(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


directDebitText Property

[image]

.NET Framework Class Library
DirectDebitService..::.directDebitText Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitText As String
C#
public string directDebitText { get; set; }
Visual C++
public:
property String^ directDebitText {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_directDebitText();
function set_directDebitText(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


directDebitType Property

[image]

.NET Framework Class Library
DirectDebitService..::.directDebitType Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitType As String
C#
public string directDebitType { get; set; }
Visual C++
public:
property String^ directDebitType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_directDebitType();
function set_directDebitType(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


mandateID Property

[image]

.NET Framework Class Library
DirectDebitService..::.mandateID Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mandateID As String
C#
public string mandateID { get; set; }
Visual C++
public:
property String^ mandateID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mandateID();
function set_mandateID(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
DirectDebitService..::.reconciliationID Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


recurringType Property

[image]

.NET Framework Class Library
DirectDebitService..::.recurringType Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property recurringType As String
C#
public string recurringType { get; set; }
Visual C++
public:
property String^ recurringType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_recurringType();
function set_recurringType(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
DirectDebitService..::.run Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


transactionType Property

[image]

.NET Framework Class Library
DirectDebitService..::.transactionType Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionType As String
C#
public string transactionType { get; set; }
Visual C++
public:
property String^ transactionType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionType();
function set_transactionType(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


validateRequestID Property

[image]

.NET Framework Class Library
DirectDebitService..::.validateRequestID Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property validateRequestID As String
C#
public string validateRequestID { get; set; }
Visual C++
public:
property String^ validateRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_validateRequestID();
function set_validateRequestID(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


validateRequestToken Property

[image]

.NET Framework Class Library
DirectDebitService..::.validateRequestToken Property
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property validateRequestToken As String
C#
public string validateRequestToken { get; set; }
Visual C++
public:
property String^ validateRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_validateRequestToken();
function set_validateRequestToken(value);

Remarks

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitService Events

[image] [image]

.NET Framework Class Library
DirectDebitService Events
DirectDebitService Class See Also Send Feedback

The DirectDebitService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DirectDebitService..::.PropertyChanged Event
DirectDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DirectDebitService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateReply Class

[image]

.NET Framework Class Library
DirectDebitValidateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DirectDebitValidateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DirectDebitValidateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DirectDebitValidateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DirectDebitValidateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DirectDebitValidateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DirectDebitValidateReply

See Also

DirectDebitValidateReply Members
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateReply Members

[image] [image]

.NET Framework Class Library
DirectDebitValidateReply Members
DirectDebitValidateReply Class Constructors Methods Properties Events See Also Send Feedback

The DirectDebitValidateReply type exposes the following members.

Constructors

Name | Description
DirectDebitValidateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateReply Constructor

[image]

.NET Framework Class Library
DirectDebitValidateReply Constructor
DirectDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DirectDebitValidateReply()
Visual C++
public:
DirectDebitValidateReply()
JavaScript
InSite.Domain.CyberSourceService.DirectDebitValidateReply = function();

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateReply Methods

[image] [image]

.NET Framework Class Library
DirectDebitValidateReply Methods
DirectDebitValidateReply Class See Also Send Feedback

The DirectDebitValidateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DirectDebitValidateReply..::.RaisePropertyChanged Method
DirectDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateReply Properties

[image] [image]

.NET Framework Class Library
DirectDebitValidateReply Properties
DirectDebitValidateReply Class See Also Send Feedback

The DirectDebitValidateReply type exposes the following members.

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
DirectDebitValidateReply..::.amount Property
DirectDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
DirectDebitValidateReply..::.processorResponse Property
DirectDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
DirectDebitValidateReply..::.reasonCode Property
DirectDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
DirectDebitValidateReply..::.reconciliationID Property
DirectDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
DirectDebitValidateReply..::.requestDateTime Property
DirectDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateReply Events

[image] [image]

.NET Framework Class Library
DirectDebitValidateReply Events
DirectDebitValidateReply Class See Also Send Feedback

The DirectDebitValidateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DirectDebitValidateReply..::.PropertyChanged Event
DirectDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DirectDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateService Class

[image]

.NET Framework Class Library
DirectDebitValidateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class DirectDebitValidateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class DirectDebitValidateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class DirectDebitValidateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.DirectDebitValidateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.DirectDebitValidateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.DirectDebitValidateService

See Also

DirectDebitValidateService Members
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateService Members

[image] [image]

.NET Framework Class Library
DirectDebitValidateService Members
DirectDebitValidateService Class Constructors Methods Properties Events See Also Send Feedback

The DirectDebitValidateService type exposes the following members.

Constructors

Name | Description
DirectDebitValidateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
directDebitValidateText |
run |

Events

Name | Description
PropertyChanged |

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateService Constructor

[image]

.NET Framework Class Library
DirectDebitValidateService Constructor
DirectDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DirectDebitValidateService()
Visual C++
public:
DirectDebitValidateService()
JavaScript
InSite.Domain.CyberSourceService.DirectDebitValidateService = function();

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateService Methods

[image] [image]

.NET Framework Class Library
DirectDebitValidateService Methods
DirectDebitValidateService Class See Also Send Feedback

The DirectDebitValidateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
DirectDebitValidateService..::.RaisePropertyChanged Method
DirectDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateService Properties

[image] [image]

.NET Framework Class Library
DirectDebitValidateService Properties
DirectDebitValidateService Class See Also Send Feedback

The DirectDebitValidateService type exposes the following members.

Properties

Name | Description
directDebitValidateText |
run |

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


directDebitValidateText Property

[image]

.NET Framework Class Library
DirectDebitValidateService..::.directDebitValidateText Property
DirectDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitValidateText As String
C#
public string directDebitValidateText { get; set; }
Visual C++
public:
property String^ directDebitValidateText {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_directDebitValidateText();
function set_directDebitValidateText(value);

Remarks

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
DirectDebitValidateService..::.run Property
DirectDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


DirectDebitValidateService Events

[image] [image]

.NET Framework Class Library
DirectDebitValidateService Events
DirectDebitValidateService Class See Also Send Feedback

The DirectDebitValidateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DirectDebitValidateService..::.PropertyChanged Event
DirectDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DirectDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


ECCreditReply Class

[image]

.NET Framework Class Library
ECCreditReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ECCreditReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ECCreditReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ECCreditReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ECCreditReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ECCreditReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ECCreditReply

See Also

ECCreditReply Members
InSite.Domain.CyberSourceService Namespace


ECCreditReply Members

[image] [image]

.NET Framework Class Library
ECCreditReply Members
ECCreditReply Class Constructors Methods Properties Events See Also Send Feedback

The ECCreditReply type exposes the following members.

Constructors

Name | Description
ECCreditReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
processorResponse |
processorTransactionID |
reasonCode |
reconciliationID |
requestDateTime |
settlementMethod |

Events

Name | Description
PropertyChanged |

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


ECCreditReply Constructor

[image]

.NET Framework Class Library
ECCreditReply Constructor
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ECCreditReply()
Visual C++
public:
ECCreditReply()
JavaScript
InSite.Domain.CyberSourceService.ECCreditReply = function();

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


ECCreditReply Methods

[image] [image]

.NET Framework Class Library
ECCreditReply Methods
ECCreditReply Class See Also Send Feedback

The ECCreditReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ECCreditReply..::.RaisePropertyChanged Method
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


ECCreditReply Properties

[image] [image]

.NET Framework Class Library
ECCreditReply Properties
ECCreditReply Class See Also Send Feedback

The ECCreditReply type exposes the following members.

Properties

Name | Description
amount |
processorResponse |
processorTransactionID |
reasonCode |
reconciliationID |
requestDateTime |
settlementMethod |

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
ECCreditReply..::.amount Property
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
ECCreditReply..::.processorResponse Property
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


processorTransactionID Property

[image]

.NET Framework Class Library
ECCreditReply..::.processorTransactionID Property
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorTransactionID As String
C#
public string processorTransactionID { get; set; }
Visual C++
public:
property String^ processorTransactionID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorTransactionID();
function set_processorTransactionID(value);

Remarks

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
ECCreditReply..::.reasonCode Property
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
ECCreditReply..::.reconciliationID Property
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
ECCreditReply..::.requestDateTime Property
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


settlementMethod Property

[image]

.NET Framework Class Library
ECCreditReply..::.settlementMethod Property
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property settlementMethod As String
C#
public string settlementMethod { get; set; }
Visual C++
public:
property String^ settlementMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_settlementMethod();
function set_settlementMethod(value);

Remarks

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


ECCreditReply Events

[image] [image]

.NET Framework Class Library
ECCreditReply Events
ECCreditReply Class See Also Send Feedback

The ECCreditReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ECCreditReply..::.PropertyChanged Event
ECCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ECCreditReply Class
InSite.Domain.CyberSourceService Namespace


ECCreditService Class

[image]

.NET Framework Class Library
ECCreditService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ECCreditService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ECCreditService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ECCreditService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ECCreditService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ECCreditService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ECCreditService

See Also

ECCreditService Members
InSite.Domain.CyberSourceService Namespace


ECCreditService Members

[image] [image]

.NET Framework Class Library
ECCreditService Members
ECCreditService Class Constructors Methods Properties Events See Also Send Feedback

The ECCreditService type exposes the following members.

Constructors

Name | Description
ECCreditService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
commerceIndicator |
debitRequestID |
debitRequestToken |
partialPaymentID |
referenceNumber |
run |
settlementMethod |
transactionToken |

Events

Name | Description
PropertyChanged |

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


ECCreditService Constructor

[image]

.NET Framework Class Library
ECCreditService Constructor
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ECCreditService()
Visual C++
public:
ECCreditService()
JavaScript
InSite.Domain.CyberSourceService.ECCreditService = function();

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


ECCreditService Methods

[image] [image]

.NET Framework Class Library
ECCreditService Methods
ECCreditService Class See Also Send Feedback

The ECCreditService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ECCreditService..::.RaisePropertyChanged Method
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


ECCreditService Properties

[image] [image]

.NET Framework Class Library
ECCreditService Properties
ECCreditService Class See Also Send Feedback

The ECCreditService type exposes the following members.

Properties

Name | Description
commerceIndicator |
debitRequestID |
debitRequestToken |
partialPaymentID |
referenceNumber |
run |
settlementMethod |
transactionToken |

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


commerceIndicator Property

[image]

.NET Framework Class Library
ECCreditService..::.commerceIndicator Property
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commerceIndicator As String
C#
public string commerceIndicator { get; set; }
Visual C++
public:
property String^ commerceIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commerceIndicator();
function set_commerceIndicator(value);

Remarks

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


debitRequestID Property

[image]

.NET Framework Class Library
ECCreditService..::.debitRequestID Property
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property debitRequestID As String
C#
public string debitRequestID { get; set; }
Visual C++
public:
property String^ debitRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_debitRequestID();
function set_debitRequestID(value);

Remarks

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


debitRequestToken Property

[image]

.NET Framework Class Library
ECCreditService..::.debitRequestToken Property
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property debitRequestToken As String
C#
public string debitRequestToken { get; set; }
Visual C++
public:
property String^ debitRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_debitRequestToken();
function set_debitRequestToken(value);

Remarks

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


partialPaymentID Property

[image]

.NET Framework Class Library
ECCreditService..::.partialPaymentID Property
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property partialPaymentID As String
C#
public string partialPaymentID { get; set; }
Visual C++
public:
property String^ partialPaymentID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_partialPaymentID();
function set_partialPaymentID(value);

Remarks

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


referenceNumber Property

[image]

.NET Framework Class Library
ECCreditService..::.referenceNumber Property
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property referenceNumber As String
C#
public string referenceNumber { get; set; }
Visual C++
public:
property String^ referenceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_referenceNumber();
function set_referenceNumber(value);

Remarks

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
ECCreditService..::.run Property
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


settlementMethod Property

[image]

.NET Framework Class Library
ECCreditService..::.settlementMethod Property
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property settlementMethod As String
C#
public string settlementMethod { get; set; }
Visual C++
public:
property String^ settlementMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_settlementMethod();
function set_settlementMethod(value);

Remarks

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


transactionToken Property

[image]

.NET Framework Class Library
ECCreditService..::.transactionToken Property
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionToken As String
C#
public string transactionToken { get; set; }
Visual C++
public:
property String^ transactionToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionToken();
function set_transactionToken(value);

Remarks

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


ECCreditService Events

[image] [image]

.NET Framework Class Library
ECCreditService Events
ECCreditService Class See Also Send Feedback

The ECCreditService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ECCreditService..::.PropertyChanged Event
ECCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ECCreditService Class
InSite.Domain.CyberSourceService Namespace


ECDebitReply Class

[image]

.NET Framework Class Library
ECDebitReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ECDebitReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ECDebitReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ECDebitReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ECDebitReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ECDebitReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ECDebitReply

See Also

ECDebitReply Members
InSite.Domain.CyberSourceService Namespace


ECDebitReply Members

[image] [image]

.NET Framework Class Library
ECDebitReply Members
ECDebitReply Class Constructors Methods Properties Events See Also Send Feedback

The ECDebitReply type exposes the following members.

Constructors

Name | Description
ECDebitReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
avsCode |
avsCodeRaw |
processorResponse |
processorTransactionID |
reasonCode |
reconciliationID |
requestDateTime |
settlementMethod |
verificationLevel |

Events

Name | Description
PropertyChanged |

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


ECDebitReply Constructor

[image]

.NET Framework Class Library
ECDebitReply Constructor
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ECDebitReply()
Visual C++
public:
ECDebitReply()
JavaScript
InSite.Domain.CyberSourceService.ECDebitReply = function();

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


ECDebitReply Methods

[image] [image]

.NET Framework Class Library
ECDebitReply Methods
ECDebitReply Class See Also Send Feedback

The ECDebitReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ECDebitReply..::.RaisePropertyChanged Method
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


ECDebitReply Properties

[image] [image]

.NET Framework Class Library
ECDebitReply Properties
ECDebitReply Class See Also Send Feedback

The ECDebitReply type exposes the following members.

Properties

Name | Description
amount |
avsCode |
avsCodeRaw |
processorResponse |
processorTransactionID |
reasonCode |
reconciliationID |
requestDateTime |
settlementMethod |
verificationLevel |

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
ECDebitReply..::.amount Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


avsCode Property

[image]

.NET Framework Class Library
ECDebitReply..::.avsCode Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property avsCode As String
C#
public string avsCode { get; set; }
Visual C++
public:
property String^ avsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsCode();
function set_avsCode(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


avsCodeRaw Property

[image]

.NET Framework Class Library
ECDebitReply..::.avsCodeRaw Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property avsCodeRaw As String
C#
public string avsCodeRaw { get; set; }
Visual C++
public:
property String^ avsCodeRaw {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsCodeRaw();
function set_avsCodeRaw(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
ECDebitReply..::.processorResponse Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


processorTransactionID Property

[image]

.NET Framework Class Library
ECDebitReply..::.processorTransactionID Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorTransactionID As String
C#
public string processorTransactionID { get; set; }
Visual C++
public:
property String^ processorTransactionID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorTransactionID();
function set_processorTransactionID(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
ECDebitReply..::.reasonCode Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
ECDebitReply..::.reconciliationID Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
ECDebitReply..::.requestDateTime Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


settlementMethod Property

[image]

.NET Framework Class Library
ECDebitReply..::.settlementMethod Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property settlementMethod As String
C#
public string settlementMethod { get; set; }
Visual C++
public:
property String^ settlementMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_settlementMethod();
function set_settlementMethod(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


verificationLevel Property

[image]

.NET Framework Class Library
ECDebitReply..::.verificationLevel Property
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property verificationLevel As String
C#
public string verificationLevel { get; set; }
Visual C++
public:
property String^ verificationLevel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_verificationLevel();
function set_verificationLevel(value);

Remarks

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


ECDebitReply Events

[image] [image]

.NET Framework Class Library
ECDebitReply Events
ECDebitReply Class See Also Send Feedback

The ECDebitReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ECDebitReply..::.PropertyChanged Event
ECDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ECDebitReply Class
InSite.Domain.CyberSourceService Namespace


ECDebitService Class

[image]

.NET Framework Class Library
ECDebitService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ECDebitService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ECDebitService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ECDebitService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ECDebitService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ECDebitService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ECDebitService

See Also

ECDebitService Members
InSite.Domain.CyberSourceService Namespace


ECDebitService Members

[image] [image]

.NET Framework Class Library
ECDebitService Members
ECDebitService Class Constructors Methods Properties Events See Also Send Feedback

The ECDebitService type exposes the following members.

Constructors

Name | Description
ECDebitService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
commerceIndicator |
partialPaymentID |
paymentMode |
referenceNumber |
run |
settlementMethod |
transactionToken |
verificationLevel |

Events

Name | Description
PropertyChanged |

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


ECDebitService Constructor

[image]

.NET Framework Class Library
ECDebitService Constructor
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ECDebitService()
Visual C++
public:
ECDebitService()
JavaScript
InSite.Domain.CyberSourceService.ECDebitService = function();

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


ECDebitService Methods

[image] [image]

.NET Framework Class Library
ECDebitService Methods
ECDebitService Class See Also Send Feedback

The ECDebitService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ECDebitService..::.RaisePropertyChanged Method
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


ECDebitService Properties

[image] [image]

.NET Framework Class Library
ECDebitService Properties
ECDebitService Class See Also Send Feedback

The ECDebitService type exposes the following members.

Properties

Name | Description
commerceIndicator |
partialPaymentID |
paymentMode |
referenceNumber |
run |
settlementMethod |
transactionToken |
verificationLevel |

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


commerceIndicator Property

[image]

.NET Framework Class Library
ECDebitService..::.commerceIndicator Property
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commerceIndicator As String
C#
public string commerceIndicator { get; set; }
Visual C++
public:
property String^ commerceIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commerceIndicator();
function set_commerceIndicator(value);

Remarks

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


partialPaymentID Property

[image]

.NET Framework Class Library
ECDebitService..::.partialPaymentID Property
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property partialPaymentID As String
C#
public string partialPaymentID { get; set; }
Visual C++
public:
property String^ partialPaymentID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_partialPaymentID();
function set_partialPaymentID(value);

Remarks

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


paymentMode Property

[image]

.NET Framework Class Library
ECDebitService..::.paymentMode Property
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentMode As String
C#
public string paymentMode { get; set; }
Visual C++
public:
property String^ paymentMode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentMode();
function set_paymentMode(value);

Remarks

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


referenceNumber Property

[image]

.NET Framework Class Library
ECDebitService..::.referenceNumber Property
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property referenceNumber As String
C#
public string referenceNumber { get; set; }
Visual C++
public:
property String^ referenceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_referenceNumber();
function set_referenceNumber(value);

Remarks

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
ECDebitService..::.run Property
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


settlementMethod Property

[image]

.NET Framework Class Library
ECDebitService..::.settlementMethod Property
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property settlementMethod As String
C#
public string settlementMethod { get; set; }
Visual C++
public:
property String^ settlementMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_settlementMethod();
function set_settlementMethod(value);

Remarks

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


transactionToken Property

[image]

.NET Framework Class Library
ECDebitService..::.transactionToken Property
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionToken As String
C#
public string transactionToken { get; set; }
Visual C++
public:
property String^ transactionToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionToken();
function set_transactionToken(value);

Remarks

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


verificationLevel Property

[image]

.NET Framework Class Library
ECDebitService..::.verificationLevel Property
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property verificationLevel As String
C#
public string verificationLevel { get; set; }
Visual C++
public:
property String^ verificationLevel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_verificationLevel();
function set_verificationLevel(value);

Remarks

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


ECDebitService Events

[image] [image]

.NET Framework Class Library
ECDebitService Events
ECDebitService Class See Also Send Feedback

The ECDebitService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ECDebitService..::.PropertyChanged Event
ECDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ECDebitService Class
InSite.Domain.CyberSourceService Namespace


ExportReply Class

[image]

.NET Framework Class Library
ExportReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ExportReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ExportReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ExportReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ExportReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ExportReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ExportReply

See Also

ExportReply Members
InSite.Domain.CyberSourceService Namespace


ExportReply Members

[image] [image]

.NET Framework Class Library
ExportReply Members
ExportReply Class Constructors Methods Properties Events See Also Send Feedback

The ExportReply type exposes the following members.

Constructors

Name | Description
ExportReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
infoCode |
ipCountryConfidence |
reasonCode |

Events

Name | Description
PropertyChanged |

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


ExportReply Constructor

[image]

.NET Framework Class Library
ExportReply Constructor
ExportReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExportReply()
Visual C++
public:
ExportReply()
JavaScript
InSite.Domain.CyberSourceService.ExportReply = function();

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


ExportReply Methods

[image] [image]

.NET Framework Class Library
ExportReply Methods
ExportReply Class See Also Send Feedback

The ExportReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ExportReply..::.RaisePropertyChanged Method
ExportReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


ExportReply Properties

[image] [image]

.NET Framework Class Library
ExportReply Properties
ExportReply Class See Also Send Feedback

The ExportReply type exposes the following members.

Properties

Name | Description
infoCode |
ipCountryConfidence |
reasonCode |

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


infoCode Property

[image]

.NET Framework Class Library
ExportReply..::.infoCode Property
ExportReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property infoCode As String
C#
public string infoCode { get; set; }
Visual C++
public:
property String^ infoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_infoCode();
function set_infoCode(value);

Remarks

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


ipCountryConfidence Property

[image]

.NET Framework Class Library
ExportReply..::.ipCountryConfidence Property
ExportReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ipCountryConfidence As String
C#
public string ipCountryConfidence { get; set; }
Visual C++
public:
property String^ ipCountryConfidence {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ipCountryConfidence();
function set_ipCountryConfidence(value);

Remarks

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
ExportReply..::.reasonCode Property
ExportReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


ExportReply Events

[image] [image]

.NET Framework Class Library
ExportReply Events
ExportReply Class See Also Send Feedback

The ExportReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ExportReply..::.PropertyChanged Event
ExportReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ExportReply Class
InSite.Domain.CyberSourceService Namespace


ExportService Class

[image]

.NET Framework Class Library
ExportService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ExportService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ExportService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ExportService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ExportService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ExportService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ExportService

See Also

ExportService Members
InSite.Domain.CyberSourceService Namespace


ExportService Members

[image] [image]

.NET Framework Class Library
ExportService Members
ExportService Class Constructors Methods Properties Events See Also Send Feedback

The ExportService type exposes the following members.

Constructors

Name | Description
ExportService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
addressOperator |
addressWeight |
companyWeight |
nameWeight |
run |

Events

Name | Description
PropertyChanged |

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


ExportService Constructor

[image]

.NET Framework Class Library
ExportService Constructor
ExportService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExportService()
Visual C++
public:
ExportService()
JavaScript
InSite.Domain.CyberSourceService.ExportService = function();

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


ExportService Methods

[image] [image]

.NET Framework Class Library
ExportService Methods
ExportService Class See Also Send Feedback

The ExportService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ExportService..::.RaisePropertyChanged Method
ExportService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


ExportService Properties

[image] [image]

.NET Framework Class Library
ExportService Properties
ExportService Class See Also Send Feedback

The ExportService type exposes the following members.

Properties

Name | Description
addressOperator |
addressWeight |
companyWeight |
nameWeight |
run |

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


addressOperator Property

[image]

.NET Framework Class Library
ExportService..::.addressOperator Property
ExportService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property addressOperator As String
C#
public string addressOperator { get; set; }
Visual C++
public:
property String^ addressOperator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_addressOperator();
function set_addressOperator(value);

Remarks

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


addressWeight Property

[image]

.NET Framework Class Library
ExportService..::.addressWeight Property
ExportService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property addressWeight As String
C#
public string addressWeight { get; set; }
Visual C++
public:
property String^ addressWeight {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_addressWeight();
function set_addressWeight(value);

Remarks

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


companyWeight Property

[image]

.NET Framework Class Library
ExportService..::.companyWeight Property
ExportService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property companyWeight As String
C#
public string companyWeight { get; set; }
Visual C++
public:
property String^ companyWeight {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_companyWeight();
function set_companyWeight(value);

Remarks

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


nameWeight Property

[image]

.NET Framework Class Library
ExportService..::.nameWeight Property
ExportService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property nameWeight As String
C#
public string nameWeight { get; set; }
Visual C++
public:
property String^ nameWeight {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nameWeight();
function set_nameWeight(value);

Remarks

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
ExportService..::.run Property
ExportService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


ExportService Events

[image] [image]

.NET Framework Class Library
ExportService Events
ExportService Class See Also Send Feedback

The ExportService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ExportService..::.PropertyChanged Event
ExportService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ExportService Class
InSite.Domain.CyberSourceService Namespace


FundingTotals Class

[image]

.NET Framework Class Library
FundingTotals Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class FundingTotals _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class FundingTotals : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class FundingTotals : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.FundingTotals = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.FundingTotals',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.FundingTotals

See Also

FundingTotals Members
InSite.Domain.CyberSourceService Namespace


FundingTotals Members

[image] [image]

.NET Framework Class Library
FundingTotals Members
FundingTotals Class Constructors Methods Properties Events See Also Send Feedback

The FundingTotals type exposes the following members.

Constructors

Name | Description
FundingTotals |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
currency |
grandTotalAmount |

Events

Name | Description
PropertyChanged |

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


FundingTotals Constructor

[image]

.NET Framework Class Library
FundingTotals Constructor
FundingTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FundingTotals()
Visual C++
public:
FundingTotals()
JavaScript
InSite.Domain.CyberSourceService.FundingTotals = function();

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


FundingTotals Methods

[image] [image]

.NET Framework Class Library
FundingTotals Methods
FundingTotals Class See Also Send Feedback

The FundingTotals type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
FundingTotals..::.RaisePropertyChanged Method
FundingTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


FundingTotals Properties

[image] [image]

.NET Framework Class Library
FundingTotals Properties
FundingTotals Class See Also Send Feedback

The FundingTotals type exposes the following members.

Properties

Name | Description
currency |
grandTotalAmount |

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
FundingTotals..::.currency Property
FundingTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


grandTotalAmount Property

[image]

.NET Framework Class Library
FundingTotals..::.grandTotalAmount Property
FundingTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property grandTotalAmount As String
C#
public string grandTotalAmount { get; set; }
Visual C++
public:
property String^ grandTotalAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_grandTotalAmount();
function set_grandTotalAmount(value);

Remarks

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


FundingTotals Events

[image] [image]

.NET Framework Class Library
FundingTotals Events
FundingTotals Class See Also Send Feedback

The FundingTotals type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
FundingTotals..::.PropertyChanged Event
FundingTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

FundingTotals Class
InSite.Domain.CyberSourceService Namespace


FundTransfer Class

[image]

.NET Framework Class Library
FundTransfer Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class FundTransfer _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class FundTransfer : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class FundTransfer : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.FundTransfer = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.FundTransfer',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.FundTransfer

See Also

FundTransfer Members
InSite.Domain.CyberSourceService Namespace


FundTransfer Members

[image] [image]

.NET Framework Class Library
FundTransfer Members
FundTransfer Class Constructors Methods Properties Events See Also Send Feedback

The FundTransfer type exposes the following members.

Constructors

Name | Description
FundTransfer |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
accountName |
accountNumber |
bankCheckDigit |
iban |

Events

Name | Description
PropertyChanged |

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


FundTransfer Constructor

[image]

.NET Framework Class Library
FundTransfer Constructor
FundTransfer Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FundTransfer()
Visual C++
public:
FundTransfer()
JavaScript
InSite.Domain.CyberSourceService.FundTransfer = function();

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


FundTransfer Methods

[image] [image]

.NET Framework Class Library
FundTransfer Methods
FundTransfer Class See Also Send Feedback

The FundTransfer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
FundTransfer..::.RaisePropertyChanged Method
FundTransfer Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


FundTransfer Properties

[image] [image]

.NET Framework Class Library
FundTransfer Properties
FundTransfer Class See Also Send Feedback

The FundTransfer type exposes the following members.

Properties

Name | Description
accountName |
accountNumber |
bankCheckDigit |
iban |

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


accountName Property

[image]

.NET Framework Class Library
FundTransfer..::.accountName Property
FundTransfer Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountName As String
C#
public string accountName { get; set; }
Visual C++
public:
property String^ accountName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountName();
function set_accountName(value);

Remarks

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


accountNumber Property

[image]

.NET Framework Class Library
FundTransfer..::.accountNumber Property
FundTransfer Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property accountNumber As String
C#
public string accountNumber { get; set; }
Visual C++
public:
property String^ accountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


bankCheckDigit Property

[image]

.NET Framework Class Library
FundTransfer..::.bankCheckDigit Property
FundTransfer Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankCheckDigit As String
C#
public string bankCheckDigit { get; set; }
Visual C++
public:
property String^ bankCheckDigit {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankCheckDigit();
function set_bankCheckDigit(value);

Remarks

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


iban Property

[image]

.NET Framework Class Library
FundTransfer..::.iban Property
FundTransfer Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property iban As String
C#
public string iban { get; set; }
Visual C++
public:
property String^ iban {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_iban();
function set_iban(value);

Remarks

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


FundTransfer Events

[image] [image]

.NET Framework Class Library
FundTransfer Events
FundTransfer Class See Also Send Feedback

The FundTransfer type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
FundTransfer..::.PropertyChanged Event
FundTransfer Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

FundTransfer Class
InSite.Domain.CyberSourceService Namespace


FXQuote Class

[image]

.NET Framework Class Library
FXQuote Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class FXQuote _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class FXQuote : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class FXQuote : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.FXQuote = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.FXQuote',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.FXQuote

See Also

FXQuote Members
InSite.Domain.CyberSourceService Namespace


FXQuote Members

[image] [image]

.NET Framework Class Library
FXQuote Members
FXQuote Class Constructors Methods Properties Events See Also Send Feedback

The FXQuote type exposes the following members.

Constructors

Name | Description
FXQuote |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
currency |
expirationDateTime |
fundingCurrency |
id |
rate |
receivedDateTime |
type |

Events

Name | Description
PropertyChanged |

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


FXQuote Constructor

[image]

.NET Framework Class Library
FXQuote Constructor
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FXQuote()
Visual C++
public:
FXQuote()
JavaScript
InSite.Domain.CyberSourceService.FXQuote = function();

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


FXQuote Methods

[image] [image]

.NET Framework Class Library
FXQuote Methods
FXQuote Class See Also Send Feedback

The FXQuote type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
FXQuote..::.RaisePropertyChanged Method
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


FXQuote Properties

[image] [image]

.NET Framework Class Library
FXQuote Properties
FXQuote Class See Also Send Feedback

The FXQuote type exposes the following members.

Properties

Name | Description
currency |
expirationDateTime |
fundingCurrency |
id |
rate |
receivedDateTime |
type |

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
FXQuote..::.currency Property
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


expirationDateTime Property

[image]

.NET Framework Class Library
FXQuote..::.expirationDateTime Property
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property expirationDateTime As String
C#
public string expirationDateTime { get; set; }
Visual C++
public:
property String^ expirationDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationDateTime();
function set_expirationDateTime(value);

Remarks

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


fundingCurrency Property

[image]

.NET Framework Class Library
FXQuote..::.fundingCurrency Property
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fundingCurrency As String
C#
public string fundingCurrency { get; set; }
Visual C++
public:
property String^ fundingCurrency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fundingCurrency();
function set_fundingCurrency(value);

Remarks

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


id Property

[image]

.NET Framework Class Library
FXQuote..::.id Property
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property id As String
C#
public string id { get; set; }
Visual C++
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


rate Property

[image]

.NET Framework Class Library
FXQuote..::.rate Property
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property rate As String
C#
public string rate { get; set; }
Visual C++
public:
property String^ rate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_rate();
function set_rate(value);

Remarks

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


receivedDateTime Property

[image]

.NET Framework Class Library
FXQuote..::.receivedDateTime Property
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property receivedDateTime As String
C#
public string receivedDateTime { get; set; }
Visual C++
public:
property String^ receivedDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_receivedDateTime();
function set_receivedDateTime(value);

Remarks

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


type Property

[image]

.NET Framework Class Library
FXQuote..::.type Property
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property type As String
C#
public string type { get; set; }
Visual C++
public:
property String^ type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


FXQuote Events

[image] [image]

.NET Framework Class Library
FXQuote Events
FXQuote Class See Also Send Feedback

The FXQuote type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
FXQuote..::.PropertyChanged Event
FXQuote Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

FXQuote Class
InSite.Domain.CyberSourceService Namespace


FXRatesReply Class

[image]

.NET Framework Class Library
FXRatesReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class FXRatesReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class FXRatesReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class FXRatesReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.FXRatesReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.FXRatesReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.FXRatesReply

See Also

FXRatesReply Members
InSite.Domain.CyberSourceService Namespace


FXRatesReply Members

[image] [image]

.NET Framework Class Library
FXRatesReply Members
FXRatesReply Class Constructors Methods Properties Events See Also Send Feedback

The FXRatesReply type exposes the following members.

Constructors

Name | Description
FXRatesReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
quote |
reasonCode |

Events

Name | Description
PropertyChanged |

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


FXRatesReply Constructor

[image]

.NET Framework Class Library
FXRatesReply Constructor
FXRatesReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FXRatesReply()
Visual C++
public:
FXRatesReply()
JavaScript
InSite.Domain.CyberSourceService.FXRatesReply = function();

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


FXRatesReply Methods

[image] [image]

.NET Framework Class Library
FXRatesReply Methods
FXRatesReply Class See Also Send Feedback

The FXRatesReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
FXRatesReply..::.RaisePropertyChanged Method
FXRatesReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


FXRatesReply Properties

[image] [image]

.NET Framework Class Library
FXRatesReply Properties
FXRatesReply Class See Also Send Feedback

The FXRatesReply type exposes the following members.

Properties

Name | Description
quote |
reasonCode |

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


quote Property

[image]

.NET Framework Class Library
FXRatesReply..::.quote Property
FXRatesReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property quote As FXQuote()
C#
public FXQuote[] quote { get; set; }
Visual C++
public:
property array<FXQuote^>^ quote {
    array<FXQuote^>^ get ();
    void set (array<FXQuote^>^ value);
}
JavaScript
function get_quote();
function set_quote(value);

Remarks

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
FXRatesReply..::.reasonCode Property
FXRatesReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


FXRatesReply Events

[image] [image]

.NET Framework Class Library
FXRatesReply Events
FXRatesReply Class See Also Send Feedback

The FXRatesReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
FXRatesReply..::.PropertyChanged Event
FXRatesReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

FXRatesReply Class
InSite.Domain.CyberSourceService Namespace


FXRatesService Class

[image]

.NET Framework Class Library
FXRatesService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class FXRatesService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class FXRatesService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class FXRatesService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.FXRatesService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.FXRatesService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.FXRatesService

See Also

FXRatesService Members
InSite.Domain.CyberSourceService Namespace


FXRatesService Members

[image] [image]

.NET Framework Class Library
FXRatesService Members
FXRatesService Class Constructors Methods Properties Events See Also Send Feedback

The FXRatesService type exposes the following members.

Constructors

Name | Description
FXRatesService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |

Events

Name | Description
PropertyChanged |

See Also

FXRatesService Class
InSite.Domain.CyberSourceService Namespace


FXRatesService Constructor

[image]

.NET Framework Class Library
FXRatesService Constructor
FXRatesService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FXRatesService()
Visual C++
public:
FXRatesService()
JavaScript
InSite.Domain.CyberSourceService.FXRatesService = function();

See Also

FXRatesService Class
InSite.Domain.CyberSourceService Namespace


FXRatesService Methods

[image] [image]

.NET Framework Class Library
FXRatesService Methods
FXRatesService Class See Also Send Feedback

The FXRatesService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FXRatesService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
FXRatesService..::.RaisePropertyChanged Method
FXRatesService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

FXRatesService Class
InSite.Domain.CyberSourceService Namespace


FXRatesService Properties

[image] [image]

.NET Framework Class Library
FXRatesService Properties
FXRatesService Class See Also Send Feedback

The FXRatesService type exposes the following members.

Properties

Name | Description
run |

See Also

FXRatesService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
FXRatesService..::.run Property
FXRatesService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

FXRatesService Class
InSite.Domain.CyberSourceService Namespace


FXRatesService Events

[image] [image]

.NET Framework Class Library
FXRatesService Events
FXRatesService Class See Also Send Feedback

The FXRatesService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

FXRatesService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
FXRatesService..::.PropertyChanged Event
FXRatesService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

FXRatesService Class
InSite.Domain.CyberSourceService Namespace


GECC Class

[image]

.NET Framework Class Library
GECC Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class GECC _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class GECC : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class GECC : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.GECC = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.GECC',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.GECC

See Also

GECC Members
InSite.Domain.CyberSourceService Namespace


GECC Members

[image] [image]

.NET Framework Class Library
GECC Members
GECC Class Constructors Methods Properties Events See Also Send Feedback

The GECC type exposes the following members.

Constructors

Name | Description
GECC |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
line |
planNumber |
promotionEndDate |
promotionPlan |
saleType |
sequenceNumber |

Events

Name | Description
PropertyChanged |

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


GECC Constructor

[image]

.NET Framework Class Library
GECC Constructor
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GECC()
Visual C++
public:
GECC()
JavaScript
InSite.Domain.CyberSourceService.GECC = function();

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


GECC Methods

[image] [image]

.NET Framework Class Library
GECC Methods
GECC Class See Also Send Feedback

The GECC type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
GECC..::.RaisePropertyChanged Method
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


GECC Properties

[image] [image]

.NET Framework Class Library
GECC Properties
GECC Class See Also Send Feedback

The GECC type exposes the following members.

Properties

Name | Description
line |
planNumber |
promotionEndDate |
promotionPlan |
saleType |
sequenceNumber |

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


line Property

[image]

.NET Framework Class Library
GECC..::.line Property
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property line As String()
C#
public string[] line { get; set; }
Visual C++
public:
property array<String^>^ line {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_line();
function set_line(value);

Remarks

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


planNumber Property

[image]

.NET Framework Class Library
GECC..::.planNumber Property
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property planNumber As String
C#
public string planNumber { get; set; }
Visual C++
public:
property String^ planNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_planNumber();
function set_planNumber(value);

Remarks

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


promotionEndDate Property

[image]

.NET Framework Class Library
GECC..::.promotionEndDate Property
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property promotionEndDate As String
C#
public string promotionEndDate { get; set; }
Visual C++
public:
property String^ promotionEndDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_promotionEndDate();
function set_promotionEndDate(value);

Remarks

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


promotionPlan Property

[image]

.NET Framework Class Library
GECC..::.promotionPlan Property
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property promotionPlan As String
C#
public string promotionPlan { get; set; }
Visual C++
public:
property String^ promotionPlan {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_promotionPlan();
function set_promotionPlan(value);

Remarks

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


saleType Property

[image]

.NET Framework Class Library
GECC..::.saleType Property
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property saleType As String
C#
public string saleType { get; set; }
Visual C++
public:
property String^ saleType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_saleType();
function set_saleType(value);

Remarks

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


sequenceNumber Property

[image]

.NET Framework Class Library
GECC..::.sequenceNumber Property
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property sequenceNumber As String
C#
public string sequenceNumber { get; set; }
Visual C++
public:
property String^ sequenceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_sequenceNumber();
function set_sequenceNumber(value);

Remarks

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


GECC Events

[image] [image]

.NET Framework Class Library
GECC Events
GECC Class See Also Send Feedback

The GECC type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
GECC..::.PropertyChanged Event
GECC Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

GECC Class
InSite.Domain.CyberSourceService Namespace


inputMessageIn Class

[image]

.NET Framework Class Library
inputMessageIn Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<MessageContractAttribute(IsWrapped := False)> _
<GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")> _
Public Class inputMessageIn
C#
[MessageContractAttribute(IsWrapped = false)]
[GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
public class inputMessageIn
Visual C++
[MessageContractAttribute(IsWrapped = false)]
[GeneratedCodeAttribute(L"System.ServiceModel", L"3.0.0.0")]
public ref class inputMessageIn
JavaScript
InSite.Domain.CyberSourceService.inputMessageIn = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.inputMessageIn');

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.inputMessageIn

See Also

inputMessageIn Members
InSite.Domain.CyberSourceService Namespace


inputMessageIn Members

[image] [image]

.NET Framework Class Library
inputMessageIn Members
inputMessageIn Class Constructors Methods Fields See Also Send Feedback

The inputMessageIn type exposes the following members.

Constructors

Name | Description
inputMessageIn | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
requestMessage |

See Also

inputMessageIn Class
InSite.Domain.CyberSourceService Namespace


inputMessageIn Constructor

[image] [image]

.NET Framework Class Library
inputMessageIn Constructor
inputMessageIn Class See Also Send Feedback

Overload List

Name | Description
inputMessageIn()()() |
inputMessageIn(RequestMessage) |

See Also

inputMessageIn Class
inputMessageIn Members
InSite.Domain.CyberSourceService Namespace


inputMessageIn Constructor

[image]

.NET Framework Class Library
inputMessageIn Constructor
inputMessageIn Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public inputMessageIn()
Visual C++
public:
inputMessageIn()
JavaScript
InSite.Domain.CyberSourceService.inputMessageIn = function();

See Also

inputMessageIn Class
inputMessageIn Overload
InSite.Domain.CyberSourceService Namespace


inputMessageIn Constructor (RequestMessage)

[image]

.NET Framework Class Library
inputMessageIn Constructor (RequestMessage)
inputMessageIn Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    requestMessage As RequestMessage _
)
C#
public inputMessageIn(
    RequestMessage requestMessage
)
Visual C++
public:
inputMessageIn(
    RequestMessage^ requestMessage
)
JavaScript
InSite.Domain.CyberSourceService.inputMessageIn = function(requestMessage);

Parameters

requestMessage
Type: InSite.Domain.CyberSourceService..::.RequestMessage

See Also

inputMessageIn Class
inputMessageIn Overload
InSite.Domain.CyberSourceService Namespace


inputMessageIn Fields

[image] [image]

.NET Framework Class Library
inputMessageIn Fields
inputMessageIn Class See Also Send Feedback

The inputMessageIn type exposes the following members.

Fields

Name | Description
requestMessage |

See Also

inputMessageIn Class
InSite.Domain.CyberSourceService Namespace


requestMessage Field

[image]

.NET Framework Class Library
inputMessageIn..::.requestMessage Field
inputMessageIn Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<MessageBodyMemberAttribute(Namespace := "urn:schemas-cybersource-com:transaction-data-1.42",  _
    Order := )> _
Public requestMessage As RequestMessage
C#
[MessageBodyMemberAttribute(Namespace = "urn:schemas-cybersource-com:transaction-data-1.42",
    Order = )]
public RequestMessage requestMessage
Visual C++
[MessageBodyMemberAttribute(Namespace = L"urn:schemas-cybersource-com:transaction-data-1.42",
    Order = )]
public:
RequestMessage^ requestMessage
JavaScript
requestMessage

See Also

inputMessageIn Class
InSite.Domain.CyberSourceService Namespace


inputMessageIn Methods

[image] [image]

.NET Framework Class Library
inputMessageIn Methods
inputMessageIn Class See Also Send Feedback

The inputMessageIn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

inputMessageIn Class
InSite.Domain.CyberSourceService Namespace


Installment Class

[image]

.NET Framework Class Library
Installment Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Installment _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Installment : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Installment : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Installment = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Installment',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Installment

See Also

Installment Members
InSite.Domain.CyberSourceService Namespace


Installment Members

[image] [image]

.NET Framework Class Library
Installment Members
Installment Class Constructors Methods Properties Events See Also Send Feedback

The Installment type exposes the following members.

Constructors

Name | Description
Installment |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
sequence |
totalCount |

Events

Name | Description
PropertyChanged |

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


Installment Constructor

[image]

.NET Framework Class Library
Installment Constructor
Installment Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Installment()
Visual C++
public:
Installment()
JavaScript
InSite.Domain.CyberSourceService.Installment = function();

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


Installment Methods

[image] [image]

.NET Framework Class Library
Installment Methods
Installment Class See Also Send Feedback

The Installment type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Installment..::.RaisePropertyChanged Method
Installment Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


Installment Properties

[image] [image]

.NET Framework Class Library
Installment Properties
Installment Class See Also Send Feedback

The Installment type exposes the following members.

Properties

Name | Description
sequence |
totalCount |

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


sequence Property

[image]

.NET Framework Class Library
Installment..::.sequence Property
Installment Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property sequence As String
C#
public string sequence { get; set; }
Visual C++
public:
property String^ sequence {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_sequence();
function set_sequence(value);

Remarks

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


totalCount Property

[image]

.NET Framework Class Library
Installment..::.totalCount Property
Installment Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalCount As String
C#
public string totalCount { get; set; }
Visual C++
public:
property String^ totalCount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalCount();
function set_totalCount(value);

Remarks

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


Installment Events

[image] [image]

.NET Framework Class Library
Installment Events
Installment Class See Also Send Feedback

The Installment type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Installment..::.PropertyChanged Event
Installment Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Installment Class
InSite.Domain.CyberSourceService Namespace


InvoiceHeader Class

[image]

.NET Framework Class Library
InvoiceHeader Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class InvoiceHeader _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class InvoiceHeader : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class InvoiceHeader : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.InvoiceHeader = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.InvoiceHeader',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.InvoiceHeader

See Also

InvoiceHeader Members
InSite.Domain.CyberSourceService Namespace


InvoiceHeader Members

[image] [image]

.NET Framework Class Library
InvoiceHeader Members
InvoiceHeader Class Constructors Methods Properties Events See Also Send Feedback

The InvoiceHeader type exposes the following members.

Constructors

Name | Description
InvoiceHeader |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amexDataTAA1 |
amexDataTAA2 |
amexDataTAA3 |
amexDataTAA4 |
costCenter |
invoiceDate |
isGift |
merchantDescriptor |
merchantDescriptorAlternate |
merchantDescriptorContact |
merchantVATRegistrationNumber |
purchaserCode |
purchaserOrderDate |
purchaserVATRegistrationNumber |
returnsAccepted |
summaryCommodityCode |
supplierOrderReference |
taxable |
tenderType |
userPO |
vatInvoiceReferenceNumber |

Events

Name | Description
PropertyChanged |

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


InvoiceHeader Constructor

[image]

.NET Framework Class Library
InvoiceHeader Constructor
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InvoiceHeader()
Visual C++
public:
InvoiceHeader()
JavaScript
InSite.Domain.CyberSourceService.InvoiceHeader = function();

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


InvoiceHeader Methods

[image] [image]

.NET Framework Class Library
InvoiceHeader Methods
InvoiceHeader Class See Also Send Feedback

The InvoiceHeader type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
InvoiceHeader..::.RaisePropertyChanged Method
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


InvoiceHeader Properties

[image] [image]

.NET Framework Class Library
InvoiceHeader Properties
InvoiceHeader Class See Also Send Feedback

The InvoiceHeader type exposes the following members.

Properties

Name | Description
amexDataTAA1 |
amexDataTAA2 |
amexDataTAA3 |
amexDataTAA4 |
costCenter |
invoiceDate |
isGift |
merchantDescriptor |
merchantDescriptorAlternate |
merchantDescriptorContact |
merchantVATRegistrationNumber |
purchaserCode |
purchaserOrderDate |
purchaserVATRegistrationNumber |
returnsAccepted |
summaryCommodityCode |
supplierOrderReference |
taxable |
tenderType |
userPO |
vatInvoiceReferenceNumber |

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


amexDataTAA1 Property

[image]

.NET Framework Class Library
InvoiceHeader..::.amexDataTAA1 Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amexDataTAA1 As String
C#
public string amexDataTAA1 { get; set; }
Visual C++
public:
property String^ amexDataTAA1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amexDataTAA1();
function set_amexDataTAA1(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


amexDataTAA2 Property

[image]

.NET Framework Class Library
InvoiceHeader..::.amexDataTAA2 Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amexDataTAA2 As String
C#
public string amexDataTAA2 { get; set; }
Visual C++
public:
property String^ amexDataTAA2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amexDataTAA2();
function set_amexDataTAA2(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


amexDataTAA3 Property

[image]

.NET Framework Class Library
InvoiceHeader..::.amexDataTAA3 Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amexDataTAA3 As String
C#
public string amexDataTAA3 { get; set; }
Visual C++
public:
property String^ amexDataTAA3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amexDataTAA3();
function set_amexDataTAA3(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


amexDataTAA4 Property

[image]

.NET Framework Class Library
InvoiceHeader..::.amexDataTAA4 Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amexDataTAA4 As String
C#
public string amexDataTAA4 { get; set; }
Visual C++
public:
property String^ amexDataTAA4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amexDataTAA4();
function set_amexDataTAA4(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


costCenter Property

[image]

.NET Framework Class Library
InvoiceHeader..::.costCenter Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property costCenter As String
C#
public string costCenter { get; set; }
Visual C++
public:
property String^ costCenter {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_costCenter();
function set_costCenter(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


invoiceDate Property

[image]

.NET Framework Class Library
InvoiceHeader..::.invoiceDate Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceDate As String
C#
public string invoiceDate { get; set; }
Visual C++
public:
property String^ invoiceDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceDate();
function set_invoiceDate(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


isGift Property

[image]

.NET Framework Class Library
InvoiceHeader..::.isGift Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property isGift As String
C#
public string isGift { get; set; }
Visual C++
public:
property String^ isGift {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_isGift();
function set_isGift(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


merchantDescriptor Property

[image]

.NET Framework Class Library
InvoiceHeader..::.merchantDescriptor Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantDescriptor As String
C#
public string merchantDescriptor { get; set; }
Visual C++
public:
property String^ merchantDescriptor {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantDescriptor();
function set_merchantDescriptor(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


merchantDescriptorAlternate Property

[image]

.NET Framework Class Library
InvoiceHeader..::.merchantDescriptorAlternate Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantDescriptorAlternate As String
C#
public string merchantDescriptorAlternate { get; set; }
Visual C++
public:
property String^ merchantDescriptorAlternate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantDescriptorAlternate();
function set_merchantDescriptorAlternate(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


merchantDescriptorContact Property

[image]

.NET Framework Class Library
InvoiceHeader..::.merchantDescriptorContact Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantDescriptorContact As String
C#
public string merchantDescriptorContact { get; set; }
Visual C++
public:
property String^ merchantDescriptorContact {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantDescriptorContact();
function set_merchantDescriptorContact(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


merchantVATRegistrationNumber Property

[image]

.NET Framework Class Library
InvoiceHeader..::.merchantVATRegistrationNumber Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantVATRegistrationNumber As String
C#
public string merchantVATRegistrationNumber { get; set; }
Visual C++
public:
property String^ merchantVATRegistrationNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantVATRegistrationNumber();
function set_merchantVATRegistrationNumber(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


purchaserCode Property

[image]

.NET Framework Class Library
InvoiceHeader..::.purchaserCode Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchaserCode As String
C#
public string purchaserCode { get; set; }
Visual C++
public:
property String^ purchaserCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchaserCode();
function set_purchaserCode(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


purchaserOrderDate Property

[image]

.NET Framework Class Library
InvoiceHeader..::.purchaserOrderDate Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchaserOrderDate As String
C#
public string purchaserOrderDate { get; set; }
Visual C++
public:
property String^ purchaserOrderDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchaserOrderDate();
function set_purchaserOrderDate(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


purchaserVATRegistrationNumber Property

[image]

.NET Framework Class Library
InvoiceHeader..::.purchaserVATRegistrationNumber Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchaserVATRegistrationNumber As String
C#
public string purchaserVATRegistrationNumber { get; set; }
Visual C++
public:
property String^ purchaserVATRegistrationNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchaserVATRegistrationNumber();
function set_purchaserVATRegistrationNumber(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


returnsAccepted Property

[image]

.NET Framework Class Library
InvoiceHeader..::.returnsAccepted Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property returnsAccepted As String
C#
public string returnsAccepted { get; set; }
Visual C++
public:
property String^ returnsAccepted {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_returnsAccepted();
function set_returnsAccepted(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


summaryCommodityCode Property

[image]

.NET Framework Class Library
InvoiceHeader..::.summaryCommodityCode Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property summaryCommodityCode As String
C#
public string summaryCommodityCode { get; set; }
Visual C++
public:
property String^ summaryCommodityCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_summaryCommodityCode();
function set_summaryCommodityCode(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


supplierOrderReference Property

[image]

.NET Framework Class Library
InvoiceHeader..::.supplierOrderReference Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property supplierOrderReference As String
C#
public string supplierOrderReference { get; set; }
Visual C++
public:
property String^ supplierOrderReference {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_supplierOrderReference();
function set_supplierOrderReference(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


taxable Property

[image]

.NET Framework Class Library
InvoiceHeader..::.taxable Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxable As String
C#
public string taxable { get; set; }
Visual C++
public:
property String^ taxable {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxable();
function set_taxable(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


tenderType Property

[image]

.NET Framework Class Library
InvoiceHeader..::.tenderType Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property tenderType As String
C#
public string tenderType { get; set; }
Visual C++
public:
property String^ tenderType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_tenderType();
function set_tenderType(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


userPO Property

[image]

.NET Framework Class Library
InvoiceHeader..::.userPO Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property userPO As String
C#
public string userPO { get; set; }
Visual C++
public:
property String^ userPO {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_userPO();
function set_userPO(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


vatInvoiceReferenceNumber Property

[image]

.NET Framework Class Library
InvoiceHeader..::.vatInvoiceReferenceNumber Property
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property vatInvoiceReferenceNumber As String
C#
public string vatInvoiceReferenceNumber { get; set; }
Visual C++
public:
property String^ vatInvoiceReferenceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vatInvoiceReferenceNumber();
function set_vatInvoiceReferenceNumber(value);

Remarks

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


InvoiceHeader Events

[image] [image]

.NET Framework Class Library
InvoiceHeader Events
InvoiceHeader Class See Also Send Feedback

The InvoiceHeader type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
InvoiceHeader..::.PropertyChanged Event
InvoiceHeader Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

InvoiceHeader Class
InSite.Domain.CyberSourceService Namespace


Item Class

[image]

.NET Framework Class Library
Item Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Item _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Item : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Item : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Item = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Item',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Item

See Also

Item Members
InSite.Domain.CyberSourceService Namespace


Item Members

[image] [image]

.NET Framework Class Library
Item Members
Item Class Constructors Methods Properties Events See Also Send Feedback

The Item type exposes the following members.

Constructors

Name | Description
Item |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
alternateTaxAmount |
alternateTaxID |
alternateTaxRate |
alternateTaxType |
alternateTaxTypeApplied |
buyerRegistration |
cityOverrideAmount |
cityOverrideRate |
commodityCode |
countryOverrideAmount |
countryOverrideRate |
countyOverrideAmount |
countyOverrideRate |
discountAmount |
discountIndicator |
discountRate |
districtOverrideAmount |
districtOverrideRate |
export |
giftCategory |
grossNetIndicator |
hostHedge |
id |
localTax |
middlemanRegistration |
nationalTax |
noExport |
nonsensicalHedge |
obscenitiesHedge |
orderAcceptanceCity |
orderAcceptanceCountry |
orderAcceptanceCounty |
orderAcceptancePostalCode |
orderAcceptanceState |
orderOriginCity |
orderOriginCountry |
orderOriginCounty |
orderOriginPostalCode |
orderOriginState |
phoneHedge |
pointOfTitleTransfer |
productCode |
productName |
productRisk |
productSKU |
quantity |
sellerRegistration |
shipFromCity |
shipFromCountry |
shipFromCounty |
shipFromPostalCode |
shipFromState |
stateOverrideAmount |
stateOverrideRate |
taxAmount |
taxRate |
taxTypeApplied |
timeCategory |
timeHedge |
totalAmount |
unitOfMeasure |
unitPrice |
vatRate |
velocityHedge |
zeroCostToCustomerIndicator |

Events

Name | Description
PropertyChanged |

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


Item Constructor

[image]

.NET Framework Class Library
Item Constructor
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Item()
Visual C++
public:
Item()
JavaScript
InSite.Domain.CyberSourceService.Item = function();

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


Item Methods

[image] [image]

.NET Framework Class Library
Item Methods
Item Class See Also Send Feedback

The Item type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Item..::.RaisePropertyChanged Method
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


Item Properties

[image] [image]

.NET Framework Class Library
Item Properties
Item Class See Also Send Feedback

The Item type exposes the following members.

Properties

Name | Description
alternateTaxAmount |
alternateTaxID |
alternateTaxRate |
alternateTaxType |
alternateTaxTypeApplied |
buyerRegistration |
cityOverrideAmount |
cityOverrideRate |
commodityCode |
countryOverrideAmount |
countryOverrideRate |
countyOverrideAmount |
countyOverrideRate |
discountAmount |
discountIndicator |
discountRate |
districtOverrideAmount |
districtOverrideRate |
export |
giftCategory |
grossNetIndicator |
hostHedge |
id |
localTax |
middlemanRegistration |
nationalTax |
noExport |
nonsensicalHedge |
obscenitiesHedge |
orderAcceptanceCity |
orderAcceptanceCountry |
orderAcceptanceCounty |
orderAcceptancePostalCode |
orderAcceptanceState |
orderOriginCity |
orderOriginCountry |
orderOriginCounty |
orderOriginPostalCode |
orderOriginState |
phoneHedge |
pointOfTitleTransfer |
productCode |
productName |
productRisk |
productSKU |
quantity |
sellerRegistration |
shipFromCity |
shipFromCountry |
shipFromCounty |
shipFromPostalCode |
shipFromState |
stateOverrideAmount |
stateOverrideRate |
taxAmount |
taxRate |
taxTypeApplied |
timeCategory |
timeHedge |
totalAmount |
unitOfMeasure |
unitPrice |
vatRate |
velocityHedge |
zeroCostToCustomerIndicator |

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


alternateTaxAmount Property

[image]

.NET Framework Class Library
Item..::.alternateTaxAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateTaxAmount As String
C#
public string alternateTaxAmount { get; set; }
Visual C++
public:
property String^ alternateTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateTaxAmount();
function set_alternateTaxAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


alternateTaxID Property

[image]

.NET Framework Class Library
Item..::.alternateTaxID Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateTaxID As String
C#
public string alternateTaxID { get; set; }
Visual C++
public:
property String^ alternateTaxID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateTaxID();
function set_alternateTaxID(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


alternateTaxRate Property

[image]

.NET Framework Class Library
Item..::.alternateTaxRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateTaxRate As String
C#
public string alternateTaxRate { get; set; }
Visual C++
public:
property String^ alternateTaxRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateTaxRate();
function set_alternateTaxRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


alternateTaxType Property

[image]

.NET Framework Class Library
Item..::.alternateTaxType Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateTaxType As String
C#
public string alternateTaxType { get; set; }
Visual C++
public:
property String^ alternateTaxType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateTaxType();
function set_alternateTaxType(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


alternateTaxTypeApplied Property

[image]

.NET Framework Class Library
Item..::.alternateTaxTypeApplied Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateTaxTypeApplied As String
C#
public string alternateTaxTypeApplied { get; set; }
Visual C++
public:
property String^ alternateTaxTypeApplied {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateTaxTypeApplied();
function set_alternateTaxTypeApplied(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


buyerRegistration Property

[image]

.NET Framework Class Library
Item..::.buyerRegistration Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property buyerRegistration As String
C#
public string buyerRegistration { get; set; }
Visual C++
public:
property String^ buyerRegistration {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_buyerRegistration();
function set_buyerRegistration(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


cityOverrideAmount Property

[image]

.NET Framework Class Library
Item..::.cityOverrideAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cityOverrideAmount As String
C#
public string cityOverrideAmount { get; set; }
Visual C++
public:
property String^ cityOverrideAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cityOverrideAmount();
function set_cityOverrideAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


cityOverrideRate Property

[image]

.NET Framework Class Library
Item..::.cityOverrideRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cityOverrideRate As String
C#
public string cityOverrideRate { get; set; }
Visual C++
public:
property String^ cityOverrideRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cityOverrideRate();
function set_cityOverrideRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


commodityCode Property

[image]

.NET Framework Class Library
Item..::.commodityCode Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commodityCode As String
C#
public string commodityCode { get; set; }
Visual C++
public:
property String^ commodityCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commodityCode();
function set_commodityCode(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


countryOverrideAmount Property

[image]

.NET Framework Class Library
Item..::.countryOverrideAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countryOverrideAmount As String
C#
public string countryOverrideAmount { get; set; }
Visual C++
public:
property String^ countryOverrideAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryOverrideAmount();
function set_countryOverrideAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


countryOverrideRate Property

[image]

.NET Framework Class Library
Item..::.countryOverrideRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countryOverrideRate As String
C#
public string countryOverrideRate { get; set; }
Visual C++
public:
property String^ countryOverrideRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryOverrideRate();
function set_countryOverrideRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


countyOverrideAmount Property

[image]

.NET Framework Class Library
Item..::.countyOverrideAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countyOverrideAmount As String
C#
public string countyOverrideAmount { get; set; }
Visual C++
public:
property String^ countyOverrideAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countyOverrideAmount();
function set_countyOverrideAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


countyOverrideRate Property

[image]

.NET Framework Class Library
Item..::.countyOverrideRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countyOverrideRate As String
C#
public string countyOverrideRate { get; set; }
Visual C++
public:
property String^ countyOverrideRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countyOverrideRate();
function set_countyOverrideRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


discountAmount Property

[image]

.NET Framework Class Library
Item..::.discountAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property discountAmount As String
C#
public string discountAmount { get; set; }
Visual C++
public:
property String^ discountAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_discountAmount();
function set_discountAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


discountIndicator Property

[image]

.NET Framework Class Library
Item..::.discountIndicator Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property discountIndicator As String
C#
public string discountIndicator { get; set; }
Visual C++
public:
property String^ discountIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_discountIndicator();
function set_discountIndicator(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


discountRate Property

[image]

.NET Framework Class Library
Item..::.discountRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property discountRate As String
C#
public string discountRate { get; set; }
Visual C++
public:
property String^ discountRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_discountRate();
function set_discountRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


districtOverrideAmount Property

[image]

.NET Framework Class Library
Item..::.districtOverrideAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property districtOverrideAmount As String
C#
public string districtOverrideAmount { get; set; }
Visual C++
public:
property String^ districtOverrideAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_districtOverrideAmount();
function set_districtOverrideAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


districtOverrideRate Property

[image]

.NET Framework Class Library
Item..::.districtOverrideRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property districtOverrideRate As String
C#
public string districtOverrideRate { get; set; }
Visual C++
public:
property String^ districtOverrideRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_districtOverrideRate();
function set_districtOverrideRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


export Property

[image]

.NET Framework Class Library
Item..::.export Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property export As String
C#
public string export { get; set; }
Visual C++
public:
property String^ export {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_export();
function set_export(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


giftCategory Property

[image]

.NET Framework Class Library
Item..::.giftCategory Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property giftCategory As String
C#
public string giftCategory { get; set; }
Visual C++
public:
property String^ giftCategory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_giftCategory();
function set_giftCategory(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


grossNetIndicator Property

[image]

.NET Framework Class Library
Item..::.grossNetIndicator Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property grossNetIndicator As String
C#
public string grossNetIndicator { get; set; }
Visual C++
public:
property String^ grossNetIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_grossNetIndicator();
function set_grossNetIndicator(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


hostHedge Property

[image]

.NET Framework Class Library
Item..::.hostHedge Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property hostHedge As String
C#
public string hostHedge { get; set; }
Visual C++
public:
property String^ hostHedge {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_hostHedge();
function set_hostHedge(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


id Property

[image]

.NET Framework Class Library
Item..::.id Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property id As String
C#
public string id { get; set; }
Visual C++
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


localTax Property

[image]

.NET Framework Class Library
Item..::.localTax Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property localTax As String
C#
public string localTax { get; set; }
Visual C++
public:
property String^ localTax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_localTax();
function set_localTax(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


middlemanRegistration Property

[image]

.NET Framework Class Library
Item..::.middlemanRegistration Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property middlemanRegistration As String
C#
public string middlemanRegistration { get; set; }
Visual C++
public:
property String^ middlemanRegistration {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_middlemanRegistration();
function set_middlemanRegistration(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


nationalTax Property

[image]

.NET Framework Class Library
Item..::.nationalTax Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property nationalTax As String
C#
public string nationalTax { get; set; }
Visual C++
public:
property String^ nationalTax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nationalTax();
function set_nationalTax(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


noExport Property

[image]

.NET Framework Class Library
Item..::.noExport Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property noExport As String
C#
public string noExport { get; set; }
Visual C++
public:
property String^ noExport {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_noExport();
function set_noExport(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


nonsensicalHedge Property

[image]

.NET Framework Class Library
Item..::.nonsensicalHedge Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property nonsensicalHedge As String
C#
public string nonsensicalHedge { get; set; }
Visual C++
public:
property String^ nonsensicalHedge {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nonsensicalHedge();
function set_nonsensicalHedge(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


obscenitiesHedge Property

[image]

.NET Framework Class Library
Item..::.obscenitiesHedge Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property obscenitiesHedge As String
C#
public string obscenitiesHedge { get; set; }
Visual C++
public:
property String^ obscenitiesHedge {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_obscenitiesHedge();
function set_obscenitiesHedge(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderAcceptanceCity Property

[image]

.NET Framework Class Library
Item..::.orderAcceptanceCity Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptanceCity As String
C#
public string orderAcceptanceCity { get; set; }
Visual C++
public:
property String^ orderAcceptanceCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptanceCity();
function set_orderAcceptanceCity(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderAcceptanceCountry Property

[image]

.NET Framework Class Library
Item..::.orderAcceptanceCountry Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptanceCountry As String
C#
public string orderAcceptanceCountry { get; set; }
Visual C++
public:
property String^ orderAcceptanceCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptanceCountry();
function set_orderAcceptanceCountry(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderAcceptanceCounty Property

[image]

.NET Framework Class Library
Item..::.orderAcceptanceCounty Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptanceCounty As String
C#
public string orderAcceptanceCounty { get; set; }
Visual C++
public:
property String^ orderAcceptanceCounty {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptanceCounty();
function set_orderAcceptanceCounty(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderAcceptancePostalCode Property

[image]

.NET Framework Class Library
Item..::.orderAcceptancePostalCode Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptancePostalCode As String
C#
public string orderAcceptancePostalCode { get; set; }
Visual C++
public:
property String^ orderAcceptancePostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptancePostalCode();
function set_orderAcceptancePostalCode(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderAcceptanceState Property

[image]

.NET Framework Class Library
Item..::.orderAcceptanceState Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptanceState As String
C#
public string orderAcceptanceState { get; set; }
Visual C++
public:
property String^ orderAcceptanceState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptanceState();
function set_orderAcceptanceState(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderOriginCity Property

[image]

.NET Framework Class Library
Item..::.orderOriginCity Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginCity As String
C#
public string orderOriginCity { get; set; }
Visual C++
public:
property String^ orderOriginCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginCity();
function set_orderOriginCity(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderOriginCountry Property

[image]

.NET Framework Class Library
Item..::.orderOriginCountry Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginCountry As String
C#
public string orderOriginCountry { get; set; }
Visual C++
public:
property String^ orderOriginCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginCountry();
function set_orderOriginCountry(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderOriginCounty Property

[image]

.NET Framework Class Library
Item..::.orderOriginCounty Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginCounty As String
C#
public string orderOriginCounty { get; set; }
Visual C++
public:
property String^ orderOriginCounty {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginCounty();
function set_orderOriginCounty(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderOriginPostalCode Property

[image]

.NET Framework Class Library
Item..::.orderOriginPostalCode Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginPostalCode As String
C#
public string orderOriginPostalCode { get; set; }
Visual C++
public:
property String^ orderOriginPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginPostalCode();
function set_orderOriginPostalCode(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


orderOriginState Property

[image]

.NET Framework Class Library
Item..::.orderOriginState Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginState As String
C#
public string orderOriginState { get; set; }
Visual C++
public:
property String^ orderOriginState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginState();
function set_orderOriginState(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


phoneHedge Property

[image]

.NET Framework Class Library
Item..::.phoneHedge Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property phoneHedge As String
C#
public string phoneHedge { get; set; }
Visual C++
public:
property String^ phoneHedge {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneHedge();
function set_phoneHedge(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


pointOfTitleTransfer Property

[image]

.NET Framework Class Library
Item..::.pointOfTitleTransfer Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pointOfTitleTransfer As String
C#
public string pointOfTitleTransfer { get; set; }
Visual C++
public:
property String^ pointOfTitleTransfer {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pointOfTitleTransfer();
function set_pointOfTitleTransfer(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


productCode Property

[image]

.NET Framework Class Library
Item..::.productCode Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property productCode As String
C#
public string productCode { get; set; }
Visual C++
public:
property String^ productCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productCode();
function set_productCode(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


productName Property

[image]

.NET Framework Class Library
Item..::.productName Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property productName As String
C#
public string productName { get; set; }
Visual C++
public:
property String^ productName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productName();
function set_productName(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


productRisk Property

[image]

.NET Framework Class Library
Item..::.productRisk Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property productRisk As String
C#
public string productRisk { get; set; }
Visual C++
public:
property String^ productRisk {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productRisk();
function set_productRisk(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


productSKU Property

[image]

.NET Framework Class Library
Item..::.productSKU Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property productSKU As String
C#
public string productSKU { get; set; }
Visual C++
public:
property String^ productSKU {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productSKU();
function set_productSKU(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


quantity Property

[image]

.NET Framework Class Library
Item..::.quantity Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property quantity As String
C#
public string quantity { get; set; }
Visual C++
public:
property String^ quantity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_quantity();
function set_quantity(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


sellerRegistration Property

[image]

.NET Framework Class Library
Item..::.sellerRegistration Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property sellerRegistration As String
C#
public string sellerRegistration { get; set; }
Visual C++
public:
property String^ sellerRegistration {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_sellerRegistration();
function set_sellerRegistration(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


shipFromCity Property

[image]

.NET Framework Class Library
Item..::.shipFromCity Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipFromCity As String
C#
public string shipFromCity { get; set; }
Visual C++
public:
property String^ shipFromCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromCity();
function set_shipFromCity(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


shipFromCountry Property

[image]

.NET Framework Class Library
Item..::.shipFromCountry Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipFromCountry As String
C#
public string shipFromCountry { get; set; }
Visual C++
public:
property String^ shipFromCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromCountry();
function set_shipFromCountry(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


shipFromCounty Property

[image]

.NET Framework Class Library
Item..::.shipFromCounty Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipFromCounty As String
C#
public string shipFromCounty { get; set; }
Visual C++
public:
property String^ shipFromCounty {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromCounty();
function set_shipFromCounty(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


shipFromPostalCode Property

[image]

.NET Framework Class Library
Item..::.shipFromPostalCode Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipFromPostalCode As String
C#
public string shipFromPostalCode { get; set; }
Visual C++
public:
property String^ shipFromPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromPostalCode();
function set_shipFromPostalCode(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


shipFromState Property

[image]

.NET Framework Class Library
Item..::.shipFromState Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipFromState As String
C#
public string shipFromState { get; set; }
Visual C++
public:
property String^ shipFromState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromState();
function set_shipFromState(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


stateOverrideAmount Property

[image]

.NET Framework Class Library
Item..::.stateOverrideAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property stateOverrideAmount As String
C#
public string stateOverrideAmount { get; set; }
Visual C++
public:
property String^ stateOverrideAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stateOverrideAmount();
function set_stateOverrideAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


stateOverrideRate Property

[image]

.NET Framework Class Library
Item..::.stateOverrideRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property stateOverrideRate As String
C#
public string stateOverrideRate { get; set; }
Visual C++
public:
property String^ stateOverrideRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stateOverrideRate();
function set_stateOverrideRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


taxAmount Property

[image]

.NET Framework Class Library
Item..::.taxAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxAmount As String
C#
public string taxAmount { get; set; }
Visual C++
public:
property String^ taxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxAmount();
function set_taxAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


taxRate Property

[image]

.NET Framework Class Library
Item..::.taxRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxRate As String
C#
public string taxRate { get; set; }
Visual C++
public:
property String^ taxRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxRate();
function set_taxRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


taxTypeApplied Property

[image]

.NET Framework Class Library
Item..::.taxTypeApplied Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxTypeApplied As String
C#
public string taxTypeApplied { get; set; }
Visual C++
public:
property String^ taxTypeApplied {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxTypeApplied();
function set_taxTypeApplied(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


timeCategory Property

[image]

.NET Framework Class Library
Item..::.timeCategory Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property timeCategory As String
C#
public string timeCategory { get; set; }
Visual C++
public:
property String^ timeCategory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_timeCategory();
function set_timeCategory(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


timeHedge Property

[image]

.NET Framework Class Library
Item..::.timeHedge Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property timeHedge As String
C#
public string timeHedge { get; set; }
Visual C++
public:
property String^ timeHedge {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_timeHedge();
function set_timeHedge(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


totalAmount Property

[image]

.NET Framework Class Library
Item..::.totalAmount Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalAmount As String
C#
public string totalAmount { get; set; }
Visual C++
public:
property String^ totalAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalAmount();
function set_totalAmount(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


unitOfMeasure Property

[image]

.NET Framework Class Library
Item..::.unitOfMeasure Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property unitOfMeasure As String
C#
public string unitOfMeasure { get; set; }
Visual C++
public:
property String^ unitOfMeasure {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_unitOfMeasure();
function set_unitOfMeasure(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


unitPrice Property

[image]

.NET Framework Class Library
Item..::.unitPrice Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property unitPrice As String
C#
public string unitPrice { get; set; }
Visual C++
public:
property String^ unitPrice {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_unitPrice();
function set_unitPrice(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


vatRate Property

[image]

.NET Framework Class Library
Item..::.vatRate Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property vatRate As String
C#
public string vatRate { get; set; }
Visual C++
public:
property String^ vatRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vatRate();
function set_vatRate(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


velocityHedge Property

[image]

.NET Framework Class Library
Item..::.velocityHedge Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property velocityHedge As String
C#
public string velocityHedge { get; set; }
Visual C++
public:
property String^ velocityHedge {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_velocityHedge();
function set_velocityHedge(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


zeroCostToCustomerIndicator Property

[image]

.NET Framework Class Library
Item..::.zeroCostToCustomerIndicator Property
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property zeroCostToCustomerIndicator As String
C#
public string zeroCostToCustomerIndicator { get; set; }
Visual C++
public:
property String^ zeroCostToCustomerIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zeroCostToCustomerIndicator();
function set_zeroCostToCustomerIndicator(value);

Remarks

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


Item Events

[image] [image]

.NET Framework Class Library
Item Events
Item Class See Also Send Feedback

The Item type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Item..::.PropertyChanged Event
Item Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Item Class
InSite.Domain.CyberSourceService Namespace


ITransactionProcessor Interface

[image]

.NET Framework Class Library
ITransactionProcessor Interface
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")> _
<ServiceContractAttribute(Namespace := "urn:schemas-cybersource-com:transaction-data:TransactionProcessor",  _
    ConfigurationName := "CyberSourceService.ITransactionProcessor")> _
Public Interface ITransactionProcessor
C#
[GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
[ServiceContractAttribute(Namespace = "urn:schemas-cybersource-com:transaction-data:TransactionProcessor",
    ConfigurationName = "CyberSourceService.ITransactionProcessor")]
public interface ITransactionProcessor
Visual C++
[GeneratedCodeAttribute(L"System.ServiceModel", L"3.0.0.0")]
[ServiceContractAttribute(Namespace = L"urn:schemas-cybersource-com:transaction-data:TransactionProcessor",
    ConfigurationName = L"CyberSourceService.ITransactionProcessor")]
public interface class ITransactionProcessor
JavaScript
InSite.Domain.CyberSourceService.ITransactionProcessor = function();
InSite.Domain.CyberSourceService.ITransactionProcessor.createInterface('InSite.Domain.CyberSourceService.ITransactionProcessor');

See Also

ITransactionProcessor Members
InSite.Domain.CyberSourceService Namespace


ITransactionProcessor Members

[image] [image]

.NET Framework Class Library
ITransactionProcessor Members
ITransactionProcessor Interface Methods See Also Send Feedback

The ITransactionProcessor type exposes the following members.

Methods

Name | Description
runTransaction |

See Also

ITransactionProcessor Interface
InSite.Domain.CyberSourceService Namespace


ITransactionProcessor Methods

[image] [image]

.NET Framework Class Library
ITransactionProcessor Methods
ITransactionProcessor Interface See Also Send Feedback

The ITransactionProcessor type exposes the following members.

Methods

Name | Description
runTransaction |

See Also

ITransactionProcessor Interface
InSite.Domain.CyberSourceService Namespace


runTransaction Method

[image]

.NET Framework Class Library
ITransactionProcessor..::.runTransaction Method
ITransactionProcessor Interface See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<XmlSerializerFormatAttribute> _
<OperationContractAttribute(Action := "runTransaction", ReplyAction := "*")> _
Function runTransaction ( _
    request As inputMessageIn _
) As outputMessageOut
C#
[XmlSerializerFormatAttribute]
[OperationContractAttribute(Action = "runTransaction", ReplyAction = "*")]
outputMessageOut runTransaction(
    inputMessageIn request
)
Visual C++
[XmlSerializerFormatAttribute]
[OperationContractAttribute(Action = L"runTransaction", ReplyAction = L"*")]
outputMessageOut^ runTransaction(
    inputMessageIn^ request
)
JavaScript
function runTransaction(request);

Parameters

request
Type: InSite.Domain.CyberSourceService..::.inputMessageIn

See Also

ITransactionProcessor Interface
InSite.Domain.CyberSourceService Namespace


ITransactionProcessorChannel Interface

[image]

.NET Framework Class Library
ITransactionProcessorChannel Interface
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")> _
Public Interface ITransactionProcessorChannel _
    Implements ITransactionProcessor, IClientChannel, IContextChannel, IChannel,  _
    ICommunicationObject, IExtensibleObject(Of IContextChannel), IDisposable
C#
[GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
public interface ITransactionProcessorChannel : ITransactionProcessor,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel>,
    IDisposable
Visual C++
[GeneratedCodeAttribute(L"System.ServiceModel", L"3.0.0.0")]
public interface class ITransactionProcessorChannel : ITransactionProcessor,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel^>,
    IDisposable
JavaScript
InSite.Domain.CyberSourceService.ITransactionProcessorChannel = function();
InSite.Domain.CyberSourceService.ITransactionProcessorChannel.createInterface('InSite.Domain.CyberSourceService.ITransactionProcessorChannel');

See Also

ITransactionProcessorChannel Members
InSite.Domain.CyberSourceService Namespace


ITransactionProcessorChannel Members

[image] [image]

.NET Framework Class Library
ITransactionProcessorChannel Members
ITransactionProcessorChannel Interface Methods Properties Events See Also Send Feedback

The ITransactionProcessorChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginOpen | Overloaded.
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndOpen | (Inherited from ICommunicationObject.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.
runTransaction | (Inherited from ITransactionProcessor.)

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

ITransactionProcessorChannel Interface
InSite.Domain.CyberSourceService Namespace


ITransactionProcessorChannel Methods

[image] [image]

.NET Framework Class Library
ITransactionProcessorChannel Methods
ITransactionProcessorChannel Interface See Also Send Feedback

The ITransactionProcessorChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginOpen | Overloaded.
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndOpen | (Inherited from ICommunicationObject.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.
runTransaction | (Inherited from ITransactionProcessor.)

See Also

ITransactionProcessorChannel Interface
InSite.Domain.CyberSourceService Namespace


BeginClose Method

[image] [image]

.NET Framework Class Library
ITransactionProcessorChannel..::.BeginClose Method
ITransactionProcessorChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginClose(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginClose(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

ITransactionProcessorChannel Interface
ITransactionProcessorChannel Members
InSite.Domain.CyberSourceService Namespace


BeginOpen Method

[image] [image]

.NET Framework Class Library
ITransactionProcessorChannel..::.BeginOpen Method
ITransactionProcessorChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginOpen(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginOpen(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

ITransactionProcessorChannel Interface
ITransactionProcessorChannel Members
InSite.Domain.CyberSourceService Namespace


Close Method

[image] [image]

.NET Framework Class Library
ITransactionProcessorChannel..::.Close Method
ITransactionProcessorChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | (Inherited from ICommunicationObject.)
Close(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

ITransactionProcessorChannel Interface
ITransactionProcessorChannel Members
InSite.Domain.CyberSourceService Namespace


Open Method

[image] [image]

.NET Framework Class Library
ITransactionProcessorChannel..::.Open Method
ITransactionProcessorChannel Interface See Also Send Feedback

Overload List

Name | Description
Open()()() | (Inherited from ICommunicationObject.)
Open(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

ITransactionProcessorChannel Interface
ITransactionProcessorChannel Members
InSite.Domain.CyberSourceService Namespace


ITransactionProcessorChannel Properties

[image] [image]

.NET Framework Class Library
ITransactionProcessorChannel Properties
ITransactionProcessorChannel Interface See Also Send Feedback

The ITransactionProcessorChannel type exposes the following members.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

See Also

ITransactionProcessorChannel Interface
InSite.Domain.CyberSourceService Namespace


ITransactionProcessorChannel Events

[image] [image]

.NET Framework Class Library
ITransactionProcessorChannel Events
ITransactionProcessorChannel Interface See Also Send Feedback

The ITransactionProcessorChannel type exposes the following members.

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

ITransactionProcessorChannel Interface
InSite.Domain.CyberSourceService Namespace


JPO Class

[image]

.NET Framework Class Library
JPO Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class JPO _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class JPO : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class JPO : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.JPO = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.JPO',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.JPO

See Also

JPO Members
InSite.Domain.CyberSourceService Namespace


JPO Members

[image] [image]

.NET Framework Class Library
JPO Members
JPO Class Constructors Methods Properties Events See Also Send Feedback

The JPO type exposes the following members.

Constructors

Name | Description
JPO |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
bonusAmount |
bonuses |
installments |
paymentMethod |

Events

Name | Description
PropertyChanged |

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


JPO Constructor

[image]

.NET Framework Class Library
JPO Constructor
JPO Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public JPO()
Visual C++
public:
JPO()
JavaScript
InSite.Domain.CyberSourceService.JPO = function();

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


JPO Methods

[image] [image]

.NET Framework Class Library
JPO Methods
JPO Class See Also Send Feedback

The JPO type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
JPO..::.RaisePropertyChanged Method
JPO Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


JPO Properties

[image] [image]

.NET Framework Class Library
JPO Properties
JPO Class See Also Send Feedback

The JPO type exposes the following members.

Properties

Name | Description
bonusAmount |
bonuses |
installments |
paymentMethod |

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


bonusAmount Property

[image]

.NET Framework Class Library
JPO..::.bonusAmount Property
JPO Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bonusAmount As String
C#
public string bonusAmount { get; set; }
Visual C++
public:
property String^ bonusAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bonusAmount();
function set_bonusAmount(value);

Remarks

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


bonuses Property

[image]

.NET Framework Class Library
JPO..::.bonuses Property
JPO Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bonuses As String
C#
public string bonuses { get; set; }
Visual C++
public:
property String^ bonuses {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bonuses();
function set_bonuses(value);

Remarks

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


installments Property

[image]

.NET Framework Class Library
JPO..::.installments Property
JPO Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property installments As String
C#
public string installments { get; set; }
Visual C++
public:
property String^ installments {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_installments();
function set_installments(value);

Remarks

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


paymentMethod Property

[image]

.NET Framework Class Library
JPO..::.paymentMethod Property
JPO Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentMethod As String
C#
public string paymentMethod { get; set; }
Visual C++
public:
property String^ paymentMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentMethod();
function set_paymentMethod(value);

Remarks

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


JPO Events

[image] [image]

.NET Framework Class Library
JPO Events
JPO Class See Also Send Feedback

The JPO type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
JPO..::.PropertyChanged Event
JPO Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

JPO Class
InSite.Domain.CyberSourceService Namespace


Leg Class

[image]

.NET Framework Class Library
Leg Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Leg _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Leg : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Leg : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Leg = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Leg',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Leg

See Also

Leg Members
InSite.Domain.CyberSourceService Namespace


Leg Members

[image] [image]

.NET Framework Class Library
Leg Members
Leg Class Constructors Methods Properties Events See Also Send Feedback

The Leg type exposes the following members.

Constructors

Name | Description
Leg |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
arrivalTime |
arrivalTimeSegment |
carrierCode |
class |
conjunctionTicket |
couponNumber |
departTax |
departureDate |
departureTime |
departureTimeSegment |
destination |
endorsementsRestrictions |
exchangeTicket |
fareBasis |
flightNumber |
id |
originatingAirportCode |
stopoverCode |

Events

Name | Description
PropertyChanged |

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


Leg Constructor

[image]

.NET Framework Class Library
Leg Constructor
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Leg()
Visual C++
public:
Leg()
JavaScript
InSite.Domain.CyberSourceService.Leg = function();

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


Leg Methods

[image] [image]

.NET Framework Class Library
Leg Methods
Leg Class See Also Send Feedback

The Leg type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Leg..::.RaisePropertyChanged Method
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


Leg Properties

[image] [image]

.NET Framework Class Library
Leg Properties
Leg Class See Also Send Feedback

The Leg type exposes the following members.

Properties

Name | Description
arrivalTime |
arrivalTimeSegment |
carrierCode |
class |
conjunctionTicket |
couponNumber |
departTax |
departureDate |
departureTime |
departureTimeSegment |
destination |
endorsementsRestrictions |
exchangeTicket |
fareBasis |
flightNumber |
id |
originatingAirportCode |
stopoverCode |

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


arrivalTime Property

[image]

.NET Framework Class Library
Leg..::.arrivalTime Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property arrivalTime As String
C#
public string arrivalTime { get; set; }
Visual C++
public:
property String^ arrivalTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_arrivalTime();
function set_arrivalTime(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


arrivalTimeSegment Property

[image]

.NET Framework Class Library
Leg..::.arrivalTimeSegment Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property arrivalTimeSegment As String
C#
public string arrivalTimeSegment { get; set; }
Visual C++
public:
property String^ arrivalTimeSegment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_arrivalTimeSegment();
function set_arrivalTimeSegment(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


carrierCode Property

[image]

.NET Framework Class Library
Leg..::.carrierCode Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property carrierCode As String
C#
public string carrierCode { get; set; }
Visual C++
public:
property String^ carrierCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_carrierCode();
function set_carrierCode(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


class Property

[image]

.NET Framework Class Library
Leg..::.class Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property class As String
C#
public string class { get; set; }
Visual C++
public:
property String^ class {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_class();
function set_class(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


conjunctionTicket Property

[image]

.NET Framework Class Library
Leg..::.conjunctionTicket Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property conjunctionTicket As String
C#
public string conjunctionTicket { get; set; }
Visual C++
public:
property String^ conjunctionTicket {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_conjunctionTicket();
function set_conjunctionTicket(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


couponNumber Property

[image]

.NET Framework Class Library
Leg..::.couponNumber Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property couponNumber As String
C#
public string couponNumber { get; set; }
Visual C++
public:
property String^ couponNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_couponNumber();
function set_couponNumber(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


departTax Property

[image]

.NET Framework Class Library
Leg..::.departTax Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property departTax As String
C#
public string departTax { get; set; }
Visual C++
public:
property String^ departTax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_departTax();
function set_departTax(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


departureDate Property

[image]

.NET Framework Class Library
Leg..::.departureDate Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property departureDate As String
C#
public string departureDate { get; set; }
Visual C++
public:
property String^ departureDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_departureDate();
function set_departureDate(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


departureTime Property

[image]

.NET Framework Class Library
Leg..::.departureTime Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property departureTime As String
C#
public string departureTime { get; set; }
Visual C++
public:
property String^ departureTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_departureTime();
function set_departureTime(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


departureTimeSegment Property

[image]

.NET Framework Class Library
Leg..::.departureTimeSegment Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property departureTimeSegment As String
C#
public string departureTimeSegment { get; set; }
Visual C++
public:
property String^ departureTimeSegment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_departureTimeSegment();
function set_departureTimeSegment(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


destination Property

[image]

.NET Framework Class Library
Leg..::.destination Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property destination As String
C#
public string destination { get; set; }
Visual C++
public:
property String^ destination {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_destination();
function set_destination(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


endorsementsRestrictions Property

[image]

.NET Framework Class Library
Leg..::.endorsementsRestrictions Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property endorsementsRestrictions As String
C#
public string endorsementsRestrictions { get; set; }
Visual C++
public:
property String^ endorsementsRestrictions {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_endorsementsRestrictions();
function set_endorsementsRestrictions(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


exchangeTicket Property

[image]

.NET Framework Class Library
Leg..::.exchangeTicket Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property exchangeTicket As String
C#
public string exchangeTicket { get; set; }
Visual C++
public:
property String^ exchangeTicket {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_exchangeTicket();
function set_exchangeTicket(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


fareBasis Property

[image]

.NET Framework Class Library
Leg..::.fareBasis Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fareBasis As String
C#
public string fareBasis { get; set; }
Visual C++
public:
property String^ fareBasis {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fareBasis();
function set_fareBasis(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


flightNumber Property

[image]

.NET Framework Class Library
Leg..::.flightNumber Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property flightNumber As String
C#
public string flightNumber { get; set; }
Visual C++
public:
property String^ flightNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_flightNumber();
function set_flightNumber(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


id Property

[image]

.NET Framework Class Library
Leg..::.id Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property id As String
C#
public string id { get; set; }
Visual C++
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


originatingAirportCode Property

[image]

.NET Framework Class Library
Leg..::.originatingAirportCode Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property originatingAirportCode As String
C#
public string originatingAirportCode { get; set; }
Visual C++
public:
property String^ originatingAirportCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_originatingAirportCode();
function set_originatingAirportCode(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


stopoverCode Property

[image]

.NET Framework Class Library
Leg..::.stopoverCode Property
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property stopoverCode As String
C#
public string stopoverCode { get; set; }
Visual C++
public:
property String^ stopoverCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stopoverCode();
function set_stopoverCode(value);

Remarks

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


Leg Events

[image] [image]

.NET Framework Class Library
Leg Events
Leg Class See Also Send Feedback

The Leg type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Leg..::.PropertyChanged Event
Leg Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Leg Class
InSite.Domain.CyberSourceService Namespace


MerchantDefinedData Class

[image]

.NET Framework Class Library
MerchantDefinedData Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class MerchantDefinedData _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class MerchantDefinedData : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class MerchantDefinedData : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.MerchantDefinedData = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.MerchantDefinedData',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.MerchantDefinedData

See Also

MerchantDefinedData Members
InSite.Domain.CyberSourceService Namespace


MerchantDefinedData Members

[image] [image]

.NET Framework Class Library
MerchantDefinedData Members
MerchantDefinedData Class Constructors Methods Properties Events See Also Send Feedback

The MerchantDefinedData type exposes the following members.

Constructors

Name | Description
MerchantDefinedData |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
field1 |
field10 |
field11 |
field12 |
field13 |
field14 |
field15 |
field16 |
field17 |
field18 |
field19 |
field2 |
field20 |
field3 |
field4 |
field5 |
field6 |
field7 |
field8 |
field9 |

Events

Name | Description
PropertyChanged |

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


MerchantDefinedData Constructor

[image]

.NET Framework Class Library
MerchantDefinedData Constructor
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MerchantDefinedData()
Visual C++
public:
MerchantDefinedData()
JavaScript
InSite.Domain.CyberSourceService.MerchantDefinedData = function();

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


MerchantDefinedData Methods

[image] [image]

.NET Framework Class Library
MerchantDefinedData Methods
MerchantDefinedData Class See Also Send Feedback

The MerchantDefinedData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
MerchantDefinedData..::.RaisePropertyChanged Method
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


MerchantDefinedData Properties

[image] [image]

.NET Framework Class Library
MerchantDefinedData Properties
MerchantDefinedData Class See Also Send Feedback

The MerchantDefinedData type exposes the following members.

Properties

Name | Description
field1 |
field10 |
field11 |
field12 |
field13 |
field14 |
field15 |
field16 |
field17 |
field18 |
field19 |
field2 |
field20 |
field3 |
field4 |
field5 |
field6 |
field7 |
field8 |
field9 |

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field1 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field1 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field1 As String
C#
public string field1 { get; set; }
Visual C++
public:
property String^ field1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field1();
function set_field1(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field10 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field10 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field10 As String
C#
public string field10 { get; set; }
Visual C++
public:
property String^ field10 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field10();
function set_field10(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field11 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field11 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field11 As String
C#
public string field11 { get; set; }
Visual C++
public:
property String^ field11 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field11();
function set_field11(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field12 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field12 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field12 As String
C#
public string field12 { get; set; }
Visual C++
public:
property String^ field12 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field12();
function set_field12(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field13 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field13 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field13 As String
C#
public string field13 { get; set; }
Visual C++
public:
property String^ field13 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field13();
function set_field13(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field14 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field14 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field14 As String
C#
public string field14 { get; set; }
Visual C++
public:
property String^ field14 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field14();
function set_field14(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field15 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field15 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field15 As String
C#
public string field15 { get; set; }
Visual C++
public:
property String^ field15 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field15();
function set_field15(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field16 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field16 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field16 As String
C#
public string field16 { get; set; }
Visual C++
public:
property String^ field16 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field16();
function set_field16(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field17 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field17 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field17 As String
C#
public string field17 { get; set; }
Visual C++
public:
property String^ field17 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field17();
function set_field17(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field18 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field18 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field18 As String
C#
public string field18 { get; set; }
Visual C++
public:
property String^ field18 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field18();
function set_field18(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field19 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field19 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field19 As String
C#
public string field19 { get; set; }
Visual C++
public:
property String^ field19 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field19();
function set_field19(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field2 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field2 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field2 As String
C#
public string field2 { get; set; }
Visual C++
public:
property String^ field2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field2();
function set_field2(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field20 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field20 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field20 As String
C#
public string field20 { get; set; }
Visual C++
public:
property String^ field20 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field20();
function set_field20(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field3 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field3 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field3 As String
C#
public string field3 { get; set; }
Visual C++
public:
property String^ field3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field3();
function set_field3(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field4 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field4 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field4 As String
C#
public string field4 { get; set; }
Visual C++
public:
property String^ field4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field4();
function set_field4(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field5 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field5 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field5 As String
C#
public string field5 { get; set; }
Visual C++
public:
property String^ field5 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field5();
function set_field5(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field6 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field6 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field6 As String
C#
public string field6 { get; set; }
Visual C++
public:
property String^ field6 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field6();
function set_field6(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field7 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field7 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field7 As String
C#
public string field7 { get; set; }
Visual C++
public:
property String^ field7 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field7();
function set_field7(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field8 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field8 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field8 As String
C#
public string field8 { get; set; }
Visual C++
public:
property String^ field8 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field8();
function set_field8(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


field9 Property

[image]

.NET Framework Class Library
MerchantDefinedData..::.field9 Property
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field9 As String
C#
public string field9 { get; set; }
Visual C++
public:
property String^ field9 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field9();
function set_field9(value);

Remarks

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


MerchantDefinedData Events

[image] [image]

.NET Framework Class Library
MerchantDefinedData Events
MerchantDefinedData Class See Also Send Feedback

The MerchantDefinedData type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
MerchantDefinedData..::.PropertyChanged Event
MerchantDefinedData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

MerchantDefinedData Class
InSite.Domain.CyberSourceService Namespace


MerchantSecureData Class

[image]

.NET Framework Class Library
MerchantSecureData Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class MerchantSecureData _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class MerchantSecureData : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class MerchantSecureData : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.MerchantSecureData = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.MerchantSecureData',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.MerchantSecureData

See Also

MerchantSecureData Members
InSite.Domain.CyberSourceService Namespace


MerchantSecureData Members

[image] [image]

.NET Framework Class Library
MerchantSecureData Members
MerchantSecureData Class Constructors Methods Properties Events See Also Send Feedback

The MerchantSecureData type exposes the following members.

Constructors

Name | Description
MerchantSecureData |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
field1 |
field2 |
field3 |
field4 |

Events

Name | Description
PropertyChanged |

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


MerchantSecureData Constructor

[image]

.NET Framework Class Library
MerchantSecureData Constructor
MerchantSecureData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public MerchantSecureData()
Visual C++
public:
MerchantSecureData()
JavaScript
InSite.Domain.CyberSourceService.MerchantSecureData = function();

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


MerchantSecureData Methods

[image] [image]

.NET Framework Class Library
MerchantSecureData Methods
MerchantSecureData Class See Also Send Feedback

The MerchantSecureData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
MerchantSecureData..::.RaisePropertyChanged Method
MerchantSecureData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


MerchantSecureData Properties

[image] [image]

.NET Framework Class Library
MerchantSecureData Properties
MerchantSecureData Class See Also Send Feedback

The MerchantSecureData type exposes the following members.

Properties

Name | Description
field1 |
field2 |
field3 |
field4 |

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


field1 Property

[image]

.NET Framework Class Library
MerchantSecureData..::.field1 Property
MerchantSecureData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field1 As String
C#
public string field1 { get; set; }
Visual C++
public:
property String^ field1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field1();
function set_field1(value);

Remarks

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


field2 Property

[image]

.NET Framework Class Library
MerchantSecureData..::.field2 Property
MerchantSecureData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field2 As String
C#
public string field2 { get; set; }
Visual C++
public:
property String^ field2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field2();
function set_field2(value);

Remarks

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


field3 Property

[image]

.NET Framework Class Library
MerchantSecureData..::.field3 Property
MerchantSecureData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field3 As String
C#
public string field3 { get; set; }
Visual C++
public:
property String^ field3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field3();
function set_field3(value);

Remarks

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


field4 Property

[image]

.NET Framework Class Library
MerchantSecureData..::.field4 Property
MerchantSecureData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property field4 As String
C#
public string field4 { get; set; }
Visual C++
public:
property String^ field4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_field4();
function set_field4(value);

Remarks

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


MerchantSecureData Events

[image] [image]

.NET Framework Class Library
MerchantSecureData Events
MerchantSecureData Class See Also Send Feedback

The MerchantSecureData type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
MerchantSecureData..::.PropertyChanged Event
MerchantSecureData Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

MerchantSecureData Class
InSite.Domain.CyberSourceService Namespace


OtherTax Class

[image]

.NET Framework Class Library
OtherTax Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class OtherTax _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class OtherTax : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class OtherTax : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.OtherTax = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.OtherTax',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.OtherTax

See Also

OtherTax Members
InSite.Domain.CyberSourceService Namespace


OtherTax Members

[image] [image]

.NET Framework Class Library
OtherTax Members
OtherTax Class Constructors Methods Properties Events See Also Send Feedback

The OtherTax type exposes the following members.

Constructors

Name | Description
OtherTax |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
alternateTaxAmount |
alternateTaxID |
alternateTaxIndicator |
localTaxAmount |
localTaxIndicator |
nationalTaxAmount |
nationalTaxIndicator |
vatTaxAmount |
vatTaxRate |

Events

Name | Description
PropertyChanged |

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


OtherTax Constructor

[image]

.NET Framework Class Library
OtherTax Constructor
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OtherTax()
Visual C++
public:
OtherTax()
JavaScript
InSite.Domain.CyberSourceService.OtherTax = function();

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


OtherTax Methods

[image] [image]

.NET Framework Class Library
OtherTax Methods
OtherTax Class See Also Send Feedback

The OtherTax type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
OtherTax..::.RaisePropertyChanged Method
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


OtherTax Properties

[image] [image]

.NET Framework Class Library
OtherTax Properties
OtherTax Class See Also Send Feedback

The OtherTax type exposes the following members.

Properties

Name | Description
alternateTaxAmount |
alternateTaxID |
alternateTaxIndicator |
localTaxAmount |
localTaxIndicator |
nationalTaxAmount |
nationalTaxIndicator |
vatTaxAmount |
vatTaxRate |

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


alternateTaxAmount Property

[image]

.NET Framework Class Library
OtherTax..::.alternateTaxAmount Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateTaxAmount As String
C#
public string alternateTaxAmount { get; set; }
Visual C++
public:
property String^ alternateTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateTaxAmount();
function set_alternateTaxAmount(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


alternateTaxID Property

[image]

.NET Framework Class Library
OtherTax..::.alternateTaxID Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateTaxID As String
C#
public string alternateTaxID { get; set; }
Visual C++
public:
property String^ alternateTaxID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateTaxID();
function set_alternateTaxID(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


alternateTaxIndicator Property

[image]

.NET Framework Class Library
OtherTax..::.alternateTaxIndicator Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property alternateTaxIndicator As String
C#
public string alternateTaxIndicator { get; set; }
Visual C++
public:
property String^ alternateTaxIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_alternateTaxIndicator();
function set_alternateTaxIndicator(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


localTaxAmount Property

[image]

.NET Framework Class Library
OtherTax..::.localTaxAmount Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property localTaxAmount As String
C#
public string localTaxAmount { get; set; }
Visual C++
public:
property String^ localTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_localTaxAmount();
function set_localTaxAmount(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


localTaxIndicator Property

[image]

.NET Framework Class Library
OtherTax..::.localTaxIndicator Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property localTaxIndicator As String
C#
public string localTaxIndicator { get; set; }
Visual C++
public:
property String^ localTaxIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_localTaxIndicator();
function set_localTaxIndicator(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


nationalTaxAmount Property

[image]

.NET Framework Class Library
OtherTax..::.nationalTaxAmount Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property nationalTaxAmount As String
C#
public string nationalTaxAmount { get; set; }
Visual C++
public:
property String^ nationalTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nationalTaxAmount();
function set_nationalTaxAmount(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


nationalTaxIndicator Property

[image]

.NET Framework Class Library
OtherTax..::.nationalTaxIndicator Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property nationalTaxIndicator As String
C#
public string nationalTaxIndicator { get; set; }
Visual C++
public:
property String^ nationalTaxIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nationalTaxIndicator();
function set_nationalTaxIndicator(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


vatTaxAmount Property

[image]

.NET Framework Class Library
OtherTax..::.vatTaxAmount Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property vatTaxAmount As String
C#
public string vatTaxAmount { get; set; }
Visual C++
public:
property String^ vatTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vatTaxAmount();
function set_vatTaxAmount(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


vatTaxRate Property

[image]

.NET Framework Class Library
OtherTax..::.vatTaxRate Property
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property vatTaxRate As String
C#
public string vatTaxRate { get; set; }
Visual C++
public:
property String^ vatTaxRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vatTaxRate();
function set_vatTaxRate(value);

Remarks

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


OtherTax Events

[image] [image]

.NET Framework Class Library
OtherTax Events
OtherTax Class See Also Send Feedback

The OtherTax type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
OtherTax..::.PropertyChanged Event
OtherTax Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

OtherTax Class
InSite.Domain.CyberSourceService Namespace


outputMessageOut Class

[image]

.NET Framework Class Library
outputMessageOut Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<MessageContractAttribute(IsWrapped := False)> _
<GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")> _
Public Class outputMessageOut
C#
[MessageContractAttribute(IsWrapped = false)]
[GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
public class outputMessageOut
Visual C++
[MessageContractAttribute(IsWrapped = false)]
[GeneratedCodeAttribute(L"System.ServiceModel", L"3.0.0.0")]
public ref class outputMessageOut
JavaScript
InSite.Domain.CyberSourceService.outputMessageOut = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.outputMessageOut');

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.outputMessageOut

See Also

outputMessageOut Members
InSite.Domain.CyberSourceService Namespace


outputMessageOut Members

[image] [image]

.NET Framework Class Library
outputMessageOut Members
outputMessageOut Class Constructors Methods Fields See Also Send Feedback

The outputMessageOut type exposes the following members.

Constructors

Name | Description
outputMessageOut | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
replyMessage |

See Also

outputMessageOut Class
InSite.Domain.CyberSourceService Namespace


outputMessageOut Constructor

[image] [image]

.NET Framework Class Library
outputMessageOut Constructor
outputMessageOut Class See Also Send Feedback

Overload List

Name | Description
outputMessageOut()()() |
outputMessageOut(ReplyMessage) |

See Also

outputMessageOut Class
outputMessageOut Members
InSite.Domain.CyberSourceService Namespace


outputMessageOut Constructor

[image]

.NET Framework Class Library
outputMessageOut Constructor
outputMessageOut Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public outputMessageOut()
Visual C++
public:
outputMessageOut()
JavaScript
InSite.Domain.CyberSourceService.outputMessageOut = function();

See Also

outputMessageOut Class
outputMessageOut Overload
InSite.Domain.CyberSourceService Namespace


outputMessageOut Constructor (ReplyMessage)

[image]

.NET Framework Class Library
outputMessageOut Constructor (ReplyMessage)
outputMessageOut Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    replyMessage As ReplyMessage _
)
C#
public outputMessageOut(
    ReplyMessage replyMessage
)
Visual C++
public:
outputMessageOut(
    ReplyMessage^ replyMessage
)
JavaScript
InSite.Domain.CyberSourceService.outputMessageOut = function(replyMessage);

Parameters

replyMessage
Type: InSite.Domain.CyberSourceService..::.ReplyMessage

See Also

outputMessageOut Class
outputMessageOut Overload
InSite.Domain.CyberSourceService Namespace


outputMessageOut Fields

[image] [image]

.NET Framework Class Library
outputMessageOut Fields
outputMessageOut Class See Also Send Feedback

The outputMessageOut type exposes the following members.

Fields

Name | Description
replyMessage |

See Also

outputMessageOut Class
InSite.Domain.CyberSourceService Namespace


replyMessage Field

[image]

.NET Framework Class Library
outputMessageOut..::.replyMessage Field
outputMessageOut Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<MessageBodyMemberAttribute(Namespace := "urn:schemas-cybersource-com:transaction-data-1.42",  _
    Order := )> _
Public replyMessage As ReplyMessage
C#
[MessageBodyMemberAttribute(Namespace = "urn:schemas-cybersource-com:transaction-data-1.42",
    Order = )]
public ReplyMessage replyMessage
Visual C++
[MessageBodyMemberAttribute(Namespace = L"urn:schemas-cybersource-com:transaction-data-1.42",
    Order = )]
public:
ReplyMessage^ replyMessage
JavaScript
replyMessage

See Also

outputMessageOut Class
InSite.Domain.CyberSourceService Namespace


outputMessageOut Methods

[image] [image]

.NET Framework Class Library
outputMessageOut Methods
outputMessageOut Class See Also Send Feedback

The outputMessageOut type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

outputMessageOut Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollReply Class

[image]

.NET Framework Class Library
PayerAuthEnrollReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayerAuthEnrollReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayerAuthEnrollReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayerAuthEnrollReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayerAuthEnrollReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayerAuthEnrollReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayerAuthEnrollReply

See Also

PayerAuthEnrollReply Members
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollReply Members

[image] [image]

.NET Framework Class Library
PayerAuthEnrollReply Members
PayerAuthEnrollReply Class Constructors Methods Properties Events See Also Send Feedback

The PayerAuthEnrollReply type exposes the following members.

Constructors

Name | Description
PayerAuthEnrollReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
acsURL |
commerceIndicator |
eci |
paReq |
proofXML |
proxyPAN |
reasonCode |
ucafCollectionIndicator |
veresEnrolled |
xid |

Events

Name | Description
PropertyChanged |

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollReply Constructor

[image]

.NET Framework Class Library
PayerAuthEnrollReply Constructor
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayerAuthEnrollReply()
Visual C++
public:
PayerAuthEnrollReply()
JavaScript
InSite.Domain.CyberSourceService.PayerAuthEnrollReply = function();

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollReply Methods

[image] [image]

.NET Framework Class Library
PayerAuthEnrollReply Methods
PayerAuthEnrollReply Class See Also Send Feedback

The PayerAuthEnrollReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.RaisePropertyChanged Method
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollReply Properties

[image] [image]

.NET Framework Class Library
PayerAuthEnrollReply Properties
PayerAuthEnrollReply Class See Also Send Feedback

The PayerAuthEnrollReply type exposes the following members.

Properties

Name | Description
acsURL |
commerceIndicator |
eci |
paReq |
proofXML |
proxyPAN |
reasonCode |
ucafCollectionIndicator |
veresEnrolled |
xid |

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


acsURL Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.acsURL Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property acsURL As String
C#
public string acsURL { get; set; }
Visual C++
public:
property String^ acsURL {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_acsURL();
function set_acsURL(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


commerceIndicator Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.commerceIndicator Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commerceIndicator As String
C#
public string commerceIndicator { get; set; }
Visual C++
public:
property String^ commerceIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commerceIndicator();
function set_commerceIndicator(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


eci Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.eci Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property eci As String
C#
public string eci { get; set; }
Visual C++
public:
property String^ eci {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_eci();
function set_eci(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


paReq Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.paReq Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paReq As String
C#
public string paReq { get; set; }
Visual C++
public:
property String^ paReq {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paReq();
function set_paReq(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


proofXML Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.proofXML Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property proofXML As String
C#
public string proofXML { get; set; }
Visual C++
public:
property String^ proofXML {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_proofXML();
function set_proofXML(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


proxyPAN Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.proxyPAN Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property proxyPAN As String
C#
public string proxyPAN { get; set; }
Visual C++
public:
property String^ proxyPAN {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_proxyPAN();
function set_proxyPAN(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.reasonCode Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


ucafCollectionIndicator Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.ucafCollectionIndicator Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ucafCollectionIndicator As String
C#
public string ucafCollectionIndicator { get; set; }
Visual C++
public:
property String^ ucafCollectionIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ucafCollectionIndicator();
function set_ucafCollectionIndicator(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


veresEnrolled Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.veresEnrolled Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property veresEnrolled As String
C#
public string veresEnrolled { get; set; }
Visual C++
public:
property String^ veresEnrolled {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_veresEnrolled();
function set_veresEnrolled(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


xid Property

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.xid Property
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property xid As String
C#
public string xid { get; set; }
Visual C++
public:
property String^ xid {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_xid();
function set_xid(value);

Remarks

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollReply Events

[image] [image]

.NET Framework Class Library
PayerAuthEnrollReply Events
PayerAuthEnrollReply Class See Also Send Feedback

The PayerAuthEnrollReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayerAuthEnrollReply..::.PropertyChanged Event
PayerAuthEnrollReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayerAuthEnrollReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollService Class

[image]

.NET Framework Class Library
PayerAuthEnrollService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayerAuthEnrollService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayerAuthEnrollService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayerAuthEnrollService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayerAuthEnrollService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayerAuthEnrollService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayerAuthEnrollService

See Also

PayerAuthEnrollService Members
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollService Members

[image] [image]

.NET Framework Class Library
PayerAuthEnrollService Members
PayerAuthEnrollService Class Constructors Methods Properties Events See Also Send Feedback

The PayerAuthEnrollService type exposes the following members.

Constructors

Name | Description
PayerAuthEnrollService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
acquirerBin |
countryCode |
httpAccept |
httpUserAgent |
loginID |
merchantID |
merchantName |
merchantURL |
password |
purchaseDescription |
purchaseTime |
run |

Events

Name | Description
PropertyChanged |

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollService Constructor

[image]

.NET Framework Class Library
PayerAuthEnrollService Constructor
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayerAuthEnrollService()
Visual C++
public:
PayerAuthEnrollService()
JavaScript
InSite.Domain.CyberSourceService.PayerAuthEnrollService = function();

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollService Methods

[image] [image]

.NET Framework Class Library
PayerAuthEnrollService Methods
PayerAuthEnrollService Class See Also Send Feedback

The PayerAuthEnrollService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.RaisePropertyChanged Method
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollService Properties

[image] [image]

.NET Framework Class Library
PayerAuthEnrollService Properties
PayerAuthEnrollService Class See Also Send Feedback

The PayerAuthEnrollService type exposes the following members.

Properties

Name | Description
acquirerBin |
countryCode |
httpAccept |
httpUserAgent |
loginID |
merchantID |
merchantName |
merchantURL |
password |
purchaseDescription |
purchaseTime |
run |

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


acquirerBin Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.acquirerBin Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property acquirerBin As String
C#
public string acquirerBin { get; set; }
Visual C++
public:
property String^ acquirerBin {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_acquirerBin();
function set_acquirerBin(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


countryCode Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.countryCode Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countryCode As String
C#
public string countryCode { get; set; }
Visual C++
public:
property String^ countryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryCode();
function set_countryCode(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


httpAccept Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.httpAccept Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property httpAccept As String
C#
public string httpAccept { get; set; }
Visual C++
public:
property String^ httpAccept {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_httpAccept();
function set_httpAccept(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


httpUserAgent Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.httpUserAgent Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property httpUserAgent As String
C#
public string httpUserAgent { get; set; }
Visual C++
public:
property String^ httpUserAgent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_httpUserAgent();
function set_httpUserAgent(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


loginID Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.loginID Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property loginID As String
C#
public string loginID { get; set; }
Visual C++
public:
property String^ loginID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_loginID();
function set_loginID(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


merchantID Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.merchantID Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantID As String
C#
public string merchantID { get; set; }
Visual C++
public:
property String^ merchantID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantID();
function set_merchantID(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


merchantName Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.merchantName Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantName As String
C#
public string merchantName { get; set; }
Visual C++
public:
property String^ merchantName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantName();
function set_merchantName(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


merchantURL Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.merchantURL Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantURL As String
C#
public string merchantURL { get; set; }
Visual C++
public:
property String^ merchantURL {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantURL();
function set_merchantURL(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


password Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.password Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property password As String
C#
public string password { get; set; }
Visual C++
public:
property String^ password {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_password();
function set_password(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


purchaseDescription Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.purchaseDescription Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchaseDescription As String
C#
public string purchaseDescription { get; set; }
Visual C++
public:
property String^ purchaseDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchaseDescription();
function set_purchaseDescription(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


purchaseTime Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.purchaseTime Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchaseTime As String
C#
public string purchaseTime { get; set; }
Visual C++
public:
property String^ purchaseTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purchaseTime();
function set_purchaseTime(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.run Property
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthEnrollService Events

[image] [image]

.NET Framework Class Library
PayerAuthEnrollService Events
PayerAuthEnrollService Class See Also Send Feedback

The PayerAuthEnrollService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayerAuthEnrollService..::.PropertyChanged Event
PayerAuthEnrollService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayerAuthEnrollService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateReply Class

[image]

.NET Framework Class Library
PayerAuthValidateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayerAuthValidateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayerAuthValidateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayerAuthValidateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayerAuthValidateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayerAuthValidateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayerAuthValidateReply

See Also

PayerAuthValidateReply Members
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateReply Members

[image] [image]

.NET Framework Class Library
PayerAuthValidateReply Members
PayerAuthValidateReply Class Constructors Methods Properties Events See Also Send Feedback

The PayerAuthValidateReply type exposes the following members.

Constructors

Name | Description
PayerAuthValidateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
authenticationResult |
authenticationStatusMessage |
cavv |
cavvAlgorithm |
commerceIndicator |
eci |
eciRaw |
paresStatus |
reasonCode |
ucafAuthenticationData |
ucafCollectionIndicator |
xid |

Events

Name | Description
PropertyChanged |

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateReply Constructor

[image]

.NET Framework Class Library
PayerAuthValidateReply Constructor
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayerAuthValidateReply()
Visual C++
public:
PayerAuthValidateReply()
JavaScript
InSite.Domain.CyberSourceService.PayerAuthValidateReply = function();

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateReply Methods

[image] [image]

.NET Framework Class Library
PayerAuthValidateReply Methods
PayerAuthValidateReply Class See Also Send Feedback

The PayerAuthValidateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.RaisePropertyChanged Method
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateReply Properties

[image] [image]

.NET Framework Class Library
PayerAuthValidateReply Properties
PayerAuthValidateReply Class See Also Send Feedback

The PayerAuthValidateReply type exposes the following members.

Properties

Name | Description
authenticationResult |
authenticationStatusMessage |
cavv |
cavvAlgorithm |
commerceIndicator |
eci |
eciRaw |
paresStatus |
reasonCode |
ucafAuthenticationData |
ucafCollectionIndicator |
xid |

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


authenticationResult Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.authenticationResult Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authenticationResult As String
C#
public string authenticationResult { get; set; }
Visual C++
public:
property String^ authenticationResult {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authenticationResult();
function set_authenticationResult(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


authenticationStatusMessage Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.authenticationStatusMessage Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authenticationStatusMessage As String
C#
public string authenticationStatusMessage { get; set; }
Visual C++
public:
property String^ authenticationStatusMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authenticationStatusMessage();
function set_authenticationStatusMessage(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


cavv Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.cavv Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cavv As String
C#
public string cavv { get; set; }
Visual C++
public:
property String^ cavv {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cavv();
function set_cavv(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


cavvAlgorithm Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.cavvAlgorithm Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cavvAlgorithm As String
C#
public string cavvAlgorithm { get; set; }
Visual C++
public:
property String^ cavvAlgorithm {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cavvAlgorithm();
function set_cavvAlgorithm(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


commerceIndicator Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.commerceIndicator Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commerceIndicator As String
C#
public string commerceIndicator { get; set; }
Visual C++
public:
property String^ commerceIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commerceIndicator();
function set_commerceIndicator(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


eci Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.eci Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property eci As String
C#
public string eci { get; set; }
Visual C++
public:
property String^ eci {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_eci();
function set_eci(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


eciRaw Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.eciRaw Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property eciRaw As String
C#
public string eciRaw { get; set; }
Visual C++
public:
property String^ eciRaw {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_eciRaw();
function set_eciRaw(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


paresStatus Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.paresStatus Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paresStatus As String
C#
public string paresStatus { get; set; }
Visual C++
public:
property String^ paresStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paresStatus();
function set_paresStatus(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.reasonCode Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


ucafAuthenticationData Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.ucafAuthenticationData Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ucafAuthenticationData As String
C#
public string ucafAuthenticationData { get; set; }
Visual C++
public:
property String^ ucafAuthenticationData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ucafAuthenticationData();
function set_ucafAuthenticationData(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


ucafCollectionIndicator Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.ucafCollectionIndicator Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ucafCollectionIndicator As String
C#
public string ucafCollectionIndicator { get; set; }
Visual C++
public:
property String^ ucafCollectionIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ucafCollectionIndicator();
function set_ucafCollectionIndicator(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


xid Property

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.xid Property
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property xid As String
C#
public string xid { get; set; }
Visual C++
public:
property String^ xid {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_xid();
function set_xid(value);

Remarks

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateReply Events

[image] [image]

.NET Framework Class Library
PayerAuthValidateReply Events
PayerAuthValidateReply Class See Also Send Feedback

The PayerAuthValidateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayerAuthValidateReply..::.PropertyChanged Event
PayerAuthValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayerAuthValidateReply Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateService Class

[image]

.NET Framework Class Library
PayerAuthValidateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayerAuthValidateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayerAuthValidateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayerAuthValidateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayerAuthValidateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayerAuthValidateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayerAuthValidateService

See Also

PayerAuthValidateService Members
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateService Members

[image] [image]

.NET Framework Class Library
PayerAuthValidateService Members
PayerAuthValidateService Class Constructors Methods Properties Events See Also Send Feedback

The PayerAuthValidateService type exposes the following members.

Constructors

Name | Description
PayerAuthValidateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |
signedPARes |

Events

Name | Description
PropertyChanged |

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateService Constructor

[image]

.NET Framework Class Library
PayerAuthValidateService Constructor
PayerAuthValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayerAuthValidateService()
Visual C++
public:
PayerAuthValidateService()
JavaScript
InSite.Domain.CyberSourceService.PayerAuthValidateService = function();

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateService Methods

[image] [image]

.NET Framework Class Library
PayerAuthValidateService Methods
PayerAuthValidateService Class See Also Send Feedback

The PayerAuthValidateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayerAuthValidateService..::.RaisePropertyChanged Method
PayerAuthValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateService Properties

[image] [image]

.NET Framework Class Library
PayerAuthValidateService Properties
PayerAuthValidateService Class See Also Send Feedback

The PayerAuthValidateService type exposes the following members.

Properties

Name | Description
run |
signedPARes |

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayerAuthValidateService..::.run Property
PayerAuthValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


signedPARes Property

[image]

.NET Framework Class Library
PayerAuthValidateService..::.signedPARes Property
PayerAuthValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property signedPARes As String
C#
public string signedPARes { get; set; }
Visual C++
public:
property String^ signedPARes {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_signedPARes();
function set_signedPARes(value);

Remarks

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


PayerAuthValidateService Events

[image] [image]

.NET Framework Class Library
PayerAuthValidateService Events
PayerAuthValidateService Class See Also Send Feedback

The PayerAuthValidateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayerAuthValidateService..::.PropertyChanged Event
PayerAuthValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayerAuthValidateService Class
InSite.Domain.CyberSourceService Namespace


PayPal Class

[image]

.NET Framework Class Library
PayPal Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPal _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPal : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPal : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPal = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPal',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPal

See Also

PayPal Members
InSite.Domain.CyberSourceService Namespace


PayPal Members

[image] [image]

.NET Framework Class Library
PayPal Members
PayPal Class Constructors Methods Properties Events See Also Send Feedback

The PayPal type exposes the following members.

Constructors

Name | Description
PayPal |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Any |

Events

Name | Description
PropertyChanged |

See Also

PayPal Class
InSite.Domain.CyberSourceService Namespace


PayPal Constructor

[image]

.NET Framework Class Library
PayPal Constructor
PayPal Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPal()
Visual C++
public:
PayPal()
JavaScript
InSite.Domain.CyberSourceService.PayPal = function();

See Also

PayPal Class
InSite.Domain.CyberSourceService Namespace


PayPal Methods

[image] [image]

.NET Framework Class Library
PayPal Methods
PayPal Class See Also Send Feedback

The PayPal type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPal Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPal..::.RaisePropertyChanged Method
PayPal Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPal Class
InSite.Domain.CyberSourceService Namespace


PayPal Properties

[image] [image]

.NET Framework Class Library
PayPal Properties
PayPal Class See Also Send Feedback

The PayPal type exposes the following members.

Properties

Name | Description
Any |

See Also

PayPal Class
InSite.Domain.CyberSourceService Namespace


Any Property

[image]

.NET Framework Class Library
PayPal..::.Any Property
PayPal Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Any As XmlElement()
C#
public XmlElement[] Any { get; set; }
Visual C++
public:
property array<XmlElement^>^ Any {
    array<XmlElement^>^ get ();
    void set (array<XmlElement^>^ value);
}
JavaScript
function get_any();
function set_any(value);

Remarks

See Also

PayPal Class
InSite.Domain.CyberSourceService Namespace


PayPal Events

[image] [image]

.NET Framework Class Library
PayPal Events
PayPal Class See Also Send Feedback

The PayPal type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPal Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPal..::.PropertyChanged Event
PayPal Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPal Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationReply Class

[image]

.NET Framework Class Library
PayPalAuthorizationReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalAuthorizationReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalAuthorizationReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalAuthorizationReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalAuthorizationReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalAuthorizationReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalAuthorizationReply

See Also

PayPalAuthorizationReply Members
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationReply Members

[image] [image]

.NET Framework Class Library
PayPalAuthorizationReply Members
PayPalAuthorizationReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalAuthorizationReply type exposes the following members.

Constructors

Name | Description
PayPalAuthorizationReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
correlationID |
currency |
errorCode |
paypalAmount |
reasonCode |
transactionId |

Events

Name | Description
PropertyChanged |

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationReply Constructor

[image]

.NET Framework Class Library
PayPalAuthorizationReply Constructor
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalAuthorizationReply()
Visual C++
public:
PayPalAuthorizationReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalAuthorizationReply = function();

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationReply Methods

[image] [image]

.NET Framework Class Library
PayPalAuthorizationReply Methods
PayPalAuthorizationReply Class See Also Send Feedback

The PayPalAuthorizationReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.RaisePropertyChanged Method
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationReply Properties

[image] [image]

.NET Framework Class Library
PayPalAuthorizationReply Properties
PayPalAuthorizationReply Class See Also Send Feedback

The PayPalAuthorizationReply type exposes the following members.

Properties

Name | Description
amount |
correlationID |
currency |
errorCode |
paypalAmount |
reasonCode |
transactionId |

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.amount Property
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


correlationID Property

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.correlationID Property
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property correlationID As String
C#
public string correlationID { get; set; }
Visual C++
public:
property String^ correlationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_correlationID();
function set_correlationID(value);

Remarks

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.currency Property
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


errorCode Property

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.errorCode Property
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property errorCode As String
C#
public string errorCode { get; set; }
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorCode();
function set_errorCode(value);

Remarks

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


paypalAmount Property

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.paypalAmount Property
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAmount As String
C#
public string paypalAmount { get; set; }
Visual C++
public:
property String^ paypalAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAmount();
function set_paypalAmount(value);

Remarks

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.reasonCode Property
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


transactionId Property

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.transactionId Property
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionId As String
C#
public string transactionId { get; set; }
Visual C++
public:
property String^ transactionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionId();
function set_transactionId(value);

Remarks

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationReply Events

[image] [image]

.NET Framework Class Library
PayPalAuthorizationReply Events
PayPalAuthorizationReply Class See Also Send Feedback

The PayPalAuthorizationReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalAuthorizationReply..::.PropertyChanged Event
PayPalAuthorizationReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalAuthorizationReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationService Class

[image]

.NET Framework Class Library
PayPalAuthorizationService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalAuthorizationService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalAuthorizationService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalAuthorizationService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalAuthorizationService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalAuthorizationService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalAuthorizationService

See Also

PayPalAuthorizationService Members
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationService Members

[image] [image]

.NET Framework Class Library
PayPalAuthorizationService Members
PayPalAuthorizationService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalAuthorizationService type exposes the following members.

Constructors

Name | Description
PayPalAuthorizationService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
paypalCustomerEmail |
paypalEcOrderSetupRequestID |
paypalEcOrderSetupRequestToken |
paypalOrderId |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationService Constructor

[image]

.NET Framework Class Library
PayPalAuthorizationService Constructor
PayPalAuthorizationService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalAuthorizationService()
Visual C++
public:
PayPalAuthorizationService()
JavaScript
InSite.Domain.CyberSourceService.PayPalAuthorizationService = function();

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationService Methods

[image] [image]

.NET Framework Class Library
PayPalAuthorizationService Methods
PayPalAuthorizationService Class See Also Send Feedback

The PayPalAuthorizationService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalAuthorizationService..::.RaisePropertyChanged Method
PayPalAuthorizationService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationService Properties

[image] [image]

.NET Framework Class Library
PayPalAuthorizationService Properties
PayPalAuthorizationService Class See Also Send Feedback

The PayPalAuthorizationService type exposes the following members.

Properties

Name | Description
paypalCustomerEmail |
paypalEcOrderSetupRequestID |
paypalEcOrderSetupRequestToken |
paypalOrderId |
run |

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


paypalCustomerEmail Property

[image]

.NET Framework Class Library
PayPalAuthorizationService..::.paypalCustomerEmail Property
PayPalAuthorizationService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalCustomerEmail As String
C#
public string paypalCustomerEmail { get; set; }
Visual C++
public:
property String^ paypalCustomerEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalCustomerEmail();
function set_paypalCustomerEmail(value);

Remarks

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


paypalEcOrderSetupRequestID Property

[image]

.NET Framework Class Library
PayPalAuthorizationService..::.paypalEcOrderSetupRequestID Property
PayPalAuthorizationService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcOrderSetupRequestID As String
C#
public string paypalEcOrderSetupRequestID { get; set; }
Visual C++
public:
property String^ paypalEcOrderSetupRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcOrderSetupRequestID();
function set_paypalEcOrderSetupRequestID(value);

Remarks

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


paypalEcOrderSetupRequestToken Property

[image]

.NET Framework Class Library
PayPalAuthorizationService..::.paypalEcOrderSetupRequestToken Property
PayPalAuthorizationService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcOrderSetupRequestToken As String
C#
public string paypalEcOrderSetupRequestToken { get; set; }
Visual C++
public:
property String^ paypalEcOrderSetupRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcOrderSetupRequestToken();
function set_paypalEcOrderSetupRequestToken(value);

Remarks

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


paypalOrderId Property

[image]

.NET Framework Class Library
PayPalAuthorizationService..::.paypalOrderId Property
PayPalAuthorizationService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalOrderId As String
C#
public string paypalOrderId { get; set; }
Visual C++
public:
property String^ paypalOrderId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalOrderId();
function set_paypalOrderId(value);

Remarks

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalAuthorizationService..::.run Property
PayPalAuthorizationService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthorizationService Events

[image] [image]

.NET Framework Class Library
PayPalAuthorizationService Events
PayPalAuthorizationService Class See Also Send Feedback

The PayPalAuthorizationService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalAuthorizationService..::.PropertyChanged Event
PayPalAuthorizationService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalAuthorizationService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalReply Class

[image]

.NET Framework Class Library
PayPalAuthReversalReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalAuthReversalReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalAuthReversalReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalAuthReversalReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalAuthReversalReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalAuthReversalReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalAuthReversalReply

See Also

PayPalAuthReversalReply Members
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalReply Members

[image] [image]

.NET Framework Class Library
PayPalAuthReversalReply Members
PayPalAuthReversalReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalAuthReversalReply type exposes the following members.

Constructors

Name | Description
PayPalAuthReversalReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
authorizationId |
correlationID |
errorCode |
reasonCode |

Events

Name | Description
PropertyChanged |

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalReply Constructor

[image]

.NET Framework Class Library
PayPalAuthReversalReply Constructor
PayPalAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalAuthReversalReply()
Visual C++
public:
PayPalAuthReversalReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalAuthReversalReply = function();

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalReply Methods

[image] [image]

.NET Framework Class Library
PayPalAuthReversalReply Methods
PayPalAuthReversalReply Class See Also Send Feedback

The PayPalAuthReversalReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalAuthReversalReply..::.RaisePropertyChanged Method
PayPalAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalReply Properties

[image] [image]

.NET Framework Class Library
PayPalAuthReversalReply Properties
PayPalAuthReversalReply Class See Also Send Feedback

The PayPalAuthReversalReply type exposes the following members.

Properties

Name | Description
authorizationId |
correlationID |
errorCode |
reasonCode |

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


authorizationId Property

[image]

.NET Framework Class Library
PayPalAuthReversalReply..::.authorizationId Property
PayPalAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationId As String
C#
public string authorizationId { get; set; }
Visual C++
public:
property String^ authorizationId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationId();
function set_authorizationId(value);

Remarks

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


correlationID Property

[image]

.NET Framework Class Library
PayPalAuthReversalReply..::.correlationID Property
PayPalAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property correlationID As String
C#
public string correlationID { get; set; }
Visual C++
public:
property String^ correlationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_correlationID();
function set_correlationID(value);

Remarks

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


errorCode Property

[image]

.NET Framework Class Library
PayPalAuthReversalReply..::.errorCode Property
PayPalAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property errorCode As String
C#
public string errorCode { get; set; }
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorCode();
function set_errorCode(value);

Remarks

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalAuthReversalReply..::.reasonCode Property
PayPalAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalReply Events

[image] [image]

.NET Framework Class Library
PayPalAuthReversalReply Events
PayPalAuthReversalReply Class See Also Send Feedback

The PayPalAuthReversalReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalAuthReversalReply..::.PropertyChanged Event
PayPalAuthReversalReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalAuthReversalReply Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalService Class

[image]

.NET Framework Class Library
PayPalAuthReversalService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalAuthReversalService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalAuthReversalService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalAuthReversalService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalAuthReversalService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalAuthReversalService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalAuthReversalService

See Also

PayPalAuthReversalService Members
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalService Members

[image] [image]

.NET Framework Class Library
PayPalAuthReversalService Members
PayPalAuthReversalService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalAuthReversalService type exposes the following members.

Constructors

Name | Description
PayPalAuthReversalService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
paypalAuthorizationId |
paypalAuthorizationRequestID |
paypalAuthorizationRequestToken |
paypalEcDoPaymentRequestID |
paypalEcDoPaymentRequestToken |
paypalEcOrderSetupRequestID |
paypalEcOrderSetupRequestToken |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalService Constructor

[image]

.NET Framework Class Library
PayPalAuthReversalService Constructor
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalAuthReversalService()
Visual C++
public:
PayPalAuthReversalService()
JavaScript
InSite.Domain.CyberSourceService.PayPalAuthReversalService = function();

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalService Methods

[image] [image]

.NET Framework Class Library
PayPalAuthReversalService Methods
PayPalAuthReversalService Class See Also Send Feedback

The PayPalAuthReversalService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.RaisePropertyChanged Method
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalService Properties

[image] [image]

.NET Framework Class Library
PayPalAuthReversalService Properties
PayPalAuthReversalService Class See Also Send Feedback

The PayPalAuthReversalService type exposes the following members.

Properties

Name | Description
paypalAuthorizationId |
paypalAuthorizationRequestID |
paypalAuthorizationRequestToken |
paypalEcDoPaymentRequestID |
paypalEcDoPaymentRequestToken |
paypalEcOrderSetupRequestID |
paypalEcOrderSetupRequestToken |
run |

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


paypalAuthorizationId Property

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.paypalAuthorizationId Property
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAuthorizationId As String
C#
public string paypalAuthorizationId { get; set; }
Visual C++
public:
property String^ paypalAuthorizationId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAuthorizationId();
function set_paypalAuthorizationId(value);

Remarks

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


paypalAuthorizationRequestID Property

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.paypalAuthorizationRequestID Property
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAuthorizationRequestID As String
C#
public string paypalAuthorizationRequestID { get; set; }
Visual C++
public:
property String^ paypalAuthorizationRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAuthorizationRequestID();
function set_paypalAuthorizationRequestID(value);

Remarks

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


paypalAuthorizationRequestToken Property

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.paypalAuthorizationRequestToken Property
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAuthorizationRequestToken As String
C#
public string paypalAuthorizationRequestToken { get; set; }
Visual C++
public:
property String^ paypalAuthorizationRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAuthorizationRequestToken();
function set_paypalAuthorizationRequestToken(value);

Remarks

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


paypalEcDoPaymentRequestID Property

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.paypalEcDoPaymentRequestID Property
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcDoPaymentRequestID As String
C#
public string paypalEcDoPaymentRequestID { get; set; }
Visual C++
public:
property String^ paypalEcDoPaymentRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcDoPaymentRequestID();
function set_paypalEcDoPaymentRequestID(value);

Remarks

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


paypalEcDoPaymentRequestToken Property

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.paypalEcDoPaymentRequestToken Property
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcDoPaymentRequestToken As String
C#
public string paypalEcDoPaymentRequestToken { get; set; }
Visual C++
public:
property String^ paypalEcDoPaymentRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcDoPaymentRequestToken();
function set_paypalEcDoPaymentRequestToken(value);

Remarks

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


paypalEcOrderSetupRequestID Property

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.paypalEcOrderSetupRequestID Property
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcOrderSetupRequestID As String
C#
public string paypalEcOrderSetupRequestID { get; set; }
Visual C++
public:
property String^ paypalEcOrderSetupRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcOrderSetupRequestID();
function set_paypalEcOrderSetupRequestID(value);

Remarks

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


paypalEcOrderSetupRequestToken Property

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.paypalEcOrderSetupRequestToken Property
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcOrderSetupRequestToken As String
C#
public string paypalEcOrderSetupRequestToken { get; set; }
Visual C++
public:
property String^ paypalEcOrderSetupRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcOrderSetupRequestToken();
function set_paypalEcOrderSetupRequestToken(value);

Remarks

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.run Property
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


PayPalAuthReversalService Events

[image] [image]

.NET Framework Class Library
PayPalAuthReversalService Events
PayPalAuthReversalService Class See Also Send Feedback

The PayPalAuthReversalService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalAuthReversalService..::.PropertyChanged Event
PayPalAuthReversalService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalAuthReversalService Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateReply Class

[image]

.NET Framework Class Library
PayPalButtonCreateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalButtonCreateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalButtonCreateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalButtonCreateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalButtonCreateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalButtonCreateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalButtonCreateReply

See Also

PayPalButtonCreateReply Members
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateReply Members

[image] [image]

.NET Framework Class Library
PayPalButtonCreateReply Members
PayPalButtonCreateReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalButtonCreateReply type exposes the following members.

Constructors

Name | Description
PayPalButtonCreateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
buttonType |
encryptedFormData |
reasonCode |
reconciliationID |
requestDateTime |
unencryptedFormData |

Events

Name | Description
PropertyChanged |

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateReply Constructor

[image]

.NET Framework Class Library
PayPalButtonCreateReply Constructor
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalButtonCreateReply()
Visual C++
public:
PayPalButtonCreateReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalButtonCreateReply = function();

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateReply Methods

[image] [image]

.NET Framework Class Library
PayPalButtonCreateReply Methods
PayPalButtonCreateReply Class See Also Send Feedback

The PayPalButtonCreateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalButtonCreateReply..::.RaisePropertyChanged Method
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateReply Properties

[image] [image]

.NET Framework Class Library
PayPalButtonCreateReply Properties
PayPalButtonCreateReply Class See Also Send Feedback

The PayPalButtonCreateReply type exposes the following members.

Properties

Name | Description
buttonType |
encryptedFormData |
reasonCode |
reconciliationID |
requestDateTime |
unencryptedFormData |

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


buttonType Property

[image]

.NET Framework Class Library
PayPalButtonCreateReply..::.buttonType Property
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property buttonType As String
C#
public string buttonType { get; set; }
Visual C++
public:
property String^ buttonType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_buttonType();
function set_buttonType(value);

Remarks

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


encryptedFormData Property

[image]

.NET Framework Class Library
PayPalButtonCreateReply..::.encryptedFormData Property
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property encryptedFormData As String
C#
public string encryptedFormData { get; set; }
Visual C++
public:
property String^ encryptedFormData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_encryptedFormData();
function set_encryptedFormData(value);

Remarks

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalButtonCreateReply..::.reasonCode Property
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalButtonCreateReply..::.reconciliationID Property
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
PayPalButtonCreateReply..::.requestDateTime Property
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


unencryptedFormData Property

[image]

.NET Framework Class Library
PayPalButtonCreateReply..::.unencryptedFormData Property
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property unencryptedFormData As String
C#
public string unencryptedFormData { get; set; }
Visual C++
public:
property String^ unencryptedFormData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_unencryptedFormData();
function set_unencryptedFormData(value);

Remarks

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateReply Events

[image] [image]

.NET Framework Class Library
PayPalButtonCreateReply Events
PayPalButtonCreateReply Class See Also Send Feedback

The PayPalButtonCreateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalButtonCreateReply..::.PropertyChanged Event
PayPalButtonCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalButtonCreateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateService Class

[image]

.NET Framework Class Library
PayPalButtonCreateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalButtonCreateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalButtonCreateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalButtonCreateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalButtonCreateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalButtonCreateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalButtonCreateService

See Also

PayPalButtonCreateService Members
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateService Members

[image] [image]

.NET Framework Class Library
PayPalButtonCreateService Members
PayPalButtonCreateService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalButtonCreateService type exposes the following members.

Constructors

Name | Description
PayPalButtonCreateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
buttonType |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateService Constructor

[image]

.NET Framework Class Library
PayPalButtonCreateService Constructor
PayPalButtonCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalButtonCreateService()
Visual C++
public:
PayPalButtonCreateService()
JavaScript
InSite.Domain.CyberSourceService.PayPalButtonCreateService = function();

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateService Methods

[image] [image]

.NET Framework Class Library
PayPalButtonCreateService Methods
PayPalButtonCreateService Class See Also Send Feedback

The PayPalButtonCreateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalButtonCreateService..::.RaisePropertyChanged Method
PayPalButtonCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateService Properties

[image] [image]

.NET Framework Class Library
PayPalButtonCreateService Properties
PayPalButtonCreateService Class See Also Send Feedback

The PayPalButtonCreateService type exposes the following members.

Properties

Name | Description
buttonType |
reconciliationID |
run |

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


buttonType Property

[image]

.NET Framework Class Library
PayPalButtonCreateService..::.buttonType Property
PayPalButtonCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property buttonType As String
C#
public string buttonType { get; set; }
Visual C++
public:
property String^ buttonType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_buttonType();
function set_buttonType(value);

Remarks

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalButtonCreateService..::.reconciliationID Property
PayPalButtonCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalButtonCreateService..::.run Property
PayPalButtonCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


PayPalButtonCreateService Events

[image] [image]

.NET Framework Class Library
PayPalButtonCreateService Events
PayPalButtonCreateService Class See Also Send Feedback

The PayPalButtonCreateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalButtonCreateService..::.PropertyChanged Event
PayPalButtonCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalButtonCreateService Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditReply Class

[image]

.NET Framework Class Library
PayPalCreditReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalCreditReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalCreditReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalCreditReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalCreditReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalCreditReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalCreditReply

See Also

PayPalCreditReply Members
InSite.Domain.CyberSourceService Namespace


PayPalCreditReply Members

[image] [image]

.NET Framework Class Library
PayPalCreditReply Members
PayPalCreditReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalCreditReply type exposes the following members.

Constructors

Name | Description
PayPalCreditReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditReply Constructor

[image]

.NET Framework Class Library
PayPalCreditReply Constructor
PayPalCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalCreditReply()
Visual C++
public:
PayPalCreditReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalCreditReply = function();

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditReply Methods

[image] [image]

.NET Framework Class Library
PayPalCreditReply Methods
PayPalCreditReply Class See Also Send Feedback

The PayPalCreditReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalCreditReply..::.RaisePropertyChanged Method
PayPalCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditReply Properties

[image] [image]

.NET Framework Class Library
PayPalCreditReply Properties
PayPalCreditReply Class See Also Send Feedback

The PayPalCreditReply type exposes the following members.

Properties

Name | Description
amount |
processorResponse |
reasonCode |
reconciliationID |
requestDateTime |

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PayPalCreditReply..::.amount Property
PayPalCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
PayPalCreditReply..::.processorResponse Property
PayPalCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalCreditReply..::.reasonCode Property
PayPalCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalCreditReply..::.reconciliationID Property
PayPalCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
PayPalCreditReply..::.requestDateTime Property
PayPalCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditReply Events

[image] [image]

.NET Framework Class Library
PayPalCreditReply Events
PayPalCreditReply Class See Also Send Feedback

The PayPalCreditReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalCreditReply..::.PropertyChanged Event
PayPalCreditReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalCreditReply Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditService Class

[image]

.NET Framework Class Library
PayPalCreditService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalCreditService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalCreditService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalCreditService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalCreditService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalCreditService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalCreditService

See Also

PayPalCreditService Members
InSite.Domain.CyberSourceService Namespace


PayPalCreditService Members

[image] [image]

.NET Framework Class Library
PayPalCreditService Members
PayPalCreditService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalCreditService type exposes the following members.

Constructors

Name | Description
PayPalCreditService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
payPalPaymentRequestID |
payPalPaymentRequestToken |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditService Constructor

[image]

.NET Framework Class Library
PayPalCreditService Constructor
PayPalCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalCreditService()
Visual C++
public:
PayPalCreditService()
JavaScript
InSite.Domain.CyberSourceService.PayPalCreditService = function();

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditService Methods

[image] [image]

.NET Framework Class Library
PayPalCreditService Methods
PayPalCreditService Class See Also Send Feedback

The PayPalCreditService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalCreditService..::.RaisePropertyChanged Method
PayPalCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditService Properties

[image] [image]

.NET Framework Class Library
PayPalCreditService Properties
PayPalCreditService Class See Also Send Feedback

The PayPalCreditService type exposes the following members.

Properties

Name | Description
payPalPaymentRequestID |
payPalPaymentRequestToken |
reconciliationID |
run |

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


payPalPaymentRequestID Property

[image]

.NET Framework Class Library
PayPalCreditService..::.payPalPaymentRequestID Property
PayPalCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalPaymentRequestID As String
C#
public string payPalPaymentRequestID { get; set; }
Visual C++
public:
property String^ payPalPaymentRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payPalPaymentRequestID();
function set_payPalPaymentRequestID(value);

Remarks

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


payPalPaymentRequestToken Property

[image]

.NET Framework Class Library
PayPalCreditService..::.payPalPaymentRequestToken Property
PayPalCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalPaymentRequestToken As String
C#
public string payPalPaymentRequestToken { get; set; }
Visual C++
public:
property String^ payPalPaymentRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payPalPaymentRequestToken();
function set_payPalPaymentRequestToken(value);

Remarks

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalCreditService..::.reconciliationID Property
PayPalCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalCreditService..::.run Property
PayPalCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


PayPalCreditService Events

[image] [image]

.NET Framework Class Library
PayPalCreditService Events
PayPalCreditService Class See Also Send Feedback

The PayPalCreditService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalCreditService..::.PropertyChanged Event
PayPalCreditService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalCreditService Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureReply Class

[image]

.NET Framework Class Library
PayPalDoCaptureReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalDoCaptureReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalDoCaptureReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalDoCaptureReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalDoCaptureReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalDoCaptureReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalDoCaptureReply

See Also

PayPalDoCaptureReply Members
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureReply Members

[image] [image]

.NET Framework Class Library
PayPalDoCaptureReply Members
PayPalDoCaptureReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalDoCaptureReply type exposes the following members.

Constructors

Name | Description
PayPalDoCaptureReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
authorizationId |
correlationID |
currency |
errorCode |
parentTransactionId |
paypalExchangeRate |
paypalFeeAmount |
paypalOrderTime |
paypalPaymentGrossAmount |
paypalPaymentStatus |
paypalPaymentType |
paypalReceiptId |
paypalTaxAmount |
paypalTransactiontype |
reasonCode |
transactionId |

Events

Name | Description
PropertyChanged |

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureReply Constructor

[image]

.NET Framework Class Library
PayPalDoCaptureReply Constructor
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalDoCaptureReply()
Visual C++
public:
PayPalDoCaptureReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalDoCaptureReply = function();

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureReply Methods

[image] [image]

.NET Framework Class Library
PayPalDoCaptureReply Methods
PayPalDoCaptureReply Class See Also Send Feedback

The PayPalDoCaptureReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.RaisePropertyChanged Method
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureReply Properties

[image] [image]

.NET Framework Class Library
PayPalDoCaptureReply Properties
PayPalDoCaptureReply Class See Also Send Feedback

The PayPalDoCaptureReply type exposes the following members.

Properties

Name | Description
amount |
authorizationId |
correlationID |
currency |
errorCode |
parentTransactionId |
paypalExchangeRate |
paypalFeeAmount |
paypalOrderTime |
paypalPaymentGrossAmount |
paypalPaymentStatus |
paypalPaymentType |
paypalReceiptId |
paypalTaxAmount |
paypalTransactiontype |
reasonCode |
transactionId |

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.amount Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


authorizationId Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.authorizationId Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationId As String
C#
public string authorizationId { get; set; }
Visual C++
public:
property String^ authorizationId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationId();
function set_authorizationId(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


correlationID Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.correlationID Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property correlationID As String
C#
public string correlationID { get; set; }
Visual C++
public:
property String^ correlationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_correlationID();
function set_correlationID(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.currency Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


errorCode Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.errorCode Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property errorCode As String
C#
public string errorCode { get; set; }
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorCode();
function set_errorCode(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


parentTransactionId Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.parentTransactionId Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property parentTransactionId As String
C#
public string parentTransactionId { get; set; }
Visual C++
public:
property String^ parentTransactionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parentTransactionId();
function set_parentTransactionId(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalExchangeRate Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalExchangeRate Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalExchangeRate As String
C#
public string paypalExchangeRate { get; set; }
Visual C++
public:
property String^ paypalExchangeRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalExchangeRate();
function set_paypalExchangeRate(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalFeeAmount Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalFeeAmount Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalFeeAmount As String
C#
public string paypalFeeAmount { get; set; }
Visual C++
public:
property String^ paypalFeeAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalFeeAmount();
function set_paypalFeeAmount(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalOrderTime Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalOrderTime Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalOrderTime As String
C#
public string paypalOrderTime { get; set; }
Visual C++
public:
property String^ paypalOrderTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalOrderTime();
function set_paypalOrderTime(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalPaymentGrossAmount Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalPaymentGrossAmount Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPaymentGrossAmount As String
C#
public string paypalPaymentGrossAmount { get; set; }
Visual C++
public:
property String^ paypalPaymentGrossAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPaymentGrossAmount();
function set_paypalPaymentGrossAmount(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalPaymentStatus Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalPaymentStatus Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPaymentStatus As String
C#
public string paypalPaymentStatus { get; set; }
Visual C++
public:
property String^ paypalPaymentStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPaymentStatus();
function set_paypalPaymentStatus(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalPaymentType Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalPaymentType Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPaymentType As String
C#
public string paypalPaymentType { get; set; }
Visual C++
public:
property String^ paypalPaymentType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPaymentType();
function set_paypalPaymentType(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalReceiptId Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalReceiptId Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalReceiptId As String
C#
public string paypalReceiptId { get; set; }
Visual C++
public:
property String^ paypalReceiptId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalReceiptId();
function set_paypalReceiptId(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalTaxAmount Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalTaxAmount Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalTaxAmount As String
C#
public string paypalTaxAmount { get; set; }
Visual C++
public:
property String^ paypalTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalTaxAmount();
function set_paypalTaxAmount(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


paypalTransactiontype Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.paypalTransactiontype Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalTransactiontype As String
C#
public string paypalTransactiontype { get; set; }
Visual C++
public:
property String^ paypalTransactiontype {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalTransactiontype();
function set_paypalTransactiontype(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.reasonCode Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


transactionId Property

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.transactionId Property
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionId As String
C#
public string transactionId { get; set; }
Visual C++
public:
property String^ transactionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionId();
function set_transactionId(value);

Remarks

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureReply Events

[image] [image]

.NET Framework Class Library
PayPalDoCaptureReply Events
PayPalDoCaptureReply Class See Also Send Feedback

The PayPalDoCaptureReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalDoCaptureReply..::.PropertyChanged Event
PayPalDoCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalDoCaptureReply Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureService Class

[image]

.NET Framework Class Library
PayPalDoCaptureService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalDoCaptureService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalDoCaptureService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalDoCaptureService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalDoCaptureService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalDoCaptureService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalDoCaptureService

See Also

PayPalDoCaptureService Members
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureService Members

[image] [image]

.NET Framework Class Library
PayPalDoCaptureService Members
PayPalDoCaptureService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalDoCaptureService type exposes the following members.

Constructors

Name | Description
PayPalDoCaptureService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
completeType |
invoiceNumber |
paypalAuthorizationId |
paypalAuthorizationRequestID |
paypalAuthorizationRequestToken |
paypalEcDoPaymentRequestID |
paypalEcDoPaymentRequestToken |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureService Constructor

[image]

.NET Framework Class Library
PayPalDoCaptureService Constructor
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalDoCaptureService()
Visual C++
public:
PayPalDoCaptureService()
JavaScript
InSite.Domain.CyberSourceService.PayPalDoCaptureService = function();

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureService Methods

[image] [image]

.NET Framework Class Library
PayPalDoCaptureService Methods
PayPalDoCaptureService Class See Also Send Feedback

The PayPalDoCaptureService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.RaisePropertyChanged Method
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureService Properties

[image] [image]

.NET Framework Class Library
PayPalDoCaptureService Properties
PayPalDoCaptureService Class See Also Send Feedback

The PayPalDoCaptureService type exposes the following members.

Properties

Name | Description
completeType |
invoiceNumber |
paypalAuthorizationId |
paypalAuthorizationRequestID |
paypalAuthorizationRequestToken |
paypalEcDoPaymentRequestID |
paypalEcDoPaymentRequestToken |
run |

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


completeType Property

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.completeType Property
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property completeType As String
C#
public string completeType { get; set; }
Visual C++
public:
property String^ completeType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_completeType();
function set_completeType(value);

Remarks

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


invoiceNumber Property

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.invoiceNumber Property
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceNumber As String
C#
public string invoiceNumber { get; set; }
Visual C++
public:
property String^ invoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceNumber();
function set_invoiceNumber(value);

Remarks

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


paypalAuthorizationId Property

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.paypalAuthorizationId Property
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAuthorizationId As String
C#
public string paypalAuthorizationId { get; set; }
Visual C++
public:
property String^ paypalAuthorizationId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAuthorizationId();
function set_paypalAuthorizationId(value);

Remarks

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


paypalAuthorizationRequestID Property

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.paypalAuthorizationRequestID Property
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAuthorizationRequestID As String
C#
public string paypalAuthorizationRequestID { get; set; }
Visual C++
public:
property String^ paypalAuthorizationRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAuthorizationRequestID();
function set_paypalAuthorizationRequestID(value);

Remarks

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


paypalAuthorizationRequestToken Property

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.paypalAuthorizationRequestToken Property
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAuthorizationRequestToken As String
C#
public string paypalAuthorizationRequestToken { get; set; }
Visual C++
public:
property String^ paypalAuthorizationRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAuthorizationRequestToken();
function set_paypalAuthorizationRequestToken(value);

Remarks

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


paypalEcDoPaymentRequestID Property

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.paypalEcDoPaymentRequestID Property
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcDoPaymentRequestID As String
C#
public string paypalEcDoPaymentRequestID { get; set; }
Visual C++
public:
property String^ paypalEcDoPaymentRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcDoPaymentRequestID();
function set_paypalEcDoPaymentRequestID(value);

Remarks

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


paypalEcDoPaymentRequestToken Property

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.paypalEcDoPaymentRequestToken Property
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcDoPaymentRequestToken As String
C#
public string paypalEcDoPaymentRequestToken { get; set; }
Visual C++
public:
property String^ paypalEcDoPaymentRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcDoPaymentRequestToken();
function set_paypalEcDoPaymentRequestToken(value);

Remarks

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.run Property
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


PayPalDoCaptureService Events

[image] [image]

.NET Framework Class Library
PayPalDoCaptureService Events
PayPalDoCaptureService Class See Also Send Feedback

The PayPalDoCaptureService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalDoCaptureService..::.PropertyChanged Event
PayPalDoCaptureService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalDoCaptureService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentReply Class

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalEcDoPaymentReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalEcDoPaymentReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalEcDoPaymentReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalEcDoPaymentReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalEcDoPaymentReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalEcDoPaymentReply

See Also

PayPalEcDoPaymentReply Members
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentReply Members

[image] [image]

.NET Framework Class Library
PayPalEcDoPaymentReply Members
PayPalEcDoPaymentReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalEcDoPaymentReply type exposes the following members.

Constructors

Name | Description
PayPalEcDoPaymentReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
correlationID |
currency |
errorCode |
orderId |
paymentType |
paypalAmount |
paypalExchangeRate |
paypalFeeAmount |
paypalOrderTime |
paypalPaymentStatus |
paypalPendingReason |
paypalReasonCode |
paypalTaxAmount |
paypalToken |
paypalTransactiontype |
reasonCode |
transactionId |

Events

Name | Description
PropertyChanged |

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentReply Constructor

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply Constructor
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalEcDoPaymentReply()
Visual C++
public:
PayPalEcDoPaymentReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalEcDoPaymentReply = function();

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentReply Methods

[image] [image]

.NET Framework Class Library
PayPalEcDoPaymentReply Methods
PayPalEcDoPaymentReply Class See Also Send Feedback

The PayPalEcDoPaymentReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.RaisePropertyChanged Method
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentReply Properties

[image] [image]

.NET Framework Class Library
PayPalEcDoPaymentReply Properties
PayPalEcDoPaymentReply Class See Also Send Feedback

The PayPalEcDoPaymentReply type exposes the following members.

Properties

Name | Description
amount |
correlationID |
currency |
errorCode |
orderId |
paymentType |
paypalAmount |
paypalExchangeRate |
paypalFeeAmount |
paypalOrderTime |
paypalPaymentStatus |
paypalPendingReason |
paypalReasonCode |
paypalTaxAmount |
paypalToken |
paypalTransactiontype |
reasonCode |
transactionId |

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.amount Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


correlationID Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.correlationID Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property correlationID As String
C#
public string correlationID { get; set; }
Visual C++
public:
property String^ correlationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_correlationID();
function set_correlationID(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.currency Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


errorCode Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.errorCode Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property errorCode As String
C#
public string errorCode { get; set; }
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorCode();
function set_errorCode(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


orderId Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.orderId Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderId As String
C#
public string orderId { get; set; }
Visual C++
public:
property String^ orderId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderId();
function set_orderId(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paymentType Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paymentType Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentType As String
C#
public string paymentType { get; set; }
Visual C++
public:
property String^ paymentType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentType();
function set_paymentType(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalAmount Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalAmount Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAmount As String
C#
public string paypalAmount { get; set; }
Visual C++
public:
property String^ paypalAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAmount();
function set_paypalAmount(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalExchangeRate Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalExchangeRate Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalExchangeRate As String
C#
public string paypalExchangeRate { get; set; }
Visual C++
public:
property String^ paypalExchangeRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalExchangeRate();
function set_paypalExchangeRate(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalFeeAmount Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalFeeAmount Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalFeeAmount As String
C#
public string paypalFeeAmount { get; set; }
Visual C++
public:
property String^ paypalFeeAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalFeeAmount();
function set_paypalFeeAmount(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalOrderTime Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalOrderTime Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalOrderTime As String
C#
public string paypalOrderTime { get; set; }
Visual C++
public:
property String^ paypalOrderTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalOrderTime();
function set_paypalOrderTime(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalPaymentStatus Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalPaymentStatus Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPaymentStatus As String
C#
public string paypalPaymentStatus { get; set; }
Visual C++
public:
property String^ paypalPaymentStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPaymentStatus();
function set_paypalPaymentStatus(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalPendingReason Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalPendingReason Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPendingReason As String
C#
public string paypalPendingReason { get; set; }
Visual C++
public:
property String^ paypalPendingReason {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPendingReason();
function set_paypalPendingReason(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalReasonCode Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalReasonCode Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalReasonCode As String
C#
public string paypalReasonCode { get; set; }
Visual C++
public:
property String^ paypalReasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalReasonCode();
function set_paypalReasonCode(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalTaxAmount Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalTaxAmount Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalTaxAmount As String
C#
public string paypalTaxAmount { get; set; }
Visual C++
public:
property String^ paypalTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalTaxAmount();
function set_paypalTaxAmount(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalToken Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalToken Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalToken As String
C#
public string paypalToken { get; set; }
Visual C++
public:
property String^ paypalToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalToken();
function set_paypalToken(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paypalTransactiontype Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.paypalTransactiontype Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalTransactiontype As String
C#
public string paypalTransactiontype { get; set; }
Visual C++
public:
property String^ paypalTransactiontype {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalTransactiontype();
function set_paypalTransactiontype(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.reasonCode Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


transactionId Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.transactionId Property
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionId As String
C#
public string transactionId { get; set; }
Visual C++
public:
property String^ transactionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionId();
function set_transactionId(value);

Remarks

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentReply Events

[image] [image]

.NET Framework Class Library
PayPalEcDoPaymentReply Events
PayPalEcDoPaymentReply Class See Also Send Feedback

The PayPalEcDoPaymentReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalEcDoPaymentReply..::.PropertyChanged Event
PayPalEcDoPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalEcDoPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentService Class

[image]

.NET Framework Class Library
PayPalEcDoPaymentService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalEcDoPaymentService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalEcDoPaymentService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalEcDoPaymentService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalEcDoPaymentService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalEcDoPaymentService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalEcDoPaymentService

See Also

PayPalEcDoPaymentService Members
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentService Members

[image] [image]

.NET Framework Class Library
PayPalEcDoPaymentService Members
PayPalEcDoPaymentService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalEcDoPaymentService type exposes the following members.

Constructors

Name | Description
PayPalEcDoPaymentService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
invoiceNumber |
paypalCustomerEmail |
paypalDesc |
paypalEcSetRequestID |
paypalEcSetRequestToken |
paypalPayerId |
paypalToken |
promoCode0 |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentService Constructor

[image]

.NET Framework Class Library
PayPalEcDoPaymentService Constructor
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalEcDoPaymentService()
Visual C++
public:
PayPalEcDoPaymentService()
JavaScript
InSite.Domain.CyberSourceService.PayPalEcDoPaymentService = function();

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentService Methods

[image] [image]

.NET Framework Class Library
PayPalEcDoPaymentService Methods
PayPalEcDoPaymentService Class See Also Send Feedback

The PayPalEcDoPaymentService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.RaisePropertyChanged Method
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentService Properties

[image] [image]

.NET Framework Class Library
PayPalEcDoPaymentService Properties
PayPalEcDoPaymentService Class See Also Send Feedback

The PayPalEcDoPaymentService type exposes the following members.

Properties

Name | Description
invoiceNumber |
paypalCustomerEmail |
paypalDesc |
paypalEcSetRequestID |
paypalEcSetRequestToken |
paypalPayerId |
paypalToken |
promoCode0 |
run |

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


invoiceNumber Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.invoiceNumber Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceNumber As String
C#
public string invoiceNumber { get; set; }
Visual C++
public:
property String^ invoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceNumber();
function set_invoiceNumber(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


paypalCustomerEmail Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.paypalCustomerEmail Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalCustomerEmail As String
C#
public string paypalCustomerEmail { get; set; }
Visual C++
public:
property String^ paypalCustomerEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalCustomerEmail();
function set_paypalCustomerEmail(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


paypalDesc Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.paypalDesc Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalDesc As String
C#
public string paypalDesc { get; set; }
Visual C++
public:
property String^ paypalDesc {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalDesc();
function set_paypalDesc(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


paypalEcSetRequestID Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.paypalEcSetRequestID Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcSetRequestID As String
C#
public string paypalEcSetRequestID { get; set; }
Visual C++
public:
property String^ paypalEcSetRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcSetRequestID();
function set_paypalEcSetRequestID(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


paypalEcSetRequestToken Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.paypalEcSetRequestToken Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcSetRequestToken As String
C#
public string paypalEcSetRequestToken { get; set; }
Visual C++
public:
property String^ paypalEcSetRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcSetRequestToken();
function set_paypalEcSetRequestToken(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


paypalPayerId Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.paypalPayerId Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPayerId As String
C#
public string paypalPayerId { get; set; }
Visual C++
public:
property String^ paypalPayerId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPayerId();
function set_paypalPayerId(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


paypalToken Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.paypalToken Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalToken As String
C#
public string paypalToken { get; set; }
Visual C++
public:
property String^ paypalToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalToken();
function set_paypalToken(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


promoCode0 Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.promoCode0 Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property promoCode0 As String
C#
public string promoCode0 { get; set; }
Visual C++
public:
property String^ promoCode0 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_promoCode0();
function set_promoCode0(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.run Property
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcDoPaymentService Events

[image] [image]

.NET Framework Class Library
PayPalEcDoPaymentService Events
PayPalEcDoPaymentService Class See Also Send Feedback

The PayPalEcDoPaymentService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalEcDoPaymentService..::.PropertyChanged Event
PayPalEcDoPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalEcDoPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsReply Class

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalEcGetDetailsReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalEcGetDetailsReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalEcGetDetailsReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalEcGetDetailsReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalEcGetDetailsReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalEcGetDetailsReply

See Also

PayPalEcGetDetailsReply Members
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsReply Members

[image] [image]

.NET Framework Class Library
PayPalEcGetDetailsReply Members
PayPalEcGetDetailsReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalEcGetDetailsReply type exposes the following members.

Constructors

Name | Description
PayPalEcGetDetailsReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
addressID |
addressStatus |
avsCode |
city |
correlationID |
countryCode |
countryName |
errorCode |
payer |
payerBusiness |
payerCountry |
payerFirstname |
payerId |
payerLastname |
payerMiddlename |
payerPhone |
payerSalutation |
payerStatus |
payerSuffix |
paypalToken |
postalCode |
reasonCode |
shipToAddress1 |
shipToAddress2 |
shipToCity |
shipToCountry |
shipToName |
shipToState |
shipToZip |
state |
street1 |
street2 |

Events

Name | Description
PropertyChanged |

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsReply Constructor

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply Constructor
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalEcGetDetailsReply()
Visual C++
public:
PayPalEcGetDetailsReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalEcGetDetailsReply = function();

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsReply Methods

[image] [image]

.NET Framework Class Library
PayPalEcGetDetailsReply Methods
PayPalEcGetDetailsReply Class See Also Send Feedback

The PayPalEcGetDetailsReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.RaisePropertyChanged Method
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsReply Properties

[image] [image]

.NET Framework Class Library
PayPalEcGetDetailsReply Properties
PayPalEcGetDetailsReply Class See Also Send Feedback

The PayPalEcGetDetailsReply type exposes the following members.

Properties

Name | Description
addressID |
addressStatus |
avsCode |
city |
correlationID |
countryCode |
countryName |
errorCode |
payer |
payerBusiness |
payerCountry |
payerFirstname |
payerId |
payerLastname |
payerMiddlename |
payerPhone |
payerSalutation |
payerStatus |
payerSuffix |
paypalToken |
postalCode |
reasonCode |
shipToAddress1 |
shipToAddress2 |
shipToCity |
shipToCountry |
shipToName |
shipToState |
shipToZip |
state |
street1 |
street2 |

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


addressID Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.addressID Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property addressID As String
C#
public string addressID { get; set; }
Visual C++
public:
property String^ addressID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_addressID();
function set_addressID(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


addressStatus Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.addressStatus Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property addressStatus As String
C#
public string addressStatus { get; set; }
Visual C++
public:
property String^ addressStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_addressStatus();
function set_addressStatus(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


avsCode Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.avsCode Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property avsCode As String
C#
public string avsCode { get; set; }
Visual C++
public:
property String^ avsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsCode();
function set_avsCode(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


city Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.city Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


correlationID Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.correlationID Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property correlationID As String
C#
public string correlationID { get; set; }
Visual C++
public:
property String^ correlationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_correlationID();
function set_correlationID(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


countryCode Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.countryCode Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countryCode As String
C#
public string countryCode { get; set; }
Visual C++
public:
property String^ countryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryCode();
function set_countryCode(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


countryName Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.countryName Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countryName As String
C#
public string countryName { get; set; }
Visual C++
public:
property String^ countryName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryName();
function set_countryName(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


errorCode Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.errorCode Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property errorCode As String
C#
public string errorCode { get; set; }
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorCode();
function set_errorCode(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payer Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payer Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payer As String
C#
public string payer { get; set; }
Visual C++
public:
property String^ payer {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payer();
function set_payer(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerBusiness Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerBusiness Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerBusiness As String
C#
public string payerBusiness { get; set; }
Visual C++
public:
property String^ payerBusiness {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerBusiness();
function set_payerBusiness(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerCountry Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerCountry Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerCountry As String
C#
public string payerCountry { get; set; }
Visual C++
public:
property String^ payerCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerCountry();
function set_payerCountry(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerFirstname Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerFirstname Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerFirstname As String
C#
public string payerFirstname { get; set; }
Visual C++
public:
property String^ payerFirstname {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerFirstname();
function set_payerFirstname(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerId Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerId Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerId As String
C#
public string payerId { get; set; }
Visual C++
public:
property String^ payerId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerId();
function set_payerId(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerLastname Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerLastname Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerLastname As String
C#
public string payerLastname { get; set; }
Visual C++
public:
property String^ payerLastname {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerLastname();
function set_payerLastname(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerMiddlename Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerMiddlename Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerMiddlename As String
C#
public string payerMiddlename { get; set; }
Visual C++
public:
property String^ payerMiddlename {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerMiddlename();
function set_payerMiddlename(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerPhone Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerPhone Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerPhone As String
C#
public string payerPhone { get; set; }
Visual C++
public:
property String^ payerPhone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerPhone();
function set_payerPhone(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerSalutation Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerSalutation Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerSalutation As String
C#
public string payerSalutation { get; set; }
Visual C++
public:
property String^ payerSalutation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerSalutation();
function set_payerSalutation(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerStatus Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerStatus Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerStatus As String
C#
public string payerStatus { get; set; }
Visual C++
public:
property String^ payerStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerStatus();
function set_payerStatus(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


payerSuffix Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.payerSuffix Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerSuffix As String
C#
public string payerSuffix { get; set; }
Visual C++
public:
property String^ payerSuffix {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerSuffix();
function set_payerSuffix(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


paypalToken Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.paypalToken Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalToken As String
C#
public string paypalToken { get; set; }
Visual C++
public:
property String^ paypalToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalToken();
function set_paypalToken(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


postalCode Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.postalCode Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property postalCode As String
C#
public string postalCode { get; set; }
Visual C++
public:
property String^ postalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.reasonCode Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


shipToAddress1 Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.shipToAddress1 Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToAddress1 As String
C#
public string shipToAddress1 { get; set; }
Visual C++
public:
property String^ shipToAddress1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToAddress1();
function set_shipToAddress1(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


shipToAddress2 Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.shipToAddress2 Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToAddress2 As String
C#
public string shipToAddress2 { get; set; }
Visual C++
public:
property String^ shipToAddress2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToAddress2();
function set_shipToAddress2(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


shipToCity Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.shipToCity Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToCity As String
C#
public string shipToCity { get; set; }
Visual C++
public:
property String^ shipToCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCity();
function set_shipToCity(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


shipToCountry Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.shipToCountry Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToCountry As String
C#
public string shipToCountry { get; set; }
Visual C++
public:
property String^ shipToCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCountry();
function set_shipToCountry(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


shipToName Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.shipToName Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToName As String
C#
public string shipToName { get; set; }
Visual C++
public:
property String^ shipToName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToName();
function set_shipToName(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


shipToState Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.shipToState Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToState As String
C#
public string shipToState { get; set; }
Visual C++
public:
property String^ shipToState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToState();
function set_shipToState(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


shipToZip Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.shipToZip Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToZip As String
C#
public string shipToZip { get; set; }
Visual C++
public:
property String^ shipToZip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToZip();
function set_shipToZip(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


state Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.state Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


street1 Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.street1 Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street1 As String
C#
public string street1 { get; set; }
Visual C++
public:
property String^ street1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street1();
function set_street1(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


street2 Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.street2 Property
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street2 As String
C#
public string street2 { get; set; }
Visual C++
public:
property String^ street2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street2();
function set_street2(value);

Remarks

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsReply Events

[image] [image]

.NET Framework Class Library
PayPalEcGetDetailsReply Events
PayPalEcGetDetailsReply Class See Also Send Feedback

The PayPalEcGetDetailsReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalEcGetDetailsReply..::.PropertyChanged Event
PayPalEcGetDetailsReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalEcGetDetailsReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsService Class

[image]

.NET Framework Class Library
PayPalEcGetDetailsService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalEcGetDetailsService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalEcGetDetailsService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalEcGetDetailsService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalEcGetDetailsService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalEcGetDetailsService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalEcGetDetailsService

See Also

PayPalEcGetDetailsService Members
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsService Members

[image] [image]

.NET Framework Class Library
PayPalEcGetDetailsService Members
PayPalEcGetDetailsService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalEcGetDetailsService type exposes the following members.

Constructors

Name | Description
PayPalEcGetDetailsService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
paypalEcSetRequestID |
paypalEcSetRequestToken |
paypalToken |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsService Constructor

[image]

.NET Framework Class Library
PayPalEcGetDetailsService Constructor
PayPalEcGetDetailsService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalEcGetDetailsService()
Visual C++
public:
PayPalEcGetDetailsService()
JavaScript
InSite.Domain.CyberSourceService.PayPalEcGetDetailsService = function();

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsService Methods

[image] [image]

.NET Framework Class Library
PayPalEcGetDetailsService Methods
PayPalEcGetDetailsService Class See Also Send Feedback

The PayPalEcGetDetailsService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalEcGetDetailsService..::.RaisePropertyChanged Method
PayPalEcGetDetailsService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsService Properties

[image] [image]

.NET Framework Class Library
PayPalEcGetDetailsService Properties
PayPalEcGetDetailsService Class See Also Send Feedback

The PayPalEcGetDetailsService type exposes the following members.

Properties

Name | Description
paypalEcSetRequestID |
paypalEcSetRequestToken |
paypalToken |
run |

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


paypalEcSetRequestID Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsService..::.paypalEcSetRequestID Property
PayPalEcGetDetailsService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcSetRequestID As String
C#
public string paypalEcSetRequestID { get; set; }
Visual C++
public:
property String^ paypalEcSetRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcSetRequestID();
function set_paypalEcSetRequestID(value);

Remarks

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


paypalEcSetRequestToken Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsService..::.paypalEcSetRequestToken Property
PayPalEcGetDetailsService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcSetRequestToken As String
C#
public string paypalEcSetRequestToken { get; set; }
Visual C++
public:
property String^ paypalEcSetRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcSetRequestToken();
function set_paypalEcSetRequestToken(value);

Remarks

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


paypalToken Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsService..::.paypalToken Property
PayPalEcGetDetailsService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalToken As String
C#
public string paypalToken { get; set; }
Visual C++
public:
property String^ paypalToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalToken();
function set_paypalToken(value);

Remarks

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalEcGetDetailsService..::.run Property
PayPalEcGetDetailsService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcGetDetailsService Events

[image] [image]

.NET Framework Class Library
PayPalEcGetDetailsService Events
PayPalEcGetDetailsService Class See Also Send Feedback

The PayPalEcGetDetailsService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalEcGetDetailsService..::.PropertyChanged Event
PayPalEcGetDetailsService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalEcGetDetailsService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupReply Class

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalEcOrderSetupReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalEcOrderSetupReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalEcOrderSetupReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalEcOrderSetupReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalEcOrderSetupReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalEcOrderSetupReply

See Also

PayPalEcOrderSetupReply Members
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupReply Members

[image] [image]

.NET Framework Class Library
PayPalEcOrderSetupReply Members
PayPalEcOrderSetupReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalEcOrderSetupReply type exposes the following members.

Constructors

Name | Description
PayPalEcOrderSetupReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
correlationID |
currency |
errorCode |
paymentType |
paypalAmount |
paypalExchangeRate |
paypalFeeAmount |
paypalOrderTime |
paypalPaymentStatus |
paypalPendingReason |
paypalReasonCode |
paypalTaxAmount |
paypalToken |
paypalTransactiontype |
reasonCode |
transactionId |

Events

Name | Description
PropertyChanged |

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupReply Constructor

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply Constructor
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalEcOrderSetupReply()
Visual C++
public:
PayPalEcOrderSetupReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalEcOrderSetupReply = function();

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupReply Methods

[image] [image]

.NET Framework Class Library
PayPalEcOrderSetupReply Methods
PayPalEcOrderSetupReply Class See Also Send Feedback

The PayPalEcOrderSetupReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.RaisePropertyChanged Method
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupReply Properties

[image] [image]

.NET Framework Class Library
PayPalEcOrderSetupReply Properties
PayPalEcOrderSetupReply Class See Also Send Feedback

The PayPalEcOrderSetupReply type exposes the following members.

Properties

Name | Description
amount |
correlationID |
currency |
errorCode |
paymentType |
paypalAmount |
paypalExchangeRate |
paypalFeeAmount |
paypalOrderTime |
paypalPaymentStatus |
paypalPendingReason |
paypalReasonCode |
paypalTaxAmount |
paypalToken |
paypalTransactiontype |
reasonCode |
transactionId |

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.amount Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


correlationID Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.correlationID Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property correlationID As String
C#
public string correlationID { get; set; }
Visual C++
public:
property String^ correlationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_correlationID();
function set_correlationID(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.currency Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


errorCode Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.errorCode Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property errorCode As String
C#
public string errorCode { get; set; }
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorCode();
function set_errorCode(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paymentType Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paymentType Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentType As String
C#
public string paymentType { get; set; }
Visual C++
public:
property String^ paymentType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentType();
function set_paymentType(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalAmount Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalAmount Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAmount As String
C#
public string paypalAmount { get; set; }
Visual C++
public:
property String^ paypalAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAmount();
function set_paypalAmount(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalExchangeRate Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalExchangeRate Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalExchangeRate As String
C#
public string paypalExchangeRate { get; set; }
Visual C++
public:
property String^ paypalExchangeRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalExchangeRate();
function set_paypalExchangeRate(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalFeeAmount Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalFeeAmount Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalFeeAmount As String
C#
public string paypalFeeAmount { get; set; }
Visual C++
public:
property String^ paypalFeeAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalFeeAmount();
function set_paypalFeeAmount(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalOrderTime Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalOrderTime Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalOrderTime As String
C#
public string paypalOrderTime { get; set; }
Visual C++
public:
property String^ paypalOrderTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalOrderTime();
function set_paypalOrderTime(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalPaymentStatus Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalPaymentStatus Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPaymentStatus As String
C#
public string paypalPaymentStatus { get; set; }
Visual C++
public:
property String^ paypalPaymentStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPaymentStatus();
function set_paypalPaymentStatus(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalPendingReason Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalPendingReason Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPendingReason As String
C#
public string paypalPendingReason { get; set; }
Visual C++
public:
property String^ paypalPendingReason {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPendingReason();
function set_paypalPendingReason(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalReasonCode Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalReasonCode Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalReasonCode As String
C#
public string paypalReasonCode { get; set; }
Visual C++
public:
property String^ paypalReasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalReasonCode();
function set_paypalReasonCode(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalTaxAmount Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalTaxAmount Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalTaxAmount As String
C#
public string paypalTaxAmount { get; set; }
Visual C++
public:
property String^ paypalTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalTaxAmount();
function set_paypalTaxAmount(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalToken Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalToken Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalToken As String
C#
public string paypalToken { get; set; }
Visual C++
public:
property String^ paypalToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalToken();
function set_paypalToken(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


paypalTransactiontype Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.paypalTransactiontype Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalTransactiontype As String
C#
public string paypalTransactiontype { get; set; }
Visual C++
public:
property String^ paypalTransactiontype {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalTransactiontype();
function set_paypalTransactiontype(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.reasonCode Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


transactionId Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.transactionId Property
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionId As String
C#
public string transactionId { get; set; }
Visual C++
public:
property String^ transactionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionId();
function set_transactionId(value);

Remarks

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupReply Events

[image] [image]

.NET Framework Class Library
PayPalEcOrderSetupReply Events
PayPalEcOrderSetupReply Class See Also Send Feedback

The PayPalEcOrderSetupReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalEcOrderSetupReply..::.PropertyChanged Event
PayPalEcOrderSetupReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalEcOrderSetupReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupService Class

[image]

.NET Framework Class Library
PayPalEcOrderSetupService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalEcOrderSetupService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalEcOrderSetupService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalEcOrderSetupService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalEcOrderSetupService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalEcOrderSetupService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalEcOrderSetupService

See Also

PayPalEcOrderSetupService Members
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupService Members

[image] [image]

.NET Framework Class Library
PayPalEcOrderSetupService Members
PayPalEcOrderSetupService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalEcOrderSetupService type exposes the following members.

Constructors

Name | Description
PayPalEcOrderSetupService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
invoiceNumber |
paypalCustomerEmail |
paypalDesc |
paypalEcSetRequestID |
paypalEcSetRequestToken |
paypalPayerId |
paypalToken |
promoCode0 |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupService Constructor

[image]

.NET Framework Class Library
PayPalEcOrderSetupService Constructor
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalEcOrderSetupService()
Visual C++
public:
PayPalEcOrderSetupService()
JavaScript
InSite.Domain.CyberSourceService.PayPalEcOrderSetupService = function();

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupService Methods

[image] [image]

.NET Framework Class Library
PayPalEcOrderSetupService Methods
PayPalEcOrderSetupService Class See Also Send Feedback

The PayPalEcOrderSetupService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.RaisePropertyChanged Method
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupService Properties

[image] [image]

.NET Framework Class Library
PayPalEcOrderSetupService Properties
PayPalEcOrderSetupService Class See Also Send Feedback

The PayPalEcOrderSetupService type exposes the following members.

Properties

Name | Description
invoiceNumber |
paypalCustomerEmail |
paypalDesc |
paypalEcSetRequestID |
paypalEcSetRequestToken |
paypalPayerId |
paypalToken |
promoCode0 |
run |

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


invoiceNumber Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.invoiceNumber Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceNumber As String
C#
public string invoiceNumber { get; set; }
Visual C++
public:
property String^ invoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceNumber();
function set_invoiceNumber(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


paypalCustomerEmail Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.paypalCustomerEmail Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalCustomerEmail As String
C#
public string paypalCustomerEmail { get; set; }
Visual C++
public:
property String^ paypalCustomerEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalCustomerEmail();
function set_paypalCustomerEmail(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


paypalDesc Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.paypalDesc Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalDesc As String
C#
public string paypalDesc { get; set; }
Visual C++
public:
property String^ paypalDesc {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalDesc();
function set_paypalDesc(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


paypalEcSetRequestID Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.paypalEcSetRequestID Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcSetRequestID As String
C#
public string paypalEcSetRequestID { get; set; }
Visual C++
public:
property String^ paypalEcSetRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcSetRequestID();
function set_paypalEcSetRequestID(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


paypalEcSetRequestToken Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.paypalEcSetRequestToken Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcSetRequestToken As String
C#
public string paypalEcSetRequestToken { get; set; }
Visual C++
public:
property String^ paypalEcSetRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcSetRequestToken();
function set_paypalEcSetRequestToken(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


paypalPayerId Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.paypalPayerId Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPayerId As String
C#
public string paypalPayerId { get; set; }
Visual C++
public:
property String^ paypalPayerId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPayerId();
function set_paypalPayerId(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


paypalToken Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.paypalToken Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalToken As String
C#
public string paypalToken { get; set; }
Visual C++
public:
property String^ paypalToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalToken();
function set_paypalToken(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


promoCode0 Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.promoCode0 Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property promoCode0 As String
C#
public string promoCode0 { get; set; }
Visual C++
public:
property String^ promoCode0 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_promoCode0();
function set_promoCode0(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.run Property
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcOrderSetupService Events

[image] [image]

.NET Framework Class Library
PayPalEcOrderSetupService Events
PayPalEcOrderSetupService Class See Also Send Feedback

The PayPalEcOrderSetupService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalEcOrderSetupService..::.PropertyChanged Event
PayPalEcOrderSetupService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalEcOrderSetupService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetReply Class

[image]

.NET Framework Class Library
PayPalEcSetReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalEcSetReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalEcSetReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalEcSetReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalEcSetReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalEcSetReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalEcSetReply

See Also

PayPalEcSetReply Members
InSite.Domain.CyberSourceService Namespace


PayPalEcSetReply Members

[image] [image]

.NET Framework Class Library
PayPalEcSetReply Members
PayPalEcSetReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalEcSetReply type exposes the following members.

Constructors

Name | Description
PayPalEcSetReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
correlationID |
currency |
errorCode |
paypalToken |
reasonCode |

Events

Name | Description
PropertyChanged |

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetReply Constructor

[image]

.NET Framework Class Library
PayPalEcSetReply Constructor
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalEcSetReply()
Visual C++
public:
PayPalEcSetReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalEcSetReply = function();

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetReply Methods

[image] [image]

.NET Framework Class Library
PayPalEcSetReply Methods
PayPalEcSetReply Class See Also Send Feedback

The PayPalEcSetReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalEcSetReply..::.RaisePropertyChanged Method
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetReply Properties

[image] [image]

.NET Framework Class Library
PayPalEcSetReply Properties
PayPalEcSetReply Class See Also Send Feedback

The PayPalEcSetReply type exposes the following members.

Properties

Name | Description
amount |
correlationID |
currency |
errorCode |
paypalToken |
reasonCode |

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PayPalEcSetReply..::.amount Property
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


correlationID Property

[image]

.NET Framework Class Library
PayPalEcSetReply..::.correlationID Property
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property correlationID As String
C#
public string correlationID { get; set; }
Visual C++
public:
property String^ correlationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_correlationID();
function set_correlationID(value);

Remarks

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
PayPalEcSetReply..::.currency Property
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


errorCode Property

[image]

.NET Framework Class Library
PayPalEcSetReply..::.errorCode Property
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property errorCode As String
C#
public string errorCode { get; set; }
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorCode();
function set_errorCode(value);

Remarks

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


paypalToken Property

[image]

.NET Framework Class Library
PayPalEcSetReply..::.paypalToken Property
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalToken As String
C#
public string paypalToken { get; set; }
Visual C++
public:
property String^ paypalToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalToken();
function set_paypalToken(value);

Remarks

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalEcSetReply..::.reasonCode Property
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetReply Events

[image] [image]

.NET Framework Class Library
PayPalEcSetReply Events
PayPalEcSetReply Class See Also Send Feedback

The PayPalEcSetReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalEcSetReply..::.PropertyChanged Event
PayPalEcSetReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalEcSetReply Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetService Class

[image]

.NET Framework Class Library
PayPalEcSetService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalEcSetService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalEcSetService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalEcSetService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalEcSetService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalEcSetService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalEcSetService

See Also

PayPalEcSetService Members
InSite.Domain.CyberSourceService Namespace


PayPalEcSetService Members

[image] [image]

.NET Framework Class Library
PayPalEcSetService Members
PayPalEcSetService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalEcSetService type exposes the following members.

Constructors

Name | Description
PayPalEcSetService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
invoiceNumber |
paypalAddressOverride |
paypalCancelReturn |
paypalCustomerEmail |
paypalDesc |
paypalEcSetRequestID |
paypalEcSetRequestToken |
paypalHdrbackcolor |
paypalHdrbordercolor |
paypalHdrimg |
paypalLc |
paypalMaxamt |
paypalNoshipping |
paypalPagestyle |
paypalPayflowcolor |
paypalReqconfirmshipping |
paypalReturn |
paypalToken |
promoCode0 |
requestBillingAddress |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetService Constructor

[image]

.NET Framework Class Library
PayPalEcSetService Constructor
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalEcSetService()
Visual C++
public:
PayPalEcSetService()
JavaScript
InSite.Domain.CyberSourceService.PayPalEcSetService = function();

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetService Methods

[image] [image]

.NET Framework Class Library
PayPalEcSetService Methods
PayPalEcSetService Class See Also Send Feedback

The PayPalEcSetService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalEcSetService..::.RaisePropertyChanged Method
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetService Properties

[image] [image]

.NET Framework Class Library
PayPalEcSetService Properties
PayPalEcSetService Class See Also Send Feedback

The PayPalEcSetService type exposes the following members.

Properties

Name | Description
invoiceNumber |
paypalAddressOverride |
paypalCancelReturn |
paypalCustomerEmail |
paypalDesc |
paypalEcSetRequestID |
paypalEcSetRequestToken |
paypalHdrbackcolor |
paypalHdrbordercolor |
paypalHdrimg |
paypalLc |
paypalMaxamt |
paypalNoshipping |
paypalPagestyle |
paypalPayflowcolor |
paypalReqconfirmshipping |
paypalReturn |
paypalToken |
promoCode0 |
requestBillingAddress |
run |

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


invoiceNumber Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.invoiceNumber Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceNumber As String
C#
public string invoiceNumber { get; set; }
Visual C++
public:
property String^ invoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceNumber();
function set_invoiceNumber(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalAddressOverride Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalAddressOverride Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalAddressOverride As String
C#
public string paypalAddressOverride { get; set; }
Visual C++
public:
property String^ paypalAddressOverride {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalAddressOverride();
function set_paypalAddressOverride(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalCancelReturn Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalCancelReturn Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalCancelReturn As String
C#
public string paypalCancelReturn { get; set; }
Visual C++
public:
property String^ paypalCancelReturn {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalCancelReturn();
function set_paypalCancelReturn(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalCustomerEmail Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalCustomerEmail Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalCustomerEmail As String
C#
public string paypalCustomerEmail { get; set; }
Visual C++
public:
property String^ paypalCustomerEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalCustomerEmail();
function set_paypalCustomerEmail(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalDesc Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalDesc Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalDesc As String
C#
public string paypalDesc { get; set; }
Visual C++
public:
property String^ paypalDesc {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalDesc();
function set_paypalDesc(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalEcSetRequestID Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalEcSetRequestID Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcSetRequestID As String
C#
public string paypalEcSetRequestID { get; set; }
Visual C++
public:
property String^ paypalEcSetRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcSetRequestID();
function set_paypalEcSetRequestID(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalEcSetRequestToken Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalEcSetRequestToken Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalEcSetRequestToken As String
C#
public string paypalEcSetRequestToken { get; set; }
Visual C++
public:
property String^ paypalEcSetRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalEcSetRequestToken();
function set_paypalEcSetRequestToken(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalHdrbackcolor Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalHdrbackcolor Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalHdrbackcolor As String
C#
public string paypalHdrbackcolor { get; set; }
Visual C++
public:
property String^ paypalHdrbackcolor {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalHdrbackcolor();
function set_paypalHdrbackcolor(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalHdrbordercolor Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalHdrbordercolor Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalHdrbordercolor As String
C#
public string paypalHdrbordercolor { get; set; }
Visual C++
public:
property String^ paypalHdrbordercolor {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalHdrbordercolor();
function set_paypalHdrbordercolor(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalHdrimg Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalHdrimg Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalHdrimg As String
C#
public string paypalHdrimg { get; set; }
Visual C++
public:
property String^ paypalHdrimg {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalHdrimg();
function set_paypalHdrimg(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalLc Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalLc Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalLc As String
C#
public string paypalLc { get; set; }
Visual C++
public:
property String^ paypalLc {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalLc();
function set_paypalLc(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalMaxamt Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalMaxamt Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalMaxamt As String
C#
public string paypalMaxamt { get; set; }
Visual C++
public:
property String^ paypalMaxamt {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalMaxamt();
function set_paypalMaxamt(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalNoshipping Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalNoshipping Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalNoshipping As String
C#
public string paypalNoshipping { get; set; }
Visual C++
public:
property String^ paypalNoshipping {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalNoshipping();
function set_paypalNoshipping(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalPagestyle Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalPagestyle Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPagestyle As String
C#
public string paypalPagestyle { get; set; }
Visual C++
public:
property String^ paypalPagestyle {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPagestyle();
function set_paypalPagestyle(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalPayflowcolor Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalPayflowcolor Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalPayflowcolor As String
C#
public string paypalPayflowcolor { get; set; }
Visual C++
public:
property String^ paypalPayflowcolor {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalPayflowcolor();
function set_paypalPayflowcolor(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalReqconfirmshipping Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalReqconfirmshipping Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalReqconfirmshipping As String
C#
public string paypalReqconfirmshipping { get; set; }
Visual C++
public:
property String^ paypalReqconfirmshipping {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalReqconfirmshipping();
function set_paypalReqconfirmshipping(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalReturn Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalReturn Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalReturn As String
C#
public string paypalReturn { get; set; }
Visual C++
public:
property String^ paypalReturn {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalReturn();
function set_paypalReturn(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


paypalToken Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.paypalToken Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalToken As String
C#
public string paypalToken { get; set; }
Visual C++
public:
property String^ paypalToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalToken();
function set_paypalToken(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


promoCode0 Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.promoCode0 Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property promoCode0 As String
C#
public string promoCode0 { get; set; }
Visual C++
public:
property String^ promoCode0 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_promoCode0();
function set_promoCode0(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


requestBillingAddress Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.requestBillingAddress Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestBillingAddress As String
C#
public string requestBillingAddress { get; set; }
Visual C++
public:
property String^ requestBillingAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestBillingAddress();
function set_requestBillingAddress(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalEcSetService..::.run Property
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


PayPalEcSetService Events

[image] [image]

.NET Framework Class Library
PayPalEcSetService Events
PayPalEcSetService Class See Also Send Feedback

The PayPalEcSetService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalEcSetService..::.PropertyChanged Event
PayPalEcSetService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalEcSetService Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentReply Class

[image]

.NET Framework Class Library
PayPalPaymentReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalPaymentReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalPaymentReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalPaymentReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalPaymentReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalPaymentReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalPaymentReply

See Also

PayPalPaymentReply Members
InSite.Domain.CyberSourceService Namespace


PayPalPaymentReply Members

[image] [image]

.NET Framework Class Library
PayPalPaymentReply Members
PayPalPaymentReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalPaymentReply type exposes the following members.

Constructors

Name | Description
PayPalPaymentReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
reasonCode |
reconciliationID |
requestDateTime |
secureData |

Events

Name | Description
PropertyChanged |

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentReply Constructor

[image]

.NET Framework Class Library
PayPalPaymentReply Constructor
PayPalPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalPaymentReply()
Visual C++
public:
PayPalPaymentReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalPaymentReply = function();

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentReply Methods

[image] [image]

.NET Framework Class Library
PayPalPaymentReply Methods
PayPalPaymentReply Class See Also Send Feedback

The PayPalPaymentReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalPaymentReply..::.RaisePropertyChanged Method
PayPalPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentReply Properties

[image] [image]

.NET Framework Class Library
PayPalPaymentReply Properties
PayPalPaymentReply Class See Also Send Feedback

The PayPalPaymentReply type exposes the following members.

Properties

Name | Description
amount |
reasonCode |
reconciliationID |
requestDateTime |
secureData |

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PayPalPaymentReply..::.amount Property
PayPalPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalPaymentReply..::.reasonCode Property
PayPalPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalPaymentReply..::.reconciliationID Property
PayPalPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
PayPalPaymentReply..::.requestDateTime Property
PayPalPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


secureData Property

[image]

.NET Framework Class Library
PayPalPaymentReply..::.secureData Property
PayPalPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property secureData As String
C#
public string secureData { get; set; }
Visual C++
public:
property String^ secureData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_secureData();
function set_secureData(value);

Remarks

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentReply Events

[image] [image]

.NET Framework Class Library
PayPalPaymentReply Events
PayPalPaymentReply Class See Also Send Feedback

The PayPalPaymentReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalPaymentReply..::.PropertyChanged Event
PayPalPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentService Class

[image]

.NET Framework Class Library
PayPalPaymentService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalPaymentService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalPaymentService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalPaymentService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalPaymentService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalPaymentService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalPaymentService

See Also

PayPalPaymentService Members
InSite.Domain.CyberSourceService Namespace


PayPalPaymentService Members

[image] [image]

.NET Framework Class Library
PayPalPaymentService Members
PayPalPaymentService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalPaymentService type exposes the following members.

Constructors

Name | Description
PayPalPaymentService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
cancelURL |
reconciliationID |
run |
successURL |

Events

Name | Description
PropertyChanged |

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentService Constructor

[image]

.NET Framework Class Library
PayPalPaymentService Constructor
PayPalPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalPaymentService()
Visual C++
public:
PayPalPaymentService()
JavaScript
InSite.Domain.CyberSourceService.PayPalPaymentService = function();

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentService Methods

[image] [image]

.NET Framework Class Library
PayPalPaymentService Methods
PayPalPaymentService Class See Also Send Feedback

The PayPalPaymentService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalPaymentService..::.RaisePropertyChanged Method
PayPalPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentService Properties

[image] [image]

.NET Framework Class Library
PayPalPaymentService Properties
PayPalPaymentService Class See Also Send Feedback

The PayPalPaymentService type exposes the following members.

Properties

Name | Description
cancelURL |
reconciliationID |
run |
successURL |

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


cancelURL Property

[image]

.NET Framework Class Library
PayPalPaymentService..::.cancelURL Property
PayPalPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cancelURL As String
C#
public string cancelURL { get; set; }
Visual C++
public:
property String^ cancelURL {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cancelURL();
function set_cancelURL(value);

Remarks

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalPaymentService..::.reconciliationID Property
PayPalPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalPaymentService..::.run Property
PayPalPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


successURL Property

[image]

.NET Framework Class Library
PayPalPaymentService..::.successURL Property
PayPalPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property successURL As String
C#
public string successURL { get; set; }
Visual C++
public:
property String^ successURL {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_successURL();
function set_successURL(value);

Remarks

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPaymentService Events

[image] [image]

.NET Framework Class Library
PayPalPaymentService Events
PayPalPaymentService Class See Also Send Feedback

The PayPalPaymentService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalPaymentService..::.PropertyChanged Event
PayPalPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentReply Class

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalPreapprovedPaymentReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalPreapprovedPaymentReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalPreapprovedPaymentReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalPreapprovedPaymentReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalPreapprovedPaymentReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalPreapprovedPaymentReply

See Also

PayPalPreapprovedPaymentReply Members
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentReply Members

[image] [image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply Members
PayPalPreapprovedPaymentReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalPreapprovedPaymentReply type exposes the following members.

Constructors

Name | Description
PayPalPreapprovedPaymentReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
desc |
exchangeRate |
feeAmount |
mpMax |
mpStatus |
payer |
payerBusiness |
payerCountry |
payerID |
payerName |
payerStatus |
paymentDate |
paymentGrossAmount |
paymentSourceID |
paymentStatus |
paymentType |
pendingReason |
reasonCode |
reconciliationID |
requestDateTime |
settleAmount |
taxAmount |
transactionID |
transactionType |

Events

Name | Description
PropertyChanged |

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentReply Constructor

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply Constructor
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalPreapprovedPaymentReply()
Visual C++
public:
PayPalPreapprovedPaymentReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalPreapprovedPaymentReply = function();

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentReply Methods

[image] [image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply Methods
PayPalPreapprovedPaymentReply Class See Also Send Feedback

The PayPalPreapprovedPaymentReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.RaisePropertyChanged Method
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentReply Properties

[image] [image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply Properties
PayPalPreapprovedPaymentReply Class See Also Send Feedback

The PayPalPreapprovedPaymentReply type exposes the following members.

Properties

Name | Description
desc |
exchangeRate |
feeAmount |
mpMax |
mpStatus |
payer |
payerBusiness |
payerCountry |
payerID |
payerName |
payerStatus |
paymentDate |
paymentGrossAmount |
paymentSourceID |
paymentStatus |
paymentType |
pendingReason |
reasonCode |
reconciliationID |
requestDateTime |
settleAmount |
taxAmount |
transactionID |
transactionType |

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


desc Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.desc Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property desc As String
C#
public string desc { get; set; }
Visual C++
public:
property String^ desc {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_desc();
function set_desc(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


exchangeRate Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.exchangeRate Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property exchangeRate As String
C#
public string exchangeRate { get; set; }
Visual C++
public:
property String^ exchangeRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_exchangeRate();
function set_exchangeRate(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


feeAmount Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.feeAmount Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property feeAmount As String
C#
public string feeAmount { get; set; }
Visual C++
public:
property String^ feeAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_feeAmount();
function set_feeAmount(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


mpMax Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.mpMax Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mpMax As String
C#
public string mpMax { get; set; }
Visual C++
public:
property String^ mpMax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mpMax();
function set_mpMax(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


mpStatus Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.mpStatus Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mpStatus As String
C#
public string mpStatus { get; set; }
Visual C++
public:
property String^ mpStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mpStatus();
function set_mpStatus(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


payer Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.payer Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payer As String
C#
public string payer { get; set; }
Visual C++
public:
property String^ payer {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payer();
function set_payer(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


payerBusiness Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.payerBusiness Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerBusiness As String
C#
public string payerBusiness { get; set; }
Visual C++
public:
property String^ payerBusiness {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerBusiness();
function set_payerBusiness(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


payerCountry Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.payerCountry Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerCountry As String
C#
public string payerCountry { get; set; }
Visual C++
public:
property String^ payerCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerCountry();
function set_payerCountry(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


payerID Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.payerID Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerID As String
C#
public string payerID { get; set; }
Visual C++
public:
property String^ payerID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerID();
function set_payerID(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


payerName Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.payerName Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerName As String
C#
public string payerName { get; set; }
Visual C++
public:
property String^ payerName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerName();
function set_payerName(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


payerStatus Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.payerStatus Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerStatus As String
C#
public string payerStatus { get; set; }
Visual C++
public:
property String^ payerStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerStatus();
function set_payerStatus(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paymentDate Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.paymentDate Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentDate As String
C#
public string paymentDate { get; set; }
Visual C++
public:
property String^ paymentDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentDate();
function set_paymentDate(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paymentGrossAmount Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.paymentGrossAmount Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentGrossAmount As String
C#
public string paymentGrossAmount { get; set; }
Visual C++
public:
property String^ paymentGrossAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentGrossAmount();
function set_paymentGrossAmount(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paymentSourceID Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.paymentSourceID Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentSourceID As String
C#
public string paymentSourceID { get; set; }
Visual C++
public:
property String^ paymentSourceID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentSourceID();
function set_paymentSourceID(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paymentStatus Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.paymentStatus Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentStatus As String
C#
public string paymentStatus { get; set; }
Visual C++
public:
property String^ paymentStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentStatus();
function set_paymentStatus(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


paymentType Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.paymentType Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentType As String
C#
public string paymentType { get; set; }
Visual C++
public:
property String^ paymentType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentType();
function set_paymentType(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


pendingReason Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.pendingReason Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pendingReason As String
C#
public string pendingReason { get; set; }
Visual C++
public:
property String^ pendingReason {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pendingReason();
function set_pendingReason(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.reasonCode Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.reconciliationID Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.requestDateTime Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


settleAmount Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.settleAmount Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property settleAmount As String
C#
public string settleAmount { get; set; }
Visual C++
public:
property String^ settleAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_settleAmount();
function set_settleAmount(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


taxAmount Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.taxAmount Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxAmount As String
C#
public string taxAmount { get; set; }
Visual C++
public:
property String^ taxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxAmount();
function set_taxAmount(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


transactionID Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.transactionID Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionID As String
C#
public string transactionID { get; set; }
Visual C++
public:
property String^ transactionID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionID();
function set_transactionID(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


transactionType Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.transactionType Property
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionType As String
C#
public string transactionType { get; set; }
Visual C++
public:
property String^ transactionType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionType();
function set_transactionType(value);

Remarks

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentReply Events

[image] [image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply Events
PayPalPreapprovedPaymentReply Class See Also Send Feedback

The PayPalPreapprovedPaymentReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentReply..::.PropertyChanged Event
PayPalPreapprovedPaymentReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalPreapprovedPaymentReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentService Class

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalPreapprovedPaymentService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalPreapprovedPaymentService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalPreapprovedPaymentService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalPreapprovedPaymentService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalPreapprovedPaymentService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalPreapprovedPaymentService

See Also

PayPalPreapprovedPaymentService Members
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentService Members

[image] [image]

.NET Framework Class Library
PayPalPreapprovedPaymentService Members
PayPalPreapprovedPaymentService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalPreapprovedPaymentService type exposes the following members.

Constructors

Name | Description
PayPalPreapprovedPaymentService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
mpID |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentService Constructor

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentService Constructor
PayPalPreapprovedPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalPreapprovedPaymentService()
Visual C++
public:
PayPalPreapprovedPaymentService()
JavaScript
InSite.Domain.CyberSourceService.PayPalPreapprovedPaymentService = function();

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentService Methods

[image] [image]

.NET Framework Class Library
PayPalPreapprovedPaymentService Methods
PayPalPreapprovedPaymentService Class See Also Send Feedback

The PayPalPreapprovedPaymentService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentService..::.RaisePropertyChanged Method
PayPalPreapprovedPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentService Properties

[image] [image]

.NET Framework Class Library
PayPalPreapprovedPaymentService Properties
PayPalPreapprovedPaymentService Class See Also Send Feedback

The PayPalPreapprovedPaymentService type exposes the following members.

Properties

Name | Description
mpID |
reconciliationID |
run |

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


mpID Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentService..::.mpID Property
PayPalPreapprovedPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mpID As String
C#
public string mpID { get; set; }
Visual C++
public:
property String^ mpID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mpID();
function set_mpID(value);

Remarks

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentService..::.reconciliationID Property
PayPalPreapprovedPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentService..::.run Property
PayPalPreapprovedPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedPaymentService Events

[image] [image]

.NET Framework Class Library
PayPalPreapprovedPaymentService Events
PayPalPreapprovedPaymentService Class See Also Send Feedback

The PayPalPreapprovedPaymentService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalPreapprovedPaymentService..::.PropertyChanged Event
PayPalPreapprovedPaymentService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalPreapprovedPaymentService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateReply Class

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalPreapprovedUpdateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalPreapprovedUpdateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalPreapprovedUpdateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalPreapprovedUpdateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalPreapprovedUpdateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalPreapprovedUpdateReply

See Also

PayPalPreapprovedUpdateReply Members
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateReply Members

[image] [image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply Members
PayPalPreapprovedUpdateReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalPreapprovedUpdateReply type exposes the following members.

Constructors

Name | Description
PayPalPreapprovedUpdateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
desc |
mpMax |
mpStatus |
payer |
payerBusiness |
payerCountry |
payerID |
payerName |
payerStatus |
paymentSourceID |
reasonCode |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateReply Constructor

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply Constructor
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalPreapprovedUpdateReply()
Visual C++
public:
PayPalPreapprovedUpdateReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalPreapprovedUpdateReply = function();

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateReply Methods

[image] [image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply Methods
PayPalPreapprovedUpdateReply Class See Also Send Feedback

The PayPalPreapprovedUpdateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.RaisePropertyChanged Method
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateReply Properties

[image] [image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply Properties
PayPalPreapprovedUpdateReply Class See Also Send Feedback

The PayPalPreapprovedUpdateReply type exposes the following members.

Properties

Name | Description
desc |
mpMax |
mpStatus |
payer |
payerBusiness |
payerCountry |
payerID |
payerName |
payerStatus |
paymentSourceID |
reasonCode |
reconciliationID |
requestDateTime |

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


desc Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.desc Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property desc As String
C#
public string desc { get; set; }
Visual C++
public:
property String^ desc {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_desc();
function set_desc(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


mpMax Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.mpMax Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mpMax As String
C#
public string mpMax { get; set; }
Visual C++
public:
property String^ mpMax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mpMax();
function set_mpMax(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


mpStatus Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.mpStatus Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mpStatus As String
C#
public string mpStatus { get; set; }
Visual C++
public:
property String^ mpStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mpStatus();
function set_mpStatus(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


payer Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.payer Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payer As String
C#
public string payer { get; set; }
Visual C++
public:
property String^ payer {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payer();
function set_payer(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


payerBusiness Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.payerBusiness Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerBusiness As String
C#
public string payerBusiness { get; set; }
Visual C++
public:
property String^ payerBusiness {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerBusiness();
function set_payerBusiness(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


payerCountry Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.payerCountry Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerCountry As String
C#
public string payerCountry { get; set; }
Visual C++
public:
property String^ payerCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerCountry();
function set_payerCountry(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


payerID Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.payerID Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerID As String
C#
public string payerID { get; set; }
Visual C++
public:
property String^ payerID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerID();
function set_payerID(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


payerName Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.payerName Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerName As String
C#
public string payerName { get; set; }
Visual C++
public:
property String^ payerName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerName();
function set_payerName(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


payerStatus Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.payerStatus Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerStatus As String
C#
public string payerStatus { get; set; }
Visual C++
public:
property String^ payerStatus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerStatus();
function set_payerStatus(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


paymentSourceID Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.paymentSourceID Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentSourceID As String
C#
public string paymentSourceID { get; set; }
Visual C++
public:
property String^ paymentSourceID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentSourceID();
function set_paymentSourceID(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.reasonCode Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.reconciliationID Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.requestDateTime Property
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateReply Events

[image] [image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply Events
PayPalPreapprovedUpdateReply Class See Also Send Feedback

The PayPalPreapprovedUpdateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateReply..::.PropertyChanged Event
PayPalPreapprovedUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalPreapprovedUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateService Class

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalPreapprovedUpdateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalPreapprovedUpdateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalPreapprovedUpdateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalPreapprovedUpdateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalPreapprovedUpdateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalPreapprovedUpdateService

See Also

PayPalPreapprovedUpdateService Members
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateService Members

[image] [image]

.NET Framework Class Library
PayPalPreapprovedUpdateService Members
PayPalPreapprovedUpdateService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalPreapprovedUpdateService type exposes the following members.

Constructors

Name | Description
PayPalPreapprovedUpdateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
mpID |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateService Constructor

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateService Constructor
PayPalPreapprovedUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalPreapprovedUpdateService()
Visual C++
public:
PayPalPreapprovedUpdateService()
JavaScript
InSite.Domain.CyberSourceService.PayPalPreapprovedUpdateService = function();

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateService Methods

[image] [image]

.NET Framework Class Library
PayPalPreapprovedUpdateService Methods
PayPalPreapprovedUpdateService Class See Also Send Feedback

The PayPalPreapprovedUpdateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateService..::.RaisePropertyChanged Method
PayPalPreapprovedUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateService Properties

[image] [image]

.NET Framework Class Library
PayPalPreapprovedUpdateService Properties
PayPalPreapprovedUpdateService Class See Also Send Feedback

The PayPalPreapprovedUpdateService type exposes the following members.

Properties

Name | Description
mpID |
reconciliationID |
run |

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


mpID Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateService..::.mpID Property
PayPalPreapprovedUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property mpID As String
C#
public string mpID { get; set; }
Visual C++
public:
property String^ mpID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mpID();
function set_mpID(value);

Remarks

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateService..::.reconciliationID Property
PayPalPreapprovedUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateService..::.run Property
PayPalPreapprovedUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


PayPalPreapprovedUpdateService Events

[image] [image]

.NET Framework Class Library
PayPalPreapprovedUpdateService Events
PayPalPreapprovedUpdateService Class See Also Send Feedback

The PayPalPreapprovedUpdateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalPreapprovedUpdateService..::.PropertyChanged Event
PayPalPreapprovedUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalPreapprovedUpdateService Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundReply Class

[image]

.NET Framework Class Library
PayPalRefundReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalRefundReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalRefundReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalRefundReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalRefundReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalRefundReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalRefundReply

See Also

PayPalRefundReply Members
InSite.Domain.CyberSourceService Namespace


PayPalRefundReply Members

[image] [image]

.NET Framework Class Library
PayPalRefundReply Members
PayPalRefundReply Class Constructors Methods Properties Events See Also Send Feedback

The PayPalRefundReply type exposes the following members.

Constructors

Name | Description
PayPalRefundReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
correlationID |
errorCode |
paypalFeeRefundAmount |
paypalGrossRefundAmount |
paypalNetRefundAmount |
reasonCode |
transactionId |

Events

Name | Description
PropertyChanged |

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundReply Constructor

[image]

.NET Framework Class Library
PayPalRefundReply Constructor
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalRefundReply()
Visual C++
public:
PayPalRefundReply()
JavaScript
InSite.Domain.CyberSourceService.PayPalRefundReply = function();

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundReply Methods

[image] [image]

.NET Framework Class Library
PayPalRefundReply Methods
PayPalRefundReply Class See Also Send Feedback

The PayPalRefundReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalRefundReply..::.RaisePropertyChanged Method
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundReply Properties

[image] [image]

.NET Framework Class Library
PayPalRefundReply Properties
PayPalRefundReply Class See Also Send Feedback

The PayPalRefundReply type exposes the following members.

Properties

Name | Description
correlationID |
errorCode |
paypalFeeRefundAmount |
paypalGrossRefundAmount |
paypalNetRefundAmount |
reasonCode |
transactionId |

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


correlationID Property

[image]

.NET Framework Class Library
PayPalRefundReply..::.correlationID Property
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property correlationID As String
C#
public string correlationID { get; set; }
Visual C++
public:
property String^ correlationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_correlationID();
function set_correlationID(value);

Remarks

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


errorCode Property

[image]

.NET Framework Class Library
PayPalRefundReply..::.errorCode Property
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property errorCode As String
C#
public string errorCode { get; set; }
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorCode();
function set_errorCode(value);

Remarks

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


paypalFeeRefundAmount Property

[image]

.NET Framework Class Library
PayPalRefundReply..::.paypalFeeRefundAmount Property
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalFeeRefundAmount As String
C#
public string paypalFeeRefundAmount { get; set; }
Visual C++
public:
property String^ paypalFeeRefundAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalFeeRefundAmount();
function set_paypalFeeRefundAmount(value);

Remarks

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


paypalGrossRefundAmount Property

[image]

.NET Framework Class Library
PayPalRefundReply..::.paypalGrossRefundAmount Property
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalGrossRefundAmount As String
C#
public string paypalGrossRefundAmount { get; set; }
Visual C++
public:
property String^ paypalGrossRefundAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalGrossRefundAmount();
function set_paypalGrossRefundAmount(value);

Remarks

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


paypalNetRefundAmount Property

[image]

.NET Framework Class Library
PayPalRefundReply..::.paypalNetRefundAmount Property
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalNetRefundAmount As String
C#
public string paypalNetRefundAmount { get; set; }
Visual C++
public:
property String^ paypalNetRefundAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalNetRefundAmount();
function set_paypalNetRefundAmount(value);

Remarks

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PayPalRefundReply..::.reasonCode Property
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


transactionId Property

[image]

.NET Framework Class Library
PayPalRefundReply..::.transactionId Property
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionId As String
C#
public string transactionId { get; set; }
Visual C++
public:
property String^ transactionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionId();
function set_transactionId(value);

Remarks

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundReply Events

[image] [image]

.NET Framework Class Library
PayPalRefundReply Events
PayPalRefundReply Class See Also Send Feedback

The PayPalRefundReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalRefundReply..::.PropertyChanged Event
PayPalRefundReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalRefundReply Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundService Class

[image]

.NET Framework Class Library
PayPalRefundService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PayPalRefundService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PayPalRefundService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PayPalRefundService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PayPalRefundService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PayPalRefundService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PayPalRefundService

See Also

PayPalRefundService Members
InSite.Domain.CyberSourceService Namespace


PayPalRefundService Members

[image] [image]

.NET Framework Class Library
PayPalRefundService Members
PayPalRefundService Class Constructors Methods Properties Events See Also Send Feedback

The PayPalRefundService type exposes the following members.

Constructors

Name | Description
PayPalRefundService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
paypalCaptureId |
paypalDoCaptureRequestID |
paypalDoCaptureRequestToken |
paypalNote |
run |

Events

Name | Description
PropertyChanged |

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundService Constructor

[image]

.NET Framework Class Library
PayPalRefundService Constructor
PayPalRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PayPalRefundService()
Visual C++
public:
PayPalRefundService()
JavaScript
InSite.Domain.CyberSourceService.PayPalRefundService = function();

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundService Methods

[image] [image]

.NET Framework Class Library
PayPalRefundService Methods
PayPalRefundService Class See Also Send Feedback

The PayPalRefundService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PayPalRefundService..::.RaisePropertyChanged Method
PayPalRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundService Properties

[image] [image]

.NET Framework Class Library
PayPalRefundService Properties
PayPalRefundService Class See Also Send Feedback

The PayPalRefundService type exposes the following members.

Properties

Name | Description
paypalCaptureId |
paypalDoCaptureRequestID |
paypalDoCaptureRequestToken |
paypalNote |
run |

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


paypalCaptureId Property

[image]

.NET Framework Class Library
PayPalRefundService..::.paypalCaptureId Property
PayPalRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalCaptureId As String
C#
public string paypalCaptureId { get; set; }
Visual C++
public:
property String^ paypalCaptureId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalCaptureId();
function set_paypalCaptureId(value);

Remarks

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


paypalDoCaptureRequestID Property

[image]

.NET Framework Class Library
PayPalRefundService..::.paypalDoCaptureRequestID Property
PayPalRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalDoCaptureRequestID As String
C#
public string paypalDoCaptureRequestID { get; set; }
Visual C++
public:
property String^ paypalDoCaptureRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalDoCaptureRequestID();
function set_paypalDoCaptureRequestID(value);

Remarks

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


paypalDoCaptureRequestToken Property

[image]

.NET Framework Class Library
PayPalRefundService..::.paypalDoCaptureRequestToken Property
PayPalRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalDoCaptureRequestToken As String
C#
public string paypalDoCaptureRequestToken { get; set; }
Visual C++
public:
property String^ paypalDoCaptureRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalDoCaptureRequestToken();
function set_paypalDoCaptureRequestToken(value);

Remarks

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


paypalNote Property

[image]

.NET Framework Class Library
PayPalRefundService..::.paypalNote Property
PayPalRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypalNote As String
C#
public string paypalNote { get; set; }
Visual C++
public:
property String^ paypalNote {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paypalNote();
function set_paypalNote(value);

Remarks

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PayPalRefundService..::.run Property
PayPalRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


PayPalRefundService Events

[image] [image]

.NET Framework Class Library
PayPalRefundService Events
PayPalRefundService Class See Also Send Feedback

The PayPalRefundService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PayPalRefundService..::.PropertyChanged Event
PayPalRefundService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PayPalRefundService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateReply Class

[image]

.NET Framework Class Library
PaySubscriptionCreateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionCreateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionCreateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionCreateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionCreateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionCreateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionCreateReply

See Also

PaySubscriptionCreateReply Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateReply Members

[image] [image]

.NET Framework Class Library
PaySubscriptionCreateReply Members
PaySubscriptionCreateReply Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionCreateReply type exposes the following members.

Constructors

Name | Description
PaySubscriptionCreateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
reasonCode |
subscriptionID |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateReply Constructor

[image]

.NET Framework Class Library
PaySubscriptionCreateReply Constructor
PaySubscriptionCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionCreateReply()
Visual C++
public:
PaySubscriptionCreateReply()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionCreateReply = function();

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateReply Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionCreateReply Methods
PaySubscriptionCreateReply Class See Also Send Feedback

The PaySubscriptionCreateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionCreateReply..::.RaisePropertyChanged Method
PaySubscriptionCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateReply Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionCreateReply Properties
PaySubscriptionCreateReply Class See Also Send Feedback

The PaySubscriptionCreateReply type exposes the following members.

Properties

Name | Description
reasonCode |
subscriptionID |

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PaySubscriptionCreateReply..::.reasonCode Property
PaySubscriptionCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


subscriptionID Property

[image]

.NET Framework Class Library
PaySubscriptionCreateReply..::.subscriptionID Property
PaySubscriptionCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property subscriptionID As String
C#
public string subscriptionID { get; set; }
Visual C++
public:
property String^ subscriptionID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_subscriptionID();
function set_subscriptionID(value);

Remarks

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateReply Events

[image] [image]

.NET Framework Class Library
PaySubscriptionCreateReply Events
PaySubscriptionCreateReply Class See Also Send Feedback

The PaySubscriptionCreateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionCreateReply..::.PropertyChanged Event
PaySubscriptionCreateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionCreateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateService Class

[image]

.NET Framework Class Library
PaySubscriptionCreateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionCreateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionCreateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionCreateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionCreateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionCreateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionCreateService

See Also

PaySubscriptionCreateService Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateService Members

[image] [image]

.NET Framework Class Library
PaySubscriptionCreateService Members
PaySubscriptionCreateService Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionCreateService type exposes the following members.

Constructors

Name | Description
PaySubscriptionCreateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
disableAutoAuth |
paymentRequestID |
paymentRequestToken |
run |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateService Constructor

[image]

.NET Framework Class Library
PaySubscriptionCreateService Constructor
PaySubscriptionCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionCreateService()
Visual C++
public:
PaySubscriptionCreateService()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionCreateService = function();

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateService Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionCreateService Methods
PaySubscriptionCreateService Class See Also Send Feedback

The PaySubscriptionCreateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionCreateService..::.RaisePropertyChanged Method
PaySubscriptionCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateService Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionCreateService Properties
PaySubscriptionCreateService Class See Also Send Feedback

The PaySubscriptionCreateService type exposes the following members.

Properties

Name | Description
disableAutoAuth |
paymentRequestID |
paymentRequestToken |
run |

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


disableAutoAuth Property

[image]

.NET Framework Class Library
PaySubscriptionCreateService..::.disableAutoAuth Property
PaySubscriptionCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property disableAutoAuth As String
C#
public string disableAutoAuth { get; set; }
Visual C++
public:
property String^ disableAutoAuth {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_disableAutoAuth();
function set_disableAutoAuth(value);

Remarks

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


paymentRequestID Property

[image]

.NET Framework Class Library
PaySubscriptionCreateService..::.paymentRequestID Property
PaySubscriptionCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentRequestID As String
C#
public string paymentRequestID { get; set; }
Visual C++
public:
property String^ paymentRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentRequestID();
function set_paymentRequestID(value);

Remarks

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


paymentRequestToken Property

[image]

.NET Framework Class Library
PaySubscriptionCreateService..::.paymentRequestToken Property
PaySubscriptionCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentRequestToken As String
C#
public string paymentRequestToken { get; set; }
Visual C++
public:
property String^ paymentRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentRequestToken();
function set_paymentRequestToken(value);

Remarks

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PaySubscriptionCreateService..::.run Property
PaySubscriptionCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionCreateService Events

[image] [image]

.NET Framework Class Library
PaySubscriptionCreateService Events
PaySubscriptionCreateService Class See Also Send Feedback

The PaySubscriptionCreateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionCreateService..::.PropertyChanged Event
PaySubscriptionCreateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionCreateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEvent Class

[image]

.NET Framework Class Library
PaySubscriptionEvent Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionEvent _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionEvent : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionEvent : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionEvent = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionEvent',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionEvent

See Also

PaySubscriptionEvent Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEvent Members

[image] [image]

.NET Framework Class Library
PaySubscriptionEvent Members
PaySubscriptionEvent Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionEvent type exposes the following members.

Constructors

Name | Description
PaySubscriptionEvent |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
approvedBy |
number |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEvent Constructor

[image]

.NET Framework Class Library
PaySubscriptionEvent Constructor
PaySubscriptionEvent Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionEvent()
Visual C++
public:
PaySubscriptionEvent()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionEvent = function();

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEvent Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionEvent Methods
PaySubscriptionEvent Class See Also Send Feedback

The PaySubscriptionEvent type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionEvent..::.RaisePropertyChanged Method
PaySubscriptionEvent Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEvent Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionEvent Properties
PaySubscriptionEvent Class See Also Send Feedback

The PaySubscriptionEvent type exposes the following members.

Properties

Name | Description
amount |
approvedBy |
number |

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PaySubscriptionEvent..::.amount Property
PaySubscriptionEvent Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


approvedBy Property

[image]

.NET Framework Class Library
PaySubscriptionEvent..::.approvedBy Property
PaySubscriptionEvent Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property approvedBy As String
C#
public string approvedBy { get; set; }
Visual C++
public:
property String^ approvedBy {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_approvedBy();
function set_approvedBy(value);

Remarks

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


number Property

[image]

.NET Framework Class Library
PaySubscriptionEvent..::.number Property
PaySubscriptionEvent Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property number As String
C#
public string number { get; set; }
Visual C++
public:
property String^ number {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_number();
function set_number(value);

Remarks

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEvent Events

[image] [image]

.NET Framework Class Library
PaySubscriptionEvent Events
PaySubscriptionEvent Class See Also Send Feedback

The PaySubscriptionEvent type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionEvent..::.PropertyChanged Event
PaySubscriptionEvent Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionEvent Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateReply Class

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionEventUpdateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionEventUpdateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionEventUpdateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionEventUpdateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionEventUpdateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionEventUpdateReply

See Also

PaySubscriptionEventUpdateReply Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateReply Members

[image] [image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply Members
PaySubscriptionEventUpdateReply Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionEventUpdateReply type exposes the following members.

Constructors

Name | Description
PaySubscriptionEventUpdateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
reasonCode |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionEventUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateReply Constructor

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply Constructor
PaySubscriptionEventUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionEventUpdateReply()
Visual C++
public:
PaySubscriptionEventUpdateReply()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionEventUpdateReply = function();

See Also

PaySubscriptionEventUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateReply Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply Methods
PaySubscriptionEventUpdateReply Class See Also Send Feedback

The PaySubscriptionEventUpdateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionEventUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply..::.RaisePropertyChanged Method
PaySubscriptionEventUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionEventUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateReply Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply Properties
PaySubscriptionEventUpdateReply Class See Also Send Feedback

The PaySubscriptionEventUpdateReply type exposes the following members.

Properties

Name | Description
reasonCode |

See Also

PaySubscriptionEventUpdateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply..::.reasonCode Property
PaySubscriptionEventUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PaySubscriptionEventUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateReply Events

[image] [image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply Events
PaySubscriptionEventUpdateReply Class See Also Send Feedback

The PaySubscriptionEventUpdateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionEventUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateReply..::.PropertyChanged Event
PaySubscriptionEventUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionEventUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateService Class

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionEventUpdateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionEventUpdateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionEventUpdateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionEventUpdateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionEventUpdateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionEventUpdateService

See Also

PaySubscriptionEventUpdateService Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateService Members

[image] [image]

.NET Framework Class Library
PaySubscriptionEventUpdateService Members
PaySubscriptionEventUpdateService Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionEventUpdateService type exposes the following members.

Constructors

Name | Description
PaySubscriptionEventUpdateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
action |
run |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateService Constructor

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateService Constructor
PaySubscriptionEventUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionEventUpdateService()
Visual C++
public:
PaySubscriptionEventUpdateService()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionEventUpdateService = function();

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateService Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionEventUpdateService Methods
PaySubscriptionEventUpdateService Class See Also Send Feedback

The PaySubscriptionEventUpdateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateService..::.RaisePropertyChanged Method
PaySubscriptionEventUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateService Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionEventUpdateService Properties
PaySubscriptionEventUpdateService Class See Also Send Feedback

The PaySubscriptionEventUpdateService type exposes the following members.

Properties

Name | Description
action |
run |

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


action Property

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateService..::.action Property
PaySubscriptionEventUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property action As String
C#
public string action { get; set; }
Visual C++
public:
property String^ action {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_action();
function set_action(value);

Remarks

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateService..::.run Property
PaySubscriptionEventUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionEventUpdateService Events

[image] [image]

.NET Framework Class Library
PaySubscriptionEventUpdateService Events
PaySubscriptionEventUpdateService Class See Also Send Feedback

The PaySubscriptionEventUpdateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionEventUpdateService..::.PropertyChanged Event
PaySubscriptionEventUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionEventUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveReply Class

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionRetrieveReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionRetrieveReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionRetrieveReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionRetrieveReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionRetrieveReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionRetrieveReply

See Also

PaySubscriptionRetrieveReply Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveReply Members

[image] [image]

.NET Framework Class Library
PaySubscriptionRetrieveReply Members
PaySubscriptionRetrieveReply Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionRetrieveReply type exposes the following members.

Constructors

Name | Description
PaySubscriptionRetrieveReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
approvalRequired |
automaticRenew |
billPayment |
cardAccountNumber |
cardExpirationMonth |
cardExpirationYear |
cardIssueNumber |
cardStartMonth |
cardStartYear |
cardType |
checkAccountNumber |
checkAccountType |
checkBankTransitNumber |
city |
comments |
companyName |
country |
currency |
customerAccountID |
email |
endDate |
firstName |
frequency |
lastName |
merchantDefinedDataField1 |
merchantDefinedDataField2 |
merchantDefinedDataField3 |
merchantDefinedDataField4 |
merchantReferenceCode |
merchantSecureDataField1 |
merchantSecureDataField2 |
merchantSecureDataField3 |
merchantSecureDataField4 |
paymentMethod |
paymentsRemaining |
phoneNumber |
postalCode |
reasonCode |
recurringAmount |
setupAmount |
shipToCity |
shipToCompany |
shipToCountry |
shipToFirstName |
shipToLastName |
shipToPostalCode |
shipToState |
shipToStreet1 |
shipToStreet2 |
startDate |
state |
status |
street1 |
street2 |
subscriptionID |
title |
totalPayments |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveReply Constructor

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply Constructor
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionRetrieveReply()
Visual C++
public:
PaySubscriptionRetrieveReply()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionRetrieveReply = function();

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveReply Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionRetrieveReply Methods
PaySubscriptionRetrieveReply Class See Also Send Feedback

The PaySubscriptionRetrieveReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.RaisePropertyChanged Method
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveReply Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionRetrieveReply Properties
PaySubscriptionRetrieveReply Class See Also Send Feedback

The PaySubscriptionRetrieveReply type exposes the following members.

Properties

Name | Description
approvalRequired |
automaticRenew |
billPayment |
cardAccountNumber |
cardExpirationMonth |
cardExpirationYear |
cardIssueNumber |
cardStartMonth |
cardStartYear |
cardType |
checkAccountNumber |
checkAccountType |
checkBankTransitNumber |
city |
comments |
companyName |
country |
currency |
customerAccountID |
email |
endDate |
firstName |
frequency |
lastName |
merchantDefinedDataField1 |
merchantDefinedDataField2 |
merchantDefinedDataField3 |
merchantDefinedDataField4 |
merchantReferenceCode |
merchantSecureDataField1 |
merchantSecureDataField2 |
merchantSecureDataField3 |
merchantSecureDataField4 |
paymentMethod |
paymentsRemaining |
phoneNumber |
postalCode |
reasonCode |
recurringAmount |
setupAmount |
shipToCity |
shipToCompany |
shipToCountry |
shipToFirstName |
shipToLastName |
shipToPostalCode |
shipToState |
shipToStreet1 |
shipToStreet2 |
startDate |
state |
status |
street1 |
street2 |
subscriptionID |
title |
totalPayments |

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


approvalRequired Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.approvalRequired Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property approvalRequired As String
C#
public string approvalRequired { get; set; }
Visual C++
public:
property String^ approvalRequired {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_approvalRequired();
function set_approvalRequired(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


automaticRenew Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.automaticRenew Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property automaticRenew As String
C#
public string automaticRenew { get; set; }
Visual C++
public:
property String^ automaticRenew {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_automaticRenew();
function set_automaticRenew(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


billPayment Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.billPayment Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billPayment As String
C#
public string billPayment { get; set; }
Visual C++
public:
property String^ billPayment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_billPayment();
function set_billPayment(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


cardAccountNumber Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.cardAccountNumber Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardAccountNumber As String
C#
public string cardAccountNumber { get; set; }
Visual C++
public:
property String^ cardAccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardAccountNumber();
function set_cardAccountNumber(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


cardExpirationMonth Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.cardExpirationMonth Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardExpirationMonth As String
C#
public string cardExpirationMonth { get; set; }
Visual C++
public:
property String^ cardExpirationMonth {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardExpirationMonth();
function set_cardExpirationMonth(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


cardExpirationYear Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.cardExpirationYear Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardExpirationYear As String
C#
public string cardExpirationYear { get; set; }
Visual C++
public:
property String^ cardExpirationYear {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardExpirationYear();
function set_cardExpirationYear(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


cardIssueNumber Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.cardIssueNumber Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardIssueNumber As String
C#
public string cardIssueNumber { get; set; }
Visual C++
public:
property String^ cardIssueNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardIssueNumber();
function set_cardIssueNumber(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


cardStartMonth Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.cardStartMonth Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardStartMonth As String
C#
public string cardStartMonth { get; set; }
Visual C++
public:
property String^ cardStartMonth {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardStartMonth();
function set_cardStartMonth(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


cardStartYear Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.cardStartYear Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardStartYear As String
C#
public string cardStartYear { get; set; }
Visual C++
public:
property String^ cardStartYear {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardStartYear();
function set_cardStartYear(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


cardType Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.cardType Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardType As String
C#
public string cardType { get; set; }
Visual C++
public:
property String^ cardType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardType();
function set_cardType(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


checkAccountNumber Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.checkAccountNumber Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property checkAccountNumber As String
C#
public string checkAccountNumber { get; set; }
Visual C++
public:
property String^ checkAccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_checkAccountNumber();
function set_checkAccountNumber(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


checkAccountType Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.checkAccountType Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property checkAccountType As String
C#
public string checkAccountType { get; set; }
Visual C++
public:
property String^ checkAccountType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_checkAccountType();
function set_checkAccountType(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


checkBankTransitNumber Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.checkBankTransitNumber Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property checkBankTransitNumber As String
C#
public string checkBankTransitNumber { get; set; }
Visual C++
public:
property String^ checkBankTransitNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_checkBankTransitNumber();
function set_checkBankTransitNumber(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


city Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.city Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


comments Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.comments Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property comments As String
C#
public string comments { get; set; }
Visual C++
public:
property String^ comments {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_comments();
function set_comments(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


companyName Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.companyName Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property companyName As String
C#
public string companyName { get; set; }
Visual C++
public:
property String^ companyName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_companyName();
function set_companyName(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


country Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.country Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property country As String
C#
public string country { get; set; }
Visual C++
public:
property String^ country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.currency Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


customerAccountID Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.customerAccountID Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property customerAccountID As String
C#
public string customerAccountID { get; set; }
Visual C++
public:
property String^ customerAccountID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerAccountID();
function set_customerAccountID(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


email Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.email Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property email As String
C#
public string email { get; set; }
Visual C++
public:
property String^ email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


endDate Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.endDate Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property endDate As String
C#
public string endDate { get; set; }
Visual C++
public:
property String^ endDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_endDate();
function set_endDate(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


firstName Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.firstName Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property firstName As String
C#
public string firstName { get; set; }
Visual C++
public:
property String^ firstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


frequency Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.frequency Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property frequency As String
C#
public string frequency { get; set; }
Visual C++
public:
property String^ frequency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


lastName Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.lastName Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property lastName As String
C#
public string lastName { get; set; }
Visual C++
public:
property String^ lastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantDefinedDataField1 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantDefinedDataField1 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantDefinedDataField1 As String
C#
public string merchantDefinedDataField1 { get; set; }
Visual C++
public:
property String^ merchantDefinedDataField1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantDefinedDataField1();
function set_merchantDefinedDataField1(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantDefinedDataField2 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantDefinedDataField2 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantDefinedDataField2 As String
C#
public string merchantDefinedDataField2 { get; set; }
Visual C++
public:
property String^ merchantDefinedDataField2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantDefinedDataField2();
function set_merchantDefinedDataField2(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantDefinedDataField3 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantDefinedDataField3 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantDefinedDataField3 As String
C#
public string merchantDefinedDataField3 { get; set; }
Visual C++
public:
property String^ merchantDefinedDataField3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantDefinedDataField3();
function set_merchantDefinedDataField3(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantDefinedDataField4 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantDefinedDataField4 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantDefinedDataField4 As String
C#
public string merchantDefinedDataField4 { get; set; }
Visual C++
public:
property String^ merchantDefinedDataField4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantDefinedDataField4();
function set_merchantDefinedDataField4(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantReferenceCode Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantReferenceCode Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantReferenceCode As String
C#
public string merchantReferenceCode { get; set; }
Visual C++
public:
property String^ merchantReferenceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantReferenceCode();
function set_merchantReferenceCode(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantSecureDataField1 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantSecureDataField1 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantSecureDataField1 As String
C#
public string merchantSecureDataField1 { get; set; }
Visual C++
public:
property String^ merchantSecureDataField1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantSecureDataField1();
function set_merchantSecureDataField1(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantSecureDataField2 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantSecureDataField2 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantSecureDataField2 As String
C#
public string merchantSecureDataField2 { get; set; }
Visual C++
public:
property String^ merchantSecureDataField2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantSecureDataField2();
function set_merchantSecureDataField2(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantSecureDataField3 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantSecureDataField3 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantSecureDataField3 As String
C#
public string merchantSecureDataField3 { get; set; }
Visual C++
public:
property String^ merchantSecureDataField3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantSecureDataField3();
function set_merchantSecureDataField3(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


merchantSecureDataField4 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.merchantSecureDataField4 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantSecureDataField4 As String
C#
public string merchantSecureDataField4 { get; set; }
Visual C++
public:
property String^ merchantSecureDataField4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantSecureDataField4();
function set_merchantSecureDataField4(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


paymentMethod Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.paymentMethod Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentMethod As String
C#
public string paymentMethod { get; set; }
Visual C++
public:
property String^ paymentMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentMethod();
function set_paymentMethod(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


paymentsRemaining Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.paymentsRemaining Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentsRemaining As String
C#
public string paymentsRemaining { get; set; }
Visual C++
public:
property String^ paymentsRemaining {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentsRemaining();
function set_paymentsRemaining(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


phoneNumber Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.phoneNumber Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property phoneNumber As String
C#
public string phoneNumber { get; set; }
Visual C++
public:
property String^ phoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


postalCode Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.postalCode Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property postalCode As String
C#
public string postalCode { get; set; }
Visual C++
public:
property String^ postalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.reasonCode Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


recurringAmount Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.recurringAmount Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property recurringAmount As String
C#
public string recurringAmount { get; set; }
Visual C++
public:
property String^ recurringAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_recurringAmount();
function set_recurringAmount(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


setupAmount Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.setupAmount Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property setupAmount As String
C#
public string setupAmount { get; set; }
Visual C++
public:
property String^ setupAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_setupAmount();
function set_setupAmount(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToCity Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToCity Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToCity As String
C#
public string shipToCity { get; set; }
Visual C++
public:
property String^ shipToCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCity();
function set_shipToCity(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToCompany Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToCompany Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToCompany As String
C#
public string shipToCompany { get; set; }
Visual C++
public:
property String^ shipToCompany {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCompany();
function set_shipToCompany(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToCountry Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToCountry Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToCountry As String
C#
public string shipToCountry { get; set; }
Visual C++
public:
property String^ shipToCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCountry();
function set_shipToCountry(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToFirstName Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToFirstName Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToFirstName As String
C#
public string shipToFirstName { get; set; }
Visual C++
public:
property String^ shipToFirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToFirstName();
function set_shipToFirstName(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToLastName Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToLastName Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToLastName As String
C#
public string shipToLastName { get; set; }
Visual C++
public:
property String^ shipToLastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToLastName();
function set_shipToLastName(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToPostalCode Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToPostalCode Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToPostalCode As String
C#
public string shipToPostalCode { get; set; }
Visual C++
public:
property String^ shipToPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToPostalCode();
function set_shipToPostalCode(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToState Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToState Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToState As String
C#
public string shipToState { get; set; }
Visual C++
public:
property String^ shipToState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToState();
function set_shipToState(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToStreet1 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToStreet1 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToStreet1 As String
C#
public string shipToStreet1 { get; set; }
Visual C++
public:
property String^ shipToStreet1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToStreet1();
function set_shipToStreet1(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


shipToStreet2 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.shipToStreet2 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipToStreet2 As String
C#
public string shipToStreet2 { get; set; }
Visual C++
public:
property String^ shipToStreet2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToStreet2();
function set_shipToStreet2(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


startDate Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.startDate Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property startDate As String
C#
public string startDate { get; set; }
Visual C++
public:
property String^ startDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_startDate();
function set_startDate(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


state Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.state Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


status Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.status Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property status As String
C#
public string status { get; set; }
Visual C++
public:
property String^ status {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_status();
function set_status(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


street1 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.street1 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street1 As String
C#
public string street1 { get; set; }
Visual C++
public:
property String^ street1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street1();
function set_street1(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


street2 Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.street2 Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street2 As String
C#
public string street2 { get; set; }
Visual C++
public:
property String^ street2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street2();
function set_street2(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


subscriptionID Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.subscriptionID Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property subscriptionID As String
C#
public string subscriptionID { get; set; }
Visual C++
public:
property String^ subscriptionID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_subscriptionID();
function set_subscriptionID(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


title Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.title Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property title As String
C#
public string title { get; set; }
Visual C++
public:
property String^ title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


totalPayments Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.totalPayments Property
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalPayments As String
C#
public string totalPayments { get; set; }
Visual C++
public:
property String^ totalPayments {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalPayments();
function set_totalPayments(value);

Remarks

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveReply Events

[image] [image]

.NET Framework Class Library
PaySubscriptionRetrieveReply Events
PaySubscriptionRetrieveReply Class See Also Send Feedback

The PaySubscriptionRetrieveReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionRetrieveReply..::.PropertyChanged Event
PaySubscriptionRetrieveReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionRetrieveReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveService Class

[image]

.NET Framework Class Library
PaySubscriptionRetrieveService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionRetrieveService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionRetrieveService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionRetrieveService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionRetrieveService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionRetrieveService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionRetrieveService

See Also

PaySubscriptionRetrieveService Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveService Members

[image] [image]

.NET Framework Class Library
PaySubscriptionRetrieveService Members
PaySubscriptionRetrieveService Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionRetrieveService type exposes the following members.

Constructors

Name | Description
PaySubscriptionRetrieveService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionRetrieveService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveService Constructor

[image]

.NET Framework Class Library
PaySubscriptionRetrieveService Constructor
PaySubscriptionRetrieveService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionRetrieveService()
Visual C++
public:
PaySubscriptionRetrieveService()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionRetrieveService = function();

See Also

PaySubscriptionRetrieveService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveService Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionRetrieveService Methods
PaySubscriptionRetrieveService Class See Also Send Feedback

The PaySubscriptionRetrieveService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionRetrieveService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionRetrieveService..::.RaisePropertyChanged Method
PaySubscriptionRetrieveService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionRetrieveService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveService Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionRetrieveService Properties
PaySubscriptionRetrieveService Class See Also Send Feedback

The PaySubscriptionRetrieveService type exposes the following members.

Properties

Name | Description
run |

See Also

PaySubscriptionRetrieveService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PaySubscriptionRetrieveService..::.run Property
PaySubscriptionRetrieveService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PaySubscriptionRetrieveService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionRetrieveService Events

[image] [image]

.NET Framework Class Library
PaySubscriptionRetrieveService Events
PaySubscriptionRetrieveService Class See Also Send Feedback

The PaySubscriptionRetrieveService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionRetrieveService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionRetrieveService..::.PropertyChanged Event
PaySubscriptionRetrieveService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionRetrieveService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateReply Class

[image]

.NET Framework Class Library
PaySubscriptionUpdateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionUpdateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionUpdateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionUpdateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionUpdateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionUpdateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionUpdateReply

See Also

PaySubscriptionUpdateReply Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateReply Members

[image] [image]

.NET Framework Class Library
PaySubscriptionUpdateReply Members
PaySubscriptionUpdateReply Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionUpdateReply type exposes the following members.

Constructors

Name | Description
PaySubscriptionUpdateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
reasonCode |
subscriptionID |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateReply Constructor

[image]

.NET Framework Class Library
PaySubscriptionUpdateReply Constructor
PaySubscriptionUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionUpdateReply()
Visual C++
public:
PaySubscriptionUpdateReply()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionUpdateReply = function();

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateReply Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionUpdateReply Methods
PaySubscriptionUpdateReply Class See Also Send Feedback

The PaySubscriptionUpdateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionUpdateReply..::.RaisePropertyChanged Method
PaySubscriptionUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateReply Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionUpdateReply Properties
PaySubscriptionUpdateReply Class See Also Send Feedback

The PaySubscriptionUpdateReply type exposes the following members.

Properties

Name | Description
reasonCode |
subscriptionID |

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PaySubscriptionUpdateReply..::.reasonCode Property
PaySubscriptionUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


subscriptionID Property

[image]

.NET Framework Class Library
PaySubscriptionUpdateReply..::.subscriptionID Property
PaySubscriptionUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property subscriptionID As String
C#
public string subscriptionID { get; set; }
Visual C++
public:
property String^ subscriptionID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_subscriptionID();
function set_subscriptionID(value);

Remarks

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateReply Events

[image] [image]

.NET Framework Class Library
PaySubscriptionUpdateReply Events
PaySubscriptionUpdateReply Class See Also Send Feedback

The PaySubscriptionUpdateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionUpdateReply..::.PropertyChanged Event
PaySubscriptionUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateService Class

[image]

.NET Framework Class Library
PaySubscriptionUpdateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PaySubscriptionUpdateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PaySubscriptionUpdateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PaySubscriptionUpdateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionUpdateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PaySubscriptionUpdateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PaySubscriptionUpdateService

See Also

PaySubscriptionUpdateService Members
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateService Members

[image] [image]

.NET Framework Class Library
PaySubscriptionUpdateService Members
PaySubscriptionUpdateService Class Constructors Methods Properties Events See Also Send Feedback

The PaySubscriptionUpdateService type exposes the following members.

Constructors

Name | Description
PaySubscriptionUpdateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateService Constructor

[image]

.NET Framework Class Library
PaySubscriptionUpdateService Constructor
PaySubscriptionUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaySubscriptionUpdateService()
Visual C++
public:
PaySubscriptionUpdateService()
JavaScript
InSite.Domain.CyberSourceService.PaySubscriptionUpdateService = function();

See Also

PaySubscriptionUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateService Methods

[image] [image]

.NET Framework Class Library
PaySubscriptionUpdateService Methods
PaySubscriptionUpdateService Class See Also Send Feedback

The PaySubscriptionUpdateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaySubscriptionUpdateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PaySubscriptionUpdateService..::.RaisePropertyChanged Method
PaySubscriptionUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PaySubscriptionUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateService Properties

[image] [image]

.NET Framework Class Library
PaySubscriptionUpdateService Properties
PaySubscriptionUpdateService Class See Also Send Feedback

The PaySubscriptionUpdateService type exposes the following members.

Properties

Name | Description
run |

See Also

PaySubscriptionUpdateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PaySubscriptionUpdateService..::.run Property
PaySubscriptionUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PaySubscriptionUpdateService Class
InSite.Domain.CyberSourceService Namespace


PaySubscriptionUpdateService Events

[image] [image]

.NET Framework Class Library
PaySubscriptionUpdateService Events
PaySubscriptionUpdateService Class See Also Send Feedback

The PaySubscriptionUpdateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PaySubscriptionUpdateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PaySubscriptionUpdateService..::.PropertyChanged Event
PaySubscriptionUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PaySubscriptionUpdateService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitReply Class

[image]

.NET Framework Class Library
PinlessDebitReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PinlessDebitReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PinlessDebitReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PinlessDebitReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PinlessDebitReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PinlessDebitReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PinlessDebitReply

See Also

PinlessDebitReply Members
InSite.Domain.CyberSourceService Namespace


PinlessDebitReply Members

[image] [image]

.NET Framework Class Library
PinlessDebitReply Members
PinlessDebitReply Class Constructors Methods Properties Events See Also Send Feedback

The PinlessDebitReply type exposes the following members.

Constructors

Name | Description
PinlessDebitReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
authorizationCode |
processorResponse |
reasonCode |
receiptNumber |
reconciliationID |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitReply Constructor

[image]

.NET Framework Class Library
PinlessDebitReply Constructor
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PinlessDebitReply()
Visual C++
public:
PinlessDebitReply()
JavaScript
InSite.Domain.CyberSourceService.PinlessDebitReply = function();

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitReply Methods

[image] [image]

.NET Framework Class Library
PinlessDebitReply Methods
PinlessDebitReply Class See Also Send Feedback

The PinlessDebitReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PinlessDebitReply..::.RaisePropertyChanged Method
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitReply Properties

[image] [image]

.NET Framework Class Library
PinlessDebitReply Properties
PinlessDebitReply Class See Also Send Feedback

The PinlessDebitReply type exposes the following members.

Properties

Name | Description
amount |
authorizationCode |
processorResponse |
reasonCode |
receiptNumber |
reconciliationID |
requestDateTime |

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
PinlessDebitReply..::.amount Property
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


authorizationCode Property

[image]

.NET Framework Class Library
PinlessDebitReply..::.authorizationCode Property
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authorizationCode As String
C#
public string authorizationCode { get; set; }
Visual C++
public:
property String^ authorizationCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authorizationCode();
function set_authorizationCode(value);

Remarks

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


processorResponse Property

[image]

.NET Framework Class Library
PinlessDebitReply..::.processorResponse Property
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property processorResponse As String
C#
public string processorResponse { get; set; }
Visual C++
public:
property String^ processorResponse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processorResponse();
function set_processorResponse(value);

Remarks

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PinlessDebitReply..::.reasonCode Property
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


receiptNumber Property

[image]

.NET Framework Class Library
PinlessDebitReply..::.receiptNumber Property
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property receiptNumber As String
C#
public string receiptNumber { get; set; }
Visual C++
public:
property String^ receiptNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_receiptNumber();
function set_receiptNumber(value);

Remarks

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PinlessDebitReply..::.reconciliationID Property
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
PinlessDebitReply..::.requestDateTime Property
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitReply Events

[image] [image]

.NET Framework Class Library
PinlessDebitReply Events
PinlessDebitReply Class See Also Send Feedback

The PinlessDebitReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PinlessDebitReply..::.PropertyChanged Event
PinlessDebitReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PinlessDebitReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitService Class

[image]

.NET Framework Class Library
PinlessDebitService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PinlessDebitService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PinlessDebitService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PinlessDebitService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PinlessDebitService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PinlessDebitService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PinlessDebitService

See Also

PinlessDebitService Members
InSite.Domain.CyberSourceService Namespace


PinlessDebitService Members

[image] [image]

.NET Framework Class Library
PinlessDebitService Members
PinlessDebitService Class Constructors Methods Properties Events See Also Send Feedback

The PinlessDebitService type exposes the following members.

Constructors

Name | Description
PinlessDebitService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
commerceIndicator |
reconciliationID |
run |

Events

Name | Description
PropertyChanged |

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitService Constructor

[image]

.NET Framework Class Library
PinlessDebitService Constructor
PinlessDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PinlessDebitService()
Visual C++
public:
PinlessDebitService()
JavaScript
InSite.Domain.CyberSourceService.PinlessDebitService = function();

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitService Methods

[image] [image]

.NET Framework Class Library
PinlessDebitService Methods
PinlessDebitService Class See Also Send Feedback

The PinlessDebitService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PinlessDebitService..::.RaisePropertyChanged Method
PinlessDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitService Properties

[image] [image]

.NET Framework Class Library
PinlessDebitService Properties
PinlessDebitService Class See Also Send Feedback

The PinlessDebitService type exposes the following members.

Properties

Name | Description
commerceIndicator |
reconciliationID |
run |

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


commerceIndicator Property

[image]

.NET Framework Class Library
PinlessDebitService..::.commerceIndicator Property
PinlessDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property commerceIndicator As String
C#
public string commerceIndicator { get; set; }
Visual C++
public:
property String^ commerceIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commerceIndicator();
function set_commerceIndicator(value);

Remarks

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


reconciliationID Property

[image]

.NET Framework Class Library
PinlessDebitService..::.reconciliationID Property
PinlessDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reconciliationID As String
C#
public string reconciliationID { get; set; }
Visual C++
public:
property String^ reconciliationID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reconciliationID();
function set_reconciliationID(value);

Remarks

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PinlessDebitService..::.run Property
PinlessDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitService Events

[image] [image]

.NET Framework Class Library
PinlessDebitService Events
PinlessDebitService Class See Also Send Feedback

The PinlessDebitService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PinlessDebitService..::.PropertyChanged Event
PinlessDebitService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PinlessDebitService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateReply Class

[image]

.NET Framework Class Library
PinlessDebitValidateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PinlessDebitValidateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PinlessDebitValidateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PinlessDebitValidateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PinlessDebitValidateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PinlessDebitValidateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PinlessDebitValidateReply

See Also

PinlessDebitValidateReply Members
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateReply Members

[image] [image]

.NET Framework Class Library
PinlessDebitValidateReply Members
PinlessDebitValidateReply Class Constructors Methods Properties Events See Also Send Feedback

The PinlessDebitValidateReply type exposes the following members.

Constructors

Name | Description
PinlessDebitValidateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
reasonCode |
requestDateTime |
status |

Events

Name | Description
PropertyChanged |

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateReply Constructor

[image]

.NET Framework Class Library
PinlessDebitValidateReply Constructor
PinlessDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PinlessDebitValidateReply()
Visual C++
public:
PinlessDebitValidateReply()
JavaScript
InSite.Domain.CyberSourceService.PinlessDebitValidateReply = function();

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateReply Methods

[image] [image]

.NET Framework Class Library
PinlessDebitValidateReply Methods
PinlessDebitValidateReply Class See Also Send Feedback

The PinlessDebitValidateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PinlessDebitValidateReply..::.RaisePropertyChanged Method
PinlessDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateReply Properties

[image] [image]

.NET Framework Class Library
PinlessDebitValidateReply Properties
PinlessDebitValidateReply Class See Also Send Feedback

The PinlessDebitValidateReply type exposes the following members.

Properties

Name | Description
reasonCode |
requestDateTime |
status |

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
PinlessDebitValidateReply..::.reasonCode Property
PinlessDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
PinlessDebitValidateReply..::.requestDateTime Property
PinlessDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


status Property

[image]

.NET Framework Class Library
PinlessDebitValidateReply..::.status Property
PinlessDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property status As String
C#
public string status { get; set; }
Visual C++
public:
property String^ status {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_status();
function set_status(value);

Remarks

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateReply Events

[image] [image]

.NET Framework Class Library
PinlessDebitValidateReply Events
PinlessDebitValidateReply Class See Also Send Feedback

The PinlessDebitValidateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PinlessDebitValidateReply..::.PropertyChanged Event
PinlessDebitValidateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PinlessDebitValidateReply Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateService Class

[image]

.NET Framework Class Library
PinlessDebitValidateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PinlessDebitValidateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PinlessDebitValidateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PinlessDebitValidateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PinlessDebitValidateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PinlessDebitValidateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PinlessDebitValidateService

See Also

PinlessDebitValidateService Members
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateService Members

[image] [image]

.NET Framework Class Library
PinlessDebitValidateService Members
PinlessDebitValidateService Class Constructors Methods Properties Events See Also Send Feedback

The PinlessDebitValidateService type exposes the following members.

Constructors

Name | Description
PinlessDebitValidateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |

Events

Name | Description
PropertyChanged |

See Also

PinlessDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateService Constructor

[image]

.NET Framework Class Library
PinlessDebitValidateService Constructor
PinlessDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PinlessDebitValidateService()
Visual C++
public:
PinlessDebitValidateService()
JavaScript
InSite.Domain.CyberSourceService.PinlessDebitValidateService = function();

See Also

PinlessDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateService Methods

[image] [image]

.NET Framework Class Library
PinlessDebitValidateService Methods
PinlessDebitValidateService Class See Also Send Feedback

The PinlessDebitValidateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PinlessDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PinlessDebitValidateService..::.RaisePropertyChanged Method
PinlessDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PinlessDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateService Properties

[image] [image]

.NET Framework Class Library
PinlessDebitValidateService Properties
PinlessDebitValidateService Class See Also Send Feedback

The PinlessDebitValidateService type exposes the following members.

Properties

Name | Description
run |

See Also

PinlessDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
PinlessDebitValidateService..::.run Property
PinlessDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

PinlessDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


PinlessDebitValidateService Events

[image] [image]

.NET Framework Class Library
PinlessDebitValidateService Events
PinlessDebitValidateService Class See Also Send Feedback

The PinlessDebitValidateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PinlessDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PinlessDebitValidateService..::.PropertyChanged Event
PinlessDebitValidateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PinlessDebitValidateService Class
InSite.Domain.CyberSourceService Namespace


Pos Class

[image]

.NET Framework Class Library
Pos Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Pos _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Pos : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Pos : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Pos = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Pos',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Pos

See Also

Pos Members
InSite.Domain.CyberSourceService Namespace


Pos Members

[image] [image]

.NET Framework Class Library
Pos Members
Pos Class Constructors Methods Properties Events See Also Send Feedback

The Pos type exposes the following members.

Constructors

Name | Description
Pos |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
cardPresent |
catLevel |
conditionCode |
entryMode |
terminalCapability |
terminalID |
terminalLocation |
terminalType |
trackData |
transactionSecurity |

Events

Name | Description
PropertyChanged |

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


Pos Constructor

[image]

.NET Framework Class Library
Pos Constructor
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Pos()
Visual C++
public:
Pos()
JavaScript
InSite.Domain.CyberSourceService.Pos = function();

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


Pos Methods

[image] [image]

.NET Framework Class Library
Pos Methods
Pos Class See Also Send Feedback

The Pos type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Pos..::.RaisePropertyChanged Method
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


Pos Properties

[image] [image]

.NET Framework Class Library
Pos Properties
Pos Class See Also Send Feedback

The Pos type exposes the following members.

Properties

Name | Description
cardPresent |
catLevel |
conditionCode |
entryMode |
terminalCapability |
terminalID |
terminalLocation |
terminalType |
trackData |
transactionSecurity |

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


cardPresent Property

[image]

.NET Framework Class Library
Pos..::.cardPresent Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cardPresent As String
C#
public string cardPresent { get; set; }
Visual C++
public:
property String^ cardPresent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardPresent();
function set_cardPresent(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


catLevel Property

[image]

.NET Framework Class Library
Pos..::.catLevel Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property catLevel As String
C#
public string catLevel { get; set; }
Visual C++
public:
property String^ catLevel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_catLevel();
function set_catLevel(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


conditionCode Property

[image]

.NET Framework Class Library
Pos..::.conditionCode Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property conditionCode As String
C#
public string conditionCode { get; set; }
Visual C++
public:
property String^ conditionCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_conditionCode();
function set_conditionCode(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


entryMode Property

[image]

.NET Framework Class Library
Pos..::.entryMode Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property entryMode As String
C#
public string entryMode { get; set; }
Visual C++
public:
property String^ entryMode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_entryMode();
function set_entryMode(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


terminalCapability Property

[image]

.NET Framework Class Library
Pos..::.terminalCapability Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property terminalCapability As String
C#
public string terminalCapability { get; set; }
Visual C++
public:
property String^ terminalCapability {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_terminalCapability();
function set_terminalCapability(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


terminalID Property

[image]

.NET Framework Class Library
Pos..::.terminalID Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property terminalID As String
C#
public string terminalID { get; set; }
Visual C++
public:
property String^ terminalID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_terminalID();
function set_terminalID(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


terminalLocation Property

[image]

.NET Framework Class Library
Pos..::.terminalLocation Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property terminalLocation As String
C#
public string terminalLocation { get; set; }
Visual C++
public:
property String^ terminalLocation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_terminalLocation();
function set_terminalLocation(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


terminalType Property

[image]

.NET Framework Class Library
Pos..::.terminalType Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property terminalType As String
C#
public string terminalType { get; set; }
Visual C++
public:
property String^ terminalType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_terminalType();
function set_terminalType(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


trackData Property

[image]

.NET Framework Class Library
Pos..::.trackData Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property trackData As String
C#
public string trackData { get; set; }
Visual C++
public:
property String^ trackData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_trackData();
function set_trackData(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


transactionSecurity Property

[image]

.NET Framework Class Library
Pos..::.transactionSecurity Property
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property transactionSecurity As String
C#
public string transactionSecurity { get; set; }
Visual C++
public:
property String^ transactionSecurity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionSecurity();
function set_transactionSecurity(value);

Remarks

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


Pos Events

[image] [image]

.NET Framework Class Library
Pos Events
Pos Class See Also Send Feedback

The Pos type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Pos..::.PropertyChanged Event
Pos Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Pos Class
InSite.Domain.CyberSourceService Namespace


ProfileReply Class

[image]

.NET Framework Class Library
ProfileReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ProfileReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ProfileReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ProfileReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ProfileReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ProfileReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ProfileReply

See Also

ProfileReply Members
InSite.Domain.CyberSourceService Namespace


ProfileReply Members

[image] [image]

.NET Framework Class Library
ProfileReply Members
ProfileReply Class Constructors Methods Properties Events See Also Send Feedback

The ProfileReply type exposes the following members.

Constructors

Name | Description
ProfileReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
destinationQueue |
name |
rulesTriggered |
selectedBy |

Events

Name | Description
PropertyChanged |

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


ProfileReply Constructor

[image]

.NET Framework Class Library
ProfileReply Constructor
ProfileReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProfileReply()
Visual C++
public:
ProfileReply()
JavaScript
InSite.Domain.CyberSourceService.ProfileReply = function();

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


ProfileReply Methods

[image] [image]

.NET Framework Class Library
ProfileReply Methods
ProfileReply Class See Also Send Feedback

The ProfileReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ProfileReply..::.RaisePropertyChanged Method
ProfileReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


ProfileReply Properties

[image] [image]

.NET Framework Class Library
ProfileReply Properties
ProfileReply Class See Also Send Feedback

The ProfileReply type exposes the following members.

Properties

Name | Description
destinationQueue |
name |
rulesTriggered |
selectedBy |

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


destinationQueue Property

[image]

.NET Framework Class Library
ProfileReply..::.destinationQueue Property
ProfileReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property destinationQueue As String
C#
public string destinationQueue { get; set; }
Visual C++
public:
property String^ destinationQueue {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_destinationQueue();
function set_destinationQueue(value);

Remarks

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


name Property

[image]

.NET Framework Class Library
ProfileReply..::.name Property
ProfileReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String
C#
public string name { get; set; }
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


rulesTriggered Property

[image]

.NET Framework Class Library
ProfileReply..::.rulesTriggered Property
ProfileReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property rulesTriggered As RuleResultItem()
C#
public RuleResultItem[] rulesTriggered { get; set; }
Visual C++
public:
property array<RuleResultItem^>^ rulesTriggered {
    array<RuleResultItem^>^ get ();
    void set (array<RuleResultItem^>^ value);
}
JavaScript
function get_rulesTriggered();
function set_rulesTriggered(value);

Remarks

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


selectedBy Property

[image]

.NET Framework Class Library
ProfileReply..::.selectedBy Property
ProfileReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property selectedBy As String
C#
public string selectedBy { get; set; }
Visual C++
public:
property String^ selectedBy {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_selectedBy();
function set_selectedBy(value);

Remarks

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


ProfileReply Events

[image] [image]

.NET Framework Class Library
ProfileReply Events
ProfileReply Class See Also Send Feedback

The ProfileReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ProfileReply..::.PropertyChanged Event
ProfileReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ProfileReply Class
InSite.Domain.CyberSourceService Namespace


PurchaseTotals Class

[image]

.NET Framework Class Library
PurchaseTotals Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class PurchaseTotals _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class PurchaseTotals : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class PurchaseTotals : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.PurchaseTotals = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.PurchaseTotals',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.PurchaseTotals

See Also

PurchaseTotals Members
InSite.Domain.CyberSourceService Namespace


PurchaseTotals Members

[image] [image]

.NET Framework Class Library
PurchaseTotals Members
PurchaseTotals Class Constructors Methods Properties Events See Also Send Feedback

The PurchaseTotals type exposes the following members.

Constructors

Name | Description
PurchaseTotals |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
currency |
discountAmount |
dutyAmount |
exchangeRate |
exchangeRateTimeStamp |
foreignAmount |
foreignCurrency |
freightAmount |
grandTotalAmount |
taxAmount |

Events

Name | Description
PropertyChanged |

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


PurchaseTotals Constructor

[image]

.NET Framework Class Library
PurchaseTotals Constructor
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PurchaseTotals()
Visual C++
public:
PurchaseTotals()
JavaScript
InSite.Domain.CyberSourceService.PurchaseTotals = function();

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


PurchaseTotals Methods

[image] [image]

.NET Framework Class Library
PurchaseTotals Methods
PurchaseTotals Class See Also Send Feedback

The PurchaseTotals type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
PurchaseTotals..::.RaisePropertyChanged Method
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


PurchaseTotals Properties

[image] [image]

.NET Framework Class Library
PurchaseTotals Properties
PurchaseTotals Class See Also Send Feedback

The PurchaseTotals type exposes the following members.

Properties

Name | Description
currency |
discountAmount |
dutyAmount |
exchangeRate |
exchangeRateTimeStamp |
foreignAmount |
foreignCurrency |
freightAmount |
grandTotalAmount |
taxAmount |

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
PurchaseTotals..::.currency Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


discountAmount Property

[image]

.NET Framework Class Library
PurchaseTotals..::.discountAmount Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property discountAmount As String
C#
public string discountAmount { get; set; }
Visual C++
public:
property String^ discountAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_discountAmount();
function set_discountAmount(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


dutyAmount Property

[image]

.NET Framework Class Library
PurchaseTotals..::.dutyAmount Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dutyAmount As String
C#
public string dutyAmount { get; set; }
Visual C++
public:
property String^ dutyAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dutyAmount();
function set_dutyAmount(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


exchangeRate Property

[image]

.NET Framework Class Library
PurchaseTotals..::.exchangeRate Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property exchangeRate As String
C#
public string exchangeRate { get; set; }
Visual C++
public:
property String^ exchangeRate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_exchangeRate();
function set_exchangeRate(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


exchangeRateTimeStamp Property

[image]

.NET Framework Class Library
PurchaseTotals..::.exchangeRateTimeStamp Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property exchangeRateTimeStamp As String
C#
public string exchangeRateTimeStamp { get; set; }
Visual C++
public:
property String^ exchangeRateTimeStamp {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_exchangeRateTimeStamp();
function set_exchangeRateTimeStamp(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


foreignAmount Property

[image]

.NET Framework Class Library
PurchaseTotals..::.foreignAmount Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property foreignAmount As String
C#
public string foreignAmount { get; set; }
Visual C++
public:
property String^ foreignAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_foreignAmount();
function set_foreignAmount(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


foreignCurrency Property

[image]

.NET Framework Class Library
PurchaseTotals..::.foreignCurrency Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property foreignCurrency As String
C#
public string foreignCurrency { get; set; }
Visual C++
public:
property String^ foreignCurrency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_foreignCurrency();
function set_foreignCurrency(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


freightAmount Property

[image]

.NET Framework Class Library
PurchaseTotals..::.freightAmount Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property freightAmount As String
C#
public string freightAmount { get; set; }
Visual C++
public:
property String^ freightAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_freightAmount();
function set_freightAmount(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


grandTotalAmount Property

[image]

.NET Framework Class Library
PurchaseTotals..::.grandTotalAmount Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property grandTotalAmount As String
C#
public string grandTotalAmount { get; set; }
Visual C++
public:
property String^ grandTotalAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_grandTotalAmount();
function set_grandTotalAmount(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


taxAmount Property

[image]

.NET Framework Class Library
PurchaseTotals..::.taxAmount Property
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxAmount As String
C#
public string taxAmount { get; set; }
Visual C++
public:
property String^ taxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxAmount();
function set_taxAmount(value);

Remarks

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


PurchaseTotals Events

[image] [image]

.NET Framework Class Library
PurchaseTotals Events
PurchaseTotals Class See Also Send Feedback

The PurchaseTotals type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
PurchaseTotals..::.PropertyChanged Event
PurchaseTotals Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

PurchaseTotals Class
InSite.Domain.CyberSourceService Namespace


RecurringSubscriptionInfo Class

[image]

.NET Framework Class Library
RecurringSubscriptionInfo Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class RecurringSubscriptionInfo _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class RecurringSubscriptionInfo : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class RecurringSubscriptionInfo : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.RecurringSubscriptionInfo = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.RecurringSubscriptionInfo',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.RecurringSubscriptionInfo

See Also

RecurringSubscriptionInfo Members
InSite.Domain.CyberSourceService Namespace


RecurringSubscriptionInfo Members

[image] [image]

.NET Framework Class Library
RecurringSubscriptionInfo Members
RecurringSubscriptionInfo Class Constructors Methods Properties Events See Also Send Feedback

The RecurringSubscriptionInfo type exposes the following members.

Constructors

Name | Description
RecurringSubscriptionInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
approvalRequired |
automaticRenew |
billPayment |
endDate |
event |
frequency |
numberOfPayments |
numberOfPaymentsToAdd |
startDate |
status |
subscriptionID |

Events

Name | Description
PropertyChanged |

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


RecurringSubscriptionInfo Constructor

[image]

.NET Framework Class Library
RecurringSubscriptionInfo Constructor
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RecurringSubscriptionInfo()
Visual C++
public:
RecurringSubscriptionInfo()
JavaScript
InSite.Domain.CyberSourceService.RecurringSubscriptionInfo = function();

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


RecurringSubscriptionInfo Methods

[image] [image]

.NET Framework Class Library
RecurringSubscriptionInfo Methods
RecurringSubscriptionInfo Class See Also Send Feedback

The RecurringSubscriptionInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.RaisePropertyChanged Method
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


RecurringSubscriptionInfo Properties

[image] [image]

.NET Framework Class Library
RecurringSubscriptionInfo Properties
RecurringSubscriptionInfo Class See Also Send Feedback

The RecurringSubscriptionInfo type exposes the following members.

Properties

Name | Description
amount |
approvalRequired |
automaticRenew |
billPayment |
endDate |
event |
frequency |
numberOfPayments |
numberOfPaymentsToAdd |
startDate |
status |
subscriptionID |

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.amount Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


approvalRequired Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.approvalRequired Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property approvalRequired As String
C#
public string approvalRequired { get; set; }
Visual C++
public:
property String^ approvalRequired {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_approvalRequired();
function set_approvalRequired(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


automaticRenew Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.automaticRenew Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property automaticRenew As String
C#
public string automaticRenew { get; set; }
Visual C++
public:
property String^ automaticRenew {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_automaticRenew();
function set_automaticRenew(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


billPayment Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.billPayment Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billPayment As String
C#
public string billPayment { get; set; }
Visual C++
public:
property String^ billPayment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_billPayment();
function set_billPayment(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


endDate Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.endDate Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property endDate As String
C#
public string endDate { get; set; }
Visual C++
public:
property String^ endDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_endDate();
function set_endDate(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


event Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.event Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property event As PaySubscriptionEvent
C#
public PaySubscriptionEvent event { get; set; }
Visual C++
public:
property PaySubscriptionEvent^ event {
    PaySubscriptionEvent^ get ();
    void set (PaySubscriptionEvent^ value);
}
JavaScript
function get_event();
function set_event(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


frequency Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.frequency Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property frequency As String
C#
public string frequency { get; set; }
Visual C++
public:
property String^ frequency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_frequency();
function set_frequency(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


numberOfPayments Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.numberOfPayments Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property numberOfPayments As String
C#
public string numberOfPayments { get; set; }
Visual C++
public:
property String^ numberOfPayments {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_numberOfPayments();
function set_numberOfPayments(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


numberOfPaymentsToAdd Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.numberOfPaymentsToAdd Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property numberOfPaymentsToAdd As String
C#
public string numberOfPaymentsToAdd { get; set; }
Visual C++
public:
property String^ numberOfPaymentsToAdd {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_numberOfPaymentsToAdd();
function set_numberOfPaymentsToAdd(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


startDate Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.startDate Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property startDate As String
C#
public string startDate { get; set; }
Visual C++
public:
property String^ startDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_startDate();
function set_startDate(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


status Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.status Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property status As String
C#
public string status { get; set; }
Visual C++
public:
property String^ status {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_status();
function set_status(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


subscriptionID Property

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.subscriptionID Property
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property subscriptionID As String
C#
public string subscriptionID { get; set; }
Visual C++
public:
property String^ subscriptionID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_subscriptionID();
function set_subscriptionID(value);

Remarks

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


RecurringSubscriptionInfo Events

[image] [image]

.NET Framework Class Library
RecurringSubscriptionInfo Events
RecurringSubscriptionInfo Class See Also Send Feedback

The RecurringSubscriptionInfo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
RecurringSubscriptionInfo..::.PropertyChanged Event
RecurringSubscriptionInfo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

RecurringSubscriptionInfo Class
InSite.Domain.CyberSourceService Namespace


ReplyMessage Class

[image]

.NET Framework Class Library
ReplyMessage Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ReplyMessage _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ReplyMessage : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ReplyMessage : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ReplyMessage = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ReplyMessage',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ReplyMessage

See Also

ReplyMessage Members
InSite.Domain.CyberSourceService Namespace


ReplyMessage Members

[image] [image]

.NET Framework Class Library
ReplyMessage Members
ReplyMessage Class Constructors Methods Properties Events See Also Send Feedback

The ReplyMessage type exposes the following members.

Constructors

Name | Description
ReplyMessage |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
afsReply |
bankTransferRealTimeReply |
bankTransferRefundReply |
bankTransferReply |
boletoPaymentReply |
ccAuthReply |
ccAuthReversalReply |
ccAutoAuthReversalReply |
ccCaptureReply |
ccCreditReply |
ccDCCReply |
chinaPaymentReply |
chinaRefundReply |
davReply |
decision |
decisionReply |
deniedPartiesMatch |
directDebitMandateReply |
directDebitRefundReply |
directDebitReply |
directDebitValidateReply |
ecCreditReply |
ecDebitReply |
exportReply |
fxRatesReply |
invalidField |
merchantReferenceCode |
missingField |
payerAuthEnrollReply |
payerAuthValidateReply |
payPalAuthorizationReply |
payPalAuthReversalReply |
payPalButtonCreateReply |
payPalCreditReply |
payPalDoCaptureReply |
payPalEcDoPaymentReply |
payPalEcGetDetailsReply |
payPalEcOrderSetupReply |
payPalEcSetReply |
payPalPaymentReply |
payPalPreapprovedPaymentReply |
payPalPreapprovedUpdateReply |
payPalRefundReply |
paySubscriptionCreateReply |
paySubscriptionEventUpdateReply |
paySubscriptionRetrieveReply |
paySubscriptionUpdateReply |
pinlessDebitReply |
pinlessDebitValidateReply |
purchaseTotals |
reasonCode |
requestID |
requestToken |
reserved |
riskUpdateReply |
taxReply |
voidReply |

Events

Name | Description
PropertyChanged |

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ReplyMessage Constructor

[image]

.NET Framework Class Library
ReplyMessage Constructor
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReplyMessage()
Visual C++
public:
ReplyMessage()
JavaScript
InSite.Domain.CyberSourceService.ReplyMessage = function();

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ReplyMessage Methods

[image] [image]

.NET Framework Class Library
ReplyMessage Methods
ReplyMessage Class See Also Send Feedback

The ReplyMessage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ReplyMessage..::.RaisePropertyChanged Method
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ReplyMessage Properties

[image] [image]

.NET Framework Class Library
ReplyMessage Properties
ReplyMessage Class See Also Send Feedback

The ReplyMessage type exposes the following members.

Properties

Name | Description
afsReply |
bankTransferRealTimeReply |
bankTransferRefundReply |
bankTransferReply |
boletoPaymentReply |
ccAuthReply |
ccAuthReversalReply |
ccAutoAuthReversalReply |
ccCaptureReply |
ccCreditReply |
ccDCCReply |
chinaPaymentReply |
chinaRefundReply |
davReply |
decision |
decisionReply |
deniedPartiesMatch |
directDebitMandateReply |
directDebitRefundReply |
directDebitReply |
directDebitValidateReply |
ecCreditReply |
ecDebitReply |
exportReply |
fxRatesReply |
invalidField |
merchantReferenceCode |
missingField |
payerAuthEnrollReply |
payerAuthValidateReply |
payPalAuthorizationReply |
payPalAuthReversalReply |
payPalButtonCreateReply |
payPalCreditReply |
payPalDoCaptureReply |
payPalEcDoPaymentReply |
payPalEcGetDetailsReply |
payPalEcOrderSetupReply |
payPalEcSetReply |
payPalPaymentReply |
payPalPreapprovedPaymentReply |
payPalPreapprovedUpdateReply |
payPalRefundReply |
paySubscriptionCreateReply |
paySubscriptionEventUpdateReply |
paySubscriptionRetrieveReply |
paySubscriptionUpdateReply |
pinlessDebitReply |
pinlessDebitValidateReply |
purchaseTotals |
reasonCode |
requestID |
requestToken |
reserved |
riskUpdateReply |
taxReply |
voidReply |

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


afsReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.afsReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property afsReply As AFSReply
C#
public AFSReply afsReply { get; set; }
Visual C++
public:
property AFSReply^ afsReply {
    AFSReply^ get ();
    void set (AFSReply^ value);
}
JavaScript
function get_afsReply();
function set_afsReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


bankTransferRealTimeReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.bankTransferRealTimeReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRealTimeReply As BankTransferRealTimeReply
C#
public BankTransferRealTimeReply bankTransferRealTimeReply { get; set; }
Visual C++
public:
property BankTransferRealTimeReply^ bankTransferRealTimeReply {
    BankTransferRealTimeReply^ get ();
    void set (BankTransferRealTimeReply^ value);
}
JavaScript
function get_bankTransferRealTimeReply();
function set_bankTransferRealTimeReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


bankTransferRefundReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.bankTransferRefundReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRefundReply As BankTransferRefundReply
C#
public BankTransferRefundReply bankTransferRefundReply { get; set; }
Visual C++
public:
property BankTransferRefundReply^ bankTransferRefundReply {
    BankTransferRefundReply^ get ();
    void set (BankTransferRefundReply^ value);
}
JavaScript
function get_bankTransferRefundReply();
function set_bankTransferRefundReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


bankTransferReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.bankTransferReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferReply As BankTransferReply
C#
public BankTransferReply bankTransferReply { get; set; }
Visual C++
public:
property BankTransferReply^ bankTransferReply {
    BankTransferReply^ get ();
    void set (BankTransferReply^ value);
}
JavaScript
function get_bankTransferReply();
function set_bankTransferReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


boletoPaymentReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.boletoPaymentReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property boletoPaymentReply As BoletoPaymentReply
C#
public BoletoPaymentReply boletoPaymentReply { get; set; }
Visual C++
public:
property BoletoPaymentReply^ boletoPaymentReply {
    BoletoPaymentReply^ get ();
    void set (BoletoPaymentReply^ value);
}
JavaScript
function get_boletoPaymentReply();
function set_boletoPaymentReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ccAuthReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.ccAuthReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccAuthReply As CCAuthReply
C#
public CCAuthReply ccAuthReply { get; set; }
Visual C++
public:
property CCAuthReply^ ccAuthReply {
    CCAuthReply^ get ();
    void set (CCAuthReply^ value);
}
JavaScript
function get_ccAuthReply();
function set_ccAuthReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ccAuthReversalReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.ccAuthReversalReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccAuthReversalReply As CCAuthReversalReply
C#
public CCAuthReversalReply ccAuthReversalReply { get; set; }
Visual C++
public:
property CCAuthReversalReply^ ccAuthReversalReply {
    CCAuthReversalReply^ get ();
    void set (CCAuthReversalReply^ value);
}
JavaScript
function get_ccAuthReversalReply();
function set_ccAuthReversalReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ccAutoAuthReversalReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.ccAutoAuthReversalReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccAutoAuthReversalReply As CCAutoAuthReversalReply
C#
public CCAutoAuthReversalReply ccAutoAuthReversalReply { get; set; }
Visual C++
public:
property CCAutoAuthReversalReply^ ccAutoAuthReversalReply {
    CCAutoAuthReversalReply^ get ();
    void set (CCAutoAuthReversalReply^ value);
}
JavaScript
function get_ccAutoAuthReversalReply();
function set_ccAutoAuthReversalReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ccCaptureReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.ccCaptureReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccCaptureReply As CCCaptureReply
C#
public CCCaptureReply ccCaptureReply { get; set; }
Visual C++
public:
property CCCaptureReply^ ccCaptureReply {
    CCCaptureReply^ get ();
    void set (CCCaptureReply^ value);
}
JavaScript
function get_ccCaptureReply();
function set_ccCaptureReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ccCreditReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.ccCreditReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccCreditReply As CCCreditReply
C#
public CCCreditReply ccCreditReply { get; set; }
Visual C++
public:
property CCCreditReply^ ccCreditReply {
    CCCreditReply^ get ();
    void set (CCCreditReply^ value);
}
JavaScript
function get_ccCreditReply();
function set_ccCreditReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ccDCCReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.ccDCCReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccDCCReply As CCDCCReply
C#
public CCDCCReply ccDCCReply { get; set; }
Visual C++
public:
property CCDCCReply^ ccDCCReply {
    CCDCCReply^ get ();
    void set (CCDCCReply^ value);
}
JavaScript
function get_ccDCCReply();
function set_ccDCCReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


chinaPaymentReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.chinaPaymentReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property chinaPaymentReply As ChinaPaymentReply
C#
public ChinaPaymentReply chinaPaymentReply { get; set; }
Visual C++
public:
property ChinaPaymentReply^ chinaPaymentReply {
    ChinaPaymentReply^ get ();
    void set (ChinaPaymentReply^ value);
}
JavaScript
function get_chinaPaymentReply();
function set_chinaPaymentReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


chinaRefundReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.chinaRefundReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property chinaRefundReply As ChinaRefundReply
C#
public ChinaRefundReply chinaRefundReply { get; set; }
Visual C++
public:
property ChinaRefundReply^ chinaRefundReply {
    ChinaRefundReply^ get ();
    void set (ChinaRefundReply^ value);
}
JavaScript
function get_chinaRefundReply();
function set_chinaRefundReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


davReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.davReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property davReply As DAVReply
C#
public DAVReply davReply { get; set; }
Visual C++
public:
property DAVReply^ davReply {
    DAVReply^ get ();
    void set (DAVReply^ value);
}
JavaScript
function get_davReply();
function set_davReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


decision Property

[image]

.NET Framework Class Library
ReplyMessage..::.decision Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property decision As String
C#
public string decision { get; set; }
Visual C++
public:
property String^ decision {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_decision();
function set_decision(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


decisionReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.decisionReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property decisionReply As DecisionReply
C#
public DecisionReply decisionReply { get; set; }
Visual C++
public:
property DecisionReply^ decisionReply {
    DecisionReply^ get ();
    void set (DecisionReply^ value);
}
JavaScript
function get_decisionReply();
function set_decisionReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


deniedPartiesMatch Property

[image]

.NET Framework Class Library
ReplyMessage..::.deniedPartiesMatch Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property deniedPartiesMatch As DeniedPartiesMatch()
C#
public DeniedPartiesMatch[] deniedPartiesMatch { get; set; }
Visual C++
public:
property array<DeniedPartiesMatch^>^ deniedPartiesMatch {
    array<DeniedPartiesMatch^>^ get ();
    void set (array<DeniedPartiesMatch^>^ value);
}
JavaScript
function get_deniedPartiesMatch();
function set_deniedPartiesMatch(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


directDebitMandateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.directDebitMandateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitMandateReply As DirectDebitMandateReply
C#
public DirectDebitMandateReply directDebitMandateReply { get; set; }
Visual C++
public:
property DirectDebitMandateReply^ directDebitMandateReply {
    DirectDebitMandateReply^ get ();
    void set (DirectDebitMandateReply^ value);
}
JavaScript
function get_directDebitMandateReply();
function set_directDebitMandateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


directDebitRefundReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.directDebitRefundReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitRefundReply As DirectDebitRefundReply
C#
public DirectDebitRefundReply directDebitRefundReply { get; set; }
Visual C++
public:
property DirectDebitRefundReply^ directDebitRefundReply {
    DirectDebitRefundReply^ get ();
    void set (DirectDebitRefundReply^ value);
}
JavaScript
function get_directDebitRefundReply();
function set_directDebitRefundReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


directDebitReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.directDebitReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitReply As DirectDebitReply
C#
public DirectDebitReply directDebitReply { get; set; }
Visual C++
public:
property DirectDebitReply^ directDebitReply {
    DirectDebitReply^ get ();
    void set (DirectDebitReply^ value);
}
JavaScript
function get_directDebitReply();
function set_directDebitReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


directDebitValidateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.directDebitValidateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitValidateReply As DirectDebitValidateReply
C#
public DirectDebitValidateReply directDebitValidateReply { get; set; }
Visual C++
public:
property DirectDebitValidateReply^ directDebitValidateReply {
    DirectDebitValidateReply^ get ();
    void set (DirectDebitValidateReply^ value);
}
JavaScript
function get_directDebitValidateReply();
function set_directDebitValidateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ecCreditReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.ecCreditReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ecCreditReply As ECCreditReply
C#
public ECCreditReply ecCreditReply { get; set; }
Visual C++
public:
property ECCreditReply^ ecCreditReply {
    ECCreditReply^ get ();
    void set (ECCreditReply^ value);
}
JavaScript
function get_ecCreditReply();
function set_ecCreditReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ecDebitReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.ecDebitReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ecDebitReply As ECDebitReply
C#
public ECDebitReply ecDebitReply { get; set; }
Visual C++
public:
property ECDebitReply^ ecDebitReply {
    ECDebitReply^ get ();
    void set (ECDebitReply^ value);
}
JavaScript
function get_ecDebitReply();
function set_ecDebitReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


exportReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.exportReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property exportReply As ExportReply
C#
public ExportReply exportReply { get; set; }
Visual C++
public:
property ExportReply^ exportReply {
    ExportReply^ get ();
    void set (ExportReply^ value);
}
JavaScript
function get_exportReply();
function set_exportReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


fxRatesReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.fxRatesReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxRatesReply As FXRatesReply
C#
public FXRatesReply fxRatesReply { get; set; }
Visual C++
public:
property FXRatesReply^ fxRatesReply {
    FXRatesReply^ get ();
    void set (FXRatesReply^ value);
}
JavaScript
function get_fxRatesReply();
function set_fxRatesReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


invalidField Property

[image]

.NET Framework Class Library
ReplyMessage..::.invalidField Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invalidField As String()
C#
public string[] invalidField { get; set; }
Visual C++
public:
property array<String^>^ invalidField {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_invalidField();
function set_invalidField(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


merchantReferenceCode Property

[image]

.NET Framework Class Library
ReplyMessage..::.merchantReferenceCode Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantReferenceCode As String
C#
public string merchantReferenceCode { get; set; }
Visual C++
public:
property String^ merchantReferenceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantReferenceCode();
function set_merchantReferenceCode(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


missingField Property

[image]

.NET Framework Class Library
ReplyMessage..::.missingField Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property missingField As String()
C#
public string[] missingField { get; set; }
Visual C++
public:
property array<String^>^ missingField {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_missingField();
function set_missingField(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payerAuthEnrollReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payerAuthEnrollReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerAuthEnrollReply As PayerAuthEnrollReply
C#
public PayerAuthEnrollReply payerAuthEnrollReply { get; set; }
Visual C++
public:
property PayerAuthEnrollReply^ payerAuthEnrollReply {
    PayerAuthEnrollReply^ get ();
    void set (PayerAuthEnrollReply^ value);
}
JavaScript
function get_payerAuthEnrollReply();
function set_payerAuthEnrollReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payerAuthValidateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payerAuthValidateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerAuthValidateReply As PayerAuthValidateReply
C#
public PayerAuthValidateReply payerAuthValidateReply { get; set; }
Visual C++
public:
property PayerAuthValidateReply^ payerAuthValidateReply {
    PayerAuthValidateReply^ get ();
    void set (PayerAuthValidateReply^ value);
}
JavaScript
function get_payerAuthValidateReply();
function set_payerAuthValidateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalAuthorizationReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalAuthorizationReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalAuthorizationReply As PayPalAuthorizationReply
C#
public PayPalAuthorizationReply payPalAuthorizationReply { get; set; }
Visual C++
public:
property PayPalAuthorizationReply^ payPalAuthorizationReply {
    PayPalAuthorizationReply^ get ();
    void set (PayPalAuthorizationReply^ value);
}
JavaScript
function get_payPalAuthorizationReply();
function set_payPalAuthorizationReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalAuthReversalReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalAuthReversalReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalAuthReversalReply As PayPalAuthReversalReply
C#
public PayPalAuthReversalReply payPalAuthReversalReply { get; set; }
Visual C++
public:
property PayPalAuthReversalReply^ payPalAuthReversalReply {
    PayPalAuthReversalReply^ get ();
    void set (PayPalAuthReversalReply^ value);
}
JavaScript
function get_payPalAuthReversalReply();
function set_payPalAuthReversalReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalButtonCreateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalButtonCreateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalButtonCreateReply As PayPalButtonCreateReply
C#
public PayPalButtonCreateReply payPalButtonCreateReply { get; set; }
Visual C++
public:
property PayPalButtonCreateReply^ payPalButtonCreateReply {
    PayPalButtonCreateReply^ get ();
    void set (PayPalButtonCreateReply^ value);
}
JavaScript
function get_payPalButtonCreateReply();
function set_payPalButtonCreateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalCreditReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalCreditReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalCreditReply As PayPalCreditReply
C#
public PayPalCreditReply payPalCreditReply { get; set; }
Visual C++
public:
property PayPalCreditReply^ payPalCreditReply {
    PayPalCreditReply^ get ();
    void set (PayPalCreditReply^ value);
}
JavaScript
function get_payPalCreditReply();
function set_payPalCreditReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalDoCaptureReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalDoCaptureReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalDoCaptureReply As PayPalDoCaptureReply
C#
public PayPalDoCaptureReply payPalDoCaptureReply { get; set; }
Visual C++
public:
property PayPalDoCaptureReply^ payPalDoCaptureReply {
    PayPalDoCaptureReply^ get ();
    void set (PayPalDoCaptureReply^ value);
}
JavaScript
function get_payPalDoCaptureReply();
function set_payPalDoCaptureReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalEcDoPaymentReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalEcDoPaymentReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalEcDoPaymentReply As PayPalEcDoPaymentReply
C#
public PayPalEcDoPaymentReply payPalEcDoPaymentReply { get; set; }
Visual C++
public:
property PayPalEcDoPaymentReply^ payPalEcDoPaymentReply {
    PayPalEcDoPaymentReply^ get ();
    void set (PayPalEcDoPaymentReply^ value);
}
JavaScript
function get_payPalEcDoPaymentReply();
function set_payPalEcDoPaymentReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalEcGetDetailsReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalEcGetDetailsReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalEcGetDetailsReply As PayPalEcGetDetailsReply
C#
public PayPalEcGetDetailsReply payPalEcGetDetailsReply { get; set; }
Visual C++
public:
property PayPalEcGetDetailsReply^ payPalEcGetDetailsReply {
    PayPalEcGetDetailsReply^ get ();
    void set (PayPalEcGetDetailsReply^ value);
}
JavaScript
function get_payPalEcGetDetailsReply();
function set_payPalEcGetDetailsReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalEcOrderSetupReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalEcOrderSetupReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalEcOrderSetupReply As PayPalEcOrderSetupReply
C#
public PayPalEcOrderSetupReply payPalEcOrderSetupReply { get; set; }
Visual C++
public:
property PayPalEcOrderSetupReply^ payPalEcOrderSetupReply {
    PayPalEcOrderSetupReply^ get ();
    void set (PayPalEcOrderSetupReply^ value);
}
JavaScript
function get_payPalEcOrderSetupReply();
function set_payPalEcOrderSetupReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalEcSetReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalEcSetReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalEcSetReply As PayPalEcSetReply
C#
public PayPalEcSetReply payPalEcSetReply { get; set; }
Visual C++
public:
property PayPalEcSetReply^ payPalEcSetReply {
    PayPalEcSetReply^ get ();
    void set (PayPalEcSetReply^ value);
}
JavaScript
function get_payPalEcSetReply();
function set_payPalEcSetReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalPaymentReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalPaymentReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalPaymentReply As PayPalPaymentReply
C#
public PayPalPaymentReply payPalPaymentReply { get; set; }
Visual C++
public:
property PayPalPaymentReply^ payPalPaymentReply {
    PayPalPaymentReply^ get ();
    void set (PayPalPaymentReply^ value);
}
JavaScript
function get_payPalPaymentReply();
function set_payPalPaymentReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalPreapprovedPaymentReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalPreapprovedPaymentReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalPreapprovedPaymentReply As PayPalPreapprovedPaymentReply
C#
public PayPalPreapprovedPaymentReply payPalPreapprovedPaymentReply { get; set; }
Visual C++
public:
property PayPalPreapprovedPaymentReply^ payPalPreapprovedPaymentReply {
    PayPalPreapprovedPaymentReply^ get ();
    void set (PayPalPreapprovedPaymentReply^ value);
}
JavaScript
function get_payPalPreapprovedPaymentReply();
function set_payPalPreapprovedPaymentReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalPreapprovedUpdateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalPreapprovedUpdateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalPreapprovedUpdateReply As PayPalPreapprovedUpdateReply
C#
public PayPalPreapprovedUpdateReply payPalPreapprovedUpdateReply { get; set; }
Visual C++
public:
property PayPalPreapprovedUpdateReply^ payPalPreapprovedUpdateReply {
    PayPalPreapprovedUpdateReply^ get ();
    void set (PayPalPreapprovedUpdateReply^ value);
}
JavaScript
function get_payPalPreapprovedUpdateReply();
function set_payPalPreapprovedUpdateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


payPalRefundReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.payPalRefundReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalRefundReply As PayPalRefundReply
C#
public PayPalRefundReply payPalRefundReply { get; set; }
Visual C++
public:
property PayPalRefundReply^ payPalRefundReply {
    PayPalRefundReply^ get ();
    void set (PayPalRefundReply^ value);
}
JavaScript
function get_payPalRefundReply();
function set_payPalRefundReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


paySubscriptionCreateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.paySubscriptionCreateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paySubscriptionCreateReply As PaySubscriptionCreateReply
C#
public PaySubscriptionCreateReply paySubscriptionCreateReply { get; set; }
Visual C++
public:
property PaySubscriptionCreateReply^ paySubscriptionCreateReply {
    PaySubscriptionCreateReply^ get ();
    void set (PaySubscriptionCreateReply^ value);
}
JavaScript
function get_paySubscriptionCreateReply();
function set_paySubscriptionCreateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


paySubscriptionEventUpdateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.paySubscriptionEventUpdateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paySubscriptionEventUpdateReply As PaySubscriptionEventUpdateReply
C#
public PaySubscriptionEventUpdateReply paySubscriptionEventUpdateReply { get; set; }
Visual C++
public:
property PaySubscriptionEventUpdateReply^ paySubscriptionEventUpdateReply {
    PaySubscriptionEventUpdateReply^ get ();
    void set (PaySubscriptionEventUpdateReply^ value);
}
JavaScript
function get_paySubscriptionEventUpdateReply();
function set_paySubscriptionEventUpdateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


paySubscriptionRetrieveReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.paySubscriptionRetrieveReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paySubscriptionRetrieveReply As PaySubscriptionRetrieveReply
C#
public PaySubscriptionRetrieveReply paySubscriptionRetrieveReply { get; set; }
Visual C++
public:
property PaySubscriptionRetrieveReply^ paySubscriptionRetrieveReply {
    PaySubscriptionRetrieveReply^ get ();
    void set (PaySubscriptionRetrieveReply^ value);
}
JavaScript
function get_paySubscriptionRetrieveReply();
function set_paySubscriptionRetrieveReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


paySubscriptionUpdateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.paySubscriptionUpdateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paySubscriptionUpdateReply As PaySubscriptionUpdateReply
C#
public PaySubscriptionUpdateReply paySubscriptionUpdateReply { get; set; }
Visual C++
public:
property PaySubscriptionUpdateReply^ paySubscriptionUpdateReply {
    PaySubscriptionUpdateReply^ get ();
    void set (PaySubscriptionUpdateReply^ value);
}
JavaScript
function get_paySubscriptionUpdateReply();
function set_paySubscriptionUpdateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


pinlessDebitReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.pinlessDebitReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pinlessDebitReply As PinlessDebitReply
C#
public PinlessDebitReply pinlessDebitReply { get; set; }
Visual C++
public:
property PinlessDebitReply^ pinlessDebitReply {
    PinlessDebitReply^ get ();
    void set (PinlessDebitReply^ value);
}
JavaScript
function get_pinlessDebitReply();
function set_pinlessDebitReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


pinlessDebitValidateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.pinlessDebitValidateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pinlessDebitValidateReply As PinlessDebitValidateReply
C#
public PinlessDebitValidateReply pinlessDebitValidateReply { get; set; }
Visual C++
public:
property PinlessDebitValidateReply^ pinlessDebitValidateReply {
    PinlessDebitValidateReply^ get ();
    void set (PinlessDebitValidateReply^ value);
}
JavaScript
function get_pinlessDebitValidateReply();
function set_pinlessDebitValidateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


purchaseTotals Property

[image]

.NET Framework Class Library
ReplyMessage..::.purchaseTotals Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchaseTotals As PurchaseTotals
C#
public PurchaseTotals purchaseTotals { get; set; }
Visual C++
public:
property PurchaseTotals^ purchaseTotals {
    PurchaseTotals^ get ();
    void set (PurchaseTotals^ value);
}
JavaScript
function get_purchaseTotals();
function set_purchaseTotals(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
ReplyMessage..::.reasonCode Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


requestID Property

[image]

.NET Framework Class Library
ReplyMessage..::.requestID Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestID As String
C#
public string requestID { get; set; }
Visual C++
public:
property String^ requestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestID();
function set_requestID(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


requestToken Property

[image]

.NET Framework Class Library
ReplyMessage..::.requestToken Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestToken As String
C#
public string requestToken { get; set; }
Visual C++
public:
property String^ requestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestToken();
function set_requestToken(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


reserved Property

[image]

.NET Framework Class Library
ReplyMessage..::.reserved Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reserved As XmlElement
C#
public XmlElement reserved { get; set; }
Visual C++
public:
property XmlElement^ reserved {
    XmlElement^ get ();
    void set (XmlElement^ value);
}
JavaScript
function get_reserved();
function set_reserved(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


riskUpdateReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.riskUpdateReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property riskUpdateReply As RiskUpdateReply
C#
public RiskUpdateReply riskUpdateReply { get; set; }
Visual C++
public:
property RiskUpdateReply^ riskUpdateReply {
    RiskUpdateReply^ get ();
    void set (RiskUpdateReply^ value);
}
JavaScript
function get_riskUpdateReply();
function set_riskUpdateReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


taxReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.taxReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxReply As TaxReply
C#
public TaxReply taxReply { get; set; }
Visual C++
public:
property TaxReply^ taxReply {
    TaxReply^ get ();
    void set (TaxReply^ value);
}
JavaScript
function get_taxReply();
function set_taxReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


voidReply Property

[image]

.NET Framework Class Library
ReplyMessage..::.voidReply Property
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property voidReply As VoidReply
C#
public VoidReply voidReply { get; set; }
Visual C++
public:
property VoidReply^ voidReply {
    VoidReply^ get ();
    void set (VoidReply^ value);
}
JavaScript
function get_voidReply();
function set_voidReply(value);

Remarks

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


ReplyMessage Events

[image] [image]

.NET Framework Class Library
ReplyMessage Events
ReplyMessage Class See Also Send Feedback

The ReplyMessage type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ReplyMessage..::.PropertyChanged Event
ReplyMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ReplyMessage Class
InSite.Domain.CyberSourceService Namespace


RequestMessage Class

[image]

.NET Framework Class Library
RequestMessage Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class RequestMessage _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class RequestMessage : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class RequestMessage : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.RequestMessage = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.RequestMessage',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.RequestMessage

See Also

RequestMessage Members
InSite.Domain.CyberSourceService Namespace


RequestMessage Members

[image] [image]

.NET Framework Class Library
RequestMessage Members
RequestMessage Class Constructors Methods Properties Events See Also Send Feedback

The RequestMessage type exposes the following members.

Constructors

Name | Description
RequestMessage |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
afsService |
airlineData |
bankInfo |
bankTransferRealTimeService |
bankTransferRefundService |
bankTransferService |
batch |
billTo |
bml |
boletoPaymentService |
businessRules |
card |
ccAuthReversalService |
ccAuthService |
ccAutoAuthReversalService |
ccCaptureService |
ccCreditService |
ccDCCService |
check |
chinaPaymentService |
chinaRefundService |
clientApplication |
clientApplicationUser |
clientApplicationVersion |
clientEnvironment |
clientLibrary |
clientLibraryVersion |
clientSecurityLibraryVersion |
comments |
davService |
dcc |
debtIndicator |
decisionManager |
deviceFingerprintID |
directDebitMandateService |
directDebitRefundService |
directDebitService |
directDebitValidateService |
ecCreditService |
ecDebitService |
exportService |
fundingTotals |
fundTransfer |
fxRatesService |
gecc |
installment |
invoiceHeader |
item |
jpo |
merchantDefinedData |
merchantID |
merchantReferenceCode |
merchantSecureData |
orderRequestToken |
otherTax |
payerAuthEnrollService |
payerAuthValidateService |
paypal |
payPalAuthorizationService |
payPalAuthReversalService |
payPalButtonCreateService |
payPalCreditService |
payPalDoCaptureService |
payPalEcDoPaymentService |
payPalEcGetDetailsService |
payPalEcOrderSetupService |
payPalEcSetService |
payPalPaymentService |
payPalPreapprovedPaymentService |
payPalPreapprovedUpdateService |
payPalRefundService |
paySubscriptionCreateService |
paySubscriptionEventUpdateService |
paySubscriptionRetrieveService |
paySubscriptionUpdateService |
pinlessDebitService |
pinlessDebitValidateService |
pos |
purchaseTotals |
recurringSubscriptionInfo |
reserved |
riskUpdateService |
routingCode |
shipFrom |
shipTo |
subscription |
taxService |
ucaf |
voidService |

Events

Name | Description
PropertyChanged |

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


RequestMessage Constructor

[image]

.NET Framework Class Library
RequestMessage Constructor
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RequestMessage()
Visual C++
public:
RequestMessage()
JavaScript
InSite.Domain.CyberSourceService.RequestMessage = function();

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


RequestMessage Methods

[image] [image]

.NET Framework Class Library
RequestMessage Methods
RequestMessage Class See Also Send Feedback

The RequestMessage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
RequestMessage..::.RaisePropertyChanged Method
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


RequestMessage Properties

[image] [image]

.NET Framework Class Library
RequestMessage Properties
RequestMessage Class See Also Send Feedback

The RequestMessage type exposes the following members.

Properties

Name | Description
afsService |
airlineData |
bankInfo |
bankTransferRealTimeService |
bankTransferRefundService |
bankTransferService |
batch |
billTo |
bml |
boletoPaymentService |
businessRules |
card |
ccAuthReversalService |
ccAuthService |
ccAutoAuthReversalService |
ccCaptureService |
ccCreditService |
ccDCCService |
check |
chinaPaymentService |
chinaRefundService |
clientApplication |
clientApplicationUser |
clientApplicationVersion |
clientEnvironment |
clientLibrary |
clientLibraryVersion |
clientSecurityLibraryVersion |
comments |
davService |
dcc |
debtIndicator |
decisionManager |
deviceFingerprintID |
directDebitMandateService |
directDebitRefundService |
directDebitService |
directDebitValidateService |
ecCreditService |
ecDebitService |
exportService |
fundingTotals |
fundTransfer |
fxRatesService |
gecc |
installment |
invoiceHeader |
item |
jpo |
merchantDefinedData |
merchantID |
merchantReferenceCode |
merchantSecureData |
orderRequestToken |
otherTax |
payerAuthEnrollService |
payerAuthValidateService |
paypal |
payPalAuthorizationService |
payPalAuthReversalService |
payPalButtonCreateService |
payPalCreditService |
payPalDoCaptureService |
payPalEcDoPaymentService |
payPalEcGetDetailsService |
payPalEcOrderSetupService |
payPalEcSetService |
payPalPaymentService |
payPalPreapprovedPaymentService |
payPalPreapprovedUpdateService |
payPalRefundService |
paySubscriptionCreateService |
paySubscriptionEventUpdateService |
paySubscriptionRetrieveService |
paySubscriptionUpdateService |
pinlessDebitService |
pinlessDebitValidateService |
pos |
purchaseTotals |
recurringSubscriptionInfo |
reserved |
riskUpdateService |
routingCode |
shipFrom |
shipTo |
subscription |
taxService |
ucaf |
voidService |

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


afsService Property

[image]

.NET Framework Class Library
RequestMessage..::.afsService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property afsService As AFSService
C#
public AFSService afsService { get; set; }
Visual C++
public:
property AFSService^ afsService {
    AFSService^ get ();
    void set (AFSService^ value);
}
JavaScript
function get_afsService();
function set_afsService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


airlineData Property

[image]

.NET Framework Class Library
RequestMessage..::.airlineData Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property airlineData As AirlineData
C#
public AirlineData airlineData { get; set; }
Visual C++
public:
property AirlineData^ airlineData {
    AirlineData^ get ();
    void set (AirlineData^ value);
}
JavaScript
function get_airlineData();
function set_airlineData(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


bankInfo Property

[image]

.NET Framework Class Library
RequestMessage..::.bankInfo Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankInfo As BankInfo
C#
public BankInfo bankInfo { get; set; }
Visual C++
public:
property BankInfo^ bankInfo {
    BankInfo^ get ();
    void set (BankInfo^ value);
}
JavaScript
function get_bankInfo();
function set_bankInfo(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


bankTransferRealTimeService Property

[image]

.NET Framework Class Library
RequestMessage..::.bankTransferRealTimeService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRealTimeService As BankTransferRealTimeService
C#
public BankTransferRealTimeService bankTransferRealTimeService { get; set; }
Visual C++
public:
property BankTransferRealTimeService^ bankTransferRealTimeService {
    BankTransferRealTimeService^ get ();
    void set (BankTransferRealTimeService^ value);
}
JavaScript
function get_bankTransferRealTimeService();
function set_bankTransferRealTimeService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


bankTransferRefundService Property

[image]

.NET Framework Class Library
RequestMessage..::.bankTransferRefundService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferRefundService As BankTransferRefundService
C#
public BankTransferRefundService bankTransferRefundService { get; set; }
Visual C++
public:
property BankTransferRefundService^ bankTransferRefundService {
    BankTransferRefundService^ get ();
    void set (BankTransferRefundService^ value);
}
JavaScript
function get_bankTransferRefundService();
function set_bankTransferRefundService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


bankTransferService Property

[image]

.NET Framework Class Library
RequestMessage..::.bankTransferService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bankTransferService As BankTransferService
C#
public BankTransferService bankTransferService { get; set; }
Visual C++
public:
property BankTransferService^ bankTransferService {
    BankTransferService^ get ();
    void set (BankTransferService^ value);
}
JavaScript
function get_bankTransferService();
function set_bankTransferService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


batch Property

[image]

.NET Framework Class Library
RequestMessage..::.batch Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property batch As Batch
C#
public Batch batch { get; set; }
Visual C++
public:
property Batch^ batch {
    Batch^ get ();
    void set (Batch^ value);
}
JavaScript
function get_batch();
function set_batch(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


billTo Property

[image]

.NET Framework Class Library
RequestMessage..::.billTo Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property billTo As BillTo
C#
public BillTo billTo { get; set; }
Visual C++
public:
property BillTo^ billTo {
    BillTo^ get ();
    void set (BillTo^ value);
}
JavaScript
function get_billTo();
function set_billTo(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


bml Property

[image]

.NET Framework Class Library
RequestMessage..::.bml Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property bml As BML
C#
public BML bml { get; set; }
Visual C++
public:
property BML^ bml {
    BML^ get ();
    void set (BML^ value);
}
JavaScript
function get_bml();
function set_bml(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


boletoPaymentService Property

[image]

.NET Framework Class Library
RequestMessage..::.boletoPaymentService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property boletoPaymentService As BoletoPaymentService
C#
public BoletoPaymentService boletoPaymentService { get; set; }
Visual C++
public:
property BoletoPaymentService^ boletoPaymentService {
    BoletoPaymentService^ get ();
    void set (BoletoPaymentService^ value);
}
JavaScript
function get_boletoPaymentService();
function set_boletoPaymentService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


businessRules Property

[image]

.NET Framework Class Library
RequestMessage..::.businessRules Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property businessRules As BusinessRules
C#
public BusinessRules businessRules { get; set; }
Visual C++
public:
property BusinessRules^ businessRules {
    BusinessRules^ get ();
    void set (BusinessRules^ value);
}
JavaScript
function get_businessRules();
function set_businessRules(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


card Property

[image]

.NET Framework Class Library
RequestMessage..::.card Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property card As Card
C#
public Card card { get; set; }
Visual C++
public:
property Card^ card {
    Card^ get ();
    void set (Card^ value);
}
JavaScript
function get_card();
function set_card(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ccAuthReversalService Property

[image]

.NET Framework Class Library
RequestMessage..::.ccAuthReversalService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccAuthReversalService As CCAuthReversalService
C#
public CCAuthReversalService ccAuthReversalService { get; set; }
Visual C++
public:
property CCAuthReversalService^ ccAuthReversalService {
    CCAuthReversalService^ get ();
    void set (CCAuthReversalService^ value);
}
JavaScript
function get_ccAuthReversalService();
function set_ccAuthReversalService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ccAuthService Property

[image]

.NET Framework Class Library
RequestMessage..::.ccAuthService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccAuthService As CCAuthService
C#
public CCAuthService ccAuthService { get; set; }
Visual C++
public:
property CCAuthService^ ccAuthService {
    CCAuthService^ get ();
    void set (CCAuthService^ value);
}
JavaScript
function get_ccAuthService();
function set_ccAuthService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ccAutoAuthReversalService Property

[image]

.NET Framework Class Library
RequestMessage..::.ccAutoAuthReversalService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccAutoAuthReversalService As CCAutoAuthReversalService
C#
public CCAutoAuthReversalService ccAutoAuthReversalService { get; set; }
Visual C++
public:
property CCAutoAuthReversalService^ ccAutoAuthReversalService {
    CCAutoAuthReversalService^ get ();
    void set (CCAutoAuthReversalService^ value);
}
JavaScript
function get_ccAutoAuthReversalService();
function set_ccAutoAuthReversalService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ccCaptureService Property

[image]

.NET Framework Class Library
RequestMessage..::.ccCaptureService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccCaptureService As CCCaptureService
C#
public CCCaptureService ccCaptureService { get; set; }
Visual C++
public:
property CCCaptureService^ ccCaptureService {
    CCCaptureService^ get ();
    void set (CCCaptureService^ value);
}
JavaScript
function get_ccCaptureService();
function set_ccCaptureService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ccCreditService Property

[image]

.NET Framework Class Library
RequestMessage..::.ccCreditService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccCreditService As CCCreditService
C#
public CCCreditService ccCreditService { get; set; }
Visual C++
public:
property CCCreditService^ ccCreditService {
    CCCreditService^ get ();
    void set (CCCreditService^ value);
}
JavaScript
function get_ccCreditService();
function set_ccCreditService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ccDCCService Property

[image]

.NET Framework Class Library
RequestMessage..::.ccDCCService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ccDCCService As CCDCCService
C#
public CCDCCService ccDCCService { get; set; }
Visual C++
public:
property CCDCCService^ ccDCCService {
    CCDCCService^ get ();
    void set (CCDCCService^ value);
}
JavaScript
function get_ccDCCService();
function set_ccDCCService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


check Property

[image]

.NET Framework Class Library
RequestMessage..::.check Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property check As Check
C#
public Check check { get; set; }
Visual C++
public:
property Check^ check {
    Check^ get ();
    void set (Check^ value);
}
JavaScript
function get_check();
function set_check(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


chinaPaymentService Property

[image]

.NET Framework Class Library
RequestMessage..::.chinaPaymentService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property chinaPaymentService As ChinaPaymentService
C#
public ChinaPaymentService chinaPaymentService { get; set; }
Visual C++
public:
property ChinaPaymentService^ chinaPaymentService {
    ChinaPaymentService^ get ();
    void set (ChinaPaymentService^ value);
}
JavaScript
function get_chinaPaymentService();
function set_chinaPaymentService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


chinaRefundService Property

[image]

.NET Framework Class Library
RequestMessage..::.chinaRefundService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property chinaRefundService As ChinaRefundService
C#
public ChinaRefundService chinaRefundService { get; set; }
Visual C++
public:
property ChinaRefundService^ chinaRefundService {
    ChinaRefundService^ get ();
    void set (ChinaRefundService^ value);
}
JavaScript
function get_chinaRefundService();
function set_chinaRefundService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


clientApplication Property

[image]

.NET Framework Class Library
RequestMessage..::.clientApplication Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clientApplication As String
C#
public string clientApplication { get; set; }
Visual C++
public:
property String^ clientApplication {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientApplication();
function set_clientApplication(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


clientApplicationUser Property

[image]

.NET Framework Class Library
RequestMessage..::.clientApplicationUser Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clientApplicationUser As String
C#
public string clientApplicationUser { get; set; }
Visual C++
public:
property String^ clientApplicationUser {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientApplicationUser();
function set_clientApplicationUser(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


clientApplicationVersion Property

[image]

.NET Framework Class Library
RequestMessage..::.clientApplicationVersion Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clientApplicationVersion As String
C#
public string clientApplicationVersion { get; set; }
Visual C++
public:
property String^ clientApplicationVersion {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientApplicationVersion();
function set_clientApplicationVersion(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


clientEnvironment Property

[image]

.NET Framework Class Library
RequestMessage..::.clientEnvironment Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clientEnvironment As String
C#
public string clientEnvironment { get; set; }
Visual C++
public:
property String^ clientEnvironment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientEnvironment();
function set_clientEnvironment(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


clientLibrary Property

[image]

.NET Framework Class Library
RequestMessage..::.clientLibrary Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clientLibrary As String
C#
public string clientLibrary { get; set; }
Visual C++
public:
property String^ clientLibrary {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientLibrary();
function set_clientLibrary(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


clientLibraryVersion Property

[image]

.NET Framework Class Library
RequestMessage..::.clientLibraryVersion Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clientLibraryVersion As String
C#
public string clientLibraryVersion { get; set; }
Visual C++
public:
property String^ clientLibraryVersion {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientLibraryVersion();
function set_clientLibraryVersion(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


clientSecurityLibraryVersion Property

[image]

.NET Framework Class Library
RequestMessage..::.clientSecurityLibraryVersion Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property clientSecurityLibraryVersion As String
C#
public string clientSecurityLibraryVersion { get; set; }
Visual C++
public:
property String^ clientSecurityLibraryVersion {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientSecurityLibraryVersion();
function set_clientSecurityLibraryVersion(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


comments Property

[image]

.NET Framework Class Library
RequestMessage..::.comments Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property comments As String
C#
public string comments { get; set; }
Visual C++
public:
property String^ comments {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_comments();
function set_comments(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


davService Property

[image]

.NET Framework Class Library
RequestMessage..::.davService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property davService As DAVService
C#
public DAVService davService { get; set; }
Visual C++
public:
property DAVService^ davService {
    DAVService^ get ();
    void set (DAVService^ value);
}
JavaScript
function get_davService();
function set_davService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


dcc Property

[image]

.NET Framework Class Library
RequestMessage..::.dcc Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property dcc As DCC
C#
public DCC dcc { get; set; }
Visual C++
public:
property DCC^ dcc {
    DCC^ get ();
    void set (DCC^ value);
}
JavaScript
function get_dcc();
function set_dcc(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


debtIndicator Property

[image]

.NET Framework Class Library
RequestMessage..::.debtIndicator Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property debtIndicator As String
C#
public string debtIndicator { get; set; }
Visual C++
public:
property String^ debtIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_debtIndicator();
function set_debtIndicator(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


decisionManager Property

[image]

.NET Framework Class Library
RequestMessage..::.decisionManager Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property decisionManager As DecisionManager
C#
public DecisionManager decisionManager { get; set; }
Visual C++
public:
property DecisionManager^ decisionManager {
    DecisionManager^ get ();
    void set (DecisionManager^ value);
}
JavaScript
function get_decisionManager();
function set_decisionManager(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


deviceFingerprintID Property

[image]

.NET Framework Class Library
RequestMessage..::.deviceFingerprintID Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property deviceFingerprintID As String
C#
public string deviceFingerprintID { get; set; }
Visual C++
public:
property String^ deviceFingerprintID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_deviceFingerprintID();
function set_deviceFingerprintID(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


directDebitMandateService Property

[image]

.NET Framework Class Library
RequestMessage..::.directDebitMandateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitMandateService As DirectDebitMandateService
C#
public DirectDebitMandateService directDebitMandateService { get; set; }
Visual C++
public:
property DirectDebitMandateService^ directDebitMandateService {
    DirectDebitMandateService^ get ();
    void set (DirectDebitMandateService^ value);
}
JavaScript
function get_directDebitMandateService();
function set_directDebitMandateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


directDebitRefundService Property

[image]

.NET Framework Class Library
RequestMessage..::.directDebitRefundService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitRefundService As DirectDebitRefundService
C#
public DirectDebitRefundService directDebitRefundService { get; set; }
Visual C++
public:
property DirectDebitRefundService^ directDebitRefundService {
    DirectDebitRefundService^ get ();
    void set (DirectDebitRefundService^ value);
}
JavaScript
function get_directDebitRefundService();
function set_directDebitRefundService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


directDebitService Property

[image]

.NET Framework Class Library
RequestMessage..::.directDebitService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitService As DirectDebitService
C#
public DirectDebitService directDebitService { get; set; }
Visual C++
public:
property DirectDebitService^ directDebitService {
    DirectDebitService^ get ();
    void set (DirectDebitService^ value);
}
JavaScript
function get_directDebitService();
function set_directDebitService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


directDebitValidateService Property

[image]

.NET Framework Class Library
RequestMessage..::.directDebitValidateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property directDebitValidateService As DirectDebitValidateService
C#
public DirectDebitValidateService directDebitValidateService { get; set; }
Visual C++
public:
property DirectDebitValidateService^ directDebitValidateService {
    DirectDebitValidateService^ get ();
    void set (DirectDebitValidateService^ value);
}
JavaScript
function get_directDebitValidateService();
function set_directDebitValidateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ecCreditService Property

[image]

.NET Framework Class Library
RequestMessage..::.ecCreditService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ecCreditService As ECCreditService
C#
public ECCreditService ecCreditService { get; set; }
Visual C++
public:
property ECCreditService^ ecCreditService {
    ECCreditService^ get ();
    void set (ECCreditService^ value);
}
JavaScript
function get_ecCreditService();
function set_ecCreditService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ecDebitService Property

[image]

.NET Framework Class Library
RequestMessage..::.ecDebitService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ecDebitService As ECDebitService
C#
public ECDebitService ecDebitService { get; set; }
Visual C++
public:
property ECDebitService^ ecDebitService {
    ECDebitService^ get ();
    void set (ECDebitService^ value);
}
JavaScript
function get_ecDebitService();
function set_ecDebitService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


exportService Property

[image]

.NET Framework Class Library
RequestMessage..::.exportService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property exportService As ExportService
C#
public ExportService exportService { get; set; }
Visual C++
public:
property ExportService^ exportService {
    ExportService^ get ();
    void set (ExportService^ value);
}
JavaScript
function get_exportService();
function set_exportService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


fundingTotals Property

[image]

.NET Framework Class Library
RequestMessage..::.fundingTotals Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fundingTotals As FundingTotals
C#
public FundingTotals fundingTotals { get; set; }
Visual C++
public:
property FundingTotals^ fundingTotals {
    FundingTotals^ get ();
    void set (FundingTotals^ value);
}
JavaScript
function get_fundingTotals();
function set_fundingTotals(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


fundTransfer Property

[image]

.NET Framework Class Library
RequestMessage..::.fundTransfer Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fundTransfer As FundTransfer
C#
public FundTransfer fundTransfer { get; set; }
Visual C++
public:
property FundTransfer^ fundTransfer {
    FundTransfer^ get ();
    void set (FundTransfer^ value);
}
JavaScript
function get_fundTransfer();
function set_fundTransfer(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


fxRatesService Property

[image]

.NET Framework Class Library
RequestMessage..::.fxRatesService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property fxRatesService As FXRatesService
C#
public FXRatesService fxRatesService { get; set; }
Visual C++
public:
property FXRatesService^ fxRatesService {
    FXRatesService^ get ();
    void set (FXRatesService^ value);
}
JavaScript
function get_fxRatesService();
function set_fxRatesService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


gecc Property

[image]

.NET Framework Class Library
RequestMessage..::.gecc Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property gecc As GECC
C#
public GECC gecc { get; set; }
Visual C++
public:
property GECC^ gecc {
    GECC^ get ();
    void set (GECC^ value);
}
JavaScript
function get_gecc();
function set_gecc(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


installment Property

[image]

.NET Framework Class Library
RequestMessage..::.installment Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property installment As Installment
C#
public Installment installment { get; set; }
Visual C++
public:
property Installment^ installment {
    Installment^ get ();
    void set (Installment^ value);
}
JavaScript
function get_installment();
function set_installment(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


invoiceHeader Property

[image]

.NET Framework Class Library
RequestMessage..::.invoiceHeader Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property invoiceHeader As InvoiceHeader
C#
public InvoiceHeader invoiceHeader { get; set; }
Visual C++
public:
property InvoiceHeader^ invoiceHeader {
    InvoiceHeader^ get ();
    void set (InvoiceHeader^ value);
}
JavaScript
function get_invoiceHeader();
function set_invoiceHeader(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


item Property

[image]

.NET Framework Class Library
RequestMessage..::.item Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property item As Item()
C#
public Item[] item { get; set; }
Visual C++
public:
property array<Item^>^ item {
    array<Item^>^ get ();
    void set (array<Item^>^ value);
}
JavaScript
function get_item();
function set_item(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


jpo Property

[image]

.NET Framework Class Library
RequestMessage..::.jpo Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property jpo As JPO
C#
public JPO jpo { get; set; }
Visual C++
public:
property JPO^ jpo {
    JPO^ get ();
    void set (JPO^ value);
}
JavaScript
function get_jpo();
function set_jpo(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


merchantDefinedData Property

[image]

.NET Framework Class Library
RequestMessage..::.merchantDefinedData Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantDefinedData As MerchantDefinedData
C#
public MerchantDefinedData merchantDefinedData { get; set; }
Visual C++
public:
property MerchantDefinedData^ merchantDefinedData {
    MerchantDefinedData^ get ();
    void set (MerchantDefinedData^ value);
}
JavaScript
function get_merchantDefinedData();
function set_merchantDefinedData(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


merchantID Property

[image]

.NET Framework Class Library
RequestMessage..::.merchantID Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantID As String
C#
public string merchantID { get; set; }
Visual C++
public:
property String^ merchantID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantID();
function set_merchantID(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


merchantReferenceCode Property

[image]

.NET Framework Class Library
RequestMessage..::.merchantReferenceCode Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantReferenceCode As String
C#
public string merchantReferenceCode { get; set; }
Visual C++
public:
property String^ merchantReferenceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantReferenceCode();
function set_merchantReferenceCode(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


merchantSecureData Property

[image]

.NET Framework Class Library
RequestMessage..::.merchantSecureData Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property merchantSecureData As MerchantSecureData
C#
public MerchantSecureData merchantSecureData { get; set; }
Visual C++
public:
property MerchantSecureData^ merchantSecureData {
    MerchantSecureData^ get ();
    void set (MerchantSecureData^ value);
}
JavaScript
function get_merchantSecureData();
function set_merchantSecureData(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


orderRequestToken Property

[image]

.NET Framework Class Library
RequestMessage..::.orderRequestToken Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderRequestToken As String
C#
public string orderRequestToken { get; set; }
Visual C++
public:
property String^ orderRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderRequestToken();
function set_orderRequestToken(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


otherTax Property

[image]

.NET Framework Class Library
RequestMessage..::.otherTax Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property otherTax As OtherTax
C#
public OtherTax otherTax { get; set; }
Visual C++
public:
property OtherTax^ otherTax {
    OtherTax^ get ();
    void set (OtherTax^ value);
}
JavaScript
function get_otherTax();
function set_otherTax(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payerAuthEnrollService Property

[image]

.NET Framework Class Library
RequestMessage..::.payerAuthEnrollService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerAuthEnrollService As PayerAuthEnrollService
C#
public PayerAuthEnrollService payerAuthEnrollService { get; set; }
Visual C++
public:
property PayerAuthEnrollService^ payerAuthEnrollService {
    PayerAuthEnrollService^ get ();
    void set (PayerAuthEnrollService^ value);
}
JavaScript
function get_payerAuthEnrollService();
function set_payerAuthEnrollService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payerAuthValidateService Property

[image]

.NET Framework Class Library
RequestMessage..::.payerAuthValidateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payerAuthValidateService As PayerAuthValidateService
C#
public PayerAuthValidateService payerAuthValidateService { get; set; }
Visual C++
public:
property PayerAuthValidateService^ payerAuthValidateService {
    PayerAuthValidateService^ get ();
    void set (PayerAuthValidateService^ value);
}
JavaScript
function get_payerAuthValidateService();
function set_payerAuthValidateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


paypal Property

[image]

.NET Framework Class Library
RequestMessage..::.paypal Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paypal As PayPal
C#
public PayPal paypal { get; set; }
Visual C++
public:
property PayPal^ paypal {
    PayPal^ get ();
    void set (PayPal^ value);
}
JavaScript
function get_paypal();
function set_paypal(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalAuthorizationService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalAuthorizationService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalAuthorizationService As PayPalAuthorizationService
C#
public PayPalAuthorizationService payPalAuthorizationService { get; set; }
Visual C++
public:
property PayPalAuthorizationService^ payPalAuthorizationService {
    PayPalAuthorizationService^ get ();
    void set (PayPalAuthorizationService^ value);
}
JavaScript
function get_payPalAuthorizationService();
function set_payPalAuthorizationService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalAuthReversalService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalAuthReversalService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalAuthReversalService As PayPalAuthReversalService
C#
public PayPalAuthReversalService payPalAuthReversalService { get; set; }
Visual C++
public:
property PayPalAuthReversalService^ payPalAuthReversalService {
    PayPalAuthReversalService^ get ();
    void set (PayPalAuthReversalService^ value);
}
JavaScript
function get_payPalAuthReversalService();
function set_payPalAuthReversalService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalButtonCreateService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalButtonCreateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalButtonCreateService As PayPalButtonCreateService
C#
public PayPalButtonCreateService payPalButtonCreateService { get; set; }
Visual C++
public:
property PayPalButtonCreateService^ payPalButtonCreateService {
    PayPalButtonCreateService^ get ();
    void set (PayPalButtonCreateService^ value);
}
JavaScript
function get_payPalButtonCreateService();
function set_payPalButtonCreateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalCreditService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalCreditService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalCreditService As PayPalCreditService
C#
public PayPalCreditService payPalCreditService { get; set; }
Visual C++
public:
property PayPalCreditService^ payPalCreditService {
    PayPalCreditService^ get ();
    void set (PayPalCreditService^ value);
}
JavaScript
function get_payPalCreditService();
function set_payPalCreditService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalDoCaptureService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalDoCaptureService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalDoCaptureService As PayPalDoCaptureService
C#
public PayPalDoCaptureService payPalDoCaptureService { get; set; }
Visual C++
public:
property PayPalDoCaptureService^ payPalDoCaptureService {
    PayPalDoCaptureService^ get ();
    void set (PayPalDoCaptureService^ value);
}
JavaScript
function get_payPalDoCaptureService();
function set_payPalDoCaptureService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalEcDoPaymentService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalEcDoPaymentService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalEcDoPaymentService As PayPalEcDoPaymentService
C#
public PayPalEcDoPaymentService payPalEcDoPaymentService { get; set; }
Visual C++
public:
property PayPalEcDoPaymentService^ payPalEcDoPaymentService {
    PayPalEcDoPaymentService^ get ();
    void set (PayPalEcDoPaymentService^ value);
}
JavaScript
function get_payPalEcDoPaymentService();
function set_payPalEcDoPaymentService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalEcGetDetailsService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalEcGetDetailsService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalEcGetDetailsService As PayPalEcGetDetailsService
C#
public PayPalEcGetDetailsService payPalEcGetDetailsService { get; set; }
Visual C++
public:
property PayPalEcGetDetailsService^ payPalEcGetDetailsService {
    PayPalEcGetDetailsService^ get ();
    void set (PayPalEcGetDetailsService^ value);
}
JavaScript
function get_payPalEcGetDetailsService();
function set_payPalEcGetDetailsService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalEcOrderSetupService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalEcOrderSetupService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalEcOrderSetupService As PayPalEcOrderSetupService
C#
public PayPalEcOrderSetupService payPalEcOrderSetupService { get; set; }
Visual C++
public:
property PayPalEcOrderSetupService^ payPalEcOrderSetupService {
    PayPalEcOrderSetupService^ get ();
    void set (PayPalEcOrderSetupService^ value);
}
JavaScript
function get_payPalEcOrderSetupService();
function set_payPalEcOrderSetupService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalEcSetService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalEcSetService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalEcSetService As PayPalEcSetService
C#
public PayPalEcSetService payPalEcSetService { get; set; }
Visual C++
public:
property PayPalEcSetService^ payPalEcSetService {
    PayPalEcSetService^ get ();
    void set (PayPalEcSetService^ value);
}
JavaScript
function get_payPalEcSetService();
function set_payPalEcSetService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalPaymentService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalPaymentService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalPaymentService As PayPalPaymentService
C#
public PayPalPaymentService payPalPaymentService { get; set; }
Visual C++
public:
property PayPalPaymentService^ payPalPaymentService {
    PayPalPaymentService^ get ();
    void set (PayPalPaymentService^ value);
}
JavaScript
function get_payPalPaymentService();
function set_payPalPaymentService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalPreapprovedPaymentService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalPreapprovedPaymentService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalPreapprovedPaymentService As PayPalPreapprovedPaymentService
C#
public PayPalPreapprovedPaymentService payPalPreapprovedPaymentService { get; set; }
Visual C++
public:
property PayPalPreapprovedPaymentService^ payPalPreapprovedPaymentService {
    PayPalPreapprovedPaymentService^ get ();
    void set (PayPalPreapprovedPaymentService^ value);
}
JavaScript
function get_payPalPreapprovedPaymentService();
function set_payPalPreapprovedPaymentService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalPreapprovedUpdateService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalPreapprovedUpdateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalPreapprovedUpdateService As PayPalPreapprovedUpdateService
C#
public PayPalPreapprovedUpdateService payPalPreapprovedUpdateService { get; set; }
Visual C++
public:
property PayPalPreapprovedUpdateService^ payPalPreapprovedUpdateService {
    PayPalPreapprovedUpdateService^ get ();
    void set (PayPalPreapprovedUpdateService^ value);
}
JavaScript
function get_payPalPreapprovedUpdateService();
function set_payPalPreapprovedUpdateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


payPalRefundService Property

[image]

.NET Framework Class Library
RequestMessage..::.payPalRefundService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property payPalRefundService As PayPalRefundService
C#
public PayPalRefundService payPalRefundService { get; set; }
Visual C++
public:
property PayPalRefundService^ payPalRefundService {
    PayPalRefundService^ get ();
    void set (PayPalRefundService^ value);
}
JavaScript
function get_payPalRefundService();
function set_payPalRefundService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


paySubscriptionCreateService Property

[image]

.NET Framework Class Library
RequestMessage..::.paySubscriptionCreateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paySubscriptionCreateService As PaySubscriptionCreateService
C#
public PaySubscriptionCreateService paySubscriptionCreateService { get; set; }
Visual C++
public:
property PaySubscriptionCreateService^ paySubscriptionCreateService {
    PaySubscriptionCreateService^ get ();
    void set (PaySubscriptionCreateService^ value);
}
JavaScript
function get_paySubscriptionCreateService();
function set_paySubscriptionCreateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


paySubscriptionEventUpdateService Property

[image]

.NET Framework Class Library
RequestMessage..::.paySubscriptionEventUpdateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paySubscriptionEventUpdateService As PaySubscriptionEventUpdateService
C#
public PaySubscriptionEventUpdateService paySubscriptionEventUpdateService { get; set; }
Visual C++
public:
property PaySubscriptionEventUpdateService^ paySubscriptionEventUpdateService {
    PaySubscriptionEventUpdateService^ get ();
    void set (PaySubscriptionEventUpdateService^ value);
}
JavaScript
function get_paySubscriptionEventUpdateService();
function set_paySubscriptionEventUpdateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


paySubscriptionRetrieveService Property

[image]

.NET Framework Class Library
RequestMessage..::.paySubscriptionRetrieveService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paySubscriptionRetrieveService As PaySubscriptionRetrieveService
C#
public PaySubscriptionRetrieveService paySubscriptionRetrieveService { get; set; }
Visual C++
public:
property PaySubscriptionRetrieveService^ paySubscriptionRetrieveService {
    PaySubscriptionRetrieveService^ get ();
    void set (PaySubscriptionRetrieveService^ value);
}
JavaScript
function get_paySubscriptionRetrieveService();
function set_paySubscriptionRetrieveService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


paySubscriptionUpdateService Property

[image]

.NET Framework Class Library
RequestMessage..::.paySubscriptionUpdateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paySubscriptionUpdateService As PaySubscriptionUpdateService
C#
public PaySubscriptionUpdateService paySubscriptionUpdateService { get; set; }
Visual C++
public:
property PaySubscriptionUpdateService^ paySubscriptionUpdateService {
    PaySubscriptionUpdateService^ get ();
    void set (PaySubscriptionUpdateService^ value);
}
JavaScript
function get_paySubscriptionUpdateService();
function set_paySubscriptionUpdateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


pinlessDebitService Property

[image]

.NET Framework Class Library
RequestMessage..::.pinlessDebitService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pinlessDebitService As PinlessDebitService
C#
public PinlessDebitService pinlessDebitService { get; set; }
Visual C++
public:
property PinlessDebitService^ pinlessDebitService {
    PinlessDebitService^ get ();
    void set (PinlessDebitService^ value);
}
JavaScript
function get_pinlessDebitService();
function set_pinlessDebitService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


pinlessDebitValidateService Property

[image]

.NET Framework Class Library
RequestMessage..::.pinlessDebitValidateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pinlessDebitValidateService As PinlessDebitValidateService
C#
public PinlessDebitValidateService pinlessDebitValidateService { get; set; }
Visual C++
public:
property PinlessDebitValidateService^ pinlessDebitValidateService {
    PinlessDebitValidateService^ get ();
    void set (PinlessDebitValidateService^ value);
}
JavaScript
function get_pinlessDebitValidateService();
function set_pinlessDebitValidateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


pos Property

[image]

.NET Framework Class Library
RequestMessage..::.pos Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pos As Pos
C#
public Pos pos { get; set; }
Visual C++
public:
property Pos^ pos {
    Pos^ get ();
    void set (Pos^ value);
}
JavaScript
function get_pos();
function set_pos(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


purchaseTotals Property

[image]

.NET Framework Class Library
RequestMessage..::.purchaseTotals Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property purchaseTotals As PurchaseTotals
C#
public PurchaseTotals purchaseTotals { get; set; }
Visual C++
public:
property PurchaseTotals^ purchaseTotals {
    PurchaseTotals^ get ();
    void set (PurchaseTotals^ value);
}
JavaScript
function get_purchaseTotals();
function set_purchaseTotals(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


recurringSubscriptionInfo Property

[image]

.NET Framework Class Library
RequestMessage..::.recurringSubscriptionInfo Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property recurringSubscriptionInfo As RecurringSubscriptionInfo
C#
public RecurringSubscriptionInfo recurringSubscriptionInfo { get; set; }
Visual C++
public:
property RecurringSubscriptionInfo^ recurringSubscriptionInfo {
    RecurringSubscriptionInfo^ get ();
    void set (RecurringSubscriptionInfo^ value);
}
JavaScript
function get_recurringSubscriptionInfo();
function set_recurringSubscriptionInfo(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


reserved Property

[image]

.NET Framework Class Library
RequestMessage..::.reserved Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reserved As RequestReserved()
C#
public RequestReserved[] reserved { get; set; }
Visual C++
public:
property array<RequestReserved^>^ reserved {
    array<RequestReserved^>^ get ();
    void set (array<RequestReserved^>^ value);
}
JavaScript
function get_reserved();
function set_reserved(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


riskUpdateService Property

[image]

.NET Framework Class Library
RequestMessage..::.riskUpdateService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property riskUpdateService As RiskUpdateService
C#
public RiskUpdateService riskUpdateService { get; set; }
Visual C++
public:
property RiskUpdateService^ riskUpdateService {
    RiskUpdateService^ get ();
    void set (RiskUpdateService^ value);
}
JavaScript
function get_riskUpdateService();
function set_riskUpdateService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


routingCode Property

[image]

.NET Framework Class Library
RequestMessage..::.routingCode Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property routingCode As String
C#
public string routingCode { get; set; }
Visual C++
public:
property String^ routingCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_routingCode();
function set_routingCode(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


shipFrom Property

[image]

.NET Framework Class Library
RequestMessage..::.shipFrom Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipFrom As ShipFrom
C#
public ShipFrom shipFrom { get; set; }
Visual C++
public:
property ShipFrom^ shipFrom {
    ShipFrom^ get ();
    void set (ShipFrom^ value);
}
JavaScript
function get_shipFrom();
function set_shipFrom(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


shipTo Property

[image]

.NET Framework Class Library
RequestMessage..::.shipTo Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shipTo As ShipTo
C#
public ShipTo shipTo { get; set; }
Visual C++
public:
property ShipTo^ shipTo {
    ShipTo^ get ();
    void set (ShipTo^ value);
}
JavaScript
function get_shipTo();
function set_shipTo(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


subscription Property

[image]

.NET Framework Class Library
RequestMessage..::.subscription Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property subscription As Subscription
C#
public Subscription subscription { get; set; }
Visual C++
public:
property Subscription^ subscription {
    Subscription^ get ();
    void set (Subscription^ value);
}
JavaScript
function get_subscription();
function set_subscription(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


taxService Property

[image]

.NET Framework Class Library
RequestMessage..::.taxService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property taxService As TaxService
C#
public TaxService taxService { get; set; }
Visual C++
public:
property TaxService^ taxService {
    TaxService^ get ();
    void set (TaxService^ value);
}
JavaScript
function get_taxService();
function set_taxService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


ucaf Property

[image]

.NET Framework Class Library
RequestMessage..::.ucaf Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ucaf As UCAF
C#
public UCAF ucaf { get; set; }
Visual C++
public:
property UCAF^ ucaf {
    UCAF^ get ();
    void set (UCAF^ value);
}
JavaScript
function get_ucaf();
function set_ucaf(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


voidService Property

[image]

.NET Framework Class Library
RequestMessage..::.voidService Property
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property voidService As VoidService
C#
public VoidService voidService { get; set; }
Visual C++
public:
property VoidService^ voidService {
    VoidService^ get ();
    void set (VoidService^ value);
}
JavaScript
function get_voidService();
function set_voidService(value);

Remarks

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


RequestMessage Events

[image] [image]

.NET Framework Class Library
RequestMessage Events
RequestMessage Class See Also Send Feedback

The RequestMessage type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
RequestMessage..::.PropertyChanged Event
RequestMessage Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

RequestMessage Class
InSite.Domain.CyberSourceService Namespace


RequestReserved Class

[image]

.NET Framework Class Library
RequestReserved Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class RequestReserved _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class RequestReserved : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class RequestReserved : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.RequestReserved = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.RequestReserved',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.RequestReserved

See Also

RequestReserved Members
InSite.Domain.CyberSourceService Namespace


RequestReserved Members

[image] [image]

.NET Framework Class Library
RequestReserved Members
RequestReserved Class Constructors Methods Properties Events See Also Send Feedback

The RequestReserved type exposes the following members.

Constructors

Name | Description
RequestReserved |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
name |
value |

Events

Name | Description
PropertyChanged |

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


RequestReserved Constructor

[image]

.NET Framework Class Library
RequestReserved Constructor
RequestReserved Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RequestReserved()
Visual C++
public:
RequestReserved()
JavaScript
InSite.Domain.CyberSourceService.RequestReserved = function();

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


RequestReserved Methods

[image] [image]

.NET Framework Class Library
RequestReserved Methods
RequestReserved Class See Also Send Feedback

The RequestReserved type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
RequestReserved..::.RaisePropertyChanged Method
RequestReserved Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


RequestReserved Properties

[image] [image]

.NET Framework Class Library
RequestReserved Properties
RequestReserved Class See Also Send Feedback

The RequestReserved type exposes the following members.

Properties

Name | Description
name |
value |

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


name Property

[image]

.NET Framework Class Library
RequestReserved..::.name Property
RequestReserved Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String
C#
public string name { get; set; }
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


value Property

[image]

.NET Framework Class Library
RequestReserved..::.value Property
RequestReserved Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property value As String
C#
public string value { get; set; }
Visual C++
public:
property String^ value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


RequestReserved Events

[image] [image]

.NET Framework Class Library
RequestReserved Events
RequestReserved Class See Also Send Feedback

The RequestReserved type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
RequestReserved..::.PropertyChanged Event
RequestReserved Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

RequestReserved Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateReply Class

[image]

.NET Framework Class Library
RiskUpdateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class RiskUpdateReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class RiskUpdateReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class RiskUpdateReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.RiskUpdateReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.RiskUpdateReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.RiskUpdateReply

See Also

RiskUpdateReply Members
InSite.Domain.CyberSourceService Namespace


RiskUpdateReply Members

[image] [image]

.NET Framework Class Library
RiskUpdateReply Members
RiskUpdateReply Class Constructors Methods Properties Events See Also Send Feedback

The RiskUpdateReply type exposes the following members.

Constructors

Name | Description
RiskUpdateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
reasonCode |

Events

Name | Description
PropertyChanged |

See Also

RiskUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateReply Constructor

[image]

.NET Framework Class Library
RiskUpdateReply Constructor
RiskUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RiskUpdateReply()
Visual C++
public:
RiskUpdateReply()
JavaScript
InSite.Domain.CyberSourceService.RiskUpdateReply = function();

See Also

RiskUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateReply Methods

[image] [image]

.NET Framework Class Library
RiskUpdateReply Methods
RiskUpdateReply Class See Also Send Feedback

The RiskUpdateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RiskUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
RiskUpdateReply..::.RaisePropertyChanged Method
RiskUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

RiskUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateReply Properties

[image] [image]

.NET Framework Class Library
RiskUpdateReply Properties
RiskUpdateReply Class See Also Send Feedback

The RiskUpdateReply type exposes the following members.

Properties

Name | Description
reasonCode |

See Also

RiskUpdateReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
RiskUpdateReply..::.reasonCode Property
RiskUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

RiskUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateReply Events

[image] [image]

.NET Framework Class Library
RiskUpdateReply Events
RiskUpdateReply Class See Also Send Feedback

The RiskUpdateReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

RiskUpdateReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
RiskUpdateReply..::.PropertyChanged Event
RiskUpdateReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

RiskUpdateReply Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateService Class

[image]

.NET Framework Class Library
RiskUpdateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class RiskUpdateService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class RiskUpdateService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class RiskUpdateService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.RiskUpdateService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.RiskUpdateService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.RiskUpdateService

See Also

RiskUpdateService Members
InSite.Domain.CyberSourceService Namespace


RiskUpdateService Members

[image] [image]

.NET Framework Class Library
RiskUpdateService Members
RiskUpdateService Class Constructors Methods Properties Events See Also Send Feedback

The RiskUpdateService type exposes the following members.

Constructors

Name | Description
RiskUpdateService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
actionCode |
markingNotes |
markingReason |
negativeAddress |
recordID |
recordName |
run |

Events

Name | Description
PropertyChanged |

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateService Constructor

[image]

.NET Framework Class Library
RiskUpdateService Constructor
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RiskUpdateService()
Visual C++
public:
RiskUpdateService()
JavaScript
InSite.Domain.CyberSourceService.RiskUpdateService = function();

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateService Methods

[image] [image]

.NET Framework Class Library
RiskUpdateService Methods
RiskUpdateService Class See Also Send Feedback

The RiskUpdateService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
RiskUpdateService..::.RaisePropertyChanged Method
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateService Properties

[image] [image]

.NET Framework Class Library
RiskUpdateService Properties
RiskUpdateService Class See Also Send Feedback

The RiskUpdateService type exposes the following members.

Properties

Name | Description
actionCode |
markingNotes |
markingReason |
negativeAddress |
recordID |
recordName |
run |

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


actionCode Property

[image]

.NET Framework Class Library
RiskUpdateService..::.actionCode Property
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property actionCode As String
C#
public string actionCode { get; set; }
Visual C++
public:
property String^ actionCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_actionCode();
function set_actionCode(value);

Remarks

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


markingNotes Property

[image]

.NET Framework Class Library
RiskUpdateService..::.markingNotes Property
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property markingNotes As String
C#
public string markingNotes { get; set; }
Visual C++
public:
property String^ markingNotes {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_markingNotes();
function set_markingNotes(value);

Remarks

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


markingReason Property

[image]

.NET Framework Class Library
RiskUpdateService..::.markingReason Property
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property markingReason As String
C#
public string markingReason { get; set; }
Visual C++
public:
property String^ markingReason {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_markingReason();
function set_markingReason(value);

Remarks

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


negativeAddress Property

[image]

.NET Framework Class Library
RiskUpdateService..::.negativeAddress Property
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property negativeAddress As Address
C#
public Address negativeAddress { get; set; }
Visual C++
public:
property Address^ negativeAddress {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_negativeAddress();
function set_negativeAddress(value);

Remarks

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


recordID Property

[image]

.NET Framework Class Library
RiskUpdateService..::.recordID Property
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property recordID As String
C#
public string recordID { get; set; }
Visual C++
public:
property String^ recordID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_recordID();
function set_recordID(value);

Remarks

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


recordName Property

[image]

.NET Framework Class Library
RiskUpdateService..::.recordName Property
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property recordName As String
C#
public string recordName { get; set; }
Visual C++
public:
property String^ recordName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_recordName();
function set_recordName(value);

Remarks

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
RiskUpdateService..::.run Property
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


RiskUpdateService Events

[image] [image]

.NET Framework Class Library
RiskUpdateService Events
RiskUpdateService Class See Also Send Feedback

The RiskUpdateService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
RiskUpdateService..::.PropertyChanged Event
RiskUpdateService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

RiskUpdateService Class
InSite.Domain.CyberSourceService Namespace


RuleResultItem Class

[image]

.NET Framework Class Library
RuleResultItem Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class RuleResultItem _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class RuleResultItem : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class RuleResultItem : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.RuleResultItem = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.RuleResultItem',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.RuleResultItem

See Also

RuleResultItem Members
InSite.Domain.CyberSourceService Namespace


RuleResultItem Members

[image] [image]

.NET Framework Class Library
RuleResultItem Members
RuleResultItem Class Constructors Methods Properties Events See Also Send Feedback

The RuleResultItem type exposes the following members.

Constructors

Name | Description
RuleResultItem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
decision |
evaluation |
name |
ruleID |

Events

Name | Description
PropertyChanged |

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


RuleResultItem Constructor

[image]

.NET Framework Class Library
RuleResultItem Constructor
RuleResultItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RuleResultItem()
Visual C++
public:
RuleResultItem()
JavaScript
InSite.Domain.CyberSourceService.RuleResultItem = function();

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


RuleResultItem Methods

[image] [image]

.NET Framework Class Library
RuleResultItem Methods
RuleResultItem Class See Also Send Feedback

The RuleResultItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
RuleResultItem..::.RaisePropertyChanged Method
RuleResultItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


RuleResultItem Properties

[image] [image]

.NET Framework Class Library
RuleResultItem Properties
RuleResultItem Class See Also Send Feedback

The RuleResultItem type exposes the following members.

Properties

Name | Description
decision |
evaluation |
name |
ruleID |

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


decision Property

[image]

.NET Framework Class Library
RuleResultItem..::.decision Property
RuleResultItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property decision As String
C#
public string decision { get; set; }
Visual C++
public:
property String^ decision {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_decision();
function set_decision(value);

Remarks

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


evaluation Property

[image]

.NET Framework Class Library
RuleResultItem..::.evaluation Property
RuleResultItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property evaluation As String
C#
public string evaluation { get; set; }
Visual C++
public:
property String^ evaluation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_evaluation();
function set_evaluation(value);

Remarks

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


name Property

[image]

.NET Framework Class Library
RuleResultItem..::.name Property
RuleResultItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property name As String
C#
public string name { get; set; }
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


ruleID Property

[image]

.NET Framework Class Library
RuleResultItem..::.ruleID Property
RuleResultItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ruleID As String
C#
public string ruleID { get; set; }
Visual C++
public:
property String^ ruleID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ruleID();
function set_ruleID(value);

Remarks

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


RuleResultItem Events

[image] [image]

.NET Framework Class Library
RuleResultItem Events
RuleResultItem Class See Also Send Feedback

The RuleResultItem type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
RuleResultItem..::.PropertyChanged Event
RuleResultItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

RuleResultItem Class
InSite.Domain.CyberSourceService Namespace


ShipFrom Class

[image]

.NET Framework Class Library
ShipFrom Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ShipFrom _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ShipFrom : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ShipFrom : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ShipFrom = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ShipFrom',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ShipFrom

See Also

ShipFrom Members
InSite.Domain.CyberSourceService Namespace


ShipFrom Members

[image] [image]

.NET Framework Class Library
ShipFrom Members
ShipFrom Class Constructors Methods Properties Events See Also Send Feedback

The ShipFrom type exposes the following members.

Constructors

Name | Description
ShipFrom |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
city |
company |
country |
county |
email |
firstName |
lastName |
middleName |
phoneNumber |
postalCode |
state |
street1 |
street2 |
street3 |
street4 |
suffix |
title |

Events

Name | Description
PropertyChanged |

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


ShipFrom Constructor

[image]

.NET Framework Class Library
ShipFrom Constructor
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipFrom()
Visual C++
public:
ShipFrom()
JavaScript
InSite.Domain.CyberSourceService.ShipFrom = function();

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


ShipFrom Methods

[image] [image]

.NET Framework Class Library
ShipFrom Methods
ShipFrom Class See Also Send Feedback

The ShipFrom type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ShipFrom..::.RaisePropertyChanged Method
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


ShipFrom Properties

[image] [image]

.NET Framework Class Library
ShipFrom Properties
ShipFrom Class See Also Send Feedback

The ShipFrom type exposes the following members.

Properties

Name | Description
city |
company |
country |
county |
email |
firstName |
lastName |
middleName |
phoneNumber |
postalCode |
state |
street1 |
street2 |
street3 |
street4 |
suffix |
title |

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


city Property

[image]

.NET Framework Class Library
ShipFrom..::.city Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


company Property

[image]

.NET Framework Class Library
ShipFrom..::.company Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property company As String
C#
public string company { get; set; }
Visual C++
public:
property String^ company {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_company();
function set_company(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


country Property

[image]

.NET Framework Class Library
ShipFrom..::.country Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property country As String
C#
public string country { get; set; }
Visual C++
public:
property String^ country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


county Property

[image]

.NET Framework Class Library
ShipFrom..::.county Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property county As String
C#
public string county { get; set; }
Visual C++
public:
property String^ county {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_county();
function set_county(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


email Property

[image]

.NET Framework Class Library
ShipFrom..::.email Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property email As String
C#
public string email { get; set; }
Visual C++
public:
property String^ email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


firstName Property

[image]

.NET Framework Class Library
ShipFrom..::.firstName Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property firstName As String
C#
public string firstName { get; set; }
Visual C++
public:
property String^ firstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


lastName Property

[image]

.NET Framework Class Library
ShipFrom..::.lastName Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property lastName As String
C#
public string lastName { get; set; }
Visual C++
public:
property String^ lastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


middleName Property

[image]

.NET Framework Class Library
ShipFrom..::.middleName Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property middleName As String
C#
public string middleName { get; set; }
Visual C++
public:
property String^ middleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_middleName();
function set_middleName(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


phoneNumber Property

[image]

.NET Framework Class Library
ShipFrom..::.phoneNumber Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property phoneNumber As String
C#
public string phoneNumber { get; set; }
Visual C++
public:
property String^ phoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


postalCode Property

[image]

.NET Framework Class Library
ShipFrom..::.postalCode Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property postalCode As String
C#
public string postalCode { get; set; }
Visual C++
public:
property String^ postalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


state Property

[image]

.NET Framework Class Library
ShipFrom..::.state Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


street1 Property

[image]

.NET Framework Class Library
ShipFrom..::.street1 Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street1 As String
C#
public string street1 { get; set; }
Visual C++
public:
property String^ street1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street1();
function set_street1(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


street2 Property

[image]

.NET Framework Class Library
ShipFrom..::.street2 Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street2 As String
C#
public string street2 { get; set; }
Visual C++
public:
property String^ street2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street2();
function set_street2(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


street3 Property

[image]

.NET Framework Class Library
ShipFrom..::.street3 Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street3 As String
C#
public string street3 { get; set; }
Visual C++
public:
property String^ street3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street3();
function set_street3(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


street4 Property

[image]

.NET Framework Class Library
ShipFrom..::.street4 Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street4 As String
C#
public string street4 { get; set; }
Visual C++
public:
property String^ street4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street4();
function set_street4(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


suffix Property

[image]

.NET Framework Class Library
ShipFrom..::.suffix Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property suffix As String
C#
public string suffix { get; set; }
Visual C++
public:
property String^ suffix {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_suffix();
function set_suffix(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


title Property

[image]

.NET Framework Class Library
ShipFrom..::.title Property
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property title As String
C#
public string title { get; set; }
Visual C++
public:
property String^ title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

Remarks

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


ShipFrom Events

[image] [image]

.NET Framework Class Library
ShipFrom Events
ShipFrom Class See Also Send Feedback

The ShipFrom type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ShipFrom..::.PropertyChanged Event
ShipFrom Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ShipFrom Class
InSite.Domain.CyberSourceService Namespace


ShipTo Class

[image]

.NET Framework Class Library
ShipTo Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ShipTo _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ShipTo : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ShipTo : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.ShipTo = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.ShipTo',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.ShipTo

See Also

ShipTo Members
InSite.Domain.CyberSourceService Namespace


ShipTo Members

[image] [image]

.NET Framework Class Library
ShipTo Members
ShipTo Class Constructors Methods Properties Events See Also Send Feedback

The ShipTo type exposes the following members.

Constructors

Name | Description
ShipTo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
city |
company |
country |
county |
email |
firstName |
lastName |
middleName |
phoneNumber |
postalCode |
shippingMethod |
state |
street1 |
street2 |
street3 |
street4 |
suffix |
title |

Events

Name | Description
PropertyChanged |

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


ShipTo Constructor

[image]

.NET Framework Class Library
ShipTo Constructor
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipTo()
Visual C++
public:
ShipTo()
JavaScript
InSite.Domain.CyberSourceService.ShipTo = function();

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


ShipTo Methods

[image] [image]

.NET Framework Class Library
ShipTo Methods
ShipTo Class See Also Send Feedback

The ShipTo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
ShipTo..::.RaisePropertyChanged Method
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


ShipTo Properties

[image] [image]

.NET Framework Class Library
ShipTo Properties
ShipTo Class See Also Send Feedback

The ShipTo type exposes the following members.

Properties

Name | Description
city |
company |
country |
county |
email |
firstName |
lastName |
middleName |
phoneNumber |
postalCode |
shippingMethod |
state |
street1 |
street2 |
street3 |
street4 |
suffix |
title |

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


city Property

[image]

.NET Framework Class Library
ShipTo..::.city Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


company Property

[image]

.NET Framework Class Library
ShipTo..::.company Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property company As String
C#
public string company { get; set; }
Visual C++
public:
property String^ company {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_company();
function set_company(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


country Property

[image]

.NET Framework Class Library
ShipTo..::.country Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property country As String
C#
public string country { get; set; }
Visual C++
public:
property String^ country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


county Property

[image]

.NET Framework Class Library
ShipTo..::.county Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property county As String
C#
public string county { get; set; }
Visual C++
public:
property String^ county {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_county();
function set_county(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


email Property

[image]

.NET Framework Class Library
ShipTo..::.email Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property email As String
C#
public string email { get; set; }
Visual C++
public:
property String^ email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


firstName Property

[image]

.NET Framework Class Library
ShipTo..::.firstName Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property firstName As String
C#
public string firstName { get; set; }
Visual C++
public:
property String^ firstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


lastName Property

[image]

.NET Framework Class Library
ShipTo..::.lastName Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property lastName As String
C#
public string lastName { get; set; }
Visual C++
public:
property String^ lastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


middleName Property

[image]

.NET Framework Class Library
ShipTo..::.middleName Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property middleName As String
C#
public string middleName { get; set; }
Visual C++
public:
property String^ middleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_middleName();
function set_middleName(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


phoneNumber Property

[image]

.NET Framework Class Library
ShipTo..::.phoneNumber Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property phoneNumber As String
C#
public string phoneNumber { get; set; }
Visual C++
public:
property String^ phoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


postalCode Property

[image]

.NET Framework Class Library
ShipTo..::.postalCode Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property postalCode As String
C#
public string postalCode { get; set; }
Visual C++
public:
property String^ postalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


shippingMethod Property

[image]

.NET Framework Class Library
ShipTo..::.shippingMethod Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property shippingMethod As String
C#
public string shippingMethod { get; set; }
Visual C++
public:
property String^ shippingMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shippingMethod();
function set_shippingMethod(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


state Property

[image]

.NET Framework Class Library
ShipTo..::.state Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


street1 Property

[image]

.NET Framework Class Library
ShipTo..::.street1 Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street1 As String
C#
public string street1 { get; set; }
Visual C++
public:
property String^ street1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street1();
function set_street1(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


street2 Property

[image]

.NET Framework Class Library
ShipTo..::.street2 Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street2 As String
C#
public string street2 { get; set; }
Visual C++
public:
property String^ street2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street2();
function set_street2(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


street3 Property

[image]

.NET Framework Class Library
ShipTo..::.street3 Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street3 As String
C#
public string street3 { get; set; }
Visual C++
public:
property String^ street3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street3();
function set_street3(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


street4 Property

[image]

.NET Framework Class Library
ShipTo..::.street4 Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property street4 As String
C#
public string street4 { get; set; }
Visual C++
public:
property String^ street4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_street4();
function set_street4(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


suffix Property

[image]

.NET Framework Class Library
ShipTo..::.suffix Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property suffix As String
C#
public string suffix { get; set; }
Visual C++
public:
property String^ suffix {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_suffix();
function set_suffix(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


title Property

[image]

.NET Framework Class Library
ShipTo..::.title Property
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property title As String
C#
public string title { get; set; }
Visual C++
public:
property String^ title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

Remarks

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


ShipTo Events

[image] [image]

.NET Framework Class Library
ShipTo Events
ShipTo Class See Also Send Feedback

The ShipTo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ShipTo..::.PropertyChanged Event
ShipTo Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ShipTo Class
InSite.Domain.CyberSourceService Namespace


Subscription Class

[image]

.NET Framework Class Library
Subscription Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class Subscription _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class Subscription : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class Subscription : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.Subscription = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.Subscription',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.Subscription

See Also

Subscription Members
InSite.Domain.CyberSourceService Namespace


Subscription Members

[image] [image]

.NET Framework Class Library
Subscription Members
Subscription Class Constructors Methods Properties Events See Also Send Feedback

The Subscription type exposes the following members.

Constructors

Name | Description
Subscription |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
paymentMethod |
title |

Events

Name | Description
PropertyChanged |

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


Subscription Constructor

[image]

.NET Framework Class Library
Subscription Constructor
Subscription Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Subscription()
Visual C++
public:
Subscription()
JavaScript
InSite.Domain.CyberSourceService.Subscription = function();

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


Subscription Methods

[image] [image]

.NET Framework Class Library
Subscription Methods
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
Subscription..::.RaisePropertyChanged Method
Subscription Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


Subscription Properties

[image] [image]

.NET Framework Class Library
Subscription Properties
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Properties

Name | Description
paymentMethod |
title |

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


paymentMethod Property

[image]

.NET Framework Class Library
Subscription..::.paymentMethod Property
Subscription Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property paymentMethod As String
C#
public string paymentMethod { get; set; }
Visual C++
public:
property String^ paymentMethod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_paymentMethod();
function set_paymentMethod(value);

Remarks

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


title Property

[image]

.NET Framework Class Library
Subscription..::.title Property
Subscription Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property title As String
C#
public string title { get; set; }
Visual C++
public:
property String^ title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

Remarks

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


Subscription Events

[image] [image]

.NET Framework Class Library
Subscription Events
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
Subscription..::.PropertyChanged Event
Subscription Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Subscription Class
InSite.Domain.CyberSourceService Namespace


TaxReply Class

[image]

.NET Framework Class Library
TaxReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class TaxReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class TaxReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class TaxReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.TaxReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.TaxReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.TaxReply

See Also

TaxReply Members
InSite.Domain.CyberSourceService Namespace


TaxReply Members

[image] [image]

.NET Framework Class Library
TaxReply Members
TaxReply Class Constructors Methods Properties Events See Also Send Feedback

The TaxReply type exposes the following members.

Constructors

Name | Description
TaxReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
city |
county |
currency |
geocode |
grandTotalAmount |
item |
postalCode |
reasonCode |
state |
totalCityTaxAmount |
totalCountyTaxAmount |
totalDistrictTaxAmount |
totalStateTaxAmount |
totalTaxAmount |

Events

Name | Description
PropertyChanged |

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


TaxReply Constructor

[image]

.NET Framework Class Library
TaxReply Constructor
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaxReply()
Visual C++
public:
TaxReply()
JavaScript
InSite.Domain.CyberSourceService.TaxReply = function();

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


TaxReply Methods

[image] [image]

.NET Framework Class Library
TaxReply Methods
TaxReply Class See Also Send Feedback

The TaxReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
TaxReply..::.RaisePropertyChanged Method
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


TaxReply Properties

[image] [image]

.NET Framework Class Library
TaxReply Properties
TaxReply Class See Also Send Feedback

The TaxReply type exposes the following members.

Properties

Name | Description
city |
county |
currency |
geocode |
grandTotalAmount |
item |
postalCode |
reasonCode |
state |
totalCityTaxAmount |
totalCountyTaxAmount |
totalDistrictTaxAmount |
totalStateTaxAmount |
totalTaxAmount |

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


city Property

[image]

.NET Framework Class Library
TaxReply..::.city Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property city As String
C#
public string city { get; set; }
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


county Property

[image]

.NET Framework Class Library
TaxReply..::.county Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property county As String
C#
public string county { get; set; }
Visual C++
public:
property String^ county {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_county();
function set_county(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
TaxReply..::.currency Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


geocode Property

[image]

.NET Framework Class Library
TaxReply..::.geocode Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property geocode As String
C#
public string geocode { get; set; }
Visual C++
public:
property String^ geocode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_geocode();
function set_geocode(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


grandTotalAmount Property

[image]

.NET Framework Class Library
TaxReply..::.grandTotalAmount Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property grandTotalAmount As String
C#
public string grandTotalAmount { get; set; }
Visual C++
public:
property String^ grandTotalAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_grandTotalAmount();
function set_grandTotalAmount(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


item Property

[image]

.NET Framework Class Library
TaxReply..::.item Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property item As TaxReplyItem()
C#
public TaxReplyItem[] item { get; set; }
Visual C++
public:
property array<TaxReplyItem^>^ item {
    array<TaxReplyItem^>^ get ();
    void set (array<TaxReplyItem^>^ value);
}
JavaScript
function get_item();
function set_item(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


postalCode Property

[image]

.NET Framework Class Library
TaxReply..::.postalCode Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property postalCode As String
C#
public string postalCode { get; set; }
Visual C++
public:
property String^ postalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
TaxReply..::.reasonCode Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


state Property

[image]

.NET Framework Class Library
TaxReply..::.state Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property state As String
C#
public string state { get; set; }
Visual C++
public:
property String^ state {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


totalCityTaxAmount Property

[image]

.NET Framework Class Library
TaxReply..::.totalCityTaxAmount Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalCityTaxAmount As String
C#
public string totalCityTaxAmount { get; set; }
Visual C++
public:
property String^ totalCityTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalCityTaxAmount();
function set_totalCityTaxAmount(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


totalCountyTaxAmount Property

[image]

.NET Framework Class Library
TaxReply..::.totalCountyTaxAmount Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalCountyTaxAmount As String
C#
public string totalCountyTaxAmount { get; set; }
Visual C++
public:
property String^ totalCountyTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalCountyTaxAmount();
function set_totalCountyTaxAmount(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


totalDistrictTaxAmount Property

[image]

.NET Framework Class Library
TaxReply..::.totalDistrictTaxAmount Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalDistrictTaxAmount As String
C#
public string totalDistrictTaxAmount { get; set; }
Visual C++
public:
property String^ totalDistrictTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalDistrictTaxAmount();
function set_totalDistrictTaxAmount(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


totalStateTaxAmount Property

[image]

.NET Framework Class Library
TaxReply..::.totalStateTaxAmount Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalStateTaxAmount As String
C#
public string totalStateTaxAmount { get; set; }
Visual C++
public:
property String^ totalStateTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalStateTaxAmount();
function set_totalStateTaxAmount(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


totalTaxAmount Property

[image]

.NET Framework Class Library
TaxReply..::.totalTaxAmount Property
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalTaxAmount As String
C#
public string totalTaxAmount { get; set; }
Visual C++
public:
property String^ totalTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalTaxAmount();
function set_totalTaxAmount(value);

Remarks

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


TaxReply Events

[image] [image]

.NET Framework Class Library
TaxReply Events
TaxReply Class See Also Send Feedback

The TaxReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
TaxReply..::.PropertyChanged Event
TaxReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

TaxReply Class
InSite.Domain.CyberSourceService Namespace


TaxReplyItem Class

[image]

.NET Framework Class Library
TaxReplyItem Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class TaxReplyItem _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class TaxReplyItem : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class TaxReplyItem : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.TaxReplyItem = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.TaxReplyItem',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.TaxReplyItem

See Also

TaxReplyItem Members
InSite.Domain.CyberSourceService Namespace


TaxReplyItem Members

[image] [image]

.NET Framework Class Library
TaxReplyItem Members
TaxReplyItem Class Constructors Methods Properties Events See Also Send Feedback

The TaxReplyItem type exposes the following members.

Constructors

Name | Description
TaxReplyItem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
cityTaxAmount |
countyTaxAmount |
districtTaxAmount |
id |
stateTaxAmount |
totalTaxAmount |

Events

Name | Description
PropertyChanged |

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


TaxReplyItem Constructor

[image]

.NET Framework Class Library
TaxReplyItem Constructor
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaxReplyItem()
Visual C++
public:
TaxReplyItem()
JavaScript
InSite.Domain.CyberSourceService.TaxReplyItem = function();

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


TaxReplyItem Methods

[image] [image]

.NET Framework Class Library
TaxReplyItem Methods
TaxReplyItem Class See Also Send Feedback

The TaxReplyItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
TaxReplyItem..::.RaisePropertyChanged Method
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


TaxReplyItem Properties

[image] [image]

.NET Framework Class Library
TaxReplyItem Properties
TaxReplyItem Class See Also Send Feedback

The TaxReplyItem type exposes the following members.

Properties

Name | Description
cityTaxAmount |
countyTaxAmount |
districtTaxAmount |
id |
stateTaxAmount |
totalTaxAmount |

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


cityTaxAmount Property

[image]

.NET Framework Class Library
TaxReplyItem..::.cityTaxAmount Property
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property cityTaxAmount As String
C#
public string cityTaxAmount { get; set; }
Visual C++
public:
property String^ cityTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cityTaxAmount();
function set_cityTaxAmount(value);

Remarks

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


countyTaxAmount Property

[image]

.NET Framework Class Library
TaxReplyItem..::.countyTaxAmount Property
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property countyTaxAmount As String
C#
public string countyTaxAmount { get; set; }
Visual C++
public:
property String^ countyTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countyTaxAmount();
function set_countyTaxAmount(value);

Remarks

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


districtTaxAmount Property

[image]

.NET Framework Class Library
TaxReplyItem..::.districtTaxAmount Property
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property districtTaxAmount As String
C#
public string districtTaxAmount { get; set; }
Visual C++
public:
property String^ districtTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_districtTaxAmount();
function set_districtTaxAmount(value);

Remarks

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


id Property

[image]

.NET Framework Class Library
TaxReplyItem..::.id Property
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property id As String
C#
public string id { get; set; }
Visual C++
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


stateTaxAmount Property

[image]

.NET Framework Class Library
TaxReplyItem..::.stateTaxAmount Property
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property stateTaxAmount As String
C#
public string stateTaxAmount { get; set; }
Visual C++
public:
property String^ stateTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stateTaxAmount();
function set_stateTaxAmount(value);

Remarks

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


totalTaxAmount Property

[image]

.NET Framework Class Library
TaxReplyItem..::.totalTaxAmount Property
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property totalTaxAmount As String
C#
public string totalTaxAmount { get; set; }
Visual C++
public:
property String^ totalTaxAmount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_totalTaxAmount();
function set_totalTaxAmount(value);

Remarks

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


TaxReplyItem Events

[image] [image]

.NET Framework Class Library
TaxReplyItem Events
TaxReplyItem Class See Also Send Feedback

The TaxReplyItem type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
TaxReplyItem..::.PropertyChanged Event
TaxReplyItem Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

TaxReplyItem Class
InSite.Domain.CyberSourceService Namespace


TaxService Class

[image]

.NET Framework Class Library
TaxService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class TaxService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class TaxService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class TaxService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.TaxService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.TaxService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.TaxService

See Also

TaxService Members
InSite.Domain.CyberSourceService Namespace


TaxService Members

[image] [image]

.NET Framework Class Library
TaxService Members
TaxService Class Constructors Methods Properties Events See Also Send Feedback

The TaxService type exposes the following members.

Constructors

Name | Description
TaxService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
buyerRegistration |
middlemanRegistration |
nexus |
noNexus |
orderAcceptanceCity |
orderAcceptanceCountry |
orderAcceptanceCounty |
orderAcceptancePostalCode |
orderAcceptanceState |
orderOriginCity |
orderOriginCountry |
orderOriginCounty |
orderOriginPostalCode |
orderOriginState |
pointOfTitleTransfer |
run |
sellerRegistration |

Events

Name | Description
PropertyChanged |

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


TaxService Constructor

[image]

.NET Framework Class Library
TaxService Constructor
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaxService()
Visual C++
public:
TaxService()
JavaScript
InSite.Domain.CyberSourceService.TaxService = function();

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


TaxService Methods

[image] [image]

.NET Framework Class Library
TaxService Methods
TaxService Class See Also Send Feedback

The TaxService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
TaxService..::.RaisePropertyChanged Method
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


TaxService Properties

[image] [image]

.NET Framework Class Library
TaxService Properties
TaxService Class See Also Send Feedback

The TaxService type exposes the following members.

Properties

Name | Description
buyerRegistration |
middlemanRegistration |
nexus |
noNexus |
orderAcceptanceCity |
orderAcceptanceCountry |
orderAcceptanceCounty |
orderAcceptancePostalCode |
orderAcceptanceState |
orderOriginCity |
orderOriginCountry |
orderOriginCounty |
orderOriginPostalCode |
orderOriginState |
pointOfTitleTransfer |
run |
sellerRegistration |

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


buyerRegistration Property

[image]

.NET Framework Class Library
TaxService..::.buyerRegistration Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property buyerRegistration As String
C#
public string buyerRegistration { get; set; }
Visual C++
public:
property String^ buyerRegistration {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_buyerRegistration();
function set_buyerRegistration(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


middlemanRegistration Property

[image]

.NET Framework Class Library
TaxService..::.middlemanRegistration Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property middlemanRegistration As String
C#
public string middlemanRegistration { get; set; }
Visual C++
public:
property String^ middlemanRegistration {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_middlemanRegistration();
function set_middlemanRegistration(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


nexus Property

[image]

.NET Framework Class Library
TaxService..::.nexus Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property nexus As String
C#
public string nexus { get; set; }
Visual C++
public:
property String^ nexus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nexus();
function set_nexus(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


noNexus Property

[image]

.NET Framework Class Library
TaxService..::.noNexus Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property noNexus As String
C#
public string noNexus { get; set; }
Visual C++
public:
property String^ noNexus {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_noNexus();
function set_noNexus(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderAcceptanceCity Property

[image]

.NET Framework Class Library
TaxService..::.orderAcceptanceCity Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptanceCity As String
C#
public string orderAcceptanceCity { get; set; }
Visual C++
public:
property String^ orderAcceptanceCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptanceCity();
function set_orderAcceptanceCity(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderAcceptanceCountry Property

[image]

.NET Framework Class Library
TaxService..::.orderAcceptanceCountry Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptanceCountry As String
C#
public string orderAcceptanceCountry { get; set; }
Visual C++
public:
property String^ orderAcceptanceCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptanceCountry();
function set_orderAcceptanceCountry(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderAcceptanceCounty Property

[image]

.NET Framework Class Library
TaxService..::.orderAcceptanceCounty Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptanceCounty As String
C#
public string orderAcceptanceCounty { get; set; }
Visual C++
public:
property String^ orderAcceptanceCounty {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptanceCounty();
function set_orderAcceptanceCounty(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderAcceptancePostalCode Property

[image]

.NET Framework Class Library
TaxService..::.orderAcceptancePostalCode Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptancePostalCode As String
C#
public string orderAcceptancePostalCode { get; set; }
Visual C++
public:
property String^ orderAcceptancePostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptancePostalCode();
function set_orderAcceptancePostalCode(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderAcceptanceState Property

[image]

.NET Framework Class Library
TaxService..::.orderAcceptanceState Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderAcceptanceState As String
C#
public string orderAcceptanceState { get; set; }
Visual C++
public:
property String^ orderAcceptanceState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderAcceptanceState();
function set_orderAcceptanceState(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderOriginCity Property

[image]

.NET Framework Class Library
TaxService..::.orderOriginCity Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginCity As String
C#
public string orderOriginCity { get; set; }
Visual C++
public:
property String^ orderOriginCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginCity();
function set_orderOriginCity(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderOriginCountry Property

[image]

.NET Framework Class Library
TaxService..::.orderOriginCountry Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginCountry As String
C#
public string orderOriginCountry { get; set; }
Visual C++
public:
property String^ orderOriginCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginCountry();
function set_orderOriginCountry(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderOriginCounty Property

[image]

.NET Framework Class Library
TaxService..::.orderOriginCounty Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginCounty As String
C#
public string orderOriginCounty { get; set; }
Visual C++
public:
property String^ orderOriginCounty {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginCounty();
function set_orderOriginCounty(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderOriginPostalCode Property

[image]

.NET Framework Class Library
TaxService..::.orderOriginPostalCode Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginPostalCode As String
C#
public string orderOriginPostalCode { get; set; }
Visual C++
public:
property String^ orderOriginPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginPostalCode();
function set_orderOriginPostalCode(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


orderOriginState Property

[image]

.NET Framework Class Library
TaxService..::.orderOriginState Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property orderOriginState As String
C#
public string orderOriginState { get; set; }
Visual C++
public:
property String^ orderOriginState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderOriginState();
function set_orderOriginState(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


pointOfTitleTransfer Property

[image]

.NET Framework Class Library
TaxService..::.pointOfTitleTransfer Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property pointOfTitleTransfer As String
C#
public string pointOfTitleTransfer { get; set; }
Visual C++
public:
property String^ pointOfTitleTransfer {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pointOfTitleTransfer();
function set_pointOfTitleTransfer(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
TaxService..::.run Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


sellerRegistration Property

[image]

.NET Framework Class Library
TaxService..::.sellerRegistration Property
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property sellerRegistration As String
C#
public string sellerRegistration { get; set; }
Visual C++
public:
property String^ sellerRegistration {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_sellerRegistration();
function set_sellerRegistration(value);

Remarks

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


TaxService Events

[image] [image]

.NET Framework Class Library
TaxService Events
TaxService Class See Also Send Feedback

The TaxService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
TaxService..::.PropertyChanged Event
TaxService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

TaxService Class
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Class

[image]

.NET Framework Class Library
TransactionProcessorClient Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")> _
Public Class TransactionProcessorClient _
    Inherits ClientBase(Of ITransactionProcessor) _
    Implements ITransactionProcessor
C#
[GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
public class TransactionProcessorClient : ClientBase<ITransactionProcessor>,
    ITransactionProcessor
Visual C++
[GeneratedCodeAttribute(L"System.ServiceModel", L"3.0.0.0")]
public ref class TransactionProcessorClient : public ClientBase<ITransactionProcessor^>,
    ITransactionProcessor
JavaScript
InSite.Domain.CyberSourceService.TransactionProcessorClient = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.TransactionProcessorClient',
    ClientBase`1,
    InSite.Domain.CyberSourceService.ITransactionProcessor);

Inheritance Hierarchy

System..::.Object
System.ServiceModel..::.ClientBase <(Of <( ITransactionProcessor >)>)
InSite.Domain.CyberSourceService..::.TransactionProcessorClient

See Also

TransactionProcessorClient Members
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Members

[image] [image]

.NET Framework Class Library
TransactionProcessorClient Members
TransactionProcessorClient Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The TransactionProcessorClient type exposes the following members.

Constructors

Name | Description
TransactionProcessorClient | Overloaded.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
Close | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
CreateChannel | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
DisplayInitializationUI | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeAsync | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
runTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ClientCredentials | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
Endpoint | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
State | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)

Events

Name Description

Explicit Interface Implementations

Name | Description
BeginClose | Overloaded.
BeginOpen | Overloaded.
ICommunicationObject..::.Close | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Closed | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Closing | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
IDisposable..::.Dispose | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.EndClose | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.EndOpen | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Faulted | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Open | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Opened | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Opening | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ITransactionProcessor..::.runTransaction |

See Also

TransactionProcessorClient Class
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Constructor

[image] [image]

.NET Framework Class Library
TransactionProcessorClient Constructor
TransactionProcessorClient Class See Also Send Feedback

Overload List

Name | Description
TransactionProcessorClient()()() |
TransactionProcessorClient(String) |
TransactionProcessorClient(Binding, EndpointAddress) |
TransactionProcessorClient(String, EndpointAddress) |
TransactionProcessorClient(String, String) |

See Also

TransactionProcessorClient Class
TransactionProcessorClient Members
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Constructor

[image]

.NET Framework Class Library
TransactionProcessorClient Constructor
TransactionProcessorClient Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TransactionProcessorClient()
Visual C++
public:
TransactionProcessorClient()
JavaScript
InSite.Domain.CyberSourceService.TransactionProcessorClient = function();

See Also

TransactionProcessorClient Class
TransactionProcessorClient Overload
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Constructor (String)

[image]

.NET Framework Class Library
TransactionProcessorClient Constructor (String)
TransactionProcessorClient Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String _
)
C#
public TransactionProcessorClient(
    string endpointConfigurationName
)
Visual C++
public:
TransactionProcessorClient(
    String^ endpointConfigurationName
)
JavaScript
InSite.Domain.CyberSourceService.TransactionProcessorClient = function(endpointConfigurationName);

Parameters

endpointConfigurationName
Type: System..::.String

See Also

TransactionProcessorClient Class
TransactionProcessorClient Overload
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Constructor (Binding, EndpointAddress)

[image]

.NET Framework Class Library
TransactionProcessorClient Constructor (Binding, EndpointAddress)
TransactionProcessorClient Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    binding As Binding, _
    remoteAddress As EndpointAddress _
)
C#
public TransactionProcessorClient(
    Binding binding,
    EndpointAddress remoteAddress
)
Visual C++
public:
TransactionProcessorClient(
    Binding^ binding,
    EndpointAddress^ remoteAddress
)
JavaScript
InSite.Domain.CyberSourceService.TransactionProcessorClient = function(binding, remoteAddress);

Parameters

binding
Type: System.ServiceModel.Channels..::.Binding
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

TransactionProcessorClient Class
TransactionProcessorClient Overload
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Constructor (String, EndpointAddress)

[image]

.NET Framework Class Library
TransactionProcessorClient Constructor (String, EndpointAddress)
TransactionProcessorClient Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As EndpointAddress _
)
C#
public TransactionProcessorClient(
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)
Visual C++
public:
TransactionProcessorClient(
    String^ endpointConfigurationName,
    EndpointAddress^ remoteAddress
)
JavaScript
InSite.Domain.CyberSourceService.TransactionProcessorClient = function(endpointConfigurationName, remoteAddress);

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

TransactionProcessorClient Class
TransactionProcessorClient Overload
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Constructor (String, String)

[image]

.NET Framework Class Library
TransactionProcessorClient Constructor (String, String)
TransactionProcessorClient Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As String _
)
C#
public TransactionProcessorClient(
    string endpointConfigurationName,
    string remoteAddress
)
Visual C++
public:
TransactionProcessorClient(
    String^ endpointConfigurationName,
    String^ remoteAddress
)
JavaScript
InSite.Domain.CyberSourceService.TransactionProcessorClient = function(endpointConfigurationName, remoteAddress);

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System..::.String

See Also

TransactionProcessorClient Class
TransactionProcessorClient Overload
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Methods

[image] [image]

.NET Framework Class Library
TransactionProcessorClient Methods
TransactionProcessorClient Class See Also Send Feedback

The TransactionProcessorClient type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
Close | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
CreateChannel | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
DisplayInitializationUI | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeAsync | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
runTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
BeginClose | Overloaded.
BeginOpen | Overloaded.
ICommunicationObject..::.Close | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
IDisposable..::.Dispose | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.EndClose | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.EndOpen | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Open | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ITransactionProcessor..::.runTransaction |

See Also

TransactionProcessorClient Class
InSite.Domain.CyberSourceService Namespace


BeginClose Method

[image] [image]

.NET Framework Class Library
TransactionProcessorClient..::.BeginClose Method
TransactionProcessorClient Class See Also Send Feedback

Overload List

Name | Description
ICommunicationObject..::.BeginClose(AsyncCallback, Object) | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.BeginClose(TimeSpan, AsyncCallback, Object) | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)

See Also

TransactionProcessorClient Class
TransactionProcessorClient Members
InSite.Domain.CyberSourceService Namespace


BeginOpen Method

[image] [image]

.NET Framework Class Library
TransactionProcessorClient..::.BeginOpen Method
TransactionProcessorClient Class See Also Send Feedback

Overload List

Name | Description
ICommunicationObject..::.BeginOpen(AsyncCallback, Object) | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.BeginOpen(TimeSpan, AsyncCallback, Object) | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)

See Also

TransactionProcessorClient Class
TransactionProcessorClient Members
InSite.Domain.CyberSourceService Namespace


ITransactionProcessor.runTransaction Method

[image]

.NET Framework Class Library
TransactionProcessorClient..::.ITransactionProcessor..::.runTransaction Method
TransactionProcessorClient Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Private Function runTransaction ( _
    request As inputMessageIn _
) As outputMessageOut Implements ITransactionProcessor.runTransaction
C#
outputMessageOut ITransactionProcessor.runTransaction(
    inputMessageIn request
)
Visual C++
private:
virtual outputMessageOut^ runTransaction(
    inputMessageIn^ request
) sealed = ITransactionProcessor::runTransaction
JavaScript
JavaScript does not support explicit interface implementations.

Parameters

request
Type: InSite.Domain.CyberSourceService..::.inputMessageIn

Implements

ITransactionProcessor..::.runTransaction(inputMessageIn)

See Also

TransactionProcessorClient Class
InSite.Domain.CyberSourceService Namespace


runTransaction Method

[image]

.NET Framework Class Library
TransactionProcessorClient..::.runTransaction Method
TransactionProcessorClient Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function runTransaction ( _
    requestMessage As RequestMessage _
) As ReplyMessage
C#
public ReplyMessage runTransaction(
    RequestMessage requestMessage
)
Visual C++
public:
ReplyMessage^ runTransaction(
    RequestMessage^ requestMessage
)
JavaScript
function runTransaction(requestMessage);

Parameters

requestMessage
Type: InSite.Domain.CyberSourceService..::.RequestMessage

See Also

TransactionProcessorClient Class
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Properties

[image] [image]

.NET Framework Class Library
TransactionProcessorClient Properties
TransactionProcessorClient Class See Also Send Feedback

The TransactionProcessorClient type exposes the following members.

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ClientCredentials | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
Endpoint | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
State | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)

See Also

TransactionProcessorClient Class
InSite.Domain.CyberSourceService Namespace


TransactionProcessorClient Events

[image] [image]

.NET Framework Class Library
TransactionProcessorClient Events
TransactionProcessorClient Class See Also Send Feedback

Events

Name Description

Explicit Interface Implementations

Name | Description
ICommunicationObject..::.Closed | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Closing | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Faulted | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Opened | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)
ICommunicationObject..::.Opening | (Inherited from ClientBase <(Of <( ITransactionProcessor >)>).)

See Also

TransactionProcessorClient Class
InSite.Domain.CyberSourceService Namespace


UCAF Class

[image]

.NET Framework Class Library
UCAF Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class UCAF _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class UCAF : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class UCAF : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.UCAF = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.UCAF',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.UCAF

See Also

UCAF Members
InSite.Domain.CyberSourceService Namespace


UCAF Members

[image] [image]

.NET Framework Class Library
UCAF Members
UCAF Class Constructors Methods Properties Events See Also Send Feedback

The UCAF type exposes the following members.

Constructors

Name | Description
UCAF |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
authenticationData |
collectionIndicator |

Events

Name | Description
PropertyChanged |

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


UCAF Constructor

[image]

.NET Framework Class Library
UCAF Constructor
UCAF Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UCAF()
Visual C++
public:
UCAF()
JavaScript
InSite.Domain.CyberSourceService.UCAF = function();

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


UCAF Methods

[image] [image]

.NET Framework Class Library
UCAF Methods
UCAF Class See Also Send Feedback

The UCAF type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
UCAF..::.RaisePropertyChanged Method
UCAF Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


UCAF Properties

[image] [image]

.NET Framework Class Library
UCAF Properties
UCAF Class See Also Send Feedback

The UCAF type exposes the following members.

Properties

Name | Description
authenticationData |
collectionIndicator |

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


authenticationData Property

[image]

.NET Framework Class Library
UCAF..::.authenticationData Property
UCAF Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property authenticationData As String
C#
public string authenticationData { get; set; }
Visual C++
public:
property String^ authenticationData {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authenticationData();
function set_authenticationData(value);

Remarks

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


collectionIndicator Property

[image]

.NET Framework Class Library
UCAF..::.collectionIndicator Property
UCAF Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property collectionIndicator As String
C#
public string collectionIndicator { get; set; }
Visual C++
public:
property String^ collectionIndicator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_collectionIndicator();
function set_collectionIndicator(value);

Remarks

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


UCAF Events

[image] [image]

.NET Framework Class Library
UCAF Events
UCAF Class See Also Send Feedback

The UCAF type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
UCAF..::.PropertyChanged Event
UCAF Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

UCAF Class
InSite.Domain.CyberSourceService Namespace


VoidReply Class

[image]

.NET Framework Class Library
VoidReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class VoidReply _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class VoidReply : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class VoidReply : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.VoidReply = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.VoidReply',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.VoidReply

See Also

VoidReply Members
InSite.Domain.CyberSourceService Namespace


VoidReply Members

[image] [image]

.NET Framework Class Library
VoidReply Members
VoidReply Class Constructors Methods Properties Events See Also Send Feedback

The VoidReply type exposes the following members.

Constructors

Name | Description
VoidReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
amount |
currency |
reasonCode |
requestDateTime |

Events

Name | Description
PropertyChanged |

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


VoidReply Constructor

[image]

.NET Framework Class Library
VoidReply Constructor
VoidReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VoidReply()
Visual C++
public:
VoidReply()
JavaScript
InSite.Domain.CyberSourceService.VoidReply = function();

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


VoidReply Methods

[image] [image]

.NET Framework Class Library
VoidReply Methods
VoidReply Class See Also Send Feedback

The VoidReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
VoidReply..::.RaisePropertyChanged Method
VoidReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


VoidReply Properties

[image] [image]

.NET Framework Class Library
VoidReply Properties
VoidReply Class See Also Send Feedback

The VoidReply type exposes the following members.

Properties

Name | Description
amount |
currency |
reasonCode |
requestDateTime |

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


amount Property

[image]

.NET Framework Class Library
VoidReply..::.amount Property
VoidReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property amount As String
C#
public string amount { get; set; }
Visual C++
public:
property String^ amount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


currency Property

[image]

.NET Framework Class Library
VoidReply..::.currency Property
VoidReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property currency As String
C#
public string currency { get; set; }
Visual C++
public:
property String^ currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


reasonCode Property

[image]

.NET Framework Class Library
VoidReply..::.reasonCode Property
VoidReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property reasonCode As String
C#
public string reasonCode { get; set; }
Visual C++
public:
property String^ reasonCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonCode();
function set_reasonCode(value);

Remarks

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


requestDateTime Property

[image]

.NET Framework Class Library
VoidReply..::.requestDateTime Property
VoidReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property requestDateTime As String
C#
public string requestDateTime { get; set; }
Visual C++
public:
property String^ requestDateTime {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestDateTime();
function set_requestDateTime(value);

Remarks

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


VoidReply Events

[image] [image]

.NET Framework Class Library
VoidReply Events
VoidReply Class See Also Send Feedback

The VoidReply type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
VoidReply..::.PropertyChanged Event
VoidReply Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

VoidReply Class
InSite.Domain.CyberSourceService Namespace


VoidService Class

[image]

.NET Framework Class Library
VoidService Class
Members See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class VoidService _
    Implements INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class VoidService : INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class VoidService : INotifyPropertyChanged
JavaScript
InSite.Domain.CyberSourceService.VoidService = function();

Type.createClass(
    'InSite.Domain.CyberSourceService.VoidService',
    null,
    INotifyPropertyChanged);

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.CyberSourceService..::.VoidService

See Also

VoidService Members
InSite.Domain.CyberSourceService Namespace


VoidService Members

[image] [image]

.NET Framework Class Library
VoidService Members
VoidService Class Constructors Methods Properties Events See Also Send Feedback

The VoidService type exposes the following members.

Constructors

Name | Description
VoidService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
run |
voidRequestID |
voidRequestToken |

Events

Name | Description
PropertyChanged |

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


VoidService Constructor

[image]

.NET Framework Class Library
VoidService Constructor
VoidService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VoidService()
Visual C++
public:
VoidService()
JavaScript
InSite.Domain.CyberSourceService.VoidService = function();

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


VoidService Methods

[image] [image]

.NET Framework Class Library
VoidService Methods
VoidService Class See Also Send Feedback

The VoidService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
VoidService..::.RaisePropertyChanged Method
VoidService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


VoidService Properties

[image] [image]

.NET Framework Class Library
VoidService Properties
VoidService Class See Also Send Feedback

The VoidService type exposes the following members.

Properties

Name | Description
run |
voidRequestID |
voidRequestToken |

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


run Property

[image]

.NET Framework Class Library
VoidService..::.run Property
VoidService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property run As String
C#
public string run { get; set; }
Visual C++
public:
property String^ run {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_run();
function set_run(value);

Remarks

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


voidRequestID Property

[image]

.NET Framework Class Library
VoidService..::.voidRequestID Property
VoidService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property voidRequestID As String
C#
public string voidRequestID { get; set; }
Visual C++
public:
property String^ voidRequestID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_voidRequestID();
function set_voidRequestID(value);

Remarks

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


voidRequestToken Property

[image]

.NET Framework Class Library
VoidService..::.voidRequestToken Property
VoidService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property voidRequestToken As String
C#
public string voidRequestToken { get; set; }
Visual C++
public:
property String^ voidRequestToken {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_voidRequestToken();
function set_voidRequestToken(value);

Remarks

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


VoidService Events

[image] [image]

.NET Framework Class Library
VoidService Events
VoidService Class See Also Send Feedback

The VoidService type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
VoidService..::.PropertyChanged Event
VoidService Class See Also Send Feedback

Namespace: InSite.Domain.CyberSourceService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

VoidService Class
InSite.Domain.CyberSourceService Namespace


InSite.Domain.Emails Namespace

[image]

.NET Framework Class Library
InSite.Domain.Emails Namespace
Send Feedback

Classes

Class | Description
BuildEmailValues_Generic |
EmailListProcessor |
ShipmentConfirmationEmail |


BuildEmailValues_Generic Class

[image]

.NET Framework Class Library
BuildEmailValues_Generic Class
Members See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class BuildEmailValues_Generic _
    Implements IBuildEmailValues
C#
public class BuildEmailValues_Generic : IBuildEmailValues
Visual C++
public ref class BuildEmailValues_Generic : IBuildEmailValues
JavaScript
InSite.Domain.Emails.BuildEmailValues_Generic = function();

Type.createClass(
    'InSite.Domain.Emails.BuildEmailValues_Generic',
    null,
    InSite.Model.IBuildEmailValues);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Emails..::.BuildEmailValues_Generic

See Also

BuildEmailValues_Generic Members
InSite.Domain.Emails Namespace


BuildEmailValues_Generic Members

[image] [image]

.NET Framework Class Library
BuildEmailValues_Generic Members
BuildEmailValues_Generic Class Constructors Methods See Also Send Feedback

The BuildEmailValues_Generic type exposes the following members.

Constructors

Name | Description
BuildEmailValues_Generic |

Methods

Name | Description
BuildOrderEmailToList |
BuildOrderEmailValues |
BuildShipmentEmailToList |
BuildShipmentEmailValues |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildEmailValues_Generic Class
InSite.Domain.Emails Namespace


BuildEmailValues_Generic Constructor

[image]

.NET Framework Class Library
BuildEmailValues_Generic Constructor
BuildEmailValues_Generic Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public BuildEmailValues_Generic()
Visual C++
public:
BuildEmailValues_Generic()
JavaScript
InSite.Domain.Emails.BuildEmailValues_Generic = function();

See Also

BuildEmailValues_Generic Class
InSite.Domain.Emails Namespace


BuildEmailValues_Generic Methods

[image] [image]

.NET Framework Class Library
BuildEmailValues_Generic Methods
BuildEmailValues_Generic Class See Also Send Feedback

The BuildEmailValues_Generic type exposes the following members.

Methods

Name | Description
BuildOrderEmailToList |
BuildOrderEmailValues |
BuildShipmentEmailToList |
BuildShipmentEmailValues |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildEmailValues_Generic Class
InSite.Domain.Emails Namespace


BuildOrderEmailToList Method

[image]

.NET Framework Class Library
BuildEmailValues_Generic..::.BuildOrderEmailToList Method
BuildEmailValues_Generic Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildOrderEmailToList ( _
    customerOrder As CustomerOrder _
) As String
C#
public virtual string BuildOrderEmailToList(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual String^ BuildOrderEmailToList(
    CustomerOrder^ customerOrder
)
JavaScript
function buildOrderEmailToList(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Implements

IBuildEmailValues..::.BuildOrderEmailToList(CustomerOrder)

See Also

BuildEmailValues_Generic Class
InSite.Domain.Emails Namespace


BuildOrderEmailValues Method

[image]

.NET Framework Class Library
BuildEmailValues_Generic..::.BuildOrderEmailValues Method
BuildEmailValues_Generic Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildOrderEmailValues ( _
    customerOrder As CustomerOrder _
) As NameValueCollection
C#
public virtual NameValueCollection BuildOrderEmailValues(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual NameValueCollection^ BuildOrderEmailValues(
    CustomerOrder^ customerOrder
)
JavaScript
function buildOrderEmailValues(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Implements

IBuildEmailValues..::.BuildOrderEmailValues(CustomerOrder)

See Also

BuildEmailValues_Generic Class
InSite.Domain.Emails Namespace


BuildShipmentEmailToList Method

[image]

.NET Framework Class Library
BuildEmailValues_Generic..::.BuildShipmentEmailToList Method
BuildEmailValues_Generic Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildShipmentEmailToList ( _
    shipment As Shipment _
) As String
C#
public virtual string BuildShipmentEmailToList(
    Shipment shipment
)
Visual C++
public:
virtual String^ BuildShipmentEmailToList(
    Shipment^ shipment
)
JavaScript
function buildShipmentEmailToList(shipment);

Parameters

shipment
Type: InSite.Model..::.Shipment

Implements

IBuildEmailValues..::.BuildShipmentEmailToList(Shipment)

See Also

BuildEmailValues_Generic Class
InSite.Domain.Emails Namespace


BuildShipmentEmailValues Method

[image]

.NET Framework Class Library
BuildEmailValues_Generic..::.BuildShipmentEmailValues Method
BuildEmailValues_Generic Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildShipmentEmailValues ( _
    shipment As Shipment _
) As NameValueCollection
C#
public virtual NameValueCollection BuildShipmentEmailValues(
    Shipment shipment
)
Visual C++
public:
virtual NameValueCollection^ BuildShipmentEmailValues(
    Shipment^ shipment
)
JavaScript
function buildShipmentEmailValues(shipment);

Parameters

shipment
Type: InSite.Model..::.Shipment

Implements

IBuildEmailValues..::.BuildShipmentEmailValues(Shipment)

See Also

BuildEmailValues_Generic Class
InSite.Domain.Emails Namespace


EmailListProcessor Class

[image]

.NET Framework Class Library
EmailListProcessor Class
Members See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class EmailListProcessor _
    Implements IEmailProcessor
C#
public class EmailListProcessor : IEmailProcessor
Visual C++
public ref class EmailListProcessor : IEmailProcessor
JavaScript
InSite.Domain.Emails.EmailListProcessor = function();

Type.createClass(
    'InSite.Domain.Emails.EmailListProcessor',
    null,
    InSite.Model.IEmailProcessor);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Emails..::.EmailListProcessor

See Also

EmailListProcessor Members
InSite.Domain.Emails Namespace


EmailListProcessor Members

[image] [image]

.NET Framework Class Library
EmailListProcessor Members
EmailListProcessor Class Constructors Methods Properties See Also Send Feedback

The EmailListProcessor type exposes the following members.

Constructors

Name | Description
EmailListProcessor | Overloaded.

Methods

Name | Description
AddTokenKeyValue | Add keys that will be replaced by values from the user. key should match the user property. "UserName" will find user.UserName.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Send | Overloaded.
SendEmail |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EmailList |

See Also

EmailListProcessor Class
InSite.Domain.Emails Namespace


EmailListProcessor Constructor

[image] [image]

.NET Framework Class Library
EmailListProcessor Constructor
EmailListProcessor Class See Also Send Feedback

Overload List

Name | Description
EmailListProcessor()()() |
EmailListProcessor(EmailList) |
EmailListProcessor(String) |

See Also

EmailListProcessor Class
EmailListProcessor Members
InSite.Domain.Emails Namespace


EmailListProcessor Constructor

[image]

.NET Framework Class Library
EmailListProcessor Constructor
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EmailListProcessor()
Visual C++
public:
EmailListProcessor()
JavaScript
InSite.Domain.Emails.EmailListProcessor = function();

See Also

EmailListProcessor Class
EmailListProcessor Overload
InSite.Domain.Emails Namespace


EmailListProcessor Constructor (EmailList)

[image]

.NET Framework Class Library
EmailListProcessor Constructor (EmailList)
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    emailList As EmailList _
)
C#
public EmailListProcessor(
    EmailList emailList
)
Visual C++
public:
EmailListProcessor(
    EmailList^ emailList
)
JavaScript
InSite.Domain.Emails.EmailListProcessor = function(emailList);

Parameters

emailList
Type: InSite.Model..::.EmailList

See Also

EmailListProcessor Class
EmailListProcessor Overload
InSite.Domain.Emails Namespace


EmailListProcessor Constructor (String)

[image]

.NET Framework Class Library
EmailListProcessor Constructor (String)
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    emailListName As String _
)
C#
public EmailListProcessor(
    string emailListName
)
Visual C++
public:
EmailListProcessor(
    String^ emailListName
)
JavaScript
InSite.Domain.Emails.EmailListProcessor = function(emailListName);

Parameters

emailListName
Type: System..::.String

See Also

EmailListProcessor Class
EmailListProcessor Overload
InSite.Domain.Emails Namespace


EmailListProcessor Methods

[image] [image]

.NET Framework Class Library
EmailListProcessor Methods
EmailListProcessor Class See Also Send Feedback

The EmailListProcessor type exposes the following members.

Methods

Name | Description
AddTokenKeyValue | Add keys that will be replaced by values from the user. key should match the user property. "UserName" will find user.UserName.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Send | Overloaded.
SendEmail |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailListProcessor Class
InSite.Domain.Emails Namespace


AddTokenKeyValue Method

[image]

.NET Framework Class Library
EmailListProcessor..::.AddTokenKeyValue Method
EmailListProcessor Class See Also Send Feedback

Add keys that will be replaced by values from the user. key should match the user property. "UserName" will find user.UserName.

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddTokenKeyValue ( _
    key As String _
)
C#
public void AddTokenKeyValue(
    string key
)
Visual C++
public:
void AddTokenKeyValue(
    String^ key
)
JavaScript
function addTokenKeyValue(key);

Parameters

key
Type: System..::.String

See Also

EmailListProcessor Class
InSite.Domain.Emails Namespace


Send Method

[image] [image]

.NET Framework Class Library
EmailListProcessor..::.Send Method
EmailListProcessor Class See Also Send Feedback

Overload List

Name | Description
Send(String, NameValueCollection) |
Send(String, String) |
Send(String, String, NameValueCollection) |
Send(String, String, String, NameValueCollection) |
Send(String, String, String, String) |
Send(String, String, String, NameValueCollection, Attachment) |

See Also

EmailListProcessor Class
EmailListProcessor Members
InSite.Domain.Emails Namespace


Send Method (String, NameValueCollection)

[image]

.NET Framework Class Library
EmailListProcessor..::.Send Method (String, NameValueCollection)
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Send ( _
    toAddress As String, _
    formData As NameValueCollection _
)
C#
public void Send(
    string toAddress,
    NameValueCollection formData
)
Visual C++
public:
void Send(
    String^ toAddress,
    NameValueCollection^ formData
)
JavaScript
function send(toAddress, formData);

Parameters

toAddress
Type: System..::.String
formData
Type: System.Collections.Specialized..::.NameValueCollection

See Also

EmailListProcessor Class
Send Overload
InSite.Domain.Emails Namespace


Send Method (String, String)

[image]

.NET Framework Class Library
EmailListProcessor..::.Send Method (String, String)
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Send ( _
    fromAddress As String, _
    subject As String _
)
C#
public void Send(
    string fromAddress,
    string subject
)
Visual C++
public:
void Send(
    String^ fromAddress,
    String^ subject
)
JavaScript
function send(fromAddress, subject);

Parameters

fromAddress
Type: System..::.String
subject
Type: System..::.String

See Also

EmailListProcessor Class
Send Overload
InSite.Domain.Emails Namespace


Send Method (String, String, NameValueCollection)

[image]

.NET Framework Class Library
EmailListProcessor..::.Send Method (String, String, NameValueCollection)
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Send ( _
    fromAddress As String, _
    subject As String, _
    formData As NameValueCollection _
)
C#
public void Send(
    string fromAddress,
    string subject,
    NameValueCollection formData
)
Visual C++
public:
void Send(
    String^ fromAddress,
    String^ subject,
    NameValueCollection^ formData
)
JavaScript
function send(fromAddress, subject, formData);

Parameters

fromAddress
Type: System..::.String
subject
Type: System..::.String
formData
Type: System.Collections.Specialized..::.NameValueCollection

See Also

EmailListProcessor Class
Send Overload
InSite.Domain.Emails Namespace


Send Method (String, String, String, NameValueCollection)

[image]

.NET Framework Class Library
EmailListProcessor..::.Send Method (String, String, String, NameValueCollection)
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Send ( _
    toAddress As String, _
    fromAddress As String, _
    subject As String, _
    formData As NameValueCollection _
)
C#
public void Send(
    string toAddress,
    string fromAddress,
    string subject,
    NameValueCollection formData
)
Visual C++
public:
void Send(
    String^ toAddress,
    String^ fromAddress,
    String^ subject,
    NameValueCollection^ formData
)
JavaScript
function send(toAddress, fromAddress, subject, formData);

Parameters

toAddress
Type: System..::.String
fromAddress
Type: System..::.String
subject
Type: System..::.String
formData
Type: System.Collections.Specialized..::.NameValueCollection

See Also

EmailListProcessor Class
Send Overload
InSite.Domain.Emails Namespace


Send Method (String, String, String, String)

[image]

.NET Framework Class Library
EmailListProcessor..::.Send Method (String, String, String, String)
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Send ( _
    toAddress As String, _
    fromAddress As String, _
    subject As String, _
    body As String _
)
C#
public void Send(
    string toAddress,
    string fromAddress,
    string subject,
    string body
)
Visual C++
public:
void Send(
    String^ toAddress,
    String^ fromAddress,
    String^ subject,
    String^ body
)
JavaScript
function send(toAddress, fromAddress, subject, body);

Parameters

toAddress
Type: System..::.String
fromAddress
Type: System..::.String
subject
Type: System..::.String
body
Type: System..::.String

See Also

EmailListProcessor Class
Send Overload
InSite.Domain.Emails Namespace


Send Method (String, String, String, NameValueCollection, Attachment)

[image]

.NET Framework Class Library
EmailListProcessor..::.Send Method (String, String, String, NameValueCollection, Attachment)
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Send ( _
    toAddress As String, _
    fromAddress As String, _
    subject As String, _
    formData As NameValueCollection, _
    attachment As Attachment _
)
C#
public void Send(
    string toAddress,
    string fromAddress,
    string subject,
    NameValueCollection formData,
    Attachment attachment
)
Visual C++
public:
void Send(
    String^ toAddress,
    String^ fromAddress,
    String^ subject,
    NameValueCollection^ formData,
    Attachment^ attachment
)
JavaScript
function send(toAddress, fromAddress, subject, formData, attachment);

Parameters

toAddress
Type: System..::.String
fromAddress
Type: System..::.String
subject
Type: System..::.String
formData
Type: System.Collections.Specialized..::.NameValueCollection
attachment
Type: System.Net.Mail..::.Attachment

See Also

EmailListProcessor Class
Send Overload
InSite.Domain.Emails Namespace


SendEmail Method

[image]

.NET Framework Class Library
EmailListProcessor..::.SendEmail Method
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SendEmail ( _
    toAddress As String, _
    fromAddress As String, _
    subject As String, _
    body As String _
)
C#
public void SendEmail(
    string toAddress,
    string fromAddress,
    string subject,
    string body
)
Visual C++
public:
virtual void SendEmail(
    String^ toAddress,
    String^ fromAddress,
    String^ subject,
    String^ body
) sealed
JavaScript
function sendEmail(toAddress, fromAddress, subject, body);

Parameters

toAddress
Type: System..::.String
fromAddress
Type: System..::.String
subject
Type: System..::.String
body
Type: System..::.String

Implements

IEmailProcessor..::.SendEmail(String, String, String, String)

See Also

EmailListProcessor Class
InSite.Domain.Emails Namespace


EmailListProcessor Properties

[image] [image]

.NET Framework Class Library
EmailListProcessor Properties
EmailListProcessor Class See Also Send Feedback

The EmailListProcessor type exposes the following members.

Properties

Name | Description
EmailList |

See Also

EmailListProcessor Class
InSite.Domain.Emails Namespace


EmailList Property

[image]

.NET Framework Class Library
EmailListProcessor..::.EmailList Property
EmailListProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EmailList As EmailList
C#
public virtual EmailList EmailList { get; set; }
Visual C++
public:
virtual property EmailList^ EmailList {
    EmailList^ get ();
    void set (EmailList^ value);
}
JavaScript
function get_emailList();
function set_emailList(value);

See Also

EmailListProcessor Class
InSite.Domain.Emails Namespace


ShipmentConfirmationEmail Class

[image]

.NET Framework Class Library
ShipmentConfirmationEmail Class
Members See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ShipmentConfirmationEmail
C#
public class ShipmentConfirmationEmail
Visual C++
public ref class ShipmentConfirmationEmail
JavaScript
InSite.Domain.Emails.ShipmentConfirmationEmail = function();

Type.createClass(
    'InSite.Domain.Emails.ShipmentConfirmationEmail');

Inheritance Hierarchy

System..::.Object
InSite.Domain.Emails..::.ShipmentConfirmationEmail

See Also

ShipmentConfirmationEmail Members
InSite.Domain.Emails Namespace


ShipmentConfirmationEmail Members

[image] [image]

.NET Framework Class Library
ShipmentConfirmationEmail Members
ShipmentConfirmationEmail Class Constructors Methods See Also Send Feedback

The ShipmentConfirmationEmail type exposes the following members.

Constructors

Name | Description
ShipmentConfirmationEmail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Send |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShipmentConfirmationEmail Class
InSite.Domain.Emails Namespace


ShipmentConfirmationEmail Constructor

[image]

.NET Framework Class Library
ShipmentConfirmationEmail Constructor
ShipmentConfirmationEmail Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipmentConfirmationEmail()
Visual C++
public:
ShipmentConfirmationEmail()
JavaScript
InSite.Domain.Emails.ShipmentConfirmationEmail = function();

See Also

ShipmentConfirmationEmail Class
InSite.Domain.Emails Namespace


ShipmentConfirmationEmail Methods

[image] [image]

.NET Framework Class Library
ShipmentConfirmationEmail Methods
ShipmentConfirmationEmail Class See Also Send Feedback

The ShipmentConfirmationEmail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Send |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShipmentConfirmationEmail Class
InSite.Domain.Emails Namespace


Send Method

[image]

.NET Framework Class Library
ShipmentConfirmationEmail..::.Send Method
ShipmentConfirmationEmail Class See Also Send Feedback

Namespace: InSite.Domain.Emails
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Send
C#
public static void Send()
Visual C++
public:
static void Send()
JavaScript
InSite.Domain.Emails.ShipmentConfirmationEmail.send = function();

See Also

ShipmentConfirmationEmail Class
InSite.Domain.Emails Namespace


InSite.Domain.ERPIntegration Namespace

[image]

.NET Framework Class Library
InSite.Domain.ERPIntegration Namespace
Send Feedback

Classes

Class | Description
ClientSpecificTasks_Generic |
CustomerOrderRefresh |
CustomerOrderUpdate_Generic |
CustomerRefresh |
CustomerUpdate_Generic |
DealerRefresh |
ExecuteQuery |
InventoryRefresh |
InvoiceRefresh |
PricingRefresh |
ProcessDataSet_Generic |
ProductRefresh_Generic |
ProductUpdate_Generic |
RefreshBase |
SalesmanRefresh |
ShipmentRefresh |

Interfaces

Interface | Description
IClientSpecificTasks |
ICustomerOrderUpdate |
ICustomerUpdate |
IProcessDataSet |
IProductRefresh |
IProductUpdate |


ClientSpecificTasks_Generic Class

[image]

.NET Framework Class Library
ClientSpecificTasks_Generic Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ClientSpecificTasks_Generic _
    Implements IClientSpecificTasks
C#
public class ClientSpecificTasks_Generic : IClientSpecificTasks
Visual C++
public ref class ClientSpecificTasks_Generic : IClientSpecificTasks
JavaScript
InSite.Domain.ERPIntegration.ClientSpecificTasks_Generic = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.ClientSpecificTasks_Generic',
    null,
    InSite.Domain.ERPIntegration.IClientSpecificTasks);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.ClientSpecificTasks_Generic

See Also

ClientSpecificTasks_Generic Members
InSite.Domain.ERPIntegration Namespace


ClientSpecificTasks_Generic Members

[image] [image]

.NET Framework Class Library
ClientSpecificTasks_Generic Members
ClientSpecificTasks_Generic Class Constructors Methods See Also Send Feedback

The ClientSpecificTasks_Generic type exposes the following members.

Constructors

Name | Description
ClientSpecificTasks_Generic |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteTasks |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientSpecificTasks_Generic Class
InSite.Domain.ERPIntegration Namespace


ClientSpecificTasks_Generic Constructor

[image]

.NET Framework Class Library
ClientSpecificTasks_Generic Constructor
ClientSpecificTasks_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ClientSpecificTasks_Generic()
Visual C++
public:
ClientSpecificTasks_Generic()
JavaScript
InSite.Domain.ERPIntegration.ClientSpecificTasks_Generic = function();

See Also

ClientSpecificTasks_Generic Class
InSite.Domain.ERPIntegration Namespace


ClientSpecificTasks_Generic Methods

[image] [image]

.NET Framework Class Library
ClientSpecificTasks_Generic Methods
ClientSpecificTasks_Generic Class See Also Send Feedback

The ClientSpecificTasks_Generic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
ExecuteTasks |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientSpecificTasks_Generic Class
InSite.Domain.ERPIntegration Namespace


ExecuteTasks Method

[image]

.NET Framework Class Library
ClientSpecificTasks_Generic..::.ExecuteTasks Method
ClientSpecificTasks_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ExecuteTasks
C#
public void ExecuteTasks()
Visual C++
public:
virtual void ExecuteTasks() sealed
JavaScript
function executeTasks();

Implements

IClientSpecificTasks..::.ExecuteTasks()()()

See Also

ClientSpecificTasks_Generic Class
InSite.Domain.ERPIntegration Namespace


CustomerOrderRefresh Class

[image]

.NET Framework Class Library
CustomerOrderRefresh Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class CustomerOrderRefresh _
    Inherits RefreshBase
C#
public class CustomerOrderRefresh : RefreshBase
Visual C++
public ref class CustomerOrderRefresh : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.CustomerOrderRefresh = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.CustomerOrderRefresh',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.CustomerOrderRefresh

See Also

CustomerOrderRefresh Members
InSite.Domain.ERPIntegration Namespace


CustomerOrderRefresh Members

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh Members
CustomerOrderRefresh Class Constructors Methods Properties See Also Send Feedback

The CustomerOrderRefresh type exposes the following members.

Constructors

Name | Description
CustomerOrderRefresh | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPackLists |
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshCustomerOrders | Overloaded.
ReSubmitOrders | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
SubmitOrder |
SubmitPayment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerOrderDataSet |
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

CustomerOrderRefresh Class
InSite.Domain.ERPIntegration Namespace


CustomerOrderRefresh Constructor

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh Constructor
CustomerOrderRefresh Class See Also Send Feedback

Overload List

Name | Description
CustomerOrderRefresh(WebSite) |
CustomerOrderRefresh(String) |

See Also

CustomerOrderRefresh Class
CustomerOrderRefresh Members
InSite.Domain.ERPIntegration Namespace


CustomerOrderRefresh Constructor (WebSite)

[image]

.NET Framework Class Library
CustomerOrderRefresh Constructor (WebSite)
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public CustomerOrderRefresh(
    WebSite webSite
)
Visual C++
public:
CustomerOrderRefresh(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.CustomerOrderRefresh = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

CustomerOrderRefresh Class
CustomerOrderRefresh Overload
InSite.Domain.ERPIntegration Namespace


CustomerOrderRefresh Constructor (String)

[image]

.NET Framework Class Library
CustomerOrderRefresh Constructor (String)
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSiteName As String _
)
C#
public CustomerOrderRefresh(
    string webSiteName
)
Visual C++
public:
CustomerOrderRefresh(
    String^ webSiteName
)
JavaScript
InSite.Domain.ERPIntegration.CustomerOrderRefresh = function(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

CustomerOrderRefresh Class
CustomerOrderRefresh Overload
InSite.Domain.ERPIntegration Namespace


CustomerOrderRefresh Methods

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh Methods
CustomerOrderRefresh Class See Also Send Feedback

The CustomerOrderRefresh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPackLists |
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshCustomerOrders | Overloaded.
ReSubmitOrders | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
SubmitOrder |
SubmitPayment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerOrderRefresh Class
InSite.Domain.ERPIntegration Namespace


GetPackLists Method

[image]

.NET Framework Class Library
CustomerOrderRefresh..::.GetPackLists Method
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function GetPackLists ( _
    orderNumber As String, _
    shipmentNumber As String _
) As DataSet
C#
public DataSet GetPackLists(
    string orderNumber,
    string shipmentNumber
)
Visual C++
public:
DataSet^ GetPackLists(
    String^ orderNumber,
    String^ shipmentNumber
)
JavaScript
function getPackLists(orderNumber, shipmentNumber);

Parameters

orderNumber
Type: System..::.String
shipmentNumber
Type: System..::.String

See Also

CustomerOrderRefresh Class
InSite.Domain.ERPIntegration Namespace


RefreshCustomerOrders Method

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh..::.RefreshCustomerOrders Method
CustomerOrderRefresh Class See Also Send Feedback

Overload List

Name | Description
RefreshCustomerOrders()()() |
RefreshCustomerOrders(String) |

See Also

CustomerOrderRefresh Class
CustomerOrderRefresh Members
InSite.Domain.ERPIntegration Namespace


RefreshCustomerOrders Method

[image]

.NET Framework Class Library
CustomerOrderRefresh..::.RefreshCustomerOrders Method
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshCustomerOrders
C#
public void RefreshCustomerOrders()
Visual C++
public:
void RefreshCustomerOrders()
JavaScript
function refreshCustomerOrders();

See Also

CustomerOrderRefresh Class
RefreshCustomerOrders Overload
InSite.Domain.ERPIntegration Namespace


RefreshCustomerOrders Method (String)

[image]

.NET Framework Class Library
CustomerOrderRefresh..::.RefreshCustomerOrders Method (String)
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshCustomerOrders ( _
    orderNumber As String _
)
C#
public void RefreshCustomerOrders(
    string orderNumber
)
Visual C++
public:
void RefreshCustomerOrders(
    String^ orderNumber
)
JavaScript
function refreshCustomerOrders(orderNumber);

Parameters

orderNumber
Type: System..::.String

See Also

CustomerOrderRefresh Class
RefreshCustomerOrders Overload
InSite.Domain.ERPIntegration Namespace


ReSubmitOrders Method

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh..::.ReSubmitOrders Method
CustomerOrderRefresh Class See Also Send Feedback

Overload List

Name | Description
ReSubmitOrders()()() |
ReSubmitOrders(Int32) |

See Also

CustomerOrderRefresh Class
CustomerOrderRefresh Members
InSite.Domain.ERPIntegration Namespace


ReSubmitOrders Method

[image]

.NET Framework Class Library
CustomerOrderRefresh..::.ReSubmitOrders Method
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReSubmitOrders
C#
public void ReSubmitOrders()
Visual C++
public:
void ReSubmitOrders()
JavaScript
function reSubmitOrders();

See Also

CustomerOrderRefresh Class
ReSubmitOrders Overload
InSite.Domain.ERPIntegration Namespace


ReSubmitOrders Method (Int32)

[image]

.NET Framework Class Library
CustomerOrderRefresh..::.ReSubmitOrders Method (Int32)
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReSubmitOrders ( _
    batchNumber As Integer _
)
C#
public void ReSubmitOrders(
    int batchNumber
)
Visual C++
public:
void ReSubmitOrders(
    int batchNumber
)
JavaScript
function reSubmitOrders(batchNumber);

Parameters

batchNumber
Type: System..::.Int32

See Also

CustomerOrderRefresh Class
ReSubmitOrders Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh..::.SaveDataSetIfNeeded Method
CustomerOrderRefresh Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

CustomerOrderRefresh Class
CustomerOrderRefresh Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh..::.SendErrorEmail Method
CustomerOrderRefresh Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

CustomerOrderRefresh Class
CustomerOrderRefresh Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh..::.Setup Method
CustomerOrderRefresh Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

CustomerOrderRefresh Class
CustomerOrderRefresh Members
InSite.Domain.ERPIntegration Namespace


SubmitOrder Method

[image]

.NET Framework Class Library
CustomerOrderRefresh..::.SubmitOrder Method
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitOrder ( _
    customerOrder As CustomerOrder _
)
C#
public void SubmitOrder(
    CustomerOrder customerOrder
)
Visual C++
public:
void SubmitOrder(
    CustomerOrder^ customerOrder
)
JavaScript
function submitOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

CustomerOrderRefresh Class
InSite.Domain.ERPIntegration Namespace


SubmitPayment Method

[image]

.NET Framework Class Library
CustomerOrderRefresh..::.SubmitPayment Method
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitPayment ( _
    creditCardTransaction As CreditCardTransaction _
)
C#
public void SubmitPayment(
    CreditCardTransaction creditCardTransaction
)
Visual C++
public:
void SubmitPayment(
    CreditCardTransaction^ creditCardTransaction
)
JavaScript
function submitPayment(creditCardTransaction);

Parameters

creditCardTransaction
Type: InSite.Model..::.CreditCardTransaction

See Also

CustomerOrderRefresh Class
InSite.Domain.ERPIntegration Namespace


CustomerOrderRefresh Properties

[image] [image]

.NET Framework Class Library
CustomerOrderRefresh Properties
CustomerOrderRefresh Class See Also Send Feedback

The CustomerOrderRefresh type exposes the following members.

Properties

Name | Description
CustomerOrderDataSet |
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

CustomerOrderRefresh Class
InSite.Domain.ERPIntegration Namespace


CustomerOrderDataSet Property

[image]

.NET Framework Class Library
CustomerOrderRefresh..::.CustomerOrderDataSet Property
CustomerOrderRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerOrderDataSet As DataSet
C#
public DataSet CustomerOrderDataSet { get; set; }
Visual C++
public:
property DataSet^ CustomerOrderDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_customerOrderDataSet();
function set_customerOrderDataSet(value);

See Also

CustomerOrderRefresh Class
InSite.Domain.ERPIntegration Namespace


CustomerOrderUpdate_Generic Class

[image]

.NET Framework Class Library
CustomerOrderUpdate_Generic Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class CustomerOrderUpdate_Generic _
    Implements ICustomerOrderUpdate
C#
public class CustomerOrderUpdate_Generic : ICustomerOrderUpdate
Visual C++
public ref class CustomerOrderUpdate_Generic : ICustomerOrderUpdate
JavaScript
InSite.Domain.ERPIntegration.CustomerOrderUpdate_Generic = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.CustomerOrderUpdate_Generic',
    null,
    InSite.Domain.ERPIntegration.ICustomerOrderUpdate);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.CustomerOrderUpdate_Generic

See Also

CustomerOrderUpdate_Generic Members
InSite.Domain.ERPIntegration Namespace


CustomerOrderUpdate_Generic Members

[image] [image]

.NET Framework Class Library
CustomerOrderUpdate_Generic Members
CustomerOrderUpdate_Generic Class Constructors Methods See Also Send Feedback

The CustomerOrderUpdate_Generic type exposes the following members.

Constructors

Name | Description
CustomerOrderUpdate_Generic |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update |
UpdateLine |

See Also

CustomerOrderUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


CustomerOrderUpdate_Generic Constructor

[image]

.NET Framework Class Library
CustomerOrderUpdate_Generic Constructor
CustomerOrderUpdate_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerOrderUpdate_Generic()
Visual C++
public:
CustomerOrderUpdate_Generic()
JavaScript
InSite.Domain.ERPIntegration.CustomerOrderUpdate_Generic = function();

See Also

CustomerOrderUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


CustomerOrderUpdate_Generic Methods

[image] [image]

.NET Framework Class Library
CustomerOrderUpdate_Generic Methods
CustomerOrderUpdate_Generic Class See Also Send Feedback

The CustomerOrderUpdate_Generic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update |
UpdateLine |

See Also

CustomerOrderUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


Update Method

[image]

.NET Framework Class Library
CustomerOrderUpdate_Generic..::.Update Method
CustomerOrderUpdate_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Update ( _
    customerOrder As CustomerOrder, _
    customerOrderDataRow As DataRow _
)
C#
public void Update(
    CustomerOrder customerOrder,
    DataRow customerOrderDataRow
)
Visual C++
public:
virtual void Update(
    CustomerOrder^ customerOrder,
    DataRow^ customerOrderDataRow
) sealed
JavaScript
function update(customerOrder, customerOrderDataRow);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customerOrderDataRow
Type: System.Data..::.DataRow

Implements

ICustomerOrderUpdate..::.Update(CustomerOrder, DataRow)

See Also

CustomerOrderUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


UpdateLine Method

[image]

.NET Framework Class Library
CustomerOrderUpdate_Generic..::.UpdateLine Method
CustomerOrderUpdate_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateLine ( _
    orderLine As OrderLine, _
    orderLineDataRow As DataRow _
)
C#
public void UpdateLine(
    OrderLine orderLine,
    DataRow orderLineDataRow
)
Visual C++
public:
virtual void UpdateLine(
    OrderLine^ orderLine,
    DataRow^ orderLineDataRow
) sealed
JavaScript
function updateLine(orderLine, orderLineDataRow);

Parameters

orderLine
Type: InSite.Model..::.OrderLine
orderLineDataRow
Type: System.Data..::.DataRow

Implements

ICustomerOrderUpdate..::.UpdateLine(OrderLine, DataRow)

See Also

CustomerOrderUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


CustomerRefresh Class

[image]

.NET Framework Class Library
CustomerRefresh Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class CustomerRefresh _
    Inherits RefreshBase
C#
public class CustomerRefresh : RefreshBase
Visual C++
public ref class CustomerRefresh : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.CustomerRefresh = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.CustomerRefresh',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.CustomerRefresh

See Also

CustomerRefresh Members
InSite.Domain.ERPIntegration Namespace


CustomerRefresh Members

[image] [image]

.NET Framework Class Library
CustomerRefresh Members
CustomerRefresh Class Constructors Methods Properties See Also Send Feedback

The CustomerRefresh type exposes the following members.

Constructors

Name | Description
CustomerRefresh | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshCustomers | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerDataSet |
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

CustomerRefresh Class
InSite.Domain.ERPIntegration Namespace


CustomerRefresh Constructor

[image] [image]

.NET Framework Class Library
CustomerRefresh Constructor
CustomerRefresh Class See Also Send Feedback

Overload List

Name | Description
CustomerRefresh()()() |
CustomerRefresh(WebSite) |
CustomerRefresh(String) |

See Also

CustomerRefresh Class
CustomerRefresh Members
InSite.Domain.ERPIntegration Namespace


CustomerRefresh Constructor

[image]

.NET Framework Class Library
CustomerRefresh Constructor
CustomerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerRefresh()
Visual C++
public:
CustomerRefresh()
JavaScript
InSite.Domain.ERPIntegration.CustomerRefresh = function();

See Also

CustomerRefresh Class
CustomerRefresh Overload
InSite.Domain.ERPIntegration Namespace


CustomerRefresh Constructor (WebSite)

[image]

.NET Framework Class Library
CustomerRefresh Constructor (WebSite)
CustomerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public CustomerRefresh(
    WebSite webSite
)
Visual C++
public:
CustomerRefresh(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.CustomerRefresh = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

CustomerRefresh Class
CustomerRefresh Overload
InSite.Domain.ERPIntegration Namespace


CustomerRefresh Constructor (String)

[image]

.NET Framework Class Library
CustomerRefresh Constructor (String)
CustomerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSiteName As String _
)
C#
public CustomerRefresh(
    string webSiteName
)
Visual C++
public:
CustomerRefresh(
    String^ webSiteName
)
JavaScript
InSite.Domain.ERPIntegration.CustomerRefresh = function(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

CustomerRefresh Class
CustomerRefresh Overload
InSite.Domain.ERPIntegration Namespace


CustomerRefresh Methods

[image] [image]

.NET Framework Class Library
CustomerRefresh Methods
CustomerRefresh Class See Also Send Feedback

The CustomerRefresh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshCustomers | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerRefresh Class
InSite.Domain.ERPIntegration Namespace


RefreshCustomers Method

[image] [image]

.NET Framework Class Library
CustomerRefresh..::.RefreshCustomers Method
CustomerRefresh Class See Also Send Feedback

Overload List

Name | Description
RefreshCustomers()()() |
RefreshCustomers(String) |

See Also

CustomerRefresh Class
CustomerRefresh Members
InSite.Domain.ERPIntegration Namespace


RefreshCustomers Method

[image]

.NET Framework Class Library
CustomerRefresh..::.RefreshCustomers Method
CustomerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshCustomers
C#
public void RefreshCustomers()
Visual C++
public:
void RefreshCustomers()
JavaScript
function refreshCustomers();

See Also

CustomerRefresh Class
RefreshCustomers Overload
InSite.Domain.ERPIntegration Namespace


RefreshCustomers Method (String)

[image]

.NET Framework Class Library
CustomerRefresh..::.RefreshCustomers Method (String)
CustomerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshCustomers ( _
    customerNumber As String _
)
C#
public void RefreshCustomers(
    string customerNumber
)
Visual C++
public:
void RefreshCustomers(
    String^ customerNumber
)
JavaScript
function refreshCustomers(customerNumber);

Parameters

customerNumber
Type: System..::.String

See Also

CustomerRefresh Class
RefreshCustomers Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
CustomerRefresh..::.SaveDataSetIfNeeded Method
CustomerRefresh Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

CustomerRefresh Class
CustomerRefresh Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
CustomerRefresh..::.SendErrorEmail Method
CustomerRefresh Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

CustomerRefresh Class
CustomerRefresh Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
CustomerRefresh..::.Setup Method
CustomerRefresh Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

CustomerRefresh Class
CustomerRefresh Members
InSite.Domain.ERPIntegration Namespace


CustomerRefresh Properties

[image] [image]

.NET Framework Class Library
CustomerRefresh Properties
CustomerRefresh Class See Also Send Feedback

The CustomerRefresh type exposes the following members.

Properties

Name | Description
CustomerDataSet |
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

CustomerRefresh Class
InSite.Domain.ERPIntegration Namespace


CustomerDataSet Property

[image]

.NET Framework Class Library
CustomerRefresh..::.CustomerDataSet Property
CustomerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerDataSet As DataSet
C#
public DataSet CustomerDataSet { get; set; }
Visual C++
public:
property DataSet^ CustomerDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_customerDataSet();
function set_customerDataSet(value);

See Also

CustomerRefresh Class
InSite.Domain.ERPIntegration Namespace


CustomerUpdate_Generic Class

[image]

.NET Framework Class Library
CustomerUpdate_Generic Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class CustomerUpdate_Generic _
    Implements ICustomerUpdate
C#
public class CustomerUpdate_Generic : ICustomerUpdate
Visual C++
public ref class CustomerUpdate_Generic : ICustomerUpdate
JavaScript
InSite.Domain.ERPIntegration.CustomerUpdate_Generic = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.CustomerUpdate_Generic',
    null,
    InSite.Domain.ERPIntegration.ICustomerUpdate);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.CustomerUpdate_Generic

See Also

CustomerUpdate_Generic Members
InSite.Domain.ERPIntegration Namespace


CustomerUpdate_Generic Members

[image] [image]

.NET Framework Class Library
CustomerUpdate_Generic Members
CustomerUpdate_Generic Class Constructors Methods See Also Send Feedback

The CustomerUpdate_Generic type exposes the following members.

Constructors

Name | Description
CustomerUpdate_Generic |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update |

See Also

CustomerUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


CustomerUpdate_Generic Constructor

[image]

.NET Framework Class Library
CustomerUpdate_Generic Constructor
CustomerUpdate_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerUpdate_Generic()
Visual C++
public:
CustomerUpdate_Generic()
JavaScript
InSite.Domain.ERPIntegration.CustomerUpdate_Generic = function();

See Also

CustomerUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


CustomerUpdate_Generic Methods

[image] [image]

.NET Framework Class Library
CustomerUpdate_Generic Methods
CustomerUpdate_Generic Class See Also Send Feedback

The CustomerUpdate_Generic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update |

See Also

CustomerUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


Update Method

[image]

.NET Framework Class Library
CustomerUpdate_Generic..::.Update Method
CustomerUpdate_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Update ( _
    customer As Customer, _
    customerDataRow As DataRow, _
    salesmen As List(Of Salesman) _
)
C#
public virtual void Update(
    Customer customer,
    DataRow customerDataRow,
    List<Salesman> salesmen
)
Visual C++
public:
virtual void Update(
    Customer^ customer,
    DataRow^ customerDataRow,
    List<Salesman^>^ salesmen
)
JavaScript
function update(customer, customerDataRow, salesmen);

Parameters

customer
Type: InSite.Model..::.Customer
customerDataRow
Type: System.Data..::.DataRow
salesmen
Type: System.Collections.Generic..::.List <(Of <( Salesman >)>)

Implements

ICustomerUpdate..::.Update(Customer, DataRow, List<(Of <(Salesman>)>))

See Also

CustomerUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


DealerRefresh Class

[image]

.NET Framework Class Library
DealerRefresh Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class DealerRefresh _
    Inherits RefreshBase
C#
public class DealerRefresh : RefreshBase
Visual C++
public ref class DealerRefresh : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.DealerRefresh = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.DealerRefresh',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.DealerRefresh

See Also

DealerRefresh Members
InSite.Domain.ERPIntegration Namespace


DealerRefresh Members

[image] [image]

.NET Framework Class Library
DealerRefresh Members
DealerRefresh Class Constructors Methods Properties See Also Send Feedback

The DealerRefresh type exposes the following members.

Constructors

Name | Description
DealerRefresh | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshDealers |
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DealerDataSet |
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

DealerRefresh Class
InSite.Domain.ERPIntegration Namespace


DealerRefresh Constructor

[image] [image]

.NET Framework Class Library
DealerRefresh Constructor
DealerRefresh Class See Also Send Feedback

Overload List

Name | Description
DealerRefresh(WebSite) |
DealerRefresh(String) |

See Also

DealerRefresh Class
DealerRefresh Members
InSite.Domain.ERPIntegration Namespace


DealerRefresh Constructor (WebSite)

[image]

.NET Framework Class Library
DealerRefresh Constructor (WebSite)
DealerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public DealerRefresh(
    WebSite webSite
)
Visual C++
public:
DealerRefresh(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.DealerRefresh = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

DealerRefresh Class
DealerRefresh Overload
InSite.Domain.ERPIntegration Namespace


DealerRefresh Constructor (String)

[image]

.NET Framework Class Library
DealerRefresh Constructor (String)
DealerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSiteName As String _
)
C#
public DealerRefresh(
    string webSiteName
)
Visual C++
public:
DealerRefresh(
    String^ webSiteName
)
JavaScript
InSite.Domain.ERPIntegration.DealerRefresh = function(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

DealerRefresh Class
DealerRefresh Overload
InSite.Domain.ERPIntegration Namespace


DealerRefresh Methods

[image] [image]

.NET Framework Class Library
DealerRefresh Methods
DealerRefresh Class See Also Send Feedback

The DealerRefresh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshDealers |
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DealerRefresh Class
InSite.Domain.ERPIntegration Namespace


RefreshDealers Method

[image]

.NET Framework Class Library
DealerRefresh..::.RefreshDealers Method
DealerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshDealers
C#
public void RefreshDealers()
Visual C++
public:
void RefreshDealers()
JavaScript
function refreshDealers();

See Also

DealerRefresh Class
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
DealerRefresh..::.SaveDataSetIfNeeded Method
DealerRefresh Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

DealerRefresh Class
DealerRefresh Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
DealerRefresh..::.SendErrorEmail Method
DealerRefresh Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

DealerRefresh Class
DealerRefresh Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
DealerRefresh..::.Setup Method
DealerRefresh Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

DealerRefresh Class
DealerRefresh Members
InSite.Domain.ERPIntegration Namespace


DealerRefresh Properties

[image] [image]

.NET Framework Class Library
DealerRefresh Properties
DealerRefresh Class See Also Send Feedback

The DealerRefresh type exposes the following members.

Properties

Name | Description
DealerDataSet |
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

DealerRefresh Class
InSite.Domain.ERPIntegration Namespace


DealerDataSet Property

[image]

.NET Framework Class Library
DealerRefresh..::.DealerDataSet Property
DealerRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DealerDataSet As DataSet
C#
public DataSet DealerDataSet { get; set; }
Visual C++
public:
property DataSet^ DealerDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_dealerDataSet();
function set_dealerDataSet(value);

See Also

DealerRefresh Class
InSite.Domain.ERPIntegration Namespace


ExecuteQuery Class

[image]

.NET Framework Class Library
ExecuteQuery Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ExecuteQuery _
    Inherits RefreshBase
C#
public class ExecuteQuery : RefreshBase
Visual C++
public ref class ExecuteQuery : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.ExecuteQuery = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.ExecuteQuery',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.ExecuteQuery

See Also

ExecuteQuery Members
InSite.Domain.ERPIntegration Namespace


ExecuteQuery Members

[image] [image]

.NET Framework Class Library
ExecuteQuery Members
ExecuteQuery Class Constructors Methods Properties See Also Send Feedback

The ExecuteQuery type exposes the following members.

Constructors

Name | Description
ExecuteQuery | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
ResultDataSet |
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

ExecuteQuery Class
InSite.Domain.ERPIntegration Namespace


ExecuteQuery Constructor

[image] [image]

.NET Framework Class Library
ExecuteQuery Constructor
ExecuteQuery Class See Also Send Feedback

Overload List

Name | Description
ExecuteQuery(WebSite) |
ExecuteQuery(String) |

See Also

ExecuteQuery Class
ExecuteQuery Members
InSite.Domain.ERPIntegration Namespace


ExecuteQuery Constructor (WebSite)

[image]

.NET Framework Class Library
ExecuteQuery Constructor (WebSite)
ExecuteQuery Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public ExecuteQuery(
    WebSite webSite
)
Visual C++
public:
ExecuteQuery(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.ExecuteQuery = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

ExecuteQuery Class
ExecuteQuery Overload
InSite.Domain.ERPIntegration Namespace


ExecuteQuery Constructor (String)

[image]

.NET Framework Class Library
ExecuteQuery Constructor (String)
ExecuteQuery Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSiteName As String _
)
C#
public ExecuteQuery(
    string webSiteName
)
Visual C++
public:
ExecuteQuery(
    String^ webSiteName
)
JavaScript
InSite.Domain.ERPIntegration.ExecuteQuery = function(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

ExecuteQuery Class
ExecuteQuery Overload
InSite.Domain.ERPIntegration Namespace


ExecuteQuery Methods

[image] [image]

.NET Framework Class Library
ExecuteQuery Methods
ExecuteQuery Class See Also Send Feedback

The ExecuteQuery type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Execute |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecuteQuery Class
InSite.Domain.ERPIntegration Namespace


Execute Method

[image]

.NET Framework Class Library
ExecuteQuery..::.Execute Method
ExecuteQuery Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Execute ( _
    query As String _
)
C#
public void Execute(
    string query
)
Visual C++
public:
void Execute(
    String^ query
)
JavaScript
function execute(query);

Parameters

query
Type: System..::.String

See Also

ExecuteQuery Class
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
ExecuteQuery..::.SaveDataSetIfNeeded Method
ExecuteQuery Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

ExecuteQuery Class
ExecuteQuery Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
ExecuteQuery..::.SendErrorEmail Method
ExecuteQuery Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

ExecuteQuery Class
ExecuteQuery Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
ExecuteQuery..::.Setup Method
ExecuteQuery Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

ExecuteQuery Class
ExecuteQuery Members
InSite.Domain.ERPIntegration Namespace


ExecuteQuery Properties

[image] [image]

.NET Framework Class Library
ExecuteQuery Properties
ExecuteQuery Class See Also Send Feedback

The ExecuteQuery type exposes the following members.

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
ResultDataSet |
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

ExecuteQuery Class
InSite.Domain.ERPIntegration Namespace


ResultDataSet Property

[image]

.NET Framework Class Library
ExecuteQuery..::.ResultDataSet Property
ExecuteQuery Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ResultDataSet As DataSet
C#
public DataSet ResultDataSet { get; set; }
Visual C++
public:
property DataSet^ ResultDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_resultDataSet();
function set_resultDataSet(value);

See Also

ExecuteQuery Class
InSite.Domain.ERPIntegration Namespace


IClientSpecificTasks Interface

[image]

.NET Framework Class Library
IClientSpecificTasks Interface
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface IClientSpecificTasks
C#
public interface IClientSpecificTasks
Visual C++
public interface class IClientSpecificTasks
JavaScript
InSite.Domain.ERPIntegration.IClientSpecificTasks = function();
InSite.Domain.ERPIntegration.IClientSpecificTasks.createInterface('InSite.Domain.ERPIntegration.IClientSpecificTasks');

See Also

IClientSpecificTasks Members
InSite.Domain.ERPIntegration Namespace


IClientSpecificTasks Members

[image] [image]

.NET Framework Class Library
IClientSpecificTasks Members
IClientSpecificTasks Interface Methods See Also Send Feedback

The IClientSpecificTasks type exposes the following members.

Methods

Name | Description
ExecuteTasks |

See Also

IClientSpecificTasks Interface
InSite.Domain.ERPIntegration Namespace


IClientSpecificTasks Methods

[image] [image]

.NET Framework Class Library
IClientSpecificTasks Methods
IClientSpecificTasks Interface See Also Send Feedback

The IClientSpecificTasks type exposes the following members.

Methods

Name | Description
ExecuteTasks |

See Also

IClientSpecificTasks Interface
InSite.Domain.ERPIntegration Namespace


ExecuteTasks Method

[image]

.NET Framework Class Library
IClientSpecificTasks..::.ExecuteTasks Method
IClientSpecificTasks Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub ExecuteTasks
C#
void ExecuteTasks()
Visual C++
void ExecuteTasks()
JavaScript
function executeTasks();

See Also

IClientSpecificTasks Interface
InSite.Domain.ERPIntegration Namespace


ICustomerOrderUpdate Interface

[image]

.NET Framework Class Library
ICustomerOrderUpdate Interface
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICustomerOrderUpdate
C#
public interface ICustomerOrderUpdate
Visual C++
public interface class ICustomerOrderUpdate
JavaScript
InSite.Domain.ERPIntegration.ICustomerOrderUpdate = function();
InSite.Domain.ERPIntegration.ICustomerOrderUpdate.createInterface('InSite.Domain.ERPIntegration.ICustomerOrderUpdate');

See Also

ICustomerOrderUpdate Members
InSite.Domain.ERPIntegration Namespace


ICustomerOrderUpdate Members

[image] [image]

.NET Framework Class Library
ICustomerOrderUpdate Members
ICustomerOrderUpdate Interface Methods See Also Send Feedback

The ICustomerOrderUpdate type exposes the following members.

Methods

Name | Description
Update |
UpdateLine |

See Also

ICustomerOrderUpdate Interface
InSite.Domain.ERPIntegration Namespace


ICustomerOrderUpdate Methods

[image] [image]

.NET Framework Class Library
ICustomerOrderUpdate Methods
ICustomerOrderUpdate Interface See Also Send Feedback

The ICustomerOrderUpdate type exposes the following members.

Methods

Name | Description
Update |
UpdateLine |

See Also

ICustomerOrderUpdate Interface
InSite.Domain.ERPIntegration Namespace


Update Method

[image]

.NET Framework Class Library
ICustomerOrderUpdate..::.Update Method
ICustomerOrderUpdate Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub Update ( _
    customerOrder As CustomerOrder, _
    customerOrderDataRow As DataRow _
)
C#
void Update(
    CustomerOrder customerOrder,
    DataRow customerOrderDataRow
)
Visual C++
void Update(
    CustomerOrder^ customerOrder,
    DataRow^ customerOrderDataRow
)
JavaScript
function update(customerOrder, customerOrderDataRow);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customerOrderDataRow
Type: System.Data..::.DataRow

See Also

ICustomerOrderUpdate Interface
InSite.Domain.ERPIntegration Namespace


UpdateLine Method

[image]

.NET Framework Class Library
ICustomerOrderUpdate..::.UpdateLine Method
ICustomerOrderUpdate Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub UpdateLine ( _
    orderLine As OrderLine, _
    orderLineDataRow As DataRow _
)
C#
void UpdateLine(
    OrderLine orderLine,
    DataRow orderLineDataRow
)
Visual C++
void UpdateLine(
    OrderLine^ orderLine,
    DataRow^ orderLineDataRow
)
JavaScript
function updateLine(orderLine, orderLineDataRow);

Parameters

orderLine
Type: InSite.Model..::.OrderLine
orderLineDataRow
Type: System.Data..::.DataRow

See Also

ICustomerOrderUpdate Interface
InSite.Domain.ERPIntegration Namespace


ICustomerUpdate Interface

[image]

.NET Framework Class Library
ICustomerUpdate Interface
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICustomerUpdate
C#
public interface ICustomerUpdate
Visual C++
public interface class ICustomerUpdate
JavaScript
InSite.Domain.ERPIntegration.ICustomerUpdate = function();
InSite.Domain.ERPIntegration.ICustomerUpdate.createInterface('InSite.Domain.ERPIntegration.ICustomerUpdate');

See Also

ICustomerUpdate Members
InSite.Domain.ERPIntegration Namespace


ICustomerUpdate Members

[image] [image]

.NET Framework Class Library
ICustomerUpdate Members
ICustomerUpdate Interface Methods See Also Send Feedback

The ICustomerUpdate type exposes the following members.

Methods

Name | Description
Update |

See Also

ICustomerUpdate Interface
InSite.Domain.ERPIntegration Namespace


ICustomerUpdate Methods

[image] [image]

.NET Framework Class Library
ICustomerUpdate Methods
ICustomerUpdate Interface See Also Send Feedback

The ICustomerUpdate type exposes the following members.

Methods

Name | Description
Update |

See Also

ICustomerUpdate Interface
InSite.Domain.ERPIntegration Namespace


Update Method

[image]

.NET Framework Class Library
ICustomerUpdate..::.Update Method
ICustomerUpdate Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub Update ( _
    customer As Customer, _
    customerDataRow As DataRow, _
    salesmen As List(Of Salesman) _
)
C#
void Update(
    Customer customer,
    DataRow customerDataRow,
    List<Salesman> salesmen
)
Visual C++
void Update(
    Customer^ customer,
    DataRow^ customerDataRow,
    List<Salesman^>^ salesmen
)
JavaScript
function update(customer, customerDataRow, salesmen);

Parameters

customer
Type: InSite.Model..::.Customer
customerDataRow
Type: System.Data..::.DataRow
salesmen
Type: System.Collections.Generic..::.List <(Of <( Salesman >)>)

See Also

ICustomerUpdate Interface
InSite.Domain.ERPIntegration Namespace


InventoryRefresh Class

[image]

.NET Framework Class Library
InventoryRefresh Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class InventoryRefresh _
    Inherits RefreshBase
C#
public class InventoryRefresh : RefreshBase
Visual C++
public ref class InventoryRefresh : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.InventoryRefresh = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.InventoryRefresh',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.InventoryRefresh

See Also

InventoryRefresh Members
InSite.Domain.ERPIntegration Namespace


InventoryRefresh Members

[image] [image]

.NET Framework Class Library
InventoryRefresh Members
InventoryRefresh Class Constructors Methods Properties See Also Send Feedback

The InventoryRefresh type exposes the following members.

Constructors

Name | Description
InventoryRefresh | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshInventory | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
InventoryDataSet |
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

InventoryRefresh Class
InSite.Domain.ERPIntegration Namespace


InventoryRefresh Constructor

[image] [image]

.NET Framework Class Library
InventoryRefresh Constructor
InventoryRefresh Class See Also Send Feedback

Overload List

Name | Description
InventoryRefresh(WebSite) |
InventoryRefresh(String) |

See Also

InventoryRefresh Class
InventoryRefresh Members
InSite.Domain.ERPIntegration Namespace


InventoryRefresh Constructor (WebSite)

[image]

.NET Framework Class Library
InventoryRefresh Constructor (WebSite)
InventoryRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public InventoryRefresh(
    WebSite webSite
)
Visual C++
public:
InventoryRefresh(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.InventoryRefresh = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

InventoryRefresh Class
InventoryRefresh Overload
InSite.Domain.ERPIntegration Namespace


InventoryRefresh Constructor (String)

[image]

.NET Framework Class Library
InventoryRefresh Constructor (String)
InventoryRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSiteName As String _
)
C#
public InventoryRefresh(
    string webSiteName
)
Visual C++
public:
InventoryRefresh(
    String^ webSiteName
)
JavaScript
InSite.Domain.ERPIntegration.InventoryRefresh = function(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

InventoryRefresh Class
InventoryRefresh Overload
InSite.Domain.ERPIntegration Namespace


InventoryRefresh Methods

[image] [image]

.NET Framework Class Library
InventoryRefresh Methods
InventoryRefresh Class See Also Send Feedback

The InventoryRefresh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshInventory | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InventoryRefresh Class
InSite.Domain.ERPIntegration Namespace


RefreshInventory Method

[image] [image]

.NET Framework Class Library
InventoryRefresh..::.RefreshInventory Method
InventoryRefresh Class See Also Send Feedback

Overload List

Name | Description
RefreshInventory()()() |
RefreshInventory(String) |

See Also

InventoryRefresh Class
InventoryRefresh Members
InSite.Domain.ERPIntegration Namespace


RefreshInventory Method

[image]

.NET Framework Class Library
InventoryRefresh..::.RefreshInventory Method
InventoryRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshInventory
C#
public void RefreshInventory()
Visual C++
public:
void RefreshInventory()
JavaScript
function refreshInventory();

See Also

InventoryRefresh Class
RefreshInventory Overload
InSite.Domain.ERPIntegration Namespace


RefreshInventory Method (String)

[image]

.NET Framework Class Library
InventoryRefresh..::.RefreshInventory Method (String)
InventoryRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshInventory ( _
    erpNumber As String _
)
C#
public void RefreshInventory(
    string erpNumber
)
Visual C++
public:
void RefreshInventory(
    String^ erpNumber
)
JavaScript
function refreshInventory(erpNumber);

Parameters

erpNumber
Type: System..::.String

See Also

InventoryRefresh Class
RefreshInventory Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
InventoryRefresh..::.SaveDataSetIfNeeded Method
InventoryRefresh Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

InventoryRefresh Class
InventoryRefresh Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
InventoryRefresh..::.SendErrorEmail Method
InventoryRefresh Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

InventoryRefresh Class
InventoryRefresh Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
InventoryRefresh..::.Setup Method
InventoryRefresh Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

InventoryRefresh Class
InventoryRefresh Members
InSite.Domain.ERPIntegration Namespace


InventoryRefresh Properties

[image] [image]

.NET Framework Class Library
InventoryRefresh Properties
InventoryRefresh Class See Also Send Feedback

The InventoryRefresh type exposes the following members.

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
InventoryDataSet |
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

InventoryRefresh Class
InSite.Domain.ERPIntegration Namespace


InventoryDataSet Property

[image]

.NET Framework Class Library
InventoryRefresh..::.InventoryDataSet Property
InventoryRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property InventoryDataSet As DataSet
C#
public DataSet InventoryDataSet { get; set; }
Visual C++
public:
property DataSet^ InventoryDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_inventoryDataSet();
function set_inventoryDataSet(value);

See Also

InventoryRefresh Class
InSite.Domain.ERPIntegration Namespace


InvoiceRefresh Class

[image]

.NET Framework Class Library
InvoiceRefresh Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class InvoiceRefresh _
    Inherits RefreshBase
C#
public class InvoiceRefresh : RefreshBase
Visual C++
public ref class InvoiceRefresh : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.InvoiceRefresh = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.InvoiceRefresh',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.InvoiceRefresh

See Also

InvoiceRefresh Members
InSite.Domain.ERPIntegration Namespace


InvoiceRefresh Members

[image] [image]

.NET Framework Class Library
InvoiceRefresh Members
InvoiceRefresh Class Constructors Methods Properties See Also Send Feedback

The InvoiceRefresh type exposes the following members.

Constructors

Name | Description
InvoiceRefresh | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshInvoices | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
InvoiceDataSet |
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

InvoiceRefresh Class
InSite.Domain.ERPIntegration Namespace


InvoiceRefresh Constructor

[image] [image]

.NET Framework Class Library
InvoiceRefresh Constructor
InvoiceRefresh Class See Also Send Feedback

Overload List

Name | Description
InvoiceRefresh(WebSite) |
InvoiceRefresh(String) |

See Also

InvoiceRefresh Class
InvoiceRefresh Members
InSite.Domain.ERPIntegration Namespace


InvoiceRefresh Constructor (WebSite)

[image]

.NET Framework Class Library
InvoiceRefresh Constructor (WebSite)
InvoiceRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public InvoiceRefresh(
    WebSite webSite
)
Visual C++
public:
InvoiceRefresh(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.InvoiceRefresh = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

InvoiceRefresh Class
InvoiceRefresh Overload
InSite.Domain.ERPIntegration Namespace


InvoiceRefresh Constructor (String)

[image]

.NET Framework Class Library
InvoiceRefresh Constructor (String)
InvoiceRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSiteName As String _
)
C#
public InvoiceRefresh(
    string webSiteName
)
Visual C++
public:
InvoiceRefresh(
    String^ webSiteName
)
JavaScript
InSite.Domain.ERPIntegration.InvoiceRefresh = function(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

InvoiceRefresh Class
InvoiceRefresh Overload
InSite.Domain.ERPIntegration Namespace


InvoiceRefresh Methods

[image] [image]

.NET Framework Class Library
InvoiceRefresh Methods
InvoiceRefresh Class See Also Send Feedback

The InvoiceRefresh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshInvoices | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InvoiceRefresh Class
InSite.Domain.ERPIntegration Namespace


RefreshInvoices Method

[image] [image]

.NET Framework Class Library
InvoiceRefresh..::.RefreshInvoices Method
InvoiceRefresh Class See Also Send Feedback

Overload List

Name | Description
RefreshInvoices()()() |
RefreshInvoices(String) |

See Also

InvoiceRefresh Class
InvoiceRefresh Members
InSite.Domain.ERPIntegration Namespace


RefreshInvoices Method

[image]

.NET Framework Class Library
InvoiceRefresh..::.RefreshInvoices Method
InvoiceRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshInvoices
C#
public void RefreshInvoices()
Visual C++
public:
void RefreshInvoices()
JavaScript
function refreshInvoices();

See Also

InvoiceRefresh Class
RefreshInvoices Overload
InSite.Domain.ERPIntegration Namespace


RefreshInvoices Method (String)

[image]

.NET Framework Class Library
InvoiceRefresh..::.RefreshInvoices Method (String)
InvoiceRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshInvoices ( _
    invoiceNumber As String _
)
C#
public void RefreshInvoices(
    string invoiceNumber
)
Visual C++
public:
void RefreshInvoices(
    String^ invoiceNumber
)
JavaScript
function refreshInvoices(invoiceNumber);

Parameters

invoiceNumber
Type: System..::.String

See Also

InvoiceRefresh Class
RefreshInvoices Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
InvoiceRefresh..::.SaveDataSetIfNeeded Method
InvoiceRefresh Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

InvoiceRefresh Class
InvoiceRefresh Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
InvoiceRefresh..::.SendErrorEmail Method
InvoiceRefresh Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

InvoiceRefresh Class
InvoiceRefresh Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
InvoiceRefresh..::.Setup Method
InvoiceRefresh Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

InvoiceRefresh Class
InvoiceRefresh Members
InSite.Domain.ERPIntegration Namespace


InvoiceRefresh Properties

[image] [image]

.NET Framework Class Library
InvoiceRefresh Properties
InvoiceRefresh Class See Also Send Feedback

The InvoiceRefresh type exposes the following members.

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
InvoiceDataSet |
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

InvoiceRefresh Class
InSite.Domain.ERPIntegration Namespace


InvoiceDataSet Property

[image]

.NET Framework Class Library
InvoiceRefresh..::.InvoiceDataSet Property
InvoiceRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property InvoiceDataSet As DataSet
C#
public DataSet InvoiceDataSet { get; set; }
Visual C++
public:
property DataSet^ InvoiceDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_invoiceDataSet();
function set_invoiceDataSet(value);

See Also

InvoiceRefresh Class
InSite.Domain.ERPIntegration Namespace


IProcessDataSet Interface

[image]

.NET Framework Class Library
IProcessDataSet Interface
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface IProcessDataSet
C#
public interface IProcessDataSet
Visual C++
public interface class IProcessDataSet
JavaScript
InSite.Domain.ERPIntegration.IProcessDataSet = function();
InSite.Domain.ERPIntegration.IProcessDataSet.createInterface('InSite.Domain.ERPIntegration.IProcessDataSet');

See Also

IProcessDataSet Members
InSite.Domain.ERPIntegration Namespace


IProcessDataSet Members

[image] [image]

.NET Framework Class Library
IProcessDataSet Members
IProcessDataSet Interface Methods See Also Send Feedback

The IProcessDataSet type exposes the following members.

Methods

Name | Description
ProcessDataSet |

See Also

IProcessDataSet Interface
InSite.Domain.ERPIntegration Namespace


IProcessDataSet Methods

[image] [image]

.NET Framework Class Library
IProcessDataSet Methods
IProcessDataSet Interface See Also Send Feedback

The IProcessDataSet type exposes the following members.

Methods

Name | Description
ProcessDataSet |

See Also

IProcessDataSet Interface
InSite.Domain.ERPIntegration Namespace


ProcessDataSet Method

[image]

.NET Framework Class Library
IProcessDataSet..::.ProcessDataSet Method
IProcessDataSet Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub ProcessDataSet ( _
    dataSet As DataSet _
)
C#
void ProcessDataSet(
    DataSet dataSet
)
Visual C++
void ProcessDataSet(
    DataSet^ dataSet
)
JavaScript
function processDataSet(dataSet);

Parameters

dataSet
Type: System.Data..::.DataSet

See Also

IProcessDataSet Interface
InSite.Domain.ERPIntegration Namespace


IProductRefresh Interface

[image]

.NET Framework Class Library
IProductRefresh Interface
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface IProductRefresh
C#
public interface IProductRefresh
Visual C++
public interface class IProductRefresh
JavaScript
InSite.Domain.ERPIntegration.IProductRefresh = function();
InSite.Domain.ERPIntegration.IProductRefresh.createInterface('InSite.Domain.ERPIntegration.IProductRefresh');

See Also

IProductRefresh Members
InSite.Domain.ERPIntegration Namespace


IProductRefresh Members

[image] [image]

.NET Framework Class Library
IProductRefresh Members
IProductRefresh Interface Methods Properties See Also Send Feedback

The IProductRefresh type exposes the following members.

Methods

Name | Description
RefreshProducts | Overloaded.
SetWebSite | Overloaded.

Properties

Name | Description
ProductDataSet |

See Also

IProductRefresh Interface
InSite.Domain.ERPIntegration Namespace


IProductRefresh Methods

[image] [image]

.NET Framework Class Library
IProductRefresh Methods
IProductRefresh Interface See Also Send Feedback

Methods

Name | Description
RefreshProducts | Overloaded.
SetWebSite | Overloaded.

See Also

IProductRefresh Interface
InSite.Domain.ERPIntegration Namespace


RefreshProducts Method

[image] [image]

.NET Framework Class Library
IProductRefresh..::.RefreshProducts Method
IProductRefresh Interface See Also Send Feedback

Overload List

Name | Description
RefreshProducts()()() |
RefreshProducts(String) |

See Also

IProductRefresh Interface
IProductRefresh Members
InSite.Domain.ERPIntegration Namespace


RefreshProducts Method

[image]

.NET Framework Class Library
IProductRefresh..::.RefreshProducts Method
IProductRefresh Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub RefreshProducts
C#
void RefreshProducts()
Visual C++
void RefreshProducts()
JavaScript
function refreshProducts();

See Also

IProductRefresh Interface
RefreshProducts Overload
InSite.Domain.ERPIntegration Namespace


RefreshProducts Method (String)

[image]

.NET Framework Class Library
IProductRefresh..::.RefreshProducts Method (String)
IProductRefresh Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub RefreshProducts ( _
    productName As String _
)
C#
void RefreshProducts(
    string productName
)
Visual C++
void RefreshProducts(
    String^ productName
)
JavaScript
function refreshProducts(productName);

Parameters

productName
Type: System..::.String

See Also

IProductRefresh Interface
RefreshProducts Overload
InSite.Domain.ERPIntegration Namespace


SetWebSite Method

[image] [image]

.NET Framework Class Library
IProductRefresh..::.SetWebSite Method
IProductRefresh Interface See Also Send Feedback

Overload List

Name | Description
SetWebSite(WebSite) |
SetWebSite(String) |

See Also

IProductRefresh Interface
IProductRefresh Members
InSite.Domain.ERPIntegration Namespace


SetWebSite Method (WebSite)

[image]

.NET Framework Class Library
IProductRefresh..::.SetWebSite Method (WebSite)
IProductRefresh Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub SetWebSite ( _
    webSite As WebSite _
)
C#
void SetWebSite(
    WebSite webSite
)
Visual C++
void SetWebSite(
    WebSite^ webSite
)
JavaScript
function setWebSite(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

IProductRefresh Interface
SetWebSite Overload
InSite.Domain.ERPIntegration Namespace


SetWebSite Method (String)

[image]

.NET Framework Class Library
IProductRefresh..::.SetWebSite Method (String)
IProductRefresh Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub SetWebSite ( _
    webSiteName As String _
)
C#
void SetWebSite(
    string webSiteName
)
Visual C++
void SetWebSite(
    String^ webSiteName
)
JavaScript
function setWebSite(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

IProductRefresh Interface
SetWebSite Overload
InSite.Domain.ERPIntegration Namespace


IProductRefresh Properties

[image] [image]

.NET Framework Class Library
IProductRefresh Properties
IProductRefresh Interface See Also Send Feedback

The IProductRefresh type exposes the following members.

Properties

Name | Description
ProductDataSet |

See Also

IProductRefresh Interface
InSite.Domain.ERPIntegration Namespace


ProductDataSet Property

[image]

.NET Framework Class Library
IProductRefresh..::.ProductDataSet Property
IProductRefresh Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Property ProductDataSet As DataSet
C#
DataSet ProductDataSet { get; set; }
Visual C++
property DataSet^ ProductDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_productDataSet();
function set_productDataSet(value);

See Also

IProductRefresh Interface
InSite.Domain.ERPIntegration Namespace


IProductUpdate Interface

[image]

.NET Framework Class Library
IProductUpdate Interface
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface IProductUpdate
C#
public interface IProductUpdate
Visual C++
public interface class IProductUpdate
JavaScript
InSite.Domain.ERPIntegration.IProductUpdate = function();
InSite.Domain.ERPIntegration.IProductUpdate.createInterface('InSite.Domain.ERPIntegration.IProductUpdate');

See Also

IProductUpdate Members
InSite.Domain.ERPIntegration Namespace


IProductUpdate Members

[image] [image]

.NET Framework Class Library
IProductUpdate Members
IProductUpdate Interface Methods See Also Send Feedback

Methods

Name | Description
Update | Overloaded.

See Also

IProductUpdate Interface
InSite.Domain.ERPIntegration Namespace


IProductUpdate Methods

[image] [image]

.NET Framework Class Library
IProductUpdate Methods
IProductUpdate Interface See Also Send Feedback

Methods

Name | Description
Update | Overloaded.

See Also

IProductUpdate Interface
InSite.Domain.ERPIntegration Namespace


Update Method

[image] [image]

.NET Framework Class Library
IProductUpdate..::.Update Method
IProductUpdate Interface See Also Send Feedback

Overload List

Name | Description
Update(Product, DataRow) |
Update(Product, DataRow, List<(Of <(String>)>)) |

See Also

IProductUpdate Interface
IProductUpdate Members
InSite.Domain.ERPIntegration Namespace


Update Method (Product, DataRow)

[image]

.NET Framework Class Library
IProductUpdate..::.Update Method (Product, DataRow)
IProductUpdate Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub Update ( _
    product As Product, _
    productDataRow As DataRow _
)
C#
void Update(
    Product product,
    DataRow productDataRow
)
Visual C++
void Update(
    Product^ product,
    DataRow^ productDataRow
)
JavaScript
function update(product, productDataRow);

Parameters

product
Type: InSite.Model..::.Product
productDataRow
Type: System.Data..::.DataRow

See Also

IProductUpdate Interface
Update Overload
InSite.Domain.ERPIntegration Namespace


Update Method (Product, DataRow, List(String))

[image]

.NET Framework Class Library
IProductUpdate..::.Update Method (Product, DataRow, List<(Of <(String>)>))
IProductUpdate Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Sub Update ( _
    product As Product, _
    productDataRow As DataRow, _
    propertiesToIgnore As List(Of String) _
)
C#
void Update(
    Product product,
    DataRow productDataRow,
    List<string> propertiesToIgnore
)
Visual C++
void Update(
    Product^ product,
    DataRow^ productDataRow,
    List<String^>^ propertiesToIgnore
)
JavaScript
function update(product, productDataRow, propertiesToIgnore);

Parameters

product
Type: InSite.Model..::.Product
productDataRow
Type: System.Data..::.DataRow
propertiesToIgnore
Type: System.Collections.Generic..::.List <(Of <( String >)>)

See Also

IProductUpdate Interface
Update Overload
InSite.Domain.ERPIntegration Namespace


PricingRefresh Class

[image]

.NET Framework Class Library
PricingRefresh Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PricingRefresh _
    Inherits RefreshBase
C#
public class PricingRefresh : RefreshBase
Visual C++
public ref class PricingRefresh : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.PricingRefresh = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.PricingRefresh',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.PricingRefresh

See Also

PricingRefresh Members
InSite.Domain.ERPIntegration Namespace


PricingRefresh Members

[image] [image]

.NET Framework Class Library
PricingRefresh Members
PricingRefresh Class Constructors Methods Properties See Also Send Feedback

The PricingRefresh type exposes the following members.

Constructors

Name | Description
PricingRefresh |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshPricing | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
PricingDataSet |
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

PricingRefresh Class
InSite.Domain.ERPIntegration Namespace


PricingRefresh Constructor

[image]

.NET Framework Class Library
PricingRefresh Constructor
PricingRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public PricingRefresh(
    WebSite webSite
)
Visual C++
public:
PricingRefresh(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.PricingRefresh = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

PricingRefresh Class
InSite.Domain.ERPIntegration Namespace


PricingRefresh Methods

[image] [image]

.NET Framework Class Library
PricingRefresh Methods
PricingRefresh Class See Also Send Feedback

The PricingRefresh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshPricing | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PricingRefresh Class
InSite.Domain.ERPIntegration Namespace


RefreshPricing Method

[image] [image]

.NET Framework Class Library
PricingRefresh..::.RefreshPricing Method
PricingRefresh Class See Also Send Feedback

Overload List

Name | Description
RefreshPricing()()() |
RefreshPricing(String) |

See Also

PricingRefresh Class
PricingRefresh Members
InSite.Domain.ERPIntegration Namespace


RefreshPricing Method

[image]

.NET Framework Class Library
PricingRefresh..::.RefreshPricing Method
PricingRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshPricing
C#
public void RefreshPricing()
Visual C++
public:
void RefreshPricing()
JavaScript
function refreshPricing();

See Also

PricingRefresh Class
RefreshPricing Overload
InSite.Domain.ERPIntegration Namespace


RefreshPricing Method (String)

[image]

.NET Framework Class Library
PricingRefresh..::.RefreshPricing Method (String)
PricingRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshPricing ( _
    unused As String _
)
C#
public void RefreshPricing(
    string unused
)
Visual C++
public:
void RefreshPricing(
    String^ unused
)
JavaScript
function refreshPricing(unused);

Parameters

unused
Type: System..::.String

See Also

PricingRefresh Class
RefreshPricing Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
PricingRefresh..::.SaveDataSetIfNeeded Method
PricingRefresh Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

PricingRefresh Class
PricingRefresh Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
PricingRefresh..::.SendErrorEmail Method
PricingRefresh Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

PricingRefresh Class
PricingRefresh Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
PricingRefresh..::.Setup Method
PricingRefresh Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

PricingRefresh Class
PricingRefresh Members
InSite.Domain.ERPIntegration Namespace


PricingRefresh Properties

[image] [image]

.NET Framework Class Library
PricingRefresh Properties
PricingRefresh Class See Also Send Feedback

The PricingRefresh type exposes the following members.

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
PricingDataSet |
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

PricingRefresh Class
InSite.Domain.ERPIntegration Namespace


PricingDataSet Property

[image]

.NET Framework Class Library
PricingRefresh..::.PricingDataSet Property
PricingRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PricingDataSet As DataSet
C#
public DataSet PricingDataSet { get; set; }
Visual C++
public:
property DataSet^ PricingDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_pricingDataSet();
function set_pricingDataSet(value);

See Also

PricingRefresh Class
InSite.Domain.ERPIntegration Namespace


ProcessDataSet_Generic Class

[image]

.NET Framework Class Library
ProcessDataSet_Generic Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ProcessDataSet_Generic _
    Implements IProcessDataSet
C#
public class ProcessDataSet_Generic : IProcessDataSet
Visual C++
public ref class ProcessDataSet_Generic : IProcessDataSet
JavaScript
InSite.Domain.ERPIntegration.ProcessDataSet_Generic = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.ProcessDataSet_Generic',
    null,
    InSite.Domain.ERPIntegration.IProcessDataSet);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.ProcessDataSet_Generic

See Also

ProcessDataSet_Generic Members
InSite.Domain.ERPIntegration Namespace


ProcessDataSet_Generic Members

[image] [image]

.NET Framework Class Library
ProcessDataSet_Generic Members
ProcessDataSet_Generic Class Constructors Methods See Also Send Feedback

The ProcessDataSet_Generic type exposes the following members.

Constructors

Name | Description
ProcessDataSet_Generic |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessDataSet |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessDataSet_Generic Class
InSite.Domain.ERPIntegration Namespace


ProcessDataSet_Generic Constructor

[image]

.NET Framework Class Library
ProcessDataSet_Generic Constructor
ProcessDataSet_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProcessDataSet_Generic()
Visual C++
public:
ProcessDataSet_Generic()
JavaScript
InSite.Domain.ERPIntegration.ProcessDataSet_Generic = function();

See Also

ProcessDataSet_Generic Class
InSite.Domain.ERPIntegration Namespace


ProcessDataSet_Generic Methods

[image] [image]

.NET Framework Class Library
ProcessDataSet_Generic Methods
ProcessDataSet_Generic Class See Also Send Feedback

The ProcessDataSet_Generic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessDataSet |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProcessDataSet_Generic Class
InSite.Domain.ERPIntegration Namespace


ProcessDataSet Method

[image]

.NET Framework Class Library
ProcessDataSet_Generic..::.ProcessDataSet Method
ProcessDataSet_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub ProcessDataSet ( _
    dataSet As DataSet _
)
C#
public void ProcessDataSet(
    DataSet dataSet
)
Visual C++
public:
virtual void ProcessDataSet(
    DataSet^ dataSet
) sealed
JavaScript
function processDataSet(dataSet);

Parameters

dataSet
Type: System.Data..::.DataSet

Implements

IProcessDataSet..::.ProcessDataSet(DataSet)

See Also

ProcessDataSet_Generic Class
InSite.Domain.ERPIntegration Namespace


ProductRefresh_Generic Class

[image]

.NET Framework Class Library
ProductRefresh_Generic Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ProductRefresh_Generic _
    Inherits RefreshBase _
    Implements IProductRefresh
C#
public class ProductRefresh_Generic : RefreshBase,
    IProductRefresh
Visual C++
public ref class ProductRefresh_Generic : public RefreshBase,
    IProductRefresh
JavaScript
InSite.Domain.ERPIntegration.ProductRefresh_Generic = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.ProductRefresh_Generic',
    InSite.Domain.ERPIntegration.RefreshBase,
    InSite.Domain.ERPIntegration.IProductRefresh);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.ProductRefresh_Generic

See Also

ProductRefresh_Generic Members
InSite.Domain.ERPIntegration Namespace


ProductRefresh_Generic Members

[image] [image]

.NET Framework Class Library
ProductRefresh_Generic Members
ProductRefresh_Generic Class Constructors Methods Properties See Also Send Feedback

The ProductRefresh_Generic type exposes the following members.

Constructors

Name | Description
ProductRefresh_Generic |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshProducts | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
SetWebSite | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColumnsNotToOverwrite |
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
ProductDataSet |
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts |
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

ProductRefresh_Generic Class
InSite.Domain.ERPIntegration Namespace


ProductRefresh_Generic Constructor

[image]

.NET Framework Class Library
ProductRefresh_Generic Constructor
ProductRefresh_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProductRefresh_Generic()
Visual C++
public:
ProductRefresh_Generic()
JavaScript
InSite.Domain.ERPIntegration.ProductRefresh_Generic = function();

See Also

ProductRefresh_Generic Class
InSite.Domain.ERPIntegration Namespace


ProductRefresh_Generic Methods

[image] [image]

.NET Framework Class Library
ProductRefresh_Generic Methods
ProductRefresh_Generic Class See Also Send Feedback

The ProductRefresh_Generic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshProducts | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
SetWebSite | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProductRefresh_Generic Class
InSite.Domain.ERPIntegration Namespace


RefreshProducts Method

[image] [image]

.NET Framework Class Library
ProductRefresh_Generic..::.RefreshProducts Method
ProductRefresh_Generic Class See Also Send Feedback

Overload List

Name | Description
RefreshProducts()()() |
RefreshProducts(String) |

See Also

ProductRefresh_Generic Class
ProductRefresh_Generic Members
InSite.Domain.ERPIntegration Namespace


RefreshProducts Method

[image]

.NET Framework Class Library
ProductRefresh_Generic..::.RefreshProducts Method
ProductRefresh_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshProducts
C#
public void RefreshProducts()
Visual C++
public:
virtual void RefreshProducts() sealed
JavaScript
function refreshProducts();

Implements

IProductRefresh..::.RefreshProducts()()()

See Also

ProductRefresh_Generic Class
RefreshProducts Overload
InSite.Domain.ERPIntegration Namespace


RefreshProducts Method (String)

[image]

.NET Framework Class Library
ProductRefresh_Generic..::.RefreshProducts Method (String)
ProductRefresh_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshProducts ( _
    productName As String _
)
C#
public void RefreshProducts(
    string productName
)
Visual C++
public:
virtual void RefreshProducts(
    String^ productName
) sealed
JavaScript
function refreshProducts(productName);

Parameters

productName
Type: System..::.String

Implements

IProductRefresh..::.RefreshProducts(String)

See Also

ProductRefresh_Generic Class
RefreshProducts Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
ProductRefresh_Generic..::.SaveDataSetIfNeeded Method
ProductRefresh_Generic Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

ProductRefresh_Generic Class
ProductRefresh_Generic Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
ProductRefresh_Generic..::.SendErrorEmail Method
ProductRefresh_Generic Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

ProductRefresh_Generic Class
ProductRefresh_Generic Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
ProductRefresh_Generic..::.Setup Method
ProductRefresh_Generic Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

ProductRefresh_Generic Class
ProductRefresh_Generic Members
InSite.Domain.ERPIntegration Namespace


SetWebSite Method

[image] [image]

.NET Framework Class Library
ProductRefresh_Generic..::.SetWebSite Method
ProductRefresh_Generic Class See Also Send Feedback

Overload List

Name | Description
SetWebSite(WebSite) |
SetWebSite(String) |

See Also

ProductRefresh_Generic Class
ProductRefresh_Generic Members
InSite.Domain.ERPIntegration Namespace


SetWebSite Method (WebSite)

[image]

.NET Framework Class Library
ProductRefresh_Generic..::.SetWebSite Method (WebSite)
ProductRefresh_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWebSite ( _
    webSite As WebSite _
)
C#
public void SetWebSite(
    WebSite webSite
)
Visual C++
public:
virtual void SetWebSite(
    WebSite^ webSite
) sealed
JavaScript
function setWebSite(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

Implements

IProductRefresh..::.SetWebSite(WebSite)

See Also

ProductRefresh_Generic Class
SetWebSite Overload
InSite.Domain.ERPIntegration Namespace


SetWebSite Method (String)

[image]

.NET Framework Class Library
ProductRefresh_Generic..::.SetWebSite Method (String)
ProductRefresh_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetWebSite ( _
    webSiteName As String _
)
C#
public void SetWebSite(
    string webSiteName
)
Visual C++
public:
virtual void SetWebSite(
    String^ webSiteName
) sealed
JavaScript
function setWebSite(webSiteName);

Parameters

webSiteName
Type: System..::.String

Implements

IProductRefresh..::.SetWebSite(String)

See Also

ProductRefresh_Generic Class
SetWebSite Overload
InSite.Domain.ERPIntegration Namespace


ProductRefresh_Generic Properties

[image] [image]

.NET Framework Class Library
ProductRefresh_Generic Properties
ProductRefresh_Generic Class See Also Send Feedback

The ProductRefresh_Generic type exposes the following members.

Properties

Name | Description
ColumnsNotToOverwrite |
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
ProductDataSet |
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts |
RunBatch | (Inherited from RefreshBase.)
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

ProductRefresh_Generic Class
InSite.Domain.ERPIntegration Namespace


ColumnsNotToOverwrite Property

[image]

.NET Framework Class Library
ProductRefresh_Generic..::.ColumnsNotToOverwrite Property
ProductRefresh_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ColumnsNotToOverwrite As List(Of String)
C#
public List<string> ColumnsNotToOverwrite { get; }
Visual C++
public:
property List<String^>^ ColumnsNotToOverwrite {
    List<String^>^ get ();
}
JavaScript
function get_columnsNotToOverwrite();

See Also

ProductRefresh_Generic Class
InSite.Domain.ERPIntegration Namespace


ProductDataSet Property

[image]

.NET Framework Class Library
ProductRefresh_Generic..::.ProductDataSet Property
ProductRefresh_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductDataSet As DataSet
C#
public virtual DataSet ProductDataSet { get; set; }
Visual C++
public:
virtual property DataSet^ ProductDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_productDataSet();
function set_productDataSet(value);

Implements

IProductRefresh..::.ProductDataSet

See Also

ProductRefresh_Generic Class
InSite.Domain.ERPIntegration Namespace


RefreshPreLoadProducts Property

[image]

.NET Framework Class Library
ProductRefresh_Generic..::.RefreshPreLoadProducts Property
ProductRefresh_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshPreLoadProducts As Boolean
C#
public bool RefreshPreLoadProducts { get; set; }
Visual C++
public:
property bool RefreshPreLoadProducts {
    bool get ();
    void set (bool value);
}
JavaScript
function get_refreshPreLoadProducts();
function set_refreshPreLoadProducts(value);

See Also

ProductRefresh_Generic Class
InSite.Domain.ERPIntegration Namespace


ProductUpdate_Generic Class

[image]

.NET Framework Class Library
ProductUpdate_Generic Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ProductUpdate_Generic _
    Implements IProductUpdate
C#
public class ProductUpdate_Generic : IProductUpdate
Visual C++
public ref class ProductUpdate_Generic : IProductUpdate
JavaScript
InSite.Domain.ERPIntegration.ProductUpdate_Generic = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.ProductUpdate_Generic',
    null,
    InSite.Domain.ERPIntegration.IProductUpdate);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.ProductUpdate_Generic

See Also

ProductUpdate_Generic Members
InSite.Domain.ERPIntegration Namespace


ProductUpdate_Generic Members

[image] [image]

.NET Framework Class Library
ProductUpdate_Generic Members
ProductUpdate_Generic Class Constructors Methods See Also Send Feedback

The ProductUpdate_Generic type exposes the following members.

Constructors

Name | Description
ProductUpdate_Generic |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update | Overloaded.

See Also

ProductUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


ProductUpdate_Generic Constructor

[image]

.NET Framework Class Library
ProductUpdate_Generic Constructor
ProductUpdate_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProductUpdate_Generic()
Visual C++
public:
ProductUpdate_Generic()
JavaScript
InSite.Domain.ERPIntegration.ProductUpdate_Generic = function();

See Also

ProductUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


ProductUpdate_Generic Methods

[image] [image]

.NET Framework Class Library
ProductUpdate_Generic Methods
ProductUpdate_Generic Class See Also Send Feedback

The ProductUpdate_Generic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update | Overloaded.

See Also

ProductUpdate_Generic Class
InSite.Domain.ERPIntegration Namespace


Update Method

[image] [image]

.NET Framework Class Library
ProductUpdate_Generic..::.Update Method
ProductUpdate_Generic Class See Also Send Feedback

Overload List

Name | Description
Update(Product, DataRow) |
Update(Product, DataRow, List<(Of <(String>)>)) |

See Also

ProductUpdate_Generic Class
ProductUpdate_Generic Members
InSite.Domain.ERPIntegration Namespace


Update Method (Product, DataRow)

[image]

.NET Framework Class Library
ProductUpdate_Generic..::.Update Method (Product, DataRow)
ProductUpdate_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Update ( _
    product As Product, _
    productDataRow As DataRow _
)
C#
public virtual void Update(
    Product product,
    DataRow productDataRow
)
Visual C++
public:
virtual void Update(
    Product^ product,
    DataRow^ productDataRow
)
JavaScript
function update(product, productDataRow);

Parameters

product
Type: InSite.Model..::.Product
productDataRow
Type: System.Data..::.DataRow

Implements

IProductUpdate..::.Update(Product, DataRow)

See Also

ProductUpdate_Generic Class
Update Overload
InSite.Domain.ERPIntegration Namespace


Update Method (Product, DataRow, List(String))

[image]

.NET Framework Class Library
ProductUpdate_Generic..::.Update Method (Product, DataRow, List<(Of <(String>)>))
ProductUpdate_Generic Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Update ( _
    product As Product, _
    productDataRow As DataRow, _
    propertiesToIgnore As List(Of String) _
)
C#
public virtual void Update(
    Product product,
    DataRow productDataRow,
    List<string> propertiesToIgnore
)
Visual C++
public:
virtual void Update(
    Product^ product,
    DataRow^ productDataRow,
    List<String^>^ propertiesToIgnore
)
JavaScript
function update(product, productDataRow, propertiesToIgnore);

Parameters

product
Type: InSite.Model..::.Product
productDataRow
Type: System.Data..::.DataRow
propertiesToIgnore
Type: System.Collections.Generic..::.List <(Of <( String >)>)

Implements

IProductUpdate..::.Update(Product, DataRow, List<(Of <(String>)>))

See Also

ProductUpdate_Generic Class
Update Overload
InSite.Domain.ERPIntegration Namespace


RefreshBase Class

[image]

.NET Framework Class Library
RefreshBase Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class RefreshBase
C#
public abstract class RefreshBase
Visual C++
public ref class RefreshBase abstract
JavaScript
InSite.Domain.ERPIntegration.RefreshBase = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.RefreshBase');

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.CustomerOrderRefresh
InSite.Domain.ERPIntegration..::.CustomerRefresh
InSite.Domain.ERPIntegration..::.DealerRefresh
InSite.Domain.ERPIntegration..::.ExecuteQuery
InSite.Domain.ERPIntegration..::.InventoryRefresh
InSite.Domain.ERPIntegration..::.InvoiceRefresh
InSite.Domain.ERPIntegration..::.PricingRefresh
InSite.Domain.ERPIntegration..::.ProductRefresh_Generic
InSite.Domain.ERPIntegration..::.SalesmanRefresh
InSite.Domain.ERPIntegration..::.ShipmentRefresh

See Also

RefreshBase Members
InSite.Domain.ERPIntegration Namespace


RefreshBase Members

[image] [image]

.NET Framework Class Library
RefreshBase Members
RefreshBase Class Constructors Methods Properties See Also Send Feedback

The RefreshBase type exposes the following members.

Constructors

Name | Description
RefreshBase |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh |
GetERPDataSet |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ERPService |
PageSize |
RefreshName |
RefreshPreLoadCustomers |
RefreshPreLoadProducts |
RunBatch |
UseWindowsService |
WebSite |

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


RefreshBase Constructor

[image]

.NET Framework Class Library
RefreshBase Constructor
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected RefreshBase()
Visual C++
protected:
RefreshBase()
JavaScript
InSite.Domain.ERPIntegration.RefreshBase = function();

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


RefreshBase Methods

[image] [image]

.NET Framework Class Library
RefreshBase Methods
RefreshBase Class See Also Send Feedback

The RefreshBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh |
GetERPDataSet |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


FinishRefresh Method

[image]

.NET Framework Class Library
RefreshBase..::.FinishRefresh Method
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub FinishRefresh ( _
    start As DateTime _
)
C#
protected void FinishRefresh(
    DateTime start
)
Visual C++
protected:
void FinishRefresh(
    DateTime start
)
JavaScript
function finishRefresh(start);

Parameters

start
Type: System..::.DateTime

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


GetERPDataSet Method

[image]

.NET Framework Class Library
RefreshBase..::.GetERPDataSet Method
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetERPDataSet ( _
    erpService As ERPService, _
    methodName As String, _
    dataSetName As String _
) As DataSet
C#
protected DataSet GetERPDataSet(
    ERPService erpService,
    string methodName,
    string dataSetName
)
Visual C++
protected:
DataSet^ GetERPDataSet(
    ERPService^ erpService,
    String^ methodName,
    String^ dataSetName
)
JavaScript
function getERPDataSet(erpService, methodName, dataSetName);

Parameters

erpService
Type: InSite.Domain.InSiteERPService..::.ERPService
methodName
Type: System..::.String
dataSetName
Type: System..::.String

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


GetStoredDataSet Method

[image]

.NET Framework Class Library
RefreshBase..::.GetStoredDataSet Method
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetStoredDataSet ( _
    dataSetName As String _
) As DataSet
C#
protected DataSet GetStoredDataSet(
    string dataSetName
)
Visual C++
protected:
DataSet^ GetStoredDataSet(
    String^ dataSetName
)
JavaScript
function getStoredDataSet(dataSetName);

Parameters

dataSetName
Type: System..::.String

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
RefreshBase..::.SaveDataSetIfNeeded Method
RefreshBase Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) |
SaveDataSetIfNeeded(DataSet, String) |

See Also

RefreshBase Class
RefreshBase Members
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method (DataSet)

[image]

.NET Framework Class Library
RefreshBase..::.SaveDataSetIfNeeded Method (DataSet)
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SaveDataSetIfNeeded ( _
    dataSet As DataSet _
)
C#
protected void SaveDataSetIfNeeded(
    DataSet dataSet
)
Visual C++
protected:
void SaveDataSetIfNeeded(
    DataSet^ dataSet
)
JavaScript
function saveDataSetIfNeeded(dataSet);

Parameters

dataSet
Type: System.Data..::.DataSet

See Also

RefreshBase Class
SaveDataSetIfNeeded Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method (DataSet, String)

[image]

.NET Framework Class Library
RefreshBase..::.SaveDataSetIfNeeded Method (DataSet, String)
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SaveDataSetIfNeeded ( _
    dataSet As DataSet, _
    saveName As String _
)
C#
protected void SaveDataSetIfNeeded(
    DataSet dataSet,
    string saveName
)
Visual C++
protected:
void SaveDataSetIfNeeded(
    DataSet^ dataSet,
    String^ saveName
)
JavaScript
function saveDataSetIfNeeded(dataSet, saveName);

Parameters

dataSet
Type: System.Data..::.DataSet
saveName
Type: System..::.String

See Also

RefreshBase Class
SaveDataSetIfNeeded Overload
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
RefreshBase..::.SendErrorEmail Method
RefreshBase Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) |
SendErrorEmail(Exception) |
SendErrorEmail(List<(Of <(Exception>)>), String) |
SendErrorEmail(Exception, String) |

See Also

RefreshBase Class
RefreshBase Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method (List(Exception))

[image]

.NET Framework Class Library
RefreshBase..::.SendErrorEmail Method (List<(Of <(Exception>)>))
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SendErrorEmail ( _
    exceptions As List(Of Exception) _
)
C#
protected void SendErrorEmail(
    List<Exception> exceptions
)
Visual C++
protected:
void SendErrorEmail(
    List<Exception^>^ exceptions
)
JavaScript
function sendErrorEmail(exceptions);

Parameters

exceptions
Type: System.Collections.Generic..::.List <(Of <( Exception >)>)

See Also

RefreshBase Class
SendErrorEmail Overload
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method (Exception)

[image]

.NET Framework Class Library
RefreshBase..::.SendErrorEmail Method (Exception)
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SendErrorEmail ( _
    ex As Exception _
)
C#
protected void SendErrorEmail(
    Exception ex
)
Visual C++
protected:
void SendErrorEmail(
    Exception^ ex
)
JavaScript
function sendErrorEmail(ex);

Parameters

ex
Type: System..::.Exception

See Also

RefreshBase Class
SendErrorEmail Overload
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method (List(Exception), String)

[image]

.NET Framework Class Library
RefreshBase..::.SendErrorEmail Method (List<(Of <(Exception>)>), String)
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SendErrorEmail ( _
    exceptions As List(Of Exception), _
    refreshMethod As String _
)
C#
protected void SendErrorEmail(
    List<Exception> exceptions,
    string refreshMethod
)
Visual C++
protected:
void SendErrorEmail(
    List<Exception^>^ exceptions,
    String^ refreshMethod
)
JavaScript
function sendErrorEmail(exceptions, refreshMethod);

Parameters

exceptions
Type: System.Collections.Generic..::.List <(Of <( Exception >)>)
refreshMethod
Type: System..::.String

See Also

RefreshBase Class
SendErrorEmail Overload
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method (Exception, String)

[image]

.NET Framework Class Library
RefreshBase..::.SendErrorEmail Method (Exception, String)
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub SendErrorEmail ( _
    ex As Exception, _
    refreshName As String _
)
C#
protected void SendErrorEmail(
    Exception ex,
    string refreshName
)
Visual C++
protected:
void SendErrorEmail(
    Exception^ ex,
    String^ refreshName
)
JavaScript
function sendErrorEmail(ex, refreshName);

Parameters

ex
Type: System..::.Exception
refreshName
Type: System..::.String

See Also

RefreshBase Class
SendErrorEmail Overload
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
RefreshBase..::.Setup Method
RefreshBase Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) |
Setup(String, String) |

See Also

RefreshBase Class
RefreshBase Members
InSite.Domain.ERPIntegration Namespace


Setup Method (WebSite, String)

[image]

.NET Framework Class Library
RefreshBase..::.Setup Method (WebSite, String)
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub Setup ( _
    webSite As WebSite, _
    refreshName As String _
)
C#
protected void Setup(
    WebSite webSite,
    string refreshName
)
Visual C++
protected:
void Setup(
    WebSite^ webSite,
    String^ refreshName
)
JavaScript
function setup(webSite, refreshName);

Parameters

webSite
Type: InSite.Model..::.WebSite
refreshName
Type: System..::.String

See Also

RefreshBase Class
Setup Overload
InSite.Domain.ERPIntegration Namespace


Setup Method (String, String)

[image]

.NET Framework Class Library
RefreshBase..::.Setup Method (String, String)
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub Setup ( _
    webSiteName As String, _
    refreshName As String _
)
C#
protected void Setup(
    string webSiteName,
    string refreshName
)
Visual C++
protected:
void Setup(
    String^ webSiteName,
    String^ refreshName
)
JavaScript
function setup(webSiteName, refreshName);

Parameters

webSiteName
Type: System..::.String
refreshName
Type: System..::.String

See Also

RefreshBase Class
Setup Overload
InSite.Domain.ERPIntegration Namespace


StoreDataSet Method

[image]

.NET Framework Class Library
RefreshBase..::.StoreDataSet Method
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub StoreDataSet ( _
    dataSet As DataSet, _
    dataSetName As String _
)
C#
protected void StoreDataSet(
    DataSet dataSet,
    string dataSetName
)
Visual C++
protected:
void StoreDataSet(
    DataSet^ dataSet,
    String^ dataSetName
)
JavaScript
function storeDataSet(dataSet, dataSetName);

Parameters

dataSet
Type: System.Data..::.DataSet
dataSetName
Type: System..::.String

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


RefreshBase Properties

[image] [image]

.NET Framework Class Library
RefreshBase Properties
RefreshBase Class See Also Send Feedback

The RefreshBase type exposes the following members.

Properties

Name | Description
ERPService |
PageSize |
RefreshName |
RefreshPreLoadCustomers |
RefreshPreLoadProducts |
RunBatch |
UseWindowsService |
WebSite |

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


ERPService Property

[image]

.NET Framework Class Library
RefreshBase..::.ERPService Property
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ERPService As ERPService
C#
public ERPService ERPService { get; set; }
Visual C++
public:
property ERPService^ ERPService {
    ERPService^ get ();
    void set (ERPService^ value);
}
JavaScript
function get_erpService();
function set_erpService(value);

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


PageSize Property

[image]

.NET Framework Class Library
RefreshBase..::.PageSize Property
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Property PageSize As Integer
C#
protected int PageSize { get; set; }
Visual C++
protected:
property int PageSize {
    int get ();
    void set (int value);
}
JavaScript
function get_pageSize();
function set_pageSize(value);

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


RefreshName Property

[image]

.NET Framework Class Library
RefreshBase..::.RefreshName Property
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshName As String
C#
public string RefreshName { get; set; }
Visual C++
public:
property String^ RefreshName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_refreshName();
function set_refreshName(value);

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


RefreshPreLoadCustomers Property

[image]

.NET Framework Class Library
RefreshBase..::.RefreshPreLoadCustomers Property
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshPreLoadCustomers As Boolean
C#
public bool RefreshPreLoadCustomers { get; set; }
Visual C++
public:
property bool RefreshPreLoadCustomers {
    bool get ();
    void set (bool value);
}
JavaScript
function get_refreshPreLoadCustomers();
function set_refreshPreLoadCustomers(value);

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


RefreshPreLoadProducts Property

[image]

.NET Framework Class Library
RefreshBase..::.RefreshPreLoadProducts Property
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshPreLoadProducts As Boolean
C#
public bool RefreshPreLoadProducts { get; set; }
Visual C++
public:
property bool RefreshPreLoadProducts {
    bool get ();
    void set (bool value);
}
JavaScript
function get_refreshPreLoadProducts();
function set_refreshPreLoadProducts(value);

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


RunBatch Property

[image]

.NET Framework Class Library
RefreshBase..::.RunBatch Property
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Property RunBatch As Integer
C#
protected int RunBatch { get; set; }
Visual C++
protected:
property int RunBatch {
    int get ();
    void set (int value);
}
JavaScript
function get_runBatch();
function set_runBatch(value);

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


UseWindowsService Property

[image]

.NET Framework Class Library
RefreshBase..::.UseWindowsService Property
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UseWindowsService As Boolean
C#
public bool UseWindowsService { get; set; }
Visual C++
public:
property bool UseWindowsService {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useWindowsService();
function set_useWindowsService(value);

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


WebSite Property

[image]

.NET Framework Class Library
RefreshBase..::.WebSite Property
RefreshBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property WebSite As WebSite
C#
public WebSite WebSite { get; set; }
Visual C++
public:
property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

RefreshBase Class
InSite.Domain.ERPIntegration Namespace


SalesmanRefresh Class

[image]

.NET Framework Class Library
SalesmanRefresh Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class SalesmanRefresh _
    Inherits RefreshBase
C#
public class SalesmanRefresh : RefreshBase
Visual C++
public ref class SalesmanRefresh : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.SalesmanRefresh = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.SalesmanRefresh',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.SalesmanRefresh

See Also

SalesmanRefresh Members
InSite.Domain.ERPIntegration Namespace


SalesmanRefresh Members

[image] [image]

.NET Framework Class Library
SalesmanRefresh Members
SalesmanRefresh Class Constructors Methods Properties See Also Send Feedback

The SalesmanRefresh type exposes the following members.

Constructors

Name | Description
SalesmanRefresh | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshSalesman | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
SalesmanDataSet |
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

SalesmanRefresh Class
InSite.Domain.ERPIntegration Namespace


SalesmanRefresh Constructor

[image] [image]

.NET Framework Class Library
SalesmanRefresh Constructor
SalesmanRefresh Class See Also Send Feedback

Overload List

Name | Description
SalesmanRefresh(WebSite) |
SalesmanRefresh(String) |

See Also

SalesmanRefresh Class
SalesmanRefresh Members
InSite.Domain.ERPIntegration Namespace


SalesmanRefresh Constructor (WebSite)

[image]

.NET Framework Class Library
SalesmanRefresh Constructor (WebSite)
SalesmanRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public SalesmanRefresh(
    WebSite webSite
)
Visual C++
public:
SalesmanRefresh(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.SalesmanRefresh = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

SalesmanRefresh Class
SalesmanRefresh Overload
InSite.Domain.ERPIntegration Namespace


SalesmanRefresh Constructor (String)

[image]

.NET Framework Class Library
SalesmanRefresh Constructor (String)
SalesmanRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSiteName As String _
)
C#
public SalesmanRefresh(
    string webSiteName
)
Visual C++
public:
SalesmanRefresh(
    String^ webSiteName
)
JavaScript
InSite.Domain.ERPIntegration.SalesmanRefresh = function(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

SalesmanRefresh Class
SalesmanRefresh Overload
InSite.Domain.ERPIntegration Namespace


SalesmanRefresh Methods

[image] [image]

.NET Framework Class Library
SalesmanRefresh Methods
SalesmanRefresh Class See Also Send Feedback

The SalesmanRefresh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshSalesman | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SalesmanRefresh Class
InSite.Domain.ERPIntegration Namespace


RefreshSalesman Method

[image] [image]

.NET Framework Class Library
SalesmanRefresh..::.RefreshSalesman Method
SalesmanRefresh Class See Also Send Feedback

Overload List

Name | Description
RefreshSalesman()()() |
RefreshSalesman(String) |

See Also

SalesmanRefresh Class
SalesmanRefresh Members
InSite.Domain.ERPIntegration Namespace


RefreshSalesman Method

[image]

.NET Framework Class Library
SalesmanRefresh..::.RefreshSalesman Method
SalesmanRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshSalesman
C#
public void RefreshSalesman()
Visual C++
public:
void RefreshSalesman()
JavaScript
function refreshSalesman();

See Also

SalesmanRefresh Class
RefreshSalesman Overload
InSite.Domain.ERPIntegration Namespace


RefreshSalesman Method (String)

[image]

.NET Framework Class Library
SalesmanRefresh..::.RefreshSalesman Method (String)
SalesmanRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshSalesman ( _
    salesmanNumber As String _
)
C#
public void RefreshSalesman(
    string salesmanNumber
)
Visual C++
public:
void RefreshSalesman(
    String^ salesmanNumber
)
JavaScript
function refreshSalesman(salesmanNumber);

Parameters

salesmanNumber
Type: System..::.String

See Also

SalesmanRefresh Class
RefreshSalesman Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
SalesmanRefresh..::.SaveDataSetIfNeeded Method
SalesmanRefresh Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

SalesmanRefresh Class
SalesmanRefresh Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
SalesmanRefresh..::.SendErrorEmail Method
SalesmanRefresh Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

SalesmanRefresh Class
SalesmanRefresh Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
SalesmanRefresh..::.Setup Method
SalesmanRefresh Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

SalesmanRefresh Class
SalesmanRefresh Members
InSite.Domain.ERPIntegration Namespace


SalesmanRefresh Properties

[image] [image]

.NET Framework Class Library
SalesmanRefresh Properties
SalesmanRefresh Class See Also Send Feedback

The SalesmanRefresh type exposes the following members.

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
SalesmanDataSet |
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

SalesmanRefresh Class
InSite.Domain.ERPIntegration Namespace


SalesmanDataSet Property

[image]

.NET Framework Class Library
SalesmanRefresh..::.SalesmanDataSet Property
SalesmanRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SalesmanDataSet As DataSet
C#
public DataSet SalesmanDataSet { get; set; }
Visual C++
public:
property DataSet^ SalesmanDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_salesmanDataSet();
function set_salesmanDataSet(value);

See Also

SalesmanRefresh Class
InSite.Domain.ERPIntegration Namespace


ShipmentRefresh Class

[image]

.NET Framework Class Library
ShipmentRefresh Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ShipmentRefresh _
    Inherits RefreshBase
C#
public class ShipmentRefresh : RefreshBase
Visual C++
public ref class ShipmentRefresh : public RefreshBase
JavaScript
InSite.Domain.ERPIntegration.ShipmentRefresh = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.ShipmentRefresh',
    InSite.Domain.ERPIntegration.RefreshBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration..::.RefreshBase
InSite.Domain.ERPIntegration..::.ShipmentRefresh

See Also

ShipmentRefresh Members
InSite.Domain.ERPIntegration Namespace


ShipmentRefresh Members

[image] [image]

.NET Framework Class Library
ShipmentRefresh Members
ShipmentRefresh Class Constructors Methods Properties See Also Send Feedback

The ShipmentRefresh type exposes the following members.

Constructors

Name | Description
ShipmentRefresh | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshShipments | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
SetOrderStatusToComplete |
ShipmentDataSet |
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

ShipmentRefresh Class
InSite.Domain.ERPIntegration Namespace


ShipmentRefresh Constructor

[image] [image]

.NET Framework Class Library
ShipmentRefresh Constructor
ShipmentRefresh Class See Also Send Feedback

Overload List

Name | Description
ShipmentRefresh()()() |
ShipmentRefresh(WebSite) |
ShipmentRefresh(String) |

See Also

ShipmentRefresh Class
ShipmentRefresh Members
InSite.Domain.ERPIntegration Namespace


ShipmentRefresh Constructor

[image]

.NET Framework Class Library
ShipmentRefresh Constructor
ShipmentRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipmentRefresh()
Visual C++
public:
ShipmentRefresh()
JavaScript
InSite.Domain.ERPIntegration.ShipmentRefresh = function();

See Also

ShipmentRefresh Class
ShipmentRefresh Overload
InSite.Domain.ERPIntegration Namespace


ShipmentRefresh Constructor (WebSite)

[image]

.NET Framework Class Library
ShipmentRefresh Constructor (WebSite)
ShipmentRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSite As WebSite _
)
C#
public ShipmentRefresh(
    WebSite webSite
)
Visual C++
public:
ShipmentRefresh(
    WebSite^ webSite
)
JavaScript
InSite.Domain.ERPIntegration.ShipmentRefresh = function(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

ShipmentRefresh Class
ShipmentRefresh Overload
InSite.Domain.ERPIntegration Namespace


ShipmentRefresh Constructor (String)

[image]

.NET Framework Class Library
ShipmentRefresh Constructor (String)
ShipmentRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    webSiteName As String _
)
C#
public ShipmentRefresh(
    string webSiteName
)
Visual C++
public:
ShipmentRefresh(
    String^ webSiteName
)
JavaScript
InSite.Domain.ERPIntegration.ShipmentRefresh = function(webSiteName);

Parameters

webSiteName
Type: System..::.String

See Also

ShipmentRefresh Class
ShipmentRefresh Overload
InSite.Domain.ERPIntegration Namespace


ShipmentRefresh Methods

[image] [image]

.NET Framework Class Library
ShipmentRefresh Methods
ShipmentRefresh Class See Also Send Feedback

The ShipmentRefresh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FinishRefresh | (Inherited from RefreshBase.)
GetERPDataSet | (Inherited from RefreshBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetStoredDataSet | (Inherited from RefreshBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RefreshShipments | Overloaded.
SaveDataSetIfNeeded | Overloaded.
SendErrorEmail | Overloaded.
Setup | Overloaded.
StoreDataSet | (Inherited from RefreshBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShipmentRefresh Class
InSite.Domain.ERPIntegration Namespace


RefreshShipments Method

[image] [image]

.NET Framework Class Library
ShipmentRefresh..::.RefreshShipments Method
ShipmentRefresh Class See Also Send Feedback

Overload List

Name | Description
RefreshShipments()()() |
RefreshShipments(String) |

See Also

ShipmentRefresh Class
ShipmentRefresh Members
InSite.Domain.ERPIntegration Namespace


RefreshShipments Method

[image]

.NET Framework Class Library
ShipmentRefresh..::.RefreshShipments Method
ShipmentRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub RefreshShipments
C#
public void RefreshShipments()
Visual C++
public:
void RefreshShipments()
JavaScript
function refreshShipments();

See Also

ShipmentRefresh Class
RefreshShipments Overload
InSite.Domain.ERPIntegration Namespace


RefreshShipments Method (String)

[image]

.NET Framework Class Library
ShipmentRefresh..::.RefreshShipments Method (String)
ShipmentRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RefreshShipments ( _
    orderNumber As String _
)
C#
public virtual void RefreshShipments(
    string orderNumber
)
Visual C++
public:
virtual void RefreshShipments(
    String^ orderNumber
)
JavaScript
function refreshShipments(orderNumber);

Parameters

orderNumber
Type: System..::.String

See Also

ShipmentRefresh Class
RefreshShipments Overload
InSite.Domain.ERPIntegration Namespace


SaveDataSetIfNeeded Method

[image] [image]

.NET Framework Class Library
ShipmentRefresh..::.SaveDataSetIfNeeded Method
ShipmentRefresh Class See Also Send Feedback

Overload List

Name | Description
SaveDataSetIfNeeded(DataSet) | (Inherited from RefreshBase.)
SaveDataSetIfNeeded(DataSet, String) | (Inherited from RefreshBase.)

See Also

ShipmentRefresh Class
ShipmentRefresh Members
InSite.Domain.ERPIntegration Namespace


SendErrorEmail Method

[image] [image]

.NET Framework Class Library
ShipmentRefresh..::.SendErrorEmail Method
ShipmentRefresh Class See Also Send Feedback

Overload List

Name | Description
SendErrorEmail(List<(Of <(Exception>)>)) | (Inherited from RefreshBase.)
SendErrorEmail(Exception) | (Inherited from RefreshBase.)
SendErrorEmail(List<(Of <(Exception>)>), String) | (Inherited from RefreshBase.)
SendErrorEmail(Exception, String) | (Inherited from RefreshBase.)

See Also

ShipmentRefresh Class
ShipmentRefresh Members
InSite.Domain.ERPIntegration Namespace


Setup Method

[image] [image]

.NET Framework Class Library
ShipmentRefresh..::.Setup Method
ShipmentRefresh Class See Also Send Feedback

Overload List

Name | Description
Setup(WebSite, String) | (Inherited from RefreshBase.)
Setup(String, String) | (Inherited from RefreshBase.)

See Also

ShipmentRefresh Class
ShipmentRefresh Members
InSite.Domain.ERPIntegration Namespace


ShipmentRefresh Properties

[image] [image]

.NET Framework Class Library
ShipmentRefresh Properties
ShipmentRefresh Class See Also Send Feedback

The ShipmentRefresh type exposes the following members.

Properties

Name | Description
ERPService | (Inherited from RefreshBase.)
PageSize | (Inherited from RefreshBase.)
RefreshName | (Inherited from RefreshBase.)
RefreshPreLoadCustomers | (Inherited from RefreshBase.)
RefreshPreLoadProducts | (Inherited from RefreshBase.)
RunBatch | (Inherited from RefreshBase.)
SetOrderStatusToComplete |
ShipmentDataSet |
UseWindowsService | (Inherited from RefreshBase.)
WebSite | (Inherited from RefreshBase.)

See Also

ShipmentRefresh Class
InSite.Domain.ERPIntegration Namespace


SetOrderStatusToComplete Property

[image]

.NET Framework Class Library
ShipmentRefresh..::.SetOrderStatusToComplete Property
ShipmentRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SetOrderStatusToComplete As Boolean
C#
public bool SetOrderStatusToComplete { get; }
Visual C++
public:
property bool SetOrderStatusToComplete {
    bool get ();
}
JavaScript
function get_setOrderStatusToComplete();

See Also

ShipmentRefresh Class
InSite.Domain.ERPIntegration Namespace


ShipmentDataSet Property

[image]

.NET Framework Class Library
ShipmentRefresh..::.ShipmentDataSet Property
ShipmentRefresh Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipmentDataSet As DataSet
C#
public DataSet ShipmentDataSet { get; set; }
Visual C++
public:
property DataSet^ ShipmentDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_shipmentDataSet();
function set_shipmentDataSet(value);

See Also

ShipmentRefresh Class
InSite.Domain.ERPIntegration Namespace


InSite.Domain.ERPIntegration.IntegrationTasks Namespace

[image]

.NET Framework Class Library
InSite.Domain.ERPIntegration.IntegrationTasks Namespace
Send Feedback

Classes

Class | Description
IntegrationQuery |
IntegrationTask |
TaskBuilder_Epicor9 |
TaskBuilder_Mas200 |
TaskBuilder_Solomon |
TaskBuilder_SXe |
TaskBuilder_SyteLine6 |
TaskBuilder_SyteLine7 |
TaskBuilder_Vantage |
TaskBuilder_Visual |
TaskBuilderBase |

Interfaces

Interface | Description
ITaskBuilder |


IntegrationQuery Class

[image]

.NET Framework Class Library
IntegrationQuery Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class IntegrationQuery
C#
public class IntegrationQuery
Visual C++
public ref class IntegrationQuery
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.IntegrationQuery = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.IntegrationQuery');

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.IntegrationQuery

See Also

IntegrationQuery Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationQuery Members

[image] [image]

.NET Framework Class Library
IntegrationQuery Members
IntegrationQuery Class Constructors Methods Properties See Also Send Feedback

The IntegrationQuery type exposes the following members.

Constructors

Name | Description
IntegrationQuery |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Keys |
Query |
QueryName |

See Also

IntegrationQuery Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationQuery Constructor

[image]

.NET Framework Class Library
IntegrationQuery Constructor
IntegrationQuery Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public IntegrationQuery()
Visual C++
public:
IntegrationQuery()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.IntegrationQuery = function();

See Also

IntegrationQuery Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationQuery Methods

[image] [image]

.NET Framework Class Library
IntegrationQuery Methods
IntegrationQuery Class See Also Send Feedback

The IntegrationQuery type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntegrationQuery Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationQuery Properties

[image] [image]

.NET Framework Class Library
IntegrationQuery Properties
IntegrationQuery Class See Also Send Feedback

The IntegrationQuery type exposes the following members.

Properties

Name | Description
Keys |
Query |
QueryName |

See Also

IntegrationQuery Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


Keys Property

[image]

.NET Framework Class Library
IntegrationQuery..::.Keys Property
IntegrationQuery Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Keys As String
C#
public string Keys { get; set; }
Visual C++
public:
property String^ Keys {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_keys();
function set_keys(value);

See Also

IntegrationQuery Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


Query Property

[image]

.NET Framework Class Library
IntegrationQuery..::.Query Property
IntegrationQuery Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Query As String
C#
public string Query { get; set; }
Visual C++
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_query();
function set_query(value);

See Also

IntegrationQuery Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


QueryName Property

[image]

.NET Framework Class Library
IntegrationQuery..::.QueryName Property
IntegrationQuery Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property QueryName As String
C#
public string QueryName { get; set; }
Visual C++
public:
property String^ QueryName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_queryName();
function set_queryName(value);

See Also

IntegrationQuery Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationTask Class

[image]

.NET Framework Class Library
IntegrationTask Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class IntegrationTask
C#
[SerializableAttribute]
public class IntegrationTask
Visual C++
[SerializableAttribute]
public ref class IntegrationTask
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.IntegrationTask = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.IntegrationTask');

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.IntegrationTask

See Also

IntegrationTask Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationTask Members

[image] [image]

.NET Framework Class Library
IntegrationTask Members
IntegrationTask Class Constructors Methods Properties See Also Send Feedback

The IntegrationTask type exposes the following members.

Constructors

Name | Description
IntegrationTask |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString |
ERPType |
Parameter |
Queries |
RefreshType |
ScheduledTaskId |

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationTask Constructor

[image]

.NET Framework Class Library
IntegrationTask Constructor
IntegrationTask Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public IntegrationTask()
Visual C++
public:
IntegrationTask()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.IntegrationTask = function();

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationTask Methods

[image] [image]

.NET Framework Class Library
IntegrationTask Methods
IntegrationTask Class See Also Send Feedback

The IntegrationTask type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


IntegrationTask Properties

[image] [image]

.NET Framework Class Library
IntegrationTask Properties
IntegrationTask Class See Also Send Feedback

The IntegrationTask type exposes the following members.

Properties

Name | Description
ConnectionString |
ERPType |
Parameter |
Queries |
RefreshType |
ScheduledTaskId |

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ConnectionString Property

[image]

.NET Framework Class Library
IntegrationTask..::.ConnectionString Property
IntegrationTask Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ConnectionString As String
C#
public string ConnectionString { get; set; }
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_connectionString();
function set_connectionString(value);

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
IntegrationTask..::.ERPType Property
IntegrationTask Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ERPType As String
C#
public string ERPType { get; set; }
Visual C++
public:
property String^ ERPType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpType();
function set_erpType(value);

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


Parameter Property

[image]

.NET Framework Class Library
IntegrationTask..::.Parameter Property
IntegrationTask Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Parameter As String
C#
public string Parameter { get; set; }
Visual C++
public:
property String^ Parameter {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parameter();
function set_parameter(value);

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


Queries Property

[image]

.NET Framework Class Library
IntegrationTask..::.Queries Property
IntegrationTask Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Queries As List(Of IntegrationQuery)
C#
public List<IntegrationQuery> Queries { get; set; }
Visual C++
public:
property List<IntegrationQuery^>^ Queries {
    List<IntegrationQuery^>^ get ();
    void set (List<IntegrationQuery^>^ value);
}
JavaScript
function get_queries();
function set_queries(value);

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


RefreshType Property

[image]

.NET Framework Class Library
IntegrationTask..::.RefreshType Property
IntegrationTask Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RefreshType As String
C#
public string RefreshType { get; set; }
Visual C++
public:
property String^ RefreshType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_refreshType();
function set_refreshType(value);

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ScheduledTaskId Property

[image]

.NET Framework Class Library
IntegrationTask..::.ScheduledTaskId Property
IntegrationTask Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ScheduledTaskId As Guid
C#
public Guid ScheduledTaskId { get; set; }
Visual C++
public:
property Guid ScheduledTaskId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_scheduledTaskId();
function set_scheduledTaskId(value);

See Also

IntegrationTask Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ITaskBuilder Interface

[image]

.NET Framework Class Library
ITaskBuilder Interface
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITaskBuilder
C#
public interface ITaskBuilder
Visual C++
public interface class ITaskBuilder
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.ITaskBuilder = function();
InSite.Domain.ERPIntegration.IntegrationTasks.ITaskBuilder.createInterface('InSite.Domain.ERPIntegration.IntegrationTasks.ITaskBuilder');

See Also

ITaskBuilder Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ITaskBuilder Members

[image] [image]

.NET Framework Class Library
ITaskBuilder Members
ITaskBuilder Interface Methods See Also Send Feedback

The ITaskBuilder type exposes the following members.

Methods

Name | Description
BuildTasks |

See Also

ITaskBuilder Interface
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ITaskBuilder Methods

[image] [image]

.NET Framework Class Library
ITaskBuilder Methods
ITaskBuilder Interface See Also Send Feedback

The ITaskBuilder type exposes the following members.

Methods

Name | Description
BuildTasks |

See Also

ITaskBuilder Interface
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildTasks Method

[image]

.NET Framework Class Library
ITaskBuilder..::.BuildTasks Method
ITaskBuilder Interface See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Function BuildTasks ( _
    scheduledTasks As IList(Of ScheduledTask) _
) As List(Of IntegrationTask)
C#
List<IntegrationTask> BuildTasks(
    IList<ScheduledTask> scheduledTasks
)
Visual C++
List<IntegrationTask^>^ BuildTasks(
    IList<ScheduledTask^>^ scheduledTasks
)
JavaScript
function buildTasks(scheduledTasks);

Parameters

scheduledTasks
Type: System.Collections.Generic..::.IList <(Of <( ScheduledTask >)>)

See Also

ITaskBuilder Interface
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Epicor9 Class

[image]

.NET Framework Class Library
TaskBuilder_Epicor9 Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBuilder_Epicor9 _
    Inherits TaskBuilderBase
C#
public class TaskBuilder_Epicor9 : TaskBuilderBase
Visual C++
public ref class TaskBuilder_Epicor9 : public TaskBuilderBase
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Epicor9 = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Epicor9',
    InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Epicor9

See Also

TaskBuilder_Epicor9 Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Epicor9 Members

[image] [image]

.NET Framework Class Library
TaskBuilder_Epicor9 Members
TaskBuilder_Epicor9 Class Constructors Methods Properties See Also Send Feedback

The TaskBuilder_Epicor9 type exposes the following members.

Constructors

Name | Description
TaskBuilder_Epicor9 |

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Inherited from TaskBuilderBase.)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Inherited from TaskBuilderBase.)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Inherited from TaskBuilderBase.)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Overrides TaskBuilderBase..::.BuildTasks(IList<(Of <(ScheduledTask>)>)).)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_Epicor9 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Epicor9 Constructor

[image]

.NET Framework Class Library
TaskBuilder_Epicor9 Constructor
TaskBuilder_Epicor9 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskBuilder_Epicor9()
Visual C++
public:
TaskBuilder_Epicor9()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Epicor9 = function();

See Also

TaskBuilder_Epicor9 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Epicor9 Methods

[image] [image]

.NET Framework Class Library
TaskBuilder_Epicor9 Methods
TaskBuilder_Epicor9 Class See Also Send Feedback

The TaskBuilder_Epicor9 type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Inherited from TaskBuilderBase.)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Inherited from TaskBuilderBase.)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Inherited from TaskBuilderBase.)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Overrides TaskBuilderBase..::.BuildTasks(IList<(Of <(ScheduledTask>)>)).)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilder_Epicor9 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildTasks Method

[image]

.NET Framework Class Library
TaskBuilder_Epicor9..::.BuildTasks Method
TaskBuilder_Epicor9 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildTasks ( _
    scheduledTasks As IList(Of ScheduledTask) _
) As List(Of IntegrationTask)
C#
public override List<IntegrationTask> BuildTasks(
    IList<ScheduledTask> scheduledTasks
)
Visual C++
public:
virtual List<IntegrationTask^>^ BuildTasks(
    IList<ScheduledTask^>^ scheduledTasks
) override
JavaScript
function buildTasks(scheduledTasks);

Parameters

scheduledTasks
Type: System.Collections.Generic..::.IList <(Of <( ScheduledTask >)>)

Implements

ITaskBuilder..::.BuildTasks(IList<(Of <(ScheduledTask>)>))

See Also

TaskBuilder_Epicor9 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Epicor9 Properties

[image] [image]

.NET Framework Class Library
TaskBuilder_Epicor9 Properties
TaskBuilder_Epicor9 Class See Also Send Feedback

The TaskBuilder_Epicor9 type exposes the following members.

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_Epicor9 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilder_Epicor9..::.ERPType Property
TaskBuilder_Epicor9 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ERPType As String
C#
public override string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () override;
}
JavaScript
function get_erpType();

See Also

TaskBuilder_Epicor9 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Mas200 Class

[image]

.NET Framework Class Library
TaskBuilder_Mas200 Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBuilder_Mas200 _
    Inherits TaskBuilderBase
C#
public class TaskBuilder_Mas200 : TaskBuilderBase
Visual C++
public ref class TaskBuilder_Mas200 : public TaskBuilderBase
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Mas200 = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Mas200',
    InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Mas200

See Also

TaskBuilder_Mas200 Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Mas200 Members

[image] [image]

.NET Framework Class Library
TaskBuilder_Mas200 Members
TaskBuilder_Mas200 Class Constructors Methods Properties See Also Send Feedback

The TaskBuilder_Mas200 type exposes the following members.

Constructors

Name | Description
TaskBuilder_Mas200 |

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Inherited from TaskBuilderBase.)
BuildDealerRefreshTask | (Overrides TaskBuilderBase..::.BuildDealerRefreshTask(ScheduledTask).)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Overrides TaskBuilderBase..::.BuildShipmentsRefreshTask(ScheduledTask).)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)
ProductQuery |

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Mas200 Constructor

[image]

.NET Framework Class Library
TaskBuilder_Mas200 Constructor
TaskBuilder_Mas200 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskBuilder_Mas200()
Visual C++
public:
TaskBuilder_Mas200()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Mas200 = function();

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Mas200 Methods

[image] [image]

.NET Framework Class Library
TaskBuilder_Mas200 Methods
TaskBuilder_Mas200 Class See Also Send Feedback

The TaskBuilder_Mas200 type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Inherited from TaskBuilderBase.)
BuildDealerRefreshTask | (Overrides TaskBuilderBase..::.BuildDealerRefreshTask(ScheduledTask).)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Overrides TaskBuilderBase..::.BuildShipmentsRefreshTask(ScheduledTask).)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildDealerRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Mas200..::.BuildDealerRefreshTask Method
TaskBuilder_Mas200 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildDealerRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildDealerRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildDealerRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildDealerRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildProductRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Mas200..::.BuildProductRefreshTask Method
TaskBuilder_Mas200 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildProductRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildProductRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildProductRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildProductRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildShipmentsRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Mas200..::.BuildShipmentsRefreshTask Method
TaskBuilder_Mas200 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildShipmentsRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildShipmentsRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildShipmentsRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildShipmentsRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Mas200 Properties

[image] [image]

.NET Framework Class Library
TaskBuilder_Mas200 Properties
TaskBuilder_Mas200 Class See Also Send Feedback

The TaskBuilder_Mas200 type exposes the following members.

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)
ProductQuery |

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilder_Mas200..::.ERPType Property
TaskBuilder_Mas200 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ERPType As String
C#
public override string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () override;
}
JavaScript
function get_erpType();

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ProductQuery Property

[image]

.NET Framework Class Library
TaskBuilder_Mas200..::.ProductQuery Property
TaskBuilder_Mas200 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProductQuery As String
C#
public string ProductQuery { get; }
Visual C++
public:
property String^ ProductQuery {
    String^ get ();
}
JavaScript
function get_productQuery();

See Also

TaskBuilder_Mas200 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Solomon Class

[image]

.NET Framework Class Library
TaskBuilder_Solomon Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBuilder_Solomon _
    Inherits TaskBuilderBase
C#
public class TaskBuilder_Solomon : TaskBuilderBase
Visual C++
public ref class TaskBuilder_Solomon : public TaskBuilderBase
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Solomon = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Solomon',
    InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Solomon

See Also

TaskBuilder_Solomon Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Solomon Members

[image] [image]

.NET Framework Class Library
TaskBuilder_Solomon Members
TaskBuilder_Solomon Class Constructors Methods Properties See Also Send Feedback

The TaskBuilder_Solomon type exposes the following members.

Constructors

Name | Description
TaskBuilder_Solomon |

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerOrdersRefreshTask(ScheduledTask).)
BuildCustomerRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerRefreshTask(ScheduledTask).)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Overrides TaskBuilderBase..::.BuildInvoicesRefreshTask(ScheduledTask).)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Overrides TaskBuilderBase..::.BuildShipmentsRefreshTask(ScheduledTask).)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomerRefreshQuery |
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Solomon Constructor

[image]

.NET Framework Class Library
TaskBuilder_Solomon Constructor
TaskBuilder_Solomon Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskBuilder_Solomon()
Visual C++
public:
TaskBuilder_Solomon()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Solomon = function();

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Solomon Methods

[image] [image]

.NET Framework Class Library
TaskBuilder_Solomon Methods
TaskBuilder_Solomon Class See Also Send Feedback

The TaskBuilder_Solomon type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerOrdersRefreshTask(ScheduledTask).)
BuildCustomerRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerRefreshTask(ScheduledTask).)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Overrides TaskBuilderBase..::.BuildInvoicesRefreshTask(ScheduledTask).)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Overrides TaskBuilderBase..::.BuildShipmentsRefreshTask(ScheduledTask).)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomerRefreshQuery |
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerOrdersRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Solomon..::.BuildCustomerOrdersRefreshTask Method
TaskBuilder_Solomon Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildCustomerOrdersRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildCustomerOrdersRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerOrdersRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildCustomerOrdersRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Solomon..::.BuildCustomerRefreshTask Method
TaskBuilder_Solomon Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildCustomerRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildCustomerRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildCustomerRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildInvoicesRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Solomon..::.BuildInvoicesRefreshTask Method
TaskBuilder_Solomon Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildInvoicesRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildInvoicesRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildInvoicesRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildInvoicesRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildProductRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Solomon..::.BuildProductRefreshTask Method
TaskBuilder_Solomon Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildProductRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildProductRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildProductRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildProductRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildShipmentsRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Solomon..::.BuildShipmentsRefreshTask Method
TaskBuilder_Solomon Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildShipmentsRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildShipmentsRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildShipmentsRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildShipmentsRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


GetCustomerRefreshQuery Method

[image]

.NET Framework Class Library
TaskBuilder_Solomon..::.GetCustomerRefreshQuery Method
TaskBuilder_Solomon Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetCustomerRefreshQuery ( _
    task As IntegrationTask _
) As IntegrationQuery
C#
protected virtual IntegrationQuery GetCustomerRefreshQuery(
    IntegrationTask task
)
Visual C++
protected:
virtual IntegrationQuery^ GetCustomerRefreshQuery(
    IntegrationTask^ task
)
JavaScript
function getCustomerRefreshQuery(task);

Parameters

task
Type: InSite.Domain.ERPIntegration.IntegrationTasks..::.IntegrationTask

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Solomon Properties

[image] [image]

.NET Framework Class Library
TaskBuilder_Solomon Properties
TaskBuilder_Solomon Class See Also Send Feedback

The TaskBuilder_Solomon type exposes the following members.

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilder_Solomon..::.ERPType Property
TaskBuilder_Solomon Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ERPType As String
C#
public override string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () override;
}
JavaScript
function get_erpType();

See Also

TaskBuilder_Solomon Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SXe Class

[image]

.NET Framework Class Library
TaskBuilder_SXe Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBuilder_SXe _
    Inherits TaskBuilderBase
C#
public class TaskBuilder_SXe : TaskBuilderBase
Visual C++
public ref class TaskBuilder_SXe : public TaskBuilderBase
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SXe = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SXe',
    InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_SXe

See Also

TaskBuilder_SXe Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SXe Members

[image] [image]

.NET Framework Class Library
TaskBuilder_SXe Members
TaskBuilder_SXe Class Constructors Methods Properties See Also Send Feedback

The TaskBuilder_SXe type exposes the following members.

Constructors

Name | Description
TaskBuilder_SXe |

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Inherited from TaskBuilderBase.)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Overrides TaskBuilderBase..::.BuildInventoryRefreshTask(ScheduledTask).)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Inherited from TaskBuilderBase.)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Inherited from TaskBuilderBase.)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_SXe Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SXe Constructor

[image]

.NET Framework Class Library
TaskBuilder_SXe Constructor
TaskBuilder_SXe Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskBuilder_SXe()
Visual C++
public:
TaskBuilder_SXe()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SXe = function();

See Also

TaskBuilder_SXe Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SXe Methods

[image] [image]

.NET Framework Class Library
TaskBuilder_SXe Methods
TaskBuilder_SXe Class See Also Send Feedback

The TaskBuilder_SXe type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Inherited from TaskBuilderBase.)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Overrides TaskBuilderBase..::.BuildInventoryRefreshTask(ScheduledTask).)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Inherited from TaskBuilderBase.)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Inherited from TaskBuilderBase.)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilder_SXe Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildInventoryRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SXe..::.BuildInventoryRefreshTask Method
TaskBuilder_SXe Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildInventoryRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildInventoryRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildInventoryRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildInventoryRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SXe Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SXe Properties

[image] [image]

.NET Framework Class Library
TaskBuilder_SXe Properties
TaskBuilder_SXe Class See Also Send Feedback

The TaskBuilder_SXe type exposes the following members.

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_SXe Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilder_SXe..::.ERPType Property
TaskBuilder_SXe Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ERPType As String
C#
public override string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () override;
}
JavaScript
function get_erpType();

See Also

TaskBuilder_SXe Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine6 Class

[image]

.NET Framework Class Library
TaskBuilder_SyteLine6 Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBuilder_SyteLine6 _
    Inherits TaskBuilderBase
C#
public class TaskBuilder_SyteLine6 : TaskBuilderBase
Visual C++
public ref class TaskBuilder_SyteLine6 : public TaskBuilderBase
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SyteLine6 = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SyteLine6',
    InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_SyteLine6

See Also

TaskBuilder_SyteLine6 Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine6 Members

[image] [image]

.NET Framework Class Library
TaskBuilder_SyteLine6 Members
TaskBuilder_SyteLine6 Class Constructors Methods Properties See Also Send Feedback

The TaskBuilder_SyteLine6 type exposes the following members.

Constructors

Name | Description
TaskBuilder_SyteLine6 |

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerOrdersRefreshTask(ScheduledTask).)
BuildCustomerRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerRefreshTask(ScheduledTask).)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Overrides TaskBuilderBase..::.BuildInvoicesRefreshTask(ScheduledTask).)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Overrides TaskBuilderBase..::.BuildShipmentsRefreshTask(ScheduledTask).)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine6 Constructor

[image]

.NET Framework Class Library
TaskBuilder_SyteLine6 Constructor
TaskBuilder_SyteLine6 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskBuilder_SyteLine6()
Visual C++
public:
TaskBuilder_SyteLine6()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SyteLine6 = function();

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine6 Methods

[image] [image]

.NET Framework Class Library
TaskBuilder_SyteLine6 Methods
TaskBuilder_SyteLine6 Class See Also Send Feedback

The TaskBuilder_SyteLine6 type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerOrdersRefreshTask(ScheduledTask).)
BuildCustomerRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerRefreshTask(ScheduledTask).)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Overrides TaskBuilderBase..::.BuildInvoicesRefreshTask(ScheduledTask).)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Overrides TaskBuilderBase..::.BuildShipmentsRefreshTask(ScheduledTask).)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerOrdersRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine6..::.BuildCustomerOrdersRefreshTask Method
TaskBuilder_SyteLine6 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildCustomerOrdersRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildCustomerOrdersRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerOrdersRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildCustomerOrdersRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine6..::.BuildCustomerRefreshTask Method
TaskBuilder_SyteLine6 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildCustomerRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildCustomerRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildCustomerRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildInvoicesRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine6..::.BuildInvoicesRefreshTask Method
TaskBuilder_SyteLine6 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildInvoicesRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildInvoicesRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildInvoicesRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildInvoicesRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildProductRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine6..::.BuildProductRefreshTask Method
TaskBuilder_SyteLine6 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildProductRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildProductRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildProductRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildProductRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildShipmentsRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine6..::.BuildShipmentsRefreshTask Method
TaskBuilder_SyteLine6 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildShipmentsRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildShipmentsRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildShipmentsRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildShipmentsRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine6 Properties

[image] [image]

.NET Framework Class Library
TaskBuilder_SyteLine6 Properties
TaskBuilder_SyteLine6 Class See Also Send Feedback

The TaskBuilder_SyteLine6 type exposes the following members.

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilder_SyteLine6..::.ERPType Property
TaskBuilder_SyteLine6 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ERPType As String
C#
public override string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () override;
}
JavaScript
function get_erpType();

See Also

TaskBuilder_SyteLine6 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine7 Class

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7 Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBuilder_SyteLine7 _
    Inherits TaskBuilderBase
C#
public class TaskBuilder_SyteLine7 : TaskBuilderBase
Visual C++
public ref class TaskBuilder_SyteLine7 : public TaskBuilderBase
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SyteLine7 = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SyteLine7',
    InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_SyteLine7

See Also

TaskBuilder_SyteLine7 Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine7 Members

[image] [image]

.NET Framework Class Library
TaskBuilder_SyteLine7 Members
TaskBuilder_SyteLine7 Class Constructors Methods Properties See Also Send Feedback

The TaskBuilder_SyteLine7 type exposes the following members.

Constructors

Name | Description
TaskBuilder_SyteLine7 |

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerOrdersRefreshTask(ScheduledTask).)
BuildCustomerRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerRefreshTask(ScheduledTask).)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Overrides TaskBuilderBase..::.BuildInvoicesRefreshTask(ScheduledTask).)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Overrides TaskBuilderBase..::.BuildSalesmanRefreshTask(ScheduledTask).)
BuildShipmentsRefreshTask | (Overrides TaskBuilderBase..::.BuildShipmentsRefreshTask(ScheduledTask).)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine7 Constructor

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7 Constructor
TaskBuilder_SyteLine7 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskBuilder_SyteLine7()
Visual C++
public:
TaskBuilder_SyteLine7()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_SyteLine7 = function();

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine7 Methods

[image] [image]

.NET Framework Class Library
TaskBuilder_SyteLine7 Methods
TaskBuilder_SyteLine7 Class See Also Send Feedback

The TaskBuilder_SyteLine7 type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerOrdersRefreshTask(ScheduledTask).)
BuildCustomerRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerRefreshTask(ScheduledTask).)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Overrides TaskBuilderBase..::.BuildInvoicesRefreshTask(ScheduledTask).)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Overrides TaskBuilderBase..::.BuildSalesmanRefreshTask(ScheduledTask).)
BuildShipmentsRefreshTask | (Overrides TaskBuilderBase..::.BuildShipmentsRefreshTask(ScheduledTask).)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerOrdersRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7..::.BuildCustomerOrdersRefreshTask Method
TaskBuilder_SyteLine7 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildCustomerOrdersRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildCustomerOrdersRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerOrdersRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildCustomerOrdersRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7..::.BuildCustomerRefreshTask Method
TaskBuilder_SyteLine7 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildCustomerRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildCustomerRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildCustomerRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildInvoicesRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7..::.BuildInvoicesRefreshTask Method
TaskBuilder_SyteLine7 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildInvoicesRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildInvoicesRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildInvoicesRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildInvoicesRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildProductRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7..::.BuildProductRefreshTask Method
TaskBuilder_SyteLine7 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildProductRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildProductRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildProductRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildProductRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildSalesmanRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7..::.BuildSalesmanRefreshTask Method
TaskBuilder_SyteLine7 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildSalesmanRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildSalesmanRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildSalesmanRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildSalesmanRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildShipmentsRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7..::.BuildShipmentsRefreshTask Method
TaskBuilder_SyteLine7 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildShipmentsRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildShipmentsRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildShipmentsRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildShipmentsRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_SyteLine7 Properties

[image] [image]

.NET Framework Class Library
TaskBuilder_SyteLine7 Properties
TaskBuilder_SyteLine7 Class See Also Send Feedback

The TaskBuilder_SyteLine7 type exposes the following members.

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilder_SyteLine7..::.ERPType Property
TaskBuilder_SyteLine7 Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ERPType As String
C#
public override string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () override;
}
JavaScript
function get_erpType();

See Also

TaskBuilder_SyteLine7 Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Vantage Class

[image]

.NET Framework Class Library
TaskBuilder_Vantage Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBuilder_Vantage _
    Inherits TaskBuilderBase
C#
public class TaskBuilder_Vantage : TaskBuilderBase
Visual C++
public ref class TaskBuilder_Vantage : public TaskBuilderBase
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Vantage = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Vantage',
    InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Vantage

See Also

TaskBuilder_Vantage Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Vantage Members

[image] [image]

.NET Framework Class Library
TaskBuilder_Vantage Members
TaskBuilder_Vantage Class Constructors Methods Properties See Also Send Feedback

The TaskBuilder_Vantage type exposes the following members.

Constructors

Name | Description
TaskBuilder_Vantage |

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Inherited from TaskBuilderBase.)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Inherited from TaskBuilderBase.)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Inherited from TaskBuilderBase.)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Overrides TaskBuilderBase..::.BuildTasks(IList<(Of <(ScheduledTask>)>)).)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_Vantage Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Vantage Constructor

[image]

.NET Framework Class Library
TaskBuilder_Vantage Constructor
TaskBuilder_Vantage Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskBuilder_Vantage()
Visual C++
public:
TaskBuilder_Vantage()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Vantage = function();

See Also

TaskBuilder_Vantage Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Vantage Methods

[image] [image]

.NET Framework Class Library
TaskBuilder_Vantage Methods
TaskBuilder_Vantage Class See Also Send Feedback

The TaskBuilder_Vantage type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Inherited from TaskBuilderBase.)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Inherited from TaskBuilderBase.)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Inherited from TaskBuilderBase.)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Overrides TaskBuilderBase..::.BuildTasks(IList<(Of <(ScheduledTask>)>)).)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilder_Vantage Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildTasks Method

[image]

.NET Framework Class Library
TaskBuilder_Vantage..::.BuildTasks Method
TaskBuilder_Vantage Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildTasks ( _
    scheduledTasks As IList(Of ScheduledTask) _
) As List(Of IntegrationTask)
C#
public override List<IntegrationTask> BuildTasks(
    IList<ScheduledTask> scheduledTasks
)
Visual C++
public:
virtual List<IntegrationTask^>^ BuildTasks(
    IList<ScheduledTask^>^ scheduledTasks
) override
JavaScript
function buildTasks(scheduledTasks);

Parameters

scheduledTasks
Type: System.Collections.Generic..::.IList <(Of <( ScheduledTask >)>)

Implements

ITaskBuilder..::.BuildTasks(IList<(Of <(ScheduledTask>)>))

See Also

TaskBuilder_Vantage Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Vantage Properties

[image] [image]

.NET Framework Class Library
TaskBuilder_Vantage Properties
TaskBuilder_Vantage Class See Also Send Feedback

The TaskBuilder_Vantage type exposes the following members.

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_Vantage Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilder_Vantage..::.ERPType Property
TaskBuilder_Vantage Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ERPType As String
C#
public override string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () override;
}
JavaScript
function get_erpType();

See Also

TaskBuilder_Vantage Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Visual Class

[image]

.NET Framework Class Library
TaskBuilder_Visual Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class TaskBuilder_Visual _
    Inherits TaskBuilderBase
C#
public class TaskBuilder_Visual : TaskBuilderBase
Visual C++
public ref class TaskBuilder_Visual : public TaskBuilderBase
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Visual = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Visual',
    InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Visual

See Also

TaskBuilder_Visual Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Visual Members

[image] [image]

.NET Framework Class Library
TaskBuilder_Visual Members
TaskBuilder_Visual Class Constructors Methods Properties See Also Send Feedback

The TaskBuilder_Visual type exposes the following members.

Constructors

Name | Description
TaskBuilder_Visual |

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerRefreshTask(ScheduledTask).)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Inherited from TaskBuilderBase.)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_Visual Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Visual Constructor

[image]

.NET Framework Class Library
TaskBuilder_Visual Constructor
TaskBuilder_Visual Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaskBuilder_Visual()
Visual C++
public:
TaskBuilder_Visual()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilder_Visual = function();

See Also

TaskBuilder_Visual Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Visual Methods

[image] [image]

.NET Framework Class Library
TaskBuilder_Visual Methods
TaskBuilder_Visual Class See Also Send Feedback

The TaskBuilder_Visual type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask | (Inherited from TaskBuilderBase.)
BuildCustomerRefreshTask | (Overrides TaskBuilderBase..::.BuildCustomerRefreshTask(ScheduledTask).)
BuildDealerRefreshTask | (Inherited from TaskBuilderBase.)
BuildInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildInvoicesRefreshTask | (Inherited from TaskBuilderBase.)
BuildPricingRefreshTask | (Inherited from TaskBuilderBase.)
BuildProductRefreshTask | (Overrides TaskBuilderBase..::.BuildProductRefreshTask(ScheduledTask).)
BuildRealTimeInventoryRefreshTask | (Inherited from TaskBuilderBase.)
BuildSalesmanRefreshTask | (Inherited from TaskBuilderBase.)
BuildShipmentsRefreshTask | (Inherited from TaskBuilderBase.)
BuildStandardTask | (Inherited from TaskBuilderBase.)
BuildTasks | (Inherited from TaskBuilderBase.)
BuildVendorRefreshTask | (Inherited from TaskBuilderBase.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns | (Inherited from TaskBuilderBase.)
GetCustomFilter | (Inherited from TaskBuilderBase.)
GetCustomFromClause | (Inherited from TaskBuilderBase.)
GetCustomJoin | (Inherited from TaskBuilderBase.)
GetCustomSelectClause | (Inherited from TaskBuilderBase.)
GetCustomWhereClause | (Inherited from TaskBuilderBase.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery | (Inherited from TaskBuilderBase.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilder_Visual Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Visual..::.BuildCustomerRefreshTask Method
TaskBuilder_Visual Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildCustomerRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildCustomerRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildCustomerRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Visual Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildProductRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilder_Visual..::.BuildProductRefreshTask Method
TaskBuilder_Visual Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function BuildProductRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public override IntegrationTask BuildProductRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildProductRefreshTask(
    ScheduledTask^ scheduledTask
) override
JavaScript
function buildProductRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilder_Visual Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilder_Visual Properties

[image] [image]

.NET Framework Class Library
TaskBuilder_Visual Properties
TaskBuilder_Visual Class See Also Send Feedback

The TaskBuilder_Visual type exposes the following members.

Properties

Name | Description
ConnectionString | (Inherited from TaskBuilderBase.)
ERPType | (Overrides TaskBuilderBase..::.ERPType.)

See Also

TaskBuilder_Visual Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilder_Visual..::.ERPType Property
TaskBuilder_Visual Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ERPType As String
C#
public override string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () override;
}
JavaScript
function get_erpType();

See Also

TaskBuilder_Visual Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilderBase Class

[image]

.NET Framework Class Library
TaskBuilderBase Class
Members See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class TaskBuilderBase _
    Implements ITaskBuilder
C#
public abstract class TaskBuilderBase : ITaskBuilder
Visual C++
public ref class TaskBuilderBase abstract : ITaskBuilder
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase = function();

Type.createClass(
    'InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase',
    null,
    InSite.Domain.ERPIntegration.IntegrationTasks.ITaskBuilder);

Inheritance Hierarchy

System..::.Object
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilderBase
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Epicor9
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Mas200
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Solomon
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_SXe
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_SyteLine6
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_SyteLine7
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Vantage
InSite.Domain.ERPIntegration.IntegrationTasks..::.TaskBuilder_Visual

See Also

TaskBuilderBase Members
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilderBase Members

[image] [image]

.NET Framework Class Library
TaskBuilderBase Members
TaskBuilderBase Class Constructors Methods Properties See Also Send Feedback

The TaskBuilderBase type exposes the following members.

Constructors

Name | Description
TaskBuilderBase |

Methods

Name | Description
BuildCustomerOrdersRefreshTask |
BuildCustomerRefreshTask |
BuildDealerRefreshTask |
BuildInventoryRefreshTask |
BuildInvoicesRefreshTask |
BuildPricingRefreshTask |
BuildProductRefreshTask |
BuildRealTimeInventoryRefreshTask |
BuildSalesmanRefreshTask |
BuildShipmentsRefreshTask |
BuildStandardTask |
BuildSystemTasks |
BuildTasks |
BuildVendorRefreshTask |
CheckForReSubmitOrders |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns |
GetCustomFilter |
GetCustomFromClause |
GetCustomJoin |
GetCustomSelectClause |
GetCustomWhereClause |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConnectionString |
ERPType |

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilderBase Constructor

[image]

.NET Framework Class Library
TaskBuilderBase Constructor
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected TaskBuilderBase()
Visual C++
protected:
TaskBuilderBase()
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase = function();

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilderBase Methods

[image] [image]

.NET Framework Class Library
TaskBuilderBase Methods
TaskBuilderBase Class See Also Send Feedback

The TaskBuilderBase type exposes the following members.

Methods

Name | Description
BuildCustomerOrdersRefreshTask |
BuildCustomerRefreshTask |
BuildDealerRefreshTask |
BuildInventoryRefreshTask |
BuildInvoicesRefreshTask |
BuildPricingRefreshTask |
BuildProductRefreshTask |
BuildRealTimeInventoryRefreshTask |
BuildSalesmanRefreshTask |
BuildShipmentsRefreshTask |
BuildStandardTask |
BuildSystemTasks |
BuildTasks |
BuildVendorRefreshTask |
CheckForReSubmitOrders |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomAdditionalColumns |
GetCustomFilter |
GetCustomFromClause |
GetCustomJoin |
GetCustomSelectClause |
GetCustomWhereClause |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetQuery |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerOrdersRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildCustomerOrdersRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildCustomerOrdersRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildCustomerOrdersRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerOrdersRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildCustomerOrdersRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildCustomerRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildCustomerRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildCustomerRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildCustomerRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildCustomerRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildCustomerRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildDealerRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildDealerRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildDealerRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildDealerRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildDealerRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildDealerRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildInventoryRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildInventoryRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildInventoryRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildInventoryRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildInventoryRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildInventoryRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildInvoicesRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildInvoicesRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildInvoicesRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildInvoicesRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildInvoicesRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildInvoicesRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildPricingRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildPricingRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildPricingRefreshTask ( _
    scheduledtask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildPricingRefreshTask(
    ScheduledTask scheduledtask
)
Visual C++
public:
virtual IntegrationTask^ BuildPricingRefreshTask(
    ScheduledTask^ scheduledtask
)
JavaScript
function buildPricingRefreshTask(scheduledtask);

Parameters

scheduledtask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildProductRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildProductRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildProductRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildProductRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildProductRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildProductRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildRealTimeInventoryRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildRealTimeInventoryRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildRealTimeInventoryRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildRealTimeInventoryRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildRealTimeInventoryRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildRealTimeInventoryRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildSalesmanRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildSalesmanRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildSalesmanRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildSalesmanRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildSalesmanRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildSalesmanRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildShipmentsRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildShipmentsRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildShipmentsRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildShipmentsRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildShipmentsRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildShipmentsRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildStandardTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildStandardTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function BuildStandardTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
protected IntegrationTask BuildStandardTask(
    ScheduledTask scheduledTask
)
Visual C++
protected:
IntegrationTask^ BuildStandardTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildStandardTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildSystemTasks Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildSystemTasks Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BuildSystemTasks ( _
    scheduledTasks As IList(Of ScheduledTask) _
) As List(Of IntegrationTask)
C#
public static List<IntegrationTask> BuildSystemTasks(
    IList<ScheduledTask> scheduledTasks
)
Visual C++
public:
static List<IntegrationTask^>^ BuildSystemTasks(
    IList<ScheduledTask^>^ scheduledTasks
)
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase.buildSystemTasks = function(scheduledTasks);

Parameters

scheduledTasks
Type: System.Collections.Generic..::.IList <(Of <( ScheduledTask >)>)

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildTasks Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildTasks Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildTasks ( _
    scheduledTasks As IList(Of ScheduledTask) _
) As List(Of IntegrationTask)
C#
public virtual List<IntegrationTask> BuildTasks(
    IList<ScheduledTask> scheduledTasks
)
Visual C++
public:
virtual List<IntegrationTask^>^ BuildTasks(
    IList<ScheduledTask^>^ scheduledTasks
)
JavaScript
function buildTasks(scheduledTasks);

Parameters

scheduledTasks
Type: System.Collections.Generic..::.IList <(Of <( ScheduledTask >)>)

Implements

ITaskBuilder..::.BuildTasks(IList<(Of <(ScheduledTask>)>))

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


BuildVendorRefreshTask Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.BuildVendorRefreshTask Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function BuildVendorRefreshTask ( _
    scheduledTask As ScheduledTask _
) As IntegrationTask
C#
public virtual IntegrationTask BuildVendorRefreshTask(
    ScheduledTask scheduledTask
)
Visual C++
public:
virtual IntegrationTask^ BuildVendorRefreshTask(
    ScheduledTask^ scheduledTask
)
JavaScript
function buildVendorRefreshTask(scheduledTask);

Parameters

scheduledTask
Type: InSite.Model..::.ScheduledTask

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


CheckForReSubmitOrders Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.CheckForReSubmitOrders Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CheckForReSubmitOrders ( _
    scheduledTasks As IList(Of ScheduledTask) _
)
C#
public static void CheckForReSubmitOrders(
    IList<ScheduledTask> scheduledTasks
)
Visual C++
public:
static void CheckForReSubmitOrders(
    IList<ScheduledTask^>^ scheduledTasks
)
JavaScript
InSite.Domain.ERPIntegration.IntegrationTasks.TaskBuilderBase.checkForReSubmitOrders = function(scheduledTasks);

Parameters

scheduledTasks
Type: System.Collections.Generic..::.IList <(Of <( ScheduledTask >)>)

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


GetCustomAdditionalColumns Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.GetCustomAdditionalColumns Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetCustomAdditionalColumns ( _
    queryName As String _
) As String
C#
protected string GetCustomAdditionalColumns(
    string queryName
)
Visual C++
protected:
String^ GetCustomAdditionalColumns(
    String^ queryName
)
JavaScript
function getCustomAdditionalColumns(queryName);

Parameters

queryName
Type: System..::.String

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


GetCustomFilter Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.GetCustomFilter Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetCustomFilter ( _
    queryName As String, _
    prependAnd As Boolean _
) As String
C#
protected string GetCustomFilter(
    string queryName,
    bool prependAnd
)
Visual C++
protected:
String^ GetCustomFilter(
    String^ queryName,
    bool prependAnd
)
JavaScript
function getCustomFilter(queryName, prependAnd);

Parameters

queryName
Type: System..::.String
prependAnd
Type: System..::.Boolean

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


GetCustomFromClause Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.GetCustomFromClause Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetCustomFromClause ( _
    queryName As String _
) As String
C#
protected string GetCustomFromClause(
    string queryName
)
Visual C++
protected:
String^ GetCustomFromClause(
    String^ queryName
)
JavaScript
function getCustomFromClause(queryName);

Parameters

queryName
Type: System..::.String

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


GetCustomJoin Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.GetCustomJoin Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetCustomJoin ( _
    queryName As String _
) As String
C#
protected string GetCustomJoin(
    string queryName
)
Visual C++
protected:
String^ GetCustomJoin(
    String^ queryName
)
JavaScript
function getCustomJoin(queryName);

Parameters

queryName
Type: System..::.String

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


GetCustomSelectClause Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.GetCustomSelectClause Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetCustomSelectClause ( _
    queryName As String _
) As String
C#
protected string GetCustomSelectClause(
    string queryName
)
Visual C++
protected:
String^ GetCustomSelectClause(
    String^ queryName
)
JavaScript
function getCustomSelectClause(queryName);

Parameters

queryName
Type: System..::.String

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


GetCustomWhereClause Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.GetCustomWhereClause Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetCustomWhereClause ( _
    queryName As String _
) As String
C#
protected string GetCustomWhereClause(
    string queryName
)
Visual C++
protected:
String^ GetCustomWhereClause(
    String^ queryName
)
JavaScript
function getCustomWhereClause(queryName);

Parameters

queryName
Type: System..::.String

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


GetQuery Method

[image]

.NET Framework Class Library
TaskBuilderBase..::.GetQuery Method
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Function GetQuery ( _
    queryName As String, _
    standardQueryColumns As String, _
    standardFromClause As String, _
    whereClause As String _
) As String
C#
protected string GetQuery(
    string queryName,
    string standardQueryColumns,
    string standardFromClause,
    string whereClause
)
Visual C++
protected:
String^ GetQuery(
    String^ queryName,
    String^ standardQueryColumns,
    String^ standardFromClause,
    String^ whereClause
)
JavaScript
function getQuery(queryName, standardQueryColumns, standardFromClause, whereClause);

Parameters

queryName
Type: System..::.String
standardQueryColumns
Type: System..::.String
standardFromClause
Type: System..::.String
whereClause
Type: System..::.String

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


TaskBuilderBase Properties

[image] [image]

.NET Framework Class Library
TaskBuilderBase Properties
TaskBuilderBase Class See Also Send Feedback

The TaskBuilderBase type exposes the following members.

Properties

Name | Description
ConnectionString |
ERPType |

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ConnectionString Property

[image]

.NET Framework Class Library
TaskBuilderBase..::.ConnectionString Property
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ConnectionString As String
C#
public string ConnectionString { get; }
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
}
JavaScript
function get_connectionString();

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


ERPType Property

[image]

.NET Framework Class Library
TaskBuilderBase..::.ERPType Property
TaskBuilderBase Class See Also Send Feedback

Namespace: InSite.Domain.ERPIntegration.IntegrationTasks
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property ERPType As String
C#
public abstract string ERPType { get; }
Visual C++
public:
virtual property String^ ERPType {
    String^ get () abstract;
}
JavaScript
function get_erpType();

See Also

TaskBuilderBase Class
InSite.Domain.ERPIntegration.IntegrationTasks Namespace


InSite.Domain.Exceptions Namespace

[image]

.NET Framework Class Library
InSite.Domain.Exceptions Namespace
Send Feedback

Classes

Class | Description
MissingWebPageContentException |
ShippingException |
SiteConfigurationException |


MissingWebPageContentException Class

[image]

.NET Framework Class Library
MissingWebPageContentException Class
Members See Also Send Feedback

Namespace: InSite.Domain.Exceptions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class MissingWebPageContentException _
    Inherits Exception
C#
public class MissingWebPageContentException : Exception
Visual C++
public ref class MissingWebPageContentException : public Exception
JavaScript
InSite.Domain.Exceptions.MissingWebPageContentException = function();

Type.createClass(
    'InSite.Domain.Exceptions.MissingWebPageContentException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Domain.Exceptions..::.MissingWebPageContentException

See Also

MissingWebPageContentException Members
InSite.Domain.Exceptions Namespace


MissingWebPageContentException Members

[image] [image]

.NET Framework Class Library
MissingWebPageContentException Members
MissingWebPageContentException Class Constructors Methods Properties See Also Send Feedback

The MissingWebPageContentException type exposes the following members.

Constructors

Name | Description
MissingWebPageContentException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MissingWebPageContentException Class
InSite.Domain.Exceptions Namespace


MissingWebPageContentException Constructor

[image]

.NET Framework Class Library
MissingWebPageContentException Constructor
MissingWebPageContentException Class See Also Send Feedback

Namespace: InSite.Domain.Exceptions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    contentName As String, _
    webSiteName As String _
)
C#
public MissingWebPageContentException(
    string contentName,
    string webSiteName
)
Visual C++
public:
MissingWebPageContentException(
    String^ contentName,
    String^ webSiteName
)
JavaScript
InSite.Domain.Exceptions.MissingWebPageContentException = function(contentName, webSiteName);

Parameters

contentName
Type: System..::.String
webSiteName
Type: System..::.String

See Also

MissingWebPageContentException Class
InSite.Domain.Exceptions Namespace


MissingWebPageContentException Methods

[image] [image]

.NET Framework Class Library
MissingWebPageContentException Methods
MissingWebPageContentException Class See Also Send Feedback

The MissingWebPageContentException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MissingWebPageContentException Class
InSite.Domain.Exceptions Namespace


MissingWebPageContentException Properties

[image] [image]

.NET Framework Class Library
MissingWebPageContentException Properties
MissingWebPageContentException Class See Also Send Feedback

The MissingWebPageContentException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MissingWebPageContentException Class
InSite.Domain.Exceptions Namespace


ShippingException Class

[image]

.NET Framework Class Library
ShippingException Class
Members See Also Send Feedback

Namespace: InSite.Domain.Exceptions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ShippingException _
    Inherits Exception
C#
public class ShippingException : Exception
Visual C++
public ref class ShippingException : public Exception
JavaScript
InSite.Domain.Exceptions.ShippingException = function();

Type.createClass(
    'InSite.Domain.Exceptions.ShippingException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Domain.Exceptions..::.ShippingException

See Also

ShippingException Members
InSite.Domain.Exceptions Namespace


ShippingException Members

[image] [image]

.NET Framework Class Library
ShippingException Members
ShippingException Class Constructors Methods Properties See Also Send Feedback

The ShippingException type exposes the following members.

Constructors

Name | Description
ShippingException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ShippingException Class
InSite.Domain.Exceptions Namespace


ShippingException Constructor

[image]

.NET Framework Class Library
ShippingException Constructor
ShippingException Class See Also Send Feedback

Namespace: InSite.Domain.Exceptions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public ShippingException(
    string message
)
Visual C++
public:
ShippingException(
    String^ message
)
JavaScript
InSite.Domain.Exceptions.ShippingException = function(message);

Parameters

message
Type: System..::.String

See Also

ShippingException Class
InSite.Domain.Exceptions Namespace


ShippingException Methods

[image] [image]

.NET Framework Class Library
ShippingException Methods
ShippingException Class See Also Send Feedback

The ShippingException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ShippingException Class
InSite.Domain.Exceptions Namespace


ShippingException Properties

[image] [image]

.NET Framework Class Library
ShippingException Properties
ShippingException Class See Also Send Feedback

The ShippingException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ShippingException Class
InSite.Domain.Exceptions Namespace


SiteConfigurationException Class

[image]

.NET Framework Class Library
SiteConfigurationException Class
Members See Also Send Feedback

Namespace: InSite.Domain.Exceptions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class SiteConfigurationException _
    Inherits Exception
C#
public class SiteConfigurationException : Exception
Visual C++
public ref class SiteConfigurationException : public Exception
JavaScript
InSite.Domain.Exceptions.SiteConfigurationException = function();

Type.createClass(
    'InSite.Domain.Exceptions.SiteConfigurationException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Domain.Exceptions..::.SiteConfigurationException

See Also

SiteConfigurationException Members
InSite.Domain.Exceptions Namespace


SiteConfigurationException Members

[image] [image]

.NET Framework Class Library
SiteConfigurationException Members
SiteConfigurationException Class Constructors Methods Properties See Also Send Feedback

The SiteConfigurationException type exposes the following members.

Constructors

Name | Description
SiteConfigurationException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SiteConfigurationException Class
InSite.Domain.Exceptions Namespace


SiteConfigurationException Constructor

[image]

.NET Framework Class Library
SiteConfigurationException Constructor
SiteConfigurationException Class See Also Send Feedback

Namespace: InSite.Domain.Exceptions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public SiteConfigurationException(
    string message
)
Visual C++
public:
SiteConfigurationException(
    String^ message
)
JavaScript
InSite.Domain.Exceptions.SiteConfigurationException = function(message);

Parameters

message
Type: System..::.String

See Also

SiteConfigurationException Class
InSite.Domain.Exceptions Namespace


SiteConfigurationException Methods

[image] [image]

.NET Framework Class Library
SiteConfigurationException Methods
SiteConfigurationException Class See Also Send Feedback

The SiteConfigurationException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

SiteConfigurationException Class
InSite.Domain.Exceptions Namespace


SiteConfigurationException Properties

[image] [image]

.NET Framework Class Library
SiteConfigurationException Properties
SiteConfigurationException Class See Also Send Feedback

The SiteConfigurationException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

SiteConfigurationException Class
InSite.Domain.Exceptions Namespace


InSite.Domain.FedExRateService Namespace

[image]

.NET Framework Class Library
InSite.Domain.FedExRateService Namespace
Send Feedback

Classes

Class | Description
AdditionalLabelsDetail |
Address |
CertificateOfOriginDetail |
ClientDetail |
CodDetail |
CommercialInvoice |
CommercialInvoiceDetail |
CommitDetail |
Commodity |
ConfigurableLabelReferenceEntry |
Contact |
ContactAndAddress |
ContentRecord |
CurrencyExchangeRate |
CustomerImageUsage |
CustomerProvidedImage |
CustomerReference |
CustomerSpecifiedLabelDetail |
CustomLabelBarcodeEntry |
CustomLabelBoxEntry |
CustomLabelDetail |
CustomLabelGraphicEntry |
CustomLabelPosition |
CustomLabelTextEntry |
DangerousGoodsDetail |
DateRange |
DelayDetail |
DestinationControlDetail |
Dimensions |
Distance |
DocTabContent |
DocTabContentBarcoded |
DocTabZoneSpecification |
EdtCommodityTax |
EdtExciseCondition |
EdtTaxDetail |
EMailLabelDetail |
EMailNotificationDetail |
EMailNotificationRecipient |
EtdDetail |
ExportDetail |
ExpressFreightDetail |
ExpressFreightDetailContact |
FreightBaseCharge |
FreightCommitDetail |
FreightGuaranteeDetail |
FreightRateDetail |
FreightRateNotation |
FreightServiceCenterDetail |
FreightShipmentDetail |
FreightShipmentLineItem |
GeneralAgencyAgreementDetail |
getRatesCompletedEventArgs |
HazMatCertificateData |
HoldAtLocationDetail |
HomeDeliveryPremiumDetail |
InternationalDetail |
LabelSpecification |
Localization |
Measure |
Money |
NaftaCertificateOfOriginDetail |
NaftaCommodityDetail |
NaftaProducer |
Notification |
NotificationParameter |
PackageRateDetail |
PackageSpecialServicesRequested |
Party |
Payment |
Payor |
PendingShipmentDetail |
PickupDetail |
RateDiscount |
RatedPackageDetail |
RatedShipmentDetail |
RateReply |
RateReplyDetail |
RateRequest |
RateService |
Rebate |
RequestedPackageLineItem |
RequestedShipment |
ReturnEMailDetail |
ReturnShipmentDetail |
Rma |
ServiceSubOptionDetail |
ShipmentDryIceDetail |
ShipmentRateDetail |
ShipmentSpecialServicesRequested |
ShippingDocumentFormat |
ShippingDocumentSpecification |
SignatureOptionDetail |
SmartPostShipmentDetail |
Surcharge |
Tax |
TaxpayerIdentification |
TrackingId |
TransactionDetail |
UploadDocumentDetail |
UploadDocumentReferenceDetail |
VariableHandlingChargeDetail |
VariableHandlingCharges |
VersionId |
Volume |
WebAuthenticationCredential |
WebAuthenticationDetail |
Weight |

Delegates

Delegate | Description
getRatesCompletedEventHandler |

Enumerations

Enumeration | Description
AdditionalLabelsType |
B13AFilingOptionType |
BarcodeSymbologyType |
CarrierCodeType |
ClearanceBrokerageType |
CodAddTransportationChargesType |
CodCollectionType |
CodReturnReferenceIndicatorType |
CommitmentDelayType |
CustomerImageUsageType |
CustomerReferenceType |
CustomLabelCoordinateUnits |
DangerousGoodsAccessibilityType |
DayOfWeekType |
DelayLevelType |
DelayPointType |
DestinationControlStatementType |
DistanceUnits |
DocTabContentType |
DocTabZoneJustificationType |
DropoffType |
EdtRequestType |
EdtTaxType |
EMailNotificationFormatType |
EMailNotificationRecipientType |
ExpressRegionCode |
FlatbedTrailerOption |
FreightAccountPaymentType |
FreightChargeBasisType |
FreightClassType |
FreightGuaranteeType |
FreightServiceSchedulingType |
FreightShipmentRoleType |
HomeDeliveryPremiumType |
InternationalDocumentContentType |
LabelFormatType |
LabelMaskableDataType |
LabelPrintingOrientationType |
LabelRotationType |
LabelStockType |
LinearUnits |
MinimumChargeType |
NaftaImporterSpecificationType |
NaftaNetCostMethodCode |
NaftaPreferenceCriterionCode |
NaftaProducerDeterminationCode |
NaftaProducerSpecificationType |
NotificationSeverityType |
OversizeClassType |
PackageSpecialServiceType |
PackagingType |
PaymentType |
PendingShipmentType |
PhysicalPackagingType |
PickupRequestSourceType |
PickupRequestType |
PricingCodeType |
PurposeOfShipmentType |
RateDiscountType |
RatedWeightMethod |
RateRequestType |
RebateType |
RecipientCustomsIdType |
RegulatoryControlType |
RequestedPackageDetailType |
RequestedShippingDocumentType |
RequiredShippingDocumentType |
ReturnedRateType |
ReturnEMailAllowedSpecialServiceType |
ReturnType |
ServiceOptionType |
ServiceType |
ShipmentSpecialServiceType |
ShippingDocumentImageType |
ShippingDocumentStockType |
SignatureOptionType |
SmartPostAncillaryEndorsementType |
SmartPostIndiciaType |
SmartPostShipmentSpecialServiceType |
SpecialRatingAppliedType |
SurchargeLevelType |
SurchargeType |
TaxType |
TermsOfSaleType |
TinType |
TrackingIdType |
TransitTimeType |
UploadDocumentIdProducer |
UploadDocumentProducerType |
UploadDocumentType |
VariableHandlingChargeType |
VolumeUnits |
WeightUnits |


AdditionalLabelsDetail Class

[image]

.NET Framework Class Library
AdditionalLabelsDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class AdditionalLabelsDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class AdditionalLabelsDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class AdditionalLabelsDetail
JavaScript
InSite.Domain.FedExRateService.AdditionalLabelsDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.AdditionalLabelsDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.AdditionalLabelsDetail

See Also

AdditionalLabelsDetail Members
InSite.Domain.FedExRateService Namespace


AdditionalLabelsDetail Members

[image] [image]

.NET Framework Class Library
AdditionalLabelsDetail Members
AdditionalLabelsDetail Class Constructors Methods Properties See Also Send Feedback

The AdditionalLabelsDetail type exposes the following members.

Constructors

Name | Description
AdditionalLabelsDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
Type |
TypeSpecified |

See Also

AdditionalLabelsDetail Class
InSite.Domain.FedExRateService Namespace


AdditionalLabelsDetail Constructor

[image]

.NET Framework Class Library
AdditionalLabelsDetail Constructor
AdditionalLabelsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public AdditionalLabelsDetail()
Visual C++
public:
AdditionalLabelsDetail()
JavaScript
InSite.Domain.FedExRateService.AdditionalLabelsDetail = function();

See Also

AdditionalLabelsDetail Class
InSite.Domain.FedExRateService Namespace


AdditionalLabelsDetail Methods

[image] [image]

.NET Framework Class Library
AdditionalLabelsDetail Methods
AdditionalLabelsDetail Class See Also Send Feedback

The AdditionalLabelsDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdditionalLabelsDetail Class
InSite.Domain.FedExRateService Namespace


AdditionalLabelsDetail Properties

[image] [image]

.NET Framework Class Library
AdditionalLabelsDetail Properties
AdditionalLabelsDetail Class See Also Send Feedback

The AdditionalLabelsDetail type exposes the following members.

Properties

Name | Description
Count |
Type |
TypeSpecified |

See Also

AdditionalLabelsDetail Class
InSite.Domain.FedExRateService Namespace


Count Property

[image]

.NET Framework Class Library
AdditionalLabelsDetail..::.Count Property
AdditionalLabelsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Count As String
C#
public string Count { get; set; }
Visual C++
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_count();
function set_count(value);

Remarks

See Also

AdditionalLabelsDetail Class
InSite.Domain.FedExRateService Namespace


Type Property

[image]

.NET Framework Class Library
AdditionalLabelsDetail..::.Type Property
AdditionalLabelsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As AdditionalLabelsType
C#
public AdditionalLabelsType Type { get; set; }
Visual C++
public:
property AdditionalLabelsType Type {
    AdditionalLabelsType get ();
    void set (AdditionalLabelsType value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

AdditionalLabelsDetail Class
InSite.Domain.FedExRateService Namespace


TypeSpecified Property

[image]

.NET Framework Class Library
AdditionalLabelsDetail..::.TypeSpecified Property
AdditionalLabelsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSpecified As Boolean
C#
public bool TypeSpecified { get; set; }
Visual C++
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_typeSpecified();
function set_typeSpecified(value);

Remarks

See Also

AdditionalLabelsDetail Class
InSite.Domain.FedExRateService Namespace


AdditionalLabelsType Enumeration

[image]

.NET Framework Class Library
AdditionalLabelsType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration AdditionalLabelsType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum AdditionalLabelsType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class AdditionalLabelsType
JavaScript
InSite.Domain.FedExRateService.AdditionalLabelsType = function();
InSite.Domain.FedExRateService.AdditionalLabelsType.createEnum('InSite.Domain.FedExRateService.AdditionalLabelsType', false);

Members

Member name | Description
BROKER |
CONSIGNEE |
CUSTOMS |
DESTINATION |
MANIFEST |
ORIGIN |
RECIPIENT |
SHIPPER |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Address Class

[image]

.NET Framework Class Library
Address Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Address
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Address
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Address
JavaScript
InSite.Domain.FedExRateService.Address = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Address');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Address

See Also

Address Members
InSite.Domain.FedExRateService Namespace


Address Members

[image] [image]

.NET Framework Class Library
Address Members
Address Class Constructors Methods Properties See Also Send Feedback

The Address type exposes the following members.

Constructors

Name | Description
Address |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
City |
CountryCode |
PostalCode |
Residential |
ResidentialSpecified |
StateOrProvinceCode |
StreetLines |
UrbanizationCode |

See Also

Address Class
InSite.Domain.FedExRateService Namespace


Address Constructor

[image]

.NET Framework Class Library
Address Constructor
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Address()
Visual C++
public:
Address()
JavaScript
InSite.Domain.FedExRateService.Address = function();

See Also

Address Class
InSite.Domain.FedExRateService Namespace


Address Methods

[image] [image]

.NET Framework Class Library
Address Methods
Address Class See Also Send Feedback

The Address type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Address Class
InSite.Domain.FedExRateService Namespace


Address Properties

[image] [image]

.NET Framework Class Library
Address Properties
Address Class See Also Send Feedback

The Address type exposes the following members.

Properties

Name | Description
City |
CountryCode |
PostalCode |
Residential |
ResidentialSpecified |
StateOrProvinceCode |
StreetLines |
UrbanizationCode |

See Also

Address Class
InSite.Domain.FedExRateService Namespace


City Property

[image]

.NET Framework Class Library
Address..::.City Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property City As String
C#
public string City { get; set; }
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRateService Namespace


CountryCode Property

[image]

.NET Framework Class Library
Address..::.CountryCode Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CountryCode As String
C#
public string CountryCode { get; set; }
Visual C++
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryCode();
function set_countryCode(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRateService Namespace


PostalCode Property

[image]

.NET Framework Class Library
Address..::.PostalCode Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PostalCode As String
C#
public string PostalCode { get; set; }
Visual C++
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRateService Namespace


Residential Property

[image]

.NET Framework Class Library
Address..::.Residential Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Residential As Boolean
C#
public bool Residential { get; set; }
Visual C++
public:
property bool Residential {
    bool get ();
    void set (bool value);
}
JavaScript
function get_residential();
function set_residential(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRateService Namespace


ResidentialSpecified Property

[image]

.NET Framework Class Library
Address..::.ResidentialSpecified Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ResidentialSpecified As Boolean
C#
public bool ResidentialSpecified { get; set; }
Visual C++
public:
property bool ResidentialSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_residentialSpecified();
function set_residentialSpecified(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRateService Namespace


StateOrProvinceCode Property

[image]

.NET Framework Class Library
Address..::.StateOrProvinceCode Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property StateOrProvinceCode As String
C#
public string StateOrProvinceCode { get; set; }
Visual C++
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stateOrProvinceCode();
function set_stateOrProvinceCode(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRateService Namespace


StreetLines Property

[image]

.NET Framework Class Library
Address..::.StreetLines Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property StreetLines As String()
C#
public string[] StreetLines { get; set; }
Visual C++
public:
property array<String^>^ StreetLines {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_streetLines();
function set_streetLines(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRateService Namespace


UrbanizationCode Property

[image]

.NET Framework Class Library
Address..::.UrbanizationCode Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UrbanizationCode As String
C#
public string UrbanizationCode { get; set; }
Visual C++
public:
property String^ UrbanizationCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_urbanizationCode();
function set_urbanizationCode(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRateService Namespace


B13AFilingOptionType Enumeration

[image]

.NET Framework Class Library
B13AFilingOptionType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration B13AFilingOptionType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum B13AFilingOptionType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class B13AFilingOptionType
JavaScript
InSite.Domain.FedExRateService.B13AFilingOptionType = function();
InSite.Domain.FedExRateService.B13AFilingOptionType.createEnum('InSite.Domain.FedExRateService.B13AFilingOptionType', false);

Members

Member name | Description
FILED_ELECTRONICALLY |
MANUALLY_ATTACHED |
NOT_REQUIRED |
SUMMARY_REPORTING |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


BarcodeSymbologyType Enumeration

[image]

.NET Framework Class Library
BarcodeSymbologyType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration BarcodeSymbologyType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum BarcodeSymbologyType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class BarcodeSymbologyType
JavaScript
InSite.Domain.FedExRateService.BarcodeSymbologyType = function();
InSite.Domain.FedExRateService.BarcodeSymbologyType.createEnum('InSite.Domain.FedExRateService.BarcodeSymbologyType', false);

Members

Member name | Description
CODABAR |
CODE128 |
CODE128B |
CODE128C |
CODE39 |
CODE93 |
I2OF5 |
MANUAL |
PDF417 |
POSTNET |
UCC128 |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


CarrierCodeType Enumeration

[image]

.NET Framework Class Library
CarrierCodeType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CarrierCodeType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CarrierCodeType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CarrierCodeType
JavaScript
InSite.Domain.FedExRateService.CarrierCodeType = function();
InSite.Domain.FedExRateService.CarrierCodeType.createEnum('InSite.Domain.FedExRateService.CarrierCodeType', false);

Members

Member name | Description
FDXE |
FDXG |
FXFR |
FXSP |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


CertificateOfOriginDetail Class

[image]

.NET Framework Class Library
CertificateOfOriginDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CertificateOfOriginDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CertificateOfOriginDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CertificateOfOriginDetail
JavaScript
InSite.Domain.FedExRateService.CertificateOfOriginDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CertificateOfOriginDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CertificateOfOriginDetail

See Also

CertificateOfOriginDetail Members
InSite.Domain.FedExRateService Namespace


CertificateOfOriginDetail Members

[image] [image]

.NET Framework Class Library
CertificateOfOriginDetail Members
CertificateOfOriginDetail Class Constructors Methods Properties See Also Send Feedback

The CertificateOfOriginDetail type exposes the following members.

Constructors

Name | Description
CertificateOfOriginDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerImageUsages |
DocumentFormat |

See Also

CertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


CertificateOfOriginDetail Constructor

[image]

.NET Framework Class Library
CertificateOfOriginDetail Constructor
CertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CertificateOfOriginDetail()
Visual C++
public:
CertificateOfOriginDetail()
JavaScript
InSite.Domain.FedExRateService.CertificateOfOriginDetail = function();

See Also

CertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


CertificateOfOriginDetail Methods

[image] [image]

.NET Framework Class Library
CertificateOfOriginDetail Methods
CertificateOfOriginDetail Class See Also Send Feedback

The CertificateOfOriginDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


CertificateOfOriginDetail Properties

[image] [image]

.NET Framework Class Library
CertificateOfOriginDetail Properties
CertificateOfOriginDetail Class See Also Send Feedback

The CertificateOfOriginDetail type exposes the following members.

Properties

Name | Description
CustomerImageUsages |
DocumentFormat |

See Also

CertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


CustomerImageUsages Property

[image]

.NET Framework Class Library
CertificateOfOriginDetail..::.CustomerImageUsages Property
CertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerImageUsages As CustomerImageUsage
C#
public CustomerImageUsage CustomerImageUsages { get; set; }
Visual C++
public:
property CustomerImageUsage^ CustomerImageUsages {
    CustomerImageUsage^ get ();
    void set (CustomerImageUsage^ value);
}
JavaScript
function get_customerImageUsages();
function set_customerImageUsages(value);

Remarks

See Also

CertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


DocumentFormat Property

[image]

.NET Framework Class Library
CertificateOfOriginDetail..::.DocumentFormat Property
CertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentFormat As ShippingDocumentFormat
C#
public ShippingDocumentFormat DocumentFormat { get; set; }
Visual C++
public:
property ShippingDocumentFormat^ DocumentFormat {
    ShippingDocumentFormat^ get ();
    void set (ShippingDocumentFormat^ value);
}
JavaScript
function get_documentFormat();
function set_documentFormat(value);

Remarks

See Also

CertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


ClearanceBrokerageType Enumeration

[image]

.NET Framework Class Library
ClearanceBrokerageType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ClearanceBrokerageType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ClearanceBrokerageType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ClearanceBrokerageType
JavaScript
InSite.Domain.FedExRateService.ClearanceBrokerageType = function();
InSite.Domain.FedExRateService.ClearanceBrokerageType.createEnum('InSite.Domain.FedExRateService.ClearanceBrokerageType', false);

Members

Member name | Description
BROKER_INCLUSIVE |
BROKER_INCLUSIVE_NON_RESIDENT_IMPORTER |
BROKER_SELECT |
BROKER_SELECT_NON_RESIDENT_IMPORTER |
BROKER_UNASSIGNED |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


ClientDetail Class

[image]

.NET Framework Class Library
ClientDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ClientDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ClientDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ClientDetail
JavaScript
InSite.Domain.FedExRateService.ClientDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ClientDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ClientDetail

See Also

ClientDetail Members
InSite.Domain.FedExRateService Namespace


ClientDetail Members

[image] [image]

.NET Framework Class Library
ClientDetail Members
ClientDetail Class Constructors Methods Properties See Also Send Feedback

The ClientDetail type exposes the following members.

Constructors

Name | Description
ClientDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccountNumber |
ClientProductId |
ClientProductVersion |
IntegratorId |
Localization |
MeterNumber |
Region |
RegionSpecified |

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


ClientDetail Constructor

[image]

.NET Framework Class Library
ClientDetail Constructor
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ClientDetail()
Visual C++
public:
ClientDetail()
JavaScript
InSite.Domain.FedExRateService.ClientDetail = function();

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


ClientDetail Methods

[image] [image]

.NET Framework Class Library
ClientDetail Methods
ClientDetail Class See Also Send Feedback

The ClientDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


ClientDetail Properties

[image] [image]

.NET Framework Class Library
ClientDetail Properties
ClientDetail Class See Also Send Feedback

The ClientDetail type exposes the following members.

Properties

Name | Description
AccountNumber |
ClientProductId |
ClientProductVersion |
IntegratorId |
Localization |
MeterNumber |
Region |
RegionSpecified |

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


AccountNumber Property

[image]

.NET Framework Class Library
ClientDetail..::.AccountNumber Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AccountNumber As String
C#
public string AccountNumber { get; set; }
Visual C++
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


ClientProductId Property

[image]

.NET Framework Class Library
ClientDetail..::.ClientProductId Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientProductId As String
C#
public string ClientProductId { get; set; }
Visual C++
public:
property String^ ClientProductId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientProductId();
function set_clientProductId(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


ClientProductVersion Property

[image]

.NET Framework Class Library
ClientDetail..::.ClientProductVersion Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientProductVersion As String
C#
public string ClientProductVersion { get; set; }
Visual C++
public:
property String^ ClientProductVersion {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientProductVersion();
function set_clientProductVersion(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


IntegratorId Property

[image]

.NET Framework Class Library
ClientDetail..::.IntegratorId Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IntegratorId As String
C#
public string IntegratorId { get; set; }
Visual C++
public:
property String^ IntegratorId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_integratorId();
function set_integratorId(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


Localization Property

[image]

.NET Framework Class Library
ClientDetail..::.Localization Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Localization As Localization
C#
public Localization Localization { get; set; }
Visual C++
public:
property Localization^ Localization {
    Localization^ get ();
    void set (Localization^ value);
}
JavaScript
function get_localization();
function set_localization(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


MeterNumber Property

[image]

.NET Framework Class Library
ClientDetail..::.MeterNumber Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MeterNumber As String
C#
public string MeterNumber { get; set; }
Visual C++
public:
property String^ MeterNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_meterNumber();
function set_meterNumber(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


Region Property

[image]

.NET Framework Class Library
ClientDetail..::.Region Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Region As ExpressRegionCode
C#
public ExpressRegionCode Region { get; set; }
Visual C++
public:
property ExpressRegionCode Region {
    ExpressRegionCode get ();
    void set (ExpressRegionCode value);
}
JavaScript
function get_region();
function set_region(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


RegionSpecified Property

[image]

.NET Framework Class Library
ClientDetail..::.RegionSpecified Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RegionSpecified As Boolean
C#
public bool RegionSpecified { get; set; }
Visual C++
public:
property bool RegionSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_regionSpecified();
function set_regionSpecified(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRateService Namespace


CodAddTransportationChargesType Enumeration

[image]

.NET Framework Class Library
CodAddTransportationChargesType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CodAddTransportationChargesType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CodAddTransportationChargesType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CodAddTransportationChargesType
JavaScript
InSite.Domain.FedExRateService.CodAddTransportationChargesType = function();
InSite.Domain.FedExRateService.CodAddTransportationChargesType.createEnum('InSite.Domain.FedExRateService.CodAddTransportationChargesType', false);

Members

Member name | Description
ADD_ACCOUNT_COD_SURCHARGE |
ADD_ACCOUNT_NET_CHARGE |
ADD_ACCOUNT_NET_FREIGHT |
ADD_ACCOUNT_TOTAL_CUSTOMER_CHARGE |
ADD_LIST_COD_SURCHARGE |
ADD_LIST_NET_CHARGE |
ADD_LIST_NET_FREIGHT |
ADD_LIST_TOTAL_CUSTOMER_CHARGE |
ADD_SHIPMENT_MULTIWEIGHT_NET_CHARGE |
ADD_SHIPMENT_MULTIWEIGHT_NET_FREIGHT |
ADD_SUM_OF_ACCOUNT_NET_CHARGES |
ADD_SUM_OF_ACCOUNT_NET_FREIGHT |
ADD_SUM_OF_LIST_NET_CHARGES |
ADD_SUM_OF_LIST_NET_FREIGHT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


CodCollectionType Enumeration

[image]

.NET Framework Class Library
CodCollectionType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CodCollectionType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CodCollectionType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CodCollectionType
JavaScript
InSite.Domain.FedExRateService.CodCollectionType = function();
InSite.Domain.FedExRateService.CodCollectionType.createEnum('InSite.Domain.FedExRateService.CodCollectionType', false);

Members

Member name | Description
ANY |
CASH |
GUARANTEED_FUNDS |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


CodDetail Class

[image]

.NET Framework Class Library
CodDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CodDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CodDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CodDetail
JavaScript
InSite.Domain.FedExRateService.CodDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CodDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CodDetail

See Also

CodDetail Members
InSite.Domain.FedExRateService Namespace


CodDetail Members

[image] [image]

.NET Framework Class Library
CodDetail Members
CodDetail Class Constructors Methods Properties See Also Send Feedback

The CodDetail type exposes the following members.

Constructors

Name | Description
CodDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AddTransportationCharges |
AddTransportationChargesSpecified |
CodRecipient |
CollectionType |
ReferenceIndicator |
ReferenceIndicatorSpecified |

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


CodDetail Constructor

[image]

.NET Framework Class Library
CodDetail Constructor
CodDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CodDetail()
Visual C++
public:
CodDetail()
JavaScript
InSite.Domain.FedExRateService.CodDetail = function();

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


CodDetail Methods

[image] [image]

.NET Framework Class Library
CodDetail Methods
CodDetail Class See Also Send Feedback

The CodDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


CodDetail Properties

[image] [image]

.NET Framework Class Library
CodDetail Properties
CodDetail Class See Also Send Feedback

The CodDetail type exposes the following members.

Properties

Name | Description
AddTransportationCharges |
AddTransportationChargesSpecified |
CodRecipient |
CollectionType |
ReferenceIndicator |
ReferenceIndicatorSpecified |

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


AddTransportationCharges Property

[image]

.NET Framework Class Library
CodDetail..::.AddTransportationCharges Property
CodDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AddTransportationCharges As CodAddTransportationChargesType
C#
public CodAddTransportationChargesType AddTransportationCharges { get; set; }
Visual C++
public:
property CodAddTransportationChargesType AddTransportationCharges {
    CodAddTransportationChargesType get ();
    void set (CodAddTransportationChargesType value);
}
JavaScript
function get_addTransportationCharges();
function set_addTransportationCharges(value);

Remarks

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


AddTransportationChargesSpecified Property

[image]

.NET Framework Class Library
CodDetail..::.AddTransportationChargesSpecified Property
CodDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AddTransportationChargesSpecified As Boolean
C#
public bool AddTransportationChargesSpecified { get; set; }
Visual C++
public:
property bool AddTransportationChargesSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_addTransportationChargesSpecified();
function set_addTransportationChargesSpecified(value);

Remarks

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


CodRecipient Property

[image]

.NET Framework Class Library
CodDetail..::.CodRecipient Property
CodDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CodRecipient As Party
C#
public Party CodRecipient { get; set; }
Visual C++
public:
property Party^ CodRecipient {
    Party^ get ();
    void set (Party^ value);
}
JavaScript
function get_codRecipient();
function set_codRecipient(value);

Remarks

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


CollectionType Property

[image]

.NET Framework Class Library
CodDetail..::.CollectionType Property
CodDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CollectionType As CodCollectionType
C#
public CodCollectionType CollectionType { get; set; }
Visual C++
public:
property CodCollectionType CollectionType {
    CodCollectionType get ();
    void set (CodCollectionType value);
}
JavaScript
function get_collectionType();
function set_collectionType(value);

Remarks

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


ReferenceIndicator Property

[image]

.NET Framework Class Library
CodDetail..::.ReferenceIndicator Property
CodDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferenceIndicator As CodReturnReferenceIndicatorType
C#
public CodReturnReferenceIndicatorType ReferenceIndicator { get; set; }
Visual C++
public:
property CodReturnReferenceIndicatorType ReferenceIndicator {
    CodReturnReferenceIndicatorType get ();
    void set (CodReturnReferenceIndicatorType value);
}
JavaScript
function get_referenceIndicator();
function set_referenceIndicator(value);

Remarks

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


ReferenceIndicatorSpecified Property

[image]

.NET Framework Class Library
CodDetail..::.ReferenceIndicatorSpecified Property
CodDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferenceIndicatorSpecified As Boolean
C#
public bool ReferenceIndicatorSpecified { get; set; }
Visual C++
public:
property bool ReferenceIndicatorSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_referenceIndicatorSpecified();
function set_referenceIndicatorSpecified(value);

Remarks

See Also

CodDetail Class
InSite.Domain.FedExRateService Namespace


CodReturnReferenceIndicatorType Enumeration

[image]

.NET Framework Class Library
CodReturnReferenceIndicatorType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CodReturnReferenceIndicatorType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CodReturnReferenceIndicatorType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CodReturnReferenceIndicatorType
JavaScript
InSite.Domain.FedExRateService.CodReturnReferenceIndicatorType = function();
InSite.Domain.FedExRateService.CodReturnReferenceIndicatorType.createEnum('InSite.Domain.FedExRateService.CodReturnReferenceIndicatorType', false);

Members

Member name | Description
INVOICE |
PO |
REFERENCE |
TRACKING |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


CommercialInvoice Class

[image]

.NET Framework Class Library
CommercialInvoice Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CommercialInvoice
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CommercialInvoice
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CommercialInvoice
JavaScript
InSite.Domain.FedExRateService.CommercialInvoice = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CommercialInvoice');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CommercialInvoice

See Also

CommercialInvoice Members
InSite.Domain.FedExRateService Namespace


CommercialInvoice Members

[image] [image]

.NET Framework Class Library
CommercialInvoice Members
CommercialInvoice Class Constructors Methods Properties See Also Send Feedback

The CommercialInvoice type exposes the following members.

Constructors

Name | Description
CommercialInvoice |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Comments |
CustomerInvoiceNumber |
FreightCharge |
Purpose |
PurposeOfShipmentDescription |
PurposeSpecified |
TaxesOrMiscellaneousCharge |
TermsOfSale |
TermsOfSaleSpecified |

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


CommercialInvoice Constructor

[image]

.NET Framework Class Library
CommercialInvoice Constructor
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CommercialInvoice()
Visual C++
public:
CommercialInvoice()
JavaScript
InSite.Domain.FedExRateService.CommercialInvoice = function();

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


CommercialInvoice Methods

[image] [image]

.NET Framework Class Library
CommercialInvoice Methods
CommercialInvoice Class See Also Send Feedback

The CommercialInvoice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


CommercialInvoice Properties

[image] [image]

.NET Framework Class Library
CommercialInvoice Properties
CommercialInvoice Class See Also Send Feedback

The CommercialInvoice type exposes the following members.

Properties

Name | Description
Comments |
CustomerInvoiceNumber |
FreightCharge |
Purpose |
PurposeOfShipmentDescription |
PurposeSpecified |
TaxesOrMiscellaneousCharge |
TermsOfSale |
TermsOfSaleSpecified |

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


Comments Property

[image]

.NET Framework Class Library
CommercialInvoice..::.Comments Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Comments As String()
C#
public string[] Comments { get; set; }
Visual C++
public:
property array<String^>^ Comments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_comments();
function set_comments(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


CustomerInvoiceNumber Property

[image]

.NET Framework Class Library
CommercialInvoice..::.CustomerInvoiceNumber Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerInvoiceNumber As String
C#
public string CustomerInvoiceNumber { get; set; }
Visual C++
public:
property String^ CustomerInvoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerInvoiceNumber();
function set_customerInvoiceNumber(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


FreightCharge Property

[image]

.NET Framework Class Library
CommercialInvoice..::.FreightCharge Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightCharge As Money
C#
public Money FreightCharge { get; set; }
Visual C++
public:
property Money^ FreightCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_freightCharge();
function set_freightCharge(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


Purpose Property

[image]

.NET Framework Class Library
CommercialInvoice..::.Purpose Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Purpose As PurposeOfShipmentType
C#
public PurposeOfShipmentType Purpose { get; set; }
Visual C++
public:
property PurposeOfShipmentType Purpose {
    PurposeOfShipmentType get ();
    void set (PurposeOfShipmentType value);
}
JavaScript
function get_purpose();
function set_purpose(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


PurposeOfShipmentDescription Property

[image]

.NET Framework Class Library
CommercialInvoice..::.PurposeOfShipmentDescription Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PurposeOfShipmentDescription As String
C#
public string PurposeOfShipmentDescription { get; set; }
Visual C++
public:
property String^ PurposeOfShipmentDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_purposeOfShipmentDescription();
function set_purposeOfShipmentDescription(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


PurposeSpecified Property

[image]

.NET Framework Class Library
CommercialInvoice..::.PurposeSpecified Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PurposeSpecified As Boolean
C#
public bool PurposeSpecified { get; set; }
Visual C++
public:
property bool PurposeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_purposeSpecified();
function set_purposeSpecified(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


TaxesOrMiscellaneousCharge Property

[image]

.NET Framework Class Library
CommercialInvoice..::.TaxesOrMiscellaneousCharge Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TaxesOrMiscellaneousCharge As Money
C#
public Money TaxesOrMiscellaneousCharge { get; set; }
Visual C++
public:
property Money^ TaxesOrMiscellaneousCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_taxesOrMiscellaneousCharge();
function set_taxesOrMiscellaneousCharge(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


TermsOfSale Property

[image]

.NET Framework Class Library
CommercialInvoice..::.TermsOfSale Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TermsOfSale As TermsOfSaleType
C#
public TermsOfSaleType TermsOfSale { get; set; }
Visual C++
public:
property TermsOfSaleType TermsOfSale {
    TermsOfSaleType get ();
    void set (TermsOfSaleType value);
}
JavaScript
function get_termsOfSale();
function set_termsOfSale(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


TermsOfSaleSpecified Property

[image]

.NET Framework Class Library
CommercialInvoice..::.TermsOfSaleSpecified Property
CommercialInvoice Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TermsOfSaleSpecified As Boolean
C#
public bool TermsOfSaleSpecified { get; set; }
Visual C++
public:
property bool TermsOfSaleSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_termsOfSaleSpecified();
function set_termsOfSaleSpecified(value);

Remarks

See Also

CommercialInvoice Class
InSite.Domain.FedExRateService Namespace


CommercialInvoiceDetail Class

[image]

.NET Framework Class Library
CommercialInvoiceDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CommercialInvoiceDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CommercialInvoiceDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CommercialInvoiceDetail
JavaScript
InSite.Domain.FedExRateService.CommercialInvoiceDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CommercialInvoiceDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CommercialInvoiceDetail

See Also

CommercialInvoiceDetail Members
InSite.Domain.FedExRateService Namespace


CommercialInvoiceDetail Members

[image] [image]

.NET Framework Class Library
CommercialInvoiceDetail Members
CommercialInvoiceDetail Class Constructors Methods Properties See Also Send Feedback

The CommercialInvoiceDetail type exposes the following members.

Constructors

Name | Description
CommercialInvoiceDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerImageUsages |
Format |

See Also

CommercialInvoiceDetail Class
InSite.Domain.FedExRateService Namespace


CommercialInvoiceDetail Constructor

[image]

.NET Framework Class Library
CommercialInvoiceDetail Constructor
CommercialInvoiceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CommercialInvoiceDetail()
Visual C++
public:
CommercialInvoiceDetail()
JavaScript
InSite.Domain.FedExRateService.CommercialInvoiceDetail = function();

See Also

CommercialInvoiceDetail Class
InSite.Domain.FedExRateService Namespace


CommercialInvoiceDetail Methods

[image] [image]

.NET Framework Class Library
CommercialInvoiceDetail Methods
CommercialInvoiceDetail Class See Also Send Feedback

The CommercialInvoiceDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommercialInvoiceDetail Class
InSite.Domain.FedExRateService Namespace


CommercialInvoiceDetail Properties

[image] [image]

.NET Framework Class Library
CommercialInvoiceDetail Properties
CommercialInvoiceDetail Class See Also Send Feedback

The CommercialInvoiceDetail type exposes the following members.

Properties

Name | Description
CustomerImageUsages |
Format |

See Also

CommercialInvoiceDetail Class
InSite.Domain.FedExRateService Namespace


CustomerImageUsages Property

[image]

.NET Framework Class Library
CommercialInvoiceDetail..::.CustomerImageUsages Property
CommercialInvoiceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerImageUsages As CustomerImageUsage()
C#
public CustomerImageUsage[] CustomerImageUsages { get; set; }
Visual C++
public:
property array<CustomerImageUsage^>^ CustomerImageUsages {
    array<CustomerImageUsage^>^ get ();
    void set (array<CustomerImageUsage^>^ value);
}
JavaScript
function get_customerImageUsages();
function set_customerImageUsages(value);

Remarks

See Also

CommercialInvoiceDetail Class
InSite.Domain.FedExRateService Namespace


Format Property

[image]

.NET Framework Class Library
CommercialInvoiceDetail..::.Format Property
CommercialInvoiceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As ShippingDocumentFormat
C#
public ShippingDocumentFormat Format { get; set; }
Visual C++
public:
property ShippingDocumentFormat^ Format {
    ShippingDocumentFormat^ get ();
    void set (ShippingDocumentFormat^ value);
}
JavaScript
function get_format();
function set_format(value);

Remarks

See Also

CommercialInvoiceDetail Class
InSite.Domain.FedExRateService Namespace


CommitDetail Class

[image]

.NET Framework Class Library
CommitDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CommitDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CommitDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CommitDetail
JavaScript
InSite.Domain.FedExRateService.CommitDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CommitDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CommitDetail

See Also

CommitDetail Members
InSite.Domain.FedExRateService Namespace


CommitDetail Members

[image] [image]

.NET Framework Class Library
CommitDetail Members
CommitDetail Class Constructors Methods Properties See Also Send Feedback

The CommitDetail type exposes the following members.

Constructors

Name | Description
CommitDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AppliedOptions |
BrokerAddress |
BrokerCommitDayOfWeek |
BrokerCommitDayOfWeekSpecified |
BrokerCommitTimestamp |
BrokerCommitTimestampSpecified |
BrokerLocationId |
BrokerToDestinationDays |
CommitMessages |
CommitTimestamp |
CommitTimestampSpecified |
CommodityName |
DayOfWeek |
DayOfWeekSpecified |
DelayDetails |
DeliveryMessages |
DestinationServiceArea |
FreightCommitDetail |
ProofOfDeliveryDate |
ProofOfDeliveryDateSpecified |
ProofOfDeliveryDayOfWeek |
ProofOfDeliveryDayOfWeekSpecified |
RequiredDocuments |
ServiceType |
ServiceTypeSpecified |
TransitTime |
TransitTimeSpecified |

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


CommitDetail Constructor

[image]

.NET Framework Class Library
CommitDetail Constructor
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CommitDetail()
Visual C++
public:
CommitDetail()
JavaScript
InSite.Domain.FedExRateService.CommitDetail = function();

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


CommitDetail Methods

[image] [image]

.NET Framework Class Library
CommitDetail Methods
CommitDetail Class See Also Send Feedback

The CommitDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


CommitDetail Properties

[image] [image]

.NET Framework Class Library
CommitDetail Properties
CommitDetail Class See Also Send Feedback

The CommitDetail type exposes the following members.

Properties

Name | Description
AppliedOptions |
BrokerAddress |
BrokerCommitDayOfWeek |
BrokerCommitDayOfWeekSpecified |
BrokerCommitTimestamp |
BrokerCommitTimestampSpecified |
BrokerLocationId |
BrokerToDestinationDays |
CommitMessages |
CommitTimestamp |
CommitTimestampSpecified |
CommodityName |
DayOfWeek |
DayOfWeekSpecified |
DelayDetails |
DeliveryMessages |
DestinationServiceArea |
FreightCommitDetail |
ProofOfDeliveryDate |
ProofOfDeliveryDateSpecified |
ProofOfDeliveryDayOfWeek |
ProofOfDeliveryDayOfWeekSpecified |
RequiredDocuments |
ServiceType |
ServiceTypeSpecified |
TransitTime |
TransitTimeSpecified |

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


AppliedOptions Property

[image]

.NET Framework Class Library
CommitDetail..::.AppliedOptions Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AppliedOptions As ServiceOptionType()
C#
public ServiceOptionType[] AppliedOptions { get; set; }
Visual C++
public:
property array<ServiceOptionType>^ AppliedOptions {
    array<ServiceOptionType>^ get ();
    void set (array<ServiceOptionType>^ value);
}
JavaScript
function get_appliedOptions();
function set_appliedOptions(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


BrokerAddress Property

[image]

.NET Framework Class Library
CommitDetail..::.BrokerAddress Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerAddress As Address
C#
public Address BrokerAddress { get; set; }
Visual C++
public:
property Address^ BrokerAddress {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_brokerAddress();
function set_brokerAddress(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


BrokerCommitDayOfWeek Property

[image]

.NET Framework Class Library
CommitDetail..::.BrokerCommitDayOfWeek Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerCommitDayOfWeek As DayOfWeekType
C#
public DayOfWeekType BrokerCommitDayOfWeek { get; set; }
Visual C++
public:
property DayOfWeekType BrokerCommitDayOfWeek {
    DayOfWeekType get ();
    void set (DayOfWeekType value);
}
JavaScript
function get_brokerCommitDayOfWeek();
function set_brokerCommitDayOfWeek(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


BrokerCommitDayOfWeekSpecified Property

[image]

.NET Framework Class Library
CommitDetail..::.BrokerCommitDayOfWeekSpecified Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerCommitDayOfWeekSpecified As Boolean
C#
public bool BrokerCommitDayOfWeekSpecified { get; set; }
Visual C++
public:
property bool BrokerCommitDayOfWeekSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_brokerCommitDayOfWeekSpecified();
function set_brokerCommitDayOfWeekSpecified(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


BrokerCommitTimestamp Property

[image]

.NET Framework Class Library
CommitDetail..::.BrokerCommitTimestamp Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerCommitTimestamp As DateTime
C#
public DateTime BrokerCommitTimestamp { get; set; }
Visual C++
public:
property DateTime BrokerCommitTimestamp {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_brokerCommitTimestamp();
function set_brokerCommitTimestamp(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


BrokerCommitTimestampSpecified Property

[image]

.NET Framework Class Library
CommitDetail..::.BrokerCommitTimestampSpecified Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerCommitTimestampSpecified As Boolean
C#
public bool BrokerCommitTimestampSpecified { get; set; }
Visual C++
public:
property bool BrokerCommitTimestampSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_brokerCommitTimestampSpecified();
function set_brokerCommitTimestampSpecified(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


BrokerLocationId Property

[image]

.NET Framework Class Library
CommitDetail..::.BrokerLocationId Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerLocationId As String
C#
public string BrokerLocationId { get; set; }
Visual C++
public:
property String^ BrokerLocationId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_brokerLocationId();
function set_brokerLocationId(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


BrokerToDestinationDays Property

[image]

.NET Framework Class Library
CommitDetail..::.BrokerToDestinationDays Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BrokerToDestinationDays As String
C#
public string BrokerToDestinationDays { get; set; }
Visual C++
public:
property String^ BrokerToDestinationDays {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_brokerToDestinationDays();
function set_brokerToDestinationDays(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


CommitMessages Property

[image]

.NET Framework Class Library
CommitDetail..::.CommitMessages Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CommitMessages As Notification()
C#
public Notification[] CommitMessages { get; set; }
Visual C++
public:
property array<Notification^>^ CommitMessages {
    array<Notification^>^ get ();
    void set (array<Notification^>^ value);
}
JavaScript
function get_commitMessages();
function set_commitMessages(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


CommitTimestamp Property

[image]

.NET Framework Class Library
CommitDetail..::.CommitTimestamp Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CommitTimestamp As DateTime
C#
public DateTime CommitTimestamp { get; set; }
Visual C++
public:
property DateTime CommitTimestamp {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_commitTimestamp();
function set_commitTimestamp(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


CommitTimestampSpecified Property

[image]

.NET Framework Class Library
CommitDetail..::.CommitTimestampSpecified Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CommitTimestampSpecified As Boolean
C#
public bool CommitTimestampSpecified { get; set; }
Visual C++
public:
property bool CommitTimestampSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_commitTimestampSpecified();
function set_commitTimestampSpecified(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


CommodityName Property

[image]

.NET Framework Class Library
CommitDetail..::.CommodityName Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CommodityName As String
C#
public string CommodityName { get; set; }
Visual C++
public:
property String^ CommodityName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_commodityName();
function set_commodityName(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


DayOfWeek Property

[image]

.NET Framework Class Library
CommitDetail..::.DayOfWeek Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DayOfWeek As DayOfWeekType
C#
public DayOfWeekType DayOfWeek { get; set; }
Visual C++
public:
property DayOfWeekType DayOfWeek {
    DayOfWeekType get ();
    void set (DayOfWeekType value);
}
JavaScript
function get_dayOfWeek();
function set_dayOfWeek(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


DayOfWeekSpecified Property

[image]

.NET Framework Class Library
CommitDetail..::.DayOfWeekSpecified Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DayOfWeekSpecified As Boolean
C#
public bool DayOfWeekSpecified { get; set; }
Visual C++
public:
property bool DayOfWeekSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dayOfWeekSpecified();
function set_dayOfWeekSpecified(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


DelayDetails Property

[image]

.NET Framework Class Library
CommitDetail..::.DelayDetails Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DelayDetails As DelayDetail()
C#
public DelayDetail[] DelayDetails { get; set; }
Visual C++
public:
property array<DelayDetail^>^ DelayDetails {
    array<DelayDetail^>^ get ();
    void set (array<DelayDetail^>^ value);
}
JavaScript
function get_delayDetails();
function set_delayDetails(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


DeliveryMessages Property

[image]

.NET Framework Class Library
CommitDetail..::.DeliveryMessages Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DeliveryMessages As String()
C#
public string[] DeliveryMessages { get; set; }
Visual C++
public:
property array<String^>^ DeliveryMessages {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_deliveryMessages();
function set_deliveryMessages(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


DestinationServiceArea Property

[image]

.NET Framework Class Library
CommitDetail..::.DestinationServiceArea Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationServiceArea As String
C#
public string DestinationServiceArea { get; set; }
Visual C++
public:
property String^ DestinationServiceArea {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_destinationServiceArea();
function set_destinationServiceArea(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


FreightCommitDetail Property

[image]

.NET Framework Class Library
CommitDetail..::.FreightCommitDetail Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightCommitDetail As FreightCommitDetail
C#
public FreightCommitDetail FreightCommitDetail { get; set; }
Visual C++
public:
property FreightCommitDetail^ FreightCommitDetail {
    FreightCommitDetail^ get ();
    void set (FreightCommitDetail^ value);
}
JavaScript
function get_freightCommitDetail();
function set_freightCommitDetail(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


ProofOfDeliveryDate Property

[image]

.NET Framework Class Library
CommitDetail..::.ProofOfDeliveryDate Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProofOfDeliveryDate As DateTime
C#
public DateTime ProofOfDeliveryDate { get; set; }
Visual C++
public:
property DateTime ProofOfDeliveryDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_proofOfDeliveryDate();
function set_proofOfDeliveryDate(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


ProofOfDeliveryDateSpecified Property

[image]

.NET Framework Class Library
CommitDetail..::.ProofOfDeliveryDateSpecified Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProofOfDeliveryDateSpecified As Boolean
C#
public bool ProofOfDeliveryDateSpecified { get; set; }
Visual C++
public:
property bool ProofOfDeliveryDateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_proofOfDeliveryDateSpecified();
function set_proofOfDeliveryDateSpecified(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


ProofOfDeliveryDayOfWeek Property

[image]

.NET Framework Class Library
CommitDetail..::.ProofOfDeliveryDayOfWeek Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProofOfDeliveryDayOfWeek As DayOfWeekType
C#
public DayOfWeekType ProofOfDeliveryDayOfWeek { get; set; }
Visual C++
public:
property DayOfWeekType ProofOfDeliveryDayOfWeek {
    DayOfWeekType get ();
    void set (DayOfWeekType value);
}
JavaScript
function get_proofOfDeliveryDayOfWeek();
function set_proofOfDeliveryDayOfWeek(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


ProofOfDeliveryDayOfWeekSpecified Property

[image]

.NET Framework Class Library
CommitDetail..::.ProofOfDeliveryDayOfWeekSpecified Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProofOfDeliveryDayOfWeekSpecified As Boolean
C#
public bool ProofOfDeliveryDayOfWeekSpecified { get; set; }
Visual C++
public:
property bool ProofOfDeliveryDayOfWeekSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_proofOfDeliveryDayOfWeekSpecified();
function set_proofOfDeliveryDayOfWeekSpecified(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


RequiredDocuments Property

[image]

.NET Framework Class Library
CommitDetail..::.RequiredDocuments Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RequiredDocuments As RequiredShippingDocumentType()
C#
public RequiredShippingDocumentType[] RequiredDocuments { get; set; }
Visual C++
public:
property array<RequiredShippingDocumentType>^ RequiredDocuments {
    array<RequiredShippingDocumentType>^ get ();
    void set (array<RequiredShippingDocumentType>^ value);
}
JavaScript
function get_requiredDocuments();
function set_requiredDocuments(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


ServiceType Property

[image]

.NET Framework Class Library
CommitDetail..::.ServiceType Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceType As ServiceType
C#
public ServiceType ServiceType { get; set; }
Visual C++
public:
property ServiceType ServiceType {
    ServiceType get ();
    void set (ServiceType value);
}
JavaScript
function get_serviceType();
function set_serviceType(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


ServiceTypeSpecified Property

[image]

.NET Framework Class Library
CommitDetail..::.ServiceTypeSpecified Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceTypeSpecified As Boolean
C#
public bool ServiceTypeSpecified { get; set; }
Visual C++
public:
property bool ServiceTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_serviceTypeSpecified();
function set_serviceTypeSpecified(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


TransitTime Property

[image]

.NET Framework Class Library
CommitDetail..::.TransitTime Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransitTime As TransitTimeType
C#
public TransitTimeType TransitTime { get; set; }
Visual C++
public:
property TransitTimeType TransitTime {
    TransitTimeType get ();
    void set (TransitTimeType value);
}
JavaScript
function get_transitTime();
function set_transitTime(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


TransitTimeSpecified Property

[image]

.NET Framework Class Library
CommitDetail..::.TransitTimeSpecified Property
CommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransitTimeSpecified As Boolean
C#
public bool TransitTimeSpecified { get; set; }
Visual C++
public:
property bool TransitTimeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transitTimeSpecified();
function set_transitTimeSpecified(value);

Remarks

See Also

CommitDetail Class
InSite.Domain.FedExRateService Namespace


CommitmentDelayType Enumeration

[image]

.NET Framework Class Library
CommitmentDelayType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CommitmentDelayType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CommitmentDelayType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CommitmentDelayType
JavaScript
InSite.Domain.FedExRateService.CommitmentDelayType = function();
InSite.Domain.FedExRateService.CommitmentDelayType.createEnum('InSite.Domain.FedExRateService.CommitmentDelayType', false);

Members

Member name | Description
HOLIDAY |
NON_WORKDAY |
NO_CITY_DELIVERY |
NO_HOLD_AT_LOCATION |
NO_LOCATION_DELIVERY |
NO_SERVICE_AREA_DELIVERY |
NO_SERVICE_AREA_SPECIAL_SERVICE_DELIVERY |
NO_SPECIAL_SERVICE_DELIVERY |
NO_ZIP_DELIVERY |
WEEKEND |
WEEKEND_SPECIAL |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Commodity Class

[image]

.NET Framework Class Library
Commodity Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Commodity
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Commodity
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Commodity
JavaScript
InSite.Domain.FedExRateService.Commodity = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Commodity');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Commodity

See Also

Commodity Members
InSite.Domain.FedExRateService Namespace


Commodity Members

[image] [image]

.NET Framework Class Library
Commodity Members
Commodity Class Constructors Methods Properties See Also Send Feedback

The Commodity type exposes the following members.

Constructors

Name | Description
Commodity |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AdditionalMeasures |
CIMarksAndNumbers |
CountryOfManufacture |
CustomsValue |
Description |
ExciseConditions |
ExportLicenseExpirationDate |
ExportLicenseExpirationDateSpecified |
ExportLicenseNumber |
HarmonizedCode |
NaftaDetail |
Name |
NumberOfPieces |
Quantity |
QuantityUnits |
UnitPrice |
Weight |

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


Commodity Constructor

[image]

.NET Framework Class Library
Commodity Constructor
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Commodity()
Visual C++
public:
Commodity()
JavaScript
InSite.Domain.FedExRateService.Commodity = function();

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


Commodity Methods

[image] [image]

.NET Framework Class Library
Commodity Methods
Commodity Class See Also Send Feedback

The Commodity type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


Commodity Properties

[image] [image]

.NET Framework Class Library
Commodity Properties
Commodity Class See Also Send Feedback

The Commodity type exposes the following members.

Properties

Name | Description
AdditionalMeasures |
CIMarksAndNumbers |
CountryOfManufacture |
CustomsValue |
Description |
ExciseConditions |
ExportLicenseExpirationDate |
ExportLicenseExpirationDateSpecified |
ExportLicenseNumber |
HarmonizedCode |
NaftaDetail |
Name |
NumberOfPieces |
Quantity |
QuantityUnits |
UnitPrice |
Weight |

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


AdditionalMeasures Property

[image]

.NET Framework Class Library
Commodity..::.AdditionalMeasures Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AdditionalMeasures As Measure()
C#
public Measure[] AdditionalMeasures { get; set; }
Visual C++
public:
property array<Measure^>^ AdditionalMeasures {
    array<Measure^>^ get ();
    void set (array<Measure^>^ value);
}
JavaScript
function get_additionalMeasures();
function set_additionalMeasures(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


CIMarksAndNumbers Property

[image]

.NET Framework Class Library
Commodity..::.CIMarksAndNumbers Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CIMarksAndNumbers As String
C#
public string CIMarksAndNumbers { get; set; }
Visual C++
public:
property String^ CIMarksAndNumbers {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ciMarksAndNumbers();
function set_ciMarksAndNumbers(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


CountryOfManufacture Property

[image]

.NET Framework Class Library
Commodity..::.CountryOfManufacture Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CountryOfManufacture As String
C#
public string CountryOfManufacture { get; set; }
Visual C++
public:
property String^ CountryOfManufacture {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryOfManufacture();
function set_countryOfManufacture(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


CustomsValue Property

[image]

.NET Framework Class Library
Commodity..::.CustomsValue Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomsValue As Money
C#
public Money CustomsValue { get; set; }
Visual C++
public:
property Money^ CustomsValue {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_customsValue();
function set_customsValue(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
Commodity..::.Description Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


ExciseConditions Property

[image]

.NET Framework Class Library
Commodity..::.ExciseConditions Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExciseConditions As EdtExciseCondition()
C#
public EdtExciseCondition[] ExciseConditions { get; set; }
Visual C++
public:
property array<EdtExciseCondition^>^ ExciseConditions {
    array<EdtExciseCondition^>^ get ();
    void set (array<EdtExciseCondition^>^ value);
}
JavaScript
function get_exciseConditions();
function set_exciseConditions(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


ExportLicenseExpirationDate Property

[image]

.NET Framework Class Library
Commodity..::.ExportLicenseExpirationDate Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportLicenseExpirationDate As DateTime
C#
public DateTime ExportLicenseExpirationDate { get; set; }
Visual C++
public:
property DateTime ExportLicenseExpirationDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_exportLicenseExpirationDate();
function set_exportLicenseExpirationDate(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


ExportLicenseExpirationDateSpecified Property

[image]

.NET Framework Class Library
Commodity..::.ExportLicenseExpirationDateSpecified Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportLicenseExpirationDateSpecified As Boolean
C#
public bool ExportLicenseExpirationDateSpecified { get; set; }
Visual C++
public:
property bool ExportLicenseExpirationDateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_exportLicenseExpirationDateSpecified();
function set_exportLicenseExpirationDateSpecified(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


ExportLicenseNumber Property

[image]

.NET Framework Class Library
Commodity..::.ExportLicenseNumber Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportLicenseNumber As String
C#
public string ExportLicenseNumber { get; set; }
Visual C++
public:
property String^ ExportLicenseNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_exportLicenseNumber();
function set_exportLicenseNumber(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


HarmonizedCode Property

[image]

.NET Framework Class Library
Commodity..::.HarmonizedCode Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HarmonizedCode As String
C#
public string HarmonizedCode { get; set; }
Visual C++
public:
property String^ HarmonizedCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_harmonizedCode();
function set_harmonizedCode(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


NaftaDetail Property

[image]

.NET Framework Class Library
Commodity..::.NaftaDetail Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NaftaDetail As NaftaCommodityDetail
C#
public NaftaCommodityDetail NaftaDetail { get; set; }
Visual C++
public:
property NaftaCommodityDetail^ NaftaDetail {
    NaftaCommodityDetail^ get ();
    void set (NaftaCommodityDetail^ value);
}
JavaScript
function get_naftaDetail();
function set_naftaDetail(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


Name Property

[image]

.NET Framework Class Library
Commodity..::.Name Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


NumberOfPieces Property

[image]

.NET Framework Class Library
Commodity..::.NumberOfPieces Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NumberOfPieces As String
C#
public string NumberOfPieces { get; set; }
Visual C++
public:
property String^ NumberOfPieces {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_numberOfPieces();
function set_numberOfPieces(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


Quantity Property

[image]

.NET Framework Class Library
Commodity..::.Quantity Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Quantity As String
C#
public string Quantity { get; set; }
Visual C++
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_quantity();
function set_quantity(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


QuantityUnits Property

[image]

.NET Framework Class Library
Commodity..::.QuantityUnits Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property QuantityUnits As String
C#
public string QuantityUnits { get; set; }
Visual C++
public:
property String^ QuantityUnits {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_quantityUnits();
function set_quantityUnits(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


UnitPrice Property

[image]

.NET Framework Class Library
Commodity..::.UnitPrice Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UnitPrice As Money
C#
public Money UnitPrice { get; set; }
Visual C++
public:
property Money^ UnitPrice {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_unitPrice();
function set_unitPrice(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


Weight Property

[image]

.NET Framework Class Library
Commodity..::.Weight Property
Commodity Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Weight As Weight
C#
public Weight Weight { get; set; }
Visual C++
public:
property Weight^ Weight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_weight();
function set_weight(value);

Remarks

See Also

Commodity Class
InSite.Domain.FedExRateService Namespace


ConfigurableLabelReferenceEntry Class

[image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ConfigurableLabelReferenceEntry
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ConfigurableLabelReferenceEntry
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ConfigurableLabelReferenceEntry
JavaScript
InSite.Domain.FedExRateService.ConfigurableLabelReferenceEntry = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ConfigurableLabelReferenceEntry');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ConfigurableLabelReferenceEntry

See Also

ConfigurableLabelReferenceEntry Members
InSite.Domain.FedExRateService Namespace


ConfigurableLabelReferenceEntry Members

[image] [image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry Members
ConfigurableLabelReferenceEntry Class Constructors Methods Properties See Also Send Feedback

The ConfigurableLabelReferenceEntry type exposes the following members.

Constructors

Name | Description
ConfigurableLabelReferenceEntry |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataField |
Header |
LiteralValue |
ZoneNumber |

See Also

ConfigurableLabelReferenceEntry Class
InSite.Domain.FedExRateService Namespace


ConfigurableLabelReferenceEntry Constructor

[image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry Constructor
ConfigurableLabelReferenceEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ConfigurableLabelReferenceEntry()
Visual C++
public:
ConfigurableLabelReferenceEntry()
JavaScript
InSite.Domain.FedExRateService.ConfigurableLabelReferenceEntry = function();

See Also

ConfigurableLabelReferenceEntry Class
InSite.Domain.FedExRateService Namespace


ConfigurableLabelReferenceEntry Methods

[image] [image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry Methods
ConfigurableLabelReferenceEntry Class See Also Send Feedback

The ConfigurableLabelReferenceEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigurableLabelReferenceEntry Class
InSite.Domain.FedExRateService Namespace


ConfigurableLabelReferenceEntry Properties

[image] [image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry Properties
ConfigurableLabelReferenceEntry Class See Also Send Feedback

The ConfigurableLabelReferenceEntry type exposes the following members.

Properties

Name | Description
DataField |
Header |
LiteralValue |
ZoneNumber |

See Also

ConfigurableLabelReferenceEntry Class
InSite.Domain.FedExRateService Namespace


DataField Property

[image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry..::.DataField Property
ConfigurableLabelReferenceEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DataField As String
C#
public string DataField { get; set; }
Visual C++
public:
property String^ DataField {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dataField();
function set_dataField(value);

Remarks

See Also

ConfigurableLabelReferenceEntry Class
InSite.Domain.FedExRateService Namespace


Header Property

[image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry..::.Header Property
ConfigurableLabelReferenceEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Header As String
C#
public string Header { get; set; }
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_header();
function set_header(value);

Remarks

See Also

ConfigurableLabelReferenceEntry Class
InSite.Domain.FedExRateService Namespace


LiteralValue Property

[image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry..::.LiteralValue Property
ConfigurableLabelReferenceEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LiteralValue As String
C#
public string LiteralValue { get; set; }
Visual C++
public:
property String^ LiteralValue {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_literalValue();
function set_literalValue(value);

Remarks

See Also

ConfigurableLabelReferenceEntry Class
InSite.Domain.FedExRateService Namespace


ZoneNumber Property

[image]

.NET Framework Class Library
ConfigurableLabelReferenceEntry..::.ZoneNumber Property
ConfigurableLabelReferenceEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoneNumber As String
C#
public string ZoneNumber { get; set; }
Visual C++
public:
property String^ ZoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zoneNumber();
function set_zoneNumber(value);

Remarks

See Also

ConfigurableLabelReferenceEntry Class
InSite.Domain.FedExRateService Namespace


Contact Class

[image]

.NET Framework Class Library
Contact Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Contact
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Contact
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Contact
JavaScript
InSite.Domain.FedExRateService.Contact = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Contact');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Contact

See Also

Contact Members
InSite.Domain.FedExRateService Namespace


Contact Members

[image] [image]

.NET Framework Class Library
Contact Members
Contact Class Constructors Methods Properties See Also Send Feedback

The Contact type exposes the following members.

Constructors

Name | Description
Contact |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompanyName |
EMailAddress |
FaxNumber |
PagerNumber |
PersonName |
PhoneExtension |
PhoneNumber |
Title |

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


Contact Constructor

[image]

.NET Framework Class Library
Contact Constructor
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Contact()
Visual C++
public:
Contact()
JavaScript
InSite.Domain.FedExRateService.Contact = function();

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


Contact Methods

[image] [image]

.NET Framework Class Library
Contact Methods
Contact Class See Also Send Feedback

The Contact type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


Contact Properties

[image] [image]

.NET Framework Class Library
Contact Properties
Contact Class See Also Send Feedback

The Contact type exposes the following members.

Properties

Name | Description
CompanyName |
EMailAddress |
FaxNumber |
PagerNumber |
PersonName |
PhoneExtension |
PhoneNumber |
Title |

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


CompanyName Property

[image]

.NET Framework Class Library
Contact..::.CompanyName Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CompanyName As String
C#
public string CompanyName { get; set; }
Visual C++
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_companyName();
function set_companyName(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


EMailAddress Property

[image]

.NET Framework Class Library
Contact..::.EMailAddress Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EMailAddress As String
C#
public string EMailAddress { get; set; }
Visual C++
public:
property String^ EMailAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_eMailAddress();
function set_eMailAddress(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


FaxNumber Property

[image]

.NET Framework Class Library
Contact..::.FaxNumber Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FaxNumber As String
C#
public string FaxNumber { get; set; }
Visual C++
public:
property String^ FaxNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_faxNumber();
function set_faxNumber(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


PagerNumber Property

[image]

.NET Framework Class Library
Contact..::.PagerNumber Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PagerNumber As String
C#
public string PagerNumber { get; set; }
Visual C++
public:
property String^ PagerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pagerNumber();
function set_pagerNumber(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


PersonName Property

[image]

.NET Framework Class Library
Contact..::.PersonName Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PersonName As String
C#
public string PersonName { get; set; }
Visual C++
public:
property String^ PersonName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_personName();
function set_personName(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


PhoneExtension Property

[image]

.NET Framework Class Library
Contact..::.PhoneExtension Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PhoneExtension As String
C#
public string PhoneExtension { get; set; }
Visual C++
public:
property String^ PhoneExtension {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneExtension();
function set_phoneExtension(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


PhoneNumber Property

[image]

.NET Framework Class Library
Contact..::.PhoneNumber Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PhoneNumber As String
C#
public string PhoneNumber { get; set; }
Visual C++
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


Title Property

[image]

.NET Framework Class Library
Contact..::.Title Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title { get; set; }
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRateService Namespace


ContactAndAddress Class

[image]

.NET Framework Class Library
ContactAndAddress Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ContactAndAddress
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ContactAndAddress
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ContactAndAddress
JavaScript
InSite.Domain.FedExRateService.ContactAndAddress = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ContactAndAddress');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ContactAndAddress

See Also

ContactAndAddress Members
InSite.Domain.FedExRateService Namespace


ContactAndAddress Members

[image] [image]

.NET Framework Class Library
ContactAndAddress Members
ContactAndAddress Class Constructors Methods Properties See Also Send Feedback

The ContactAndAddress type exposes the following members.

Constructors

Name | Description
ContactAndAddress |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address |
Contact |

See Also

ContactAndAddress Class
InSite.Domain.FedExRateService Namespace


ContactAndAddress Constructor

[image]

.NET Framework Class Library
ContactAndAddress Constructor
ContactAndAddress Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ContactAndAddress()
Visual C++
public:
ContactAndAddress()
JavaScript
InSite.Domain.FedExRateService.ContactAndAddress = function();

See Also

ContactAndAddress Class
InSite.Domain.FedExRateService Namespace


ContactAndAddress Methods

[image] [image]

.NET Framework Class Library
ContactAndAddress Methods
ContactAndAddress Class See Also Send Feedback

The ContactAndAddress type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactAndAddress Class
InSite.Domain.FedExRateService Namespace


ContactAndAddress Properties

[image] [image]

.NET Framework Class Library
ContactAndAddress Properties
ContactAndAddress Class See Also Send Feedback

The ContactAndAddress type exposes the following members.

Properties

Name | Description
Address |
Contact |

See Also

ContactAndAddress Class
InSite.Domain.FedExRateService Namespace


Address Property

[image]

.NET Framework Class Library
ContactAndAddress..::.Address Property
ContactAndAddress Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As Address
C#
public Address Address { get; set; }
Visual C++
public:
property Address^ Address {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

ContactAndAddress Class
InSite.Domain.FedExRateService Namespace


Contact Property

[image]

.NET Framework Class Library
ContactAndAddress..::.Contact Property
ContactAndAddress Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Contact As Contact
C#
public Contact Contact { get; set; }
Visual C++
public:
property Contact^ Contact {
    Contact^ get ();
    void set (Contact^ value);
}
JavaScript
function get_contact();
function set_contact(value);

Remarks

See Also

ContactAndAddress Class
InSite.Domain.FedExRateService Namespace


ContentRecord Class

[image]

.NET Framework Class Library
ContentRecord Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ContentRecord
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ContentRecord
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ContentRecord
JavaScript
InSite.Domain.FedExRateService.ContentRecord = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ContentRecord');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ContentRecord

See Also

ContentRecord Members
InSite.Domain.FedExRateService Namespace


ContentRecord Members

[image] [image]

.NET Framework Class Library
ContentRecord Members
ContentRecord Class Constructors Methods Properties See Also Send Feedback

The ContentRecord type exposes the following members.

Constructors

Name | Description
ContentRecord |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description |
ItemNumber |
PartNumber |
ReceivedQuantity |

See Also

ContentRecord Class
InSite.Domain.FedExRateService Namespace


ContentRecord Constructor

[image]

.NET Framework Class Library
ContentRecord Constructor
ContentRecord Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ContentRecord()
Visual C++
public:
ContentRecord()
JavaScript
InSite.Domain.FedExRateService.ContentRecord = function();

See Also

ContentRecord Class
InSite.Domain.FedExRateService Namespace


ContentRecord Methods

[image] [image]

.NET Framework Class Library
ContentRecord Methods
ContentRecord Class See Also Send Feedback

The ContentRecord type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContentRecord Class
InSite.Domain.FedExRateService Namespace


ContentRecord Properties

[image] [image]

.NET Framework Class Library
ContentRecord Properties
ContentRecord Class See Also Send Feedback

The ContentRecord type exposes the following members.

Properties

Name | Description
Description |
ItemNumber |
PartNumber |
ReceivedQuantity |

See Also

ContentRecord Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
ContentRecord..::.Description Property
ContentRecord Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

ContentRecord Class
InSite.Domain.FedExRateService Namespace


ItemNumber Property

[image]

.NET Framework Class Library
ContentRecord..::.ItemNumber Property
ContentRecord Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ItemNumber As String
C#
public string ItemNumber { get; set; }
Visual C++
public:
property String^ ItemNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_itemNumber();
function set_itemNumber(value);

Remarks

See Also

ContentRecord Class
InSite.Domain.FedExRateService Namespace


PartNumber Property

[image]

.NET Framework Class Library
ContentRecord..::.PartNumber Property
ContentRecord Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PartNumber As String
C#
public string PartNumber { get; set; }
Visual C++
public:
property String^ PartNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_partNumber();
function set_partNumber(value);

Remarks

See Also

ContentRecord Class
InSite.Domain.FedExRateService Namespace


ReceivedQuantity Property

[image]

.NET Framework Class Library
ContentRecord..::.ReceivedQuantity Property
ContentRecord Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReceivedQuantity As String
C#
public string ReceivedQuantity { get; set; }
Visual C++
public:
property String^ ReceivedQuantity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_receivedQuantity();
function set_receivedQuantity(value);

Remarks

See Also

ContentRecord Class
InSite.Domain.FedExRateService Namespace


CurrencyExchangeRate Class

[image]

.NET Framework Class Library
CurrencyExchangeRate Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CurrencyExchangeRate
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CurrencyExchangeRate
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CurrencyExchangeRate
JavaScript
InSite.Domain.FedExRateService.CurrencyExchangeRate = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CurrencyExchangeRate');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CurrencyExchangeRate

See Also

CurrencyExchangeRate Members
InSite.Domain.FedExRateService Namespace


CurrencyExchangeRate Members

[image] [image]

.NET Framework Class Library
CurrencyExchangeRate Members
CurrencyExchangeRate Class Constructors Methods Properties See Also Send Feedback

The CurrencyExchangeRate type exposes the following members.

Constructors

Name | Description
CurrencyExchangeRate |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FromCurrency |
IntoCurrency |
Rate |
RateSpecified |

See Also

CurrencyExchangeRate Class
InSite.Domain.FedExRateService Namespace


CurrencyExchangeRate Constructor

[image]

.NET Framework Class Library
CurrencyExchangeRate Constructor
CurrencyExchangeRate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CurrencyExchangeRate()
Visual C++
public:
CurrencyExchangeRate()
JavaScript
InSite.Domain.FedExRateService.CurrencyExchangeRate = function();

See Also

CurrencyExchangeRate Class
InSite.Domain.FedExRateService Namespace


CurrencyExchangeRate Methods

[image] [image]

.NET Framework Class Library
CurrencyExchangeRate Methods
CurrencyExchangeRate Class See Also Send Feedback

The CurrencyExchangeRate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurrencyExchangeRate Class
InSite.Domain.FedExRateService Namespace


CurrencyExchangeRate Properties

[image] [image]

.NET Framework Class Library
CurrencyExchangeRate Properties
CurrencyExchangeRate Class See Also Send Feedback

The CurrencyExchangeRate type exposes the following members.

Properties

Name | Description
FromCurrency |
IntoCurrency |
Rate |
RateSpecified |

See Also

CurrencyExchangeRate Class
InSite.Domain.FedExRateService Namespace


FromCurrency Property

[image]

.NET Framework Class Library
CurrencyExchangeRate..::.FromCurrency Property
CurrencyExchangeRate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FromCurrency As String
C#
public string FromCurrency { get; set; }
Visual C++
public:
property String^ FromCurrency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fromCurrency();
function set_fromCurrency(value);

Remarks

See Also

CurrencyExchangeRate Class
InSite.Domain.FedExRateService Namespace


IntoCurrency Property

[image]

.NET Framework Class Library
CurrencyExchangeRate..::.IntoCurrency Property
CurrencyExchangeRate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IntoCurrency As String
C#
public string IntoCurrency { get; set; }
Visual C++
public:
property String^ IntoCurrency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_intoCurrency();
function set_intoCurrency(value);

Remarks

See Also

CurrencyExchangeRate Class
InSite.Domain.FedExRateService Namespace


Rate Property

[image]

.NET Framework Class Library
CurrencyExchangeRate..::.Rate Property
CurrencyExchangeRate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Rate As Decimal
C#
public decimal Rate { get; set; }
Visual C++
public:
property Decimal Rate {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_rate();
function set_rate(value);

Remarks

See Also

CurrencyExchangeRate Class
InSite.Domain.FedExRateService Namespace


RateSpecified Property

[image]

.NET Framework Class Library
CurrencyExchangeRate..::.RateSpecified Property
CurrencyExchangeRate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateSpecified As Boolean
C#
public bool RateSpecified { get; set; }
Visual C++
public:
property bool RateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_rateSpecified();
function set_rateSpecified(value);

Remarks

See Also

CurrencyExchangeRate Class
InSite.Domain.FedExRateService Namespace


CustomerImageUsage Class

[image]

.NET Framework Class Library
CustomerImageUsage Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomerImageUsage
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomerImageUsage
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomerImageUsage
JavaScript
InSite.Domain.FedExRateService.CustomerImageUsage = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomerImageUsage');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomerImageUsage

See Also

CustomerImageUsage Members
InSite.Domain.FedExRateService Namespace


CustomerImageUsage Members

[image] [image]

.NET Framework Class Library
CustomerImageUsage Members
CustomerImageUsage Class Constructors Methods Properties See Also Send Feedback

The CustomerImageUsage type exposes the following members.

Constructors

Name | Description
CustomerImageUsage |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Type |
TypeSpecified |

See Also

CustomerImageUsage Class
InSite.Domain.FedExRateService Namespace


CustomerImageUsage Constructor

[image]

.NET Framework Class Library
CustomerImageUsage Constructor
CustomerImageUsage Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerImageUsage()
Visual C++
public:
CustomerImageUsage()
JavaScript
InSite.Domain.FedExRateService.CustomerImageUsage = function();

See Also

CustomerImageUsage Class
InSite.Domain.FedExRateService Namespace


CustomerImageUsage Methods

[image] [image]

.NET Framework Class Library
CustomerImageUsage Methods
CustomerImageUsage Class See Also Send Feedback

The CustomerImageUsage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerImageUsage Class
InSite.Domain.FedExRateService Namespace


CustomerImageUsage Properties

[image] [image]

.NET Framework Class Library
CustomerImageUsage Properties
CustomerImageUsage Class See Also Send Feedback

The CustomerImageUsage type exposes the following members.

Properties

Name | Description
Id |
Type |
TypeSpecified |

See Also

CustomerImageUsage Class
InSite.Domain.FedExRateService Namespace


Id Property

[image]

.NET Framework Class Library
CustomerImageUsage..::.Id Property
CustomerImageUsage Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id { get; set; }
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

CustomerImageUsage Class
InSite.Domain.FedExRateService Namespace


Type Property

[image]

.NET Framework Class Library
CustomerImageUsage..::.Type Property
CustomerImageUsage Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As CustomerImageUsageType
C#
public CustomerImageUsageType Type { get; set; }
Visual C++
public:
property CustomerImageUsageType Type {
    CustomerImageUsageType get ();
    void set (CustomerImageUsageType value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

CustomerImageUsage Class
InSite.Domain.FedExRateService Namespace


TypeSpecified Property

[image]

.NET Framework Class Library
CustomerImageUsage..::.TypeSpecified Property
CustomerImageUsage Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSpecified As Boolean
C#
public bool TypeSpecified { get; set; }
Visual C++
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_typeSpecified();
function set_typeSpecified(value);

Remarks

See Also

CustomerImageUsage Class
InSite.Domain.FedExRateService Namespace


CustomerImageUsageType Enumeration

[image]

.NET Framework Class Library
CustomerImageUsageType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CustomerImageUsageType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CustomerImageUsageType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CustomerImageUsageType
JavaScript
InSite.Domain.FedExRateService.CustomerImageUsageType = function();
InSite.Domain.FedExRateService.CustomerImageUsageType.createEnum('InSite.Domain.FedExRateService.CustomerImageUsageType', false);

Members

Member name | Description
LETTER_HEAD |
SIGNATURE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


CustomerProvidedImage Class

[image]

.NET Framework Class Library
CustomerProvidedImage Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomerProvidedImage
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomerProvidedImage
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomerProvidedImage
JavaScript
InSite.Domain.FedExRateService.CustomerProvidedImage = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomerProvidedImage');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomerProvidedImage

See Also

CustomerProvidedImage Members
InSite.Domain.FedExRateService Namespace


CustomerProvidedImage Members

[image] [image]

.NET Framework Class Library
CustomerProvidedImage Members
CustomerProvidedImage Class Constructors Methods Properties See Also Send Feedback

The CustomerProvidedImage type exposes the following members.

Constructors

Name | Description
CustomerProvidedImage |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Image |
ImageId |

See Also

CustomerProvidedImage Class
InSite.Domain.FedExRateService Namespace


CustomerProvidedImage Constructor

[image]

.NET Framework Class Library
CustomerProvidedImage Constructor
CustomerProvidedImage Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerProvidedImage()
Visual C++
public:
CustomerProvidedImage()
JavaScript
InSite.Domain.FedExRateService.CustomerProvidedImage = function();

See Also

CustomerProvidedImage Class
InSite.Domain.FedExRateService Namespace


CustomerProvidedImage Methods

[image] [image]

.NET Framework Class Library
CustomerProvidedImage Methods
CustomerProvidedImage Class See Also Send Feedback

The CustomerProvidedImage type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerProvidedImage Class
InSite.Domain.FedExRateService Namespace


CustomerProvidedImage Properties

[image] [image]

.NET Framework Class Library
CustomerProvidedImage Properties
CustomerProvidedImage Class See Also Send Feedback

The CustomerProvidedImage type exposes the following members.

Properties

Name | Description
Image |
ImageId |

See Also

CustomerProvidedImage Class
InSite.Domain.FedExRateService Namespace


Image Property

[image]

.NET Framework Class Library
CustomerProvidedImage..::.Image Property
CustomerProvidedImage Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Image As Byte()
C#
public byte[] Image { get; set; }
Visual C++
public:
property array<unsigned char>^ Image {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
JavaScript
function get_image();
function set_image(value);

Remarks

See Also

CustomerProvidedImage Class
InSite.Domain.FedExRateService Namespace


ImageId Property

[image]

.NET Framework Class Library
CustomerProvidedImage..::.ImageId Property
CustomerProvidedImage Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageId As String
C#
public string ImageId { get; set; }
Visual C++
public:
property String^ ImageId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_imageId();
function set_imageId(value);

Remarks

See Also

CustomerProvidedImage Class
InSite.Domain.FedExRateService Namespace


CustomerReference Class

[image]

.NET Framework Class Library
CustomerReference Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomerReference
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomerReference
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomerReference
JavaScript
InSite.Domain.FedExRateService.CustomerReference = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomerReference');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomerReference

See Also

CustomerReference Members
InSite.Domain.FedExRateService Namespace


CustomerReference Members

[image] [image]

.NET Framework Class Library
CustomerReference Members
CustomerReference Class Constructors Methods Properties See Also Send Feedback

The CustomerReference type exposes the following members.

Constructors

Name | Description
CustomerReference |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerReferenceType |
Value |

See Also

CustomerReference Class
InSite.Domain.FedExRateService Namespace


CustomerReference Constructor

[image]

.NET Framework Class Library
CustomerReference Constructor
CustomerReference Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerReference()
Visual C++
public:
CustomerReference()
JavaScript
InSite.Domain.FedExRateService.CustomerReference = function();

See Also

CustomerReference Class
InSite.Domain.FedExRateService Namespace


CustomerReference Methods

[image] [image]

.NET Framework Class Library
CustomerReference Methods
CustomerReference Class See Also Send Feedback

The CustomerReference type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerReference Class
InSite.Domain.FedExRateService Namespace


CustomerReference Properties

[image] [image]

.NET Framework Class Library
CustomerReference Properties
CustomerReference Class See Also Send Feedback

The CustomerReference type exposes the following members.

Properties

Name | Description
CustomerReferenceType |
Value |

See Also

CustomerReference Class
InSite.Domain.FedExRateService Namespace


CustomerReferenceType Property

[image]

.NET Framework Class Library
CustomerReference..::.CustomerReferenceType Property
CustomerReference Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerReferenceType As CustomerReferenceType
C#
public CustomerReferenceType CustomerReferenceType { get; set; }
Visual C++
public:
property CustomerReferenceType CustomerReferenceType {
    CustomerReferenceType get ();
    void set (CustomerReferenceType value);
}
JavaScript
function get_customerReferenceType();
function set_customerReferenceType(value);

Remarks

See Also

CustomerReference Class
InSite.Domain.FedExRateService Namespace


Value Property

[image]

.NET Framework Class Library
CustomerReference..::.Value Property
CustomerReference Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

CustomerReference Class
InSite.Domain.FedExRateService Namespace


CustomerReferenceType Enumeration

[image]

.NET Framework Class Library
CustomerReferenceType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CustomerReferenceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CustomerReferenceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CustomerReferenceType
JavaScript
InSite.Domain.FedExRateService.CustomerReferenceType = function();
InSite.Domain.FedExRateService.CustomerReferenceType.createEnum('InSite.Domain.FedExRateService.CustomerReferenceType', false);

Members

Member name | Description
BILL_OF_LADING |
CUSTOMER_REFERENCE |
DEPARTMENT_NUMBER |
ELECTRONIC_PRODUCT_CODE |
INVOICE_NUMBER |
P_O_NUMBER |
SHIPMENT_INTEGRITY |
STORE_NUMBER |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


CustomerSpecifiedLabelDetail Class

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomerSpecifiedLabelDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomerSpecifiedLabelDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomerSpecifiedLabelDetail
JavaScript
InSite.Domain.FedExRateService.CustomerSpecifiedLabelDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomerSpecifiedLabelDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomerSpecifiedLabelDetail

See Also

CustomerSpecifiedLabelDetail Members
InSite.Domain.FedExRateService Namespace


CustomerSpecifiedLabelDetail Members

[image] [image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail Members
CustomerSpecifiedLabelDetail Class Constructors Methods Properties See Also Send Feedback

The CustomerSpecifiedLabelDetail type exposes the following members.

Constructors

Name | Description
CustomerSpecifiedLabelDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AdditionalLabels |
AirWaybillSuppressionCount |
ConfigurableReferenceEntries |
CustomContent |
DocTabContent |
MaskedData |
TermsAndConditionsLocalization |

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomerSpecifiedLabelDetail Constructor

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail Constructor
CustomerSpecifiedLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerSpecifiedLabelDetail()
Visual C++
public:
CustomerSpecifiedLabelDetail()
JavaScript
InSite.Domain.FedExRateService.CustomerSpecifiedLabelDetail = function();

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomerSpecifiedLabelDetail Methods

[image] [image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail Methods
CustomerSpecifiedLabelDetail Class See Also Send Feedback

The CustomerSpecifiedLabelDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomerSpecifiedLabelDetail Properties

[image] [image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail Properties
CustomerSpecifiedLabelDetail Class See Also Send Feedback

The CustomerSpecifiedLabelDetail type exposes the following members.

Properties

Name | Description
AdditionalLabels |
AirWaybillSuppressionCount |
ConfigurableReferenceEntries |
CustomContent |
DocTabContent |
MaskedData |
TermsAndConditionsLocalization |

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


AdditionalLabels Property

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail..::.AdditionalLabels Property
CustomerSpecifiedLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AdditionalLabels As AdditionalLabelsDetail()
C#
public AdditionalLabelsDetail[] AdditionalLabels { get; set; }
Visual C++
public:
property array<AdditionalLabelsDetail^>^ AdditionalLabels {
    array<AdditionalLabelsDetail^>^ get ();
    void set (array<AdditionalLabelsDetail^>^ value);
}
JavaScript
function get_additionalLabels();
function set_additionalLabels(value);

Remarks

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


AirWaybillSuppressionCount Property

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail..::.AirWaybillSuppressionCount Property
CustomerSpecifiedLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AirWaybillSuppressionCount As String
C#
public string AirWaybillSuppressionCount { get; set; }
Visual C++
public:
property String^ AirWaybillSuppressionCount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_airWaybillSuppressionCount();
function set_airWaybillSuppressionCount(value);

Remarks

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


ConfigurableReferenceEntries Property

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail..::.ConfigurableReferenceEntries Property
CustomerSpecifiedLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ConfigurableReferenceEntries As ConfigurableLabelReferenceEntry()
C#
public ConfigurableLabelReferenceEntry[] ConfigurableReferenceEntries { get; set; }
Visual C++
public:
property array<ConfigurableLabelReferenceEntry^>^ ConfigurableReferenceEntries {
    array<ConfigurableLabelReferenceEntry^>^ get ();
    void set (array<ConfigurableLabelReferenceEntry^>^ value);
}
JavaScript
function get_configurableReferenceEntries();
function set_configurableReferenceEntries(value);

Remarks

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomContent Property

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail..::.CustomContent Property
CustomerSpecifiedLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomContent As CustomLabelDetail
C#
public CustomLabelDetail CustomContent { get; set; }
Visual C++
public:
property CustomLabelDetail^ CustomContent {
    CustomLabelDetail^ get ();
    void set (CustomLabelDetail^ value);
}
JavaScript
function get_customContent();
function set_customContent(value);

Remarks

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


DocTabContent Property

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail..::.DocTabContent Property
CustomerSpecifiedLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocTabContent As DocTabContent
C#
public DocTabContent DocTabContent { get; set; }
Visual C++
public:
property DocTabContent^ DocTabContent {
    DocTabContent^ get ();
    void set (DocTabContent^ value);
}
JavaScript
function get_docTabContent();
function set_docTabContent(value);

Remarks

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


MaskedData Property

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail..::.MaskedData Property
CustomerSpecifiedLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MaskedData As LabelMaskableDataType()
C#
public LabelMaskableDataType[] MaskedData { get; set; }
Visual C++
public:
property array<LabelMaskableDataType>^ MaskedData {
    array<LabelMaskableDataType>^ get ();
    void set (array<LabelMaskableDataType>^ value);
}
JavaScript
function get_maskedData();
function set_maskedData(value);

Remarks

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


TermsAndConditionsLocalization Property

[image]

.NET Framework Class Library
CustomerSpecifiedLabelDetail..::.TermsAndConditionsLocalization Property
CustomerSpecifiedLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TermsAndConditionsLocalization As Localization
C#
public Localization TermsAndConditionsLocalization { get; set; }
Visual C++
public:
property Localization^ TermsAndConditionsLocalization {
    Localization^ get ();
    void set (Localization^ value);
}
JavaScript
function get_termsAndConditionsLocalization();
function set_termsAndConditionsLocalization(value);

Remarks

See Also

CustomerSpecifiedLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomLabelBarcodeEntry Class

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomLabelBarcodeEntry
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomLabelBarcodeEntry
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomLabelBarcodeEntry
JavaScript
InSite.Domain.FedExRateService.CustomLabelBarcodeEntry = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomLabelBarcodeEntry');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomLabelBarcodeEntry

See Also

CustomLabelBarcodeEntry Members
InSite.Domain.FedExRateService Namespace


CustomLabelBarcodeEntry Members

[image] [image]

.NET Framework Class Library
CustomLabelBarcodeEntry Members
CustomLabelBarcodeEntry Class Constructors Methods Properties See Also Send Feedback

The CustomLabelBarcodeEntry type exposes the following members.

Constructors

Name | Description
CustomLabelBarcodeEntry |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BarcodeSymbology |
BarcodeSymbologySpecified |
BarHeight |
BarHeightSpecified |
DataFields |
Format |
Position |
ThinBarWidth |
ThinBarWidthSpecified |

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelBarcodeEntry Constructor

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry Constructor
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomLabelBarcodeEntry()
Visual C++
public:
CustomLabelBarcodeEntry()
JavaScript
InSite.Domain.FedExRateService.CustomLabelBarcodeEntry = function();

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelBarcodeEntry Methods

[image] [image]

.NET Framework Class Library
CustomLabelBarcodeEntry Methods
CustomLabelBarcodeEntry Class See Also Send Feedback

The CustomLabelBarcodeEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelBarcodeEntry Properties

[image] [image]

.NET Framework Class Library
CustomLabelBarcodeEntry Properties
CustomLabelBarcodeEntry Class See Also Send Feedback

The CustomLabelBarcodeEntry type exposes the following members.

Properties

Name | Description
BarcodeSymbology |
BarcodeSymbologySpecified |
BarHeight |
BarHeightSpecified |
DataFields |
Format |
Position |
ThinBarWidth |
ThinBarWidthSpecified |

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


BarcodeSymbology Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.BarcodeSymbology Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BarcodeSymbology As BarcodeSymbologyType
C#
public BarcodeSymbologyType BarcodeSymbology { get; set; }
Visual C++
public:
property BarcodeSymbologyType BarcodeSymbology {
    BarcodeSymbologyType get ();
    void set (BarcodeSymbologyType value);
}
JavaScript
function get_barcodeSymbology();
function set_barcodeSymbology(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


BarcodeSymbologySpecified Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.BarcodeSymbologySpecified Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BarcodeSymbologySpecified As Boolean
C#
public bool BarcodeSymbologySpecified { get; set; }
Visual C++
public:
property bool BarcodeSymbologySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_barcodeSymbologySpecified();
function set_barcodeSymbologySpecified(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


BarHeight Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.BarHeight Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BarHeight As Integer
C#
public int BarHeight { get; set; }
Visual C++
public:
property int BarHeight {
    int get ();
    void set (int value);
}
JavaScript
function get_barHeight();
function set_barHeight(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


BarHeightSpecified Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.BarHeightSpecified Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BarHeightSpecified As Boolean
C#
public bool BarHeightSpecified { get; set; }
Visual C++
public:
property bool BarHeightSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_barHeightSpecified();
function set_barHeightSpecified(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


DataFields Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.DataFields Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DataFields As String()
C#
public string[] DataFields { get; set; }
Visual C++
public:
property array<String^>^ DataFields {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_dataFields();
function set_dataFields(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


Format Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.Format Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As String
C#
public string Format { get; set; }
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_format();
function set_format(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


Position Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.Position Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As CustomLabelPosition
C#
public CustomLabelPosition Position { get; set; }
Visual C++
public:
property CustomLabelPosition^ Position {
    CustomLabelPosition^ get ();
    void set (CustomLabelPosition^ value);
}
JavaScript
function get_position();
function set_position(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


ThinBarWidth Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.ThinBarWidth Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ThinBarWidth As Integer
C#
public int ThinBarWidth { get; set; }
Visual C++
public:
property int ThinBarWidth {
    int get ();
    void set (int value);
}
JavaScript
function get_thinBarWidth();
function set_thinBarWidth(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


ThinBarWidthSpecified Property

[image]

.NET Framework Class Library
CustomLabelBarcodeEntry..::.ThinBarWidthSpecified Property
CustomLabelBarcodeEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ThinBarWidthSpecified As Boolean
C#
public bool ThinBarWidthSpecified { get; set; }
Visual C++
public:
property bool ThinBarWidthSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_thinBarWidthSpecified();
function set_thinBarWidthSpecified(value);

Remarks

See Also

CustomLabelBarcodeEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelBoxEntry Class

[image]

.NET Framework Class Library
CustomLabelBoxEntry Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomLabelBoxEntry
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomLabelBoxEntry
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomLabelBoxEntry
JavaScript
InSite.Domain.FedExRateService.CustomLabelBoxEntry = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomLabelBoxEntry');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomLabelBoxEntry

See Also

CustomLabelBoxEntry Members
InSite.Domain.FedExRateService Namespace


CustomLabelBoxEntry Members

[image] [image]

.NET Framework Class Library
CustomLabelBoxEntry Members
CustomLabelBoxEntry Class Constructors Methods Properties See Also Send Feedback

The CustomLabelBoxEntry type exposes the following members.

Constructors

Name | Description
CustomLabelBoxEntry |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BottomRightCorner |
TopLeftCorner |

See Also

CustomLabelBoxEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelBoxEntry Constructor

[image]

.NET Framework Class Library
CustomLabelBoxEntry Constructor
CustomLabelBoxEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomLabelBoxEntry()
Visual C++
public:
CustomLabelBoxEntry()
JavaScript
InSite.Domain.FedExRateService.CustomLabelBoxEntry = function();

See Also

CustomLabelBoxEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelBoxEntry Methods

[image] [image]

.NET Framework Class Library
CustomLabelBoxEntry Methods
CustomLabelBoxEntry Class See Also Send Feedback

The CustomLabelBoxEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomLabelBoxEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelBoxEntry Properties

[image] [image]

.NET Framework Class Library
CustomLabelBoxEntry Properties
CustomLabelBoxEntry Class See Also Send Feedback

The CustomLabelBoxEntry type exposes the following members.

Properties

Name | Description
BottomRightCorner |
TopLeftCorner |

See Also

CustomLabelBoxEntry Class
InSite.Domain.FedExRateService Namespace


BottomRightCorner Property

[image]

.NET Framework Class Library
CustomLabelBoxEntry..::.BottomRightCorner Property
CustomLabelBoxEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BottomRightCorner As CustomLabelPosition
C#
public CustomLabelPosition BottomRightCorner { get; set; }
Visual C++
public:
property CustomLabelPosition^ BottomRightCorner {
    CustomLabelPosition^ get ();
    void set (CustomLabelPosition^ value);
}
JavaScript
function get_bottomRightCorner();
function set_bottomRightCorner(value);

Remarks

See Also

CustomLabelBoxEntry Class
InSite.Domain.FedExRateService Namespace


TopLeftCorner Property

[image]

.NET Framework Class Library
CustomLabelBoxEntry..::.TopLeftCorner Property
CustomLabelBoxEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TopLeftCorner As CustomLabelPosition
C#
public CustomLabelPosition TopLeftCorner { get; set; }
Visual C++
public:
property CustomLabelPosition^ TopLeftCorner {
    CustomLabelPosition^ get ();
    void set (CustomLabelPosition^ value);
}
JavaScript
function get_topLeftCorner();
function set_topLeftCorner(value);

Remarks

See Also

CustomLabelBoxEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelCoordinateUnits Enumeration

[image]

.NET Framework Class Library
CustomLabelCoordinateUnits Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CustomLabelCoordinateUnits
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CustomLabelCoordinateUnits
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CustomLabelCoordinateUnits
JavaScript
InSite.Domain.FedExRateService.CustomLabelCoordinateUnits = function();
InSite.Domain.FedExRateService.CustomLabelCoordinateUnits.createEnum('InSite.Domain.FedExRateService.CustomLabelCoordinateUnits', false);

Members

Member name | Description
MILS |
PIXELS |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


CustomLabelDetail Class

[image]

.NET Framework Class Library
CustomLabelDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomLabelDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomLabelDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomLabelDetail
JavaScript
InSite.Domain.FedExRateService.CustomLabelDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomLabelDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomLabelDetail

See Also

CustomLabelDetail Members
InSite.Domain.FedExRateService Namespace


CustomLabelDetail Members

[image] [image]

.NET Framework Class Library
CustomLabelDetail Members
CustomLabelDetail Class Constructors Methods Properties See Also Send Feedback

The CustomLabelDetail type exposes the following members.

Constructors

Name | Description
CustomLabelDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BarcodeEntries |
BoxEntries |
CoordinateUnits |
CoordinateUnitsSpecified |
GraphicEntries |
TextEntries |

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomLabelDetail Constructor

[image]

.NET Framework Class Library
CustomLabelDetail Constructor
CustomLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomLabelDetail()
Visual C++
public:
CustomLabelDetail()
JavaScript
InSite.Domain.FedExRateService.CustomLabelDetail = function();

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomLabelDetail Methods

[image] [image]

.NET Framework Class Library
CustomLabelDetail Methods
CustomLabelDetail Class See Also Send Feedback

The CustomLabelDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomLabelDetail Properties

[image] [image]

.NET Framework Class Library
CustomLabelDetail Properties
CustomLabelDetail Class See Also Send Feedback

The CustomLabelDetail type exposes the following members.

Properties

Name | Description
BarcodeEntries |
BoxEntries |
CoordinateUnits |
CoordinateUnitsSpecified |
GraphicEntries |
TextEntries |

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


BarcodeEntries Property

[image]

.NET Framework Class Library
CustomLabelDetail..::.BarcodeEntries Property
CustomLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BarcodeEntries As CustomLabelBarcodeEntry()
C#
public CustomLabelBarcodeEntry[] BarcodeEntries { get; set; }
Visual C++
public:
property array<CustomLabelBarcodeEntry^>^ BarcodeEntries {
    array<CustomLabelBarcodeEntry^>^ get ();
    void set (array<CustomLabelBarcodeEntry^>^ value);
}
JavaScript
function get_barcodeEntries();
function set_barcodeEntries(value);

Remarks

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


BoxEntries Property

[image]

.NET Framework Class Library
CustomLabelDetail..::.BoxEntries Property
CustomLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BoxEntries As CustomLabelBoxEntry()
C#
public CustomLabelBoxEntry[] BoxEntries { get; set; }
Visual C++
public:
property array<CustomLabelBoxEntry^>^ BoxEntries {
    array<CustomLabelBoxEntry^>^ get ();
    void set (array<CustomLabelBoxEntry^>^ value);
}
JavaScript
function get_boxEntries();
function set_boxEntries(value);

Remarks

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


CoordinateUnits Property

[image]

.NET Framework Class Library
CustomLabelDetail..::.CoordinateUnits Property
CustomLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CoordinateUnits As CustomLabelCoordinateUnits
C#
public CustomLabelCoordinateUnits CoordinateUnits { get; set; }
Visual C++
public:
property CustomLabelCoordinateUnits CoordinateUnits {
    CustomLabelCoordinateUnits get ();
    void set (CustomLabelCoordinateUnits value);
}
JavaScript
function get_coordinateUnits();
function set_coordinateUnits(value);

Remarks

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


CoordinateUnitsSpecified Property

[image]

.NET Framework Class Library
CustomLabelDetail..::.CoordinateUnitsSpecified Property
CustomLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CoordinateUnitsSpecified As Boolean
C#
public bool CoordinateUnitsSpecified { get; set; }
Visual C++
public:
property bool CoordinateUnitsSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_coordinateUnitsSpecified();
function set_coordinateUnitsSpecified(value);

Remarks

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


GraphicEntries Property

[image]

.NET Framework Class Library
CustomLabelDetail..::.GraphicEntries Property
CustomLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property GraphicEntries As CustomLabelGraphicEntry()
C#
public CustomLabelGraphicEntry[] GraphicEntries { get; set; }
Visual C++
public:
property array<CustomLabelGraphicEntry^>^ GraphicEntries {
    array<CustomLabelGraphicEntry^>^ get ();
    void set (array<CustomLabelGraphicEntry^>^ value);
}
JavaScript
function get_graphicEntries();
function set_graphicEntries(value);

Remarks

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


TextEntries Property

[image]

.NET Framework Class Library
CustomLabelDetail..::.TextEntries Property
CustomLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TextEntries As CustomLabelTextEntry()
C#
public CustomLabelTextEntry[] TextEntries { get; set; }
Visual C++
public:
property array<CustomLabelTextEntry^>^ TextEntries {
    array<CustomLabelTextEntry^>^ get ();
    void set (array<CustomLabelTextEntry^>^ value);
}
JavaScript
function get_textEntries();
function set_textEntries(value);

Remarks

See Also

CustomLabelDetail Class
InSite.Domain.FedExRateService Namespace


CustomLabelGraphicEntry Class

[image]

.NET Framework Class Library
CustomLabelGraphicEntry Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomLabelGraphicEntry
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomLabelGraphicEntry
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomLabelGraphicEntry
JavaScript
InSite.Domain.FedExRateService.CustomLabelGraphicEntry = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomLabelGraphicEntry');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomLabelGraphicEntry

See Also

CustomLabelGraphicEntry Members
InSite.Domain.FedExRateService Namespace


CustomLabelGraphicEntry Members

[image] [image]

.NET Framework Class Library
CustomLabelGraphicEntry Members
CustomLabelGraphicEntry Class Constructors Methods Properties See Also Send Feedback

The CustomLabelGraphicEntry type exposes the following members.

Constructors

Name | Description
CustomLabelGraphicEntry |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FileGraphicFullName |
Position |
PrinterGraphicId |

See Also

CustomLabelGraphicEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelGraphicEntry Constructor

[image]

.NET Framework Class Library
CustomLabelGraphicEntry Constructor
CustomLabelGraphicEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomLabelGraphicEntry()
Visual C++
public:
CustomLabelGraphicEntry()
JavaScript
InSite.Domain.FedExRateService.CustomLabelGraphicEntry = function();

See Also

CustomLabelGraphicEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelGraphicEntry Methods

[image] [image]

.NET Framework Class Library
CustomLabelGraphicEntry Methods
CustomLabelGraphicEntry Class See Also Send Feedback

The CustomLabelGraphicEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomLabelGraphicEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelGraphicEntry Properties

[image] [image]

.NET Framework Class Library
CustomLabelGraphicEntry Properties
CustomLabelGraphicEntry Class See Also Send Feedback

The CustomLabelGraphicEntry type exposes the following members.

Properties

Name | Description
FileGraphicFullName |
Position |
PrinterGraphicId |

See Also

CustomLabelGraphicEntry Class
InSite.Domain.FedExRateService Namespace


FileGraphicFullName Property

[image]

.NET Framework Class Library
CustomLabelGraphicEntry..::.FileGraphicFullName Property
CustomLabelGraphicEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FileGraphicFullName As String
C#
public string FileGraphicFullName { get; set; }
Visual C++
public:
property String^ FileGraphicFullName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fileGraphicFullName();
function set_fileGraphicFullName(value);

Remarks

See Also

CustomLabelGraphicEntry Class
InSite.Domain.FedExRateService Namespace


Position Property

[image]

.NET Framework Class Library
CustomLabelGraphicEntry..::.Position Property
CustomLabelGraphicEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As CustomLabelPosition
C#
public CustomLabelPosition Position { get; set; }
Visual C++
public:
property CustomLabelPosition^ Position {
    CustomLabelPosition^ get ();
    void set (CustomLabelPosition^ value);
}
JavaScript
function get_position();
function set_position(value);

Remarks

See Also

CustomLabelGraphicEntry Class
InSite.Domain.FedExRateService Namespace


PrinterGraphicId Property

[image]

.NET Framework Class Library
CustomLabelGraphicEntry..::.PrinterGraphicId Property
CustomLabelGraphicEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PrinterGraphicId As String
C#
public string PrinterGraphicId { get; set; }
Visual C++
public:
property String^ PrinterGraphicId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_printerGraphicId();
function set_printerGraphicId(value);

Remarks

See Also

CustomLabelGraphicEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelPosition Class

[image]

.NET Framework Class Library
CustomLabelPosition Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomLabelPosition
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomLabelPosition
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomLabelPosition
JavaScript
InSite.Domain.FedExRateService.CustomLabelPosition = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomLabelPosition');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomLabelPosition

See Also

CustomLabelPosition Members
InSite.Domain.FedExRateService Namespace


CustomLabelPosition Members

[image] [image]

.NET Framework Class Library
CustomLabelPosition Members
CustomLabelPosition Class Constructors Methods Properties See Also Send Feedback

The CustomLabelPosition type exposes the following members.

Constructors

Name | Description
CustomLabelPosition |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
X |
Y |

See Also

CustomLabelPosition Class
InSite.Domain.FedExRateService Namespace


CustomLabelPosition Constructor

[image]

.NET Framework Class Library
CustomLabelPosition Constructor
CustomLabelPosition Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomLabelPosition()
Visual C++
public:
CustomLabelPosition()
JavaScript
InSite.Domain.FedExRateService.CustomLabelPosition = function();

See Also

CustomLabelPosition Class
InSite.Domain.FedExRateService Namespace


CustomLabelPosition Methods

[image] [image]

.NET Framework Class Library
CustomLabelPosition Methods
CustomLabelPosition Class See Also Send Feedback

The CustomLabelPosition type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomLabelPosition Class
InSite.Domain.FedExRateService Namespace


CustomLabelPosition Properties

[image] [image]

.NET Framework Class Library
CustomLabelPosition Properties
CustomLabelPosition Class See Also Send Feedback

The CustomLabelPosition type exposes the following members.

Properties

Name | Description
X |
Y |

See Also

CustomLabelPosition Class
InSite.Domain.FedExRateService Namespace


X Property

[image]

.NET Framework Class Library
CustomLabelPosition..::.X Property
CustomLabelPosition Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property X As String
C#
public string X { get; set; }
Visual C++
public:
property String^ X {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_x();
function set_x(value);

Remarks

See Also

CustomLabelPosition Class
InSite.Domain.FedExRateService Namespace


Y Property

[image]

.NET Framework Class Library
CustomLabelPosition..::.Y Property
CustomLabelPosition Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Y As String
C#
public string Y { get; set; }
Visual C++
public:
property String^ Y {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_y();
function set_y(value);

Remarks

See Also

CustomLabelPosition Class
InSite.Domain.FedExRateService Namespace


CustomLabelTextEntry Class

[image]

.NET Framework Class Library
CustomLabelTextEntry Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class CustomLabelTextEntry
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class CustomLabelTextEntry
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class CustomLabelTextEntry
JavaScript
InSite.Domain.FedExRateService.CustomLabelTextEntry = function();

Type.createClass(
    'InSite.Domain.FedExRateService.CustomLabelTextEntry');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.CustomLabelTextEntry

See Also

CustomLabelTextEntry Members
InSite.Domain.FedExRateService Namespace


CustomLabelTextEntry Members

[image] [image]

.NET Framework Class Library
CustomLabelTextEntry Members
CustomLabelTextEntry Class Constructors Methods Properties See Also Send Feedback

The CustomLabelTextEntry type exposes the following members.

Constructors

Name | Description
CustomLabelTextEntry |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataFields |
FontName |
FontSize |
Format |
Position |
ThermalFontId |

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelTextEntry Constructor

[image]

.NET Framework Class Library
CustomLabelTextEntry Constructor
CustomLabelTextEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomLabelTextEntry()
Visual C++
public:
CustomLabelTextEntry()
JavaScript
InSite.Domain.FedExRateService.CustomLabelTextEntry = function();

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelTextEntry Methods

[image] [image]

.NET Framework Class Library
CustomLabelTextEntry Methods
CustomLabelTextEntry Class See Also Send Feedback

The CustomLabelTextEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


CustomLabelTextEntry Properties

[image] [image]

.NET Framework Class Library
CustomLabelTextEntry Properties
CustomLabelTextEntry Class See Also Send Feedback

The CustomLabelTextEntry type exposes the following members.

Properties

Name | Description
DataFields |
FontName |
FontSize |
Format |
Position |
ThermalFontId |

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


DataFields Property

[image]

.NET Framework Class Library
CustomLabelTextEntry..::.DataFields Property
CustomLabelTextEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DataFields As String()
C#
public string[] DataFields { get; set; }
Visual C++
public:
property array<String^>^ DataFields {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_dataFields();
function set_dataFields(value);

Remarks

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


FontName Property

[image]

.NET Framework Class Library
CustomLabelTextEntry..::.FontName Property
CustomLabelTextEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FontName As String
C#
public string FontName { get; set; }
Visual C++
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fontName();
function set_fontName(value);

Remarks

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


FontSize Property

[image]

.NET Framework Class Library
CustomLabelTextEntry..::.FontSize Property
CustomLabelTextEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FontSize As String
C#
public string FontSize { get; set; }
Visual C++
public:
property String^ FontSize {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fontSize();
function set_fontSize(value);

Remarks

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


Format Property

[image]

.NET Framework Class Library
CustomLabelTextEntry..::.Format Property
CustomLabelTextEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As String
C#
public string Format { get; set; }
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_format();
function set_format(value);

Remarks

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


Position Property

[image]

.NET Framework Class Library
CustomLabelTextEntry..::.Position Property
CustomLabelTextEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Position As CustomLabelPosition
C#
public CustomLabelPosition Position { get; set; }
Visual C++
public:
property CustomLabelPosition^ Position {
    CustomLabelPosition^ get ();
    void set (CustomLabelPosition^ value);
}
JavaScript
function get_position();
function set_position(value);

Remarks

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


ThermalFontId Property

[image]

.NET Framework Class Library
CustomLabelTextEntry..::.ThermalFontId Property
CustomLabelTextEntry Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ThermalFontId As String
C#
public string ThermalFontId { get; set; }
Visual C++
public:
property String^ ThermalFontId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_thermalFontId();
function set_thermalFontId(value);

Remarks

See Also

CustomLabelTextEntry Class
InSite.Domain.FedExRateService Namespace


DangerousGoodsAccessibilityType Enumeration

[image]

.NET Framework Class Library
DangerousGoodsAccessibilityType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DangerousGoodsAccessibilityType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DangerousGoodsAccessibilityType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DangerousGoodsAccessibilityType
JavaScript
InSite.Domain.FedExRateService.DangerousGoodsAccessibilityType = function();
InSite.Domain.FedExRateService.DangerousGoodsAccessibilityType.createEnum('InSite.Domain.FedExRateService.DangerousGoodsAccessibilityType', false);

Members

Member name | Description
ACCESSIBLE |
INACCESSIBLE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


DangerousGoodsDetail Class

[image]

.NET Framework Class Library
DangerousGoodsDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class DangerousGoodsDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class DangerousGoodsDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class DangerousGoodsDetail
JavaScript
InSite.Domain.FedExRateService.DangerousGoodsDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.DangerousGoodsDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.DangerousGoodsDetail

See Also

DangerousGoodsDetail Members
InSite.Domain.FedExRateService Namespace


DangerousGoodsDetail Members

[image] [image]

.NET Framework Class Library
DangerousGoodsDetail Members
DangerousGoodsDetail Class Constructors Methods Properties See Also Send Feedback

The DangerousGoodsDetail type exposes the following members.

Constructors

Name | Description
DangerousGoodsDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Accessibility |
AccessibilitySpecified |
CargoAircraftOnly |
CargoAircraftOnlySpecified |
HazMatCertificateData |

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


DangerousGoodsDetail Constructor

[image]

.NET Framework Class Library
DangerousGoodsDetail Constructor
DangerousGoodsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DangerousGoodsDetail()
Visual C++
public:
DangerousGoodsDetail()
JavaScript
InSite.Domain.FedExRateService.DangerousGoodsDetail = function();

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


DangerousGoodsDetail Methods

[image] [image]

.NET Framework Class Library
DangerousGoodsDetail Methods
DangerousGoodsDetail Class See Also Send Feedback

The DangerousGoodsDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


DangerousGoodsDetail Properties

[image] [image]

.NET Framework Class Library
DangerousGoodsDetail Properties
DangerousGoodsDetail Class See Also Send Feedback

The DangerousGoodsDetail type exposes the following members.

Properties

Name | Description
Accessibility |
AccessibilitySpecified |
CargoAircraftOnly |
CargoAircraftOnlySpecified |
HazMatCertificateData |

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


Accessibility Property

[image]

.NET Framework Class Library
DangerousGoodsDetail..::.Accessibility Property
DangerousGoodsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Accessibility As DangerousGoodsAccessibilityType
C#
public DangerousGoodsAccessibilityType Accessibility { get; set; }
Visual C++
public:
property DangerousGoodsAccessibilityType Accessibility {
    DangerousGoodsAccessibilityType get ();
    void set (DangerousGoodsAccessibilityType value);
}
JavaScript
function get_accessibility();
function set_accessibility(value);

Remarks

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


AccessibilitySpecified Property

[image]

.NET Framework Class Library
DangerousGoodsDetail..::.AccessibilitySpecified Property
DangerousGoodsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AccessibilitySpecified As Boolean
C#
public bool AccessibilitySpecified { get; set; }
Visual C++
public:
property bool AccessibilitySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_accessibilitySpecified();
function set_accessibilitySpecified(value);

Remarks

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


CargoAircraftOnly Property

[image]

.NET Framework Class Library
DangerousGoodsDetail..::.CargoAircraftOnly Property
DangerousGoodsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CargoAircraftOnly As Boolean
C#
public bool CargoAircraftOnly { get; set; }
Visual C++
public:
property bool CargoAircraftOnly {
    bool get ();
    void set (bool value);
}
JavaScript
function get_cargoAircraftOnly();
function set_cargoAircraftOnly(value);

Remarks

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


CargoAircraftOnlySpecified Property

[image]

.NET Framework Class Library
DangerousGoodsDetail..::.CargoAircraftOnlySpecified Property
DangerousGoodsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CargoAircraftOnlySpecified As Boolean
C#
public bool CargoAircraftOnlySpecified { get; set; }
Visual C++
public:
property bool CargoAircraftOnlySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_cargoAircraftOnlySpecified();
function set_cargoAircraftOnlySpecified(value);

Remarks

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


HazMatCertificateData Property

[image]

.NET Framework Class Library
DangerousGoodsDetail..::.HazMatCertificateData Property
DangerousGoodsDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HazMatCertificateData As HazMatCertificateData
C#
public HazMatCertificateData HazMatCertificateData { get; set; }
Visual C++
public:
property HazMatCertificateData^ HazMatCertificateData {
    HazMatCertificateData^ get ();
    void set (HazMatCertificateData^ value);
}
JavaScript
function get_hazMatCertificateData();
function set_hazMatCertificateData(value);

Remarks

See Also

DangerousGoodsDetail Class
InSite.Domain.FedExRateService Namespace


DateRange Class

[image]

.NET Framework Class Library
DateRange Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class DateRange
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class DateRange
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class DateRange
JavaScript
InSite.Domain.FedExRateService.DateRange = function();

Type.createClass(
    'InSite.Domain.FedExRateService.DateRange');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.DateRange

See Also

DateRange Members
InSite.Domain.FedExRateService Namespace


DateRange Members

[image] [image]

.NET Framework Class Library
DateRange Members
DateRange Class Constructors Methods Properties See Also Send Feedback

The DateRange type exposes the following members.

Constructors

Name | Description
DateRange |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Begins |
Ends |

See Also

DateRange Class
InSite.Domain.FedExRateService Namespace


DateRange Constructor

[image]

.NET Framework Class Library
DateRange Constructor
DateRange Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DateRange()
Visual C++
public:
DateRange()
JavaScript
InSite.Domain.FedExRateService.DateRange = function();

See Also

DateRange Class
InSite.Domain.FedExRateService Namespace


DateRange Methods

[image] [image]

.NET Framework Class Library
DateRange Methods
DateRange Class See Also Send Feedback

The DateRange type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateRange Class
InSite.Domain.FedExRateService Namespace


DateRange Properties

[image] [image]

.NET Framework Class Library
DateRange Properties
DateRange Class See Also Send Feedback

The DateRange type exposes the following members.

Properties

Name | Description
Begins |
Ends |

See Also

DateRange Class
InSite.Domain.FedExRateService Namespace


Begins Property

[image]

.NET Framework Class Library
DateRange..::.Begins Property
DateRange Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Begins As DateTime
C#
public DateTime Begins { get; set; }
Visual C++
public:
property DateTime Begins {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_begins();
function set_begins(value);

Remarks

See Also

DateRange Class
InSite.Domain.FedExRateService Namespace


Ends Property

[image]

.NET Framework Class Library
DateRange..::.Ends Property
DateRange Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Ends As DateTime
C#
public DateTime Ends { get; set; }
Visual C++
public:
property DateTime Ends {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_ends();
function set_ends(value);

Remarks

See Also

DateRange Class
InSite.Domain.FedExRateService Namespace


DayOfWeekType Enumeration

[image]

.NET Framework Class Library
DayOfWeekType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DayOfWeekType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DayOfWeekType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DayOfWeekType
JavaScript
InSite.Domain.FedExRateService.DayOfWeekType = function();
InSite.Domain.FedExRateService.DayOfWeekType.createEnum('InSite.Domain.FedExRateService.DayOfWeekType', false);

Members

Member name | Description
FRI |
MON |
SAT |
SUN |
THU |
TUE |
WED |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


DelayDetail Class

[image]

.NET Framework Class Library
DelayDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class DelayDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class DelayDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class DelayDetail
JavaScript
InSite.Domain.FedExRateService.DelayDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.DelayDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.DelayDetail

See Also

DelayDetail Members
InSite.Domain.FedExRateService Namespace


DelayDetail Members

[image] [image]

.NET Framework Class Library
DelayDetail Members
DelayDetail Class Constructors Methods Properties See Also Send Feedback

The DelayDetail type exposes the following members.

Constructors

Name | Description
DelayDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Date |
DateSpecified |
DayOfWeek |
DayOfWeekSpecified |
Description |
Level |
LevelSpecified |
Point |
PointSpecified |
Type |
TypeSpecified |

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


DelayDetail Constructor

[image]

.NET Framework Class Library
DelayDetail Constructor
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DelayDetail()
Visual C++
public:
DelayDetail()
JavaScript
InSite.Domain.FedExRateService.DelayDetail = function();

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


DelayDetail Methods

[image] [image]

.NET Framework Class Library
DelayDetail Methods
DelayDetail Class See Also Send Feedback

The DelayDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


DelayDetail Properties

[image] [image]

.NET Framework Class Library
DelayDetail Properties
DelayDetail Class See Also Send Feedback

The DelayDetail type exposes the following members.

Properties

Name | Description
Date |
DateSpecified |
DayOfWeek |
DayOfWeekSpecified |
Description |
Level |
LevelSpecified |
Point |
PointSpecified |
Type |
TypeSpecified |

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


Date Property

[image]

.NET Framework Class Library
DelayDetail..::.Date Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Date As DateTime
C#
public DateTime Date { get; set; }
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_date();
function set_date(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


DateSpecified Property

[image]

.NET Framework Class Library
DelayDetail..::.DateSpecified Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DateSpecified As Boolean
C#
public bool DateSpecified { get; set; }
Visual C++
public:
property bool DateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dateSpecified();
function set_dateSpecified(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


DayOfWeek Property

[image]

.NET Framework Class Library
DelayDetail..::.DayOfWeek Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DayOfWeek As DayOfWeekType
C#
public DayOfWeekType DayOfWeek { get; set; }
Visual C++
public:
property DayOfWeekType DayOfWeek {
    DayOfWeekType get ();
    void set (DayOfWeekType value);
}
JavaScript
function get_dayOfWeek();
function set_dayOfWeek(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


DayOfWeekSpecified Property

[image]

.NET Framework Class Library
DelayDetail..::.DayOfWeekSpecified Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DayOfWeekSpecified As Boolean
C#
public bool DayOfWeekSpecified { get; set; }
Visual C++
public:
property bool DayOfWeekSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dayOfWeekSpecified();
function set_dayOfWeekSpecified(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
DelayDetail..::.Description Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


Level Property

[image]

.NET Framework Class Library
DelayDetail..::.Level Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Level As DelayLevelType
C#
public DelayLevelType Level { get; set; }
Visual C++
public:
property DelayLevelType Level {
    DelayLevelType get ();
    void set (DelayLevelType value);
}
JavaScript
function get_level();
function set_level(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


LevelSpecified Property

[image]

.NET Framework Class Library
DelayDetail..::.LevelSpecified Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LevelSpecified As Boolean
C#
public bool LevelSpecified { get; set; }
Visual C++
public:
property bool LevelSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_levelSpecified();
function set_levelSpecified(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


Point Property

[image]

.NET Framework Class Library
DelayDetail..::.Point Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Point As DelayPointType
C#
public DelayPointType Point { get; set; }
Visual C++
public:
property DelayPointType Point {
    DelayPointType get ();
    void set (DelayPointType value);
}
JavaScript
function get_point();
function set_point(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


PointSpecified Property

[image]

.NET Framework Class Library
DelayDetail..::.PointSpecified Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PointSpecified As Boolean
C#
public bool PointSpecified { get; set; }
Visual C++
public:
property bool PointSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_pointSpecified();
function set_pointSpecified(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


Type Property

[image]

.NET Framework Class Library
DelayDetail..::.Type Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As CommitmentDelayType
C#
public CommitmentDelayType Type { get; set; }
Visual C++
public:
property CommitmentDelayType Type {
    CommitmentDelayType get ();
    void set (CommitmentDelayType value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


TypeSpecified Property

[image]

.NET Framework Class Library
DelayDetail..::.TypeSpecified Property
DelayDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSpecified As Boolean
C#
public bool TypeSpecified { get; set; }
Visual C++
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_typeSpecified();
function set_typeSpecified(value);

Remarks

See Also

DelayDetail Class
InSite.Domain.FedExRateService Namespace


DelayLevelType Enumeration

[image]

.NET Framework Class Library
DelayLevelType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DelayLevelType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DelayLevelType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DelayLevelType
JavaScript
InSite.Domain.FedExRateService.DelayLevelType = function();
InSite.Domain.FedExRateService.DelayLevelType.createEnum('InSite.Domain.FedExRateService.DelayLevelType', false);

Members

Member name | Description
CITY |
COUNTRY |
LOCATION |
POSTAL_CODE |
SERVICE_AREA |
SERVICE_AREA_SPECIAL_SERVICE |
SPECIAL_SERVICE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


DelayPointType Enumeration

[image]

.NET Framework Class Library
DelayPointType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DelayPointType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DelayPointType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DelayPointType
JavaScript
InSite.Domain.FedExRateService.DelayPointType = function();
InSite.Domain.FedExRateService.DelayPointType.createEnum('InSite.Domain.FedExRateService.DelayPointType', false);

Members

Member name | Description
BROKER |
DESTINATION |
ORIGIN |
ORIGIN_DESTINATION_PAIR |
PROOF_OF_DELIVERY_POINT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


DestinationControlDetail Class

[image]

.NET Framework Class Library
DestinationControlDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class DestinationControlDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class DestinationControlDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class DestinationControlDetail
JavaScript
InSite.Domain.FedExRateService.DestinationControlDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.DestinationControlDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.DestinationControlDetail

See Also

DestinationControlDetail Members
InSite.Domain.FedExRateService Namespace


DestinationControlDetail Members

[image] [image]

.NET Framework Class Library
DestinationControlDetail Members
DestinationControlDetail Class Constructors Methods Properties See Also Send Feedback

The DestinationControlDetail type exposes the following members.

Constructors

Name | Description
DestinationControlDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DestinationCountries |
EndUser |
StatementTypes |

See Also

DestinationControlDetail Class
InSite.Domain.FedExRateService Namespace


DestinationControlDetail Constructor

[image]

.NET Framework Class Library
DestinationControlDetail Constructor
DestinationControlDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DestinationControlDetail()
Visual C++
public:
DestinationControlDetail()
JavaScript
InSite.Domain.FedExRateService.DestinationControlDetail = function();

See Also

DestinationControlDetail Class
InSite.Domain.FedExRateService Namespace


DestinationControlDetail Methods

[image] [image]

.NET Framework Class Library
DestinationControlDetail Methods
DestinationControlDetail Class See Also Send Feedback

The DestinationControlDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DestinationControlDetail Class
InSite.Domain.FedExRateService Namespace


DestinationControlDetail Properties

[image] [image]

.NET Framework Class Library
DestinationControlDetail Properties
DestinationControlDetail Class See Also Send Feedback

The DestinationControlDetail type exposes the following members.

Properties

Name | Description
DestinationCountries |
EndUser |
StatementTypes |

See Also

DestinationControlDetail Class
InSite.Domain.FedExRateService Namespace


DestinationCountries Property

[image]

.NET Framework Class Library
DestinationControlDetail..::.DestinationCountries Property
DestinationControlDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationCountries As String
C#
public string DestinationCountries { get; set; }
Visual C++
public:
property String^ DestinationCountries {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_destinationCountries();
function set_destinationCountries(value);

Remarks

See Also

DestinationControlDetail Class
InSite.Domain.FedExRateService Namespace


EndUser Property

[image]

.NET Framework Class Library
DestinationControlDetail..::.EndUser Property
DestinationControlDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EndUser As String
C#
public string EndUser { get; set; }
Visual C++
public:
property String^ EndUser {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_endUser();
function set_endUser(value);

Remarks

See Also

DestinationControlDetail Class
InSite.Domain.FedExRateService Namespace


StatementTypes Property

[image]

.NET Framework Class Library
DestinationControlDetail..::.StatementTypes Property
DestinationControlDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property StatementTypes As DestinationControlStatementType()
C#
public DestinationControlStatementType[] StatementTypes { get; set; }
Visual C++
public:
property array<DestinationControlStatementType>^ StatementTypes {
    array<DestinationControlStatementType>^ get ();
    void set (array<DestinationControlStatementType>^ value);
}
JavaScript
function get_statementTypes();
function set_statementTypes(value);

Remarks

See Also

DestinationControlDetail Class
InSite.Domain.FedExRateService Namespace


DestinationControlStatementType Enumeration

[image]

.NET Framework Class Library
DestinationControlStatementType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DestinationControlStatementType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DestinationControlStatementType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DestinationControlStatementType
JavaScript
InSite.Domain.FedExRateService.DestinationControlStatementType = function();
InSite.Domain.FedExRateService.DestinationControlStatementType.createEnum('InSite.Domain.FedExRateService.DestinationControlStatementType', false);

Members

Member name | Description
DEPARTMENT_OF_COMMERCE |
DEPARTMENT_OF_STATE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Dimensions Class

[image]

.NET Framework Class Library
Dimensions Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Dimensions
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Dimensions
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Dimensions
JavaScript
InSite.Domain.FedExRateService.Dimensions = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Dimensions');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Dimensions

See Also

Dimensions Members
InSite.Domain.FedExRateService Namespace


Dimensions Members

[image] [image]

.NET Framework Class Library
Dimensions Members
Dimensions Class Constructors Methods Properties See Also Send Feedback

The Dimensions type exposes the following members.

Constructors

Name | Description
Dimensions |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height |
Length |
Units |
Width |

See Also

Dimensions Class
InSite.Domain.FedExRateService Namespace


Dimensions Constructor

[image]

.NET Framework Class Library
Dimensions Constructor
Dimensions Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Dimensions()
Visual C++
public:
Dimensions()
JavaScript
InSite.Domain.FedExRateService.Dimensions = function();

See Also

Dimensions Class
InSite.Domain.FedExRateService Namespace


Dimensions Methods

[image] [image]

.NET Framework Class Library
Dimensions Methods
Dimensions Class See Also Send Feedback

The Dimensions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Dimensions Class
InSite.Domain.FedExRateService Namespace


Dimensions Properties

[image] [image]

.NET Framework Class Library
Dimensions Properties
Dimensions Class See Also Send Feedback

The Dimensions type exposes the following members.

Properties

Name | Description
Height |
Length |
Units |
Width |

See Also

Dimensions Class
InSite.Domain.FedExRateService Namespace


Height Property

[image]

.NET Framework Class Library
Dimensions..::.Height Property
Dimensions Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As String
C#
public string Height { get; set; }
Visual C++
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_height();
function set_height(value);

Remarks

See Also

Dimensions Class
InSite.Domain.FedExRateService Namespace


Length Property

[image]

.NET Framework Class Library
Dimensions..::.Length Property
Dimensions Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As String
C#
public string Length { get; set; }
Visual C++
public:
property String^ Length {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_length();
function set_length(value);

Remarks

See Also

Dimensions Class
InSite.Domain.FedExRateService Namespace


Units Property

[image]

.NET Framework Class Library
Dimensions..::.Units Property
Dimensions Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As LinearUnits
C#
public LinearUnits Units { get; set; }
Visual C++
public:
property LinearUnits Units {
    LinearUnits get ();
    void set (LinearUnits value);
}
JavaScript
function get_units();
function set_units(value);

Remarks

See Also

Dimensions Class
InSite.Domain.FedExRateService Namespace


Width Property

[image]

.NET Framework Class Library
Dimensions..::.Width Property
Dimensions Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As String
C#
public string Width { get; set; }
Visual C++
public:
property String^ Width {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_width();
function set_width(value);

Remarks

See Also

Dimensions Class
InSite.Domain.FedExRateService Namespace


Distance Class

[image]

.NET Framework Class Library
Distance Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Distance
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Distance
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Distance
JavaScript
InSite.Domain.FedExRateService.Distance = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Distance');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Distance

See Also

Distance Members
InSite.Domain.FedExRateService Namespace


Distance Members

[image] [image]

.NET Framework Class Library
Distance Members
Distance Class Constructors Methods Properties See Also Send Feedback

The Distance type exposes the following members.

Constructors

Name | Description
Distance |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Units |
UnitsSpecified |
Value |
ValueSpecified |

See Also

Distance Class
InSite.Domain.FedExRateService Namespace


Distance Constructor

[image]

.NET Framework Class Library
Distance Constructor
Distance Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Distance()
Visual C++
public:
Distance()
JavaScript
InSite.Domain.FedExRateService.Distance = function();

See Also

Distance Class
InSite.Domain.FedExRateService Namespace


Distance Methods

[image] [image]

.NET Framework Class Library
Distance Methods
Distance Class See Also Send Feedback

The Distance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Distance Class
InSite.Domain.FedExRateService Namespace


Distance Properties

[image] [image]

.NET Framework Class Library
Distance Properties
Distance Class See Also Send Feedback

The Distance type exposes the following members.

Properties

Name | Description
Units |
UnitsSpecified |
Value |
ValueSpecified |

See Also

Distance Class
InSite.Domain.FedExRateService Namespace


Units Property

[image]

.NET Framework Class Library
Distance..::.Units Property
Distance Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As DistanceUnits
C#
public DistanceUnits Units { get; set; }
Visual C++
public:
property DistanceUnits Units {
    DistanceUnits get ();
    void set (DistanceUnits value);
}
JavaScript
function get_units();
function set_units(value);

Remarks

See Also

Distance Class
InSite.Domain.FedExRateService Namespace


UnitsSpecified Property

[image]

.NET Framework Class Library
Distance..::.UnitsSpecified Property
Distance Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UnitsSpecified As Boolean
C#
public bool UnitsSpecified { get; set; }
Visual C++
public:
property bool UnitsSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_unitsSpecified();
function set_unitsSpecified(value);

Remarks

See Also

Distance Class
InSite.Domain.FedExRateService Namespace


Value Property

[image]

.NET Framework Class Library
Distance..::.Value Property
Distance Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Decimal
C#
public decimal Value { get; set; }
Visual C++
public:
property Decimal Value {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Distance Class
InSite.Domain.FedExRateService Namespace


ValueSpecified Property

[image]

.NET Framework Class Library
Distance..::.ValueSpecified Property
Distance Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueSpecified As Boolean
C#
public bool ValueSpecified { get; set; }
Visual C++
public:
property bool ValueSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_valueSpecified();
function set_valueSpecified(value);

Remarks

See Also

Distance Class
InSite.Domain.FedExRateService Namespace


DistanceUnits Enumeration

[image]

.NET Framework Class Library
DistanceUnits Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DistanceUnits
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DistanceUnits
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DistanceUnits
JavaScript
InSite.Domain.FedExRateService.DistanceUnits = function();
InSite.Domain.FedExRateService.DistanceUnits.createEnum('InSite.Domain.FedExRateService.DistanceUnits', false);

Members

Member name | Description
KM |
MI |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


DocTabContent Class

[image]

.NET Framework Class Library
DocTabContent Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class DocTabContent
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class DocTabContent
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class DocTabContent
JavaScript
InSite.Domain.FedExRateService.DocTabContent = function();

Type.createClass(
    'InSite.Domain.FedExRateService.DocTabContent');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.DocTabContent

See Also

DocTabContent Members
InSite.Domain.FedExRateService Namespace


DocTabContent Members

[image] [image]

.NET Framework Class Library
DocTabContent Members
DocTabContent Class Constructors Methods Properties See Also Send Feedback

The DocTabContent type exposes the following members.

Constructors

Name | Description
DocTabContent |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Barcoded |
DocTabContentType |
DocTabContentTypeSpecified |
Zone001 |

See Also

DocTabContent Class
InSite.Domain.FedExRateService Namespace


DocTabContent Constructor

[image]

.NET Framework Class Library
DocTabContent Constructor
DocTabContent Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DocTabContent()
Visual C++
public:
DocTabContent()
JavaScript
InSite.Domain.FedExRateService.DocTabContent = function();

See Also

DocTabContent Class
InSite.Domain.FedExRateService Namespace


DocTabContent Methods

[image] [image]

.NET Framework Class Library
DocTabContent Methods
DocTabContent Class See Also Send Feedback

The DocTabContent type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocTabContent Class
InSite.Domain.FedExRateService Namespace


DocTabContent Properties

[image] [image]

.NET Framework Class Library
DocTabContent Properties
DocTabContent Class See Also Send Feedback

The DocTabContent type exposes the following members.

Properties

Name | Description
Barcoded |
DocTabContentType |
DocTabContentTypeSpecified |
Zone001 |

See Also

DocTabContent Class
InSite.Domain.FedExRateService Namespace


Barcoded Property

[image]

.NET Framework Class Library
DocTabContent..::.Barcoded Property
DocTabContent Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Barcoded As DocTabContentBarcoded
C#
public DocTabContentBarcoded Barcoded { get; set; }
Visual C++
public:
property DocTabContentBarcoded^ Barcoded {
    DocTabContentBarcoded^ get ();
    void set (DocTabContentBarcoded^ value);
}
JavaScript
function get_barcoded();
function set_barcoded(value);

Remarks

See Also

DocTabContent Class
InSite.Domain.FedExRateService Namespace


DocTabContentType Property

[image]

.NET Framework Class Library
DocTabContent..::.DocTabContentType Property
DocTabContent Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocTabContentType As DocTabContentType
C#
public DocTabContentType DocTabContentType { get; set; }
Visual C++
public:
property DocTabContentType DocTabContentType {
    DocTabContentType get ();
    void set (DocTabContentType value);
}
JavaScript
function get_docTabContentType();
function set_docTabContentType(value);

Remarks

See Also

DocTabContent Class
InSite.Domain.FedExRateService Namespace


DocTabContentTypeSpecified Property

[image]

.NET Framework Class Library
DocTabContent..::.DocTabContentTypeSpecified Property
DocTabContent Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocTabContentTypeSpecified As Boolean
C#
public bool DocTabContentTypeSpecified { get; set; }
Visual C++
public:
property bool DocTabContentTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_docTabContentTypeSpecified();
function set_docTabContentTypeSpecified(value);

Remarks

See Also

DocTabContent Class
InSite.Domain.FedExRateService Namespace


Zone001 Property

[image]

.NET Framework Class Library
DocTabContent..::.Zone001 Property
DocTabContent Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Zone001 As DocTabZoneSpecification()
C#
public DocTabZoneSpecification[] Zone001 { get; set; }
Visual C++
public:
property array<DocTabZoneSpecification^>^ Zone001 {
    array<DocTabZoneSpecification^>^ get ();
    void set (array<DocTabZoneSpecification^>^ value);
}
JavaScript
function get_zone001();
function set_zone001(value);

Remarks

See Also

DocTabContent Class
InSite.Domain.FedExRateService Namespace


DocTabContentBarcoded Class

[image]

.NET Framework Class Library
DocTabContentBarcoded Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class DocTabContentBarcoded
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class DocTabContentBarcoded
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class DocTabContentBarcoded
JavaScript
InSite.Domain.FedExRateService.DocTabContentBarcoded = function();

Type.createClass(
    'InSite.Domain.FedExRateService.DocTabContentBarcoded');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.DocTabContentBarcoded

See Also

DocTabContentBarcoded Members
InSite.Domain.FedExRateService Namespace


DocTabContentBarcoded Members

[image] [image]

.NET Framework Class Library
DocTabContentBarcoded Members
DocTabContentBarcoded Class Constructors Methods Properties See Also Send Feedback

The DocTabContentBarcoded type exposes the following members.

Constructors

Name | Description
DocTabContentBarcoded |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Specification |
Symbology |
SymbologySpecified |

See Also

DocTabContentBarcoded Class
InSite.Domain.FedExRateService Namespace


DocTabContentBarcoded Constructor

[image]

.NET Framework Class Library
DocTabContentBarcoded Constructor
DocTabContentBarcoded Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DocTabContentBarcoded()
Visual C++
public:
DocTabContentBarcoded()
JavaScript
InSite.Domain.FedExRateService.DocTabContentBarcoded = function();

See Also

DocTabContentBarcoded Class
InSite.Domain.FedExRateService Namespace


DocTabContentBarcoded Methods

[image] [image]

.NET Framework Class Library
DocTabContentBarcoded Methods
DocTabContentBarcoded Class See Also Send Feedback

The DocTabContentBarcoded type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocTabContentBarcoded Class
InSite.Domain.FedExRateService Namespace


DocTabContentBarcoded Properties

[image] [image]

.NET Framework Class Library
DocTabContentBarcoded Properties
DocTabContentBarcoded Class See Also Send Feedback

The DocTabContentBarcoded type exposes the following members.

Properties

Name | Description
Specification |
Symbology |
SymbologySpecified |

See Also

DocTabContentBarcoded Class
InSite.Domain.FedExRateService Namespace


Specification Property

[image]

.NET Framework Class Library
DocTabContentBarcoded..::.Specification Property
DocTabContentBarcoded Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Specification As DocTabZoneSpecification
C#
public DocTabZoneSpecification Specification { get; set; }
Visual C++
public:
property DocTabZoneSpecification^ Specification {
    DocTabZoneSpecification^ get ();
    void set (DocTabZoneSpecification^ value);
}
JavaScript
function get_specification();
function set_specification(value);

Remarks

See Also

DocTabContentBarcoded Class
InSite.Domain.FedExRateService Namespace


Symbology Property

[image]

.NET Framework Class Library
DocTabContentBarcoded..::.Symbology Property
DocTabContentBarcoded Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Symbology As BarcodeSymbologyType
C#
public BarcodeSymbologyType Symbology { get; set; }
Visual C++
public:
property BarcodeSymbologyType Symbology {
    BarcodeSymbologyType get ();
    void set (BarcodeSymbologyType value);
}
JavaScript
function get_symbology();
function set_symbology(value);

Remarks

See Also

DocTabContentBarcoded Class
InSite.Domain.FedExRateService Namespace


SymbologySpecified Property

[image]

.NET Framework Class Library
DocTabContentBarcoded..::.SymbologySpecified Property
DocTabContentBarcoded Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SymbologySpecified As Boolean
C#
public bool SymbologySpecified { get; set; }
Visual C++
public:
property bool SymbologySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_symbologySpecified();
function set_symbologySpecified(value);

Remarks

See Also

DocTabContentBarcoded Class
InSite.Domain.FedExRateService Namespace


DocTabContentType Enumeration

[image]

.NET Framework Class Library
DocTabContentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DocTabContentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DocTabContentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DocTabContentType
JavaScript
InSite.Domain.FedExRateService.DocTabContentType = function();
InSite.Domain.FedExRateService.DocTabContentType.createEnum('InSite.Domain.FedExRateService.DocTabContentType', false);

Members

Member name | Description
BARCODED |
MINIMUM |
STANDARD |
ZONE001 |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


DocTabZoneJustificationType Enumeration

[image]

.NET Framework Class Library
DocTabZoneJustificationType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DocTabZoneJustificationType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DocTabZoneJustificationType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DocTabZoneJustificationType
JavaScript
InSite.Domain.FedExRateService.DocTabZoneJustificationType = function();
InSite.Domain.FedExRateService.DocTabZoneJustificationType.createEnum('InSite.Domain.FedExRateService.DocTabZoneJustificationType', false);

Members

Member name | Description
LEFT |
RIGHT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


DocTabZoneSpecification Class

[image]

.NET Framework Class Library
DocTabZoneSpecification Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class DocTabZoneSpecification
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class DocTabZoneSpecification
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class DocTabZoneSpecification
JavaScript
InSite.Domain.FedExRateService.DocTabZoneSpecification = function();

Type.createClass(
    'InSite.Domain.FedExRateService.DocTabZoneSpecification');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.DocTabZoneSpecification

See Also

DocTabZoneSpecification Members
InSite.Domain.FedExRateService Namespace


DocTabZoneSpecification Members

[image] [image]

.NET Framework Class Library
DocTabZoneSpecification Members
DocTabZoneSpecification Class Constructors Methods Properties See Also Send Feedback

The DocTabZoneSpecification type exposes the following members.

Constructors

Name | Description
DocTabZoneSpecification |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataField |
Header |
Justification |
JustificationSpecified |
LiteralValue |
ZoneNumber |

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


DocTabZoneSpecification Constructor

[image]

.NET Framework Class Library
DocTabZoneSpecification Constructor
DocTabZoneSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DocTabZoneSpecification()
Visual C++
public:
DocTabZoneSpecification()
JavaScript
InSite.Domain.FedExRateService.DocTabZoneSpecification = function();

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


DocTabZoneSpecification Methods

[image] [image]

.NET Framework Class Library
DocTabZoneSpecification Methods
DocTabZoneSpecification Class See Also Send Feedback

The DocTabZoneSpecification type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


DocTabZoneSpecification Properties

[image] [image]

.NET Framework Class Library
DocTabZoneSpecification Properties
DocTabZoneSpecification Class See Also Send Feedback

The DocTabZoneSpecification type exposes the following members.

Properties

Name | Description
DataField |
Header |
Justification |
JustificationSpecified |
LiteralValue |
ZoneNumber |

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


DataField Property

[image]

.NET Framework Class Library
DocTabZoneSpecification..::.DataField Property
DocTabZoneSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DataField As String
C#
public string DataField { get; set; }
Visual C++
public:
property String^ DataField {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dataField();
function set_dataField(value);

Remarks

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


Header Property

[image]

.NET Framework Class Library
DocTabZoneSpecification..::.Header Property
DocTabZoneSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Header As String
C#
public string Header { get; set; }
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_header();
function set_header(value);

Remarks

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


Justification Property

[image]

.NET Framework Class Library
DocTabZoneSpecification..::.Justification Property
DocTabZoneSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Justification As DocTabZoneJustificationType
C#
public DocTabZoneJustificationType Justification { get; set; }
Visual C++
public:
property DocTabZoneJustificationType Justification {
    DocTabZoneJustificationType get ();
    void set (DocTabZoneJustificationType value);
}
JavaScript
function get_justification();
function set_justification(value);

Remarks

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


JustificationSpecified Property

[image]

.NET Framework Class Library
DocTabZoneSpecification..::.JustificationSpecified Property
DocTabZoneSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property JustificationSpecified As Boolean
C#
public bool JustificationSpecified { get; set; }
Visual C++
public:
property bool JustificationSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_justificationSpecified();
function set_justificationSpecified(value);

Remarks

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


LiteralValue Property

[image]

.NET Framework Class Library
DocTabZoneSpecification..::.LiteralValue Property
DocTabZoneSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LiteralValue As String
C#
public string LiteralValue { get; set; }
Visual C++
public:
property String^ LiteralValue {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_literalValue();
function set_literalValue(value);

Remarks

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


ZoneNumber Property

[image]

.NET Framework Class Library
DocTabZoneSpecification..::.ZoneNumber Property
DocTabZoneSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ZoneNumber As String
C#
public string ZoneNumber { get; set; }
Visual C++
public:
property String^ ZoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zoneNumber();
function set_zoneNumber(value);

Remarks

See Also

DocTabZoneSpecification Class
InSite.Domain.FedExRateService Namespace


DropoffType Enumeration

[image]

.NET Framework Class Library
DropoffType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration DropoffType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum DropoffType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class DropoffType
JavaScript
InSite.Domain.FedExRateService.DropoffType = function();
InSite.Domain.FedExRateService.DropoffType.createEnum('InSite.Domain.FedExRateService.DropoffType', false);

Members

Member name | Description
BUSINESS_SERVICE_CENTER |
DROP_BOX |
REGULAR_PICKUP |
REQUEST_COURIER |
STATION |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


EdtCommodityTax Class

[image]

.NET Framework Class Library
EdtCommodityTax Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class EdtCommodityTax
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class EdtCommodityTax
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class EdtCommodityTax
JavaScript
InSite.Domain.FedExRateService.EdtCommodityTax = function();

Type.createClass(
    'InSite.Domain.FedExRateService.EdtCommodityTax');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.EdtCommodityTax

See Also

EdtCommodityTax Members
InSite.Domain.FedExRateService Namespace


EdtCommodityTax Members

[image] [image]

.NET Framework Class Library
EdtCommodityTax Members
EdtCommodityTax Class Constructors Methods Properties See Also Send Feedback

The EdtCommodityTax type exposes the following members.

Constructors

Name | Description
EdtCommodityTax |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HarmonizedCode |
Taxes |

See Also

EdtCommodityTax Class
InSite.Domain.FedExRateService Namespace


EdtCommodityTax Constructor

[image]

.NET Framework Class Library
EdtCommodityTax Constructor
EdtCommodityTax Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EdtCommodityTax()
Visual C++
public:
EdtCommodityTax()
JavaScript
InSite.Domain.FedExRateService.EdtCommodityTax = function();

See Also

EdtCommodityTax Class
InSite.Domain.FedExRateService Namespace


EdtCommodityTax Methods

[image] [image]

.NET Framework Class Library
EdtCommodityTax Methods
EdtCommodityTax Class See Also Send Feedback

The EdtCommodityTax type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdtCommodityTax Class
InSite.Domain.FedExRateService Namespace


EdtCommodityTax Properties

[image] [image]

.NET Framework Class Library
EdtCommodityTax Properties
EdtCommodityTax Class See Also Send Feedback

The EdtCommodityTax type exposes the following members.

Properties

Name | Description
HarmonizedCode |
Taxes |

See Also

EdtCommodityTax Class
InSite.Domain.FedExRateService Namespace


HarmonizedCode Property

[image]

.NET Framework Class Library
EdtCommodityTax..::.HarmonizedCode Property
EdtCommodityTax Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HarmonizedCode As String
C#
public string HarmonizedCode { get; set; }
Visual C++
public:
property String^ HarmonizedCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_harmonizedCode();
function set_harmonizedCode(value);

Remarks

See Also

EdtCommodityTax Class
InSite.Domain.FedExRateService Namespace


Taxes Property

[image]

.NET Framework Class Library
EdtCommodityTax..::.Taxes Property
EdtCommodityTax Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Taxes As EdtTaxDetail()
C#
public EdtTaxDetail[] Taxes { get; set; }
Visual C++
public:
property array<EdtTaxDetail^>^ Taxes {
    array<EdtTaxDetail^>^ get ();
    void set (array<EdtTaxDetail^>^ value);
}
JavaScript
function get_taxes();
function set_taxes(value);

Remarks

See Also

EdtCommodityTax Class
InSite.Domain.FedExRateService Namespace


EdtExciseCondition Class

[image]

.NET Framework Class Library
EdtExciseCondition Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class EdtExciseCondition
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class EdtExciseCondition
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class EdtExciseCondition
JavaScript
InSite.Domain.FedExRateService.EdtExciseCondition = function();

Type.createClass(
    'InSite.Domain.FedExRateService.EdtExciseCondition');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.EdtExciseCondition

See Also

EdtExciseCondition Members
InSite.Domain.FedExRateService Namespace


EdtExciseCondition Members

[image] [image]

.NET Framework Class Library
EdtExciseCondition Members
EdtExciseCondition Class Constructors Methods Properties See Also Send Feedback

The EdtExciseCondition type exposes the following members.

Constructors

Name | Description
EdtExciseCondition |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Category |
Value |

See Also

EdtExciseCondition Class
InSite.Domain.FedExRateService Namespace


EdtExciseCondition Constructor

[image]

.NET Framework Class Library
EdtExciseCondition Constructor
EdtExciseCondition Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EdtExciseCondition()
Visual C++
public:
EdtExciseCondition()
JavaScript
InSite.Domain.FedExRateService.EdtExciseCondition = function();

See Also

EdtExciseCondition Class
InSite.Domain.FedExRateService Namespace


EdtExciseCondition Methods

[image] [image]

.NET Framework Class Library
EdtExciseCondition Methods
EdtExciseCondition Class See Also Send Feedback

The EdtExciseCondition type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdtExciseCondition Class
InSite.Domain.FedExRateService Namespace


EdtExciseCondition Properties

[image] [image]

.NET Framework Class Library
EdtExciseCondition Properties
EdtExciseCondition Class See Also Send Feedback

The EdtExciseCondition type exposes the following members.

Properties

Name | Description
Category |
Value |

See Also

EdtExciseCondition Class
InSite.Domain.FedExRateService Namespace


Category Property

[image]

.NET Framework Class Library
EdtExciseCondition..::.Category Property
EdtExciseCondition Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Category As String
C#
public string Category { get; set; }
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_category();
function set_category(value);

Remarks

See Also

EdtExciseCondition Class
InSite.Domain.FedExRateService Namespace


Value Property

[image]

.NET Framework Class Library
EdtExciseCondition..::.Value Property
EdtExciseCondition Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

EdtExciseCondition Class
InSite.Domain.FedExRateService Namespace


EdtRequestType Enumeration

[image]

.NET Framework Class Library
EdtRequestType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration EdtRequestType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum EdtRequestType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class EdtRequestType
JavaScript
InSite.Domain.FedExRateService.EdtRequestType = function();
InSite.Domain.FedExRateService.EdtRequestType.createEnum('InSite.Domain.FedExRateService.EdtRequestType', false);

Members

Member name | Description
ALL |
NONE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


EdtTaxDetail Class

[image]

.NET Framework Class Library
EdtTaxDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class EdtTaxDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class EdtTaxDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class EdtTaxDetail
JavaScript
InSite.Domain.FedExRateService.EdtTaxDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.EdtTaxDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.EdtTaxDetail

See Also

EdtTaxDetail Members
InSite.Domain.FedExRateService Namespace


EdtTaxDetail Members

[image] [image]

.NET Framework Class Library
EdtTaxDetail Members
EdtTaxDetail Class Constructors Methods Properties See Also Send Feedback

The EdtTaxDetail type exposes the following members.

Constructors

Name | Description
EdtTaxDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Description |
EffectiveDate |
EffectiveDateSpecified |
Formula |
Name |
TaxableValue |
TaxType |
TaxTypeSpecified |

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


EdtTaxDetail Constructor

[image]

.NET Framework Class Library
EdtTaxDetail Constructor
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EdtTaxDetail()
Visual C++
public:
EdtTaxDetail()
JavaScript
InSite.Domain.FedExRateService.EdtTaxDetail = function();

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


EdtTaxDetail Methods

[image] [image]

.NET Framework Class Library
EdtTaxDetail Methods
EdtTaxDetail Class See Also Send Feedback

The EdtTaxDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


EdtTaxDetail Properties

[image] [image]

.NET Framework Class Library
EdtTaxDetail Properties
EdtTaxDetail Class See Also Send Feedback

The EdtTaxDetail type exposes the following members.

Properties

Name | Description
Amount |
Description |
EffectiveDate |
EffectiveDateSpecified |
Formula |
Name |
TaxableValue |
TaxType |
TaxTypeSpecified |

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


Amount Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.Amount Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As Money
C#
public Money Amount { get; set; }
Visual C++
public:
property Money^ Amount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.Description Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


EffectiveDate Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.EffectiveDate Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EffectiveDate As DateTime
C#
public DateTime EffectiveDate { get; set; }
Visual C++
public:
property DateTime EffectiveDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_effectiveDate();
function set_effectiveDate(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


EffectiveDateSpecified Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.EffectiveDateSpecified Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EffectiveDateSpecified As Boolean
C#
public bool EffectiveDateSpecified { get; set; }
Visual C++
public:
property bool EffectiveDateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_effectiveDateSpecified();
function set_effectiveDateSpecified(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


Formula Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.Formula Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Formula As String
C#
public string Formula { get; set; }
Visual C++
public:
property String^ Formula {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_formula();
function set_formula(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


Name Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.Name Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


TaxableValue Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.TaxableValue Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TaxableValue As Money
C#
public Money TaxableValue { get; set; }
Visual C++
public:
property Money^ TaxableValue {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_taxableValue();
function set_taxableValue(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


TaxType Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.TaxType Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TaxType As EdtTaxType
C#
public EdtTaxType TaxType { get; set; }
Visual C++
public:
property EdtTaxType TaxType {
    EdtTaxType get ();
    void set (EdtTaxType value);
}
JavaScript
function get_taxType();
function set_taxType(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


TaxTypeSpecified Property

[image]

.NET Framework Class Library
EdtTaxDetail..::.TaxTypeSpecified Property
EdtTaxDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TaxTypeSpecified As Boolean
C#
public bool TaxTypeSpecified { get; set; }
Visual C++
public:
property bool TaxTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxTypeSpecified();
function set_taxTypeSpecified(value);

Remarks

See Also

EdtTaxDetail Class
InSite.Domain.FedExRateService Namespace


EdtTaxType Enumeration

[image]

.NET Framework Class Library
EdtTaxType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration EdtTaxType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum EdtTaxType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class EdtTaxType
JavaScript
InSite.Domain.FedExRateService.EdtTaxType = function();
InSite.Domain.FedExRateService.EdtTaxType.createEnum('InSite.Domain.FedExRateService.EdtTaxType', false);

Members

Member name | Description
ADDITIONAL_TAXES |
CONSULAR_INVOICE_FEE |
CUSTOMS_SURCHARGES |
DUTY |
EXCISE_TAX |
FOREIGN_EXCHANGE_TAX |
GENERAL_SALES_TAX |
IMPORT_LICENSE_FEE |
INTERNAL_ADDITIONAL_TAXES |
INTERNAL_SENSITIVE_PRODUCTS_TAX |
OTHER |
SENSITIVE_PRODUCTS_TAX |
STAMP_TAX |
STATISTICAL_TAX |
TRANSPORT_FACILITIES_TAX |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


EMailLabelDetail Class

[image]

.NET Framework Class Library
EMailLabelDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class EMailLabelDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class EMailLabelDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class EMailLabelDetail
JavaScript
InSite.Domain.FedExRateService.EMailLabelDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.EMailLabelDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.EMailLabelDetail

See Also

EMailLabelDetail Members
InSite.Domain.FedExRateService Namespace


EMailLabelDetail Members

[image] [image]

.NET Framework Class Library
EMailLabelDetail Members
EMailLabelDetail Class Constructors Methods Properties See Also Send Feedback

The EMailLabelDetail type exposes the following members.

Constructors

Name | Description
EMailLabelDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NotificationEMailAddress |
NotificationMessage |

See Also

EMailLabelDetail Class
InSite.Domain.FedExRateService Namespace


EMailLabelDetail Constructor

[image]

.NET Framework Class Library
EMailLabelDetail Constructor
EMailLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EMailLabelDetail()
Visual C++
public:
EMailLabelDetail()
JavaScript
InSite.Domain.FedExRateService.EMailLabelDetail = function();

See Also

EMailLabelDetail Class
InSite.Domain.FedExRateService Namespace


EMailLabelDetail Methods

[image] [image]

.NET Framework Class Library
EMailLabelDetail Methods
EMailLabelDetail Class See Also Send Feedback

The EMailLabelDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EMailLabelDetail Class
InSite.Domain.FedExRateService Namespace


EMailLabelDetail Properties

[image] [image]

.NET Framework Class Library
EMailLabelDetail Properties
EMailLabelDetail Class See Also Send Feedback

The EMailLabelDetail type exposes the following members.

Properties

Name | Description
NotificationEMailAddress |
NotificationMessage |

See Also

EMailLabelDetail Class
InSite.Domain.FedExRateService Namespace


NotificationEMailAddress Property

[image]

.NET Framework Class Library
EMailLabelDetail..::.NotificationEMailAddress Property
EMailLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NotificationEMailAddress As String
C#
public string NotificationEMailAddress { get; set; }
Visual C++
public:
property String^ NotificationEMailAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_notificationEMailAddress();
function set_notificationEMailAddress(value);

Remarks

See Also

EMailLabelDetail Class
InSite.Domain.FedExRateService Namespace


NotificationMessage Property

[image]

.NET Framework Class Library
EMailLabelDetail..::.NotificationMessage Property
EMailLabelDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NotificationMessage As String
C#
public string NotificationMessage { get; set; }
Visual C++
public:
property String^ NotificationMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_notificationMessage();
function set_notificationMessage(value);

Remarks

See Also

EMailLabelDetail Class
InSite.Domain.FedExRateService Namespace


EMailNotificationDetail Class

[image]

.NET Framework Class Library
EMailNotificationDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class EMailNotificationDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class EMailNotificationDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class EMailNotificationDetail
JavaScript
InSite.Domain.FedExRateService.EMailNotificationDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.EMailNotificationDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.EMailNotificationDetail

See Also

EMailNotificationDetail Members
InSite.Domain.FedExRateService Namespace


EMailNotificationDetail Members

[image] [image]

.NET Framework Class Library
EMailNotificationDetail Members
EMailNotificationDetail Class Constructors Methods Properties See Also Send Feedback

The EMailNotificationDetail type exposes the following members.

Constructors

Name | Description
EMailNotificationDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PersonalMessage |
Recipients |

See Also

EMailNotificationDetail Class
InSite.Domain.FedExRateService Namespace


EMailNotificationDetail Constructor

[image]

.NET Framework Class Library
EMailNotificationDetail Constructor
EMailNotificationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EMailNotificationDetail()
Visual C++
public:
EMailNotificationDetail()
JavaScript
InSite.Domain.FedExRateService.EMailNotificationDetail = function();

See Also

EMailNotificationDetail Class
InSite.Domain.FedExRateService Namespace


EMailNotificationDetail Methods

[image] [image]

.NET Framework Class Library
EMailNotificationDetail Methods
EMailNotificationDetail Class See Also Send Feedback

The EMailNotificationDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EMailNotificationDetail Class
InSite.Domain.FedExRateService Namespace


EMailNotificationDetail Properties

[image] [image]

.NET Framework Class Library
EMailNotificationDetail Properties
EMailNotificationDetail Class See Also Send Feedback

The EMailNotificationDetail type exposes the following members.

Properties

Name | Description
PersonalMessage |
Recipients |

See Also

EMailNotificationDetail Class
InSite.Domain.FedExRateService Namespace


PersonalMessage Property

[image]

.NET Framework Class Library
EMailNotificationDetail..::.PersonalMessage Property
EMailNotificationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PersonalMessage As String
C#
public string PersonalMessage { get; set; }
Visual C++
public:
property String^ PersonalMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_personalMessage();
function set_personalMessage(value);

Remarks

See Also

EMailNotificationDetail Class
InSite.Domain.FedExRateService Namespace


Recipients Property

[image]

.NET Framework Class Library
EMailNotificationDetail..::.Recipients Property
EMailNotificationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Recipients As EMailNotificationRecipient()
C#
public EMailNotificationRecipient[] Recipients { get; set; }
Visual C++
public:
property array<EMailNotificationRecipient^>^ Recipients {
    array<EMailNotificationRecipient^>^ get ();
    void set (array<EMailNotificationRecipient^>^ value);
}
JavaScript
function get_recipients();
function set_recipients(value);

Remarks

See Also

EMailNotificationDetail Class
InSite.Domain.FedExRateService Namespace


EMailNotificationFormatType Enumeration

[image]

.NET Framework Class Library
EMailNotificationFormatType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration EMailNotificationFormatType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum EMailNotificationFormatType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class EMailNotificationFormatType
JavaScript
InSite.Domain.FedExRateService.EMailNotificationFormatType = function();
InSite.Domain.FedExRateService.EMailNotificationFormatType.createEnum('InSite.Domain.FedExRateService.EMailNotificationFormatType', false);

Members

Member name | Description
HTML |
TEXT |
WIRELESS |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


EMailNotificationRecipient Class

[image]

.NET Framework Class Library
EMailNotificationRecipient Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class EMailNotificationRecipient
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class EMailNotificationRecipient
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class EMailNotificationRecipient
JavaScript
InSite.Domain.FedExRateService.EMailNotificationRecipient = function();

Type.createClass(
    'InSite.Domain.FedExRateService.EMailNotificationRecipient');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.EMailNotificationRecipient

See Also

EMailNotificationRecipient Members
InSite.Domain.FedExRateService Namespace


EMailNotificationRecipient Members

[image] [image]

.NET Framework Class Library
EMailNotificationRecipient Members
EMailNotificationRecipient Class Constructors Methods Properties See Also Send Feedback

The EMailNotificationRecipient type exposes the following members.

Constructors

Name | Description
EMailNotificationRecipient |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EMailAddress |
EMailNotificationRecipientType |
Format |
FormatSpecified |
Localization |
NotifyOnDelivery |
NotifyOnDeliverySpecified |
NotifyOnException |
NotifyOnExceptionSpecified |
NotifyOnShipment |
NotifyOnShipmentSpecified |

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


EMailNotificationRecipient Constructor

[image]

.NET Framework Class Library
EMailNotificationRecipient Constructor
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EMailNotificationRecipient()
Visual C++
public:
EMailNotificationRecipient()
JavaScript
InSite.Domain.FedExRateService.EMailNotificationRecipient = function();

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


EMailNotificationRecipient Methods

[image] [image]

.NET Framework Class Library
EMailNotificationRecipient Methods
EMailNotificationRecipient Class See Also Send Feedback

The EMailNotificationRecipient type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


EMailNotificationRecipient Properties

[image] [image]

.NET Framework Class Library
EMailNotificationRecipient Properties
EMailNotificationRecipient Class See Also Send Feedback

The EMailNotificationRecipient type exposes the following members.

Properties

Name | Description
EMailAddress |
EMailNotificationRecipientType |
Format |
FormatSpecified |
Localization |
NotifyOnDelivery |
NotifyOnDeliverySpecified |
NotifyOnException |
NotifyOnExceptionSpecified |
NotifyOnShipment |
NotifyOnShipmentSpecified |

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


EMailAddress Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.EMailAddress Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EMailAddress As String
C#
public string EMailAddress { get; set; }
Visual C++
public:
property String^ EMailAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_eMailAddress();
function set_eMailAddress(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


EMailNotificationRecipientType Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.EMailNotificationRecipientType Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EMailNotificationRecipientType As EMailNotificationRecipientType
C#
public EMailNotificationRecipientType EMailNotificationRecipientType { get; set; }
Visual C++
public:
property EMailNotificationRecipientType EMailNotificationRecipientType {
    EMailNotificationRecipientType get ();
    void set (EMailNotificationRecipientType value);
}
JavaScript
function get_eMailNotificationRecipientType();
function set_eMailNotificationRecipientType(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


Format Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.Format Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As EMailNotificationFormatType
C#
public EMailNotificationFormatType Format { get; set; }
Visual C++
public:
property EMailNotificationFormatType Format {
    EMailNotificationFormatType get ();
    void set (EMailNotificationFormatType value);
}
JavaScript
function get_format();
function set_format(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


FormatSpecified Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.FormatSpecified Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FormatSpecified As Boolean
C#
public bool FormatSpecified { get; set; }
Visual C++
public:
property bool FormatSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_formatSpecified();
function set_formatSpecified(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


Localization Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.Localization Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Localization As Localization
C#
public Localization Localization { get; set; }
Visual C++
public:
property Localization^ Localization {
    Localization^ get ();
    void set (Localization^ value);
}
JavaScript
function get_localization();
function set_localization(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


NotifyOnDelivery Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.NotifyOnDelivery Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NotifyOnDelivery As Boolean
C#
public bool NotifyOnDelivery { get; set; }
Visual C++
public:
property bool NotifyOnDelivery {
    bool get ();
    void set (bool value);
}
JavaScript
function get_notifyOnDelivery();
function set_notifyOnDelivery(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


NotifyOnDeliverySpecified Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.NotifyOnDeliverySpecified Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NotifyOnDeliverySpecified As Boolean
C#
public bool NotifyOnDeliverySpecified { get; set; }
Visual C++
public:
property bool NotifyOnDeliverySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_notifyOnDeliverySpecified();
function set_notifyOnDeliverySpecified(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


NotifyOnException Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.NotifyOnException Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NotifyOnException As Boolean
C#
public bool NotifyOnException { get; set; }
Visual C++
public:
property bool NotifyOnException {
    bool get ();
    void set (bool value);
}
JavaScript
function get_notifyOnException();
function set_notifyOnException(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


NotifyOnExceptionSpecified Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.NotifyOnExceptionSpecified Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NotifyOnExceptionSpecified As Boolean
C#
public bool NotifyOnExceptionSpecified { get; set; }
Visual C++
public:
property bool NotifyOnExceptionSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_notifyOnExceptionSpecified();
function set_notifyOnExceptionSpecified(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


NotifyOnShipment Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.NotifyOnShipment Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NotifyOnShipment As Boolean
C#
public bool NotifyOnShipment { get; set; }
Visual C++
public:
property bool NotifyOnShipment {
    bool get ();
    void set (bool value);
}
JavaScript
function get_notifyOnShipment();
function set_notifyOnShipment(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


NotifyOnShipmentSpecified Property

[image]

.NET Framework Class Library
EMailNotificationRecipient..::.NotifyOnShipmentSpecified Property
EMailNotificationRecipient Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NotifyOnShipmentSpecified As Boolean
C#
public bool NotifyOnShipmentSpecified { get; set; }
Visual C++
public:
property bool NotifyOnShipmentSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_notifyOnShipmentSpecified();
function set_notifyOnShipmentSpecified(value);

Remarks

See Also

EMailNotificationRecipient Class
InSite.Domain.FedExRateService Namespace


EMailNotificationRecipientType Enumeration

[image]

.NET Framework Class Library
EMailNotificationRecipientType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration EMailNotificationRecipientType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum EMailNotificationRecipientType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class EMailNotificationRecipientType
JavaScript
InSite.Domain.FedExRateService.EMailNotificationRecipientType = function();
InSite.Domain.FedExRateService.EMailNotificationRecipientType.createEnum('InSite.Domain.FedExRateService.EMailNotificationRecipientType', false);

Members

Member name | Description
BROKER |
OTHER |
RECIPIENT |
SHIPPER |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


EtdDetail Class

[image]

.NET Framework Class Library
EtdDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class EtdDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class EtdDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class EtdDetail
JavaScript
InSite.Domain.FedExRateService.EtdDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.EtdDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.EtdDetail

See Also

EtdDetail Members
InSite.Domain.FedExRateService Namespace


EtdDetail Members

[image] [image]

.NET Framework Class Library
EtdDetail Members
EtdDetail Class Constructors Methods Properties See Also Send Feedback

The EtdDetail type exposes the following members.

Constructors

Name | Description
EtdDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DocumentReferences |
Documents |
RequestedDocumentCopies |

See Also

EtdDetail Class
InSite.Domain.FedExRateService Namespace


EtdDetail Constructor

[image]

.NET Framework Class Library
EtdDetail Constructor
EtdDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EtdDetail()
Visual C++
public:
EtdDetail()
JavaScript
InSite.Domain.FedExRateService.EtdDetail = function();

See Also

EtdDetail Class
InSite.Domain.FedExRateService Namespace


EtdDetail Methods

[image] [image]

.NET Framework Class Library
EtdDetail Methods
EtdDetail Class See Also Send Feedback

The EtdDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EtdDetail Class
InSite.Domain.FedExRateService Namespace


EtdDetail Properties

[image] [image]

.NET Framework Class Library
EtdDetail Properties
EtdDetail Class See Also Send Feedback

The EtdDetail type exposes the following members.

Properties

Name | Description
DocumentReferences |
Documents |
RequestedDocumentCopies |

See Also

EtdDetail Class
InSite.Domain.FedExRateService Namespace


DocumentReferences Property

[image]

.NET Framework Class Library
EtdDetail..::.DocumentReferences Property
EtdDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentReferences As UploadDocumentReferenceDetail()
C#
public UploadDocumentReferenceDetail[] DocumentReferences { get; set; }
Visual C++
public:
property array<UploadDocumentReferenceDetail^>^ DocumentReferences {
    array<UploadDocumentReferenceDetail^>^ get ();
    void set (array<UploadDocumentReferenceDetail^>^ value);
}
JavaScript
function get_documentReferences();
function set_documentReferences(value);

Remarks

See Also

EtdDetail Class
InSite.Domain.FedExRateService Namespace


Documents Property

[image]

.NET Framework Class Library
EtdDetail..::.Documents Property
EtdDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Documents As UploadDocumentDetail()
C#
public UploadDocumentDetail[] Documents { get; set; }
Visual C++
public:
property array<UploadDocumentDetail^>^ Documents {
    array<UploadDocumentDetail^>^ get ();
    void set (array<UploadDocumentDetail^>^ value);
}
JavaScript
function get_documents();
function set_documents(value);

Remarks

See Also

EtdDetail Class
InSite.Domain.FedExRateService Namespace


RequestedDocumentCopies Property

[image]

.NET Framework Class Library
EtdDetail..::.RequestedDocumentCopies Property
EtdDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RequestedDocumentCopies As RequestedShippingDocumentType()
C#
public RequestedShippingDocumentType[] RequestedDocumentCopies { get; set; }
Visual C++
public:
property array<RequestedShippingDocumentType>^ RequestedDocumentCopies {
    array<RequestedShippingDocumentType>^ get ();
    void set (array<RequestedShippingDocumentType>^ value);
}
JavaScript
function get_requestedDocumentCopies();
function set_requestedDocumentCopies(value);

Remarks

See Also

EtdDetail Class
InSite.Domain.FedExRateService Namespace


ExportDetail Class

[image]

.NET Framework Class Library
ExportDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ExportDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ExportDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ExportDetail
JavaScript
InSite.Domain.FedExRateService.ExportDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ExportDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ExportDetail

See Also

ExportDetail Members
InSite.Domain.FedExRateService Namespace


ExportDetail Members

[image] [image]

.NET Framework Class Library
ExportDetail Members
ExportDetail Class Constructors Methods Properties See Also Send Feedback

The ExportDetail type exposes the following members.

Constructors

Name | Description
ExportDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
B13AFilingOption |
B13AFilingOptionSpecified |
DestinationControlDetail |
ExportComplianceStatement |
PermitNumber |

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


ExportDetail Constructor

[image]

.NET Framework Class Library
ExportDetail Constructor
ExportDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExportDetail()
Visual C++
public:
ExportDetail()
JavaScript
InSite.Domain.FedExRateService.ExportDetail = function();

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


ExportDetail Methods

[image] [image]

.NET Framework Class Library
ExportDetail Methods
ExportDetail Class See Also Send Feedback

The ExportDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


ExportDetail Properties

[image] [image]

.NET Framework Class Library
ExportDetail Properties
ExportDetail Class See Also Send Feedback

The ExportDetail type exposes the following members.

Properties

Name | Description
B13AFilingOption |
B13AFilingOptionSpecified |
DestinationControlDetail |
ExportComplianceStatement |
PermitNumber |

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


B13AFilingOption Property

[image]

.NET Framework Class Library
ExportDetail..::.B13AFilingOption Property
ExportDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property B13AFilingOption As B13AFilingOptionType
C#
public B13AFilingOptionType B13AFilingOption { get; set; }
Visual C++
public:
property B13AFilingOptionType B13AFilingOption {
    B13AFilingOptionType get ();
    void set (B13AFilingOptionType value);
}
JavaScript
function get_b13AFilingOption();
function set_b13AFilingOption(value);

Remarks

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


B13AFilingOptionSpecified Property

[image]

.NET Framework Class Library
ExportDetail..::.B13AFilingOptionSpecified Property
ExportDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property B13AFilingOptionSpecified As Boolean
C#
public bool B13AFilingOptionSpecified { get; set; }
Visual C++
public:
property bool B13AFilingOptionSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_b13AFilingOptionSpecified();
function set_b13AFilingOptionSpecified(value);

Remarks

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


DestinationControlDetail Property

[image]

.NET Framework Class Library
ExportDetail..::.DestinationControlDetail Property
ExportDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationControlDetail As DestinationControlDetail
C#
public DestinationControlDetail DestinationControlDetail { get; set; }
Visual C++
public:
property DestinationControlDetail^ DestinationControlDetail {
    DestinationControlDetail^ get ();
    void set (DestinationControlDetail^ value);
}
JavaScript
function get_destinationControlDetail();
function set_destinationControlDetail(value);

Remarks

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


ExportComplianceStatement Property

[image]

.NET Framework Class Library
ExportDetail..::.ExportComplianceStatement Property
ExportDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportComplianceStatement As String
C#
public string ExportComplianceStatement { get; set; }
Visual C++
public:
property String^ ExportComplianceStatement {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_exportComplianceStatement();
function set_exportComplianceStatement(value);

Remarks

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


PermitNumber Property

[image]

.NET Framework Class Library
ExportDetail..::.PermitNumber Property
ExportDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PermitNumber As String
C#
public string PermitNumber { get; set; }
Visual C++
public:
property String^ PermitNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_permitNumber();
function set_permitNumber(value);

Remarks

See Also

ExportDetail Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetail Class

[image]

.NET Framework Class Library
ExpressFreightDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ExpressFreightDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ExpressFreightDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ExpressFreightDetail
JavaScript
InSite.Domain.FedExRateService.ExpressFreightDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ExpressFreightDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ExpressFreightDetail

See Also

ExpressFreightDetail Members
InSite.Domain.FedExRateService Namespace


ExpressFreightDetail Members

[image] [image]

.NET Framework Class Library
ExpressFreightDetail Members
ExpressFreightDetail Class Constructors Methods Properties See Also Send Feedback

The ExpressFreightDetail type exposes the following members.

Constructors

Name | Description
ExpressFreightDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BeforeDeliveryContact |
BookingConfirmationNumber |
PackingListEnclosed |
PackingListEnclosedSpecified |
ReferenceLabelRequested |
ReferenceLabelRequestedSpecified |
ShippersLoadAndCount |
UndeliverableContact |

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetail Constructor

[image]

.NET Framework Class Library
ExpressFreightDetail Constructor
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExpressFreightDetail()
Visual C++
public:
ExpressFreightDetail()
JavaScript
InSite.Domain.FedExRateService.ExpressFreightDetail = function();

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetail Methods

[image] [image]

.NET Framework Class Library
ExpressFreightDetail Methods
ExpressFreightDetail Class See Also Send Feedback

The ExpressFreightDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetail Properties

[image] [image]

.NET Framework Class Library
ExpressFreightDetail Properties
ExpressFreightDetail Class See Also Send Feedback

The ExpressFreightDetail type exposes the following members.

Properties

Name | Description
BeforeDeliveryContact |
BookingConfirmationNumber |
PackingListEnclosed |
PackingListEnclosedSpecified |
ReferenceLabelRequested |
ReferenceLabelRequestedSpecified |
ShippersLoadAndCount |
UndeliverableContact |

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


BeforeDeliveryContact Property

[image]

.NET Framework Class Library
ExpressFreightDetail..::.BeforeDeliveryContact Property
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BeforeDeliveryContact As ExpressFreightDetailContact
C#
public ExpressFreightDetailContact BeforeDeliveryContact { get; set; }
Visual C++
public:
property ExpressFreightDetailContact^ BeforeDeliveryContact {
    ExpressFreightDetailContact^ get ();
    void set (ExpressFreightDetailContact^ value);
}
JavaScript
function get_beforeDeliveryContact();
function set_beforeDeliveryContact(value);

Remarks

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


BookingConfirmationNumber Property

[image]

.NET Framework Class Library
ExpressFreightDetail..::.BookingConfirmationNumber Property
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BookingConfirmationNumber As String
C#
public string BookingConfirmationNumber { get; set; }
Visual C++
public:
property String^ BookingConfirmationNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bookingConfirmationNumber();
function set_bookingConfirmationNumber(value);

Remarks

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


PackingListEnclosed Property

[image]

.NET Framework Class Library
ExpressFreightDetail..::.PackingListEnclosed Property
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackingListEnclosed As Boolean
C#
public bool PackingListEnclosed { get; set; }
Visual C++
public:
property bool PackingListEnclosed {
    bool get ();
    void set (bool value);
}
JavaScript
function get_packingListEnclosed();
function set_packingListEnclosed(value);

Remarks

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


PackingListEnclosedSpecified Property

[image]

.NET Framework Class Library
ExpressFreightDetail..::.PackingListEnclosedSpecified Property
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackingListEnclosedSpecified As Boolean
C#
public bool PackingListEnclosedSpecified { get; set; }
Visual C++
public:
property bool PackingListEnclosedSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_packingListEnclosedSpecified();
function set_packingListEnclosedSpecified(value);

Remarks

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


ReferenceLabelRequested Property

[image]

.NET Framework Class Library
ExpressFreightDetail..::.ReferenceLabelRequested Property
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferenceLabelRequested As Boolean
C#
public bool ReferenceLabelRequested { get; set; }
Visual C++
public:
property bool ReferenceLabelRequested {
    bool get ();
    void set (bool value);
}
JavaScript
function get_referenceLabelRequested();
function set_referenceLabelRequested(value);

Remarks

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


ReferenceLabelRequestedSpecified Property

[image]

.NET Framework Class Library
ExpressFreightDetail..::.ReferenceLabelRequestedSpecified Property
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReferenceLabelRequestedSpecified As Boolean
C#
public bool ReferenceLabelRequestedSpecified { get; set; }
Visual C++
public:
property bool ReferenceLabelRequestedSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_referenceLabelRequestedSpecified();
function set_referenceLabelRequestedSpecified(value);

Remarks

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


ShippersLoadAndCount Property

[image]

.NET Framework Class Library
ExpressFreightDetail..::.ShippersLoadAndCount Property
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShippersLoadAndCount As String
C#
public string ShippersLoadAndCount { get; set; }
Visual C++
public:
property String^ ShippersLoadAndCount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shippersLoadAndCount();
function set_shippersLoadAndCount(value);

Remarks

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


UndeliverableContact Property

[image]

.NET Framework Class Library
ExpressFreightDetail..::.UndeliverableContact Property
ExpressFreightDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UndeliverableContact As ExpressFreightDetailContact
C#
public ExpressFreightDetailContact UndeliverableContact { get; set; }
Visual C++
public:
property ExpressFreightDetailContact^ UndeliverableContact {
    ExpressFreightDetailContact^ get ();
    void set (ExpressFreightDetailContact^ value);
}
JavaScript
function get_undeliverableContact();
function set_undeliverableContact(value);

Remarks

See Also

ExpressFreightDetail Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetailContact Class

[image]

.NET Framework Class Library
ExpressFreightDetailContact Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ExpressFreightDetailContact
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ExpressFreightDetailContact
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ExpressFreightDetailContact
JavaScript
InSite.Domain.FedExRateService.ExpressFreightDetailContact = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ExpressFreightDetailContact');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ExpressFreightDetailContact

See Also

ExpressFreightDetailContact Members
InSite.Domain.FedExRateService Namespace


ExpressFreightDetailContact Members

[image] [image]

.NET Framework Class Library
ExpressFreightDetailContact Members
ExpressFreightDetailContact Class Constructors Methods Properties See Also Send Feedback

The ExpressFreightDetailContact type exposes the following members.

Constructors

Name | Description
ExpressFreightDetailContact |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
Phone |

See Also

ExpressFreightDetailContact Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetailContact Constructor

[image]

.NET Framework Class Library
ExpressFreightDetailContact Constructor
ExpressFreightDetailContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ExpressFreightDetailContact()
Visual C++
public:
ExpressFreightDetailContact()
JavaScript
InSite.Domain.FedExRateService.ExpressFreightDetailContact = function();

See Also

ExpressFreightDetailContact Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetailContact Methods

[image] [image]

.NET Framework Class Library
ExpressFreightDetailContact Methods
ExpressFreightDetailContact Class See Also Send Feedback

The ExpressFreightDetailContact type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpressFreightDetailContact Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetailContact Properties

[image] [image]

.NET Framework Class Library
ExpressFreightDetailContact Properties
ExpressFreightDetailContact Class See Also Send Feedback

The ExpressFreightDetailContact type exposes the following members.

Properties

Name | Description
Name |
Phone |

See Also

ExpressFreightDetailContact Class
InSite.Domain.FedExRateService Namespace


Name Property

[image]

.NET Framework Class Library
ExpressFreightDetailContact..::.Name Property
ExpressFreightDetailContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Remarks

See Also

ExpressFreightDetailContact Class
InSite.Domain.FedExRateService Namespace


Phone Property

[image]

.NET Framework Class Library
ExpressFreightDetailContact..::.Phone Property
ExpressFreightDetailContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Phone As String
C#
public string Phone { get; set; }
Visual C++
public:
property String^ Phone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone();
function set_phone(value);

Remarks

See Also

ExpressFreightDetailContact Class
InSite.Domain.FedExRateService Namespace


ExpressRegionCode Enumeration

[image]

.NET Framework Class Library
ExpressRegionCode Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ExpressRegionCode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ExpressRegionCode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ExpressRegionCode
JavaScript
InSite.Domain.FedExRateService.ExpressRegionCode = function();
InSite.Domain.FedExRateService.ExpressRegionCode.createEnum('InSite.Domain.FedExRateService.ExpressRegionCode', false);

Members

Member name | Description
APAC |
CA |
EMEA |
LAC |
US |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


FlatbedTrailerOption Enumeration

[image]

.NET Framework Class Library
FlatbedTrailerOption Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration FlatbedTrailerOption
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum FlatbedTrailerOption
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class FlatbedTrailerOption
JavaScript
InSite.Domain.FedExRateService.FlatbedTrailerOption = function();
InSite.Domain.FedExRateService.FlatbedTrailerOption.createEnum('InSite.Domain.FedExRateService.FlatbedTrailerOption', false);

Members

Member name | Description
OVER_DIMENSION |
TARP |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


FreightAccountPaymentType Enumeration

[image]

.NET Framework Class Library
FreightAccountPaymentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration FreightAccountPaymentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum FreightAccountPaymentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class FreightAccountPaymentType
JavaScript
InSite.Domain.FedExRateService.FreightAccountPaymentType = function();
InSite.Domain.FedExRateService.FreightAccountPaymentType.createEnum('InSite.Domain.FedExRateService.FreightAccountPaymentType', false);

Members

Member name | Description
COLLECT |
PREPAID |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


FreightBaseCharge Class

[image]

.NET Framework Class Library
FreightBaseCharge Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class FreightBaseCharge
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class FreightBaseCharge
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class FreightBaseCharge
JavaScript
InSite.Domain.FedExRateService.FreightBaseCharge = function();

Type.createClass(
    'InSite.Domain.FedExRateService.FreightBaseCharge');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.FreightBaseCharge

See Also

FreightBaseCharge Members
InSite.Domain.FedExRateService Namespace


FreightBaseCharge Members

[image] [image]

.NET Framework Class Library
FreightBaseCharge Members
FreightBaseCharge Class Constructors Methods Properties See Also Send Feedback

The FreightBaseCharge type exposes the following members.

Constructors

Name | Description
FreightBaseCharge |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ChargeBasis |
ChargeBasisSpecified |
ChargeRate |
Description |
ExtendedAmount |
FreightClass |
FreightClassSpecified |
NmfcCode |
RatedAsClass |
RatedAsClassSpecified |
Weight |

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


FreightBaseCharge Constructor

[image]

.NET Framework Class Library
FreightBaseCharge Constructor
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightBaseCharge()
Visual C++
public:
FreightBaseCharge()
JavaScript
InSite.Domain.FedExRateService.FreightBaseCharge = function();

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


FreightBaseCharge Methods

[image] [image]

.NET Framework Class Library
FreightBaseCharge Methods
FreightBaseCharge Class See Also Send Feedback

The FreightBaseCharge type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


FreightBaseCharge Properties

[image] [image]

.NET Framework Class Library
FreightBaseCharge Properties
FreightBaseCharge Class See Also Send Feedback

The FreightBaseCharge type exposes the following members.

Properties

Name | Description
ChargeBasis |
ChargeBasisSpecified |
ChargeRate |
Description |
ExtendedAmount |
FreightClass |
FreightClassSpecified |
NmfcCode |
RatedAsClass |
RatedAsClassSpecified |
Weight |

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


ChargeBasis Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.ChargeBasis Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ChargeBasis As FreightChargeBasisType
C#
public FreightChargeBasisType ChargeBasis { get; set; }
Visual C++
public:
property FreightChargeBasisType ChargeBasis {
    FreightChargeBasisType get ();
    void set (FreightChargeBasisType value);
}
JavaScript
function get_chargeBasis();
function set_chargeBasis(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


ChargeBasisSpecified Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.ChargeBasisSpecified Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ChargeBasisSpecified As Boolean
C#
public bool ChargeBasisSpecified { get; set; }
Visual C++
public:
property bool ChargeBasisSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_chargeBasisSpecified();
function set_chargeBasisSpecified(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


ChargeRate Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.ChargeRate Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ChargeRate As Money
C#
public Money ChargeRate { get; set; }
Visual C++
public:
property Money^ ChargeRate {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_chargeRate();
function set_chargeRate(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.Description Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


ExtendedAmount Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.ExtendedAmount Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtendedAmount As Money
C#
public Money ExtendedAmount { get; set; }
Visual C++
public:
property Money^ ExtendedAmount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_extendedAmount();
function set_extendedAmount(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


FreightClass Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.FreightClass Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightClass As FreightClassType
C#
public FreightClassType FreightClass { get; set; }
Visual C++
public:
property FreightClassType FreightClass {
    FreightClassType get ();
    void set (FreightClassType value);
}
JavaScript
function get_freightClass();
function set_freightClass(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


FreightClassSpecified Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.FreightClassSpecified Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightClassSpecified As Boolean
C#
public bool FreightClassSpecified { get; set; }
Visual C++
public:
property bool FreightClassSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_freightClassSpecified();
function set_freightClassSpecified(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


NmfcCode Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.NmfcCode Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NmfcCode As String
C#
public string NmfcCode { get; set; }
Visual C++
public:
property String^ NmfcCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_nmfcCode();
function set_nmfcCode(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


RatedAsClass Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.RatedAsClass Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RatedAsClass As FreightClassType
C#
public FreightClassType RatedAsClass { get; set; }
Visual C++
public:
property FreightClassType RatedAsClass {
    FreightClassType get ();
    void set (FreightClassType value);
}
JavaScript
function get_ratedAsClass();
function set_ratedAsClass(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


RatedAsClassSpecified Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.RatedAsClassSpecified Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RatedAsClassSpecified As Boolean
C#
public bool RatedAsClassSpecified { get; set; }
Visual C++
public:
property bool RatedAsClassSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_ratedAsClassSpecified();
function set_ratedAsClassSpecified(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


Weight Property

[image]

.NET Framework Class Library
FreightBaseCharge..::.Weight Property
FreightBaseCharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Weight As Weight
C#
public Weight Weight { get; set; }
Visual C++
public:
property Weight^ Weight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_weight();
function set_weight(value);

Remarks

See Also

FreightBaseCharge Class
InSite.Domain.FedExRateService Namespace


FreightChargeBasisType Enumeration

[image]

.NET Framework Class Library
FreightChargeBasisType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration FreightChargeBasisType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum FreightChargeBasisType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class FreightChargeBasisType
JavaScript
InSite.Domain.FedExRateService.FreightChargeBasisType = function();
InSite.Domain.FedExRateService.FreightChargeBasisType.createEnum('InSite.Domain.FedExRateService.FreightChargeBasisType', false);

Members

Member name | Description
CWT |
FLAT |
MINIMUM |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


FreightClassType Enumeration

[image]

.NET Framework Class Library
FreightClassType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration FreightClassType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum FreightClassType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class FreightClassType
JavaScript
InSite.Domain.FedExRateService.FreightClassType = function();
InSite.Domain.FedExRateService.FreightClassType.createEnum('InSite.Domain.FedExRateService.FreightClassType', false);

Members

Member name | Description
CLASS_050 |
CLASS_055 |
CLASS_060 |
CLASS_065 |
CLASS_070 |
CLASS_077_5 |
CLASS_085 |
CLASS_092_5 |
CLASS_100 |
CLASS_110 |
CLASS_125 |
CLASS_150 |
CLASS_175 |
CLASS_200 |
CLASS_250 |
CLASS_300 |
CLASS_400 |
CLASS_500 |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


FreightCommitDetail Class

[image]

.NET Framework Class Library
FreightCommitDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class FreightCommitDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class FreightCommitDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class FreightCommitDetail
JavaScript
InSite.Domain.FedExRateService.FreightCommitDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.FreightCommitDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.FreightCommitDetail

See Also

FreightCommitDetail Members
InSite.Domain.FedExRateService Namespace


FreightCommitDetail Members

[image] [image]

.NET Framework Class Library
FreightCommitDetail Members
FreightCommitDetail Class Constructors Methods Properties See Also Send Feedback

The FreightCommitDetail type exposes the following members.

Constructors

Name | Description
FreightCommitDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DestinationDetail |
OriginDetail |
TotalDistance |

See Also

FreightCommitDetail Class
InSite.Domain.FedExRateService Namespace


FreightCommitDetail Constructor

[image]

.NET Framework Class Library
FreightCommitDetail Constructor
FreightCommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightCommitDetail()
Visual C++
public:
FreightCommitDetail()
JavaScript
InSite.Domain.FedExRateService.FreightCommitDetail = function();

See Also

FreightCommitDetail Class
InSite.Domain.FedExRateService Namespace


FreightCommitDetail Methods

[image] [image]

.NET Framework Class Library
FreightCommitDetail Methods
FreightCommitDetail Class See Also Send Feedback

The FreightCommitDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightCommitDetail Class
InSite.Domain.FedExRateService Namespace


FreightCommitDetail Properties

[image] [image]

.NET Framework Class Library
FreightCommitDetail Properties
FreightCommitDetail Class See Also Send Feedback

The FreightCommitDetail type exposes the following members.

Properties

Name | Description
DestinationDetail |
OriginDetail |
TotalDistance |

See Also

FreightCommitDetail Class
InSite.Domain.FedExRateService Namespace


DestinationDetail Property

[image]

.NET Framework Class Library
FreightCommitDetail..::.DestinationDetail Property
FreightCommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationDetail As FreightServiceCenterDetail
C#
public FreightServiceCenterDetail DestinationDetail { get; set; }
Visual C++
public:
property FreightServiceCenterDetail^ DestinationDetail {
    FreightServiceCenterDetail^ get ();
    void set (FreightServiceCenterDetail^ value);
}
JavaScript
function get_destinationDetail();
function set_destinationDetail(value);

Remarks

See Also

FreightCommitDetail Class
InSite.Domain.FedExRateService Namespace


OriginDetail Property

[image]

.NET Framework Class Library
FreightCommitDetail..::.OriginDetail Property
FreightCommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OriginDetail As FreightServiceCenterDetail
C#
public FreightServiceCenterDetail OriginDetail { get; set; }
Visual C++
public:
property FreightServiceCenterDetail^ OriginDetail {
    FreightServiceCenterDetail^ get ();
    void set (FreightServiceCenterDetail^ value);
}
JavaScript
function get_originDetail();
function set_originDetail(value);

Remarks

See Also

FreightCommitDetail Class
InSite.Domain.FedExRateService Namespace


TotalDistance Property

[image]

.NET Framework Class Library
FreightCommitDetail..::.TotalDistance Property
FreightCommitDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalDistance As Distance
C#
public Distance TotalDistance { get; set; }
Visual C++
public:
property Distance^ TotalDistance {
    Distance^ get ();
    void set (Distance^ value);
}
JavaScript
function get_totalDistance();
function set_totalDistance(value);

Remarks

See Also

FreightCommitDetail Class
InSite.Domain.FedExRateService Namespace


FreightGuaranteeDetail Class

[image]

.NET Framework Class Library
FreightGuaranteeDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class FreightGuaranteeDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class FreightGuaranteeDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class FreightGuaranteeDetail
JavaScript
InSite.Domain.FedExRateService.FreightGuaranteeDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.FreightGuaranteeDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.FreightGuaranteeDetail

See Also

FreightGuaranteeDetail Members
InSite.Domain.FedExRateService Namespace


FreightGuaranteeDetail Members

[image] [image]

.NET Framework Class Library
FreightGuaranteeDetail Members
FreightGuaranteeDetail Class Constructors Methods Properties See Also Send Feedback

The FreightGuaranteeDetail type exposes the following members.

Constructors

Name | Description
FreightGuaranteeDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Date |
DateSpecified |
Time |
TimeSpecified |
Type |
TypeSpecified |

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


FreightGuaranteeDetail Constructor

[image]

.NET Framework Class Library
FreightGuaranteeDetail Constructor
FreightGuaranteeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightGuaranteeDetail()
Visual C++
public:
FreightGuaranteeDetail()
JavaScript
InSite.Domain.FedExRateService.FreightGuaranteeDetail = function();

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


FreightGuaranteeDetail Methods

[image] [image]

.NET Framework Class Library
FreightGuaranteeDetail Methods
FreightGuaranteeDetail Class See Also Send Feedback

The FreightGuaranteeDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


FreightGuaranteeDetail Properties

[image] [image]

.NET Framework Class Library
FreightGuaranteeDetail Properties
FreightGuaranteeDetail Class See Also Send Feedback

The FreightGuaranteeDetail type exposes the following members.

Properties

Name | Description
Date |
DateSpecified |
Time |
TimeSpecified |
Type |
TypeSpecified |

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


Date Property

[image]

.NET Framework Class Library
FreightGuaranteeDetail..::.Date Property
FreightGuaranteeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Date As DateTime
C#
public DateTime Date { get; set; }
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_date();
function set_date(value);

Remarks

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


DateSpecified Property

[image]

.NET Framework Class Library
FreightGuaranteeDetail..::.DateSpecified Property
FreightGuaranteeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DateSpecified As Boolean
C#
public bool DateSpecified { get; set; }
Visual C++
public:
property bool DateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dateSpecified();
function set_dateSpecified(value);

Remarks

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


Time Property

[image]

.NET Framework Class Library
FreightGuaranteeDetail..::.Time Property
FreightGuaranteeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Time As DateTime
C#
public DateTime Time { get; set; }
Visual C++
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_time();
function set_time(value);

Remarks

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


TimeSpecified Property

[image]

.NET Framework Class Library
FreightGuaranteeDetail..::.TimeSpecified Property
FreightGuaranteeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TimeSpecified As Boolean
C#
public bool TimeSpecified { get; set; }
Visual C++
public:
property bool TimeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_timeSpecified();
function set_timeSpecified(value);

Remarks

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


Type Property

[image]

.NET Framework Class Library
FreightGuaranteeDetail..::.Type Property
FreightGuaranteeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As FreightGuaranteeType
C#
public FreightGuaranteeType Type { get; set; }
Visual C++
public:
property FreightGuaranteeType Type {
    FreightGuaranteeType get ();
    void set (FreightGuaranteeType value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


TypeSpecified Property

[image]

.NET Framework Class Library
FreightGuaranteeDetail..::.TypeSpecified Property
FreightGuaranteeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TypeSpecified As Boolean
C#
public bool TypeSpecified { get; set; }
Visual C++
public:
property bool TypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_typeSpecified();
function set_typeSpecified(value);

Remarks

See Also

FreightGuaranteeDetail Class
InSite.Domain.FedExRateService Namespace


FreightGuaranteeType Enumeration

[image]

.NET Framework Class Library
FreightGuaranteeType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration FreightGuaranteeType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum FreightGuaranteeType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class FreightGuaranteeType
JavaScript
InSite.Domain.FedExRateService.FreightGuaranteeType = function();
InSite.Domain.FedExRateService.FreightGuaranteeType.createEnum('InSite.Domain.FedExRateService.FreightGuaranteeType', false);

Members

Member name | Description
GUARANTEED_DATE |
GUARANTEED_MORNING |
GUARANTEED_TIME |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


FreightRateDetail Class

[image]

.NET Framework Class Library
FreightRateDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class FreightRateDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class FreightRateDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class FreightRateDetail
JavaScript
InSite.Domain.FedExRateService.FreightRateDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.FreightRateDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.FreightRateDetail

See Also

FreightRateDetail Members
InSite.Domain.FedExRateService Namespace


FreightRateDetail Members

[image] [image]

.NET Framework Class Library
FreightRateDetail Members
FreightRateDetail Class Constructors Methods Properties See Also Send Feedback

The FreightRateDetail type exposes the following members.

Constructors

Name | Description
FreightRateDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseCharges |
Notations |
QuoteNumber |

See Also

FreightRateDetail Class
InSite.Domain.FedExRateService Namespace


FreightRateDetail Constructor

[image]

.NET Framework Class Library
FreightRateDetail Constructor
FreightRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightRateDetail()
Visual C++
public:
FreightRateDetail()
JavaScript
InSite.Domain.FedExRateService.FreightRateDetail = function();

See Also

FreightRateDetail Class
InSite.Domain.FedExRateService Namespace


FreightRateDetail Methods

[image] [image]

.NET Framework Class Library
FreightRateDetail Methods
FreightRateDetail Class See Also Send Feedback

The FreightRateDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightRateDetail Class
InSite.Domain.FedExRateService Namespace


FreightRateDetail Properties

[image] [image]

.NET Framework Class Library
FreightRateDetail Properties
FreightRateDetail Class See Also Send Feedback

The FreightRateDetail type exposes the following members.

Properties

Name | Description
BaseCharges |
Notations |
QuoteNumber |

See Also

FreightRateDetail Class
InSite.Domain.FedExRateService Namespace


BaseCharges Property

[image]

.NET Framework Class Library
FreightRateDetail..::.BaseCharges Property
FreightRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseCharges As FreightBaseCharge()
C#
public FreightBaseCharge[] BaseCharges { get; set; }
Visual C++
public:
property array<FreightBaseCharge^>^ BaseCharges {
    array<FreightBaseCharge^>^ get ();
    void set (array<FreightBaseCharge^>^ value);
}
JavaScript
function get_baseCharges();
function set_baseCharges(value);

Remarks

See Also

FreightRateDetail Class
InSite.Domain.FedExRateService Namespace


Notations Property

[image]

.NET Framework Class Library
FreightRateDetail..::.Notations Property
FreightRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Notations As FreightRateNotation()
C#
public FreightRateNotation[] Notations { get; set; }
Visual C++
public:
property array<FreightRateNotation^>^ Notations {
    array<FreightRateNotation^>^ get ();
    void set (array<FreightRateNotation^>^ value);
}
JavaScript
function get_notations();
function set_notations(value);

Remarks

See Also

FreightRateDetail Class
InSite.Domain.FedExRateService Namespace


QuoteNumber Property

[image]

.NET Framework Class Library
FreightRateDetail..::.QuoteNumber Property
FreightRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property QuoteNumber As String
C#
public string QuoteNumber { get; set; }
Visual C++
public:
property String^ QuoteNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_quoteNumber();
function set_quoteNumber(value);

Remarks

See Also

FreightRateDetail Class
InSite.Domain.FedExRateService Namespace


FreightRateNotation Class

[image]

.NET Framework Class Library
FreightRateNotation Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class FreightRateNotation
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class FreightRateNotation
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class FreightRateNotation
JavaScript
InSite.Domain.FedExRateService.FreightRateNotation = function();

Type.createClass(
    'InSite.Domain.FedExRateService.FreightRateNotation');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.FreightRateNotation

See Also

FreightRateNotation Members
InSite.Domain.FedExRateService Namespace


FreightRateNotation Members

[image] [image]

.NET Framework Class Library
FreightRateNotation Members
FreightRateNotation Class Constructors Methods Properties See Also Send Feedback

The FreightRateNotation type exposes the following members.

Constructors

Name | Description
FreightRateNotation |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Code |
Description |

See Also

FreightRateNotation Class
InSite.Domain.FedExRateService Namespace


FreightRateNotation Constructor

[image]

.NET Framework Class Library
FreightRateNotation Constructor
FreightRateNotation Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightRateNotation()
Visual C++
public:
FreightRateNotation()
JavaScript
InSite.Domain.FedExRateService.FreightRateNotation = function();

See Also

FreightRateNotation Class
InSite.Domain.FedExRateService Namespace


FreightRateNotation Methods

[image] [image]

.NET Framework Class Library
FreightRateNotation Methods
FreightRateNotation Class See Also Send Feedback

The FreightRateNotation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightRateNotation Class
InSite.Domain.FedExRateService Namespace


FreightRateNotation Properties

[image] [image]

.NET Framework Class Library
FreightRateNotation Properties
FreightRateNotation Class See Also Send Feedback

The FreightRateNotation type exposes the following members.

Properties

Name | Description
Code |
Description |

See Also

FreightRateNotation Class
InSite.Domain.FedExRateService Namespace


Code Property

[image]

.NET Framework Class Library
FreightRateNotation..::.Code Property
FreightRateNotation Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code { get; set; }
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_code();
function set_code(value);

Remarks

See Also

FreightRateNotation Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
FreightRateNotation..::.Description Property
FreightRateNotation Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

FreightRateNotation Class
InSite.Domain.FedExRateService Namespace


FreightServiceCenterDetail Class

[image]

.NET Framework Class Library
FreightServiceCenterDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class FreightServiceCenterDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class FreightServiceCenterDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class FreightServiceCenterDetail
JavaScript
InSite.Domain.FedExRateService.FreightServiceCenterDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.FreightServiceCenterDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.FreightServiceCenterDetail

See Also

FreightServiceCenterDetail Members
InSite.Domain.FedExRateService Namespace


FreightServiceCenterDetail Members

[image] [image]

.NET Framework Class Library
FreightServiceCenterDetail Members
FreightServiceCenterDetail Class Constructors Methods Properties See Also Send Feedback

The FreightServiceCenterDetail type exposes the following members.

Constructors

Name | Description
FreightServiceCenterDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AdditionalDays |
AdditionalDaysSpecified |
GatewayLocationId |
InterlineCarrierCode |
InterlineCarrierName |
LimitedServiceDays |
LocalDistance |
LocalDuration |
LocalService |
LocalServiceScheduling |
LocalServiceSchedulingSpecified |
LocalServiceSpecified |

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


FreightServiceCenterDetail Constructor

[image]

.NET Framework Class Library
FreightServiceCenterDetail Constructor
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightServiceCenterDetail()
Visual C++
public:
FreightServiceCenterDetail()
JavaScript
InSite.Domain.FedExRateService.FreightServiceCenterDetail = function();

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


FreightServiceCenterDetail Methods

[image] [image]

.NET Framework Class Library
FreightServiceCenterDetail Methods
FreightServiceCenterDetail Class See Also Send Feedback

The FreightServiceCenterDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


FreightServiceCenterDetail Properties

[image] [image]

.NET Framework Class Library
FreightServiceCenterDetail Properties
FreightServiceCenterDetail Class See Also Send Feedback

The FreightServiceCenterDetail type exposes the following members.

Properties

Name | Description
AdditionalDays |
AdditionalDaysSpecified |
GatewayLocationId |
InterlineCarrierCode |
InterlineCarrierName |
LimitedServiceDays |
LocalDistance |
LocalDuration |
LocalService |
LocalServiceScheduling |
LocalServiceSchedulingSpecified |
LocalServiceSpecified |

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


AdditionalDays Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.AdditionalDays Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AdditionalDays As Integer
C#
public int AdditionalDays { get; set; }
Visual C++
public:
property int AdditionalDays {
    int get ();
    void set (int value);
}
JavaScript
function get_additionalDays();
function set_additionalDays(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


AdditionalDaysSpecified Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.AdditionalDaysSpecified Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AdditionalDaysSpecified As Boolean
C#
public bool AdditionalDaysSpecified { get; set; }
Visual C++
public:
property bool AdditionalDaysSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_additionalDaysSpecified();
function set_additionalDaysSpecified(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


GatewayLocationId Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.GatewayLocationId Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property GatewayLocationId As String
C#
public string GatewayLocationId { get; set; }
Visual C++
public:
property String^ GatewayLocationId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_gatewayLocationId();
function set_gatewayLocationId(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


InterlineCarrierCode Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.InterlineCarrierCode Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property InterlineCarrierCode As String
C#
public string InterlineCarrierCode { get; set; }
Visual C++
public:
property String^ InterlineCarrierCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_interlineCarrierCode();
function set_interlineCarrierCode(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


InterlineCarrierName Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.InterlineCarrierName Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property InterlineCarrierName As String
C#
public string InterlineCarrierName { get; set; }
Visual C++
public:
property String^ InterlineCarrierName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_interlineCarrierName();
function set_interlineCarrierName(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


LimitedServiceDays Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.LimitedServiceDays Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LimitedServiceDays As DayOfWeekType()
C#
public DayOfWeekType[] LimitedServiceDays { get; set; }
Visual C++
public:
property array<DayOfWeekType>^ LimitedServiceDays {
    array<DayOfWeekType>^ get ();
    void set (array<DayOfWeekType>^ value);
}
JavaScript
function get_limitedServiceDays();
function set_limitedServiceDays(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


LocalDistance Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.LocalDistance Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalDistance As Distance
C#
public Distance LocalDistance { get; set; }
Visual C++
public:
property Distance^ LocalDistance {
    Distance^ get ();
    void set (Distance^ value);
}
JavaScript
function get_localDistance();
function set_localDistance(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


LocalDuration Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.LocalDuration Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalDuration As String
C#
public string LocalDuration { get; set; }
Visual C++
public:
property String^ LocalDuration {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_localDuration();
function set_localDuration(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


LocalService Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.LocalService Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalService As ServiceType
C#
public ServiceType LocalService { get; set; }
Visual C++
public:
property ServiceType LocalService {
    ServiceType get ();
    void set (ServiceType value);
}
JavaScript
function get_localService();
function set_localService(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


LocalServiceScheduling Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.LocalServiceScheduling Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalServiceScheduling As FreightServiceSchedulingType
C#
public FreightServiceSchedulingType LocalServiceScheduling { get; set; }
Visual C++
public:
property FreightServiceSchedulingType LocalServiceScheduling {
    FreightServiceSchedulingType get ();
    void set (FreightServiceSchedulingType value);
}
JavaScript
function get_localServiceScheduling();
function set_localServiceScheduling(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


LocalServiceSchedulingSpecified Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.LocalServiceSchedulingSpecified Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalServiceSchedulingSpecified As Boolean
C#
public bool LocalServiceSchedulingSpecified { get; set; }
Visual C++
public:
property bool LocalServiceSchedulingSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_localServiceSchedulingSpecified();
function set_localServiceSchedulingSpecified(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


LocalServiceSpecified Property

[image]

.NET Framework Class Library
FreightServiceCenterDetail..::.LocalServiceSpecified Property
FreightServiceCenterDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalServiceSpecified As Boolean
C#
public bool LocalServiceSpecified { get; set; }
Visual C++
public:
property bool LocalServiceSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_localServiceSpecified();
function set_localServiceSpecified(value);

Remarks

See Also

FreightServiceCenterDetail Class
InSite.Domain.FedExRateService Namespace


FreightServiceSchedulingType Enumeration

[image]

.NET Framework Class Library
FreightServiceSchedulingType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration FreightServiceSchedulingType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum FreightServiceSchedulingType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class FreightServiceSchedulingType
JavaScript
InSite.Domain.FedExRateService.FreightServiceSchedulingType = function();
InSite.Domain.FedExRateService.FreightServiceSchedulingType.createEnum('InSite.Domain.FedExRateService.FreightServiceSchedulingType', false);

Members

Member name | Description
LIMITED |
STANDARD |
WILL_CALL |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


FreightShipmentDetail Class

[image]

.NET Framework Class Library
FreightShipmentDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class FreightShipmentDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class FreightShipmentDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class FreightShipmentDetail
JavaScript
InSite.Domain.FedExRateService.FreightShipmentDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.FreightShipmentDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.FreightShipmentDetail

See Also

FreightShipmentDetail Members
InSite.Domain.FedExRateService Namespace


FreightShipmentDetail Members

[image] [image]

.NET Framework Class Library
FreightShipmentDetail Members
FreightShipmentDetail Class Constructors Methods Properties See Also Send Feedback

The FreightShipmentDetail type exposes the following members.

Constructors

Name | Description
FreightShipmentDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ClientDiscountPercent |
ClientDiscountPercentSpecified |
Comment |
Coupons |
DeclaredValue |
FedExFreightAccountNumber |
FedExFreightBillingAddress |
FedExNationalFreightAccountNumber |
FedExNationalFreightBillingAddress |
HandlingUnits |
LineItems |
NewGoods |
NewGoodsSpecified |
PalletWeight |
PaymentType |
PaymentTypeSpecified |
Role |
RoleSpecified |
ShipmentDimensions |

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


FreightShipmentDetail Constructor

[image]

.NET Framework Class Library
FreightShipmentDetail Constructor
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightShipmentDetail()
Visual C++
public:
FreightShipmentDetail()
JavaScript
InSite.Domain.FedExRateService.FreightShipmentDetail = function();

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


FreightShipmentDetail Methods

[image] [image]

.NET Framework Class Library
FreightShipmentDetail Methods
FreightShipmentDetail Class See Also Send Feedback

The FreightShipmentDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


FreightShipmentDetail Properties

[image] [image]

.NET Framework Class Library
FreightShipmentDetail Properties
FreightShipmentDetail Class See Also Send Feedback

The FreightShipmentDetail type exposes the following members.

Properties

Name | Description
ClientDiscountPercent |
ClientDiscountPercentSpecified |
Comment |
Coupons |
DeclaredValue |
FedExFreightAccountNumber |
FedExFreightBillingAddress |
FedExNationalFreightAccountNumber |
FedExNationalFreightBillingAddress |
HandlingUnits |
LineItems |
NewGoods |
NewGoodsSpecified |
PalletWeight |
PaymentType |
PaymentTypeSpecified |
Role |
RoleSpecified |
ShipmentDimensions |

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ClientDiscountPercent Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.ClientDiscountPercent Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientDiscountPercent As Decimal
C#
public decimal ClientDiscountPercent { get; set; }
Visual C++
public:
property Decimal ClientDiscountPercent {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_clientDiscountPercent();
function set_clientDiscountPercent(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ClientDiscountPercentSpecified Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.ClientDiscountPercentSpecified Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientDiscountPercentSpecified As Boolean
C#
public bool ClientDiscountPercentSpecified { get; set; }
Visual C++
public:
property bool ClientDiscountPercentSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_clientDiscountPercentSpecified();
function set_clientDiscountPercentSpecified(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


Comment Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.Comment Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Comment As String
C#
public string Comment { get; set; }
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_comment();
function set_comment(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


Coupons Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.Coupons Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Coupons As String()
C#
public string[] Coupons { get; set; }
Visual C++
public:
property array<String^>^ Coupons {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_coupons();
function set_coupons(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


DeclaredValue Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.DeclaredValue Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DeclaredValue As Money
C#
public Money DeclaredValue { get; set; }
Visual C++
public:
property Money^ DeclaredValue {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_declaredValue();
function set_declaredValue(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


FedExFreightAccountNumber Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.FedExFreightAccountNumber Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FedExFreightAccountNumber As String
C#
public string FedExFreightAccountNumber { get; set; }
Visual C++
public:
property String^ FedExFreightAccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fedExFreightAccountNumber();
function set_fedExFreightAccountNumber(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


FedExFreightBillingAddress Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.FedExFreightBillingAddress Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FedExFreightBillingAddress As Address
C#
public Address FedExFreightBillingAddress { get; set; }
Visual C++
public:
property Address^ FedExFreightBillingAddress {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_fedExFreightBillingAddress();
function set_fedExFreightBillingAddress(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


FedExNationalFreightAccountNumber Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.FedExNationalFreightAccountNumber Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FedExNationalFreightAccountNumber As String
C#
public string FedExNationalFreightAccountNumber { get; set; }
Visual C++
public:
property String^ FedExNationalFreightAccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fedExNationalFreightAccountNumber();
function set_fedExNationalFreightAccountNumber(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


FedExNationalFreightBillingAddress Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.FedExNationalFreightBillingAddress Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FedExNationalFreightBillingAddress As Address
C#
public Address FedExNationalFreightBillingAddress { get; set; }
Visual C++
public:
property Address^ FedExNationalFreightBillingAddress {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_fedExNationalFreightBillingAddress();
function set_fedExNationalFreightBillingAddress(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


HandlingUnits Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.HandlingUnits Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HandlingUnits As String
C#
public string HandlingUnits { get; set; }
Visual C++
public:
property String^ HandlingUnits {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_handlingUnits();
function set_handlingUnits(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


LineItems Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.LineItems Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LineItems As FreightShipmentLineItem()
C#
public FreightShipmentLineItem[] LineItems { get; set; }
Visual C++
public:
property array<FreightShipmentLineItem^>^ LineItems {
    array<FreightShipmentLineItem^>^ get ();
    void set (array<FreightShipmentLineItem^>^ value);
}
JavaScript
function get_lineItems();
function set_lineItems(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


NewGoods Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.NewGoods Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NewGoods As Boolean
C#
public bool NewGoods { get; set; }
Visual C++
public:
property bool NewGoods {
    bool get ();
    void set (bool value);
}
JavaScript
function get_newGoods();
function set_newGoods(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


NewGoodsSpecified Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.NewGoodsSpecified Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NewGoodsSpecified As Boolean
C#
public bool NewGoodsSpecified { get; set; }
Visual C++
public:
property bool NewGoodsSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_newGoodsSpecified();
function set_newGoodsSpecified(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


PalletWeight Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.PalletWeight Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PalletWeight As Weight
C#
public Weight PalletWeight { get; set; }
Visual C++
public:
property Weight^ PalletWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_palletWeight();
function set_palletWeight(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


PaymentType Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.PaymentType Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PaymentType As FreightAccountPaymentType
C#
public FreightAccountPaymentType PaymentType { get; set; }
Visual C++
public:
property FreightAccountPaymentType PaymentType {
    FreightAccountPaymentType get ();
    void set (FreightAccountPaymentType value);
}
JavaScript
function get_paymentType();
function set_paymentType(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


PaymentTypeSpecified Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.PaymentTypeSpecified Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PaymentTypeSpecified As Boolean
C#
public bool PaymentTypeSpecified { get; set; }
Visual C++
public:
property bool PaymentTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_paymentTypeSpecified();
function set_paymentTypeSpecified(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


Role Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.Role Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Role As FreightShipmentRoleType
C#
public FreightShipmentRoleType Role { get; set; }
Visual C++
public:
property FreightShipmentRoleType Role {
    FreightShipmentRoleType get ();
    void set (FreightShipmentRoleType value);
}
JavaScript
function get_role();
function set_role(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


RoleSpecified Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.RoleSpecified Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RoleSpecified As Boolean
C#
public bool RoleSpecified { get; set; }
Visual C++
public:
property bool RoleSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_roleSpecified();
function set_roleSpecified(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentDimensions Property

[image]

.NET Framework Class Library
FreightShipmentDetail..::.ShipmentDimensions Property
FreightShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipmentDimensions As Dimensions
C#
public Dimensions ShipmentDimensions { get; set; }
Visual C++
public:
property Dimensions^ ShipmentDimensions {
    Dimensions^ get ();
    void set (Dimensions^ value);
}
JavaScript
function get_shipmentDimensions();
function set_shipmentDimensions(value);

Remarks

See Also

FreightShipmentDetail Class
InSite.Domain.FedExRateService Namespace


FreightShipmentLineItem Class

[image]

.NET Framework Class Library
FreightShipmentLineItem Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class FreightShipmentLineItem
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class FreightShipmentLineItem
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class FreightShipmentLineItem
JavaScript
InSite.Domain.FedExRateService.FreightShipmentLineItem = function();

Type.createClass(
    'InSite.Domain.FedExRateService.FreightShipmentLineItem');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.FreightShipmentLineItem

See Also

FreightShipmentLineItem Members
InSite.Domain.FedExRateService Namespace


FreightShipmentLineItem Members

[image] [image]

.NET Framework Class Library
FreightShipmentLineItem Members
FreightShipmentLineItem Class Constructors Methods Properties See Also Send Feedback

The FreightShipmentLineItem type exposes the following members.

Constructors

Name | Description
FreightShipmentLineItem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Description |
Dimensions |
FreightClass |
FreightClassSpecified |
Packaging |
PackagingSpecified |
Volume |
Weight |

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


FreightShipmentLineItem Constructor

[image]

.NET Framework Class Library
FreightShipmentLineItem Constructor
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightShipmentLineItem()
Visual C++
public:
FreightShipmentLineItem()
JavaScript
InSite.Domain.FedExRateService.FreightShipmentLineItem = function();

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


FreightShipmentLineItem Methods

[image] [image]

.NET Framework Class Library
FreightShipmentLineItem Methods
FreightShipmentLineItem Class See Also Send Feedback

The FreightShipmentLineItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


FreightShipmentLineItem Properties

[image] [image]

.NET Framework Class Library
FreightShipmentLineItem Properties
FreightShipmentLineItem Class See Also Send Feedback

The FreightShipmentLineItem type exposes the following members.

Properties

Name | Description
Description |
Dimensions |
FreightClass |
FreightClassSpecified |
Packaging |
PackagingSpecified |
Volume |
Weight |

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
FreightShipmentLineItem..::.Description Property
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


Dimensions Property

[image]

.NET Framework Class Library
FreightShipmentLineItem..::.Dimensions Property
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Dimensions As Dimensions
C#
public Dimensions Dimensions { get; set; }
Visual C++
public:
property Dimensions^ Dimensions {
    Dimensions^ get ();
    void set (Dimensions^ value);
}
JavaScript
function get_dimensions();
function set_dimensions(value);

Remarks

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


FreightClass Property

[image]

.NET Framework Class Library
FreightShipmentLineItem..::.FreightClass Property
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightClass As FreightClassType
C#
public FreightClassType FreightClass { get; set; }
Visual C++
public:
property FreightClassType FreightClass {
    FreightClassType get ();
    void set (FreightClassType value);
}
JavaScript
function get_freightClass();
function set_freightClass(value);

Remarks

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


FreightClassSpecified Property

[image]

.NET Framework Class Library
FreightShipmentLineItem..::.FreightClassSpecified Property
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightClassSpecified As Boolean
C#
public bool FreightClassSpecified { get; set; }
Visual C++
public:
property bool FreightClassSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_freightClassSpecified();
function set_freightClassSpecified(value);

Remarks

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


Packaging Property

[image]

.NET Framework Class Library
FreightShipmentLineItem..::.Packaging Property
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Packaging As PhysicalPackagingType
C#
public PhysicalPackagingType Packaging { get; set; }
Visual C++
public:
property PhysicalPackagingType Packaging {
    PhysicalPackagingType get ();
    void set (PhysicalPackagingType value);
}
JavaScript
function get_packaging();
function set_packaging(value);

Remarks

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


PackagingSpecified Property

[image]

.NET Framework Class Library
FreightShipmentLineItem..::.PackagingSpecified Property
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackagingSpecified As Boolean
C#
public bool PackagingSpecified { get; set; }
Visual C++
public:
property bool PackagingSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_packagingSpecified();
function set_packagingSpecified(value);

Remarks

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


Volume Property

[image]

.NET Framework Class Library
FreightShipmentLineItem..::.Volume Property
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Volume As Volume
C#
public Volume Volume { get; set; }
Visual C++
public:
property Volume^ Volume {
    Volume^ get ();
    void set (Volume^ value);
}
JavaScript
function get_volume();
function set_volume(value);

Remarks

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


Weight Property

[image]

.NET Framework Class Library
FreightShipmentLineItem..::.Weight Property
FreightShipmentLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Weight As Weight
C#
public Weight Weight { get; set; }
Visual C++
public:
property Weight^ Weight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_weight();
function set_weight(value);

Remarks

See Also

FreightShipmentLineItem Class
InSite.Domain.FedExRateService Namespace


FreightShipmentRoleType Enumeration

[image]

.NET Framework Class Library
FreightShipmentRoleType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration FreightShipmentRoleType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum FreightShipmentRoleType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class FreightShipmentRoleType
JavaScript
InSite.Domain.FedExRateService.FreightShipmentRoleType = function();
InSite.Domain.FedExRateService.FreightShipmentRoleType.createEnum('InSite.Domain.FedExRateService.FreightShipmentRoleType', false);

Members

Member name | Description
CONSIGNEE |
SHIPPER |
THIRD_PARTY |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


GeneralAgencyAgreementDetail Class

[image]

.NET Framework Class Library
GeneralAgencyAgreementDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class GeneralAgencyAgreementDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class GeneralAgencyAgreementDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class GeneralAgencyAgreementDetail
JavaScript
InSite.Domain.FedExRateService.GeneralAgencyAgreementDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.GeneralAgencyAgreementDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.GeneralAgencyAgreementDetail

See Also

GeneralAgencyAgreementDetail Members
InSite.Domain.FedExRateService Namespace


GeneralAgencyAgreementDetail Members

[image] [image]

.NET Framework Class Library
GeneralAgencyAgreementDetail Members
GeneralAgencyAgreementDetail Class Constructors Methods Properties See Also Send Feedback

The GeneralAgencyAgreementDetail type exposes the following members.

Constructors

Name | Description
GeneralAgencyAgreementDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Format |

See Also

GeneralAgencyAgreementDetail Class
InSite.Domain.FedExRateService Namespace


GeneralAgencyAgreementDetail Constructor

[image]

.NET Framework Class Library
GeneralAgencyAgreementDetail Constructor
GeneralAgencyAgreementDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GeneralAgencyAgreementDetail()
Visual C++
public:
GeneralAgencyAgreementDetail()
JavaScript
InSite.Domain.FedExRateService.GeneralAgencyAgreementDetail = function();

See Also

GeneralAgencyAgreementDetail Class
InSite.Domain.FedExRateService Namespace


GeneralAgencyAgreementDetail Methods

[image] [image]

.NET Framework Class Library
GeneralAgencyAgreementDetail Methods
GeneralAgencyAgreementDetail Class See Also Send Feedback

The GeneralAgencyAgreementDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeneralAgencyAgreementDetail Class
InSite.Domain.FedExRateService Namespace


GeneralAgencyAgreementDetail Properties

[image] [image]

.NET Framework Class Library
GeneralAgencyAgreementDetail Properties
GeneralAgencyAgreementDetail Class See Also Send Feedback

The GeneralAgencyAgreementDetail type exposes the following members.

Properties

Name | Description
Format |

See Also

GeneralAgencyAgreementDetail Class
InSite.Domain.FedExRateService Namespace


Format Property

[image]

.NET Framework Class Library
GeneralAgencyAgreementDetail..::.Format Property
GeneralAgencyAgreementDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As ShippingDocumentFormat
C#
public ShippingDocumentFormat Format { get; set; }
Visual C++
public:
property ShippingDocumentFormat^ Format {
    ShippingDocumentFormat^ get ();
    void set (ShippingDocumentFormat^ value);
}
JavaScript
function get_format();
function set_format(value);

Remarks

See Also

GeneralAgencyAgreementDetail Class
InSite.Domain.FedExRateService Namespace


getRatesCompletedEventArgs Class

[image]

.NET Framework Class Library
getRatesCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Class getRatesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public class getRatesCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public ref class getRatesCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.FedExRateService.getRatesCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.FedExRateService.getRatesCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.FedExRateService..::.getRatesCompletedEventArgs

See Also

getRatesCompletedEventArgs Members
InSite.Domain.FedExRateService Namespace


getRatesCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
getRatesCompletedEventArgs Members
getRatesCompletedEventArgs Class Methods Properties See Also Send Feedback

The getRatesCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

getRatesCompletedEventArgs Class
InSite.Domain.FedExRateService Namespace


getRatesCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
getRatesCompletedEventArgs Methods
getRatesCompletedEventArgs Class See Also Send Feedback

The getRatesCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

getRatesCompletedEventArgs Class
InSite.Domain.FedExRateService Namespace


getRatesCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
getRatesCompletedEventArgs Properties
getRatesCompletedEventArgs Class See Also Send Feedback

The getRatesCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

getRatesCompletedEventArgs Class
InSite.Domain.FedExRateService Namespace


Result Property

[image]

.NET Framework Class Library
getRatesCompletedEventArgs..::.Result Property
getRatesCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As RateReply
C#
public RateReply Result { get; }
Visual C++
public:
property RateReply^ Result {
    RateReply^ get ();
}
JavaScript
function get_result();

Remarks

See Also

getRatesCompletedEventArgs Class
InSite.Domain.FedExRateService Namespace


getRatesCompletedEventHandler Delegate

[image]

.NET Framework Class Library
getRatesCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Delegate Sub getRatesCompletedEventHandler ( _
    sender As Object, _
    e As getRatesCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public delegate void getRatesCompletedEventHandler(
    Object sender,
    getRatesCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public delegate void getRatesCompletedEventHandler(
    Object^ sender,
    getRatesCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.FedExRateService..::.getRatesCompletedEventArgs

Remarks

See Also

InSite.Domain.FedExRateService Namespace


HazMatCertificateData Class

[image]

.NET Framework Class Library
HazMatCertificateData Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class HazMatCertificateData
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class HazMatCertificateData
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class HazMatCertificateData
JavaScript
InSite.Domain.FedExRateService.HazMatCertificateData = function();

Type.createClass(
    'InSite.Domain.FedExRateService.HazMatCertificateData');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.HazMatCertificateData

See Also

HazMatCertificateData Members
InSite.Domain.FedExRateService Namespace


HazMatCertificateData Members

[image] [image]

.NET Framework Class Library
HazMatCertificateData Members
HazMatCertificateData Class Constructors Methods Properties See Also Send Feedback

The HazMatCertificateData type exposes the following members.

Constructors

Name | Description
HazMatCertificateData |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DotHazardClassOrDivision |
DotIdNumber |
DotLabelType |
DotProperShippingName |
PackingGroup |
Quantity |
QuantitySpecified |
TwentyFourHourEmergencyResponseContactName |
TwentyFourHourEmergencyResponseContactNumber |
Units |

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


HazMatCertificateData Constructor

[image]

.NET Framework Class Library
HazMatCertificateData Constructor
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public HazMatCertificateData()
Visual C++
public:
HazMatCertificateData()
JavaScript
InSite.Domain.FedExRateService.HazMatCertificateData = function();

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


HazMatCertificateData Methods

[image] [image]

.NET Framework Class Library
HazMatCertificateData Methods
HazMatCertificateData Class See Also Send Feedback

The HazMatCertificateData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


HazMatCertificateData Properties

[image] [image]

.NET Framework Class Library
HazMatCertificateData Properties
HazMatCertificateData Class See Also Send Feedback

The HazMatCertificateData type exposes the following members.

Properties

Name | Description
DotHazardClassOrDivision |
DotIdNumber |
DotLabelType |
DotProperShippingName |
PackingGroup |
Quantity |
QuantitySpecified |
TwentyFourHourEmergencyResponseContactName |
TwentyFourHourEmergencyResponseContactNumber |
Units |

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


DotHazardClassOrDivision Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.DotHazardClassOrDivision Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DotHazardClassOrDivision As String
C#
public string DotHazardClassOrDivision { get; set; }
Visual C++
public:
property String^ DotHazardClassOrDivision {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dotHazardClassOrDivision();
function set_dotHazardClassOrDivision(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


DotIdNumber Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.DotIdNumber Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DotIdNumber As String
C#
public string DotIdNumber { get; set; }
Visual C++
public:
property String^ DotIdNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dotIdNumber();
function set_dotIdNumber(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


DotLabelType Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.DotLabelType Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DotLabelType As String
C#
public string DotLabelType { get; set; }
Visual C++
public:
property String^ DotLabelType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dotLabelType();
function set_dotLabelType(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


DotProperShippingName Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.DotProperShippingName Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DotProperShippingName As String()
C#
public string[] DotProperShippingName { get; set; }
Visual C++
public:
property array<String^>^ DotProperShippingName {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_dotProperShippingName();
function set_dotProperShippingName(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


PackingGroup Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.PackingGroup Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackingGroup As String
C#
public string PackingGroup { get; set; }
Visual C++
public:
property String^ PackingGroup {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_packingGroup();
function set_packingGroup(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


Quantity Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.Quantity Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Quantity As Decimal
C#
public decimal Quantity { get; set; }
Visual C++
public:
property Decimal Quantity {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_quantity();
function set_quantity(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


QuantitySpecified Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.QuantitySpecified Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property QuantitySpecified As Boolean
C#
public bool QuantitySpecified { get; set; }
Visual C++
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_quantitySpecified();
function set_quantitySpecified(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


TwentyFourHourEmergencyResponseContactName Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.TwentyFourHourEmergencyResponseContactName Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TwentyFourHourEmergencyResponseContactName As String
C#
public string TwentyFourHourEmergencyResponseContactName { get; set; }
Visual C++
public:
property String^ TwentyFourHourEmergencyResponseContactName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_twentyFourHourEmergencyResponseContactName();
function set_twentyFourHourEmergencyResponseContactName(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


TwentyFourHourEmergencyResponseContactNumber Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.TwentyFourHourEmergencyResponseContactNumber Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TwentyFourHourEmergencyResponseContactNumber As String
C#
public string TwentyFourHourEmergencyResponseContactNumber { get; set; }
Visual C++
public:
property String^ TwentyFourHourEmergencyResponseContactNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_twentyFourHourEmergencyResponseContactNumber();
function set_twentyFourHourEmergencyResponseContactNumber(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


Units Property

[image]

.NET Framework Class Library
HazMatCertificateData..::.Units Property
HazMatCertificateData Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As String
C#
public string Units { get; set; }
Visual C++
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_units();
function set_units(value);

Remarks

See Also

HazMatCertificateData Class
InSite.Domain.FedExRateService Namespace


HoldAtLocationDetail Class

[image]

.NET Framework Class Library
HoldAtLocationDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class HoldAtLocationDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class HoldAtLocationDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class HoldAtLocationDetail
JavaScript
InSite.Domain.FedExRateService.HoldAtLocationDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.HoldAtLocationDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.HoldAtLocationDetail

See Also

HoldAtLocationDetail Members
InSite.Domain.FedExRateService Namespace


HoldAtLocationDetail Members

[image] [image]

.NET Framework Class Library
HoldAtLocationDetail Members
HoldAtLocationDetail Class Constructors Methods Properties See Also Send Feedback

The HoldAtLocationDetail type exposes the following members.

Constructors

Name | Description
HoldAtLocationDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address |
PhoneNumber |

See Also

HoldAtLocationDetail Class
InSite.Domain.FedExRateService Namespace


HoldAtLocationDetail Constructor

[image]

.NET Framework Class Library
HoldAtLocationDetail Constructor
HoldAtLocationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public HoldAtLocationDetail()
Visual C++
public:
HoldAtLocationDetail()
JavaScript
InSite.Domain.FedExRateService.HoldAtLocationDetail = function();

See Also

HoldAtLocationDetail Class
InSite.Domain.FedExRateService Namespace


HoldAtLocationDetail Methods

[image] [image]

.NET Framework Class Library
HoldAtLocationDetail Methods
HoldAtLocationDetail Class See Also Send Feedback

The HoldAtLocationDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HoldAtLocationDetail Class
InSite.Domain.FedExRateService Namespace


HoldAtLocationDetail Properties

[image] [image]

.NET Framework Class Library
HoldAtLocationDetail Properties
HoldAtLocationDetail Class See Also Send Feedback

The HoldAtLocationDetail type exposes the following members.

Properties

Name | Description
Address |
PhoneNumber |

See Also

HoldAtLocationDetail Class
InSite.Domain.FedExRateService Namespace


Address Property

[image]

.NET Framework Class Library
HoldAtLocationDetail..::.Address Property
HoldAtLocationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As Address
C#
public Address Address { get; set; }
Visual C++
public:
property Address^ Address {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

HoldAtLocationDetail Class
InSite.Domain.FedExRateService Namespace


PhoneNumber Property

[image]

.NET Framework Class Library
HoldAtLocationDetail..::.PhoneNumber Property
HoldAtLocationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PhoneNumber As String
C#
public string PhoneNumber { get; set; }
Visual C++
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

HoldAtLocationDetail Class
InSite.Domain.FedExRateService Namespace


HomeDeliveryPremiumDetail Class

[image]

.NET Framework Class Library
HomeDeliveryPremiumDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class HomeDeliveryPremiumDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class HomeDeliveryPremiumDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class HomeDeliveryPremiumDetail
JavaScript
InSite.Domain.FedExRateService.HomeDeliveryPremiumDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.HomeDeliveryPremiumDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.HomeDeliveryPremiumDetail

See Also

HomeDeliveryPremiumDetail Members
InSite.Domain.FedExRateService Namespace


HomeDeliveryPremiumDetail Members

[image] [image]

.NET Framework Class Library
HomeDeliveryPremiumDetail Members
HomeDeliveryPremiumDetail Class Constructors Methods Properties See Also Send Feedback

The HomeDeliveryPremiumDetail type exposes the following members.

Constructors

Name | Description
HomeDeliveryPremiumDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Date |
DateSpecified |
HomeDeliveryPremiumType |
PhoneNumber |

See Also

HomeDeliveryPremiumDetail Class
InSite.Domain.FedExRateService Namespace


HomeDeliveryPremiumDetail Constructor

[image]

.NET Framework Class Library
HomeDeliveryPremiumDetail Constructor
HomeDeliveryPremiumDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public HomeDeliveryPremiumDetail()
Visual C++
public:
HomeDeliveryPremiumDetail()
JavaScript
InSite.Domain.FedExRateService.HomeDeliveryPremiumDetail = function();

See Also

HomeDeliveryPremiumDetail Class
InSite.Domain.FedExRateService Namespace


HomeDeliveryPremiumDetail Methods

[image] [image]

.NET Framework Class Library
HomeDeliveryPremiumDetail Methods
HomeDeliveryPremiumDetail Class See Also Send Feedback

The HomeDeliveryPremiumDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HomeDeliveryPremiumDetail Class
InSite.Domain.FedExRateService Namespace


HomeDeliveryPremiumDetail Properties

[image] [image]

.NET Framework Class Library
HomeDeliveryPremiumDetail Properties
HomeDeliveryPremiumDetail Class See Also Send Feedback

The HomeDeliveryPremiumDetail type exposes the following members.

Properties

Name | Description
Date |
DateSpecified |
HomeDeliveryPremiumType |
PhoneNumber |

See Also

HomeDeliveryPremiumDetail Class
InSite.Domain.FedExRateService Namespace


Date Property

[image]

.NET Framework Class Library
HomeDeliveryPremiumDetail..::.Date Property
HomeDeliveryPremiumDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Date As DateTime
C#
public DateTime Date { get; set; }
Visual C++
public:
property DateTime Date {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_date();
function set_date(value);

Remarks

See Also

HomeDeliveryPremiumDetail Class
InSite.Domain.FedExRateService Namespace


DateSpecified Property

[image]

.NET Framework Class Library
HomeDeliveryPremiumDetail..::.DateSpecified Property
HomeDeliveryPremiumDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DateSpecified As Boolean
C#
public bool DateSpecified { get; set; }
Visual C++
public:
property bool DateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dateSpecified();
function set_dateSpecified(value);

Remarks

See Also

HomeDeliveryPremiumDetail Class
InSite.Domain.FedExRateService Namespace


HomeDeliveryPremiumType Property

[image]

.NET Framework Class Library
HomeDeliveryPremiumDetail..::.HomeDeliveryPremiumType Property
HomeDeliveryPremiumDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HomeDeliveryPremiumType As HomeDeliveryPremiumType
C#
public HomeDeliveryPremiumType HomeDeliveryPremiumType { get; set; }
Visual C++
public:
property HomeDeliveryPremiumType HomeDeliveryPremiumType {
    HomeDeliveryPremiumType get ();
    void set (HomeDeliveryPremiumType value);
}
JavaScript
function get_homeDeliveryPremiumType();
function set_homeDeliveryPremiumType(value);

Remarks

See Also

HomeDeliveryPremiumDetail Class
InSite.Domain.FedExRateService Namespace


PhoneNumber Property

[image]

.NET Framework Class Library
HomeDeliveryPremiumDetail..::.PhoneNumber Property
HomeDeliveryPremiumDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PhoneNumber As String
C#
public string PhoneNumber { get; set; }
Visual C++
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

HomeDeliveryPremiumDetail Class
InSite.Domain.FedExRateService Namespace


HomeDeliveryPremiumType Enumeration

[image]

.NET Framework Class Library
HomeDeliveryPremiumType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration HomeDeliveryPremiumType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum HomeDeliveryPremiumType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class HomeDeliveryPremiumType
JavaScript
InSite.Domain.FedExRateService.HomeDeliveryPremiumType = function();
InSite.Domain.FedExRateService.HomeDeliveryPremiumType.createEnum('InSite.Domain.FedExRateService.HomeDeliveryPremiumType', false);

Members

Member name | Description
APPOINTMENT |
DATE_CERTAIN |
EVENING |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


InternationalDetail Class

[image]

.NET Framework Class Library
InternationalDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class InternationalDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class InternationalDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class InternationalDetail
JavaScript
InSite.Domain.FedExRateService.InternationalDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.InternationalDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.InternationalDetail

See Also

InternationalDetail Members
InSite.Domain.FedExRateService Namespace


InternationalDetail Members

[image] [image]

.NET Framework Class Library
InternationalDetail Members
InternationalDetail Class Constructors Methods Properties See Also Send Feedback

The InternationalDetail type exposes the following members.

Constructors

Name | Description
InternationalDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Broker |
ClearanceBrokerage |
ClearanceBrokerageSpecified |
CommercialInvoice |
Commodities |
CustomsValue |
DocumentContent |
DocumentContentSpecified |
DutiesPayment |
ExportDetail |
ImporterOfRecord |
InsuranceCharges |
RecipientCustomsIdType |
RecipientCustomsIdTypeSpecified |
RegulatoryControls |

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


InternationalDetail Constructor

[image]

.NET Framework Class Library
InternationalDetail Constructor
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InternationalDetail()
Visual C++
public:
InternationalDetail()
JavaScript
InSite.Domain.FedExRateService.InternationalDetail = function();

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


InternationalDetail Methods

[image] [image]

.NET Framework Class Library
InternationalDetail Methods
InternationalDetail Class See Also Send Feedback

The InternationalDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


InternationalDetail Properties

[image] [image]

.NET Framework Class Library
InternationalDetail Properties
InternationalDetail Class See Also Send Feedback

The InternationalDetail type exposes the following members.

Properties

Name | Description
Broker |
ClearanceBrokerage |
ClearanceBrokerageSpecified |
CommercialInvoice |
Commodities |
CustomsValue |
DocumentContent |
DocumentContentSpecified |
DutiesPayment |
ExportDetail |
ImporterOfRecord |
InsuranceCharges |
RecipientCustomsIdType |
RecipientCustomsIdTypeSpecified |
RegulatoryControls |

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


Broker Property

[image]

.NET Framework Class Library
InternationalDetail..::.Broker Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Broker As Party
C#
public Party Broker { get; set; }
Visual C++
public:
property Party^ Broker {
    Party^ get ();
    void set (Party^ value);
}
JavaScript
function get_broker();
function set_broker(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


ClearanceBrokerage Property

[image]

.NET Framework Class Library
InternationalDetail..::.ClearanceBrokerage Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClearanceBrokerage As ClearanceBrokerageType
C#
public ClearanceBrokerageType ClearanceBrokerage { get; set; }
Visual C++
public:
property ClearanceBrokerageType ClearanceBrokerage {
    ClearanceBrokerageType get ();
    void set (ClearanceBrokerageType value);
}
JavaScript
function get_clearanceBrokerage();
function set_clearanceBrokerage(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


ClearanceBrokerageSpecified Property

[image]

.NET Framework Class Library
InternationalDetail..::.ClearanceBrokerageSpecified Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClearanceBrokerageSpecified As Boolean
C#
public bool ClearanceBrokerageSpecified { get; set; }
Visual C++
public:
property bool ClearanceBrokerageSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_clearanceBrokerageSpecified();
function set_clearanceBrokerageSpecified(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


CommercialInvoice Property

[image]

.NET Framework Class Library
InternationalDetail..::.CommercialInvoice Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CommercialInvoice As CommercialInvoice
C#
public CommercialInvoice CommercialInvoice { get; set; }
Visual C++
public:
property CommercialInvoice^ CommercialInvoice {
    CommercialInvoice^ get ();
    void set (CommercialInvoice^ value);
}
JavaScript
function get_commercialInvoice();
function set_commercialInvoice(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


Commodities Property

[image]

.NET Framework Class Library
InternationalDetail..::.Commodities Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Commodities As Commodity()
C#
public Commodity[] Commodities { get; set; }
Visual C++
public:
property array<Commodity^>^ Commodities {
    array<Commodity^>^ get ();
    void set (array<Commodity^>^ value);
}
JavaScript
function get_commodities();
function set_commodities(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


CustomsValue Property

[image]

.NET Framework Class Library
InternationalDetail..::.CustomsValue Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomsValue As Money
C#
public Money CustomsValue { get; set; }
Visual C++
public:
property Money^ CustomsValue {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_customsValue();
function set_customsValue(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


DocumentContent Property

[image]

.NET Framework Class Library
InternationalDetail..::.DocumentContent Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentContent As InternationalDocumentContentType
C#
public InternationalDocumentContentType DocumentContent { get; set; }
Visual C++
public:
property InternationalDocumentContentType DocumentContent {
    InternationalDocumentContentType get ();
    void set (InternationalDocumentContentType value);
}
JavaScript
function get_documentContent();
function set_documentContent(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


DocumentContentSpecified Property

[image]

.NET Framework Class Library
InternationalDetail..::.DocumentContentSpecified Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentContentSpecified As Boolean
C#
public bool DocumentContentSpecified { get; set; }
Visual C++
public:
property bool DocumentContentSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_documentContentSpecified();
function set_documentContentSpecified(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


DutiesPayment Property

[image]

.NET Framework Class Library
InternationalDetail..::.DutiesPayment Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DutiesPayment As Payment
C#
public Payment DutiesPayment { get; set; }
Visual C++
public:
property Payment^ DutiesPayment {
    Payment^ get ();
    void set (Payment^ value);
}
JavaScript
function get_dutiesPayment();
function set_dutiesPayment(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


ExportDetail Property

[image]

.NET Framework Class Library
InternationalDetail..::.ExportDetail Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExportDetail As ExportDetail
C#
public ExportDetail ExportDetail { get; set; }
Visual C++
public:
property ExportDetail^ ExportDetail {
    ExportDetail^ get ();
    void set (ExportDetail^ value);
}
JavaScript
function get_exportDetail();
function set_exportDetail(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


ImporterOfRecord Property

[image]

.NET Framework Class Library
InternationalDetail..::.ImporterOfRecord Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ImporterOfRecord As Party
C#
public Party ImporterOfRecord { get; set; }
Visual C++
public:
property Party^ ImporterOfRecord {
    Party^ get ();
    void set (Party^ value);
}
JavaScript
function get_importerOfRecord();
function set_importerOfRecord(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


InsuranceCharges Property

[image]

.NET Framework Class Library
InternationalDetail..::.InsuranceCharges Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property InsuranceCharges As Money
C#
public Money InsuranceCharges { get; set; }
Visual C++
public:
property Money^ InsuranceCharges {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_insuranceCharges();
function set_insuranceCharges(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


RecipientCustomsIdType Property

[image]

.NET Framework Class Library
InternationalDetail..::.RecipientCustomsIdType Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RecipientCustomsIdType As RecipientCustomsIdType
C#
public RecipientCustomsIdType RecipientCustomsIdType { get; set; }
Visual C++
public:
property RecipientCustomsIdType RecipientCustomsIdType {
    RecipientCustomsIdType get ();
    void set (RecipientCustomsIdType value);
}
JavaScript
function get_recipientCustomsIdType();
function set_recipientCustomsIdType(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


RecipientCustomsIdTypeSpecified Property

[image]

.NET Framework Class Library
InternationalDetail..::.RecipientCustomsIdTypeSpecified Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RecipientCustomsIdTypeSpecified As Boolean
C#
public bool RecipientCustomsIdTypeSpecified { get; set; }
Visual C++
public:
property bool RecipientCustomsIdTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_recipientCustomsIdTypeSpecified();
function set_recipientCustomsIdTypeSpecified(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


RegulatoryControls Property

[image]

.NET Framework Class Library
InternationalDetail..::.RegulatoryControls Property
InternationalDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RegulatoryControls As RegulatoryControlType()
C#
public RegulatoryControlType[] RegulatoryControls { get; set; }
Visual C++
public:
property array<RegulatoryControlType>^ RegulatoryControls {
    array<RegulatoryControlType>^ get ();
    void set (array<RegulatoryControlType>^ value);
}
JavaScript
function get_regulatoryControls();
function set_regulatoryControls(value);

Remarks

See Also

InternationalDetail Class
InSite.Domain.FedExRateService Namespace


InternationalDocumentContentType Enumeration

[image]

.NET Framework Class Library
InternationalDocumentContentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration InternationalDocumentContentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum InternationalDocumentContentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class InternationalDocumentContentType
JavaScript
InSite.Domain.FedExRateService.InternationalDocumentContentType = function();
InSite.Domain.FedExRateService.InternationalDocumentContentType.createEnum('InSite.Domain.FedExRateService.InternationalDocumentContentType', false);

Members

Member name | Description
DOCUMENTS_ONLY |
NON_DOCUMENTS |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


LabelFormatType Enumeration

[image]

.NET Framework Class Library
LabelFormatType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration LabelFormatType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum LabelFormatType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class LabelFormatType
JavaScript
InSite.Domain.FedExRateService.LabelFormatType = function();
InSite.Domain.FedExRateService.LabelFormatType.createEnum('InSite.Domain.FedExRateService.LabelFormatType', false);

Members

Member name | Description
COMMON2D |
LABEL_DATA_ONLY |
MAILROOM |
NO_LABEL |
PRE_COMMON2D |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


LabelMaskableDataType Enumeration

[image]

.NET Framework Class Library
LabelMaskableDataType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration LabelMaskableDataType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum LabelMaskableDataType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class LabelMaskableDataType
JavaScript
InSite.Domain.FedExRateService.LabelMaskableDataType = function();
InSite.Domain.FedExRateService.LabelMaskableDataType.createEnum('InSite.Domain.FedExRateService.LabelMaskableDataType', false);

Members

Member name | Description
CUSTOMS_VALUE |
DIMENSIONS |
DUTIES_AND_TAXES_PAYOR_ACCOUNT_NUMBER |
FREIGHT_PAYOR_ACCOUNT_NUMBER |
PACKAGE_SEQUENCE_AND_COUNT |
SHIPPER_ACCOUNT_NUMBER |
SUPPLEMENTAL_LABEL_DOC_TAB |
TERMS_AND_CONDITIONS |
TOTAL_WEIGHT |
TRANSPORTATION_CHARGES_PAYOR_ACCOUNT_NUMBER |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


LabelPrintingOrientationType Enumeration

[image]

.NET Framework Class Library
LabelPrintingOrientationType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration LabelPrintingOrientationType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum LabelPrintingOrientationType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class LabelPrintingOrientationType
JavaScript
InSite.Domain.FedExRateService.LabelPrintingOrientationType = function();
InSite.Domain.FedExRateService.LabelPrintingOrientationType.createEnum('InSite.Domain.FedExRateService.LabelPrintingOrientationType', false);

Members

Member name | Description
BOTTOM_EDGE_OF_TEXT_FIRST |
TOP_EDGE_OF_TEXT_FIRST |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


LabelRotationType Enumeration

[image]

.NET Framework Class Library
LabelRotationType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration LabelRotationType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum LabelRotationType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class LabelRotationType
JavaScript
InSite.Domain.FedExRateService.LabelRotationType = function();
InSite.Domain.FedExRateService.LabelRotationType.createEnum('InSite.Domain.FedExRateService.LabelRotationType', false);

Members

Member name | Description
NONE |
RIGHT |
UPSIDE_DOWN |
LEFT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


LabelSpecification Class

[image]

.NET Framework Class Library
LabelSpecification Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class LabelSpecification
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class LabelSpecification
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class LabelSpecification
JavaScript
InSite.Domain.FedExRateService.LabelSpecification = function();

Type.createClass(
    'InSite.Domain.FedExRateService.LabelSpecification');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.LabelSpecification

See Also

LabelSpecification Members
InSite.Domain.FedExRateService Namespace


LabelSpecification Members

[image] [image]

.NET Framework Class Library
LabelSpecification Members
LabelSpecification Class Constructors Methods Properties See Also Send Feedback

The LabelSpecification type exposes the following members.

Constructors

Name | Description
LabelSpecification |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerSpecifiedDetail |
ImageType |
ImageTypeSpecified |
LabelFormatType |
LabelFormatTypeSpecified |
LabelPrintingOrientation |
LabelPrintingOrientationSpecified |
LabelRotation |
LabelRotationSpecified |
LabelStockType |
LabelStockTypeSpecified |
PrintedLabelOrigin |

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelSpecification Constructor

[image]

.NET Framework Class Library
LabelSpecification Constructor
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LabelSpecification()
Visual C++
public:
LabelSpecification()
JavaScript
InSite.Domain.FedExRateService.LabelSpecification = function();

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelSpecification Methods

[image] [image]

.NET Framework Class Library
LabelSpecification Methods
LabelSpecification Class See Also Send Feedback

The LabelSpecification type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelSpecification Properties

[image] [image]

.NET Framework Class Library
LabelSpecification Properties
LabelSpecification Class See Also Send Feedback

The LabelSpecification type exposes the following members.

Properties

Name | Description
CustomerSpecifiedDetail |
ImageType |
ImageTypeSpecified |
LabelFormatType |
LabelFormatTypeSpecified |
LabelPrintingOrientation |
LabelPrintingOrientationSpecified |
LabelRotation |
LabelRotationSpecified |
LabelStockType |
LabelStockTypeSpecified |
PrintedLabelOrigin |

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


CustomerSpecifiedDetail Property

[image]

.NET Framework Class Library
LabelSpecification..::.CustomerSpecifiedDetail Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerSpecifiedDetail As CustomerSpecifiedLabelDetail
C#
public CustomerSpecifiedLabelDetail CustomerSpecifiedDetail { get; set; }
Visual C++
public:
property CustomerSpecifiedLabelDetail^ CustomerSpecifiedDetail {
    CustomerSpecifiedLabelDetail^ get ();
    void set (CustomerSpecifiedLabelDetail^ value);
}
JavaScript
function get_customerSpecifiedDetail();
function set_customerSpecifiedDetail(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


ImageType Property

[image]

.NET Framework Class Library
LabelSpecification..::.ImageType Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageType As ShippingDocumentImageType
C#
public ShippingDocumentImageType ImageType { get; set; }
Visual C++
public:
property ShippingDocumentImageType ImageType {
    ShippingDocumentImageType get ();
    void set (ShippingDocumentImageType value);
}
JavaScript
function get_imageType();
function set_imageType(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


ImageTypeSpecified Property

[image]

.NET Framework Class Library
LabelSpecification..::.ImageTypeSpecified Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageTypeSpecified As Boolean
C#
public bool ImageTypeSpecified { get; set; }
Visual C++
public:
property bool ImageTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_imageTypeSpecified();
function set_imageTypeSpecified(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelFormatType Property

[image]

.NET Framework Class Library
LabelSpecification..::.LabelFormatType Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelFormatType As LabelFormatType
C#
public LabelFormatType LabelFormatType { get; set; }
Visual C++
public:
property LabelFormatType LabelFormatType {
    LabelFormatType get ();
    void set (LabelFormatType value);
}
JavaScript
function get_labelFormatType();
function set_labelFormatType(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelFormatTypeSpecified Property

[image]

.NET Framework Class Library
LabelSpecification..::.LabelFormatTypeSpecified Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelFormatTypeSpecified As Boolean
C#
public bool LabelFormatTypeSpecified { get; set; }
Visual C++
public:
property bool LabelFormatTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_labelFormatTypeSpecified();
function set_labelFormatTypeSpecified(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelPrintingOrientation Property

[image]

.NET Framework Class Library
LabelSpecification..::.LabelPrintingOrientation Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelPrintingOrientation As LabelPrintingOrientationType
C#
public LabelPrintingOrientationType LabelPrintingOrientation { get; set; }
Visual C++
public:
property LabelPrintingOrientationType LabelPrintingOrientation {
    LabelPrintingOrientationType get ();
    void set (LabelPrintingOrientationType value);
}
JavaScript
function get_labelPrintingOrientation();
function set_labelPrintingOrientation(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelPrintingOrientationSpecified Property

[image]

.NET Framework Class Library
LabelSpecification..::.LabelPrintingOrientationSpecified Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelPrintingOrientationSpecified As Boolean
C#
public bool LabelPrintingOrientationSpecified { get; set; }
Visual C++
public:
property bool LabelPrintingOrientationSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_labelPrintingOrientationSpecified();
function set_labelPrintingOrientationSpecified(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelRotation Property

[image]

.NET Framework Class Library
LabelSpecification..::.LabelRotation Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelRotation As LabelRotationType
C#
public LabelRotationType LabelRotation { get; set; }
Visual C++
public:
property LabelRotationType LabelRotation {
    LabelRotationType get ();
    void set (LabelRotationType value);
}
JavaScript
function get_labelRotation();
function set_labelRotation(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelRotationSpecified Property

[image]

.NET Framework Class Library
LabelSpecification..::.LabelRotationSpecified Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelRotationSpecified As Boolean
C#
public bool LabelRotationSpecified { get; set; }
Visual C++
public:
property bool LabelRotationSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_labelRotationSpecified();
function set_labelRotationSpecified(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelStockType Property

[image]

.NET Framework Class Library
LabelSpecification..::.LabelStockType Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelStockType As LabelStockType
C#
public LabelStockType LabelStockType { get; set; }
Visual C++
public:
property LabelStockType LabelStockType {
    LabelStockType get ();
    void set (LabelStockType value);
}
JavaScript
function get_labelStockType();
function set_labelStockType(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelStockTypeSpecified Property

[image]

.NET Framework Class Library
LabelSpecification..::.LabelStockTypeSpecified Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelStockTypeSpecified As Boolean
C#
public bool LabelStockTypeSpecified { get; set; }
Visual C++
public:
property bool LabelStockTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_labelStockTypeSpecified();
function set_labelStockTypeSpecified(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


PrintedLabelOrigin Property

[image]

.NET Framework Class Library
LabelSpecification..::.PrintedLabelOrigin Property
LabelSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PrintedLabelOrigin As ContactAndAddress
C#
public ContactAndAddress PrintedLabelOrigin { get; set; }
Visual C++
public:
property ContactAndAddress^ PrintedLabelOrigin {
    ContactAndAddress^ get ();
    void set (ContactAndAddress^ value);
}
JavaScript
function get_printedLabelOrigin();
function set_printedLabelOrigin(value);

Remarks

See Also

LabelSpecification Class
InSite.Domain.FedExRateService Namespace


LabelStockType Enumeration

[image]

.NET Framework Class Library
LabelStockType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration LabelStockType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum LabelStockType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class LabelStockType
JavaScript
InSite.Domain.FedExRateService.LabelStockType = function();
InSite.Domain.FedExRateService.LabelStockType.createEnum('InSite.Domain.FedExRateService.LabelStockType', false);

Members

Member name | Description
PAPER_4X6 |
PAPER_4X8 |
PAPER_4X9 |
PAPER_7X475 |
PAPER_85X11_BOTTOM_HALF_LABEL |
PAPER_85X11_TOP_HALF_LABEL |
STOCK_4X6 |
STOCK_4X675_LEADING_DOC_TAB |
STOCK_4X675_TRAILING_DOC_TAB |
STOCK_4X8 |
STOCK_4X9_LEADING_DOC_TAB |
STOCK_4X9_TRAILING_DOC_TAB |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


LinearUnits Enumeration

[image]

.NET Framework Class Library
LinearUnits Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration LinearUnits
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum LinearUnits
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class LinearUnits
JavaScript
InSite.Domain.FedExRateService.LinearUnits = function();
InSite.Domain.FedExRateService.LinearUnits.createEnum('InSite.Domain.FedExRateService.LinearUnits', false);

Members

Member name | Description
CM |
IN |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Localization Class

[image]

.NET Framework Class Library
Localization Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Localization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Localization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Localization
JavaScript
InSite.Domain.FedExRateService.Localization = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Localization');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Localization

See Also

Localization Members
InSite.Domain.FedExRateService Namespace


Localization Members

[image] [image]

.NET Framework Class Library
Localization Members
Localization Class Constructors Methods Properties See Also Send Feedback

The Localization type exposes the following members.

Constructors

Name | Description
Localization |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LanguageCode |
LocaleCode |

See Also

Localization Class
InSite.Domain.FedExRateService Namespace


Localization Constructor

[image]

.NET Framework Class Library
Localization Constructor
Localization Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Localization()
Visual C++
public:
Localization()
JavaScript
InSite.Domain.FedExRateService.Localization = function();

See Also

Localization Class
InSite.Domain.FedExRateService Namespace


Localization Methods

[image] [image]

.NET Framework Class Library
Localization Methods
Localization Class See Also Send Feedback

The Localization type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Localization Class
InSite.Domain.FedExRateService Namespace


Localization Properties

[image] [image]

.NET Framework Class Library
Localization Properties
Localization Class See Also Send Feedback

The Localization type exposes the following members.

Properties

Name | Description
LanguageCode |
LocaleCode |

See Also

Localization Class
InSite.Domain.FedExRateService Namespace


LanguageCode Property

[image]

.NET Framework Class Library
Localization..::.LanguageCode Property
Localization Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LanguageCode As String
C#
public string LanguageCode { get; set; }
Visual C++
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_languageCode();
function set_languageCode(value);

Remarks

See Also

Localization Class
InSite.Domain.FedExRateService Namespace


LocaleCode Property

[image]

.NET Framework Class Library
Localization..::.LocaleCode Property
Localization Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocaleCode As String
C#
public string LocaleCode { get; set; }
Visual C++
public:
property String^ LocaleCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_localeCode();
function set_localeCode(value);

Remarks

See Also

Localization Class
InSite.Domain.FedExRateService Namespace


Measure Class

[image]

.NET Framework Class Library
Measure Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Measure
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Measure
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Measure
JavaScript
InSite.Domain.FedExRateService.Measure = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Measure');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Measure

See Also

Measure Members
InSite.Domain.FedExRateService Namespace


Measure Members

[image] [image]

.NET Framework Class Library
Measure Members
Measure Class Constructors Methods Properties See Also Send Feedback

The Measure type exposes the following members.

Constructors

Name | Description
Measure |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Quantity |
QuantitySpecified |
Units |

See Also

Measure Class
InSite.Domain.FedExRateService Namespace


Measure Constructor

[image]

.NET Framework Class Library
Measure Constructor
Measure Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Measure()
Visual C++
public:
Measure()
JavaScript
InSite.Domain.FedExRateService.Measure = function();

See Also

Measure Class
InSite.Domain.FedExRateService Namespace


Measure Methods

[image] [image]

.NET Framework Class Library
Measure Methods
Measure Class See Also Send Feedback

The Measure type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Measure Class
InSite.Domain.FedExRateService Namespace


Measure Properties

[image] [image]

.NET Framework Class Library
Measure Properties
Measure Class See Also Send Feedback

The Measure type exposes the following members.

Properties

Name | Description
Quantity |
QuantitySpecified |
Units |

See Also

Measure Class
InSite.Domain.FedExRateService Namespace


Quantity Property

[image]

.NET Framework Class Library
Measure..::.Quantity Property
Measure Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Quantity As Decimal
C#
public decimal Quantity { get; set; }
Visual C++
public:
property Decimal Quantity {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_quantity();
function set_quantity(value);

Remarks

See Also

Measure Class
InSite.Domain.FedExRateService Namespace


QuantitySpecified Property

[image]

.NET Framework Class Library
Measure..::.QuantitySpecified Property
Measure Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property QuantitySpecified As Boolean
C#
public bool QuantitySpecified { get; set; }
Visual C++
public:
property bool QuantitySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_quantitySpecified();
function set_quantitySpecified(value);

Remarks

See Also

Measure Class
InSite.Domain.FedExRateService Namespace


Units Property

[image]

.NET Framework Class Library
Measure..::.Units Property
Measure Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As String
C#
public string Units { get; set; }
Visual C++
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_units();
function set_units(value);

Remarks

See Also

Measure Class
InSite.Domain.FedExRateService Namespace


MinimumChargeType Enumeration

[image]

.NET Framework Class Library
MinimumChargeType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration MinimumChargeType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum MinimumChargeType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class MinimumChargeType
JavaScript
InSite.Domain.FedExRateService.MinimumChargeType = function();
InSite.Domain.FedExRateService.MinimumChargeType.createEnum('InSite.Domain.FedExRateService.MinimumChargeType', false);

Members

Member name | Description
CUSTOMER |
CUSTOMER_FREIGHT_WEIGHT |
EARNED_DISCOUNT |
RATE_SCALE |
MIXED |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Money Class

[image]

.NET Framework Class Library
Money Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Money
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Money
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Money
JavaScript
InSite.Domain.FedExRateService.Money = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Money');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Money

See Also

Money Members
InSite.Domain.FedExRateService Namespace


Money Members

[image] [image]

.NET Framework Class Library
Money Members
Money Class Constructors Methods Properties See Also Send Feedback

The Money type exposes the following members.

Constructors

Name | Description
Money |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Currency |

See Also

Money Class
InSite.Domain.FedExRateService Namespace


Money Constructor

[image]

.NET Framework Class Library
Money Constructor
Money Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Money()
Visual C++
public:
Money()
JavaScript
InSite.Domain.FedExRateService.Money = function();

See Also

Money Class
InSite.Domain.FedExRateService Namespace


Money Methods

[image] [image]

.NET Framework Class Library
Money Methods
Money Class See Also Send Feedback

The Money type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Money Class
InSite.Domain.FedExRateService Namespace


Money Properties

[image] [image]

.NET Framework Class Library
Money Properties
Money Class See Also Send Feedback

The Money type exposes the following members.

Properties

Name | Description
Amount |
Currency |

See Also

Money Class
InSite.Domain.FedExRateService Namespace


Amount Property

[image]

.NET Framework Class Library
Money..::.Amount Property
Money Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As Decimal
C#
public decimal Amount { get; set; }
Visual C++
public:
property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

Money Class
InSite.Domain.FedExRateService Namespace


Currency Property

[image]

.NET Framework Class Library
Money..::.Currency Property
Money Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Currency As String
C#
public string Currency { get; set; }
Visual C++
public:
property String^ Currency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currency();
function set_currency(value);

Remarks

See Also

Money Class
InSite.Domain.FedExRateService Namespace


NaftaCertificateOfOriginDetail Class

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class NaftaCertificateOfOriginDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class NaftaCertificateOfOriginDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class NaftaCertificateOfOriginDetail
JavaScript
InSite.Domain.FedExRateService.NaftaCertificateOfOriginDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.NaftaCertificateOfOriginDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.NaftaCertificateOfOriginDetail

See Also

NaftaCertificateOfOriginDetail Members
InSite.Domain.FedExRateService Namespace


NaftaCertificateOfOriginDetail Members

[image] [image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail Members
NaftaCertificateOfOriginDetail Class Constructors Methods Properties See Also Send Feedback

The NaftaCertificateOfOriginDetail type exposes the following members.

Constructors

Name | Description
NaftaCertificateOfOriginDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BlanketPeriod |
CustomerImageUsages |
Format |
ImporterSpecification |
ImporterSpecificationSpecified |
Producers |
ProducerSpecification |
ProducerSpecificationSpecified |
SignatureContact |

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


NaftaCertificateOfOriginDetail Constructor

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail Constructor
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NaftaCertificateOfOriginDetail()
Visual C++
public:
NaftaCertificateOfOriginDetail()
JavaScript
InSite.Domain.FedExRateService.NaftaCertificateOfOriginDetail = function();

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


NaftaCertificateOfOriginDetail Methods

[image] [image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail Methods
NaftaCertificateOfOriginDetail Class See Also Send Feedback

The NaftaCertificateOfOriginDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


NaftaCertificateOfOriginDetail Properties

[image] [image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail Properties
NaftaCertificateOfOriginDetail Class See Also Send Feedback

The NaftaCertificateOfOriginDetail type exposes the following members.

Properties

Name | Description
BlanketPeriod |
CustomerImageUsages |
Format |
ImporterSpecification |
ImporterSpecificationSpecified |
Producers |
ProducerSpecification |
ProducerSpecificationSpecified |
SignatureContact |

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


BlanketPeriod Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.BlanketPeriod Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BlanketPeriod As DateRange
C#
public DateRange BlanketPeriod { get; set; }
Visual C++
public:
property DateRange^ BlanketPeriod {
    DateRange^ get ();
    void set (DateRange^ value);
}
JavaScript
function get_blanketPeriod();
function set_blanketPeriod(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


CustomerImageUsages Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.CustomerImageUsages Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerImageUsages As CustomerImageUsage()
C#
public CustomerImageUsage[] CustomerImageUsages { get; set; }
Visual C++
public:
property array<CustomerImageUsage^>^ CustomerImageUsages {
    array<CustomerImageUsage^>^ get ();
    void set (array<CustomerImageUsage^>^ value);
}
JavaScript
function get_customerImageUsages();
function set_customerImageUsages(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


Format Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.Format Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Format As ShippingDocumentFormat
C#
public ShippingDocumentFormat Format { get; set; }
Visual C++
public:
property ShippingDocumentFormat^ Format {
    ShippingDocumentFormat^ get ();
    void set (ShippingDocumentFormat^ value);
}
JavaScript
function get_format();
function set_format(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


ImporterSpecification Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.ImporterSpecification Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ImporterSpecification As NaftaImporterSpecificationType
C#
public NaftaImporterSpecificationType ImporterSpecification { get; set; }
Visual C++
public:
property NaftaImporterSpecificationType ImporterSpecification {
    NaftaImporterSpecificationType get ();
    void set (NaftaImporterSpecificationType value);
}
JavaScript
function get_importerSpecification();
function set_importerSpecification(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


ImporterSpecificationSpecified Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.ImporterSpecificationSpecified Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ImporterSpecificationSpecified As Boolean
C#
public bool ImporterSpecificationSpecified { get; set; }
Visual C++
public:
property bool ImporterSpecificationSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_importerSpecificationSpecified();
function set_importerSpecificationSpecified(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


Producers Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.Producers Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Producers As NaftaProducer()
C#
public NaftaProducer[] Producers { get; set; }
Visual C++
public:
property array<NaftaProducer^>^ Producers {
    array<NaftaProducer^>^ get ();
    void set (array<NaftaProducer^>^ value);
}
JavaScript
function get_producers();
function set_producers(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


ProducerSpecification Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.ProducerSpecification Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProducerSpecification As NaftaProducerSpecificationType
C#
public NaftaProducerSpecificationType ProducerSpecification { get; set; }
Visual C++
public:
property NaftaProducerSpecificationType ProducerSpecification {
    NaftaProducerSpecificationType get ();
    void set (NaftaProducerSpecificationType value);
}
JavaScript
function get_producerSpecification();
function set_producerSpecification(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


ProducerSpecificationSpecified Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.ProducerSpecificationSpecified Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProducerSpecificationSpecified As Boolean
C#
public bool ProducerSpecificationSpecified { get; set; }
Visual C++
public:
property bool ProducerSpecificationSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_producerSpecificationSpecified();
function set_producerSpecificationSpecified(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


SignatureContact Property

[image]

.NET Framework Class Library
NaftaCertificateOfOriginDetail..::.SignatureContact Property
NaftaCertificateOfOriginDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SignatureContact As Contact
C#
public Contact SignatureContact { get; set; }
Visual C++
public:
property Contact^ SignatureContact {
    Contact^ get ();
    void set (Contact^ value);
}
JavaScript
function get_signatureContact();
function set_signatureContact(value);

Remarks

See Also

NaftaCertificateOfOriginDetail Class
InSite.Domain.FedExRateService Namespace


NaftaCommodityDetail Class

[image]

.NET Framework Class Library
NaftaCommodityDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class NaftaCommodityDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class NaftaCommodityDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class NaftaCommodityDetail
JavaScript
InSite.Domain.FedExRateService.NaftaCommodityDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.NaftaCommodityDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.NaftaCommodityDetail

See Also

NaftaCommodityDetail Members
InSite.Domain.FedExRateService Namespace


NaftaCommodityDetail Members

[image] [image]

.NET Framework Class Library
NaftaCommodityDetail Members
NaftaCommodityDetail Class Constructors Methods Properties See Also Send Feedback

The NaftaCommodityDetail type exposes the following members.

Constructors

Name | Description
NaftaCommodityDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NetCostDateRange |
NetCostMethod |
NetCostMethodSpecified |
PreferenceCriterion |
PreferenceCriterionSpecified |
ProducerDetermination |
ProducerDeterminationSpecified |
ProducerId |

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


NaftaCommodityDetail Constructor

[image]

.NET Framework Class Library
NaftaCommodityDetail Constructor
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NaftaCommodityDetail()
Visual C++
public:
NaftaCommodityDetail()
JavaScript
InSite.Domain.FedExRateService.NaftaCommodityDetail = function();

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


NaftaCommodityDetail Methods

[image] [image]

.NET Framework Class Library
NaftaCommodityDetail Methods
NaftaCommodityDetail Class See Also Send Feedback

The NaftaCommodityDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


NaftaCommodityDetail Properties

[image] [image]

.NET Framework Class Library
NaftaCommodityDetail Properties
NaftaCommodityDetail Class See Also Send Feedback

The NaftaCommodityDetail type exposes the following members.

Properties

Name | Description
NetCostDateRange |
NetCostMethod |
NetCostMethodSpecified |
PreferenceCriterion |
PreferenceCriterionSpecified |
ProducerDetermination |
ProducerDeterminationSpecified |
ProducerId |

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


NetCostDateRange Property

[image]

.NET Framework Class Library
NaftaCommodityDetail..::.NetCostDateRange Property
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NetCostDateRange As DateRange
C#
public DateRange NetCostDateRange { get; set; }
Visual C++
public:
property DateRange^ NetCostDateRange {
    DateRange^ get ();
    void set (DateRange^ value);
}
JavaScript
function get_netCostDateRange();
function set_netCostDateRange(value);

Remarks

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


NetCostMethod Property

[image]

.NET Framework Class Library
NaftaCommodityDetail..::.NetCostMethod Property
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NetCostMethod As NaftaNetCostMethodCode
C#
public NaftaNetCostMethodCode NetCostMethod { get; set; }
Visual C++
public:
property NaftaNetCostMethodCode NetCostMethod {
    NaftaNetCostMethodCode get ();
    void set (NaftaNetCostMethodCode value);
}
JavaScript
function get_netCostMethod();
function set_netCostMethod(value);

Remarks

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


NetCostMethodSpecified Property

[image]

.NET Framework Class Library
NaftaCommodityDetail..::.NetCostMethodSpecified Property
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NetCostMethodSpecified As Boolean
C#
public bool NetCostMethodSpecified { get; set; }
Visual C++
public:
property bool NetCostMethodSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_netCostMethodSpecified();
function set_netCostMethodSpecified(value);

Remarks

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


PreferenceCriterion Property

[image]

.NET Framework Class Library
NaftaCommodityDetail..::.PreferenceCriterion Property
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PreferenceCriterion As NaftaPreferenceCriterionCode
C#
public NaftaPreferenceCriterionCode PreferenceCriterion { get; set; }
Visual C++
public:
property NaftaPreferenceCriterionCode PreferenceCriterion {
    NaftaPreferenceCriterionCode get ();
    void set (NaftaPreferenceCriterionCode value);
}
JavaScript
function get_preferenceCriterion();
function set_preferenceCriterion(value);

Remarks

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


PreferenceCriterionSpecified Property

[image]

.NET Framework Class Library
NaftaCommodityDetail..::.PreferenceCriterionSpecified Property
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PreferenceCriterionSpecified As Boolean
C#
public bool PreferenceCriterionSpecified { get; set; }
Visual C++
public:
property bool PreferenceCriterionSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_preferenceCriterionSpecified();
function set_preferenceCriterionSpecified(value);

Remarks

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


ProducerDetermination Property

[image]

.NET Framework Class Library
NaftaCommodityDetail..::.ProducerDetermination Property
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProducerDetermination As NaftaProducerDeterminationCode
C#
public NaftaProducerDeterminationCode ProducerDetermination { get; set; }
Visual C++
public:
property NaftaProducerDeterminationCode ProducerDetermination {
    NaftaProducerDeterminationCode get ();
    void set (NaftaProducerDeterminationCode value);
}
JavaScript
function get_producerDetermination();
function set_producerDetermination(value);

Remarks

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


ProducerDeterminationSpecified Property

[image]

.NET Framework Class Library
NaftaCommodityDetail..::.ProducerDeterminationSpecified Property
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProducerDeterminationSpecified As Boolean
C#
public bool ProducerDeterminationSpecified { get; set; }
Visual C++
public:
property bool ProducerDeterminationSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_producerDeterminationSpecified();
function set_producerDeterminationSpecified(value);

Remarks

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


ProducerId Property

[image]

.NET Framework Class Library
NaftaCommodityDetail..::.ProducerId Property
NaftaCommodityDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProducerId As String
C#
public string ProducerId { get; set; }
Visual C++
public:
property String^ ProducerId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_producerId();
function set_producerId(value);

Remarks

See Also

NaftaCommodityDetail Class
InSite.Domain.FedExRateService Namespace


NaftaImporterSpecificationType Enumeration

[image]

.NET Framework Class Library
NaftaImporterSpecificationType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration NaftaImporterSpecificationType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum NaftaImporterSpecificationType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class NaftaImporterSpecificationType
JavaScript
InSite.Domain.FedExRateService.NaftaImporterSpecificationType = function();
InSite.Domain.FedExRateService.NaftaImporterSpecificationType.createEnum('InSite.Domain.FedExRateService.NaftaImporterSpecificationType', false);

Members

Member name | Description
IMPORTER_OF_RECORD |
RECIPIENT |
UNKNOWN |
VARIOUS |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


NaftaNetCostMethodCode Enumeration

[image]

.NET Framework Class Library
NaftaNetCostMethodCode Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration NaftaNetCostMethodCode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum NaftaNetCostMethodCode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class NaftaNetCostMethodCode
JavaScript
InSite.Domain.FedExRateService.NaftaNetCostMethodCode = function();
InSite.Domain.FedExRateService.NaftaNetCostMethodCode.createEnum('InSite.Domain.FedExRateService.NaftaNetCostMethodCode', false);

Members

Member name | Description
NC |
NO |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


NaftaPreferenceCriterionCode Enumeration

[image]

.NET Framework Class Library
NaftaPreferenceCriterionCode Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration NaftaPreferenceCriterionCode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum NaftaPreferenceCriterionCode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class NaftaPreferenceCriterionCode
JavaScript
InSite.Domain.FedExRateService.NaftaPreferenceCriterionCode = function();
InSite.Domain.FedExRateService.NaftaPreferenceCriterionCode.createEnum('InSite.Domain.FedExRateService.NaftaPreferenceCriterionCode', false);

Members

Member name | Description
A |
B |
C |
D |
E |
F |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


NaftaProducer Class

[image]

.NET Framework Class Library
NaftaProducer Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class NaftaProducer
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class NaftaProducer
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class NaftaProducer
JavaScript
InSite.Domain.FedExRateService.NaftaProducer = function();

Type.createClass(
    'InSite.Domain.FedExRateService.NaftaProducer');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.NaftaProducer

See Also

NaftaProducer Members
InSite.Domain.FedExRateService Namespace


NaftaProducer Members

[image] [image]

.NET Framework Class Library
NaftaProducer Members
NaftaProducer Class Constructors Methods Properties See Also Send Feedback

The NaftaProducer type exposes the following members.

Constructors

Name | Description
NaftaProducer |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Producer |

See Also

NaftaProducer Class
InSite.Domain.FedExRateService Namespace


NaftaProducer Constructor

[image]

.NET Framework Class Library
NaftaProducer Constructor
NaftaProducer Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NaftaProducer()
Visual C++
public:
NaftaProducer()
JavaScript
InSite.Domain.FedExRateService.NaftaProducer = function();

See Also

NaftaProducer Class
InSite.Domain.FedExRateService Namespace


NaftaProducer Methods

[image] [image]

.NET Framework Class Library
NaftaProducer Methods
NaftaProducer Class See Also Send Feedback

The NaftaProducer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NaftaProducer Class
InSite.Domain.FedExRateService Namespace


NaftaProducer Properties

[image] [image]

.NET Framework Class Library
NaftaProducer Properties
NaftaProducer Class See Also Send Feedback

The NaftaProducer type exposes the following members.

Properties

Name | Description
Id |
Producer |

See Also

NaftaProducer Class
InSite.Domain.FedExRateService Namespace


Id Property

[image]

.NET Framework Class Library
NaftaProducer..::.Id Property
NaftaProducer Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id { get; set; }
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

NaftaProducer Class
InSite.Domain.FedExRateService Namespace


Producer Property

[image]

.NET Framework Class Library
NaftaProducer..::.Producer Property
NaftaProducer Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Producer As Party
C#
public Party Producer { get; set; }
Visual C++
public:
property Party^ Producer {
    Party^ get ();
    void set (Party^ value);
}
JavaScript
function get_producer();
function set_producer(value);

Remarks

See Also

NaftaProducer Class
InSite.Domain.FedExRateService Namespace


NaftaProducerDeterminationCode Enumeration

[image]

.NET Framework Class Library
NaftaProducerDeterminationCode Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration NaftaProducerDeterminationCode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum NaftaProducerDeterminationCode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class NaftaProducerDeterminationCode
JavaScript
InSite.Domain.FedExRateService.NaftaProducerDeterminationCode = function();
InSite.Domain.FedExRateService.NaftaProducerDeterminationCode.createEnum('InSite.Domain.FedExRateService.NaftaProducerDeterminationCode', false);

Members

Member name | Description
NO_1 |
NO_2 |
NO_3 |
YES |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


NaftaProducerSpecificationType Enumeration

[image]

.NET Framework Class Library
NaftaProducerSpecificationType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration NaftaProducerSpecificationType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum NaftaProducerSpecificationType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class NaftaProducerSpecificationType
JavaScript
InSite.Domain.FedExRateService.NaftaProducerSpecificationType = function();
InSite.Domain.FedExRateService.NaftaProducerSpecificationType.createEnum('InSite.Domain.FedExRateService.NaftaProducerSpecificationType', false);

Members

Member name | Description
AVAILABLE_UPON_REQUEST |
MULTIPLE_SPECIFIED |
SAME |
SINGLE_SPECIFIED |
UNKNOWN |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Notification Class

[image]

.NET Framework Class Library
Notification Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Notification
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Notification
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Notification
JavaScript
InSite.Domain.FedExRateService.Notification = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Notification');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Notification

See Also

Notification Members
InSite.Domain.FedExRateService Namespace


Notification Members

[image] [image]

.NET Framework Class Library
Notification Members
Notification Class Constructors Methods Properties See Also Send Feedback

The Notification type exposes the following members.

Constructors

Name | Description
Notification |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Code |
LocalizedMessage |
Message |
MessageParameters |
Severity |
Source |

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


Notification Constructor

[image]

.NET Framework Class Library
Notification Constructor
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Notification()
Visual C++
public:
Notification()
JavaScript
InSite.Domain.FedExRateService.Notification = function();

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


Notification Methods

[image] [image]

.NET Framework Class Library
Notification Methods
Notification Class See Also Send Feedback

The Notification type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


Notification Properties

[image] [image]

.NET Framework Class Library
Notification Properties
Notification Class See Also Send Feedback

The Notification type exposes the following members.

Properties

Name | Description
Code |
LocalizedMessage |
Message |
MessageParameters |
Severity |
Source |

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


Code Property

[image]

.NET Framework Class Library
Notification..::.Code Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code { get; set; }
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_code();
function set_code(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


LocalizedMessage Property

[image]

.NET Framework Class Library
Notification..::.LocalizedMessage Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalizedMessage As String
C#
public string LocalizedMessage { get; set; }
Visual C++
public:
property String^ LocalizedMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_localizedMessage();
function set_localizedMessage(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


Message Property

[image]

.NET Framework Class Library
Notification..::.Message Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message { get; set; }
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_message();
function set_message(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


MessageParameters Property

[image]

.NET Framework Class Library
Notification..::.MessageParameters Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageParameters As NotificationParameter()
C#
public NotificationParameter[] MessageParameters { get; set; }
Visual C++
public:
property array<NotificationParameter^>^ MessageParameters {
    array<NotificationParameter^>^ get ();
    void set (array<NotificationParameter^>^ value);
}
JavaScript
function get_messageParameters();
function set_messageParameters(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


Severity Property

[image]

.NET Framework Class Library
Notification..::.Severity Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Severity As NotificationSeverityType
C#
public NotificationSeverityType Severity { get; set; }
Visual C++
public:
property NotificationSeverityType Severity {
    NotificationSeverityType get ();
    void set (NotificationSeverityType value);
}
JavaScript
function get_severity();
function set_severity(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


Source Property

[image]

.NET Framework Class Library
Notification..::.Source Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Source As String
C#
public string Source { get; set; }
Visual C++
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_source();
function set_source(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRateService Namespace


NotificationParameter Class

[image]

.NET Framework Class Library
NotificationParameter Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class NotificationParameter
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class NotificationParameter
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class NotificationParameter
JavaScript
InSite.Domain.FedExRateService.NotificationParameter = function();

Type.createClass(
    'InSite.Domain.FedExRateService.NotificationParameter');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.NotificationParameter

See Also

NotificationParameter Members
InSite.Domain.FedExRateService Namespace


NotificationParameter Members

[image] [image]

.NET Framework Class Library
NotificationParameter Members
NotificationParameter Class Constructors Methods Properties See Also Send Feedback

The NotificationParameter type exposes the following members.

Constructors

Name | Description
NotificationParameter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Value |

See Also

NotificationParameter Class
InSite.Domain.FedExRateService Namespace


NotificationParameter Constructor

[image]

.NET Framework Class Library
NotificationParameter Constructor
NotificationParameter Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NotificationParameter()
Visual C++
public:
NotificationParameter()
JavaScript
InSite.Domain.FedExRateService.NotificationParameter = function();

See Also

NotificationParameter Class
InSite.Domain.FedExRateService Namespace


NotificationParameter Methods

[image] [image]

.NET Framework Class Library
NotificationParameter Methods
NotificationParameter Class See Also Send Feedback

The NotificationParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationParameter Class
InSite.Domain.FedExRateService Namespace


NotificationParameter Properties

[image] [image]

.NET Framework Class Library
NotificationParameter Properties
NotificationParameter Class See Also Send Feedback

The NotificationParameter type exposes the following members.

Properties

Name | Description
Id |
Value |

See Also

NotificationParameter Class
InSite.Domain.FedExRateService Namespace


Id Property

[image]

.NET Framework Class Library
NotificationParameter..::.Id Property
NotificationParameter Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id { get; set; }
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

NotificationParameter Class
InSite.Domain.FedExRateService Namespace


Value Property

[image]

.NET Framework Class Library
NotificationParameter..::.Value Property
NotificationParameter Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

NotificationParameter Class
InSite.Domain.FedExRateService Namespace


NotificationSeverityType Enumeration

[image]

.NET Framework Class Library
NotificationSeverityType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration NotificationSeverityType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum NotificationSeverityType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class NotificationSeverityType
JavaScript
InSite.Domain.FedExRateService.NotificationSeverityType = function();
InSite.Domain.FedExRateService.NotificationSeverityType.createEnum('InSite.Domain.FedExRateService.NotificationSeverityType', false);

Members

Member name | Description
SUCCESS |
NOTE |
WARNING |
ERROR |
FAILURE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


OversizeClassType Enumeration

[image]

.NET Framework Class Library
OversizeClassType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration OversizeClassType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum OversizeClassType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class OversizeClassType
JavaScript
InSite.Domain.FedExRateService.OversizeClassType = function();
InSite.Domain.FedExRateService.OversizeClassType.createEnum('InSite.Domain.FedExRateService.OversizeClassType', false);

Members

Member name | Description
OVERSIZE_1 |
OVERSIZE_2 |
OVERSIZE_3 |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


PackageRateDetail Class

[image]

.NET Framework Class Library
PackageRateDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class PackageRateDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class PackageRateDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class PackageRateDetail
JavaScript
InSite.Domain.FedExRateService.PackageRateDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.PackageRateDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.PackageRateDetail

See Also

PackageRateDetail Members
InSite.Domain.FedExRateService Namespace


PackageRateDetail Members

[image] [image]

.NET Framework Class Library
PackageRateDetail Members
PackageRateDetail Class Constructors Methods Properties See Also Send Feedback

The PackageRateDetail type exposes the following members.

Constructors

Name | Description
PackageRateDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BaseCharge |
BillingWeight |
DimWeight |
FreightDiscounts |
MinimumChargeType |
MinimumChargeTypeSpecified |
NetCharge |
NetFedExCharge |
NetFreight |
OversizeWeight |
RatedWeightMethod |
RatedWeightMethodSpecified |
RateType |
RateTypeSpecified |
Rebates |
Surcharges |
Taxes |
TotalFreightDiscounts |
TotalRebates |
TotalSurcharges |
TotalTaxes |
VariableHandlingCharges |

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


PackageRateDetail Constructor

[image]

.NET Framework Class Library
PackageRateDetail Constructor
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PackageRateDetail()
Visual C++
public:
PackageRateDetail()
JavaScript
InSite.Domain.FedExRateService.PackageRateDetail = function();

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


PackageRateDetail Methods

[image] [image]

.NET Framework Class Library
PackageRateDetail Methods
PackageRateDetail Class See Also Send Feedback

The PackageRateDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


PackageRateDetail Properties

[image] [image]

.NET Framework Class Library
PackageRateDetail Properties
PackageRateDetail Class See Also Send Feedback

The PackageRateDetail type exposes the following members.

Properties

Name | Description
BaseCharge |
BillingWeight |
DimWeight |
FreightDiscounts |
MinimumChargeType |
MinimumChargeTypeSpecified |
NetCharge |
NetFedExCharge |
NetFreight |
OversizeWeight |
RatedWeightMethod |
RatedWeightMethodSpecified |
RateType |
RateTypeSpecified |
Rebates |
Surcharges |
Taxes |
TotalFreightDiscounts |
TotalRebates |
TotalSurcharges |
TotalTaxes |
VariableHandlingCharges |

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


BaseCharge Property

[image]

.NET Framework Class Library
PackageRateDetail..::.BaseCharge Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseCharge As Money
C#
public Money BaseCharge { get; set; }
Visual C++
public:
property Money^ BaseCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_baseCharge();
function set_baseCharge(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


BillingWeight Property

[image]

.NET Framework Class Library
PackageRateDetail..::.BillingWeight Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BillingWeight As Weight
C#
public Weight BillingWeight { get; set; }
Visual C++
public:
property Weight^ BillingWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_billingWeight();
function set_billingWeight(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


DimWeight Property

[image]

.NET Framework Class Library
PackageRateDetail..::.DimWeight Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DimWeight As Weight
C#
public Weight DimWeight { get; set; }
Visual C++
public:
property Weight^ DimWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_dimWeight();
function set_dimWeight(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


FreightDiscounts Property

[image]

.NET Framework Class Library
PackageRateDetail..::.FreightDiscounts Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightDiscounts As RateDiscount()
C#
public RateDiscount[] FreightDiscounts { get; set; }
Visual C++
public:
property array<RateDiscount^>^ FreightDiscounts {
    array<RateDiscount^>^ get ();
    void set (array<RateDiscount^>^ value);
}
JavaScript
function get_freightDiscounts();
function set_freightDiscounts(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


MinimumChargeType Property

[image]

.NET Framework Class Library
PackageRateDetail..::.MinimumChargeType Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MinimumChargeType As MinimumChargeType
C#
public MinimumChargeType MinimumChargeType { get; set; }
Visual C++
public:
property MinimumChargeType MinimumChargeType {
    MinimumChargeType get ();
    void set (MinimumChargeType value);
}
JavaScript
function get_minimumChargeType();
function set_minimumChargeType(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


MinimumChargeTypeSpecified Property

[image]

.NET Framework Class Library
PackageRateDetail..::.MinimumChargeTypeSpecified Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MinimumChargeTypeSpecified As Boolean
C#
public bool MinimumChargeTypeSpecified { get; set; }
Visual C++
public:
property bool MinimumChargeTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_minimumChargeTypeSpecified();
function set_minimumChargeTypeSpecified(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


NetCharge Property

[image]

.NET Framework Class Library
PackageRateDetail..::.NetCharge Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NetCharge As Money
C#
public Money NetCharge { get; set; }
Visual C++
public:
property Money^ NetCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_netCharge();
function set_netCharge(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


NetFedExCharge Property

[image]

.NET Framework Class Library
PackageRateDetail..::.NetFedExCharge Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NetFedExCharge As Money
C#
public Money NetFedExCharge { get; set; }
Visual C++
public:
property Money^ NetFedExCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_netFedExCharge();
function set_netFedExCharge(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


NetFreight Property

[image]

.NET Framework Class Library
PackageRateDetail..::.NetFreight Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NetFreight As Money
C#
public Money NetFreight { get; set; }
Visual C++
public:
property Money^ NetFreight {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_netFreight();
function set_netFreight(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


OversizeWeight Property

[image]

.NET Framework Class Library
PackageRateDetail..::.OversizeWeight Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OversizeWeight As Weight
C#
public Weight OversizeWeight { get; set; }
Visual C++
public:
property Weight^ OversizeWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_oversizeWeight();
function set_oversizeWeight(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


RatedWeightMethod Property

[image]

.NET Framework Class Library
PackageRateDetail..::.RatedWeightMethod Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RatedWeightMethod As RatedWeightMethod
C#
public RatedWeightMethod RatedWeightMethod { get; set; }
Visual C++
public:
property RatedWeightMethod RatedWeightMethod {
    RatedWeightMethod get ();
    void set (RatedWeightMethod value);
}
JavaScript
function get_ratedWeightMethod();
function set_ratedWeightMethod(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


RatedWeightMethodSpecified Property

[image]

.NET Framework Class Library
PackageRateDetail..::.RatedWeightMethodSpecified Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RatedWeightMethodSpecified As Boolean
C#
public bool RatedWeightMethodSpecified { get; set; }
Visual C++
public:
property bool RatedWeightMethodSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_ratedWeightMethodSpecified();
function set_ratedWeightMethodSpecified(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


RateType Property

[image]

.NET Framework Class Library
PackageRateDetail..::.RateType Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateType As ReturnedRateType
C#
public ReturnedRateType RateType { get; set; }
Visual C++
public:
property ReturnedRateType RateType {
    ReturnedRateType get ();
    void set (ReturnedRateType value);
}
JavaScript
function get_rateType();
function set_rateType(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


RateTypeSpecified Property

[image]

.NET Framework Class Library
PackageRateDetail..::.RateTypeSpecified Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateTypeSpecified As Boolean
C#
public bool RateTypeSpecified { get; set; }
Visual C++
public:
property bool RateTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_rateTypeSpecified();
function set_rateTypeSpecified(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


Rebates Property

[image]

.NET Framework Class Library
PackageRateDetail..::.Rebates Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Rebates As Rebate()
C#
public Rebate[] Rebates { get; set; }
Visual C++
public:
property array<Rebate^>^ Rebates {
    array<Rebate^>^ get ();
    void set (array<Rebate^>^ value);
}
JavaScript
function get_rebates();
function set_rebates(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


Surcharges Property

[image]

.NET Framework Class Library
PackageRateDetail..::.Surcharges Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Surcharges As Surcharge()
C#
public Surcharge[] Surcharges { get; set; }
Visual C++
public:
property array<Surcharge^>^ Surcharges {
    array<Surcharge^>^ get ();
    void set (array<Surcharge^>^ value);
}
JavaScript
function get_surcharges();
function set_surcharges(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


Taxes Property

[image]

.NET Framework Class Library
PackageRateDetail..::.Taxes Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Taxes As Tax()
C#
public Tax[] Taxes { get; set; }
Visual C++
public:
property array<Tax^>^ Taxes {
    array<Tax^>^ get ();
    void set (array<Tax^>^ value);
}
JavaScript
function get_taxes();
function set_taxes(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalFreightDiscounts Property

[image]

.NET Framework Class Library
PackageRateDetail..::.TotalFreightDiscounts Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalFreightDiscounts As Money
C#
public Money TotalFreightDiscounts { get; set; }
Visual C++
public:
property Money^ TotalFreightDiscounts {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalFreightDiscounts();
function set_totalFreightDiscounts(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalRebates Property

[image]

.NET Framework Class Library
PackageRateDetail..::.TotalRebates Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalRebates As Money
C#
public Money TotalRebates { get; set; }
Visual C++
public:
property Money^ TotalRebates {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalRebates();
function set_totalRebates(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalSurcharges Property

[image]

.NET Framework Class Library
PackageRateDetail..::.TotalSurcharges Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalSurcharges As Money
C#
public Money TotalSurcharges { get; set; }
Visual C++
public:
property Money^ TotalSurcharges {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalSurcharges();
function set_totalSurcharges(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalTaxes Property

[image]

.NET Framework Class Library
PackageRateDetail..::.TotalTaxes Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalTaxes As Money
C#
public Money TotalTaxes { get; set; }
Visual C++
public:
property Money^ TotalTaxes {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalTaxes();
function set_totalTaxes(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


VariableHandlingCharges Property

[image]

.NET Framework Class Library
PackageRateDetail..::.VariableHandlingCharges Property
PackageRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableHandlingCharges As VariableHandlingCharges
C#
public VariableHandlingCharges VariableHandlingCharges { get; set; }
Visual C++
public:
property VariableHandlingCharges^ VariableHandlingCharges {
    VariableHandlingCharges^ get ();
    void set (VariableHandlingCharges^ value);
}
JavaScript
function get_variableHandlingCharges();
function set_variableHandlingCharges(value);

Remarks

See Also

PackageRateDetail Class
InSite.Domain.FedExRateService Namespace


PackageSpecialServicesRequested Class

[image]

.NET Framework Class Library
PackageSpecialServicesRequested Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class PackageSpecialServicesRequested
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class PackageSpecialServicesRequested
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class PackageSpecialServicesRequested
JavaScript
InSite.Domain.FedExRateService.PackageSpecialServicesRequested = function();

Type.createClass(
    'InSite.Domain.FedExRateService.PackageSpecialServicesRequested');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.PackageSpecialServicesRequested

See Also

PackageSpecialServicesRequested Members
InSite.Domain.FedExRateService Namespace


PackageSpecialServicesRequested Members

[image] [image]

.NET Framework Class Library
PackageSpecialServicesRequested Members
PackageSpecialServicesRequested Class Constructors Methods Properties See Also Send Feedback

The PackageSpecialServicesRequested type exposes the following members.

Constructors

Name | Description
PackageSpecialServicesRequested |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CodCollectionAmount |
DangerousGoodsDetail |
DryIceWeight |
PriorityAlertDetail |
SignatureOptionDetail |
SpecialServiceTypes |

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


PackageSpecialServicesRequested Constructor

[image]

.NET Framework Class Library
PackageSpecialServicesRequested Constructor
PackageSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PackageSpecialServicesRequested()
Visual C++
public:
PackageSpecialServicesRequested()
JavaScript
InSite.Domain.FedExRateService.PackageSpecialServicesRequested = function();

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


PackageSpecialServicesRequested Methods

[image] [image]

.NET Framework Class Library
PackageSpecialServicesRequested Methods
PackageSpecialServicesRequested Class See Also Send Feedback

The PackageSpecialServicesRequested type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


PackageSpecialServicesRequested Properties

[image] [image]

.NET Framework Class Library
PackageSpecialServicesRequested Properties
PackageSpecialServicesRequested Class See Also Send Feedback

The PackageSpecialServicesRequested type exposes the following members.

Properties

Name | Description
CodCollectionAmount |
DangerousGoodsDetail |
DryIceWeight |
PriorityAlertDetail |
SignatureOptionDetail |
SpecialServiceTypes |

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


CodCollectionAmount Property

[image]

.NET Framework Class Library
PackageSpecialServicesRequested..::.CodCollectionAmount Property
PackageSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CodCollectionAmount As Money
C#
public Money CodCollectionAmount { get; set; }
Visual C++
public:
property Money^ CodCollectionAmount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_codCollectionAmount();
function set_codCollectionAmount(value);

Remarks

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


DangerousGoodsDetail Property

[image]

.NET Framework Class Library
PackageSpecialServicesRequested..::.DangerousGoodsDetail Property
PackageSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DangerousGoodsDetail As DangerousGoodsDetail
C#
public DangerousGoodsDetail DangerousGoodsDetail { get; set; }
Visual C++
public:
property DangerousGoodsDetail^ DangerousGoodsDetail {
    DangerousGoodsDetail^ get ();
    void set (DangerousGoodsDetail^ value);
}
JavaScript
function get_dangerousGoodsDetail();
function set_dangerousGoodsDetail(value);

Remarks

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


DryIceWeight Property

[image]

.NET Framework Class Library
PackageSpecialServicesRequested..::.DryIceWeight Property
PackageSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DryIceWeight As Weight
C#
public Weight DryIceWeight { get; set; }
Visual C++
public:
property Weight^ DryIceWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_dryIceWeight();
function set_dryIceWeight(value);

Remarks

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


PriorityAlertDetail Property

[image]

.NET Framework Class Library
PackageSpecialServicesRequested..::.PriorityAlertDetail Property
PackageSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PriorityAlertDetail As String()
C#
public string[] PriorityAlertDetail { get; set; }
Visual C++
public:
property array<String^>^ PriorityAlertDetail {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_priorityAlertDetail();
function set_priorityAlertDetail(value);

Remarks

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


SignatureOptionDetail Property

[image]

.NET Framework Class Library
PackageSpecialServicesRequested..::.SignatureOptionDetail Property
PackageSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SignatureOptionDetail As SignatureOptionDetail
C#
public SignatureOptionDetail SignatureOptionDetail { get; set; }
Visual C++
public:
property SignatureOptionDetail^ SignatureOptionDetail {
    SignatureOptionDetail^ get ();
    void set (SignatureOptionDetail^ value);
}
JavaScript
function get_signatureOptionDetail();
function set_signatureOptionDetail(value);

Remarks

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


SpecialServiceTypes Property

[image]

.NET Framework Class Library
PackageSpecialServicesRequested..::.SpecialServiceTypes Property
PackageSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecialServiceTypes As PackageSpecialServiceType()
C#
public PackageSpecialServiceType[] SpecialServiceTypes { get; set; }
Visual C++
public:
property array<PackageSpecialServiceType>^ SpecialServiceTypes {
    array<PackageSpecialServiceType>^ get ();
    void set (array<PackageSpecialServiceType>^ value);
}
JavaScript
function get_specialServiceTypes();
function set_specialServiceTypes(value);

Remarks

See Also

PackageSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


PackageSpecialServiceType Enumeration

[image]

.NET Framework Class Library
PackageSpecialServiceType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PackageSpecialServiceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PackageSpecialServiceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PackageSpecialServiceType
JavaScript
InSite.Domain.FedExRateService.PackageSpecialServiceType = function();
InSite.Domain.FedExRateService.PackageSpecialServiceType.createEnum('InSite.Domain.FedExRateService.PackageSpecialServiceType', false);

Members

Member name | Description
APPOINTMENT_DELIVERY |
DANGEROUS_GOODS |
DRY_ICE |
NON_STANDARD_CONTAINER |
PRIORITY_ALERT |
SIGNATURE_OPTION |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


PackagingType Enumeration

[image]

.NET Framework Class Library
PackagingType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PackagingType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PackagingType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PackagingType
JavaScript
InSite.Domain.FedExRateService.PackagingType = function();
InSite.Domain.FedExRateService.PackagingType.createEnum('InSite.Domain.FedExRateService.PackagingType', false);

Members

Member name | Description
FEDEX_10KG_BOX |
FEDEX_25KG_BOX |
FEDEX_BOX |
FEDEX_ENVELOPE |
FEDEX_PAK |
FEDEX_TUBE |
YOUR_PACKAGING |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Party Class

[image]

.NET Framework Class Library
Party Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Party
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Party
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Party
JavaScript
InSite.Domain.FedExRateService.Party = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Party');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Party

See Also

Party Members
InSite.Domain.FedExRateService Namespace


Party Members

[image] [image]

.NET Framework Class Library
Party Members
Party Class Constructors Methods Properties See Also Send Feedback

The Party type exposes the following members.

Constructors

Name | Description
Party |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccountNumber |
Address |
Contact |
Tin |

See Also

Party Class
InSite.Domain.FedExRateService Namespace


Party Constructor

[image]

.NET Framework Class Library
Party Constructor
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Party()
Visual C++
public:
Party()
JavaScript
InSite.Domain.FedExRateService.Party = function();

See Also

Party Class
InSite.Domain.FedExRateService Namespace


Party Methods

[image] [image]

.NET Framework Class Library
Party Methods
Party Class See Also Send Feedback

The Party type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Party Class
InSite.Domain.FedExRateService Namespace


Party Properties

[image] [image]

.NET Framework Class Library
Party Properties
Party Class See Also Send Feedback

The Party type exposes the following members.

Properties

Name | Description
AccountNumber |
Address |
Contact |
Tin |

See Also

Party Class
InSite.Domain.FedExRateService Namespace


AccountNumber Property

[image]

.NET Framework Class Library
Party..::.AccountNumber Property
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AccountNumber As String
C#
public string AccountNumber { get; set; }
Visual C++
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

Party Class
InSite.Domain.FedExRateService Namespace


Address Property

[image]

.NET Framework Class Library
Party..::.Address Property
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As Address
C#
public Address Address { get; set; }
Visual C++
public:
property Address^ Address {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

Party Class
InSite.Domain.FedExRateService Namespace


Contact Property

[image]

.NET Framework Class Library
Party..::.Contact Property
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Contact As Contact
C#
public Contact Contact { get; set; }
Visual C++
public:
property Contact^ Contact {
    Contact^ get ();
    void set (Contact^ value);
}
JavaScript
function get_contact();
function set_contact(value);

Remarks

See Also

Party Class
InSite.Domain.FedExRateService Namespace


Tin Property

[image]

.NET Framework Class Library
Party..::.Tin Property
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Tin As TaxpayerIdentification
C#
public TaxpayerIdentification Tin { get; set; }
Visual C++
public:
property TaxpayerIdentification^ Tin {
    TaxpayerIdentification^ get ();
    void set (TaxpayerIdentification^ value);
}
JavaScript
function get_tin();
function set_tin(value);

Remarks

See Also

Party Class
InSite.Domain.FedExRateService Namespace


Payment Class

[image]

.NET Framework Class Library
Payment Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Payment
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Payment
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Payment
JavaScript
InSite.Domain.FedExRateService.Payment = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Payment');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Payment

See Also

Payment Members
InSite.Domain.FedExRateService Namespace


Payment Members

[image] [image]

.NET Framework Class Library
Payment Members
Payment Class Constructors Methods Properties See Also Send Feedback

The Payment type exposes the following members.

Constructors

Name | Description
Payment |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PaymentType |
PaymentTypeSpecified |
Payor |

See Also

Payment Class
InSite.Domain.FedExRateService Namespace


Payment Constructor

[image]

.NET Framework Class Library
Payment Constructor
Payment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Payment()
Visual C++
public:
Payment()
JavaScript
InSite.Domain.FedExRateService.Payment = function();

See Also

Payment Class
InSite.Domain.FedExRateService Namespace


Payment Methods

[image] [image]

.NET Framework Class Library
Payment Methods
Payment Class See Also Send Feedback

The Payment type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Payment Class
InSite.Domain.FedExRateService Namespace


Payment Properties

[image] [image]

.NET Framework Class Library
Payment Properties
Payment Class See Also Send Feedback

The Payment type exposes the following members.

Properties

Name | Description
PaymentType |
PaymentTypeSpecified |
Payor |

See Also

Payment Class
InSite.Domain.FedExRateService Namespace


PaymentType Property

[image]

.NET Framework Class Library
Payment..::.PaymentType Property
Payment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PaymentType As PaymentType
C#
public PaymentType PaymentType { get; set; }
Visual C++
public:
property PaymentType PaymentType {
    PaymentType get ();
    void set (PaymentType value);
}
JavaScript
function get_paymentType();
function set_paymentType(value);

Remarks

See Also

Payment Class
InSite.Domain.FedExRateService Namespace


PaymentTypeSpecified Property

[image]

.NET Framework Class Library
Payment..::.PaymentTypeSpecified Property
Payment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PaymentTypeSpecified As Boolean
C#
public bool PaymentTypeSpecified { get; set; }
Visual C++
public:
property bool PaymentTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_paymentTypeSpecified();
function set_paymentTypeSpecified(value);

Remarks

See Also

Payment Class
InSite.Domain.FedExRateService Namespace


Payor Property

[image]

.NET Framework Class Library
Payment..::.Payor Property
Payment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Payor As Payor
C#
public Payor Payor { get; set; }
Visual C++
public:
property Payor^ Payor {
    Payor^ get ();
    void set (Payor^ value);
}
JavaScript
function get_payor();
function set_payor(value);

Remarks

See Also

Payment Class
InSite.Domain.FedExRateService Namespace


PaymentType Enumeration

[image]

.NET Framework Class Library
PaymentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PaymentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PaymentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PaymentType
JavaScript
InSite.Domain.FedExRateService.PaymentType = function();
InSite.Domain.FedExRateService.PaymentType.createEnum('InSite.Domain.FedExRateService.PaymentType', false);

Members

Member name | Description
COLLECT |
RECIPIENT |
SENDER |
THIRD_PARTY |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Payor Class

[image]

.NET Framework Class Library
Payor Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Payor
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Payor
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Payor
JavaScript
InSite.Domain.FedExRateService.Payor = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Payor');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Payor

See Also

Payor Members
InSite.Domain.FedExRateService Namespace


Payor Members

[image] [image]

.NET Framework Class Library
Payor Members
Payor Class Constructors Methods Properties See Also Send Feedback

The Payor type exposes the following members.

Constructors

Name | Description
Payor |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccountNumber |
CountryCode |

See Also

Payor Class
InSite.Domain.FedExRateService Namespace


Payor Constructor

[image]

.NET Framework Class Library
Payor Constructor
Payor Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Payor()
Visual C++
public:
Payor()
JavaScript
InSite.Domain.FedExRateService.Payor = function();

See Also

Payor Class
InSite.Domain.FedExRateService Namespace


Payor Methods

[image] [image]

.NET Framework Class Library
Payor Methods
Payor Class See Also Send Feedback

The Payor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Payor Class
InSite.Domain.FedExRateService Namespace


Payor Properties

[image] [image]

.NET Framework Class Library
Payor Properties
Payor Class See Also Send Feedback

The Payor type exposes the following members.

Properties

Name | Description
AccountNumber |
CountryCode |

See Also

Payor Class
InSite.Domain.FedExRateService Namespace


AccountNumber Property

[image]

.NET Framework Class Library
Payor..::.AccountNumber Property
Payor Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AccountNumber As String
C#
public string AccountNumber { get; set; }
Visual C++
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

Payor Class
InSite.Domain.FedExRateService Namespace


CountryCode Property

[image]

.NET Framework Class Library
Payor..::.CountryCode Property
Payor Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CountryCode As String
C#
public string CountryCode { get; set; }
Visual C++
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryCode();
function set_countryCode(value);

Remarks

See Also

Payor Class
InSite.Domain.FedExRateService Namespace


PendingShipmentDetail Class

[image]

.NET Framework Class Library
PendingShipmentDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class PendingShipmentDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class PendingShipmentDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class PendingShipmentDetail
JavaScript
InSite.Domain.FedExRateService.PendingShipmentDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.PendingShipmentDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.PendingShipmentDetail

See Also

PendingShipmentDetail Members
InSite.Domain.FedExRateService Namespace


PendingShipmentDetail Members

[image] [image]

.NET Framework Class Library
PendingShipmentDetail Members
PendingShipmentDetail Class Constructors Methods Properties See Also Send Feedback

The PendingShipmentDetail type exposes the following members.

Constructors

Name | Description
PendingShipmentDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EmailLabelDetail |
ExpirationDate |
ExpirationDateSpecified |
Type |

See Also

PendingShipmentDetail Class
InSite.Domain.FedExRateService Namespace


PendingShipmentDetail Constructor

[image]

.NET Framework Class Library
PendingShipmentDetail Constructor
PendingShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PendingShipmentDetail()
Visual C++
public:
PendingShipmentDetail()
JavaScript
InSite.Domain.FedExRateService.PendingShipmentDetail = function();

See Also

PendingShipmentDetail Class
InSite.Domain.FedExRateService Namespace


PendingShipmentDetail Methods

[image] [image]

.NET Framework Class Library
PendingShipmentDetail Methods
PendingShipmentDetail Class See Also Send Feedback

The PendingShipmentDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PendingShipmentDetail Class
InSite.Domain.FedExRateService Namespace


PendingShipmentDetail Properties

[image] [image]

.NET Framework Class Library
PendingShipmentDetail Properties
PendingShipmentDetail Class See Also Send Feedback

The PendingShipmentDetail type exposes the following members.

Properties

Name | Description
EmailLabelDetail |
ExpirationDate |
ExpirationDateSpecified |
Type |

See Also

PendingShipmentDetail Class
InSite.Domain.FedExRateService Namespace


EmailLabelDetail Property

[image]

.NET Framework Class Library
PendingShipmentDetail..::.EmailLabelDetail Property
PendingShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EmailLabelDetail As EMailLabelDetail
C#
public EMailLabelDetail EmailLabelDetail { get; set; }
Visual C++
public:
property EMailLabelDetail^ EmailLabelDetail {
    EMailLabelDetail^ get ();
    void set (EMailLabelDetail^ value);
}
JavaScript
function get_emailLabelDetail();
function set_emailLabelDetail(value);

Remarks

See Also

PendingShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ExpirationDate Property

[image]

.NET Framework Class Library
PendingShipmentDetail..::.ExpirationDate Property
PendingShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpirationDate As DateTime
C#
public DateTime ExpirationDate { get; set; }
Visual C++
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_expirationDate();
function set_expirationDate(value);

Remarks

See Also

PendingShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ExpirationDateSpecified Property

[image]

.NET Framework Class Library
PendingShipmentDetail..::.ExpirationDateSpecified Property
PendingShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpirationDateSpecified As Boolean
C#
public bool ExpirationDateSpecified { get; set; }
Visual C++
public:
property bool ExpirationDateSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_expirationDateSpecified();
function set_expirationDateSpecified(value);

Remarks

See Also

PendingShipmentDetail Class
InSite.Domain.FedExRateService Namespace


Type Property

[image]

.NET Framework Class Library
PendingShipmentDetail..::.Type Property
PendingShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As PendingShipmentType
C#
public PendingShipmentType Type { get; set; }
Visual C++
public:
property PendingShipmentType Type {
    PendingShipmentType get ();
    void set (PendingShipmentType value);
}
JavaScript
function get_type();
function set_type(value);

Remarks

See Also

PendingShipmentDetail Class
InSite.Domain.FedExRateService Namespace


PendingShipmentType Enumeration

[image]

.NET Framework Class Library
PendingShipmentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PendingShipmentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PendingShipmentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PendingShipmentType
JavaScript
InSite.Domain.FedExRateService.PendingShipmentType = function();
InSite.Domain.FedExRateService.PendingShipmentType.createEnum('InSite.Domain.FedExRateService.PendingShipmentType', false);

Members

Member name | Description
EMAIL |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


PhysicalPackagingType Enumeration

[image]

.NET Framework Class Library
PhysicalPackagingType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PhysicalPackagingType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PhysicalPackagingType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PhysicalPackagingType
JavaScript
InSite.Domain.FedExRateService.PhysicalPackagingType = function();
InSite.Domain.FedExRateService.PhysicalPackagingType.createEnum('InSite.Domain.FedExRateService.PhysicalPackagingType', false);

Members

Member name | Description
BAG |
BARREL |
BASKET |
BOX |
BUCKET |
BUNDLE |
CARTON |
CASE |
CONTAINER |
CRATE |
CYLINDER |
DRUM |
ENVELOPE |
HAMPER |
OTHER |
PAIL |
PALLET |
PIECE |
REEL |
ROLL |
SKID |
TANK |
TUBE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


PickupDetail Class

[image]

.NET Framework Class Library
PickupDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class PickupDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class PickupDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class PickupDetail
JavaScript
InSite.Domain.FedExRateService.PickupDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.PickupDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.PickupDetail

See Also

PickupDetail Members
InSite.Domain.FedExRateService Namespace


PickupDetail Members

[image] [image]

.NET Framework Class Library
PickupDetail Members
PickupDetail Class Constructors Methods Properties See Also Send Feedback

The PickupDetail type exposes the following members.

Constructors

Name | Description
PickupDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CourierInstructions |
LatestPickupDateTime |
LatestPickupDateTimeSpecified |
ReadyDateTime |
ReadyDateTimeSpecified |
RequestSource |
RequestSourceSpecified |
RequestType |
RequestTypeSpecified |

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


PickupDetail Constructor

[image]

.NET Framework Class Library
PickupDetail Constructor
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PickupDetail()
Visual C++
public:
PickupDetail()
JavaScript
InSite.Domain.FedExRateService.PickupDetail = function();

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


PickupDetail Methods

[image] [image]

.NET Framework Class Library
PickupDetail Methods
PickupDetail Class See Also Send Feedback

The PickupDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


PickupDetail Properties

[image] [image]

.NET Framework Class Library
PickupDetail Properties
PickupDetail Class See Also Send Feedback

The PickupDetail type exposes the following members.

Properties

Name | Description
CourierInstructions |
LatestPickupDateTime |
LatestPickupDateTimeSpecified |
ReadyDateTime |
ReadyDateTimeSpecified |
RequestSource |
RequestSourceSpecified |
RequestType |
RequestTypeSpecified |

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


CourierInstructions Property

[image]

.NET Framework Class Library
PickupDetail..::.CourierInstructions Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CourierInstructions As String
C#
public string CourierInstructions { get; set; }
Visual C++
public:
property String^ CourierInstructions {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_courierInstructions();
function set_courierInstructions(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


LatestPickupDateTime Property

[image]

.NET Framework Class Library
PickupDetail..::.LatestPickupDateTime Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LatestPickupDateTime As DateTime
C#
public DateTime LatestPickupDateTime { get; set; }
Visual C++
public:
property DateTime LatestPickupDateTime {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_latestPickupDateTime();
function set_latestPickupDateTime(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


LatestPickupDateTimeSpecified Property

[image]

.NET Framework Class Library
PickupDetail..::.LatestPickupDateTimeSpecified Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LatestPickupDateTimeSpecified As Boolean
C#
public bool LatestPickupDateTimeSpecified { get; set; }
Visual C++
public:
property bool LatestPickupDateTimeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_latestPickupDateTimeSpecified();
function set_latestPickupDateTimeSpecified(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


ReadyDateTime Property

[image]

.NET Framework Class Library
PickupDetail..::.ReadyDateTime Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadyDateTime As DateTime
C#
public DateTime ReadyDateTime { get; set; }
Visual C++
public:
property DateTime ReadyDateTime {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_readyDateTime();
function set_readyDateTime(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


ReadyDateTimeSpecified Property

[image]

.NET Framework Class Library
PickupDetail..::.ReadyDateTimeSpecified Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadyDateTimeSpecified As Boolean
C#
public bool ReadyDateTimeSpecified { get; set; }
Visual C++
public:
property bool ReadyDateTimeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_readyDateTimeSpecified();
function set_readyDateTimeSpecified(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


RequestSource Property

[image]

.NET Framework Class Library
PickupDetail..::.RequestSource Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RequestSource As PickupRequestSourceType
C#
public PickupRequestSourceType RequestSource { get; set; }
Visual C++
public:
property PickupRequestSourceType RequestSource {
    PickupRequestSourceType get ();
    void set (PickupRequestSourceType value);
}
JavaScript
function get_requestSource();
function set_requestSource(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


RequestSourceSpecified Property

[image]

.NET Framework Class Library
PickupDetail..::.RequestSourceSpecified Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RequestSourceSpecified As Boolean
C#
public bool RequestSourceSpecified { get; set; }
Visual C++
public:
property bool RequestSourceSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_requestSourceSpecified();
function set_requestSourceSpecified(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


RequestType Property

[image]

.NET Framework Class Library
PickupDetail..::.RequestType Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RequestType As PickupRequestType
C#
public PickupRequestType RequestType { get; set; }
Visual C++
public:
property PickupRequestType RequestType {
    PickupRequestType get ();
    void set (PickupRequestType value);
}
JavaScript
function get_requestType();
function set_requestType(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


RequestTypeSpecified Property

[image]

.NET Framework Class Library
PickupDetail..::.RequestTypeSpecified Property
PickupDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RequestTypeSpecified As Boolean
C#
public bool RequestTypeSpecified { get; set; }
Visual C++
public:
property bool RequestTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_requestTypeSpecified();
function set_requestTypeSpecified(value);

Remarks

See Also

PickupDetail Class
InSite.Domain.FedExRateService Namespace


PickupRequestSourceType Enumeration

[image]

.NET Framework Class Library
PickupRequestSourceType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PickupRequestSourceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PickupRequestSourceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PickupRequestSourceType
JavaScript
InSite.Domain.FedExRateService.PickupRequestSourceType = function();
InSite.Domain.FedExRateService.PickupRequestSourceType.createEnum('InSite.Domain.FedExRateService.PickupRequestSourceType', false);

Members

Member name | Description
AUTOMATION |
CUSTOMER_SERVICE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


PickupRequestType Enumeration

[image]

.NET Framework Class Library
PickupRequestType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PickupRequestType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PickupRequestType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PickupRequestType
JavaScript
InSite.Domain.FedExRateService.PickupRequestType = function();
InSite.Domain.FedExRateService.PickupRequestType.createEnum('InSite.Domain.FedExRateService.PickupRequestType', false);

Members

Member name | Description
SAME_DAY |
FUTURE_DAY |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


PricingCodeType Enumeration

[image]

.NET Framework Class Library
PricingCodeType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PricingCodeType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PricingCodeType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PricingCodeType
JavaScript
InSite.Domain.FedExRateService.PricingCodeType = function();
InSite.Domain.FedExRateService.PricingCodeType.createEnum('InSite.Domain.FedExRateService.PricingCodeType', false);

Members

Member name | Description
ACTUAL |
ALTERNATE |
BASE |
HUNDREDWEIGHT |
HUNDREDWEIGHT_ALTERNATE |
INTERNATIONAL_DISTRIBUTION |
INTERNATIONAL_ECONOMY_SERVICE |
LTL_FREIGHT |
PACKAGE |
SHIPMENT |
SHIPMENT_FIVE_POUND_OPTIONAL |
SHIPMENT_OPTIONAL |
SPECIAL |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


PurposeOfShipmentType Enumeration

[image]

.NET Framework Class Library
PurposeOfShipmentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration PurposeOfShipmentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum PurposeOfShipmentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class PurposeOfShipmentType
JavaScript
InSite.Domain.FedExRateService.PurposeOfShipmentType = function();
InSite.Domain.FedExRateService.PurposeOfShipmentType.createEnum('InSite.Domain.FedExRateService.PurposeOfShipmentType', false);

Members

Member name | Description
GIFT |
NOT_SOLD |
PERSONAL_EFFECTS |
REPAIR_AND_RETURN |
SAMPLE |
SOLD |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RateDiscount Class

[image]

.NET Framework Class Library
RateDiscount Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RateDiscount
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RateDiscount
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RateDiscount
JavaScript
InSite.Domain.FedExRateService.RateDiscount = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RateDiscount');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.RateDiscount

See Also

RateDiscount Members
InSite.Domain.FedExRateService Namespace


RateDiscount Members

[image] [image]

.NET Framework Class Library
RateDiscount Members
RateDiscount Class Constructors Methods Properties See Also Send Feedback

The RateDiscount type exposes the following members.

Constructors

Name | Description
RateDiscount |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Description |
Percent |
PercentSpecified |
RateDiscountType |
RateDiscountTypeSpecified |

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


RateDiscount Constructor

[image]

.NET Framework Class Library
RateDiscount Constructor
RateDiscount Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RateDiscount()
Visual C++
public:
RateDiscount()
JavaScript
InSite.Domain.FedExRateService.RateDiscount = function();

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


RateDiscount Methods

[image] [image]

.NET Framework Class Library
RateDiscount Methods
RateDiscount Class See Also Send Feedback

The RateDiscount type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


RateDiscount Properties

[image] [image]

.NET Framework Class Library
RateDiscount Properties
RateDiscount Class See Also Send Feedback

The RateDiscount type exposes the following members.

Properties

Name | Description
Amount |
Description |
Percent |
PercentSpecified |
RateDiscountType |
RateDiscountTypeSpecified |

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


Amount Property

[image]

.NET Framework Class Library
RateDiscount..::.Amount Property
RateDiscount Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As Money
C#
public Money Amount { get; set; }
Visual C++
public:
property Money^ Amount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
RateDiscount..::.Description Property
RateDiscount Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


Percent Property

[image]

.NET Framework Class Library
RateDiscount..::.Percent Property
RateDiscount Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Percent As Decimal
C#
public decimal Percent { get; set; }
Visual C++
public:
property Decimal Percent {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_percent();
function set_percent(value);

Remarks

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


PercentSpecified Property

[image]

.NET Framework Class Library
RateDiscount..::.PercentSpecified Property
RateDiscount Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PercentSpecified As Boolean
C#
public bool PercentSpecified { get; set; }
Visual C++
public:
property bool PercentSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_percentSpecified();
function set_percentSpecified(value);

Remarks

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


RateDiscountType Property

[image]

.NET Framework Class Library
RateDiscount..::.RateDiscountType Property
RateDiscount Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateDiscountType As RateDiscountType
C#
public RateDiscountType RateDiscountType { get; set; }
Visual C++
public:
property RateDiscountType RateDiscountType {
    RateDiscountType get ();
    void set (RateDiscountType value);
}
JavaScript
function get_rateDiscountType();
function set_rateDiscountType(value);

Remarks

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


RateDiscountTypeSpecified Property

[image]

.NET Framework Class Library
RateDiscount..::.RateDiscountTypeSpecified Property
RateDiscount Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateDiscountTypeSpecified As Boolean
C#
public bool RateDiscountTypeSpecified { get; set; }
Visual C++
public:
property bool RateDiscountTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_rateDiscountTypeSpecified();
function set_rateDiscountTypeSpecified(value);

Remarks

See Also

RateDiscount Class
InSite.Domain.FedExRateService Namespace


RateDiscountType Enumeration

[image]

.NET Framework Class Library
RateDiscountType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RateDiscountType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RateDiscountType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RateDiscountType
JavaScript
InSite.Domain.FedExRateService.RateDiscountType = function();
InSite.Domain.FedExRateService.RateDiscountType.createEnum('InSite.Domain.FedExRateService.RateDiscountType', false);

Members

Member name | Description
BONUS |
EARNED |
OTHER |
VOLUME |
COUPON |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RatedPackageDetail Class

[image]

.NET Framework Class Library
RatedPackageDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RatedPackageDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RatedPackageDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RatedPackageDetail
JavaScript
InSite.Domain.FedExRateService.RatedPackageDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RatedPackageDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.RatedPackageDetail

See Also

RatedPackageDetail Members
InSite.Domain.FedExRateService Namespace


RatedPackageDetail Members

[image] [image]

.NET Framework Class Library
RatedPackageDetail Members
RatedPackageDetail Class Constructors Methods Properties See Also Send Feedback

The RatedPackageDetail type exposes the following members.

Constructors

Name | Description
RatedPackageDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AdjustedCodCollectionAmount |
EffectiveNetDiscount |
GroupNumber |
OversizeClass |
OversizeClassSpecified |
PackageRateDetail |
TrackingIds |

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


RatedPackageDetail Constructor

[image]

.NET Framework Class Library
RatedPackageDetail Constructor
RatedPackageDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RatedPackageDetail()
Visual C++
public:
RatedPackageDetail()
JavaScript
InSite.Domain.FedExRateService.RatedPackageDetail = function();

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


RatedPackageDetail Methods

[image] [image]

.NET Framework Class Library
RatedPackageDetail Methods
RatedPackageDetail Class See Also Send Feedback

The RatedPackageDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


RatedPackageDetail Properties

[image] [image]

.NET Framework Class Library
RatedPackageDetail Properties
RatedPackageDetail Class See Also Send Feedback

The RatedPackageDetail type exposes the following members.

Properties

Name | Description
AdjustedCodCollectionAmount |
EffectiveNetDiscount |
GroupNumber |
OversizeClass |
OversizeClassSpecified |
PackageRateDetail |
TrackingIds |

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


AdjustedCodCollectionAmount Property

[image]

.NET Framework Class Library
RatedPackageDetail..::.AdjustedCodCollectionAmount Property
RatedPackageDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AdjustedCodCollectionAmount As Money
C#
public Money AdjustedCodCollectionAmount { get; set; }
Visual C++
public:
property Money^ AdjustedCodCollectionAmount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_adjustedCodCollectionAmount();
function set_adjustedCodCollectionAmount(value);

Remarks

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


EffectiveNetDiscount Property

[image]

.NET Framework Class Library
RatedPackageDetail..::.EffectiveNetDiscount Property
RatedPackageDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EffectiveNetDiscount As Money
C#
public Money EffectiveNetDiscount { get; set; }
Visual C++
public:
property Money^ EffectiveNetDiscount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_effectiveNetDiscount();
function set_effectiveNetDiscount(value);

Remarks

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


GroupNumber Property

[image]

.NET Framework Class Library
RatedPackageDetail..::.GroupNumber Property
RatedPackageDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property GroupNumber As String
C#
public string GroupNumber { get; set; }
Visual C++
public:
property String^ GroupNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_groupNumber();
function set_groupNumber(value);

Remarks

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


OversizeClass Property

[image]

.NET Framework Class Library
RatedPackageDetail..::.OversizeClass Property
RatedPackageDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OversizeClass As OversizeClassType
C#
public OversizeClassType OversizeClass { get; set; }
Visual C++
public:
property OversizeClassType OversizeClass {
    OversizeClassType get ();
    void set (OversizeClassType value);
}
JavaScript
function get_oversizeClass();
function set_oversizeClass(value);

Remarks

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


OversizeClassSpecified Property

[image]

.NET Framework Class Library
RatedPackageDetail..::.OversizeClassSpecified Property
RatedPackageDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OversizeClassSpecified As Boolean
C#
public bool OversizeClassSpecified { get; set; }
Visual C++
public:
property bool OversizeClassSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_oversizeClassSpecified();
function set_oversizeClassSpecified(value);

Remarks

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


PackageRateDetail Property

[image]

.NET Framework Class Library
RatedPackageDetail..::.PackageRateDetail Property
RatedPackageDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackageRateDetail As PackageRateDetail
C#
public PackageRateDetail PackageRateDetail { get; set; }
Visual C++
public:
property PackageRateDetail^ PackageRateDetail {
    PackageRateDetail^ get ();
    void set (PackageRateDetail^ value);
}
JavaScript
function get_packageRateDetail();
function set_packageRateDetail(value);

Remarks

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


TrackingIds Property

[image]

.NET Framework Class Library
RatedPackageDetail..::.TrackingIds Property
RatedPackageDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackingIds As TrackingId()
C#
public TrackingId[] TrackingIds { get; set; }
Visual C++
public:
property array<TrackingId^>^ TrackingIds {
    array<TrackingId^>^ get ();
    void set (array<TrackingId^>^ value);
}
JavaScript
function get_trackingIds();
function set_trackingIds(value);

Remarks

See Also

RatedPackageDetail Class
InSite.Domain.FedExRateService Namespace


RatedShipmentDetail Class

[image]

.NET Framework Class Library
RatedShipmentDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RatedShipmentDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RatedShipmentDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RatedShipmentDetail
JavaScript
InSite.Domain.FedExRateService.RatedShipmentDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RatedShipmentDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.RatedShipmentDetail

See Also

RatedShipmentDetail Members
InSite.Domain.FedExRateService Namespace


RatedShipmentDetail Members

[image] [image]

.NET Framework Class Library
RatedShipmentDetail Members
RatedShipmentDetail Class Constructors Methods Properties See Also Send Feedback

The RatedShipmentDetail type exposes the following members.

Constructors

Name | Description
RatedShipmentDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AdjustedCodCollectionAmount |
EffectiveNetDiscount |
RatedPackages |
ShipmentRateDetail |

See Also

RatedShipmentDetail Class
InSite.Domain.FedExRateService Namespace


RatedShipmentDetail Constructor

[image]

.NET Framework Class Library
RatedShipmentDetail Constructor
RatedShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RatedShipmentDetail()
Visual C++
public:
RatedShipmentDetail()
JavaScript
InSite.Domain.FedExRateService.RatedShipmentDetail = function();

See Also

RatedShipmentDetail Class
InSite.Domain.FedExRateService Namespace


RatedShipmentDetail Methods

[image] [image]

.NET Framework Class Library
RatedShipmentDetail Methods
RatedShipmentDetail Class See Also Send Feedback

The RatedShipmentDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RatedShipmentDetail Class
InSite.Domain.FedExRateService Namespace


RatedShipmentDetail Properties

[image] [image]

.NET Framework Class Library
RatedShipmentDetail Properties
RatedShipmentDetail Class See Also Send Feedback

The RatedShipmentDetail type exposes the following members.

Properties

Name | Description
AdjustedCodCollectionAmount |
EffectiveNetDiscount |
RatedPackages |
ShipmentRateDetail |

See Also

RatedShipmentDetail Class
InSite.Domain.FedExRateService Namespace


AdjustedCodCollectionAmount Property

[image]

.NET Framework Class Library
RatedShipmentDetail..::.AdjustedCodCollectionAmount Property
RatedShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AdjustedCodCollectionAmount As Money
C#
public Money AdjustedCodCollectionAmount { get; set; }
Visual C++
public:
property Money^ AdjustedCodCollectionAmount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_adjustedCodCollectionAmount();
function set_adjustedCodCollectionAmount(value);

Remarks

See Also

RatedShipmentDetail Class
InSite.Domain.FedExRateService Namespace


EffectiveNetDiscount Property

[image]

.NET Framework Class Library
RatedShipmentDetail..::.EffectiveNetDiscount Property
RatedShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EffectiveNetDiscount As Money
C#
public Money EffectiveNetDiscount { get; set; }
Visual C++
public:
property Money^ EffectiveNetDiscount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_effectiveNetDiscount();
function set_effectiveNetDiscount(value);

Remarks

See Also

RatedShipmentDetail Class
InSite.Domain.FedExRateService Namespace


RatedPackages Property

[image]

.NET Framework Class Library
RatedShipmentDetail..::.RatedPackages Property
RatedShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RatedPackages As RatedPackageDetail()
C#
public RatedPackageDetail[] RatedPackages { get; set; }
Visual C++
public:
property array<RatedPackageDetail^>^ RatedPackages {
    array<RatedPackageDetail^>^ get ();
    void set (array<RatedPackageDetail^>^ value);
}
JavaScript
function get_ratedPackages();
function set_ratedPackages(value);

Remarks

See Also

RatedShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentRateDetail Property

[image]

.NET Framework Class Library
RatedShipmentDetail..::.ShipmentRateDetail Property
RatedShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipmentRateDetail As ShipmentRateDetail
C#
public ShipmentRateDetail ShipmentRateDetail { get; set; }
Visual C++
public:
property ShipmentRateDetail^ ShipmentRateDetail {
    ShipmentRateDetail^ get ();
    void set (ShipmentRateDetail^ value);
}
JavaScript
function get_shipmentRateDetail();
function set_shipmentRateDetail(value);

Remarks

See Also

RatedShipmentDetail Class
InSite.Domain.FedExRateService Namespace


RatedWeightMethod Enumeration

[image]

.NET Framework Class Library
RatedWeightMethod Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RatedWeightMethod
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RatedWeightMethod
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RatedWeightMethod
JavaScript
InSite.Domain.FedExRateService.RatedWeightMethod = function();
InSite.Domain.FedExRateService.RatedWeightMethod.createEnum('InSite.Domain.FedExRateService.RatedWeightMethod', false);

Members

Member name | Description
ACTUAL |
DIM |
FREIGHT_MINIMUM |
OVERSIZE_1 |
OVERSIZE_2 |
OVERSIZE_3 |
BALLOON |
MIXED |
OVERSIZE |
WEIGHT_BREAK |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RateReply Class

[image]

.NET Framework Class Library
RateReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RateReply
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RateReply
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RateReply
JavaScript
InSite.Domain.FedExRateService.RateReply = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RateReply');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.RateReply

See Also

RateReply Members
InSite.Domain.FedExRateService Namespace


RateReply Members

[image] [image]

.NET Framework Class Library
RateReply Members
RateReply Class Constructors Methods Properties See Also Send Feedback

The RateReply type exposes the following members.

Constructors

Name | Description
RateReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HighestSeverity |
Notifications |
RateReplyDetails |
TransactionDetail |
Version |

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


RateReply Constructor

[image]

.NET Framework Class Library
RateReply Constructor
RateReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RateReply()
Visual C++
public:
RateReply()
JavaScript
InSite.Domain.FedExRateService.RateReply = function();

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


RateReply Methods

[image] [image]

.NET Framework Class Library
RateReply Methods
RateReply Class See Also Send Feedback

The RateReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


RateReply Properties

[image] [image]

.NET Framework Class Library
RateReply Properties
RateReply Class See Also Send Feedback

The RateReply type exposes the following members.

Properties

Name | Description
HighestSeverity |
Notifications |
RateReplyDetails |
TransactionDetail |
Version |

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


HighestSeverity Property

[image]

.NET Framework Class Library
RateReply..::.HighestSeverity Property
RateReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HighestSeverity As NotificationSeverityType
C#
public NotificationSeverityType HighestSeverity { get; set; }
Visual C++
public:
property NotificationSeverityType HighestSeverity {
    NotificationSeverityType get ();
    void set (NotificationSeverityType value);
}
JavaScript
function get_highestSeverity();
function set_highestSeverity(value);

Remarks

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


Notifications Property

[image]

.NET Framework Class Library
RateReply..::.Notifications Property
RateReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Notifications As Notification()
C#
public Notification[] Notifications { get; set; }
Visual C++
public:
property array<Notification^>^ Notifications {
    array<Notification^>^ get ();
    void set (array<Notification^>^ value);
}
JavaScript
function get_notifications();
function set_notifications(value);

Remarks

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


RateReplyDetails Property

[image]

.NET Framework Class Library
RateReply..::.RateReplyDetails Property
RateReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateReplyDetails As RateReplyDetail()
C#
public RateReplyDetail[] RateReplyDetails { get; set; }
Visual C++
public:
property array<RateReplyDetail^>^ RateReplyDetails {
    array<RateReplyDetail^>^ get ();
    void set (array<RateReplyDetail^>^ value);
}
JavaScript
function get_rateReplyDetails();
function set_rateReplyDetails(value);

Remarks

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


TransactionDetail Property

[image]

.NET Framework Class Library
RateReply..::.TransactionDetail Property
RateReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionDetail As TransactionDetail
C#
public TransactionDetail TransactionDetail { get; set; }
Visual C++
public:
property TransactionDetail^ TransactionDetail {
    TransactionDetail^ get ();
    void set (TransactionDetail^ value);
}
JavaScript
function get_transactionDetail();
function set_transactionDetail(value);

Remarks

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


Version Property

[image]

.NET Framework Class Library
RateReply..::.Version Property
RateReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As VersionId
C#
public VersionId Version { get; set; }
Visual C++
public:
property VersionId^ Version {
    VersionId^ get ();
    void set (VersionId^ value);
}
JavaScript
function get_version();
function set_version(value);

Remarks

See Also

RateReply Class
InSite.Domain.FedExRateService Namespace


RateReplyDetail Class

[image]

.NET Framework Class Library
RateReplyDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RateReplyDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RateReplyDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RateReplyDetail
JavaScript
InSite.Domain.FedExRateService.RateReplyDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RateReplyDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.RateReplyDetail

See Also

RateReplyDetail Members
InSite.Domain.FedExRateService Namespace


RateReplyDetail Members

[image] [image]

.NET Framework Class Library
RateReplyDetail Members
RateReplyDetail Class Constructors Methods Properties See Also Send Feedback

The RateReplyDetail type exposes the following members.

Constructors

Name | Description
RateReplyDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActualRateType |
ActualRateTypeSpecified |
AppliedOptions |
AppliedSubOptions |
CommitDetails |
DeliveryDayOfWeek |
DeliveryDayOfWeekSpecified |
DeliveryStation |
DeliveryTimestamp |
DeliveryTimestampSpecified |
DestinationAirportId |
DestinationServiceArea |
IneligibleForMoneyBackGuarantee |
IneligibleForMoneyBackGuaranteeSpecified |
OriginServiceArea |
PackagingType |
PackagingTypeSpecified |
RatedShipmentDetails |
ServiceType |
ServiceTypeSpecified |
SignatureOption |
SignatureOptionSpecified |
TransitTime |
TransitTimeSpecified |

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


RateReplyDetail Constructor

[image]

.NET Framework Class Library
RateReplyDetail Constructor
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RateReplyDetail()
Visual C++
public:
RateReplyDetail()
JavaScript
InSite.Domain.FedExRateService.RateReplyDetail = function();

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


RateReplyDetail Methods

[image] [image]

.NET Framework Class Library
RateReplyDetail Methods
RateReplyDetail Class See Also Send Feedback

The RateReplyDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


RateReplyDetail Properties

[image] [image]

.NET Framework Class Library
RateReplyDetail Properties
RateReplyDetail Class See Also Send Feedback

The RateReplyDetail type exposes the following members.

Properties

Name | Description
ActualRateType |
ActualRateTypeSpecified |
AppliedOptions |
AppliedSubOptions |
CommitDetails |
DeliveryDayOfWeek |
DeliveryDayOfWeekSpecified |
DeliveryStation |
DeliveryTimestamp |
DeliveryTimestampSpecified |
DestinationAirportId |
DestinationServiceArea |
IneligibleForMoneyBackGuarantee |
IneligibleForMoneyBackGuaranteeSpecified |
OriginServiceArea |
PackagingType |
PackagingTypeSpecified |
RatedShipmentDetails |
ServiceType |
ServiceTypeSpecified |
SignatureOption |
SignatureOptionSpecified |
TransitTime |
TransitTimeSpecified |

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


ActualRateType Property

[image]

.NET Framework Class Library
RateReplyDetail..::.ActualRateType Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ActualRateType As ReturnedRateType
C#
public ReturnedRateType ActualRateType { get; set; }
Visual C++
public:
property ReturnedRateType ActualRateType {
    ReturnedRateType get ();
    void set (ReturnedRateType value);
}
JavaScript
function get_actualRateType();
function set_actualRateType(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


ActualRateTypeSpecified Property

[image]

.NET Framework Class Library
RateReplyDetail..::.ActualRateTypeSpecified Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ActualRateTypeSpecified As Boolean
C#
public bool ActualRateTypeSpecified { get; set; }
Visual C++
public:
property bool ActualRateTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_actualRateTypeSpecified();
function set_actualRateTypeSpecified(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


AppliedOptions Property

[image]

.NET Framework Class Library
RateReplyDetail..::.AppliedOptions Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AppliedOptions As ServiceOptionType()
C#
public ServiceOptionType[] AppliedOptions { get; set; }
Visual C++
public:
property array<ServiceOptionType>^ AppliedOptions {
    array<ServiceOptionType>^ get ();
    void set (array<ServiceOptionType>^ value);
}
JavaScript
function get_appliedOptions();
function set_appliedOptions(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


AppliedSubOptions Property

[image]

.NET Framework Class Library
RateReplyDetail..::.AppliedSubOptions Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AppliedSubOptions As ServiceSubOptionDetail
C#
public ServiceSubOptionDetail AppliedSubOptions { get; set; }
Visual C++
public:
property ServiceSubOptionDetail^ AppliedSubOptions {
    ServiceSubOptionDetail^ get ();
    void set (ServiceSubOptionDetail^ value);
}
JavaScript
function get_appliedSubOptions();
function set_appliedSubOptions(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


CommitDetails Property

[image]

.NET Framework Class Library
RateReplyDetail..::.CommitDetails Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CommitDetails As CommitDetail()
C#
public CommitDetail[] CommitDetails { get; set; }
Visual C++
public:
property array<CommitDetail^>^ CommitDetails {
    array<CommitDetail^>^ get ();
    void set (array<CommitDetail^>^ value);
}
JavaScript
function get_commitDetails();
function set_commitDetails(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


DeliveryDayOfWeek Property

[image]

.NET Framework Class Library
RateReplyDetail..::.DeliveryDayOfWeek Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DeliveryDayOfWeek As DayOfWeekType
C#
public DayOfWeekType DeliveryDayOfWeek { get; set; }
Visual C++
public:
property DayOfWeekType DeliveryDayOfWeek {
    DayOfWeekType get ();
    void set (DayOfWeekType value);
}
JavaScript
function get_deliveryDayOfWeek();
function set_deliveryDayOfWeek(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


DeliveryDayOfWeekSpecified Property

[image]

.NET Framework Class Library
RateReplyDetail..::.DeliveryDayOfWeekSpecified Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DeliveryDayOfWeekSpecified As Boolean
C#
public bool DeliveryDayOfWeekSpecified { get; set; }
Visual C++
public:
property bool DeliveryDayOfWeekSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_deliveryDayOfWeekSpecified();
function set_deliveryDayOfWeekSpecified(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


DeliveryStation Property

[image]

.NET Framework Class Library
RateReplyDetail..::.DeliveryStation Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DeliveryStation As String
C#
public string DeliveryStation { get; set; }
Visual C++
public:
property String^ DeliveryStation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_deliveryStation();
function set_deliveryStation(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


DeliveryTimestamp Property

[image]

.NET Framework Class Library
RateReplyDetail..::.DeliveryTimestamp Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DeliveryTimestamp As DateTime
C#
public DateTime DeliveryTimestamp { get; set; }
Visual C++
public:
property DateTime DeliveryTimestamp {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_deliveryTimestamp();
function set_deliveryTimestamp(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


DeliveryTimestampSpecified Property

[image]

.NET Framework Class Library
RateReplyDetail..::.DeliveryTimestampSpecified Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DeliveryTimestampSpecified As Boolean
C#
public bool DeliveryTimestampSpecified { get; set; }
Visual C++
public:
property bool DeliveryTimestampSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_deliveryTimestampSpecified();
function set_deliveryTimestampSpecified(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


DestinationAirportId Property

[image]

.NET Framework Class Library
RateReplyDetail..::.DestinationAirportId Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationAirportId As String
C#
public string DestinationAirportId { get; set; }
Visual C++
public:
property String^ DestinationAirportId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_destinationAirportId();
function set_destinationAirportId(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


DestinationServiceArea Property

[image]

.NET Framework Class Library
RateReplyDetail..::.DestinationServiceArea Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationServiceArea As String
C#
public string DestinationServiceArea { get; set; }
Visual C++
public:
property String^ DestinationServiceArea {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_destinationServiceArea();
function set_destinationServiceArea(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


IneligibleForMoneyBackGuarantee Property

[image]

.NET Framework Class Library
RateReplyDetail..::.IneligibleForMoneyBackGuarantee Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IneligibleForMoneyBackGuarantee As Boolean
C#
public bool IneligibleForMoneyBackGuarantee { get; set; }
Visual C++
public:
property bool IneligibleForMoneyBackGuarantee {
    bool get ();
    void set (bool value);
}
JavaScript
function get_ineligibleForMoneyBackGuarantee();
function set_ineligibleForMoneyBackGuarantee(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


IneligibleForMoneyBackGuaranteeSpecified Property

[image]

.NET Framework Class Library
RateReplyDetail..::.IneligibleForMoneyBackGuaranteeSpecified Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IneligibleForMoneyBackGuaranteeSpecified As Boolean
C#
public bool IneligibleForMoneyBackGuaranteeSpecified { get; set; }
Visual C++
public:
property bool IneligibleForMoneyBackGuaranteeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_ineligibleForMoneyBackGuaranteeSpecified();
function set_ineligibleForMoneyBackGuaranteeSpecified(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


OriginServiceArea Property

[image]

.NET Framework Class Library
RateReplyDetail..::.OriginServiceArea Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OriginServiceArea As String
C#
public string OriginServiceArea { get; set; }
Visual C++
public:
property String^ OriginServiceArea {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_originServiceArea();
function set_originServiceArea(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


PackagingType Property

[image]

.NET Framework Class Library
RateReplyDetail..::.PackagingType Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackagingType As PackagingType
C#
public PackagingType PackagingType { get; set; }
Visual C++
public:
property PackagingType PackagingType {
    PackagingType get ();
    void set (PackagingType value);
}
JavaScript
function get_packagingType();
function set_packagingType(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


PackagingTypeSpecified Property

[image]

.NET Framework Class Library
RateReplyDetail..::.PackagingTypeSpecified Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackagingTypeSpecified As Boolean
C#
public bool PackagingTypeSpecified { get; set; }
Visual C++
public:
property bool PackagingTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_packagingTypeSpecified();
function set_packagingTypeSpecified(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


RatedShipmentDetails Property

[image]

.NET Framework Class Library
RateReplyDetail..::.RatedShipmentDetails Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RatedShipmentDetails As RatedShipmentDetail()
C#
public RatedShipmentDetail[] RatedShipmentDetails { get; set; }
Visual C++
public:
property array<RatedShipmentDetail^>^ RatedShipmentDetails {
    array<RatedShipmentDetail^>^ get ();
    void set (array<RatedShipmentDetail^>^ value);
}
JavaScript
function get_ratedShipmentDetails();
function set_ratedShipmentDetails(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


ServiceType Property

[image]

.NET Framework Class Library
RateReplyDetail..::.ServiceType Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceType As ServiceType
C#
public ServiceType ServiceType { get; set; }
Visual C++
public:
property ServiceType ServiceType {
    ServiceType get ();
    void set (ServiceType value);
}
JavaScript
function get_serviceType();
function set_serviceType(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


ServiceTypeSpecified Property

[image]

.NET Framework Class Library
RateReplyDetail..::.ServiceTypeSpecified Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceTypeSpecified As Boolean
C#
public bool ServiceTypeSpecified { get; set; }
Visual C++
public:
property bool ServiceTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_serviceTypeSpecified();
function set_serviceTypeSpecified(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


SignatureOption Property

[image]

.NET Framework Class Library
RateReplyDetail..::.SignatureOption Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SignatureOption As SignatureOptionType
C#
public SignatureOptionType SignatureOption { get; set; }
Visual C++
public:
property SignatureOptionType SignatureOption {
    SignatureOptionType get ();
    void set (SignatureOptionType value);
}
JavaScript
function get_signatureOption();
function set_signatureOption(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


SignatureOptionSpecified Property

[image]

.NET Framework Class Library
RateReplyDetail..::.SignatureOptionSpecified Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SignatureOptionSpecified As Boolean
C#
public bool SignatureOptionSpecified { get; set; }
Visual C++
public:
property bool SignatureOptionSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_signatureOptionSpecified();
function set_signatureOptionSpecified(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


TransitTime Property

[image]

.NET Framework Class Library
RateReplyDetail..::.TransitTime Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransitTime As TransitTimeType
C#
public TransitTimeType TransitTime { get; set; }
Visual C++
public:
property TransitTimeType TransitTime {
    TransitTimeType get ();
    void set (TransitTimeType value);
}
JavaScript
function get_transitTime();
function set_transitTime(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


TransitTimeSpecified Property

[image]

.NET Framework Class Library
RateReplyDetail..::.TransitTimeSpecified Property
RateReplyDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransitTimeSpecified As Boolean
C#
public bool TransitTimeSpecified { get; set; }
Visual C++
public:
property bool TransitTimeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transitTimeSpecified();
function set_transitTimeSpecified(value);

Remarks

See Also

RateReplyDetail Class
InSite.Domain.FedExRateService Namespace


RateRequest Class

[image]

.NET Framework Class Library
RateRequest Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RateRequest
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RateRequest
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RateRequest
JavaScript
InSite.Domain.FedExRateService.RateRequest = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RateRequest');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.RateRequest

See Also

RateRequest Members
InSite.Domain.FedExRateService Namespace


RateRequest Members

[image] [image]

.NET Framework Class Library
RateRequest Members
RateRequest Class Constructors Methods Properties See Also Send Feedback

The RateRequest type exposes the following members.

Constructors

Name | Description
RateRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CarrierCodes |
ClientDetail |
RequestedShipment |
ReturnTransitAndCommit |
ReturnTransitAndCommitSpecified |
TransactionDetail |
VariableOptions |
Version |
WebAuthenticationDetail |

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


RateRequest Constructor

[image]

.NET Framework Class Library
RateRequest Constructor
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RateRequest()
Visual C++
public:
RateRequest()
JavaScript
InSite.Domain.FedExRateService.RateRequest = function();

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


RateRequest Methods

[image] [image]

.NET Framework Class Library
RateRequest Methods
RateRequest Class See Also Send Feedback

The RateRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


RateRequest Properties

[image] [image]

.NET Framework Class Library
RateRequest Properties
RateRequest Class See Also Send Feedback

The RateRequest type exposes the following members.

Properties

Name | Description
CarrierCodes |
ClientDetail |
RequestedShipment |
ReturnTransitAndCommit |
ReturnTransitAndCommitSpecified |
TransactionDetail |
VariableOptions |
Version |
WebAuthenticationDetail |

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


CarrierCodes Property

[image]

.NET Framework Class Library
RateRequest..::.CarrierCodes Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CarrierCodes As CarrierCodeType()
C#
public CarrierCodeType[] CarrierCodes { get; set; }
Visual C++
public:
property array<CarrierCodeType>^ CarrierCodes {
    array<CarrierCodeType>^ get ();
    void set (array<CarrierCodeType>^ value);
}
JavaScript
function get_carrierCodes();
function set_carrierCodes(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


ClientDetail Property

[image]

.NET Framework Class Library
RateRequest..::.ClientDetail Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientDetail As ClientDetail
C#
public ClientDetail ClientDetail { get; set; }
Visual C++
public:
property ClientDetail^ ClientDetail {
    ClientDetail^ get ();
    void set (ClientDetail^ value);
}
JavaScript
function get_clientDetail();
function set_clientDetail(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


RequestedShipment Property

[image]

.NET Framework Class Library
RateRequest..::.RequestedShipment Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RequestedShipment As RequestedShipment
C#
public RequestedShipment RequestedShipment { get; set; }
Visual C++
public:
property RequestedShipment^ RequestedShipment {
    RequestedShipment^ get ();
    void set (RequestedShipment^ value);
}
JavaScript
function get_requestedShipment();
function set_requestedShipment(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


ReturnTransitAndCommit Property

[image]

.NET Framework Class Library
RateRequest..::.ReturnTransitAndCommit Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnTransitAndCommit As Boolean
C#
public bool ReturnTransitAndCommit { get; set; }
Visual C++
public:
property bool ReturnTransitAndCommit {
    bool get ();
    void set (bool value);
}
JavaScript
function get_returnTransitAndCommit();
function set_returnTransitAndCommit(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


ReturnTransitAndCommitSpecified Property

[image]

.NET Framework Class Library
RateRequest..::.ReturnTransitAndCommitSpecified Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnTransitAndCommitSpecified As Boolean
C#
public bool ReturnTransitAndCommitSpecified { get; set; }
Visual C++
public:
property bool ReturnTransitAndCommitSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_returnTransitAndCommitSpecified();
function set_returnTransitAndCommitSpecified(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


TransactionDetail Property

[image]

.NET Framework Class Library
RateRequest..::.TransactionDetail Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionDetail As TransactionDetail
C#
public TransactionDetail TransactionDetail { get; set; }
Visual C++
public:
property TransactionDetail^ TransactionDetail {
    TransactionDetail^ get ();
    void set (TransactionDetail^ value);
}
JavaScript
function get_transactionDetail();
function set_transactionDetail(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


VariableOptions Property

[image]

.NET Framework Class Library
RateRequest..::.VariableOptions Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableOptions As ServiceOptionType()
C#
public ServiceOptionType[] VariableOptions { get; set; }
Visual C++
public:
property array<ServiceOptionType>^ VariableOptions {
    array<ServiceOptionType>^ get ();
    void set (array<ServiceOptionType>^ value);
}
JavaScript
function get_variableOptions();
function set_variableOptions(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


Version Property

[image]

.NET Framework Class Library
RateRequest..::.Version Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As VersionId
C#
public VersionId Version { get; set; }
Visual C++
public:
property VersionId^ Version {
    VersionId^ get ();
    void set (VersionId^ value);
}
JavaScript
function get_version();
function set_version(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


WebAuthenticationDetail Property

[image]

.NET Framework Class Library
RateRequest..::.WebAuthenticationDetail Property
RateRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property WebAuthenticationDetail As WebAuthenticationDetail
C#
public WebAuthenticationDetail WebAuthenticationDetail { get; set; }
Visual C++
public:
property WebAuthenticationDetail^ WebAuthenticationDetail {
    WebAuthenticationDetail^ get ();
    void set (WebAuthenticationDetail^ value);
}
JavaScript
function get_webAuthenticationDetail();
function set_webAuthenticationDetail(value);

Remarks

See Also

RateRequest Class
InSite.Domain.FedExRateService Namespace


RateRequestType Enumeration

[image]

.NET Framework Class Library
RateRequestType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RateRequestType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RateRequestType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RateRequestType
JavaScript
InSite.Domain.FedExRateService.RateRequestType = function();
InSite.Domain.FedExRateService.RateRequestType.createEnum('InSite.Domain.FedExRateService.RateRequestType', false);

Members

Member name | Description
ACCOUNT |
LIST |
MULTIWEIGHT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RateService Class

[image]

.NET Framework Class Library
RateService Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<WebServiceBindingAttribute(Name := "RateServiceSoapBinding", Namespace := "http://fedex.com/ws/rate/v7")> _
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Class RateService _
    Inherits SoapHttpClientProtocol
C#
[WebServiceBindingAttribute(Name = "RateServiceSoapBinding", Namespace = "http://fedex.com/ws/rate/v7")]
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public class RateService : SoapHttpClientProtocol
Visual C++
[WebServiceBindingAttribute(Name = L"RateServiceSoapBinding", Namespace = L"http://fedex.com/ws/rate/v7")]
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public ref class RateService : public SoapHttpClientProtocol
JavaScript
InSite.Domain.FedExRateService.RateService = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RateService',
    SoapHttpClientProtocol);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Web.Services.Protocols..::.WebClientProtocol
System.Web.Services.Protocols..::.HttpWebClientProtocol
System.Web.Services.Protocols..::.SoapHttpClientProtocol
InSite.Domain.FedExRateService..::.RateService

See Also

RateService Members
InSite.Domain.FedExRateService Namespace


RateService Members

[image] [image]

.NET Framework Class Library
RateService Members
RateService Class Constructors Methods Properties Events See Also Send Feedback

The RateService type exposes the following members.

Constructors

Name | Description
RateService |

Methods

Name | Description
Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
CancelAsync |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Dispose | Overloaded.
EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
getRates |
getRatesAsync | Overloaded.
GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
GetWebResponse | Overloaded.
GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
InvokeAsync | Overloaded.
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true. (Inherited from HttpWebClientProtocol.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Url |
UseDefaultCredentials |
UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)

Events

Name | Description
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
getRatesCompleted |

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


RateService Constructor

[image]

.NET Framework Class Library
RateService Constructor
RateService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RateService()
Visual C++
public:
RateService()
JavaScript
InSite.Domain.FedExRateService.RateService = function();

Remarks

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


RateService Methods

[image] [image]

.NET Framework Class Library
RateService Methods
RateService Class See Also Send Feedback

The RateService type exposes the following members.

Methods

Name | Description
Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
CancelAsync |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Dispose | Overloaded.
EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
getRates |
getRatesAsync | Overloaded.
GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
GetWebResponse | Overloaded.
GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
InvokeAsync | Overloaded.
MemberwiseClone | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


CancelAsync Method

[image]

.NET Framework Class Library
RateService..::.CancelAsync Method
RateService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelAsync ( _
    userState As Object _
)
C#
public void CancelAsync(
    Object userState
)
Visual C++
public:
void CancelAsync(
    Object^ userState
)
JavaScript
function cancelAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
RateService..::.Dispose Method
RateService Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

RateService Class
RateService Members
InSite.Domain.FedExRateService Namespace


getRates Method

[image]

.NET Framework Class Library
RateService..::.getRates Method
RateService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("getRates", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
Public Function getRates ( _
    RateRequest As RateRequest _
) As RateReply
C#
[SoapDocumentMethodAttribute("getRates", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
public RateReply getRates(
    RateRequest RateRequest
)
Visual C++
[SoapDocumentMethodAttribute(L"getRates", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
public:
RateReply^ getRates(
    RateRequest^ RateRequest
)
JavaScript
function getRates(RateRequest);

Parameters

RateRequest
Type: InSite.Domain.FedExRateService..::.RateRequest

Remarks

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


getRatesAsync Method

[image] [image]

.NET Framework Class Library
RateService..::.getRatesAsync Method
RateService Class See Also Send Feedback

Overload List

Name | Description
getRatesAsync(RateRequest) |
getRatesAsync(RateRequest, Object) |

See Also

RateService Class
RateService Members
InSite.Domain.FedExRateService Namespace


getRatesAsync Method (RateRequest)

[image]

.NET Framework Class Library
RateService..::.getRatesAsync Method (RateRequest)
RateService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub getRatesAsync ( _
    RateRequest As RateRequest _
)
C#
public void getRatesAsync(
    RateRequest RateRequest
)
Visual C++
public:
void getRatesAsync(
    RateRequest^ RateRequest
)
JavaScript
function getRatesAsync(RateRequest);

Parameters

RateRequest
Type: InSite.Domain.FedExRateService..::.RateRequest

Remarks

See Also

RateService Class
getRatesAsync Overload
InSite.Domain.FedExRateService Namespace


getRatesAsync Method (RateRequest, Object)

[image]

.NET Framework Class Library
RateService..::.getRatesAsync Method (RateRequest, Object)
RateService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub getRatesAsync ( _
    RateRequest As RateRequest, _
    userState As Object _
)
C#
public void getRatesAsync(
    RateRequest RateRequest,
    Object userState
)
Visual C++
public:
void getRatesAsync(
    RateRequest^ RateRequest,
    Object^ userState
)
JavaScript
function getRatesAsync(RateRequest, userState);

Parameters

RateRequest
Type: InSite.Domain.FedExRateService..::.RateRequest
userState
Type: System..::.Object

Remarks

See Also

RateService Class
getRatesAsync Overload
InSite.Domain.FedExRateService Namespace


GetWebResponse Method

[image] [image]

.NET Framework Class Library
RateService..::.GetWebResponse Method
RateService Class See Also Send Feedback

Overload List

Name | Description
GetWebResponse(WebRequest) | Returns a response from a synchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
GetWebResponse(WebRequest, IAsyncResult) | Returns a response from an asynchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)

See Also

RateService Class
RateService Members
InSite.Domain.FedExRateService Namespace


InvokeAsync Method

[image] [image]

.NET Framework Class Library
RateService..::.InvokeAsync Method
RateService Class See Also Send Feedback

Overload List

Name | Description
InvokeAsync(String, array<Object>[]()[], SendOrPostCallback) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
InvokeAsync(String, array<Object>[]()[], SendOrPostCallback, Object) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)

See Also

RateService Class
RateService Members
InSite.Domain.FedExRateService Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
RateService..::.MemberwiseClone Method
RateService Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RateService Class
RateService Members
InSite.Domain.FedExRateService Namespace


RateService Properties

[image] [image]

.NET Framework Class Library
RateService Properties
RateService Class See Also Send Feedback

The RateService type exposes the following members.

Properties

Name | Description
AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true. (Inherited from HttpWebClientProtocol.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Url |
UseDefaultCredentials |
UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


Url Property

[image]

.NET Framework Class Library
RateService..::.Url Property
RateService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url { get; set; }
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_url();
function set_url(value);

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


UseDefaultCredentials Property

[image]

.NET Framework Class Library
RateService..::.UseDefaultCredentials Property
RateService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UseDefaultCredentials As Boolean
C#
public bool UseDefaultCredentials { get; set; }
Visual C++
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useDefaultCredentials();
function set_useDefaultCredentials(value);

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


RateService Events

[image] [image]

.NET Framework Class Library
RateService Events
RateService Class See Also Send Feedback

The RateService type exposes the following members.

Events

Name | Description
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
getRatesCompleted |

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


getRatesCompleted Event

[image]

.NET Framework Class Library
RateService..::.getRatesCompleted Event
RateService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event getRatesCompleted As getRatesCompletedEventHandler
C#
public event getRatesCompletedEventHandler getRatesCompleted
Visual C++
public:
 event getRatesCompletedEventHandler^ getRatesCompleted {
    void add (getRatesCompletedEventHandler^ value);
    void remove (getRatesCompletedEventHandler^ value);
}
JavaScript
function add_getRatesCompleted(value);
function remove_getRatesCompleted(value);

Remarks

See Also

RateService Class
InSite.Domain.FedExRateService Namespace


Rebate Class

[image]

.NET Framework Class Library
Rebate Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Rebate
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Rebate
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Rebate
JavaScript
InSite.Domain.FedExRateService.Rebate = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Rebate');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Rebate

See Also

Rebate Members
InSite.Domain.FedExRateService Namespace


Rebate Members

[image] [image]

.NET Framework Class Library
Rebate Members
Rebate Class Constructors Methods Properties See Also Send Feedback

The Rebate type exposes the following members.

Constructors

Name | Description
Rebate |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Description |
Percent |
PercentSpecified |
RebateType |
RebateTypeSpecified |

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


Rebate Constructor

[image]

.NET Framework Class Library
Rebate Constructor
Rebate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Rebate()
Visual C++
public:
Rebate()
JavaScript
InSite.Domain.FedExRateService.Rebate = function();

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


Rebate Methods

[image] [image]

.NET Framework Class Library
Rebate Methods
Rebate Class See Also Send Feedback

The Rebate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


Rebate Properties

[image] [image]

.NET Framework Class Library
Rebate Properties
Rebate Class See Also Send Feedback

The Rebate type exposes the following members.

Properties

Name | Description
Amount |
Description |
Percent |
PercentSpecified |
RebateType |
RebateTypeSpecified |

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


Amount Property

[image]

.NET Framework Class Library
Rebate..::.Amount Property
Rebate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As Money
C#
public Money Amount { get; set; }
Visual C++
public:
property Money^ Amount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
Rebate..::.Description Property
Rebate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


Percent Property

[image]

.NET Framework Class Library
Rebate..::.Percent Property
Rebate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Percent As Decimal
C#
public decimal Percent { get; set; }
Visual C++
public:
property Decimal Percent {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_percent();
function set_percent(value);

Remarks

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


PercentSpecified Property

[image]

.NET Framework Class Library
Rebate..::.PercentSpecified Property
Rebate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PercentSpecified As Boolean
C#
public bool PercentSpecified { get; set; }
Visual C++
public:
property bool PercentSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_percentSpecified();
function set_percentSpecified(value);

Remarks

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


RebateType Property

[image]

.NET Framework Class Library
Rebate..::.RebateType Property
Rebate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RebateType As RebateType
C#
public RebateType RebateType { get; set; }
Visual C++
public:
property RebateType RebateType {
    RebateType get ();
    void set (RebateType value);
}
JavaScript
function get_rebateType();
function set_rebateType(value);

Remarks

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


RebateTypeSpecified Property

[image]

.NET Framework Class Library
Rebate..::.RebateTypeSpecified Property
Rebate Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RebateTypeSpecified As Boolean
C#
public bool RebateTypeSpecified { get; set; }
Visual C++
public:
property bool RebateTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_rebateTypeSpecified();
function set_rebateTypeSpecified(value);

Remarks

See Also

Rebate Class
InSite.Domain.FedExRateService Namespace


RebateType Enumeration

[image]

.NET Framework Class Library
RebateType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RebateType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RebateType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RebateType
JavaScript
InSite.Domain.FedExRateService.RebateType = function();
InSite.Domain.FedExRateService.RebateType.createEnum('InSite.Domain.FedExRateService.RebateType', false);

Members

Member name | Description
EARNED |
OTHER |
BONUS |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RecipientCustomsIdType Enumeration

[image]

.NET Framework Class Library
RecipientCustomsIdType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RecipientCustomsIdType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RecipientCustomsIdType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RecipientCustomsIdType
JavaScript
InSite.Domain.FedExRateService.RecipientCustomsIdType = function();
InSite.Domain.FedExRateService.RecipientCustomsIdType.createEnum('InSite.Domain.FedExRateService.RecipientCustomsIdType', false);

Members

Member name | Description
COMPANY |
INDIVIDUAL |
PASSPORT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RegulatoryControlType Enumeration

[image]

.NET Framework Class Library
RegulatoryControlType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RegulatoryControlType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RegulatoryControlType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RegulatoryControlType
JavaScript
InSite.Domain.FedExRateService.RegulatoryControlType = function();
InSite.Domain.FedExRateService.RegulatoryControlType.createEnum('InSite.Domain.FedExRateService.RegulatoryControlType', false);

Members

Member name | Description
EU_CIRCULATION |
FOOD_OR_PERISHABLE |
NAFTA |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RequestedPackageDetailType Enumeration

[image]

.NET Framework Class Library
RequestedPackageDetailType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RequestedPackageDetailType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RequestedPackageDetailType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RequestedPackageDetailType
JavaScript
InSite.Domain.FedExRateService.RequestedPackageDetailType = function();
InSite.Domain.FedExRateService.RequestedPackageDetailType.createEnum('InSite.Domain.FedExRateService.RequestedPackageDetailType', false);

Members

Member name | Description
INDIVIDUAL_PACKAGES |
PACKAGE_SUMMARY |
PACKAGE_GROUPS |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RequestedPackageLineItem Class

[image]

.NET Framework Class Library
RequestedPackageLineItem Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RequestedPackageLineItem
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RequestedPackageLineItem
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RequestedPackageLineItem
JavaScript
InSite.Domain.FedExRateService.RequestedPackageLineItem = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RequestedPackageLineItem');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.RequestedPackageLineItem

See Also

RequestedPackageLineItem Members
InSite.Domain.FedExRateService Namespace


RequestedPackageLineItem Members

[image] [image]

.NET Framework Class Library
RequestedPackageLineItem Members
RequestedPackageLineItem Class Constructors Methods Properties See Also Send Feedback

The RequestedPackageLineItem type exposes the following members.

Constructors

Name | Description
RequestedPackageLineItem |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ContentRecords |
CustomerReferences |
Dimensions |
GroupNumber |
GroupPackageCount |
InsuredValue |
ItemDescription |
PhysicalPackaging |
PhysicalPackagingSpecified |
SequenceNumber |
SpecialServicesRequested |
VariableHandlingChargeDetail |
Weight |

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


RequestedPackageLineItem Constructor

[image]

.NET Framework Class Library
RequestedPackageLineItem Constructor
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RequestedPackageLineItem()
Visual C++
public:
RequestedPackageLineItem()
JavaScript
InSite.Domain.FedExRateService.RequestedPackageLineItem = function();

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


RequestedPackageLineItem Methods

[image] [image]

.NET Framework Class Library
RequestedPackageLineItem Methods
RequestedPackageLineItem Class See Also Send Feedback

The RequestedPackageLineItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


RequestedPackageLineItem Properties

[image] [image]

.NET Framework Class Library
RequestedPackageLineItem Properties
RequestedPackageLineItem Class See Also Send Feedback

The RequestedPackageLineItem type exposes the following members.

Properties

Name | Description
ContentRecords |
CustomerReferences |
Dimensions |
GroupNumber |
GroupPackageCount |
InsuredValue |
ItemDescription |
PhysicalPackaging |
PhysicalPackagingSpecified |
SequenceNumber |
SpecialServicesRequested |
VariableHandlingChargeDetail |
Weight |

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


ContentRecords Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.ContentRecords Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentRecords As ContentRecord()
C#
public ContentRecord[] ContentRecords { get; set; }
Visual C++
public:
property array<ContentRecord^>^ ContentRecords {
    array<ContentRecord^>^ get ();
    void set (array<ContentRecord^>^ value);
}
JavaScript
function get_contentRecords();
function set_contentRecords(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


CustomerReferences Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.CustomerReferences Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerReferences As CustomerReference()
C#
public CustomerReference[] CustomerReferences { get; set; }
Visual C++
public:
property array<CustomerReference^>^ CustomerReferences {
    array<CustomerReference^>^ get ();
    void set (array<CustomerReference^>^ value);
}
JavaScript
function get_customerReferences();
function set_customerReferences(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


Dimensions Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.Dimensions Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Dimensions As Dimensions
C#
public Dimensions Dimensions { get; set; }
Visual C++
public:
property Dimensions^ Dimensions {
    Dimensions^ get ();
    void set (Dimensions^ value);
}
JavaScript
function get_dimensions();
function set_dimensions(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


GroupNumber Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.GroupNumber Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property GroupNumber As String
C#
public string GroupNumber { get; set; }
Visual C++
public:
property String^ GroupNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_groupNumber();
function set_groupNumber(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


GroupPackageCount Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.GroupPackageCount Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property GroupPackageCount As String
C#
public string GroupPackageCount { get; set; }
Visual C++
public:
property String^ GroupPackageCount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_groupPackageCount();
function set_groupPackageCount(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


InsuredValue Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.InsuredValue Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property InsuredValue As Money
C#
public Money InsuredValue { get; set; }
Visual C++
public:
property Money^ InsuredValue {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_insuredValue();
function set_insuredValue(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


ItemDescription Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.ItemDescription Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ItemDescription As String
C#
public string ItemDescription { get; set; }
Visual C++
public:
property String^ ItemDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_itemDescription();
function set_itemDescription(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


PhysicalPackaging Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.PhysicalPackaging Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PhysicalPackaging As PhysicalPackagingType
C#
public PhysicalPackagingType PhysicalPackaging { get; set; }
Visual C++
public:
property PhysicalPackagingType PhysicalPackaging {
    PhysicalPackagingType get ();
    void set (PhysicalPackagingType value);
}
JavaScript
function get_physicalPackaging();
function set_physicalPackaging(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


PhysicalPackagingSpecified Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.PhysicalPackagingSpecified Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PhysicalPackagingSpecified As Boolean
C#
public bool PhysicalPackagingSpecified { get; set; }
Visual C++
public:
property bool PhysicalPackagingSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_physicalPackagingSpecified();
function set_physicalPackagingSpecified(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


SequenceNumber Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.SequenceNumber Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SequenceNumber As String
C#
public string SequenceNumber { get; set; }
Visual C++
public:
property String^ SequenceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_sequenceNumber();
function set_sequenceNumber(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


SpecialServicesRequested Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.SpecialServicesRequested Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecialServicesRequested As PackageSpecialServicesRequested
C#
public PackageSpecialServicesRequested SpecialServicesRequested { get; set; }
Visual C++
public:
property PackageSpecialServicesRequested^ SpecialServicesRequested {
    PackageSpecialServicesRequested^ get ();
    void set (PackageSpecialServicesRequested^ value);
}
JavaScript
function get_specialServicesRequested();
function set_specialServicesRequested(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


VariableHandlingChargeDetail Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.VariableHandlingChargeDetail Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableHandlingChargeDetail As VariableHandlingChargeDetail
C#
public VariableHandlingChargeDetail VariableHandlingChargeDetail { get; set; }
Visual C++
public:
property VariableHandlingChargeDetail^ VariableHandlingChargeDetail {
    VariableHandlingChargeDetail^ get ();
    void set (VariableHandlingChargeDetail^ value);
}
JavaScript
function get_variableHandlingChargeDetail();
function set_variableHandlingChargeDetail(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


Weight Property

[image]

.NET Framework Class Library
RequestedPackageLineItem..::.Weight Property
RequestedPackageLineItem Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Weight As Weight
C#
public Weight Weight { get; set; }
Visual C++
public:
property Weight^ Weight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_weight();
function set_weight(value);

Remarks

See Also

RequestedPackageLineItem Class
InSite.Domain.FedExRateService Namespace


RequestedShipment Class

[image]

.NET Framework Class Library
RequestedShipment Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RequestedShipment
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RequestedShipment
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RequestedShipment
JavaScript
InSite.Domain.FedExRateService.RequestedShipment = function();

Type.createClass(
    'InSite.Domain.FedExRateService.RequestedShipment');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.RequestedShipment

See Also

RequestedShipment Members
InSite.Domain.FedExRateService Namespace


RequestedShipment Members

[image] [image]

.NET Framework Class Library
RequestedShipment Members
RequestedShipment Class Constructors Methods Properties See Also Send Feedback

The RequestedShipment type exposes the following members.

Constructors

Name | Description
RequestedShipment |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BlockInsightVisibility |
BlockInsightVisibilitySpecified |
DeliveryInstructions |
DropoffType |
DropoffTypeSpecified |
EdtRequestType |
EdtRequestTypeSpecified |
ExpressFreightDetail |
FreightShipmentDetail |
InternationalDetail |
LabelSpecification |
Origin |
PackageCount |
PackageDetail |
PackageDetailSpecified |
PackagingType |
PackagingTypeSpecified |
PickupDetail |
RateRequestTypes |
Recipient |
RecipientLocationNumber |
RequestedPackageLineItems |
ServiceType |
ServiceTypeSpecified |
Shipper |
ShippingChargesPayment |
ShippingDocumentSpecification |
ShipTimestamp |
ShipTimestampSpecified |
SmartPostDetail |
SpecialServicesRequested |
TotalInsuredValue |
TotalWeight |
VariableHandlingChargeDetail |

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


RequestedShipment Constructor

[image]

.NET Framework Class Library
RequestedShipment Constructor
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RequestedShipment()
Visual C++
public:
RequestedShipment()
JavaScript
InSite.Domain.FedExRateService.RequestedShipment = function();

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


RequestedShipment Methods

[image] [image]

.NET Framework Class Library
RequestedShipment Methods
RequestedShipment Class See Also Send Feedback

The RequestedShipment type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


RequestedShipment Properties

[image] [image]

.NET Framework Class Library
RequestedShipment Properties
RequestedShipment Class See Also Send Feedback

The RequestedShipment type exposes the following members.

Properties

Name | Description
BlockInsightVisibility |
BlockInsightVisibilitySpecified |
DeliveryInstructions |
DropoffType |
DropoffTypeSpecified |
EdtRequestType |
EdtRequestTypeSpecified |
ExpressFreightDetail |
FreightShipmentDetail |
InternationalDetail |
LabelSpecification |
Origin |
PackageCount |
PackageDetail |
PackageDetailSpecified |
PackagingType |
PackagingTypeSpecified |
PickupDetail |
RateRequestTypes |
Recipient |
RecipientLocationNumber |
RequestedPackageLineItems |
ServiceType |
ServiceTypeSpecified |
Shipper |
ShippingChargesPayment |
ShippingDocumentSpecification |
ShipTimestamp |
ShipTimestampSpecified |
SmartPostDetail |
SpecialServicesRequested |
TotalInsuredValue |
TotalWeight |
VariableHandlingChargeDetail |

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


BlockInsightVisibility Property

[image]

.NET Framework Class Library
RequestedShipment..::.BlockInsightVisibility Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BlockInsightVisibility As Boolean
C#
public bool BlockInsightVisibility { get; set; }
Visual C++
public:
property bool BlockInsightVisibility {
    bool get ();
    void set (bool value);
}
JavaScript
function get_blockInsightVisibility();
function set_blockInsightVisibility(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


BlockInsightVisibilitySpecified Property

[image]

.NET Framework Class Library
RequestedShipment..::.BlockInsightVisibilitySpecified Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BlockInsightVisibilitySpecified As Boolean
C#
public bool BlockInsightVisibilitySpecified { get; set; }
Visual C++
public:
property bool BlockInsightVisibilitySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_blockInsightVisibilitySpecified();
function set_blockInsightVisibilitySpecified(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


DeliveryInstructions Property

[image]

.NET Framework Class Library
RequestedShipment..::.DeliveryInstructions Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DeliveryInstructions As String
C#
public string DeliveryInstructions { get; set; }
Visual C++
public:
property String^ DeliveryInstructions {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_deliveryInstructions();
function set_deliveryInstructions(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


DropoffType Property

[image]

.NET Framework Class Library
RequestedShipment..::.DropoffType Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DropoffType As DropoffType
C#
public DropoffType DropoffType { get; set; }
Visual C++
public:
property DropoffType DropoffType {
    DropoffType get ();
    void set (DropoffType value);
}
JavaScript
function get_dropoffType();
function set_dropoffType(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


DropoffTypeSpecified Property

[image]

.NET Framework Class Library
RequestedShipment..::.DropoffTypeSpecified Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DropoffTypeSpecified As Boolean
C#
public bool DropoffTypeSpecified { get; set; }
Visual C++
public:
property bool DropoffTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dropoffTypeSpecified();
function set_dropoffTypeSpecified(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


EdtRequestType Property

[image]

.NET Framework Class Library
RequestedShipment..::.EdtRequestType Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EdtRequestType As EdtRequestType
C#
public EdtRequestType EdtRequestType { get; set; }
Visual C++
public:
property EdtRequestType EdtRequestType {
    EdtRequestType get ();
    void set (EdtRequestType value);
}
JavaScript
function get_edtRequestType();
function set_edtRequestType(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


EdtRequestTypeSpecified Property

[image]

.NET Framework Class Library
RequestedShipment..::.EdtRequestTypeSpecified Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EdtRequestTypeSpecified As Boolean
C#
public bool EdtRequestTypeSpecified { get; set; }
Visual C++
public:
property bool EdtRequestTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_edtRequestTypeSpecified();
function set_edtRequestTypeSpecified(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


ExpressFreightDetail Property

[image]

.NET Framework Class Library
RequestedShipment..::.ExpressFreightDetail Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpressFreightDetail As ExpressFreightDetail
C#
public ExpressFreightDetail ExpressFreightDetail { get; set; }
Visual C++
public:
property ExpressFreightDetail^ ExpressFreightDetail {
    ExpressFreightDetail^ get ();
    void set (ExpressFreightDetail^ value);
}
JavaScript
function get_expressFreightDetail();
function set_expressFreightDetail(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


FreightShipmentDetail Property

[image]

.NET Framework Class Library
RequestedShipment..::.FreightShipmentDetail Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightShipmentDetail As FreightShipmentDetail
C#
public FreightShipmentDetail FreightShipmentDetail { get; set; }
Visual C++
public:
property FreightShipmentDetail^ FreightShipmentDetail {
    FreightShipmentDetail^ get ();
    void set (FreightShipmentDetail^ value);
}
JavaScript
function get_freightShipmentDetail();
function set_freightShipmentDetail(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


InternationalDetail Property

[image]

.NET Framework Class Library
RequestedShipment..::.InternationalDetail Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property InternationalDetail As InternationalDetail
C#
public InternationalDetail InternationalDetail { get; set; }
Visual C++
public:
property InternationalDetail^ InternationalDetail {
    InternationalDetail^ get ();
    void set (InternationalDetail^ value);
}
JavaScript
function get_internationalDetail();
function set_internationalDetail(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


LabelSpecification Property

[image]

.NET Framework Class Library
RequestedShipment..::.LabelSpecification Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LabelSpecification As LabelSpecification
C#
public LabelSpecification LabelSpecification { get; set; }
Visual C++
public:
property LabelSpecification^ LabelSpecification {
    LabelSpecification^ get ();
    void set (LabelSpecification^ value);
}
JavaScript
function get_labelSpecification();
function set_labelSpecification(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


Origin Property

[image]

.NET Framework Class Library
RequestedShipment..::.Origin Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Origin As ContactAndAddress
C#
public ContactAndAddress Origin { get; set; }
Visual C++
public:
property ContactAndAddress^ Origin {
    ContactAndAddress^ get ();
    void set (ContactAndAddress^ value);
}
JavaScript
function get_origin();
function set_origin(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


PackageCount Property

[image]

.NET Framework Class Library
RequestedShipment..::.PackageCount Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackageCount As String
C#
public string PackageCount { get; set; }
Visual C++
public:
property String^ PackageCount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_packageCount();
function set_packageCount(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


PackageDetail Property

[image]

.NET Framework Class Library
RequestedShipment..::.PackageDetail Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackageDetail As RequestedPackageDetailType
C#
public RequestedPackageDetailType PackageDetail { get; set; }
Visual C++
public:
property RequestedPackageDetailType PackageDetail {
    RequestedPackageDetailType get ();
    void set (RequestedPackageDetailType value);
}
JavaScript
function get_packageDetail();
function set_packageDetail(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


PackageDetailSpecified Property

[image]

.NET Framework Class Library
RequestedShipment..::.PackageDetailSpecified Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackageDetailSpecified As Boolean
C#
public bool PackageDetailSpecified { get; set; }
Visual C++
public:
property bool PackageDetailSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_packageDetailSpecified();
function set_packageDetailSpecified(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


PackagingType Property

[image]

.NET Framework Class Library
RequestedShipment..::.PackagingType Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackagingType As PackagingType
C#
public PackagingType PackagingType { get; set; }
Visual C++
public:
property PackagingType PackagingType {
    PackagingType get ();
    void set (PackagingType value);
}
JavaScript
function get_packagingType();
function set_packagingType(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


PackagingTypeSpecified Property

[image]

.NET Framework Class Library
RequestedShipment..::.PackagingTypeSpecified Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackagingTypeSpecified As Boolean
C#
public bool PackagingTypeSpecified { get; set; }
Visual C++
public:
property bool PackagingTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_packagingTypeSpecified();
function set_packagingTypeSpecified(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


PickupDetail Property

[image]

.NET Framework Class Library
RequestedShipment..::.PickupDetail Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PickupDetail As PickupDetail
C#
public PickupDetail PickupDetail { get; set; }
Visual C++
public:
property PickupDetail^ PickupDetail {
    PickupDetail^ get ();
    void set (PickupDetail^ value);
}
JavaScript
function get_pickupDetail();
function set_pickupDetail(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


RateRequestTypes Property

[image]

.NET Framework Class Library
RequestedShipment..::.RateRequestTypes Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateRequestTypes As RateRequestType()
C#
public RateRequestType[] RateRequestTypes { get; set; }
Visual C++
public:
property array<RateRequestType>^ RateRequestTypes {
    array<RateRequestType>^ get ();
    void set (array<RateRequestType>^ value);
}
JavaScript
function get_rateRequestTypes();
function set_rateRequestTypes(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


Recipient Property

[image]

.NET Framework Class Library
RequestedShipment..::.Recipient Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Recipient As Party
C#
public Party Recipient { get; set; }
Visual C++
public:
property Party^ Recipient {
    Party^ get ();
    void set (Party^ value);
}
JavaScript
function get_recipient();
function set_recipient(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


RecipientLocationNumber Property

[image]

.NET Framework Class Library
RequestedShipment..::.RecipientLocationNumber Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RecipientLocationNumber As String
C#
public string RecipientLocationNumber { get; set; }
Visual C++
public:
property String^ RecipientLocationNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_recipientLocationNumber();
function set_recipientLocationNumber(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


RequestedPackageLineItems Property

[image]

.NET Framework Class Library
RequestedShipment..::.RequestedPackageLineItems Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RequestedPackageLineItems As RequestedPackageLineItem()
C#
public RequestedPackageLineItem[] RequestedPackageLineItems { get; set; }
Visual C++
public:
property array<RequestedPackageLineItem^>^ RequestedPackageLineItems {
    array<RequestedPackageLineItem^>^ get ();
    void set (array<RequestedPackageLineItem^>^ value);
}
JavaScript
function get_requestedPackageLineItems();
function set_requestedPackageLineItems(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


ServiceType Property

[image]

.NET Framework Class Library
RequestedShipment..::.ServiceType Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceType As ServiceType
C#
public ServiceType ServiceType { get; set; }
Visual C++
public:
property ServiceType ServiceType {
    ServiceType get ();
    void set (ServiceType value);
}
JavaScript
function get_serviceType();
function set_serviceType(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


ServiceTypeSpecified Property

[image]

.NET Framework Class Library
RequestedShipment..::.ServiceTypeSpecified Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceTypeSpecified As Boolean
C#
public bool ServiceTypeSpecified { get; set; }
Visual C++
public:
property bool ServiceTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_serviceTypeSpecified();
function set_serviceTypeSpecified(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


Shipper Property

[image]

.NET Framework Class Library
RequestedShipment..::.Shipper Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Shipper As Party
C#
public Party Shipper { get; set; }
Visual C++
public:
property Party^ Shipper {
    Party^ get ();
    void set (Party^ value);
}
JavaScript
function get_shipper();
function set_shipper(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


ShippingChargesPayment Property

[image]

.NET Framework Class Library
RequestedShipment..::.ShippingChargesPayment Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShippingChargesPayment As Payment
C#
public Payment ShippingChargesPayment { get; set; }
Visual C++
public:
property Payment^ ShippingChargesPayment {
    Payment^ get ();
    void set (Payment^ value);
}
JavaScript
function get_shippingChargesPayment();
function set_shippingChargesPayment(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentSpecification Property

[image]

.NET Framework Class Library
RequestedShipment..::.ShippingDocumentSpecification Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShippingDocumentSpecification As ShippingDocumentSpecification
C#
public ShippingDocumentSpecification ShippingDocumentSpecification { get; set; }
Visual C++
public:
property ShippingDocumentSpecification^ ShippingDocumentSpecification {
    ShippingDocumentSpecification^ get ();
    void set (ShippingDocumentSpecification^ value);
}
JavaScript
function get_shippingDocumentSpecification();
function set_shippingDocumentSpecification(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


ShipTimestamp Property

[image]

.NET Framework Class Library
RequestedShipment..::.ShipTimestamp Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipTimestamp As DateTime
C#
public DateTime ShipTimestamp { get; set; }
Visual C++
public:
property DateTime ShipTimestamp {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_shipTimestamp();
function set_shipTimestamp(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


ShipTimestampSpecified Property

[image]

.NET Framework Class Library
RequestedShipment..::.ShipTimestampSpecified Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipTimestampSpecified As Boolean
C#
public bool ShipTimestampSpecified { get; set; }
Visual C++
public:
property bool ShipTimestampSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shipTimestampSpecified();
function set_shipTimestampSpecified(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


SmartPostDetail Property

[image]

.NET Framework Class Library
RequestedShipment..::.SmartPostDetail Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SmartPostDetail As SmartPostShipmentDetail
C#
public SmartPostShipmentDetail SmartPostDetail { get; set; }
Visual C++
public:
property SmartPostShipmentDetail^ SmartPostDetail {
    SmartPostShipmentDetail^ get ();
    void set (SmartPostShipmentDetail^ value);
}
JavaScript
function get_smartPostDetail();
function set_smartPostDetail(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


SpecialServicesRequested Property

[image]

.NET Framework Class Library
RequestedShipment..::.SpecialServicesRequested Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecialServicesRequested As ShipmentSpecialServicesRequested
C#
public ShipmentSpecialServicesRequested SpecialServicesRequested { get; set; }
Visual C++
public:
property ShipmentSpecialServicesRequested^ SpecialServicesRequested {
    ShipmentSpecialServicesRequested^ get ();
    void set (ShipmentSpecialServicesRequested^ value);
}
JavaScript
function get_specialServicesRequested();
function set_specialServicesRequested(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


TotalInsuredValue Property

[image]

.NET Framework Class Library
RequestedShipment..::.TotalInsuredValue Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalInsuredValue As Money
C#
public Money TotalInsuredValue { get; set; }
Visual C++
public:
property Money^ TotalInsuredValue {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalInsuredValue();
function set_totalInsuredValue(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


TotalWeight Property

[image]

.NET Framework Class Library
RequestedShipment..::.TotalWeight Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalWeight As Weight
C#
public Weight TotalWeight { get; set; }
Visual C++
public:
property Weight^ TotalWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_totalWeight();
function set_totalWeight(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


VariableHandlingChargeDetail Property

[image]

.NET Framework Class Library
RequestedShipment..::.VariableHandlingChargeDetail Property
RequestedShipment Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableHandlingChargeDetail As VariableHandlingChargeDetail
C#
public VariableHandlingChargeDetail VariableHandlingChargeDetail { get; set; }
Visual C++
public:
property VariableHandlingChargeDetail^ VariableHandlingChargeDetail {
    VariableHandlingChargeDetail^ get ();
    void set (VariableHandlingChargeDetail^ value);
}
JavaScript
function get_variableHandlingChargeDetail();
function set_variableHandlingChargeDetail(value);

Remarks

See Also

RequestedShipment Class
InSite.Domain.FedExRateService Namespace


RequestedShippingDocumentType Enumeration

[image]

.NET Framework Class Library
RequestedShippingDocumentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RequestedShippingDocumentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RequestedShippingDocumentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RequestedShippingDocumentType
JavaScript
InSite.Domain.FedExRateService.RequestedShippingDocumentType = function();
InSite.Domain.FedExRateService.RequestedShippingDocumentType.createEnum('InSite.Domain.FedExRateService.RequestedShippingDocumentType', false);

Members

Member name | Description
COMMERCIAL_INVOICE |
CUSTOMER_SPECIFIED_LABELS |
GENERAL_AGENCY_AGREEMENT |
LABEL |
NAFTA_CERTIFICATE_OF_ORIGIN |
RETURN_INSTRUCTIONS |
CERTIFICATE_OF_ORIGIN |
PRO_FORMA_INVOICE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


RequiredShippingDocumentType Enumeration

[image]

.NET Framework Class Library
RequiredShippingDocumentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration RequiredShippingDocumentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum RequiredShippingDocumentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class RequiredShippingDocumentType
JavaScript
InSite.Domain.FedExRateService.RequiredShippingDocumentType = function();
InSite.Domain.FedExRateService.RequiredShippingDocumentType.createEnum('InSite.Domain.FedExRateService.RequiredShippingDocumentType', false);

Members

Member name | Description
CANADIAN_B13A |
CERTIFICATE_OF_ORIGIN |
COMMERCIAL_INVOICE |
INTERNATIONAL_AIRWAY_BILL |
MAIL_SERVICE_AIRWAY_BILL |
SHIPPERS_EXPORT_DECLARATION |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


ReturnedRateType Enumeration

[image]

.NET Framework Class Library
ReturnedRateType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ReturnedRateType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ReturnedRateType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ReturnedRateType
JavaScript
InSite.Domain.FedExRateService.ReturnedRateType = function();
InSite.Domain.FedExRateService.ReturnedRateType.createEnum('InSite.Domain.FedExRateService.ReturnedRateType', false);

Members

Member name | Description
PAYOR_ACCOUNT |
PAYOR_LIST |
PAYOR_MULTIWEIGHT |
RATED_ACCOUNT |
RATED_LIST |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


ReturnEMailAllowedSpecialServiceType Enumeration

[image]

.NET Framework Class Library
ReturnEMailAllowedSpecialServiceType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ReturnEMailAllowedSpecialServiceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ReturnEMailAllowedSpecialServiceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ReturnEMailAllowedSpecialServiceType
JavaScript
InSite.Domain.FedExRateService.ReturnEMailAllowedSpecialServiceType = function();
InSite.Domain.FedExRateService.ReturnEMailAllowedSpecialServiceType.createEnum('InSite.Domain.FedExRateService.ReturnEMailAllowedSpecialServiceType', false);

Members

Member name | Description
SATURDAY_DELIVERY |
SATURDAY_PICKUP |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


ReturnEMailDetail Class

[image]

.NET Framework Class Library
ReturnEMailDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ReturnEMailDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ReturnEMailDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ReturnEMailDetail
JavaScript
InSite.Domain.FedExRateService.ReturnEMailDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ReturnEMailDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ReturnEMailDetail

See Also

ReturnEMailDetail Members
InSite.Domain.FedExRateService Namespace


ReturnEMailDetail Members

[image] [image]

.NET Framework Class Library
ReturnEMailDetail Members
ReturnEMailDetail Class Constructors Methods Properties See Also Send Feedback

The ReturnEMailDetail type exposes the following members.

Constructors

Name | Description
ReturnEMailDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowedSpecialServices |
AllowedSpecialServicesSpecified |
MerchantPhoneNumber |

See Also

ReturnEMailDetail Class
InSite.Domain.FedExRateService Namespace


ReturnEMailDetail Constructor

[image]

.NET Framework Class Library
ReturnEMailDetail Constructor
ReturnEMailDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReturnEMailDetail()
Visual C++
public:
ReturnEMailDetail()
JavaScript
InSite.Domain.FedExRateService.ReturnEMailDetail = function();

See Also

ReturnEMailDetail Class
InSite.Domain.FedExRateService Namespace


ReturnEMailDetail Methods

[image] [image]

.NET Framework Class Library
ReturnEMailDetail Methods
ReturnEMailDetail Class See Also Send Feedback

The ReturnEMailDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReturnEMailDetail Class
InSite.Domain.FedExRateService Namespace


ReturnEMailDetail Properties

[image] [image]

.NET Framework Class Library
ReturnEMailDetail Properties
ReturnEMailDetail Class See Also Send Feedback

The ReturnEMailDetail type exposes the following members.

Properties

Name | Description
AllowedSpecialServices |
AllowedSpecialServicesSpecified |
MerchantPhoneNumber |

See Also

ReturnEMailDetail Class
InSite.Domain.FedExRateService Namespace


AllowedSpecialServices Property

[image]

.NET Framework Class Library
ReturnEMailDetail..::.AllowedSpecialServices Property
ReturnEMailDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowedSpecialServices As ReturnEMailAllowedSpecialServiceType
C#
public ReturnEMailAllowedSpecialServiceType AllowedSpecialServices { get; set; }
Visual C++
public:
property ReturnEMailAllowedSpecialServiceType AllowedSpecialServices {
    ReturnEMailAllowedSpecialServiceType get ();
    void set (ReturnEMailAllowedSpecialServiceType value);
}
JavaScript
function get_allowedSpecialServices();
function set_allowedSpecialServices(value);

Remarks

See Also

ReturnEMailDetail Class
InSite.Domain.FedExRateService Namespace


AllowedSpecialServicesSpecified Property

[image]

.NET Framework Class Library
ReturnEMailDetail..::.AllowedSpecialServicesSpecified Property
ReturnEMailDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowedSpecialServicesSpecified As Boolean
C#
public bool AllowedSpecialServicesSpecified { get; set; }
Visual C++
public:
property bool AllowedSpecialServicesSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowedSpecialServicesSpecified();
function set_allowedSpecialServicesSpecified(value);

Remarks

See Also

ReturnEMailDetail Class
InSite.Domain.FedExRateService Namespace


MerchantPhoneNumber Property

[image]

.NET Framework Class Library
ReturnEMailDetail..::.MerchantPhoneNumber Property
ReturnEMailDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MerchantPhoneNumber As String
C#
public string MerchantPhoneNumber { get; set; }
Visual C++
public:
property String^ MerchantPhoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_merchantPhoneNumber();
function set_merchantPhoneNumber(value);

Remarks

See Also

ReturnEMailDetail Class
InSite.Domain.FedExRateService Namespace


ReturnShipmentDetail Class

[image]

.NET Framework Class Library
ReturnShipmentDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ReturnShipmentDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ReturnShipmentDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ReturnShipmentDetail
JavaScript
InSite.Domain.FedExRateService.ReturnShipmentDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ReturnShipmentDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ReturnShipmentDetail

See Also

ReturnShipmentDetail Members
InSite.Domain.FedExRateService Namespace


ReturnShipmentDetail Members

[image] [image]

.NET Framework Class Library
ReturnShipmentDetail Members
ReturnShipmentDetail Class Constructors Methods Properties See Also Send Feedback

The ReturnShipmentDetail type exposes the following members.

Constructors

Name | Description
ReturnShipmentDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ReturnEMailDetail |
ReturnType |
Rma |

See Also

ReturnShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ReturnShipmentDetail Constructor

[image]

.NET Framework Class Library
ReturnShipmentDetail Constructor
ReturnShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ReturnShipmentDetail()
Visual C++
public:
ReturnShipmentDetail()
JavaScript
InSite.Domain.FedExRateService.ReturnShipmentDetail = function();

See Also

ReturnShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ReturnShipmentDetail Methods

[image] [image]

.NET Framework Class Library
ReturnShipmentDetail Methods
ReturnShipmentDetail Class See Also Send Feedback

The ReturnShipmentDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReturnShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ReturnShipmentDetail Properties

[image] [image]

.NET Framework Class Library
ReturnShipmentDetail Properties
ReturnShipmentDetail Class See Also Send Feedback

The ReturnShipmentDetail type exposes the following members.

Properties

Name | Description
ReturnEMailDetail |
ReturnType |
Rma |

See Also

ReturnShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ReturnEMailDetail Property

[image]

.NET Framework Class Library
ReturnShipmentDetail..::.ReturnEMailDetail Property
ReturnShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnEMailDetail As ReturnEMailDetail
C#
public ReturnEMailDetail ReturnEMailDetail { get; set; }
Visual C++
public:
property ReturnEMailDetail^ ReturnEMailDetail {
    ReturnEMailDetail^ get ();
    void set (ReturnEMailDetail^ value);
}
JavaScript
function get_returnEMailDetail();
function set_returnEMailDetail(value);

Remarks

See Also

ReturnShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ReturnType Property

[image]

.NET Framework Class Library
ReturnShipmentDetail..::.ReturnType Property
ReturnShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnType As ReturnType
C#
public ReturnType ReturnType { get; set; }
Visual C++
public:
property ReturnType ReturnType {
    ReturnType get ();
    void set (ReturnType value);
}
JavaScript
function get_returnType();
function set_returnType(value);

Remarks

See Also

ReturnShipmentDetail Class
InSite.Domain.FedExRateService Namespace


Rma Property

[image]

.NET Framework Class Library
ReturnShipmentDetail..::.Rma Property
ReturnShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Rma As Rma
C#
public Rma Rma { get; set; }
Visual C++
public:
property Rma^ Rma {
    Rma^ get ();
    void set (Rma^ value);
}
JavaScript
function get_rma();
function set_rma(value);

Remarks

See Also

ReturnShipmentDetail Class
InSite.Domain.FedExRateService Namespace


ReturnType Enumeration

[image]

.NET Framework Class Library
ReturnType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ReturnType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ReturnType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ReturnType
JavaScript
InSite.Domain.FedExRateService.ReturnType = function();
InSite.Domain.FedExRateService.ReturnType.createEnum('InSite.Domain.FedExRateService.ReturnType', false);

Members

Member name | Description
AUTOMATION_CALL_TAG |
FEDEX_TAG |
PENDING |
PRINT_RETURN_LABEL |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Rma Class

[image]

.NET Framework Class Library
Rma Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Rma
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Rma
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Rma
JavaScript
InSite.Domain.FedExRateService.Rma = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Rma');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Rma

See Also

Rma Members
InSite.Domain.FedExRateService Namespace


Rma Members

[image] [image]

.NET Framework Class Library
Rma Members
Rma Class Constructors Methods Properties See Also Send Feedback

The Rma type exposes the following members.

Constructors

Name | Description
Rma |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Number |
Reason |

See Also

Rma Class
InSite.Domain.FedExRateService Namespace


Rma Constructor

[image]

.NET Framework Class Library
Rma Constructor
Rma Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Rma()
Visual C++
public:
Rma()
JavaScript
InSite.Domain.FedExRateService.Rma = function();

See Also

Rma Class
InSite.Domain.FedExRateService Namespace


Rma Methods

[image] [image]

.NET Framework Class Library
Rma Methods
Rma Class See Also Send Feedback

The Rma type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rma Class
InSite.Domain.FedExRateService Namespace


Rma Properties

[image] [image]

.NET Framework Class Library
Rma Properties
Rma Class See Also Send Feedback

The Rma type exposes the following members.

Properties

Name | Description
Number |
Reason |

See Also

Rma Class
InSite.Domain.FedExRateService Namespace


Number Property

[image]

.NET Framework Class Library
Rma..::.Number Property
Rma Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Number As String
C#
public string Number { get; set; }
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_number();
function set_number(value);

Remarks

See Also

Rma Class
InSite.Domain.FedExRateService Namespace


Reason Property

[image]

.NET Framework Class Library
Rma..::.Reason Property
Rma Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Reason As String
C#
public string Reason { get; set; }
Visual C++
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reason();
function set_reason(value);

Remarks

See Also

Rma Class
InSite.Domain.FedExRateService Namespace


ServiceOptionType Enumeration

[image]

.NET Framework Class Library
ServiceOptionType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ServiceOptionType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ServiceOptionType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ServiceOptionType
JavaScript
InSite.Domain.FedExRateService.ServiceOptionType = function();
InSite.Domain.FedExRateService.ServiceOptionType.createEnum('InSite.Domain.FedExRateService.ServiceOptionType', false);

Members

Member name | Description
SATURDAY_DELIVERY |
FREIGHT_GUARANTEE |
SMARTPOST_HUB_ID |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


ServiceSubOptionDetail Class

[image]

.NET Framework Class Library
ServiceSubOptionDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ServiceSubOptionDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ServiceSubOptionDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ServiceSubOptionDetail
JavaScript
InSite.Domain.FedExRateService.ServiceSubOptionDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ServiceSubOptionDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ServiceSubOptionDetail

See Also

ServiceSubOptionDetail Members
InSite.Domain.FedExRateService Namespace


ServiceSubOptionDetail Members

[image] [image]

.NET Framework Class Library
ServiceSubOptionDetail Members
ServiceSubOptionDetail Class Constructors Methods Properties See Also Send Feedback

The ServiceSubOptionDetail type exposes the following members.

Constructors

Name | Description
ServiceSubOptionDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FreightGuarantee |
FreightGuaranteeSpecified |
SmartPostHubId |

See Also

ServiceSubOptionDetail Class
InSite.Domain.FedExRateService Namespace


ServiceSubOptionDetail Constructor

[image]

.NET Framework Class Library
ServiceSubOptionDetail Constructor
ServiceSubOptionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ServiceSubOptionDetail()
Visual C++
public:
ServiceSubOptionDetail()
JavaScript
InSite.Domain.FedExRateService.ServiceSubOptionDetail = function();

See Also

ServiceSubOptionDetail Class
InSite.Domain.FedExRateService Namespace


ServiceSubOptionDetail Methods

[image] [image]

.NET Framework Class Library
ServiceSubOptionDetail Methods
ServiceSubOptionDetail Class See Also Send Feedback

The ServiceSubOptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServiceSubOptionDetail Class
InSite.Domain.FedExRateService Namespace


ServiceSubOptionDetail Properties

[image] [image]

.NET Framework Class Library
ServiceSubOptionDetail Properties
ServiceSubOptionDetail Class See Also Send Feedback

The ServiceSubOptionDetail type exposes the following members.

Properties

Name | Description
FreightGuarantee |
FreightGuaranteeSpecified |
SmartPostHubId |

See Also

ServiceSubOptionDetail Class
InSite.Domain.FedExRateService Namespace


FreightGuarantee Property

[image]

.NET Framework Class Library
ServiceSubOptionDetail..::.FreightGuarantee Property
ServiceSubOptionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightGuarantee As FreightGuaranteeType
C#
public FreightGuaranteeType FreightGuarantee { get; set; }
Visual C++
public:
property FreightGuaranteeType FreightGuarantee {
    FreightGuaranteeType get ();
    void set (FreightGuaranteeType value);
}
JavaScript
function get_freightGuarantee();
function set_freightGuarantee(value);

Remarks

See Also

ServiceSubOptionDetail Class
InSite.Domain.FedExRateService Namespace


FreightGuaranteeSpecified Property

[image]

.NET Framework Class Library
ServiceSubOptionDetail..::.FreightGuaranteeSpecified Property
ServiceSubOptionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightGuaranteeSpecified As Boolean
C#
public bool FreightGuaranteeSpecified { get; set; }
Visual C++
public:
property bool FreightGuaranteeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_freightGuaranteeSpecified();
function set_freightGuaranteeSpecified(value);

Remarks

See Also

ServiceSubOptionDetail Class
InSite.Domain.FedExRateService Namespace


SmartPostHubId Property

[image]

.NET Framework Class Library
ServiceSubOptionDetail..::.SmartPostHubId Property
ServiceSubOptionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SmartPostHubId As String
C#
public string SmartPostHubId { get; set; }
Visual C++
public:
property String^ SmartPostHubId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_smartPostHubId();
function set_smartPostHubId(value);

Remarks

See Also

ServiceSubOptionDetail Class
InSite.Domain.FedExRateService Namespace


ServiceType Enumeration

[image]

.NET Framework Class Library
ServiceType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ServiceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ServiceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ServiceType
JavaScript
InSite.Domain.FedExRateService.ServiceType = function();
InSite.Domain.FedExRateService.ServiceType.createEnum('InSite.Domain.FedExRateService.ServiceType', false);

Members

Member name | Description
EUROPE_FIRST_INTERNATIONAL_PRIORITY |
FEDEX_1_DAY_FREIGHT |
FEDEX_2_DAY |
FEDEX_2_DAY_FREIGHT |
FEDEX_3_DAY_FREIGHT |
FEDEX_EXPRESS_SAVER |
FEDEX_GROUND |
FIRST_OVERNIGHT |
GROUND_HOME_DELIVERY |
INTERNATIONAL_ECONOMY |
INTERNATIONAL_ECONOMY_FREIGHT |
INTERNATIONAL_FIRST |
INTERNATIONAL_PRIORITY |
INTERNATIONAL_PRIORITY_FREIGHT |
PRIORITY_OVERNIGHT |
SMART_POST |
STANDARD_OVERNIGHT |
FEDEX_FREIGHT |
FEDEX_NATIONAL_FREIGHT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


ShipmentDryIceDetail Class

[image]

.NET Framework Class Library
ShipmentDryIceDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ShipmentDryIceDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ShipmentDryIceDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ShipmentDryIceDetail
JavaScript
InSite.Domain.FedExRateService.ShipmentDryIceDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ShipmentDryIceDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ShipmentDryIceDetail

See Also

ShipmentDryIceDetail Members
InSite.Domain.FedExRateService Namespace


ShipmentDryIceDetail Members

[image] [image]

.NET Framework Class Library
ShipmentDryIceDetail Members
ShipmentDryIceDetail Class Constructors Methods Properties See Also Send Feedback

The ShipmentDryIceDetail type exposes the following members.

Constructors

Name | Description
ShipmentDryIceDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PackageCount |
TotalWeight |

See Also

ShipmentDryIceDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentDryIceDetail Constructor

[image]

.NET Framework Class Library
ShipmentDryIceDetail Constructor
ShipmentDryIceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipmentDryIceDetail()
Visual C++
public:
ShipmentDryIceDetail()
JavaScript
InSite.Domain.FedExRateService.ShipmentDryIceDetail = function();

See Also

ShipmentDryIceDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentDryIceDetail Methods

[image] [image]

.NET Framework Class Library
ShipmentDryIceDetail Methods
ShipmentDryIceDetail Class See Also Send Feedback

The ShipmentDryIceDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShipmentDryIceDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentDryIceDetail Properties

[image] [image]

.NET Framework Class Library
ShipmentDryIceDetail Properties
ShipmentDryIceDetail Class See Also Send Feedback

The ShipmentDryIceDetail type exposes the following members.

Properties

Name | Description
PackageCount |
TotalWeight |

See Also

ShipmentDryIceDetail Class
InSite.Domain.FedExRateService Namespace


PackageCount Property

[image]

.NET Framework Class Library
ShipmentDryIceDetail..::.PackageCount Property
ShipmentDryIceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PackageCount As String
C#
public string PackageCount { get; set; }
Visual C++
public:
property String^ PackageCount {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_packageCount();
function set_packageCount(value);

Remarks

See Also

ShipmentDryIceDetail Class
InSite.Domain.FedExRateService Namespace


TotalWeight Property

[image]

.NET Framework Class Library
ShipmentDryIceDetail..::.TotalWeight Property
ShipmentDryIceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalWeight As Weight
C#
public Weight TotalWeight { get; set; }
Visual C++
public:
property Weight^ TotalWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_totalWeight();
function set_totalWeight(value);

Remarks

See Also

ShipmentDryIceDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentRateDetail Class

[image]

.NET Framework Class Library
ShipmentRateDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ShipmentRateDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ShipmentRateDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ShipmentRateDetail
JavaScript
InSite.Domain.FedExRateService.ShipmentRateDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ShipmentRateDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ShipmentRateDetail

See Also

ShipmentRateDetail Members
InSite.Domain.FedExRateService Namespace


ShipmentRateDetail Members

[image] [image]

.NET Framework Class Library
ShipmentRateDetail Members
ShipmentRateDetail Class Constructors Methods Properties See Also Send Feedback

The ShipmentRateDetail type exposes the following members.

Constructors

Name | Description
ShipmentRateDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrencyExchangeRate |
DimDivisor |
DutiesAndTaxes |
FreightDiscounts |
FreightRateDetail |
FuelSurchargePercent |
FuelSurchargePercentSpecified |
MinimumChargeType |
MinimumChargeTypeSpecified |
PricingCode |
PricingCodeSpecified |
RatedWeightMethod |
RatedWeightMethodSpecified |
RateScale |
RateType |
RateTypeSpecified |
RateZone |
Rebates |
SpecialRatingApplied |
Surcharges |
Taxes |
TotalBaseCharge |
TotalBillingWeight |
TotalDimWeight |
TotalDutiesAndTaxes |
TotalFreightDiscounts |
TotalNetCharge |
TotalNetChargeWithDutiesAndTaxes |
TotalNetFedExCharge |
TotalNetFreight |
TotalRebates |
TotalSurcharges |
TotalTaxes |
TotalVariableHandlingCharges |
VariableHandlingCharges |

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentRateDetail Constructor

[image]

.NET Framework Class Library
ShipmentRateDetail Constructor
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipmentRateDetail()
Visual C++
public:
ShipmentRateDetail()
JavaScript
InSite.Domain.FedExRateService.ShipmentRateDetail = function();

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentRateDetail Methods

[image] [image]

.NET Framework Class Library
ShipmentRateDetail Methods
ShipmentRateDetail Class See Also Send Feedback

The ShipmentRateDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentRateDetail Properties

[image] [image]

.NET Framework Class Library
ShipmentRateDetail Properties
ShipmentRateDetail Class See Also Send Feedback

The ShipmentRateDetail type exposes the following members.

Properties

Name | Description
CurrencyExchangeRate |
DimDivisor |
DutiesAndTaxes |
FreightDiscounts |
FreightRateDetail |
FuelSurchargePercent |
FuelSurchargePercentSpecified |
MinimumChargeType |
MinimumChargeTypeSpecified |
PricingCode |
PricingCodeSpecified |
RatedWeightMethod |
RatedWeightMethodSpecified |
RateScale |
RateType |
RateTypeSpecified |
RateZone |
Rebates |
SpecialRatingApplied |
Surcharges |
Taxes |
TotalBaseCharge |
TotalBillingWeight |
TotalDimWeight |
TotalDutiesAndTaxes |
TotalFreightDiscounts |
TotalNetCharge |
TotalNetChargeWithDutiesAndTaxes |
TotalNetFedExCharge |
TotalNetFreight |
TotalRebates |
TotalSurcharges |
TotalTaxes |
TotalVariableHandlingCharges |
VariableHandlingCharges |

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


CurrencyExchangeRate Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.CurrencyExchangeRate Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CurrencyExchangeRate As CurrencyExchangeRate
C#
public CurrencyExchangeRate CurrencyExchangeRate { get; set; }
Visual C++
public:
property CurrencyExchangeRate^ CurrencyExchangeRate {
    CurrencyExchangeRate^ get ();
    void set (CurrencyExchangeRate^ value);
}
JavaScript
function get_currencyExchangeRate();
function set_currencyExchangeRate(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


DimDivisor Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.DimDivisor Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DimDivisor As String
C#
public string DimDivisor { get; set; }
Visual C++
public:
property String^ DimDivisor {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dimDivisor();
function set_dimDivisor(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


DutiesAndTaxes Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.DutiesAndTaxes Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DutiesAndTaxes As EdtCommodityTax()
C#
public EdtCommodityTax[] DutiesAndTaxes { get; set; }
Visual C++
public:
property array<EdtCommodityTax^>^ DutiesAndTaxes {
    array<EdtCommodityTax^>^ get ();
    void set (array<EdtCommodityTax^>^ value);
}
JavaScript
function get_dutiesAndTaxes();
function set_dutiesAndTaxes(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


FreightDiscounts Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.FreightDiscounts Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightDiscounts As RateDiscount()
C#
public RateDiscount[] FreightDiscounts { get; set; }
Visual C++
public:
property array<RateDiscount^>^ FreightDiscounts {
    array<RateDiscount^>^ get ();
    void set (array<RateDiscount^>^ value);
}
JavaScript
function get_freightDiscounts();
function set_freightDiscounts(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


FreightRateDetail Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.FreightRateDetail Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightRateDetail As FreightRateDetail
C#
public FreightRateDetail FreightRateDetail { get; set; }
Visual C++
public:
property FreightRateDetail^ FreightRateDetail {
    FreightRateDetail^ get ();
    void set (FreightRateDetail^ value);
}
JavaScript
function get_freightRateDetail();
function set_freightRateDetail(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


FuelSurchargePercent Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.FuelSurchargePercent Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FuelSurchargePercent As Decimal
C#
public decimal FuelSurchargePercent { get; set; }
Visual C++
public:
property Decimal FuelSurchargePercent {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_fuelSurchargePercent();
function set_fuelSurchargePercent(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


FuelSurchargePercentSpecified Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.FuelSurchargePercentSpecified Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FuelSurchargePercentSpecified As Boolean
C#
public bool FuelSurchargePercentSpecified { get; set; }
Visual C++
public:
property bool FuelSurchargePercentSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_fuelSurchargePercentSpecified();
function set_fuelSurchargePercentSpecified(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


MinimumChargeType Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.MinimumChargeType Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MinimumChargeType As MinimumChargeType
C#
public MinimumChargeType MinimumChargeType { get; set; }
Visual C++
public:
property MinimumChargeType MinimumChargeType {
    MinimumChargeType get ();
    void set (MinimumChargeType value);
}
JavaScript
function get_minimumChargeType();
function set_minimumChargeType(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


MinimumChargeTypeSpecified Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.MinimumChargeTypeSpecified Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MinimumChargeTypeSpecified As Boolean
C#
public bool MinimumChargeTypeSpecified { get; set; }
Visual C++
public:
property bool MinimumChargeTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_minimumChargeTypeSpecified();
function set_minimumChargeTypeSpecified(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


PricingCode Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.PricingCode Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PricingCode As PricingCodeType
C#
public PricingCodeType PricingCode { get; set; }
Visual C++
public:
property PricingCodeType PricingCode {
    PricingCodeType get ();
    void set (PricingCodeType value);
}
JavaScript
function get_pricingCode();
function set_pricingCode(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


PricingCodeSpecified Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.PricingCodeSpecified Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PricingCodeSpecified As Boolean
C#
public bool PricingCodeSpecified { get; set; }
Visual C++
public:
property bool PricingCodeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_pricingCodeSpecified();
function set_pricingCodeSpecified(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


RatedWeightMethod Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.RatedWeightMethod Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RatedWeightMethod As RatedWeightMethod
C#
public RatedWeightMethod RatedWeightMethod { get; set; }
Visual C++
public:
property RatedWeightMethod RatedWeightMethod {
    RatedWeightMethod get ();
    void set (RatedWeightMethod value);
}
JavaScript
function get_ratedWeightMethod();
function set_ratedWeightMethod(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


RatedWeightMethodSpecified Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.RatedWeightMethodSpecified Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RatedWeightMethodSpecified As Boolean
C#
public bool RatedWeightMethodSpecified { get; set; }
Visual C++
public:
property bool RatedWeightMethodSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_ratedWeightMethodSpecified();
function set_ratedWeightMethodSpecified(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


RateScale Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.RateScale Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateScale As String
C#
public string RateScale { get; set; }
Visual C++
public:
property String^ RateScale {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_rateScale();
function set_rateScale(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


RateType Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.RateType Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateType As ReturnedRateType
C#
public ReturnedRateType RateType { get; set; }
Visual C++
public:
property ReturnedRateType RateType {
    ReturnedRateType get ();
    void set (ReturnedRateType value);
}
JavaScript
function get_rateType();
function set_rateType(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


RateTypeSpecified Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.RateTypeSpecified Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateTypeSpecified As Boolean
C#
public bool RateTypeSpecified { get; set; }
Visual C++
public:
property bool RateTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_rateTypeSpecified();
function set_rateTypeSpecified(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


RateZone Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.RateZone Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RateZone As String
C#
public string RateZone { get; set; }
Visual C++
public:
property String^ RateZone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_rateZone();
function set_rateZone(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


Rebates Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.Rebates Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Rebates As Rebate()
C#
public Rebate[] Rebates { get; set; }
Visual C++
public:
property array<Rebate^>^ Rebates {
    array<Rebate^>^ get ();
    void set (array<Rebate^>^ value);
}
JavaScript
function get_rebates();
function set_rebates(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


SpecialRatingApplied Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.SpecialRatingApplied Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecialRatingApplied As SpecialRatingAppliedType()
C#
public SpecialRatingAppliedType[] SpecialRatingApplied { get; set; }
Visual C++
public:
property array<SpecialRatingAppliedType>^ SpecialRatingApplied {
    array<SpecialRatingAppliedType>^ get ();
    void set (array<SpecialRatingAppliedType>^ value);
}
JavaScript
function get_specialRatingApplied();
function set_specialRatingApplied(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


Surcharges Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.Surcharges Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Surcharges As Surcharge()
C#
public Surcharge[] Surcharges { get; set; }
Visual C++
public:
property array<Surcharge^>^ Surcharges {
    array<Surcharge^>^ get ();
    void set (array<Surcharge^>^ value);
}
JavaScript
function get_surcharges();
function set_surcharges(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


Taxes Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.Taxes Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Taxes As Tax()
C#
public Tax[] Taxes { get; set; }
Visual C++
public:
property array<Tax^>^ Taxes {
    array<Tax^>^ get ();
    void set (array<Tax^>^ value);
}
JavaScript
function get_taxes();
function set_taxes(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalBaseCharge Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalBaseCharge Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalBaseCharge As Money
C#
public Money TotalBaseCharge { get; set; }
Visual C++
public:
property Money^ TotalBaseCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalBaseCharge();
function set_totalBaseCharge(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalBillingWeight Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalBillingWeight Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalBillingWeight As Weight
C#
public Weight TotalBillingWeight { get; set; }
Visual C++
public:
property Weight^ TotalBillingWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_totalBillingWeight();
function set_totalBillingWeight(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalDimWeight Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalDimWeight Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalDimWeight As Weight
C#
public Weight TotalDimWeight { get; set; }
Visual C++
public:
property Weight^ TotalDimWeight {
    Weight^ get ();
    void set (Weight^ value);
}
JavaScript
function get_totalDimWeight();
function set_totalDimWeight(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalDutiesAndTaxes Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalDutiesAndTaxes Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalDutiesAndTaxes As Money
C#
public Money TotalDutiesAndTaxes { get; set; }
Visual C++
public:
property Money^ TotalDutiesAndTaxes {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalDutiesAndTaxes();
function set_totalDutiesAndTaxes(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalFreightDiscounts Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalFreightDiscounts Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalFreightDiscounts As Money
C#
public Money TotalFreightDiscounts { get; set; }
Visual C++
public:
property Money^ TotalFreightDiscounts {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalFreightDiscounts();
function set_totalFreightDiscounts(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalNetCharge Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalNetCharge Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalNetCharge As Money
C#
public Money TotalNetCharge { get; set; }
Visual C++
public:
property Money^ TotalNetCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalNetCharge();
function set_totalNetCharge(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalNetChargeWithDutiesAndTaxes Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalNetChargeWithDutiesAndTaxes Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalNetChargeWithDutiesAndTaxes As Money
C#
public Money TotalNetChargeWithDutiesAndTaxes { get; set; }
Visual C++
public:
property Money^ TotalNetChargeWithDutiesAndTaxes {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalNetChargeWithDutiesAndTaxes();
function set_totalNetChargeWithDutiesAndTaxes(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalNetFedExCharge Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalNetFedExCharge Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalNetFedExCharge As Money
C#
public Money TotalNetFedExCharge { get; set; }
Visual C++
public:
property Money^ TotalNetFedExCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalNetFedExCharge();
function set_totalNetFedExCharge(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalNetFreight Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalNetFreight Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalNetFreight As Money
C#
public Money TotalNetFreight { get; set; }
Visual C++
public:
property Money^ TotalNetFreight {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalNetFreight();
function set_totalNetFreight(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalRebates Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalRebates Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalRebates As Money
C#
public Money TotalRebates { get; set; }
Visual C++
public:
property Money^ TotalRebates {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalRebates();
function set_totalRebates(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalSurcharges Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalSurcharges Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalSurcharges As Money
C#
public Money TotalSurcharges { get; set; }
Visual C++
public:
property Money^ TotalSurcharges {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalSurcharges();
function set_totalSurcharges(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalTaxes Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalTaxes Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalTaxes As Money
C#
public Money TotalTaxes { get; set; }
Visual C++
public:
property Money^ TotalTaxes {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalTaxes();
function set_totalTaxes(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


TotalVariableHandlingCharges Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.TotalVariableHandlingCharges Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalVariableHandlingCharges As VariableHandlingCharges
C#
public VariableHandlingCharges TotalVariableHandlingCharges { get; set; }
Visual C++
public:
property VariableHandlingCharges^ TotalVariableHandlingCharges {
    VariableHandlingCharges^ get ();
    void set (VariableHandlingCharges^ value);
}
JavaScript
function get_totalVariableHandlingCharges();
function set_totalVariableHandlingCharges(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


VariableHandlingCharges Property

[image]

.NET Framework Class Library
ShipmentRateDetail..::.VariableHandlingCharges Property
ShipmentRateDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableHandlingCharges As VariableHandlingCharges
C#
public VariableHandlingCharges VariableHandlingCharges { get; set; }
Visual C++
public:
property VariableHandlingCharges^ VariableHandlingCharges {
    VariableHandlingCharges^ get ();
    void set (VariableHandlingCharges^ value);
}
JavaScript
function get_variableHandlingCharges();
function set_variableHandlingCharges(value);

Remarks

See Also

ShipmentRateDetail Class
InSite.Domain.FedExRateService Namespace


ShipmentSpecialServicesRequested Class

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ShipmentSpecialServicesRequested
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ShipmentSpecialServicesRequested
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ShipmentSpecialServicesRequested
JavaScript
InSite.Domain.FedExRateService.ShipmentSpecialServicesRequested = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ShipmentSpecialServicesRequested');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ShipmentSpecialServicesRequested

See Also

ShipmentSpecialServicesRequested Members
InSite.Domain.FedExRateService Namespace


ShipmentSpecialServicesRequested Members

[image] [image]

.NET Framework Class Library
ShipmentSpecialServicesRequested Members
ShipmentSpecialServicesRequested Class Constructors Methods Properties See Also Send Feedback

The ShipmentSpecialServicesRequested type exposes the following members.

Constructors

Name | Description
ShipmentSpecialServicesRequested |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CodCollectionAmount |
CodDetail |
EMailNotificationDetail |
EtdDetail |
FlatbedTrailerDetail |
FreightGuaranteeDetail |
HoldAtLocationDetail |
HomeDeliveryPremiumDetail |
PendingShipmentDetail |
ReturnShipmentDetail |
ShipmentDryIceDetail |
SpecialServiceTypes |

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


ShipmentSpecialServicesRequested Constructor

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested Constructor
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipmentSpecialServicesRequested()
Visual C++
public:
ShipmentSpecialServicesRequested()
JavaScript
InSite.Domain.FedExRateService.ShipmentSpecialServicesRequested = function();

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


ShipmentSpecialServicesRequested Methods

[image] [image]

.NET Framework Class Library
ShipmentSpecialServicesRequested Methods
ShipmentSpecialServicesRequested Class See Also Send Feedback

The ShipmentSpecialServicesRequested type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


ShipmentSpecialServicesRequested Properties

[image] [image]

.NET Framework Class Library
ShipmentSpecialServicesRequested Properties
ShipmentSpecialServicesRequested Class See Also Send Feedback

The ShipmentSpecialServicesRequested type exposes the following members.

Properties

Name | Description
CodCollectionAmount |
CodDetail |
EMailNotificationDetail |
EtdDetail |
FlatbedTrailerDetail |
FreightGuaranteeDetail |
HoldAtLocationDetail |
HomeDeliveryPremiumDetail |
PendingShipmentDetail |
ReturnShipmentDetail |
ShipmentDryIceDetail |
SpecialServiceTypes |

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


CodCollectionAmount Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.CodCollectionAmount Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CodCollectionAmount As Money
C#
public Money CodCollectionAmount { get; set; }
Visual C++
public:
property Money^ CodCollectionAmount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_codCollectionAmount();
function set_codCollectionAmount(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


CodDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.CodDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CodDetail As CodDetail
C#
public CodDetail CodDetail { get; set; }
Visual C++
public:
property CodDetail^ CodDetail {
    CodDetail^ get ();
    void set (CodDetail^ value);
}
JavaScript
function get_codDetail();
function set_codDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


EMailNotificationDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.EMailNotificationDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EMailNotificationDetail As EMailNotificationDetail
C#
public EMailNotificationDetail EMailNotificationDetail { get; set; }
Visual C++
public:
property EMailNotificationDetail^ EMailNotificationDetail {
    EMailNotificationDetail^ get ();
    void set (EMailNotificationDetail^ value);
}
JavaScript
function get_eMailNotificationDetail();
function set_eMailNotificationDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


EtdDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.EtdDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EtdDetail As EtdDetail
C#
public EtdDetail EtdDetail { get; set; }
Visual C++
public:
property EtdDetail^ EtdDetail {
    EtdDetail^ get ();
    void set (EtdDetail^ value);
}
JavaScript
function get_etdDetail();
function set_etdDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


FlatbedTrailerDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.FlatbedTrailerDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FlatbedTrailerDetail As FlatbedTrailerOption()
C#
public FlatbedTrailerOption[] FlatbedTrailerDetail { get; set; }
Visual C++
public:
property array<FlatbedTrailerOption>^ FlatbedTrailerDetail {
    array<FlatbedTrailerOption>^ get ();
    void set (array<FlatbedTrailerOption>^ value);
}
JavaScript
function get_flatbedTrailerDetail();
function set_flatbedTrailerDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


FreightGuaranteeDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.FreightGuaranteeDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightGuaranteeDetail As FreightGuaranteeDetail
C#
public FreightGuaranteeDetail FreightGuaranteeDetail { get; set; }
Visual C++
public:
property FreightGuaranteeDetail^ FreightGuaranteeDetail {
    FreightGuaranteeDetail^ get ();
    void set (FreightGuaranteeDetail^ value);
}
JavaScript
function get_freightGuaranteeDetail();
function set_freightGuaranteeDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


HoldAtLocationDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.HoldAtLocationDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HoldAtLocationDetail As HoldAtLocationDetail
C#
public HoldAtLocationDetail HoldAtLocationDetail { get; set; }
Visual C++
public:
property HoldAtLocationDetail^ HoldAtLocationDetail {
    HoldAtLocationDetail^ get ();
    void set (HoldAtLocationDetail^ value);
}
JavaScript
function get_holdAtLocationDetail();
function set_holdAtLocationDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


HomeDeliveryPremiumDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.HomeDeliveryPremiumDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HomeDeliveryPremiumDetail As HomeDeliveryPremiumDetail
C#
public HomeDeliveryPremiumDetail HomeDeliveryPremiumDetail { get; set; }
Visual C++
public:
property HomeDeliveryPremiumDetail^ HomeDeliveryPremiumDetail {
    HomeDeliveryPremiumDetail^ get ();
    void set (HomeDeliveryPremiumDetail^ value);
}
JavaScript
function get_homeDeliveryPremiumDetail();
function set_homeDeliveryPremiumDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


PendingShipmentDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.PendingShipmentDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PendingShipmentDetail As PendingShipmentDetail
C#
public PendingShipmentDetail PendingShipmentDetail { get; set; }
Visual C++
public:
property PendingShipmentDetail^ PendingShipmentDetail {
    PendingShipmentDetail^ get ();
    void set (PendingShipmentDetail^ value);
}
JavaScript
function get_pendingShipmentDetail();
function set_pendingShipmentDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


ReturnShipmentDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.ReturnShipmentDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnShipmentDetail As ReturnShipmentDetail
C#
public ReturnShipmentDetail ReturnShipmentDetail { get; set; }
Visual C++
public:
property ReturnShipmentDetail^ ReturnShipmentDetail {
    ReturnShipmentDetail^ get ();
    void set (ReturnShipmentDetail^ value);
}
JavaScript
function get_returnShipmentDetail();
function set_returnShipmentDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


ShipmentDryIceDetail Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.ShipmentDryIceDetail Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipmentDryIceDetail As ShipmentDryIceDetail
C#
public ShipmentDryIceDetail ShipmentDryIceDetail { get; set; }
Visual C++
public:
property ShipmentDryIceDetail^ ShipmentDryIceDetail {
    ShipmentDryIceDetail^ get ();
    void set (ShipmentDryIceDetail^ value);
}
JavaScript
function get_shipmentDryIceDetail();
function set_shipmentDryIceDetail(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


SpecialServiceTypes Property

[image]

.NET Framework Class Library
ShipmentSpecialServicesRequested..::.SpecialServiceTypes Property
ShipmentSpecialServicesRequested Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecialServiceTypes As ShipmentSpecialServiceType()
C#
public ShipmentSpecialServiceType[] SpecialServiceTypes { get; set; }
Visual C++
public:
property array<ShipmentSpecialServiceType>^ SpecialServiceTypes {
    array<ShipmentSpecialServiceType>^ get ();
    void set (array<ShipmentSpecialServiceType>^ value);
}
JavaScript
function get_specialServiceTypes();
function set_specialServiceTypes(value);

Remarks

See Also

ShipmentSpecialServicesRequested Class
InSite.Domain.FedExRateService Namespace


ShipmentSpecialServiceType Enumeration

[image]

.NET Framework Class Library
ShipmentSpecialServiceType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ShipmentSpecialServiceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ShipmentSpecialServiceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ShipmentSpecialServiceType
JavaScript
InSite.Domain.FedExRateService.ShipmentSpecialServiceType = function();
InSite.Domain.FedExRateService.ShipmentSpecialServiceType.createEnum('InSite.Domain.FedExRateService.ShipmentSpecialServiceType', false);

Members

Member name | Description
BROKER_SELECT_OPTION |
COD |
DRY_ICE |
EAST_COAST_SPECIAL |
ELECTRONIC_TRADE_DOCUMENTS |
EMAIL_NOTIFICATION |
FUTURE_DAY_SHIPMENT |
HOLD_AT_LOCATION |
HOME_DELIVERY_PREMIUM |
INSIDE_DELIVERY |
INSIDE_PICKUP |
PENDING_SHIPMENT |
RETURN_SHIPMENT |
SATURDAY_DELIVERY |
SATURDAY_PICKUP |
THIRD_PARTY_CONSIGNEE |
DANGEROUS_GOODS |
EXTREME_LENGTH |
FLATBED_TRAILER |
FREIGHT_GUARANTEE |
LIFTGATE_DELIVERY |
LIFTGATE_PICKUP |
LIMITED_ACCESS_DELIVERY |
LIMITED_ACCESS_PICKUP |
PRE_DELIVERY_NOTIFICATION |
PROTECTION_FROM_FREEZING |
REGIONAL_MALL_DELIVERY |
REGIONAL_MALL_PICKUP |
EXHIBITION_DELIVERY |
EXHIBITION_PICKUP |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


ShippingDocumentFormat Class

[image]

.NET Framework Class Library
ShippingDocumentFormat Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ShippingDocumentFormat
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ShippingDocumentFormat
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ShippingDocumentFormat
JavaScript
InSite.Domain.FedExRateService.ShippingDocumentFormat = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ShippingDocumentFormat');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ShippingDocumentFormat

See Also

ShippingDocumentFormat Members
InSite.Domain.FedExRateService Namespace


ShippingDocumentFormat Members

[image] [image]

.NET Framework Class Library
ShippingDocumentFormat Members
ShippingDocumentFormat Class Constructors Methods Properties See Also Send Feedback

The ShippingDocumentFormat type exposes the following members.

Constructors

Name | Description
ShippingDocumentFormat |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ImageType |
ImageTypeSpecified |
Localization |
ProvideInstructions |
ProvideInstructionsSpecified |
StockType |
StockTypeSpecified |

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentFormat Constructor

[image]

.NET Framework Class Library
ShippingDocumentFormat Constructor
ShippingDocumentFormat Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShippingDocumentFormat()
Visual C++
public:
ShippingDocumentFormat()
JavaScript
InSite.Domain.FedExRateService.ShippingDocumentFormat = function();

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentFormat Methods

[image] [image]

.NET Framework Class Library
ShippingDocumentFormat Methods
ShippingDocumentFormat Class See Also Send Feedback

The ShippingDocumentFormat type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentFormat Properties

[image] [image]

.NET Framework Class Library
ShippingDocumentFormat Properties
ShippingDocumentFormat Class See Also Send Feedback

The ShippingDocumentFormat type exposes the following members.

Properties

Name | Description
ImageType |
ImageTypeSpecified |
Localization |
ProvideInstructions |
ProvideInstructionsSpecified |
StockType |
StockTypeSpecified |

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


ImageType Property

[image]

.NET Framework Class Library
ShippingDocumentFormat..::.ImageType Property
ShippingDocumentFormat Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageType As ShippingDocumentImageType
C#
public ShippingDocumentImageType ImageType { get; set; }
Visual C++
public:
property ShippingDocumentImageType ImageType {
    ShippingDocumentImageType get ();
    void set (ShippingDocumentImageType value);
}
JavaScript
function get_imageType();
function set_imageType(value);

Remarks

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


ImageTypeSpecified Property

[image]

.NET Framework Class Library
ShippingDocumentFormat..::.ImageTypeSpecified Property
ShippingDocumentFormat Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ImageTypeSpecified As Boolean
C#
public bool ImageTypeSpecified { get; set; }
Visual C++
public:
property bool ImageTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_imageTypeSpecified();
function set_imageTypeSpecified(value);

Remarks

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


Localization Property

[image]

.NET Framework Class Library
ShippingDocumentFormat..::.Localization Property
ShippingDocumentFormat Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Localization As Localization
C#
public Localization Localization { get; set; }
Visual C++
public:
property Localization^ Localization {
    Localization^ get ();
    void set (Localization^ value);
}
JavaScript
function get_localization();
function set_localization(value);

Remarks

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


ProvideInstructions Property

[image]

.NET Framework Class Library
ShippingDocumentFormat..::.ProvideInstructions Property
ShippingDocumentFormat Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProvideInstructions As Boolean
C#
public bool ProvideInstructions { get; set; }
Visual C++
public:
property bool ProvideInstructions {
    bool get ();
    void set (bool value);
}
JavaScript
function get_provideInstructions();
function set_provideInstructions(value);

Remarks

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


ProvideInstructionsSpecified Property

[image]

.NET Framework Class Library
ShippingDocumentFormat..::.ProvideInstructionsSpecified Property
ShippingDocumentFormat Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ProvideInstructionsSpecified As Boolean
C#
public bool ProvideInstructionsSpecified { get; set; }
Visual C++
public:
property bool ProvideInstructionsSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_provideInstructionsSpecified();
function set_provideInstructionsSpecified(value);

Remarks

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


StockType Property

[image]

.NET Framework Class Library
ShippingDocumentFormat..::.StockType Property
ShippingDocumentFormat Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property StockType As ShippingDocumentStockType
C#
public ShippingDocumentStockType StockType { get; set; }
Visual C++
public:
property ShippingDocumentStockType StockType {
    ShippingDocumentStockType get ();
    void set (ShippingDocumentStockType value);
}
JavaScript
function get_stockType();
function set_stockType(value);

Remarks

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


StockTypeSpecified Property

[image]

.NET Framework Class Library
ShippingDocumentFormat..::.StockTypeSpecified Property
ShippingDocumentFormat Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property StockTypeSpecified As Boolean
C#
public bool StockTypeSpecified { get; set; }
Visual C++
public:
property bool StockTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_stockTypeSpecified();
function set_stockTypeSpecified(value);

Remarks

See Also

ShippingDocumentFormat Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentImageType Enumeration

[image]

.NET Framework Class Library
ShippingDocumentImageType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ShippingDocumentImageType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ShippingDocumentImageType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ShippingDocumentImageType
JavaScript
InSite.Domain.FedExRateService.ShippingDocumentImageType = function();
InSite.Domain.FedExRateService.ShippingDocumentImageType.createEnum('InSite.Domain.FedExRateService.ShippingDocumentImageType', false);

Members

Member name | Description
DPL |
EPL2 |
PDF |
PNG |
ZPLII |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


ShippingDocumentSpecification Class

[image]

.NET Framework Class Library
ShippingDocumentSpecification Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ShippingDocumentSpecification
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ShippingDocumentSpecification
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ShippingDocumentSpecification
JavaScript
InSite.Domain.FedExRateService.ShippingDocumentSpecification = function();

Type.createClass(
    'InSite.Domain.FedExRateService.ShippingDocumentSpecification');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.ShippingDocumentSpecification

See Also

ShippingDocumentSpecification Members
InSite.Domain.FedExRateService Namespace


ShippingDocumentSpecification Members

[image] [image]

.NET Framework Class Library
ShippingDocumentSpecification Members
ShippingDocumentSpecification Class Constructors Methods Properties See Also Send Feedback

The ShippingDocumentSpecification type exposes the following members.

Constructors

Name | Description
ShippingDocumentSpecification |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CertificateOfOrigin |
CommercialInvoiceDetail |
CustomerProvidedImages |
GeneralAgencyAgreementDetail |
NaftaCertificateOfOriginDetail |
ShippingDocumentTypes |

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentSpecification Constructor

[image]

.NET Framework Class Library
ShippingDocumentSpecification Constructor
ShippingDocumentSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShippingDocumentSpecification()
Visual C++
public:
ShippingDocumentSpecification()
JavaScript
InSite.Domain.FedExRateService.ShippingDocumentSpecification = function();

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentSpecification Methods

[image] [image]

.NET Framework Class Library
ShippingDocumentSpecification Methods
ShippingDocumentSpecification Class See Also Send Feedback

The ShippingDocumentSpecification type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentSpecification Properties

[image] [image]

.NET Framework Class Library
ShippingDocumentSpecification Properties
ShippingDocumentSpecification Class See Also Send Feedback

The ShippingDocumentSpecification type exposes the following members.

Properties

Name | Description
CertificateOfOrigin |
CommercialInvoiceDetail |
CustomerProvidedImages |
GeneralAgencyAgreementDetail |
NaftaCertificateOfOriginDetail |
ShippingDocumentTypes |

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


CertificateOfOrigin Property

[image]

.NET Framework Class Library
ShippingDocumentSpecification..::.CertificateOfOrigin Property
ShippingDocumentSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CertificateOfOrigin As CertificateOfOriginDetail
C#
public CertificateOfOriginDetail CertificateOfOrigin { get; set; }
Visual C++
public:
property CertificateOfOriginDetail^ CertificateOfOrigin {
    CertificateOfOriginDetail^ get ();
    void set (CertificateOfOriginDetail^ value);
}
JavaScript
function get_certificateOfOrigin();
function set_certificateOfOrigin(value);

Remarks

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


CommercialInvoiceDetail Property

[image]

.NET Framework Class Library
ShippingDocumentSpecification..::.CommercialInvoiceDetail Property
ShippingDocumentSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CommercialInvoiceDetail As CommercialInvoiceDetail
C#
public CommercialInvoiceDetail CommercialInvoiceDetail { get; set; }
Visual C++
public:
property CommercialInvoiceDetail^ CommercialInvoiceDetail {
    CommercialInvoiceDetail^ get ();
    void set (CommercialInvoiceDetail^ value);
}
JavaScript
function get_commercialInvoiceDetail();
function set_commercialInvoiceDetail(value);

Remarks

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


CustomerProvidedImages Property

[image]

.NET Framework Class Library
ShippingDocumentSpecification..::.CustomerProvidedImages Property
ShippingDocumentSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerProvidedImages As CustomerProvidedImage()
C#
public CustomerProvidedImage[] CustomerProvidedImages { get; set; }
Visual C++
public:
property array<CustomerProvidedImage^>^ CustomerProvidedImages {
    array<CustomerProvidedImage^>^ get ();
    void set (array<CustomerProvidedImage^>^ value);
}
JavaScript
function get_customerProvidedImages();
function set_customerProvidedImages(value);

Remarks

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


GeneralAgencyAgreementDetail Property

[image]

.NET Framework Class Library
ShippingDocumentSpecification..::.GeneralAgencyAgreementDetail Property
ShippingDocumentSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property GeneralAgencyAgreementDetail As GeneralAgencyAgreementDetail
C#
public GeneralAgencyAgreementDetail GeneralAgencyAgreementDetail { get; set; }
Visual C++
public:
property GeneralAgencyAgreementDetail^ GeneralAgencyAgreementDetail {
    GeneralAgencyAgreementDetail^ get ();
    void set (GeneralAgencyAgreementDetail^ value);
}
JavaScript
function get_generalAgencyAgreementDetail();
function set_generalAgencyAgreementDetail(value);

Remarks

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


NaftaCertificateOfOriginDetail Property

[image]

.NET Framework Class Library
ShippingDocumentSpecification..::.NaftaCertificateOfOriginDetail Property
ShippingDocumentSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property NaftaCertificateOfOriginDetail As NaftaCertificateOfOriginDetail
C#
public NaftaCertificateOfOriginDetail NaftaCertificateOfOriginDetail { get; set; }
Visual C++
public:
property NaftaCertificateOfOriginDetail^ NaftaCertificateOfOriginDetail {
    NaftaCertificateOfOriginDetail^ get ();
    void set (NaftaCertificateOfOriginDetail^ value);
}
JavaScript
function get_naftaCertificateOfOriginDetail();
function set_naftaCertificateOfOriginDetail(value);

Remarks

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentTypes Property

[image]

.NET Framework Class Library
ShippingDocumentSpecification..::.ShippingDocumentTypes Property
ShippingDocumentSpecification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShippingDocumentTypes As RequestedShippingDocumentType()
C#
public RequestedShippingDocumentType[] ShippingDocumentTypes { get; set; }
Visual C++
public:
property array<RequestedShippingDocumentType>^ ShippingDocumentTypes {
    array<RequestedShippingDocumentType>^ get ();
    void set (array<RequestedShippingDocumentType>^ value);
}
JavaScript
function get_shippingDocumentTypes();
function set_shippingDocumentTypes(value);

Remarks

See Also

ShippingDocumentSpecification Class
InSite.Domain.FedExRateService Namespace


ShippingDocumentStockType Enumeration

[image]

.NET Framework Class Library
ShippingDocumentStockType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ShippingDocumentStockType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ShippingDocumentStockType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ShippingDocumentStockType
JavaScript
InSite.Domain.FedExRateService.ShippingDocumentStockType = function();
InSite.Domain.FedExRateService.ShippingDocumentStockType.createEnum('InSite.Domain.FedExRateService.ShippingDocumentStockType', false);

Members

Member name | Description
PAPER_4X6 |
PAPER_LETTER |
STOCK_4X6 |
STOCK_4X675_LEADING_DOC_TAB |
STOCK_4X675_TRAILING_DOC_TAB |
STOCK_4X8 |
STOCK_4X9_LEADING_DOC_TAB |
STOCK_4X9_TRAILING_DOC_TAB |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


SignatureOptionDetail Class

[image]

.NET Framework Class Library
SignatureOptionDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class SignatureOptionDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class SignatureOptionDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class SignatureOptionDetail
JavaScript
InSite.Domain.FedExRateService.SignatureOptionDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.SignatureOptionDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.SignatureOptionDetail

See Also

SignatureOptionDetail Members
InSite.Domain.FedExRateService Namespace


SignatureOptionDetail Members

[image] [image]

.NET Framework Class Library
SignatureOptionDetail Members
SignatureOptionDetail Class Constructors Methods Properties See Also Send Feedback

The SignatureOptionDetail type exposes the following members.

Constructors

Name | Description
SignatureOptionDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OptionType |
SignatureReleaseNumber |

See Also

SignatureOptionDetail Class
InSite.Domain.FedExRateService Namespace


SignatureOptionDetail Constructor

[image]

.NET Framework Class Library
SignatureOptionDetail Constructor
SignatureOptionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SignatureOptionDetail()
Visual C++
public:
SignatureOptionDetail()
JavaScript
InSite.Domain.FedExRateService.SignatureOptionDetail = function();

See Also

SignatureOptionDetail Class
InSite.Domain.FedExRateService Namespace


SignatureOptionDetail Methods

[image] [image]

.NET Framework Class Library
SignatureOptionDetail Methods
SignatureOptionDetail Class See Also Send Feedback

The SignatureOptionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SignatureOptionDetail Class
InSite.Domain.FedExRateService Namespace


SignatureOptionDetail Properties

[image] [image]

.NET Framework Class Library
SignatureOptionDetail Properties
SignatureOptionDetail Class See Also Send Feedback

The SignatureOptionDetail type exposes the following members.

Properties

Name | Description
OptionType |
SignatureReleaseNumber |

See Also

SignatureOptionDetail Class
InSite.Domain.FedExRateService Namespace


OptionType Property

[image]

.NET Framework Class Library
SignatureOptionDetail..::.OptionType Property
SignatureOptionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OptionType As SignatureOptionType
C#
public SignatureOptionType OptionType { get; set; }
Visual C++
public:
property SignatureOptionType OptionType {
    SignatureOptionType get ();
    void set (SignatureOptionType value);
}
JavaScript
function get_optionType();
function set_optionType(value);

Remarks

See Also

SignatureOptionDetail Class
InSite.Domain.FedExRateService Namespace


SignatureReleaseNumber Property

[image]

.NET Framework Class Library
SignatureOptionDetail..::.SignatureReleaseNumber Property
SignatureOptionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SignatureReleaseNumber As String
C#
public string SignatureReleaseNumber { get; set; }
Visual C++
public:
property String^ SignatureReleaseNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_signatureReleaseNumber();
function set_signatureReleaseNumber(value);

Remarks

See Also

SignatureOptionDetail Class
InSite.Domain.FedExRateService Namespace


SignatureOptionType Enumeration

[image]

.NET Framework Class Library
SignatureOptionType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration SignatureOptionType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum SignatureOptionType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class SignatureOptionType
JavaScript
InSite.Domain.FedExRateService.SignatureOptionType = function();
InSite.Domain.FedExRateService.SignatureOptionType.createEnum('InSite.Domain.FedExRateService.SignatureOptionType', false);

Members

Member name | Description
ADULT |
DIRECT |
INDIRECT |
NO_SIGNATURE_REQUIRED |
SERVICE_DEFAULT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


SmartPostAncillaryEndorsementType Enumeration

[image]

.NET Framework Class Library
SmartPostAncillaryEndorsementType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration SmartPostAncillaryEndorsementType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum SmartPostAncillaryEndorsementType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class SmartPostAncillaryEndorsementType
JavaScript
InSite.Domain.FedExRateService.SmartPostAncillaryEndorsementType = function();
InSite.Domain.FedExRateService.SmartPostAncillaryEndorsementType.createEnum('InSite.Domain.FedExRateService.SmartPostAncillaryEndorsementType', false);

Members

Member name | Description
ADDRESS_CORRECTION |
CARRIER_LEAVE_IF_NO_RESPONSE |
CHANGE_SERVICE |
FORWARDING_SERVICE |
RETURN_SERVICE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


SmartPostIndiciaType Enumeration

[image]

.NET Framework Class Library
SmartPostIndiciaType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration SmartPostIndiciaType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum SmartPostIndiciaType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class SmartPostIndiciaType
JavaScript
InSite.Domain.FedExRateService.SmartPostIndiciaType = function();
InSite.Domain.FedExRateService.SmartPostIndiciaType.createEnum('InSite.Domain.FedExRateService.SmartPostIndiciaType', false);

Members

Member name | Description
MEDIA_MAIL |
PARCEL_SELECT |
PRESORTED_BOUND_PRINTED_MATTER |
PRESORTED_STANDARD |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


SmartPostShipmentDetail Class

[image]

.NET Framework Class Library
SmartPostShipmentDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class SmartPostShipmentDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class SmartPostShipmentDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class SmartPostShipmentDetail
JavaScript
InSite.Domain.FedExRateService.SmartPostShipmentDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.SmartPostShipmentDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.SmartPostShipmentDetail

See Also

SmartPostShipmentDetail Members
InSite.Domain.FedExRateService Namespace


SmartPostShipmentDetail Members

[image] [image]

.NET Framework Class Library
SmartPostShipmentDetail Members
SmartPostShipmentDetail Class Constructors Methods Properties See Also Send Feedback

The SmartPostShipmentDetail type exposes the following members.

Constructors

Name | Description
SmartPostShipmentDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AncillaryEndorsement |
AncillaryEndorsementSpecified |
CustomerManifestId |
HubId |
Indicia |
IndiciaSpecified |
SpecialServices |

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


SmartPostShipmentDetail Constructor

[image]

.NET Framework Class Library
SmartPostShipmentDetail Constructor
SmartPostShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SmartPostShipmentDetail()
Visual C++
public:
SmartPostShipmentDetail()
JavaScript
InSite.Domain.FedExRateService.SmartPostShipmentDetail = function();

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


SmartPostShipmentDetail Methods

[image] [image]

.NET Framework Class Library
SmartPostShipmentDetail Methods
SmartPostShipmentDetail Class See Also Send Feedback

The SmartPostShipmentDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


SmartPostShipmentDetail Properties

[image] [image]

.NET Framework Class Library
SmartPostShipmentDetail Properties
SmartPostShipmentDetail Class See Also Send Feedback

The SmartPostShipmentDetail type exposes the following members.

Properties

Name | Description
AncillaryEndorsement |
AncillaryEndorsementSpecified |
CustomerManifestId |
HubId |
Indicia |
IndiciaSpecified |
SpecialServices |

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


AncillaryEndorsement Property

[image]

.NET Framework Class Library
SmartPostShipmentDetail..::.AncillaryEndorsement Property
SmartPostShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AncillaryEndorsement As SmartPostAncillaryEndorsementType
C#
public SmartPostAncillaryEndorsementType AncillaryEndorsement { get; set; }
Visual C++
public:
property SmartPostAncillaryEndorsementType AncillaryEndorsement {
    SmartPostAncillaryEndorsementType get ();
    void set (SmartPostAncillaryEndorsementType value);
}
JavaScript
function get_ancillaryEndorsement();
function set_ancillaryEndorsement(value);

Remarks

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


AncillaryEndorsementSpecified Property

[image]

.NET Framework Class Library
SmartPostShipmentDetail..::.AncillaryEndorsementSpecified Property
SmartPostShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AncillaryEndorsementSpecified As Boolean
C#
public bool AncillaryEndorsementSpecified { get; set; }
Visual C++
public:
property bool AncillaryEndorsementSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_ancillaryEndorsementSpecified();
function set_ancillaryEndorsementSpecified(value);

Remarks

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


CustomerManifestId Property

[image]

.NET Framework Class Library
SmartPostShipmentDetail..::.CustomerManifestId Property
SmartPostShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerManifestId As String
C#
public string CustomerManifestId { get; set; }
Visual C++
public:
property String^ CustomerManifestId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerManifestId();
function set_customerManifestId(value);

Remarks

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


HubId Property

[image]

.NET Framework Class Library
SmartPostShipmentDetail..::.HubId Property
SmartPostShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HubId As String
C#
public string HubId { get; set; }
Visual C++
public:
property String^ HubId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_hubId();
function set_hubId(value);

Remarks

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


Indicia Property

[image]

.NET Framework Class Library
SmartPostShipmentDetail..::.Indicia Property
SmartPostShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Indicia As SmartPostIndiciaType
C#
public SmartPostIndiciaType Indicia { get; set; }
Visual C++
public:
property SmartPostIndiciaType Indicia {
    SmartPostIndiciaType get ();
    void set (SmartPostIndiciaType value);
}
JavaScript
function get_indicia();
function set_indicia(value);

Remarks

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


IndiciaSpecified Property

[image]

.NET Framework Class Library
SmartPostShipmentDetail..::.IndiciaSpecified Property
SmartPostShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IndiciaSpecified As Boolean
C#
public bool IndiciaSpecified { get; set; }
Visual C++
public:
property bool IndiciaSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_indiciaSpecified();
function set_indiciaSpecified(value);

Remarks

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


SpecialServices Property

[image]

.NET Framework Class Library
SmartPostShipmentDetail..::.SpecialServices Property
SmartPostShipmentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SpecialServices As SmartPostShipmentSpecialServiceType()
C#
public SmartPostShipmentSpecialServiceType[] SpecialServices { get; set; }
Visual C++
public:
property array<SmartPostShipmentSpecialServiceType>^ SpecialServices {
    array<SmartPostShipmentSpecialServiceType>^ get ();
    void set (array<SmartPostShipmentSpecialServiceType>^ value);
}
JavaScript
function get_specialServices();
function set_specialServices(value);

Remarks

See Also

SmartPostShipmentDetail Class
InSite.Domain.FedExRateService Namespace


SmartPostShipmentSpecialServiceType Enumeration

[image]

.NET Framework Class Library
SmartPostShipmentSpecialServiceType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration SmartPostShipmentSpecialServiceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum SmartPostShipmentSpecialServiceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class SmartPostShipmentSpecialServiceType
JavaScript
InSite.Domain.FedExRateService.SmartPostShipmentSpecialServiceType = function();
InSite.Domain.FedExRateService.SmartPostShipmentSpecialServiceType.createEnum('InSite.Domain.FedExRateService.SmartPostShipmentSpecialServiceType', false);

Members

Member name | Description
USPS_DELIVERY_CONFIRMATION |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


SpecialRatingAppliedType Enumeration

[image]

.NET Framework Class Library
SpecialRatingAppliedType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration SpecialRatingAppliedType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum SpecialRatingAppliedType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class SpecialRatingAppliedType
JavaScript
InSite.Domain.FedExRateService.SpecialRatingAppliedType = function();
InSite.Domain.FedExRateService.SpecialRatingAppliedType.createEnum('InSite.Domain.FedExRateService.SpecialRatingAppliedType', false);

Members

Member name | Description
FIXED_FUEL_SURCHARGE |
IMPORT_PRICING |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Surcharge Class

[image]

.NET Framework Class Library
Surcharge Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Surcharge
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Surcharge
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Surcharge
JavaScript
InSite.Domain.FedExRateService.Surcharge = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Surcharge');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Surcharge

See Also

Surcharge Members
InSite.Domain.FedExRateService Namespace


Surcharge Members

[image] [image]

.NET Framework Class Library
Surcharge Members
Surcharge Class Constructors Methods Properties See Also Send Feedback

The Surcharge type exposes the following members.

Constructors

Name | Description
Surcharge |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Description |
Level |
LevelSpecified |
SurchargeType |
SurchargeTypeSpecified |

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


Surcharge Constructor

[image]

.NET Framework Class Library
Surcharge Constructor
Surcharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Surcharge()
Visual C++
public:
Surcharge()
JavaScript
InSite.Domain.FedExRateService.Surcharge = function();

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


Surcharge Methods

[image] [image]

.NET Framework Class Library
Surcharge Methods
Surcharge Class See Also Send Feedback

The Surcharge type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


Surcharge Properties

[image] [image]

.NET Framework Class Library
Surcharge Properties
Surcharge Class See Also Send Feedback

The Surcharge type exposes the following members.

Properties

Name | Description
Amount |
Description |
Level |
LevelSpecified |
SurchargeType |
SurchargeTypeSpecified |

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


Amount Property

[image]

.NET Framework Class Library
Surcharge..::.Amount Property
Surcharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As Money
C#
public Money Amount { get; set; }
Visual C++
public:
property Money^ Amount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
Surcharge..::.Description Property
Surcharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


Level Property

[image]

.NET Framework Class Library
Surcharge..::.Level Property
Surcharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Level As SurchargeLevelType
C#
public SurchargeLevelType Level { get; set; }
Visual C++
public:
property SurchargeLevelType Level {
    SurchargeLevelType get ();
    void set (SurchargeLevelType value);
}
JavaScript
function get_level();
function set_level(value);

Remarks

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


LevelSpecified Property

[image]

.NET Framework Class Library
Surcharge..::.LevelSpecified Property
Surcharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LevelSpecified As Boolean
C#
public bool LevelSpecified { get; set; }
Visual C++
public:
property bool LevelSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_levelSpecified();
function set_levelSpecified(value);

Remarks

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


SurchargeType Property

[image]

.NET Framework Class Library
Surcharge..::.SurchargeType Property
Surcharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SurchargeType As SurchargeType
C#
public SurchargeType SurchargeType { get; set; }
Visual C++
public:
property SurchargeType SurchargeType {
    SurchargeType get ();
    void set (SurchargeType value);
}
JavaScript
function get_surchargeType();
function set_surchargeType(value);

Remarks

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


SurchargeTypeSpecified Property

[image]

.NET Framework Class Library
Surcharge..::.SurchargeTypeSpecified Property
Surcharge Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SurchargeTypeSpecified As Boolean
C#
public bool SurchargeTypeSpecified { get; set; }
Visual C++
public:
property bool SurchargeTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_surchargeTypeSpecified();
function set_surchargeTypeSpecified(value);

Remarks

See Also

Surcharge Class
InSite.Domain.FedExRateService Namespace


SurchargeLevelType Enumeration

[image]

.NET Framework Class Library
SurchargeLevelType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration SurchargeLevelType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum SurchargeLevelType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class SurchargeLevelType
JavaScript
InSite.Domain.FedExRateService.SurchargeLevelType = function();
InSite.Domain.FedExRateService.SurchargeLevelType.createEnum('InSite.Domain.FedExRateService.SurchargeLevelType', false);

Members

Member name | Description
PACKAGE |
SHIPMENT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


SurchargeType Enumeration

[image]

.NET Framework Class Library
SurchargeType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration SurchargeType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum SurchargeType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class SurchargeType
JavaScript
InSite.Domain.FedExRateService.SurchargeType = function();
InSite.Domain.FedExRateService.SurchargeType.createEnum('InSite.Domain.FedExRateService.SurchargeType', false);

Members

Member name | Description
ADDITIONAL_HANDLING |
APPOINTMENT_DELIVERY |
BROKER_SELECT_OPTION |
CANADIAN_DESTINATION |
CLEARANCE_ENTRY_FEE |
COD |
CUT_FLOWERS |
DANGEROUS_GOODS |
DELIVERY_AREA |
DELIVERY_CONFIRMATION |
DRY_ICE |
EMAIL_LABEL |
EUROPE_FIRST |
EXHIBITION |
EXPORT |
EXTREME_LENGTH |
FEDEX_TAG |
FICE |
FLATBED |
FREIGHT_GUARANTEE |
FUEL |
HOME_DELIVERY_APPOINTMENT |
HOME_DELIVERY_DATE_CERTAIN |
HOME_DELIVERY_EVENING |
INSIDE_DELIVERY |
INSIDE_PICKUP |
INSURED_VALUE |
INTERHAWAII |
ISLAND_DELIVERY |
ISLAND_PICKUP |
LIFTGATE_DELIVERY |
LIFTGATE_PICKUP |
LIMITED_ACCESS_DELIVERY |
LIMITED_ACCESS_PICKUP |
METRO_DELIVERY |
METRO_PICKUP |
NON_MACHINABLE |
OFFSHORE |
ON_CALL_PICKUP |
OTHER |
OUT_OF_DELIVERY_AREA |
OUT_OF_PICKUP_AREA |
OVERSIZE |
OVER_DIMENSION |
PIECE_COUNT_VERIFICATION |
PRE_DELIVERY_NOTIFICATION |
PRIORITY_ALERT |
PROTECTION_FROM_FREEZING |
REGIONAL_MALL_DELIVERY |
REGIONAL_MALL_PICKUP |
RESIDENTIAL_DELIVERY |
RESIDENTIAL_PICKUP |
RETURN_LABEL |
SATURDAY_DELIVERY |
SATURDAY_PICKUP |
SIGNATURE_OPTION |
TARP |
TRANSMART_SERVICE_FEE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


Tax Class

[image]

.NET Framework Class Library
Tax Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Tax
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Tax
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Tax
JavaScript
InSite.Domain.FedExRateService.Tax = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Tax');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Tax

See Also

Tax Members
InSite.Domain.FedExRateService Namespace


Tax Members

[image] [image]

.NET Framework Class Library
Tax Members
Tax Class Constructors Methods Properties See Also Send Feedback

The Tax type exposes the following members.

Constructors

Name | Description
Tax |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Amount |
Description |
TaxType |
TaxTypeSpecified |

See Also

Tax Class
InSite.Domain.FedExRateService Namespace


Tax Constructor

[image]

.NET Framework Class Library
Tax Constructor
Tax Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Tax()
Visual C++
public:
Tax()
JavaScript
InSite.Domain.FedExRateService.Tax = function();

See Also

Tax Class
InSite.Domain.FedExRateService Namespace


Tax Methods

[image] [image]

.NET Framework Class Library
Tax Methods
Tax Class See Also Send Feedback

The Tax type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Tax Class
InSite.Domain.FedExRateService Namespace


Tax Properties

[image] [image]

.NET Framework Class Library
Tax Properties
Tax Class See Also Send Feedback

The Tax type exposes the following members.

Properties

Name | Description
Amount |
Description |
TaxType |
TaxTypeSpecified |

See Also

Tax Class
InSite.Domain.FedExRateService Namespace


Amount Property

[image]

.NET Framework Class Library
Tax..::.Amount Property
Tax Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Amount As Money
C#
public Money Amount { get; set; }
Visual C++
public:
property Money^ Amount {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_amount();
function set_amount(value);

Remarks

See Also

Tax Class
InSite.Domain.FedExRateService Namespace


Description Property

[image]

.NET Framework Class Library
Tax..::.Description Property
Tax Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Description As String
C#
public string Description { get; set; }
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

Remarks

See Also

Tax Class
InSite.Domain.FedExRateService Namespace


TaxType Property

[image]

.NET Framework Class Library
Tax..::.TaxType Property
Tax Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TaxType As TaxType
C#
public TaxType TaxType { get; set; }
Visual C++
public:
property TaxType TaxType {
    TaxType get ();
    void set (TaxType value);
}
JavaScript
function get_taxType();
function set_taxType(value);

Remarks

See Also

Tax Class
InSite.Domain.FedExRateService Namespace


TaxTypeSpecified Property

[image]

.NET Framework Class Library
Tax..::.TaxTypeSpecified Property
Tax Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TaxTypeSpecified As Boolean
C#
public bool TaxTypeSpecified { get; set; }
Visual C++
public:
property bool TaxTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxTypeSpecified();
function set_taxTypeSpecified(value);

Remarks

See Also

Tax Class
InSite.Domain.FedExRateService Namespace


TaxpayerIdentification Class

[image]

.NET Framework Class Library
TaxpayerIdentification Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class TaxpayerIdentification
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class TaxpayerIdentification
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class TaxpayerIdentification
JavaScript
InSite.Domain.FedExRateService.TaxpayerIdentification = function();

Type.createClass(
    'InSite.Domain.FedExRateService.TaxpayerIdentification');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.TaxpayerIdentification

See Also

TaxpayerIdentification Members
InSite.Domain.FedExRateService Namespace


TaxpayerIdentification Members

[image] [image]

.NET Framework Class Library
TaxpayerIdentification Members
TaxpayerIdentification Class Constructors Methods Properties See Also Send Feedback

The TaxpayerIdentification type exposes the following members.

Constructors

Name | Description
TaxpayerIdentification |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Number |
TinType |

See Also

TaxpayerIdentification Class
InSite.Domain.FedExRateService Namespace


TaxpayerIdentification Constructor

[image]

.NET Framework Class Library
TaxpayerIdentification Constructor
TaxpayerIdentification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaxpayerIdentification()
Visual C++
public:
TaxpayerIdentification()
JavaScript
InSite.Domain.FedExRateService.TaxpayerIdentification = function();

See Also

TaxpayerIdentification Class
InSite.Domain.FedExRateService Namespace


TaxpayerIdentification Methods

[image] [image]

.NET Framework Class Library
TaxpayerIdentification Methods
TaxpayerIdentification Class See Also Send Feedback

The TaxpayerIdentification type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaxpayerIdentification Class
InSite.Domain.FedExRateService Namespace


TaxpayerIdentification Properties

[image] [image]

.NET Framework Class Library
TaxpayerIdentification Properties
TaxpayerIdentification Class See Also Send Feedback

The TaxpayerIdentification type exposes the following members.

Properties

Name | Description
Number |
TinType |

See Also

TaxpayerIdentification Class
InSite.Domain.FedExRateService Namespace


Number Property

[image]

.NET Framework Class Library
TaxpayerIdentification..::.Number Property
TaxpayerIdentification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Number As String
C#
public string Number { get; set; }
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_number();
function set_number(value);

Remarks

See Also

TaxpayerIdentification Class
InSite.Domain.FedExRateService Namespace


TinType Property

[image]

.NET Framework Class Library
TaxpayerIdentification..::.TinType Property
TaxpayerIdentification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TinType As TinType
C#
public TinType TinType { get; set; }
Visual C++
public:
property TinType TinType {
    TinType get ();
    void set (TinType value);
}
JavaScript
function get_tinType();
function set_tinType(value);

Remarks

See Also

TaxpayerIdentification Class
InSite.Domain.FedExRateService Namespace


TaxType Enumeration

[image]

.NET Framework Class Library
TaxType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration TaxType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum TaxType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class TaxType
JavaScript
InSite.Domain.FedExRateService.TaxType = function();
InSite.Domain.FedExRateService.TaxType.createEnum('InSite.Domain.FedExRateService.TaxType', false);

Members

Member name | Description
EXPORT |
GST |
HST |
OTHER |
PST |
VAT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


TermsOfSaleType Enumeration

[image]

.NET Framework Class Library
TermsOfSaleType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration TermsOfSaleType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum TermsOfSaleType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class TermsOfSaleType
JavaScript
InSite.Domain.FedExRateService.TermsOfSaleType = function();
InSite.Domain.FedExRateService.TermsOfSaleType.createEnum('InSite.Domain.FedExRateService.TermsOfSaleType', false);

Members

Member name | Description
CFR_OR_CPT |
CIF_OR_CIP |
DDP |
DDU |
EXW |
FOB_OR_FCA |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


TinType Enumeration

[image]

.NET Framework Class Library
TinType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration TinType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum TinType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class TinType
JavaScript
InSite.Domain.FedExRateService.TinType = function();
InSite.Domain.FedExRateService.TinType.createEnum('InSite.Domain.FedExRateService.TinType', false);

Members

Member name | Description
EIN |
SSN |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


TrackingId Class

[image]

.NET Framework Class Library
TrackingId Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class TrackingId
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class TrackingId
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class TrackingId
JavaScript
InSite.Domain.FedExRateService.TrackingId = function();

Type.createClass(
    'InSite.Domain.FedExRateService.TrackingId');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.TrackingId

See Also

TrackingId Members
InSite.Domain.FedExRateService Namespace


TrackingId Members

[image] [image]

.NET Framework Class Library
TrackingId Members
TrackingId Class Constructors Methods Properties See Also Send Feedback

The TrackingId type exposes the following members.

Constructors

Name | Description
TrackingId |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FormId |
TrackingIdType |
TrackingIdTypeSpecified |
TrackingNumber |

See Also

TrackingId Class
InSite.Domain.FedExRateService Namespace


TrackingId Constructor

[image]

.NET Framework Class Library
TrackingId Constructor
TrackingId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TrackingId()
Visual C++
public:
TrackingId()
JavaScript
InSite.Domain.FedExRateService.TrackingId = function();

See Also

TrackingId Class
InSite.Domain.FedExRateService Namespace


TrackingId Methods

[image] [image]

.NET Framework Class Library
TrackingId Methods
TrackingId Class See Also Send Feedback

The TrackingId type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackingId Class
InSite.Domain.FedExRateService Namespace


TrackingId Properties

[image] [image]

.NET Framework Class Library
TrackingId Properties
TrackingId Class See Also Send Feedback

The TrackingId type exposes the following members.

Properties

Name | Description
FormId |
TrackingIdType |
TrackingIdTypeSpecified |
TrackingNumber |

See Also

TrackingId Class
InSite.Domain.FedExRateService Namespace


FormId Property

[image]

.NET Framework Class Library
TrackingId..::.FormId Property
TrackingId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FormId As String
C#
public string FormId { get; set; }
Visual C++
public:
property String^ FormId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_formId();
function set_formId(value);

Remarks

See Also

TrackingId Class
InSite.Domain.FedExRateService Namespace


TrackingIdType Property

[image]

.NET Framework Class Library
TrackingId..::.TrackingIdType Property
TrackingId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackingIdType As TrackingIdType
C#
public TrackingIdType TrackingIdType { get; set; }
Visual C++
public:
property TrackingIdType TrackingIdType {
    TrackingIdType get ();
    void set (TrackingIdType value);
}
JavaScript
function get_trackingIdType();
function set_trackingIdType(value);

Remarks

See Also

TrackingId Class
InSite.Domain.FedExRateService Namespace


TrackingIdTypeSpecified Property

[image]

.NET Framework Class Library
TrackingId..::.TrackingIdTypeSpecified Property
TrackingId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackingIdTypeSpecified As Boolean
C#
public bool TrackingIdTypeSpecified { get; set; }
Visual C++
public:
property bool TrackingIdTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_trackingIdTypeSpecified();
function set_trackingIdTypeSpecified(value);

Remarks

See Also

TrackingId Class
InSite.Domain.FedExRateService Namespace


TrackingNumber Property

[image]

.NET Framework Class Library
TrackingId..::.TrackingNumber Property
TrackingId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TrackingNumber As String
C#
public string TrackingNumber { get; set; }
Visual C++
public:
property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_trackingNumber();
function set_trackingNumber(value);

Remarks

See Also

TrackingId Class
InSite.Domain.FedExRateService Namespace


TrackingIdType Enumeration

[image]

.NET Framework Class Library
TrackingIdType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration TrackingIdType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum TrackingIdType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class TrackingIdType
JavaScript
InSite.Domain.FedExRateService.TrackingIdType = function();
InSite.Domain.FedExRateService.TrackingIdType.createEnum('InSite.Domain.FedExRateService.TrackingIdType', false);

Members

Member name | Description
EXPRESS |
GROUND |
USPS |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


TransactionDetail Class

[image]

.NET Framework Class Library
TransactionDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class TransactionDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class TransactionDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class TransactionDetail
JavaScript
InSite.Domain.FedExRateService.TransactionDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.TransactionDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.TransactionDetail

See Also

TransactionDetail Members
InSite.Domain.FedExRateService Namespace


TransactionDetail Members

[image] [image]

.NET Framework Class Library
TransactionDetail Members
TransactionDetail Class Constructors Methods Properties See Also Send Feedback

The TransactionDetail type exposes the following members.

Constructors

Name | Description
TransactionDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerTransactionId |
Localization |

See Also

TransactionDetail Class
InSite.Domain.FedExRateService Namespace


TransactionDetail Constructor

[image]

.NET Framework Class Library
TransactionDetail Constructor
TransactionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TransactionDetail()
Visual C++
public:
TransactionDetail()
JavaScript
InSite.Domain.FedExRateService.TransactionDetail = function();

See Also

TransactionDetail Class
InSite.Domain.FedExRateService Namespace


TransactionDetail Methods

[image] [image]

.NET Framework Class Library
TransactionDetail Methods
TransactionDetail Class See Also Send Feedback

The TransactionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionDetail Class
InSite.Domain.FedExRateService Namespace


TransactionDetail Properties

[image] [image]

.NET Framework Class Library
TransactionDetail Properties
TransactionDetail Class See Also Send Feedback

The TransactionDetail type exposes the following members.

Properties

Name | Description
CustomerTransactionId |
Localization |

See Also

TransactionDetail Class
InSite.Domain.FedExRateService Namespace


CustomerTransactionId Property

[image]

.NET Framework Class Library
TransactionDetail..::.CustomerTransactionId Property
TransactionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerTransactionId As String
C#
public string CustomerTransactionId { get; set; }
Visual C++
public:
property String^ CustomerTransactionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerTransactionId();
function set_customerTransactionId(value);

Remarks

See Also

TransactionDetail Class
InSite.Domain.FedExRateService Namespace


Localization Property

[image]

.NET Framework Class Library
TransactionDetail..::.Localization Property
TransactionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Localization As Localization
C#
public Localization Localization { get; set; }
Visual C++
public:
property Localization^ Localization {
    Localization^ get ();
    void set (Localization^ value);
}
JavaScript
function get_localization();
function set_localization(value);

Remarks

See Also

TransactionDetail Class
InSite.Domain.FedExRateService Namespace


TransitTimeType Enumeration

[image]

.NET Framework Class Library
TransitTimeType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration TransitTimeType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum TransitTimeType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class TransitTimeType
JavaScript
InSite.Domain.FedExRateService.TransitTimeType = function();
InSite.Domain.FedExRateService.TransitTimeType.createEnum('InSite.Domain.FedExRateService.TransitTimeType', false);

Members

Member name | Description
ONE_DAY |
TWO_DAYS |
THREE_DAYS |
FOUR_DAYS |
FIVE_DAYS |
SIX_DAYS |
SEVEN_DAYS |
EIGHT_DAYS |
NINE_DAYS |
TEN_DAYS |
ELEVEN_DAYS |
TWELVE_DAYS |
THIRTEEN_DAYS |
FOURTEEN_DAYS |
FIFTEEN_DAYS |
SIXTEEN_DAYS |
SEVENTEEN_DAYS |
EIGHTEEN_DAYS |
NINETEEN_DAYS |
TWENTY_DAYS |
UNKNOWN |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


UploadDocumentDetail Class

[image]

.NET Framework Class Library
UploadDocumentDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class UploadDocumentDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class UploadDocumentDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class UploadDocumentDetail
JavaScript
InSite.Domain.FedExRateService.UploadDocumentDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.UploadDocumentDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.UploadDocumentDetail

See Also

UploadDocumentDetail Members
InSite.Domain.FedExRateService Namespace


UploadDocumentDetail Members

[image] [image]

.NET Framework Class Library
UploadDocumentDetail Members
UploadDocumentDetail Class Constructors Methods Properties See Also Send Feedback

The UploadDocumentDetail type exposes the following members.

Constructors

Name | Description
UploadDocumentDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerReference |
DocumentContent |
DocumentProducer |
DocumentProducerSpecified |
DocumentType |
DocumentTypeSpecified |
FileName |
LineNumber |

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


UploadDocumentDetail Constructor

[image]

.NET Framework Class Library
UploadDocumentDetail Constructor
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UploadDocumentDetail()
Visual C++
public:
UploadDocumentDetail()
JavaScript
InSite.Domain.FedExRateService.UploadDocumentDetail = function();

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


UploadDocumentDetail Methods

[image] [image]

.NET Framework Class Library
UploadDocumentDetail Methods
UploadDocumentDetail Class See Also Send Feedback

The UploadDocumentDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


UploadDocumentDetail Properties

[image] [image]

.NET Framework Class Library
UploadDocumentDetail Properties
UploadDocumentDetail Class See Also Send Feedback

The UploadDocumentDetail type exposes the following members.

Properties

Name | Description
CustomerReference |
DocumentContent |
DocumentProducer |
DocumentProducerSpecified |
DocumentType |
DocumentTypeSpecified |
FileName |
LineNumber |

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


CustomerReference Property

[image]

.NET Framework Class Library
UploadDocumentDetail..::.CustomerReference Property
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerReference As String
C#
public string CustomerReference { get; set; }
Visual C++
public:
property String^ CustomerReference {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerReference();
function set_customerReference(value);

Remarks

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


DocumentContent Property

[image]

.NET Framework Class Library
UploadDocumentDetail..::.DocumentContent Property
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentContent As Byte()
C#
public byte[] DocumentContent { get; set; }
Visual C++
public:
property array<unsigned char>^ DocumentContent {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
JavaScript
function get_documentContent();
function set_documentContent(value);

Remarks

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


DocumentProducer Property

[image]

.NET Framework Class Library
UploadDocumentDetail..::.DocumentProducer Property
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentProducer As UploadDocumentProducerType
C#
public UploadDocumentProducerType DocumentProducer { get; set; }
Visual C++
public:
property UploadDocumentProducerType DocumentProducer {
    UploadDocumentProducerType get ();
    void set (UploadDocumentProducerType value);
}
JavaScript
function get_documentProducer();
function set_documentProducer(value);

Remarks

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


DocumentProducerSpecified Property

[image]

.NET Framework Class Library
UploadDocumentDetail..::.DocumentProducerSpecified Property
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentProducerSpecified As Boolean
C#
public bool DocumentProducerSpecified { get; set; }
Visual C++
public:
property bool DocumentProducerSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_documentProducerSpecified();
function set_documentProducerSpecified(value);

Remarks

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


DocumentType Property

[image]

.NET Framework Class Library
UploadDocumentDetail..::.DocumentType Property
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentType As UploadDocumentType
C#
public UploadDocumentType DocumentType { get; set; }
Visual C++
public:
property UploadDocumentType DocumentType {
    UploadDocumentType get ();
    void set (UploadDocumentType value);
}
JavaScript
function get_documentType();
function set_documentType(value);

Remarks

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


DocumentTypeSpecified Property

[image]

.NET Framework Class Library
UploadDocumentDetail..::.DocumentTypeSpecified Property
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentTypeSpecified As Boolean
C#
public bool DocumentTypeSpecified { get; set; }
Visual C++
public:
property bool DocumentTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_documentTypeSpecified();
function set_documentTypeSpecified(value);

Remarks

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


FileName Property

[image]

.NET Framework Class Library
UploadDocumentDetail..::.FileName Property
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FileName As String
C#
public string FileName { get; set; }
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fileName();
function set_fileName(value);

Remarks

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


LineNumber Property

[image]

.NET Framework Class Library
UploadDocumentDetail..::.LineNumber Property
UploadDocumentDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LineNumber As String
C#
public string LineNumber { get; set; }
Visual C++
public:
property String^ LineNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lineNumber();
function set_lineNumber(value);

Remarks

See Also

UploadDocumentDetail Class
InSite.Domain.FedExRateService Namespace


UploadDocumentIdProducer Enumeration

[image]

.NET Framework Class Library
UploadDocumentIdProducer Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration UploadDocumentIdProducer
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum UploadDocumentIdProducer
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class UploadDocumentIdProducer
JavaScript
InSite.Domain.FedExRateService.UploadDocumentIdProducer = function();
InSite.Domain.FedExRateService.UploadDocumentIdProducer.createEnum('InSite.Domain.FedExRateService.UploadDocumentIdProducer', false);

Members

Member name | Description
CUSTOMER |
FEDEX_CSHP |
FEDEX_GTM |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


UploadDocumentProducerType Enumeration

[image]

.NET Framework Class Library
UploadDocumentProducerType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration UploadDocumentProducerType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum UploadDocumentProducerType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class UploadDocumentProducerType
JavaScript
InSite.Domain.FedExRateService.UploadDocumentProducerType = function();
InSite.Domain.FedExRateService.UploadDocumentProducerType.createEnum('InSite.Domain.FedExRateService.UploadDocumentProducerType', false);

Members

Member name | Description
CUSTOMER |
FEDEX_CLS |
FEDEX_GTM |
OTHER |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


UploadDocumentReferenceDetail Class

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class UploadDocumentReferenceDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class UploadDocumentReferenceDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class UploadDocumentReferenceDetail
JavaScript
InSite.Domain.FedExRateService.UploadDocumentReferenceDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.UploadDocumentReferenceDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.UploadDocumentReferenceDetail

See Also

UploadDocumentReferenceDetail Members
InSite.Domain.FedExRateService Namespace


UploadDocumentReferenceDetail Members

[image] [image]

.NET Framework Class Library
UploadDocumentReferenceDetail Members
UploadDocumentReferenceDetail Class Constructors Methods Properties See Also Send Feedback

The UploadDocumentReferenceDetail type exposes the following members.

Constructors

Name | Description
UploadDocumentReferenceDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerReference |
DocumentId |
DocumentIdProducer |
DocumentIdProducerSpecified |
DocumentProducer |
DocumentProducerSpecified |
DocumentType |
DocumentTypeSpecified |
LineNumber |

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


UploadDocumentReferenceDetail Constructor

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail Constructor
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UploadDocumentReferenceDetail()
Visual C++
public:
UploadDocumentReferenceDetail()
JavaScript
InSite.Domain.FedExRateService.UploadDocumentReferenceDetail = function();

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


UploadDocumentReferenceDetail Methods

[image] [image]

.NET Framework Class Library
UploadDocumentReferenceDetail Methods
UploadDocumentReferenceDetail Class See Also Send Feedback

The UploadDocumentReferenceDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


UploadDocumentReferenceDetail Properties

[image] [image]

.NET Framework Class Library
UploadDocumentReferenceDetail Properties
UploadDocumentReferenceDetail Class See Also Send Feedback

The UploadDocumentReferenceDetail type exposes the following members.

Properties

Name | Description
CustomerReference |
DocumentId |
DocumentIdProducer |
DocumentIdProducerSpecified |
DocumentProducer |
DocumentProducerSpecified |
DocumentType |
DocumentTypeSpecified |
LineNumber |

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


CustomerReference Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.CustomerReference Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerReference As String
C#
public string CustomerReference { get; set; }
Visual C++
public:
property String^ CustomerReference {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerReference();
function set_customerReference(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


DocumentId Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.DocumentId Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentId As String
C#
public string DocumentId { get; set; }
Visual C++
public:
property String^ DocumentId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_documentId();
function set_documentId(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


DocumentIdProducer Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.DocumentIdProducer Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentIdProducer As UploadDocumentIdProducer
C#
public UploadDocumentIdProducer DocumentIdProducer { get; set; }
Visual C++
public:
property UploadDocumentIdProducer DocumentIdProducer {
    UploadDocumentIdProducer get ();
    void set (UploadDocumentIdProducer value);
}
JavaScript
function get_documentIdProducer();
function set_documentIdProducer(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


DocumentIdProducerSpecified Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.DocumentIdProducerSpecified Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentIdProducerSpecified As Boolean
C#
public bool DocumentIdProducerSpecified { get; set; }
Visual C++
public:
property bool DocumentIdProducerSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_documentIdProducerSpecified();
function set_documentIdProducerSpecified(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


DocumentProducer Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.DocumentProducer Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentProducer As UploadDocumentProducerType
C#
public UploadDocumentProducerType DocumentProducer { get; set; }
Visual C++
public:
property UploadDocumentProducerType DocumentProducer {
    UploadDocumentProducerType get ();
    void set (UploadDocumentProducerType value);
}
JavaScript
function get_documentProducer();
function set_documentProducer(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


DocumentProducerSpecified Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.DocumentProducerSpecified Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentProducerSpecified As Boolean
C#
public bool DocumentProducerSpecified { get; set; }
Visual C++
public:
property bool DocumentProducerSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_documentProducerSpecified();
function set_documentProducerSpecified(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


DocumentType Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.DocumentType Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentType As UploadDocumentType
C#
public UploadDocumentType DocumentType { get; set; }
Visual C++
public:
property UploadDocumentType DocumentType {
    UploadDocumentType get ();
    void set (UploadDocumentType value);
}
JavaScript
function get_documentType();
function set_documentType(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


DocumentTypeSpecified Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.DocumentTypeSpecified Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentTypeSpecified As Boolean
C#
public bool DocumentTypeSpecified { get; set; }
Visual C++
public:
property bool DocumentTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_documentTypeSpecified();
function set_documentTypeSpecified(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


LineNumber Property

[image]

.NET Framework Class Library
UploadDocumentReferenceDetail..::.LineNumber Property
UploadDocumentReferenceDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LineNumber As String
C#
public string LineNumber { get; set; }
Visual C++
public:
property String^ LineNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lineNumber();
function set_lineNumber(value);

Remarks

See Also

UploadDocumentReferenceDetail Class
InSite.Domain.FedExRateService Namespace


UploadDocumentType Enumeration

[image]

.NET Framework Class Library
UploadDocumentType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration UploadDocumentType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum UploadDocumentType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class UploadDocumentType
JavaScript
InSite.Domain.FedExRateService.UploadDocumentType = function();
InSite.Domain.FedExRateService.UploadDocumentType.createEnum('InSite.Domain.FedExRateService.UploadDocumentType', false);

Members

Member name | Description
CERTIFICATE_OF_ORIGIN |
COMMERCIAL_INVOICE |
ETD_LABEL |
NAFTA_CERTIFICATE_OF_ORIGIN |
OTHER |
PRO_FORMA_INVOICE |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


VariableHandlingChargeDetail Class

[image]

.NET Framework Class Library
VariableHandlingChargeDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class VariableHandlingChargeDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class VariableHandlingChargeDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class VariableHandlingChargeDetail
JavaScript
InSite.Domain.FedExRateService.VariableHandlingChargeDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.VariableHandlingChargeDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.VariableHandlingChargeDetail

See Also

VariableHandlingChargeDetail Members
InSite.Domain.FedExRateService Namespace


VariableHandlingChargeDetail Members

[image] [image]

.NET Framework Class Library
VariableHandlingChargeDetail Members
VariableHandlingChargeDetail Class Constructors Methods Properties See Also Send Feedback

The VariableHandlingChargeDetail type exposes the following members.

Constructors

Name | Description
VariableHandlingChargeDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FixedValue |
PercentValue |
PercentValueSpecified |
VariableHandlingChargeType |

See Also

VariableHandlingChargeDetail Class
InSite.Domain.FedExRateService Namespace


VariableHandlingChargeDetail Constructor

[image]

.NET Framework Class Library
VariableHandlingChargeDetail Constructor
VariableHandlingChargeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VariableHandlingChargeDetail()
Visual C++
public:
VariableHandlingChargeDetail()
JavaScript
InSite.Domain.FedExRateService.VariableHandlingChargeDetail = function();

See Also

VariableHandlingChargeDetail Class
InSite.Domain.FedExRateService Namespace


VariableHandlingChargeDetail Methods

[image] [image]

.NET Framework Class Library
VariableHandlingChargeDetail Methods
VariableHandlingChargeDetail Class See Also Send Feedback

The VariableHandlingChargeDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VariableHandlingChargeDetail Class
InSite.Domain.FedExRateService Namespace


VariableHandlingChargeDetail Properties

[image] [image]

.NET Framework Class Library
VariableHandlingChargeDetail Properties
VariableHandlingChargeDetail Class See Also Send Feedback

The VariableHandlingChargeDetail type exposes the following members.

Properties

Name | Description
FixedValue |
PercentValue |
PercentValueSpecified |
VariableHandlingChargeType |

See Also

VariableHandlingChargeDetail Class
InSite.Domain.FedExRateService Namespace


FixedValue Property

[image]

.NET Framework Class Library
VariableHandlingChargeDetail..::.FixedValue Property
VariableHandlingChargeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FixedValue As Money
C#
public Money FixedValue { get; set; }
Visual C++
public:
property Money^ FixedValue {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_fixedValue();
function set_fixedValue(value);

Remarks

See Also

VariableHandlingChargeDetail Class
InSite.Domain.FedExRateService Namespace


PercentValue Property

[image]

.NET Framework Class Library
VariableHandlingChargeDetail..::.PercentValue Property
VariableHandlingChargeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PercentValue As Decimal
C#
public decimal PercentValue { get; set; }
Visual C++
public:
property Decimal PercentValue {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_percentValue();
function set_percentValue(value);

Remarks

See Also

VariableHandlingChargeDetail Class
InSite.Domain.FedExRateService Namespace


PercentValueSpecified Property

[image]

.NET Framework Class Library
VariableHandlingChargeDetail..::.PercentValueSpecified Property
VariableHandlingChargeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PercentValueSpecified As Boolean
C#
public bool PercentValueSpecified { get; set; }
Visual C++
public:
property bool PercentValueSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_percentValueSpecified();
function set_percentValueSpecified(value);

Remarks

See Also

VariableHandlingChargeDetail Class
InSite.Domain.FedExRateService Namespace


VariableHandlingChargeType Property

[image]

.NET Framework Class Library
VariableHandlingChargeDetail..::.VariableHandlingChargeType Property
VariableHandlingChargeDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableHandlingChargeType As VariableHandlingChargeType
C#
public VariableHandlingChargeType VariableHandlingChargeType { get; set; }
Visual C++
public:
property VariableHandlingChargeType VariableHandlingChargeType {
    VariableHandlingChargeType get ();
    void set (VariableHandlingChargeType value);
}
JavaScript
function get_variableHandlingChargeType();
function set_variableHandlingChargeType(value);

Remarks

See Also

VariableHandlingChargeDetail Class
InSite.Domain.FedExRateService Namespace


VariableHandlingCharges Class

[image]

.NET Framework Class Library
VariableHandlingCharges Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class VariableHandlingCharges
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class VariableHandlingCharges
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class VariableHandlingCharges
JavaScript
InSite.Domain.FedExRateService.VariableHandlingCharges = function();

Type.createClass(
    'InSite.Domain.FedExRateService.VariableHandlingCharges');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.VariableHandlingCharges

See Also

VariableHandlingCharges Members
InSite.Domain.FedExRateService Namespace


VariableHandlingCharges Members

[image] [image]

.NET Framework Class Library
VariableHandlingCharges Members
VariableHandlingCharges Class Constructors Methods Properties See Also Send Feedback

The VariableHandlingCharges type exposes the following members.

Constructors

Name | Description
VariableHandlingCharges |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TotalCustomerCharge |
VariableHandlingCharge |

See Also

VariableHandlingCharges Class
InSite.Domain.FedExRateService Namespace


VariableHandlingCharges Constructor

[image]

.NET Framework Class Library
VariableHandlingCharges Constructor
VariableHandlingCharges Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VariableHandlingCharges()
Visual C++
public:
VariableHandlingCharges()
JavaScript
InSite.Domain.FedExRateService.VariableHandlingCharges = function();

See Also

VariableHandlingCharges Class
InSite.Domain.FedExRateService Namespace


VariableHandlingCharges Methods

[image] [image]

.NET Framework Class Library
VariableHandlingCharges Methods
VariableHandlingCharges Class See Also Send Feedback

The VariableHandlingCharges type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VariableHandlingCharges Class
InSite.Domain.FedExRateService Namespace


VariableHandlingCharges Properties

[image] [image]

.NET Framework Class Library
VariableHandlingCharges Properties
VariableHandlingCharges Class See Also Send Feedback

The VariableHandlingCharges type exposes the following members.

Properties

Name | Description
TotalCustomerCharge |
VariableHandlingCharge |

See Also

VariableHandlingCharges Class
InSite.Domain.FedExRateService Namespace


TotalCustomerCharge Property

[image]

.NET Framework Class Library
VariableHandlingCharges..::.TotalCustomerCharge Property
VariableHandlingCharges Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TotalCustomerCharge As Money
C#
public Money TotalCustomerCharge { get; set; }
Visual C++
public:
property Money^ TotalCustomerCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_totalCustomerCharge();
function set_totalCustomerCharge(value);

Remarks

See Also

VariableHandlingCharges Class
InSite.Domain.FedExRateService Namespace


VariableHandlingCharge Property

[image]

.NET Framework Class Library
VariableHandlingCharges..::.VariableHandlingCharge Property
VariableHandlingCharges Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VariableHandlingCharge As Money
C#
public Money VariableHandlingCharge { get; set; }
Visual C++
public:
property Money^ VariableHandlingCharge {
    Money^ get ();
    void set (Money^ value);
}
JavaScript
function get_variableHandlingCharge();
function set_variableHandlingCharge(value);

Remarks

See Also

VariableHandlingCharges Class
InSite.Domain.FedExRateService Namespace


VariableHandlingChargeType Enumeration

[image]

.NET Framework Class Library
VariableHandlingChargeType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration VariableHandlingChargeType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum VariableHandlingChargeType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class VariableHandlingChargeType
JavaScript
InSite.Domain.FedExRateService.VariableHandlingChargeType = function();
InSite.Domain.FedExRateService.VariableHandlingChargeType.createEnum('InSite.Domain.FedExRateService.VariableHandlingChargeType', false);

Members

Member name | Description
FIXED_AMOUNT |
PERCENTAGE_OF_NET_CHARGE |
PERCENTAGE_OF_NET_CHARGE_EXCLUDING_TAXES |
PERCENTAGE_OF_NET_FREIGHT |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


VersionId Class

[image]

.NET Framework Class Library
VersionId Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class VersionId
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class VersionId
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class VersionId
JavaScript
InSite.Domain.FedExRateService.VersionId = function();

Type.createClass(
    'InSite.Domain.FedExRateService.VersionId');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.VersionId

See Also

VersionId Members
InSite.Domain.FedExRateService Namespace


VersionId Members

[image] [image]

.NET Framework Class Library
VersionId Members
VersionId Class Constructors Methods Properties See Also Send Feedback

The VersionId type exposes the following members.

Constructors

Name | Description
VersionId |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Intermediate |
Major |
Minor |
ServiceId |

See Also

VersionId Class
InSite.Domain.FedExRateService Namespace


VersionId Constructor

[image]

.NET Framework Class Library
VersionId Constructor
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VersionId()
Visual C++
public:
VersionId()
JavaScript
InSite.Domain.FedExRateService.VersionId = function();

See Also

VersionId Class
InSite.Domain.FedExRateService Namespace


VersionId Methods

[image] [image]

.NET Framework Class Library
VersionId Methods
VersionId Class See Also Send Feedback

The VersionId type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionId Class
InSite.Domain.FedExRateService Namespace


VersionId Properties

[image] [image]

.NET Framework Class Library
VersionId Properties
VersionId Class See Also Send Feedback

The VersionId type exposes the following members.

Properties

Name | Description
Intermediate |
Major |
Minor |
ServiceId |

See Also

VersionId Class
InSite.Domain.FedExRateService Namespace


Intermediate Property

[image]

.NET Framework Class Library
VersionId..::.Intermediate Property
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Intermediate As Integer
C#
public int Intermediate { get; set; }
Visual C++
public:
property int Intermediate {
    int get ();
    void set (int value);
}
JavaScript
function get_intermediate();
function set_intermediate(value);

Remarks

See Also

VersionId Class
InSite.Domain.FedExRateService Namespace


Major Property

[image]

.NET Framework Class Library
VersionId..::.Major Property
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Major As Integer
C#
public int Major { get; set; }
Visual C++
public:
property int Major {
    int get ();
    void set (int value);
}
JavaScript
function get_major();
function set_major(value);

Remarks

See Also

VersionId Class
InSite.Domain.FedExRateService Namespace


Minor Property

[image]

.NET Framework Class Library
VersionId..::.Minor Property
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Minor As Integer
C#
public int Minor { get; set; }
Visual C++
public:
property int Minor {
    int get ();
    void set (int value);
}
JavaScript
function get_minor();
function set_minor(value);

Remarks

See Also

VersionId Class
InSite.Domain.FedExRateService Namespace


ServiceId Property

[image]

.NET Framework Class Library
VersionId..::.ServiceId Property
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceId As String
C#
public string ServiceId { get; set; }
Visual C++
public:
property String^ ServiceId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_serviceId();
function set_serviceId(value);

Remarks

See Also

VersionId Class
InSite.Domain.FedExRateService Namespace


Volume Class

[image]

.NET Framework Class Library
Volume Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Volume
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Volume
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Volume
JavaScript
InSite.Domain.FedExRateService.Volume = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Volume');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Volume

See Also

Volume Members
InSite.Domain.FedExRateService Namespace


Volume Members

[image] [image]

.NET Framework Class Library
Volume Members
Volume Class Constructors Methods Properties See Also Send Feedback

The Volume type exposes the following members.

Constructors

Name | Description
Volume |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Units |
UnitsSpecified |
Value |
ValueSpecified |

See Also

Volume Class
InSite.Domain.FedExRateService Namespace


Volume Constructor

[image]

.NET Framework Class Library
Volume Constructor
Volume Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Volume()
Visual C++
public:
Volume()
JavaScript
InSite.Domain.FedExRateService.Volume = function();

See Also

Volume Class
InSite.Domain.FedExRateService Namespace


Volume Methods

[image] [image]

.NET Framework Class Library
Volume Methods
Volume Class See Also Send Feedback

The Volume type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Volume Class
InSite.Domain.FedExRateService Namespace


Volume Properties

[image] [image]

.NET Framework Class Library
Volume Properties
Volume Class See Also Send Feedback

The Volume type exposes the following members.

Properties

Name | Description
Units |
UnitsSpecified |
Value |
ValueSpecified |

See Also

Volume Class
InSite.Domain.FedExRateService Namespace


Units Property

[image]

.NET Framework Class Library
Volume..::.Units Property
Volume Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As VolumeUnits
C#
public VolumeUnits Units { get; set; }
Visual C++
public:
property VolumeUnits Units {
    VolumeUnits get ();
    void set (VolumeUnits value);
}
JavaScript
function get_units();
function set_units(value);

Remarks

See Also

Volume Class
InSite.Domain.FedExRateService Namespace


UnitsSpecified Property

[image]

.NET Framework Class Library
Volume..::.UnitsSpecified Property
Volume Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UnitsSpecified As Boolean
C#
public bool UnitsSpecified { get; set; }
Visual C++
public:
property bool UnitsSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_unitsSpecified();
function set_unitsSpecified(value);

Remarks

See Also

Volume Class
InSite.Domain.FedExRateService Namespace


Value Property

[image]

.NET Framework Class Library
Volume..::.Value Property
Volume Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Decimal
C#
public decimal Value { get; set; }
Visual C++
public:
property Decimal Value {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Volume Class
InSite.Domain.FedExRateService Namespace


ValueSpecified Property

[image]

.NET Framework Class Library
Volume..::.ValueSpecified Property
Volume Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ValueSpecified As Boolean
C#
public bool ValueSpecified { get; set; }
Visual C++
public:
property bool ValueSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_valueSpecified();
function set_valueSpecified(value);

Remarks

See Also

Volume Class
InSite.Domain.FedExRateService Namespace


VolumeUnits Enumeration

[image]

.NET Framework Class Library
VolumeUnits Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration VolumeUnits
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum VolumeUnits
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class VolumeUnits
JavaScript
InSite.Domain.FedExRateService.VolumeUnits = function();
InSite.Domain.FedExRateService.VolumeUnits.createEnum('InSite.Domain.FedExRateService.VolumeUnits', false);

Members

Member name | Description
CUBIC_FT |
CUBIC_M |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


WebAuthenticationCredential Class

[image]

.NET Framework Class Library
WebAuthenticationCredential Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class WebAuthenticationCredential
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class WebAuthenticationCredential
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class WebAuthenticationCredential
JavaScript
InSite.Domain.FedExRateService.WebAuthenticationCredential = function();

Type.createClass(
    'InSite.Domain.FedExRateService.WebAuthenticationCredential');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.WebAuthenticationCredential

See Also

WebAuthenticationCredential Members
InSite.Domain.FedExRateService Namespace


WebAuthenticationCredential Members

[image] [image]

.NET Framework Class Library
WebAuthenticationCredential Members
WebAuthenticationCredential Class Constructors Methods Properties See Also Send Feedback

The WebAuthenticationCredential type exposes the following members.

Constructors

Name | Description
WebAuthenticationCredential |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Key |
Password |

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRateService Namespace


WebAuthenticationCredential Constructor

[image]

.NET Framework Class Library
WebAuthenticationCredential Constructor
WebAuthenticationCredential Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebAuthenticationCredential()
Visual C++
public:
WebAuthenticationCredential()
JavaScript
InSite.Domain.FedExRateService.WebAuthenticationCredential = function();

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRateService Namespace


WebAuthenticationCredential Methods

[image] [image]

.NET Framework Class Library
WebAuthenticationCredential Methods
WebAuthenticationCredential Class See Also Send Feedback

The WebAuthenticationCredential type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRateService Namespace


WebAuthenticationCredential Properties

[image] [image]

.NET Framework Class Library
WebAuthenticationCredential Properties
WebAuthenticationCredential Class See Also Send Feedback

The WebAuthenticationCredential type exposes the following members.

Properties

Name | Description
Key |
Password |

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRateService Namespace


Key Property

[image]

.NET Framework Class Library
WebAuthenticationCredential..::.Key Property
WebAuthenticationCredential Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key { get; set; }
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_key();
function set_key(value);

Remarks

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRateService Namespace


Password Property

[image]

.NET Framework Class Library
WebAuthenticationCredential..::.Password Property
WebAuthenticationCredential Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_password();
function set_password(value);

Remarks

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRateService Namespace


WebAuthenticationDetail Class

[image]

.NET Framework Class Library
WebAuthenticationDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class WebAuthenticationDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class WebAuthenticationDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class WebAuthenticationDetail
JavaScript
InSite.Domain.FedExRateService.WebAuthenticationDetail = function();

Type.createClass(
    'InSite.Domain.FedExRateService.WebAuthenticationDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.WebAuthenticationDetail

See Also

WebAuthenticationDetail Members
InSite.Domain.FedExRateService Namespace


WebAuthenticationDetail Members

[image] [image]

.NET Framework Class Library
WebAuthenticationDetail Members
WebAuthenticationDetail Class Constructors Methods Properties See Also Send Feedback

The WebAuthenticationDetail type exposes the following members.

Constructors

Name | Description
WebAuthenticationDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CspCredential |
UserCredential |

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRateService Namespace


WebAuthenticationDetail Constructor

[image]

.NET Framework Class Library
WebAuthenticationDetail Constructor
WebAuthenticationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebAuthenticationDetail()
Visual C++
public:
WebAuthenticationDetail()
JavaScript
InSite.Domain.FedExRateService.WebAuthenticationDetail = function();

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRateService Namespace


WebAuthenticationDetail Methods

[image] [image]

.NET Framework Class Library
WebAuthenticationDetail Methods
WebAuthenticationDetail Class See Also Send Feedback

The WebAuthenticationDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRateService Namespace


WebAuthenticationDetail Properties

[image] [image]

.NET Framework Class Library
WebAuthenticationDetail Properties
WebAuthenticationDetail Class See Also Send Feedback

The WebAuthenticationDetail type exposes the following members.

Properties

Name | Description
CspCredential |
UserCredential |

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRateService Namespace


CspCredential Property

[image]

.NET Framework Class Library
WebAuthenticationDetail..::.CspCredential Property
WebAuthenticationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CspCredential As WebAuthenticationCredential
C#
public WebAuthenticationCredential CspCredential { get; set; }
Visual C++
public:
property WebAuthenticationCredential^ CspCredential {
    WebAuthenticationCredential^ get ();
    void set (WebAuthenticationCredential^ value);
}
JavaScript
function get_cspCredential();
function set_cspCredential(value);

Remarks

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRateService Namespace


UserCredential Property

[image]

.NET Framework Class Library
WebAuthenticationDetail..::.UserCredential Property
WebAuthenticationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UserCredential As WebAuthenticationCredential
C#
public WebAuthenticationCredential UserCredential { get; set; }
Visual C++
public:
property WebAuthenticationCredential^ UserCredential {
    WebAuthenticationCredential^ get ();
    void set (WebAuthenticationCredential^ value);
}
JavaScript
function get_userCredential();
function set_userCredential(value);

Remarks

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRateService Namespace


Weight Class

[image]

.NET Framework Class Library
Weight Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Weight
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Weight
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Weight
JavaScript
InSite.Domain.FedExRateService.Weight = function();

Type.createClass(
    'InSite.Domain.FedExRateService.Weight');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRateService..::.Weight

See Also

Weight Members
InSite.Domain.FedExRateService Namespace


Weight Members

[image] [image]

.NET Framework Class Library
Weight Members
Weight Class Constructors Methods Properties See Also Send Feedback

The Weight type exposes the following members.

Constructors

Name | Description
Weight |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Units |
Value |

See Also

Weight Class
InSite.Domain.FedExRateService Namespace


Weight Constructor

[image]

.NET Framework Class Library
Weight Constructor
Weight Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Weight()
Visual C++
public:
Weight()
JavaScript
InSite.Domain.FedExRateService.Weight = function();

See Also

Weight Class
InSite.Domain.FedExRateService Namespace


Weight Methods

[image] [image]

.NET Framework Class Library
Weight Methods
Weight Class See Also Send Feedback

The Weight type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Weight Class
InSite.Domain.FedExRateService Namespace


Weight Properties

[image] [image]

.NET Framework Class Library
Weight Properties
Weight Class See Also Send Feedback

The Weight type exposes the following members.

Properties

Name | Description
Units |
Value |

See Also

Weight Class
InSite.Domain.FedExRateService Namespace


Units Property

[image]

.NET Framework Class Library
Weight..::.Units Property
Weight Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Units As WeightUnits
C#
public WeightUnits Units { get; set; }
Visual C++
public:
property WeightUnits Units {
    WeightUnits get ();
    void set (WeightUnits value);
}
JavaScript
function get_units();
function set_units(value);

Remarks

See Also

Weight Class
InSite.Domain.FedExRateService Namespace


Value Property

[image]

.NET Framework Class Library
Weight..::.Value Property
Weight Class See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As Decimal
C#
public decimal Value { get; set; }
Visual C++
public:
property Decimal Value {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

Weight Class
InSite.Domain.FedExRateService Namespace


WeightUnits Enumeration

[image]

.NET Framework Class Library
WeightUnits Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRateService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration WeightUnits
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum WeightUnits
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class WeightUnits
JavaScript
InSite.Domain.FedExRateService.WeightUnits = function();
InSite.Domain.FedExRateService.WeightUnits.createEnum('InSite.Domain.FedExRateService.WeightUnits', false);

Members

Member name | Description
KG |
LB |

Remarks

See Also

InSite.Domain.FedExRateService Namespace


InSite.Domain.FedExRegistrationService Namespace

[image]

.NET Framework Class Library
InSite.Domain.FedExRegistrationService Namespace
Send Feedback

Classes

Class | Description
Address |
ClientDetail |
Contact |
Localization |
Notification |
NotificationParameter |
ParsedContact |
ParsedContactAndAddress |
ParsedPersonName |
Party |
registerWebCSPUserCompletedEventArgs |
RegisterWebCspUserReply |
RegisterWebCspUserRequest |
RegistrationService |
subscriptionCompletedEventArgs |
SubscriptionReply |
SubscriptionRequest |
TransactionDetail |
versionCaptureCompletedEventArgs |
VersionCaptureReply |
VersionCaptureRequest |
VersionId |
WebAuthenticationCredential |
WebAuthenticationDetail |

Delegates

Delegate | Description
registerWebCSPUserCompletedEventHandler |
subscriptionCompletedEventHandler |
versionCaptureCompletedEventHandler |

Enumerations

Enumeration | Description
CspType |
ExpressRegionCode |
NotificationSeverityType |
SubscriptionServiceType |
WebServiceCategoryType |


Address Class

[image]

.NET Framework Class Library
Address Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Address
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Address
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Address
JavaScript
InSite.Domain.FedExRegistrationService.Address = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.Address');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.Address

See Also

Address Members
InSite.Domain.FedExRegistrationService Namespace


Address Members

[image] [image]

.NET Framework Class Library
Address Members
Address Class Constructors Methods Properties See Also Send Feedback

The Address type exposes the following members.

Constructors

Name | Description
Address |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
City |
CountryCode |
PostalCode |
StateOrProvinceCode |
StreetLines |

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


Address Constructor

[image]

.NET Framework Class Library
Address Constructor
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Address()
Visual C++
public:
Address()
JavaScript
InSite.Domain.FedExRegistrationService.Address = function();

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


Address Methods

[image] [image]

.NET Framework Class Library
Address Methods
Address Class See Also Send Feedback

The Address type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


Address Properties

[image] [image]

.NET Framework Class Library
Address Properties
Address Class See Also Send Feedback

The Address type exposes the following members.

Properties

Name | Description
City |
CountryCode |
PostalCode |
StateOrProvinceCode |
StreetLines |

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


City Property

[image]

.NET Framework Class Library
Address..::.City Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property City As String
C#
public string City { get; set; }
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


CountryCode Property

[image]

.NET Framework Class Library
Address..::.CountryCode Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CountryCode As String
C#
public string CountryCode { get; set; }
Visual C++
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_countryCode();
function set_countryCode(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


PostalCode Property

[image]

.NET Framework Class Library
Address..::.PostalCode Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PostalCode As String
C#
public string PostalCode { get; set; }
Visual C++
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_postalCode();
function set_postalCode(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


StateOrProvinceCode Property

[image]

.NET Framework Class Library
Address..::.StateOrProvinceCode Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property StateOrProvinceCode As String
C#
public string StateOrProvinceCode { get; set; }
Visual C++
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stateOrProvinceCode();
function set_stateOrProvinceCode(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


StreetLines Property

[image]

.NET Framework Class Library
Address..::.StreetLines Property
Address Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property StreetLines As String()
C#
public string[] StreetLines { get; set; }
Visual C++
public:
property array<String^>^ StreetLines {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_streetLines();
function set_streetLines(value);

Remarks

See Also

Address Class
InSite.Domain.FedExRegistrationService Namespace


ClientDetail Class

[image]

.NET Framework Class Library
ClientDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ClientDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ClientDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ClientDetail
JavaScript
InSite.Domain.FedExRegistrationService.ClientDetail = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.ClientDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.ClientDetail

See Also

ClientDetail Members
InSite.Domain.FedExRegistrationService Namespace


ClientDetail Members

[image] [image]

.NET Framework Class Library
ClientDetail Members
ClientDetail Class Constructors Methods Properties See Also Send Feedback

The ClientDetail type exposes the following members.

Constructors

Name | Description
ClientDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccountNumber |
ClientProductId |
ClientProductVersion |
IntegratorId |
Localization |
MeterNumber |
Region |
RegionSpecified |

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


ClientDetail Constructor

[image]

.NET Framework Class Library
ClientDetail Constructor
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ClientDetail()
Visual C++
public:
ClientDetail()
JavaScript
InSite.Domain.FedExRegistrationService.ClientDetail = function();

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


ClientDetail Methods

[image] [image]

.NET Framework Class Library
ClientDetail Methods
ClientDetail Class See Also Send Feedback

The ClientDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


ClientDetail Properties

[image] [image]

.NET Framework Class Library
ClientDetail Properties
ClientDetail Class See Also Send Feedback

The ClientDetail type exposes the following members.

Properties

Name | Description
AccountNumber |
ClientProductId |
ClientProductVersion |
IntegratorId |
Localization |
MeterNumber |
Region |
RegionSpecified |

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


AccountNumber Property

[image]

.NET Framework Class Library
ClientDetail..::.AccountNumber Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AccountNumber As String
C#
public string AccountNumber { get; set; }
Visual C++
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


ClientProductId Property

[image]

.NET Framework Class Library
ClientDetail..::.ClientProductId Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientProductId As String
C#
public string ClientProductId { get; set; }
Visual C++
public:
property String^ ClientProductId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientProductId();
function set_clientProductId(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


ClientProductVersion Property

[image]

.NET Framework Class Library
ClientDetail..::.ClientProductVersion Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientProductVersion As String
C#
public string ClientProductVersion { get; set; }
Visual C++
public:
property String^ ClientProductVersion {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_clientProductVersion();
function set_clientProductVersion(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


IntegratorId Property

[image]

.NET Framework Class Library
ClientDetail..::.IntegratorId Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IntegratorId As String
C#
public string IntegratorId { get; set; }
Visual C++
public:
property String^ IntegratorId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_integratorId();
function set_integratorId(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


Localization Property

[image]

.NET Framework Class Library
ClientDetail..::.Localization Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Localization As Localization
C#
public Localization Localization { get; set; }
Visual C++
public:
property Localization^ Localization {
    Localization^ get ();
    void set (Localization^ value);
}
JavaScript
function get_localization();
function set_localization(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


MeterNumber Property

[image]

.NET Framework Class Library
ClientDetail..::.MeterNumber Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MeterNumber As String
C#
public string MeterNumber { get; set; }
Visual C++
public:
property String^ MeterNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_meterNumber();
function set_meterNumber(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


Region Property

[image]

.NET Framework Class Library
ClientDetail..::.Region Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Region As ExpressRegionCode
C#
public ExpressRegionCode Region { get; set; }
Visual C++
public:
property ExpressRegionCode Region {
    ExpressRegionCode get ();
    void set (ExpressRegionCode value);
}
JavaScript
function get_region();
function set_region(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


RegionSpecified Property

[image]

.NET Framework Class Library
ClientDetail..::.RegionSpecified Property
ClientDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RegionSpecified As Boolean
C#
public bool RegionSpecified { get; set; }
Visual C++
public:
property bool RegionSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_regionSpecified();
function set_regionSpecified(value);

Remarks

See Also

ClientDetail Class
InSite.Domain.FedExRegistrationService Namespace


Contact Class

[image]

.NET Framework Class Library
Contact Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Contact
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Contact
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Contact
JavaScript
InSite.Domain.FedExRegistrationService.Contact = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.Contact');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.Contact

See Also

Contact Members
InSite.Domain.FedExRegistrationService Namespace


Contact Members

[image] [image]

.NET Framework Class Library
Contact Members
Contact Class Constructors Methods Properties See Also Send Feedback

The Contact type exposes the following members.

Constructors

Name | Description
Contact |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompanyName |
EMailAddress |
FaxNumber |
PagerNumber |
PersonName |
PhoneNumber |

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


Contact Constructor

[image]

.NET Framework Class Library
Contact Constructor
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Contact()
Visual C++
public:
Contact()
JavaScript
InSite.Domain.FedExRegistrationService.Contact = function();

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


Contact Methods

[image] [image]

.NET Framework Class Library
Contact Methods
Contact Class See Also Send Feedback

The Contact type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


Contact Properties

[image] [image]

.NET Framework Class Library
Contact Properties
Contact Class See Also Send Feedback

The Contact type exposes the following members.

Properties

Name | Description
CompanyName |
EMailAddress |
FaxNumber |
PagerNumber |
PersonName |
PhoneNumber |

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


CompanyName Property

[image]

.NET Framework Class Library
Contact..::.CompanyName Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CompanyName As String
C#
public string CompanyName { get; set; }
Visual C++
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_companyName();
function set_companyName(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


EMailAddress Property

[image]

.NET Framework Class Library
Contact..::.EMailAddress Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EMailAddress As String
C#
public string EMailAddress { get; set; }
Visual C++
public:
property String^ EMailAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_eMailAddress();
function set_eMailAddress(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


FaxNumber Property

[image]

.NET Framework Class Library
Contact..::.FaxNumber Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FaxNumber As String
C#
public string FaxNumber { get; set; }
Visual C++
public:
property String^ FaxNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_faxNumber();
function set_faxNumber(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


PagerNumber Property

[image]

.NET Framework Class Library
Contact..::.PagerNumber Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PagerNumber As String
C#
public string PagerNumber { get; set; }
Visual C++
public:
property String^ PagerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pagerNumber();
function set_pagerNumber(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


PersonName Property

[image]

.NET Framework Class Library
Contact..::.PersonName Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PersonName As String
C#
public string PersonName { get; set; }
Visual C++
public:
property String^ PersonName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_personName();
function set_personName(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


PhoneNumber Property

[image]

.NET Framework Class Library
Contact..::.PhoneNumber Property
Contact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PhoneNumber As String
C#
public string PhoneNumber { get; set; }
Visual C++
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

Contact Class
InSite.Domain.FedExRegistrationService Namespace


CspType Enumeration

[image]

.NET Framework Class Library
CspType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration CspType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum CspType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class CspType
JavaScript
InSite.Domain.FedExRegistrationService.CspType = function();
InSite.Domain.FedExRegistrationService.CspType.createEnum('InSite.Domain.FedExRegistrationService.CspType', false);

Members

Member name | Description
CERTIFIED_SOLUTION_PROVIDER |
TRADITIONAL_API |

Remarks

See Also

InSite.Domain.FedExRegistrationService Namespace


ExpressRegionCode Enumeration

[image]

.NET Framework Class Library
ExpressRegionCode Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration ExpressRegionCode
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum ExpressRegionCode
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class ExpressRegionCode
JavaScript
InSite.Domain.FedExRegistrationService.ExpressRegionCode = function();
InSite.Domain.FedExRegistrationService.ExpressRegionCode.createEnum('InSite.Domain.FedExRegistrationService.ExpressRegionCode', false);

Members

Member name | Description
APAC |
CA |
EMEA |
LAC |
US |

Remarks

See Also

InSite.Domain.FedExRegistrationService Namespace


Localization Class

[image]

.NET Framework Class Library
Localization Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Localization
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Localization
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Localization
JavaScript
InSite.Domain.FedExRegistrationService.Localization = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.Localization');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.Localization

See Also

Localization Members
InSite.Domain.FedExRegistrationService Namespace


Localization Members

[image] [image]

.NET Framework Class Library
Localization Members
Localization Class Constructors Methods Properties See Also Send Feedback

The Localization type exposes the following members.

Constructors

Name | Description
Localization |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LanguageCode |
LocaleCode |

See Also

Localization Class
InSite.Domain.FedExRegistrationService Namespace


Localization Constructor

[image]

.NET Framework Class Library
Localization Constructor
Localization Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Localization()
Visual C++
public:
Localization()
JavaScript
InSite.Domain.FedExRegistrationService.Localization = function();

See Also

Localization Class
InSite.Domain.FedExRegistrationService Namespace


Localization Methods

[image] [image]

.NET Framework Class Library
Localization Methods
Localization Class See Also Send Feedback

The Localization type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Localization Class
InSite.Domain.FedExRegistrationService Namespace


Localization Properties

[image] [image]

.NET Framework Class Library
Localization Properties
Localization Class See Also Send Feedback

The Localization type exposes the following members.

Properties

Name | Description
LanguageCode |
LocaleCode |

See Also

Localization Class
InSite.Domain.FedExRegistrationService Namespace


LanguageCode Property

[image]

.NET Framework Class Library
Localization..::.LanguageCode Property
Localization Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LanguageCode As String
C#
public string LanguageCode { get; set; }
Visual C++
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_languageCode();
function set_languageCode(value);

Remarks

See Also

Localization Class
InSite.Domain.FedExRegistrationService Namespace


LocaleCode Property

[image]

.NET Framework Class Library
Localization..::.LocaleCode Property
Localization Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocaleCode As String
C#
public string LocaleCode { get; set; }
Visual C++
public:
property String^ LocaleCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_localeCode();
function set_localeCode(value);

Remarks

See Also

Localization Class
InSite.Domain.FedExRegistrationService Namespace


Notification Class

[image]

.NET Framework Class Library
Notification Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Notification
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Notification
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Notification
JavaScript
InSite.Domain.FedExRegistrationService.Notification = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.Notification');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.Notification

See Also

Notification Members
InSite.Domain.FedExRegistrationService Namespace


Notification Members

[image] [image]

.NET Framework Class Library
Notification Members
Notification Class Constructors Methods Properties See Also Send Feedback

The Notification type exposes the following members.

Constructors

Name | Description
Notification |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Code |
LocalizedMessage |
Message |
MessageParameters |
Severity |
SeveritySpecified |
Source |

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


Notification Constructor

[image]

.NET Framework Class Library
Notification Constructor
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Notification()
Visual C++
public:
Notification()
JavaScript
InSite.Domain.FedExRegistrationService.Notification = function();

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


Notification Methods

[image] [image]

.NET Framework Class Library
Notification Methods
Notification Class See Also Send Feedback

The Notification type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


Notification Properties

[image] [image]

.NET Framework Class Library
Notification Properties
Notification Class See Also Send Feedback

The Notification type exposes the following members.

Properties

Name | Description
Code |
LocalizedMessage |
Message |
MessageParameters |
Severity |
SeveritySpecified |
Source |

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


Code Property

[image]

.NET Framework Class Library
Notification..::.Code Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Code As String
C#
public string Code { get; set; }
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_code();
function set_code(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


LocalizedMessage Property

[image]

.NET Framework Class Library
Notification..::.LocalizedMessage Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LocalizedMessage As String
C#
public string LocalizedMessage { get; set; }
Visual C++
public:
property String^ LocalizedMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_localizedMessage();
function set_localizedMessage(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


Message Property

[image]

.NET Framework Class Library
Notification..::.Message Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Message As String
C#
public string Message { get; set; }
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_message();
function set_message(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


MessageParameters Property

[image]

.NET Framework Class Library
Notification..::.MessageParameters Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageParameters As NotificationParameter()
C#
public NotificationParameter[] MessageParameters { get; set; }
Visual C++
public:
property array<NotificationParameter^>^ MessageParameters {
    array<NotificationParameter^>^ get ();
    void set (array<NotificationParameter^>^ value);
}
JavaScript
function get_messageParameters();
function set_messageParameters(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


Severity Property

[image]

.NET Framework Class Library
Notification..::.Severity Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Severity As NotificationSeverityType
C#
public NotificationSeverityType Severity { get; set; }
Visual C++
public:
property NotificationSeverityType Severity {
    NotificationSeverityType get ();
    void set (NotificationSeverityType value);
}
JavaScript
function get_severity();
function set_severity(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


SeveritySpecified Property

[image]

.NET Framework Class Library
Notification..::.SeveritySpecified Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SeveritySpecified As Boolean
C#
public bool SeveritySpecified { get; set; }
Visual C++
public:
property bool SeveritySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_severitySpecified();
function set_severitySpecified(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


Source Property

[image]

.NET Framework Class Library
Notification..::.Source Property
Notification Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Source As String
C#
public string Source { get; set; }
Visual C++
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_source();
function set_source(value);

Remarks

See Also

Notification Class
InSite.Domain.FedExRegistrationService Namespace


NotificationParameter Class

[image]

.NET Framework Class Library
NotificationParameter Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class NotificationParameter
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class NotificationParameter
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class NotificationParameter
JavaScript
InSite.Domain.FedExRegistrationService.NotificationParameter = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.NotificationParameter');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.NotificationParameter

See Also

NotificationParameter Members
InSite.Domain.FedExRegistrationService Namespace


NotificationParameter Members

[image] [image]

.NET Framework Class Library
NotificationParameter Members
NotificationParameter Class Constructors Methods Properties See Also Send Feedback

The NotificationParameter type exposes the following members.

Constructors

Name | Description
NotificationParameter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Value |

See Also

NotificationParameter Class
InSite.Domain.FedExRegistrationService Namespace


NotificationParameter Constructor

[image]

.NET Framework Class Library
NotificationParameter Constructor
NotificationParameter Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NotificationParameter()
Visual C++
public:
NotificationParameter()
JavaScript
InSite.Domain.FedExRegistrationService.NotificationParameter = function();

See Also

NotificationParameter Class
InSite.Domain.FedExRegistrationService Namespace


NotificationParameter Methods

[image] [image]

.NET Framework Class Library
NotificationParameter Methods
NotificationParameter Class See Also Send Feedback

The NotificationParameter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationParameter Class
InSite.Domain.FedExRegistrationService Namespace


NotificationParameter Properties

[image] [image]

.NET Framework Class Library
NotificationParameter Properties
NotificationParameter Class See Also Send Feedback

The NotificationParameter type exposes the following members.

Properties

Name | Description
Id |
Value |

See Also

NotificationParameter Class
InSite.Domain.FedExRegistrationService Namespace


Id Property

[image]

.NET Framework Class Library
NotificationParameter..::.Id Property
NotificationParameter Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Id As String
C#
public string Id { get; set; }
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_id();
function set_id(value);

Remarks

See Also

NotificationParameter Class
InSite.Domain.FedExRegistrationService Namespace


Value Property

[image]

.NET Framework Class Library
NotificationParameter..::.Value Property
NotificationParameter Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Value As String
C#
public string Value { get; set; }
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

Remarks

See Also

NotificationParameter Class
InSite.Domain.FedExRegistrationService Namespace


NotificationSeverityType Enumeration

[image]

.NET Framework Class Library
NotificationSeverityType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration NotificationSeverityType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum NotificationSeverityType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class NotificationSeverityType
JavaScript
InSite.Domain.FedExRegistrationService.NotificationSeverityType = function();
InSite.Domain.FedExRegistrationService.NotificationSeverityType.createEnum('InSite.Domain.FedExRegistrationService.NotificationSeverityType', false);

Members

Member name | Description
ERROR |
FAILURE |
NOTE |
SUCCESS |
WARNING |

Remarks

See Also

InSite.Domain.FedExRegistrationService Namespace


ParsedContact Class

[image]

.NET Framework Class Library
ParsedContact Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ParsedContact
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ParsedContact
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ParsedContact
JavaScript
InSite.Domain.FedExRegistrationService.ParsedContact = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.ParsedContact');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.ParsedContact

See Also

ParsedContact Members
InSite.Domain.FedExRegistrationService Namespace


ParsedContact Members

[image] [image]

.NET Framework Class Library
ParsedContact Members
ParsedContact Class Constructors Methods Properties See Also Send Feedback

The ParsedContact type exposes the following members.

Constructors

Name | Description
ParsedContact |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CompanyName |
Department |
EMailAddress |
FaxNumber |
PagerNumber |
PersonName |
PhoneNumber |
Title |

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


ParsedContact Constructor

[image]

.NET Framework Class Library
ParsedContact Constructor
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ParsedContact()
Visual C++
public:
ParsedContact()
JavaScript
InSite.Domain.FedExRegistrationService.ParsedContact = function();

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


ParsedContact Methods

[image] [image]

.NET Framework Class Library
ParsedContact Methods
ParsedContact Class See Also Send Feedback

The ParsedContact type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


ParsedContact Properties

[image] [image]

.NET Framework Class Library
ParsedContact Properties
ParsedContact Class See Also Send Feedback

The ParsedContact type exposes the following members.

Properties

Name | Description
CompanyName |
Department |
EMailAddress |
FaxNumber |
PagerNumber |
PersonName |
PhoneNumber |
Title |

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


CompanyName Property

[image]

.NET Framework Class Library
ParsedContact..::.CompanyName Property
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CompanyName As String
C#
public string CompanyName { get; set; }
Visual C++
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_companyName();
function set_companyName(value);

Remarks

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


Department Property

[image]

.NET Framework Class Library
ParsedContact..::.Department Property
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Department As String
C#
public string Department { get; set; }
Visual C++
public:
property String^ Department {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_department();
function set_department(value);

Remarks

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


EMailAddress Property

[image]

.NET Framework Class Library
ParsedContact..::.EMailAddress Property
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EMailAddress As String
C#
public string EMailAddress { get; set; }
Visual C++
public:
property String^ EMailAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_eMailAddress();
function set_eMailAddress(value);

Remarks

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


FaxNumber Property

[image]

.NET Framework Class Library
ParsedContact..::.FaxNumber Property
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FaxNumber As String
C#
public string FaxNumber { get; set; }
Visual C++
public:
property String^ FaxNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_faxNumber();
function set_faxNumber(value);

Remarks

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


PagerNumber Property

[image]

.NET Framework Class Library
ParsedContact..::.PagerNumber Property
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PagerNumber As String
C#
public string PagerNumber { get; set; }
Visual C++
public:
property String^ PagerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pagerNumber();
function set_pagerNumber(value);

Remarks

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


PersonName Property

[image]

.NET Framework Class Library
ParsedContact..::.PersonName Property
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PersonName As ParsedPersonName
C#
public ParsedPersonName PersonName { get; set; }
Visual C++
public:
property ParsedPersonName^ PersonName {
    ParsedPersonName^ get ();
    void set (ParsedPersonName^ value);
}
JavaScript
function get_personName();
function set_personName(value);

Remarks

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


PhoneNumber Property

[image]

.NET Framework Class Library
ParsedContact..::.PhoneNumber Property
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PhoneNumber As String
C#
public string PhoneNumber { get; set; }
Visual C++
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phoneNumber();
function set_phoneNumber(value);

Remarks

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


Title Property

[image]

.NET Framework Class Library
ParsedContact..::.Title Property
ParsedContact Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Title As String
C#
public string Title { get; set; }
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

Remarks

See Also

ParsedContact Class
InSite.Domain.FedExRegistrationService Namespace


ParsedContactAndAddress Class

[image]

.NET Framework Class Library
ParsedContactAndAddress Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ParsedContactAndAddress
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ParsedContactAndAddress
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ParsedContactAndAddress
JavaScript
InSite.Domain.FedExRegistrationService.ParsedContactAndAddress = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.ParsedContactAndAddress');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.ParsedContactAndAddress

See Also

ParsedContactAndAddress Members
InSite.Domain.FedExRegistrationService Namespace


ParsedContactAndAddress Members

[image] [image]

.NET Framework Class Library
ParsedContactAndAddress Members
ParsedContactAndAddress Class Constructors Methods Properties See Also Send Feedback

The ParsedContactAndAddress type exposes the following members.

Constructors

Name | Description
ParsedContactAndAddress |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address |
Contact |

See Also

ParsedContactAndAddress Class
InSite.Domain.FedExRegistrationService Namespace


ParsedContactAndAddress Constructor

[image]

.NET Framework Class Library
ParsedContactAndAddress Constructor
ParsedContactAndAddress Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ParsedContactAndAddress()
Visual C++
public:
ParsedContactAndAddress()
JavaScript
InSite.Domain.FedExRegistrationService.ParsedContactAndAddress = function();

See Also

ParsedContactAndAddress Class
InSite.Domain.FedExRegistrationService Namespace


ParsedContactAndAddress Methods

[image] [image]

.NET Framework Class Library
ParsedContactAndAddress Methods
ParsedContactAndAddress Class See Also Send Feedback

The ParsedContactAndAddress type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParsedContactAndAddress Class
InSite.Domain.FedExRegistrationService Namespace


ParsedContactAndAddress Properties

[image] [image]

.NET Framework Class Library
ParsedContactAndAddress Properties
ParsedContactAndAddress Class See Also Send Feedback

The ParsedContactAndAddress type exposes the following members.

Properties

Name | Description
Address |
Contact |

See Also

ParsedContactAndAddress Class
InSite.Domain.FedExRegistrationService Namespace


Address Property

[image]

.NET Framework Class Library
ParsedContactAndAddress..::.Address Property
ParsedContactAndAddress Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As Address
C#
public Address Address { get; set; }
Visual C++
public:
property Address^ Address {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

ParsedContactAndAddress Class
InSite.Domain.FedExRegistrationService Namespace


Contact Property

[image]

.NET Framework Class Library
ParsedContactAndAddress..::.Contact Property
ParsedContactAndAddress Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Contact As ParsedContact
C#
public ParsedContact Contact { get; set; }
Visual C++
public:
property ParsedContact^ Contact {
    ParsedContact^ get ();
    void set (ParsedContact^ value);
}
JavaScript
function get_contact();
function set_contact(value);

Remarks

See Also

ParsedContactAndAddress Class
InSite.Domain.FedExRegistrationService Namespace


ParsedPersonName Class

[image]

.NET Framework Class Library
ParsedPersonName Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class ParsedPersonName
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class ParsedPersonName
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class ParsedPersonName
JavaScript
InSite.Domain.FedExRegistrationService.ParsedPersonName = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.ParsedPersonName');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.ParsedPersonName

See Also

ParsedPersonName Members
InSite.Domain.FedExRegistrationService Namespace


ParsedPersonName Members

[image] [image]

.NET Framework Class Library
ParsedPersonName Members
ParsedPersonName Class Constructors Methods Properties See Also Send Feedback

The ParsedPersonName type exposes the following members.

Constructors

Name | Description
ParsedPersonName |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FirstName |
LastName |

See Also

ParsedPersonName Class
InSite.Domain.FedExRegistrationService Namespace


ParsedPersonName Constructor

[image]

.NET Framework Class Library
ParsedPersonName Constructor
ParsedPersonName Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ParsedPersonName()
Visual C++
public:
ParsedPersonName()
JavaScript
InSite.Domain.FedExRegistrationService.ParsedPersonName = function();

See Also

ParsedPersonName Class
InSite.Domain.FedExRegistrationService Namespace


ParsedPersonName Methods

[image] [image]

.NET Framework Class Library
ParsedPersonName Methods
ParsedPersonName Class See Also Send Feedback

The ParsedPersonName type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParsedPersonName Class
InSite.Domain.FedExRegistrationService Namespace


ParsedPersonName Properties

[image] [image]

.NET Framework Class Library
ParsedPersonName Properties
ParsedPersonName Class See Also Send Feedback

The ParsedPersonName type exposes the following members.

Properties

Name | Description
FirstName |
LastName |

See Also

ParsedPersonName Class
InSite.Domain.FedExRegistrationService Namespace


FirstName Property

[image]

.NET Framework Class Library
ParsedPersonName..::.FirstName Property
ParsedPersonName Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FirstName As String
C#
public string FirstName { get; set; }
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

Remarks

See Also

ParsedPersonName Class
InSite.Domain.FedExRegistrationService Namespace


LastName Property

[image]

.NET Framework Class Library
ParsedPersonName..::.LastName Property
ParsedPersonName Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property LastName As String
C#
public string LastName { get; set; }
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

Remarks

See Also

ParsedPersonName Class
InSite.Domain.FedExRegistrationService Namespace


Party Class

[image]

.NET Framework Class Library
Party Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class Party
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class Party
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class Party
JavaScript
InSite.Domain.FedExRegistrationService.Party = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.Party');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.Party

See Also

Party Members
InSite.Domain.FedExRegistrationService Namespace


Party Members

[image] [image]

.NET Framework Class Library
Party Members
Party Class Constructors Methods Properties See Also Send Feedback

The Party type exposes the following members.

Constructors

Name | Description
Party |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccountNumber |
Address |
Contact |

See Also

Party Class
InSite.Domain.FedExRegistrationService Namespace


Party Constructor

[image]

.NET Framework Class Library
Party Constructor
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Party()
Visual C++
public:
Party()
JavaScript
InSite.Domain.FedExRegistrationService.Party = function();

See Also

Party Class
InSite.Domain.FedExRegistrationService Namespace


Party Methods

[image] [image]

.NET Framework Class Library
Party Methods
Party Class See Also Send Feedback

The Party type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Party Class
InSite.Domain.FedExRegistrationService Namespace


Party Properties

[image] [image]

.NET Framework Class Library
Party Properties
Party Class See Also Send Feedback

The Party type exposes the following members.

Properties

Name | Description
AccountNumber |
Address |
Contact |

See Also

Party Class
InSite.Domain.FedExRegistrationService Namespace


AccountNumber Property

[image]

.NET Framework Class Library
Party..::.AccountNumber Property
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AccountNumber As String
C#
public string AccountNumber { get; set; }
Visual C++
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

Remarks

See Also

Party Class
InSite.Domain.FedExRegistrationService Namespace


Address Property

[image]

.NET Framework Class Library
Party..::.Address Property
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Address As Address
C#
public Address Address { get; set; }
Visual C++
public:
property Address^ Address {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_address();
function set_address(value);

Remarks

See Also

Party Class
InSite.Domain.FedExRegistrationService Namespace


Contact Property

[image]

.NET Framework Class Library
Party..::.Contact Property
Party Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Contact As Contact
C#
public Contact Contact { get; set; }
Visual C++
public:
property Contact^ Contact {
    Contact^ get ();
    void set (Contact^ value);
}
JavaScript
function get_contact();
function set_contact(value);

Remarks

See Also

Party Class
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserCompletedEventArgs Class

[image]

.NET Framework Class Library
registerWebCSPUserCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Class registerWebCSPUserCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public class registerWebCSPUserCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public ref class registerWebCSPUserCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.FedExRegistrationService.registerWebCSPUserCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.registerWebCSPUserCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.FedExRegistrationService..::.registerWebCSPUserCompletedEventArgs

See Also

registerWebCSPUserCompletedEventArgs Members
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
registerWebCSPUserCompletedEventArgs Members
registerWebCSPUserCompletedEventArgs Class Methods Properties See Also Send Feedback

The registerWebCSPUserCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

registerWebCSPUserCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
registerWebCSPUserCompletedEventArgs Methods
registerWebCSPUserCompletedEventArgs Class See Also Send Feedback

The registerWebCSPUserCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

registerWebCSPUserCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
registerWebCSPUserCompletedEventArgs Properties
registerWebCSPUserCompletedEventArgs Class See Also Send Feedback

The registerWebCSPUserCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

registerWebCSPUserCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


Result Property

[image]

.NET Framework Class Library
registerWebCSPUserCompletedEventArgs..::.Result Property
registerWebCSPUserCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As RegisterWebCspUserReply
C#
public RegisterWebCspUserReply Result { get; }
Visual C++
public:
property RegisterWebCspUserReply^ Result {
    RegisterWebCspUserReply^ get ();
}
JavaScript
function get_result();

Remarks

See Also

registerWebCSPUserCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserCompletedEventHandler Delegate

[image]

.NET Framework Class Library
registerWebCSPUserCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Delegate Sub registerWebCSPUserCompletedEventHandler ( _
    sender As Object, _
    e As registerWebCSPUserCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public delegate void registerWebCSPUserCompletedEventHandler(
    Object sender,
    registerWebCSPUserCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public delegate void registerWebCSPUserCompletedEventHandler(
    Object^ sender,
    registerWebCSPUserCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.FedExRegistrationService..::.registerWebCSPUserCompletedEventArgs

Remarks

See Also

InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserReply Class

[image]

.NET Framework Class Library
RegisterWebCspUserReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RegisterWebCspUserReply
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RegisterWebCspUserReply
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RegisterWebCspUserReply
JavaScript
InSite.Domain.FedExRegistrationService.RegisterWebCspUserReply = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.RegisterWebCspUserReply');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.RegisterWebCspUserReply

See Also

RegisterWebCspUserReply Members
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserReply Members

[image] [image]

.NET Framework Class Library
RegisterWebCspUserReply Members
RegisterWebCspUserReply Class Constructors Methods Properties See Also Send Feedback

The RegisterWebCspUserReply type exposes the following members.

Constructors

Name | Description
RegisterWebCspUserReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Credential |
HighestSeverity |
HighestSeveritySpecified |
Notifications |
TransactionDetail |
Version |

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserReply Constructor

[image]

.NET Framework Class Library
RegisterWebCspUserReply Constructor
RegisterWebCspUserReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegisterWebCspUserReply()
Visual C++
public:
RegisterWebCspUserReply()
JavaScript
InSite.Domain.FedExRegistrationService.RegisterWebCspUserReply = function();

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserReply Methods

[image] [image]

.NET Framework Class Library
RegisterWebCspUserReply Methods
RegisterWebCspUserReply Class See Also Send Feedback

The RegisterWebCspUserReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserReply Properties

[image] [image]

.NET Framework Class Library
RegisterWebCspUserReply Properties
RegisterWebCspUserReply Class See Also Send Feedback

The RegisterWebCspUserReply type exposes the following members.

Properties

Name | Description
Credential |
HighestSeverity |
HighestSeveritySpecified |
Notifications |
TransactionDetail |
Version |

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


Credential Property

[image]

.NET Framework Class Library
RegisterWebCspUserReply..::.Credential Property
RegisterWebCspUserReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Credential As WebAuthenticationCredential
C#
public WebAuthenticationCredential Credential { get; set; }
Visual C++
public:
property WebAuthenticationCredential^ Credential {
    WebAuthenticationCredential^ get ();
    void set (WebAuthenticationCredential^ value);
}
JavaScript
function get_credential();
function set_credential(value);

Remarks

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


HighestSeverity Property

[image]

.NET Framework Class Library
RegisterWebCspUserReply..::.HighestSeverity Property
RegisterWebCspUserReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HighestSeverity As NotificationSeverityType
C#
public NotificationSeverityType HighestSeverity { get; set; }
Visual C++
public:
property NotificationSeverityType HighestSeverity {
    NotificationSeverityType get ();
    void set (NotificationSeverityType value);
}
JavaScript
function get_highestSeverity();
function set_highestSeverity(value);

Remarks

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


HighestSeveritySpecified Property

[image]

.NET Framework Class Library
RegisterWebCspUserReply..::.HighestSeveritySpecified Property
RegisterWebCspUserReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HighestSeveritySpecified As Boolean
C#
public bool HighestSeveritySpecified { get; set; }
Visual C++
public:
property bool HighestSeveritySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_highestSeveritySpecified();
function set_highestSeveritySpecified(value);

Remarks

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


Notifications Property

[image]

.NET Framework Class Library
RegisterWebCspUserReply..::.Notifications Property
RegisterWebCspUserReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Notifications As Notification()
C#
public Notification[] Notifications { get; set; }
Visual C++
public:
property array<Notification^>^ Notifications {
    array<Notification^>^ get ();
    void set (array<Notification^>^ value);
}
JavaScript
function get_notifications();
function set_notifications(value);

Remarks

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Property

[image]

.NET Framework Class Library
RegisterWebCspUserReply..::.TransactionDetail Property
RegisterWebCspUserReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionDetail As TransactionDetail
C#
public TransactionDetail TransactionDetail { get; set; }
Visual C++
public:
property TransactionDetail^ TransactionDetail {
    TransactionDetail^ get ();
    void set (TransactionDetail^ value);
}
JavaScript
function get_transactionDetail();
function set_transactionDetail(value);

Remarks

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


Version Property

[image]

.NET Framework Class Library
RegisterWebCspUserReply..::.Version Property
RegisterWebCspUserReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As VersionId
C#
public VersionId Version { get; set; }
Visual C++
public:
property VersionId^ Version {
    VersionId^ get ();
    void set (VersionId^ value);
}
JavaScript
function get_version();
function set_version(value);

Remarks

See Also

RegisterWebCspUserReply Class
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserRequest Class

[image]

.NET Framework Class Library
RegisterWebCspUserRequest Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class RegisterWebCspUserRequest
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class RegisterWebCspUserRequest
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class RegisterWebCspUserRequest
JavaScript
InSite.Domain.FedExRegistrationService.RegisterWebCspUserRequest = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.RegisterWebCspUserRequest');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.RegisterWebCspUserRequest

See Also

RegisterWebCspUserRequest Members
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserRequest Members

[image] [image]

.NET Framework Class Library
RegisterWebCspUserRequest Members
RegisterWebCspUserRequest Class Constructors Methods Properties See Also Send Feedback

The RegisterWebCspUserRequest type exposes the following members.

Constructors

Name | Description
RegisterWebCspUserRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BillingAddress |
Categories |
ClientDetail |
SecondaryEmail |
TransactionDetail |
UserContactAndAddress |
Version |
WebAuthenticationDetail |

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserRequest Constructor

[image]

.NET Framework Class Library
RegisterWebCspUserRequest Constructor
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegisterWebCspUserRequest()
Visual C++
public:
RegisterWebCspUserRequest()
JavaScript
InSite.Domain.FedExRegistrationService.RegisterWebCspUserRequest = function();

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserRequest Methods

[image] [image]

.NET Framework Class Library
RegisterWebCspUserRequest Methods
RegisterWebCspUserRequest Class See Also Send Feedback

The RegisterWebCspUserRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


RegisterWebCspUserRequest Properties

[image] [image]

.NET Framework Class Library
RegisterWebCspUserRequest Properties
RegisterWebCspUserRequest Class See Also Send Feedback

The RegisterWebCspUserRequest type exposes the following members.

Properties

Name | Description
BillingAddress |
Categories |
ClientDetail |
SecondaryEmail |
TransactionDetail |
UserContactAndAddress |
Version |
WebAuthenticationDetail |

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


BillingAddress Property

[image]

.NET Framework Class Library
RegisterWebCspUserRequest..::.BillingAddress Property
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BillingAddress As Address
C#
public Address BillingAddress { get; set; }
Visual C++
public:
property Address^ BillingAddress {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_billingAddress();
function set_billingAddress(value);

Remarks

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


Categories Property

[image]

.NET Framework Class Library
RegisterWebCspUserRequest..::.Categories Property
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Categories As WebServiceCategoryType()
C#
public WebServiceCategoryType[] Categories { get; set; }
Visual C++
public:
property array<WebServiceCategoryType>^ Categories {
    array<WebServiceCategoryType>^ get ();
    void set (array<WebServiceCategoryType>^ value);
}
JavaScript
function get_categories();
function set_categories(value);

Remarks

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


ClientDetail Property

[image]

.NET Framework Class Library
RegisterWebCspUserRequest..::.ClientDetail Property
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientDetail As ClientDetail
C#
public ClientDetail ClientDetail { get; set; }
Visual C++
public:
property ClientDetail^ ClientDetail {
    ClientDetail^ get ();
    void set (ClientDetail^ value);
}
JavaScript
function get_clientDetail();
function set_clientDetail(value);

Remarks

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


SecondaryEmail Property

[image]

.NET Framework Class Library
RegisterWebCspUserRequest..::.SecondaryEmail Property
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property SecondaryEmail As String
C#
public string SecondaryEmail { get; set; }
Visual C++
public:
property String^ SecondaryEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_secondaryEmail();
function set_secondaryEmail(value);

Remarks

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Property

[image]

.NET Framework Class Library
RegisterWebCspUserRequest..::.TransactionDetail Property
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionDetail As TransactionDetail
C#
public TransactionDetail TransactionDetail { get; set; }
Visual C++
public:
property TransactionDetail^ TransactionDetail {
    TransactionDetail^ get ();
    void set (TransactionDetail^ value);
}
JavaScript
function get_transactionDetail();
function set_transactionDetail(value);

Remarks

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


UserContactAndAddress Property

[image]

.NET Framework Class Library
RegisterWebCspUserRequest..::.UserContactAndAddress Property
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UserContactAndAddress As ParsedContactAndAddress
C#
public ParsedContactAndAddress UserContactAndAddress { get; set; }
Visual C++
public:
property ParsedContactAndAddress^ UserContactAndAddress {
    ParsedContactAndAddress^ get ();
    void set (ParsedContactAndAddress^ value);
}
JavaScript
function get_userContactAndAddress();
function set_userContactAndAddress(value);

Remarks

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


Version Property

[image]

.NET Framework Class Library
RegisterWebCspUserRequest..::.Version Property
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As VersionId
C#
public VersionId Version { get; set; }
Visual C++
public:
property VersionId^ Version {
    VersionId^ get ();
    void set (VersionId^ value);
}
JavaScript
function get_version();
function set_version(value);

Remarks

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationDetail Property

[image]

.NET Framework Class Library
RegisterWebCspUserRequest..::.WebAuthenticationDetail Property
RegisterWebCspUserRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property WebAuthenticationDetail As WebAuthenticationDetail
C#
public WebAuthenticationDetail WebAuthenticationDetail { get; set; }
Visual C++
public:
property WebAuthenticationDetail^ WebAuthenticationDetail {
    WebAuthenticationDetail^ get ();
    void set (WebAuthenticationDetail^ value);
}
JavaScript
function get_webAuthenticationDetail();
function set_webAuthenticationDetail(value);

Remarks

See Also

RegisterWebCspUserRequest Class
InSite.Domain.FedExRegistrationService Namespace


RegistrationService Class

[image]

.NET Framework Class Library
RegistrationService Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<WebServiceBindingAttribute(Name := "RegistrationServiceSoapBinding", Namespace := "http://fedex.com/ws/registration/v2")> _
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Class RegistrationService _
    Inherits SoapHttpClientProtocol
C#
[WebServiceBindingAttribute(Name = "RegistrationServiceSoapBinding", Namespace = "http://fedex.com/ws/registration/v2")]
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public class RegistrationService : SoapHttpClientProtocol
Visual C++
[WebServiceBindingAttribute(Name = L"RegistrationServiceSoapBinding", Namespace = L"http://fedex.com/ws/registration/v2")]
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public ref class RegistrationService : public SoapHttpClientProtocol
JavaScript
InSite.Domain.FedExRegistrationService.RegistrationService = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.RegistrationService',
    SoapHttpClientProtocol);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Web.Services.Protocols..::.WebClientProtocol
System.Web.Services.Protocols..::.HttpWebClientProtocol
System.Web.Services.Protocols..::.SoapHttpClientProtocol
InSite.Domain.FedExRegistrationService..::.RegistrationService

See Also

RegistrationService Members
InSite.Domain.FedExRegistrationService Namespace


RegistrationService Members

[image] [image]

.NET Framework Class Library
RegistrationService Members
RegistrationService Class Constructors Methods Properties Events See Also Send Feedback

The RegistrationService type exposes the following members.

Constructors

Name | Description
RegistrationService |

Methods

Name | Description
Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
CancelAsync |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Dispose | Overloaded.
EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
GetWebResponse | Overloaded.
GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
InvokeAsync | Overloaded.
MemberwiseClone | Overloaded.
registerWebCSPUser |
registerWebCSPUserAsync | Overloaded.
subscription |
subscriptionAsync | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
versionCapture |
versionCaptureAsync | Overloaded.

Properties

Name | Description
AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true. (Inherited from HttpWebClientProtocol.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Url |
UseDefaultCredentials |
UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)

Events

Name | Description
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
registerWebCSPUserCompleted |
subscriptionCompleted |
versionCaptureCompleted |

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


RegistrationService Constructor

[image]

.NET Framework Class Library
RegistrationService Constructor
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegistrationService()
Visual C++
public:
RegistrationService()
JavaScript
InSite.Domain.FedExRegistrationService.RegistrationService = function();

Remarks

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


RegistrationService Methods

[image] [image]

.NET Framework Class Library
RegistrationService Methods
RegistrationService Class See Also Send Feedback

The RegistrationService type exposes the following members.

Methods

Name | Description
Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
CancelAsync |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Dispose | Overloaded.
EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
GetWebResponse | Overloaded.
GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
InvokeAsync | Overloaded.
MemberwiseClone | Overloaded.
registerWebCSPUser |
registerWebCSPUserAsync | Overloaded.
subscription |
subscriptionAsync | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
versionCapture |
versionCaptureAsync | Overloaded.

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


CancelAsync Method

[image]

.NET Framework Class Library
RegistrationService..::.CancelAsync Method
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelAsync ( _
    userState As Object _
)
C#
public void CancelAsync(
    Object userState
)
Visual C++
public:
void CancelAsync(
    Object^ userState
)
JavaScript
function cancelAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
RegistrationService..::.Dispose Method
RegistrationService Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

RegistrationService Class
RegistrationService Members
InSite.Domain.FedExRegistrationService Namespace


GetWebResponse Method

[image] [image]

.NET Framework Class Library
RegistrationService..::.GetWebResponse Method
RegistrationService Class See Also Send Feedback

Overload List

Name | Description
GetWebResponse(WebRequest) | Returns a response from a synchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
GetWebResponse(WebRequest, IAsyncResult) | Returns a response from an asynchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)

See Also

RegistrationService Class
RegistrationService Members
InSite.Domain.FedExRegistrationService Namespace


InvokeAsync Method

[image] [image]

.NET Framework Class Library
RegistrationService..::.InvokeAsync Method
RegistrationService Class See Also Send Feedback

Overload List

Name | Description
InvokeAsync(String, array<Object>[]()[], SendOrPostCallback) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
InvokeAsync(String, array<Object>[]()[], SendOrPostCallback, Object) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)

See Also

RegistrationService Class
RegistrationService Members
InSite.Domain.FedExRegistrationService Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
RegistrationService..::.MemberwiseClone Method
RegistrationService Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

RegistrationService Class
RegistrationService Members
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUser Method

[image]

.NET Framework Class Library
RegistrationService..::.registerWebCSPUser Method
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("registerWebCSPUser", Use := SoapBindingUse.Literal,  _
    ParameterStyle := SoapParameterStyle.Bare)> _
Public Function registerWebCSPUser ( _
    RegisterWebCspUserRequest As RegisterWebCspUserRequest _
) As RegisterWebCspUserReply
C#
[SoapDocumentMethodAttribute("registerWebCSPUser", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
public RegisterWebCspUserReply registerWebCSPUser(
    RegisterWebCspUserRequest RegisterWebCspUserRequest
)
Visual C++
[SoapDocumentMethodAttribute(L"registerWebCSPUser", Use = SoapBindingUse::Literal,
    ParameterStyle = SoapParameterStyle::Bare)]
public:
RegisterWebCspUserReply^ registerWebCSPUser(
    RegisterWebCspUserRequest^ RegisterWebCspUserRequest
)
JavaScript
function registerWebCSPUser(RegisterWebCspUserRequest);

Parameters

RegisterWebCspUserRequest
Type: InSite.Domain.FedExRegistrationService..::.RegisterWebCspUserRequest

Remarks

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserAsync Method

[image] [image]

.NET Framework Class Library
RegistrationService..::.registerWebCSPUserAsync Method
RegistrationService Class See Also Send Feedback

Overload List

Name | Description
registerWebCSPUserAsync(RegisterWebCspUserRequest) |
registerWebCSPUserAsync(RegisterWebCspUserRequest, Object) |

See Also

RegistrationService Class
RegistrationService Members
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserAsync Method (RegisterWebCspUserRequest)

[image]

.NET Framework Class Library
RegistrationService..::.registerWebCSPUserAsync Method (RegisterWebCspUserRequest)
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub registerWebCSPUserAsync ( _
    RegisterWebCspUserRequest As RegisterWebCspUserRequest _
)
C#
public void registerWebCSPUserAsync(
    RegisterWebCspUserRequest RegisterWebCspUserRequest
)
Visual C++
public:
void registerWebCSPUserAsync(
    RegisterWebCspUserRequest^ RegisterWebCspUserRequest
)
JavaScript
function registerWebCSPUserAsync(RegisterWebCspUserRequest);

Parameters

RegisterWebCspUserRequest
Type: InSite.Domain.FedExRegistrationService..::.RegisterWebCspUserRequest

Remarks

See Also

RegistrationService Class
registerWebCSPUserAsync Overload
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserAsync Method (RegisterWebCspUserRequest, Object)

[image]

.NET Framework Class Library
RegistrationService..::.registerWebCSPUserAsync Method (RegisterWebCspUserRequest, Object)
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub registerWebCSPUserAsync ( _
    RegisterWebCspUserRequest As RegisterWebCspUserRequest, _
    userState As Object _
)
C#
public void registerWebCSPUserAsync(
    RegisterWebCspUserRequest RegisterWebCspUserRequest,
    Object userState
)
Visual C++
public:
void registerWebCSPUserAsync(
    RegisterWebCspUserRequest^ RegisterWebCspUserRequest,
    Object^ userState
)
JavaScript
function registerWebCSPUserAsync(RegisterWebCspUserRequest, userState);

Parameters

RegisterWebCspUserRequest
Type: InSite.Domain.FedExRegistrationService..::.RegisterWebCspUserRequest
userState
Type: System..::.Object

Remarks

See Also

RegistrationService Class
registerWebCSPUserAsync Overload
InSite.Domain.FedExRegistrationService Namespace


subscription Method

[image]

.NET Framework Class Library
RegistrationService..::.subscription Method
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("subscription", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
Public Function subscription ( _
    SubscriptionRequest As SubscriptionRequest _
) As SubscriptionReply
C#
[SoapDocumentMethodAttribute("subscription", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
public SubscriptionReply subscription(
    SubscriptionRequest SubscriptionRequest
)
Visual C++
[SoapDocumentMethodAttribute(L"subscription", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
public:
SubscriptionReply^ subscription(
    SubscriptionRequest^ SubscriptionRequest
)
JavaScript
function subscription(SubscriptionRequest);

Parameters

SubscriptionRequest
Type: InSite.Domain.FedExRegistrationService..::.SubscriptionRequest

Remarks

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


subscriptionAsync Method

[image] [image]

.NET Framework Class Library
RegistrationService..::.subscriptionAsync Method
RegistrationService Class See Also Send Feedback

Overload List

Name | Description
subscriptionAsync(SubscriptionRequest) |
subscriptionAsync(SubscriptionRequest, Object) |

See Also

RegistrationService Class
RegistrationService Members
InSite.Domain.FedExRegistrationService Namespace


subscriptionAsync Method (SubscriptionRequest)

[image]

.NET Framework Class Library
RegistrationService..::.subscriptionAsync Method (SubscriptionRequest)
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub subscriptionAsync ( _
    SubscriptionRequest As SubscriptionRequest _
)
C#
public void subscriptionAsync(
    SubscriptionRequest SubscriptionRequest
)
Visual C++
public:
void subscriptionAsync(
    SubscriptionRequest^ SubscriptionRequest
)
JavaScript
function subscriptionAsync(SubscriptionRequest);

Parameters

SubscriptionRequest
Type: InSite.Domain.FedExRegistrationService..::.SubscriptionRequest

Remarks

See Also

RegistrationService Class
subscriptionAsync Overload
InSite.Domain.FedExRegistrationService Namespace


subscriptionAsync Method (SubscriptionRequest, Object)

[image]

.NET Framework Class Library
RegistrationService..::.subscriptionAsync Method (SubscriptionRequest, Object)
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub subscriptionAsync ( _
    SubscriptionRequest As SubscriptionRequest, _
    userState As Object _
)
C#
public void subscriptionAsync(
    SubscriptionRequest SubscriptionRequest,
    Object userState
)
Visual C++
public:
void subscriptionAsync(
    SubscriptionRequest^ SubscriptionRequest,
    Object^ userState
)
JavaScript
function subscriptionAsync(SubscriptionRequest, userState);

Parameters

SubscriptionRequest
Type: InSite.Domain.FedExRegistrationService..::.SubscriptionRequest
userState
Type: System..::.Object

Remarks

See Also

RegistrationService Class
subscriptionAsync Overload
InSite.Domain.FedExRegistrationService Namespace


versionCapture Method

[image]

.NET Framework Class Library
RegistrationService..::.versionCapture Method
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("versionCapture", Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Bare)> _
Public Function versionCapture ( _
    VersionCaptureRequest As VersionCaptureRequest _
) As VersionCaptureReply
C#
[SoapDocumentMethodAttribute("versionCapture", Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Bare)]
public VersionCaptureReply versionCapture(
    VersionCaptureRequest VersionCaptureRequest
)
Visual C++
[SoapDocumentMethodAttribute(L"versionCapture", Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Bare)]
public:
VersionCaptureReply^ versionCapture(
    VersionCaptureRequest^ VersionCaptureRequest
)
JavaScript
function versionCapture(VersionCaptureRequest);

Parameters

VersionCaptureRequest
Type: InSite.Domain.FedExRegistrationService..::.VersionCaptureRequest

Remarks

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


versionCaptureAsync Method

[image] [image]

.NET Framework Class Library
RegistrationService..::.versionCaptureAsync Method
RegistrationService Class See Also Send Feedback

Overload List

Name | Description
versionCaptureAsync(VersionCaptureRequest) |
versionCaptureAsync(VersionCaptureRequest, Object) |

See Also

RegistrationService Class
RegistrationService Members
InSite.Domain.FedExRegistrationService Namespace


versionCaptureAsync Method (VersionCaptureRequest)

[image]

.NET Framework Class Library
RegistrationService..::.versionCaptureAsync Method (VersionCaptureRequest)
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub versionCaptureAsync ( _
    VersionCaptureRequest As VersionCaptureRequest _
)
C#
public void versionCaptureAsync(
    VersionCaptureRequest VersionCaptureRequest
)
Visual C++
public:
void versionCaptureAsync(
    VersionCaptureRequest^ VersionCaptureRequest
)
JavaScript
function versionCaptureAsync(VersionCaptureRequest);

Parameters

VersionCaptureRequest
Type: InSite.Domain.FedExRegistrationService..::.VersionCaptureRequest

Remarks

See Also

RegistrationService Class
versionCaptureAsync Overload
InSite.Domain.FedExRegistrationService Namespace


versionCaptureAsync Method (VersionCaptureRequest, Object)

[image]

.NET Framework Class Library
RegistrationService..::.versionCaptureAsync Method (VersionCaptureRequest, Object)
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub versionCaptureAsync ( _
    VersionCaptureRequest As VersionCaptureRequest, _
    userState As Object _
)
C#
public void versionCaptureAsync(
    VersionCaptureRequest VersionCaptureRequest,
    Object userState
)
Visual C++
public:
void versionCaptureAsync(
    VersionCaptureRequest^ VersionCaptureRequest,
    Object^ userState
)
JavaScript
function versionCaptureAsync(VersionCaptureRequest, userState);

Parameters

VersionCaptureRequest
Type: InSite.Domain.FedExRegistrationService..::.VersionCaptureRequest
userState
Type: System..::.Object

Remarks

See Also

RegistrationService Class
versionCaptureAsync Overload
InSite.Domain.FedExRegistrationService Namespace


RegistrationService Properties

[image] [image]

.NET Framework Class Library
RegistrationService Properties
RegistrationService Class See Also Send Feedback

The RegistrationService type exposes the following members.

Properties

Name | Description
AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true. (Inherited from HttpWebClientProtocol.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Url |
UseDefaultCredentials |
UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


Url Property

[image]

.NET Framework Class Library
RegistrationService..::.Url Property
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url { get; set; }
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_url();
function set_url(value);

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


UseDefaultCredentials Property

[image]

.NET Framework Class Library
RegistrationService..::.UseDefaultCredentials Property
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UseDefaultCredentials As Boolean
C#
public bool UseDefaultCredentials { get; set; }
Visual C++
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useDefaultCredentials();
function set_useDefaultCredentials(value);

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


RegistrationService Events

[image] [image]

.NET Framework Class Library
RegistrationService Events
RegistrationService Class See Also Send Feedback

The RegistrationService type exposes the following members.

Events

Name | Description
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
registerWebCSPUserCompleted |
subscriptionCompleted |
versionCaptureCompleted |

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


registerWebCSPUserCompleted Event

[image]

.NET Framework Class Library
RegistrationService..::.registerWebCSPUserCompleted Event
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event registerWebCSPUserCompleted As registerWebCSPUserCompletedEventHandler
C#
public event registerWebCSPUserCompletedEventHandler registerWebCSPUserCompleted
Visual C++
public:
 event registerWebCSPUserCompletedEventHandler^ registerWebCSPUserCompleted {
    void add (registerWebCSPUserCompletedEventHandler^ value);
    void remove (registerWebCSPUserCompletedEventHandler^ value);
}
JavaScript
function add_registerWebCSPUserCompleted(value);
function remove_registerWebCSPUserCompleted(value);

Remarks

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


subscriptionCompleted Event

[image]

.NET Framework Class Library
RegistrationService..::.subscriptionCompleted Event
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event subscriptionCompleted As subscriptionCompletedEventHandler
C#
public event subscriptionCompletedEventHandler subscriptionCompleted
Visual C++
public:
 event subscriptionCompletedEventHandler^ subscriptionCompleted {
    void add (subscriptionCompletedEventHandler^ value);
    void remove (subscriptionCompletedEventHandler^ value);
}
JavaScript
function add_subscriptionCompleted(value);
function remove_subscriptionCompleted(value);

Remarks

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


versionCaptureCompleted Event

[image]

.NET Framework Class Library
RegistrationService..::.versionCaptureCompleted Event
RegistrationService Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event versionCaptureCompleted As versionCaptureCompletedEventHandler
C#
public event versionCaptureCompletedEventHandler versionCaptureCompleted
Visual C++
public:
 event versionCaptureCompletedEventHandler^ versionCaptureCompleted {
    void add (versionCaptureCompletedEventHandler^ value);
    void remove (versionCaptureCompletedEventHandler^ value);
}
JavaScript
function add_versionCaptureCompleted(value);
function remove_versionCaptureCompleted(value);

Remarks

See Also

RegistrationService Class
InSite.Domain.FedExRegistrationService Namespace


subscriptionCompletedEventArgs Class

[image]

.NET Framework Class Library
subscriptionCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Class subscriptionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public class subscriptionCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public ref class subscriptionCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.FedExRegistrationService.subscriptionCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.subscriptionCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.FedExRegistrationService..::.subscriptionCompletedEventArgs

See Also

subscriptionCompletedEventArgs Members
InSite.Domain.FedExRegistrationService Namespace


subscriptionCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
subscriptionCompletedEventArgs Members
subscriptionCompletedEventArgs Class Methods Properties See Also Send Feedback

The subscriptionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

subscriptionCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


subscriptionCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
subscriptionCompletedEventArgs Methods
subscriptionCompletedEventArgs Class See Also Send Feedback

The subscriptionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

subscriptionCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


subscriptionCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
subscriptionCompletedEventArgs Properties
subscriptionCompletedEventArgs Class See Also Send Feedback

The subscriptionCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

subscriptionCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


Result Property

[image]

.NET Framework Class Library
subscriptionCompletedEventArgs..::.Result Property
subscriptionCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As SubscriptionReply
C#
public SubscriptionReply Result { get; }
Visual C++
public:
property SubscriptionReply^ Result {
    SubscriptionReply^ get ();
}
JavaScript
function get_result();

Remarks

See Also

subscriptionCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


subscriptionCompletedEventHandler Delegate

[image]

.NET Framework Class Library
subscriptionCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Delegate Sub subscriptionCompletedEventHandler ( _
    sender As Object, _
    e As subscriptionCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public delegate void subscriptionCompletedEventHandler(
    Object sender,
    subscriptionCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public delegate void subscriptionCompletedEventHandler(
    Object^ sender,
    subscriptionCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.FedExRegistrationService..::.subscriptionCompletedEventArgs

Remarks

See Also

InSite.Domain.FedExRegistrationService Namespace


SubscriptionReply Class

[image]

.NET Framework Class Library
SubscriptionReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class SubscriptionReply
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class SubscriptionReply
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class SubscriptionReply
JavaScript
InSite.Domain.FedExRegistrationService.SubscriptionReply = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.SubscriptionReply');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.SubscriptionReply

See Also

SubscriptionReply Members
InSite.Domain.FedExRegistrationService Namespace


SubscriptionReply Members

[image] [image]

.NET Framework Class Library
SubscriptionReply Members
SubscriptionReply Class Constructors Methods Properties See Also Send Feedback

The SubscriptionReply type exposes the following members.

Constructors

Name | Description
SubscriptionReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HighestSeverity |
HighestSeveritySpecified |
MeterNumber |
Notifications |
RegisteredServices |
TransactionDetail |
Version |

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


SubscriptionReply Constructor

[image]

.NET Framework Class Library
SubscriptionReply Constructor
SubscriptionReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SubscriptionReply()
Visual C++
public:
SubscriptionReply()
JavaScript
InSite.Domain.FedExRegistrationService.SubscriptionReply = function();

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


SubscriptionReply Methods

[image] [image]

.NET Framework Class Library
SubscriptionReply Methods
SubscriptionReply Class See Also Send Feedback

The SubscriptionReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


SubscriptionReply Properties

[image] [image]

.NET Framework Class Library
SubscriptionReply Properties
SubscriptionReply Class See Also Send Feedback

The SubscriptionReply type exposes the following members.

Properties

Name | Description
HighestSeverity |
HighestSeveritySpecified |
MeterNumber |
Notifications |
RegisteredServices |
TransactionDetail |
Version |

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


HighestSeverity Property

[image]

.NET Framework Class Library
SubscriptionReply..::.HighestSeverity Property
SubscriptionReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HighestSeverity As NotificationSeverityType
C#
public NotificationSeverityType HighestSeverity { get; set; }
Visual C++
public:
property NotificationSeverityType HighestSeverity {
    NotificationSeverityType get ();
    void set (NotificationSeverityType value);
}
JavaScript
function get_highestSeverity();
function set_highestSeverity(value);

Remarks

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


HighestSeveritySpecified Property

[image]

.NET Framework Class Library
SubscriptionReply..::.HighestSeveritySpecified Property
SubscriptionReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HighestSeveritySpecified As Boolean
C#
public bool HighestSeveritySpecified { get; set; }
Visual C++
public:
property bool HighestSeveritySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_highestSeveritySpecified();
function set_highestSeveritySpecified(value);

Remarks

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


MeterNumber Property

[image]

.NET Framework Class Library
SubscriptionReply..::.MeterNumber Property
SubscriptionReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MeterNumber As String
C#
public string MeterNumber { get; set; }
Visual C++
public:
property String^ MeterNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_meterNumber();
function set_meterNumber(value);

Remarks

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


Notifications Property

[image]

.NET Framework Class Library
SubscriptionReply..::.Notifications Property
SubscriptionReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Notifications As Notification()
C#
public Notification[] Notifications { get; set; }
Visual C++
public:
property array<Notification^>^ Notifications {
    array<Notification^>^ get ();
    void set (array<Notification^>^ value);
}
JavaScript
function get_notifications();
function set_notifications(value);

Remarks

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


RegisteredServices Property

[image]

.NET Framework Class Library
SubscriptionReply..::.RegisteredServices Property
SubscriptionReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RegisteredServices As SubscriptionServiceType()
C#
public SubscriptionServiceType[] RegisteredServices { get; set; }
Visual C++
public:
property array<SubscriptionServiceType>^ RegisteredServices {
    array<SubscriptionServiceType>^ get ();
    void set (array<SubscriptionServiceType>^ value);
}
JavaScript
function get_registeredServices();
function set_registeredServices(value);

Remarks

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Property

[image]

.NET Framework Class Library
SubscriptionReply..::.TransactionDetail Property
SubscriptionReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionDetail As TransactionDetail
C#
public TransactionDetail TransactionDetail { get; set; }
Visual C++
public:
property TransactionDetail^ TransactionDetail {
    TransactionDetail^ get ();
    void set (TransactionDetail^ value);
}
JavaScript
function get_transactionDetail();
function set_transactionDetail(value);

Remarks

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


Version Property

[image]

.NET Framework Class Library
SubscriptionReply..::.Version Property
SubscriptionReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As VersionId
C#
public VersionId Version { get; set; }
Visual C++
public:
property VersionId^ Version {
    VersionId^ get ();
    void set (VersionId^ value);
}
JavaScript
function get_version();
function set_version(value);

Remarks

See Also

SubscriptionReply Class
InSite.Domain.FedExRegistrationService Namespace


SubscriptionRequest Class

[image]

.NET Framework Class Library
SubscriptionRequest Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class SubscriptionRequest
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class SubscriptionRequest
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class SubscriptionRequest
JavaScript
InSite.Domain.FedExRegistrationService.SubscriptionRequest = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.SubscriptionRequest');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.SubscriptionRequest

See Also

SubscriptionRequest Members
InSite.Domain.FedExRegistrationService Namespace


SubscriptionRequest Members

[image] [image]

.NET Framework Class Library
SubscriptionRequest Members
SubscriptionRequest Class Constructors Methods Properties See Also Send Feedback

The SubscriptionRequest type exposes the following members.

Constructors

Name | Description
SubscriptionRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccountShippingAddress |
ClientDetail |
CspSolutionId |
CspType |
CspTypeSpecified |
Subscriber |
TransactionDetail |
Version |
WebAuthenticationDetail |

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


SubscriptionRequest Constructor

[image]

.NET Framework Class Library
SubscriptionRequest Constructor
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SubscriptionRequest()
Visual C++
public:
SubscriptionRequest()
JavaScript
InSite.Domain.FedExRegistrationService.SubscriptionRequest = function();

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


SubscriptionRequest Methods

[image] [image]

.NET Framework Class Library
SubscriptionRequest Methods
SubscriptionRequest Class See Also Send Feedback

The SubscriptionRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


SubscriptionRequest Properties

[image] [image]

.NET Framework Class Library
SubscriptionRequest Properties
SubscriptionRequest Class See Also Send Feedback

The SubscriptionRequest type exposes the following members.

Properties

Name | Description
AccountShippingAddress |
ClientDetail |
CspSolutionId |
CspType |
CspTypeSpecified |
Subscriber |
TransactionDetail |
Version |
WebAuthenticationDetail |

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


AccountShippingAddress Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.AccountShippingAddress Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AccountShippingAddress As Address
C#
public Address AccountShippingAddress { get; set; }
Visual C++
public:
property Address^ AccountShippingAddress {
    Address^ get ();
    void set (Address^ value);
}
JavaScript
function get_accountShippingAddress();
function set_accountShippingAddress(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


ClientDetail Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.ClientDetail Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientDetail As ClientDetail
C#
public ClientDetail ClientDetail { get; set; }
Visual C++
public:
property ClientDetail^ ClientDetail {
    ClientDetail^ get ();
    void set (ClientDetail^ value);
}
JavaScript
function get_clientDetail();
function set_clientDetail(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


CspSolutionId Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.CspSolutionId Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CspSolutionId As String
C#
public string CspSolutionId { get; set; }
Visual C++
public:
property String^ CspSolutionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cspSolutionId();
function set_cspSolutionId(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


CspType Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.CspType Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CspType As CspType
C#
public CspType CspType { get; set; }
Visual C++
public:
property CspType CspType {
    CspType get ();
    void set (CspType value);
}
JavaScript
function get_cspType();
function set_cspType(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


CspTypeSpecified Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.CspTypeSpecified Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CspTypeSpecified As Boolean
C#
public bool CspTypeSpecified { get; set; }
Visual C++
public:
property bool CspTypeSpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_cspTypeSpecified();
function set_cspTypeSpecified(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


Subscriber Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.Subscriber Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Subscriber As Party
C#
public Party Subscriber { get; set; }
Visual C++
public:
property Party^ Subscriber {
    Party^ get ();
    void set (Party^ value);
}
JavaScript
function get_subscriber();
function set_subscriber(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.TransactionDetail Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionDetail As TransactionDetail
C#
public TransactionDetail TransactionDetail { get; set; }
Visual C++
public:
property TransactionDetail^ TransactionDetail {
    TransactionDetail^ get ();
    void set (TransactionDetail^ value);
}
JavaScript
function get_transactionDetail();
function set_transactionDetail(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


Version Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.Version Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As VersionId
C#
public VersionId Version { get; set; }
Visual C++
public:
property VersionId^ Version {
    VersionId^ get ();
    void set (VersionId^ value);
}
JavaScript
function get_version();
function set_version(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationDetail Property

[image]

.NET Framework Class Library
SubscriptionRequest..::.WebAuthenticationDetail Property
SubscriptionRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property WebAuthenticationDetail As WebAuthenticationDetail
C#
public WebAuthenticationDetail WebAuthenticationDetail { get; set; }
Visual C++
public:
property WebAuthenticationDetail^ WebAuthenticationDetail {
    WebAuthenticationDetail^ get ();
    void set (WebAuthenticationDetail^ value);
}
JavaScript
function get_webAuthenticationDetail();
function set_webAuthenticationDetail(value);

Remarks

See Also

SubscriptionRequest Class
InSite.Domain.FedExRegistrationService Namespace


SubscriptionServiceType Enumeration

[image]

.NET Framework Class Library
SubscriptionServiceType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration SubscriptionServiceType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum SubscriptionServiceType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class SubscriptionServiceType
JavaScript
InSite.Domain.FedExRegistrationService.SubscriptionServiceType = function();
InSite.Domain.FedExRegistrationService.SubscriptionServiceType.createEnum('InSite.Domain.FedExRegistrationService.SubscriptionServiceType', false);

Members

Member name | Description
EXPRESS_SHIPPING |
GROUND_SHIPPING |

Remarks

See Also

InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Class

[image]

.NET Framework Class Library
TransactionDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class TransactionDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class TransactionDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class TransactionDetail
JavaScript
InSite.Domain.FedExRegistrationService.TransactionDetail = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.TransactionDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.TransactionDetail

See Also

TransactionDetail Members
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Members

[image] [image]

.NET Framework Class Library
TransactionDetail Members
TransactionDetail Class Constructors Methods Properties See Also Send Feedback

The TransactionDetail type exposes the following members.

Constructors

Name | Description
TransactionDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CustomerTransactionId |
Localization |

See Also

TransactionDetail Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Constructor

[image]

.NET Framework Class Library
TransactionDetail Constructor
TransactionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TransactionDetail()
Visual C++
public:
TransactionDetail()
JavaScript
InSite.Domain.FedExRegistrationService.TransactionDetail = function();

See Also

TransactionDetail Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Methods

[image] [image]

.NET Framework Class Library
TransactionDetail Methods
TransactionDetail Class See Also Send Feedback

The TransactionDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionDetail Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Properties

[image] [image]

.NET Framework Class Library
TransactionDetail Properties
TransactionDetail Class See Also Send Feedback

The TransactionDetail type exposes the following members.

Properties

Name | Description
CustomerTransactionId |
Localization |

See Also

TransactionDetail Class
InSite.Domain.FedExRegistrationService Namespace


CustomerTransactionId Property

[image]

.NET Framework Class Library
TransactionDetail..::.CustomerTransactionId Property
TransactionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerTransactionId As String
C#
public string CustomerTransactionId { get; set; }
Visual C++
public:
property String^ CustomerTransactionId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerTransactionId();
function set_customerTransactionId(value);

Remarks

See Also

TransactionDetail Class
InSite.Domain.FedExRegistrationService Namespace


Localization Property

[image]

.NET Framework Class Library
TransactionDetail..::.Localization Property
TransactionDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Localization As Localization
C#
public Localization Localization { get; set; }
Visual C++
public:
property Localization^ Localization {
    Localization^ get ();
    void set (Localization^ value);
}
JavaScript
function get_localization();
function set_localization(value);

Remarks

See Also

TransactionDetail Class
InSite.Domain.FedExRegistrationService Namespace


versionCaptureCompletedEventArgs Class

[image]

.NET Framework Class Library
versionCaptureCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Class versionCaptureCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public class versionCaptureCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public ref class versionCaptureCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.FedExRegistrationService.versionCaptureCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.versionCaptureCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.FedExRegistrationService..::.versionCaptureCompletedEventArgs

See Also

versionCaptureCompletedEventArgs Members
InSite.Domain.FedExRegistrationService Namespace


versionCaptureCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
versionCaptureCompletedEventArgs Members
versionCaptureCompletedEventArgs Class Methods Properties See Also Send Feedback

The versionCaptureCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

versionCaptureCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


versionCaptureCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
versionCaptureCompletedEventArgs Methods
versionCaptureCompletedEventArgs Class See Also Send Feedback

The versionCaptureCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

versionCaptureCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


versionCaptureCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
versionCaptureCompletedEventArgs Properties
versionCaptureCompletedEventArgs Class See Also Send Feedback

The versionCaptureCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

versionCaptureCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


Result Property

[image]

.NET Framework Class Library
versionCaptureCompletedEventArgs..::.Result Property
versionCaptureCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As VersionCaptureReply
C#
public VersionCaptureReply Result { get; }
Visual C++
public:
property VersionCaptureReply^ Result {
    VersionCaptureReply^ get ();
}
JavaScript
function get_result();

Remarks

See Also

versionCaptureCompletedEventArgs Class
InSite.Domain.FedExRegistrationService Namespace


versionCaptureCompletedEventHandler Delegate

[image]

.NET Framework Class Library
versionCaptureCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")> _
Public Delegate Sub versionCaptureCompletedEventHandler ( _
    sender As Object, _
    e As versionCaptureCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.4016")]
public delegate void versionCaptureCompletedEventHandler(
    Object sender,
    versionCaptureCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.4016")]
public delegate void versionCaptureCompletedEventHandler(
    Object^ sender,
    versionCaptureCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.FedExRegistrationService..::.versionCaptureCompletedEventArgs

Remarks

See Also

InSite.Domain.FedExRegistrationService Namespace


VersionCaptureReply Class

[image]

.NET Framework Class Library
VersionCaptureReply Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class VersionCaptureReply
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class VersionCaptureReply
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class VersionCaptureReply
JavaScript
InSite.Domain.FedExRegistrationService.VersionCaptureReply = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.VersionCaptureReply');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.VersionCaptureReply

See Also

VersionCaptureReply Members
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureReply Members

[image] [image]

.NET Framework Class Library
VersionCaptureReply Members
VersionCaptureReply Class Constructors Methods Properties See Also Send Feedback

The VersionCaptureReply type exposes the following members.

Constructors

Name | Description
VersionCaptureReply |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HighestSeverity |
HighestSeveritySpecified |
Notifications |
TransactionDetail |
Version |

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureReply Constructor

[image]

.NET Framework Class Library
VersionCaptureReply Constructor
VersionCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VersionCaptureReply()
Visual C++
public:
VersionCaptureReply()
JavaScript
InSite.Domain.FedExRegistrationService.VersionCaptureReply = function();

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureReply Methods

[image] [image]

.NET Framework Class Library
VersionCaptureReply Methods
VersionCaptureReply Class See Also Send Feedback

The VersionCaptureReply type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureReply Properties

[image] [image]

.NET Framework Class Library
VersionCaptureReply Properties
VersionCaptureReply Class See Also Send Feedback

The VersionCaptureReply type exposes the following members.

Properties

Name | Description
HighestSeverity |
HighestSeveritySpecified |
Notifications |
TransactionDetail |
Version |

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


HighestSeverity Property

[image]

.NET Framework Class Library
VersionCaptureReply..::.HighestSeverity Property
VersionCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HighestSeverity As NotificationSeverityType
C#
public NotificationSeverityType HighestSeverity { get; set; }
Visual C++
public:
property NotificationSeverityType HighestSeverity {
    NotificationSeverityType get ();
    void set (NotificationSeverityType value);
}
JavaScript
function get_highestSeverity();
function set_highestSeverity(value);

Remarks

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


HighestSeveritySpecified Property

[image]

.NET Framework Class Library
VersionCaptureReply..::.HighestSeveritySpecified Property
VersionCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property HighestSeveritySpecified As Boolean
C#
public bool HighestSeveritySpecified { get; set; }
Visual C++
public:
property bool HighestSeveritySpecified {
    bool get ();
    void set (bool value);
}
JavaScript
function get_highestSeveritySpecified();
function set_highestSeveritySpecified(value);

Remarks

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


Notifications Property

[image]

.NET Framework Class Library
VersionCaptureReply..::.Notifications Property
VersionCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Notifications As Notification()
C#
public Notification[] Notifications { get; set; }
Visual C++
public:
property array<Notification^>^ Notifications {
    array<Notification^>^ get ();
    void set (array<Notification^>^ value);
}
JavaScript
function get_notifications();
function set_notifications(value);

Remarks

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Property

[image]

.NET Framework Class Library
VersionCaptureReply..::.TransactionDetail Property
VersionCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionDetail As TransactionDetail
C#
public TransactionDetail TransactionDetail { get; set; }
Visual C++
public:
property TransactionDetail^ TransactionDetail {
    TransactionDetail^ get ();
    void set (TransactionDetail^ value);
}
JavaScript
function get_transactionDetail();
function set_transactionDetail(value);

Remarks

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


Version Property

[image]

.NET Framework Class Library
VersionCaptureReply..::.Version Property
VersionCaptureReply Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As VersionId
C#
public VersionId Version { get; set; }
Visual C++
public:
property VersionId^ Version {
    VersionId^ get ();
    void set (VersionId^ value);
}
JavaScript
function get_version();
function set_version(value);

Remarks

See Also

VersionCaptureReply Class
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureRequest Class

[image]

.NET Framework Class Library
VersionCaptureRequest Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class VersionCaptureRequest
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class VersionCaptureRequest
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class VersionCaptureRequest
JavaScript
InSite.Domain.FedExRegistrationService.VersionCaptureRequest = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.VersionCaptureRequest');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.VersionCaptureRequest

See Also

VersionCaptureRequest Members
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureRequest Members

[image] [image]

.NET Framework Class Library
VersionCaptureRequest Members
VersionCaptureRequest Class Constructors Methods Properties See Also Send Feedback

The VersionCaptureRequest type exposes the following members.

Constructors

Name | Description
VersionCaptureRequest |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ClientDetail |
OriginLocationId |
TransactionDetail |
VendorProductPlatform |
Version |
WebAuthenticationDetail |

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureRequest Constructor

[image]

.NET Framework Class Library
VersionCaptureRequest Constructor
VersionCaptureRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VersionCaptureRequest()
Visual C++
public:
VersionCaptureRequest()
JavaScript
InSite.Domain.FedExRegistrationService.VersionCaptureRequest = function();

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureRequest Methods

[image] [image]

.NET Framework Class Library
VersionCaptureRequest Methods
VersionCaptureRequest Class See Also Send Feedback

The VersionCaptureRequest type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


VersionCaptureRequest Properties

[image] [image]

.NET Framework Class Library
VersionCaptureRequest Properties
VersionCaptureRequest Class See Also Send Feedback

The VersionCaptureRequest type exposes the following members.

Properties

Name | Description
ClientDetail |
OriginLocationId |
TransactionDetail |
VendorProductPlatform |
Version |
WebAuthenticationDetail |

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


ClientDetail Property

[image]

.NET Framework Class Library
VersionCaptureRequest..::.ClientDetail Property
VersionCaptureRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ClientDetail As ClientDetail
C#
public ClientDetail ClientDetail { get; set; }
Visual C++
public:
property ClientDetail^ ClientDetail {
    ClientDetail^ get ();
    void set (ClientDetail^ value);
}
JavaScript
function get_clientDetail();
function set_clientDetail(value);

Remarks

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


OriginLocationId Property

[image]

.NET Framework Class Library
VersionCaptureRequest..::.OriginLocationId Property
VersionCaptureRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OriginLocationId As String
C#
public string OriginLocationId { get; set; }
Visual C++
public:
property String^ OriginLocationId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_originLocationId();
function set_originLocationId(value);

Remarks

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


TransactionDetail Property

[image]

.NET Framework Class Library
VersionCaptureRequest..::.TransactionDetail Property
VersionCaptureRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionDetail As TransactionDetail
C#
public TransactionDetail TransactionDetail { get; set; }
Visual C++
public:
property TransactionDetail^ TransactionDetail {
    TransactionDetail^ get ();
    void set (TransactionDetail^ value);
}
JavaScript
function get_transactionDetail();
function set_transactionDetail(value);

Remarks

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


VendorProductPlatform Property

[image]

.NET Framework Class Library
VersionCaptureRequest..::.VendorProductPlatform Property
VersionCaptureRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VendorProductPlatform As String
C#
public string VendorProductPlatform { get; set; }
Visual C++
public:
property String^ VendorProductPlatform {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vendorProductPlatform();
function set_vendorProductPlatform(value);

Remarks

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


Version Property

[image]

.NET Framework Class Library
VersionCaptureRequest..::.Version Property
VersionCaptureRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Version As VersionId
C#
public VersionId Version { get; set; }
Visual C++
public:
property VersionId^ Version {
    VersionId^ get ();
    void set (VersionId^ value);
}
JavaScript
function get_version();
function set_version(value);

Remarks

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationDetail Property

[image]

.NET Framework Class Library
VersionCaptureRequest..::.WebAuthenticationDetail Property
VersionCaptureRequest Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property WebAuthenticationDetail As WebAuthenticationDetail
C#
public WebAuthenticationDetail WebAuthenticationDetail { get; set; }
Visual C++
public:
property WebAuthenticationDetail^ WebAuthenticationDetail {
    WebAuthenticationDetail^ get ();
    void set (WebAuthenticationDetail^ value);
}
JavaScript
function get_webAuthenticationDetail();
function set_webAuthenticationDetail(value);

Remarks

See Also

VersionCaptureRequest Class
InSite.Domain.FedExRegistrationService Namespace


VersionId Class

[image]

.NET Framework Class Library
VersionId Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class VersionId
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class VersionId
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class VersionId
JavaScript
InSite.Domain.FedExRegistrationService.VersionId = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.VersionId');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.VersionId

See Also

VersionId Members
InSite.Domain.FedExRegistrationService Namespace


VersionId Members

[image] [image]

.NET Framework Class Library
VersionId Members
VersionId Class Constructors Methods Properties See Also Send Feedback

The VersionId type exposes the following members.

Constructors

Name | Description
VersionId |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Intermediate |
Major |
Minor |
ServiceId |

See Also

VersionId Class
InSite.Domain.FedExRegistrationService Namespace


VersionId Constructor

[image]

.NET Framework Class Library
VersionId Constructor
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public VersionId()
Visual C++
public:
VersionId()
JavaScript
InSite.Domain.FedExRegistrationService.VersionId = function();

See Also

VersionId Class
InSite.Domain.FedExRegistrationService Namespace


VersionId Methods

[image] [image]

.NET Framework Class Library
VersionId Methods
VersionId Class See Also Send Feedback

The VersionId type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VersionId Class
InSite.Domain.FedExRegistrationService Namespace


VersionId Properties

[image] [image]

.NET Framework Class Library
VersionId Properties
VersionId Class See Also Send Feedback

The VersionId type exposes the following members.

Properties

Name | Description
Intermediate |
Major |
Minor |
ServiceId |

See Also

VersionId Class
InSite.Domain.FedExRegistrationService Namespace


Intermediate Property

[image]

.NET Framework Class Library
VersionId..::.Intermediate Property
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Intermediate As Integer
C#
public int Intermediate { get; set; }
Visual C++
public:
property int Intermediate {
    int get ();
    void set (int value);
}
JavaScript
function get_intermediate();
function set_intermediate(value);

Remarks

See Also

VersionId Class
InSite.Domain.FedExRegistrationService Namespace


Major Property

[image]

.NET Framework Class Library
VersionId..::.Major Property
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Major As Integer
C#
public int Major { get; set; }
Visual C++
public:
property int Major {
    int get ();
    void set (int value);
}
JavaScript
function get_major();
function set_major(value);

Remarks

See Also

VersionId Class
InSite.Domain.FedExRegistrationService Namespace


Minor Property

[image]

.NET Framework Class Library
VersionId..::.Minor Property
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Minor As Integer
C#
public int Minor { get; set; }
Visual C++
public:
property int Minor {
    int get ();
    void set (int value);
}
JavaScript
function get_minor();
function set_minor(value);

Remarks

See Also

VersionId Class
InSite.Domain.FedExRegistrationService Namespace


ServiceId Property

[image]

.NET Framework Class Library
VersionId..::.ServiceId Property
VersionId Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceId As String
C#
public string ServiceId { get; set; }
Visual C++
public:
property String^ ServiceId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_serviceId();
function set_serviceId(value);

Remarks

See Also

VersionId Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationCredential Class

[image]

.NET Framework Class Library
WebAuthenticationCredential Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class WebAuthenticationCredential
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class WebAuthenticationCredential
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class WebAuthenticationCredential
JavaScript
InSite.Domain.FedExRegistrationService.WebAuthenticationCredential = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.WebAuthenticationCredential');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.WebAuthenticationCredential

See Also

WebAuthenticationCredential Members
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationCredential Members

[image] [image]

.NET Framework Class Library
WebAuthenticationCredential Members
WebAuthenticationCredential Class Constructors Methods Properties See Also Send Feedback

The WebAuthenticationCredential type exposes the following members.

Constructors

Name | Description
WebAuthenticationCredential |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Key |
Password |

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationCredential Constructor

[image]

.NET Framework Class Library
WebAuthenticationCredential Constructor
WebAuthenticationCredential Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebAuthenticationCredential()
Visual C++
public:
WebAuthenticationCredential()
JavaScript
InSite.Domain.FedExRegistrationService.WebAuthenticationCredential = function();

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationCredential Methods

[image] [image]

.NET Framework Class Library
WebAuthenticationCredential Methods
WebAuthenticationCredential Class See Also Send Feedback

The WebAuthenticationCredential type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationCredential Properties

[image] [image]

.NET Framework Class Library
WebAuthenticationCredential Properties
WebAuthenticationCredential Class See Also Send Feedback

The WebAuthenticationCredential type exposes the following members.

Properties

Name | Description
Key |
Password |

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRegistrationService Namespace


Key Property

[image]

.NET Framework Class Library
WebAuthenticationCredential..::.Key Property
WebAuthenticationCredential Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Key As String
C#
public string Key { get; set; }
Visual C++
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_key();
function set_key(value);

Remarks

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRegistrationService Namespace


Password Property

[image]

.NET Framework Class Library
WebAuthenticationCredential..::.Password Property
WebAuthenticationCredential Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_password();
function set_password(value);

Remarks

See Also

WebAuthenticationCredential Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationDetail Class

[image]

.NET Framework Class Library
WebAuthenticationDetail Class
Members See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Class WebAuthenticationDetail
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public class WebAuthenticationDetail
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public ref class WebAuthenticationDetail
JavaScript
InSite.Domain.FedExRegistrationService.WebAuthenticationDetail = function();

Type.createClass(
    'InSite.Domain.FedExRegistrationService.WebAuthenticationDetail');

Remarks

Inheritance Hierarchy

System..::.Object
InSite.Domain.FedExRegistrationService..::.WebAuthenticationDetail

See Also

WebAuthenticationDetail Members
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationDetail Members

[image] [image]

.NET Framework Class Library
WebAuthenticationDetail Members
WebAuthenticationDetail Class Constructors Methods Properties See Also Send Feedback

The WebAuthenticationDetail type exposes the following members.

Constructors

Name | Description
WebAuthenticationDetail |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CspCredential |
UserCredential |

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationDetail Constructor

[image]

.NET Framework Class Library
WebAuthenticationDetail Constructor
WebAuthenticationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebAuthenticationDetail()
Visual C++
public:
WebAuthenticationDetail()
JavaScript
InSite.Domain.FedExRegistrationService.WebAuthenticationDetail = function();

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationDetail Methods

[image] [image]

.NET Framework Class Library
WebAuthenticationDetail Methods
WebAuthenticationDetail Class See Also Send Feedback

The WebAuthenticationDetail type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRegistrationService Namespace


WebAuthenticationDetail Properties

[image] [image]

.NET Framework Class Library
WebAuthenticationDetail Properties
WebAuthenticationDetail Class See Also Send Feedback

The WebAuthenticationDetail type exposes the following members.

Properties

Name | Description
CspCredential |
UserCredential |

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRegistrationService Namespace


CspCredential Property

[image]

.NET Framework Class Library
WebAuthenticationDetail..::.CspCredential Property
WebAuthenticationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CspCredential As WebAuthenticationCredential
C#
public WebAuthenticationCredential CspCredential { get; set; }
Visual C++
public:
property WebAuthenticationCredential^ CspCredential {
    WebAuthenticationCredential^ get ();
    void set (WebAuthenticationCredential^ value);
}
JavaScript
function get_cspCredential();
function set_cspCredential(value);

Remarks

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRegistrationService Namespace


UserCredential Property

[image]

.NET Framework Class Library
WebAuthenticationDetail..::.UserCredential Property
WebAuthenticationDetail Class See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UserCredential As WebAuthenticationCredential
C#
public WebAuthenticationCredential UserCredential { get; set; }
Visual C++
public:
property WebAuthenticationCredential^ UserCredential {
    WebAuthenticationCredential^ get ();
    void set (WebAuthenticationCredential^ value);
}
JavaScript
function get_userCredential();
function set_userCredential(value);

Remarks

See Also

WebAuthenticationDetail Class
InSite.Domain.FedExRegistrationService Namespace


WebServiceCategoryType Enumeration

[image]

.NET Framework Class Library
WebServiceCategoryType Enumeration
See Also Send Feedback

Namespace: InSite.Domain.FedExRegistrationService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")> _
Public Enumeration WebServiceCategoryType
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.4016")]
public enum WebServiceCategoryType
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.4016")]
public enum class WebServiceCategoryType
JavaScript
InSite.Domain.FedExRegistrationService.WebServiceCategoryType = function();
InSite.Domain.FedExRegistrationService.WebServiceCategoryType.createEnum('InSite.Domain.FedExRegistrationService.WebServiceCategoryType', false);

Members

Member name | Description
OFFICE_AND_PRINT |
SHIPPING |

Remarks

See Also

InSite.Domain.FedExRegistrationService Namespace


InSite.Domain.InSiteERPService Namespace

[image]

.NET Framework Class Library
InSite.Domain.InSiteERPService Namespace
Send Feedback

Classes

Class | Description
ERPService |
GetACustomersPricingCompletedEventArgs |
GetBillTosCompletedEventArgs |
GetCustomerCompletedEventArgs |
GetCustomerPricingCompletedEventArgs |
GetCustomersCompletedEventArgs |
GetDataSetCompletedEventArgs |
GetInvoiceCompletedEventArgs |
GetInvoiceDetailsCompletedEventArgs |
GetInvoiceHeadersCompletedEventArgs |
GetInvoicesCompletedEventArgs |
GetOrderCompletedEventArgs |
GetOrderDetailsCompletedEventArgs |
GetOrderHeadersCompletedEventArgs |
GetOrdersCompletedEventArgs |
GetPackingListCompletedEventArgs |
GetProductCompletedEventArgs |
GetProductsCompletedEventArgs |
GetResellersCompletedEventArgs |
GetSalesmanCompletedEventArgs |
GetSalesmenCompletedEventArgs |
GetShipmentCompletedEventArgs |
GetShipmentsByShipmentDateCompletedEventArgs |
GetShipmentsCompletedEventArgs |
GetShipTosCompletedEventArgs |
GetTrackingDataCompletedEventArgs |
GetTrackingNumbersCompletedEventArgs |
GetVersionCompletedEventArgs |
ServiceAuthHeader |
SubmitJournalCompletedEventArgs |
SubmitOrdersCompletedEventArgs |
SubmitPaymentsCompletedEventArgs |

Delegates

Delegate | Description
GetACustomersPricingCompletedEventHandler |
GetBillTosCompletedEventHandler |
GetCustomerCompletedEventHandler |
GetCustomerPricingCompletedEventHandler |
GetCustomersCompletedEventHandler |
GetDataSetCompletedEventHandler |
GetInvoiceCompletedEventHandler |
GetInvoiceDetailsCompletedEventHandler |
GetInvoiceHeadersCompletedEventHandler |
GetInvoicesCompletedEventHandler |
GetOrderCompletedEventHandler |
GetOrderDetailsCompletedEventHandler |
GetOrderHeadersCompletedEventHandler |
GetOrdersCompletedEventHandler |
GetPackingListCompletedEventHandler |
GetProductCompletedEventHandler |
GetProductsCompletedEventHandler |
GetResellersCompletedEventHandler |
GetSalesmanCompletedEventHandler |
GetSalesmenCompletedEventHandler |
GetShipmentCompletedEventHandler |
GetShipmentsByShipmentDateCompletedEventHandler |
GetShipmentsCompletedEventHandler |
GetShipTosCompletedEventHandler |
GetTrackingDataCompletedEventHandler |
GetTrackingNumbersCompletedEventHandler |
GetVersionCompletedEventHandler |
SubmitJournalCompletedEventHandler |
SubmitOrdersCompletedEventHandler |
SubmitPaymentsCompletedEventHandler |


ERPService Class

[image]

.NET Framework Class Library
ERPService Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
<WebServiceBindingAttribute(Name := "ERPServiceSoap", Namespace := "http://tempuri.org/InSiteERPService/ERPService")> _
Public Class ERPService _
    Inherits SoapHttpClientProtocol
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
[WebServiceBindingAttribute(Name = "ERPServiceSoap", Namespace = "http://tempuri.org/InSiteERPService/ERPService")]
public class ERPService : SoapHttpClientProtocol
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
[WebServiceBindingAttribute(Name = L"ERPServiceSoap", Namespace = L"http://tempuri.org/InSiteERPService/ERPService")]
public ref class ERPService : public SoapHttpClientProtocol
JavaScript
InSite.Domain.InSiteERPService.ERPService = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.ERPService',
    SoapHttpClientProtocol);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Web.Services.Protocols..::.WebClientProtocol
System.Web.Services.Protocols..::.HttpWebClientProtocol
System.Web.Services.Protocols..::.SoapHttpClientProtocol
InSite.Domain.InSiteERPService..::.ERPService

See Also

ERPService Members
InSite.Domain.InSiteERPService Namespace


ERPService Members

[image] [image]

.NET Framework Class Library
ERPService Members
ERPService Class Constructors Methods Properties Events See Also Send Feedback

The ERPService type exposes the following members.

Constructors

Name | Description
ERPService |

Methods

Name | Description
Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
CancelAsync |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Dispose | Overloaded.
EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetACustomersPricing |
GetACustomersPricingAsync | Overloaded.
GetBillTos |
GetBillTosAsync | Overloaded.
GetCustomer |
GetCustomerAsync | Overloaded.
GetCustomerPricing |
GetCustomerPricingAsync | Overloaded.
GetCustomers |
GetCustomersAsync | Overloaded.
GetDataSet |
GetDataSetAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInvoice |
GetInvoiceAsync | Overloaded.
GetInvoiceDetails |
GetInvoiceDetailsAsync | Overloaded.
GetInvoiceHeaders |
GetInvoiceHeadersAsync | Overloaded.
GetInvoices |
GetInvoicesAsync | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetOrder |
GetOrderAsync | Overloaded.
GetOrderDetails |
GetOrderDetailsAsync | Overloaded.
GetOrderHeaders |
GetOrderHeadersAsync | Overloaded.
GetOrders |
GetOrdersAsync | Overloaded.
GetPackingList |
GetPackingListAsync | Overloaded.
GetProduct |
GetProductAsync | Overloaded.
GetProducts |
GetProductsAsync | Overloaded.
GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
GetResellers |
GetResellersAsync | Overloaded.
GetSalesman |
GetSalesmanAsync | Overloaded.
GetSalesmen |
GetSalesmenAsync | Overloaded.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetShipment |
GetShipmentAsync | Overloaded.
GetShipments |
GetShipmentsAsync | Overloaded.
GetShipmentsByShipmentDate |
GetShipmentsByShipmentDateAsync | Overloaded.
GetShipTos |
GetShipTosAsync | Overloaded.
GetTrackingData |
GetTrackingDataAsync | Overloaded.
GetTrackingNumbers |
GetTrackingNumbersAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
GetVersionAsync | Overloaded.
GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
GetWebResponse | Overloaded.
GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
InvokeAsync | Overloaded.
MemberwiseClone | Overloaded.
SubmitJournal |
SubmitJournalAsync | Overloaded.
SubmitOrders |
SubmitOrdersAsync | Overloaded.
SubmitPayments |
SubmitPaymentsAsync | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

Properties

Name | Description
AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true. (Inherited from HttpWebClientProtocol.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
ServiceAuthHeaderValue |
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Url |
UseDefaultCredentials |
UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)

Events

Name | Description
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
GetACustomersPricingCompleted |
GetBillTosCompleted |
GetCustomerCompleted |
GetCustomerPricingCompleted |
GetCustomersCompleted |
GetDataSetCompleted |
GetInvoiceCompleted |
GetInvoiceDetailsCompleted |
GetInvoiceHeadersCompleted |
GetInvoicesCompleted |
GetOrderCompleted |
GetOrderDetailsCompleted |
GetOrderHeadersCompleted |
GetOrdersCompleted |
GetPackingListCompleted |
GetProductCompleted |
GetProductsCompleted |
GetResellersCompleted |
GetSalesmanCompleted |
GetSalesmenCompleted |
GetShipmentCompleted |
GetShipmentsByShipmentDateCompleted |
GetShipmentsCompleted |
GetShipTosCompleted |
GetTrackingDataCompleted |
GetTrackingNumbersCompleted |
GetVersionCompleted |
SubmitJournalCompleted |
SubmitOrdersCompleted |
SubmitPaymentsCompleted |

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


ERPService Constructor

[image]

.NET Framework Class Library
ERPService Constructor
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ERPService()
Visual C++
public:
ERPService()
JavaScript
InSite.Domain.InSiteERPService.ERPService = function();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


ERPService Methods

[image] [image]

.NET Framework Class Library
ERPService Methods
ERPService Class See Also Send Feedback

The ERPService type exposes the following members.

Methods

Name | Description
Abort | Cancels a request to an XML Web service method. (Inherited from WebClientProtocol.)
BeginInvoke | Starts an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
CancelAsync |
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Discover | Dynamically binds to an XML Web service described in the discovery document at Url. (Inherited from SoapHttpClientProtocol.)
Dispose | Overloaded.
EndInvoke | Ends an asynchronous invocation of an XML Web service method using SOAP. (Inherited from SoapHttpClientProtocol.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
GetACustomersPricing |
GetACustomersPricingAsync | Overloaded.
GetBillTos |
GetBillTosAsync | Overloaded.
GetCustomer |
GetCustomerAsync | Overloaded.
GetCustomerPricing |
GetCustomerPricingAsync | Overloaded.
GetCustomers |
GetCustomersAsync | Overloaded.
GetDataSet |
GetDataSetAsync | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetInvoice |
GetInvoiceAsync | Overloaded.
GetInvoiceDetails |
GetInvoiceDetailsAsync | Overloaded.
GetInvoiceHeaders |
GetInvoiceHeadersAsync | Overloaded.
GetInvoices |
GetInvoicesAsync | Overloaded.
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetOrder |
GetOrderAsync | Overloaded.
GetOrderDetails |
GetOrderDetailsAsync | Overloaded.
GetOrderHeaders |
GetOrderHeadersAsync | Overloaded.
GetOrders |
GetOrdersAsync | Overloaded.
GetPackingList |
GetPackingListAsync | Overloaded.
GetProduct |
GetProductAsync | Overloaded.
GetProducts |
GetProductsAsync | Overloaded.
GetReaderForMessage | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
GetResellers |
GetResellersAsync | Overloaded.
GetSalesman |
GetSalesmanAsync | Overloaded.
GetSalesmen |
GetSalesmenAsync | Overloaded.
GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
GetShipment |
GetShipmentAsync | Overloaded.
GetShipments |
GetShipmentsAsync | Overloaded.
GetShipmentsByShipmentDate |
GetShipmentsByShipmentDateAsync | Overloaded.
GetShipTos |
GetShipTosAsync | Overloaded.
GetTrackingData |
GetTrackingDataAsync | Overloaded.
GetTrackingNumbers |
GetTrackingNumbersAsync | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetVersion |
GetVersionAsync | Overloaded.
GetWebRequest | Creates a WebRequest for the specified uri. (Inherited from SoapHttpClientProtocol.)
GetWebResponse | Overloaded.
GetWriterForMessage | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter. (Inherited from SoapHttpClientProtocol.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Invoke | Invokes an XML Web service method synchronously using SOAP. (Inherited from SoapHttpClientProtocol.)
InvokeAsync | Overloaded.
MemberwiseClone | Overloaded.
SubmitJournal |
SubmitJournalAsync | Overloaded.
SubmitOrders |
SubmitOrdersAsync | Overloaded.
SubmitPayments |
SubmitPaymentsAsync | Overloaded.
ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


CancelAsync Method

[image]

.NET Framework Class Library
ERPService..::.CancelAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub CancelAsync ( _
    userState As Object _
)
C#
public void CancelAsync(
    Object userState
)
Visual C++
public:
void CancelAsync(
    Object^ userState
)
JavaScript
function cancelAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
ERPService..::.Dispose Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Component. (Inherited from Component.)
Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetACustomersPricing Method

[image]

.NET Framework Class Library
ERPService..::.GetACustomersPricing Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetACustomersPricing", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetACustomersPricing ( _
    pstrCustomerNumber As String _
) As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetACustomersPricing", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetACustomersPricing(
    string pstrCustomerNumber
)
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetACustomersPricing", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetACustomersPricing(
    String^ pstrCustomerNumber
)
JavaScript
function getACustomersPricing(pstrCustomerNumber);

Parameters

pstrCustomerNumber
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetACustomersPricingAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetACustomersPricingAsync(String) |
GetACustomersPricingAsync(String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingAsync Method (String)

[image]

.NET Framework Class Library
ERPService..::.GetACustomersPricingAsync Method (String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetACustomersPricingAsync ( _
    pstrCustomerNumber As String _
)
C#
public void GetACustomersPricingAsync(
    string pstrCustomerNumber
)
Visual C++
public:
void GetACustomersPricingAsync(
    String^ pstrCustomerNumber
)
JavaScript
function getACustomersPricingAsync(pstrCustomerNumber);

Parameters

pstrCustomerNumber
Type: System..::.String

Remarks

See Also

ERPService Class
GetACustomersPricingAsync Overload
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingAsync Method (String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetACustomersPricingAsync Method (String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetACustomersPricingAsync ( _
    pstrCustomerNumber As String, _
    userState As Object _
)
C#
public void GetACustomersPricingAsync(
    string pstrCustomerNumber,
    Object userState
)
Visual C++
public:
void GetACustomersPricingAsync(
    String^ pstrCustomerNumber,
    Object^ userState
)
JavaScript
function getACustomersPricingAsync(pstrCustomerNumber, userState);

Parameters

pstrCustomerNumber
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetACustomersPricingAsync Overload
InSite.Domain.InSiteERPService Namespace


GetBillTos Method

[image]

.NET Framework Class Library
ERPService..::.GetBillTos Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetBillTos", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetBillTos As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetBillTos", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetBillTos()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetBillTos", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetBillTos()
JavaScript
function getBillTos();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetBillTosAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetBillTosAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetBillTosAsync()()() |
GetBillTosAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetBillTosAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetBillTosAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetBillTosAsync
C#
public void GetBillTosAsync()
Visual C++
public:
void GetBillTosAsync()
JavaScript
function getBillTosAsync();

Remarks

See Also

ERPService Class
GetBillTosAsync Overload
InSite.Domain.InSiteERPService Namespace


GetBillTosAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetBillTosAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetBillTosAsync ( _
    userState As Object _
)
C#
public void GetBillTosAsync(
    Object userState
)
Visual C++
public:
void GetBillTosAsync(
    Object^ userState
)
JavaScript
function getBillTosAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetBillTosAsync Overload
InSite.Domain.InSiteERPService Namespace


GetCustomer Method

[image]

.NET Framework Class Library
ERPService..::.GetCustomer Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetCustomer", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetCustomer ( _
    pstrCustomerNumber As String _
) As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetCustomer", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetCustomer(
    string pstrCustomerNumber
)
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetCustomer", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetCustomer(
    String^ pstrCustomerNumber
)
JavaScript
function getCustomer(pstrCustomerNumber);

Parameters

pstrCustomerNumber
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetCustomerAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetCustomerAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetCustomerAsync(String) |
GetCustomerAsync(String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetCustomerAsync Method (String)

[image]

.NET Framework Class Library
ERPService..::.GetCustomerAsync Method (String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerAsync ( _
    pstrCustomerNumber As String _
)
C#
public void GetCustomerAsync(
    string pstrCustomerNumber
)
Visual C++
public:
void GetCustomerAsync(
    String^ pstrCustomerNumber
)
JavaScript
function getCustomerAsync(pstrCustomerNumber);

Parameters

pstrCustomerNumber
Type: System..::.String

Remarks

See Also

ERPService Class
GetCustomerAsync Overload
InSite.Domain.InSiteERPService Namespace


GetCustomerAsync Method (String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetCustomerAsync Method (String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerAsync ( _
    pstrCustomerNumber As String, _
    userState As Object _
)
C#
public void GetCustomerAsync(
    string pstrCustomerNumber,
    Object userState
)
Visual C++
public:
void GetCustomerAsync(
    String^ pstrCustomerNumber,
    Object^ userState
)
JavaScript
function getCustomerAsync(pstrCustomerNumber, userState);

Parameters

pstrCustomerNumber
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetCustomerAsync Overload
InSite.Domain.InSiteERPService Namespace


GetCustomerPricing Method

[image]

.NET Framework Class Library
ERPService..::.GetCustomerPricing Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetCustomerPricing", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetCustomerPricing As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetCustomerPricing", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetCustomerPricing()
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetCustomerPricing", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetCustomerPricing()
JavaScript
function getCustomerPricing();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetCustomerPricingAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetCustomerPricingAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetCustomerPricingAsync()()() |
GetCustomerPricingAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetCustomerPricingAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetCustomerPricingAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerPricingAsync
C#
public void GetCustomerPricingAsync()
Visual C++
public:
void GetCustomerPricingAsync()
JavaScript
function getCustomerPricingAsync();

Remarks

See Also

ERPService Class
GetCustomerPricingAsync Overload
InSite.Domain.InSiteERPService Namespace


GetCustomerPricingAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetCustomerPricingAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomerPricingAsync ( _
    userState As Object _
)
C#
public void GetCustomerPricingAsync(
    Object userState
)
Visual C++
public:
void GetCustomerPricingAsync(
    Object^ userState
)
JavaScript
function getCustomerPricingAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetCustomerPricingAsync Overload
InSite.Domain.InSiteERPService Namespace


GetCustomers Method

[image]

.NET Framework Class Library
ERPService..::.GetCustomers Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetCustomers", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetCustomers As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetCustomers", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetCustomers()
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetCustomers", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetCustomers()
JavaScript
function getCustomers();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetCustomersAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetCustomersAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetCustomersAsync()()() |
GetCustomersAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetCustomersAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetCustomersAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomersAsync
C#
public void GetCustomersAsync()
Visual C++
public:
void GetCustomersAsync()
JavaScript
function getCustomersAsync();

Remarks

See Also

ERPService Class
GetCustomersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetCustomersAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetCustomersAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetCustomersAsync ( _
    userState As Object _
)
C#
public void GetCustomersAsync(
    Object userState
)
Visual C++
public:
void GetCustomersAsync(
    Object^ userState
)
JavaScript
function getCustomersAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetCustomersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetDataSet Method

[image]

.NET Framework Class Library
ERPService..::.GetDataSet Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetDataSet", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetDataSet ( _
    pstrSelect As String, _
    pstrTableName As String, _
    pstrWhere As String _
) As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetDataSet", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetDataSet(
    string pstrSelect,
    string pstrTableName,
    string pstrWhere
)
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetDataSet", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetDataSet(
    String^ pstrSelect,
    String^ pstrTableName,
    String^ pstrWhere
)
JavaScript
function getDataSet(pstrSelect, pstrTableName, pstrWhere);

Parameters

pstrSelect
Type: System..::.String
pstrTableName
Type: System..::.String
pstrWhere
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetDataSetAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetDataSetAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetDataSetAsync(String, String, String) |
GetDataSetAsync(String, String, String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetDataSetAsync Method (String, String, String)

[image]

.NET Framework Class Library
ERPService..::.GetDataSetAsync Method (String, String, String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetDataSetAsync ( _
    pstrSelect As String, _
    pstrTableName As String, _
    pstrWhere As String _
)
C#
public void GetDataSetAsync(
    string pstrSelect,
    string pstrTableName,
    string pstrWhere
)
Visual C++
public:
void GetDataSetAsync(
    String^ pstrSelect,
    String^ pstrTableName,
    String^ pstrWhere
)
JavaScript
function getDataSetAsync(pstrSelect, pstrTableName, pstrWhere);

Parameters

pstrSelect
Type: System..::.String
pstrTableName
Type: System..::.String
pstrWhere
Type: System..::.String

Remarks

See Also

ERPService Class
GetDataSetAsync Overload
InSite.Domain.InSiteERPService Namespace


GetDataSetAsync Method (String, String, String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetDataSetAsync Method (String, String, String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetDataSetAsync ( _
    pstrSelect As String, _
    pstrTableName As String, _
    pstrWhere As String, _
    userState As Object _
)
C#
public void GetDataSetAsync(
    string pstrSelect,
    string pstrTableName,
    string pstrWhere,
    Object userState
)
Visual C++
public:
void GetDataSetAsync(
    String^ pstrSelect,
    String^ pstrTableName,
    String^ pstrWhere,
    Object^ userState
)
JavaScript
function getDataSetAsync(pstrSelect, pstrTableName, pstrWhere, userState);

Parameters

pstrSelect
Type: System..::.String
pstrTableName
Type: System..::.String
pstrWhere
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetDataSetAsync Overload
InSite.Domain.InSiteERPService Namespace


GetInvoice Method

[image]

.NET Framework Class Library
ERPService..::.GetInvoice Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetInvoice", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetInvoice ( _
    pstrInvoiceNumber As String _
) As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetInvoice", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetInvoice(
    string pstrInvoiceNumber
)
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetInvoice", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetInvoice(
    String^ pstrInvoiceNumber
)
JavaScript
function getInvoice(pstrInvoiceNumber);

Parameters

pstrInvoiceNumber
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetInvoiceAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetInvoiceAsync(String) |
GetInvoiceAsync(String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetInvoiceAsync Method (String)

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceAsync Method (String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetInvoiceAsync ( _
    pstrInvoiceNumber As String _
)
C#
public void GetInvoiceAsync(
    string pstrInvoiceNumber
)
Visual C++
public:
void GetInvoiceAsync(
    String^ pstrInvoiceNumber
)
JavaScript
function getInvoiceAsync(pstrInvoiceNumber);

Parameters

pstrInvoiceNumber
Type: System..::.String

Remarks

See Also

ERPService Class
GetInvoiceAsync Overload
InSite.Domain.InSiteERPService Namespace


GetInvoiceAsync Method (String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceAsync Method (String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetInvoiceAsync ( _
    pstrInvoiceNumber As String, _
    userState As Object _
)
C#
public void GetInvoiceAsync(
    string pstrInvoiceNumber,
    Object userState
)
Visual C++
public:
void GetInvoiceAsync(
    String^ pstrInvoiceNumber,
    Object^ userState
)
JavaScript
function getInvoiceAsync(pstrInvoiceNumber, userState);

Parameters

pstrInvoiceNumber
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetInvoiceAsync Overload
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetails Method

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceDetails Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetInvoiceDetails", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetInvoiceDetails As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetInvoiceDetails", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetInvoiceDetails()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetInvoiceDetails", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetInvoiceDetails()
JavaScript
function getInvoiceDetails();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetInvoiceDetailsAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetInvoiceDetailsAsync()()() |
GetInvoiceDetailsAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceDetailsAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetInvoiceDetailsAsync
C#
public void GetInvoiceDetailsAsync()
Visual C++
public:
void GetInvoiceDetailsAsync()
JavaScript
function getInvoiceDetailsAsync();

Remarks

See Also

ERPService Class
GetInvoiceDetailsAsync Overload
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceDetailsAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetInvoiceDetailsAsync ( _
    userState As Object _
)
C#
public void GetInvoiceDetailsAsync(
    Object userState
)
Visual C++
public:
void GetInvoiceDetailsAsync(
    Object^ userState
)
JavaScript
function getInvoiceDetailsAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetInvoiceDetailsAsync Overload
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeaders Method

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceHeaders Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetInvoiceHeaders", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetInvoiceHeaders As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetInvoiceHeaders", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetInvoiceHeaders()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetInvoiceHeaders", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetInvoiceHeaders()
JavaScript
function getInvoiceHeaders();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetInvoiceHeadersAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetInvoiceHeadersAsync()()() |
GetInvoiceHeadersAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceHeadersAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetInvoiceHeadersAsync
C#
public void GetInvoiceHeadersAsync()
Visual C++
public:
void GetInvoiceHeadersAsync()
JavaScript
function getInvoiceHeadersAsync();

Remarks

See Also

ERPService Class
GetInvoiceHeadersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceHeadersAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetInvoiceHeadersAsync ( _
    userState As Object _
)
C#
public void GetInvoiceHeadersAsync(
    Object userState
)
Visual C++
public:
void GetInvoiceHeadersAsync(
    Object^ userState
)
JavaScript
function getInvoiceHeadersAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetInvoiceHeadersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetInvoices Method

[image]

.NET Framework Class Library
ERPService..::.GetInvoices Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetInvoices", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetInvoices As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetInvoices", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetInvoices()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetInvoices", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetInvoices()
JavaScript
function getInvoices();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetInvoicesAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetInvoicesAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetInvoicesAsync()()() |
GetInvoicesAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetInvoicesAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetInvoicesAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetInvoicesAsync
C#
public void GetInvoicesAsync()
Visual C++
public:
void GetInvoicesAsync()
JavaScript
function getInvoicesAsync();

Remarks

See Also

ERPService Class
GetInvoicesAsync Overload
InSite.Domain.InSiteERPService Namespace


GetInvoicesAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetInvoicesAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetInvoicesAsync ( _
    userState As Object _
)
C#
public void GetInvoicesAsync(
    Object userState
)
Visual C++
public:
void GetInvoicesAsync(
    Object^ userState
)
JavaScript
function getInvoicesAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetInvoicesAsync Overload
InSite.Domain.InSiteERPService Namespace


GetOrder Method

[image]

.NET Framework Class Library
ERPService..::.GetOrder Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetOrder", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetOrder ( _
    pstrOrderNumber As String _
) As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetOrder", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetOrder(
    string pstrOrderNumber
)
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetOrder", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetOrder(
    String^ pstrOrderNumber
)
JavaScript
function getOrder(pstrOrderNumber);

Parameters

pstrOrderNumber
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetOrderAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetOrderAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetOrderAsync(String) |
GetOrderAsync(String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetOrderAsync Method (String)

[image]

.NET Framework Class Library
ERPService..::.GetOrderAsync Method (String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetOrderAsync ( _
    pstrOrderNumber As String _
)
C#
public void GetOrderAsync(
    string pstrOrderNumber
)
Visual C++
public:
void GetOrderAsync(
    String^ pstrOrderNumber
)
JavaScript
function getOrderAsync(pstrOrderNumber);

Parameters

pstrOrderNumber
Type: System..::.String

Remarks

See Also

ERPService Class
GetOrderAsync Overload
InSite.Domain.InSiteERPService Namespace


GetOrderAsync Method (String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetOrderAsync Method (String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetOrderAsync ( _
    pstrOrderNumber As String, _
    userState As Object _
)
C#
public void GetOrderAsync(
    string pstrOrderNumber,
    Object userState
)
Visual C++
public:
void GetOrderAsync(
    String^ pstrOrderNumber,
    Object^ userState
)
JavaScript
function getOrderAsync(pstrOrderNumber, userState);

Parameters

pstrOrderNumber
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetOrderAsync Overload
InSite.Domain.InSiteERPService Namespace


GetOrderDetails Method

[image]

.NET Framework Class Library
ERPService..::.GetOrderDetails Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetOrderDetails", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetOrderDetails As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetOrderDetails", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetOrderDetails()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetOrderDetails", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetOrderDetails()
JavaScript
function getOrderDetails();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetOrderDetailsAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetOrderDetailsAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetOrderDetailsAsync()()() |
GetOrderDetailsAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetOrderDetailsAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetOrderDetailsAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetOrderDetailsAsync
C#
public void GetOrderDetailsAsync()
Visual C++
public:
void GetOrderDetailsAsync()
JavaScript
function getOrderDetailsAsync();

Remarks

See Also

ERPService Class
GetOrderDetailsAsync Overload
InSite.Domain.InSiteERPService Namespace


GetOrderDetailsAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetOrderDetailsAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetOrderDetailsAsync ( _
    userState As Object _
)
C#
public void GetOrderDetailsAsync(
    Object userState
)
Visual C++
public:
void GetOrderDetailsAsync(
    Object^ userState
)
JavaScript
function getOrderDetailsAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetOrderDetailsAsync Overload
InSite.Domain.InSiteERPService Namespace


GetOrderHeaders Method

[image]

.NET Framework Class Library
ERPService..::.GetOrderHeaders Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetOrderHeaders", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetOrderHeaders As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetOrderHeaders", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetOrderHeaders()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetOrderHeaders", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetOrderHeaders()
JavaScript
function getOrderHeaders();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetOrderHeadersAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetOrderHeadersAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetOrderHeadersAsync()()() |
GetOrderHeadersAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetOrderHeadersAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetOrderHeadersAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetOrderHeadersAsync
C#
public void GetOrderHeadersAsync()
Visual C++
public:
void GetOrderHeadersAsync()
JavaScript
function getOrderHeadersAsync();

Remarks

See Also

ERPService Class
GetOrderHeadersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetOrderHeadersAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetOrderHeadersAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetOrderHeadersAsync ( _
    userState As Object _
)
C#
public void GetOrderHeadersAsync(
    Object userState
)
Visual C++
public:
void GetOrderHeadersAsync(
    Object^ userState
)
JavaScript
function getOrderHeadersAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetOrderHeadersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetOrders Method

[image]

.NET Framework Class Library
ERPService..::.GetOrders Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetOrders", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetOrders As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetOrders", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetOrders()
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetOrders", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetOrders()
JavaScript
function getOrders();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetOrdersAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetOrdersAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetOrdersAsync()()() |
GetOrdersAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetOrdersAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetOrdersAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetOrdersAsync
C#
public void GetOrdersAsync()
Visual C++
public:
void GetOrdersAsync()
JavaScript
function getOrdersAsync();

Remarks

See Also

ERPService Class
GetOrdersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetOrdersAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetOrdersAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetOrdersAsync ( _
    userState As Object _
)
C#
public void GetOrdersAsync(
    Object userState
)
Visual C++
public:
void GetOrdersAsync(
    Object^ userState
)
JavaScript
function getOrdersAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetOrdersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetPackingList Method

[image]

.NET Framework Class Library
ERPService..::.GetPackingList Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetPackingList", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetPackingList ( _
    pstrPackListID As String, _
    pstrOrderID As String _
) As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetPackingList", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetPackingList(
    string pstrPackListID,
    string pstrOrderID
)
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetPackingList", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetPackingList(
    String^ pstrPackListID,
    String^ pstrOrderID
)
JavaScript
function getPackingList(pstrPackListID, pstrOrderID);

Parameters

pstrPackListID
Type: System..::.String
pstrOrderID
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetPackingListAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetPackingListAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetPackingListAsync(String, String) |
GetPackingListAsync(String, String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetPackingListAsync Method (String, String)

[image]

.NET Framework Class Library
ERPService..::.GetPackingListAsync Method (String, String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetPackingListAsync ( _
    pstrPackListID As String, _
    pstrOrderID As String _
)
C#
public void GetPackingListAsync(
    string pstrPackListID,
    string pstrOrderID
)
Visual C++
public:
void GetPackingListAsync(
    String^ pstrPackListID,
    String^ pstrOrderID
)
JavaScript
function getPackingListAsync(pstrPackListID, pstrOrderID);

Parameters

pstrPackListID
Type: System..::.String
pstrOrderID
Type: System..::.String

Remarks

See Also

ERPService Class
GetPackingListAsync Overload
InSite.Domain.InSiteERPService Namespace


GetPackingListAsync Method (String, String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetPackingListAsync Method (String, String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetPackingListAsync ( _
    pstrPackListID As String, _
    pstrOrderID As String, _
    userState As Object _
)
C#
public void GetPackingListAsync(
    string pstrPackListID,
    string pstrOrderID,
    Object userState
)
Visual C++
public:
void GetPackingListAsync(
    String^ pstrPackListID,
    String^ pstrOrderID,
    Object^ userState
)
JavaScript
function getPackingListAsync(pstrPackListID, pstrOrderID, userState);

Parameters

pstrPackListID
Type: System..::.String
pstrOrderID
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetPackingListAsync Overload
InSite.Domain.InSiteERPService Namespace


GetProduct Method

[image]

.NET Framework Class Library
ERPService..::.GetProduct Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetProduct", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetProduct ( _
    pstrProductName As String _
) As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetProduct", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetProduct(
    string pstrProductName
)
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetProduct", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetProduct(
    String^ pstrProductName
)
JavaScript
function getProduct(pstrProductName);

Parameters

pstrProductName
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetProductAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetProductAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetProductAsync(String) |
GetProductAsync(String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetProductAsync Method (String)

[image]

.NET Framework Class Library
ERPService..::.GetProductAsync Method (String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetProductAsync ( _
    pstrProductName As String _
)
C#
public void GetProductAsync(
    string pstrProductName
)
Visual C++
public:
void GetProductAsync(
    String^ pstrProductName
)
JavaScript
function getProductAsync(pstrProductName);

Parameters

pstrProductName
Type: System..::.String

Remarks

See Also

ERPService Class
GetProductAsync Overload
InSite.Domain.InSiteERPService Namespace


GetProductAsync Method (String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetProductAsync Method (String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetProductAsync ( _
    pstrProductName As String, _
    userState As Object _
)
C#
public void GetProductAsync(
    string pstrProductName,
    Object userState
)
Visual C++
public:
void GetProductAsync(
    String^ pstrProductName,
    Object^ userState
)
JavaScript
function getProductAsync(pstrProductName, userState);

Parameters

pstrProductName
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetProductAsync Overload
InSite.Domain.InSiteERPService Namespace


GetProducts Method

[image]

.NET Framework Class Library
ERPService..::.GetProducts Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetProducts", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetProducts As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetProducts", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetProducts()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetProducts", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetProducts()
JavaScript
function getProducts();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetProductsAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetProductsAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetProductsAsync()()() |
GetProductsAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetProductsAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetProductsAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetProductsAsync
C#
public void GetProductsAsync()
Visual C++
public:
void GetProductsAsync()
JavaScript
function getProductsAsync();

Remarks

See Also

ERPService Class
GetProductsAsync Overload
InSite.Domain.InSiteERPService Namespace


GetProductsAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetProductsAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetProductsAsync ( _
    userState As Object _
)
C#
public void GetProductsAsync(
    Object userState
)
Visual C++
public:
void GetProductsAsync(
    Object^ userState
)
JavaScript
function getProductsAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetProductsAsync Overload
InSite.Domain.InSiteERPService Namespace


GetResellers Method

[image]

.NET Framework Class Library
ERPService..::.GetResellers Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetResellers", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetResellers As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetResellers", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetResellers()
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetResellers", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetResellers()
JavaScript
function getResellers();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetResellersAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetResellersAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetResellersAsync()()() |
GetResellersAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetResellersAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetResellersAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetResellersAsync
C#
public void GetResellersAsync()
Visual C++
public:
void GetResellersAsync()
JavaScript
function getResellersAsync();

Remarks

See Also

ERPService Class
GetResellersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetResellersAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetResellersAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetResellersAsync ( _
    userState As Object _
)
C#
public void GetResellersAsync(
    Object userState
)
Visual C++
public:
void GetResellersAsync(
    Object^ userState
)
JavaScript
function getResellersAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetResellersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetSalesman Method

[image]

.NET Framework Class Library
ERPService..::.GetSalesman Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetSalesman", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetSalesman ( _
    pstrSalesman As String _
) As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetSalesman", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetSalesman(
    string pstrSalesman
)
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetSalesman", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetSalesman(
    String^ pstrSalesman
)
JavaScript
function getSalesman(pstrSalesman);

Parameters

pstrSalesman
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetSalesmanAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetSalesmanAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetSalesmanAsync(String) |
GetSalesmanAsync(String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetSalesmanAsync Method (String)

[image]

.NET Framework Class Library
ERPService..::.GetSalesmanAsync Method (String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetSalesmanAsync ( _
    pstrSalesman As String _
)
C#
public void GetSalesmanAsync(
    string pstrSalesman
)
Visual C++
public:
void GetSalesmanAsync(
    String^ pstrSalesman
)
JavaScript
function getSalesmanAsync(pstrSalesman);

Parameters

pstrSalesman
Type: System..::.String

Remarks

See Also

ERPService Class
GetSalesmanAsync Overload
InSite.Domain.InSiteERPService Namespace


GetSalesmanAsync Method (String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetSalesmanAsync Method (String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetSalesmanAsync ( _
    pstrSalesman As String, _
    userState As Object _
)
C#
public void GetSalesmanAsync(
    string pstrSalesman,
    Object userState
)
Visual C++
public:
void GetSalesmanAsync(
    String^ pstrSalesman,
    Object^ userState
)
JavaScript
function getSalesmanAsync(pstrSalesman, userState);

Parameters

pstrSalesman
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetSalesmanAsync Overload
InSite.Domain.InSiteERPService Namespace


GetSalesmen Method

[image]

.NET Framework Class Library
ERPService..::.GetSalesmen Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetSalesmen", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetSalesmen As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetSalesmen", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetSalesmen()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetSalesmen", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetSalesmen()
JavaScript
function getSalesmen();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetSalesmenAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetSalesmenAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetSalesmenAsync()()() |
GetSalesmenAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetSalesmenAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetSalesmenAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetSalesmenAsync
C#
public void GetSalesmenAsync()
Visual C++
public:
void GetSalesmenAsync()
JavaScript
function getSalesmenAsync();

Remarks

See Also

ERPService Class
GetSalesmenAsync Overload
InSite.Domain.InSiteERPService Namespace


GetSalesmenAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetSalesmenAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetSalesmenAsync ( _
    userState As Object _
)
C#
public void GetSalesmenAsync(
    Object userState
)
Visual C++
public:
void GetSalesmenAsync(
    Object^ userState
)
JavaScript
function getSalesmenAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetSalesmenAsync Overload
InSite.Domain.InSiteERPService Namespace


GetShipment Method

[image]

.NET Framework Class Library
ERPService..::.GetShipment Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetShipment", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetShipment ( _
    pstrOrderNumber As String _
) As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetShipment", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetShipment(
    string pstrOrderNumber
)
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetShipment", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetShipment(
    String^ pstrOrderNumber
)
JavaScript
function getShipment(pstrOrderNumber);

Parameters

pstrOrderNumber
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetShipmentAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetShipmentAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetShipmentAsync(String) |
GetShipmentAsync(String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetShipmentAsync Method (String)

[image]

.NET Framework Class Library
ERPService..::.GetShipmentAsync Method (String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetShipmentAsync ( _
    pstrOrderNumber As String _
)
C#
public void GetShipmentAsync(
    string pstrOrderNumber
)
Visual C++
public:
void GetShipmentAsync(
    String^ pstrOrderNumber
)
JavaScript
function getShipmentAsync(pstrOrderNumber);

Parameters

pstrOrderNumber
Type: System..::.String

Remarks

See Also

ERPService Class
GetShipmentAsync Overload
InSite.Domain.InSiteERPService Namespace


GetShipmentAsync Method (String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetShipmentAsync Method (String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetShipmentAsync ( _
    pstrOrderNumber As String, _
    userState As Object _
)
C#
public void GetShipmentAsync(
    string pstrOrderNumber,
    Object userState
)
Visual C++
public:
void GetShipmentAsync(
    String^ pstrOrderNumber,
    Object^ userState
)
JavaScript
function getShipmentAsync(pstrOrderNumber, userState);

Parameters

pstrOrderNumber
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetShipmentAsync Overload
InSite.Domain.InSiteERPService Namespace


GetShipments Method

[image]

.NET Framework Class Library
ERPService..::.GetShipments Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetShipments", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetShipments As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetShipments", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetShipments()
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetShipments", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetShipments()
JavaScript
function getShipments();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetShipmentsAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetShipmentsAsync()()() |
GetShipmentsAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetShipmentsAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetShipmentsAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetShipmentsAsync
C#
public void GetShipmentsAsync()
Visual C++
public:
void GetShipmentsAsync()
JavaScript
function getShipmentsAsync();

Remarks

See Also

ERPService Class
GetShipmentsAsync Overload
InSite.Domain.InSiteERPService Namespace


GetShipmentsAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetShipmentsAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetShipmentsAsync ( _
    userState As Object _
)
C#
public void GetShipmentsAsync(
    Object userState
)
Visual C++
public:
void GetShipmentsAsync(
    Object^ userState
)
JavaScript
function getShipmentsAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetShipmentsAsync Overload
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDate Method

[image]

.NET Framework Class Library
ERPService..::.GetShipmentsByShipmentDate Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetShipmentsByShipmentDate", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetShipmentsByShipmentDate ( _
    pdatShipmentDate As DateTime _
) As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetShipmentsByShipmentDate", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetShipmentsByShipmentDate(
    DateTime pdatShipmentDate
)
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetShipmentsByShipmentDate", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetShipmentsByShipmentDate(
    DateTime pdatShipmentDate
)
JavaScript
function getShipmentsByShipmentDate(pdatShipmentDate);

Parameters

pdatShipmentDate
Type: System..::.DateTime

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetShipmentsByShipmentDateAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetShipmentsByShipmentDateAsync(DateTime) |
GetShipmentsByShipmentDateAsync(DateTime, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateAsync Method (DateTime)

[image]

.NET Framework Class Library
ERPService..::.GetShipmentsByShipmentDateAsync Method (DateTime)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetShipmentsByShipmentDateAsync ( _
    pdatShipmentDate As DateTime _
)
C#
public void GetShipmentsByShipmentDateAsync(
    DateTime pdatShipmentDate
)
Visual C++
public:
void GetShipmentsByShipmentDateAsync(
    DateTime pdatShipmentDate
)
JavaScript
function getShipmentsByShipmentDateAsync(pdatShipmentDate);

Parameters

pdatShipmentDate
Type: System..::.DateTime

Remarks

See Also

ERPService Class
GetShipmentsByShipmentDateAsync Overload
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateAsync Method (DateTime, Object)

[image]

.NET Framework Class Library
ERPService..::.GetShipmentsByShipmentDateAsync Method (DateTime, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetShipmentsByShipmentDateAsync ( _
    pdatShipmentDate As DateTime, _
    userState As Object _
)
C#
public void GetShipmentsByShipmentDateAsync(
    DateTime pdatShipmentDate,
    Object userState
)
Visual C++
public:
void GetShipmentsByShipmentDateAsync(
    DateTime pdatShipmentDate,
    Object^ userState
)
JavaScript
function getShipmentsByShipmentDateAsync(pdatShipmentDate, userState);

Parameters

pdatShipmentDate
Type: System..::.DateTime
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetShipmentsByShipmentDateAsync Overload
InSite.Domain.InSiteERPService Namespace


GetShipTos Method

[image]

.NET Framework Class Library
ERPService..::.GetShipTos Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetShipTos", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetShipTos As DataSet
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetShipTos", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public DataSet GetShipTos()
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetShipTos", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
DataSet^ GetShipTos()
JavaScript
function getShipTos();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetShipTosAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetShipTosAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetShipTosAsync()()() |
GetShipTosAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetShipTosAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetShipTosAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetShipTosAsync
C#
public void GetShipTosAsync()
Visual C++
public:
void GetShipTosAsync()
JavaScript
function getShipTosAsync();

Remarks

See Also

ERPService Class
GetShipTosAsync Overload
InSite.Domain.InSiteERPService Namespace


GetShipTosAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetShipTosAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetShipTosAsync ( _
    userState As Object _
)
C#
public void GetShipTosAsync(
    Object userState
)
Visual C++
public:
void GetShipTosAsync(
    Object^ userState
)
JavaScript
function getShipTosAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetShipTosAsync Overload
InSite.Domain.InSiteERPService Namespace


GetTrackingData Method

[image]

.NET Framework Class Library
ERPService..::.GetTrackingData Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetTrackingData", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetTrackingData As DataSet
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetTrackingData", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public DataSet GetTrackingData()
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetTrackingData", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
DataSet^ GetTrackingData()
JavaScript
function getTrackingData();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetTrackingDataAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetTrackingDataAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetTrackingDataAsync()()() |
GetTrackingDataAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetTrackingDataAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetTrackingDataAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetTrackingDataAsync
C#
public void GetTrackingDataAsync()
Visual C++
public:
void GetTrackingDataAsync()
JavaScript
function getTrackingDataAsync();

Remarks

See Also

ERPService Class
GetTrackingDataAsync Overload
InSite.Domain.InSiteERPService Namespace


GetTrackingDataAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetTrackingDataAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetTrackingDataAsync ( _
    userState As Object _
)
C#
public void GetTrackingDataAsync(
    Object userState
)
Visual C++
public:
void GetTrackingDataAsync(
    Object^ userState
)
JavaScript
function getTrackingDataAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetTrackingDataAsync Overload
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbers Method

[image]

.NET Framework Class Library
ERPService..::.GetTrackingNumbers Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetTrackingNumbers", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function GetTrackingNumbers ( _
    pstrOrderNumber As String _
) As String
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetTrackingNumbers", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public string GetTrackingNumbers(
    string pstrOrderNumber
)
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetTrackingNumbers", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
String^ GetTrackingNumbers(
    String^ pstrOrderNumber
)
JavaScript
function getTrackingNumbers(pstrOrderNumber);

Parameters

pstrOrderNumber
Type: System..::.String

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetTrackingNumbersAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetTrackingNumbersAsync(String) |
GetTrackingNumbersAsync(String, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersAsync Method (String)

[image]

.NET Framework Class Library
ERPService..::.GetTrackingNumbersAsync Method (String)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetTrackingNumbersAsync ( _
    pstrOrderNumber As String _
)
C#
public void GetTrackingNumbersAsync(
    string pstrOrderNumber
)
Visual C++
public:
void GetTrackingNumbersAsync(
    String^ pstrOrderNumber
)
JavaScript
function getTrackingNumbersAsync(pstrOrderNumber);

Parameters

pstrOrderNumber
Type: System..::.String

Remarks

See Also

ERPService Class
GetTrackingNumbersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersAsync Method (String, Object)

[image]

.NET Framework Class Library
ERPService..::.GetTrackingNumbersAsync Method (String, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetTrackingNumbersAsync ( _
    pstrOrderNumber As String, _
    userState As Object _
)
C#
public void GetTrackingNumbersAsync(
    string pstrOrderNumber,
    Object userState
)
Visual C++
public:
void GetTrackingNumbersAsync(
    String^ pstrOrderNumber,
    Object^ userState
)
JavaScript
function getTrackingNumbersAsync(pstrOrderNumber, userState);

Parameters

pstrOrderNumber
Type: System..::.String
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetTrackingNumbersAsync Overload
InSite.Domain.InSiteERPService Namespace


GetVersion Method

[image]

.NET Framework Class Library
ERPService..::.GetVersion Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetVersion", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function GetVersion As String
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/GetVersion", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public string GetVersion()
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/GetVersion", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
String^ GetVersion()
JavaScript
function getVersion();

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetVersionAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetVersionAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetVersionAsync()()() |
GetVersionAsync(Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


GetVersionAsync Method

[image]

.NET Framework Class Library
ERPService..::.GetVersionAsync Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetVersionAsync
C#
public void GetVersionAsync()
Visual C++
public:
void GetVersionAsync()
JavaScript
function getVersionAsync();

Remarks

See Also

ERPService Class
GetVersionAsync Overload
InSite.Domain.InSiteERPService Namespace


GetVersionAsync Method (Object)

[image]

.NET Framework Class Library
ERPService..::.GetVersionAsync Method (Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetVersionAsync ( _
    userState As Object _
)
C#
public void GetVersionAsync(
    Object userState
)
Visual C++
public:
void GetVersionAsync(
    Object^ userState
)
JavaScript
function getVersionAsync(userState);

Parameters

userState
Type: System..::.Object

Remarks

See Also

ERPService Class
GetVersionAsync Overload
InSite.Domain.InSiteERPService Namespace


GetWebResponse Method

[image] [image]

.NET Framework Class Library
ERPService..::.GetWebResponse Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
GetWebResponse(WebRequest) | Returns a response from a synchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)
GetWebResponse(WebRequest, IAsyncResult) | Returns a response from an asynchronous request to an XML Web service method. (Inherited from HttpWebClientProtocol.)

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


InvokeAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.InvokeAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
InvokeAsync(String, array<Object>[]()[], SendOrPostCallback) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)
InvokeAsync(String, array<Object>[]()[], SendOrPostCallback, Object) | Invokes the specified method asynchronously. (Inherited from SoapHttpClientProtocol.)

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
ERPService..::.MemberwiseClone Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


SubmitJournal Method

[image]

.NET Framework Class Library
ERPService..::.SubmitJournal Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/SubmitJournal", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
Public Function SubmitJournal ( _
    ERPJournal As DataSet _
) As String
C#
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/SubmitJournal", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
public string SubmitJournal(
    DataSet ERPJournal
)
Visual C++
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/SubmitJournal", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
public:
String^ SubmitJournal(
    DataSet^ ERPJournal
)
JavaScript
function submitJournal(ERPJournal);

Parameters

ERPJournal
Type: System.Data..::.DataSet

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


SubmitJournalAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.SubmitJournalAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
SubmitJournalAsync(DataSet) |
SubmitJournalAsync(DataSet, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


SubmitJournalAsync Method (DataSet)

[image]

.NET Framework Class Library
ERPService..::.SubmitJournalAsync Method (DataSet)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitJournalAsync ( _
    ERPJournal As DataSet _
)
C#
public void SubmitJournalAsync(
    DataSet ERPJournal
)
Visual C++
public:
void SubmitJournalAsync(
    DataSet^ ERPJournal
)
JavaScript
function submitJournalAsync(ERPJournal);

Parameters

ERPJournal
Type: System.Data..::.DataSet

Remarks

See Also

ERPService Class
SubmitJournalAsync Overload
InSite.Domain.InSiteERPService Namespace


SubmitJournalAsync Method (DataSet, Object)

[image]

.NET Framework Class Library
ERPService..::.SubmitJournalAsync Method (DataSet, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitJournalAsync ( _
    ERPJournal As DataSet, _
    userState As Object _
)
C#
public void SubmitJournalAsync(
    DataSet ERPJournal,
    Object userState
)
Visual C++
public:
void SubmitJournalAsync(
    DataSet^ ERPJournal,
    Object^ userState
)
JavaScript
function submitJournalAsync(ERPJournal, userState);

Parameters

ERPJournal
Type: System.Data..::.DataSet
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
SubmitJournalAsync Overload
InSite.Domain.InSiteERPService Namespace


SubmitOrders Method

[image]

.NET Framework Class Library
ERPService..::.SubmitOrders Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/SubmitOrders", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function SubmitOrders ( _
    ERPOrders As DataSet _
) As String
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/SubmitOrders", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public string SubmitOrders(
    DataSet ERPOrders
)
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/SubmitOrders", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
String^ SubmitOrders(
    DataSet^ ERPOrders
)
JavaScript
function submitOrders(ERPOrders);

Parameters

ERPOrders
Type: System.Data..::.DataSet

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


SubmitOrdersAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.SubmitOrdersAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
SubmitOrdersAsync(DataSet) |
SubmitOrdersAsync(DataSet, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


SubmitOrdersAsync Method (DataSet)

[image]

.NET Framework Class Library
ERPService..::.SubmitOrdersAsync Method (DataSet)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitOrdersAsync ( _
    ERPOrders As DataSet _
)
C#
public void SubmitOrdersAsync(
    DataSet ERPOrders
)
Visual C++
public:
void SubmitOrdersAsync(
    DataSet^ ERPOrders
)
JavaScript
function submitOrdersAsync(ERPOrders);

Parameters

ERPOrders
Type: System.Data..::.DataSet

Remarks

See Also

ERPService Class
SubmitOrdersAsync Overload
InSite.Domain.InSiteERPService Namespace


SubmitOrdersAsync Method (DataSet, Object)

[image]

.NET Framework Class Library
ERPService..::.SubmitOrdersAsync Method (DataSet, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitOrdersAsync ( _
    ERPOrders As DataSet, _
    userState As Object _
)
C#
public void SubmitOrdersAsync(
    DataSet ERPOrders,
    Object userState
)
Visual C++
public:
void SubmitOrdersAsync(
    DataSet^ ERPOrders,
    Object^ userState
)
JavaScript
function submitOrdersAsync(ERPOrders, userState);

Parameters

ERPOrders
Type: System.Data..::.DataSet
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
SubmitOrdersAsync Overload
InSite.Domain.InSiteERPService Namespace


SubmitPayments Method

[image]

.NET Framework Class Library
ERPService..::.SubmitPayments Method
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SoapHeaderAttribute("ServiceAuthHeaderValue")> _
<SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/SubmitPayments", RequestNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    ResponseNamespace := "http://tempuri.org/InSiteERPService/ERPService",  _
    Use := SoapBindingUse.Literal, ParameterStyle := SoapParameterStyle.Wrapped)> _
Public Function SubmitPayments ( _
    ERPPayments As DataSet _
) As String
C#
[SoapHeaderAttribute("ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute("http://tempuri.org/InSiteERPService/ERPService/SubmitPayments", RequestNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = "http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse.Literal, ParameterStyle = SoapParameterStyle.Wrapped)]
public string SubmitPayments(
    DataSet ERPPayments
)
Visual C++
[SoapHeaderAttribute(L"ServiceAuthHeaderValue")]
[SoapDocumentMethodAttribute(L"http://tempuri.org/InSiteERPService/ERPService/SubmitPayments", RequestNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    ResponseNamespace = L"http://tempuri.org/InSiteERPService/ERPService",
    Use = SoapBindingUse::Literal, ParameterStyle = SoapParameterStyle::Wrapped)]
public:
String^ SubmitPayments(
    DataSet^ ERPPayments
)
JavaScript
function submitPayments(ERPPayments);

Parameters

ERPPayments
Type: System.Data..::.DataSet

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


SubmitPaymentsAsync Method

[image] [image]

.NET Framework Class Library
ERPService..::.SubmitPaymentsAsync Method
ERPService Class See Also Send Feedback

Overload List

Name | Description
SubmitPaymentsAsync(DataSet) |
SubmitPaymentsAsync(DataSet, Object) |

See Also

ERPService Class
ERPService Members
InSite.Domain.InSiteERPService Namespace


SubmitPaymentsAsync Method (DataSet)

[image]

.NET Framework Class Library
ERPService..::.SubmitPaymentsAsync Method (DataSet)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitPaymentsAsync ( _
    ERPPayments As DataSet _
)
C#
public void SubmitPaymentsAsync(
    DataSet ERPPayments
)
Visual C++
public:
void SubmitPaymentsAsync(
    DataSet^ ERPPayments
)
JavaScript
function submitPaymentsAsync(ERPPayments);

Parameters

ERPPayments
Type: System.Data..::.DataSet

Remarks

See Also

ERPService Class
SubmitPaymentsAsync Overload
InSite.Domain.InSiteERPService Namespace


SubmitPaymentsAsync Method (DataSet, Object)

[image]

.NET Framework Class Library
ERPService..::.SubmitPaymentsAsync Method (DataSet, Object)
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub SubmitPaymentsAsync ( _
    ERPPayments As DataSet, _
    userState As Object _
)
C#
public void SubmitPaymentsAsync(
    DataSet ERPPayments,
    Object userState
)
Visual C++
public:
void SubmitPaymentsAsync(
    DataSet^ ERPPayments,
    Object^ userState
)
JavaScript
function submitPaymentsAsync(ERPPayments, userState);

Parameters

ERPPayments
Type: System.Data..::.DataSet
userState
Type: System..::.Object

Remarks

See Also

ERPService Class
SubmitPaymentsAsync Overload
InSite.Domain.InSiteERPService Namespace


ERPService Properties

[image] [image]

.NET Framework Class Library
ERPService Properties
ERPService Class See Also Send Feedback

The ERPService type exposes the following members.

Properties

Name | Description
AllowAutoRedirect | Gets or sets whether the client automatically follows server redirects. (Inherited from HttpWebClientProtocol.)
CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
ClientCertificates | Gets the collection of client certificates. (Inherited from HttpWebClientProtocol.)
ConnectionGroupName | Gets or sets the name of the connection group for the request. (Inherited from WebClientProtocol.)
Container | Gets the IContainer that contains the Component. (Inherited from Component.)
CookieContainer | Gets or sets the collection of cookies. (Inherited from HttpWebClientProtocol.)
Credentials | Gets or sets security credentials for XML Web service client authentication. (Inherited from WebClientProtocol.)
DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
EnableDecompression | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true. (Inherited from HttpWebClientProtocol.)
Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
PreAuthenticate | Gets or sets whether pre-authentication is enabled. (Inherited from WebClientProtocol.)
Proxy | Gets or sets proxy information for making an XML Web service request through a firewall. (Inherited from HttpWebClientProtocol.)
RequestEncoding | The Encoding used to make the client request to the XML Web service. (Inherited from WebClientProtocol.)
ServiceAuthHeaderValue |
Site | Gets or sets the ISite of the Component. (Inherited from Component.)
SoapVersion | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from SoapHttpClientProtocol.)
Timeout | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds). (Inherited from WebClientProtocol.)
UnsafeAuthenticatedConnectionSharing | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service. (Inherited from HttpWebClientProtocol.)
Url |
UseDefaultCredentials |
UserAgent | Gets or sets the value for the user agent header that is sent with each request. (Inherited from HttpWebClientProtocol.)

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


ServiceAuthHeaderValue Property

[image]

.NET Framework Class Library
ERPService..::.ServiceAuthHeaderValue Property
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ServiceAuthHeaderValue As ServiceAuthHeader
C#
public ServiceAuthHeader ServiceAuthHeaderValue { get; set; }
Visual C++
public:
property ServiceAuthHeader^ ServiceAuthHeaderValue {
    ServiceAuthHeader^ get ();
    void set (ServiceAuthHeader^ value);
}
JavaScript
function get_serviceAuthHeaderValue();
function set_serviceAuthHeaderValue(value);

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


Url Property

[image]

.NET Framework Class Library
ERPService..::.Url Property
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Url As String
C#
public string Url { get; set; }
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_url();
function set_url(value);

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


UseDefaultCredentials Property

[image]

.NET Framework Class Library
ERPService..::.UseDefaultCredentials Property
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UseDefaultCredentials As Boolean
C#
public bool UseDefaultCredentials { get; set; }
Visual C++
public:
property bool UseDefaultCredentials {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useDefaultCredentials();
function set_useDefaultCredentials(value);

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


ERPService Events

[image] [image]

.NET Framework Class Library
ERPService Events
ERPService Class See Also Send Feedback

The ERPService type exposes the following members.

Events

Name | Description
Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
GetACustomersPricingCompleted |
GetBillTosCompleted |
GetCustomerCompleted |
GetCustomerPricingCompleted |
GetCustomersCompleted |
GetDataSetCompleted |
GetInvoiceCompleted |
GetInvoiceDetailsCompleted |
GetInvoiceHeadersCompleted |
GetInvoicesCompleted |
GetOrderCompleted |
GetOrderDetailsCompleted |
GetOrderHeadersCompleted |
GetOrdersCompleted |
GetPackingListCompleted |
GetProductCompleted |
GetProductsCompleted |
GetResellersCompleted |
GetSalesmanCompleted |
GetSalesmenCompleted |
GetShipmentCompleted |
GetShipmentsByShipmentDateCompleted |
GetShipmentsCompleted |
GetShipTosCompleted |
GetTrackingDataCompleted |
GetTrackingNumbersCompleted |
GetVersionCompleted |
SubmitJournalCompleted |
SubmitOrdersCompleted |
SubmitPaymentsCompleted |

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetACustomersPricingCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetACustomersPricingCompleted As GetACustomersPricingCompletedEventHandler
C#
public event GetACustomersPricingCompletedEventHandler GetACustomersPricingCompleted
Visual C++
public:
 event GetACustomersPricingCompletedEventHandler^ GetACustomersPricingCompleted {
    void add (GetACustomersPricingCompletedEventHandler^ value);
    void remove (GetACustomersPricingCompletedEventHandler^ value);
}
JavaScript
function add_getACustomersPricingCompleted(value);
function remove_getACustomersPricingCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetBillTosCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetBillTosCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetBillTosCompleted As GetBillTosCompletedEventHandler
C#
public event GetBillTosCompletedEventHandler GetBillTosCompleted
Visual C++
public:
 event GetBillTosCompletedEventHandler^ GetBillTosCompleted {
    void add (GetBillTosCompletedEventHandler^ value);
    void remove (GetBillTosCompletedEventHandler^ value);
}
JavaScript
function add_getBillTosCompleted(value);
function remove_getBillTosCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetCustomerCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetCustomerCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetCustomerCompleted As GetCustomerCompletedEventHandler
C#
public event GetCustomerCompletedEventHandler GetCustomerCompleted
Visual C++
public:
 event GetCustomerCompletedEventHandler^ GetCustomerCompleted {
    void add (GetCustomerCompletedEventHandler^ value);
    void remove (GetCustomerCompletedEventHandler^ value);
}
JavaScript
function add_getCustomerCompleted(value);
function remove_getCustomerCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetCustomerPricingCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetCustomerPricingCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetCustomerPricingCompleted As GetCustomerPricingCompletedEventHandler
C#
public event GetCustomerPricingCompletedEventHandler GetCustomerPricingCompleted
Visual C++
public:
 event GetCustomerPricingCompletedEventHandler^ GetCustomerPricingCompleted {
    void add (GetCustomerPricingCompletedEventHandler^ value);
    void remove (GetCustomerPricingCompletedEventHandler^ value);
}
JavaScript
function add_getCustomerPricingCompleted(value);
function remove_getCustomerPricingCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetCustomersCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetCustomersCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetCustomersCompleted As GetCustomersCompletedEventHandler
C#
public event GetCustomersCompletedEventHandler GetCustomersCompleted
Visual C++
public:
 event GetCustomersCompletedEventHandler^ GetCustomersCompleted {
    void add (GetCustomersCompletedEventHandler^ value);
    void remove (GetCustomersCompletedEventHandler^ value);
}
JavaScript
function add_getCustomersCompleted(value);
function remove_getCustomersCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetDataSetCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetDataSetCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetDataSetCompleted As GetDataSetCompletedEventHandler
C#
public event GetDataSetCompletedEventHandler GetDataSetCompleted
Visual C++
public:
 event GetDataSetCompletedEventHandler^ GetDataSetCompleted {
    void add (GetDataSetCompletedEventHandler^ value);
    void remove (GetDataSetCompletedEventHandler^ value);
}
JavaScript
function add_getDataSetCompleted(value);
function remove_getDataSetCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetInvoiceCompleted As GetInvoiceCompletedEventHandler
C#
public event GetInvoiceCompletedEventHandler GetInvoiceCompleted
Visual C++
public:
 event GetInvoiceCompletedEventHandler^ GetInvoiceCompleted {
    void add (GetInvoiceCompletedEventHandler^ value);
    void remove (GetInvoiceCompletedEventHandler^ value);
}
JavaScript
function add_getInvoiceCompleted(value);
function remove_getInvoiceCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceDetailsCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetInvoiceDetailsCompleted As GetInvoiceDetailsCompletedEventHandler
C#
public event GetInvoiceDetailsCompletedEventHandler GetInvoiceDetailsCompleted
Visual C++
public:
 event GetInvoiceDetailsCompletedEventHandler^ GetInvoiceDetailsCompleted {
    void add (GetInvoiceDetailsCompletedEventHandler^ value);
    void remove (GetInvoiceDetailsCompletedEventHandler^ value);
}
JavaScript
function add_getInvoiceDetailsCompleted(value);
function remove_getInvoiceDetailsCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetInvoiceHeadersCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetInvoiceHeadersCompleted As GetInvoiceHeadersCompletedEventHandler
C#
public event GetInvoiceHeadersCompletedEventHandler GetInvoiceHeadersCompleted
Visual C++
public:
 event GetInvoiceHeadersCompletedEventHandler^ GetInvoiceHeadersCompleted {
    void add (GetInvoiceHeadersCompletedEventHandler^ value);
    void remove (GetInvoiceHeadersCompletedEventHandler^ value);
}
JavaScript
function add_getInvoiceHeadersCompleted(value);
function remove_getInvoiceHeadersCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetInvoicesCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetInvoicesCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetInvoicesCompleted As GetInvoicesCompletedEventHandler
C#
public event GetInvoicesCompletedEventHandler GetInvoicesCompleted
Visual C++
public:
 event GetInvoicesCompletedEventHandler^ GetInvoicesCompleted {
    void add (GetInvoicesCompletedEventHandler^ value);
    void remove (GetInvoicesCompletedEventHandler^ value);
}
JavaScript
function add_getInvoicesCompleted(value);
function remove_getInvoicesCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetOrderCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetOrderCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetOrderCompleted As GetOrderCompletedEventHandler
C#
public event GetOrderCompletedEventHandler GetOrderCompleted
Visual C++
public:
 event GetOrderCompletedEventHandler^ GetOrderCompleted {
    void add (GetOrderCompletedEventHandler^ value);
    void remove (GetOrderCompletedEventHandler^ value);
}
JavaScript
function add_getOrderCompleted(value);
function remove_getOrderCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetOrderDetailsCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetOrderDetailsCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetOrderDetailsCompleted As GetOrderDetailsCompletedEventHandler
C#
public event GetOrderDetailsCompletedEventHandler GetOrderDetailsCompleted
Visual C++
public:
 event GetOrderDetailsCompletedEventHandler^ GetOrderDetailsCompleted {
    void add (GetOrderDetailsCompletedEventHandler^ value);
    void remove (GetOrderDetailsCompletedEventHandler^ value);
}
JavaScript
function add_getOrderDetailsCompleted(value);
function remove_getOrderDetailsCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetOrderHeadersCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetOrderHeadersCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetOrderHeadersCompleted As GetOrderHeadersCompletedEventHandler
C#
public event GetOrderHeadersCompletedEventHandler GetOrderHeadersCompleted
Visual C++
public:
 event GetOrderHeadersCompletedEventHandler^ GetOrderHeadersCompleted {
    void add (GetOrderHeadersCompletedEventHandler^ value);
    void remove (GetOrderHeadersCompletedEventHandler^ value);
}
JavaScript
function add_getOrderHeadersCompleted(value);
function remove_getOrderHeadersCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetOrdersCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetOrdersCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetOrdersCompleted As GetOrdersCompletedEventHandler
C#
public event GetOrdersCompletedEventHandler GetOrdersCompleted
Visual C++
public:
 event GetOrdersCompletedEventHandler^ GetOrdersCompleted {
    void add (GetOrdersCompletedEventHandler^ value);
    void remove (GetOrdersCompletedEventHandler^ value);
}
JavaScript
function add_getOrdersCompleted(value);
function remove_getOrdersCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetPackingListCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetPackingListCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetPackingListCompleted As GetPackingListCompletedEventHandler
C#
public event GetPackingListCompletedEventHandler GetPackingListCompleted
Visual C++
public:
 event GetPackingListCompletedEventHandler^ GetPackingListCompleted {
    void add (GetPackingListCompletedEventHandler^ value);
    void remove (GetPackingListCompletedEventHandler^ value);
}
JavaScript
function add_getPackingListCompleted(value);
function remove_getPackingListCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetProductCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetProductCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetProductCompleted As GetProductCompletedEventHandler
C#
public event GetProductCompletedEventHandler GetProductCompleted
Visual C++
public:
 event GetProductCompletedEventHandler^ GetProductCompleted {
    void add (GetProductCompletedEventHandler^ value);
    void remove (GetProductCompletedEventHandler^ value);
}
JavaScript
function add_getProductCompleted(value);
function remove_getProductCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetProductsCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetProductsCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetProductsCompleted As GetProductsCompletedEventHandler
C#
public event GetProductsCompletedEventHandler GetProductsCompleted
Visual C++
public:
 event GetProductsCompletedEventHandler^ GetProductsCompleted {
    void add (GetProductsCompletedEventHandler^ value);
    void remove (GetProductsCompletedEventHandler^ value);
}
JavaScript
function add_getProductsCompleted(value);
function remove_getProductsCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetResellersCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetResellersCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetResellersCompleted As GetResellersCompletedEventHandler
C#
public event GetResellersCompletedEventHandler GetResellersCompleted
Visual C++
public:
 event GetResellersCompletedEventHandler^ GetResellersCompleted {
    void add (GetResellersCompletedEventHandler^ value);
    void remove (GetResellersCompletedEventHandler^ value);
}
JavaScript
function add_getResellersCompleted(value);
function remove_getResellersCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetSalesmanCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetSalesmanCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetSalesmanCompleted As GetSalesmanCompletedEventHandler
C#
public event GetSalesmanCompletedEventHandler GetSalesmanCompleted
Visual C++
public:
 event GetSalesmanCompletedEventHandler^ GetSalesmanCompleted {
    void add (GetSalesmanCompletedEventHandler^ value);
    void remove (GetSalesmanCompletedEventHandler^ value);
}
JavaScript
function add_getSalesmanCompleted(value);
function remove_getSalesmanCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetSalesmenCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetSalesmenCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetSalesmenCompleted As GetSalesmenCompletedEventHandler
C#
public event GetSalesmenCompletedEventHandler GetSalesmenCompleted
Visual C++
public:
 event GetSalesmenCompletedEventHandler^ GetSalesmenCompleted {
    void add (GetSalesmenCompletedEventHandler^ value);
    void remove (GetSalesmenCompletedEventHandler^ value);
}
JavaScript
function add_getSalesmenCompleted(value);
function remove_getSalesmenCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetShipmentCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetShipmentCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetShipmentCompleted As GetShipmentCompletedEventHandler
C#
public event GetShipmentCompletedEventHandler GetShipmentCompleted
Visual C++
public:
 event GetShipmentCompletedEventHandler^ GetShipmentCompleted {
    void add (GetShipmentCompletedEventHandler^ value);
    void remove (GetShipmentCompletedEventHandler^ value);
}
JavaScript
function add_getShipmentCompleted(value);
function remove_getShipmentCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetShipmentsByShipmentDateCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetShipmentsByShipmentDateCompleted As GetShipmentsByShipmentDateCompletedEventHandler
C#
public event GetShipmentsByShipmentDateCompletedEventHandler GetShipmentsByShipmentDateCompleted
Visual C++
public:
 event GetShipmentsByShipmentDateCompletedEventHandler^ GetShipmentsByShipmentDateCompleted {
    void add (GetShipmentsByShipmentDateCompletedEventHandler^ value);
    void remove (GetShipmentsByShipmentDateCompletedEventHandler^ value);
}
JavaScript
function add_getShipmentsByShipmentDateCompleted(value);
function remove_getShipmentsByShipmentDateCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetShipmentsCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetShipmentsCompleted As GetShipmentsCompletedEventHandler
C#
public event GetShipmentsCompletedEventHandler GetShipmentsCompleted
Visual C++
public:
 event GetShipmentsCompletedEventHandler^ GetShipmentsCompleted {
    void add (GetShipmentsCompletedEventHandler^ value);
    void remove (GetShipmentsCompletedEventHandler^ value);
}
JavaScript
function add_getShipmentsCompleted(value);
function remove_getShipmentsCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetShipTosCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetShipTosCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetShipTosCompleted As GetShipTosCompletedEventHandler
C#
public event GetShipTosCompletedEventHandler GetShipTosCompleted
Visual C++
public:
 event GetShipTosCompletedEventHandler^ GetShipTosCompleted {
    void add (GetShipTosCompletedEventHandler^ value);
    void remove (GetShipTosCompletedEventHandler^ value);
}
JavaScript
function add_getShipTosCompleted(value);
function remove_getShipTosCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetTrackingDataCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetTrackingDataCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetTrackingDataCompleted As GetTrackingDataCompletedEventHandler
C#
public event GetTrackingDataCompletedEventHandler GetTrackingDataCompleted
Visual C++
public:
 event GetTrackingDataCompletedEventHandler^ GetTrackingDataCompleted {
    void add (GetTrackingDataCompletedEventHandler^ value);
    void remove (GetTrackingDataCompletedEventHandler^ value);
}
JavaScript
function add_getTrackingDataCompleted(value);
function remove_getTrackingDataCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetTrackingNumbersCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetTrackingNumbersCompleted As GetTrackingNumbersCompletedEventHandler
C#
public event GetTrackingNumbersCompletedEventHandler GetTrackingNumbersCompleted
Visual C++
public:
 event GetTrackingNumbersCompletedEventHandler^ GetTrackingNumbersCompleted {
    void add (GetTrackingNumbersCompletedEventHandler^ value);
    void remove (GetTrackingNumbersCompletedEventHandler^ value);
}
JavaScript
function add_getTrackingNumbersCompleted(value);
function remove_getTrackingNumbersCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetVersionCompleted Event

[image]

.NET Framework Class Library
ERPService..::.GetVersionCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event GetVersionCompleted As GetVersionCompletedEventHandler
C#
public event GetVersionCompletedEventHandler GetVersionCompleted
Visual C++
public:
 event GetVersionCompletedEventHandler^ GetVersionCompleted {
    void add (GetVersionCompletedEventHandler^ value);
    void remove (GetVersionCompletedEventHandler^ value);
}
JavaScript
function add_getVersionCompleted(value);
function remove_getVersionCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


SubmitJournalCompleted Event

[image]

.NET Framework Class Library
ERPService..::.SubmitJournalCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event SubmitJournalCompleted As SubmitJournalCompletedEventHandler
C#
public event SubmitJournalCompletedEventHandler SubmitJournalCompleted
Visual C++
public:
 event SubmitJournalCompletedEventHandler^ SubmitJournalCompleted {
    void add (SubmitJournalCompletedEventHandler^ value);
    void remove (SubmitJournalCompletedEventHandler^ value);
}
JavaScript
function add_submitJournalCompleted(value);
function remove_submitJournalCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


SubmitOrdersCompleted Event

[image]

.NET Framework Class Library
ERPService..::.SubmitOrdersCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event SubmitOrdersCompleted As SubmitOrdersCompletedEventHandler
C#
public event SubmitOrdersCompletedEventHandler SubmitOrdersCompleted
Visual C++
public:
 event SubmitOrdersCompletedEventHandler^ SubmitOrdersCompleted {
    void add (SubmitOrdersCompletedEventHandler^ value);
    void remove (SubmitOrdersCompletedEventHandler^ value);
}
JavaScript
function add_submitOrdersCompleted(value);
function remove_submitOrdersCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


SubmitPaymentsCompleted Event

[image]

.NET Framework Class Library
ERPService..::.SubmitPaymentsCompleted Event
ERPService Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Event SubmitPaymentsCompleted As SubmitPaymentsCompletedEventHandler
C#
public event SubmitPaymentsCompletedEventHandler SubmitPaymentsCompleted
Visual C++
public:
 event SubmitPaymentsCompletedEventHandler^ SubmitPaymentsCompleted {
    void add (SubmitPaymentsCompletedEventHandler^ value);
    void remove (SubmitPaymentsCompletedEventHandler^ value);
}
JavaScript
function add_submitPaymentsCompleted(value);
function remove_submitPaymentsCompleted(value);

Remarks

See Also

ERPService Class
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingCompletedEventArgs Class

[image]

.NET Framework Class Library
GetACustomersPricingCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetACustomersPricingCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetACustomersPricingCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetACustomersPricingCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetACustomersPricingCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetACustomersPricingCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetACustomersPricingCompletedEventArgs

See Also

GetACustomersPricingCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetACustomersPricingCompletedEventArgs Members
GetACustomersPricingCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetACustomersPricingCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetACustomersPricingCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetACustomersPricingCompletedEventArgs Methods
GetACustomersPricingCompletedEventArgs Class See Also Send Feedback

The GetACustomersPricingCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetACustomersPricingCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetACustomersPricingCompletedEventArgs Properties
GetACustomersPricingCompletedEventArgs Class See Also Send Feedback

The GetACustomersPricingCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetACustomersPricingCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetACustomersPricingCompletedEventArgs..::.Result Property
GetACustomersPricingCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetACustomersPricingCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetACustomersPricingCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetACustomersPricingCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetACustomersPricingCompletedEventHandler ( _
    sender As Object, _
    e As GetACustomersPricingCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetACustomersPricingCompletedEventHandler(
    Object sender,
    GetACustomersPricingCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetACustomersPricingCompletedEventHandler(
    Object^ sender,
    GetACustomersPricingCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetACustomersPricingCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetBillTosCompletedEventArgs Class

[image]

.NET Framework Class Library
GetBillTosCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetBillTosCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetBillTosCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetBillTosCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetBillTosCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetBillTosCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetBillTosCompletedEventArgs

See Also

GetBillTosCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetBillTosCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetBillTosCompletedEventArgs Members
GetBillTosCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetBillTosCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetBillTosCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetBillTosCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetBillTosCompletedEventArgs Methods
GetBillTosCompletedEventArgs Class See Also Send Feedback

The GetBillTosCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetBillTosCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetBillTosCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetBillTosCompletedEventArgs Properties
GetBillTosCompletedEventArgs Class See Also Send Feedback

The GetBillTosCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetBillTosCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetBillTosCompletedEventArgs..::.Result Property
GetBillTosCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetBillTosCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetBillTosCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetBillTosCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetBillTosCompletedEventHandler ( _
    sender As Object, _
    e As GetBillTosCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetBillTosCompletedEventHandler(
    Object sender,
    GetBillTosCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetBillTosCompletedEventHandler(
    Object^ sender,
    GetBillTosCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetBillTosCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetCustomerCompletedEventArgs Class

[image]

.NET Framework Class Library
GetCustomerCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetCustomerCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetCustomerCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetCustomerCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetCustomerCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetCustomerCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetCustomerCompletedEventArgs

See Also

GetCustomerCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetCustomerCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetCustomerCompletedEventArgs Members
GetCustomerCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetCustomerCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomerCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetCustomerCompletedEventArgs Methods
GetCustomerCompletedEventArgs Class See Also Send Feedback

The GetCustomerCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomerCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomerCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetCustomerCompletedEventArgs Properties
GetCustomerCompletedEventArgs Class See Also Send Feedback

The GetCustomerCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetCustomerCompletedEventArgs..::.Result Property
GetCustomerCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetCustomerCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomerCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetCustomerCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetCustomerCompletedEventHandler ( _
    sender As Object, _
    e As GetCustomerCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetCustomerCompletedEventHandler(
    Object sender,
    GetCustomerCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetCustomerCompletedEventHandler(
    Object^ sender,
    GetCustomerCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetCustomerCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetCustomerPricingCompletedEventArgs Class

[image]

.NET Framework Class Library
GetCustomerPricingCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetCustomerPricingCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetCustomerPricingCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetCustomerPricingCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetCustomerPricingCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetCustomerPricingCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetCustomerPricingCompletedEventArgs

See Also

GetCustomerPricingCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetCustomerPricingCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetCustomerPricingCompletedEventArgs Members
GetCustomerPricingCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetCustomerPricingCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerPricingCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomerPricingCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetCustomerPricingCompletedEventArgs Methods
GetCustomerPricingCompletedEventArgs Class See Also Send Feedback

The GetCustomerPricingCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomerPricingCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomerPricingCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetCustomerPricingCompletedEventArgs Properties
GetCustomerPricingCompletedEventArgs Class See Also Send Feedback

The GetCustomerPricingCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomerPricingCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetCustomerPricingCompletedEventArgs..::.Result Property
GetCustomerPricingCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetCustomerPricingCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomerPricingCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetCustomerPricingCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetCustomerPricingCompletedEventHandler ( _
    sender As Object, _
    e As GetCustomerPricingCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetCustomerPricingCompletedEventHandler(
    Object sender,
    GetCustomerPricingCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetCustomerPricingCompletedEventHandler(
    Object^ sender,
    GetCustomerPricingCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetCustomerPricingCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetCustomersCompletedEventArgs Class

[image]

.NET Framework Class Library
GetCustomersCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetCustomersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetCustomersCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetCustomersCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetCustomersCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetCustomersCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetCustomersCompletedEventArgs

See Also

GetCustomersCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetCustomersCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetCustomersCompletedEventArgs Members
GetCustomersCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetCustomersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomersCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetCustomersCompletedEventArgs Methods
GetCustomersCompletedEventArgs Class See Also Send Feedback

The GetCustomersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetCustomersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomersCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetCustomersCompletedEventArgs Properties
GetCustomersCompletedEventArgs Class See Also Send Feedback

The GetCustomersCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetCustomersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetCustomersCompletedEventArgs..::.Result Property
GetCustomersCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetCustomersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetCustomersCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetCustomersCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetCustomersCompletedEventHandler ( _
    sender As Object, _
    e As GetCustomersCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetCustomersCompletedEventHandler(
    Object sender,
    GetCustomersCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetCustomersCompletedEventHandler(
    Object^ sender,
    GetCustomersCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetCustomersCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetDataSetCompletedEventArgs Class

[image]

.NET Framework Class Library
GetDataSetCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetDataSetCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetDataSetCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetDataSetCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetDataSetCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetDataSetCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetDataSetCompletedEventArgs

See Also

GetDataSetCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetDataSetCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetDataSetCompletedEventArgs Members
GetDataSetCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetDataSetCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetDataSetCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetDataSetCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetDataSetCompletedEventArgs Methods
GetDataSetCompletedEventArgs Class See Also Send Feedback

The GetDataSetCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetDataSetCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetDataSetCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetDataSetCompletedEventArgs Properties
GetDataSetCompletedEventArgs Class See Also Send Feedback

The GetDataSetCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetDataSetCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetDataSetCompletedEventArgs..::.Result Property
GetDataSetCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetDataSetCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetDataSetCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetDataSetCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetDataSetCompletedEventHandler ( _
    sender As Object, _
    e As GetDataSetCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetDataSetCompletedEventHandler(
    Object sender,
    GetDataSetCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetDataSetCompletedEventHandler(
    Object^ sender,
    GetDataSetCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetDataSetCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetInvoiceCompletedEventArgs Class

[image]

.NET Framework Class Library
GetInvoiceCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetInvoiceCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetInvoiceCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetInvoiceCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetInvoiceCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetInvoiceCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetInvoiceCompletedEventArgs

See Also

GetInvoiceCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetInvoiceCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetInvoiceCompletedEventArgs Members
GetInvoiceCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetInvoiceCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInvoiceCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetInvoiceCompletedEventArgs Methods
GetInvoiceCompletedEventArgs Class See Also Send Feedback

The GetInvoiceCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInvoiceCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetInvoiceCompletedEventArgs Properties
GetInvoiceCompletedEventArgs Class See Also Send Feedback

The GetInvoiceCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInvoiceCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetInvoiceCompletedEventArgs..::.Result Property
GetInvoiceCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetInvoiceCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetInvoiceCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetInvoiceCompletedEventHandler ( _
    sender As Object, _
    e As GetInvoiceCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetInvoiceCompletedEventHandler(
    Object sender,
    GetInvoiceCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetInvoiceCompletedEventHandler(
    Object^ sender,
    GetInvoiceCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetInvoiceCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsCompletedEventArgs Class

[image]

.NET Framework Class Library
GetInvoiceDetailsCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetInvoiceDetailsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetInvoiceDetailsCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetInvoiceDetailsCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetInvoiceDetailsCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetInvoiceDetailsCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetInvoiceDetailsCompletedEventArgs

See Also

GetInvoiceDetailsCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetInvoiceDetailsCompletedEventArgs Members
GetInvoiceDetailsCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetInvoiceDetailsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInvoiceDetailsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetInvoiceDetailsCompletedEventArgs Methods
GetInvoiceDetailsCompletedEventArgs Class See Also Send Feedback

The GetInvoiceDetailsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInvoiceDetailsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetInvoiceDetailsCompletedEventArgs Properties
GetInvoiceDetailsCompletedEventArgs Class See Also Send Feedback

The GetInvoiceDetailsCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInvoiceDetailsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetInvoiceDetailsCompletedEventArgs..::.Result Property
GetInvoiceDetailsCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetInvoiceDetailsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceDetailsCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetInvoiceDetailsCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetInvoiceDetailsCompletedEventHandler ( _
    sender As Object, _
    e As GetInvoiceDetailsCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetInvoiceDetailsCompletedEventHandler(
    Object sender,
    GetInvoiceDetailsCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetInvoiceDetailsCompletedEventHandler(
    Object^ sender,
    GetInvoiceDetailsCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetInvoiceDetailsCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersCompletedEventArgs Class

[image]

.NET Framework Class Library
GetInvoiceHeadersCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetInvoiceHeadersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetInvoiceHeadersCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetInvoiceHeadersCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetInvoiceHeadersCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetInvoiceHeadersCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetInvoiceHeadersCompletedEventArgs

See Also

GetInvoiceHeadersCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetInvoiceHeadersCompletedEventArgs Members
GetInvoiceHeadersCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetInvoiceHeadersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInvoiceHeadersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetInvoiceHeadersCompletedEventArgs Methods
GetInvoiceHeadersCompletedEventArgs Class See Also Send Feedback

The GetInvoiceHeadersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInvoiceHeadersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetInvoiceHeadersCompletedEventArgs Properties
GetInvoiceHeadersCompletedEventArgs Class See Also Send Feedback

The GetInvoiceHeadersCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInvoiceHeadersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetInvoiceHeadersCompletedEventArgs..::.Result Property
GetInvoiceHeadersCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetInvoiceHeadersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoiceHeadersCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetInvoiceHeadersCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetInvoiceHeadersCompletedEventHandler ( _
    sender As Object, _
    e As GetInvoiceHeadersCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetInvoiceHeadersCompletedEventHandler(
    Object sender,
    GetInvoiceHeadersCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetInvoiceHeadersCompletedEventHandler(
    Object^ sender,
    GetInvoiceHeadersCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetInvoiceHeadersCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetInvoicesCompletedEventArgs Class

[image]

.NET Framework Class Library
GetInvoicesCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetInvoicesCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetInvoicesCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetInvoicesCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetInvoicesCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetInvoicesCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetInvoicesCompletedEventArgs

See Also

GetInvoicesCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetInvoicesCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetInvoicesCompletedEventArgs Members
GetInvoicesCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetInvoicesCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInvoicesCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoicesCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetInvoicesCompletedEventArgs Methods
GetInvoicesCompletedEventArgs Class See Also Send Feedback

The GetInvoicesCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetInvoicesCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoicesCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetInvoicesCompletedEventArgs Properties
GetInvoicesCompletedEventArgs Class See Also Send Feedback

The GetInvoicesCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetInvoicesCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetInvoicesCompletedEventArgs..::.Result Property
GetInvoicesCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetInvoicesCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetInvoicesCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetInvoicesCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetInvoicesCompletedEventHandler ( _
    sender As Object, _
    e As GetInvoicesCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetInvoicesCompletedEventHandler(
    Object sender,
    GetInvoicesCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetInvoicesCompletedEventHandler(
    Object^ sender,
    GetInvoicesCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetInvoicesCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetOrderCompletedEventArgs Class

[image]

.NET Framework Class Library
GetOrderCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetOrderCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetOrderCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetOrderCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetOrderCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetOrderCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetOrderCompletedEventArgs

See Also

GetOrderCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetOrderCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetOrderCompletedEventArgs Members
GetOrderCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetOrderCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrderCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetOrderCompletedEventArgs Methods
GetOrderCompletedEventArgs Class See Also Send Feedback

The GetOrderCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetOrderCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetOrderCompletedEventArgs Properties
GetOrderCompletedEventArgs Class See Also Send Feedback

The GetOrderCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrderCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetOrderCompletedEventArgs..::.Result Property
GetOrderCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetOrderCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetOrderCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetOrderCompletedEventHandler ( _
    sender As Object, _
    e As GetOrderCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetOrderCompletedEventHandler(
    Object sender,
    GetOrderCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetOrderCompletedEventHandler(
    Object^ sender,
    GetOrderCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetOrderCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetOrderDetailsCompletedEventArgs Class

[image]

.NET Framework Class Library
GetOrderDetailsCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetOrderDetailsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetOrderDetailsCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetOrderDetailsCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetOrderDetailsCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetOrderDetailsCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetOrderDetailsCompletedEventArgs

See Also

GetOrderDetailsCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetOrderDetailsCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetOrderDetailsCompletedEventArgs Members
GetOrderDetailsCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetOrderDetailsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrderDetailsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderDetailsCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetOrderDetailsCompletedEventArgs Methods
GetOrderDetailsCompletedEventArgs Class See Also Send Feedback

The GetOrderDetailsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetOrderDetailsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderDetailsCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetOrderDetailsCompletedEventArgs Properties
GetOrderDetailsCompletedEventArgs Class See Also Send Feedback

The GetOrderDetailsCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrderDetailsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetOrderDetailsCompletedEventArgs..::.Result Property
GetOrderDetailsCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetOrderDetailsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderDetailsCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetOrderDetailsCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetOrderDetailsCompletedEventHandler ( _
    sender As Object, _
    e As GetOrderDetailsCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetOrderDetailsCompletedEventHandler(
    Object sender,
    GetOrderDetailsCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetOrderDetailsCompletedEventHandler(
    Object^ sender,
    GetOrderDetailsCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetOrderDetailsCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetOrderHeadersCompletedEventArgs Class

[image]

.NET Framework Class Library
GetOrderHeadersCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetOrderHeadersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetOrderHeadersCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetOrderHeadersCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetOrderHeadersCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetOrderHeadersCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetOrderHeadersCompletedEventArgs

See Also

GetOrderHeadersCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetOrderHeadersCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetOrderHeadersCompletedEventArgs Members
GetOrderHeadersCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetOrderHeadersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrderHeadersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderHeadersCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetOrderHeadersCompletedEventArgs Methods
GetOrderHeadersCompletedEventArgs Class See Also Send Feedback

The GetOrderHeadersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetOrderHeadersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderHeadersCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetOrderHeadersCompletedEventArgs Properties
GetOrderHeadersCompletedEventArgs Class See Also Send Feedback

The GetOrderHeadersCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrderHeadersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetOrderHeadersCompletedEventArgs..::.Result Property
GetOrderHeadersCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetOrderHeadersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrderHeadersCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetOrderHeadersCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetOrderHeadersCompletedEventHandler ( _
    sender As Object, _
    e As GetOrderHeadersCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetOrderHeadersCompletedEventHandler(
    Object sender,
    GetOrderHeadersCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetOrderHeadersCompletedEventHandler(
    Object^ sender,
    GetOrderHeadersCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetOrderHeadersCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetOrdersCompletedEventArgs Class

[image]

.NET Framework Class Library
GetOrdersCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetOrdersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetOrdersCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetOrdersCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetOrdersCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetOrdersCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetOrdersCompletedEventArgs

See Also

GetOrdersCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetOrdersCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetOrdersCompletedEventArgs Members
GetOrdersCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetOrdersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrdersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrdersCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetOrdersCompletedEventArgs Methods
GetOrdersCompletedEventArgs Class See Also Send Feedback

The GetOrdersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetOrdersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrdersCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetOrdersCompletedEventArgs Properties
GetOrdersCompletedEventArgs Class See Also Send Feedback

The GetOrdersCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetOrdersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetOrdersCompletedEventArgs..::.Result Property
GetOrdersCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetOrdersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetOrdersCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetOrdersCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetOrdersCompletedEventHandler ( _
    sender As Object, _
    e As GetOrdersCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetOrdersCompletedEventHandler(
    Object sender,
    GetOrdersCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetOrdersCompletedEventHandler(
    Object^ sender,
    GetOrdersCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetOrdersCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetPackingListCompletedEventArgs Class

[image]

.NET Framework Class Library
GetPackingListCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetPackingListCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetPackingListCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetPackingListCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetPackingListCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetPackingListCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetPackingListCompletedEventArgs

See Also

GetPackingListCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetPackingListCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetPackingListCompletedEventArgs Members
GetPackingListCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetPackingListCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPackingListCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetPackingListCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetPackingListCompletedEventArgs Methods
GetPackingListCompletedEventArgs Class See Also Send Feedback

The GetPackingListCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetPackingListCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetPackingListCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetPackingListCompletedEventArgs Properties
GetPackingListCompletedEventArgs Class See Also Send Feedback

The GetPackingListCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetPackingListCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetPackingListCompletedEventArgs..::.Result Property
GetPackingListCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetPackingListCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetPackingListCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetPackingListCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetPackingListCompletedEventHandler ( _
    sender As Object, _
    e As GetPackingListCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetPackingListCompletedEventHandler(
    Object sender,
    GetPackingListCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetPackingListCompletedEventHandler(
    Object^ sender,
    GetPackingListCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetPackingListCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetProductCompletedEventArgs Class

[image]

.NET Framework Class Library
GetProductCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetProductCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetProductCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetProductCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetProductCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetProductCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetProductCompletedEventArgs

See Also

GetProductCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetProductCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetProductCompletedEventArgs Members
GetProductCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetProductCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetProductCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetProductCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetProductCompletedEventArgs Methods
GetProductCompletedEventArgs Class See Also Send Feedback

The GetProductCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetProductCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetProductCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetProductCompletedEventArgs Properties
GetProductCompletedEventArgs Class See Also Send Feedback

The GetProductCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetProductCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetProductCompletedEventArgs..::.Result Property
GetProductCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetProductCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetProductCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetProductCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetProductCompletedEventHandler ( _
    sender As Object, _
    e As GetProductCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetProductCompletedEventHandler(
    Object sender,
    GetProductCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetProductCompletedEventHandler(
    Object^ sender,
    GetProductCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetProductCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetProductsCompletedEventArgs Class

[image]

.NET Framework Class Library
GetProductsCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetProductsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetProductsCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetProductsCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetProductsCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetProductsCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetProductsCompletedEventArgs

See Also

GetProductsCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetProductsCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetProductsCompletedEventArgs Members
GetProductsCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetProductsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetProductsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetProductsCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetProductsCompletedEventArgs Methods
GetProductsCompletedEventArgs Class See Also Send Feedback

The GetProductsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetProductsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetProductsCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetProductsCompletedEventArgs Properties
GetProductsCompletedEventArgs Class See Also Send Feedback

The GetProductsCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetProductsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetProductsCompletedEventArgs..::.Result Property
GetProductsCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetProductsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetProductsCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetProductsCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetProductsCompletedEventHandler ( _
    sender As Object, _
    e As GetProductsCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetProductsCompletedEventHandler(
    Object sender,
    GetProductsCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetProductsCompletedEventHandler(
    Object^ sender,
    GetProductsCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetProductsCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetResellersCompletedEventArgs Class

[image]

.NET Framework Class Library
GetResellersCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetResellersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetResellersCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetResellersCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetResellersCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetResellersCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetResellersCompletedEventArgs

See Also

GetResellersCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetResellersCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetResellersCompletedEventArgs Members
GetResellersCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetResellersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetResellersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetResellersCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetResellersCompletedEventArgs Methods
GetResellersCompletedEventArgs Class See Also Send Feedback

The GetResellersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetResellersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetResellersCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetResellersCompletedEventArgs Properties
GetResellersCompletedEventArgs Class See Also Send Feedback

The GetResellersCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetResellersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetResellersCompletedEventArgs..::.Result Property
GetResellersCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetResellersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetResellersCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetResellersCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetResellersCompletedEventHandler ( _
    sender As Object, _
    e As GetResellersCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetResellersCompletedEventHandler(
    Object sender,
    GetResellersCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetResellersCompletedEventHandler(
    Object^ sender,
    GetResellersCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetResellersCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetSalesmanCompletedEventArgs Class

[image]

.NET Framework Class Library
GetSalesmanCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetSalesmanCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetSalesmanCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetSalesmanCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetSalesmanCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetSalesmanCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetSalesmanCompletedEventArgs

See Also

GetSalesmanCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetSalesmanCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetSalesmanCompletedEventArgs Members
GetSalesmanCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetSalesmanCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetSalesmanCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetSalesmanCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetSalesmanCompletedEventArgs Methods
GetSalesmanCompletedEventArgs Class See Also Send Feedback

The GetSalesmanCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetSalesmanCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetSalesmanCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetSalesmanCompletedEventArgs Properties
GetSalesmanCompletedEventArgs Class See Also Send Feedback

The GetSalesmanCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetSalesmanCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetSalesmanCompletedEventArgs..::.Result Property
GetSalesmanCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetSalesmanCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetSalesmanCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetSalesmanCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetSalesmanCompletedEventHandler ( _
    sender As Object, _
    e As GetSalesmanCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetSalesmanCompletedEventHandler(
    Object sender,
    GetSalesmanCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetSalesmanCompletedEventHandler(
    Object^ sender,
    GetSalesmanCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetSalesmanCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetSalesmenCompletedEventArgs Class

[image]

.NET Framework Class Library
GetSalesmenCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetSalesmenCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetSalesmenCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetSalesmenCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetSalesmenCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetSalesmenCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetSalesmenCompletedEventArgs

See Also

GetSalesmenCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetSalesmenCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetSalesmenCompletedEventArgs Members
GetSalesmenCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetSalesmenCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetSalesmenCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetSalesmenCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetSalesmenCompletedEventArgs Methods
GetSalesmenCompletedEventArgs Class See Also Send Feedback

The GetSalesmenCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetSalesmenCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetSalesmenCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetSalesmenCompletedEventArgs Properties
GetSalesmenCompletedEventArgs Class See Also Send Feedback

The GetSalesmenCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetSalesmenCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetSalesmenCompletedEventArgs..::.Result Property
GetSalesmenCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetSalesmenCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetSalesmenCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetSalesmenCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetSalesmenCompletedEventHandler ( _
    sender As Object, _
    e As GetSalesmenCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetSalesmenCompletedEventHandler(
    Object sender,
    GetSalesmenCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetSalesmenCompletedEventHandler(
    Object^ sender,
    GetSalesmenCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetSalesmenCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetShipmentCompletedEventArgs Class

[image]

.NET Framework Class Library
GetShipmentCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetShipmentCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetShipmentCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetShipmentCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetShipmentCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetShipmentCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetShipmentCompletedEventArgs

See Also

GetShipmentCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetShipmentCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetShipmentCompletedEventArgs Members
GetShipmentCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetShipmentCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetShipmentCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetShipmentCompletedEventArgs Methods
GetShipmentCompletedEventArgs Class See Also Send Feedback

The GetShipmentCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetShipmentCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetShipmentCompletedEventArgs Properties
GetShipmentCompletedEventArgs Class See Also Send Feedback

The GetShipmentCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetShipmentCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetShipmentCompletedEventArgs..::.Result Property
GetShipmentCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetShipmentCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetShipmentCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetShipmentCompletedEventHandler ( _
    sender As Object, _
    e As GetShipmentCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetShipmentCompletedEventHandler(
    Object sender,
    GetShipmentCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetShipmentCompletedEventHandler(
    Object^ sender,
    GetShipmentCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetShipmentCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateCompletedEventArgs Class

[image]

.NET Framework Class Library
GetShipmentsByShipmentDateCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetShipmentsByShipmentDateCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetShipmentsByShipmentDateCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetShipmentsByShipmentDateCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetShipmentsByShipmentDateCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetShipmentsByShipmentDateCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetShipmentsByShipmentDateCompletedEventArgs

See Also

GetShipmentsByShipmentDateCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetShipmentsByShipmentDateCompletedEventArgs Members
GetShipmentsByShipmentDateCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetShipmentsByShipmentDateCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetShipmentsByShipmentDateCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetShipmentsByShipmentDateCompletedEventArgs Methods
GetShipmentsByShipmentDateCompletedEventArgs Class See Also Send Feedback

The GetShipmentsByShipmentDateCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetShipmentsByShipmentDateCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetShipmentsByShipmentDateCompletedEventArgs Properties
GetShipmentsByShipmentDateCompletedEventArgs Class See Also Send Feedback

The GetShipmentsByShipmentDateCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetShipmentsByShipmentDateCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetShipmentsByShipmentDateCompletedEventArgs..::.Result Property
GetShipmentsByShipmentDateCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetShipmentsByShipmentDateCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsByShipmentDateCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetShipmentsByShipmentDateCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetShipmentsByShipmentDateCompletedEventHandler ( _
    sender As Object, _
    e As GetShipmentsByShipmentDateCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetShipmentsByShipmentDateCompletedEventHandler(
    Object sender,
    GetShipmentsByShipmentDateCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetShipmentsByShipmentDateCompletedEventHandler(
    Object^ sender,
    GetShipmentsByShipmentDateCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetShipmentsByShipmentDateCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetShipmentsCompletedEventArgs Class

[image]

.NET Framework Class Library
GetShipmentsCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetShipmentsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetShipmentsCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetShipmentsCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetShipmentsCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetShipmentsCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetShipmentsCompletedEventArgs

See Also

GetShipmentsCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetShipmentsCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetShipmentsCompletedEventArgs Members
GetShipmentsCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetShipmentsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetShipmentsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetShipmentsCompletedEventArgs Methods
GetShipmentsCompletedEventArgs Class See Also Send Feedback

The GetShipmentsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetShipmentsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetShipmentsCompletedEventArgs Properties
GetShipmentsCompletedEventArgs Class See Also Send Feedback

The GetShipmentsCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetShipmentsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetShipmentsCompletedEventArgs..::.Result Property
GetShipmentsCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetShipmentsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipmentsCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetShipmentsCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetShipmentsCompletedEventHandler ( _
    sender As Object, _
    e As GetShipmentsCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetShipmentsCompletedEventHandler(
    Object sender,
    GetShipmentsCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetShipmentsCompletedEventHandler(
    Object^ sender,
    GetShipmentsCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetShipmentsCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetShipTosCompletedEventArgs Class

[image]

.NET Framework Class Library
GetShipTosCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetShipTosCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetShipTosCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetShipTosCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetShipTosCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetShipTosCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetShipTosCompletedEventArgs

See Also

GetShipTosCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetShipTosCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetShipTosCompletedEventArgs Members
GetShipTosCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetShipTosCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetShipTosCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipTosCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetShipTosCompletedEventArgs Methods
GetShipTosCompletedEventArgs Class See Also Send Feedback

The GetShipTosCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetShipTosCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipTosCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetShipTosCompletedEventArgs Properties
GetShipTosCompletedEventArgs Class See Also Send Feedback

The GetShipTosCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetShipTosCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetShipTosCompletedEventArgs..::.Result Property
GetShipTosCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetShipTosCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetShipTosCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetShipTosCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetShipTosCompletedEventHandler ( _
    sender As Object, _
    e As GetShipTosCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetShipTosCompletedEventHandler(
    Object sender,
    GetShipTosCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetShipTosCompletedEventHandler(
    Object^ sender,
    GetShipTosCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetShipTosCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetTrackingDataCompletedEventArgs Class

[image]

.NET Framework Class Library
GetTrackingDataCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetTrackingDataCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetTrackingDataCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetTrackingDataCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetTrackingDataCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetTrackingDataCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetTrackingDataCompletedEventArgs

See Also

GetTrackingDataCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetTrackingDataCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetTrackingDataCompletedEventArgs Members
GetTrackingDataCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetTrackingDataCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetTrackingDataCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetTrackingDataCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetTrackingDataCompletedEventArgs Methods
GetTrackingDataCompletedEventArgs Class See Also Send Feedback

The GetTrackingDataCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetTrackingDataCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetTrackingDataCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetTrackingDataCompletedEventArgs Properties
GetTrackingDataCompletedEventArgs Class See Also Send Feedback

The GetTrackingDataCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetTrackingDataCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetTrackingDataCompletedEventArgs..::.Result Property
GetTrackingDataCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As DataSet
C#
public DataSet Result { get; }
Visual C++
public:
property DataSet^ Result {
    DataSet^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetTrackingDataCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetTrackingDataCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetTrackingDataCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetTrackingDataCompletedEventHandler ( _
    sender As Object, _
    e As GetTrackingDataCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetTrackingDataCompletedEventHandler(
    Object sender,
    GetTrackingDataCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetTrackingDataCompletedEventHandler(
    Object^ sender,
    GetTrackingDataCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetTrackingDataCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersCompletedEventArgs Class

[image]

.NET Framework Class Library
GetTrackingNumbersCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetTrackingNumbersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetTrackingNumbersCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetTrackingNumbersCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetTrackingNumbersCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetTrackingNumbersCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetTrackingNumbersCompletedEventArgs

See Also

GetTrackingNumbersCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetTrackingNumbersCompletedEventArgs Members
GetTrackingNumbersCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetTrackingNumbersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetTrackingNumbersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetTrackingNumbersCompletedEventArgs Methods
GetTrackingNumbersCompletedEventArgs Class See Also Send Feedback

The GetTrackingNumbersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetTrackingNumbersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetTrackingNumbersCompletedEventArgs Properties
GetTrackingNumbersCompletedEventArgs Class See Also Send Feedback

The GetTrackingNumbersCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetTrackingNumbersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetTrackingNumbersCompletedEventArgs..::.Result Property
GetTrackingNumbersCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As String
C#
public string Result { get; }
Visual C++
public:
property String^ Result {
    String^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetTrackingNumbersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetTrackingNumbersCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetTrackingNumbersCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetTrackingNumbersCompletedEventHandler ( _
    sender As Object, _
    e As GetTrackingNumbersCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetTrackingNumbersCompletedEventHandler(
    Object sender,
    GetTrackingNumbersCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetTrackingNumbersCompletedEventHandler(
    Object^ sender,
    GetTrackingNumbersCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetTrackingNumbersCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


GetVersionCompletedEventArgs Class

[image]

.NET Framework Class Library
GetVersionCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class GetVersionCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class GetVersionCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class GetVersionCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.GetVersionCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.GetVersionCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.GetVersionCompletedEventArgs

See Also

GetVersionCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


GetVersionCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
GetVersionCompletedEventArgs Members
GetVersionCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetVersionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetVersionCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetVersionCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
GetVersionCompletedEventArgs Methods
GetVersionCompletedEventArgs Class See Also Send Feedback

The GetVersionCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetVersionCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetVersionCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
GetVersionCompletedEventArgs Properties
GetVersionCompletedEventArgs Class See Also Send Feedback

The GetVersionCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetVersionCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
GetVersionCompletedEventArgs..::.Result Property
GetVersionCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As String
C#
public string Result { get; }
Visual C++
public:
property String^ Result {
    String^ get ();
}
JavaScript
function get_result();

Remarks

See Also

GetVersionCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


GetVersionCompletedEventHandler Delegate

[image]

.NET Framework Class Library
GetVersionCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub GetVersionCompletedEventHandler ( _
    sender As Object, _
    e As GetVersionCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void GetVersionCompletedEventHandler(
    Object sender,
    GetVersionCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void GetVersionCompletedEventHandler(
    Object^ sender,
    GetVersionCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.GetVersionCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


ServiceAuthHeader Class

[image]

.NET Framework Class Library
ServiceAuthHeader Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")> _
Public Class ServiceAuthHeader _
    Inherits SoapHeader
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Xml", "2.0.50727.3053")]
public class ServiceAuthHeader : SoapHeader
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Xml", L"2.0.50727.3053")]
public ref class ServiceAuthHeader : public SoapHeader
JavaScript
InSite.Domain.InSiteERPService.ServiceAuthHeader = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.ServiceAuthHeader',
    SoapHeader);

Remarks

Inheritance Hierarchy

System..::.Object
System.Web.Services.Protocols..::.SoapHeader
InSite.Domain.InSiteERPService..::.ServiceAuthHeader

See Also

ServiceAuthHeader Members
InSite.Domain.InSiteERPService Namespace


ServiceAuthHeader Members

[image] [image]

.NET Framework Class Library
ServiceAuthHeader Members
ServiceAuthHeader Class Constructors Methods Properties See Also Send Feedback

The ServiceAuthHeader type exposes the following members.

Constructors

Name | Description
ServiceAuthHeader |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Actor | Gets or sets the recipient of the SOAP header. (Inherited from SoapHeader.)
AnyAttr |
DidUnderstand | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header. (Inherited from SoapHeader.)
EncodedMustUnderstand | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1. (Inherited from SoapHeader.)
EncodedMustUnderstand12 | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2. (Inherited from SoapHeader.)
EncodedRelay | Gets or sets the relay attribute of the SOAP 1.2 header. (Inherited from SoapHeader.)
MustUnderstand | Gets or sets a value indicating whether the SoapHeader must be understood. (Inherited from SoapHeader.)
Password |
Relay | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header. (Inherited from SoapHeader.)
Role | Gets or sets the recipient of the SOAP header. (Inherited from SoapHeader.)
UserName |

See Also

ServiceAuthHeader Class
InSite.Domain.InSiteERPService Namespace


ServiceAuthHeader Constructor

[image]

.NET Framework Class Library
ServiceAuthHeader Constructor
ServiceAuthHeader Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ServiceAuthHeader()
Visual C++
public:
ServiceAuthHeader()
JavaScript
InSite.Domain.InSiteERPService.ServiceAuthHeader = function();

See Also

ServiceAuthHeader Class
InSite.Domain.InSiteERPService Namespace


ServiceAuthHeader Methods

[image] [image]

.NET Framework Class Library
ServiceAuthHeader Methods
ServiceAuthHeader Class See Also Send Feedback

The ServiceAuthHeader type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServiceAuthHeader Class
InSite.Domain.InSiteERPService Namespace


ServiceAuthHeader Properties

[image] [image]

.NET Framework Class Library
ServiceAuthHeader Properties
ServiceAuthHeader Class See Also Send Feedback

The ServiceAuthHeader type exposes the following members.

Properties

Name | Description
Actor | Gets or sets the recipient of the SOAP header. (Inherited from SoapHeader.)
AnyAttr |
DidUnderstand | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header. (Inherited from SoapHeader.)
EncodedMustUnderstand | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1. (Inherited from SoapHeader.)
EncodedMustUnderstand12 | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2. (Inherited from SoapHeader.)
EncodedRelay | Gets or sets the relay attribute of the SOAP 1.2 header. (Inherited from SoapHeader.)
MustUnderstand | Gets or sets a value indicating whether the SoapHeader must be understood. (Inherited from SoapHeader.)
Password |
Relay | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header. (Inherited from SoapHeader.)
Role | Gets or sets the recipient of the SOAP header. (Inherited from SoapHeader.)
UserName |

See Also

ServiceAuthHeader Class
InSite.Domain.InSiteERPService Namespace


AnyAttr Property

[image]

.NET Framework Class Library
ServiceAuthHeader..::.AnyAttr Property
ServiceAuthHeader Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AnyAttr As XmlAttribute()
C#
public XmlAttribute[] AnyAttr { get; set; }
Visual C++
public:
property array<XmlAttribute^>^ AnyAttr {
    array<XmlAttribute^>^ get ();
    void set (array<XmlAttribute^>^ value);
}
JavaScript
function get_anyAttr();
function set_anyAttr(value);

Remarks

See Also

ServiceAuthHeader Class
InSite.Domain.InSiteERPService Namespace


Password Property

[image]

.NET Framework Class Library
ServiceAuthHeader..::.Password Property
ServiceAuthHeader Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password { get; set; }
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_password();
function set_password(value);

Remarks

See Also

ServiceAuthHeader Class
InSite.Domain.InSiteERPService Namespace


UserName Property

[image]

.NET Framework Class Library
ServiceAuthHeader..::.UserName Property
ServiceAuthHeader Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UserName As String
C#
public string UserName { get; set; }
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_userName();
function set_userName(value);

Remarks

See Also

ServiceAuthHeader Class
InSite.Domain.InSiteERPService Namespace


SubmitJournalCompletedEventArgs Class

[image]

.NET Framework Class Library
SubmitJournalCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class SubmitJournalCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class SubmitJournalCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class SubmitJournalCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.SubmitJournalCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.SubmitJournalCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.SubmitJournalCompletedEventArgs

See Also

SubmitJournalCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


SubmitJournalCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
SubmitJournalCompletedEventArgs Members
SubmitJournalCompletedEventArgs Class Methods Properties See Also Send Feedback

The SubmitJournalCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SubmitJournalCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitJournalCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
SubmitJournalCompletedEventArgs Methods
SubmitJournalCompletedEventArgs Class See Also Send Feedback

The SubmitJournalCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitJournalCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitJournalCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
SubmitJournalCompletedEventArgs Properties
SubmitJournalCompletedEventArgs Class See Also Send Feedback

The SubmitJournalCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SubmitJournalCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
SubmitJournalCompletedEventArgs..::.Result Property
SubmitJournalCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As String
C#
public string Result { get; }
Visual C++
public:
property String^ Result {
    String^ get ();
}
JavaScript
function get_result();

Remarks

See Also

SubmitJournalCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitJournalCompletedEventHandler Delegate

[image]

.NET Framework Class Library
SubmitJournalCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub SubmitJournalCompletedEventHandler ( _
    sender As Object, _
    e As SubmitJournalCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void SubmitJournalCompletedEventHandler(
    Object sender,
    SubmitJournalCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void SubmitJournalCompletedEventHandler(
    Object^ sender,
    SubmitJournalCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.SubmitJournalCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


SubmitOrdersCompletedEventArgs Class

[image]

.NET Framework Class Library
SubmitOrdersCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class SubmitOrdersCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class SubmitOrdersCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class SubmitOrdersCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.SubmitOrdersCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.SubmitOrdersCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.SubmitOrdersCompletedEventArgs

See Also

SubmitOrdersCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


SubmitOrdersCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
SubmitOrdersCompletedEventArgs Members
SubmitOrdersCompletedEventArgs Class Methods Properties See Also Send Feedback

The SubmitOrdersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SubmitOrdersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitOrdersCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
SubmitOrdersCompletedEventArgs Methods
SubmitOrdersCompletedEventArgs Class See Also Send Feedback

The SubmitOrdersCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitOrdersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitOrdersCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
SubmitOrdersCompletedEventArgs Properties
SubmitOrdersCompletedEventArgs Class See Also Send Feedback

The SubmitOrdersCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SubmitOrdersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
SubmitOrdersCompletedEventArgs..::.Result Property
SubmitOrdersCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As String
C#
public string Result { get; }
Visual C++
public:
property String^ Result {
    String^ get ();
}
JavaScript
function get_result();

Remarks

See Also

SubmitOrdersCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitOrdersCompletedEventHandler Delegate

[image]

.NET Framework Class Library
SubmitOrdersCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub SubmitOrdersCompletedEventHandler ( _
    sender As Object, _
    e As SubmitOrdersCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void SubmitOrdersCompletedEventHandler(
    Object sender,
    SubmitOrdersCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void SubmitOrdersCompletedEventHandler(
    Object^ sender,
    SubmitOrdersCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.SubmitOrdersCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


SubmitPaymentsCompletedEventArgs Class

[image]

.NET Framework Class Library
SubmitPaymentsCompletedEventArgs Class
Members See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Class SubmitPaymentsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public class SubmitPaymentsCompletedEventArgs : AsyncCompletedEventArgs
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public ref class SubmitPaymentsCompletedEventArgs : public AsyncCompletedEventArgs
JavaScript
InSite.Domain.InSiteERPService.SubmitPaymentsCompletedEventArgs = function();

Type.createClass(
    'InSite.Domain.InSiteERPService.SubmitPaymentsCompletedEventArgs',
    AsyncCompletedEventArgs);

Remarks

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
InSite.Domain.InSiteERPService..::.SubmitPaymentsCompletedEventArgs

See Also

SubmitPaymentsCompletedEventArgs Members
InSite.Domain.InSiteERPService Namespace


SubmitPaymentsCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
SubmitPaymentsCompletedEventArgs Members
SubmitPaymentsCompletedEventArgs Class Methods Properties See Also Send Feedback

The SubmitPaymentsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SubmitPaymentsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitPaymentsCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
SubmitPaymentsCompletedEventArgs Methods
SubmitPaymentsCompletedEventArgs Class See Also Send Feedback

The SubmitPaymentsCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubmitPaymentsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitPaymentsCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
SubmitPaymentsCompletedEventArgs Properties
SubmitPaymentsCompletedEventArgs Class See Also Send Feedback

The SubmitPaymentsCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Result |
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

SubmitPaymentsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


Result Property

[image]

.NET Framework Class Library
SubmitPaymentsCompletedEventArgs..::.Result Property
SubmitPaymentsCompletedEventArgs Class See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Result As String
C#
public string Result { get; }
Visual C++
public:
property String^ Result {
    String^ get ();
}
JavaScript
function get_result();

Remarks

See Also

SubmitPaymentsCompletedEventArgs Class
InSite.Domain.InSiteERPService Namespace


SubmitPaymentsCompletedEventHandler Delegate

[image]

.NET Framework Class Library
SubmitPaymentsCompletedEventHandler Delegate
See Also Send Feedback

Namespace: InSite.Domain.InSiteERPService
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")> _
Public Delegate Sub SubmitPaymentsCompletedEventHandler ( _
    sender As Object, _
    e As SubmitPaymentsCompletedEventArgs _
)
C#
[GeneratedCodeAttribute("System.Web.Services", "2.0.50727.3053")]
public delegate void SubmitPaymentsCompletedEventHandler(
    Object sender,
    SubmitPaymentsCompletedEventArgs e
)
Visual C++
[GeneratedCodeAttribute(L"System.Web.Services", L"2.0.50727.3053")]
public delegate void SubmitPaymentsCompletedEventHandler(
    Object^ sender,
    SubmitPaymentsCompletedEventArgs^ e
)
JavaScript
function(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: InSite.Domain.InSiteERPService..::.SubmitPaymentsCompletedEventArgs

Remarks

See Also

InSite.Domain.InSiteERPService Namespace


InSite.Domain.PaymentGateways Namespace

[image]

.NET Framework Class Library
InSite.Domain.PaymentGateways Namespace
Send Feedback

Classes

Class | Description
CreditCardTransactionException |
CreditCardTransactionExceptionPayPal |
PaymentGateway |
PaymentGateway_AuthorizeNet |
PaymentGateway_CyberSource |
PaymentGateway_Dummy |
PaymentGateway_ESelect |
PaymentGateway_PayflowPro |
PaymentGateway_PCCharge |
PaymentProcessor |
PCCTransaction | Taken from a devkit sample. If this is not cleaned up and refactored come find me and kick me.


CreditCardTransactionException Class

[image]

.NET Framework Class Library
CreditCardTransactionException Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class CreditCardTransactionException _
    Inherits Exception
C#
public class CreditCardTransactionException : Exception
Visual C++
public ref class CreditCardTransactionException : public Exception
JavaScript
InSite.Domain.PaymentGateways.CreditCardTransactionException = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.CreditCardTransactionException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Domain.PaymentGateways..::.CreditCardTransactionException
InSite.Domain.PaymentGateways..::.CreditCardTransactionExceptionPayPal

See Also

CreditCardTransactionException Members
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionException Members

[image] [image]

.NET Framework Class Library
CreditCardTransactionException Members
CreditCardTransactionException Class Constructors Methods Fields Properties See Also Send Feedback

The CreditCardTransactionException type exposes the following members.

Constructors

Name | Description
CreditCardTransactionException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
_message |

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message |
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CreditCardTransactionException Class
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionException Constructor

[image] [image]

.NET Framework Class Library
CreditCardTransactionException Constructor
CreditCardTransactionException Class See Also Send Feedback

Overload List

Name | Description
CreditCardTransactionException(String) |
CreditCardTransactionException(String, String) |

See Also

CreditCardTransactionException Class
CreditCardTransactionException Members
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionException Constructor (String)

[image]

.NET Framework Class Library
CreditCardTransactionException Constructor (String)
CreditCardTransactionException Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public CreditCardTransactionException(
    string message
)
Visual C++
public:
CreditCardTransactionException(
    String^ message
)
JavaScript
InSite.Domain.PaymentGateways.CreditCardTransactionException = function(message);

Parameters

message
Type: System..::.String

See Also

CreditCardTransactionException Class
CreditCardTransactionException Overload
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionException Constructor (String, String)

[image]

.NET Framework Class Library
CreditCardTransactionException Constructor (String, String)
CreditCardTransactionException Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    message As String, _
    defaultMessage As String _
)
C#
protected CreditCardTransactionException(
    string message,
    string defaultMessage
)
Visual C++
protected:
CreditCardTransactionException(
    String^ message,
    String^ defaultMessage
)
JavaScript
InSite.Domain.PaymentGateways.CreditCardTransactionException = function(message, defaultMessage);

Parameters

message
Type: System..::.String
defaultMessage
Type: System..::.String

See Also

CreditCardTransactionException Class
CreditCardTransactionException Overload
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionException Fields

[image] [image]

.NET Framework Class Library
CreditCardTransactionException Fields
CreditCardTransactionException Class See Also Send Feedback

The CreditCardTransactionException type exposes the following members.

Fields

Name | Description
_message |

See Also

CreditCardTransactionException Class
InSite.Domain.PaymentGateways Namespace


_message Field

[image]

.NET Framework Class Library
CreditCardTransactionException..::._message Field
CreditCardTransactionException Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected _message As String
C#
protected string _message
Visual C++
protected:
String^ _message
JavaScript
_message

See Also

CreditCardTransactionException Class
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionException Methods

[image] [image]

.NET Framework Class Library
CreditCardTransactionException Methods
CreditCardTransactionException Class See Also Send Feedback

The CreditCardTransactionException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CreditCardTransactionException Class
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionException Properties

[image] [image]

.NET Framework Class Library
CreditCardTransactionException Properties
CreditCardTransactionException Class See Also Send Feedback

The CreditCardTransactionException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message |
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CreditCardTransactionException Class
InSite.Domain.PaymentGateways Namespace


Message Property

[image]

.NET Framework Class Library
CreditCardTransactionException..::.Message Property
CreditCardTransactionException Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
C#
public string Message { get; }
Visual C++
public:
property String^ Message {
    String^ get ();
}
JavaScript
function get_message();

See Also

CreditCardTransactionException Class
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionExceptionPayPal Class

[image]

.NET Framework Class Library
CreditCardTransactionExceptionPayPal Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class CreditCardTransactionExceptionPayPal _
    Inherits CreditCardTransactionException
C#
public class CreditCardTransactionExceptionPayPal : CreditCardTransactionException
Visual C++
public ref class CreditCardTransactionExceptionPayPal : public CreditCardTransactionException
JavaScript
InSite.Domain.PaymentGateways.CreditCardTransactionExceptionPayPal = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.CreditCardTransactionExceptionPayPal',
    InSite.Domain.PaymentGateways.CreditCardTransactionException);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Domain.PaymentGateways..::.CreditCardTransactionException
InSite.Domain.PaymentGateways..::.CreditCardTransactionExceptionPayPal

See Also

CreditCardTransactionExceptionPayPal Members
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionExceptionPayPal Members

[image] [image]

.NET Framework Class Library
CreditCardTransactionExceptionPayPal Members
CreditCardTransactionExceptionPayPal Class Constructors Methods Fields Properties See Also Send Feedback

The CreditCardTransactionExceptionPayPal type exposes the following members.

Constructors

Name | Description
CreditCardTransactionExceptionPayPal |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
_message | (Inherited from CreditCardTransactionException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | (Inherited from CreditCardTransactionException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CreditCardTransactionExceptionPayPal Class
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionExceptionPayPal Constructor

[image]

.NET Framework Class Library
CreditCardTransactionExceptionPayPal Constructor
CreditCardTransactionExceptionPayPal Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public CreditCardTransactionExceptionPayPal(
    string message
)
Visual C++
public:
CreditCardTransactionExceptionPayPal(
    String^ message
)
JavaScript
InSite.Domain.PaymentGateways.CreditCardTransactionExceptionPayPal = function(message);

Parameters

message
Type: System..::.String

See Also

CreditCardTransactionExceptionPayPal Class
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionExceptionPayPal Fields

[image] [image]

.NET Framework Class Library
CreditCardTransactionExceptionPayPal Fields
CreditCardTransactionExceptionPayPal Class See Also Send Feedback

The CreditCardTransactionExceptionPayPal type exposes the following members.

Fields

Name | Description
_message | (Inherited from CreditCardTransactionException.)

See Also

CreditCardTransactionExceptionPayPal Class
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionExceptionPayPal Methods

[image] [image]

.NET Framework Class Library
CreditCardTransactionExceptionPayPal Methods
CreditCardTransactionExceptionPayPal Class See Also Send Feedback

The CreditCardTransactionExceptionPayPal type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

CreditCardTransactionExceptionPayPal Class
InSite.Domain.PaymentGateways Namespace


CreditCardTransactionExceptionPayPal Properties

[image] [image]

.NET Framework Class Library
CreditCardTransactionExceptionPayPal Properties
CreditCardTransactionExceptionPayPal Class See Also Send Feedback

The CreditCardTransactionExceptionPayPal type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | (Inherited from CreditCardTransactionException.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

CreditCardTransactionExceptionPayPal Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway Class

[image]

.NET Framework Class Library
PaymentGateway Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PaymentGateway
C#
public class PaymentGateway
Visual C++
public ref class PaymentGateway
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PaymentGateway');

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PaymentGateway

See Also

PaymentGateway Members
InSite.Domain.PaymentGateways Namespace


PaymentGateway Members

[image] [image]

.NET Framework Class Library
PaymentGateway Members
PaymentGateway Class Constructors Methods See Also Send Feedback

The PaymentGateway type exposes the following members.

Constructors

Name | Description
PaymentGateway |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway Constructor

[image]

.NET Framework Class Library
PaymentGateway Constructor
PaymentGateway Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    paymentGateway As IPaymentGateway _
)
C#
public PaymentGateway(
    IPaymentGateway paymentGateway
)
Visual C++
public:
PaymentGateway(
    IPaymentGateway^ paymentGateway
)
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway = function(paymentGateway);

Parameters

paymentGateway
Type: InSite.Model..::.IPaymentGateway

See Also

PaymentGateway Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway Methods

[image] [image]

.NET Framework Class Library
PaymentGateway Methods
PaymentGateway Class See Also Send Feedback

The PaymentGateway type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway Class
InSite.Domain.PaymentGateways Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
PaymentGateway..::.SubmitTransaction Method
PaymentGateway Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SubmitTransaction ( _
    transactionType As String, _
    creditCard As CreditCard, _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction SubmitTransaction(
    string transactionType,
    CreditCard creditCard,
    CustomerOrder customerOrder
)
Visual C++
public:
CreditCardTransaction^ SubmitTransaction(
    String^ transactionType,
    CreditCard^ creditCard,
    CustomerOrder^ customerOrder
)
JavaScript
function submitTransaction(transactionType, creditCard, customerOrder);

Parameters

transactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard
customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PaymentGateway Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_AuthorizeNet Class

[image]

.NET Framework Class Library
PaymentGateway_AuthorizeNet Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PaymentGateway_AuthorizeNet _
    Implements IPaymentGateway
C#
public class PaymentGateway_AuthorizeNet : IPaymentGateway
Visual C++
public ref class PaymentGateway_AuthorizeNet : IPaymentGateway
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_AuthorizeNet = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PaymentGateway_AuthorizeNet',
    null,
    InSite.Model.IPaymentGateway);

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PaymentGateway_AuthorizeNet

See Also

PaymentGateway_AuthorizeNet Members
InSite.Domain.PaymentGateways Namespace


PaymentGateway_AuthorizeNet Members

[image] [image]

.NET Framework Class Library
PaymentGateway_AuthorizeNet Members
PaymentGateway_AuthorizeNet Class Constructors Methods See Also Send Feedback

The PaymentGateway_AuthorizeNet type exposes the following members.

Constructors

Name | Description
PaymentGateway_AuthorizeNet |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseResponseData | Overloaded.
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_AuthorizeNet Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_AuthorizeNet Constructor

[image]

.NET Framework Class Library
PaymentGateway_AuthorizeNet Constructor
PaymentGateway_AuthorizeNet Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentGateway_AuthorizeNet()
Visual C++
public:
PaymentGateway_AuthorizeNet()
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_AuthorizeNet = function();

See Also

PaymentGateway_AuthorizeNet Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_AuthorizeNet Methods

[image] [image]

.NET Framework Class Library
PaymentGateway_AuthorizeNet Methods
PaymentGateway_AuthorizeNet Class See Also Send Feedback

The PaymentGateway_AuthorizeNet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseResponseData | Overloaded.
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_AuthorizeNet Class
InSite.Domain.PaymentGateways Namespace


ParseResponseData Method

[image] [image]

.NET Framework Class Library
PaymentGateway_AuthorizeNet..::.ParseResponseData Method
PaymentGateway_AuthorizeNet Class See Also Send Feedback

Overload List

Name | Description
ParseResponseData(CreditCardTransaction, String, Char) |
ParseResponseData(CreditCardTransaction, String, CreditCard, Char) |

See Also

PaymentGateway_AuthorizeNet Class
PaymentGateway_AuthorizeNet Members
InSite.Domain.PaymentGateways Namespace


ParseResponseData Method (CreditCardTransaction, String, Char)

[image]

.NET Framework Class Library
PaymentGateway_AuthorizeNet..::.ParseResponseData Method (CreditCardTransaction, String, Char)
PaymentGateway_AuthorizeNet Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ParseResponseData ( _
    creditCardTransaction As CreditCardTransaction, _
    result As String, _
    delimiter As Char _
)
C#
public static void ParseResponseData(
    CreditCardTransaction creditCardTransaction,
    string result,
    char delimiter
)
Visual C++
public:
static void ParseResponseData(
    CreditCardTransaction^ creditCardTransaction,
    String^ result,
    wchar_t delimiter
)
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_AuthorizeNet.parseResponseData = function(creditCardTransaction, result, delimiter);

Parameters

creditCardTransaction
Type: InSite.Model..::.CreditCardTransaction
result
Type: System..::.String
delimiter
Type: System..::.Char

See Also

PaymentGateway_AuthorizeNet Class
ParseResponseData Overload
InSite.Domain.PaymentGateways Namespace


ParseResponseData Method (CreditCardTransaction, String, CreditCard, Char)

[image]

.NET Framework Class Library
PaymentGateway_AuthorizeNet..::.ParseResponseData Method (CreditCardTransaction, String, CreditCard, Char)
PaymentGateway_AuthorizeNet Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ParseResponseData ( _
    creditCardTransaction As CreditCardTransaction, _
    result As String, _
    card As CreditCard, _
    delimiter As Char _
)
C#
public static void ParseResponseData(
    CreditCardTransaction creditCardTransaction,
    string result,
    CreditCard card,
    char delimiter
)
Visual C++
public:
static void ParseResponseData(
    CreditCardTransaction^ creditCardTransaction,
    String^ result,
    CreditCard^ card,
    wchar_t delimiter
)
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_AuthorizeNet.parseResponseData = function(creditCardTransaction, result, card, delimiter);

Parameters

creditCardTransaction
Type: InSite.Model..::.CreditCardTransaction
result
Type: System..::.String
card
Type: InSite.Model..::.CreditCard
delimiter
Type: System..::.Char

See Also

PaymentGateway_AuthorizeNet Class
ParseResponseData Overload
InSite.Domain.PaymentGateways Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
PaymentGateway_AuthorizeNet..::.SubmitTransaction Method
PaymentGateway_AuthorizeNet Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SubmitTransaction ( _
    creditCardTransactionType As String, _
    card As CreditCard, _
    order As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction SubmitTransaction(
    string creditCardTransactionType,
    CreditCard card,
    CustomerOrder order
)
Visual C++
public:
virtual CreditCardTransaction^ SubmitTransaction(
    String^ creditCardTransactionType,
    CreditCard^ card,
    CustomerOrder^ order
) sealed
JavaScript
function submitTransaction(creditCardTransactionType, card, order);

Parameters

creditCardTransactionType
Type: System..::.String
card
Type: InSite.Model..::.CreditCard
order
Type: InSite.Model..::.CustomerOrder

Implements

IPaymentGateway..::.SubmitTransaction(String, CreditCard, CustomerOrder)

See Also

PaymentGateway_AuthorizeNet Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_CyberSource Class

[image]

.NET Framework Class Library
PaymentGateway_CyberSource Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PaymentGateway_CyberSource _
    Implements IPaymentGateway
C#
public class PaymentGateway_CyberSource : IPaymentGateway
Visual C++
public ref class PaymentGateway_CyberSource : IPaymentGateway
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_CyberSource = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PaymentGateway_CyberSource',
    null,
    InSite.Model.IPaymentGateway);

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PaymentGateway_CyberSource

See Also

PaymentGateway_CyberSource Members
InSite.Domain.PaymentGateways Namespace


PaymentGateway_CyberSource Members

[image] [image]

.NET Framework Class Library
PaymentGateway_CyberSource Members
PaymentGateway_CyberSource Class Constructors Methods See Also Send Feedback

The PaymentGateway_CyberSource type exposes the following members.

Constructors

Name | Description
PaymentGateway_CyberSource |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_CyberSource Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_CyberSource Constructor

[image]

.NET Framework Class Library
PaymentGateway_CyberSource Constructor
PaymentGateway_CyberSource Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentGateway_CyberSource()
Visual C++
public:
PaymentGateway_CyberSource()
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_CyberSource = function();

See Also

PaymentGateway_CyberSource Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_CyberSource Methods

[image] [image]

.NET Framework Class Library
PaymentGateway_CyberSource Methods
PaymentGateway_CyberSource Class See Also Send Feedback

The PaymentGateway_CyberSource type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_CyberSource Class
InSite.Domain.PaymentGateways Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
PaymentGateway_CyberSource..::.SubmitTransaction Method
PaymentGateway_CyberSource Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SubmitTransaction ( _
    creditCardTransactionType As String, _
    creditCard As CreditCard, _
    order As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction SubmitTransaction(
    string creditCardTransactionType,
    CreditCard creditCard,
    CustomerOrder order
)
Visual C++
public:
virtual CreditCardTransaction^ SubmitTransaction(
    String^ creditCardTransactionType,
    CreditCard^ creditCard,
    CustomerOrder^ order
) sealed
JavaScript
function submitTransaction(creditCardTransactionType, creditCard, order);

Parameters

creditCardTransactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard
order
Type: InSite.Model..::.CustomerOrder

Implements

IPaymentGateway..::.SubmitTransaction(String, CreditCard, CustomerOrder)

See Also

PaymentGateway_CyberSource Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_Dummy Class

[image]

.NET Framework Class Library
PaymentGateway_Dummy Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PaymentGateway_Dummy _
    Implements IPaymentGateway
C#
public class PaymentGateway_Dummy : IPaymentGateway
Visual C++
public ref class PaymentGateway_Dummy : IPaymentGateway
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_Dummy = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PaymentGateway_Dummy',
    null,
    InSite.Model.IPaymentGateway);

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PaymentGateway_Dummy

See Also

PaymentGateway_Dummy Members
InSite.Domain.PaymentGateways Namespace


PaymentGateway_Dummy Members

[image] [image]

.NET Framework Class Library
PaymentGateway_Dummy Members
PaymentGateway_Dummy Class Constructors Methods See Also Send Feedback

The PaymentGateway_Dummy type exposes the following members.

Constructors

Name | Description
PaymentGateway_Dummy |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_Dummy Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_Dummy Constructor

[image]

.NET Framework Class Library
PaymentGateway_Dummy Constructor
PaymentGateway_Dummy Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentGateway_Dummy()
Visual C++
public:
PaymentGateway_Dummy()
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_Dummy = function();

See Also

PaymentGateway_Dummy Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_Dummy Methods

[image] [image]

.NET Framework Class Library
PaymentGateway_Dummy Methods
PaymentGateway_Dummy Class See Also Send Feedback

The PaymentGateway_Dummy type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_Dummy Class
InSite.Domain.PaymentGateways Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
PaymentGateway_Dummy..::.SubmitTransaction Method
PaymentGateway_Dummy Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SubmitTransaction ( _
    transactionType As String, _
    creditCard As CreditCard, _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction SubmitTransaction(
    string transactionType,
    CreditCard creditCard,
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CreditCardTransaction^ SubmitTransaction(
    String^ transactionType,
    CreditCard^ creditCard,
    CustomerOrder^ customerOrder
) sealed
JavaScript
function submitTransaction(transactionType, creditCard, customerOrder);

Parameters

transactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard
customerOrder
Type: InSite.Model..::.CustomerOrder

Implements

IPaymentGateway..::.SubmitTransaction(String, CreditCard, CustomerOrder)

See Also

PaymentGateway_Dummy Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_ESelect Class

[image]

.NET Framework Class Library
PaymentGateway_ESelect Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PaymentGateway_ESelect _
    Implements IPaymentGateway
C#
public class PaymentGateway_ESelect : IPaymentGateway
Visual C++
public ref class PaymentGateway_ESelect : IPaymentGateway
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_ESelect = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PaymentGateway_ESelect',
    null,
    InSite.Model.IPaymentGateway);

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PaymentGateway_ESelect

See Also

PaymentGateway_ESelect Members
InSite.Domain.PaymentGateways Namespace


PaymentGateway_ESelect Members

[image] [image]

.NET Framework Class Library
PaymentGateway_ESelect Members
PaymentGateway_ESelect Class Constructors Methods See Also Send Feedback

The PaymentGateway_ESelect type exposes the following members.

Constructors

Name | Description
PaymentGateway_ESelect |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_ESelect Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_ESelect Constructor

[image]

.NET Framework Class Library
PaymentGateway_ESelect Constructor
PaymentGateway_ESelect Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentGateway_ESelect()
Visual C++
public:
PaymentGateway_ESelect()
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_ESelect = function();

See Also

PaymentGateway_ESelect Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_ESelect Methods

[image] [image]

.NET Framework Class Library
PaymentGateway_ESelect Methods
PaymentGateway_ESelect Class See Also Send Feedback

The PaymentGateway_ESelect type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_ESelect Class
InSite.Domain.PaymentGateways Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
PaymentGateway_ESelect..::.SubmitTransaction Method
PaymentGateway_ESelect Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SubmitTransaction ( _
    transactionType As String, _
    creditCard As CreditCard, _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction SubmitTransaction(
    string transactionType,
    CreditCard creditCard,
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CreditCardTransaction^ SubmitTransaction(
    String^ transactionType,
    CreditCard^ creditCard,
    CustomerOrder^ customerOrder
) sealed
JavaScript
function submitTransaction(transactionType, creditCard, customerOrder);

Parameters

transactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard
customerOrder
Type: InSite.Model..::.CustomerOrder

Implements

IPaymentGateway..::.SubmitTransaction(String, CreditCard, CustomerOrder)

See Also

PaymentGateway_ESelect Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_PayflowPro Class

[image]

.NET Framework Class Library
PaymentGateway_PayflowPro Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PaymentGateway_PayflowPro _
    Implements IPaymentGateway
C#
public class PaymentGateway_PayflowPro : IPaymentGateway
Visual C++
public ref class PaymentGateway_PayflowPro : IPaymentGateway
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_PayflowPro = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PaymentGateway_PayflowPro',
    null,
    InSite.Model.IPaymentGateway);

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PaymentGateway_PayflowPro

See Also

PaymentGateway_PayflowPro Members
InSite.Domain.PaymentGateways Namespace


PaymentGateway_PayflowPro Members

[image] [image]

.NET Framework Class Library
PaymentGateway_PayflowPro Members
PaymentGateway_PayflowPro Class Constructors Methods See Also Send Feedback

The PaymentGateway_PayflowPro type exposes the following members.

Constructors

Name | Description
PaymentGateway_PayflowPro |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_PayflowPro Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_PayflowPro Constructor

[image]

.NET Framework Class Library
PaymentGateway_PayflowPro Constructor
PaymentGateway_PayflowPro Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentGateway_PayflowPro()
Visual C++
public:
PaymentGateway_PayflowPro()
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_PayflowPro = function();

See Also

PaymentGateway_PayflowPro Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_PayflowPro Methods

[image] [image]

.NET Framework Class Library
PaymentGateway_PayflowPro Methods
PaymentGateway_PayflowPro Class See Also Send Feedback

The PaymentGateway_PayflowPro type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_PayflowPro Class
InSite.Domain.PaymentGateways Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
PaymentGateway_PayflowPro..::.SubmitTransaction Method
PaymentGateway_PayflowPro Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SubmitTransaction ( _
    transactionType As String, _
    creditCard As CreditCard, _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction SubmitTransaction(
    string transactionType,
    CreditCard creditCard,
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CreditCardTransaction^ SubmitTransaction(
    String^ transactionType,
    CreditCard^ creditCard,
    CustomerOrder^ customerOrder
) sealed
JavaScript
function submitTransaction(transactionType, creditCard, customerOrder);

Parameters

transactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard
customerOrder
Type: InSite.Model..::.CustomerOrder

Implements

IPaymentGateway..::.SubmitTransaction(String, CreditCard, CustomerOrder)

See Also

PaymentGateway_PayflowPro Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_PCCharge Class

[image]

.NET Framework Class Library
PaymentGateway_PCCharge Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PaymentGateway_PCCharge _
    Implements IPaymentGateway
C#
public class PaymentGateway_PCCharge : IPaymentGateway
Visual C++
public ref class PaymentGateway_PCCharge : IPaymentGateway
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_PCCharge = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PaymentGateway_PCCharge',
    null,
    InSite.Model.IPaymentGateway);

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PaymentGateway_PCCharge

See Also

PaymentGateway_PCCharge Members
InSite.Domain.PaymentGateways Namespace


PaymentGateway_PCCharge Members

[image] [image]

.NET Framework Class Library
PaymentGateway_PCCharge Members
PaymentGateway_PCCharge Class Constructors Methods See Also Send Feedback

The PaymentGateway_PCCharge type exposes the following members.

Constructors

Name | Description
PaymentGateway_PCCharge |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_PCCharge Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_PCCharge Constructor

[image]

.NET Framework Class Library
PaymentGateway_PCCharge Constructor
PaymentGateway_PCCharge Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentGateway_PCCharge()
Visual C++
public:
PaymentGateway_PCCharge()
JavaScript
InSite.Domain.PaymentGateways.PaymentGateway_PCCharge = function();

See Also

PaymentGateway_PCCharge Class
InSite.Domain.PaymentGateways Namespace


PaymentGateway_PCCharge Methods

[image] [image]

.NET Framework Class Library
PaymentGateway_PCCharge Methods
PaymentGateway_PCCharge Class See Also Send Feedback

The PaymentGateway_PCCharge type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentGateway_PCCharge Class
InSite.Domain.PaymentGateways Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
PaymentGateway_PCCharge..::.SubmitTransaction Method
PaymentGateway_PCCharge Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function SubmitTransaction ( _
    transactionType As String, _
    creditCard As CreditCard, _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
public CreditCardTransaction SubmitTransaction(
    string transactionType,
    CreditCard creditCard,
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CreditCardTransaction^ SubmitTransaction(
    String^ transactionType,
    CreditCard^ creditCard,
    CustomerOrder^ customerOrder
) sealed
JavaScript
function submitTransaction(transactionType, creditCard, customerOrder);

Parameters

transactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard
customerOrder
Type: InSite.Model..::.CustomerOrder

Implements

IPaymentGateway..::.SubmitTransaction(String, CreditCard, CustomerOrder)

See Also

PaymentGateway_PCCharge Class
InSite.Domain.PaymentGateways Namespace


PaymentProcessor Class

[image]

.NET Framework Class Library
PaymentProcessor Class
Members See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PaymentProcessor
C#
public class PaymentProcessor
Visual C++
public ref class PaymentProcessor
JavaScript
InSite.Domain.PaymentGateways.PaymentProcessor = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PaymentProcessor');

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PaymentProcessor

See Also

PaymentProcessor Members
InSite.Domain.PaymentGateways Namespace


PaymentProcessor Members

[image] [image]

.NET Framework Class Library
PaymentProcessor Members
PaymentProcessor Class Constructors Methods See Also Send Feedback

The PaymentProcessor type exposes the following members.

Constructors

Name | Description
PaymentProcessor |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetUpTransaction |
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentProcessor Class
InSite.Domain.PaymentGateways Namespace


PaymentProcessor Constructor

[image]

.NET Framework Class Library
PaymentProcessor Constructor
PaymentProcessor Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentProcessor()
Visual C++
public:
PaymentProcessor()
JavaScript
InSite.Domain.PaymentGateways.PaymentProcessor = function();

See Also

PaymentProcessor Class
InSite.Domain.PaymentGateways Namespace


PaymentProcessor Methods

[image] [image]

.NET Framework Class Library
PaymentProcessor Methods
PaymentProcessor Class See Also Send Feedback

The PaymentProcessor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetUpTransaction |
SubmitTransaction |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaymentProcessor Class
InSite.Domain.PaymentGateways Namespace


SetUpTransaction Method

[image]

.NET Framework Class Library
PaymentProcessor..::.SetUpTransaction Method
PaymentProcessor Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SetUpTransaction ( _
    transactionType As String, _
    customerOrder As CustomerOrder, _
    returnURL As String, _
    cancelURL As String _
) As String
C#
public static string SetUpTransaction(
    string transactionType,
    CustomerOrder customerOrder,
    string returnURL,
    string cancelURL
)
Visual C++
public:
static String^ SetUpTransaction(
    String^ transactionType,
    CustomerOrder^ customerOrder,
    String^ returnURL,
    String^ cancelURL
)
JavaScript
InSite.Domain.PaymentGateways.PaymentProcessor.setUpTransaction = function(transactionType, customerOrder, returnURL, cancelURL);

Parameters

transactionType
Type: System..::.String
customerOrder
Type: InSite.Model..::.CustomerOrder
returnURL
Type: System..::.String
cancelURL
Type: System..::.String

See Also

PaymentProcessor Class
InSite.Domain.PaymentGateways Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
PaymentProcessor..::.SubmitTransaction Method
PaymentProcessor Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SubmitTransaction ( _
    transactionType As String, _
    creditCard As CreditCard, _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
public static CreditCardTransaction SubmitTransaction(
    string transactionType,
    CreditCard creditCard,
    CustomerOrder customerOrder
)
Visual C++
public:
static CreditCardTransaction^ SubmitTransaction(
    String^ transactionType,
    CreditCard^ creditCard,
    CustomerOrder^ customerOrder
)
JavaScript
InSite.Domain.PaymentGateways.PaymentProcessor.submitTransaction = function(transactionType, creditCard, customerOrder);

Parameters

transactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard
customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PaymentProcessor Class
InSite.Domain.PaymentGateways Namespace


PCCTransaction Class

[image]

.NET Framework Class Library
PCCTransaction Class
Members See Also Send Feedback

Taken from a devkit sample. If this is not cleaned up and refactored come find me and kick me.

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class PCCTransaction
C#
public class PCCTransaction
Visual C++
public ref class PCCTransaction
JavaScript
InSite.Domain.PaymentGateways.PCCTransaction = function();

Type.createClass(
    'InSite.Domain.PaymentGateways.PCCTransaction');

Inheritance Hierarchy

System..::.Object
InSite.Domain.PaymentGateways..::.PCCTransaction

See Also

PCCTransaction Members
InSite.Domain.PaymentGateways Namespace


PCCTransaction Members

[image] [image]

.NET Framework Class Library
PCCTransaction Members
PCCTransaction Class Constructors Methods Properties See Also Send Feedback

The PCCTransaction type exposes the following members.

Constructors

Name | Description
PCCTransaction |

Methods

Name | Description
BuildMesssage |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ACCT_NUM |
AMX_CHARGE_DESCRIPTION |
AMX_DESCRIPTION_1 |
AMX_DESCRIPTION_2 |
AMX_DESCRIPTION_3 |
AMX_DESCRIPTION_4 |
AUTH_CODE |
BILLPAY |
CARDHOLDER |
CMRCL_FLAG |
COMMAND |
CREDIT_PLAN_NUMBER |
CUSTOMER_CODE |
CUSTOMER_ZIP |
CVV2 |
DEST_ZIP_CODE |
DRIVER_ID |
DRIVER_PIN |
EXP_DATE |
GRATUITY_AMNT |
GRATUITY_AMNT_EST |
ID_NUMBER |
ITEM_ID |
MANUAL_FLAG |
MCSC |
MCSN |
MERCH_NUM |
MULTI_FLAG |
ODOMETER |
OFFLINE_FLAG |
PERIODIC_PAYMENT_FLAG |
PRESENT_FLAG |
PRINT_RECEIPTS_FLAG |
PROCESSOR_ID |
PRODUCT_DETAIL_AMOUNT_XX |
PRODUCT_DETAIL_CODE_XX |
PRODUCT_DETAIL_COUNT |
PRODUCT_DETAIL_QUANTITY_XX |
REFERENCE |
RESTRICTION_CODE |
RFID |
STREET |
TAX_AMOUNT |
TAX_EXEMPT |
TICKET_NUM |
TRACK_DATA |
TRANS_AMOUNT |
TRANS_STORE |
TROUTD |
TXN_TIMEOUT |
USER_ID |
VEHICLE_ID |
ZIP_CODE |

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PCCTransaction Constructor

[image]

.NET Framework Class Library
PCCTransaction Constructor
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PCCTransaction()
Visual C++
public:
PCCTransaction()
JavaScript
InSite.Domain.PaymentGateways.PCCTransaction = function();

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PCCTransaction Methods

[image] [image]

.NET Framework Class Library
PCCTransaction Methods
PCCTransaction Class See Also Send Feedback

The PCCTransaction type exposes the following members.

Methods

Name | Description
BuildMesssage |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


BuildMesssage Method

[image]

.NET Framework Class Library
PCCTransaction..::.BuildMesssage Method
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function BuildMesssage As String
C#
public string BuildMesssage()
Visual C++
public:
String^ BuildMesssage()
JavaScript
function buildMesssage();

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PCCTransaction Properties

[image] [image]

.NET Framework Class Library
PCCTransaction Properties
PCCTransaction Class See Also Send Feedback

The PCCTransaction type exposes the following members.

Properties

Name | Description
ACCT_NUM |
AMX_CHARGE_DESCRIPTION |
AMX_DESCRIPTION_1 |
AMX_DESCRIPTION_2 |
AMX_DESCRIPTION_3 |
AMX_DESCRIPTION_4 |
AUTH_CODE |
BILLPAY |
CARDHOLDER |
CMRCL_FLAG |
COMMAND |
CREDIT_PLAN_NUMBER |
CUSTOMER_CODE |
CUSTOMER_ZIP |
CVV2 |
DEST_ZIP_CODE |
DRIVER_ID |
DRIVER_PIN |
EXP_DATE |
GRATUITY_AMNT |
GRATUITY_AMNT_EST |
ID_NUMBER |
ITEM_ID |
MANUAL_FLAG |
MCSC |
MCSN |
MERCH_NUM |
MULTI_FLAG |
ODOMETER |
OFFLINE_FLAG |
PERIODIC_PAYMENT_FLAG |
PRESENT_FLAG |
PRINT_RECEIPTS_FLAG |
PROCESSOR_ID |
PRODUCT_DETAIL_AMOUNT_XX |
PRODUCT_DETAIL_CODE_XX |
PRODUCT_DETAIL_COUNT |
PRODUCT_DETAIL_QUANTITY_XX |
REFERENCE |
RESTRICTION_CODE |
RFID |
STREET |
TAX_AMOUNT |
TAX_EXEMPT |
TICKET_NUM |
TRACK_DATA |
TRANS_AMOUNT |
TRANS_STORE |
TROUTD |
TXN_TIMEOUT |
USER_ID |
VEHICLE_ID |
ZIP_CODE |

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


ACCT_NUM Property

[image]

.NET Framework Class Library
PCCTransaction..::.ACCT_NUM Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ACCT_NUM As String
C#
public string ACCT_NUM { get; set; }
Visual C++
public:
property String^ ACCT_NUM {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accT_NUM();
function set_accT_NUM(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


AMX_CHARGE_DESCRIPTION Property

[image]

.NET Framework Class Library
PCCTransaction..::.AMX_CHARGE_DESCRIPTION Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AMX_CHARGE_DESCRIPTION As String
C#
public string AMX_CHARGE_DESCRIPTION { get; set; }
Visual C++
public:
property String^ AMX_CHARGE_DESCRIPTION {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amX_CHARGE_DESCRIPTION();
function set_amX_CHARGE_DESCRIPTION(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


AMX_DESCRIPTION_1 Property

[image]

.NET Framework Class Library
PCCTransaction..::.AMX_DESCRIPTION_1 Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AMX_DESCRIPTION_1 As String
C#
public string AMX_DESCRIPTION_1 { get; set; }
Visual C++
public:
property String^ AMX_DESCRIPTION_1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amX_DESCRIPTION_1();
function set_amX_DESCRIPTION_1(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


AMX_DESCRIPTION_2 Property

[image]

.NET Framework Class Library
PCCTransaction..::.AMX_DESCRIPTION_2 Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AMX_DESCRIPTION_2 As String
C#
public string AMX_DESCRIPTION_2 { get; set; }
Visual C++
public:
property String^ AMX_DESCRIPTION_2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amX_DESCRIPTION_2();
function set_amX_DESCRIPTION_2(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


AMX_DESCRIPTION_3 Property

[image]

.NET Framework Class Library
PCCTransaction..::.AMX_DESCRIPTION_3 Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AMX_DESCRIPTION_3 As String
C#
public string AMX_DESCRIPTION_3 { get; set; }
Visual C++
public:
property String^ AMX_DESCRIPTION_3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amX_DESCRIPTION_3();
function set_amX_DESCRIPTION_3(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


AMX_DESCRIPTION_4 Property

[image]

.NET Framework Class Library
PCCTransaction..::.AMX_DESCRIPTION_4 Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AMX_DESCRIPTION_4 As String
C#
public string AMX_DESCRIPTION_4 { get; set; }
Visual C++
public:
property String^ AMX_DESCRIPTION_4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_amX_DESCRIPTION_4();
function set_amX_DESCRIPTION_4(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


AUTH_CODE Property

[image]

.NET Framework Class Library
PCCTransaction..::.AUTH_CODE Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property AUTH_CODE As String
C#
public string AUTH_CODE { get; set; }
Visual C++
public:
property String^ AUTH_CODE {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_autH_CODE();
function set_autH_CODE(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


BILLPAY Property

[image]

.NET Framework Class Library
PCCTransaction..::.BILLPAY Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property BILLPAY As String
C#
public string BILLPAY { get; set; }
Visual C++
public:
property String^ BILLPAY {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_BILLPAY();
function set_BILLPAY(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


CARDHOLDER Property

[image]

.NET Framework Class Library
PCCTransaction..::.CARDHOLDER Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CARDHOLDER As String
C#
public string CARDHOLDER { get; set; }
Visual C++
public:
property String^ CARDHOLDER {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_CARDHOLDER();
function set_CARDHOLDER(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


CMRCL_FLAG Property

[image]

.NET Framework Class Library
PCCTransaction..::.CMRCL_FLAG Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CMRCL_FLAG As String
C#
public string CMRCL_FLAG { get; set; }
Visual C++
public:
property String^ CMRCL_FLAG {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cmrcL_FLAG();
function set_cmrcL_FLAG(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


COMMAND Property

[image]

.NET Framework Class Library
PCCTransaction..::.COMMAND Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property COMMAND As String
C#
public string COMMAND { get; set; }
Visual C++
public:
property String^ COMMAND {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_COMMAND();
function set_COMMAND(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


CREDIT_PLAN_NUMBER Property

[image]

.NET Framework Class Library
PCCTransaction..::.CREDIT_PLAN_NUMBER Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CREDIT_PLAN_NUMBER As String
C#
public string CREDIT_PLAN_NUMBER { get; set; }
Visual C++
public:
property String^ CREDIT_PLAN_NUMBER {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_crediT_PLAN_NUMBER();
function set_crediT_PLAN_NUMBER(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


CUSTOMER_CODE Property

[image]

.NET Framework Class Library
PCCTransaction..::.CUSTOMER_CODE Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CUSTOMER_CODE As String
C#
public string CUSTOMER_CODE { get; set; }
Visual C++
public:
property String^ CUSTOMER_CODE {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customeR_CODE();
function set_customeR_CODE(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


CUSTOMER_ZIP Property

[image]

.NET Framework Class Library
PCCTransaction..::.CUSTOMER_ZIP Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CUSTOMER_ZIP As String
C#
public string CUSTOMER_ZIP { get; set; }
Visual C++
public:
property String^ CUSTOMER_ZIP {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customeR_ZIP();
function set_customeR_ZIP(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


CVV2 Property

[image]

.NET Framework Class Library
PCCTransaction..::.CVV2 Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CVV2 As String
C#
public string CVV2 { get; set; }
Visual C++
public:
property String^ CVV2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cvV2();
function set_cvV2(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


DEST_ZIP_CODE Property

[image]

.NET Framework Class Library
PCCTransaction..::.DEST_ZIP_CODE Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DEST_ZIP_CODE As String
C#
public string DEST_ZIP_CODE { get; set; }
Visual C++
public:
property String^ DEST_ZIP_CODE {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_desT_ZIP_CODE();
function set_desT_ZIP_CODE(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


DRIVER_ID Property

[image]

.NET Framework Class Library
PCCTransaction..::.DRIVER_ID Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIVER_ID As String
C#
public string DRIVER_ID { get; set; }
Visual C++
public:
property String^ DRIVER_ID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_driveR_ID();
function set_driveR_ID(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


DRIVER_PIN Property

[image]

.NET Framework Class Library
PCCTransaction..::.DRIVER_PIN Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DRIVER_PIN As String
C#
public string DRIVER_PIN { get; set; }
Visual C++
public:
property String^ DRIVER_PIN {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_driveR_PIN();
function set_driveR_PIN(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


EXP_DATE Property

[image]

.NET Framework Class Library
PCCTransaction..::.EXP_DATE Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property EXP_DATE As String
C#
public string EXP_DATE { get; set; }
Visual C++
public:
property String^ EXP_DATE {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_exP_DATE();
function set_exP_DATE(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


GRATUITY_AMNT Property

[image]

.NET Framework Class Library
PCCTransaction..::.GRATUITY_AMNT Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property GRATUITY_AMNT As String
C#
public string GRATUITY_AMNT { get; set; }
Visual C++
public:
property String^ GRATUITY_AMNT {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_gratuitY_AMNT();
function set_gratuitY_AMNT(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


GRATUITY_AMNT_EST Property

[image]

.NET Framework Class Library
PCCTransaction..::.GRATUITY_AMNT_EST Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property GRATUITY_AMNT_EST As String
C#
public string GRATUITY_AMNT_EST { get; set; }
Visual C++
public:
property String^ GRATUITY_AMNT_EST {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_gratuitY_AMNT_EST();
function set_gratuitY_AMNT_EST(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


ID_NUMBER Property

[image]

.NET Framework Class Library
PCCTransaction..::.ID_NUMBER Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ID_NUMBER As String
C#
public string ID_NUMBER { get; set; }
Visual C++
public:
property String^ ID_NUMBER {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_iD_NUMBER();
function set_iD_NUMBER(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


ITEM_ID Property

[image]

.NET Framework Class Library
PCCTransaction..::.ITEM_ID Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ITEM_ID As String
C#
public string ITEM_ID { get; set; }
Visual C++
public:
property String^ ITEM_ID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_iteM_ID();
function set_iteM_ID(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


MANUAL_FLAG Property

[image]

.NET Framework Class Library
PCCTransaction..::.MANUAL_FLAG Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MANUAL_FLAG As String
C#
public string MANUAL_FLAG { get; set; }
Visual C++
public:
property String^ MANUAL_FLAG {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_manuaL_FLAG();
function set_manuaL_FLAG(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


MCSC Property

[image]

.NET Framework Class Library
PCCTransaction..::.MCSC Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MCSC As String
C#
public string MCSC { get; set; }
Visual C++
public:
property String^ MCSC {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_MCSC();
function set_MCSC(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


MCSN Property

[image]

.NET Framework Class Library
PCCTransaction..::.MCSN Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MCSN As String
C#
public string MCSN { get; set; }
Visual C++
public:
property String^ MCSN {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_MCSN();
function set_MCSN(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


MERCH_NUM Property

[image]

.NET Framework Class Library
PCCTransaction..::.MERCH_NUM Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MERCH_NUM As String
C#
public string MERCH_NUM { get; set; }
Visual C++
public:
property String^ MERCH_NUM {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mercH_NUM();
function set_mercH_NUM(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


MULTI_FLAG Property

[image]

.NET Framework Class Library
PCCTransaction..::.MULTI_FLAG Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property MULTI_FLAG As String
C#
public string MULTI_FLAG { get; set; }
Visual C++
public:
property String^ MULTI_FLAG {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_multI_FLAG();
function set_multI_FLAG(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


ODOMETER Property

[image]

.NET Framework Class Library
PCCTransaction..::.ODOMETER Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ODOMETER As String
C#
public string ODOMETER { get; set; }
Visual C++
public:
property String^ ODOMETER {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ODOMETER();
function set_ODOMETER(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


OFFLINE_FLAG Property

[image]

.NET Framework Class Library
PCCTransaction..::.OFFLINE_FLAG Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OFFLINE_FLAG As String
C#
public string OFFLINE_FLAG { get; set; }
Visual C++
public:
property String^ OFFLINE_FLAG {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_offlinE_FLAG();
function set_offlinE_FLAG(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PERIODIC_PAYMENT_FLAG Property

[image]

.NET Framework Class Library
PCCTransaction..::.PERIODIC_PAYMENT_FLAG Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PERIODIC_PAYMENT_FLAG As String
C#
public string PERIODIC_PAYMENT_FLAG { get; set; }
Visual C++
public:
property String^ PERIODIC_PAYMENT_FLAG {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_periodiC_PAYMENT_FLAG();
function set_periodiC_PAYMENT_FLAG(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PRESENT_FLAG Property

[image]

.NET Framework Class Library
PCCTransaction..::.PRESENT_FLAG Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PRESENT_FLAG As String
C#
public string PRESENT_FLAG { get; set; }
Visual C++
public:
property String^ PRESENT_FLAG {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_presenT_FLAG();
function set_presenT_FLAG(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PRINT_RECEIPTS_FLAG Property

[image]

.NET Framework Class Library
PCCTransaction..::.PRINT_RECEIPTS_FLAG Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PRINT_RECEIPTS_FLAG As String
C#
public string PRINT_RECEIPTS_FLAG { get; set; }
Visual C++
public:
property String^ PRINT_RECEIPTS_FLAG {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_prinT_RECEIPTS_FLAG();
function set_prinT_RECEIPTS_FLAG(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PROCESSOR_ID Property

[image]

.NET Framework Class Library
PCCTransaction..::.PROCESSOR_ID Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PROCESSOR_ID As String
C#
public string PROCESSOR_ID { get; set; }
Visual C++
public:
property String^ PROCESSOR_ID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processoR_ID();
function set_processoR_ID(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PRODUCT_DETAIL_AMOUNT_XX Property

[image]

.NET Framework Class Library
PCCTransaction..::.PRODUCT_DETAIL_AMOUNT_XX Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PRODUCT_DETAIL_AMOUNT_XX As String
C#
public string PRODUCT_DETAIL_AMOUNT_XX { get; set; }
Visual C++
public:
property String^ PRODUCT_DETAIL_AMOUNT_XX {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_producT_DETAIL_AMOUNT_XX();
function set_producT_DETAIL_AMOUNT_XX(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PRODUCT_DETAIL_CODE_XX Property

[image]

.NET Framework Class Library
PCCTransaction..::.PRODUCT_DETAIL_CODE_XX Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PRODUCT_DETAIL_CODE_XX As String
C#
public string PRODUCT_DETAIL_CODE_XX { get; set; }
Visual C++
public:
property String^ PRODUCT_DETAIL_CODE_XX {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_producT_DETAIL_CODE_XX();
function set_producT_DETAIL_CODE_XX(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PRODUCT_DETAIL_COUNT Property

[image]

.NET Framework Class Library
PCCTransaction..::.PRODUCT_DETAIL_COUNT Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PRODUCT_DETAIL_COUNT As String
C#
public string PRODUCT_DETAIL_COUNT { get; set; }
Visual C++
public:
property String^ PRODUCT_DETAIL_COUNT {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_producT_DETAIL_COUNT();
function set_producT_DETAIL_COUNT(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


PRODUCT_DETAIL_QUANTITY_XX Property

[image]

.NET Framework Class Library
PCCTransaction..::.PRODUCT_DETAIL_QUANTITY_XX Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property PRODUCT_DETAIL_QUANTITY_XX As String
C#
public string PRODUCT_DETAIL_QUANTITY_XX { get; set; }
Visual C++
public:
property String^ PRODUCT_DETAIL_QUANTITY_XX {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_producT_DETAIL_QUANTITY_XX();
function set_producT_DETAIL_QUANTITY_XX(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


REFERENCE Property

[image]

.NET Framework Class Library
PCCTransaction..::.REFERENCE Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property REFERENCE As String
C#
public string REFERENCE { get; set; }
Visual C++
public:
property String^ REFERENCE {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_REFERENCE();
function set_REFERENCE(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


RESTRICTION_CODE Property

[image]

.NET Framework Class Library
PCCTransaction..::.RESTRICTION_CODE Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RESTRICTION_CODE As String
C#
public string RESTRICTION_CODE { get; set; }
Visual C++
public:
property String^ RESTRICTION_CODE {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_restrictioN_CODE();
function set_restrictioN_CODE(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


RFID Property

[image]

.NET Framework Class Library
PCCTransaction..::.RFID Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property RFID As String
C#
public string RFID { get; set; }
Visual C++
public:
property String^ RFID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_RFID();
function set_RFID(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


STREET Property

[image]

.NET Framework Class Library
PCCTransaction..::.STREET Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property STREET As String
C#
public string STREET { get; set; }
Visual C++
public:
property String^ STREET {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_STREET();
function set_STREET(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


TAX_AMOUNT Property

[image]

.NET Framework Class Library
PCCTransaction..::.TAX_AMOUNT Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TAX_AMOUNT As String
C#
public string TAX_AMOUNT { get; set; }
Visual C++
public:
property String^ TAX_AMOUNT {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taX_AMOUNT();
function set_taX_AMOUNT(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


TAX_EXEMPT Property

[image]

.NET Framework Class Library
PCCTransaction..::.TAX_EXEMPT Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TAX_EXEMPT As String
C#
public string TAX_EXEMPT { get; set; }
Visual C++
public:
property String^ TAX_EXEMPT {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taX_EXEMPT();
function set_taX_EXEMPT(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


TICKET_NUM Property

[image]

.NET Framework Class Library
PCCTransaction..::.TICKET_NUM Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TICKET_NUM As String
C#
public string TICKET_NUM { get; set; }
Visual C++
public:
property String^ TICKET_NUM {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_tickeT_NUM();
function set_tickeT_NUM(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


TRACK_DATA Property

[image]

.NET Framework Class Library
PCCTransaction..::.TRACK_DATA Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TRACK_DATA As String
C#
public string TRACK_DATA { get; set; }
Visual C++
public:
property String^ TRACK_DATA {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_tracK_DATA();
function set_tracK_DATA(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


TRANS_AMOUNT Property

[image]

.NET Framework Class Library
PCCTransaction..::.TRANS_AMOUNT Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TRANS_AMOUNT As String
C#
public string TRANS_AMOUNT { get; set; }
Visual C++
public:
property String^ TRANS_AMOUNT {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_tranS_AMOUNT();
function set_tranS_AMOUNT(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


TRANS_STORE Property

[image]

.NET Framework Class Library
PCCTransaction..::.TRANS_STORE Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TRANS_STORE As String
C#
public string TRANS_STORE { get; set; }
Visual C++
public:
property String^ TRANS_STORE {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_tranS_STORE();
function set_tranS_STORE(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


TROUTD Property

[image]

.NET Framework Class Library
PCCTransaction..::.TROUTD Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TROUTD As String
C#
public string TROUTD { get; set; }
Visual C++
public:
property String^ TROUTD {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_TROUTD();
function set_TROUTD(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


TXN_TIMEOUT Property

[image]

.NET Framework Class Library
PCCTransaction..::.TXN_TIMEOUT Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property TXN_TIMEOUT As String
C#
public string TXN_TIMEOUT { get; set; }
Visual C++
public:
property String^ TXN_TIMEOUT {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_txN_TIMEOUT();
function set_txN_TIMEOUT(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


USER_ID Property

[image]

.NET Framework Class Library
PCCTransaction..::.USER_ID Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property USER_ID As String
C#
public string USER_ID { get; set; }
Visual C++
public:
property String^ USER_ID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_useR_ID();
function set_useR_ID(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


VEHICLE_ID Property

[image]

.NET Framework Class Library
PCCTransaction..::.VEHICLE_ID Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property VEHICLE_ID As String
C#
public string VEHICLE_ID { get; set; }
Visual C++
public:
property String^ VEHICLE_ID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vehiclE_ID();
function set_vehiclE_ID(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


ZIP_CODE Property

[image]

.NET Framework Class Library
PCCTransaction..::.ZIP_CODE Property
PCCTransaction Class See Also Send Feedback

Namespace: InSite.Domain.PaymentGateways
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ZIP_CODE As String
C#
public string ZIP_CODE { get; set; }
Visual C++
public:
property String^ ZIP_CODE {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ziP_CODE();
function set_ziP_CODE(value);

See Also

PCCTransaction Class
InSite.Domain.PaymentGateways Namespace


InSite.Domain.Promotions Namespace

[image]

.NET Framework Class Library
InSite.Domain.Promotions Namespace
Send Feedback

Classes

Class | Description
PromotionEngine |


PromotionEngine Class

[image]

.NET Framework Class Library
PromotionEngine Class
Members See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PromotionEngine _
    Implements IPromotionEngine
C#
[SerializableAttribute]
public class PromotionEngine : IPromotionEngine
Visual C++
[SerializableAttribute]
public ref class PromotionEngine : IPromotionEngine
JavaScript
InSite.Domain.Promotions.PromotionEngine = function();

Type.createClass(
    'InSite.Domain.Promotions.PromotionEngine',
    null,
    InSite.Model.IPromotionEngine);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Promotions..::.PromotionEngine

See Also

PromotionEngine Members
InSite.Domain.Promotions Namespace


PromotionEngine Members

[image] [image]

.NET Framework Class Library
PromotionEngine Members
PromotionEngine Class Constructors Methods Properties See Also Send Feedback

The PromotionEngine type exposes the following members.

Constructors

Name | Description
PromotionEngine | Overloaded.

Methods

Name | Description
ApplyPromotions |
ClearPromotions |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PromotionCodeExpired |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidatePromotions |

Properties

Name | Description
CustomerOrder |

See Also

PromotionEngine Class
InSite.Domain.Promotions Namespace


PromotionEngine Constructor

[image] [image]

.NET Framework Class Library
PromotionEngine Constructor
PromotionEngine Class See Also Send Feedback

Overload List

Name | Description
PromotionEngine()()() |
PromotionEngine(IList<(Of <(Promotion>)>), CustomerOrder, Customer) |
PromotionEngine(IList<(Of <(Promotion>)>), CustomerOrder, Customer, Boolean) |

See Also

PromotionEngine Class
PromotionEngine Members
InSite.Domain.Promotions Namespace


PromotionEngine Constructor

[image]

.NET Framework Class Library
PromotionEngine Constructor
PromotionEngine Class See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionEngine()
Visual C++
public:
PromotionEngine()
JavaScript
InSite.Domain.Promotions.PromotionEngine = function();

See Also

PromotionEngine Class
PromotionEngine Overload
InSite.Domain.Promotions Namespace


PromotionEngine Constructor (IList(Promotion), CustomerOrder, Customer)

[image]

.NET Framework Class Library
PromotionEngine Constructor (IList<(Of <(Promotion>)>), CustomerOrder, Customer)
PromotionEngine Class See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    promotions As IList(Of Promotion), _
    customerOrder As CustomerOrder, _
    customer As Customer _
)
C#
public PromotionEngine(
    IList<Promotion> promotions,
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
PromotionEngine(
    IList<Promotion^>^ promotions,
    CustomerOrder^ customerOrder,
    Customer^ customer
)
JavaScript
InSite.Domain.Promotions.PromotionEngine = function(promotions, customerOrder, customer);

Parameters

promotions
Type: System.Collections.Generic..::.IList <(Of <( Promotion >)>)
customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

See Also

PromotionEngine Class
PromotionEngine Overload
InSite.Domain.Promotions Namespace


PromotionEngine Constructor (IList(Promotion), CustomerOrder, Customer, Boolean)

[image]

.NET Framework Class Library
PromotionEngine Constructor (IList<(Of <(Promotion>)>), CustomerOrder, Customer, Boolean)
PromotionEngine Class See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    promotions As IList(Of Promotion), _
    customerOrder As CustomerOrder, _
    customer As Customer, _
    caseSensitive As Boolean _
)
C#
public PromotionEngine(
    IList<Promotion> promotions,
    CustomerOrder customerOrder,
    Customer customer,
    bool caseSensitive
)
Visual C++
public:
PromotionEngine(
    IList<Promotion^>^ promotions,
    CustomerOrder^ customerOrder,
    Customer^ customer,
    bool caseSensitive
)
JavaScript
InSite.Domain.Promotions.PromotionEngine = function(promotions, customerOrder, customer, caseSensitive);

Parameters

promotions
Type: System.Collections.Generic..::.IList <(Of <( Promotion >)>)
customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer
caseSensitive
Type: System..::.Boolean

See Also

PromotionEngine Class
PromotionEngine Overload
InSite.Domain.Promotions Namespace


PromotionEngine Methods

[image] [image]

.NET Framework Class Library
PromotionEngine Methods
PromotionEngine Class See Also Send Feedback

The PromotionEngine type exposes the following members.

Methods

Name | Description
ApplyPromotions |
ClearPromotions |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PromotionCodeExpired |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValidatePromotions |

See Also

PromotionEngine Class
InSite.Domain.Promotions Namespace


ApplyPromotions Method

[image]

.NET Framework Class Library
PromotionEngine..::.ApplyPromotions Method
PromotionEngine Class See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function ApplyPromotions As CustomerOrder
C#
public CustomerOrder ApplyPromotions()
Visual C++
public:
virtual CustomerOrder^ ApplyPromotions() sealed
JavaScript
function applyPromotions();

Implements

IPromotionEngine..::.ApplyPromotions()()()

See Also

PromotionEngine Class
InSite.Domain.Promotions Namespace


ClearPromotions Method

[image]

.NET Framework Class Library
PromotionEngine..::.ClearPromotions Method
PromotionEngine Class See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function ClearPromotions As CustomerOrder
C#
public CustomerOrder ClearPromotions()
Visual C++
public:
virtual CustomerOrder^ ClearPromotions() sealed
JavaScript
function clearPromotions();

Implements

IPromotionEngine..::.ClearPromotions()()()

See Also

PromotionEngine Class
InSite.Domain.Promotions Namespace


PromotionCodeExpired Method

[image]

.NET Framework Class Library
PromotionEngine..::.PromotionCodeExpired Method
PromotionEngine Class See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function PromotionCodeExpired ( _
    promotionCode As String _
) As Boolean
C#
public bool PromotionCodeExpired(
    string promotionCode
)
Visual C++
public:
bool PromotionCodeExpired(
    String^ promotionCode
)
JavaScript
function promotionCodeExpired(promotionCode);

Parameters

promotionCode
Type: System..::.String

See Also

PromotionEngine Class
InSite.Domain.Promotions Namespace


ValidatePromotions Method

[image]

.NET Framework Class Library
PromotionEngine..::.ValidatePromotions Method
PromotionEngine Class See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function ValidatePromotions As IList(Of Promotion)
C#
public IList<Promotion> ValidatePromotions()
Visual C++
public:
virtual IList<Promotion^>^ ValidatePromotions() sealed
JavaScript
function validatePromotions();

Implements

IPromotionEngine..::.ValidatePromotions()()()

See Also

PromotionEngine Class
InSite.Domain.Promotions Namespace


PromotionEngine Properties

[image] [image]

.NET Framework Class Library
PromotionEngine Properties
PromotionEngine Class See Also Send Feedback

The PromotionEngine type exposes the following members.

Properties

Name | Description
CustomerOrder |

See Also

PromotionEngine Class
InSite.Domain.Promotions Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
PromotionEngine..::.CustomerOrder Property
PromotionEngine Class See Also Send Feedback

Namespace: InSite.Domain.Promotions
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

Implements

IPromotionEngine..::.CustomerOrder

See Also

PromotionEngine Class
InSite.Domain.Promotions Namespace


InSite.Domain.Reports Namespace

[image]

.NET Framework Class Library
InSite.Domain.Reports Namespace
Send Feedback

Classes

Class | Description
CrystalReporter |


CrystalReporter Class

[image]

.NET Framework Class Library
CrystalReporter Class
Members See Also Send Feedback

Namespace: InSite.Domain.Reports
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class CrystalReporter
C#
public class CrystalReporter
Visual C++
public ref class CrystalReporter
JavaScript
InSite.Domain.Reports.CrystalReporter = function();

Type.createClass(
    'InSite.Domain.Reports.CrystalReporter');

Inheritance Hierarchy

System..::.Object
InSite.Domain.Reports..::.CrystalReporter

See Also

CrystalReporter Members
InSite.Domain.Reports Namespace


CrystalReporter Members

[image] [image]

.NET Framework Class Library
CrystalReporter Members
CrystalReporter Class Constructors Methods See Also Send Feedback

The CrystalReporter type exposes the following members.

Constructors

Name | Description
CrystalReporter |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GeneratePDF |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CrystalReporter Class
InSite.Domain.Reports Namespace


CrystalReporter Constructor

[image]

.NET Framework Class Library
CrystalReporter Constructor
CrystalReporter Class See Also Send Feedback

Namespace: InSite.Domain.Reports
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CrystalReporter()
Visual C++
public:
CrystalReporter()
JavaScript
InSite.Domain.Reports.CrystalReporter = function();

See Also

CrystalReporter Class
InSite.Domain.Reports Namespace


CrystalReporter Methods

[image] [image]

.NET Framework Class Library
CrystalReporter Methods
CrystalReporter Class See Also Send Feedback

The CrystalReporter type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GeneratePDF |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CrystalReporter Class
InSite.Domain.Reports Namespace


GeneratePDF Method

[image]

.NET Framework Class Library
CrystalReporter..::.GeneratePDF Method
CrystalReporter Class See Also Send Feedback

Namespace: InSite.Domain.Reports
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub GeneratePDF ( _
    reportName As String, _
    reportDataSets As Hashtable, _
    parms As Hashtable, _
    response As HttpResponse _
)
C#
public void GeneratePDF(
    string reportName,
    Hashtable reportDataSets,
    Hashtable parms,
    HttpResponse response
)
Visual C++
public:
void GeneratePDF(
    String^ reportName,
    Hashtable^ reportDataSets,
    Hashtable^ parms,
    HttpResponse^ response
)
JavaScript
function generatePDF(reportName, reportDataSets, parms, response);

Parameters

reportName
Type: System..::.String
reportDataSets
Type: System.Collections..::.Hashtable
parms
Type: System.Collections..::.Hashtable
response
Type: System.Web..::.HttpResponse

See Also

CrystalReporter Class
InSite.Domain.Reports Namespace


InSite.Domain.Shipping Namespace

[image]

.NET Framework Class Library
InSite.Domain.Shipping Namespace
Send Feedback

Classes

Class | Description
FedExRatingService |
FreightQuoteRatingService |
InsiteCommerceSSLCertificatePolicy |
InsiteDomainShippingException |
NoneRatingService |
OrderPackager_Generic |
Package |
RatingServiceFactory |
ShippingCost |
ShippingEngine |
ShippingProcessor |
SpeedeeDeliveryRatingService |
UPSRatingService |
UPSShip |
UPSShipAddress |

Interfaces

Interface | Description
IRatingService |
IUPSPackager |


FedExRatingService Class

[image]

.NET Framework Class Library
FedExRatingService Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class FedExRatingService _
    Implements IRatingService
C#
public class FedExRatingService : IRatingService
Visual C++
public ref class FedExRatingService : IRatingService
JavaScript
InSite.Domain.Shipping.FedExRatingService = function();

Type.createClass(
    'InSite.Domain.Shipping.FedExRatingService',
    null,
    InSite.Domain.Shipping.IRatingService);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.FedExRatingService

See Also

FedExRatingService Members
InSite.Domain.Shipping Namespace


FedExRatingService Members

[image] [image]

.NET Framework Class Library
FedExRatingService Members
FedExRatingService Class Constructors Methods Properties See Also Send Feedback

The FedExRatingService type exposes the following members.

Constructors

Name | Description
FedExRatingService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


FedExRatingService Constructor

[image]

.NET Framework Class Library
FedExRatingService Constructor
FedExRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FedExRatingService()
Visual C++
public:
FedExRatingService()
JavaScript
InSite.Domain.Shipping.FedExRatingService = function();

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


FedExRatingService Methods

[image] [image]

.NET Framework Class Library
FedExRatingService Methods
FedExRatingService Class See Also Send Feedback

The FedExRatingService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


RateShipment Method

[image]

.NET Framework Class Library
FedExRatingService..::.RateShipment Method
FedExRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function RateShipment ( _
    packages As IList(Of IPackage), _
    carrier As Carrier _
) As IList(Of ShippingCost)
C#
public IList<ShippingCost> RateShipment(
    IList<IPackage> packages,
    Carrier carrier
)
Visual C++
public:
virtual IList<ShippingCost^>^ RateShipment(
    IList<IPackage^>^ packages,
    Carrier^ carrier
) sealed
JavaScript
function rateShipment(packages, carrier);

Parameters

packages
Type: System.Collections.Generic..::.IList <(Of <( IPackage >)>)
carrier
Type: InSite.Model..::.Carrier

Implements

IRatingService..::.RateShipment(IList<(Of <(IPackage>)>), Carrier)

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


FedExRatingService Properties

[image] [image]

.NET Framework Class Library
FedExRatingService Properties
FedExRatingService Class See Also Send Feedback

The FedExRatingService type exposes the following members.

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


Company Property

[image]

.NET Framework Class Library
FedExRatingService..::.Company Property
FedExRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Company As Company
C#
public Company Company { set; }
Visual C++
public:
virtual property Company^ Company {
    void set (Company^ value) sealed;
}
JavaScript
function set_company(value);

Implements

IRatingService..::.Company

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
FedExRatingService..::.CustomerOrder Property
FedExRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property CustomerOrder As CustomerOrder
C#
public CustomerOrder CustomerOrder { set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    void set (CustomerOrder^ value) sealed;
}
JavaScript
function set_customerOrder(value);

Implements

IRatingService..::.CustomerOrder

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


DestinationZipCode Property

[image]

.NET Framework Class Library
FedExRatingService..::.DestinationZipCode Property
FedExRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestinationZipCode As String
C#
public string DestinationZipCode { set; }
Visual C++
public:
virtual property String^ DestinationZipCode {
    void set (String^ value) sealed;
}
JavaScript
function set_destinationZipCode(value);

Implements

IRatingService..::.DestinationZipCode

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


IsWholeSaleOrder Property

[image]

.NET Framework Class Library
FedExRatingService..::.IsWholeSaleOrder Property
FedExRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IsWholeSaleOrder As Boolean
C#
public bool IsWholeSaleOrder { get; set; }
Visual C++
public:
virtual property bool IsWholeSaleOrder {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_isWholeSaleOrder();
function set_isWholeSaleOrder(value);

Implements

IRatingService..::.IsWholeSaleOrder

See Also

FedExRatingService Class
InSite.Domain.Shipping Namespace


FreightQuoteRatingService Class

[image]

.NET Framework Class Library
FreightQuoteRatingService Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class FreightQuoteRatingService _
    Implements IRatingService
C#
public class FreightQuoteRatingService : IRatingService
Visual C++
public ref class FreightQuoteRatingService : IRatingService
JavaScript
InSite.Domain.Shipping.FreightQuoteRatingService = function();

Type.createClass(
    'InSite.Domain.Shipping.FreightQuoteRatingService',
    null,
    InSite.Domain.Shipping.IRatingService);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.FreightQuoteRatingService

See Also

FreightQuoteRatingService Members
InSite.Domain.Shipping Namespace


FreightQuoteRatingService Members

[image] [image]

.NET Framework Class Library
FreightQuoteRatingService Members
FreightQuoteRatingService Class Constructors Methods Properties See Also Send Feedback

The FreightQuoteRatingService type exposes the following members.

Constructors

Name | Description
FreightQuoteRatingService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


FreightQuoteRatingService Constructor

[image]

.NET Framework Class Library
FreightQuoteRatingService Constructor
FreightQuoteRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FreightQuoteRatingService()
Visual C++
public:
FreightQuoteRatingService()
JavaScript
InSite.Domain.Shipping.FreightQuoteRatingService = function();

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


FreightQuoteRatingService Methods

[image] [image]

.NET Framework Class Library
FreightQuoteRatingService Methods
FreightQuoteRatingService Class See Also Send Feedback

The FreightQuoteRatingService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


RateShipment Method

[image]

.NET Framework Class Library
FreightQuoteRatingService..::.RateShipment Method
FreightQuoteRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function RateShipment ( _
    packages As IList(Of IPackage), _
    carrier As Carrier _
) As IList(Of ShippingCost)
C#
public IList<ShippingCost> RateShipment(
    IList<IPackage> packages,
    Carrier carrier
)
Visual C++
public:
virtual IList<ShippingCost^>^ RateShipment(
    IList<IPackage^>^ packages,
    Carrier^ carrier
) sealed
JavaScript
function rateShipment(packages, carrier);

Parameters

packages
Type: System.Collections.Generic..::.IList <(Of <( IPackage >)>)
carrier
Type: InSite.Model..::.Carrier

Implements

IRatingService..::.RateShipment(IList<(Of <(IPackage>)>), Carrier)

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


FreightQuoteRatingService Properties

[image] [image]

.NET Framework Class Library
FreightQuoteRatingService Properties
FreightQuoteRatingService Class See Also Send Feedback

The FreightQuoteRatingService type exposes the following members.

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


Company Property

[image]

.NET Framework Class Library
FreightQuoteRatingService..::.Company Property
FreightQuoteRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Company As Company
C#
public Company Company { set; }
Visual C++
public:
virtual property Company^ Company {
    void set (Company^ value) sealed;
}
JavaScript
function set_company(value);

Implements

IRatingService..::.Company

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
FreightQuoteRatingService..::.CustomerOrder Property
FreightQuoteRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property CustomerOrder As CustomerOrder
C#
public CustomerOrder CustomerOrder { set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    void set (CustomerOrder^ value) sealed;
}
JavaScript
function set_customerOrder(value);

Implements

IRatingService..::.CustomerOrder

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


DestinationZipCode Property

[image]

.NET Framework Class Library
FreightQuoteRatingService..::.DestinationZipCode Property
FreightQuoteRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestinationZipCode As String
C#
public string DestinationZipCode { set; }
Visual C++
public:
virtual property String^ DestinationZipCode {
    void set (String^ value) sealed;
}
JavaScript
function set_destinationZipCode(value);

Implements

IRatingService..::.DestinationZipCode

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


IsWholeSaleOrder Property

[image]

.NET Framework Class Library
FreightQuoteRatingService..::.IsWholeSaleOrder Property
FreightQuoteRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IsWholeSaleOrder As Boolean
C#
public bool IsWholeSaleOrder { get; set; }
Visual C++
public:
virtual property bool IsWholeSaleOrder {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_isWholeSaleOrder();
function set_isWholeSaleOrder(value);

Implements

IRatingService..::.IsWholeSaleOrder

See Also

FreightQuoteRatingService Class
InSite.Domain.Shipping Namespace


InsiteCommerceSSLCertificatePolicy Class

[image]

.NET Framework Class Library
InsiteCommerceSSLCertificatePolicy Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class InsiteCommerceSSLCertificatePolicy _
    Implements ICertificatePolicy
C#
public class InsiteCommerceSSLCertificatePolicy : ICertificatePolicy
Visual C++
public ref class InsiteCommerceSSLCertificatePolicy : ICertificatePolicy
JavaScript
InSite.Domain.Shipping.InsiteCommerceSSLCertificatePolicy = function();

Type.createClass(
    'InSite.Domain.Shipping.InsiteCommerceSSLCertificatePolicy',
    null,
    ICertificatePolicy);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.InsiteCommerceSSLCertificatePolicy

See Also

InsiteCommerceSSLCertificatePolicy Members
InSite.Domain.Shipping Namespace


InsiteCommerceSSLCertificatePolicy Members

[image] [image]

.NET Framework Class Library
InsiteCommerceSSLCertificatePolicy Members
InsiteCommerceSSLCertificatePolicy Class Constructors Methods See Also Send Feedback

The InsiteCommerceSSLCertificatePolicy type exposes the following members.

Constructors

Name | Description
InsiteCommerceSSLCertificatePolicy |

Methods

Name | Description
CheckValidationResult |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsiteCommerceSSLCertificatePolicy Class
InSite.Domain.Shipping Namespace


InsiteCommerceSSLCertificatePolicy Constructor

[image]

.NET Framework Class Library
InsiteCommerceSSLCertificatePolicy Constructor
InsiteCommerceSSLCertificatePolicy Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InsiteCommerceSSLCertificatePolicy()
Visual C++
public:
InsiteCommerceSSLCertificatePolicy()
JavaScript
InSite.Domain.Shipping.InsiteCommerceSSLCertificatePolicy = function();

See Also

InsiteCommerceSSLCertificatePolicy Class
InSite.Domain.Shipping Namespace


InsiteCommerceSSLCertificatePolicy Methods

[image] [image]

.NET Framework Class Library
InsiteCommerceSSLCertificatePolicy Methods
InsiteCommerceSSLCertificatePolicy Class See Also Send Feedback

The InsiteCommerceSSLCertificatePolicy type exposes the following members.

Methods

Name | Description
CheckValidationResult |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsiteCommerceSSLCertificatePolicy Class
InSite.Domain.Shipping Namespace


CheckValidationResult Method

[image]

.NET Framework Class Library
InsiteCommerceSSLCertificatePolicy..::.CheckValidationResult Method
InsiteCommerceSSLCertificatePolicy Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function CheckValidationResult ( _
    sp As ServicePoint, _
    cert As X509Certificate, _
    request As WebRequest, _
    problem As Integer _
) As Boolean
C#
public bool CheckValidationResult(
    ServicePoint sp,
    X509Certificate cert,
    WebRequest request,
    int problem
)
Visual C++
public:
virtual bool CheckValidationResult(
    ServicePoint^ sp,
    X509Certificate^ cert,
    WebRequest^ request,
    int problem
) sealed
JavaScript
function checkValidationResult(sp, cert, request, problem);

Parameters

sp
Type: System.Net..::.ServicePoint
cert
Type: System.Security.Cryptography.X509Certificates..::.X509Certificate
request
Type: System.Net..::.WebRequest
problem
Type: System..::.Int32

Implements

ICertificatePolicy..::.CheckValidationResult(ServicePoint, X509Certificate, WebRequest, Int32)

See Also

InsiteCommerceSSLCertificatePolicy Class
InSite.Domain.Shipping Namespace


InsiteDomainShippingException Class

[image]

.NET Framework Class Library
InsiteDomainShippingException Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class InsiteDomainShippingException _
    Inherits Exception
C#
public class InsiteDomainShippingException : Exception
Visual C++
public ref class InsiteDomainShippingException : public Exception
JavaScript
InSite.Domain.Shipping.InsiteDomainShippingException = function();

Type.createClass(
    'InSite.Domain.Shipping.InsiteDomainShippingException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Domain.Shipping..::.InsiteDomainShippingException

See Also

InsiteDomainShippingException Members
InSite.Domain.Shipping Namespace


InsiteDomainShippingException Members

[image] [image]

.NET Framework Class Library
InsiteDomainShippingException Members
InsiteDomainShippingException Class Constructors Methods Properties See Also Send Feedback

The InsiteDomainShippingException type exposes the following members.

Constructors

Name | Description
InsiteDomainShippingException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InsiteDomainShippingException Class
InSite.Domain.Shipping Namespace


InsiteDomainShippingException Constructor

[image]

.NET Framework Class Library
InsiteDomainShippingException Constructor
InsiteDomainShippingException Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public InsiteDomainShippingException(
    string message
)
Visual C++
public:
InsiteDomainShippingException(
    String^ message
)
JavaScript
InSite.Domain.Shipping.InsiteDomainShippingException = function(message);

Parameters

message
Type: System..::.String

See Also

InsiteDomainShippingException Class
InSite.Domain.Shipping Namespace


InsiteDomainShippingException Methods

[image] [image]

.NET Framework Class Library
InsiteDomainShippingException Methods
InsiteDomainShippingException Class See Also Send Feedback

The InsiteDomainShippingException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InsiteDomainShippingException Class
InSite.Domain.Shipping Namespace


InsiteDomainShippingException Properties

[image] [image]

.NET Framework Class Library
InsiteDomainShippingException Properties
InsiteDomainShippingException Class See Also Send Feedback

The InsiteDomainShippingException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InsiteDomainShippingException Class
InSite.Domain.Shipping Namespace


IRatingService Interface

[image]

.NET Framework Class Library
IRatingService Interface
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRatingService
C#
public interface IRatingService
Visual C++
public interface class IRatingService
JavaScript
InSite.Domain.Shipping.IRatingService = function();
InSite.Domain.Shipping.IRatingService.createInterface('InSite.Domain.Shipping.IRatingService');

See Also

IRatingService Members
InSite.Domain.Shipping Namespace


IRatingService Members

[image] [image]

.NET Framework Class Library
IRatingService Members
IRatingService Interface Methods Properties See Also Send Feedback

The IRatingService type exposes the following members.

Methods

Name | Description
RateShipment |

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

IRatingService Interface
InSite.Domain.Shipping Namespace


IRatingService Methods

[image] [image]

.NET Framework Class Library
IRatingService Methods
IRatingService Interface See Also Send Feedback

The IRatingService type exposes the following members.

Methods

Name | Description
RateShipment |

See Also

IRatingService Interface
InSite.Domain.Shipping Namespace


RateShipment Method

[image]

.NET Framework Class Library
IRatingService..::.RateShipment Method
IRatingService Interface See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Function RateShipment ( _
    packages As IList(Of IPackage), _
    carrier As Carrier _
) As IList(Of ShippingCost)
C#
IList<ShippingCost> RateShipment(
    IList<IPackage> packages,
    Carrier carrier
)
Visual C++
IList<ShippingCost^>^ RateShipment(
    IList<IPackage^>^ packages,
    Carrier^ carrier
)
JavaScript
function rateShipment(packages, carrier);

Parameters

packages
Type: System.Collections.Generic..::.IList <(Of <( IPackage >)>)
carrier
Type: InSite.Model..::.Carrier

See Also

IRatingService Interface
InSite.Domain.Shipping Namespace


IRatingService Properties

[image] [image]

.NET Framework Class Library
IRatingService Properties
IRatingService Interface See Also Send Feedback

The IRatingService type exposes the following members.

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

IRatingService Interface
InSite.Domain.Shipping Namespace


Company Property

[image]

.NET Framework Class Library
IRatingService..::.Company Property
IRatingService Interface See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
WriteOnly Property Company As Company
C#
Company Company { set; }
Visual C++
property Company^ Company {
    void set (Company^ value);
}
JavaScript
function set_company(value);

See Also

IRatingService Interface
InSite.Domain.Shipping Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
IRatingService..::.CustomerOrder Property
IRatingService Interface See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
WriteOnly Property CustomerOrder As CustomerOrder
C#
CustomerOrder CustomerOrder { set; }
Visual C++
property CustomerOrder^ CustomerOrder {
    void set (CustomerOrder^ value);
}
JavaScript
function set_customerOrder(value);

See Also

IRatingService Interface
InSite.Domain.Shipping Namespace


DestinationZipCode Property

[image]

.NET Framework Class Library
IRatingService..::.DestinationZipCode Property
IRatingService Interface See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
WriteOnly Property DestinationZipCode As String
C#
string DestinationZipCode { set; }
Visual C++
property String^ DestinationZipCode {
    void set (String^ value);
}
JavaScript
function set_destinationZipCode(value);

See Also

IRatingService Interface
InSite.Domain.Shipping Namespace


IsWholeSaleOrder Property

[image]

.NET Framework Class Library
IRatingService..::.IsWholeSaleOrder Property
IRatingService Interface See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Property IsWholeSaleOrder As Boolean
C#
bool IsWholeSaleOrder { get; set; }
Visual C++
property bool IsWholeSaleOrder {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isWholeSaleOrder();
function set_isWholeSaleOrder(value);

See Also

IRatingService Interface
InSite.Domain.Shipping Namespace


IUPSPackager Interface

[image]

.NET Framework Class Library
IUPSPackager Interface
See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Interface IUPSPackager
C#
public interface IUPSPackager
Visual C++
public interface class IUPSPackager
JavaScript
InSite.Domain.Shipping.IUPSPackager = function();
InSite.Domain.Shipping.IUPSPackager.createInterface('InSite.Domain.Shipping.IUPSPackager');

See Also

InSite.Domain.Shipping Namespace


NoneRatingService Class

[image]

.NET Framework Class Library
NoneRatingService Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class NoneRatingService _
    Implements IRatingService
C#
public class NoneRatingService : IRatingService
Visual C++
public ref class NoneRatingService : IRatingService
JavaScript
InSite.Domain.Shipping.NoneRatingService = function();

Type.createClass(
    'InSite.Domain.Shipping.NoneRatingService',
    null,
    InSite.Domain.Shipping.IRatingService);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.NoneRatingService

See Also

NoneRatingService Members
InSite.Domain.Shipping Namespace


NoneRatingService Members

[image] [image]

.NET Framework Class Library
NoneRatingService Members
NoneRatingService Class Constructors Methods Properties See Also Send Feedback

The NoneRatingService type exposes the following members.

Constructors

Name | Description
NoneRatingService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


NoneRatingService Constructor

[image]

.NET Framework Class Library
NoneRatingService Constructor
NoneRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NoneRatingService()
Visual C++
public:
NoneRatingService()
JavaScript
InSite.Domain.Shipping.NoneRatingService = function();

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


NoneRatingService Methods

[image] [image]

.NET Framework Class Library
NoneRatingService Methods
NoneRatingService Class See Also Send Feedback

The NoneRatingService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


RateShipment Method

[image]

.NET Framework Class Library
NoneRatingService..::.RateShipment Method
NoneRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function RateShipment ( _
    packages As IList(Of IPackage), _
    carrier As Carrier _
) As IList(Of ShippingCost)
C#
public IList<ShippingCost> RateShipment(
    IList<IPackage> packages,
    Carrier carrier
)
Visual C++
public:
virtual IList<ShippingCost^>^ RateShipment(
    IList<IPackage^>^ packages,
    Carrier^ carrier
) sealed
JavaScript
function rateShipment(packages, carrier);

Parameters

packages
Type: System.Collections.Generic..::.IList <(Of <( IPackage >)>)
carrier
Type: InSite.Model..::.Carrier

Implements

IRatingService..::.RateShipment(IList<(Of <(IPackage>)>), Carrier)

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


NoneRatingService Properties

[image] [image]

.NET Framework Class Library
NoneRatingService Properties
NoneRatingService Class See Also Send Feedback

The NoneRatingService type exposes the following members.

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


Company Property

[image]

.NET Framework Class Library
NoneRatingService..::.Company Property
NoneRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Company As Company
C#
public Company Company { set; }
Visual C++
public:
virtual property Company^ Company {
    void set (Company^ value) sealed;
}
JavaScript
function set_company(value);

Implements

IRatingService..::.Company

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
NoneRatingService..::.CustomerOrder Property
NoneRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property CustomerOrder As CustomerOrder
C#
public CustomerOrder CustomerOrder { set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    void set (CustomerOrder^ value) sealed;
}
JavaScript
function set_customerOrder(value);

Implements

IRatingService..::.CustomerOrder

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


DestinationZipCode Property

[image]

.NET Framework Class Library
NoneRatingService..::.DestinationZipCode Property
NoneRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestinationZipCode As String
C#
public string DestinationZipCode { set; }
Visual C++
public:
virtual property String^ DestinationZipCode {
    void set (String^ value) sealed;
}
JavaScript
function set_destinationZipCode(value);

Implements

IRatingService..::.DestinationZipCode

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


IsWholeSaleOrder Property

[image]

.NET Framework Class Library
NoneRatingService..::.IsWholeSaleOrder Property
NoneRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IsWholeSaleOrder As Boolean
C#
public bool IsWholeSaleOrder { get; set; }
Visual C++
public:
virtual property bool IsWholeSaleOrder {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_isWholeSaleOrder();
function set_isWholeSaleOrder(value);

Implements

IRatingService..::.IsWholeSaleOrder

See Also

NoneRatingService Class
InSite.Domain.Shipping Namespace


OrderPackager_Generic Class

[image]

.NET Framework Class Library
OrderPackager_Generic Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OrderPackager_Generic _
    Implements IOrderPackager
C#
[SerializableAttribute]
public class OrderPackager_Generic : IOrderPackager
Visual C++
[SerializableAttribute]
public ref class OrderPackager_Generic : IOrderPackager
JavaScript
InSite.Domain.Shipping.OrderPackager_Generic = function();

Type.createClass(
    'InSite.Domain.Shipping.OrderPackager_Generic',
    null,
    InSite.Model.IOrderPackager);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.OrderPackager_Generic

See Also

OrderPackager_Generic Members
InSite.Domain.Shipping Namespace


OrderPackager_Generic Members

[image] [image]

.NET Framework Class Library
OrderPackager_Generic Members
OrderPackager_Generic Class Constructors Methods See Also Send Feedback

The OrderPackager_Generic type exposes the following members.

Constructors

Name | Description
OrderPackager_Generic |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakePackages | MakePackages - Goes through the OrderLine by OrderLine quantity and adds the products in to the package defined in the Carrier, when the total weight of the items contained in the package reaches (but stays below) the weight in the package defined in the Carrier, it creates a new package and adds items to it until enough packages are created for all the products in the Order
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrderPackager_Generic Class
InSite.Domain.Shipping Namespace


OrderPackager_Generic Constructor

[image]

.NET Framework Class Library
OrderPackager_Generic Constructor
OrderPackager_Generic Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OrderPackager_Generic()
Visual C++
public:
OrderPackager_Generic()
JavaScript
InSite.Domain.Shipping.OrderPackager_Generic = function();

See Also

OrderPackager_Generic Class
InSite.Domain.Shipping Namespace


OrderPackager_Generic Methods

[image] [image]

.NET Framework Class Library
OrderPackager_Generic Methods
OrderPackager_Generic Class See Also Send Feedback

The OrderPackager_Generic type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MakePackages | MakePackages - Goes through the OrderLine by OrderLine quantity and adds the products in to the package defined in the Carrier, when the total weight of the items contained in the package reaches (but stays below) the weight in the package defined in the Carrier, it creates a new package and adds items to it until enough packages are created for all the products in the Order
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrderPackager_Generic Class
InSite.Domain.Shipping Namespace


MakePackages Method

[image]

.NET Framework Class Library
OrderPackager_Generic..::.MakePackages Method
OrderPackager_Generic Class See Also Send Feedback

MakePackages - Goes through the OrderLine by OrderLine quantity and adds the products in to the package defined in the Carrier, when the total weight of the items contained in the package reaches (but stays below) the weight in the package defined in the Carrier, it creates a new package and adds items to it until enough packages are created for all the products in the Order

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function MakePackages ( _
    customerOrder As CustomerOrder, _
    carrier As Carrier _
) As IList(Of IPackage)
C#
public IList<IPackage> MakePackages(
    CustomerOrder customerOrder,
    Carrier carrier
)
Visual C++
public:
virtual IList<IPackage^>^ MakePackages(
    CustomerOrder^ customerOrder,
    Carrier^ carrier
) sealed
JavaScript
function makePackages(customerOrder, carrier);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
carrier
Type: InSite.Model..::.Carrier

Return Value

A list of Packages as defined by the Carrier being rated

Implements

IOrderPackager..::.MakePackages(CustomerOrder, Carrier)

See Also

OrderPackager_Generic Class
InSite.Domain.Shipping Namespace


Package Class

[image]

.NET Framework Class Library
Package Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Package _
    Implements IPackage
C#
[SerializableAttribute]
public class Package : IPackage
Visual C++
[SerializableAttribute]
public ref class Package : IPackage
JavaScript
InSite.Domain.Shipping.Package = function();

Type.createClass(
    'InSite.Domain.Shipping.Package',
    null,
    InSite.Model.IPackage);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.Package

See Also

Package Members
InSite.Domain.Shipping Namespace


Package Members

[image] [image]

.NET Framework Class Library
Package Members
Package Class Constructors Methods Properties See Also Send Feedback

The Package type exposes the following members.

Constructors

Name | Description
Package |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height |
ItemCount |
Length |
ShippingClassification |
Type |
Weight |
Width |

See Also

Package Class
InSite.Domain.Shipping Namespace


Package Constructor

[image]

.NET Framework Class Library
Package Constructor
Package Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Package()
Visual C++
public:
Package()
JavaScript
InSite.Domain.Shipping.Package = function();

See Also

Package Class
InSite.Domain.Shipping Namespace


Package Methods

[image] [image]

.NET Framework Class Library
Package Methods
Package Class See Also Send Feedback

The Package type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Package Class
InSite.Domain.Shipping Namespace


Package Properties

[image] [image]

.NET Framework Class Library
Package Properties
Package Class See Also Send Feedback

The Package type exposes the following members.

Properties

Name | Description
Height |
ItemCount |
Length |
ShippingClassification |
Type |
Weight |
Width |

See Also

Package Class
InSite.Domain.Shipping Namespace


Height Property

[image]

.NET Framework Class Library
Package..::.Height Property
Package Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Decimal
C#
public decimal Height { get; set; }
Visual C++
public:
virtual property Decimal Height {
    Decimal get () sealed;
    void set (Decimal value) sealed;
}
JavaScript
function get_height();
function set_height(value);

Implements

IPackage..::.Height

See Also

Package Class
InSite.Domain.Shipping Namespace


ItemCount Property

[image]

.NET Framework Class Library
Package..::.ItemCount Property
Package Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ItemCount As Integer
C#
public int ItemCount { get; set; }
Visual C++
public:
virtual property int ItemCount {
    int get () sealed;
    void set (int value) sealed;
}
JavaScript
function get_itemCount();
function set_itemCount(value);

Implements

IPackage..::.ItemCount

See Also

Package Class
InSite.Domain.Shipping Namespace


Length Property

[image]

.NET Framework Class Library
Package..::.Length Property
Package Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Decimal
C#
public decimal Length { get; set; }
Visual C++
public:
virtual property Decimal Length {
    Decimal get () sealed;
    void set (Decimal value) sealed;
}
JavaScript
function get_length();
function set_length(value);

Implements

IPackage..::.Length

See Also

Package Class
InSite.Domain.Shipping Namespace


ShippingClassification Property

[image]

.NET Framework Class Library
Package..::.ShippingClassification Property
Package Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShippingClassification As String
C#
public string ShippingClassification { get; set; }
Visual C++
public:
virtual property String^ ShippingClassification {
    String^ get () sealed;
    void set (String^ value) sealed;
}
JavaScript
function get_shippingClassification();
function set_shippingClassification(value);

Implements

IPackage..::.ShippingClassification

See Also

Package Class
InSite.Domain.Shipping Namespace


Type Property

[image]

.NET Framework Class Library
Package..::.Type Property
Package Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
Visual C++
public:
virtual property String^ Type {
    String^ get () sealed;
    void set (String^ value) sealed;
}
JavaScript
function get_type();
function set_type(value);

Implements

IPackage..::.Type

See Also

Package Class
InSite.Domain.Shipping Namespace


Weight Property

[image]

.NET Framework Class Library
Package..::.Weight Property
Package Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Weight As Decimal
C#
public decimal Weight { get; set; }
Visual C++
public:
virtual property Decimal Weight {
    Decimal get () sealed;
    void set (Decimal value) sealed;
}
JavaScript
function get_weight();
function set_weight(value);

Implements

IPackage..::.Weight

See Also

Package Class
InSite.Domain.Shipping Namespace


Width Property

[image]

.NET Framework Class Library
Package..::.Width Property
Package Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Decimal
C#
public decimal Width { get; set; }
Visual C++
public:
virtual property Decimal Width {
    Decimal get () sealed;
    void set (Decimal value) sealed;
}
JavaScript
function get_width();
function set_width(value);

Implements

IPackage..::.Width

See Also

Package Class
InSite.Domain.Shipping Namespace


RatingServiceFactory Class

[image]

.NET Framework Class Library
RatingServiceFactory Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class RatingServiceFactory
C#
public class RatingServiceFactory
Visual C++
public ref class RatingServiceFactory
JavaScript
InSite.Domain.Shipping.RatingServiceFactory = function();

Type.createClass(
    'InSite.Domain.Shipping.RatingServiceFactory');

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.RatingServiceFactory

See Also

RatingServiceFactory Members
InSite.Domain.Shipping Namespace


RatingServiceFactory Members

[image] [image]

.NET Framework Class Library
RatingServiceFactory Members
RatingServiceFactory Class Constructors Methods See Also Send Feedback

The RatingServiceFactory type exposes the following members.

Constructors

Name | Description
RatingServiceFactory |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRatingService |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RatingServiceFactory Class
InSite.Domain.Shipping Namespace


RatingServiceFactory Constructor

[image]

.NET Framework Class Library
RatingServiceFactory Constructor
RatingServiceFactory Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RatingServiceFactory()
Visual C++
public:
RatingServiceFactory()
JavaScript
InSite.Domain.Shipping.RatingServiceFactory = function();

See Also

RatingServiceFactory Class
InSite.Domain.Shipping Namespace


RatingServiceFactory Methods

[image] [image]

.NET Framework Class Library
RatingServiceFactory Methods
RatingServiceFactory Class See Also Send Feedback

The RatingServiceFactory type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRatingService |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RatingServiceFactory Class
InSite.Domain.Shipping Namespace


GetRatingService Method

[image]

.NET Framework Class Library
RatingServiceFactory..::.GetRatingService Method
RatingServiceFactory Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRatingService ( _
    carrier As Carrier _
) As IRatingService
C#
public static IRatingService GetRatingService(
    Carrier carrier
)
Visual C++
public:
static IRatingService^ GetRatingService(
    Carrier^ carrier
)
JavaScript
InSite.Domain.Shipping.RatingServiceFactory.getRatingService = function(carrier);

Parameters

carrier
Type: InSite.Model..::.Carrier

See Also

RatingServiceFactory Class
InSite.Domain.Shipping Namespace


ShippingCost Class

[image]

.NET Framework Class Library
ShippingCost Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ShippingCost _
    Implements IShippingCost
C#
[SerializableAttribute]
public class ShippingCost : IShippingCost
Visual C++
[SerializableAttribute]
public ref class ShippingCost : IShippingCost
JavaScript
InSite.Domain.Shipping.ShippingCost = function();

Type.createClass(
    'InSite.Domain.Shipping.ShippingCost',
    null,
    InSite.Model.IShippingCost);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.ShippingCost

See Also

ShippingCost Members
InSite.Domain.Shipping Namespace


ShippingCost Members

[image] [image]

.NET Framework Class Library
ShippingCost Members
ShippingCost Class Constructors Methods Properties See Also Send Feedback

The ShippingCost type exposes the following members.

Constructors

Name | Description
ShippingCost | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cost |
Description |
DescriptionAndCost |
FreightQuoteId |
ShipCode |
ShipVia |

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


ShippingCost Constructor

[image] [image]

.NET Framework Class Library
ShippingCost Constructor
ShippingCost Class See Also Send Feedback

Overload List

Name | Description
ShippingCost()()() |
ShippingCost(ShipVia, Decimal) |

See Also

ShippingCost Class
ShippingCost Members
InSite.Domain.Shipping Namespace


ShippingCost Constructor

[image]

.NET Framework Class Library
ShippingCost Constructor
ShippingCost Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShippingCost()
Visual C++
public:
ShippingCost()
JavaScript
InSite.Domain.Shipping.ShippingCost = function();

See Also

ShippingCost Class
ShippingCost Overload
InSite.Domain.Shipping Namespace


ShippingCost Constructor (ShipVia, Decimal)

[image]

.NET Framework Class Library
ShippingCost Constructor (ShipVia, Decimal)
ShippingCost Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    shipVia As ShipVia, _
    cost As Decimal _
)
C#
public ShippingCost(
    ShipVia shipVia,
    decimal cost
)
Visual C++
public:
ShippingCost(
    ShipVia^ shipVia,
    Decimal cost
)
JavaScript
InSite.Domain.Shipping.ShippingCost = function(shipVia, cost);

Parameters

shipVia
Type: InSite.Model..::.ShipVia
cost
Type: System..::.Decimal

See Also

ShippingCost Class
ShippingCost Overload
InSite.Domain.Shipping Namespace


ShippingCost Methods

[image] [image]

.NET Framework Class Library
ShippingCost Methods
ShippingCost Class See Also Send Feedback

The ShippingCost type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


ShippingCost Properties

[image] [image]

.NET Framework Class Library
ShippingCost Properties
ShippingCost Class See Also Send Feedback

The ShippingCost type exposes the following members.

Properties

Name | Description
Cost |
Description |
DescriptionAndCost |
FreightQuoteId |
ShipCode |
ShipVia |

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


Cost Property

[image]

.NET Framework Class Library
ShippingCost..::.Cost Property
ShippingCost Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Cost As Decimal
C#
public decimal Cost { get; set; }
Visual C++
public:
virtual property Decimal Cost {
    Decimal get () sealed;
    void set (Decimal value) sealed;
}
JavaScript
function get_cost();
function set_cost(value);

Implements

IShippingCost..::.Cost

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


Description Property

[image]

.NET Framework Class Library
ShippingCost..::.Description Property
ShippingCost Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Description As String
C#
public virtual string Description { get; }
Visual C++
public:
virtual property String^ Description {
    String^ get ();
}
JavaScript
function get_description();

Implements

IShippingCost..::.Description

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


DescriptionAndCost Property

[image]

.NET Framework Class Library
ShippingCost..::.DescriptionAndCost Property
ShippingCost Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DescriptionAndCost As String
C#
public virtual string DescriptionAndCost { get; }
Visual C++
public:
virtual property String^ DescriptionAndCost {
    String^ get ();
}
JavaScript
function get_descriptionAndCost();

Implements

IShippingCost..::.DescriptionAndCost

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


FreightQuoteId Property

[image]

.NET Framework Class Library
ShippingCost..::.FreightQuoteId Property
ShippingCost Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property FreightQuoteId As String
C#
public string FreightQuoteId { get; set; }
Visual C++
public:
property String^ FreightQuoteId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_freightQuoteId();
function set_freightQuoteId(value);

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


ShipCode Property

[image]

.NET Framework Class Library
ShippingCost..::.ShipCode Property
ShippingCost Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShipCode As String
C#
public string ShipCode { get; }
Visual C++
public:
virtual property String^ ShipCode {
    String^ get () sealed;
}
JavaScript
function get_shipCode();

Implements

IShippingCost..::.ShipCode

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


ShipVia Property

[image]

.NET Framework Class Library
ShippingCost..::.ShipVia Property
ShippingCost Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipVia As ShipVia
C#
public ShipVia ShipVia { get; set; }
Visual C++
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get () sealed;
    void set (ShipVia^ value) sealed;
}
JavaScript
function get_shipVia();
function set_shipVia(value);

Implements

IShippingCost..::.ShipVia

See Also

ShippingCost Class
InSite.Domain.Shipping Namespace


ShippingEngine Class

[image]

.NET Framework Class Library
ShippingEngine Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ShippingEngine _
    Implements IShippingEngine
C#
[SerializableAttribute]
public class ShippingEngine : IShippingEngine
Visual C++
[SerializableAttribute]
public ref class ShippingEngine : IShippingEngine
JavaScript
InSite.Domain.Shipping.ShippingEngine = function();

Type.createClass(
    'InSite.Domain.Shipping.ShippingEngine',
    null,
    InSite.Model.IShippingEngine);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.ShippingEngine

See Also

ShippingEngine Members
InSite.Domain.Shipping Namespace


ShippingEngine Members

[image] [image]

.NET Framework Class Library
ShippingEngine Members
ShippingEngine Class Constructors Methods Properties See Also Send Feedback

The ShippingEngine type exposes the following members.

Constructors

Name | Description
ShippingEngine | Overloaded.

Methods

Name | Description
AddShippingCost |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessShipping |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Carriers |
Company |
CustomerOrder |
DefaultShippingCost |
DestinationZipCode |
IsWholeSaleOrder |
OrderPackager |
ShippingCosts |
ShipVias |

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


ShippingEngine Constructor

[image] [image]

.NET Framework Class Library
ShippingEngine Constructor
ShippingEngine Class See Also Send Feedback

Overload List

Name | Description
ShippingEngine()()() |
ShippingEngine(CustomerOrder, IList<(Of <(Carrier>)>), Company) |
ShippingEngine(CustomerOrder, IList<(Of <(Carrier>)>), Company, String) |

See Also

ShippingEngine Class
ShippingEngine Members
InSite.Domain.Shipping Namespace


ShippingEngine Constructor

[image]

.NET Framework Class Library
ShippingEngine Constructor
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShippingEngine()
Visual C++
public:
ShippingEngine()
JavaScript
InSite.Domain.Shipping.ShippingEngine = function();

See Also

ShippingEngine Class
ShippingEngine Overload
InSite.Domain.Shipping Namespace


ShippingEngine Constructor (CustomerOrder, IList(Carrier), Company)

[image]

.NET Framework Class Library
ShippingEngine Constructor (CustomerOrder, IList<(Of <(Carrier>)>), Company)
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    customerOrder As CustomerOrder, _
    carriers As IList(Of Carrier), _
    company As Company _
)
C#
public ShippingEngine(
    CustomerOrder customerOrder,
    IList<Carrier> carriers,
    Company company
)
Visual C++
public:
ShippingEngine(
    CustomerOrder^ customerOrder,
    IList<Carrier^>^ carriers,
    Company^ company
)
JavaScript
InSite.Domain.Shipping.ShippingEngine = function(customerOrder, carriers, company);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
carriers
Type: System.Collections.Generic..::.IList <(Of <( Carrier >)>)
company
Type: InSite.Model..::.Company

See Also

ShippingEngine Class
ShippingEngine Overload
InSite.Domain.Shipping Namespace


ShippingEngine Constructor (CustomerOrder, IList(Carrier), Company, String)

[image]

.NET Framework Class Library
ShippingEngine Constructor (CustomerOrder, IList<(Of <(Carrier>)>), Company, String)
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    customerOrder As CustomerOrder, _
    carriers As IList(Of Carrier), _
    company As Company, _
    destinationZipCode As String _
)
C#
public ShippingEngine(
    CustomerOrder customerOrder,
    IList<Carrier> carriers,
    Company company,
    string destinationZipCode
)
Visual C++
public:
ShippingEngine(
    CustomerOrder^ customerOrder,
    IList<Carrier^>^ carriers,
    Company^ company,
    String^ destinationZipCode
)
JavaScript
InSite.Domain.Shipping.ShippingEngine = function(customerOrder, carriers, company, destinationZipCode);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
carriers
Type: System.Collections.Generic..::.IList <(Of <( Carrier >)>)
company
Type: InSite.Model..::.Company
destinationZipCode
Type: System..::.String

See Also

ShippingEngine Class
ShippingEngine Overload
InSite.Domain.Shipping Namespace


ShippingEngine Methods

[image] [image]

.NET Framework Class Library
ShippingEngine Methods
ShippingEngine Class See Also Send Feedback

The ShippingEngine type exposes the following members.

Methods

Name | Description
AddShippingCost |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ProcessShipping |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


AddShippingCost Method

[image]

.NET Framework Class Library
ShippingEngine..::.AddShippingCost Method
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Protected Sub AddShippingCost ( _
    shippingCost As ShippingCost _
)
C#
protected void AddShippingCost(
    ShippingCost shippingCost
)
Visual C++
protected:
void AddShippingCost(
    ShippingCost^ shippingCost
)
JavaScript
function addShippingCost(shippingCost);

Parameters

shippingCost
Type: InSite.Domain.Shipping..::.ShippingCost

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


ProcessShipping Method

[image]

.NET Framework Class Library
ShippingEngine..::.ProcessShipping Method
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ProcessShipping
C#
public virtual void ProcessShipping()
Visual C++
public:
virtual void ProcessShipping()
JavaScript
function processShipping();

Implements

IShippingEngine..::.ProcessShipping()()()

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


ShippingEngine Properties

[image] [image]

.NET Framework Class Library
ShippingEngine Properties
ShippingEngine Class See Also Send Feedback

The ShippingEngine type exposes the following members.

Properties

Name | Description
Carriers |
Company |
CustomerOrder |
DefaultShippingCost |
DestinationZipCode |
IsWholeSaleOrder |
OrderPackager |
ShippingCosts |
ShipVias |

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


Carriers Property

[image]

.NET Framework Class Library
ShippingEngine..::.Carriers Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Carriers As IList(Of Carrier)
C#
public IList<Carrier> Carriers { get; set; }
Visual C++
public:
virtual property IList<Carrier^>^ Carriers {
    IList<Carrier^>^ get () sealed;
    void set (IList<Carrier^>^ value) sealed;
}
JavaScript
function get_carriers();
function set_carriers(value);

Implements

IShippingEngine..::.Carriers

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


Company Property

[image]

.NET Framework Class Library
ShippingEngine..::.Company Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property Company As Company
C#
public Company Company { get; set; }
Visual C++
public:
virtual property Company^ Company {
    Company^ get () sealed;
    void set (Company^ value) sealed;
}
JavaScript
function get_company();
function set_company(value);

Implements

IShippingEngine..::.Company

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
ShippingEngine..::.CustomerOrder Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerOrder As CustomerOrder
C#
public CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get () sealed;
    void set (CustomerOrder^ value) sealed;
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

Implements

IShippingEngine..::.CustomerOrder

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


DefaultShippingCost Property

[image]

.NET Framework Class Library
ShippingEngine..::.DefaultShippingCost Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultShippingCost As IShippingCost
C#
public IShippingCost DefaultShippingCost { get; }
Visual C++
public:
virtual property IShippingCost^ DefaultShippingCost {
    IShippingCost^ get () sealed;
}
JavaScript
function get_defaultShippingCost();

Implements

IShippingEngine..::.DefaultShippingCost

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


DestinationZipCode Property

[image]

.NET Framework Class Library
ShippingEngine..::.DestinationZipCode Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property DestinationZipCode As String
C#
public string DestinationZipCode { get; set; }
Visual C++
public:
virtual property String^ DestinationZipCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}
JavaScript
function get_destinationZipCode();
function set_destinationZipCode(value);

Implements

IShippingEngine..::.DestinationZipCode

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


IsWholeSaleOrder Property

[image]

.NET Framework Class Library
ShippingEngine..::.IsWholeSaleOrder Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IsWholeSaleOrder As Boolean
C#
public bool IsWholeSaleOrder { get; set; }
Visual C++
public:
virtual property bool IsWholeSaleOrder {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_isWholeSaleOrder();
function set_isWholeSaleOrder(value);

Implements

IShippingEngine..::.IsWholeSaleOrder

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


OrderPackager Property

[image]

.NET Framework Class Library
ShippingEngine..::.OrderPackager Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OrderPackager As IOrderPackager
C#
public IOrderPackager OrderPackager { get; set; }
Visual C++
public:
virtual property IOrderPackager^ OrderPackager {
    IOrderPackager^ get () sealed;
    void set (IOrderPackager^ value) sealed;
}
JavaScript
function get_orderPackager();
function set_orderPackager(value);

Implements

IShippingEngine..::.OrderPackager

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


ShippingCosts Property

[image]

.NET Framework Class Library
ShippingEngine..::.ShippingCosts Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ShippingCosts As IList(Of IShippingCost)
C#
public IList<IShippingCost> ShippingCosts { get; }
Visual C++
public:
virtual property IList<IShippingCost^>^ ShippingCosts {
    IList<IShippingCost^>^ get () sealed;
}
JavaScript
function get_shippingCosts();

Implements

IShippingEngine..::.ShippingCosts

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


ShipVias Property

[image]

.NET Framework Class Library
ShippingEngine..::.ShipVias Property
ShippingEngine Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipVias As IList(Of ShipVia)
C#
public virtual IList<ShipVia> ShipVias { get; set; }
Visual C++
public:
virtual property IList<ShipVia^>^ ShipVias {
    IList<ShipVia^>^ get ();
    void set (IList<ShipVia^>^ value);
}
JavaScript
function get_shipVias();
function set_shipVias(value);

Implements

IShippingEngine..::.ShipVias

See Also

ShippingEngine Class
InSite.Domain.Shipping Namespace


ShippingProcessor Class

[image]

.NET Framework Class Library
ShippingProcessor Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class ShippingProcessor
C#
public class ShippingProcessor
Visual C++
public ref class ShippingProcessor
JavaScript
InSite.Domain.Shipping.ShippingProcessor = function();

Type.createClass(
    'InSite.Domain.Shipping.ShippingProcessor');

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.ShippingProcessor

See Also

ShippingProcessor Members
InSite.Domain.Shipping Namespace


ShippingProcessor Members

[image] [image]

.NET Framework Class Library
ShippingProcessor Members
ShippingProcessor Class Constructors Methods Properties See Also Send Feedback

The ShippingProcessor type exposes the following members.

Constructors

Name | Description
ShippingProcessor | Overloaded.

Methods

Name | Description
CalculateShipping |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
OrderPackager |

See Also

ShippingProcessor Class
InSite.Domain.Shipping Namespace


ShippingProcessor Constructor

[image] [image]

.NET Framework Class Library
ShippingProcessor Constructor
ShippingProcessor Class See Also Send Feedback

Overload List

Name | Description
ShippingProcessor()()() |
ShippingProcessor(IOrderPackager) |

See Also

ShippingProcessor Class
ShippingProcessor Members
InSite.Domain.Shipping Namespace


ShippingProcessor Constructor

[image]

.NET Framework Class Library
ShippingProcessor Constructor
ShippingProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShippingProcessor()
Visual C++
public:
ShippingProcessor()
JavaScript
InSite.Domain.Shipping.ShippingProcessor = function();

See Also

ShippingProcessor Class
ShippingProcessor Overload
InSite.Domain.Shipping Namespace


ShippingProcessor Constructor (IOrderPackager)

[image]

.NET Framework Class Library
ShippingProcessor Constructor (IOrderPackager)
ShippingProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    orderPackager As IOrderPackager _
)
C#
public ShippingProcessor(
    IOrderPackager orderPackager
)
Visual C++
public:
ShippingProcessor(
    IOrderPackager^ orderPackager
)
JavaScript
InSite.Domain.Shipping.ShippingProcessor = function(orderPackager);

Parameters

orderPackager
Type: InSite.Model..::.IOrderPackager

See Also

ShippingProcessor Class
ShippingProcessor Overload
InSite.Domain.Shipping Namespace


ShippingProcessor Methods

[image] [image]

.NET Framework Class Library
ShippingProcessor Methods
ShippingProcessor Class See Also Send Feedback

The ShippingProcessor type exposes the following members.

Methods

Name | Description
CalculateShipping |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShippingProcessor Class
InSite.Domain.Shipping Namespace


CalculateShipping Method

[image]

.NET Framework Class Library
ShippingProcessor..::.CalculateShipping Method
ShippingProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function CalculateShipping ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public CustomerOrder CalculateShipping(
    CustomerOrder customerOrder
)
Visual C++
public:
CustomerOrder^ CalculateShipping(
    CustomerOrder^ customerOrder
)
JavaScript
function calculateShipping(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

ShippingProcessor Class
InSite.Domain.Shipping Namespace


ShippingProcessor Properties

[image] [image]

.NET Framework Class Library
ShippingProcessor Properties
ShippingProcessor Class See Also Send Feedback

The ShippingProcessor type exposes the following members.

Properties

Name | Description
OrderPackager |

See Also

ShippingProcessor Class
InSite.Domain.Shipping Namespace


OrderPackager Property

[image]

.NET Framework Class Library
ShippingProcessor..::.OrderPackager Property
ShippingProcessor Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property OrderPackager As IOrderPackager
C#
public IOrderPackager OrderPackager { get; set; }
Visual C++
public:
property IOrderPackager^ OrderPackager {
    IOrderPackager^ get ();
    void set (IOrderPackager^ value);
}
JavaScript
function get_orderPackager();
function set_orderPackager(value);

See Also

ShippingProcessor Class
InSite.Domain.Shipping Namespace


SpeedeeDeliveryRatingService Class

[image]

.NET Framework Class Library
SpeedeeDeliveryRatingService Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class SpeedeeDeliveryRatingService _
    Implements IRatingService
C#
public class SpeedeeDeliveryRatingService : IRatingService
Visual C++
public ref class SpeedeeDeliveryRatingService : IRatingService
JavaScript
InSite.Domain.Shipping.SpeedeeDeliveryRatingService = function();

Type.createClass(
    'InSite.Domain.Shipping.SpeedeeDeliveryRatingService',
    null,
    InSite.Domain.Shipping.IRatingService);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.SpeedeeDeliveryRatingService

See Also

SpeedeeDeliveryRatingService Members
InSite.Domain.Shipping Namespace


SpeedeeDeliveryRatingService Members

[image] [image]

.NET Framework Class Library
SpeedeeDeliveryRatingService Members
SpeedeeDeliveryRatingService Class Constructors Methods Properties See Also Send Feedback

The SpeedeeDeliveryRatingService type exposes the following members.

Constructors

Name | Description
SpeedeeDeliveryRatingService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


SpeedeeDeliveryRatingService Constructor

[image]

.NET Framework Class Library
SpeedeeDeliveryRatingService Constructor
SpeedeeDeliveryRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SpeedeeDeliveryRatingService()
Visual C++
public:
SpeedeeDeliveryRatingService()
JavaScript
InSite.Domain.Shipping.SpeedeeDeliveryRatingService = function();

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


SpeedeeDeliveryRatingService Methods

[image] [image]

.NET Framework Class Library
SpeedeeDeliveryRatingService Methods
SpeedeeDeliveryRatingService Class See Also Send Feedback

The SpeedeeDeliveryRatingService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


RateShipment Method

[image]

.NET Framework Class Library
SpeedeeDeliveryRatingService..::.RateShipment Method
SpeedeeDeliveryRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function RateShipment ( _
    packages As IList(Of IPackage), _
    carrier As Carrier _
) As IList(Of ShippingCost)
C#
public IList<ShippingCost> RateShipment(
    IList<IPackage> packages,
    Carrier carrier
)
Visual C++
public:
virtual IList<ShippingCost^>^ RateShipment(
    IList<IPackage^>^ packages,
    Carrier^ carrier
) sealed
JavaScript
function rateShipment(packages, carrier);

Parameters

packages
Type: System.Collections.Generic..::.IList <(Of <( IPackage >)>)
carrier
Type: InSite.Model..::.Carrier

Implements

IRatingService..::.RateShipment(IList<(Of <(IPackage>)>), Carrier)

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


SpeedeeDeliveryRatingService Properties

[image] [image]

.NET Framework Class Library
SpeedeeDeliveryRatingService Properties
SpeedeeDeliveryRatingService Class See Also Send Feedback

The SpeedeeDeliveryRatingService type exposes the following members.

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


Company Property

[image]

.NET Framework Class Library
SpeedeeDeliveryRatingService..::.Company Property
SpeedeeDeliveryRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Company As Company
C#
public Company Company { set; }
Visual C++
public:
virtual property Company^ Company {
    void set (Company^ value) sealed;
}
JavaScript
function set_company(value);

Implements

IRatingService..::.Company

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
SpeedeeDeliveryRatingService..::.CustomerOrder Property
SpeedeeDeliveryRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property CustomerOrder As CustomerOrder
C#
public CustomerOrder CustomerOrder { set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    void set (CustomerOrder^ value) sealed;
}
JavaScript
function set_customerOrder(value);

Implements

IRatingService..::.CustomerOrder

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


DestinationZipCode Property

[image]

.NET Framework Class Library
SpeedeeDeliveryRatingService..::.DestinationZipCode Property
SpeedeeDeliveryRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestinationZipCode As String
C#
public string DestinationZipCode { set; }
Visual C++
public:
virtual property String^ DestinationZipCode {
    void set (String^ value) sealed;
}
JavaScript
function set_destinationZipCode(value);

Implements

IRatingService..::.DestinationZipCode

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


IsWholeSaleOrder Property

[image]

.NET Framework Class Library
SpeedeeDeliveryRatingService..::.IsWholeSaleOrder Property
SpeedeeDeliveryRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IsWholeSaleOrder As Boolean
C#
public bool IsWholeSaleOrder { get; set; }
Visual C++
public:
virtual property bool IsWholeSaleOrder {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_isWholeSaleOrder();
function set_isWholeSaleOrder(value);

Implements

IRatingService..::.IsWholeSaleOrder

See Also

SpeedeeDeliveryRatingService Class
InSite.Domain.Shipping Namespace


UPSRatingService Class

[image]

.NET Framework Class Library
UPSRatingService Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class UPSRatingService _
    Implements IRatingService
C#
public class UPSRatingService : IRatingService
Visual C++
public ref class UPSRatingService : IRatingService
JavaScript
InSite.Domain.Shipping.UPSRatingService = function();

Type.createClass(
    'InSite.Domain.Shipping.UPSRatingService',
    null,
    InSite.Domain.Shipping.IRatingService);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.UPSRatingService

See Also

UPSRatingService Members
InSite.Domain.Shipping Namespace


UPSRatingService Members

[image] [image]

.NET Framework Class Library
UPSRatingService Members
UPSRatingService Class Constructors Methods Properties See Also Send Feedback

The UPSRatingService type exposes the following members.

Constructors

Name | Description
UPSRatingService |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


UPSRatingService Constructor

[image]

.NET Framework Class Library
UPSRatingService Constructor
UPSRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UPSRatingService()
Visual C++
public:
UPSRatingService()
JavaScript
InSite.Domain.Shipping.UPSRatingService = function();

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


UPSRatingService Methods

[image] [image]

.NET Framework Class Library
UPSRatingService Methods
UPSRatingService Class See Also Send Feedback

The UPSRatingService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RateShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


RateShipment Method

[image]

.NET Framework Class Library
UPSRatingService..::.RateShipment Method
UPSRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function RateShipment ( _
    packages As IList(Of IPackage), _
    carrier As Carrier _
) As IList(Of ShippingCost)
C#
public IList<ShippingCost> RateShipment(
    IList<IPackage> packages,
    Carrier carrier
)
Visual C++
public:
virtual IList<ShippingCost^>^ RateShipment(
    IList<IPackage^>^ packages,
    Carrier^ carrier
) sealed
JavaScript
function rateShipment(packages, carrier);

Parameters

packages
Type: System.Collections.Generic..::.IList <(Of <( IPackage >)>)
carrier
Type: InSite.Model..::.Carrier

Implements

IRatingService..::.RateShipment(IList<(Of <(IPackage>)>), Carrier)

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


UPSRatingService Properties

[image] [image]

.NET Framework Class Library
UPSRatingService Properties
UPSRatingService Class See Also Send Feedback

The UPSRatingService type exposes the following members.

Properties

Name | Description
Company |
CustomerOrder |
DestinationZipCode |
IsWholeSaleOrder |

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


Company Property

[image]

.NET Framework Class Library
UPSRatingService..::.Company Property
UPSRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property Company As Company
C#
public Company Company { set; }
Visual C++
public:
virtual property Company^ Company {
    void set (Company^ value) sealed;
}
JavaScript
function set_company(value);

Implements

IRatingService..::.Company

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
UPSRatingService..::.CustomerOrder Property
UPSRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property CustomerOrder As CustomerOrder
C#
public CustomerOrder CustomerOrder { set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    void set (CustomerOrder^ value) sealed;
}
JavaScript
function set_customerOrder(value);

Implements

IRatingService..::.CustomerOrder

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


DestinationZipCode Property

[image]

.NET Framework Class Library
UPSRatingService..::.DestinationZipCode Property
UPSRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property DestinationZipCode As String
C#
public string DestinationZipCode { set; }
Visual C++
public:
virtual property String^ DestinationZipCode {
    void set (String^ value) sealed;
}
JavaScript
function set_destinationZipCode(value);

Implements

IRatingService..::.DestinationZipCode

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


IsWholeSaleOrder Property

[image]

.NET Framework Class Library
UPSRatingService..::.IsWholeSaleOrder Property
UPSRatingService Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property IsWholeSaleOrder As Boolean
C#
public bool IsWholeSaleOrder { get; set; }
Visual C++
public:
virtual property bool IsWholeSaleOrder {
    bool get () sealed;
    void set (bool value) sealed;
}
JavaScript
function get_isWholeSaleOrder();
function set_isWholeSaleOrder(value);

Implements

IRatingService..::.IsWholeSaleOrder

See Also

UPSRatingService Class
InSite.Domain.Shipping Namespace


UPSShip Class

[image]

.NET Framework Class Library
UPSShip Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class UPSShip _
    Implements IDisposable
C#
public class UPSShip : IDisposable
Visual C++
public ref class UPSShip : IDisposable
JavaScript
InSite.Domain.Shipping.UPSShip = function();

Type.createClass(
    'InSite.Domain.Shipping.UPSShip',
    null,
    IDisposable);

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.UPSShip

See Also

UPSShip Members
InSite.Domain.Shipping Namespace


UPSShip Members

[image] [image]

.NET Framework Class Library
UPSShip Members
UPSShip Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The UPSShip type exposes the following members.

Constructors

Name | Description
UPSShip | Overloaded.

Methods

Name | Description
CertValidation |
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRatesAndService |
GetServiceCodeName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackShipment |
ValidateUSAddress |

Properties

Name | Description
UPSAccessKey |
UPSAddressValidationStatus |
UPSAddressValidationStatusDescription |
UPSAddressValidationURL |
UPSPassword |
UPSRatesAndServiceStatus |
UPSRatesAndServiceStatusDescription |
UPSRatesAndServiceURL |
UPSTestMode |
UPSTrackingStatus |
UPSTrackingStatusDescription |
UPSTrackingURL |
UPSUserName |

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose |

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSShip Constructor

[image] [image]

.NET Framework Class Library
UPSShip Constructor
UPSShip Class See Also Send Feedback

Overload List

Name | Description
UPSShip()()() |
UPSShip(String, String, String, Boolean) |

See Also

UPSShip Class
UPSShip Members
InSite.Domain.Shipping Namespace


UPSShip Constructor

[image]

.NET Framework Class Library
UPSShip Constructor
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UPSShip()
Visual C++
public:
UPSShip()
JavaScript
InSite.Domain.Shipping.UPSShip = function();

See Also

UPSShip Class
UPSShip Overload
InSite.Domain.Shipping Namespace


UPSShip Constructor (String, String, String, Boolean)

[image]

.NET Framework Class Library
UPSShip Constructor (String, String, String, Boolean)
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    UPSAccessKey As String, _
    UPSUserName As String, _
    UPSPassword As String, _
    UPSTestMode As Boolean _
)
C#
public UPSShip(
    string UPSAccessKey,
    string UPSUserName,
    string UPSPassword,
    bool UPSTestMode
)
Visual C++
public:
UPSShip(
    String^ UPSAccessKey,
    String^ UPSUserName,
    String^ UPSPassword,
    bool UPSTestMode
)
JavaScript
InSite.Domain.Shipping.UPSShip = function(UPSAccessKey, UPSUserName, UPSPassword, UPSTestMode);

Parameters

UPSAccessKey
Type: System..::.String
UPSUserName
Type: System..::.String
UPSPassword
Type: System..::.String
UPSTestMode
Type: System..::.Boolean

See Also

UPSShip Class
UPSShip Overload
InSite.Domain.Shipping Namespace


UPSShip Methods

[image] [image]

.NET Framework Class Library
UPSShip Methods
UPSShip Class See Also Send Feedback

The UPSShip type exposes the following members.

Methods

Name | Description
CertValidation |
Dispose |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRatesAndService |
GetServiceCodeName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackShipment |
ValidateUSAddress |

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose |

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


IDisposable.Dispose Method

[image]

.NET Framework Class Library
UPSShip..::.IDisposable..::.Dispose Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Private Sub Dispose Implements IDisposable.Dispose
C#
void IDisposable.Dispose()
Visual C++
private:
virtual void Dispose() sealed = IDisposable::Dispose
JavaScript
JavaScript does not support explicit interface implementations.

Implements

IDisposable..::.Dispose()()()

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


CertValidation Method

[image]

.NET Framework Class Library
UPSShip..::.CertValidation Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CertValidation ( _
    sender As Object, _
    certificate As X509Certificate, _
    chain As X509Chain, _
    sslPolicyErrors As SslPolicyErrors _
) As Boolean
C#
public static bool CertValidation(
    Object sender,
    X509Certificate certificate,
    X509Chain chain,
    SslPolicyErrors sslPolicyErrors
)
Visual C++
public:
static bool CertValidation(
    Object^ sender,
    X509Certificate^ certificate,
    X509Chain^ chain,
    SslPolicyErrors sslPolicyErrors
)
JavaScript
InSite.Domain.Shipping.UPSShip.certValidation = function(sender, certificate, chain, sslPolicyErrors);

Parameters

sender
Type: System..::.Object
certificate
Type: System.Security.Cryptography.X509Certificates..::.X509Certificate
chain
Type: System.Security.Cryptography.X509Certificates..::.X509Chain
sslPolicyErrors
Type: System.Net.Security..::.SslPolicyErrors

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


Dispose Method

[image]

.NET Framework Class Library
UPSShip..::.Dispose Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose ( _
    dispose As Boolean _
)
C#
public void Dispose(
    bool dispose
)
Visual C++
public:
void Dispose(
    bool dispose
)
JavaScript
function dispose(dispose);

Parameters

dispose
Type: System..::.Boolean

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


GetRatesAndService Method

[image]

.NET Framework Class Library
UPSShip..::.GetRatesAndService Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRatesAndService ( _
    packages As IList(Of IPackage), _
    shipAddress As UPSShipAddress, _
    isWholesale As Boolean _
) As DataSet
C#
public DataSet GetRatesAndService(
    IList<IPackage> packages,
    UPSShipAddress shipAddress,
    bool isWholesale
)
Visual C++
public:
DataSet^ GetRatesAndService(
    IList<IPackage^>^ packages,
    UPSShipAddress^ shipAddress,
    bool isWholesale
)
JavaScript
function getRatesAndService(packages, shipAddress, isWholesale);

Parameters

packages
Type: System.Collections.Generic..::.IList <(Of <( IPackage >)>)
shipAddress
Type: InSite.Domain.Shipping..::.UPSShipAddress
isWholesale
Type: System..::.Boolean

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


GetServiceCodeName Method

[image]

.NET Framework Class Library
UPSShip..::.GetServiceCodeName Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetServiceCodeName ( _
    ServiceCode As String _
) As String
C#
public static string GetServiceCodeName(
    string ServiceCode
)
Visual C++
public:
static String^ GetServiceCodeName(
    String^ ServiceCode
)
JavaScript
InSite.Domain.Shipping.UPSShip.getServiceCodeName = function(ServiceCode);

Parameters

ServiceCode
Type: System..::.String

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


TrackShipment Method

[image]

.NET Framework Class Library
UPSShip..::.TrackShipment Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function TrackShipment ( _
    TrackingNumber As String _
) As DataSet
C#
public DataSet TrackShipment(
    string TrackingNumber
)
Visual C++
public:
DataSet^ TrackShipment(
    String^ TrackingNumber
)
JavaScript
function trackShipment(TrackingNumber);

Parameters

TrackingNumber
Type: System..::.String

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


ValidateUSAddress Method

[image]

.NET Framework Class Library
UPSShip..::.ValidateUSAddress Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Function ValidateUSAddress ( _
    City As String, _
    State As String, _
    PostalCode As String _
) As DataSet
C#
public DataSet ValidateUSAddress(
    string City,
    string State,
    string PostalCode
)
Visual C++
public:
DataSet^ ValidateUSAddress(
    String^ City,
    String^ State,
    String^ PostalCode
)
JavaScript
function validateUSAddress(City, State, PostalCode);

Parameters

City
Type: System..::.String
State
Type: System..::.String
PostalCode
Type: System..::.String

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSShip Properties

[image] [image]

.NET Framework Class Library
UPSShip Properties
UPSShip Class See Also Send Feedback

The UPSShip type exposes the following members.

Properties

Name | Description
UPSAccessKey |
UPSAddressValidationStatus |
UPSAddressValidationStatusDescription |
UPSAddressValidationURL |
UPSPassword |
UPSRatesAndServiceStatus |
UPSRatesAndServiceStatusDescription |
UPSRatesAndServiceURL |
UPSTestMode |
UPSTrackingStatus |
UPSTrackingStatusDescription |
UPSTrackingURL |
UPSUserName |

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSAccessKey Property

[image]

.NET Framework Class Library
UPSShip..::.UPSAccessKey Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UPSAccessKey As String
C#
public string UPSAccessKey { get; set; }
Visual C++
public:
property String^ UPSAccessKey {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_upsAccessKey();
function set_upsAccessKey(value);

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSAddressValidationStatus Property

[image]

.NET Framework Class Library
UPSShip..::.UPSAddressValidationStatus Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSAddressValidationStatus As Integer
C#
public int UPSAddressValidationStatus { get; }
Visual C++
public:
property int UPSAddressValidationStatus {
    int get ();
}
JavaScript
function get_upsAddressValidationStatus();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSAddressValidationStatusDescription Property

[image]

.NET Framework Class Library
UPSShip..::.UPSAddressValidationStatusDescription Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSAddressValidationStatusDescription As String
C#
public string UPSAddressValidationStatusDescription { get; }
Visual C++
public:
property String^ UPSAddressValidationStatusDescription {
    String^ get ();
}
JavaScript
function get_upsAddressValidationStatusDescription();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSAddressValidationURL Property

[image]

.NET Framework Class Library
UPSShip..::.UPSAddressValidationURL Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSAddressValidationURL As String
C#
public string UPSAddressValidationURL { get; }
Visual C++
public:
property String^ UPSAddressValidationURL {
    String^ get ();
}
JavaScript
function get_upsAddressValidationURL();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSPassword Property

[image]

.NET Framework Class Library
UPSShip..::.UPSPassword Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UPSPassword As String
C#
public string UPSPassword { get; set; }
Visual C++
public:
property String^ UPSPassword {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_upsPassword();
function set_upsPassword(value);

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSRatesAndServiceStatus Property

[image]

.NET Framework Class Library
UPSShip..::.UPSRatesAndServiceStatus Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSRatesAndServiceStatus As Integer
C#
public int UPSRatesAndServiceStatus { get; }
Visual C++
public:
property int UPSRatesAndServiceStatus {
    int get ();
}
JavaScript
function get_upsRatesAndServiceStatus();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSRatesAndServiceStatusDescription Property

[image]

.NET Framework Class Library
UPSShip..::.UPSRatesAndServiceStatusDescription Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSRatesAndServiceStatusDescription As String
C#
public string UPSRatesAndServiceStatusDescription { get; }
Visual C++
public:
property String^ UPSRatesAndServiceStatusDescription {
    String^ get ();
}
JavaScript
function get_upsRatesAndServiceStatusDescription();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSRatesAndServiceURL Property

[image]

.NET Framework Class Library
UPSShip..::.UPSRatesAndServiceURL Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSRatesAndServiceURL As String
C#
public string UPSRatesAndServiceURL { get; }
Visual C++
public:
property String^ UPSRatesAndServiceURL {
    String^ get ();
}
JavaScript
function get_upsRatesAndServiceURL();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSTestMode Property

[image]

.NET Framework Class Library
UPSShip..::.UPSTestMode Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UPSTestMode As Boolean
C#
public bool UPSTestMode { get; set; }
Visual C++
public:
property bool UPSTestMode {
    bool get ();
    void set (bool value);
}
JavaScript
function get_upsTestMode();
function set_upsTestMode(value);

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSTrackingStatus Property

[image]

.NET Framework Class Library
UPSShip..::.UPSTrackingStatus Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSTrackingStatus As Integer
C#
public int UPSTrackingStatus { get; }
Visual C++
public:
property int UPSTrackingStatus {
    int get ();
}
JavaScript
function get_upsTrackingStatus();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSTrackingStatusDescription Property

[image]

.NET Framework Class Library
UPSShip..::.UPSTrackingStatusDescription Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSTrackingStatusDescription As String
C#
public string UPSTrackingStatusDescription { get; }
Visual C++
public:
property String^ UPSTrackingStatusDescription {
    String^ get ();
}
JavaScript
function get_upsTrackingStatusDescription();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSTrackingURL Property

[image]

.NET Framework Class Library
UPSShip..::.UPSTrackingURL Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSTrackingURL As String
C#
public string UPSTrackingURL { get; }
Visual C++
public:
property String^ UPSTrackingURL {
    String^ get ();
}
JavaScript
function get_upsTrackingURL();

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSUserName Property

[image]

.NET Framework Class Library
UPSShip..::.UPSUserName Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property UPSUserName As String
C#
public string UPSUserName { get; set; }
Visual C++
public:
property String^ UPSUserName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_upsUserName();
function set_upsUserName(value);

See Also

UPSShip Class
InSite.Domain.Shipping Namespace


UPSShipAddress Class

[image]

.NET Framework Class Library
UPSShipAddress Class
Members See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Class UPSShipAddress
C#
public class UPSShipAddress
Visual C++
public ref class UPSShipAddress
JavaScript
InSite.Domain.Shipping.UPSShipAddress = function();

Type.createClass(
    'InSite.Domain.Shipping.UPSShipAddress');

Inheritance Hierarchy

System..::.Object
InSite.Domain.Shipping..::.UPSShipAddress

See Also

UPSShipAddress Members
InSite.Domain.Shipping Namespace


UPSShipAddress Members

[image] [image]

.NET Framework Class Library
UPSShipAddress Members
UPSShipAddress Class Constructors Methods Properties See Also Send Feedback

The UPSShipAddress type exposes the following members.

Constructors

Name | Description
UPSShipAddress | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ShipFromCity |
ShipFromCountryCode |
ShipFromPostalCode |
ShipFromStateProvinceCode |
ShipperCity |
ShipperCountryCode |
ShipperPostalCode |
ShipperStateProvinceCode |
ShipToCity |
ShipToCountryCode |
ShipToIsResidentialAddress |
ShipToPostalCode |
ShipToStateProvinceCode |

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


UPSShipAddress Constructor

[image] [image]

.NET Framework Class Library
UPSShipAddress Constructor
UPSShipAddress Class See Also Send Feedback

Overload List

Name | Description
UPSShipAddress()()() |
UPSShipAddress(String, String, String, String, String, String, String, String, String, String, String, String, Boolean) |
UPSShipAddress(String, String, String, String, String, String, String, String, Boolean) |

See Also

UPSShipAddress Class
UPSShipAddress Members
InSite.Domain.Shipping Namespace


UPSShipAddress Constructor

[image]

.NET Framework Class Library
UPSShipAddress Constructor
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UPSShipAddress()
Visual C++
public:
UPSShipAddress()
JavaScript
InSite.Domain.Shipping.UPSShipAddress = function();

See Also

UPSShipAddress Class
UPSShipAddress Overload
InSite.Domain.Shipping Namespace


UPSShipAddress Constructor (String, String, String, String, String, String, String, String, String, String, String, String, Boolean)

[image]

.NET Framework Class Library
UPSShipAddress Constructor (String, String, String, String, String, String, String, String, String, String, String, String, Boolean)
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    shipperCity As String, _
    shipperStateProvinceCode As String, _
    shipperPostalCode As String, _
    shipperCountryCode As String, _
    shipFromCity As String, _
    shipFromStateProvinceCode As String, _
    shipFromPostalCode As String, _
    shipFromCountryCode As String, _
    shipToCity As String, _
    shipToStateProvinceCode As String, _
    shipToPostalCode As String, _
    shipToCountryCode As String, _
    shipToIsResidentialAddress As Boolean _
)
C#
public UPSShipAddress(
    string shipperCity,
    string shipperStateProvinceCode,
    string shipperPostalCode,
    string shipperCountryCode,
    string shipFromCity,
    string shipFromStateProvinceCode,
    string shipFromPostalCode,
    string shipFromCountryCode,
    string shipToCity,
    string shipToStateProvinceCode,
    string shipToPostalCode,
    string shipToCountryCode,
    bool shipToIsResidentialAddress
)
Visual C++
public:
UPSShipAddress(
    String^ shipperCity,
    String^ shipperStateProvinceCode,
    String^ shipperPostalCode,
    String^ shipperCountryCode,
    String^ shipFromCity,
    String^ shipFromStateProvinceCode,
    String^ shipFromPostalCode,
    String^ shipFromCountryCode,
    String^ shipToCity,
    String^ shipToStateProvinceCode,
    String^ shipToPostalCode,
    String^ shipToCountryCode,
    bool shipToIsResidentialAddress
)
JavaScript
InSite.Domain.Shipping.UPSShipAddress = function(shipperCity, shipperStateProvinceCode, shipperPostalCode, shipperCountryCode, shipFromCity, shipFromStateProvinceCode, shipFromPostalCode, shipFromCountryCode, shipToCity, shipToStateProvinceCode, shipToPostalCode, shipToCountryCode, shipToIsResidentialAddress);

Parameters

shipperCity
Type: System..::.String
shipperStateProvinceCode
Type: System..::.String
shipperPostalCode
Type: System..::.String
shipperCountryCode
Type: System..::.String
shipFromCity
Type: System..::.String
shipFromStateProvinceCode
Type: System..::.String
shipFromPostalCode
Type: System..::.String
shipFromCountryCode
Type: System..::.String
shipToCity
Type: System..::.String
shipToStateProvinceCode
Type: System..::.String
shipToPostalCode
Type: System..::.String
shipToCountryCode
Type: System..::.String
shipToIsResidentialAddress
Type: System..::.Boolean

See Also

UPSShipAddress Class
UPSShipAddress Overload
InSite.Domain.Shipping Namespace


UPSShipAddress Constructor (String, String, String, String, String, String, String, String, Boolean)

[image]

.NET Framework Class Library
UPSShipAddress Constructor (String, String, String, String, String, String, String, String, Boolean)
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    shipperCity As String, _
    shipperStateProvinceCode As String, _
    shipperPostalCode As String, _
    shipperCountryCode As String, _
    shipToCity As String, _
    shipToStateProvinceCode As String, _
    shipToPostalCode As String, _
    shipToCountryCode As String, _
    shipToIsResidentialAddress As Boolean _
)
C#
public UPSShipAddress(
    string shipperCity,
    string shipperStateProvinceCode,
    string shipperPostalCode,
    string shipperCountryCode,
    string shipToCity,
    string shipToStateProvinceCode,
    string shipToPostalCode,
    string shipToCountryCode,
    bool shipToIsResidentialAddress
)
Visual C++
public:
UPSShipAddress(
    String^ shipperCity,
    String^ shipperStateProvinceCode,
    String^ shipperPostalCode,
    String^ shipperCountryCode,
    String^ shipToCity,
    String^ shipToStateProvinceCode,
    String^ shipToPostalCode,
    String^ shipToCountryCode,
    bool shipToIsResidentialAddress
)
JavaScript
InSite.Domain.Shipping.UPSShipAddress = function(shipperCity, shipperStateProvinceCode, shipperPostalCode, shipperCountryCode, shipToCity, shipToStateProvinceCode, shipToPostalCode, shipToCountryCode, shipToIsResidentialAddress);

Parameters

shipperCity
Type: System..::.String
shipperStateProvinceCode
Type: System..::.String
shipperPostalCode
Type: System..::.String
shipperCountryCode
Type: System..::.String
shipToCity
Type: System..::.String
shipToStateProvinceCode
Type: System..::.String
shipToPostalCode
Type: System..::.String
shipToCountryCode
Type: System..::.String
shipToIsResidentialAddress
Type: System..::.Boolean

See Also

UPSShipAddress Class
UPSShipAddress Overload
InSite.Domain.Shipping Namespace


UPSShipAddress Methods

[image] [image]

.NET Framework Class Library
UPSShipAddress Methods
UPSShipAddress Class See Also Send Feedback

The UPSShipAddress type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


UPSShipAddress Properties

[image] [image]

.NET Framework Class Library
UPSShipAddress Properties
UPSShipAddress Class See Also Send Feedback

The UPSShipAddress type exposes the following members.

Properties

Name | Description
ShipFromCity |
ShipFromCountryCode |
ShipFromPostalCode |
ShipFromStateProvinceCode |
ShipperCity |
ShipperCountryCode |
ShipperPostalCode |
ShipperStateProvinceCode |
ShipToCity |
ShipToCountryCode |
ShipToIsResidentialAddress |
ShipToPostalCode |
ShipToStateProvinceCode |

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipFromCity Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipFromCity Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipFromCity As String
C#
public string ShipFromCity { get; set; }
Visual C++
public:
property String^ ShipFromCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromCity();
function set_shipFromCity(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipFromCountryCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipFromCountryCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipFromCountryCode As String
C#
public string ShipFromCountryCode { get; set; }
Visual C++
public:
property String^ ShipFromCountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromCountryCode();
function set_shipFromCountryCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipFromPostalCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipFromPostalCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipFromPostalCode As String
C#
public string ShipFromPostalCode { get; set; }
Visual C++
public:
property String^ ShipFromPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromPostalCode();
function set_shipFromPostalCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipFromStateProvinceCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipFromStateProvinceCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipFromStateProvinceCode As String
C#
public string ShipFromStateProvinceCode { get; set; }
Visual C++
public:
property String^ ShipFromStateProvinceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromStateProvinceCode();
function set_shipFromStateProvinceCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipperCity Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipperCity Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipperCity As String
C#
public string ShipperCity { get; set; }
Visual C++
public:
property String^ ShipperCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipperCity();
function set_shipperCity(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipperCountryCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipperCountryCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipperCountryCode As String
C#
public string ShipperCountryCode { get; set; }
Visual C++
public:
property String^ ShipperCountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipperCountryCode();
function set_shipperCountryCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipperPostalCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipperPostalCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipperPostalCode As String
C#
public string ShipperPostalCode { get; set; }
Visual C++
public:
property String^ ShipperPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipperPostalCode();
function set_shipperPostalCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipperStateProvinceCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipperStateProvinceCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipperStateProvinceCode As String
C#
public string ShipperStateProvinceCode { get; set; }
Visual C++
public:
property String^ ShipperStateProvinceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipperStateProvinceCode();
function set_shipperStateProvinceCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipToCity Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToCity Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToCity As String
C#
public string ShipToCity { get; set; }
Visual C++
public:
property String^ ShipToCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCity();
function set_shipToCity(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipToCountryCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToCountryCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToCountryCode As String
C#
public string ShipToCountryCode { get; set; }
Visual C++
public:
property String^ ShipToCountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCountryCode();
function set_shipToCountryCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipToIsResidentialAddress Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToIsResidentialAddress Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToIsResidentialAddress As Boolean
C#
public bool ShipToIsResidentialAddress { get; set; }
Visual C++
public:
property bool ShipToIsResidentialAddress {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shipToIsResidentialAddress();
function set_shipToIsResidentialAddress(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipToPostalCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToPostalCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToPostalCode As String
C#
public string ShipToPostalCode { get; set; }
Visual C++
public:
property String^ ShipToPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToPostalCode();
function set_shipToPostalCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


ShipToStateProvinceCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToStateProvinceCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Domain.Shipping
Assembly: InSite.Domain (in InSite.Domain.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToStateProvinceCode As String
C#
public string ShipToStateProvinceCode { get; set; }
Visual C++
public:
property String^ ShipToStateProvinceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToStateProvinceCode();
function set_shipToStateProvinceCode(value);

See Also

UPSShipAddress Class
InSite.Domain.Shipping Namespace


InSite.Library Namespace

[image]

.NET Framework Class Library
InSite.Library Namespace
Send Feedback

Classes

Class | Description
ControlHelper |
DynamicComparer<(Of <(T>)>) |
FileHelper |
ListHelper |
LowerCaseHashtable<(Of <(T>)>) |
ObjectHelper |
RegularExpressionLibrary |
ScriptHelper |
SQLHelper |
StringHelper |
WebControlHelper |
WebPathResolver |

Structures

Structure | Description
SortProperty |

Delegates

Delegate | Description
DynamicComparer<(Of <(T>)>)..::.CompareMethodInvoker |


ControlHelper Class

[image]

.NET Framework Class Library
ControlHelper Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class ControlHelper
C#
public class ControlHelper
Visual C++
public ref class ControlHelper
JavaScript
InSite.Library.ControlHelper = function();

Type.createClass(
    'InSite.Library.ControlHelper');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.ControlHelper

See Also

ControlHelper Members
InSite.Library Namespace


ControlHelper Members

[image] [image]

.NET Framework Class Library
ControlHelper Members
ControlHelper Class Constructors Methods See Also Send Feedback

The ControlHelper type exposes the following members.

Constructors

Name | Description
ControlHelper |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillWithMonths |
FillWithYears |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlHelper Class
InSite.Library Namespace


ControlHelper Constructor

[image]

.NET Framework Class Library
ControlHelper Constructor
ControlHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ControlHelper()
Visual C++
public:
ControlHelper()
JavaScript
InSite.Library.ControlHelper = function();

See Also

ControlHelper Class
InSite.Library Namespace


ControlHelper Methods

[image] [image]

.NET Framework Class Library
ControlHelper Methods
ControlHelper Class See Also Send Feedback

The ControlHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillWithMonths |
FillWithYears |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControlHelper Class
InSite.Library Namespace


FillWithMonths Method

[image]

.NET Framework Class Library
ControlHelper..::.FillWithMonths Method
ControlHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FillWithMonths ( _
    DropDownListMonth As DropDownList, _
    SetCurrentMonth As Boolean _
)
C#
public static void FillWithMonths(
    DropDownList DropDownListMonth,
    bool SetCurrentMonth
)
Visual C++
public:
static void FillWithMonths(
    DropDownList^ DropDownListMonth,
    bool SetCurrentMonth
)
JavaScript
InSite.Library.ControlHelper.fillWithMonths = function(DropDownListMonth, SetCurrentMonth);

Parameters

DropDownListMonth
Type: System.Web.UI.WebControls..::.DropDownList
SetCurrentMonth
Type: System..::.Boolean

See Also

ControlHelper Class
InSite.Library Namespace


FillWithYears Method

[image]

.NET Framework Class Library
ControlHelper..::.FillWithYears Method
ControlHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub FillWithYears ( _
    DropDownListYear As DropDownList _
)
C#
public static void FillWithYears(
    DropDownList DropDownListYear
)
Visual C++
public:
static void FillWithYears(
    DropDownList^ DropDownListYear
)
JavaScript
InSite.Library.ControlHelper.fillWithYears = function(DropDownListYear);

Parameters

DropDownListYear
Type: System.Web.UI.WebControls..::.DropDownList

See Also

ControlHelper Class
InSite.Library Namespace


DynamicComparer(T) Class

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>) Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class DynamicComparer(Of T) _
    Implements IComparer(Of T)
C#
public class DynamicComparer<T> : IComparer<T>
Visual C++
generic<typename T>
public ref class DynamicComparer : IComparer<T>
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

Inheritance Hierarchy

System..::.Object
InSite.Library..::.DynamicComparer<(Of <(T>)>)

See Also

DynamicComparer<(Of <(T>)>) Members
InSite.Library Namespace


DynamicComparer(T) Members

[image] [image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>) Members
DynamicComparer<(Of <(T>)>) Class Constructors Methods Fields See Also Send Feedback

The DynamicComparer<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
DynamicComparer<(Of <(T>)>) | Overloaded.

Methods

Name | Description
CheckSortProperties |
Compare |
CreateDynamicCompareMethod |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseOrderBy |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
comparer |
method |

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


DynamicComparer(T) Constructor

[image] [image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>) Constructor
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
DynamicComparer<(Of <(T>)>)(array<SortProperty>[]()[]) |
DynamicComparer<(Of <(T>)>)(String) |

See Also

DynamicComparer<(Of <(T>)>) Class
DynamicComparer<(Of <(T>)>) Members
InSite.Library Namespace


DynamicComparer(T) Constructor (SortProperty[])

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>) Constructor (array<SortProperty>[]()[])
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    sortProperties As SortProperty() _
)
C#
public DynamicComparer(
    SortProperty[] sortProperties
)
Visual C++
public:
DynamicComparer(
    array<SortProperty>^ sortProperties
)
JavaScript
InSite.Library.DynamicComparer = function(sortProperties);

Parameters

sortProperties
Type: array< InSite.Library..::.SortProperty >[]()[]

See Also

DynamicComparer<(Of <(T>)>) Class
DynamicComparer<(Of <(T>)>) Overload
InSite.Library Namespace


DynamicComparer(T) Constructor (String)

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>) Constructor (String)
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    orderBy As String _
)
C#
public DynamicComparer(
    string orderBy
)
Visual C++
public:
DynamicComparer(
    String^ orderBy
)
JavaScript
InSite.Library.DynamicComparer = function(orderBy);

Parameters

orderBy
Type: System..::.String

See Also

DynamicComparer<(Of <(T>)>) Class
DynamicComparer<(Of <(T>)>) Overload
InSite.Library Namespace


DynamicComparer(T) Fields

[image] [image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>) Fields
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

The DynamicComparer<(Of <(T>)>) type exposes the following members.

Fields

Name | Description
comparer |
method |

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


comparer Field

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.comparer Field
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Protected comparer As DynamicComparer<(Of <(T>)>)..::.CompareMethodInvoker
C#
protected DynamicComparer<(Of <(T>)>)..::.CompareMethodInvoker comparer
Visual C++
protected:
DynamicComparer<(Of <(T>)>)..::.CompareMethodInvoker^ comparer
JavaScript
comparer

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


method Field

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.method Field
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Protected method As DynamicMethod
C#
protected DynamicMethod method
Visual C++
protected:
DynamicMethod^ method
JavaScript
method

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


DynamicComparer(T) Methods

[image] [image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>) Methods
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

The DynamicComparer<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
CheckSortProperties |
Compare |
CreateDynamicCompareMethod |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ParseOrderBy |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


CheckSortProperties Method

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.CheckSortProperties Method
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Protected Sub CheckSortProperties ( _
    sortProperties As SortProperty() _
)
C#
protected void CheckSortProperties(
    SortProperty[] sortProperties
)
Visual C++
protected:
void CheckSortProperties(
    array<SortProperty>^ sortProperties
)
JavaScript
function checkSortProperties(sortProperties);

Parameters

sortProperties
Type: array< InSite.Library..::.SortProperty >[]()[]

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


Compare Method

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.Compare Method
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Function Compare ( _
    x As T, _
    y As T _
) As Integer
C#
public int Compare(
    T x,
    T y
)
Visual C++
public:
virtual int Compare(
    T x,
    T y
) sealed
JavaScript
function compare(x, y);

Parameters

x
Type: T
y
Type: T

Implements

IComparer<(Of <(T>)>)..::.Compare(T, T)

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


CreateDynamicCompareMethod Method

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.CreateDynamicCompareMethod Method
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Protected Function CreateDynamicCompareMethod ( _
    sortProperties As SortProperty() _
) As DynamicMethod
C#
protected DynamicMethod CreateDynamicCompareMethod(
    SortProperty[] sortProperties
)
Visual C++
protected:
DynamicMethod^ CreateDynamicCompareMethod(
    array<SortProperty>^ sortProperties
)
JavaScript
function createDynamicCompareMethod(sortProperties);

Parameters

sortProperties
Type: array< InSite.Library..::.SortProperty >[]()[]

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


Initialize Method

[image] [image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.Initialize Method
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Initialize(array<SortProperty>[]()[]) |
Initialize(String) |

See Also

DynamicComparer<(Of <(T>)>) Class
DynamicComparer<(Of <(T>)>) Members
InSite.Library Namespace


Initialize Method (SortProperty[])

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.Initialize Method (array<SortProperty>[]()[])
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub Initialize ( _
    sortProperties As SortProperty() _
)
C#
public void Initialize(
    SortProperty[] sortProperties
)
Visual C++
public:
void Initialize(
    array<SortProperty>^ sortProperties
)
JavaScript
function initialize(sortProperties);

Parameters

sortProperties
Type: array< InSite.Library..::.SortProperty >[]()[]

See Also

DynamicComparer<(Of <(T>)>) Class
Initialize Overload
InSite.Library Namespace


Initialize Method (String)

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.Initialize Method (String)
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub Initialize ( _
    orderBy As String _
)
C#
public void Initialize(
    string orderBy
)
Visual C++
public:
void Initialize(
    String^ orderBy
)
JavaScript
function initialize(orderBy);

Parameters

orderBy
Type: System..::.String

See Also

DynamicComparer<(Of <(T>)>) Class
Initialize Overload
InSite.Library Namespace


ParseOrderBy Method

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.ParseOrderBy Method
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Protected Function ParseOrderBy ( _
    orderBy As String _
) As SortProperty()
C#
protected SortProperty[] ParseOrderBy(
    string orderBy
)
Visual C++
protected:
array<SortProperty>^ ParseOrderBy(
    String^ orderBy
)
JavaScript
function parseOrderBy(orderBy);

Parameters

orderBy
Type: System..::.String

See Also

DynamicComparer<(Of <(T>)>) Class
InSite.Library Namespace


DynamicComparer(T).CompareMethodInvoker Delegate

[image]

.NET Framework Class Library
DynamicComparer<(Of <(T>)>)..::.CompareMethodInvoker Delegate
DynamicComparer<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Protected Delegate Function CompareMethodInvoker ( _
    x As T, _
    y As T _
) As Integer
C#
protected delegate int CompareMethodInvoker(
    T x,
    T y
)
Visual C++
protected delegate int CompareMethodInvoker(
    T x,
    T y
)
JavaScript
function(x, y);

Parameters

x
Type: T
y
Type: T

See Also

InSite.Library Namespace


FileHelper Class

[image]

.NET Framework Class Library
FileHelper Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class FileHelper
C#
public class FileHelper
Visual C++
public ref class FileHelper
JavaScript
InSite.Library.FileHelper = function();

Type.createClass(
    'InSite.Library.FileHelper');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.FileHelper

See Also

FileHelper Members
InSite.Library Namespace


FileHelper Members

[image] [image]

.NET Framework Class Library
FileHelper Members
FileHelper Class Constructors Methods See Also Send Feedback

The FileHelper type exposes the following members.

Constructors

Name | Description
FileHelper |

Methods

Name | Description
EnsureDirectoryExists | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCSVFile |
GetExcelConnection |
GetExcelWorkSheet |
GetFullUrl |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadFileInToDataSet |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UploadFile |
WriteExcelWorkSheet | Overloaded.

See Also

FileHelper Class
InSite.Library Namespace


FileHelper Constructor

[image]

.NET Framework Class Library
FileHelper Constructor
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FileHelper()
Visual C++
public:
FileHelper()
JavaScript
InSite.Library.FileHelper = function();

See Also

FileHelper Class
InSite.Library Namespace


FileHelper Methods

[image] [image]

.NET Framework Class Library
FileHelper Methods
FileHelper Class See Also Send Feedback

The FileHelper type exposes the following members.

Methods

Name | Description
EnsureDirectoryExists | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCSVFile |
GetExcelConnection |
GetExcelWorkSheet |
GetFullUrl |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadFileInToDataSet |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UploadFile |
WriteExcelWorkSheet | Overloaded.

See Also

FileHelper Class
InSite.Library Namespace


EnsureDirectoryExists Method

[image] [image]

.NET Framework Class Library
FileHelper..::.EnsureDirectoryExists Method
FileHelper Class See Also Send Feedback

Overload List

Name | Description
EnsureDirectoryExists(DirectoryInfo) |
EnsureDirectoryExists(String) |

See Also

FileHelper Class
FileHelper Members
InSite.Library Namespace


EnsureDirectoryExists Method (DirectoryInfo)

[image]

.NET Framework Class Library
FileHelper..::.EnsureDirectoryExists Method (DirectoryInfo)
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub EnsureDirectoryExists ( _
    directory As DirectoryInfo _
)
C#
public static void EnsureDirectoryExists(
    DirectoryInfo directory
)
Visual C++
public:
static void EnsureDirectoryExists(
    DirectoryInfo^ directory
)
JavaScript
InSite.Library.FileHelper.ensureDirectoryExists = function(directory);

Parameters

directory
Type: System.IO..::.DirectoryInfo

See Also

FileHelper Class
EnsureDirectoryExists Overload
InSite.Library Namespace


EnsureDirectoryExists Method (String)

[image]

.NET Framework Class Library
FileHelper..::.EnsureDirectoryExists Method (String)
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub EnsureDirectoryExists ( _
    filePath As String _
)
C#
public static void EnsureDirectoryExists(
    string filePath
)
Visual C++
public:
static void EnsureDirectoryExists(
    String^ filePath
)
JavaScript
InSite.Library.FileHelper.ensureDirectoryExists = function(filePath);

Parameters

filePath
Type: System..::.String

See Also

FileHelper Class
EnsureDirectoryExists Overload
InSite.Library Namespace


GetCSVFile Method

[image]

.NET Framework Class Library
FileHelper..::.GetCSVFile Method
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCSVFile ( _
    pathName As String, _
    fileName As String _
) As DataSet
C#
public static DataSet GetCSVFile(
    string pathName,
    string fileName
)
Visual C++
public:
static DataSet^ GetCSVFile(
    String^ pathName,
    String^ fileName
)
JavaScript
InSite.Library.FileHelper.getCSVFile = function(pathName, fileName);

Parameters

pathName
Type: System..::.String
fileName
Type: System..::.String

See Also

FileHelper Class
InSite.Library Namespace


GetExcelConnection Method

[image]

.NET Framework Class Library
FileHelper..::.GetExcelConnection Method
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetExcelConnection ( _
    pathName As String, _
    fileName As String _
) As OleDbConnection
C#
public static OleDbConnection GetExcelConnection(
    string pathName,
    string fileName
)
Visual C++
public:
static OleDbConnection^ GetExcelConnection(
    String^ pathName,
    String^ fileName
)
JavaScript
InSite.Library.FileHelper.getExcelConnection = function(pathName, fileName);

Parameters

pathName
Type: System..::.String
fileName
Type: System..::.String

See Also

FileHelper Class
InSite.Library Namespace


GetExcelWorkSheet Method

[image]

.NET Framework Class Library
FileHelper..::.GetExcelWorkSheet Method
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetExcelWorkSheet ( _
    pathName As String, _
    fileName As String, _
    workSheetNumber As Integer _
) As DataSet
C#
public static DataSet GetExcelWorkSheet(
    string pathName,
    string fileName,
    int workSheetNumber
)
Visual C++
public:
static DataSet^ GetExcelWorkSheet(
    String^ pathName,
    String^ fileName,
    int workSheetNumber
)
JavaScript
InSite.Library.FileHelper.getExcelWorkSheet = function(pathName, fileName, workSheetNumber);

Parameters

pathName
Type: System..::.String
fileName
Type: System..::.String
workSheetNumber
Type: System..::.Int32

See Also

FileHelper Class
InSite.Library Namespace


GetFullUrl Method

[image]

.NET Framework Class Library
FileHelper..::.GetFullUrl Method
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFullUrl ( _
    relativeUrl As String _
) As String
C#
public static string GetFullUrl(
    string relativeUrl
)
Visual C++
public:
static String^ GetFullUrl(
    String^ relativeUrl
)
JavaScript
InSite.Library.FileHelper.getFullUrl = function(relativeUrl);

Parameters

relativeUrl
Type: System..::.String

See Also

FileHelper Class
InSite.Library Namespace


ReadFileInToDataSet Method

[image]

.NET Framework Class Library
FileHelper..::.ReadFileInToDataSet Method
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ReadFileInToDataSet ( _
    file As String, _
    mappedPath As String _
) As DataSet
C#
public static DataSet ReadFileInToDataSet(
    string file,
    string mappedPath
)
Visual C++
public:
static DataSet^ ReadFileInToDataSet(
    String^ file,
    String^ mappedPath
)
JavaScript
InSite.Library.FileHelper.readFileInToDataSet = function(file, mappedPath);

Parameters

file
Type: System..::.String
mappedPath
Type: System..::.String

See Also

FileHelper Class
InSite.Library Namespace


UploadFile Method

[image]

.NET Framework Class Library
FileHelper..::.UploadFile Method
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function UploadFile ( _
    fileUpload As FileUpload, _
    mappedPath As String _
) As String
C#
public static string UploadFile(
    FileUpload fileUpload,
    string mappedPath
)
Visual C++
public:
static String^ UploadFile(
    FileUpload^ fileUpload,
    String^ mappedPath
)
JavaScript
InSite.Library.FileHelper.uploadFile = function(fileUpload, mappedPath);

Parameters

fileUpload
Type: System.Web.UI.WebControls..::.FileUpload
mappedPath
Type: System..::.String

See Also

FileHelper Class
InSite.Library Namespace


WriteExcelWorkSheet Method

[image] [image]

.NET Framework Class Library
FileHelper..::.WriteExcelWorkSheet Method
FileHelper Class See Also Send Feedback

Overload List

Name | Description
WriteExcelWorkSheet(String, HttpResponse) |
WriteExcelWorkSheet(HttpResponse, array<IList<(Of <(String>)>)>[]()[]) |
WriteExcelWorkSheet(String, String, String) |

See Also

FileHelper Class
FileHelper Members
InSite.Library Namespace


WriteExcelWorkSheet Method (String, HttpResponse)

[image]

.NET Framework Class Library
FileHelper..::.WriteExcelWorkSheet Method (String, HttpResponse)
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteExcelWorkSheet ( _
    columns As String, _
    response As HttpResponse _
)
C#
public static void WriteExcelWorkSheet(
    string columns,
    HttpResponse response
)
Visual C++
public:
static void WriteExcelWorkSheet(
    String^ columns,
    HttpResponse^ response
)
JavaScript
InSite.Library.FileHelper.writeExcelWorkSheet = function(columns, response);

Parameters

columns
Type: System..::.String
response
Type: System.Web..::.HttpResponse

See Also

FileHelper Class
WriteExcelWorkSheet Overload
InSite.Library Namespace


WriteExcelWorkSheet Method (HttpResponse, IList(String)[])

[image]

.NET Framework Class Library
FileHelper..::.WriteExcelWorkSheet Method (HttpResponse, array<IList<(Of <(String>)>)>[]()[])
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteExcelWorkSheet ( _
    response As HttpResponse, _
    ParamArray columnValues As IList(Of String)() _
)
C#
public static void WriteExcelWorkSheet(
    HttpResponse response,
    params IList<string>[] columnValues
)
Visual C++
public:
static void WriteExcelWorkSheet(
    HttpResponse^ response,
    ... array<IList<String^>^>^ columnValues
)
JavaScript
InSite.Library.FileHelper.writeExcelWorkSheet = function(response, ... columnValues);

Parameters

response
Type: System.Web..::.HttpResponse
columnValues
Type: array< System.Collections.Generic..::.IList <(Of <( String >)>) >[]()[]

See Also

FileHelper Class
WriteExcelWorkSheet Overload
InSite.Library Namespace


WriteExcelWorkSheet Method (String, String, String)

[image]

.NET Framework Class Library
FileHelper..::.WriteExcelWorkSheet Method (String, String, String)
FileHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub WriteExcelWorkSheet ( _
    file As String, _
    mappedPath As String, _
    columns As String _
)
C#
public static void WriteExcelWorkSheet(
    string file,
    string mappedPath,
    string columns
)
Visual C++
public:
static void WriteExcelWorkSheet(
    String^ file,
    String^ mappedPath,
    String^ columns
)
JavaScript
InSite.Library.FileHelper.writeExcelWorkSheet = function(file, mappedPath, columns);

Parameters

file
Type: System..::.String
mappedPath
Type: System..::.String
columns
Type: System..::.String

See Also

FileHelper Class
WriteExcelWorkSheet Overload
InSite.Library Namespace


ListHelper Class

[image]

.NET Framework Class Library
ListHelper Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class ListHelper
C#
public class ListHelper
Visual C++
public ref class ListHelper
JavaScript
InSite.Library.ListHelper = function();

Type.createClass(
    'InSite.Library.ListHelper');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.ListHelper

See Also

ListHelper Members
InSite.Library Namespace


ListHelper Members

[image] [image]

.NET Framework Class Library
ListHelper Members
ListHelper Class Constructors Methods See Also Send Feedback

The ListHelper type exposes the following members.

Constructors

Name | Description
ListHelper |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSortedList<(Of <(T>)>) |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListHelper Class
InSite.Library Namespace


ListHelper Constructor

[image]

.NET Framework Class Library
ListHelper Constructor
ListHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ListHelper()
Visual C++
public:
ListHelper()
JavaScript
InSite.Library.ListHelper = function();

See Also

ListHelper Class
InSite.Library Namespace


ListHelper Methods

[image] [image]

.NET Framework Class Library
ListHelper Methods
ListHelper Class See Also Send Feedback

The ListHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSortedList<(Of <(T>)>) |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListHelper Class
InSite.Library Namespace


GetSortedList(T) Method

[image]

.NET Framework Class Library
ListHelper..::.GetSortedList<(Of <(T>)>) Method
ListHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSortedList(Of T) ( _
    list As IList(Of T), _
    sort As String _
) As List(Of T)
C#
public static List<T> GetSortedList<T>(
    IList<T> list,
    string sort
)
Visual C++
public:
generic<typename T>
static List<T>^ GetSortedList(
    IList<T>^ list,
    String^ sort
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

list
Type: System.Collections.Generic..::.IList <(Of <(T>)>)
sort
Type: System..::.String

Type Parameters

T

See Also

ListHelper Class
InSite.Library Namespace


LowerCaseHashtable(T) Class

[image]

.NET Framework Class Library
LowerCaseHashtable<(Of <(T>)>) Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class LowerCaseHashtable(Of T)
C#
public class LowerCaseHashtable<T>
Visual C++
generic<typename T>
public ref class LowerCaseHashtable
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

Inheritance Hierarchy

System..::.Object
InSite.Library..::.LowerCaseHashtable<(Of <(T>)>)

See Also

LowerCaseHashtable<(Of <(T>)>) Members
InSite.Library Namespace


LowerCaseHashtable(T) Members

[image] [image]

.NET Framework Class Library
LowerCaseHashtable<(Of <(T>)>) Members
LowerCaseHashtable<(Of <(T>)>) Class Constructors Methods Properties See Also Send Feedback

The LowerCaseHashtable<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
LowerCaseHashtable<(Of <(T>)>) |

Methods

Name | Description
Add |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item |

See Also

LowerCaseHashtable<(Of <(T>)>) Class
InSite.Library Namespace


LowerCaseHashtable(T) Constructor

[image]

.NET Framework Class Library
LowerCaseHashtable<(Of <(T>)>) Constructor
LowerCaseHashtable<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LowerCaseHashtable()
Visual C++
public:
LowerCaseHashtable()
JavaScript
InSite.Library.LowerCaseHashtable = function();

See Also

LowerCaseHashtable<(Of <(T>)>) Class
InSite.Library Namespace


LowerCaseHashtable(T) Methods

[image] [image]

.NET Framework Class Library
LowerCaseHashtable<(Of <(T>)>) Methods
LowerCaseHashtable<(Of <(T>)>) Class See Also Send Feedback

The LowerCaseHashtable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LowerCaseHashtable<(Of <(T>)>) Class
InSite.Library Namespace


Add Method

[image]

.NET Framework Class Library
LowerCaseHashtable<(Of <(T>)>)..::.Add Method
LowerCaseHashtable<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add ( _
    key As String, _
    value As T _
)
C#
public void Add(
    string key,
    T value
)
Visual C++
public:
void Add(
    String^ key,
    T value
)
JavaScript
function add(key, value);

Parameters

key
Type: System..::.String
value
Type: T

See Also

LowerCaseHashtable<(Of <(T>)>) Class
InSite.Library Namespace


LowerCaseHashtable(T) Properties

[image] [image]

.NET Framework Class Library
LowerCaseHashtable<(Of <(T>)>) Properties
LowerCaseHashtable<(Of <(T>)>) Class See Also Send Feedback

The LowerCaseHashtable<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Item |

See Also

LowerCaseHashtable<(Of <(T>)>) Class
InSite.Library Namespace


Item Property

[image]

.NET Framework Class Library
LowerCaseHashtable<(Of <(T>)>)..::.Item Property
LowerCaseHashtable<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As T
C#
public T this[
    string key
] { get; }
Visual C++
public:
property T default[String^ key] {
    T get (String^ key);
}
JavaScript
function get_item(key);

Parameters

key
Type: System..::.String

See Also

LowerCaseHashtable<(Of <(T>)>) Class
InSite.Library Namespace


ObjectHelper Class

[image]

.NET Framework Class Library
ObjectHelper Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class ObjectHelper
C#
public class ObjectHelper
Visual C++
public ref class ObjectHelper
JavaScript
InSite.Library.ObjectHelper = function();

Type.createClass(
    'InSite.Library.ObjectHelper');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.ObjectHelper

See Also

ObjectHelper Members
InSite.Library Namespace


ObjectHelper Members

[image] [image]

.NET Framework Class Library
ObjectHelper Members
ObjectHelper Class Constructors Methods See Also Send Feedback

The ObjectHelper type exposes the following members.

Constructors

Name | Description
ObjectHelper |

Methods

Name | Description
CopyDataRowToObject | Overloaded.
DataMemberPropertyCopyObject |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataTableFromList | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSortedProperties |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsSimpleProperty |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NullableToRegularDateType |
SimplePropertyCopyObject | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectHelper Class
InSite.Library Namespace


ObjectHelper Constructor

[image]

.NET Framework Class Library
ObjectHelper Constructor
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ObjectHelper()
Visual C++
public:
ObjectHelper()
JavaScript
InSite.Library.ObjectHelper = function();

See Also

ObjectHelper Class
InSite.Library Namespace


ObjectHelper Methods

[image] [image]

.NET Framework Class Library
ObjectHelper Methods
ObjectHelper Class See Also Send Feedback

The ObjectHelper type exposes the following members.

Methods

Name | Description
CopyDataRowToObject | Overloaded.
DataMemberPropertyCopyObject |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataTableFromList | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSortedProperties |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsSimpleProperty |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NullableToRegularDateType |
SimplePropertyCopyObject | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectHelper Class
InSite.Library Namespace


CopyDataRowToObject Method

[image] [image]

.NET Framework Class Library
ObjectHelper..::.CopyDataRowToObject Method
ObjectHelper Class See Also Send Feedback

Overload List

Name | Description
CopyDataRowToObject(DataRow, Object) |
CopyDataRowToObject(DataRow, Object, List<(Of <(String>)>)) |

See Also

ObjectHelper Class
ObjectHelper Members
InSite.Library Namespace


CopyDataRowToObject Method (DataRow, Object)

[image]

.NET Framework Class Library
ObjectHelper..::.CopyDataRowToObject Method (DataRow, Object)
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyDataRowToObject ( _
    source As DataRow, _
    destination As Object _
)
C#
public static void CopyDataRowToObject(
    DataRow source,
    Object destination
)
Visual C++
public:
static void CopyDataRowToObject(
    DataRow^ source,
    Object^ destination
)
JavaScript
InSite.Library.ObjectHelper.copyDataRowToObject = function(source, destination);

Parameters

source
Type: System.Data..::.DataRow
destination
Type: System..::.Object

See Also

ObjectHelper Class
CopyDataRowToObject Overload
InSite.Library Namespace


CopyDataRowToObject Method (DataRow, Object, List(String))

[image]

.NET Framework Class Library
ObjectHelper..::.CopyDataRowToObject Method (DataRow, Object, List<(Of <(String>)>))
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CopyDataRowToObject ( _
    source As DataRow, _
    destination As Object, _
    propertiesToIgnore As List(Of String) _
)
C#
public static void CopyDataRowToObject(
    DataRow source,
    Object destination,
    List<string> propertiesToIgnore
)
Visual C++
public:
static void CopyDataRowToObject(
    DataRow^ source,
    Object^ destination,
    List<String^>^ propertiesToIgnore
)
JavaScript
InSite.Library.ObjectHelper.copyDataRowToObject = function(source, destination, propertiesToIgnore);

Parameters

source
Type: System.Data..::.DataRow
destination
Type: System..::.Object
propertiesToIgnore
Type: System.Collections.Generic..::.List <(Of <( String >)>)

See Also

ObjectHelper Class
CopyDataRowToObject Overload
InSite.Library Namespace


DataMemberPropertyCopyObject Method

[image]

.NET Framework Class Library
ObjectHelper..::.DataMemberPropertyCopyObject Method
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DataMemberPropertyCopyObject ( _
    source As Object, _
    destination As Object _
)
C#
public static void DataMemberPropertyCopyObject(
    Object source,
    Object destination
)
Visual C++
public:
static void DataMemberPropertyCopyObject(
    Object^ source,
    Object^ destination
)
JavaScript
InSite.Library.ObjectHelper.dataMemberPropertyCopyObject = function(source, destination);

Parameters

source
Type: System..::.Object
destination
Type: System..::.Object

See Also

ObjectHelper Class
InSite.Library Namespace


GetDataTableFromList Method

[image] [image]

.NET Framework Class Library
ObjectHelper..::.GetDataTableFromList Method
ObjectHelper Class See Also Send Feedback

Overload List

Name | Description
GetDataTableFromList(IList, Type) |
GetDataTableFromList(IList, Type, String, Nullable<(Of <(Guid>)>)) |

See Also

ObjectHelper Class
ObjectHelper Members
InSite.Library Namespace


GetDataTableFromList Method (IList, Type)

[image]

.NET Framework Class Library
ObjectHelper..::.GetDataTableFromList Method (IList, Type)
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataTableFromList ( _
    list As IList, _
    type As Type _
) As DataTable
C#
public static DataTable GetDataTableFromList(
    IList list,
    Type type
)
Visual C++
public:
static DataTable^ GetDataTableFromList(
    IList^ list,
    Type^ type
)
JavaScript
InSite.Library.ObjectHelper.getDataTableFromList = function(list, type);

Parameters

list
Type: System.Collections..::.IList
type
Type: System..::.Type

See Also

ObjectHelper Class
GetDataTableFromList Overload
InSite.Library Namespace


GetDataTableFromList Method (IList, Type, String, Nullable(Guid))

[image]

.NET Framework Class Library
ObjectHelper..::.GetDataTableFromList Method (IList, Type, String, Nullable<(Of <(Guid>)>))
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetDataTableFromList ( _
    list As IList, _
    type As Type, _
    parentFieldName As String, _
    parentFieldValue As Nullable(Of Guid) _
) As DataTable
C#
public static DataTable GetDataTableFromList(
    IList list,
    Type type,
    string parentFieldName,
    Nullable<Guid> parentFieldValue
)
Visual C++
public:
static DataTable^ GetDataTableFromList(
    IList^ list,
    Type^ type,
    String^ parentFieldName,
    Nullable<Guid> parentFieldValue
)
JavaScript
InSite.Library.ObjectHelper.getDataTableFromList = function(list, type, parentFieldName, parentFieldValue);

Parameters

list
Type: System.Collections..::.IList
type
Type: System..::.Type
parentFieldName
Type: System..::.String
parentFieldValue
Type: System..::.Nullable <(Of <( Guid >)>)

See Also

ObjectHelper Class
GetDataTableFromList Overload
InSite.Library Namespace


GetSortedProperties Method

[image]

.NET Framework Class Library
ObjectHelper..::.GetSortedProperties Method
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSortedProperties ( _
    type As Type _
) As SortedDictionary(Of String, PropertyInfo)
C#
public static SortedDictionary<string, PropertyInfo> GetSortedProperties(
    Type type
)
Visual C++
public:
static SortedDictionary<String^, PropertyInfo^>^ GetSortedProperties(
    Type^ type
)
JavaScript
InSite.Library.ObjectHelper.getSortedProperties = function(type);

Parameters

type
Type: System..::.Type

See Also

ObjectHelper Class
InSite.Library Namespace


IsSimpleProperty Method

[image]

.NET Framework Class Library
ObjectHelper..::.IsSimpleProperty Method
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsSimpleProperty ( _
    pi As PropertyInfo _
) As Boolean
C#
public static bool IsSimpleProperty(
    PropertyInfo pi
)
Visual C++
public:
static bool IsSimpleProperty(
    PropertyInfo^ pi
)
JavaScript
InSite.Library.ObjectHelper.isSimpleProperty = function(pi);

Parameters

pi
Type: System.Reflection..::.PropertyInfo

See Also

ObjectHelper Class
InSite.Library Namespace


NullableToRegularDateType Method

[image]

.NET Framework Class Library
ObjectHelper..::.NullableToRegularDateType Method
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function NullableToRegularDateType ( _
    type As Type _
) As Type
C#
public static Type NullableToRegularDateType(
    Type type
)
Visual C++
public:
static Type^ NullableToRegularDateType(
    Type^ type
)
JavaScript
InSite.Library.ObjectHelper.nullableToRegularDateType = function(type);

Parameters

type
Type: System..::.Type

See Also

ObjectHelper Class
InSite.Library Namespace


SimplePropertyCopyObject Method

[image] [image]

.NET Framework Class Library
ObjectHelper..::.SimplePropertyCopyObject Method
ObjectHelper Class See Also Send Feedback

Overload List

Name | Description
SimplePropertyCopyObject(Object, Object) |
SimplePropertyCopyObject(Object, Object, Boolean) |

See Also

ObjectHelper Class
ObjectHelper Members
InSite.Library Namespace


SimplePropertyCopyObject Method (Object, Object)

[image]

.NET Framework Class Library
ObjectHelper..::.SimplePropertyCopyObject Method (Object, Object)
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SimplePropertyCopyObject ( _
    source As Object, _
    destination As Object _
)
C#
public static void SimplePropertyCopyObject(
    Object source,
    Object destination
)
Visual C++
public:
static void SimplePropertyCopyObject(
    Object^ source,
    Object^ destination
)
JavaScript
InSite.Library.ObjectHelper.simplePropertyCopyObject = function(source, destination);

Parameters

source
Type: System..::.Object
destination
Type: System..::.Object

See Also

ObjectHelper Class
SimplePropertyCopyObject Overload
InSite.Library Namespace


SimplePropertyCopyObject Method (Object, Object, Boolean)

[image]

.NET Framework Class Library
ObjectHelper..::.SimplePropertyCopyObject Method (Object, Object, Boolean)
ObjectHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SimplePropertyCopyObject ( _
    source As Object, _
    destination As Object, _
    excludeIdProperty As Boolean _
)
C#
public static void SimplePropertyCopyObject(
    Object source,
    Object destination,
    bool excludeIdProperty
)
Visual C++
public:
static void SimplePropertyCopyObject(
    Object^ source,
    Object^ destination,
    bool excludeIdProperty
)
JavaScript
InSite.Library.ObjectHelper.simplePropertyCopyObject = function(source, destination, excludeIdProperty);

Parameters

source
Type: System..::.Object
destination
Type: System..::.Object
excludeIdProperty
Type: System..::.Boolean

See Also

ObjectHelper Class
SimplePropertyCopyObject Overload
InSite.Library Namespace


RegularExpressionLibrary Class

[image]

.NET Framework Class Library
RegularExpressionLibrary Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class RegularExpressionLibrary
C#
public class RegularExpressionLibrary
Visual C++
public ref class RegularExpressionLibrary
JavaScript
InSite.Library.RegularExpressionLibrary = function();

Type.createClass(
    'InSite.Library.RegularExpressionLibrary');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.RegularExpressionLibrary

See Also

RegularExpressionLibrary Members
InSite.Library Namespace


RegularExpressionLibrary Members

[image] [image]

.NET Framework Class Library
RegularExpressionLibrary Members
RegularExpressionLibrary Class Constructors Methods Properties See Also Send Feedback

The RegularExpressionLibrary type exposes the following members.

Constructors

Name | Description
RegularExpressionLibrary |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidEmail |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
POBoxAddress |
USZipAndCanadaPostalCode |

See Also

RegularExpressionLibrary Class
InSite.Library Namespace


RegularExpressionLibrary Constructor

[image]

.NET Framework Class Library
RegularExpressionLibrary Constructor
RegularExpressionLibrary Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegularExpressionLibrary()
Visual C++
public:
RegularExpressionLibrary()
JavaScript
InSite.Library.RegularExpressionLibrary = function();

See Also

RegularExpressionLibrary Class
InSite.Library Namespace


RegularExpressionLibrary Methods

[image] [image]

.NET Framework Class Library
RegularExpressionLibrary Methods
RegularExpressionLibrary Class See Also Send Feedback

The RegularExpressionLibrary type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValidEmail |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegularExpressionLibrary Class
InSite.Library Namespace


IsValidEmail Method

[image]

.NET Framework Class Library
RegularExpressionLibrary..::.IsValidEmail Method
RegularExpressionLibrary Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsValidEmail ( _
    possibleEmail As String _
) As Boolean
C#
public static bool IsValidEmail(
    string possibleEmail
)
Visual C++
public:
static bool IsValidEmail(
    String^ possibleEmail
)
JavaScript
InSite.Library.RegularExpressionLibrary.isValidEmail = function(possibleEmail);

Parameters

possibleEmail
Type: System..::.String

See Also

RegularExpressionLibrary Class
InSite.Library Namespace


RegularExpressionLibrary Properties

[image] [image]

.NET Framework Class Library
RegularExpressionLibrary Properties
RegularExpressionLibrary Class See Also Send Feedback

The RegularExpressionLibrary type exposes the following members.

Properties

Name | Description
POBoxAddress |
USZipAndCanadaPostalCode |

See Also

RegularExpressionLibrary Class
InSite.Library Namespace


POBoxAddress Property

[image]

.NET Framework Class Library
RegularExpressionLibrary..::.POBoxAddress Property
RegularExpressionLibrary Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property POBoxAddress As Regex
C#
public static Regex POBoxAddress { get; }
Visual C++
public:
static property Regex^ POBoxAddress {
    Regex^ get ();
}
JavaScript
InSite.Library.RegularExpressionLibrary.get_poBoxAddress = function();

See Also

RegularExpressionLibrary Class
InSite.Library Namespace


USZipAndCanadaPostalCode Property

[image]

.NET Framework Class Library
RegularExpressionLibrary..::.USZipAndCanadaPostalCode Property
RegularExpressionLibrary Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property USZipAndCanadaPostalCode As Regex
C#
public static Regex USZipAndCanadaPostalCode { get; }
Visual C++
public:
static property Regex^ USZipAndCanadaPostalCode {
    Regex^ get ();
}
JavaScript
InSite.Library.RegularExpressionLibrary.get_usZipAndCanadaPostalCode = function();

See Also

RegularExpressionLibrary Class
InSite.Library Namespace


ScriptHelper Class

[image]

.NET Framework Class Library
ScriptHelper Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class ScriptHelper
C#
public class ScriptHelper
Visual C++
public ref class ScriptHelper
JavaScript
InSite.Library.ScriptHelper = function();

Type.createClass(
    'InSite.Library.ScriptHelper');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.ScriptHelper

See Also

ScriptHelper Members
InSite.Library Namespace


ScriptHelper Members

[image] [image]

.NET Framework Class Library
ScriptHelper Members
ScriptHelper Class Constructors Methods See Also Send Feedback

The ScriptHelper type exposes the following members.

Constructors

Name | Description
ScriptHelper |

Methods

Name | Description
CenterDiv | Requires jQuery Should position a div as a popup in the center of the screen.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptHelper Class
InSite.Library Namespace


ScriptHelper Constructor

[image]

.NET Framework Class Library
ScriptHelper Constructor
ScriptHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ScriptHelper()
Visual C++
public:
ScriptHelper()
JavaScript
InSite.Library.ScriptHelper = function();

See Also

ScriptHelper Class
InSite.Library Namespace


ScriptHelper Methods

[image] [image]

.NET Framework Class Library
ScriptHelper Methods
ScriptHelper Class See Also Send Feedback

The ScriptHelper type exposes the following members.

Methods

Name | Description
CenterDiv | Requires jQuery Should position a div as a popup in the center of the screen.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptHelper Class
InSite.Library Namespace


CenterDiv Method

[image]

.NET Framework Class Library
ScriptHelper..::.CenterDiv Method
ScriptHelper Class See Also Send Feedback

Requires jQuery Should position a div as a popup in the center of the screen.

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CenterDiv ( _
    cssId As String _
) As String
C#
public static string CenterDiv(
    string cssId
)
Visual C++
public:
static String^ CenterDiv(
    String^ cssId
)
JavaScript
InSite.Library.ScriptHelper.centerDiv = function(cssId);

Parameters

cssId
Type: System..::.String

Return Value

See Also

ScriptHelper Class
InSite.Library Namespace


SortProperty Structure

[image]

.NET Framework Class Library
SortProperty Structure
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Structure SortProperty
C#
public struct SortProperty
Visual C++
public value class SortProperty
JavaScript
JavaScript supports the use of structures, but not the declaration of new ones.

See Also

SortProperty Members
InSite.Library Namespace


SortProperty Members

[image] [image]

.NET Framework Class Library
SortProperty Members
SortProperty Structure Constructors Methods Properties See Also Send Feedback

The SortProperty type exposes the following members.

Constructors

Name | Description
SortProperty | Overloaded.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Descending |
Name |

See Also

SortProperty Structure
InSite.Library Namespace


SortProperty Constructor

[image] [image]

.NET Framework Class Library
SortProperty Constructor
SortProperty Structure See Also Send Feedback

Overload List

Name | Description
SortProperty(String) |
SortProperty(String, Boolean) |

See Also

SortProperty Structure
SortProperty Members
InSite.Library Namespace


SortProperty Constructor (String)

[image]

.NET Framework Class Library
SortProperty Constructor (String)
SortProperty Structure See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    propertyName As String _
)
C#
public SortProperty(
    string propertyName
)
Visual C++
public:
SortProperty(
    String^ propertyName
)
JavaScript
InSite.Library.SortProperty = function(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

SortProperty Structure
SortProperty Overload
InSite.Library Namespace


SortProperty Constructor (String, Boolean)

[image]

.NET Framework Class Library
SortProperty Constructor (String, Boolean)
SortProperty Structure See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    propertyName As String, _
    sortDescending As Boolean _
)
C#
public SortProperty(
    string propertyName,
    bool sortDescending
)
Visual C++
public:
SortProperty(
    String^ propertyName,
    bool sortDescending
)
JavaScript
InSite.Library.SortProperty = function(propertyName, sortDescending);

Parameters

propertyName
Type: System..::.String
sortDescending
Type: System..::.Boolean

See Also

SortProperty Structure
SortProperty Overload
InSite.Library Namespace


SortProperty Methods

[image] [image]

.NET Framework Class Library
SortProperty Methods
SortProperty Structure See Also Send Feedback

The SortProperty type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SortProperty Structure
InSite.Library Namespace


SortProperty Properties

[image] [image]

.NET Framework Class Library
SortProperty Properties
SortProperty Structure See Also Send Feedback

The SortProperty type exposes the following members.

Properties

Name | Description
Descending |
Name |

See Also

SortProperty Structure
InSite.Library Namespace


Descending Property

[image]

.NET Framework Class Library
SortProperty..::.Descending Property
SortProperty Structure See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property Descending As Boolean
C#
public bool Descending { get; set; }
Visual C++
public:
property bool Descending {
    bool get ();
    void set (bool value);
}
JavaScript
function get_descending();
function set_descending(value);

See Also

SortProperty Structure
InSite.Library Namespace


Name Property

[image]

.NET Framework Class Library
SortProperty..::.Name Property
SortProperty Structure See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

SortProperty Structure
InSite.Library Namespace


SQLHelper Class

[image]

.NET Framework Class Library
SQLHelper Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class SQLHelper
C#
public class SQLHelper
Visual C++
public ref class SQLHelper
JavaScript
InSite.Library.SQLHelper = function();

Type.createClass(
    'InSite.Library.SQLHelper');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.SQLHelper

See Also

SQLHelper Members
InSite.Library Namespace


SQLHelper Members

[image] [image]

.NET Framework Class Library
SQLHelper Members
SQLHelper Class Constructors Methods See Also Send Feedback

The SQLHelper type exposes the following members.

Constructors

Name | Description
SQLHelper |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatSearch |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SQLHelper Class
InSite.Library Namespace


SQLHelper Constructor

[image]

.NET Framework Class Library
SQLHelper Constructor
SQLHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SQLHelper()
Visual C++
public:
SQLHelper()
JavaScript
InSite.Library.SQLHelper = function();

See Also

SQLHelper Class
InSite.Library Namespace


SQLHelper Methods

[image] [image]

.NET Framework Class Library
SQLHelper Methods
SQLHelper Class See Also Send Feedback

The SQLHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatSearch |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SQLHelper Class
InSite.Library Namespace


FormatSearch Method

[image]

.NET Framework Class Library
SQLHelper..::.FormatSearch Method
SQLHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function FormatSearch ( _
    search As String _
) As String
C#
public static string FormatSearch(
    string search
)
Visual C++
public:
static String^ FormatSearch(
    String^ search
)
JavaScript
InSite.Library.SQLHelper.formatSearch = function(search);

Parameters

search
Type: System..::.String

See Also

SQLHelper Class
InSite.Library Namespace


StringHelper Class

[image]

.NET Framework Class Library
StringHelper Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class StringHelper
C#
public class StringHelper
Visual C++
public ref class StringHelper
JavaScript
InSite.Library.StringHelper = function();

Type.createClass(
    'InSite.Library.StringHelper');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.StringHelper

See Also

StringHelper Members
InSite.Library Namespace


StringHelper Members

[image] [image]

.NET Framework Class Library
StringHelper Members
StringHelper Class Constructors Methods Fields See Also Send Feedback

The StringHelper type exposes the following members.

Constructors

Name | Description
StringHelper |

Methods

Name | Description
BuildCommaDelimitedString | Overloaded.
Char |
Decrypt |
Encrypt |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Fill |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Left |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Mid | Overloaded.
NullToEmptyString |
Right |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UTF8ByteArrayToString |

Fields

Name | Description
COMMA_SPLITTER |
VERTICAL_SPLITTER |

See Also

StringHelper Class
InSite.Library Namespace


StringHelper Constructor

[image]

.NET Framework Class Library
StringHelper Constructor
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StringHelper()
Visual C++
public:
StringHelper()
JavaScript
InSite.Library.StringHelper = function();

See Also

StringHelper Class
InSite.Library Namespace


StringHelper Fields

[image] [image]

.NET Framework Class Library
StringHelper Fields
StringHelper Class See Also Send Feedback

The StringHelper type exposes the following members.

Fields

Name | Description
COMMA_SPLITTER |
VERTICAL_SPLITTER |

See Also

StringHelper Class
InSite.Library Namespace


COMMA_SPLITTER Field

[image]

.NET Framework Class Library
StringHelper..::.COMMA_SPLITTER Field
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared COMMA_SPLITTER As Char()
C#
public static char[] COMMA_SPLITTER
Visual C++
public:
static array<wchar_t>^ COMMA_SPLITTER
JavaScript
InSite.Library.StringHelper.commA_SPLITTER

See Also

StringHelper Class
InSite.Library Namespace


VERTICAL_SPLITTER Field

[image]

.NET Framework Class Library
StringHelper..::.VERTICAL_SPLITTER Field
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared VERTICAL_SPLITTER As Char()
C#
public static char[] VERTICAL_SPLITTER
Visual C++
public:
static array<wchar_t>^ VERTICAL_SPLITTER
JavaScript
InSite.Library.StringHelper.verticaL_SPLITTER

See Also

StringHelper Class
InSite.Library Namespace


StringHelper Methods

[image] [image]

.NET Framework Class Library
StringHelper Methods
StringHelper Class See Also Send Feedback

The StringHelper type exposes the following members.

Methods

Name | Description
BuildCommaDelimitedString | Overloaded.
Char |
Decrypt |
Encrypt |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Fill |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Left |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Mid | Overloaded.
NullToEmptyString |
Right |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UTF8ByteArrayToString |

See Also

StringHelper Class
InSite.Library Namespace


BuildCommaDelimitedString Method

[image] [image]

.NET Framework Class Library
StringHelper..::.BuildCommaDelimitedString Method
StringHelper Class See Also Send Feedback

Overload List

Name | Description
BuildCommaDelimitedString(IList<(Of <(String>)>)) |
BuildCommaDelimitedString(IList<(Of <(String>)>), Boolean) |

See Also

StringHelper Class
StringHelper Members
InSite.Library Namespace


BuildCommaDelimitedString Method (IList(String))

[image]

.NET Framework Class Library
StringHelper..::.BuildCommaDelimitedString Method (IList<(Of <(String>)>))
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BuildCommaDelimitedString ( _
    itemList As IList(Of String) _
) As String
C#
public static string BuildCommaDelimitedString(
    IList<string> itemList
)
Visual C++
public:
static String^ BuildCommaDelimitedString(
    IList<String^>^ itemList
)
JavaScript
InSite.Library.StringHelper.buildCommaDelimitedString = function(itemList);

Parameters

itemList
Type: System.Collections.Generic..::.IList <(Of <( String >)>)

See Also

StringHelper Class
BuildCommaDelimitedString Overload
InSite.Library Namespace


BuildCommaDelimitedString Method (IList(String), Boolean)

[image]

.NET Framework Class Library
StringHelper..::.BuildCommaDelimitedString Method (IList<(Of <(String>)>), Boolean)
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function BuildCommaDelimitedString ( _
    itemList As IList(Of String), _
    includeQuotes As Boolean _
) As String
C#
public static string BuildCommaDelimitedString(
    IList<string> itemList,
    bool includeQuotes
)
Visual C++
public:
static String^ BuildCommaDelimitedString(
    IList<String^>^ itemList,
    bool includeQuotes
)
JavaScript
InSite.Library.StringHelper.buildCommaDelimitedString = function(itemList, includeQuotes);

Parameters

itemList
Type: System.Collections.Generic..::.IList <(Of <( String >)>)
includeQuotes
Type: System..::.Boolean

See Also

StringHelper Class
BuildCommaDelimitedString Overload
InSite.Library Namespace


Char Method

[image]

.NET Framework Class Library
StringHelper..::.Char Method
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Char ( _
    asciiCode As Integer _
) As String
C#
public static string Char(
    int asciiCode
)
Visual C++
public:
static String^ Char(
    int asciiCode
)
JavaScript
InSite.Library.StringHelper.char = function(asciiCode);

Parameters

asciiCode
Type: System..::.Int32

See Also

StringHelper Class
InSite.Library Namespace


Decrypt Method

[image]

.NET Framework Class Library
StringHelper..::.Decrypt Method
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Decrypt ( _
    cryptedString As String _
) As String
C#
public static string Decrypt(
    string cryptedString
)
Visual C++
public:
static String^ Decrypt(
    String^ cryptedString
)
JavaScript
InSite.Library.StringHelper.decrypt = function(cryptedString);

Parameters

cryptedString
Type: System..::.String

See Also

StringHelper Class
InSite.Library Namespace


Encrypt Method

[image]

.NET Framework Class Library
StringHelper..::.Encrypt Method
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Encrypt ( _
    originalString As String _
) As String
C#
public static string Encrypt(
    string originalString
)
Visual C++
public:
static String^ Encrypt(
    String^ originalString
)
JavaScript
InSite.Library.StringHelper.encrypt = function(originalString);

Parameters

originalString
Type: System..::.String

See Also

StringHelper Class
InSite.Library Namespace


Fill Method

[image]

.NET Framework Class Library
StringHelper..::.Fill Method
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Fill ( _
    fillChar As String, _
    length As Integer _
) As String
C#
public static string Fill(
    string fillChar,
    int length
)
Visual C++
public:
static String^ Fill(
    String^ fillChar,
    int length
)
JavaScript
InSite.Library.StringHelper.fill = function(fillChar, length);

Parameters

fillChar
Type: System..::.String
length
Type: System..::.Int32

See Also

StringHelper Class
InSite.Library Namespace


Left Method

[image]

.NET Framework Class Library
StringHelper..::.Left Method
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Left ( _
    value As String, _
    length As Integer _
) As String
C#
public static string Left(
    string value,
    int length
)
Visual C++
public:
static String^ Left(
    String^ value,
    int length
)
JavaScript
InSite.Library.StringHelper.left = function(value, length);

Parameters

value
Type: System..::.String
length
Type: System..::.Int32

See Also

StringHelper Class
InSite.Library Namespace


Mid Method

[image] [image]

.NET Framework Class Library
StringHelper..::.Mid Method
StringHelper Class See Also Send Feedback

Overload List

Name | Description
Mid(String, Int32) |
Mid(String, Int32, Int32) |

See Also

StringHelper Class
StringHelper Members
InSite.Library Namespace


Mid Method (String, Int32)

[image]

.NET Framework Class Library
StringHelper..::.Mid Method (String, Int32)
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Mid ( _
    value As String, _
    startIndex As Integer _
) As String
C#
public static string Mid(
    string value,
    int startIndex
)
Visual C++
public:
static String^ Mid(
    String^ value,
    int startIndex
)
JavaScript
InSite.Library.StringHelper.mid = function(value, startIndex);

Parameters

value
Type: System..::.String
startIndex
Type: System..::.Int32

See Also

StringHelper Class
Mid Overload
InSite.Library Namespace


Mid Method (String, Int32, Int32)

[image]

.NET Framework Class Library
StringHelper..::.Mid Method (String, Int32, Int32)
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Mid ( _
    value As String, _
    startIndex As Integer, _
    length As Integer _
) As String
C#
public static string Mid(
    string value,
    int startIndex,
    int length
)
Visual C++
public:
static String^ Mid(
    String^ value,
    int startIndex,
    int length
)
JavaScript
InSite.Library.StringHelper.mid = function(value, startIndex, length);

Parameters

value
Type: System..::.String
startIndex
Type: System..::.Int32
length
Type: System..::.Int32

See Also

StringHelper Class
Mid Overload
InSite.Library Namespace


NullToEmptyString Method

[image]

.NET Framework Class Library
StringHelper..::.NullToEmptyString Method
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function NullToEmptyString ( _
    value As String _
) As String
C#
public static string NullToEmptyString(
    string value
)
Visual C++
public:
static String^ NullToEmptyString(
    String^ value
)
JavaScript
InSite.Library.StringHelper.nullToEmptyString = function(value);

Parameters

value
Type: System..::.String

See Also

StringHelper Class
InSite.Library Namespace


Right Method

[image]

.NET Framework Class Library
StringHelper..::.Right Method
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Right ( _
    value As String, _
    length As Integer _
) As String
C#
public static string Right(
    string value,
    int length
)
Visual C++
public:
static String^ Right(
    String^ value,
    int length
)
JavaScript
InSite.Library.StringHelper.right = function(value, length);

Parameters

value
Type: System..::.String
length
Type: System..::.Int32

See Also

StringHelper Class
InSite.Library Namespace


UTF8ByteArrayToString Method

[image]

.NET Framework Class Library
StringHelper..::.UTF8ByteArrayToString Method
StringHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function UTF8ByteArrayToString ( _
    characters As Byte() _
) As String
C#
public static string UTF8ByteArrayToString(
    byte[] characters
)
Visual C++
public:
static String^ UTF8ByteArrayToString(
    array<unsigned char>^ characters
)
JavaScript
InSite.Library.StringHelper.utF8ByteArrayToString = function(characters);

Parameters

characters
Type: array< System..::.Byte >[]()[]

See Also

StringHelper Class
InSite.Library Namespace


WebControlHelper Class

[image]

.NET Framework Class Library
WebControlHelper Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class WebControlHelper
C#
public class WebControlHelper
Visual C++
public ref class WebControlHelper
JavaScript
InSite.Library.WebControlHelper = function();

Type.createClass(
    'InSite.Library.WebControlHelper');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.WebControlHelper

See Also

WebControlHelper Members
InSite.Library Namespace


WebControlHelper Members

[image] [image]

.NET Framework Class Library
WebControlHelper Members
WebControlHelper Class Constructors Methods See Also Send Feedback

The WebControlHelper type exposes the following members.

Constructors

Name | Description
WebControlHelper |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetDefaultButton | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebControlHelper Class
InSite.Library Namespace


WebControlHelper Constructor

[image]

.NET Framework Class Library
WebControlHelper Constructor
WebControlHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebControlHelper()
Visual C++
public:
WebControlHelper()
JavaScript
InSite.Library.WebControlHelper = function();

See Also

WebControlHelper Class
InSite.Library Namespace


WebControlHelper Methods

[image] [image]

.NET Framework Class Library
WebControlHelper Methods
WebControlHelper Class See Also Send Feedback

The WebControlHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetDefaultButton | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebControlHelper Class
InSite.Library Namespace


SetDefaultButton Method

[image] [image]

.NET Framework Class Library
WebControlHelper..::.SetDefaultButton Method
WebControlHelper Class See Also Send Feedback

Overload List

Name | Description
SetDefaultButton(TextBox, Button) |
SetDefaultButton(TextBox, LinkButton) | Adds javascript so that an enter keypress in the given TextBox will fire off the given LinkButton. For some reason asp.net default buttons do not play well with LinkButtons

See Also

WebControlHelper Class
WebControlHelper Members
InSite.Library Namespace


SetDefaultButton Method (TextBox, Button)

[image]

.NET Framework Class Library
WebControlHelper..::.SetDefaultButton Method (TextBox, Button)
WebControlHelper Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetDefaultButton ( _
    textBox As TextBox, _
    button As Button _
)
C#
public static void SetDefaultButton(
    TextBox textBox,
    Button button
)
Visual C++
public:
static void SetDefaultButton(
    TextBox^ textBox,
    Button^ button
)
JavaScript
InSite.Library.WebControlHelper.setDefaultButton = function(textBox, button);

Parameters

textBox
Type: System.Web.UI.WebControls..::.TextBox
button
Type: System.Web.UI.WebControls..::.Button

See Also

WebControlHelper Class
SetDefaultButton Overload
InSite.Library Namespace


SetDefaultButton Method (TextBox, LinkButton)

[image]

.NET Framework Class Library
WebControlHelper..::.SetDefaultButton Method (TextBox, LinkButton)
WebControlHelper Class See Also Send Feedback

Adds javascript so that an enter keypress in the given TextBox will fire off the given LinkButton. For some reason asp.net default buttons do not play well with LinkButtons

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetDefaultButton ( _
    textBox As TextBox, _
    linkButton As LinkButton _
)
C#
public static void SetDefaultButton(
    TextBox textBox,
    LinkButton linkButton
)
Visual C++
public:
static void SetDefaultButton(
    TextBox^ textBox,
    LinkButton^ linkButton
)
JavaScript
InSite.Library.WebControlHelper.setDefaultButton = function(textBox, linkButton);

Parameters

textBox
Type: System.Web.UI.WebControls..::.TextBox
linkButton
Type: System.Web.UI.WebControls..::.LinkButton

See Also

WebControlHelper Class
SetDefaultButton Overload
InSite.Library Namespace


WebPathResolver Class

[image]

.NET Framework Class Library
WebPathResolver Class
Members See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class WebPathResolver
C#
public class WebPathResolver
Visual C++
public ref class WebPathResolver
JavaScript
InSite.Library.WebPathResolver = function();

Type.createClass(
    'InSite.Library.WebPathResolver');

Inheritance Hierarchy

System..::.Object
InSite.Library..::.WebPathResolver

See Also

WebPathResolver Members
InSite.Library Namespace


WebPathResolver Members

[image] [image]

.NET Framework Class Library
WebPathResolver Members
WebPathResolver Class Constructors Methods See Also Send Feedback

The WebPathResolver type exposes the following members.

Constructors

Name | Description
WebPathResolver |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ResolveImage |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebPathResolver Class
InSite.Library Namespace


WebPathResolver Constructor

[image]

.NET Framework Class Library
WebPathResolver Constructor
WebPathResolver Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    systemPath As String, _
    webRoot As String, _
    webImageDirectory As String _
)
C#
public WebPathResolver(
    string systemPath,
    string webRoot,
    string webImageDirectory
)
Visual C++
public:
WebPathResolver(
    String^ systemPath,
    String^ webRoot,
    String^ webImageDirectory
)
JavaScript
InSite.Library.WebPathResolver = function(systemPath, webRoot, webImageDirectory);

Parameters

systemPath
Type: System..::.String
webRoot
Type: System..::.String
webImageDirectory
Type: System..::.String

See Also

WebPathResolver Class
InSite.Library Namespace


WebPathResolver Methods

[image] [image]

.NET Framework Class Library
WebPathResolver Methods
WebPathResolver Class See Also Send Feedback

The WebPathResolver type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ResolveImage |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebPathResolver Class
InSite.Library Namespace


ResolveImage Method

[image]

.NET Framework Class Library
WebPathResolver..::.ResolveImage Method
WebPathResolver Class See Also Send Feedback

Namespace: InSite.Library
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Function ResolveImage ( _
    defaultImage As String, _
    image As String _
) As String
C#
public string ResolveImage(
    string defaultImage,
    string image
)
Visual C++
public:
String^ ResolveImage(
    String^ defaultImage,
    String^ image
)
JavaScript
function resolveImage(defaultImage, image);

Parameters

defaultImage
Type: System..::.String
image
Type: System..::.String

See Also

WebPathResolver Class
InSite.Library Namespace


InSite.Library.Exceptions Namespace

[image]

.NET Framework Class Library
InSite.Library.Exceptions Namespace
Send Feedback

Classes

Class | Description
InSiteException |


InSiteException Class

[image]

.NET Framework Class Library
InSiteException Class
Members See Also Send Feedback

Namespace: InSite.Library.Exceptions
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class InSiteException _
    Inherits Exception
C#
public class InSiteException : Exception
Visual C++
public ref class InSiteException : public Exception
JavaScript
InSite.Library.Exceptions.InSiteException = function();

Type.createClass(
    'InSite.Library.Exceptions.InSiteException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Library.Exceptions..::.InSiteException

See Also

InSiteException Members
InSite.Library.Exceptions Namespace


InSiteException Members

[image] [image]

.NET Framework Class Library
InSiteException Members
InSiteException Class Constructors Methods Properties See Also Send Feedback

The InSiteException type exposes the following members.

Constructors

Name | Description
InSiteException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InSiteException Class
InSite.Library.Exceptions Namespace


InSiteException Constructor

[image]

.NET Framework Class Library
InSiteException Constructor
InSiteException Class See Also Send Feedback

Namespace: InSite.Library.Exceptions
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public InSiteException(
    string message
)
Visual C++
public:
InSiteException(
    String^ message
)
JavaScript
InSite.Library.Exceptions.InSiteException = function(message);

Parameters

message
Type: System..::.String

See Also

InSiteException Class
InSite.Library.Exceptions Namespace


InSiteException Methods

[image] [image]

.NET Framework Class Library
InSiteException Methods
InSiteException Class See Also Send Feedback

The InSiteException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InSiteException Class
InSite.Library.Exceptions Namespace


InSiteException Properties

[image] [image]

.NET Framework Class Library
InSiteException Properties
InSiteException Class See Also Send Feedback

The InSiteException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InSiteException Class
InSite.Library.Exceptions Namespace


InSite.Library.Shipping Namespace

[image]

.NET Framework Class Library
InSite.Library.Shipping Namespace
Send Feedback

Classes

Class | Description
Package |
UPSShip |
UPSShipAddress |

Interfaces

Interface | Description
IUPSPackager |


IUPSPackager Interface

[image]

.NET Framework Class Library
IUPSPackager Interface
See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Interface IUPSPackager
C#
public interface IUPSPackager
Visual C++
public interface class IUPSPackager
JavaScript
InSite.Library.Shipping.IUPSPackager = function();
InSite.Library.Shipping.IUPSPackager.createInterface('InSite.Library.Shipping.IUPSPackager');

See Also

InSite.Library.Shipping Namespace


Package Class

[image]

.NET Framework Class Library
Package Class
Members See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class Package
C#
public class Package
Visual C++
public ref class Package
JavaScript
InSite.Library.Shipping.Package = function();

Type.createClass(
    'InSite.Library.Shipping.Package');

Inheritance Hierarchy

System..::.Object
InSite.Library.Shipping..::.Package

See Also

Package Members
InSite.Library.Shipping Namespace


Package Members

[image] [image]

.NET Framework Class Library
Package Members
Package Class Constructors Methods Properties See Also Send Feedback

The Package type exposes the following members.

Constructors

Name | Description
Package |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height |
Length |
Type |
Weight |
Width |

See Also

Package Class
InSite.Library.Shipping Namespace


Package Constructor

[image]

.NET Framework Class Library
Package Constructor
Package Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Package()
Visual C++
public:
Package()
JavaScript
InSite.Library.Shipping.Package = function();

See Also

Package Class
InSite.Library.Shipping Namespace


Package Methods

[image] [image]

.NET Framework Class Library
Package Methods
Package Class See Also Send Feedback

The Package type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Package Class
InSite.Library.Shipping Namespace


Package Properties

[image] [image]

.NET Framework Class Library
Package Properties
Package Class See Also Send Feedback

The Package type exposes the following members.

Properties

Name | Description
Height |
Length |
Type |
Weight |
Width |

See Also

Package Class
InSite.Library.Shipping Namespace


Height Property

[image]

.NET Framework Class Library
Package..::.Height Property
Package Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property Height As Decimal
C#
public decimal Height { get; set; }
Visual C++
public:
property Decimal Height {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_height();
function set_height(value);

See Also

Package Class
InSite.Library.Shipping Namespace


Length Property

[image]

.NET Framework Class Library
Package..::.Length Property
Package Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property Length As Decimal
C#
public decimal Length { get; set; }
Visual C++
public:
property Decimal Length {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_length();
function set_length(value);

See Also

Package Class
InSite.Library.Shipping Namespace


Type Property

[image]

.NET Framework Class Library
Package..::.Type Property
Package Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property Type As String
C#
public string Type { get; set; }
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

See Also

Package Class
InSite.Library.Shipping Namespace


Weight Property

[image]

.NET Framework Class Library
Package..::.Weight Property
Package Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property Weight As Decimal
C#
public decimal Weight { get; set; }
Visual C++
public:
property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_weight();
function set_weight(value);

See Also

Package Class
InSite.Library.Shipping Namespace


Width Property

[image]

.NET Framework Class Library
Package..::.Width Property
Package Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property Width As Decimal
C#
public decimal Width { get; set; }
Visual C++
public:
property Decimal Width {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_width();
function set_width(value);

See Also

Package Class
InSite.Library.Shipping Namespace


UPSShip Class

[image]

.NET Framework Class Library
UPSShip Class
Members See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class UPSShip
C#
public class UPSShip
Visual C++
public ref class UPSShip
JavaScript
InSite.Library.Shipping.UPSShip = function();

Type.createClass(
    'InSite.Library.Shipping.UPSShip');

Inheritance Hierarchy

System..::.Object
InSite.Library.Shipping..::.UPSShip

See Also

UPSShip Members
InSite.Library.Shipping Namespace


UPSShip Members

[image] [image]

.NET Framework Class Library
UPSShip Members
UPSShip Class Constructors Methods Properties See Also Send Feedback

The UPSShip type exposes the following members.

Constructors

Name | Description
UPSShip | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRatesAndService |
GetServiceCodeName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackShipment |
ValidateUSAddress |

Properties

Name | Description
UPSAccessKey |
UPSAddressValidationStatus |
UPSAddressValidationStatusDescription |
UPSAddressValidationURL |
UPSPassword |
UPSRatesAndServiceStatus |
UPSRatesAndServiceStatusDescription |
UPSRatesAndServiceURL |
UPSTestMode |
UPSTrackingStatus |
UPSTrackingStatusDescription |
UPSTrackingURL |
UPSUserName |

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSShip Constructor

[image] [image]

.NET Framework Class Library
UPSShip Constructor
UPSShip Class See Also Send Feedback

Overload List

Name | Description
UPSShip()()() |
UPSShip(String, String, String, Boolean) |

See Also

UPSShip Class
UPSShip Members
InSite.Library.Shipping Namespace


UPSShip Constructor

[image]

.NET Framework Class Library
UPSShip Constructor
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UPSShip()
Visual C++
public:
UPSShip()
JavaScript
InSite.Library.Shipping.UPSShip = function();

See Also

UPSShip Class
UPSShip Overload
InSite.Library.Shipping Namespace


UPSShip Constructor (String, String, String, Boolean)

[image]

.NET Framework Class Library
UPSShip Constructor (String, String, String, Boolean)
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    UPSAccessKey As String, _
    UPSUserName As String, _
    UPSPassword As String, _
    UPSTestMode As Boolean _
)
C#
public UPSShip(
    string UPSAccessKey,
    string UPSUserName,
    string UPSPassword,
    bool UPSTestMode
)
Visual C++
public:
UPSShip(
    String^ UPSAccessKey,
    String^ UPSUserName,
    String^ UPSPassword,
    bool UPSTestMode
)
JavaScript
InSite.Library.Shipping.UPSShip = function(UPSAccessKey, UPSUserName, UPSPassword, UPSTestMode);

Parameters

UPSAccessKey
Type: System..::.String
UPSUserName
Type: System..::.String
UPSPassword
Type: System..::.String
UPSTestMode
Type: System..::.Boolean

See Also

UPSShip Class
UPSShip Overload
InSite.Library.Shipping Namespace


UPSShip Methods

[image] [image]

.NET Framework Class Library
UPSShip Methods
UPSShip Class See Also Send Feedback

The UPSShip type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRatesAndService |
GetServiceCodeName |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackShipment |
ValidateUSAddress |

See Also

UPSShip Class
InSite.Library.Shipping Namespace


GetRatesAndService Method

[image]

.NET Framework Class Library
UPSShip..::.GetRatesAndService Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Function GetRatesAndService ( _
    packages As IList(Of Package), _
    shipAddress As UPSShipAddress, _
    isWholesale As Boolean _
) As DataSet
C#
public DataSet GetRatesAndService(
    IList<Package> packages,
    UPSShipAddress shipAddress,
    bool isWholesale
)
Visual C++
public:
DataSet^ GetRatesAndService(
    IList<Package^>^ packages,
    UPSShipAddress^ shipAddress,
    bool isWholesale
)
JavaScript
function getRatesAndService(packages, shipAddress, isWholesale);

Parameters

packages
Type: System.Collections.Generic..::.IList <(Of <( Package >)>)
shipAddress
Type: InSite.Library.Shipping..::.UPSShipAddress
isWholesale
Type: System..::.Boolean

See Also

UPSShip Class
InSite.Library.Shipping Namespace


GetServiceCodeName Method

[image]

.NET Framework Class Library
UPSShip..::.GetServiceCodeName Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetServiceCodeName ( _
    ServiceCode As String _
) As String
C#
public static string GetServiceCodeName(
    string ServiceCode
)
Visual C++
public:
static String^ GetServiceCodeName(
    String^ ServiceCode
)
JavaScript
InSite.Library.Shipping.UPSShip.getServiceCodeName = function(ServiceCode);

Parameters

ServiceCode
Type: System..::.String

See Also

UPSShip Class
InSite.Library.Shipping Namespace


TrackShipment Method

[image]

.NET Framework Class Library
UPSShip..::.TrackShipment Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Function TrackShipment ( _
    TrackingNumber As String _
) As DataSet
C#
public DataSet TrackShipment(
    string TrackingNumber
)
Visual C++
public:
DataSet^ TrackShipment(
    String^ TrackingNumber
)
JavaScript
function trackShipment(TrackingNumber);

Parameters

TrackingNumber
Type: System..::.String

See Also

UPSShip Class
InSite.Library.Shipping Namespace


ValidateUSAddress Method

[image]

.NET Framework Class Library
UPSShip..::.ValidateUSAddress Method
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Function ValidateUSAddress ( _
    City As String, _
    State As String, _
    PostalCode As String _
) As DataSet
C#
public DataSet ValidateUSAddress(
    string City,
    string State,
    string PostalCode
)
Visual C++
public:
DataSet^ ValidateUSAddress(
    String^ City,
    String^ State,
    String^ PostalCode
)
JavaScript
function validateUSAddress(City, State, PostalCode);

Parameters

City
Type: System..::.String
State
Type: System..::.String
PostalCode
Type: System..::.String

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSShip Properties

[image] [image]

.NET Framework Class Library
UPSShip Properties
UPSShip Class See Also Send Feedback

The UPSShip type exposes the following members.

Properties

Name | Description
UPSAccessKey |
UPSAddressValidationStatus |
UPSAddressValidationStatusDescription |
UPSAddressValidationURL |
UPSPassword |
UPSRatesAndServiceStatus |
UPSRatesAndServiceStatusDescription |
UPSRatesAndServiceURL |
UPSTestMode |
UPSTrackingStatus |
UPSTrackingStatusDescription |
UPSTrackingURL |
UPSUserName |

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSAccessKey Property

[image]

.NET Framework Class Library
UPSShip..::.UPSAccessKey Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property UPSAccessKey As String
C#
public string UPSAccessKey { get; set; }
Visual C++
public:
property String^ UPSAccessKey {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_upsAccessKey();
function set_upsAccessKey(value);

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSAddressValidationStatus Property

[image]

.NET Framework Class Library
UPSShip..::.UPSAddressValidationStatus Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSAddressValidationStatus As Integer
C#
public int UPSAddressValidationStatus { get; }
Visual C++
public:
property int UPSAddressValidationStatus {
    int get ();
}
JavaScript
function get_upsAddressValidationStatus();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSAddressValidationStatusDescription Property

[image]

.NET Framework Class Library
UPSShip..::.UPSAddressValidationStatusDescription Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSAddressValidationStatusDescription As String
C#
public string UPSAddressValidationStatusDescription { get; }
Visual C++
public:
property String^ UPSAddressValidationStatusDescription {
    String^ get ();
}
JavaScript
function get_upsAddressValidationStatusDescription();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSAddressValidationURL Property

[image]

.NET Framework Class Library
UPSShip..::.UPSAddressValidationURL Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSAddressValidationURL As String
C#
public string UPSAddressValidationURL { get; }
Visual C++
public:
property String^ UPSAddressValidationURL {
    String^ get ();
}
JavaScript
function get_upsAddressValidationURL();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSPassword Property

[image]

.NET Framework Class Library
UPSShip..::.UPSPassword Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property UPSPassword As String
C#
public string UPSPassword { get; set; }
Visual C++
public:
property String^ UPSPassword {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_upsPassword();
function set_upsPassword(value);

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSRatesAndServiceStatus Property

[image]

.NET Framework Class Library
UPSShip..::.UPSRatesAndServiceStatus Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSRatesAndServiceStatus As Integer
C#
public int UPSRatesAndServiceStatus { get; }
Visual C++
public:
property int UPSRatesAndServiceStatus {
    int get ();
}
JavaScript
function get_upsRatesAndServiceStatus();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSRatesAndServiceStatusDescription Property

[image]

.NET Framework Class Library
UPSShip..::.UPSRatesAndServiceStatusDescription Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSRatesAndServiceStatusDescription As String
C#
public string UPSRatesAndServiceStatusDescription { get; }
Visual C++
public:
property String^ UPSRatesAndServiceStatusDescription {
    String^ get ();
}
JavaScript
function get_upsRatesAndServiceStatusDescription();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSRatesAndServiceURL Property

[image]

.NET Framework Class Library
UPSShip..::.UPSRatesAndServiceURL Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSRatesAndServiceURL As String
C#
public string UPSRatesAndServiceURL { get; }
Visual C++
public:
property String^ UPSRatesAndServiceURL {
    String^ get ();
}
JavaScript
function get_upsRatesAndServiceURL();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSTestMode Property

[image]

.NET Framework Class Library
UPSShip..::.UPSTestMode Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property UPSTestMode As Boolean
C#
public bool UPSTestMode { get; set; }
Visual C++
public:
property bool UPSTestMode {
    bool get ();
    void set (bool value);
}
JavaScript
function get_upsTestMode();
function set_upsTestMode(value);

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSTrackingStatus Property

[image]

.NET Framework Class Library
UPSShip..::.UPSTrackingStatus Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSTrackingStatus As Integer
C#
public int UPSTrackingStatus { get; }
Visual C++
public:
property int UPSTrackingStatus {
    int get ();
}
JavaScript
function get_upsTrackingStatus();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSTrackingStatusDescription Property

[image]

.NET Framework Class Library
UPSShip..::.UPSTrackingStatusDescription Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSTrackingStatusDescription As String
C#
public string UPSTrackingStatusDescription { get; }
Visual C++
public:
property String^ UPSTrackingStatusDescription {
    String^ get ();
}
JavaScript
function get_upsTrackingStatusDescription();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSTrackingURL Property

[image]

.NET Framework Class Library
UPSShip..::.UPSTrackingURL Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UPSTrackingURL As String
C#
public string UPSTrackingURL { get; }
Visual C++
public:
property String^ UPSTrackingURL {
    String^ get ();
}
JavaScript
function get_upsTrackingURL();

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSUserName Property

[image]

.NET Framework Class Library
UPSShip..::.UPSUserName Property
UPSShip Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property UPSUserName As String
C#
public string UPSUserName { get; set; }
Visual C++
public:
property String^ UPSUserName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_upsUserName();
function set_upsUserName(value);

See Also

UPSShip Class
InSite.Library.Shipping Namespace


UPSShipAddress Class

[image]

.NET Framework Class Library
UPSShipAddress Class
Members See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Class UPSShipAddress
C#
public class UPSShipAddress
Visual C++
public ref class UPSShipAddress
JavaScript
InSite.Library.Shipping.UPSShipAddress = function();

Type.createClass(
    'InSite.Library.Shipping.UPSShipAddress');

Inheritance Hierarchy

System..::.Object
InSite.Library.Shipping..::.UPSShipAddress

See Also

UPSShipAddress Members
InSite.Library.Shipping Namespace


UPSShipAddress Members

[image] [image]

.NET Framework Class Library
UPSShipAddress Members
UPSShipAddress Class Constructors Methods Properties See Also Send Feedback

The UPSShipAddress type exposes the following members.

Constructors

Name | Description
UPSShipAddress | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ShipFromCity |
ShipFromCountryCode |
ShipFromPostalCode |
ShipFromStateProvinceCode |
ShipperCity |
ShipperCountryCode |
ShipperPostalCode |
ShipperStateProvinceCode |
ShipToCity |
ShipToCountryCode |
ShipToIsResidentialAddress |
ShipToPostalCode |
ShipToStateProvinceCode |

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


UPSShipAddress Constructor

[image] [image]

.NET Framework Class Library
UPSShipAddress Constructor
UPSShipAddress Class See Also Send Feedback

Overload List

Name | Description
UPSShipAddress()()() |
UPSShipAddress(String, String, String, String, String, String, String, String, String, String, String, String, Boolean) |
UPSShipAddress(String, String, String, String, String, String, String, String, Boolean) |

See Also

UPSShipAddress Class
UPSShipAddress Members
InSite.Library.Shipping Namespace


UPSShipAddress Constructor

[image]

.NET Framework Class Library
UPSShipAddress Constructor
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UPSShipAddress()
Visual C++
public:
UPSShipAddress()
JavaScript
InSite.Library.Shipping.UPSShipAddress = function();

See Also

UPSShipAddress Class
UPSShipAddress Overload
InSite.Library.Shipping Namespace


UPSShipAddress Constructor (String, String, String, String, String, String, String, String, String, String, String, String, Boolean)

[image]

.NET Framework Class Library
UPSShipAddress Constructor (String, String, String, String, String, String, String, String, String, String, String, String, Boolean)
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    shipperCity As String, _
    shipperStateProvinceCode As String, _
    shipperPostalCode As String, _
    shipperCountryCode As String, _
    shipFromCity As String, _
    shipFromStateProvinceCode As String, _
    shipFromPostalCode As String, _
    shipFromCountryCode As String, _
    shipToCity As String, _
    shipToStateProvinceCode As String, _
    shipToPostalCode As String, _
    shipToCountryCode As String, _
    shipToIsResidentialAddress As Boolean _
)
C#
public UPSShipAddress(
    string shipperCity,
    string shipperStateProvinceCode,
    string shipperPostalCode,
    string shipperCountryCode,
    string shipFromCity,
    string shipFromStateProvinceCode,
    string shipFromPostalCode,
    string shipFromCountryCode,
    string shipToCity,
    string shipToStateProvinceCode,
    string shipToPostalCode,
    string shipToCountryCode,
    bool shipToIsResidentialAddress
)
Visual C++
public:
UPSShipAddress(
    String^ shipperCity,
    String^ shipperStateProvinceCode,
    String^ shipperPostalCode,
    String^ shipperCountryCode,
    String^ shipFromCity,
    String^ shipFromStateProvinceCode,
    String^ shipFromPostalCode,
    String^ shipFromCountryCode,
    String^ shipToCity,
    String^ shipToStateProvinceCode,
    String^ shipToPostalCode,
    String^ shipToCountryCode,
    bool shipToIsResidentialAddress
)
JavaScript
InSite.Library.Shipping.UPSShipAddress = function(shipperCity, shipperStateProvinceCode, shipperPostalCode, shipperCountryCode, shipFromCity, shipFromStateProvinceCode, shipFromPostalCode, shipFromCountryCode, shipToCity, shipToStateProvinceCode, shipToPostalCode, shipToCountryCode, shipToIsResidentialAddress);

Parameters

shipperCity
Type: System..::.String
shipperStateProvinceCode
Type: System..::.String
shipperPostalCode
Type: System..::.String
shipperCountryCode
Type: System..::.String
shipFromCity
Type: System..::.String
shipFromStateProvinceCode
Type: System..::.String
shipFromPostalCode
Type: System..::.String
shipFromCountryCode
Type: System..::.String
shipToCity
Type: System..::.String
shipToStateProvinceCode
Type: System..::.String
shipToPostalCode
Type: System..::.String
shipToCountryCode
Type: System..::.String
shipToIsResidentialAddress
Type: System..::.Boolean

See Also

UPSShipAddress Class
UPSShipAddress Overload
InSite.Library.Shipping Namespace


UPSShipAddress Constructor (String, String, String, String, String, String, String, String, Boolean)

[image]

.NET Framework Class Library
UPSShipAddress Constructor (String, String, String, String, String, String, String, String, Boolean)
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    shipperCity As String, _
    shipperStateProvinceCode As String, _
    shipperPostalCode As String, _
    shipperCountryCode As String, _
    shipToCity As String, _
    shipToStateProvinceCode As String, _
    shipToPostalCode As String, _
    shipToCountryCode As String, _
    shipToIsResidentialAddress As Boolean _
)
C#
public UPSShipAddress(
    string shipperCity,
    string shipperStateProvinceCode,
    string shipperPostalCode,
    string shipperCountryCode,
    string shipToCity,
    string shipToStateProvinceCode,
    string shipToPostalCode,
    string shipToCountryCode,
    bool shipToIsResidentialAddress
)
Visual C++
public:
UPSShipAddress(
    String^ shipperCity,
    String^ shipperStateProvinceCode,
    String^ shipperPostalCode,
    String^ shipperCountryCode,
    String^ shipToCity,
    String^ shipToStateProvinceCode,
    String^ shipToPostalCode,
    String^ shipToCountryCode,
    bool shipToIsResidentialAddress
)
JavaScript
InSite.Library.Shipping.UPSShipAddress = function(shipperCity, shipperStateProvinceCode, shipperPostalCode, shipperCountryCode, shipToCity, shipToStateProvinceCode, shipToPostalCode, shipToCountryCode, shipToIsResidentialAddress);

Parameters

shipperCity
Type: System..::.String
shipperStateProvinceCode
Type: System..::.String
shipperPostalCode
Type: System..::.String
shipperCountryCode
Type: System..::.String
shipToCity
Type: System..::.String
shipToStateProvinceCode
Type: System..::.String
shipToPostalCode
Type: System..::.String
shipToCountryCode
Type: System..::.String
shipToIsResidentialAddress
Type: System..::.Boolean

See Also

UPSShipAddress Class
UPSShipAddress Overload
InSite.Library.Shipping Namespace


UPSShipAddress Methods

[image] [image]

.NET Framework Class Library
UPSShipAddress Methods
UPSShipAddress Class See Also Send Feedback

The UPSShipAddress type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


UPSShipAddress Properties

[image] [image]

.NET Framework Class Library
UPSShipAddress Properties
UPSShipAddress Class See Also Send Feedback

The UPSShipAddress type exposes the following members.

Properties

Name | Description
ShipFromCity |
ShipFromCountryCode |
ShipFromPostalCode |
ShipFromStateProvinceCode |
ShipperCity |
ShipperCountryCode |
ShipperPostalCode |
ShipperStateProvinceCode |
ShipToCity |
ShipToCountryCode |
ShipToIsResidentialAddress |
ShipToPostalCode |
ShipToStateProvinceCode |

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipFromCity Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipFromCity Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipFromCity As String
C#
public string ShipFromCity { get; set; }
Visual C++
public:
property String^ ShipFromCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromCity();
function set_shipFromCity(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipFromCountryCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipFromCountryCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipFromCountryCode As String
C#
public string ShipFromCountryCode { get; set; }
Visual C++
public:
property String^ ShipFromCountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromCountryCode();
function set_shipFromCountryCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipFromPostalCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipFromPostalCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipFromPostalCode As String
C#
public string ShipFromPostalCode { get; set; }
Visual C++
public:
property String^ ShipFromPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromPostalCode();
function set_shipFromPostalCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipFromStateProvinceCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipFromStateProvinceCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipFromStateProvinceCode As String
C#
public string ShipFromStateProvinceCode { get; set; }
Visual C++
public:
property String^ ShipFromStateProvinceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipFromStateProvinceCode();
function set_shipFromStateProvinceCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipperCity Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipperCity Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipperCity As String
C#
public string ShipperCity { get; set; }
Visual C++
public:
property String^ ShipperCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipperCity();
function set_shipperCity(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipperCountryCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipperCountryCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipperCountryCode As String
C#
public string ShipperCountryCode { get; set; }
Visual C++
public:
property String^ ShipperCountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipperCountryCode();
function set_shipperCountryCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipperPostalCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipperPostalCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipperPostalCode As String
C#
public string ShipperPostalCode { get; set; }
Visual C++
public:
property String^ ShipperPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipperPostalCode();
function set_shipperPostalCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipperStateProvinceCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipperStateProvinceCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipperStateProvinceCode As String
C#
public string ShipperStateProvinceCode { get; set; }
Visual C++
public:
property String^ ShipperStateProvinceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipperStateProvinceCode();
function set_shipperStateProvinceCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipToCity Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToCity Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToCity As String
C#
public string ShipToCity { get; set; }
Visual C++
public:
property String^ ShipToCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCity();
function set_shipToCity(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipToCountryCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToCountryCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToCountryCode As String
C#
public string ShipToCountryCode { get; set; }
Visual C++
public:
property String^ ShipToCountryCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToCountryCode();
function set_shipToCountryCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipToIsResidentialAddress Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToIsResidentialAddress Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToIsResidentialAddress As Boolean
C#
public bool ShipToIsResidentialAddress { get; set; }
Visual C++
public:
property bool ShipToIsResidentialAddress {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shipToIsResidentialAddress();
function set_shipToIsResidentialAddress(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipToPostalCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToPostalCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToPostalCode As String
C#
public string ShipToPostalCode { get; set; }
Visual C++
public:
property String^ ShipToPostalCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToPostalCode();
function set_shipToPostalCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


ShipToStateProvinceCode Property

[image]

.NET Framework Class Library
UPSShipAddress..::.ShipToStateProvinceCode Property
UPSShipAddress Class See Also Send Feedback

Namespace: InSite.Library.Shipping
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Property ShipToStateProvinceCode As String
C#
public string ShipToStateProvinceCode { get; set; }
Visual C++
public:
property String^ ShipToStateProvinceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipToStateProvinceCode();
function set_shipToStateProvinceCode(value);

See Also

UPSShipAddress Class
InSite.Library.Shipping Namespace


InSite.Model Namespace

[image]

.NET Framework Class Library
InSite.Model Namespace
Send Feedback

Classes

Class | Description
Affiliate |
ApplicationDictionary |
ApplicationLog |
ApplicationMessage |
ApplicationSetting |
Audit |
Carrier |
CarrierPackage |
CarrierZone |
CarrierZoneRate |
CarrierZoneZipCodeRange |
Category |
CategoryFilterSection |
CategoryProperty |
ChildList<(Of <(T>)>) |
City |
Company |
Content |
ContentManager |
Country |
County |
CreditCard |
CreditCardPayPal | CreditCard_PayPal is a dummy credit card, in the sense that it has no name/number/expiration date, etc. The class has been created as dreived from CreditCard in order to allow it to pass throgh the code. If we were starting from scratch we may have come up with a "PaymentMethod" class from which "CreditCard" and "PayPal" are derived.
CreditCardTransaction |
Customer |
CustomerDiscount |
CustomerOrder |
CustomerOrderProperty |
CustomerProduct |
CustomerProductSet |
CustomerProperty |
DataStoreSingleton |
Dealer |
DealerProperty |
DictionaryAttribute |
DictionaryLabel |
DisplayType |
Document |
DocumentManager |
EmailList |
EmailTemplate |
FilterSection |
FilterValue |
GiftCard |
GiftCardTransaction |
HtmlRedirect |
InventoryTransaction |
Invoice |
InvoiceLine |
License | The class representing a license
LicenseCountException | The exception class thrown when the license count is not sufficient.
LicenseExpiredException | The exception class thrown when the license has expired
Licensing | The Licensing class has just one public (static) function, that checks for the availability of a license.
LoadForSOA |
LocalTaxRate |
Menu |
ModelBase<(Of <(T>)>) |
NewsArticle |
ObjectState |
OrderLine |
OrderLineAttribute |
PackageLine |
PaymentTerm |
PriceCalculator_Generic | PriceCalculator_Generic - the Generic or Standard Price Calculator
PriceMatrix |
Product |
ProductInfo | A Simplified view of the Product Object
ProductProperty |
Promotion |
PromotionCode |
PromotionProcessor |
PromotionResult |
PromotionResultAddFreeProduct |
PromotionResultAddFreeProductFromCategory |
PromotionResultDiscountProductsInCategory |
PromotionResultDiscountProductsOfVendor |
PromotionResultDollarOffOrder |
PromotionResultDollarOffProduct |
PromotionResultDollarOffShipping |
PromotionResultPercentOffOrder |
PromotionResultPercentOffProduct |
PromotionResultPercentOffShipping |
PromotionResultSetOrderedProductToAmount |
PromotionResultSetOrderedProductToFree |
PromotionRule |
PromotionRuleCustomerMaximumTimesPromotionAllowed |
PromotionRuleExcludesCustomer |
PromotionRuleExcludesUserRole |
PromotionRuleIncludesCustomer |
PromotionRuleIncludesUserRole |
PromotionRuleMaximumPromotionUsedQuanity |
PromotionRuleOrderContainsOrderedProduct |
PromotionRuleOrderContainsOrderedProductInCategory |
PromotionRuleOrderContainsOrderedProductOfVendor |
PromotionRuleOrderContainsPromotion |
PromotionRuleOrderDoesNotContainPromotion |
PromotionRuleOrderNotShippingToCountry |
PromotionRuleOrderNotShippingToState |
PromotionRuleOrderProductTotalGreaterThan |
PromotionRuleOrderProductTotalIsInRange |
PromotionRuleOrderShippingToCountry |
PromotionRuleOrderShippingToState |
PromotionRuleOrderShipViaMatches |
PromotionRuleValidPromotionCode |
Restriction |
Review |
Role |
RuleValidator |
Salesman |
SaveChildren |
ScheduledTask |
SearchField |
ShipCharge |
Shipment |
ShipmentPackage |
ShippingClassification |
ShipRate |
ShipRule |
ShipRuleCustomerIsCustomerType |
ShipRuleCustomerIsNotCustomerType |
ShipRuleOrderAtLeastOneProductInCategory |
ShipRuleOrderDoesNotHaveTermsCode |
ShipRuleOrderHasTermsCode |
ShipRuleOrderNotShippingToCountry |
ShipRuleOrderNotShippingToState |
ShipRuleOrderNotShippingToZipCode |
ShipRuleOrderProductsNotInCategory |
ShipRuleOrderProductsOnlyInCategory |
ShipRuleOrderShipDateIsDayOfWeek |
ShipRuleOrderShipDateIsDayOfWeekOrNull |
ShipRuleOrderShipDateIsNotDayOfWeek |
ShipRuleOrderShippingToCountry |
ShipRuleOrderShippingToState |
ShipRuleOrderShippingToZipCode |
ShipRuleOrderSubTotalDoesExceedMinimum |
ShipRuleOrderSubTotalDoesNotExceedMaximum |
ShipRuleOrderSubTotalInRange |
ShipVia |
SOAFilterObject |
SOAFilterOperator |
SOAFilterProperty |
SOAResult |
SOAResultStatus |
SortField |
Specification |
State |
StyleClass |
StyleTrait |
StyleTraitValue |
Subscription |
SubscriptionLine |
SubscriptionProduct |
TaxCalculator_Generic |
TaxExemption |
UserProfile |
UserProfileProperty |
Vendor |
WebPage |
WebPageContent |
WebSite |
WebSiteConfiguration |
WebSiteInfo | A simplified view of the WebSite Object
WishList |
WishListProduct |

Interfaces

Interface | Description
IBuildEmailValues |
ICustomerOrderProcessor |
IDataController |
IEmailProcessor |
IOrderPackager |
IPackage |
IPaymentGateway |
IPriceCalculator | IPriceCalculator - Interface for the Price Calculator
IPromotionEngine |
IRule |
IShippingCost |
IShippingEngine |
ITaxCalculator |
IValidatable |

Enumerations

Enumeration | Description
FlushModeEnum |
LicenseStatus | An enum of the possible license statuses. Needs to be compatible with a similar enum in InSite.LicenseService.
SearchMode |


Affiliate Class

[image]

.NET Framework Class Library
Affiliate Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Affiliate _
    Inherits ModelBase(Of Affiliate)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Affiliate : ModelBase<Affiliate>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Affiliate : public ModelBase<Affiliate^>
JavaScript
InSite.Model.Affiliate = function();

Type.createClass(
    'InSite.Model.Affiliate',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Affiliate>)>)
InSite.Model..::.Affiliate

See Also

Affiliate Members
InSite.Model Namespace


Affiliate Members

[image] [image]

.NET Framework Class Library
Affiliate Members
Affiliate Class Constructors Methods Fields Properties See Also Send Feedback

The Affiliate type exposes the following members.

Constructors

Name | Description
Affiliate | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
AffiliateId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Image |
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReplaceLogoImage |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Url |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Affiliate Class
InSite.Model Namespace


Affiliate Constructor

[image] [image]

.NET Framework Class Library
Affiliate Constructor
Affiliate Class See Also Send Feedback

Overload List

Name | Description
Affiliate()()() |
Affiliate(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Affiliate Class
Affiliate Members
InSite.Model Namespace


Affiliate Constructor

[image]

.NET Framework Class Library
Affiliate Constructor
Affiliate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Affiliate()
Visual C++
public:
Affiliate()
JavaScript
InSite.Model.Affiliate = function();

See Also

Affiliate Class
Affiliate Overload
InSite.Model Namespace


Affiliate Constructor (SearchMode)

[image]

.NET Framework Class Library
Affiliate Constructor (SearchMode)
Affiliate Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Affiliate(
    SearchMode searchMode
)
Visual C++
public:
Affiliate(
    SearchMode searchMode
)
JavaScript
InSite.Model.Affiliate = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Affiliate Class
Affiliate Overload
InSite.Model Namespace


Affiliate Fields

[image] [image]

.NET Framework Class Library
Affiliate Fields
Affiliate Class See Also Send Feedback

The Affiliate type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Affiliate Class
InSite.Model Namespace


Affiliate Methods

[image] [image]

.NET Framework Class Library
Affiliate Methods
Affiliate Class See Also Send Feedback

The Affiliate type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Affiliate Class
InSite.Model Namespace


Affiliate Properties

[image] [image]

.NET Framework Class Library
Affiliate Properties
Affiliate Class See Also Send Feedback

The Affiliate type exposes the following members.

Properties

Name | Description
AffiliateId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Image |
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReplaceLogoImage |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Url |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Affiliate Class
InSite.Model Namespace


AffiliateId Property

[image]

.NET Framework Class Library
Affiliate..::.AffiliateId Property
Affiliate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property AffiliateId As Guid
C#
public virtual Guid AffiliateId { get; set; }
Visual C++
public:
virtual property Guid AffiliateId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_affiliateId();
function set_affiliateId(value);

See Also

Affiliate Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Affiliate..::.Description Property
Affiliate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Affiliate Class
InSite.Model Namespace


Image Property

[image]

.NET Framework Class Library
Affiliate..::.Image Property
Affiliate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Image As String
C#
[DataMemberAttribute]
public virtual string Image { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Image {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_image();
function set_image(value);

See Also

Affiliate Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
Affiliate..::.IsActive Property
Affiliate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

Affiliate Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Affiliate..::.Name Property
Affiliate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Affiliate Class
InSite.Model Namespace


ReplaceLogoImage Property

[image]

.NET Framework Class Library
Affiliate..::.ReplaceLogoImage Property
Affiliate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ReplaceLogoImage As Boolean
C#
[DataMemberAttribute]
public virtual bool ReplaceLogoImage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ReplaceLogoImage {
    bool get ();
    void set (bool value);
}
JavaScript
function get_replaceLogoImage();
function set_replaceLogoImage(value);

See Also

Affiliate Class
InSite.Model Namespace


Url Property

[image]

.NET Framework Class Library
Affiliate..::.Url Property
Affiliate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Url As String
C#
[DataMemberAttribute]
public virtual string Url { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Url {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_url();
function set_url(value);

See Also

Affiliate Class
InSite.Model Namespace


ApplicationDictionary Class

[image]

.NET Framework Class Library
ApplicationDictionary Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ApplicationDictionary _
    Inherits ModelBase(Of ApplicationDictionary)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ApplicationDictionary : ModelBase<ApplicationDictionary>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ApplicationDictionary : public ModelBase<ApplicationDictionary^>
JavaScript
InSite.Model.ApplicationDictionary = function();

Type.createClass(
    'InSite.Model.ApplicationDictionary',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ApplicationDictionary>)>)
InSite.Model..::.ApplicationDictionary

See Also

ApplicationDictionary Members
InSite.Model Namespace


ApplicationDictionary Members

[image] [image]

.NET Framework Class Library
ApplicationDictionary Members
ApplicationDictionary Class Constructors Methods Fields Properties See Also Send Feedback

The ApplicationDictionary type exposes the following members.

Constructors

Name | Description
ApplicationDictionary | Overloaded.

Methods

Name | Description
AddDictionaryAttribute |
AddDictionaryLabel |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetDictionaryAttribute |
GetDictionaryLabel |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetListForObject |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImportChildrenXLS |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveDictionaryAttribute |
RemoveDictionaryLabel |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ApplicationDictionaryId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
DictionaryAttributes |
DictionaryLabels |
FieldName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectName |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RequiredForExport | Determines if this property is required to be exported when children of this object are exported as the human readable parent identifier
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationDictionary Class
InSite.Model Namespace


ApplicationDictionary Constructor

[image] [image]

.NET Framework Class Library
ApplicationDictionary Constructor
ApplicationDictionary Class See Also Send Feedback

Overload List

Name | Description
ApplicationDictionary()()() |
ApplicationDictionary(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ApplicationDictionary Class
ApplicationDictionary Members
InSite.Model Namespace


ApplicationDictionary Constructor

[image]

.NET Framework Class Library
ApplicationDictionary Constructor
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ApplicationDictionary()
Visual C++
public:
ApplicationDictionary()
JavaScript
InSite.Model.ApplicationDictionary = function();

See Also

ApplicationDictionary Class
ApplicationDictionary Overload
InSite.Model Namespace


ApplicationDictionary Constructor (SearchMode)

[image]

.NET Framework Class Library
ApplicationDictionary Constructor (SearchMode)
ApplicationDictionary Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ApplicationDictionary(
    SearchMode searchMode
)
Visual C++
public:
ApplicationDictionary(
    SearchMode searchMode
)
JavaScript
InSite.Model.ApplicationDictionary = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ApplicationDictionary Class
ApplicationDictionary Overload
InSite.Model Namespace


ApplicationDictionary Fields

[image] [image]

.NET Framework Class Library
ApplicationDictionary Fields
ApplicationDictionary Class See Also Send Feedback

The ApplicationDictionary type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationDictionary Class
InSite.Model Namespace


ApplicationDictionary Methods

[image] [image]

.NET Framework Class Library
ApplicationDictionary Methods
ApplicationDictionary Class See Also Send Feedback

The ApplicationDictionary type exposes the following members.

Methods

Name | Description
AddDictionaryAttribute |
AddDictionaryLabel |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetDictionaryAttribute |
GetDictionaryLabel |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetListForObject |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImportChildrenXLS |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveDictionaryAttribute |
RemoveDictionaryLabel |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationDictionary Class
InSite.Model Namespace


AddDictionaryAttribute Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.AddDictionaryAttribute Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddDictionaryAttribute ( _
    value As DictionaryAttribute _
)
C#
public virtual void AddDictionaryAttribute(
    DictionaryAttribute value
)
Visual C++
public:
virtual void AddDictionaryAttribute(
    DictionaryAttribute^ value
)
JavaScript
function addDictionaryAttribute(value);

Parameters

value
Type: InSite.Model..::.DictionaryAttribute

See Also

ApplicationDictionary Class
InSite.Model Namespace


AddDictionaryLabel Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.AddDictionaryLabel Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddDictionaryLabel ( _
    value As DictionaryLabel _
)
C#
public virtual void AddDictionaryLabel(
    DictionaryLabel value
)
Visual C++
public:
virtual void AddDictionaryLabel(
    DictionaryLabel^ value
)
JavaScript
function addDictionaryLabel(value);

Parameters

value
Type: InSite.Model..::.DictionaryLabel

See Also

ApplicationDictionary Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.GetByName Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    objectName As String, _
    fieldName As String _
) As ApplicationDictionary
C#
public static ApplicationDictionary GetByName(
    string objectName,
    string fieldName
)
Visual C++
public:
static ApplicationDictionary^ GetByName(
    String^ objectName,
    String^ fieldName
)
JavaScript
InSite.Model.ApplicationDictionary.getByName = function(objectName, fieldName);

Parameters

objectName
Type: System..::.String
fieldName
Type: System..::.String

See Also

ApplicationDictionary Class
InSite.Model Namespace


GetDictionaryAttribute Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.GetDictionaryAttribute Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDictionaryAttribute ( _
    roleName As String _
) As DictionaryAttribute
C#
public virtual DictionaryAttribute GetDictionaryAttribute(
    string roleName
)
Visual C++
public:
virtual DictionaryAttribute^ GetDictionaryAttribute(
    String^ roleName
)
JavaScript
function getDictionaryAttribute(roleName);

Parameters

roleName
Type: System..::.String

See Also

ApplicationDictionary Class
InSite.Model Namespace


GetDictionaryLabel Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.GetDictionaryLabel Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDictionaryLabel ( _
    languageCode As String _
) As DictionaryLabel
C#
public virtual DictionaryLabel GetDictionaryLabel(
    string languageCode
)
Visual C++
public:
virtual DictionaryLabel^ GetDictionaryLabel(
    String^ languageCode
)
JavaScript
function getDictionaryLabel(languageCode);

Parameters

languageCode
Type: System..::.String

See Also

ApplicationDictionary Class
InSite.Model Namespace


GetListForObject Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.GetListForObject Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetListForObject ( _
    objectName As String _
) As IList(Of ApplicationDictionary)
C#
public static IList<ApplicationDictionary> GetListForObject(
    string objectName
)
Visual C++
public:
static IList<ApplicationDictionary^>^ GetListForObject(
    String^ objectName
)
JavaScript
InSite.Model.ApplicationDictionary.getListForObject = function(objectName);

Parameters

objectName
Type: System..::.String

See Also

ApplicationDictionary Class
InSite.Model Namespace


ImportChildrenXLS Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.ImportChildrenXLS Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ImportChildrenXLS ( _
    row As DataRow _
)
C#
public virtual void ImportChildrenXLS(
    DataRow row
)
Visual C++
public:
virtual void ImportChildrenXLS(
    DataRow^ row
)
JavaScript
function importChildrenXLS(row);

Parameters

row
Type: System.Data..::.DataRow

See Also

ApplicationDictionary Class
InSite.Model Namespace


RemoveDictionaryAttribute Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.RemoveDictionaryAttribute Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveDictionaryAttribute ( _
    value As DictionaryAttribute _
)
C#
public virtual void RemoveDictionaryAttribute(
    DictionaryAttribute value
)
Visual C++
public:
virtual void RemoveDictionaryAttribute(
    DictionaryAttribute^ value
)
JavaScript
function removeDictionaryAttribute(value);

Parameters

value
Type: InSite.Model..::.DictionaryAttribute

See Also

ApplicationDictionary Class
InSite.Model Namespace


RemoveDictionaryLabel Method

[image]

.NET Framework Class Library
ApplicationDictionary..::.RemoveDictionaryLabel Method
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveDictionaryLabel ( _
    value As DictionaryLabel _
)
C#
public virtual void RemoveDictionaryLabel(
    DictionaryLabel value
)
Visual C++
public:
virtual void RemoveDictionaryLabel(
    DictionaryLabel^ value
)
JavaScript
function removeDictionaryLabel(value);

Parameters

value
Type: InSite.Model..::.DictionaryLabel

See Also

ApplicationDictionary Class
InSite.Model Namespace


ApplicationDictionary Properties

[image] [image]

.NET Framework Class Library
ApplicationDictionary Properties
ApplicationDictionary Class See Also Send Feedback

The ApplicationDictionary type exposes the following members.

Properties

Name | Description
ApplicationDictionaryId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
DictionaryAttributes |
DictionaryLabels |
FieldName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectName |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RequiredForExport | Determines if this property is required to be exported when children of this object are exported as the human readable parent identifier
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationDictionary Class
InSite.Model Namespace


ApplicationDictionaryId Property

[image]

.NET Framework Class Library
ApplicationDictionary..::.ApplicationDictionaryId Property
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ApplicationDictionaryId As Guid
C#
public virtual Guid ApplicationDictionaryId { get; set; }
Visual C++
public:
virtual property Guid ApplicationDictionaryId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_applicationDictionaryId();
function set_applicationDictionaryId(value);

See Also

ApplicationDictionary Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
ApplicationDictionary..::.Description Property
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

ApplicationDictionary Class
InSite.Model Namespace


DictionaryAttributes Property

[image]

.NET Framework Class Library
ApplicationDictionary..::.DictionaryAttributes Property
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DictionaryAttributes As ChildList(Of DictionaryAttribute)
C#
[DataMemberAttribute]
public virtual ChildList<DictionaryAttribute> DictionaryAttributes { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<DictionaryAttribute^>^ DictionaryAttributes {
    ChildList<DictionaryAttribute^>^ get ();
    void set (ChildList<DictionaryAttribute^>^ value);
}
JavaScript
function get_dictionaryAttributes();
function set_dictionaryAttributes(value);

See Also

ApplicationDictionary Class
InSite.Model Namespace


DictionaryLabels Property

[image]

.NET Framework Class Library
ApplicationDictionary..::.DictionaryLabels Property
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DictionaryLabels As ChildList(Of DictionaryLabel)
C#
[DataMemberAttribute]
public virtual ChildList<DictionaryLabel> DictionaryLabels { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<DictionaryLabel^>^ DictionaryLabels {
    ChildList<DictionaryLabel^>^ get ();
    void set (ChildList<DictionaryLabel^>^ value);
}
JavaScript
function get_dictionaryLabels();
function set_dictionaryLabels(value);

See Also

ApplicationDictionary Class
InSite.Model Namespace


FieldName Property

[image]

.NET Framework Class Library
ApplicationDictionary..::.FieldName Property
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FieldName As String
C#
[DataMemberAttribute]
public virtual string FieldName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ FieldName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fieldName();
function set_fieldName(value);

See Also

ApplicationDictionary Class
InSite.Model Namespace


ObjectName Property

[image]

.NET Framework Class Library
ApplicationDictionary..::.ObjectName Property
ApplicationDictionary Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ObjectName As String
C#
[DataMemberAttribute]
public virtual string ObjectName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_objectName();
function set_objectName(value);

See Also

ApplicationDictionary Class
InSite.Model Namespace


RequiredForExport Property

[image]

.NET Framework Class Library
ApplicationDictionary..::.RequiredForExport Property
ApplicationDictionary Class See Also Send Feedback

Determines if this property is required to be exported when children of this object are exported as the human readable parent identifier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RequiredForExport As Boolean
C#
[DataMemberAttribute]
public virtual bool RequiredForExport { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool RequiredForExport {
    bool get ();
    void set (bool value);
}
JavaScript
function get_requiredForExport();
function set_requiredForExport(value);

See Also

ApplicationDictionary Class
InSite.Model Namespace


ApplicationLog Class

[image]

.NET Framework Class Library
ApplicationLog Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ApplicationLog _
    Inherits ModelBase(Of ApplicationLog)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ApplicationLog : ModelBase<ApplicationLog>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ApplicationLog : public ModelBase<ApplicationLog^>
JavaScript
InSite.Model.ApplicationLog = function();

Type.createClass(
    'InSite.Model.ApplicationLog',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ApplicationLog>)>)
InSite.Model..::.ApplicationLog

See Also

ApplicationLog Members
InSite.Model Namespace


ApplicationLog Members

[image] [image]

.NET Framework Class Library
ApplicationLog Members
ApplicationLog Class Constructors Methods Fields Properties See Also Send Feedback

The ApplicationLog type exposes the following members.

Constructors

Name | Description
ApplicationLog | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DebugMessage | Overloaded.
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetNextBatchNumber |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LogError | Overloaded.
LogInfo |
LogMessage | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
DebugType |
ErrorType |
InformationType |
SecurityType |

Properties

Name | Description
ApplicationLogId |
BatchNumber |
Browser |
BrowserPlatform |
BrowserType |
BrowserVersion |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CleanedMessage |
ClientIP |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExceptionPage |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LinkedFromPage |
LogDate |
Message |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Sequence |
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortMessage |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Source |
Type |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationLog Class
InSite.Model Namespace


ApplicationLog Constructor

[image] [image]

.NET Framework Class Library
ApplicationLog Constructor
ApplicationLog Class See Also Send Feedback

Overload List

Name | Description
ApplicationLog()()() |
ApplicationLog(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ApplicationLog Class
ApplicationLog Members
InSite.Model Namespace


ApplicationLog Constructor

[image]

.NET Framework Class Library
ApplicationLog Constructor
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ApplicationLog()
Visual C++
public:
ApplicationLog()
JavaScript
InSite.Model.ApplicationLog = function();

See Also

ApplicationLog Class
ApplicationLog Overload
InSite.Model Namespace


ApplicationLog Constructor (SearchMode)

[image]

.NET Framework Class Library
ApplicationLog Constructor (SearchMode)
ApplicationLog Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ApplicationLog(
    SearchMode searchMode
)
Visual C++
public:
ApplicationLog(
    SearchMode searchMode
)
JavaScript
InSite.Model.ApplicationLog = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ApplicationLog Class
ApplicationLog Overload
InSite.Model Namespace


ApplicationLog Fields

[image] [image]

.NET Framework Class Library
ApplicationLog Fields
ApplicationLog Class See Also Send Feedback

The ApplicationLog type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
DebugType |
ErrorType |
InformationType |
SecurityType |

See Also

ApplicationLog Class
InSite.Model Namespace


DebugType Field

[image]

.NET Framework Class Library
ApplicationLog..::.DebugType Field
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared DebugType As String
C#
public static string DebugType
Visual C++
public:
static String^ DebugType
JavaScript
InSite.Model.ApplicationLog.debugType

See Also

ApplicationLog Class
InSite.Model Namespace


ErrorType Field

[image]

.NET Framework Class Library
ApplicationLog..::.ErrorType Field
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ErrorType As String
C#
public static string ErrorType
Visual C++
public:
static String^ ErrorType
JavaScript
InSite.Model.ApplicationLog.errorType

See Also

ApplicationLog Class
InSite.Model Namespace


InformationType Field

[image]

.NET Framework Class Library
ApplicationLog..::.InformationType Field
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared InformationType As String
C#
public static string InformationType
Visual C++
public:
static String^ InformationType
JavaScript
InSite.Model.ApplicationLog.informationType

See Also

ApplicationLog Class
InSite.Model Namespace


SecurityType Field

[image]

.NET Framework Class Library
ApplicationLog..::.SecurityType Field
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared SecurityType As String
C#
public static string SecurityType
Visual C++
public:
static String^ SecurityType
JavaScript
InSite.Model.ApplicationLog.securityType

See Also

ApplicationLog Class
InSite.Model Namespace


ApplicationLog Methods

[image] [image]

.NET Framework Class Library
ApplicationLog Methods
ApplicationLog Class See Also Send Feedback

The ApplicationLog type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DebugMessage | Overloaded.
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetNextBatchNumber |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LogError | Overloaded.
LogInfo |
LogMessage | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationLog Class
InSite.Model Namespace


DebugMessage Method

[image] [image]

.NET Framework Class Library
ApplicationLog..::.DebugMessage Method
ApplicationLog Class See Also Send Feedback

Overload List

Name | Description
DebugMessage(String, String) |
DebugMessage(String, String, Int32) |

See Also

ApplicationLog Class
ApplicationLog Members
InSite.Model Namespace


DebugMessage Method (String, String)

[image]

.NET Framework Class Library
ApplicationLog..::.DebugMessage Method (String, String)
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DebugMessage ( _
    source As String, _
    message As String _
)
C#
public static void DebugMessage(
    string source,
    string message
)
Visual C++
public:
static void DebugMessage(
    String^ source,
    String^ message
)
JavaScript
InSite.Model.ApplicationLog.debugMessage = function(source, message);

Parameters

source
Type: System..::.String
message
Type: System..::.String

See Also

ApplicationLog Class
DebugMessage Overload
InSite.Model Namespace


DebugMessage Method (String, String, Int32)

[image]

.NET Framework Class Library
ApplicationLog..::.DebugMessage Method (String, String, Int32)
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub DebugMessage ( _
    source As String, _
    message As String, _
    batchNumber As Integer _
)
C#
public static void DebugMessage(
    string source,
    string message,
    int batchNumber
)
Visual C++
public:
static void DebugMessage(
    String^ source,
    String^ message,
    int batchNumber
)
JavaScript
InSite.Model.ApplicationLog.debugMessage = function(source, message, batchNumber);

Parameters

source
Type: System..::.String
message
Type: System..::.String
batchNumber
Type: System..::.Int32

See Also

ApplicationLog Class
DebugMessage Overload
InSite.Model Namespace


GetNextBatchNumber Method

[image]

.NET Framework Class Library
ApplicationLog..::.GetNextBatchNumber Method
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNextBatchNumber As Integer
C#
public static int GetNextBatchNumber()
Visual C++
public:
static int GetNextBatchNumber()
JavaScript
InSite.Model.ApplicationLog.getNextBatchNumber = function();

See Also

ApplicationLog Class
InSite.Model Namespace


LogError Method

[image] [image]

.NET Framework Class Library
ApplicationLog..::.LogError Method
ApplicationLog Class See Also Send Feedback

Overload List

Name | Description
LogError(String, Exception, Int32) |
LogError(String, String, Int32) |
LogError(String, Exception, String, Int32) |

See Also

ApplicationLog Class
ApplicationLog Members
InSite.Model Namespace


LogError Method (String, Exception, Int32)

[image]

.NET Framework Class Library
ApplicationLog..::.LogError Method (String, Exception, Int32)
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogError ( _
    source As String, _
    ex As Exception, _
    batchNumber As Integer _
)
C#
public static void LogError(
    string source,
    Exception ex,
    int batchNumber
)
Visual C++
public:
static void LogError(
    String^ source,
    Exception^ ex,
    int batchNumber
)
JavaScript
InSite.Model.ApplicationLog.logError = function(source, ex, batchNumber);

Parameters

source
Type: System..::.String
ex
Type: System..::.Exception
batchNumber
Type: System..::.Int32

See Also

ApplicationLog Class
LogError Overload
InSite.Model Namespace


LogError Method (String, String, Int32)

[image]

.NET Framework Class Library
ApplicationLog..::.LogError Method (String, String, Int32)
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogError ( _
    source As String, _
    message As String, _
    batchNumber As Integer _
)
C#
public static void LogError(
    string source,
    string message,
    int batchNumber
)
Visual C++
public:
static void LogError(
    String^ source,
    String^ message,
    int batchNumber
)
JavaScript
InSite.Model.ApplicationLog.logError = function(source, message, batchNumber);

Parameters

source
Type: System..::.String
message
Type: System..::.String
batchNumber
Type: System..::.Int32

See Also

ApplicationLog Class
LogError Overload
InSite.Model Namespace


LogError Method (String, Exception, String, Int32)

[image]

.NET Framework Class Library
ApplicationLog..::.LogError Method (String, Exception, String, Int32)
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogError ( _
    source As String, _
    ex As Exception, _
    additionalInfo As String, _
    batchNumber As Integer _
)
C#
public static void LogError(
    string source,
    Exception ex,
    string additionalInfo,
    int batchNumber
)
Visual C++
public:
static void LogError(
    String^ source,
    Exception^ ex,
    String^ additionalInfo,
    int batchNumber
)
JavaScript
InSite.Model.ApplicationLog.logError = function(source, ex, additionalInfo, batchNumber);

Parameters

source
Type: System..::.String
ex
Type: System..::.Exception
additionalInfo
Type: System..::.String
batchNumber
Type: System..::.Int32

See Also

ApplicationLog Class
LogError Overload
InSite.Model Namespace


LogInfo Method

[image]

.NET Framework Class Library
ApplicationLog..::.LogInfo Method
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogInfo ( _
    source As String, _
    message As String, _
    batchNumber As Integer _
)
C#
public static void LogInfo(
    string source,
    string message,
    int batchNumber
)
Visual C++
public:
static void LogInfo(
    String^ source,
    String^ message,
    int batchNumber
)
JavaScript
InSite.Model.ApplicationLog.logInfo = function(source, message, batchNumber);

Parameters

source
Type: System..::.String
message
Type: System..::.String
batchNumber
Type: System..::.Int32

See Also

ApplicationLog Class
InSite.Model Namespace


LogMessage Method

[image] [image]

.NET Framework Class Library
ApplicationLog..::.LogMessage Method
ApplicationLog Class See Also Send Feedback

Overload List

Name | Description
LogMessage(String, String, String) |
LogMessage(String, String, String, Int32) |

See Also

ApplicationLog Class
ApplicationLog Members
InSite.Model Namespace


LogMessage Method (String, String, String)

[image]

.NET Framework Class Library
ApplicationLog..::.LogMessage Method (String, String, String)
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogMessage ( _
    source As String, _
    type As String, _
    message As String _
)
C#
public static void LogMessage(
    string source,
    string type,
    string message
)
Visual C++
public:
static void LogMessage(
    String^ source,
    String^ type,
    String^ message
)
JavaScript
InSite.Model.ApplicationLog.logMessage = function(source, type, message);

Parameters

source
Type: System..::.String
type
Type: System..::.String
message
Type: System..::.String

See Also

ApplicationLog Class
LogMessage Overload
InSite.Model Namespace


LogMessage Method (String, String, String, Int32)

[image]

.NET Framework Class Library
ApplicationLog..::.LogMessage Method (String, String, String, Int32)
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub LogMessage ( _
    source As String, _
    type As String, _
    message As String, _
    batchNumber As Integer _
)
C#
public static void LogMessage(
    string source,
    string type,
    string message,
    int batchNumber
)
Visual C++
public:
static void LogMessage(
    String^ source,
    String^ type,
    String^ message,
    int batchNumber
)
JavaScript
InSite.Model.ApplicationLog.logMessage = function(source, type, message, batchNumber);

Parameters

source
Type: System..::.String
type
Type: System..::.String
message
Type: System..::.String
batchNumber
Type: System..::.Int32

See Also

ApplicationLog Class
LogMessage Overload
InSite.Model Namespace


ApplicationLog Properties

[image] [image]

.NET Framework Class Library
ApplicationLog Properties
ApplicationLog Class See Also Send Feedback

The ApplicationLog type exposes the following members.

Properties

Name | Description
ApplicationLogId |
BatchNumber |
Browser |
BrowserPlatform |
BrowserType |
BrowserVersion |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CleanedMessage |
ClientIP |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExceptionPage |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LinkedFromPage |
LogDate |
Message |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Sequence |
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortMessage |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Source |
Type |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationLog Class
InSite.Model Namespace


ApplicationLogId Property

[image]

.NET Framework Class Library
ApplicationLog..::.ApplicationLogId Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ApplicationLogId As Guid
C#
public virtual Guid ApplicationLogId { get; set; }
Visual C++
public:
virtual property Guid ApplicationLogId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_applicationLogId();
function set_applicationLogId(value);

See Also

ApplicationLog Class
InSite.Model Namespace


BatchNumber Property

[image]

.NET Framework Class Library
ApplicationLog..::.BatchNumber Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property BatchNumber As Integer
C#
[SortField]
[DataMemberAttribute]
public virtual int BatchNumber { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property int BatchNumber {
    int get ();
    void set (int value);
}
JavaScript
function get_batchNumber();
function set_batchNumber(value);

See Also

ApplicationLog Class
InSite.Model Namespace


Browser Property

[image]

.NET Framework Class Library
ApplicationLog..::.Browser Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Browser As String
C#
public virtual string Browser { get; }
Visual C++
public:
virtual property String^ Browser {
    String^ get ();
}
JavaScript
function get_browser();

See Also

ApplicationLog Class
InSite.Model Namespace


BrowserPlatform Property

[image]

.NET Framework Class Library
ApplicationLog..::.BrowserPlatform Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BrowserPlatform As String
C#
public virtual string BrowserPlatform { get; }
Visual C++
public:
virtual property String^ BrowserPlatform {
    String^ get ();
}
JavaScript
function get_browserPlatform();

See Also

ApplicationLog Class
InSite.Model Namespace


BrowserType Property

[image]

.NET Framework Class Library
ApplicationLog..::.BrowserType Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BrowserType As String
C#
public virtual string BrowserType { get; }
Visual C++
public:
virtual property String^ BrowserType {
    String^ get ();
}
JavaScript
function get_browserType();

See Also

ApplicationLog Class
InSite.Model Namespace


BrowserVersion Property

[image]

.NET Framework Class Library
ApplicationLog..::.BrowserVersion Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BrowserVersion As String
C#
public virtual string BrowserVersion { get; }
Visual C++
public:
virtual property String^ BrowserVersion {
    String^ get ();
}
JavaScript
function get_browserVersion();

See Also

ApplicationLog Class
InSite.Model Namespace


CleanedMessage Property

[image]

.NET Framework Class Library
ApplicationLog..::.CleanedMessage Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CleanedMessage As String
C#
public virtual string CleanedMessage { get; }
Visual C++
public:
virtual property String^ CleanedMessage {
    String^ get ();
}
JavaScript
function get_cleanedMessage();

See Also

ApplicationLog Class
InSite.Model Namespace


ClientIP Property

[image]

.NET Framework Class Library
ApplicationLog..::.ClientIP Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ClientIP As String
C#
public virtual string ClientIP { get; }
Visual C++
public:
virtual property String^ ClientIP {
    String^ get ();
}
JavaScript
function get_clientIP();

See Also

ApplicationLog Class
InSite.Model Namespace


ExceptionPage Property

[image]

.NET Framework Class Library
ApplicationLog..::.ExceptionPage Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ExceptionPage As String
C#
public virtual string ExceptionPage { get; }
Visual C++
public:
virtual property String^ ExceptionPage {
    String^ get ();
}
JavaScript
function get_exceptionPage();

See Also

ApplicationLog Class
InSite.Model Namespace


LinkedFromPage Property

[image]

.NET Framework Class Library
ApplicationLog..::.LinkedFromPage Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LinkedFromPage As String
C#
public virtual string LinkedFromPage { get; }
Visual C++
public:
virtual property String^ LinkedFromPage {
    String^ get ();
}
JavaScript
function get_linkedFromPage();

See Also

ApplicationLog Class
InSite.Model Namespace


LogDate Property

[image]

.NET Framework Class Library
ApplicationLog..::.LogDate Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LogDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime LogDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime LogDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_logDate();
function set_logDate(value);

See Also

ApplicationLog Class
InSite.Model Namespace


Message Property

[image]

.NET Framework Class Library
ApplicationLog..::.Message Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Message As String
C#
public virtual string Message { get; set; }
Visual C++
public:
virtual property String^ Message {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_message();
function set_message(value);

See Also

ApplicationLog Class
InSite.Model Namespace


Sequence Property

[image]

.NET Framework Class Library
ApplicationLog..::.Sequence Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property Sequence As Integer
C#
[DataMemberAttribute]
public virtual int Sequence { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property int Sequence {
    int get ();
}
JavaScript
function get_sequence();

See Also

ApplicationLog Class
InSite.Model Namespace


ShortMessage Property

[image]

.NET Framework Class Library
ApplicationLog..::.ShortMessage Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShortMessage As String
C#
[DataMemberAttribute]
public virtual string ShortMessage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShortMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shortMessage();
function set_shortMessage(value);

See Also

ApplicationLog Class
InSite.Model Namespace


Source Property

[image]

.NET Framework Class Library
ApplicationLog..::.Source Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Source As String
C#
[DataMemberAttribute]
public virtual string Source { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Source {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_source();
function set_source(value);

See Also

ApplicationLog Class
InSite.Model Namespace


Type Property

[image]

.NET Framework Class Library
ApplicationLog..::.Type Property
ApplicationLog Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Type As String
C#
[DataMemberAttribute]
public virtual string Type { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

See Also

ApplicationLog Class
InSite.Model Namespace


ApplicationMessage Class

[image]

.NET Framework Class Library
ApplicationMessage Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ApplicationMessage _
    Inherits ModelBase(Of ApplicationMessage)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ApplicationMessage : ModelBase<ApplicationMessage>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ApplicationMessage : public ModelBase<ApplicationMessage^>
JavaScript
InSite.Model.ApplicationMessage = function();

Type.createClass(
    'InSite.Model.ApplicationMessage',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ApplicationMessage>)>)
InSite.Model..::.ApplicationMessage

See Also

ApplicationMessage Members
InSite.Model Namespace


ApplicationMessage Members

[image] [image]

.NET Framework Class Library
ApplicationMessage Members
ApplicationMessage Class Constructors Methods Fields Properties See Also Send Feedback

The ApplicationMessage type exposes the following members.

Constructors

Name | Description
ApplicationMessage | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName | Overloaded.
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ApplicationMessageId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
Message |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationMessage Class
InSite.Model Namespace


ApplicationMessage Constructor

[image] [image]

.NET Framework Class Library
ApplicationMessage Constructor
ApplicationMessage Class See Also Send Feedback

Overload List

Name | Description
ApplicationMessage()()() |
ApplicationMessage(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ApplicationMessage Class
ApplicationMessage Members
InSite.Model Namespace


ApplicationMessage Constructor

[image]

.NET Framework Class Library
ApplicationMessage Constructor
ApplicationMessage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ApplicationMessage()
Visual C++
public:
ApplicationMessage()
JavaScript
InSite.Model.ApplicationMessage = function();

See Also

ApplicationMessage Class
ApplicationMessage Overload
InSite.Model Namespace


ApplicationMessage Constructor (SearchMode)

[image]

.NET Framework Class Library
ApplicationMessage Constructor (SearchMode)
ApplicationMessage Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ApplicationMessage(
    SearchMode searchMode
)
Visual C++
public:
ApplicationMessage(
    SearchMode searchMode
)
JavaScript
InSite.Model.ApplicationMessage = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ApplicationMessage Class
ApplicationMessage Overload
InSite.Model Namespace


ApplicationMessage Fields

[image] [image]

.NET Framework Class Library
ApplicationMessage Fields
ApplicationMessage Class See Also Send Feedback

The ApplicationMessage type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationMessage Class
InSite.Model Namespace


ApplicationMessage Methods

[image] [image]

.NET Framework Class Library
ApplicationMessage Methods
ApplicationMessage Class See Also Send Feedback

The ApplicationMessage type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName | Overloaded.
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationMessage Class
InSite.Model Namespace


GetByName Method

[image] [image]

.NET Framework Class Library
ApplicationMessage..::.GetByName Method
ApplicationMessage Class See Also Send Feedback

Overload List

Name | Description
GetByName(String) |
GetByName(String, String) |

See Also

ApplicationMessage Class
ApplicationMessage Members
InSite.Model Namespace


GetByName Method (String)

[image]

.NET Framework Class Library
ApplicationMessage..::.GetByName Method (String)
ApplicationMessage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As ApplicationMessage
C#
public static ApplicationMessage GetByName(
    string name
)
Visual C++
public:
static ApplicationMessage^ GetByName(
    String^ name
)
JavaScript
InSite.Model.ApplicationMessage.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

ApplicationMessage Class
GetByName Overload
InSite.Model Namespace


GetByName Method (String, String)

[image]

.NET Framework Class Library
ApplicationMessage..::.GetByName Method (String, String)
ApplicationMessage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String, _
    defaultValue As String _
) As ApplicationMessage
C#
public static ApplicationMessage GetByName(
    string name,
    string defaultValue
)
Visual C++
public:
static ApplicationMessage^ GetByName(
    String^ name,
    String^ defaultValue
)
JavaScript
InSite.Model.ApplicationMessage.getByName = function(name, defaultValue);

Parameters

name
Type: System..::.String
defaultValue
Type: System..::.String

See Also

ApplicationMessage Class
GetByName Overload
InSite.Model Namespace


ApplicationMessage Properties

[image] [image]

.NET Framework Class Library
ApplicationMessage Properties
ApplicationMessage Class See Also Send Feedback

The ApplicationMessage type exposes the following members.

Properties

Name | Description
ApplicationMessageId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
Message |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationMessage Class
InSite.Model Namespace


ApplicationMessageId Property

[image]

.NET Framework Class Library
ApplicationMessage..::.ApplicationMessageId Property
ApplicationMessage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ApplicationMessageId As Guid
C#
public virtual Guid ApplicationMessageId { get; set; }
Visual C++
public:
virtual property Guid ApplicationMessageId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_applicationMessageId();
function set_applicationMessageId(value);

See Also

ApplicationMessage Class
InSite.Model Namespace


LanguageCode Property

[image]

.NET Framework Class Library
ApplicationMessage..::.LanguageCode Property
ApplicationMessage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LanguageCode As String
C#
[DataMemberAttribute]
public virtual string LanguageCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_languageCode();
function set_languageCode(value);

See Also

ApplicationMessage Class
InSite.Model Namespace


Message Property

[image]

.NET Framework Class Library
ApplicationMessage..::.Message Property
ApplicationMessage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Message As String
C#
[DataMemberAttribute]
public virtual string Message { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Message {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_message();
function set_message(value);

See Also

ApplicationMessage Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
ApplicationMessage..::.Name Property
ApplicationMessage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

ApplicationMessage Class
InSite.Model Namespace


ApplicationSetting Class

[image]

.NET Framework Class Library
ApplicationSetting Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ApplicationSetting _
    Inherits ModelBase(Of ApplicationSetting)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ApplicationSetting : ModelBase<ApplicationSetting>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ApplicationSetting : public ModelBase<ApplicationSetting^>
JavaScript
InSite.Model.ApplicationSetting = function();

Type.createClass(
    'InSite.Model.ApplicationSetting',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ApplicationSetting>)>)
InSite.Model..::.ApplicationSetting

See Also

ApplicationSetting Members
InSite.Model Namespace


ApplicationSetting Members

[image] [image]

.NET Framework Class Library
ApplicationSetting Members
ApplicationSetting Class Constructors Methods Fields Properties See Also Send Feedback

The ApplicationSetting type exposes the following members.

Constructors

Name | Description
ApplicationSetting | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName | Overloaded.
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ApplicationSettingId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationSetting Class
InSite.Model Namespace


ApplicationSetting Constructor

[image] [image]

.NET Framework Class Library
ApplicationSetting Constructor
ApplicationSetting Class See Also Send Feedback

Overload List

Name | Description
ApplicationSetting()()() |
ApplicationSetting(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ApplicationSetting Class
ApplicationSetting Members
InSite.Model Namespace


ApplicationSetting Constructor

[image]

.NET Framework Class Library
ApplicationSetting Constructor
ApplicationSetting Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ApplicationSetting()
Visual C++
public:
ApplicationSetting()
JavaScript
InSite.Model.ApplicationSetting = function();

See Also

ApplicationSetting Class
ApplicationSetting Overload
InSite.Model Namespace


ApplicationSetting Constructor (SearchMode)

[image]

.NET Framework Class Library
ApplicationSetting Constructor (SearchMode)
ApplicationSetting Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ApplicationSetting(
    SearchMode searchMode
)
Visual C++
public:
ApplicationSetting(
    SearchMode searchMode
)
JavaScript
InSite.Model.ApplicationSetting = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ApplicationSetting Class
ApplicationSetting Overload
InSite.Model Namespace


ApplicationSetting Fields

[image] [image]

.NET Framework Class Library
ApplicationSetting Fields
ApplicationSetting Class See Also Send Feedback

The ApplicationSetting type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationSetting Class
InSite.Model Namespace


ApplicationSetting Methods

[image] [image]

.NET Framework Class Library
ApplicationSetting Methods
ApplicationSetting Class See Also Send Feedback

The ApplicationSetting type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName | Overloaded.
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationSetting Class
InSite.Model Namespace


GetByName Method

[image] [image]

.NET Framework Class Library
ApplicationSetting..::.GetByName Method
ApplicationSetting Class See Also Send Feedback

Overload List

Name | Description
GetByName(String, String) |
GetByName(String, String, String) |

See Also

ApplicationSetting Class
ApplicationSetting Members
InSite.Model Namespace


GetByName Method (String, String)

[image]

.NET Framework Class Library
ApplicationSetting..::.GetByName Method (String, String)
ApplicationSetting Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String, _
    defaultValue As String _
) As ApplicationSetting
C#
public static ApplicationSetting GetByName(
    string name,
    string defaultValue
)
Visual C++
public:
static ApplicationSetting^ GetByName(
    String^ name,
    String^ defaultValue
)
JavaScript
InSite.Model.ApplicationSetting.getByName = function(name, defaultValue);

Parameters

name
Type: System..::.String
defaultValue
Type: System..::.String

See Also

ApplicationSetting Class
GetByName Overload
InSite.Model Namespace


GetByName Method (String, String, String)

[image]

.NET Framework Class Library
ApplicationSetting..::.GetByName Method (String, String, String)
ApplicationSetting Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String, _
    defaultValue As String, _
    defaultDescription As String _
) As ApplicationSetting
C#
public static ApplicationSetting GetByName(
    string name,
    string defaultValue,
    string defaultDescription
)
Visual C++
public:
static ApplicationSetting^ GetByName(
    String^ name,
    String^ defaultValue,
    String^ defaultDescription
)
JavaScript
InSite.Model.ApplicationSetting.getByName = function(name, defaultValue, defaultDescription);

Parameters

name
Type: System..::.String
defaultValue
Type: System..::.String
defaultDescription
Type: System..::.String

See Also

ApplicationSetting Class
GetByName Overload
InSite.Model Namespace


ApplicationSetting Properties

[image] [image]

.NET Framework Class Library
ApplicationSetting Properties
ApplicationSetting Class See Also Send Feedback

The ApplicationSetting type exposes the following members.

Properties

Name | Description
ApplicationSettingId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ApplicationSetting Class
InSite.Model Namespace


ApplicationSettingId Property

[image]

.NET Framework Class Library
ApplicationSetting..::.ApplicationSettingId Property
ApplicationSetting Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ApplicationSettingId As Guid
C#
public virtual Guid ApplicationSettingId { get; set; }
Visual C++
public:
virtual property Guid ApplicationSettingId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_applicationSettingId();
function set_applicationSettingId(value);

See Also

ApplicationSetting Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
ApplicationSetting..::.Description Property
ApplicationSetting Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

ApplicationSetting Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
ApplicationSetting..::.Name Property
ApplicationSetting Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

ApplicationSetting Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
ApplicationSetting..::.Value Property
ApplicationSetting Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

ApplicationSetting Class
InSite.Model Namespace


Audit Class

[image]

.NET Framework Class Library
Audit Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Audit _
    Inherits ModelBase(Of Audit)
C#
[SerializableAttribute]
public class Audit : ModelBase<Audit>
Visual C++
[SerializableAttribute]
public ref class Audit : public ModelBase<Audit^>
JavaScript
InSite.Model.Audit = function();

Type.createClass(
    'InSite.Model.Audit',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Audit>)>)
InSite.Model..::.Audit

See Also

Audit Members
InSite.Model Namespace


Audit Members

[image] [image]

.NET Framework Class Library
Audit Members
Audit Class Constructors Methods Fields Properties See Also Send Feedback

The Audit type exposes the following members.

Constructors

Name | Description
Audit | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Action |
AuditDate |
AuditId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrder |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IpAddress |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Audit Class
InSite.Model Namespace


Audit Constructor

[image] [image]

.NET Framework Class Library
Audit Constructor
Audit Class See Also Send Feedback

Overload List

Name | Description
Audit()()() |
Audit(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Audit Class
Audit Members
InSite.Model Namespace


Audit Constructor

[image]

.NET Framework Class Library
Audit Constructor
Audit Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Audit()
Visual C++
public:
Audit()
JavaScript
InSite.Model.Audit = function();

See Also

Audit Class
Audit Overload
InSite.Model Namespace


Audit Constructor (SearchMode)

[image]

.NET Framework Class Library
Audit Constructor (SearchMode)
Audit Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Audit(
    SearchMode searchMode
)
Visual C++
public:
Audit(
    SearchMode searchMode
)
JavaScript
InSite.Model.Audit = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Audit Class
Audit Overload
InSite.Model Namespace


Audit Fields

[image] [image]

.NET Framework Class Library
Audit Fields
Audit Class See Also Send Feedback

The Audit type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Audit Class
InSite.Model Namespace


Audit Methods

[image] [image]

.NET Framework Class Library
Audit Methods
Audit Class See Also Send Feedback

The Audit type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Audit Class
InSite.Model Namespace


Audit Properties

[image] [image]

.NET Framework Class Library
Audit Properties
Audit Class See Also Send Feedback

The Audit type exposes the following members.

Properties

Name | Description
Action |
AuditDate |
AuditId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrder |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IpAddress |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Audit Class
InSite.Model Namespace


Action Property

[image]

.NET Framework Class Library
Audit..::.Action Property
Audit Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Action As String
C#
public virtual string Action { get; set; }
Visual C++
public:
virtual property String^ Action {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_action();
function set_action(value);

See Also

Audit Class
InSite.Model Namespace


AuditDate Property

[image]

.NET Framework Class Library
Audit..::.AuditDate Property
Audit Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property AuditDate As DateTime
C#
public virtual DateTime AuditDate { get; set; }
Visual C++
public:
virtual property DateTime AuditDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_auditDate();
function set_auditDate(value);

See Also

Audit Class
InSite.Model Namespace


AuditId Property

[image]

.NET Framework Class Library
Audit..::.AuditId Property
Audit Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property AuditId As Guid
C#
public virtual Guid AuditId { get; set; }
Visual C++
public:
virtual property Guid AuditId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_auditId();
function set_auditId(value);

See Also

Audit Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
Audit..::.CustomerOrder Property
Audit Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

Audit Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Audit..::.Description Property
Audit Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Description As String
C#
public virtual string Description { get; set; }
Visual C++
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Audit Class
InSite.Model Namespace


IpAddress Property

[image]

.NET Framework Class Library
Audit..::.IpAddress Property
Audit Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property IpAddress As String
C#
public virtual string IpAddress { get; set; }
Visual C++
public:
virtual property String^ IpAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ipAddress();
function set_ipAddress(value);

See Also

Audit Class
InSite.Model Namespace


UserProfile Property

[image]

.NET Framework Class Library
Audit..::.UserProfile Property
Audit Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfile As UserProfile
C#
public virtual UserProfile UserProfile { get; set; }
Visual C++
public:
virtual property UserProfile^ UserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_userProfile();
function set_userProfile(value);

See Also

Audit Class
InSite.Model Namespace


Carrier Class

[image]

.NET Framework Class Library
Carrier Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Carrier _
    Inherits ModelBase(Of Carrier)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Carrier : ModelBase<Carrier>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Carrier : public ModelBase<Carrier^>
JavaScript
InSite.Model.Carrier = function();

Type.createClass(
    'InSite.Model.Carrier',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Carrier>)>)
InSite.Model..::.Carrier

See Also

Carrier Members
InSite.Model Namespace


Carrier Members

[image] [image]

.NET Framework Class Library
Carrier Members
Carrier Class Constructors Methods Fields Properties See Also Send Feedback

The Carrier type exposes the following members.

Constructors

Name | Description
Carrier | Overloaded.

Methods

Name | Description
AddCarrierPackage |
AddCarrierZone |
AddCustomer | Add Customer to Carrier
AddShipCharge |
AddShipRule |
AddShipVia | Add ShipVia to Carrier
AddWebSite | Add WebSite to Carrier
ClearCarrierZones |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetCarrierZone |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetShipVia | Returns a ShipVia if it can find one matching the shipCode input parameter. Returns null if it can not find a ShipVia.
GetShipViaByDescription |
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasShipCode | Returns true/false if a carrier has a ShipCode matching the input string
HasShipName | Returns true/false if carriers has a description matching the input string.
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCarrierPackage |
RemoveCarrierZone |
RemoveCustomer | Remove Customer from Carrier
RemoveShipCharge |
RemoveShipRule |
RemoveShipVia |
RemoveWebSite | Removes WebSite from Carrier
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
RatingServiceFedEx |
RatingServiceFreightQuote |
RatingServiceMileage |
RatingServiceNone |
RatingServiceSpeedeeDelivery |
RatingServiceUPS |
ShippingCalculationFlat | Flat Fee Charges per ShipVia.
ShippingCalculationMileageRate | Rate for Mileage
ShippingCalculationNone | $0 No Charge
ShippingCalculationPercent | Percent of Order Total
ShippingCalculationProductShippingCostOverride |
ShippingCalculationRate | Rate via service

Properties

Name | Description
AccessKey | Gets or sets and access key for rating services
AccountNumber | Gets or sets the account number for rating services
BackUpCarrier | Gets or Sets a BackUp Carrier for this carrier for the shipping processor
BackUpCarrierName |
CarrierId | Gets or Sets the unique identifier for a carrier
CarrierPackages |
CarrierZones | Gets/Sets a collection of Carrier Zones used for zone rating such as sir speedy
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContactEmail | Gets or sets the Contacts email address
ContactName | Gets or sets the Contact Name for the carrier
ContactPhone | Gets or Sets the Contact Phone number
Customers | Gets a list of Customers this Carrier is associated with.
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description | Gets or Sets a Description
Enable | Gets or Sets whether this Carrier is enabled or disables.
HasBackUpCarrier |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Image | Gets or Sets the Image Name
IsLive | Gets or Sets whether the Carrier Processing is Live or Test.
IsPrimaryCarrier | Gets or Sets whether this Carrier is a primary Shipping Carrier.
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LiveUrl | Gets or Sets the Live URL for Rating.
Name | Gets or sets a name for a carrier
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Password | Gets or sets the password for rating services
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RatingService | Gets or sets the Rating Processor
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipChargeAmount |
ShipCharges |
ShippingCalculation |
ShipRules | Gets/Sets a collection of Shipping Rules that the Shipping Engine will use to Validate whether the carrier can be used for the order
ShipVias | Gets a list of ShipVias this Carrier is associated with.
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TestUrl | Gets or Sets the Test URL for Rating.
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Url | Returns a URL, if IsLive is true, returns LiveUrl else it returns TestUrl.
UserName | Gets or Sets the User Name for the rating services
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSites | Gets a list of Websites this Carrier is associated with.
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Carrier Class
InSite.Model Namespace


Carrier Constructor

[image] [image]

.NET Framework Class Library
Carrier Constructor
Carrier Class See Also Send Feedback

Overload List

Name | Description
Carrier()()() |
Carrier(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Carrier Class
Carrier Members
InSite.Model Namespace


Carrier Constructor

[image]

.NET Framework Class Library
Carrier Constructor
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Carrier()
Visual C++
public:
Carrier()
JavaScript
InSite.Model.Carrier = function();

See Also

Carrier Class
Carrier Overload
InSite.Model Namespace


Carrier Constructor (SearchMode)

[image]

.NET Framework Class Library
Carrier Constructor (SearchMode)
Carrier Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Carrier(
    SearchMode searchMode
)
Visual C++
public:
Carrier(
    SearchMode searchMode
)
JavaScript
InSite.Model.Carrier = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Carrier Class
Carrier Overload
InSite.Model Namespace


Carrier Fields

[image] [image]

.NET Framework Class Library
Carrier Fields
Carrier Class See Also Send Feedback

The Carrier type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
RatingServiceFedEx |
RatingServiceFreightQuote |
RatingServiceMileage |
RatingServiceNone |
RatingServiceSpeedeeDelivery |
RatingServiceUPS |
ShippingCalculationFlat | Flat Fee Charges per ShipVia.
ShippingCalculationMileageRate | Rate for Mileage
ShippingCalculationNone | $0 No Charge
ShippingCalculationPercent | Percent of Order Total
ShippingCalculationProductShippingCostOverride |
ShippingCalculationRate | Rate via service

See Also

Carrier Class
InSite.Model Namespace


RatingServiceFedEx Field

[image]

.NET Framework Class Library
Carrier..::.RatingServiceFedEx Field
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared RatingServiceFedEx As String
C#
public static string RatingServiceFedEx
Visual C++
public:
static String^ RatingServiceFedEx
JavaScript
InSite.Model.Carrier.ratingServiceFedEx

See Also

Carrier Class
InSite.Model Namespace


RatingServiceFreightQuote Field

[image]

.NET Framework Class Library
Carrier..::.RatingServiceFreightQuote Field
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared RatingServiceFreightQuote As String
C#
public static string RatingServiceFreightQuote
Visual C++
public:
static String^ RatingServiceFreightQuote
JavaScript
InSite.Model.Carrier.ratingServiceFreightQuote

See Also

Carrier Class
InSite.Model Namespace


RatingServiceMileage Field

[image]

.NET Framework Class Library
Carrier..::.RatingServiceMileage Field
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared RatingServiceMileage As String
C#
public static string RatingServiceMileage
Visual C++
public:
static String^ RatingServiceMileage
JavaScript
InSite.Model.Carrier.ratingServiceMileage

See Also

Carrier Class
InSite.Model Namespace


RatingServiceNone Field

[image]

.NET Framework Class Library
Carrier..::.RatingServiceNone Field
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared RatingServiceNone As String
C#
public static string RatingServiceNone
Visual C++
public:
static String^ RatingServiceNone
JavaScript
InSite.Model.Carrier.ratingServiceNone

See Also

Carrier Class
InSite.Model Namespace


RatingServiceSpeedeeDelivery Field

[image]

.NET Framework Class Library
Carrier..::.RatingServiceSpeedeeDelivery Field
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared RatingServiceSpeedeeDelivery As String
C#
public static string RatingServiceSpeedeeDelivery
Visual C++
public:
static String^ RatingServiceSpeedeeDelivery
JavaScript
InSite.Model.Carrier.ratingServiceSpeedeeDelivery

See Also

Carrier Class
InSite.Model Namespace


RatingServiceUPS Field

[image]

.NET Framework Class Library
Carrier..::.RatingServiceUPS Field
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared RatingServiceUPS As String
C#
public static string RatingServiceUPS
Visual C++
public:
static String^ RatingServiceUPS
JavaScript
InSite.Model.Carrier.ratingServiceUPS

See Also

Carrier Class
InSite.Model Namespace


ShippingCalculationFlat Field

[image]

.NET Framework Class Library
Carrier..::.ShippingCalculationFlat Field
Carrier Class See Also Send Feedback

Flat Fee Charges per ShipVia.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ShippingCalculationFlat As String
C#
public static string ShippingCalculationFlat
Visual C++
public:
static String^ ShippingCalculationFlat
JavaScript
InSite.Model.Carrier.shippingCalculationFlat

See Also

Carrier Class
InSite.Model Namespace


ShippingCalculationMileageRate Field

[image]

.NET Framework Class Library
Carrier..::.ShippingCalculationMileageRate Field
Carrier Class See Also Send Feedback

Rate for Mileage

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ShippingCalculationMileageRate As String
C#
public static string ShippingCalculationMileageRate
Visual C++
public:
static String^ ShippingCalculationMileageRate
JavaScript
InSite.Model.Carrier.shippingCalculationMileageRate

See Also

Carrier Class
InSite.Model Namespace


ShippingCalculationNone Field

[image]

.NET Framework Class Library
Carrier..::.ShippingCalculationNone Field
Carrier Class See Also Send Feedback

$0 No Charge

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ShippingCalculationNone As String
C#
public static string ShippingCalculationNone
Visual C++
public:
static String^ ShippingCalculationNone
JavaScript
InSite.Model.Carrier.shippingCalculationNone

See Also

Carrier Class
InSite.Model Namespace


ShippingCalculationPercent Field

[image]

.NET Framework Class Library
Carrier..::.ShippingCalculationPercent Field
Carrier Class See Also Send Feedback

Percent of Order Total

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ShippingCalculationPercent As String
C#
public static string ShippingCalculationPercent
Visual C++
public:
static String^ ShippingCalculationPercent
JavaScript
InSite.Model.Carrier.shippingCalculationPercent

See Also

Carrier Class
InSite.Model Namespace


ShippingCalculationProductShippingCostOverride Field

[image]

.NET Framework Class Library
Carrier..::.ShippingCalculationProductShippingCostOverride Field
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ShippingCalculationProductShippingCostOverride As String
C#
public static string ShippingCalculationProductShippingCostOverride
Visual C++
public:
static String^ ShippingCalculationProductShippingCostOverride
JavaScript
InSite.Model.Carrier.shippingCalculationProductShippingCostOverride

See Also

Carrier Class
InSite.Model Namespace


ShippingCalculationRate Field

[image]

.NET Framework Class Library
Carrier..::.ShippingCalculationRate Field
Carrier Class See Also Send Feedback

Rate via service

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ShippingCalculationRate As String
C#
public static string ShippingCalculationRate
Visual C++
public:
static String^ ShippingCalculationRate
JavaScript
InSite.Model.Carrier.shippingCalculationRate

See Also

Carrier Class
InSite.Model Namespace


Carrier Methods

[image] [image]

.NET Framework Class Library
Carrier Methods
Carrier Class See Also Send Feedback

The Carrier type exposes the following members.

Methods

Name | Description
AddCarrierPackage |
AddCarrierZone |
AddCustomer | Add Customer to Carrier
AddShipCharge |
AddShipRule |
AddShipVia | Add ShipVia to Carrier
AddWebSite | Add WebSite to Carrier
ClearCarrierZones |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetCarrierZone |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetShipVia | Returns a ShipVia if it can find one matching the shipCode input parameter. Returns null if it can not find a ShipVia.
GetShipViaByDescription |
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasShipCode | Returns true/false if a carrier has a ShipCode matching the input string
HasShipName | Returns true/false if carriers has a description matching the input string.
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCarrierPackage |
RemoveCarrierZone |
RemoveCustomer | Remove Customer from Carrier
RemoveShipCharge |
RemoveShipRule |
RemoveShipVia |
RemoveWebSite | Removes WebSite from Carrier
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Carrier Class
InSite.Model Namespace


AddCarrierPackage Method

[image]

.NET Framework Class Library
Carrier..::.AddCarrierPackage Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCarrierPackage ( _
    value As CarrierPackage _
)
C#
public virtual void AddCarrierPackage(
    CarrierPackage value
)
Visual C++
public:
virtual void AddCarrierPackage(
    CarrierPackage^ value
)
JavaScript
function addCarrierPackage(value);

Parameters

value
Type: InSite.Model..::.CarrierPackage

See Also

Carrier Class
InSite.Model Namespace


AddCarrierZone Method

[image]

.NET Framework Class Library
Carrier..::.AddCarrierZone Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCarrierZone ( _
    value As CarrierZone _
)
C#
public virtual void AddCarrierZone(
    CarrierZone value
)
Visual C++
public:
virtual void AddCarrierZone(
    CarrierZone^ value
)
JavaScript
function addCarrierZone(value);

Parameters

value
Type: InSite.Model..::.CarrierZone

See Also

Carrier Class
InSite.Model Namespace


AddCustomer Method

[image]

.NET Framework Class Library
Carrier..::.AddCustomer Method
Carrier Class See Also Send Feedback

Add Customer to Carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomer ( _
    value As Customer _
)
C#
public virtual void AddCustomer(
    Customer value
)
Visual C++
public:
virtual void AddCustomer(
    Customer^ value
)
JavaScript
function addCustomer(value);

Parameters

value
Type: InSite.Model..::.Customer
Customer

See Also

Carrier Class
InSite.Model Namespace


AddShipCharge Method

[image]

.NET Framework Class Library
Carrier..::.AddShipCharge Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipCharge ( _
    value As ShipCharge _
)
C#
public virtual void AddShipCharge(
    ShipCharge value
)
Visual C++
public:
virtual void AddShipCharge(
    ShipCharge^ value
)
JavaScript
function addShipCharge(value);

Parameters

value
Type: InSite.Model..::.ShipCharge

See Also

Carrier Class
InSite.Model Namespace


AddShipRule Method

[image]

.NET Framework Class Library
Carrier..::.AddShipRule Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipRule ( _
    value As ShipRule _
)
C#
public virtual void AddShipRule(
    ShipRule value
)
Visual C++
public:
virtual void AddShipRule(
    ShipRule^ value
)
JavaScript
function addShipRule(value);

Parameters

value
Type: InSite.Model..::.ShipRule

See Also

Carrier Class
InSite.Model Namespace


AddShipVia Method

[image]

.NET Framework Class Library
Carrier..::.AddShipVia Method
Carrier Class See Also Send Feedback

Add ShipVia to Carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipVia ( _
    value As ShipVia _
)
C#
public virtual void AddShipVia(
    ShipVia value
)
Visual C++
public:
virtual void AddShipVia(
    ShipVia^ value
)
JavaScript
function addShipVia(value);

Parameters

value
Type: InSite.Model..::.ShipVia
ShipVia

See Also

Carrier Class
InSite.Model Namespace


AddWebSite Method

[image]

.NET Framework Class Library
Carrier..::.AddWebSite Method
Carrier Class See Also Send Feedback

Add WebSite to Carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWebSite ( _
    value As WebSite _
)
C#
public virtual void AddWebSite(
    WebSite value
)
Visual C++
public:
virtual void AddWebSite(
    WebSite^ value
)
JavaScript
function addWebSite(value);

Parameters

value
Type: InSite.Model..::.WebSite
WebSite

See Also

Carrier Class
InSite.Model Namespace


ClearCarrierZones Method

[image]

.NET Framework Class Library
Carrier..::.ClearCarrierZones Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ClearCarrierZones
C#
public virtual void ClearCarrierZones()
Visual C++
public:
virtual void ClearCarrierZones()
JavaScript
function clearCarrierZones();

See Also

Carrier Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
Carrier..::.GetByName Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As Carrier
C#
public static Carrier GetByName(
    string name
)
Visual C++
public:
static Carrier^ GetByName(
    String^ name
)
JavaScript
InSite.Model.Carrier.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

Carrier Class
InSite.Model Namespace


GetCarrierZone Method

[image]

.NET Framework Class Library
Carrier..::.GetCarrierZone Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCarrierZone ( _
    zipCode As String _
) As CarrierZone
C#
public virtual CarrierZone GetCarrierZone(
    string zipCode
)
Visual C++
public:
virtual CarrierZone^ GetCarrierZone(
    String^ zipCode
)
JavaScript
function getCarrierZone(zipCode);

Parameters

zipCode
Type: System..::.String

See Also

Carrier Class
InSite.Model Namespace


GetShipVia Method

[image]

.NET Framework Class Library
Carrier..::.GetShipVia Method
Carrier Class See Also Send Feedback

Returns a ShipVia if it can find one matching the shipCode input parameter. Returns null if it can not find a ShipVia.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function GetShipVia ( _
    shipCode As String _
) As ShipVia
C#
public ShipVia GetShipVia(
    string shipCode
)
Visual C++
public:
ShipVia^ GetShipVia(
    String^ shipCode
)
JavaScript
function getShipVia(shipCode);

Parameters

shipCode
Type: System..::.String

Return Value

See Also

Carrier Class
InSite.Model Namespace


GetShipViaByDescription Method

[image]

.NET Framework Class Library
Carrier..::.GetShipViaByDescription Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function GetShipViaByDescription ( _
    description As String _
) As ShipVia
C#
public ShipVia GetShipViaByDescription(
    string description
)
Visual C++
public:
ShipVia^ GetShipViaByDescription(
    String^ description
)
JavaScript
function getShipViaByDescription(description);

Parameters

description
Type: System..::.String

See Also

Carrier Class
InSite.Model Namespace


HasShipCode Method

[image]

.NET Framework Class Library
Carrier..::.HasShipCode Method
Carrier Class See Also Send Feedback

Returns true/false if a carrier has a ShipCode matching the input string

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function HasShipCode ( _
    shipCode As String _
) As Boolean
C#
public bool HasShipCode(
    string shipCode
)
Visual C++
public:
bool HasShipCode(
    String^ shipCode
)
JavaScript
function hasShipCode(shipCode);

Parameters

shipCode
Type: System..::.String

Return Value

Boolean

See Also

Carrier Class
InSite.Model Namespace


HasShipName Method

[image]

.NET Framework Class Library
Carrier..::.HasShipName Method
Carrier Class See Also Send Feedback

Returns true/false if carriers has a description matching the input string.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function HasShipName ( _
    shipName As String _
) As Boolean
C#
public bool HasShipName(
    string shipName
)
Visual C++
public:
bool HasShipName(
    String^ shipName
)
JavaScript
function hasShipName(shipName);

Parameters

shipName
Type: System..::.String

Return Value

Boolean

See Also

Carrier Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
Carrier..::.IsValid Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    customerOrder As CustomerOrder _
) As Boolean
C#
public virtual bool IsValid(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder
)
JavaScript
function isValid(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Carrier Class
InSite.Model Namespace


RemoveCarrierPackage Method

[image]

.NET Framework Class Library
Carrier..::.RemoveCarrierPackage Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCarrierPackage ( _
    value As CarrierPackage _
)
C#
public virtual void RemoveCarrierPackage(
    CarrierPackage value
)
Visual C++
public:
virtual void RemoveCarrierPackage(
    CarrierPackage^ value
)
JavaScript
function removeCarrierPackage(value);

Parameters

value
Type: InSite.Model..::.CarrierPackage

See Also

Carrier Class
InSite.Model Namespace


RemoveCarrierZone Method

[image]

.NET Framework Class Library
Carrier..::.RemoveCarrierZone Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCarrierZone ( _
    value As CarrierZone _
)
C#
public virtual void RemoveCarrierZone(
    CarrierZone value
)
Visual C++
public:
virtual void RemoveCarrierZone(
    CarrierZone^ value
)
JavaScript
function removeCarrierZone(value);

Parameters

value
Type: InSite.Model..::.CarrierZone

See Also

Carrier Class
InSite.Model Namespace


RemoveCustomer Method

[image]

.NET Framework Class Library
Carrier..::.RemoveCustomer Method
Carrier Class See Also Send Feedback

Remove Customer from Carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomer ( _
    value As Customer _
)
C#
public virtual void RemoveCustomer(
    Customer value
)
Visual C++
public:
virtual void RemoveCustomer(
    Customer^ value
)
JavaScript
function removeCustomer(value);

Parameters

value
Type: InSite.Model..::.Customer
Customer

See Also

Carrier Class
InSite.Model Namespace


RemoveShipCharge Method

[image]

.NET Framework Class Library
Carrier..::.RemoveShipCharge Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipCharge ( _
    value As ShipCharge _
)
C#
public virtual void RemoveShipCharge(
    ShipCharge value
)
Visual C++
public:
virtual void RemoveShipCharge(
    ShipCharge^ value
)
JavaScript
function removeShipCharge(value);

Parameters

value
Type: InSite.Model..::.ShipCharge

See Also

Carrier Class
InSite.Model Namespace


RemoveShipRule Method

[image]

.NET Framework Class Library
Carrier..::.RemoveShipRule Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipRule ( _
    value As ShipRule _
)
C#
public virtual void RemoveShipRule(
    ShipRule value
)
Visual C++
public:
virtual void RemoveShipRule(
    ShipRule^ value
)
JavaScript
function removeShipRule(value);

Parameters

value
Type: InSite.Model..::.ShipRule

See Also

Carrier Class
InSite.Model Namespace


RemoveShipVia Method

[image]

.NET Framework Class Library
Carrier..::.RemoveShipVia Method
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipVia ( _
    value As ShipVia _
)
C#
public virtual void RemoveShipVia(
    ShipVia value
)
Visual C++
public:
virtual void RemoveShipVia(
    ShipVia^ value
)
JavaScript
function removeShipVia(value);

Parameters

value
Type: InSite.Model..::.ShipVia

See Also

Carrier Class
InSite.Model Namespace


RemoveWebSite Method

[image]

.NET Framework Class Library
Carrier..::.RemoveWebSite Method
Carrier Class See Also Send Feedback

Removes WebSite from Carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWebSite ( _
    value As WebSite _
)
C#
public virtual void RemoveWebSite(
    WebSite value
)
Visual C++
public:
virtual void RemoveWebSite(
    WebSite^ value
)
JavaScript
function removeWebSite(value);

Parameters

value
Type: InSite.Model..::.WebSite
WebSite

See Also

Carrier Class
InSite.Model Namespace


Carrier Properties

[image] [image]

.NET Framework Class Library
Carrier Properties
Carrier Class See Also Send Feedback

The Carrier type exposes the following members.

Properties

Name | Description
AccessKey | Gets or sets and access key for rating services
AccountNumber | Gets or sets the account number for rating services
BackUpCarrier | Gets or Sets a BackUp Carrier for this carrier for the shipping processor
BackUpCarrierName |
CarrierId | Gets or Sets the unique identifier for a carrier
CarrierPackages |
CarrierZones | Gets/Sets a collection of Carrier Zones used for zone rating such as sir speedy
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContactEmail | Gets or sets the Contacts email address
ContactName | Gets or sets the Contact Name for the carrier
ContactPhone | Gets or Sets the Contact Phone number
Customers | Gets a list of Customers this Carrier is associated with.
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description | Gets or Sets a Description
Enable | Gets or Sets whether this Carrier is enabled or disables.
HasBackUpCarrier |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Image | Gets or Sets the Image Name
IsLive | Gets or Sets whether the Carrier Processing is Live or Test.
IsPrimaryCarrier | Gets or Sets whether this Carrier is a primary Shipping Carrier.
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LiveUrl | Gets or Sets the Live URL for Rating.
Name | Gets or sets a name for a carrier
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Password | Gets or sets the password for rating services
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RatingService | Gets or sets the Rating Processor
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipChargeAmount |
ShipCharges |
ShippingCalculation |
ShipRules | Gets/Sets a collection of Shipping Rules that the Shipping Engine will use to Validate whether the carrier can be used for the order
ShipVias | Gets a list of ShipVias this Carrier is associated with.
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TestUrl | Gets or Sets the Test URL for Rating.
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Url | Returns a URL, if IsLive is true, returns LiveUrl else it returns TestUrl.
UserName | Gets or Sets the User Name for the rating services
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSites | Gets a list of Websites this Carrier is associated with.
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Carrier Class
InSite.Model Namespace


AccessKey Property

[image]

.NET Framework Class Library
Carrier..::.AccessKey Property
Carrier Class See Also Send Feedback

Gets or sets and access key for rating services

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AccessKey As String
C#
[DataMemberAttribute]
public virtual string AccessKey { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AccessKey {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accessKey();
function set_accessKey(value);

See Also

Carrier Class
InSite.Model Namespace


AccountNumber Property

[image]

.NET Framework Class Library
Carrier..::.AccountNumber Property
Carrier Class See Also Send Feedback

Gets or sets the account number for rating services

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AccountNumber As String
C#
[DataMemberAttribute]
public virtual string AccountNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_accountNumber();
function set_accountNumber(value);

See Also

Carrier Class
InSite.Model Namespace


BackUpCarrier Property

[image]

.NET Framework Class Library
Carrier..::.BackUpCarrier Property
Carrier Class See Also Send Feedback

Gets or Sets a BackUp Carrier for this carrier for the shipping processor

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property BackUpCarrier As Carrier
C#
public virtual Carrier BackUpCarrier { get; set; }
Visual C++
public:
virtual property Carrier^ BackUpCarrier {
    Carrier^ get ();
    void set (Carrier^ value);
}
JavaScript
function get_backUpCarrier();
function set_backUpCarrier(value);

See Also

Carrier Class
InSite.Model Namespace


BackUpCarrierName Property

[image]

.NET Framework Class Library
Carrier..::.BackUpCarrierName Property
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BackUpCarrierName As String
C#
[DataMemberAttribute]
public virtual string BackUpCarrierName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BackUpCarrierName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_backUpCarrierName();
function set_backUpCarrierName(value);

See Also

Carrier Class
InSite.Model Namespace


CarrierId Property

[image]

.NET Framework Class Library
Carrier..::.CarrierId Property
Carrier Class See Also Send Feedback

Gets or Sets the unique identifier for a carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CarrierId As Guid
C#
public virtual Guid CarrierId { get; set; }
Visual C++
public:
virtual property Guid CarrierId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_carrierId();
function set_carrierId(value);

See Also

Carrier Class
InSite.Model Namespace


CarrierPackages Property

[image]

.NET Framework Class Library
Carrier..::.CarrierPackages Property
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CarrierPackages As ChildList(Of CarrierPackage)
C#
[DataMemberAttribute]
public virtual ChildList<CarrierPackage> CarrierPackages { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<CarrierPackage^>^ CarrierPackages {
    ChildList<CarrierPackage^>^ get ();
    void set (ChildList<CarrierPackage^>^ value);
}
JavaScript
function get_carrierPackages();
function set_carrierPackages(value);

See Also

Carrier Class
InSite.Model Namespace


CarrierZones Property

[image]

.NET Framework Class Library
Carrier..::.CarrierZones Property
Carrier Class See Also Send Feedback

Gets/Sets a collection of Carrier Zones used for zone rating such as sir speedy

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SaveChildren> _
<DataMemberAttribute> _
Public Overridable Property CarrierZones As ChildList(Of CarrierZone)
C#
[SaveChildren]
[DataMemberAttribute]
public virtual ChildList<CarrierZone> CarrierZones { get; private set; }
Visual C++
[SaveChildren]
[DataMemberAttribute]
public:
virtual property ChildList<CarrierZone^>^ CarrierZones {
    ChildList<CarrierZone^>^ get ();
    void set (ChildList<CarrierZone^>^ value);
}
JavaScript
function get_carrierZones();
function set_carrierZones(value);

See Also

Carrier Class
InSite.Model Namespace


ContactEmail Property

[image]

.NET Framework Class Library
Carrier..::.ContactEmail Property
Carrier Class See Also Send Feedback

Gets or sets the Contacts email address

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ContactEmail As String
C#
[DataMemberAttribute]
public virtual string ContactEmail { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ContactEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contactEmail();
function set_contactEmail(value);

See Also

Carrier Class
InSite.Model Namespace


ContactName Property

[image]

.NET Framework Class Library
Carrier..::.ContactName Property
Carrier Class See Also Send Feedback

Gets or sets the Contact Name for the carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ContactName As String
C#
[DataMemberAttribute]
public virtual string ContactName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ContactName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contactName();
function set_contactName(value);

See Also

Carrier Class
InSite.Model Namespace


ContactPhone Property

[image]

.NET Framework Class Library
Carrier..::.ContactPhone Property
Carrier Class See Also Send Feedback

Gets or Sets the Contact Phone number

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ContactPhone As String
C#
[DataMemberAttribute]
public virtual string ContactPhone { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ContactPhone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contactPhone();
function set_contactPhone(value);

See Also

Carrier Class
InSite.Model Namespace


Customers Property

[image]

.NET Framework Class Library
Carrier..::.Customers Property
Carrier Class See Also Send Feedback

Gets a list of Customers this Carrier is associated with.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customers As ChildList(Of Customer)
C#
public virtual ChildList<Customer> Customers { get; private set; }
Visual C++
public:
virtual property ChildList<Customer^>^ Customers {
    ChildList<Customer^>^ get ();
    void set (ChildList<Customer^>^ value);
}
JavaScript
function get_customers();
function set_customers(value);

See Also

Carrier Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Carrier..::.Description Property
Carrier Class See Also Send Feedback

Gets or Sets a Description

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Carrier Class
InSite.Model Namespace


Enable Property

[image]

.NET Framework Class Library
Carrier..::.Enable Property
Carrier Class See Also Send Feedback

Gets or Sets whether this Carrier is enabled or disables.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Enable As Boolean
C#
[DataMemberAttribute]
public virtual bool Enable { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool Enable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enable();
function set_enable(value);

See Also

Carrier Class
InSite.Model Namespace


HasBackUpCarrier Property

[image]

.NET Framework Class Library
Carrier..::.HasBackUpCarrier Property
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HasBackUpCarrier As Boolean
C#
public virtual bool HasBackUpCarrier { get; }
Visual C++
public:
virtual property bool HasBackUpCarrier {
    bool get ();
}
JavaScript
function get_hasBackUpCarrier();

See Also

Carrier Class
InSite.Model Namespace


Image Property

[image]

.NET Framework Class Library
Carrier..::.Image Property
Carrier Class See Also Send Feedback

Gets or Sets the Image Name

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Image As String
C#
[DataMemberAttribute]
public virtual string Image { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Image {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_image();
function set_image(value);

See Also

Carrier Class
InSite.Model Namespace


IsLive Property

[image]

.NET Framework Class Library
Carrier..::.IsLive Property
Carrier Class See Also Send Feedback

Gets or Sets whether the Carrier Processing is Live or Test.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsLive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsLive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsLive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isLive();
function set_isLive(value);

See Also

Carrier Class
InSite.Model Namespace


IsPrimaryCarrier Property

[image]

.NET Framework Class Library
Carrier..::.IsPrimaryCarrier Property
Carrier Class See Also Send Feedback

Gets or Sets whether this Carrier is a primary Shipping Carrier.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsPrimaryCarrier As Boolean
C#
[DataMemberAttribute]
public virtual bool IsPrimaryCarrier { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsPrimaryCarrier {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isPrimaryCarrier();
function set_isPrimaryCarrier(value);

See Also

Carrier Class
InSite.Model Namespace


LiveUrl Property

[image]

.NET Framework Class Library
Carrier..::.LiveUrl Property
Carrier Class See Also Send Feedback

Gets or Sets the Live URL for Rating.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LiveUrl As String
C#
[DataMemberAttribute]
public virtual string LiveUrl { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LiveUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_liveUrl();
function set_liveUrl(value);

See Also

Carrier Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Carrier..::.Name Property
Carrier Class See Also Send Feedback

Gets or sets a name for a carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Carrier Class
InSite.Model Namespace


Password Property

[image]

.NET Framework Class Library
Carrier..::.Password Property
Carrier Class See Also Send Feedback

Gets or sets the password for rating services

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Password As String
C#
[DataMemberAttribute]
public virtual string Password { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Password {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_password();
function set_password(value);

See Also

Carrier Class
InSite.Model Namespace


RatingService Property

[image]

.NET Framework Class Library
Carrier..::.RatingService Property
Carrier Class See Also Send Feedback

Gets or sets the Rating Processor

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RatingService As String
C#
[DataMemberAttribute]
public virtual string RatingService { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RatingService {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ratingService();
function set_ratingService(value);

See Also

Carrier Class
InSite.Model Namespace


ShipChargeAmount Property

[image]

.NET Framework Class Library
Carrier..::.ShipChargeAmount Property
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ShipChargeAmount As Decimal
C#
public virtual decimal ShipChargeAmount { get; }
Visual C++
public:
virtual property Decimal ShipChargeAmount {
    Decimal get ();
}
JavaScript
function get_shipChargeAmount();

See Also

Carrier Class
InSite.Model Namespace


ShipCharges Property

[image]

.NET Framework Class Library
Carrier..::.ShipCharges Property
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipCharges As ChildList(Of ShipCharge)
C#
[DataMemberAttribute]
public virtual ChildList<ShipCharge> ShipCharges { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ShipCharge^>^ ShipCharges {
    ChildList<ShipCharge^>^ get ();
    void set (ChildList<ShipCharge^>^ value);
}
JavaScript
function get_shipCharges();
function set_shipCharges(value);

See Also

Carrier Class
InSite.Model Namespace


ShippingCalculation Property

[image]

.NET Framework Class Library
Carrier..::.ShippingCalculation Property
Carrier Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShippingCalculation As String
C#
[DataMemberAttribute]
public virtual string ShippingCalculation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShippingCalculation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shippingCalculation();
function set_shippingCalculation(value);

See Also

Carrier Class
InSite.Model Namespace


ShipRules Property

[image]

.NET Framework Class Library
Carrier..::.ShipRules Property
Carrier Class See Also Send Feedback

Gets/Sets a collection of Shipping Rules that the Shipping Engine will use to Validate whether the carrier can be used for the order

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipRules As ChildList(Of ShipRule)
C#
[DataMemberAttribute]
public virtual ChildList<ShipRule> ShipRules { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ShipRule^>^ ShipRules {
    ChildList<ShipRule^>^ get ();
    void set (ChildList<ShipRule^>^ value);
}
JavaScript
function get_shipRules();
function set_shipRules(value);

See Also

Carrier Class
InSite.Model Namespace


ShipVias Property

[image]

.NET Framework Class Library
Carrier..::.ShipVias Property
Carrier Class See Also Send Feedback

Gets a list of ShipVias this Carrier is associated with.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SaveChildren> _
Public Overridable Property ShipVias As ChildList(Of ShipVia)
C#
[DataMemberAttribute]
[SaveChildren]
public virtual ChildList<ShipVia> ShipVias { get; private set; }
Visual C++
[DataMemberAttribute]
[SaveChildren]
public:
virtual property ChildList<ShipVia^>^ ShipVias {
    ChildList<ShipVia^>^ get ();
    void set (ChildList<ShipVia^>^ value);
}
JavaScript
function get_shipVias();
function set_shipVias(value);

See Also

Carrier Class
InSite.Model Namespace


TestUrl Property

[image]

.NET Framework Class Library
Carrier..::.TestUrl Property
Carrier Class See Also Send Feedback

Gets or Sets the Test URL for Rating.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TestUrl As String
C#
[DataMemberAttribute]
public virtual string TestUrl { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TestUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_testUrl();
function set_testUrl(value);

See Also

Carrier Class
InSite.Model Namespace


Url Property

[image]

.NET Framework Class Library
Carrier..::.Url Property
Carrier Class See Also Send Feedback

Returns a URL, if IsLive is true, returns LiveUrl else it returns TestUrl.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Url As String
C#
public string Url { get; }
Visual C++
public:
property String^ Url {
    String^ get ();
}
JavaScript
function get_url();

See Also

Carrier Class
InSite.Model Namespace


UserName Property

[image]

.NET Framework Class Library
Carrier..::.UserName Property
Carrier Class See Also Send Feedback

Gets or Sets the User Name for the rating services

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UserName As String
C#
[DataMemberAttribute]
public virtual string UserName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ UserName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_userName();
function set_userName(value);

See Also

Carrier Class
InSite.Model Namespace


WebSites Property

[image]

.NET Framework Class Library
Carrier..::.WebSites Property
Carrier Class See Also Send Feedback

Gets a list of Websites this Carrier is associated with.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSites As ChildList(Of WebSite)
C#
public virtual ChildList<WebSite> WebSites { get; private set; }
Visual C++
public:
virtual property ChildList<WebSite^>^ WebSites {
    ChildList<WebSite^>^ get ();
    void set (ChildList<WebSite^>^ value);
}
JavaScript
function get_webSites();
function set_webSites(value);

See Also

Carrier Class
InSite.Model Namespace


CarrierPackage Class

[image]

.NET Framework Class Library
CarrierPackage Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CarrierPackage _
    Inherits ModelBase(Of CarrierPackage)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CarrierPackage : ModelBase<CarrierPackage>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CarrierPackage : public ModelBase<CarrierPackage^>
JavaScript
InSite.Model.CarrierPackage = function();

Type.createClass(
    'InSite.Model.CarrierPackage',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CarrierPackage>)>)
InSite.Model..::.CarrierPackage

See Also

CarrierPackage Members
InSite.Model Namespace


CarrierPackage Members

[image] [image]

.NET Framework Class Library
CarrierPackage Members
CarrierPackage Class Constructors Methods Fields Properties See Also Send Feedback

The CarrierPackage type exposes the following members.

Constructors

Name | Description
CarrierPackage | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier |
CarrierPackageId | Gets or Sets the unique identifier for a carrier
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Height |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Length |
Name | Gets or sets a name for a carrier
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Weight |
Width |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierPackage Class
InSite.Model Namespace


CarrierPackage Constructor

[image] [image]

.NET Framework Class Library
CarrierPackage Constructor
CarrierPackage Class See Also Send Feedback

Overload List

Name | Description
CarrierPackage()()() |
CarrierPackage(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CarrierPackage Class
CarrierPackage Members
InSite.Model Namespace


CarrierPackage Constructor

[image]

.NET Framework Class Library
CarrierPackage Constructor
CarrierPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CarrierPackage()
Visual C++
public:
CarrierPackage()
JavaScript
InSite.Model.CarrierPackage = function();

See Also

CarrierPackage Class
CarrierPackage Overload
InSite.Model Namespace


CarrierPackage Constructor (SearchMode)

[image]

.NET Framework Class Library
CarrierPackage Constructor (SearchMode)
CarrierPackage Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CarrierPackage(
    SearchMode searchMode
)
Visual C++
public:
CarrierPackage(
    SearchMode searchMode
)
JavaScript
InSite.Model.CarrierPackage = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CarrierPackage Class
CarrierPackage Overload
InSite.Model Namespace


CarrierPackage Fields

[image] [image]

.NET Framework Class Library
CarrierPackage Fields
CarrierPackage Class See Also Send Feedback

The CarrierPackage type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierPackage Class
InSite.Model Namespace


CarrierPackage Methods

[image] [image]

.NET Framework Class Library
CarrierPackage Methods
CarrierPackage Class See Also Send Feedback

The CarrierPackage type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierPackage Class
InSite.Model Namespace


CarrierPackage Properties

[image] [image]

.NET Framework Class Library
CarrierPackage Properties
CarrierPackage Class See Also Send Feedback

The CarrierPackage type exposes the following members.

Properties

Name | Description
Carrier |
CarrierPackageId | Gets or Sets the unique identifier for a carrier
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Height |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Length |
Name | Gets or sets a name for a carrier
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Weight |
Width |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierPackage Class
InSite.Model Namespace


Carrier Property

[image]

.NET Framework Class Library
CarrierPackage..::.Carrier Property
CarrierPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Carrier As Carrier
C#
public virtual Carrier Carrier { get; set; }
Visual C++
public:
virtual property Carrier^ Carrier {
    Carrier^ get ();
    void set (Carrier^ value);
}
JavaScript
function get_carrier();
function set_carrier(value);

See Also

CarrierPackage Class
InSite.Model Namespace


CarrierPackageId Property

[image]

.NET Framework Class Library
CarrierPackage..::.CarrierPackageId Property
CarrierPackage Class See Also Send Feedback

Gets or Sets the unique identifier for a carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CarrierPackageId As Guid
C#
public virtual Guid CarrierPackageId { get; set; }
Visual C++
public:
virtual property Guid CarrierPackageId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_carrierPackageId();
function set_carrierPackageId(value);

See Also

CarrierPackage Class
InSite.Model Namespace


Height Property

[image]

.NET Framework Class Library
CarrierPackage..::.Height Property
CarrierPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Height As Decimal
C#
[DataMemberAttribute]
public virtual decimal Height { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Height {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_height();
function set_height(value);

See Also

CarrierPackage Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
CarrierPackage..::.IsActive Property
CarrierPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

CarrierPackage Class
InSite.Model Namespace


Length Property

[image]

.NET Framework Class Library
CarrierPackage..::.Length Property
CarrierPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Length As Decimal
C#
[DataMemberAttribute]
public virtual decimal Length { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Length {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_length();
function set_length(value);

See Also

CarrierPackage Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CarrierPackage..::.Name Property
CarrierPackage Class See Also Send Feedback

Gets or sets a name for a carrier

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CarrierPackage Class
InSite.Model Namespace


Weight Property

[image]

.NET Framework Class Library
CarrierPackage..::.Weight Property
CarrierPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Weight As Decimal
C#
[DataMemberAttribute]
public virtual decimal Weight { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_weight();
function set_weight(value);

See Also

CarrierPackage Class
InSite.Model Namespace


Width Property

[image]

.NET Framework Class Library
CarrierPackage..::.Width Property
CarrierPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Width As Decimal
C#
[DataMemberAttribute]
public virtual decimal Width { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Width {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_width();
function set_width(value);

See Also

CarrierPackage Class
InSite.Model Namespace


CarrierZone Class

[image]

.NET Framework Class Library
CarrierZone Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CarrierZone _
    Inherits ModelBase(Of CarrierZone)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CarrierZone : ModelBase<CarrierZone>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CarrierZone : public ModelBase<CarrierZone^>
JavaScript
InSite.Model.CarrierZone = function();

Type.createClass(
    'InSite.Model.CarrierZone',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CarrierZone>)>)
InSite.Model..::.CarrierZone

See Also

CarrierZone Members
InSite.Model Namespace


CarrierZone Members

[image] [image]

.NET Framework Class Library
CarrierZone Members
CarrierZone Class Constructors Methods Fields Properties See Also Send Feedback

The CarrierZone type exposes the following members.

Constructors

Name | Description
CarrierZone | Overloaded.

Methods

Name | Description
AddCarrierZoneRate |
AddCarrierZoneZipCodeRange |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCarrierZoneRate |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCarrierZoneRate |
RemoveCarrierZoneZipCodeRange |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier |
CarrierZoneId |
CarrierZoneRates |
CarrierZoneZipCodeRanges |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zone |

See Also

CarrierZone Class
InSite.Model Namespace


CarrierZone Constructor

[image] [image]

.NET Framework Class Library
CarrierZone Constructor
CarrierZone Class See Also Send Feedback

Overload List

Name | Description
CarrierZone()()() |
CarrierZone(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CarrierZone Class
CarrierZone Members
InSite.Model Namespace


CarrierZone Constructor

[image]

.NET Framework Class Library
CarrierZone Constructor
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CarrierZone()
Visual C++
public:
CarrierZone()
JavaScript
InSite.Model.CarrierZone = function();

See Also

CarrierZone Class
CarrierZone Overload
InSite.Model Namespace


CarrierZone Constructor (SearchMode)

[image]

.NET Framework Class Library
CarrierZone Constructor (SearchMode)
CarrierZone Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CarrierZone(
    SearchMode searchMode
)
Visual C++
public:
CarrierZone(
    SearchMode searchMode
)
JavaScript
InSite.Model.CarrierZone = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CarrierZone Class
CarrierZone Overload
InSite.Model Namespace


CarrierZone Fields

[image] [image]

.NET Framework Class Library
CarrierZone Fields
CarrierZone Class See Also Send Feedback

The CarrierZone type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierZone Class
InSite.Model Namespace


CarrierZone Methods

[image] [image]

.NET Framework Class Library
CarrierZone Methods
CarrierZone Class See Also Send Feedback

The CarrierZone type exposes the following members.

Methods

Name | Description
AddCarrierZoneRate |
AddCarrierZoneZipCodeRange |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCarrierZoneRate |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCarrierZoneRate |
RemoveCarrierZoneZipCodeRange |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierZone Class
InSite.Model Namespace


AddCarrierZoneRate Method

[image]

.NET Framework Class Library
CarrierZone..::.AddCarrierZoneRate Method
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCarrierZoneRate ( _
    value As CarrierZoneRate _
)
C#
public virtual void AddCarrierZoneRate(
    CarrierZoneRate value
)
Visual C++
public:
virtual void AddCarrierZoneRate(
    CarrierZoneRate^ value
)
JavaScript
function addCarrierZoneRate(value);

Parameters

value
Type: InSite.Model..::.CarrierZoneRate

See Also

CarrierZone Class
InSite.Model Namespace


AddCarrierZoneZipCodeRange Method

[image]

.NET Framework Class Library
CarrierZone..::.AddCarrierZoneZipCodeRange Method
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCarrierZoneZipCodeRange ( _
    value As CarrierZoneZipCodeRange _
)
C#
public virtual void AddCarrierZoneZipCodeRange(
    CarrierZoneZipCodeRange value
)
Visual C++
public:
virtual void AddCarrierZoneZipCodeRange(
    CarrierZoneZipCodeRange^ value
)
JavaScript
function addCarrierZoneZipCodeRange(value);

Parameters

value
Type: InSite.Model..::.CarrierZoneZipCodeRange

See Also

CarrierZone Class
InSite.Model Namespace


GetCarrierZoneRate Method

[image]

.NET Framework Class Library
CarrierZone..::.GetCarrierZoneRate Method
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCarrierZoneRate ( _
    weight As Decimal _
) As CarrierZoneRate
C#
public virtual CarrierZoneRate GetCarrierZoneRate(
    decimal weight
)
Visual C++
public:
virtual CarrierZoneRate^ GetCarrierZoneRate(
    Decimal weight
)
JavaScript
function getCarrierZoneRate(weight);

Parameters

weight
Type: System..::.Decimal

See Also

CarrierZone Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
CarrierZone..::.IsValid Method
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    zipCode As String _
) As Boolean
C#
public virtual bool IsValid(
    string zipCode
)
Visual C++
public:
virtual bool IsValid(
    String^ zipCode
)
JavaScript
function isValid(zipCode);

Parameters

zipCode
Type: System..::.String

See Also

CarrierZone Class
InSite.Model Namespace


RemoveCarrierZoneRate Method

[image]

.NET Framework Class Library
CarrierZone..::.RemoveCarrierZoneRate Method
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCarrierZoneRate ( _
    value As CarrierZoneRate _
)
C#
public virtual void RemoveCarrierZoneRate(
    CarrierZoneRate value
)
Visual C++
public:
virtual void RemoveCarrierZoneRate(
    CarrierZoneRate^ value
)
JavaScript
function removeCarrierZoneRate(value);

Parameters

value
Type: InSite.Model..::.CarrierZoneRate

See Also

CarrierZone Class
InSite.Model Namespace


RemoveCarrierZoneZipCodeRange Method

[image]

.NET Framework Class Library
CarrierZone..::.RemoveCarrierZoneZipCodeRange Method
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCarrierZoneZipCodeRange ( _
    value As CarrierZoneZipCodeRange _
)
C#
public virtual void RemoveCarrierZoneZipCodeRange(
    CarrierZoneZipCodeRange value
)
Visual C++
public:
virtual void RemoveCarrierZoneZipCodeRange(
    CarrierZoneZipCodeRange^ value
)
JavaScript
function removeCarrierZoneZipCodeRange(value);

Parameters

value
Type: InSite.Model..::.CarrierZoneZipCodeRange

See Also

CarrierZone Class
InSite.Model Namespace


CarrierZone Properties

[image] [image]

.NET Framework Class Library
CarrierZone Properties
CarrierZone Class See Also Send Feedback

The CarrierZone type exposes the following members.

Properties

Name | Description
Carrier |
CarrierZoneId |
CarrierZoneRates |
CarrierZoneZipCodeRanges |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zone |

See Also

CarrierZone Class
InSite.Model Namespace


Carrier Property

[image]

.NET Framework Class Library
CarrierZone..::.Carrier Property
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Carrier As Carrier
C#
public virtual Carrier Carrier { get; set; }
Visual C++
public:
virtual property Carrier^ Carrier {
    Carrier^ get ();
    void set (Carrier^ value);
}
JavaScript
function get_carrier();
function set_carrier(value);

See Also

CarrierZone Class
InSite.Model Namespace


CarrierZoneId Property

[image]

.NET Framework Class Library
CarrierZone..::.CarrierZoneId Property
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CarrierZoneId As Guid
C#
public virtual Guid CarrierZoneId { get; set; }
Visual C++
public:
virtual property Guid CarrierZoneId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_carrierZoneId();
function set_carrierZoneId(value);

See Also

CarrierZone Class
InSite.Model Namespace


CarrierZoneRates Property

[image]

.NET Framework Class Library
CarrierZone..::.CarrierZoneRates Property
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CarrierZoneRates As ChildList(Of CarrierZoneRate)
C#
[DataMemberAttribute]
public virtual ChildList<CarrierZoneRate> CarrierZoneRates { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<CarrierZoneRate^>^ CarrierZoneRates {
    ChildList<CarrierZoneRate^>^ get ();
    void set (ChildList<CarrierZoneRate^>^ value);
}
JavaScript
function get_carrierZoneRates();
function set_carrierZoneRates(value);

See Also

CarrierZone Class
InSite.Model Namespace


CarrierZoneZipCodeRanges Property

[image]

.NET Framework Class Library
CarrierZone..::.CarrierZoneZipCodeRanges Property
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CarrierZoneZipCodeRanges As ChildList(Of CarrierZoneZipCodeRange)
C#
[DataMemberAttribute]
public virtual ChildList<CarrierZoneZipCodeRange> CarrierZoneZipCodeRanges { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<CarrierZoneZipCodeRange^>^ CarrierZoneZipCodeRanges {
    ChildList<CarrierZoneZipCodeRange^>^ get ();
    void set (ChildList<CarrierZoneZipCodeRange^>^ value);
}
JavaScript
function get_carrierZoneZipCodeRanges();
function set_carrierZoneZipCodeRanges(value);

See Also

CarrierZone Class
InSite.Model Namespace


Zone Property

[image]

.NET Framework Class Library
CarrierZone..::.Zone Property
CarrierZone Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Zone As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Zone { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Zone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zone();
function set_zone(value);

See Also

CarrierZone Class
InSite.Model Namespace


CarrierZoneRate Class

[image]

.NET Framework Class Library
CarrierZoneRate Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CarrierZoneRate _
    Inherits ModelBase(Of CarrierZoneRate)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CarrierZoneRate : ModelBase<CarrierZoneRate>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CarrierZoneRate : public ModelBase<CarrierZoneRate^>
JavaScript
InSite.Model.CarrierZoneRate = function();

Type.createClass(
    'InSite.Model.CarrierZoneRate',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CarrierZoneRate>)>)
InSite.Model..::.CarrierZoneRate

See Also

CarrierZoneRate Members
InSite.Model Namespace


CarrierZoneRate Members

[image] [image]

.NET Framework Class Library
CarrierZoneRate Members
CarrierZoneRate Class Constructors Methods Fields Properties See Also Send Feedback

The CarrierZoneRate type exposes the following members.

Constructors

Name | Description
CarrierZoneRate | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
CarrierZone |
CarrierZoneRateId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Rate |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Weight |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierZoneRate Class
InSite.Model Namespace


CarrierZoneRate Constructor

[image] [image]

.NET Framework Class Library
CarrierZoneRate Constructor
CarrierZoneRate Class See Also Send Feedback

Overload List

Name | Description
CarrierZoneRate()()() |
CarrierZoneRate(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CarrierZoneRate Class
CarrierZoneRate Members
InSite.Model Namespace


CarrierZoneRate Constructor

[image]

.NET Framework Class Library
CarrierZoneRate Constructor
CarrierZoneRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CarrierZoneRate()
Visual C++
public:
CarrierZoneRate()
JavaScript
InSite.Model.CarrierZoneRate = function();

See Also

CarrierZoneRate Class
CarrierZoneRate Overload
InSite.Model Namespace


CarrierZoneRate Constructor (SearchMode)

[image]

.NET Framework Class Library
CarrierZoneRate Constructor (SearchMode)
CarrierZoneRate Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CarrierZoneRate(
    SearchMode searchMode
)
Visual C++
public:
CarrierZoneRate(
    SearchMode searchMode
)
JavaScript
InSite.Model.CarrierZoneRate = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CarrierZoneRate Class
CarrierZoneRate Overload
InSite.Model Namespace


CarrierZoneRate Fields

[image] [image]

.NET Framework Class Library
CarrierZoneRate Fields
CarrierZoneRate Class See Also Send Feedback

The CarrierZoneRate type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierZoneRate Class
InSite.Model Namespace


CarrierZoneRate Methods

[image] [image]

.NET Framework Class Library
CarrierZoneRate Methods
CarrierZoneRate Class See Also Send Feedback

The CarrierZoneRate type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierZoneRate Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
CarrierZoneRate..::.IsValid Method
CarrierZoneRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    weight As Decimal _
) As Boolean
C#
public virtual bool IsValid(
    decimal weight
)
Visual C++
public:
virtual bool IsValid(
    Decimal weight
)
JavaScript
function isValid(weight);

Parameters

weight
Type: System..::.Decimal

See Also

CarrierZoneRate Class
InSite.Model Namespace


CarrierZoneRate Properties

[image] [image]

.NET Framework Class Library
CarrierZoneRate Properties
CarrierZoneRate Class See Also Send Feedback

The CarrierZoneRate type exposes the following members.

Properties

Name | Description
CarrierZone |
CarrierZoneRateId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Rate |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Weight |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierZoneRate Class
InSite.Model Namespace


CarrierZone Property

[image]

.NET Framework Class Library
CarrierZoneRate..::.CarrierZone Property
CarrierZoneRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CarrierZone As CarrierZone
C#
public virtual CarrierZone CarrierZone { get; set; }
Visual C++
public:
virtual property CarrierZone^ CarrierZone {
    CarrierZone^ get ();
    void set (CarrierZone^ value);
}
JavaScript
function get_carrierZone();
function set_carrierZone(value);

See Also

CarrierZoneRate Class
InSite.Model Namespace


CarrierZoneRateId Property

[image]

.NET Framework Class Library
CarrierZoneRate..::.CarrierZoneRateId Property
CarrierZoneRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CarrierZoneRateId As Guid
C#
public virtual Guid CarrierZoneRateId { get; set; }
Visual C++
public:
virtual property Guid CarrierZoneRateId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_carrierZoneRateId();
function set_carrierZoneRateId(value);

See Also

CarrierZoneRate Class
InSite.Model Namespace


Rate Property

[image]

.NET Framework Class Library
CarrierZoneRate..::.Rate Property
CarrierZoneRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Rate As Decimal
C#
[DataMemberAttribute]
public virtual decimal Rate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Rate {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_rate();
function set_rate(value);

See Also

CarrierZoneRate Class
InSite.Model Namespace


Weight Property

[image]

.NET Framework Class Library
CarrierZoneRate..::.Weight Property
CarrierZoneRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Weight As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Weight { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_weight();
function set_weight(value);

See Also

CarrierZoneRate Class
InSite.Model Namespace


CarrierZoneZipCodeRange Class

[image]

.NET Framework Class Library
CarrierZoneZipCodeRange Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CarrierZoneZipCodeRange _
    Inherits ModelBase(Of CarrierZoneZipCodeRange)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CarrierZoneZipCodeRange : ModelBase<CarrierZoneZipCodeRange>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CarrierZoneZipCodeRange : public ModelBase<CarrierZoneZipCodeRange^>
JavaScript
InSite.Model.CarrierZoneZipCodeRange = function();

Type.createClass(
    'InSite.Model.CarrierZoneZipCodeRange',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CarrierZoneZipCodeRange>)>)
InSite.Model..::.CarrierZoneZipCodeRange

See Also

CarrierZoneZipCodeRange Members
InSite.Model Namespace


CarrierZoneZipCodeRange Members

[image] [image]

.NET Framework Class Library
CarrierZoneZipCodeRange Members
CarrierZoneZipCodeRange Class Constructors Methods Fields Properties See Also Send Feedback

The CarrierZoneZipCodeRange type exposes the following members.

Constructors

Name | Description
CarrierZoneZipCodeRange | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
CarrierZone |
CarrierZoneZipCodeRangeId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
ZipEndRange |
ZipStartRange |

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


CarrierZoneZipCodeRange Constructor

[image] [image]

.NET Framework Class Library
CarrierZoneZipCodeRange Constructor
CarrierZoneZipCodeRange Class See Also Send Feedback

Overload List

Name | Description
CarrierZoneZipCodeRange()()() |
CarrierZoneZipCodeRange(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CarrierZoneZipCodeRange Class
CarrierZoneZipCodeRange Members
InSite.Model Namespace


CarrierZoneZipCodeRange Constructor

[image]

.NET Framework Class Library
CarrierZoneZipCodeRange Constructor
CarrierZoneZipCodeRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CarrierZoneZipCodeRange()
Visual C++
public:
CarrierZoneZipCodeRange()
JavaScript
InSite.Model.CarrierZoneZipCodeRange = function();

See Also

CarrierZoneZipCodeRange Class
CarrierZoneZipCodeRange Overload
InSite.Model Namespace


CarrierZoneZipCodeRange Constructor (SearchMode)

[image]

.NET Framework Class Library
CarrierZoneZipCodeRange Constructor (SearchMode)
CarrierZoneZipCodeRange Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CarrierZoneZipCodeRange(
    SearchMode searchMode
)
Visual C++
public:
CarrierZoneZipCodeRange(
    SearchMode searchMode
)
JavaScript
InSite.Model.CarrierZoneZipCodeRange = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CarrierZoneZipCodeRange Class
CarrierZoneZipCodeRange Overload
InSite.Model Namespace


CarrierZoneZipCodeRange Fields

[image] [image]

.NET Framework Class Library
CarrierZoneZipCodeRange Fields
CarrierZoneZipCodeRange Class See Also Send Feedback

The CarrierZoneZipCodeRange type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


CarrierZoneZipCodeRange Methods

[image] [image]

.NET Framework Class Library
CarrierZoneZipCodeRange Methods
CarrierZoneZipCodeRange Class See Also Send Feedback

The CarrierZoneZipCodeRange type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
CarrierZoneZipCodeRange..::.IsValid Method
CarrierZoneZipCodeRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    zipCode As String _
) As Boolean
C#
public virtual bool IsValid(
    string zipCode
)
Visual C++
public:
virtual bool IsValid(
    String^ zipCode
)
JavaScript
function isValid(zipCode);

Parameters

zipCode
Type: System..::.String

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


CarrierZoneZipCodeRange Properties

[image] [image]

.NET Framework Class Library
CarrierZoneZipCodeRange Properties
CarrierZoneZipCodeRange Class See Also Send Feedback

The CarrierZoneZipCodeRange type exposes the following members.

Properties

Name | Description
CarrierZone |
CarrierZoneZipCodeRangeId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
ZipEndRange |
ZipStartRange |

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


CarrierZone Property

[image]

.NET Framework Class Library
CarrierZoneZipCodeRange..::.CarrierZone Property
CarrierZoneZipCodeRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CarrierZone As CarrierZone
C#
public virtual CarrierZone CarrierZone { get; set; }
Visual C++
public:
virtual property CarrierZone^ CarrierZone {
    CarrierZone^ get ();
    void set (CarrierZone^ value);
}
JavaScript
function get_carrierZone();
function set_carrierZone(value);

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


CarrierZoneZipCodeRangeId Property

[image]

.NET Framework Class Library
CarrierZoneZipCodeRange..::.CarrierZoneZipCodeRangeId Property
CarrierZoneZipCodeRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CarrierZoneZipCodeRangeId As Guid
C#
public virtual Guid CarrierZoneZipCodeRangeId { get; set; }
Visual C++
public:
virtual property Guid CarrierZoneZipCodeRangeId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_carrierZoneZipCodeRangeId();
function set_carrierZoneZipCodeRangeId(value);

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


ZipEndRange Property

[image]

.NET Framework Class Library
CarrierZoneZipCodeRange..::.ZipEndRange Property
CarrierZoneZipCodeRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ZipEndRange As String
C#
[DataMemberAttribute]
public virtual string ZipEndRange { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ZipEndRange {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zipEndRange();
function set_zipEndRange(value);

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


ZipStartRange Property

[image]

.NET Framework Class Library
CarrierZoneZipCodeRange..::.ZipStartRange Property
CarrierZoneZipCodeRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property ZipStartRange As String
C#
[DataMemberAttribute]
[SortField]
public virtual string ZipStartRange { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ ZipStartRange {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zipStartRange();
function set_zipStartRange(value);

See Also

CarrierZoneZipCodeRange Class
InSite.Model Namespace


Category Class

[image]

.NET Framework Class Library
Category Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Category _
    Inherits ModelBase(Of Category)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Category : ModelBase<Category>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Category : public ModelBase<Category^>
JavaScript
InSite.Model.Category = function();

Type.createClass(
    'InSite.Model.Category',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Category>)>)
InSite.Model..::.Category

See Also

Category Members
InSite.Model Namespace


Category Members

[image] [image]

.NET Framework Class Library
Category Members
Category Class Constructors Methods Fields Properties See Also Send Feedback

The Category type exposes the following members.

Constructors

Name | Description
Category | Overloaded.

Methods

Name | Description
AddCategoryFilterSection |
AddCategoryProperty |
AddConfigSection |
AddCrossSell |
AddDealer |
AddDocument |
AddFilterValue |
AddProduct |
AddProductInfo |
AddRestriction |
AddSpecification |
AddSubCategory |
AddTaxExemption |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetActiveProducts | Overloaded.
GetByName |
GetCategoryProperty |
GetConfigSections |
GetFilteredList |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetSectionOption |
GetSectionOptions |
GetSpecification |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PassesRestrictions |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategoryFilterSection |
RemoveCategoryProperty |
RemoveConfigSection |
RemoveCrossSell |
RemoveDealer |
RemoveDocument |
RemoveFilterValue |
RemoveProduct |
RemoveProductInfo |
RemoveRestriction |
RemoveSpecification |
RemoveSubCategory |
RemoveTaxExemption |
SaveConfigDataSet |
ToString | (Overrides Object..::.ToString()()().)
UpdateConfigSection |
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
ActiveCategoryFilterSections |
ActiveCrossSells |
ActiveProducts |
ActiveProductsCount |
ActiveSubCategories |
CategoryFilterSections |
CategoryId |
CategoryProperties |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ConfigDataSet |
ConfigSectionArray |
ContentManager |
CrossSells |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Dealers |
Description |
DocumentManager |
Documents |
ERPProductValues |
FilterValues |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsConfigured |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LargeImagePath |
MetaDescription |
MetaTags |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PageTitle |
ParentCategory |
ParentCategoryName |
ParentWebSiteName |
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Restrictions |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortDescription |
ShowDetail |
SmallImagePath |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
Specifications |
StyleSheet |
SubCategories |
TaxExemptions |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Category Class
InSite.Model Namespace


Category Constructor

[image] [image]

.NET Framework Class Library
Category Constructor
Category Class See Also Send Feedback

Overload List

Name | Description
Category()()() |
Category(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Category Class
Category Members
InSite.Model Namespace


Category Constructor

[image]

.NET Framework Class Library
Category Constructor
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Category()
Visual C++
public:
Category()
JavaScript
InSite.Model.Category = function();

See Also

Category Class
Category Overload
InSite.Model Namespace


Category Constructor (SearchMode)

[image]

.NET Framework Class Library
Category Constructor (SearchMode)
Category Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Category(
    SearchMode searchMode
)
Visual C++
public:
Category(
    SearchMode searchMode
)
JavaScript
InSite.Model.Category = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Category Class
Category Overload
InSite.Model Namespace


Category Fields

[image] [image]

.NET Framework Class Library
Category Fields
Category Class See Also Send Feedback

The Category type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Category Class
InSite.Model Namespace


Category Methods

[image] [image]

.NET Framework Class Library
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

Name | Description
AddCategoryFilterSection |
AddCategoryProperty |
AddConfigSection |
AddCrossSell |
AddDealer |
AddDocument |
AddFilterValue |
AddProduct |
AddProductInfo |
AddRestriction |
AddSpecification |
AddSubCategory |
AddTaxExemption |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetActiveProducts | Overloaded.
GetByName |
GetCategoryProperty |
GetConfigSections |
GetFilteredList |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetSectionOption |
GetSectionOptions |
GetSpecification |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PassesRestrictions |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategoryFilterSection |
RemoveCategoryProperty |
RemoveConfigSection |
RemoveCrossSell |
RemoveDealer |
RemoveDocument |
RemoveFilterValue |
RemoveProduct |
RemoveProductInfo |
RemoveRestriction |
RemoveSpecification |
RemoveSubCategory |
RemoveTaxExemption |
SaveConfigDataSet |
ToString | (Overrides Object..::.ToString()()().)
UpdateConfigSection |
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Category Class
InSite.Model Namespace


AddCategoryFilterSection Method

[image]

.NET Framework Class Library
Category..::.AddCategoryFilterSection Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategoryFilterSection ( _
    value As CategoryFilterSection _
)
C#
public virtual void AddCategoryFilterSection(
    CategoryFilterSection value
)
Visual C++
public:
virtual void AddCategoryFilterSection(
    CategoryFilterSection^ value
)
JavaScript
function addCategoryFilterSection(value);

Parameters

value
Type: InSite.Model..::.CategoryFilterSection

See Also

Category Class
InSite.Model Namespace


AddCategoryProperty Method

[image]

.NET Framework Class Library
Category..::.AddCategoryProperty Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategoryProperty ( _
    value As CategoryProperty _
)
C#
public virtual void AddCategoryProperty(
    CategoryProperty value
)
Visual C++
public:
virtual void AddCategoryProperty(
    CategoryProperty^ value
)
JavaScript
function addCategoryProperty(value);

Parameters

value
Type: InSite.Model..::.CategoryProperty

See Also

Category Class
InSite.Model Namespace


AddConfigSection Method

[image]

.NET Framework Class Library
Category..::.AddConfigSection Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddConfigSection ( _
    sectionName As String _
)
C#
public virtual void AddConfigSection(
    string sectionName
)
Visual C++
public:
virtual void AddConfigSection(
    String^ sectionName
)
JavaScript
function addConfigSection(sectionName);

Parameters

sectionName
Type: System..::.String

See Also

Category Class
InSite.Model Namespace


AddCrossSell Method

[image]

.NET Framework Class Library
Category..::.AddCrossSell Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCrossSell ( _
    value As ProductInfo _
)
C#
public virtual void AddCrossSell(
    ProductInfo value
)
Visual C++
public:
virtual void AddCrossSell(
    ProductInfo^ value
)
JavaScript
function addCrossSell(value);

Parameters

value
Type: InSite.Model..::.ProductInfo

See Also

Category Class
InSite.Model Namespace


AddDealer Method

[image]

.NET Framework Class Library
Category..::.AddDealer Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddDealer ( _
    value As Dealer _
)
C#
public virtual void AddDealer(
    Dealer value
)
Visual C++
public:
virtual void AddDealer(
    Dealer^ value
)
JavaScript
function addDealer(value);

Parameters

value
Type: InSite.Model..::.Dealer

See Also

Category Class
InSite.Model Namespace


AddDocument Method

[image]

.NET Framework Class Library
Category..::.AddDocument Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddDocument ( _
    value As Document _
)
C#
public virtual void AddDocument(
    Document value
)
Visual C++
public:
virtual void AddDocument(
    Document^ value
)
JavaScript
function addDocument(value);

Parameters

value
Type: InSite.Model..::.Document

See Also

Category Class
InSite.Model Namespace


AddFilterValue Method

[image]

.NET Framework Class Library
Category..::.AddFilterValue Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddFilterValue ( _
    value As FilterValue _
)
C#
public virtual void AddFilterValue(
    FilterValue value
)
Visual C++
public:
virtual void AddFilterValue(
    FilterValue^ value
)
JavaScript
function addFilterValue(value);

Parameters

value
Type: InSite.Model..::.FilterValue

See Also

Category Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
Category..::.AddProduct Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    product As Product _
)
C#
public virtual void AddProduct(
    Product product
)
Visual C++
public:
virtual void AddProduct(
    Product^ product
)
JavaScript
function addProduct(product);

Parameters

product
Type: InSite.Model..::.Product

See Also

Category Class
InSite.Model Namespace


AddProductInfo Method

[image]

.NET Framework Class Library
Category..::.AddProductInfo Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProductInfo ( _
    productInfo As ProductInfo _
)
C#
public virtual void AddProductInfo(
    ProductInfo productInfo
)
Visual C++
public:
virtual void AddProductInfo(
    ProductInfo^ productInfo
)
JavaScript
function addProductInfo(productInfo);

Parameters

productInfo
Type: InSite.Model..::.ProductInfo

See Also

Category Class
InSite.Model Namespace


AddRestriction Method

[image]

.NET Framework Class Library
Category..::.AddRestriction Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRestriction ( _
    value As Restriction _
)
C#
public virtual void AddRestriction(
    Restriction value
)
Visual C++
public:
virtual void AddRestriction(
    Restriction^ value
)
JavaScript
function addRestriction(value);

Parameters

value
Type: InSite.Model..::.Restriction

See Also

Category Class
InSite.Model Namespace


AddSpecification Method

[image]

.NET Framework Class Library
Category..::.AddSpecification Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddSpecification ( _
    value As Specification _
)
C#
public virtual void AddSpecification(
    Specification value
)
Visual C++
public:
virtual void AddSpecification(
    Specification^ value
)
JavaScript
function addSpecification(value);

Parameters

value
Type: InSite.Model..::.Specification

See Also

Category Class
InSite.Model Namespace


AddSubCategory Method

[image]

.NET Framework Class Library
Category..::.AddSubCategory Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddSubCategory ( _
    value As Category _
)
C#
public virtual void AddSubCategory(
    Category value
)
Visual C++
public:
virtual void AddSubCategory(
    Category^ value
)
JavaScript
function addSubCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

Category Class
InSite.Model Namespace


AddTaxExemption Method

[image]

.NET Framework Class Library
Category..::.AddTaxExemption Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddTaxExemption ( _
    value As TaxExemption _
)
C#
public virtual void AddTaxExemption(
    TaxExemption value
)
Visual C++
public:
virtual void AddTaxExemption(
    TaxExemption^ value
)
JavaScript
function addTaxExemption(value);

Parameters

value
Type: InSite.Model..::.TaxExemption

See Also

Category Class
InSite.Model Namespace


GetActiveProducts Method

[image] [image]

.NET Framework Class Library
Category..::.GetActiveProducts Method
Category Class See Also Send Feedback

Overload List

Name | Description
GetActiveProducts(Int32, Int32) | Retrives a SortOrder, Name sorted list of Products in this category that are currently active. Provides parameters for use with an ObjectDataSource paging.
GetActiveProducts(Int32, Int32, String) | Retrives a list of Products in this category that are currently active. Provides parameters for use with an ObjectDataSource paging.

See Also

Category Class
Category Members
InSite.Model Namespace


GetActiveProducts Method (Int32, Int32)

[image]

.NET Framework Class Library
Category..::.GetActiveProducts Method (Int32, Int32)
Category Class See Also Send Feedback

Retrives a SortOrder, Name sorted list of Products in this category that are currently active. Provides parameters for use with an ObjectDataSource paging.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetActiveProducts ( _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of ProductInfo)
C#
public virtual IList<ProductInfo> GetActiveProducts(
    int startRow,
    int pageSize
)
Visual C++
public:
virtual IList<ProductInfo^>^ GetActiveProducts(
    int startRow,
    int pageSize
)
JavaScript
function getActiveProducts(startRow, pageSize);

Parameters

startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

Return Value

List of Products pulled from Category.Products

See Also

Category Class
GetActiveProducts Overload
InSite.Model Namespace


GetActiveProducts Method (Int32, Int32, String)

[image]

.NET Framework Class Library
Category..::.GetActiveProducts Method (Int32, Int32, String)
Category Class See Also Send Feedback

Retrives a list of Products in this category that are currently active. Provides parameters for use with an ObjectDataSource paging.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetActiveProducts ( _
    startRow As Integer, _
    pageSize As Integer, _
    sort As String _
) As IList(Of ProductInfo)
C#
public virtual IList<ProductInfo> GetActiveProducts(
    int startRow,
    int pageSize,
    string sort
)
Visual C++
public:
virtual IList<ProductInfo^>^ GetActiveProducts(
    int startRow,
    int pageSize,
    String^ sort
)
JavaScript
function getActiveProducts(startRow, pageSize, sort);

Parameters

startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32
sort
Type: System..::.String
Sort

Return Value

List of Products pulled from Category.Products

See Also

Category Class
GetActiveProducts Overload
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
Category..::.GetByName Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    categoryName As String _
) As Category
C#
public static Category GetByName(
    string categoryName
)
Visual C++
public:
static Category^ GetByName(
    String^ categoryName
)
JavaScript
InSite.Model.Category.getByName = function(categoryName);

Parameters

categoryName
Type: System..::.String

See Also

Category Class
InSite.Model Namespace


GetCategoryProperty Method

[image]

.NET Framework Class Library
Category..::.GetCategoryProperty Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCategoryProperty ( _
    name As String _
) As CategoryProperty
C#
public virtual CategoryProperty GetCategoryProperty(
    string name
)
Visual C++
public:
virtual CategoryProperty^ GetCategoryProperty(
    String^ name
)
JavaScript
function getCategoryProperty(name);

Parameters

name
Type: System..::.String

See Also

Category Class
InSite.Model Namespace


GetConfigSections Method

[image]

.NET Framework Class Library
Category..::.GetConfigSections Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetConfigSections As DataRowCollection
C#
public virtual DataRowCollection GetConfigSections()
Visual C++
public:
virtual DataRowCollection^ GetConfigSections()
JavaScript
function getConfigSections();

See Also

Category Class
InSite.Model Namespace


GetFilteredList Method

[image]

.NET Framework Class Library
Category..::.GetFilteredList Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFilteredList ( _
    filterValues As IList(Of FilterValue), _
    sort As String, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of Category)
C#
public static IList<Category> GetFilteredList(
    IList<FilterValue> filterValues,
    string sort,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<Category^>^ GetFilteredList(
    IList<FilterValue^>^ filterValues,
    String^ sort,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.Category.getFilteredList = function(filterValues, sort, startRow, pageSize);

Parameters

filterValues
Type: System.Collections.Generic..::.IList <(Of <( FilterValue >)>)
sort
Type: System..::.String
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

Category Class
InSite.Model Namespace


GetSectionOption Method

[image]

.NET Framework Class Library
Category..::.GetSectionOption Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSectionOption ( _
    sectionName As String, _
    productName As String _
) As DataRow
C#
public virtual DataRow GetSectionOption(
    string sectionName,
    string productName
)
Visual C++
public:
virtual DataRow^ GetSectionOption(
    String^ sectionName,
    String^ productName
)
JavaScript
function getSectionOption(sectionName, productName);

Parameters

sectionName
Type: System..::.String
productName
Type: System..::.String

See Also

Category Class
InSite.Model Namespace


GetSectionOptions Method

[image]

.NET Framework Class Library
Category..::.GetSectionOptions Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSectionOptions ( _
    sectionName As String _
) As OrderedEnumerableRowCollection(Of DataRow)
C#
public virtual OrderedEnumerableRowCollection<DataRow> GetSectionOptions(
    string sectionName
)
Visual C++
public:
virtual OrderedEnumerableRowCollection<DataRow^>^ GetSectionOptions(
    String^ sectionName
)
JavaScript
function getSectionOptions(sectionName);

Parameters

sectionName
Type: System..::.String

See Also

Category Class
InSite.Model Namespace


GetSpecification Method

[image]

.NET Framework Class Library
Category..::.GetSpecification Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSpecification ( _
    name As String _
) As Specification
C#
public virtual Specification GetSpecification(
    string name
)
Visual C++
public:
virtual Specification^ GetSpecification(
    String^ name
)
JavaScript
function getSpecification(name);

Parameters

name
Type: System..::.String

See Also

Category Class
InSite.Model Namespace


PassesRestrictions Method

[image]

.NET Framework Class Library
Category..::.PassesRestrictions Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function PassesRestrictions ( _
    customerOrder As CustomerOrder _
) As Boolean
C#
public virtual bool PassesRestrictions(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual bool PassesRestrictions(
    CustomerOrder^ customerOrder
)
JavaScript
function passesRestrictions(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Category Class
InSite.Model Namespace


RemoveCategoryFilterSection Method

[image]

.NET Framework Class Library
Category..::.RemoveCategoryFilterSection Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategoryFilterSection ( _
    value As CategoryFilterSection _
)
C#
public virtual void RemoveCategoryFilterSection(
    CategoryFilterSection value
)
Visual C++
public:
virtual void RemoveCategoryFilterSection(
    CategoryFilterSection^ value
)
JavaScript
function removeCategoryFilterSection(value);

Parameters

value
Type: InSite.Model..::.CategoryFilterSection

See Also

Category Class
InSite.Model Namespace


RemoveCategoryProperty Method

[image]

.NET Framework Class Library
Category..::.RemoveCategoryProperty Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategoryProperty ( _
    value As CategoryProperty _
)
C#
public virtual void RemoveCategoryProperty(
    CategoryProperty value
)
Visual C++
public:
virtual void RemoveCategoryProperty(
    CategoryProperty^ value
)
JavaScript
function removeCategoryProperty(value);

Parameters

value
Type: InSite.Model..::.CategoryProperty

See Also

Category Class
InSite.Model Namespace


RemoveConfigSection Method

[image]

.NET Framework Class Library
Category..::.RemoveConfigSection Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveConfigSection ( _
    sectionName As String _
)
C#
public virtual void RemoveConfigSection(
    string sectionName
)
Visual C++
public:
virtual void RemoveConfigSection(
    String^ sectionName
)
JavaScript
function removeConfigSection(sectionName);

Parameters

sectionName
Type: System..::.String

See Also

Category Class
InSite.Model Namespace


RemoveCrossSell Method

[image]

.NET Framework Class Library
Category..::.RemoveCrossSell Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCrossSell ( _
    value As ProductInfo _
)
C#
public virtual void RemoveCrossSell(
    ProductInfo value
)
Visual C++
public:
virtual void RemoveCrossSell(
    ProductInfo^ value
)
JavaScript
function removeCrossSell(value);

Parameters

value
Type: InSite.Model..::.ProductInfo

See Also

Category Class
InSite.Model Namespace


RemoveDealer Method

[image]

.NET Framework Class Library
Category..::.RemoveDealer Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveDealer ( _
    value As Dealer _
)
C#
public virtual void RemoveDealer(
    Dealer value
)
Visual C++
public:
virtual void RemoveDealer(
    Dealer^ value
)
JavaScript
function removeDealer(value);

Parameters

value
Type: InSite.Model..::.Dealer

See Also

Category Class
InSite.Model Namespace


RemoveDocument Method

[image]

.NET Framework Class Library
Category..::.RemoveDocument Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveDocument ( _
    value As Document _
)
C#
public virtual void RemoveDocument(
    Document value
)
Visual C++
public:
virtual void RemoveDocument(
    Document^ value
)
JavaScript
function removeDocument(value);

Parameters

value
Type: InSite.Model..::.Document

See Also

Category Class
InSite.Model Namespace


RemoveFilterValue Method

[image]

.NET Framework Class Library
Category..::.RemoveFilterValue Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveFilterValue ( _
    value As FilterValue _
)
C#
public virtual void RemoveFilterValue(
    FilterValue value
)
Visual C++
public:
virtual void RemoveFilterValue(
    FilterValue^ value
)
JavaScript
function removeFilterValue(value);

Parameters

value
Type: InSite.Model..::.FilterValue

See Also

Category Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
Category..::.RemoveProduct Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    product As Product _
)
C#
public virtual void RemoveProduct(
    Product product
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ product
)
JavaScript
function removeProduct(product);

Parameters

product
Type: InSite.Model..::.Product

See Also

Category Class
InSite.Model Namespace


RemoveProductInfo Method

[image]

.NET Framework Class Library
Category..::.RemoveProductInfo Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProductInfo ( _
    productInfo As ProductInfo _
)
C#
public virtual void RemoveProductInfo(
    ProductInfo productInfo
)
Visual C++
public:
virtual void RemoveProductInfo(
    ProductInfo^ productInfo
)
JavaScript
function removeProductInfo(productInfo);

Parameters

productInfo
Type: InSite.Model..::.ProductInfo

See Also

Category Class
InSite.Model Namespace


RemoveRestriction Method

[image]

.NET Framework Class Library
Category..::.RemoveRestriction Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveRestriction ( _
    value As Restriction _
)
C#
public virtual void RemoveRestriction(
    Restriction value
)
Visual C++
public:
virtual void RemoveRestriction(
    Restriction^ value
)
JavaScript
function removeRestriction(value);

Parameters

value
Type: InSite.Model..::.Restriction

See Also

Category Class
InSite.Model Namespace


RemoveSpecification Method

[image]

.NET Framework Class Library
Category..::.RemoveSpecification Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSpecification ( _
    value As Specification _
)
C#
public virtual void RemoveSpecification(
    Specification value
)
Visual C++
public:
virtual void RemoveSpecification(
    Specification^ value
)
JavaScript
function removeSpecification(value);

Parameters

value
Type: InSite.Model..::.Specification

See Also

Category Class
InSite.Model Namespace


RemoveSubCategory Method

[image]

.NET Framework Class Library
Category..::.RemoveSubCategory Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSubCategory ( _
    value As Category _
)
C#
public virtual void RemoveSubCategory(
    Category value
)
Visual C++
public:
virtual void RemoveSubCategory(
    Category^ value
)
JavaScript
function removeSubCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

Category Class
InSite.Model Namespace


RemoveTaxExemption Method

[image]

.NET Framework Class Library
Category..::.RemoveTaxExemption Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveTaxExemption ( _
    value As TaxExemption _
)
C#
public virtual void RemoveTaxExemption(
    TaxExemption value
)
Visual C++
public:
virtual void RemoveTaxExemption(
    TaxExemption^ value
)
JavaScript
function removeTaxExemption(value);

Parameters

value
Type: InSite.Model..::.TaxExemption

See Also

Category Class
InSite.Model Namespace


SaveConfigDataSet Method

[image]

.NET Framework Class Library
Category..::.SaveConfigDataSet Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveConfigDataSet
C#
public virtual void SaveConfigDataSet()
Visual C++
public:
virtual void SaveConfigDataSet()
JavaScript
function saveConfigDataSet();

See Also

Category Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
Category..::.ToString Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

Category Class
InSite.Model Namespace


UpdateConfigSection Method

[image]

.NET Framework Class Library
Category..::.UpdateConfigSection Method
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub UpdateConfigSection ( _
    oldSectionName As String, _
    newSectionName As String _
)
C#
public virtual void UpdateConfigSection(
    string oldSectionName,
    string newSectionName
)
Visual C++
public:
virtual void UpdateConfigSection(
    String^ oldSectionName,
    String^ newSectionName
)
JavaScript
function updateConfigSection(oldSectionName, newSectionName);

Parameters

oldSectionName
Type: System..::.String
newSectionName
Type: System..::.String

See Also

Category Class
InSite.Model Namespace


Category Properties

[image] [image]

.NET Framework Class Library
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

Name | Description
Active |
ActiveCategoryFilterSections |
ActiveCrossSells |
ActiveProducts |
ActiveProductsCount |
ActiveSubCategories |
CategoryFilterSections |
CategoryId |
CategoryProperties |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ConfigDataSet |
ConfigSectionArray |
ContentManager |
CrossSells |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Dealers |
Description |
DocumentManager |
Documents |
ERPProductValues |
FilterValues |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsConfigured |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LargeImagePath |
MetaDescription |
MetaTags |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PageTitle |
ParentCategory |
ParentCategoryName |
ParentWebSiteName |
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Restrictions |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortDescription |
ShowDetail |
SmallImagePath |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
Specifications |
StyleSheet |
SubCategories |
TaxExemptions |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Category Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
Category..::.Active Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

Category Class
InSite.Model Namespace


ActiveCategoryFilterSections Property

[image]

.NET Framework Class Library
Category..::.ActiveCategoryFilterSections Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveCategoryFilterSections As ChildList(Of CategoryFilterSection)
C#
public virtual ChildList<CategoryFilterSection> ActiveCategoryFilterSections { get; }
Visual C++
public:
virtual property ChildList<CategoryFilterSection^>^ ActiveCategoryFilterSections {
    ChildList<CategoryFilterSection^>^ get ();
}
JavaScript
function get_activeCategoryFilterSections();

See Also

Category Class
InSite.Model Namespace


ActiveCrossSells Property

[image]

.NET Framework Class Library
Category..::.ActiveCrossSells Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveCrossSells As ChildList(Of ProductInfo)
C#
public virtual ChildList<ProductInfo> ActiveCrossSells { get; }
Visual C++
public:
virtual property ChildList<ProductInfo^>^ ActiveCrossSells {
    ChildList<ProductInfo^>^ get ();
}
JavaScript
function get_activeCrossSells();

See Also

Category Class
InSite.Model Namespace


ActiveProducts Property

[image]

.NET Framework Class Library
Category..::.ActiveProducts Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveProducts As ChildList(Of ProductInfo)
C#
public virtual ChildList<ProductInfo> ActiveProducts { get; }
Visual C++
public:
virtual property ChildList<ProductInfo^>^ ActiveProducts {
    ChildList<ProductInfo^>^ get ();
}
JavaScript
function get_activeProducts();

See Also

Category Class
InSite.Model Namespace


ActiveProductsCount Property

[image]

.NET Framework Class Library
Category..::.ActiveProductsCount Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveProductsCount As Integer
C#
public virtual int ActiveProductsCount { get; }
Visual C++
public:
virtual property int ActiveProductsCount {
    int get ();
}
JavaScript
function get_activeProductsCount();

See Also

Category Class
InSite.Model Namespace


ActiveSubCategories Property

[image]

.NET Framework Class Library
Category..::.ActiveSubCategories Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveSubCategories As ChildList(Of Category)
C#
public virtual ChildList<Category> ActiveSubCategories { get; }
Visual C++
public:
virtual property ChildList<Category^>^ ActiveSubCategories {
    ChildList<Category^>^ get ();
}
JavaScript
function get_activeSubCategories();

See Also

Category Class
InSite.Model Namespace


CategoryFilterSections Property

[image]

.NET Framework Class Library
Category..::.CategoryFilterSections Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CategoryFilterSections As ChildList(Of CategoryFilterSection)
C#
public virtual ChildList<CategoryFilterSection> CategoryFilterSections { get; private set; }
Visual C++
public:
virtual property ChildList<CategoryFilterSection^>^ CategoryFilterSections {
    ChildList<CategoryFilterSection^>^ get ();
    void set (ChildList<CategoryFilterSection^>^ value);
}
JavaScript
function get_categoryFilterSections();
function set_categoryFilterSections(value);

See Also

Category Class
InSite.Model Namespace


CategoryId Property

[image]

.NET Framework Class Library
Category..::.CategoryId Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CategoryId As Guid
C#
public virtual Guid CategoryId { get; set; }
Visual C++
public:
virtual property Guid CategoryId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_categoryId();
function set_categoryId(value);

See Also

Category Class
InSite.Model Namespace


CategoryProperties Property

[image]

.NET Framework Class Library
Category..::.CategoryProperties Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CategoryProperties As ChildList(Of CategoryProperty)
C#
[DataMemberAttribute]
public virtual ChildList<CategoryProperty> CategoryProperties { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<CategoryProperty^>^ CategoryProperties {
    ChildList<CategoryProperty^>^ get ();
    void set (ChildList<CategoryProperty^>^ value);
}
JavaScript
function get_categoryProperties();
function set_categoryProperties(value);

See Also

Category Class
InSite.Model Namespace


ConfigDataSet Property

[image]

.NET Framework Class Library
Category..::.ConfigDataSet Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ConfigDataSet As DataSet
C#
public virtual DataSet ConfigDataSet { get; set; }
Visual C++
public:
virtual property DataSet^ ConfigDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_configDataSet();
function set_configDataSet(value);

See Also

Category Class
InSite.Model Namespace


ConfigSectionArray Property

[image]

.NET Framework Class Library
Category..::.ConfigSectionArray Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ConfigSectionArray As ArrayList
C#
public virtual ArrayList ConfigSectionArray { get; }
Visual C++
public:
virtual property ArrayList^ ConfigSectionArray {
    ArrayList^ get ();
}
JavaScript
function get_configSectionArray();

See Also

Category Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
Category..::.ContentManager Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

Category Class
InSite.Model Namespace


CrossSells Property

[image]

.NET Framework Class Library
Category..::.CrossSells Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CrossSells As ChildList(Of ProductInfo)
C#
[DataMemberAttribute]
public virtual ChildList<ProductInfo> CrossSells { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ProductInfo^>^ CrossSells {
    ChildList<ProductInfo^>^ get ();
    void set (ChildList<ProductInfo^>^ value);
}
JavaScript
function get_crossSells();
function set_crossSells(value);

See Also

Category Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
Category..::.Deactivate Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

Category Class
InSite.Model Namespace


Dealers Property

[image]

.NET Framework Class Library
Category..::.Dealers Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Dealers As ChildList(Of Dealer)
C#
public virtual ChildList<Dealer> Dealers { get; private set; }
Visual C++
public:
virtual property ChildList<Dealer^>^ Dealers {
    ChildList<Dealer^>^ get ();
    void set (ChildList<Dealer^>^ value);
}
JavaScript
function get_dealers();
function set_dealers(value);

See Also

Category Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Category..::.Description Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Description As String
C#
public virtual string Description { get; set; }
Visual C++
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Category Class
InSite.Model Namespace


DocumentManager Property

[image]

.NET Framework Class Library
Category..::.DocumentManager Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SaveChildren> _
<DataMemberAttribute> _
Public Overridable Property DocumentManager As DocumentManager
C#
[SaveChildren]
[DataMemberAttribute]
public virtual DocumentManager DocumentManager { get; set; }
Visual C++
[SaveChildren]
[DataMemberAttribute]
public:
virtual property DocumentManager^ DocumentManager {
    DocumentManager^ get ();
    void set (DocumentManager^ value);
}
JavaScript
function get_documentManager();
function set_documentManager(value);

See Also

Category Class
InSite.Model Namespace


Documents Property

[image]

.NET Framework Class Library
Category..::.Documents Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Documents As ChildList(Of Document)
C#
public virtual ChildList<Document> Documents { get; set; }
Visual C++
public:
virtual property ChildList<Document^>^ Documents {
    ChildList<Document^>^ get ();
    void set (ChildList<Document^>^ value);
}
JavaScript
function get_documents();
function set_documents(value);

See Also

Category Class
InSite.Model Namespace


ERPProductValues Property

[image]

.NET Framework Class Library
Category..::.ERPProductValues Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPProductValues As String
C#
[DataMemberAttribute]
public virtual string ERPProductValues { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPProductValues {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpProductValues();
function set_erpProductValues(value);

See Also

Category Class
InSite.Model Namespace


FilterValues Property

[image]

.NET Framework Class Library
Category..::.FilterValues Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FilterValues As ChildList(Of FilterValue)
C#
public virtual ChildList<FilterValue> FilterValues { get; private set; }
Visual C++
public:
virtual property ChildList<FilterValue^>^ FilterValues {
    ChildList<FilterValue^>^ get ();
    void set (ChildList<FilterValue^>^ value);
}
JavaScript
function get_filterValues();
function set_filterValues(value);

See Also

Category Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
Category..::.HtmlContent Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HtmlContent As String
C#
[DataMemberAttribute]
public virtual string HtmlContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

Category Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
Category..::.IsActive Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

Category Class
InSite.Model Namespace


IsConfigured Property

[image]

.NET Framework Class Library
Category..::.IsConfigured Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property IsConfigured As Boolean
C#
public virtual bool IsConfigured { get; set; }
Visual C++
public:
virtual property bool IsConfigured {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isConfigured();
function set_isConfigured(value);

See Also

Category Class
InSite.Model Namespace


LargeImagePath Property

[image]

.NET Framework Class Library
Category..::.LargeImagePath Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LargeImagePath As String
C#
[DataMemberAttribute]
public virtual string LargeImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LargeImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_largeImagePath();
function set_largeImagePath(value);

See Also

Category Class
InSite.Model Namespace


MetaDescription Property

[image]

.NET Framework Class Library
Category..::.MetaDescription Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MetaDescription As String
C#
[DataMemberAttribute]
public virtual string MetaDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MetaDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_metaDescription();
function set_metaDescription(value);

See Also

Category Class
InSite.Model Namespace


MetaTags Property

[image]

.NET Framework Class Library
Category..::.MetaTags Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MetaTags As String
C#
[DataMemberAttribute]
public virtual string MetaTags { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MetaTags {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_metaTags();
function set_metaTags(value);

See Also

Category Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Category..::.Name Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Category Class
InSite.Model Namespace


PageTitle Property

[image]

.NET Framework Class Library
Category..::.PageTitle Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PageTitle As String
C#
[DataMemberAttribute]
public virtual string PageTitle { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PageTitle {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pageTitle();
function set_pageTitle(value);

See Also

Category Class
InSite.Model Namespace


ParentCategory Property

[image]

.NET Framework Class Library
Category..::.ParentCategory Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ParentCategory As Category
C#
public virtual Category ParentCategory { get; set; }
Visual C++
public:
virtual property Category^ ParentCategory {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_parentCategory();
function set_parentCategory(value);

See Also

Category Class
InSite.Model Namespace


ParentCategoryName Property

[image]

.NET Framework Class Library
Category..::.ParentCategoryName Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ParentCategoryName As String
C#
[DataMemberAttribute]
public virtual string ParentCategoryName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ParentCategoryName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parentCategoryName();
function set_parentCategoryName(value);

See Also

Category Class
InSite.Model Namespace


ParentWebSiteName Property

[image]

.NET Framework Class Library
Category..::.ParentWebSiteName Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ParentWebSiteName As String
C#
[DataMemberAttribute]
public virtual string ParentWebSiteName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ParentWebSiteName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parentWebSiteName();
function set_parentWebSiteName(value);

See Also

Category Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
Category..::.Products Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Products As ChildList(Of ProductInfo)
C#
[DataMemberAttribute]
public virtual ChildList<ProductInfo> Products { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ProductInfo^>^ Products {
    ChildList<ProductInfo^>^ get ();
    void set (ChildList<ProductInfo^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

Category Class
InSite.Model Namespace


Restrictions Property

[image]

.NET Framework Class Library
Category..::.Restrictions Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Restrictions As ChildList(Of Restriction)
C#
[DataMemberAttribute]
public virtual ChildList<Restriction> Restrictions { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Restriction^>^ Restrictions {
    ChildList<Restriction^>^ get ();
    void set (ChildList<Restriction^>^ value);
}
JavaScript
function get_restrictions();
function set_restrictions(value);

See Also

Category Class
InSite.Model Namespace


ShortDescription Property

[image]

.NET Framework Class Library
Category..::.ShortDescription Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShortDescription As String
C#
[DataMemberAttribute]
public virtual string ShortDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShortDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shortDescription();
function set_shortDescription(value);

See Also

Category Class
InSite.Model Namespace


ShowDetail Property

[image]

.NET Framework Class Library
Category..::.ShowDetail Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShowDetail As Boolean
C#
[DataMemberAttribute]
public virtual bool ShowDetail { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShowDetail {
    bool get ();
    void set (bool value);
}
JavaScript
function get_showDetail();
function set_showDetail(value);

See Also

Category Class
InSite.Model Namespace


SmallImagePath Property

[image]

.NET Framework Class Library
Category..::.SmallImagePath Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SmallImagePath As String
C#
[DataMemberAttribute]
public virtual string SmallImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SmallImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_smallImagePath();
function set_smallImagePath(value);

See Also

Category Class
InSite.Model Namespace


SortOrder Property

[image]

.NET Framework Class Library
Category..::.SortOrder Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SortOrder As Integer
C#
[DataMemberAttribute]
public virtual int SortOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int SortOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_sortOrder();
function set_sortOrder(value);

See Also

Category Class
InSite.Model Namespace


Specifications Property

[image]

.NET Framework Class Library
Category..::.Specifications Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Specifications As ChildList(Of Specification)
C#
[DataMemberAttribute]
public virtual ChildList<Specification> Specifications { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Specification^>^ Specifications {
    ChildList<Specification^>^ get ();
    void set (ChildList<Specification^>^ value);
}
JavaScript
function get_specifications();
function set_specifications(value);

See Also

Category Class
InSite.Model Namespace


StyleSheet Property

[image]

.NET Framework Class Library
Category..::.StyleSheet Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleSheet As String
C#
public virtual string StyleSheet { get; set; }
Visual C++
public:
virtual property String^ StyleSheet {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_styleSheet();
function set_styleSheet(value);

See Also

Category Class
InSite.Model Namespace


SubCategories Property

[image]

.NET Framework Class Library
Category..::.SubCategories Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SubCategories As ChildList(Of Category)
C#
public virtual ChildList<Category> SubCategories { get; private set; }
Visual C++
public:
virtual property ChildList<Category^>^ SubCategories {
    ChildList<Category^>^ get ();
    void set (ChildList<Category^>^ value);
}
JavaScript
function get_subCategories();
function set_subCategories(value);

See Also

Category Class
InSite.Model Namespace


TaxExemptions Property

[image]

.NET Framework Class Library
Category..::.TaxExemptions Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxExemptions As ChildList(Of TaxExemption)
C#
public virtual ChildList<TaxExemption> TaxExemptions { get; private set; }
Visual C++
public:
virtual property ChildList<TaxExemption^>^ TaxExemptions {
    ChildList<TaxExemption^>^ get ();
    void set (ChildList<TaxExemption^>^ value);
}
JavaScript
function get_taxExemptions();
function set_taxExemptions(value);

See Also

Category Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
Category..::.WebSite Property
Category Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

Category Class
InSite.Model Namespace


CategoryFilterSection Class

[image]

.NET Framework Class Library
CategoryFilterSection Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CategoryFilterSection _
    Inherits ModelBase(Of CategoryFilterSection)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CategoryFilterSection : ModelBase<CategoryFilterSection>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CategoryFilterSection : public ModelBase<CategoryFilterSection^>
JavaScript
InSite.Model.CategoryFilterSection = function();

Type.createClass(
    'InSite.Model.CategoryFilterSection',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CategoryFilterSection>)>)
InSite.Model..::.CategoryFilterSection

See Also

CategoryFilterSection Members
InSite.Model Namespace


CategoryFilterSection Members

[image] [image]

.NET Framework Class Library
CategoryFilterSection Members
CategoryFilterSection Class Constructors Methods Fields Properties See Also Send Feedback

The CategoryFilterSection type exposes the following members.

Constructors

Name | Description
CategoryFilterSection | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Category |
CategoryFilterSectionId |
CategoryName |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
FilterSection |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CategoryFilterSection Class
InSite.Model Namespace


CategoryFilterSection Constructor

[image] [image]

.NET Framework Class Library
CategoryFilterSection Constructor
CategoryFilterSection Class See Also Send Feedback

Overload List

Name | Description
CategoryFilterSection()()() |
CategoryFilterSection(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CategoryFilterSection Class
CategoryFilterSection Members
InSite.Model Namespace


CategoryFilterSection Constructor

[image]

.NET Framework Class Library
CategoryFilterSection Constructor
CategoryFilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CategoryFilterSection()
Visual C++
public:
CategoryFilterSection()
JavaScript
InSite.Model.CategoryFilterSection = function();

See Also

CategoryFilterSection Class
CategoryFilterSection Overload
InSite.Model Namespace


CategoryFilterSection Constructor (SearchMode)

[image]

.NET Framework Class Library
CategoryFilterSection Constructor (SearchMode)
CategoryFilterSection Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CategoryFilterSection(
    SearchMode searchMode
)
Visual C++
public:
CategoryFilterSection(
    SearchMode searchMode
)
JavaScript
InSite.Model.CategoryFilterSection = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CategoryFilterSection Class
CategoryFilterSection Overload
InSite.Model Namespace


CategoryFilterSection Fields

[image] [image]

.NET Framework Class Library
CategoryFilterSection Fields
CategoryFilterSection Class See Also Send Feedback

The CategoryFilterSection type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CategoryFilterSection Class
InSite.Model Namespace


CategoryFilterSection Methods

[image] [image]

.NET Framework Class Library
CategoryFilterSection Methods
CategoryFilterSection Class See Also Send Feedback

The CategoryFilterSection type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CategoryFilterSection Class
InSite.Model Namespace


CategoryFilterSection Properties

[image] [image]

.NET Framework Class Library
CategoryFilterSection Properties
CategoryFilterSection Class See Also Send Feedback

The CategoryFilterSection type exposes the following members.

Properties

Name | Description
Category |
CategoryFilterSectionId |
CategoryName |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
FilterSection |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CategoryFilterSection Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
CategoryFilterSection..::.Category Property
CategoryFilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Category As Category
C#
[DataMemberAttribute]
public virtual Category Category { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

CategoryFilterSection Class
InSite.Model Namespace


CategoryFilterSectionId Property

[image]

.NET Framework Class Library
CategoryFilterSection..::.CategoryFilterSectionId Property
CategoryFilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CategoryFilterSectionId As Guid
C#
public virtual Guid CategoryFilterSectionId { get; set; }
Visual C++
public:
virtual property Guid CategoryFilterSectionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_categoryFilterSectionId();
function set_categoryFilterSectionId(value);

See Also

CategoryFilterSection Class
InSite.Model Namespace


CategoryName Property

[image]

.NET Framework Class Library
CategoryFilterSection..::.CategoryName Property
CategoryFilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CategoryName As String
C#
[DataMemberAttribute]
public virtual string CategoryName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_categoryName();
function set_categoryName(value);

See Also

CategoryFilterSection Class
InSite.Model Namespace


FilterSection Property

[image]

.NET Framework Class Library
CategoryFilterSection..::.FilterSection Property
CategoryFilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FilterSection As FilterSection
C#
public virtual FilterSection FilterSection { get; set; }
Visual C++
public:
virtual property FilterSection^ FilterSection {
    FilterSection^ get ();
    void set (FilterSection^ value);
}
JavaScript
function get_filterSection();
function set_filterSection(value);

See Also

CategoryFilterSection Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
CategoryFilterSection..::.IsActive Property
CategoryFilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

CategoryFilterSection Class
InSite.Model Namespace


SortOrder Property

[image]

.NET Framework Class Library
CategoryFilterSection..::.SortOrder Property
CategoryFilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property SortOrder As Integer
C#
[SortField]
[DataMemberAttribute]
public virtual int SortOrder { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property int SortOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_sortOrder();
function set_sortOrder(value);

See Also

CategoryFilterSection Class
InSite.Model Namespace


CategoryProperty Class

[image]

.NET Framework Class Library
CategoryProperty Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CategoryProperty _
    Inherits ModelBase(Of CategoryProperty)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CategoryProperty : ModelBase<CategoryProperty>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CategoryProperty : public ModelBase<CategoryProperty^>
JavaScript
InSite.Model.CategoryProperty = function();

Type.createClass(
    'InSite.Model.CategoryProperty',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CategoryProperty>)>)
InSite.Model..::.CategoryProperty

See Also

CategoryProperty Members
InSite.Model Namespace


CategoryProperty Members

[image] [image]

.NET Framework Class Library
CategoryProperty Members
CategoryProperty Class Constructors Methods Fields Properties See Also Send Feedback

The CategoryProperty type exposes the following members.

Constructors

Name | Description
CategoryProperty | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Category |
CategoryPropertyId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CategoryProperty Class
InSite.Model Namespace


CategoryProperty Constructor

[image] [image]

.NET Framework Class Library
CategoryProperty Constructor
CategoryProperty Class See Also Send Feedback

Overload List

Name | Description
CategoryProperty()()() |
CategoryProperty(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CategoryProperty Class
CategoryProperty Members
InSite.Model Namespace


CategoryProperty Constructor

[image]

.NET Framework Class Library
CategoryProperty Constructor
CategoryProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CategoryProperty()
Visual C++
public:
CategoryProperty()
JavaScript
InSite.Model.CategoryProperty = function();

See Also

CategoryProperty Class
CategoryProperty Overload
InSite.Model Namespace


CategoryProperty Constructor (SearchMode)

[image]

.NET Framework Class Library
CategoryProperty Constructor (SearchMode)
CategoryProperty Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CategoryProperty(
    SearchMode searchMode
)
Visual C++
public:
CategoryProperty(
    SearchMode searchMode
)
JavaScript
InSite.Model.CategoryProperty = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CategoryProperty Class
CategoryProperty Overload
InSite.Model Namespace


CategoryProperty Fields

[image] [image]

.NET Framework Class Library
CategoryProperty Fields
CategoryProperty Class See Also Send Feedback

The CategoryProperty type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CategoryProperty Class
InSite.Model Namespace


CategoryProperty Methods

[image] [image]

.NET Framework Class Library
CategoryProperty Methods
CategoryProperty Class See Also Send Feedback

The CategoryProperty type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CategoryProperty Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
CategoryProperty..::.ToString Method
CategoryProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

CategoryProperty Class
InSite.Model Namespace


CategoryProperty Properties

[image] [image]

.NET Framework Class Library
CategoryProperty Properties
CategoryProperty Class See Also Send Feedback

The CategoryProperty type exposes the following members.

Properties

Name | Description
Category |
CategoryPropertyId |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CategoryProperty Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
CategoryProperty..::.Category Property
CategoryProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Category As Category
C#
public virtual Category Category { get; set; }
Visual C++
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

CategoryProperty Class
InSite.Model Namespace


CategoryPropertyId Property

[image]

.NET Framework Class Library
CategoryProperty..::.CategoryPropertyId Property
CategoryProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CategoryPropertyId As Guid
C#
public virtual Guid CategoryPropertyId { get; set; }
Visual C++
public:
virtual property Guid CategoryPropertyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_categoryPropertyId();
function set_categoryPropertyId(value);

See Also

CategoryProperty Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CategoryProperty..::.Name Property
CategoryProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CategoryProperty Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
CategoryProperty..::.Value Property
CategoryProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

CategoryProperty Class
InSite.Model Namespace


ChildList(T) Class

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>) Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ChildList(Of T) _
    Implements IList(Of T), ICollection(Of T),  _
    IEnumerable(Of T), IList, ICollection, IEnumerable
C#
[SerializableAttribute]
public class ChildList<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IList, ICollection, IEnumerable
Visual C++
[SerializableAttribute]
generic<typename T>
public ref class ChildList : IList<T>,
    ICollection<T>, IEnumerable<T>, IList, ICollection, IEnumerable
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ChildList<(Of <(T>)>)

See Also

ChildList<(Of <(T>)>) Members
InSite.Model Namespace


ChildList(T) Members

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>) Members
ChildList<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChildList<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
ChildList<(Of <(T>)>) | Overloaded.

Methods

Name | Description
Add | Overloaded.
AsList |
Clear |
Contains | Overloaded.
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSortedList |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAt |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
IsFixedSize |
IsReadOnly |
IsSynchronized |
Item | Overloaded.
SyncRoot |

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |
IList..::.Item |

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


ChildList(T) Constructor

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>) Constructor
ChildList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
ChildList<(Of <(T>)>)()()() |
ChildList<(Of <(T>)>)(IList<(Of <(T>)>)) |

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Members
InSite.Model Namespace


ChildList(T) Constructor

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>) Constructor
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ChildList()
Visual C++
public:
ChildList()
JavaScript
InSite.Model.ChildList = function();

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Overload
InSite.Model Namespace


ChildList(T) Constructor (IList(T))

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>) Constructor (IList<(Of <(T>)>))
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    value As IList(Of T) _
)
C#
public ChildList(
    IList<T> value
)
Visual C++
public:
ChildList(
    IList<T>^ value
)
JavaScript
InSite.Model.ChildList = function(value);

Parameters

value
Type: System.Collections.Generic..::.IList <(Of <( T >)>)

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Overload
InSite.Model Namespace


ChildList(T) Methods

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>) Methods
ChildList<(Of <(T>)>) Class See Also Send Feedback

The ChildList<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AsList |
Clear |
Contains | Overloaded.
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSortedList |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAt |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


IEnumerable.GetEnumerator Method

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.IEnumerable..::.GetEnumerator Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator
C#
IEnumerator IEnumerable.GetEnumerator()
Visual C++
private:
virtual IEnumerator^ GetEnumerator() sealed = IEnumerable::GetEnumerator
JavaScript
JavaScript does not support explicit interface implementations.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


Add Method

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Add Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Add(Object) |
Add(T) |

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Members
InSite.Model Namespace


Add Method (Object)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Add Method (Object)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function Add ( _
    value As Object _
) As Integer
C#
public int Add(
    Object value
)
Visual C++
public:
virtual int Add(
    Object^ value
) sealed
JavaScript
function add(value);

Parameters

value
Type: System..::.Object

Implements

IList..::.Add(Object)

See Also

ChildList<(Of <(T>)>) Class
Add Overload
InSite.Model Namespace


Add Method (T)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Add Method (T)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add ( _
    item As T _
)
C#
public void Add(
    T item
)
Visual C++
public:
virtual void Add(
    T item
) sealed
JavaScript
function add(item);

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ChildList<(Of <(T>)>) Class
Add Overload
InSite.Model Namespace


AsList Method

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.AsList Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function AsList As List(Of T)
C#
public List<T> AsList()
Visual C++
public:
List<T>^ AsList()
JavaScript
function asList();

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


Clear Method

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Clear Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub Clear
C#
public void Clear()
Visual C++
public:
virtual void Clear() sealed
JavaScript
function clear();

Implements

ICollection<(Of <(T>)>)..::.Clear()()()
IList..::.Clear()()()

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


Contains Method

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Contains Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Contains(Object) |
Contains(T) |

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Members
InSite.Model Namespace


Contains Method (Object)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Contains Method (Object)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains ( _
    value As Object _
) As Boolean
C#
public bool Contains(
    Object value
)
Visual C++
public:
virtual bool Contains(
    Object^ value
) sealed
JavaScript
function contains(value);

Parameters

value
Type: System..::.Object

Implements

IList..::.Contains(Object)

See Also

ChildList<(Of <(T>)>) Class
Contains Overload
InSite.Model Namespace


Contains Method (T)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Contains Method (T)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function Contains ( _
    item As T _
) As Boolean
C#
public bool Contains(
    T item
)
Visual C++
public:
virtual bool Contains(
    T item
) sealed
JavaScript
function contains(item);

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ChildList<(Of <(T>)>) Class
Contains Overload
InSite.Model Namespace


CopyTo Method

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.CopyTo Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
CopyTo(Array, Int32) |
CopyTo(array<T>[]()[], Int32) |

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Members
InSite.Model Namespace


CopyTo Method (Array, Int32)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.CopyTo Method (Array, Int32)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
C#
public void CopyTo(
    Array array,
    int index
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed
JavaScript
function copyTo(array, index);

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

ChildList<(Of <(T>)>) Class
CopyTo Overload
InSite.Model Namespace


CopyTo Method (T[], Int32)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.CopyTo Method (array<T>[]()[], Int32)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As T(), _
    arrayIndex As Integer _
)
C#
public void CopyTo(
    T[] array,
    int arrayIndex
)
Visual C++
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed
JavaScript
function copyTo(array, arrayIndex);

Parameters

array
Type: array< T >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ChildList<(Of <(T>)>) Class
CopyTo Overload
InSite.Model Namespace


GetEnumerator Method

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.GetEnumerator Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of T)
C#
public IEnumerator<T> GetEnumerator()
Visual C++
public:
virtual IEnumerator<T>^ GetEnumerator() sealed
JavaScript
function getEnumerator();

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


GetSortedList Method

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.GetSortedList Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSortedList ( _
    sort As String _
) As ChildList(Of T)
C#
public ChildList<T> GetSortedList(
    string sort
)
Visual C++
public:
ChildList<T>^ GetSortedList(
    String^ sort
)
JavaScript
function getSortedList(sort);

Parameters

sort
Type: System..::.String

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.IndexOf Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
IndexOf(Object) |
IndexOf(T) |

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Members
InSite.Model Namespace


IndexOf Method (Object)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.IndexOf Method (Object)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Object _
) As Integer
C#
public int IndexOf(
    Object value
)
Visual C++
public:
virtual int IndexOf(
    Object^ value
) sealed
JavaScript
function indexOf(value);

Parameters

value
Type: System..::.Object

Implements

IList..::.IndexOf(Object)

See Also

ChildList<(Of <(T>)>) Class
IndexOf Overload
InSite.Model Namespace


IndexOf Method (T)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.IndexOf Method (T)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function IndexOf ( _
    item As T _
) As Integer
C#
public int IndexOf(
    T item
)
Visual C++
public:
virtual int IndexOf(
    T item
) sealed
JavaScript
function indexOf(item);

Parameters

item
Type: T

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

ChildList<(Of <(T>)>) Class
IndexOf Overload
InSite.Model Namespace


Insert Method

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Insert Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Insert(Int32, Object) |
Insert(Int32, T) |

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Members
InSite.Model Namespace


Insert Method (Int32, Object)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Insert Method (Int32, Object)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Object _
)
C#
public void Insert(
    int index,
    Object value
)
Visual C++
public:
virtual void Insert(
    int index,
    Object^ value
) sealed
JavaScript
function insert(index, value);

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

Implements

IList..::.Insert(Int32, Object)

See Also

ChildList<(Of <(T>)>) Class
Insert Overload
InSite.Model Namespace


Insert Method (Int32, T)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Insert Method (Int32, T)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    item As T _
)
C#
public void Insert(
    int index,
    T item
)
Visual C++
public:
virtual void Insert(
    int index,
    T item
) sealed
JavaScript
function insert(index, item);

Parameters

index
Type: System..::.Int32
item
Type: T

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

ChildList<(Of <(T>)>) Class
Insert Overload
InSite.Model Namespace


Remove Method

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Remove Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Remove(Object) |
Remove(T) |

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Members
InSite.Model Namespace


Remove Method (Object)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Remove Method (Object)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub Remove ( _
    value As Object _
)
C#
public void Remove(
    Object value
)
Visual C++
public:
virtual void Remove(
    Object^ value
) sealed
JavaScript
function remove(value);

Parameters

value
Type: System..::.Object

Implements

IList..::.Remove(Object)

See Also

ChildList<(Of <(T>)>) Class
Remove Overload
InSite.Model Namespace


Remove Method (T)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Remove Method (T)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function Remove ( _
    item As T _
) As Boolean
C#
public bool Remove(
    T item
)
Visual C++
public:
virtual bool Remove(
    T item
) sealed
JavaScript
function remove(item);

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ChildList<(Of <(T>)>) Class
Remove Overload
InSite.Model Namespace


RemoveAt Method

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.RemoveAt Method
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)
C#
public void RemoveAt(
    int index
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed
JavaScript
function removeAt(index);

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)
IList..::.RemoveAt(Int32)

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


ChildList(T) Properties

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>) Properties
ChildList<(Of <(T>)>) Class See Also Send Feedback

The ChildList<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count |
IsFixedSize |
IsReadOnly |
IsSynchronized |
Item | Overloaded.
SyncRoot |

Explicit Interface Implementations

Name | Description
IList..::.Item |

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


IList.Item Property

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.IList..::.Item Property
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Private Property Item ( _
    index As Integer _
) As Object Implements IList.Item
C#
Object IList.Item[
    int index
] { get; set; }
Visual C++
private:
virtual property Object^ Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
JavaScript
JavaScript does not support explicit interface implementations.

Parameters

index
Type: System..::.Int32

Implements

IList..::.Item[([(Int32])])

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


Count Property

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Count Property
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count { get; }
Visual C++
public:
virtual property int Count {
    int get () sealed;
}
JavaScript
function get_count();

Implements

ICollection<(Of <(T>)>)..::.Count
ICollection..::.Count

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


IsFixedSize Property

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.IsFixedSize Property
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean
C#
public bool IsFixedSize { get; }
Visual C++
public:
virtual property bool IsFixedSize {
    bool get () sealed;
}
JavaScript
function get_isFixedSize();

Implements

IList..::.IsFixedSize

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


IsReadOnly Property

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.IsReadOnly Property
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
C#
public bool IsReadOnly { get; }
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}
JavaScript
function get_isReadOnly();

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly
IList..::.IsReadOnly

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


IsSynchronized Property

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.IsSynchronized Property
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
C#
public bool IsSynchronized { get; }
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}
JavaScript
function get_isSynchronized();

Implements

ICollection..::.IsSynchronized

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


Item Property

[image] [image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Item Property
ChildList<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(String])]) | Gets an object from the list by matching that obect's .ToString() representation

See Also

ChildList<(Of <(T>)>) Class
ChildList<(Of <(T>)>) Members
InSite.Model Namespace


Item Property (Int32)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Item Property (Int32)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As T
C#
public T this[
    int index
] { get; set; }
Visual C++
public:
virtual property T default[int index] {
    T get (int index) sealed;
    void set (int index, T value) sealed;
}
JavaScript
function get_item(index);
function set_item(value);

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ChildList<(Of <(T>)>) Class
Item Overload
InSite.Model Namespace


Item Property (String)

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.Item Property (String)
ChildList<(Of <(T>)>) Class See Also Send Feedback

Gets an object from the list by matching that obect's .ToString() representation

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As T
C#
public T this[
    string key
] { get; }
Visual C++
public:
property T default[String^ key] {
    T get (String^ key);
}
JavaScript
function get_item(key);

Parameters

key
Type: System..::.String
Sting to match

Return Value

Object from list

See Also

ChildList<(Of <(T>)>) Class
Item Overload
InSite.Model Namespace


SyncRoot Property

[image]

.NET Framework Class Library
ChildList<(Of <(T>)>)..::.SyncRoot Property
ChildList<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
C#
public Object SyncRoot { get; }
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}
JavaScript
function get_syncRoot();

Implements

ICollection..::.SyncRoot

See Also

ChildList<(Of <(T>)>) Class
InSite.Model Namespace


City Class

[image]

.NET Framework Class Library
City Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class City _
    Inherits ModelBase(Of City)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class City : ModelBase<City>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class City : public ModelBase<City^>
JavaScript
InSite.Model.City = function();

Type.createClass(
    'InSite.Model.City',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(City>)>)
InSite.Model..::.City

See Also

City Members
InSite.Model Namespace


City Members

[image] [image]

.NET Framework Class Library
City Members
City Class Constructors Methods Fields Properties See Also Send Feedback

The City type exposes the following members.

Constructors

Name | Description
City | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CityId |
CityName |
County |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

City Class
InSite.Model Namespace


City Constructor

[image] [image]

.NET Framework Class Library
City Constructor
City Class See Also Send Feedback

Overload List

Name | Description
City()()() |
City(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

City Class
City Members
InSite.Model Namespace


City Constructor

[image]

.NET Framework Class Library
City Constructor
City Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public City()
Visual C++
public:
City()
JavaScript
InSite.Model.City = function();

See Also

City Class
City Overload
InSite.Model Namespace


City Constructor (SearchMode)

[image]

.NET Framework Class Library
City Constructor (SearchMode)
City Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public City(
    SearchMode searchMode
)
Visual C++
public:
City(
    SearchMode searchMode
)
JavaScript
InSite.Model.City = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

City Class
City Overload
InSite.Model Namespace


City Fields

[image] [image]

.NET Framework Class Library
City Fields
City Class See Also Send Feedback

The City type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

City Class
InSite.Model Namespace


City Methods

[image] [image]

.NET Framework Class Library
City Methods
City Class See Also Send Feedback

The City type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

City Class
InSite.Model Namespace


City Properties

[image] [image]

.NET Framework Class Library
City Properties
City Class See Also Send Feedback

The City type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CityId |
CityName |
County |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

City Class
InSite.Model Namespace


CityId Property

[image]

.NET Framework Class Library
City..::.CityId Property
City Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CityId As Guid
C#
public virtual Guid CityId { get; set; }
Visual C++
public:
virtual property Guid CityId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_cityId();
function set_cityId(value);

See Also

City Class
InSite.Model Namespace


CityName Property

[image]

.NET Framework Class Library
City..::.CityName Property
City Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property CityName As String
C#
[DataMemberAttribute]
[SortField]
public virtual string CityName { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ CityName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cityName();
function set_cityName(value);

See Also

City Class
InSite.Model Namespace


County Property

[image]

.NET Framework Class Library
City..::.County Property
City Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property County As County
C#
[DataMemberAttribute]
public virtual County County { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property County^ County {
    County^ get ();
    void set (County^ value);
}
JavaScript
function get_county();
function set_county(value);

See Also

City Class
InSite.Model Namespace


Company Class

[image]

.NET Framework Class Library
Company Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Company _
    Inherits ModelBase(Of Company)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Company : ModelBase<Company>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Company : public ModelBase<Company^>
JavaScript
InSite.Model.Company = function();

Type.createClass(
    'InSite.Model.Company',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Company>)>)
InSite.Model..::.Company

See Also

Company Members
InSite.Model Namespace


Company Members

[image] [image]

.NET Framework Class Library
Company Members
Company Class Constructors Methods Fields Properties See Also Send Feedback

The Company type exposes the following members.

Constructors

Name | Description
Company | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Address |
BottomNavigation |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
City |
CompanyId |
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Fax |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Image |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LeftNavigation |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Phone |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReplaceLogoImage |
RightNavigation |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
TollFreePhone |
TopNavigation |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

Company Class
InSite.Model Namespace


Company Constructor

[image] [image]

.NET Framework Class Library
Company Constructor
Company Class See Also Send Feedback

Overload List

Name | Description
Company()()() |
Company(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Company Class
Company Members
InSite.Model Namespace


Company Constructor

[image]

.NET Framework Class Library
Company Constructor
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Company()
Visual C++
public:
Company()
JavaScript
InSite.Model.Company = function();

See Also

Company Class
Company Overload
InSite.Model Namespace


Company Constructor (SearchMode)

[image]

.NET Framework Class Library
Company Constructor (SearchMode)
Company Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Company(
    SearchMode searchMode
)
Visual C++
public:
Company(
    SearchMode searchMode
)
JavaScript
InSite.Model.Company = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Company Class
Company Overload
InSite.Model Namespace


Company Fields

[image] [image]

.NET Framework Class Library
Company Fields
Company Class See Also Send Feedback

The Company type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Company Class
InSite.Model Namespace


Company Methods

[image] [image]

.NET Framework Class Library
Company Methods
Company Class See Also Send Feedback

The Company type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Company Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
Company..::.GetByName Method
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As Company
C#
public static Company GetByName(
    string name
)
Visual C++
public:
static Company^ GetByName(
    String^ name
)
JavaScript
InSite.Model.Company.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

Company Class
InSite.Model Namespace


Company Properties

[image] [image]

.NET Framework Class Library
Company Properties
Company Class See Also Send Feedback

The Company type exposes the following members.

Properties

Name | Description
Address |
BottomNavigation |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
City |
CompanyId |
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Fax |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Image |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LeftNavigation |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Phone |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReplaceLogoImage |
RightNavigation |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
TollFreePhone |
TopNavigation |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

Company Class
InSite.Model Namespace


Address Property

[image]

.NET Framework Class Library
Company..::.Address Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address As String
C#
[DataMemberAttribute]
public virtual string Address { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address();
function set_address(value);

See Also

Company Class
InSite.Model Namespace


BottomNavigation Property

[image]

.NET Framework Class Library
Company..::.BottomNavigation Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BottomNavigation As String
C#
[DataMemberAttribute]
public virtual string BottomNavigation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BottomNavigation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bottomNavigation();
function set_bottomNavigation(value);

See Also

Company Class
InSite.Model Namespace


City Property

[image]

.NET Framework Class Library
Company..::.City Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property City As String
C#
[DataMemberAttribute]
public virtual string City { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ City {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

See Also

Company Class
InSite.Model Namespace


CompanyId Property

[image]

.NET Framework Class Library
Company..::.CompanyId Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CompanyId As Guid
C#
public virtual Guid CompanyId { get; set; }
Visual C++
public:
virtual property Guid CompanyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_companyId();
function set_companyId(value);

See Also

Company Class
InSite.Model Namespace


Country Property

[image]

.NET Framework Class Library
Company..::.Country Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Country As String
C#
[DataMemberAttribute]
public virtual string Country { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

Company Class
InSite.Model Namespace


Fax Property

[image]

.NET Framework Class Library
Company..::.Fax Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Fax As String
C#
[DataMemberAttribute]
public virtual string Fax { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Fax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fax();
function set_fax(value);

See Also

Company Class
InSite.Model Namespace


Image Property

[image]

.NET Framework Class Library
Company..::.Image Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Image As String
C#
[DataMemberAttribute]
public virtual string Image { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Image {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_image();
function set_image(value);

See Also

Company Class
InSite.Model Namespace


LeftNavigation Property

[image]

.NET Framework Class Library
Company..::.LeftNavigation Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LeftNavigation As String
C#
[DataMemberAttribute]
public virtual string LeftNavigation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LeftNavigation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_leftNavigation();
function set_leftNavigation(value);

See Also

Company Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Company..::.Name Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Company Class
InSite.Model Namespace


Phone Property

[image]

.NET Framework Class Library
Company..::.Phone Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone As String
C#
[DataMemberAttribute]
public virtual string Phone { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone();
function set_phone(value);

See Also

Company Class
InSite.Model Namespace


ReplaceLogoImage Property

[image]

.NET Framework Class Library
Company..::.ReplaceLogoImage Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ReplaceLogoImage As Boolean
C#
[DataMemberAttribute]
public virtual bool ReplaceLogoImage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ReplaceLogoImage {
    bool get ();
    void set (bool value);
}
JavaScript
function get_replaceLogoImage();
function set_replaceLogoImage(value);

See Also

Company Class
InSite.Model Namespace


RightNavigation Property

[image]

.NET Framework Class Library
Company..::.RightNavigation Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RightNavigation As String
C#
[DataMemberAttribute]
public virtual string RightNavigation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RightNavigation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_rightNavigation();
function set_rightNavigation(value);

See Also

Company Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
Company..::.State Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property State As String
C#
[DataMemberAttribute]
public virtual string State { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ State {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

Company Class
InSite.Model Namespace


TollFreePhone Property

[image]

.NET Framework Class Library
Company..::.TollFreePhone Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TollFreePhone As String
C#
[DataMemberAttribute]
public virtual string TollFreePhone { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TollFreePhone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_tollFreePhone();
function set_tollFreePhone(value);

See Also

Company Class
InSite.Model Namespace


TopNavigation Property

[image]

.NET Framework Class Library
Company..::.TopNavigation Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TopNavigation As String
C#
[DataMemberAttribute]
public virtual string TopNavigation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TopNavigation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_topNavigation();
function set_topNavigation(value);

See Also

Company Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
Company..::.WebSite Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

Company Class
InSite.Model Namespace


Zip Property

[image]

.NET Framework Class Library
Company..::.Zip Property
Company Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Zip As String
C#
[DataMemberAttribute]
public virtual string Zip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

See Also

Company Class
InSite.Model Namespace


Content Class

[image]

.NET Framework Class Library
Content Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Content _
    Inherits ModelBase(Of Content)
C#
[SerializableAttribute]
public class Content : ModelBase<Content>
Visual C++
[SerializableAttribute]
public ref class Content : public ModelBase<Content^>
JavaScript
InSite.Model.Content = function();

Type.createClass(
    'InSite.Model.Content',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Content>)>)
InSite.Model..::.Content

See Also

Content Members
InSite.Model Namespace


Content Members

[image] [image]

.NET Framework Class Library
Content Members
Content Class Constructors Methods Fields Properties See Also Send Feedback

The Content type exposes the following members.

Constructors

Name | Description
Content | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Approved |
ApprovedBy |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentId |
ContentManager |
Created |
CreatedBy |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Html |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PublishToProduction |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Revision |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SubmittedForApproval |
Type |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Content Class
InSite.Model Namespace


Content Constructor

[image] [image]

.NET Framework Class Library
Content Constructor
Content Class See Also Send Feedback

Overload List

Name | Description
Content()()() |
Content(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Content Class
Content Members
InSite.Model Namespace


Content Constructor

[image]

.NET Framework Class Library
Content Constructor
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Content()
Visual C++
public:
Content()
JavaScript
InSite.Model.Content = function();

See Also

Content Class
Content Overload
InSite.Model Namespace


Content Constructor (SearchMode)

[image]

.NET Framework Class Library
Content Constructor (SearchMode)
Content Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Content(
    SearchMode searchMode
)
Visual C++
public:
Content(
    SearchMode searchMode
)
JavaScript
InSite.Model.Content = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Content Class
Content Overload
InSite.Model Namespace


Content Fields

[image] [image]

.NET Framework Class Library
Content Fields
Content Class See Also Send Feedback

The Content type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Content Class
InSite.Model Namespace


Content Methods

[image] [image]

.NET Framework Class Library
Content Methods
Content Class See Also Send Feedback

The Content type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Content Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
Content..::.Copy Method
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As Content
C#
public virtual Content Copy()
Visual C++
public:
virtual Content^ Copy()
JavaScript
function copy();

See Also

Content Class
InSite.Model Namespace


Content Properties

[image] [image]

.NET Framework Class Library
Content Properties
Content Class See Also Send Feedback

The Content type exposes the following members.

Properties

Name | Description
Approved |
ApprovedBy |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentId |
ContentManager |
Created |
CreatedBy |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Html |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PublishToProduction |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Revision |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SubmittedForApproval |
Type |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Content Class
InSite.Model Namespace


Approved Property

[image]

.NET Framework Class Library
Content..::.Approved Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Approved As Nullable(Of DateTime)
C#
public virtual Nullable<DateTime> Approved { get; set; }
Visual C++
public:
virtual property Nullable<DateTime> Approved {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_approved();
function set_approved(value);

See Also

Content Class
InSite.Model Namespace


ApprovedBy Property

[image]

.NET Framework Class Library
Content..::.ApprovedBy Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ApprovedBy As UserProfile
C#
public virtual UserProfile ApprovedBy { get; set; }
Visual C++
public:
virtual property UserProfile^ ApprovedBy {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_approvedBy();
function set_approvedBy(value);

See Also

Content Class
InSite.Model Namespace


ContentId Property

[image]

.NET Framework Class Library
Content..::.ContentId Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentId As Guid
C#
public virtual Guid ContentId { get; set; }
Visual C++
public:
virtual property Guid ContentId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_contentId();
function set_contentId(value);

See Also

Content Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
Content..::.ContentManager Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

Content Class
InSite.Model Namespace


Created Property

[image]

.NET Framework Class Library
Content..::.Created Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Created As DateTime
C#
public virtual DateTime Created { get; set; }
Visual C++
public:
virtual property DateTime Created {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_created();
function set_created(value);

See Also

Content Class
InSite.Model Namespace


CreatedBy Property

[image]

.NET Framework Class Library
Content..::.CreatedBy Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreatedBy As UserProfile
C#
public virtual UserProfile CreatedBy { get; set; }
Visual C++
public:
virtual property UserProfile^ CreatedBy {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_createdBy();
function set_createdBy(value);

See Also

Content Class
InSite.Model Namespace


Html Property

[image]

.NET Framework Class Library
Content..::.Html Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Html As String
C#
public virtual string Html { get; set; }
Visual C++
public:
virtual property String^ Html {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_html();
function set_html(value);

See Also

Content Class
InSite.Model Namespace


LanguageCode Property

[image]

.NET Framework Class Library
Content..::.LanguageCode Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property LanguageCode As String
C#
public virtual string LanguageCode { get; set; }
Visual C++
public:
virtual property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_languageCode();
function set_languageCode(value);

See Also

Content Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Content..::.Name Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Content Class
InSite.Model Namespace


PublishToProduction Property

[image]

.NET Framework Class Library
Content..::.PublishToProduction Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PublishToProduction As Nullable(Of DateTime)
C#
public virtual Nullable<DateTime> PublishToProduction { get; set; }
Visual C++
public:
virtual property Nullable<DateTime> PublishToProduction {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_publishToProduction();
function set_publishToProduction(value);

See Also

Content Class
InSite.Model Namespace


Revision Property

[image]

.NET Framework Class Library
Content..::.Revision Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Revision As Integer
C#
public virtual int Revision { get; set; }
Visual C++
public:
virtual property int Revision {
    int get ();
    void set (int value);
}
JavaScript
function get_revision();
function set_revision(value);

See Also

Content Class
InSite.Model Namespace


SubmittedForApproval Property

[image]

.NET Framework Class Library
Content..::.SubmittedForApproval Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SubmittedForApproval As Nullable(Of DateTime)
C#
public virtual Nullable<DateTime> SubmittedForApproval { get; set; }
Visual C++
public:
virtual property Nullable<DateTime> SubmittedForApproval {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_submittedForApproval();
function set_submittedForApproval(value);

See Also

Content Class
InSite.Model Namespace


Type Property

[image]

.NET Framework Class Library
Content..::.Type Property
Content Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Type As String
C#
public virtual string Type { get; set; }
Visual C++
public:
virtual property String^ Type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

See Also

Content Class
InSite.Model Namespace


ContentManager Class

[image]

.NET Framework Class Library
ContentManager Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ContentManager _
    Inherits ModelBase(Of ContentManager)
C#
[SerializableAttribute]
public class ContentManager : ModelBase<ContentManager>
Visual C++
[SerializableAttribute]
public ref class ContentManager : public ModelBase<ContentManager^>
JavaScript
InSite.Model.ContentManager = function();

Type.createClass(
    'InSite.Model.ContentManager',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ContentManager>)>)
InSite.Model..::.ContentManager

See Also

ContentManager Members
InSite.Model Namespace


ContentManager Members

[image] [image]

.NET Framework Class Library
ContentManager Members
ContentManager Class Constructors Methods Fields Properties See Also Send Feedback

The ContentManager type exposes the following members.

Constructors

Name | Description
ContentManager | Overloaded.

Methods

Name | Description
AddContent |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveContent |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManagerId |
Contents |
CurrentContent |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ContentManager Class
InSite.Model Namespace


ContentManager Constructor

[image] [image]

.NET Framework Class Library
ContentManager Constructor
ContentManager Class See Also Send Feedback

Overload List

Name | Description
ContentManager()()() |
ContentManager(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ContentManager Class
ContentManager Members
InSite.Model Namespace


ContentManager Constructor

[image]

.NET Framework Class Library
ContentManager Constructor
ContentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ContentManager()
Visual C++
public:
ContentManager()
JavaScript
InSite.Model.ContentManager = function();

See Also

ContentManager Class
ContentManager Overload
InSite.Model Namespace


ContentManager Constructor (SearchMode)

[image]

.NET Framework Class Library
ContentManager Constructor (SearchMode)
ContentManager Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ContentManager(
    SearchMode searchMode
)
Visual C++
public:
ContentManager(
    SearchMode searchMode
)
JavaScript
InSite.Model.ContentManager = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ContentManager Class
ContentManager Overload
InSite.Model Namespace


ContentManager Fields

[image] [image]

.NET Framework Class Library
ContentManager Fields
ContentManager Class See Also Send Feedback

The ContentManager type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ContentManager Class
InSite.Model Namespace


ContentManager Methods

[image] [image]

.NET Framework Class Library
ContentManager Methods
ContentManager Class See Also Send Feedback

The ContentManager type exposes the following members.

Methods

Name | Description
AddContent |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveContent |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ContentManager Class
InSite.Model Namespace


AddContent Method

[image]

.NET Framework Class Library
ContentManager..::.AddContent Method
ContentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddContent ( _
    value As Content _
)
C#
public virtual void AddContent(
    Content value
)
Visual C++
public:
virtual void AddContent(
    Content^ value
)
JavaScript
function addContent(value);

Parameters

value
Type: InSite.Model..::.Content

See Also

ContentManager Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
ContentManager..::.Copy Method
ContentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As ContentManager
C#
public virtual ContentManager Copy()
Visual C++
public:
virtual ContentManager^ Copy()
JavaScript
function copy();

See Also

ContentManager Class
InSite.Model Namespace


RemoveContent Method

[image]

.NET Framework Class Library
ContentManager..::.RemoveContent Method
ContentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveContent ( _
    value As Content _
)
C#
public virtual void RemoveContent(
    Content value
)
Visual C++
public:
virtual void RemoveContent(
    Content^ value
)
JavaScript
function removeContent(value);

Parameters

value
Type: InSite.Model..::.Content

See Also

ContentManager Class
InSite.Model Namespace


ContentManager Properties

[image] [image]

.NET Framework Class Library
ContentManager Properties
ContentManager Class See Also Send Feedback

The ContentManager type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManagerId |
Contents |
CurrentContent |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ContentManager Class
InSite.Model Namespace


ContentManagerId Property

[image]

.NET Framework Class Library
ContentManager..::.ContentManagerId Property
ContentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManagerId As Guid
C#
public virtual Guid ContentManagerId { get; set; }
Visual C++
public:
virtual property Guid ContentManagerId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_contentManagerId();
function set_contentManagerId(value);

See Also

ContentManager Class
InSite.Model Namespace


Contents Property

[image]

.NET Framework Class Library
ContentManager..::.Contents Property
ContentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Contents As ChildList(Of Content)
C#
public virtual ChildList<Content> Contents { get; private set; }
Visual C++
public:
virtual property ChildList<Content^>^ Contents {
    ChildList<Content^>^ get ();
    void set (ChildList<Content^>^ value);
}
JavaScript
function get_contents();
function set_contents(value);

See Also

ContentManager Class
InSite.Model Namespace


CurrentContent Property

[image]

.NET Framework Class Library
ContentManager..::.CurrentContent Property
ContentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CurrentContent As Content
C#
public virtual Content CurrentContent { get; }
Visual C++
public:
virtual property Content^ CurrentContent {
    Content^ get ();
}
JavaScript
function get_currentContent();

See Also

ContentManager Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
ContentManager..::.Name Property
ContentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

ContentManager Class
InSite.Model Namespace


Country Class

[image]

.NET Framework Class Library
Country Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Country _
    Inherits ModelBase(Of Country)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Country : ModelBase<Country>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Country : public ModelBase<Country^>
JavaScript
InSite.Model.Country = function();

Type.createClass(
    'InSite.Model.Country',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Country>)>)
InSite.Model..::.Country

See Also

Country Members
InSite.Model Namespace


Country Members

[image] [image]

.NET Framework Class Library
Country Members
Country Class Constructors Methods Fields Properties See Also Send Feedback

The Country type exposes the following members.

Constructors

Name | Description
Country | Overloaded.

Methods

Name | Description
AddState |
AddWebSite |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByAbbreviation |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveState |
RemoveWebSite |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Abbreviation |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CountryId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Default |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
ISOCode2 |
ISOCode3 |
ISONumber |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
States |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSites |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Country Class
InSite.Model Namespace


Country Constructor

[image] [image]

.NET Framework Class Library
Country Constructor
Country Class See Also Send Feedback

Overload List

Name | Description
Country()()() |
Country(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Country Class
Country Members
InSite.Model Namespace


Country Constructor

[image]

.NET Framework Class Library
Country Constructor
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Country()
Visual C++
public:
Country()
JavaScript
InSite.Model.Country = function();

See Also

Country Class
Country Overload
InSite.Model Namespace


Country Constructor (SearchMode)

[image]

.NET Framework Class Library
Country Constructor (SearchMode)
Country Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Country(
    SearchMode searchMode
)
Visual C++
public:
Country(
    SearchMode searchMode
)
JavaScript
InSite.Model.Country = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Country Class
Country Overload
InSite.Model Namespace


Country Fields

[image] [image]

.NET Framework Class Library
Country Fields
Country Class See Also Send Feedback

The Country type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Country Class
InSite.Model Namespace


Country Methods

[image] [image]

.NET Framework Class Library
Country Methods
Country Class See Also Send Feedback

The Country type exposes the following members.

Methods

Name | Description
AddState |
AddWebSite |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByAbbreviation |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveState |
RemoveWebSite |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Country Class
InSite.Model Namespace


AddState Method

[image]

.NET Framework Class Library
Country..::.AddState Method
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddState ( _
    value As State _
)
C#
public virtual void AddState(
    State value
)
Visual C++
public:
virtual void AddState(
    State^ value
)
JavaScript
function addState(value);

Parameters

value
Type: InSite.Model..::.State

See Also

Country Class
InSite.Model Namespace


AddWebSite Method

[image]

.NET Framework Class Library
Country..::.AddWebSite Method
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWebSite ( _
    value As WebSite _
)
C#
public virtual void AddWebSite(
    WebSite value
)
Visual C++
public:
virtual void AddWebSite(
    WebSite^ value
)
JavaScript
function addWebSite(value);

Parameters

value
Type: InSite.Model..::.WebSite

See Also

Country Class
InSite.Model Namespace


GetByAbbreviation Method

[image]

.NET Framework Class Library
Country..::.GetByAbbreviation Method
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByAbbreviation ( _
    abbreviation As String _
) As Country
C#
public static Country GetByAbbreviation(
    string abbreviation
)
Visual C++
public:
static Country^ GetByAbbreviation(
    String^ abbreviation
)
JavaScript
InSite.Model.Country.getByAbbreviation = function(abbreviation);

Parameters

abbreviation
Type: System..::.String

See Also

Country Class
InSite.Model Namespace


RemoveState Method

[image]

.NET Framework Class Library
Country..::.RemoveState Method
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveState ( _
    value As State _
)
C#
public virtual void RemoveState(
    State value
)
Visual C++
public:
virtual void RemoveState(
    State^ value
)
JavaScript
function removeState(value);

Parameters

value
Type: InSite.Model..::.State

See Also

Country Class
InSite.Model Namespace


RemoveWebSite Method

[image]

.NET Framework Class Library
Country..::.RemoveWebSite Method
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWebSite ( _
    value As WebSite _
)
C#
public virtual void RemoveWebSite(
    WebSite value
)
Visual C++
public:
virtual void RemoveWebSite(
    WebSite^ value
)
JavaScript
function removeWebSite(value);

Parameters

value
Type: InSite.Model..::.WebSite

See Also

Country Class
InSite.Model Namespace


Country Properties

[image] [image]

.NET Framework Class Library
Country Properties
Country Class See Also Send Feedback

The Country type exposes the following members.

Properties

Name | Description
Abbreviation |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CountryId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Default |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
ISOCode2 |
ISOCode3 |
ISONumber |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
States |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSites |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Country Class
InSite.Model Namespace


Abbreviation Property

[image]

.NET Framework Class Library
Country..::.Abbreviation Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Abbreviation As String
C#
[DataMemberAttribute]
public virtual string Abbreviation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Abbreviation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_abbreviation();
function set_abbreviation(value);

See Also

Country Class
InSite.Model Namespace


CountryId Property

[image]

.NET Framework Class Library
Country..::.CountryId Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CountryId As Guid
C#
public virtual Guid CountryId { get; set; }
Visual C++
public:
virtual property Guid CountryId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_countryId();
function set_countryId(value);

See Also

Country Class
InSite.Model Namespace


Default Property

[image]

.NET Framework Class Library
Country..::.Default Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Default As Country
C#
public static Country Default { get; }
Visual C++
public:
static property Country^ Default {
    Country^ get ();
}
JavaScript
InSite.Model.Country.get_default = function();

See Also

Country Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
Country..::.IsActive Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

Country Class
InSite.Model Namespace


ISOCode2 Property

[image]

.NET Framework Class Library
Country..::.ISOCode2 Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ISOCode2 As String
C#
[DataMemberAttribute]
public virtual string ISOCode2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ISOCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_isoCode2();
function set_isoCode2(value);

See Also

Country Class
InSite.Model Namespace


ISOCode3 Property

[image]

.NET Framework Class Library
Country..::.ISOCode3 Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ISOCode3 As String
C#
[DataMemberAttribute]
public virtual string ISOCode3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ISOCode3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_isoCode3();
function set_isoCode3(value);

See Also

Country Class
InSite.Model Namespace


ISONumber Property

[image]

.NET Framework Class Library
Country..::.ISONumber Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ISONumber As String
C#
[DataMemberAttribute]
public virtual string ISONumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ISONumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_isoNumber();
function set_isoNumber(value);

See Also

Country Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Country..::.Name Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Country Class
InSite.Model Namespace


States Property

[image]

.NET Framework Class Library
Country..::.States Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property States As ChildList(Of State)
C#
[DataMemberAttribute]
public virtual ChildList<State> States { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<State^>^ States {
    ChildList<State^>^ get ();
    void set (ChildList<State^>^ value);
}
JavaScript
function get_states();
function set_states(value);

See Also

Country Class
InSite.Model Namespace


WebSites Property

[image]

.NET Framework Class Library
Country..::.WebSites Property
Country Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSites As ChildList(Of WebSite)
C#
public virtual ChildList<WebSite> WebSites { get; private set; }
Visual C++
public:
virtual property ChildList<WebSite^>^ WebSites {
    ChildList<WebSite^>^ get ();
    void set (ChildList<WebSite^>^ value);
}
JavaScript
function get_webSites();
function set_webSites(value);

See Also

Country Class
InSite.Model Namespace


County Class

[image]

.NET Framework Class Library
County Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class County _
    Inherits ModelBase(Of County)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class County : ModelBase<County>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class County : public ModelBase<County^>
JavaScript
InSite.Model.County = function();

Type.createClass(
    'InSite.Model.County',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(County>)>)
InSite.Model..::.County

See Also

County Members
InSite.Model Namespace


County Members

[image] [image]

.NET Framework Class Library
County Members
County Class Constructors Methods Fields Properties See Also Send Feedback

The County type exposes the following members.

Constructors

Name | Description
County | Overloaded.

Methods

Name | Description
AddCity |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCity |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Abbreviation |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Cities |
CountyId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
StateId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

County Class
InSite.Model Namespace


County Constructor

[image] [image]

.NET Framework Class Library
County Constructor
County Class See Also Send Feedback

Overload List

Name | Description
County()()() |
County(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

County Class
County Members
InSite.Model Namespace


County Constructor

[image]

.NET Framework Class Library
County Constructor
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public County()
Visual C++
public:
County()
JavaScript
InSite.Model.County = function();

See Also

County Class
County Overload
InSite.Model Namespace


County Constructor (SearchMode)

[image]

.NET Framework Class Library
County Constructor (SearchMode)
County Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public County(
    SearchMode searchMode
)
Visual C++
public:
County(
    SearchMode searchMode
)
JavaScript
InSite.Model.County = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

County Class
County Overload
InSite.Model Namespace


County Fields

[image] [image]

.NET Framework Class Library
County Fields
County Class See Also Send Feedback

The County type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

County Class
InSite.Model Namespace


County Methods

[image] [image]

.NET Framework Class Library
County Methods
County Class See Also Send Feedback

The County type exposes the following members.

Methods

Name | Description
AddCity |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCity |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

County Class
InSite.Model Namespace


AddCity Method

[image]

.NET Framework Class Library
County..::.AddCity Method
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCity ( _
    value As City _
)
C#
public virtual void AddCity(
    City value
)
Visual C++
public:
virtual void AddCity(
    City^ value
)
JavaScript
function addCity(value);

Parameters

value
Type: InSite.Model..::.City

See Also

County Class
InSite.Model Namespace


RemoveCity Method

[image]

.NET Framework Class Library
County..::.RemoveCity Method
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCity ( _
    value As City _
)
C#
public virtual void RemoveCity(
    City value
)
Visual C++
public:
virtual void RemoveCity(
    City^ value
)
JavaScript
function removeCity(value);

Parameters

value
Type: InSite.Model..::.City

See Also

County Class
InSite.Model Namespace


County Properties

[image] [image]

.NET Framework Class Library
County Properties
County Class See Also Send Feedback

The County type exposes the following members.

Properties

Name | Description
Abbreviation |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Cities |
CountyId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
StateId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

County Class
InSite.Model Namespace


Abbreviation Property

[image]

.NET Framework Class Library
County..::.Abbreviation Property
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Abbreviation As String
C#
[DataMemberAttribute]
public virtual string Abbreviation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Abbreviation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_abbreviation();
function set_abbreviation(value);

See Also

County Class
InSite.Model Namespace


Cities Property

[image]

.NET Framework Class Library
County..::.Cities Property
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Cities As ChildList(Of City)
C#
public virtual ChildList<City> Cities { get; private set; }
Visual C++
public:
virtual property ChildList<City^>^ Cities {
    ChildList<City^>^ get ();
    void set (ChildList<City^>^ value);
}
JavaScript
function get_cities();
function set_cities(value);

See Also

County Class
InSite.Model Namespace


CountyId Property

[image]

.NET Framework Class Library
County..::.CountyId Property
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CountyId As Guid
C#
public virtual Guid CountyId { get; set; }
Visual C++
public:
virtual property Guid CountyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_countyId();
function set_countyId(value);

See Also

County Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
County..::.Name Property
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

County Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
County..::.State Property
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property State As State
C#
public virtual State State { get; set; }
Visual C++
public:
virtual property State^ State {
    State^ get ();
    void set (State^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

County Class
InSite.Model Namespace


StateId Property

[image]

.NET Framework Class Library
County..::.StateId Property
County Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property StateId As String
C#
[DataMemberAttribute]
public virtual string StateId { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ StateId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stateId();
function set_stateId(value);

See Also

County Class
InSite.Model Namespace


CreditCard Class

[image]

.NET Framework Class Library
CreditCard Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CreditCard _
    Inherits ModelBase(Of CreditCard)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CreditCard : ModelBase<CreditCard>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CreditCard : public ModelBase<CreditCard^>
JavaScript
InSite.Model.CreditCard = function();

Type.createClass(
    'InSite.Model.CreditCard',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CreditCard>)>)
InSite.Model..::.CreditCard
InSite.Model..::.CreditCardPayPal

See Also

CreditCard Members
InSite.Model Namespace


CreditCard Members

[image] [image]

.NET Framework Class Library
CreditCard Members
CreditCard Class Constructors Methods Fields Properties See Also Send Feedback

The CreditCard type exposes the following members.

Constructors

Name | Description
CreditCard |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
AmericanExpress |
AuthorizationTransaction |
CaptureTransaction |
CreditTransaction |
Discover |
ForceAuthTransaction |
InquiryTransaction |
MasterCard |
PayPal |
RecurringTransaction |
SaleTransaction |
Visa |
VoidTransaction |

Properties

Name | Description
Amount |
AuthCode |
CardNumber |
CardType |
CardTypes |
CCV |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CreditCardId |
CreditCardTransaction |
CSC |
CustomerNumber |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExpirationDate |
ExpirationMonth |
ExpirationYear |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsCIM |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderNumber |
OrigId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentNumber |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCard Class
InSite.Model Namespace


CreditCard Constructor

[image]

.NET Framework Class Library
CreditCard Constructor
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreditCard()
Visual C++
public:
CreditCard()
JavaScript
InSite.Model.CreditCard = function();

See Also

CreditCard Class
InSite.Model Namespace


CreditCard Fields

[image] [image]

.NET Framework Class Library
CreditCard Fields
CreditCard Class See Also Send Feedback

The CreditCard type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
AmericanExpress |
AuthorizationTransaction |
CaptureTransaction |
CreditTransaction |
Discover |
ForceAuthTransaction |
InquiryTransaction |
MasterCard |
PayPal |
RecurringTransaction |
SaleTransaction |
Visa |
VoidTransaction |

See Also

CreditCard Class
InSite.Model Namespace


AmericanExpress Field

[image]

.NET Framework Class Library
CreditCard..::.AmericanExpress Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const AmericanExpress As String
C#
public const string AmericanExpress
Visual C++
public:
literal String^ AmericanExpress
JavaScript
InSite.Model.CreditCard.americanExpress

See Also

CreditCard Class
InSite.Model Namespace


AuthorizationTransaction Field

[image]

.NET Framework Class Library
CreditCard..::.AuthorizationTransaction Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const AuthorizationTransaction As String
C#
public const string AuthorizationTransaction
Visual C++
public:
literal String^ AuthorizationTransaction
JavaScript
InSite.Model.CreditCard.authorizationTransaction

See Also

CreditCard Class
InSite.Model Namespace


CaptureTransaction Field

[image]

.NET Framework Class Library
CreditCard..::.CaptureTransaction Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CaptureTransaction As String
C#
public const string CaptureTransaction
Visual C++
public:
literal String^ CaptureTransaction
JavaScript
InSite.Model.CreditCard.captureTransaction

See Also

CreditCard Class
InSite.Model Namespace


CreditTransaction Field

[image]

.NET Framework Class Library
CreditCard..::.CreditTransaction Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CreditTransaction As String
C#
public const string CreditTransaction
Visual C++
public:
literal String^ CreditTransaction
JavaScript
InSite.Model.CreditCard.creditTransaction

See Also

CreditCard Class
InSite.Model Namespace


Discover Field

[image]

.NET Framework Class Library
CreditCard..::.Discover Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const Discover As String
C#
public const string Discover
Visual C++
public:
literal String^ Discover
JavaScript
InSite.Model.CreditCard.discover

See Also

CreditCard Class
InSite.Model Namespace


ForceAuthTransaction Field

[image]

.NET Framework Class Library
CreditCard..::.ForceAuthTransaction Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ForceAuthTransaction As String
C#
public const string ForceAuthTransaction
Visual C++
public:
literal String^ ForceAuthTransaction
JavaScript
InSite.Model.CreditCard.forceAuthTransaction

See Also

CreditCard Class
InSite.Model Namespace


InquiryTransaction Field

[image]

.NET Framework Class Library
CreditCard..::.InquiryTransaction Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const InquiryTransaction As String
C#
public const string InquiryTransaction
Visual C++
public:
literal String^ InquiryTransaction
JavaScript
InSite.Model.CreditCard.inquiryTransaction

See Also

CreditCard Class
InSite.Model Namespace


MasterCard Field

[image]

.NET Framework Class Library
CreditCard..::.MasterCard Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const MasterCard As String
C#
public const string MasterCard
Visual C++
public:
literal String^ MasterCard
JavaScript
InSite.Model.CreditCard.masterCard

See Also

CreditCard Class
InSite.Model Namespace


PayPal Field

[image]

.NET Framework Class Library
CreditCard..::.PayPal Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const PayPal As String
C#
public const string PayPal
Visual C++
public:
literal String^ PayPal
JavaScript
InSite.Model.CreditCard.payPal

See Also

CreditCard Class
InSite.Model Namespace


RecurringTransaction Field

[image]

.NET Framework Class Library
CreditCard..::.RecurringTransaction Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RecurringTransaction As String
C#
public const string RecurringTransaction
Visual C++
public:
literal String^ RecurringTransaction
JavaScript
InSite.Model.CreditCard.recurringTransaction

See Also

CreditCard Class
InSite.Model Namespace


SaleTransaction Field

[image]

.NET Framework Class Library
CreditCard..::.SaleTransaction Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const SaleTransaction As String
C#
public const string SaleTransaction
Visual C++
public:
literal String^ SaleTransaction
JavaScript
InSite.Model.CreditCard.saleTransaction

See Also

CreditCard Class
InSite.Model Namespace


Visa Field

[image]

.NET Framework Class Library
CreditCard..::.Visa Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const Visa As String
C#
public const string Visa
Visual C++
public:
literal String^ Visa
JavaScript
InSite.Model.CreditCard.visa

See Also

CreditCard Class
InSite.Model Namespace


VoidTransaction Field

[image]

.NET Framework Class Library
CreditCard..::.VoidTransaction Field
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const VoidTransaction As String
C#
public const string VoidTransaction
Visual C++
public:
literal String^ VoidTransaction
JavaScript
InSite.Model.CreditCard.voidTransaction

See Also

CreditCard Class
InSite.Model Namespace


CreditCard Methods

[image] [image]

.NET Framework Class Library
CreditCard Methods
CreditCard Class See Also Send Feedback

The CreditCard type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCard Class
InSite.Model Namespace


CreditCard Properties

[image] [image]

.NET Framework Class Library
CreditCard Properties
CreditCard Class See Also Send Feedback

The CreditCard type exposes the following members.

Properties

Name | Description
Amount |
AuthCode |
CardNumber |
CardType |
CardTypes |
CCV |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CreditCardId |
CreditCardTransaction |
CSC |
CustomerNumber |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExpirationDate |
ExpirationMonth |
ExpirationYear |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsCIM |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderNumber |
OrigId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentNumber |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCard Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
CreditCard..::.Amount Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Amount As Decimal
C#
[DataMemberAttribute]
public decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
public:
property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

CreditCard Class
InSite.Model Namespace


AuthCode Property

[image]

.NET Framework Class Library
CreditCard..::.AuthCode Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property AuthCode As String
C#
[DataMemberAttribute]
public string AuthCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ AuthCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authCode();
function set_authCode(value);

See Also

CreditCard Class
InSite.Model Namespace


CardNumber Property

[image]

.NET Framework Class Library
CreditCard..::.CardNumber Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property CardNumber As String
C#
[DataMemberAttribute]
public string CardNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ CardNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardNumber();
function set_cardNumber(value);

See Also

CreditCard Class
InSite.Model Namespace


CardType Property

[image]

.NET Framework Class Library
CreditCard..::.CardType Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property CardType As String
C#
public string CardType { get; set; }
Visual C++
public:
property String^ CardType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cardType();
function set_cardType(value);

See Also

CreditCard Class
InSite.Model Namespace


CardTypes Property

[image]

.NET Framework Class Library
CreditCard..::.CardTypes Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CardTypes As List(Of String)
C#
public static List<string> CardTypes { get; }
Visual C++
public:
static property List<String^>^ CardTypes {
    List<String^>^ get ();
}
JavaScript
InSite.Model.CreditCard.get_cardTypes = function();

See Also

CreditCard Class
InSite.Model Namespace


CCV Property

[image]

.NET Framework Class Library
CreditCard..::.CCV Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property CCV As String
C#
public string CCV { get; set; }
Visual C++
public:
property String^ CCV {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_CCV();
function set_CCV(value);

See Also

CreditCard Class
InSite.Model Namespace


CreditCardId Property

[image]

.NET Framework Class Library
CreditCard..::.CreditCardId Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property CreditCardId As Guid
C#
public Guid CreditCardId { get; set; }
Visual C++
public:
property Guid CreditCardId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_creditCardId();
function set_creditCardId(value);

See Also

CreditCard Class
InSite.Model Namespace


CreditCardTransaction Property

[image]

.NET Framework Class Library
CreditCard..::.CreditCardTransaction Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CreditCardTransaction As CreditCardTransaction
C#
[DataMemberAttribute]
public virtual CreditCardTransaction CreditCardTransaction { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property CreditCardTransaction^ CreditCardTransaction {
    CreditCardTransaction^ get ();
    void set (CreditCardTransaction^ value);
}
JavaScript
function get_creditCardTransaction();
function set_creditCardTransaction(value);

See Also

CreditCard Class
InSite.Model Namespace


CSC Property

[image]

.NET Framework Class Library
CreditCard..::.CSC Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property CSC As String
C#
[DataMemberAttribute]
public string CSC { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ CSC {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_CSC();
function set_CSC(value);

See Also

CreditCard Class
InSite.Model Namespace


CustomerNumber Property

[image]

.NET Framework Class Library
CreditCard..::.CustomerNumber Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumber As String
C#
[DataMemberAttribute]
public virtual string CustomerNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumber();
function set_customerNumber(value);

See Also

CreditCard Class
InSite.Model Namespace


ExpirationDate Property

[image]

.NET Framework Class Library
CreditCard..::.ExpirationDate Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpirationDate As String
C#
public string ExpirationDate { get; set; }
Visual C++
public:
property String^ ExpirationDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationDate();
function set_expirationDate(value);

See Also

CreditCard Class
InSite.Model Namespace


ExpirationMonth Property

[image]

.NET Framework Class Library
CreditCard..::.ExpirationMonth Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property ExpirationMonth As Integer
C#
[DataMemberAttribute]
public int ExpirationMonth { get; set; }
Visual C++
[DataMemberAttribute]
public:
property int ExpirationMonth {
    int get ();
    void set (int value);
}
JavaScript
function get_expirationMonth();
function set_expirationMonth(value);

See Also

CreditCard Class
InSite.Model Namespace


ExpirationYear Property

[image]

.NET Framework Class Library
CreditCard..::.ExpirationYear Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property ExpirationYear As Integer
C#
[DataMemberAttribute]
public int ExpirationYear { get; set; }
Visual C++
[DataMemberAttribute]
public:
property int ExpirationYear {
    int get ();
    void set (int value);
}
JavaScript
function get_expirationYear();
function set_expirationYear(value);

See Also

CreditCard Class
InSite.Model Namespace


IsCIM Property

[image]

.NET Framework Class Library
CreditCard..::.IsCIM Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property IsCIM As Boolean
C#
public bool IsCIM { get; set; }
Visual C++
public:
property bool IsCIM {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isCIM();
function set_isCIM(value);

See Also

CreditCard Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CreditCard..::.Name Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Property Name As String
C#
[SortField]
[DataMemberAttribute]
public string Name { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CreditCard Class
InSite.Model Namespace


OrderNumber Property

[image]

.NET Framework Class Library
CreditCard..::.OrderNumber Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderNumber As String
C#
[DataMemberAttribute]
public virtual string OrderNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumber();
function set_orderNumber(value);

See Also

CreditCard Class
InSite.Model Namespace


OrigId Property

[image]

.NET Framework Class Library
CreditCard..::.OrigId Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property OrigId As String
C#
[DataMemberAttribute]
public string OrigId { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ OrigId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_origId();
function set_origId(value);

See Also

CreditCard Class
InSite.Model Namespace


ShipmentNumber Property

[image]

.NET Framework Class Library
CreditCard..::.ShipmentNumber Property
CreditCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipmentNumber As String
C#
[DataMemberAttribute]
public virtual string ShipmentNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipmentNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipmentNumber();
function set_shipmentNumber(value);

See Also

CreditCard Class
InSite.Model Namespace


CreditCardPayPal Class

[image]

.NET Framework Class Library
CreditCardPayPal Class
Members See Also Send Feedback

CreditCard_PayPal is a dummy credit card, in the sense that it has no name/number/expiration date, etc. The class has been created as dreived from CreditCard in order to allow it to pass throgh the code. If we were starting from scratch we may have come up with a "PaymentMethod" class from which "CreditCard" and "PayPal" are derived.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class CreditCardPayPal _
    Inherits CreditCard
C#
public class CreditCardPayPal : CreditCard
Visual C++
public ref class CreditCardPayPal : public CreditCard
JavaScript
InSite.Model.CreditCardPayPal = function();

Type.createClass(
    'InSite.Model.CreditCardPayPal',
    InSite.Model.CreditCard);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( CreditCard >)>)
InSite.Model..::.CreditCard
InSite.Model..::.CreditCardPayPal

See Also

CreditCardPayPal Members
InSite.Model Namespace


CreditCardPayPal Members

[image] [image]

.NET Framework Class Library
CreditCardPayPal Members
CreditCardPayPal Class Constructors Methods Fields Properties See Also Send Feedback

The CreditCardPayPal type exposes the following members.

Constructors

Name | Description
CreditCardPayPal |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount | (Inherited from CreditCard.)
AuthCode | (Inherited from CreditCard.)
CardNumber | (Inherited from CreditCard.)
CardType | (Inherited from CreditCard.)
CCV | (Inherited from CreditCard.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CreditCardId | (Inherited from CreditCard.)
CreditCardTransaction | (Inherited from CreditCard.)
CSC | (Inherited from CreditCard.)
CustomerNumber | (Inherited from CreditCard.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExpirationDate | (Inherited from CreditCard.)
ExpirationMonth | (Inherited from CreditCard.)
ExpirationYear | (Inherited from CreditCard.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsCIM | (Inherited from CreditCard.)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name | (Inherited from CreditCard.)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderNumber | (Inherited from CreditCard.)
OrigId | (Inherited from CreditCard.)
PayerID |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentNumber | (Inherited from CreditCard.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Token |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCardPayPal Class
InSite.Model Namespace


CreditCardPayPal Constructor

[image]

.NET Framework Class Library
CreditCardPayPal Constructor
CreditCardPayPal Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreditCardPayPal()
Visual C++
public:
CreditCardPayPal()
JavaScript
InSite.Model.CreditCardPayPal = function();

See Also

CreditCardPayPal Class
InSite.Model Namespace


CreditCardPayPal Fields

[image] [image]

.NET Framework Class Library
CreditCardPayPal Fields
CreditCardPayPal Class See Also Send Feedback

The CreditCardPayPal type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCardPayPal Class
InSite.Model Namespace


CreditCardPayPal Methods

[image] [image]

.NET Framework Class Library
CreditCardPayPal Methods
CreditCardPayPal Class See Also Send Feedback

The CreditCardPayPal type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCardPayPal Class
InSite.Model Namespace


CreditCardPayPal Properties

[image] [image]

.NET Framework Class Library
CreditCardPayPal Properties
CreditCardPayPal Class See Also Send Feedback

The CreditCardPayPal type exposes the following members.

Properties

Name | Description
Amount | (Inherited from CreditCard.)
AuthCode | (Inherited from CreditCard.)
CardNumber | (Inherited from CreditCard.)
CardType | (Inherited from CreditCard.)
CCV | (Inherited from CreditCard.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CreditCardId | (Inherited from CreditCard.)
CreditCardTransaction | (Inherited from CreditCard.)
CSC | (Inherited from CreditCard.)
CustomerNumber | (Inherited from CreditCard.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExpirationDate | (Inherited from CreditCard.)
ExpirationMonth | (Inherited from CreditCard.)
ExpirationYear | (Inherited from CreditCard.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsCIM | (Inherited from CreditCard.)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name | (Inherited from CreditCard.)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderNumber | (Inherited from CreditCard.)
OrigId | (Inherited from CreditCard.)
PayerID |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentNumber | (Inherited from CreditCard.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Token |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCardPayPal Class
InSite.Model Namespace


PayerID Property

[image]

.NET Framework Class Library
CreditCardPayPal..::.PayerID Property
CreditCardPayPal Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property PayerID As String
C#
public string PayerID { get; set; }
Visual C++
public:
property String^ PayerID {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_payerID();
function set_payerID(value);

See Also

CreditCardPayPal Class
InSite.Model Namespace


Token Property

[image]

.NET Framework Class Library
CreditCardPayPal..::.Token Property
CreditCardPayPal Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property Token As String
C#
public string Token { get; set; }
Visual C++
public:
property String^ Token {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_token();
function set_token(value);

See Also

CreditCardPayPal Class
InSite.Model Namespace


CreditCardTransaction Class

[image]

.NET Framework Class Library
CreditCardTransaction Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CreditCardTransaction _
    Inherits ModelBase(Of CreditCardTransaction)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CreditCardTransaction : ModelBase<CreditCardTransaction>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CreditCardTransaction : public ModelBase<CreditCardTransaction^>
JavaScript
InSite.Model.CreditCardTransaction = function();

Type.createClass(
    'InSite.Model.CreditCardTransaction',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CreditCardTransaction>)>)
InSite.Model..::.CreditCardTransaction

See Also

CreditCardTransaction Members
InSite.Model Namespace


CreditCardTransaction Members

[image] [image]

.NET Framework Class Library
CreditCardTransaction Members
CreditCardTransaction Class Constructors Methods Fields Properties See Also Send Feedback

The CreditCardTransaction type exposes the following members.

Constructors

Name | Description
CreditCardTransaction | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetReSubmitPaymentList |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PurgeEncryptedNumbers | Used to clean out encrypted numbers that are older than daysToStore days
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
CapturedAuthorizationStatus |
ErrorStatus |
NotApplicableStatus |
NotSubmittedStatus |
OpenAuthorizationStatus |
SubmittedStatus |
SubmittedToERPStatus |
VoidedStatus |

Properties

Name | Description
Amount |
AuthCode |
AVSAddr |
AVSZip |
BankCode |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CreditCardNumber |
CreditCardTransactionId |
CustomerNumber |
CustomerOrder |
CVV2Match |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExpirationDate |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderNumber |
OrigId |
PNRef |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RequestId |
RequestString |
RespMsg |
ResponseString |
RespText |
Result |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentNumber |
Site |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Status |
TransactionDate |
TransactionDescription |
TransactionType |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UnencryptedCreditCard |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCardTransaction Class
InSite.Model Namespace


CreditCardTransaction Constructor

[image] [image]

.NET Framework Class Library
CreditCardTransaction Constructor
CreditCardTransaction Class See Also Send Feedback

Overload List

Name | Description
CreditCardTransaction()()() |
CreditCardTransaction(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CreditCardTransaction Class
CreditCardTransaction Members
InSite.Model Namespace


CreditCardTransaction Constructor

[image]

.NET Framework Class Library
CreditCardTransaction Constructor
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CreditCardTransaction()
Visual C++
public:
CreditCardTransaction()
JavaScript
InSite.Model.CreditCardTransaction = function();

See Also

CreditCardTransaction Class
CreditCardTransaction Overload
InSite.Model Namespace


CreditCardTransaction Constructor (SearchMode)

[image]

.NET Framework Class Library
CreditCardTransaction Constructor (SearchMode)
CreditCardTransaction Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CreditCardTransaction(
    SearchMode searchMode
)
Visual C++
public:
CreditCardTransaction(
    SearchMode searchMode
)
JavaScript
InSite.Model.CreditCardTransaction = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CreditCardTransaction Class
CreditCardTransaction Overload
InSite.Model Namespace


CreditCardTransaction Fields

[image] [image]

.NET Framework Class Library
CreditCardTransaction Fields
CreditCardTransaction Class See Also Send Feedback

The CreditCardTransaction type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
CapturedAuthorizationStatus |
ErrorStatus |
NotApplicableStatus |
NotSubmittedStatus |
OpenAuthorizationStatus |
SubmittedStatus |
SubmittedToERPStatus |
VoidedStatus |

See Also

CreditCardTransaction Class
InSite.Model Namespace


CapturedAuthorizationStatus Field

[image]

.NET Framework Class Library
CreditCardTransaction..::.CapturedAuthorizationStatus Field
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared CapturedAuthorizationStatus As String
C#
public static string CapturedAuthorizationStatus
Visual C++
public:
static String^ CapturedAuthorizationStatus
JavaScript
InSite.Model.CreditCardTransaction.capturedAuthorizationStatus

See Also

CreditCardTransaction Class
InSite.Model Namespace


ErrorStatus Field

[image]

.NET Framework Class Library
CreditCardTransaction..::.ErrorStatus Field
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ErrorStatus As String
C#
public static string ErrorStatus
Visual C++
public:
static String^ ErrorStatus
JavaScript
InSite.Model.CreditCardTransaction.errorStatus

See Also

CreditCardTransaction Class
InSite.Model Namespace


NotApplicableStatus Field

[image]

.NET Framework Class Library
CreditCardTransaction..::.NotApplicableStatus Field
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared NotApplicableStatus As String
C#
public static string NotApplicableStatus
Visual C++
public:
static String^ NotApplicableStatus
JavaScript
InSite.Model.CreditCardTransaction.notApplicableStatus

See Also

CreditCardTransaction Class
InSite.Model Namespace


NotSubmittedStatus Field

[image]

.NET Framework Class Library
CreditCardTransaction..::.NotSubmittedStatus Field
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared NotSubmittedStatus As String
C#
public static string NotSubmittedStatus
Visual C++
public:
static String^ NotSubmittedStatus
JavaScript
InSite.Model.CreditCardTransaction.notSubmittedStatus

See Also

CreditCardTransaction Class
InSite.Model Namespace


OpenAuthorizationStatus Field

[image]

.NET Framework Class Library
CreditCardTransaction..::.OpenAuthorizationStatus Field
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared OpenAuthorizationStatus As String
C#
public static string OpenAuthorizationStatus
Visual C++
public:
static String^ OpenAuthorizationStatus
JavaScript
InSite.Model.CreditCardTransaction.openAuthorizationStatus

See Also

CreditCardTransaction Class
InSite.Model Namespace


SubmittedStatus Field

[image]

.NET Framework Class Library
CreditCardTransaction..::.SubmittedStatus Field
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared SubmittedStatus As String
C#
public static string SubmittedStatus
Visual C++
public:
static String^ SubmittedStatus
JavaScript
InSite.Model.CreditCardTransaction.submittedStatus

See Also

CreditCardTransaction Class
InSite.Model Namespace


SubmittedToERPStatus Field

[image]

.NET Framework Class Library
CreditCardTransaction..::.SubmittedToERPStatus Field
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared SubmittedToERPStatus As String
C#
public static string SubmittedToERPStatus
Visual C++
public:
static String^ SubmittedToERPStatus
JavaScript
InSite.Model.CreditCardTransaction.submittedToERPStatus

See Also

CreditCardTransaction Class
InSite.Model Namespace


VoidedStatus Field

[image]

.NET Framework Class Library
CreditCardTransaction..::.VoidedStatus Field
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared VoidedStatus As String
C#
public static string VoidedStatus
Visual C++
public:
static String^ VoidedStatus
JavaScript
InSite.Model.CreditCardTransaction.voidedStatus

See Also

CreditCardTransaction Class
InSite.Model Namespace


CreditCardTransaction Methods

[image] [image]

.NET Framework Class Library
CreditCardTransaction Methods
CreditCardTransaction Class See Also Send Feedback

The CreditCardTransaction type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetReSubmitPaymentList |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PurgeEncryptedNumbers | Used to clean out encrypted numbers that are older than daysToStore days
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCardTransaction Class
InSite.Model Namespace


GetReSubmitPaymentList Method

[image]

.NET Framework Class Library
CreditCardTransaction..::.GetReSubmitPaymentList Method
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetReSubmitPaymentList As IList(Of CreditCardTransaction)
C#
public static IList<CreditCardTransaction> GetReSubmitPaymentList()
Visual C++
public:
static IList<CreditCardTransaction^>^ GetReSubmitPaymentList()
JavaScript
InSite.Model.CreditCardTransaction.getReSubmitPaymentList = function();

See Also

CreditCardTransaction Class
InSite.Model Namespace


PurgeEncryptedNumbers Method

[image]

.NET Framework Class Library
CreditCardTransaction..::.PurgeEncryptedNumbers Method
CreditCardTransaction Class See Also Send Feedback

Used to clean out encrypted numbers that are older than daysToStore days

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub PurgeEncryptedNumbers ( _
    daysToStore As Integer _
)
C#
public static void PurgeEncryptedNumbers(
    int daysToStore
)
Visual C++
public:
static void PurgeEncryptedNumbers(
    int daysToStore
)
JavaScript
InSite.Model.CreditCardTransaction.purgeEncryptedNumbers = function(daysToStore);

Parameters

daysToStore
Type: System..::.Int32

See Also

CreditCardTransaction Class
InSite.Model Namespace


CreditCardTransaction Properties

[image] [image]

.NET Framework Class Library
CreditCardTransaction Properties
CreditCardTransaction Class See Also Send Feedback

The CreditCardTransaction type exposes the following members.

Properties

Name | Description
Amount |
AuthCode |
AVSAddr |
AVSZip |
BankCode |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CreditCardNumber |
CreditCardTransactionId |
CustomerNumber |
CustomerOrder |
CVV2Match |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExpirationDate |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderNumber |
OrigId |
PNRef |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RequestId |
RequestString |
RespMsg |
ResponseString |
RespText |
Result |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentNumber |
Site |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Status |
TransactionDate |
TransactionDescription |
TransactionType |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UnencryptedCreditCard |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CreditCardTransaction Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.Amount Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


AuthCode Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.AuthCode Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AuthCode As String
C#
[DataMemberAttribute]
public virtual string AuthCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AuthCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_authCode();
function set_authCode(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


AVSAddr Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.AVSAddr Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AVSAddr As String
C#
[DataMemberAttribute]
public virtual string AVSAddr { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AVSAddr {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsAddr();
function set_avsAddr(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


AVSZip Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.AVSZip Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AVSZip As String
C#
[DataMemberAttribute]
public virtual string AVSZip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AVSZip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_avsZip();
function set_avsZip(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


BankCode Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.BankCode Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BankCode As String
C#
[DataMemberAttribute]
public virtual string BankCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BankCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankCode();
function set_bankCode(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


CreditCardNumber Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.CreditCardNumber Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CreditCardNumber As String
C#
[DataMemberAttribute]
public virtual string CreditCardNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CreditCardNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_creditCardNumber();
function set_creditCardNumber(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


CreditCardTransactionId Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.CreditCardTransactionId Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCardTransactionId As Guid
C#
public virtual Guid CreditCardTransactionId { get; set; }
Visual C++
public:
virtual property Guid CreditCardTransactionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_creditCardTransactionId();
function set_creditCardTransactionId(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


CustomerNumber Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.CustomerNumber Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumber As String
C#
[DataMemberAttribute]
public virtual string CustomerNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumber();
function set_customerNumber(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.CustomerOrder Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


CVV2Match Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.CVV2Match Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CVV2Match As String
C#
[DataMemberAttribute]
public virtual string CVV2Match { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CVV2Match {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cvV2Match();
function set_cvV2Match(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


ExpirationDate Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.ExpirationDate Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ExpirationDate As String
C#
[DataMemberAttribute]
public virtual string ExpirationDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ExpirationDate {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_expirationDate();
function set_expirationDate(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.Name Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


OrderNumber Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.OrderNumber Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderNumber As String
C#
[DataMemberAttribute]
public virtual string OrderNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumber();
function set_orderNumber(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


OrigId Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.OrigId Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrigId As String
C#
[DataMemberAttribute]
public virtual string OrigId { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ OrigId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_origId();
function set_origId(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


PNRef Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.PNRef Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PNRef As String
C#
[DataMemberAttribute]
public virtual string PNRef { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PNRef {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pnRef();
function set_pnRef(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


RequestId Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.RequestId Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RequestId As String
C#
[DataMemberAttribute]
public virtual string RequestId { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RequestId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestId();
function set_requestId(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


RequestString Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.RequestString Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RequestString As String
C#
[DataMemberAttribute]
public virtual string RequestString { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RequestString {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_requestString();
function set_requestString(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


RespMsg Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.RespMsg Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RespMsg As String
C#
[DataMemberAttribute]
public virtual string RespMsg { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RespMsg {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_respMsg();
function set_respMsg(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


ResponseString Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.ResponseString Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ResponseString As String
C#
[DataMemberAttribute]
public virtual string ResponseString { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ResponseString {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_responseString();
function set_responseString(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


RespText Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.RespText Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RespText As String
C#
[DataMemberAttribute]
public virtual string RespText { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RespText {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_respText();
function set_respText(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


Result Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.Result Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Result As String
C#
[DataMemberAttribute]
public virtual string Result { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Result {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_result();
function set_result(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


ShipmentNumber Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.ShipmentNumber Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipmentNumber As String
C#
[DataMemberAttribute]
public virtual string ShipmentNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipmentNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipmentNumber();
function set_shipmentNumber(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


Site Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.Site Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Site As String
C#
[DataMemberAttribute]
public virtual string Site { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Site {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_site();
function set_site(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


Status Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.Status Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Status As String
C#
[DataMemberAttribute]
public virtual string Status { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Status {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_status();
function set_status(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


TransactionDate Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.TransactionDate Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TransactionDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime TransactionDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime TransactionDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_transactionDate();
function set_transactionDate(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


TransactionDescription Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.TransactionDescription Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TransactionDescription As String
C#
public virtual string TransactionDescription { get; }
Visual C++
public:
virtual property String^ TransactionDescription {
    String^ get ();
}
JavaScript
function get_transactionDescription();

See Also

CreditCardTransaction Class
InSite.Model Namespace


TransactionType Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.TransactionType Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property TransactionType As String
C#
[SortField]
[DataMemberAttribute]
public virtual string TransactionType { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ TransactionType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_transactionType();
function set_transactionType(value);

See Also

CreditCardTransaction Class
InSite.Model Namespace


UnencryptedCreditCard Property

[image]

.NET Framework Class Library
CreditCardTransaction..::.UnencryptedCreditCard Property
CreditCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property UnencryptedCreditCard As String
C#
public virtual string UnencryptedCreditCard { get; }
Visual C++
public:
virtual property String^ UnencryptedCreditCard {
    String^ get ();
}
JavaScript
function get_unencryptedCreditCard();

See Also

CreditCardTransaction Class
InSite.Model Namespace


Customer Class

[image]

.NET Framework Class Library
Customer Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Customer _
    Inherits ModelBase(Of Customer)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Customer : ModelBase<Customer>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Customer : public ModelBase<Customer^>
JavaScript
InSite.Model.Customer = function();

Type.createClass(
    'InSite.Model.Customer',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Customer>)>)
InSite.Model..::.Customer

See Also

Customer Members
InSite.Model Namespace


Customer Members

[image] [image]

.NET Framework Class Library
Customer Members
Customer Class Constructors Methods Fields Properties See Also Send Feedback

The Customer type exposes the following members.

Constructors

Name | Description
Customer | Overloaded.

Methods

Name | Description
AddCarrier |
AddCustomerDiscount |
AddCustomerProduct |
AddCustomerProductSet |
AddCustomerProperty |
AddProduct |
AddSalesman |
AddShipTo |
AddUserProfile |
AddWishList |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByNumber |
GetByNumberSequence |
GetCustomerListByCustomerProperty |
GetCustomerProduct |
GetCustomerProperty |
GetCustomerUser |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetNextCustomerNumber | Overloaded.
GetNextCustomerSequence |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetShipTo |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebSiteDiscount |
HasWebSiteDiscount |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCarrier |
RemoveCustomerDiscount |
RemoveCustomerProduct |
RemoveCustomerProductSet |
RemoveCustomerProperty |
RemoveProduct |
RemoveSalesman |
RemoveShipTo |
RemoveUserProfile |
RemoveWishList |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
AbandonedCartNumber |

Properties

Name | Description
ActiveShipTosWithBillTo |
ActiveShipTosWithoutBillTo |
Address1 |
Address2 |
Address3 |
Address4 |
AllowDropShip |
AvailableCreditLimit |
BankCode |
Carriers | Sets/Gets a list of carriers for this customer if the this is a shipto for a customer it returns the shipto carriers list no matter what.
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
City |
Company |
Contact1 |
Contact2 |
Contact3 |
Countries |
Country |
County |
CreditHold |
CreditLimit |
CurrencyCode |
Current |
CustomerCarriers | Gets a list of Carriers for this customer. if the customer is a shipto it will return the shipto carriers if they have more than 0 carriers, if the carrier count is 0 and there is a parent it will return the parents carriers.
CustomerCountry |
CustomerId |
CustomerName |
CustomerNumber |
CustomerNumberFormat |
CustomerNumberPrefix |
CustomerNumberSequenceName |
CustomerOrders |
CustomerProducts | Holds Customer specific extended information about Products (ex. Customer Product Name)
CustomerProductSets |
CustomerProperties |
CustomerSalesmen | Gets a list of Salesmen for this customer. if the customer is a shipto it will return the shipto Salesmen if they have more than 0 Salesmen, if the Salesmen count is 0 and there is a parent it will return the parents Salesmen.
CustomerSequence |
CustomerSequenceFormat |
CustomerSequencePrefix |
CustomerState |
CustomerType |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Discount |
Discounts |
DropShipFeeRequired |
Email |
EndUserType |
ERPNumber |
Fax |
FirstName |
HTMLAddress |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InvoiceFrequency |
Invoices |
IsActive |
IsDropShip |
IsGuest |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LastName |
MiddleName |
NonCartOrders |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OpenInvoiceAmount |
OpenOrderAmount |
ParentCustomer |
Phone1 |
Phone2 |
Phone3 |
PriceCode |
Products | Holds a list of Products attached to this Customer, could be used for a Wish List etc
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Salesman |
Salesmen |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
SendEmail |
SendFax |
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipCode |
ShipEarly |
ShipPartial |
ShipSite |
ShipTos |
ShipTosByCompany |
SiteCompany |
SiteCompanyName |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
States |
TaxCode1 |
TaxCode2 |
TermsCode |
Territory |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfiles |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Warehouse |
WishLists |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

Customer Class
InSite.Model Namespace


Customer Constructor

[image] [image]

.NET Framework Class Library
Customer Constructor
Customer Class See Also Send Feedback

Overload List

Name | Description
Customer()()() |
Customer(SearchMode) |

See Also

Customer Class
Customer Members
InSite.Model Namespace


Customer Constructor

[image]

.NET Framework Class Library
Customer Constructor
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Customer()
Visual C++
public:
Customer()
JavaScript
InSite.Model.Customer = function();

See Also

Customer Class
Customer Overload
InSite.Model Namespace


Customer Constructor (SearchMode)

[image]

.NET Framework Class Library
Customer Constructor (SearchMode)
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Customer(
    SearchMode searchMode
)
Visual C++
public:
Customer(
    SearchMode searchMode
)
JavaScript
InSite.Model.Customer = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Customer Class
Customer Overload
InSite.Model Namespace


Customer Fields

[image] [image]

.NET Framework Class Library
Customer Fields
Customer Class See Also Send Feedback

The Customer type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
AbandonedCartNumber |

See Also

Customer Class
InSite.Model Namespace


AbandonedCartNumber Field

[image]

.NET Framework Class Library
Customer..::.AbandonedCartNumber Field
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared AbandonedCartNumber As String
C#
public static string AbandonedCartNumber
Visual C++
public:
static String^ AbandonedCartNumber
JavaScript
InSite.Model.Customer.abandonedCartNumber

See Also

Customer Class
InSite.Model Namespace


Customer Methods

[image] [image]

.NET Framework Class Library
Customer Methods
Customer Class See Also Send Feedback

The Customer type exposes the following members.

Methods

Name | Description
AddCarrier |
AddCustomerDiscount |
AddCustomerProduct |
AddCustomerProductSet |
AddCustomerProperty |
AddProduct |
AddSalesman |
AddShipTo |
AddUserProfile |
AddWishList |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByNumber |
GetByNumberSequence |
GetCustomerListByCustomerProperty |
GetCustomerProduct |
GetCustomerProperty |
GetCustomerUser |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetNextCustomerNumber | Overloaded.
GetNextCustomerSequence |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetShipTo |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebSiteDiscount |
HasWebSiteDiscount |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCarrier |
RemoveCustomerDiscount |
RemoveCustomerProduct |
RemoveCustomerProductSet |
RemoveCustomerProperty |
RemoveProduct |
RemoveSalesman |
RemoveShipTo |
RemoveUserProfile |
RemoveWishList |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Customer Class
InSite.Model Namespace


AddCarrier Method

[image]

.NET Framework Class Library
Customer..::.AddCarrier Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCarrier ( _
    value As Carrier _
)
C#
public virtual void AddCarrier(
    Carrier value
)
Visual C++
public:
virtual void AddCarrier(
    Carrier^ value
)
JavaScript
function addCarrier(value);

Parameters

value
Type: InSite.Model..::.Carrier

See Also

Customer Class
InSite.Model Namespace


AddCustomerDiscount Method

[image]

.NET Framework Class Library
Customer..::.AddCustomerDiscount Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomerDiscount ( _
    value As CustomerDiscount _
)
C#
public virtual void AddCustomerDiscount(
    CustomerDiscount value
)
Visual C++
public:
virtual void AddCustomerDiscount(
    CustomerDiscount^ value
)
JavaScript
function addCustomerDiscount(value);

Parameters

value
Type: InSite.Model..::.CustomerDiscount

See Also

Customer Class
InSite.Model Namespace


AddCustomerProduct Method

[image]

.NET Framework Class Library
Customer..::.AddCustomerProduct Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomerProduct ( _
    value As CustomerProduct _
)
C#
public virtual void AddCustomerProduct(
    CustomerProduct value
)
Visual C++
public:
virtual void AddCustomerProduct(
    CustomerProduct^ value
)
JavaScript
function addCustomerProduct(value);

Parameters

value
Type: InSite.Model..::.CustomerProduct

See Also

Customer Class
InSite.Model Namespace


AddCustomerProductSet Method

[image]

.NET Framework Class Library
Customer..::.AddCustomerProductSet Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomerProductSet ( _
    value As CustomerProductSet _
)
C#
public virtual void AddCustomerProductSet(
    CustomerProductSet value
)
Visual C++
public:
virtual void AddCustomerProductSet(
    CustomerProductSet^ value
)
JavaScript
function addCustomerProductSet(value);

Parameters

value
Type: InSite.Model..::.CustomerProductSet

See Also

Customer Class
InSite.Model Namespace


AddCustomerProperty Method

[image]

.NET Framework Class Library
Customer..::.AddCustomerProperty Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomerProperty ( _
    value As CustomerProperty _
)
C#
public virtual void AddCustomerProperty(
    CustomerProperty value
)
Visual C++
public:
virtual void AddCustomerProperty(
    CustomerProperty^ value
)
JavaScript
function addCustomerProperty(value);

Parameters

value
Type: InSite.Model..::.CustomerProperty

See Also

Customer Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
Customer..::.AddProduct Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Customer Class
InSite.Model Namespace


AddSalesman Method

[image]

.NET Framework Class Library
Customer..::.AddSalesman Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddSalesman ( _
    value As Salesman _
)
C#
public virtual void AddSalesman(
    Salesman value
)
Visual C++
public:
virtual void AddSalesman(
    Salesman^ value
)
JavaScript
function addSalesman(value);

Parameters

value
Type: InSite.Model..::.Salesman

See Also

Customer Class
InSite.Model Namespace


AddShipTo Method

[image]

.NET Framework Class Library
Customer..::.AddShipTo Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipTo ( _
    value As Customer _
)
C#
public virtual void AddShipTo(
    Customer value
)
Visual C++
public:
virtual void AddShipTo(
    Customer^ value
)
JavaScript
function addShipTo(value);

Parameters

value
Type: InSite.Model..::.Customer

See Also

Customer Class
InSite.Model Namespace


AddUserProfile Method

[image]

.NET Framework Class Library
Customer..::.AddUserProfile Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddUserProfile ( _
    value As UserProfile _
)
C#
public virtual void AddUserProfile(
    UserProfile value
)
Visual C++
public:
virtual void AddUserProfile(
    UserProfile^ value
)
JavaScript
function addUserProfile(value);

Parameters

value
Type: InSite.Model..::.UserProfile

See Also

Customer Class
InSite.Model Namespace


AddWishList Method

[image]

.NET Framework Class Library
Customer..::.AddWishList Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWishList ( _
    value As WishList _
)
C#
public virtual void AddWishList(
    WishList value
)
Visual C++
public:
virtual void AddWishList(
    WishList^ value
)
JavaScript
function addWishList(value);

Parameters

value
Type: InSite.Model..::.WishList

See Also

Customer Class
InSite.Model Namespace


GetByNumber Method

[image]

.NET Framework Class Library
Customer..::.GetByNumber Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByNumber ( _
    customerNumber As String _
) As Customer
C#
public static Customer GetByNumber(
    string customerNumber
)
Visual C++
public:
static Customer^ GetByNumber(
    String^ customerNumber
)
JavaScript
InSite.Model.Customer.getByNumber = function(customerNumber);

Parameters

customerNumber
Type: System..::.String

See Also

Customer Class
InSite.Model Namespace


GetByNumberSequence Method

[image]

.NET Framework Class Library
Customer..::.GetByNumberSequence Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByNumberSequence ( _
    customerNumber As String, _
    customerSequence As String _
) As Customer
C#
public static Customer GetByNumberSequence(
    string customerNumber,
    string customerSequence
)
Visual C++
public:
static Customer^ GetByNumberSequence(
    String^ customerNumber,
    String^ customerSequence
)
JavaScript
InSite.Model.Customer.getByNumberSequence = function(customerNumber, customerSequence);

Parameters

customerNumber
Type: System..::.String
customerSequence
Type: System..::.String

See Also

Customer Class
InSite.Model Namespace


GetCustomerListByCustomerProperty Method

[image]

.NET Framework Class Library
Customer..::.GetCustomerListByCustomerProperty Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCustomerListByCustomerProperty ( _
    customerProperty As String, _
    customerPropertyValue As String _
) As IList(Of Customer)
C#
public static IList<Customer> GetCustomerListByCustomerProperty(
    string customerProperty,
    string customerPropertyValue
)
Visual C++
public:
static IList<Customer^>^ GetCustomerListByCustomerProperty(
    String^ customerProperty,
    String^ customerPropertyValue
)
JavaScript
InSite.Model.Customer.getCustomerListByCustomerProperty = function(customerProperty, customerPropertyValue);

Parameters

customerProperty
Type: System..::.String
customerPropertyValue
Type: System..::.String

See Also

Customer Class
InSite.Model Namespace


GetCustomerProduct Method

[image]

.NET Framework Class Library
Customer..::.GetCustomerProduct Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCustomerProduct ( _
    product As Product _
) As CustomerProduct
C#
public virtual CustomerProduct GetCustomerProduct(
    Product product
)
Visual C++
public:
virtual CustomerProduct^ GetCustomerProduct(
    Product^ product
)
JavaScript
function getCustomerProduct(product);

Parameters

product
Type: InSite.Model..::.Product

See Also

Customer Class
InSite.Model Namespace


GetCustomerProperty Method

[image]

.NET Framework Class Library
Customer..::.GetCustomerProperty Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCustomerProperty ( _
    name As String _
) As CustomerProperty
C#
public virtual CustomerProperty GetCustomerProperty(
    string name
)
Visual C++
public:
virtual CustomerProperty^ GetCustomerProperty(
    String^ name
)
JavaScript
function getCustomerProperty(name);

Parameters

name
Type: System..::.String

See Also

Customer Class
InSite.Model Namespace


GetCustomerUser Method

[image]

.NET Framework Class Library
Customer..::.GetCustomerUser Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCustomerUser ( _
    userName As String _
) As UserProfile
C#
public virtual UserProfile GetCustomerUser(
    string userName
)
Visual C++
public:
virtual UserProfile^ GetCustomerUser(
    String^ userName
)
JavaScript
function getCustomerUser(userName);

Parameters

userName
Type: System..::.String

See Also

Customer Class
InSite.Model Namespace


GetNextCustomerNumber Method

[image] [image]

.NET Framework Class Library
Customer..::.GetNextCustomerNumber Method
Customer Class See Also Send Feedback

Overload List

Name | Description
GetNextCustomerNumber()()() |
GetNextCustomerNumber(String, String) |

See Also

Customer Class
Customer Members
InSite.Model Namespace


GetNextCustomerNumber Method

[image]

.NET Framework Class Library
Customer..::.GetNextCustomerNumber Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNextCustomerNumber As String
C#
public static string GetNextCustomerNumber()
Visual C++
public:
static String^ GetNextCustomerNumber()
JavaScript
InSite.Model.Customer.getNextCustomerNumber = function();

See Also

Customer Class
GetNextCustomerNumber Overload
InSite.Model Namespace


GetNextCustomerNumber Method (String, String)

[image]

.NET Framework Class Library
Customer..::.GetNextCustomerNumber Method (String, String)
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNextCustomerNumber ( _
    prefix As String, _
    format As String _
) As String
C#
public static string GetNextCustomerNumber(
    string prefix,
    string format
)
Visual C++
public:
static String^ GetNextCustomerNumber(
    String^ prefix,
    String^ format
)
JavaScript
InSite.Model.Customer.getNextCustomerNumber = function(prefix, format);

Parameters

prefix
Type: System..::.String
format
Type: System..::.String

See Also

Customer Class
GetNextCustomerNumber Overload
InSite.Model Namespace


GetNextCustomerSequence Method

[image]

.NET Framework Class Library
Customer..::.GetNextCustomerSequence Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNextCustomerSequence ( _
    customerNumber As String _
) As String
C#
public static string GetNextCustomerSequence(
    string customerNumber
)
Visual C++
public:
static String^ GetNextCustomerSequence(
    String^ customerNumber
)
JavaScript
InSite.Model.Customer.getNextCustomerSequence = function(customerNumber);

Parameters

customerNumber
Type: System..::.String

See Also

Customer Class
InSite.Model Namespace


GetShipTo Method

[image]

.NET Framework Class Library
Customer..::.GetShipTo Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetShipTo ( _
    customerSequence As String _
) As Customer
C#
public virtual Customer GetShipTo(
    string customerSequence
)
Visual C++
public:
virtual Customer^ GetShipTo(
    String^ customerSequence
)
JavaScript
function getShipTo(customerSequence);

Parameters

customerSequence
Type: System..::.String

See Also

Customer Class
InSite.Model Namespace


GetWebSiteDiscount Method

[image]

.NET Framework Class Library
Customer..::.GetWebSiteDiscount Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetWebSiteDiscount ( _
    webSite As WebSite _
) As CustomerDiscount
C#
public virtual CustomerDiscount GetWebSiteDiscount(
    WebSite webSite
)
Visual C++
public:
virtual CustomerDiscount^ GetWebSiteDiscount(
    WebSite^ webSite
)
JavaScript
function getWebSiteDiscount(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

Customer Class
InSite.Model Namespace


HasWebSiteDiscount Method

[image]

.NET Framework Class Library
Customer..::.HasWebSiteDiscount Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function HasWebSiteDiscount ( _
    webSite As WebSite _
) As Boolean
C#
public virtual bool HasWebSiteDiscount(
    WebSite webSite
)
Visual C++
public:
virtual bool HasWebSiteDiscount(
    WebSite^ webSite
)
JavaScript
function hasWebSiteDiscount(webSite);

Parameters

webSite
Type: InSite.Model..::.WebSite

See Also

Customer Class
InSite.Model Namespace


RemoveCarrier Method

[image]

.NET Framework Class Library
Customer..::.RemoveCarrier Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCarrier ( _
    value As Carrier _
)
C#
public virtual void RemoveCarrier(
    Carrier value
)
Visual C++
public:
virtual void RemoveCarrier(
    Carrier^ value
)
JavaScript
function removeCarrier(value);

Parameters

value
Type: InSite.Model..::.Carrier

See Also

Customer Class
InSite.Model Namespace


RemoveCustomerDiscount Method

[image]

.NET Framework Class Library
Customer..::.RemoveCustomerDiscount Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomerDiscount ( _
    value As CustomerDiscount _
)
C#
public virtual void RemoveCustomerDiscount(
    CustomerDiscount value
)
Visual C++
public:
virtual void RemoveCustomerDiscount(
    CustomerDiscount^ value
)
JavaScript
function removeCustomerDiscount(value);

Parameters

value
Type: InSite.Model..::.CustomerDiscount

See Also

Customer Class
InSite.Model Namespace


RemoveCustomerProduct Method

[image]

.NET Framework Class Library
Customer..::.RemoveCustomerProduct Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomerProduct ( _
    value As CustomerProduct _
)
C#
public virtual void RemoveCustomerProduct(
    CustomerProduct value
)
Visual C++
public:
virtual void RemoveCustomerProduct(
    CustomerProduct^ value
)
JavaScript
function removeCustomerProduct(value);

Parameters

value
Type: InSite.Model..::.CustomerProduct

See Also

Customer Class
InSite.Model Namespace


RemoveCustomerProductSet Method

[image]

.NET Framework Class Library
Customer..::.RemoveCustomerProductSet Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomerProductSet ( _
    value As CustomerProductSet _
)
C#
public virtual void RemoveCustomerProductSet(
    CustomerProductSet value
)
Visual C++
public:
virtual void RemoveCustomerProductSet(
    CustomerProductSet^ value
)
JavaScript
function removeCustomerProductSet(value);

Parameters

value
Type: InSite.Model..::.CustomerProductSet

See Also

Customer Class
InSite.Model Namespace


RemoveCustomerProperty Method

[image]

.NET Framework Class Library
Customer..::.RemoveCustomerProperty Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomerProperty ( _
    value As CustomerProperty _
)
C#
public virtual void RemoveCustomerProperty(
    CustomerProperty value
)
Visual C++
public:
virtual void RemoveCustomerProperty(
    CustomerProperty^ value
)
JavaScript
function removeCustomerProperty(value);

Parameters

value
Type: InSite.Model..::.CustomerProperty

See Also

Customer Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
Customer..::.RemoveProduct Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Customer Class
InSite.Model Namespace


RemoveSalesman Method

[image]

.NET Framework Class Library
Customer..::.RemoveSalesman Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSalesman ( _
    value As Salesman _
)
C#
public virtual void RemoveSalesman(
    Salesman value
)
Visual C++
public:
virtual void RemoveSalesman(
    Salesman^ value
)
JavaScript
function removeSalesman(value);

Parameters

value
Type: InSite.Model..::.Salesman

See Also

Customer Class
InSite.Model Namespace


RemoveShipTo Method

[image]

.NET Framework Class Library
Customer..::.RemoveShipTo Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipTo ( _
    value As Customer _
)
C#
public virtual void RemoveShipTo(
    Customer value
)
Visual C++
public:
virtual void RemoveShipTo(
    Customer^ value
)
JavaScript
function removeShipTo(value);

Parameters

value
Type: InSite.Model..::.Customer

See Also

Customer Class
InSite.Model Namespace


RemoveUserProfile Method

[image]

.NET Framework Class Library
Customer..::.RemoveUserProfile Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveUserProfile ( _
    value As UserProfile _
)
C#
public virtual void RemoveUserProfile(
    UserProfile value
)
Visual C++
public:
virtual void RemoveUserProfile(
    UserProfile^ value
)
JavaScript
function removeUserProfile(value);

Parameters

value
Type: InSite.Model..::.UserProfile

See Also

Customer Class
InSite.Model Namespace


RemoveWishList Method

[image]

.NET Framework Class Library
Customer..::.RemoveWishList Method
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWishList ( _
    value As WishList _
)
C#
public virtual void RemoveWishList(
    WishList value
)
Visual C++
public:
virtual void RemoveWishList(
    WishList^ value
)
JavaScript
function removeWishList(value);

Parameters

value
Type: InSite.Model..::.WishList

See Also

Customer Class
InSite.Model Namespace


Customer Properties

[image] [image]

.NET Framework Class Library
Customer Properties
Customer Class See Also Send Feedback

The Customer type exposes the following members.

Properties

Name | Description
ActiveShipTosWithBillTo |
ActiveShipTosWithoutBillTo |
Address1 |
Address2 |
Address3 |
Address4 |
AllowDropShip |
AvailableCreditLimit |
BankCode |
Carriers | Sets/Gets a list of carriers for this customer if the this is a shipto for a customer it returns the shipto carriers list no matter what.
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
City |
Company |
Contact1 |
Contact2 |
Contact3 |
Countries |
Country |
County |
CreditHold |
CreditLimit |
CurrencyCode |
Current |
CustomerCarriers | Gets a list of Carriers for this customer. if the customer is a shipto it will return the shipto carriers if they have more than 0 carriers, if the carrier count is 0 and there is a parent it will return the parents carriers.
CustomerCountry |
CustomerId |
CustomerName |
CustomerNumber |
CustomerNumberFormat |
CustomerNumberPrefix |
CustomerNumberSequenceName |
CustomerOrders |
CustomerProducts | Holds Customer specific extended information about Products (ex. Customer Product Name)
CustomerProductSets |
CustomerProperties |
CustomerSalesmen | Gets a list of Salesmen for this customer. if the customer is a shipto it will return the shipto Salesmen if they have more than 0 Salesmen, if the Salesmen count is 0 and there is a parent it will return the parents Salesmen.
CustomerSequence |
CustomerSequenceFormat |
CustomerSequencePrefix |
CustomerState |
CustomerType |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Discount |
Discounts |
DropShipFeeRequired |
Email |
EndUserType |
ERPNumber |
Fax |
FirstName |
HTMLAddress |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InvoiceFrequency |
Invoices |
IsActive |
IsDropShip |
IsGuest |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LastName |
MiddleName |
NonCartOrders |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OpenInvoiceAmount |
OpenOrderAmount |
ParentCustomer |
Phone1 |
Phone2 |
Phone3 |
PriceCode |
Products | Holds a list of Products attached to this Customer, could be used for a Wish List etc
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Salesman |
Salesmen |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
SendEmail |
SendFax |
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipCode |
ShipEarly |
ShipPartial |
ShipSite |
ShipTos |
ShipTosByCompany |
SiteCompany |
SiteCompanyName |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
States |
TaxCode1 |
TaxCode2 |
TermsCode |
Territory |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfiles |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Warehouse |
WishLists |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

Customer Class
InSite.Model Namespace


ActiveShipTosWithBillTo Property

[image]

.NET Framework Class Library
Customer..::.ActiveShipTosWithBillTo Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveShipTosWithBillTo As ChildList(Of Customer)
C#
public virtual ChildList<Customer> ActiveShipTosWithBillTo { get; }
Visual C++
public:
virtual property ChildList<Customer^>^ ActiveShipTosWithBillTo {
    ChildList<Customer^>^ get ();
}
JavaScript
function get_activeShipTosWithBillTo();

See Also

Customer Class
InSite.Model Namespace


ActiveShipTosWithoutBillTo Property

[image]

.NET Framework Class Library
Customer..::.ActiveShipTosWithoutBillTo Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveShipTosWithoutBillTo As ChildList(Of Customer)
C#
public virtual ChildList<Customer> ActiveShipTosWithoutBillTo { get; }
Visual C++
public:
virtual property ChildList<Customer^>^ ActiveShipTosWithoutBillTo {
    ChildList<Customer^>^ get ();
}
JavaScript
function get_activeShipTosWithoutBillTo();

See Also

Customer Class
InSite.Model Namespace


Address1 Property

[image]

.NET Framework Class Library
Customer..::.Address1 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address1 As String
C#
[DataMemberAttribute]
public virtual string Address1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address1();
function set_address1(value);

See Also

Customer Class
InSite.Model Namespace


Address2 Property

[image]

.NET Framework Class Library
Customer..::.Address2 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address2 As String
C#
[DataMemberAttribute]
public virtual string Address2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address2();
function set_address2(value);

See Also

Customer Class
InSite.Model Namespace


Address3 Property

[image]

.NET Framework Class Library
Customer..::.Address3 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address3 As String
C#
[DataMemberAttribute]
public virtual string Address3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address3();
function set_address3(value);

See Also

Customer Class
InSite.Model Namespace


Address4 Property

[image]

.NET Framework Class Library
Customer..::.Address4 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address4 As String
C#
[DataMemberAttribute]
public virtual string Address4 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address4();
function set_address4(value);

See Also

Customer Class
InSite.Model Namespace


AllowDropShip Property

[image]

.NET Framework Class Library
Customer..::.AllowDropShip Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AllowDropShip As Boolean
C#
[DataMemberAttribute]
public virtual bool AllowDropShip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool AllowDropShip {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowDropShip();
function set_allowDropShip(value);

See Also

Customer Class
InSite.Model Namespace


AvailableCreditLimit Property

[image]

.NET Framework Class Library
Customer..::.AvailableCreditLimit Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property AvailableCreditLimit As Decimal
C#
public virtual decimal AvailableCreditLimit { get; private set; }
Visual C++
public:
virtual property Decimal AvailableCreditLimit {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_availableCreditLimit();
function set_availableCreditLimit(value);

See Also

Customer Class
InSite.Model Namespace


BankCode Property

[image]

.NET Framework Class Library
Customer..::.BankCode Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BankCode As String
C#
[DataMemberAttribute]
public virtual string BankCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BankCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bankCode();
function set_bankCode(value);

See Also

Customer Class
InSite.Model Namespace


Carriers Property

[image]

.NET Framework Class Library
Customer..::.Carriers Property
Customer Class See Also Send Feedback

Sets/Gets a list of carriers for this customer if the this is a shipto for a customer it returns the shipto carriers list no matter what.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Carriers As ChildList(Of Carrier)
C#
[DataMemberAttribute]
public virtual ChildList<Carrier> Carriers { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Carrier^>^ Carriers {
    ChildList<Carrier^>^ get ();
    void set (ChildList<Carrier^>^ value);
}
JavaScript
function get_carriers();
function set_carriers(value);

See Also

Customer Class
InSite.Model Namespace


City Property

[image]

.NET Framework Class Library
Customer..::.City Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property City As String
C#
[DataMemberAttribute]
public virtual string City { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ City {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

See Also

Customer Class
InSite.Model Namespace


Company Property

[image]

.NET Framework Class Library
Customer..::.Company Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Company As String
C#
[DataMemberAttribute]
public virtual string Company { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Company {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_company();
function set_company(value);

See Also

Customer Class
InSite.Model Namespace


Contact1 Property

[image]

.NET Framework Class Library
Customer..::.Contact1 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Contact1 As String
C#
[DataMemberAttribute]
public virtual string Contact1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Contact1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contact1();
function set_contact1(value);

See Also

Customer Class
InSite.Model Namespace


Contact2 Property

[image]

.NET Framework Class Library
Customer..::.Contact2 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Contact2 As String
C#
[DataMemberAttribute]
public virtual string Contact2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Contact2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contact2();
function set_contact2(value);

See Also

Customer Class
InSite.Model Namespace


Contact3 Property

[image]

.NET Framework Class Library
Customer..::.Contact3 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Contact3 As String
C#
[DataMemberAttribute]
public virtual string Contact3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Contact3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contact3();
function set_contact3(value);

See Also

Customer Class
InSite.Model Namespace


Countries Property

[image]

.NET Framework Class Library
Customer..::.Countries Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Countries As IList(Of Country)
C#
public virtual IList<Country> Countries { get; }
Visual C++
public:
virtual property IList<Country^>^ Countries {
    IList<Country^>^ get ();
}
JavaScript
function get_countries();

See Also

Customer Class
InSite.Model Namespace


Country Property

[image]

.NET Framework Class Library
Customer..::.Country Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Country As String
C#
[DataMemberAttribute]
public virtual string Country { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

Customer Class
InSite.Model Namespace


County Property

[image]

.NET Framework Class Library
Customer..::.County Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property County As String
C#
[DataMemberAttribute]
public virtual string County { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ County {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_county();
function set_county(value);

See Also

Customer Class
InSite.Model Namespace


CreditHold Property

[image]

.NET Framework Class Library
Customer..::.CreditHold Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CreditHold As Boolean
C#
[DataMemberAttribute]
public virtual bool CreditHold { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool CreditHold {
    bool get ();
    void set (bool value);
}
JavaScript
function get_creditHold();
function set_creditHold(value);

See Also

Customer Class
InSite.Model Namespace


CreditLimit Property

[image]

.NET Framework Class Library
Customer..::.CreditLimit Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CreditLimit As Decimal
C#
[DataMemberAttribute]
public virtual decimal CreditLimit { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal CreditLimit {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_creditLimit();
function set_creditLimit(value);

See Also

Customer Class
InSite.Model Namespace


CurrencyCode Property

[image]

.NET Framework Class Library
Customer..::.CurrencyCode Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CurrencyCode As String
C#
[DataMemberAttribute]
public virtual string CurrencyCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currencyCode();
function set_currencyCode(value);

See Also

Customer Class
InSite.Model Namespace


Current Property

[image]

.NET Framework Class Library
Customer..::.Current Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property Current As Customer
C#
public static Customer Current { get; set; }
Visual C++
public:
static property Customer^ Current {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
InSite.Model.Customer.get_current = function();
InSite.Model.Customer.set_current = function(value);

See Also

Customer Class
InSite.Model Namespace


CustomerCarriers Property

[image]

.NET Framework Class Library
Customer..::.CustomerCarriers Property
Customer Class See Also Send Feedback

Gets a list of Carriers for this customer. if the customer is a shipto it will return the shipto carriers if they have more than 0 carriers, if the carrier count is 0 and there is a parent it will return the parents carriers.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CustomerCarriers As ChildList(Of Carrier)
C#
public virtual ChildList<Carrier> CustomerCarriers { get; }
Visual C++
public:
virtual property ChildList<Carrier^>^ CustomerCarriers {
    ChildList<Carrier^>^ get ();
}
JavaScript
function get_customerCarriers();

See Also

Customer Class
InSite.Model Namespace


CustomerCountry Property

[image]

.NET Framework Class Library
Customer..::.CustomerCountry Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerCountry As Country
C#
public virtual Country CustomerCountry { get; set; }
Visual C++
public:
virtual property Country^ CustomerCountry {
    Country^ get ();
    void set (Country^ value);
}
JavaScript
function get_customerCountry();
function set_customerCountry(value);

See Also

Customer Class
InSite.Model Namespace


CustomerId Property

[image]

.NET Framework Class Library
Customer..::.CustomerId Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerId As Guid
C#
public virtual Guid CustomerId { get; set; }
Visual C++
public:
virtual property Guid CustomerId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_customerId();
function set_customerId(value);

See Also

Customer Class
InSite.Model Namespace


CustomerName Property

[image]

.NET Framework Class Library
Customer..::.CustomerName Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerName As String
C#
[DataMemberAttribute]
public virtual string CustomerName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerName();
function set_customerName(value);

See Also

Customer Class
InSite.Model Namespace


CustomerNumber Property

[image]

.NET Framework Class Library
Customer..::.CustomerNumber Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property CustomerNumber As String
C#
[DataMemberAttribute]
[SortField]
public virtual string CustomerNumber { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ CustomerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumber();
function set_customerNumber(value);

See Also

Customer Class
InSite.Model Namespace


CustomerNumberFormat Property

[image]

.NET Framework Class Library
Customer..::.CustomerNumberFormat Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CustomerNumberFormat As String
C#
public static string CustomerNumberFormat { get; }
Visual C++
public:
static property String^ CustomerNumberFormat {
    String^ get ();
}
JavaScript
InSite.Model.Customer.get_customerNumberFormat = function();

See Also

Customer Class
InSite.Model Namespace


CustomerNumberPrefix Property

[image]

.NET Framework Class Library
Customer..::.CustomerNumberPrefix Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CustomerNumberPrefix As String
C#
public static string CustomerNumberPrefix { get; }
Visual C++
public:
static property String^ CustomerNumberPrefix {
    String^ get ();
}
JavaScript
InSite.Model.Customer.get_customerNumberPrefix = function();

See Also

Customer Class
InSite.Model Namespace


CustomerNumberSequenceName Property

[image]

.NET Framework Class Library
Customer..::.CustomerNumberSequenceName Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumberSequenceName As String
C#
[DataMemberAttribute]
public virtual string CustomerNumberSequenceName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumberSequenceName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumberSequenceName();
function set_customerNumberSequenceName(value);

See Also

Customer Class
InSite.Model Namespace


CustomerOrders Property

[image]

.NET Framework Class Library
Customer..::.CustomerOrders Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrders As ChildList(Of CustomerOrder)
C#
public virtual ChildList<CustomerOrder> CustomerOrders { get; private set; }
Visual C++
public:
virtual property ChildList<CustomerOrder^>^ CustomerOrders {
    ChildList<CustomerOrder^>^ get ();
    void set (ChildList<CustomerOrder^>^ value);
}
JavaScript
function get_customerOrders();
function set_customerOrders(value);

See Also

Customer Class
InSite.Model Namespace


CustomerProducts Property

[image]

.NET Framework Class Library
Customer..::.CustomerProducts Property
Customer Class See Also Send Feedback

Holds Customer specific extended information about Products (ex. Customer Product Name)

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerProducts As ChildList(Of CustomerProduct)
C#
public virtual ChildList<CustomerProduct> CustomerProducts { get; private set; }
Visual C++
public:
virtual property ChildList<CustomerProduct^>^ CustomerProducts {
    ChildList<CustomerProduct^>^ get ();
    void set (ChildList<CustomerProduct^>^ value);
}
JavaScript
function get_customerProducts();
function set_customerProducts(value);

See Also

Customer Class
InSite.Model Namespace


CustomerProductSets Property

[image]

.NET Framework Class Library
Customer..::.CustomerProductSets Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerProductSets As ChildList(Of CustomerProductSet)
C#
public virtual ChildList<CustomerProductSet> CustomerProductSets { get; private set; }
Visual C++
public:
virtual property ChildList<CustomerProductSet^>^ CustomerProductSets {
    ChildList<CustomerProductSet^>^ get ();
    void set (ChildList<CustomerProductSet^>^ value);
}
JavaScript
function get_customerProductSets();
function set_customerProductSets(value);

See Also

Customer Class
InSite.Model Namespace


CustomerProperties Property

[image]

.NET Framework Class Library
Customer..::.CustomerProperties Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SaveChildren> _
<DataMemberAttribute> _
Public Overridable Property CustomerProperties As ChildList(Of CustomerProperty)
C#
[SaveChildren]
[DataMemberAttribute]
public virtual ChildList<CustomerProperty> CustomerProperties { get; private set; }
Visual C++
[SaveChildren]
[DataMemberAttribute]
public:
virtual property ChildList<CustomerProperty^>^ CustomerProperties {
    ChildList<CustomerProperty^>^ get ();
    void set (ChildList<CustomerProperty^>^ value);
}
JavaScript
function get_customerProperties();
function set_customerProperties(value);

See Also

Customer Class
InSite.Model Namespace


CustomerSalesmen Property

[image]

.NET Framework Class Library
Customer..::.CustomerSalesmen Property
Customer Class See Also Send Feedback

Gets a list of Salesmen for this customer. if the customer is a shipto it will return the shipto Salesmen if they have more than 0 Salesmen, if the Salesmen count is 0 and there is a parent it will return the parents Salesmen.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CustomerSalesmen As ChildList(Of Salesman)
C#
public virtual ChildList<Salesman> CustomerSalesmen { get; }
Visual C++
public:
virtual property ChildList<Salesman^>^ CustomerSalesmen {
    ChildList<Salesman^>^ get ();
}
JavaScript
function get_customerSalesmen();

See Also

Customer Class
InSite.Model Namespace


CustomerSequence Property

[image]

.NET Framework Class Library
Customer..::.CustomerSequence Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerSequence As String
C#
[DataMemberAttribute]
public virtual string CustomerSequence { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerSequence {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerSequence();
function set_customerSequence(value);

See Also

Customer Class
InSite.Model Namespace


CustomerSequenceFormat Property

[image]

.NET Framework Class Library
Customer..::.CustomerSequenceFormat Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CustomerSequenceFormat As String
C#
public static string CustomerSequenceFormat { get; }
Visual C++
public:
static property String^ CustomerSequenceFormat {
    String^ get ();
}
JavaScript
InSite.Model.Customer.get_customerSequenceFormat = function();

See Also

Customer Class
InSite.Model Namespace


CustomerSequencePrefix Property

[image]

.NET Framework Class Library
Customer..::.CustomerSequencePrefix Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property CustomerSequencePrefix As String
C#
public static string CustomerSequencePrefix { get; }
Visual C++
public:
static property String^ CustomerSequencePrefix {
    String^ get ();
}
JavaScript
InSite.Model.Customer.get_customerSequencePrefix = function();

See Also

Customer Class
InSite.Model Namespace


CustomerState Property

[image]

.NET Framework Class Library
Customer..::.CustomerState Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerState As State
C#
public virtual State CustomerState { get; set; }
Visual C++
public:
virtual property State^ CustomerState {
    State^ get ();
    void set (State^ value);
}
JavaScript
function get_customerState();
function set_customerState(value);

See Also

Customer Class
InSite.Model Namespace


CustomerType Property

[image]

.NET Framework Class Library
Customer..::.CustomerType Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerType As String
C#
[DataMemberAttribute]
public virtual string CustomerType { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerType();
function set_customerType(value);

See Also

Customer Class
InSite.Model Namespace


Discount Property

[image]

.NET Framework Class Library
Customer..::.Discount Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Discount As Decimal
C#
[DataMemberAttribute]
public virtual decimal Discount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Discount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discount();
function set_discount(value);

See Also

Customer Class
InSite.Model Namespace


Discounts Property

[image]

.NET Framework Class Library
Customer..::.Discounts Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Discounts As ChildList(Of CustomerDiscount)
C#
[DataMemberAttribute]
public virtual ChildList<CustomerDiscount> Discounts { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<CustomerDiscount^>^ Discounts {
    ChildList<CustomerDiscount^>^ get ();
    void set (ChildList<CustomerDiscount^>^ value);
}
JavaScript
function get_discounts();
function set_discounts(value);

See Also

Customer Class
InSite.Model Namespace


DropShipFeeRequired Property

[image]

.NET Framework Class Library
Customer..::.DropShipFeeRequired Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DropShipFeeRequired As Boolean
C#
[DataMemberAttribute]
public virtual bool DropShipFeeRequired { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool DropShipFeeRequired {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dropShipFeeRequired();
function set_dropShipFeeRequired(value);

See Also

Customer Class
InSite.Model Namespace


Email Property

[image]

.NET Framework Class Library
Customer..::.Email Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Email As String
C#
[DataMemberAttribute]
public virtual string Email { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

See Also

Customer Class
InSite.Model Namespace


EndUserType Property

[image]

.NET Framework Class Library
Customer..::.EndUserType Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property EndUserType As String
C#
[DataMemberAttribute]
public virtual string EndUserType { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ EndUserType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_endUserType();
function set_endUserType(value);

See Also

Customer Class
InSite.Model Namespace


ERPNumber Property

[image]

.NET Framework Class Library
Customer..::.ERPNumber Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPNumber As String
C#
[DataMemberAttribute]
public virtual string ERPNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpNumber();
function set_erpNumber(value);

See Also

Customer Class
InSite.Model Namespace


Fax Property

[image]

.NET Framework Class Library
Customer..::.Fax Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Fax As String
C#
[DataMemberAttribute]
public virtual string Fax { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Fax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fax();
function set_fax(value);

See Also

Customer Class
InSite.Model Namespace


FirstName Property

[image]

.NET Framework Class Library
Customer..::.FirstName Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FirstName As String
C#
[DataMemberAttribute]
public virtual string FirstName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ FirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

See Also

Customer Class
InSite.Model Namespace


HTMLAddress Property

[image]

.NET Framework Class Library
Customer..::.HTMLAddress Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HTMLAddress As String
C#
public virtual string HTMLAddress { get; }
Visual C++
public:
virtual property String^ HTMLAddress {
    String^ get ();
}
JavaScript
function get_htmlAddress();

See Also

Customer Class
InSite.Model Namespace


InvoiceFrequency Property

[image]

.NET Framework Class Library
Customer..::.InvoiceFrequency Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property InvoiceFrequency As String
C#
[DataMemberAttribute]
public virtual string InvoiceFrequency { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ InvoiceFrequency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceFrequency();
function set_invoiceFrequency(value);

See Also

Customer Class
InSite.Model Namespace


Invoices Property

[image]

.NET Framework Class Library
Customer..::.Invoices Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Invoices As ChildList(Of Invoice)
C#
public virtual ChildList<Invoice> Invoices { get; private set; }
Visual C++
public:
virtual property ChildList<Invoice^>^ Invoices {
    ChildList<Invoice^>^ get ();
    void set (ChildList<Invoice^>^ value);
}
JavaScript
function get_invoices();
function set_invoices(value);

See Also

Customer Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
Customer..::.IsActive Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

Customer Class
InSite.Model Namespace


IsDropShip Property

[image]

.NET Framework Class Library
Customer..::.IsDropShip Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsDropShip As Boolean
C#
[DataMemberAttribute]
public virtual bool IsDropShip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsDropShip {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDropShip();
function set_isDropShip(value);

See Also

Customer Class
InSite.Model Namespace


IsGuest Property

[image]

.NET Framework Class Library
Customer..::.IsGuest Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsGuest As Boolean
C#
[DataMemberAttribute]
public virtual bool IsGuest { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsGuest {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isGuest();
function set_isGuest(value);

See Also

Customer Class
InSite.Model Namespace


LastName Property

[image]

.NET Framework Class Library
Customer..::.LastName Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LastName As String
C#
[DataMemberAttribute]
public virtual string LastName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

See Also

Customer Class
InSite.Model Namespace


MiddleName Property

[image]

.NET Framework Class Library
Customer..::.MiddleName Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MiddleName As String
C#
[DataMemberAttribute]
public virtual string MiddleName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MiddleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_middleName();
function set_middleName(value);

See Also

Customer Class
InSite.Model Namespace


NonCartOrders Property

[image]

.NET Framework Class Library
Customer..::.NonCartOrders Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NonCartOrders As ReadOnlyCollection(Of CustomerOrder)
C#
public virtual ReadOnlyCollection<CustomerOrder> NonCartOrders { get; }
Visual C++
public:
virtual property ReadOnlyCollection<CustomerOrder^>^ NonCartOrders {
    ReadOnlyCollection<CustomerOrder^>^ get ();
}
JavaScript
function get_nonCartOrders();

See Also

Customer Class
InSite.Model Namespace


OpenInvoiceAmount Property

[image]

.NET Framework Class Library
Customer..::.OpenInvoiceAmount Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OpenInvoiceAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal OpenInvoiceAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal OpenInvoiceAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_openInvoiceAmount();
function set_openInvoiceAmount(value);

See Also

Customer Class
InSite.Model Namespace


OpenOrderAmount Property

[image]

.NET Framework Class Library
Customer..::.OpenOrderAmount Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OpenOrderAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal OpenOrderAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal OpenOrderAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_openOrderAmount();
function set_openOrderAmount(value);

See Also

Customer Class
InSite.Model Namespace


ParentCustomer Property

[image]

.NET Framework Class Library
Customer..::.ParentCustomer Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ParentCustomer As Customer
C#
public virtual Customer ParentCustomer { get; set; }
Visual C++
public:
virtual property Customer^ ParentCustomer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_parentCustomer();
function set_parentCustomer(value);

See Also

Customer Class
InSite.Model Namespace


Phone1 Property

[image]

.NET Framework Class Library
Customer..::.Phone1 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone1 As String
C#
[DataMemberAttribute]
public virtual string Phone1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone1();
function set_phone1(value);

See Also

Customer Class
InSite.Model Namespace


Phone2 Property

[image]

.NET Framework Class Library
Customer..::.Phone2 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone2 As String
C#
[DataMemberAttribute]
public virtual string Phone2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone2();
function set_phone2(value);

See Also

Customer Class
InSite.Model Namespace


Phone3 Property

[image]

.NET Framework Class Library
Customer..::.Phone3 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone3 As String
C#
[DataMemberAttribute]
public virtual string Phone3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone3();
function set_phone3(value);

See Also

Customer Class
InSite.Model Namespace


PriceCode Property

[image]

.NET Framework Class Library
Customer..::.PriceCode Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceCode As String
C#
[DataMemberAttribute]
public virtual string PriceCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceCode();
function set_priceCode(value);

See Also

Customer Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
Customer..::.Products Property
Customer Class See Also Send Feedback

Holds a list of Products attached to this Customer, could be used for a Wish List etc

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Products As ChildList(Of Product)
C#
[DataMemberAttribute]
public virtual ChildList<Product> Products { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

Customer Class
InSite.Model Namespace


Salesman Property

[image]

.NET Framework Class Library
Customer..::.Salesman Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Salesman As String
C#
[DataMemberAttribute]
public virtual string Salesman { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Salesman {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_salesman();
function set_salesman(value);

See Also

Customer Class
InSite.Model Namespace


Salesmen Property

[image]

.NET Framework Class Library
Customer..::.Salesmen Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Salesmen As ChildList(Of Salesman)
C#
[DataMemberAttribute]
public virtual ChildList<Salesman> Salesmen { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Salesman^>^ Salesmen {
    ChildList<Salesman^>^ get ();
    void set (ChildList<Salesman^>^ value);
}
JavaScript
function get_salesmen();
function set_salesmen(value);

See Also

Customer Class
InSite.Model Namespace


SendEmail Property

[image]

.NET Framework Class Library
Customer..::.SendEmail Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SendEmail As Boolean
C#
[DataMemberAttribute]
public virtual bool SendEmail { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SendEmail {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sendEmail();
function set_sendEmail(value);

See Also

Customer Class
InSite.Model Namespace


SendFax Property

[image]

.NET Framework Class Library
Customer..::.SendFax Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SendFax As Boolean
C#
[DataMemberAttribute]
public virtual bool SendFax { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SendFax {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sendFax();
function set_sendFax(value);

See Also

Customer Class
InSite.Model Namespace


ShipCode Property

[image]

.NET Framework Class Library
Customer..::.ShipCode Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipCode As String
C#
[DataMemberAttribute]
public virtual string ShipCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipCode();
function set_shipCode(value);

See Also

Customer Class
InSite.Model Namespace


ShipEarly Property

[image]

.NET Framework Class Library
Customer..::.ShipEarly Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipEarly As Boolean
C#
[DataMemberAttribute]
public virtual bool ShipEarly { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShipEarly {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shipEarly();
function set_shipEarly(value);

See Also

Customer Class
InSite.Model Namespace


ShipPartial Property

[image]

.NET Framework Class Library
Customer..::.ShipPartial Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipPartial As Boolean
C#
[DataMemberAttribute]
public virtual bool ShipPartial { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShipPartial {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shipPartial();
function set_shipPartial(value);

See Also

Customer Class
InSite.Model Namespace


ShipSite Property

[image]

.NET Framework Class Library
Customer..::.ShipSite Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipSite As String
C#
[DataMemberAttribute]
public virtual string ShipSite { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipSite {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipSite();
function set_shipSite(value);

See Also

Customer Class
InSite.Model Namespace


ShipTos Property

[image]

.NET Framework Class Library
Customer..::.ShipTos Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipTos As ChildList(Of Customer)
C#
public virtual ChildList<Customer> ShipTos { get; private set; }
Visual C++
public:
virtual property ChildList<Customer^>^ ShipTos {
    ChildList<Customer^>^ get ();
    void set (ChildList<Customer^>^ value);
}
JavaScript
function get_shipTos();
function set_shipTos(value);

See Also

Customer Class
InSite.Model Namespace


ShipTosByCompany Property

[image]

.NET Framework Class Library
Customer..::.ShipTosByCompany Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ShipTosByCompany As ChildList(Of Customer)
C#
public virtual ChildList<Customer> ShipTosByCompany { get; }
Visual C++
public:
virtual property ChildList<Customer^>^ ShipTosByCompany {
    ChildList<Customer^>^ get ();
}
JavaScript
function get_shipTosByCompany();

See Also

Customer Class
InSite.Model Namespace


SiteCompany Property

[image]

.NET Framework Class Library
Customer..::.SiteCompany Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SiteCompany As Company
C#
public virtual Company SiteCompany { get; set; }
Visual C++
public:
virtual property Company^ SiteCompany {
    Company^ get ();
    void set (Company^ value);
}
JavaScript
function get_siteCompany();
function set_siteCompany(value);

See Also

Customer Class
InSite.Model Namespace


SiteCompanyName Property

[image]

.NET Framework Class Library
Customer..::.SiteCompanyName Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SiteCompanyName As String
C#
[DataMemberAttribute]
public virtual string SiteCompanyName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SiteCompanyName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_siteCompanyName();
function set_siteCompanyName(value);

See Also

Customer Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
Customer..::.State Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property State As String
C#
[DataMemberAttribute]
public virtual string State { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ State {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

Customer Class
InSite.Model Namespace


States Property

[image]

.NET Framework Class Library
Customer..::.States Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property States As IList(Of State)
C#
public virtual IList<State> States { get; }
Visual C++
public:
virtual property IList<State^>^ States {
    IList<State^>^ get ();
}
JavaScript
function get_states();

See Also

Customer Class
InSite.Model Namespace


TaxCode1 Property

[image]

.NET Framework Class Library
Customer..::.TaxCode1 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode1 As String
C#
[DataMemberAttribute]
public virtual string TaxCode1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode1();
function set_taxCode1(value);

See Also

Customer Class
InSite.Model Namespace


TaxCode2 Property

[image]

.NET Framework Class Library
Customer..::.TaxCode2 Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode2 As String
C#
[DataMemberAttribute]
public virtual string TaxCode2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode2();
function set_taxCode2(value);

See Also

Customer Class
InSite.Model Namespace


TermsCode Property

[image]

.NET Framework Class Library
Customer..::.TermsCode Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TermsCode As String
C#
[DataMemberAttribute]
public virtual string TermsCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TermsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_termsCode();
function set_termsCode(value);

See Also

Customer Class
InSite.Model Namespace


Territory Property

[image]

.NET Framework Class Library
Customer..::.Territory Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Territory As String
C#
[DataMemberAttribute]
public virtual string Territory { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Territory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_territory();
function set_territory(value);

See Also

Customer Class
InSite.Model Namespace


UserProfiles Property

[image]

.NET Framework Class Library
Customer..::.UserProfiles Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UserProfiles As ChildList(Of UserProfile)
C#
[DataMemberAttribute]
public virtual ChildList<UserProfile> UserProfiles { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<UserProfile^>^ UserProfiles {
    ChildList<UserProfile^>^ get ();
    void set (ChildList<UserProfile^>^ value);
}
JavaScript
function get_userProfiles();
function set_userProfiles(value);

See Also

Customer Class
InSite.Model Namespace


Warehouse Property

[image]

.NET Framework Class Library
Customer..::.Warehouse Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Warehouse As String
C#
[DataMemberAttribute]
public virtual string Warehouse { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Warehouse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_warehouse();
function set_warehouse(value);

See Also

Customer Class
InSite.Model Namespace


WishLists Property

[image]

.NET Framework Class Library
Customer..::.WishLists Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WishLists As ChildList(Of WishList)
C#
public virtual ChildList<WishList> WishLists { get; private set; }
Visual C++
public:
virtual property ChildList<WishList^>^ WishLists {
    ChildList<WishList^>^ get ();
    void set (ChildList<WishList^>^ value);
}
JavaScript
function get_wishLists();
function set_wishLists(value);

See Also

Customer Class
InSite.Model Namespace


Zip Property

[image]

.NET Framework Class Library
Customer..::.Zip Property
Customer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Zip As String
C#
[DataMemberAttribute]
public virtual string Zip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

See Also

Customer Class
InSite.Model Namespace


CustomerDiscount Class

[image]

.NET Framework Class Library
CustomerDiscount Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CustomerDiscount _
    Inherits ModelBase(Of CustomerDiscount)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CustomerDiscount : ModelBase<CustomerDiscount>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CustomerDiscount : public ModelBase<CustomerDiscount^>
JavaScript
InSite.Model.CustomerDiscount = function();

Type.createClass(
    'InSite.Model.CustomerDiscount',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CustomerDiscount>)>)
InSite.Model..::.CustomerDiscount

See Also

CustomerDiscount Members
InSite.Model Namespace


CustomerDiscount Members

[image] [image]

.NET Framework Class Library
CustomerDiscount Members
CustomerDiscount Class Constructors Methods Fields Properties See Also Send Feedback

The CustomerDiscount type exposes the following members.

Constructors

Name | Description
CustomerDiscount | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ApplyDiscount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerDiscountId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Discount |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WebSiteName |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerDiscount Class
InSite.Model Namespace


CustomerDiscount Constructor

[image] [image]

.NET Framework Class Library
CustomerDiscount Constructor
CustomerDiscount Class See Also Send Feedback

Overload List

Name | Description
CustomerDiscount()()() |
CustomerDiscount(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CustomerDiscount Class
CustomerDiscount Members
InSite.Model Namespace


CustomerDiscount Constructor

[image]

.NET Framework Class Library
CustomerDiscount Constructor
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerDiscount()
Visual C++
public:
CustomerDiscount()
JavaScript
InSite.Model.CustomerDiscount = function();

See Also

CustomerDiscount Class
CustomerDiscount Overload
InSite.Model Namespace


CustomerDiscount Constructor (SearchMode)

[image]

.NET Framework Class Library
CustomerDiscount Constructor (SearchMode)
CustomerDiscount Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CustomerDiscount(
    SearchMode searchMode
)
Visual C++
public:
CustomerDiscount(
    SearchMode searchMode
)
JavaScript
InSite.Model.CustomerDiscount = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CustomerDiscount Class
CustomerDiscount Overload
InSite.Model Namespace


CustomerDiscount Fields

[image] [image]

.NET Framework Class Library
CustomerDiscount Fields
CustomerDiscount Class See Also Send Feedback

The CustomerDiscount type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerDiscount Class
InSite.Model Namespace


CustomerDiscount Methods

[image] [image]

.NET Framework Class Library
CustomerDiscount Methods
CustomerDiscount Class See Also Send Feedback

The CustomerDiscount type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerDiscount Class
InSite.Model Namespace


CustomerDiscount Properties

[image] [image]

.NET Framework Class Library
CustomerDiscount Properties
CustomerDiscount Class See Also Send Feedback

The CustomerDiscount type exposes the following members.

Properties

Name | Description
ApplyDiscount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerDiscountId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Discount |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WebSiteName |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerDiscount Class
InSite.Model Namespace


ApplyDiscount Property

[image]

.NET Framework Class Library
CustomerDiscount..::.ApplyDiscount Property
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ApplyDiscount As Boolean
C#
[DataMemberAttribute]
public virtual bool ApplyDiscount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ApplyDiscount {
    bool get ();
    void set (bool value);
}
JavaScript
function get_applyDiscount();
function set_applyDiscount(value);

See Also

CustomerDiscount Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
CustomerDiscount..::.Customer Property
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customer As Customer
C#
public virtual Customer Customer { get; set; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

CustomerDiscount Class
InSite.Model Namespace


CustomerDiscountId Property

[image]

.NET Framework Class Library
CustomerDiscount..::.CustomerDiscountId Property
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerDiscountId As Guid
C#
public virtual Guid CustomerDiscountId { get; set; }
Visual C++
public:
virtual property Guid CustomerDiscountId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_customerDiscountId();
function set_customerDiscountId(value);

See Also

CustomerDiscount Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
CustomerDiscount..::.Description Property
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

CustomerDiscount Class
InSite.Model Namespace


Discount Property

[image]

.NET Framework Class Library
CustomerDiscount..::.Discount Property
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Discount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Discount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Discount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discount();
function set_discount(value);

See Also

CustomerDiscount Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CustomerDiscount..::.Name Property
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CustomerDiscount Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
CustomerDiscount..::.WebSite Property
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

CustomerDiscount Class
InSite.Model Namespace


WebSiteName Property

[image]

.NET Framework Class Library
CustomerDiscount..::.WebSiteName Property
CustomerDiscount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property WebSiteName As String
C#
[DataMemberAttribute]
public virtual string WebSiteName { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ WebSiteName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_webSiteName();
function set_webSiteName(value);

See Also

CustomerDiscount Class
InSite.Model Namespace


CustomerOrder Class

[image]

.NET Framework Class Library
CustomerOrder Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CustomerOrder _
    Inherits ModelBase(Of CustomerOrder)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CustomerOrder : ModelBase<CustomerOrder>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CustomerOrder : public ModelBase<CustomerOrder^>
JavaScript
InSite.Model.CustomerOrder = function();

Type.createClass(
    'InSite.Model.CustomerOrder',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CustomerOrder>)>)
InSite.Model..::.CustomerOrder

See Also

CustomerOrder Members
InSite.Model Namespace


CustomerOrder Members

[image] [image]

.NET Framework Class Library
CustomerOrder Members
CustomerOrder Class Constructors Methods Fields Properties See Also Send Feedback

The CustomerOrder type exposes the following members.

Constructors

Name | Description
CustomerOrder | Overloaded.

Methods

Name | Description
AddCreditCardTransaction |
AddCustomerOrderProperty |
AddGiftCard |
AddGiftCardTransaction |
AddOrderLine | Overloaded.
AddPromotion |
AddPromotionCode |
AddPromotionCodeOrGiftCard |
AddShipment |
ApplyPromotions | ApplyPromotions will Apply Promotions to the order
CalculateShippingCosts |
CalculateTax | Overloaded.
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
EmptyCart |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByOrderNumber |
GetCustomerOrderProperty |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetListForERPRefresh |
GetNextOrderNumber | Overloaded.
GetOrderLine | Overloaded.
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetReSubmitCustomerOrderList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasProduct |
HasPromotion |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PurgeSavedOrders |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomerOrderProperty |
RemoveGiftCard |
RemoveOrderLine | Overloaded.
RemovePromotion |
RemovePromotionCode | Overloaded.
RemoveRestrictedOrderLines |
RemoveShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
CartStatus |
CompleteStatus |
OrderType |
ProcessingStatus |
QuoteType |
ReadyForPickupStatus |
ReviewStatus |
SavedStatus |
SubmittedStatus |
VoidStatus |

Properties

Name | Description
AmountPaid | Returns the total amount paid with credit card transactions, this will be charges - voids/credits
AppliedPromoCodes |
AutoCalculatePrice |
AvailableCreditLimit |
BatchNumber |
BTAddress1 |
BTAddress2 |
BTAddress3 |
BTAddress4 |
BTCity |
BTCompany |
BTContact1 |
BTContact2 |
BTContact3 |
BTCountry |
BTCounty |
BTDisplayName |
BTEmail |
BTFax |
BTFirstName |
BTLastName |
BTMiddleName |
BTPhone1 |
BTPhone2 |
BTPhone3 |
BTState |
BTZip |
Buyer |
CanProcessOrder |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CollectAccountNumber |
CreditCard | CreditCard - Contained object to hold Credit Card information It must be set on the same postback that the order submission happens Alternatively you can bind to the flattened out CreditCard properties, either way they don't persist past a postback, they must be set during the order submission postback
CreditCardAmount |
CreditCardCSC |
CreditCardExpirationMonth |
CreditCardExpirationYear |
CreditCardName |
CreditCardNumber |
CreditCardTransactions |
CreditCardType |
CurrencyCode |
Current | Returns the Current Customer Order in the Shopping Cart, if there isn't one, one is created for you
Customer |
CustomerNumber |
CustomerOrderDataSet |
CustomerOrderId |
CustomerOrderProperties |
CustomerPO |
CustomerPOTypeCode |
CustomerReference1 |
CustomerReference2 |
CustomerSequence |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DiscountAmount |
DiscountPercent |
DollarOffOrder |
DollarOffShipping |
DropShip |
EndUserType |
ERPOrderNumber |
ERPShipCode |
FailedRestrictionOrderLines |
FullShippingCharge |
GiftCards |
GiftCardTotal |
GiftCardTransactions |
Handling |
HasSubscription | Will return true if this Order has an OrderLine that is a Subscription
HtmlBillingAddress |
HtmlShippingAddress |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InsideDelivery |
InvoiceFrequency |
IsDropShip |
IsGiftCardOnlyOrder |
IsOrderOverCreditLimit |
IsSubscription |
IsSubscriptionOnlyOrder |
IsValid |
LanguageCode |
LiftGateService |
LocalShippingAndHandlingTax |
LocalTax |
LocalTaxableTotal |
LocalTaxRate |
LocalTaxRates |
Notes |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderAffiliate |
OrderDate |
OrderFreightableQuantity |
OrderFreightableTotal |
OrderGrandTotal | Order Grand Total is (this.OrderTotal + this.TotalTax + this.ShippingAndHandling)
OrderLines |
OrderNonTaxableTotal |
OrderNumber |
OrderNumberFormat |
OrderNumberPrefix |
OrderProductValue |
OrderSavingsAmount |
OrderSavingsPercent |
OrderSubTotal |
OrderSubTotalWithOutProductDiscounts |
OrderTaxableTotal |
OrderTotal | OrderTotal is (this.OrderSubTotal - this.DollarOffOrder) * (1 - this.PercentOffOrder)
OrderTotalDue | Order Total Due is (this.OrderGrandTotal - this.GiftCardTotal - this.PromotionProductDiscountTotal - this.PromotionShippingDiscountTotal)
PassesRestrictions |
PercentOffOrder |
PercentOffShipping |
PriceCode |
ProductOverriddenFreightTotal |
PromotionCodes |
PromotionOrderDiscountTotal |
PromotionProductDiscountTotal |
Promotions |
PromotionShippingDiscountTotal |
PromotionTotal |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RequestedShipDate |
Residential |
Salesman |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipCode |
ShipEarly |
ShipmentPackages |
ShipmentQuoteNumber |
Shipments |
ShipPartial |
Shipping |
ShippingAndHandling |
ShippingCosts |
ShipTo |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
STAddress1 |
STAddress2 |
STAddress3 |
STAddress4 |
StateShippingAndHandlingTax |
StateTax |
StateTaxableTotal |
StateTaxRate |
StateTaxRates |
Status |
STCity |
STCompany |
STContact1 |
STContact2 |
STContact3 |
STCountry |
STCounty |
STDisplayName |
STEmail |
STFax |
STFirstName |
STLastName |
STMiddleName |
STPhone1 |
STPhone2 |
STPhone3 |
STState |
STZip |
Subscription |
Subscriptions |
TaxCode1 |
TaxCode2 |
TermsCode |
TotalItemsOrdered |
TotalSalesTax | TotalSalesTax - Total Tax excluding Shipping And Handling Tax
TotalShippingAndHandlingTax |
TotalTax |
TotalWeight |
Type |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserName |
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
VerificationSent |
Warehouse |
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerOrder Constructor

[image] [image]

.NET Framework Class Library
CustomerOrder Constructor
CustomerOrder Class See Also Send Feedback

Overload List

Name | Description
CustomerOrder()()() |
CustomerOrder(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CustomerOrder Class
CustomerOrder Members
InSite.Model Namespace


CustomerOrder Constructor

[image]

.NET Framework Class Library
CustomerOrder Constructor
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerOrder()
Visual C++
public:
CustomerOrder()
JavaScript
InSite.Model.CustomerOrder = function();

See Also

CustomerOrder Class
CustomerOrder Overload
InSite.Model Namespace


CustomerOrder Constructor (SearchMode)

[image]

.NET Framework Class Library
CustomerOrder Constructor (SearchMode)
CustomerOrder Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CustomerOrder(
    SearchMode searchMode
)
Visual C++
public:
CustomerOrder(
    SearchMode searchMode
)
JavaScript
InSite.Model.CustomerOrder = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CustomerOrder Class
CustomerOrder Overload
InSite.Model Namespace


CustomerOrder Fields

[image] [image]

.NET Framework Class Library
CustomerOrder Fields
CustomerOrder Class See Also Send Feedback

The CustomerOrder type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
CartStatus |
CompleteStatus |
OrderType |
ProcessingStatus |
QuoteType |
ReadyForPickupStatus |
ReviewStatus |
SavedStatus |
SubmittedStatus |
VoidStatus |

See Also

CustomerOrder Class
InSite.Model Namespace


CartStatus Field

[image]

.NET Framework Class Library
CustomerOrder..::.CartStatus Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CartStatus As String
C#
public const string CartStatus
Visual C++
public:
literal String^ CartStatus
JavaScript
InSite.Model.CustomerOrder.cartStatus

See Also

CustomerOrder Class
InSite.Model Namespace


CompleteStatus Field

[image]

.NET Framework Class Library
CustomerOrder..::.CompleteStatus Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CompleteStatus As String
C#
public const string CompleteStatus
Visual C++
public:
literal String^ CompleteStatus
JavaScript
InSite.Model.CustomerOrder.completeStatus

See Also

CustomerOrder Class
InSite.Model Namespace


OrderType Field

[image]

.NET Framework Class Library
CustomerOrder..::.OrderType Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const OrderType As String
C#
public const string OrderType
Visual C++
public:
literal String^ OrderType
JavaScript
InSite.Model.CustomerOrder.orderType

See Also

CustomerOrder Class
InSite.Model Namespace


ProcessingStatus Field

[image]

.NET Framework Class Library
CustomerOrder..::.ProcessingStatus Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ProcessingStatus As String
C#
public const string ProcessingStatus
Visual C++
public:
literal String^ ProcessingStatus
JavaScript
InSite.Model.CustomerOrder.processingStatus

See Also

CustomerOrder Class
InSite.Model Namespace


QuoteType Field

[image]

.NET Framework Class Library
CustomerOrder..::.QuoteType Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const QuoteType As String
C#
public const string QuoteType
Visual C++
public:
literal String^ QuoteType
JavaScript
InSite.Model.CustomerOrder.quoteType

See Also

CustomerOrder Class
InSite.Model Namespace


ReadyForPickupStatus Field

[image]

.NET Framework Class Library
CustomerOrder..::.ReadyForPickupStatus Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ReadyForPickupStatus As String
C#
public const string ReadyForPickupStatus
Visual C++
public:
literal String^ ReadyForPickupStatus
JavaScript
InSite.Model.CustomerOrder.readyForPickupStatus

See Also

CustomerOrder Class
InSite.Model Namespace


ReviewStatus Field

[image]

.NET Framework Class Library
CustomerOrder..::.ReviewStatus Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ReviewStatus As String
C#
public const string ReviewStatus
Visual C++
public:
literal String^ ReviewStatus
JavaScript
InSite.Model.CustomerOrder.reviewStatus

See Also

CustomerOrder Class
InSite.Model Namespace


SavedStatus Field

[image]

.NET Framework Class Library
CustomerOrder..::.SavedStatus Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const SavedStatus As String
C#
public const string SavedStatus
Visual C++
public:
literal String^ SavedStatus
JavaScript
InSite.Model.CustomerOrder.savedStatus

See Also

CustomerOrder Class
InSite.Model Namespace


SubmittedStatus Field

[image]

.NET Framework Class Library
CustomerOrder..::.SubmittedStatus Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const SubmittedStatus As String
C#
public const string SubmittedStatus
Visual C++
public:
literal String^ SubmittedStatus
JavaScript
InSite.Model.CustomerOrder.submittedStatus

See Also

CustomerOrder Class
InSite.Model Namespace


VoidStatus Field

[image]

.NET Framework Class Library
CustomerOrder..::.VoidStatus Field
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const VoidStatus As String
C#
public const string VoidStatus
Visual C++
public:
literal String^ VoidStatus
JavaScript
InSite.Model.CustomerOrder.voidStatus

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerOrder Methods

[image] [image]

.NET Framework Class Library
CustomerOrder Methods
CustomerOrder Class See Also Send Feedback

The CustomerOrder type exposes the following members.

Methods

Name | Description
AddCreditCardTransaction |
AddCustomerOrderProperty |
AddGiftCard |
AddGiftCardTransaction |
AddOrderLine | Overloaded.
AddPromotion |
AddPromotionCode |
AddPromotionCodeOrGiftCard |
AddShipment |
ApplyPromotions | ApplyPromotions will Apply Promotions to the order
CalculateShippingCosts |
CalculateTax | Overloaded.
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
EmptyCart |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByOrderNumber |
GetCustomerOrderProperty |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetListForERPRefresh |
GetNextOrderNumber | Overloaded.
GetOrderLine | Overloaded.
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetReSubmitCustomerOrderList | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasProduct |
HasPromotion |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PurgeSavedOrders |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomerOrderProperty |
RemoveGiftCard |
RemoveOrderLine | Overloaded.
RemovePromotion |
RemovePromotionCode | Overloaded.
RemoveRestrictedOrderLines |
RemoveShipment |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerOrder Class
InSite.Model Namespace


AddCreditCardTransaction Method

[image]

.NET Framework Class Library
CustomerOrder..::.AddCreditCardTransaction Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCreditCardTransaction ( _
    value As CreditCardTransaction _
)
C#
public virtual void AddCreditCardTransaction(
    CreditCardTransaction value
)
Visual C++
public:
virtual void AddCreditCardTransaction(
    CreditCardTransaction^ value
)
JavaScript
function addCreditCardTransaction(value);

Parameters

value
Type: InSite.Model..::.CreditCardTransaction

See Also

CustomerOrder Class
InSite.Model Namespace


AddCustomerOrderProperty Method

[image]

.NET Framework Class Library
CustomerOrder..::.AddCustomerOrderProperty Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomerOrderProperty ( _
    value As CustomerOrderProperty _
)
C#
public virtual void AddCustomerOrderProperty(
    CustomerOrderProperty value
)
Visual C++
public:
virtual void AddCustomerOrderProperty(
    CustomerOrderProperty^ value
)
JavaScript
function addCustomerOrderProperty(value);

Parameters

value
Type: InSite.Model..::.CustomerOrderProperty

See Also

CustomerOrder Class
InSite.Model Namespace


AddGiftCard Method

[image]

.NET Framework Class Library
CustomerOrder..::.AddGiftCard Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddGiftCard ( _
    value As GiftCard _
)
C#
public virtual void AddGiftCard(
    GiftCard value
)
Visual C++
public:
virtual void AddGiftCard(
    GiftCard^ value
)
JavaScript
function addGiftCard(value);

Parameters

value
Type: InSite.Model..::.GiftCard

See Also

CustomerOrder Class
InSite.Model Namespace


AddGiftCardTransaction Method

[image]

.NET Framework Class Library
CustomerOrder..::.AddGiftCardTransaction Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddGiftCardTransaction ( _
    value As GiftCardTransaction _
)
C#
public virtual void AddGiftCardTransaction(
    GiftCardTransaction value
)
Visual C++
public:
virtual void AddGiftCardTransaction(
    GiftCardTransaction^ value
)
JavaScript
function addGiftCardTransaction(value);

Parameters

value
Type: InSite.Model..::.GiftCardTransaction

See Also

CustomerOrder Class
InSite.Model Namespace


AddOrderLine Method

[image] [image]

.NET Framework Class Library
CustomerOrder..::.AddOrderLine Method
CustomerOrder Class See Also Send Feedback

Overload List

Name | Description
AddOrderLine(OrderLine) |
AddOrderLine(Product, String, Decimal) |
AddOrderLine(Product, String, Decimal, IList<(Of <(OrderLineAttribute>)>)) |

See Also

CustomerOrder Class
CustomerOrder Members
InSite.Model Namespace


AddOrderLine Method (OrderLine)

[image]

.NET Framework Class Library
CustomerOrder..::.AddOrderLine Method (OrderLine)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddOrderLine ( _
    value As OrderLine _
)
C#
public virtual void AddOrderLine(
    OrderLine value
)
Visual C++
public:
virtual void AddOrderLine(
    OrderLine^ value
)
JavaScript
function addOrderLine(value);

Parameters

value
Type: InSite.Model..::.OrderLine

See Also

CustomerOrder Class
AddOrderLine Overload
InSite.Model Namespace


AddOrderLine Method (Product, String, Decimal)

[image]

.NET Framework Class Library
CustomerOrder..::.AddOrderLine Method (Product, String, Decimal)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function AddOrderLine ( _
    product As Product, _
    notes As String, _
    qtyOrdered As Decimal _
) As OrderLine
C#
public virtual OrderLine AddOrderLine(
    Product product,
    string notes,
    decimal qtyOrdered
)
Visual C++
public:
virtual OrderLine^ AddOrderLine(
    Product^ product,
    String^ notes,
    Decimal qtyOrdered
)
JavaScript
function addOrderLine(product, notes, qtyOrdered);

Parameters

product
Type: InSite.Model..::.Product
notes
Type: System..::.String
qtyOrdered
Type: System..::.Decimal

See Also

CustomerOrder Class
AddOrderLine Overload
InSite.Model Namespace


AddOrderLine Method (Product, String, Decimal, IList(OrderLineAttribute))

[image]

.NET Framework Class Library
CustomerOrder..::.AddOrderLine Method (Product, String, Decimal, IList<(Of <(OrderLineAttribute>)>))
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function AddOrderLine ( _
    product As Product, _
    notes As String, _
    qtyOrdered As Decimal, _
    orderLineAttributes As IList(Of OrderLineAttribute) _
) As OrderLine
C#
public virtual OrderLine AddOrderLine(
    Product product,
    string notes,
    decimal qtyOrdered,
    IList<OrderLineAttribute> orderLineAttributes
)
Visual C++
public:
virtual OrderLine^ AddOrderLine(
    Product^ product,
    String^ notes,
    Decimal qtyOrdered,
    IList<OrderLineAttribute^>^ orderLineAttributes
)
JavaScript
function addOrderLine(product, notes, qtyOrdered, orderLineAttributes);

Parameters

product
Type: InSite.Model..::.Product
notes
Type: System..::.String
qtyOrdered
Type: System..::.Decimal
orderLineAttributes
Type: System.Collections.Generic..::.IList <(Of <( OrderLineAttribute >)>)

See Also

CustomerOrder Class
AddOrderLine Overload
InSite.Model Namespace


AddPromotion Method

[image]

.NET Framework Class Library
CustomerOrder..::.AddPromotion Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddPromotion ( _
    value As Promotion _
)
C#
public virtual void AddPromotion(
    Promotion value
)
Visual C++
public:
virtual void AddPromotion(
    Promotion^ value
)
JavaScript
function addPromotion(value);

Parameters

value
Type: InSite.Model..::.Promotion

See Also

CustomerOrder Class
InSite.Model Namespace


AddPromotionCode Method

[image]

.NET Framework Class Library
CustomerOrder..::.AddPromotionCode Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddPromotionCode ( _
    value As PromotionCode _
)
C#
public virtual void AddPromotionCode(
    PromotionCode value
)
Visual C++
public:
virtual void AddPromotionCode(
    PromotionCode^ value
)
JavaScript
function addPromotionCode(value);

Parameters

value
Type: InSite.Model..::.PromotionCode

See Also

CustomerOrder Class
InSite.Model Namespace


AddPromotionCodeOrGiftCard Method

[image]

.NET Framework Class Library
CustomerOrder..::.AddPromotionCodeOrGiftCard Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddPromotionCodeOrGiftCard ( _
    promotionCodeOrGiftCardNumber As String _
)
C#
public virtual void AddPromotionCodeOrGiftCard(
    string promotionCodeOrGiftCardNumber
)
Visual C++
public:
virtual void AddPromotionCodeOrGiftCard(
    String^ promotionCodeOrGiftCardNumber
)
JavaScript
function addPromotionCodeOrGiftCard(promotionCodeOrGiftCardNumber);

Parameters

promotionCodeOrGiftCardNumber
Type: System..::.String

See Also

CustomerOrder Class
InSite.Model Namespace


AddShipment Method

[image]

.NET Framework Class Library
CustomerOrder..::.AddShipment Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipment ( _
    value As Shipment _
)
C#
public virtual void AddShipment(
    Shipment value
)
Visual C++
public:
virtual void AddShipment(
    Shipment^ value
)
JavaScript
function addShipment(value);

Parameters

value
Type: InSite.Model..::.Shipment

See Also

CustomerOrder Class
InSite.Model Namespace


ApplyPromotions Method

[image]

.NET Framework Class Library
CustomerOrder..::.ApplyPromotions Method
CustomerOrder Class See Also Send Feedback

ApplyPromotions will Apply Promotions to the order

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ApplyPromotions
C#
public virtual void ApplyPromotions()
Visual C++
public:
virtual void ApplyPromotions()
JavaScript
function applyPromotions();

See Also

CustomerOrder Class
InSite.Model Namespace


CalculateShippingCosts Method

[image]

.NET Framework Class Library
CustomerOrder..::.CalculateShippingCosts Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CalculateShippingCosts
C#
public virtual void CalculateShippingCosts()
Visual C++
public:
virtual void CalculateShippingCosts()
JavaScript
function calculateShippingCosts();

See Also

CustomerOrder Class
InSite.Model Namespace


CalculateTax Method

[image] [image]

.NET Framework Class Library
CustomerOrder..::.CalculateTax Method
CustomerOrder Class See Also Send Feedback

Overload List

Name | Description
CalculateTax()()() |
CalculateTax(State, String) |
CalculateTax(String, String) |

See Also

CustomerOrder Class
CustomerOrder Members
InSite.Model Namespace


CalculateTax Method

[image]

.NET Framework Class Library
CustomerOrder..::.CalculateTax Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CalculateTax
C#
public virtual void CalculateTax()
Visual C++
public:
virtual void CalculateTax()
JavaScript
function calculateTax();

See Also

CustomerOrder Class
CalculateTax Overload
InSite.Model Namespace


CalculateTax Method (State, String)

[image]

.NET Framework Class Library
CustomerOrder..::.CalculateTax Method (State, String)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CalculateTax ( _
    state As State, _
    zip As String _
) As Decimal
C#
public virtual decimal CalculateTax(
    State state,
    string zip
)
Visual C++
public:
virtual Decimal CalculateTax(
    State^ state,
    String^ zip
)
JavaScript
function calculateTax(state, zip);

Parameters

state
Type: InSite.Model..::.State
zip
Type: System..::.String

See Also

CustomerOrder Class
CalculateTax Overload
InSite.Model Namespace


CalculateTax Method (String, String)

[image]

.NET Framework Class Library
CustomerOrder..::.CalculateTax Method (String, String)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CalculateTax ( _
    stateAbbreviation As String, _
    zip As String _
) As Decimal
C#
public virtual decimal CalculateTax(
    string stateAbbreviation,
    string zip
)
Visual C++
public:
virtual Decimal CalculateTax(
    String^ stateAbbreviation,
    String^ zip
)
JavaScript
function calculateTax(stateAbbreviation, zip);

Parameters

stateAbbreviation
Type: System..::.String
zip
Type: System..::.String

See Also

CustomerOrder Class
CalculateTax Overload
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
CustomerOrder..::.Copy Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As CustomerOrder
C#
public virtual CustomerOrder Copy()
Visual C++
public:
virtual CustomerOrder^ Copy()
JavaScript
function copy();

See Also

CustomerOrder Class
InSite.Model Namespace


EmptyCart Method

[image]

.NET Framework Class Library
CustomerOrder..::.EmptyCart Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub EmptyCart
C#
public virtual void EmptyCart()
Visual C++
public:
virtual void EmptyCart()
JavaScript
function emptyCart();

See Also

CustomerOrder Class
InSite.Model Namespace


GetByOrderNumber Method

[image]

.NET Framework Class Library
CustomerOrder..::.GetByOrderNumber Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByOrderNumber ( _
    orderNumber As String _
) As CustomerOrder
C#
public static CustomerOrder GetByOrderNumber(
    string orderNumber
)
Visual C++
public:
static CustomerOrder^ GetByOrderNumber(
    String^ orderNumber
)
JavaScript
InSite.Model.CustomerOrder.getByOrderNumber = function(orderNumber);

Parameters

orderNumber
Type: System..::.String

See Also

CustomerOrder Class
InSite.Model Namespace


GetCustomerOrderProperty Method

[image]

.NET Framework Class Library
CustomerOrder..::.GetCustomerOrderProperty Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCustomerOrderProperty ( _
    name As String _
) As CustomerOrderProperty
C#
public virtual CustomerOrderProperty GetCustomerOrderProperty(
    string name
)
Visual C++
public:
virtual CustomerOrderProperty^ GetCustomerOrderProperty(
    String^ name
)
JavaScript
function getCustomerOrderProperty(name);

Parameters

name
Type: System..::.String

See Also

CustomerOrder Class
InSite.Model Namespace


GetListForERPRefresh Method

[image]

.NET Framework Class Library
CustomerOrder..::.GetListForERPRefresh Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetListForERPRefresh As IList(Of CustomerOrder)
C#
public static IList<CustomerOrder> GetListForERPRefresh()
Visual C++
public:
static IList<CustomerOrder^>^ GetListForERPRefresh()
JavaScript
InSite.Model.CustomerOrder.getListForERPRefresh = function();

See Also

CustomerOrder Class
InSite.Model Namespace


GetNextOrderNumber Method

[image] [image]

.NET Framework Class Library
CustomerOrder..::.GetNextOrderNumber Method
CustomerOrder Class See Also Send Feedback

Overload List

Name | Description
GetNextOrderNumber()()() |
GetNextOrderNumber(String, String) |

See Also

CustomerOrder Class
CustomerOrder Members
InSite.Model Namespace


GetNextOrderNumber Method

[image]

.NET Framework Class Library
CustomerOrder..::.GetNextOrderNumber Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNextOrderNumber As String
C#
public static string GetNextOrderNumber()
Visual C++
public:
static String^ GetNextOrderNumber()
JavaScript
InSite.Model.CustomerOrder.getNextOrderNumber = function();

See Also

CustomerOrder Class
GetNextOrderNumber Overload
InSite.Model Namespace


GetNextOrderNumber Method (String, String)

[image]

.NET Framework Class Library
CustomerOrder..::.GetNextOrderNumber Method (String, String)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNextOrderNumber ( _
    prefix As String, _
    format As String _
) As String
C#
public static string GetNextOrderNumber(
    string prefix,
    string format
)
Visual C++
public:
static String^ GetNextOrderNumber(
    String^ prefix,
    String^ format
)
JavaScript
InSite.Model.CustomerOrder.getNextOrderNumber = function(prefix, format);

Parameters

prefix
Type: System..::.String
format
Type: System..::.String

See Also

CustomerOrder Class
GetNextOrderNumber Overload
InSite.Model Namespace


GetOrderLine Method

[image] [image]

.NET Framework Class Library
CustomerOrder..::.GetOrderLine Method
CustomerOrder Class See Also Send Feedback

Overload List

Name | Description
GetOrderLine(Int32) |
GetOrderLine(String) |

See Also

CustomerOrder Class
CustomerOrder Members
InSite.Model Namespace


GetOrderLine Method (Int32)

[image]

.NET Framework Class Library
CustomerOrder..::.GetOrderLine Method (Int32)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetOrderLine ( _
    line As Integer _
) As OrderLine
C#
public virtual OrderLine GetOrderLine(
    int line
)
Visual C++
public:
virtual OrderLine^ GetOrderLine(
    int line
)
JavaScript
function getOrderLine(line);

Parameters

line
Type: System..::.Int32

See Also

CustomerOrder Class
GetOrderLine Overload
InSite.Model Namespace


GetOrderLine Method (String)

[image]

.NET Framework Class Library
CustomerOrder..::.GetOrderLine Method (String)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetOrderLine ( _
    productName As String _
) As OrderLine
C#
public virtual OrderLine GetOrderLine(
    string productName
)
Visual C++
public:
virtual OrderLine^ GetOrderLine(
    String^ productName
)
JavaScript
function getOrderLine(productName);

Parameters

productName
Type: System..::.String

See Also

CustomerOrder Class
GetOrderLine Overload
InSite.Model Namespace


GetReSubmitCustomerOrderList Method

[image] [image]

.NET Framework Class Library
CustomerOrder..::.GetReSubmitCustomerOrderList Method
CustomerOrder Class See Also Send Feedback

Overload List

Name | Description
GetReSubmitCustomerOrderList()()() |
GetReSubmitCustomerOrderList(Int32) |

See Also

CustomerOrder Class
CustomerOrder Members
InSite.Model Namespace


GetReSubmitCustomerOrderList Method

[image]

.NET Framework Class Library
CustomerOrder..::.GetReSubmitCustomerOrderList Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetReSubmitCustomerOrderList As IList(Of CustomerOrder)
C#
public static IList<CustomerOrder> GetReSubmitCustomerOrderList()
Visual C++
public:
static IList<CustomerOrder^>^ GetReSubmitCustomerOrderList()
JavaScript
InSite.Model.CustomerOrder.getReSubmitCustomerOrderList = function();

See Also

CustomerOrder Class
GetReSubmitCustomerOrderList Overload
InSite.Model Namespace


GetReSubmitCustomerOrderList Method (Int32)

[image]

.NET Framework Class Library
CustomerOrder..::.GetReSubmitCustomerOrderList Method (Int32)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetReSubmitCustomerOrderList ( _
    batchNumber As Integer _
) As IList(Of CustomerOrder)
C#
public static IList<CustomerOrder> GetReSubmitCustomerOrderList(
    int batchNumber
)
Visual C++
public:
static IList<CustomerOrder^>^ GetReSubmitCustomerOrderList(
    int batchNumber
)
JavaScript
InSite.Model.CustomerOrder.getReSubmitCustomerOrderList = function(batchNumber);

Parameters

batchNumber
Type: System..::.Int32

See Also

CustomerOrder Class
GetReSubmitCustomerOrderList Overload
InSite.Model Namespace


HasProduct Method

[image]

.NET Framework Class Library
CustomerOrder..::.HasProduct Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function HasProduct ( _
    product As Product _
) As Boolean
C#
public virtual bool HasProduct(
    Product product
)
Visual C++
public:
virtual bool HasProduct(
    Product^ product
)
JavaScript
function hasProduct(product);

Parameters

product
Type: InSite.Model..::.Product

See Also

CustomerOrder Class
InSite.Model Namespace


HasPromotion Method

[image]

.NET Framework Class Library
CustomerOrder..::.HasPromotion Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function HasPromotion ( _
    promotion As Promotion _
) As Boolean
C#
public virtual bool HasPromotion(
    Promotion promotion
)
Visual C++
public:
virtual bool HasPromotion(
    Promotion^ promotion
)
JavaScript
function hasPromotion(promotion);

Parameters

promotion
Type: InSite.Model..::.Promotion

See Also

CustomerOrder Class
InSite.Model Namespace


PurgeSavedOrders Method

[image]

.NET Framework Class Library
CustomerOrder..::.PurgeSavedOrders Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub PurgeSavedOrders
C#
public static void PurgeSavedOrders()
Visual C++
public:
static void PurgeSavedOrders()
JavaScript
InSite.Model.CustomerOrder.purgeSavedOrders = function();

See Also

CustomerOrder Class
InSite.Model Namespace


RemoveCustomerOrderProperty Method

[image]

.NET Framework Class Library
CustomerOrder..::.RemoveCustomerOrderProperty Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomerOrderProperty ( _
    value As CustomerOrderProperty _
)
C#
public virtual void RemoveCustomerOrderProperty(
    CustomerOrderProperty value
)
Visual C++
public:
virtual void RemoveCustomerOrderProperty(
    CustomerOrderProperty^ value
)
JavaScript
function removeCustomerOrderProperty(value);

Parameters

value
Type: InSite.Model..::.CustomerOrderProperty

See Also

CustomerOrder Class
InSite.Model Namespace


RemoveGiftCard Method

[image]

.NET Framework Class Library
CustomerOrder..::.RemoveGiftCard Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveGiftCard ( _
    value As GiftCard _
)
C#
public virtual void RemoveGiftCard(
    GiftCard value
)
Visual C++
public:
virtual void RemoveGiftCard(
    GiftCard^ value
)
JavaScript
function removeGiftCard(value);

Parameters

value
Type: InSite.Model..::.GiftCard

See Also

CustomerOrder Class
InSite.Model Namespace


RemoveOrderLine Method

[image] [image]

.NET Framework Class Library
CustomerOrder..::.RemoveOrderLine Method
CustomerOrder Class See Also Send Feedback

Overload List

Name | Description
RemoveOrderLine(OrderLine) |
RemoveOrderLine(Int32) |

See Also

CustomerOrder Class
CustomerOrder Members
InSite.Model Namespace


RemoveOrderLine Method (OrderLine)

[image]

.NET Framework Class Library
CustomerOrder..::.RemoveOrderLine Method (OrderLine)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveOrderLine ( _
    value As OrderLine _
)
C#
public virtual void RemoveOrderLine(
    OrderLine value
)
Visual C++
public:
virtual void RemoveOrderLine(
    OrderLine^ value
)
JavaScript
function removeOrderLine(value);

Parameters

value
Type: InSite.Model..::.OrderLine

See Also

CustomerOrder Class
RemoveOrderLine Overload
InSite.Model Namespace


RemoveOrderLine Method (Int32)

[image]

.NET Framework Class Library
CustomerOrder..::.RemoveOrderLine Method (Int32)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveOrderLine ( _
    lineNumber As Integer _
)
C#
public virtual void RemoveOrderLine(
    int lineNumber
)
Visual C++
public:
virtual void RemoveOrderLine(
    int lineNumber
)
JavaScript
function removeOrderLine(lineNumber);

Parameters

lineNumber
Type: System..::.Int32

See Also

CustomerOrder Class
RemoveOrderLine Overload
InSite.Model Namespace


RemovePromotion Method

[image]

.NET Framework Class Library
CustomerOrder..::.RemovePromotion Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemovePromotion ( _
    value As Promotion _
)
C#
public virtual void RemovePromotion(
    Promotion value
)
Visual C++
public:
virtual void RemovePromotion(
    Promotion^ value
)
JavaScript
function removePromotion(value);

Parameters

value
Type: InSite.Model..::.Promotion

See Also

CustomerOrder Class
InSite.Model Namespace


RemovePromotionCode Method

[image] [image]

.NET Framework Class Library
CustomerOrder..::.RemovePromotionCode Method
CustomerOrder Class See Also Send Feedback

Overload List

Name | Description
RemovePromotionCode(PromotionCode) |
RemovePromotionCode(String) |

See Also

CustomerOrder Class
CustomerOrder Members
InSite.Model Namespace


RemovePromotionCode Method (PromotionCode)

[image]

.NET Framework Class Library
CustomerOrder..::.RemovePromotionCode Method (PromotionCode)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemovePromotionCode ( _
    value As PromotionCode _
)
C#
public virtual void RemovePromotionCode(
    PromotionCode value
)
Visual C++
public:
virtual void RemovePromotionCode(
    PromotionCode^ value
)
JavaScript
function removePromotionCode(value);

Parameters

value
Type: InSite.Model..::.PromotionCode

See Also

CustomerOrder Class
RemovePromotionCode Overload
InSite.Model Namespace


RemovePromotionCode Method (String)

[image]

.NET Framework Class Library
CustomerOrder..::.RemovePromotionCode Method (String)
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemovePromotionCode ( _
    value As String _
)
C#
public virtual void RemovePromotionCode(
    string value
)
Visual C++
public:
virtual void RemovePromotionCode(
    String^ value
)
JavaScript
function removePromotionCode(value);

Parameters

value
Type: System..::.String

See Also

CustomerOrder Class
RemovePromotionCode Overload
InSite.Model Namespace


RemoveRestrictedOrderLines Method

[image]

.NET Framework Class Library
CustomerOrder..::.RemoveRestrictedOrderLines Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveRestrictedOrderLines
C#
public virtual void RemoveRestrictedOrderLines()
Visual C++
public:
virtual void RemoveRestrictedOrderLines()
JavaScript
function removeRestrictedOrderLines();

See Also

CustomerOrder Class
InSite.Model Namespace


RemoveShipment Method

[image]

.NET Framework Class Library
CustomerOrder..::.RemoveShipment Method
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipment ( _
    value As Shipment _
)
C#
public virtual void RemoveShipment(
    Shipment value
)
Visual C++
public:
virtual void RemoveShipment(
    Shipment^ value
)
JavaScript
function removeShipment(value);

Parameters

value
Type: InSite.Model..::.Shipment

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerOrder Properties

[image] [image]

.NET Framework Class Library
CustomerOrder Properties
CustomerOrder Class See Also Send Feedback

The CustomerOrder type exposes the following members.

Properties

Name | Description
AmountPaid | Returns the total amount paid with credit card transactions, this will be charges - voids/credits
AppliedPromoCodes |
AutoCalculatePrice |
AvailableCreditLimit |
BatchNumber |
BTAddress1 |
BTAddress2 |
BTAddress3 |
BTAddress4 |
BTCity |
BTCompany |
BTContact1 |
BTContact2 |
BTContact3 |
BTCountry |
BTCounty |
BTDisplayName |
BTEmail |
BTFax |
BTFirstName |
BTLastName |
BTMiddleName |
BTPhone1 |
BTPhone2 |
BTPhone3 |
BTState |
BTZip |
Buyer |
CanProcessOrder |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CollectAccountNumber |
CreditCard | CreditCard - Contained object to hold Credit Card information It must be set on the same postback that the order submission happens Alternatively you can bind to the flattened out CreditCard properties, either way they don't persist past a postback, they must be set during the order submission postback
CreditCardAmount |
CreditCardCSC |
CreditCardExpirationMonth |
CreditCardExpirationYear |
CreditCardName |
CreditCardNumber |
CreditCardTransactions |
CreditCardType |
CurrencyCode |
Current | Returns the Current Customer Order in the Shopping Cart, if there isn't one, one is created for you
Customer |
CustomerNumber |
CustomerOrderDataSet |
CustomerOrderId |
CustomerOrderProperties |
CustomerPO |
CustomerPOTypeCode |
CustomerReference1 |
CustomerReference2 |
CustomerSequence |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DiscountAmount |
DiscountPercent |
DollarOffOrder |
DollarOffShipping |
DropShip |
EndUserType |
ERPOrderNumber |
ERPShipCode |
FailedRestrictionOrderLines |
FullShippingCharge |
GiftCards |
GiftCardTotal |
GiftCardTransactions |
Handling |
HasSubscription | Will return true if this Order has an OrderLine that is a Subscription
HtmlBillingAddress |
HtmlShippingAddress |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InsideDelivery |
InvoiceFrequency |
IsDropShip |
IsGiftCardOnlyOrder |
IsOrderOverCreditLimit |
IsSubscription |
IsSubscriptionOnlyOrder |
IsValid |
LanguageCode |
LiftGateService |
LocalShippingAndHandlingTax |
LocalTax |
LocalTaxableTotal |
LocalTaxRate |
LocalTaxRates |
Notes |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderAffiliate |
OrderDate |
OrderFreightableQuantity |
OrderFreightableTotal |
OrderGrandTotal | Order Grand Total is (this.OrderTotal + this.TotalTax + this.ShippingAndHandling)
OrderLines |
OrderNonTaxableTotal |
OrderNumber |
OrderNumberFormat |
OrderNumberPrefix |
OrderProductValue |
OrderSavingsAmount |
OrderSavingsPercent |
OrderSubTotal |
OrderSubTotalWithOutProductDiscounts |
OrderTaxableTotal |
OrderTotal | OrderTotal is (this.OrderSubTotal - this.DollarOffOrder) * (1 - this.PercentOffOrder)
OrderTotalDue | Order Total Due is (this.OrderGrandTotal - this.GiftCardTotal - this.PromotionProductDiscountTotal - this.PromotionShippingDiscountTotal)
PassesRestrictions |
PercentOffOrder |
PercentOffShipping |
PriceCode |
ProductOverriddenFreightTotal |
PromotionCodes |
PromotionOrderDiscountTotal |
PromotionProductDiscountTotal |
Promotions |
PromotionShippingDiscountTotal |
PromotionTotal |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RequestedShipDate |
Residential |
Salesman |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipCode |
ShipEarly |
ShipmentPackages |
ShipmentQuoteNumber |
Shipments |
ShipPartial |
Shipping |
ShippingAndHandling |
ShippingCosts |
ShipTo |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
STAddress1 |
STAddress2 |
STAddress3 |
STAddress4 |
StateShippingAndHandlingTax |
StateTax |
StateTaxableTotal |
StateTaxRate |
StateTaxRates |
Status |
STCity |
STCompany |
STContact1 |
STContact2 |
STContact3 |
STCountry |
STCounty |
STDisplayName |
STEmail |
STFax |
STFirstName |
STLastName |
STMiddleName |
STPhone1 |
STPhone2 |
STPhone3 |
STState |
STZip |
Subscription |
Subscriptions |
TaxCode1 |
TaxCode2 |
TermsCode |
TotalItemsOrdered |
TotalSalesTax | TotalSalesTax - Total Tax excluding Shipping And Handling Tax
TotalShippingAndHandlingTax |
TotalTax |
TotalWeight |
Type |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserName |
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
VerificationSent |
Warehouse |
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerOrder Class
InSite.Model Namespace


AmountPaid Property

[image]

.NET Framework Class Library
CustomerOrder..::.AmountPaid Property
CustomerOrder Class See Also Send Feedback

Returns the total amount paid with credit card transactions, this will be charges - voids/credits

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AmountPaid As Decimal
C#
public virtual decimal AmountPaid { get; }
Visual C++
public:
virtual property Decimal AmountPaid {
    Decimal get ();
}
JavaScript
function get_amountPaid();

See Also

CustomerOrder Class
InSite.Model Namespace


AppliedPromoCodes Property

[image]

.NET Framework Class Library
CustomerOrder..::.AppliedPromoCodes Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AppliedPromoCodes As String
C#
public virtual string AppliedPromoCodes { get; }
Visual C++
public:
virtual property String^ AppliedPromoCodes {
    String^ get ();
}
JavaScript
function get_appliedPromoCodes();

See Also

CustomerOrder Class
InSite.Model Namespace


AutoCalculatePrice Property

[image]

.NET Framework Class Library
CustomerOrder..::.AutoCalculatePrice Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AutoCalculatePrice As String
C#
public virtual string AutoCalculatePrice { get; }
Visual C++
public:
virtual property String^ AutoCalculatePrice {
    String^ get ();
}
JavaScript
function get_autoCalculatePrice();

See Also

CustomerOrder Class
InSite.Model Namespace


AvailableCreditLimit Property

[image]

.NET Framework Class Library
CustomerOrder..::.AvailableCreditLimit Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AvailableCreditLimit As Decimal
C#
public virtual decimal AvailableCreditLimit { get; }
Visual C++
public:
virtual property Decimal AvailableCreditLimit {
    Decimal get ();
}
JavaScript
function get_availableCreditLimit();

See Also

CustomerOrder Class
InSite.Model Namespace


BatchNumber Property

[image]

.NET Framework Class Library
CustomerOrder..::.BatchNumber Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BatchNumber As Integer
C#
[DataMemberAttribute]
public virtual int BatchNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int BatchNumber {
    int get ();
    void set (int value);
}
JavaScript
function get_batchNumber();
function set_batchNumber(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTAddress1 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTAddress1 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTAddress1 As String
C#
[DataMemberAttribute]
public virtual string BTAddress1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTAddress1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btAddress1();
function set_btAddress1(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTAddress2 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTAddress2 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTAddress2 As String
C#
[DataMemberAttribute]
public virtual string BTAddress2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTAddress2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btAddress2();
function set_btAddress2(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTAddress3 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTAddress3 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTAddress3 As String
C#
[DataMemberAttribute]
public virtual string BTAddress3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTAddress3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btAddress3();
function set_btAddress3(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTAddress4 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTAddress4 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTAddress4 As String
C#
[DataMemberAttribute]
public virtual string BTAddress4 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTAddress4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btAddress4();
function set_btAddress4(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTCity Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTCity Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTCity As String
C#
[DataMemberAttribute]
public virtual string BTCity { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btCity();
function set_btCity(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTCompany Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTCompany Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTCompany As String
C#
[DataMemberAttribute]
public virtual string BTCompany { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTCompany {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btCompany();
function set_btCompany(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTContact1 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTContact1 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTContact1 As String
C#
[DataMemberAttribute]
public virtual string BTContact1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTContact1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btContact1();
function set_btContact1(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTContact2 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTContact2 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTContact2 As String
C#
[DataMemberAttribute]
public virtual string BTContact2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTContact2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btContact2();
function set_btContact2(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTContact3 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTContact3 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTContact3 As String
C#
[DataMemberAttribute]
public virtual string BTContact3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTContact3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btContact3();
function set_btContact3(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTCountry Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTCountry Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTCountry As String
C#
[DataMemberAttribute]
public virtual string BTCountry { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btCountry();
function set_btCountry(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTCounty Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTCounty Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTCounty As String
C#
[DataMemberAttribute]
public virtual string BTCounty { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTCounty {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btCounty();
function set_btCounty(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTDisplayName Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTDisplayName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BTDisplayName As String
C#
public virtual string BTDisplayName { get; }
Visual C++
public:
virtual property String^ BTDisplayName {
    String^ get ();
}
JavaScript
function get_btDisplayName();

See Also

CustomerOrder Class
InSite.Model Namespace


BTEmail Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTEmail Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTEmail As String
C#
[DataMemberAttribute]
public virtual string BTEmail { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btEmail();
function set_btEmail(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTFax Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTFax Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTFax As String
C#
[DataMemberAttribute]
public virtual string BTFax { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTFax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btFax();
function set_btFax(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTFirstName Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTFirstName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTFirstName As String
C#
[DataMemberAttribute]
public virtual string BTFirstName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTFirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btFirstName();
function set_btFirstName(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTLastName Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTLastName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTLastName As String
C#
[DataMemberAttribute]
public virtual string BTLastName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTLastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btLastName();
function set_btLastName(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTMiddleName Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTMiddleName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTMiddleName As String
C#
[DataMemberAttribute]
public virtual string BTMiddleName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTMiddleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btMiddleName();
function set_btMiddleName(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTPhone1 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTPhone1 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTPhone1 As String
C#
[DataMemberAttribute]
public virtual string BTPhone1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTPhone1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btPhone1();
function set_btPhone1(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTPhone2 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTPhone2 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTPhone2 As String
C#
[DataMemberAttribute]
public virtual string BTPhone2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTPhone2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btPhone2();
function set_btPhone2(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTPhone3 Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTPhone3 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTPhone3 As String
C#
[DataMemberAttribute]
public virtual string BTPhone3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTPhone3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btPhone3();
function set_btPhone3(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTState Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTState Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTState As String
C#
[DataMemberAttribute]
public virtual string BTState { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btState();
function set_btState(value);

See Also

CustomerOrder Class
InSite.Model Namespace


BTZip Property

[image]

.NET Framework Class Library
CustomerOrder..::.BTZip Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BTZip As String
C#
[DataMemberAttribute]
public virtual string BTZip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BTZip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_btZip();
function set_btZip(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Buyer Property

[image]

.NET Framework Class Library
CustomerOrder..::.Buyer Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Buyer As String
C#
[DataMemberAttribute]
public virtual string Buyer { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Buyer {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_buyer();
function set_buyer(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CanProcessOrder Property

[image]

.NET Framework Class Library
CustomerOrder..::.CanProcessOrder Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CanProcessOrder As Boolean
C#
public virtual bool CanProcessOrder { get; }
Visual C++
public:
virtual property bool CanProcessOrder {
    bool get ();
}
JavaScript
function get_canProcessOrder();

See Also

CustomerOrder Class
InSite.Model Namespace


CollectAccountNumber Property

[image]

.NET Framework Class Library
CustomerOrder..::.CollectAccountNumber Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CollectAccountNumber As String
C#
[DataMemberAttribute]
public virtual string CollectAccountNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CollectAccountNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_collectAccountNumber();
function set_collectAccountNumber(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCard Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCard Property
CustomerOrder Class See Also Send Feedback

CreditCard - Contained object to hold Credit Card information It must be set on the same postback that the order submission happens Alternatively you can bind to the flattened out CreditCard properties, either way they don't persist past a postback, they must be set during the order submission postback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCard As CreditCard
C#
public virtual CreditCard CreditCard { get; set; }
Visual C++
public:
virtual property CreditCard^ CreditCard {
    CreditCard^ get ();
    void set (CreditCard^ value);
}
JavaScript
function get_creditCard();
function set_creditCard(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCardAmount Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCardAmount Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCardAmount As Decimal
C#
public virtual decimal CreditCardAmount { get; set; }
Visual C++
public:
virtual property Decimal CreditCardAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_creditCardAmount();
function set_creditCardAmount(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCardCSC Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCardCSC Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCardCSC As String
C#
public virtual string CreditCardCSC { get; set; }
Visual C++
public:
virtual property String^ CreditCardCSC {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_creditCardCSC();
function set_creditCardCSC(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCardExpirationMonth Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCardExpirationMonth Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCardExpirationMonth As Integer
C#
public virtual int CreditCardExpirationMonth { get; set; }
Visual C++
public:
virtual property int CreditCardExpirationMonth {
    int get ();
    void set (int value);
}
JavaScript
function get_creditCardExpirationMonth();
function set_creditCardExpirationMonth(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCardExpirationYear Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCardExpirationYear Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCardExpirationYear As Integer
C#
public virtual int CreditCardExpirationYear { get; set; }
Visual C++
public:
virtual property int CreditCardExpirationYear {
    int get ();
    void set (int value);
}
JavaScript
function get_creditCardExpirationYear();
function set_creditCardExpirationYear(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCardName Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCardName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCardName As String
C#
public virtual string CreditCardName { get; set; }
Visual C++
public:
virtual property String^ CreditCardName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_creditCardName();
function set_creditCardName(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCardNumber Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCardNumber Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCardNumber As String
C#
public virtual string CreditCardNumber { get; set; }
Visual C++
public:
virtual property String^ CreditCardNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_creditCardNumber();
function set_creditCardNumber(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCardTransactions Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCardTransactions Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CreditCardTransactions As ChildList(Of CreditCardTransaction)
C#
[DataMemberAttribute]
public virtual ChildList<CreditCardTransaction> CreditCardTransactions { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<CreditCardTransaction^>^ CreditCardTransactions {
    ChildList<CreditCardTransaction^>^ get ();
    void set (ChildList<CreditCardTransaction^>^ value);
}
JavaScript
function get_creditCardTransactions();
function set_creditCardTransactions(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CreditCardType Property

[image]

.NET Framework Class Library
CustomerOrder..::.CreditCardType Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CreditCardType As String
C#
public virtual string CreditCardType { get; set; }
Visual C++
public:
virtual property String^ CreditCardType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_creditCardType();
function set_creditCardType(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CurrencyCode Property

[image]

.NET Framework Class Library
CustomerOrder..::.CurrencyCode Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CurrencyCode As String
C#
[DataMemberAttribute]
public virtual string CurrencyCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currencyCode();
function set_currencyCode(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Current Property

[image]

.NET Framework Class Library
CustomerOrder..::.Current Property
CustomerOrder Class See Also Send Feedback

Returns the Current Customer Order in the Shopping Cart, if there isn't one, one is created for you

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Current As CustomerOrder
C#
public static CustomerOrder Current { get; }
Visual C++
public:
static property CustomerOrder^ Current {
    CustomerOrder^ get ();
}
JavaScript
InSite.Model.CustomerOrder.get_current = function();

See Also

CustomerOrder Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
CustomerOrder..::.Customer Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customer As Customer
C#
public virtual Customer Customer { get; set; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerNumber Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerNumber Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumber As String
C#
[DataMemberAttribute]
public virtual string CustomerNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumber();
function set_customerNumber(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerOrderDataSet Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerOrderDataSet Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CustomerOrderDataSet As DataSet
C#
public virtual DataSet CustomerOrderDataSet { get; }
Visual C++
public:
virtual property DataSet^ CustomerOrderDataSet {
    DataSet^ get ();
}
JavaScript
function get_customerOrderDataSet();

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerOrderId Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerOrderId Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrderId As Guid
C#
public virtual Guid CustomerOrderId { get; set; }
Visual C++
public:
virtual property Guid CustomerOrderId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_customerOrderId();
function set_customerOrderId(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerOrderProperties Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerOrderProperties Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrderProperties As ChildList(Of CustomerOrderProperty)
C#
public virtual ChildList<CustomerOrderProperty> CustomerOrderProperties { get; private set; }
Visual C++
public:
virtual property ChildList<CustomerOrderProperty^>^ CustomerOrderProperties {
    ChildList<CustomerOrderProperty^>^ get ();
    void set (ChildList<CustomerOrderProperty^>^ value);
}
JavaScript
function get_customerOrderProperties();
function set_customerOrderProperties(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerPO Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerPO Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerPO As String
C#
[DataMemberAttribute]
public virtual string CustomerPO { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerPO {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerPO();
function set_customerPO(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerPOTypeCode Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerPOTypeCode Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerPOTypeCode As String
C#
[DataMemberAttribute]
public virtual string CustomerPOTypeCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerPOTypeCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerPOTypeCode();
function set_customerPOTypeCode(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerReference1 Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerReference1 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerReference1 As String
C#
[DataMemberAttribute]
public virtual string CustomerReference1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerReference1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerReference1();
function set_customerReference1(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerReference2 Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerReference2 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerReference2 As String
C#
[DataMemberAttribute]
public virtual string CustomerReference2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerReference2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerReference2();
function set_customerReference2(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerSequence Property

[image]

.NET Framework Class Library
CustomerOrder..::.CustomerSequence Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerSequence As String
C#
[DataMemberAttribute]
public virtual string CustomerSequence { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerSequence {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerSequence();
function set_customerSequence(value);

See Also

CustomerOrder Class
InSite.Model Namespace


DiscountAmount Property

[image]

.NET Framework Class Library
CustomerOrder..::.DiscountAmount Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DiscountAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal DiscountAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal DiscountAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discountAmount();
function set_discountAmount(value);

See Also

CustomerOrder Class
InSite.Model Namespace


DiscountPercent Property

[image]

.NET Framework Class Library
CustomerOrder..::.DiscountPercent Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DiscountPercent As Decimal
C#
[DataMemberAttribute]
public virtual decimal DiscountPercent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal DiscountPercent {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discountPercent();
function set_discountPercent(value);

See Also

CustomerOrder Class
InSite.Model Namespace


DollarOffOrder Property

[image]

.NET Framework Class Library
CustomerOrder..::.DollarOffOrder Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DollarOffOrder As Decimal
C#
public virtual decimal DollarOffOrder { get; }
Visual C++
public:
virtual property Decimal DollarOffOrder {
    Decimal get ();
}
JavaScript
function get_dollarOffOrder();

See Also

CustomerOrder Class
InSite.Model Namespace


DollarOffShipping Property

[image]

.NET Framework Class Library
CustomerOrder..::.DollarOffShipping Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DollarOffShipping As Decimal
C#
public virtual decimal DollarOffShipping { get; }
Visual C++
public:
virtual property Decimal DollarOffShipping {
    Decimal get ();
}
JavaScript
function get_dollarOffShipping();

See Also

CustomerOrder Class
InSite.Model Namespace


DropShip Property

[image]

.NET Framework Class Library
CustomerOrder..::.DropShip Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DropShip As Customer
C#
public virtual Customer DropShip { get; set; }
Visual C++
public:
virtual property Customer^ DropShip {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_dropShip();
function set_dropShip(value);

See Also

CustomerOrder Class
InSite.Model Namespace


EndUserType Property

[image]

.NET Framework Class Library
CustomerOrder..::.EndUserType Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property EndUserType As String
C#
[DataMemberAttribute]
public virtual string EndUserType { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ EndUserType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_endUserType();
function set_endUserType(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ERPOrderNumber Property

[image]

.NET Framework Class Library
CustomerOrder..::.ERPOrderNumber Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPOrderNumber As String
C#
[DataMemberAttribute]
public virtual string ERPOrderNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPOrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpOrderNumber();
function set_erpOrderNumber(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ERPShipCode Property

[image]

.NET Framework Class Library
CustomerOrder..::.ERPShipCode Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ERPShipCode As String
C#
public virtual string ERPShipCode { get; }
Visual C++
public:
virtual property String^ ERPShipCode {
    String^ get ();
}
JavaScript
function get_erpShipCode();

See Also

CustomerOrder Class
InSite.Model Namespace


FailedRestrictionOrderLines Property

[image]

.NET Framework Class Library
CustomerOrder..::.FailedRestrictionOrderLines Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FailedRestrictionOrderLines As ChildList(Of OrderLine)
C#
public virtual ChildList<OrderLine> FailedRestrictionOrderLines { get; }
Visual C++
public:
virtual property ChildList<OrderLine^>^ FailedRestrictionOrderLines {
    ChildList<OrderLine^>^ get ();
}
JavaScript
function get_failedRestrictionOrderLines();

See Also

CustomerOrder Class
InSite.Model Namespace


FullShippingCharge Property

[image]

.NET Framework Class Library
CustomerOrder..::.FullShippingCharge Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FullShippingCharge As Decimal
C#
public virtual decimal FullShippingCharge { get; }
Visual C++
public:
virtual property Decimal FullShippingCharge {
    Decimal get ();
}
JavaScript
function get_fullShippingCharge();

See Also

CustomerOrder Class
InSite.Model Namespace


GiftCards Property

[image]

.NET Framework Class Library
CustomerOrder..::.GiftCards Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property GiftCards As ChildList(Of GiftCard)
C#
public virtual ChildList<GiftCard> GiftCards { get; private set; }
Visual C++
public:
virtual property ChildList<GiftCard^>^ GiftCards {
    ChildList<GiftCard^>^ get ();
    void set (ChildList<GiftCard^>^ value);
}
JavaScript
function get_giftCards();
function set_giftCards(value);

See Also

CustomerOrder Class
InSite.Model Namespace


GiftCardTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.GiftCardTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property GiftCardTotal As Decimal
C#
public virtual decimal GiftCardTotal { get; }
Visual C++
public:
virtual property Decimal GiftCardTotal {
    Decimal get ();
}
JavaScript
function get_giftCardTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


GiftCardTransactions Property

[image]

.NET Framework Class Library
CustomerOrder..::.GiftCardTransactions Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property GiftCardTransactions As ChildList(Of GiftCardTransaction)
C#
public virtual ChildList<GiftCardTransaction> GiftCardTransactions { get; private set; }
Visual C++
public:
virtual property ChildList<GiftCardTransaction^>^ GiftCardTransactions {
    ChildList<GiftCardTransaction^>^ get ();
    void set (ChildList<GiftCardTransaction^>^ value);
}
JavaScript
function get_giftCardTransactions();
function set_giftCardTransactions(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Handling Property

[image]

.NET Framework Class Library
CustomerOrder..::.Handling Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Handling As Decimal
C#
[DataMemberAttribute]
public virtual decimal Handling { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Handling {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_handling();
function set_handling(value);

See Also

CustomerOrder Class
InSite.Model Namespace


HasSubscription Property

[image]

.NET Framework Class Library
CustomerOrder..::.HasSubscription Property
CustomerOrder Class See Also Send Feedback

Will return true if this Order has an OrderLine that is a Subscription

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HasSubscription As Boolean
C#
public virtual bool HasSubscription { get; }
Visual C++
public:
virtual property bool HasSubscription {
    bool get ();
}
JavaScript
function get_hasSubscription();

See Also

CustomerOrder Class
InSite.Model Namespace


HtmlBillingAddress Property

[image]

.NET Framework Class Library
CustomerOrder..::.HtmlBillingAddress Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HtmlBillingAddress As String
C#
public virtual string HtmlBillingAddress { get; }
Visual C++
public:
virtual property String^ HtmlBillingAddress {
    String^ get ();
}
JavaScript
function get_htmlBillingAddress();

See Also

CustomerOrder Class
InSite.Model Namespace


HtmlShippingAddress Property

[image]

.NET Framework Class Library
CustomerOrder..::.HtmlShippingAddress Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HtmlShippingAddress As String
C#
public virtual string HtmlShippingAddress { get; }
Visual C++
public:
virtual property String^ HtmlShippingAddress {
    String^ get ();
}
JavaScript
function get_htmlShippingAddress();

See Also

CustomerOrder Class
InSite.Model Namespace


InsideDelivery Property

[image]

.NET Framework Class Library
CustomerOrder..::.InsideDelivery Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property InsideDelivery As Boolean
C#
[DataMemberAttribute]
public virtual bool InsideDelivery { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool InsideDelivery {
    bool get ();
    void set (bool value);
}
JavaScript
function get_insideDelivery();
function set_insideDelivery(value);

See Also

CustomerOrder Class
InSite.Model Namespace


InvoiceFrequency Property

[image]

.NET Framework Class Library
CustomerOrder..::.InvoiceFrequency Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property InvoiceFrequency As String
C#
[DataMemberAttribute]
public virtual string InvoiceFrequency { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ InvoiceFrequency {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceFrequency();
function set_invoiceFrequency(value);

See Also

CustomerOrder Class
InSite.Model Namespace


IsDropShip Property

[image]

.NET Framework Class Library
CustomerOrder..::.IsDropShip Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDropShip As Boolean
C#
public virtual bool IsDropShip { get; }
Visual C++
public:
virtual property bool IsDropShip {
    bool get ();
}
JavaScript
function get_isDropShip();

See Also

CustomerOrder Class
InSite.Model Namespace


IsGiftCardOnlyOrder Property

[image]

.NET Framework Class Library
CustomerOrder..::.IsGiftCardOnlyOrder Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsGiftCardOnlyOrder As Boolean
C#
public virtual bool IsGiftCardOnlyOrder { get; }
Visual C++
public:
virtual property bool IsGiftCardOnlyOrder {
    bool get ();
}
JavaScript
function get_isGiftCardOnlyOrder();

See Also

CustomerOrder Class
InSite.Model Namespace


IsOrderOverCreditLimit Property

[image]

.NET Framework Class Library
CustomerOrder..::.IsOrderOverCreditLimit Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsOrderOverCreditLimit As Boolean
C#
public virtual bool IsOrderOverCreditLimit { get; }
Visual C++
public:
virtual property bool IsOrderOverCreditLimit {
    bool get ();
}
JavaScript
function get_isOrderOverCreditLimit();

See Also

CustomerOrder Class
InSite.Model Namespace


IsSubscription Property

[image]

.NET Framework Class Library
CustomerOrder..::.IsSubscription Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsSubscription As Boolean
C#
public virtual bool IsSubscription { get; }
Visual C++
public:
virtual property bool IsSubscription {
    bool get ();
}
JavaScript
function get_isSubscription();

See Also

CustomerOrder Class
InSite.Model Namespace


IsSubscriptionOnlyOrder Property

[image]

.NET Framework Class Library
CustomerOrder..::.IsSubscriptionOnlyOrder Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsSubscriptionOnlyOrder As Boolean
C#
public virtual bool IsSubscriptionOnlyOrder { get; }
Visual C++
public:
virtual property bool IsSubscriptionOnlyOrder {
    bool get ();
}
JavaScript
function get_isSubscriptionOnlyOrder();

See Also

CustomerOrder Class
InSite.Model Namespace


IsValid Property

[image]

.NET Framework Class Library
CustomerOrder..::.IsValid Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsValid As Boolean
C#
public virtual bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get ();
}
JavaScript
function get_isValid();

See Also

CustomerOrder Class
InSite.Model Namespace


LanguageCode Property

[image]

.NET Framework Class Library
CustomerOrder..::.LanguageCode Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LanguageCode As String
C#
[DataMemberAttribute]
public virtual string LanguageCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_languageCode();
function set_languageCode(value);

See Also

CustomerOrder Class
InSite.Model Namespace


LiftGateService Property

[image]

.NET Framework Class Library
CustomerOrder..::.LiftGateService Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LiftGateService As Boolean
C#
[DataMemberAttribute]
public virtual bool LiftGateService { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool LiftGateService {
    bool get ();
    void set (bool value);
}
JavaScript
function get_liftGateService();
function set_liftGateService(value);

See Also

CustomerOrder Class
InSite.Model Namespace


LocalShippingAndHandlingTax Property

[image]

.NET Framework Class Library
CustomerOrder..::.LocalShippingAndHandlingTax Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LocalShippingAndHandlingTax As Decimal
C#
public virtual decimal LocalShippingAndHandlingTax { get; }
Visual C++
public:
virtual property Decimal LocalShippingAndHandlingTax {
    Decimal get ();
}
JavaScript
function get_localShippingAndHandlingTax();

See Also

CustomerOrder Class
InSite.Model Namespace


LocalTax Property

[image]

.NET Framework Class Library
CustomerOrder..::.LocalTax Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LocalTax As Decimal
C#
[DataMemberAttribute]
public virtual decimal LocalTax { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal LocalTax {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_localTax();
function set_localTax(value);

See Also

CustomerOrder Class
InSite.Model Namespace


LocalTaxableTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.LocalTaxableTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LocalTaxableTotal As Decimal
C#
public virtual decimal LocalTaxableTotal { get; }
Visual C++
public:
virtual property Decimal LocalTaxableTotal {
    Decimal get ();
}
JavaScript
function get_localTaxableTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


LocalTaxRate Property

[image]

.NET Framework Class Library
CustomerOrder..::.LocalTaxRate Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LocalTaxRate As LocalTaxRate
C#
public virtual LocalTaxRate LocalTaxRate { get; }
Visual C++
public:
virtual property LocalTaxRate^ LocalTaxRate {
    LocalTaxRate^ get ();
}
JavaScript
function get_localTaxRate();

See Also

CustomerOrder Class
InSite.Model Namespace


LocalTaxRates Property

[image]

.NET Framework Class Library
CustomerOrder..::.LocalTaxRates Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LocalTaxRates As IList(Of LocalTaxRate)
C#
public virtual IList<LocalTaxRate> LocalTaxRates { get; }
Visual C++
public:
virtual property IList<LocalTaxRate^>^ LocalTaxRates {
    IList<LocalTaxRate^>^ get ();
}
JavaScript
function get_localTaxRates();

See Also

CustomerOrder Class
InSite.Model Namespace


Notes Property

[image]

.NET Framework Class Library
CustomerOrder..::.Notes Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Notes As String
C#
[DataMemberAttribute]
public virtual string Notes { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Notes {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_notes();
function set_notes(value);

See Also

CustomerOrder Class
InSite.Model Namespace


OrderAffiliate Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderAffiliate Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderAffiliate As Affiliate
C#
public virtual Affiliate OrderAffiliate { get; set; }
Visual C++
public:
virtual property Affiliate^ OrderAffiliate {
    Affiliate^ get ();
    void set (Affiliate^ value);
}
JavaScript
function get_orderAffiliate();
function set_orderAffiliate(value);

See Also

CustomerOrder Class
InSite.Model Namespace


OrderDate Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderDate Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime OrderDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime OrderDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_orderDate();
function set_orderDate(value);

See Also

CustomerOrder Class
InSite.Model Namespace


OrderFreightableQuantity Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderFreightableQuantity Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderFreightableQuantity As Decimal
C#
public virtual decimal OrderFreightableQuantity { get; }
Visual C++
public:
virtual property Decimal OrderFreightableQuantity {
    Decimal get ();
}
JavaScript
function get_orderFreightableQuantity();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderFreightableTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderFreightableTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderFreightableTotal As Decimal
C#
public virtual decimal OrderFreightableTotal { get; }
Visual C++
public:
virtual property Decimal OrderFreightableTotal {
    Decimal get ();
}
JavaScript
function get_orderFreightableTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderGrandTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderGrandTotal Property
CustomerOrder Class See Also Send Feedback

Order Grand Total is (this.OrderTotal + this.TotalTax + this.ShippingAndHandling)

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderGrandTotal As Decimal
C#
public virtual decimal OrderGrandTotal { get; set; }
Visual C++
public:
virtual property Decimal OrderGrandTotal {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_orderGrandTotal();
function set_orderGrandTotal(value);

See Also

CustomerOrder Class
InSite.Model Namespace


OrderLines Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderLines Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderLines As ChildList(Of OrderLine)
C#
[DataMemberAttribute]
public virtual ChildList<OrderLine> OrderLines { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<OrderLine^>^ OrderLines {
    ChildList<OrderLine^>^ get ();
    void set (ChildList<OrderLine^>^ value);
}
JavaScript
function get_orderLines();
function set_orderLines(value);

See Also

CustomerOrder Class
InSite.Model Namespace


OrderNonTaxableTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderNonTaxableTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderNonTaxableTotal As Decimal
C#
public virtual decimal OrderNonTaxableTotal { get; }
Visual C++
public:
virtual property Decimal OrderNonTaxableTotal {
    Decimal get ();
}
JavaScript
function get_orderNonTaxableTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderNumber Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderNumber Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property OrderNumber As String
C#
[SortField]
[DataMemberAttribute]
public virtual string OrderNumber { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumber();
function set_orderNumber(value);

See Also

CustomerOrder Class
InSite.Model Namespace


OrderNumberFormat Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderNumberFormat Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property OrderNumberFormat As String
C#
public static string OrderNumberFormat { get; }
Visual C++
public:
static property String^ OrderNumberFormat {
    String^ get ();
}
JavaScript
InSite.Model.CustomerOrder.get_orderNumberFormat = function();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderNumberPrefix Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderNumberPrefix Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property OrderNumberPrefix As String
C#
public static string OrderNumberPrefix { get; }
Visual C++
public:
static property String^ OrderNumberPrefix {
    String^ get ();
}
JavaScript
InSite.Model.CustomerOrder.get_orderNumberPrefix = function();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderProductValue Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderProductValue Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderProductValue As Decimal
C#
public virtual decimal OrderProductValue { get; }
Visual C++
public:
virtual property Decimal OrderProductValue {
    Decimal get ();
}
JavaScript
function get_orderProductValue();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderSavingsAmount Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderSavingsAmount Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderSavingsAmount As Decimal
C#
public virtual decimal OrderSavingsAmount { get; }
Visual C++
public:
virtual property Decimal OrderSavingsAmount {
    Decimal get ();
}
JavaScript
function get_orderSavingsAmount();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderSavingsPercent Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderSavingsPercent Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderSavingsPercent As Decimal
C#
public virtual decimal OrderSavingsPercent { get; }
Visual C++
public:
virtual property Decimal OrderSavingsPercent {
    Decimal get ();
}
JavaScript
function get_orderSavingsPercent();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderSubTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderSubTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderSubTotal As Decimal
C#
public virtual decimal OrderSubTotal { get; }
Visual C++
public:
virtual property Decimal OrderSubTotal {
    Decimal get ();
}
JavaScript
function get_orderSubTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderSubTotalWithOutProductDiscounts Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderSubTotalWithOutProductDiscounts Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderSubTotalWithOutProductDiscounts As Decimal
C#
public virtual decimal OrderSubTotalWithOutProductDiscounts { get; }
Visual C++
public:
virtual property Decimal OrderSubTotalWithOutProductDiscounts {
    Decimal get ();
}
JavaScript
function get_orderSubTotalWithOutProductDiscounts();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderTaxableTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderTaxableTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderTaxableTotal As Decimal
C#
public virtual decimal OrderTaxableTotal { get; }
Visual C++
public:
virtual property Decimal OrderTaxableTotal {
    Decimal get ();
}
JavaScript
function get_orderTaxableTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


OrderTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderTotal Property
CustomerOrder Class See Also Send Feedback

OrderTotal is (this.OrderSubTotal - this.DollarOffOrder) * (1 - this.PercentOffOrder)

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderTotal As Decimal
C#
[DataMemberAttribute]
public virtual decimal OrderTotal { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal OrderTotal {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_orderTotal();
function set_orderTotal(value);

See Also

CustomerOrder Class
InSite.Model Namespace


OrderTotalDue Property

[image]

.NET Framework Class Library
CustomerOrder..::.OrderTotalDue Property
CustomerOrder Class See Also Send Feedback

Order Total Due is (this.OrderGrandTotal - this.GiftCardTotal - this.PromotionProductDiscountTotal - this.PromotionShippingDiscountTotal)

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OrderTotalDue As Decimal
C#
public virtual decimal OrderTotalDue { get; }
Visual C++
public:
virtual property Decimal OrderTotalDue {
    Decimal get ();
}
JavaScript
function get_orderTotalDue();

See Also

CustomerOrder Class
InSite.Model Namespace


PassesRestrictions Property

[image]

.NET Framework Class Library
CustomerOrder..::.PassesRestrictions Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PassesRestrictions As Boolean
C#
public virtual bool PassesRestrictions { get; }
Visual C++
public:
virtual property bool PassesRestrictions {
    bool get ();
}
JavaScript
function get_passesRestrictions();

See Also

CustomerOrder Class
InSite.Model Namespace


PercentOffOrder Property

[image]

.NET Framework Class Library
CustomerOrder..::.PercentOffOrder Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PercentOffOrder As Decimal
C#
public virtual decimal PercentOffOrder { get; }
Visual C++
public:
virtual property Decimal PercentOffOrder {
    Decimal get ();
}
JavaScript
function get_percentOffOrder();

See Also

CustomerOrder Class
InSite.Model Namespace


PercentOffShipping Property

[image]

.NET Framework Class Library
CustomerOrder..::.PercentOffShipping Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PercentOffShipping As Decimal
C#
public virtual decimal PercentOffShipping { get; }
Visual C++
public:
virtual property Decimal PercentOffShipping {
    Decimal get ();
}
JavaScript
function get_percentOffShipping();

See Also

CustomerOrder Class
InSite.Model Namespace


PriceCode Property

[image]

.NET Framework Class Library
CustomerOrder..::.PriceCode Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceCode As String
C#
[DataMemberAttribute]
public virtual string PriceCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceCode();
function set_priceCode(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ProductOverriddenFreightTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.ProductOverriddenFreightTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ProductOverriddenFreightTotal As Decimal
C#
public virtual decimal ProductOverriddenFreightTotal { get; }
Visual C++
public:
virtual property Decimal ProductOverriddenFreightTotal {
    Decimal get ();
}
JavaScript
function get_productOverriddenFreightTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


PromotionCodes Property

[image]

.NET Framework Class Library
CustomerOrder..::.PromotionCodes Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PromotionCodes As ChildList(Of PromotionCode)
C#
public virtual ChildList<PromotionCode> PromotionCodes { get; private set; }
Visual C++
public:
virtual property ChildList<PromotionCode^>^ PromotionCodes {
    ChildList<PromotionCode^>^ get ();
    void set (ChildList<PromotionCode^>^ value);
}
JavaScript
function get_promotionCodes();
function set_promotionCodes(value);

See Also

CustomerOrder Class
InSite.Model Namespace


PromotionOrderDiscountTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.PromotionOrderDiscountTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PromotionOrderDiscountTotal As Decimal
C#
public virtual decimal PromotionOrderDiscountTotal { get; }
Visual C++
public:
virtual property Decimal PromotionOrderDiscountTotal {
    Decimal get ();
}
JavaScript
function get_promotionOrderDiscountTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


PromotionProductDiscountTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.PromotionProductDiscountTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PromotionProductDiscountTotal As Decimal
C#
public virtual decimal PromotionProductDiscountTotal { get; }
Visual C++
public:
virtual property Decimal PromotionProductDiscountTotal {
    Decimal get ();
}
JavaScript
function get_promotionProductDiscountTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


Promotions Property

[image]

.NET Framework Class Library
CustomerOrder..::.Promotions Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Promotions As ChildList(Of Promotion)
C#
public virtual ChildList<Promotion> Promotions { get; private set; }
Visual C++
public:
virtual property ChildList<Promotion^>^ Promotions {
    ChildList<Promotion^>^ get ();
    void set (ChildList<Promotion^>^ value);
}
JavaScript
function get_promotions();
function set_promotions(value);

See Also

CustomerOrder Class
InSite.Model Namespace


PromotionShippingDiscountTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.PromotionShippingDiscountTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PromotionShippingDiscountTotal As Decimal
C#
public virtual decimal PromotionShippingDiscountTotal { get; }
Visual C++
public:
virtual property Decimal PromotionShippingDiscountTotal {
    Decimal get ();
}
JavaScript
function get_promotionShippingDiscountTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


PromotionTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.PromotionTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PromotionTotal As Decimal
C#
[DataMemberAttribute]
public virtual decimal PromotionTotal { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal PromotionTotal {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_promotionTotal();
function set_promotionTotal(value);

See Also

CustomerOrder Class
InSite.Model Namespace


RequestedShipDate Property

[image]

.NET Framework Class Library
CustomerOrder..::.RequestedShipDate Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RequestedShipDate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> RequestedShipDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> RequestedShipDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_requestedShipDate();
function set_requestedShipDate(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Residential Property

[image]

.NET Framework Class Library
CustomerOrder..::.Residential Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Residential As Boolean
C#
[DataMemberAttribute]
public virtual bool Residential { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool Residential {
    bool get ();
    void set (bool value);
}
JavaScript
function get_residential();
function set_residential(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Salesman Property

[image]

.NET Framework Class Library
CustomerOrder..::.Salesman Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Salesman As String
C#
[DataMemberAttribute]
public virtual string Salesman { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Salesman {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_salesman();
function set_salesman(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ShipCode Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShipCode Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipCode As String
C#
[DataMemberAttribute]
public virtual string ShipCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipCode();
function set_shipCode(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ShipEarly Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShipEarly Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipEarly As Boolean
C#
[DataMemberAttribute]
public virtual bool ShipEarly { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShipEarly {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shipEarly();
function set_shipEarly(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ShipmentPackages Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShipmentPackages Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ShipmentPackages As ChildList(Of ShipmentPackage)
C#
public virtual ChildList<ShipmentPackage> ShipmentPackages { get; }
Visual C++
public:
virtual property ChildList<ShipmentPackage^>^ ShipmentPackages {
    ChildList<ShipmentPackage^>^ get ();
}
JavaScript
function get_shipmentPackages();

See Also

CustomerOrder Class
InSite.Model Namespace


ShipmentQuoteNumber Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShipmentQuoteNumber Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipmentQuoteNumber As String
C#
[DataMemberAttribute]
public virtual string ShipmentQuoteNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipmentQuoteNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipmentQuoteNumber();
function set_shipmentQuoteNumber(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Shipments Property

[image]

.NET Framework Class Library
CustomerOrder..::.Shipments Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Shipments As ChildList(Of Shipment)
C#
[DataMemberAttribute]
public virtual ChildList<Shipment> Shipments { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Shipment^>^ Shipments {
    ChildList<Shipment^>^ get ();
    void set (ChildList<Shipment^>^ value);
}
JavaScript
function get_shipments();
function set_shipments(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ShipPartial Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShipPartial Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipPartial As Boolean
C#
[DataMemberAttribute]
public virtual bool ShipPartial { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShipPartial {
    bool get ();
    void set (bool value);
}
JavaScript
function get_shipPartial();
function set_shipPartial(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Shipping Property

[image]

.NET Framework Class Library
CustomerOrder..::.Shipping Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Shipping As Decimal
C#
[DataMemberAttribute]
public virtual decimal Shipping { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Shipping {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_shipping();
function set_shipping(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ShippingAndHandling Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShippingAndHandling Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ShippingAndHandling As Decimal
C#
public virtual decimal ShippingAndHandling { get; }
Visual C++
public:
virtual property Decimal ShippingAndHandling {
    Decimal get ();
}
JavaScript
function get_shippingAndHandling();

See Also

CustomerOrder Class
InSite.Model Namespace


ShippingCosts Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShippingCosts Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ShippingCosts As IList(Of IShippingCost)
C#
public virtual IList<IShippingCost> ShippingCosts { get; }
Visual C++
public:
virtual property IList<IShippingCost^>^ ShippingCosts {
    IList<IShippingCost^>^ get ();
}
JavaScript
function get_shippingCosts();

See Also

CustomerOrder Class
InSite.Model Namespace


ShipTo Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShipTo Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipTo As Customer
C#
public virtual Customer ShipTo { get; set; }
Visual C++
public:
virtual property Customer^ ShipTo {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_shipTo();
function set_shipTo(value);

See Also

CustomerOrder Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
CustomerOrder..::.ShipVia Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipVia As ShipVia
C#
public virtual ShipVia ShipVia { get; set; }
Visual C++
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STAddress1 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STAddress1 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STAddress1 As String
C#
[DataMemberAttribute]
public virtual string STAddress1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STAddress1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stAddress1();
function set_stAddress1(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STAddress2 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STAddress2 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STAddress2 As String
C#
[DataMemberAttribute]
public virtual string STAddress2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STAddress2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stAddress2();
function set_stAddress2(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STAddress3 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STAddress3 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STAddress3 As String
C#
[DataMemberAttribute]
public virtual string STAddress3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STAddress3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stAddress3();
function set_stAddress3(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STAddress4 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STAddress4 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STAddress4 As String
C#
[DataMemberAttribute]
public virtual string STAddress4 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STAddress4 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stAddress4();
function set_stAddress4(value);

See Also

CustomerOrder Class
InSite.Model Namespace


StateShippingAndHandlingTax Property

[image]

.NET Framework Class Library
CustomerOrder..::.StateShippingAndHandlingTax Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StateShippingAndHandlingTax As Decimal
C#
public virtual decimal StateShippingAndHandlingTax { get; }
Visual C++
public:
virtual property Decimal StateShippingAndHandlingTax {
    Decimal get ();
}
JavaScript
function get_stateShippingAndHandlingTax();

See Also

CustomerOrder Class
InSite.Model Namespace


StateTax Property

[image]

.NET Framework Class Library
CustomerOrder..::.StateTax Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property StateTax As Decimal
C#
[DataMemberAttribute]
public virtual decimal StateTax { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal StateTax {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_stateTax();
function set_stateTax(value);

See Also

CustomerOrder Class
InSite.Model Namespace


StateTaxableTotal Property

[image]

.NET Framework Class Library
CustomerOrder..::.StateTaxableTotal Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StateTaxableTotal As Decimal
C#
public virtual decimal StateTaxableTotal { get; }
Visual C++
public:
virtual property Decimal StateTaxableTotal {
    Decimal get ();
}
JavaScript
function get_stateTaxableTotal();

See Also

CustomerOrder Class
InSite.Model Namespace


StateTaxRate Property

[image]

.NET Framework Class Library
CustomerOrder..::.StateTaxRate Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StateTaxRate As State
C#
public virtual State StateTaxRate { get; }
Visual C++
public:
virtual property State^ StateTaxRate {
    State^ get ();
}
JavaScript
function get_stateTaxRate();

See Also

CustomerOrder Class
InSite.Model Namespace


StateTaxRates Property

[image]

.NET Framework Class Library
CustomerOrder..::.StateTaxRates Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StateTaxRates As IList(Of State)
C#
public virtual IList<State> StateTaxRates { get; }
Visual C++
public:
virtual property IList<State^>^ StateTaxRates {
    IList<State^>^ get ();
}
JavaScript
function get_stateTaxRates();

See Also

CustomerOrder Class
InSite.Model Namespace


Status Property

[image]

.NET Framework Class Library
CustomerOrder..::.Status Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Status As String
C#
[DataMemberAttribute]
public virtual string Status { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Status {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_status();
function set_status(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STCity Property

[image]

.NET Framework Class Library
CustomerOrder..::.STCity Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STCity As String
C#
[DataMemberAttribute]
public virtual string STCity { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STCity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stCity();
function set_stCity(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STCompany Property

[image]

.NET Framework Class Library
CustomerOrder..::.STCompany Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STCompany As String
C#
[DataMemberAttribute]
public virtual string STCompany { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STCompany {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stCompany();
function set_stCompany(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STContact1 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STContact1 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STContact1 As String
C#
[DataMemberAttribute]
public virtual string STContact1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STContact1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stContact1();
function set_stContact1(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STContact2 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STContact2 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STContact2 As String
C#
[DataMemberAttribute]
public virtual string STContact2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STContact2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stContact2();
function set_stContact2(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STContact3 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STContact3 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STContact3 As String
C#
[DataMemberAttribute]
public virtual string STContact3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STContact3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stContact3();
function set_stContact3(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STCountry Property

[image]

.NET Framework Class Library
CustomerOrder..::.STCountry Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STCountry As String
C#
[DataMemberAttribute]
public virtual string STCountry { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STCountry {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stCountry();
function set_stCountry(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STCounty Property

[image]

.NET Framework Class Library
CustomerOrder..::.STCounty Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STCounty As String
C#
[DataMemberAttribute]
public virtual string STCounty { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STCounty {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stCounty();
function set_stCounty(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STDisplayName Property

[image]

.NET Framework Class Library
CustomerOrder..::.STDisplayName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property STDisplayName As String
C#
public virtual string STDisplayName { get; }
Visual C++
public:
virtual property String^ STDisplayName {
    String^ get ();
}
JavaScript
function get_stDisplayName();

See Also

CustomerOrder Class
InSite.Model Namespace


STEmail Property

[image]

.NET Framework Class Library
CustomerOrder..::.STEmail Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STEmail As String
C#
[DataMemberAttribute]
public virtual string STEmail { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stEmail();
function set_stEmail(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STFax Property

[image]

.NET Framework Class Library
CustomerOrder..::.STFax Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STFax As String
C#
[DataMemberAttribute]
public virtual string STFax { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STFax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stFax();
function set_stFax(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STFirstName Property

[image]

.NET Framework Class Library
CustomerOrder..::.STFirstName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STFirstName As String
C#
[DataMemberAttribute]
public virtual string STFirstName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STFirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stFirstName();
function set_stFirstName(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STLastName Property

[image]

.NET Framework Class Library
CustomerOrder..::.STLastName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STLastName As String
C#
[DataMemberAttribute]
public virtual string STLastName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STLastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stLastName();
function set_stLastName(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STMiddleName Property

[image]

.NET Framework Class Library
CustomerOrder..::.STMiddleName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STMiddleName As String
C#
[DataMemberAttribute]
public virtual string STMiddleName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STMiddleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stMiddleName();
function set_stMiddleName(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STPhone1 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STPhone1 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STPhone1 As String
C#
[DataMemberAttribute]
public virtual string STPhone1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STPhone1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stPhone1();
function set_stPhone1(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STPhone2 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STPhone2 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STPhone2 As String
C#
[DataMemberAttribute]
public virtual string STPhone2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STPhone2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stPhone2();
function set_stPhone2(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STPhone3 Property

[image]

.NET Framework Class Library
CustomerOrder..::.STPhone3 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STPhone3 As String
C#
[DataMemberAttribute]
public virtual string STPhone3 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STPhone3 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stPhone3();
function set_stPhone3(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STState Property

[image]

.NET Framework Class Library
CustomerOrder..::.STState Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STState As String
C#
[DataMemberAttribute]
public virtual string STState { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stState();
function set_stState(value);

See Also

CustomerOrder Class
InSite.Model Namespace


STZip Property

[image]

.NET Framework Class Library
CustomerOrder..::.STZip Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property STZip As String
C#
[DataMemberAttribute]
public virtual string STZip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ STZip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stZip();
function set_stZip(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Subscription Property

[image]

.NET Framework Class Library
CustomerOrder..::.Subscription Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Subscription As Subscription
C#
public virtual Subscription Subscription { get; set; }
Visual C++
public:
virtual property Subscription^ Subscription {
    Subscription^ get ();
    void set (Subscription^ value);
}
JavaScript
function get_subscription();
function set_subscription(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Subscriptions Property

[image]

.NET Framework Class Library
CustomerOrder..::.Subscriptions Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Subscriptions As ChildList(Of Subscription)
C#
public virtual ChildList<Subscription> Subscriptions { get; private set; }
Visual C++
public:
virtual property ChildList<Subscription^>^ Subscriptions {
    ChildList<Subscription^>^ get ();
    void set (ChildList<Subscription^>^ value);
}
JavaScript
function get_subscriptions();
function set_subscriptions(value);

See Also

CustomerOrder Class
InSite.Model Namespace


TaxCode1 Property

[image]

.NET Framework Class Library
CustomerOrder..::.TaxCode1 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode1 As String
C#
[DataMemberAttribute]
public virtual string TaxCode1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode1();
function set_taxCode1(value);

See Also

CustomerOrder Class
InSite.Model Namespace


TaxCode2 Property

[image]

.NET Framework Class Library
CustomerOrder..::.TaxCode2 Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode2 As String
C#
[DataMemberAttribute]
public virtual string TaxCode2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode2();
function set_taxCode2(value);

See Also

CustomerOrder Class
InSite.Model Namespace


TermsCode Property

[image]

.NET Framework Class Library
CustomerOrder..::.TermsCode Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TermsCode As String
C#
[DataMemberAttribute]
public virtual string TermsCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TermsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_termsCode();
function set_termsCode(value);

See Also

CustomerOrder Class
InSite.Model Namespace


TotalItemsOrdered Property

[image]

.NET Framework Class Library
CustomerOrder..::.TotalItemsOrdered Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TotalItemsOrdered As Integer
C#
public virtual int TotalItemsOrdered { get; }
Visual C++
public:
virtual property int TotalItemsOrdered {
    int get ();
}
JavaScript
function get_totalItemsOrdered();

See Also

CustomerOrder Class
InSite.Model Namespace


TotalSalesTax Property

[image]

.NET Framework Class Library
CustomerOrder..::.TotalSalesTax Property
CustomerOrder Class See Also Send Feedback

TotalSalesTax - Total Tax excluding Shipping And Handling Tax

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TotalSalesTax As Decimal
C#
public virtual decimal TotalSalesTax { get; }
Visual C++
public:
virtual property Decimal TotalSalesTax {
    Decimal get ();
}
JavaScript
function get_totalSalesTax();

See Also

CustomerOrder Class
InSite.Model Namespace


TotalShippingAndHandlingTax Property

[image]

.NET Framework Class Library
CustomerOrder..::.TotalShippingAndHandlingTax Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TotalShippingAndHandlingTax As Decimal
C#
public virtual decimal TotalShippingAndHandlingTax { get; }
Visual C++
public:
virtual property Decimal TotalShippingAndHandlingTax {
    Decimal get ();
}
JavaScript
function get_totalShippingAndHandlingTax();

See Also

CustomerOrder Class
InSite.Model Namespace


TotalTax Property

[image]

.NET Framework Class Library
CustomerOrder..::.TotalTax Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TotalTax As Decimal
C#
public virtual decimal TotalTax { get; }
Visual C++
public:
virtual property Decimal TotalTax {
    Decimal get ();
}
JavaScript
function get_totalTax();

See Also

CustomerOrder Class
InSite.Model Namespace


TotalWeight Property

[image]

.NET Framework Class Library
CustomerOrder..::.TotalWeight Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TotalWeight As Decimal
C#
public virtual decimal TotalWeight { get; }
Visual C++
public:
virtual property Decimal TotalWeight {
    Decimal get ();
}
JavaScript
function get_totalWeight();

See Also

CustomerOrder Class
InSite.Model Namespace


Type Property

[image]

.NET Framework Class Library
CustomerOrder..::.Type Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Type As String
C#
[DataMemberAttribute]
public virtual string Type { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

See Also

CustomerOrder Class
InSite.Model Namespace


UserName Property

[image]

.NET Framework Class Library
CustomerOrder..::.UserName Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UserName As String
C#
[DataMemberAttribute]
public virtual string UserName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ UserName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_userName();
function set_userName(value);

See Also

CustomerOrder Class
InSite.Model Namespace


UserProfile Property

[image]

.NET Framework Class Library
CustomerOrder..::.UserProfile Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfile As UserProfile
C#
public virtual UserProfile UserProfile { get; set; }
Visual C++
public:
virtual property UserProfile^ UserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_userProfile();
function set_userProfile(value);

See Also

CustomerOrder Class
InSite.Model Namespace


VerificationSent Property

[image]

.NET Framework Class Library
CustomerOrder..::.VerificationSent Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property VerificationSent As DateTime
C#
public virtual DateTime VerificationSent { get; set; }
Visual C++
public:
virtual property DateTime VerificationSent {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_verificationSent();
function set_verificationSent(value);

See Also

CustomerOrder Class
InSite.Model Namespace


Warehouse Property

[image]

.NET Framework Class Library
CustomerOrder..::.Warehouse Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Warehouse As String
C#
[DataMemberAttribute]
public virtual string Warehouse { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Warehouse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_warehouse();
function set_warehouse(value);

See Also

CustomerOrder Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
CustomerOrder..::.WebSite Property
CustomerOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

CustomerOrder Class
InSite.Model Namespace


CustomerOrderProperty Class

[image]

.NET Framework Class Library
CustomerOrderProperty Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CustomerOrderProperty _
    Inherits ModelBase(Of CustomerOrderProperty)
C#
[SerializableAttribute]
public class CustomerOrderProperty : ModelBase<CustomerOrderProperty>
Visual C++
[SerializableAttribute]
public ref class CustomerOrderProperty : public ModelBase<CustomerOrderProperty^>
JavaScript
InSite.Model.CustomerOrderProperty = function();

Type.createClass(
    'InSite.Model.CustomerOrderProperty',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CustomerOrderProperty>)>)
InSite.Model..::.CustomerOrderProperty

See Also

CustomerOrderProperty Members
InSite.Model Namespace


CustomerOrderProperty Members

[image] [image]

.NET Framework Class Library
CustomerOrderProperty Members
CustomerOrderProperty Class Constructors Methods Fields Properties See Also Send Feedback

The CustomerOrderProperty type exposes the following members.

Constructors

Name | Description
CustomerOrderProperty | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrder |
CustomerOrderPropertyId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerOrderProperty Class
InSite.Model Namespace


CustomerOrderProperty Constructor

[image] [image]

.NET Framework Class Library
CustomerOrderProperty Constructor
CustomerOrderProperty Class See Also Send Feedback

Overload List

Name | Description
CustomerOrderProperty()()() |
CustomerOrderProperty(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CustomerOrderProperty Class
CustomerOrderProperty Members
InSite.Model Namespace


CustomerOrderProperty Constructor

[image]

.NET Framework Class Library
CustomerOrderProperty Constructor
CustomerOrderProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerOrderProperty()
Visual C++
public:
CustomerOrderProperty()
JavaScript
InSite.Model.CustomerOrderProperty = function();

See Also

CustomerOrderProperty Class
CustomerOrderProperty Overload
InSite.Model Namespace


CustomerOrderProperty Constructor (SearchMode)

[image]

.NET Framework Class Library
CustomerOrderProperty Constructor (SearchMode)
CustomerOrderProperty Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CustomerOrderProperty(
    SearchMode searchMode
)
Visual C++
public:
CustomerOrderProperty(
    SearchMode searchMode
)
JavaScript
InSite.Model.CustomerOrderProperty = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CustomerOrderProperty Class
CustomerOrderProperty Overload
InSite.Model Namespace


CustomerOrderProperty Fields

[image] [image]

.NET Framework Class Library
CustomerOrderProperty Fields
CustomerOrderProperty Class See Also Send Feedback

The CustomerOrderProperty type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerOrderProperty Class
InSite.Model Namespace


CustomerOrderProperty Methods

[image] [image]

.NET Framework Class Library
CustomerOrderProperty Methods
CustomerOrderProperty Class See Also Send Feedback

The CustomerOrderProperty type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerOrderProperty Class
InSite.Model Namespace


CustomerOrderProperty Properties

[image] [image]

.NET Framework Class Library
CustomerOrderProperty Properties
CustomerOrderProperty Class See Also Send Feedback

The CustomerOrderProperty type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrder |
CustomerOrderPropertyId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerOrderProperty Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
CustomerOrderProperty..::.CustomerOrder Property
CustomerOrderProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

CustomerOrderProperty Class
InSite.Model Namespace


CustomerOrderPropertyId Property

[image]

.NET Framework Class Library
CustomerOrderProperty..::.CustomerOrderPropertyId Property
CustomerOrderProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrderPropertyId As Guid
C#
public virtual Guid CustomerOrderPropertyId { get; set; }
Visual C++
public:
virtual property Guid CustomerOrderPropertyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_customerOrderPropertyId();
function set_customerOrderPropertyId(value);

See Also

CustomerOrderProperty Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CustomerOrderProperty..::.Name Property
CustomerOrderProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CustomerOrderProperty Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
CustomerOrderProperty..::.Value Property
CustomerOrderProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Value As String
C#
public virtual string Value { get; set; }
Visual C++
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

CustomerOrderProperty Class
InSite.Model Namespace


CustomerProduct Class

[image]

.NET Framework Class Library
CustomerProduct Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CustomerProduct _
    Inherits ModelBase(Of CustomerProduct)
C#
[SerializableAttribute]
public class CustomerProduct : ModelBase<CustomerProduct>
Visual C++
[SerializableAttribute]
public ref class CustomerProduct : public ModelBase<CustomerProduct^>
JavaScript
InSite.Model.CustomerProduct = function();

Type.createClass(
    'InSite.Model.CustomerProduct',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CustomerProduct>)>)
InSite.Model..::.CustomerProduct

See Also

CustomerProduct Members
InSite.Model Namespace


CustomerProduct Members

[image] [image]

.NET Framework Class Library
CustomerProduct Members
CustomerProduct Class Constructors Methods Fields Properties See Also Send Feedback

The CustomerProduct type exposes the following members.

Constructors

Name | Description
CustomerProduct | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerProductId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProduct Class
InSite.Model Namespace


CustomerProduct Constructor

[image] [image]

.NET Framework Class Library
CustomerProduct Constructor
CustomerProduct Class See Also Send Feedback

Overload List

Name | Description
CustomerProduct()()() |
CustomerProduct(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CustomerProduct Class
CustomerProduct Members
InSite.Model Namespace


CustomerProduct Constructor

[image]

.NET Framework Class Library
CustomerProduct Constructor
CustomerProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerProduct()
Visual C++
public:
CustomerProduct()
JavaScript
InSite.Model.CustomerProduct = function();

See Also

CustomerProduct Class
CustomerProduct Overload
InSite.Model Namespace


CustomerProduct Constructor (SearchMode)

[image]

.NET Framework Class Library
CustomerProduct Constructor (SearchMode)
CustomerProduct Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CustomerProduct(
    SearchMode searchMode
)
Visual C++
public:
CustomerProduct(
    SearchMode searchMode
)
JavaScript
InSite.Model.CustomerProduct = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CustomerProduct Class
CustomerProduct Overload
InSite.Model Namespace


CustomerProduct Fields

[image] [image]

.NET Framework Class Library
CustomerProduct Fields
CustomerProduct Class See Also Send Feedback

The CustomerProduct type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProduct Class
InSite.Model Namespace


CustomerProduct Methods

[image] [image]

.NET Framework Class Library
CustomerProduct Methods
CustomerProduct Class See Also Send Feedback

The CustomerProduct type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProduct Class
InSite.Model Namespace


CustomerProduct Properties

[image] [image]

.NET Framework Class Library
CustomerProduct Properties
CustomerProduct Class See Also Send Feedback

The CustomerProduct type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerProductId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProduct Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
CustomerProduct..::.Customer Property
CustomerProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customer As Customer
C#
public virtual Customer Customer { get; set; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

CustomerProduct Class
InSite.Model Namespace


CustomerProductId Property

[image]

.NET Framework Class Library
CustomerProduct..::.CustomerProductId Property
CustomerProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerProductId As Guid
C#
public virtual Guid CustomerProductId { get; set; }
Visual C++
public:
virtual property Guid CustomerProductId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_customerProductId();
function set_customerProductId(value);

See Also

CustomerProduct Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CustomerProduct..::.Name Property
CustomerProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CustomerProduct Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
CustomerProduct..::.Product Property
CustomerProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

CustomerProduct Class
InSite.Model Namespace


CustomerProductSet Class

[image]

.NET Framework Class Library
CustomerProductSet Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CustomerProductSet _
    Inherits ModelBase(Of CustomerProductSet)
C#
[SerializableAttribute]
public class CustomerProductSet : ModelBase<CustomerProductSet>
Visual C++
[SerializableAttribute]
public ref class CustomerProductSet : public ModelBase<CustomerProductSet^>
JavaScript
InSite.Model.CustomerProductSet = function();

Type.createClass(
    'InSite.Model.CustomerProductSet',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CustomerProductSet>)>)
InSite.Model..::.CustomerProductSet

See Also

CustomerProductSet Members
InSite.Model Namespace


CustomerProductSet Members

[image] [image]

.NET Framework Class Library
CustomerProductSet Members
CustomerProductSet Class Constructors Methods Fields Properties See Also Send Feedback

The CustomerProductSet type exposes the following members.

Constructors

Name | Description
CustomerProductSet | Overloaded.

Methods

Name | Description
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveAllProducts |
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerProductId |
CustomerProductSetId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProductSet Class
InSite.Model Namespace


CustomerProductSet Constructor

[image] [image]

.NET Framework Class Library
CustomerProductSet Constructor
CustomerProductSet Class See Also Send Feedback

Overload List

Name | Description
CustomerProductSet()()() |
CustomerProductSet(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CustomerProductSet Class
CustomerProductSet Members
InSite.Model Namespace


CustomerProductSet Constructor

[image]

.NET Framework Class Library
CustomerProductSet Constructor
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerProductSet()
Visual C++
public:
CustomerProductSet()
JavaScript
InSite.Model.CustomerProductSet = function();

See Also

CustomerProductSet Class
CustomerProductSet Overload
InSite.Model Namespace


CustomerProductSet Constructor (SearchMode)

[image]

.NET Framework Class Library
CustomerProductSet Constructor (SearchMode)
CustomerProductSet Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CustomerProductSet(
    SearchMode searchMode
)
Visual C++
public:
CustomerProductSet(
    SearchMode searchMode
)
JavaScript
InSite.Model.CustomerProductSet = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CustomerProductSet Class
CustomerProductSet Overload
InSite.Model Namespace


CustomerProductSet Fields

[image] [image]

.NET Framework Class Library
CustomerProductSet Fields
CustomerProductSet Class See Also Send Feedback

The CustomerProductSet type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProductSet Class
InSite.Model Namespace


CustomerProductSet Methods

[image] [image]

.NET Framework Class Library
CustomerProductSet Methods
CustomerProductSet Class See Also Send Feedback

The CustomerProductSet type exposes the following members.

Methods

Name | Description
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveAllProducts |
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProductSet Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
CustomerProductSet..::.AddProduct Method
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

CustomerProductSet Class
InSite.Model Namespace


RemoveAllProducts Method

[image]

.NET Framework Class Library
CustomerProductSet..::.RemoveAllProducts Method
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAllProducts
C#
public virtual void RemoveAllProducts()
Visual C++
public:
virtual void RemoveAllProducts()
JavaScript
function removeAllProducts();

See Also

CustomerProductSet Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
CustomerProductSet..::.RemoveProduct Method
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

CustomerProductSet Class
InSite.Model Namespace


CustomerProductSet Properties

[image] [image]

.NET Framework Class Library
CustomerProductSet Properties
CustomerProductSet Class See Also Send Feedback

The CustomerProductSet type exposes the following members.

Properties

Name | Description
Active |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerProductId |
CustomerProductSetId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProductSet Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
CustomerProductSet..::.Active Property
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Active As DateTime
C#
public virtual DateTime Active { get; set; }
Visual C++
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

CustomerProductSet Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
CustomerProductSet..::.Customer Property
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customer As Customer
C#
public virtual Customer Customer { get; set; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

CustomerProductSet Class
InSite.Model Namespace


CustomerProductId Property

[image]

.NET Framework Class Library
CustomerProductSet..::.CustomerProductId Property
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerProductId As Guid
C#
public virtual Guid CustomerProductId { get; set; }
Visual C++
public:
virtual property Guid CustomerProductId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_customerProductId();
function set_customerProductId(value);

See Also

CustomerProductSet Class
InSite.Model Namespace


CustomerProductSetId Property

[image]

.NET Framework Class Library
CustomerProductSet..::.CustomerProductSetId Property
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerProductSetId As Guid
C#
public virtual Guid CustomerProductSetId { get; set; }
Visual C++
public:
virtual property Guid CustomerProductSetId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_customerProductSetId();
function set_customerProductSetId(value);

See Also

CustomerProductSet Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
CustomerProductSet..::.Deactivate Property
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

CustomerProductSet Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
CustomerProductSet..::.Description Property
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Description As String
C#
public virtual string Description { get; set; }
Visual C++
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

CustomerProductSet Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CustomerProductSet..::.Name Property
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CustomerProductSet Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
CustomerProductSet..::.Products Property
CustomerProductSet Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Products As ChildList(Of Product)
C#
public virtual ChildList<Product> Products { get; private set; }
Visual C++
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

CustomerProductSet Class
InSite.Model Namespace


CustomerProperty Class

[image]

.NET Framework Class Library
CustomerProperty Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class CustomerProperty _
    Inherits ModelBase(Of CustomerProperty)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class CustomerProperty : ModelBase<CustomerProperty>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class CustomerProperty : public ModelBase<CustomerProperty^>
JavaScript
InSite.Model.CustomerProperty = function();

Type.createClass(
    'InSite.Model.CustomerProperty',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(CustomerProperty>)>)
InSite.Model..::.CustomerProperty

See Also

CustomerProperty Members
InSite.Model Namespace


CustomerProperty Members

[image] [image]

.NET Framework Class Library
CustomerProperty Members
CustomerProperty Class Constructors Methods Fields Properties See Also Send Feedback

The CustomerProperty type exposes the following members.

Constructors

Name | Description
CustomerProperty | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ModelBase<(Of <(T>)>)..::.GetHashCode()()().)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerPropertyId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProperty Class
InSite.Model Namespace


CustomerProperty Constructor

[image] [image]

.NET Framework Class Library
CustomerProperty Constructor
CustomerProperty Class See Also Send Feedback

Overload List

Name | Description
CustomerProperty()()() |
CustomerProperty(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

CustomerProperty Class
CustomerProperty Members
InSite.Model Namespace


CustomerProperty Constructor

[image]

.NET Framework Class Library
CustomerProperty Constructor
CustomerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public CustomerProperty()
Visual C++
public:
CustomerProperty()
JavaScript
InSite.Model.CustomerProperty = function();

See Also

CustomerProperty Class
CustomerProperty Overload
InSite.Model Namespace


CustomerProperty Constructor (SearchMode)

[image]

.NET Framework Class Library
CustomerProperty Constructor (SearchMode)
CustomerProperty Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public CustomerProperty(
    SearchMode searchMode
)
Visual C++
public:
CustomerProperty(
    SearchMode searchMode
)
JavaScript
InSite.Model.CustomerProperty = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

CustomerProperty Class
CustomerProperty Overload
InSite.Model Namespace


CustomerProperty Fields

[image] [image]

.NET Framework Class Library
CustomerProperty Fields
CustomerProperty Class See Also Send Feedback

The CustomerProperty type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProperty Class
InSite.Model Namespace


CustomerProperty Methods

[image] [image]

.NET Framework Class Library
CustomerProperty Methods
CustomerProperty Class See Also Send Feedback

The CustomerProperty type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ModelBase<(Of <(T>)>)..::.GetHashCode()()().)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProperty Class
InSite.Model Namespace


GetHashCode Method

[image]

.NET Framework Class Library
CustomerProperty..::.GetHashCode Method
CustomerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

See Also

CustomerProperty Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
CustomerProperty..::.ToString Method
CustomerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

CustomerProperty Class
InSite.Model Namespace


CustomerProperty Properties

[image] [image]

.NET Framework Class Library
CustomerProperty Properties
CustomerProperty Class See Also Send Feedback

The CustomerProperty type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerPropertyId |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

CustomerProperty Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
CustomerProperty..::.Customer Property
CustomerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customer As Customer
C#
public virtual Customer Customer { get; set; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

CustomerProperty Class
InSite.Model Namespace


CustomerPropertyId Property

[image]

.NET Framework Class Library
CustomerProperty..::.CustomerPropertyId Property
CustomerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerPropertyId As Guid
C#
public virtual Guid CustomerPropertyId { get; set; }
Visual C++
public:
virtual property Guid CustomerPropertyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_customerPropertyId();
function set_customerPropertyId(value);

See Also

CustomerProperty Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
CustomerProperty..::.Name Property
CustomerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

CustomerProperty Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
CustomerProperty..::.Value Property
CustomerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

CustomerProperty Class
InSite.Model Namespace


DataStoreSingleton Class

[image]

.NET Framework Class Library
DataStoreSingleton Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class DataStoreSingleton
C#
public class DataStoreSingleton
Visual C++
public ref class DataStoreSingleton
JavaScript
InSite.Model.DataStoreSingleton = function();

Type.createClass(
    'InSite.Model.DataStoreSingleton');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.DataStoreSingleton

See Also

DataStoreSingleton Members
InSite.Model Namespace


DataStoreSingleton Members

[image] [image]

.NET Framework Class Library
DataStoreSingleton Members
DataStoreSingleton Class Constructors Methods Properties See Also Send Feedback

The DataStoreSingleton type exposes the following members.

Constructors

Name | Description
DataStoreSingleton |

Methods

Name | Description
CreateConfigDataSetSchema | Returns a DataSet with the standard Configuration Schema used in Product and Category
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetApplicationSetting | Gets an ApplicationSetting.Value for the name, if one doesn't exist, it is created
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPluginList |
GetSortedProperties | GetSortedProperties - Returns a SortedDictionary of the properties for the type given
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWindsorComponent | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RegenerateApplicationDictionaries | RegenerateApplicationDictionaries - Creates new and updates existing ApplicationDictionaries to match the Object Model in a non-destructive way (ie, it doesn't overwrite or delete anything the user has entered)
SetApplicationSetting | Sets an ApplicationSetting
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApplicationSettings |
BatchUpdate | BatchUpdate mode to turn off (BatchUpdate equals true) automatic processing like Shipping Calculation and Promotions, default is BatchUpdate equals false
BuildEmailValues |
Countries |
CurrentCustomer | CurrentCustomer is session based, but support a setter and using the private member for unit testing
CurrentCustomerOrder | CurrentCustomerOrder is session based, but support a setter and using the private member for unit testing
CurrentUserProfile | UserProfile is session based, but support a setter and using the private member for unit testing
CurrentWebSite | CurrentWebSite is session based, but supports a setter and using the private member for unit testing
CustomerOrderProcessor | CustomerOrderProcessor configured for this application
DataController | DataController configured for this application
EmailProcessor |
HasSession |
LocalTaxRates |
OrderPackager | OrderPackager configured for this application
PaymentGateway | PaymentGateway configured for this application
PriceCalculator | PriceCalculator configured for this application
PromotionEngine | PromotionEngine configured for this application
ShippingEngine | ShippingEngine configured for this application
ShoppingCartRetentionDays | ShoppingCartRetentionDays - Number of days to retain shopping cart
States |
TaxCalculator | TaxCalculator configured for this application

See Also

DataStoreSingleton Class
InSite.Model Namespace


DataStoreSingleton Constructor

[image]

.NET Framework Class Library
DataStoreSingleton Constructor
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DataStoreSingleton()
Visual C++
public:
DataStoreSingleton()
JavaScript
InSite.Model.DataStoreSingleton = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


DataStoreSingleton Methods

[image] [image]

.NET Framework Class Library
DataStoreSingleton Methods
DataStoreSingleton Class See Also Send Feedback

The DataStoreSingleton type exposes the following members.

Methods

Name | Description
CreateConfigDataSetSchema | Returns a DataSet with the standard Configuration Schema used in Product and Category
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetApplicationSetting | Gets an ApplicationSetting.Value for the name, if one doesn't exist, it is created
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPluginList |
GetSortedProperties | GetSortedProperties - Returns a SortedDictionary of the properties for the type given
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWindsorComponent | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RegenerateApplicationDictionaries | RegenerateApplicationDictionaries - Creates new and updates existing ApplicationDictionaries to match the Object Model in a non-destructive way (ie, it doesn't overwrite or delete anything the user has entered)
SetApplicationSetting | Sets an ApplicationSetting
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataStoreSingleton Class
InSite.Model Namespace


CreateConfigDataSetSchema Method

[image]

.NET Framework Class Library
DataStoreSingleton..::.CreateConfigDataSetSchema Method
DataStoreSingleton Class See Also Send Feedback

Returns a DataSet with the standard Configuration Schema used in Product and Category

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateConfigDataSetSchema As DataSet
C#
public static DataSet CreateConfigDataSetSchema()
Visual C++
public:
static DataSet^ CreateConfigDataSetSchema()
JavaScript
InSite.Model.DataStoreSingleton.createConfigDataSetSchema = function();

Return Value

See Also

DataStoreSingleton Class
InSite.Model Namespace


GetApplicationSetting Method

[image]

.NET Framework Class Library
DataStoreSingleton..::.GetApplicationSetting Method
DataStoreSingleton Class See Also Send Feedback

Gets an ApplicationSetting.Value for the name, if one doesn't exist, it is created

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetApplicationSetting ( _
    name As String, _
    defaultValue As String _
) As String
C#
public static string GetApplicationSetting(
    string name,
    string defaultValue
)
Visual C++
public:
static String^ GetApplicationSetting(
    String^ name,
    String^ defaultValue
)
JavaScript
InSite.Model.DataStoreSingleton.getApplicationSetting = function(name, defaultValue);

Parameters

name
Type: System..::.String
defaultValue
Type: System..::.String

Return Value

See Also

DataStoreSingleton Class
InSite.Model Namespace


GetPluginList Method

[image]

.NET Framework Class Library
DataStoreSingleton..::.GetPluginList Method
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetPluginList As DataTable
C#
public static DataTable GetPluginList()
Visual C++
public:
static DataTable^ GetPluginList()
JavaScript
InSite.Model.DataStoreSingleton.getPluginList = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


GetSortedProperties Method

[image]

.NET Framework Class Library
DataStoreSingleton..::.GetSortedProperties Method
DataStoreSingleton Class See Also Send Feedback

GetSortedProperties - Returns a SortedDictionary of the properties for the type given

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetSortedProperties ( _
    type As Type _
) As SortedDictionary(Of String, PropertyInfo)
C#
public static SortedDictionary<string, PropertyInfo> GetSortedProperties(
    Type type
)
Visual C++
public:
static SortedDictionary<String^, PropertyInfo^>^ GetSortedProperties(
    Type^ type
)
JavaScript
InSite.Model.DataStoreSingleton.getSortedProperties = function(type);

Parameters

type
Type: System..::.Type

Return Value

See Also

DataStoreSingleton Class
InSite.Model Namespace


GetWindsorComponent Method

[image] [image]

.NET Framework Class Library
DataStoreSingleton..::.GetWindsorComponent Method
DataStoreSingleton Class See Also Send Feedback

Overload List

Name | Description
GetWindsorComponent(String) |
GetWindsorComponent(Type) |

See Also

DataStoreSingleton Class
DataStoreSingleton Members
InSite.Model Namespace


GetWindsorComponent Method (String)

[image]

.NET Framework Class Library
DataStoreSingleton..::.GetWindsorComponent Method (String)
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetWindsorComponent ( _
    key As String _
) As Object
C#
public static Object GetWindsorComponent(
    string key
)
Visual C++
public:
static Object^ GetWindsorComponent(
    String^ key
)
JavaScript
InSite.Model.DataStoreSingleton.getWindsorComponent = function(key);

Parameters

key
Type: System..::.String

See Also

DataStoreSingleton Class
GetWindsorComponent Overload
InSite.Model Namespace


GetWindsorComponent Method (Type)

[image]

.NET Framework Class Library
DataStoreSingleton..::.GetWindsorComponent Method (Type)
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetWindsorComponent ( _
    type As Type _
) As Object
C#
public static Object GetWindsorComponent(
    Type type
)
Visual C++
public:
static Object^ GetWindsorComponent(
    Type^ type
)
JavaScript
InSite.Model.DataStoreSingleton.getWindsorComponent = function(type);

Parameters

type
Type: System..::.Type

See Also

DataStoreSingleton Class
GetWindsorComponent Overload
InSite.Model Namespace


RegenerateApplicationDictionaries Method

[image]

.NET Framework Class Library
DataStoreSingleton..::.RegenerateApplicationDictionaries Method
DataStoreSingleton Class See Also Send Feedback

RegenerateApplicationDictionaries - Creates new and updates existing ApplicationDictionaries to match the Object Model in a non-destructive way (ie, it doesn't overwrite or delete anything the user has entered)

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub RegenerateApplicationDictionaries
C#
public static void RegenerateApplicationDictionaries()
Visual C++
public:
static void RegenerateApplicationDictionaries()
JavaScript
InSite.Model.DataStoreSingleton.regenerateApplicationDictionaries = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


SetApplicationSetting Method

[image]

.NET Framework Class Library
DataStoreSingleton..::.SetApplicationSetting Method
DataStoreSingleton Class See Also Send Feedback

Sets an ApplicationSetting

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetApplicationSetting ( _
    name As String, _
    value As String _
)
C#
public static void SetApplicationSetting(
    string name,
    string value
)
Visual C++
public:
static void SetApplicationSetting(
    String^ name,
    String^ value
)
JavaScript
InSite.Model.DataStoreSingleton.setApplicationSetting = function(name, value);

Parameters

name
Type: System..::.String
value
Type: System..::.String

Return Value

See Also

DataStoreSingleton Class
InSite.Model Namespace


DataStoreSingleton Properties

[image] [image]

.NET Framework Class Library
DataStoreSingleton Properties
DataStoreSingleton Class See Also Send Feedback

The DataStoreSingleton type exposes the following members.

Properties

Name | Description
ApplicationSettings |
BatchUpdate | BatchUpdate mode to turn off (BatchUpdate equals true) automatic processing like Shipping Calculation and Promotions, default is BatchUpdate equals false
BuildEmailValues |
Countries |
CurrentCustomer | CurrentCustomer is session based, but support a setter and using the private member for unit testing
CurrentCustomerOrder | CurrentCustomerOrder is session based, but support a setter and using the private member for unit testing
CurrentUserProfile | UserProfile is session based, but support a setter and using the private member for unit testing
CurrentWebSite | CurrentWebSite is session based, but supports a setter and using the private member for unit testing
CustomerOrderProcessor | CustomerOrderProcessor configured for this application
DataController | DataController configured for this application
EmailProcessor |
HasSession |
LocalTaxRates |
OrderPackager | OrderPackager configured for this application
PaymentGateway | PaymentGateway configured for this application
PriceCalculator | PriceCalculator configured for this application
PromotionEngine | PromotionEngine configured for this application
ShippingEngine | ShippingEngine configured for this application
ShoppingCartRetentionDays | ShoppingCartRetentionDays - Number of days to retain shopping cart
States |
TaxCalculator | TaxCalculator configured for this application

See Also

DataStoreSingleton Class
InSite.Model Namespace


ApplicationSettings Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.ApplicationSettings Property
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property ApplicationSettings As IList(Of ApplicationSetting)
C#
public static IList<ApplicationSetting> ApplicationSettings { get; set; }
Visual C++
public:
static property IList<ApplicationSetting^>^ ApplicationSettings {
    IList<ApplicationSetting^>^ get ();
    void set (IList<ApplicationSetting^>^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_applicationSettings = function();
InSite.Model.DataStoreSingleton.set_applicationSettings = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


BatchUpdate Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.BatchUpdate Property
DataStoreSingleton Class See Also Send Feedback

BatchUpdate mode to turn off (BatchUpdate equals true) automatic processing like Shipping Calculation and Promotions, default is BatchUpdate equals false

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property BatchUpdate As Boolean
C#
public static bool BatchUpdate { get; set; }
Visual C++
public:
static property bool BatchUpdate {
    bool get ();
    void set (bool value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_batchUpdate = function();
InSite.Model.DataStoreSingleton.set_batchUpdate = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


BuildEmailValues Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.BuildEmailValues Property
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property BuildEmailValues As IBuildEmailValues
C#
public static IBuildEmailValues BuildEmailValues { get; }
Visual C++
public:
static property IBuildEmailValues^ BuildEmailValues {
    IBuildEmailValues^ get ();
}
JavaScript
InSite.Model.DataStoreSingleton.get_buildEmailValues = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


Countries Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.Countries Property
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Countries As IList(Of Country)
C#
public static IList<Country> Countries { get; }
Visual C++
public:
static property IList<Country^>^ Countries {
    IList<Country^>^ get ();
}
JavaScript
InSite.Model.DataStoreSingleton.get_countries = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


CurrentCustomer Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.CurrentCustomer Property
DataStoreSingleton Class See Also Send Feedback

CurrentCustomer is session based, but support a setter and using the private member for unit testing

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property CurrentCustomer As Customer
C#
public static Customer CurrentCustomer { get; set; }
Visual C++
public:
static property Customer^ CurrentCustomer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_currentCustomer = function();
InSite.Model.DataStoreSingleton.set_currentCustomer = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


CurrentCustomerOrder Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.CurrentCustomerOrder Property
DataStoreSingleton Class See Also Send Feedback

CurrentCustomerOrder is session based, but support a setter and using the private member for unit testing

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property CurrentCustomerOrder As CustomerOrder
C#
public static CustomerOrder CurrentCustomerOrder { get; set; }
Visual C++
public:
static property CustomerOrder^ CurrentCustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_currentCustomerOrder = function();
InSite.Model.DataStoreSingleton.set_currentCustomerOrder = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


CurrentUserProfile Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.CurrentUserProfile Property
DataStoreSingleton Class See Also Send Feedback

UserProfile is session based, but support a setter and using the private member for unit testing

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property CurrentUserProfile As UserProfile
C#
public static UserProfile CurrentUserProfile { get; set; }
Visual C++
public:
static property UserProfile^ CurrentUserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_currentUserProfile = function();
InSite.Model.DataStoreSingleton.set_currentUserProfile = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


CurrentWebSite Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.CurrentWebSite Property
DataStoreSingleton Class See Also Send Feedback

CurrentWebSite is session based, but supports a setter and using the private member for unit testing

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property CurrentWebSite As WebSite
C#
public static WebSite CurrentWebSite { get; set; }
Visual C++
public:
static property WebSite^ CurrentWebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_currentWebSite = function();
InSite.Model.DataStoreSingleton.set_currentWebSite = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


CustomerOrderProcessor Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.CustomerOrderProcessor Property
DataStoreSingleton Class See Also Send Feedback

CustomerOrderProcessor configured for this application

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property CustomerOrderProcessor As ICustomerOrderProcessor
C#
public static ICustomerOrderProcessor CustomerOrderProcessor { get; set; }
Visual C++
public:
static property ICustomerOrderProcessor^ CustomerOrderProcessor {
    ICustomerOrderProcessor^ get ();
    void set (ICustomerOrderProcessor^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_customerOrderProcessor = function();
InSite.Model.DataStoreSingleton.set_customerOrderProcessor = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


DataController Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.DataController Property
DataStoreSingleton Class See Also Send Feedback

DataController configured for this application

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property DataController As IDataController
C#
public static IDataController DataController { get; set; }
Visual C++
public:
static property IDataController^ DataController {
    IDataController^ get ();
    void set (IDataController^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_dataController = function();
InSite.Model.DataStoreSingleton.set_dataController = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


EmailProcessor Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.EmailProcessor Property
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property EmailProcessor As IEmailProcessor
C#
public static IEmailProcessor EmailProcessor { get; }
Visual C++
public:
static property IEmailProcessor^ EmailProcessor {
    IEmailProcessor^ get ();
}
JavaScript
InSite.Model.DataStoreSingleton.get_emailProcessor = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


HasSession Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.HasSession Property
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property HasSession As Boolean
C#
public static bool HasSession { get; }
Visual C++
public:
static property bool HasSession {
    bool get ();
}
JavaScript
InSite.Model.DataStoreSingleton.get_hasSession = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


LocalTaxRates Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.LocalTaxRates Property
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property LocalTaxRates As IList(Of LocalTaxRate)
C#
public static IList<LocalTaxRate> LocalTaxRates { get; }
Visual C++
public:
static property IList<LocalTaxRate^>^ LocalTaxRates {
    IList<LocalTaxRate^>^ get ();
}
JavaScript
InSite.Model.DataStoreSingleton.get_localTaxRates = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


OrderPackager Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.OrderPackager Property
DataStoreSingleton Class See Also Send Feedback

OrderPackager configured for this application

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property OrderPackager As IOrderPackager
C#
public static IOrderPackager OrderPackager { get; set; }
Visual C++
public:
static property IOrderPackager^ OrderPackager {
    IOrderPackager^ get ();
    void set (IOrderPackager^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_orderPackager = function();
InSite.Model.DataStoreSingleton.set_orderPackager = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


PaymentGateway Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.PaymentGateway Property
DataStoreSingleton Class See Also Send Feedback

PaymentGateway configured for this application

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property PaymentGateway As IPaymentGateway
C#
public static IPaymentGateway PaymentGateway { get; set; }
Visual C++
public:
static property IPaymentGateway^ PaymentGateway {
    IPaymentGateway^ get ();
    void set (IPaymentGateway^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_paymentGateway = function();
InSite.Model.DataStoreSingleton.set_paymentGateway = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


PriceCalculator Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.PriceCalculator Property
DataStoreSingleton Class See Also Send Feedback

PriceCalculator configured for this application

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property PriceCalculator As IPriceCalculator
C#
public static IPriceCalculator PriceCalculator { get; set; }
Visual C++
public:
static property IPriceCalculator^ PriceCalculator {
    IPriceCalculator^ get ();
    void set (IPriceCalculator^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_priceCalculator = function();
InSite.Model.DataStoreSingleton.set_priceCalculator = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


PromotionEngine Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.PromotionEngine Property
DataStoreSingleton Class See Also Send Feedback

PromotionEngine configured for this application

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property PromotionEngine As IPromotionEngine
C#
public static IPromotionEngine PromotionEngine { get; set; }
Visual C++
public:
static property IPromotionEngine^ PromotionEngine {
    IPromotionEngine^ get ();
    void set (IPromotionEngine^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_promotionEngine = function();
InSite.Model.DataStoreSingleton.set_promotionEngine = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


ShippingEngine Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.ShippingEngine Property
DataStoreSingleton Class See Also Send Feedback

ShippingEngine configured for this application

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property ShippingEngine As IShippingEngine
C#
public static IShippingEngine ShippingEngine { get; set; }
Visual C++
public:
static property IShippingEngine^ ShippingEngine {
    IShippingEngine^ get ();
    void set (IShippingEngine^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_shippingEngine = function();
InSite.Model.DataStoreSingleton.set_shippingEngine = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


ShoppingCartRetentionDays Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.ShoppingCartRetentionDays Property
DataStoreSingleton Class See Also Send Feedback

ShoppingCartRetentionDays - Number of days to retain shopping cart

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ShoppingCartRetentionDays As Integer
C#
public static int ShoppingCartRetentionDays { get; }
Visual C++
public:
static property int ShoppingCartRetentionDays {
    int get ();
}
JavaScript
InSite.Model.DataStoreSingleton.get_shoppingCartRetentionDays = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


States Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.States Property
DataStoreSingleton Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property States As IList(Of State)
C#
public static IList<State> States { get; }
Visual C++
public:
static property IList<State^>^ States {
    IList<State^>^ get ();
}
JavaScript
InSite.Model.DataStoreSingleton.get_states = function();

See Also

DataStoreSingleton Class
InSite.Model Namespace


TaxCalculator Property

[image]

.NET Framework Class Library
DataStoreSingleton..::.TaxCalculator Property
DataStoreSingleton Class See Also Send Feedback

TaxCalculator configured for this application

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property TaxCalculator As ITaxCalculator
C#
public static ITaxCalculator TaxCalculator { get; set; }
Visual C++
public:
static property ITaxCalculator^ TaxCalculator {
    ITaxCalculator^ get ();
    void set (ITaxCalculator^ value);
}
JavaScript
InSite.Model.DataStoreSingleton.get_taxCalculator = function();
InSite.Model.DataStoreSingleton.set_taxCalculator = function(value);

See Also

DataStoreSingleton Class
InSite.Model Namespace


Dealer Class

[image]

.NET Framework Class Library
Dealer Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Dealer _
    Inherits ModelBase(Of Dealer)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Dealer : ModelBase<Dealer>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Dealer : public ModelBase<Dealer^>
JavaScript
InSite.Model.Dealer = function();

Type.createClass(
    'InSite.Model.Dealer',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Dealer>)>)
InSite.Model..::.Dealer

See Also

Dealer Members
InSite.Model Namespace


Dealer Members

[image] [image]

.NET Framework Class Library
Dealer Members
Dealer Class Constructors Methods Fields Properties See Also Send Feedback

The Dealer type exposes the following members.

Constructors

Name | Description
Dealer | Overloaded.

Methods

Name | Description
AddCategory |
AddDealerProperty |
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDealerProperty |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategory |
RemoveDealerProperty |
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Address1 |
Address2 |
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
City |
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DealerCountry |
DealerId |
DealerProperties |
Fax1 |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Latitude |
Longitude |
Manager |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Phone1 |
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WebSiteUrl |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

Dealer Class
InSite.Model Namespace


Dealer Constructor

[image] [image]

.NET Framework Class Library
Dealer Constructor
Dealer Class See Also Send Feedback

Overload List

Name | Description
Dealer()()() |
Dealer(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Dealer Class
Dealer Members
InSite.Model Namespace


Dealer Constructor

[image]

.NET Framework Class Library
Dealer Constructor
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Dealer()
Visual C++
public:
Dealer()
JavaScript
InSite.Model.Dealer = function();

See Also

Dealer Class
Dealer Overload
InSite.Model Namespace


Dealer Constructor (SearchMode)

[image]

.NET Framework Class Library
Dealer Constructor (SearchMode)
Dealer Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Dealer(
    SearchMode searchMode
)
Visual C++
public:
Dealer(
    SearchMode searchMode
)
JavaScript
InSite.Model.Dealer = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Dealer Class
Dealer Overload
InSite.Model Namespace


Dealer Fields

[image] [image]

.NET Framework Class Library
Dealer Fields
Dealer Class See Also Send Feedback

The Dealer type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Dealer Class
InSite.Model Namespace


Dealer Methods

[image] [image]

.NET Framework Class Library
Dealer Methods
Dealer Class See Also Send Feedback

The Dealer type exposes the following members.

Methods

Name | Description
AddCategory |
AddDealerProperty |
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDealerProperty |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategory |
RemoveDealerProperty |
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Dealer Class
InSite.Model Namespace


AddCategory Method

[image]

.NET Framework Class Library
Dealer..::.AddCategory Method
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategory ( _
    value As Category _
)
C#
public virtual void AddCategory(
    Category value
)
Visual C++
public:
virtual void AddCategory(
    Category^ value
)
JavaScript
function addCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

Dealer Class
InSite.Model Namespace


AddDealerProperty Method

[image]

.NET Framework Class Library
Dealer..::.AddDealerProperty Method
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddDealerProperty ( _
    value As DealerProperty _
)
C#
public virtual void AddDealerProperty(
    DealerProperty value
)
Visual C++
public:
virtual void AddDealerProperty(
    DealerProperty^ value
)
JavaScript
function addDealerProperty(value);

Parameters

value
Type: InSite.Model..::.DealerProperty

See Also

Dealer Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
Dealer..::.AddProduct Method
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Dealer Class
InSite.Model Namespace


GetDealerProperty Method

[image]

.NET Framework Class Library
Dealer..::.GetDealerProperty Method
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetDealerProperty ( _
    name As String _
) As DealerProperty
C#
public virtual DealerProperty GetDealerProperty(
    string name
)
Visual C++
public:
virtual DealerProperty^ GetDealerProperty(
    String^ name
)
JavaScript
function getDealerProperty(name);

Parameters

name
Type: System..::.String

See Also

Dealer Class
InSite.Model Namespace


RemoveCategory Method

[image]

.NET Framework Class Library
Dealer..::.RemoveCategory Method
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategory ( _
    value As Category _
)
C#
public virtual void RemoveCategory(
    Category value
)
Visual C++
public:
virtual void RemoveCategory(
    Category^ value
)
JavaScript
function removeCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

Dealer Class
InSite.Model Namespace


RemoveDealerProperty Method

[image]

.NET Framework Class Library
Dealer..::.RemoveDealerProperty Method
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveDealerProperty ( _
    value As DealerProperty _
)
C#
public virtual void RemoveDealerProperty(
    DealerProperty value
)
Visual C++
public:
virtual void RemoveDealerProperty(
    DealerProperty^ value
)
JavaScript
function removeDealerProperty(value);

Parameters

value
Type: InSite.Model..::.DealerProperty

See Also

Dealer Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
Dealer..::.RemoveProduct Method
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Dealer Class
InSite.Model Namespace


Dealer Properties

[image] [image]

.NET Framework Class Library
Dealer Properties
Dealer Class See Also Send Feedback

The Dealer type exposes the following members.

Properties

Name | Description
Address1 |
Address2 |
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
City |
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DealerCountry |
DealerId |
DealerProperties |
Fax1 |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Latitude |
Longitude |
Manager |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Phone1 |
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WebSiteUrl |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

Dealer Class
InSite.Model Namespace


Address1 Property

[image]

.NET Framework Class Library
Dealer..::.Address1 Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address1 As String
C#
[DataMemberAttribute]
public virtual string Address1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address1();
function set_address1(value);

See Also

Dealer Class
InSite.Model Namespace


Address2 Property

[image]

.NET Framework Class Library
Dealer..::.Address2 Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address2 As String
C#
[DataMemberAttribute]
public virtual string Address2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address2();
function set_address2(value);

See Also

Dealer Class
InSite.Model Namespace


Categories Property

[image]

.NET Framework Class Library
Dealer..::.Categories Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Categories As ChildList(Of Category)
C#
[DataMemberAttribute]
public virtual ChildList<Category> Categories { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Category^>^ Categories {
    ChildList<Category^>^ get ();
    void set (ChildList<Category^>^ value);
}
JavaScript
function get_categories();
function set_categories(value);

See Also

Dealer Class
InSite.Model Namespace


City Property

[image]

.NET Framework Class Library
Dealer..::.City Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property City As String
C#
[DataMemberAttribute]
public virtual string City { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ City {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

See Also

Dealer Class
InSite.Model Namespace


Country Property

[image]

.NET Framework Class Library
Dealer..::.Country Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Country As String
C#
[DataMemberAttribute]
public virtual string Country { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

Dealer Class
InSite.Model Namespace


DealerCountry Property

[image]

.NET Framework Class Library
Dealer..::.DealerCountry Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DealerCountry As Country
C#
[DataMemberAttribute]
public virtual Country DealerCountry { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Country^ DealerCountry {
    Country^ get ();
    void set (Country^ value);
}
JavaScript
function get_dealerCountry();
function set_dealerCountry(value);

See Also

Dealer Class
InSite.Model Namespace


DealerId Property

[image]

.NET Framework Class Library
Dealer..::.DealerId Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DealerId As Guid
C#
public virtual Guid DealerId { get; set; }
Visual C++
public:
virtual property Guid DealerId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_dealerId();
function set_dealerId(value);

See Also

Dealer Class
InSite.Model Namespace


DealerProperties Property

[image]

.NET Framework Class Library
Dealer..::.DealerProperties Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DealerProperties As ChildList(Of DealerProperty)
C#
[DataMemberAttribute]
public virtual ChildList<DealerProperty> DealerProperties { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<DealerProperty^>^ DealerProperties {
    ChildList<DealerProperty^>^ get ();
    void set (ChildList<DealerProperty^>^ value);
}
JavaScript
function get_dealerProperties();
function set_dealerProperties(value);

See Also

Dealer Class
InSite.Model Namespace


Fax1 Property

[image]

.NET Framework Class Library
Dealer..::.Fax1 Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Fax1 As String
C#
[DataMemberAttribute]
public virtual string Fax1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Fax1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fax1();
function set_fax1(value);

See Also

Dealer Class
InSite.Model Namespace


Latitude Property

[image]

.NET Framework Class Library
Dealer..::.Latitude Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Latitude As Decimal
C#
[DataMemberAttribute]
public virtual decimal Latitude { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Latitude {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_latitude();
function set_latitude(value);

See Also

Dealer Class
InSite.Model Namespace


Longitude Property

[image]

.NET Framework Class Library
Dealer..::.Longitude Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Longitude As Decimal
C#
[DataMemberAttribute]
public virtual decimal Longitude { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Longitude {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_longitude();
function set_longitude(value);

See Also

Dealer Class
InSite.Model Namespace


Manager Property

[image]

.NET Framework Class Library
Dealer..::.Manager Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Manager As String
C#
[DataMemberAttribute]
public virtual string Manager { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Manager {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_manager();
function set_manager(value);

See Also

Dealer Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Dealer..::.Name Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Dealer Class
InSite.Model Namespace


Phone1 Property

[image]

.NET Framework Class Library
Dealer..::.Phone1 Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone1 As String
C#
[DataMemberAttribute]
public virtual string Phone1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone1();
function set_phone1(value);

See Also

Dealer Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
Dealer..::.Products Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Products As ChildList(Of Product)
C#
[DataMemberAttribute]
public virtual ChildList<Product> Products { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

Dealer Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
Dealer..::.State Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property State As String
C#
[DataMemberAttribute]
public virtual string State { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ State {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

Dealer Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
Dealer..::.WebSite Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

Dealer Class
InSite.Model Namespace


WebSiteUrl Property

[image]

.NET Framework Class Library
Dealer..::.WebSiteUrl Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property WebSiteUrl As String
C#
[DataMemberAttribute]
public virtual string WebSiteUrl { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ WebSiteUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_webSiteUrl();
function set_webSiteUrl(value);

See Also

Dealer Class
InSite.Model Namespace


Zip Property

[image]

.NET Framework Class Library
Dealer..::.Zip Property
Dealer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Zip As String
C#
[DataMemberAttribute]
public virtual string Zip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

See Also

Dealer Class
InSite.Model Namespace


DealerProperty Class

[image]

.NET Framework Class Library
DealerProperty Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class DealerProperty _
    Inherits ModelBase(Of DealerProperty)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class DealerProperty : ModelBase<DealerProperty>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class DealerProperty : public ModelBase<DealerProperty^>
JavaScript
InSite.Model.DealerProperty = function();

Type.createClass(
    'InSite.Model.DealerProperty',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(DealerProperty>)>)
InSite.Model..::.DealerProperty

See Also

DealerProperty Members
InSite.Model Namespace


DealerProperty Members

[image] [image]

.NET Framework Class Library
DealerProperty Members
DealerProperty Class Constructors Methods Fields Properties See Also Send Feedback

The DealerProperty type exposes the following members.

Constructors

Name | Description
DealerProperty | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Dealer |
DealerPropertyId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DealerProperty Class
InSite.Model Namespace


DealerProperty Constructor

[image] [image]

.NET Framework Class Library
DealerProperty Constructor
DealerProperty Class See Also Send Feedback

Overload List

Name | Description
DealerProperty()()() |
DealerProperty(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

DealerProperty Class
DealerProperty Members
InSite.Model Namespace


DealerProperty Constructor

[image]

.NET Framework Class Library
DealerProperty Constructor
DealerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DealerProperty()
Visual C++
public:
DealerProperty()
JavaScript
InSite.Model.DealerProperty = function();

See Also

DealerProperty Class
DealerProperty Overload
InSite.Model Namespace


DealerProperty Constructor (SearchMode)

[image]

.NET Framework Class Library
DealerProperty Constructor (SearchMode)
DealerProperty Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public DealerProperty(
    SearchMode searchMode
)
Visual C++
public:
DealerProperty(
    SearchMode searchMode
)
JavaScript
InSite.Model.DealerProperty = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

DealerProperty Class
DealerProperty Overload
InSite.Model Namespace


DealerProperty Fields

[image] [image]

.NET Framework Class Library
DealerProperty Fields
DealerProperty Class See Also Send Feedback

The DealerProperty type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DealerProperty Class
InSite.Model Namespace


DealerProperty Methods

[image] [image]

.NET Framework Class Library
DealerProperty Methods
DealerProperty Class See Also Send Feedback

The DealerProperty type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DealerProperty Class
InSite.Model Namespace


DealerProperty Properties

[image] [image]

.NET Framework Class Library
DealerProperty Properties
DealerProperty Class See Also Send Feedback

The DealerProperty type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Dealer |
DealerPropertyId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DealerProperty Class
InSite.Model Namespace


Dealer Property

[image]

.NET Framework Class Library
DealerProperty..::.Dealer Property
DealerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Dealer As Dealer
C#
public virtual Dealer Dealer { get; set; }
Visual C++
public:
virtual property Dealer^ Dealer {
    Dealer^ get ();
    void set (Dealer^ value);
}
JavaScript
function get_dealer();
function set_dealer(value);

See Also

DealerProperty Class
InSite.Model Namespace


DealerPropertyId Property

[image]

.NET Framework Class Library
DealerProperty..::.DealerPropertyId Property
DealerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DealerPropertyId As Guid
C#
public virtual Guid DealerPropertyId { get; set; }
Visual C++
public:
virtual property Guid DealerPropertyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_dealerPropertyId();
function set_dealerPropertyId(value);

See Also

DealerProperty Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
DealerProperty..::.Name Property
DealerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

DealerProperty Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
DealerProperty..::.Value Property
DealerProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

DealerProperty Class
InSite.Model Namespace


DictionaryAttribute Class

[image]

.NET Framework Class Library
DictionaryAttribute Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class DictionaryAttribute _
    Inherits ModelBase(Of DictionaryAttribute)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class DictionaryAttribute : ModelBase<DictionaryAttribute>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class DictionaryAttribute : public ModelBase<DictionaryAttribute^>
JavaScript
InSite.Model.DictionaryAttribute = function();

Type.createClass(
    'InSite.Model.DictionaryAttribute',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(DictionaryAttribute>)>)
InSite.Model..::.DictionaryAttribute

See Also

DictionaryAttribute Members
InSite.Model Namespace


DictionaryAttribute Members

[image] [image]

.NET Framework Class Library
DictionaryAttribute Members
DictionaryAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The DictionaryAttribute type exposes the following members.

Constructors

Name | Description
DictionaryAttribute | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ApplicationDictionary |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DefaultValue |
DictionaryAttributeId |
DisplayType |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IncludeInGrid |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MaximumValue |
MinimumValue |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RequiredField |
RoleName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DictionaryAttribute Class
InSite.Model Namespace


DictionaryAttribute Constructor

[image] [image]

.NET Framework Class Library
DictionaryAttribute Constructor
DictionaryAttribute Class See Also Send Feedback

Overload List

Name | Description
DictionaryAttribute()()() |
DictionaryAttribute(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

DictionaryAttribute Class
DictionaryAttribute Members
InSite.Model Namespace


DictionaryAttribute Constructor

[image]

.NET Framework Class Library
DictionaryAttribute Constructor
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DictionaryAttribute()
Visual C++
public:
DictionaryAttribute()
JavaScript
InSite.Model.DictionaryAttribute = function();

See Also

DictionaryAttribute Class
DictionaryAttribute Overload
InSite.Model Namespace


DictionaryAttribute Constructor (SearchMode)

[image]

.NET Framework Class Library
DictionaryAttribute Constructor (SearchMode)
DictionaryAttribute Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public DictionaryAttribute(
    SearchMode searchMode
)
Visual C++
public:
DictionaryAttribute(
    SearchMode searchMode
)
JavaScript
InSite.Model.DictionaryAttribute = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

DictionaryAttribute Class
DictionaryAttribute Overload
InSite.Model Namespace


DictionaryAttribute Fields

[image] [image]

.NET Framework Class Library
DictionaryAttribute Fields
DictionaryAttribute Class See Also Send Feedback

The DictionaryAttribute type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DictionaryAttribute Class
InSite.Model Namespace


DictionaryAttribute Methods

[image] [image]

.NET Framework Class Library
DictionaryAttribute Methods
DictionaryAttribute Class See Also Send Feedback

The DictionaryAttribute type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DictionaryAttribute Class
InSite.Model Namespace


DictionaryAttribute Properties

[image] [image]

.NET Framework Class Library
DictionaryAttribute Properties
DictionaryAttribute Class See Also Send Feedback

The DictionaryAttribute type exposes the following members.

Properties

Name | Description
ApplicationDictionary |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DefaultValue |
DictionaryAttributeId |
DisplayType |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IncludeInGrid |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MaximumValue |
MinimumValue |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RequiredField |
RoleName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DictionaryAttribute Class
InSite.Model Namespace


ApplicationDictionary Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.ApplicationDictionary Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ApplicationDictionary As ApplicationDictionary
C#
public virtual ApplicationDictionary ApplicationDictionary { get; set; }
Visual C++
public:
virtual property ApplicationDictionary^ ApplicationDictionary {
    ApplicationDictionary^ get ();
    void set (ApplicationDictionary^ value);
}
JavaScript
function get_applicationDictionary();
function set_applicationDictionary(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


DefaultValue Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.DefaultValue Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DefaultValue As String
C#
[DataMemberAttribute]
public virtual string DefaultValue { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DefaultValue {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_defaultValue();
function set_defaultValue(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


DictionaryAttributeId Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.DictionaryAttributeId Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DictionaryAttributeId As Guid
C#
public virtual Guid DictionaryAttributeId { get; set; }
Visual C++
public:
virtual property Guid DictionaryAttributeId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_dictionaryAttributeId();
function set_dictionaryAttributeId(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


DisplayType Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.DisplayType Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DisplayType As Integer
C#
[DataMemberAttribute]
public virtual int DisplayType { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int DisplayType {
    int get ();
    void set (int value);
}
JavaScript
function get_displayType();
function set_displayType(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


IncludeInGrid Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.IncludeInGrid Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IncludeInGrid As Boolean
C#
[DataMemberAttribute]
public virtual bool IncludeInGrid { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IncludeInGrid {
    bool get ();
    void set (bool value);
}
JavaScript
function get_includeInGrid();
function set_includeInGrid(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


MaximumValue Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.MaximumValue Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MaximumValue As String
C#
[DataMemberAttribute]
public virtual string MaximumValue { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MaximumValue {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_maximumValue();
function set_maximumValue(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


MinimumValue Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.MinimumValue Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MinimumValue As String
C#
[DataMemberAttribute]
public virtual string MinimumValue { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MinimumValue {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_minimumValue();
function set_minimumValue(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


RequiredField Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.RequiredField Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RequiredField As Boolean
C#
[DataMemberAttribute]
public virtual bool RequiredField { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool RequiredField {
    bool get ();
    void set (bool value);
}
JavaScript
function get_requiredField();
function set_requiredField(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


RoleName Property

[image]

.NET Framework Class Library
DictionaryAttribute..::.RoleName Property
DictionaryAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RoleName As String
C#
[DataMemberAttribute]
public virtual string RoleName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RoleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_roleName();
function set_roleName(value);

See Also

DictionaryAttribute Class
InSite.Model Namespace


DictionaryLabel Class

[image]

.NET Framework Class Library
DictionaryLabel Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class DictionaryLabel _
    Inherits ModelBase(Of DictionaryLabel)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class DictionaryLabel : ModelBase<DictionaryLabel>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class DictionaryLabel : public ModelBase<DictionaryLabel^>
JavaScript
InSite.Model.DictionaryLabel = function();

Type.createClass(
    'InSite.Model.DictionaryLabel',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(DictionaryLabel>)>)
InSite.Model..::.DictionaryLabel

See Also

DictionaryLabel Members
InSite.Model Namespace


DictionaryLabel Members

[image] [image]

.NET Framework Class Library
DictionaryLabel Members
DictionaryLabel Class Constructors Methods Fields Properties See Also Send Feedback

The DictionaryLabel type exposes the following members.

Constructors

Name | Description
DictionaryLabel | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ApplicationDictionary |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerLabel |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DictionaryLabelId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SystemLabel |
ToolTip |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DictionaryLabel Class
InSite.Model Namespace


DictionaryLabel Constructor

[image] [image]

.NET Framework Class Library
DictionaryLabel Constructor
DictionaryLabel Class See Also Send Feedback

Overload List

Name | Description
DictionaryLabel()()() |
DictionaryLabel(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

DictionaryLabel Class
DictionaryLabel Members
InSite.Model Namespace


DictionaryLabel Constructor

[image]

.NET Framework Class Library
DictionaryLabel Constructor
DictionaryLabel Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DictionaryLabel()
Visual C++
public:
DictionaryLabel()
JavaScript
InSite.Model.DictionaryLabel = function();

See Also

DictionaryLabel Class
DictionaryLabel Overload
InSite.Model Namespace


DictionaryLabel Constructor (SearchMode)

[image]

.NET Framework Class Library
DictionaryLabel Constructor (SearchMode)
DictionaryLabel Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public DictionaryLabel(
    SearchMode searchMode
)
Visual C++
public:
DictionaryLabel(
    SearchMode searchMode
)
JavaScript
InSite.Model.DictionaryLabel = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

DictionaryLabel Class
DictionaryLabel Overload
InSite.Model Namespace


DictionaryLabel Fields

[image] [image]

.NET Framework Class Library
DictionaryLabel Fields
DictionaryLabel Class See Also Send Feedback

The DictionaryLabel type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DictionaryLabel Class
InSite.Model Namespace


DictionaryLabel Methods

[image] [image]

.NET Framework Class Library
DictionaryLabel Methods
DictionaryLabel Class See Also Send Feedback

The DictionaryLabel type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DictionaryLabel Class
InSite.Model Namespace


DictionaryLabel Properties

[image] [image]

.NET Framework Class Library
DictionaryLabel Properties
DictionaryLabel Class See Also Send Feedback

The DictionaryLabel type exposes the following members.

Properties

Name | Description
ApplicationDictionary |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerLabel |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DictionaryLabelId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SystemLabel |
ToolTip |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DictionaryLabel Class
InSite.Model Namespace


ApplicationDictionary Property

[image]

.NET Framework Class Library
DictionaryLabel..::.ApplicationDictionary Property
DictionaryLabel Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ApplicationDictionary As ApplicationDictionary
C#
public virtual ApplicationDictionary ApplicationDictionary { get; set; }
Visual C++
public:
virtual property ApplicationDictionary^ ApplicationDictionary {
    ApplicationDictionary^ get ();
    void set (ApplicationDictionary^ value);
}
JavaScript
function get_applicationDictionary();
function set_applicationDictionary(value);

See Also

DictionaryLabel Class
InSite.Model Namespace


CustomerLabel Property

[image]

.NET Framework Class Library
DictionaryLabel..::.CustomerLabel Property
DictionaryLabel Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerLabel As String
C#
[DataMemberAttribute]
public virtual string CustomerLabel { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerLabel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerLabel();
function set_customerLabel(value);

See Also

DictionaryLabel Class
InSite.Model Namespace


DictionaryLabelId Property

[image]

.NET Framework Class Library
DictionaryLabel..::.DictionaryLabelId Property
DictionaryLabel Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DictionaryLabelId As Guid
C#
public virtual Guid DictionaryLabelId { get; set; }
Visual C++
public:
virtual property Guid DictionaryLabelId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_dictionaryLabelId();
function set_dictionaryLabelId(value);

See Also

DictionaryLabel Class
InSite.Model Namespace


LanguageCode Property

[image]

.NET Framework Class Library
DictionaryLabel..::.LanguageCode Property
DictionaryLabel Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LanguageCode As String
C#
[DataMemberAttribute]
public virtual string LanguageCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_languageCode();
function set_languageCode(value);

See Also

DictionaryLabel Class
InSite.Model Namespace


SystemLabel Property

[image]

.NET Framework Class Library
DictionaryLabel..::.SystemLabel Property
DictionaryLabel Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SystemLabel As String
C#
[DataMemberAttribute]
public virtual string SystemLabel { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SystemLabel {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_systemLabel();
function set_systemLabel(value);

See Also

DictionaryLabel Class
InSite.Model Namespace


ToolTip Property

[image]

.NET Framework Class Library
DictionaryLabel..::.ToolTip Property
DictionaryLabel Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ToolTip As String
C#
[DataMemberAttribute]
public virtual string ToolTip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_toolTip();
function set_toolTip(value);

See Also

DictionaryLabel Class
InSite.Model Namespace


DisplayType Class

[image]

.NET Framework Class Library
DisplayType Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DisplayType
C#
public sealed class DisplayType
Visual C++
public ref class DisplayType sealed
JavaScript
InSite.Model.DisplayType = function();

Type.createClass(
    'InSite.Model.DisplayType');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.DisplayType

See Also

DisplayType Members
InSite.Model Namespace


DisplayType Members

[image] [image]

.NET Framework Class Library
DisplayType Members
DisplayType Class Constructors Methods Fields See Also Send Feedback

The DisplayType type exposes the following members.

Constructors

Name | Description
DisplayType |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Enabled |
Hidden |
Visible |

See Also

DisplayType Class
InSite.Model Namespace


DisplayType Constructor

[image]

.NET Framework Class Library
DisplayType Constructor
DisplayType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DisplayType()
Visual C++
public:
DisplayType()
JavaScript
InSite.Model.DisplayType = function();

See Also

DisplayType Class
InSite.Model Namespace


DisplayType Fields

[image] [image]

.NET Framework Class Library
DisplayType Fields
DisplayType Class See Also Send Feedback

The DisplayType type exposes the following members.

Fields

Name | Description
Enabled |
Hidden |
Visible |

See Also

DisplayType Class
InSite.Model Namespace


Enabled Field

[image]

.NET Framework Class Library
DisplayType..::.Enabled Field
DisplayType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Enabled As Integer
C#
public static int Enabled
Visual C++
public:
static int Enabled
JavaScript
InSite.Model.DisplayType.enabled

See Also

DisplayType Class
InSite.Model Namespace


Hidden Field

[image]

.NET Framework Class Library
DisplayType..::.Hidden Field
DisplayType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Hidden As Integer
C#
public static int Hidden
Visual C++
public:
static int Hidden
JavaScript
InSite.Model.DisplayType.hidden

See Also

DisplayType Class
InSite.Model Namespace


Visible Field

[image]

.NET Framework Class Library
DisplayType..::.Visible Field
DisplayType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Visible As Integer
C#
public static int Visible
Visual C++
public:
static int Visible
JavaScript
InSite.Model.DisplayType.visible

See Also

DisplayType Class
InSite.Model Namespace


DisplayType Methods

[image] [image]

.NET Framework Class Library
DisplayType Methods
DisplayType Class See Also Send Feedback

The DisplayType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DisplayType Class
InSite.Model Namespace


Document Class

[image]

.NET Framework Class Library
Document Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Document _
    Inherits ModelBase(Of Document)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Document : ModelBase<Document>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Document : public ModelBase<Document^>
JavaScript
InSite.Model.Document = function();

Type.createClass(
    'InSite.Model.Document',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Document>)>)
InSite.Model..::.Document

See Also

Document Members
InSite.Model Namespace


Document Members

[image] [image]

.NET Framework Class Library
Document Members
Document Class Constructors Methods Fields Properties See Also Send Feedback

The Document type exposes the following members.

Constructors

Name | Description
Document | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Created |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
DocumentId |
DocumentManager |
DocumentType |
FileName |
FilePath |
FullPathName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Document Class
InSite.Model Namespace


Document Constructor

[image] [image]

.NET Framework Class Library
Document Constructor
Document Class See Also Send Feedback

Overload List

Name | Description
Document()()() |
Document(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Document Class
Document Members
InSite.Model Namespace


Document Constructor

[image]

.NET Framework Class Library
Document Constructor
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Document()
Visual C++
public:
Document()
JavaScript
InSite.Model.Document = function();

See Also

Document Class
Document Overload
InSite.Model Namespace


Document Constructor (SearchMode)

[image]

.NET Framework Class Library
Document Constructor (SearchMode)
Document Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Document(
    SearchMode searchMode
)
Visual C++
public:
Document(
    SearchMode searchMode
)
JavaScript
InSite.Model.Document = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Document Class
Document Overload
InSite.Model Namespace


Document Fields

[image] [image]

.NET Framework Class Library
Document Fields
Document Class See Also Send Feedback

The Document type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Document Class
InSite.Model Namespace


Document Methods

[image] [image]

.NET Framework Class Library
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Document Class
InSite.Model Namespace


Document Properties

[image] [image]

.NET Framework Class Library
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Created |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
DocumentId |
DocumentManager |
DocumentType |
FileName |
FilePath |
FullPathName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Document Class
InSite.Model Namespace


Created Property

[image]

.NET Framework Class Library
Document..::.Created Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Created As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Created { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Created {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_created();
function set_created(value);

See Also

Document Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Document..::.Description Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Document Class
InSite.Model Namespace


DocumentId Property

[image]

.NET Framework Class Library
Document..::.DocumentId Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DocumentId As Guid
C#
public virtual Guid DocumentId { get; set; }
Visual C++
public:
virtual property Guid DocumentId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_documentId();
function set_documentId(value);

See Also

Document Class
InSite.Model Namespace


DocumentManager Property

[image]

.NET Framework Class Library
Document..::.DocumentManager Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DocumentManager As DocumentManager
C#
public virtual DocumentManager DocumentManager { get; set; }
Visual C++
public:
virtual property DocumentManager^ DocumentManager {
    DocumentManager^ get ();
    void set (DocumentManager^ value);
}
JavaScript
function get_documentManager();
function set_documentManager(value);

See Also

Document Class
InSite.Model Namespace


DocumentType Property

[image]

.NET Framework Class Library
Document..::.DocumentType Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DocumentType As String
C#
[DataMemberAttribute]
public virtual string DocumentType { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DocumentType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_documentType();
function set_documentType(value);

See Also

Document Class
InSite.Model Namespace


FileName Property

[image]

.NET Framework Class Library
Document..::.FileName Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FileName As String
C#
[DataMemberAttribute]
public virtual string FileName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fileName();
function set_fileName(value);

See Also

Document Class
InSite.Model Namespace


FilePath Property

[image]

.NET Framework Class Library
Document..::.FilePath Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FilePath As String
C#
[DataMemberAttribute]
public virtual string FilePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_filePath();
function set_filePath(value);

See Also

Document Class
InSite.Model Namespace


FullPathName Property

[image]

.NET Framework Class Library
Document..::.FullPathName Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FullPathName As String
C#
public virtual string FullPathName { get; }
Visual C++
public:
virtual property String^ FullPathName {
    String^ get ();
}
JavaScript
function get_fullPathName();

See Also

Document Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Document..::.Name Property
Document Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Document Class
InSite.Model Namespace


DocumentManager Class

[image]

.NET Framework Class Library
DocumentManager Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class DocumentManager _
    Inherits ModelBase(Of DocumentManager)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class DocumentManager : ModelBase<DocumentManager>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class DocumentManager : public ModelBase<DocumentManager^>
JavaScript
InSite.Model.DocumentManager = function();

Type.createClass(
    'InSite.Model.DocumentManager',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(DocumentManager>)>)
InSite.Model..::.DocumentManager

See Also

DocumentManager Members
InSite.Model Namespace


DocumentManager Members

[image] [image]

.NET Framework Class Library
DocumentManager Members
DocumentManager Class Constructors Methods Fields Properties See Also Send Feedback

The DocumentManager type exposes the following members.

Constructors

Name | Description
DocumentManager | Overloaded.

Methods

Name | Description
AddDocument |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveDocument |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DocumentManagerId |
Documents |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DocumentManager Class
InSite.Model Namespace


DocumentManager Constructor

[image] [image]

.NET Framework Class Library
DocumentManager Constructor
DocumentManager Class See Also Send Feedback

Overload List

Name | Description
DocumentManager()()() |
DocumentManager(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

DocumentManager Class
DocumentManager Members
InSite.Model Namespace


DocumentManager Constructor

[image]

.NET Framework Class Library
DocumentManager Constructor
DocumentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DocumentManager()
Visual C++
public:
DocumentManager()
JavaScript
InSite.Model.DocumentManager = function();

See Also

DocumentManager Class
DocumentManager Overload
InSite.Model Namespace


DocumentManager Constructor (SearchMode)

[image]

.NET Framework Class Library
DocumentManager Constructor (SearchMode)
DocumentManager Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public DocumentManager(
    SearchMode searchMode
)
Visual C++
public:
DocumentManager(
    SearchMode searchMode
)
JavaScript
InSite.Model.DocumentManager = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

DocumentManager Class
DocumentManager Overload
InSite.Model Namespace


DocumentManager Fields

[image] [image]

.NET Framework Class Library
DocumentManager Fields
DocumentManager Class See Also Send Feedback

The DocumentManager type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DocumentManager Class
InSite.Model Namespace


DocumentManager Methods

[image] [image]

.NET Framework Class Library
DocumentManager Methods
DocumentManager Class See Also Send Feedback

The DocumentManager type exposes the following members.

Methods

Name | Description
AddDocument |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveDocument |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DocumentManager Class
InSite.Model Namespace


AddDocument Method

[image]

.NET Framework Class Library
DocumentManager..::.AddDocument Method
DocumentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddDocument ( _
    value As Document _
)
C#
public virtual void AddDocument(
    Document value
)
Visual C++
public:
virtual void AddDocument(
    Document^ value
)
JavaScript
function addDocument(value);

Parameters

value
Type: InSite.Model..::.Document

See Also

DocumentManager Class
InSite.Model Namespace


RemoveDocument Method

[image]

.NET Framework Class Library
DocumentManager..::.RemoveDocument Method
DocumentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveDocument ( _
    value As Document _
)
C#
public virtual void RemoveDocument(
    Document value
)
Visual C++
public:
virtual void RemoveDocument(
    Document^ value
)
JavaScript
function removeDocument(value);

Parameters

value
Type: InSite.Model..::.Document

See Also

DocumentManager Class
InSite.Model Namespace


DocumentManager Properties

[image] [image]

.NET Framework Class Library
DocumentManager Properties
DocumentManager Class See Also Send Feedback

The DocumentManager type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DocumentManagerId |
Documents |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

DocumentManager Class
InSite.Model Namespace


DocumentManagerId Property

[image]

.NET Framework Class Library
DocumentManager..::.DocumentManagerId Property
DocumentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DocumentManagerId As Guid
C#
public virtual Guid DocumentManagerId { get; set; }
Visual C++
public:
virtual property Guid DocumentManagerId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_documentManagerId();
function set_documentManagerId(value);

See Also

DocumentManager Class
InSite.Model Namespace


Documents Property

[image]

.NET Framework Class Library
DocumentManager..::.Documents Property
DocumentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Documents As ChildList(Of Document)
C#
[DataMemberAttribute]
public virtual ChildList<Document> Documents { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Document^>^ Documents {
    ChildList<Document^>^ get ();
    void set (ChildList<Document^>^ value);
}
JavaScript
function get_documents();
function set_documents(value);

See Also

DocumentManager Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
DocumentManager..::.Name Property
DocumentManager Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

DocumentManager Class
InSite.Model Namespace


EmailList Class

[image]

.NET Framework Class Library
EmailList Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class EmailList _
    Inherits ModelBase(Of EmailList)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class EmailList : ModelBase<EmailList>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class EmailList : public ModelBase<EmailList^>
JavaScript
InSite.Model.EmailList = function();

Type.createClass(
    'InSite.Model.EmailList',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(EmailList>)>)
InSite.Model..::.EmailList

See Also

EmailList Members
InSite.Model Namespace


EmailList Members

[image] [image]

.NET Framework Class Library
EmailList Members
EmailList Class Constructors Methods Fields Properties See Also Send Feedback

The EmailList type exposes the following members.

Constructors

Name | Description
EmailList | Overloaded.

Methods

Name | Description
AddUserProfile |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveUserProfile |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
CanSubscribe |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
EmailListId |
EmailTemplate |
FromAddress |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Subject |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfiles |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

EmailList Class
InSite.Model Namespace


EmailList Constructor

[image] [image]

.NET Framework Class Library
EmailList Constructor
EmailList Class See Also Send Feedback

Overload List

Name | Description
EmailList()()() |
EmailList(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

EmailList Class
EmailList Members
InSite.Model Namespace


EmailList Constructor

[image]

.NET Framework Class Library
EmailList Constructor
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EmailList()
Visual C++
public:
EmailList()
JavaScript
InSite.Model.EmailList = function();

See Also

EmailList Class
EmailList Overload
InSite.Model Namespace


EmailList Constructor (SearchMode)

[image]

.NET Framework Class Library
EmailList Constructor (SearchMode)
EmailList Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public EmailList(
    SearchMode searchMode
)
Visual C++
public:
EmailList(
    SearchMode searchMode
)
JavaScript
InSite.Model.EmailList = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

EmailList Class
EmailList Overload
InSite.Model Namespace


EmailList Fields

[image] [image]

.NET Framework Class Library
EmailList Fields
EmailList Class See Also Send Feedback

The EmailList type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

EmailList Class
InSite.Model Namespace


EmailList Methods

[image] [image]

.NET Framework Class Library
EmailList Methods
EmailList Class See Also Send Feedback

The EmailList type exposes the following members.

Methods

Name | Description
AddUserProfile |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveUserProfile |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

EmailList Class
InSite.Model Namespace


AddUserProfile Method

[image]

.NET Framework Class Library
EmailList..::.AddUserProfile Method
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddUserProfile ( _
    value As UserProfile _
)
C#
public virtual void AddUserProfile(
    UserProfile value
)
Visual C++
public:
virtual void AddUserProfile(
    UserProfile^ value
)
JavaScript
function addUserProfile(value);

Parameters

value
Type: InSite.Model..::.UserProfile

See Also

EmailList Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
EmailList..::.GetByName Method
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As EmailList
C#
public static EmailList GetByName(
    string name
)
Visual C++
public:
static EmailList^ GetByName(
    String^ name
)
JavaScript
InSite.Model.EmailList.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

EmailList Class
InSite.Model Namespace


RemoveUserProfile Method

[image]

.NET Framework Class Library
EmailList..::.RemoveUserProfile Method
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveUserProfile ( _
    value As UserProfile _
)
C#
public virtual void RemoveUserProfile(
    UserProfile value
)
Visual C++
public:
virtual void RemoveUserProfile(
    UserProfile^ value
)
JavaScript
function removeUserProfile(value);

Parameters

value
Type: InSite.Model..::.UserProfile

See Also

EmailList Class
InSite.Model Namespace


EmailList Properties

[image] [image]

.NET Framework Class Library
EmailList Properties
EmailList Class See Also Send Feedback

The EmailList type exposes the following members.

Properties

Name | Description
CanSubscribe |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
EmailListId |
EmailTemplate |
FromAddress |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Subject |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfiles |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

EmailList Class
InSite.Model Namespace


CanSubscribe Property

[image]

.NET Framework Class Library
EmailList..::.CanSubscribe Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CanSubscribe As Boolean
C#
[DataMemberAttribute]
public virtual bool CanSubscribe { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool CanSubscribe {
    bool get ();
    void set (bool value);
}
JavaScript
function get_canSubscribe();
function set_canSubscribe(value);

See Also

EmailList Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
EmailList..::.Description Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

EmailList Class
InSite.Model Namespace


EmailListId Property

[image]

.NET Framework Class Library
EmailList..::.EmailListId Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EmailListId As Guid
C#
public virtual Guid EmailListId { get; set; }
Visual C++
public:
virtual property Guid EmailListId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_emailListId();
function set_emailListId(value);

See Also

EmailList Class
InSite.Model Namespace


EmailTemplate Property

[image]

.NET Framework Class Library
EmailList..::.EmailTemplate Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EmailTemplate As EmailTemplate
C#
public virtual EmailTemplate EmailTemplate { get; set; }
Visual C++
public:
virtual property EmailTemplate^ EmailTemplate {
    EmailTemplate^ get ();
    void set (EmailTemplate^ value);
}
JavaScript
function get_emailTemplate();
function set_emailTemplate(value);

See Also

EmailList Class
InSite.Model Namespace


FromAddress Property

[image]

.NET Framework Class Library
EmailList..::.FromAddress Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FromAddress As String
C#
[DataMemberAttribute]
public virtual string FromAddress { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fromAddress();
function set_fromAddress(value);

See Also

EmailList Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
EmailList..::.HtmlContent Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HtmlContent As String
C#
[DataMemberAttribute]
public virtual string HtmlContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

EmailList Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
EmailList..::.Name Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

EmailList Class
InSite.Model Namespace


Subject Property

[image]

.NET Framework Class Library
EmailList..::.Subject Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Subject As String
C#
[DataMemberAttribute]
public virtual string Subject { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Subject {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_subject();
function set_subject(value);

See Also

EmailList Class
InSite.Model Namespace


UserProfiles Property

[image]

.NET Framework Class Library
EmailList..::.UserProfiles Property
EmailList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UserProfiles As ChildList(Of UserProfile)
C#
[DataMemberAttribute]
public virtual ChildList<UserProfile> UserProfiles { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<UserProfile^>^ UserProfiles {
    ChildList<UserProfile^>^ get ();
    void set (ChildList<UserProfile^>^ value);
}
JavaScript
function get_userProfiles();
function set_userProfiles(value);

See Also

EmailList Class
InSite.Model Namespace


EmailTemplate Class

[image]

.NET Framework Class Library
EmailTemplate Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class EmailTemplate _
    Inherits ModelBase(Of EmailTemplate)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class EmailTemplate : ModelBase<EmailTemplate>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class EmailTemplate : public ModelBase<EmailTemplate^>
JavaScript
InSite.Model.EmailTemplate = function();

Type.createClass(
    'InSite.Model.EmailTemplate',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(EmailTemplate>)>)
InSite.Model..::.EmailTemplate

See Also

EmailTemplate Members
InSite.Model Namespace


EmailTemplate Members

[image] [image]

.NET Framework Class Library
EmailTemplate Members
EmailTemplate Class Constructors Methods Fields Properties See Also Send Feedback

The EmailTemplate type exposes the following members.

Constructors

Name | Description
EmailTemplate | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
EmailTemplateID |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

EmailTemplate Class
InSite.Model Namespace


EmailTemplate Constructor

[image] [image]

.NET Framework Class Library
EmailTemplate Constructor
EmailTemplate Class See Also Send Feedback

Overload List

Name | Description
EmailTemplate()()() |
EmailTemplate(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

EmailTemplate Class
EmailTemplate Members
InSite.Model Namespace


EmailTemplate Constructor

[image]

.NET Framework Class Library
EmailTemplate Constructor
EmailTemplate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public EmailTemplate()
Visual C++
public:
EmailTemplate()
JavaScript
InSite.Model.EmailTemplate = function();

See Also

EmailTemplate Class
EmailTemplate Overload
InSite.Model Namespace


EmailTemplate Constructor (SearchMode)

[image]

.NET Framework Class Library
EmailTemplate Constructor (SearchMode)
EmailTemplate Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public EmailTemplate(
    SearchMode searchMode
)
Visual C++
public:
EmailTemplate(
    SearchMode searchMode
)
JavaScript
InSite.Model.EmailTemplate = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

EmailTemplate Class
EmailTemplate Overload
InSite.Model Namespace


EmailTemplate Fields

[image] [image]

.NET Framework Class Library
EmailTemplate Fields
EmailTemplate Class See Also Send Feedback

The EmailTemplate type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

EmailTemplate Class
InSite.Model Namespace


EmailTemplate Methods

[image] [image]

.NET Framework Class Library
EmailTemplate Methods
EmailTemplate Class See Also Send Feedback

The EmailTemplate type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

EmailTemplate Class
InSite.Model Namespace


EmailTemplate Properties

[image] [image]

.NET Framework Class Library
EmailTemplate Properties
EmailTemplate Class See Also Send Feedback

The EmailTemplate type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
EmailTemplateID |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

EmailTemplate Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
EmailTemplate..::.ContentManager Property
EmailTemplate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

EmailTemplate Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
EmailTemplate..::.Description Property
EmailTemplate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

EmailTemplate Class
InSite.Model Namespace


EmailTemplateID Property

[image]

.NET Framework Class Library
EmailTemplate..::.EmailTemplateID Property
EmailTemplate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EmailTemplateID As Guid
C#
public virtual Guid EmailTemplateID { get; set; }
Visual C++
public:
virtual property Guid EmailTemplateID {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_emailTemplateID();
function set_emailTemplateID(value);

See Also

EmailTemplate Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
EmailTemplate..::.HtmlContent Property
EmailTemplate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HtmlContent As String
C#
[DataMemberAttribute]
public virtual string HtmlContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

EmailTemplate Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
EmailTemplate..::.Name Property
EmailTemplate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

EmailTemplate Class
InSite.Model Namespace


FilterSection Class

[image]

.NET Framework Class Library
FilterSection Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class FilterSection _
    Inherits ModelBase(Of FilterSection)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class FilterSection : ModelBase<FilterSection>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class FilterSection : public ModelBase<FilterSection^>
JavaScript
InSite.Model.FilterSection = function();

Type.createClass(
    'InSite.Model.FilterSection',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(FilterSection>)>)
InSite.Model..::.FilterSection

See Also

FilterSection Members
InSite.Model Namespace


FilterSection Members

[image] [image]

.NET Framework Class Library
FilterSection Members
FilterSection Class Constructors Methods Fields Properties See Also Send Feedback

The FilterSection type exposes the following members.

Constructors

Name | Description
FilterSection | Overloaded.

Methods

Name | Description
AddCategoryFilterSection |
AddFilterValue |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MyGetList |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategoryFilterSection |
RemoveFilterValue |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ActiveCategoryFilterSections |
ActiveFilterValues |
CategoryFilterSections |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
FilterSectionId |
FilterValues |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Label |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

FilterSection Class
InSite.Model Namespace


FilterSection Constructor

[image] [image]

.NET Framework Class Library
FilterSection Constructor
FilterSection Class See Also Send Feedback

Overload List

Name | Description
FilterSection()()() |
FilterSection(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

FilterSection Class
FilterSection Members
InSite.Model Namespace


FilterSection Constructor

[image]

.NET Framework Class Library
FilterSection Constructor
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterSection()
Visual C++
public:
FilterSection()
JavaScript
InSite.Model.FilterSection = function();

See Also

FilterSection Class
FilterSection Overload
InSite.Model Namespace


FilterSection Constructor (SearchMode)

[image]

.NET Framework Class Library
FilterSection Constructor (SearchMode)
FilterSection Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public FilterSection(
    SearchMode searchMode
)
Visual C++
public:
FilterSection(
    SearchMode searchMode
)
JavaScript
InSite.Model.FilterSection = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

FilterSection Class
FilterSection Overload
InSite.Model Namespace


FilterSection Fields

[image] [image]

.NET Framework Class Library
FilterSection Fields
FilterSection Class See Also Send Feedback

The FilterSection type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

FilterSection Class
InSite.Model Namespace


FilterSection Methods

[image] [image]

.NET Framework Class Library
FilterSection Methods
FilterSection Class See Also Send Feedback

The FilterSection type exposes the following members.

Methods

Name | Description
AddCategoryFilterSection |
AddFilterValue |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MyGetList |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategoryFilterSection |
RemoveFilterValue |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

FilterSection Class
InSite.Model Namespace


AddCategoryFilterSection Method

[image]

.NET Framework Class Library
FilterSection..::.AddCategoryFilterSection Method
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategoryFilterSection ( _
    value As CategoryFilterSection _
)
C#
public virtual void AddCategoryFilterSection(
    CategoryFilterSection value
)
Visual C++
public:
virtual void AddCategoryFilterSection(
    CategoryFilterSection^ value
)
JavaScript
function addCategoryFilterSection(value);

Parameters

value
Type: InSite.Model..::.CategoryFilterSection

See Also

FilterSection Class
InSite.Model Namespace


AddFilterValue Method

[image]

.NET Framework Class Library
FilterSection..::.AddFilterValue Method
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddFilterValue ( _
    value As FilterValue _
)
C#
public virtual void AddFilterValue(
    FilterValue value
)
Visual C++
public:
virtual void AddFilterValue(
    FilterValue^ value
)
JavaScript
function addFilterValue(value);

Parameters

value
Type: InSite.Model..::.FilterValue

See Also

FilterSection Class
InSite.Model Namespace


MyGetList Method

[image]

.NET Framework Class Library
FilterSection..::.MyGetList Method
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function MyGetList As IList(Of FilterSection)
C#
public virtual IList<FilterSection> MyGetList()
Visual C++
public:
virtual IList<FilterSection^>^ MyGetList()
JavaScript
function myGetList();

See Also

FilterSection Class
InSite.Model Namespace


RemoveCategoryFilterSection Method

[image]

.NET Framework Class Library
FilterSection..::.RemoveCategoryFilterSection Method
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategoryFilterSection ( _
    value As CategoryFilterSection _
)
C#
public virtual void RemoveCategoryFilterSection(
    CategoryFilterSection value
)
Visual C++
public:
virtual void RemoveCategoryFilterSection(
    CategoryFilterSection^ value
)
JavaScript
function removeCategoryFilterSection(value);

Parameters

value
Type: InSite.Model..::.CategoryFilterSection

See Also

FilterSection Class
InSite.Model Namespace


RemoveFilterValue Method

[image]

.NET Framework Class Library
FilterSection..::.RemoveFilterValue Method
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveFilterValue ( _
    value As FilterValue _
)
C#
public virtual void RemoveFilterValue(
    FilterValue value
)
Visual C++
public:
virtual void RemoveFilterValue(
    FilterValue^ value
)
JavaScript
function removeFilterValue(value);

Parameters

value
Type: InSite.Model..::.FilterValue

See Also

FilterSection Class
InSite.Model Namespace


FilterSection Properties

[image] [image]

.NET Framework Class Library
FilterSection Properties
FilterSection Class See Also Send Feedback

The FilterSection type exposes the following members.

Properties

Name | Description
ActiveCategoryFilterSections |
ActiveFilterValues |
CategoryFilterSections |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
FilterSectionId |
FilterValues |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Label |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

FilterSection Class
InSite.Model Namespace


ActiveCategoryFilterSections Property

[image]

.NET Framework Class Library
FilterSection..::.ActiveCategoryFilterSections Property
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveCategoryFilterSections As ChildList(Of CategoryFilterSection)
C#
public virtual ChildList<CategoryFilterSection> ActiveCategoryFilterSections { get; }
Visual C++
public:
virtual property ChildList<CategoryFilterSection^>^ ActiveCategoryFilterSections {
    ChildList<CategoryFilterSection^>^ get ();
}
JavaScript
function get_activeCategoryFilterSections();

See Also

FilterSection Class
InSite.Model Namespace


ActiveFilterValues Property

[image]

.NET Framework Class Library
FilterSection..::.ActiveFilterValues Property
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveFilterValues As ChildList(Of FilterValue)
C#
public virtual ChildList<FilterValue> ActiveFilterValues { get; }
Visual C++
public:
virtual property ChildList<FilterValue^>^ ActiveFilterValues {
    ChildList<FilterValue^>^ get ();
}
JavaScript
function get_activeFilterValues();

See Also

FilterSection Class
InSite.Model Namespace


CategoryFilterSections Property

[image]

.NET Framework Class Library
FilterSection..::.CategoryFilterSections Property
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CategoryFilterSections As ChildList(Of CategoryFilterSection)
C#
[DataMemberAttribute]
public virtual ChildList<CategoryFilterSection> CategoryFilterSections { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<CategoryFilterSection^>^ CategoryFilterSections {
    ChildList<CategoryFilterSection^>^ get ();
    void set (ChildList<CategoryFilterSection^>^ value);
}
JavaScript
function get_categoryFilterSections();
function set_categoryFilterSections(value);

See Also

FilterSection Class
InSite.Model Namespace


FilterSectionId Property

[image]

.NET Framework Class Library
FilterSection..::.FilterSectionId Property
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FilterSectionId As Guid
C#
public virtual Guid FilterSectionId { get; set; }
Visual C++
public:
virtual property Guid FilterSectionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_filterSectionId();
function set_filterSectionId(value);

See Also

FilterSection Class
InSite.Model Namespace


FilterValues Property

[image]

.NET Framework Class Library
FilterSection..::.FilterValues Property
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SaveChildren> _
Public Overridable Property FilterValues As ChildList(Of FilterValue)
C#
[DataMemberAttribute]
[SaveChildren]
public virtual ChildList<FilterValue> FilterValues { get; private set; }
Visual C++
[DataMemberAttribute]
[SaveChildren]
public:
virtual property ChildList<FilterValue^>^ FilterValues {
    ChildList<FilterValue^>^ get ();
    void set (ChildList<FilterValue^>^ value);
}
JavaScript
function get_filterValues();
function set_filterValues(value);

See Also

FilterSection Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
FilterSection..::.IsActive Property
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

FilterSection Class
InSite.Model Namespace


Label Property

[image]

.NET Framework Class Library
FilterSection..::.Label Property
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Label As String
C#
[DataMemberAttribute]
public virtual string Label { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Label {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_label();
function set_label(value);

See Also

FilterSection Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
FilterSection..::.Name Property
FilterSection Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

FilterSection Class
InSite.Model Namespace


FilterValue Class

[image]

.NET Framework Class Library
FilterValue Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class FilterValue _
    Inherits ModelBase(Of FilterValue)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class FilterValue : ModelBase<FilterValue>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class FilterValue : public ModelBase<FilterValue^>
JavaScript
InSite.Model.FilterValue = function();

Type.createClass(
    'InSite.Model.FilterValue',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(FilterValue>)>)
InSite.Model..::.FilterValue

See Also

FilterValue Members
InSite.Model Namespace


FilterValue Members

[image] [image]

.NET Framework Class Library
FilterValue Members
FilterValue Class Constructors Methods Fields Properties See Also Send Feedback

The FilterValue type exposes the following members.

Constructors

Name | Description
FilterValue | Overloaded.

Methods

Name | Description
AddCategory |
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategory |
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
FilterSection |
FilterValueId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

FilterValue Class
InSite.Model Namespace


FilterValue Constructor

[image] [image]

.NET Framework Class Library
FilterValue Constructor
FilterValue Class See Also Send Feedback

Overload List

Name | Description
FilterValue()()() |
FilterValue(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

FilterValue Class
FilterValue Members
InSite.Model Namespace


FilterValue Constructor

[image]

.NET Framework Class Library
FilterValue Constructor
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FilterValue()
Visual C++
public:
FilterValue()
JavaScript
InSite.Model.FilterValue = function();

See Also

FilterValue Class
FilterValue Overload
InSite.Model Namespace


FilterValue Constructor (SearchMode)

[image]

.NET Framework Class Library
FilterValue Constructor (SearchMode)
FilterValue Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public FilterValue(
    SearchMode searchMode
)
Visual C++
public:
FilterValue(
    SearchMode searchMode
)
JavaScript
InSite.Model.FilterValue = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

FilterValue Class
FilterValue Overload
InSite.Model Namespace


FilterValue Fields

[image] [image]

.NET Framework Class Library
FilterValue Fields
FilterValue Class See Also Send Feedback

The FilterValue type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

FilterValue Class
InSite.Model Namespace


FilterValue Methods

[image] [image]

.NET Framework Class Library
FilterValue Methods
FilterValue Class See Also Send Feedback

The FilterValue type exposes the following members.

Methods

Name | Description
AddCategory |
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategory |
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

FilterValue Class
InSite.Model Namespace


AddCategory Method

[image]

.NET Framework Class Library
FilterValue..::.AddCategory Method
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategory ( _
    value As Category _
)
C#
public virtual void AddCategory(
    Category value
)
Visual C++
public:
virtual void AddCategory(
    Category^ value
)
JavaScript
function addCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

FilterValue Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
FilterValue..::.AddProduct Method
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

FilterValue Class
InSite.Model Namespace


RemoveCategory Method

[image]

.NET Framework Class Library
FilterValue..::.RemoveCategory Method
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategory ( _
    value As Category _
)
C#
public virtual void RemoveCategory(
    Category value
)
Visual C++
public:
virtual void RemoveCategory(
    Category^ value
)
JavaScript
function removeCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

FilterValue Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
FilterValue..::.RemoveProduct Method
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

FilterValue Class
InSite.Model Namespace


FilterValue Properties

[image] [image]

.NET Framework Class Library
FilterValue Properties
FilterValue Class See Also Send Feedback

The FilterValue type exposes the following members.

Properties

Name | Description
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
FilterSection |
FilterValueId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

FilterValue Class
InSite.Model Namespace


Categories Property

[image]

.NET Framework Class Library
FilterValue..::.Categories Property
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Categories As ChildList(Of Category)
C#
[DataMemberAttribute]
public virtual ChildList<Category> Categories { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Category^>^ Categories {
    ChildList<Category^>^ get ();
    void set (ChildList<Category^>^ value);
}
JavaScript
function get_categories();
function set_categories(value);

See Also

FilterValue Class
InSite.Model Namespace


FilterSection Property

[image]

.NET Framework Class Library
FilterValue..::.FilterSection Property
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FilterSection As FilterSection
C#
public virtual FilterSection FilterSection { get; set; }
Visual C++
public:
virtual property FilterSection^ FilterSection {
    FilterSection^ get ();
    void set (FilterSection^ value);
}
JavaScript
function get_filterSection();
function set_filterSection(value);

See Also

FilterValue Class
InSite.Model Namespace


FilterValueId Property

[image]

.NET Framework Class Library
FilterValue..::.FilterValueId Property
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FilterValueId As Guid
C#
public virtual Guid FilterValueId { get; set; }
Visual C++
public:
virtual property Guid FilterValueId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_filterValueId();
function set_filterValueId(value);

See Also

FilterValue Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
FilterValue..::.IsActive Property
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

FilterValue Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
FilterValue..::.Products Property
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Products As ChildList(Of Product)
C#
[DataMemberAttribute]
public virtual ChildList<Product> Products { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

FilterValue Class
InSite.Model Namespace


SortOrder Property

[image]

.NET Framework Class Library
FilterValue..::.SortOrder Property
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property SortOrder As Integer
C#
[SortField]
[DataMemberAttribute]
public virtual int SortOrder { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property int SortOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_sortOrder();
function set_sortOrder(value);

See Also

FilterValue Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
FilterValue..::.Value Property
FilterValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

FilterValue Class
InSite.Model Namespace


FlushModeEnum Enumeration

[image]

.NET Framework Class Library
FlushModeEnum Enumeration
See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration FlushModeEnum
C#
public enum FlushModeEnum
Visual C++
public enum class FlushModeEnum
JavaScript
InSite.Model.FlushModeEnum = function();
InSite.Model.FlushModeEnum.createEnum('InSite.Model.FlushModeEnum', false);

Members

Member name | Description
Never |
Auto |

See Also

InSite.Model Namespace


GiftCard Class

[image]

.NET Framework Class Library
GiftCard Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class GiftCard _
    Inherits ModelBase(Of GiftCard)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class GiftCard : ModelBase<GiftCard>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class GiftCard : public ModelBase<GiftCard^>
JavaScript
InSite.Model.GiftCard = function();

Type.createClass(
    'InSite.Model.GiftCard',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(GiftCard>)>)
InSite.Model..::.GiftCard

See Also

GiftCard Members
InSite.Model Namespace


GiftCard Members

[image] [image]

.NET Framework Class Library
GiftCard Members
GiftCard Class Constructors Methods Fields Properties See Also Send Feedback

The GiftCard type exposes the following members.

Constructors

Name | Description
GiftCard | Overloaded.

Methods

Name | Description
AddCustomerOrder |
AddGiftCardTransaction |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByNumber |
GetGiftCardNumber |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomerOrder |
RemoveGiftCardTransaciton |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
Balance |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrders |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Email |
Expired |
FirstName |
GiftCardId |
GiftCardNumber |
GiftCardTransactions |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LastName |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderLine |
OrderNumber |
Purchased |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

GiftCard Class
InSite.Model Namespace


GiftCard Constructor

[image] [image]

.NET Framework Class Library
GiftCard Constructor
GiftCard Class See Also Send Feedback

Overload List

Name | Description
GiftCard()()() |
GiftCard(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

GiftCard Class
GiftCard Members
InSite.Model Namespace


GiftCard Constructor

[image]

.NET Framework Class Library
GiftCard Constructor
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GiftCard()
Visual C++
public:
GiftCard()
JavaScript
InSite.Model.GiftCard = function();

See Also

GiftCard Class
GiftCard Overload
InSite.Model Namespace


GiftCard Constructor (SearchMode)

[image]

.NET Framework Class Library
GiftCard Constructor (SearchMode)
GiftCard Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public GiftCard(
    SearchMode searchMode
)
Visual C++
public:
GiftCard(
    SearchMode searchMode
)
JavaScript
InSite.Model.GiftCard = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

GiftCard Class
GiftCard Overload
InSite.Model Namespace


GiftCard Fields

[image] [image]

.NET Framework Class Library
GiftCard Fields
GiftCard Class See Also Send Feedback

The GiftCard type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

GiftCard Class
InSite.Model Namespace


GiftCard Methods

[image] [image]

.NET Framework Class Library
GiftCard Methods
GiftCard Class See Also Send Feedback

The GiftCard type exposes the following members.

Methods

Name | Description
AddCustomerOrder |
AddGiftCardTransaction |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByNumber |
GetGiftCardNumber |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomerOrder |
RemoveGiftCardTransaciton |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

GiftCard Class
InSite.Model Namespace


AddCustomerOrder Method

[image]

.NET Framework Class Library
GiftCard..::.AddCustomerOrder Method
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomerOrder ( _
    value As CustomerOrder _
)
C#
public virtual void AddCustomerOrder(
    CustomerOrder value
)
Visual C++
public:
virtual void AddCustomerOrder(
    CustomerOrder^ value
)
JavaScript
function addCustomerOrder(value);

Parameters

value
Type: InSite.Model..::.CustomerOrder

See Also

GiftCard Class
InSite.Model Namespace


AddGiftCardTransaction Method

[image]

.NET Framework Class Library
GiftCard..::.AddGiftCardTransaction Method
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddGiftCardTransaction ( _
    value As GiftCardTransaction _
)
C#
public virtual void AddGiftCardTransaction(
    GiftCardTransaction value
)
Visual C++
public:
virtual void AddGiftCardTransaction(
    GiftCardTransaction^ value
)
JavaScript
function addGiftCardTransaction(value);

Parameters

value
Type: InSite.Model..::.GiftCardTransaction

See Also

GiftCard Class
InSite.Model Namespace


GetByNumber Method

[image]

.NET Framework Class Library
GiftCard..::.GetByNumber Method
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByNumber ( _
    number As String _
) As GiftCard
C#
public static GiftCard GetByNumber(
    string number
)
Visual C++
public:
static GiftCard^ GetByNumber(
    String^ number
)
JavaScript
InSite.Model.GiftCard.getByNumber = function(number);

Parameters

number
Type: System..::.String

See Also

GiftCard Class
InSite.Model Namespace


GetGiftCardNumber Method

[image]

.NET Framework Class Library
GiftCard..::.GetGiftCardNumber Method
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetGiftCardNumber As String
C#
public static string GetGiftCardNumber()
Visual C++
public:
static String^ GetGiftCardNumber()
JavaScript
InSite.Model.GiftCard.getGiftCardNumber = function();

See Also

GiftCard Class
InSite.Model Namespace


RemoveCustomerOrder Method

[image]

.NET Framework Class Library
GiftCard..::.RemoveCustomerOrder Method
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomerOrder ( _
    value As CustomerOrder _
)
C#
public virtual void RemoveCustomerOrder(
    CustomerOrder value
)
Visual C++
public:
virtual void RemoveCustomerOrder(
    CustomerOrder^ value
)
JavaScript
function removeCustomerOrder(value);

Parameters

value
Type: InSite.Model..::.CustomerOrder

See Also

GiftCard Class
InSite.Model Namespace


RemoveGiftCardTransaciton Method

[image]

.NET Framework Class Library
GiftCard..::.RemoveGiftCardTransaciton Method
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveGiftCardTransaciton ( _
    value As GiftCardTransaction _
)
C#
public virtual void RemoveGiftCardTransaciton(
    GiftCardTransaction value
)
Visual C++
public:
virtual void RemoveGiftCardTransaciton(
    GiftCardTransaction^ value
)
JavaScript
function removeGiftCardTransaciton(value);

Parameters

value
Type: InSite.Model..::.GiftCardTransaction

See Also

GiftCard Class
InSite.Model Namespace


GiftCard Properties

[image] [image]

.NET Framework Class Library
GiftCard Properties
GiftCard Class See Also Send Feedback

The GiftCard type exposes the following members.

Properties

Name | Description
Amount |
Balance |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrders |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Email |
Expired |
FirstName |
GiftCardId |
GiftCardNumber |
GiftCardTransactions |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LastName |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderLine |
OrderNumber |
Purchased |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

GiftCard Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
GiftCard..::.Amount Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

GiftCard Class
InSite.Model Namespace


Balance Property

[image]

.NET Framework Class Library
GiftCard..::.Balance Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Balance As Decimal
C#
[DataMemberAttribute]
public virtual decimal Balance { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Balance {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_balance();
function set_balance(value);

See Also

GiftCard Class
InSite.Model Namespace


CustomerOrders Property

[image]

.NET Framework Class Library
GiftCard..::.CustomerOrders Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrders As ChildList(Of CustomerOrder)
C#
public virtual ChildList<CustomerOrder> CustomerOrders { get; private set; }
Visual C++
public:
virtual property ChildList<CustomerOrder^>^ CustomerOrders {
    ChildList<CustomerOrder^>^ get ();
    void set (ChildList<CustomerOrder^>^ value);
}
JavaScript
function get_customerOrders();
function set_customerOrders(value);

See Also

GiftCard Class
InSite.Model Namespace


Email Property

[image]

.NET Framework Class Library
GiftCard..::.Email Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Email As String
C#
[DataMemberAttribute]
public virtual string Email { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

See Also

GiftCard Class
InSite.Model Namespace


Expired Property

[image]

.NET Framework Class Library
GiftCard..::.Expired Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Expired As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Expired { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Expired {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_expired();
function set_expired(value);

See Also

GiftCard Class
InSite.Model Namespace


FirstName Property

[image]

.NET Framework Class Library
GiftCard..::.FirstName Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FirstName As String
C#
[DataMemberAttribute]
public virtual string FirstName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ FirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

See Also

GiftCard Class
InSite.Model Namespace


GiftCardId Property

[image]

.NET Framework Class Library
GiftCard..::.GiftCardId Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property GiftCardId As Guid
C#
public virtual Guid GiftCardId { get; set; }
Visual C++
public:
virtual property Guid GiftCardId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_giftCardId();
function set_giftCardId(value);

See Also

GiftCard Class
InSite.Model Namespace


GiftCardNumber Property

[image]

.NET Framework Class Library
GiftCard..::.GiftCardNumber Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property GiftCardNumber As String
C#
[DataMemberAttribute]
[SortField]
public virtual string GiftCardNumber { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ GiftCardNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_giftCardNumber();
function set_giftCardNumber(value);

See Also

GiftCard Class
InSite.Model Namespace


GiftCardTransactions Property

[image]

.NET Framework Class Library
GiftCard..::.GiftCardTransactions Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property GiftCardTransactions As ChildList(Of GiftCardTransaction)
C#
[DataMemberAttribute]
public virtual ChildList<GiftCardTransaction> GiftCardTransactions { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<GiftCardTransaction^>^ GiftCardTransactions {
    ChildList<GiftCardTransaction^>^ get ();
    void set (ChildList<GiftCardTransaction^>^ value);
}
JavaScript
function get_giftCardTransactions();
function set_giftCardTransactions(value);

See Also

GiftCard Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
GiftCard..::.IsActive Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

GiftCard Class
InSite.Model Namespace


LastName Property

[image]

.NET Framework Class Library
GiftCard..::.LastName Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LastName As String
C#
[DataMemberAttribute]
public virtual string LastName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

See Also

GiftCard Class
InSite.Model Namespace


OrderLine Property

[image]

.NET Framework Class Library
GiftCard..::.OrderLine Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderLine As OrderLine
C#
public virtual OrderLine OrderLine { get; set; }
Visual C++
public:
virtual property OrderLine^ OrderLine {
    OrderLine^ get ();
    void set (OrderLine^ value);
}
JavaScript
function get_orderLine();
function set_orderLine(value);

See Also

GiftCard Class
InSite.Model Namespace


OrderNumber Property

[image]

.NET Framework Class Library
GiftCard..::.OrderNumber Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderNumber As String
C#
[DataMemberAttribute]
public virtual string OrderNumber { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumber();
function set_orderNumber(value);

See Also

GiftCard Class
InSite.Model Namespace


Purchased Property

[image]

.NET Framework Class Library
GiftCard..::.Purchased Property
GiftCard Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Purchased As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Purchased { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Purchased {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_purchased();
function set_purchased(value);

See Also

GiftCard Class
InSite.Model Namespace


GiftCardTransaction Class

[image]

.NET Framework Class Library
GiftCardTransaction Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class GiftCardTransaction _
    Inherits ModelBase(Of GiftCardTransaction)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class GiftCardTransaction : ModelBase<GiftCardTransaction>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class GiftCardTransaction : public ModelBase<GiftCardTransaction^>
JavaScript
InSite.Model.GiftCardTransaction = function();

Type.createClass(
    'InSite.Model.GiftCardTransaction',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(GiftCardTransaction>)>)
InSite.Model..::.GiftCardTransaction

See Also

GiftCardTransaction Members
InSite.Model Namespace


GiftCardTransaction Members

[image] [image]

.NET Framework Class Library
GiftCardTransaction Members
GiftCardTransaction Class Constructors Methods Fields Properties See Also Send Feedback

The GiftCardTransaction type exposes the following members.

Constructors

Name | Description
GiftCardTransaction | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrder |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
GiftCard |
GiftCardNumber |
GiftCardTransactionId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TransactionDate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

GiftCardTransaction Class
InSite.Model Namespace


GiftCardTransaction Constructor

[image] [image]

.NET Framework Class Library
GiftCardTransaction Constructor
GiftCardTransaction Class See Also Send Feedback

Overload List

Name | Description
GiftCardTransaction()()() |
GiftCardTransaction(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

GiftCardTransaction Class
GiftCardTransaction Members
InSite.Model Namespace


GiftCardTransaction Constructor

[image]

.NET Framework Class Library
GiftCardTransaction Constructor
GiftCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public GiftCardTransaction()
Visual C++
public:
GiftCardTransaction()
JavaScript
InSite.Model.GiftCardTransaction = function();

See Also

GiftCardTransaction Class
GiftCardTransaction Overload
InSite.Model Namespace


GiftCardTransaction Constructor (SearchMode)

[image]

.NET Framework Class Library
GiftCardTransaction Constructor (SearchMode)
GiftCardTransaction Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public GiftCardTransaction(
    SearchMode searchMode
)
Visual C++
public:
GiftCardTransaction(
    SearchMode searchMode
)
JavaScript
InSite.Model.GiftCardTransaction = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

GiftCardTransaction Class
GiftCardTransaction Overload
InSite.Model Namespace


GiftCardTransaction Fields

[image] [image]

.NET Framework Class Library
GiftCardTransaction Fields
GiftCardTransaction Class See Also Send Feedback

The GiftCardTransaction type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

GiftCardTransaction Class
InSite.Model Namespace


GiftCardTransaction Methods

[image] [image]

.NET Framework Class Library
GiftCardTransaction Methods
GiftCardTransaction Class See Also Send Feedback

The GiftCardTransaction type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

GiftCardTransaction Class
InSite.Model Namespace


GiftCardTransaction Properties

[image] [image]

.NET Framework Class Library
GiftCardTransaction Properties
GiftCardTransaction Class See Also Send Feedback

The GiftCardTransaction type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrder |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
GiftCard |
GiftCardNumber |
GiftCardTransactionId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TransactionDate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

GiftCardTransaction Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
GiftCardTransaction..::.Amount Property
GiftCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

GiftCardTransaction Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
GiftCardTransaction..::.CustomerOrder Property
GiftCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

GiftCardTransaction Class
InSite.Model Namespace


GiftCard Property

[image]

.NET Framework Class Library
GiftCardTransaction..::.GiftCard Property
GiftCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property GiftCard As GiftCard
C#
public virtual GiftCard GiftCard { get; set; }
Visual C++
public:
virtual property GiftCard^ GiftCard {
    GiftCard^ get ();
    void set (GiftCard^ value);
}
JavaScript
function get_giftCard();
function set_giftCard(value);

See Also

GiftCardTransaction Class
InSite.Model Namespace


GiftCardNumber Property

[image]

.NET Framework Class Library
GiftCardTransaction..::.GiftCardNumber Property
GiftCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property GiftCardNumber As String
C#
[DataMemberAttribute]
public virtual string GiftCardNumber { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ GiftCardNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_giftCardNumber();
function set_giftCardNumber(value);

See Also

GiftCardTransaction Class
InSite.Model Namespace


GiftCardTransactionId Property

[image]

.NET Framework Class Library
GiftCardTransaction..::.GiftCardTransactionId Property
GiftCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property GiftCardTransactionId As Guid
C#
public virtual Guid GiftCardTransactionId { get; set; }
Visual C++
public:
virtual property Guid GiftCardTransactionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_giftCardTransactionId();
function set_giftCardTransactionId(value);

See Also

GiftCardTransaction Class
InSite.Model Namespace


TransactionDate Property

[image]

.NET Framework Class Library
GiftCardTransaction..::.TransactionDate Property
GiftCardTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TransactionDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime TransactionDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime TransactionDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_transactionDate();
function set_transactionDate(value);

See Also

GiftCardTransaction Class
InSite.Model Namespace


HtmlRedirect Class

[image]

.NET Framework Class Library
HtmlRedirect Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class HtmlRedirect _
    Inherits ModelBase(Of HtmlRedirect)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class HtmlRedirect : ModelBase<HtmlRedirect>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class HtmlRedirect : public ModelBase<HtmlRedirect^>
JavaScript
InSite.Model.HtmlRedirect = function();

Type.createClass(
    'InSite.Model.HtmlRedirect',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(HtmlRedirect>)>)
InSite.Model..::.HtmlRedirect

See Also

HtmlRedirect Members
InSite.Model Namespace


HtmlRedirect Members

[image] [image]

.NET Framework Class Library
HtmlRedirect Members
HtmlRedirect Class Constructors Methods Fields Properties See Also Send Feedback

The HtmlRedirect type exposes the following members.

Constructors

Name | Description
HtmlRedirect | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByOldUrl |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
HtmlRedirectId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
NewUrl |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OldUrl |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

HtmlRedirect Class
InSite.Model Namespace


HtmlRedirect Constructor

[image] [image]

.NET Framework Class Library
HtmlRedirect Constructor
HtmlRedirect Class See Also Send Feedback

Overload List

Name | Description
HtmlRedirect()()() |
HtmlRedirect(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

HtmlRedirect Class
HtmlRedirect Members
InSite.Model Namespace


HtmlRedirect Constructor

[image]

.NET Framework Class Library
HtmlRedirect Constructor
HtmlRedirect Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public HtmlRedirect()
Visual C++
public:
HtmlRedirect()
JavaScript
InSite.Model.HtmlRedirect = function();

See Also

HtmlRedirect Class
HtmlRedirect Overload
InSite.Model Namespace


HtmlRedirect Constructor (SearchMode)

[image]

.NET Framework Class Library
HtmlRedirect Constructor (SearchMode)
HtmlRedirect Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public HtmlRedirect(
    SearchMode searchMode
)
Visual C++
public:
HtmlRedirect(
    SearchMode searchMode
)
JavaScript
InSite.Model.HtmlRedirect = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

HtmlRedirect Class
HtmlRedirect Overload
InSite.Model Namespace


HtmlRedirect Fields

[image] [image]

.NET Framework Class Library
HtmlRedirect Fields
HtmlRedirect Class See Also Send Feedback

The HtmlRedirect type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

HtmlRedirect Class
InSite.Model Namespace


HtmlRedirect Methods

[image] [image]

.NET Framework Class Library
HtmlRedirect Methods
HtmlRedirect Class See Also Send Feedback

The HtmlRedirect type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByOldUrl |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

HtmlRedirect Class
InSite.Model Namespace


GetByOldUrl Method

[image]

.NET Framework Class Library
HtmlRedirect..::.GetByOldUrl Method
HtmlRedirect Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByOldUrl ( _
    oldUrl As String _
) As HtmlRedirect
C#
public static HtmlRedirect GetByOldUrl(
    string oldUrl
)
Visual C++
public:
static HtmlRedirect^ GetByOldUrl(
    String^ oldUrl
)
JavaScript
InSite.Model.HtmlRedirect.getByOldUrl = function(oldUrl);

Parameters

oldUrl
Type: System..::.String

See Also

HtmlRedirect Class
InSite.Model Namespace


HtmlRedirect Properties

[image] [image]

.NET Framework Class Library
HtmlRedirect Properties
HtmlRedirect Class See Also Send Feedback

The HtmlRedirect type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
HtmlRedirectId |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
NewUrl |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OldUrl |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

HtmlRedirect Class
InSite.Model Namespace


HtmlRedirectId Property

[image]

.NET Framework Class Library
HtmlRedirect..::.HtmlRedirectId Property
HtmlRedirect Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property HtmlRedirectId As Guid
C#
public virtual Guid HtmlRedirectId { get; set; }
Visual C++
public:
virtual property Guid HtmlRedirectId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_htmlRedirectId();
function set_htmlRedirectId(value);

See Also

HtmlRedirect Class
InSite.Model Namespace


NewUrl Property

[image]

.NET Framework Class Library
HtmlRedirect..::.NewUrl Property
HtmlRedirect Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property NewUrl As String
C#
[DataMemberAttribute]
public virtual string NewUrl { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ NewUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_newUrl();
function set_newUrl(value);

See Also

HtmlRedirect Class
InSite.Model Namespace


OldUrl Property

[image]

.NET Framework Class Library
HtmlRedirect..::.OldUrl Property
HtmlRedirect Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property OldUrl As String
C#
[SortField]
[DataMemberAttribute]
public virtual string OldUrl { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ OldUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_oldUrl();
function set_oldUrl(value);

See Also

HtmlRedirect Class
InSite.Model Namespace


IBuildEmailValues Interface

[image]

.NET Framework Class Library
IBuildEmailValues Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IBuildEmailValues
C#
public interface IBuildEmailValues
Visual C++
public interface class IBuildEmailValues
JavaScript
InSite.Model.IBuildEmailValues = function();
InSite.Model.IBuildEmailValues.createInterface('InSite.Model.IBuildEmailValues');

See Also

IBuildEmailValues Members
InSite.Model Namespace


IBuildEmailValues Members

[image] [image]

.NET Framework Class Library
IBuildEmailValues Members
IBuildEmailValues Interface Methods See Also Send Feedback

The IBuildEmailValues type exposes the following members.

Methods

Name | Description
BuildOrderEmailToList |
BuildOrderEmailValues |
BuildShipmentEmailToList |
BuildShipmentEmailValues |

See Also

IBuildEmailValues Interface
InSite.Model Namespace


IBuildEmailValues Methods

[image] [image]

.NET Framework Class Library
IBuildEmailValues Methods
IBuildEmailValues Interface See Also Send Feedback

The IBuildEmailValues type exposes the following members.

Methods

Name | Description
BuildOrderEmailToList |
BuildOrderEmailValues |
BuildShipmentEmailToList |
BuildShipmentEmailValues |

See Also

IBuildEmailValues Interface
InSite.Model Namespace


BuildOrderEmailToList Method

[image]

.NET Framework Class Library
IBuildEmailValues..::.BuildOrderEmailToList Method
IBuildEmailValues Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function BuildOrderEmailToList ( _
    customerOrder As CustomerOrder _
) As String
C#
string BuildOrderEmailToList(
    CustomerOrder customerOrder
)
Visual C++
String^ BuildOrderEmailToList(
    CustomerOrder^ customerOrder
)
JavaScript
function buildOrderEmailToList(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

IBuildEmailValues Interface
InSite.Model Namespace


BuildOrderEmailValues Method

[image]

.NET Framework Class Library
IBuildEmailValues..::.BuildOrderEmailValues Method
IBuildEmailValues Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function BuildOrderEmailValues ( _
    customerOrder As CustomerOrder _
) As NameValueCollection
C#
NameValueCollection BuildOrderEmailValues(
    CustomerOrder customerOrder
)
Visual C++
NameValueCollection^ BuildOrderEmailValues(
    CustomerOrder^ customerOrder
)
JavaScript
function buildOrderEmailValues(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

IBuildEmailValues Interface
InSite.Model Namespace


BuildShipmentEmailToList Method

[image]

.NET Framework Class Library
IBuildEmailValues..::.BuildShipmentEmailToList Method
IBuildEmailValues Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function BuildShipmentEmailToList ( _
    shipment As Shipment _
) As String
C#
string BuildShipmentEmailToList(
    Shipment shipment
)
Visual C++
String^ BuildShipmentEmailToList(
    Shipment^ shipment
)
JavaScript
function buildShipmentEmailToList(shipment);

Parameters

shipment
Type: InSite.Model..::.Shipment

See Also

IBuildEmailValues Interface
InSite.Model Namespace


BuildShipmentEmailValues Method

[image]

.NET Framework Class Library
IBuildEmailValues..::.BuildShipmentEmailValues Method
IBuildEmailValues Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function BuildShipmentEmailValues ( _
    shipment As Shipment _
) As NameValueCollection
C#
NameValueCollection BuildShipmentEmailValues(
    Shipment shipment
)
Visual C++
NameValueCollection^ BuildShipmentEmailValues(
    Shipment^ shipment
)
JavaScript
function buildShipmentEmailValues(shipment);

Parameters

shipment
Type: InSite.Model..::.Shipment

See Also

IBuildEmailValues Interface
InSite.Model Namespace


ICustomerOrderProcessor Interface

[image]

.NET Framework Class Library
ICustomerOrderProcessor Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface ICustomerOrderProcessor
C#
public interface ICustomerOrderProcessor
Visual C++
public interface class ICustomerOrderProcessor
JavaScript
InSite.Model.ICustomerOrderProcessor = function();
InSite.Model.ICustomerOrderProcessor.createInterface('InSite.Model.ICustomerOrderProcessor');

See Also

ICustomerOrderProcessor Members
InSite.Model Namespace


ICustomerOrderProcessor Members

[image] [image]

.NET Framework Class Library
ICustomerOrderProcessor Members
ICustomerOrderProcessor Interface Methods See Also Send Feedback

The ICustomerOrderProcessor type exposes the following members.

Methods

Name | Description
SetUpOrder |
SubmitOrder |

See Also

ICustomerOrderProcessor Interface
InSite.Model Namespace


ICustomerOrderProcessor Methods

[image] [image]

.NET Framework Class Library
ICustomerOrderProcessor Methods
ICustomerOrderProcessor Interface See Also Send Feedback

The ICustomerOrderProcessor type exposes the following members.

Methods

Name | Description
SetUpOrder |
SubmitOrder |

See Also

ICustomerOrderProcessor Interface
InSite.Model Namespace


SetUpOrder Method

[image]

.NET Framework Class Library
ICustomerOrderProcessor..::.SetUpOrder Method
ICustomerOrderProcessor Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function SetUpOrder ( _
    customerOrder As CustomerOrder, _
    returnURL As String, _
    cancelURL As String _
) As String
C#
string SetUpOrder(
    CustomerOrder customerOrder,
    string returnURL,
    string cancelURL
)
Visual C++
String^ SetUpOrder(
    CustomerOrder^ customerOrder,
    String^ returnURL,
    String^ cancelURL
)
JavaScript
function setUpOrder(customerOrder, returnURL, cancelURL);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
returnURL
Type: System..::.String
cancelURL
Type: System..::.String

See Also

ICustomerOrderProcessor Interface
InSite.Model Namespace


SubmitOrder Method

[image]

.NET Framework Class Library
ICustomerOrderProcessor..::.SubmitOrder Method
ICustomerOrderProcessor Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub SubmitOrder ( _
    customerOrder As CustomerOrder _
)
C#
void SubmitOrder(
    CustomerOrder customerOrder
)
Visual C++
void SubmitOrder(
    CustomerOrder^ customerOrder
)
JavaScript
function submitOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

ICustomerOrderProcessor Interface
InSite.Model Namespace


IDataController Interface

[image]

.NET Framework Class Library
IDataController Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IDataController
C#
public interface IDataController
Visual C++
public interface class IDataController
JavaScript
InSite.Model.IDataController = function();
InSite.Model.IDataController.createInterface('InSite.Model.IDataController');

See Also

IDataController Members
InSite.Model Namespace


IDataController Members

[image] [image]

.NET Framework Class Library
IDataController Members
IDataController Interface Methods Properties See Also Send Feedback

The IDataController type exposes the following members.

Methods

Name | Description
BeginTransaction |
CommitTransaction |
Delete<(Of <(T>)>) |
Evict<(Of <(T>)>) |
FlushSession |
Get | Overloaded.
GetCount | Overloaded.
GetList | Overloaded.
GetSqlDataAdapter |
GetValues |
Initialize | Overloaded.
Insert<(Of <(T>)>) |
New<(Of <(T>)>) |
Refresh<(Of <(T>)>) |
RollBackTransaction |
SqlExecuteNonQuery |
SqlExecuteReader |
SqlExecuteScalar |
SqlExecuteStoredProcedure |
Update<(Of <(T>)>) |

Properties

Name | Description
FlushMode |

See Also

IDataController Interface
InSite.Model Namespace


IDataController Methods

[image] [image]

.NET Framework Class Library
IDataController Methods
IDataController Interface See Also Send Feedback

The IDataController type exposes the following members.

Methods

Name | Description
BeginTransaction |
CommitTransaction |
Delete<(Of <(T>)>) |
Evict<(Of <(T>)>) |
FlushSession |
Get | Overloaded.
GetCount | Overloaded.
GetList | Overloaded.
GetSqlDataAdapter |
GetValues |
Initialize | Overloaded.
Insert<(Of <(T>)>) |
New<(Of <(T>)>) |
Refresh<(Of <(T>)>) |
RollBackTransaction |
SqlExecuteNonQuery |
SqlExecuteReader |
SqlExecuteScalar |
SqlExecuteStoredProcedure |
Update<(Of <(T>)>) |

See Also

IDataController Interface
InSite.Model Namespace


BeginTransaction Method

[image]

.NET Framework Class Library
IDataController..::.BeginTransaction Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub BeginTransaction
C#
void BeginTransaction()
Visual C++
void BeginTransaction()
JavaScript
function beginTransaction();

See Also

IDataController Interface
InSite.Model Namespace


CommitTransaction Method

[image]

.NET Framework Class Library
IDataController..::.CommitTransaction Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub CommitTransaction
C#
void CommitTransaction()
Visual C++
void CommitTransaction()
JavaScript
function commitTransaction();

See Also

IDataController Interface
InSite.Model Namespace


Delete(T) Method

[image]

.NET Framework Class Library
IDataController..::.Delete<(Of <(T>)>) Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub Delete(Of T) ( _
    deleted As T _
)
C#
void Delete<T>(
    T deleted
)
Visual C++
generic<typename T>
void Delete(
    T deleted
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

deleted
Type: T

Type Parameters

T

See Also

IDataController Interface
InSite.Model Namespace


Evict(T) Method

[image]

.NET Framework Class Library
IDataController..::.Evict<(Of <(T>)>) Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub Evict(Of T) ( _
    evicted As T _
)
C#
void Evict<T>(
    T evicted
)
Visual C++
generic<typename T>
void Evict(
    T evicted
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

evicted
Type: T

Type Parameters

T

See Also

IDataController Interface
InSite.Model Namespace


FlushSession Method

[image]

.NET Framework Class Library
IDataController..::.FlushSession Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub FlushSession
C#
void FlushSession()
Visual C++
void FlushSession()
JavaScript
function flushSession();

See Also

IDataController Interface
InSite.Model Namespace


Get Method

[image] [image]

.NET Framework Class Library
IDataController..::.Get Method
IDataController Interface See Also Send Feedback

Overload List

Name | Description
Get<(Of <(T>)>)(Guid) |
Get<(Of <(T>)>)(String) |
Get<(Of <(T>)>)(String, String) |

See Also

IDataController Interface
IDataController Members
InSite.Model Namespace


Get(T) Method (Guid)

[image]

.NET Framework Class Library
IDataController..::.Get<(Of <(T>)>) Method (Guid)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function Get(Of T) ( _
    id As Guid _
) As T
C#
T Get<T>(
    Guid id
)
Visual C++
generic<typename T>
T Get(
    Guid id
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

id
Type: System..::.Guid

Type Parameters

T

See Also

IDataController Interface
Get Overload
InSite.Model Namespace


Get(T) Method (String)

[image]

.NET Framework Class Library
IDataController..::.Get<(Of <(T>)>) Method (String)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function Get(Of T) ( _
    id As String _
) As T
C#
T Get<T>(
    string id
)
Visual C++
generic<typename T>
T Get(
    String^ id
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

id
Type: System..::.String

Type Parameters

T

See Also

IDataController Interface
Get Overload
InSite.Model Namespace


Get(T) Method (String, String)

[image]

.NET Framework Class Library
IDataController..::.Get<(Of <(T>)>) Method (String, String)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function Get(Of T) ( _
    propertyName As String, _
    propertyValue As String _
) As T
C#
T Get<T>(
    string propertyName,
    string propertyValue
)
Visual C++
generic<typename T>
T Get(
    String^ propertyName,
    String^ propertyValue
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: System..::.String
propertyValue
Type: System..::.String

Type Parameters

T

See Also

IDataController Interface
Get Overload
InSite.Model Namespace


GetCount Method

[image] [image]

.NET Framework Class Library
IDataController..::.GetCount Method
IDataController Interface See Also Send Feedback

Overload List

Name | Description
GetCount<(Of <(T>)>)()()() |
GetCount<(Of <(T>)>)(String, Hashtable, NameValueCollection) |

See Also

IDataController Interface
IDataController Members
InSite.Model Namespace


GetCount(T) Method

[image]

.NET Framework Class Library
IDataController..::.GetCount<(Of <(T>)>) Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetCount(Of T) As Integer
C#
int GetCount<T>()
Visual C++
generic<typename T>
int GetCount()
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

See Also

IDataController Interface
GetCount Overload
InSite.Model Namespace


GetCount(T) Method (String, Hashtable, NameValueCollection)

[image]

.NET Framework Class Library
IDataController..::.GetCount<(Of <(T>)>) Method (String, Hashtable, NameValueCollection)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetCount(Of T) ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection _
) As Integer
C#
int GetCount<T>(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions
)
Visual C++
generic<typename T>
int GetCount(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection

Type Parameters

T

See Also

IDataController Interface
GetCount Overload
InSite.Model Namespace


GetList Method

[image] [image]

.NET Framework Class Library
IDataController..::.GetList Method
IDataController Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(T>)>)()()() |
GetList<(Of <(T>)>)(String) |
GetList<(Of <(T>)>)(T, String) |
GetList<(Of <(T>)>)(String, Hashtable, NameValueCollection) |
GetList<(Of <(T>)>)(String, Int32, Int32) |
GetList<(Of <(T>)>)(String, String, String) |
GetList<(Of <(T>)>)(T, String, Int32, Int32) |
GetList<(Of <(T>)>)(String, Hashtable, NameValueCollection, Int32, Int32) |
GetList<(Of <(T>)>)(String, String, String, Int32, Int32) |

See Also

IDataController Interface
IDataController Members
InSite.Model Namespace


GetList(T) Method

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) As IList(Of T)
C#
IList<T> GetList<T>()
Visual C++
generic<typename T>
IList<T>^ GetList()
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetList(T) Method (String)

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method (String)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) ( _
    sort As String _
) As IList(Of T)
C#
IList<T> GetList<T>(
    string sort
)
Visual C++
generic<typename T>
IList<T>^ GetList(
    String^ sort
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

sort
Type: System..::.String

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetList(T) Method (T, String)

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method (T, String)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) ( _
    query As T, _
    sort As String _
) As IList(Of T)
C#
IList<T> GetList<T>(
    T query,
    string sort
)
Visual C++
generic<typename T>
IList<T>^ GetList(
    T query,
    String^ sort
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: T
sort
Type: System..::.String

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetList(T) Method (String, Hashtable, NameValueCollection)

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method (String, Hashtable, NameValueCollection)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection _
) As IList(Of T)
C#
IList<T> GetList<T>(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions
)
Visual C++
generic<typename T>
IList<T>^ GetList(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetList(T) Method (String, Int32, Int32)

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method (String, Int32, Int32)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) ( _
    sort As String, _
    start As Integer, _
    size As Integer _
) As IList(Of T)
C#
IList<T> GetList<T>(
    string sort,
    int start,
    int size
)
Visual C++
generic<typename T>
IList<T>^ GetList(
    String^ sort,
    int start,
    int size
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

sort
Type: System..::.String
start
Type: System..::.Int32
size
Type: System..::.Int32

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetList(T) Method (String, String, String)

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method (String, String, String)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) ( _
    propertyName As String, _
    propertyValue As String, _
    sort As String _
) As IList(Of T)
C#
IList<T> GetList<T>(
    string propertyName,
    string propertyValue,
    string sort
)
Visual C++
generic<typename T>
IList<T>^ GetList(
    String^ propertyName,
    String^ propertyValue,
    String^ sort
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: System..::.String
propertyValue
Type: System..::.String
sort
Type: System..::.String

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetList(T) Method (T, String, Int32, Int32)

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method (T, String, Int32, Int32)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) ( _
    query As T, _
    sort As String, _
    start As Integer, _
    size As Integer _
) As IList(Of T)
C#
IList<T> GetList<T>(
    T query,
    string sort,
    int start,
    int size
)
Visual C++
generic<typename T>
IList<T>^ GetList(
    T query,
    String^ sort,
    int start,
    int size
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: T
sort
Type: System..::.String
start
Type: System..::.Int32
size
Type: System..::.Int32

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetList(T) Method (String, Hashtable, NameValueCollection, Int32, Int32)

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method (String, Hashtable, NameValueCollection, Int32, Int32)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection, _
    start As Integer, _
    size As Integer _
) As IList(Of T)
C#
IList<T> GetList<T>(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions,
    int start,
    int size
)
Visual C++
generic<typename T>
IList<T>^ GetList(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions,
    int start,
    int size
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection
start
Type: System..::.Int32
size
Type: System..::.Int32

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetList(T) Method (String, String, String, Int32, Int32)

[image]

.NET Framework Class Library
IDataController..::.GetList<(Of <(T>)>) Method (String, String, String, Int32, Int32)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetList(Of T) ( _
    propertyName As String, _
    propertyValue As String, _
    sort As String, _
    start As Integer, _
    size As Integer _
) As IList(Of T)
C#
IList<T> GetList<T>(
    string propertyName,
    string propertyValue,
    string sort,
    int start,
    int size
)
Visual C++
generic<typename T>
IList<T>^ GetList(
    String^ propertyName,
    String^ propertyValue,
    String^ sort,
    int start,
    int size
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: System..::.String
propertyValue
Type: System..::.String
sort
Type: System..::.String
start
Type: System..::.Int32
size
Type: System..::.Int32

Type Parameters

T

See Also

IDataController Interface
GetList Overload
InSite.Model Namespace


GetSqlDataAdapter Method

[image]

.NET Framework Class Library
IDataController..::.GetSqlDataAdapter Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetSqlDataAdapter ( _
    sqlQuery As String _
) As SqlDataAdapter
C#
SqlDataAdapter GetSqlDataAdapter(
    string sqlQuery
)
Visual C++
SqlDataAdapter^ GetSqlDataAdapter(
    String^ sqlQuery
)
JavaScript
function getSqlDataAdapter(sqlQuery);

Parameters

sqlQuery
Type: System..::.String

See Also

IDataController Interface
InSite.Model Namespace


GetValues Method

[image]

.NET Framework Class Library
IDataController..::.GetValues Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function GetValues ( _
    query As String _
) As IList(Of String)
C#
IList<string> GetValues(
    string query
)
Visual C++
IList<String^>^ GetValues(
    String^ query
)
JavaScript
function getValues(query);

Parameters

query
Type: System..::.String

See Also

IDataController Interface
InSite.Model Namespace


Initialize Method

[image] [image]

.NET Framework Class Library
IDataController..::.Initialize Method
IDataController Interface See Also Send Feedback

Overload List

Name | Description
Initialize<(Of <(T>)>)(IList<(Of <(T>)>)) |
Initialize(Object) |

See Also

IDataController Interface
IDataController Members
InSite.Model Namespace


Initialize(T) Method (IList(T))

[image]

.NET Framework Class Library
IDataController..::.Initialize<(Of <(T>)>) Method (IList<(Of <(T>)>))
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub Initialize(Of T) ( _
    initializeList As IList(Of T) _
)
C#
void Initialize<T>(
    IList<T> initializeList
)
Visual C++
generic<typename T>
void Initialize(
    IList<T>^ initializeList
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

initializeList
Type: System.Collections.Generic..::.IList <(Of <(T>)>)

Type Parameters

T

See Also

IDataController Interface
Initialize Overload
InSite.Model Namespace


Initialize Method (Object)

[image]

.NET Framework Class Library
IDataController..::.Initialize Method (Object)
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub Initialize ( _
    proxy As Object _
)
C#
void Initialize(
    Object proxy
)
Visual C++
void Initialize(
    Object^ proxy
)
JavaScript
function initialize(proxy);

Parameters

proxy
Type: System..::.Object

See Also

IDataController Interface
Initialize Overload
InSite.Model Namespace


Insert(T) Method

[image]

.NET Framework Class Library
IDataController..::.Insert<(Of <(T>)>) Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub Insert(Of T) ( _
    inserted As T _
)
C#
void Insert<T>(
    T inserted
)
Visual C++
generic<typename T>
void Insert(
    T inserted
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

inserted
Type: T

Type Parameters

T

See Also

IDataController Interface
InSite.Model Namespace


New(T) Method

[image]

.NET Framework Class Library
IDataController..::.New<(Of <(T>)>) Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function New(Of T As {Class, New}) As T
C#
T New<T>()
where T : class, new()
Visual C++
generic<typename T>
where T : ref class, gcnew()
T New()
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

See Also

IDataController Interface
InSite.Model Namespace


Refresh(T) Method

[image]

.NET Framework Class Library
IDataController..::.Refresh<(Of <(T>)>) Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub Refresh(Of T) ( _
    refreshed As T _
)
C#
void Refresh<T>(
    T refreshed
)
Visual C++
generic<typename T>
void Refresh(
    T refreshed
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

refreshed
Type: T

Type Parameters

T

See Also

IDataController Interface
InSite.Model Namespace


RollBackTransaction Method

[image]

.NET Framework Class Library
IDataController..::.RollBackTransaction Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub RollBackTransaction
C#
void RollBackTransaction()
Visual C++
void RollBackTransaction()
JavaScript
function rollBackTransaction();

See Also

IDataController Interface
InSite.Model Namespace


SqlExecuteNonQuery Method

[image]

.NET Framework Class Library
IDataController..::.SqlExecuteNonQuery Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub SqlExecuteNonQuery ( _
    sqlQuery As String _
)
C#
void SqlExecuteNonQuery(
    string sqlQuery
)
Visual C++
void SqlExecuteNonQuery(
    String^ sqlQuery
)
JavaScript
function sqlExecuteNonQuery(sqlQuery);

Parameters

sqlQuery
Type: System..::.String

See Also

IDataController Interface
InSite.Model Namespace


SqlExecuteReader Method

[image]

.NET Framework Class Library
IDataController..::.SqlExecuteReader Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function SqlExecuteReader ( _
    sqlQuery As String _
) As SqlDataReader
C#
SqlDataReader SqlExecuteReader(
    string sqlQuery
)
Visual C++
SqlDataReader^ SqlExecuteReader(
    String^ sqlQuery
)
JavaScript
function sqlExecuteReader(sqlQuery);

Parameters

sqlQuery
Type: System..::.String

See Also

IDataController Interface
InSite.Model Namespace


SqlExecuteScalar Method

[image]

.NET Framework Class Library
IDataController..::.SqlExecuteScalar Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function SqlExecuteScalar ( _
    sqlQuery As String _
) As Object
C#
Object SqlExecuteScalar(
    string sqlQuery
)
Visual C++
Object^ SqlExecuteScalar(
    String^ sqlQuery
)
JavaScript
function sqlExecuteScalar(sqlQuery);

Parameters

sqlQuery
Type: System..::.String

See Also

IDataController Interface
InSite.Model Namespace


SqlExecuteStoredProcedure Method

[image]

.NET Framework Class Library
IDataController..::.SqlExecuteStoredProcedure Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function SqlExecuteStoredProcedure ( _
    storedProcedureName As String, _
    parameters As List(Of SqlParameter) _
) As Integer
C#
int SqlExecuteStoredProcedure(
    string storedProcedureName,
    List<SqlParameter> parameters
)
Visual C++
int SqlExecuteStoredProcedure(
    String^ storedProcedureName,
    List<SqlParameter^>^ parameters
)
JavaScript
function sqlExecuteStoredProcedure(storedProcedureName, parameters);

Parameters

storedProcedureName
Type: System..::.String
parameters
Type: System.Collections.Generic..::.List <(Of <( SqlParameter >)>)

See Also

IDataController Interface
InSite.Model Namespace


Update(T) Method

[image]

.NET Framework Class Library
IDataController..::.Update<(Of <(T>)>) Method
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub Update(Of T) ( _
    updated As T _
)
C#
void Update<T>(
    T updated
)
Visual C++
generic<typename T>
void Update(
    T updated
)
JavaScript
JavaScript does not support generic types or methods.

Parameters

updated
Type: T

Type Parameters

T

See Also

IDataController Interface
InSite.Model Namespace


IDataController Properties

[image] [image]

.NET Framework Class Library
IDataController Properties
IDataController Interface See Also Send Feedback

The IDataController type exposes the following members.

Properties

Name | Description
FlushMode |

See Also

IDataController Interface
InSite.Model Namespace


FlushMode Property

[image]

.NET Framework Class Library
IDataController..::.FlushMode Property
IDataController Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property FlushMode As FlushModeEnum
C#
FlushModeEnum FlushMode { get; set; }
Visual C++
property FlushModeEnum FlushMode {
    FlushModeEnum get ();
    void set (FlushModeEnum value);
}
JavaScript
function get_flushMode();
function set_flushMode(value);

See Also

IDataController Interface
InSite.Model Namespace


IEmailProcessor Interface

[image]

.NET Framework Class Library
IEmailProcessor Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IEmailProcessor
C#
public interface IEmailProcessor
Visual C++
public interface class IEmailProcessor
JavaScript
InSite.Model.IEmailProcessor = function();
InSite.Model.IEmailProcessor.createInterface('InSite.Model.IEmailProcessor');

See Also

IEmailProcessor Members
InSite.Model Namespace


IEmailProcessor Members

[image] [image]

.NET Framework Class Library
IEmailProcessor Members
IEmailProcessor Interface Methods See Also Send Feedback

The IEmailProcessor type exposes the following members.

Methods

Name | Description
SendEmail |

See Also

IEmailProcessor Interface
InSite.Model Namespace


IEmailProcessor Methods

[image] [image]

.NET Framework Class Library
IEmailProcessor Methods
IEmailProcessor Interface See Also Send Feedback

The IEmailProcessor type exposes the following members.

Methods

Name | Description
SendEmail |

See Also

IEmailProcessor Interface
InSite.Model Namespace


SendEmail Method

[image]

.NET Framework Class Library
IEmailProcessor..::.SendEmail Method
IEmailProcessor Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub SendEmail ( _
    toAddress As String, _
    fromAddress As String, _
    subject As String, _
    body As String _
)
C#
void SendEmail(
    string toAddress,
    string fromAddress,
    string subject,
    string body
)
Visual C++
void SendEmail(
    String^ toAddress,
    String^ fromAddress,
    String^ subject,
    String^ body
)
JavaScript
function sendEmail(toAddress, fromAddress, subject, body);

Parameters

toAddress
Type: System..::.String
fromAddress
Type: System..::.String
subject
Type: System..::.String
body
Type: System..::.String

See Also

IEmailProcessor Interface
InSite.Model Namespace


InventoryTransaction Class

[image]

.NET Framework Class Library
InventoryTransaction Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class InventoryTransaction _
    Inherits ModelBase(Of InventoryTransaction)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class InventoryTransaction : ModelBase<InventoryTransaction>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class InventoryTransaction : public ModelBase<InventoryTransaction^>
JavaScript
InSite.Model.InventoryTransaction = function();

Type.createClass(
    'InSite.Model.InventoryTransaction',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(InventoryTransaction>)>)
InSite.Model..::.InventoryTransaction

See Also

InventoryTransaction Members
InSite.Model Namespace


InventoryTransaction Members

[image] [image]

.NET Framework Class Library
InventoryTransaction Members
InventoryTransaction Class Constructors Methods Fields Properties See Also Send Feedback

The InventoryTransaction type exposes the following members.

Constructors

Name | Description
InventoryTransaction | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InventoryTransactionId |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TransactionDate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

InventoryTransaction Class
InSite.Model Namespace


InventoryTransaction Constructor

[image] [image]

.NET Framework Class Library
InventoryTransaction Constructor
InventoryTransaction Class See Also Send Feedback

Overload List

Name | Description
InventoryTransaction()()() |
InventoryTransaction(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

InventoryTransaction Class
InventoryTransaction Members
InSite.Model Namespace


InventoryTransaction Constructor

[image]

.NET Framework Class Library
InventoryTransaction Constructor
InventoryTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InventoryTransaction()
Visual C++
public:
InventoryTransaction()
JavaScript
InSite.Model.InventoryTransaction = function();

See Also

InventoryTransaction Class
InventoryTransaction Overload
InSite.Model Namespace


InventoryTransaction Constructor (SearchMode)

[image]

.NET Framework Class Library
InventoryTransaction Constructor (SearchMode)
InventoryTransaction Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public InventoryTransaction(
    SearchMode searchMode
)
Visual C++
public:
InventoryTransaction(
    SearchMode searchMode
)
JavaScript
InSite.Model.InventoryTransaction = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

InventoryTransaction Class
InventoryTransaction Overload
InSite.Model Namespace


InventoryTransaction Fields

[image] [image]

.NET Framework Class Library
InventoryTransaction Fields
InventoryTransaction Class See Also Send Feedback

The InventoryTransaction type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

InventoryTransaction Class
InSite.Model Namespace


InventoryTransaction Methods

[image] [image]

.NET Framework Class Library
InventoryTransaction Methods
InventoryTransaction Class See Also Send Feedback

The InventoryTransaction type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

InventoryTransaction Class
InSite.Model Namespace


InventoryTransaction Properties

[image] [image]

.NET Framework Class Library
InventoryTransaction Properties
InventoryTransaction Class See Also Send Feedback

The InventoryTransaction type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InventoryTransactionId |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TransactionDate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

InventoryTransaction Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
InventoryTransaction..::.Amount Property
InventoryTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

InventoryTransaction Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
InventoryTransaction..::.Description Property
InventoryTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

InventoryTransaction Class
InSite.Model Namespace


InventoryTransactionId Property

[image]

.NET Framework Class Library
InventoryTransaction..::.InventoryTransactionId Property
InventoryTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InventoryTransactionId As Guid
C#
public virtual Guid InventoryTransactionId { get; set; }
Visual C++
public:
virtual property Guid InventoryTransactionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_inventoryTransactionId();
function set_inventoryTransactionId(value);

See Also

InventoryTransaction Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
InventoryTransaction..::.Product Property
InventoryTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

InventoryTransaction Class
InSite.Model Namespace


TransactionDate Property

[image]

.NET Framework Class Library
InventoryTransaction..::.TransactionDate Property
InventoryTransaction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property TransactionDate As DateTime
C#
[DataMemberAttribute]
[SortField]
public virtual DateTime TransactionDate { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property DateTime TransactionDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_transactionDate();
function set_transactionDate(value);

See Also

InventoryTransaction Class
InSite.Model Namespace


Invoice Class

[image]

.NET Framework Class Library
Invoice Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Invoice _
    Inherits ModelBase(Of Invoice)
C#
[SerializableAttribute]
public class Invoice : ModelBase<Invoice>
Visual C++
[SerializableAttribute]
public ref class Invoice : public ModelBase<Invoice^>
JavaScript
InSite.Model.Invoice = function();

Type.createClass(
    'InSite.Model.Invoice',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Invoice>)>)
InSite.Model..::.Invoice

See Also

Invoice Members
InSite.Model Namespace


Invoice Members

[image] [image]

.NET Framework Class Library
Invoice Members
Invoice Class Constructors Methods Fields Properties See Also Send Feedback

The Invoice type exposes the following members.

Constructors

Name | Description
Invoice | Overloaded.

Methods

Name | Description
AddInvoiceLine |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByNumberSequence |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveInvoiceLine |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
BillType |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Cost |
Customer |
CustomerPO |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Discount |
DONumber |
ECCode |
ExchangeRate |
Freight |
FreightTaxCode1 |
FreightTaxCode2 |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InvoiceDate |
InvoiceId |
InvoiceLines |
InvoiceNumber |
InvoiceSent |
InvoiceSequence |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MiscellaneousCharges |
MiscellaneousTaxCode1 |
MiscellaneousTaxCode2 |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderNumber |
OriginalTotal |
PrepaidAmount |
Price |
QuantityOfPackages |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Salesman |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipCode |
ShipDate |
ShipTo |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
SubTotal |
TaxCode1 |
TaxCode2 |
TaxDate |
TermsCode |
Total |
TotalTax |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UseExchangeRate |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Invoice Class
InSite.Model Namespace


Invoice Constructor

[image] [image]

.NET Framework Class Library
Invoice Constructor
Invoice Class See Also Send Feedback

Overload List

Name | Description
Invoice()()() |
Invoice(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Invoice Class
Invoice Members
InSite.Model Namespace


Invoice Constructor

[image]

.NET Framework Class Library
Invoice Constructor
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Invoice()
Visual C++
public:
Invoice()
JavaScript
InSite.Model.Invoice = function();

See Also

Invoice Class
Invoice Overload
InSite.Model Namespace


Invoice Constructor (SearchMode)

[image]

.NET Framework Class Library
Invoice Constructor (SearchMode)
Invoice Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Invoice(
    SearchMode searchMode
)
Visual C++
public:
Invoice(
    SearchMode searchMode
)
JavaScript
InSite.Model.Invoice = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Invoice Class
Invoice Overload
InSite.Model Namespace


Invoice Fields

[image] [image]

.NET Framework Class Library
Invoice Fields
Invoice Class See Also Send Feedback

The Invoice type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Invoice Class
InSite.Model Namespace


Invoice Methods

[image] [image]

.NET Framework Class Library
Invoice Methods
Invoice Class See Also Send Feedback

The Invoice type exposes the following members.

Methods

Name | Description
AddInvoiceLine |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByNumberSequence |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveInvoiceLine |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Invoice Class
InSite.Model Namespace


AddInvoiceLine Method

[image]

.NET Framework Class Library
Invoice..::.AddInvoiceLine Method
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddInvoiceLine ( _
    value As InvoiceLine _
)
C#
public virtual void AddInvoiceLine(
    InvoiceLine value
)
Visual C++
public:
virtual void AddInvoiceLine(
    InvoiceLine^ value
)
JavaScript
function addInvoiceLine(value);

Parameters

value
Type: InSite.Model..::.InvoiceLine

See Also

Invoice Class
InSite.Model Namespace


GetByNumberSequence Method

[image]

.NET Framework Class Library
Invoice..::.GetByNumberSequence Method
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByNumberSequence ( _
    number As String, _
    sequence As Integer _
) As Invoice
C#
public static Invoice GetByNumberSequence(
    string number,
    int sequence
)
Visual C++
public:
static Invoice^ GetByNumberSequence(
    String^ number,
    int sequence
)
JavaScript
InSite.Model.Invoice.getByNumberSequence = function(number, sequence);

Parameters

number
Type: System..::.String
sequence
Type: System..::.Int32

See Also

Invoice Class
InSite.Model Namespace


RemoveInvoiceLine Method

[image]

.NET Framework Class Library
Invoice..::.RemoveInvoiceLine Method
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveInvoiceLine ( _
    value As InvoiceLine _
)
C#
public virtual void RemoveInvoiceLine(
    InvoiceLine value
)
Visual C++
public:
virtual void RemoveInvoiceLine(
    InvoiceLine^ value
)
JavaScript
function removeInvoiceLine(value);

Parameters

value
Type: InSite.Model..::.InvoiceLine

See Also

Invoice Class
InSite.Model Namespace


Invoice Properties

[image] [image]

.NET Framework Class Library
Invoice Properties
Invoice Class See Also Send Feedback

The Invoice type exposes the following members.

Properties

Name | Description
BillType |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Cost |
Customer |
CustomerPO |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Discount |
DONumber |
ECCode |
ExchangeRate |
Freight |
FreightTaxCode1 |
FreightTaxCode2 |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InvoiceDate |
InvoiceId |
InvoiceLines |
InvoiceNumber |
InvoiceSent |
InvoiceSequence |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MiscellaneousCharges |
MiscellaneousTaxCode1 |
MiscellaneousTaxCode2 |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderNumber |
OriginalTotal |
PrepaidAmount |
Price |
QuantityOfPackages |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Salesman |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipCode |
ShipDate |
ShipTo |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
SubTotal |
TaxCode1 |
TaxCode2 |
TaxDate |
TermsCode |
Total |
TotalTax |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UseExchangeRate |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Invoice Class
InSite.Model Namespace


BillType Property

[image]

.NET Framework Class Library
Invoice..::.BillType Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property BillType As String
C#
public virtual string BillType { get; set; }
Visual C++
public:
virtual property String^ BillType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_billType();
function set_billType(value);

See Also

Invoice Class
InSite.Model Namespace


Cost Property

[image]

.NET Framework Class Library
Invoice..::.Cost Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Cost As Decimal
C#
public virtual decimal Cost { get; set; }
Visual C++
public:
virtual property Decimal Cost {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_cost();
function set_cost(value);

See Also

Invoice Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
Invoice..::.Customer Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customer As Customer
C#
public virtual Customer Customer { get; set; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

Invoice Class
InSite.Model Namespace


CustomerPO Property

[image]

.NET Framework Class Library
Invoice..::.CustomerPO Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerPO As String
C#
public virtual string CustomerPO { get; set; }
Visual C++
public:
virtual property String^ CustomerPO {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerPO();
function set_customerPO(value);

See Also

Invoice Class
InSite.Model Namespace


Discount Property

[image]

.NET Framework Class Library
Invoice..::.Discount Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Discount As Decimal
C#
public virtual decimal Discount { get; set; }
Visual C++
public:
virtual property Decimal Discount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discount();
function set_discount(value);

See Also

Invoice Class
InSite.Model Namespace


DONumber Property

[image]

.NET Framework Class Library
Invoice..::.DONumber Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DONumber As String
C#
public virtual string DONumber { get; set; }
Visual C++
public:
virtual property String^ DONumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_doNumber();
function set_doNumber(value);

See Also

Invoice Class
InSite.Model Namespace


ECCode Property

[image]

.NET Framework Class Library
Invoice..::.ECCode Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ECCode As String
C#
public virtual string ECCode { get; set; }
Visual C++
public:
virtual property String^ ECCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ecCode();
function set_ecCode(value);

See Also

Invoice Class
InSite.Model Namespace


ExchangeRate Property

[image]

.NET Framework Class Library
Invoice..::.ExchangeRate Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ExchangeRate As Decimal
C#
public virtual decimal ExchangeRate { get; set; }
Visual C++
public:
virtual property Decimal ExchangeRate {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_exchangeRate();
function set_exchangeRate(value);

See Also

Invoice Class
InSite.Model Namespace


Freight Property

[image]

.NET Framework Class Library
Invoice..::.Freight Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Freight As Decimal
C#
public virtual decimal Freight { get; set; }
Visual C++
public:
virtual property Decimal Freight {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_freight();
function set_freight(value);

See Also

Invoice Class
InSite.Model Namespace


FreightTaxCode1 Property

[image]

.NET Framework Class Library
Invoice..::.FreightTaxCode1 Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FreightTaxCode1 As String
C#
public virtual string FreightTaxCode1 { get; set; }
Visual C++
public:
virtual property String^ FreightTaxCode1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_freightTaxCode1();
function set_freightTaxCode1(value);

See Also

Invoice Class
InSite.Model Namespace


FreightTaxCode2 Property

[image]

.NET Framework Class Library
Invoice..::.FreightTaxCode2 Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FreightTaxCode2 As String
C#
public virtual string FreightTaxCode2 { get; set; }
Visual C++
public:
virtual property String^ FreightTaxCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_freightTaxCode2();
function set_freightTaxCode2(value);

See Also

Invoice Class
InSite.Model Namespace


InvoiceDate Property

[image]

.NET Framework Class Library
Invoice..::.InvoiceDate Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceDate As DateTime
C#
public virtual DateTime InvoiceDate { get; set; }
Visual C++
public:
virtual property DateTime InvoiceDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_invoiceDate();
function set_invoiceDate(value);

See Also

Invoice Class
InSite.Model Namespace


InvoiceId Property

[image]

.NET Framework Class Library
Invoice..::.InvoiceId Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceId As Guid
C#
public virtual Guid InvoiceId { get; set; }
Visual C++
public:
virtual property Guid InvoiceId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_invoiceId();
function set_invoiceId(value);

See Also

Invoice Class
InSite.Model Namespace


InvoiceLines Property

[image]

.NET Framework Class Library
Invoice..::.InvoiceLines Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceLines As ChildList(Of InvoiceLine)
C#
public virtual ChildList<InvoiceLine> InvoiceLines { get; private set; }
Visual C++
public:
virtual property ChildList<InvoiceLine^>^ InvoiceLines {
    ChildList<InvoiceLine^>^ get ();
    void set (ChildList<InvoiceLine^>^ value);
}
JavaScript
function get_invoiceLines();
function set_invoiceLines(value);

See Also

Invoice Class
InSite.Model Namespace


InvoiceNumber Property

[image]

.NET Framework Class Library
Invoice..::.InvoiceNumber Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceNumber As String
C#
public virtual string InvoiceNumber { get; set; }
Visual C++
public:
virtual property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceNumber();
function set_invoiceNumber(value);

See Also

Invoice Class
InSite.Model Namespace


InvoiceSent Property

[image]

.NET Framework Class Library
Invoice..::.InvoiceSent Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceSent As Nullable(Of DateTime)
C#
public virtual Nullable<DateTime> InvoiceSent { get; set; }
Visual C++
public:
virtual property Nullable<DateTime> InvoiceSent {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_invoiceSent();
function set_invoiceSent(value);

See Also

Invoice Class
InSite.Model Namespace


InvoiceSequence Property

[image]

.NET Framework Class Library
Invoice..::.InvoiceSequence Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceSequence As Integer
C#
public virtual int InvoiceSequence { get; set; }
Visual C++
public:
virtual property int InvoiceSequence {
    int get ();
    void set (int value);
}
JavaScript
function get_invoiceSequence();
function set_invoiceSequence(value);

See Also

Invoice Class
InSite.Model Namespace


MiscellaneousCharges Property

[image]

.NET Framework Class Library
Invoice..::.MiscellaneousCharges Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property MiscellaneousCharges As Decimal
C#
public virtual decimal MiscellaneousCharges { get; set; }
Visual C++
public:
virtual property Decimal MiscellaneousCharges {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_miscellaneousCharges();
function set_miscellaneousCharges(value);

See Also

Invoice Class
InSite.Model Namespace


MiscellaneousTaxCode1 Property

[image]

.NET Framework Class Library
Invoice..::.MiscellaneousTaxCode1 Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property MiscellaneousTaxCode1 As String
C#
public virtual string MiscellaneousTaxCode1 { get; set; }
Visual C++
public:
virtual property String^ MiscellaneousTaxCode1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_miscellaneousTaxCode1();
function set_miscellaneousTaxCode1(value);

See Also

Invoice Class
InSite.Model Namespace


MiscellaneousTaxCode2 Property

[image]

.NET Framework Class Library
Invoice..::.MiscellaneousTaxCode2 Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property MiscellaneousTaxCode2 As String
C#
public virtual string MiscellaneousTaxCode2 { get; set; }
Visual C++
public:
virtual property String^ MiscellaneousTaxCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_miscellaneousTaxCode2();
function set_miscellaneousTaxCode2(value);

See Also

Invoice Class
InSite.Model Namespace


OrderNumber Property

[image]

.NET Framework Class Library
Invoice..::.OrderNumber Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderNumber As String
C#
public virtual string OrderNumber { get; set; }
Visual C++
public:
virtual property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumber();
function set_orderNumber(value);

See Also

Invoice Class
InSite.Model Namespace


OriginalTotal Property

[image]

.NET Framework Class Library
Invoice..::.OriginalTotal Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OriginalTotal As Decimal
C#
public virtual decimal OriginalTotal { get; set; }
Visual C++
public:
virtual property Decimal OriginalTotal {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_originalTotal();
function set_originalTotal(value);

See Also

Invoice Class
InSite.Model Namespace


PrepaidAmount Property

[image]

.NET Framework Class Library
Invoice..::.PrepaidAmount Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PrepaidAmount As Decimal
C#
public virtual decimal PrepaidAmount { get; set; }
Visual C++
public:
virtual property Decimal PrepaidAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_prepaidAmount();
function set_prepaidAmount(value);

See Also

Invoice Class
InSite.Model Namespace


Price Property

[image]

.NET Framework Class Library
Invoice..::.Price Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Price As Decimal
C#
public virtual decimal Price { get; set; }
Visual C++
public:
virtual property Decimal Price {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_price();
function set_price(value);

See Also

Invoice Class
InSite.Model Namespace


QuantityOfPackages Property

[image]

.NET Framework Class Library
Invoice..::.QuantityOfPackages Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property QuantityOfPackages As Integer
C#
public virtual int QuantityOfPackages { get; set; }
Visual C++
public:
virtual property int QuantityOfPackages {
    int get ();
    void set (int value);
}
JavaScript
function get_quantityOfPackages();
function set_quantityOfPackages(value);

See Also

Invoice Class
InSite.Model Namespace


Salesman Property

[image]

.NET Framework Class Library
Invoice..::.Salesman Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Salesman As String
C#
public virtual string Salesman { get; set; }
Visual C++
public:
virtual property String^ Salesman {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_salesman();
function set_salesman(value);

See Also

Invoice Class
InSite.Model Namespace


ShipCode Property

[image]

.NET Framework Class Library
Invoice..::.ShipCode Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipCode As String
C#
public virtual string ShipCode { get; set; }
Visual C++
public:
virtual property String^ ShipCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipCode();
function set_shipCode(value);

See Also

Invoice Class
InSite.Model Namespace


ShipDate Property

[image]

.NET Framework Class Library
Invoice..::.ShipDate Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipDate As DateTime
C#
public virtual DateTime ShipDate { get; set; }
Visual C++
public:
virtual property DateTime ShipDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_shipDate();
function set_shipDate(value);

See Also

Invoice Class
InSite.Model Namespace


ShipTo Property

[image]

.NET Framework Class Library
Invoice..::.ShipTo Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipTo As Customer
C#
public virtual Customer ShipTo { get; set; }
Visual C++
public:
virtual property Customer^ ShipTo {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_shipTo();
function set_shipTo(value);

See Also

Invoice Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
Invoice..::.State Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property State As String
C#
public virtual string State { get; set; }
Visual C++
public:
virtual property String^ State {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

Invoice Class
InSite.Model Namespace


SubTotal Property

[image]

.NET Framework Class Library
Invoice..::.SubTotal Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SubTotal As Decimal
C#
public virtual decimal SubTotal { get; }
Visual C++
public:
virtual property Decimal SubTotal {
    Decimal get ();
}
JavaScript
function get_subTotal();

See Also

Invoice Class
InSite.Model Namespace


TaxCode1 Property

[image]

.NET Framework Class Library
Invoice..::.TaxCode1 Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxCode1 As String
C#
public virtual string TaxCode1 { get; set; }
Visual C++
public:
virtual property String^ TaxCode1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode1();
function set_taxCode1(value);

See Also

Invoice Class
InSite.Model Namespace


TaxCode2 Property

[image]

.NET Framework Class Library
Invoice..::.TaxCode2 Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxCode2 As String
C#
public virtual string TaxCode2 { get; set; }
Visual C++
public:
virtual property String^ TaxCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode2();
function set_taxCode2(value);

See Also

Invoice Class
InSite.Model Namespace


TaxDate Property

[image]

.NET Framework Class Library
Invoice..::.TaxDate Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxDate As DateTime
C#
public virtual DateTime TaxDate { get; set; }
Visual C++
public:
virtual property DateTime TaxDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_taxDate();
function set_taxDate(value);

See Also

Invoice Class
InSite.Model Namespace


TermsCode Property

[image]

.NET Framework Class Library
Invoice..::.TermsCode Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TermsCode As String
C#
public virtual string TermsCode { get; set; }
Visual C++
public:
virtual property String^ TermsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_termsCode();
function set_termsCode(value);

See Also

Invoice Class
InSite.Model Namespace


Total Property

[image]

.NET Framework Class Library
Invoice..::.Total Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Total As Decimal
C#
public virtual decimal Total { get; set; }
Visual C++
public:
virtual property Decimal Total {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_total();
function set_total(value);

See Also

Invoice Class
InSite.Model Namespace


TotalTax Property

[image]

.NET Framework Class Library
Invoice..::.TotalTax Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TotalTax As Decimal
C#
public virtual decimal TotalTax { get; }
Visual C++
public:
virtual property Decimal TotalTax {
    Decimal get ();
}
JavaScript
function get_totalTax();

See Also

Invoice Class
InSite.Model Namespace


UseExchangeRate Property

[image]

.NET Framework Class Library
Invoice..::.UseExchangeRate Property
Invoice Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UseExchangeRate As Boolean
C#
public virtual bool UseExchangeRate { get; set; }
Visual C++
public:
virtual property bool UseExchangeRate {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useExchangeRate();
function set_useExchangeRate(value);

See Also

Invoice Class
InSite.Model Namespace


InvoiceLine Class

[image]

.NET Framework Class Library
InvoiceLine Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class InvoiceLine _
    Inherits ModelBase(Of InvoiceLine)
C#
[SerializableAttribute]
public class InvoiceLine : ModelBase<InvoiceLine>
Visual C++
[SerializableAttribute]
public ref class InvoiceLine : public ModelBase<InvoiceLine^>
JavaScript
InSite.Model.InvoiceLine = function();

Type.createClass(
    'InSite.Model.InvoiceLine',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(InvoiceLine>)>)
InSite.Model..::.InvoiceLine

See Also

InvoiceLine Members
InSite.Model Namespace


InvoiceLine Members

[image] [image]

.NET Framework Class Library
InvoiceLine Members
InvoiceLine Class Constructors Methods Fields Properties See Also Send Feedback

The InvoiceLine type exposes the following members.

Constructors

Name | Description
InvoiceLine | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ConsignmentType |
Cost |
CustomerPO |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Discount |
DOLine |
DONumber |
DOSequence |
ExtendedPrice |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Invoice |
InvoiceLineId |
InvoiceLineNumber |
InvoiceNumber |
InvoiceSequence |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
NewPrice |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OldPrice |
OrderLine |
OrderNumber |
OrderRelease |
OriginalInvoiceNumber |
Price |
ProcessIdentifier |
ProductCode |
ProductDescription |
ProductName |
QuantityInvoiced |
QuantityOrdered |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReasonText |
RestockFee |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TaxCode1 |
TaxCode2 |
TaxDate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

InvoiceLine Class
InSite.Model Namespace


InvoiceLine Constructor

[image] [image]

.NET Framework Class Library
InvoiceLine Constructor
InvoiceLine Class See Also Send Feedback

Overload List

Name | Description
InvoiceLine()()() |
InvoiceLine(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

InvoiceLine Class
InvoiceLine Members
InSite.Model Namespace


InvoiceLine Constructor

[image]

.NET Framework Class Library
InvoiceLine Constructor
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InvoiceLine()
Visual C++
public:
InvoiceLine()
JavaScript
InSite.Model.InvoiceLine = function();

See Also

InvoiceLine Class
InvoiceLine Overload
InSite.Model Namespace


InvoiceLine Constructor (SearchMode)

[image]

.NET Framework Class Library
InvoiceLine Constructor (SearchMode)
InvoiceLine Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public InvoiceLine(
    SearchMode searchMode
)
Visual C++
public:
InvoiceLine(
    SearchMode searchMode
)
JavaScript
InSite.Model.InvoiceLine = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

InvoiceLine Class
InvoiceLine Overload
InSite.Model Namespace


InvoiceLine Fields

[image] [image]

.NET Framework Class Library
InvoiceLine Fields
InvoiceLine Class See Also Send Feedback

The InvoiceLine type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

InvoiceLine Class
InSite.Model Namespace


InvoiceLine Methods

[image] [image]

.NET Framework Class Library
InvoiceLine Methods
InvoiceLine Class See Also Send Feedback

The InvoiceLine type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

InvoiceLine Class
InSite.Model Namespace


InvoiceLine Properties

[image] [image]

.NET Framework Class Library
InvoiceLine Properties
InvoiceLine Class See Also Send Feedback

The InvoiceLine type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ConsignmentType |
Cost |
CustomerPO |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Discount |
DOLine |
DONumber |
DOSequence |
ExtendedPrice |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Invoice |
InvoiceLineId |
InvoiceLineNumber |
InvoiceNumber |
InvoiceSequence |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
NewPrice |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OldPrice |
OrderLine |
OrderNumber |
OrderRelease |
OriginalInvoiceNumber |
Price |
ProcessIdentifier |
ProductCode |
ProductDescription |
ProductName |
QuantityInvoiced |
QuantityOrdered |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReasonText |
RestockFee |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TaxCode1 |
TaxCode2 |
TaxDate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

InvoiceLine Class
InSite.Model Namespace


ConsignmentType Property

[image]

.NET Framework Class Library
InvoiceLine..::.ConsignmentType Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ConsignmentType As Integer
C#
public virtual int ConsignmentType { get; set; }
Visual C++
public:
virtual property int ConsignmentType {
    int get ();
    void set (int value);
}
JavaScript
function get_consignmentType();
function set_consignmentType(value);

See Also

InvoiceLine Class
InSite.Model Namespace


Cost Property

[image]

.NET Framework Class Library
InvoiceLine..::.Cost Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Cost As Decimal
C#
public virtual decimal Cost { get; set; }
Visual C++
public:
virtual property Decimal Cost {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_cost();
function set_cost(value);

See Also

InvoiceLine Class
InSite.Model Namespace


CustomerPO Property

[image]

.NET Framework Class Library
InvoiceLine..::.CustomerPO Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerPO As String
C#
public virtual string CustomerPO { get; set; }
Visual C++
public:
virtual property String^ CustomerPO {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerPO();
function set_customerPO(value);

See Also

InvoiceLine Class
InSite.Model Namespace


Discount Property

[image]

.NET Framework Class Library
InvoiceLine..::.Discount Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Discount As Decimal
C#
public virtual decimal Discount { get; set; }
Visual C++
public:
virtual property Decimal Discount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discount();
function set_discount(value);

See Also

InvoiceLine Class
InSite.Model Namespace


DOLine Property

[image]

.NET Framework Class Library
InvoiceLine..::.DOLine Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DOLine As Integer
C#
public virtual int DOLine { get; set; }
Visual C++
public:
virtual property int DOLine {
    int get ();
    void set (int value);
}
JavaScript
function get_doLine();
function set_doLine(value);

See Also

InvoiceLine Class
InSite.Model Namespace


DONumber Property

[image]

.NET Framework Class Library
InvoiceLine..::.DONumber Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DONumber As String
C#
public virtual string DONumber { get; set; }
Visual C++
public:
virtual property String^ DONumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_doNumber();
function set_doNumber(value);

See Also

InvoiceLine Class
InSite.Model Namespace


DOSequence Property

[image]

.NET Framework Class Library
InvoiceLine..::.DOSequence Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DOSequence As Integer
C#
public virtual int DOSequence { get; set; }
Visual C++
public:
virtual property int DOSequence {
    int get ();
    void set (int value);
}
JavaScript
function get_doSequence();
function set_doSequence(value);

See Also

InvoiceLine Class
InSite.Model Namespace


ExtendedPrice Property

[image]

.NET Framework Class Library
InvoiceLine..::.ExtendedPrice Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ExtendedPrice As Decimal
C#
public virtual decimal ExtendedPrice { get; }
Visual C++
public:
virtual property Decimal ExtendedPrice {
    Decimal get ();
}
JavaScript
function get_extendedPrice();

See Also

InvoiceLine Class
InSite.Model Namespace


Invoice Property

[image]

.NET Framework Class Library
InvoiceLine..::.Invoice Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Invoice As Invoice
C#
public virtual Invoice Invoice { get; set; }
Visual C++
public:
virtual property Invoice^ Invoice {
    Invoice^ get ();
    void set (Invoice^ value);
}
JavaScript
function get_invoice();
function set_invoice(value);

See Also

InvoiceLine Class
InSite.Model Namespace


InvoiceLineId Property

[image]

.NET Framework Class Library
InvoiceLine..::.InvoiceLineId Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceLineId As Guid
C#
public virtual Guid InvoiceLineId { get; set; }
Visual C++
public:
virtual property Guid InvoiceLineId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_invoiceLineId();
function set_invoiceLineId(value);

See Also

InvoiceLine Class
InSite.Model Namespace


InvoiceLineNumber Property

[image]

.NET Framework Class Library
InvoiceLine..::.InvoiceLineNumber Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceLineNumber As Integer
C#
public virtual int InvoiceLineNumber { get; set; }
Visual C++
public:
virtual property int InvoiceLineNumber {
    int get ();
    void set (int value);
}
JavaScript
function get_invoiceLineNumber();
function set_invoiceLineNumber(value);

See Also

InvoiceLine Class
InSite.Model Namespace


InvoiceNumber Property

[image]

.NET Framework Class Library
InvoiceLine..::.InvoiceNumber Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceNumber As String
C#
public virtual string InvoiceNumber { get; set; }
Visual C++
public:
virtual property String^ InvoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_invoiceNumber();
function set_invoiceNumber(value);

See Also

InvoiceLine Class
InSite.Model Namespace


InvoiceSequence Property

[image]

.NET Framework Class Library
InvoiceLine..::.InvoiceSequence Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property InvoiceSequence As Integer
C#
public virtual int InvoiceSequence { get; set; }
Visual C++
public:
virtual property int InvoiceSequence {
    int get ();
    void set (int value);
}
JavaScript
function get_invoiceSequence();
function set_invoiceSequence(value);

See Also

InvoiceLine Class
InSite.Model Namespace


NewPrice Property

[image]

.NET Framework Class Library
InvoiceLine..::.NewPrice Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property NewPrice As Decimal
C#
public virtual decimal NewPrice { get; set; }
Visual C++
public:
virtual property Decimal NewPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_newPrice();
function set_newPrice(value);

See Also

InvoiceLine Class
InSite.Model Namespace


OldPrice Property

[image]

.NET Framework Class Library
InvoiceLine..::.OldPrice Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OldPrice As Decimal
C#
public virtual decimal OldPrice { get; set; }
Visual C++
public:
virtual property Decimal OldPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_oldPrice();
function set_oldPrice(value);

See Also

InvoiceLine Class
InSite.Model Namespace


OrderLine Property

[image]

.NET Framework Class Library
InvoiceLine..::.OrderLine Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderLine As Integer
C#
public virtual int OrderLine { get; set; }
Visual C++
public:
virtual property int OrderLine {
    int get ();
    void set (int value);
}
JavaScript
function get_orderLine();
function set_orderLine(value);

See Also

InvoiceLine Class
InSite.Model Namespace


OrderNumber Property

[image]

.NET Framework Class Library
InvoiceLine..::.OrderNumber Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderNumber As String
C#
public virtual string OrderNumber { get; set; }
Visual C++
public:
virtual property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumber();
function set_orderNumber(value);

See Also

InvoiceLine Class
InSite.Model Namespace


OrderRelease Property

[image]

.NET Framework Class Library
InvoiceLine..::.OrderRelease Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderRelease As Integer
C#
public virtual int OrderRelease { get; set; }
Visual C++
public:
virtual property int OrderRelease {
    int get ();
    void set (int value);
}
JavaScript
function get_orderRelease();
function set_orderRelease(value);

See Also

InvoiceLine Class
InSite.Model Namespace


OriginalInvoiceNumber Property

[image]

.NET Framework Class Library
InvoiceLine..::.OriginalInvoiceNumber Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OriginalInvoiceNumber As String
C#
public virtual string OriginalInvoiceNumber { get; set; }
Visual C++
public:
virtual property String^ OriginalInvoiceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_originalInvoiceNumber();
function set_originalInvoiceNumber(value);

See Also

InvoiceLine Class
InSite.Model Namespace


Price Property

[image]

.NET Framework Class Library
InvoiceLine..::.Price Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Price As Decimal
C#
public virtual decimal Price { get; set; }
Visual C++
public:
virtual property Decimal Price {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_price();
function set_price(value);

See Also

InvoiceLine Class
InSite.Model Namespace


ProcessIdentifier Property

[image]

.NET Framework Class Library
InvoiceLine..::.ProcessIdentifier Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProcessIdentifier As String
C#
public virtual string ProcessIdentifier { get; set; }
Visual C++
public:
virtual property String^ ProcessIdentifier {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_processIdentifier();
function set_processIdentifier(value);

See Also

InvoiceLine Class
InSite.Model Namespace


ProductCode Property

[image]

.NET Framework Class Library
InvoiceLine..::.ProductCode Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductCode As String
C#
public virtual string ProductCode { get; set; }
Visual C++
public:
virtual property String^ ProductCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productCode();
function set_productCode(value);

See Also

InvoiceLine Class
InSite.Model Namespace


ProductDescription Property

[image]

.NET Framework Class Library
InvoiceLine..::.ProductDescription Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductDescription As String
C#
public virtual string ProductDescription { get; set; }
Visual C++
public:
virtual property String^ ProductDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productDescription();
function set_productDescription(value);

See Also

InvoiceLine Class
InSite.Model Namespace


ProductName Property

[image]

.NET Framework Class Library
InvoiceLine..::.ProductName Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductName As String
C#
public virtual string ProductName { get; set; }
Visual C++
public:
virtual property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productName();
function set_productName(value);

See Also

InvoiceLine Class
InSite.Model Namespace


QuantityInvoiced Property

[image]

.NET Framework Class Library
InvoiceLine..::.QuantityInvoiced Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property QuantityInvoiced As Integer
C#
public virtual int QuantityInvoiced { get; set; }
Visual C++
public:
virtual property int QuantityInvoiced {
    int get ();
    void set (int value);
}
JavaScript
function get_quantityInvoiced();
function set_quantityInvoiced(value);

See Also

InvoiceLine Class
InSite.Model Namespace


QuantityOrdered Property

[image]

.NET Framework Class Library
InvoiceLine..::.QuantityOrdered Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property QuantityOrdered As Integer
C#
public virtual int QuantityOrdered { get; set; }
Visual C++
public:
virtual property int QuantityOrdered {
    int get ();
    void set (int value);
}
JavaScript
function get_quantityOrdered();
function set_quantityOrdered(value);

See Also

InvoiceLine Class
InSite.Model Namespace


ReasonText Property

[image]

.NET Framework Class Library
InvoiceLine..::.ReasonText Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ReasonText As String
C#
public virtual string ReasonText { get; set; }
Visual C++
public:
virtual property String^ ReasonText {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_reasonText();
function set_reasonText(value);

See Also

InvoiceLine Class
InSite.Model Namespace


RestockFee Property

[image]

.NET Framework Class Library
InvoiceLine..::.RestockFee Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property RestockFee As Decimal
C#
public virtual decimal RestockFee { get; set; }
Visual C++
public:
virtual property Decimal RestockFee {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_restockFee();
function set_restockFee(value);

See Also

InvoiceLine Class
InSite.Model Namespace


TaxCode1 Property

[image]

.NET Framework Class Library
InvoiceLine..::.TaxCode1 Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxCode1 As String
C#
public virtual string TaxCode1 { get; set; }
Visual C++
public:
virtual property String^ TaxCode1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode1();
function set_taxCode1(value);

See Also

InvoiceLine Class
InSite.Model Namespace


TaxCode2 Property

[image]

.NET Framework Class Library
InvoiceLine..::.TaxCode2 Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxCode2 As String
C#
public virtual string TaxCode2 { get; set; }
Visual C++
public:
virtual property String^ TaxCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode2();
function set_taxCode2(value);

See Also

InvoiceLine Class
InSite.Model Namespace


TaxDate Property

[image]

.NET Framework Class Library
InvoiceLine..::.TaxDate Property
InvoiceLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxDate As DateTime
C#
public virtual DateTime TaxDate { get; set; }
Visual C++
public:
virtual property DateTime TaxDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_taxDate();
function set_taxDate(value);

See Also

InvoiceLine Class
InSite.Model Namespace


IOrderPackager Interface

[image]

.NET Framework Class Library
IOrderPackager Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IOrderPackager
C#
public interface IOrderPackager
Visual C++
public interface class IOrderPackager
JavaScript
InSite.Model.IOrderPackager = function();
InSite.Model.IOrderPackager.createInterface('InSite.Model.IOrderPackager');

See Also

IOrderPackager Members
InSite.Model Namespace


IOrderPackager Members

[image] [image]

.NET Framework Class Library
IOrderPackager Members
IOrderPackager Interface Methods See Also Send Feedback

The IOrderPackager type exposes the following members.

Methods

Name | Description
MakePackages |

See Also

IOrderPackager Interface
InSite.Model Namespace


IOrderPackager Methods

[image] [image]

.NET Framework Class Library
IOrderPackager Methods
IOrderPackager Interface See Also Send Feedback

The IOrderPackager type exposes the following members.

Methods

Name | Description
MakePackages |

See Also

IOrderPackager Interface
InSite.Model Namespace


MakePackages Method

[image]

.NET Framework Class Library
IOrderPackager..::.MakePackages Method
IOrderPackager Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function MakePackages ( _
    customerOrder As CustomerOrder, _
    carrier As Carrier _
) As IList(Of IPackage)
C#
IList<IPackage> MakePackages(
    CustomerOrder customerOrder,
    Carrier carrier
)
Visual C++
IList<IPackage^>^ MakePackages(
    CustomerOrder^ customerOrder,
    Carrier^ carrier
)
JavaScript
function makePackages(customerOrder, carrier);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
carrier
Type: InSite.Model..::.Carrier

See Also

IOrderPackager Interface
InSite.Model Namespace


IPackage Interface

[image]

.NET Framework Class Library
IPackage Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPackage
C#
public interface IPackage
Visual C++
public interface class IPackage
JavaScript
InSite.Model.IPackage = function();
InSite.Model.IPackage.createInterface('InSite.Model.IPackage');

See Also

IPackage Members
InSite.Model Namespace


IPackage Members

[image] [image]

.NET Framework Class Library
IPackage Members
IPackage Interface Properties See Also Send Feedback

The IPackage type exposes the following members.

Properties

Name | Description
Height |
ItemCount |
Length |
ShippingClassification |
Type |
Weight |
Width |

See Also

IPackage Interface
InSite.Model Namespace


IPackage Properties

[image] [image]

.NET Framework Class Library
IPackage Properties
IPackage Interface See Also Send Feedback

The IPackage type exposes the following members.

Properties

Name | Description
Height |
ItemCount |
Length |
ShippingClassification |
Type |
Weight |
Width |

See Also

IPackage Interface
InSite.Model Namespace


Height Property

[image]

.NET Framework Class Library
IPackage..::.Height Property
IPackage Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Height As Decimal
C#
decimal Height { get; set; }
Visual C++
property Decimal Height {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_height();
function set_height(value);

See Also

IPackage Interface
InSite.Model Namespace


ItemCount Property

[image]

.NET Framework Class Library
IPackage..::.ItemCount Property
IPackage Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property ItemCount As Integer
C#
int ItemCount { get; set; }
Visual C++
property int ItemCount {
    int get ();
    void set (int value);
}
JavaScript
function get_itemCount();
function set_itemCount(value);

See Also

IPackage Interface
InSite.Model Namespace


Length Property

[image]

.NET Framework Class Library
IPackage..::.Length Property
IPackage Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Length As Decimal
C#
decimal Length { get; set; }
Visual C++
property Decimal Length {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_length();
function set_length(value);

See Also

IPackage Interface
InSite.Model Namespace


ShippingClassification Property

[image]

.NET Framework Class Library
IPackage..::.ShippingClassification Property
IPackage Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property ShippingClassification As String
C#
string ShippingClassification { get; set; }
Visual C++
property String^ ShippingClassification {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shippingClassification();
function set_shippingClassification(value);

See Also

IPackage Interface
InSite.Model Namespace


Type Property

[image]

.NET Framework Class Library
IPackage..::.Type Property
IPackage Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Type As String
C#
string Type { get; set; }
Visual C++
property String^ Type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

See Also

IPackage Interface
InSite.Model Namespace


Weight Property

[image]

.NET Framework Class Library
IPackage..::.Weight Property
IPackage Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Weight As Decimal
C#
decimal Weight { get; set; }
Visual C++
property Decimal Weight {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_weight();
function set_weight(value);

See Also

IPackage Interface
InSite.Model Namespace


Width Property

[image]

.NET Framework Class Library
IPackage..::.Width Property
IPackage Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Width As Decimal
C#
decimal Width { get; set; }
Visual C++
property Decimal Width {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_width();
function set_width(value);

See Also

IPackage Interface
InSite.Model Namespace


IPaymentGateway Interface

[image]

.NET Framework Class Library
IPaymentGateway Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPaymentGateway
C#
public interface IPaymentGateway
Visual C++
public interface class IPaymentGateway
JavaScript
InSite.Model.IPaymentGateway = function();
InSite.Model.IPaymentGateway.createInterface('InSite.Model.IPaymentGateway');

See Also

IPaymentGateway Members
InSite.Model Namespace


IPaymentGateway Members

[image] [image]

.NET Framework Class Library
IPaymentGateway Members
IPaymentGateway Interface Methods See Also Send Feedback

The IPaymentGateway type exposes the following members.

Methods

Name | Description
SubmitTransaction |

See Also

IPaymentGateway Interface
InSite.Model Namespace


IPaymentGateway Methods

[image] [image]

.NET Framework Class Library
IPaymentGateway Methods
IPaymentGateway Interface See Also Send Feedback

The IPaymentGateway type exposes the following members.

Methods

Name | Description
SubmitTransaction |

See Also

IPaymentGateway Interface
InSite.Model Namespace


SubmitTransaction Method

[image]

.NET Framework Class Library
IPaymentGateway..::.SubmitTransaction Method
IPaymentGateway Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function SubmitTransaction ( _
    creditCardTransactionType As String, _
    creditCard As CreditCard, _
    customerOrder As CustomerOrder _
) As CreditCardTransaction
C#
CreditCardTransaction SubmitTransaction(
    string creditCardTransactionType,
    CreditCard creditCard,
    CustomerOrder customerOrder
)
Visual C++
CreditCardTransaction^ SubmitTransaction(
    String^ creditCardTransactionType,
    CreditCard^ creditCard,
    CustomerOrder^ customerOrder
)
JavaScript
function submitTransaction(creditCardTransactionType, creditCard, customerOrder);

Parameters

creditCardTransactionType
Type: System..::.String
creditCard
Type: InSite.Model..::.CreditCard
customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

IPaymentGateway Interface
InSite.Model Namespace


IPriceCalculator Interface

[image]

.NET Framework Class Library
IPriceCalculator Interface
Members See Also Send Feedback

IPriceCalculator - Interface for the Price Calculator

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPriceCalculator
C#
public interface IPriceCalculator
Visual C++
public interface class IPriceCalculator
JavaScript
InSite.Model.IPriceCalculator = function();
InSite.Model.IPriceCalculator.createInterface('InSite.Model.IPriceCalculator');

See Also

IPriceCalculator Members
InSite.Model Namespace


IPriceCalculator Members

[image] [image]

.NET Framework Class Library
IPriceCalculator Members
IPriceCalculator Interface Methods See Also Send Feedback

Methods

Name | Description
CalculatePrice | Overloaded.

See Also

IPriceCalculator Interface
InSite.Model Namespace


IPriceCalculator Methods

[image] [image]

.NET Framework Class Library
IPriceCalculator Methods
IPriceCalculator Interface See Also Send Feedback

Methods

Name | Description
CalculatePrice | Overloaded.

See Also

IPriceCalculator Interface
InSite.Model Namespace


CalculatePrice Method

[image] [image]

.NET Framework Class Library
IPriceCalculator..::.CalculatePrice Method
IPriceCalculator Interface See Also Send Feedback

Overload List

Name | Description
CalculatePrice(OrderLine, Boolean, Boolean%) | Calculates Price for OrderLine
CalculatePrice(Customer, Product, Decimal, DataSet, Boolean, Boolean%) | Calculates Price for given Customer, Product and optionally Configuration

See Also

IPriceCalculator Interface
IPriceCalculator Members
InSite.Model Namespace


CalculatePrice Method (OrderLine, Boolean, Boolean)

[image]

.NET Framework Class Library
IPriceCalculator..::.CalculatePrice Method (OrderLine, Boolean, Boolean%)
IPriceCalculator Interface See Also Send Feedback

Calculates Price for OrderLine

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function CalculatePrice ( _
    orderLine As OrderLine, _
    regularPrice As Boolean, _
    <OutAttribute> ByRef isSalePrice As Boolean _
) As Decimal
C#
decimal CalculatePrice(
    OrderLine orderLine,
    bool regularPrice,
    out bool isSalePrice
)
Visual C++
Decimal CalculatePrice(
    OrderLine^ orderLine,
    bool regularPrice,
    [OutAttribute] bool% isSalePrice
)
JavaScript
function calculatePrice(orderLine, regularPrice, isSalePrice);

Parameters

orderLine
Type: InSite.Model..::.OrderLine
Required
regularPrice
Type: System..::.Boolean
If true, calculates Regular Price, if false, calculates Actual Price
isSalePrice
Type: System..::.Boolean %
Output paramter that returns true if Sale Price is returned, false if not

Return Value

Price

See Also

IPriceCalculator Interface
CalculatePrice Overload
InSite.Model Namespace


CalculatePrice Method (Customer, Product, Decimal, DataSet, Boolean, Boolean)

[image]

.NET Framework Class Library
IPriceCalculator..::.CalculatePrice Method (Customer, Product, Decimal, DataSet, Boolean, Boolean%)
IPriceCalculator Interface See Also Send Feedback

Calculates Price for given Customer, Product and optionally Configuration

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function CalculatePrice ( _
    customer As Customer, _
    product As Product, _
    qtyOrdered As Decimal, _
    configDataSet As DataSet, _
    regularPrice As Boolean, _
    <OutAttribute> ByRef isSalePrice As Boolean _
) As Decimal
C#
decimal CalculatePrice(
    Customer customer,
    Product product,
    decimal qtyOrdered,
    DataSet configDataSet,
    bool regularPrice,
    out bool isSalePrice
)
Visual C++
Decimal CalculatePrice(
    Customer^ customer,
    Product^ product,
    Decimal qtyOrdered,
    DataSet^ configDataSet,
    bool regularPrice,
    [OutAttribute] bool% isSalePrice
)
JavaScript
function calculatePrice(customer, product, qtyOrdered, configDataSet, regularPrice, isSalePrice);

Parameters

customer
Type: InSite.Model..::.Customer
Can be null
product
Type: InSite.Model..::.Product
Required
qtyOrdered
Type: System..::.Decimal
Required
configDataSet
Type: System.Data..::.DataSet
Can be null
regularPrice
Type: System..::.Boolean
If true, calculates Regular Price, if false, calculates Actual Price
isSalePrice
Type: System..::.Boolean %
Output paramter that returns true if Sale Price is returned, false if not

Return Value

Price

See Also

IPriceCalculator Interface
CalculatePrice Overload
InSite.Model Namespace


IPromotionEngine Interface

[image]

.NET Framework Class Library
IPromotionEngine Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IPromotionEngine
C#
public interface IPromotionEngine
Visual C++
public interface class IPromotionEngine
JavaScript
InSite.Model.IPromotionEngine = function();
InSite.Model.IPromotionEngine.createInterface('InSite.Model.IPromotionEngine');

See Also

IPromotionEngine Members
InSite.Model Namespace


IPromotionEngine Members

[image] [image]

.NET Framework Class Library
IPromotionEngine Members
IPromotionEngine Interface Methods Properties See Also Send Feedback

The IPromotionEngine type exposes the following members.

Methods

Name | Description
ApplyPromotions |
ClearPromotions |
ValidatePromotions |

Properties

Name | Description
CustomerOrder |

See Also

IPromotionEngine Interface
InSite.Model Namespace


IPromotionEngine Methods

[image] [image]

.NET Framework Class Library
IPromotionEngine Methods
IPromotionEngine Interface See Also Send Feedback

The IPromotionEngine type exposes the following members.

Methods

Name | Description
ApplyPromotions |
ClearPromotions |
ValidatePromotions |

See Also

IPromotionEngine Interface
InSite.Model Namespace


ApplyPromotions Method

[image]

.NET Framework Class Library
IPromotionEngine..::.ApplyPromotions Method
IPromotionEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function ApplyPromotions As CustomerOrder
C#
CustomerOrder ApplyPromotions()
Visual C++
CustomerOrder^ ApplyPromotions()
JavaScript
function applyPromotions();

See Also

IPromotionEngine Interface
InSite.Model Namespace


ClearPromotions Method

[image]

.NET Framework Class Library
IPromotionEngine..::.ClearPromotions Method
IPromotionEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function ClearPromotions As CustomerOrder
C#
CustomerOrder ClearPromotions()
Visual C++
CustomerOrder^ ClearPromotions()
JavaScript
function clearPromotions();

See Also

IPromotionEngine Interface
InSite.Model Namespace


ValidatePromotions Method

[image]

.NET Framework Class Library
IPromotionEngine..::.ValidatePromotions Method
IPromotionEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function ValidatePromotions As IList(Of Promotion)
C#
IList<Promotion> ValidatePromotions()
Visual C++
IList<Promotion^>^ ValidatePromotions()
JavaScript
function validatePromotions();

See Also

IPromotionEngine Interface
InSite.Model Namespace


IPromotionEngine Properties

[image] [image]

.NET Framework Class Library
IPromotionEngine Properties
IPromotionEngine Interface See Also Send Feedback

The IPromotionEngine type exposes the following members.

Properties

Name | Description
CustomerOrder |

See Also

IPromotionEngine Interface
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
IPromotionEngine..::.CustomerOrder Property
IPromotionEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property CustomerOrder As CustomerOrder
C#
CustomerOrder CustomerOrder { get; set; }
Visual C++
property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

IPromotionEngine Interface
InSite.Model Namespace


IRule Interface

[image]

.NET Framework Class Library
IRule Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IRule
C#
public interface IRule
Visual C++
public interface class IRule
JavaScript
InSite.Model.IRule = function();
InSite.Model.IRule.createInterface('InSite.Model.IRule');

See Also

IRule Members
InSite.Model Namespace


IRule Members

[image] [image]

.NET Framework Class Library
IRule Members
IRule Interface Methods Properties See Also Send Feedback

The IRule type exposes the following members.

Methods

Name | Description
IsValid |

Properties

Name | Description
Condition |
ExecutionGroup |
ExecutionOrder |

See Also

IRule Interface
InSite.Model Namespace


IRule Methods

[image] [image]

.NET Framework Class Library
IRule Methods
IRule Interface See Also Send Feedback

The IRule type exposes the following members.

Methods

Name | Description
IsValid |

See Also

IRule Interface
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
IRule..::.IsValid Method
IRule Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
)
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

See Also

IRule Interface
InSite.Model Namespace


IRule Properties

[image] [image]

.NET Framework Class Library
IRule Properties
IRule Interface See Also Send Feedback

The IRule type exposes the following members.

Properties

Name | Description
Condition |
ExecutionGroup |
ExecutionOrder |

See Also

IRule Interface
InSite.Model Namespace


Condition Property

[image]

.NET Framework Class Library
IRule..::.Condition Property
IRule Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Condition As String
C#
string Condition { get; set; }
Visual C++
property String^ Condition {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_condition();
function set_condition(value);

See Also

IRule Interface
InSite.Model Namespace


ExecutionGroup Property

[image]

.NET Framework Class Library
IRule..::.ExecutionGroup Property
IRule Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property ExecutionGroup As Integer
C#
int ExecutionGroup { get; set; }
Visual C++
property int ExecutionGroup {
    int get ();
    void set (int value);
}
JavaScript
function get_executionGroup();
function set_executionGroup(value);

See Also

IRule Interface
InSite.Model Namespace


ExecutionOrder Property

[image]

.NET Framework Class Library
IRule..::.ExecutionOrder Property
IRule Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property ExecutionOrder As Integer
C#
int ExecutionOrder { get; set; }
Visual C++
property int ExecutionOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_executionOrder();
function set_executionOrder(value);

See Also

IRule Interface
InSite.Model Namespace


IShippingCost Interface

[image]

.NET Framework Class Library
IShippingCost Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IShippingCost
C#
public interface IShippingCost
Visual C++
public interface class IShippingCost
JavaScript
InSite.Model.IShippingCost = function();
InSite.Model.IShippingCost.createInterface('InSite.Model.IShippingCost');

See Also

IShippingCost Members
InSite.Model Namespace


IShippingCost Members

[image] [image]

.NET Framework Class Library
IShippingCost Members
IShippingCost Interface Properties See Also Send Feedback

The IShippingCost type exposes the following members.

Properties

Name | Description
Cost |
Description |
DescriptionAndCost |
ShipCode |
ShipVia |

See Also

IShippingCost Interface
InSite.Model Namespace


IShippingCost Properties

[image] [image]

.NET Framework Class Library
IShippingCost Properties
IShippingCost Interface See Also Send Feedback

The IShippingCost type exposes the following members.

Properties

Name | Description
Cost |
Description |
DescriptionAndCost |
ShipCode |
ShipVia |

See Also

IShippingCost Interface
InSite.Model Namespace


Cost Property

[image]

.NET Framework Class Library
IShippingCost..::.Cost Property
IShippingCost Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Cost As Decimal
C#
decimal Cost { get; set; }
Visual C++
property Decimal Cost {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_cost();
function set_cost(value);

See Also

IShippingCost Interface
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
IShippingCost..::.Description Property
IShippingCost Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property Description As String
C#
string Description { get; }
Visual C++
property String^ Description {
    String^ get ();
}
JavaScript
function get_description();

See Also

IShippingCost Interface
InSite.Model Namespace


DescriptionAndCost Property

[image]

.NET Framework Class Library
IShippingCost..::.DescriptionAndCost Property
IShippingCost Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DescriptionAndCost As String
C#
string DescriptionAndCost { get; }
Visual C++
property String^ DescriptionAndCost {
    String^ get ();
}
JavaScript
function get_descriptionAndCost();

See Also

IShippingCost Interface
InSite.Model Namespace


ShipCode Property

[image]

.NET Framework Class Library
IShippingCost..::.ShipCode Property
IShippingCost Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ShipCode As String
C#
string ShipCode { get; }
Visual C++
property String^ ShipCode {
    String^ get ();
}
JavaScript
function get_shipCode();

See Also

IShippingCost Interface
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
IShippingCost..::.ShipVia Property
IShippingCost Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property ShipVia As ShipVia
C#
ShipVia ShipVia { get; set; }
Visual C++
property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

IShippingCost Interface
InSite.Model Namespace


IShippingEngine Interface

[image]

.NET Framework Class Library
IShippingEngine Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IShippingEngine
C#
public interface IShippingEngine
Visual C++
public interface class IShippingEngine
JavaScript
InSite.Model.IShippingEngine = function();
InSite.Model.IShippingEngine.createInterface('InSite.Model.IShippingEngine');

See Also

IShippingEngine Members
InSite.Model Namespace


IShippingEngine Members

[image] [image]

.NET Framework Class Library
IShippingEngine Members
IShippingEngine Interface Methods Properties See Also Send Feedback

The IShippingEngine type exposes the following members.

Methods

Name | Description
ProcessShipping |

Properties

Name | Description
Carriers |
Company |
CustomerOrder |
DefaultShippingCost |
DestinationZipCode |
IsWholeSaleOrder |
OrderPackager |
ShippingCosts |
ShipVias |

See Also

IShippingEngine Interface
InSite.Model Namespace


IShippingEngine Methods

[image] [image]

.NET Framework Class Library
IShippingEngine Methods
IShippingEngine Interface See Also Send Feedback

The IShippingEngine type exposes the following members.

Methods

Name | Description
ProcessShipping |

See Also

IShippingEngine Interface
InSite.Model Namespace


ProcessShipping Method

[image]

.NET Framework Class Library
IShippingEngine..::.ProcessShipping Method
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub ProcessShipping
C#
void ProcessShipping()
Visual C++
void ProcessShipping()
JavaScript
function processShipping();

See Also

IShippingEngine Interface
InSite.Model Namespace


IShippingEngine Properties

[image] [image]

.NET Framework Class Library
IShippingEngine Properties
IShippingEngine Interface See Also Send Feedback

The IShippingEngine type exposes the following members.

Properties

Name | Description
Carriers |
Company |
CustomerOrder |
DefaultShippingCost |
DestinationZipCode |
IsWholeSaleOrder |
OrderPackager |
ShippingCosts |
ShipVias |

See Also

IShippingEngine Interface
InSite.Model Namespace


Carriers Property

[image]

.NET Framework Class Library
IShippingEngine..::.Carriers Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Carriers As IList(Of Carrier)
C#
IList<Carrier> Carriers { get; set; }
Visual C++
property IList<Carrier^>^ Carriers {
    IList<Carrier^>^ get ();
    void set (IList<Carrier^>^ value);
}
JavaScript
function get_carriers();
function set_carriers(value);

See Also

IShippingEngine Interface
InSite.Model Namespace


Company Property

[image]

.NET Framework Class Library
IShippingEngine..::.Company Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property Company As Company
C#
Company Company { get; set; }
Visual C++
property Company^ Company {
    Company^ get ();
    void set (Company^ value);
}
JavaScript
function get_company();
function set_company(value);

See Also

IShippingEngine Interface
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
IShippingEngine..::.CustomerOrder Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property CustomerOrder As CustomerOrder
C#
CustomerOrder CustomerOrder { get; set; }
Visual C++
property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

IShippingEngine Interface
InSite.Model Namespace


DefaultShippingCost Property

[image]

.NET Framework Class Library
IShippingEngine..::.DefaultShippingCost Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property DefaultShippingCost As IShippingCost
C#
IShippingCost DefaultShippingCost { get; }
Visual C++
property IShippingCost^ DefaultShippingCost {
    IShippingCost^ get ();
}
JavaScript
function get_defaultShippingCost();

See Also

IShippingEngine Interface
InSite.Model Namespace


DestinationZipCode Property

[image]

.NET Framework Class Library
IShippingEngine..::.DestinationZipCode Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property DestinationZipCode As String
C#
string DestinationZipCode { get; set; }
Visual C++
property String^ DestinationZipCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_destinationZipCode();
function set_destinationZipCode(value);

See Also

IShippingEngine Interface
InSite.Model Namespace


IsWholeSaleOrder Property

[image]

.NET Framework Class Library
IShippingEngine..::.IsWholeSaleOrder Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property IsWholeSaleOrder As Boolean
C#
bool IsWholeSaleOrder { get; set; }
Visual C++
property bool IsWholeSaleOrder {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isWholeSaleOrder();
function set_isWholeSaleOrder(value);

See Also

IShippingEngine Interface
InSite.Model Namespace


OrderPackager Property

[image]

.NET Framework Class Library
IShippingEngine..::.OrderPackager Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property OrderPackager As IOrderPackager
C#
IOrderPackager OrderPackager { get; set; }
Visual C++
property IOrderPackager^ OrderPackager {
    IOrderPackager^ get ();
    void set (IOrderPackager^ value);
}
JavaScript
function get_orderPackager();
function set_orderPackager(value);

See Also

IShippingEngine Interface
InSite.Model Namespace


ShippingCosts Property

[image]

.NET Framework Class Library
IShippingEngine..::.ShippingCosts Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property ShippingCosts As IList(Of IShippingCost)
C#
IList<IShippingCost> ShippingCosts { get; }
Visual C++
property IList<IShippingCost^>^ ShippingCosts {
    IList<IShippingCost^>^ get ();
}
JavaScript
function get_shippingCosts();

See Also

IShippingEngine Interface
InSite.Model Namespace


ShipVias Property

[image]

.NET Framework Class Library
IShippingEngine..::.ShipVias Property
IShippingEngine Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Property ShipVias As IList(Of ShipVia)
C#
IList<ShipVia> ShipVias { get; set; }
Visual C++
property IList<ShipVia^>^ ShipVias {
    IList<ShipVia^>^ get ();
    void set (IList<ShipVia^>^ value);
}
JavaScript
function get_shipVias();
function set_shipVias(value);

See Also

IShippingEngine Interface
InSite.Model Namespace


ITaxCalculator Interface

[image]

.NET Framework Class Library
ITaxCalculator Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface ITaxCalculator
C#
public interface ITaxCalculator
Visual C++
public interface class ITaxCalculator
JavaScript
InSite.Model.ITaxCalculator = function();
InSite.Model.ITaxCalculator.createInterface('InSite.Model.ITaxCalculator');

See Also

ITaxCalculator Members
InSite.Model Namespace


ITaxCalculator Members

[image] [image]

.NET Framework Class Library
ITaxCalculator Members
ITaxCalculator Interface Methods See Also Send Feedback

Methods

Name | Description
CalculateTax | Overloaded.

See Also

ITaxCalculator Interface
InSite.Model Namespace


ITaxCalculator Methods

[image] [image]

.NET Framework Class Library
ITaxCalculator Methods
ITaxCalculator Interface See Also Send Feedback

Methods

Name | Description
CalculateTax | Overloaded.

See Also

ITaxCalculator Interface
InSite.Model Namespace


CalculateTax Method

[image] [image]

.NET Framework Class Library
ITaxCalculator..::.CalculateTax Method
ITaxCalculator Interface See Also Send Feedback

Overload List

Name | Description
CalculateTax(WebSite, CustomerOrder) | CalculateTax - Calculates Tax for the WebSite and Order. Use when Order has ShipTo.
CalculateTax(WebSite, CustomerOrder, String, String) | CalculateTax - Calculates Tax for the WebSite, Order, State and Zip. Use to pass in State and Zip before Order has ShipTo.

See Also

ITaxCalculator Interface
ITaxCalculator Members
InSite.Model Namespace


CalculateTax Method (WebSite, CustomerOrder)

[image]

.NET Framework Class Library
ITaxCalculator..::.CalculateTax Method (WebSite, CustomerOrder)
ITaxCalculator Interface See Also Send Feedback

CalculateTax - Calculates Tax for the WebSite and Order. Use when Order has ShipTo.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Sub CalculateTax ( _
    webSite As WebSite, _
    customerOrder As CustomerOrder _
)
C#
void CalculateTax(
    WebSite webSite,
    CustomerOrder customerOrder
)
Visual C++
void CalculateTax(
    WebSite^ webSite,
    CustomerOrder^ customerOrder
)
JavaScript
function calculateTax(webSite, customerOrder);

Parameters

webSite
Type: InSite.Model..::.WebSite
customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

ITaxCalculator Interface
CalculateTax Overload
InSite.Model Namespace


CalculateTax Method (WebSite, CustomerOrder, String, String)

[image]

.NET Framework Class Library
ITaxCalculator..::.CalculateTax Method (WebSite, CustomerOrder, String, String)
ITaxCalculator Interface See Also Send Feedback

CalculateTax - Calculates Tax for the WebSite, Order, State and Zip. Use to pass in State and Zip before Order has ShipTo.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function CalculateTax ( _
    webSite As WebSite, _
    customerOrder As CustomerOrder, _
    stateAbbreviation As String, _
    zip As String _
) As Decimal
C#
decimal CalculateTax(
    WebSite webSite,
    CustomerOrder customerOrder,
    string stateAbbreviation,
    string zip
)
Visual C++
Decimal CalculateTax(
    WebSite^ webSite,
    CustomerOrder^ customerOrder,
    String^ stateAbbreviation,
    String^ zip
)
JavaScript
function calculateTax(webSite, customerOrder, stateAbbreviation, zip);

Parameters

webSite
Type: InSite.Model..::.WebSite
customerOrder
Type: InSite.Model..::.CustomerOrder
stateAbbreviation
Type: System..::.String
zip
Type: System..::.String

Return Value

Calculated Tax Amount

See Also

ITaxCalculator Interface
CalculateTax Overload
InSite.Model Namespace


IValidatable Interface

[image]

.NET Framework Class Library
IValidatable Interface
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Interface IValidatable
C#
public interface IValidatable
Visual C++
public interface class IValidatable
JavaScript
InSite.Model.IValidatable = function();
InSite.Model.IValidatable.createInterface('InSite.Model.IValidatable');

See Also

IValidatable Members
InSite.Model Namespace


IValidatable Members

[image] [image]

.NET Framework Class Library
IValidatable Members
IValidatable Interface Methods Properties See Also Send Feedback

The IValidatable type exposes the following members.

Methods

Name | Description
Validate |

Properties

Name | Description
IsValid |

See Also

IValidatable Interface
InSite.Model Namespace


IValidatable Methods

[image] [image]

.NET Framework Class Library
IValidatable Methods
IValidatable Interface See Also Send Feedback

The IValidatable type exposes the following members.

Methods

Name | Description
Validate |

See Also

IValidatable Interface
InSite.Model Namespace


Validate Method

[image]

.NET Framework Class Library
IValidatable..::.Validate Method
IValidatable Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Function Validate As ValidationResults
C#
ValidationResults Validate()
Visual C++
ValidationResults^ Validate()
JavaScript
function validate();

See Also

IValidatable Interface
InSite.Model Namespace


IValidatable Properties

[image] [image]

.NET Framework Class Library
IValidatable Properties
IValidatable Interface See Also Send Feedback

The IValidatable type exposes the following members.

Properties

Name | Description
IsValid |

See Also

IValidatable Interface
InSite.Model Namespace


IsValid Property

[image]

.NET Framework Class Library
IValidatable..::.IsValid Property
IValidatable Interface See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
ReadOnly Property IsValid As Boolean
C#
bool IsValid { get; }
Visual C++
property bool IsValid {
    bool get ();
}
JavaScript
function get_isValid();

See Also

IValidatable Interface
InSite.Model Namespace


License Class

[image]

.NET Framework Class Library
License Class
Members See Also Send Feedback

The class representing a license

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class License
C#
public class License
Visual C++
public ref class License
JavaScript
InSite.Model.License = function();

Type.createClass(
    'InSite.Model.License');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.License

See Also

License Members
InSite.Model Namespace


License Members

[image] [image]

.NET Framework Class Library
License Members
License Class Constructors Methods Properties See Also Send Feedback

The License type exposes the following members.

Constructors

Name | Description
License | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
ExpirationDate |
HasExpired |
Module |
NextCheckDate |
Status |

See Also

License Class
InSite.Model Namespace


License Constructor

[image] [image]

.NET Framework Class Library
License Constructor
License Class See Also Send Feedback

Overload List

Name | Description
License()()() |
License(License) |

See Also

License Class
License Members
InSite.Model Namespace


License Constructor

[image]

.NET Framework Class Library
License Constructor
License Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public License()
Visual C++
public:
License()
JavaScript
InSite.Model.License = function();

See Also

License Class
License Overload
InSite.Model Namespace


License Constructor (License)

[image]

.NET Framework Class Library
License Constructor (License)
License Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    that As License _
)
C#
public License(
    License that
)
Visual C++
public:
License(
    License^ that
)
JavaScript
InSite.Model.License = function(that);

Parameters

that
Type: InSite.Model..::.License

See Also

License Class
License Overload
InSite.Model Namespace


License Methods

[image] [image]

.NET Framework Class Library
License Methods
License Class See Also Send Feedback

The License type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

License Class
InSite.Model Namespace


License Properties

[image] [image]

.NET Framework Class Library
License Properties
License Class See Also Send Feedback

The License type exposes the following members.

Properties

Name | Description
Count |
ExpirationDate |
HasExpired |
Module |
NextCheckDate |
Status |

See Also

License Class
InSite.Model Namespace


Count Property

[image]

.NET Framework Class Library
License..::.Count Property
License Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property Count As Integer
C#
public int Count { get; set; }
Visual C++
public:
property int Count {
    int get ();
    void set (int value);
}
JavaScript
function get_count();
function set_count(value);

See Also

License Class
InSite.Model Namespace


ExpirationDate Property

[image]

.NET Framework Class Library
License..::.ExpirationDate Property
License Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property ExpirationDate As DateTime
C#
public DateTime ExpirationDate { get; set; }
Visual C++
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_expirationDate();
function set_expirationDate(value);

See Also

License Class
InSite.Model Namespace


HasExpired Property

[image]

.NET Framework Class Library
License..::.HasExpired Property
License Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasExpired As Boolean
C#
public bool HasExpired { get; }
Visual C++
public:
property bool HasExpired {
    bool get ();
}
JavaScript
function get_hasExpired();

See Also

License Class
InSite.Model Namespace


Module Property

[image]

.NET Framework Class Library
License..::.Module Property
License Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property Module As String
C#
public string Module { get; set; }
Visual C++
public:
property String^ Module {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_module();
function set_module(value);

See Also

License Class
InSite.Model Namespace


NextCheckDate Property

[image]

.NET Framework Class Library
License..::.NextCheckDate Property
License Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property NextCheckDate As DateTime
C#
public DateTime NextCheckDate { get; set; }
Visual C++
public:
property DateTime NextCheckDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_nextCheckDate();
function set_nextCheckDate(value);

See Also

License Class
InSite.Model Namespace


Status Property

[image]

.NET Framework Class Library
License..::.Status Property
License Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property Status As LicenseStatus
C#
public LicenseStatus Status { get; set; }
Visual C++
public:
property LicenseStatus Status {
    LicenseStatus get ();
    void set (LicenseStatus value);
}
JavaScript
function get_status();
function set_status(value);

See Also

License Class
InSite.Model Namespace


LicenseCountException Class

[image]

.NET Framework Class Library
LicenseCountException Class
Members See Also Send Feedback

The exception class thrown when the license count is not sufficient.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class LicenseCountException _
    Inherits Exception
C#
public class LicenseCountException : Exception
Visual C++
public ref class LicenseCountException : public Exception
JavaScript
InSite.Model.LicenseCountException = function();

Type.createClass(
    'InSite.Model.LicenseCountException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Model..::.LicenseCountException

See Also

LicenseCountException Members
InSite.Model Namespace


LicenseCountException Members

[image] [image]

.NET Framework Class Library
LicenseCountException Members
LicenseCountException Class Constructors Methods Properties See Also Send Feedback

The LicenseCountException type exposes the following members.

Constructors

Name | Description
LicenseCountException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | (Overrides Exception..::.Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseCountException Class
InSite.Model Namespace


LicenseCountException Constructor

[image]

.NET Framework Class Library
LicenseCountException Constructor
LicenseCountException Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    module As String, _
    count As Integer _
)
C#
public LicenseCountException(
    string module,
    int count
)
Visual C++
public:
LicenseCountException(
    String^ module,
    int count
)
JavaScript
InSite.Model.LicenseCountException = function(module, count);

Parameters

module
Type: System..::.String
count
Type: System..::.Int32

See Also

LicenseCountException Class
InSite.Model Namespace


LicenseCountException Methods

[image] [image]

.NET Framework Class Library
LicenseCountException Methods
LicenseCountException Class See Also Send Feedback

The LicenseCountException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LicenseCountException Class
InSite.Model Namespace


LicenseCountException Properties

[image] [image]

.NET Framework Class Library
LicenseCountException Properties
LicenseCountException Class See Also Send Feedback

The LicenseCountException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | (Overrides Exception..::.Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseCountException Class
InSite.Model Namespace


Message Property

[image]

.NET Framework Class Library
LicenseCountException..::.Message Property
LicenseCountException Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
C#
public override string Message { get; }
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}
JavaScript
function get_message();

Implements

_Exception..::.Message

See Also

LicenseCountException Class
InSite.Model Namespace


LicenseExpiredException Class

[image]

.NET Framework Class Library
LicenseExpiredException Class
Members See Also Send Feedback

The exception class thrown when the license has expired

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class LicenseExpiredException _
    Inherits Exception
C#
public class LicenseExpiredException : Exception
Visual C++
public ref class LicenseExpiredException : public Exception
JavaScript
InSite.Model.LicenseExpiredException = function();

Type.createClass(
    'InSite.Model.LicenseExpiredException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Model..::.LicenseExpiredException

See Also

LicenseExpiredException Members
InSite.Model Namespace


LicenseExpiredException Members

[image] [image]

.NET Framework Class Library
LicenseExpiredException Members
LicenseExpiredException Class Constructors Methods Properties See Also Send Feedback

The LicenseExpiredException type exposes the following members.

Constructors

Name | Description
LicenseExpiredException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | (Overrides Exception..::.Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseExpiredException Class
InSite.Model Namespace


LicenseExpiredException Constructor

[image]

.NET Framework Class Library
LicenseExpiredException Constructor
LicenseExpiredException Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    module As String _
)
C#
public LicenseExpiredException(
    string module
)
Visual C++
public:
LicenseExpiredException(
    String^ module
)
JavaScript
InSite.Model.LicenseExpiredException = function(module);

Parameters

module
Type: System..::.String

See Also

LicenseExpiredException Class
InSite.Model Namespace


LicenseExpiredException Methods

[image] [image]

.NET Framework Class Library
LicenseExpiredException Methods
LicenseExpiredException Class See Also Send Feedback

The LicenseExpiredException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LicenseExpiredException Class
InSite.Model Namespace


LicenseExpiredException Properties

[image] [image]

.NET Framework Class Library
LicenseExpiredException Properties
LicenseExpiredException Class See Also Send Feedback

The LicenseExpiredException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | (Overrides Exception..::.Message.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LicenseExpiredException Class
InSite.Model Namespace


Message Property

[image]

.NET Framework Class Library
LicenseExpiredException..::.Message Property
LicenseExpiredException Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Message As String
C#
public override string Message { get; }
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}
JavaScript
function get_message();

Implements

_Exception..::.Message

See Also

LicenseExpiredException Class
InSite.Model Namespace


LicenseStatus Enumeration

[image]

.NET Framework Class Library
LicenseStatus Enumeration
See Also Send Feedback

An enum of the possible license statuses. Needs to be compatible with a similar enum in InSite.LicenseService.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration LicenseStatus
C#
public enum LicenseStatus
Visual C++
public enum class LicenseStatus
JavaScript
InSite.Model.LicenseStatus = function();
InSite.Model.LicenseStatus.createEnum('InSite.Model.LicenseStatus', false);

Members

Member name | Description
Permanent |
Temporary |
Pending |
Presumed |

See Also

InSite.Model Namespace


Licensing Class

[image]

.NET Framework Class Library
Licensing Class
Members See Also Send Feedback

The Licensing class has just one public (static) function, that checks for the availability of a license.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Licensing
C#
public sealed class Licensing
Visual C++
public ref class Licensing sealed
JavaScript
InSite.Model.Licensing = function();

Type.createClass(
    'InSite.Model.Licensing');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.Licensing

See Also

Licensing Members
InSite.Model Namespace


Licensing Members

[image] [image]

.NET Framework Class Library
Licensing Members
Licensing Class Constructors Methods See Also Send Feedback

The Licensing type exposes the following members.

Constructors

Name | Description
Licensing |

Methods

Name | Description
Check | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExistingLicense | Gets an existing licenses for the module. Used by management console to show a particular license.
GetExistingLicenses | Gets all existing licenses. Used by management console to show all licenses.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Register | Requests registration of the clients's licenses.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Licensing Class
InSite.Model Namespace


Licensing Constructor

[image]

.NET Framework Class Library
Licensing Constructor
Licensing Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Licensing()
Visual C++
public:
Licensing()
JavaScript
InSite.Model.Licensing = function();

See Also

Licensing Class
InSite.Model Namespace


Licensing Methods

[image] [image]

.NET Framework Class Library
Licensing Methods
Licensing Class See Also Send Feedback

The Licensing type exposes the following members.

Methods

Name | Description
Check | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExistingLicense | Gets an existing licenses for the module. Used by management console to show a particular license.
GetExistingLicenses | Gets all existing licenses. Used by management console to show all licenses.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Register | Requests registration of the clients's licenses.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Licensing Class
InSite.Model Namespace


Check Method

[image] [image]

.NET Framework Class Library
Licensing..::.Check Method
Licensing Class See Also Send Feedback

Overload List

Name | Description
Check(String) | Checks the licensing for the given module. Throws if expired.
Check(String, Int32) | Checks the licensing for the given module and license count. Throws if expired ot count is not sufficient.

See Also

Licensing Class
Licensing Members
InSite.Model Namespace


Check Method (String)

[image]

.NET Framework Class Library
Licensing..::.Check Method (String)
Licensing Class See Also Send Feedback

Checks the licensing for the given module. Throws if expired.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Check ( _
    module As String _
)
C#
public static void Check(
    string module
)
Visual C++
public:
static void Check(
    String^ module
)
JavaScript
InSite.Model.Licensing.check = function(module);

Parameters

module
Type: System..::.String
The name of the module

See Also

Licensing Class
Check Overload
InSite.Model Namespace


Check Method (String, Int32)

[image]

.NET Framework Class Library
Licensing..::.Check Method (String, Int32)
Licensing Class See Also Send Feedback

Checks the licensing for the given module and license count. Throws if expired ot count is not sufficient.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Check ( _
    module As String, _
    count As Integer _
)
C#
public static void Check(
    string module,
    int count
)
Visual C++
public:
static void Check(
    String^ module,
    int count
)
JavaScript
InSite.Model.Licensing.check = function(module, count);

Parameters

module
Type: System..::.String
The name of the module
count
Type: System..::.Int32
The required license count

See Also

Licensing Class
Check Overload
InSite.Model Namespace


GetExistingLicense Method

[image]

.NET Framework Class Library
Licensing..::.GetExistingLicense Method
Licensing Class See Also Send Feedback

Gets an existing licenses for the module. Used by management console to show a particular license.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetExistingLicense ( _
    module As String _
) As License
C#
public static License GetExistingLicense(
    string module
)
Visual C++
public:
static License^ GetExistingLicense(
    String^ module
)
JavaScript
InSite.Model.Licensing.getExistingLicense = function(module);

Parameters

module
Type: System..::.String

Return Value

null if no license for the module

See Also

Licensing Class
InSite.Model Namespace


GetExistingLicenses Method

[image]

.NET Framework Class Library
Licensing..::.GetExistingLicenses Method
Licensing Class See Also Send Feedback

Gets all existing licenses. Used by management console to show all licenses.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetExistingLicenses As IList(Of License)
C#
public static IList<License> GetExistingLicenses()
Visual C++
public:
static IList<License^>^ GetExistingLicenses()
JavaScript
InSite.Model.Licensing.getExistingLicenses = function();

Return Value

See Also

Licensing Class
InSite.Model Namespace


Register Method

[image]

.NET Framework Class Library
Licensing..::.Register Method
Licensing Class See Also Send Feedback

Requests registration of the clients's licenses.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Register ( _
    customerId As String, _
    contactName As String, _
    contactPhone As String, _
    contactEmail As String, _
    company As Company _
) As IList(Of License)
C#
public static IList<License> Register(
    string customerId,
    string contactName,
    string contactPhone,
    string contactEmail,
    Company company
)
Visual C++
public:
static IList<License^>^ Register(
    String^ customerId,
    String^ contactName,
    String^ contactPhone,
    String^ contactEmail,
    Company^ company
)
JavaScript
InSite.Model.Licensing.register = function(customerId, contactName, contactPhone, contactEmail, company);

Parameters

customerId
Type: System..::.String
contactName
Type: System..::.String
contactPhone
Type: System..::.String
contactEmail
Type: System..::.String
company
Type: InSite.Model..::.Company

Return Value

See Also

Licensing Class
InSite.Model Namespace


LoadForSOA Class

[image]

.NET Framework Class Library
LoadForSOA Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public Class LoadForSOA _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public class LoadForSOA : Attribute
Visual C++
[AttributeUsageAttribute(AttributeTargets::Property)]
public ref class LoadForSOA : public Attribute
JavaScript
InSite.Model.LoadForSOA = function();

Type.createClass(
    'InSite.Model.LoadForSOA',
    Attribute);

Inheritance Hierarchy

System..::.Object
System..::.Attribute
InSite.Model..::.LoadForSOA

See Also

LoadForSOA Members
InSite.Model Namespace


LoadForSOA Members

[image] [image]

.NET Framework Class Library
LoadForSOA Members
LoadForSOA Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LoadForSOA type exposes the following members.

Constructors

Name | Description
LoadForSOA |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

LoadForSOA Class
InSite.Model Namespace


LoadForSOA Constructor

[image]

.NET Framework Class Library
LoadForSOA Constructor
LoadForSOA Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LoadForSOA()
Visual C++
public:
LoadForSOA()
JavaScript
InSite.Model.LoadForSOA = function();

See Also

LoadForSOA Class
InSite.Model Namespace


LoadForSOA Methods

[image] [image]

.NET Framework Class Library
LoadForSOA Methods
LoadForSOA Class See Also Send Feedback

The LoadForSOA type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

LoadForSOA Class
InSite.Model Namespace


LoadForSOA Properties

[image] [image]

.NET Framework Class Library
LoadForSOA Properties
LoadForSOA Class See Also Send Feedback

The LoadForSOA type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

LoadForSOA Class
InSite.Model Namespace


LocalTaxRate Class

[image]

.NET Framework Class Library
LocalTaxRate Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class LocalTaxRate _
    Inherits ModelBase(Of LocalTaxRate)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class LocalTaxRate : ModelBase<LocalTaxRate>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class LocalTaxRate : public ModelBase<LocalTaxRate^>
JavaScript
InSite.Model.LocalTaxRate = function();

Type.createClass(
    'InSite.Model.LocalTaxRate',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(LocalTaxRate>)>)
InSite.Model..::.LocalTaxRate

See Also

LocalTaxRate Members
InSite.Model Namespace


LocalTaxRate Members

[image] [image]

.NET Framework Class Library
LocalTaxRate Members
LocalTaxRate Class Constructors Methods Fields Properties See Also Send Feedback

The LocalTaxRate type exposes the following members.

Constructors

Name | Description
LocalTaxRate | Overloaded.

Methods

Name | Description
AddTaxExemption |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveTaxExemption |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LocalTaxRateId |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TaxCode |
TaxExemptions |
TaxFreight |
TaxRate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

LocalTaxRate Class
InSite.Model Namespace


LocalTaxRate Constructor

[image] [image]

.NET Framework Class Library
LocalTaxRate Constructor
LocalTaxRate Class See Also Send Feedback

Overload List

Name | Description
LocalTaxRate()()() |
LocalTaxRate(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

LocalTaxRate Class
LocalTaxRate Members
InSite.Model Namespace


LocalTaxRate Constructor

[image]

.NET Framework Class Library
LocalTaxRate Constructor
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LocalTaxRate()
Visual C++
public:
LocalTaxRate()
JavaScript
InSite.Model.LocalTaxRate = function();

See Also

LocalTaxRate Class
LocalTaxRate Overload
InSite.Model Namespace


LocalTaxRate Constructor (SearchMode)

[image]

.NET Framework Class Library
LocalTaxRate Constructor (SearchMode)
LocalTaxRate Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public LocalTaxRate(
    SearchMode searchMode
)
Visual C++
public:
LocalTaxRate(
    SearchMode searchMode
)
JavaScript
InSite.Model.LocalTaxRate = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

LocalTaxRate Class
LocalTaxRate Overload
InSite.Model Namespace


LocalTaxRate Fields

[image] [image]

.NET Framework Class Library
LocalTaxRate Fields
LocalTaxRate Class See Also Send Feedback

The LocalTaxRate type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

LocalTaxRate Class
InSite.Model Namespace


LocalTaxRate Methods

[image] [image]

.NET Framework Class Library
LocalTaxRate Methods
LocalTaxRate Class See Also Send Feedback

The LocalTaxRate type exposes the following members.

Methods

Name | Description
AddTaxExemption |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveTaxExemption |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

LocalTaxRate Class
InSite.Model Namespace


AddTaxExemption Method

[image]

.NET Framework Class Library
LocalTaxRate..::.AddTaxExemption Method
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddTaxExemption ( _
    value As TaxExemption _
)
C#
public virtual void AddTaxExemption(
    TaxExemption value
)
Visual C++
public:
virtual void AddTaxExemption(
    TaxExemption^ value
)
JavaScript
function addTaxExemption(value);

Parameters

value
Type: InSite.Model..::.TaxExemption

See Also

LocalTaxRate Class
InSite.Model Namespace


RemoveTaxExemption Method

[image]

.NET Framework Class Library
LocalTaxRate..::.RemoveTaxExemption Method
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveTaxExemption ( _
    value As TaxExemption _
)
C#
public virtual void RemoveTaxExemption(
    TaxExemption value
)
Visual C++
public:
virtual void RemoveTaxExemption(
    TaxExemption^ value
)
JavaScript
function removeTaxExemption(value);

Parameters

value
Type: InSite.Model..::.TaxExemption

See Also

LocalTaxRate Class
InSite.Model Namespace


LocalTaxRate Properties

[image] [image]

.NET Framework Class Library
LocalTaxRate Properties
LocalTaxRate Class See Also Send Feedback

The LocalTaxRate type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LocalTaxRateId |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TaxCode |
TaxExemptions |
TaxFreight |
TaxRate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

LocalTaxRate Class
InSite.Model Namespace


LocalTaxRateId Property

[image]

.NET Framework Class Library
LocalTaxRate..::.LocalTaxRateId Property
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property LocalTaxRateId As Guid
C#
public virtual Guid LocalTaxRateId { get; set; }
Visual C++
public:
virtual property Guid LocalTaxRateId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_localTaxRateId();
function set_localTaxRateId(value);

See Also

LocalTaxRate Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
LocalTaxRate..::.Name Property
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; private set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

LocalTaxRate Class
InSite.Model Namespace


TaxCode Property

[image]

.NET Framework Class Library
LocalTaxRate..::.TaxCode Property
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode As String
C#
[DataMemberAttribute]
public virtual string TaxCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode();
function set_taxCode(value);

See Also

LocalTaxRate Class
InSite.Model Namespace


TaxExemptions Property

[image]

.NET Framework Class Library
LocalTaxRate..::.TaxExemptions Property
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxExemptions As ChildList(Of TaxExemption)
C#
public virtual ChildList<TaxExemption> TaxExemptions { get; private set; }
Visual C++
public:
virtual property ChildList<TaxExemption^>^ TaxExemptions {
    ChildList<TaxExemption^>^ get ();
    void set (ChildList<TaxExemption^>^ value);
}
JavaScript
function get_taxExemptions();
function set_taxExemptions(value);

See Also

LocalTaxRate Class
InSite.Model Namespace


TaxFreight Property

[image]

.NET Framework Class Library
LocalTaxRate..::.TaxFreight Property
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxFreight As Boolean
C#
[DataMemberAttribute]
public virtual bool TaxFreight { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool TaxFreight {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxFreight();
function set_taxFreight(value);

See Also

LocalTaxRate Class
InSite.Model Namespace


TaxRate Property

[image]

.NET Framework Class Library
LocalTaxRate..::.TaxRate Property
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxRate As Decimal
C#
[DataMemberAttribute]
public virtual decimal TaxRate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal TaxRate {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_taxRate();
function set_taxRate(value);

See Also

LocalTaxRate Class
InSite.Model Namespace


Zip Property

[image]

.NET Framework Class Library
LocalTaxRate..::.Zip Property
LocalTaxRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Zip As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Zip { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

See Also

LocalTaxRate Class
InSite.Model Namespace


Menu Class

[image]

.NET Framework Class Library
Menu Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute> _
Public Class Menu _
    Inherits ModelBase(Of Menu)
C#
[SerializableAttribute]
[DataContractAttribute]
public class Menu : ModelBase<Menu>
Visual C++
[SerializableAttribute]
[DataContractAttribute]
public ref class Menu : public ModelBase<Menu^>
JavaScript
InSite.Model.Menu = function();

Type.createClass(
    'InSite.Model.Menu',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Menu>)>)
InSite.Model..::.Menu

See Also

Menu Members
InSite.Model Namespace


Menu Members

[image] [image]

.NET Framework Class Library
Menu Members
Menu Class Constructors Methods Fields Properties See Also Send Feedback

The Menu type exposes the following members.

Constructors

Name | Description
Menu | Overloaded.

Methods

Name | Description
AddSubMenu |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveSubMenu |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Image |
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
MenuId |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentMenu |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
SubMenus |
Target |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Menu Class
InSite.Model Namespace


Menu Constructor

[image] [image]

.NET Framework Class Library
Menu Constructor
Menu Class See Also Send Feedback

Overload List

Name | Description
Menu()()() |
Menu(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Menu Class
Menu Members
InSite.Model Namespace


Menu Constructor

[image]

.NET Framework Class Library
Menu Constructor
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Menu()
Visual C++
public:
Menu()
JavaScript
InSite.Model.Menu = function();

See Also

Menu Class
Menu Overload
InSite.Model Namespace


Menu Constructor (SearchMode)

[image]

.NET Framework Class Library
Menu Constructor (SearchMode)
Menu Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Menu(
    SearchMode searchMode
)
Visual C++
public:
Menu(
    SearchMode searchMode
)
JavaScript
InSite.Model.Menu = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Menu Class
Menu Overload
InSite.Model Namespace


Menu Fields

[image] [image]

.NET Framework Class Library
Menu Fields
Menu Class See Also Send Feedback

The Menu type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Menu Class
InSite.Model Namespace


Menu Methods

[image] [image]

.NET Framework Class Library
Menu Methods
Menu Class See Also Send Feedback

The Menu type exposes the following members.

Methods

Name | Description
AddSubMenu |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveSubMenu |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Menu Class
InSite.Model Namespace


AddSubMenu Method

[image]

.NET Framework Class Library
Menu..::.AddSubMenu Method
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddSubMenu ( _
    value As Menu _
)
C#
public virtual void AddSubMenu(
    Menu value
)
Visual C++
public:
virtual void AddSubMenu(
    Menu^ value
)
JavaScript
function addSubMenu(value);

Parameters

value
Type: InSite.Model..::.Menu

See Also

Menu Class
InSite.Model Namespace


RemoveSubMenu Method

[image]

.NET Framework Class Library
Menu..::.RemoveSubMenu Method
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSubMenu ( _
    value As Menu _
)
C#
public virtual void RemoveSubMenu(
    Menu value
)
Visual C++
public:
virtual void RemoveSubMenu(
    Menu^ value
)
JavaScript
function removeSubMenu(value);

Parameters

value
Type: InSite.Model..::.Menu

See Also

Menu Class
InSite.Model Namespace


Menu Properties

[image] [image]

.NET Framework Class Library
Menu Properties
Menu Class See Also Send Feedback

The Menu type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
Image |
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
MenuId |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentMenu |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
SubMenus |
Target |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Menu Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Menu..::.Description Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Menu Class
InSite.Model Namespace


Image Property

[image]

.NET Framework Class Library
Menu..::.Image Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Image As String
C#
[DataMemberAttribute]
public virtual string Image { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Image {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_image();
function set_image(value);

See Also

Menu Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
Menu..::.IsActive Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

Menu Class
InSite.Model Namespace


LanguageCode Property

[image]

.NET Framework Class Library
Menu..::.LanguageCode Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LanguageCode As String
C#
[DataMemberAttribute]
public virtual string LanguageCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_languageCode();
function set_languageCode(value);

See Also

Menu Class
InSite.Model Namespace


MenuId Property

[image]

.NET Framework Class Library
Menu..::.MenuId Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MenuId As Guid
C#
[DataMemberAttribute]
public virtual Guid MenuId { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Guid MenuId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_menuId();
function set_menuId(value);

See Also

Menu Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Menu..::.Name Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Menu Class
InSite.Model Namespace


ParentMenu Property

[image]

.NET Framework Class Library
Menu..::.ParentMenu Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ParentMenu As Menu
C#
[DataMemberAttribute]
public virtual Menu ParentMenu { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Menu^ ParentMenu {
    Menu^ get ();
    void set (Menu^ value);
}
JavaScript
function get_parentMenu();
function set_parentMenu(value);

See Also

Menu Class
InSite.Model Namespace


SortOrder Property

[image]

.NET Framework Class Library
Menu..::.SortOrder Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SortOrder As Integer
C#
[DataMemberAttribute]
public virtual int SortOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int SortOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_sortOrder();
function set_sortOrder(value);

See Also

Menu Class
InSite.Model Namespace


SubMenus Property

[image]

.NET Framework Class Library
Menu..::.SubMenus Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubMenus As ChildList(Of Menu)
C#
[DataMemberAttribute]
public virtual ChildList<Menu> SubMenus { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Menu^>^ SubMenus {
    ChildList<Menu^>^ get ();
    void set (ChildList<Menu^>^ value);
}
JavaScript
function get_subMenus();
function set_subMenus(value);

See Also

Menu Class
InSite.Model Namespace


Target Property

[image]

.NET Framework Class Library
Menu..::.Target Property
Menu Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Target As String
C#
[DataMemberAttribute]
public virtual string Target { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Target {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_target();
function set_target(value);

See Also

Menu Class
InSite.Model Namespace


ModelBase(T) Class

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>) Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ModelBase(Of T As New) _
    Implements IComparable, IValidatable, IExternalizable
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ModelBase<T> : IComparable, IValidatable,
    IExternalizable
where T : new()
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
generic<typename T>
where T : gcnew()
public ref class ModelBase : IComparable,
    IValidatable, IExternalizable
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase<(Of <(T>)>)
InSite.Model..::.Affiliate
InSite.Model..::.ApplicationDictionary
InSite.Model..::.ApplicationLog
InSite.Model..::.ApplicationMessage
InSite.Model..::.ApplicationSetting
InSite.Model..::.Audit
InSite.Model..::.Carrier
InSite.Model..::.CarrierPackage
InSite.Model..::.CarrierZone
InSite.Model..::.CarrierZoneRate
InSite.Model..::.CarrierZoneZipCodeRange
InSite.Model..::.Category
InSite.Model..::.CategoryFilterSection
InSite.Model..::.CategoryProperty
InSite.Model..::.City
InSite.Model..::.Company
InSite.Model..::.Content
InSite.Model..::.ContentManager
InSite.Model..::.Country
InSite.Model..::.County
InSite.Model..::.CreditCard
InSite.Model..::.CreditCardTransaction
InSite.Model..::.Customer
InSite.Model..::.CustomerDiscount
InSite.Model..::.CustomerOrder
InSite.Model..::.CustomerOrderProperty
InSite.Model..::.CustomerProduct
InSite.Model..::.CustomerProductSet
InSite.Model..::.CustomerProperty
InSite.Model..::.Dealer
InSite.Model..::.DealerProperty
InSite.Model..::.DictionaryAttribute
InSite.Model..::.DictionaryLabel
InSite.Model..::.Document
InSite.Model..::.DocumentManager
InSite.Model..::.EmailList
InSite.Model..::.EmailTemplate
InSite.Model..::.FilterSection
InSite.Model..::.FilterValue
InSite.Model..::.GiftCard
InSite.Model..::.GiftCardTransaction
InSite.Model..::.HtmlRedirect
InSite.Model..::.InventoryTransaction
InSite.Model..::.Invoice
InSite.Model..::.InvoiceLine
InSite.Model..::.LocalTaxRate
InSite.Model..::.Menu
InSite.Model..::.NewsArticle
InSite.Model..::.OrderLine
InSite.Model..::.OrderLineAttribute
InSite.Model..::.PackageLine
InSite.Model..::.PaymentTerm
InSite.Model..::.PriceMatrix
InSite.Model..::.Product
InSite.Model..::.ProductInfo
InSite.Model..::.ProductProperty
InSite.Model..::.Promotion
InSite.Model..::.PromotionCode
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionRule
InSite.Model..::.Restriction
InSite.Model..::.Review
InSite.Model..::.Role
InSite.Model..::.Salesman
InSite.Model..::.ScheduledTask
InSite.Model..::.ShipCharge
InSite.Model..::.Shipment
InSite.Model..::.ShipmentPackage
InSite.Model..::.ShippingClassification
InSite.Model..::.ShipRate
InSite.Model..::.ShipRule
InSite.Model..::.ShipVia
InSite.Model..::.SOAFilterObject
InSite.Model..::.SOAFilterProperty
InSite.Model..::.SOAResult
InSite.Model..::.Specification
InSite.Model..::.State
InSite.Model..::.StyleClass
InSite.Model..::.StyleTrait
InSite.Model..::.StyleTraitValue
InSite.Model..::.Subscription
InSite.Model..::.SubscriptionLine
InSite.Model..::.SubscriptionProduct
InSite.Model..::.TaxExemption
InSite.Model..::.UserProfile
InSite.Model..::.UserProfileProperty
InSite.Model..::.Vendor
InSite.Model..::.WebPage
InSite.Model..::.WebPageContent
InSite.Model..::.WebSite
InSite.Model..::.WebSiteConfiguration
InSite.Model..::.WebSiteInfo
InSite.Model..::.WishList
InSite.Model..::.WishListProduct

See Also

ModelBase<(Of <(T>)>) Members
InSite.Model Namespace


ModelBase(T) Members

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>) Members
ModelBase<(Of <(T>)>) Class Constructors Methods Fields Properties See Also Send Feedback

The ModelBase<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
ModelBase<(Of <(T>)>) | Overloaded.

Methods

Name | Description
CompareTo |
ConvertList |
Delete |
Equals | (Overrides Object..::.Equals(Object).)
Evict |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get | Overloaded.
GetCount | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetList | Overloaded.
GetPropertiesCollection |
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImportXLS |
Insert |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal |
SOAGetList |
SOAUpdate | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update |
Validate |
WriteExternal |

Fields

Name | Description
_validationService |

Properties

Name | Description
ChangedProperties |
DataTable |
Id |
IdString |
IsValid |
ObjectState |
QueryRecordCount |
SearchableProperties |
SearchMode |
Serializing |
SOAMessage |
UnchangedProperties |
ValidationMessage |
WriteableColumns |

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ModelBase(T) Constructor

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>) Constructor
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
ModelBase<(Of <(T>)>)()()() |
ModelBase<(Of <(T>)>)(SearchMode) |

See Also

ModelBase<(Of <(T>)>) Class
ModelBase<(Of <(T>)>) Members
InSite.Model Namespace


ModelBase(T) Constructor

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>) Constructor
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ModelBase()
Visual C++
public:
ModelBase()
JavaScript
InSite.Model.ModelBase = function();

See Also

ModelBase<(Of <(T>)>) Class
ModelBase<(Of <(T>)>) Overload
InSite.Model Namespace


ModelBase(T) Constructor (SearchMode)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>) Constructor (SearchMode)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ModelBase(
    SearchMode searchMode
)
Visual C++
public:
ModelBase(
    SearchMode searchMode
)
JavaScript
InSite.Model.ModelBase = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ModelBase<(Of <(T>)>) Class
ModelBase<(Of <(T>)>) Overload
InSite.Model Namespace


ModelBase(T) Fields

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>) Fields
ModelBase<(Of <(T>)>) Class See Also Send Feedback

The ModelBase<(Of <(T>)>) type exposes the following members.

Fields

Name | Description
_validationService |

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


_validationService Field

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::._validationService Field
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _validationService As Validator(Of T)
C#
protected Validator<T> _validationService
Visual C++
protected:
Validator<T>^ _validationService
JavaScript
_validationService

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ModelBase(T) Methods

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>) Methods
ModelBase<(Of <(T>)>) Class See Also Send Feedback

The ModelBase<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
CompareTo |
ConvertList |
Delete |
Equals | (Overrides Object..::.Equals(Object).)
Evict |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get | Overloaded.
GetCount | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetList | Overloaded.
GetPropertiesCollection |
GetType | Gets the Type of the current instance. (Inherited from Object.)
ImportXLS |
Insert |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal |
SOAGetList |
SOAUpdate | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update |
Validate |
WriteExternal |

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


CompareTo Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.CompareTo Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CompareTo ( _
    obj As Object _
) As Integer
C#
public virtual int CompareTo(
    Object obj
)
Visual C++
public:
virtual int CompareTo(
    Object^ obj
)
JavaScript
function compareTo(obj);

Parameters

obj
Type: System..::.Object

Implements

IComparable..::.CompareTo(Object)

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ConvertList Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.ConvertList Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ConvertList ( _
    source As IList, _
    toListType As Type _
) As IList
C#
public static IList ConvertList(
    IList source,
    Type toListType
)
Visual C++
public:
static IList^ ConvertList(
    IList^ source,
    Type^ toListType
)
JavaScript
InSite.Model.ModelBase.convertList = function(source, toListType);

Parameters

source
Type: System.Collections..::.IList
toListType
Type: System..::.Type

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


Delete Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Delete Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Delete ( _
    obj As T _
)
C#
public static void Delete(
    T obj
)
Visual C++
public:
static void Delete(
    T obj
)
JavaScript
InSite.Model.ModelBase.delete = function(obj);

Parameters

obj
Type: T

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


Equals Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Equals Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::.Object

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


Evict Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Evict Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Evict ( _
    obj As T _
)
C#
public static void Evict(
    T obj
)
Visual C++
public:
static void Evict(
    T obj
)
JavaScript
InSite.Model.ModelBase.evict = function(obj);

Parameters

obj
Type: T

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


Get Method

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Get Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
Get(Guid) |
Get(String) |
Get(T) |

See Also

ModelBase<(Of <(T>)>) Class
ModelBase<(Of <(T>)>) Members
InSite.Model Namespace


Get Method (Guid)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Get Method (Guid)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get ( _
    id As Guid _
) As T
C#
public static T Get(
    Guid id
)
Visual C++
public:
static T Get(
    Guid id
)
JavaScript
InSite.Model.ModelBase.get = function(id);

Parameters

id
Type: System..::.Guid

See Also

ModelBase<(Of <(T>)>) Class
Get Overload
InSite.Model Namespace


Get Method (String)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Get Method (String)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get ( _
    id As String _
) As T
C#
public static T Get(
    string id
)
Visual C++
public:
static T Get(
    String^ id
)
JavaScript
InSite.Model.ModelBase.get = function(id);

Parameters

id
Type: System..::.String

See Also

ModelBase<(Of <(T>)>) Class
Get Overload
InSite.Model Namespace


Get Method (T)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Get Method (T)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get ( _
    query As T _
) As T
C#
public static T Get(
    T query
)
Visual C++
public:
static T Get(
    T query
)
JavaScript
InSite.Model.ModelBase.get = function(query);

Parameters

query
Type: T

See Also

ModelBase<(Of <(T>)>) Class
Get Overload
InSite.Model Namespace


GetCount Method

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetCount Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
GetCount()()() |
GetCount(String, Hashtable, NameValueCollection) |

See Also

ModelBase<(Of <(T>)>) Class
ModelBase<(Of <(T>)>) Members
InSite.Model Namespace


GetCount Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetCount Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCount As Integer
C#
public static int GetCount()
Visual C++
public:
static int GetCount()
JavaScript
InSite.Model.ModelBase.getCount = function();

See Also

ModelBase<(Of <(T>)>) Class
GetCount Overload
InSite.Model Namespace


GetCount Method (String, Hashtable, NameValueCollection)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetCount Method (String, Hashtable, NameValueCollection)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCount ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection _
) As Integer
C#
public static int GetCount(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions
)
Visual C++
public:
static int GetCount(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions
)
JavaScript
InSite.Model.ModelBase.getCount = function(query, parameters, queryOptions);

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection

See Also

ModelBase<(Of <(T>)>) Class
GetCount Overload
InSite.Model Namespace


GetHashCode Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetHashCode Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


GetList Method

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
GetList()()() |
GetList(Guid) |
GetList(String) |
GetList(T, String) |
GetList(String, Hashtable, NameValueCollection) |
GetList(String, Int32, Int32) |
GetList(String, String, String) |
GetList(T, String, Int32, Int32) |
GetList(String, Hashtable, NameValueCollection, Int32, Int32) |
GetList(String, String, String, Int32, Int32) |

See Also

ModelBase<(Of <(T>)>) Class
ModelBase<(Of <(T>)>) Members
InSite.Model Namespace


GetList Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList As IList(Of T)
C#
public static IList<T> GetList()
Visual C++
public:
static IList<T>^ GetList()
JavaScript
InSite.Model.ModelBase.getList = function();

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (Guid)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (Guid)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    id As Guid _
) As IList(Of T)
C#
public static IList<T> GetList(
    Guid id
)
Visual C++
public:
static IList<T>^ GetList(
    Guid id
)
JavaScript
InSite.Model.ModelBase.getList = function(id);

Parameters

id
Type: System..::.Guid

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (String)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (String)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    sort As String _
) As IList(Of T)
C#
public static IList<T> GetList(
    string sort
)
Visual C++
public:
static IList<T>^ GetList(
    String^ sort
)
JavaScript
InSite.Model.ModelBase.getList = function(sort);

Parameters

sort
Type: System..::.String

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (T, String)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (T, String)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    query As T, _
    sort As String _
) As IList(Of T)
C#
public static IList<T> GetList(
    T query,
    string sort
)
Visual C++
public:
static IList<T>^ GetList(
    T query,
    String^ sort
)
JavaScript
InSite.Model.ModelBase.getList = function(query, sort);

Parameters

query
Type: T
sort
Type: System..::.String

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (String, Hashtable, NameValueCollection)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (String, Hashtable, NameValueCollection)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection _
) As IList(Of T)
C#
public static IList<T> GetList(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions
)
Visual C++
public:
static IList<T>^ GetList(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions
)
JavaScript
InSite.Model.ModelBase.getList = function(query, parameters, queryOptions);

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (String, Int32, Int32)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (String, Int32, Int32)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    sort As String, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of T)
C#
public static IList<T> GetList(
    string sort,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<T>^ GetList(
    String^ sort,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.ModelBase.getList = function(sort, startRow, pageSize);

Parameters

sort
Type: System..::.String
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (String, String, String)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (String, String, String)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    propertyName As String, _
    propertyValue As String, _
    sort As String _
) As IList(Of T)
C#
public static IList<T> GetList(
    string propertyName,
    string propertyValue,
    string sort
)
Visual C++
public:
static IList<T>^ GetList(
    String^ propertyName,
    String^ propertyValue,
    String^ sort
)
JavaScript
InSite.Model.ModelBase.getList = function(propertyName, propertyValue, sort);

Parameters

propertyName
Type: System..::.String
propertyValue
Type: System..::.String
sort
Type: System..::.String

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (T, String, Int32, Int32)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (T, String, Int32, Int32)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    query As T, _
    sort As String, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of T)
C#
public static IList<T> GetList(
    T query,
    string sort,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<T>^ GetList(
    T query,
    String^ sort,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.ModelBase.getList = function(query, sort, startRow, pageSize);

Parameters

query
Type: T
sort
Type: System..::.String
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (String, Hashtable, NameValueCollection, Int32, Int32)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (String, Hashtable, NameValueCollection, Int32, Int32)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of T)
C#
public static IList<T> GetList(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<T>^ GetList(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.ModelBase.getList = function(query, parameters, queryOptions, startRow, pageSize);

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetList Method (String, String, String, Int32, Int32)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetList Method (String, String, String, Int32, Int32)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    propertyName As String, _
    propertyValue As String, _
    sort As String, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of T)
C#
public static IList<T> GetList(
    string propertyName,
    string propertyValue,
    string sort,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<T>^ GetList(
    String^ propertyName,
    String^ propertyValue,
    String^ sort,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.ModelBase.getList = function(propertyName, propertyValue, sort, startRow, pageSize);

Parameters

propertyName
Type: System..::.String
propertyValue
Type: System..::.String
sort
Type: System..::.String
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

ModelBase<(Of <(T>)>) Class
GetList Overload
InSite.Model Namespace


GetPropertiesCollection Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.GetPropertiesCollection Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPropertiesCollection As NameValueCollection
C#
public virtual NameValueCollection GetPropertiesCollection()
Visual C++
public:
virtual NameValueCollection^ GetPropertiesCollection()
JavaScript
function getPropertiesCollection();

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ImportXLS Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.ImportXLS Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ImportXLS ( _
    pathName As String, _
    fileName As String _
) As IList(Of T)
C#
public static IList<T> ImportXLS(
    string pathName,
    string fileName
)
Visual C++
public:
static IList<T>^ ImportXLS(
    String^ pathName,
    String^ fileName
)
JavaScript
InSite.Model.ModelBase.importXLS = function(pathName, fileName);

Parameters

pathName
Type: System..::.String
fileName
Type: System..::.String

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


Insert Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Insert Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Insert ( _
    obj As T _
)
C#
public static void Insert(
    T obj
)
Visual C++
public:
static void Insert(
    T obj
)
JavaScript
InSite.Model.ModelBase.insert = function(obj);

Parameters

obj
Type: T

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ReadExternal Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.ReadExternal Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub ReadExternal ( _
    input As IDataInput _
)
C#
public virtual void ReadExternal(
    IDataInput input
)
Visual C++
public:
virtual void ReadExternal(
    IDataInput^ input
)
JavaScript
function readExternal(input);

Parameters

input
Type: IDataInput

Implements

IExternalizableReadExternal(IDataInput)

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


SOAGetList Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SOAGetList Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SOAGetList ( _
    filter As SOAFilterObject, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of T)
C#
public static IList<T> SOAGetList(
    SOAFilterObject filter,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<T>^ SOAGetList(
    SOAFilterObject^ filter,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.ModelBase.soaGetList = function(filter, startRow, pageSize);

Parameters

filter
Type: InSite.Model..::.SOAFilterObject
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


SOAUpdate Method

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SOAUpdate Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Overload List

Name | Description
SOAUpdate(IList<(Of <(T>)>)) |
SOAUpdate(Object, IList<(Of <(T>)>)) |
SOAUpdate(Object, IList<(Of <(T>)>), Boolean) |
SOAUpdate(Object, IList<(Of <(T>)>), Boolean, String) |

See Also

ModelBase<(Of <(T>)>) Class
ModelBase<(Of <(T>)>) Members
InSite.Model Namespace


SOAUpdate Method (IList(T))

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SOAUpdate Method (IList<(Of <(T>)>))
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SOAUpdate ( _
    updates As IList(Of T) _
) As IList(Of SOAResult)
C#
public static IList<SOAResult> SOAUpdate(
    IList<T> updates
)
Visual C++
public:
static IList<SOAResult^>^ SOAUpdate(
    IList<T>^ updates
)
JavaScript
InSite.Model.ModelBase.soaUpdate = function(updates);

Parameters

updates
Type: System.Collections.Generic..::.IList <(Of <( T >)>)

See Also

ModelBase<(Of <(T>)>) Class
SOAUpdate Overload
InSite.Model Namespace


SOAUpdate Method (Object, IList(T))

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SOAUpdate Method (Object, IList<(Of <(T>)>))
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SOAUpdate ( _
    parent As Object, _
    updates As IList(Of T) _
) As IList(Of SOAResult)
C#
public static IList<SOAResult> SOAUpdate(
    Object parent,
    IList<T> updates
)
Visual C++
public:
static IList<SOAResult^>^ SOAUpdate(
    Object^ parent,
    IList<T>^ updates
)
JavaScript
InSite.Model.ModelBase.soaUpdate = function(parent, updates);

Parameters

parent
Type: System..::.Object
updates
Type: System.Collections.Generic..::.IList <(Of <( T >)>)

See Also

ModelBase<(Of <(T>)>) Class
SOAUpdate Overload
InSite.Model Namespace


SOAUpdate Method (Object, IList(T), Boolean)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SOAUpdate Method (Object, IList<(Of <(T>)>), Boolean)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SOAUpdate ( _
    parent As Object, _
    updates As IList(Of T), _
    saveChildren As Boolean _
) As IList(Of SOAResult)
C#
public static IList<SOAResult> SOAUpdate(
    Object parent,
    IList<T> updates,
    bool saveChildren
)
Visual C++
public:
static IList<SOAResult^>^ SOAUpdate(
    Object^ parent,
    IList<T>^ updates,
    bool saveChildren
)
JavaScript
InSite.Model.ModelBase.soaUpdate = function(parent, updates, saveChildren);

Parameters

parent
Type: System..::.Object
updates
Type: System.Collections.Generic..::.IList <(Of <( T >)>)
saveChildren
Type: System..::.Boolean

See Also

ModelBase<(Of <(T>)>) Class
SOAUpdate Overload
InSite.Model Namespace


SOAUpdate Method (Object, IList(T), Boolean, String)

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SOAUpdate Method (Object, IList<(Of <(T>)>), Boolean, String)
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SOAUpdate ( _
    parent As Object, _
    updates As IList(Of T), _
    saveChildren As Boolean, _
    childName As String _
) As IList(Of SOAResult)
C#
public static IList<SOAResult> SOAUpdate(
    Object parent,
    IList<T> updates,
    bool saveChildren,
    string childName
)
Visual C++
public:
static IList<SOAResult^>^ SOAUpdate(
    Object^ parent,
    IList<T>^ updates,
    bool saveChildren,
    String^ childName
)
JavaScript
InSite.Model.ModelBase.soaUpdate = function(parent, updates, saveChildren, childName);

Parameters

parent
Type: System..::.Object
updates
Type: System.Collections.Generic..::.IList <(Of <( T >)>)
saveChildren
Type: System..::.Boolean
childName
Type: System..::.String

See Also

ModelBase<(Of <(T>)>) Class
SOAUpdate Overload
InSite.Model Namespace


Update Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Update Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Update ( _
    obj As T _
)
C#
public static void Update(
    T obj
)
Visual C++
public:
static void Update(
    T obj
)
JavaScript
InSite.Model.ModelBase.update = function(obj);

Parameters

obj
Type: T

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


Validate Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Validate Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Validate As ValidationResults
C#
public virtual ValidationResults Validate()
Visual C++
public:
virtual ValidationResults^ Validate()
JavaScript
function validate();

Implements

IValidatable..::.Validate()()()

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


WriteExternal Method

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.WriteExternal Method
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteExternal ( _
    output As IDataOutput _
)
C#
public virtual void WriteExternal(
    IDataOutput output
)
Visual C++
public:
virtual void WriteExternal(
    IDataOutput^ output
)
JavaScript
function writeExternal(output);

Parameters

output
Type: IDataOutput

Implements

IExternalizableWriteExternal(IDataOutput)

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ModelBase(T) Properties

[image] [image]

.NET Framework Class Library
ModelBase<(Of <(T>)>) Properties
ModelBase<(Of <(T>)>) Class See Also Send Feedback

The ModelBase<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
ChangedProperties |
DataTable |
Id |
IdString |
IsValid |
ObjectState |
QueryRecordCount |
SearchableProperties |
SearchMode |
Serializing |
SOAMessage |
UnchangedProperties |
ValidationMessage |
WriteableColumns |

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ChangedProperties Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.ChangedProperties Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ChangedProperties As List(Of String)
C#
public virtual List<string> ChangedProperties { get; }
Visual C++
public:
virtual property List<String^>^ ChangedProperties {
    List<String^>^ get ();
}
JavaScript
function get_changedProperties();

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


DataTable Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.DataTable Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DataTable As DataTable
C#
public virtual DataTable DataTable { get; }
Visual C++
public:
virtual property DataTable^ DataTable {
    DataTable^ get ();
}
JavaScript
function get_dataTable();

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


Id Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Id Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Id As Guid
C#
public virtual Guid Id { get; set; }
Visual C++
public:
virtual property Guid Id {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_id();
function set_id(value);

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


IdString Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.IdString Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IdString As String
C#
[DataMemberAttribute]
public virtual string IdString { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ IdString {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_idString();
function set_idString(value);

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


IsValid Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.IsValid Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsValid As Boolean
C#
public virtual bool IsValid { get; }
Visual C++
public:
virtual property bool IsValid {
    bool get ();
}
JavaScript
function get_isValid();

Implements

IValidatable..::.IsValid

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ObjectState Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.ObjectState Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ObjectState As String
C#
[DataMemberAttribute]
public virtual string ObjectState { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ObjectState {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_objectState();
function set_objectState(value);

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


QueryRecordCount Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.QueryRecordCount Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property QueryRecordCount As Integer
C#
[DataMemberAttribute]
public virtual int QueryRecordCount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int QueryRecordCount {
    int get ();
    void set (int value);
}
JavaScript
function get_queryRecordCount();
function set_queryRecordCount(value);

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


SearchableProperties Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SearchableProperties Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property SearchableProperties As List(Of String)
C#
public virtual List<string> SearchableProperties { get; }
Visual C++
public:
virtual property List<String^>^ SearchableProperties {
    List<String^>^ get ();
}
JavaScript
function get_searchableProperties();

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


SearchMode Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SearchMode Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SearchMode As SearchMode
C#
public virtual SearchMode SearchMode { get; set; }
Visual C++
public:
virtual property SearchMode SearchMode {
    SearchMode get ();
    void set (SearchMode value);
}
JavaScript
function get_searchMode();
function set_searchMode(value);

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


Serializing Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.Serializing Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Serializing As Boolean
C#
public virtual bool Serializing { get; set; }
Visual C++
public:
virtual property bool Serializing {
    bool get ();
    void set (bool value);
}
JavaScript
function get_serializing();
function set_serializing(value);

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


SOAMessage Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.SOAMessage Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SOAMessage As String
C#
[DataMemberAttribute]
public virtual string SOAMessage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SOAMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_soaMessage();
function set_soaMessage(value);

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


UnchangedProperties Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.UnchangedProperties Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property UnchangedProperties As List(Of String)
C#
public virtual List<string> UnchangedProperties { get; }
Visual C++
public:
virtual property List<String^>^ UnchangedProperties {
    List<String^>^ get ();
}
JavaScript
function get_unchangedProperties();

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


ValidationMessage Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.ValidationMessage Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ValidationMessage As String
C#
[DataMemberAttribute]
public virtual string ValidationMessage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ValidationMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_validationMessage();
function set_validationMessage(value);

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


WriteableColumns Property

[image]

.NET Framework Class Library
ModelBase<(Of <(T>)>)..::.WriteableColumns Property
ModelBase<(Of <(T>)>) Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property WriteableColumns As String
C#
public virtual string WriteableColumns { get; }
Visual C++
public:
virtual property String^ WriteableColumns {
    String^ get ();
}
JavaScript
function get_writeableColumns();

See Also

ModelBase<(Of <(T>)>) Class
InSite.Model Namespace


NewsArticle Class

[image]

.NET Framework Class Library
NewsArticle Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class NewsArticle _
    Inherits ModelBase(Of NewsArticle)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class NewsArticle : ModelBase<NewsArticle>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class NewsArticle : public ModelBase<NewsArticle^>
JavaScript
InSite.Model.NewsArticle = function();

Type.createClass(
    'InSite.Model.NewsArticle',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(NewsArticle>)>)
InSite.Model..::.NewsArticle

See Also

NewsArticle Members
InSite.Model Namespace


NewsArticle Members

[image] [image]

.NET Framework Class Library
NewsArticle Members
NewsArticle Class Constructors Methods Fields Properties See Also Send Feedback

The NewsArticle type exposes the following members.

Constructors

Name | Description
NewsArticle | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LargeImage |
NewsArticleDate |
NewsArticleId |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentWebSiteName |
PublishDate |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SmallImage |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Title |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

NewsArticle Class
InSite.Model Namespace


NewsArticle Constructor

[image] [image]

.NET Framework Class Library
NewsArticle Constructor
NewsArticle Class See Also Send Feedback

Overload List

Name | Description
NewsArticle()()() |
NewsArticle(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

NewsArticle Class
NewsArticle Members
InSite.Model Namespace


NewsArticle Constructor

[image]

.NET Framework Class Library
NewsArticle Constructor
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public NewsArticle()
Visual C++
public:
NewsArticle()
JavaScript
InSite.Model.NewsArticle = function();

See Also

NewsArticle Class
NewsArticle Overload
InSite.Model Namespace


NewsArticle Constructor (SearchMode)

[image]

.NET Framework Class Library
NewsArticle Constructor (SearchMode)
NewsArticle Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public NewsArticle(
    SearchMode searchMode
)
Visual C++
public:
NewsArticle(
    SearchMode searchMode
)
JavaScript
InSite.Model.NewsArticle = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

NewsArticle Class
NewsArticle Overload
InSite.Model Namespace


NewsArticle Fields

[image] [image]

.NET Framework Class Library
NewsArticle Fields
NewsArticle Class See Also Send Feedback

The NewsArticle type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

NewsArticle Class
InSite.Model Namespace


NewsArticle Methods

[image] [image]

.NET Framework Class Library
NewsArticle Methods
NewsArticle Class See Also Send Feedback

The NewsArticle type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

NewsArticle Class
InSite.Model Namespace


NewsArticle Properties

[image] [image]

.NET Framework Class Library
NewsArticle Properties
NewsArticle Class See Also Send Feedback

The NewsArticle type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LargeImage |
NewsArticleDate |
NewsArticleId |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentWebSiteName |
PublishDate |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SmallImage |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Title |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

NewsArticle Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
NewsArticle..::.ContentManager Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

NewsArticle Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
NewsArticle..::.Description Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

NewsArticle Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
NewsArticle..::.HtmlContent Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HtmlContent As String
C#
[DataMemberAttribute]
public virtual string HtmlContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

NewsArticle Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
NewsArticle..::.IsActive Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

NewsArticle Class
InSite.Model Namespace


LargeImage Property

[image]

.NET Framework Class Library
NewsArticle..::.LargeImage Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LargeImage As String
C#
[DataMemberAttribute]
public virtual string LargeImage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LargeImage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_largeImage();
function set_largeImage(value);

See Also

NewsArticle Class
InSite.Model Namespace


NewsArticleDate Property

[image]

.NET Framework Class Library
NewsArticle..::.NewsArticleDate Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property NewsArticleDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime NewsArticleDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime NewsArticleDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_newsArticleDate();
function set_newsArticleDate(value);

See Also

NewsArticle Class
InSite.Model Namespace


NewsArticleId Property

[image]

.NET Framework Class Library
NewsArticle..::.NewsArticleId Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property NewsArticleId As Guid
C#
public virtual Guid NewsArticleId { get; set; }
Visual C++
public:
virtual property Guid NewsArticleId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_newsArticleId();
function set_newsArticleId(value);

See Also

NewsArticle Class
InSite.Model Namespace


ParentWebSiteName Property

[image]

.NET Framework Class Library
NewsArticle..::.ParentWebSiteName Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ParentWebSiteName As String
C#
[DataMemberAttribute]
public virtual string ParentWebSiteName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ParentWebSiteName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parentWebSiteName();
function set_parentWebSiteName(value);

See Also

NewsArticle Class
InSite.Model Namespace


PublishDate Property

[image]

.NET Framework Class Library
NewsArticle..::.PublishDate Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PublishDate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> PublishDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> PublishDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_publishDate();
function set_publishDate(value);

See Also

NewsArticle Class
InSite.Model Namespace


SmallImage Property

[image]

.NET Framework Class Library
NewsArticle..::.SmallImage Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SmallImage As String
C#
[DataMemberAttribute]
public virtual string SmallImage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SmallImage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_smallImage();
function set_smallImage(value);

See Also

NewsArticle Class
InSite.Model Namespace


Title Property

[image]

.NET Framework Class Library
NewsArticle..::.Title Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Title As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Title { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

See Also

NewsArticle Class
InSite.Model Namespace


UserProfile Property

[image]

.NET Framework Class Library
NewsArticle..::.UserProfile Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfile As UserProfile
C#
public virtual UserProfile UserProfile { get; set; }
Visual C++
public:
virtual property UserProfile^ UserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_userProfile();
function set_userProfile(value);

See Also

NewsArticle Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
NewsArticle..::.WebSite Property
NewsArticle Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

NewsArticle Class
InSite.Model Namespace


ObjectState Class

[image]

.NET Framework Class Library
ObjectState Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class ObjectState
C#
public sealed class ObjectState
Visual C++
public ref class ObjectState sealed
JavaScript
InSite.Model.ObjectState = function();

Type.createClass(
    'InSite.Model.ObjectState');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ObjectState

See Also

ObjectState Members
InSite.Model Namespace


ObjectState Members

[image] [image]

.NET Framework Class Library
ObjectState Members
ObjectState Class Constructors Methods Fields See Also Send Feedback

The ObjectState type exposes the following members.

Constructors

Name | Description
ObjectState |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Clean |
Deleted |
Inserted |
Modified |

See Also

ObjectState Class
InSite.Model Namespace


ObjectState Constructor

[image]

.NET Framework Class Library
ObjectState Constructor
ObjectState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ObjectState()
Visual C++
public:
ObjectState()
JavaScript
InSite.Model.ObjectState = function();

See Also

ObjectState Class
InSite.Model Namespace


ObjectState Fields

[image] [image]

.NET Framework Class Library
ObjectState Fields
ObjectState Class See Also Send Feedback

The ObjectState type exposes the following members.

Fields

Name | Description
Clean |
Deleted |
Inserted |
Modified |

See Also

ObjectState Class
InSite.Model Namespace


Clean Field

[image]

.NET Framework Class Library
ObjectState..::.Clean Field
ObjectState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Clean As String
C#
public static string Clean
Visual C++
public:
static String^ Clean
JavaScript
InSite.Model.ObjectState.clean

See Also

ObjectState Class
InSite.Model Namespace


Deleted Field

[image]

.NET Framework Class Library
ObjectState..::.Deleted Field
ObjectState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Deleted As String
C#
public static string Deleted
Visual C++
public:
static String^ Deleted
JavaScript
InSite.Model.ObjectState.deleted

See Also

ObjectState Class
InSite.Model Namespace


Inserted Field

[image]

.NET Framework Class Library
ObjectState..::.Inserted Field
ObjectState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Inserted As String
C#
public static string Inserted
Visual C++
public:
static String^ Inserted
JavaScript
InSite.Model.ObjectState.inserted

See Also

ObjectState Class
InSite.Model Namespace


Modified Field

[image]

.NET Framework Class Library
ObjectState..::.Modified Field
ObjectState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Modified As String
C#
public static string Modified
Visual C++
public:
static String^ Modified
JavaScript
InSite.Model.ObjectState.modified

See Also

ObjectState Class
InSite.Model Namespace


ObjectState Methods

[image] [image]

.NET Framework Class Library
ObjectState Methods
ObjectState Class See Also Send Feedback

The ObjectState type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectState Class
InSite.Model Namespace


OrderLine Class

[image]

.NET Framework Class Library
OrderLine Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class OrderLine _
    Inherits ModelBase(Of OrderLine)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class OrderLine : ModelBase<OrderLine>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class OrderLine : public ModelBase<OrderLine^>
JavaScript
InSite.Model.OrderLine = function();

Type.createClass(
    'InSite.Model.OrderLine',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(OrderLine>)>)
InSite.Model..::.OrderLine

See Also

OrderLine Members
InSite.Model Namespace


OrderLine Members

[image] [image]

.NET Framework Class Library
OrderLine Members
OrderLine Class Constructors Methods Fields Properties See Also Send Feedback

The OrderLine type exposes the following members.

Constructors

Name | Description
OrderLine | Overloaded.

Methods

Name | Description
AddOrderLineAttribute |
CalculatePrice |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetOrderLineAttribute |
GetOrderLineAttributeValue |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveOrderLineAttribute |
SaveConfigDataSet |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ActualPrice |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ConfigDataSet |
ConfiguredOptions |
CustomerOrder |
CustomerPOLine |
CustomerProductNumber |
CustomerRegularPrice | CustomerRegularPrice - If there is Customer Specific Pricing, this will return the Regular Price for this Customer without any Discounts applied
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
DescriptionWithAttributes | Returns the description of the OrderLine along with all OrderLineAttribute name/value pairs in the following format:
DescriptionWithConfiguredOptions |
DiscountAmount |
DiscountPercent |
DueDate |
ERPNumber |
ExtendedActualPrice |
ExtendedRegularPrice |
GiftCard |
GiftCardAmount |
GiftCardBalance |
GiftCardExpiration |
GiftCardNumber |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsGiftCard |
IsPromotionItem |
IsSubscription |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Line |
Notes |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderLineAttributes |
OrderLineId |
OrderLineSavingsAmount |
OrderLineSavingsPercent |
PassesRestrictions |
Product |
ProductActualPrice |
ProductExtendedActualPrice |
ProductExtendedRegularPrice |
ProductId |
ProductName |
ProductRegularPrice |
PromiseDate |
PromotionResult |
QtyOrdered |
QtyShipped |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RegularPrice |
Release |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipDate |
ShipSite |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Status |
SubscriptionProductName |
TaxCode1 |
TaxCode2 |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UnitOfMeasure |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

OrderLine Class
InSite.Model Namespace


OrderLine Constructor

[image] [image]

.NET Framework Class Library
OrderLine Constructor
OrderLine Class See Also Send Feedback

Overload List

Name | Description
OrderLine()()() |
OrderLine(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

OrderLine Class
OrderLine Members
InSite.Model Namespace


OrderLine Constructor

[image]

.NET Framework Class Library
OrderLine Constructor
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OrderLine()
Visual C++
public:
OrderLine()
JavaScript
InSite.Model.OrderLine = function();

See Also

OrderLine Class
OrderLine Overload
InSite.Model Namespace


OrderLine Constructor (SearchMode)

[image]

.NET Framework Class Library
OrderLine Constructor (SearchMode)
OrderLine Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public OrderLine(
    SearchMode searchMode
)
Visual C++
public:
OrderLine(
    SearchMode searchMode
)
JavaScript
InSite.Model.OrderLine = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

OrderLine Class
OrderLine Overload
InSite.Model Namespace


OrderLine Fields

[image] [image]

.NET Framework Class Library
OrderLine Fields
OrderLine Class See Also Send Feedback

The OrderLine type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

OrderLine Class
InSite.Model Namespace


OrderLine Methods

[image] [image]

.NET Framework Class Library
OrderLine Methods
OrderLine Class See Also Send Feedback

The OrderLine type exposes the following members.

Methods

Name | Description
AddOrderLineAttribute |
CalculatePrice |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetOrderLineAttribute |
GetOrderLineAttributeValue |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveOrderLineAttribute |
SaveConfigDataSet |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

OrderLine Class
InSite.Model Namespace


AddOrderLineAttribute Method

[image]

.NET Framework Class Library
OrderLine..::.AddOrderLineAttribute Method
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddOrderLineAttribute ( _
    value As OrderLineAttribute _
)
C#
public virtual void AddOrderLineAttribute(
    OrderLineAttribute value
)
Visual C++
public:
virtual void AddOrderLineAttribute(
    OrderLineAttribute^ value
)
JavaScript
function addOrderLineAttribute(value);

Parameters

value
Type: InSite.Model..::.OrderLineAttribute

See Also

OrderLine Class
InSite.Model Namespace


CalculatePrice Method

[image]

.NET Framework Class Library
OrderLine..::.CalculatePrice Method
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub CalculatePrice
C#
public virtual void CalculatePrice()
Visual C++
public:
virtual void CalculatePrice()
JavaScript
function calculatePrice();

See Also

OrderLine Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
OrderLine..::.Copy Method
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As OrderLine
C#
public virtual OrderLine Copy()
Visual C++
public:
virtual OrderLine^ Copy()
JavaScript
function copy();

See Also

OrderLine Class
InSite.Model Namespace


GetOrderLineAttribute Method

[image]

.NET Framework Class Library
OrderLine..::.GetOrderLineAttribute Method
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetOrderLineAttribute ( _
    name As String _
) As OrderLineAttribute
C#
public virtual OrderLineAttribute GetOrderLineAttribute(
    string name
)
Visual C++
public:
virtual OrderLineAttribute^ GetOrderLineAttribute(
    String^ name
)
JavaScript
function getOrderLineAttribute(name);

Parameters

name
Type: System..::.String

See Also

OrderLine Class
InSite.Model Namespace


GetOrderLineAttributeValue Method

[image]

.NET Framework Class Library
OrderLine..::.GetOrderLineAttributeValue Method
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetOrderLineAttributeValue ( _
    name As String _
) As String
C#
public virtual string GetOrderLineAttributeValue(
    string name
)
Visual C++
public:
virtual String^ GetOrderLineAttributeValue(
    String^ name
)
JavaScript
function getOrderLineAttributeValue(name);

Parameters

name
Type: System..::.String

See Also

OrderLine Class
InSite.Model Namespace


RemoveOrderLineAttribute Method

[image]

.NET Framework Class Library
OrderLine..::.RemoveOrderLineAttribute Method
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveOrderLineAttribute ( _
    value As OrderLineAttribute _
)
C#
public virtual void RemoveOrderLineAttribute(
    OrderLineAttribute value
)
Visual C++
public:
virtual void RemoveOrderLineAttribute(
    OrderLineAttribute^ value
)
JavaScript
function removeOrderLineAttribute(value);

Parameters

value
Type: InSite.Model..::.OrderLineAttribute

See Also

OrderLine Class
InSite.Model Namespace


SaveConfigDataSet Method

[image]

.NET Framework Class Library
OrderLine..::.SaveConfigDataSet Method
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveConfigDataSet
C#
public virtual void SaveConfigDataSet()
Visual C++
public:
virtual void SaveConfigDataSet()
JavaScript
function saveConfigDataSet();

See Also

OrderLine Class
InSite.Model Namespace


OrderLine Properties

[image] [image]

.NET Framework Class Library
OrderLine Properties
OrderLine Class See Also Send Feedback

The OrderLine type exposes the following members.

Properties

Name | Description
ActualPrice |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ConfigDataSet |
ConfiguredOptions |
CustomerOrder |
CustomerPOLine |
CustomerProductNumber |
CustomerRegularPrice | CustomerRegularPrice - If there is Customer Specific Pricing, this will return the Regular Price for this Customer without any Discounts applied
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
DescriptionWithAttributes | Returns the description of the OrderLine along with all OrderLineAttribute name/value pairs in the following format:
DescriptionWithConfiguredOptions |
DiscountAmount |
DiscountPercent |
DueDate |
ERPNumber |
ExtendedActualPrice |
ExtendedRegularPrice |
GiftCard |
GiftCardAmount |
GiftCardBalance |
GiftCardExpiration |
GiftCardNumber |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsGiftCard |
IsPromotionItem |
IsSubscription |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Line |
Notes |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderLineAttributes |
OrderLineId |
OrderLineSavingsAmount |
OrderLineSavingsPercent |
PassesRestrictions |
Product |
ProductActualPrice |
ProductExtendedActualPrice |
ProductExtendedRegularPrice |
ProductId |
ProductName |
ProductRegularPrice |
PromiseDate |
PromotionResult |
QtyOrdered |
QtyShipped |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RegularPrice |
Release |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipDate |
ShipSite |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Status |
SubscriptionProductName |
TaxCode1 |
TaxCode2 |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UnitOfMeasure |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

OrderLine Class
InSite.Model Namespace


ActualPrice Property

[image]

.NET Framework Class Library
OrderLine..::.ActualPrice Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ActualPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal ActualPrice { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ActualPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_actualPrice();
function set_actualPrice(value);

See Also

OrderLine Class
InSite.Model Namespace


ConfigDataSet Property

[image]

.NET Framework Class Library
OrderLine..::.ConfigDataSet Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ConfigDataSet As DataSet
C#
public virtual DataSet ConfigDataSet { get; set; }
Visual C++
public:
virtual property DataSet^ ConfigDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_configDataSet();
function set_configDataSet(value);

See Also

OrderLine Class
InSite.Model Namespace


ConfiguredOptions Property

[image]

.NET Framework Class Library
OrderLine..::.ConfiguredOptions Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ConfiguredOptions As String
C#
public virtual string ConfiguredOptions { get; }
Visual C++
public:
virtual property String^ ConfiguredOptions {
    String^ get ();
}
JavaScript
function get_configuredOptions();

See Also

OrderLine Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
OrderLine..::.CustomerOrder Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

OrderLine Class
InSite.Model Namespace


CustomerPOLine Property

[image]

.NET Framework Class Library
OrderLine..::.CustomerPOLine Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerPOLine As String
C#
[DataMemberAttribute]
public virtual string CustomerPOLine { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerPOLine {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerPOLine();
function set_customerPOLine(value);

See Also

OrderLine Class
InSite.Model Namespace


CustomerProductNumber Property

[image]

.NET Framework Class Library
OrderLine..::.CustomerProductNumber Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property CustomerProductNumber As String
C#
[DataMemberAttribute]
public virtual string CustomerProductNumber { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerProductNumber {
    String^ get ();
}
JavaScript
function get_customerProductNumber();

See Also

OrderLine Class
InSite.Model Namespace


CustomerRegularPrice Property

[image]

.NET Framework Class Library
OrderLine..::.CustomerRegularPrice Property
OrderLine Class See Also Send Feedback

CustomerRegularPrice - If there is Customer Specific Pricing, this will return the Regular Price for this Customer without any Discounts applied

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property CustomerRegularPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal CustomerRegularPrice { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal CustomerRegularPrice {
    Decimal get ();
}
JavaScript
function get_customerRegularPrice();

See Also

OrderLine Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
OrderLine..::.Description Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

OrderLine Class
InSite.Model Namespace


DescriptionWithAttributes Property

[image]

.NET Framework Class Library
OrderLine..::.DescriptionWithAttributes Property
OrderLine Class See Also Send Feedback

Returns the description of the OrderLine along with all OrderLineAttribute name/value pairs in the following format:

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property DescriptionWithAttributes As String
C#
[DataMemberAttribute]
public virtual string DescriptionWithAttributes { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DescriptionWithAttributes {
    String^ get ();
}
JavaScript
function get_descriptionWithAttributes();

See Also

OrderLine Class
InSite.Model Namespace


DescriptionWithConfiguredOptions Property

[image]

.NET Framework Class Library
OrderLine..::.DescriptionWithConfiguredOptions Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DescriptionWithConfiguredOptions As String
C#
public virtual string DescriptionWithConfiguredOptions { get; }
Visual C++
public:
virtual property String^ DescriptionWithConfiguredOptions {
    String^ get ();
}
JavaScript
function get_descriptionWithConfiguredOptions();

See Also

OrderLine Class
InSite.Model Namespace


DiscountAmount Property

[image]

.NET Framework Class Library
OrderLine..::.DiscountAmount Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DiscountAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal DiscountAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal DiscountAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discountAmount();
function set_discountAmount(value);

See Also

OrderLine Class
InSite.Model Namespace


DiscountPercent Property

[image]

.NET Framework Class Library
OrderLine..::.DiscountPercent Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DiscountPercent As Decimal
C#
[DataMemberAttribute]
public virtual decimal DiscountPercent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal DiscountPercent {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discountPercent();
function set_discountPercent(value);

See Also

OrderLine Class
InSite.Model Namespace


DueDate Property

[image]

.NET Framework Class Library
OrderLine..::.DueDate Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DueDate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> DueDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> DueDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_dueDate();
function set_dueDate(value);

See Also

OrderLine Class
InSite.Model Namespace


ERPNumber Property

[image]

.NET Framework Class Library
OrderLine..::.ERPNumber Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property ERPNumber As String
C#
[DataMemberAttribute]
public virtual string ERPNumber { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPNumber {
    String^ get ();
}
JavaScript
function get_erpNumber();

See Also

OrderLine Class
InSite.Model Namespace


ExtendedActualPrice Property

[image]

.NET Framework Class Library
OrderLine..::.ExtendedActualPrice Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property ExtendedActualPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal ExtendedActualPrice { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ExtendedActualPrice {
    Decimal get ();
}
JavaScript
function get_extendedActualPrice();

See Also

OrderLine Class
InSite.Model Namespace


ExtendedRegularPrice Property

[image]

.NET Framework Class Library
OrderLine..::.ExtendedRegularPrice Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property ExtendedRegularPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal ExtendedRegularPrice { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ExtendedRegularPrice {
    Decimal get ();
}
JavaScript
function get_extendedRegularPrice();

See Also

OrderLine Class
InSite.Model Namespace


GiftCard Property

[image]

.NET Framework Class Library
OrderLine..::.GiftCard Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property GiftCard As GiftCard
C#
public virtual GiftCard GiftCard { get; set; }
Visual C++
public:
virtual property GiftCard^ GiftCard {
    GiftCard^ get ();
    void set (GiftCard^ value);
}
JavaScript
function get_giftCard();
function set_giftCard(value);

See Also

OrderLine Class
InSite.Model Namespace


GiftCardAmount Property

[image]

.NET Framework Class Library
OrderLine..::.GiftCardAmount Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property GiftCardAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal GiftCardAmount { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal GiftCardAmount {
    Decimal get ();
}
JavaScript
function get_giftCardAmount();

See Also

OrderLine Class
InSite.Model Namespace


GiftCardBalance Property

[image]

.NET Framework Class Library
OrderLine..::.GiftCardBalance Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property GiftCardBalance As Decimal
C#
[DataMemberAttribute]
public virtual decimal GiftCardBalance { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal GiftCardBalance {
    Decimal get ();
}
JavaScript
function get_giftCardBalance();

See Also

OrderLine Class
InSite.Model Namespace


GiftCardExpiration Property

[image]

.NET Framework Class Library
OrderLine..::.GiftCardExpiration Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property GiftCardExpiration As DateTime
C#
[DataMemberAttribute]
public virtual DateTime GiftCardExpiration { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime GiftCardExpiration {
    DateTime get ();
}
JavaScript
function get_giftCardExpiration();

See Also

OrderLine Class
InSite.Model Namespace


GiftCardNumber Property

[image]

.NET Framework Class Library
OrderLine..::.GiftCardNumber Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property GiftCardNumber As String
C#
[DataMemberAttribute]
public virtual string GiftCardNumber { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ GiftCardNumber {
    String^ get ();
}
JavaScript
function get_giftCardNumber();

See Also

OrderLine Class
InSite.Model Namespace


IsGiftCard Property

[image]

.NET Framework Class Library
OrderLine..::.IsGiftCard Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property IsGiftCard As Boolean
C#
[DataMemberAttribute]
public virtual bool IsGiftCard { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsGiftCard {
    bool get ();
}
JavaScript
function get_isGiftCard();

See Also

OrderLine Class
InSite.Model Namespace


IsPromotionItem Property

[image]

.NET Framework Class Library
OrderLine..::.IsPromotionItem Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsPromotionItem As Boolean
C#
[DataMemberAttribute]
public virtual bool IsPromotionItem { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsPromotionItem {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isPromotionItem();
function set_isPromotionItem(value);

See Also

OrderLine Class
InSite.Model Namespace


IsSubscription Property

[image]

.NET Framework Class Library
OrderLine..::.IsSubscription Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property IsSubscription As Boolean
C#
[DataMemberAttribute]
public virtual bool IsSubscription { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsSubscription {
    bool get ();
}
JavaScript
function get_isSubscription();

See Also

OrderLine Class
InSite.Model Namespace


Line Property

[image]

.NET Framework Class Library
OrderLine..::.Line Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Line As Integer
C#
[DataMemberAttribute]
public virtual int Line { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int Line {
    int get ();
    void set (int value);
}
JavaScript
function get_line();
function set_line(value);

See Also

OrderLine Class
InSite.Model Namespace


Notes Property

[image]

.NET Framework Class Library
OrderLine..::.Notes Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Notes As String
C#
[DataMemberAttribute]
public virtual string Notes { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Notes {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_notes();
function set_notes(value);

See Also

OrderLine Class
InSite.Model Namespace


OrderLineAttributes Property

[image]

.NET Framework Class Library
OrderLine..::.OrderLineAttributes Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderLineAttributes As ChildList(Of OrderLineAttribute)
C#
public virtual ChildList<OrderLineAttribute> OrderLineAttributes { get; private set; }
Visual C++
public:
virtual property ChildList<OrderLineAttribute^>^ OrderLineAttributes {
    ChildList<OrderLineAttribute^>^ get ();
    void set (ChildList<OrderLineAttribute^>^ value);
}
JavaScript
function get_orderLineAttributes();
function set_orderLineAttributes(value);

See Also

OrderLine Class
InSite.Model Namespace


OrderLineId Property

[image]

.NET Framework Class Library
OrderLine..::.OrderLineId Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderLineId As Guid
C#
public virtual Guid OrderLineId { get; set; }
Visual C++
public:
virtual property Guid OrderLineId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_orderLineId();
function set_orderLineId(value);

See Also

OrderLine Class
InSite.Model Namespace


OrderLineSavingsAmount Property

[image]

.NET Framework Class Library
OrderLine..::.OrderLineSavingsAmount Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property OrderLineSavingsAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal OrderLineSavingsAmount { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal OrderLineSavingsAmount {
    Decimal get ();
}
JavaScript
function get_orderLineSavingsAmount();

See Also

OrderLine Class
InSite.Model Namespace


OrderLineSavingsPercent Property

[image]

.NET Framework Class Library
OrderLine..::.OrderLineSavingsPercent Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property OrderLineSavingsPercent As Decimal
C#
[DataMemberAttribute]
public virtual decimal OrderLineSavingsPercent { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal OrderLineSavingsPercent {
    Decimal get ();
}
JavaScript
function get_orderLineSavingsPercent();

See Also

OrderLine Class
InSite.Model Namespace


PassesRestrictions Property

[image]

.NET Framework Class Library
OrderLine..::.PassesRestrictions Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property PassesRestrictions As Boolean
C#
[DataMemberAttribute]
public virtual bool PassesRestrictions { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool PassesRestrictions {
    bool get ();
}
JavaScript
function get_passesRestrictions();

See Also

OrderLine Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
OrderLine..::.Product Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

OrderLine Class
InSite.Model Namespace


ProductActualPrice Property

[image]

.NET Framework Class Library
OrderLine..::.ProductActualPrice Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property ProductActualPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal ProductActualPrice { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ProductActualPrice {
    Decimal get ();
}
JavaScript
function get_productActualPrice();

See Also

OrderLine Class
InSite.Model Namespace


ProductExtendedActualPrice Property

[image]

.NET Framework Class Library
OrderLine..::.ProductExtendedActualPrice Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property ProductExtendedActualPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal ProductExtendedActualPrice { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ProductExtendedActualPrice {
    Decimal get ();
}
JavaScript
function get_productExtendedActualPrice();

See Also

OrderLine Class
InSite.Model Namespace


ProductExtendedRegularPrice Property

[image]

.NET Framework Class Library
OrderLine..::.ProductExtendedRegularPrice Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property ProductExtendedRegularPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal ProductExtendedRegularPrice { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ProductExtendedRegularPrice {
    Decimal get ();
}
JavaScript
function get_productExtendedRegularPrice();

See Also

OrderLine Class
InSite.Model Namespace


ProductId Property

[image]

.NET Framework Class Library
OrderLine..::.ProductId Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ProductId As Guid
C#
public virtual Guid ProductId { get; }
Visual C++
public:
virtual property Guid ProductId {
    Guid get ();
}
JavaScript
function get_productId();

See Also

OrderLine Class
InSite.Model Namespace


ProductName Property

[image]

.NET Framework Class Library
OrderLine..::.ProductName Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property ProductName As String
C#
[DataMemberAttribute]
public virtual string ProductName { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProductName {
    String^ get ();
}
JavaScript
function get_productName();

See Also

OrderLine Class
InSite.Model Namespace


ProductRegularPrice Property

[image]

.NET Framework Class Library
OrderLine..::.ProductRegularPrice Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable ReadOnly Property ProductRegularPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal ProductRegularPrice { get; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ProductRegularPrice {
    Decimal get ();
}
JavaScript
function get_productRegularPrice();

See Also

OrderLine Class
InSite.Model Namespace


PromiseDate Property

[image]

.NET Framework Class Library
OrderLine..::.PromiseDate Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PromiseDate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> PromiseDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> PromiseDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_promiseDate();
function set_promiseDate(value);

See Also

OrderLine Class
InSite.Model Namespace


PromotionResult Property

[image]

.NET Framework Class Library
OrderLine..::.PromotionResult Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PromotionResult As PromotionResult
C#
public virtual PromotionResult PromotionResult { get; set; }
Visual C++
public:
virtual property PromotionResult^ PromotionResult {
    PromotionResult^ get ();
    void set (PromotionResult^ value);
}
JavaScript
function get_promotionResult();
function set_promotionResult(value);

See Also

OrderLine Class
InSite.Model Namespace


QtyOrdered Property

[image]

.NET Framework Class Library
OrderLine..::.QtyOrdered Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property QtyOrdered As Decimal
C#
[DataMemberAttribute]
public virtual decimal QtyOrdered { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal QtyOrdered {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_qtyOrdered();
function set_qtyOrdered(value);

See Also

OrderLine Class
InSite.Model Namespace


QtyShipped Property

[image]

.NET Framework Class Library
OrderLine..::.QtyShipped Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property QtyShipped As Decimal
C#
[DataMemberAttribute]
public virtual decimal QtyShipped { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal QtyShipped {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_qtyShipped();
function set_qtyShipped(value);

See Also

OrderLine Class
InSite.Model Namespace


RegularPrice Property

[image]

.NET Framework Class Library
OrderLine..::.RegularPrice Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RegularPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal RegularPrice { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal RegularPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_regularPrice();
function set_regularPrice(value);

See Also

OrderLine Class
InSite.Model Namespace


Release Property

[image]

.NET Framework Class Library
OrderLine..::.Release Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Release As Integer
C#
[DataMemberAttribute]
public virtual int Release { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int Release {
    int get ();
    void set (int value);
}
JavaScript
function get_release();
function set_release(value);

See Also

OrderLine Class
InSite.Model Namespace


ShipDate Property

[image]

.NET Framework Class Library
OrderLine..::.ShipDate Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipDate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> ShipDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> ShipDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_shipDate();
function set_shipDate(value);

See Also

OrderLine Class
InSite.Model Namespace


ShipSite Property

[image]

.NET Framework Class Library
OrderLine..::.ShipSite Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipSite As String
C#
[DataMemberAttribute]
public virtual string ShipSite { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipSite {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipSite();
function set_shipSite(value);

See Also

OrderLine Class
InSite.Model Namespace


Status Property

[image]

.NET Framework Class Library
OrderLine..::.Status Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Status As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Status { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Status {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_status();
function set_status(value);

See Also

OrderLine Class
InSite.Model Namespace


SubscriptionProductName Property

[image]

.NET Framework Class Library
OrderLine..::.SubscriptionProductName Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionProductName As String
C#
[DataMemberAttribute]
public virtual string SubscriptionProductName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SubscriptionProductName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_subscriptionProductName();
function set_subscriptionProductName(value);

See Also

OrderLine Class
InSite.Model Namespace


TaxCode1 Property

[image]

.NET Framework Class Library
OrderLine..::.TaxCode1 Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode1 As String
C#
[DataMemberAttribute]
public virtual string TaxCode1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode1();
function set_taxCode1(value);

See Also

OrderLine Class
InSite.Model Namespace


TaxCode2 Property

[image]

.NET Framework Class Library
OrderLine..::.TaxCode2 Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode2 As String
C#
[DataMemberAttribute]
public virtual string TaxCode2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode2();
function set_taxCode2(value);

See Also

OrderLine Class
InSite.Model Namespace


UnitOfMeasure Property

[image]

.NET Framework Class Library
OrderLine..::.UnitOfMeasure Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UnitOfMeasure As String
C#
[DataMemberAttribute]
public virtual string UnitOfMeasure { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ UnitOfMeasure {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_unitOfMeasure();
function set_unitOfMeasure(value);

See Also

OrderLine Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
OrderLine..::.WebSite Property
OrderLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

OrderLine Class
InSite.Model Namespace


OrderLineAttribute Class

[image]

.NET Framework Class Library
OrderLineAttribute Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OrderLineAttribute _
    Inherits ModelBase(Of OrderLineAttribute)
C#
[SerializableAttribute]
public class OrderLineAttribute : ModelBase<OrderLineAttribute>
Visual C++
[SerializableAttribute]
public ref class OrderLineAttribute : public ModelBase<OrderLineAttribute^>
JavaScript
InSite.Model.OrderLineAttribute = function();

Type.createClass(
    'InSite.Model.OrderLineAttribute',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(OrderLineAttribute>)>)
InSite.Model..::.OrderLineAttribute

See Also

OrderLineAttribute Members
InSite.Model Namespace


OrderLineAttribute Members

[image] [image]

.NET Framework Class Library
OrderLineAttribute Members
OrderLineAttribute Class Constructors Methods Fields Properties See Also Send Feedback

The OrderLineAttribute type exposes the following members.

Constructors

Name | Description
OrderLineAttribute | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Hidden |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderLine |
OrderLineAttributeId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

OrderLineAttribute Class
InSite.Model Namespace


OrderLineAttribute Constructor

[image] [image]

.NET Framework Class Library
OrderLineAttribute Constructor
OrderLineAttribute Class See Also Send Feedback

Overload List

Name | Description
OrderLineAttribute()()() |
OrderLineAttribute(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

OrderLineAttribute Class
OrderLineAttribute Members
InSite.Model Namespace


OrderLineAttribute Constructor

[image]

.NET Framework Class Library
OrderLineAttribute Constructor
OrderLineAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public OrderLineAttribute()
Visual C++
public:
OrderLineAttribute()
JavaScript
InSite.Model.OrderLineAttribute = function();

See Also

OrderLineAttribute Class
OrderLineAttribute Overload
InSite.Model Namespace


OrderLineAttribute Constructor (SearchMode)

[image]

.NET Framework Class Library
OrderLineAttribute Constructor (SearchMode)
OrderLineAttribute Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public OrderLineAttribute(
    SearchMode searchMode
)
Visual C++
public:
OrderLineAttribute(
    SearchMode searchMode
)
JavaScript
InSite.Model.OrderLineAttribute = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

OrderLineAttribute Class
OrderLineAttribute Overload
InSite.Model Namespace


OrderLineAttribute Fields

[image] [image]

.NET Framework Class Library
OrderLineAttribute Fields
OrderLineAttribute Class See Also Send Feedback

The OrderLineAttribute type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

OrderLineAttribute Class
InSite.Model Namespace


OrderLineAttribute Methods

[image] [image]

.NET Framework Class Library
OrderLineAttribute Methods
OrderLineAttribute Class See Also Send Feedback

The OrderLineAttribute type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

OrderLineAttribute Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
OrderLineAttribute..::.Copy Method
OrderLineAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As OrderLineAttribute
C#
public virtual OrderLineAttribute Copy()
Visual C++
public:
virtual OrderLineAttribute^ Copy()
JavaScript
function copy();

See Also

OrderLineAttribute Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
OrderLineAttribute..::.ToString Method
OrderLineAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

OrderLineAttribute Class
InSite.Model Namespace


OrderLineAttribute Properties

[image] [image]

.NET Framework Class Library
OrderLineAttribute Properties
OrderLineAttribute Class See Also Send Feedback

The OrderLineAttribute type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Hidden |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderLine |
OrderLineAttributeId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

OrderLineAttribute Class
InSite.Model Namespace


Hidden Property

[image]

.NET Framework Class Library
OrderLineAttribute..::.Hidden Property
OrderLineAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Hidden As Boolean
C#
public virtual bool Hidden { get; set; }
Visual C++
public:
virtual property bool Hidden {
    bool get ();
    void set (bool value);
}
JavaScript
function get_hidden();
function set_hidden(value);

See Also

OrderLineAttribute Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
OrderLineAttribute..::.Name Property
OrderLineAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

OrderLineAttribute Class
InSite.Model Namespace


OrderLine Property

[image]

.NET Framework Class Library
OrderLineAttribute..::.OrderLine Property
OrderLineAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderLine As OrderLine
C#
public virtual OrderLine OrderLine { get; set; }
Visual C++
public:
virtual property OrderLine^ OrderLine {
    OrderLine^ get ();
    void set (OrderLine^ value);
}
JavaScript
function get_orderLine();
function set_orderLine(value);

See Also

OrderLineAttribute Class
InSite.Model Namespace


OrderLineAttributeId Property

[image]

.NET Framework Class Library
OrderLineAttribute..::.OrderLineAttributeId Property
OrderLineAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderLineAttributeId As Guid
C#
public virtual Guid OrderLineAttributeId { get; set; }
Visual C++
public:
virtual property Guid OrderLineAttributeId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_orderLineAttributeId();
function set_orderLineAttributeId(value);

See Also

OrderLineAttribute Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
OrderLineAttribute..::.Value Property
OrderLineAttribute Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Value As String
C#
public virtual string Value { get; set; }
Visual C++
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

OrderLineAttribute Class
InSite.Model Namespace


PackageLine Class

[image]

.NET Framework Class Library
PackageLine Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PackageLine _
    Inherits ModelBase(Of PackageLine)
C#
[SerializableAttribute]
public class PackageLine : ModelBase<PackageLine>
Visual C++
[SerializableAttribute]
public ref class PackageLine : public ModelBase<PackageLine^>
JavaScript
InSite.Model.PackageLine = function();

Type.createClass(
    'InSite.Model.PackageLine',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(PackageLine>)>)
InSite.Model..::.PackageLine

See Also

PackageLine Members
InSite.Model Namespace


PackageLine Members

[image] [image]

.NET Framework Class Library
PackageLine Members
PackageLine Class Constructors Methods Fields Properties See Also Send Feedback

The PackageLine type exposes the following members.

Constructors

Name | Description
PackageLine | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExtendedPrice |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderLine |
PackageLineId |
Price |
ProductCode |
ProductDescription |
ProductName |
QtyOrdered |
QtyShipped |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentPackage |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PackageLine Class
InSite.Model Namespace


PackageLine Constructor

[image] [image]

.NET Framework Class Library
PackageLine Constructor
PackageLine Class See Also Send Feedback

Overload List

Name | Description
PackageLine()()() |
PackageLine(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

PackageLine Class
PackageLine Members
InSite.Model Namespace


PackageLine Constructor

[image]

.NET Framework Class Library
PackageLine Constructor
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PackageLine()
Visual C++
public:
PackageLine()
JavaScript
InSite.Model.PackageLine = function();

See Also

PackageLine Class
PackageLine Overload
InSite.Model Namespace


PackageLine Constructor (SearchMode)

[image]

.NET Framework Class Library
PackageLine Constructor (SearchMode)
PackageLine Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public PackageLine(
    SearchMode searchMode
)
Visual C++
public:
PackageLine(
    SearchMode searchMode
)
JavaScript
InSite.Model.PackageLine = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

PackageLine Class
PackageLine Overload
InSite.Model Namespace


PackageLine Fields

[image] [image]

.NET Framework Class Library
PackageLine Fields
PackageLine Class See Also Send Feedback

The PackageLine type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PackageLine Class
InSite.Model Namespace


PackageLine Methods

[image] [image]

.NET Framework Class Library
PackageLine Methods
PackageLine Class See Also Send Feedback

The PackageLine type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PackageLine Class
InSite.Model Namespace


PackageLine Properties

[image] [image]

.NET Framework Class Library
PackageLine Properties
PackageLine Class See Also Send Feedback

The PackageLine type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExtendedPrice |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderLine |
PackageLineId |
Price |
ProductCode |
ProductDescription |
ProductName |
QtyOrdered |
QtyShipped |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentPackage |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PackageLine Class
InSite.Model Namespace


ExtendedPrice Property

[image]

.NET Framework Class Library
PackageLine..::.ExtendedPrice Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ExtendedPrice As Decimal
C#
public virtual decimal ExtendedPrice { get; }
Visual C++
public:
virtual property Decimal ExtendedPrice {
    Decimal get ();
}
JavaScript
function get_extendedPrice();

See Also

PackageLine Class
InSite.Model Namespace


OrderLine Property

[image]

.NET Framework Class Library
PackageLine..::.OrderLine Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property OrderLine As OrderLine
C#
public virtual OrderLine OrderLine { get; set; }
Visual C++
public:
virtual property OrderLine^ OrderLine {
    OrderLine^ get ();
    void set (OrderLine^ value);
}
JavaScript
function get_orderLine();
function set_orderLine(value);

See Also

PackageLine Class
InSite.Model Namespace


PackageLineId Property

[image]

.NET Framework Class Library
PackageLine..::.PackageLineId Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PackageLineId As Guid
C#
public virtual Guid PackageLineId { get; set; }
Visual C++
public:
virtual property Guid PackageLineId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_packageLineId();
function set_packageLineId(value);

See Also

PackageLine Class
InSite.Model Namespace


Price Property

[image]

.NET Framework Class Library
PackageLine..::.Price Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Price As Decimal
C#
public virtual decimal Price { get; set; }
Visual C++
public:
virtual property Decimal Price {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_price();
function set_price(value);

See Also

PackageLine Class
InSite.Model Namespace


ProductCode Property

[image]

.NET Framework Class Library
PackageLine..::.ProductCode Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductCode As String
C#
public virtual string ProductCode { get; set; }
Visual C++
public:
virtual property String^ ProductCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productCode();
function set_productCode(value);

See Also

PackageLine Class
InSite.Model Namespace


ProductDescription Property

[image]

.NET Framework Class Library
PackageLine..::.ProductDescription Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductDescription As String
C#
public virtual string ProductDescription { get; set; }
Visual C++
public:
virtual property String^ ProductDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productDescription();
function set_productDescription(value);

See Also

PackageLine Class
InSite.Model Namespace


ProductName Property

[image]

.NET Framework Class Library
PackageLine..::.ProductName Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductName As String
C#
public virtual string ProductName { get; set; }
Visual C++
public:
virtual property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productName();
function set_productName(value);

See Also

PackageLine Class
InSite.Model Namespace


QtyOrdered Property

[image]

.NET Framework Class Library
PackageLine..::.QtyOrdered Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property QtyOrdered As Decimal
C#
public virtual decimal QtyOrdered { get; set; }
Visual C++
public:
virtual property Decimal QtyOrdered {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_qtyOrdered();
function set_qtyOrdered(value);

See Also

PackageLine Class
InSite.Model Namespace


QtyShipped Property

[image]

.NET Framework Class Library
PackageLine..::.QtyShipped Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property QtyShipped As Decimal
C#
public virtual decimal QtyShipped { get; set; }
Visual C++
public:
virtual property Decimal QtyShipped {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_qtyShipped();
function set_qtyShipped(value);

See Also

PackageLine Class
InSite.Model Namespace


ShipmentPackage Property

[image]

.NET Framework Class Library
PackageLine..::.ShipmentPackage Property
PackageLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipmentPackage As ShipmentPackage
C#
public virtual ShipmentPackage ShipmentPackage { get; set; }
Visual C++
public:
virtual property ShipmentPackage^ ShipmentPackage {
    ShipmentPackage^ get ();
    void set (ShipmentPackage^ value);
}
JavaScript
function get_shipmentPackage();
function set_shipmentPackage(value);

See Also

PackageLine Class
InSite.Model Namespace


PaymentTerm Class

[image]

.NET Framework Class Library
PaymentTerm Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PaymentTerm _
    Inherits ModelBase(Of PaymentTerm)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PaymentTerm : ModelBase<PaymentTerm>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PaymentTerm : public ModelBase<PaymentTerm^>
JavaScript
InSite.Model.PaymentTerm = function();

Type.createClass(
    'InSite.Model.PaymentTerm',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(PaymentTerm>)>)
InSite.Model..::.PaymentTerm

See Also

PaymentTerm Members
InSite.Model Namespace


PaymentTerm Members

[image] [image]

.NET Framework Class Library
PaymentTerm Members
PaymentTerm Class Constructors Methods Fields Properties See Also Send Feedback

The PaymentTerm type exposes the following members.

Constructors

Name | Description
PaymentTerm | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByTermsCode | Overloaded.
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsMatch |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customers |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsCreditCard |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PaymentTermId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TermsCode |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PaymentTerm Class
InSite.Model Namespace


PaymentTerm Constructor

[image] [image]

.NET Framework Class Library
PaymentTerm Constructor
PaymentTerm Class See Also Send Feedback

Overload List

Name | Description
PaymentTerm()()() |
PaymentTerm(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

PaymentTerm Class
PaymentTerm Members
InSite.Model Namespace


PaymentTerm Constructor

[image]

.NET Framework Class Library
PaymentTerm Constructor
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PaymentTerm()
Visual C++
public:
PaymentTerm()
JavaScript
InSite.Model.PaymentTerm = function();

See Also

PaymentTerm Class
PaymentTerm Overload
InSite.Model Namespace


PaymentTerm Constructor (SearchMode)

[image]

.NET Framework Class Library
PaymentTerm Constructor (SearchMode)
PaymentTerm Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public PaymentTerm(
    SearchMode searchMode
)
Visual C++
public:
PaymentTerm(
    SearchMode searchMode
)
JavaScript
InSite.Model.PaymentTerm = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

PaymentTerm Class
PaymentTerm Overload
InSite.Model Namespace


PaymentTerm Fields

[image] [image]

.NET Framework Class Library
PaymentTerm Fields
PaymentTerm Class See Also Send Feedback

The PaymentTerm type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PaymentTerm Class
InSite.Model Namespace


PaymentTerm Methods

[image] [image]

.NET Framework Class Library
PaymentTerm Methods
PaymentTerm Class See Also Send Feedback

The PaymentTerm type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByTermsCode | Overloaded.
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsMatch |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PaymentTerm Class
InSite.Model Namespace


GetByTermsCode Method

[image] [image]

.NET Framework Class Library
PaymentTerm..::.GetByTermsCode Method
PaymentTerm Class See Also Send Feedback

Overload List

Name | Description
GetByTermsCode(String) | Gets PaymentTerm for the TermsCode, returns null if not found
GetByTermsCode(String, String) | Gets a PaymentTerm for the TermsCode, if there is none, will create a new one with that TermsCode and Description

See Also

PaymentTerm Class
PaymentTerm Members
InSite.Model Namespace


GetByTermsCode Method (String)

[image]

.NET Framework Class Library
PaymentTerm..::.GetByTermsCode Method (String)
PaymentTerm Class See Also Send Feedback

Gets PaymentTerm for the TermsCode, returns null if not found

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByTermsCode ( _
    termsCode As String _
) As PaymentTerm
C#
public static PaymentTerm GetByTermsCode(
    string termsCode
)
Visual C++
public:
static PaymentTerm^ GetByTermsCode(
    String^ termsCode
)
JavaScript
InSite.Model.PaymentTerm.getByTermsCode = function(termsCode);

Parameters

termsCode
Type: System..::.String

Return Value

See Also

PaymentTerm Class
GetByTermsCode Overload
InSite.Model Namespace


GetByTermsCode Method (String, String)

[image]

.NET Framework Class Library
PaymentTerm..::.GetByTermsCode Method (String, String)
PaymentTerm Class See Also Send Feedback

Gets a PaymentTerm for the TermsCode, if there is none, will create a new one with that TermsCode and Description

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByTermsCode ( _
    termsCode As String, _
    description As String _
) As PaymentTerm
C#
public static PaymentTerm GetByTermsCode(
    string termsCode,
    string description
)
Visual C++
public:
static PaymentTerm^ GetByTermsCode(
    String^ termsCode,
    String^ description
)
JavaScript
InSite.Model.PaymentTerm.getByTermsCode = function(termsCode, description);

Parameters

termsCode
Type: System..::.String
description
Type: System..::.String

Return Value

See Also

PaymentTerm Class
GetByTermsCode Overload
InSite.Model Namespace


IsMatch Method

[image]

.NET Framework Class Library
PaymentTerm..::.IsMatch Method
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsMatch ( _
    termsCode As String _
) As Boolean
C#
public virtual bool IsMatch(
    string termsCode
)
Visual C++
public:
virtual bool IsMatch(
    String^ termsCode
)
JavaScript
function isMatch(termsCode);

Parameters

termsCode
Type: System..::.String

See Also

PaymentTerm Class
InSite.Model Namespace


PaymentTerm Properties

[image] [image]

.NET Framework Class Library
PaymentTerm Properties
PaymentTerm Class See Also Send Feedback

The PaymentTerm type exposes the following members.

Properties

Name | Description
Active |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customers |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsCreditCard |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PaymentTermId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TermsCode |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PaymentTerm Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
PaymentTerm..::.Active Property
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

PaymentTerm Class
InSite.Model Namespace


Customers Property

[image]

.NET Framework Class Library
PaymentTerm..::.Customers Property
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Customers As ChildList(Of Customer)
C#
public virtual ChildList<Customer> Customers { get; }
Visual C++
public:
virtual property ChildList<Customer^>^ Customers {
    ChildList<Customer^>^ get ();
}
JavaScript
function get_customers();

See Also

PaymentTerm Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
PaymentTerm..::.Deactivate Property
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

PaymentTerm Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
PaymentTerm..::.Description Property
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

PaymentTerm Class
InSite.Model Namespace


IsCreditCard Property

[image]

.NET Framework Class Library
PaymentTerm..::.IsCreditCard Property
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsCreditCard As Boolean
C#
[DataMemberAttribute]
public virtual bool IsCreditCard { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsCreditCard {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isCreditCard();
function set_isCreditCard(value);

See Also

PaymentTerm Class
InSite.Model Namespace


PaymentTermId Property

[image]

.NET Framework Class Library
PaymentTerm..::.PaymentTermId Property
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PaymentTermId As Guid
C#
public virtual Guid PaymentTermId { get; set; }
Visual C++
public:
virtual property Guid PaymentTermId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_paymentTermId();
function set_paymentTermId(value);

See Also

PaymentTerm Class
InSite.Model Namespace


TermsCode Property

[image]

.NET Framework Class Library
PaymentTerm..::.TermsCode Property
PaymentTerm Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property TermsCode As String
C#
[DataMemberAttribute]
[SortField]
public virtual string TermsCode { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ TermsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_termsCode();
function set_termsCode(value);

See Also

PaymentTerm Class
InSite.Model Namespace


PriceCalculator_Generic Class

[image]

.NET Framework Class Library
PriceCalculator_Generic Class
Members See Also Send Feedback

PriceCalculator_Generic - the Generic or Standard Price Calculator

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PriceCalculator_Generic _
    Implements IPriceCalculator
C#
[SerializableAttribute]
public class PriceCalculator_Generic : IPriceCalculator
Visual C++
[SerializableAttribute]
public ref class PriceCalculator_Generic : IPriceCalculator
JavaScript
InSite.Model.PriceCalculator_Generic = function();

Type.createClass(
    'InSite.Model.PriceCalculator_Generic',
    null,
    InSite.Model.IPriceCalculator);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.PriceCalculator_Generic

See Also

PriceCalculator_Generic Members
InSite.Model Namespace


PriceCalculator_Generic Members

[image] [image]

.NET Framework Class Library
PriceCalculator_Generic Members
PriceCalculator_Generic Class Constructors Methods See Also Send Feedback

The PriceCalculator_Generic type exposes the following members.

Constructors

Name | Description
PriceCalculator_Generic |

Methods

Name | Description
CalculatePrice | Overloaded.
ConfigurePrice | Calculates price for configured options
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PriceCalculator_Generic Class
InSite.Model Namespace


PriceCalculator_Generic Constructor

[image]

.NET Framework Class Library
PriceCalculator_Generic Constructor
PriceCalculator_Generic Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PriceCalculator_Generic()
Visual C++
public:
PriceCalculator_Generic()
JavaScript
InSite.Model.PriceCalculator_Generic = function();

See Also

PriceCalculator_Generic Class
InSite.Model Namespace


PriceCalculator_Generic Methods

[image] [image]

.NET Framework Class Library
PriceCalculator_Generic Methods
PriceCalculator_Generic Class See Also Send Feedback

The PriceCalculator_Generic type exposes the following members.

Methods

Name | Description
CalculatePrice | Overloaded.
ConfigurePrice | Calculates price for configured options
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PriceCalculator_Generic Class
InSite.Model Namespace


CalculatePrice Method

[image] [image]

.NET Framework Class Library
PriceCalculator_Generic..::.CalculatePrice Method
PriceCalculator_Generic Class See Also Send Feedback

Overload List

Name | Description
CalculatePrice(OrderLine, Boolean, Boolean%) | Calculates Price for OrderLine
CalculatePrice(Customer, Product, Decimal, DataSet, Boolean, Boolean%) | Calculates Price for given Customer, Product and optionally Configuration

See Also

PriceCalculator_Generic Class
PriceCalculator_Generic Members
InSite.Model Namespace


CalculatePrice Method (OrderLine, Boolean, Boolean)

[image]

.NET Framework Class Library
PriceCalculator_Generic..::.CalculatePrice Method (OrderLine, Boolean, Boolean%)
PriceCalculator_Generic Class See Also Send Feedback

Calculates Price for OrderLine

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CalculatePrice ( _
    orderLine As OrderLine, _
    regularPrice As Boolean, _
    <OutAttribute> ByRef isSalePrice As Boolean _
) As Decimal
C#
public virtual decimal CalculatePrice(
    OrderLine orderLine,
    bool regularPrice,
    out bool isSalePrice
)
Visual C++
public:
virtual Decimal CalculatePrice(
    OrderLine^ orderLine,
    bool regularPrice,
    [OutAttribute] bool% isSalePrice
)
JavaScript
function calculatePrice(orderLine, regularPrice, isSalePrice);

Parameters

orderLine
Type: InSite.Model..::.OrderLine
regularPrice
Type: System..::.Boolean
If true, calculates Regular Price, if false, calculates Actual Price
isSalePrice
Type: System..::.Boolean %
Output parameter that returns true if Sale Price is returned, false if not

Return Value

Price

Implements

IPriceCalculator..::.CalculatePrice(OrderLine, Boolean, Boolean%)

See Also

PriceCalculator_Generic Class
CalculatePrice Overload
InSite.Model Namespace


CalculatePrice Method (Customer, Product, Decimal, DataSet, Boolean, Boolean)

[image]

.NET Framework Class Library
PriceCalculator_Generic..::.CalculatePrice Method (Customer, Product, Decimal, DataSet, Boolean, Boolean%)
PriceCalculator_Generic Class See Also Send Feedback

Calculates Price for given Customer, Product and optionally Configuration

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function CalculatePrice ( _
    customer As Customer, _
    product As Product, _
    qtyOrdered As Decimal, _
    configDataSet As DataSet, _
    regularPrice As Boolean, _
    <OutAttribute> ByRef isSalePrice As Boolean _
) As Decimal
C#
public virtual decimal CalculatePrice(
    Customer customer,
    Product product,
    decimal qtyOrdered,
    DataSet configDataSet,
    bool regularPrice,
    out bool isSalePrice
)
Visual C++
public:
virtual Decimal CalculatePrice(
    Customer^ customer,
    Product^ product,
    Decimal qtyOrdered,
    DataSet^ configDataSet,
    bool regularPrice,
    [OutAttribute] bool% isSalePrice
)
JavaScript
function calculatePrice(customer, product, qtyOrdered, configDataSet, regularPrice, isSalePrice);

Parameters

customer
Type: InSite.Model..::.Customer
Can be null
product
Type: InSite.Model..::.Product
Required
qtyOrdered
Type: System..::.Decimal
Required
configDataSet
Type: System.Data..::.DataSet
Can be null
regularPrice
Type: System..::.Boolean
If true, calculates Regular Price, if false, calculates Actual Price
isSalePrice
Type: System..::.Boolean %
Output paramter that returns true if Sale Price is returned, false if not

Return Value

Price

Implements

IPriceCalculator..::.CalculatePrice(Customer, Product, Decimal, DataSet, Boolean, Boolean%)

See Also

PriceCalculator_Generic Class
CalculatePrice Overload
InSite.Model Namespace


ConfigurePrice Method

[image]

.NET Framework Class Library
PriceCalculator_Generic..::.ConfigurePrice Method
PriceCalculator_Generic Class See Also Send Feedback

Calculates price for configured options

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Function ConfigurePrice ( _
    price As Decimal, _
    configDataSet As DataSet _
) As Decimal
C#
protected virtual decimal ConfigurePrice(
    decimal price,
    DataSet configDataSet
)
Visual C++
protected:
virtual Decimal ConfigurePrice(
    Decimal price,
    DataSet^ configDataSet
)
JavaScript
function configurePrice(price, configDataSet);

Parameters

price
Type: System..::.Decimal
configDataSet
Type: System.Data..::.DataSet

Return Value

See Also

PriceCalculator_Generic Class
InSite.Model Namespace


PriceMatrix Class

[image]

.NET Framework Class Library
PriceMatrix Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PriceMatrix _
    Inherits ModelBase(Of PriceMatrix)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PriceMatrix : ModelBase<PriceMatrix>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PriceMatrix : public ModelBase<PriceMatrix^>
JavaScript
InSite.Model.PriceMatrix = function();

Type.createClass(
    'InSite.Model.PriceMatrix',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(PriceMatrix>)>)
InSite.Model..::.PriceMatrix

See Also

PriceMatrix Members
InSite.Model Namespace


PriceMatrix Members

[image] [image]

.NET Framework Class Library
PriceMatrix Members
PriceMatrix Class Constructors Methods Fields Properties See Also Send Feedback

The PriceMatrix type exposes the following members.

Constructors

Name | Description
PriceMatrix | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
CustomerPriceCodeProductPriceCodeRecordType |
CustomerPriceCodeProductRecordType |
CustomerPriceCodeRecordType |
CustomerProductPriceCategoryRecordType |
CustomerProductPriceCodeRecordType |
CustomerProductPriceLineRecordType |
CustomerProductRecordType |
CustomerRecordType |
ProductPriceCodeRecordType |
ProductRecordType |

Properties

Name | Description
Active |
AdjustmentType01 |
AdjustmentType02 |
AdjustmentType03 |
AdjustmentType04 |
AdjustmentType05 |
AdjustmentType06 |
AdjustmentType07 |
AdjustmentType08 |
AdjustmentType09 |
AdjustmentType10 |
AdjustmentType11 |
AltAmount01 |
AltAmount02 |
AltAmount03 |
AltAmount04 |
AltAmount05 |
AltAmount06 |
AltAmount07 |
AltAmount08 |
AltAmount09 |
AltAmount10 |
AltAmount11 |
Amount01 |
Amount02 |
Amount03 |
Amount04 |
Amount05 |
Amount06 |
Amount07 |
Amount08 |
Amount09 |
Amount10 |
Amount11 |
BreakQty01 |
BreakQty02 |
BreakQty03 |
BreakQty04 |
BreakQty05 |
BreakQty06 |
BreakQty07 |
BreakQty08 |
BreakQty09 |
BreakQty10 |
BreakQty11 |
CalculationFlags |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CurrencyCode |
CustomerKeyPart |
CustomerNumberSequenceName |
CustomerPriceCode |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PriceBasis01 |
PriceBasis02 |
PriceBasis03 |
PriceBasis04 |
PriceBasis05 |
PriceBasis06 |
PriceBasis07 |
PriceBasis08 |
PriceBasis09 |
PriceBasis10 |
PriceBasis11 |
PriceMatrixId |
ProductKeyPart |
ProductName |
ProductPriceCategory |
ProductPriceCode |
ProductPriceLine |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RecordType |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UnitOfMeasure |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Warehouse |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PriceMatrix Class
InSite.Model Namespace


PriceMatrix Constructor

[image] [image]

.NET Framework Class Library
PriceMatrix Constructor
PriceMatrix Class See Also Send Feedback

Overload List

Name | Description
PriceMatrix()()() |
PriceMatrix(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

PriceMatrix Class
PriceMatrix Members
InSite.Model Namespace


PriceMatrix Constructor

[image]

.NET Framework Class Library
PriceMatrix Constructor
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PriceMatrix()
Visual C++
public:
PriceMatrix()
JavaScript
InSite.Model.PriceMatrix = function();

See Also

PriceMatrix Class
PriceMatrix Overload
InSite.Model Namespace


PriceMatrix Constructor (SearchMode)

[image]

.NET Framework Class Library
PriceMatrix Constructor (SearchMode)
PriceMatrix Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public PriceMatrix(
    SearchMode searchMode
)
Visual C++
public:
PriceMatrix(
    SearchMode searchMode
)
JavaScript
InSite.Model.PriceMatrix = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

PriceMatrix Class
PriceMatrix Overload
InSite.Model Namespace


PriceMatrix Fields

[image] [image]

.NET Framework Class Library
PriceMatrix Fields
PriceMatrix Class See Also Send Feedback

The PriceMatrix type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
CustomerPriceCodeProductPriceCodeRecordType |
CustomerPriceCodeProductRecordType |
CustomerPriceCodeRecordType |
CustomerProductPriceCategoryRecordType |
CustomerProductPriceCodeRecordType |
CustomerProductPriceLineRecordType |
CustomerProductRecordType |
CustomerRecordType |
ProductPriceCodeRecordType |
ProductRecordType |

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerPriceCodeProductPriceCodeRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerPriceCodeProductPriceCodeRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CustomerPriceCodeProductPriceCodeRecordType As String
C#
public const string CustomerPriceCodeProductPriceCodeRecordType
Visual C++
public:
literal String^ CustomerPriceCodeProductPriceCodeRecordType
JavaScript
InSite.Model.PriceMatrix.customerPriceCodeProductPriceCodeRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerPriceCodeProductRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerPriceCodeProductRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CustomerPriceCodeProductRecordType As String
C#
public const string CustomerPriceCodeProductRecordType
Visual C++
public:
literal String^ CustomerPriceCodeProductRecordType
JavaScript
InSite.Model.PriceMatrix.customerPriceCodeProductRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerPriceCodeRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerPriceCodeRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CustomerPriceCodeRecordType As String
C#
public const string CustomerPriceCodeRecordType
Visual C++
public:
literal String^ CustomerPriceCodeRecordType
JavaScript
InSite.Model.PriceMatrix.customerPriceCodeRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerProductPriceCategoryRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerProductPriceCategoryRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CustomerProductPriceCategoryRecordType As String
C#
public const string CustomerProductPriceCategoryRecordType
Visual C++
public:
literal String^ CustomerProductPriceCategoryRecordType
JavaScript
InSite.Model.PriceMatrix.customerProductPriceCategoryRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerProductPriceCodeRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerProductPriceCodeRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CustomerProductPriceCodeRecordType As String
C#
public const string CustomerProductPriceCodeRecordType
Visual C++
public:
literal String^ CustomerProductPriceCodeRecordType
JavaScript
InSite.Model.PriceMatrix.customerProductPriceCodeRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerProductPriceLineRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerProductPriceLineRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CustomerProductPriceLineRecordType As String
C#
public const string CustomerProductPriceLineRecordType
Visual C++
public:
literal String^ CustomerProductPriceLineRecordType
JavaScript
InSite.Model.PriceMatrix.customerProductPriceLineRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerProductRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerProductRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CustomerProductRecordType As String
C#
public const string CustomerProductRecordType
Visual C++
public:
literal String^ CustomerProductRecordType
JavaScript
InSite.Model.PriceMatrix.customerProductRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const CustomerRecordType As String
C#
public const string CustomerRecordType
Visual C++
public:
literal String^ CustomerRecordType
JavaScript
InSite.Model.PriceMatrix.customerRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


ProductPriceCodeRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.ProductPriceCodeRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ProductPriceCodeRecordType As String
C#
public const string ProductPriceCodeRecordType
Visual C++
public:
literal String^ ProductPriceCodeRecordType
JavaScript
InSite.Model.PriceMatrix.productPriceCodeRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


ProductRecordType Field

[image]

.NET Framework Class Library
PriceMatrix..::.ProductRecordType Field
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ProductRecordType As String
C#
public const string ProductRecordType
Visual C++
public:
literal String^ ProductRecordType
JavaScript
InSite.Model.PriceMatrix.productRecordType

See Also

PriceMatrix Class
InSite.Model Namespace


PriceMatrix Methods

[image] [image]

.NET Framework Class Library
PriceMatrix Methods
PriceMatrix Class See Also Send Feedback

The PriceMatrix type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PriceMatrix Class
InSite.Model Namespace


PriceMatrix Properties

[image] [image]

.NET Framework Class Library
PriceMatrix Properties
PriceMatrix Class See Also Send Feedback

The PriceMatrix type exposes the following members.

Properties

Name | Description
Active |
AdjustmentType01 |
AdjustmentType02 |
AdjustmentType03 |
AdjustmentType04 |
AdjustmentType05 |
AdjustmentType06 |
AdjustmentType07 |
AdjustmentType08 |
AdjustmentType09 |
AdjustmentType10 |
AdjustmentType11 |
AltAmount01 |
AltAmount02 |
AltAmount03 |
AltAmount04 |
AltAmount05 |
AltAmount06 |
AltAmount07 |
AltAmount08 |
AltAmount09 |
AltAmount10 |
AltAmount11 |
Amount01 |
Amount02 |
Amount03 |
Amount04 |
Amount05 |
Amount06 |
Amount07 |
Amount08 |
Amount09 |
Amount10 |
Amount11 |
BreakQty01 |
BreakQty02 |
BreakQty03 |
BreakQty04 |
BreakQty05 |
BreakQty06 |
BreakQty07 |
BreakQty08 |
BreakQty09 |
BreakQty10 |
BreakQty11 |
CalculationFlags |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CurrencyCode |
CustomerKeyPart |
CustomerNumberSequenceName |
CustomerPriceCode |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PriceBasis01 |
PriceBasis02 |
PriceBasis03 |
PriceBasis04 |
PriceBasis05 |
PriceBasis06 |
PriceBasis07 |
PriceBasis08 |
PriceBasis09 |
PriceBasis10 |
PriceBasis11 |
PriceMatrixId |
ProductKeyPart |
ProductName |
ProductPriceCategory |
ProductPriceCode |
ProductPriceLine |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RecordType |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UnitOfMeasure |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Warehouse |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PriceMatrix Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
PriceMatrix..::.Active Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType01 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType01 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType01 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType01 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType01 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType01();
function set_adjustmentType01(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType02 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType02 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType02 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType02 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType02 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType02();
function set_adjustmentType02(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType03 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType03 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType03 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType03 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType03 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType03();
function set_adjustmentType03(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType04 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType04 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType04 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType04 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType04 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType04();
function set_adjustmentType04(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType05 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType05 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType05 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType05 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType05 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType05();
function set_adjustmentType05(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType06 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType06 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType06 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType06 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType06 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType06();
function set_adjustmentType06(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType07 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType07 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType07 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType07 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType07 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType07();
function set_adjustmentType07(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType08 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType08 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType08 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType08 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType08 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType08();
function set_adjustmentType08(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType09 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType09 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType09 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType09 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType09 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType09();
function set_adjustmentType09(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType10 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType10 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType10 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType10 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType10 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType10();
function set_adjustmentType10(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AdjustmentType11 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AdjustmentType11 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AdjustmentType11 As String
C#
[DataMemberAttribute]
public virtual string AdjustmentType11 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ AdjustmentType11 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_adjustmentType11();
function set_adjustmentType11(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount01 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount01 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount01 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount01 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount01 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount01();
function set_altAmount01(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount02 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount02 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount02 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount02 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount02 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount02();
function set_altAmount02(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount03 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount03 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount03 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount03 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount03 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount03();
function set_altAmount03(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount04 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount04 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount04 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount04 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount04 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount04();
function set_altAmount04(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount05 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount05 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount05 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount05 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount05 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount05();
function set_altAmount05(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount06 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount06 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount06 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount06 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount06 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount06();
function set_altAmount06(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount07 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount07 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount07 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount07 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount07 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount07();
function set_altAmount07(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount08 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount08 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount08 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount08 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount08 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount08();
function set_altAmount08(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount09 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount09 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount09 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount09 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount09 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount09();
function set_altAmount09(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount10 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount10 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount10 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount10 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount10 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount10();
function set_altAmount10(value);

See Also

PriceMatrix Class
InSite.Model Namespace


AltAmount11 Property

[image]

.NET Framework Class Library
PriceMatrix..::.AltAmount11 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AltAmount11 As Decimal
C#
[DataMemberAttribute]
public virtual decimal AltAmount11 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal AltAmount11 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_altAmount11();
function set_altAmount11(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount01 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount01 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount01 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount01 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount01 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount01();
function set_amount01(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount02 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount02 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount02 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount02 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount02 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount02();
function set_amount02(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount03 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount03 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount03 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount03 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount03 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount03();
function set_amount03(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount04 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount04 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount04 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount04 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount04 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount04();
function set_amount04(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount05 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount05 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount05 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount05 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount05 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount05();
function set_amount05(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount06 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount06 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount06 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount06 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount06 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount06();
function set_amount06(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount07 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount07 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount07 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount07 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount07 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount07();
function set_amount07(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount08 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount08 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount08 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount08 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount08 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount08();
function set_amount08(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount09 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount09 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount09 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount09 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount09 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount09();
function set_amount09(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount10 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount10 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount10 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount10 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount10 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount10();
function set_amount10(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Amount11 Property

[image]

.NET Framework Class Library
PriceMatrix..::.Amount11 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount11 As Decimal
C#
[DataMemberAttribute]
public virtual decimal Amount11 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Amount11 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount11();
function set_amount11(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty01 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty01 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty01 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty01 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty01 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty01();
function set_breakQty01(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty02 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty02 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty02 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty02 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty02 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty02();
function set_breakQty02(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty03 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty03 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty03 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty03 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty03 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty03();
function set_breakQty03(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty04 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty04 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty04 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty04 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty04 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty04();
function set_breakQty04(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty05 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty05 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty05 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty05 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty05 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty05();
function set_breakQty05(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty06 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty06 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty06 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty06 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty06 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty06();
function set_breakQty06(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty07 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty07 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty07 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty07 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty07 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty07();
function set_breakQty07(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty08 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty08 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty08 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty08 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty08 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty08();
function set_breakQty08(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty09 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty09 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty09 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty09 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty09 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty09();
function set_breakQty09(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty10 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty10 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty10 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty10 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty10 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty10();
function set_breakQty10(value);

See Also

PriceMatrix Class
InSite.Model Namespace


BreakQty11 Property

[image]

.NET Framework Class Library
PriceMatrix..::.BreakQty11 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BreakQty11 As Decimal
C#
[DataMemberAttribute]
public virtual decimal BreakQty11 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BreakQty11 {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_breakQty11();
function set_breakQty11(value);

See Also

PriceMatrix Class
InSite.Model Namespace


CalculationFlags Property

[image]

.NET Framework Class Library
PriceMatrix..::.CalculationFlags Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CalculationFlags As String
C#
[DataMemberAttribute]
public virtual string CalculationFlags { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CalculationFlags {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_calculationFlags();
function set_calculationFlags(value);

See Also

PriceMatrix Class
InSite.Model Namespace


CurrencyCode Property

[image]

.NET Framework Class Library
PriceMatrix..::.CurrencyCode Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CurrencyCode As String
C#
[DataMemberAttribute]
public virtual string CurrencyCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_currencyCode();
function set_currencyCode(value);

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerKeyPart Property

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerKeyPart Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerKeyPart As String
C#
[DataMemberAttribute]
public virtual string CustomerKeyPart { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerKeyPart {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerKeyPart();
function set_customerKeyPart(value);

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerNumberSequenceName Property

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerNumberSequenceName Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumberSequenceName As String
C#
[DataMemberAttribute]
public virtual string CustomerNumberSequenceName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumberSequenceName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumberSequenceName();
function set_customerNumberSequenceName(value);

See Also

PriceMatrix Class
InSite.Model Namespace


CustomerPriceCode Property

[image]

.NET Framework Class Library
PriceMatrix..::.CustomerPriceCode Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerPriceCode As String
C#
[DataMemberAttribute]
public virtual string CustomerPriceCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerPriceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerPriceCode();
function set_customerPriceCode(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
PriceMatrix..::.Deactivate Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis01 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis01 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis01 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis01 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis01 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis01();
function set_priceBasis01(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis02 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis02 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis02 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis02 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis02 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis02();
function set_priceBasis02(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis03 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis03 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis03 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis03 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis03 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis03();
function set_priceBasis03(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis04 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis04 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis04 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis04 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis04 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis04();
function set_priceBasis04(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis05 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis05 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis05 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis05 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis05 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis05();
function set_priceBasis05(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis06 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis06 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis06 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis06 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis06 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis06();
function set_priceBasis06(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis07 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis07 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis07 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis07 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis07 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis07();
function set_priceBasis07(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis08 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis08 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis08 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis08 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis08 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis08();
function set_priceBasis08(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis09 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis09 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis09 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis09 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis09 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis09();
function set_priceBasis09(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis10 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis10 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis10 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis10 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis10 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis10();
function set_priceBasis10(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceBasis11 Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceBasis11 Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceBasis11 As String
C#
[DataMemberAttribute]
public virtual string PriceBasis11 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceBasis11 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceBasis11();
function set_priceBasis11(value);

See Also

PriceMatrix Class
InSite.Model Namespace


PriceMatrixId Property

[image]

.NET Framework Class Library
PriceMatrix..::.PriceMatrixId Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PriceMatrixId As Guid
C#
public virtual Guid PriceMatrixId { get; set; }
Visual C++
public:
virtual property Guid PriceMatrixId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_priceMatrixId();
function set_priceMatrixId(value);

See Also

PriceMatrix Class
InSite.Model Namespace


ProductKeyPart Property

[image]

.NET Framework Class Library
PriceMatrix..::.ProductKeyPart Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProductKeyPart As String
C#
[DataMemberAttribute]
public virtual string ProductKeyPart { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProductKeyPart {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productKeyPart();
function set_productKeyPart(value);

See Also

PriceMatrix Class
InSite.Model Namespace


ProductName Property

[image]

.NET Framework Class Library
PriceMatrix..::.ProductName Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProductName As String
C#
[DataMemberAttribute]
public virtual string ProductName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productName();
function set_productName(value);

See Also

PriceMatrix Class
InSite.Model Namespace


ProductPriceCategory Property

[image]

.NET Framework Class Library
PriceMatrix..::.ProductPriceCategory Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProductPriceCategory As String
C#
[DataMemberAttribute]
public virtual string ProductPriceCategory { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProductPriceCategory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productPriceCategory();
function set_productPriceCategory(value);

See Also

PriceMatrix Class
InSite.Model Namespace


ProductPriceCode Property

[image]

.NET Framework Class Library
PriceMatrix..::.ProductPriceCode Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProductPriceCode As String
C#
[DataMemberAttribute]
public virtual string ProductPriceCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProductPriceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productPriceCode();
function set_productPriceCode(value);

See Also

PriceMatrix Class
InSite.Model Namespace


ProductPriceLine Property

[image]

.NET Framework Class Library
PriceMatrix..::.ProductPriceLine Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProductPriceLine As String
C#
[DataMemberAttribute]
public virtual string ProductPriceLine { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProductPriceLine {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productPriceLine();
function set_productPriceLine(value);

See Also

PriceMatrix Class
InSite.Model Namespace


RecordType Property

[image]

.NET Framework Class Library
PriceMatrix..::.RecordType Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property RecordType As String
C#
[SortField]
[DataMemberAttribute]
public virtual string RecordType { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ RecordType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_recordType();
function set_recordType(value);

See Also

PriceMatrix Class
InSite.Model Namespace


UnitOfMeasure Property

[image]

.NET Framework Class Library
PriceMatrix..::.UnitOfMeasure Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UnitOfMeasure As String
C#
[DataMemberAttribute]
public virtual string UnitOfMeasure { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ UnitOfMeasure {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_unitOfMeasure();
function set_unitOfMeasure(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Warehouse Property

[image]

.NET Framework Class Library
PriceMatrix..::.Warehouse Property
PriceMatrix Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Warehouse As String
C#
[DataMemberAttribute]
public virtual string Warehouse { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Warehouse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_warehouse();
function set_warehouse(value);

See Also

PriceMatrix Class
InSite.Model Namespace


Product Class

[image]

.NET Framework Class Library
Product Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Product _
    Inherits ModelBase(Of Product)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Product : ModelBase<Product>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Product : public ModelBase<Product^>
JavaScript
InSite.Model.Product = function();

Type.createClass(
    'InSite.Model.Product',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Product>)>)
InSite.Model..::.Product

See Also

Product Members
InSite.Model Namespace


Product Members

[image] [image]

.NET Framework Class Library
Product Members
Product Class Constructors Methods Fields Properties See Also Send Feedback

The Product type exposes the following members.

Constructors

Name | Description
Product | Overloaded.

Methods

Name | Description
AddAccessory |
AddCategory |
AddCrossSell |
AddCustomer |
AddDealer |
AddFilterValue |
AddInventoryTransaction |
AddProductProperty |
AddRestriction |
AddReview |
AddSpecification |
AddStyleChild |
AddStyleTraitValue |
AddSubscriptionProduct |
AddTaxExemption |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy | Returns a Copy of this Product
DecrementQtyOnHand |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetActiveProductCount |
GetActiveProductList | Overloaded.
GetActualConfiguredPrice | Gets Actual Price to Charge for the Quantity Ordered with Configuration (includes Sales Price, Customer Pricing and Discounts)
GetActualPrice | Gets Actual Price to Charge for the Quantity Ordered (includes Sales Price, Customer Pricing and Discounts)
GetByName |
GetConfigSections |
GetERPList |
GetFilteredList | Overloaded.
GetFirstByERPNumber |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetIsOnSale | Determines if there is a sale for this Product for the Quantity Ordered
GetProductProperty | Overloaded.
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetQtyOnHand |
GetRegularConfiguredPrice | Gets Regular Full Price for the Quantity Ordered with Configuration
GetRegularPrice | Gets Regular Full Price for the Quantity Ordered
GetReview |
GetSectionOptions |
GetSpecification |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsInStock |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PassesRestrictions |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveAccessory |
RemoveCategory |
RemoveCrossSell |
RemoveCustomer |
RemoveDealer |
RemoveFilterValue |
RemoveInventoryTransaction |
RemoveProductProperty |
RemoveRestriction |
RemoveReview |
RemoveSpecification |
RemoveStyleChild |
RemoveStyleTraitValue |
RemoveSubscriptionProduct |
RemoveTaxExemption |
SaveConfigDataSet |
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Accessories |
Active |
ActiveAccessories |
ActiveCrossSells |
ActualPrice | ActualPrice the Calculated Price to Charge for a Quantity of 1 (includes Sales Price, Customer Pricing and Discounts)
AllowAnyGiftCardAmount |
BasicListPrice |
BasicSaleEnd |
BasicSalePrice |
BasicSaleStart |
Categories |
CategoryTree |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ConfigDataSet |
ContentManager |
Cost | Cost the Product Cost that may be used for pricing
CrossSells |
CustomerProductSets |
Customers |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Dealers |
Description |
DocumentManager |
Documents |
ERPDescription |
ERPManaged |
ERPNumber |
FilterValues |
HandlingAmountOverride |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InventoryTransactions |
IsActive |
IsConfigured |
IsGiftCard |
IsOnSale | IsOnSale returns if this Product is on sale for a Quantity of 1
IsSubscription |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LargeImagePath |
MediumImagePath |
MetaDescription |
MetaKeywords |
ModelNumber |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PageTitle |
PriceCode |
ProductCode |
ProductId |
ProductProperties |
QtyOnHand |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RegularPrice | RegularPrice the Calculated Regular Full Price for a Quantity of 1 with no Configuration
Restrictions |
Reviews |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShippingAmountOverride |
ShippingClassification |
ShippingHeight |
ShippingLength |
ShippingWeight |
ShippingWidth |
ShortDescription |
Sku |
SmallImagePath |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
Specifications |
StyleChildren |
StyleClass |
StyleParent |
StyleSheet |
StyleTraitValues |
SubscriptionApril |
SubscriptionAugust |
SubscriptionCyclePeriod |
SubscriptionDecember |
SubscriptionFebruary |
SubscriptionFixedPrice |
SubscriptionIncludeInInitialOrder |
SubscriptionJanuary |
SubscriptionJuly |
SubscriptionJune |
SubscriptionMarch |
SubscriptionMay |
SubscriptionNovember |
SubscriptionOctober |
SubscriptionPeriodsPerCycle |
SubscriptionProducts |
SubscriptionSeptember |
SubscriptionShipVia |
SubscriptionTotalCycles |
TaxCategory |
TaxCode1 |
TaxCode2 |
TaxExemptions |
TrackInventory |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UnitOfMeasure |
UPCCode |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Vendor |
WishListProducts |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Product Class
InSite.Model Namespace


Product Constructor

[image] [image]

.NET Framework Class Library
Product Constructor
Product Class See Also Send Feedback

Overload List

Name | Description
Product()()() |
Product(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Product Class
Product Members
InSite.Model Namespace


Product Constructor

[image]

.NET Framework Class Library
Product Constructor
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Product()
Visual C++
public:
Product()
JavaScript
InSite.Model.Product = function();

See Also

Product Class
Product Overload
InSite.Model Namespace


Product Constructor (SearchMode)

[image]

.NET Framework Class Library
Product Constructor (SearchMode)
Product Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Product(
    SearchMode searchMode
)
Visual C++
public:
Product(
    SearchMode searchMode
)
JavaScript
InSite.Model.Product = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Product Class
Product Overload
InSite.Model Namespace


Product Fields

[image] [image]

.NET Framework Class Library
Product Fields
Product Class See Also Send Feedback

The Product type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Product Class
InSite.Model Namespace


Product Methods

[image] [image]

.NET Framework Class Library
Product Methods
Product Class See Also Send Feedback

The Product type exposes the following members.

Methods

Name | Description
AddAccessory |
AddCategory |
AddCrossSell |
AddCustomer |
AddDealer |
AddFilterValue |
AddInventoryTransaction |
AddProductProperty |
AddRestriction |
AddReview |
AddSpecification |
AddStyleChild |
AddStyleTraitValue |
AddSubscriptionProduct |
AddTaxExemption |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy | Returns a Copy of this Product
DecrementQtyOnHand |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetActiveProductCount |
GetActiveProductList | Overloaded.
GetActualConfiguredPrice | Gets Actual Price to Charge for the Quantity Ordered with Configuration (includes Sales Price, Customer Pricing and Discounts)
GetActualPrice | Gets Actual Price to Charge for the Quantity Ordered (includes Sales Price, Customer Pricing and Discounts)
GetByName |
GetConfigSections |
GetERPList |
GetFilteredList | Overloaded.
GetFirstByERPNumber |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetIsOnSale | Determines if there is a sale for this Product for the Quantity Ordered
GetProductProperty | Overloaded.
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetQtyOnHand |
GetRegularConfiguredPrice | Gets Regular Full Price for the Quantity Ordered with Configuration
GetRegularPrice | Gets Regular Full Price for the Quantity Ordered
GetReview |
GetSectionOptions |
GetSpecification |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsInStock |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PassesRestrictions |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveAccessory |
RemoveCategory |
RemoveCrossSell |
RemoveCustomer |
RemoveDealer |
RemoveFilterValue |
RemoveInventoryTransaction |
RemoveProductProperty |
RemoveRestriction |
RemoveReview |
RemoveSpecification |
RemoveStyleChild |
RemoveStyleTraitValue |
RemoveSubscriptionProduct |
RemoveTaxExemption |
SaveConfigDataSet |
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Product Class
InSite.Model Namespace


AddAccessory Method

[image]

.NET Framework Class Library
Product..::.AddAccessory Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddAccessory ( _
    value As ProductInfo _
)
C#
public virtual void AddAccessory(
    ProductInfo value
)
Visual C++
public:
virtual void AddAccessory(
    ProductInfo^ value
)
JavaScript
function addAccessory(value);

Parameters

value
Type: InSite.Model..::.ProductInfo

See Also

Product Class
InSite.Model Namespace


AddCategory Method

[image]

.NET Framework Class Library
Product..::.AddCategory Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategory ( _
    value As Category _
)
C#
public virtual void AddCategory(
    Category value
)
Visual C++
public:
virtual void AddCategory(
    Category^ value
)
JavaScript
function addCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

Product Class
InSite.Model Namespace


AddCrossSell Method

[image]

.NET Framework Class Library
Product..::.AddCrossSell Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCrossSell ( _
    value As ProductInfo _
)
C#
public virtual void AddCrossSell(
    ProductInfo value
)
Visual C++
public:
virtual void AddCrossSell(
    ProductInfo^ value
)
JavaScript
function addCrossSell(value);

Parameters

value
Type: InSite.Model..::.ProductInfo

See Also

Product Class
InSite.Model Namespace


AddCustomer Method

[image]

.NET Framework Class Library
Product..::.AddCustomer Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomer ( _
    value As Customer _
)
C#
public virtual void AddCustomer(
    Customer value
)
Visual C++
public:
virtual void AddCustomer(
    Customer^ value
)
JavaScript
function addCustomer(value);

Parameters

value
Type: InSite.Model..::.Customer

See Also

Product Class
InSite.Model Namespace


AddDealer Method

[image]

.NET Framework Class Library
Product..::.AddDealer Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddDealer ( _
    value As Dealer _
)
C#
public virtual void AddDealer(
    Dealer value
)
Visual C++
public:
virtual void AddDealer(
    Dealer^ value
)
JavaScript
function addDealer(value);

Parameters

value
Type: InSite.Model..::.Dealer

See Also

Product Class
InSite.Model Namespace


AddFilterValue Method

[image]

.NET Framework Class Library
Product..::.AddFilterValue Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddFilterValue ( _
    value As FilterValue _
)
C#
public virtual void AddFilterValue(
    FilterValue value
)
Visual C++
public:
virtual void AddFilterValue(
    FilterValue^ value
)
JavaScript
function addFilterValue(value);

Parameters

value
Type: InSite.Model..::.FilterValue

See Also

Product Class
InSite.Model Namespace


AddInventoryTransaction Method

[image]

.NET Framework Class Library
Product..::.AddInventoryTransaction Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddInventoryTransaction ( _
    value As InventoryTransaction _
)
C#
public virtual void AddInventoryTransaction(
    InventoryTransaction value
)
Visual C++
public:
virtual void AddInventoryTransaction(
    InventoryTransaction^ value
)
JavaScript
function addInventoryTransaction(value);

Parameters

value
Type: InSite.Model..::.InventoryTransaction

See Also

Product Class
InSite.Model Namespace


AddProductProperty Method

[image]

.NET Framework Class Library
Product..::.AddProductProperty Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProductProperty ( _
    value As ProductProperty _
)
C#
public virtual void AddProductProperty(
    ProductProperty value
)
Visual C++
public:
virtual void AddProductProperty(
    ProductProperty^ value
)
JavaScript
function addProductProperty(value);

Parameters

value
Type: InSite.Model..::.ProductProperty

See Also

Product Class
InSite.Model Namespace


AddRestriction Method

[image]

.NET Framework Class Library
Product..::.AddRestriction Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRestriction ( _
    value As Restriction _
)
C#
public virtual void AddRestriction(
    Restriction value
)
Visual C++
public:
virtual void AddRestriction(
    Restriction^ value
)
JavaScript
function addRestriction(value);

Parameters

value
Type: InSite.Model..::.Restriction

See Also

Product Class
InSite.Model Namespace


AddReview Method

[image]

.NET Framework Class Library
Product..::.AddReview Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddReview ( _
    value As Review _
)
C#
public virtual void AddReview(
    Review value
)
Visual C++
public:
virtual void AddReview(
    Review^ value
)
JavaScript
function addReview(value);

Parameters

value
Type: InSite.Model..::.Review

See Also

Product Class
InSite.Model Namespace


AddSpecification Method

[image]

.NET Framework Class Library
Product..::.AddSpecification Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddSpecification ( _
    value As Specification _
)
C#
public virtual void AddSpecification(
    Specification value
)
Visual C++
public:
virtual void AddSpecification(
    Specification^ value
)
JavaScript
function addSpecification(value);

Parameters

value
Type: InSite.Model..::.Specification

See Also

Product Class
InSite.Model Namespace


AddStyleChild Method

[image]

.NET Framework Class Library
Product..::.AddStyleChild Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddStyleChild ( _
    value As Product _
)
C#
public virtual void AddStyleChild(
    Product value
)
Visual C++
public:
virtual void AddStyleChild(
    Product^ value
)
JavaScript
function addStyleChild(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Product Class
InSite.Model Namespace


AddStyleTraitValue Method

[image]

.NET Framework Class Library
Product..::.AddStyleTraitValue Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddStyleTraitValue ( _
    value As StyleTraitValue _
)
C#
public virtual void AddStyleTraitValue(
    StyleTraitValue value
)
Visual C++
public:
virtual void AddStyleTraitValue(
    StyleTraitValue^ value
)
JavaScript
function addStyleTraitValue(value);

Parameters

value
Type: InSite.Model..::.StyleTraitValue

See Also

Product Class
InSite.Model Namespace


AddSubscriptionProduct Method

[image]

.NET Framework Class Library
Product..::.AddSubscriptionProduct Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddSubscriptionProduct ( _
    value As SubscriptionProduct _
)
C#
public virtual void AddSubscriptionProduct(
    SubscriptionProduct value
)
Visual C++
public:
virtual void AddSubscriptionProduct(
    SubscriptionProduct^ value
)
JavaScript
function addSubscriptionProduct(value);

Parameters

value
Type: InSite.Model..::.SubscriptionProduct

See Also

Product Class
InSite.Model Namespace


AddTaxExemption Method

[image]

.NET Framework Class Library
Product..::.AddTaxExemption Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddTaxExemption ( _
    value As TaxExemption _
)
C#
public virtual void AddTaxExemption(
    TaxExemption value
)
Visual C++
public:
virtual void AddTaxExemption(
    TaxExemption^ value
)
JavaScript
function addTaxExemption(value);

Parameters

value
Type: InSite.Model..::.TaxExemption

See Also

Product Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
Product..::.Copy Method
Product Class See Also Send Feedback

Returns a Copy of this Product

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As Product
C#
public virtual Product Copy()
Visual C++
public:
virtual Product^ Copy()
JavaScript
function copy();

Return Value

See Also

Product Class
InSite.Model Namespace


DecrementQtyOnHand Method

[image]

.NET Framework Class Library
Product..::.DecrementQtyOnHand Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub DecrementQtyOnHand ( _
    qtyToDecrement As Decimal _
)
C#
public virtual void DecrementQtyOnHand(
    decimal qtyToDecrement
)
Visual C++
public:
virtual void DecrementQtyOnHand(
    Decimal qtyToDecrement
)
JavaScript
function decrementQtyOnHand(qtyToDecrement);

Parameters

qtyToDecrement
Type: System..::.Decimal

See Also

Product Class
InSite.Model Namespace


GetActiveProductCount Method

[image]

.NET Framework Class Library
Product..::.GetActiveProductCount Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetActiveProductCount ( _
    search As String _
) As Integer
C#
public static int GetActiveProductCount(
    string search
)
Visual C++
public:
static int GetActiveProductCount(
    String^ search
)
JavaScript
InSite.Model.Product.getActiveProductCount = function(search);

Parameters

search
Type: System..::.String

See Also

Product Class
InSite.Model Namespace


GetActiveProductList Method

[image] [image]

.NET Framework Class Library
Product..::.GetActiveProductList Method
Product Class See Also Send Feedback

Overload List

Name | Description
GetActiveProductList(String, String) |
GetActiveProductList(String, String, Int32, Int32) |

See Also

Product Class
Product Members
InSite.Model Namespace


GetActiveProductList Method (String, String)

[image]

.NET Framework Class Library
Product..::.GetActiveProductList Method (String, String)
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetActiveProductList ( _
    search As String, _
    sort As String _
) As IList(Of Product)
C#
public static IList<Product> GetActiveProductList(
    string search,
    string sort
)
Visual C++
public:
static IList<Product^>^ GetActiveProductList(
    String^ search,
    String^ sort
)
JavaScript
InSite.Model.Product.getActiveProductList = function(search, sort);

Parameters

search
Type: System..::.String
sort
Type: System..::.String

See Also

Product Class
GetActiveProductList Overload
InSite.Model Namespace


GetActiveProductList Method (String, String, Int32, Int32)

[image]

.NET Framework Class Library
Product..::.GetActiveProductList Method (String, String, Int32, Int32)
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetActiveProductList ( _
    search As String, _
    sort As String, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of Product)
C#
public static IList<Product> GetActiveProductList(
    string search,
    string sort,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<Product^>^ GetActiveProductList(
    String^ search,
    String^ sort,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.Product.getActiveProductList = function(search, sort, startRow, pageSize);

Parameters

search
Type: System..::.String
sort
Type: System..::.String
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

Product Class
GetActiveProductList Overload
InSite.Model Namespace


GetActualConfiguredPrice Method

[image]

.NET Framework Class Library
Product..::.GetActualConfiguredPrice Method
Product Class See Also Send Feedback

Gets Actual Price to Charge for the Quantity Ordered with Configuration (includes Sales Price, Customer Pricing and Discounts)

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetActualConfiguredPrice ( _
    qtyOrdered As Decimal, _
    configDataSet As DataSet _
) As Decimal
C#
public virtual decimal GetActualConfiguredPrice(
    decimal qtyOrdered,
    DataSet configDataSet
)
Visual C++
public:
virtual Decimal GetActualConfiguredPrice(
    Decimal qtyOrdered,
    DataSet^ configDataSet
)
JavaScript
function getActualConfiguredPrice(qtyOrdered, configDataSet);

Parameters

qtyOrdered
Type: System..::.Decimal
Required
configDataSet
Type: System.Data..::.DataSet
Required

Return Value

Price

See Also

Product Class
InSite.Model Namespace


GetActualPrice Method

[image]

.NET Framework Class Library
Product..::.GetActualPrice Method
Product Class See Also Send Feedback

Gets Actual Price to Charge for the Quantity Ordered (includes Sales Price, Customer Pricing and Discounts)

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetActualPrice ( _
    qtyOrdered As Decimal _
) As Decimal
C#
public virtual decimal GetActualPrice(
    decimal qtyOrdered
)
Visual C++
public:
virtual Decimal GetActualPrice(
    Decimal qtyOrdered
)
JavaScript
function getActualPrice(qtyOrdered);

Parameters

qtyOrdered
Type: System..::.Decimal
Required

Return Value

Price

See Also

Product Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
Product..::.GetByName Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    productName As String _
) As Product
C#
public static Product GetByName(
    string productName
)
Visual C++
public:
static Product^ GetByName(
    String^ productName
)
JavaScript
InSite.Model.Product.getByName = function(productName);

Parameters

productName
Type: System..::.String

See Also

Product Class
InSite.Model Namespace


GetConfigSections Method

[image]

.NET Framework Class Library
Product..::.GetConfigSections Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetConfigSections As DataRowCollection
C#
public virtual DataRowCollection GetConfigSections()
Visual C++
public:
virtual DataRowCollection^ GetConfigSections()
JavaScript
function getConfigSections();

See Also

Product Class
InSite.Model Namespace


GetERPList Method

[image]

.NET Framework Class Library
Product..::.GetERPList Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetERPList ( _
    erpNumber As String _
) As IList(Of Product)
C#
public static IList<Product> GetERPList(
    string erpNumber
)
Visual C++
public:
static IList<Product^>^ GetERPList(
    String^ erpNumber
)
JavaScript
InSite.Model.Product.getERPList = function(erpNumber);

Parameters

erpNumber
Type: System..::.String

See Also

Product Class
InSite.Model Namespace


GetFilteredList Method

[image] [image]

.NET Framework Class Library
Product..::.GetFilteredList Method
Product Class See Also Send Feedback

Overload List

Name | Description
GetFilteredList(IList<(Of <(FilterValue>)>), String, Int32, Int32) |
GetFilteredList(IList<(Of <(FilterValue>)>), IList<(Of <(Category>)>), String, Int32, Int32) |

See Also

Product Class
Product Members
InSite.Model Namespace


GetFilteredList Method (IList(FilterValue), String, Int32, Int32)

[image]

.NET Framework Class Library
Product..::.GetFilteredList Method (IList<(Of <(FilterValue>)>), String, Int32, Int32)
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFilteredList ( _
    filterValues As IList(Of FilterValue), _
    sort As String, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of Product)
C#
public static IList<Product> GetFilteredList(
    IList<FilterValue> filterValues,
    string sort,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<Product^>^ GetFilteredList(
    IList<FilterValue^>^ filterValues,
    String^ sort,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.Product.getFilteredList = function(filterValues, sort, startRow, pageSize);

Parameters

filterValues
Type: System.Collections.Generic..::.IList <(Of <( FilterValue >)>)
sort
Type: System..::.String
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

Product Class
GetFilteredList Overload
InSite.Model Namespace


GetFilteredList Method (IList(FilterValue), IList(Category), String, Int32, Int32)

[image]

.NET Framework Class Library
Product..::.GetFilteredList Method (IList<(Of <(FilterValue>)>), IList<(Of <(Category>)>), String, Int32, Int32)
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFilteredList ( _
    filterValues As IList(Of FilterValue), _
    filterCategories As IList(Of Category), _
    sort As String, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of Product)
C#
public static IList<Product> GetFilteredList(
    IList<FilterValue> filterValues,
    IList<Category> filterCategories,
    string sort,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<Product^>^ GetFilteredList(
    IList<FilterValue^>^ filterValues,
    IList<Category^>^ filterCategories,
    String^ sort,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.Product.getFilteredList = function(filterValues, filterCategories, sort, startRow, pageSize);

Parameters

filterValues
Type: System.Collections.Generic..::.IList <(Of <( FilterValue >)>)
filterCategories
Type: System.Collections.Generic..::.IList <(Of <( Category >)>)
sort
Type: System..::.String
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

Product Class
GetFilteredList Overload
InSite.Model Namespace


GetFirstByERPNumber Method

[image]

.NET Framework Class Library
Product..::.GetFirstByERPNumber Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetFirstByERPNumber ( _
    erpNumber As String _
) As Product
C#
public static Product GetFirstByERPNumber(
    string erpNumber
)
Visual C++
public:
static Product^ GetFirstByERPNumber(
    String^ erpNumber
)
JavaScript
InSite.Model.Product.getFirstByERPNumber = function(erpNumber);

Parameters

erpNumber
Type: System..::.String

See Also

Product Class
InSite.Model Namespace


GetIsOnSale Method

[image]

.NET Framework Class Library
Product..::.GetIsOnSale Method
Product Class See Also Send Feedback

Determines if there is a sale for this Product for the Quantity Ordered

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetIsOnSale ( _
    qtyOrdered As Decimal _
) As Boolean
C#
public virtual bool GetIsOnSale(
    decimal qtyOrdered
)
Visual C++
public:
virtual bool GetIsOnSale(
    Decimal qtyOrdered
)
JavaScript
function getIsOnSale(qtyOrdered);

Parameters

qtyOrdered
Type: System..::.Decimal
Required

Return Value

true or false

See Also

Product Class
InSite.Model Namespace


GetProductProperty Method

[image] [image]

.NET Framework Class Library
Product..::.GetProductProperty Method
Product Class See Also Send Feedback

Overload List

Name | Description
GetProductProperty(String) |
GetProductProperty(String, String) |

See Also

Product Class
Product Members
InSite.Model Namespace


GetProductProperty Method (String)

[image]

.NET Framework Class Library
Product..::.GetProductProperty Method (String)
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProductProperty ( _
    name As String _
) As ProductProperty
C#
public virtual ProductProperty GetProductProperty(
    string name
)
Visual C++
public:
virtual ProductProperty^ GetProductProperty(
    String^ name
)
JavaScript
function getProductProperty(name);

Parameters

name
Type: System..::.String

See Also

Product Class
GetProductProperty Overload
InSite.Model Namespace


GetProductProperty Method (String, String)

[image]

.NET Framework Class Library
Product..::.GetProductProperty Method (String, String)
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetProductProperty ( _
    name As String, _
    defaultValue As String _
) As ProductProperty
C#
public virtual ProductProperty GetProductProperty(
    string name,
    string defaultValue
)
Visual C++
public:
virtual ProductProperty^ GetProductProperty(
    String^ name,
    String^ defaultValue
)
JavaScript
function getProductProperty(name, defaultValue);

Parameters

name
Type: System..::.String
defaultValue
Type: System..::.String

See Also

Product Class
GetProductProperty Overload
InSite.Model Namespace


GetQtyOnHand Method

[image]

.NET Framework Class Library
Product..::.GetQtyOnHand Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetQtyOnHand ( _
    asOf As DateTime _
) As Decimal
C#
public virtual decimal GetQtyOnHand(
    DateTime asOf
)
Visual C++
public:
virtual Decimal GetQtyOnHand(
    DateTime asOf
)
JavaScript
function getQtyOnHand(asOf);

Parameters

asOf
Type: System..::.DateTime

See Also

Product Class
InSite.Model Namespace


GetRegularConfiguredPrice Method

[image]

.NET Framework Class Library
Product..::.GetRegularConfiguredPrice Method
Product Class See Also Send Feedback

Gets Regular Full Price for the Quantity Ordered with Configuration

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRegularConfiguredPrice ( _
    qtyOrdered As Decimal, _
    configDataSet As DataSet _
) As Decimal
C#
public virtual decimal GetRegularConfiguredPrice(
    decimal qtyOrdered,
    DataSet configDataSet
)
Visual C++
public:
virtual Decimal GetRegularConfiguredPrice(
    Decimal qtyOrdered,
    DataSet^ configDataSet
)
JavaScript
function getRegularConfiguredPrice(qtyOrdered, configDataSet);

Parameters

qtyOrdered
Type: System..::.Decimal
Required
configDataSet
Type: System.Data..::.DataSet
Required

Return Value

Price

See Also

Product Class
InSite.Model Namespace


GetRegularPrice Method

[image]

.NET Framework Class Library
Product..::.GetRegularPrice Method
Product Class See Also Send Feedback

Gets Regular Full Price for the Quantity Ordered

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetRegularPrice ( _
    qtyOrdered As Decimal _
) As Decimal
C#
public virtual decimal GetRegularPrice(
    decimal qtyOrdered
)
Visual C++
public:
virtual Decimal GetRegularPrice(
    Decimal qtyOrdered
)
JavaScript
function getRegularPrice(qtyOrdered);

Parameters

qtyOrdered
Type: System..::.Decimal
Required

Return Value

Price

See Also

Product Class
InSite.Model Namespace


GetReview Method

[image]

.NET Framework Class Library
Product..::.GetReview Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetReview ( _
    categoryId As Guid _
) As String
C#
public virtual string GetReview(
    Guid categoryId
)
Visual C++
public:
virtual String^ GetReview(
    Guid categoryId
)
JavaScript
function getReview(categoryId);

Parameters

categoryId
Type: System..::.Guid

See Also

Product Class
InSite.Model Namespace


GetSectionOptions Method

[image]

.NET Framework Class Library
Product..::.GetSectionOptions Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSectionOptions ( _
    sectionName As String _
) As OrderedEnumerableRowCollection(Of DataRow)
C#
public virtual OrderedEnumerableRowCollection<DataRow> GetSectionOptions(
    string sectionName
)
Visual C++
public:
virtual OrderedEnumerableRowCollection<DataRow^>^ GetSectionOptions(
    String^ sectionName
)
JavaScript
function getSectionOptions(sectionName);

Parameters

sectionName
Type: System..::.String

See Also

Product Class
InSite.Model Namespace


GetSpecification Method

[image]

.NET Framework Class Library
Product..::.GetSpecification Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSpecification ( _
    name As String _
) As Specification
C#
public virtual Specification GetSpecification(
    string name
)
Visual C++
public:
virtual Specification^ GetSpecification(
    String^ name
)
JavaScript
function getSpecification(name);

Parameters

name
Type: System..::.String

See Also

Product Class
InSite.Model Namespace


IsInStock Method

[image]

.NET Framework Class Library
Product..::.IsInStock Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsInStock ( _
    qtyToOrder As Decimal _
) As Boolean
C#
public virtual bool IsInStock(
    decimal qtyToOrder
)
Visual C++
public:
virtual bool IsInStock(
    Decimal qtyToOrder
)
JavaScript
function isInStock(qtyToOrder);

Parameters

qtyToOrder
Type: System..::.Decimal

See Also

Product Class
InSite.Model Namespace


PassesRestrictions Method

[image]

.NET Framework Class Library
Product..::.PassesRestrictions Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function PassesRestrictions ( _
    customerOrder As CustomerOrder _
) As Boolean
C#
public virtual bool PassesRestrictions(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual bool PassesRestrictions(
    CustomerOrder^ customerOrder
)
JavaScript
function passesRestrictions(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Product Class
InSite.Model Namespace


RemoveAccessory Method

[image]

.NET Framework Class Library
Product..::.RemoveAccessory Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAccessory ( _
    value As ProductInfo _
)
C#
public virtual void RemoveAccessory(
    ProductInfo value
)
Visual C++
public:
virtual void RemoveAccessory(
    ProductInfo^ value
)
JavaScript
function removeAccessory(value);

Parameters

value
Type: InSite.Model..::.ProductInfo

See Also

Product Class
InSite.Model Namespace


RemoveCategory Method

[image]

.NET Framework Class Library
Product..::.RemoveCategory Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategory ( _
    value As Category _
)
C#
public virtual void RemoveCategory(
    Category value
)
Visual C++
public:
virtual void RemoveCategory(
    Category^ value
)
JavaScript
function removeCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

Product Class
InSite.Model Namespace


RemoveCrossSell Method

[image]

.NET Framework Class Library
Product..::.RemoveCrossSell Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCrossSell ( _
    value As ProductInfo _
)
C#
public virtual void RemoveCrossSell(
    ProductInfo value
)
Visual C++
public:
virtual void RemoveCrossSell(
    ProductInfo^ value
)
JavaScript
function removeCrossSell(value);

Parameters

value
Type: InSite.Model..::.ProductInfo

See Also

Product Class
InSite.Model Namespace


RemoveCustomer Method

[image]

.NET Framework Class Library
Product..::.RemoveCustomer Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomer ( _
    value As Customer _
)
C#
public virtual void RemoveCustomer(
    Customer value
)
Visual C++
public:
virtual void RemoveCustomer(
    Customer^ value
)
JavaScript
function removeCustomer(value);

Parameters

value
Type: InSite.Model..::.Customer

See Also

Product Class
InSite.Model Namespace


RemoveDealer Method

[image]

.NET Framework Class Library
Product..::.RemoveDealer Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveDealer ( _
    value As Dealer _
)
C#
public virtual void RemoveDealer(
    Dealer value
)
Visual C++
public:
virtual void RemoveDealer(
    Dealer^ value
)
JavaScript
function removeDealer(value);

Parameters

value
Type: InSite.Model..::.Dealer

See Also

Product Class
InSite.Model Namespace


RemoveFilterValue Method

[image]

.NET Framework Class Library
Product..::.RemoveFilterValue Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveFilterValue ( _
    value As FilterValue _
)
C#
public virtual void RemoveFilterValue(
    FilterValue value
)
Visual C++
public:
virtual void RemoveFilterValue(
    FilterValue^ value
)
JavaScript
function removeFilterValue(value);

Parameters

value
Type: InSite.Model..::.FilterValue

See Also

Product Class
InSite.Model Namespace


RemoveInventoryTransaction Method

[image]

.NET Framework Class Library
Product..::.RemoveInventoryTransaction Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveInventoryTransaction ( _
    value As InventoryTransaction _
)
C#
public virtual void RemoveInventoryTransaction(
    InventoryTransaction value
)
Visual C++
public:
virtual void RemoveInventoryTransaction(
    InventoryTransaction^ value
)
JavaScript
function removeInventoryTransaction(value);

Parameters

value
Type: InSite.Model..::.InventoryTransaction

See Also

Product Class
InSite.Model Namespace


RemoveProductProperty Method

[image]

.NET Framework Class Library
Product..::.RemoveProductProperty Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProductProperty ( _
    value As ProductProperty _
)
C#
public virtual void RemoveProductProperty(
    ProductProperty value
)
Visual C++
public:
virtual void RemoveProductProperty(
    ProductProperty^ value
)
JavaScript
function removeProductProperty(value);

Parameters

value
Type: InSite.Model..::.ProductProperty

See Also

Product Class
InSite.Model Namespace


RemoveRestriction Method

[image]

.NET Framework Class Library
Product..::.RemoveRestriction Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveRestriction ( _
    value As Restriction _
)
C#
public virtual void RemoveRestriction(
    Restriction value
)
Visual C++
public:
virtual void RemoveRestriction(
    Restriction^ value
)
JavaScript
function removeRestriction(value);

Parameters

value
Type: InSite.Model..::.Restriction

See Also

Product Class
InSite.Model Namespace


RemoveReview Method

[image]

.NET Framework Class Library
Product..::.RemoveReview Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveReview ( _
    value As Review _
)
C#
public virtual void RemoveReview(
    Review value
)
Visual C++
public:
virtual void RemoveReview(
    Review^ value
)
JavaScript
function removeReview(value);

Parameters

value
Type: InSite.Model..::.Review

See Also

Product Class
InSite.Model Namespace


RemoveSpecification Method

[image]

.NET Framework Class Library
Product..::.RemoveSpecification Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSpecification ( _
    value As Specification _
)
C#
public virtual void RemoveSpecification(
    Specification value
)
Visual C++
public:
virtual void RemoveSpecification(
    Specification^ value
)
JavaScript
function removeSpecification(value);

Parameters

value
Type: InSite.Model..::.Specification

See Also

Product Class
InSite.Model Namespace


RemoveStyleChild Method

[image]

.NET Framework Class Library
Product..::.RemoveStyleChild Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveStyleChild ( _
    value As Product _
)
C#
public virtual void RemoveStyleChild(
    Product value
)
Visual C++
public:
virtual void RemoveStyleChild(
    Product^ value
)
JavaScript
function removeStyleChild(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Product Class
InSite.Model Namespace


RemoveStyleTraitValue Method

[image]

.NET Framework Class Library
Product..::.RemoveStyleTraitValue Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveStyleTraitValue ( _
    value As StyleTraitValue _
)
C#
public virtual void RemoveStyleTraitValue(
    StyleTraitValue value
)
Visual C++
public:
virtual void RemoveStyleTraitValue(
    StyleTraitValue^ value
)
JavaScript
function removeStyleTraitValue(value);

Parameters

value
Type: InSite.Model..::.StyleTraitValue

See Also

Product Class
InSite.Model Namespace


RemoveSubscriptionProduct Method

[image]

.NET Framework Class Library
Product..::.RemoveSubscriptionProduct Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSubscriptionProduct ( _
    value As SubscriptionProduct _
)
C#
public virtual void RemoveSubscriptionProduct(
    SubscriptionProduct value
)
Visual C++
public:
virtual void RemoveSubscriptionProduct(
    SubscriptionProduct^ value
)
JavaScript
function removeSubscriptionProduct(value);

Parameters

value
Type: InSite.Model..::.SubscriptionProduct

See Also

Product Class
InSite.Model Namespace


RemoveTaxExemption Method

[image]

.NET Framework Class Library
Product..::.RemoveTaxExemption Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveTaxExemption ( _
    value As TaxExemption _
)
C#
public virtual void RemoveTaxExemption(
    TaxExemption value
)
Visual C++
public:
virtual void RemoveTaxExemption(
    TaxExemption^ value
)
JavaScript
function removeTaxExemption(value);

Parameters

value
Type: InSite.Model..::.TaxExemption

See Also

Product Class
InSite.Model Namespace


SaveConfigDataSet Method

[image]

.NET Framework Class Library
Product..::.SaveConfigDataSet Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveConfigDataSet
C#
public virtual void SaveConfigDataSet()
Visual C++
public:
virtual void SaveConfigDataSet()
JavaScript
function saveConfigDataSet();

See Also

Product Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
Product..::.ToString Method
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

Product Class
InSite.Model Namespace


Product Properties

[image] [image]

.NET Framework Class Library
Product Properties
Product Class See Also Send Feedback

The Product type exposes the following members.

Properties

Name | Description
Accessories |
Active |
ActiveAccessories |
ActiveCrossSells |
ActualPrice | ActualPrice the Calculated Price to Charge for a Quantity of 1 (includes Sales Price, Customer Pricing and Discounts)
AllowAnyGiftCardAmount |
BasicListPrice |
BasicSaleEnd |
BasicSalePrice |
BasicSaleStart |
Categories |
CategoryTree |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ConfigDataSet |
ContentManager |
Cost | Cost the Product Cost that may be used for pricing
CrossSells |
CustomerProductSets |
Customers |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Dealers |
Description |
DocumentManager |
Documents |
ERPDescription |
ERPManaged |
ERPNumber |
FilterValues |
HandlingAmountOverride |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
InventoryTransactions |
IsActive |
IsConfigured |
IsGiftCard |
IsOnSale | IsOnSale returns if this Product is on sale for a Quantity of 1
IsSubscription |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LargeImagePath |
MediumImagePath |
MetaDescription |
MetaKeywords |
ModelNumber |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PageTitle |
PriceCode |
ProductCode |
ProductId |
ProductProperties |
QtyOnHand |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RegularPrice | RegularPrice the Calculated Regular Full Price for a Quantity of 1 with no Configuration
Restrictions |
Reviews |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShippingAmountOverride |
ShippingClassification |
ShippingHeight |
ShippingLength |
ShippingWeight |
ShippingWidth |
ShortDescription |
Sku |
SmallImagePath |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
Specifications |
StyleChildren |
StyleClass |
StyleParent |
StyleSheet |
StyleTraitValues |
SubscriptionApril |
SubscriptionAugust |
SubscriptionCyclePeriod |
SubscriptionDecember |
SubscriptionFebruary |
SubscriptionFixedPrice |
SubscriptionIncludeInInitialOrder |
SubscriptionJanuary |
SubscriptionJuly |
SubscriptionJune |
SubscriptionMarch |
SubscriptionMay |
SubscriptionNovember |
SubscriptionOctober |
SubscriptionPeriodsPerCycle |
SubscriptionProducts |
SubscriptionSeptember |
SubscriptionShipVia |
SubscriptionTotalCycles |
TaxCategory |
TaxCode1 |
TaxCode2 |
TaxExemptions |
TrackInventory |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UnitOfMeasure |
UPCCode |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Vendor |
WishListProducts |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Product Class
InSite.Model Namespace


Accessories Property

[image]

.NET Framework Class Library
Product..::.Accessories Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Accessories As ChildList(Of ProductInfo)
C#
[DataMemberAttribute]
public virtual ChildList<ProductInfo> Accessories { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ProductInfo^>^ Accessories {
    ChildList<ProductInfo^>^ get ();
    void set (ChildList<ProductInfo^>^ value);
}
JavaScript
function get_accessories();
function set_accessories(value);

See Also

Product Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
Product..::.Active Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

Product Class
InSite.Model Namespace


ActiveAccessories Property

[image]

.NET Framework Class Library
Product..::.ActiveAccessories Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveAccessories As ChildList(Of ProductInfo)
C#
public virtual ChildList<ProductInfo> ActiveAccessories { get; }
Visual C++
public:
virtual property ChildList<ProductInfo^>^ ActiveAccessories {
    ChildList<ProductInfo^>^ get ();
}
JavaScript
function get_activeAccessories();

See Also

Product Class
InSite.Model Namespace


ActiveCrossSells Property

[image]

.NET Framework Class Library
Product..::.ActiveCrossSells Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveCrossSells As ChildList(Of ProductInfo)
C#
public virtual ChildList<ProductInfo> ActiveCrossSells { get; }
Visual C++
public:
virtual property ChildList<ProductInfo^>^ ActiveCrossSells {
    ChildList<ProductInfo^>^ get ();
}
JavaScript
function get_activeCrossSells();

See Also

Product Class
InSite.Model Namespace


ActualPrice Property

[image]

.NET Framework Class Library
Product..::.ActualPrice Property
Product Class See Also Send Feedback

ActualPrice the Calculated Price to Charge for a Quantity of 1 (includes Sales Price, Customer Pricing and Discounts)

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ActualPrice As Decimal
C#
public virtual decimal ActualPrice { get; private set; }
Visual C++
public:
virtual property Decimal ActualPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_actualPrice();
function set_actualPrice(value);

See Also

Product Class
InSite.Model Namespace


AllowAnyGiftCardAmount Property

[image]

.NET Framework Class Library
Product..::.AllowAnyGiftCardAmount Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AllowAnyGiftCardAmount As Boolean
C#
[DataMemberAttribute]
public virtual bool AllowAnyGiftCardAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool AllowAnyGiftCardAmount {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowAnyGiftCardAmount();
function set_allowAnyGiftCardAmount(value);

See Also

Product Class
InSite.Model Namespace


BasicListPrice Property

[image]

.NET Framework Class Library
Product..::.BasicListPrice Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BasicListPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal BasicListPrice { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BasicListPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_basicListPrice();
function set_basicListPrice(value);

See Also

Product Class
InSite.Model Namespace


BasicSaleEnd Property

[image]

.NET Framework Class Library
Product..::.BasicSaleEnd Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BasicSaleEnd As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> BasicSaleEnd { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> BasicSaleEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_basicSaleEnd();
function set_basicSaleEnd(value);

See Also

Product Class
InSite.Model Namespace


BasicSalePrice Property

[image]

.NET Framework Class Library
Product..::.BasicSalePrice Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BasicSalePrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal BasicSalePrice { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BasicSalePrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_basicSalePrice();
function set_basicSalePrice(value);

See Also

Product Class
InSite.Model Namespace


BasicSaleStart Property

[image]

.NET Framework Class Library
Product..::.BasicSaleStart Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BasicSaleStart As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> BasicSaleStart { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> BasicSaleStart {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_basicSaleStart();
function set_basicSaleStart(value);

See Also

Product Class
InSite.Model Namespace


Categories Property

[image]

.NET Framework Class Library
Product..::.Categories Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Categories As ChildList(Of Category)
C#
[DataMemberAttribute]
public virtual ChildList<Category> Categories { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Category^>^ Categories {
    ChildList<Category^>^ get ();
    void set (ChildList<Category^>^ value);
}
JavaScript
function get_categories();
function set_categories(value);

See Also

Product Class
InSite.Model Namespace


CategoryTree Property

[image]

.NET Framework Class Library
Product..::.CategoryTree Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CategoryTree As ChildList(Of Category)
C#
public virtual ChildList<Category> CategoryTree { get; }
Visual C++
public:
virtual property ChildList<Category^>^ CategoryTree {
    ChildList<Category^>^ get ();
}
JavaScript
function get_categoryTree();

See Also

Product Class
InSite.Model Namespace


ConfigDataSet Property

[image]

.NET Framework Class Library
Product..::.ConfigDataSet Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ConfigDataSet As DataSet
C#
public virtual DataSet ConfigDataSet { get; set; }
Visual C++
public:
virtual property DataSet^ ConfigDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}
JavaScript
function get_configDataSet();
function set_configDataSet(value);

See Also

Product Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
Product..::.ContentManager Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

Product Class
InSite.Model Namespace


Cost Property

[image]

.NET Framework Class Library
Product..::.Cost Property
Product Class See Also Send Feedback

Cost the Product Cost that may be used for pricing

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Cost As Decimal
C#
[DataMemberAttribute]
public virtual decimal Cost { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Cost {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_cost();
function set_cost(value);

See Also

Product Class
InSite.Model Namespace


CrossSells Property

[image]

.NET Framework Class Library
Product..::.CrossSells Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CrossSells As ChildList(Of ProductInfo)
C#
[DataMemberAttribute]
public virtual ChildList<ProductInfo> CrossSells { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ProductInfo^>^ CrossSells {
    ChildList<ProductInfo^>^ get ();
    void set (ChildList<ProductInfo^>^ value);
}
JavaScript
function get_crossSells();
function set_crossSells(value);

See Also

Product Class
InSite.Model Namespace


CustomerProductSets Property

[image]

.NET Framework Class Library
Product..::.CustomerProductSets Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CustomerProductSets As ChildList(Of CustomerProductSet)
C#
public virtual ChildList<CustomerProductSet> CustomerProductSets { get; }
Visual C++
public:
virtual property ChildList<CustomerProductSet^>^ CustomerProductSets {
    ChildList<CustomerProductSet^>^ get ();
}
JavaScript
function get_customerProductSets();

See Also

Product Class
InSite.Model Namespace


Customers Property

[image]

.NET Framework Class Library
Product..::.Customers Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customers As ChildList(Of Customer)
C#
public virtual ChildList<Customer> Customers { get; private set; }
Visual C++
public:
virtual property ChildList<Customer^>^ Customers {
    ChildList<Customer^>^ get ();
    void set (ChildList<Customer^>^ value);
}
JavaScript
function get_customers();
function set_customers(value);

See Also

Product Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
Product..::.Deactivate Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

Product Class
InSite.Model Namespace


Dealers Property

[image]

.NET Framework Class Library
Product..::.Dealers Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Dealers As ChildList(Of Dealer)
C#
public virtual ChildList<Dealer> Dealers { get; private set; }
Visual C++
public:
virtual property ChildList<Dealer^>^ Dealers {
    ChildList<Dealer^>^ get ();
    void set (ChildList<Dealer^>^ value);
}
JavaScript
function get_dealers();
function set_dealers(value);

See Also

Product Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Product..::.Description Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Description As String
C#
public virtual string Description { get; set; }
Visual C++
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Product Class
InSite.Model Namespace


DocumentManager Property

[image]

.NET Framework Class Library
Product..::.DocumentManager Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SaveChildren> _
Public Overridable Property DocumentManager As DocumentManager
C#
[DataMemberAttribute]
[SaveChildren]
public virtual DocumentManager DocumentManager { get; set; }
Visual C++
[DataMemberAttribute]
[SaveChildren]
public:
virtual property DocumentManager^ DocumentManager {
    DocumentManager^ get ();
    void set (DocumentManager^ value);
}
JavaScript
function get_documentManager();
function set_documentManager(value);

See Also

Product Class
InSite.Model Namespace


Documents Property

[image]

.NET Framework Class Library
Product..::.Documents Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Documents As ChildList(Of Document)
C#
public virtual ChildList<Document> Documents { get; set; }
Visual C++
public:
virtual property ChildList<Document^>^ Documents {
    ChildList<Document^>^ get ();
    void set (ChildList<Document^>^ value);
}
JavaScript
function get_documents();
function set_documents(value);

See Also

Product Class
InSite.Model Namespace


ERPDescription Property

[image]

.NET Framework Class Library
Product..::.ERPDescription Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPDescription As String
C#
[DataMemberAttribute]
public virtual string ERPDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpDescription();
function set_erpDescription(value);

See Also

Product Class
InSite.Model Namespace


ERPManaged Property

[image]

.NET Framework Class Library
Product..::.ERPManaged Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPManaged As Boolean
C#
[DataMemberAttribute]
public virtual bool ERPManaged { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ERPManaged {
    bool get ();
    void set (bool value);
}
JavaScript
function get_erpManaged();
function set_erpManaged(value);

See Also

Product Class
InSite.Model Namespace


ERPNumber Property

[image]

.NET Framework Class Library
Product..::.ERPNumber Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPNumber As String
C#
[DataMemberAttribute]
public virtual string ERPNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpNumber();
function set_erpNumber(value);

See Also

Product Class
InSite.Model Namespace


FilterValues Property

[image]

.NET Framework Class Library
Product..::.FilterValues Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FilterValues As ChildList(Of FilterValue)
C#
public virtual ChildList<FilterValue> FilterValues { get; private set; }
Visual C++
public:
virtual property ChildList<FilterValue^>^ FilterValues {
    ChildList<FilterValue^>^ get ();
    void set (ChildList<FilterValue^>^ value);
}
JavaScript
function get_filterValues();
function set_filterValues(value);

See Also

Product Class
InSite.Model Namespace


HandlingAmountOverride Property

[image]

.NET Framework Class Library
Product..::.HandlingAmountOverride Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HandlingAmountOverride As Nullable(Of Decimal)
C#
[DataMemberAttribute]
public virtual Nullable<decimal> HandlingAmountOverride { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<Decimal> HandlingAmountOverride {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}
JavaScript
function get_handlingAmountOverride();
function set_handlingAmountOverride(value);

See Also

Product Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
Product..::.HtmlContent Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HtmlContent As String
C#
[DataMemberAttribute]
public virtual string HtmlContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

Product Class
InSite.Model Namespace


InventoryTransactions Property

[image]

.NET Framework Class Library
Product..::.InventoryTransactions Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property InventoryTransactions As ChildList(Of InventoryTransaction)
C#
[DataMemberAttribute]
public virtual ChildList<InventoryTransaction> InventoryTransactions { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<InventoryTransaction^>^ InventoryTransactions {
    ChildList<InventoryTransaction^>^ get ();
    void set (ChildList<InventoryTransaction^>^ value);
}
JavaScript
function get_inventoryTransactions();
function set_inventoryTransactions(value);

See Also

Product Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
Product..::.IsActive Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

Product Class
InSite.Model Namespace


IsConfigured Property

[image]

.NET Framework Class Library
Product..::.IsConfigured Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property IsConfigured As Boolean
C#
public virtual bool IsConfigured { get; set; }
Visual C++
public:
virtual property bool IsConfigured {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isConfigured();
function set_isConfigured(value);

See Also

Product Class
InSite.Model Namespace


IsGiftCard Property

[image]

.NET Framework Class Library
Product..::.IsGiftCard Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsGiftCard As Boolean
C#
[DataMemberAttribute]
public virtual bool IsGiftCard { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsGiftCard {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isGiftCard();
function set_isGiftCard(value);

See Also

Product Class
InSite.Model Namespace


IsOnSale Property

[image]

.NET Framework Class Library
Product..::.IsOnSale Property
Product Class See Also Send Feedback

IsOnSale returns if this Product is on sale for a Quantity of 1

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property IsOnSale As Boolean
C#
public virtual bool IsOnSale { get; private set; }
Visual C++
public:
virtual property bool IsOnSale {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isOnSale();
function set_isOnSale(value);

See Also

Product Class
InSite.Model Namespace


IsSubscription Property

[image]

.NET Framework Class Library
Product..::.IsSubscription Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsSubscription As Boolean
C#
[DataMemberAttribute]
public virtual bool IsSubscription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsSubscription {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSubscription();
function set_isSubscription(value);

See Also

Product Class
InSite.Model Namespace


LargeImagePath Property

[image]

.NET Framework Class Library
Product..::.LargeImagePath Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LargeImagePath As String
C#
[DataMemberAttribute]
public virtual string LargeImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LargeImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_largeImagePath();
function set_largeImagePath(value);

See Also

Product Class
InSite.Model Namespace


MediumImagePath Property

[image]

.NET Framework Class Library
Product..::.MediumImagePath Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MediumImagePath As String
C#
[DataMemberAttribute]
public virtual string MediumImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MediumImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mediumImagePath();
function set_mediumImagePath(value);

See Also

Product Class
InSite.Model Namespace


MetaDescription Property

[image]

.NET Framework Class Library
Product..::.MetaDescription Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MetaDescription As String
C#
[DataMemberAttribute]
public virtual string MetaDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MetaDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_metaDescription();
function set_metaDescription(value);

See Also

Product Class
InSite.Model Namespace


MetaKeywords Property

[image]

.NET Framework Class Library
Product..::.MetaKeywords Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MetaKeywords As String
C#
[DataMemberAttribute]
public virtual string MetaKeywords { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MetaKeywords {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_metaKeywords();
function set_metaKeywords(value);

See Also

Product Class
InSite.Model Namespace


ModelNumber Property

[image]

.NET Framework Class Library
Product..::.ModelNumber Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ModelNumber As String
C#
[DataMemberAttribute]
public virtual string ModelNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ModelNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_modelNumber();
function set_modelNumber(value);

See Also

Product Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Product..::.Name Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Product Class
InSite.Model Namespace


PageTitle Property

[image]

.NET Framework Class Library
Product..::.PageTitle Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PageTitle As String
C#
[DataMemberAttribute]
public virtual string PageTitle { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PageTitle {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pageTitle();
function set_pageTitle(value);

See Also

Product Class
InSite.Model Namespace


PriceCode Property

[image]

.NET Framework Class Library
Product..::.PriceCode Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PriceCode As String
C#
[DataMemberAttribute]
public virtual string PriceCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PriceCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_priceCode();
function set_priceCode(value);

See Also

Product Class
InSite.Model Namespace


ProductCode Property

[image]

.NET Framework Class Library
Product..::.ProductCode Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProductCode As String
C#
[DataMemberAttribute]
public virtual string ProductCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProductCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productCode();
function set_productCode(value);

See Also

Product Class
InSite.Model Namespace


ProductId Property

[image]

.NET Framework Class Library
Product..::.ProductId Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductId As Guid
C#
public virtual Guid ProductId { get; set; }
Visual C++
public:
virtual property Guid ProductId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_productId();
function set_productId(value);

See Also

Product Class
InSite.Model Namespace


ProductProperties Property

[image]

.NET Framework Class Library
Product..::.ProductProperties Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProductProperties As ChildList(Of ProductProperty)
C#
[DataMemberAttribute]
public virtual ChildList<ProductProperty> ProductProperties { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ProductProperty^>^ ProductProperties {
    ChildList<ProductProperty^>^ get ();
    void set (ChildList<ProductProperty^>^ value);
}
JavaScript
function get_productProperties();
function set_productProperties(value);

See Also

Product Class
InSite.Model Namespace


QtyOnHand Property

[image]

.NET Framework Class Library
Product..::.QtyOnHand Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property QtyOnHand As Decimal
C#
[DataMemberAttribute]
public virtual decimal QtyOnHand { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal QtyOnHand {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_qtyOnHand();
function set_qtyOnHand(value);

See Also

Product Class
InSite.Model Namespace


RegularPrice Property

[image]

.NET Framework Class Library
Product..::.RegularPrice Property
Product Class See Also Send Feedback

RegularPrice the Calculated Regular Full Price for a Quantity of 1 with no Configuration

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property RegularPrice As Decimal
C#
public virtual decimal RegularPrice { get; private set; }
Visual C++
public:
virtual property Decimal RegularPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_regularPrice();
function set_regularPrice(value);

See Also

Product Class
InSite.Model Namespace


Restrictions Property

[image]

.NET Framework Class Library
Product..::.Restrictions Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Restrictions As ChildList(Of Restriction)
C#
[DataMemberAttribute]
public virtual ChildList<Restriction> Restrictions { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Restriction^>^ Restrictions {
    ChildList<Restriction^>^ get ();
    void set (ChildList<Restriction^>^ value);
}
JavaScript
function get_restrictions();
function set_restrictions(value);

See Also

Product Class
InSite.Model Namespace


Reviews Property

[image]

.NET Framework Class Library
Product..::.Reviews Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Reviews As ChildList(Of Review)
C#
public virtual ChildList<Review> Reviews { get; private set; }
Visual C++
public:
virtual property ChildList<Review^>^ Reviews {
    ChildList<Review^>^ get ();
    void set (ChildList<Review^>^ value);
}
JavaScript
function get_reviews();
function set_reviews(value);

See Also

Product Class
InSite.Model Namespace


ShippingAmountOverride Property

[image]

.NET Framework Class Library
Product..::.ShippingAmountOverride Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShippingAmountOverride As Nullable(Of Decimal)
C#
[DataMemberAttribute]
public virtual Nullable<decimal> ShippingAmountOverride { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<Decimal> ShippingAmountOverride {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}
JavaScript
function get_shippingAmountOverride();
function set_shippingAmountOverride(value);

See Also

Product Class
InSite.Model Namespace


ShippingClassification Property

[image]

.NET Framework Class Library
Product..::.ShippingClassification Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShippingClassification As String
C#
[DataMemberAttribute]
public virtual string ShippingClassification { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShippingClassification {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shippingClassification();
function set_shippingClassification(value);

See Also

Product Class
InSite.Model Namespace


ShippingHeight Property

[image]

.NET Framework Class Library
Product..::.ShippingHeight Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShippingHeight As Decimal
C#
[DataMemberAttribute]
public virtual decimal ShippingHeight { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ShippingHeight {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_shippingHeight();
function set_shippingHeight(value);

See Also

Product Class
InSite.Model Namespace


ShippingLength Property

[image]

.NET Framework Class Library
Product..::.ShippingLength Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShippingLength As Decimal
C#
[DataMemberAttribute]
public virtual decimal ShippingLength { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ShippingLength {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_shippingLength();
function set_shippingLength(value);

See Also

Product Class
InSite.Model Namespace


ShippingWeight Property

[image]

.NET Framework Class Library
Product..::.ShippingWeight Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShippingWeight As Decimal
C#
[DataMemberAttribute]
public virtual decimal ShippingWeight { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ShippingWeight {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_shippingWeight();
function set_shippingWeight(value);

See Also

Product Class
InSite.Model Namespace


ShippingWidth Property

[image]

.NET Framework Class Library
Product..::.ShippingWidth Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShippingWidth As Decimal
C#
[DataMemberAttribute]
public virtual decimal ShippingWidth { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ShippingWidth {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_shippingWidth();
function set_shippingWidth(value);

See Also

Product Class
InSite.Model Namespace


ShortDescription Property

[image]

.NET Framework Class Library
Product..::.ShortDescription Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShortDescription As String
C#
[DataMemberAttribute]
public virtual string ShortDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShortDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shortDescription();
function set_shortDescription(value);

See Also

Product Class
InSite.Model Namespace


Sku Property

[image]

.NET Framework Class Library
Product..::.Sku Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Sku As String
C#
[DataMemberAttribute]
public virtual string Sku { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Sku {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_sku();
function set_sku(value);

See Also

Product Class
InSite.Model Namespace


SmallImagePath Property

[image]

.NET Framework Class Library
Product..::.SmallImagePath Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SmallImagePath As String
C#
[DataMemberAttribute]
public virtual string SmallImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SmallImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_smallImagePath();
function set_smallImagePath(value);

See Also

Product Class
InSite.Model Namespace


SortOrder Property

[image]

.NET Framework Class Library
Product..::.SortOrder Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SortOrder As Integer
C#
[DataMemberAttribute]
public virtual int SortOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int SortOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_sortOrder();
function set_sortOrder(value);

See Also

Product Class
InSite.Model Namespace


Specifications Property

[image]

.NET Framework Class Library
Product..::.Specifications Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Specifications As ChildList(Of Specification)
C#
[DataMemberAttribute]
public virtual ChildList<Specification> Specifications { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Specification^>^ Specifications {
    ChildList<Specification^>^ get ();
    void set (ChildList<Specification^>^ value);
}
JavaScript
function get_specifications();
function set_specifications(value);

See Also

Product Class
InSite.Model Namespace


StyleChildren Property

[image]

.NET Framework Class Library
Product..::.StyleChildren Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleChildren As ChildList(Of Product)
C#
public virtual ChildList<Product> StyleChildren { get; private set; }
Visual C++
public:
virtual property ChildList<Product^>^ StyleChildren {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_styleChildren();
function set_styleChildren(value);

See Also

Product Class
InSite.Model Namespace


StyleClass Property

[image]

.NET Framework Class Library
Product..::.StyleClass Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleClass As StyleClass
C#
public virtual StyleClass StyleClass { get; set; }
Visual C++
public:
virtual property StyleClass^ StyleClass {
    StyleClass^ get ();
    void set (StyleClass^ value);
}
JavaScript
function get_styleClass();
function set_styleClass(value);

See Also

Product Class
InSite.Model Namespace


StyleParent Property

[image]

.NET Framework Class Library
Product..::.StyleParent Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleParent As Product
C#
public virtual Product StyleParent { get; set; }
Visual C++
public:
virtual property Product^ StyleParent {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_styleParent();
function set_styleParent(value);

See Also

Product Class
InSite.Model Namespace


StyleSheet Property

[image]

.NET Framework Class Library
Product..::.StyleSheet Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property StyleSheet As String
C#
[DataMemberAttribute]
public virtual string StyleSheet { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ StyleSheet {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_styleSheet();
function set_styleSheet(value);

See Also

Product Class
InSite.Model Namespace


StyleTraitValues Property

[image]

.NET Framework Class Library
Product..::.StyleTraitValues Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleTraitValues As ChildList(Of StyleTraitValue)
C#
public virtual ChildList<StyleTraitValue> StyleTraitValues { get; private set; }
Visual C++
public:
virtual property ChildList<StyleTraitValue^>^ StyleTraitValues {
    ChildList<StyleTraitValue^>^ get ();
    void set (ChildList<StyleTraitValue^>^ value);
}
JavaScript
function get_styleTraitValues();
function set_styleTraitValues(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionApril Property

[image]

.NET Framework Class Library
Product..::.SubscriptionApril Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionApril As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionApril { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionApril {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionApril();
function set_subscriptionApril(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionAugust Property

[image]

.NET Framework Class Library
Product..::.SubscriptionAugust Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionAugust As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionAugust { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionAugust {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionAugust();
function set_subscriptionAugust(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionCyclePeriod Property

[image]

.NET Framework Class Library
Product..::.SubscriptionCyclePeriod Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionCyclePeriod As String
C#
[DataMemberAttribute]
public virtual string SubscriptionCyclePeriod { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SubscriptionCyclePeriod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_subscriptionCyclePeriod();
function set_subscriptionCyclePeriod(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionDecember Property

[image]

.NET Framework Class Library
Product..::.SubscriptionDecember Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionDecember As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionDecember { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionDecember {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionDecember();
function set_subscriptionDecember(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionFebruary Property

[image]

.NET Framework Class Library
Product..::.SubscriptionFebruary Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionFebruary As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionFebruary { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionFebruary {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionFebruary();
function set_subscriptionFebruary(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionFixedPrice Property

[image]

.NET Framework Class Library
Product..::.SubscriptionFixedPrice Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionFixedPrice As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionFixedPrice { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionFixedPrice {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionFixedPrice();
function set_subscriptionFixedPrice(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionIncludeInInitialOrder Property

[image]

.NET Framework Class Library
Product..::.SubscriptionIncludeInInitialOrder Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionIncludeInInitialOrder As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionIncludeInInitialOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionIncludeInInitialOrder {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionIncludeInInitialOrder();
function set_subscriptionIncludeInInitialOrder(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionJanuary Property

[image]

.NET Framework Class Library
Product..::.SubscriptionJanuary Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionJanuary As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionJanuary { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionJanuary {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionJanuary();
function set_subscriptionJanuary(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionJuly Property

[image]

.NET Framework Class Library
Product..::.SubscriptionJuly Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionJuly As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionJuly { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionJuly {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionJuly();
function set_subscriptionJuly(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionJune Property

[image]

.NET Framework Class Library
Product..::.SubscriptionJune Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionJune As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionJune { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionJune {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionJune();
function set_subscriptionJune(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionMarch Property

[image]

.NET Framework Class Library
Product..::.SubscriptionMarch Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionMarch As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionMarch { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionMarch {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionMarch();
function set_subscriptionMarch(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionMay Property

[image]

.NET Framework Class Library
Product..::.SubscriptionMay Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionMay As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionMay { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionMay {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionMay();
function set_subscriptionMay(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionNovember Property

[image]

.NET Framework Class Library
Product..::.SubscriptionNovember Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionNovember As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionNovember { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionNovember {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionNovember();
function set_subscriptionNovember(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionOctober Property

[image]

.NET Framework Class Library
Product..::.SubscriptionOctober Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionOctober As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionOctober { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionOctober {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionOctober();
function set_subscriptionOctober(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionPeriodsPerCycle Property

[image]

.NET Framework Class Library
Product..::.SubscriptionPeriodsPerCycle Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionPeriodsPerCycle As Integer
C#
[DataMemberAttribute]
public virtual int SubscriptionPeriodsPerCycle { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int SubscriptionPeriodsPerCycle {
    int get ();
    void set (int value);
}
JavaScript
function get_subscriptionPeriodsPerCycle();
function set_subscriptionPeriodsPerCycle(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionProducts Property

[image]

.NET Framework Class Library
Product..::.SubscriptionProducts Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionProducts As ChildList(Of SubscriptionProduct)
C#
[DataMemberAttribute]
public virtual ChildList<SubscriptionProduct> SubscriptionProducts { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<SubscriptionProduct^>^ SubscriptionProducts {
    ChildList<SubscriptionProduct^>^ get ();
    void set (ChildList<SubscriptionProduct^>^ value);
}
JavaScript
function get_subscriptionProducts();
function set_subscriptionProducts(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionSeptember Property

[image]

.NET Framework Class Library
Product..::.SubscriptionSeptember Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionSeptember As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionSeptember { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionSeptember {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionSeptember();
function set_subscriptionSeptember(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionShipVia Property

[image]

.NET Framework Class Library
Product..::.SubscriptionShipVia Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionShipVia As ShipVia
C#
[DataMemberAttribute]
public virtual ShipVia SubscriptionShipVia { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ShipVia^ SubscriptionShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_subscriptionShipVia();
function set_subscriptionShipVia(value);

See Also

Product Class
InSite.Model Namespace


SubscriptionTotalCycles Property

[image]

.NET Framework Class Library
Product..::.SubscriptionTotalCycles Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionTotalCycles As Integer
C#
[DataMemberAttribute]
public virtual int SubscriptionTotalCycles { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int SubscriptionTotalCycles {
    int get ();
    void set (int value);
}
JavaScript
function get_subscriptionTotalCycles();
function set_subscriptionTotalCycles(value);

See Also

Product Class
InSite.Model Namespace


TaxCategory Property

[image]

.NET Framework Class Library
Product..::.TaxCategory Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCategory As String
C#
[DataMemberAttribute]
public virtual string TaxCategory { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCategory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCategory();
function set_taxCategory(value);

See Also

Product Class
InSite.Model Namespace


TaxCode1 Property

[image]

.NET Framework Class Library
Product..::.TaxCode1 Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode1 As String
C#
[DataMemberAttribute]
public virtual string TaxCode1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode1();
function set_taxCode1(value);

See Also

Product Class
InSite.Model Namespace


TaxCode2 Property

[image]

.NET Framework Class Library
Product..::.TaxCode2 Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode2 As String
C#
[DataMemberAttribute]
public virtual string TaxCode2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode2();
function set_taxCode2(value);

See Also

Product Class
InSite.Model Namespace


TaxExemptions Property

[image]

.NET Framework Class Library
Product..::.TaxExemptions Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxExemptions As ChildList(Of TaxExemption)
C#
public virtual ChildList<TaxExemption> TaxExemptions { get; private set; }
Visual C++
public:
virtual property ChildList<TaxExemption^>^ TaxExemptions {
    ChildList<TaxExemption^>^ get ();
    void set (ChildList<TaxExemption^>^ value);
}
JavaScript
function get_taxExemptions();
function set_taxExemptions(value);

See Also

Product Class
InSite.Model Namespace


TrackInventory Property

[image]

.NET Framework Class Library
Product..::.TrackInventory Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TrackInventory As Boolean
C#
[DataMemberAttribute]
public virtual bool TrackInventory { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool TrackInventory {
    bool get ();
    void set (bool value);
}
JavaScript
function get_trackInventory();
function set_trackInventory(value);

See Also

Product Class
InSite.Model Namespace


UnitOfMeasure Property

[image]

.NET Framework Class Library
Product..::.UnitOfMeasure Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UnitOfMeasure As String
C#
[DataMemberAttribute]
public virtual string UnitOfMeasure { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ UnitOfMeasure {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_unitOfMeasure();
function set_unitOfMeasure(value);

See Also

Product Class
InSite.Model Namespace


UPCCode Property

[image]

.NET Framework Class Library
Product..::.UPCCode Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UPCCode As String
C#
[DataMemberAttribute]
public virtual string UPCCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ UPCCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_upcCode();
function set_upcCode(value);

See Also

Product Class
InSite.Model Namespace


Vendor Property

[image]

.NET Framework Class Library
Product..::.Vendor Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Vendor As Vendor
C#
[DataMemberAttribute]
public virtual Vendor Vendor { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Vendor^ Vendor {
    Vendor^ get ();
    void set (Vendor^ value);
}
JavaScript
function get_vendor();
function set_vendor(value);

See Also

Product Class
InSite.Model Namespace


WishListProducts Property

[image]

.NET Framework Class Library
Product..::.WishListProducts Property
Product Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WishListProducts As ChildList(Of WishListProduct)
C#
public virtual ChildList<WishListProduct> WishListProducts { get; private set; }
Visual C++
public:
virtual property ChildList<WishListProduct^>^ WishListProducts {
    ChildList<WishListProduct^>^ get ();
    void set (ChildList<WishListProduct^>^ value);
}
JavaScript
function get_wishListProducts();
function set_wishListProducts(value);

See Also

Product Class
InSite.Model Namespace


ProductInfo Class

[image]

.NET Framework Class Library
ProductInfo Class
Members See Also Send Feedback

A Simplified view of the Product Object

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ProductInfo _
    Inherits ModelBase(Of ProductInfo)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ProductInfo : ModelBase<ProductInfo>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ProductInfo : public ModelBase<ProductInfo^>
JavaScript
InSite.Model.ProductInfo = function();

Type.createClass(
    'InSite.Model.ProductInfo',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ProductInfo>)>)
InSite.Model..::.ProductInfo

See Also

ProductInfo Members
InSite.Model Namespace


ProductInfo Members

[image] [image]

.NET Framework Class Library
ProductInfo Members
ProductInfo Class Constructors Methods Fields Properties See Also Send Feedback

The ProductInfo type exposes the following members.

Constructors

Name | Description
ProductInfo | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
BasicListPrice |
BasicSaleEnd |
BasicSalePrice |
BasicSaleStart |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
ERPDescription |
ERPNumber |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LargeImagePath |
MediumImagePath |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
ProductId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortDescription |
SmallImagePath |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ProductInfo Class
InSite.Model Namespace


ProductInfo Constructor

[image] [image]

.NET Framework Class Library
ProductInfo Constructor
ProductInfo Class See Also Send Feedback

Overload List

Name | Description
ProductInfo()()() |
ProductInfo(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ProductInfo Class
ProductInfo Members
InSite.Model Namespace


ProductInfo Constructor

[image]

.NET Framework Class Library
ProductInfo Constructor
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProductInfo()
Visual C++
public:
ProductInfo()
JavaScript
InSite.Model.ProductInfo = function();

See Also

ProductInfo Class
ProductInfo Overload
InSite.Model Namespace


ProductInfo Constructor (SearchMode)

[image]

.NET Framework Class Library
ProductInfo Constructor (SearchMode)
ProductInfo Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ProductInfo(
    SearchMode searchMode
)
Visual C++
public:
ProductInfo(
    SearchMode searchMode
)
JavaScript
InSite.Model.ProductInfo = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ProductInfo Class
ProductInfo Overload
InSite.Model Namespace


ProductInfo Fields

[image] [image]

.NET Framework Class Library
ProductInfo Fields
ProductInfo Class See Also Send Feedback

The ProductInfo type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ProductInfo Class
InSite.Model Namespace


ProductInfo Methods

[image] [image]

.NET Framework Class Library
ProductInfo Methods
ProductInfo Class See Also Send Feedback

The ProductInfo type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ProductInfo Class
InSite.Model Namespace


ProductInfo Properties

[image] [image]

.NET Framework Class Library
ProductInfo Properties
ProductInfo Class See Also Send Feedback

The ProductInfo type exposes the following members.

Properties

Name | Description
Active |
BasicListPrice |
BasicSaleEnd |
BasicSalePrice |
BasicSaleStart |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
ERPDescription |
ERPNumber |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LargeImagePath |
MediumImagePath |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
ProductId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortDescription |
SmallImagePath |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ProductInfo Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
ProductInfo..::.Active Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

ProductInfo Class
InSite.Model Namespace


BasicListPrice Property

[image]

.NET Framework Class Library
ProductInfo..::.BasicListPrice Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BasicListPrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal BasicListPrice { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BasicListPrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_basicListPrice();
function set_basicListPrice(value);

See Also

ProductInfo Class
InSite.Model Namespace


BasicSaleEnd Property

[image]

.NET Framework Class Library
ProductInfo..::.BasicSaleEnd Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BasicSaleEnd As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> BasicSaleEnd { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> BasicSaleEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_basicSaleEnd();
function set_basicSaleEnd(value);

See Also

ProductInfo Class
InSite.Model Namespace


BasicSalePrice Property

[image]

.NET Framework Class Library
ProductInfo..::.BasicSalePrice Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BasicSalePrice As Decimal
C#
[DataMemberAttribute]
public virtual decimal BasicSalePrice { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal BasicSalePrice {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_basicSalePrice();
function set_basicSalePrice(value);

See Also

ProductInfo Class
InSite.Model Namespace


BasicSaleStart Property

[image]

.NET Framework Class Library
ProductInfo..::.BasicSaleStart Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BasicSaleStart As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> BasicSaleStart { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> BasicSaleStart {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_basicSaleStart();
function set_basicSaleStart(value);

See Also

ProductInfo Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
ProductInfo..::.Deactivate Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

ProductInfo Class
InSite.Model Namespace


ERPDescription Property

[image]

.NET Framework Class Library
ProductInfo..::.ERPDescription Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPDescription As String
C#
[DataMemberAttribute]
public virtual string ERPDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpDescription();
function set_erpDescription(value);

See Also

ProductInfo Class
InSite.Model Namespace


ERPNumber Property

[image]

.NET Framework Class Library
ProductInfo..::.ERPNumber Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPNumber As String
C#
[DataMemberAttribute]
public virtual string ERPNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpNumber();
function set_erpNumber(value);

See Also

ProductInfo Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
ProductInfo..::.IsActive Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

ProductInfo Class
InSite.Model Namespace


LargeImagePath Property

[image]

.NET Framework Class Library
ProductInfo..::.LargeImagePath Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LargeImagePath As String
C#
[DataMemberAttribute]
public virtual string LargeImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LargeImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_largeImagePath();
function set_largeImagePath(value);

See Also

ProductInfo Class
InSite.Model Namespace


MediumImagePath Property

[image]

.NET Framework Class Library
ProductInfo..::.MediumImagePath Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MediumImagePath As String
C#
[DataMemberAttribute]
public virtual string MediumImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MediumImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_mediumImagePath();
function set_mediumImagePath(value);

See Also

ProductInfo Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
ProductInfo..::.Name Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

ProductInfo Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
ProductInfo..::.Product Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Product As Product
C#
public virtual Product Product { get; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
}
JavaScript
function get_product();

See Also

ProductInfo Class
InSite.Model Namespace


ProductId Property

[image]

.NET Framework Class Library
ProductInfo..::.ProductId Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductId As Guid
C#
public virtual Guid ProductId { get; set; }
Visual C++
public:
virtual property Guid ProductId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_productId();
function set_productId(value);

See Also

ProductInfo Class
InSite.Model Namespace


ShortDescription Property

[image]

.NET Framework Class Library
ProductInfo..::.ShortDescription Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShortDescription As String
C#
[DataMemberAttribute]
public virtual string ShortDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShortDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shortDescription();
function set_shortDescription(value);

See Also

ProductInfo Class
InSite.Model Namespace


SmallImagePath Property

[image]

.NET Framework Class Library
ProductInfo..::.SmallImagePath Property
ProductInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SmallImagePath As String
C#
[DataMemberAttribute]
public virtual string SmallImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SmallImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_smallImagePath();
function set_smallImagePath(value);

See Also

ProductInfo Class
InSite.Model Namespace


ProductProperty Class

[image]

.NET Framework Class Library
ProductProperty Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ProductProperty _
    Inherits ModelBase(Of ProductProperty)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ProductProperty : ModelBase<ProductProperty>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ProductProperty : public ModelBase<ProductProperty^>
JavaScript
InSite.Model.ProductProperty = function();

Type.createClass(
    'InSite.Model.ProductProperty',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ProductProperty>)>)
InSite.Model..::.ProductProperty

See Also

ProductProperty Members
InSite.Model Namespace


ProductProperty Members

[image] [image]

.NET Framework Class Library
ProductProperty Members
ProductProperty Class Constructors Methods Fields Properties See Also Send Feedback

The ProductProperty type exposes the following members.

Constructors

Name | Description
ProductProperty | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
ProductPropertyId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ProductProperty Class
InSite.Model Namespace


ProductProperty Constructor

[image] [image]

.NET Framework Class Library
ProductProperty Constructor
ProductProperty Class See Also Send Feedback

Overload List

Name | Description
ProductProperty()()() |
ProductProperty(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ProductProperty Class
ProductProperty Members
InSite.Model Namespace


ProductProperty Constructor

[image]

.NET Framework Class Library
ProductProperty Constructor
ProductProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ProductProperty()
Visual C++
public:
ProductProperty()
JavaScript
InSite.Model.ProductProperty = function();

See Also

ProductProperty Class
ProductProperty Overload
InSite.Model Namespace


ProductProperty Constructor (SearchMode)

[image]

.NET Framework Class Library
ProductProperty Constructor (SearchMode)
ProductProperty Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ProductProperty(
    SearchMode searchMode
)
Visual C++
public:
ProductProperty(
    SearchMode searchMode
)
JavaScript
InSite.Model.ProductProperty = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ProductProperty Class
ProductProperty Overload
InSite.Model Namespace


ProductProperty Fields

[image] [image]

.NET Framework Class Library
ProductProperty Fields
ProductProperty Class See Also Send Feedback

The ProductProperty type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ProductProperty Class
InSite.Model Namespace


ProductProperty Methods

[image] [image]

.NET Framework Class Library
ProductProperty Methods
ProductProperty Class See Also Send Feedback

The ProductProperty type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ProductProperty Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
ProductProperty..::.Copy Method
ProductProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As ProductProperty
C#
public virtual ProductProperty Copy()
Visual C++
public:
virtual ProductProperty^ Copy()
JavaScript
function copy();

See Also

ProductProperty Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
ProductProperty..::.ToString Method
ProductProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

ProductProperty Class
InSite.Model Namespace


ProductProperty Properties

[image] [image]

.NET Framework Class Library
ProductProperty Properties
ProductProperty Class See Also Send Feedback

The ProductProperty type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
ProductPropertyId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ProductProperty Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
ProductProperty..::.Name Property
ProductProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

ProductProperty Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
ProductProperty..::.Product Property
ProductProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

ProductProperty Class
InSite.Model Namespace


ProductPropertyId Property

[image]

.NET Framework Class Library
ProductProperty..::.ProductPropertyId Property
ProductProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProductPropertyId As Guid
C#
public virtual Guid ProductPropertyId { get; set; }
Visual C++
public:
virtual property Guid ProductPropertyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_productPropertyId();
function set_productPropertyId(value);

See Also

ProductProperty Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
ProductProperty..::.Value Property
ProductProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

ProductProperty Class
InSite.Model Namespace


Promotion Class

[image]

.NET Framework Class Library
Promotion Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Promotion _
    Inherits ModelBase(Of Promotion)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Promotion : ModelBase<Promotion>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Promotion : public ModelBase<Promotion^>
JavaScript
InSite.Model.Promotion = function();

Type.createClass(
    'InSite.Model.Promotion',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Promotion>)>)
InSite.Model..::.Promotion

See Also

Promotion Members
InSite.Model Namespace


Promotion Members

[image] [image]

.NET Framework Class Library
Promotion Members
Promotion Class Constructors Methods Fields Properties See Also Send Feedback

The Promotion type exposes the following members.

Constructors

Name | Description
Promotion | Overloaded.

Methods

Name | Description
AddPromotionResult |
AddPromotionRule |
AddWebSite |
ApplyPromotion |
ClearPromotion |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder |
DollarOffShipping |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder |
PercentOffShipping |
ProductDiscounts |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemovePromotionResult |
RemovePromotionRule |
RemoveWebSite |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
AppliedPromoCodes |
CaseSensitive |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrderCount |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
DiscountAmount | Deprecate
DisplayMessage |
HasCustomerOrders |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsAutomatic | Deprecate
IsFreight | Deprecate
IsPercentage | Deprecate
IsPromotionCodePromotion |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PromoCode |
PromotionId |
PromotionResults |
PromotionRules |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Rank |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSites |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Promotion Class
InSite.Model Namespace


Promotion Constructor

[image] [image]

.NET Framework Class Library
Promotion Constructor
Promotion Class See Also Send Feedback

Overload List

Name | Description
Promotion()()() |
Promotion(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Promotion Class
Promotion Members
InSite.Model Namespace


Promotion Constructor

[image]

.NET Framework Class Library
Promotion Constructor
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Promotion()
Visual C++
public:
Promotion()
JavaScript
InSite.Model.Promotion = function();

See Also

Promotion Class
Promotion Overload
InSite.Model Namespace


Promotion Constructor (SearchMode)

[image]

.NET Framework Class Library
Promotion Constructor (SearchMode)
Promotion Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Promotion(
    SearchMode searchMode
)
Visual C++
public:
Promotion(
    SearchMode searchMode
)
JavaScript
InSite.Model.Promotion = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Promotion Class
Promotion Overload
InSite.Model Namespace


Promotion Fields

[image] [image]

.NET Framework Class Library
Promotion Fields
Promotion Class See Also Send Feedback

The Promotion type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Promotion Class
InSite.Model Namespace


Promotion Methods

[image] [image]

.NET Framework Class Library
Promotion Methods
Promotion Class See Also Send Feedback

The Promotion type exposes the following members.

Methods

Name | Description
AddPromotionResult |
AddPromotionRule |
AddWebSite |
ApplyPromotion |
ClearPromotion |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder |
DollarOffShipping |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder |
PercentOffShipping |
ProductDiscounts |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemovePromotionResult |
RemovePromotionRule |
RemoveWebSite |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Promotion Class
InSite.Model Namespace


AddPromotionResult Method

[image]

.NET Framework Class Library
Promotion..::.AddPromotionResult Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddPromotionResult ( _
    value As PromotionResult _
)
C#
public virtual void AddPromotionResult(
    PromotionResult value
)
Visual C++
public:
virtual void AddPromotionResult(
    PromotionResult^ value
)
JavaScript
function addPromotionResult(value);

Parameters

value
Type: InSite.Model..::.PromotionResult

See Also

Promotion Class
InSite.Model Namespace


AddPromotionRule Method

[image]

.NET Framework Class Library
Promotion..::.AddPromotionRule Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddPromotionRule ( _
    value As PromotionRule _
)
C#
public virtual void AddPromotionRule(
    PromotionRule value
)
Visual C++
public:
virtual void AddPromotionRule(
    PromotionRule^ value
)
JavaScript
function addPromotionRule(value);

Parameters

value
Type: InSite.Model..::.PromotionRule

See Also

Promotion Class
InSite.Model Namespace


AddWebSite Method

[image]

.NET Framework Class Library
Promotion..::.AddWebSite Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWebSite ( _
    value As WebSite _
)
C#
public virtual void AddWebSite(
    WebSite value
)
Visual C++
public:
virtual void AddWebSite(
    WebSite^ value
)
JavaScript
function addWebSite(value);

Parameters

value
Type: InSite.Model..::.WebSite

See Also

Promotion Class
InSite.Model Namespace


ApplyPromotion Method

[image]

.NET Framework Class Library
Promotion..::.ApplyPromotion Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ApplyPromotion ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As CustomerOrder
C#
public virtual CustomerOrder ApplyPromotion(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotion(
    CustomerOrder^ customerOrder,
    Customer^ customer
)
JavaScript
function applyPromotion(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

See Also

Promotion Class
InSite.Model Namespace


ClearPromotion Method

[image]

.NET Framework Class Library
Promotion..::.ClearPromotion Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ClearPromotion ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public virtual CustomerOrder ClearPromotion(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotion(
    CustomerOrder^ customerOrder
)
JavaScript
function clearPromotion(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Promotion Class
InSite.Model Namespace


DollarOffOrder Method

[image]

.NET Framework Class Library
Promotion..::.DollarOffOrder Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DollarOffOrder ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal DollarOffOrder(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal DollarOffOrder(
    CustomerOrder^ customerOrder
)
JavaScript
function dollarOffOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Promotion Class
InSite.Model Namespace


DollarOffShipping Method

[image]

.NET Framework Class Library
Promotion..::.DollarOffShipping Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DollarOffShipping ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal DollarOffShipping(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal DollarOffShipping(
    CustomerOrder^ customerOrder
)
JavaScript
function dollarOffShipping(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Promotion Class
InSite.Model Namespace


IsValid Method

[image] [image]

.NET Framework Class Library
Promotion..::.IsValid Method
Promotion Class See Also Send Feedback

Overload List

Name | Description
IsValid()()() | Deprecate
IsValid(String) | Deprecate
IsValid(CustomerOrder, Customer) |

See Also

Promotion Class
Promotion Members
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
Promotion..::.IsValid Method
Promotion Class See Also Send Feedback

Deprecate

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid As Boolean
C#
public virtual bool IsValid()
Visual C++
public:
virtual bool IsValid()
JavaScript
function isValid();

Return Value

See Also

Promotion Class
IsValid Overload
InSite.Model Namespace


IsValid Method (String)

[image]

.NET Framework Class Library
Promotion..::.IsValid Method (String)
Promotion Class See Also Send Feedback

Deprecate

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    promoCode As String _
) As Boolean
C#
public virtual bool IsValid(
    string promoCode
)
Visual C++
public:
virtual bool IsValid(
    String^ promoCode
)
JavaScript
function isValid(promoCode);

Parameters

promoCode
Type: System..::.String

Return Value

See Also

Promotion Class
IsValid Overload
InSite.Model Namespace


IsValid Method (CustomerOrder, Customer)

[image]

.NET Framework Class Library
Promotion..::.IsValid Method (CustomerOrder, Customer)
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public virtual bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
)
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

See Also

Promotion Class
IsValid Overload
InSite.Model Namespace


PercentOffOrder Method

[image]

.NET Framework Class Library
Promotion..::.PercentOffOrder Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function PercentOffOrder ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal PercentOffOrder(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal PercentOffOrder(
    CustomerOrder^ customerOrder
)
JavaScript
function percentOffOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Promotion Class
InSite.Model Namespace


PercentOffShipping Method

[image]

.NET Framework Class Library
Promotion..::.PercentOffShipping Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function PercentOffShipping ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal PercentOffShipping(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal PercentOffShipping(
    CustomerOrder^ customerOrder
)
JavaScript
function percentOffShipping(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Promotion Class
InSite.Model Namespace


ProductDiscounts Method

[image]

.NET Framework Class Library
Promotion..::.ProductDiscounts Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ProductDiscounts ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal ProductDiscounts(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscounts(
    CustomerOrder^ customerOrder
)
JavaScript
function productDiscounts(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Promotion Class
InSite.Model Namespace


RemovePromotionResult Method

[image]

.NET Framework Class Library
Promotion..::.RemovePromotionResult Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemovePromotionResult ( _
    value As PromotionResult _
)
C#
public virtual void RemovePromotionResult(
    PromotionResult value
)
Visual C++
public:
virtual void RemovePromotionResult(
    PromotionResult^ value
)
JavaScript
function removePromotionResult(value);

Parameters

value
Type: InSite.Model..::.PromotionResult

See Also

Promotion Class
InSite.Model Namespace


RemovePromotionRule Method

[image]

.NET Framework Class Library
Promotion..::.RemovePromotionRule Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemovePromotionRule ( _
    value As PromotionRule _
)
C#
public virtual void RemovePromotionRule(
    PromotionRule value
)
Visual C++
public:
virtual void RemovePromotionRule(
    PromotionRule^ value
)
JavaScript
function removePromotionRule(value);

Parameters

value
Type: InSite.Model..::.PromotionRule

See Also

Promotion Class
InSite.Model Namespace


RemoveWebSite Method

[image]

.NET Framework Class Library
Promotion..::.RemoveWebSite Method
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWebSite ( _
    value As WebSite _
)
C#
public virtual void RemoveWebSite(
    WebSite value
)
Visual C++
public:
virtual void RemoveWebSite(
    WebSite^ value
)
JavaScript
function removeWebSite(value);

Parameters

value
Type: InSite.Model..::.WebSite

See Also

Promotion Class
InSite.Model Namespace


Promotion Properties

[image] [image]

.NET Framework Class Library
Promotion Properties
Promotion Class See Also Send Feedback

The Promotion type exposes the following members.

Properties

Name | Description
Active |
AppliedPromoCodes |
CaseSensitive |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrderCount |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
DiscountAmount | Deprecate
DisplayMessage |
HasCustomerOrders |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsAutomatic | Deprecate
IsFreight | Deprecate
IsPercentage | Deprecate
IsPromotionCodePromotion |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PromoCode |
PromotionId |
PromotionResults |
PromotionRules |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Rank |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSites |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Promotion Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
Promotion..::.Active Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

Promotion Class
InSite.Model Namespace


AppliedPromoCodes Property

[image]

.NET Framework Class Library
Promotion..::.AppliedPromoCodes Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AppliedPromoCodes As String
C#
public virtual string AppliedPromoCodes { get; }
Visual C++
public:
virtual property String^ AppliedPromoCodes {
    String^ get ();
}
JavaScript
function get_appliedPromoCodes();

See Also

Promotion Class
InSite.Model Namespace


CaseSensitive Property

[image]

.NET Framework Class Library
Promotion..::.CaseSensitive Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CaseSensitive As Boolean
C#
public virtual bool CaseSensitive { get; set; }
Visual C++
public:
virtual property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_caseSensitive();
function set_caseSensitive(value);

See Also

Promotion Class
InSite.Model Namespace


CustomerOrderCount Property

[image]

.NET Framework Class Library
Promotion..::.CustomerOrderCount Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerOrderCount As Integer
C#
[DataMemberAttribute]
public virtual int CustomerOrderCount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int CustomerOrderCount {
    int get ();
    void set (int value);
}
JavaScript
function get_customerOrderCount();
function set_customerOrderCount(value);

See Also

Promotion Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
Promotion..::.Deactivate Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

Promotion Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Promotion..::.Description Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Promotion Class
InSite.Model Namespace


DiscountAmount Property

[image]

.NET Framework Class Library
Promotion..::.DiscountAmount Property
Promotion Class See Also Send Feedback

Deprecate

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DiscountAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal DiscountAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal DiscountAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_discountAmount();
function set_discountAmount(value);

See Also

Promotion Class
InSite.Model Namespace


DisplayMessage Property

[image]

.NET Framework Class Library
Promotion..::.DisplayMessage Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DisplayMessage As String
C#
[DataMemberAttribute]
public virtual string DisplayMessage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DisplayMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_displayMessage();
function set_displayMessage(value);

See Also

Promotion Class
InSite.Model Namespace


HasCustomerOrders Property

[image]

.NET Framework Class Library
Promotion..::.HasCustomerOrders Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property HasCustomerOrders As Boolean
C#
public virtual bool HasCustomerOrders { get; }
Visual C++
public:
virtual property bool HasCustomerOrders {
    bool get ();
}
JavaScript
function get_hasCustomerOrders();

See Also

Promotion Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
Promotion..::.IsActive Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

Promotion Class
InSite.Model Namespace


IsAutomatic Property

[image]

.NET Framework Class Library
Promotion..::.IsAutomatic Property
Promotion Class See Also Send Feedback

Deprecate

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property IsAutomatic As Boolean
C#
public virtual bool IsAutomatic { get; set; }
Visual C++
public:
virtual property bool IsAutomatic {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isAutomatic();
function set_isAutomatic(value);

See Also

Promotion Class
InSite.Model Namespace


IsFreight Property

[image]

.NET Framework Class Library
Promotion..::.IsFreight Property
Promotion Class See Also Send Feedback

Deprecate

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property IsFreight As Boolean
C#
public virtual bool IsFreight { get; set; }
Visual C++
public:
virtual property bool IsFreight {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isFreight();
function set_isFreight(value);

See Also

Promotion Class
InSite.Model Namespace


IsPercentage Property

[image]

.NET Framework Class Library
Promotion..::.IsPercentage Property
Promotion Class See Also Send Feedback

Deprecate

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property IsPercentage As Boolean
C#
public virtual bool IsPercentage { get; set; }
Visual C++
public:
virtual property bool IsPercentage {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isPercentage();
function set_isPercentage(value);

See Also

Promotion Class
InSite.Model Namespace


IsPromotionCodePromotion Property

[image]

.NET Framework Class Library
Promotion..::.IsPromotionCodePromotion Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsPromotionCodePromotion As Boolean
C#
public virtual bool IsPromotionCodePromotion { get; }
Visual C++
public:
virtual property bool IsPromotionCodePromotion {
    bool get ();
}
JavaScript
function get_isPromotionCodePromotion();

See Also

Promotion Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Promotion..::.Name Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Promotion Class
InSite.Model Namespace


PromoCode Property

[image]

.NET Framework Class Library
Promotion..::.PromoCode Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PromoCode As String
C#
[DataMemberAttribute]
public virtual string PromoCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PromoCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_promoCode();
function set_promoCode(value);

See Also

Promotion Class
InSite.Model Namespace


PromotionId Property

[image]

.NET Framework Class Library
Promotion..::.PromotionId Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PromotionId As Guid
C#
public virtual Guid PromotionId { get; set; }
Visual C++
public:
virtual property Guid PromotionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_promotionId();
function set_promotionId(value);

See Also

Promotion Class
InSite.Model Namespace


PromotionResults Property

[image]

.NET Framework Class Library
Promotion..::.PromotionResults Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PromotionResults As ChildList(Of PromotionResult)
C#
[DataMemberAttribute]
public virtual ChildList<PromotionResult> PromotionResults { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<PromotionResult^>^ PromotionResults {
    ChildList<PromotionResult^>^ get ();
    void set (ChildList<PromotionResult^>^ value);
}
JavaScript
function get_promotionResults();
function set_promotionResults(value);

See Also

Promotion Class
InSite.Model Namespace


PromotionRules Property

[image]

.NET Framework Class Library
Promotion..::.PromotionRules Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PromotionRules As ChildList(Of PromotionRule)
C#
[DataMemberAttribute]
public virtual ChildList<PromotionRule> PromotionRules { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<PromotionRule^>^ PromotionRules {
    ChildList<PromotionRule^>^ get ();
    void set (ChildList<PromotionRule^>^ value);
}
JavaScript
function get_promotionRules();
function set_promotionRules(value);

See Also

Promotion Class
InSite.Model Namespace


Rank Property

[image]

.NET Framework Class Library
Promotion..::.Rank Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Rank As Decimal
C#
[DataMemberAttribute]
public virtual decimal Rank { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Rank {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_rank();
function set_rank(value);

See Also

Promotion Class
InSite.Model Namespace


WebSites Property

[image]

.NET Framework Class Library
Promotion..::.WebSites Property
Promotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSites As ChildList(Of WebSite)
C#
public virtual ChildList<WebSite> WebSites { get; private set; }
Visual C++
public:
virtual property ChildList<WebSite^>^ WebSites {
    ChildList<WebSite^>^ get ();
    void set (ChildList<WebSite^>^ value);
}
JavaScript
function get_webSites();
function set_webSites(value);

See Also

Promotion Class
InSite.Model Namespace


PromotionCode Class

[image]

.NET Framework Class Library
PromotionCode Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PromotionCode _
    Inherits ModelBase(Of PromotionCode)
C#
[SerializableAttribute]
public class PromotionCode : ModelBase<PromotionCode>
Visual C++
[SerializableAttribute]
public ref class PromotionCode : public ModelBase<PromotionCode^>
JavaScript
InSite.Model.PromotionCode = function();

Type.createClass(
    'InSite.Model.PromotionCode',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(PromotionCode>)>)
InSite.Model..::.PromotionCode

See Also

PromotionCode Members
InSite.Model Namespace


PromotionCode Members

[image] [image]

.NET Framework Class Library
PromotionCode Members
PromotionCode Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionCode type exposes the following members.

Constructors

Name | Description
PromotionCode | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Code |
CustomerOrder |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PromotionCodeId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionCode Class
InSite.Model Namespace


PromotionCode Constructor

[image] [image]

.NET Framework Class Library
PromotionCode Constructor
PromotionCode Class See Also Send Feedback

Overload List

Name | Description
PromotionCode()()() |
PromotionCode(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

PromotionCode Class
PromotionCode Members
InSite.Model Namespace


PromotionCode Constructor

[image]

.NET Framework Class Library
PromotionCode Constructor
PromotionCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionCode()
Visual C++
public:
PromotionCode()
JavaScript
InSite.Model.PromotionCode = function();

See Also

PromotionCode Class
PromotionCode Overload
InSite.Model Namespace


PromotionCode Constructor (SearchMode)

[image]

.NET Framework Class Library
PromotionCode Constructor (SearchMode)
PromotionCode Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public PromotionCode(
    SearchMode searchMode
)
Visual C++
public:
PromotionCode(
    SearchMode searchMode
)
JavaScript
InSite.Model.PromotionCode = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

PromotionCode Class
PromotionCode Overload
InSite.Model Namespace


PromotionCode Fields

[image] [image]

.NET Framework Class Library
PromotionCode Fields
PromotionCode Class See Also Send Feedback

The PromotionCode type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionCode Class
InSite.Model Namespace


PromotionCode Methods

[image] [image]

.NET Framework Class Library
PromotionCode Methods
PromotionCode Class See Also Send Feedback

The PromotionCode type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionCode Class
InSite.Model Namespace


PromotionCode Properties

[image] [image]

.NET Framework Class Library
PromotionCode Properties
PromotionCode Class See Also Send Feedback

The PromotionCode type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Code |
CustomerOrder |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PromotionCodeId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionCode Class
InSite.Model Namespace


Code Property

[image]

.NET Framework Class Library
PromotionCode..::.Code Property
PromotionCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Code As String
C#
public virtual string Code { get; set; }
Visual C++
public:
virtual property String^ Code {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_code();
function set_code(value);

See Also

PromotionCode Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
PromotionCode..::.CustomerOrder Property
PromotionCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

PromotionCode Class
InSite.Model Namespace


PromotionCodeId Property

[image]

.NET Framework Class Library
PromotionCode..::.PromotionCodeId Property
PromotionCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PromotionCodeId As Guid
C#
public virtual Guid PromotionCodeId { get; set; }
Visual C++
public:
virtual property Guid PromotionCodeId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_promotionCodeId();
function set_promotionCodeId(value);

See Also

PromotionCode Class
InSite.Model Namespace


PromotionProcessor Class

[image]

.NET Framework Class Library
PromotionProcessor Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PromotionProcessor
C#
[SerializableAttribute]
public class PromotionProcessor
Visual C++
[SerializableAttribute]
public ref class PromotionProcessor
JavaScript
InSite.Model.PromotionProcessor = function();

Type.createClass(
    'InSite.Model.PromotionProcessor');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.PromotionProcessor

See Also

PromotionProcessor Members
InSite.Model Namespace


PromotionProcessor Members

[image] [image]

.NET Framework Class Library
PromotionProcessor Members
PromotionProcessor Class Constructors Methods Properties See Also Send Feedback

The PromotionProcessor type exposes the following members.

Constructors

Name | Description
PromotionProcessor | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PassedPromotions |
ProcessedOrder |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowAutomaticPromotions |
AllowMultiplePromotions |
CustomerOrder |
PromotionCode |
Promotions |

See Also

PromotionProcessor Class
InSite.Model Namespace


PromotionProcessor Constructor

[image] [image]

.NET Framework Class Library
PromotionProcessor Constructor
PromotionProcessor Class See Also Send Feedback

Overload List

Name | Description
PromotionProcessor()()() |
PromotionProcessor(IList<(Of <(Promotion>)>)) |
PromotionProcessor(IList<(Of <(Promotion>)>), CustomerOrder) |

See Also

PromotionProcessor Class
PromotionProcessor Members
InSite.Model Namespace


PromotionProcessor Constructor

[image]

.NET Framework Class Library
PromotionProcessor Constructor
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionProcessor()
Visual C++
public:
PromotionProcessor()
JavaScript
InSite.Model.PromotionProcessor = function();

See Also

PromotionProcessor Class
PromotionProcessor Overload
InSite.Model Namespace


PromotionProcessor Constructor (IList(Promotion))

[image]

.NET Framework Class Library
PromotionProcessor Constructor (IList<(Of <(Promotion>)>))
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    promotions As IList(Of Promotion) _
)
C#
public PromotionProcessor(
    IList<Promotion> promotions
)
Visual C++
public:
PromotionProcessor(
    IList<Promotion^>^ promotions
)
JavaScript
InSite.Model.PromotionProcessor = function(promotions);

Parameters

promotions
Type: System.Collections.Generic..::.IList <(Of <( Promotion >)>)

See Also

PromotionProcessor Class
PromotionProcessor Overload
InSite.Model Namespace


PromotionProcessor Constructor (IList(Promotion), CustomerOrder)

[image]

.NET Framework Class Library
PromotionProcessor Constructor (IList<(Of <(Promotion>)>), CustomerOrder)
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    promotions As IList(Of Promotion), _
    customerOrder As CustomerOrder _
)
C#
public PromotionProcessor(
    IList<Promotion> promotions,
    CustomerOrder customerOrder
)
Visual C++
public:
PromotionProcessor(
    IList<Promotion^>^ promotions,
    CustomerOrder^ customerOrder
)
JavaScript
InSite.Model.PromotionProcessor = function(promotions, customerOrder);

Parameters

promotions
Type: System.Collections.Generic..::.IList <(Of <( Promotion >)>)
customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionProcessor Class
PromotionProcessor Overload
InSite.Model Namespace


PromotionProcessor Methods

[image] [image]

.NET Framework Class Library
PromotionProcessor Methods
PromotionProcessor Class See Also Send Feedback

The PromotionProcessor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PassedPromotions |
ProcessedOrder |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PromotionProcessor Class
InSite.Model Namespace


PassedPromotions Method

[image]

.NET Framework Class Library
PromotionProcessor..::.PassedPromotions Method
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function PassedPromotions As IList(Of Promotion)
C#
public IList<Promotion> PassedPromotions()
Visual C++
public:
IList<Promotion^>^ PassedPromotions()
JavaScript
function passedPromotions();

See Also

PromotionProcessor Class
InSite.Model Namespace


ProcessedOrder Method

[image]

.NET Framework Class Library
PromotionProcessor..::.ProcessedOrder Method
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function ProcessedOrder As CustomerOrder
C#
public CustomerOrder ProcessedOrder()
Visual C++
public:
CustomerOrder^ ProcessedOrder()
JavaScript
function processedOrder();

See Also

PromotionProcessor Class
InSite.Model Namespace


PromotionProcessor Properties

[image] [image]

.NET Framework Class Library
PromotionProcessor Properties
PromotionProcessor Class See Also Send Feedback

The PromotionProcessor type exposes the following members.

Properties

Name | Description
AllowAutomaticPromotions |
AllowMultiplePromotions |
CustomerOrder |
PromotionCode |
Promotions |

See Also

PromotionProcessor Class
InSite.Model Namespace


AllowAutomaticPromotions Property

[image]

.NET Framework Class Library
PromotionProcessor..::.AllowAutomaticPromotions Property
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowAutomaticPromotions As Boolean
C#
public bool AllowAutomaticPromotions { get; set; }
Visual C++
public:
property bool AllowAutomaticPromotions {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowAutomaticPromotions();
function set_allowAutomaticPromotions(value);

See Also

PromotionProcessor Class
InSite.Model Namespace


AllowMultiplePromotions Property

[image]

.NET Framework Class Library
PromotionProcessor..::.AllowMultiplePromotions Property
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowMultiplePromotions As Boolean
C#
public bool AllowMultiplePromotions { get; set; }
Visual C++
public:
property bool AllowMultiplePromotions {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowMultiplePromotions();
function set_allowMultiplePromotions(value);

See Also

PromotionProcessor Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
PromotionProcessor..::.CustomerOrder Property
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property CustomerOrder As CustomerOrder
C#
public CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

PromotionProcessor Class
InSite.Model Namespace


PromotionCode Property

[image]

.NET Framework Class Library
PromotionProcessor..::.PromotionCode Property
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property PromotionCode As String
C#
public string PromotionCode { get; set; }
Visual C++
public:
property String^ PromotionCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_promotionCode();
function set_promotionCode(value);

See Also

PromotionProcessor Class
InSite.Model Namespace


Promotions Property

[image]

.NET Framework Class Library
PromotionProcessor..::.Promotions Property
PromotionProcessor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property Promotions As IList(Of Promotion)
C#
public IList<Promotion> Promotions { get; set; }
Visual C++
public:
property IList<Promotion^>^ Promotions {
    IList<Promotion^>^ get ();
    void set (IList<Promotion^>^ value);
}
JavaScript
function get_promotions();
function set_promotions(value);

See Also

PromotionProcessor Class
InSite.Model Namespace


PromotionResult Class

[image]

.NET Framework Class Library
PromotionResult Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResult _
    Inherits ModelBase(Of PromotionResult)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResult : ModelBase<PromotionResult>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResult : public ModelBase<PromotionResult^>
JavaScript
InSite.Model.PromotionResult = function();

Type.createClass(
    'InSite.Model.PromotionResult',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(PromotionResult>)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultAddFreeProduct
InSite.Model..::.PromotionResultAddFreeProductFromCategory
InSite.Model..::.PromotionResultDiscountProductsInCategory
InSite.Model..::.PromotionResultDiscountProductsOfVendor
InSite.Model..::.PromotionResultDollarOffOrder
InSite.Model..::.PromotionResultDollarOffProduct
InSite.Model..::.PromotionResultDollarOffShipping
InSite.Model..::.PromotionResultPercentOffOrder
InSite.Model..::.PromotionResultPercentOffProduct
InSite.Model..::.PromotionResultPercentOffShipping
InSite.Model..::.PromotionResultSetOrderedProductToAmount
InSite.Model..::.PromotionResultSetOrderedProductToFree

See Also

PromotionResult Members
InSite.Model Namespace


PromotionResult Members

[image] [image]

.NET Framework Class Library
PromotionResult Members
PromotionResult Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResult type exposes the following members.

Constructors

Name | Description
PromotionResult |

Methods

Name | Description
ApplyPromotionResult |
ClearPromotionResult |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder |
DollarOffShipping |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder |
PercentOffShipping |
ProductDiscount |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult |
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion |
_promotionResultId |
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible |

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion |
PromotionResultId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResult Class
InSite.Model Namespace


PromotionResult Constructor

[image]

.NET Framework Class Library
PromotionResult Constructor
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResult()
Visual C++
public:
PromotionResult()
JavaScript
InSite.Model.PromotionResult = function();

See Also

PromotionResult Class
InSite.Model Namespace


PromotionResult Fields

[image] [image]

.NET Framework Class Library
PromotionResult Fields
PromotionResult Class See Also Send Feedback

The PromotionResult type exposes the following members.

Fields

Name | Description
_promotion |
_promotionResultId |
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible |

See Also

PromotionResult Class
InSite.Model Namespace


_promotion Field

[image]

.NET Framework Class Library
PromotionResult..::._promotion Field
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _promotion As Promotion
C#
protected Promotion _promotion
Visual C++
protected:
Promotion^ _promotion
JavaScript
_promotion

See Also

PromotionResult Class
InSite.Model Namespace


_promotionResultId Field

[image]

.NET Framework Class Library
PromotionResult..::._promotionResultId Field
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _promotionResultId As Guid
C#
protected Guid _promotionResultId
Visual C++
protected:
Guid _promotionResultId
JavaScript
_promotionResultId

See Also

PromotionResult Class
InSite.Model Namespace


_visible Field

[image]

.NET Framework Class Library
PromotionResult..::._visible Field
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _visible As Boolean
C#
protected bool _visible
Visual C++
protected:
bool _visible
JavaScript
_visible

See Also

PromotionResult Class
InSite.Model Namespace


PromotionResult Methods

[image] [image]

.NET Framework Class Library
PromotionResult Methods
PromotionResult Class See Also Send Feedback

The PromotionResult type exposes the following members.

Methods

Name | Description
ApplyPromotionResult |
ClearPromotionResult |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder |
DollarOffShipping |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder |
PercentOffShipping |
ProductDiscount |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult |
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResult Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResult..::.ApplyPromotionResult Method
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public virtual CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
)
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResult Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResult..::.ClearPromotionResult Method
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public virtual CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
)
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResult Class
InSite.Model Namespace


DollarOffOrder Method

[image]

.NET Framework Class Library
PromotionResult..::.DollarOffOrder Method
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DollarOffOrder ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal DollarOffOrder(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal DollarOffOrder(
    CustomerOrder^ customerOrder
)
JavaScript
function dollarOffOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResult Class
InSite.Model Namespace


DollarOffShipping Method

[image]

.NET Framework Class Library
PromotionResult..::.DollarOffShipping Method
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function DollarOffShipping ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal DollarOffShipping(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal DollarOffShipping(
    CustomerOrder^ customerOrder
)
JavaScript
function dollarOffShipping(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResult Class
InSite.Model Namespace


PercentOffOrder Method

[image]

.NET Framework Class Library
PromotionResult..::.PercentOffOrder Method
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function PercentOffOrder ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal PercentOffOrder(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal PercentOffOrder(
    CustomerOrder^ customerOrder
)
JavaScript
function percentOffOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResult Class
InSite.Model Namespace


PercentOffShipping Method

[image]

.NET Framework Class Library
PromotionResult..::.PercentOffShipping Method
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function PercentOffShipping ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal PercentOffShipping(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal PercentOffShipping(
    CustomerOrder^ customerOrder
)
JavaScript
function percentOffShipping(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResult Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResult..::.ProductDiscount Method
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public virtual decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
)
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResult Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResult..::.UnApplyPromotionResult Method
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public virtual CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
)
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResult Class
InSite.Model Namespace


PromotionResult Properties

[image] [image]

.NET Framework Class Library
PromotionResult Properties
PromotionResult Class See Also Send Feedback

The PromotionResult type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion |
PromotionResultId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResult Class
InSite.Model Namespace


Promotion Property

[image]

.NET Framework Class Library
PromotionResult..::.Promotion Property
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Promotion As Promotion
C#
public virtual Promotion Promotion { get; set; }
Visual C++
public:
virtual property Promotion^ Promotion {
    Promotion^ get ();
    void set (Promotion^ value);
}
JavaScript
function get_promotion();
function set_promotion(value);

See Also

PromotionResult Class
InSite.Model Namespace


PromotionResultId Property

[image]

.NET Framework Class Library
PromotionResult..::.PromotionResultId Property
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PromotionResultId As Guid
C#
public virtual Guid PromotionResultId { get; set; }
Visual C++
public:
virtual property Guid PromotionResultId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_promotionResultId();
function set_promotionResultId(value);

See Also

PromotionResult Class
InSite.Model Namespace


ResultName Property

[image]

.NET Framework Class Library
PromotionResult..::.ResultName Property
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property ResultName As String
C#
[SortField]
[DataMemberAttribute]
public virtual string ResultName { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ ResultName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_resultName();
function set_resultName(value);

See Also

PromotionResult Class
InSite.Model Namespace


Visible Property

[image]

.NET Framework Class Library
PromotionResult..::.Visible Property
PromotionResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Visible As Boolean
C#
[DataMemberAttribute]
public virtual bool Visible { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool Visible {
    bool get ();
    void set (bool value);
}
JavaScript
function get_visible();
function set_visible(value);

See Also

PromotionResult Class
InSite.Model Namespace


PromotionResultAddFreeProduct Class

[image]

.NET Framework Class Library
PromotionResultAddFreeProduct Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultAddFreeProduct _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultAddFreeProduct : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultAddFreeProduct : public PromotionResult
JavaScript
InSite.Model.PromotionResultAddFreeProduct = function();

Type.createClass(
    'InSite.Model.PromotionResultAddFreeProduct',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultAddFreeProduct

See Also

PromotionResultAddFreeProduct Members
InSite.Model Namespace


PromotionResultAddFreeProduct Members

[image] [image]

.NET Framework Class Library
PromotionResultAddFreeProduct Members
PromotionResultAddFreeProduct Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultAddFreeProduct type exposes the following members.

Constructors

Name | Description
PromotionResultAddFreeProduct |

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


PromotionResultAddFreeProduct Constructor

[image]

.NET Framework Class Library
PromotionResultAddFreeProduct Constructor
PromotionResultAddFreeProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultAddFreeProduct()
Visual C++
public:
PromotionResultAddFreeProduct()
JavaScript
InSite.Model.PromotionResultAddFreeProduct = function();

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


PromotionResultAddFreeProduct Fields

[image] [image]

.NET Framework Class Library
PromotionResultAddFreeProduct Fields
PromotionResultAddFreeProduct Class See Also Send Feedback

The PromotionResultAddFreeProduct type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


PromotionResultAddFreeProduct Methods

[image] [image]

.NET Framework Class Library
PromotionResultAddFreeProduct Methods
PromotionResultAddFreeProduct Class See Also Send Feedback

The PromotionResultAddFreeProduct type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultAddFreeProduct..::.ApplyPromotionResult Method
PromotionResultAddFreeProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultAddFreeProduct..::.ClearPromotionResult Method
PromotionResultAddFreeProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResultAddFreeProduct..::.ProductDiscount Method
PromotionResultAddFreeProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
) override
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultAddFreeProduct..::.UnApplyPromotionResult Method
PromotionResultAddFreeProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


PromotionResultAddFreeProduct Properties

[image] [image]

.NET Framework Class Library
PromotionResultAddFreeProduct Properties
PromotionResultAddFreeProduct Class See Also Send Feedback

The PromotionResultAddFreeProduct type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultAddFreeProduct..::.Amount Property
PromotionResultAddFreeProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
PromotionResultAddFreeProduct..::.Product Property
PromotionResultAddFreeProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Product As Product
C#
[DataMemberAttribute]
public virtual Product Product { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

PromotionResultAddFreeProduct Class
InSite.Model Namespace


PromotionResultAddFreeProductFromCategory Class

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultAddFreeProductFromCategory _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultAddFreeProductFromCategory : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultAddFreeProductFromCategory : public PromotionResult
JavaScript
InSite.Model.PromotionResultAddFreeProductFromCategory = function();

Type.createClass(
    'InSite.Model.PromotionResultAddFreeProductFromCategory',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultAddFreeProductFromCategory

See Also

PromotionResultAddFreeProductFromCategory Members
InSite.Model Namespace


PromotionResultAddFreeProductFromCategory Members

[image] [image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory Members
PromotionResultAddFreeProductFromCategory Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultAddFreeProductFromCategory type exposes the following members.

Constructors

Name | Description
PromotionResultAddFreeProductFromCategory |

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
AvailableProducts |
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MaxValue |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


PromotionResultAddFreeProductFromCategory Constructor

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory Constructor
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultAddFreeProductFromCategory()
Visual C++
public:
PromotionResultAddFreeProductFromCategory()
JavaScript
InSite.Model.PromotionResultAddFreeProductFromCategory = function();

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


PromotionResultAddFreeProductFromCategory Fields

[image] [image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory Fields
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

The PromotionResultAddFreeProductFromCategory type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


PromotionResultAddFreeProductFromCategory Methods

[image] [image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory Methods
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

The PromotionResultAddFreeProductFromCategory type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory..::.ApplyPromotionResult Method
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory..::.ClearPromotionResult Method
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory..::.ProductDiscount Method
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
) override
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory..::.UnApplyPromotionResult Method
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


PromotionResultAddFreeProductFromCategory Properties

[image] [image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory Properties
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

The PromotionResultAddFreeProductFromCategory type exposes the following members.

Properties

Name | Description
Amount |
AvailableProducts |
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MaxValue |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory..::.Amount Property
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


AvailableProducts Property

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory..::.AvailableProducts Property
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property AvailableProducts As ReadOnlyCollection(Of ProductInfo)
C#
public virtual ReadOnlyCollection<ProductInfo> AvailableProducts { get; }
Visual C++
public:
virtual property ReadOnlyCollection<ProductInfo^>^ AvailableProducts {
    ReadOnlyCollection<ProductInfo^>^ get ();
}
JavaScript
function get_availableProducts();

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory..::.Category Property
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Category As Category
C#
[DataMemberAttribute]
public virtual Category Category { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


MaxValue Property

[image]

.NET Framework Class Library
PromotionResultAddFreeProductFromCategory..::.MaxValue Property
PromotionResultAddFreeProductFromCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MaxValue As Decimal
C#
[DataMemberAttribute]
public virtual decimal MaxValue { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal MaxValue {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_maxValue();
function set_maxValue(value);

See Also

PromotionResultAddFreeProductFromCategory Class
InSite.Model Namespace


PromotionResultDiscountProductsInCategory Class

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultDiscountProductsInCategory _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultDiscountProductsInCategory : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultDiscountProductsInCategory : public PromotionResult
JavaScript
InSite.Model.PromotionResultDiscountProductsInCategory = function();

Type.createClass(
    'InSite.Model.PromotionResultDiscountProductsInCategory',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultDiscountProductsInCategory

See Also

PromotionResultDiscountProductsInCategory Members
InSite.Model Namespace


PromotionResultDiscountProductsInCategory Members

[image] [image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory Members
PromotionResultDiscountProductsInCategory Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultDiscountProductsInCategory type exposes the following members.

Constructors

Name | Description
PromotionResultDiscountProductsInCategory |

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsPercent |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


PromotionResultDiscountProductsInCategory Constructor

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory Constructor
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultDiscountProductsInCategory()
Visual C++
public:
PromotionResultDiscountProductsInCategory()
JavaScript
InSite.Model.PromotionResultDiscountProductsInCategory = function();

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


PromotionResultDiscountProductsInCategory Fields

[image] [image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory Fields
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

The PromotionResultDiscountProductsInCategory type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


PromotionResultDiscountProductsInCategory Methods

[image] [image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory Methods
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

The PromotionResultDiscountProductsInCategory type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory..::.ApplyPromotionResult Method
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory..::.ClearPromotionResult Method
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory..::.ProductDiscount Method
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
) override
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory..::.UnApplyPromotionResult Method
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Return Value

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


PromotionResultDiscountProductsInCategory Properties

[image] [image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory Properties
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

The PromotionResultDiscountProductsInCategory type exposes the following members.

Properties

Name | Description
Amount |
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsPercent |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory..::.Amount Property
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory..::.Category Property
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Category As Category
C#
[DataMemberAttribute]
public virtual Category Category { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


IsPercent Property

[image]

.NET Framework Class Library
PromotionResultDiscountProductsInCategory..::.IsPercent Property
PromotionResultDiscountProductsInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsPercent As Boolean
C#
[DataMemberAttribute]
public virtual bool IsPercent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsPercent {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isPercent();
function set_isPercent(value);

See Also

PromotionResultDiscountProductsInCategory Class
InSite.Model Namespace


PromotionResultDiscountProductsOfVendor Class

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultDiscountProductsOfVendor _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultDiscountProductsOfVendor : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultDiscountProductsOfVendor : public PromotionResult
JavaScript
InSite.Model.PromotionResultDiscountProductsOfVendor = function();

Type.createClass(
    'InSite.Model.PromotionResultDiscountProductsOfVendor',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultDiscountProductsOfVendor

See Also

PromotionResultDiscountProductsOfVendor Members
InSite.Model Namespace


PromotionResultDiscountProductsOfVendor Members

[image] [image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor Members
PromotionResultDiscountProductsOfVendor Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultDiscountProductsOfVendor type exposes the following members.

Constructors

Name | Description
PromotionResultDiscountProductsOfVendor |

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsPercent |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Vendor |
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


PromotionResultDiscountProductsOfVendor Constructor

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor Constructor
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultDiscountProductsOfVendor()
Visual C++
public:
PromotionResultDiscountProductsOfVendor()
JavaScript
InSite.Model.PromotionResultDiscountProductsOfVendor = function();

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


PromotionResultDiscountProductsOfVendor Fields

[image] [image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor Fields
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

The PromotionResultDiscountProductsOfVendor type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


PromotionResultDiscountProductsOfVendor Methods

[image] [image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor Methods
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

The PromotionResultDiscountProductsOfVendor type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor..::.ApplyPromotionResult Method
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor..::.ClearPromotionResult Method
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor..::.ProductDiscount Method
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
) override
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor..::.UnApplyPromotionResult Method
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Return Value

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


PromotionResultDiscountProductsOfVendor Properties

[image] [image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor Properties
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

The PromotionResultDiscountProductsOfVendor type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsPercent |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Vendor |
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor..::.Amount Property
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


IsPercent Property

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor..::.IsPercent Property
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsPercent As Boolean
C#
[DataMemberAttribute]
public virtual bool IsPercent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsPercent {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isPercent();
function set_isPercent(value);

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


Vendor Property

[image]

.NET Framework Class Library
PromotionResultDiscountProductsOfVendor..::.Vendor Property
PromotionResultDiscountProductsOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Vendor As Vendor
C#
[DataMemberAttribute]
public virtual Vendor Vendor { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Vendor^ Vendor {
    Vendor^ get ();
    void set (Vendor^ value);
}
JavaScript
function get_vendor();
function set_vendor(value);

See Also

PromotionResultDiscountProductsOfVendor Class
InSite.Model Namespace


PromotionResultDollarOffOrder Class

[image]

.NET Framework Class Library
PromotionResultDollarOffOrder Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultDollarOffOrder _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultDollarOffOrder : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultDollarOffOrder : public PromotionResult
JavaScript
InSite.Model.PromotionResultDollarOffOrder = function();

Type.createClass(
    'InSite.Model.PromotionResultDollarOffOrder',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultDollarOffOrder

See Also

PromotionResultDollarOffOrder Members
InSite.Model Namespace


PromotionResultDollarOffOrder Members

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffOrder Members
PromotionResultDollarOffOrder Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultDollarOffOrder type exposes the following members.

Constructors

Name | Description
PromotionResultDollarOffOrder |

Methods

Name | Description
ApplyPromotionResult | (Inherited from PromotionResult.)
ClearPromotionResult | (Inherited from PromotionResult.)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Overrides PromotionResult..::.DollarOffOrder(CustomerOrder).)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Inherited from PromotionResult.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Inherited from PromotionResult.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffOrder Class
InSite.Model Namespace


PromotionResultDollarOffOrder Constructor

[image]

.NET Framework Class Library
PromotionResultDollarOffOrder Constructor
PromotionResultDollarOffOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultDollarOffOrder()
Visual C++
public:
PromotionResultDollarOffOrder()
JavaScript
InSite.Model.PromotionResultDollarOffOrder = function();

See Also

PromotionResultDollarOffOrder Class
InSite.Model Namespace


PromotionResultDollarOffOrder Fields

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffOrder Fields
PromotionResultDollarOffOrder Class See Also Send Feedback

The PromotionResultDollarOffOrder type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultDollarOffOrder Class
InSite.Model Namespace


PromotionResultDollarOffOrder Methods

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffOrder Methods
PromotionResultDollarOffOrder Class See Also Send Feedback

The PromotionResultDollarOffOrder type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Inherited from PromotionResult.)
ClearPromotionResult | (Inherited from PromotionResult.)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Overrides PromotionResult..::.DollarOffOrder(CustomerOrder).)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Inherited from PromotionResult.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Inherited from PromotionResult.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffOrder Class
InSite.Model Namespace


DollarOffOrder Method

[image]

.NET Framework Class Library
PromotionResultDollarOffOrder..::.DollarOffOrder Method
PromotionResultDollarOffOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function DollarOffOrder ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal DollarOffOrder(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal DollarOffOrder(
    CustomerOrder^ customerOrder
) override
JavaScript
function dollarOffOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDollarOffOrder Class
InSite.Model Namespace


PromotionResultDollarOffOrder Properties

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffOrder Properties
PromotionResultDollarOffOrder Class See Also Send Feedback

The PromotionResultDollarOffOrder type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffOrder Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultDollarOffOrder..::.Amount Property
PromotionResultDollarOffOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultDollarOffOrder Class
InSite.Model Namespace


PromotionResultDollarOffProduct Class

[image]

.NET Framework Class Library
PromotionResultDollarOffProduct Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultDollarOffProduct _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultDollarOffProduct : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultDollarOffProduct : public PromotionResult
JavaScript
InSite.Model.PromotionResultDollarOffProduct = function();

Type.createClass(
    'InSite.Model.PromotionResultDollarOffProduct',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultDollarOffProduct

See Also

PromotionResultDollarOffProduct Members
InSite.Model Namespace


PromotionResultDollarOffProduct Members

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffProduct Members
PromotionResultDollarOffProduct Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultDollarOffProduct type exposes the following members.

Constructors

Name | Description
PromotionResultDollarOffProduct |

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


PromotionResultDollarOffProduct Constructor

[image]

.NET Framework Class Library
PromotionResultDollarOffProduct Constructor
PromotionResultDollarOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultDollarOffProduct()
Visual C++
public:
PromotionResultDollarOffProduct()
JavaScript
InSite.Model.PromotionResultDollarOffProduct = function();

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


PromotionResultDollarOffProduct Fields

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffProduct Fields
PromotionResultDollarOffProduct Class See Also Send Feedback

The PromotionResultDollarOffProduct type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


PromotionResultDollarOffProduct Methods

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffProduct Methods
PromotionResultDollarOffProduct Class See Also Send Feedback

The PromotionResultDollarOffProduct type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDollarOffProduct..::.ApplyPromotionResult Method
PromotionResultDollarOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDollarOffProduct..::.ClearPromotionResult Method
PromotionResultDollarOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResultDollarOffProduct..::.ProductDiscount Method
PromotionResultDollarOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
) override
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultDollarOffProduct..::.UnApplyPromotionResult Method
PromotionResultDollarOffProduct Class See Also Send Feedback

UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Return Value

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


PromotionResultDollarOffProduct Properties

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffProduct Properties
PromotionResultDollarOffProduct Class See Also Send Feedback

The PromotionResultDollarOffProduct type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultDollarOffProduct..::.Amount Property
PromotionResultDollarOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
PromotionResultDollarOffProduct..::.Product Property
PromotionResultDollarOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Product As Product
C#
[DataMemberAttribute]
public virtual Product Product { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

PromotionResultDollarOffProduct Class
InSite.Model Namespace


PromotionResultDollarOffShipping Class

[image]

.NET Framework Class Library
PromotionResultDollarOffShipping Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultDollarOffShipping _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultDollarOffShipping : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultDollarOffShipping : public PromotionResult
JavaScript
InSite.Model.PromotionResultDollarOffShipping = function();

Type.createClass(
    'InSite.Model.PromotionResultDollarOffShipping',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultDollarOffShipping

See Also

PromotionResultDollarOffShipping Members
InSite.Model Namespace


PromotionResultDollarOffShipping Members

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffShipping Members
PromotionResultDollarOffShipping Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultDollarOffShipping type exposes the following members.

Constructors

Name | Description
PromotionResultDollarOffShipping |

Methods

Name | Description
ApplyPromotionResult | (Inherited from PromotionResult.)
ClearPromotionResult | (Inherited from PromotionResult.)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Overrides PromotionResult..::.DollarOffShipping(CustomerOrder).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Inherited from PromotionResult.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Inherited from PromotionResult.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffShipping Class
InSite.Model Namespace


PromotionResultDollarOffShipping Constructor

[image]

.NET Framework Class Library
PromotionResultDollarOffShipping Constructor
PromotionResultDollarOffShipping Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultDollarOffShipping()
Visual C++
public:
PromotionResultDollarOffShipping()
JavaScript
InSite.Model.PromotionResultDollarOffShipping = function();

See Also

PromotionResultDollarOffShipping Class
InSite.Model Namespace


PromotionResultDollarOffShipping Fields

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffShipping Fields
PromotionResultDollarOffShipping Class See Also Send Feedback

The PromotionResultDollarOffShipping type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultDollarOffShipping Class
InSite.Model Namespace


PromotionResultDollarOffShipping Methods

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffShipping Methods
PromotionResultDollarOffShipping Class See Also Send Feedback

The PromotionResultDollarOffShipping type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Inherited from PromotionResult.)
ClearPromotionResult | (Inherited from PromotionResult.)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Overrides PromotionResult..::.DollarOffShipping(CustomerOrder).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Inherited from PromotionResult.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Inherited from PromotionResult.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffShipping Class
InSite.Model Namespace


DollarOffShipping Method

[image]

.NET Framework Class Library
PromotionResultDollarOffShipping..::.DollarOffShipping Method
PromotionResultDollarOffShipping Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function DollarOffShipping ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal DollarOffShipping(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal DollarOffShipping(
    CustomerOrder^ customerOrder
) override
JavaScript
function dollarOffShipping(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultDollarOffShipping Class
InSite.Model Namespace


PromotionResultDollarOffShipping Properties

[image] [image]

.NET Framework Class Library
PromotionResultDollarOffShipping Properties
PromotionResultDollarOffShipping Class See Also Send Feedback

The PromotionResultDollarOffShipping type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultDollarOffShipping Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultDollarOffShipping..::.Amount Property
PromotionResultDollarOffShipping Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultDollarOffShipping Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
PromotionResultDollarOffShipping..::.ShipVia Property
PromotionResultDollarOffShipping Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipVia As ShipVia
C#
[DataMemberAttribute]
public virtual ShipVia ShipVia { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

PromotionResultDollarOffShipping Class
InSite.Model Namespace


PromotionResultPercentOffOrder Class

[image]

.NET Framework Class Library
PromotionResultPercentOffOrder Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultPercentOffOrder _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultPercentOffOrder : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultPercentOffOrder : public PromotionResult
JavaScript
InSite.Model.PromotionResultPercentOffOrder = function();

Type.createClass(
    'InSite.Model.PromotionResultPercentOffOrder',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultPercentOffOrder

See Also

PromotionResultPercentOffOrder Members
InSite.Model Namespace


PromotionResultPercentOffOrder Members

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffOrder Members
PromotionResultPercentOffOrder Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultPercentOffOrder type exposes the following members.

Constructors

Name | Description
PromotionResultPercentOffOrder |

Methods

Name | Description
ApplyPromotionResult | (Inherited from PromotionResult.)
ClearPromotionResult | (Inherited from PromotionResult.)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Overrides PromotionResult..::.PercentOffOrder(CustomerOrder).)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Inherited from PromotionResult.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Inherited from PromotionResult.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffOrder Class
InSite.Model Namespace


PromotionResultPercentOffOrder Constructor

[image]

.NET Framework Class Library
PromotionResultPercentOffOrder Constructor
PromotionResultPercentOffOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultPercentOffOrder()
Visual C++
public:
PromotionResultPercentOffOrder()
JavaScript
InSite.Model.PromotionResultPercentOffOrder = function();

See Also

PromotionResultPercentOffOrder Class
InSite.Model Namespace


PromotionResultPercentOffOrder Fields

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffOrder Fields
PromotionResultPercentOffOrder Class See Also Send Feedback

The PromotionResultPercentOffOrder type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultPercentOffOrder Class
InSite.Model Namespace


PromotionResultPercentOffOrder Methods

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffOrder Methods
PromotionResultPercentOffOrder Class See Also Send Feedback

The PromotionResultPercentOffOrder type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Inherited from PromotionResult.)
ClearPromotionResult | (Inherited from PromotionResult.)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Overrides PromotionResult..::.PercentOffOrder(CustomerOrder).)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Inherited from PromotionResult.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Inherited from PromotionResult.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffOrder Class
InSite.Model Namespace


PercentOffOrder Method

[image]

.NET Framework Class Library
PromotionResultPercentOffOrder..::.PercentOffOrder Method
PromotionResultPercentOffOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function PercentOffOrder ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal PercentOffOrder(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal PercentOffOrder(
    CustomerOrder^ customerOrder
) override
JavaScript
function percentOffOrder(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultPercentOffOrder Class
InSite.Model Namespace


PromotionResultPercentOffOrder Properties

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffOrder Properties
PromotionResultPercentOffOrder Class See Also Send Feedback

The PromotionResultPercentOffOrder type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffOrder Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultPercentOffOrder..::.Amount Property
PromotionResultPercentOffOrder Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultPercentOffOrder Class
InSite.Model Namespace


PromotionResultPercentOffProduct Class

[image]

.NET Framework Class Library
PromotionResultPercentOffProduct Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultPercentOffProduct _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultPercentOffProduct : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultPercentOffProduct : public PromotionResult
JavaScript
InSite.Model.PromotionResultPercentOffProduct = function();

Type.createClass(
    'InSite.Model.PromotionResultPercentOffProduct',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultPercentOffProduct

See Also

PromotionResultPercentOffProduct Members
InSite.Model Namespace


PromotionResultPercentOffProduct Members

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffProduct Members
PromotionResultPercentOffProduct Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultPercentOffProduct type exposes the following members.

Constructors

Name | Description
PromotionResultPercentOffProduct |

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


PromotionResultPercentOffProduct Constructor

[image]

.NET Framework Class Library
PromotionResultPercentOffProduct Constructor
PromotionResultPercentOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultPercentOffProduct()
Visual C++
public:
PromotionResultPercentOffProduct()
JavaScript
InSite.Model.PromotionResultPercentOffProduct = function();

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


PromotionResultPercentOffProduct Fields

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffProduct Fields
PromotionResultPercentOffProduct Class See Also Send Feedback

The PromotionResultPercentOffProduct type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


PromotionResultPercentOffProduct Methods

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffProduct Methods
PromotionResultPercentOffProduct Class See Also Send Feedback

The PromotionResultPercentOffProduct type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultPercentOffProduct..::.ApplyPromotionResult Method
PromotionResultPercentOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultPercentOffProduct..::.ClearPromotionResult Method
PromotionResultPercentOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResultPercentOffProduct..::.ProductDiscount Method
PromotionResultPercentOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
) override
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultPercentOffProduct..::.UnApplyPromotionResult Method
PromotionResultPercentOffProduct Class See Also Send Feedback

UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Return Value

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


PromotionResultPercentOffProduct Properties

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffProduct Properties
PromotionResultPercentOffProduct Class See Also Send Feedback

The PromotionResultPercentOffProduct type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultPercentOffProduct..::.Amount Property
PromotionResultPercentOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
PromotionResultPercentOffProduct..::.Product Property
PromotionResultPercentOffProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Product As Product
C#
[DataMemberAttribute]
public virtual Product Product { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

PromotionResultPercentOffProduct Class
InSite.Model Namespace


PromotionResultPercentOffShipping Class

[image]

.NET Framework Class Library
PromotionResultPercentOffShipping Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultPercentOffShipping _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultPercentOffShipping : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultPercentOffShipping : public PromotionResult
JavaScript
InSite.Model.PromotionResultPercentOffShipping = function();

Type.createClass(
    'InSite.Model.PromotionResultPercentOffShipping',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultPercentOffShipping

See Also

PromotionResultPercentOffShipping Members
InSite.Model Namespace


PromotionResultPercentOffShipping Members

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffShipping Members
PromotionResultPercentOffShipping Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultPercentOffShipping type exposes the following members.

Constructors

Name | Description
PromotionResultPercentOffShipping |

Methods

Name | Description
ApplyPromotionResult | (Inherited from PromotionResult.)
ClearPromotionResult | (Inherited from PromotionResult.)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Overrides PromotionResult..::.PercentOffShipping(CustomerOrder).)
ProductDiscount | (Inherited from PromotionResult.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Inherited from PromotionResult.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffShipping Class
InSite.Model Namespace


PromotionResultPercentOffShipping Constructor

[image]

.NET Framework Class Library
PromotionResultPercentOffShipping Constructor
PromotionResultPercentOffShipping Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultPercentOffShipping()
Visual C++
public:
PromotionResultPercentOffShipping()
JavaScript
InSite.Model.PromotionResultPercentOffShipping = function();

See Also

PromotionResultPercentOffShipping Class
InSite.Model Namespace


PromotionResultPercentOffShipping Fields

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffShipping Fields
PromotionResultPercentOffShipping Class See Also Send Feedback

The PromotionResultPercentOffShipping type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultPercentOffShipping Class
InSite.Model Namespace


PromotionResultPercentOffShipping Methods

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffShipping Methods
PromotionResultPercentOffShipping Class See Also Send Feedback

The PromotionResultPercentOffShipping type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Inherited from PromotionResult.)
ClearPromotionResult | (Inherited from PromotionResult.)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Overrides PromotionResult..::.PercentOffShipping(CustomerOrder).)
ProductDiscount | (Inherited from PromotionResult.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | (Inherited from PromotionResult.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffShipping Class
InSite.Model Namespace


PercentOffShipping Method

[image]

.NET Framework Class Library
PromotionResultPercentOffShipping..::.PercentOffShipping Method
PromotionResultPercentOffShipping Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function PercentOffShipping ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal PercentOffShipping(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal PercentOffShipping(
    CustomerOrder^ customerOrder
) override
JavaScript
function percentOffShipping(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultPercentOffShipping Class
InSite.Model Namespace


PromotionResultPercentOffShipping Properties

[image] [image]

.NET Framework Class Library
PromotionResultPercentOffShipping Properties
PromotionResultPercentOffShipping Class See Also Send Feedback

The PromotionResultPercentOffShipping type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultPercentOffShipping Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultPercentOffShipping..::.Amount Property
PromotionResultPercentOffShipping Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultPercentOffShipping Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
PromotionResultPercentOffShipping..::.ShipVia Property
PromotionResultPercentOffShipping Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipVia As ShipVia
C#
[DataMemberAttribute]
public virtual ShipVia ShipVia { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

PromotionResultPercentOffShipping Class
InSite.Model Namespace


PromotionResultSetOrderedProductToAmount Class

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultSetOrderedProductToAmount _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultSetOrderedProductToAmount : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultSetOrderedProductToAmount : public PromotionResult
JavaScript
InSite.Model.PromotionResultSetOrderedProductToAmount = function();

Type.createClass(
    'InSite.Model.PromotionResultSetOrderedProductToAmount',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultSetOrderedProductToAmount

See Also

PromotionResultSetOrderedProductToAmount Members
InSite.Model Namespace


PromotionResultSetOrderedProductToAmount Members

[image] [image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount Members
PromotionResultSetOrderedProductToAmount Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultSetOrderedProductToAmount type exposes the following members.

Constructors

Name | Description
PromotionResultSetOrderedProductToAmount |

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


PromotionResultSetOrderedProductToAmount Constructor

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount Constructor
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultSetOrderedProductToAmount()
Visual C++
public:
PromotionResultSetOrderedProductToAmount()
JavaScript
InSite.Model.PromotionResultSetOrderedProductToAmount = function();

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


PromotionResultSetOrderedProductToAmount Fields

[image] [image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount Fields
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

The PromotionResultSetOrderedProductToAmount type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


PromotionResultSetOrderedProductToAmount Methods

[image] [image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount Methods
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

The PromotionResultSetOrderedProductToAmount type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount..::.ApplyPromotionResult Method
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount..::.ClearPromotionResult Method
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount..::.ProductDiscount Method
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
) override
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount..::.UnApplyPromotionResult Method
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Return Value

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


PromotionResultSetOrderedProductToAmount Properties

[image] [image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount Properties
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

The PromotionResultSetOrderedProductToAmount type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount..::.Amount Property
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToAmount..::.Product Property
PromotionResultSetOrderedProductToAmount Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Product As Product
C#
[DataMemberAttribute]
public virtual Product Product { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

PromotionResultSetOrderedProductToAmount Class
InSite.Model Namespace


PromotionResultSetOrderedProductToFree Class

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionResultSetOrderedProductToFree _
    Inherits PromotionResult
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionResultSetOrderedProductToFree : PromotionResult
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionResultSetOrderedProductToFree : public PromotionResult
JavaScript
InSite.Model.PromotionResultSetOrderedProductToFree = function();

Type.createClass(
    'InSite.Model.PromotionResultSetOrderedProductToFree',
    InSite.Model.PromotionResult);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionResult >)>)
InSite.Model..::.PromotionResult
InSite.Model..::.PromotionResultSetOrderedProductToFree

See Also

PromotionResultSetOrderedProductToFree Members
InSite.Model Namespace


PromotionResultSetOrderedProductToFree Members

[image] [image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree Members
PromotionResultSetOrderedProductToFree Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionResultSetOrderedProductToFree type exposes the following members.

Constructors

Name | Description
PromotionResultSetOrderedProductToFree |

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


PromotionResultSetOrderedProductToFree Constructor

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree Constructor
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionResultSetOrderedProductToFree()
Visual C++
public:
PromotionResultSetOrderedProductToFree()
JavaScript
InSite.Model.PromotionResultSetOrderedProductToFree = function();

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


PromotionResultSetOrderedProductToFree Fields

[image] [image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree Fields
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

The PromotionResultSetOrderedProductToFree type exposes the following members.

Fields

Name | Description
_promotion | (Inherited from PromotionResult.)
_promotionResultId | (Inherited from PromotionResult.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
_visible | (Inherited from PromotionResult.)

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


PromotionResultSetOrderedProductToFree Methods

[image] [image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree Methods
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

The PromotionResultSetOrderedProductToFree type exposes the following members.

Methods

Name | Description
ApplyPromotionResult | (Overrides PromotionResult..::.ApplyPromotionResult(CustomerOrder).)
ClearPromotionResult | (Overrides PromotionResult..::.ClearPromotionResult(CustomerOrder).)
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
DollarOffOrder | (Inherited from PromotionResult.)
DollarOffShipping | (Inherited from PromotionResult.)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PercentOffOrder | (Inherited from PromotionResult.)
PercentOffShipping | (Inherited from PromotionResult.)
ProductDiscount | (Overrides PromotionResult..::.ProductDiscount(CustomerOrder).)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnApplyPromotionResult | UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result (Overrides PromotionResult..::.UnApplyPromotionResult(CustomerOrder).)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


ApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree..::.ApplyPromotionResult Method
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function applyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


ClearPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree..::.ClearPromotionResult Method
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ClearPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder ClearPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ ClearPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function clearPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


ProductDiscount Method

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree..::.ProductDiscount Method
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ProductDiscount ( _
    customerOrder As CustomerOrder _
) As Decimal
C#
public override decimal ProductDiscount(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual Decimal ProductDiscount(
    CustomerOrder^ customerOrder
) override
JavaScript
function productDiscount(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


UnApplyPromotionResult Method

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree..::.UnApplyPromotionResult Method
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

UnApplyPromotionResult - Called from within OrderLine.CalculatePrice, only difference between this and ClearPromotionResult is that it doesn't set the PromotionResult to null, so we don't get a null reference exception on the next line where it re-applies the promotion result

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function UnApplyPromotionResult ( _
    customerOrder As CustomerOrder _
) As CustomerOrder
C#
public override CustomerOrder UnApplyPromotionResult(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual CustomerOrder^ UnApplyPromotionResult(
    CustomerOrder^ customerOrder
) override
JavaScript
function unApplyPromotionResult(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

Return Value

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


PromotionResultSetOrderedProductToFree Properties

[image] [image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree Properties
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

The PromotionResultSetOrderedProductToFree type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionResult.)
PromotionResultId | (Inherited from PromotionResult.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ResultName | (Inherited from PromotionResult.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Visible | (Inherited from PromotionResult.)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
PromotionResultSetOrderedProductToFree..::.Product Property
PromotionResultSetOrderedProductToFree Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Product As Product
C#
[DataMemberAttribute]
[SortField]
public virtual Product Product { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

PromotionResultSetOrderedProductToFree Class
InSite.Model Namespace


PromotionRule Class

[image]

.NET Framework Class Library
PromotionRule Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRule _
    Inherits ModelBase(Of PromotionRule) _
    Implements IRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRule : ModelBase<PromotionRule>,
    IRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRule : public ModelBase<PromotionRule^>,
    IRule
JavaScript
InSite.Model.PromotionRule = function();

Type.createClass(
    'InSite.Model.PromotionRule',
    InSite.Model.ModelBase`1,
    InSite.Model.IRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(PromotionRule>)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleCustomerMaximumTimesPromotionAllowed
InSite.Model..::.PromotionRuleExcludesCustomer
InSite.Model..::.PromotionRuleExcludesUserRole
InSite.Model..::.PromotionRuleIncludesCustomer
InSite.Model..::.PromotionRuleIncludesUserRole
InSite.Model..::.PromotionRuleMaximumPromotionUsedQuanity
InSite.Model..::.PromotionRuleOrderContainsOrderedProduct
InSite.Model..::.PromotionRuleOrderContainsOrderedProductInCategory
InSite.Model..::.PromotionRuleOrderContainsOrderedProductOfVendor
InSite.Model..::.PromotionRuleOrderContainsPromotion
InSite.Model..::.PromotionRuleOrderDoesNotContainPromotion
InSite.Model..::.PromotionRuleOrderNotShippingToCountry
InSite.Model..::.PromotionRuleOrderNotShippingToState
InSite.Model..::.PromotionRuleOrderProductTotalGreaterThan
InSite.Model..::.PromotionRuleOrderProductTotalIsInRange
InSite.Model..::.PromotionRuleOrderShippingToCountry
InSite.Model..::.PromotionRuleOrderShippingToState
InSite.Model..::.PromotionRuleOrderShipViaMatches
InSite.Model..::.PromotionRuleValidPromotionCode

See Also

PromotionRule Members
InSite.Model Namespace


PromotionRule Members

[image] [image]

.NET Framework Class Library
PromotionRule Members
PromotionRule Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRule type exposes the following members.

Constructors

Name | Description
PromotionRule |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition |
_executionGroup |
_executionOrder |
_promotion |
_promotionRuleId |
_ruleName |
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
AmountIsDollar |
AmountIsQuantity |
ConditionAnd |
ConditionOr |

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup |
ExecutionOrder |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion |
PromotionRuleId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRule Class
InSite.Model Namespace


PromotionRule Constructor

[image]

.NET Framework Class Library
PromotionRule Constructor
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRule()
Visual C++
public:
PromotionRule()
JavaScript
InSite.Model.PromotionRule = function();

See Also

PromotionRule Class
InSite.Model Namespace


PromotionRule Fields

[image] [image]

.NET Framework Class Library
PromotionRule Fields
PromotionRule Class See Also Send Feedback

The PromotionRule type exposes the following members.

Fields

Name | Description
_condition |
_executionGroup |
_executionOrder |
_promotion |
_promotionRuleId |
_ruleName |
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
AmountIsDollar |
AmountIsQuantity |
ConditionAnd |
ConditionOr |

See Also

PromotionRule Class
InSite.Model Namespace


_condition Field

[image]

.NET Framework Class Library
PromotionRule..::._condition Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _condition As String
C#
protected string _condition
Visual C++
protected:
String^ _condition
JavaScript
_condition

See Also

PromotionRule Class
InSite.Model Namespace


_executionGroup Field

[image]

.NET Framework Class Library
PromotionRule..::._executionGroup Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _executionGroup As Integer
C#
protected int _executionGroup
Visual C++
protected:
int _executionGroup
JavaScript
_executionGroup

See Also

PromotionRule Class
InSite.Model Namespace


_executionOrder Field

[image]

.NET Framework Class Library
PromotionRule..::._executionOrder Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _executionOrder As Integer
C#
protected int _executionOrder
Visual C++
protected:
int _executionOrder
JavaScript
_executionOrder

See Also

PromotionRule Class
InSite.Model Namespace


_promotion Field

[image]

.NET Framework Class Library
PromotionRule..::._promotion Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _promotion As Promotion
C#
protected Promotion _promotion
Visual C++
protected:
Promotion^ _promotion
JavaScript
_promotion

See Also

PromotionRule Class
InSite.Model Namespace


_promotionRuleId Field

[image]

.NET Framework Class Library
PromotionRule..::._promotionRuleId Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _promotionRuleId As Guid
C#
protected Guid _promotionRuleId
Visual C++
protected:
Guid _promotionRuleId
JavaScript
_promotionRuleId

See Also

PromotionRule Class
InSite.Model Namespace


_ruleName Field

[image]

.NET Framework Class Library
PromotionRule..::._ruleName Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _ruleName As String
C#
protected string _ruleName
Visual C++
protected:
String^ _ruleName
JavaScript
_ruleName

See Also

PromotionRule Class
InSite.Model Namespace


AmountIsDollar Field

[image]

.NET Framework Class Library
PromotionRule..::.AmountIsDollar Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const AmountIsDollar As String
C#
public const string AmountIsDollar
Visual C++
public:
literal String^ AmountIsDollar
JavaScript
InSite.Model.PromotionRule.amountIsDollar

See Also

PromotionRule Class
InSite.Model Namespace


AmountIsQuantity Field

[image]

.NET Framework Class Library
PromotionRule..::.AmountIsQuantity Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const AmountIsQuantity As String
C#
public const string AmountIsQuantity
Visual C++
public:
literal String^ AmountIsQuantity
JavaScript
InSite.Model.PromotionRule.amountIsQuantity

See Also

PromotionRule Class
InSite.Model Namespace


ConditionAnd Field

[image]

.NET Framework Class Library
PromotionRule..::.ConditionAnd Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ConditionAnd As String
C#
public const string ConditionAnd
Visual C++
public:
literal String^ ConditionAnd
JavaScript
InSite.Model.PromotionRule.conditionAnd

See Also

PromotionRule Class
InSite.Model Namespace


ConditionOr Field

[image]

.NET Framework Class Library
PromotionRule..::.ConditionOr Field
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ConditionOr As String
C#
public const string ConditionOr
Visual C++
public:
literal String^ ConditionOr
JavaScript
InSite.Model.PromotionRule.conditionOr

See Also

PromotionRule Class
InSite.Model Namespace


PromotionRule Methods

[image] [image]

.NET Framework Class Library
PromotionRule Methods
PromotionRule Class See Also Send Feedback

The PromotionRule type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRule Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRule..::.IsValid Method
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public virtual bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
)
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRule Class
InSite.Model Namespace


PromotionRule Properties

[image] [image]

.NET Framework Class Library
PromotionRule Properties
PromotionRule Class See Also Send Feedback

The PromotionRule type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup |
ExecutionOrder |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion |
PromotionRuleId |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRule Class
InSite.Model Namespace


Condition Property

[image]

.NET Framework Class Library
PromotionRule..::.Condition Property
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Condition As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Condition { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Condition {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_condition();
function set_condition(value);

Implements

IRule..::.Condition

See Also

PromotionRule Class
InSite.Model Namespace


ExecutionGroup Property

[image]

.NET Framework Class Library
PromotionRule..::.ExecutionGroup Property
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ExecutionGroup As Integer
C#
[DataMemberAttribute]
public virtual int ExecutionGroup { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int ExecutionGroup {
    int get ();
    void set (int value);
}
JavaScript
function get_executionGroup();
function set_executionGroup(value);

Implements

IRule..::.ExecutionGroup

See Also

PromotionRule Class
InSite.Model Namespace


ExecutionOrder Property

[image]

.NET Framework Class Library
PromotionRule..::.ExecutionOrder Property
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ExecutionOrder As Integer
C#
[DataMemberAttribute]
public virtual int ExecutionOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int ExecutionOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_executionOrder();
function set_executionOrder(value);

Implements

IRule..::.ExecutionOrder

See Also

PromotionRule Class
InSite.Model Namespace


Promotion Property

[image]

.NET Framework Class Library
PromotionRule..::.Promotion Property
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Promotion As Promotion
C#
public virtual Promotion Promotion { get; set; }
Visual C++
public:
virtual property Promotion^ Promotion {
    Promotion^ get ();
    void set (Promotion^ value);
}
JavaScript
function get_promotion();
function set_promotion(value);

See Also

PromotionRule Class
InSite.Model Namespace


PromotionRuleId Property

[image]

.NET Framework Class Library
PromotionRule..::.PromotionRuleId Property
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PromotionRuleId As Guid
C#
public virtual Guid PromotionRuleId { get; set; }
Visual C++
public:
virtual property Guid PromotionRuleId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_promotionRuleId();
function set_promotionRuleId(value);

See Also

PromotionRule Class
InSite.Model Namespace


RuleName Property

[image]

.NET Framework Class Library
PromotionRule..::.RuleName Property
PromotionRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RuleName As String
C#
[DataMemberAttribute]
public virtual string RuleName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RuleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ruleName();
function set_ruleName(value);

See Also

PromotionRule Class
InSite.Model Namespace


PromotionRuleCustomerMaximumTimesPromotionAllowed Class

[image]

.NET Framework Class Library
PromotionRuleCustomerMaximumTimesPromotionAllowed Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleCustomerMaximumTimesPromotionAllowed _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleCustomerMaximumTimesPromotionAllowed : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleCustomerMaximumTimesPromotionAllowed : public PromotionRule
JavaScript
InSite.Model.PromotionRuleCustomerMaximumTimesPromotionAllowed = function();

Type.createClass(
    'InSite.Model.PromotionRuleCustomerMaximumTimesPromotionAllowed',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleCustomerMaximumTimesPromotionAllowed

See Also

PromotionRuleCustomerMaximumTimesPromotionAllowed Members
InSite.Model Namespace


PromotionRuleCustomerMaximumTimesPromotionAllowed Members

[image] [image]

.NET Framework Class Library
PromotionRuleCustomerMaximumTimesPromotionAllowed Members
PromotionRuleCustomerMaximumTimesPromotionAllowed Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleCustomerMaximumTimesPromotionAllowed type exposes the following members.

Constructors

Name | Description
PromotionRuleCustomerMaximumTimesPromotionAllowed |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleCustomerMaximumTimesPromotionAllowed Class
InSite.Model Namespace


PromotionRuleCustomerMaximumTimesPromotionAllowed Constructor

[image]

.NET Framework Class Library
PromotionRuleCustomerMaximumTimesPromotionAllowed Constructor
PromotionRuleCustomerMaximumTimesPromotionAllowed Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleCustomerMaximumTimesPromotionAllowed()
Visual C++
public:
PromotionRuleCustomerMaximumTimesPromotionAllowed()
JavaScript
InSite.Model.PromotionRuleCustomerMaximumTimesPromotionAllowed = function();

See Also

PromotionRuleCustomerMaximumTimesPromotionAllowed Class
InSite.Model Namespace


PromotionRuleCustomerMaximumTimesPromotionAllowed Fields

[image] [image]

.NET Framework Class Library
PromotionRuleCustomerMaximumTimesPromotionAllowed Fields
PromotionRuleCustomerMaximumTimesPromotionAllowed Class See Also Send Feedback

The PromotionRuleCustomerMaximumTimesPromotionAllowed type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleCustomerMaximumTimesPromotionAllowed Class
InSite.Model Namespace


PromotionRuleCustomerMaximumTimesPromotionAllowed Methods

[image] [image]

.NET Framework Class Library
PromotionRuleCustomerMaximumTimesPromotionAllowed Methods
PromotionRuleCustomerMaximumTimesPromotionAllowed Class See Also Send Feedback

The PromotionRuleCustomerMaximumTimesPromotionAllowed type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleCustomerMaximumTimesPromotionAllowed Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleCustomerMaximumTimesPromotionAllowed..::.IsValid Method
PromotionRuleCustomerMaximumTimesPromotionAllowed Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleCustomerMaximumTimesPromotionAllowed Class
InSite.Model Namespace


PromotionRuleCustomerMaximumTimesPromotionAllowed Properties

[image] [image]

.NET Framework Class Library
PromotionRuleCustomerMaximumTimesPromotionAllowed Properties
PromotionRuleCustomerMaximumTimesPromotionAllowed Class See Also Send Feedback

The PromotionRuleCustomerMaximumTimesPromotionAllowed type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleCustomerMaximumTimesPromotionAllowed Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionRuleCustomerMaximumTimesPromotionAllowed..::.Amount Property
PromotionRuleCustomerMaximumTimesPromotionAllowed Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionRuleCustomerMaximumTimesPromotionAllowed Class
InSite.Model Namespace


PromotionRuleExcludesCustomer Class

[image]

.NET Framework Class Library
PromotionRuleExcludesCustomer Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleExcludesCustomer _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleExcludesCustomer : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleExcludesCustomer : public PromotionRule
JavaScript
InSite.Model.PromotionRuleExcludesCustomer = function();

Type.createClass(
    'InSite.Model.PromotionRuleExcludesCustomer',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleExcludesCustomer

See Also

PromotionRuleExcludesCustomer Members
InSite.Model Namespace


PromotionRuleExcludesCustomer Members

[image] [image]

.NET Framework Class Library
PromotionRuleExcludesCustomer Members
PromotionRuleExcludesCustomer Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleExcludesCustomer type exposes the following members.

Constructors

Name | Description
PromotionRuleExcludesCustomer |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
Customer |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleExcludesCustomer Class
InSite.Model Namespace


PromotionRuleExcludesCustomer Constructor

[image]

.NET Framework Class Library
PromotionRuleExcludesCustomer Constructor
PromotionRuleExcludesCustomer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleExcludesCustomer()
Visual C++
public:
PromotionRuleExcludesCustomer()
JavaScript
InSite.Model.PromotionRuleExcludesCustomer = function();

See Also

PromotionRuleExcludesCustomer Class
InSite.Model Namespace


PromotionRuleExcludesCustomer Fields

[image] [image]

.NET Framework Class Library
PromotionRuleExcludesCustomer Fields
PromotionRuleExcludesCustomer Class See Also Send Feedback

The PromotionRuleExcludesCustomer type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleExcludesCustomer Class
InSite.Model Namespace


PromotionRuleExcludesCustomer Methods

[image] [image]

.NET Framework Class Library
PromotionRuleExcludesCustomer Methods
PromotionRuleExcludesCustomer Class See Also Send Feedback

The PromotionRuleExcludesCustomer type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleExcludesCustomer Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleExcludesCustomer..::.IsValid Method
PromotionRuleExcludesCustomer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleExcludesCustomer Class
InSite.Model Namespace


PromotionRuleExcludesCustomer Properties

[image] [image]

.NET Framework Class Library
PromotionRuleExcludesCustomer Properties
PromotionRuleExcludesCustomer Class See Also Send Feedback

The PromotionRuleExcludesCustomer type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
Customer |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleExcludesCustomer Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
PromotionRuleExcludesCustomer..::.Customer Property
PromotionRuleExcludesCustomer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Customer As Customer
C#
[DataMemberAttribute]
[SortField]
public virtual Customer Customer { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

PromotionRuleExcludesCustomer Class
InSite.Model Namespace


PromotionRuleExcludesUserRole Class

[image]

.NET Framework Class Library
PromotionRuleExcludesUserRole Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleExcludesUserRole _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleExcludesUserRole : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleExcludesUserRole : public PromotionRule
JavaScript
InSite.Model.PromotionRuleExcludesUserRole = function();

Type.createClass(
    'InSite.Model.PromotionRuleExcludesUserRole',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleExcludesUserRole

See Also

PromotionRuleExcludesUserRole Members
InSite.Model Namespace


PromotionRuleExcludesUserRole Members

[image] [image]

.NET Framework Class Library
PromotionRuleExcludesUserRole Members
PromotionRuleExcludesUserRole Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleExcludesUserRole type exposes the following members.

Constructors

Name | Description
PromotionRuleExcludesUserRole |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RoleName |
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleExcludesUserRole Class
InSite.Model Namespace


PromotionRuleExcludesUserRole Constructor

[image]

.NET Framework Class Library
PromotionRuleExcludesUserRole Constructor
PromotionRuleExcludesUserRole Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleExcludesUserRole()
Visual C++
public:
PromotionRuleExcludesUserRole()
JavaScript
InSite.Model.PromotionRuleExcludesUserRole = function();

See Also

PromotionRuleExcludesUserRole Class
InSite.Model Namespace


PromotionRuleExcludesUserRole Fields

[image] [image]

.NET Framework Class Library
PromotionRuleExcludesUserRole Fields
PromotionRuleExcludesUserRole Class See Also Send Feedback

The PromotionRuleExcludesUserRole type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleExcludesUserRole Class
InSite.Model Namespace


PromotionRuleExcludesUserRole Methods

[image] [image]

.NET Framework Class Library
PromotionRuleExcludesUserRole Methods
PromotionRuleExcludesUserRole Class See Also Send Feedback

The PromotionRuleExcludesUserRole type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleExcludesUserRole Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleExcludesUserRole..::.IsValid Method
PromotionRuleExcludesUserRole Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleExcludesUserRole Class
InSite.Model Namespace


PromotionRuleExcludesUserRole Properties

[image] [image]

.NET Framework Class Library
PromotionRuleExcludesUserRole Properties
PromotionRuleExcludesUserRole Class See Also Send Feedback

The PromotionRuleExcludesUserRole type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RoleName |
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleExcludesUserRole Class
InSite.Model Namespace


RoleName Property

[image]

.NET Framework Class Library
PromotionRuleExcludesUserRole..::.RoleName Property
PromotionRuleExcludesUserRole Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property RoleName As String
C#
[DataMemberAttribute]
[SortField]
public virtual string RoleName { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ RoleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_roleName();
function set_roleName(value);

See Also

PromotionRuleExcludesUserRole Class
InSite.Model Namespace


PromotionRuleIncludesCustomer Class

[image]

.NET Framework Class Library
PromotionRuleIncludesCustomer Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleIncludesCustomer _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleIncludesCustomer : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleIncludesCustomer : public PromotionRule
JavaScript
InSite.Model.PromotionRuleIncludesCustomer = function();

Type.createClass(
    'InSite.Model.PromotionRuleIncludesCustomer',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleIncludesCustomer

See Also

PromotionRuleIncludesCustomer Members
InSite.Model Namespace


PromotionRuleIncludesCustomer Members

[image] [image]

.NET Framework Class Library
PromotionRuleIncludesCustomer Members
PromotionRuleIncludesCustomer Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleIncludesCustomer type exposes the following members.

Constructors

Name | Description
PromotionRuleIncludesCustomer |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
Customer |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleIncludesCustomer Class
InSite.Model Namespace


PromotionRuleIncludesCustomer Constructor

[image]

.NET Framework Class Library
PromotionRuleIncludesCustomer Constructor
PromotionRuleIncludesCustomer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleIncludesCustomer()
Visual C++
public:
PromotionRuleIncludesCustomer()
JavaScript
InSite.Model.PromotionRuleIncludesCustomer = function();

See Also

PromotionRuleIncludesCustomer Class
InSite.Model Namespace


PromotionRuleIncludesCustomer Fields

[image] [image]

.NET Framework Class Library
PromotionRuleIncludesCustomer Fields
PromotionRuleIncludesCustomer Class See Also Send Feedback

The PromotionRuleIncludesCustomer type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleIncludesCustomer Class
InSite.Model Namespace


PromotionRuleIncludesCustomer Methods

[image] [image]

.NET Framework Class Library
PromotionRuleIncludesCustomer Methods
PromotionRuleIncludesCustomer Class See Also Send Feedback

The PromotionRuleIncludesCustomer type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleIncludesCustomer Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleIncludesCustomer..::.IsValid Method
PromotionRuleIncludesCustomer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleIncludesCustomer Class
InSite.Model Namespace


PromotionRuleIncludesCustomer Properties

[image] [image]

.NET Framework Class Library
PromotionRuleIncludesCustomer Properties
PromotionRuleIncludesCustomer Class See Also Send Feedback

The PromotionRuleIncludesCustomer type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
Customer |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleIncludesCustomer Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
PromotionRuleIncludesCustomer..::.Customer Property
PromotionRuleIncludesCustomer Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Customer As Customer
C#
[SortField]
[DataMemberAttribute]
public virtual Customer Customer { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

PromotionRuleIncludesCustomer Class
InSite.Model Namespace


PromotionRuleIncludesUserRole Class

[image]

.NET Framework Class Library
PromotionRuleIncludesUserRole Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleIncludesUserRole _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleIncludesUserRole : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleIncludesUserRole : public PromotionRule
JavaScript
InSite.Model.PromotionRuleIncludesUserRole = function();

Type.createClass(
    'InSite.Model.PromotionRuleIncludesUserRole',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleIncludesUserRole

See Also

PromotionRuleIncludesUserRole Members
InSite.Model Namespace


PromotionRuleIncludesUserRole Members

[image] [image]

.NET Framework Class Library
PromotionRuleIncludesUserRole Members
PromotionRuleIncludesUserRole Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleIncludesUserRole type exposes the following members.

Constructors

Name | Description
PromotionRuleIncludesUserRole |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RoleName |
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleIncludesUserRole Class
InSite.Model Namespace


PromotionRuleIncludesUserRole Constructor

[image]

.NET Framework Class Library
PromotionRuleIncludesUserRole Constructor
PromotionRuleIncludesUserRole Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleIncludesUserRole()
Visual C++
public:
PromotionRuleIncludesUserRole()
JavaScript
InSite.Model.PromotionRuleIncludesUserRole = function();

See Also

PromotionRuleIncludesUserRole Class
InSite.Model Namespace


PromotionRuleIncludesUserRole Fields

[image] [image]

.NET Framework Class Library
PromotionRuleIncludesUserRole Fields
PromotionRuleIncludesUserRole Class See Also Send Feedback

The PromotionRuleIncludesUserRole type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleIncludesUserRole Class
InSite.Model Namespace


PromotionRuleIncludesUserRole Methods

[image] [image]

.NET Framework Class Library
PromotionRuleIncludesUserRole Methods
PromotionRuleIncludesUserRole Class See Also Send Feedback

The PromotionRuleIncludesUserRole type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleIncludesUserRole Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleIncludesUserRole..::.IsValid Method
PromotionRuleIncludesUserRole Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleIncludesUserRole Class
InSite.Model Namespace


PromotionRuleIncludesUserRole Properties

[image] [image]

.NET Framework Class Library
PromotionRuleIncludesUserRole Properties
PromotionRuleIncludesUserRole Class See Also Send Feedback

The PromotionRuleIncludesUserRole type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RoleName |
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleIncludesUserRole Class
InSite.Model Namespace


RoleName Property

[image]

.NET Framework Class Library
PromotionRuleIncludesUserRole..::.RoleName Property
PromotionRuleIncludesUserRole Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property RoleName As String
C#
[SortField]
[DataMemberAttribute]
public virtual string RoleName { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ RoleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_roleName();
function set_roleName(value);

See Also

PromotionRuleIncludesUserRole Class
InSite.Model Namespace


PromotionRuleMaximumPromotionUsedQuanity Class

[image]

.NET Framework Class Library
PromotionRuleMaximumPromotionUsedQuanity Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleMaximumPromotionUsedQuanity _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleMaximumPromotionUsedQuanity : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleMaximumPromotionUsedQuanity : public PromotionRule
JavaScript
InSite.Model.PromotionRuleMaximumPromotionUsedQuanity = function();

Type.createClass(
    'InSite.Model.PromotionRuleMaximumPromotionUsedQuanity',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleMaximumPromotionUsedQuanity

See Also

PromotionRuleMaximumPromotionUsedQuanity Members
InSite.Model Namespace


PromotionRuleMaximumPromotionUsedQuanity Members

[image] [image]

.NET Framework Class Library
PromotionRuleMaximumPromotionUsedQuanity Members
PromotionRuleMaximumPromotionUsedQuanity Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleMaximumPromotionUsedQuanity type exposes the following members.

Constructors

Name | Description
PromotionRuleMaximumPromotionUsedQuanity |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleMaximumPromotionUsedQuanity Class
InSite.Model Namespace


PromotionRuleMaximumPromotionUsedQuanity Constructor

[image]

.NET Framework Class Library
PromotionRuleMaximumPromotionUsedQuanity Constructor
PromotionRuleMaximumPromotionUsedQuanity Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleMaximumPromotionUsedQuanity()
Visual C++
public:
PromotionRuleMaximumPromotionUsedQuanity()
JavaScript
InSite.Model.PromotionRuleMaximumPromotionUsedQuanity = function();

See Also

PromotionRuleMaximumPromotionUsedQuanity Class
InSite.Model Namespace


PromotionRuleMaximumPromotionUsedQuanity Fields

[image] [image]

.NET Framework Class Library
PromotionRuleMaximumPromotionUsedQuanity Fields
PromotionRuleMaximumPromotionUsedQuanity Class See Also Send Feedback

The PromotionRuleMaximumPromotionUsedQuanity type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleMaximumPromotionUsedQuanity Class
InSite.Model Namespace


PromotionRuleMaximumPromotionUsedQuanity Methods

[image] [image]

.NET Framework Class Library
PromotionRuleMaximumPromotionUsedQuanity Methods
PromotionRuleMaximumPromotionUsedQuanity Class See Also Send Feedback

The PromotionRuleMaximumPromotionUsedQuanity type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleMaximumPromotionUsedQuanity Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleMaximumPromotionUsedQuanity..::.IsValid Method
PromotionRuleMaximumPromotionUsedQuanity Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleMaximumPromotionUsedQuanity Class
InSite.Model Namespace


PromotionRuleMaximumPromotionUsedQuanity Properties

[image] [image]

.NET Framework Class Library
PromotionRuleMaximumPromotionUsedQuanity Properties
PromotionRuleMaximumPromotionUsedQuanity Class See Also Send Feedback

The PromotionRuleMaximumPromotionUsedQuanity type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleMaximumPromotionUsedQuanity Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionRuleMaximumPromotionUsedQuanity..::.Amount Property
PromotionRuleMaximumPromotionUsedQuanity Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionRuleMaximumPromotionUsedQuanity Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProduct Class

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderContainsOrderedProduct _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderContainsOrderedProduct : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderContainsOrderedProduct : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderContainsOrderedProduct = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderContainsOrderedProduct',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderContainsOrderedProduct

See Also

PromotionRuleOrderContainsOrderedProduct Members
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProduct Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct Members
PromotionRuleOrderContainsOrderedProduct Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderContainsOrderedProduct type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderContainsOrderedProduct |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProduct Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProduct Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct Constructor
PromotionRuleOrderContainsOrderedProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderContainsOrderedProduct()
Visual C++
public:
PromotionRuleOrderContainsOrderedProduct()
JavaScript
InSite.Model.PromotionRuleOrderContainsOrderedProduct = function();

See Also

PromotionRuleOrderContainsOrderedProduct Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProduct Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct Fields
PromotionRuleOrderContainsOrderedProduct Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProduct type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProduct Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProduct Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct Methods
PromotionRuleOrderContainsOrderedProduct Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProduct type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProduct Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct..::.IsValid Method
PromotionRuleOrderContainsOrderedProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderContainsOrderedProduct Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProduct Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct Properties
PromotionRuleOrderContainsOrderedProduct Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProduct type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProduct Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct..::.Amount Property
PromotionRuleOrderContainsOrderedProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionRuleOrderContainsOrderedProduct Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProduct..::.Product Property
PromotionRuleOrderContainsOrderedProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Product As Product
C#
[DataMemberAttribute]
public virtual Product Product { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

PromotionRuleOrderContainsOrderedProduct Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductInCategory Class

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderContainsOrderedProductInCategory _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderContainsOrderedProductInCategory : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderContainsOrderedProductInCategory : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderContainsOrderedProductInCategory = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderContainsOrderedProductInCategory',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderContainsOrderedProductInCategory

See Also

PromotionRuleOrderContainsOrderedProductInCategory Members
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductInCategory Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory Members
PromotionRuleOrderContainsOrderedProductInCategory Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderContainsOrderedProductInCategory type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderContainsOrderedProductInCategory |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DollarOrQuantity |
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductInCategory Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory Constructor
PromotionRuleOrderContainsOrderedProductInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderContainsOrderedProductInCategory()
Visual C++
public:
PromotionRuleOrderContainsOrderedProductInCategory()
JavaScript
InSite.Model.PromotionRuleOrderContainsOrderedProductInCategory = function();

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductInCategory Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory Fields
PromotionRuleOrderContainsOrderedProductInCategory Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProductInCategory type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductInCategory Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory Methods
PromotionRuleOrderContainsOrderedProductInCategory Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProductInCategory type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory..::.IsValid Method
PromotionRuleOrderContainsOrderedProductInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductInCategory Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory Properties
PromotionRuleOrderContainsOrderedProductInCategory Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProductInCategory type exposes the following members.

Properties

Name | Description
Amount |
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DollarOrQuantity |
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory..::.Amount Property
PromotionRuleOrderContainsOrderedProductInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Amount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal Amount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory..::.Category Property
PromotionRuleOrderContainsOrderedProductInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Category As Category
C#
[DataMemberAttribute]
public virtual Category Category { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


DollarOrQuantity Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductInCategory..::.DollarOrQuantity Property
PromotionRuleOrderContainsOrderedProductInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DollarOrQuantity As String
C#
[DataMemberAttribute]
public virtual string DollarOrQuantity { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DollarOrQuantity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dollarOrQuantity();
function set_dollarOrQuantity(value);

See Also

PromotionRuleOrderContainsOrderedProductInCategory Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductOfVendor Class

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderContainsOrderedProductOfVendor _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderContainsOrderedProductOfVendor : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderContainsOrderedProductOfVendor : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderContainsOrderedProductOfVendor = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderContainsOrderedProductOfVendor',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderContainsOrderedProductOfVendor

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Members
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductOfVendor Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor Members
PromotionRuleOrderContainsOrderedProductOfVendor Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderContainsOrderedProductOfVendor type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderContainsOrderedProductOfVendor |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DollarOrQuantity |
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Vendor |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductOfVendor Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor Constructor
PromotionRuleOrderContainsOrderedProductOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderContainsOrderedProductOfVendor()
Visual C++
public:
PromotionRuleOrderContainsOrderedProductOfVendor()
JavaScript
InSite.Model.PromotionRuleOrderContainsOrderedProductOfVendor = function();

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductOfVendor Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor Fields
PromotionRuleOrderContainsOrderedProductOfVendor Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProductOfVendor type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductOfVendor Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor Methods
PromotionRuleOrderContainsOrderedProductOfVendor Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProductOfVendor type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor..::.IsValid Method
PromotionRuleOrderContainsOrderedProductOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


PromotionRuleOrderContainsOrderedProductOfVendor Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor Properties
PromotionRuleOrderContainsOrderedProductOfVendor Class See Also Send Feedback

The PromotionRuleOrderContainsOrderedProductOfVendor type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DollarOrQuantity |
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Vendor |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor..::.Amount Property
PromotionRuleOrderContainsOrderedProductOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


DollarOrQuantity Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor..::.DollarOrQuantity Property
PromotionRuleOrderContainsOrderedProductOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DollarOrQuantity As String
C#
[DataMemberAttribute]
public virtual string DollarOrQuantity { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DollarOrQuantity {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dollarOrQuantity();
function set_dollarOrQuantity(value);

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


Vendor Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsOrderedProductOfVendor..::.Vendor Property
PromotionRuleOrderContainsOrderedProductOfVendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Vendor As Vendor
C#
[DataMemberAttribute]
public virtual Vendor Vendor { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Vendor^ Vendor {
    Vendor^ get ();
    void set (Vendor^ value);
}
JavaScript
function get_vendor();
function set_vendor(value);

See Also

PromotionRuleOrderContainsOrderedProductOfVendor Class
InSite.Model Namespace


PromotionRuleOrderContainsPromotion Class

[image]

.NET Framework Class Library
PromotionRuleOrderContainsPromotion Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderContainsPromotion _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderContainsPromotion : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderContainsPromotion : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderContainsPromotion = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderContainsPromotion',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderContainsPromotion

See Also

PromotionRuleOrderContainsPromotion Members
InSite.Model Namespace


PromotionRuleOrderContainsPromotion Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsPromotion Members
PromotionRuleOrderContainsPromotion Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderContainsPromotion type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderContainsPromotion |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
ContainedPromotion |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsPromotion Class
InSite.Model Namespace


PromotionRuleOrderContainsPromotion Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderContainsPromotion Constructor
PromotionRuleOrderContainsPromotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderContainsPromotion()
Visual C++
public:
PromotionRuleOrderContainsPromotion()
JavaScript
InSite.Model.PromotionRuleOrderContainsPromotion = function();

See Also

PromotionRuleOrderContainsPromotion Class
InSite.Model Namespace


PromotionRuleOrderContainsPromotion Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsPromotion Fields
PromotionRuleOrderContainsPromotion Class See Also Send Feedback

The PromotionRuleOrderContainsPromotion type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsPromotion Class
InSite.Model Namespace


PromotionRuleOrderContainsPromotion Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsPromotion Methods
PromotionRuleOrderContainsPromotion Class See Also Send Feedback

The PromotionRuleOrderContainsPromotion type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsPromotion Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderContainsPromotion..::.IsValid Method
PromotionRuleOrderContainsPromotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderContainsPromotion Class
InSite.Model Namespace


PromotionRuleOrderContainsPromotion Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderContainsPromotion Properties
PromotionRuleOrderContainsPromotion Class See Also Send Feedback

The PromotionRuleOrderContainsPromotion type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
ContainedPromotion |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderContainsPromotion Class
InSite.Model Namespace


ContainedPromotion Property

[image]

.NET Framework Class Library
PromotionRuleOrderContainsPromotion..::.ContainedPromotion Property
PromotionRuleOrderContainsPromotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property ContainedPromotion As Promotion
C#
[DataMemberAttribute]
[SortField]
public virtual Promotion ContainedPromotion { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Promotion^ ContainedPromotion {
    Promotion^ get ();
    void set (Promotion^ value);
}
JavaScript
function get_containedPromotion();
function set_containedPromotion(value);

See Also

PromotionRuleOrderContainsPromotion Class
InSite.Model Namespace


PromotionRuleOrderDoesNotContainPromotion Class

[image]

.NET Framework Class Library
PromotionRuleOrderDoesNotContainPromotion Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderDoesNotContainPromotion _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderDoesNotContainPromotion : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderDoesNotContainPromotion : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderDoesNotContainPromotion = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderDoesNotContainPromotion',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderDoesNotContainPromotion

See Also

PromotionRuleOrderDoesNotContainPromotion Members
InSite.Model Namespace


PromotionRuleOrderDoesNotContainPromotion Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderDoesNotContainPromotion Members
PromotionRuleOrderDoesNotContainPromotion Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderDoesNotContainPromotion type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderDoesNotContainPromotion |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
ContainedPromotion |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderDoesNotContainPromotion Class
InSite.Model Namespace


PromotionRuleOrderDoesNotContainPromotion Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderDoesNotContainPromotion Constructor
PromotionRuleOrderDoesNotContainPromotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderDoesNotContainPromotion()
Visual C++
public:
PromotionRuleOrderDoesNotContainPromotion()
JavaScript
InSite.Model.PromotionRuleOrderDoesNotContainPromotion = function();

See Also

PromotionRuleOrderDoesNotContainPromotion Class
InSite.Model Namespace


PromotionRuleOrderDoesNotContainPromotion Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderDoesNotContainPromotion Fields
PromotionRuleOrderDoesNotContainPromotion Class See Also Send Feedback

The PromotionRuleOrderDoesNotContainPromotion type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderDoesNotContainPromotion Class
InSite.Model Namespace


PromotionRuleOrderDoesNotContainPromotion Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderDoesNotContainPromotion Methods
PromotionRuleOrderDoesNotContainPromotion Class See Also Send Feedback

The PromotionRuleOrderDoesNotContainPromotion type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderDoesNotContainPromotion Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderDoesNotContainPromotion..::.IsValid Method
PromotionRuleOrderDoesNotContainPromotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderDoesNotContainPromotion Class
InSite.Model Namespace


PromotionRuleOrderDoesNotContainPromotion Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderDoesNotContainPromotion Properties
PromotionRuleOrderDoesNotContainPromotion Class See Also Send Feedback

The PromotionRuleOrderDoesNotContainPromotion type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
ContainedPromotion |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderDoesNotContainPromotion Class
InSite.Model Namespace


ContainedPromotion Property

[image]

.NET Framework Class Library
PromotionRuleOrderDoesNotContainPromotion..::.ContainedPromotion Property
PromotionRuleOrderDoesNotContainPromotion Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property ContainedPromotion As Promotion
C#
[SortField]
[DataMemberAttribute]
public virtual Promotion ContainedPromotion { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Promotion^ ContainedPromotion {
    Promotion^ get ();
    void set (Promotion^ value);
}
JavaScript
function get_containedPromotion();
function set_containedPromotion(value);

See Also

PromotionRuleOrderDoesNotContainPromotion Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToCountry Class

[image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToCountry Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderNotShippingToCountry _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderNotShippingToCountry : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderNotShippingToCountry : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderNotShippingToCountry = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderNotShippingToCountry',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderNotShippingToCountry

See Also

PromotionRuleOrderNotShippingToCountry Members
InSite.Model Namespace


PromotionRuleOrderNotShippingToCountry Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToCountry Members
PromotionRuleOrderNotShippingToCountry Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderNotShippingToCountry type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderNotShippingToCountry |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderNotShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToCountry Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToCountry Constructor
PromotionRuleOrderNotShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderNotShippingToCountry()
Visual C++
public:
PromotionRuleOrderNotShippingToCountry()
JavaScript
InSite.Model.PromotionRuleOrderNotShippingToCountry = function();

See Also

PromotionRuleOrderNotShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToCountry Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToCountry Fields
PromotionRuleOrderNotShippingToCountry Class See Also Send Feedback

The PromotionRuleOrderNotShippingToCountry type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderNotShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToCountry Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToCountry Methods
PromotionRuleOrderNotShippingToCountry Class See Also Send Feedback

The PromotionRuleOrderNotShippingToCountry type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderNotShippingToCountry Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToCountry..::.IsValid Method
PromotionRuleOrderNotShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderNotShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToCountry Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToCountry Properties
PromotionRuleOrderNotShippingToCountry Class See Also Send Feedback

The PromotionRuleOrderNotShippingToCountry type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderNotShippingToCountry Class
InSite.Model Namespace


Country Property

[image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToCountry..::.Country Property
PromotionRuleOrderNotShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Country As Country
C#
[SortField]
[DataMemberAttribute]
public virtual Country Country { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Country^ Country {
    Country^ get ();
    void set (Country^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

PromotionRuleOrderNotShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToState Class

[image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToState Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderNotShippingToState _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderNotShippingToState : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderNotShippingToState : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderNotShippingToState = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderNotShippingToState',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderNotShippingToState

See Also

PromotionRuleOrderNotShippingToState Members
InSite.Model Namespace


PromotionRuleOrderNotShippingToState Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToState Members
PromotionRuleOrderNotShippingToState Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderNotShippingToState type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderNotShippingToState |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderNotShippingToState Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToState Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToState Constructor
PromotionRuleOrderNotShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderNotShippingToState()
Visual C++
public:
PromotionRuleOrderNotShippingToState()
JavaScript
InSite.Model.PromotionRuleOrderNotShippingToState = function();

See Also

PromotionRuleOrderNotShippingToState Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToState Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToState Fields
PromotionRuleOrderNotShippingToState Class See Also Send Feedback

The PromotionRuleOrderNotShippingToState type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderNotShippingToState Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToState Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToState Methods
PromotionRuleOrderNotShippingToState Class See Also Send Feedback

The PromotionRuleOrderNotShippingToState type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderNotShippingToState Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToState..::.IsValid Method
PromotionRuleOrderNotShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderNotShippingToState Class
InSite.Model Namespace


PromotionRuleOrderNotShippingToState Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToState Properties
PromotionRuleOrderNotShippingToState Class See Also Send Feedback

The PromotionRuleOrderNotShippingToState type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderNotShippingToState Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
PromotionRuleOrderNotShippingToState..::.State Property
PromotionRuleOrderNotShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property State As State
C#
[DataMemberAttribute]
[SortField]
public virtual State State { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property State^ State {
    State^ get ();
    void set (State^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

PromotionRuleOrderNotShippingToState Class
InSite.Model Namespace


PromotionRuleOrderProductTotalGreaterThan Class

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalGreaterThan Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderProductTotalGreaterThan _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderProductTotalGreaterThan : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderProductTotalGreaterThan : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderProductTotalGreaterThan = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderProductTotalGreaterThan',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderProductTotalGreaterThan

See Also

PromotionRuleOrderProductTotalGreaterThan Members
InSite.Model Namespace


PromotionRuleOrderProductTotalGreaterThan Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderProductTotalGreaterThan Members
PromotionRuleOrderProductTotalGreaterThan Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderProductTotalGreaterThan type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderProductTotalGreaterThan |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderProductTotalGreaterThan Class
InSite.Model Namespace


PromotionRuleOrderProductTotalGreaterThan Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalGreaterThan Constructor
PromotionRuleOrderProductTotalGreaterThan Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderProductTotalGreaterThan()
Visual C++
public:
PromotionRuleOrderProductTotalGreaterThan()
JavaScript
InSite.Model.PromotionRuleOrderProductTotalGreaterThan = function();

See Also

PromotionRuleOrderProductTotalGreaterThan Class
InSite.Model Namespace


PromotionRuleOrderProductTotalGreaterThan Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderProductTotalGreaterThan Fields
PromotionRuleOrderProductTotalGreaterThan Class See Also Send Feedback

The PromotionRuleOrderProductTotalGreaterThan type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderProductTotalGreaterThan Class
InSite.Model Namespace


PromotionRuleOrderProductTotalGreaterThan Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderProductTotalGreaterThan Methods
PromotionRuleOrderProductTotalGreaterThan Class See Also Send Feedback

The PromotionRuleOrderProductTotalGreaterThan type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderProductTotalGreaterThan Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalGreaterThan..::.IsValid Method
PromotionRuleOrderProductTotalGreaterThan Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderProductTotalGreaterThan Class
InSite.Model Namespace


PromotionRuleOrderProductTotalGreaterThan Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderProductTotalGreaterThan Properties
PromotionRuleOrderProductTotalGreaterThan Class See Also Send Feedback

The PromotionRuleOrderProductTotalGreaterThan type exposes the following members.

Properties

Name | Description
Amount |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderProductTotalGreaterThan Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalGreaterThan..::.Amount Property
PromotionRuleOrderProductTotalGreaterThan Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Amount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal Amount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

PromotionRuleOrderProductTotalGreaterThan Class
InSite.Model Namespace


PromotionRuleOrderProductTotalIsInRange Class

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderProductTotalIsInRange _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderProductTotalIsInRange : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderProductTotalIsInRange : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderProductTotalIsInRange = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderProductTotalIsInRange',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderProductTotalIsInRange

See Also

PromotionRuleOrderProductTotalIsInRange Members
InSite.Model Namespace


PromotionRuleOrderProductTotalIsInRange Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange Members
PromotionRuleOrderProductTotalIsInRange Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderProductTotalIsInRange type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderProductTotalIsInRange |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LowerRange |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UpperRange |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderProductTotalIsInRange Class
InSite.Model Namespace


PromotionRuleOrderProductTotalIsInRange Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange Constructor
PromotionRuleOrderProductTotalIsInRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderProductTotalIsInRange()
Visual C++
public:
PromotionRuleOrderProductTotalIsInRange()
JavaScript
InSite.Model.PromotionRuleOrderProductTotalIsInRange = function();

See Also

PromotionRuleOrderProductTotalIsInRange Class
InSite.Model Namespace


PromotionRuleOrderProductTotalIsInRange Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange Fields
PromotionRuleOrderProductTotalIsInRange Class See Also Send Feedback

The PromotionRuleOrderProductTotalIsInRange type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderProductTotalIsInRange Class
InSite.Model Namespace


PromotionRuleOrderProductTotalIsInRange Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange Methods
PromotionRuleOrderProductTotalIsInRange Class See Also Send Feedback

The PromotionRuleOrderProductTotalIsInRange type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderProductTotalIsInRange Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange..::.IsValid Method
PromotionRuleOrderProductTotalIsInRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderProductTotalIsInRange Class
InSite.Model Namespace


PromotionRuleOrderProductTotalIsInRange Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange Properties
PromotionRuleOrderProductTotalIsInRange Class See Also Send Feedback

The PromotionRuleOrderProductTotalIsInRange type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LowerRange |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UpperRange |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderProductTotalIsInRange Class
InSite.Model Namespace


LowerRange Property

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange..::.LowerRange Property
PromotionRuleOrderProductTotalIsInRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property LowerRange As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal LowerRange { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal LowerRange {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_lowerRange();
function set_lowerRange(value);

See Also

PromotionRuleOrderProductTotalIsInRange Class
InSite.Model Namespace


UpperRange Property

[image]

.NET Framework Class Library
PromotionRuleOrderProductTotalIsInRange..::.UpperRange Property
PromotionRuleOrderProductTotalIsInRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UpperRange As Decimal
C#
[DataMemberAttribute]
public virtual decimal UpperRange { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal UpperRange {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_upperRange();
function set_upperRange(value);

See Also

PromotionRuleOrderProductTotalIsInRange Class
InSite.Model Namespace


PromotionRuleOrderShippingToCountry Class

[image]

.NET Framework Class Library
PromotionRuleOrderShippingToCountry Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderShippingToCountry _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderShippingToCountry : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderShippingToCountry : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderShippingToCountry = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderShippingToCountry',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderShippingToCountry

See Also

PromotionRuleOrderShippingToCountry Members
InSite.Model Namespace


PromotionRuleOrderShippingToCountry Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShippingToCountry Members
PromotionRuleOrderShippingToCountry Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderShippingToCountry type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderShippingToCountry |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderShippingToCountry Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderShippingToCountry Constructor
PromotionRuleOrderShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderShippingToCountry()
Visual C++
public:
PromotionRuleOrderShippingToCountry()
JavaScript
InSite.Model.PromotionRuleOrderShippingToCountry = function();

See Also

PromotionRuleOrderShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderShippingToCountry Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShippingToCountry Fields
PromotionRuleOrderShippingToCountry Class See Also Send Feedback

The PromotionRuleOrderShippingToCountry type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderShippingToCountry Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShippingToCountry Methods
PromotionRuleOrderShippingToCountry Class See Also Send Feedback

The PromotionRuleOrderShippingToCountry type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShippingToCountry Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderShippingToCountry..::.IsValid Method
PromotionRuleOrderShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderShippingToCountry Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShippingToCountry Properties
PromotionRuleOrderShippingToCountry Class See Also Send Feedback

The PromotionRuleOrderShippingToCountry type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShippingToCountry Class
InSite.Model Namespace


Country Property

[image]

.NET Framework Class Library
PromotionRuleOrderShippingToCountry..::.Country Property
PromotionRuleOrderShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Country As Country
C#
[SortField]
[DataMemberAttribute]
public virtual Country Country { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Country^ Country {
    Country^ get ();
    void set (Country^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

PromotionRuleOrderShippingToCountry Class
InSite.Model Namespace


PromotionRuleOrderShippingToState Class

[image]

.NET Framework Class Library
PromotionRuleOrderShippingToState Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderShippingToState _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderShippingToState : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderShippingToState : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderShippingToState = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderShippingToState',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderShippingToState

See Also

PromotionRuleOrderShippingToState Members
InSite.Model Namespace


PromotionRuleOrderShippingToState Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShippingToState Members
PromotionRuleOrderShippingToState Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderShippingToState type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderShippingToState |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShippingToState Class
InSite.Model Namespace


PromotionRuleOrderShippingToState Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderShippingToState Constructor
PromotionRuleOrderShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderShippingToState()
Visual C++
public:
PromotionRuleOrderShippingToState()
JavaScript
InSite.Model.PromotionRuleOrderShippingToState = function();

See Also

PromotionRuleOrderShippingToState Class
InSite.Model Namespace


PromotionRuleOrderShippingToState Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShippingToState Fields
PromotionRuleOrderShippingToState Class See Also Send Feedback

The PromotionRuleOrderShippingToState type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShippingToState Class
InSite.Model Namespace


PromotionRuleOrderShippingToState Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShippingToState Methods
PromotionRuleOrderShippingToState Class See Also Send Feedback

The PromotionRuleOrderShippingToState type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShippingToState Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderShippingToState..::.IsValid Method
PromotionRuleOrderShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderShippingToState Class
InSite.Model Namespace


PromotionRuleOrderShippingToState Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShippingToState Properties
PromotionRuleOrderShippingToState Class See Also Send Feedback

The PromotionRuleOrderShippingToState type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShippingToState Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
PromotionRuleOrderShippingToState..::.State Property
PromotionRuleOrderShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property State As State
C#
[DataMemberAttribute]
[SortField]
public virtual State State { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property State^ State {
    State^ get ();
    void set (State^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

PromotionRuleOrderShippingToState Class
InSite.Model Namespace


PromotionRuleOrderShipViaMatches Class

[image]

.NET Framework Class Library
PromotionRuleOrderShipViaMatches Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleOrderShipViaMatches _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleOrderShipViaMatches : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleOrderShipViaMatches : public PromotionRule
JavaScript
InSite.Model.PromotionRuleOrderShipViaMatches = function();

Type.createClass(
    'InSite.Model.PromotionRuleOrderShipViaMatches',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleOrderShipViaMatches

See Also

PromotionRuleOrderShipViaMatches Members
InSite.Model Namespace


PromotionRuleOrderShipViaMatches Members

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShipViaMatches Members
PromotionRuleOrderShipViaMatches Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleOrderShipViaMatches type exposes the following members.

Constructors

Name | Description
PromotionRuleOrderShipViaMatches |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShipViaMatches Class
InSite.Model Namespace


PromotionRuleOrderShipViaMatches Constructor

[image]

.NET Framework Class Library
PromotionRuleOrderShipViaMatches Constructor
PromotionRuleOrderShipViaMatches Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleOrderShipViaMatches()
Visual C++
public:
PromotionRuleOrderShipViaMatches()
JavaScript
InSite.Model.PromotionRuleOrderShipViaMatches = function();

See Also

PromotionRuleOrderShipViaMatches Class
InSite.Model Namespace


PromotionRuleOrderShipViaMatches Fields

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShipViaMatches Fields
PromotionRuleOrderShipViaMatches Class See Also Send Feedback

The PromotionRuleOrderShipViaMatches type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShipViaMatches Class
InSite.Model Namespace


PromotionRuleOrderShipViaMatches Methods

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShipViaMatches Methods
PromotionRuleOrderShipViaMatches Class See Also Send Feedback

The PromotionRuleOrderShipViaMatches type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShipViaMatches Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleOrderShipViaMatches..::.IsValid Method
PromotionRuleOrderShipViaMatches Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleOrderShipViaMatches Class
InSite.Model Namespace


PromotionRuleOrderShipViaMatches Properties

[image] [image]

.NET Framework Class Library
PromotionRuleOrderShipViaMatches Properties
PromotionRuleOrderShipViaMatches Class See Also Send Feedback

The PromotionRuleOrderShipViaMatches type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleOrderShipViaMatches Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
PromotionRuleOrderShipViaMatches..::.ShipVia Property
PromotionRuleOrderShipViaMatches Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property ShipVia As ShipVia
C#
[SortField]
[DataMemberAttribute]
public virtual ShipVia ShipVia { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

PromotionRuleOrderShipViaMatches Class
InSite.Model Namespace


PromotionRuleValidPromotionCode Class

[image]

.NET Framework Class Library
PromotionRuleValidPromotionCode Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class PromotionRuleValidPromotionCode _
    Inherits PromotionRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class PromotionRuleValidPromotionCode : PromotionRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class PromotionRuleValidPromotionCode : public PromotionRule
JavaScript
InSite.Model.PromotionRuleValidPromotionCode = function();

Type.createClass(
    'InSite.Model.PromotionRuleValidPromotionCode',
    InSite.Model.PromotionRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( PromotionRule >)>)
InSite.Model..::.PromotionRule
InSite.Model..::.PromotionRuleValidPromotionCode

See Also

PromotionRuleValidPromotionCode Members
InSite.Model Namespace


PromotionRuleValidPromotionCode Members

[image] [image]

.NET Framework Class Library
PromotionRuleValidPromotionCode Members
PromotionRuleValidPromotionCode Class Constructors Methods Fields Properties See Also Send Feedback

The PromotionRuleValidPromotionCode type exposes the following members.

Constructors

Name | Description
PromotionRuleValidPromotionCode |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Code |
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleValidPromotionCode Class
InSite.Model Namespace


PromotionRuleValidPromotionCode Constructor

[image]

.NET Framework Class Library
PromotionRuleValidPromotionCode Constructor
PromotionRuleValidPromotionCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public PromotionRuleValidPromotionCode()
Visual C++
public:
PromotionRuleValidPromotionCode()
JavaScript
InSite.Model.PromotionRuleValidPromotionCode = function();

See Also

PromotionRuleValidPromotionCode Class
InSite.Model Namespace


PromotionRuleValidPromotionCode Fields

[image] [image]

.NET Framework Class Library
PromotionRuleValidPromotionCode Fields
PromotionRuleValidPromotionCode Class See Also Send Feedback

The PromotionRuleValidPromotionCode type exposes the following members.

Fields

Name | Description
_condition | (Inherited from PromotionRule.)
_executionGroup | (Inherited from PromotionRule.)
_executionOrder | (Inherited from PromotionRule.)
_promotion | (Inherited from PromotionRule.)
_promotionRuleId | (Inherited from PromotionRule.)
_ruleName | (Inherited from PromotionRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleValidPromotionCode Class
InSite.Model Namespace


PromotionRuleValidPromotionCode Methods

[image] [image]

.NET Framework Class Library
PromotionRuleValidPromotionCode Methods
PromotionRuleValidPromotionCode Class See Also Send Feedback

The PromotionRuleValidPromotionCode type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides PromotionRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleValidPromotionCode Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
PromotionRuleValidPromotionCode..::.IsValid Method
PromotionRuleValidPromotionCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

PromotionRuleValidPromotionCode Class
InSite.Model Namespace


PromotionRuleValidPromotionCode Properties

[image] [image]

.NET Framework Class Library
PromotionRuleValidPromotionCode Properties
PromotionRuleValidPromotionCode Class See Also Send Feedback

The PromotionRuleValidPromotionCode type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Code |
Condition | (Inherited from PromotionRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from PromotionRule.)
ExecutionOrder | (Inherited from PromotionRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Promotion | (Inherited from PromotionRule.)
PromotionRuleId | (Inherited from PromotionRule.)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from PromotionRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

PromotionRuleValidPromotionCode Class
InSite.Model Namespace


Code Property

[image]

.NET Framework Class Library
PromotionRuleValidPromotionCode..::.Code Property
PromotionRuleValidPromotionCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Code As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Code { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Code {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_code();
function set_code(value);

See Also

PromotionRuleValidPromotionCode Class
InSite.Model Namespace


Restriction Class

[image]

.NET Framework Class Library
Restriction Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Restriction _
    Inherits ModelBase(Of Restriction)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Restriction : ModelBase<Restriction>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Restriction : public ModelBase<Restriction^>
JavaScript
InSite.Model.Restriction = function();

Type.createClass(
    'InSite.Model.Restriction',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Restriction>)>)
InSite.Model..::.Restriction

See Also

Restriction Members
InSite.Model Namespace


Restriction Members

[image] [image]

.NET Framework Class Library
Restriction Members
Restriction Class Constructors Methods Fields Properties See Also Send Feedback

The Restriction type exposes the following members.

Constructors

Name | Description
Restriction | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PassesRestriction |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RestrictionId |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
StateName |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Restriction Class
InSite.Model Namespace


Restriction Constructor

[image] [image]

.NET Framework Class Library
Restriction Constructor
Restriction Class See Also Send Feedback

Overload List

Name | Description
Restriction()()() |
Restriction(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Restriction Class
Restriction Members
InSite.Model Namespace


Restriction Constructor

[image]

.NET Framework Class Library
Restriction Constructor
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Restriction()
Visual C++
public:
Restriction()
JavaScript
InSite.Model.Restriction = function();

See Also

Restriction Class
Restriction Overload
InSite.Model Namespace


Restriction Constructor (SearchMode)

[image]

.NET Framework Class Library
Restriction Constructor (SearchMode)
Restriction Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Restriction(
    SearchMode searchMode
)
Visual C++
public:
Restriction(
    SearchMode searchMode
)
JavaScript
InSite.Model.Restriction = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Restriction Class
Restriction Overload
InSite.Model Namespace


Restriction Fields

[image] [image]

.NET Framework Class Library
Restriction Fields
Restriction Class See Also Send Feedback

The Restriction type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Restriction Class
InSite.Model Namespace


Restriction Methods

[image] [image]

.NET Framework Class Library
Restriction Methods
Restriction Class See Also Send Feedback

The Restriction type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PassesRestriction |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Restriction Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
Restriction..::.Copy Method
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As Restriction
C#
public virtual Restriction Copy()
Visual C++
public:
virtual Restriction^ Copy()
JavaScript
function copy();

See Also

Restriction Class
InSite.Model Namespace


PassesRestriction Method

[image]

.NET Framework Class Library
Restriction..::.PassesRestriction Method
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function PassesRestriction ( _
    customerOrder As CustomerOrder _
) As Boolean
C#
public virtual bool PassesRestriction(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual bool PassesRestriction(
    CustomerOrder^ customerOrder
)
JavaScript
function passesRestriction(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

Restriction Class
InSite.Model Namespace


Restriction Properties

[image] [image]

.NET Framework Class Library
Restriction Properties
Restriction Class See Also Send Feedback

The Restriction type exposes the following members.

Properties

Name | Description
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RestrictionId |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
StateName |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Restriction Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
Restriction..::.Category Property
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Category As Category
C#
public virtual Category Category { get; set; }
Visual C++
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

Restriction Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
Restriction..::.IsActive Property
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

Restriction Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Restriction..::.Name Property
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Restriction Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
Restriction..::.Product Property
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

Restriction Class
InSite.Model Namespace


RestrictionId Property

[image]

.NET Framework Class Library
Restriction..::.RestrictionId Property
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property RestrictionId As Guid
C#
public virtual Guid RestrictionId { get; set; }
Visual C++
public:
virtual property Guid RestrictionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_restrictionId();
function set_restrictionId(value);

See Also

Restriction Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
Restriction..::.State Property
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property State As State
C#
public virtual State State { get; set; }
Visual C++
public:
virtual property State^ State {
    State^ get ();
    void set (State^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

Restriction Class
InSite.Model Namespace


StateName Property

[image]

.NET Framework Class Library
Restriction..::.StateName Property
Restriction Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property StateName As String
C#
[DataMemberAttribute]
public virtual string StateName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ StateName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stateName();
function set_stateName(value);

See Also

Restriction Class
InSite.Model Namespace


Review Class

[image]

.NET Framework Class Library
Review Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Review _
    Inherits ModelBase(Of Review)
C#
[SerializableAttribute]
public class Review : ModelBase<Review>
Visual C++
[SerializableAttribute]
public ref class Review : public ModelBase<Review^>
JavaScript
InSite.Model.Review = function();

Type.createClass(
    'InSite.Model.Review',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Review>)>)
InSite.Model..::.Review

See Also

Review Members
InSite.Model Namespace


Review Members

[image] [image]

.NET Framework Class Library
Review Members
Review Class Constructors Methods Fields Properties See Also Send Feedback

The Review type exposes the following members.

Constructors

Name | Description
Review | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReviewId |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Review Class
InSite.Model Namespace


Review Constructor

[image] [image]

.NET Framework Class Library
Review Constructor
Review Class See Also Send Feedback

Overload List

Name | Description
Review()()() |
Review(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Review Class
Review Members
InSite.Model Namespace


Review Constructor

[image]

.NET Framework Class Library
Review Constructor
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Review()
Visual C++
public:
Review()
JavaScript
InSite.Model.Review = function();

See Also

Review Class
Review Overload
InSite.Model Namespace


Review Constructor (SearchMode)

[image]

.NET Framework Class Library
Review Constructor (SearchMode)
Review Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Review(
    SearchMode searchMode
)
Visual C++
public:
Review(
    SearchMode searchMode
)
JavaScript
InSite.Model.Review = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Review Class
Review Overload
InSite.Model Namespace


Review Fields

[image] [image]

.NET Framework Class Library
Review Fields
Review Class See Also Send Feedback

The Review type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Review Class
InSite.Model Namespace


Review Methods

[image] [image]

.NET Framework Class Library
Review Methods
Review Class See Also Send Feedback

The Review type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Review Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
Review..::.Copy Method
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As Review
C#
public virtual Review Copy()
Visual C++
public:
virtual Review^ Copy()
JavaScript
function copy();

See Also

Review Class
InSite.Model Namespace


Review Properties

[image] [image]

.NET Framework Class Library
Review Properties
Review Class See Also Send Feedback

The Review type exposes the following members.

Properties

Name | Description
Active |
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReviewId |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Review Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
Review..::.Active Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Active As DateTime
C#
public virtual DateTime Active { get; set; }
Visual C++
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

Review Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
Review..::.Category Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Category As Category
C#
public virtual Category Category { get; set; }
Visual C++
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

Review Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
Review..::.ContentManager Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

Review Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
Review..::.Deactivate Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

Review Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Review..::.Description Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Description As String
C#
public virtual string Description { get; set; }
Visual C++
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Review Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
Review..::.HtmlContent Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property HtmlContent As String
C#
public virtual string HtmlContent { get; set; }
Visual C++
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

Review Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Review..::.Name Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Review Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
Review..::.Product Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

Review Class
InSite.Model Namespace


ReviewId Property

[image]

.NET Framework Class Library
Review..::.ReviewId Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ReviewId As Guid
C#
public virtual Guid ReviewId { get; set; }
Visual C++
public:
virtual property Guid ReviewId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_reviewId();
function set_reviewId(value);

See Also

Review Class
InSite.Model Namespace


UserProfile Property

[image]

.NET Framework Class Library
Review..::.UserProfile Property
Review Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfile As UserProfile
C#
public virtual UserProfile UserProfile { get; set; }
Visual C++
public:
virtual property UserProfile^ UserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_userProfile();
function set_userProfile(value);

See Also

Review Class
InSite.Model Namespace


Role Class

[image]

.NET Framework Class Library
Role Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute> _
Public Class Role _
    Inherits ModelBase(Of Role)
C#
[SerializableAttribute]
[DataContractAttribute]
public class Role : ModelBase<Role>
Visual C++
[SerializableAttribute]
[DataContractAttribute]
public ref class Role : public ModelBase<Role^>
JavaScript
InSite.Model.Role = function();

Type.createClass(
    'InSite.Model.Role',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Role>)>)
InSite.Model..::.Role

See Also

Role Members
InSite.Model Namespace


Role Members

[image] [image]

.NET Framework Class Library
Role Members
Role Class Constructors Methods Fields Properties See Also Send Feedback

The Role type exposes the following members.

Constructors

Name | Description
Role | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
SOAGetList |
SOAUpdate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RoleId |
RoleName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Role Class
InSite.Model Namespace


Role Constructor

[image] [image]

.NET Framework Class Library
Role Constructor
Role Class See Also Send Feedback

Overload List

Name | Description
Role()()() |
Role(String) |

See Also

Role Class
Role Members
InSite.Model Namespace


Role Constructor

[image]

.NET Framework Class Library
Role Constructor
Role Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Role()
Visual C++
public:
Role()
JavaScript
InSite.Model.Role = function();

See Also

Role Class
Role Overload
InSite.Model Namespace


Role Constructor (String)

[image]

.NET Framework Class Library
Role Constructor (String)
Role Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    roleName As String _
)
C#
public Role(
    string roleName
)
Visual C++
public:
Role(
    String^ roleName
)
JavaScript
InSite.Model.Role = function(roleName);

Parameters

roleName
Type: System..::.String

See Also

Role Class
Role Overload
InSite.Model Namespace


Role Fields

[image] [image]

.NET Framework Class Library
Role Fields
Role Class See Also Send Feedback

The Role type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Role Class
InSite.Model Namespace


Role Methods

[image] [image]

.NET Framework Class Library
Role Methods
Role Class See Also Send Feedback

The Role type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
SOAGetList |
SOAUpdate |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Role Class
InSite.Model Namespace


SOAGetList Method

[image]

.NET Framework Class Library
Role..::.SOAGetList Method
Role Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SOAGetList As IList(Of Role)
C#
public static IList<Role> SOAGetList()
Visual C++
public:
static IList<Role^>^ SOAGetList()
JavaScript
InSite.Model.Role.soaGetList = function();

See Also

Role Class
InSite.Model Namespace


SOAUpdate Method

[image]

.NET Framework Class Library
Role..::.SOAUpdate Method
Role Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function SOAUpdate ( _
    updates As IList(Of Role) _
) As IList(Of SOAResult)
C#
public static IList<SOAResult> SOAUpdate(
    IList<Role> updates
)
Visual C++
public:
static IList<SOAResult^>^ SOAUpdate(
    IList<Role^>^ updates
)
JavaScript
InSite.Model.Role.soaUpdate = function(updates);

Parameters

updates
Type: System.Collections.Generic..::.IList <(Of <( Role >)>)

See Also

Role Class
InSite.Model Namespace


Role Properties

[image] [image]

.NET Framework Class Library
Role Properties
Role Class See Also Send Feedback

The Role type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RoleId |
RoleName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Role Class
InSite.Model Namespace


RoleId Property

[image]

.NET Framework Class Library
Role..::.RoleId Property
Role Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property RoleId As Guid
C#
public virtual Guid RoleId { get; set; }
Visual C++
public:
virtual property Guid RoleId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_roleId();
function set_roleId(value);

See Also

Role Class
InSite.Model Namespace


RoleName Property

[image]

.NET Framework Class Library
Role..::.RoleName Property
Role Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property RoleName As String
C#
[SortField]
[DataMemberAttribute]
public virtual string RoleName { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ RoleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_roleName();
function set_roleName(value);

See Also

Role Class
InSite.Model Namespace


RuleValidator Class

[image]

.NET Framework Class Library
RuleValidator Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class RuleValidator
C#
public class RuleValidator
Visual C++
public ref class RuleValidator
JavaScript
InSite.Model.RuleValidator = function();

Type.createClass(
    'InSite.Model.RuleValidator');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.RuleValidator

See Also

RuleValidator Members
InSite.Model Namespace


RuleValidator Members

[image] [image]

.NET Framework Class Library
RuleValidator Members
RuleValidator Class Constructors Methods See Also Send Feedback

The RuleValidator type exposes the following members.

Constructors

Name | Description
RuleValidator |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValdiateRules |

See Also

RuleValidator Class
InSite.Model Namespace


RuleValidator Constructor

[image]

.NET Framework Class Library
RuleValidator Constructor
RuleValidator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RuleValidator()
Visual C++
public:
RuleValidator()
JavaScript
InSite.Model.RuleValidator = function();

See Also

RuleValidator Class
InSite.Model Namespace


RuleValidator Methods

[image] [image]

.NET Framework Class Library
RuleValidator Methods
RuleValidator Class See Also Send Feedback

The RuleValidator type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ValdiateRules |

See Also

RuleValidator Class
InSite.Model Namespace


ValdiateRules Method

[image]

.NET Framework Class Library
RuleValidator..::.ValdiateRules Method
RuleValidator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ValdiateRules ( _
    rules As IList(Of IRule), _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public static bool ValdiateRules(
    IList<IRule> rules,
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
static bool ValdiateRules(
    IList<IRule^>^ rules,
    CustomerOrder^ customerOrder,
    Customer^ customer
)
JavaScript
InSite.Model.RuleValidator.valdiateRules = function(rules, customerOrder, customer);

Parameters

rules
Type: System.Collections.Generic..::.IList <(Of <( IRule >)>)
customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

See Also

RuleValidator Class
InSite.Model Namespace


Salesman Class

[image]

.NET Framework Class Library
Salesman Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Salesman _
    Inherits ModelBase(Of Salesman)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Salesman : ModelBase<Salesman>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Salesman : public ModelBase<Salesman^>
JavaScript
InSite.Model.Salesman = function();

Type.createClass(
    'InSite.Model.Salesman',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Salesman>)>)
InSite.Model..::.Salesman

See Also

Salesman Members
InSite.Model Namespace


Salesman Members

[image] [image]

.NET Framework Class Library
Salesman Members
Salesman Class Constructors Methods Fields Properties See Also Send Feedback

The Salesman type exposes the following members.

Constructors

Name | Description
Salesman | Overloaded.

Methods

Name | Description
AddCustomer |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBySalesmanNumber |
GetByUserProfile |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetListByUserProfile |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomer |
RemoveParentSalesman |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Code |
Customers |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Email |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
ImagePath |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Outside |
ParentSalesman |
ParentSalesmanName |
Phone1 |
Phone2 |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReferenceNumber |
SalesClass |
SalesManager |
SalesmanId |
SalesmanNumber |
SalesmanNumberName |
SalesPeriodToDate |
SalesYearToDate |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Title |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Salesman Class
InSite.Model Namespace


Salesman Constructor

[image] [image]

.NET Framework Class Library
Salesman Constructor
Salesman Class See Also Send Feedback

Overload List

Name | Description
Salesman()()() |
Salesman(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Salesman Class
Salesman Members
InSite.Model Namespace


Salesman Constructor

[image]

.NET Framework Class Library
Salesman Constructor
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Salesman()
Visual C++
public:
Salesman()
JavaScript
InSite.Model.Salesman = function();

See Also

Salesman Class
Salesman Overload
InSite.Model Namespace


Salesman Constructor (SearchMode)

[image]

.NET Framework Class Library
Salesman Constructor (SearchMode)
Salesman Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Salesman(
    SearchMode searchMode
)
Visual C++
public:
Salesman(
    SearchMode searchMode
)
JavaScript
InSite.Model.Salesman = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Salesman Class
Salesman Overload
InSite.Model Namespace


Salesman Fields

[image] [image]

.NET Framework Class Library
Salesman Fields
Salesman Class See Also Send Feedback

The Salesman type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Salesman Class
InSite.Model Namespace


Salesman Methods

[image] [image]

.NET Framework Class Library
Salesman Methods
Salesman Class See Also Send Feedback

The Salesman type exposes the following members.

Methods

Name | Description
AddCustomer |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBySalesmanNumber |
GetByUserProfile |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetListByUserProfile |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomer |
RemoveParentSalesman |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Salesman Class
InSite.Model Namespace


AddCustomer Method

[image]

.NET Framework Class Library
Salesman..::.AddCustomer Method
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomer ( _
    value As Customer _
)
C#
public virtual void AddCustomer(
    Customer value
)
Visual C++
public:
virtual void AddCustomer(
    Customer^ value
)
JavaScript
function addCustomer(value);

Parameters

value
Type: InSite.Model..::.Customer

See Also

Salesman Class
InSite.Model Namespace


GetBySalesmanNumber Method

[image]

.NET Framework Class Library
Salesman..::.GetBySalesmanNumber Method
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetBySalesmanNumber ( _
    salesmanNumber As String _
) As Salesman
C#
public static Salesman GetBySalesmanNumber(
    string salesmanNumber
)
Visual C++
public:
static Salesman^ GetBySalesmanNumber(
    String^ salesmanNumber
)
JavaScript
InSite.Model.Salesman.getBySalesmanNumber = function(salesmanNumber);

Parameters

salesmanNumber
Type: System..::.String

See Also

Salesman Class
InSite.Model Namespace


GetByUserProfile Method

[image]

.NET Framework Class Library
Salesman..::.GetByUserProfile Method
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByUserProfile ( _
    userProfile As UserProfile _
) As Salesman
C#
public static Salesman GetByUserProfile(
    UserProfile userProfile
)
Visual C++
public:
static Salesman^ GetByUserProfile(
    UserProfile^ userProfile
)
JavaScript
InSite.Model.Salesman.getByUserProfile = function(userProfile);

Parameters

userProfile
Type: InSite.Model..::.UserProfile

See Also

Salesman Class
InSite.Model Namespace


GetListByUserProfile Method

[image]

.NET Framework Class Library
Salesman..::.GetListByUserProfile Method
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetListByUserProfile ( _
    userProfile As UserProfile _
) As IList(Of Salesman)
C#
public static IList<Salesman> GetListByUserProfile(
    UserProfile userProfile
)
Visual C++
public:
static IList<Salesman^>^ GetListByUserProfile(
    UserProfile^ userProfile
)
JavaScript
InSite.Model.Salesman.getListByUserProfile = function(userProfile);

Parameters

userProfile
Type: InSite.Model..::.UserProfile

See Also

Salesman Class
InSite.Model Namespace


RemoveCustomer Method

[image]

.NET Framework Class Library
Salesman..::.RemoveCustomer Method
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomer ( _
    value As Customer _
)
C#
public virtual void RemoveCustomer(
    Customer value
)
Visual C++
public:
virtual void RemoveCustomer(
    Customer^ value
)
JavaScript
function removeCustomer(value);

Parameters

value
Type: InSite.Model..::.Customer

See Also

Salesman Class
InSite.Model Namespace


RemoveParentSalesman Method

[image]

.NET Framework Class Library
Salesman..::.RemoveParentSalesman Method
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveParentSalesman
C#
public virtual void RemoveParentSalesman()
Visual C++
public:
virtual void RemoveParentSalesman()
JavaScript
function removeParentSalesman();

See Also

Salesman Class
InSite.Model Namespace


Salesman Properties

[image] [image]

.NET Framework Class Library
Salesman Properties
Salesman Class See Also Send Feedback

The Salesman type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Code |
Customers |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Email |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
ImagePath |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Outside |
ParentSalesman |
ParentSalesmanName |
Phone1 |
Phone2 |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
ReferenceNumber |
SalesClass |
SalesManager |
SalesmanId |
SalesmanNumber |
SalesmanNumberName |
SalesPeriodToDate |
SalesYearToDate |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Title |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Salesman Class
InSite.Model Namespace


Code Property

[image]

.NET Framework Class Library
Salesman..::.Code Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Code As String
C#
[DataMemberAttribute]
public virtual string Code { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Code {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_code();
function set_code(value);

See Also

Salesman Class
InSite.Model Namespace


Customers Property

[image]

.NET Framework Class Library
Salesman..::.Customers Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customers As ChildList(Of Customer)
C#
public virtual ChildList<Customer> Customers { get; private set; }
Visual C++
public:
virtual property ChildList<Customer^>^ Customers {
    ChildList<Customer^>^ get ();
    void set (ChildList<Customer^>^ value);
}
JavaScript
function get_customers();
function set_customers(value);

See Also

Salesman Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Salesman..::.Description Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Salesman Class
InSite.Model Namespace


Email Property

[image]

.NET Framework Class Library
Salesman..::.Email Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Email As String
C#
[DataMemberAttribute]
public virtual string Email { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

See Also

Salesman Class
InSite.Model Namespace


ImagePath Property

[image]

.NET Framework Class Library
Salesman..::.ImagePath Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ImagePath As String
C#
[DataMemberAttribute]
public virtual string ImagePath { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_imagePath();
function set_imagePath(value);

See Also

Salesman Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Salesman..::.Name Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Salesman Class
InSite.Model Namespace


Outside Property

[image]

.NET Framework Class Library
Salesman..::.Outside Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Outside As Boolean
C#
[DataMemberAttribute]
public virtual bool Outside { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool Outside {
    bool get ();
    void set (bool value);
}
JavaScript
function get_outside();
function set_outside(value);

See Also

Salesman Class
InSite.Model Namespace


ParentSalesman Property

[image]

.NET Framework Class Library
Salesman..::.ParentSalesman Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ParentSalesman As Salesman
C#
public virtual Salesman ParentSalesman { get; set; }
Visual C++
public:
virtual property Salesman^ ParentSalesman {
    Salesman^ get ();
    void set (Salesman^ value);
}
JavaScript
function get_parentSalesman();
function set_parentSalesman(value);

See Also

Salesman Class
InSite.Model Namespace


ParentSalesmanName Property

[image]

.NET Framework Class Library
Salesman..::.ParentSalesmanName Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ParentSalesmanName As String
C#
public virtual string ParentSalesmanName { get; }
Visual C++
public:
virtual property String^ ParentSalesmanName {
    String^ get ();
}
JavaScript
function get_parentSalesmanName();

See Also

Salesman Class
InSite.Model Namespace


Phone1 Property

[image]

.NET Framework Class Library
Salesman..::.Phone1 Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone1 As String
C#
[DataMemberAttribute]
public virtual string Phone1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone1();
function set_phone1(value);

See Also

Salesman Class
InSite.Model Namespace


Phone2 Property

[image]

.NET Framework Class Library
Salesman..::.Phone2 Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone2 As String
C#
[DataMemberAttribute]
public virtual string Phone2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone2();
function set_phone2(value);

See Also

Salesman Class
InSite.Model Namespace


ReferenceNumber Property

[image]

.NET Framework Class Library
Salesman..::.ReferenceNumber Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ReferenceNumber As String
C#
[DataMemberAttribute]
public virtual string ReferenceNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ReferenceNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_referenceNumber();
function set_referenceNumber(value);

See Also

Salesman Class
InSite.Model Namespace


SalesClass Property

[image]

.NET Framework Class Library
Salesman..::.SalesClass Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SalesClass As String
C#
[DataMemberAttribute]
public virtual string SalesClass { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SalesClass {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_salesClass();
function set_salesClass(value);

See Also

Salesman Class
InSite.Model Namespace


SalesManager Property

[image]

.NET Framework Class Library
Salesman..::.SalesManager Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SalesManager As String
C#
[DataMemberAttribute]
public virtual string SalesManager { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SalesManager {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_salesManager();
function set_salesManager(value);

See Also

Salesman Class
InSite.Model Namespace


SalesmanId Property

[image]

.NET Framework Class Library
Salesman..::.SalesmanId Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SalesmanId As Guid
C#
public virtual Guid SalesmanId { get; set; }
Visual C++
public:
virtual property Guid SalesmanId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_salesmanId();
function set_salesmanId(value);

See Also

Salesman Class
InSite.Model Namespace


SalesmanNumber Property

[image]

.NET Framework Class Library
Salesman..::.SalesmanNumber Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property SalesmanNumber As String
C#
[DataMemberAttribute]
[SortField]
public virtual string SalesmanNumber { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ SalesmanNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_salesmanNumber();
function set_salesmanNumber(value);

See Also

Salesman Class
InSite.Model Namespace


SalesmanNumberName Property

[image]

.NET Framework Class Library
Salesman..::.SalesmanNumberName Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SalesmanNumberName As String
C#
[DataMemberAttribute]
public virtual string SalesmanNumberName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SalesmanNumberName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_salesmanNumberName();
function set_salesmanNumberName(value);

See Also

Salesman Class
InSite.Model Namespace


SalesPeriodToDate Property

[image]

.NET Framework Class Library
Salesman..::.SalesPeriodToDate Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SalesPeriodToDate As Decimal
C#
[DataMemberAttribute]
public virtual decimal SalesPeriodToDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal SalesPeriodToDate {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_salesPeriodToDate();
function set_salesPeriodToDate(value);

See Also

Salesman Class
InSite.Model Namespace


SalesYearToDate Property

[image]

.NET Framework Class Library
Salesman..::.SalesYearToDate Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SalesYearToDate As Decimal
C#
[DataMemberAttribute]
public virtual decimal SalesYearToDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal SalesYearToDate {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_salesYearToDate();
function set_salesYearToDate(value);

See Also

Salesman Class
InSite.Model Namespace


Title Property

[image]

.NET Framework Class Library
Salesman..::.Title Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Title As String
C#
[DataMemberAttribute]
public virtual string Title { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

See Also

Salesman Class
InSite.Model Namespace


UserProfile Property

[image]

.NET Framework Class Library
Salesman..::.UserProfile Property
Salesman Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfile As UserProfile
C#
public virtual UserProfile UserProfile { get; set; }
Visual C++
public:
virtual property UserProfile^ UserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_userProfile();
function set_userProfile(value);

See Also

Salesman Class
InSite.Model Namespace


SaveChildren Class

[image]

.NET Framework Class Library
SaveChildren Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public Class SaveChildren _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public class SaveChildren : Attribute
Visual C++
[AttributeUsageAttribute(AttributeTargets::Property)]
public ref class SaveChildren : public Attribute
JavaScript
InSite.Model.SaveChildren = function();

Type.createClass(
    'InSite.Model.SaveChildren',
    Attribute);

Inheritance Hierarchy

System..::.Object
System..::.Attribute
InSite.Model..::.SaveChildren

See Also

SaveChildren Members
InSite.Model Namespace


SaveChildren Members

[image] [image]

.NET Framework Class Library
SaveChildren Members
SaveChildren Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SaveChildren type exposes the following members.

Constructors

Name | Description
SaveChildren |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SaveChildren Class
InSite.Model Namespace


SaveChildren Constructor

[image]

.NET Framework Class Library
SaveChildren Constructor
SaveChildren Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SaveChildren()
Visual C++
public:
SaveChildren()
JavaScript
InSite.Model.SaveChildren = function();

See Also

SaveChildren Class
InSite.Model Namespace


SaveChildren Methods

[image] [image]

.NET Framework Class Library
SaveChildren Methods
SaveChildren Class See Also Send Feedback

The SaveChildren type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SaveChildren Class
InSite.Model Namespace


SaveChildren Properties

[image] [image]

.NET Framework Class Library
SaveChildren Properties
SaveChildren Class See Also Send Feedback

The SaveChildren type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SaveChildren Class
InSite.Model Namespace


ScheduledTask Class

[image]

.NET Framework Class Library
ScheduledTask Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ScheduledTask _
    Inherits ModelBase(Of ScheduledTask)
C#
[SerializableAttribute]
public class ScheduledTask : ModelBase<ScheduledTask>
Visual C++
[SerializableAttribute]
public ref class ScheduledTask : public ModelBase<ScheduledTask^>
JavaScript
InSite.Model.ScheduledTask = function();

Type.createClass(
    'InSite.Model.ScheduledTask',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ScheduledTask>)>)
InSite.Model..::.ScheduledTask

See Also

ScheduledTask Members
InSite.Model Namespace


ScheduledTask Members

[image] [image]

.NET Framework Class Library
ScheduledTask Members
ScheduledTask Class Constructors Methods Fields Properties See Also Send Feedback

The ScheduledTask type exposes the following members.

Constructors

Name | Description
ScheduledTask | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
ExecuteRealTimeTask |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetRealTimeTasksToRun |
GetTasksToRun |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ScheduleTask |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
ExecuteSqlQuery |
RefreshCustomerOrders |
RefreshCustomers |
RefreshDealers |
RefreshInventory |
RefreshInvoices |
RefreshPricing |
RefreshProducts |
RefreshResellers |
RefreshSalesmen |
RefreshShipments |
RefreshVendors |
ReSubmitOrders |
RetryOrderSubmit |
SubmitOrders |
SystemPause |

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsRealTime |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LastFinishedDateTime |
LastRunDateTime |
MinuteInterval |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Parameter |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RunDateTime |
ScheduledTaskId |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TaskTypeList |
Type |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ScheduledTask Class
InSite.Model Namespace


ScheduledTask Constructor

[image] [image]

.NET Framework Class Library
ScheduledTask Constructor
ScheduledTask Class See Also Send Feedback

Overload List

Name | Description
ScheduledTask()()() |
ScheduledTask(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ScheduledTask Class
ScheduledTask Members
InSite.Model Namespace


ScheduledTask Constructor

[image]

.NET Framework Class Library
ScheduledTask Constructor
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ScheduledTask()
Visual C++
public:
ScheduledTask()
JavaScript
InSite.Model.ScheduledTask = function();

See Also

ScheduledTask Class
ScheduledTask Overload
InSite.Model Namespace


ScheduledTask Constructor (SearchMode)

[image]

.NET Framework Class Library
ScheduledTask Constructor (SearchMode)
ScheduledTask Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ScheduledTask(
    SearchMode searchMode
)
Visual C++
public:
ScheduledTask(
    SearchMode searchMode
)
JavaScript
InSite.Model.ScheduledTask = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ScheduledTask Class
ScheduledTask Overload
InSite.Model Namespace


ScheduledTask Fields

[image] [image]

.NET Framework Class Library
ScheduledTask Fields
ScheduledTask Class See Also Send Feedback

The ScheduledTask type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
ExecuteSqlQuery |
RefreshCustomerOrders |
RefreshCustomers |
RefreshDealers |
RefreshInventory |
RefreshInvoices |
RefreshPricing |
RefreshProducts |
RefreshResellers |
RefreshSalesmen |
RefreshShipments |
RefreshVendors |
ReSubmitOrders |
RetryOrderSubmit |
SubmitOrders |
SystemPause |

See Also

ScheduledTask Class
InSite.Model Namespace


ExecuteSqlQuery Field

[image]

.NET Framework Class Library
ScheduledTask..::.ExecuteSqlQuery Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ExecuteSqlQuery As String
C#
public const string ExecuteSqlQuery
Visual C++
public:
literal String^ ExecuteSqlQuery
JavaScript
InSite.Model.ScheduledTask.executeSqlQuery

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshCustomerOrders Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshCustomerOrders Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshCustomerOrders As String
C#
public const string RefreshCustomerOrders
Visual C++
public:
literal String^ RefreshCustomerOrders
JavaScript
InSite.Model.ScheduledTask.refreshCustomerOrders

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshCustomers Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshCustomers Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshCustomers As String
C#
public const string RefreshCustomers
Visual C++
public:
literal String^ RefreshCustomers
JavaScript
InSite.Model.ScheduledTask.refreshCustomers

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshDealers Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshDealers Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshDealers As String
C#
public const string RefreshDealers
Visual C++
public:
literal String^ RefreshDealers
JavaScript
InSite.Model.ScheduledTask.refreshDealers

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshInventory Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshInventory Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshInventory As String
C#
public const string RefreshInventory
Visual C++
public:
literal String^ RefreshInventory
JavaScript
InSite.Model.ScheduledTask.refreshInventory

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshInvoices Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshInvoices Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshInvoices As String
C#
public const string RefreshInvoices
Visual C++
public:
literal String^ RefreshInvoices
JavaScript
InSite.Model.ScheduledTask.refreshInvoices

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshPricing Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshPricing Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshPricing As String
C#
public const string RefreshPricing
Visual C++
public:
literal String^ RefreshPricing
JavaScript
InSite.Model.ScheduledTask.refreshPricing

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshProducts Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshProducts Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshProducts As String
C#
public const string RefreshProducts
Visual C++
public:
literal String^ RefreshProducts
JavaScript
InSite.Model.ScheduledTask.refreshProducts

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshResellers Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshResellers Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshResellers As String
C#
public const string RefreshResellers
Visual C++
public:
literal String^ RefreshResellers
JavaScript
InSite.Model.ScheduledTask.refreshResellers

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshSalesmen Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshSalesmen Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshSalesmen As String
C#
public const string RefreshSalesmen
Visual C++
public:
literal String^ RefreshSalesmen
JavaScript
InSite.Model.ScheduledTask.refreshSalesmen

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshShipments Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshShipments Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshShipments As String
C#
public const string RefreshShipments
Visual C++
public:
literal String^ RefreshShipments
JavaScript
InSite.Model.ScheduledTask.refreshShipments

See Also

ScheduledTask Class
InSite.Model Namespace


RefreshVendors Field

[image]

.NET Framework Class Library
ScheduledTask..::.RefreshVendors Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RefreshVendors As String
C#
public const string RefreshVendors
Visual C++
public:
literal String^ RefreshVendors
JavaScript
InSite.Model.ScheduledTask.refreshVendors

See Also

ScheduledTask Class
InSite.Model Namespace


ReSubmitOrders Field

[image]

.NET Framework Class Library
ScheduledTask..::.ReSubmitOrders Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ReSubmitOrders As String
C#
public const string ReSubmitOrders
Visual C++
public:
literal String^ ReSubmitOrders
JavaScript
InSite.Model.ScheduledTask.reSubmitOrders

See Also

ScheduledTask Class
InSite.Model Namespace


RetryOrderSubmit Field

[image]

.NET Framework Class Library
ScheduledTask..::.RetryOrderSubmit Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const RetryOrderSubmit As String
C#
public const string RetryOrderSubmit
Visual C++
public:
literal String^ RetryOrderSubmit
JavaScript
InSite.Model.ScheduledTask.retryOrderSubmit

See Also

ScheduledTask Class
InSite.Model Namespace


SubmitOrders Field

[image]

.NET Framework Class Library
ScheduledTask..::.SubmitOrders Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const SubmitOrders As String
C#
public const string SubmitOrders
Visual C++
public:
literal String^ SubmitOrders
JavaScript
InSite.Model.ScheduledTask.submitOrders

See Also

ScheduledTask Class
InSite.Model Namespace


SystemPause Field

[image]

.NET Framework Class Library
ScheduledTask..::.SystemPause Field
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const SystemPause As String
C#
public const string SystemPause
Visual C++
public:
literal String^ SystemPause
JavaScript
InSite.Model.ScheduledTask.systemPause

See Also

ScheduledTask Class
InSite.Model Namespace


ScheduledTask Methods

[image] [image]

.NET Framework Class Library
ScheduledTask Methods
ScheduledTask Class See Also Send Feedback

The ScheduledTask type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
ExecuteRealTimeTask |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetRealTimeTasksToRun |
GetTasksToRun |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ScheduleTask |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ScheduledTask Class
InSite.Model Namespace


ExecuteRealTimeTask Method

[image]

.NET Framework Class Library
ScheduledTask..::.ExecuteRealTimeTask Method
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ExecuteRealTimeTask ( _
    taskType As String, _
    parameter As String _
)
C#
public static void ExecuteRealTimeTask(
    string taskType,
    string parameter
)
Visual C++
public:
static void ExecuteRealTimeTask(
    String^ taskType,
    String^ parameter
)
JavaScript
InSite.Model.ScheduledTask.executeRealTimeTask = function(taskType, parameter);

Parameters

taskType
Type: System..::.String
parameter
Type: System..::.String

See Also

ScheduledTask Class
InSite.Model Namespace


GetRealTimeTasksToRun Method

[image]

.NET Framework Class Library
ScheduledTask..::.GetRealTimeTasksToRun Method
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetRealTimeTasksToRun As IList(Of ScheduledTask)
C#
public static IList<ScheduledTask> GetRealTimeTasksToRun()
Visual C++
public:
static IList<ScheduledTask^>^ GetRealTimeTasksToRun()
JavaScript
InSite.Model.ScheduledTask.getRealTimeTasksToRun = function();

See Also

ScheduledTask Class
InSite.Model Namespace


GetTasksToRun Method

[image]

.NET Framework Class Library
ScheduledTask..::.GetTasksToRun Method
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetTasksToRun As IList(Of ScheduledTask)
C#
public static IList<ScheduledTask> GetTasksToRun()
Visual C++
public:
static IList<ScheduledTask^>^ GetTasksToRun()
JavaScript
InSite.Model.ScheduledTask.getTasksToRun = function();

See Also

ScheduledTask Class
InSite.Model Namespace


ScheduleTask Method

[image]

.NET Framework Class Library
ScheduledTask..::.ScheduleTask Method
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub ScheduleTask ( _
    taskType As String, _
    parameter As String, _
    runDateTime As DateTime, _
    minuteInterval As Integer _
)
C#
public static void ScheduleTask(
    string taskType,
    string parameter,
    DateTime runDateTime,
    int minuteInterval
)
Visual C++
public:
static void ScheduleTask(
    String^ taskType,
    String^ parameter,
    DateTime runDateTime,
    int minuteInterval
)
JavaScript
InSite.Model.ScheduledTask.scheduleTask = function(taskType, parameter, runDateTime, minuteInterval);

Parameters

taskType
Type: System..::.String
parameter
Type: System..::.String
runDateTime
Type: System..::.DateTime
minuteInterval
Type: System..::.Int32

See Also

ScheduledTask Class
InSite.Model Namespace


ScheduledTask Properties

[image] [image]

.NET Framework Class Library
ScheduledTask Properties
ScheduledTask Class See Also Send Feedback

The ScheduledTask type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsRealTime |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LastFinishedDateTime |
LastRunDateTime |
MinuteInterval |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Parameter |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RunDateTime |
ScheduledTaskId |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TaskTypeList |
Type |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ScheduledTask Class
InSite.Model Namespace


IsRealTime Property

[image]

.NET Framework Class Library
ScheduledTask..::.IsRealTime Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property IsRealTime As Boolean
C#
public virtual bool IsRealTime { get; set; }
Visual C++
public:
virtual property bool IsRealTime {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isRealTime();
function set_isRealTime(value);

See Also

ScheduledTask Class
InSite.Model Namespace


LastFinishedDateTime Property

[image]

.NET Framework Class Library
ScheduledTask..::.LastFinishedDateTime Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property LastFinishedDateTime As Nullable(Of DateTime)
C#
public virtual Nullable<DateTime> LastFinishedDateTime { get; set; }
Visual C++
public:
virtual property Nullable<DateTime> LastFinishedDateTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_lastFinishedDateTime();
function set_lastFinishedDateTime(value);

See Also

ScheduledTask Class
InSite.Model Namespace


LastRunDateTime Property

[image]

.NET Framework Class Library
ScheduledTask..::.LastRunDateTime Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property LastRunDateTime As Nullable(Of DateTime)
C#
public virtual Nullable<DateTime> LastRunDateTime { get; set; }
Visual C++
public:
virtual property Nullable<DateTime> LastRunDateTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_lastRunDateTime();
function set_lastRunDateTime(value);

See Also

ScheduledTask Class
InSite.Model Namespace


MinuteInterval Property

[image]

.NET Framework Class Library
ScheduledTask..::.MinuteInterval Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property MinuteInterval As Integer
C#
public virtual int MinuteInterval { get; set; }
Visual C++
public:
virtual property int MinuteInterval {
    int get ();
    void set (int value);
}
JavaScript
function get_minuteInterval();
function set_minuteInterval(value);

See Also

ScheduledTask Class
InSite.Model Namespace


Parameter Property

[image]

.NET Framework Class Library
ScheduledTask..::.Parameter Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Parameter As String
C#
public virtual string Parameter { get; set; }
Visual C++
public:
virtual property String^ Parameter {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parameter();
function set_parameter(value);

See Also

ScheduledTask Class
InSite.Model Namespace


RunDateTime Property

[image]

.NET Framework Class Library
ScheduledTask..::.RunDateTime Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property RunDateTime As DateTime
C#
public virtual DateTime RunDateTime { get; set; }
Visual C++
public:
virtual property DateTime RunDateTime {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_runDateTime();
function set_runDateTime(value);

See Also

ScheduledTask Class
InSite.Model Namespace


ScheduledTaskId Property

[image]

.NET Framework Class Library
ScheduledTask..::.ScheduledTaskId Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ScheduledTaskId As Guid
C#
public virtual Guid ScheduledTaskId { get; set; }
Visual C++
public:
virtual property Guid ScheduledTaskId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_scheduledTaskId();
function set_scheduledTaskId(value);

See Also

ScheduledTask Class
InSite.Model Namespace


TaskTypeList Property

[image]

.NET Framework Class Library
ScheduledTask..::.TaskTypeList Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TaskTypeList As String
C#
public static string TaskTypeList { get; }
Visual C++
public:
static property String^ TaskTypeList {
    String^ get ();
}
JavaScript
InSite.Model.ScheduledTask.get_taskTypeList = function();

See Also

ScheduledTask Class
InSite.Model Namespace


Type Property

[image]

.NET Framework Class Library
ScheduledTask..::.Type Property
ScheduledTask Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Type As String
C#
public virtual string Type { get; set; }
Visual C++
public:
virtual property String^ Type {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_type();
function set_type(value);

See Also

ScheduledTask Class
InSite.Model Namespace


SearchField Class

[image]

.NET Framework Class Library
SearchField Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public Class SearchField _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public class SearchField : Attribute
Visual C++
[AttributeUsageAttribute(AttributeTargets::Property)]
public ref class SearchField : public Attribute
JavaScript
InSite.Model.SearchField = function();

Type.createClass(
    'InSite.Model.SearchField',
    Attribute);

Inheritance Hierarchy

System..::.Object
System..::.Attribute
InSite.Model..::.SearchField

See Also

SearchField Members
InSite.Model Namespace


SearchField Members

[image] [image]

.NET Framework Class Library
SearchField Members
SearchField Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SearchField type exposes the following members.

Constructors

Name | Description
SearchField |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SearchField Class
InSite.Model Namespace


SearchField Constructor

[image]

.NET Framework Class Library
SearchField Constructor
SearchField Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SearchField()
Visual C++
public:
SearchField()
JavaScript
InSite.Model.SearchField = function();

See Also

SearchField Class
InSite.Model Namespace


SearchField Methods

[image] [image]

.NET Framework Class Library
SearchField Methods
SearchField Class See Also Send Feedback

The SearchField type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SearchField Class
InSite.Model Namespace


SearchField Properties

[image] [image]

.NET Framework Class Library
SearchField Properties
SearchField Class See Also Send Feedback

The SearchField type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SearchField Class
InSite.Model Namespace


SearchMode Enumeration

[image]

.NET Framework Class Library
SearchMode Enumeration
See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration SearchMode
C#
public enum SearchMode
Visual C++
public enum class SearchMode
JavaScript
InSite.Model.SearchMode = function();
InSite.Model.SearchMode.createEnum('InSite.Model.SearchMode', false);

Members

Member name | Description
Exact |
Begins |
Ends |
Anywhere |

See Also

InSite.Model Namespace


ShipCharge Class

[image]

.NET Framework Class Library
ShipCharge Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipCharge _
    Inherits ModelBase(Of ShipCharge)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipCharge : ModelBase<ShipCharge>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipCharge : public ModelBase<ShipCharge^>
JavaScript
InSite.Model.ShipCharge = function();

Type.createClass(
    'InSite.Model.ShipCharge',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ShipCharge>)>)
InSite.Model..::.ShipCharge

See Also

ShipCharge Members
InSite.Model Namespace


ShipCharge Members

[image] [image]

.NET Framework Class Library
ShipCharge Members
ShipCharge Class Constructors Methods Fields Properties See Also Send Feedback

The ShipCharge type exposes the following members.

Constructors

Name | Description
ShipCharge | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Charge |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Enable |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipChargeId |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipCharge Class
InSite.Model Namespace


ShipCharge Constructor

[image] [image]

.NET Framework Class Library
ShipCharge Constructor
ShipCharge Class See Also Send Feedback

Overload List

Name | Description
ShipCharge()()() |
ShipCharge(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ShipCharge Class
ShipCharge Members
InSite.Model Namespace


ShipCharge Constructor

[image]

.NET Framework Class Library
ShipCharge Constructor
ShipCharge Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipCharge()
Visual C++
public:
ShipCharge()
JavaScript
InSite.Model.ShipCharge = function();

See Also

ShipCharge Class
ShipCharge Overload
InSite.Model Namespace


ShipCharge Constructor (SearchMode)

[image]

.NET Framework Class Library
ShipCharge Constructor (SearchMode)
ShipCharge Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ShipCharge(
    SearchMode searchMode
)
Visual C++
public:
ShipCharge(
    SearchMode searchMode
)
JavaScript
InSite.Model.ShipCharge = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ShipCharge Class
ShipCharge Overload
InSite.Model Namespace


ShipCharge Fields

[image] [image]

.NET Framework Class Library
ShipCharge Fields
ShipCharge Class See Also Send Feedback

The ShipCharge type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipCharge Class
InSite.Model Namespace


ShipCharge Methods

[image] [image]

.NET Framework Class Library
ShipCharge Methods
ShipCharge Class See Also Send Feedback

The ShipCharge type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipCharge Class
InSite.Model Namespace


ShipCharge Properties

[image] [image]

.NET Framework Class Library
ShipCharge Properties
ShipCharge Class See Also Send Feedback

The ShipCharge type exposes the following members.

Properties

Name | Description
Carrier |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Charge |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Enable |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipChargeId |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipCharge Class
InSite.Model Namespace


Carrier Property

[image]

.NET Framework Class Library
ShipCharge..::.Carrier Property
ShipCharge Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Carrier As Carrier
C#
public virtual Carrier Carrier { get; set; }
Visual C++
public:
virtual property Carrier^ Carrier {
    Carrier^ get ();
    void set (Carrier^ value);
}
JavaScript
function get_carrier();
function set_carrier(value);

See Also

ShipCharge Class
InSite.Model Namespace


Charge Property

[image]

.NET Framework Class Library
ShipCharge..::.Charge Property
ShipCharge Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Charge As Decimal
C#
[DataMemberAttribute]
public virtual decimal Charge { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal Charge {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_charge();
function set_charge(value);

See Also

ShipCharge Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
ShipCharge..::.Description Property
ShipCharge Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

ShipCharge Class
InSite.Model Namespace


Enable Property

[image]

.NET Framework Class Library
ShipCharge..::.Enable Property
ShipCharge Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Enable As Boolean
C#
[DataMemberAttribute]
public virtual bool Enable { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool Enable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enable();
function set_enable(value);

See Also

ShipCharge Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
ShipCharge..::.Name Property
ShipCharge Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

ShipCharge Class
InSite.Model Namespace


ShipChargeId Property

[image]

.NET Framework Class Library
ShipCharge..::.ShipChargeId Property
ShipCharge Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipChargeId As Guid
C#
public virtual Guid ShipChargeId { get; set; }
Visual C++
public:
virtual property Guid ShipChargeId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_shipChargeId();
function set_shipChargeId(value);

See Also

ShipCharge Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
ShipCharge..::.ShipVia Property
ShipCharge Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipVia As ShipVia
C#
public virtual ShipVia ShipVia { get; set; }
Visual C++
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

ShipCharge Class
InSite.Model Namespace


Shipment Class

[image]

.NET Framework Class Library
Shipment Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Shipment _
    Inherits ModelBase(Of Shipment)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Shipment : ModelBase<Shipment>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Shipment : public ModelBase<Shipment^>
JavaScript
InSite.Model.Shipment = function();

Type.createClass(
    'InSite.Model.Shipment',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Shipment>)>)
InSite.Model..::.Shipment

See Also

Shipment Members
InSite.Model Namespace


Shipment Members

[image] [image]

.NET Framework Class Library
Shipment Members
Shipment Class Constructors Methods Fields Properties See Also Send Feedback

The Shipment type exposes the following members.

Constructors

Name | Description
Shipment | Overloaded.

Methods

Name | Description
AddShipmentPackage |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetShipmentASNs |
GetShipmentASNsToSend |
GetShipmentConfirmationEmails |
GetShipmentConfirmationEmailsToSend |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveShipmentPackage |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ASNSent |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrder |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
EmailSent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentDate |
ShipmentId |
ShipmentNumber |
ShipmentPackages |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Shipment Class
InSite.Model Namespace


Shipment Constructor

[image] [image]

.NET Framework Class Library
Shipment Constructor
Shipment Class See Also Send Feedback

Overload List

Name | Description
Shipment()()() |
Shipment(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Shipment Class
Shipment Members
InSite.Model Namespace


Shipment Constructor

[image]

.NET Framework Class Library
Shipment Constructor
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Shipment()
Visual C++
public:
Shipment()
JavaScript
InSite.Model.Shipment = function();

See Also

Shipment Class
Shipment Overload
InSite.Model Namespace


Shipment Constructor (SearchMode)

[image]

.NET Framework Class Library
Shipment Constructor (SearchMode)
Shipment Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Shipment(
    SearchMode searchMode
)
Visual C++
public:
Shipment(
    SearchMode searchMode
)
JavaScript
InSite.Model.Shipment = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Shipment Class
Shipment Overload
InSite.Model Namespace


Shipment Fields

[image] [image]

.NET Framework Class Library
Shipment Fields
Shipment Class See Also Send Feedback

The Shipment type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Shipment Class
InSite.Model Namespace


Shipment Methods

[image] [image]

.NET Framework Class Library
Shipment Methods
Shipment Class See Also Send Feedback

The Shipment type exposes the following members.

Methods

Name | Description
AddShipmentPackage |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetShipmentASNs |
GetShipmentASNsToSend |
GetShipmentConfirmationEmails |
GetShipmentConfirmationEmailsToSend |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveShipmentPackage |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Shipment Class
InSite.Model Namespace


AddShipmentPackage Method

[image]

.NET Framework Class Library
Shipment..::.AddShipmentPackage Method
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipmentPackage ( _
    value As ShipmentPackage _
)
C#
public virtual void AddShipmentPackage(
    ShipmentPackage value
)
Visual C++
public:
virtual void AddShipmentPackage(
    ShipmentPackage^ value
)
JavaScript
function addShipmentPackage(value);

Parameters

value
Type: InSite.Model..::.ShipmentPackage

See Also

Shipment Class
InSite.Model Namespace


GetShipmentASNs Method

[image]

.NET Framework Class Library
Shipment..::.GetShipmentASNs Method
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetShipmentASNs ( _
    date As DateTime _
) As IList(Of Shipment)
C#
public static IList<Shipment> GetShipmentASNs(
    DateTime date
)
Visual C++
public:
static IList<Shipment^>^ GetShipmentASNs(
    DateTime date
)
JavaScript
InSite.Model.Shipment.getShipmentASNs = function(date);

Parameters

date
Type: System..::.DateTime

See Also

Shipment Class
InSite.Model Namespace


GetShipmentASNsToSend Method

[image]

.NET Framework Class Library
Shipment..::.GetShipmentASNsToSend Method
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetShipmentASNsToSend As IList(Of Shipment)
C#
public static IList<Shipment> GetShipmentASNsToSend()
Visual C++
public:
static IList<Shipment^>^ GetShipmentASNsToSend()
JavaScript
InSite.Model.Shipment.getShipmentASNsToSend = function();

See Also

Shipment Class
InSite.Model Namespace


GetShipmentConfirmationEmails Method

[image]

.NET Framework Class Library
Shipment..::.GetShipmentConfirmationEmails Method
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetShipmentConfirmationEmails ( _
    date As DateTime _
) As IList(Of Shipment)
C#
public static IList<Shipment> GetShipmentConfirmationEmails(
    DateTime date
)
Visual C++
public:
static IList<Shipment^>^ GetShipmentConfirmationEmails(
    DateTime date
)
JavaScript
InSite.Model.Shipment.getShipmentConfirmationEmails = function(date);

Parameters

date
Type: System..::.DateTime

See Also

Shipment Class
InSite.Model Namespace


GetShipmentConfirmationEmailsToSend Method

[image]

.NET Framework Class Library
Shipment..::.GetShipmentConfirmationEmailsToSend Method
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetShipmentConfirmationEmailsToSend As IList(Of Shipment)
C#
public static IList<Shipment> GetShipmentConfirmationEmailsToSend()
Visual C++
public:
static IList<Shipment^>^ GetShipmentConfirmationEmailsToSend()
JavaScript
InSite.Model.Shipment.getShipmentConfirmationEmailsToSend = function();

See Also

Shipment Class
InSite.Model Namespace


RemoveShipmentPackage Method

[image]

.NET Framework Class Library
Shipment..::.RemoveShipmentPackage Method
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipmentPackage ( _
    value As ShipmentPackage _
)
C#
public virtual void RemoveShipmentPackage(
    ShipmentPackage value
)
Visual C++
public:
virtual void RemoveShipmentPackage(
    ShipmentPackage^ value
)
JavaScript
function removeShipmentPackage(value);

Parameters

value
Type: InSite.Model..::.ShipmentPackage

See Also

Shipment Class
InSite.Model Namespace


Shipment Properties

[image] [image]

.NET Framework Class Library
Shipment Properties
Shipment Class See Also Send Feedback

The Shipment type exposes the following members.

Properties

Name | Description
ASNSent |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
CustomerOrder |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
EmailSent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipmentDate |
ShipmentId |
ShipmentNumber |
ShipmentPackages |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Shipment Class
InSite.Model Namespace


ASNSent Property

[image]

.NET Framework Class Library
Shipment..::.ASNSent Property
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ASNSent As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> ASNSent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> ASNSent {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_asnSent();
function set_asnSent(value);

See Also

Shipment Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
Shipment..::.CustomerOrder Property
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

Shipment Class
InSite.Model Namespace


EmailSent Property

[image]

.NET Framework Class Library
Shipment..::.EmailSent Property
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property EmailSent As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> EmailSent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> EmailSent {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_emailSent();
function set_emailSent(value);

See Also

Shipment Class
InSite.Model Namespace


ShipmentDate Property

[image]

.NET Framework Class Library
Shipment..::.ShipmentDate Property
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipmentDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime ShipmentDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime ShipmentDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_shipmentDate();
function set_shipmentDate(value);

See Also

Shipment Class
InSite.Model Namespace


ShipmentId Property

[image]

.NET Framework Class Library
Shipment..::.ShipmentId Property
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipmentId As Guid
C#
public virtual Guid ShipmentId { get; set; }
Visual C++
public:
virtual property Guid ShipmentId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_shipmentId();
function set_shipmentId(value);

See Also

Shipment Class
InSite.Model Namespace


ShipmentNumber Property

[image]

.NET Framework Class Library
Shipment..::.ShipmentNumber Property
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property ShipmentNumber As String
C#
[SortField]
[DataMemberAttribute]
public virtual string ShipmentNumber { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ ShipmentNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipmentNumber();
function set_shipmentNumber(value);

See Also

Shipment Class
InSite.Model Namespace


ShipmentPackages Property

[image]

.NET Framework Class Library
Shipment..::.ShipmentPackages Property
Shipment Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipmentPackages As ChildList(Of ShipmentPackage)
C#
[DataMemberAttribute]
public virtual ChildList<ShipmentPackage> ShipmentPackages { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ShipmentPackage^>^ ShipmentPackages {
    ChildList<ShipmentPackage^>^ get ();
    void set (ChildList<ShipmentPackage^>^ value);
}
JavaScript
function get_shipmentPackages();
function set_shipmentPackages(value);

See Also

Shipment Class
InSite.Model Namespace


ShipmentPackage Class

[image]

.NET Framework Class Library
ShipmentPackage Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipmentPackage _
    Inherits ModelBase(Of ShipmentPackage)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipmentPackage : ModelBase<ShipmentPackage>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipmentPackage : public ModelBase<ShipmentPackage^>
JavaScript
InSite.Model.ShipmentPackage = function();

Type.createClass(
    'InSite.Model.ShipmentPackage',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ShipmentPackage>)>)
InSite.Model..::.ShipmentPackage

See Also

ShipmentPackage Members
InSite.Model Namespace


ShipmentPackage Members

[image] [image]

.NET Framework Class Library
ShipmentPackage Members
ShipmentPackage Class Constructors Methods Fields Properties See Also Send Feedback

The ShipmentPackage type exposes the following members.

Constructors

Name | Description
ShipmentPackage | Overloaded.

Methods

Name | Description
AddPackageLine |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemovePackageLine |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Freight |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PackageLines |
PackageNumber |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
Shipment |
ShipmentPackageId |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TrackingNumber |
TrackingURL |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipmentPackage Class
InSite.Model Namespace


ShipmentPackage Constructor

[image] [image]

.NET Framework Class Library
ShipmentPackage Constructor
ShipmentPackage Class See Also Send Feedback

Overload List

Name | Description
ShipmentPackage()()() |
ShipmentPackage(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ShipmentPackage Class
ShipmentPackage Members
InSite.Model Namespace


ShipmentPackage Constructor

[image]

.NET Framework Class Library
ShipmentPackage Constructor
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipmentPackage()
Visual C++
public:
ShipmentPackage()
JavaScript
InSite.Model.ShipmentPackage = function();

See Also

ShipmentPackage Class
ShipmentPackage Overload
InSite.Model Namespace


ShipmentPackage Constructor (SearchMode)

[image]

.NET Framework Class Library
ShipmentPackage Constructor (SearchMode)
ShipmentPackage Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ShipmentPackage(
    SearchMode searchMode
)
Visual C++
public:
ShipmentPackage(
    SearchMode searchMode
)
JavaScript
InSite.Model.ShipmentPackage = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ShipmentPackage Class
ShipmentPackage Overload
InSite.Model Namespace


ShipmentPackage Fields

[image] [image]

.NET Framework Class Library
ShipmentPackage Fields
ShipmentPackage Class See Also Send Feedback

The ShipmentPackage type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipmentPackage Class
InSite.Model Namespace


ShipmentPackage Methods

[image] [image]

.NET Framework Class Library
ShipmentPackage Methods
ShipmentPackage Class See Also Send Feedback

The ShipmentPackage type exposes the following members.

Methods

Name | Description
AddPackageLine |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemovePackageLine |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipmentPackage Class
InSite.Model Namespace


AddPackageLine Method

[image]

.NET Framework Class Library
ShipmentPackage..::.AddPackageLine Method
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddPackageLine ( _
    value As PackageLine _
)
C#
public virtual void AddPackageLine(
    PackageLine value
)
Visual C++
public:
virtual void AddPackageLine(
    PackageLine^ value
)
JavaScript
function addPackageLine(value);

Parameters

value
Type: InSite.Model..::.PackageLine

See Also

ShipmentPackage Class
InSite.Model Namespace


RemovePackageLine Method

[image]

.NET Framework Class Library
ShipmentPackage..::.RemovePackageLine Method
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemovePackageLine ( _
    value As PackageLine _
)
C#
public virtual void RemovePackageLine(
    PackageLine value
)
Visual C++
public:
virtual void RemovePackageLine(
    PackageLine^ value
)
JavaScript
function removePackageLine(value);

Parameters

value
Type: InSite.Model..::.PackageLine

See Also

ShipmentPackage Class
InSite.Model Namespace


ShipmentPackage Properties

[image] [image]

.NET Framework Class Library
ShipmentPackage Properties
ShipmentPackage Class See Also Send Feedback

The ShipmentPackage type exposes the following members.

Properties

Name | Description
Carrier |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Freight |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
PackageLines |
PackageNumber |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
Shipment |
ShipmentPackageId |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TrackingNumber |
TrackingURL |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipmentPackage Class
InSite.Model Namespace


Carrier Property

[image]

.NET Framework Class Library
ShipmentPackage..::.Carrier Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Carrier As String
C#
[DataMemberAttribute]
public virtual string Carrier { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Carrier {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_carrier();
function set_carrier(value);

See Also

ShipmentPackage Class
InSite.Model Namespace


Freight Property

[image]

.NET Framework Class Library
ShipmentPackage..::.Freight Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Freight As Decimal
C#
public virtual decimal Freight { get; set; }
Visual C++
public:
virtual property Decimal Freight {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_freight();
function set_freight(value);

See Also

ShipmentPackage Class
InSite.Model Namespace


PackageLines Property

[image]

.NET Framework Class Library
ShipmentPackage..::.PackageLines Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property PackageLines As ChildList(Of PackageLine)
C#
public virtual ChildList<PackageLine> PackageLines { get; private set; }
Visual C++
public:
virtual property ChildList<PackageLine^>^ PackageLines {
    ChildList<PackageLine^>^ get ();
    void set (ChildList<PackageLine^>^ value);
}
JavaScript
function get_packageLines();
function set_packageLines(value);

See Also

ShipmentPackage Class
InSite.Model Namespace


PackageNumber Property

[image]

.NET Framework Class Library
ShipmentPackage..::.PackageNumber Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property PackageNumber As String
C#
[DataMemberAttribute]
[SortField]
public virtual string PackageNumber { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ PackageNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_packageNumber();
function set_packageNumber(value);

See Also

ShipmentPackage Class
InSite.Model Namespace


Shipment Property

[image]

.NET Framework Class Library
ShipmentPackage..::.Shipment Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Shipment As Shipment
C#
public virtual Shipment Shipment { get; set; }
Visual C++
public:
virtual property Shipment^ Shipment {
    Shipment^ get ();
    void set (Shipment^ value);
}
JavaScript
function get_shipment();
function set_shipment(value);

See Also

ShipmentPackage Class
InSite.Model Namespace


ShipmentPackageId Property

[image]

.NET Framework Class Library
ShipmentPackage..::.ShipmentPackageId Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipmentPackageId As Guid
C#
public virtual Guid ShipmentPackageId { get; set; }
Visual C++
public:
virtual property Guid ShipmentPackageId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_shipmentPackageId();
function set_shipmentPackageId(value);

See Also

ShipmentPackage Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
ShipmentPackage..::.ShipVia Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipVia As String
C#
[DataMemberAttribute]
public virtual string ShipVia { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipVia {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

ShipmentPackage Class
InSite.Model Namespace


TrackingNumber Property

[image]

.NET Framework Class Library
ShipmentPackage..::.TrackingNumber Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TrackingNumber As String
C#
[DataMemberAttribute]
public virtual string TrackingNumber { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TrackingNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_trackingNumber();
function set_trackingNumber(value);

See Also

ShipmentPackage Class
InSite.Model Namespace


TrackingURL Property

[image]

.NET Framework Class Library
ShipmentPackage..::.TrackingURL Property
ShipmentPackage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TrackingURL As String
C#
public virtual string TrackingURL { get; }
Visual C++
public:
virtual property String^ TrackingURL {
    String^ get ();
}
JavaScript
function get_trackingURL();

See Also

ShipmentPackage Class
InSite.Model Namespace


ShippingClassification Class

[image]

.NET Framework Class Library
ShippingClassification Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ShippingClassification _
    Inherits ModelBase(Of ShippingClassification)
C#
[SerializableAttribute]
public class ShippingClassification : ModelBase<ShippingClassification>
Visual C++
[SerializableAttribute]
public ref class ShippingClassification : public ModelBase<ShippingClassification^>
JavaScript
InSite.Model.ShippingClassification = function();

Type.createClass(
    'InSite.Model.ShippingClassification',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ShippingClassification>)>)
InSite.Model..::.ShippingClassification

See Also

ShippingClassification Members
InSite.Model Namespace


ShippingClassification Members

[image] [image]

.NET Framework Class Library
ShippingClassification Members
ShippingClassification Class Constructors Methods Fields Properties See Also Send Feedback

The ShippingClassification type exposes the following members.

Constructors

Name | Description
ShippingClassification | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Classification |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShippingClassificationId |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShippingClassification Class
InSite.Model Namespace


ShippingClassification Constructor

[image] [image]

.NET Framework Class Library
ShippingClassification Constructor
ShippingClassification Class See Also Send Feedback

Overload List

Name | Description
ShippingClassification()()() |
ShippingClassification(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ShippingClassification Class
ShippingClassification Members
InSite.Model Namespace


ShippingClassification Constructor

[image]

.NET Framework Class Library
ShippingClassification Constructor
ShippingClassification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShippingClassification()
Visual C++
public:
ShippingClassification()
JavaScript
InSite.Model.ShippingClassification = function();

See Also

ShippingClassification Class
ShippingClassification Overload
InSite.Model Namespace


ShippingClassification Constructor (SearchMode)

[image]

.NET Framework Class Library
ShippingClassification Constructor (SearchMode)
ShippingClassification Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ShippingClassification(
    SearchMode searchMode
)
Visual C++
public:
ShippingClassification(
    SearchMode searchMode
)
JavaScript
InSite.Model.ShippingClassification = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ShippingClassification Class
ShippingClassification Overload
InSite.Model Namespace


ShippingClassification Fields

[image] [image]

.NET Framework Class Library
ShippingClassification Fields
ShippingClassification Class See Also Send Feedback

The ShippingClassification type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShippingClassification Class
InSite.Model Namespace


ShippingClassification Methods

[image] [image]

.NET Framework Class Library
ShippingClassification Methods
ShippingClassification Class See Also Send Feedback

The ShippingClassification type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShippingClassification Class
InSite.Model Namespace


ShippingClassification Properties

[image] [image]

.NET Framework Class Library
ShippingClassification Properties
ShippingClassification Class See Also Send Feedback

The ShippingClassification type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Classification |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShippingClassificationId |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShippingClassification Class
InSite.Model Namespace


Classification Property

[image]

.NET Framework Class Library
ShippingClassification..::.Classification Property
ShippingClassification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Classification As String
C#
public virtual string Classification { get; set; }
Visual C++
public:
virtual property String^ Classification {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_classification();
function set_classification(value);

See Also

ShippingClassification Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
ShippingClassification..::.Description Property
ShippingClassification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Description As String
C#
public virtual string Description { get; set; }
Visual C++
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

ShippingClassification Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
ShippingClassification..::.Name Property
ShippingClassification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

ShippingClassification Class
InSite.Model Namespace


ShippingClassificationId Property

[image]

.NET Framework Class Library
ShippingClassification..::.ShippingClassificationId Property
ShippingClassification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShippingClassificationId As Guid
C#
public virtual Guid ShippingClassificationId { get; set; }
Visual C++
public:
virtual property Guid ShippingClassificationId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_shippingClassificationId();
function set_shippingClassificationId(value);

See Also

ShippingClassification Class
InSite.Model Namespace


ShipRate Class

[image]

.NET Framework Class Library
ShipRate Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRate _
    Inherits ModelBase(Of ShipRate)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRate : ModelBase<ShipRate>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRate : public ModelBase<ShipRate^>
JavaScript
InSite.Model.ShipRate = function();

Type.createClass(
    'InSite.Model.ShipRate',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ShipRate>)>)
InSite.Model..::.ShipRate

See Also

ShipRate Members
InSite.Model Namespace


ShipRate Members

[image] [image]

.NET Framework Class Library
ShipRate Members
ShipRate Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRate type exposes the following members.

Constructors

Name | Description
ShipRate | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ChargeAmount |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderAmount |
PerEach |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRateId |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRate Class
InSite.Model Namespace


ShipRate Constructor

[image] [image]

.NET Framework Class Library
ShipRate Constructor
ShipRate Class See Also Send Feedback

Overload List

Name | Description
ShipRate()()() |
ShipRate(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ShipRate Class
ShipRate Members
InSite.Model Namespace


ShipRate Constructor

[image]

.NET Framework Class Library
ShipRate Constructor
ShipRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRate()
Visual C++
public:
ShipRate()
JavaScript
InSite.Model.ShipRate = function();

See Also

ShipRate Class
ShipRate Overload
InSite.Model Namespace


ShipRate Constructor (SearchMode)

[image]

.NET Framework Class Library
ShipRate Constructor (SearchMode)
ShipRate Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ShipRate(
    SearchMode searchMode
)
Visual C++
public:
ShipRate(
    SearchMode searchMode
)
JavaScript
InSite.Model.ShipRate = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ShipRate Class
ShipRate Overload
InSite.Model Namespace


ShipRate Fields

[image] [image]

.NET Framework Class Library
ShipRate Fields
ShipRate Class See Also Send Feedback

The ShipRate type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRate Class
InSite.Model Namespace


ShipRate Methods

[image] [image]

.NET Framework Class Library
ShipRate Methods
ShipRate Class See Also Send Feedback

The ShipRate type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRate Class
InSite.Model Namespace


ShipRate Properties

[image] [image]

.NET Framework Class Library
ShipRate Properties
ShipRate Class See Also Send Feedback

The ShipRate type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ChargeAmount |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OrderAmount |
PerEach |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRateId |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRate Class
InSite.Model Namespace


ChargeAmount Property

[image]

.NET Framework Class Library
ShipRate..::.ChargeAmount Property
ShipRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ChargeAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal ChargeAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ChargeAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_chargeAmount();
function set_chargeAmount(value);

See Also

ShipRate Class
InSite.Model Namespace


OrderAmount Property

[image]

.NET Framework Class Library
ShipRate..::.OrderAmount Property
ShipRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property OrderAmount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal OrderAmount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal OrderAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_orderAmount();
function set_orderAmount(value);

See Also

ShipRate Class
InSite.Model Namespace


PerEach Property

[image]

.NET Framework Class Library
ShipRate..::.PerEach Property
ShipRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PerEach As Boolean
C#
[DataMemberAttribute]
public virtual bool PerEach { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool PerEach {
    bool get ();
    void set (bool value);
}
JavaScript
function get_perEach();
function set_perEach(value);

See Also

ShipRate Class
InSite.Model Namespace


ShipRateId Property

[image]

.NET Framework Class Library
ShipRate..::.ShipRateId Property
ShipRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipRateId As Guid
C#
public virtual Guid ShipRateId { get; set; }
Visual C++
public:
virtual property Guid ShipRateId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_shipRateId();
function set_shipRateId(value);

See Also

ShipRate Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
ShipRate..::.ShipVia Property
ShipRate Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipVia As ShipVia
C#
public virtual ShipVia ShipVia { get; set; }
Visual C++
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

ShipRate Class
InSite.Model Namespace


ShipRule Class

[image]

.NET Framework Class Library
ShipRule Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRule _
    Inherits ModelBase(Of ShipRule) _
    Implements IRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRule : ModelBase<ShipRule>,
    IRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRule : public ModelBase<ShipRule^>,
    IRule
JavaScript
InSite.Model.ShipRule = function();

Type.createClass(
    'InSite.Model.ShipRule',
    InSite.Model.ModelBase`1,
    InSite.Model.IRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ShipRule>)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleCustomerIsCustomerType
InSite.Model..::.ShipRuleCustomerIsNotCustomerType
InSite.Model..::.ShipRuleOrderAtLeastOneProductInCategory
InSite.Model..::.ShipRuleOrderDoesNotHaveTermsCode
InSite.Model..::.ShipRuleOrderHasTermsCode
InSite.Model..::.ShipRuleOrderNotShippingToCountry
InSite.Model..::.ShipRuleOrderNotShippingToState
InSite.Model..::.ShipRuleOrderNotShippingToZipCode
InSite.Model..::.ShipRuleOrderProductsNotInCategory
InSite.Model..::.ShipRuleOrderProductsOnlyInCategory
InSite.Model..::.ShipRuleOrderShipDateIsDayOfWeek
InSite.Model..::.ShipRuleOrderShipDateIsDayOfWeekOrNull
InSite.Model..::.ShipRuleOrderShipDateIsNotDayOfWeek
InSite.Model..::.ShipRuleOrderShippingToCountry
InSite.Model..::.ShipRuleOrderShippingToState
InSite.Model..::.ShipRuleOrderShippingToZipCode
InSite.Model..::.ShipRuleOrderSubTotalDoesExceedMinimum
InSite.Model..::.ShipRuleOrderSubTotalDoesNotExceedMaximum
InSite.Model..::.ShipRuleOrderSubTotalInRange

See Also

ShipRule Members
InSite.Model Namespace


ShipRule Members

[image] [image]

.NET Framework Class Library
ShipRule Members
ShipRule Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRule type exposes the following members.

Constructors

Name | Description
ShipRule |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier |
_condition |
_executionGroup |
_executionOrder |
_shipRuleId |
_shipVia |
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
ConditionAnd |
ConditionOr |

Properties

Name | Description
Carrier |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup |
ExecutionOrder |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRule Class
InSite.Model Namespace


ShipRule Constructor

[image]

.NET Framework Class Library
ShipRule Constructor
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRule()
Visual C++
public:
ShipRule()
JavaScript
InSite.Model.ShipRule = function();

See Also

ShipRule Class
InSite.Model Namespace


ShipRule Fields

[image] [image]

.NET Framework Class Library
ShipRule Fields
ShipRule Class See Also Send Feedback

The ShipRule type exposes the following members.

Fields

Name | Description
_carrier |
_condition |
_executionGroup |
_executionOrder |
_shipRuleId |
_shipVia |
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
ConditionAnd |
ConditionOr |

See Also

ShipRule Class
InSite.Model Namespace


_carrier Field

[image]

.NET Framework Class Library
ShipRule..::._carrier Field
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _carrier As Carrier
C#
protected Carrier _carrier
Visual C++
protected:
Carrier^ _carrier
JavaScript
_carrier

See Also

ShipRule Class
InSite.Model Namespace


_condition Field

[image]

.NET Framework Class Library
ShipRule..::._condition Field
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _condition As String
C#
protected string _condition
Visual C++
protected:
String^ _condition
JavaScript
_condition

See Also

ShipRule Class
InSite.Model Namespace


_executionGroup Field

[image]

.NET Framework Class Library
ShipRule..::._executionGroup Field
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _executionGroup As Integer
C#
protected int _executionGroup
Visual C++
protected:
int _executionGroup
JavaScript
_executionGroup

See Also

ShipRule Class
InSite.Model Namespace


_executionOrder Field

[image]

.NET Framework Class Library
ShipRule..::._executionOrder Field
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _executionOrder As Integer
C#
protected int _executionOrder
Visual C++
protected:
int _executionOrder
JavaScript
_executionOrder

See Also

ShipRule Class
InSite.Model Namespace


_shipRuleId Field

[image]

.NET Framework Class Library
ShipRule..::._shipRuleId Field
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _shipRuleId As Guid
C#
protected Guid _shipRuleId
Visual C++
protected:
Guid _shipRuleId
JavaScript
_shipRuleId

See Also

ShipRule Class
InSite.Model Namespace


_shipVia Field

[image]

.NET Framework Class Library
ShipRule..::._shipVia Field
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected _shipVia As ShipVia
C#
protected ShipVia _shipVia
Visual C++
protected:
ShipVia^ _shipVia
JavaScript
_shipVia

See Also

ShipRule Class
InSite.Model Namespace


ConditionAnd Field

[image]

.NET Framework Class Library
ShipRule..::.ConditionAnd Field
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ConditionAnd As String
C#
public const string ConditionAnd
Visual C++
public:
literal String^ ConditionAnd
JavaScript
InSite.Model.ShipRule.conditionAnd

See Also

ShipRule Class
InSite.Model Namespace


ConditionOr Field

[image]

.NET Framework Class Library
ShipRule..::.ConditionOr Field
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const ConditionOr As String
C#
public const string ConditionOr
Visual C++
public:
literal String^ ConditionOr
JavaScript
InSite.Model.ShipRule.conditionOr

See Also

ShipRule Class
InSite.Model Namespace


ShipRule Methods

[image] [image]

.NET Framework Class Library
ShipRule Methods
ShipRule Class See Also Send Feedback

The ShipRule type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRule Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRule..::.IsValid Method
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public virtual bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
)
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRule Class
InSite.Model Namespace


ShipRule Properties

[image] [image]

.NET Framework Class Library
ShipRule Properties
ShipRule Class See Also Send Feedback

The ShipRule type exposes the following members.

Properties

Name | Description
Carrier |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup |
ExecutionOrder |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId |
ShipVia |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRule Class
InSite.Model Namespace


Carrier Property

[image]

.NET Framework Class Library
ShipRule..::.Carrier Property
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Carrier As Carrier
C#
public virtual Carrier Carrier { get; set; }
Visual C++
public:
virtual property Carrier^ Carrier {
    Carrier^ get ();
    void set (Carrier^ value);
}
JavaScript
function get_carrier();
function set_carrier(value);

See Also

ShipRule Class
InSite.Model Namespace


Condition Property

[image]

.NET Framework Class Library
ShipRule..::.Condition Property
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Condition As String
C#
[DataMemberAttribute]
public virtual string Condition { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Condition {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_condition();
function set_condition(value);

Implements

IRule..::.Condition

See Also

ShipRule Class
InSite.Model Namespace


ExecutionGroup Property

[image]

.NET Framework Class Library
ShipRule..::.ExecutionGroup Property
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ExecutionGroup As Integer
C#
[DataMemberAttribute]
public virtual int ExecutionGroup { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int ExecutionGroup {
    int get ();
    void set (int value);
}
JavaScript
function get_executionGroup();
function set_executionGroup(value);

Implements

IRule..::.ExecutionGroup

See Also

ShipRule Class
InSite.Model Namespace


ExecutionOrder Property

[image]

.NET Framework Class Library
ShipRule..::.ExecutionOrder Property
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ExecutionOrder As Integer
C#
[DataMemberAttribute]
public virtual int ExecutionOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int ExecutionOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_executionOrder();
function set_executionOrder(value);

Implements

IRule..::.ExecutionOrder

See Also

ShipRule Class
InSite.Model Namespace


RuleName Property

[image]

.NET Framework Class Library
ShipRule..::.RuleName Property
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property RuleName As String
C#
[SortField]
[DataMemberAttribute]
public virtual string RuleName { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ RuleName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_ruleName();
function set_ruleName(value);

See Also

ShipRule Class
InSite.Model Namespace


ShipRuleId Property

[image]

.NET Framework Class Library
ShipRule..::.ShipRuleId Property
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipRuleId As Guid
C#
public virtual Guid ShipRuleId { get; set; }
Visual C++
public:
virtual property Guid ShipRuleId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_shipRuleId();
function set_shipRuleId(value);

See Also

ShipRule Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
ShipRule..::.ShipVia Property
ShipRule Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipVia As ShipVia
C#
public virtual ShipVia ShipVia { get; set; }
Visual C++
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

ShipRule Class
InSite.Model Namespace


ShipRuleCustomerIsCustomerType Class

[image]

.NET Framework Class Library
ShipRuleCustomerIsCustomerType Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class ShipRuleCustomerIsCustomerType _
    Inherits ShipRule
C#
public class ShipRuleCustomerIsCustomerType : ShipRule
Visual C++
public ref class ShipRuleCustomerIsCustomerType : public ShipRule
JavaScript
InSite.Model.ShipRuleCustomerIsCustomerType = function();

Type.createClass(
    'InSite.Model.ShipRuleCustomerIsCustomerType',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleCustomerIsCustomerType

See Also

ShipRuleCustomerIsCustomerType Members
InSite.Model Namespace


ShipRuleCustomerIsCustomerType Members

[image] [image]

.NET Framework Class Library
ShipRuleCustomerIsCustomerType Members
ShipRuleCustomerIsCustomerType Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleCustomerIsCustomerType type exposes the following members.

Constructors

Name | Description
ShipRuleCustomerIsCustomerType |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
CustomerType |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleCustomerIsCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsCustomerType Constructor

[image]

.NET Framework Class Library
ShipRuleCustomerIsCustomerType Constructor
ShipRuleCustomerIsCustomerType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleCustomerIsCustomerType()
Visual C++
public:
ShipRuleCustomerIsCustomerType()
JavaScript
InSite.Model.ShipRuleCustomerIsCustomerType = function();

See Also

ShipRuleCustomerIsCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsCustomerType Fields

[image] [image]

.NET Framework Class Library
ShipRuleCustomerIsCustomerType Fields
ShipRuleCustomerIsCustomerType Class See Also Send Feedback

The ShipRuleCustomerIsCustomerType type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleCustomerIsCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsCustomerType Methods

[image] [image]

.NET Framework Class Library
ShipRuleCustomerIsCustomerType Methods
ShipRuleCustomerIsCustomerType Class See Also Send Feedback

The ShipRuleCustomerIsCustomerType type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleCustomerIsCustomerType Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleCustomerIsCustomerType..::.IsValid Method
ShipRuleCustomerIsCustomerType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleCustomerIsCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsCustomerType Properties

[image] [image]

.NET Framework Class Library
ShipRuleCustomerIsCustomerType Properties
ShipRuleCustomerIsCustomerType Class See Also Send Feedback

The ShipRuleCustomerIsCustomerType type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
CustomerType |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleCustomerIsCustomerType Class
InSite.Model Namespace


CustomerType Property

[image]

.NET Framework Class Library
ShipRuleCustomerIsCustomerType..::.CustomerType Property
ShipRuleCustomerIsCustomerType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerType As String
C#
public virtual string CustomerType { get; set; }
Visual C++
public:
virtual property String^ CustomerType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerType();
function set_customerType(value);

See Also

ShipRuleCustomerIsCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsNotCustomerType Class

[image]

.NET Framework Class Library
ShipRuleCustomerIsNotCustomerType Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class ShipRuleCustomerIsNotCustomerType _
    Inherits ShipRule
C#
public class ShipRuleCustomerIsNotCustomerType : ShipRule
Visual C++
public ref class ShipRuleCustomerIsNotCustomerType : public ShipRule
JavaScript
InSite.Model.ShipRuleCustomerIsNotCustomerType = function();

Type.createClass(
    'InSite.Model.ShipRuleCustomerIsNotCustomerType',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleCustomerIsNotCustomerType

See Also

ShipRuleCustomerIsNotCustomerType Members
InSite.Model Namespace


ShipRuleCustomerIsNotCustomerType Members

[image] [image]

.NET Framework Class Library
ShipRuleCustomerIsNotCustomerType Members
ShipRuleCustomerIsNotCustomerType Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleCustomerIsNotCustomerType type exposes the following members.

Constructors

Name | Description
ShipRuleCustomerIsNotCustomerType |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
CustomerType |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleCustomerIsNotCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsNotCustomerType Constructor

[image]

.NET Framework Class Library
ShipRuleCustomerIsNotCustomerType Constructor
ShipRuleCustomerIsNotCustomerType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleCustomerIsNotCustomerType()
Visual C++
public:
ShipRuleCustomerIsNotCustomerType()
JavaScript
InSite.Model.ShipRuleCustomerIsNotCustomerType = function();

See Also

ShipRuleCustomerIsNotCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsNotCustomerType Fields

[image] [image]

.NET Framework Class Library
ShipRuleCustomerIsNotCustomerType Fields
ShipRuleCustomerIsNotCustomerType Class See Also Send Feedback

The ShipRuleCustomerIsNotCustomerType type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleCustomerIsNotCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsNotCustomerType Methods

[image] [image]

.NET Framework Class Library
ShipRuleCustomerIsNotCustomerType Methods
ShipRuleCustomerIsNotCustomerType Class See Also Send Feedback

The ShipRuleCustomerIsNotCustomerType type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleCustomerIsNotCustomerType Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleCustomerIsNotCustomerType..::.IsValid Method
ShipRuleCustomerIsNotCustomerType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleCustomerIsNotCustomerType Class
InSite.Model Namespace


ShipRuleCustomerIsNotCustomerType Properties

[image] [image]

.NET Framework Class Library
ShipRuleCustomerIsNotCustomerType Properties
ShipRuleCustomerIsNotCustomerType Class See Also Send Feedback

The ShipRuleCustomerIsNotCustomerType type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
CustomerType |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleCustomerIsNotCustomerType Class
InSite.Model Namespace


CustomerType Property

[image]

.NET Framework Class Library
ShipRuleCustomerIsNotCustomerType..::.CustomerType Property
ShipRuleCustomerIsNotCustomerType Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerType As String
C#
public virtual string CustomerType { get; set; }
Visual C++
public:
virtual property String^ CustomerType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerType();
function set_customerType(value);

See Also

ShipRuleCustomerIsNotCustomerType Class
InSite.Model Namespace


ShipRuleOrderAtLeastOneProductInCategory Class

[image]

.NET Framework Class Library
ShipRuleOrderAtLeastOneProductInCategory Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderAtLeastOneProductInCategory _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderAtLeastOneProductInCategory : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderAtLeastOneProductInCategory : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderAtLeastOneProductInCategory = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderAtLeastOneProductInCategory',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderAtLeastOneProductInCategory

See Also

ShipRuleOrderAtLeastOneProductInCategory Members
InSite.Model Namespace


ShipRuleOrderAtLeastOneProductInCategory Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderAtLeastOneProductInCategory Members
ShipRuleOrderAtLeastOneProductInCategory Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderAtLeastOneProductInCategory type exposes the following members.

Constructors

Name | Description
ShipRuleOrderAtLeastOneProductInCategory |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderAtLeastOneProductInCategory Class
InSite.Model Namespace


ShipRuleOrderAtLeastOneProductInCategory Constructor

[image]

.NET Framework Class Library
ShipRuleOrderAtLeastOneProductInCategory Constructor
ShipRuleOrderAtLeastOneProductInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderAtLeastOneProductInCategory()
Visual C++
public:
ShipRuleOrderAtLeastOneProductInCategory()
JavaScript
InSite.Model.ShipRuleOrderAtLeastOneProductInCategory = function();

See Also

ShipRuleOrderAtLeastOneProductInCategory Class
InSite.Model Namespace


ShipRuleOrderAtLeastOneProductInCategory Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderAtLeastOneProductInCategory Fields
ShipRuleOrderAtLeastOneProductInCategory Class See Also Send Feedback

The ShipRuleOrderAtLeastOneProductInCategory type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderAtLeastOneProductInCategory Class
InSite.Model Namespace


ShipRuleOrderAtLeastOneProductInCategory Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderAtLeastOneProductInCategory Methods
ShipRuleOrderAtLeastOneProductInCategory Class See Also Send Feedback

The ShipRuleOrderAtLeastOneProductInCategory type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderAtLeastOneProductInCategory Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderAtLeastOneProductInCategory..::.IsValid Method
ShipRuleOrderAtLeastOneProductInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderAtLeastOneProductInCategory Class
InSite.Model Namespace


ShipRuleOrderAtLeastOneProductInCategory Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderAtLeastOneProductInCategory Properties
ShipRuleOrderAtLeastOneProductInCategory Class See Also Send Feedback

The ShipRuleOrderAtLeastOneProductInCategory type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderAtLeastOneProductInCategory Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
ShipRuleOrderAtLeastOneProductInCategory..::.Category Property
ShipRuleOrderAtLeastOneProductInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Category As Category
C#
[DataMemberAttribute]
[SortField]
public virtual Category Category { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

ShipRuleOrderAtLeastOneProductInCategory Class
InSite.Model Namespace


ShipRuleOrderDoesNotHaveTermsCode Class

[image]

.NET Framework Class Library
ShipRuleOrderDoesNotHaveTermsCode Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderDoesNotHaveTermsCode _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderDoesNotHaveTermsCode : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderDoesNotHaveTermsCode : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderDoesNotHaveTermsCode = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderDoesNotHaveTermsCode',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderDoesNotHaveTermsCode

See Also

ShipRuleOrderDoesNotHaveTermsCode Members
InSite.Model Namespace


ShipRuleOrderDoesNotHaveTermsCode Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderDoesNotHaveTermsCode Members
ShipRuleOrderDoesNotHaveTermsCode Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderDoesNotHaveTermsCode type exposes the following members.

Constructors

Name | Description
ShipRuleOrderDoesNotHaveTermsCode |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TermsCode |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderDoesNotHaveTermsCode Class
InSite.Model Namespace


ShipRuleOrderDoesNotHaveTermsCode Constructor

[image]

.NET Framework Class Library
ShipRuleOrderDoesNotHaveTermsCode Constructor
ShipRuleOrderDoesNotHaveTermsCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderDoesNotHaveTermsCode()
Visual C++
public:
ShipRuleOrderDoesNotHaveTermsCode()
JavaScript
InSite.Model.ShipRuleOrderDoesNotHaveTermsCode = function();

See Also

ShipRuleOrderDoesNotHaveTermsCode Class
InSite.Model Namespace


ShipRuleOrderDoesNotHaveTermsCode Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderDoesNotHaveTermsCode Fields
ShipRuleOrderDoesNotHaveTermsCode Class See Also Send Feedback

The ShipRuleOrderDoesNotHaveTermsCode type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderDoesNotHaveTermsCode Class
InSite.Model Namespace


ShipRuleOrderDoesNotHaveTermsCode Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderDoesNotHaveTermsCode Methods
ShipRuleOrderDoesNotHaveTermsCode Class See Also Send Feedback

The ShipRuleOrderDoesNotHaveTermsCode type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderDoesNotHaveTermsCode Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderDoesNotHaveTermsCode..::.IsValid Method
ShipRuleOrderDoesNotHaveTermsCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderDoesNotHaveTermsCode Class
InSite.Model Namespace


ShipRuleOrderDoesNotHaveTermsCode Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderDoesNotHaveTermsCode Properties
ShipRuleOrderDoesNotHaveTermsCode Class See Also Send Feedback

The ShipRuleOrderDoesNotHaveTermsCode type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TermsCode |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderDoesNotHaveTermsCode Class
InSite.Model Namespace


TermsCode Property

[image]

.NET Framework Class Library
ShipRuleOrderDoesNotHaveTermsCode..::.TermsCode Property
ShipRuleOrderDoesNotHaveTermsCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property TermsCode As String
C#
[DataMemberAttribute]
[SortField]
public virtual string TermsCode { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ TermsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_termsCode();
function set_termsCode(value);

See Also

ShipRuleOrderDoesNotHaveTermsCode Class
InSite.Model Namespace


ShipRuleOrderHasTermsCode Class

[image]

.NET Framework Class Library
ShipRuleOrderHasTermsCode Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderHasTermsCode _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderHasTermsCode : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderHasTermsCode : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderHasTermsCode = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderHasTermsCode',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderHasTermsCode

See Also

ShipRuleOrderHasTermsCode Members
InSite.Model Namespace


ShipRuleOrderHasTermsCode Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderHasTermsCode Members
ShipRuleOrderHasTermsCode Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderHasTermsCode type exposes the following members.

Constructors

Name | Description
ShipRuleOrderHasTermsCode |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TermsCode |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderHasTermsCode Class
InSite.Model Namespace


ShipRuleOrderHasTermsCode Constructor

[image]

.NET Framework Class Library
ShipRuleOrderHasTermsCode Constructor
ShipRuleOrderHasTermsCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderHasTermsCode()
Visual C++
public:
ShipRuleOrderHasTermsCode()
JavaScript
InSite.Model.ShipRuleOrderHasTermsCode = function();

See Also

ShipRuleOrderHasTermsCode Class
InSite.Model Namespace


ShipRuleOrderHasTermsCode Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderHasTermsCode Fields
ShipRuleOrderHasTermsCode Class See Also Send Feedback

The ShipRuleOrderHasTermsCode type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderHasTermsCode Class
InSite.Model Namespace


ShipRuleOrderHasTermsCode Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderHasTermsCode Methods
ShipRuleOrderHasTermsCode Class See Also Send Feedback

The ShipRuleOrderHasTermsCode type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderHasTermsCode Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderHasTermsCode..::.IsValid Method
ShipRuleOrderHasTermsCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderHasTermsCode Class
InSite.Model Namespace


ShipRuleOrderHasTermsCode Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderHasTermsCode Properties
ShipRuleOrderHasTermsCode Class See Also Send Feedback

The ShipRuleOrderHasTermsCode type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
TermsCode |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderHasTermsCode Class
InSite.Model Namespace


TermsCode Property

[image]

.NET Framework Class Library
ShipRuleOrderHasTermsCode..::.TermsCode Property
ShipRuleOrderHasTermsCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property TermsCode As String
C#
[SortField]
[DataMemberAttribute]
public virtual string TermsCode { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ TermsCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_termsCode();
function set_termsCode(value);

See Also

ShipRuleOrderHasTermsCode Class
InSite.Model Namespace


ShipRuleOrderNotShippingToCountry Class

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToCountry Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderNotShippingToCountry _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderNotShippingToCountry : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderNotShippingToCountry : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderNotShippingToCountry = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderNotShippingToCountry',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderNotShippingToCountry

See Also

ShipRuleOrderNotShippingToCountry Members
InSite.Model Namespace


ShipRuleOrderNotShippingToCountry Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToCountry Members
ShipRuleOrderNotShippingToCountry Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderNotShippingToCountry type exposes the following members.

Constructors

Name | Description
ShipRuleOrderNotShippingToCountry |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderNotShippingToCountry Constructor

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToCountry Constructor
ShipRuleOrderNotShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderNotShippingToCountry()
Visual C++
public:
ShipRuleOrderNotShippingToCountry()
JavaScript
InSite.Model.ShipRuleOrderNotShippingToCountry = function();

See Also

ShipRuleOrderNotShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderNotShippingToCountry Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToCountry Fields
ShipRuleOrderNotShippingToCountry Class See Also Send Feedback

The ShipRuleOrderNotShippingToCountry type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderNotShippingToCountry Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToCountry Methods
ShipRuleOrderNotShippingToCountry Class See Also Send Feedback

The ShipRuleOrderNotShippingToCountry type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToCountry Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToCountry..::.IsValid Method
ShipRuleOrderNotShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderNotShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderNotShippingToCountry Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToCountry Properties
ShipRuleOrderNotShippingToCountry Class See Also Send Feedback

The ShipRuleOrderNotShippingToCountry type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToCountry Class
InSite.Model Namespace


Country Property

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToCountry..::.Country Property
ShipRuleOrderNotShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Country As Country
C#
[DataMemberAttribute]
[SortField]
public virtual Country Country { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Country^ Country {
    Country^ get ();
    void set (Country^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

ShipRuleOrderNotShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderNotShippingToState Class

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToState Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderNotShippingToState _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderNotShippingToState : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderNotShippingToState : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderNotShippingToState = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderNotShippingToState',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderNotShippingToState

See Also

ShipRuleOrderNotShippingToState Members
InSite.Model Namespace


ShipRuleOrderNotShippingToState Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToState Members
ShipRuleOrderNotShippingToState Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderNotShippingToState type exposes the following members.

Constructors

Name | Description
ShipRuleOrderNotShippingToState |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToState Class
InSite.Model Namespace


ShipRuleOrderNotShippingToState Constructor

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToState Constructor
ShipRuleOrderNotShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderNotShippingToState()
Visual C++
public:
ShipRuleOrderNotShippingToState()
JavaScript
InSite.Model.ShipRuleOrderNotShippingToState = function();

See Also

ShipRuleOrderNotShippingToState Class
InSite.Model Namespace


ShipRuleOrderNotShippingToState Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToState Fields
ShipRuleOrderNotShippingToState Class See Also Send Feedback

The ShipRuleOrderNotShippingToState type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToState Class
InSite.Model Namespace


ShipRuleOrderNotShippingToState Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToState Methods
ShipRuleOrderNotShippingToState Class See Also Send Feedback

The ShipRuleOrderNotShippingToState type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToState Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToState..::.IsValid Method
ShipRuleOrderNotShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderNotShippingToState Class
InSite.Model Namespace


ShipRuleOrderNotShippingToState Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToState Properties
ShipRuleOrderNotShippingToState Class See Also Send Feedback

The ShipRuleOrderNotShippingToState type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToState Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToState..::.State Property
ShipRuleOrderNotShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property State As State
C#
[DataMemberAttribute]
[SortField]
public virtual State State { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property State^ State {
    State^ get ();
    void set (State^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

ShipRuleOrderNotShippingToState Class
InSite.Model Namespace


ShipRuleOrderNotShippingToZipCode Class

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToZipCode Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderNotShippingToZipCode _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderNotShippingToZipCode : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderNotShippingToZipCode : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderNotShippingToZipCode = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderNotShippingToZipCode',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderNotShippingToZipCode

See Also

ShipRuleOrderNotShippingToZipCode Members
InSite.Model Namespace


ShipRuleOrderNotShippingToZipCode Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToZipCode Members
ShipRuleOrderNotShippingToZipCode Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderNotShippingToZipCode type exposes the following members.

Constructors

Name | Description
ShipRuleOrderNotShippingToZipCode |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

ShipRuleOrderNotShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderNotShippingToZipCode Constructor

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToZipCode Constructor
ShipRuleOrderNotShippingToZipCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderNotShippingToZipCode()
Visual C++
public:
ShipRuleOrderNotShippingToZipCode()
JavaScript
InSite.Model.ShipRuleOrderNotShippingToZipCode = function();

See Also

ShipRuleOrderNotShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderNotShippingToZipCode Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToZipCode Fields
ShipRuleOrderNotShippingToZipCode Class See Also Send Feedback

The ShipRuleOrderNotShippingToZipCode type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderNotShippingToZipCode Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToZipCode Methods
ShipRuleOrderNotShippingToZipCode Class See Also Send Feedback

The ShipRuleOrderNotShippingToZipCode type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderNotShippingToZipCode Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToZipCode..::.IsValid Method
ShipRuleOrderNotShippingToZipCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderNotShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderNotShippingToZipCode Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderNotShippingToZipCode Properties
ShipRuleOrderNotShippingToZipCode Class See Also Send Feedback

The ShipRuleOrderNotShippingToZipCode type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

ShipRuleOrderNotShippingToZipCode Class
InSite.Model Namespace


Zip Property

[image]

.NET Framework Class Library
ShipRuleOrderNotShippingToZipCode..::.Zip Property
ShipRuleOrderNotShippingToZipCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Zip As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Zip { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

See Also

ShipRuleOrderNotShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderProductsNotInCategory Class

[image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderProductsNotInCategory _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderProductsNotInCategory : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderProductsNotInCategory : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderProductsNotInCategory = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderProductsNotInCategory',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderProductsNotInCategory

See Also

ShipRuleOrderProductsNotInCategory Members
InSite.Model Namespace


ShipRuleOrderProductsNotInCategory Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory Members
ShipRuleOrderProductsNotInCategory Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderProductsNotInCategory type exposes the following members.

Constructors

Name | Description
ShipRuleOrderProductsNotInCategory |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCategoryValid |
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderProductsNotInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsNotInCategory Constructor

[image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory Constructor
ShipRuleOrderProductsNotInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderProductsNotInCategory()
Visual C++
public:
ShipRuleOrderProductsNotInCategory()
JavaScript
InSite.Model.ShipRuleOrderProductsNotInCategory = function();

See Also

ShipRuleOrderProductsNotInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsNotInCategory Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory Fields
ShipRuleOrderProductsNotInCategory Class See Also Send Feedback

The ShipRuleOrderProductsNotInCategory type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderProductsNotInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsNotInCategory Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory Methods
ShipRuleOrderProductsNotInCategory Class See Also Send Feedback

The ShipRuleOrderProductsNotInCategory type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsCategoryValid |
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderProductsNotInCategory Class
InSite.Model Namespace


IsCategoryValid Method

[image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory..::.IsCategoryValid Method
ShipRuleOrderProductsNotInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsCategoryValid ( _
    category As Category _
) As Boolean
C#
public virtual bool IsCategoryValid(
    Category category
)
Visual C++
public:
virtual bool IsCategoryValid(
    Category^ category
)
JavaScript
function isCategoryValid(category);

Parameters

category
Type: InSite.Model..::.Category

See Also

ShipRuleOrderProductsNotInCategory Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory..::.IsValid Method
ShipRuleOrderProductsNotInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderProductsNotInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsNotInCategory Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory Properties
ShipRuleOrderProductsNotInCategory Class See Also Send Feedback

The ShipRuleOrderProductsNotInCategory type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderProductsNotInCategory Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
ShipRuleOrderProductsNotInCategory..::.Category Property
ShipRuleOrderProductsNotInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Category As Category
C#
[SortField]
[DataMemberAttribute]
public virtual Category Category { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

ShipRuleOrderProductsNotInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsOnlyInCategory Class

[image]

.NET Framework Class Library
ShipRuleOrderProductsOnlyInCategory Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderProductsOnlyInCategory _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderProductsOnlyInCategory : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderProductsOnlyInCategory : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderProductsOnlyInCategory = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderProductsOnlyInCategory',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderProductsOnlyInCategory

See Also

ShipRuleOrderProductsOnlyInCategory Members
InSite.Model Namespace


ShipRuleOrderProductsOnlyInCategory Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderProductsOnlyInCategory Members
ShipRuleOrderProductsOnlyInCategory Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderProductsOnlyInCategory type exposes the following members.

Constructors

Name | Description
ShipRuleOrderProductsOnlyInCategory |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderProductsOnlyInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsOnlyInCategory Constructor

[image]

.NET Framework Class Library
ShipRuleOrderProductsOnlyInCategory Constructor
ShipRuleOrderProductsOnlyInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderProductsOnlyInCategory()
Visual C++
public:
ShipRuleOrderProductsOnlyInCategory()
JavaScript
InSite.Model.ShipRuleOrderProductsOnlyInCategory = function();

See Also

ShipRuleOrderProductsOnlyInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsOnlyInCategory Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderProductsOnlyInCategory Fields
ShipRuleOrderProductsOnlyInCategory Class See Also Send Feedback

The ShipRuleOrderProductsOnlyInCategory type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderProductsOnlyInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsOnlyInCategory Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderProductsOnlyInCategory Methods
ShipRuleOrderProductsOnlyInCategory Class See Also Send Feedback

The ShipRuleOrderProductsOnlyInCategory type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderProductsOnlyInCategory Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderProductsOnlyInCategory..::.IsValid Method
ShipRuleOrderProductsOnlyInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderProductsOnlyInCategory Class
InSite.Model Namespace


ShipRuleOrderProductsOnlyInCategory Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderProductsOnlyInCategory Properties
ShipRuleOrderProductsOnlyInCategory Class See Also Send Feedback

The ShipRuleOrderProductsOnlyInCategory type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
Category |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderProductsOnlyInCategory Class
InSite.Model Namespace


Category Property

[image]

.NET Framework Class Library
ShipRuleOrderProductsOnlyInCategory..::.Category Property
ShipRuleOrderProductsOnlyInCategory Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Category As Category
C#
[DataMemberAttribute]
[SortField]
public virtual Category Category { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Category^ Category {
    Category^ get ();
    void set (Category^ value);
}
JavaScript
function get_category();
function set_category(value);

See Also

ShipRuleOrderProductsOnlyInCategory Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeek Class

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderShipDateIsDayOfWeek _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderShipDateIsDayOfWeek : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderShipDateIsDayOfWeek : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderShipDateIsDayOfWeek = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderShipDateIsDayOfWeek',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderShipDateIsDayOfWeek

See Also

ShipRuleOrderShipDateIsDayOfWeek Members
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeek Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek Members
ShipRuleOrderShipDateIsDayOfWeek Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderShipDateIsDayOfWeek type exposes the following members.

Constructors

Name | Description
ShipRuleOrderShipDateIsDayOfWeek |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DayOfWeek |
DayOfWeekString |
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeek Constructor

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek Constructor
ShipRuleOrderShipDateIsDayOfWeek Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderShipDateIsDayOfWeek()
Visual C++
public:
ShipRuleOrderShipDateIsDayOfWeek()
JavaScript
InSite.Model.ShipRuleOrderShipDateIsDayOfWeek = function();

See Also

ShipRuleOrderShipDateIsDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeek Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek Fields
ShipRuleOrderShipDateIsDayOfWeek Class See Also Send Feedback

The ShipRuleOrderShipDateIsDayOfWeek type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeek Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek Methods
ShipRuleOrderShipDateIsDayOfWeek Class See Also Send Feedback

The ShipRuleOrderShipDateIsDayOfWeek type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsDayOfWeek Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek..::.IsValid Method
ShipRuleOrderShipDateIsDayOfWeek Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderShipDateIsDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeek Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek Properties
ShipRuleOrderShipDateIsDayOfWeek Class See Also Send Feedback

The ShipRuleOrderShipDateIsDayOfWeek type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DayOfWeek |
DayOfWeekString |
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsDayOfWeek Class
InSite.Model Namespace


DayOfWeek Property

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek..::.DayOfWeek Property
ShipRuleOrderShipDateIsDayOfWeek Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DayOfWeek As DayOfWeek
C#
public virtual DayOfWeek DayOfWeek { get; set; }
Visual C++
public:
virtual property DayOfWeek DayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
JavaScript
function get_dayOfWeek();
function set_dayOfWeek(value);

See Also

ShipRuleOrderShipDateIsDayOfWeek Class
InSite.Model Namespace


DayOfWeekString Property

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeek..::.DayOfWeekString Property
ShipRuleOrderShipDateIsDayOfWeek Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property DayOfWeekString As String
C#
[SortField]
[DataMemberAttribute]
public virtual string DayOfWeekString { get; private set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ DayOfWeekString {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dayOfWeekString();
function set_dayOfWeekString(value);

See Also

ShipRuleOrderShipDateIsDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeekOrNull Class

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderShipDateIsDayOfWeekOrNull _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderShipDateIsDayOfWeekOrNull : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderShipDateIsDayOfWeekOrNull : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderShipDateIsDayOfWeekOrNull = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderShipDateIsDayOfWeekOrNull',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderShipDateIsDayOfWeekOrNull

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Members
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeekOrNull Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull Members
ShipRuleOrderShipDateIsDayOfWeekOrNull Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderShipDateIsDayOfWeekOrNull type exposes the following members.

Constructors

Name | Description
ShipRuleOrderShipDateIsDayOfWeekOrNull |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DayOfWeek |
DayOfWeekString |
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeekOrNull Constructor

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull Constructor
ShipRuleOrderShipDateIsDayOfWeekOrNull Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderShipDateIsDayOfWeekOrNull()
Visual C++
public:
ShipRuleOrderShipDateIsDayOfWeekOrNull()
JavaScript
InSite.Model.ShipRuleOrderShipDateIsDayOfWeekOrNull = function();

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeekOrNull Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull Fields
ShipRuleOrderShipDateIsDayOfWeekOrNull Class See Also Send Feedback

The ShipRuleOrderShipDateIsDayOfWeekOrNull type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeekOrNull Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull Methods
ShipRuleOrderShipDateIsDayOfWeekOrNull Class See Also Send Feedback

The ShipRuleOrderShipDateIsDayOfWeekOrNull type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull..::.IsValid Method
ShipRuleOrderShipDateIsDayOfWeekOrNull Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Class
InSite.Model Namespace


ShipRuleOrderShipDateIsDayOfWeekOrNull Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull Properties
ShipRuleOrderShipDateIsDayOfWeekOrNull Class See Also Send Feedback

The ShipRuleOrderShipDateIsDayOfWeekOrNull type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DayOfWeek |
DayOfWeekString |
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Class
InSite.Model Namespace


DayOfWeek Property

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull..::.DayOfWeek Property
ShipRuleOrderShipDateIsDayOfWeekOrNull Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DayOfWeek As DayOfWeek
C#
public virtual DayOfWeek DayOfWeek { get; set; }
Visual C++
public:
virtual property DayOfWeek DayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
JavaScript
function get_dayOfWeek();
function set_dayOfWeek(value);

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Class
InSite.Model Namespace


DayOfWeekString Property

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsDayOfWeekOrNull..::.DayOfWeekString Property
ShipRuleOrderShipDateIsDayOfWeekOrNull Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property DayOfWeekString As String
C#
[SortField]
[DataMemberAttribute]
public virtual string DayOfWeekString { get; private set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ DayOfWeekString {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dayOfWeekString();
function set_dayOfWeekString(value);

See Also

ShipRuleOrderShipDateIsDayOfWeekOrNull Class
InSite.Model Namespace


ShipRuleOrderShipDateIsNotDayOfWeek Class

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderShipDateIsNotDayOfWeek _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderShipDateIsNotDayOfWeek : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderShipDateIsNotDayOfWeek : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderShipDateIsNotDayOfWeek = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderShipDateIsNotDayOfWeek',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderShipDateIsNotDayOfWeek

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Members
InSite.Model Namespace


ShipRuleOrderShipDateIsNotDayOfWeek Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek Members
ShipRuleOrderShipDateIsNotDayOfWeek Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderShipDateIsNotDayOfWeek type exposes the following members.

Constructors

Name | Description
ShipRuleOrderShipDateIsNotDayOfWeek |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DayOfWeek |
DayOfWeekString |
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsNotDayOfWeek Constructor

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek Constructor
ShipRuleOrderShipDateIsNotDayOfWeek Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderShipDateIsNotDayOfWeek()
Visual C++
public:
ShipRuleOrderShipDateIsNotDayOfWeek()
JavaScript
InSite.Model.ShipRuleOrderShipDateIsNotDayOfWeek = function();

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsNotDayOfWeek Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek Fields
ShipRuleOrderShipDateIsNotDayOfWeek Class See Also Send Feedback

The ShipRuleOrderShipDateIsNotDayOfWeek type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsNotDayOfWeek Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek Methods
ShipRuleOrderShipDateIsNotDayOfWeek Class See Also Send Feedback

The ShipRuleOrderShipDateIsNotDayOfWeek type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek..::.IsValid Method
ShipRuleOrderShipDateIsNotDayOfWeek Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShipDateIsNotDayOfWeek Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek Properties
ShipRuleOrderShipDateIsNotDayOfWeek Class See Also Send Feedback

The ShipRuleOrderShipDateIsNotDayOfWeek type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DayOfWeek |
DayOfWeekString |
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Class
InSite.Model Namespace


DayOfWeek Property

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek..::.DayOfWeek Property
ShipRuleOrderShipDateIsNotDayOfWeek Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property DayOfWeek As DayOfWeek
C#
public virtual DayOfWeek DayOfWeek { get; set; }
Visual C++
public:
virtual property DayOfWeek DayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}
JavaScript
function get_dayOfWeek();
function set_dayOfWeek(value);

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Class
InSite.Model Namespace


DayOfWeekString Property

[image]

.NET Framework Class Library
ShipRuleOrderShipDateIsNotDayOfWeek..::.DayOfWeekString Property
ShipRuleOrderShipDateIsNotDayOfWeek Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property DayOfWeekString As String
C#
[DataMemberAttribute]
[SortField]
public virtual string DayOfWeekString { get; private set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ DayOfWeekString {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dayOfWeekString();
function set_dayOfWeekString(value);

See Also

ShipRuleOrderShipDateIsNotDayOfWeek Class
InSite.Model Namespace


ShipRuleOrderShippingToCountry Class

[image]

.NET Framework Class Library
ShipRuleOrderShippingToCountry Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderShippingToCountry _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderShippingToCountry : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderShippingToCountry : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderShippingToCountry = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderShippingToCountry',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderShippingToCountry

See Also

ShipRuleOrderShippingToCountry Members
InSite.Model Namespace


ShipRuleOrderShippingToCountry Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToCountry Members
ShipRuleOrderShippingToCountry Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderShippingToCountry type exposes the following members.

Constructors

Name | Description
ShipRuleOrderShippingToCountry |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderShippingToCountry Constructor

[image]

.NET Framework Class Library
ShipRuleOrderShippingToCountry Constructor
ShipRuleOrderShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderShippingToCountry()
Visual C++
public:
ShipRuleOrderShippingToCountry()
JavaScript
InSite.Model.ShipRuleOrderShippingToCountry = function();

See Also

ShipRuleOrderShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderShippingToCountry Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToCountry Fields
ShipRuleOrderShippingToCountry Class See Also Send Feedback

The ShipRuleOrderShippingToCountry type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderShippingToCountry Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToCountry Methods
ShipRuleOrderShippingToCountry Class See Also Send Feedback

The ShipRuleOrderShippingToCountry type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToCountry Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderShippingToCountry..::.IsValid Method
ShipRuleOrderShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderShippingToCountry Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToCountry Properties
ShipRuleOrderShippingToCountry Class See Also Send Feedback

The ShipRuleOrderShippingToCountry type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToCountry Class
InSite.Model Namespace


Country Property

[image]

.NET Framework Class Library
ShipRuleOrderShippingToCountry..::.Country Property
ShipRuleOrderShippingToCountry Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Country As Country
C#
[SortField]
[DataMemberAttribute]
public virtual Country Country { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Country^ Country {
    Country^ get ();
    void set (Country^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

ShipRuleOrderShippingToCountry Class
InSite.Model Namespace


ShipRuleOrderShippingToState Class

[image]

.NET Framework Class Library
ShipRuleOrderShippingToState Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderShippingToState _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderShippingToState : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderShippingToState : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderShippingToState = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderShippingToState',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderShippingToState

See Also

ShipRuleOrderShippingToState Members
InSite.Model Namespace


ShipRuleOrderShippingToState Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToState Members
ShipRuleOrderShippingToState Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderShippingToState type exposes the following members.

Constructors

Name | Description
ShipRuleOrderShippingToState |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToState Class
InSite.Model Namespace


ShipRuleOrderShippingToState Constructor

[image]

.NET Framework Class Library
ShipRuleOrderShippingToState Constructor
ShipRuleOrderShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderShippingToState()
Visual C++
public:
ShipRuleOrderShippingToState()
JavaScript
InSite.Model.ShipRuleOrderShippingToState = function();

See Also

ShipRuleOrderShippingToState Class
InSite.Model Namespace


ShipRuleOrderShippingToState Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToState Fields
ShipRuleOrderShippingToState Class See Also Send Feedback

The ShipRuleOrderShippingToState type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToState Class
InSite.Model Namespace


ShipRuleOrderShippingToState Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToState Methods
ShipRuleOrderShippingToState Class See Also Send Feedback

The ShipRuleOrderShippingToState type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToState Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderShippingToState..::.IsValid Method
ShipRuleOrderShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderShippingToState Class
InSite.Model Namespace


ShipRuleOrderShippingToState Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToState Properties
ShipRuleOrderShippingToState Class See Also Send Feedback

The ShipRuleOrderShippingToState type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToState Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
ShipRuleOrderShippingToState..::.State Property
ShipRuleOrderShippingToState Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property State As State
C#
[SortField]
[DataMemberAttribute]
public virtual State State { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property State^ State {
    State^ get ();
    void set (State^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

ShipRuleOrderShippingToState Class
InSite.Model Namespace


ShipRuleOrderShippingToZipCode Class

[image]

.NET Framework Class Library
ShipRuleOrderShippingToZipCode Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderShippingToZipCode _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderShippingToZipCode : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderShippingToZipCode : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderShippingToZipCode = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderShippingToZipCode',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderShippingToZipCode

See Also

ShipRuleOrderShippingToZipCode Members
InSite.Model Namespace


ShipRuleOrderShippingToZipCode Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToZipCode Members
ShipRuleOrderShippingToZipCode Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderShippingToZipCode type exposes the following members.

Constructors

Name | Description
ShipRuleOrderShippingToZipCode |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

ShipRuleOrderShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderShippingToZipCode Constructor

[image]

.NET Framework Class Library
ShipRuleOrderShippingToZipCode Constructor
ShipRuleOrderShippingToZipCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderShippingToZipCode()
Visual C++
public:
ShipRuleOrderShippingToZipCode()
JavaScript
InSite.Model.ShipRuleOrderShippingToZipCode = function();

See Also

ShipRuleOrderShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderShippingToZipCode Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToZipCode Fields
ShipRuleOrderShippingToZipCode Class See Also Send Feedback

The ShipRuleOrderShippingToZipCode type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderShippingToZipCode Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToZipCode Methods
ShipRuleOrderShippingToZipCode Class See Also Send Feedback

The ShipRuleOrderShippingToZipCode type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderShippingToZipCode Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderShippingToZipCode..::.IsValid Method
ShipRuleOrderShippingToZipCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderShippingToZipCode Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderShippingToZipCode Properties
ShipRuleOrderShippingToZipCode Class See Also Send Feedback

The ShipRuleOrderShippingToZipCode type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

ShipRuleOrderShippingToZipCode Class
InSite.Model Namespace


Zip Property

[image]

.NET Framework Class Library
ShipRuleOrderShippingToZipCode..::.Zip Property
ShipRuleOrderShippingToZipCode Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Zip As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Zip { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

See Also

ShipRuleOrderShippingToZipCode Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesExceedMinimum Class

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesExceedMinimum Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderSubTotalDoesExceedMinimum _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderSubTotalDoesExceedMinimum : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderSubTotalDoesExceedMinimum : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderSubTotalDoesExceedMinimum = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderSubTotalDoesExceedMinimum',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderSubTotalDoesExceedMinimum

See Also

ShipRuleOrderSubTotalDoesExceedMinimum Members
InSite.Model Namespace


ShipRuleOrderSubTotalDoesExceedMinimum Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesExceedMinimum Members
ShipRuleOrderSubTotalDoesExceedMinimum Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderSubTotalDoesExceedMinimum type exposes the following members.

Constructors

Name | Description
ShipRuleOrderSubTotalDoesExceedMinimum |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MinimumAmount |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalDoesExceedMinimum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesExceedMinimum Constructor

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesExceedMinimum Constructor
ShipRuleOrderSubTotalDoesExceedMinimum Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderSubTotalDoesExceedMinimum()
Visual C++
public:
ShipRuleOrderSubTotalDoesExceedMinimum()
JavaScript
InSite.Model.ShipRuleOrderSubTotalDoesExceedMinimum = function();

See Also

ShipRuleOrderSubTotalDoesExceedMinimum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesExceedMinimum Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesExceedMinimum Fields
ShipRuleOrderSubTotalDoesExceedMinimum Class See Also Send Feedback

The ShipRuleOrderSubTotalDoesExceedMinimum type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalDoesExceedMinimum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesExceedMinimum Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesExceedMinimum Methods
ShipRuleOrderSubTotalDoesExceedMinimum Class See Also Send Feedback

The ShipRuleOrderSubTotalDoesExceedMinimum type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalDoesExceedMinimum Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesExceedMinimum..::.IsValid Method
ShipRuleOrderSubTotalDoesExceedMinimum Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderSubTotalDoesExceedMinimum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesExceedMinimum Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesExceedMinimum Properties
ShipRuleOrderSubTotalDoesExceedMinimum Class See Also Send Feedback

The ShipRuleOrderSubTotalDoesExceedMinimum type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MinimumAmount |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalDoesExceedMinimum Class
InSite.Model Namespace


MinimumAmount Property

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesExceedMinimum..::.MinimumAmount Property
ShipRuleOrderSubTotalDoesExceedMinimum Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property MinimumAmount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal MinimumAmount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal MinimumAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_minimumAmount();
function set_minimumAmount(value);

See Also

ShipRuleOrderSubTotalDoesExceedMinimum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesNotExceedMaximum Class

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesNotExceedMaximum Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderSubTotalDoesNotExceedMaximum _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderSubTotalDoesNotExceedMaximum : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderSubTotalDoesNotExceedMaximum : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderSubTotalDoesNotExceedMaximum = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderSubTotalDoesNotExceedMaximum',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderSubTotalDoesNotExceedMaximum

See Also

ShipRuleOrderSubTotalDoesNotExceedMaximum Members
InSite.Model Namespace


ShipRuleOrderSubTotalDoesNotExceedMaximum Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesNotExceedMaximum Members
ShipRuleOrderSubTotalDoesNotExceedMaximum Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderSubTotalDoesNotExceedMaximum type exposes the following members.

Constructors

Name | Description
ShipRuleOrderSubTotalDoesNotExceedMaximum |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MaximumAmount |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalDoesNotExceedMaximum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesNotExceedMaximum Constructor

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesNotExceedMaximum Constructor
ShipRuleOrderSubTotalDoesNotExceedMaximum Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderSubTotalDoesNotExceedMaximum()
Visual C++
public:
ShipRuleOrderSubTotalDoesNotExceedMaximum()
JavaScript
InSite.Model.ShipRuleOrderSubTotalDoesNotExceedMaximum = function();

See Also

ShipRuleOrderSubTotalDoesNotExceedMaximum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesNotExceedMaximum Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesNotExceedMaximum Fields
ShipRuleOrderSubTotalDoesNotExceedMaximum Class See Also Send Feedback

The ShipRuleOrderSubTotalDoesNotExceedMaximum type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalDoesNotExceedMaximum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesNotExceedMaximum Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesNotExceedMaximum Methods
ShipRuleOrderSubTotalDoesNotExceedMaximum Class See Also Send Feedback

The ShipRuleOrderSubTotalDoesNotExceedMaximum type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalDoesNotExceedMaximum Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesNotExceedMaximum..::.IsValid Method
ShipRuleOrderSubTotalDoesNotExceedMaximum Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderSubTotalDoesNotExceedMaximum Class
InSite.Model Namespace


ShipRuleOrderSubTotalDoesNotExceedMaximum Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesNotExceedMaximum Properties
ShipRuleOrderSubTotalDoesNotExceedMaximum Class See Also Send Feedback

The ShipRuleOrderSubTotalDoesNotExceedMaximum type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MaximumAmount |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalDoesNotExceedMaximum Class
InSite.Model Namespace


MaximumAmount Property

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalDoesNotExceedMaximum..::.MaximumAmount Property
ShipRuleOrderSubTotalDoesNotExceedMaximum Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property MaximumAmount As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal MaximumAmount { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal MaximumAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_maximumAmount();
function set_maximumAmount(value);

See Also

ShipRuleOrderSubTotalDoesNotExceedMaximum Class
InSite.Model Namespace


ShipRuleOrderSubTotalInRange Class

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipRuleOrderSubTotalInRange _
    Inherits ShipRule
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipRuleOrderSubTotalInRange : ShipRule
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipRuleOrderSubTotalInRange : public ShipRule
JavaScript
InSite.Model.ShipRuleOrderSubTotalInRange = function();

Type.createClass(
    'InSite.Model.ShipRuleOrderSubTotalInRange',
    InSite.Model.ShipRule);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <( ShipRule >)>)
InSite.Model..::.ShipRule
InSite.Model..::.ShipRuleOrderSubTotalInRange

See Also

ShipRuleOrderSubTotalInRange Members
InSite.Model Namespace


ShipRuleOrderSubTotalInRange Members

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange Members
ShipRuleOrderSubTotalInRange Class Constructors Methods Fields Properties See Also Send Feedback

The ShipRuleOrderSubTotalInRange type exposes the following members.

Constructors

Name | Description
ShipRuleOrderSubTotalInRange |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MaximumAmount |
MinimumAmount |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalInRange Class
InSite.Model Namespace


ShipRuleOrderSubTotalInRange Constructor

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange Constructor
ShipRuleOrderSubTotalInRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipRuleOrderSubTotalInRange()
Visual C++
public:
ShipRuleOrderSubTotalInRange()
JavaScript
InSite.Model.ShipRuleOrderSubTotalInRange = function();

See Also

ShipRuleOrderSubTotalInRange Class
InSite.Model Namespace


ShipRuleOrderSubTotalInRange Fields

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange Fields
ShipRuleOrderSubTotalInRange Class See Also Send Feedback

The ShipRuleOrderSubTotalInRange type exposes the following members.

Fields

Name | Description
_carrier | (Inherited from ShipRule.)
_condition | (Inherited from ShipRule.)
_executionGroup | (Inherited from ShipRule.)
_executionOrder | (Inherited from ShipRule.)
_shipRuleId | (Inherited from ShipRule.)
_shipVia | (Inherited from ShipRule.)
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalInRange Class
InSite.Model Namespace


ShipRuleOrderSubTotalInRange Methods

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange Methods
ShipRuleOrderSubTotalInRange Class See Also Send Feedback

The ShipRuleOrderSubTotalInRange type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | (Overrides ShipRule..::.IsValid(CustomerOrder, Customer).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalInRange Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange..::.IsValid Method
ShipRuleOrderSubTotalInRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function IsValid ( _
    customerOrder As CustomerOrder, _
    customer As Customer _
) As Boolean
C#
public override bool IsValid(
    CustomerOrder customerOrder,
    Customer customer
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder,
    Customer^ customer
) override
JavaScript
function isValid(customerOrder, customer);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder
customer
Type: InSite.Model..::.Customer

Implements

IRule..::.IsValid(CustomerOrder, Customer)

See Also

ShipRuleOrderSubTotalInRange Class
InSite.Model Namespace


ShipRuleOrderSubTotalInRange Properties

[image] [image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange Properties
ShipRuleOrderSubTotalInRange Class See Also Send Feedback

The ShipRuleOrderSubTotalInRange type exposes the following members.

Properties

Name | Description
Carrier | (Inherited from ShipRule.)
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Condition | (Inherited from ShipRule.)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ExecutionGroup | (Inherited from ShipRule.)
ExecutionOrder | (Inherited from ShipRule.)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MaximumAmount |
MinimumAmount |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RuleName | (Inherited from ShipRule.)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipRuleId | (Inherited from ShipRule.)
ShipVia | (Inherited from ShipRule.)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipRuleOrderSubTotalInRange Class
InSite.Model Namespace


MaximumAmount Property

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange..::.MaximumAmount Property
ShipRuleOrderSubTotalInRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MaximumAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal MaximumAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal MaximumAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_maximumAmount();
function set_maximumAmount(value);

See Also

ShipRuleOrderSubTotalInRange Class
InSite.Model Namespace


MinimumAmount Property

[image]

.NET Framework Class Library
ShipRuleOrderSubTotalInRange..::.MinimumAmount Property
ShipRuleOrderSubTotalInRange Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property MinimumAmount As Decimal
C#
[DataMemberAttribute]
[SortField]
public virtual decimal MinimumAmount { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property Decimal MinimumAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_minimumAmount();
function set_minimumAmount(value);

See Also

ShipRuleOrderSubTotalInRange Class
InSite.Model Namespace


ShipVia Class

[image]

.NET Framework Class Library
ShipVia Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class ShipVia _
    Inherits ModelBase(Of ShipVia)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class ShipVia : ModelBase<ShipVia>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class ShipVia : public ModelBase<ShipVia^>
JavaScript
InSite.Model.ShipVia = function();

Type.createClass(
    'InSite.Model.ShipVia',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(ShipVia>)>)
InSite.Model..::.ShipVia

See Also

ShipVia Members
InSite.Model Namespace


ShipVia Members

[image] [image]

.NET Framework Class Library
ShipVia Members
ShipVia Class Constructors Methods Fields Properties See Also Send Feedback

The ShipVia type exposes the following members.

Constructors

Name | Description
ShipVia | Overloaded.

Methods

Name | Description
AddShipCharge |
AddShipRate |
AddShipRule |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAmount |
GetByShipCode |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetShipRate |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveShipCharge |
RemoveShipRate |
RemoveShipRule |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
AllowScheduledShipDate |
Carrier |
CarrierName |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ChargeAmount |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
Enable |
ErpShipCode |
FlatFee |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsDefault |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MinimumFee |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipChargeAmount |
ShipCharges |
ShipCode |
ShipRates |
ShipRules | Gets/Sets a collection of Shipping Rules that the Shipping Engine will use to Validate whether the shipvia can be used for the order
ShipViaId |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipVia Class
InSite.Model Namespace


ShipVia Constructor

[image] [image]

.NET Framework Class Library
ShipVia Constructor
ShipVia Class See Also Send Feedback

Overload List

Name | Description
ShipVia()()() |
ShipVia(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

ShipVia Class
ShipVia Members
InSite.Model Namespace


ShipVia Constructor

[image]

.NET Framework Class Library
ShipVia Constructor
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ShipVia()
Visual C++
public:
ShipVia()
JavaScript
InSite.Model.ShipVia = function();

See Also

ShipVia Class
ShipVia Overload
InSite.Model Namespace


ShipVia Constructor (SearchMode)

[image]

.NET Framework Class Library
ShipVia Constructor (SearchMode)
ShipVia Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public ShipVia(
    SearchMode searchMode
)
Visual C++
public:
ShipVia(
    SearchMode searchMode
)
JavaScript
InSite.Model.ShipVia = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

ShipVia Class
ShipVia Overload
InSite.Model Namespace


ShipVia Fields

[image] [image]

.NET Framework Class Library
ShipVia Fields
ShipVia Class See Also Send Feedback

The ShipVia type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipVia Class
InSite.Model Namespace


ShipVia Methods

[image] [image]

.NET Framework Class Library
ShipVia Methods
ShipVia Class See Also Send Feedback

The ShipVia type exposes the following members.

Methods

Name | Description
AddShipCharge |
AddShipRate |
AddShipRule |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAmount |
GetByShipCode |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetShipRate |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveShipCharge |
RemoveShipRate |
RemoveShipRule |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipVia Class
InSite.Model Namespace


AddShipCharge Method

[image]

.NET Framework Class Library
ShipVia..::.AddShipCharge Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipCharge ( _
    value As ShipCharge _
)
C#
public virtual void AddShipCharge(
    ShipCharge value
)
Visual C++
public:
virtual void AddShipCharge(
    ShipCharge^ value
)
JavaScript
function addShipCharge(value);

Parameters

value
Type: InSite.Model..::.ShipCharge

See Also

ShipVia Class
InSite.Model Namespace


AddShipRate Method

[image]

.NET Framework Class Library
ShipVia..::.AddShipRate Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipRate ( _
    value As ShipRate _
)
C#
public virtual void AddShipRate(
    ShipRate value
)
Visual C++
public:
virtual void AddShipRate(
    ShipRate^ value
)
JavaScript
function addShipRate(value);

Parameters

value
Type: InSite.Model..::.ShipRate

See Also

ShipVia Class
InSite.Model Namespace


AddShipRule Method

[image]

.NET Framework Class Library
ShipVia..::.AddShipRule Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddShipRule ( _
    value As ShipRule _
)
C#
public virtual void AddShipRule(
    ShipRule value
)
Visual C++
public:
virtual void AddShipRule(
    ShipRule^ value
)
JavaScript
function addShipRule(value);

Parameters

value
Type: InSite.Model..::.ShipRule

See Also

ShipVia Class
InSite.Model Namespace


GetAmount Method

[image]

.NET Framework Class Library
ShipVia..::.GetAmount Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetAmount ( _
    amount As Decimal _
) As Decimal
C#
public virtual decimal GetAmount(
    decimal amount
)
Visual C++
public:
virtual Decimal GetAmount(
    Decimal amount
)
JavaScript
function getAmount(amount);

Parameters

amount
Type: System..::.Decimal

See Also

ShipVia Class
InSite.Model Namespace


GetByShipCode Method

[image]

.NET Framework Class Library
ShipVia..::.GetByShipCode Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByShipCode ( _
    shipCode As String _
) As ShipVia
C#
public static ShipVia GetByShipCode(
    string shipCode
)
Visual C++
public:
static ShipVia^ GetByShipCode(
    String^ shipCode
)
JavaScript
InSite.Model.ShipVia.getByShipCode = function(shipCode);

Parameters

shipCode
Type: System..::.String

See Also

ShipVia Class
InSite.Model Namespace


GetShipRate Method

[image]

.NET Framework Class Library
ShipVia..::.GetShipRate Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetShipRate ( _
    quantity As Decimal, _
    amount As Decimal _
) As Decimal
C#
public virtual decimal GetShipRate(
    decimal quantity,
    decimal amount
)
Visual C++
public:
virtual Decimal GetShipRate(
    Decimal quantity,
    Decimal amount
)
JavaScript
function getShipRate(quantity, amount);

Parameters

quantity
Type: System..::.Decimal
amount
Type: System..::.Decimal

See Also

ShipVia Class
InSite.Model Namespace


IsValid Method

[image]

.NET Framework Class Library
ShipVia..::.IsValid Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValid ( _
    customerOrder As CustomerOrder _
) As Boolean
C#
public virtual bool IsValid(
    CustomerOrder customerOrder
)
Visual C++
public:
virtual bool IsValid(
    CustomerOrder^ customerOrder
)
JavaScript
function isValid(customerOrder);

Parameters

customerOrder
Type: InSite.Model..::.CustomerOrder

See Also

ShipVia Class
InSite.Model Namespace


RemoveShipCharge Method

[image]

.NET Framework Class Library
ShipVia..::.RemoveShipCharge Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipCharge ( _
    value As ShipCharge _
)
C#
public virtual void RemoveShipCharge(
    ShipCharge value
)
Visual C++
public:
virtual void RemoveShipCharge(
    ShipCharge^ value
)
JavaScript
function removeShipCharge(value);

Parameters

value
Type: InSite.Model..::.ShipCharge

See Also

ShipVia Class
InSite.Model Namespace


RemoveShipRate Method

[image]

.NET Framework Class Library
ShipVia..::.RemoveShipRate Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipRate ( _
    value As ShipRate _
)
C#
public virtual void RemoveShipRate(
    ShipRate value
)
Visual C++
public:
virtual void RemoveShipRate(
    ShipRate^ value
)
JavaScript
function removeShipRate(value);

Parameters

value
Type: InSite.Model..::.ShipRate

See Also

ShipVia Class
InSite.Model Namespace


RemoveShipRule Method

[image]

.NET Framework Class Library
ShipVia..::.RemoveShipRule Method
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveShipRule ( _
    value As ShipRule _
)
C#
public virtual void RemoveShipRule(
    ShipRule value
)
Visual C++
public:
virtual void RemoveShipRule(
    ShipRule^ value
)
JavaScript
function removeShipRule(value);

Parameters

value
Type: InSite.Model..::.ShipRule

See Also

ShipVia Class
InSite.Model Namespace


ShipVia Properties

[image] [image]

.NET Framework Class Library
ShipVia Properties
ShipVia Class See Also Send Feedback

The ShipVia type exposes the following members.

Properties

Name | Description
Active |
AllowScheduledShipDate |
Carrier |
CarrierName |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ChargeAmount |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
Enable |
ErpShipCode |
FlatFee |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsDefault |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MinimumFee |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipChargeAmount |
ShipCharges |
ShipCode |
ShipRates |
ShipRules | Gets/Sets a collection of Shipping Rules that the Shipping Engine will use to Validate whether the shipvia can be used for the order
ShipViaId |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

ShipVia Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
ShipVia..::.Active Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

ShipVia Class
InSite.Model Namespace


AllowScheduledShipDate Property

[image]

.NET Framework Class Library
ShipVia..::.AllowScheduledShipDate Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AllowScheduledShipDate As Boolean
C#
[DataMemberAttribute]
public virtual bool AllowScheduledShipDate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool AllowScheduledShipDate {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowScheduledShipDate();
function set_allowScheduledShipDate(value);

See Also

ShipVia Class
InSite.Model Namespace


Carrier Property

[image]

.NET Framework Class Library
ShipVia..::.Carrier Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Carrier As Carrier
C#
public virtual Carrier Carrier { get; set; }
Visual C++
public:
virtual property Carrier^ Carrier {
    Carrier^ get ();
    void set (Carrier^ value);
}
JavaScript
function get_carrier();
function set_carrier(value);

See Also

ShipVia Class
InSite.Model Namespace


CarrierName Property

[image]

.NET Framework Class Library
ShipVia..::.CarrierName Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CarrierName As String
C#
[DataMemberAttribute]
public virtual string CarrierName { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CarrierName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_carrierName();
function set_carrierName(value);

See Also

ShipVia Class
InSite.Model Namespace


ChargeAmount Property

[image]

.NET Framework Class Library
ShipVia..::.ChargeAmount Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ChargeAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal ChargeAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal ChargeAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_chargeAmount();
function set_chargeAmount(value);

See Also

ShipVia Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
ShipVia..::.Deactivate Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

ShipVia Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
ShipVia..::.Description Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

ShipVia Class
InSite.Model Namespace


Enable Property

[image]

.NET Framework Class Library
ShipVia..::.Enable Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Enable As Boolean
C#
[DataMemberAttribute]
public virtual bool Enable { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool Enable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_enable();
function set_enable(value);

See Also

ShipVia Class
InSite.Model Namespace


ErpShipCode Property

[image]

.NET Framework Class Library
ShipVia..::.ErpShipCode Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ErpShipCode As String
C#
[DataMemberAttribute]
public virtual string ErpShipCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ErpShipCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpShipCode();
function set_erpShipCode(value);

See Also

ShipVia Class
InSite.Model Namespace


FlatFee Property

[image]

.NET Framework Class Library
ShipVia..::.FlatFee Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FlatFee As Decimal
C#
[DataMemberAttribute]
public virtual decimal FlatFee { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal FlatFee {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_flatFee();
function set_flatFee(value);

See Also

ShipVia Class
InSite.Model Namespace


IsDefault Property

[image]

.NET Framework Class Library
ShipVia..::.IsDefault Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsDefault As Boolean
C#
[DataMemberAttribute]
public virtual bool IsDefault { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsDefault {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDefault();
function set_isDefault(value);

See Also

ShipVia Class
InSite.Model Namespace


MinimumFee Property

[image]

.NET Framework Class Library
ShipVia..::.MinimumFee Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MinimumFee As Decimal
C#
[DataMemberAttribute]
public virtual decimal MinimumFee { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal MinimumFee {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_minimumFee();
function set_minimumFee(value);

See Also

ShipVia Class
InSite.Model Namespace


ShipChargeAmount Property

[image]

.NET Framework Class Library
ShipVia..::.ShipChargeAmount Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ShipChargeAmount As Decimal
C#
public virtual decimal ShipChargeAmount { get; }
Visual C++
public:
virtual property Decimal ShipChargeAmount {
    Decimal get ();
}
JavaScript
function get_shipChargeAmount();

See Also

ShipVia Class
InSite.Model Namespace


ShipCharges Property

[image]

.NET Framework Class Library
ShipVia..::.ShipCharges Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipCharges As ChildList(Of ShipCharge)
C#
[DataMemberAttribute]
public virtual ChildList<ShipCharge> ShipCharges { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ShipCharge^>^ ShipCharges {
    ChildList<ShipCharge^>^ get ();
    void set (ChildList<ShipCharge^>^ value);
}
JavaScript
function get_shipCharges();
function set_shipCharges(value);

See Also

ShipVia Class
InSite.Model Namespace


ShipCode Property

[image]

.NET Framework Class Library
ShipVia..::.ShipCode Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property ShipCode As String
C#
[DataMemberAttribute]
[SortField]
public virtual string ShipCode { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ ShipCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipCode();
function set_shipCode(value);

See Also

ShipVia Class
InSite.Model Namespace


ShipRates Property

[image]

.NET Framework Class Library
ShipVia..::.ShipRates Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipRates As ChildList(Of ShipRate)
C#
[DataMemberAttribute]
public virtual ChildList<ShipRate> ShipRates { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ShipRate^>^ ShipRates {
    ChildList<ShipRate^>^ get ();
    void set (ChildList<ShipRate^>^ value);
}
JavaScript
function get_shipRates();
function set_shipRates(value);

See Also

ShipVia Class
InSite.Model Namespace


ShipRules Property

[image]

.NET Framework Class Library
ShipVia..::.ShipRules Property
ShipVia Class See Also Send Feedback

Gets/Sets a collection of Shipping Rules that the Shipping Engine will use to Validate whether the shipvia can be used for the order

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipRules As ChildList(Of ShipRule)
C#
[DataMemberAttribute]
public virtual ChildList<ShipRule> ShipRules { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ShipRule^>^ ShipRules {
    ChildList<ShipRule^>^ get ();
    void set (ChildList<ShipRule^>^ value);
}
JavaScript
function get_shipRules();
function set_shipRules(value);

See Also

ShipVia Class
InSite.Model Namespace


ShipViaId Property

[image]

.NET Framework Class Library
ShipVia..::.ShipViaId Property
ShipVia Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipViaId As Guid
C#
public virtual Guid ShipViaId { get; set; }
Visual C++
public:
virtual property Guid ShipViaId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_shipViaId();
function set_shipViaId(value);

See Also

ShipVia Class
InSite.Model Namespace


SOAFilterObject Class

[image]

.NET Framework Class Library
SOAFilterObject Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataContractAttribute> _
Public Class SOAFilterObject _
    Inherits ModelBase(Of SOAFilterObject)
C#
[DataContractAttribute]
public class SOAFilterObject : ModelBase<SOAFilterObject>
Visual C++
[DataContractAttribute]
public ref class SOAFilterObject : public ModelBase<SOAFilterObject^>
JavaScript
InSite.Model.SOAFilterObject = function();

Type.createClass(
    'InSite.Model.SOAFilterObject',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(SOAFilterObject>)>)
InSite.Model..::.SOAFilterObject

See Also

SOAFilterObject Members
InSite.Model Namespace


SOAFilterObject Members

[image] [image]

.NET Framework Class Library
SOAFilterObject Members
SOAFilterObject Class Constructors Methods Fields Properties See Also Send Feedback

The SOAFilterObject type exposes the following members.

Constructors

Name | Description
SOAFilterObject |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
FilterProperties |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectName |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAFilterObjectId |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortExpression |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAFilterObject Class
InSite.Model Namespace


SOAFilterObject Constructor

[image]

.NET Framework Class Library
SOAFilterObject Constructor
SOAFilterObject Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SOAFilterObject()
Visual C++
public:
SOAFilterObject()
JavaScript
InSite.Model.SOAFilterObject = function();

See Also

SOAFilterObject Class
InSite.Model Namespace


SOAFilterObject Fields

[image] [image]

.NET Framework Class Library
SOAFilterObject Fields
SOAFilterObject Class See Also Send Feedback

The SOAFilterObject type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAFilterObject Class
InSite.Model Namespace


SOAFilterObject Methods

[image] [image]

.NET Framework Class Library
SOAFilterObject Methods
SOAFilterObject Class See Also Send Feedback

The SOAFilterObject type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAFilterObject Class
InSite.Model Namespace


SOAFilterObject Properties

[image] [image]

.NET Framework Class Library
SOAFilterObject Properties
SOAFilterObject Class See Also Send Feedback

The SOAFilterObject type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
FilterProperties |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectName |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAFilterObjectId |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortExpression |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAFilterObject Class
InSite.Model Namespace


FilterProperties Property

[image]

.NET Framework Class Library
SOAFilterObject..::.FilterProperties Property
SOAFilterObject Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property FilterProperties As List(Of SOAFilterProperty)
C#
[DataMemberAttribute]
public List<SOAFilterProperty> FilterProperties { get; set; }
Visual C++
[DataMemberAttribute]
public:
property List<SOAFilterProperty^>^ FilterProperties {
    List<SOAFilterProperty^>^ get ();
    void set (List<SOAFilterProperty^>^ value);
}
JavaScript
function get_filterProperties();
function set_filterProperties(value);

See Also

SOAFilterObject Class
InSite.Model Namespace


ObjectName Property

[image]

.NET Framework Class Library
SOAFilterObject..::.ObjectName Property
SOAFilterObject Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property ObjectName As String
C#
[DataMemberAttribute]
public string ObjectName { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_objectName();
function set_objectName(value);

See Also

SOAFilterObject Class
InSite.Model Namespace


SOAFilterObjectId Property

[image]

.NET Framework Class Library
SOAFilterObject..::.SOAFilterObjectId Property
SOAFilterObject Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property SOAFilterObjectId As Guid
C#
public Guid SOAFilterObjectId { get; set; }
Visual C++
public:
property Guid SOAFilterObjectId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_soaFilterObjectId();
function set_soaFilterObjectId(value);

See Also

SOAFilterObject Class
InSite.Model Namespace


SortExpression Property

[image]

.NET Framework Class Library
SOAFilterObject..::.SortExpression Property
SOAFilterObject Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property SortExpression As String
C#
[DataMemberAttribute]
public string SortExpression { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ SortExpression {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_sortExpression();
function set_sortExpression(value);

See Also

SOAFilterObject Class
InSite.Model Namespace


SOAFilterOperator Class

[image]

.NET Framework Class Library
SOAFilterOperator Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class SOAFilterOperator
C#
public class SOAFilterOperator
Visual C++
public ref class SOAFilterOperator
JavaScript
InSite.Model.SOAFilterOperator = function();

Type.createClass(
    'InSite.Model.SOAFilterOperator');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.SOAFilterOperator

See Also

SOAFilterOperator Members
InSite.Model Namespace


SOAFilterOperator Members

[image] [image]

.NET Framework Class Library
SOAFilterOperator Members
SOAFilterOperator Class Constructors Methods Fields See Also Send Feedback

The SOAFilterOperator type exposes the following members.

Constructors

Name | Description
SOAFilterOperator |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AND |
BETWEEN |
EQUALTO |
GREATERTHAN |
GREATERTHANEQ |
LESSTHAN |
LESSTHANEQ |
LIKE |
NOTEQUALTO |
OR |

See Also

SOAFilterOperator Class
InSite.Model Namespace


SOAFilterOperator Constructor

[image]

.NET Framework Class Library
SOAFilterOperator Constructor
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SOAFilterOperator()
Visual C++
public:
SOAFilterOperator()
JavaScript
InSite.Model.SOAFilterOperator = function();

See Also

SOAFilterOperator Class
InSite.Model Namespace


SOAFilterOperator Fields

[image] [image]

.NET Framework Class Library
SOAFilterOperator Fields
SOAFilterOperator Class See Also Send Feedback

The SOAFilterOperator type exposes the following members.

Fields

Name | Description
AND |
BETWEEN |
EQUALTO |
GREATERTHAN |
GREATERTHANEQ |
LESSTHAN |
LESSTHANEQ |
LIKE |
NOTEQUALTO |
OR |

See Also

SOAFilterOperator Class
InSite.Model Namespace


AND Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.AND Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const AND As String
C#
public const string AND
Visual C++
public:
literal String^ AND
JavaScript
InSite.Model.SOAFilterOperator.AND

See Also

SOAFilterOperator Class
InSite.Model Namespace


BETWEEN Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.BETWEEN Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const BETWEEN As String
C#
public const string BETWEEN
Visual C++
public:
literal String^ BETWEEN
JavaScript
InSite.Model.SOAFilterOperator.BETWEEN

See Also

SOAFilterOperator Class
InSite.Model Namespace


EQUALTO Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.EQUALTO Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const EQUALTO As String
C#
public const string EQUALTO
Visual C++
public:
literal String^ EQUALTO
JavaScript
InSite.Model.SOAFilterOperator.EQUALTO

See Also

SOAFilterOperator Class
InSite.Model Namespace


GREATERTHAN Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.GREATERTHAN Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const GREATERTHAN As String
C#
public const string GREATERTHAN
Visual C++
public:
literal String^ GREATERTHAN
JavaScript
InSite.Model.SOAFilterOperator.GREATERTHAN

See Also

SOAFilterOperator Class
InSite.Model Namespace


GREATERTHANEQ Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.GREATERTHANEQ Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const GREATERTHANEQ As String
C#
public const string GREATERTHANEQ
Visual C++
public:
literal String^ GREATERTHANEQ
JavaScript
InSite.Model.SOAFilterOperator.GREATERTHANEQ

See Also

SOAFilterOperator Class
InSite.Model Namespace


LESSTHAN Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.LESSTHAN Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const LESSTHAN As String
C#
public const string LESSTHAN
Visual C++
public:
literal String^ LESSTHAN
JavaScript
InSite.Model.SOAFilterOperator.LESSTHAN

See Also

SOAFilterOperator Class
InSite.Model Namespace


LESSTHANEQ Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.LESSTHANEQ Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const LESSTHANEQ As String
C#
public const string LESSTHANEQ
Visual C++
public:
literal String^ LESSTHANEQ
JavaScript
InSite.Model.SOAFilterOperator.LESSTHANEQ

See Also

SOAFilterOperator Class
InSite.Model Namespace


LIKE Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.LIKE Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const LIKE As String
C#
public const string LIKE
Visual C++
public:
literal String^ LIKE
JavaScript
InSite.Model.SOAFilterOperator.LIKE

See Also

SOAFilterOperator Class
InSite.Model Namespace


NOTEQUALTO Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.NOTEQUALTO Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const NOTEQUALTO As String
C#
public const string NOTEQUALTO
Visual C++
public:
literal String^ NOTEQUALTO
JavaScript
InSite.Model.SOAFilterOperator.NOTEQUALTO

See Also

SOAFilterOperator Class
InSite.Model Namespace


OR Field

[image]

.NET Framework Class Library
SOAFilterOperator..::.OR Field
SOAFilterOperator Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Const OR As String
C#
public const string OR
Visual C++
public:
literal String^ OR
JavaScript
InSite.Model.SOAFilterOperator.OR

See Also

SOAFilterOperator Class
InSite.Model Namespace


SOAFilterOperator Methods

[image] [image]

.NET Framework Class Library
SOAFilterOperator Methods
SOAFilterOperator Class See Also Send Feedback

The SOAFilterOperator type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SOAFilterOperator Class
InSite.Model Namespace


SOAFilterProperty Class

[image]

.NET Framework Class Library
SOAFilterProperty Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataContractAttribute> _
Public Class SOAFilterProperty _
    Inherits ModelBase(Of SOAFilterProperty)
C#
[DataContractAttribute]
public class SOAFilterProperty : ModelBase<SOAFilterProperty>
Visual C++
[DataContractAttribute]
public ref class SOAFilterProperty : public ModelBase<SOAFilterProperty^>
JavaScript
InSite.Model.SOAFilterProperty = function();

Type.createClass(
    'InSite.Model.SOAFilterProperty',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(SOAFilterProperty>)>)
InSite.Model..::.SOAFilterProperty

See Also

SOAFilterProperty Members
InSite.Model Namespace


SOAFilterProperty Members

[image] [image]

.NET Framework Class Library
SOAFilterProperty Members
SOAFilterProperty Class Constructors Methods Fields Properties See Also Send Feedback

The SOAFilterProperty type exposes the following members.

Constructors

Name | Description
SOAFilterProperty |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
AndOr |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DataType |
Grouping |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Operator |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAFilterPropertyId |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value1 |
Value2 |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAFilterProperty Class
InSite.Model Namespace


SOAFilterProperty Constructor

[image]

.NET Framework Class Library
SOAFilterProperty Constructor
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SOAFilterProperty()
Visual C++
public:
SOAFilterProperty()
JavaScript
InSite.Model.SOAFilterProperty = function();

See Also

SOAFilterProperty Class
InSite.Model Namespace


SOAFilterProperty Fields

[image] [image]

.NET Framework Class Library
SOAFilterProperty Fields
SOAFilterProperty Class See Also Send Feedback

The SOAFilterProperty type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAFilterProperty Class
InSite.Model Namespace


SOAFilterProperty Methods

[image] [image]

.NET Framework Class Library
SOAFilterProperty Methods
SOAFilterProperty Class See Also Send Feedback

The SOAFilterProperty type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAFilterProperty Class
InSite.Model Namespace


SOAFilterProperty Properties

[image] [image]

.NET Framework Class Library
SOAFilterProperty Properties
SOAFilterProperty Class See Also Send Feedback

The SOAFilterProperty type exposes the following members.

Properties

Name | Description
AndOr |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DataType |
Grouping |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Operator |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAFilterPropertyId |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value1 |
Value2 |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAFilterProperty Class
InSite.Model Namespace


AndOr Property

[image]

.NET Framework Class Library
SOAFilterProperty..::.AndOr Property
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property AndOr As String
C#
[DataMemberAttribute]
public string AndOr { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ AndOr {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_andOr();
function set_andOr(value);

See Also

SOAFilterProperty Class
InSite.Model Namespace


DataType Property

[image]

.NET Framework Class Library
SOAFilterProperty..::.DataType Property
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property DataType As String
C#
[DataMemberAttribute]
public string DataType { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ DataType {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_dataType();
function set_dataType(value);

See Also

SOAFilterProperty Class
InSite.Model Namespace


Grouping Property

[image]

.NET Framework Class Library
SOAFilterProperty..::.Grouping Property
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Grouping As Integer
C#
[DataMemberAttribute]
public int Grouping { get; set; }
Visual C++
[DataMemberAttribute]
public:
property int Grouping {
    int get ();
    void set (int value);
}
JavaScript
function get_grouping();
function set_grouping(value);

See Also

SOAFilterProperty Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
SOAFilterProperty..::.Name Property
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Name As String
C#
[DataMemberAttribute]
public string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

SOAFilterProperty Class
InSite.Model Namespace


Operator Property

[image]

.NET Framework Class Library
SOAFilterProperty..::.Operator Property
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Operator As String
C#
[DataMemberAttribute]
public string Operator { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ Operator {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_operator();
function set_operator(value);

See Also

SOAFilterProperty Class
InSite.Model Namespace


SOAFilterPropertyId Property

[image]

.NET Framework Class Library
SOAFilterProperty..::.SOAFilterPropertyId Property
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property SOAFilterPropertyId As Guid
C#
public Guid SOAFilterPropertyId { get; set; }
Visual C++
public:
property Guid SOAFilterPropertyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_soaFilterPropertyId();
function set_soaFilterPropertyId(value);

See Also

SOAFilterProperty Class
InSite.Model Namespace


Value1 Property

[image]

.NET Framework Class Library
SOAFilterProperty..::.Value1 Property
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Value1 As String
C#
[DataMemberAttribute]
public string Value1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ Value1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value1();
function set_value1(value);

See Also

SOAFilterProperty Class
InSite.Model Namespace


Value2 Property

[image]

.NET Framework Class Library
SOAFilterProperty..::.Value2 Property
SOAFilterProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Value2 As String
C#
[DataMemberAttribute]
public string Value2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ Value2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value2();
function set_value2(value);

See Also

SOAFilterProperty Class
InSite.Model Namespace


SOAResult Class

[image]

.NET Framework Class Library
SOAResult Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute> _
Public Class SOAResult _
    Inherits ModelBase(Of SOAResult)
C#
[SerializableAttribute]
[DataContractAttribute]
public class SOAResult : ModelBase<SOAResult>
Visual C++
[SerializableAttribute]
[DataContractAttribute]
public ref class SOAResult : public ModelBase<SOAResult^>
JavaScript
InSite.Model.SOAResult = function();

Type.createClass(
    'InSite.Model.SOAResult',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(SOAResult>)>)
InSite.Model..::.SOAResult

See Also

SOAResult Members
InSite.Model Namespace


SOAResult Members

[image] [image]

.NET Framework Class Library
SOAResult Members
SOAResult Class Constructors Methods Fields Properties See Also Send Feedback

The SOAResult type exposes the following members.

Constructors

Name | Description
SOAResult | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ErrorMessage |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectId |
ObjectName |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SOAResultId |
Status |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAResult Class
InSite.Model Namespace


SOAResult Constructor

[image] [image]

.NET Framework Class Library
SOAResult Constructor
SOAResult Class See Also Send Feedback

Overload List

Name | Description
SOAResult()()() |
SOAResult(String, String, String, String) |

See Also

SOAResult Class
SOAResult Members
InSite.Model Namespace


SOAResult Constructor

[image]

.NET Framework Class Library
SOAResult Constructor
SOAResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SOAResult()
Visual C++
public:
SOAResult()
JavaScript
InSite.Model.SOAResult = function();

See Also

SOAResult Class
SOAResult Overload
InSite.Model Namespace


SOAResult Constructor (String, String, String, String)

[image]

.NET Framework Class Library
SOAResult Constructor (String, String, String, String)
SOAResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    objectName As String, _
    objectId As String, _
    status As String, _
    errorMessage As String _
)
C#
public SOAResult(
    string objectName,
    string objectId,
    string status,
    string errorMessage
)
Visual C++
public:
SOAResult(
    String^ objectName,
    String^ objectId,
    String^ status,
    String^ errorMessage
)
JavaScript
InSite.Model.SOAResult = function(objectName, objectId, status, errorMessage);

Parameters

objectName
Type: System..::.String
objectId
Type: System..::.String
status
Type: System..::.String
errorMessage
Type: System..::.String

See Also

SOAResult Class
SOAResult Overload
InSite.Model Namespace


SOAResult Fields

[image] [image]

.NET Framework Class Library
SOAResult Fields
SOAResult Class See Also Send Feedback

The SOAResult type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAResult Class
InSite.Model Namespace


SOAResult Methods

[image] [image]

.NET Framework Class Library
SOAResult Methods
SOAResult Class See Also Send Feedback

The SOAResult type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAResult Class
InSite.Model Namespace


SOAResult Properties

[image] [image]

.NET Framework Class Library
SOAResult Properties
SOAResult Class See Also Send Feedback

The SOAResult type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
ErrorMessage |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectId |
ObjectName |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SOAResultId |
Status |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SOAResult Class
InSite.Model Namespace


ErrorMessage Property

[image]

.NET Framework Class Library
SOAResult..::.ErrorMessage Property
SOAResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ErrorMessage As String
C#
[DataMemberAttribute]
public virtual string ErrorMessage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorMessage();
function set_errorMessage(value);

See Also

SOAResult Class
InSite.Model Namespace


ObjectId Property

[image]

.NET Framework Class Library
SOAResult..::.ObjectId Property
SOAResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ObjectId As String
C#
[DataMemberAttribute]
public virtual string ObjectId { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ObjectId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_objectId();
function set_objectId(value);

See Also

SOAResult Class
InSite.Model Namespace


ObjectName Property

[image]

.NET Framework Class Library
SOAResult..::.ObjectName Property
SOAResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ObjectName As String
C#
[DataMemberAttribute]
public virtual string ObjectName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_objectName();
function set_objectName(value);

See Also

SOAResult Class
InSite.Model Namespace


SOAResultId Property

[image]

.NET Framework Class Library
SOAResult..::.SOAResultId Property
SOAResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SOAResultId As Guid
C#
public virtual Guid SOAResultId { get; set; }
Visual C++
public:
virtual property Guid SOAResultId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_soaResultId();
function set_soaResultId(value);

See Also

SOAResult Class
InSite.Model Namespace


Status Property

[image]

.NET Framework Class Library
SOAResult..::.Status Property
SOAResult Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Status As String
C#
[DataMemberAttribute]
public virtual string Status { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Status {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_status();
function set_status(value);

See Also

SOAResult Class
InSite.Model Namespace


SOAResultStatus Class

[image]

.NET Framework Class Library
SOAResultStatus Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SOAResultStatus
C#
public sealed class SOAResultStatus
Visual C++
public ref class SOAResultStatus sealed
JavaScript
InSite.Model.SOAResultStatus = function();

Type.createClass(
    'InSite.Model.SOAResultStatus');

Inheritance Hierarchy

System..::.Object
InSite.Model..::.SOAResultStatus

See Also

SOAResultStatus Members
InSite.Model Namespace


SOAResultStatus Members

[image] [image]

.NET Framework Class Library
SOAResultStatus Members
SOAResultStatus Class Constructors Methods Fields See Also Send Feedback

The SOAResultStatus type exposes the following members.

Constructors

Name | Description
SOAResultStatus |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DeleteError |
DeleteSuccess |
DeleteValidationError |
InsertError |
InsertSuccess |
InsertValidationError |
UpdateError |
UpdateSuccess |
UpdateValidationError |

See Also

SOAResultStatus Class
InSite.Model Namespace


SOAResultStatus Constructor

[image]

.NET Framework Class Library
SOAResultStatus Constructor
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SOAResultStatus()
Visual C++
public:
SOAResultStatus()
JavaScript
InSite.Model.SOAResultStatus = function();

See Also

SOAResultStatus Class
InSite.Model Namespace


SOAResultStatus Fields

[image] [image]

.NET Framework Class Library
SOAResultStatus Fields
SOAResultStatus Class See Also Send Feedback

The SOAResultStatus type exposes the following members.

Fields

Name | Description
DeleteError |
DeleteSuccess |
DeleteValidationError |
InsertError |
InsertSuccess |
InsertValidationError |
UpdateError |
UpdateSuccess |
UpdateValidationError |

See Also

SOAResultStatus Class
InSite.Model Namespace


DeleteError Field

[image]

.NET Framework Class Library
SOAResultStatus..::.DeleteError Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared DeleteError As String
C#
public static string DeleteError
Visual C++
public:
static String^ DeleteError
JavaScript
InSite.Model.SOAResultStatus.deleteError

See Also

SOAResultStatus Class
InSite.Model Namespace


DeleteSuccess Field

[image]

.NET Framework Class Library
SOAResultStatus..::.DeleteSuccess Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared DeleteSuccess As String
C#
public static string DeleteSuccess
Visual C++
public:
static String^ DeleteSuccess
JavaScript
InSite.Model.SOAResultStatus.deleteSuccess

See Also

SOAResultStatus Class
InSite.Model Namespace


DeleteValidationError Field

[image]

.NET Framework Class Library
SOAResultStatus..::.DeleteValidationError Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared DeleteValidationError As String
C#
public static string DeleteValidationError
Visual C++
public:
static String^ DeleteValidationError
JavaScript
InSite.Model.SOAResultStatus.deleteValidationError

See Also

SOAResultStatus Class
InSite.Model Namespace


InsertError Field

[image]

.NET Framework Class Library
SOAResultStatus..::.InsertError Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared InsertError As String
C#
public static string InsertError
Visual C++
public:
static String^ InsertError
JavaScript
InSite.Model.SOAResultStatus.insertError

See Also

SOAResultStatus Class
InSite.Model Namespace


InsertSuccess Field

[image]

.NET Framework Class Library
SOAResultStatus..::.InsertSuccess Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared InsertSuccess As String
C#
public static string InsertSuccess
Visual C++
public:
static String^ InsertSuccess
JavaScript
InSite.Model.SOAResultStatus.insertSuccess

See Also

SOAResultStatus Class
InSite.Model Namespace


InsertValidationError Field

[image]

.NET Framework Class Library
SOAResultStatus..::.InsertValidationError Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared InsertValidationError As String
C#
public static string InsertValidationError
Visual C++
public:
static String^ InsertValidationError
JavaScript
InSite.Model.SOAResultStatus.insertValidationError

See Also

SOAResultStatus Class
InSite.Model Namespace


UpdateError Field

[image]

.NET Framework Class Library
SOAResultStatus..::.UpdateError Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared UpdateError As String
C#
public static string UpdateError
Visual C++
public:
static String^ UpdateError
JavaScript
InSite.Model.SOAResultStatus.updateError

See Also

SOAResultStatus Class
InSite.Model Namespace


UpdateSuccess Field

[image]

.NET Framework Class Library
SOAResultStatus..::.UpdateSuccess Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared UpdateSuccess As String
C#
public static string UpdateSuccess
Visual C++
public:
static String^ UpdateSuccess
JavaScript
InSite.Model.SOAResultStatus.updateSuccess

See Also

SOAResultStatus Class
InSite.Model Namespace


UpdateValidationError Field

[image]

.NET Framework Class Library
SOAResultStatus..::.UpdateValidationError Field
SOAResultStatus Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared UpdateValidationError As String
C#
public static string UpdateValidationError
Visual C++
public:
static String^ UpdateValidationError
JavaScript
InSite.Model.SOAResultStatus.updateValidationError

See Also

SOAResultStatus Class
InSite.Model Namespace


SOAResultStatus Methods

[image] [image]

.NET Framework Class Library
SOAResultStatus Methods
SOAResultStatus Class See Also Send Feedback

The SOAResultStatus type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SOAResultStatus Class
InSite.Model Namespace


SortField Class

[image]

.NET Framework Class Library
SortField Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(AttributeTargets.Property)> _
Public Class SortField _
    Inherits Attribute
C#
[AttributeUsageAttribute(AttributeTargets.Property)]
public class SortField : Attribute
Visual C++
[AttributeUsageAttribute(AttributeTargets::Property)]
public ref class SortField : public Attribute
JavaScript
InSite.Model.SortField = function();

Type.createClass(
    'InSite.Model.SortField',
    Attribute);

Inheritance Hierarchy

System..::.Object
System..::.Attribute
InSite.Model..::.SortField

See Also

SortField Members
InSite.Model Namespace


SortField Members

[image] [image]

.NET Framework Class Library
SortField Members
SortField Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SortField type exposes the following members.

Constructors

Name | Description
SortField |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SortField Class
InSite.Model Namespace


SortField Constructor

[image]

.NET Framework Class Library
SortField Constructor
SortField Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SortField()
Visual C++
public:
SortField()
JavaScript
InSite.Model.SortField = function();

See Also

SortField Class
InSite.Model Namespace


SortField Methods

[image] [image]

.NET Framework Class Library
SortField Methods
SortField Class See Also Send Feedback

The SortField type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

SortField Class
InSite.Model Namespace


SortField Properties

[image] [image]

.NET Framework Class Library
SortField Properties
SortField Class See Also Send Feedback

The SortField type exposes the following members.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

SortField Class
InSite.Model Namespace


Specification Class

[image]

.NET Framework Class Library
Specification Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Specification _
    Inherits ModelBase(Of Specification)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Specification : ModelBase<Specification>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Specification : public ModelBase<Specification^>
JavaScript
InSite.Model.Specification = function();

Type.createClass(
    'InSite.Model.Specification',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Specification>)>)
InSite.Model..::.Specification

See Also

Specification Members
InSite.Model Namespace


Specification Members

[image] [image]

.NET Framework Class Library
Specification Members
Specification Class Constructors Methods Fields Properties See Also Send Feedback

The Specification type exposes the following members.

Constructors

Name | Description
Specification | Overloaded.

Methods

Name | Description
AddCategory |
AddProduct |
AddSpecification |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategory |
RemoveProduct |
RemoveSpecification |
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentSpecification |
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
SpecificationId |
Specifications |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Specification Class
InSite.Model Namespace


Specification Constructor

[image] [image]

.NET Framework Class Library
Specification Constructor
Specification Class See Also Send Feedback

Overload List

Name | Description
Specification()()() |
Specification(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Specification Class
Specification Members
InSite.Model Namespace


Specification Constructor

[image]

.NET Framework Class Library
Specification Constructor
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Specification()
Visual C++
public:
Specification()
JavaScript
InSite.Model.Specification = function();

See Also

Specification Class
Specification Overload
InSite.Model Namespace


Specification Constructor (SearchMode)

[image]

.NET Framework Class Library
Specification Constructor (SearchMode)
Specification Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Specification(
    SearchMode searchMode
)
Visual C++
public:
Specification(
    SearchMode searchMode
)
JavaScript
InSite.Model.Specification = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Specification Class
Specification Overload
InSite.Model Namespace


Specification Fields

[image] [image]

.NET Framework Class Library
Specification Fields
Specification Class See Also Send Feedback

The Specification type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Specification Class
InSite.Model Namespace


Specification Methods

[image] [image]

.NET Framework Class Library
Specification Methods
Specification Class See Also Send Feedback

The Specification type exposes the following members.

Methods

Name | Description
AddCategory |
AddProduct |
AddSpecification |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Copy |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategory |
RemoveProduct |
RemoveSpecification |
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Specification Class
InSite.Model Namespace


AddCategory Method

[image]

.NET Framework Class Library
Specification..::.AddCategory Method
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategory ( _
    value As Category _
)
C#
public virtual void AddCategory(
    Category value
)
Visual C++
public:
virtual void AddCategory(
    Category^ value
)
JavaScript
function addCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

Specification Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
Specification..::.AddProduct Method
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Specification Class
InSite.Model Namespace


AddSpecification Method

[image]

.NET Framework Class Library
Specification..::.AddSpecification Method
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddSpecification ( _
    value As Specification _
)
C#
public virtual void AddSpecification(
    Specification value
)
Visual C++
public:
virtual void AddSpecification(
    Specification^ value
)
JavaScript
function addSpecification(value);

Parameters

value
Type: InSite.Model..::.Specification

See Also

Specification Class
InSite.Model Namespace


Copy Method

[image]

.NET Framework Class Library
Specification..::.Copy Method
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function Copy As Specification
C#
public virtual Specification Copy()
Visual C++
public:
virtual Specification^ Copy()
JavaScript
function copy();

See Also

Specification Class
InSite.Model Namespace


RemoveCategory Method

[image]

.NET Framework Class Library
Specification..::.RemoveCategory Method
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategory ( _
    value As Category _
)
C#
public virtual void RemoveCategory(
    Category value
)
Visual C++
public:
virtual void RemoveCategory(
    Category^ value
)
JavaScript
function removeCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

Specification Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
Specification..::.RemoveProduct Method
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Specification Class
InSite.Model Namespace


RemoveSpecification Method

[image]

.NET Framework Class Library
Specification..::.RemoveSpecification Method
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSpecification ( _
    value As Specification _
)
C#
public virtual void RemoveSpecification(
    Specification value
)
Visual C++
public:
virtual void RemoveSpecification(
    Specification^ value
)
JavaScript
function removeSpecification(value);

Parameters

value
Type: InSite.Model..::.Specification

See Also

Specification Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
Specification..::.ToString Method
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

Specification Class
InSite.Model Namespace


Specification Properties

[image] [image]

.NET Framework Class Library
Specification Properties
Specification Class See Also Send Feedback

The Specification type exposes the following members.

Properties

Name | Description
Active |
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentSpecification |
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
SpecificationId |
Specifications |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Specification Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
Specification..::.Active Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As Boolean
C#
[DataMemberAttribute]
public virtual bool Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool Active {
    bool get ();
    void set (bool value);
}
JavaScript
function get_active();
function set_active(value);

See Also

Specification Class
InSite.Model Namespace


Categories Property

[image]

.NET Framework Class Library
Specification..::.Categories Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Categories As ChildList(Of Category)
C#
public virtual ChildList<Category> Categories { get; private set; }
Visual C++
public:
virtual property ChildList<Category^>^ Categories {
    ChildList<Category^>^ get ();
    void set (ChildList<Category^>^ value);
}
JavaScript
function get_categories();
function set_categories(value);

See Also

Specification Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
Specification..::.ContentManager Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

Specification Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
Specification..::.Description Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

Specification Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
Specification..::.HtmlContent Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HtmlContent As String
C#
[DataMemberAttribute]
public virtual string HtmlContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

Specification Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Specification..::.Name Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Specification Class
InSite.Model Namespace


ParentSpecification Property

[image]

.NET Framework Class Library
Specification..::.ParentSpecification Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ParentSpecification As Specification
C#
public virtual Specification ParentSpecification { get; set; }
Visual C++
public:
virtual property Specification^ ParentSpecification {
    Specification^ get ();
    void set (Specification^ value);
}
JavaScript
function get_parentSpecification();
function set_parentSpecification(value);

See Also

Specification Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
Specification..::.Products Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Products As ChildList(Of Product)
C#
public virtual ChildList<Product> Products { get; private set; }
Visual C++
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

Specification Class
InSite.Model Namespace


SortOrder Property

[image]

.NET Framework Class Library
Specification..::.SortOrder Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SortOrder As Decimal
C#
[DataMemberAttribute]
public virtual decimal SortOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal SortOrder {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_sortOrder();
function set_sortOrder(value);

See Also

Specification Class
InSite.Model Namespace


SpecificationId Property

[image]

.NET Framework Class Library
Specification..::.SpecificationId Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SpecificationId As Guid
C#
public virtual Guid SpecificationId { get; set; }
Visual C++
public:
virtual property Guid SpecificationId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_specificationId();
function set_specificationId(value);

See Also

Specification Class
InSite.Model Namespace


Specifications Property

[image]

.NET Framework Class Library
Specification..::.Specifications Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Specifications As ChildList(Of Specification)
C#
public virtual ChildList<Specification> Specifications { get; private set; }
Visual C++
public:
virtual property ChildList<Specification^>^ Specifications {
    ChildList<Specification^>^ get ();
    void set (ChildList<Specification^>^ value);
}
JavaScript
function get_specifications();
function set_specifications(value);

See Also

Specification Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
Specification..::.Value Property
Specification Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

Specification Class
InSite.Model Namespace


State Class

[image]

.NET Framework Class Library
State Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class State _
    Inherits ModelBase(Of State)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class State : ModelBase<State>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class State : public ModelBase<State^>
JavaScript
InSite.Model.State = function();

Type.createClass(
    'InSite.Model.State',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(State>)>)
InSite.Model..::.State

See Also

State Members
InSite.Model Namespace


State Members

[image] [image]

.NET Framework Class Library
State Members
State Class Constructors Methods Fields Properties See Also Send Feedback

The State type exposes the following members.

Constructors

Name | Description
State | Overloaded.

Methods

Name | Description
AddCounty |
AddTaxExemption |
AddWebSite |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByAbbreviation |
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCounty |
RemoveTaxExemption |
RemoveWebSite |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Abbreviation |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Counties |
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Default |
HandlingAmount |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
StateId |
Taxable |
TaxCode |
TaxExemptions |
TaxFreight |
TaxRate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSites |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

State Class
InSite.Model Namespace


State Constructor

[image] [image]

.NET Framework Class Library
State Constructor
State Class See Also Send Feedback

Overload List

Name | Description
State()()() |
State(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

State Class
State Members
InSite.Model Namespace


State Constructor

[image]

.NET Framework Class Library
State Constructor
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public State()
Visual C++
public:
State()
JavaScript
InSite.Model.State = function();

See Also

State Class
State Overload
InSite.Model Namespace


State Constructor (SearchMode)

[image]

.NET Framework Class Library
State Constructor (SearchMode)
State Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public State(
    SearchMode searchMode
)
Visual C++
public:
State(
    SearchMode searchMode
)
JavaScript
InSite.Model.State = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

State Class
State Overload
InSite.Model Namespace


State Fields

[image] [image]

.NET Framework Class Library
State Fields
State Class See Also Send Feedback

The State type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

State Class
InSite.Model Namespace


State Methods

[image] [image]

.NET Framework Class Library
State Methods
State Class See Also Send Feedback

The State type exposes the following members.

Methods

Name | Description
AddCounty |
AddTaxExemption |
AddWebSite |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByAbbreviation |
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCounty |
RemoveTaxExemption |
RemoveWebSite |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

State Class
InSite.Model Namespace


AddCounty Method

[image]

.NET Framework Class Library
State..::.AddCounty Method
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCounty ( _
    value As County _
)
C#
public virtual void AddCounty(
    County value
)
Visual C++
public:
virtual void AddCounty(
    County^ value
)
JavaScript
function addCounty(value);

Parameters

value
Type: InSite.Model..::.County

See Also

State Class
InSite.Model Namespace


AddTaxExemption Method

[image]

.NET Framework Class Library
State..::.AddTaxExemption Method
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddTaxExemption ( _
    value As TaxExemption _
)
C#
public virtual void AddTaxExemption(
    TaxExemption value
)
Visual C++
public:
virtual void AddTaxExemption(
    TaxExemption^ value
)
JavaScript
function addTaxExemption(value);

Parameters

value
Type: InSite.Model..::.TaxExemption

See Also

State Class
InSite.Model Namespace


AddWebSite Method

[image]

.NET Framework Class Library
State..::.AddWebSite Method
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWebSite ( _
    value As WebSite _
)
C#
public virtual void AddWebSite(
    WebSite value
)
Visual C++
public:
virtual void AddWebSite(
    WebSite^ value
)
JavaScript
function addWebSite(value);

Parameters

value
Type: InSite.Model..::.WebSite

See Also

State Class
InSite.Model Namespace


GetByAbbreviation Method

[image]

.NET Framework Class Library
State..::.GetByAbbreviation Method
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByAbbreviation ( _
    abbreviation As String _
) As State
C#
public static State GetByAbbreviation(
    string abbreviation
)
Visual C++
public:
static State^ GetByAbbreviation(
    String^ abbreviation
)
JavaScript
InSite.Model.State.getByAbbreviation = function(abbreviation);

Parameters

abbreviation
Type: System..::.String

See Also

State Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
State..::.GetByName Method
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As State
C#
public static State GetByName(
    string name
)
Visual C++
public:
static State^ GetByName(
    String^ name
)
JavaScript
InSite.Model.State.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

State Class
InSite.Model Namespace


RemoveCounty Method

[image]

.NET Framework Class Library
State..::.RemoveCounty Method
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCounty ( _
    value As County _
)
C#
public virtual void RemoveCounty(
    County value
)
Visual C++
public:
virtual void RemoveCounty(
    County^ value
)
JavaScript
function removeCounty(value);

Parameters

value
Type: InSite.Model..::.County

See Also

State Class
InSite.Model Namespace


RemoveTaxExemption Method

[image]

.NET Framework Class Library
State..::.RemoveTaxExemption Method
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveTaxExemption ( _
    value As TaxExemption _
)
C#
public virtual void RemoveTaxExemption(
    TaxExemption value
)
Visual C++
public:
virtual void RemoveTaxExemption(
    TaxExemption^ value
)
JavaScript
function removeTaxExemption(value);

Parameters

value
Type: InSite.Model..::.TaxExemption

See Also

State Class
InSite.Model Namespace


RemoveWebSite Method

[image]

.NET Framework Class Library
State..::.RemoveWebSite Method
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWebSite ( _
    value As WebSite _
)
C#
public virtual void RemoveWebSite(
    WebSite value
)
Visual C++
public:
virtual void RemoveWebSite(
    WebSite^ value
)
JavaScript
function removeWebSite(value);

Parameters

value
Type: InSite.Model..::.WebSite

See Also

State Class
InSite.Model Namespace


State Properties

[image] [image]

.NET Framework Class Library
State Properties
State Class See Also Send Feedback

The State type exposes the following members.

Properties

Name | Description
Abbreviation |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Counties |
Country |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Default |
HandlingAmount |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
StateId |
Taxable |
TaxCode |
TaxExemptions |
TaxFreight |
TaxRate |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSites |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

State Class
InSite.Model Namespace


Abbreviation Property

[image]

.NET Framework Class Library
State..::.Abbreviation Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Abbreviation As String
C#
[DataMemberAttribute]
public virtual string Abbreviation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Abbreviation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_abbreviation();
function set_abbreviation(value);

See Also

State Class
InSite.Model Namespace


Counties Property

[image]

.NET Framework Class Library
State..::.Counties Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Counties As ChildList(Of County)
C#
public virtual ChildList<County> Counties { get; private set; }
Visual C++
public:
virtual property ChildList<County^>^ Counties {
    ChildList<County^>^ get ();
    void set (ChildList<County^>^ value);
}
JavaScript
function get_counties();
function set_counties(value);

See Also

State Class
InSite.Model Namespace


Country Property

[image]

.NET Framework Class Library
State..::.Country Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Country As Country
C#
public virtual Country Country { get; set; }
Visual C++
public:
virtual property Country^ Country {
    Country^ get ();
    void set (Country^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

State Class
InSite.Model Namespace


Default Property

[image]

.NET Framework Class Library
State..::.Default Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Default As State
C#
public static State Default { get; }
Visual C++
public:
static property State^ Default {
    State^ get ();
}
JavaScript
InSite.Model.State.get_default = function();

See Also

State Class
InSite.Model Namespace


HandlingAmount Property

[image]

.NET Framework Class Library
State..::.HandlingAmount Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HandlingAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal HandlingAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal HandlingAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_handlingAmount();
function set_handlingAmount(value);

See Also

State Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
State..::.IsActive Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

State Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
State..::.Name Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

State Class
InSite.Model Namespace


StateId Property

[image]

.NET Framework Class Library
State..::.StateId Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StateId As Guid
C#
public virtual Guid StateId { get; set; }
Visual C++
public:
virtual property Guid StateId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_stateId();
function set_stateId(value);

See Also

State Class
InSite.Model Namespace


Taxable Property

[image]

.NET Framework Class Library
State..::.Taxable Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Taxable As Boolean
C#
[DataMemberAttribute]
public virtual bool Taxable { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool Taxable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxable();
function set_taxable(value);

See Also

State Class
InSite.Model Namespace


TaxCode Property

[image]

.NET Framework Class Library
State..::.TaxCode Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCode As String
C#
[DataMemberAttribute]
public virtual string TaxCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCode();
function set_taxCode(value);

See Also

State Class
InSite.Model Namespace


TaxExemptions Property

[image]

.NET Framework Class Library
State..::.TaxExemptions Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxExemptions As ChildList(Of TaxExemption)
C#
[DataMemberAttribute]
public virtual ChildList<TaxExemption> TaxExemptions { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<TaxExemption^>^ TaxExemptions {
    ChildList<TaxExemption^>^ get ();
    void set (ChildList<TaxExemption^>^ value);
}
JavaScript
function get_taxExemptions();
function set_taxExemptions(value);

See Also

State Class
InSite.Model Namespace


TaxFreight Property

[image]

.NET Framework Class Library
State..::.TaxFreight Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxFreight As Boolean
C#
[DataMemberAttribute]
public virtual bool TaxFreight { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool TaxFreight {
    bool get ();
    void set (bool value);
}
JavaScript
function get_taxFreight();
function set_taxFreight(value);

See Also

State Class
InSite.Model Namespace


TaxRate Property

[image]

.NET Framework Class Library
State..::.TaxRate Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxRate As Decimal
C#
[DataMemberAttribute]
public virtual decimal TaxRate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal TaxRate {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_taxRate();
function set_taxRate(value);

See Also

State Class
InSite.Model Namespace


WebSites Property

[image]

.NET Framework Class Library
State..::.WebSites Property
State Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSites As ChildList(Of WebSite)
C#
public virtual ChildList<WebSite> WebSites { get; private set; }
Visual C++
public:
virtual property ChildList<WebSite^>^ WebSites {
    ChildList<WebSite^>^ get ();
    void set (ChildList<WebSite^>^ value);
}
JavaScript
function get_webSites();
function set_webSites(value);

See Also

State Class
InSite.Model Namespace


StyleClass Class

[image]

.NET Framework Class Library
StyleClass Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class StyleClass _
    Inherits ModelBase(Of StyleClass)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class StyleClass : ModelBase<StyleClass>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class StyleClass : public ModelBase<StyleClass^>
JavaScript
InSite.Model.StyleClass = function();

Type.createClass(
    'InSite.Model.StyleClass',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(StyleClass>)>)
InSite.Model..::.StyleClass

See Also

StyleClass Members
InSite.Model Namespace


StyleClass Members

[image] [image]

.NET Framework Class Library
StyleClass Members
StyleClass Class Constructors Methods Fields Properties See Also Send Feedback

The StyleClass type exposes the following members.

Constructors

Name | Description
StyleClass | Overloaded.

Methods

Name | Description
AddProduct |
AddStyleTrait |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveProduct |
RemoveStyleTrait |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
StyleClassId |
StyleTraits |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleClass Class
InSite.Model Namespace


StyleClass Constructor

[image] [image]

.NET Framework Class Library
StyleClass Constructor
StyleClass Class See Also Send Feedback

Overload List

Name | Description
StyleClass()()() |
StyleClass(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

StyleClass Class
StyleClass Members
InSite.Model Namespace


StyleClass Constructor

[image]

.NET Framework Class Library
StyleClass Constructor
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StyleClass()
Visual C++
public:
StyleClass()
JavaScript
InSite.Model.StyleClass = function();

See Also

StyleClass Class
StyleClass Overload
InSite.Model Namespace


StyleClass Constructor (SearchMode)

[image]

.NET Framework Class Library
StyleClass Constructor (SearchMode)
StyleClass Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public StyleClass(
    SearchMode searchMode
)
Visual C++
public:
StyleClass(
    SearchMode searchMode
)
JavaScript
InSite.Model.StyleClass = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

StyleClass Class
StyleClass Overload
InSite.Model Namespace


StyleClass Fields

[image] [image]

.NET Framework Class Library
StyleClass Fields
StyleClass Class See Also Send Feedback

The StyleClass type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleClass Class
InSite.Model Namespace


StyleClass Methods

[image] [image]

.NET Framework Class Library
StyleClass Methods
StyleClass Class See Also Send Feedback

The StyleClass type exposes the following members.

Methods

Name | Description
AddProduct |
AddStyleTrait |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveProduct |
RemoveStyleTrait |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleClass Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
StyleClass..::.AddProduct Method
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

StyleClass Class
InSite.Model Namespace


AddStyleTrait Method

[image]

.NET Framework Class Library
StyleClass..::.AddStyleTrait Method
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddStyleTrait ( _
    value As StyleTrait _
)
C#
public virtual void AddStyleTrait(
    StyleTrait value
)
Visual C++
public:
virtual void AddStyleTrait(
    StyleTrait^ value
)
JavaScript
function addStyleTrait(value);

Parameters

value
Type: InSite.Model..::.StyleTrait

See Also

StyleClass Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
StyleClass..::.GetByName Method
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As StyleClass
C#
public static StyleClass GetByName(
    string name
)
Visual C++
public:
static StyleClass^ GetByName(
    String^ name
)
JavaScript
InSite.Model.StyleClass.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

StyleClass Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
StyleClass..::.RemoveProduct Method
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

StyleClass Class
InSite.Model Namespace


RemoveStyleTrait Method

[image]

.NET Framework Class Library
StyleClass..::.RemoveStyleTrait Method
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveStyleTrait ( _
    value As StyleTrait _
)
C#
public virtual void RemoveStyleTrait(
    StyleTrait value
)
Visual C++
public:
virtual void RemoveStyleTrait(
    StyleTrait^ value
)
JavaScript
function removeStyleTrait(value);

Parameters

value
Type: InSite.Model..::.StyleTrait

See Also

StyleClass Class
InSite.Model Namespace


StyleClass Properties

[image] [image]

.NET Framework Class Library
StyleClass Properties
StyleClass Class See Also Send Feedback

The StyleClass type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
StyleClassId |
StyleTraits |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleClass Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
StyleClass..::.Description Property
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

StyleClass Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
StyleClass..::.IsActive Property
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

StyleClass Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
StyleClass..::.Name Property
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

StyleClass Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
StyleClass..::.Products Property
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Products As ChildList(Of Product)
C#
[DataMemberAttribute]
public virtual ChildList<Product> Products { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

StyleClass Class
InSite.Model Namespace


StyleClassId Property

[image]

.NET Framework Class Library
StyleClass..::.StyleClassId Property
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleClassId As Guid
C#
public virtual Guid StyleClassId { get; set; }
Visual C++
public:
virtual property Guid StyleClassId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_styleClassId();
function set_styleClassId(value);

See Also

StyleClass Class
InSite.Model Namespace


StyleTraits Property

[image]

.NET Framework Class Library
StyleClass..::.StyleTraits Property
StyleClass Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property StyleTraits As ChildList(Of StyleTrait)
C#
[DataMemberAttribute]
public virtual ChildList<StyleTrait> StyleTraits { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<StyleTrait^>^ StyleTraits {
    ChildList<StyleTrait^>^ get ();
    void set (ChildList<StyleTrait^>^ value);
}
JavaScript
function get_styleTraits();
function set_styleTraits(value);

See Also

StyleClass Class
InSite.Model Namespace


StyleTrait Class

[image]

.NET Framework Class Library
StyleTrait Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class StyleTrait _
    Inherits ModelBase(Of StyleTrait)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class StyleTrait : ModelBase<StyleTrait>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class StyleTrait : public ModelBase<StyleTrait^>
JavaScript
InSite.Model.StyleTrait = function();

Type.createClass(
    'InSite.Model.StyleTrait',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(StyleTrait>)>)
InSite.Model..::.StyleTrait

See Also

StyleTrait Members
InSite.Model Namespace


StyleTrait Members

[image] [image]

.NET Framework Class Library
StyleTrait Members
StyleTrait Class Constructors Methods Fields Properties See Also Send Feedback

The StyleTrait type exposes the following members.

Constructors

Name | Description
StyleTrait | Overloaded.

Methods

Name | Description
AddStyleTraitValue |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveStyleTraitValue |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
StyleClass |
StyleTraitId |
StyleTraitValues |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleTrait Class
InSite.Model Namespace


StyleTrait Constructor

[image] [image]

.NET Framework Class Library
StyleTrait Constructor
StyleTrait Class See Also Send Feedback

Overload List

Name | Description
StyleTrait()()() |
StyleTrait(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

StyleTrait Class
StyleTrait Members
InSite.Model Namespace


StyleTrait Constructor

[image]

.NET Framework Class Library
StyleTrait Constructor
StyleTrait Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StyleTrait()
Visual C++
public:
StyleTrait()
JavaScript
InSite.Model.StyleTrait = function();

See Also

StyleTrait Class
StyleTrait Overload
InSite.Model Namespace


StyleTrait Constructor (SearchMode)

[image]

.NET Framework Class Library
StyleTrait Constructor (SearchMode)
StyleTrait Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public StyleTrait(
    SearchMode searchMode
)
Visual C++
public:
StyleTrait(
    SearchMode searchMode
)
JavaScript
InSite.Model.StyleTrait = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

StyleTrait Class
StyleTrait Overload
InSite.Model Namespace


StyleTrait Fields

[image] [image]

.NET Framework Class Library
StyleTrait Fields
StyleTrait Class See Also Send Feedback

The StyleTrait type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleTrait Class
InSite.Model Namespace


StyleTrait Methods

[image] [image]

.NET Framework Class Library
StyleTrait Methods
StyleTrait Class See Also Send Feedback

The StyleTrait type exposes the following members.

Methods

Name | Description
AddStyleTraitValue |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveStyleTraitValue |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleTrait Class
InSite.Model Namespace


AddStyleTraitValue Method

[image]

.NET Framework Class Library
StyleTrait..::.AddStyleTraitValue Method
StyleTrait Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddStyleTraitValue ( _
    value As StyleTraitValue _
)
C#
public virtual void AddStyleTraitValue(
    StyleTraitValue value
)
Visual C++
public:
virtual void AddStyleTraitValue(
    StyleTraitValue^ value
)
JavaScript
function addStyleTraitValue(value);

Parameters

value
Type: InSite.Model..::.StyleTraitValue

See Also

StyleTrait Class
InSite.Model Namespace


RemoveStyleTraitValue Method

[image]

.NET Framework Class Library
StyleTrait..::.RemoveStyleTraitValue Method
StyleTrait Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveStyleTraitValue ( _
    value As StyleTraitValue _
)
C#
public virtual void RemoveStyleTraitValue(
    StyleTraitValue value
)
Visual C++
public:
virtual void RemoveStyleTraitValue(
    StyleTraitValue^ value
)
JavaScript
function removeStyleTraitValue(value);

Parameters

value
Type: InSite.Model..::.StyleTraitValue

See Also

StyleTrait Class
InSite.Model Namespace


StyleTrait Properties

[image] [image]

.NET Framework Class Library
StyleTrait Properties
StyleTrait Class See Also Send Feedback

The StyleTrait type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
StyleClass |
StyleTraitId |
StyleTraitValues |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleTrait Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
StyleTrait..::.Name Property
StyleTrait Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

StyleTrait Class
InSite.Model Namespace


SortOrder Property

[image]

.NET Framework Class Library
StyleTrait..::.SortOrder Property
StyleTrait Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property SortOrder As Integer
C#
[DataMemberAttribute]
[SortField]
public virtual int SortOrder { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property int SortOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_sortOrder();
function set_sortOrder(value);

See Also

StyleTrait Class
InSite.Model Namespace


StyleClass Property

[image]

.NET Framework Class Library
StyleTrait..::.StyleClass Property
StyleTrait Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleClass As StyleClass
C#
public virtual StyleClass StyleClass { get; set; }
Visual C++
public:
virtual property StyleClass^ StyleClass {
    StyleClass^ get ();
    void set (StyleClass^ value);
}
JavaScript
function get_styleClass();
function set_styleClass(value);

See Also

StyleTrait Class
InSite.Model Namespace


StyleTraitId Property

[image]

.NET Framework Class Library
StyleTrait..::.StyleTraitId Property
StyleTrait Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleTraitId As Guid
C#
public virtual Guid StyleTraitId { get; set; }
Visual C++
public:
virtual property Guid StyleTraitId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_styleTraitId();
function set_styleTraitId(value);

See Also

StyleTrait Class
InSite.Model Namespace


StyleTraitValues Property

[image]

.NET Framework Class Library
StyleTrait..::.StyleTraitValues Property
StyleTrait Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property StyleTraitValues As ChildList(Of StyleTraitValue)
C#
[DataMemberAttribute]
public virtual ChildList<StyleTraitValue> StyleTraitValues { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<StyleTraitValue^>^ StyleTraitValues {
    ChildList<StyleTraitValue^>^ get ();
    void set (ChildList<StyleTraitValue^>^ value);
}
JavaScript
function get_styleTraitValues();
function set_styleTraitValues(value);

See Also

StyleTrait Class
InSite.Model Namespace


StyleTraitValue Class

[image]

.NET Framework Class Library
StyleTraitValue Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class StyleTraitValue _
    Inherits ModelBase(Of StyleTraitValue)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class StyleTraitValue : ModelBase<StyleTraitValue>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class StyleTraitValue : public ModelBase<StyleTraitValue^>
JavaScript
InSite.Model.StyleTraitValue = function();

Type.createClass(
    'InSite.Model.StyleTraitValue',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(StyleTraitValue>)>)
InSite.Model..::.StyleTraitValue

See Also

StyleTraitValue Members
InSite.Model Namespace


StyleTraitValue Members

[image] [image]

.NET Framework Class Library
StyleTraitValue Members
StyleTraitValue Class Constructors Methods Fields Properties See Also Send Feedback

The StyleTraitValue type exposes the following members.

Constructors

Name | Description
StyleTraitValue | Overloaded.

Methods

Name | Description
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsDefault |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
StyleTrait |
StyleTraitValueId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleTraitValue Class
InSite.Model Namespace


StyleTraitValue Constructor

[image] [image]

.NET Framework Class Library
StyleTraitValue Constructor
StyleTraitValue Class See Also Send Feedback

Overload List

Name | Description
StyleTraitValue()()() |
StyleTraitValue(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

StyleTraitValue Class
StyleTraitValue Members
InSite.Model Namespace


StyleTraitValue Constructor

[image]

.NET Framework Class Library
StyleTraitValue Constructor
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public StyleTraitValue()
Visual C++
public:
StyleTraitValue()
JavaScript
InSite.Model.StyleTraitValue = function();

See Also

StyleTraitValue Class
StyleTraitValue Overload
InSite.Model Namespace


StyleTraitValue Constructor (SearchMode)

[image]

.NET Framework Class Library
StyleTraitValue Constructor (SearchMode)
StyleTraitValue Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public StyleTraitValue(
    SearchMode searchMode
)
Visual C++
public:
StyleTraitValue(
    SearchMode searchMode
)
JavaScript
InSite.Model.StyleTraitValue = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

StyleTraitValue Class
StyleTraitValue Overload
InSite.Model Namespace


StyleTraitValue Fields

[image] [image]

.NET Framework Class Library
StyleTraitValue Fields
StyleTraitValue Class See Also Send Feedback

The StyleTraitValue type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleTraitValue Class
InSite.Model Namespace


StyleTraitValue Methods

[image] [image]

.NET Framework Class Library
StyleTraitValue Methods
StyleTraitValue Class See Also Send Feedback

The StyleTraitValue type exposes the following members.

Methods

Name | Description
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleTraitValue Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
StyleTraitValue..::.AddProduct Method
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

StyleTraitValue Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
StyleTraitValue..::.RemoveProduct Method
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

StyleTraitValue Class
InSite.Model Namespace


StyleTraitValue Properties

[image] [image]

.NET Framework Class Library
StyleTraitValue Properties
StyleTraitValue Class See Also Send Feedback

The StyleTraitValue type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsDefault |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SortOrder |
StyleTrait |
StyleTraitValueId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

StyleTraitValue Class
InSite.Model Namespace


IsDefault Property

[image]

.NET Framework Class Library
StyleTraitValue..::.IsDefault Property
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsDefault As Boolean
C#
[DataMemberAttribute]
public virtual bool IsDefault { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsDefault {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isDefault();
function set_isDefault(value);

See Also

StyleTraitValue Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
StyleTraitValue..::.Products Property
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Products As ChildList(Of Product)
C#
[DataMemberAttribute]
public virtual ChildList<Product> Products { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

StyleTraitValue Class
InSite.Model Namespace


SortOrder Property

[image]

.NET Framework Class Library
StyleTraitValue..::.SortOrder Property
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property SortOrder As Integer
C#
[DataMemberAttribute]
[SortField]
public virtual int SortOrder { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property int SortOrder {
    int get ();
    void set (int value);
}
JavaScript
function get_sortOrder();
function set_sortOrder(value);

See Also

StyleTraitValue Class
InSite.Model Namespace


StyleTrait Property

[image]

.NET Framework Class Library
StyleTraitValue..::.StyleTrait Property
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleTrait As StyleTrait
C#
public virtual StyleTrait StyleTrait { get; set; }
Visual C++
public:
virtual property StyleTrait^ StyleTrait {
    StyleTrait^ get ();
    void set (StyleTrait^ value);
}
JavaScript
function get_styleTrait();
function set_styleTrait(value);

See Also

StyleTraitValue Class
InSite.Model Namespace


StyleTraitValueId Property

[image]

.NET Framework Class Library
StyleTraitValue..::.StyleTraitValueId Property
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property StyleTraitValueId As Guid
C#
public virtual Guid StyleTraitValueId { get; set; }
Visual C++
public:
virtual property Guid StyleTraitValueId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_styleTraitValueId();
function set_styleTraitValueId(value);

See Also

StyleTraitValue Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
StyleTraitValue..::.Value Property
StyleTraitValue Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

StyleTraitValue Class
InSite.Model Namespace


Subscription Class

[image]

.NET Framework Class Library
Subscription Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Subscription _
    Inherits ModelBase(Of Subscription)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Subscription : ModelBase<Subscription>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Subscription : public ModelBase<Subscription^>
JavaScript
InSite.Model.Subscription = function();

Type.createClass(
    'InSite.Model.Subscription',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Subscription>)>)
InSite.Model..::.Subscription

See Also

Subscription Members
InSite.Model Namespace


Subscription Members

[image] [image]

.NET Framework Class Library
Subscription Members
Subscription Class Constructors Methods Fields Properties See Also Send Feedback

The Subscription type exposes the following members.

Constructors

Name | Description
Subscription |

Methods

Name | Description
AddCustomerOrder |
AddSubscriptionLine |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
CreateSubscriptions |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get |
GetCount |
GetCustomerOrder |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetList |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomerOrder |
RemoveSubscriptionLine |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
DailyCyclePeriod |
MonthlyCyclePeriod |

Properties

Name | Description
Active |
April |
August |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerName |
CustomerNumber |
CustomerOrder |
CustomerOrders |
CyclePeriod |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
December |
February |
FixedPrice |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IncludeInInitialOrder |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
January |
July |
June |
LastOrderDate |
March |
May |
NextOrderDate |
November |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
October |
OrderNumber |
PeriodsPerCycle |
Product |
ProductName |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
September |
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipTo |
ShipVia |
ShipViaId |
ShipViaShipCode |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SubscriptionId |
SubscriptionLines |
TotalCycles |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Subscription Class
InSite.Model Namespace


Subscription Constructor

[image]

.NET Framework Class Library
Subscription Constructor
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Subscription()
Visual C++
public:
Subscription()
JavaScript
InSite.Model.Subscription = function();

See Also

Subscription Class
InSite.Model Namespace


Subscription Fields

[image] [image]

.NET Framework Class Library
Subscription Fields
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
DailyCyclePeriod |
MonthlyCyclePeriod |

See Also

Subscription Class
InSite.Model Namespace


DailyCyclePeriod Field

[image]

.NET Framework Class Library
Subscription..::.DailyCyclePeriod Field
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared DailyCyclePeriod As String
C#
public static string DailyCyclePeriod
Visual C++
public:
static String^ DailyCyclePeriod
JavaScript
InSite.Model.Subscription.dailyCyclePeriod

See Also

Subscription Class
InSite.Model Namespace


MonthlyCyclePeriod Field

[image]

.NET Framework Class Library
Subscription..::.MonthlyCyclePeriod Field
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared MonthlyCyclePeriod As String
C#
public static string MonthlyCyclePeriod
Visual C++
public:
static String^ MonthlyCyclePeriod
JavaScript
InSite.Model.Subscription.monthlyCyclePeriod

See Also

Subscription Class
InSite.Model Namespace


Subscription Methods

[image] [image]

.NET Framework Class Library
Subscription Methods
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Methods

Name | Description
AddCustomerOrder |
AddSubscriptionLine |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
CreateSubscriptions |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get |
GetCount |
GetCustomerOrder |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetList |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomerOrder |
RemoveSubscriptionLine |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Subscription Class
InSite.Model Namespace


AddCustomerOrder Method

[image]

.NET Framework Class Library
Subscription..::.AddCustomerOrder Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomerOrder ( _
    value As CustomerOrder _
)
C#
public virtual void AddCustomerOrder(
    CustomerOrder value
)
Visual C++
public:
virtual void AddCustomerOrder(
    CustomerOrder^ value
)
JavaScript
function addCustomerOrder(value);

Parameters

value
Type: InSite.Model..::.CustomerOrder

See Also

Subscription Class
InSite.Model Namespace


AddSubscriptionLine Method

[image]

.NET Framework Class Library
Subscription..::.AddSubscriptionLine Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddSubscriptionLine ( _
    value As SubscriptionLine _
)
C#
public virtual void AddSubscriptionLine(
    SubscriptionLine value
)
Visual C++
public:
virtual void AddSubscriptionLine(
    SubscriptionLine^ value
)
JavaScript
function addSubscriptionLine(value);

Parameters

value
Type: InSite.Model..::.SubscriptionLine

See Also

Subscription Class
InSite.Model Namespace


CreateSubscriptions Method

[image]

.NET Framework Class Library
Subscription..::.CreateSubscriptions Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CreateSubscriptions
C#
public static void CreateSubscriptions()
Visual C++
public:
static void CreateSubscriptions()
JavaScript
InSite.Model.Subscription.createSubscriptions = function();

See Also

Subscription Class
InSite.Model Namespace


Get Method

[image]

.NET Framework Class Library
Subscription..::.Get Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get ( _
    product As Product, _
    customer As Customer, _
    shipTo As Customer _
) As Subscription
C#
public static Subscription Get(
    Product product,
    Customer customer,
    Customer shipTo
)
Visual C++
public:
static Subscription^ Get(
    Product^ product,
    Customer^ customer,
    Customer^ shipTo
)
JavaScript
InSite.Model.Subscription.get = function(product, customer, shipTo);

Parameters

product
Type: InSite.Model..::.Product
customer
Type: InSite.Model..::.Customer
shipTo
Type: InSite.Model..::.Customer

See Also

Subscription Class
InSite.Model Namespace


GetCount Method

[image]

.NET Framework Class Library
Subscription..::.GetCount Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetCount ( _
    customerNumber As String, _
    orderNumber As String _
) As Integer
C#
public static int GetCount(
    string customerNumber,
    string orderNumber
)
Visual C++
public:
static int GetCount(
    String^ customerNumber,
    String^ orderNumber
)
JavaScript
InSite.Model.Subscription.getCount = function(customerNumber, orderNumber);

Parameters

customerNumber
Type: System..::.String
orderNumber
Type: System..::.String

See Also

Subscription Class
InSite.Model Namespace


GetCustomerOrder Method

[image]

.NET Framework Class Library
Subscription..::.GetCustomerOrder Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCustomerOrder As CustomerOrder
C#
public virtual CustomerOrder GetCustomerOrder()
Visual C++
public:
virtual CustomerOrder^ GetCustomerOrder()
JavaScript
function getCustomerOrder();

See Also

Subscription Class
InSite.Model Namespace


GetList Method

[image]

.NET Framework Class Library
Subscription..::.GetList Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetList ( _
    customerNumber As String, _
    orderNumber As String, _
    sort As String, _
    startRow As Integer, _
    pageSize As Integer _
) As IList(Of Subscription)
C#
public static IList<Subscription> GetList(
    string customerNumber,
    string orderNumber,
    string sort,
    int startRow,
    int pageSize
)
Visual C++
public:
static IList<Subscription^>^ GetList(
    String^ customerNumber,
    String^ orderNumber,
    String^ sort,
    int startRow,
    int pageSize
)
JavaScript
InSite.Model.Subscription.getList = function(customerNumber, orderNumber, sort, startRow, pageSize);

Parameters

customerNumber
Type: System..::.String
orderNumber
Type: System..::.String
sort
Type: System..::.String
startRow
Type: System..::.Int32
pageSize
Type: System..::.Int32

See Also

Subscription Class
InSite.Model Namespace


RemoveCustomerOrder Method

[image]

.NET Framework Class Library
Subscription..::.RemoveCustomerOrder Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomerOrder ( _
    value As CustomerOrder _
)
C#
public virtual void RemoveCustomerOrder(
    CustomerOrder value
)
Visual C++
public:
virtual void RemoveCustomerOrder(
    CustomerOrder^ value
)
JavaScript
function removeCustomerOrder(value);

Parameters

value
Type: InSite.Model..::.CustomerOrder

See Also

Subscription Class
InSite.Model Namespace


RemoveSubscriptionLine Method

[image]

.NET Framework Class Library
Subscription..::.RemoveSubscriptionLine Method
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveSubscriptionLine ( _
    value As SubscriptionLine _
)
C#
public virtual void RemoveSubscriptionLine(
    SubscriptionLine value
)
Visual C++
public:
virtual void RemoveSubscriptionLine(
    SubscriptionLine^ value
)
JavaScript
function removeSubscriptionLine(value);

Parameters

value
Type: InSite.Model..::.SubscriptionLine

See Also

Subscription Class
InSite.Model Namespace


Subscription Properties

[image] [image]

.NET Framework Class Library
Subscription Properties
Subscription Class See Also Send Feedback

The Subscription type exposes the following members.

Properties

Name | Description
Active |
April |
August |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
CustomerName |
CustomerNumber |
CustomerOrder |
CustomerOrders |
CyclePeriod |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
December |
February |
FixedPrice |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IncludeInInitialOrder |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
January |
July |
June |
LastOrderDate |
March |
May |
NextOrderDate |
November |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
October |
OrderNumber |
PeriodsPerCycle |
Product |
ProductName |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
September |
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipTo |
ShipVia |
ShipViaId |
ShipViaShipCode |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SubscriptionId |
SubscriptionLines |
TotalCycles |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Subscription Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
Subscription..::.Active Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
[SortField]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

Subscription Class
InSite.Model Namespace


April Property

[image]

.NET Framework Class Library
Subscription..::.April Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property April As Boolean
C#
[DataMemberAttribute]
public virtual bool April { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool April {
    bool get ();
    void set (bool value);
}
JavaScript
function get_april();
function set_april(value);

See Also

Subscription Class
InSite.Model Namespace


August Property

[image]

.NET Framework Class Library
Subscription..::.August Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property August As Boolean
C#
[DataMemberAttribute]
public virtual bool August { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool August {
    bool get ();
    void set (bool value);
}
JavaScript
function get_august();
function set_august(value);

See Also

Subscription Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
Subscription..::.Customer Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customer As Customer
C#
public virtual Customer Customer { get; set; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

Subscription Class
InSite.Model Namespace


CustomerName Property

[image]

.NET Framework Class Library
Subscription..::.CustomerName Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerName As String
C#
[DataMemberAttribute]
public virtual string CustomerName { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerName();
function set_customerName(value);

See Also

Subscription Class
InSite.Model Namespace


CustomerNumber Property

[image]

.NET Framework Class Library
Subscription..::.CustomerNumber Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumber As String
C#
[DataMemberAttribute]
public virtual string CustomerNumber { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumber();
function set_customerNumber(value);

See Also

Subscription Class
InSite.Model Namespace


CustomerOrder Property

[image]

.NET Framework Class Library
Subscription..::.CustomerOrder Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrder As CustomerOrder
C#
public virtual CustomerOrder CustomerOrder { get; set; }
Visual C++
public:
virtual property CustomerOrder^ CustomerOrder {
    CustomerOrder^ get ();
    void set (CustomerOrder^ value);
}
JavaScript
function get_customerOrder();
function set_customerOrder(value);

See Also

Subscription Class
InSite.Model Namespace


CustomerOrders Property

[image]

.NET Framework Class Library
Subscription..::.CustomerOrders Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerOrders As ChildList(Of CustomerOrder)
C#
public virtual ChildList<CustomerOrder> CustomerOrders { get; private set; }
Visual C++
public:
virtual property ChildList<CustomerOrder^>^ CustomerOrders {
    ChildList<CustomerOrder^>^ get ();
    void set (ChildList<CustomerOrder^>^ value);
}
JavaScript
function get_customerOrders();
function set_customerOrders(value);

See Also

Subscription Class
InSite.Model Namespace


CyclePeriod Property

[image]

.NET Framework Class Library
Subscription..::.CyclePeriod Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CyclePeriod As String
C#
[DataMemberAttribute]
public virtual string CyclePeriod { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CyclePeriod {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_cyclePeriod();
function set_cyclePeriod(value);

See Also

Subscription Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
Subscription..::.Deactivate Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

Subscription Class
InSite.Model Namespace


December Property

[image]

.NET Framework Class Library
Subscription..::.December Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property December As Boolean
C#
[DataMemberAttribute]
public virtual bool December { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool December {
    bool get ();
    void set (bool value);
}
JavaScript
function get_december();
function set_december(value);

See Also

Subscription Class
InSite.Model Namespace


February Property

[image]

.NET Framework Class Library
Subscription..::.February Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property February As Boolean
C#
[DataMemberAttribute]
public virtual bool February { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool February {
    bool get ();
    void set (bool value);
}
JavaScript
function get_february();
function set_february(value);

See Also

Subscription Class
InSite.Model Namespace


FixedPrice Property

[image]

.NET Framework Class Library
Subscription..::.FixedPrice Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FixedPrice As Boolean
C#
[DataMemberAttribute]
public virtual bool FixedPrice { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool FixedPrice {
    bool get ();
    void set (bool value);
}
JavaScript
function get_fixedPrice();
function set_fixedPrice(value);

See Also

Subscription Class
InSite.Model Namespace


IncludeInInitialOrder Property

[image]

.NET Framework Class Library
Subscription..::.IncludeInInitialOrder Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IncludeInInitialOrder As Boolean
C#
[DataMemberAttribute]
public virtual bool IncludeInInitialOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IncludeInInitialOrder {
    bool get ();
    void set (bool value);
}
JavaScript
function get_includeInInitialOrder();
function set_includeInInitialOrder(value);

See Also

Subscription Class
InSite.Model Namespace


January Property

[image]

.NET Framework Class Library
Subscription..::.January Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property January As Boolean
C#
[DataMemberAttribute]
public virtual bool January { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool January {
    bool get ();
    void set (bool value);
}
JavaScript
function get_january();
function set_january(value);

See Also

Subscription Class
InSite.Model Namespace


July Property

[image]

.NET Framework Class Library
Subscription..::.July Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property July As Boolean
C#
[DataMemberAttribute]
public virtual bool July { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool July {
    bool get ();
    void set (bool value);
}
JavaScript
function get_july();
function set_july(value);

See Also

Subscription Class
InSite.Model Namespace


June Property

[image]

.NET Framework Class Library
Subscription..::.June Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property June As Boolean
C#
[DataMemberAttribute]
public virtual bool June { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool June {
    bool get ();
    void set (bool value);
}
JavaScript
function get_june();
function set_june(value);

See Also

Subscription Class
InSite.Model Namespace


LastOrderDate Property

[image]

.NET Framework Class Library
Subscription..::.LastOrderDate Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LastOrderDate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> LastOrderDate { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> LastOrderDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_lastOrderDate();
function set_lastOrderDate(value);

See Also

Subscription Class
InSite.Model Namespace


March Property

[image]

.NET Framework Class Library
Subscription..::.March Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property March As Boolean
C#
[DataMemberAttribute]
public virtual bool March { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool March {
    bool get ();
    void set (bool value);
}
JavaScript
function get_march();
function set_march(value);

See Also

Subscription Class
InSite.Model Namespace


May Property

[image]

.NET Framework Class Library
Subscription..::.May Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property May As Boolean
C#
[DataMemberAttribute]
public virtual bool May { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool May {
    bool get ();
    void set (bool value);
}
JavaScript
function get_may();
function set_may(value);

See Also

Subscription Class
InSite.Model Namespace


NextOrderDate Property

[image]

.NET Framework Class Library
Subscription..::.NextOrderDate Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property NextOrderDate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> NextOrderDate { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> NextOrderDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_nextOrderDate();
function set_nextOrderDate(value);

See Also

Subscription Class
InSite.Model Namespace


November Property

[image]

.NET Framework Class Library
Subscription..::.November Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property November As Boolean
C#
[DataMemberAttribute]
public virtual bool November { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool November {
    bool get ();
    void set (bool value);
}
JavaScript
function get_november();
function set_november(value);

See Also

Subscription Class
InSite.Model Namespace


October Property

[image]

.NET Framework Class Library
Subscription..::.October Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property October As Boolean
C#
[DataMemberAttribute]
public virtual bool October { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool October {
    bool get ();
    void set (bool value);
}
JavaScript
function get_october();
function set_october(value);

See Also

Subscription Class
InSite.Model Namespace


OrderNumber Property

[image]

.NET Framework Class Library
Subscription..::.OrderNumber Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderNumber As String
C#
[DataMemberAttribute]
public virtual string OrderNumber { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ OrderNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumber();
function set_orderNumber(value);

See Also

Subscription Class
InSite.Model Namespace


PeriodsPerCycle Property

[image]

.NET Framework Class Library
Subscription..::.PeriodsPerCycle Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PeriodsPerCycle As Integer
C#
[DataMemberAttribute]
public virtual int PeriodsPerCycle { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int PeriodsPerCycle {
    int get ();
    void set (int value);
}
JavaScript
function get_periodsPerCycle();
function set_periodsPerCycle(value);

See Also

Subscription Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
Subscription..::.Product Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

Subscription Class
InSite.Model Namespace


ProductName Property

[image]

.NET Framework Class Library
Subscription..::.ProductName Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProductName As String
C#
[DataMemberAttribute]
public virtual string ProductName { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_productName();
function set_productName(value);

See Also

Subscription Class
InSite.Model Namespace


September Property

[image]

.NET Framework Class Library
Subscription..::.September Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property September As Boolean
C#
[DataMemberAttribute]
public virtual bool September { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool September {
    bool get ();
    void set (bool value);
}
JavaScript
function get_september();
function set_september(value);

See Also

Subscription Class
InSite.Model Namespace


ShipTo Property

[image]

.NET Framework Class Library
Subscription..::.ShipTo Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipTo As Customer
C#
public virtual Customer ShipTo { get; set; }
Visual C++
public:
virtual property Customer^ ShipTo {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_shipTo();
function set_shipTo(value);

See Also

Subscription Class
InSite.Model Namespace


ShipVia Property

[image]

.NET Framework Class Library
Subscription..::.ShipVia Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipVia As ShipVia
C#
public virtual ShipVia ShipVia { get; set; }
Visual C++
public:
virtual property ShipVia^ ShipVia {
    ShipVia^ get ();
    void set (ShipVia^ value);
}
JavaScript
function get_shipVia();
function set_shipVia(value);

See Also

Subscription Class
InSite.Model Namespace


ShipViaId Property

[image]

.NET Framework Class Library
Subscription..::.ShipViaId Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipViaId As String
C#
public virtual string ShipViaId { get; set; }
Visual C++
public:
virtual property String^ ShipViaId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipViaId();
function set_shipViaId(value);

See Also

Subscription Class
InSite.Model Namespace


ShipViaShipCode Property

[image]

.NET Framework Class Library
Subscription..::.ShipViaShipCode Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShipViaShipCode As String
C#
[DataMemberAttribute]
public virtual string ShipViaShipCode { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShipViaShipCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shipViaShipCode();
function set_shipViaShipCode(value);

See Also

Subscription Class
InSite.Model Namespace


SubscriptionId Property

[image]

.NET Framework Class Library
Subscription..::.SubscriptionId Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SubscriptionId As Guid
C#
public virtual Guid SubscriptionId { get; set; }
Visual C++
public:
virtual property Guid SubscriptionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_subscriptionId();
function set_subscriptionId(value);

See Also

Subscription Class
InSite.Model Namespace


SubscriptionLines Property

[image]

.NET Framework Class Library
Subscription..::.SubscriptionLines Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SubscriptionLines As ChildList(Of SubscriptionLine)
C#
public virtual ChildList<SubscriptionLine> SubscriptionLines { get; private set; }
Visual C++
public:
virtual property ChildList<SubscriptionLine^>^ SubscriptionLines {
    ChildList<SubscriptionLine^>^ get ();
    void set (ChildList<SubscriptionLine^>^ value);
}
JavaScript
function get_subscriptionLines();
function set_subscriptionLines(value);

See Also

Subscription Class
InSite.Model Namespace


TotalCycles Property

[image]

.NET Framework Class Library
Subscription..::.TotalCycles Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TotalCycles As Integer
C#
[DataMemberAttribute]
public virtual int TotalCycles { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int TotalCycles {
    int get ();
    void set (int value);
}
JavaScript
function get_totalCycles();
function set_totalCycles(value);

See Also

Subscription Class
InSite.Model Namespace


UserProfile Property

[image]

.NET Framework Class Library
Subscription..::.UserProfile Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfile As UserProfile
C#
public virtual UserProfile UserProfile { get; set; }
Visual C++
public:
virtual property UserProfile^ UserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_userProfile();
function set_userProfile(value);

See Also

Subscription Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
Subscription..::.WebSite Property
Subscription Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

Subscription Class
InSite.Model Namespace


SubscriptionLine Class

[image]

.NET Framework Class Library
SubscriptionLine Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SubscriptionLine _
    Inherits ModelBase(Of SubscriptionLine)
C#
[SerializableAttribute]
public class SubscriptionLine : ModelBase<SubscriptionLine>
Visual C++
[SerializableAttribute]
public ref class SubscriptionLine : public ModelBase<SubscriptionLine^>
JavaScript
InSite.Model.SubscriptionLine = function();

Type.createClass(
    'InSite.Model.SubscriptionLine',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(SubscriptionLine>)>)
InSite.Model..::.SubscriptionLine

See Also

SubscriptionLine Members
InSite.Model Namespace


SubscriptionLine Members

[image] [image]

.NET Framework Class Library
SubscriptionLine Members
SubscriptionLine Class Constructors Methods Fields Properties See Also Send Feedback

The SubscriptionLine type exposes the following members.

Constructors

Name | Description
SubscriptionLine |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Price |
Product |
QtyOrdered |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Subscription |
SubscriptionLineId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SubscriptionLine Class
InSite.Model Namespace


SubscriptionLine Constructor

[image]

.NET Framework Class Library
SubscriptionLine Constructor
SubscriptionLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SubscriptionLine()
Visual C++
public:
SubscriptionLine()
JavaScript
InSite.Model.SubscriptionLine = function();

See Also

SubscriptionLine Class
InSite.Model Namespace


SubscriptionLine Fields

[image] [image]

.NET Framework Class Library
SubscriptionLine Fields
SubscriptionLine Class See Also Send Feedback

The SubscriptionLine type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SubscriptionLine Class
InSite.Model Namespace


SubscriptionLine Methods

[image] [image]

.NET Framework Class Library
SubscriptionLine Methods
SubscriptionLine Class See Also Send Feedback

The SubscriptionLine type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SubscriptionLine Class
InSite.Model Namespace


SubscriptionLine Properties

[image] [image]

.NET Framework Class Library
SubscriptionLine Properties
SubscriptionLine Class See Also Send Feedback

The SubscriptionLine type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Price |
Product |
QtyOrdered |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Subscription |
SubscriptionLineId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SubscriptionLine Class
InSite.Model Namespace


Price Property

[image]

.NET Framework Class Library
SubscriptionLine..::.Price Property
SubscriptionLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Price As Decimal
C#
public virtual decimal Price { get; set; }
Visual C++
public:
virtual property Decimal Price {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_price();
function set_price(value);

See Also

SubscriptionLine Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
SubscriptionLine..::.Product Property
SubscriptionLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

SubscriptionLine Class
InSite.Model Namespace


QtyOrdered Property

[image]

.NET Framework Class Library
SubscriptionLine..::.QtyOrdered Property
SubscriptionLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property QtyOrdered As Decimal
C#
public virtual decimal QtyOrdered { get; set; }
Visual C++
public:
virtual property Decimal QtyOrdered {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_qtyOrdered();
function set_qtyOrdered(value);

See Also

SubscriptionLine Class
InSite.Model Namespace


Subscription Property

[image]

.NET Framework Class Library
SubscriptionLine..::.Subscription Property
SubscriptionLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Subscription As Subscription
C#
public virtual Subscription Subscription { get; set; }
Visual C++
public:
virtual property Subscription^ Subscription {
    Subscription^ get ();
    void set (Subscription^ value);
}
JavaScript
function get_subscription();
function set_subscription(value);

See Also

SubscriptionLine Class
InSite.Model Namespace


SubscriptionLineId Property

[image]

.NET Framework Class Library
SubscriptionLine..::.SubscriptionLineId Property
SubscriptionLine Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SubscriptionLineId As Guid
C#
public virtual Guid SubscriptionLineId { get; set; }
Visual C++
public:
virtual property Guid SubscriptionLineId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_subscriptionLineId();
function set_subscriptionLineId(value);

See Also

SubscriptionLine Class
InSite.Model Namespace


SubscriptionProduct Class

[image]

.NET Framework Class Library
SubscriptionProduct Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class SubscriptionProduct _
    Inherits ModelBase(Of SubscriptionProduct)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class SubscriptionProduct : ModelBase<SubscriptionProduct>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class SubscriptionProduct : public ModelBase<SubscriptionProduct^>
JavaScript
InSite.Model.SubscriptionProduct = function();

Type.createClass(
    'InSite.Model.SubscriptionProduct',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(SubscriptionProduct>)>)
InSite.Model..::.SubscriptionProduct

See Also

SubscriptionProduct Members
InSite.Model Namespace


SubscriptionProduct Members

[image] [image]

.NET Framework Class Library
SubscriptionProduct Members
SubscriptionProduct Class Constructors Methods Fields Properties See Also Send Feedback

The SubscriptionProduct type exposes the following members.

Constructors

Name | Description
SubscriptionProduct |

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentProduct |
Product |
QtyOrdered |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortDescription |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SubscriptionProductId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SubscriptionProduct Class
InSite.Model Namespace


SubscriptionProduct Constructor

[image]

.NET Framework Class Library
SubscriptionProduct Constructor
SubscriptionProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public SubscriptionProduct()
Visual C++
public:
SubscriptionProduct()
JavaScript
InSite.Model.SubscriptionProduct = function();

See Also

SubscriptionProduct Class
InSite.Model Namespace


SubscriptionProduct Fields

[image] [image]

.NET Framework Class Library
SubscriptionProduct Fields
SubscriptionProduct Class See Also Send Feedback

The SubscriptionProduct type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SubscriptionProduct Class
InSite.Model Namespace


SubscriptionProduct Methods

[image] [image]

.NET Framework Class Library
SubscriptionProduct Methods
SubscriptionProduct Class See Also Send Feedback

The SubscriptionProduct type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SubscriptionProduct Class
InSite.Model Namespace


SubscriptionProduct Properties

[image] [image]

.NET Framework Class Library
SubscriptionProduct Properties
SubscriptionProduct Class See Also Send Feedback

The SubscriptionProduct type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentProduct |
Product |
QtyOrdered |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortDescription |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SubscriptionProductId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

SubscriptionProduct Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
SubscriptionProduct..::.Name Property
SubscriptionProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

SubscriptionProduct Class
InSite.Model Namespace


ParentProduct Property

[image]

.NET Framework Class Library
SubscriptionProduct..::.ParentProduct Property
SubscriptionProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ParentProduct As Product
C#
public virtual Product ParentProduct { get; set; }
Visual C++
public:
virtual property Product^ ParentProduct {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_parentProduct();
function set_parentProduct(value);

See Also

SubscriptionProduct Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
SubscriptionProduct..::.Product Property
SubscriptionProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Product As ProductInfo
C#
[DataMemberAttribute]
public virtual ProductInfo Product { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ProductInfo^ Product {
    ProductInfo^ get ();
    void set (ProductInfo^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

SubscriptionProduct Class
InSite.Model Namespace


QtyOrdered Property

[image]

.NET Framework Class Library
SubscriptionProduct..::.QtyOrdered Property
SubscriptionProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property QtyOrdered As Decimal
C#
[SortField]
[DataMemberAttribute]
public virtual decimal QtyOrdered { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property Decimal QtyOrdered {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_qtyOrdered();
function set_qtyOrdered(value);

See Also

SubscriptionProduct Class
InSite.Model Namespace


ShortDescription Property

[image]

.NET Framework Class Library
SubscriptionProduct..::.ShortDescription Property
SubscriptionProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShortDescription As String
C#
[DataMemberAttribute]
public virtual string ShortDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ShortDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shortDescription();
function set_shortDescription(value);

See Also

SubscriptionProduct Class
InSite.Model Namespace


SubscriptionProductId Property

[image]

.NET Framework Class Library
SubscriptionProduct..::.SubscriptionProductId Property
SubscriptionProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property SubscriptionProductId As Guid
C#
public virtual Guid SubscriptionProductId { get; set; }
Visual C++
public:
virtual property Guid SubscriptionProductId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_subscriptionProductId();
function set_subscriptionProductId(value);

See Also

SubscriptionProduct Class
InSite.Model Namespace


TaxCalculator_Generic Class

[image]

.NET Framework Class Library
TaxCalculator_Generic Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TaxCalculator_Generic _
    Implements ITaxCalculator
C#
[SerializableAttribute]
public class TaxCalculator_Generic : ITaxCalculator
Visual C++
[SerializableAttribute]
public ref class TaxCalculator_Generic : ITaxCalculator
JavaScript
InSite.Model.TaxCalculator_Generic = function();

Type.createClass(
    'InSite.Model.TaxCalculator_Generic',
    null,
    InSite.Model.ITaxCalculator);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.TaxCalculator_Generic

See Also

TaxCalculator_Generic Members
InSite.Model Namespace


TaxCalculator_Generic Members

[image] [image]

.NET Framework Class Library
TaxCalculator_Generic Members
TaxCalculator_Generic Class Constructors Methods See Also Send Feedback

The TaxCalculator_Generic type exposes the following members.

Constructors

Name | Description
TaxCalculator_Generic |

Methods

Name | Description
CalculateTax | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaxCalculator_Generic Class
InSite.Model Namespace


TaxCalculator_Generic Constructor

[image]

.NET Framework Class Library
TaxCalculator_Generic Constructor
TaxCalculator_Generic Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaxCalculator_Generic()
Visual C++
public:
TaxCalculator_Generic()
JavaScript
InSite.Model.TaxCalculator_Generic = function();

See Also

TaxCalculator_Generic Class
InSite.Model Namespace


TaxCalculator_Generic Methods

[image] [image]

.NET Framework Class Library
TaxCalculator_Generic Methods
TaxCalculator_Generic Class See Also Send Feedback

The TaxCalculator_Generic type exposes the following members.

Methods

Name | Description
CalculateTax | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaxCalculator_Generic Class
InSite.Model Namespace


CalculateTax Method

[image] [image]

.NET Framework Class Library
TaxCalculator_Generic..::.CalculateTax Method
TaxCalculator_Generic Class See Also Send Feedback

Overload List

Name | Description
CalculateTax(WebSite, CustomerOrder) |
CalculateTax(WebSite, CustomerOrder, String, String) |

See Also

TaxCalculator_Generic Class
TaxCalculator_Generic Members
InSite.Model Namespace


CalculateTax Method (WebSite, CustomerOrder)

[image]

.NET Framework Class Library
TaxCalculator_Generic..::.CalculateTax Method (WebSite, CustomerOrder)
TaxCalculator_Generic Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub CalculateTax ( _
    webSite As WebSite, _
    customerOrder As CustomerOrder _
)
C#
public void CalculateTax(
    WebSite webSite,
    CustomerOrder customerOrder
)
Visual C++
public:
virtual void CalculateTax(
    WebSite^ webSite,
    CustomerOrder^ customerOrder
) sealed
JavaScript
function calculateTax(webSite, customerOrder);

Parameters

webSite
Type: InSite.Model..::.WebSite
customerOrder
Type: InSite.Model..::.CustomerOrder

Implements

ITaxCalculator..::.CalculateTax(WebSite, CustomerOrder)

See Also

TaxCalculator_Generic Class
CalculateTax Overload
InSite.Model Namespace


CalculateTax Method (WebSite, CustomerOrder, String, String)

[image]

.NET Framework Class Library
TaxCalculator_Generic..::.CalculateTax Method (WebSite, CustomerOrder, String, String)
TaxCalculator_Generic Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function CalculateTax ( _
    webSite As WebSite, _
    customerOrder As CustomerOrder, _
    stateAbbreviation As String, _
    zip As String _
) As Decimal
C#
public decimal CalculateTax(
    WebSite webSite,
    CustomerOrder customerOrder,
    string stateAbbreviation,
    string zip
)
Visual C++
public:
virtual Decimal CalculateTax(
    WebSite^ webSite,
    CustomerOrder^ customerOrder,
    String^ stateAbbreviation,
    String^ zip
) sealed
JavaScript
function calculateTax(webSite, customerOrder, stateAbbreviation, zip);

Parameters

webSite
Type: InSite.Model..::.WebSite
customerOrder
Type: InSite.Model..::.CustomerOrder
stateAbbreviation
Type: System..::.String
zip
Type: System..::.String

Implements

ITaxCalculator..::.CalculateTax(WebSite, CustomerOrder, String, String)

See Also

TaxCalculator_Generic Class
CalculateTax Overload
InSite.Model Namespace


TaxExemption Class

[image]

.NET Framework Class Library
TaxExemption Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class TaxExemption _
    Inherits ModelBase(Of TaxExemption)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class TaxExemption : ModelBase<TaxExemption>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class TaxExemption : public ModelBase<TaxExemption^>
JavaScript
InSite.Model.TaxExemption = function();

Type.createClass(
    'InSite.Model.TaxExemption',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(TaxExemption>)>)
InSite.Model..::.TaxExemption

See Also

TaxExemption Members
InSite.Model Namespace


TaxExemption Members

[image] [image]

.NET Framework Class Library
TaxExemption Members
TaxExemption Class Constructors Methods Fields Properties See Also Send Feedback

The TaxExemption type exposes the following members.

Constructors

Name | Description
TaxExemption | Overloaded.

Methods

Name | Description
AddCategory |
AddLocalTaxRate |
AddProduct |
AddState |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OrderLineQualifies |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategory |
RemoveLocalTaxRate |
RemoveProduct |
RemoveState |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Active |
Amount | Maximum Product Price for Product to Qualify for Exemption If null, there is no Maximum
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LocalTaxRates |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
States |
TaxExemptionId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

TaxExemption Class
InSite.Model Namespace


TaxExemption Constructor

[image] [image]

.NET Framework Class Library
TaxExemption Constructor
TaxExemption Class See Also Send Feedback

Overload List

Name | Description
TaxExemption()()() |
TaxExemption(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

TaxExemption Class
TaxExemption Members
InSite.Model Namespace


TaxExemption Constructor

[image]

.NET Framework Class Library
TaxExemption Constructor
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public TaxExemption()
Visual C++
public:
TaxExemption()
JavaScript
InSite.Model.TaxExemption = function();

See Also

TaxExemption Class
TaxExemption Overload
InSite.Model Namespace


TaxExemption Constructor (SearchMode)

[image]

.NET Framework Class Library
TaxExemption Constructor (SearchMode)
TaxExemption Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public TaxExemption(
    SearchMode searchMode
)
Visual C++
public:
TaxExemption(
    SearchMode searchMode
)
JavaScript
InSite.Model.TaxExemption = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

TaxExemption Class
TaxExemption Overload
InSite.Model Namespace


TaxExemption Fields

[image] [image]

.NET Framework Class Library
TaxExemption Fields
TaxExemption Class See Also Send Feedback

The TaxExemption type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

TaxExemption Class
InSite.Model Namespace


TaxExemption Methods

[image] [image]

.NET Framework Class Library
TaxExemption Methods
TaxExemption Class See Also Send Feedback

The TaxExemption type exposes the following members.

Methods

Name | Description
AddCategory |
AddLocalTaxRate |
AddProduct |
AddState |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OrderLineQualifies |
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCategory |
RemoveLocalTaxRate |
RemoveProduct |
RemoveState |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

TaxExemption Class
InSite.Model Namespace


AddCategory Method

[image]

.NET Framework Class Library
TaxExemption..::.AddCategory Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategory ( _
    value As Category _
)
C#
public virtual void AddCategory(
    Category value
)
Visual C++
public:
virtual void AddCategory(
    Category^ value
)
JavaScript
function addCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

TaxExemption Class
InSite.Model Namespace


AddLocalTaxRate Method

[image]

.NET Framework Class Library
TaxExemption..::.AddLocalTaxRate Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddLocalTaxRate ( _
    value As LocalTaxRate _
)
C#
public virtual void AddLocalTaxRate(
    LocalTaxRate value
)
Visual C++
public:
virtual void AddLocalTaxRate(
    LocalTaxRate^ value
)
JavaScript
function addLocalTaxRate(value);

Parameters

value
Type: InSite.Model..::.LocalTaxRate

See Also

TaxExemption Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
TaxExemption..::.AddProduct Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

TaxExemption Class
InSite.Model Namespace


AddState Method

[image]

.NET Framework Class Library
TaxExemption..::.AddState Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddState ( _
    value As State _
)
C#
public virtual void AddState(
    State value
)
Visual C++
public:
virtual void AddState(
    State^ value
)
JavaScript
function addState(value);

Parameters

value
Type: InSite.Model..::.State

See Also

TaxExemption Class
InSite.Model Namespace


OrderLineQualifies Method

[image]

.NET Framework Class Library
TaxExemption..::.OrderLineQualifies Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function OrderLineQualifies ( _
    orderLine As OrderLine _
) As Boolean
C#
public virtual bool OrderLineQualifies(
    OrderLine orderLine
)
Visual C++
public:
virtual bool OrderLineQualifies(
    OrderLine^ orderLine
)
JavaScript
function orderLineQualifies(orderLine);

Parameters

orderLine
Type: InSite.Model..::.OrderLine

See Also

TaxExemption Class
InSite.Model Namespace


RemoveCategory Method

[image]

.NET Framework Class Library
TaxExemption..::.RemoveCategory Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategory ( _
    value As Category _
)
C#
public virtual void RemoveCategory(
    Category value
)
Visual C++
public:
virtual void RemoveCategory(
    Category^ value
)
JavaScript
function removeCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

TaxExemption Class
InSite.Model Namespace


RemoveLocalTaxRate Method

[image]

.NET Framework Class Library
TaxExemption..::.RemoveLocalTaxRate Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveLocalTaxRate ( _
    value As LocalTaxRate _
)
C#
public virtual void RemoveLocalTaxRate(
    LocalTaxRate value
)
Visual C++
public:
virtual void RemoveLocalTaxRate(
    LocalTaxRate^ value
)
JavaScript
function removeLocalTaxRate(value);

Parameters

value
Type: InSite.Model..::.LocalTaxRate

See Also

TaxExemption Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
TaxExemption..::.RemoveProduct Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

TaxExemption Class
InSite.Model Namespace


RemoveState Method

[image]

.NET Framework Class Library
TaxExemption..::.RemoveState Method
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveState ( _
    value As State _
)
C#
public virtual void RemoveState(
    State value
)
Visual C++
public:
virtual void RemoveState(
    State^ value
)
JavaScript
function removeState(value);

Parameters

value
Type: InSite.Model..::.State

See Also

TaxExemption Class
InSite.Model Namespace


TaxExemption Properties

[image] [image]

.NET Framework Class Library
TaxExemption Properties
TaxExemption Class See Also Send Feedback

The TaxExemption type exposes the following members.

Properties

Name | Description
Active |
Amount | Maximum Product Price for Product to Qualify for Exemption If null, there is no Maximum
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Deactivate |
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LocalTaxRates |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
States |
TaxExemptionId |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

TaxExemption Class
InSite.Model Namespace


Active Property

[image]

.NET Framework Class Library
TaxExemption..::.Active Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Active As DateTime
C#
[DataMemberAttribute]
public virtual DateTime Active { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime Active {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_active();
function set_active(value);

See Also

TaxExemption Class
InSite.Model Namespace


Amount Property

[image]

.NET Framework Class Library
TaxExemption..::.Amount Property
TaxExemption Class See Also Send Feedback

Maximum Product Price for Product to Qualify for Exemption If null, there is no Maximum

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Amount As Nullable(Of Decimal)
C#
[DataMemberAttribute]
public virtual Nullable<decimal> Amount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<Decimal> Amount {
    Nullable<Decimal> get ();
    void set (Nullable<Decimal> value);
}
JavaScript
function get_amount();
function set_amount(value);

See Also

TaxExemption Class
InSite.Model Namespace


Categories Property

[image]

.NET Framework Class Library
TaxExemption..::.Categories Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Categories As ChildList(Of Category)
C#
[DataMemberAttribute]
public virtual ChildList<Category> Categories { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Category^>^ Categories {
    ChildList<Category^>^ get ();
    void set (ChildList<Category^>^ value);
}
JavaScript
function get_categories();
function set_categories(value);

See Also

TaxExemption Class
InSite.Model Namespace


Deactivate Property

[image]

.NET Framework Class Library
TaxExemption..::.Deactivate Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Deactivate As Nullable(Of DateTime)
C#
[DataMemberAttribute]
public virtual Nullable<DateTime> Deactivate { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Nullable<DateTime> Deactivate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_deactivate();
function set_deactivate(value);

See Also

TaxExemption Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
TaxExemption..::.Description Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

TaxExemption Class
InSite.Model Namespace


LocalTaxRates Property

[image]

.NET Framework Class Library
TaxExemption..::.LocalTaxRates Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LocalTaxRates As ChildList(Of LocalTaxRate)
C#
[DataMemberAttribute]
public virtual ChildList<LocalTaxRate> LocalTaxRates { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<LocalTaxRate^>^ LocalTaxRates {
    ChildList<LocalTaxRate^>^ get ();
    void set (ChildList<LocalTaxRate^>^ value);
}
JavaScript
function get_localTaxRates();
function set_localTaxRates(value);

See Also

TaxExemption Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
TaxExemption..::.Name Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

TaxExemption Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
TaxExemption..::.Products Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Products As ChildList(Of Product)
C#
[DataMemberAttribute]
public virtual ChildList<Product> Products { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

TaxExemption Class
InSite.Model Namespace


States Property

[image]

.NET Framework Class Library
TaxExemption..::.States Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property States As ChildList(Of State)
C#
[DataMemberAttribute]
public virtual ChildList<State> States { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<State^>^ States {
    ChildList<State^>^ get ();
    void set (ChildList<State^>^ value);
}
JavaScript
function get_states();
function set_states(value);

See Also

TaxExemption Class
InSite.Model Namespace


TaxExemptionId Property

[image]

.NET Framework Class Library
TaxExemption..::.TaxExemptionId Property
TaxExemption Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property TaxExemptionId As Guid
C#
public virtual Guid TaxExemptionId { get; set; }
Visual C++
public:
virtual property Guid TaxExemptionId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_taxExemptionId();
function set_taxExemptionId(value);

See Also

TaxExemption Class
InSite.Model Namespace


UserProfile Class

[image]

.NET Framework Class Library
UserProfile Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class UserProfile _
    Inherits ModelBase(Of UserProfile)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class UserProfile : ModelBase<UserProfile>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class UserProfile : public ModelBase<UserProfile^>
JavaScript
InSite.Model.UserProfile = function();

Type.createClass(
    'InSite.Model.UserProfile',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(UserProfile>)>)
InSite.Model..::.UserProfile

See Also

UserProfile Members
InSite.Model Namespace


UserProfile Members

[image] [image]

.NET Framework Class Library
UserProfile Members
UserProfile Class Constructors Methods Fields Properties See Also Send Feedback

The UserProfile type exposes the following members.

Constructors

Name | Description
UserProfile | Overloaded.

Methods

Name | Description
AddCustomer |
AddEmailList |
AddRole |
AddUserProfileProperty |
AddWishList |
ChangePassword |
ChangePasswordQuestionAndAnswer |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Delete |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateAlphaNumPassword |
GetByUserName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPassword | Overloaded.
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetSalesman | GetSalesman - If this UserProfile is a Salesman, it will return the Salesman NOTE: Done as a method to insure it isn't called by nHibernate or reflection for performance reasons
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUserProfileProperty |
HasRole |
Insert |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomer |
RemoveEmailList |
RemoveRole |
RemoveUserProfileProperty |
RemoveWishList |
ResetPassword | Overloaded.
SetSalesman | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnlockUser |
Update |
UpdateMembershipUser | This method is to be used at the end of serialization to insure all serialized changes are written to the Membership User
Validate | (Inherited from ModelBase<(Of <(T>)>).)
ValidateUser |
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ApplicationName |
CanChangePassword |
CanSubmitOrder |
CanViewAllOrders |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Comment |
Company |
CreationDate |
Current |
Customer | Customer - Returns billing customer if possible
CustomerNumber |
Customers | Customers - Complete list of Customers this User is attached to
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Email |
EmailLists |
Extension |
Fax |
FirstLastName |
FirstName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsApproved |
IsGuest |
IsLockedOut |
IsOnline |
IsSubscribed |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
LastActivityDate |
LastFirstName |
LastLockoutDate |
LastLoginDate |
LastName |
LastPasswordChangedDate |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Password | Password - Only used to transmit the password up for Excel Imports from the Management Console
PasswordQuestion |
Phone |
Position |
ProviderName |
ProviderUserKey |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Roles |
SalesmanNumberName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipTos |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SubscriptionUser | If true this user has signed up for an email subscription only and this email should be able to create an account later
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserName |
UserProfileId |
UserProfileProperties |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WishLists |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

UserProfile Class
InSite.Model Namespace


UserProfile Constructor

[image] [image]

.NET Framework Class Library
UserProfile Constructor
UserProfile Class See Also Send Feedback

Overload List

Name | Description
UserProfile()()() |
UserProfile(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

UserProfile Class
UserProfile Members
InSite.Model Namespace


UserProfile Constructor

[image]

.NET Framework Class Library
UserProfile Constructor
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UserProfile()
Visual C++
public:
UserProfile()
JavaScript
InSite.Model.UserProfile = function();

See Also

UserProfile Class
UserProfile Overload
InSite.Model Namespace


UserProfile Constructor (SearchMode)

[image]

.NET Framework Class Library
UserProfile Constructor (SearchMode)
UserProfile Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public UserProfile(
    SearchMode searchMode
)
Visual C++
public:
UserProfile(
    SearchMode searchMode
)
JavaScript
InSite.Model.UserProfile = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

UserProfile Class
UserProfile Overload
InSite.Model Namespace


UserProfile Fields

[image] [image]

.NET Framework Class Library
UserProfile Fields
UserProfile Class See Also Send Feedback

The UserProfile type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

UserProfile Class
InSite.Model Namespace


UserProfile Methods

[image] [image]

.NET Framework Class Library
UserProfile Methods
UserProfile Class See Also Send Feedback

The UserProfile type exposes the following members.

Methods

Name | Description
AddCustomer |
AddEmailList |
AddRole |
AddUserProfileProperty |
AddWishList |
ChangePassword |
ChangePasswordQuestionAndAnswer |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Delete |
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateAlphaNumPassword |
GetByUserName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPassword | Overloaded.
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetSalesman | GetSalesman - If this UserProfile is a Salesman, it will return the Salesman NOTE: Done as a method to insure it isn't called by nHibernate or reflection for performance reasons
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetUserProfileProperty |
HasRole |
Insert |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCustomer |
RemoveEmailList |
RemoveRole |
RemoveUserProfileProperty |
RemoveWishList |
ResetPassword | Overloaded.
SetSalesman | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnlockUser |
Update |
UpdateMembershipUser | This method is to be used at the end of serialization to insure all serialized changes are written to the Membership User
Validate | (Inherited from ModelBase<(Of <(T>)>).)
ValidateUser |
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

UserProfile Class
InSite.Model Namespace


AddCustomer Method

[image]

.NET Framework Class Library
UserProfile..::.AddCustomer Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomer ( _
    value As Customer _
)
C#
public virtual void AddCustomer(
    Customer value
)
Visual C++
public:
virtual void AddCustomer(
    Customer^ value
)
JavaScript
function addCustomer(value);

Parameters

value
Type: InSite.Model..::.Customer

See Also

UserProfile Class
InSite.Model Namespace


AddEmailList Method

[image]

.NET Framework Class Library
UserProfile..::.AddEmailList Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddEmailList ( _
    value As EmailList _
)
C#
public virtual void AddEmailList(
    EmailList value
)
Visual C++
public:
virtual void AddEmailList(
    EmailList^ value
)
JavaScript
function addEmailList(value);

Parameters

value
Type: InSite.Model..::.EmailList

See Also

UserProfile Class
InSite.Model Namespace


AddRole Method

[image]

.NET Framework Class Library
UserProfile..::.AddRole Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddRole ( _
    role As Role _
)
C#
public virtual void AddRole(
    Role role
)
Visual C++
public:
virtual void AddRole(
    Role^ role
)
JavaScript
function addRole(role);

Parameters

role
Type: InSite.Model..::.Role

See Also

UserProfile Class
InSite.Model Namespace


AddUserProfileProperty Method

[image]

.NET Framework Class Library
UserProfile..::.AddUserProfileProperty Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddUserProfileProperty ( _
    value As UserProfileProperty _
)
C#
public virtual void AddUserProfileProperty(
    UserProfileProperty value
)
Visual C++
public:
virtual void AddUserProfileProperty(
    UserProfileProperty^ value
)
JavaScript
function addUserProfileProperty(value);

Parameters

value
Type: InSite.Model..::.UserProfileProperty

See Also

UserProfile Class
InSite.Model Namespace


AddWishList Method

[image]

.NET Framework Class Library
UserProfile..::.AddWishList Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWishList ( _
    value As WishList _
)
C#
public virtual void AddWishList(
    WishList value
)
Visual C++
public:
virtual void AddWishList(
    WishList^ value
)
JavaScript
function addWishList(value);

Parameters

value
Type: InSite.Model..::.WishList

See Also

UserProfile Class
InSite.Model Namespace


ChangePassword Method

[image]

.NET Framework Class Library
UserProfile..::.ChangePassword Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ChangePassword ( _
    oldPassword As String, _
    newPassword As String _
) As Boolean
C#
public virtual bool ChangePassword(
    string oldPassword,
    string newPassword
)
Visual C++
public:
virtual bool ChangePassword(
    String^ oldPassword,
    String^ newPassword
)
JavaScript
function changePassword(oldPassword, newPassword);

Parameters

oldPassword
Type: System..::.String
newPassword
Type: System..::.String

See Also

UserProfile Class
InSite.Model Namespace


ChangePasswordQuestionAndAnswer Method

[image]

.NET Framework Class Library
UserProfile..::.ChangePasswordQuestionAndAnswer Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ChangePasswordQuestionAndAnswer ( _
    password As String, _
    newPasswordQuestion As String, _
    newPasswordAnswer As String _
) As Boolean
C#
public virtual bool ChangePasswordQuestionAndAnswer(
    string password,
    string newPasswordQuestion,
    string newPasswordAnswer
)
Visual C++
public:
virtual bool ChangePasswordQuestionAndAnswer(
    String^ password,
    String^ newPasswordQuestion,
    String^ newPasswordAnswer
)
JavaScript
function changePasswordQuestionAndAnswer(password, newPasswordQuestion, newPasswordAnswer);

Parameters

password
Type: System..::.String
newPasswordQuestion
Type: System..::.String
newPasswordAnswer
Type: System..::.String

See Also

UserProfile Class
InSite.Model Namespace


Delete Method

[image]

.NET Framework Class Library
UserProfile..::.Delete Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Delete ( _
    obj As UserProfile _
)
C#
public static void Delete(
    UserProfile obj
)
Visual C++
public:
static void Delete(
    UserProfile^ obj
)
JavaScript
InSite.Model.UserProfile.delete = function(obj);

Parameters

obj
Type: InSite.Model..::.UserProfile

See Also

UserProfile Class
InSite.Model Namespace


GenerateAlphaNumPassword Method

[image]

.NET Framework Class Library
UserProfile..::.GenerateAlphaNumPassword Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GenerateAlphaNumPassword ( _
    length As Integer _
) As String
C#
public static string GenerateAlphaNumPassword(
    int length
)
Visual C++
public:
static String^ GenerateAlphaNumPassword(
    int length
)
JavaScript
InSite.Model.UserProfile.generateAlphaNumPassword = function(length);

Parameters

length
Type: System..::.Int32

See Also

UserProfile Class
InSite.Model Namespace


GetByUserName Method

[image]

.NET Framework Class Library
UserProfile..::.GetByUserName Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByUserName ( _
    name As String _
) As UserProfile
C#
public static UserProfile GetByUserName(
    string name
)
Visual C++
public:
static UserProfile^ GetByUserName(
    String^ name
)
JavaScript
InSite.Model.UserProfile.getByUserName = function(name);

Parameters

name
Type: System..::.String

See Also

UserProfile Class
InSite.Model Namespace


GetPassword Method

[image] [image]

.NET Framework Class Library
UserProfile..::.GetPassword Method
UserProfile Class See Also Send Feedback

Overload List

Name | Description
GetPassword()()() |
GetPassword(String) |

See Also

UserProfile Class
UserProfile Members
InSite.Model Namespace


GetPassword Method

[image]

.NET Framework Class Library
UserProfile..::.GetPassword Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPassword As String
C#
public virtual string GetPassword()
Visual C++
public:
virtual String^ GetPassword()
JavaScript
function getPassword();

See Also

UserProfile Class
GetPassword Overload
InSite.Model Namespace


GetPassword Method (String)

[image]

.NET Framework Class Library
UserProfile..::.GetPassword Method (String)
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetPassword ( _
    passwordAnswer As String _
) As String
C#
public virtual string GetPassword(
    string passwordAnswer
)
Visual C++
public:
virtual String^ GetPassword(
    String^ passwordAnswer
)
JavaScript
function getPassword(passwordAnswer);

Parameters

passwordAnswer
Type: System..::.String

See Also

UserProfile Class
GetPassword Overload
InSite.Model Namespace


GetSalesman Method

[image]

.NET Framework Class Library
UserProfile..::.GetSalesman Method
UserProfile Class See Also Send Feedback

GetSalesman - If this UserProfile is a Salesman, it will return the Salesman NOTE: Done as a method to insure it isn't called by nHibernate or reflection for performance reasons

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetSalesman As Salesman
C#
public virtual Salesman GetSalesman()
Visual C++
public:
virtual Salesman^ GetSalesman()
JavaScript
function getSalesman();

Return Value

See Also

UserProfile Class
InSite.Model Namespace


GetUserProfileProperty Method

[image]

.NET Framework Class Library
UserProfile..::.GetUserProfileProperty Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetUserProfileProperty ( _
    name As String _
) As UserProfileProperty
C#
public virtual UserProfileProperty GetUserProfileProperty(
    string name
)
Visual C++
public:
virtual UserProfileProperty^ GetUserProfileProperty(
    String^ name
)
JavaScript
function getUserProfileProperty(name);

Parameters

name
Type: System..::.String

See Also

UserProfile Class
InSite.Model Namespace


HasRole Method

[image]

.NET Framework Class Library
UserProfile..::.HasRole Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function HasRole ( _
    roleName As String _
) As Boolean
C#
public virtual bool HasRole(
    string roleName
)
Visual C++
public:
virtual bool HasRole(
    String^ roleName
)
JavaScript
function hasRole(roleName);

Parameters

roleName
Type: System..::.String

See Also

UserProfile Class
InSite.Model Namespace


Insert Method

[image]

.NET Framework Class Library
UserProfile..::.Insert Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Insert ( _
    obj As UserProfile _
)
C#
public static void Insert(
    UserProfile obj
)
Visual C++
public:
static void Insert(
    UserProfile^ obj
)
JavaScript
InSite.Model.UserProfile.insert = function(obj);

Parameters

obj
Type: InSite.Model..::.UserProfile

See Also

UserProfile Class
InSite.Model Namespace


RemoveCustomer Method

[image]

.NET Framework Class Library
UserProfile..::.RemoveCustomer Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomer ( _
    value As Customer _
)
C#
public virtual void RemoveCustomer(
    Customer value
)
Visual C++
public:
virtual void RemoveCustomer(
    Customer^ value
)
JavaScript
function removeCustomer(value);

Parameters

value
Type: InSite.Model..::.Customer

See Also

UserProfile Class
InSite.Model Namespace


RemoveEmailList Method

[image]

.NET Framework Class Library
UserProfile..::.RemoveEmailList Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveEmailList ( _
    value As EmailList _
)
C#
public virtual void RemoveEmailList(
    EmailList value
)
Visual C++
public:
virtual void RemoveEmailList(
    EmailList^ value
)
JavaScript
function removeEmailList(value);

Parameters

value
Type: InSite.Model..::.EmailList

See Also

UserProfile Class
InSite.Model Namespace


RemoveRole Method

[image]

.NET Framework Class Library
UserProfile..::.RemoveRole Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveRole ( _
    role As Role _
)
C#
public virtual void RemoveRole(
    Role role
)
Visual C++
public:
virtual void RemoveRole(
    Role^ role
)
JavaScript
function removeRole(role);

Parameters

role
Type: InSite.Model..::.Role

See Also

UserProfile Class
InSite.Model Namespace


RemoveUserProfileProperty Method

[image]

.NET Framework Class Library
UserProfile..::.RemoveUserProfileProperty Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveUserProfileProperty ( _
    value As UserProfileProperty _
)
C#
public virtual void RemoveUserProfileProperty(
    UserProfileProperty value
)
Visual C++
public:
virtual void RemoveUserProfileProperty(
    UserProfileProperty^ value
)
JavaScript
function removeUserProfileProperty(value);

Parameters

value
Type: InSite.Model..::.UserProfileProperty

See Also

UserProfile Class
InSite.Model Namespace


RemoveWishList Method

[image]

.NET Framework Class Library
UserProfile..::.RemoveWishList Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWishList ( _
    value As WishList _
)
C#
public virtual void RemoveWishList(
    WishList value
)
Visual C++
public:
virtual void RemoveWishList(
    WishList^ value
)
JavaScript
function removeWishList(value);

Parameters

value
Type: InSite.Model..::.WishList

See Also

UserProfile Class
InSite.Model Namespace


ResetPassword Method

[image] [image]

.NET Framework Class Library
UserProfile..::.ResetPassword Method
UserProfile Class See Also Send Feedback

Overload List

Name | Description
ResetPassword()()() |
ResetPassword(String) |

See Also

UserProfile Class
UserProfile Members
InSite.Model Namespace


ResetPassword Method

[image]

.NET Framework Class Library
UserProfile..::.ResetPassword Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResetPassword As String
C#
public virtual string ResetPassword()
Visual C++
public:
virtual String^ ResetPassword()
JavaScript
function resetPassword();

See Also

UserProfile Class
ResetPassword Overload
InSite.Model Namespace


ResetPassword Method (String)

[image]

.NET Framework Class Library
UserProfile..::.ResetPassword Method (String)
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResetPassword ( _
    passwordAnswer As String _
) As String
C#
public virtual string ResetPassword(
    string passwordAnswer
)
Visual C++
public:
virtual String^ ResetPassword(
    String^ passwordAnswer
)
JavaScript
function resetPassword(passwordAnswer);

Parameters

passwordAnswer
Type: System..::.String

See Also

UserProfile Class
ResetPassword Overload
InSite.Model Namespace


SetSalesman Method

[image] [image]

.NET Framework Class Library
UserProfile..::.SetSalesman Method
UserProfile Class See Also Send Feedback

Overload List

Name | Description
SetSalesman(Guid) | SetSalesman - Set this UserProfile's Salesman to the passed in salesmanId and make sure no other UserProfile is set to this Salesman
SetSalesman(String) | SetSalesman - Set this UserProfile's Salesman to the passed in salesmanNumber and make sure no other UserProfile is set to this Salesman

See Also

UserProfile Class
UserProfile Members
InSite.Model Namespace


SetSalesman Method (Guid)

[image]

.NET Framework Class Library
UserProfile..::.SetSalesman Method (Guid)
UserProfile Class See Also Send Feedback

SetSalesman - Set this UserProfile's Salesman to the passed in salesmanId and make sure no other UserProfile is set to this Salesman

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetSalesman ( _
    salesmanId As Guid _
)
C#
public virtual void SetSalesman(
    Guid salesmanId
)
Visual C++
public:
virtual void SetSalesman(
    Guid salesmanId
)
JavaScript
function setSalesman(salesmanId);

Parameters

salesmanId
Type: System..::.Guid

See Also

UserProfile Class
SetSalesman Overload
InSite.Model Namespace


SetSalesman Method (String)

[image]

.NET Framework Class Library
UserProfile..::.SetSalesman Method (String)
UserProfile Class See Also Send Feedback

SetSalesman - Set this UserProfile's Salesman to the passed in salesmanNumber and make sure no other UserProfile is set to this Salesman

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetSalesman ( _
    salesmanNumber As String _
)
C#
public virtual void SetSalesman(
    string salesmanNumber
)
Visual C++
public:
virtual void SetSalesman(
    String^ salesmanNumber
)
JavaScript
function setSalesman(salesmanNumber);

Parameters

salesmanNumber
Type: System..::.String

See Also

UserProfile Class
SetSalesman Overload
InSite.Model Namespace


UnlockUser Method

[image]

.NET Framework Class Library
UserProfile..::.UnlockUser Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function UnlockUser As Boolean
C#
public virtual bool UnlockUser()
Visual C++
public:
virtual bool UnlockUser()
JavaScript
function unlockUser();

See Also

UserProfile Class
InSite.Model Namespace


Update Method

[image]

.NET Framework Class Library
UserProfile..::.Update Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Update ( _
    obj As UserProfile _
)
C#
public static void Update(
    UserProfile obj
)
Visual C++
public:
static void Update(
    UserProfile^ obj
)
JavaScript
InSite.Model.UserProfile.update = function(obj);

Parameters

obj
Type: InSite.Model..::.UserProfile

See Also

UserProfile Class
InSite.Model Namespace


UpdateMembershipUser Method

[image]

.NET Framework Class Library
UserProfile..::.UpdateMembershipUser Method
UserProfile Class See Also Send Feedback

This method is to be used at the end of serialization to insure all serialized changes are written to the Membership User

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub UpdateMembershipUser
C#
public virtual void UpdateMembershipUser()
Visual C++
public:
virtual void UpdateMembershipUser()
JavaScript
function updateMembershipUser();

See Also

UserProfile Class
InSite.Model Namespace


ValidateUser Method

[image]

.NET Framework Class Library
UserProfile..::.ValidateUser Method
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ValidateUser ( _
    userProfileId As String _
) As Boolean
C#
public static bool ValidateUser(
    string userProfileId
)
Visual C++
public:
static bool ValidateUser(
    String^ userProfileId
)
JavaScript
InSite.Model.UserProfile.validateUser = function(userProfileId);

Parameters

userProfileId
Type: System..::.String

See Also

UserProfile Class
InSite.Model Namespace


UserProfile Properties

[image] [image]

.NET Framework Class Library
UserProfile Properties
UserProfile Class See Also Send Feedback

The UserProfile type exposes the following members.

Properties

Name | Description
ApplicationName |
CanChangePassword |
CanSubmitOrder |
CanViewAllOrders |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Comment |
Company |
CreationDate |
Current |
Customer | Customer - Returns billing customer if possible
CustomerNumber |
Customers | Customers - Complete list of Customers this User is attached to
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Email |
EmailLists |
Extension |
Fax |
FirstLastName |
FirstName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsApproved |
IsGuest |
IsLockedOut |
IsOnline |
IsSubscribed |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
LanguageCode |
LastActivityDate |
LastFirstName |
LastLockoutDate |
LastLoginDate |
LastName |
LastPasswordChangedDate |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Password | Password - Only used to transmit the password up for Excel Imports from the Management Console
PasswordQuestion |
Phone |
Position |
ProviderName |
ProviderUserKey |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Roles |
SalesmanNumberName |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShipTos |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
SubscriptionUser | If true this user has signed up for an email subscription only and this email should be able to create an account later
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserName |
UserProfileId |
UserProfileProperties |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WishLists |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

UserProfile Class
InSite.Model Namespace


ApplicationName Property

[image]

.NET Framework Class Library
UserProfile..::.ApplicationName Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ApplicationName As String
C#
[DataMemberAttribute]
public virtual string ApplicationName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ApplicationName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_applicationName();
function set_applicationName(value);

See Also

UserProfile Class
InSite.Model Namespace


CanChangePassword Property

[image]

.NET Framework Class Library
UserProfile..::.CanChangePassword Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CanChangePassword As Boolean
C#
[DataMemberAttribute]
public virtual bool CanChangePassword { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool CanChangePassword {
    bool get ();
    void set (bool value);
}
JavaScript
function get_canChangePassword();
function set_canChangePassword(value);

See Also

UserProfile Class
InSite.Model Namespace


CanSubmitOrder Property

[image]

.NET Framework Class Library
UserProfile..::.CanSubmitOrder Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CanSubmitOrder As Boolean
C#
[DataMemberAttribute]
public virtual bool CanSubmitOrder { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool CanSubmitOrder {
    bool get ();
    void set (bool value);
}
JavaScript
function get_canSubmitOrder();
function set_canSubmitOrder(value);

See Also

UserProfile Class
InSite.Model Namespace


CanViewAllOrders Property

[image]

.NET Framework Class Library
UserProfile..::.CanViewAllOrders Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CanViewAllOrders As Boolean
C#
[DataMemberAttribute]
public virtual bool CanViewAllOrders { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool CanViewAllOrders {
    bool get ();
    void set (bool value);
}
JavaScript
function get_canViewAllOrders();
function set_canViewAllOrders(value);

See Also

UserProfile Class
InSite.Model Namespace


Comment Property

[image]

.NET Framework Class Library
UserProfile..::.Comment Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Comment As String
C#
[DataMemberAttribute]
public virtual string Comment { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Comment {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_comment();
function set_comment(value);

See Also

UserProfile Class
InSite.Model Namespace


Company Property

[image]

.NET Framework Class Library
UserProfile..::.Company Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Company As String
C#
[DataMemberAttribute]
public virtual string Company { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Company {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_company();
function set_company(value);

See Also

UserProfile Class
InSite.Model Namespace


CreationDate Property

[image]

.NET Framework Class Library
UserProfile..::.CreationDate Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CreationDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime CreationDate { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_creationDate();
function set_creationDate(value);

See Also

UserProfile Class
InSite.Model Namespace


Current Property

[image]

.NET Framework Class Library
UserProfile..::.Current Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property Current As UserProfile
C#
public static UserProfile Current { get; set; }
Visual C++
public:
static property UserProfile^ Current {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
InSite.Model.UserProfile.get_current = function();
InSite.Model.UserProfile.set_current = function(value);

See Also

UserProfile Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
UserProfile..::.Customer Property
UserProfile Class See Also Send Feedback

Customer - Returns billing customer if possible

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Customer As Customer
C#
public virtual Customer Customer { get; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
}
JavaScript
function get_customer();

See Also

UserProfile Class
InSite.Model Namespace


CustomerNumber Property

[image]

.NET Framework Class Library
UserProfile..::.CustomerNumber Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumber As String
C#
[DataMemberAttribute]
public virtual string CustomerNumber { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumber();
function set_customerNumber(value);

See Also

UserProfile Class
InSite.Model Namespace


Customers Property

[image]

.NET Framework Class Library
UserProfile..::.Customers Property
UserProfile Class See Also Send Feedback

Customers - Complete list of Customers this User is attached to

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Customers As ChildList(Of Customer)
C#
[DataMemberAttribute]
public virtual ChildList<Customer> Customers { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Customer^>^ Customers {
    ChildList<Customer^>^ get ();
    void set (ChildList<Customer^>^ value);
}
JavaScript
function get_customers();
function set_customers(value);

See Also

UserProfile Class
InSite.Model Namespace


Email Property

[image]

.NET Framework Class Library
UserProfile..::.Email Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Email As String
C#
[DataMemberAttribute]
public virtual string Email { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Email {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_email();
function set_email(value);

See Also

UserProfile Class
InSite.Model Namespace


EmailLists Property

[image]

.NET Framework Class Library
UserProfile..::.EmailLists Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property EmailLists As ChildList(Of EmailList)
C#
public virtual ChildList<EmailList> EmailLists { get; private set; }
Visual C++
public:
virtual property ChildList<EmailList^>^ EmailLists {
    ChildList<EmailList^>^ get ();
    void set (ChildList<EmailList^>^ value);
}
JavaScript
function get_emailLists();
function set_emailLists(value);

See Also

UserProfile Class
InSite.Model Namespace


Extension Property

[image]

.NET Framework Class Library
UserProfile..::.Extension Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Extension As String
C#
[DataMemberAttribute]
public virtual string Extension { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Extension {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_extension();
function set_extension(value);

See Also

UserProfile Class
InSite.Model Namespace


Fax Property

[image]

.NET Framework Class Library
UserProfile..::.Fax Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Fax As String
C#
[DataMemberAttribute]
public virtual string Fax { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Fax {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_fax();
function set_fax(value);

See Also

UserProfile Class
InSite.Model Namespace


FirstLastName Property

[image]

.NET Framework Class Library
UserProfile..::.FirstLastName Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property FirstLastName As String
C#
public virtual string FirstLastName { get; private set; }
Visual C++
public:
virtual property String^ FirstLastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstLastName();
function set_firstLastName(value);

See Also

UserProfile Class
InSite.Model Namespace


FirstName Property

[image]

.NET Framework Class Library
UserProfile..::.FirstName Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property FirstName As String
C#
[DataMemberAttribute]
public virtual string FirstName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ FirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_firstName();
function set_firstName(value);

See Also

UserProfile Class
InSite.Model Namespace


IsApproved Property

[image]

.NET Framework Class Library
UserProfile..::.IsApproved Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsApproved As Boolean
C#
[DataMemberAttribute]
public virtual bool IsApproved { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsApproved {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isApproved();
function set_isApproved(value);

See Also

UserProfile Class
InSite.Model Namespace


IsGuest Property

[image]

.NET Framework Class Library
UserProfile..::.IsGuest Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsGuest As Boolean
C#
[DataMemberAttribute]
public virtual bool IsGuest { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsGuest {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isGuest();
function set_isGuest(value);

See Also

UserProfile Class
InSite.Model Namespace


IsLockedOut Property

[image]

.NET Framework Class Library
UserProfile..::.IsLockedOut Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsLockedOut As Boolean
C#
[DataMemberAttribute]
public virtual bool IsLockedOut { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsLockedOut {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isLockedOut();
function set_isLockedOut(value);

See Also

UserProfile Class
InSite.Model Namespace


IsOnline Property

[image]

.NET Framework Class Library
UserProfile..::.IsOnline Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsOnline As Boolean
C#
[DataMemberAttribute]
public virtual bool IsOnline { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsOnline {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isOnline();
function set_isOnline(value);

See Also

UserProfile Class
InSite.Model Namespace


IsSubscribed Property

[image]

.NET Framework Class Library
UserProfile..::.IsSubscribed Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsSubscribed As Boolean
C#
[DataMemberAttribute]
public virtual bool IsSubscribed { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsSubscribed {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isSubscribed();
function set_isSubscribed(value);

See Also

UserProfile Class
InSite.Model Namespace


LanguageCode Property

[image]

.NET Framework Class Library
UserProfile..::.LanguageCode Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LanguageCode As String
C#
[DataMemberAttribute]
public virtual string LanguageCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_languageCode();
function set_languageCode(value);

See Also

UserProfile Class
InSite.Model Namespace


LastActivityDate Property

[image]

.NET Framework Class Library
UserProfile..::.LastActivityDate Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LastActivityDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime LastActivityDate { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime LastActivityDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_lastActivityDate();
function set_lastActivityDate(value);

See Also

UserProfile Class
InSite.Model Namespace


LastFirstName Property

[image]

.NET Framework Class Library
UserProfile..::.LastFirstName Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property LastFirstName As String
C#
public virtual string LastFirstName { get; private set; }
Visual C++
public:
virtual property String^ LastFirstName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastFirstName();
function set_lastFirstName(value);

See Also

UserProfile Class
InSite.Model Namespace


LastLockoutDate Property

[image]

.NET Framework Class Library
UserProfile..::.LastLockoutDate Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LastLockoutDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime LastLockoutDate { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime LastLockoutDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_lastLockoutDate();
function set_lastLockoutDate(value);

See Also

UserProfile Class
InSite.Model Namespace


LastLoginDate Property

[image]

.NET Framework Class Library
UserProfile..::.LastLoginDate Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LastLoginDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime LastLoginDate { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime LastLoginDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_lastLoginDate();
function set_lastLoginDate(value);

See Also

UserProfile Class
InSite.Model Namespace


LastName Property

[image]

.NET Framework Class Library
UserProfile..::.LastName Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LastName As String
C#
[DataMemberAttribute]
public virtual string LastName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LastName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_lastName();
function set_lastName(value);

See Also

UserProfile Class
InSite.Model Namespace


LastPasswordChangedDate Property

[image]

.NET Framework Class Library
UserProfile..::.LastPasswordChangedDate Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LastPasswordChangedDate As DateTime
C#
[DataMemberAttribute]
public virtual DateTime LastPasswordChangedDate { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property DateTime LastPasswordChangedDate {
    DateTime get ();
    void set (DateTime value);
}
JavaScript
function get_lastPasswordChangedDate();
function set_lastPasswordChangedDate(value);

See Also

UserProfile Class
InSite.Model Namespace


Password Property

[image]

.NET Framework Class Library
UserProfile..::.Password Property
UserProfile Class See Also Send Feedback

Password - Only used to transmit the password up for Excel Imports from the Management Console

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Password As String
C#
[DataMemberAttribute]
public virtual string Password { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Password {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_password();
function set_password(value);

See Also

UserProfile Class
InSite.Model Namespace


PasswordQuestion Property

[image]

.NET Framework Class Library
UserProfile..::.PasswordQuestion Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PasswordQuestion As String
C#
[DataMemberAttribute]
public virtual string PasswordQuestion { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PasswordQuestion {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_passwordQuestion();
function set_passwordQuestion(value);

See Also

UserProfile Class
InSite.Model Namespace


Phone Property

[image]

.NET Framework Class Library
UserProfile..::.Phone Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone As String
C#
[DataMemberAttribute]
public virtual string Phone { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone();
function set_phone(value);

See Also

UserProfile Class
InSite.Model Namespace


Position Property

[image]

.NET Framework Class Library
UserProfile..::.Position Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Position As String
C#
[DataMemberAttribute]
public virtual string Position { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Position {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_position();
function set_position(value);

See Also

UserProfile Class
InSite.Model Namespace


ProviderName Property

[image]

.NET Framework Class Library
UserProfile..::.ProviderName Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ProviderName As String
C#
[DataMemberAttribute]
public virtual string ProviderName { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_providerName();
function set_providerName(value);

See Also

UserProfile Class
InSite.Model Namespace


ProviderUserKey Property

[image]

.NET Framework Class Library
UserProfile..::.ProviderUserKey Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ProviderUserKey As Object
C#
public virtual Object ProviderUserKey { get; private set; }
Visual C++
public:
virtual property Object^ ProviderUserKey {
    Object^ get ();
    void set (Object^ value);
}
JavaScript
function get_providerUserKey();
function set_providerUserKey(value);

See Also

UserProfile Class
InSite.Model Namespace


Roles Property

[image]

.NET Framework Class Library
UserProfile..::.Roles Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Roles As ChildList(Of Role)
C#
[DataMemberAttribute]
public virtual ChildList<Role> Roles { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Role^>^ Roles {
    ChildList<Role^>^ get ();
    void set (ChildList<Role^>^ value);
}
JavaScript
function get_roles();
function set_roles(value);

See Also

UserProfile Class
InSite.Model Namespace


SalesmanNumberName Property

[image]

.NET Framework Class Library
UserProfile..::.SalesmanNumberName Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SalesmanNumberName As String
C#
[DataMemberAttribute]
public virtual string SalesmanNumberName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ SalesmanNumberName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_salesmanNumberName();
function set_salesmanNumberName(value);

See Also

UserProfile Class
InSite.Model Namespace


ShipTos Property

[image]

.NET Framework Class Library
UserProfile..::.ShipTos Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShipTos As IList(Of Customer)
C#
public virtual IList<Customer> ShipTos { get; private set; }
Visual C++
public:
virtual property IList<Customer^>^ ShipTos {
    IList<Customer^>^ get ();
    void set (IList<Customer^>^ value);
}
JavaScript
function get_shipTos();
function set_shipTos(value);

See Also

UserProfile Class
InSite.Model Namespace


SubscriptionUser Property

[image]

.NET Framework Class Library
UserProfile..::.SubscriptionUser Property
UserProfile Class See Also Send Feedback

If true this user has signed up for an email subscription only and this email should be able to create an account later

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SubscriptionUser As Boolean
C#
[DataMemberAttribute]
public virtual bool SubscriptionUser { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool SubscriptionUser {
    bool get ();
    void set (bool value);
}
JavaScript
function get_subscriptionUser();
function set_subscriptionUser(value);

See Also

UserProfile Class
InSite.Model Namespace


UserName Property

[image]

.NET Framework Class Library
UserProfile..::.UserName Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property UserName As String
C#
[SortField]
[DataMemberAttribute]
public virtual string UserName { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ UserName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_userName();
function set_userName(value);

See Also

UserProfile Class
InSite.Model Namespace


UserProfileId Property

[image]

.NET Framework Class Library
UserProfile..::.UserProfileId Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfileId As Guid
C#
public virtual Guid UserProfileId { get; set; }
Visual C++
public:
virtual property Guid UserProfileId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_userProfileId();
function set_userProfileId(value);

See Also

UserProfile Class
InSite.Model Namespace


UserProfileProperties Property

[image]

.NET Framework Class Library
UserProfile..::.UserProfileProperties Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property UserProfileProperties As ChildList(Of UserProfileProperty)
C#
[DataMemberAttribute]
public virtual ChildList<UserProfileProperty> UserProfileProperties { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<UserProfileProperty^>^ UserProfileProperties {
    ChildList<UserProfileProperty^>^ get ();
    void set (ChildList<UserProfileProperty^>^ value);
}
JavaScript
function get_userProfileProperties();
function set_userProfileProperties(value);

See Also

UserProfile Class
InSite.Model Namespace


WishLists Property

[image]

.NET Framework Class Library
UserProfile..::.WishLists Property
UserProfile Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WishLists As ChildList(Of WishList)
C#
public virtual ChildList<WishList> WishLists { get; private set; }
Visual C++
public:
virtual property ChildList<WishList^>^ WishLists {
    ChildList<WishList^>^ get ();
    void set (ChildList<WishList^>^ value);
}
JavaScript
function get_wishLists();
function set_wishLists(value);

See Also

UserProfile Class
InSite.Model Namespace


UserProfileProperty Class

[image]

.NET Framework Class Library
UserProfileProperty Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute> _
Public Class UserProfileProperty _
    Inherits ModelBase(Of UserProfileProperty)
C#
[SerializableAttribute]
[DataContractAttribute]
public class UserProfileProperty : ModelBase<UserProfileProperty>
Visual C++
[SerializableAttribute]
[DataContractAttribute]
public ref class UserProfileProperty : public ModelBase<UserProfileProperty^>
JavaScript
InSite.Model.UserProfileProperty = function();

Type.createClass(
    'InSite.Model.UserProfileProperty',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(UserProfileProperty>)>)
InSite.Model..::.UserProfileProperty

See Also

UserProfileProperty Members
InSite.Model Namespace


UserProfileProperty Members

[image] [image]

.NET Framework Class Library
UserProfileProperty Members
UserProfileProperty Class Constructors Methods Fields Properties See Also Send Feedback

The UserProfileProperty type exposes the following members.

Constructors

Name | Description
UserProfileProperty | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
UserProfilePropertyId |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

UserProfileProperty Class
InSite.Model Namespace


UserProfileProperty Constructor

[image] [image]

.NET Framework Class Library
UserProfileProperty Constructor
UserProfileProperty Class See Also Send Feedback

Overload List

Name | Description
UserProfileProperty()()() |
UserProfileProperty(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

UserProfileProperty Class
UserProfileProperty Members
InSite.Model Namespace


UserProfileProperty Constructor

[image]

.NET Framework Class Library
UserProfileProperty Constructor
UserProfileProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public UserProfileProperty()
Visual C++
public:
UserProfileProperty()
JavaScript
InSite.Model.UserProfileProperty = function();

See Also

UserProfileProperty Class
UserProfileProperty Overload
InSite.Model Namespace


UserProfileProperty Constructor (SearchMode)

[image]

.NET Framework Class Library
UserProfileProperty Constructor (SearchMode)
UserProfileProperty Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public UserProfileProperty(
    SearchMode searchMode
)
Visual C++
public:
UserProfileProperty(
    SearchMode searchMode
)
JavaScript
InSite.Model.UserProfileProperty = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

UserProfileProperty Class
UserProfileProperty Overload
InSite.Model Namespace


UserProfileProperty Fields

[image] [image]

.NET Framework Class Library
UserProfileProperty Fields
UserProfileProperty Class See Also Send Feedback

The UserProfileProperty type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

UserProfileProperty Class
InSite.Model Namespace


UserProfileProperty Methods

[image] [image]

.NET Framework Class Library
UserProfileProperty Methods
UserProfileProperty Class See Also Send Feedback

The UserProfileProperty type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

UserProfileProperty Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
UserProfileProperty..::.ToString Method
UserProfileProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

UserProfileProperty Class
InSite.Model Namespace


UserProfileProperty Properties

[image] [image]

.NET Framework Class Library
UserProfileProperty Properties
UserProfileProperty Class See Also Send Feedback

The UserProfileProperty type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
UserProfilePropertyId |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

UserProfileProperty Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
UserProfileProperty..::.Name Property
UserProfileProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
<SearchField> _
Public Overridable Property Name As String
C#
[SortField]
[DataMemberAttribute]
[SearchField]
public virtual string Name { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
[SearchField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

UserProfileProperty Class
InSite.Model Namespace


UserProfile Property

[image]

.NET Framework Class Library
UserProfileProperty..::.UserProfile Property
UserProfileProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfile As UserProfile
C#
public virtual UserProfile UserProfile { get; set; }
Visual C++
public:
virtual property UserProfile^ UserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_userProfile();
function set_userProfile(value);

See Also

UserProfileProperty Class
InSite.Model Namespace


UserProfilePropertyId Property

[image]

.NET Framework Class Library
UserProfileProperty..::.UserProfilePropertyId Property
UserProfileProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfilePropertyId As Guid
C#
public virtual Guid UserProfilePropertyId { get; set; }
Visual C++
public:
virtual property Guid UserProfilePropertyId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_userProfilePropertyId();
function set_userProfilePropertyId(value);

See Also

UserProfileProperty Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
UserProfileProperty..::.Value Property
UserProfileProperty Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

UserProfileProperty Class
InSite.Model Namespace


Vendor Class

[image]

.NET Framework Class Library
Vendor Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class Vendor _
    Inherits ModelBase(Of Vendor)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class Vendor : ModelBase<Vendor>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class Vendor : public ModelBase<Vendor^>
JavaScript
InSite.Model.Vendor = function();

Type.createClass(
    'InSite.Model.Vendor',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(Vendor>)>)
InSite.Model..::.Vendor

See Also

Vendor Members
InSite.Model Namespace


Vendor Members

[image] [image]

.NET Framework Class Library
Vendor Members
Vendor Class Constructors Methods Fields Properties See Also Send Feedback

The Vendor type exposes the following members.

Constructors

Name | Description
Vendor | Overloaded.

Methods

Name | Description
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetByVendorNumber |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
Address1 |
Address2 |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
City |
ContactEmail |
ContactName |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Phone |
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Ranking |
RegularMarkup |
SaleMarkup |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
VendorId |
VendorMessage |
VendorNumber |
VendorNumberName |
WebSiteAddress |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

Vendor Class
InSite.Model Namespace


Vendor Constructor

[image] [image]

.NET Framework Class Library
Vendor Constructor
Vendor Class See Also Send Feedback

Overload List

Name | Description
Vendor()()() |
Vendor(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

Vendor Class
Vendor Members
InSite.Model Namespace


Vendor Constructor

[image]

.NET Framework Class Library
Vendor Constructor
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Vendor()
Visual C++
public:
Vendor()
JavaScript
InSite.Model.Vendor = function();

See Also

Vendor Class
Vendor Overload
InSite.Model Namespace


Vendor Constructor (SearchMode)

[image]

.NET Framework Class Library
Vendor Constructor (SearchMode)
Vendor Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public Vendor(
    SearchMode searchMode
)
Visual C++
public:
Vendor(
    SearchMode searchMode
)
JavaScript
InSite.Model.Vendor = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

Vendor Class
Vendor Overload
InSite.Model Namespace


Vendor Fields

[image] [image]

.NET Framework Class Library
Vendor Fields
Vendor Class See Also Send Feedback

The Vendor type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Vendor Class
InSite.Model Namespace


Vendor Methods

[image] [image]

.NET Framework Class Library
Vendor Methods
Vendor Class See Also Send Feedback

The Vendor type exposes the following members.

Methods

Name | Description
AddProduct |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetByVendorNumber |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveProduct |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

Vendor Class
InSite.Model Namespace


AddProduct Method

[image]

.NET Framework Class Library
Vendor..::.AddProduct Method
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddProduct ( _
    value As Product _
)
C#
public virtual void AddProduct(
    Product value
)
Visual C++
public:
virtual void AddProduct(
    Product^ value
)
JavaScript
function addProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Vendor Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
Vendor..::.GetByName Method
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As Vendor
C#
public static Vendor GetByName(
    string name
)
Visual C++
public:
static Vendor^ GetByName(
    String^ name
)
JavaScript
InSite.Model.Vendor.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

Vendor Class
InSite.Model Namespace


GetByVendorNumber Method

[image]

.NET Framework Class Library
Vendor..::.GetByVendorNumber Method
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByVendorNumber ( _
    vendorNumber As String _
) As Vendor
C#
public static Vendor GetByVendorNumber(
    string vendorNumber
)
Visual C++
public:
static Vendor^ GetByVendorNumber(
    String^ vendorNumber
)
JavaScript
InSite.Model.Vendor.getByVendorNumber = function(vendorNumber);

Parameters

vendorNumber
Type: System..::.String

See Also

Vendor Class
InSite.Model Namespace


RemoveProduct Method

[image]

.NET Framework Class Library
Vendor..::.RemoveProduct Method
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveProduct ( _
    value As Product _
)
C#
public virtual void RemoveProduct(
    Product value
)
Visual C++
public:
virtual void RemoveProduct(
    Product^ value
)
JavaScript
function removeProduct(value);

Parameters

value
Type: InSite.Model..::.Product

See Also

Vendor Class
InSite.Model Namespace


Vendor Properties

[image] [image]

.NET Framework Class Library
Vendor Properties
Vendor Class See Also Send Feedback

The Vendor type exposes the following members.

Properties

Name | Description
Address1 |
Address2 |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
City |
ContactEmail |
ContactName |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Phone |
Products |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
Ranking |
RegularMarkup |
SaleMarkup |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
State |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
VendorId |
VendorMessage |
VendorNumber |
VendorNumberName |
WebSiteAddress |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)
Zip |

See Also

Vendor Class
InSite.Model Namespace


Address1 Property

[image]

.NET Framework Class Library
Vendor..::.Address1 Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address1 As String
C#
[DataMemberAttribute]
public virtual string Address1 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address1 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address1();
function set_address1(value);

See Also

Vendor Class
InSite.Model Namespace


Address2 Property

[image]

.NET Framework Class Library
Vendor..::.Address2 Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Address2 As String
C#
[DataMemberAttribute]
public virtual string Address2 { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Address2 {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address2();
function set_address2(value);

See Also

Vendor Class
InSite.Model Namespace


City Property

[image]

.NET Framework Class Library
Vendor..::.City Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property City As String
C#
[DataMemberAttribute]
public virtual string City { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ City {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

See Also

Vendor Class
InSite.Model Namespace


ContactEmail Property

[image]

.NET Framework Class Library
Vendor..::.ContactEmail Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ContactEmail As String
C#
[DataMemberAttribute]
public virtual string ContactEmail { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ContactEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contactEmail();
function set_contactEmail(value);

See Also

Vendor Class
InSite.Model Namespace


ContactName Property

[image]

.NET Framework Class Library
Vendor..::.ContactName Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ContactName As String
C#
[DataMemberAttribute]
public virtual string ContactName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ContactName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contactName();
function set_contactName(value);

See Also

Vendor Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
Vendor..::.Name Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

Vendor Class
InSite.Model Namespace


Phone Property

[image]

.NET Framework Class Library
Vendor..::.Phone Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Phone As String
C#
[DataMemberAttribute]
public virtual string Phone { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Phone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_phone();
function set_phone(value);

See Also

Vendor Class
InSite.Model Namespace


Products Property

[image]

.NET Framework Class Library
Vendor..::.Products Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Products As ChildList(Of Product)
C#
public virtual ChildList<Product> Products { get; private set; }
Visual C++
public:
virtual property ChildList<Product^>^ Products {
    ChildList<Product^>^ get ();
    void set (ChildList<Product^>^ value);
}
JavaScript
function get_products();
function set_products(value);

See Also

Vendor Class
InSite.Model Namespace


Ranking Property

[image]

.NET Framework Class Library
Vendor..::.Ranking Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Ranking As Integer
C#
[DataMemberAttribute]
public virtual int Ranking { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int Ranking {
    int get ();
    void set (int value);
}
JavaScript
function get_ranking();
function set_ranking(value);

See Also

Vendor Class
InSite.Model Namespace


RegularMarkup Property

[image]

.NET Framework Class Library
Vendor..::.RegularMarkup Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RegularMarkup As Decimal
C#
[DataMemberAttribute]
public virtual decimal RegularMarkup { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal RegularMarkup {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_regularMarkup();
function set_regularMarkup(value);

See Also

Vendor Class
InSite.Model Namespace


SaleMarkup Property

[image]

.NET Framework Class Library
Vendor..::.SaleMarkup Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property SaleMarkup As Decimal
C#
[DataMemberAttribute]
public virtual decimal SaleMarkup { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal SaleMarkup {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_saleMarkup();
function set_saleMarkup(value);

See Also

Vendor Class
InSite.Model Namespace


State Property

[image]

.NET Framework Class Library
Vendor..::.State Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property State As String
C#
[DataMemberAttribute]
public virtual string State { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ State {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

Vendor Class
InSite.Model Namespace


VendorId Property

[image]

.NET Framework Class Library
Vendor..::.VendorId Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property VendorId As Guid
C#
public virtual Guid VendorId { get; set; }
Visual C++
public:
virtual property Guid VendorId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_vendorId();
function set_vendorId(value);

See Also

Vendor Class
InSite.Model Namespace


VendorMessage Property

[image]

.NET Framework Class Library
Vendor..::.VendorMessage Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property VendorMessage As String
C#
[DataMemberAttribute]
public virtual string VendorMessage { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ VendorMessage {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vendorMessage();
function set_vendorMessage(value);

See Also

Vendor Class
InSite.Model Namespace


VendorNumber Property

[image]

.NET Framework Class Library
Vendor..::.VendorNumber Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property VendorNumber As String
C#
[DataMemberAttribute]
[SortField]
public virtual string VendorNumber { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ VendorNumber {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vendorNumber();
function set_vendorNumber(value);

See Also

Vendor Class
InSite.Model Namespace


VendorNumberName Property

[image]

.NET Framework Class Library
Vendor..::.VendorNumberName Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property VendorNumberName As String
C#
[DataMemberAttribute]
public virtual string VendorNumberName { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ VendorNumberName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_vendorNumberName();
function set_vendorNumberName(value);

See Also

Vendor Class
InSite.Model Namespace


WebSiteAddress Property

[image]

.NET Framework Class Library
Vendor..::.WebSiteAddress Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property WebSiteAddress As String
C#
[DataMemberAttribute]
public virtual string WebSiteAddress { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ WebSiteAddress {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_webSiteAddress();
function set_webSiteAddress(value);

See Also

Vendor Class
InSite.Model Namespace


Zip Property

[image]

.NET Framework Class Library
Vendor..::.Zip Property
Vendor Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Zip As String
C#
[DataMemberAttribute]
public virtual string Zip { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

See Also

Vendor Class
InSite.Model Namespace


WebPage Class

[image]

.NET Framework Class Library
WebPage Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class WebPage _
    Inherits ModelBase(Of WebPage)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class WebPage : ModelBase<WebPage>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class WebPage : public ModelBase<WebPage^>
JavaScript
InSite.Model.WebPage = function();

Type.createClass(
    'InSite.Model.WebPage',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(WebPage>)>)
InSite.Model..::.WebPage

See Also

WebPage Members
InSite.Model Namespace


WebPage Members

[image] [image]

.NET Framework Class Library
WebPage Members
WebPage Class Constructors Methods Fields Properties See Also Send Feedback

The WebPage type exposes the following members.

Constructors

Name | Description
WebPage | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MetaDescription |
MetaKeywords |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentWebSiteName |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Title |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebPageId |
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebPage Class
InSite.Model Namespace


WebPage Constructor

[image] [image]

.NET Framework Class Library
WebPage Constructor
WebPage Class See Also Send Feedback

Overload List

Name | Description
WebPage()()() |
WebPage(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

WebPage Class
WebPage Members
InSite.Model Namespace


WebPage Constructor

[image]

.NET Framework Class Library
WebPage Constructor
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebPage()
Visual C++
public:
WebPage()
JavaScript
InSite.Model.WebPage = function();

See Also

WebPage Class
WebPage Overload
InSite.Model Namespace


WebPage Constructor (SearchMode)

[image]

.NET Framework Class Library
WebPage Constructor (SearchMode)
WebPage Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public WebPage(
    SearchMode searchMode
)
Visual C++
public:
WebPage(
    SearchMode searchMode
)
JavaScript
InSite.Model.WebPage = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

WebPage Class
WebPage Overload
InSite.Model Namespace


WebPage Fields

[image] [image]

.NET Framework Class Library
WebPage Fields
WebPage Class See Also Send Feedback

The WebPage type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebPage Class
InSite.Model Namespace


WebPage Methods

[image] [image]

.NET Framework Class Library
WebPage Methods
WebPage Class See Also Send Feedback

The WebPage type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebPage Class
InSite.Model Namespace


WebPage Properties

[image] [image]

.NET Framework Class Library
WebPage Properties
WebPage Class See Also Send Feedback

The WebPage type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MetaDescription |
MetaKeywords |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
ParentWebSiteName |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
Title |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebPageId |
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebPage Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
WebPage..::.ContentManager Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

WebPage Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
WebPage..::.Description Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

WebPage Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
WebPage..::.HtmlContent Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HtmlContent As String
C#
[DataMemberAttribute]
public virtual string HtmlContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

WebPage Class
InSite.Model Namespace


MetaDescription Property

[image]

.NET Framework Class Library
WebPage..::.MetaDescription Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MetaDescription As String
C#
[DataMemberAttribute]
public virtual string MetaDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MetaDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_metaDescription();
function set_metaDescription(value);

See Also

WebPage Class
InSite.Model Namespace


MetaKeywords Property

[image]

.NET Framework Class Library
WebPage..::.MetaKeywords Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MetaKeywords As String
C#
[DataMemberAttribute]
public virtual string MetaKeywords { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MetaKeywords {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_metaKeywords();
function set_metaKeywords(value);

See Also

WebPage Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
WebPage..::.Name Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SortField> _
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[SortField]
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[SortField]
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

WebPage Class
InSite.Model Namespace


ParentWebSiteName Property

[image]

.NET Framework Class Library
WebPage..::.ParentWebSiteName Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ParentWebSiteName As String
C#
[DataMemberAttribute]
public virtual string ParentWebSiteName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ParentWebSiteName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parentWebSiteName();
function set_parentWebSiteName(value);

See Also

WebPage Class
InSite.Model Namespace


Title Property

[image]

.NET Framework Class Library
WebPage..::.Title Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Title As String
C#
[DataMemberAttribute]
public virtual string Title { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

See Also

WebPage Class
InSite.Model Namespace


WebPageId Property

[image]

.NET Framework Class Library
WebPage..::.WebPageId Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebPageId As Guid
C#
public virtual Guid WebPageId { get; set; }
Visual C++
public:
virtual property Guid WebPageId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_webPageId();
function set_webPageId(value);

See Also

WebPage Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
WebPage..::.WebSite Property
WebPage Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

WebPage Class
InSite.Model Namespace


WebPageContent Class

[image]

.NET Framework Class Library
WebPageContent Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class WebPageContent _
    Inherits ModelBase(Of WebPageContent)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class WebPageContent : ModelBase<WebPageContent>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class WebPageContent : public ModelBase<WebPageContent^>
JavaScript
InSite.Model.WebPageContent = function();

Type.createClass(
    'InSite.Model.WebPageContent',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(WebPageContent>)>)
InSite.Model..::.WebPageContent

See Also

WebPageContent Members
InSite.Model Namespace


WebPageContent Members

[image] [image]

.NET Framework Class Library
WebPageContent Members
WebPageContent Class Constructors Methods Fields Properties See Also Send Feedback

The WebPageContent type exposes the following members.

Constructors

Name | Description
WebPageContent | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
ContentTitle |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MetaDescription |
MetaTags |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OverrideParent |
PageTitle |
ParentWebSiteName |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebPageContentId |
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebPageContent Class
InSite.Model Namespace


WebPageContent Constructor

[image] [image]

.NET Framework Class Library
WebPageContent Constructor
WebPageContent Class See Also Send Feedback

Overload List

Name | Description
WebPageContent()()() |
WebPageContent(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

WebPageContent Class
WebPageContent Members
InSite.Model Namespace


WebPageContent Constructor

[image]

.NET Framework Class Library
WebPageContent Constructor
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebPageContent()
Visual C++
public:
WebPageContent()
JavaScript
InSite.Model.WebPageContent = function();

See Also

WebPageContent Class
WebPageContent Overload
InSite.Model Namespace


WebPageContent Constructor (SearchMode)

[image]

.NET Framework Class Library
WebPageContent Constructor (SearchMode)
WebPageContent Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public WebPageContent(
    SearchMode searchMode
)
Visual C++
public:
WebPageContent(
    SearchMode searchMode
)
JavaScript
InSite.Model.WebPageContent = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

WebPageContent Class
WebPageContent Overload
InSite.Model Namespace


WebPageContent Fields

[image] [image]

.NET Framework Class Library
WebPageContent Fields
WebPageContent Class See Also Send Feedback

The WebPageContent type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebPageContent Class
InSite.Model Namespace


WebPageContent Methods

[image] [image]

.NET Framework Class Library
WebPageContent Methods
WebPageContent Class See Also Send Feedback

The WebPageContent type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebPageContent Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
WebPageContent..::.GetByName Method
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    webPageContentName As String _
) As WebPageContent
C#
public static WebPageContent GetByName(
    string webPageContentName
)
Visual C++
public:
static WebPageContent^ GetByName(
    String^ webPageContentName
)
JavaScript
InSite.Model.WebPageContent.getByName = function(webPageContentName);

Parameters

webPageContentName
Type: System..::.String

See Also

WebPageContent Class
InSite.Model Namespace


WebPageContent Properties

[image] [image]

.NET Framework Class Library
WebPageContent Properties
WebPageContent Class See Also Send Feedback

The WebPageContent type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ContentManager |
ContentTitle |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
HtmlContent |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
MetaDescription |
MetaTags |
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OverrideParent |
PageTitle |
ParentWebSiteName |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebPageContentId |
WebSite |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebPageContent Class
InSite.Model Namespace


ContentManager Property

[image]

.NET Framework Class Library
WebPageContent..::.ContentManager Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ContentManager As ContentManager
C#
public virtual ContentManager ContentManager { get; set; }
Visual C++
public:
virtual property ContentManager^ ContentManager {
    ContentManager^ get ();
    void set (ContentManager^ value);
}
JavaScript
function get_contentManager();
function set_contentManager(value);

See Also

WebPageContent Class
InSite.Model Namespace


ContentTitle Property

[image]

.NET Framework Class Library
WebPageContent..::.ContentTitle Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ContentTitle As String
C#
[DataMemberAttribute]
public virtual string ContentTitle { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ContentTitle {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contentTitle();
function set_contentTitle(value);

See Also

WebPageContent Class
InSite.Model Namespace


HtmlContent Property

[image]

.NET Framework Class Library
WebPageContent..::.HtmlContent Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HtmlContent As String
C#
[DataMemberAttribute]
public virtual string HtmlContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HtmlContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_htmlContent();
function set_htmlContent(value);

See Also

WebPageContent Class
InSite.Model Namespace


MetaDescription Property

[image]

.NET Framework Class Library
WebPageContent..::.MetaDescription Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MetaDescription As String
C#
[DataMemberAttribute]
public virtual string MetaDescription { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MetaDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_metaDescription();
function set_metaDescription(value);

See Also

WebPageContent Class
InSite.Model Namespace


MetaTags Property

[image]

.NET Framework Class Library
WebPageContent..::.MetaTags Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MetaTags As String
C#
[DataMemberAttribute]
public virtual string MetaTags { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ MetaTags {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_metaTags();
function set_metaTags(value);

See Also

WebPageContent Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
WebPageContent..::.Name Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

WebPageContent Class
InSite.Model Namespace


OverrideParent Property

[image]

.NET Framework Class Library
WebPageContent..::.OverrideParent Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OverrideParent As Boolean
C#
[DataMemberAttribute]
public virtual bool OverrideParent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool OverrideParent {
    bool get ();
    void set (bool value);
}
JavaScript
function get_overrideParent();
function set_overrideParent(value);

See Also

WebPageContent Class
InSite.Model Namespace


PageTitle Property

[image]

.NET Framework Class Library
WebPageContent..::.PageTitle Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property PageTitle As String
C#
[DataMemberAttribute]
public virtual string PageTitle { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ PageTitle {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_pageTitle();
function set_pageTitle(value);

See Also

WebPageContent Class
InSite.Model Namespace


ParentWebSiteName Property

[image]

.NET Framework Class Library
WebPageContent..::.ParentWebSiteName Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ParentWebSiteName As String
C#
[DataMemberAttribute]
public virtual string ParentWebSiteName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ParentWebSiteName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_parentWebSiteName();
function set_parentWebSiteName(value);

See Also

WebPageContent Class
InSite.Model Namespace


WebPageContentId Property

[image]

.NET Framework Class Library
WebPageContent..::.WebPageContentId Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebPageContentId As Guid
C#
public virtual Guid WebPageContentId { get; set; }
Visual C++
public:
virtual property Guid WebPageContentId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_webPageContentId();
function set_webPageContentId(value);

See Also

WebPageContent Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
WebPageContent..::.WebSite Property
WebPageContent Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

WebPageContent Class
InSite.Model Namespace


WebSite Class

[image]

.NET Framework Class Library
WebSite Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class WebSite _
    Inherits ModelBase(Of WebSite)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class WebSite : ModelBase<WebSite>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class WebSite : public ModelBase<WebSite^>
JavaScript
InSite.Model.WebSite = function();

Type.createClass(
    'InSite.Model.WebSite',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(WebSite>)>)
InSite.Model..::.WebSite

See Also

WebSite Members
InSite.Model Namespace


WebSite Members

[image] [image]

.NET Framework Class Library
WebSite Members
WebSite Class Constructors Methods Fields Properties See Also Send Feedback

The WebSite type exposes the following members.

Constructors

Name | Description
WebSite | Overloaded.

Methods

Name | Description
AddCarrier |
AddCategory |
AddCountry |
AddCrossSell |
AddCustomerDiscount |
AddNewsArticle |
AddPromotion |
AddState |
AddWebPage |
AddWebPageContent |
AddWebSiteConfiguration |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByDomain |
GetByName |
GetCategory | Overloaded.
GetCategoryByName |
GetCategoryListByName | Ruturns a single category wrapped in an IList. Used for direct binding to FormView.
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetParentCategories |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebPage | Overloaded.
GetWebPageContent | Overloaded.
GetWebSiteConfiguration |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCarrier |
RemoveCategory |
RemoveCountry |
RemoveCrossSell |
RemoveCustomerDiscount |
RemoveNewsArticle |
RemovePromotion |
RemoveState |
RemoveWebPage |
RemoveWebPageContent |
RemoveWebSiteConfiguration |
SetCurrent |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
HandlingCalculationDollar |
HandlingCalculationNone |
HandlingCalculationPercent |
TaxCalculationCalculate |
TaxCalculationDollar |
TaxCalculationNone |
TaxCalculationPercent |

Properties

Name | Description
ActiveBaseCategories |
ActiveCrossSells |
AllowMultiplePromotions |
BaseCategories |
BodyStyle |
BottomContent |
Carriers |
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ClosingPageTags |
Company |
Countries |
CrossSells |
Current |
CustomerDiscounts |
CustomerNumberFormat |
CustomerNumberPrefix |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DefaultShipSite |
Description |
DomainName |
ERPServiceTimeout |
ERPServiceUrl |
FormattedStates |
HandlingAmount |
HandlingCalculation |
HeaderContent |
HostCompanyName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsERPIntegrated |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
JavaScript |
LeftContent |
MapProductsToCategories |
Name |
NewsArticles |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OpeningPageTags |
OrderNumberFormat |
OrderNumberPrefix |
Promotions |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RightContent |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShowBottomContent |
ShowLeftContent |
ShowRightContent |
ShowTopContent |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
States |
StyleSheet |
TaxAmount |
TaxCalculation |
TaxFreeTaxCode |
TermsOfUse |
Title |
TopContent |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebPageContents |
WebPages |
WebSiteConfigurations |
WebSiteId |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSite Class
InSite.Model Namespace


WebSite Constructor

[image] [image]

.NET Framework Class Library
WebSite Constructor
WebSite Class See Also Send Feedback

Overload List

Name | Description
WebSite()()() |
WebSite(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

WebSite Class
WebSite Members
InSite.Model Namespace


WebSite Constructor

[image]

.NET Framework Class Library
WebSite Constructor
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebSite()
Visual C++
public:
WebSite()
JavaScript
InSite.Model.WebSite = function();

See Also

WebSite Class
WebSite Overload
InSite.Model Namespace


WebSite Constructor (SearchMode)

[image]

.NET Framework Class Library
WebSite Constructor (SearchMode)
WebSite Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public WebSite(
    SearchMode searchMode
)
Visual C++
public:
WebSite(
    SearchMode searchMode
)
JavaScript
InSite.Model.WebSite = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

WebSite Class
WebSite Overload
InSite.Model Namespace


WebSite Fields

[image] [image]

.NET Framework Class Library
WebSite Fields
WebSite Class See Also Send Feedback

The WebSite type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)
HandlingCalculationDollar |
HandlingCalculationNone |
HandlingCalculationPercent |
TaxCalculationCalculate |
TaxCalculationDollar |
TaxCalculationNone |
TaxCalculationPercent |

See Also

WebSite Class
InSite.Model Namespace


HandlingCalculationDollar Field

[image]

.NET Framework Class Library
WebSite..::.HandlingCalculationDollar Field
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared HandlingCalculationDollar As String
C#
public static string HandlingCalculationDollar
Visual C++
public:
static String^ HandlingCalculationDollar
JavaScript
InSite.Model.WebSite.handlingCalculationDollar

See Also

WebSite Class
InSite.Model Namespace


HandlingCalculationNone Field

[image]

.NET Framework Class Library
WebSite..::.HandlingCalculationNone Field
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared HandlingCalculationNone As String
C#
public static string HandlingCalculationNone
Visual C++
public:
static String^ HandlingCalculationNone
JavaScript
InSite.Model.WebSite.handlingCalculationNone

See Also

WebSite Class
InSite.Model Namespace


HandlingCalculationPercent Field

[image]

.NET Framework Class Library
WebSite..::.HandlingCalculationPercent Field
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared HandlingCalculationPercent As String
C#
public static string HandlingCalculationPercent
Visual C++
public:
static String^ HandlingCalculationPercent
JavaScript
InSite.Model.WebSite.handlingCalculationPercent

See Also

WebSite Class
InSite.Model Namespace


TaxCalculationCalculate Field

[image]

.NET Framework Class Library
WebSite..::.TaxCalculationCalculate Field
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared TaxCalculationCalculate As String
C#
public static string TaxCalculationCalculate
Visual C++
public:
static String^ TaxCalculationCalculate
JavaScript
InSite.Model.WebSite.taxCalculationCalculate

See Also

WebSite Class
InSite.Model Namespace


TaxCalculationDollar Field

[image]

.NET Framework Class Library
WebSite..::.TaxCalculationDollar Field
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared TaxCalculationDollar As String
C#
public static string TaxCalculationDollar
Visual C++
public:
static String^ TaxCalculationDollar
JavaScript
InSite.Model.WebSite.taxCalculationDollar

See Also

WebSite Class
InSite.Model Namespace


TaxCalculationNone Field

[image]

.NET Framework Class Library
WebSite..::.TaxCalculationNone Field
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared TaxCalculationNone As String
C#
public static string TaxCalculationNone
Visual C++
public:
static String^ TaxCalculationNone
JavaScript
InSite.Model.WebSite.taxCalculationNone

See Also

WebSite Class
InSite.Model Namespace


TaxCalculationPercent Field

[image]

.NET Framework Class Library
WebSite..::.TaxCalculationPercent Field
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared TaxCalculationPercent As String
C#
public static string TaxCalculationPercent
Visual C++
public:
static String^ TaxCalculationPercent
JavaScript
InSite.Model.WebSite.taxCalculationPercent

See Also

WebSite Class
InSite.Model Namespace


WebSite Methods

[image] [image]

.NET Framework Class Library
WebSite Methods
WebSite Class See Also Send Feedback

The WebSite type exposes the following members.

Methods

Name | Description
AddCarrier |
AddCategory |
AddCountry |
AddCrossSell |
AddCustomerDiscount |
AddNewsArticle |
AddPromotion |
AddState |
AddWebPage |
AddWebPageContent |
AddWebSiteConfiguration |
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByDomain |
GetByName |
GetCategory | Overloaded.
GetCategoryByName |
GetCategoryListByName | Ruturns a single category wrapped in an IList. Used for direct binding to FormView.
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetParentCategories |
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWebPage | Overloaded.
GetWebPageContent | Overloaded.
GetWebSiteConfiguration |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveCarrier |
RemoveCategory |
RemoveCountry |
RemoveCrossSell |
RemoveCustomerDiscount |
RemoveNewsArticle |
RemovePromotion |
RemoveState |
RemoveWebPage |
RemoveWebPageContent |
RemoveWebSiteConfiguration |
SetCurrent |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSite Class
InSite.Model Namespace


AddCarrier Method

[image]

.NET Framework Class Library
WebSite..::.AddCarrier Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCarrier ( _
    value As Carrier _
)
C#
public virtual void AddCarrier(
    Carrier value
)
Visual C++
public:
virtual void AddCarrier(
    Carrier^ value
)
JavaScript
function addCarrier(value);

Parameters

value
Type: InSite.Model..::.Carrier

See Also

WebSite Class
InSite.Model Namespace


AddCategory Method

[image]

.NET Framework Class Library
WebSite..::.AddCategory Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCategory ( _
    value As Category _
)
C#
public virtual void AddCategory(
    Category value
)
Visual C++
public:
virtual void AddCategory(
    Category^ value
)
JavaScript
function addCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

WebSite Class
InSite.Model Namespace


AddCountry Method

[image]

.NET Framework Class Library
WebSite..::.AddCountry Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCountry ( _
    value As Country _
)
C#
public virtual void AddCountry(
    Country value
)
Visual C++
public:
virtual void AddCountry(
    Country^ value
)
JavaScript
function addCountry(value);

Parameters

value
Type: InSite.Model..::.Country

See Also

WebSite Class
InSite.Model Namespace


AddCrossSell Method

[image]

.NET Framework Class Library
WebSite..::.AddCrossSell Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCrossSell ( _
    value As ProductInfo _
)
C#
public virtual void AddCrossSell(
    ProductInfo value
)
Visual C++
public:
virtual void AddCrossSell(
    ProductInfo^ value
)
JavaScript
function addCrossSell(value);

Parameters

value
Type: InSite.Model..::.ProductInfo

See Also

WebSite Class
InSite.Model Namespace


AddCustomerDiscount Method

[image]

.NET Framework Class Library
WebSite..::.AddCustomerDiscount Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddCustomerDiscount ( _
    value As CustomerDiscount _
)
C#
public virtual void AddCustomerDiscount(
    CustomerDiscount value
)
Visual C++
public:
virtual void AddCustomerDiscount(
    CustomerDiscount^ value
)
JavaScript
function addCustomerDiscount(value);

Parameters

value
Type: InSite.Model..::.CustomerDiscount

See Also

WebSite Class
InSite.Model Namespace


AddNewsArticle Method

[image]

.NET Framework Class Library
WebSite..::.AddNewsArticle Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddNewsArticle ( _
    value As NewsArticle _
)
C#
public virtual void AddNewsArticle(
    NewsArticle value
)
Visual C++
public:
virtual void AddNewsArticle(
    NewsArticle^ value
)
JavaScript
function addNewsArticle(value);

Parameters

value
Type: InSite.Model..::.NewsArticle

See Also

WebSite Class
InSite.Model Namespace


AddPromotion Method

[image]

.NET Framework Class Library
WebSite..::.AddPromotion Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddPromotion ( _
    value As Promotion _
)
C#
public virtual void AddPromotion(
    Promotion value
)
Visual C++
public:
virtual void AddPromotion(
    Promotion^ value
)
JavaScript
function addPromotion(value);

Parameters

value
Type: InSite.Model..::.Promotion

See Also

WebSite Class
InSite.Model Namespace


AddState Method

[image]

.NET Framework Class Library
WebSite..::.AddState Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddState ( _
    value As State _
)
C#
public virtual void AddState(
    State value
)
Visual C++
public:
virtual void AddState(
    State^ value
)
JavaScript
function addState(value);

Parameters

value
Type: InSite.Model..::.State

See Also

WebSite Class
InSite.Model Namespace


AddWebPage Method

[image]

.NET Framework Class Library
WebSite..::.AddWebPage Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWebPage ( _
    value As WebPage _
)
C#
public virtual void AddWebPage(
    WebPage value
)
Visual C++
public:
virtual void AddWebPage(
    WebPage^ value
)
JavaScript
function addWebPage(value);

Parameters

value
Type: InSite.Model..::.WebPage

See Also

WebSite Class
InSite.Model Namespace


AddWebPageContent Method

[image]

.NET Framework Class Library
WebSite..::.AddWebPageContent Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWebPageContent ( _
    value As WebPageContent _
)
C#
public virtual void AddWebPageContent(
    WebPageContent value
)
Visual C++
public:
virtual void AddWebPageContent(
    WebPageContent^ value
)
JavaScript
function addWebPageContent(value);

Parameters

value
Type: InSite.Model..::.WebPageContent

See Also

WebSite Class
InSite.Model Namespace


AddWebSiteConfiguration Method

[image]

.NET Framework Class Library
WebSite..::.AddWebSiteConfiguration Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWebSiteConfiguration ( _
    value As WebSiteConfiguration _
)
C#
public virtual void AddWebSiteConfiguration(
    WebSiteConfiguration value
)
Visual C++
public:
virtual void AddWebSiteConfiguration(
    WebSiteConfiguration^ value
)
JavaScript
function addWebSiteConfiguration(value);

Parameters

value
Type: InSite.Model..::.WebSiteConfiguration

See Also

WebSite Class
InSite.Model Namespace


GetByDomain Method

[image]

.NET Framework Class Library
WebSite..::.GetByDomain Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByDomain ( _
    domainName As String _
) As WebSite
C#
public static WebSite GetByDomain(
    string domainName
)
Visual C++
public:
static WebSite^ GetByDomain(
    String^ domainName
)
JavaScript
InSite.Model.WebSite.getByDomain = function(domainName);

Parameters

domainName
Type: System..::.String

See Also

WebSite Class
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
WebSite..::.GetByName Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As WebSite
C#
public static WebSite GetByName(
    string name
)
Visual C++
public:
static WebSite^ GetByName(
    String^ name
)
JavaScript
InSite.Model.WebSite.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

WebSite Class
InSite.Model Namespace


GetCategory Method

[image] [image]

.NET Framework Class Library
WebSite..::.GetCategory Method
WebSite Class See Also Send Feedback

Overload List

Name | Description
GetCategory(Guid) |
GetCategory(String) |

See Also

WebSite Class
WebSite Members
InSite.Model Namespace


GetCategory Method (Guid)

[image]

.NET Framework Class Library
WebSite..::.GetCategory Method (Guid)
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCategory ( _
    categoryId As Guid _
) As Category
C#
public virtual Category GetCategory(
    Guid categoryId
)
Visual C++
public:
virtual Category^ GetCategory(
    Guid categoryId
)
JavaScript
function getCategory(categoryId);

Parameters

categoryId
Type: System..::.Guid

See Also

WebSite Class
GetCategory Overload
InSite.Model Namespace


GetCategory Method (String)

[image]

.NET Framework Class Library
WebSite..::.GetCategory Method (String)
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCategory ( _
    categoryId As String _
) As Category
C#
public virtual Category GetCategory(
    string categoryId
)
Visual C++
public:
virtual Category^ GetCategory(
    String^ categoryId
)
JavaScript
function getCategory(categoryId);

Parameters

categoryId
Type: System..::.String

See Also

WebSite Class
GetCategory Overload
InSite.Model Namespace


GetCategoryByName Method

[image]

.NET Framework Class Library
WebSite..::.GetCategoryByName Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCategoryByName ( _
    categoryName As String _
) As Category
C#
public virtual Category GetCategoryByName(
    string categoryName
)
Visual C++
public:
virtual Category^ GetCategoryByName(
    String^ categoryName
)
JavaScript
function getCategoryByName(categoryName);

Parameters

categoryName
Type: System..::.String

See Also

WebSite Class
InSite.Model Namespace


GetCategoryListByName Method

[image]

.NET Framework Class Library
WebSite..::.GetCategoryListByName Method
WebSite Class See Also Send Feedback

Ruturns a single category wrapped in an IList. Used for direct binding to FormView.

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetCategoryListByName ( _
    categoryName As String _
) As IList(Of Category)
C#
public virtual IList<Category> GetCategoryListByName(
    string categoryName
)
Visual C++
public:
virtual IList<Category^>^ GetCategoryListByName(
    String^ categoryName
)
JavaScript
function getCategoryListByName(categoryName);

Parameters

categoryName
Type: System..::.String
Name of the Category to retrive

Return Value

IList containing 1 category

See Also

WebSite Class
InSite.Model Namespace


GetParentCategories Method

[image]

.NET Framework Class Library
WebSite..::.GetParentCategories Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetParentCategories As ChildList(Of Category)
C#
public virtual ChildList<Category> GetParentCategories()
Visual C++
public:
virtual ChildList<Category^>^ GetParentCategories()
JavaScript
function getParentCategories();

See Also

WebSite Class
InSite.Model Namespace


GetWebPage Method

[image] [image]

.NET Framework Class Library
WebSite..::.GetWebPage Method
WebSite Class See Also Send Feedback

Overload List

Name | Description
GetWebPage(String) |
GetWebPage(String, Boolean) |

See Also

WebSite Class
WebSite Members
InSite.Model Namespace


GetWebPage Method (String)

[image]

.NET Framework Class Library
WebSite..::.GetWebPage Method (String)
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetWebPage ( _
    pageName As String _
) As WebPage
C#
public virtual WebPage GetWebPage(
    string pageName
)
Visual C++
public:
virtual WebPage^ GetWebPage(
    String^ pageName
)
JavaScript
function getWebPage(pageName);

Parameters

pageName
Type: System..::.String

See Also

WebSite Class
GetWebPage Overload
InSite.Model Namespace


GetWebPage Method (String, Boolean)

[image]

.NET Framework Class Library
WebSite..::.GetWebPage Method (String, Boolean)
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetWebPage ( _
    pageName As String, _
    errorOnNotFound As Boolean _
) As WebPage
C#
public virtual WebPage GetWebPage(
    string pageName,
    bool errorOnNotFound
)
Visual C++
public:
virtual WebPage^ GetWebPage(
    String^ pageName,
    bool errorOnNotFound
)
JavaScript
function getWebPage(pageName, errorOnNotFound);

Parameters

pageName
Type: System..::.String
errorOnNotFound
Type: System..::.Boolean

See Also

WebSite Class
GetWebPage Overload
InSite.Model Namespace


GetWebPageContent Method

[image] [image]

.NET Framework Class Library
WebSite..::.GetWebPageContent Method
WebSite Class See Also Send Feedback

Overload List

Name | Description
GetWebPageContent(String) |
GetWebPageContent(String, String) |

See Also

WebSite Class
WebSite Members
InSite.Model Namespace


GetWebPageContent Method (String)

[image]

.NET Framework Class Library
WebSite..::.GetWebPageContent Method (String)
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetWebPageContent ( _
    contentName As String _
) As WebPageContent
C#
public virtual WebPageContent GetWebPageContent(
    string contentName
)
Visual C++
public:
virtual WebPageContent^ GetWebPageContent(
    String^ contentName
)
JavaScript
function getWebPageContent(contentName);

Parameters

contentName
Type: System..::.String

See Also

WebSite Class
GetWebPageContent Overload
InSite.Model Namespace


GetWebPageContent Method (String, String)

[image]

.NET Framework Class Library
WebSite..::.GetWebPageContent Method (String, String)
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetWebPageContent ( _
    contentName As String, _
    defaultValue As String _
) As WebPageContent
C#
public virtual WebPageContent GetWebPageContent(
    string contentName,
    string defaultValue
)
Visual C++
public:
virtual WebPageContent^ GetWebPageContent(
    String^ contentName,
    String^ defaultValue
)
JavaScript
function getWebPageContent(contentName, defaultValue);

Parameters

contentName
Type: System..::.String
defaultValue
Type: System..::.String

See Also

WebSite Class
GetWebPageContent Overload
InSite.Model Namespace


GetWebSiteConfiguration Method

[image]

.NET Framework Class Library
WebSite..::.GetWebSiteConfiguration Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function GetWebSiteConfiguration ( _
    webSiteConfigurationName As String, _
    defaultValue As String, _
    defaultDescription As String _
) As WebSiteConfiguration
C#
public virtual WebSiteConfiguration GetWebSiteConfiguration(
    string webSiteConfigurationName,
    string defaultValue,
    string defaultDescription
)
Visual C++
public:
virtual WebSiteConfiguration^ GetWebSiteConfiguration(
    String^ webSiteConfigurationName,
    String^ defaultValue,
    String^ defaultDescription
)
JavaScript
function getWebSiteConfiguration(webSiteConfigurationName, defaultValue, defaultDescription);

Parameters

webSiteConfigurationName
Type: System..::.String
defaultValue
Type: System..::.String
defaultDescription
Type: System..::.String

See Also

WebSite Class
InSite.Model Namespace


RemoveCarrier Method

[image]

.NET Framework Class Library
WebSite..::.RemoveCarrier Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCarrier ( _
    value As Carrier _
)
C#
public virtual void RemoveCarrier(
    Carrier value
)
Visual C++
public:
virtual void RemoveCarrier(
    Carrier^ value
)
JavaScript
function removeCarrier(value);

Parameters

value
Type: InSite.Model..::.Carrier

See Also

WebSite Class
InSite.Model Namespace


RemoveCategory Method

[image]

.NET Framework Class Library
WebSite..::.RemoveCategory Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCategory ( _
    value As Category _
)
C#
public virtual void RemoveCategory(
    Category value
)
Visual C++
public:
virtual void RemoveCategory(
    Category^ value
)
JavaScript
function removeCategory(value);

Parameters

value
Type: InSite.Model..::.Category

See Also

WebSite Class
InSite.Model Namespace


RemoveCountry Method

[image]

.NET Framework Class Library
WebSite..::.RemoveCountry Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCountry ( _
    value As Country _
)
C#
public virtual void RemoveCountry(
    Country value
)
Visual C++
public:
virtual void RemoveCountry(
    Country^ value
)
JavaScript
function removeCountry(value);

Parameters

value
Type: InSite.Model..::.Country

See Also

WebSite Class
InSite.Model Namespace


RemoveCrossSell Method

[image]

.NET Framework Class Library
WebSite..::.RemoveCrossSell Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCrossSell ( _
    value As ProductInfo _
)
C#
public virtual void RemoveCrossSell(
    ProductInfo value
)
Visual C++
public:
virtual void RemoveCrossSell(
    ProductInfo^ value
)
JavaScript
function removeCrossSell(value);

Parameters

value
Type: InSite.Model..::.ProductInfo

See Also

WebSite Class
InSite.Model Namespace


RemoveCustomerDiscount Method

[image]

.NET Framework Class Library
WebSite..::.RemoveCustomerDiscount Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveCustomerDiscount ( _
    value As CustomerDiscount _
)
C#
public virtual void RemoveCustomerDiscount(
    CustomerDiscount value
)
Visual C++
public:
virtual void RemoveCustomerDiscount(
    CustomerDiscount^ value
)
JavaScript
function removeCustomerDiscount(value);

Parameters

value
Type: InSite.Model..::.CustomerDiscount

See Also

WebSite Class
InSite.Model Namespace


RemoveNewsArticle Method

[image]

.NET Framework Class Library
WebSite..::.RemoveNewsArticle Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveNewsArticle ( _
    value As NewsArticle _
)
C#
public virtual void RemoveNewsArticle(
    NewsArticle value
)
Visual C++
public:
virtual void RemoveNewsArticle(
    NewsArticle^ value
)
JavaScript
function removeNewsArticle(value);

Parameters

value
Type: InSite.Model..::.NewsArticle

See Also

WebSite Class
InSite.Model Namespace


RemovePromotion Method

[image]

.NET Framework Class Library
WebSite..::.RemovePromotion Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemovePromotion ( _
    value As Promotion _
)
C#
public virtual void RemovePromotion(
    Promotion value
)
Visual C++
public:
virtual void RemovePromotion(
    Promotion^ value
)
JavaScript
function removePromotion(value);

Parameters

value
Type: InSite.Model..::.Promotion

See Also

WebSite Class
InSite.Model Namespace


RemoveState Method

[image]

.NET Framework Class Library
WebSite..::.RemoveState Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveState ( _
    value As State _
)
C#
public virtual void RemoveState(
    State value
)
Visual C++
public:
virtual void RemoveState(
    State^ value
)
JavaScript
function removeState(value);

Parameters

value
Type: InSite.Model..::.State

See Also

WebSite Class
InSite.Model Namespace


RemoveWebPage Method

[image]

.NET Framework Class Library
WebSite..::.RemoveWebPage Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWebPage ( _
    value As WebPage _
)
C#
public virtual void RemoveWebPage(
    WebPage value
)
Visual C++
public:
virtual void RemoveWebPage(
    WebPage^ value
)
JavaScript
function removeWebPage(value);

Parameters

value
Type: InSite.Model..::.WebPage

See Also

WebSite Class
InSite.Model Namespace


RemoveWebPageContent Method

[image]

.NET Framework Class Library
WebSite..::.RemoveWebPageContent Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWebPageContent ( _
    value As WebPageContent _
)
C#
public virtual void RemoveWebPageContent(
    WebPageContent value
)
Visual C++
public:
virtual void RemoveWebPageContent(
    WebPageContent^ value
)
JavaScript
function removeWebPageContent(value);

Parameters

value
Type: InSite.Model..::.WebPageContent

See Also

WebSite Class
InSite.Model Namespace


RemoveWebSiteConfiguration Method

[image]

.NET Framework Class Library
WebSite..::.RemoveWebSiteConfiguration Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWebSiteConfiguration ( _
    value As WebSiteConfiguration _
)
C#
public virtual void RemoveWebSiteConfiguration(
    WebSiteConfiguration value
)
Visual C++
public:
virtual void RemoveWebSiteConfiguration(
    WebSiteConfiguration^ value
)
JavaScript
function removeWebSiteConfiguration(value);

Parameters

value
Type: InSite.Model..::.WebSiteConfiguration

See Also

WebSite Class
InSite.Model Namespace


SetCurrent Method

[image]

.NET Framework Class Library
WebSite..::.SetCurrent Method
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetCurrent
C#
public virtual void SetCurrent()
Visual C++
public:
virtual void SetCurrent()
JavaScript
function setCurrent();

See Also

WebSite Class
InSite.Model Namespace


WebSite Properties

[image] [image]

.NET Framework Class Library
WebSite Properties
WebSite Class See Also Send Feedback

The WebSite type exposes the following members.

Properties

Name | Description
ActiveBaseCategories |
ActiveCrossSells |
AllowMultiplePromotions |
BaseCategories |
BodyStyle |
BottomContent |
Carriers |
Categories |
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ClosingPageTags |
Company |
Countries |
CrossSells |
Current |
CustomerDiscounts |
CustomerNumberFormat |
CustomerNumberPrefix |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DefaultShipSite |
Description |
DomainName |
ERPServiceTimeout |
ERPServiceUrl |
FormattedStates |
HandlingAmount |
HandlingCalculation |
HeaderContent |
HostCompanyName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsERPIntegrated |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
JavaScript |
LeftContent |
MapProductsToCategories |
Name |
NewsArticles |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
OpeningPageTags |
OrderNumberFormat |
OrderNumberPrefix |
Promotions |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
RightContent |
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShowBottomContent |
ShowLeftContent |
ShowRightContent |
ShowTopContent |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
States |
StyleSheet |
TaxAmount |
TaxCalculation |
TaxFreeTaxCode |
TermsOfUse |
Title |
TopContent |
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebPageContents |
WebPages |
WebSiteConfigurations |
WebSiteId |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSite Class
InSite.Model Namespace


ActiveBaseCategories Property

[image]

.NET Framework Class Library
WebSite..::.ActiveBaseCategories Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveBaseCategories As ChildList(Of Category)
C#
public virtual ChildList<Category> ActiveBaseCategories { get; }
Visual C++
public:
virtual property ChildList<Category^>^ ActiveBaseCategories {
    ChildList<Category^>^ get ();
}
JavaScript
function get_activeBaseCategories();

See Also

WebSite Class
InSite.Model Namespace


ActiveCrossSells Property

[image]

.NET Framework Class Library
WebSite..::.ActiveCrossSells Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ActiveCrossSells As ChildList(Of ProductInfo)
C#
public virtual ChildList<ProductInfo> ActiveCrossSells { get; }
Visual C++
public:
virtual property ChildList<ProductInfo^>^ ActiveCrossSells {
    ChildList<ProductInfo^>^ get ();
}
JavaScript
function get_activeCrossSells();

See Also

WebSite Class
InSite.Model Namespace


AllowMultiplePromotions Property

[image]

.NET Framework Class Library
WebSite..::.AllowMultiplePromotions Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property AllowMultiplePromotions As Boolean
C#
[DataMemberAttribute]
public virtual bool AllowMultiplePromotions { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool AllowMultiplePromotions {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowMultiplePromotions();
function set_allowMultiplePromotions(value);

See Also

WebSite Class
InSite.Model Namespace


BaseCategories Property

[image]

.NET Framework Class Library
WebSite..::.BaseCategories Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property BaseCategories As ChildList(Of Category)
C#
public virtual ChildList<Category> BaseCategories { get; }
Visual C++
public:
virtual property ChildList<Category^>^ BaseCategories {
    ChildList<Category^>^ get ();
}
JavaScript
function get_baseCategories();

See Also

WebSite Class
InSite.Model Namespace


BodyStyle Property

[image]

.NET Framework Class Library
WebSite..::.BodyStyle Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BodyStyle As String
C#
[DataMemberAttribute]
public virtual string BodyStyle { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BodyStyle {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bodyStyle();
function set_bodyStyle(value);

See Also

WebSite Class
InSite.Model Namespace


BottomContent Property

[image]

.NET Framework Class Library
WebSite..::.BottomContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property BottomContent As String
C#
[DataMemberAttribute]
public virtual string BottomContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ BottomContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_bottomContent();
function set_bottomContent(value);

See Also

WebSite Class
InSite.Model Namespace


Carriers Property

[image]

.NET Framework Class Library
WebSite..::.Carriers Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Carriers As ChildList(Of Carrier)
C#
[DataMemberAttribute]
public virtual ChildList<Carrier> Carriers { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Carrier^>^ Carriers {
    ChildList<Carrier^>^ get ();
    void set (ChildList<Carrier^>^ value);
}
JavaScript
function get_carriers();
function set_carriers(value);

See Also

WebSite Class
InSite.Model Namespace


Categories Property

[image]

.NET Framework Class Library
WebSite..::.Categories Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Categories As ChildList(Of Category)
C#
public virtual ChildList<Category> Categories { get; private set; }
Visual C++
public:
virtual property ChildList<Category^>^ Categories {
    ChildList<Category^>^ get ();
    void set (ChildList<Category^>^ value);
}
JavaScript
function get_categories();
function set_categories(value);

See Also

WebSite Class
InSite.Model Namespace


ClosingPageTags Property

[image]

.NET Framework Class Library
WebSite..::.ClosingPageTags Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ClosingPageTags As String
C#
[DataMemberAttribute]
public virtual string ClosingPageTags { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ClosingPageTags {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_closingPageTags();
function set_closingPageTags(value);

See Also

WebSite Class
InSite.Model Namespace


Company Property

[image]

.NET Framework Class Library
WebSite..::.Company Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Company As Company
C#
[DataMemberAttribute]
public virtual Company Company { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Company^ Company {
    Company^ get ();
    void set (Company^ value);
}
JavaScript
function get_company();
function set_company(value);

See Also

WebSite Class
InSite.Model Namespace


Countries Property

[image]

.NET Framework Class Library
WebSite..::.Countries Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Countries As ChildList(Of Country)
C#
[DataMemberAttribute]
public virtual ChildList<Country> Countries { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Country^>^ Countries {
    ChildList<Country^>^ get ();
    void set (ChildList<Country^>^ value);
}
JavaScript
function get_countries();
function set_countries(value);

See Also

WebSite Class
InSite.Model Namespace


CrossSells Property

[image]

.NET Framework Class Library
WebSite..::.CrossSells Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CrossSells As ChildList(Of ProductInfo)
C#
[DataMemberAttribute]
public virtual ChildList<ProductInfo> CrossSells { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<ProductInfo^>^ CrossSells {
    ChildList<ProductInfo^>^ get ();
    void set (ChildList<ProductInfo^>^ value);
}
JavaScript
function get_crossSells();
function set_crossSells(value);

See Also

WebSite Class
InSite.Model Namespace


Current Property

[image]

.NET Framework Class Library
WebSite..::.Current Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Property Current As WebSite
C#
public static WebSite Current { get; set; }
Visual C++
public:
static property WebSite^ Current {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
InSite.Model.WebSite.get_current = function();
InSite.Model.WebSite.set_current = function(value);

See Also

WebSite Class
InSite.Model Namespace


CustomerDiscounts Property

[image]

.NET Framework Class Library
WebSite..::.CustomerDiscounts Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property CustomerDiscounts As ChildList(Of CustomerDiscount)
C#
public virtual ChildList<CustomerDiscount> CustomerDiscounts { get; private set; }
Visual C++
public:
virtual property ChildList<CustomerDiscount^>^ CustomerDiscounts {
    ChildList<CustomerDiscount^>^ get ();
    void set (ChildList<CustomerDiscount^>^ value);
}
JavaScript
function get_customerDiscounts();
function set_customerDiscounts(value);

See Also

WebSite Class
InSite.Model Namespace


CustomerNumberFormat Property

[image]

.NET Framework Class Library
WebSite..::.CustomerNumberFormat Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumberFormat As String
C#
[DataMemberAttribute]
public virtual string CustomerNumberFormat { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumberFormat {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumberFormat();
function set_customerNumberFormat(value);

See Also

WebSite Class
InSite.Model Namespace


CustomerNumberPrefix Property

[image]

.NET Framework Class Library
WebSite..::.CustomerNumberPrefix Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property CustomerNumberPrefix As String
C#
[DataMemberAttribute]
public virtual string CustomerNumberPrefix { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ CustomerNumberPrefix {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerNumberPrefix();
function set_customerNumberPrefix(value);

See Also

WebSite Class
InSite.Model Namespace


DefaultShipSite Property

[image]

.NET Framework Class Library
WebSite..::.DefaultShipSite Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DefaultShipSite As String
C#
[DataMemberAttribute]
public virtual string DefaultShipSite { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DefaultShipSite {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_defaultShipSite();
function set_defaultShipSite(value);

See Also

WebSite Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
WebSite..::.Description Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

WebSite Class
InSite.Model Namespace


DomainName Property

[image]

.NET Framework Class Library
WebSite..::.DomainName Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DomainName As String
C#
[DataMemberAttribute]
public virtual string DomainName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_domainName();
function set_domainName(value);

See Also

WebSite Class
InSite.Model Namespace


ERPServiceTimeout Property

[image]

.NET Framework Class Library
WebSite..::.ERPServiceTimeout Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPServiceTimeout As Integer
C#
[DataMemberAttribute]
public virtual int ERPServiceTimeout { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property int ERPServiceTimeout {
    int get ();
    void set (int value);
}
JavaScript
function get_erpServiceTimeout();
function set_erpServiceTimeout(value);

See Also

WebSite Class
InSite.Model Namespace


ERPServiceUrl Property

[image]

.NET Framework Class Library
WebSite..::.ERPServiceUrl Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ERPServiceUrl As String
C#
[DataMemberAttribute]
public virtual string ERPServiceUrl { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ ERPServiceUrl {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_erpServiceUrl();
function set_erpServiceUrl(value);

See Also

WebSite Class
InSite.Model Namespace


FormattedStates Property

[image]

.NET Framework Class Library
WebSite..::.FormattedStates Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FormattedStates As String
C#
public virtual string FormattedStates { get; }
Visual C++
public:
virtual property String^ FormattedStates {
    String^ get ();
}
JavaScript
function get_formattedStates();

See Also

WebSite Class
InSite.Model Namespace


HandlingAmount Property

[image]

.NET Framework Class Library
WebSite..::.HandlingAmount Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HandlingAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal HandlingAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal HandlingAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_handlingAmount();
function set_handlingAmount(value);

See Also

WebSite Class
InSite.Model Namespace


HandlingCalculation Property

[image]

.NET Framework Class Library
WebSite..::.HandlingCalculation Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HandlingCalculation As String
C#
[DataMemberAttribute]
public virtual string HandlingCalculation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HandlingCalculation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_handlingCalculation();
function set_handlingCalculation(value);

See Also

WebSite Class
InSite.Model Namespace


HeaderContent Property

[image]

.NET Framework Class Library
WebSite..::.HeaderContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HeaderContent As String
C#
[DataMemberAttribute]
public virtual string HeaderContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HeaderContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_headerContent();
function set_headerContent(value);

See Also

WebSite Class
InSite.Model Namespace


HostCompanyName Property

[image]

.NET Framework Class Library
WebSite..::.HostCompanyName Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property HostCompanyName As String
C#
[DataMemberAttribute]
public virtual string HostCompanyName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ HostCompanyName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_hostCompanyName();
function set_hostCompanyName(value);

See Also

WebSite Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
WebSite..::.IsActive Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

WebSite Class
InSite.Model Namespace


IsERPIntegrated Property

[image]

.NET Framework Class Library
WebSite..::.IsERPIntegrated Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property IsERPIntegrated As Boolean
C#
public virtual bool IsERPIntegrated { get; }
Visual C++
public:
virtual property bool IsERPIntegrated {
    bool get ();
}
JavaScript
function get_isERPIntegrated();

See Also

WebSite Class
InSite.Model Namespace


JavaScript Property

[image]

.NET Framework Class Library
WebSite..::.JavaScript Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property JavaScript As String
C#
[DataMemberAttribute]
public virtual string JavaScript { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ JavaScript {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_javaScript();
function set_javaScript(value);

See Also

WebSite Class
InSite.Model Namespace


LeftContent Property

[image]

.NET Framework Class Library
WebSite..::.LeftContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property LeftContent As String
C#
[DataMemberAttribute]
public virtual string LeftContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ LeftContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_leftContent();
function set_leftContent(value);

See Also

WebSite Class
InSite.Model Namespace


MapProductsToCategories Property

[image]

.NET Framework Class Library
WebSite..::.MapProductsToCategories Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property MapProductsToCategories As Boolean
C#
[DataMemberAttribute]
public virtual bool MapProductsToCategories { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool MapProductsToCategories {
    bool get ();
    void set (bool value);
}
JavaScript
function get_mapProductsToCategories();
function set_mapProductsToCategories(value);

See Also

WebSite Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
WebSite..::.Name Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

WebSite Class
InSite.Model Namespace


NewsArticles Property

[image]

.NET Framework Class Library
WebSite..::.NewsArticles Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property NewsArticles As ChildList(Of NewsArticle)
C#
public virtual ChildList<NewsArticle> NewsArticles { get; private set; }
Visual C++
public:
virtual property ChildList<NewsArticle^>^ NewsArticles {
    ChildList<NewsArticle^>^ get ();
    void set (ChildList<NewsArticle^>^ value);
}
JavaScript
function get_newsArticles();
function set_newsArticles(value);

See Also

WebSite Class
InSite.Model Namespace


OpeningPageTags Property

[image]

.NET Framework Class Library
WebSite..::.OpeningPageTags Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OpeningPageTags As String
C#
[DataMemberAttribute]
public virtual string OpeningPageTags { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ OpeningPageTags {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_openingPageTags();
function set_openingPageTags(value);

See Also

WebSite Class
InSite.Model Namespace


OrderNumberFormat Property

[image]

.NET Framework Class Library
WebSite..::.OrderNumberFormat Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderNumberFormat As String
C#
[DataMemberAttribute]
public virtual string OrderNumberFormat { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ OrderNumberFormat {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumberFormat();
function set_orderNumberFormat(value);

See Also

WebSite Class
InSite.Model Namespace


OrderNumberPrefix Property

[image]

.NET Framework Class Library
WebSite..::.OrderNumberPrefix Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property OrderNumberPrefix As String
C#
[DataMemberAttribute]
public virtual string OrderNumberPrefix { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ OrderNumberPrefix {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_orderNumberPrefix();
function set_orderNumberPrefix(value);

See Also

WebSite Class
InSite.Model Namespace


Promotions Property

[image]

.NET Framework Class Library
WebSite..::.Promotions Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Promotions As ChildList(Of Promotion)
C#
[DataMemberAttribute]
public virtual ChildList<Promotion> Promotions { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<Promotion^>^ Promotions {
    ChildList<Promotion^>^ get ();
    void set (ChildList<Promotion^>^ value);
}
JavaScript
function get_promotions();
function set_promotions(value);

See Also

WebSite Class
InSite.Model Namespace


RightContent Property

[image]

.NET Framework Class Library
WebSite..::.RightContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property RightContent As String
C#
[DataMemberAttribute]
public virtual string RightContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ RightContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_rightContent();
function set_rightContent(value);

See Also

WebSite Class
InSite.Model Namespace


ShowBottomContent Property

[image]

.NET Framework Class Library
WebSite..::.ShowBottomContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShowBottomContent As Boolean
C#
[DataMemberAttribute]
public virtual bool ShowBottomContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShowBottomContent {
    bool get ();
    void set (bool value);
}
JavaScript
function get_showBottomContent();
function set_showBottomContent(value);

See Also

WebSite Class
InSite.Model Namespace


ShowLeftContent Property

[image]

.NET Framework Class Library
WebSite..::.ShowLeftContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShowLeftContent As Boolean
C#
[DataMemberAttribute]
public virtual bool ShowLeftContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShowLeftContent {
    bool get ();
    void set (bool value);
}
JavaScript
function get_showLeftContent();
function set_showLeftContent(value);

See Also

WebSite Class
InSite.Model Namespace


ShowRightContent Property

[image]

.NET Framework Class Library
WebSite..::.ShowRightContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShowRightContent As Boolean
C#
[DataMemberAttribute]
public virtual bool ShowRightContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShowRightContent {
    bool get ();
    void set (bool value);
}
JavaScript
function get_showRightContent();
function set_showRightContent(value);

See Also

WebSite Class
InSite.Model Namespace


ShowTopContent Property

[image]

.NET Framework Class Library
WebSite..::.ShowTopContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property ShowTopContent As Boolean
C#
[DataMemberAttribute]
public virtual bool ShowTopContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool ShowTopContent {
    bool get ();
    void set (bool value);
}
JavaScript
function get_showTopContent();
function set_showTopContent(value);

See Also

WebSite Class
InSite.Model Namespace


States Property

[image]

.NET Framework Class Library
WebSite..::.States Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property States As ChildList(Of State)
C#
[DataMemberAttribute]
public virtual ChildList<State> States { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<State^>^ States {
    ChildList<State^>^ get ();
    void set (ChildList<State^>^ value);
}
JavaScript
function get_states();
function set_states(value);

See Also

WebSite Class
InSite.Model Namespace


StyleSheet Property

[image]

.NET Framework Class Library
WebSite..::.StyleSheet Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property StyleSheet As String
C#
[DataMemberAttribute]
public virtual string StyleSheet { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ StyleSheet {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_styleSheet();
function set_styleSheet(value);

See Also

WebSite Class
InSite.Model Namespace


TaxAmount Property

[image]

.NET Framework Class Library
WebSite..::.TaxAmount Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxAmount As Decimal
C#
[DataMemberAttribute]
public virtual decimal TaxAmount { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property Decimal TaxAmount {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_taxAmount();
function set_taxAmount(value);

See Also

WebSite Class
InSite.Model Namespace


TaxCalculation Property

[image]

.NET Framework Class Library
WebSite..::.TaxCalculation Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxCalculation As String
C#
[DataMemberAttribute]
public virtual string TaxCalculation { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxCalculation {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxCalculation();
function set_taxCalculation(value);

See Also

WebSite Class
InSite.Model Namespace


TaxFreeTaxCode Property

[image]

.NET Framework Class Library
WebSite..::.TaxFreeTaxCode Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TaxFreeTaxCode As String
C#
[DataMemberAttribute]
public virtual string TaxFreeTaxCode { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TaxFreeTaxCode {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_taxFreeTaxCode();
function set_taxFreeTaxCode(value);

See Also

WebSite Class
InSite.Model Namespace


TermsOfUse Property

[image]

.NET Framework Class Library
WebSite..::.TermsOfUse Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TermsOfUse As String
C#
[DataMemberAttribute]
public virtual string TermsOfUse { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TermsOfUse {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_termsOfUse();
function set_termsOfUse(value);

See Also

WebSite Class
InSite.Model Namespace


Title Property

[image]

.NET Framework Class Library
WebSite..::.Title Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Title As String
C#
[DataMemberAttribute]
public virtual string Title { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_title();
function set_title(value);

See Also

WebSite Class
InSite.Model Namespace


TopContent Property

[image]

.NET Framework Class Library
WebSite..::.TopContent Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property TopContent As String
C#
[DataMemberAttribute]
public virtual string TopContent { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ TopContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_topContent();
function set_topContent(value);

See Also

WebSite Class
InSite.Model Namespace


WebPageContents Property

[image]

.NET Framework Class Library
WebSite..::.WebPageContents Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebPageContents As ChildList(Of WebPageContent)
C#
public virtual ChildList<WebPageContent> WebPageContents { get; private set; }
Visual C++
public:
virtual property ChildList<WebPageContent^>^ WebPageContents {
    ChildList<WebPageContent^>^ get ();
    void set (ChildList<WebPageContent^>^ value);
}
JavaScript
function get_webPageContents();
function set_webPageContents(value);

See Also

WebSite Class
InSite.Model Namespace


WebPages Property

[image]

.NET Framework Class Library
WebSite..::.WebPages Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebPages As ChildList(Of WebPage)
C#
public virtual ChildList<WebPage> WebPages { get; private set; }
Visual C++
public:
virtual property ChildList<WebPage^>^ WebPages {
    ChildList<WebPage^>^ get ();
    void set (ChildList<WebPage^>^ value);
}
JavaScript
function get_webPages();
function set_webPages(value);

See Also

WebSite Class
InSite.Model Namespace


WebSiteConfigurations Property

[image]

.NET Framework Class Library
WebSite..::.WebSiteConfigurations Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property WebSiteConfigurations As ChildList(Of WebSiteConfiguration)
C#
[DataMemberAttribute]
public virtual ChildList<WebSiteConfiguration> WebSiteConfigurations { get; private set; }
Visual C++
[DataMemberAttribute]
public:
virtual property ChildList<WebSiteConfiguration^>^ WebSiteConfigurations {
    ChildList<WebSiteConfiguration^>^ get ();
    void set (ChildList<WebSiteConfiguration^>^ value);
}
JavaScript
function get_webSiteConfigurations();
function set_webSiteConfigurations(value);

See Also

WebSite Class
InSite.Model Namespace


WebSiteId Property

[image]

.NET Framework Class Library
WebSite..::.WebSiteId Property
WebSite Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSiteId As Guid
C#
public virtual Guid WebSiteId { get; set; }
Visual C++
public:
virtual property Guid WebSiteId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_webSiteId();
function set_webSiteId(value);

See Also

WebSite Class
InSite.Model Namespace


WebSiteConfiguration Class

[image]

.NET Framework Class Library
WebSiteConfiguration Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class WebSiteConfiguration _
    Inherits ModelBase(Of WebSiteConfiguration)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class WebSiteConfiguration : ModelBase<WebSiteConfiguration>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class WebSiteConfiguration : public ModelBase<WebSiteConfiguration^>
JavaScript
InSite.Model.WebSiteConfiguration = function();

Type.createClass(
    'InSite.Model.WebSiteConfiguration',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(WebSiteConfiguration>)>)
InSite.Model..::.WebSiteConfiguration

See Also

WebSiteConfiguration Members
InSite.Model Namespace


WebSiteConfiguration Members

[image] [image]

.NET Framework Class Library
WebSiteConfiguration Members
WebSiteConfiguration Class Constructors Methods Fields Properties See Also Send Feedback

The WebSiteConfiguration type exposes the following members.

Constructors

Name | Description
WebSiteConfiguration | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WebSite |
WebSiteConfigurationId |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSiteConfiguration Class
InSite.Model Namespace


WebSiteConfiguration Constructor

[image] [image]

.NET Framework Class Library
WebSiteConfiguration Constructor
WebSiteConfiguration Class See Also Send Feedback

Overload List

Name | Description
WebSiteConfiguration()()() |
WebSiteConfiguration(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

WebSiteConfiguration Class
WebSiteConfiguration Members
InSite.Model Namespace


WebSiteConfiguration Constructor

[image]

.NET Framework Class Library
WebSiteConfiguration Constructor
WebSiteConfiguration Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebSiteConfiguration()
Visual C++
public:
WebSiteConfiguration()
JavaScript
InSite.Model.WebSiteConfiguration = function();

See Also

WebSiteConfiguration Class
WebSiteConfiguration Overload
InSite.Model Namespace


WebSiteConfiguration Constructor (SearchMode)

[image]

.NET Framework Class Library
WebSiteConfiguration Constructor (SearchMode)
WebSiteConfiguration Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public WebSiteConfiguration(
    SearchMode searchMode
)
Visual C++
public:
WebSiteConfiguration(
    SearchMode searchMode
)
JavaScript
InSite.Model.WebSiteConfiguration = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

WebSiteConfiguration Class
WebSiteConfiguration Overload
InSite.Model Namespace


WebSiteConfiguration Fields

[image] [image]

.NET Framework Class Library
WebSiteConfiguration Fields
WebSiteConfiguration Class See Also Send Feedback

The WebSiteConfiguration type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSiteConfiguration Class
InSite.Model Namespace


WebSiteConfiguration Methods

[image] [image]

.NET Framework Class Library
WebSiteConfiguration Methods
WebSiteConfiguration Class See Also Send Feedback

The WebSiteConfiguration type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSiteConfiguration Class
InSite.Model Namespace


WebSiteConfiguration Properties

[image] [image]

.NET Framework Class Library
WebSiteConfiguration Properties
WebSiteConfiguration Class See Also Send Feedback

The WebSiteConfiguration type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Description |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
Value |
WebSite |
WebSiteConfigurationId |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSiteConfiguration Class
InSite.Model Namespace


Description Property

[image]

.NET Framework Class Library
WebSiteConfiguration..::.Description Property
WebSiteConfiguration Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Description As String
C#
[DataMemberAttribute]
public virtual string Description { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_description();
function set_description(value);

See Also

WebSiteConfiguration Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
WebSiteConfiguration..::.Name Property
WebSiteConfiguration Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

WebSiteConfiguration Class
InSite.Model Namespace


Value Property

[image]

.NET Framework Class Library
WebSiteConfiguration..::.Value Property
WebSiteConfiguration Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property Value As String
C#
[DataMemberAttribute]
public virtual string Value { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_value();
function set_value(value);

See Also

WebSiteConfiguration Class
InSite.Model Namespace


WebSite Property

[image]

.NET Framework Class Library
WebSiteConfiguration..::.WebSite Property
WebSiteConfiguration Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSite As WebSite
C#
public virtual WebSite WebSite { get; set; }
Visual C++
public:
virtual property WebSite^ WebSite {
    WebSite^ get ();
    void set (WebSite^ value);
}
JavaScript
function get_webSite();
function set_webSite(value);

See Also

WebSiteConfiguration Class
InSite.Model Namespace


WebSiteConfigurationId Property

[image]

.NET Framework Class Library
WebSiteConfiguration..::.WebSiteConfigurationId Property
WebSiteConfiguration Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSiteConfigurationId As Guid
C#
public virtual Guid WebSiteConfigurationId { get; set; }
Visual C++
public:
virtual property Guid WebSiteConfigurationId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_webSiteConfigurationId();
function set_webSiteConfigurationId(value);

See Also

WebSiteConfiguration Class
InSite.Model Namespace


WebSiteInfo Class

[image]

.NET Framework Class Library
WebSiteInfo Class
Members See Also Send Feedback

A simplified view of the WebSite Object

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(IsReference := True)> _
Public Class WebSiteInfo _
    Inherits ModelBase(Of WebSiteInfo)
C#
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public class WebSiteInfo : ModelBase<WebSiteInfo>
Visual C++
[SerializableAttribute]
[DataContractAttribute(IsReference = true)]
public ref class WebSiteInfo : public ModelBase<WebSiteInfo^>
JavaScript
InSite.Model.WebSiteInfo = function();

Type.createClass(
    'InSite.Model.WebSiteInfo',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(WebSiteInfo>)>)
InSite.Model..::.WebSiteInfo

See Also

WebSiteInfo Members
InSite.Model Namespace


WebSiteInfo Members

[image] [image]

.NET Framework Class Library
WebSiteInfo Members
WebSiteInfo Class Constructors Methods Fields Properties See Also Send Feedback

The WebSiteInfo type exposes the following members.

Constructors

Name | Description
WebSiteInfo | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DomainName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSiteId |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSiteInfo Class
InSite.Model Namespace


WebSiteInfo Constructor

[image] [image]

.NET Framework Class Library
WebSiteInfo Constructor
WebSiteInfo Class See Also Send Feedback

Overload List

Name | Description
WebSiteInfo()()() |
WebSiteInfo(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

WebSiteInfo Class
WebSiteInfo Members
InSite.Model Namespace


WebSiteInfo Constructor

[image]

.NET Framework Class Library
WebSiteInfo Constructor
WebSiteInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WebSiteInfo()
Visual C++
public:
WebSiteInfo()
JavaScript
InSite.Model.WebSiteInfo = function();

See Also

WebSiteInfo Class
WebSiteInfo Overload
InSite.Model Namespace


WebSiteInfo Constructor (SearchMode)

[image]

.NET Framework Class Library
WebSiteInfo Constructor (SearchMode)
WebSiteInfo Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public WebSiteInfo(
    SearchMode searchMode
)
Visual C++
public:
WebSiteInfo(
    SearchMode searchMode
)
JavaScript
InSite.Model.WebSiteInfo = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

WebSiteInfo Class
WebSiteInfo Overload
InSite.Model Namespace


WebSiteInfo Fields

[image] [image]

.NET Framework Class Library
WebSiteInfo Fields
WebSiteInfo Class See Also Send Feedback

The WebSiteInfo type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSiteInfo Class
InSite.Model Namespace


WebSiteInfo Methods

[image] [image]

.NET Framework Class Library
WebSiteInfo Methods
WebSiteInfo Class See Also Send Feedback

The WebSiteInfo type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSiteInfo Class
InSite.Model Namespace


WebSiteInfo Properties

[image] [image]

.NET Framework Class Library
WebSiteInfo Properties
WebSiteInfo Class See Also Send Feedback

The WebSiteInfo type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
DomainName |
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsActive |
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WebSiteId |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WebSiteInfo Class
InSite.Model Namespace


DomainName Property

[image]

.NET Framework Class Library
WebSiteInfo..::.DomainName Property
WebSiteInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property DomainName As String
C#
[DataMemberAttribute]
public virtual string DomainName { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_domainName();
function set_domainName(value);

See Also

WebSiteInfo Class
InSite.Model Namespace


IsActive Property

[image]

.NET Framework Class Library
WebSiteInfo..::.IsActive Property
WebSiteInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Overridable Property IsActive As Boolean
C#
[DataMemberAttribute]
public virtual bool IsActive { get; set; }
Visual C++
[DataMemberAttribute]
public:
virtual property bool IsActive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_isActive();
function set_isActive(value);

See Also

WebSiteInfo Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
WebSiteInfo..::.Name Property
WebSiteInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
<SortField> _
Public Overridable Property Name As String
C#
[DataMemberAttribute]
[SortField]
public virtual string Name { get; set; }
Visual C++
[DataMemberAttribute]
[SortField]
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

WebSiteInfo Class
InSite.Model Namespace


WebSiteId Property

[image]

.NET Framework Class Library
WebSiteInfo..::.WebSiteId Property
WebSiteInfo Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WebSiteId As Guid
C#
public virtual Guid WebSiteId { get; set; }
Visual C++
public:
virtual property Guid WebSiteId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_webSiteId();
function set_webSiteId(value);

See Also

WebSiteInfo Class
InSite.Model Namespace


WishList Class

[image]

.NET Framework Class Library
WishList Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WishList _
    Inherits ModelBase(Of WishList)
C#
[SerializableAttribute]
public class WishList : ModelBase<WishList>
Visual C++
[SerializableAttribute]
public ref class WishList : public ModelBase<WishList^>
JavaScript
InSite.Model.WishList = function();

Type.createClass(
    'InSite.Model.WishList',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(WishList>)>)
InSite.Model..::.WishList

See Also

WishList Members
InSite.Model Namespace


WishList Members

[image] [image]

.NET Framework Class Library
WishList Members
WishList Class Constructors Methods Fields Properties See Also Send Feedback

The WishList type exposes the following members.

Constructors

Name | Description
WishList | Overloaded.

Methods

Name | Description
AddWishListProduct | Overloaded.
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveAllWishListProducts |
RemoveWishListProduct | Overloaded.
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WishListId |
WishListProducts |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WishList Class
InSite.Model Namespace


WishList Constructor

[image] [image]

.NET Framework Class Library
WishList Constructor
WishList Class See Also Send Feedback

Overload List

Name | Description
WishList()()() |
WishList(SearchMode) | This Constructor is to be used when creating Query By Example objects

See Also

WishList Class
WishList Members
InSite.Model Namespace


WishList Constructor

[image]

.NET Framework Class Library
WishList Constructor
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WishList()
Visual C++
public:
WishList()
JavaScript
InSite.Model.WishList = function();

See Also

WishList Class
WishList Overload
InSite.Model Namespace


WishList Constructor (SearchMode)

[image]

.NET Framework Class Library
WishList Constructor (SearchMode)
WishList Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public WishList(
    SearchMode searchMode
)
Visual C++
public:
WishList(
    SearchMode searchMode
)
JavaScript
InSite.Model.WishList = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

WishList Class
WishList Overload
InSite.Model Namespace


WishList Fields

[image] [image]

.NET Framework Class Library
WishList Fields
WishList Class See Also Send Feedback

The WishList type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WishList Class
InSite.Model Namespace


WishList Methods

[image] [image]

.NET Framework Class Library
WishList Methods
WishList Class See Also Send Feedback

The WishList type exposes the following members.

Methods

Name | Description
AddWishListProduct | Overloaded.
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetByName |
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
RemoveAllWishListProducts |
RemoveWishListProduct | Overloaded.
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WishList Class
InSite.Model Namespace


AddWishListProduct Method

[image] [image]

.NET Framework Class Library
WishList..::.AddWishListProduct Method
WishList Class See Also Send Feedback

Overload List

Name | Description
AddWishListProduct(WishListProduct) |
AddWishListProduct(Product, Decimal) |

See Also

WishList Class
WishList Members
InSite.Model Namespace


AddWishListProduct Method (WishListProduct)

[image]

.NET Framework Class Library
WishList..::.AddWishListProduct Method (WishListProduct)
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWishListProduct ( _
    value As WishListProduct _
)
C#
public virtual void AddWishListProduct(
    WishListProduct value
)
Visual C++
public:
virtual void AddWishListProduct(
    WishListProduct^ value
)
JavaScript
function addWishListProduct(value);

Parameters

value
Type: InSite.Model..::.WishListProduct

See Also

WishList Class
AddWishListProduct Overload
InSite.Model Namespace


AddWishListProduct Method (Product, Decimal)

[image]

.NET Framework Class Library
WishList..::.AddWishListProduct Method (Product, Decimal)
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub AddWishListProduct ( _
    product As Product, _
    qtyOrdered As Decimal _
)
C#
public virtual void AddWishListProduct(
    Product product,
    decimal qtyOrdered
)
Visual C++
public:
virtual void AddWishListProduct(
    Product^ product,
    Decimal qtyOrdered
)
JavaScript
function addWishListProduct(product, qtyOrdered);

Parameters

product
Type: InSite.Model..::.Product
qtyOrdered
Type: System..::.Decimal

See Also

WishList Class
AddWishListProduct Overload
InSite.Model Namespace


GetByName Method

[image]

.NET Framework Class Library
WishList..::.GetByName Method
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetByName ( _
    name As String _
) As WishList
C#
public static WishList GetByName(
    string name
)
Visual C++
public:
static WishList^ GetByName(
    String^ name
)
JavaScript
InSite.Model.WishList.getByName = function(name);

Parameters

name
Type: System..::.String

See Also

WishList Class
InSite.Model Namespace


RemoveAllWishListProducts Method

[image]

.NET Framework Class Library
WishList..::.RemoveAllWishListProducts Method
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveAllWishListProducts
C#
public virtual void RemoveAllWishListProducts()
Visual C++
public:
virtual void RemoveAllWishListProducts()
JavaScript
function removeAllWishListProducts();

See Also

WishList Class
InSite.Model Namespace


RemoveWishListProduct Method

[image] [image]

.NET Framework Class Library
WishList..::.RemoveWishListProduct Method
WishList Class See Also Send Feedback

Overload List

Name | Description
RemoveWishListProduct(WishListProduct) |
RemoveWishListProduct(String) |

See Also

WishList Class
WishList Members
InSite.Model Namespace


RemoveWishListProduct Method (WishListProduct)

[image]

.NET Framework Class Library
WishList..::.RemoveWishListProduct Method (WishListProduct)
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWishListProduct ( _
    value As WishListProduct _
)
C#
public virtual void RemoveWishListProduct(
    WishListProduct value
)
Visual C++
public:
virtual void RemoveWishListProduct(
    WishListProduct^ value
)
JavaScript
function removeWishListProduct(value);

Parameters

value
Type: InSite.Model..::.WishListProduct

See Also

WishList Class
RemoveWishListProduct Overload
InSite.Model Namespace


RemoveWishListProduct Method (String)

[image]

.NET Framework Class Library
WishList..::.RemoveWishListProduct Method (String)
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub RemoveWishListProduct ( _
    wishListProductId As String _
)
C#
public virtual void RemoveWishListProduct(
    string wishListProductId
)
Visual C++
public:
virtual void RemoveWishListProduct(
    String^ wishListProductId
)
JavaScript
function removeWishListProduct(wishListProductId);

Parameters

wishListProductId
Type: System..::.String

See Also

WishList Class
RemoveWishListProduct Overload
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
WishList..::.ToString Method
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

WishList Class
InSite.Model Namespace


WishList Properties

[image] [image]

.NET Framework Class Library
WishList Properties
WishList Class See Also Send Feedback

The WishList type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
Customer |
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
Name |
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
UserProfile |
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WishListId |
WishListProducts |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WishList Class
InSite.Model Namespace


Customer Property

[image]

.NET Framework Class Library
WishList..::.Customer Property
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Customer As Customer
C#
public virtual Customer Customer { get; set; }
Visual C++
public:
virtual property Customer^ Customer {
    Customer^ get ();
    void set (Customer^ value);
}
JavaScript
function get_customer();
function set_customer(value);

See Also

WishList Class
InSite.Model Namespace


Name Property

[image]

.NET Framework Class Library
WishList..::.Name Property
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Name As String
C#
public virtual string Name { get; set; }
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

See Also

WishList Class
InSite.Model Namespace


UserProfile Property

[image]

.NET Framework Class Library
WishList..::.UserProfile Property
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property UserProfile As UserProfile
C#
public virtual UserProfile UserProfile { get; set; }
Visual C++
public:
virtual property UserProfile^ UserProfile {
    UserProfile^ get ();
    void set (UserProfile^ value);
}
JavaScript
function get_userProfile();
function set_userProfile(value);

See Also

WishList Class
InSite.Model Namespace


WishListId Property

[image]

.NET Framework Class Library
WishList..::.WishListId Property
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WishListId As Guid
C#
public virtual Guid WishListId { get; set; }
Visual C++
public:
virtual property Guid WishListId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_wishListId();
function set_wishListId(value);

See Also

WishList Class
InSite.Model Namespace


WishListProducts Property

[image]

.NET Framework Class Library
WishList..::.WishListProducts Property
WishList Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WishListProducts As ChildList(Of WishListProduct)
C#
public virtual ChildList<WishListProduct> WishListProducts { get; private set; }
Visual C++
public:
virtual property ChildList<WishListProduct^>^ WishListProducts {
    ChildList<WishListProduct^>^ get ();
    void set (ChildList<WishListProduct^>^ value);
}
JavaScript
function get_wishListProducts();
function set_wishListProducts(value);

See Also

WishList Class
InSite.Model Namespace


WishListProduct Class

[image]

.NET Framework Class Library
WishListProduct Class
Members See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WishListProduct _
    Inherits ModelBase(Of WishListProduct)
C#
[SerializableAttribute]
public class WishListProduct : ModelBase<WishListProduct>
Visual C++
[SerializableAttribute]
public ref class WishListProduct : public ModelBase<WishListProduct^>
JavaScript
InSite.Model.WishListProduct = function();

Type.createClass(
    'InSite.Model.WishListProduct',
    InSite.Model.ModelBase`1);

Inheritance Hierarchy

System..::.Object
InSite.Model..::.ModelBase <(Of <(WishListProduct>)>)
InSite.Model..::.WishListProduct

See Also

WishListProduct Members
InSite.Model Namespace


WishListProduct Members

[image] [image]

.NET Framework Class Library
WishListProduct Members
WishListProduct Class Constructors Methods Fields Properties See Also Send Feedback

The WishListProduct type exposes the following members.

Constructors

Name | Description
WishListProduct | Overloaded.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QtyOrdered |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortDescription |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WishList |
WishListProductId |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WishListProduct Class
InSite.Model Namespace


WishListProduct Constructor

[image] [image]

.NET Framework Class Library
WishListProduct Constructor
WishListProduct Class See Also Send Feedback

Overload List

Name | Description
WishListProduct()()() |
WishListProduct(SearchMode) | This Constructor is to be used when creating Query By Example objects
WishListProduct(Product, Decimal) | Creates a new WishListProduct

See Also

WishListProduct Class
WishListProduct Members
InSite.Model Namespace


WishListProduct Constructor

[image]

.NET Framework Class Library
WishListProduct Constructor
WishListProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public WishListProduct()
Visual C++
public:
WishListProduct()
JavaScript
InSite.Model.WishListProduct = function();

See Also

WishListProduct Class
WishListProduct Overload
InSite.Model Namespace


WishListProduct Constructor (SearchMode)

[image]

.NET Framework Class Library
WishListProduct Constructor (SearchMode)
WishListProduct Class See Also Send Feedback

This Constructor is to be used when creating Query By Example objects

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    searchMode As SearchMode _
)
C#
public WishListProduct(
    SearchMode searchMode
)
Visual C++
public:
WishListProduct(
    SearchMode searchMode
)
JavaScript
InSite.Model.WishListProduct = function(searchMode);

Parameters

searchMode
Type: InSite.Model..::.SearchMode

See Also

WishListProduct Class
WishListProduct Overload
InSite.Model Namespace


WishListProduct Constructor (Product, Decimal)

[image]

.NET Framework Class Library
WishListProduct Constructor (Product, Decimal)
WishListProduct Class See Also Send Feedback

Creates a new WishListProduct

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    product As Product, _
    qty As Decimal _
)
C#
public WishListProduct(
    Product product,
    decimal qty
)
Visual C++
public:
WishListProduct(
    Product^ product,
    Decimal qty
)
JavaScript
InSite.Model.WishListProduct = function(product, qty);

Parameters

product
Type: InSite.Model..::.Product
Product to be added to the WishList
qty
Type: System..::.Decimal
Number

See Also

WishListProduct Class
WishListProduct Overload
InSite.Model Namespace


WishListProduct Fields

[image] [image]

.NET Framework Class Library
WishListProduct Fields
WishListProduct Class See Also Send Feedback

The WishListProduct type exposes the following members.

Fields

Name | Description
_validationService | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WishListProduct Class
InSite.Model Namespace


WishListProduct Methods

[image] [image]

.NET Framework Class Library
WishListProduct Methods
WishListProduct Class See Also Send Feedback

The WishListProduct type exposes the following members.

Methods

Name | Description
CompareTo | (Inherited from ModelBase<(Of <(T>)>).)
Equals | (Inherited from ModelBase<(Of <(T>)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Inherited from ModelBase<(Of <(T>)>).)
GetPropertiesCollection | (Inherited from ModelBase<(Of <(T>)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadExternal | (Inherited from ModelBase<(Of <(T>)>).)
ToString | (Overrides Object..::.ToString()()().)
Validate | (Inherited from ModelBase<(Of <(T>)>).)
WriteExternal | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WishListProduct Class
InSite.Model Namespace


ToString Method

[image]

.NET Framework Class Library
WishListProduct..::.ToString Method
WishListProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

See Also

WishListProduct Class
InSite.Model Namespace


WishListProduct Properties

[image] [image]

.NET Framework Class Library
WishListProduct Properties
WishListProduct Class See Also Send Feedback

The WishListProduct type exposes the following members.

Properties

Name | Description
ChangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
DataTable | (Inherited from ModelBase<(Of <(T>)>).)
Id | (Inherited from ModelBase<(Of <(T>)>).)
IdString | (Inherited from ModelBase<(Of <(T>)>).)
IsValid | (Inherited from ModelBase<(Of <(T>)>).)
ObjectState | (Inherited from ModelBase<(Of <(T>)>).)
Product |
QtyOrdered |
QueryRecordCount | (Inherited from ModelBase<(Of <(T>)>).)
SearchableProperties | (Inherited from ModelBase<(Of <(T>)>).)
SearchMode | (Inherited from ModelBase<(Of <(T>)>).)
Serializing | (Inherited from ModelBase<(Of <(T>)>).)
ShortDescription |
SOAMessage | (Inherited from ModelBase<(Of <(T>)>).)
UnchangedProperties | (Inherited from ModelBase<(Of <(T>)>).)
ValidationMessage | (Inherited from ModelBase<(Of <(T>)>).)
WishList |
WishListProductId |
WriteableColumns | (Inherited from ModelBase<(Of <(T>)>).)

See Also

WishListProduct Class
InSite.Model Namespace


Product Property

[image]

.NET Framework Class Library
WishListProduct..::.Product Property
WishListProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property Product As Product
C#
public virtual Product Product { get; set; }
Visual C++
public:
virtual property Product^ Product {
    Product^ get ();
    void set (Product^ value);
}
JavaScript
function get_product();
function set_product(value);

See Also

WishListProduct Class
InSite.Model Namespace


QtyOrdered Property

[image]

.NET Framework Class Library
WishListProduct..::.QtyOrdered Property
WishListProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property QtyOrdered As Decimal
C#
public virtual decimal QtyOrdered { get; set; }
Visual C++
public:
virtual property Decimal QtyOrdered {
    Decimal get ();
    void set (Decimal value);
}
JavaScript
function get_qtyOrdered();
function set_qtyOrdered(value);

See Also

WishListProduct Class
InSite.Model Namespace


ShortDescription Property

[image]

.NET Framework Class Library
WishListProduct..::.ShortDescription Property
WishListProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property ShortDescription As String
C#
public virtual string ShortDescription { get; set; }
Visual C++
public:
virtual property String^ ShortDescription {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_shortDescription();
function set_shortDescription(value);

See Also

WishListProduct Class
InSite.Model Namespace


WishList Property

[image]

.NET Framework Class Library
WishListProduct..::.WishList Property
WishListProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WishList As WishList
C#
public virtual WishList WishList { get; set; }
Visual C++
public:
virtual property WishList^ WishList {
    WishList^ get ();
    void set (WishList^ value);
}
JavaScript
function get_wishList();
function set_wishList(value);

See Also

WishListProduct Class
InSite.Model Namespace


WishListProductId Property

[image]

.NET Framework Class Library
WishListProduct..::.WishListProductId Property
WishListProduct Class See Also Send Feedback

Namespace: InSite.Model
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Property WishListProductId As Guid
C#
public virtual Guid WishListProductId { get; set; }
Visual C++
public:
virtual property Guid WishListProductId {
    Guid get ();
    void set (Guid value);
}
JavaScript
function get_wishListProductId();
function set_wishListProductId(value);

See Also

WishListProduct Class
InSite.Model Namespace


InSite.Model.Exceptions Namespace

[image]

.NET Framework Class Library
InSite.Model.Exceptions Namespace
Send Feedback

Classes

Class | Description
InvalidBusinessObjectException |
InvalidTaskTypeException |
ProductPriceNotSetException |
RealTimeCallTimeoutException |


InvalidBusinessObjectException Class

[image]

.NET Framework Class Library
InvalidBusinessObjectException Class
Members See Also Send Feedback

Namespace: InSite.Model.Exceptions
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class InvalidBusinessObjectException _
    Inherits Exception
C#
public class InvalidBusinessObjectException : Exception
Visual C++
public ref class InvalidBusinessObjectException : public Exception
JavaScript
InSite.Model.Exceptions.InvalidBusinessObjectException = function();

Type.createClass(
    'InSite.Model.Exceptions.InvalidBusinessObjectException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Model.Exceptions..::.InvalidBusinessObjectException

See Also

InvalidBusinessObjectException Members
InSite.Model.Exceptions Namespace


InvalidBusinessObjectException Members

[image] [image]

.NET Framework Class Library
InvalidBusinessObjectException Members
InvalidBusinessObjectException Class Constructors Methods Properties See Also Send Feedback

The InvalidBusinessObjectException type exposes the following members.

Constructors

Name | Description
InvalidBusinessObjectException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidBusinessObjectException Class
InSite.Model.Exceptions Namespace


InvalidBusinessObjectException Constructor

[image]

.NET Framework Class Library
InvalidBusinessObjectException Constructor
InvalidBusinessObjectException Class See Also Send Feedback

Namespace: InSite.Model.Exceptions
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    businessObject As IValidatable _
)
C#
public InvalidBusinessObjectException(
    IValidatable businessObject
)
Visual C++
public:
InvalidBusinessObjectException(
    IValidatable^ businessObject
)
JavaScript
InSite.Model.Exceptions.InvalidBusinessObjectException = function(businessObject);

Parameters

businessObject
Type: InSite.Model..::.IValidatable

See Also

InvalidBusinessObjectException Class
InSite.Model.Exceptions Namespace


InvalidBusinessObjectException Methods

[image] [image]

.NET Framework Class Library
InvalidBusinessObjectException Methods
InvalidBusinessObjectException Class See Also Send Feedback

The InvalidBusinessObjectException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidBusinessObjectException Class
InSite.Model.Exceptions Namespace


InvalidBusinessObjectException Properties

[image] [image]

.NET Framework Class Library
InvalidBusinessObjectException Properties
InvalidBusinessObjectException Class See Also Send Feedback

The InvalidBusinessObjectException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidBusinessObjectException Class
InSite.Model.Exceptions Namespace


InvalidTaskTypeException Class

[image]

.NET Framework Class Library
InvalidTaskTypeException Class
Members See Also Send Feedback

Namespace: InSite.Model.Exceptions
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class InvalidTaskTypeException _
    Inherits Exception
C#
public class InvalidTaskTypeException : Exception
Visual C++
public ref class InvalidTaskTypeException : public Exception
JavaScript
InSite.Model.Exceptions.InvalidTaskTypeException = function();

Type.createClass(
    'InSite.Model.Exceptions.InvalidTaskTypeException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Model.Exceptions..::.InvalidTaskTypeException

See Also

InvalidTaskTypeException Members
InSite.Model.Exceptions Namespace


InvalidTaskTypeException Members

[image] [image]

.NET Framework Class Library
InvalidTaskTypeException Members
InvalidTaskTypeException Class Constructors Methods Properties See Also Send Feedback

The InvalidTaskTypeException type exposes the following members.

Constructors

Name | Description
InvalidTaskTypeException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidTaskTypeException Class
InSite.Model.Exceptions Namespace


InvalidTaskTypeException Constructor

[image]

.NET Framework Class Library
InvalidTaskTypeException Constructor
InvalidTaskTypeException Class See Also Send Feedback

Namespace: InSite.Model.Exceptions
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    taskType As String _
)
C#
public InvalidTaskTypeException(
    string taskType
)
Visual C++
public:
InvalidTaskTypeException(
    String^ taskType
)
JavaScript
InSite.Model.Exceptions.InvalidTaskTypeException = function(taskType);

Parameters

taskType
Type: System..::.String

See Also

InvalidTaskTypeException Class
InSite.Model.Exceptions Namespace


InvalidTaskTypeException Methods

[image] [image]

.NET Framework Class Library
InvalidTaskTypeException Methods
InvalidTaskTypeException Class See Also Send Feedback

The InvalidTaskTypeException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidTaskTypeException Class
InSite.Model.Exceptions Namespace


InvalidTaskTypeException Properties

[image] [image]

.NET Framework Class Library
InvalidTaskTypeException Properties
InvalidTaskTypeException Class See Also Send Feedback

The InvalidTaskTypeException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidTaskTypeException Class
InSite.Model.Exceptions Namespace


ProductPriceNotSetException Class

[image]

.NET Framework Class Library
ProductPriceNotSetException Class
Members See Also Send Feedback

Namespace: InSite.Model.Exceptions
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class ProductPriceNotSetException _
    Inherits Exception
C#
public class ProductPriceNotSetException : Exception
Visual C++
public ref class ProductPriceNotSetException : public Exception
JavaScript
InSite.Model.Exceptions.ProductPriceNotSetException = function();

Type.createClass(
    'InSite.Model.Exceptions.ProductPriceNotSetException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Model.Exceptions..::.ProductPriceNotSetException

See Also

ProductPriceNotSetException Members
InSite.Model.Exceptions Namespace


ProductPriceNotSetException Members

[image] [image]

.NET Framework Class Library
ProductPriceNotSetException Members
ProductPriceNotSetException Class Constructors Methods Properties See Also Send Feedback

The ProductPriceNotSetException type exposes the following members.

Constructors

Name | Description
ProductPriceNotSetException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProductPriceNotSetException Class
InSite.Model.Exceptions Namespace


ProductPriceNotSetException Constructor

[image]

.NET Framework Class Library
ProductPriceNotSetException Constructor
ProductPriceNotSetException Class See Also Send Feedback

Namespace: InSite.Model.Exceptions
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    product As Product _
)
C#
public ProductPriceNotSetException(
    Product product
)
Visual C++
public:
ProductPriceNotSetException(
    Product^ product
)
JavaScript
InSite.Model.Exceptions.ProductPriceNotSetException = function(product);

Parameters

product
Type: InSite.Model..::.Product

See Also

ProductPriceNotSetException Class
InSite.Model.Exceptions Namespace


ProductPriceNotSetException Methods

[image] [image]

.NET Framework Class Library
ProductPriceNotSetException Methods
ProductPriceNotSetException Class See Also Send Feedback

The ProductPriceNotSetException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ProductPriceNotSetException Class
InSite.Model.Exceptions Namespace


ProductPriceNotSetException Properties

[image] [image]

.NET Framework Class Library
ProductPriceNotSetException Properties
ProductPriceNotSetException Class See Also Send Feedback

The ProductPriceNotSetException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ProductPriceNotSetException Class
InSite.Model.Exceptions Namespace


RealTimeCallTimeoutException Class

[image]

.NET Framework Class Library
RealTimeCallTimeoutException Class
Members See Also Send Feedback

Namespace: InSite.Model.Exceptions
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Class RealTimeCallTimeoutException _
    Inherits Exception
C#
public class RealTimeCallTimeoutException : Exception
Visual C++
public ref class RealTimeCallTimeoutException : public Exception
JavaScript
InSite.Model.Exceptions.RealTimeCallTimeoutException = function();

Type.createClass(
    'InSite.Model.Exceptions.RealTimeCallTimeoutException',
    Exception);

Inheritance Hierarchy

System..::.Object
System..::.Exception
InSite.Model.Exceptions..::.RealTimeCallTimeoutException

See Also

RealTimeCallTimeoutException Members
InSite.Model.Exceptions Namespace


RealTimeCallTimeoutException Members

[image] [image]

.NET Framework Class Library
RealTimeCallTimeoutException Members
RealTimeCallTimeoutException Class Constructors Methods Properties See Also Send Feedback

The RealTimeCallTimeoutException type exposes the following members.

Constructors

Name | Description
RealTimeCallTimeoutException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RealTimeCallTimeoutException Class
InSite.Model.Exceptions Namespace


RealTimeCallTimeoutException Constructor

[image]

.NET Framework Class Library
RealTimeCallTimeoutException Constructor
RealTimeCallTimeoutException Class See Also Send Feedback

Namespace: InSite.Model.Exceptions
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    call As String _
)
C#
public RealTimeCallTimeoutException(
    string call
)
Visual C++
public:
RealTimeCallTimeoutException(
    String^ call
)
JavaScript
InSite.Model.Exceptions.RealTimeCallTimeoutException = function(call);

Parameters

call
Type: System..::.String

See Also

RealTimeCallTimeoutException Class
InSite.Model.Exceptions Namespace


RealTimeCallTimeoutException Methods

[image] [image]

.NET Framework Class Library
RealTimeCallTimeoutException Methods
RealTimeCallTimeoutException Class See Also Send Feedback

The RealTimeCallTimeoutException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RealTimeCallTimeoutException Class
InSite.Model.Exceptions Namespace


RealTimeCallTimeoutException Properties

[image] [image]

.NET Framework Class Library
RealTimeCallTimeoutException Properties
RealTimeCallTimeoutException Class See Also Send Feedback

The RealTimeCallTimeoutException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RealTimeCallTimeoutException Class
InSite.Model.Exceptions Namespace


InSite.Model.InSiteLicenseService Namespace

[image]

.NET Framework Class Library
InSite.Model.InSiteLicenseService Namespace
Send Feedback

Classes

Class | Description
InSiteLicense |
LicenseServiceClient |
RegistrationInfo |

Interfaces

Interface | Description
ILicenseService |
ILicenseServiceChannel |


ILicenseService Interface

[image]

.NET Framework Class Library
ILicenseService Interface
Members See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")> _
<ServiceContractAttribute(ConfigurationName := "InSiteLicenseService.ILicenseService")> _
Public Interface ILicenseService
C#
[GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
[ServiceContractAttribute(ConfigurationName = "InSiteLicenseService.ILicenseService")]
public interface ILicenseService
Visual C++
[GeneratedCodeAttribute(L"System.ServiceModel", L"3.0.0.0")]
[ServiceContractAttribute(ConfigurationName = L"InSiteLicenseService.ILicenseService")]
public interface class ILicenseService
JavaScript
InSite.Model.InSiteLicenseService.ILicenseService = function();
InSite.Model.InSiteLicenseService.ILicenseService.createInterface('InSite.Model.InSiteLicenseService.ILicenseService');

See Also

ILicenseService Members
InSite.Model.InSiteLicenseService Namespace


ILicenseService Members

[image] [image]

.NET Framework Class Library
ILicenseService Members
ILicenseService Interface Methods See Also Send Feedback

The ILicenseService type exposes the following members.

Methods

Name | Description
GetExistingLicenses |
GetLicense |
Register |

See Also

ILicenseService Interface
InSite.Model.InSiteLicenseService Namespace


ILicenseService Methods

[image] [image]

.NET Framework Class Library
ILicenseService Methods
ILicenseService Interface See Also Send Feedback

The ILicenseService type exposes the following members.

Methods

Name | Description
GetExistingLicenses |
GetLicense |
Register |

See Also

ILicenseService Interface
InSite.Model.InSiteLicenseService Namespace


GetExistingLicenses Method

[image]

.NET Framework Class Library
ILicenseService..::.GetExistingLicenses Method
ILicenseService Interface See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<OperationContractAttribute(Action := "http://tempuri.org/ILicenseService/GetExistingLicenses",  _
    ReplyAction := "http://tempuri.org/ILicenseService/GetExistingLicensesResponse")> _
Function GetExistingLicenses ( _
    password As String, _
    host As String _
) As InSiteLicense()
C#
[OperationContractAttribute(Action = "http://tempuri.org/ILicenseService/GetExistingLicenses",
    ReplyAction = "http://tempuri.org/ILicenseService/GetExistingLicensesResponse")]
InSiteLicense[] GetExistingLicenses(
    string password,
    string host
)
Visual C++
[OperationContractAttribute(Action = L"http://tempuri.org/ILicenseService/GetExistingLicenses",
    ReplyAction = L"http://tempuri.org/ILicenseService/GetExistingLicensesResponse")]
array<InSiteLicense^>^ GetExistingLicenses(
    String^ password,
    String^ host
)
JavaScript
function getExistingLicenses(password, host);

Parameters

password
Type: System..::.String
host
Type: System..::.String

See Also

ILicenseService Interface
InSite.Model.InSiteLicenseService Namespace


GetLicense Method

[image]

.NET Framework Class Library
ILicenseService..::.GetLicense Method
ILicenseService Interface See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<OperationContractAttribute(Action := "http://tempuri.org/ILicenseService/GetLicense",  _
    ReplyAction := "http://tempuri.org/ILicenseService/GetLicenseResponse")> _
Function GetLicense ( _
    password As String, _
    host As String, _
    module As String _
) As InSiteLicense
C#
[OperationContractAttribute(Action = "http://tempuri.org/ILicenseService/GetLicense",
    ReplyAction = "http://tempuri.org/ILicenseService/GetLicenseResponse")]
InSiteLicense GetLicense(
    string password,
    string host,
    string module
)
Visual C++
[OperationContractAttribute(Action = L"http://tempuri.org/ILicenseService/GetLicense",
    ReplyAction = L"http://tempuri.org/ILicenseService/GetLicenseResponse")]
InSiteLicense^ GetLicense(
    String^ password,
    String^ host,
    String^ module
)
JavaScript
function getLicense(password, host, module);

Parameters

password
Type: System..::.String
host
Type: System..::.String
module
Type: System..::.String

See Also

ILicenseService Interface
InSite.Model.InSiteLicenseService Namespace


Register Method

[image]

.NET Framework Class Library
ILicenseService..::.Register Method
ILicenseService Interface See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<OperationContractAttribute(Action := "http://tempuri.org/ILicenseService/Register",  _
    ReplyAction := "http://tempuri.org/ILicenseService/RegisterResponse")> _
Sub Register ( _
    password As String, _
    host As String, _
    info As RegistrationInfo _
)
C#
[OperationContractAttribute(Action = "http://tempuri.org/ILicenseService/Register",
    ReplyAction = "http://tempuri.org/ILicenseService/RegisterResponse")]
void Register(
    string password,
    string host,
    RegistrationInfo info
)
Visual C++
[OperationContractAttribute(Action = L"http://tempuri.org/ILicenseService/Register",
    ReplyAction = L"http://tempuri.org/ILicenseService/RegisterResponse")]
void Register(
    String^ password,
    String^ host,
    RegistrationInfo^ info
)
JavaScript
function register(password, host, info);

Parameters

password
Type: System..::.String
host
Type: System..::.String
info
Type: InSite.Model.InSiteLicenseService..::.RegistrationInfo

See Also

ILicenseService Interface
InSite.Model.InSiteLicenseService Namespace


ILicenseServiceChannel Interface

[image]

.NET Framework Class Library
ILicenseServiceChannel Interface
Members See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")> _
Public Interface ILicenseServiceChannel _
    Implements ILicenseService, IClientChannel, IContextChannel, IChannel,  _
    ICommunicationObject, IExtensibleObject(Of IContextChannel), IDisposable
C#
[GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
public interface ILicenseServiceChannel : ILicenseService,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel>,
    IDisposable
Visual C++
[GeneratedCodeAttribute(L"System.ServiceModel", L"3.0.0.0")]
public interface class ILicenseServiceChannel : ILicenseService,
    IClientChannel, IContextChannel, IChannel, ICommunicationObject, IExtensibleObject<IContextChannel^>,
    IDisposable
JavaScript
InSite.Model.InSiteLicenseService.ILicenseServiceChannel = function();
InSite.Model.InSiteLicenseService.ILicenseServiceChannel.createInterface('InSite.Model.InSiteLicenseService.ILicenseServiceChannel');

See Also

ILicenseServiceChannel Members
InSite.Model.InSiteLicenseService Namespace


ILicenseServiceChannel Members

[image] [image]

.NET Framework Class Library
ILicenseServiceChannel Members
ILicenseServiceChannel Interface Methods Properties Events See Also Send Feedback

The ILicenseServiceChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginOpen | Overloaded.
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndOpen | (Inherited from ICommunicationObject.)
GetExistingLicenses | (Inherited from ILicenseService.)
GetLicense | (Inherited from ILicenseService.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.
Register | (Inherited from ILicenseService.)

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

ILicenseServiceChannel Interface
InSite.Model.InSiteLicenseService Namespace


ILicenseServiceChannel Methods

[image] [image]

.NET Framework Class Library
ILicenseServiceChannel Methods
ILicenseServiceChannel Interface See Also Send Feedback

The ILicenseServiceChannel type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ICommunicationObject.)
BeginClose | Overloaded.
BeginDisplayInitializationUI | (Inherited from IClientChannel.)
BeginOpen | Overloaded.
Close | Overloaded.
DisplayInitializationUI | (Inherited from IClientChannel.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
EndClose | (Inherited from ICommunicationObject.)
EndDisplayInitializationUI | (Inherited from IClientChannel.)
EndOpen | (Inherited from ICommunicationObject.)
GetExistingLicenses | (Inherited from ILicenseService.)
GetLicense | (Inherited from ILicenseService.)
GetProperty<(Of <(T>)>) | (Inherited from IChannel.)
Open | Overloaded.
Register | (Inherited from ILicenseService.)

See Also

ILicenseServiceChannel Interface
InSite.Model.InSiteLicenseService Namespace


BeginClose Method

[image] [image]

.NET Framework Class Library
ILicenseServiceChannel..::.BeginClose Method
ILicenseServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginClose(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginClose(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

ILicenseServiceChannel Interface
ILicenseServiceChannel Members
InSite.Model.InSiteLicenseService Namespace


BeginOpen Method

[image] [image]

.NET Framework Class Library
ILicenseServiceChannel..::.BeginOpen Method
ILicenseServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
BeginOpen(AsyncCallback, Object) | (Inherited from ICommunicationObject.)
BeginOpen(TimeSpan, AsyncCallback, Object) | (Inherited from ICommunicationObject.)

See Also

ILicenseServiceChannel Interface
ILicenseServiceChannel Members
InSite.Model.InSiteLicenseService Namespace


Close Method

[image] [image]

.NET Framework Class Library
ILicenseServiceChannel..::.Close Method
ILicenseServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | (Inherited from ICommunicationObject.)
Close(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

ILicenseServiceChannel Interface
ILicenseServiceChannel Members
InSite.Model.InSiteLicenseService Namespace


Open Method

[image] [image]

.NET Framework Class Library
ILicenseServiceChannel..::.Open Method
ILicenseServiceChannel Interface See Also Send Feedback

Overload List

Name | Description
Open()()() | (Inherited from ICommunicationObject.)
Open(TimeSpan) | (Inherited from ICommunicationObject.)

See Also

ILicenseServiceChannel Interface
ILicenseServiceChannel Members
InSite.Model.InSiteLicenseService Namespace


ILicenseServiceChannel Properties

[image] [image]

.NET Framework Class Library
ILicenseServiceChannel Properties
ILicenseServiceChannel Interface See Also Send Feedback

The ILicenseServiceChannel type exposes the following members.

Properties

Name | Description
AllowInitializationUI | (Inherited from IClientChannel.)
AllowOutputBatching | (Inherited from IContextChannel.)
DidInteractiveInitialization | (Inherited from IClientChannel.)
Extensions | (Inherited from IExtensibleObject <(Of <( IContextChannel >)>).)
InputSession | (Inherited from IContextChannel.)
LocalAddress | (Inherited from IContextChannel.)
OperationTimeout | (Inherited from IContextChannel.)
OutputSession | (Inherited from IContextChannel.)
RemoteAddress | (Inherited from IContextChannel.)
SessionId | (Inherited from IContextChannel.)
State | (Inherited from ICommunicationObject.)
Via | (Inherited from IClientChannel.)

See Also

ILicenseServiceChannel Interface
InSite.Model.InSiteLicenseService Namespace


ILicenseServiceChannel Events

[image] [image]

.NET Framework Class Library
ILicenseServiceChannel Events
ILicenseServiceChannel Interface See Also Send Feedback

The ILicenseServiceChannel type exposes the following members.

Events

Name | Description
Closed | (Inherited from ICommunicationObject.)
Closing | (Inherited from ICommunicationObject.)
Faulted | (Inherited from ICommunicationObject.)
Opened | (Inherited from ICommunicationObject.)
Opening | (Inherited from ICommunicationObject.)
UnknownMessageReceived | (Inherited from IClientChannel.)

See Also

ILicenseServiceChannel Interface
InSite.Model.InSiteLicenseService Namespace


InSiteLicense Class

[image]

.NET Framework Class Library
InSiteLicense Class
Members See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "3.0.0.0")> _
<DataContractAttribute(Name := "InSiteLicense", Namespace := "http://schemas.datacontract.org/2004/07/InSite.LicenseService")> _
Public Class InSiteLicense _
    Implements IExtensibleDataObject, INotifyPropertyChanged
C#
[SerializableAttribute]
[GeneratedCodeAttribute("System.Runtime.Serialization", "3.0.0.0")]
[DataContractAttribute(Name = "InSiteLicense", Namespace = "http://schemas.datacontract.org/2004/07/InSite.LicenseService")]
public class InSiteLicense : IExtensibleDataObject,
    INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[GeneratedCodeAttribute(L"System.Runtime.Serialization", L"3.0.0.0")]
[DataContractAttribute(Name = L"InSiteLicense", Namespace = L"http://schemas.datacontract.org/2004/07/InSite.LicenseService")]
public ref class InSiteLicense : IExtensibleDataObject,
    INotifyPropertyChanged
JavaScript
InSite.Model.InSiteLicenseService.InSiteLicense = function();

Type.createClass(
    'InSite.Model.InSiteLicenseService.InSiteLicense',
    null,
    IExtensibleDataObject,
    INotifyPropertyChanged);

Inheritance Hierarchy

System..::.Object
InSite.Model.InSiteLicenseService..::.InSiteLicense

See Also

InSiteLicense Members
InSite.Model.InSiteLicenseService Namespace


InSiteLicense Members

[image] [image]

.NET Framework Class Library
InSiteLicense Members
InSiteLicense Class Constructors Methods Properties Events See Also Send Feedback

The InSiteLicense type exposes the following members.

Constructors

Name | Description
InSiteLicense |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
ExpirationSpan |
ExtensionData |
Module |
Status |

Events

Name | Description
PropertyChanged |

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


InSiteLicense Constructor

[image]

.NET Framework Class Library
InSiteLicense Constructor
InSiteLicense Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public InSiteLicense()
Visual C++
public:
InSiteLicense()
JavaScript
InSite.Model.InSiteLicenseService.InSiteLicense = function();

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


InSiteLicense Methods

[image] [image]

.NET Framework Class Library
InSiteLicense Methods
InSiteLicense Class See Also Send Feedback

The InSiteLicense type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
InSiteLicense..::.RaisePropertyChanged Method
InSiteLicense Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


InSiteLicense Properties

[image] [image]

.NET Framework Class Library
InSiteLicense Properties
InSiteLicense Class See Also Send Feedback

The InSiteLicense type exposes the following members.

Properties

Name | Description
Count |
ExpirationSpan |
ExtensionData |
Module |
Status |

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


Count Property

[image]

.NET Framework Class Library
InSiteLicense..::.Count Property
InSiteLicense Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Count As Integer
C#
[DataMemberAttribute]
public int Count { get; set; }
Visual C++
[DataMemberAttribute]
public:
property int Count {
    int get ();
    void set (int value);
}
JavaScript
function get_count();
function set_count(value);

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


ExpirationSpan Property

[image]

.NET Framework Class Library
InSiteLicense..::.ExpirationSpan Property
InSiteLicense Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property ExpirationSpan As TimeSpan
C#
[DataMemberAttribute]
public TimeSpan ExpirationSpan { get; set; }
Visual C++
[DataMemberAttribute]
public:
property TimeSpan ExpirationSpan {
    TimeSpan get ();
    void set (TimeSpan value);
}
JavaScript
function get_expirationSpan();
function set_expirationSpan(value);

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


ExtensionData Property

[image]

.NET Framework Class Library
InSiteLicense..::.ExtensionData Property
InSiteLicense Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtensionData As ExtensionDataObject
C#
public ExtensionDataObject ExtensionData { get; set; }
Visual C++
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
JavaScript
function get_extensionData();
function set_extensionData(value);

Implements

IExtensibleDataObject..::.ExtensionData

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


Module Property

[image]

.NET Framework Class Library
InSiteLicense..::.Module Property
InSiteLicense Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Module As String
C#
[DataMemberAttribute]
public string Module { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ Module {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_module();
function set_module(value);

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


Status Property

[image]

.NET Framework Class Library
InSiteLicense..::.Status Property
InSiteLicense Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Status As Short
C#
[DataMemberAttribute]
public short Status { get; set; }
Visual C++
[DataMemberAttribute]
public:
property short Status {
    short get ();
    void set (short value);
}
JavaScript
function get_status();
function set_status(value);

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


InSiteLicense Events

[image] [image]

.NET Framework Class Library
InSiteLicense Events
InSiteLicense Class See Also Send Feedback

The InSiteLicense type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
InSiteLicense..::.PropertyChanged Event
InSiteLicense Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

InSiteLicense Class
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Class

[image]

.NET Framework Class Library
LicenseServiceClient Class
Members See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")> _
Public Class LicenseServiceClient _
    Inherits ClientBase(Of ILicenseService) _
    Implements ILicenseService
C#
[GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
public class LicenseServiceClient : ClientBase<ILicenseService>,
    ILicenseService
Visual C++
[GeneratedCodeAttribute(L"System.ServiceModel", L"3.0.0.0")]
public ref class LicenseServiceClient : public ClientBase<ILicenseService^>,
    ILicenseService
JavaScript
InSite.Model.InSiteLicenseService.LicenseServiceClient = function();

Type.createClass(
    'InSite.Model.InSiteLicenseService.LicenseServiceClient',
    ClientBase`1,
    InSite.Model.InSiteLicenseService.ILicenseService);

Inheritance Hierarchy

System..::.Object
System.ServiceModel..::.ClientBase <(Of <( ILicenseService >)>)
InSite.Model.InSiteLicenseService..::.LicenseServiceClient

See Also

LicenseServiceClient Members
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Members

[image] [image]

.NET Framework Class Library
LicenseServiceClient Members
LicenseServiceClient Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The LicenseServiceClient type exposes the following members.

Constructors

Name | Description
LicenseServiceClient | Overloaded.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
Close | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
CreateChannel | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
DisplayInitializationUI | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
GetExistingLicenses |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLicense |
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeAsync | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
Register |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ClientCredentials | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
Endpoint | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
State | (Inherited from ClientBase <(Of <( ILicenseService >)>).)

Events

Name Description

Explicit Interface Implementations

Name | Description
BeginClose | Overloaded.
BeginOpen | Overloaded.
ICommunicationObject..::.Close | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Closed | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Closing | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
IDisposable..::.Dispose | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.EndClose | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.EndOpen | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Faulted | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Open | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Opened | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Opening | (Inherited from ClientBase <(Of <( ILicenseService >)>).)

See Also

LicenseServiceClient Class
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Constructor

[image] [image]

.NET Framework Class Library
LicenseServiceClient Constructor
LicenseServiceClient Class See Also Send Feedback

Overload List

Name | Description
LicenseServiceClient()()() |
LicenseServiceClient(String) |
LicenseServiceClient(Binding, EndpointAddress) |
LicenseServiceClient(String, EndpointAddress) |
LicenseServiceClient(String, String) |

See Also

LicenseServiceClient Class
LicenseServiceClient Members
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Constructor

[image]

.NET Framework Class Library
LicenseServiceClient Constructor
LicenseServiceClient Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public LicenseServiceClient()
Visual C++
public:
LicenseServiceClient()
JavaScript
InSite.Model.InSiteLicenseService.LicenseServiceClient = function();

See Also

LicenseServiceClient Class
LicenseServiceClient Overload
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Constructor (String)

[image]

.NET Framework Class Library
LicenseServiceClient Constructor (String)
LicenseServiceClient Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String _
)
C#
public LicenseServiceClient(
    string endpointConfigurationName
)
Visual C++
public:
LicenseServiceClient(
    String^ endpointConfigurationName
)
JavaScript
InSite.Model.InSiteLicenseService.LicenseServiceClient = function(endpointConfigurationName);

Parameters

endpointConfigurationName
Type: System..::.String

See Also

LicenseServiceClient Class
LicenseServiceClient Overload
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Constructor (Binding, EndpointAddress)

[image]

.NET Framework Class Library
LicenseServiceClient Constructor (Binding, EndpointAddress)
LicenseServiceClient Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    binding As Binding, _
    remoteAddress As EndpointAddress _
)
C#
public LicenseServiceClient(
    Binding binding,
    EndpointAddress remoteAddress
)
Visual C++
public:
LicenseServiceClient(
    Binding^ binding,
    EndpointAddress^ remoteAddress
)
JavaScript
InSite.Model.InSiteLicenseService.LicenseServiceClient = function(binding, remoteAddress);

Parameters

binding
Type: System.ServiceModel.Channels..::.Binding
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

LicenseServiceClient Class
LicenseServiceClient Overload
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Constructor (String, EndpointAddress)

[image]

.NET Framework Class Library
LicenseServiceClient Constructor (String, EndpointAddress)
LicenseServiceClient Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As EndpointAddress _
)
C#
public LicenseServiceClient(
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)
Visual C++
public:
LicenseServiceClient(
    String^ endpointConfigurationName,
    EndpointAddress^ remoteAddress
)
JavaScript
InSite.Model.InSiteLicenseService.LicenseServiceClient = function(endpointConfigurationName, remoteAddress);

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System.ServiceModel..::.EndpointAddress

See Also

LicenseServiceClient Class
LicenseServiceClient Overload
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Constructor (String, String)

[image]

.NET Framework Class Library
LicenseServiceClient Constructor (String, String)
LicenseServiceClient Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As String _
)
C#
public LicenseServiceClient(
    string endpointConfigurationName,
    string remoteAddress
)
Visual C++
public:
LicenseServiceClient(
    String^ endpointConfigurationName,
    String^ remoteAddress
)
JavaScript
InSite.Model.InSiteLicenseService.LicenseServiceClient = function(endpointConfigurationName, remoteAddress);

Parameters

endpointConfigurationName
Type: System..::.String
remoteAddress
Type: System..::.String

See Also

LicenseServiceClient Class
LicenseServiceClient Overload
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Methods

[image] [image]

.NET Framework Class Library
LicenseServiceClient Methods
LicenseServiceClient Class See Also Send Feedback

The LicenseServiceClient type exposes the following members.

Methods

Name | Description
Abort | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
Close | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
CreateChannel | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
DisplayInitializationUI | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDefaultValueForInitialization<(Of <(T>)>) | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
GetExistingLicenses |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLicense |
GetType | Gets the Type of the current instance. (Inherited from Object.)
InvokeAsync | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
Register |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

Name | Description
BeginClose | Overloaded.
BeginOpen | Overloaded.
ICommunicationObject..::.Close | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
IDisposable..::.Dispose | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.EndClose | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.EndOpen | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Open | (Inherited from ClientBase <(Of <( ILicenseService >)>).)

See Also

LicenseServiceClient Class
InSite.Model.InSiteLicenseService Namespace


BeginClose Method

[image] [image]

.NET Framework Class Library
LicenseServiceClient..::.BeginClose Method
LicenseServiceClient Class See Also Send Feedback

Overload List

Name | Description
ICommunicationObject..::.BeginClose(AsyncCallback, Object) | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.BeginClose(TimeSpan, AsyncCallback, Object) | (Inherited from ClientBase <(Of <( ILicenseService >)>).)

See Also

LicenseServiceClient Class
LicenseServiceClient Members
InSite.Model.InSiteLicenseService Namespace


BeginOpen Method

[image] [image]

.NET Framework Class Library
LicenseServiceClient..::.BeginOpen Method
LicenseServiceClient Class See Also Send Feedback

Overload List

Name | Description
ICommunicationObject..::.BeginOpen(AsyncCallback, Object) | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.BeginOpen(TimeSpan, AsyncCallback, Object) | (Inherited from ClientBase <(Of <( ILicenseService >)>).)

See Also

LicenseServiceClient Class
LicenseServiceClient Members
InSite.Model.InSiteLicenseService Namespace


GetExistingLicenses Method

[image]

.NET Framework Class Library
LicenseServiceClient..::.GetExistingLicenses Method
LicenseServiceClient Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function GetExistingLicenses ( _
    password As String, _
    host As String _
) As InSiteLicense()
C#
public InSiteLicense[] GetExistingLicenses(
    string password,
    string host
)
Visual C++
public:
virtual array<InSiteLicense^>^ GetExistingLicenses(
    String^ password,
    String^ host
) sealed
JavaScript
function getExistingLicenses(password, host);

Parameters

password
Type: System..::.String
host
Type: System..::.String

Implements

ILicenseService..::.GetExistingLicenses(String, String)

See Also

LicenseServiceClient Class
InSite.Model.InSiteLicenseService Namespace


GetLicense Method

[image]

.NET Framework Class Library
LicenseServiceClient..::.GetLicense Method
LicenseServiceClient Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Function GetLicense ( _
    password As String, _
    host As String, _
    module As String _
) As InSiteLicense
C#
public InSiteLicense GetLicense(
    string password,
    string host,
    string module
)
Visual C++
public:
virtual InSiteLicense^ GetLicense(
    String^ password,
    String^ host,
    String^ module
) sealed
JavaScript
function getLicense(password, host, module);

Parameters

password
Type: System..::.String
host
Type: System..::.String
module
Type: System..::.String

Implements

ILicenseService..::.GetLicense(String, String, String)

See Also

LicenseServiceClient Class
InSite.Model.InSiteLicenseService Namespace


Register Method

[image]

.NET Framework Class Library
LicenseServiceClient..::.Register Method
LicenseServiceClient Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub Register ( _
    password As String, _
    host As String, _
    info As RegistrationInfo _
)
C#
public void Register(
    string password,
    string host,
    RegistrationInfo info
)
Visual C++
public:
virtual void Register(
    String^ password,
    String^ host,
    RegistrationInfo^ info
) sealed
JavaScript
function register(password, host, info);

Parameters

password
Type: System..::.String
host
Type: System..::.String
info
Type: InSite.Model.InSiteLicenseService..::.RegistrationInfo

Implements

ILicenseService..::.Register(String, String, RegistrationInfo)

See Also

LicenseServiceClient Class
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Properties

[image] [image]

.NET Framework Class Library
LicenseServiceClient Properties
LicenseServiceClient Class See Also Send Feedback

The LicenseServiceClient type exposes the following members.

Properties

Name | Description
Channel | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ChannelFactory | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ClientCredentials | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
Endpoint | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
InnerChannel | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
State | (Inherited from ClientBase <(Of <( ILicenseService >)>).)

See Also

LicenseServiceClient Class
InSite.Model.InSiteLicenseService Namespace


LicenseServiceClient Events

[image] [image]

.NET Framework Class Library
LicenseServiceClient Events
LicenseServiceClient Class See Also Send Feedback

Events

Name Description

Explicit Interface Implementations

Name | Description
ICommunicationObject..::.Closed | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Closing | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Faulted | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Opened | (Inherited from ClientBase <(Of <( ILicenseService >)>).)
ICommunicationObject..::.Opening | (Inherited from ClientBase <(Of <( ILicenseService >)>).)

See Also

LicenseServiceClient Class
InSite.Model.InSiteLicenseService Namespace


RegistrationInfo Class

[image]

.NET Framework Class Library
RegistrationInfo Class
Members See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
<DataContractAttribute(Name := "RegistrationInfo", Namespace := "http://schemas.datacontract.org/2004/07/InSite.LicenseService")> _
<GeneratedCodeAttribute("System.Runtime.Serialization", "3.0.0.0")> _
Public Class RegistrationInfo _
    Implements IExtensibleDataObject, INotifyPropertyChanged
C#
[SerializableAttribute]
[DataContractAttribute(Name = "RegistrationInfo", Namespace = "http://schemas.datacontract.org/2004/07/InSite.LicenseService")]
[GeneratedCodeAttribute("System.Runtime.Serialization", "3.0.0.0")]
public class RegistrationInfo : IExtensibleDataObject,
    INotifyPropertyChanged
Visual C++
[SerializableAttribute]
[DataContractAttribute(Name = L"RegistrationInfo", Namespace = L"http://schemas.datacontract.org/2004/07/InSite.LicenseService")]
[GeneratedCodeAttribute(L"System.Runtime.Serialization", L"3.0.0.0")]
public ref class RegistrationInfo : IExtensibleDataObject,
    INotifyPropertyChanged
JavaScript
InSite.Model.InSiteLicenseService.RegistrationInfo = function();

Type.createClass(
    'InSite.Model.InSiteLicenseService.RegistrationInfo',
    null,
    IExtensibleDataObject,
    INotifyPropertyChanged);

Inheritance Hierarchy

System..::.Object
InSite.Model.InSiteLicenseService..::.RegistrationInfo

See Also

RegistrationInfo Members
InSite.Model.InSiteLicenseService Namespace


RegistrationInfo Members

[image] [image]

.NET Framework Class Library
RegistrationInfo Members
RegistrationInfo Class Constructors Methods Properties Events See Also Send Feedback

The RegistrationInfo type exposes the following members.

Constructors

Name | Description
RegistrationInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address |
City |
CompanyName |
ContactEmail |
ContactName |
ContactPhone |
Country |
CustomerId |
ExtensionData |
State |
Zip |

Events

Name | Description
PropertyChanged |

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


RegistrationInfo Constructor

[image]

.NET Framework Class Library
RegistrationInfo Constructor
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public RegistrationInfo()
Visual C++
public:
RegistrationInfo()
JavaScript
InSite.Model.InSiteLicenseService.RegistrationInfo = function();

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


RegistrationInfo Methods

[image] [image]

.NET Framework Class Library
RegistrationInfo Methods
RegistrationInfo Class See Also Send Feedback

The RegistrationInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaisePropertyChanged |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


RaisePropertyChanged Method

[image]

.NET Framework Class Library
RegistrationInfo..::.RaisePropertyChanged Method
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Protected Sub RaisePropertyChanged ( _
    propertyName As String _
)
C#
protected void RaisePropertyChanged(
    string propertyName
)
Visual C++
protected:
void RaisePropertyChanged(
    String^ propertyName
)
JavaScript
function raisePropertyChanged(propertyName);

Parameters

propertyName
Type: System..::.String

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


RegistrationInfo Properties

[image] [image]

.NET Framework Class Library
RegistrationInfo Properties
RegistrationInfo Class See Also Send Feedback

The RegistrationInfo type exposes the following members.

Properties

Name | Description
Address |
City |
CompanyName |
ContactEmail |
ContactName |
ContactPhone |
Country |
CustomerId |
ExtensionData |
State |
Zip |

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


Address Property

[image]

.NET Framework Class Library
RegistrationInfo..::.Address Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Address As String
C#
[DataMemberAttribute]
public string Address { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_address();
function set_address(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


City Property

[image]

.NET Framework Class Library
RegistrationInfo..::.City Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property City As String
C#
[DataMemberAttribute]
public string City { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_city();
function set_city(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


CompanyName Property

[image]

.NET Framework Class Library
RegistrationInfo..::.CompanyName Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property CompanyName As String
C#
[DataMemberAttribute]
public string CompanyName { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_companyName();
function set_companyName(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


ContactEmail Property

[image]

.NET Framework Class Library
RegistrationInfo..::.ContactEmail Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property ContactEmail As String
C#
[DataMemberAttribute]
public string ContactEmail { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ ContactEmail {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contactEmail();
function set_contactEmail(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


ContactName Property

[image]

.NET Framework Class Library
RegistrationInfo..::.ContactName Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property ContactName As String
C#
[DataMemberAttribute]
public string ContactName { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ ContactName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contactName();
function set_contactName(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


ContactPhone Property

[image]

.NET Framework Class Library
RegistrationInfo..::.ContactPhone Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property ContactPhone As String
C#
[DataMemberAttribute]
public string ContactPhone { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ ContactPhone {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_contactPhone();
function set_contactPhone(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


Country Property

[image]

.NET Framework Class Library
RegistrationInfo..::.Country Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Country As String
C#
[DataMemberAttribute]
public string Country { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_country();
function set_country(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


CustomerId Property

[image]

.NET Framework Class Library
RegistrationInfo..::.CustomerId Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property CustomerId As String
C#
[DataMemberAttribute]
public string CustomerId { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ CustomerId {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_customerId();
function set_customerId(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


ExtensionData Property

[image]

.NET Framework Class Library
RegistrationInfo..::.ExtensionData Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Property ExtensionData As ExtensionDataObject
C#
public ExtensionDataObject ExtensionData { get; set; }
Visual C++
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
JavaScript
function get_extensionData();
function set_extensionData(value);

Implements

IExtensibleDataObject..::.ExtensionData

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


State Property

[image]

.NET Framework Class Library
RegistrationInfo..::.State Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property State As String
C#
[DataMemberAttribute]
public string State { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_state();
function set_state(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


Zip Property

[image]

.NET Framework Class Library
RegistrationInfo..::.Zip Property
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
<DataMemberAttribute> _
Public Property Zip As String
C#
[DataMemberAttribute]
public string Zip { get; set; }
Visual C++
[DataMemberAttribute]
public:
property String^ Zip {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_zip();
function set_zip(value);

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


RegistrationInfo Events

[image] [image]

.NET Framework Class Library
RegistrationInfo Events
RegistrationInfo Class See Also Send Feedback

The RegistrationInfo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
RegistrationInfo..::.PropertyChanged Event
RegistrationInfo Class See Also Send Feedback

Namespace: InSite.Model.InSiteLicenseService
Assembly: InSite.Model (in InSite.Model.dll)

Syntax

Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
C#
public event PropertyChangedEventHandler PropertyChanged
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
JavaScript
function add_propertyChanged(value);
function remove_propertyChanged(value);

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

RegistrationInfo Class
InSite.Model.InSiteLicenseService Namespace


NHibernate.Helper Namespace

[image]

.NET Framework Class Library
NHibernate.Helper Namespace
Send Feedback

Classes

Class | Description
Db | Provides access to a single NHibernate session on a per request basis.
Module | HttpModule to automatically close a session at the end of a request
ValidationInterceptor |


Db Class

[image]

.NET Framework Class Library
Db Class
Members See Also Send Feedback

Provides access to a single NHibernate session on a per request basis.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Db
C#
public sealed class Db
Visual C++
public ref class Db sealed
JavaScript
NHibernate.Helper.Db = function();

Type.createClass(
    'NHibernate.Helper.Db');

Remarks

NHibernate requires mapping files to be loaded. These can be stored as embedded resources in the assemblies alongside the classes that they are for or in separate XML files. As the number of assemblies containing mapping resources may change and these have to be referenced by the NHibernate config before the SessionFactory is created, the configuration is stored in a separate config file to allow new references to be added. This would also enable the use of external mapping files if required. The name of the NHibernate configuration file is set in the appSettings section with the name "nhibernate.config". If not specified the the default value of ~/nhibernate.config is used. Note that the default config name is not used because the .xml extension is public and could be downloaded from a website whereas access to .config files is automatically restricted by ASP.NET.

Inheritance Hierarchy

System..::.Object
NHibernate.Helper..::.Db

See Also

Db Members
NHibernate.Helper Namespace


Db Members

[image] [image]

.NET Framework Class Library
Db Members
Db Class Methods Properties See Also Send Feedback

The Db type exposes the following members.

Methods

Name | Description
BeginTransaction | Start a database transaction and place in to HttpContext.Current
CloseSession | Closes any open NHibernate session if one has been used in this request. This is called from the EndRequest event.
CommitTransaction | Commits a database transaction from HttpContext.Current and remove from HttpContext.Current
CreateDatabase | Creates the specified database.
Delete | Save object item using NHibernate.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get | Gets the specified object.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Loads the specified object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RollbackTransaction | Rolls Back a database transaction from HttpContext.Current and remove from HttpContext.Current
Save | Save object item using NHibernate.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Configuration |
ConnectionString | Used by SqlExecuteNonQuery when we do logs. Without this we have to share the existing connection which causes issues when have a transaction going on OrderPayment pages
Session | Creates a new NHibernate Session object if one does not already exist. When running in the context of a web application the session object is stored in HttpContext items and has 'per request' lifetime. For client apps and testing with NUnit a normal singleton is used.
SessionFactory | Returns the NHibernate SessionFactory object.

See Also

Db Class
NHibernate.Helper Namespace


Db Methods

[image] [image]

.NET Framework Class Library
Db Methods
Db Class See Also Send Feedback

The Db type exposes the following members.

Methods

Name | Description
BeginTransaction | Start a database transaction and place in to HttpContext.Current
CloseSession | Closes any open NHibernate session if one has been used in this request. This is called from the EndRequest event.
CommitTransaction | Commits a database transaction from HttpContext.Current and remove from HttpContext.Current
CreateDatabase | Creates the specified database.
Delete | Save object item using NHibernate.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Get | Gets the specified object.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Load | Loads the specified object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RollbackTransaction | Rolls Back a database transaction from HttpContext.Current and remove from HttpContext.Current
Save | Save object item using NHibernate.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Db Class
NHibernate.Helper Namespace


BeginTransaction Method

[image]

.NET Framework Class Library
Db..::.BeginTransaction Method
Db Class See Also Send Feedback

Start a database transaction and place in to HttpContext.Current

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub BeginTransaction
C#
public static void BeginTransaction()
Visual C++
public:
static void BeginTransaction()
JavaScript
NHibernate.Helper.Db.beginTransaction = function();

See Also

Db Class
NHibernate.Helper Namespace


CloseSession Method

[image]

.NET Framework Class Library
Db..::.CloseSession Method
Db Class See Also Send Feedback

Closes any open NHibernate session if one has been used in this request.
This is called from the EndRequest event.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CloseSession
C#
public static void CloseSession()
Visual C++
public:
static void CloseSession()
JavaScript
NHibernate.Helper.Db.closeSession = function();

See Also

Db Class
NHibernate.Helper Namespace


CommitTransaction Method

[image]

.NET Framework Class Library
Db..::.CommitTransaction Method
Db Class See Also Send Feedback

Commits a database transaction from HttpContext.Current and remove from HttpContext.Current

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CommitTransaction
C#
public static void CommitTransaction()
Visual C++
public:
static void CommitTransaction()
JavaScript
NHibernate.Helper.Db.commitTransaction = function();

See Also

Db Class
NHibernate.Helper Namespace


CreateDatabase Method

[image]

.NET Framework Class Library
Db..::.CreateDatabase Method
Db Class See Also Send Feedback

Creates the specified database.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub CreateDatabase
C#
public static void CreateDatabase()
Visual C++
public:
static void CreateDatabase()
JavaScript
NHibernate.Helper.Db.createDatabase = function();

See Also

Db Class
NHibernate.Helper Namespace


Delete Method

[image]

.NET Framework Class Library
Db..::.Delete Method
Db Class See Also Send Feedback

Save object item using NHibernate.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Delete ( _
    item As Object _
)
C#
public static void Delete(
    Object item
)
Visual C++
public:
static void Delete(
    Object^ item
)
JavaScript
NHibernate.Helper.Db.delete = function(item);

Parameters

item
Type: System..::.Object
Object to delete

See Also

Db Class
NHibernate.Helper Namespace


Get Method

[image]

.NET Framework Class Library
Db..::.Get Method
Db Class See Also Send Feedback

Gets the specified object.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Get ( _
    type As Type, _
    id As Object _
) As Object
C#
public static Object Get(
    Type type,
    Object id
)
Visual C++
public:
static Object^ Get(
    Type^ type,
    Object^ id
)
JavaScript
NHibernate.Helper.Db.get = function(type, id);

Parameters

type
Type: System..::.Type
Type.
id
Type: System..::.Object
Id.

See Also

Db Class
NHibernate.Helper Namespace


Load Method

[image]

.NET Framework Class Library
Db..::.Load Method
Db Class See Also Send Feedback

Loads the specified object.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Load ( _
    type As Type, _
    id As Object _
)
C#
public static void Load(
    Type type,
    Object id
)
Visual C++
public:
static void Load(
    Type^ type,
    Object^ id
)
JavaScript
NHibernate.Helper.Db.load = function(type, id);

Parameters

type
Type: System..::.Type
Type.
id
Type: System..::.Object
Id.

See Also

Db Class
NHibernate.Helper Namespace


RollbackTransaction Method

[image]

.NET Framework Class Library
Db..::.RollbackTransaction Method
Db Class See Also Send Feedback

Rolls Back a database transaction from HttpContext.Current and remove from HttpContext.Current

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub RollbackTransaction
C#
public static void RollbackTransaction()
Visual C++
public:
static void RollbackTransaction()
JavaScript
NHibernate.Helper.Db.rollbackTransaction = function();

See Also

Db Class
NHibernate.Helper Namespace


Save Method

[image]

.NET Framework Class Library
Db..::.Save Method
Db Class See Also Send Feedback

Save object item using NHibernate.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Save ( _
    item As Object _
)
C#
public static void Save(
    Object item
)
Visual C++
public:
static void Save(
    Object^ item
)
JavaScript
NHibernate.Helper.Db.save = function(item);

Parameters

item
Type: System..::.Object
Object to save

See Also

Db Class
NHibernate.Helper Namespace


Db Properties

[image] [image]

.NET Framework Class Library
Db Properties
Db Class See Also Send Feedback

The Db type exposes the following members.

Properties

Name | Description
Configuration |
ConnectionString | Used by SqlExecuteNonQuery when we do logs. Without this we have to share the existing connection which causes issues when have a transaction going on OrderPayment pages
Session | Creates a new NHibernate Session object if one does not already exist. When running in the context of a web application the session object is stored in HttpContext items and has 'per request' lifetime. For client apps and testing with NUnit a normal singleton is used.
SessionFactory | Returns the NHibernate SessionFactory object.

See Also

Db Class
NHibernate.Helper Namespace


Configuration Property

[image]

.NET Framework Class Library
Db..::.Configuration Property
Db Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Configuration As Configuration
C#
public static Configuration Configuration { get; }
Visual C++
public:
static property Configuration^ Configuration {
    Configuration^ get ();
}
JavaScript
NHibernate.Helper.Db.get_configuration = function();

See Also

Db Class
NHibernate.Helper Namespace


ConnectionString Property

[image]

.NET Framework Class Library
Db..::.ConnectionString Property
Db Class See Also Send Feedback

Used by SqlExecuteNonQuery when we do logs. Without this we have to share the existing connection which causes issues when have a transaction going on OrderPayment pages

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ConnectionString As String
C#
public static string ConnectionString { get; }
Visual C++
public:
static property String^ ConnectionString {
    String^ get ();
}
JavaScript
NHibernate.Helper.Db.get_connectionString = function();

See Also

Db Class
NHibernate.Helper Namespace


Session Property

[image]

.NET Framework Class Library
Db..::.Session Property
Db Class See Also Send Feedback

Creates a new NHibernate Session object if one does not already exist. When running in the context of a web application the session object is stored in HttpContext items and has 'per request' lifetime. For client apps and testing with NUnit a normal singleton is used.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Session As ISession
C#
public static ISession Session { get; }
Visual C++
public:
static property ISession^ Session {
    ISession^ get ();
}
JavaScript
NHibernate.Helper.Db.get_session = function();

Return Value

NHibernate Session object.

See Also

Db Class
NHibernate.Helper Namespace


SessionFactory Property

[image]

.NET Framework Class Library
Db..::.SessionFactory Property
Db Class See Also Send Feedback

Returns the NHibernate SessionFactory object.

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property SessionFactory As ISessionFactory
C#
public static ISessionFactory SessionFactory { get; }
Visual C++
public:
static property ISessionFactory^ SessionFactory {
    ISessionFactory^ get ();
}
JavaScript
NHibernate.Helper.Db.get_sessionFactory = function();

Return Value

NHibernate SessionFactory object.

See Also

Db Class
NHibernate.Helper Namespace


Module Class

[image]

.NET Framework Class Library
Module Class
Members See Also Send Feedback

HttpModule to automatically close a session at the end of a request

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Module _
    Implements IHttpModule
C#
public sealed class Module : IHttpModule
Visual C++
public ref class Module sealed : IHttpModule
JavaScript
NHibernate.Helper.Module = function();

Type.createClass(
    'NHibernate.Helper.Module',
    null,
    IHttpModule);

Inheritance Hierarchy

System..::.Object
NHibernate.Helper..::.Module

See Also

Module Members
NHibernate.Helper Namespace


Module Members

[image] [image]

.NET Framework Class Library
Module Members
Module Class Constructors Methods See Also Send Feedback

The Module type exposes the following members.

Constructors

Name | Description
Module |

Methods

Name | Description
BeginRequest |
Dispose |
EndRequest |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Module Class
NHibernate.Helper Namespace


Module Constructor

[image]

.NET Framework Class Library
Module Constructor
Module Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public Module()
Visual C++
public:
Module()
JavaScript
NHibernate.Helper.Module = function();

See Also

Module Class
NHibernate.Helper Namespace


Module Methods

[image] [image]

.NET Framework Class Library
Module Methods
Module Class See Also Send Feedback

The Module type exposes the following members.

Methods

Name | Description
BeginRequest |
Dispose |
EndRequest |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Module Class
NHibernate.Helper Namespace


BeginRequest Method

[image]

.NET Framework Class Library
Module..::.BeginRequest Method
Module Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub BeginRequest ( _
    sender As Object, _
    e As EventArgs _
)
C#
public void BeginRequest(
    Object sender,
    EventArgs e
)
Visual C++
public:
void BeginRequest(
    Object^ sender,
    EventArgs^ e
)
JavaScript
function beginRequest(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Module Class
NHibernate.Helper Namespace


Dispose Method

[image]

.NET Framework Class Library
Module..::.Dispose Method
Module Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IHttpModule..::.Dispose()()()

See Also

Module Class
NHibernate.Helper Namespace


EndRequest Method

[image]

.NET Framework Class Library
Module..::.EndRequest Method
Module Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub EndRequest ( _
    sender As Object, _
    e As EventArgs _
)
C#
public void EndRequest(
    Object sender,
    EventArgs e
)
Visual C++
public:
void EndRequest(
    Object^ sender,
    EventArgs^ e
)
JavaScript
function endRequest(sender, e);

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Module Class
NHibernate.Helper Namespace


Init Method

[image]

.NET Framework Class Library
Module..::.Init Method
Module Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Init ( _
    context As HttpApplication _
)
C#
public void Init(
    HttpApplication context
)
Visual C++
public:
virtual void Init(
    HttpApplication^ context
) sealed
JavaScript
function init(context);

Parameters

context
Type: System.Web..::.HttpApplication

Implements

IHttpModule..::.Init(HttpApplication)

See Also

Module Class
NHibernate.Helper Namespace


ValidationInterceptor Class

[image]

.NET Framework Class Library
ValidationInterceptor Class
Members See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ValidationInterceptor _
    Implements IInterceptor
C#
[SerializableAttribute]
public class ValidationInterceptor : IInterceptor
Visual C++
[SerializableAttribute]
public ref class ValidationInterceptor : IInterceptor
JavaScript
NHibernate.Helper.ValidationInterceptor = function();

Type.createClass(
    'NHibernate.Helper.ValidationInterceptor',
    null,
    NHibernate.IInterceptor);

Inheritance Hierarchy

System..::.Object
NHibernate.Helper..::.ValidationInterceptor

See Also

ValidationInterceptor Members
NHibernate.Helper Namespace


ValidationInterceptor Members

[image] [image]

.NET Framework Class Library
ValidationInterceptor Members
ValidationInterceptor Class Constructors Methods See Also Send Feedback

The ValidationInterceptor type exposes the following members.

Constructors

Name | Description
ValidationInterceptor |

Methods

Name | Description
AfterTransactionBegin |
AfterTransactionCompletion |
BeforeTransactionCompletion |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindDirty |
GetEntity |
GetEntityName |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Instantiate | Overloaded.
IsTransient |
IsUnsaved |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionRecreate |
OnCollectionRemove |
OnCollectionUpdate |
OnDelete |
OnFlushDirty |
OnLoad |
OnPrepareStatement |
OnSave |
PostFlush |
PreFlush |
SetSession |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


ValidationInterceptor Constructor

[image]

.NET Framework Class Library
ValidationInterceptor Constructor
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public ValidationInterceptor()
Visual C++
public:
ValidationInterceptor()
JavaScript
NHibernate.Helper.ValidationInterceptor = function();

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


ValidationInterceptor Methods

[image] [image]

.NET Framework Class Library
ValidationInterceptor Methods
ValidationInterceptor Class See Also Send Feedback

The ValidationInterceptor type exposes the following members.

Methods

Name | Description
AfterTransactionBegin |
AfterTransactionCompletion |
BeforeTransactionCompletion |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindDirty |
GetEntity |
GetEntityName |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Instantiate | Overloaded.
IsTransient |
IsUnsaved |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionRecreate |
OnCollectionRemove |
OnCollectionUpdate |
OnDelete |
OnFlushDirty |
OnLoad |
OnPrepareStatement |
OnSave |
PostFlush |
PreFlush |
SetSession |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


AfterTransactionBegin Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.AfterTransactionBegin Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub AfterTransactionBegin ( _
    tx As ITransaction _
)
C#
public void AfterTransactionBegin(
    ITransaction tx
)
Visual C++
public:
virtual void AfterTransactionBegin(
    ITransaction^ tx
) sealed
JavaScript
function afterTransactionBegin(tx);

Parameters

tx
Type: ITransaction

Implements

IInterceptorAfterTransactionBegin(ITransaction)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


AfterTransactionCompletion Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.AfterTransactionCompletion Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub AfterTransactionCompletion ( _
    tx As ITransaction _
)
C#
public void AfterTransactionCompletion(
    ITransaction tx
)
Visual C++
public:
virtual void AfterTransactionCompletion(
    ITransaction^ tx
) sealed
JavaScript
function afterTransactionCompletion(tx);

Parameters

tx
Type: ITransaction

Implements

IInterceptorAfterTransactionCompletion(ITransaction)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


BeforeTransactionCompletion Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.BeforeTransactionCompletion Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub BeforeTransactionCompletion ( _
    tx As ITransaction _
)
C#
public void BeforeTransactionCompletion(
    ITransaction tx
)
Visual C++
public:
virtual void BeforeTransactionCompletion(
    ITransaction^ tx
) sealed
JavaScript
function beforeTransactionCompletion(tx);

Parameters

tx
Type: ITransaction

Implements

IInterceptorBeforeTransactionCompletion(ITransaction)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


FindDirty Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.FindDirty Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function FindDirty ( _
    entity As Object, _
    id As Object, _
    currentState As Object(), _
    previousState As Object(), _
    propertyNames As String(), _
    types As IType() _
) As Integer()
C#
public int[] FindDirty(
    Object entity,
    Object id,
    Object[] currentState,
    Object[] previousState,
    string[] propertyNames,
    IType[] types
)
Visual C++
public:
virtual array<int>^ FindDirty(
    Object^ entity,
    Object^ id,
    array<Object^>^ currentState,
    array<Object^>^ previousState,
    array<String^>^ propertyNames,
    array<IType^>^ types
) sealed
JavaScript
function findDirty(entity, id, currentState, previousState, propertyNames, types);

Parameters

entity
Type: System..::.Object
id
Type: System..::.Object
currentState
Type: array< System..::.Object >[]()[]
previousState
Type: array< System..::.Object >[]()[]
propertyNames
Type: array< System..::.String >[]()[]
types
Type: array< IType >[]()[]

Implements

IInterceptorFindDirty(Object, Object, array<Object>[]()[], array<Object>[]()[], array<String>[]()[], array<IType>[]()[])

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


GetEntity Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.GetEntity Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEntity ( _
    entityName As String, _
    id As Object _
) As Object
C#
public Object GetEntity(
    string entityName,
    Object id
)
Visual C++
public:
virtual Object^ GetEntity(
    String^ entityName,
    Object^ id
) sealed
JavaScript
function getEntity(entityName, id);

Parameters

entityName
Type: System..::.String
id
Type: System..::.Object

Implements

IInterceptorGetEntity(String, Object)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


GetEntityName Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.GetEntityName Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetEntityName ( _
    entity As Object _
) As String
C#
public string GetEntityName(
    Object entity
)
Visual C++
public:
virtual String^ GetEntityName(
    Object^ entity
) sealed
JavaScript
function getEntityName(entity);

Parameters

entity
Type: System..::.Object

Implements

IInterceptorGetEntityName(Object)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


Instantiate Method

[image] [image]

.NET Framework Class Library
ValidationInterceptor..::.Instantiate Method
ValidationInterceptor Class See Also Send Feedback

Overload List

Name | Description
Instantiate(Type, Object) |
Instantiate(String, EntityMode, Object) |

See Also

ValidationInterceptor Class
ValidationInterceptor Members
NHibernate.Helper Namespace


Instantiate Method (Type, Object)

[image]

.NET Framework Class Library
ValidationInterceptor..::.Instantiate Method (Type, Object)
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function Instantiate ( _
    type As Type, _
    id As Object _
) As Object
C#
public Object Instantiate(
    Type type,
    Object id
)
Visual C++
public:
Object^ Instantiate(
    Type^ type,
    Object^ id
)
JavaScript
function instantiate(type, id);

Parameters

type
Type: System..::.Type
id
Type: System..::.Object

See Also

ValidationInterceptor Class
Instantiate Overload
NHibernate.Helper Namespace


Instantiate Method (String, , Object)

[image]

.NET Framework Class Library
ValidationInterceptor..::.Instantiate Method (String, , Object)
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function Instantiate ( _
    entityName As String, _
    entityMode As EntityMode, _
    id As Object _
) As Object
C#
public Object Instantiate(
    string entityName,
    EntityMode entityMode,
    Object id
)
Visual C++
public:
virtual Object^ Instantiate(
    String^ entityName,
    EntityMode entityMode,
    Object^ id
) sealed
JavaScript
function instantiate(entityName, entityMode, id);

Parameters

entityName
Type: System..::.String
entityMode
Type: EntityMode
id
Type: System..::.Object

Implements

IInterceptorInstantiate(String, EntityMode, Object)

See Also

ValidationInterceptor Class
Instantiate Overload
NHibernate.Helper Namespace


IsTransient Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.IsTransient Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function IsTransient ( _
    entity As Object _
) As Nullable(Of Boolean)
C#
public Nullable<bool> IsTransient(
    Object entity
)
Visual C++
public:
virtual Nullable<bool> IsTransient(
    Object^ entity
) sealed
JavaScript
function isTransient(entity);

Parameters

entity
Type: System..::.Object

Implements

IInterceptorIsTransient(Object)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


IsUnsaved Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.IsUnsaved Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function IsUnsaved ( _
    entity As Object _
) As Object
C#
public Object IsUnsaved(
    Object entity
)
Visual C++
public:
Object^ IsUnsaved(
    Object^ entity
)
JavaScript
function isUnsaved(entity);

Parameters

entity
Type: System..::.Object

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


OnCollectionRecreate Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.OnCollectionRecreate Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub OnCollectionRecreate ( _
    collection As Object, _
    key As Object _
)
C#
public void OnCollectionRecreate(
    Object collection,
    Object key
)
Visual C++
public:
virtual void OnCollectionRecreate(
    Object^ collection,
    Object^ key
) sealed
JavaScript
function onCollectionRecreate(collection, key);

Parameters

collection
Type: System..::.Object
key
Type: System..::.Object

Implements

IInterceptorOnCollectionRecreate(Object, Object)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


OnCollectionRemove Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.OnCollectionRemove Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub OnCollectionRemove ( _
    collection As Object, _
    key As Object _
)
C#
public void OnCollectionRemove(
    Object collection,
    Object key
)
Visual C++
public:
virtual void OnCollectionRemove(
    Object^ collection,
    Object^ key
) sealed
JavaScript
function onCollectionRemove(collection, key);

Parameters

collection
Type: System..::.Object
key
Type: System..::.Object

Implements

IInterceptorOnCollectionRemove(Object, Object)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


OnCollectionUpdate Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.OnCollectionUpdate Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub OnCollectionUpdate ( _
    collection As Object, _
    key As Object _
)
C#
public void OnCollectionUpdate(
    Object collection,
    Object key
)
Visual C++
public:
virtual void OnCollectionUpdate(
    Object^ collection,
    Object^ key
) sealed
JavaScript
function onCollectionUpdate(collection, key);

Parameters

collection
Type: System..::.Object
key
Type: System..::.Object

Implements

IInterceptorOnCollectionUpdate(Object, Object)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


OnDelete Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.OnDelete Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub OnDelete ( _
    entity As Object, _
    id As Object, _
    state As Object(), _
    propertyNames As String(), _
    types As IType() _
)
C#
public void OnDelete(
    Object entity,
    Object id,
    Object[] state,
    string[] propertyNames,
    IType[] types
)
Visual C++
public:
virtual void OnDelete(
    Object^ entity,
    Object^ id,
    array<Object^>^ state,
    array<String^>^ propertyNames,
    array<IType^>^ types
) sealed
JavaScript
function onDelete(entity, id, state, propertyNames, types);

Parameters

entity
Type: System..::.Object
id
Type: System..::.Object
state
Type: array< System..::.Object >[]()[]
propertyNames
Type: array< System..::.String >[]()[]
types
Type: array< IType >[]()[]

Implements

IInterceptorOnDelete(Object, Object, array<Object>[]()[], array<String>[]()[], array<IType>[]()[])

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


OnFlushDirty Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.OnFlushDirty Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function OnFlushDirty ( _
    entity As Object, _
    id As Object, _
    currentState As Object(), _
    previousState As Object(), _
    propertyNames As String(), _
    types As IType() _
) As Boolean
C#
public bool OnFlushDirty(
    Object entity,
    Object id,
    Object[] currentState,
    Object[] previousState,
    string[] propertyNames,
    IType[] types
)
Visual C++
public:
virtual bool OnFlushDirty(
    Object^ entity,
    Object^ id,
    array<Object^>^ currentState,
    array<Object^>^ previousState,
    array<String^>^ propertyNames,
    array<IType^>^ types
) sealed
JavaScript
function onFlushDirty(entity, id, currentState, previousState, propertyNames, types);

Parameters

entity
Type: System..::.Object
id
Type: System..::.Object
currentState
Type: array< System..::.Object >[]()[]
previousState
Type: array< System..::.Object >[]()[]
propertyNames
Type: array< System..::.String >[]()[]
types
Type: array< IType >[]()[]

Implements

IInterceptorOnFlushDirty(Object, Object, array<Object>[]()[], array<Object>[]()[], array<String>[]()[], array<IType>[]()[])

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


OnLoad Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.OnLoad Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function OnLoad ( _
    entity As Object, _
    id As Object, _
    state As Object(), _
    propertyNames As String(), _
    types As IType() _
) As Boolean
C#
public bool OnLoad(
    Object entity,
    Object id,
    Object[] state,
    string[] propertyNames,
    IType[] types
)
Visual C++
public:
virtual bool OnLoad(
    Object^ entity,
    Object^ id,
    array<Object^>^ state,
    array<String^>^ propertyNames,
    array<IType^>^ types
) sealed
JavaScript
function onLoad(entity, id, state, propertyNames, types);

Parameters

entity
Type: System..::.Object
id
Type: System..::.Object
state
Type: array< System..::.Object >[]()[]
propertyNames
Type: array< System..::.String >[]()[]
types
Type: array< IType >[]()[]

Implements

IInterceptorOnLoad(Object, Object, array<Object>[]()[], array<String>[]()[], array<IType>[]()[])

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


OnPrepareStatement Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.OnPrepareStatement Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function OnPrepareStatement ( _
    sql As SqlString _
) As SqlString
C#
public SqlString OnPrepareStatement(
    SqlString sql
)
Visual C++
public:
virtual SqlString^ OnPrepareStatement(
    SqlString^ sql
) sealed
JavaScript
function onPrepareStatement(sql);

Parameters

sql
Type: SqlString

Implements

IInterceptorOnPrepareStatement(SqlString)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


OnSave Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.OnSave Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function OnSave ( _
    entity As Object, _
    id As Object, _
    state As Object(), _
    propertyNames As String(), _
    types As IType() _
) As Boolean
C#
public bool OnSave(
    Object entity,
    Object id,
    Object[] state,
    string[] propertyNames,
    IType[] types
)
Visual C++
public:
virtual bool OnSave(
    Object^ entity,
    Object^ id,
    array<Object^>^ state,
    array<String^>^ propertyNames,
    array<IType^>^ types
) sealed
JavaScript
function onSave(entity, id, state, propertyNames, types);

Parameters

entity
Type: System..::.Object
id
Type: System..::.Object
state
Type: array< System..::.Object >[]()[]
propertyNames
Type: array< System..::.String >[]()[]
types
Type: array< IType >[]()[]

Implements

IInterceptorOnSave(Object, Object, array<Object>[]()[], array<String>[]()[], array<IType>[]()[])

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


PostFlush Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.PostFlush Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub PostFlush ( _
    entities As ICollection _
)
C#
public void PostFlush(
    ICollection entities
)
Visual C++
public:
virtual void PostFlush(
    ICollection^ entities
) sealed
JavaScript
function postFlush(entities);

Parameters

entities
Type: System.Collections..::.ICollection

Implements

IInterceptorPostFlush(ICollection)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


PreFlush Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.PreFlush Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub PreFlush ( _
    entities As ICollection _
)
C#
public void PreFlush(
    ICollection entities
)
Visual C++
public:
virtual void PreFlush(
    ICollection^ entities
) sealed
JavaScript
function preFlush(entities);

Parameters

entities
Type: System.Collections..::.ICollection

Implements

IInterceptorPreFlush(ICollection)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


SetSession Method

[image]

.NET Framework Class Library
ValidationInterceptor..::.SetSession Method
ValidationInterceptor Class See Also Send Feedback

Namespace: NHibernate.Helper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetSession ( _
    session As ISession _
)
C#
public void SetSession(
    ISession session
)
Visual C++
public:
virtual void SetSession(
    ISession^ session
) sealed
JavaScript
function setSession(session);

Parameters

session
Type: ISession

Implements

IInterceptorSetSession(ISession)

See Also

ValidationInterceptor Class
NHibernate.Helper Namespace


NHibernateHelper Namespace

[image]

.NET Framework Class Library
NHibernateHelper Namespace
Send Feedback

Classes

Class | Description
DataController_NHibernate |


DataController_NHibernate Class

[image]

.NET Framework Class Library
DataController_NHibernate Class
Members See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DataController_NHibernate _
    Implements IDataController
C#
[SerializableAttribute]
public class DataController_NHibernate : IDataController
Visual C++
[SerializableAttribute]
public ref class DataController_NHibernate : IDataController
JavaScript
NHibernateHelper.DataController_NHibernate = function();

Type.createClass(
    'NHibernateHelper.DataController_NHibernate',
    null,
    InSite.Model.IDataController);

Inheritance Hierarchy

System..::.Object
NHibernateHelper..::.DataController_NHibernate

See Also

DataController_NHibernate Members
NHibernateHelper Namespace


DataController_NHibernate Members

[image] [image]

.NET Framework Class Library
DataController_NHibernate Members
DataController_NHibernate Class Constructors Methods Properties See Also Send Feedback

The DataController_NHibernate type exposes the following members.

Constructors

Name | Description
DataController_NHibernate |

Methods

Name | Description
BeginTransaction |
CommitTransaction |
Delete<(Of <(T>)>) |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evict<(Of <(T>)>) |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FlushSession |
Get | Overloaded.
GetCount | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetList | Overloaded.
GetSqlDataAdapter |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues |
Initialize | Overloaded.
Insert<(Of <(T>)>) |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
New<(Of <(T>)>) |
Refresh<(Of <(T>)>) |
RollBackTransaction |
SqlExecuteNonQuery |
SqlExecuteReader |
SqlExecuteScalar |
SqlExecuteStoredProcedure |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update<(Of <(T>)>) |

Properties

Name | Description
FlushMode |

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


DataController_NHibernate Constructor

[image]

.NET Framework Class Library
DataController_NHibernate Constructor
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DataController_NHibernate()
Visual C++
public:
DataController_NHibernate()
JavaScript
NHibernateHelper.DataController_NHibernate = function();

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


DataController_NHibernate Methods

[image] [image]

.NET Framework Class Library
DataController_NHibernate Methods
DataController_NHibernate Class See Also Send Feedback

The DataController_NHibernate type exposes the following members.

Methods

Name | Description
BeginTransaction |
CommitTransaction |
Delete<(Of <(T>)>) |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Evict<(Of <(T>)>) |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FlushSession |
Get | Overloaded.
GetCount | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetList | Overloaded.
GetSqlDataAdapter |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValues |
Initialize | Overloaded.
Insert<(Of <(T>)>) |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
New<(Of <(T>)>) |
Refresh<(Of <(T>)>) |
RollBackTransaction |
SqlExecuteNonQuery |
SqlExecuteReader |
SqlExecuteScalar |
SqlExecuteStoredProcedure |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Update<(Of <(T>)>) |

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


BeginTransaction Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.BeginTransaction Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub BeginTransaction
C#
public void BeginTransaction()
Visual C++
public:
virtual void BeginTransaction() sealed
JavaScript
function beginTransaction();

Implements

IDataController..::.BeginTransaction()()()

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


CommitTransaction Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.CommitTransaction Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub CommitTransaction
C#
public void CommitTransaction()
Visual C++
public:
virtual void CommitTransaction() sealed
JavaScript
function commitTransaction();

Implements

IDataController..::.CommitTransaction()()()

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


Delete(T) Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.Delete<(Of <(T>)>) Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Delete(Of T) ( _
    deleted As T _
)
C#
public void Delete<T>(
    T deleted
)
Visual C++
public:
generic<typename T>
virtual void Delete(
    T deleted
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

deleted
Type: T

Type Parameters

T

Implements

IDataController..::.Delete<(Of <(T>)>)(T)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


Evict(T) Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.Evict<(Of <(T>)>) Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Evict(Of T) ( _
    evicted As T _
)
C#
public void Evict<T>(
    T evicted
)
Visual C++
public:
generic<typename T>
virtual void Evict(
    T evicted
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

evicted
Type: T

Type Parameters

T

Implements

IDataController..::.Evict<(Of <(T>)>)(T)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


FlushSession Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.FlushSession Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub FlushSession
C#
public void FlushSession()
Visual C++
public:
virtual void FlushSession() sealed
JavaScript
function flushSession();

Implements

IDataController..::.FlushSession()()()

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


Get Method

[image] [image]

.NET Framework Class Library
DataController_NHibernate..::.Get Method
DataController_NHibernate Class See Also Send Feedback

Overload List

Name | Description
Get<(Of <(T>)>)(Guid) |
Get<(Of <(T>)>)(String) |
Get<(Of <(T>)>)(String, String) |

See Also

DataController_NHibernate Class
DataController_NHibernate Members
NHibernateHelper Namespace


Get(T) Method (Guid)

[image]

.NET Framework Class Library
DataController_NHibernate..::.Get<(Of <(T>)>) Method (Guid)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function Get(Of T) ( _
    id As Guid _
) As T
C#
public T Get<T>(
    Guid id
)
Visual C++
public:
generic<typename T>
virtual T Get(
    Guid id
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

id
Type: System..::.Guid

Type Parameters

T

See Also

DataController_NHibernate Class
Get Overload
NHibernateHelper Namespace


Get(T) Method (String)

[image]

.NET Framework Class Library
DataController_NHibernate..::.Get<(Of <(T>)>) Method (String)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function Get(Of T) ( _
    id As String _
) As T
C#
public T Get<T>(
    string id
)
Visual C++
public:
generic<typename T>
virtual T Get(
    String^ id
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

id
Type: System..::.String

Type Parameters

T

See Also

DataController_NHibernate Class
Get Overload
NHibernateHelper Namespace


Get(T) Method (String, String)

[image]

.NET Framework Class Library
DataController_NHibernate..::.Get<(Of <(T>)>) Method (String, String)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function Get(Of T) ( _
    propertyName As String, _
    propertyValue As String _
) As T
C#
public T Get<T>(
    string propertyName,
    string propertyValue
)
Visual C++
public:
generic<typename T>
virtual T Get(
    String^ propertyName,
    String^ propertyValue
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: System..::.String
propertyValue
Type: System..::.String

Type Parameters

T

See Also

DataController_NHibernate Class
Get Overload
NHibernateHelper Namespace


GetCount Method

[image] [image]

.NET Framework Class Library
DataController_NHibernate..::.GetCount Method
DataController_NHibernate Class See Also Send Feedback

Overload List

Name | Description
GetCount<(Of <(T>)>)()()() |
GetCount<(Of <(T>)>)(String, Hashtable, NameValueCollection) |

See Also

DataController_NHibernate Class
DataController_NHibernate Members
NHibernateHelper Namespace


GetCount(T) Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetCount<(Of <(T>)>) Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCount(Of T) As Integer
C#
public int GetCount<T>()
Visual C++
public:
generic<typename T>
virtual int GetCount() sealed
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

Implements

IDataController..::.GetCount<(Of <(T>)>)()()()

See Also

DataController_NHibernate Class
GetCount Overload
NHibernateHelper Namespace


GetCount(T) Method (String, Hashtable, NameValueCollection)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetCount<(Of <(T>)>) Method (String, Hashtable, NameValueCollection)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetCount(Of T) ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection _
) As Integer
C#
public int GetCount<T>(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions
)
Visual C++
public:
generic<typename T>
virtual int GetCount(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection

Type Parameters

T

Implements

IDataController..::.GetCount<(Of <(T>)>)(String, Hashtable, NameValueCollection)

See Also

DataController_NHibernate Class
GetCount Overload
NHibernateHelper Namespace


GetList Method

[image] [image]

.NET Framework Class Library
DataController_NHibernate..::.GetList Method
DataController_NHibernate Class See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(T>)>)()()() |
GetList<(Of <(T>)>)(String) |
GetList<(Of <(T>)>)(T, String) |
GetList<(Of <(T>)>)(String, Hashtable, NameValueCollection) |
GetList<(Of <(T>)>)(String, Int32, Int32) |
GetList<(Of <(T>)>)(String, String, String) |
GetList<(Of <(T>)>)(T, String, Int32, Int32) |
GetList<(Of <(T>)>)(String, Hashtable, NameValueCollection, Int32, Int32) |
GetList<(Of <(T>)>)(String, String, String, Int32, Int32) |

See Also

DataController_NHibernate Class
DataController_NHibernate Members
NHibernateHelper Namespace


GetList(T) Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) As IList(Of T)
C#
public IList<T> GetList<T>()
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList() sealed
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetList(T) Method (String)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method (String)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) ( _
    sort As String _
) As IList(Of T)
C#
public IList<T> GetList<T>(
    string sort
)
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList(
    String^ sort
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

sort
Type: System..::.String

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetList(T) Method (T, String)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method (T, String)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) ( _
    query As T, _
    sort As String _
) As IList(Of T)
C#
public IList<T> GetList<T>(
    T query,
    string sort
)
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList(
    T query,
    String^ sort
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: T
sort
Type: System..::.String

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetList(T) Method (String, Hashtable, NameValueCollection)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method (String, Hashtable, NameValueCollection)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection _
) As IList(Of T)
C#
public IList<T> GetList<T>(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions
)
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetList(T) Method (String, Int32, Int32)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method (String, Int32, Int32)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) ( _
    sort As String, _
    start As Integer, _
    size As Integer _
) As IList(Of T)
C#
public IList<T> GetList<T>(
    string sort,
    int start,
    int size
)
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList(
    String^ sort,
    int start,
    int size
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

sort
Type: System..::.String
start
Type: System..::.Int32
size
Type: System..::.Int32

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetList(T) Method (String, String, String)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method (String, String, String)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) ( _
    propertyName As String, _
    propertyValue As String, _
    sort As String _
) As IList(Of T)
C#
public IList<T> GetList<T>(
    string propertyName,
    string propertyValue,
    string sort
)
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList(
    String^ propertyName,
    String^ propertyValue,
    String^ sort
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: System..::.String
propertyValue
Type: System..::.String
sort
Type: System..::.String

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetList(T) Method (T, String, Int32, Int32)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method (T, String, Int32, Int32)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) ( _
    query As T, _
    sort As String, _
    start As Integer, _
    size As Integer _
) As IList(Of T)
C#
public IList<T> GetList<T>(
    T query,
    string sort,
    int start,
    int size
)
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList(
    T query,
    String^ sort,
    int start,
    int size
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: T
sort
Type: System..::.String
start
Type: System..::.Int32
size
Type: System..::.Int32

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetList(T) Method (String, Hashtable, NameValueCollection, Int32, Int32)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method (String, Hashtable, NameValueCollection, Int32, Int32)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) ( _
    query As String, _
    parameters As Hashtable, _
    queryOptions As NameValueCollection, _
    start As Integer, _
    size As Integer _
) As IList(Of T)
C#
public IList<T> GetList<T>(
    string query,
    Hashtable parameters,
    NameValueCollection queryOptions,
    int start,
    int size
)
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList(
    String^ query,
    Hashtable^ parameters,
    NameValueCollection^ queryOptions,
    int start,
    int size
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

query
Type: System..::.String
parameters
Type: System.Collections..::.Hashtable
queryOptions
Type: System.Collections.Specialized..::.NameValueCollection
start
Type: System..::.Int32
size
Type: System..::.Int32

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetList(T) Method (String, String, String, Int32, Int32)

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetList<(Of <(T>)>) Method (String, String, String, Int32, Int32)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetList(Of T) ( _
    propertyName As String, _
    propertyValue As String, _
    sort As String, _
    start As Integer, _
    size As Integer _
) As IList(Of T)
C#
public IList<T> GetList<T>(
    string propertyName,
    string propertyValue,
    string sort,
    int start,
    int size
)
Visual C++
public:
generic<typename T>
virtual IList<T>^ GetList(
    String^ propertyName,
    String^ propertyValue,
    String^ sort,
    int start,
    int size
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

propertyName
Type: System..::.String
propertyValue
Type: System..::.String
sort
Type: System..::.String
start
Type: System..::.Int32
size
Type: System..::.Int32

Type Parameters

T

See Also

DataController_NHibernate Class
GetList Overload
NHibernateHelper Namespace


GetSqlDataAdapter Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetSqlDataAdapter Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetSqlDataAdapter ( _
    sqlQuery As String _
) As SqlDataAdapter
C#
public SqlDataAdapter GetSqlDataAdapter(
    string sqlQuery
)
Visual C++
public:
virtual SqlDataAdapter^ GetSqlDataAdapter(
    String^ sqlQuery
) sealed
JavaScript
function getSqlDataAdapter(sqlQuery);

Parameters

sqlQuery
Type: System..::.String

Implements

IDataController..::.GetSqlDataAdapter(String)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


GetValues Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.GetValues Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function GetValues ( _
    query As String _
) As IList(Of String)
C#
public IList<string> GetValues(
    string query
)
Visual C++
public:
virtual IList<String^>^ GetValues(
    String^ query
) sealed
JavaScript
function getValues(query);

Parameters

query
Type: System..::.String

Implements

IDataController..::.GetValues(String)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


Initialize Method

[image] [image]

.NET Framework Class Library
DataController_NHibernate..::.Initialize Method
DataController_NHibernate Class See Also Send Feedback

Overload List

Name | Description
Initialize<(Of <(T>)>)(IList<(Of <(T>)>)) |
Initialize(Object) |

See Also

DataController_NHibernate Class
DataController_NHibernate Members
NHibernateHelper Namespace


Initialize(T) Method (IList(T))

[image]

.NET Framework Class Library
DataController_NHibernate..::.Initialize<(Of <(T>)>) Method (IList<(Of <(T>)>))
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Initialize(Of T) ( _
    initializeList As IList(Of T) _
)
C#
public void Initialize<T>(
    IList<T> initializeList
)
Visual C++
public:
generic<typename T>
virtual void Initialize(
    IList<T>^ initializeList
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

initializeList
Type: System.Collections.Generic..::.IList <(Of <(T>)>)

Type Parameters

T

Implements

IDataController..::.Initialize<(Of <(T>)>)(IList<(Of <(T>)>))

See Also

DataController_NHibernate Class
Initialize Overload
NHibernateHelper Namespace


Initialize Method (Object)

[image]

.NET Framework Class Library
DataController_NHibernate..::.Initialize Method (Object)
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Initialize ( _
    proxy As Object _
)
C#
public void Initialize(
    Object proxy
)
Visual C++
public:
virtual void Initialize(
    Object^ proxy
) sealed
JavaScript
function initialize(proxy);

Parameters

proxy
Type: System..::.Object

Implements

IDataController..::.Initialize(Object)

See Also

DataController_NHibernate Class
Initialize Overload
NHibernateHelper Namespace


Insert(T) Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.Insert<(Of <(T>)>) Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Insert(Of T) ( _
    inserted As T _
)
C#
public void Insert<T>(
    T inserted
)
Visual C++
public:
generic<typename T>
virtual void Insert(
    T inserted
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

inserted
Type: T

Type Parameters

T

Implements

IDataController..::.Insert<(Of <(T>)>)(T)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


New(T) Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.New<(Of <(T>)>) Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function New(Of T As {Class, New}) As T
C#
public T New<T>()
where T : class, new()
Visual C++
public:
generic<typename T>
where T : ref class, gcnew()
virtual T New() sealed
JavaScript
JavaScript does not support generic types or methods.

Type Parameters

T

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


Refresh(T) Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.Refresh<(Of <(T>)>) Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Refresh(Of T) ( _
    refreshed As T _
)
C#
public void Refresh<T>(
    T refreshed
)
Visual C++
public:
generic<typename T>
virtual void Refresh(
    T refreshed
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

refreshed
Type: T

Type Parameters

T

Implements

IDataController..::.Refresh<(Of <(T>)>)(T)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


RollBackTransaction Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.RollBackTransaction Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub RollBackTransaction
C#
public void RollBackTransaction()
Visual C++
public:
virtual void RollBackTransaction() sealed
JavaScript
function rollBackTransaction();

Implements

IDataController..::.RollBackTransaction()()()

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


SqlExecuteNonQuery Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.SqlExecuteNonQuery Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub SqlExecuteNonQuery ( _
    sqlQuery As String _
)
C#
public void SqlExecuteNonQuery(
    string sqlQuery
)
Visual C++
public:
virtual void SqlExecuteNonQuery(
    String^ sqlQuery
) sealed
JavaScript
function sqlExecuteNonQuery(sqlQuery);

Parameters

sqlQuery
Type: System..::.String

Implements

IDataController..::.SqlExecuteNonQuery(String)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


SqlExecuteReader Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.SqlExecuteReader Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function SqlExecuteReader ( _
    sqlQuery As String _
) As SqlDataReader
C#
public SqlDataReader SqlExecuteReader(
    string sqlQuery
)
Visual C++
public:
virtual SqlDataReader^ SqlExecuteReader(
    String^ sqlQuery
) sealed
JavaScript
function sqlExecuteReader(sqlQuery);

Parameters

sqlQuery
Type: System..::.String

Implements

IDataController..::.SqlExecuteReader(String)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


SqlExecuteScalar Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.SqlExecuteScalar Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function SqlExecuteScalar ( _
    sqlQuery As String _
) As Object
C#
public Object SqlExecuteScalar(
    string sqlQuery
)
Visual C++
public:
virtual Object^ SqlExecuteScalar(
    String^ sqlQuery
) sealed
JavaScript
function sqlExecuteScalar(sqlQuery);

Parameters

sqlQuery
Type: System..::.String

Implements

IDataController..::.SqlExecuteScalar(String)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


SqlExecuteStoredProcedure Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.SqlExecuteStoredProcedure Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Function SqlExecuteStoredProcedure ( _
    storedProcedureName As String, _
    parameters As List(Of SqlParameter) _
) As Integer
C#
public int SqlExecuteStoredProcedure(
    string storedProcedureName,
    List<SqlParameter> parameters
)
Visual C++
public:
virtual int SqlExecuteStoredProcedure(
    String^ storedProcedureName,
    List<SqlParameter^>^ parameters
) sealed
JavaScript
function sqlExecuteStoredProcedure(storedProcedureName, parameters);

Parameters

storedProcedureName
Type: System..::.String
parameters
Type: System.Collections.Generic..::.List <(Of <( SqlParameter >)>)

Implements

IDataController..::.SqlExecuteStoredProcedure(String, List<(Of <(SqlParameter>)>))

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


Update(T) Method

[image]

.NET Framework Class Library
DataController_NHibernate..::.Update<(Of <(T>)>) Method
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Sub Update(Of T) ( _
    updated As T _
)
C#
public void Update<T>(
    T updated
)
Visual C++
public:
generic<typename T>
virtual void Update(
    T updated
) sealed
JavaScript
JavaScript does not support generic types or methods.

Parameters

updated
Type: T

Type Parameters

T

Implements

IDataController..::.Update<(Of <(T>)>)(T)

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


DataController_NHibernate Properties

[image] [image]

.NET Framework Class Library
DataController_NHibernate Properties
DataController_NHibernate Class See Also Send Feedback

The DataController_NHibernate type exposes the following members.

Properties

Name | Description
FlushMode |

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


FlushMode Property

[image]

.NET Framework Class Library
DataController_NHibernate..::.FlushMode Property
DataController_NHibernate Class See Also Send Feedback

Namespace: NHibernateHelper
Assembly: NHibernate.Helper (in NHibernate.Helper.dll)

Syntax

Visual Basic (Declaration)
Public Property FlushMode As FlushModeEnum
C#
public FlushModeEnum FlushMode { get; set; }
Visual C++
public:
virtual property FlushModeEnum FlushMode {
    FlushModeEnum get () sealed;
    void set (FlushModeEnum value) sealed;
}
JavaScript
function get_flushMode();
function set_flushMode(value);

Implements

IDataController..::.FlushMode

See Also

DataController_NHibernate Class
NHibernateHelper Namespace


System Namespace

[image]

.NET Framework Class Library
System Namespace
Send Feedback

The System namespace contains fundamental classes and base classes that define commonly-used value and reference data types, events and event handlers, interfaces, attributes, and processing exceptions.

Classes

Class | Description
DateTimeExtensions |
NumericExtensions |
StringExtensions |
WebControlExtensions |
XmlDocumentExtensions |


DateTimeExtensions Class

[image]

.NET Framework Class Library
DateTimeExtensions Class
Members See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class DateTimeExtensions
C#
public static class DateTimeExtensions
Visual C++
public ref class DateTimeExtensions abstract sealed
JavaScript
System.DateTimeExtensions = function();

Type.createClass(
    'System.DateTimeExtensions');

Inheritance Hierarchy

System..::.Object
System..::.DateTimeExtensions

See Also

DateTimeExtensions Members
System Namespace


DateTimeExtensions Members

[image] [image]

.NET Framework Class Library
DateTimeExtensions Members
DateTimeExtensions Class Methods See Also Send Feedback

The DateTimeExtensions type exposes the following members.

Methods

Name | Description
ToDateBaseString |

See Also

DateTimeExtensions Class
System Namespace


DateTimeExtensions Methods

[image] [image]

.NET Framework Class Library
DateTimeExtensions Methods
DateTimeExtensions Class See Also Send Feedback

The DateTimeExtensions type exposes the following members.

Methods

Name | Description
ToDateBaseString |

See Also

DateTimeExtensions Class
System Namespace


ToDateBaseString Method

[image]

.NET Framework Class Library
DateTimeExtensions..::.ToDateBaseString Method
DateTimeExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDateBaseString ( _
    value As DateTime _
) As String
C#
public static string ToDateBaseString(
    DateTime value
)
Visual C++
public:
static String^ ToDateBaseString(
    DateTime value
)
JavaScript
System.DateTimeExtensions.toDateBaseString = function(value);

Parameters

value
Type: System..::.DateTime

See Also

DateTimeExtensions Class
System Namespace


NumericExtensions Class

[image]

.NET Framework Class Library
NumericExtensions Class
Members See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class NumericExtensions
C#
public static class NumericExtensions
Visual C++
public ref class NumericExtensions abstract sealed
JavaScript
System.NumericExtensions = function();

Type.createClass(
    'System.NumericExtensions');

Inheritance Hierarchy

System..::.Object
System..::.NumericExtensions

See Also

NumericExtensions Members
System Namespace


NumericExtensions Members

[image] [image]

.NET Framework Class Library
NumericExtensions Members
NumericExtensions Class Methods See Also Send Feedback

Methods

Name | Description
ToCurrency | Overloaded.
ToDelimited | Overloaded.
ToInteger | Overloaded.
ToPercentage | Overloaded.

See Also

NumericExtensions Class
System Namespace


NumericExtensions Methods

[image] [image]

.NET Framework Class Library
NumericExtensions Methods
NumericExtensions Class See Also Send Feedback

Methods

Name | Description
ToCurrency | Overloaded.
ToDelimited | Overloaded.
ToInteger | Overloaded.
ToPercentage | Overloaded.

See Also

NumericExtensions Class
System Namespace


ToCurrency Method

[image] [image]

.NET Framework Class Library
NumericExtensions..::.ToCurrency Method
NumericExtensions Class See Also Send Feedback

Overload List

Name | Description
ToCurrency(Decimal) |
ToCurrency(Double) |
ToCurrency(Int32) |
ToCurrency(Single) |

See Also

NumericExtensions Class
NumericExtensions Members
System Namespace


ToCurrency Method (Decimal)

[image]

.NET Framework Class Library
NumericExtensions..::.ToCurrency Method (Decimal)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToCurrency ( _
    value As Decimal _
) As String
C#
public static string ToCurrency(
    decimal value
)
Visual C++
public:
static String^ ToCurrency(
    Decimal value
)
JavaScript
System.NumericExtensions.toCurrency = function(value);

Parameters

value
Type: System..::.Decimal

See Also

NumericExtensions Class
ToCurrency Overload
System Namespace


ToCurrency Method (Double)

[image]

.NET Framework Class Library
NumericExtensions..::.ToCurrency Method (Double)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToCurrency ( _
    value As Double _
) As String
C#
public static string ToCurrency(
    double value
)
Visual C++
public:
static String^ ToCurrency(
    double value
)
JavaScript
System.NumericExtensions.toCurrency = function(value);

Parameters

value
Type: System..::.Double

See Also

NumericExtensions Class
ToCurrency Overload
System Namespace


ToCurrency Method (Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToCurrency Method (Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToCurrency ( _
    value As Integer _
) As String
C#
public static string ToCurrency(
    int value
)
Visual C++
public:
static String^ ToCurrency(
    int value
)
JavaScript
System.NumericExtensions.toCurrency = function(value);

Parameters

value
Type: System..::.Int32

See Also

NumericExtensions Class
ToCurrency Overload
System Namespace


ToCurrency Method (Single)

[image]

.NET Framework Class Library
NumericExtensions..::.ToCurrency Method (Single)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToCurrency ( _
    value As Single _
) As String
C#
public static string ToCurrency(
    float value
)
Visual C++
public:
static String^ ToCurrency(
    float value
)
JavaScript
System.NumericExtensions.toCurrency = function(value);

Parameters

value
Type: System..::.Single

See Also

NumericExtensions Class
ToCurrency Overload
System Namespace


ToDelimited Method

[image] [image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method
NumericExtensions Class See Also Send Feedback

Overload List

Name | Description
ToDelimited(Decimal) |
ToDelimited(Double) |
ToDelimited(Int32) |
ToDelimited(Single) |
ToDelimited(Decimal, Int32) |
ToDelimited(Double, Int32) |
ToDelimited(Int32, Int32) |
ToDelimited(Single, Int32) |

See Also

NumericExtensions Class
NumericExtensions Members
System Namespace


ToDelimited Method (Decimal)

[image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method (Decimal)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDelimited ( _
    value As Decimal _
) As String
C#
public static string ToDelimited(
    decimal value
)
Visual C++
public:
static String^ ToDelimited(
    Decimal value
)
JavaScript
System.NumericExtensions.toDelimited = function(value);

Parameters

value
Type: System..::.Decimal

See Also

NumericExtensions Class
ToDelimited Overload
System Namespace


ToDelimited Method (Double)

[image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method (Double)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDelimited ( _
    value As Double _
) As String
C#
public static string ToDelimited(
    double value
)
Visual C++
public:
static String^ ToDelimited(
    double value
)
JavaScript
System.NumericExtensions.toDelimited = function(value);

Parameters

value
Type: System..::.Double

See Also

NumericExtensions Class
ToDelimited Overload
System Namespace


ToDelimited Method (Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method (Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDelimited ( _
    value As Integer _
) As String
C#
public static string ToDelimited(
    int value
)
Visual C++
public:
static String^ ToDelimited(
    int value
)
JavaScript
System.NumericExtensions.toDelimited = function(value);

Parameters

value
Type: System..::.Int32

See Also

NumericExtensions Class
ToDelimited Overload
System Namespace


ToDelimited Method (Single)

[image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method (Single)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDelimited ( _
    value As Single _
) As String
C#
public static string ToDelimited(
    float value
)
Visual C++
public:
static String^ ToDelimited(
    float value
)
JavaScript
System.NumericExtensions.toDelimited = function(value);

Parameters

value
Type: System..::.Single

See Also

NumericExtensions Class
ToDelimited Overload
System Namespace


ToDelimited Method (Decimal, Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method (Decimal, Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDelimited ( _
    value As Decimal, _
    precision As Integer _
) As String
C#
public static string ToDelimited(
    decimal value,
    int precision
)
Visual C++
public:
static String^ ToDelimited(
    Decimal value,
    int precision
)
JavaScript
System.NumericExtensions.toDelimited = function(value, precision);

Parameters

value
Type: System..::.Decimal
precision
Type: System..::.Int32

See Also

NumericExtensions Class
ToDelimited Overload
System Namespace


ToDelimited Method (Double, Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method (Double, Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDelimited ( _
    value As Double, _
    precision As Integer _
) As String
C#
public static string ToDelimited(
    double value,
    int precision
)
Visual C++
public:
static String^ ToDelimited(
    double value,
    int precision
)
JavaScript
System.NumericExtensions.toDelimited = function(value, precision);

Parameters

value
Type: System..::.Double
precision
Type: System..::.Int32

See Also

NumericExtensions Class
ToDelimited Overload
System Namespace


ToDelimited Method (Int32, Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method (Int32, Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDelimited ( _
    value As Integer, _
    precision As Integer _
) As String
C#
public static string ToDelimited(
    int value,
    int precision
)
Visual C++
public:
static String^ ToDelimited(
    int value,
    int precision
)
JavaScript
System.NumericExtensions.toDelimited = function(value, precision);

Parameters

value
Type: System..::.Int32
precision
Type: System..::.Int32

See Also

NumericExtensions Class
ToDelimited Overload
System Namespace


ToDelimited Method (Single, Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToDelimited Method (Single, Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToDelimited ( _
    value As Single, _
    precision As Integer _
) As String
C#
public static string ToDelimited(
    float value,
    int precision
)
Visual C++
public:
static String^ ToDelimited(
    float value,
    int precision
)
JavaScript
System.NumericExtensions.toDelimited = function(value, precision);

Parameters

value
Type: System..::.Single
precision
Type: System..::.Int32

See Also

NumericExtensions Class
ToDelimited Overload
System Namespace


ToInteger Method

[image] [image]

.NET Framework Class Library
NumericExtensions..::.ToInteger Method
NumericExtensions Class See Also Send Feedback

Overload List

Name | Description
ToInteger(Decimal) |
ToInteger(Double) |
ToInteger(Int32) |
ToInteger(Single) |

See Also

NumericExtensions Class
NumericExtensions Members
System Namespace


ToInteger Method (Decimal)

[image]

.NET Framework Class Library
NumericExtensions..::.ToInteger Method (Decimal)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToInteger ( _
    value As Decimal _
) As String
C#
public static string ToInteger(
    decimal value
)
Visual C++
public:
static String^ ToInteger(
    Decimal value
)
JavaScript
System.NumericExtensions.toInteger = function(value);

Parameters

value
Type: System..::.Decimal

See Also

NumericExtensions Class
ToInteger Overload
System Namespace


ToInteger Method (Double)

[image]

.NET Framework Class Library
NumericExtensions..::.ToInteger Method (Double)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToInteger ( _
    value As Double _
) As String
C#
public static string ToInteger(
    double value
)
Visual C++
public:
static String^ ToInteger(
    double value
)
JavaScript
System.NumericExtensions.toInteger = function(value);

Parameters

value
Type: System..::.Double

See Also

NumericExtensions Class
ToInteger Overload
System Namespace


ToInteger Method (Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToInteger Method (Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToInteger ( _
    value As Integer _
) As String
C#
public static string ToInteger(
    int value
)
Visual C++
public:
static String^ ToInteger(
    int value
)
JavaScript
System.NumericExtensions.toInteger = function(value);

Parameters

value
Type: System..::.Int32

See Also

NumericExtensions Class
ToInteger Overload
System Namespace


ToInteger Method (Single)

[image]

.NET Framework Class Library
NumericExtensions..::.ToInteger Method (Single)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToInteger ( _
    value As Single _
) As String
C#
public static string ToInteger(
    float value
)
Visual C++
public:
static String^ ToInteger(
    float value
)
JavaScript
System.NumericExtensions.toInteger = function(value);

Parameters

value
Type: System..::.Single

See Also

NumericExtensions Class
ToInteger Overload
System Namespace


ToPercentage Method

[image] [image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method
NumericExtensions Class See Also Send Feedback

Overload List

Name | Description
ToPercentage(Decimal) |
ToPercentage(Double) |
ToPercentage(Int32) |
ToPercentage(Single) |
ToPercentage(Decimal, Int32) |
ToPercentage(Double, Int32) |
ToPercentage(Int32, Int32) |
ToPercentage(Single, Int32) |

See Also

NumericExtensions Class
NumericExtensions Members
System Namespace


ToPercentage Method (Decimal)

[image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method (Decimal)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToPercentage ( _
    value As Decimal _
) As String
C#
public static string ToPercentage(
    decimal value
)
Visual C++
public:
static String^ ToPercentage(
    Decimal value
)
JavaScript
System.NumericExtensions.toPercentage = function(value);

Parameters

value
Type: System..::.Decimal

See Also

NumericExtensions Class
ToPercentage Overload
System Namespace


ToPercentage Method (Double)

[image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method (Double)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToPercentage ( _
    value As Double _
) As String
C#
public static string ToPercentage(
    double value
)
Visual C++
public:
static String^ ToPercentage(
    double value
)
JavaScript
System.NumericExtensions.toPercentage = function(value);

Parameters

value
Type: System..::.Double

See Also

NumericExtensions Class
ToPercentage Overload
System Namespace


ToPercentage Method (Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method (Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToPercentage ( _
    value As Integer _
) As String
C#
public static string ToPercentage(
    int value
)
Visual C++
public:
static String^ ToPercentage(
    int value
)
JavaScript
System.NumericExtensions.toPercentage = function(value);

Parameters

value
Type: System..::.Int32

See Also

NumericExtensions Class
ToPercentage Overload
System Namespace


ToPercentage Method (Single)

[image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method (Single)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToPercentage ( _
    value As Single _
) As String
C#
public static string ToPercentage(
    float value
)
Visual C++
public:
static String^ ToPercentage(
    float value
)
JavaScript
System.NumericExtensions.toPercentage = function(value);

Parameters

value
Type: System..::.Single

See Also

NumericExtensions Class
ToPercentage Overload
System Namespace


ToPercentage Method (Decimal, Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method (Decimal, Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToPercentage ( _
    value As Decimal, _
    precision As Integer _
) As String
C#
public static string ToPercentage(
    decimal value,
    int precision
)
Visual C++
public:
static String^ ToPercentage(
    Decimal value,
    int precision
)
JavaScript
System.NumericExtensions.toPercentage = function(value, precision);

Parameters

value
Type: System..::.Decimal
precision
Type: System..::.Int32

See Also

NumericExtensions Class
ToPercentage Overload
System Namespace


ToPercentage Method (Double, Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method (Double, Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToPercentage ( _
    value As Double, _
    precision As Integer _
) As String
C#
public static string ToPercentage(
    double value,
    int precision
)
Visual C++
public:
static String^ ToPercentage(
    double value,
    int precision
)
JavaScript
System.NumericExtensions.toPercentage = function(value, precision);

Parameters

value
Type: System..::.Double
precision
Type: System..::.Int32

See Also

NumericExtensions Class
ToPercentage Overload
System Namespace


ToPercentage Method (Int32, Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method (Int32, Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToPercentage ( _
    value As Integer, _
    precision As Integer _
) As String
C#
public static string ToPercentage(
    int value,
    int precision
)
Visual C++
public:
static String^ ToPercentage(
    int value,
    int precision
)
JavaScript
System.NumericExtensions.toPercentage = function(value, precision);

Parameters

value
Type: System..::.Int32
precision
Type: System..::.Int32

See Also

NumericExtensions Class
ToPercentage Overload
System Namespace


ToPercentage Method (Single, Int32)

[image]

.NET Framework Class Library
NumericExtensions..::.ToPercentage Method (Single, Int32)
NumericExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function ToPercentage ( _
    value As Single, _
    precision As Integer _
) As String
C#
public static string ToPercentage(
    float value,
    int precision
)
Visual C++
public:
static String^ ToPercentage(
    float value,
    int precision
)
JavaScript
System.NumericExtensions.toPercentage = function(value, precision);

Parameters

value
Type: System..::.Single
precision
Type: System..::.Int32

See Also

NumericExtensions Class
ToPercentage Overload
System Namespace


StringExtensions Class

[image]

.NET Framework Class Library
StringExtensions Class
Members See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class StringExtensions
C#
public static class StringExtensions
Visual C++
public ref class StringExtensions abstract sealed
JavaScript
System.StringExtensions = function();

Type.createClass(
    'System.StringExtensions');

Inheritance Hierarchy

System..::.Object
System..::.StringExtensions

See Also

StringExtensions Members
System Namespace


StringExtensions Members

[image] [image]

.NET Framework Class Library
StringExtensions Members
StringExtensions Class Methods See Also Send Feedback

The StringExtensions type exposes the following members.

Methods

Name | Description
Formats |
HtmlDecode |
HtmlEncode |
IsBlank | Returns true for a null, empty or trimmed empty string.
IsNull | Depreciated, use IsBlank until we think of a better name.
StripHtml |
UrlDecode |
UrlEncode |

See Also

StringExtensions Class
System Namespace


StringExtensions Methods

[image] [image]

.NET Framework Class Library
StringExtensions Methods
StringExtensions Class See Also Send Feedback

The StringExtensions type exposes the following members.

Methods

Name | Description
Formats |
HtmlDecode |
HtmlEncode |
IsBlank | Returns true for a null, empty or trimmed empty string.
IsNull | Depreciated, use IsBlank until we think of a better name.
StripHtml |
UrlDecode |
UrlEncode |

See Also

StringExtensions Class
System Namespace


Formats Method

[image]

.NET Framework Class Library
StringExtensions..::.Formats Method
StringExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function Formats ( _
    value As String, _
    ParamArray args As Object() _
) As String
C#
public static string Formats(
    string value,
    params Object[] args
)
Visual C++
public:
static String^ Formats(
    String^ value,
    ... array<Object^>^ args
)
JavaScript
System.StringExtensions.formats = function(value, ... args);

Parameters

value
Type: System..::.String
args
Type: array< System..::.Object >[]()[]

See Also

StringExtensions Class
System Namespace


HtmlDecode Method

[image]

.NET Framework Class Library
StringExtensions..::.HtmlDecode Method
StringExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function HtmlDecode ( _
    value As String _
) As String
C#
public static string HtmlDecode(
    string value
)
Visual C++
public:
static String^ HtmlDecode(
    String^ value
)
JavaScript
System.StringExtensions.htmlDecode = function(value);

Parameters

value
Type: System..::.String

See Also

StringExtensions Class
System Namespace


HtmlEncode Method

[image]

.NET Framework Class Library
StringExtensions..::.HtmlEncode Method
StringExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function HtmlEncode ( _
    value As String _
) As String
C#
public static string HtmlEncode(
    string value
)
Visual C++
public:
static String^ HtmlEncode(
    String^ value
)
JavaScript
System.StringExtensions.htmlEncode = function(value);

Parameters

value
Type: System..::.String

See Also

StringExtensions Class
System Namespace


IsBlank Method

[image]

.NET Framework Class Library
StringExtensions..::.IsBlank Method
StringExtensions Class See Also Send Feedback

Returns true for a null, empty or trimmed empty string.

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsBlank ( _
    value As String _
) As Boolean
C#
public static bool IsBlank(
    string value
)
Visual C++
public:
static bool IsBlank(
    String^ value
)
JavaScript
System.StringExtensions.isBlank = function(value);

Parameters

value
Type: System..::.String

Return Value

See Also

StringExtensions Class
System Namespace


IsNull Method

[image]

.NET Framework Class Library
StringExtensions..::.IsNull Method
StringExtensions Class See Also Send Feedback

Depreciated, use IsBlank until we think of a better name.

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function IsNull ( _
    value As String _
) As Boolean
C#
public static bool IsNull(
    string value
)
Visual C++
public:
static bool IsNull(
    String^ value
)
JavaScript
System.StringExtensions.isNull = function(value);

Parameters

value
Type: System..::.String

Return Value

See Also

StringExtensions Class
System Namespace


StripHtml Method

[image]

.NET Framework Class Library
StringExtensions..::.StripHtml Method
StringExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function StripHtml ( _
    value As String _
) As String
C#
public static string StripHtml(
    string value
)
Visual C++
public:
static String^ StripHtml(
    String^ value
)
JavaScript
System.StringExtensions.stripHtml = function(value);

Parameters

value
Type: System..::.String

See Also

StringExtensions Class
System Namespace


UrlDecode Method

[image]

.NET Framework Class Library
StringExtensions..::.UrlDecode Method
StringExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function UrlDecode ( _
    value As String _
) As String
C#
public static string UrlDecode(
    string value
)
Visual C++
public:
static String^ UrlDecode(
    String^ value
)
JavaScript
System.StringExtensions.urlDecode = function(value);

Parameters

value
Type: System..::.String

See Also

StringExtensions Class
System Namespace


UrlEncode Method

[image]

.NET Framework Class Library
StringExtensions..::.UrlEncode Method
StringExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function UrlEncode ( _
    value As String _
) As String
C#
public static string UrlEncode(
    string value
)
Visual C++
public:
static String^ UrlEncode(
    String^ value
)
JavaScript
System.StringExtensions.urlEncode = function(value);

Parameters

value
Type: System..::.String

See Also

StringExtensions Class
System Namespace


WebControlExtensions Class

[image]

.NET Framework Class Library
WebControlExtensions Class
Members See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class WebControlExtensions
C#
public static class WebControlExtensions
Visual C++
public ref class WebControlExtensions abstract sealed
JavaScript
System.WebControlExtensions = function();

Type.createClass(
    'System.WebControlExtensions');

Inheritance Hierarchy

System..::.Object
System..::.WebControlExtensions

See Also

WebControlExtensions Members
System Namespace


WebControlExtensions Members

[image] [image]

.NET Framework Class Library
WebControlExtensions Members
WebControlExtensions Class Methods See Also Send Feedback

The WebControlExtensions type exposes the following members.

Methods

Name | Description
SetDefaultButton |

See Also

WebControlExtensions Class
System Namespace


WebControlExtensions Methods

[image] [image]

.NET Framework Class Library
WebControlExtensions Methods
WebControlExtensions Class See Also Send Feedback

The WebControlExtensions type exposes the following members.

Methods

Name | Description
SetDefaultButton |

See Also

WebControlExtensions Class
System Namespace


SetDefaultButton Method

[image]

.NET Framework Class Library
WebControlExtensions..::.SetDefaultButton Method
WebControlExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetDefaultButton ( _
    textBox As TextBox, _
    linkButton As LinkButton _
)
C#
public static void SetDefaultButton(
    TextBox textBox,
    LinkButton linkButton
)
Visual C++
public:
static void SetDefaultButton(
    TextBox^ textBox,
    LinkButton^ linkButton
)
JavaScript
System.WebControlExtensions.setDefaultButton = function(textBox, linkButton);

Parameters

textBox
Type: System.Web.UI.WebControls..::.TextBox
linkButton
Type: System.Web.UI.WebControls..::.LinkButton

See Also

WebControlExtensions Class
System Namespace


XmlDocumentExtensions Class

[image]

.NET Framework Class Library
XmlDocumentExtensions Class
Members See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlDocumentExtensions
C#
public static class XmlDocumentExtensions
Visual C++
public ref class XmlDocumentExtensions abstract sealed
JavaScript
System.XmlDocumentExtensions = function();

Type.createClass(
    'System.XmlDocumentExtensions');

Inheritance Hierarchy

System..::.Object
System..::.XmlDocumentExtensions

See Also

XmlDocumentExtensions Members
System Namespace


XmlDocumentExtensions Members

[image] [image]

.NET Framework Class Library
XmlDocumentExtensions Members
XmlDocumentExtensions Class Methods See Also Send Feedback

The XmlDocumentExtensions type exposes the following members.

Methods

Name | Description
GetNodeInnerText |

See Also

XmlDocumentExtensions Class
System Namespace


XmlDocumentExtensions Methods

[image] [image]

.NET Framework Class Library
XmlDocumentExtensions Methods
XmlDocumentExtensions Class See Also Send Feedback

The XmlDocumentExtensions type exposes the following members.

Methods

Name | Description
GetNodeInnerText |

See Also

XmlDocumentExtensions Class
System Namespace


GetNodeInnerText Method

[image]

.NET Framework Class Library
XmlDocumentExtensions..::.GetNodeInnerText Method
XmlDocumentExtensions Class See Also Send Feedback

Namespace: System
Assembly: InSite.Library (in InSite.Library.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function GetNodeInnerText ( _
    value As XmlDocument, _
    xpath As String _
) As String
C#
public static string GetNodeInnerText(
    XmlDocument value,
    string xpath
)
Visual C++
public:
static String^ GetNodeInnerText(
    XmlDocument^ value,
    String^ xpath
)
JavaScript
System.XmlDocumentExtensions.getNodeInnerText = function(value, xpath);

Parameters

value
Type: System.Xml..::.XmlDocument
xpath
Type: System..::.String

See Also

XmlDocumentExtensions Class
System Namespace